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Logic Pro is a sophisticated, fully featured audio and MIDI application that provides all
the tools you need to create professional-quality music productions.

This preface covers the following:

• About Logic Pro (p. 17)

• About the Logic Pro Documentation (p. 18)

• Additional Resources (p. 19)

About Logic Pro
Logic Pro allows you to record and edit both audio and MIDI, add high-quality effects,
and mix your music in stereo or Surround. The final mix can be exported to one or more
standard audio files, or burned to an audio CD or DVD that can be played on any computer,
home stereo, or imported into other applications and devices.

Some of the things you can do with Logic Pro include:

• Record MIDI information via connected MIDI input devices, such as keyboards, and
play back this information via any connected MIDI device (such as a synthesizer keyboard
or module) or the integrated Logic Pro software instruments.

• Create, arrange, and edit MIDI projects, make use of the powerful Score Editor, then
print musical notation via a printer connected to your computer.

• Edit the timing of audio files—Flex time editing—by shortening or expanding the
distance between transients in the audio.

• Digitally record acoustic and electric instruments or vocal performances into your
projects, and process these audio recordings with a huge array of built-in real-time
effects.

• Make use of the integrated software instruments, including Sculpture, Ultrabeat, ES1,
ES2, EVP88, EVB3, EVD6, EXS24 mkII, over a dozen high-quality GarageBand instruments,
or third-party Audio Units instruments.

• Load projects or channel strips from GarageBand, and enhance them with the additional
processing and editing possibilities afforded by Logic Pro.
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• Mix your MIDI and audio tracks, including effects and software instrument settings, via
a sophisticated total recall mix automation system. Logic Pro includes high-quality
effects that you can use in your projects. You can also install and use third-party
Audio Units effects and instruments.

• Bounce (mix down) all audio data, including instruments, effects and mix automation
settings, to stereo or multiple Surround format files for mastering or further processing.

• Work in real time:  You can work on Logic Pro projects in real time, adding to, and
editing audio and MIDI parts while the project is playing, and hearing the results of
your changes immediately.

• Use existing loop libraries:  Logic Pro directly supports Apple Loops files, and is
compatible with a wide variety of existing audio file types, including those created in
ReCycle.

• Locate and preview files easily:  The Media area, part of the Logic Pro interface, provides
powerful file browsing and search features, making it easy to locate audio files and
other supported file types.

About the Logic Pro Documentation
Logic Studio comes with various documents that will help you get started as well as
provide detailed information about the included applications.

• Logic Pro User Manual: The onscreen user manual is a comprehensive document that
describes the Logic Pro interface, commands, and menus and gives step-by-step
instructions for creating Logic Pro projects and for accomplishing specific tasks. It is
written for users of all levels of experience. The user manual is available in Logic Pro
Help (in Logic Pro, choose Help > Logic Pro Help).

• Exploring Logic Pro: This booklet presents the basics of Logic Pro in an easy, approachable
way. Each chapter presents major features and guides you in trying things out. A PDF
version of the printed manual is available in Logic Pro Help (in Logic Pro, choose Help
> Exploring Logic Pro).

• Logic Pro Control Surfaces Support: This onscreen manual describes the configuration
and use of control surfaces with Logic Pro.

• Logic Pro TDM Guide: This onscreen manual describes the essential aspects of using
TDM in Logic Pro.

• Logic Studio Instruments: This onscreen manual provides comprehensive instructions
for using the powerful collection of instruments included with Logic Pro and MainStage.

• Logic Studio Effects: This onscreen manual provides comprehensive instructions for
using the powerful collection of effects included with Logic Pro, MainStage, and
WaveBurner.
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• Logic Studio Working with Apogee Hardware: This onscreen manual describes the use
of Apogee hardware with Logic Pro.

Additional Resources
Along with the documentation that comes with Logic Studio, there are a variety of other
resources you can use to find out more.

Release Notes and New Features Documents
Each application offers detailed documentation that covers new or changed features and
functions. This documentation can be accessed in the following location:

• Click the Release Notes and New Features links in the application Help menu.

Logic Pro Website
For general information and updates, as well as the latest news on Logic Pro, go to:

• http://www.apple.com/logicstudio/logicpro

Apple Service and Support Websites
For software updates and answers to the most frequently asked questions for all Apple
products, go to the general Apple Support webpage. You’ll also have access to product
specifications, reference documentation, and Apple and third-party product technical
articles.

• http://www.apple.com/support

For software updates, documentation, discussion forums, and answers to the most
frequently asked questions for Logic Pro, go to:

• http://www.apple.com/support/logicpro

For discussion forums for all Apple products from around the world, where you can search
for an answer, post your question, or answer other users’ questions, go to:

• http://discussions.apple.com

19Preface Welcome to Logic Pro

http://www.apple.com/logicstudio/logicpro
http://www.apple.com/support
http://www.apple.com/support/logicpro
http://discussions.apple.com




This chapter gives you a conceptual overview of Logic Pro and provides an example of
a common workflow when creating music in the application.

This chapter covers the following:

• Creating Music in Logic Pro (p. 21)

• Understanding the Basics of Projects and Regions (p. 23)

Creating Music in Logic Pro
Logic Pro can be used in a variety of ways, ranging from the simple to the incredibly
sophisticated. The following section outlines a common workflow example that many
projects adhere to.

Stage 1: Creating a Project
You begin working in Logic Pro by creating a new project, or opening an existing one.

A project file contains MIDI data recordings plus information about the audio and other
files used, including pointers to these files.

All files (audio, video, samples, and so on) can be saved in a project folder. All project files
are automatically placed into appropriate sub-folders within the project folder.

More details can be found in Understanding the Basics of Projects and Regions.

Stage 2: Creating and Importing Your Musical Material
Getting musical material into Logic Pro can basically be broken down into two methods:

• Making new audio or MIDI data recordings (the latter can be played back through either
external MIDI synthesizers or software instruments).

• Importing existing audio recordings (audio files, samples, loops) or MIDI (and other file
data) into your projects. You can import existing audio recordings by simply dragging
them from the Media area, shown at the right of the Arrange window.

Recordings are made through suitable MIDI or audio hardware that is connected to, or
installed in, your Mac.
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MIDI recordings are used to trigger (play back through) either external MIDI devices, such
as synthesizers, or internal software instruments. Software instruments are played back
through your audio interface or the Mac audio outputs. Not only can you record the notes
of your performance, but you can also record and play back information such as synthesizer
parameter changes—all in real time.

Audio recordings can be made by playing an instrument (such as a guitar) or singing into
a microphone, for example.

Stage 3: Arranging and Editing
Once your musical material has been imported or recorded into Logic Pro, you will
generally organize it into a “project structure.” This is done in the main Logic Pro window,
called the Arrange window.

Musical material appears as rectangular blocks, known as regions. These regions run from
left to right across the Arrange area, and are positioned on vertically stacked lanes, known
as tracks. You may freely copy, repeat, loop, move, shorten, lengthen, or delete
regions—either on a track or across tracks. This grid-like layout and the use of building
blocks (regions) make it easy to see, and create, the overall song structure.

There will be many occasions when you’ll need to perform more detailed edits to your
MIDI or audio data recordings than is possible at the region level. Logic Pro offers a number
of editing windows that allow you to modify your musical material at a variety of levels.
For example, this might be useful if:

• You have made a recording of a great main vocal performance, but can hear a thud in
the silent passages between two phrases, where the vocalist kicked the microphone
stand. It probably goes without saying that this isn’t a sound you’d like to have on the
finalized CD. No problem. Simply edit the recording by inserting silence during the
thud, or perhaps cut that portion out of the recording entirely.

• You have made a MIDI keyboard recording that is perfect except for one note that
should have been a C, but is a B. No problem. Simply drag the MIDI note event from B
to C.

More details can be found in Understanding the Basics of Projects and Regions.

Stage 4: Mixing, Automating, and Using Plug-ins
Following the creation of your arrangement and any edits that may have been required,
you would commonly move on to the mixing phase of your project. Mixing, as a term,
generally refers to balancing the relative levels of each song component. Put another
way, the main vocal needs to be louder than the bass, guitars, drums, and keyboards,
thus allowing the lyrics to be heard.
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Mixing also entails the use of audio effects, which change, enhance, or suppress particular
song components, adding up to a unified and polished final product. Logic Pro features
numerous effects that can be used to turn your basic song into a professionally finished
project.

Logic Pro allows you to record, or automate, changes you make to track, instrument, and
effect parameters, such as volume, pan, filters, and other controls. This can be done in
real time or offline with the mouse or an external MIDI device. These changes play back
when you play the project, and can be edited independently of the musical material. This
is very useful for a number of reasons:

• You can only adjust one level or setting of a playback track, if using the computer
mouse. The ability to record and play back multiple adjustments of all track elements
allows for a sophisticated mix.

• Performances are rarely consistent. For example, a vocalist will often sing louder or
softer during different sections of his or her performance, so you may need to even
out these level changes over the course of the song, or to balance the soft and loud
vocal sections against the musical backing.

• Song dynamics (the loud and soft sections of a song) benefit from animation. In other
words, building the intensity of a song section can often be achieved by gradual or
immediate level changes. Songs that are of a consistent level throughout tend to sound
flat and lifeless.

Stage 5: Exporting and Bouncing
The final step of the Logic Pro music creation process is exporting your final product.
Logic Pro allows you to produce a stereo file of your completed mix in a variety of audio
file formats. You can also produce several stem files, formatted for most common Surround
encoding schemes. You do this in the Bounce window; simply choose the desired
outcome(s) in the available menus and click the onscreen Bounce button. You can even
burn a stereo mix directly to a CD or DVD, or create an MP3, with one simple step.

Understanding the Basics of Projects and Regions
This section will provide you with an introduction to the basic elements and terminology
of a Logic Pro project. Detailed, step-by-step instructions on working with projects, regions,
and events are provided in later chapters.

Understanding the Basics of Projects
You start working in Logic Pro by creating a project, or opening an existing one. This is
similar to using a word-processing application that requires a document to be opened
before you can begin typing. Logic Pro, like word processors, also allows you to have
multiple documents (projects) open at the same time, and transfer media and other data
between them.
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A Logic Pro project file contains all MIDI events and parameter settings, information about
the audio and video files to be played, and all edits to MIDI and audio data.

It is important to note that the project file points to your audio and video files, which are
stored as separate entities on your hard disk. You have the choice of including these, and
other file types, in the project folder.

This approach has two main benefits:

• Saving a project without its assets (audio, video, sample files, and so on) minimizes the
memory requirements for project (and project backup) file storage.

• Saving a project with assets simplifies tasks such as archiving and transport to other
Logic Pro-based studios—either physically or as email attachments.

A project can consist of the complete collection of files used, including the project itself,
project backups, all audio, sampler instruments, and samples for the EXS24 or Ultrabeat,
Space Designer reverb impulse response files and video. These are collectively known as
the project assets.

When you create a new project, a project folder is created, named, and a hard disk location
is specified. New recordings are automatically placed into an Audio Files sub-folder within
the project folder.

If you include the project assets, further sub-folders are created automatically. These can
include Audio Files, Project Backups, Samples, Video, ReCycle, and Sampler Instruments
folders.

The sub-folder structure of all projects is identical, making it easy and consistent to
navigate both your projects and those of other Logic Pro users.

Understanding the Basics of Regions
The main window of Logic Pro is known as the Arrange window. This is the window that
you first see when you open the application and a project is loaded. This is also the
window that is used for recording, editing, and arranging your projects. Your audio and
MIDI files appear in the Arrange window as rectangular areas called regions. Audio files
are represented by audio regions, MIDI files by MIDI regions.
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Audio Regions and Audio Files
Audio regions refer to (point to) an underlying audio file. Audio regions are used as
playback markers (start and end points) that can be as long as the entire audio file, or
only a few seconds long, playing a small portion of the audio file that they point to.

Audio region 1

Audio file

Audio region 2

Audio
region 3

Any audio file used in Logic Pro is automatically linked to at least one audio region that
is, by default, the length of the entire audio file.

You can freely create as many audio regions as you require. For example, imagine a live
stereo drum track that runs for the duration of your project. During the second chorus,
the drummer played perfectly, but was a little sloppy during all other chorus sections.

Logic Pro allows you to create an audio region that points to the second chorus section
of the overall (drum track) audio file, and use this perfect take in multiple places in the
project.

You do this by creating one audio region (that points to chorus 2 in the drum track audio
file), and copying it to each position that the chorus occurs in the Arrange area.

A great benefit of working with audio regions, rather than audio files, is that they use
very little memory, whereas multiple copies of the same section of the audio file would
require a lot of hard disk storage space.

It is, of course, possible to directly edit, copy, and move audio files. You do this in the
Sample Editor and Media area.
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MIDI Regions and Events
MIDI regions, by comparison, actually contain MIDI data events. They are not related to
information stored in external files. MIDI regions can be saved as individual files, but they
can also be, and generally are, stored as part of the project.

MIDI region 

MIDI note events MIDI controller events 

The MIDI data events stored within MIDI regions include note, controller, program change,
and other information. These data events represent MIDI performances that you have
recorded into Logic Pro. MIDI performances are generally created with a MIDI keyboard,
but can also be generated with MIDI controllers, MIDI guitars, your computer keyboard,
or the mouse.

MIDI data events can be affected as a group by processing the MIDI region that contains
them. Such processing includes:  transposition, quantization (timing correction, which is
similar to the spell checker of a word processor, when dealing with the language of music),
timing delays, and more.

You can also edit individual events within a MIDI region. You do this by opening the
region in one of the MIDI editors. These windows allow you to precisely alter the position,
length, and pitch of MIDI note events. Other MIDI event types can also be altered in
various ways. You can freely enter MIDI data with your MIDI keyboard, the mouse, or
computer keyboard in these editors.

For more information about MIDI and MIDI event types, see Introduction to MIDI Editing.
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Logic Pro automatically finds and configures supported audio and MIDI hardware when
first installed and opened. There are many circumstances in which you may want to
enhance or extend this basic automatic configuration. This chapter will help you to
optimize your hardware for use with Logic Pro. It also includes background information
about components your music production system can incorporate.

This chapter covers the following:

• Designing Your Music Production System (p. 27)

• Connecting Your Audio and MIDI Devices (p. 34)

• Using External MIDI Devices (p. 42)

• Using External Audio Effects (p. 43)

• Configuring Your Audio Hardware (p. 43)

• Using Distributed Audio Processing (p. 45)

Designing Your Music Production System
Your music production system can incorporate far more than your computer and Logic Pro
software.

A complete Logic Pro studio could conceivably consist of any, or all, of the following
components:

• A Mac computer and related peripherals, such as a mouse or other pointing device,
keyboard, displays, and so on

• Additional Mac computers, which can be used to boost the processing power of your
Logic Pro system via network connections. These are referred to as Logic Pro Nodes.

• Audio and MIDI interfaces

• External MIDI sound generators, such as samplers and synthesizers

• External audio devices, such as mixers, audio converters, pre-amplifiers, channel strips,
effects units, and more
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• External MIDI control surfaces and keyboards. Even external MIDI-controlled lighting
can be driven by Logic Pro.

• Amplification and speakers for stereo or multi-channel surround mixes

• Additional software that runs alongside, and integrates with, Logic Pro. This includes
a range of ReWire applications and audio or MIDI software.

• Additional effect and instrument plug-ins, including those that are DSP-accelerated,
such as PowerCore

Computer
This section outlines several computing factors that you should consider for your Logic Pro
system. System requirements are covered in the Before You Install document, found in
the Documentation folder of the Logic Pro installation discs.

Note: System requirements may change between Logic Pro releases, so you should always
check the Apple website and the latest Before You Install document included with Logic Pro
updates.

How Fast Should Your Computer Be?
Audio processing is complex, so the general rule is:  the more powerful your computer,
the better. This involves not only the speed of the processors of your Mac, but also includes
larger main memory sizes, the speed of busses, and the general efficiency of
communication with connected devices.

A Portable or Fixed Studio?
You may be wavering between a desktop or portable Mac as the basis for your Logic Pro
system, or perhaps considering the viability of a portable computer for on-the-road
composition. The good news is that portable Mac computers are ideal for Logic Pro use.
They offer excellent audio and MIDI hardware expansion capabilities in the form of FireWire
and USB connectors, and are fast enough to allow extensive software instrument and
effect use. Due to the power-saving nature of portable computers, slower hard disk drives
are usually included, resulting in a lower track count than is possible with a desktop
equivalent.

Obviously, desktop computers offer additional expansion slots, extending the range of
MIDI and audio hardware possibilities available to notebook computers, and can
incorporate multiple processors. CPU and hard disk speeds are generally higher, thus
allowing higher track playback counts, and the simultaneous use of more software
instruments and effects.

Tip: If you have both a portable and desktop Mac, you can easily transfer projects and
other data between them, and take advantage of the Node functionality, which harnesses
the processing power of both computers for your projects.
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Hard Disk Drives and Storage Locations
Music production generates a huge number of large files. These include samples for audio
instruments, loop libraries, audio recordings, video files, and more.

Consider buying a separate, large capacity hard disk drive (or several) for your audio files
and sample libraries.

You should also look at a reliable, high-capacity backup system, and should automate
your backup routine, preferably as a daily occurrence.

Audio and MIDI Interfaces
An audio interface is required to get sound signals into, and out of, your computer. A
MIDI interface is required for MIDI input and output signals.

When using optional audio and MIDI interfaces, you should install their drivers before
starting Logic Pro. This will allow Logic Pro to find and use these devices at startup.

Audio interfaces should be supported by a Core Audio driver and MIDI interfaces should
be supported by a Core MIDI driver. Check with the manufacturer of your equipment for
details on Mac OS X support.

Audio Interface
When an analog audio signal arrives at the inputs of your audio interface, it must be
converted into digital information before the computer can deal with it. This process is
called analog-to-digital conversion and is handled by the analog-to-digital converter of
the audio interface.

There are countless optional audio interfaces available, and at least as many ways that
they can be set up and used with Logic Pro and external audio gear. Given the differing
requirements and working methods of people across the world, there is no one-size-fits-all
audio interface solution. In the simplest scenario, you would use the internal audio
interface of your computer to monitor and record audio.

When choosing an audio interface, make sure that it is certified to run on Mac hardware.
If the device requires a driver, check that it is compatible with the Mac OS X version
required by Logic Pro.

Logic Pro supports input from digital audio interfaces up to a maximum sample rate of
192 kHz, and a maximum bit depth of 24 bits.

Full details about setting up your audio interface hardware can be found in Configuring
Your Audio Hardware.
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MIDI Interface
Your Mac computer does not provide MIDI inputs or outputs. If you want to use MIDI
devices equipped with MIDI ports, a MIDI interface is required for communication with
your computer. MIDI interfaces are generally connected to your Mac USB ports. Some
MIDI interfaces require the installation of driver software, and others are automatically
recognized by your Mac.

Note: Many modern MIDI devices, particularly keyboards, include a USB or FireWire
connection port that enables MIDI (and audio, in some cases) communication with your
computer. Such devices do not require an additional MIDI (or audio) interface. Some
require the installation of driver software, and others are automatically recognized by
Mac OS X. Check the websites of MIDI device manufacturers for further information.

Types of MIDI Devices
A vast array of MIDI-equipped devices exist. These include MIDI keyboards and sound
modules, control surfaces, effect processors, mixers, lighting controllers, and more.

MIDI Keyboard
The most likely candidate for inclusion in your Logic Pro system is a MIDI keyboard. MIDI
keyboards are used to input note (and controller) information into Logic Pro. Some MIDI
keyboards are simply input devices (often called controller keyboards) and some also
include their own synthesis engines (synthesizer and sampling keyboards). Logic Pro can
be used to record keyboard performances as MIDI data, and can play them back through
any connected MIDI device or internal software instrument.

If you don’t have a MIDI keyboard handy, Logic Pro offers the Caps Lock Keyboard, which
allows you to use the computer keyboard for MIDI note entry. See Using the Caps Lock
Keyboard for MIDI Step Input.

Control Surfaces
Control surfaces are hardware devices that feature a variety of controls, which can include
faders, rotary knobs, switches, and displays. These controls can be mapped to functions
in Logic Pro, allowing you to change parameters with more precision and speed than
you can by using your mouse and computer keyboard. You can also control multiple
parameters at the same time. Detailed information on the setup and use of control surfaces
can be found in the Logic Pro Control Surfaces Support manual.

Recording Light Plug-in
Logic Pro facilitates the use of a control surface plug-in, called the Recording Light, to
control an external device via MIDI events. This allows you to control an external recording
light or sign, warning visitors not to enter the recording studio before or during recording.
Logic Pro sends a MIDI signal to turn on the external device when a track is record-enabled
or when recording starts. Logic Pro sends another MIDI signal to turn off the device when
tracks are made record-safe or when recording stops.

30 Chapter 2 Setting Up Your System



Note: This control surface plug-in requires additional hardware that is not included with
Logic Pro.

Synthesizers and MIDI-Controlled Effects
Logic Pro provides plenty of software instruments and effects, and can also act as a host
for Audio Units plug-ins from other manufacturers. More information on the use of plug-in
instruments and effects can be found in Working with Instruments and Effects.

You can also incorporate hardware MIDI instruments and MIDI-controlled effects units
to your Logic Pro music production system. These are connected via a MIDI interface,
using MIDI cables. (See Connecting Your Audio and MIDI Devices.)

MIDI-controlled effects units do not process MIDI data. Rather, they are audio processors
(such as reverb or multi-effect devices) that can be controlled via MIDI messages. This
allows you to automate the parameters of these devices—such as delay time or Flanger
speed—from Logic Pro.

Typically, you would connect all external devices, such as synthesizers and MIDI-controlled
effects units to either your audio interface or a hardware mixing console. MIDI-controlled
effects units would be connected in a send/return loop, using either:

• A pair of audio ins and outs (or auxiliary in/out, if available) on your audio interface

• An auxilliary in/out (sometimes called FX send/return) pair on your mixing console

Both methods allow the use of Logic Pro’s In/Out plug-in, allowing you to freely route
audio information through the external effects unit and the MIDI connection provides
control over the effects parameters. In many ways, this is much like using one of Logic Pro’s
internal effect plug-ins.

Note: It is only practical to use the In/Out plug-in for external device routing when you’re
using an audio interface equipped with multiple in and out ports.

Both MIDI instruments and effects allow remote patch (preset) selection from Logic Pro.
This (and control) information can be stored as part of Logic Pro project files, ensuring
perfect playback from your MIDI devices the next time the project is loaded.

Ancillary Audio Devices
No discussion of a Logic Pro audio system would be complete without covering a number
of options that you should seriously consider, in order to make the most of the application.

Audio Playback System
Your audio interface provides inputs and outputs between the real world and your
computer. When performing audio playback, the audio interface translates computer
data into something you can hear and understand—sound and music.
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To facilitate this, an amplifier and speakers are required. You can certainly use headphones,
connected to the headphone jack of your audio interface, or the home hi-fi to monitor
Logic Pro playback, but this is not recommended in the long term.

You should look at a dedicated set of reference monitors (speakers), and a matching
reference amplifier. Many monitoring systems today have powered speakers, negating
the need for a separate amplifier.

Note: Reference monitors are specially designed speakers that offer a flat frequency
response across a wide range (usually 20 Hz to 20 kHz). These are not your average home
hi-fi speakers, and are usually only available from professional music and studio equipment
dealers.

This type of system is recommended due to the precision it offers. Logic Pro is capable
of delivering CD- or higher-quality audio, and creating your mixes on a home hi-fi will
generally result in music that is not properly balanced.

Put another way, most home hi-fi speakers tend to enhance particular areas of the
frequency spectrum, resulting in mixes that have too much bass, mid, or treble frequency
when played back on other systems. Reference monitors and amplifiers are designed to
provide a flat frequency response, avoiding emphasis of particular areas of your mix. This
translates to a final product that will sound good (or at least, passable) on most monitoring
systems—car stereos, home hi-fi, portable players, and so on.

Headphones
A good set of studio headphones is handy for particular tasks, such as precise EQing and
sample editing. Given the design of most headphones, and the fact that they’re used so
close to the ears, most people find that headphone mixes tend to be too bright or too
bass-heavy.

As such, they are not recommended for general monitoring duties, but they are useful
tools nonetheless. If you are recording groups of people, you will probably need several
pairs of headphones, a headphone distribution amplifier, and a mixing console.

Tip: You should not use headphones for longer than ten or twenty minutes at a time, as
they can cause listening fatigue, resulting in you making poor choices for your mix.

Audio Mixing Consoles
The inclusion of an audio mixer—analog or digital—is based on your typical studio use.
It also depends on the number of inputs and outputs provided by your audio interface
and your working preferences.

For example, if you are most likely to record bands, several MIDI synthesizers, or drum
kits in your studio, you will need numerous microphone and line-level inputs to
simultaneously record the performances of the musicians and vocalists in the group.
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Microphone inputs differ from line-level inputs in that they provide power (known as
phantom power), which is used to amplify the incoming signal from condenser
microphones.

Multiple mixer outputs and a headphone distribution amplifier are also beneficial in group
recording situations, as different signals can be sent to each performer; for example, a
click track to the drummer, a light drum mix and click track to the bass player, a composite
mix to the vocalist and guitarist, with a touch of reverb for the singer, and so on. This
different strokes approach is commonly used as it facilitates the best performances from
each group member.

Mixers can also include several auxilliary or bus channels that can be used to simplify a
number of jobs; for example, sending different signals (or mixes, if you like) to multiple
locations such as a front-of-house P.A. and a multitrack recorder, adding individual effects
to multiple channels, rerouting processed audio back to a different position in the signal
path, and much more.

Many of these mixing tasks can be performed with a multi input/output audio
interface—using Logic Pro (and the interface control software, if applicable) to adjust
levels and routings. The catch-22 with this is twofold:  it is not as immediate as physically
moving a slider or knob on a mixing console, and your computer generally needs to be
turned on, to allow control. To balance the equation, you can add a control surface to
your Logic Pro system, enabling hands-on operation. On the latter point, a number of
current audio interfaces can be used in standalone mode, but the problem of level control
remains unless the computer is turned on.

Microphones
If you are recording acoustic performances—spoken, sung, or played—into Logic Pro,
you need one or more microphones. The array of microphones available these days is
mind-boggling, but to simplify things, they basically fall into two categories:  condenser
and dynamic.

• In general terms, condenser microphones are more sensitive, and are commonly used
for vocal recording. They are also used for ambience recording, and for instruments
such as guitars and woodwinds.

• Dynamic microphones are often used for recordings with high sound pressure levels
(loud signals, in other words), such as drums and percussion.

Ultimately, either microphone type can be used for any recording job, but each will offer
a distinct advantage—sonically—in different recording situations. To further clarify, both
condenser and dynamic microphones come in a variety of forms, with many specifically
designed for the recording of certain instruments. As such, there’s no one-size-fits-all
microphone for every recording you will make, so purchasing or hiring several microphones
for different projects is advisable.
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Note: Condenser microphones require power to function. This can be provided by a
separate pre-amplifier or a phantom powered mixing console.

Connecting Your Audio and MIDI Devices
You need to connect your external audio and MIDI devices to your computer to allow
communication between Logic Pro and the devices. The following sections introduce
you to Mac expansion capabilities, audio and MIDI cabling, and other things you should
consider when connecting audio and MIDI interfaces to your system.

Computer Expansions
Depending on your Mac system, some or all of the following expansion capabilities are
available, which can be used for audio and MIDI interfaces:

• FireWire (IEEE 1394)

• USB

• PCI Express

• ExpressCard/34

Note: Data transfer rates discussed in the following sections are theoretical maximums.
In real-world use, this will be reduced due to system overheads. In general, protocols with
faster theoretical maximums will deliver data more quickly than slower protocols.

FireWire (IEEE 1394)
FireWire is a professional and consumer standard that can be used for both audio and
MIDI devices, as well as hard disks and other peripherals. It combines fast data transfer
rates, high storage capacities, and plug-and-play connection. All current Mac computers
offer FireWire connectors, and a number of FireWire audio and MIDI interfaces are available.

FireWire 400
FireWire 400, also called IEEE 1394a or i.LINK, is the consumer and professional standard
for formats such as DV, DVCAM, DVCPRO, DVCPRO 50, DVCPRO HD, and HDV. FireWire is
an inexpensive and easy way to capture and output high-quality digital video using a
variety of camcorders and decks and is capable of data rates as high as 400 Mbps. Standard
FireWire cables can be up to 4.5 meters long.
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There are two kinds of FireWire connectors:  a 4-pin connector (typically found on video
equipment such as camcorders or decks) and a 6-pin connector (used for computer
equipment). However, some newer video equipment uses the 6-pin connector, and some
video interfaces use the 4-pin connector. See your equipment’s documentation for more
information.

FireWire 400 (6-pin)
(Sometimes labeled iLINK)

FireWire 400 (4-pin)

FireWire 800
FireWire 800, also called IEEE 1394b, is the next generation of FireWire after IEEE 1394a,
a higher-bandwidth version capable of data transfer speeds of up to 800 Mbps.
FireWire 800 is also capable of supporting cable distances of up to 100 meters.

In addition to the standard 9-pin-to-9-pin FireWire 800 cables, 9-pin-to-4-pin and
9-pin-to-6-pin FireWire 400 to FireWire 800 cables are also available to connect older
devices to a FireWire 800 interface.

FireWire 800 (9-pin)

Note: FireWire 800 is commonly used to connect hard disks and other data peripherals
to your computer, but this connector is rarely used to connect video devices.

USB (Universal Serial Bus)
USB is a consumer standard used for computer peripherals and other devices. USB 1.1
offers a much lower data transfer rate than FireWire (11 Mbps). USB 2.0, however, transfers
data at 480 Mbps. It supports plug-and-play operation and the ability to connect several
devices in sequence (daisy-chaining). Some USB devices draw their power over the USB
cable, while others require a separate power connection. USB 2.0 ports are included on
all current Mac computers.

There are two kinds of USB connectors:

• A connector, typically used to connect a device to a USB hub

• B connector, typically used to connect devices together, and also to connect a device
to a computer
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Note: USB audio interfaces should always be directly connected to your computer, not
via a hub or to the computer’s display, keyboard, or another peripheral.

USB (Universal Serial Bus)

PCI Express
PCIe (Peripheral Component Interconnect Express) interfaces, unlike FireWire and USB
interfaces, require that you install a dedicated card in your computer. PCIe provides
extremely high bandwidth and fast data transfer rates, allowing you to record and play
back large numbers of files at the highest possible sample rates and bit depths.

ExpressCard/34
The ExpressCard/34 slot supports both PCIe and USB 2.0 connectivity. ExpressCards
available include audio interfaces, hard disk controller (eSATA) cards, networking, wireless
adapters, and more.

Audio Cabling
The following types of audio cables and connectors are usually used on professional and
consumer audio equipment:

• XLR

• 1/4-inch (6.35 mm) audio

• 1/8-inch (3.5 mm) miniplug

• RCA (Cinch)

• S/PDIF

• AES/EBU

• TOSLINK Optical and ADAT Lightpipe

XLR
XLR cables and connectors are used on professional-quality microphones, monitors, and
other musical equipment. They provide a high-quality, balanced signal at +4 dB level.

XLR connector (balanced)  
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1/4-inch (6.35 mm) Audio
1/4-inch (6.35 mm) connectors (sometimes called phono or phone plugs) are used on a
wide variety of professional and consumer musical equipment, including musical
instruments and amplifiers, speakers, and external effects devices. They can be either
balanced or unbalanced. Some devices require Tip-Ring-Sleeve (TRS) connectors. These
three-contact connectors are used for balanced mono signals and unbalanced stereo
signals.

1/4-inch Tip-Ring Sleeve (TRS) connector

1/4-inch Tip-Sleeve (TS) connector

1/8-inch (3.5 mm) Miniplug
Miniplug connectors are used for audio input and output to computers, and on some
consumer electronic devices, particularly portable ones.

Stereo miniplug connector (unbalanced)

RCA (Cinch)
RCA connectors are used on consumer audio equipment such as home stereo systems
and videocassette recorders.

RCA connector (unbalanced)

S/PDIF
Sony/Philips Digital Interface Format is a consumer-level variation of the AES/EBU digital
audio protocol. S/PDIF audio data can be transmitted several ways, including:

• Via coaxial cables with an RCA connector

• Via optical TOSLINK

Connectors for S/PDIF signals are found on most consumer digital equipment, such as
DAT (digital audio tape) recorders, CD players, DVD players, MiniDisc equipment, and
some audio interfaces.

S/PDIF optical digital connector
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AES/EBU
The AES/EBU (Audio Engineering Society/European Broadcasting Union) standard for
transferring digital audio typically uses XLR connectors in professional studio environments.
The data protocol is essentially identical to S/PDIF.

XLR connector  

TOSLINK Optical and ADAT Lightpipe
TOSLINK is a connector for optical digital signals. TOSLINK is used for several digital signal
formats, although most devices support only one of these formats:

• S/PDIF (stereo digital)

• AC-3 and DTS (5.1-channel surround)

• ADAT Lightpipe (an 8-channel digital signal)

TOSLINK connector

ADAT Lightpipe is an eight-channel digital audio format developed by Alesis. This signal
format uses TOSLINK optical connectors. Eight channels are supported at sample rates
of 44.1 and 48 kHz using 24 bits per sample.

Connecting Your Audio Interface
Logic Pro supports plug-and-play for audio interfaces, making it possible to connect and
turn on a new audio interface while Logic Pro is open. An alert appears when you connect
a new device, and prompts you to select and confirm the audio interface and driver that
you want to use.

All digital audio interfaces can be susceptible to latency—a noticeable delay between
the time the audio signal is produced, and when you hear it. You should always attach
your audio interface directly to the computer, rather than through a hub, or daisy-chaining
it through another device. Doing so can cause an unacceptable amount of latency,
particularly with slower USB 1.1 devices.

MIDI Cabling
MIDI is an abbreviation for Musical Instrument Digital Interface—a universal 5-pin
connection standard and computer language—that allows communication between
MIDI devices.

MIDI Connector
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Connecting Your MIDI Keyboard and Modules
If using a simple MIDI master keyboard without internal tone generation facilities, you
only need to connect the MIDI Out port of the keyboard to a MIDI In port on your MIDI
interface, using a MIDI cable.

Computer
MIDI interface

Out port 

Keyboard

In port 

If the keyboard can generate its own sounds, you should also connect the MIDI Out port
of the MIDI interface to the keyboard MIDI In port. If your MIDI interface offers more than
one MIDI output, connect any other tone generators (or other MIDI devices, such as
control surfaces that require bidirectional MIDI communication) to these.

Computer
MIDI interface Tone generator

Out port 

Out port 

Keyboard

In port 

In port 

In port 
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If the MIDI interface connected to your computer only offers one MIDI output, you need
to connect the MIDI In of the second tone generator to the keyboard MIDI Thru port. A
third device can be connected to the MIDI Thru of the second unit, and so on.

Computer
MIDI interface

Out port 

Out port 

Keyboard

In port 

In port 

In port 

In port 

MIDI Thru port 

Tone generator 2

Tone generator 3

The MIDI Thru port replicates the signals coming into the MIDI In port of the device. It is
preferable to use a direct connection from the computer MIDI Out to a device, rather
than chaining too many units, one after the other. Doing so can cause timing problems
in the chain, if numerous MIDI commands are sent quickly. This is due to the slight delays
introduced by each MIDI In to MIDI Thru transaction. As such, a multi input/output MIDI
interface is recommended in studios with several MIDI tone generators and controllers.

Using Multi-Channel MIDI Devices
Most modern MIDI tone generators can simultaneously receive MIDI data on multiple
MIDI channels (multi-timbral MIDI devices). Each MIDI channel can be assigned a tone or
sound, such as piano, strings, bass, and so on.

To take full advantage of the capabilities of each connected multi-timbral device, you
need to use separate MIDI Out ports (from the computer MIDI interface to the MIDI In
ports) for each device. To explain further, imagine a scenario where:

• There are four MIDI tone generators that are capable of receiving data on multiple
channels.

• All devices can receive on all 16 MIDI channels.

• There is only one MIDI Out from the computer, and all devices are daisy-chained via
MIDI Thru to MIDI In connections.

Logic Pro is capable of channelizing MIDI data (routing it to MIDI channels 1 to 16) and
is also capable of sending this channelized data to specific MIDI Out ports. Unfortunately,
in the scenario above, there is only one MIDI Out port available.
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As such, all data sent on MIDI channel 1 will be sent to all four of the daisy-chained MIDI
tone generators. Each MIDI tone generator will play the incoming data with the sound
assigned to channel 1, which may be:

• Bagpipes on module 1

• A drumkit on module 2

• A helicopter effect on module 3 and so on

While this would be colorful, it would hardly be musical, unless your tastes lean towards
the avant-garde. The same applies to the other 15 MIDI channels.

MIDI, as you can see from the example, can be separated onto 16 different channels, but
it can’t be separated between devices, unless a multi-output MIDI interface is used.

Using the scenario above, but substituting a single output MIDI interface with a four-output
MIDI interface—connected from MIDI Out ports A, B, C, and D—to the respective MIDI
In ports of each device. There are no MIDI Thru connections, which allows Logic Pro to
assign and send:

• A recording/performance on MIDI channel 1 to port A/module 1

• A separate recording/performance—also on MIDI channel 1—to port B/module 2

• A further recording/performance on MIDI channel 1 to port C/module 3, and so on
with subsequent channels and modules

In effect, having a multi-output MIDI interface is something like having more MIDI channels.
In this scenario, it would be like having 64 independent MIDI channels—with 16 channels
per port (A, B, C, and D).

Not only does this allow you to play up to 64 different sounds simultaneously through
your tone generators, it also allows full MIDI control for each channel of each device. This
becomes increasingly important when arranging and orchestrating such a large number
of instrument parts.

If your computer offers several MIDI inputs, you can connect the MIDI outputs of other
MIDI expanders and controllers to it.

Using USB MIDI Keyboards
If using a MIDI keyboard fitted with a USB connector, you don’t require a separate MIDI
interface, as it is already built into the keyboard. Just be sure to install the driver, if needed,
and connect the keyboard to your computer with a USB cable. Some modern USB
keyboards and controllers are automatically recognized by Mac OS X.

Separating a MIDI Keyboard from Its Sound Generator
If your MIDI keyboard has an internal sound source, it is important that you stop the
keyboard from generating sounds directly from its own keyboard.
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For example, if you buy a new keyboard that is to be used without a sequencer, and
connect it to an amplifier, you would expect the device to make a sound when you press
its keys—in other words, the keyboard is directly connected to the sound generator.

When using the MIDI keyboard with Logic Pro, however, this is not desirable. In this
situation, the keyboard is used as a computer input device, and Logic Pro passes the
incoming performance information back to the keyboard’s sound generator (or to an
internal software instrument or another connected sound module, if you like).

If the direct connection between the keyboard and its tone generator isn’t cut, a doubling
of each note results—one played directly from the keyboard to the internal tone generator,
and another sent through Logic Pro back to the tone generator.

Not only does this cause a phased sound, but it also halves the polyphony of the
keyboard’s tone generator. In situations where you want to control or record another
sound module or software instrument with your keyboard, you would hear both the
keyboard sound (due to the direct keyboard to tone generator connection) and the sound
of the software or MIDI instrument. This is why the keyboard must be separated from its
own internal sound generator.

This function is known as Local Off, and is set directly on your keyboard. Don’t worry
about losing the ability to use the tone generator of your keyboard. Logic Pro will still be
able to communicate with your keyboard tone generator just like any other connected,
keyboardless sound module or software instrument.

Note: If you cannot find the Local Off function in the MIDI menu of your keyboard, consult
its manual on sequencer use. Some keyboards allow you to select from:  Local, MIDI, or
Both for each of their Parts (individual MIDI channels/sounds in multi-timbral MIDI devices).
The MIDI setting, if applicable to your keyboard, is the equivalent of Local Off.

Using External MIDI Devices
Logic Pro recognizes all MIDI devices set up in the Audio MIDI Setup (AMS) utility, the
integrated audio and MIDI configuration tool of Mac OS X. You can find the AMS utility
in the Applications/Utilities folder. For more information on use, see the AMS Help.

The Library tab displays all MIDI devices found by the AMS utility (separated into MIDI
channels, if multi-channel devices) when an External MIDI track is selected. You can simply
select the MIDI device/sub-channel to assign it to the track.

You can configure external MIDI devices in the Inspector. For more information, see
Standard Instrument Objects, Multi-Instrument Objects, and Mapped Instrument Objects.
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Using External Audio Effects
If you want to send audio to an external (MIDI-controlled) audio effect device, you need
to insert the I/O (In/Out) plug-in into one of the Insert slots of the audio channel strip
you want to process. For further information, see Working with External Audio Effects.

Note: It is only practical to use the In/Out plug-in for external device routing when you
have an audio interface equipped with multiple in and out ports.

Configuring Your Audio Hardware
To use particular audio interfaces with Logic Pro, the driver for the device needs to be
installed, activated, and configured correctly. Drivers are software programs that enable
various pieces of hardware and software to be used with Mac OS X. This allows the device
to be recognized by applications, such as Logic Pro, and enables data routing between
software and hardware, in a format understood by both.

You select, activate, and configure a particular audio driver in Logic Pro in the Audio
Devices preferences.

To open the Audio Devices preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command), then click the Devices tab.
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µ Click the Preferences button in the Arrange toolbar, choose Audio from the pop-up menu,
then click the Devices tab.

The Devices pane contains three further tabs:  Core Audio, DAE, and Direct TDM.

In Mac OS X, all audio devices (with the exception of DAE and Direct TDM devices)are
accessed via Core Audio, an integral part of the operating system. Core Audio is a
high-performance, low-latency audio system that allows audio interface hardware to be
used by several applications at the same time.

Logic Pro is compatible with all audio hardware that offers a Core Audio driver.

Logic Pro also supports DAE (Digidesign Audio Engine) and Direct TDM. These drivers are
used for the operation of Digidesign HD system hardware, and allow Logic Pro to access
the on-board DSP chips of these devices.
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All information about the DAE and Direct TDM panes can be found in the Logic Pro TDM
Guide.

Setting Up Core Audio Devices
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the
default settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio
MIDI Setup). It can, however, be advantageous to optimize the settings for your individual
hardware setup, particularly if you use several audio interfaces or a multiple input/output
device. If possible, you should avoid using different audio devices for input and output.

For details about setting up your Core Audio device preferences (in the Logic Pro >
Preferences > Audio > Core Audio pane), see Core Audio Device Preferences.

DAE and TDM
All information on using the DAE (Digidesign Audio Engine) and TDM hardware with
Logic Pro can be found in the Logic Pro TDM Guide.

Using Distributed Audio Processing
Distributed audio processing allows you to expand the processing capacity of your
Logic Pro system. It does this by offloading calculations for software instruments or effects
to additional Mac Node computers, connected via Gigabit Ethernet. This is perfect when
using numerous instances of processor-intensive software synthesizers or effects, such
as Sculpture or Space Designer.

Additional Mac computers do not require further copies of Logic Pro, nor any MIDI or
audio hardware.

You can find the Logic Pro Node Installer on the Logic Pro Installation DVD. Install it, and
set the system volume of your Node machine as the destination. The Logic Pro Node
application has no parameters or GUI elements. It simply needs to be open on the Node
machine before you start Logic Pro.

Tip: If you plan to use a Mac solely as a Node machine, you may want to place the
Logic Pro Node application in the Startup Items folder. You may also consider using
Apple Remote Desktop to control additional Mac computers from your primary system.
In this scenario, your Node machines don’t need their own monitors or keyboards.

Considerations for Distributed Audio Processing
Distributed audio processing actually uses the built-in networking capabilities of Mac OS X.
You will need to set up an Ethernet network connection between all computers, via the
Network pane of the System Preferences. See Mac Help for details on setting up a network.
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Networking Considerations
The primary (host) computer will be a Macintosh computer with an Intel core processor,
equipped with a Gigabit Ethernet port. Ideally, node machines need one or more Intel
processors (a Gigabit Ethernet port is standard on all Intel Mac computers).

If you want to run multiple nodes, a Gigabit Ethernet switch is required.

It is recommended that you only use the network for distributed audio processing when
Nodes are active—other activities will affect performance.

Note: You must disable the software firewall. If you want to access the Internet via your
network, use of a router with a hardware firewall (or separate computer with a firewall),
is recommended.

Plug-in Considerations
Some Audio Units effects may not support the Node functionality of Logic Pro. You can
disable the Node processing for incompatible Audio Units effects in the AU Manager
application.

A number of Node-compatible third-party Audio Units effect plug-ins may open a dialog
on the Node machine. You will not see this dialog on the host machine (unless Remote
Desktop is in use). The Open dialog will lead to timing errors, and the connection to the
Node will be disrupted.

Important: You can only process a plug-in on Node machines when all Nodes have an
identical version of this plug-in installed.

Enabling Distributed Audio Processing
The following assumes that you have correctly installed the Logic Pro Node application
(and have an identical plug-in set) on all Node machines, and that it is open.

To set up, and activate, nodes in Logic Pro
1 Open the Nodes preferences by doing one of the following:

• Choose Preferences > Audio (or use the Open Audio Preferences key command), then
click the Nodes tab.
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• Click the Preferences button in the Arrange toolbar, choose Audio from the pop-up
menu, then click the Nodes tab.

2 Select the Enable Logic Nodes checkbox, and select computers in the list below:

• Selected (active) Nodes are used by the host (Logic Pro system).

• Dimmed (inactive) Nodes are due to one of the following:

• The machine is not connected to the network.

• The machine does not have the Logic Pro Node application running.

• The machine is in use by other hosts. They can remain checked for future use (when
Logic Pro is next opened).

• Unselected Nodes are not used by the host—they are, however, available to other
hosts.

• The list retains a history of previously connected Nodes. You can remove Nodes by
clicking the Remove button. This is useful if you’ve renamed a Node machine, or if
you’re sure that a Node machine will never be used again.

3 In the Arrange area, configure the track header to display the Track Node buttons:

a Open the Track Configuration window by choosing View > Configure Track Header (or
use the corresponding key command). You can also Control-click (or right-click) any
track header in the track list.

b Select the Track Node button’s checkbox.
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The Track Node buttons have four possible status indicators:

Disabled

Enabled and inactive

Enabled and active

Sync pending

• Disabled: The track is calculated on the local host (in Logic Pro, as per usual).

• Enabled and inactive: This track can potentially be calculated on the Node.

• Enabled and active (glowing): The track is actually being calculated on the Node.

• Sync pending: Data synchronization between the host and Node has not yet been
established (if the Node is not running, for example).

4 Click a Track Node button in the track list to offload that track’s processing duties to a
Node.

Tip: You can use track button slide activation to enable distributed audio processing on
multiple tracks. See Using Track Button Slide Activation.

5 Click an active Track Node button to disable distributed audio processing for the track.

Important Information on Using Nodes
Logic Pro automatically determines if enabled tracks are actually calculated on a Node
(and which Node, if multiple Node machines are available), or on the host computer. This
depends on system resources and network traffic.

The distribution of tasks to Nodes is based on an estimate of the processing resources a
certain stream will cost the host system. While the processing load of audio effects is
relatively constant, the performance of software instruments may vary greatly, depending
on the chosen setting, and on the number of simultaneously played voices.

Compensation of latencies caused by the network and processing occurs on playback
tracks—audio or software instrument, resulting in perfect timing—but this is obviously
not possible for live performance tracks.

48 Chapter 2 Setting Up Your System



What Can’t Be Processed on a Node
The Node buttons are available for all audio and software instrument tracks. There are,
however, some exceptions:

• EXS instruments: These are always calculated on the host. The reason for this is the
potentially demanding transfer of samples via the network, resulting in a slowdown of
audio processing over the network. The sample library needs to be present on the host
computer itself.

• Multi-output instruments such as Ultrabeat: Further to this, Ultrabeat also has a similar
problem to the EXS24 with sample-based kits.

• Audio Units software instruments: When an Audio Units software instrument track is
selected, the Node button is automatically turned off.

The Logic Pro Node application can process Audio Units effects.

It is possible, however, that some Audio Units effects may not support the Node
functionality of Logic Pro. You can disable the Node processing for incompatible
Audio Units effects in the Audio Units Manager.

It is not possible to calculate input, output, bus, or aux channels on a Node.
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The Logic Pro interface features several areas, each specialized for particular tasks. This
chapter introduces you to the Arrange window, which can incorporate all areas and
editors. You’ll learn how it interacts with other Logic Pro windows and editors. You are
encouraged to open Logic Pro to view these windows and editors, and to familiarize
yourself with them. Click and explore the various parts of the Logic Pro interface as they
are discussed. This will give you a feel for where things are, a brief overview of what they
do, and how they work with each other.

Note: Detailed information about the various editors and their functions can be found
in cross-referenced chapters.

This chapter covers the following:

• Opening Logic Pro (p. 52)

• Introducing the Arrange Window (p. 52)

• Working in the Arrange Area (p. 54)

• Using the Toolbar (p. 55)

• Using the Transport Bar (p. 55)

• Using the Inspector (p. 56)

• Working in the Media Area (p. 58)

• Working in the Notes Area (p. 66)

• Working in the Lists Area (p. 68)

• Working in the Editing Area (p. 72)

• Understanding Common Elements of Logic Pro Windows (p. 76)

• Understanding How Arrange Window Areas Interact (p. 80)

• Using Logic Pro Interface Elements (p. 83)

• Using the Computer Keyboard (p. 85)
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Opening Logic Pro
There are several ways to open Logic Pro.

To open Logic Pro
Do one of the following:

µ Double-click the Logic Pro icon in the Finder > Applications folder.

µ Click the Logic Pro icon in your Dock.

µ Double-click a Logic Pro project file.

When you open Logic Pro for the first time, the Templates dialog is displayed, allowing
you to select a template for the project type you want to create. (For more information
on the Templates dialog, see Creating Projects.) The setup of the Logic Pro interface
depends on the chosen template.

Introducing the Arrange Window
The Arrange window can incorporate all working areas and editors. It features the following
areas, each of which can be displayed or hidden within the Arrange window:

• Toolbar, at the top of the window

• Transport bar, at the bottom of the window

• Editing area, horizontally tiled, below the Arrange area

• Media, Notes, or Lists area, vertically tiled, right of the Arrange (and editing) area

• Inspector, vertically tiled, left of the Arrange (and editing) area

If an area is not visible, clicking the appropriate toolbar or Arrange area button opens it,
and resizes any existing areas to accommodate the new area.

Tip: Many areas can also be opened as separate windows, independent of the Arrange
window. This is done using the Window menu (or with the corresponding key commands)
or by dragging the appropriate area out of the Arrange window.
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The following is an overview of the main elements in the Arrange window:

Click this button to 
display the Toolbar.

Arrange area

Click this button to 
display the Lists area.

Click this button to 
display the Inspector.

Arrange window

Toolbar

Click this button to 
display the Notes area.

Click these buttons to 
display one of the 
editors.

Transport bar Media area

Inspector

• Arrange area: This is where you record audio and instrument parts as regions, and
arrange these audio and MIDI regions into a project structure.

• Toolbar: This is where you have quick access to buttons for frequently used commands.

• Transport bar: This is where you find the controls to navigate through your project. The
current playback, recording, or editing position is indicated by the playhead—the thin,
vertical line that appears in all Logic Pro windows that offer real-time display of
playback—namely the Arrange window and editors.

• Inspector: There is where you set track and region parameters when working in the
Arrange area, or the parameters of the editing window with key focus. For example:

• Clicking the Score Editor button (above the Transport bar) shows all scoring symbols
in the Inspector.
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• Clicking the Hyper Editor button (above the Transport bar) displays the parameters
of the currently selected hyper definition (selected row within the Hyper Editor).

• Notes area: This is where you’ll find tabs to view or edit project and track notes, when
the Notes button in the toolbar is clicked.

• Lists area: This is where you’ll find various tabs to view MIDI events (Event List), tempo
events (Tempo List), and more, when the Lists button in the toolbar is clicked.

• Media area: This is where you’ll find various tabs to locate and preview audio files
(Browser tab), select effects, instruments, and their settings (Library tab), and more,
when the Media button in the toolbar is clicked.

• Editing area: This is where you can open or close the Mixer, Sample Editor, Piano Roll
Editor, Score Editor, or Hyper Editor directly in the Arrange window. Simply click any
of the buttons along the lower edge of the Arrange area. These windows allow you to
precisely modify, delete, or add different types of data.

Working in the Arrange Area
The Arrange area is shown directly below the Arrange toolbar. It is used to record, import,
collate, and organize MIDI and audio data containers, known as regions, in a project. The
following are some of the main elements you’ll find in the Arrange area:

Bar ruler

Track list

Composition area

• Bar ruler: A linear bar divided into bar and beat segments. The Bar ruler can also display
time in hours, minutes, seconds, and finer divisions. It offers a number of functions that
can be used to mark project sections for different playback and recording tasks. For
detail, see Navigating Your Project.

• Composition area: This is where all MIDI and audio regions are displayed on horizontal
lanes, called tracks, aligned to time positions in a grid-like layout.
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• Track list: This is where you set the destination channel strip for playback of the MIDI
or audio regions on each horizontal track lane. The headers of each track list lane can
display the track name, icon, and several track buttons.

Using the Toolbar
The toolbar appears at the top of the Arrange window and contains buttons for frequently
used commands. It can be displayed or hidden by clicking the button in the top-right
corner of the Arrange window.

The toolbar can be customized to include buttons that show the Inspector, Media, and
Lists areas, create new tracks, add audio files, and other common functions. For more
information, see Customizing the Arrange Toolbar.

Using the Transport Bar
The Transport bar spans the entire lower edge of the Arrange window. You can use it to
move through your project and start recording. It contains buttons that will be immediately
familiar if you’ve used a tape recorder or CD/DVD player, such as Play, Rewind, Pause,
and so on. The Transport bar also incorporates a number of features that simplify tasks
you will perform in Logic Pro, such as recording over a repeatedly cycled section, or
listening to a part in isolation.

The Transport bar consists of three parts:

Display areaTransport buttons Mode buttons

• Transport buttons: Used to navigate your project.

• Display area: Provides information that helps with project navigation.

• Mode buttons: Enable advanced recording and playback functions.

You can alter the Transport bar by adding or removing buttons and displays, providing
faster access to the functions you need most often. You can also open an independent
SMPTE or Bar display window. For more information, see Hiding or Showing the Transport
Bar.
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Using the Inspector
The Inspector can be displayed or hidden by clicking the Inspector button in the Arrange
toolbar. The horizontal size of the Inspector cannot be altered. The content displayed in
the Inspector depends on the area in key focus:  either the Arrange area or one of the
editing areas below it. In situations where the area in key focus does not provide a
parameter area, the Inspector for the Arrange area is displayed.

Note: The Inspector updates to display the parameters of the window with key focus.
Details of window-specific parameters are found in the chapters for each window.
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The following image shows the Inspector when the Arrange area is in key focus.

Region Parameter box

Track Parameter box

Arrange channel strips

• Region Parameter box: Used to set playback parameters, such as transposition and
quantization, for individual or multiple regions on track lanes. None of the parameters
in the Region Parameter box actually alters the original data in the region. They only
affect the way the region (and events within the region) are played back. These
parameter alterations occur in real time, as the region is played.

• Track Parameter box: Used to alter various aspects of track channel strips. All regions
on the track lane are affected by any changes made here (as all regions are routed
through this channel strip).
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• Arrange channel strips: The left channel strip controls the output of the selected arrange
track. The righ channel strip can vary, depending on actions performed in the left
channel strip. For example, the right channel strip can display the first aux or output
destination channel strip for the left channel strip. This feature makes it quick and easy
to set up flexible effects and audio routing schemes. It also provides an at-a-glance
view of processing and routing for the selected arrange track, and you can access all
of the Mixer channel strip functions (volume, pan, sends, inserts, and so on) directly
from the Arrange area. Any adjustments you make to a track’s arrange channel strip
are reflected in the corresponding Mixer channel strip, and vice versa.

To show or hide the contents of the Region or Track Parameter boxes
µ Click the disclosure triangle to the left of the name in either box.

The contents of that box are displayed or hidden. Closing either box provides room for
the elements below.

To open the Region Parameter box as a floating area
Do one of the following:

µ Control-click (or right-click) the Region Parameter box, then choose Region Inspector
Float (or use the corresponding key command, default assignment:  Option-R).

µ Double-click the Region Parameter box.

Working in the Media Area
The Media area can be opened or closed by clicking the Media button in the Arrange
toolbar. The Media area is where you manage all files associated with your project,
including audio, video, and plug-in settings. It has four tabs:

• Audio Bin: Helps you to manage all audio files used in the project.

• Loop Browser: Used to search for loop files (Apple Loops, for example).

• Library: Used to search for (and can directly assign) plug-in, channel strip, and MIDI
instrument settings.

• File Browser: Used to search for all Logic Pro related files.

Introducing the Audio Bin
The Audio Bin shows all audio files used in the project. You can picture the Bin as an
audio file catalog for the project. It also provides an overview of regions that are derived
from each audio file.
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You can add, edit, delete, and rename audio files and regions in the Bin. All audio files
and regions can be dragged directly from the Bin into the Arrange area, where you can
edit, move, and copy them. You can also add files that aren’t yet used in the arrangement
to the Bin, allowing easy access during project construction.

Name column

Loop button

Play button

Info column

• Name column: Displays all audio files in the current project by name. The disclosure
triangle to the left of the filename reveals all regions associated with the selected audio
file.

• Info column: Displays audio file and region information. Horizontal bars indicate the
overall audio file length. Colored sections of these bars indicate the location and size
of regions within the audio file. Additional data, including the sample rate; bit depth;
mono, stereo, or surround status; and file size are also shown in the Info column. Mono
files are identified by a single circle symbol, stereo files by a double, interlocked circle
symbol, and surround files by five circle symbols.

• Play button: Click to hear the selected audio file or region. Click a second time to stop
playback.

• Loop button: Click to hear the selected audio file or region repeatedly. Click a second
time to stop playback.
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When you open the Audio Bin as an independent window and resize it, the Bin’s Info
column can display waveform overviews of audio files and regions.
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Introducing the Loop Browser
The Loop Browser is designed to make finding Apple Loops intuitive and efficient. You
can search for loops by using keywords, perform text searches, preview loops, view
information about loops, and limit the display to loops from a specific Jam Pack or loop
library. Matching files are displayed in the Search Results list. When you find files you
want to use, you can add them to your project by dragging them into the Arrange area.

Search field

Category buttons
Click to narrow the 
search for appropriate 
loops.

Search Results list
Displays all loops that 
match the search criteria.

View buttons (Music 
view is the default view.)View menu

Volume slider

The Loops pane has three views:  Music view, Sound Effects view, and Column Effects
view. The default Music view displays 54 buttons, each featuring a musically related
category. Click buttons in the matrix to narrow your search for appropriate Apple Loops.
Activated buttons are highlighted.
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Sound Effects view offers effect-related category buttons such as Explosions, Foley, or
People.

Column view offers a standard Mac OS X column file menu that is hierarchically separated
into All, By Genres, By Instruments, By Moods, and Favorites search criteria.

Category columns

• View buttons: Click to switch between the three views. The left button switches to
Column view, the second button (featuring the note icon) switches to Music view, and
the third button (featuring the FX icon) switches to Sound Effects view.

• View pop-up menu: Restricts displayed loops to a specific loop library.

• Search field: Type text in the field to display files with names that contain the search
text string.

• Category buttons (Music view and Sound Effects view only): Click to display files matching
the category in the Search Results list.

• Category columns (Column view only): Select a category column to display its
subcategories.

• Search Results list: Displays all loops that match the set search criteria.

• Volume slider: Adjusts the playback volume of the selected file.
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Introducing the Library
The Library is a powerful tool that you can use to access the following file types.

• Channel strip settings (.cst)

• Plug-in settings (.pst)

• EXS instruments (.exs)

• Environment instruments, and programs or banks of MIDI instruments created in the
Audio MIDI Setup utility

• ReWire MIDI instruments, and active ReWire hosts

The Library automatically displays setting files that match the selected channel strip type
and section (Channel Strip Settings menu, Insert slot, Instrument slot). A white frame
indicates the selected section of the Arrange channel strips.

You can browse for files by opening folders, or search by performing text searches.
Matching files are displayed in the Search Results list. When you find a file you want to
use, you can load it by selecting it.
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Introducing the File Browser
The File Browser allows you to navigate to, or search for, all file types that can be used
in Logic Pro, giving you easy access to (and use of ) this data during production. It displays
the following file types on any connected media volume:

• Logic project files

• Song files of older Logic versions

• GarageBand projects

• All project interchange file formats Logic Pro is compatible with (OMF, AAF, OpenTL,
XML, MIDI files)

• Audio files

• QuickTime movies

View buttons

Back and Forward 
buttons

Action pop-up menu

Search field

Search filters

File list

Path menu
Computer, Home, and 
Project buttons

Play button

Volume slider

• Back and Forward buttons: Move through previously viewed levels of the folder hierarchy.
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• Path menu: Displays the levels of the file path to the current location, allowing you to
move back to a previous level.

• Computer button: Displays the contents of the local hard disk, optical drive, and other
storage media connected to your computer, if applicable.

• Home button: Displays the contents of your home directory.

• Project button: Displays the contents of the current project folder.

• View buttons: Switches the file list between Column and List view.

• Search field: Type text in the field to display files with a name that contains the search
text. In addition to searching for files by name, you can search by other criteria (further
information stored with your files). Click the plus button to display additional search
filters. Logic Pro always searches at the displayed location.

• Search filters: Use the menus to narrow down your search to specific file types, file
formats, date, size, and other criteria.

• File list: Displays Logic-related files and folders at the current location. In Column view,
you can browse folder contents by selecting the folders.

• Action pop-up menu: Choose menu items to add a selected audio file to the Audio Bin,
or show the file location in the Finder.

• Volume slider: Adjust the playback volume of the selected file.

• Play button: Click to hear the selected file. Click a second time to stop playback.
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Working in the Notes Area
The Notes area can be opened or closed by clicking the Notes button in the Arrange
toolbar. It provides two independent tabs that show the following information:

• Project Notes: Displays notes that are associated with the project.

• Track Notes: Displays notes that are associated with individual tracks.
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Introducing Project Notes
The Project pane displays project-specific notes, of which there can only be one set per
project. You can use this pane to create, edit, or delete project notes.

• Project Text area: Enter project-specific text here.

• Project Text Edit button: Activates project text editing mode.

• Project name field: Displays the project name.

Introducing Track Notes
The Track pane displays track-specific notes, of which there can only be one set per
channel strip object. You can use this pane to create, edit, or delete track notes.

• Track Text area: Enter track-specific text here.

• Track Text Edit button: Activates track text editing mode.

• Track number and name: Display the number and name of the current track selection.
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Working in the Lists Area
The Lists area can be opened or closed by clicking the Lists button in the Arrange toolbar.
It provides four independent tabs that show a listing of the following types of data:

• Event List: Displays regions or MIDI events in the project.

• Marker List: Lists all markers in the project.

• Tempo List: Displays all tempo changes in the project.

• Signature List: Shows all time signature and key change events in the project.

The List tabs are well-suited for a number of precise editing tasks, and when a complete
view of all data is required.

Introducing the Event List
The Event List presents a list of all events in your project, such as MIDI note events or
region start events. Use it whenever you need to make precise alterations to recorded
data, and when the graphic display of the other editors is not as well-suited to the task.
You can restrict the types of events that are shown, making it easier to find specific event
types.
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The Event List can display two types of data:  region-related or event-related. The
information that is displayed depends on the current hierarchy level—in other words,
whether you are viewing information at the Arrange level, or looking inside one or more
MIDI regions in the Arrange area. Further information about the display hierarchy can be
found in Working at Different Hierarchy Levels.

Event type buttons 

Region display Event display

Hierarchy button

Create and Filter buttons List area

• Hierarchy button: Click to move up one level in the Event List hierarchy. This allows you
to see all regions in the current project.

• Create and Filter buttons: Determine the function of the event type buttons. When you
activate the Create button, clicking the event type button adds the selected event type.
When you activate the Filter button, you can use the event type buttons to filter specific
event types from the display. This merely hides the events from the display; it does not
affect playback.

• Event type buttons: Click to filter specific event types from the display, or add them
(depending on the status of the Create and Filter buttons).

• List area: Shows the actual list of events or regions, separated into columns. For details,
see Editing MIDI Events in the Event List.
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Introducing the Marker List
The Marker List displays all markers in the project. You can use it to create new markers,
edit existing ones, and to select markers for text editing. It also serves as a navigation
aid—you can click a marker name to jump to (move the playhead to) that marker position.

Marker Text Edit button

Create button

Marker List area

Marker Text area

Marker Text Area button

• Create button: Creates a new marker.

• Marker List area: Displays all markers in your project.

• Marker Text Area button: Click to display the optional Marker Text area, allowing you
to enter or edit marker text.

• Marker Text area: Enter text for the selected marker here.

• Marker Text Edit button: Activates marker text editing mode.
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Introducing the Tempo List
The Tempo List displays all tempo changes in the project. You can also use it to create
new tempo events, or to edit existing ones.

Create button

Tempo list

• Create button: Click to create a new tempo event.

• Tempo list: Displays all tempo changes, and their position in a project.

• Additional Info button: Displays all additional tempo changes located on a tempo curve,
and their position in a project.

Introducing the Signature List
The Signature List shows all time and key signature events in the project. Score symbols,
if present in the score of the project, are also shown. These include repeat signs and
double bar lines (including end of score events), half/short bar lines, hidden bar lines,
and manually inserted bar lines.
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You can use the Signature List to create, copy, move, and delete time and key signature
events.

The initial time and key 
signature of the project is 
always displayed at the 
top of the list, without 
bar position indicators. 

Working in the Editing Area
You can open the following editing areas directly in the Arrange window by clicking the
corresponding button at the bottom of the window.

• Mixer

• Sample Editor

• Piano Roll Editor

• Score Editor

• Hyper Editor
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Introducing the Mixer
The Mixer is where you mix your project. Each track is played back through a channel
strip. You can adjust the level and pan position of a channel strip, add effects, mute and
solo tracks, and send the output of a channel strip to other channel strip types, such as
output and auxiliary channel strips.

Channel strips and 
channel strip controls Filter buttonsView buttons

• Channel strips: Use to process audio or MIDI information that is routed from arrange
tracks.

• Channel strip controls: Use to adjust the level and other aspects of the audio signal
played through the channel strip.

• View buttons: Use to switch the Mixer between Single, Arrange, and All views, limiting
the Mixer view to channel strips required for the task at hand.

• Filter buttons: Use to filter the display of specific channel strip types.

Full details can be found in the Mixing chapter.
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Introducing the Sample Editor
The Sample Editor displays the contents of audio files as waveform graphics. You can use
the Sample Editor to precisely edit audio files (and regions). The Sample Editor also features
a number of useful destructive processing tools. These allow you to time stretch and
pitch shift audio, change sample rates, extract MIDI grooves from the audio, and even
quantize audio.

Info display

Region area

Waveform overviewRuler

 Waveform displayAnchor Playhead

• Ruler: Indicates the position and length of the region selected in the Arrange area, or
in the Audio Bin.

• Info display: Displays the start point and length of the selected area.

• Waveform overview: Displays a miniature view of the entire audio waveform.

• Waveform display: Provides a detailed view of the waveform area selected in the
waveform overview.

• Playhead: Reflects the current playback position.

• Anchor: Indicates the absolute start point of the audio file.

• Region area: Edit this beam to adjust the region length.

Full details can be found in Editing Audio in the Sample Editor.
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Introducing the Piano Roll Editor
The Piano Roll Editor displays MIDI notes as beams on a grid. The piano keyboard to the
left is aligned with the note pitches represented by each beam. Note length is indicated
by the relative length of each beam. Note position is displayed from left to right—a ruler
and vertical grid lines make it easy to see where notes begin and end. Note velocity (how
hard a note is struck, and usually how loud) is indicated by color.

Full details can be found in Editing MIDI Events in the Piano Roll Editor.

Introducing the Score Editor
The Score Editor uses traditional music notation to display the MIDI note events (plus
pedal and other event types) of MIDI regions. You can insert and edit MIDI note events
in staffs, and use musical symbols to clarify their meaning in this editor. Text, such as
lyrics, titles, and comments, can also be integrated into the score. The Print function
allows you to print complete scores, with staff numbers only limited by the paper size.
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Details on using the Score Editor can be found in Working with Notation.

Introducing the Hyper Editor
The Hyper Editor displays MIDI note or controller events as vertical beams, placed along
a user-defined time grid. This makes the Hyper Editor the ideal place to:

• Add or edit controller data, such as note velocities. It makes some editing tasks—such
as data scaling—much faster.

• Quickly create and edit MIDI drum parts.

Event Definition 
Parameter box

MIDI events

 Event definitions

• Event definition: Each horizontal row (or lane) provides an event definition, which
determines the type of event displayed or affected. When you select a row in the name
column, its event definition is shown in the Inspector’s Event Definition Parameter box.

• MIDI events: Each MIDI event is represented by a vertical beam, aligned with a particular
time position. The value of the controller, or velocity of the note, is indicated by the
height of the beam. Taller beams indicate higher values.

Full details can be found in Editing MIDI in the Hyper Editor.

Understanding Common Elements of Logic Pro Windows
All Logic Pro windows, including the Arrange area, feature a number of common elements.
This consistent approach between windows makes your life easier, as you’ll find these
elements in the same place throughout the application.
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Local Menu Bars
A window’s local menu bar contains buttons that access functions specific to the window.
For example, the Score Editor provides an enharmonic shift function, which is relevant
to notation, but not to Piano Roll editing.

Local menu bar

Tool Menus
The tools available in the Tool menus of each window are specific to tasks performed in
the window. For example, the Arrange area provides tools for different arrangement tasks,
such as cutting or moving regions, and automation editing. The Score Editor provides
tools used for score layout, and tasks such as voice separation.

The Left-click Tool menu assigns the Left-click tool. The Command-click Tool menu assigns
the Command-click tool. A further Tool menu (Right-click Tool menu) appears if the right
mouse button is assigned to a tool. For full details, see Working with Tools.
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Catch, Link, and Hierarchy Buttons
Most windows contains Catch, Link, and Hierarchy buttons. These are used to tie or
associate Logic Pro windows, and can aid in navigating through different levels of your
project structure. For example, if you click a region in the Arrange area, the contents of
a linked window (the Piano Roll Editor, for example) update immediately to show the
events within the region.

Hierarchy button

Catch buttonLink button

Scroll Bars
Vertical and horizontal scroll bars are shown at the right and bottom edges of the window.
These allow you to view sections that fall outside the visible display area.

Zoom Sliders
Vertical and horizontal sliders are shown at the bottom-right corner of the window. These
allow you to horizontally or vertically resize the contents of the window, giving you a
closer or more distant view of data.

Bar Ruler
All linear editing windows feature a Bar ruler at the top. The position of regions and events
within a project are aligned with Bar ruler positions. The Bar ruler displays markers and
locators, and reflects time signature changes. It also indicates three important operational
modes—solo, recording, or synchronized.
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Global Tracks
All linear editing windows feature global tracks, which are displayed just below the Bar
ruler, when opened. Click the disclosure triangle to the left of the Bar ruler (labeled Global
tracks) to view the global tracks.

• Marker track: Contains markers, which are used to label bar positions and parts of the
project. Their length, text, and color can be edited freely. For further information, see
Working with Markers.

• Tempo track: Contains all tempo changes in the project. For further information, see
Using the Tempo Track.

• Beat Mapping track: Allows you to assign a bar position to any musical event (both
MIDI notes and distinct accents in audio regions). This makes it possible to adjust the
musical timeline to the original timing of a MIDI or audio region that has been recorded
rubato (free time, including speeding up and slowing down), or just without a
metronome click. The audible outcome remains unchanged, but the resulting display
will fit the musical timeline. For further information, see Beat Mapping Regions.

• Signature track: Contains the basic key of the project, along with all time and key
signatures, as they are displayed in the Score Editor. For further information, see Working
with Time and Key Signatures.
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• Chord track: Contains chord symbols that can be derived from MIDI regions or created
with the mouse. These chord symbols may also be inserted into the score. The root
note of the chords determines the transposition (pitch shifting) of all Apple Loops, and
can also affect the playback of MIDI regions. For further information, see Editing
Transposition with the Chord and Transposition Tracks.

• Transposition track: Shows global transposition events. It is linked to the progression
of the chord root notes in the Chord track. Changing a chord root is reflected in the
Transposition track, and vice versa. For further information, see Editing Transposition
with the Chord and Transposition Tracks.

• Video track: Displays frames of a QuickTime movie as thumbnails that are perfectly
synchronized with the music, making it ideal for film scoring. Cuts in the movie can be
detected automatically and marked. For further information, see Using the Video Track.

Understanding How Arrange Window Areas Interact
The Arrange window contains various areas that interact with each other. This gives you
access to all files, editing methods, and track and channel strip parameters in one place,
making your workflow much faster. The following task outlines how these Arrange window
areas work in harmony, to accelerate music production.

To understand how Arrange window areas interact
1 Open the Media area by clicking the Media button in the Arrange toolbar.

2 Click the File Browser tab, then browse to a folder that contains audio files.

3 Select the audio filename and drag it to an audio track lane in the Arrange area.

Release the mouse button when the help tag displays position 1 1 1 1. A region is created
in the Arrange area.

4 Click the Sample Editor button at the bottom of the Arrange area.
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The Sample Editor is shown, displaying the contents of the region you just created in the
Arrange area.

5 Click the Audio Bin tab.

The Bin contains the audio file you just added to the project.

6 Click the Loops tab, then click a category button to see matching loops in the Loop
Browser’s Search Results list.

7 Select a loop with a green icon and drag it to a software instrument track in the Arrange
area.

Release the mouse button when the help tag displays position 1 1 1 1. A MIDI region is
created in the Arrange area.
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Tip: If no software instrument track exists, you can also drag the Apple Loop from the
Loop Browser directly into the blank Arrange area. A track and corresponding channel
strip are automatically created, and the Apple Loop is loaded.

8 Click the Piano Roll button at the bottom of the Arrange area.

The Piano Roll Editor is shown, displaying the contents of the region you just created in
the Arrange area.

9 Move the playhead to the beginning of your project by clicking the Go to Beginning
button in the Transport bar.

10 Play your project by clicking the Play button in the Transport bar.

You will hear the audio file and instrument loop you added to the project. You may like
the melody of the software instrument loop, but not its sound. Utilize the Library to assign
another sound to the software instrument track.

82 Chapter 3 Overview of the Logic Pro Interface



11 Select the software instrument track, then click the Inspector button.

The left channel strip displays the software instrument and effect of the selected track.

12 Click the Library tab, and browse through the displayed channel strip settings.

Because this is a software instrument track/channel strip, only software instrument channel
strip settings are shown in the Library.

13 Select one of the channel strip settings to load it.

14 Start playback again to audition the new sound.

Using Logic Pro Interface Elements
You can access all of the buttons, switches, sliders, and menus in the Logic Pro interface
using the mouse and computer keyboard.
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Checkboxes and Buttons
Checkboxes are square boxes that are selected when you click them, in order to activate
an option (or function). Click the checkbox a second time to turn it off, and deactivate
the option.

Some buttons behave in a similar fashion, in that the function they represent is temporarily
enabled (while the button is clicked, and usually illuminated).

A second click on the button disables the function. Examples of these types of buttons
include the Mute and Solo buttons.

A different type of checkbox is the round radio button. A number of grouped buttons
(each representing a different option) are available, and you need to select one of them.
They differ from checkboxes and other button types in that only one of them can be
activated at any given time. A good example are the Type radio buttons in the New Tracks
dialog.

Pull-Down and Pop-Up Menus
Pull-down menus open when you click the menu name. Pop-up menus open when you
click certain input fields or buttons.

In some menus, an arrow is shown beside one or more items, indicating a submenu. To
choose an item from a submenu, move the mouse in the direction of the arrow, and then
move vertically over the desired item. Click to activate the chosen command or setting.
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If you want to select an item that is outside the visible section of the menu, move the
mouse over the arrow at the top or bottom edge of the menu. The menu will scroll.

Shortcut Menus
Shortcut menus (also called contextual menus) are accessed by Control-clicking or
right-clicking in different areas of various Logic Pro windows. These offer a number of
selection, editing, and other area-specific commands, providing quick access to commonly
used functions.

Note: Right-click functionality is dependent on the Right Mouse Button:  Opens Shortcut
Menu option being chosen in the Logic Pro > Preferences > General > Editing pane.

Using the Computer Keyboard
You can access most Logic Pro functions with key commands. Whenever this
documentation mentions a key command, this refers to a function or option that can be
accessed with a computer keyboard keystroke (or keystroke combination, such as pressing
both the Control and W keys on your keyboard).

Use of key commands, rather than the mouse, can greatly accelerate your Logic Pro
workflow. Throughout this documentation, you will encounter a number of practical
usage examples, often in step form, that include the default key commands for particular
functions.

It is recommended that you follow the steps outlined in the documentation, and make
use of these default key commands while familiarizing yourself with Logic Pro. Not only
will this help you to remember them, but will also aid you in developing good (and faster)
working practices from the outset.
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Once you have a good understanding of Logic Pro fundamentals, and how you like to
work, you can freely assign your own set of key commands. Logic Pro functions and
options that can be assigned to key commands can also be assigned to MIDI commands,
sent from your MIDI controller. More detail on these advanced topics can be found in
Working with Key Commands.
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Logic Pro allows you to customize your window setup to fit both your working style and
the task at hand. While you will perform most of your work in the Arrange window, you
can open different combinations of windows (even several of the same type) and adjust
each individually. It is also easy to save different window arrangements called screensets,
(discussed in Using Screensets), and recall them by pressing a key. All open windows in
a project are constantly updated, following the position of the playhead. Alterations made
in one window are immediately reflected in all other open windows. For example, if the
pitch of a note event is changed in the Score Editor, this change is instantly shown in an
open Piano Roll Editor window. This chapter outlines how you can customize and save
your overall window setup. The display options of individual windows and editors are
covered in their respective chapters.

This chapter covers the following:

• Understanding the Window Types (p. 88)

• Opening and Closing Windows (p. 90)

• Moving and Resizing Windows (p. 93)

• Working at Different Hierarchy Levels (p. 97)

• Selecting the Working Area (p. 98)

• Zooming the Working Area (p. 100)

• Understanding Relationships Between Windows (p. 105)

• Hiding or Showing the Transport Bar (p. 108)

• Customizing the Arrange Toolbar (p. 108)

• Hiding or Revealing the Inspector (p. 109)

• Adjusting the Bar Ruler Display (p. 110)

• Displaying Global Tracks (p. 111)

• Using Screensets (p. 114)
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Understanding the Window Types
There are two different types of windows in Logic Pro:  normal windows and floating
windows.

Working in Normal Windows
You can open as many normal windows as you like, including several of the same type.
Even though the contents of all windows are constantly updated, only one window is
ever the top, or active, window. This is the window that is in the foreground when several
normal windows overlap. It is referred to as having key focus.

Key focus windows can be recognized by a title bar that is illuminated (with the title bar
text in black) and a white focus frame around the window content.
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Key focus areas within windows—such as the Arrange window—are indicated by a white
focus frame around the focused area.

To assign key focus to a window or area
Do one of the following:

µ Choose Window > Cycle Through Windows (or use the corresponding key command).

This command assigns key focus to the next open window, if it is fully obscured by other
windows.

µ Click the window title bar, or within the working area.

Be careful if using the latter option, as you may accidentally insert an event or region if
the Pencil tool is active in the window.

The Arrange window can incorporate several other windows in different areas. These can
be given key focus by clicking the background or title bar of the window (the area of the
Arrange window you want to use), or by using a tool in the window.

Tip: You can also use Tab or Shift-Tab to cycle through the Arrange window areas:  Tab
cycles forward, Shift-Tab cycles backward.

The main characteristic of the key focus window (or area of the Arrange window) is that
key commands only affect this window, and not any of the others.

Working in Floating Windows
Floating windows are so-named because they always float in the foreground, even above
the key focus window. (Opening numerous floating windows inevitably leads to them
covering each other—click the one you want to move to the foreground.)
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The Preferences and Project Settings windows are examples of floating windows.

Floating windows are usually recognizable by their narrower, gray title bar (except the
plug-in window, which has a different title bar style). Mouse operations performed in
floating windows behave in the same way as in normal windows.

Handling Background Windows
Background windows are not fully obscured, and can be identified by a dimmed title bar
and a faded name. They can be positioned next to the top window, or tiled underneath
it.

In background windows, you cannot only observe changes, but make almost any kind
of change, without needing to give the window key focus before making alterations.

Independent tool selection is memorized for each window, allowing you to directly edit
the contents of any window, whether it has key focus or not. As soon as any such edits
are made, the window is automatically made the key focus window. For example, suppose
you have an Arrange window with the Piano Roll Editor and Event List visible:  the Pointer
tool is active in the Arrange area, the Pencil tool is active in the Piano Roll Editor, and the
Eraser tool is active in the Event List. The tool automatically becomes active as you drag
the mouse pointer across the boundaries of each window.

Opening and Closing Windows
There are various ways to open and close windows in Logic Pro.
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To open a window
Do one of the following:

µ Choose Window > [window type] (Arrange, Score, and so on) in the main menu bar (or
use the corresponding key command).

Each window type has a corresponding key command that opens the window, without
using the mouse. For example, Command-1 opens the Arrange window, Command-2
opens the Mixer, and so on. The key command designations are shown beside each
window name in the Window menu. It’s a good idea to learn and use these key commands,
rather than the mouse, as they will speed up your workflow.

µ Drag the appropriate tab (Audio Bin, Event List, and so on) out of the Arrange window.

The tab you drag becomes an independent window.

You can open multiple windows of the same type, which may be useful when you want
to individually display and alter the contents of several regions in a particular editor type.
However, in order to streamline window management and avoid accidentally opening
multiple windows of the same type, the following behavior is observed when opening
windows:

• If the requested window type is in the background of the screenset, it is brought to
the foreground.

• If the requested window type is already in the foreground, another window of the
requested type is opened.

• If the requested window is not open in the current screenset, it is opened.

There are also a number of ways to open the Logic Pro editors in the Arrange window.

To open the Logic Pro editors
Do one of the following:

µ Click the appropriate button at the bottom of the Arrange window.

91Chapter 4 Customizing Your Window Setup



µ Drag a button at the bottom of the Arrange window. The button changes to the editor
window as you drag it.

µ Double-click an audio region in the Arrange area to open the Sample Editor at the bottom
of the Arrange window.

µ Double-click a MIDI region in the Arrange area to open the default editor at the bottom
of the Arrange window.

Note: You can determine the default editor by choosing a menu item from the
“Double-clicking a MIDI region opens” pop-up menu in the Logic Pro > Preferences >
General > Editing pane.

µ Hold down the Option key and double-click a region to open the default editor as a
separate window.

The Toggle Window key commands allow you to define one key command to open or
close the window or area of the assigned type in the active Arrange window. If the window
is not available as an Arrange window area, it is opened as an independent window. For
example, in the Arrange window you can open and close (toggle) the Lists and Media
areas with the Toggle File Browser key command, Toggle Library key command, and so
on.

There are also a number of ways to close windows in Logic Pro.

To close a window
Do one of the following:

µ Choose File > Close in the main menu bar (or use the Close Window key command, default
assignment:  Command-W).

This closes the window with key focus.
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µ Click the close button at the top-left corner of the window.

µ Option-click the close button to close all windows of the active project.

Note: If you close all open windows of a project, Logic Pro assumes that you want to
close the project, and asks if you want to save your changes.

Moving and Resizing Windows
You can move and resize all open windows individually, even across multiple monitors.
You can also alter the size of all window elements that feature the resize bar.

The size relationship of the editing and Arrange areas within the Arrange window can
also be adjusted, by clicking between them, and dragging vertically. The pointer changes
to a Resize pointer. The vertical height of the Mixer area is memorized independently. All
other editing areas share the same height.

You cannot resize the other Arrange window elements (the Inspector and Media or Lists
area). You can only open or close these areas.
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Here is an example of a possible window setup:  Imagine you want to edit the MIDI notes
of various MIDI regions. You may want to increase the height of the Piano Roll Editor to
work at a high zoom level, thus decreasing the height of the Arrange area. You would
then reduce the Arrange area zoom level, because it only needs to be used for region
selection duties.

Resize pointer

To move a window
µ Click and hold the title bar and drag the window to a new position.
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To adjust the size of a window
Do one of the following:

µ Drag the lower-right corner of the window, as with any window in the Finder.

µ Position the mouse pointer over the window edge. When the mouse pointer turns into
the Resize pointer, drag in any direction.

To adjust the size of window elements
1 Move the mouse over the resize bar.

2 When the mouse pointer turns into the Resize pointer, drag the window element.

To maximize a window
Do one of the following:

µ Select the window, then choose Window > Zoom.

µ Click the zoom button (the rightmost button of the three window controls) in the top-left
corner of the window.

Click the zoom button again to restore the original window size.
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To minimize a window
Do one of the following:

µ Select the window, then choose Window > Minimize (or use the Minimize Window key
command, default assignment:  Command-M).

µ Click the minimize button (the middle button of the three window controls) in the top-left
corner of the window.

An icon (a minimized version of the window) is placed in the Dock. The window can be
restored by clicking the icon in the Dock.

To adjust the size of a plug-in window
Do one of the following:

µ Drag the lower-right corner of the plug-in window. This scaling applies to individual
plug-ins.

µ Choose the window size in the plug-in window’s View menu. This scaling applies to
individual plug-ins.

96 Chapter 4 Customizing Your Window Setup



µ Set the default size for plug-in windows in the Logic Pro > Preferences > Display > Mixer
pane. This scaling applies to all plug-ins.

Working at Different Hierarchy Levels
Logic Pro allows you to view projects at an overview level (Arrange level) and also at a
microscopic level (editor level). These different hierarchical levels are designed for different
types of tasks, such as arranging project sections or refining instrument parts. In many
cases, you can switch between these different display levels directly, without needing to
open or access another window.

Normally, the editors are at the lowest display level, which shows individual events within
the selected region.

Clicking the Hierarchy button in the top-left corner of a window or window area moves
the displayed view up one level (generally to the Arrange level).

Note: Double-clicking the background of the editing area of a window also moves up
one display level.
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In the Piano Roll and Hyper Editors, a step up the display hierarchy shows the events of
all regions in the Arrange area.

Clicking the Hierarchy button in the Event List moves you up one level in the display
hierarchy, just like the other editors. In the Event List, however, the display remains much
the same but shows a list of regions, rather than a list of individual events, along with
region positions, names, track numbers, and lengths. The MIDI region that you were just
editing is selected within the list of region names.

Double-clicking a MIDI region (or using the Go Into Folder or Region key command)
returns you to the lowest display level, and shows the contents of the MIDI region.

Double-clicking an audio region opens it in the Sample Editor.

In the Score Editor, clicking the Hierarchy button takes you to the higher display level.
Unlike the other editors, individual events can also be edited while in higher display levels
in the Score Editor. Double-clicking a staff (at an empty point), reverts to a lower display
level.

Selecting the Working Area
The scroll bars at the right and bottom edges of a window allow you to move through
the working area in either a vertical or horizontal direction.

Scroll bar Scroll bar

98 Chapter 4 Customizing Your Window Setup



You can move the visible section by clicking the scroll arrows, or dragging the scroller.
There are two points to note:

• The size relationship of the scroller to the overall scroll bar length corresponds to the
size of the visible section of the window, in relation to the overall window size.

• The visible section changes as you move the scroller.

Use the Page Up, Page Down, Page Left, and Page Right key commands to scroll one
page up, down, left, or right, as if you had clicked in the gray area (in the scroll bar) above
or below the vertical scroller, or to the left or right of the horizontal scroller.

Click the gray area below 
the vertical scroller to 
scroll one page down.

The Page Top, Page Bottom, Page Left-Most, and Page Right-Most key commands move
the visible section of the working area to the top, bottom, left, or right, just as if you had
moved one of the scrollers to one of its extreme positions.

In the Arrange area, Event List, Hyper Editor, and Piano Roll Editor, View > Scroll to
Selection moves the visible section of the edit window to the first set of selected events.
This function is available as a key command and works in the currently active window.

Note: When a marquee selection is active, using this key command moves the visible
section of the edit window to mirror the marquee selection.
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To scroll both vertically and horizontally at the same time
Do one of the following:

µ Press Shift-Control, click-hold the Arrange window background, then drag it in the desired
direction.

µ Click-hold the Arrange window background with the third mouse button (the mouse
wheel, for example), then drag in the desired direction.

The distance of the mouse pointer from the initial clicked position determines the scrolling
speed.

Note: This second option only works if you haven’t assigned the third mouse button to
a global command, such as Exposé, for example.

Zooming the Working Area
The zoom controls are used to zoom in and out on the working display area. The zoom
value you choose reduces or increases the size of events or regions in the displayed screen
section. This allows you to:

• See more events or regions in the same amount of screen space (zoom out)

• See a detailed display of events or regions (zoom in)

While zooming, the top-left (and selected) event or region is kept in the visible area of
the screen. In other words, the first selected region or event is retained in the zoomed
window. If no selected region or event is visible, zooming is centered around the playhead.
If the playhead isn’t visible, the current center of the window is retained.

The horizontal and vertical zoom controls are located in the bottom-right corner of the
working area of the window.

Vertical zoom control

Horizontal zoom control

To zoom out
µ Click the more closely spaced bars to decrease the zoom level.
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To zoom in
µ Click the widely spaced bars to increase the zoom level.

You can drag the zoom sliders to step through several zoom levels. Any relative size
differences between tracks are retained when zooming.

Command-clicking a value in the zoom control sets the zoom slider to the respective
zoom level.

Zooming with the Playhead
The playhead can be used to zoom in and out on the working display area.

To zoom with the playhead
1 Click-hold in the lower section of the Bar ruler.

2 Drag the top of the playhead up or down.

Zooming with the Scroll Bars
The scroll bars not only allow you to move through your arrangement and editing
windows; they can also be used for zooming.

To zoom with the scroll bars
µ Click-hold the zoom handles at either end of the scroll bar, and drag:

• Up or down on the vertical scroll bar
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• Left or right on the horizontal scroll bar

As you drag, the window contents zoom.

Zooming with the Trackpad
The trackpad can be used to zoom in and out on the working display area.

To increase the zoom level
µ Pinch open on the trackpad using two fingers.

To decrease the zoom level
µ Pinch close on the trackpad using two fingers.

Zooming with the Waveform Zoom Button
Next to the Arrange area’s horizontal zoom control, you can find the Waveform Zoom
button. This button can be used to visually resize the waveform of all audio regions and
the waveform in the Beat Mapping track, if Beat Mapping is enabled in global tracks.

To toggle the state of the Waveform Zoom button
µ Click the Waveform Zoom button (or use the Toggle Waveform Vertical Zoom key

command).

When this button is activated, the waveform shown in all audio regions, and in the Beat
Mapping track, zooms to the assigned zoom level. You can change the zoom level to suit
your needs.
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To change the zoom level using the Waveform Zoom button
1 Click-hold the Waveform Zoom button. A slider appears.

2 Drag the slider. As you do, the waveform shown in all audio regions, and in the Beat
Mapping track, is increased or decreased in size.

Note: This is a purely visual function. The amplitude (level) of the waveform is not affected.

You can also change the zoom level using the following key commands:

• Waveform Vertical Zoom In

• Waveform Vertical Zoom Out

• Waveform Vertical Zoom x 1 (Normal)

• Waveform Vertical Zoom x 2

• Waveform Vertical Zoom x 4

• Waveform Vertical Zoom x 8
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Zooming In on One Section of the Screen
To enlarge a section of the screen to fill the whole window, drag to select the area with
the Zoom tool.

You can do this repeatedly, if you need to zoom in further.

Tip: You can access the Zoom tool when other tools are selected by holding down the
Control and Option keys.

Storing and Recalling Zoom Settings
You can store three different zoom settings for each window using the Save as Zoom
1–3 key commands. Use the Recall Zoom 1–3 key commands to recall your zoomed
settings. These commands only apply to the active window or window area.

Reverting to the Previous Zoom Setting
Click the background with the Zoom tool. This action returns the zoom level to the original
setting, or backtracks through previous zoom steps if the tool was used multiple times.

Using Zoom Navigation Key Commands
You can set, and recall, up to 30 zoom level and scroll bar positions for each window.
These allow you to navigate through a number of window zoom levels and scroll bar
positions, making repetitive editing tasks much faster.

You can use the following commands to zoom selected events, or a region defined by
the locators, to fit the screen. The use of all zoom commands creates a new step in the
navigation path.

• Zoom to fit Selection vertically and horizontally, store Navigation Snapshot: Displays the
current selection as large as possible, and saves it in the navigation path.

Note: When a marquee selection is active, using this key command changes the current
zoom level to fit the marquee selection.

• Zoom to fit Selection horizontally, store Navigation Snapshot: Displays the current selection
as large as possible horizontally, and saves it in the navigation path.
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Note: When a marquee selection is active, using this key command changes the current
zoom level to fit the marquee selection.

• Zoom to fit Selection vertically, store Navigation Snapshot: Displays the current selection
as large as possible vertically, and saves it in the navigation path.

• Zoom to fit Locators, store Navigation Snapshot: Displays the current locator area as
large as possible, and saves it in the navigation path.

• Zoom to fit All Contents, store Navigation Snapshot: Adjusts the zoom level in order to
fit the entire contents of the focused window into the current view.

The navigate key commands allow you to recall the previous or next zoom settings.

• Store Navigation Snapshot: The current zoom and scroll bar (window position) settings
are saved as a step in the navigation path.

• Navigation:  Back: Recalls the previous step in the navigation path.

• Navigation:  Forward: Advances to the next step in the navigation path.

As an example of where the navigation path commands could be useful:  Imagine
cutting and pasting sections of an audio region to several other locations, in a project
with hundreds of tracks. One step in your navigation path would be a zoomed view of
the audio region. Another step could be a vertically zoomed-in version of several tracks
(the target tracks for the pasted region sections). A further step could be a horizontally
zoomed-out section of the project, allowing you to paste the region segments to a
later position.

Note: There are no default key commands for most of these navigation options, so you
need to assign them in the Key Commands window. Choose Logic Pro > Preferences >
Key Commands and type “nav” in the search field. This will display the entries described
above. For more information about assigning key commands, see Assigning Key
Commands to Computer Keys.

Understanding Relationships Between Windows
Logic Pro allows you to independently link or unlink windows, providing you with flexible
viewing options. For example, you can set up two Event Lists, one showing arrange
regions, and the other showing the contents of the regions. Simply click the region name
to update the contents of the second Event List.

The two buttons at the top-left corner of most windows determine its relationship to:

• The playhead position (Catch)

105Chapter 4 Customizing Your Window Setup



• Other windows (No Link, Same Level Link, or Content Link)

Working in Catch Mode
When you work in Catch mode, the visible section of a window follows the playhead
during playback or recording. Simply click the Catch button.

If the button is disabled, the display does not update, even when the playhead moves
past the right edge of the visible portion of the window.

In the Logic Pro > Preferences > General > Catch pane, you can set the following options:

• Catch when Logic starts: Activates Catch mode whenever you click Play or Pause.

• Catch when moving playhead: Activates Catch mode whenever you move the playhead.

You also have the option of using Catch mode together with the Scroll in Play setting.
The View menus of all windows that display time horizontally (Arrange area, Score Editor,
Piano Roll Editor, and Hyper Editor) offer the View > Scroll in Play setting. If the Catch
function of the window is also activated, the playhead remains in the middle of the
window, while the background scrolls smoothly from right to left.

Working in Link Mode
The Link mode options—No Link, Same Level Link, and Content Link—allow you to define
how information is displayed when working with related editor windows.

To set any of these modes
µ Control-click (or right-click) the Link button, then choose the mode you want from the

shortcut menu.

• No Link: Unlinks the window from other windows.

• Same Level Link: When activated in a given window, this window always displays the
same contents as the key focus window. The display updates whenever the selection
(of data) in the key focus window changes. For example, imagine the key focus window
is a Piano Roll Editor. In Same Level Link mode, the Score Editor and Event List will
display the same data in another form.

106 Chapter 4 Customizing Your Window Setup



• Content Link: This mode results in the window always showing the contents of the
region selected in the key focus window. The display is therefore always one level below
that of the top window. For example, if the Arrange area is the active window, any
opened MIDI editor window will show the events of the selected MIDI region. Selecting
a different MIDI region in the Arrange area will update the display of the linked editor
to show the contents of the newly selected region. You can also use Content Link mode
in one Arrange area, to display the folder contents of another Arrange area.

Tip: You can quickly switch between these modes by clicking the Link button. Clicking
it once switches between No Link and Same Level Link mode. Double-clicking the Link
button switches to Content Link mode.

The symbol on the Link button reflects the chosen display mode:

Same Level Link mode Content Link mode

Working in Content Catch Mode
Content Catch mode is commonly used in the Arrange area, with linked MIDI editor
windows updating to show the events within the MIDI region that is currently being
played (on the selected arrange track).

The Logic Pro > Preferences > Global > Catch > “Catch content by position if Catch and
Link are enabled” preference must be selected for this to work. It is off by default.

• When the preference is turned on, Content Catch mode follows the playhead position
within the displayed region, and updates to show the contents of subsequent regions
as the playhead passes over them.

• When the preference is turned off, Content Catch mode follows the playhead position
within the displayed region, but does not update to show the contents of subsequent
regions as the playhead passes over them.

To activate Content Catch mode
1 Click the Catch button to turn it on.

2 Control-click (or right-click) the Link button, then choose Content Link from the shortcut
menu.

3 Turn on the Logic Pro > Preferences > Global > Catch > “Catch content by position if
Catch and Link are enabled” preference.

107Chapter 4 Customizing Your Window Setup



Hiding or Showing the Transport Bar
It is possible to hide the entire Transport bar, providing more workspace for regions,
editors, and other data.

To hide or show the Transport bar
Do one of the following:

µ Choose View > Transport (or use the Hide/Show Transport key command).

µ Position the pointer in the space between the Arrange area and Transport bar. When the
mouse pointer turns into the Resize pointer, drag upward or downward.

You can customize the Transport bar by adding or removing buttons and displays, allowing
access to the functions you use most often. This, in turn, has an impact on the size of the
Transport window. You can also open an independent SMPTE or Bar display window. For
more information, see Customizing the Transport Bar.

Customizing the Arrange Toolbar
You can customize the Arrange toolbar by adding buttons for the commands you use
most often. You can also configure the display to show only the button icons, or only
their labels.

To add a button to the Arrange toolbar
1 Control-click (or right-click) the Arrange toolbar, then choose Customize Toolbar from

the shortcut menu.
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2 Drag the buttons you want to add from the Customize Toolbar dialog to any empty area
along the top of the window.

If you drag a button to a location between two existing buttons, they move to make
space for the new button.

Note: You can also drag the entire default set from the bottom of the Customize Toolbar
dialog, if your customizations don’t work out as well as you’d hoped.

3 Click Done when finished.

To remove a button from the Arrange toolbar
µ Control-click (or right-click) the button you want to remove, then choose Remove Item

from the shortcut menu.

To change the appearance of toolbar items
µ The shortcut menu and Show menu in the Customize Toolbar dialog also allow you to

view toolbar items as Icon & Text, Icon Only, or Text Only. Simply choose your preferred
viewing option.

When you resize the Arrange window, the toolbar may not offer enough space to keep
all buttons visible.

To keep a toolbar button visible when you resize the Arrange window
µ Control-click (or right-click) the button, then choose Keep Item Visible from the shortcut

menu.

Hiding or Revealing the Inspector
You can hide the entire Inspector area to the left of the Arrange and editor windows,
providing more workspace for regions, events, and other data.
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To hide or show the Inspector in the Arrange window
Do one of the following:

µ Choose View > Inspector (or use the Hide/Show Inspector key command, default
assignment:  I).

µ Click the Inspector button in the Arrange toolbar.

To hide or show the Inspector in the editing windows
µ Choose View > Inspector (or use the Hide/Show Inspector key command, default

assignment:  I).

If there is not enough vertical room to display all areas of the Inspector, you can click the
disclosure triangles to hide the individual boxes.

Adjusting the Bar Ruler Display
You can switch the Bar ruler between four display modes:

• Time: Displays a SMPTE time ruler, divided into hours, minutes, seconds, and frames.

• Bar: Displays a Bar ruler, divided into bars, beats, divisions, and ticks. Depending on
the zoom settings (see Zooming the Working Area), the bars are shown at the top edge
in units of 1, 4, 8, or 16. Changes in time signature are also shown here. In the bottom
third, there is a vertical line for each bar. The shorter lines represent one beat, but are
not always visible (depending on the zoom setting).

• Bar and Time: Displays the SMPTE ruler above the Bar ruler.
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• Time and Bar: Displays the Bar ruler above the SMPTE ruler.

The appearance of the Bar ruler can be changed by clicking the small note or clock icon
at the right edge of the ruler. This opens a menu of alternate Bar and (SMPTE) Time display
settings. You can choose between time and bar linear views.

To activate a time linear view
µ Choose the Time, or Time and Bar setting from the menu.

To activate a bar linear view
µ Choose the Bar, or Bar and Time setting from the menu.

The Marquee Stripe setting hides or shows the marquee stripe—a tool used for selection
tasks. For further information, see Selecting Parts of a Region.

You can also use the following key commands to switch the ruler display:

• Event Position and Length in SMPTE Units: Switches between the Bar and SMPTE ruler if
one ruler is displayed, and switches the position of the Bar and SMPTE ruler if both are
displayed.

• Secondary Ruler: Switches the display of the second ruler.

Displaying Global Tracks
All linear editing windows can display global tracks just below the Bar ruler. You can limit
the display to particular global tracks and resize and move them. By default, the global
Marker, Signature, and Tempo tracks are visible when you open the global tracks lanes.

111Chapter 4 Customizing Your Window Setup



Hiding or Showing Global Tracks
It is possible to hide or show global tracks in general, or to hide or show particular items
in global tracks.

To hide or show global tracks
Do one of the following:

µ Choose View > Global Tracks (or use the Toggle Global Tracks key command, default
assignment:  G).

µ Click the Global Tracks disclosure triangle to the left of the Bar ruler.

To hide or show particular global tracks
Do one of the following:

µ Choose View > Configure Global Tracks (or use the corresponding key command, default
assignment:  Option-G), then select the corresponding checkboxes.

µ Control-click (or right-click) anywhere in the global tracks header area, then select or
deselect individual tracks.
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µ Control-click (or right-click) anywhere in the global tracks header area, choose Configure
Global Tracks from the shortcut menu (or use the corresponding key command, default
assignment:  Option-G), then select the corresponding checkboxes.

The choices made in the Global Tracks Configuration dialog only affect the active window.
Each window can have an independent global track display configuration.

Tip: Click the Enable All or Disable All buttons to show or hide all global tracks, respectively.
Or use their corresponding key commands—Show All Global Tracks and Hide All Global
Tracks.

Note: You can also assign, and use, any of the following Toggle key commands for each
individual global track:  Marker, Transposition, Chord, Signature, Tempo, Beat Mapping,
and Video. The key commands have an immediate impact, and do not open the Global
Tracks Configuration dialog.

Resizing or Moving Global Tracks
You can resize global tracks individually, or you can resize the entire global tracks area.

To resize individual global tracks
Do one of the following:

µ Click the disclosure triangle in the upper-left corner of each global track.

The track height is expanded and additional controls become visible. Click the triangle
again to reduce the track height.

µ Position the mouse pointer over the lane dividers between global tracks in the header
area, then drag up or down.
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To resize the entire global tracks area
µ Position the mouse pointer over the dividing line between the global tracks and the

arrange tracks, then drag up or down.

To change the order of global tracks
µ Grab anywhere (except on the control elements) in the header area of the global track

you want to move, then drag up or down.

The display order of global tracks is saved independently for each window.

Tip: If the Track Protect buttons are visible (View > Configure Track Header > Protect
Buttons), you can prevent unintentional changes to individual global tracks by clicking
the corresponding Protect button.

Using Screensets
You position windows in a way that suits your working methods. This layout of various
windows, including the display size, zoom levels, and position of each window (and other
settings), is called a screenset. Once defined, you can save, and freely switch between
different screensets, much as you might between different computer displays.

Creating, Recalling, and Switching Screensets
Screensets are numbered from 1 to 99 (using only the 1 to 9 computer keys—the 0 key
is assigned to the Stop command by default).

You don’t need to save screensets with an explicit command. It happens automatically,
as soon as you switch to another screenset. Thus, without any effort, your current working
view is always stored as the current screenset.

To create a screenset
1 Press any numerical key except 0; for example, 7.

For two-digit screensets, hold down the Control key while entering the first digit.

2 Arrange your windows, including changes to zoom settings, the relationship of the Arrange
area and editor areas, open or closed Inspector and Media or Lists areas, and so on.

Note: When you choose a screenset number that has not been saved, a maximized
Arrange window opens.

To recall or switch between screensets
Do one of the following:

µ Input the number of the screenset (1 to 9) you want.

For two-digit screensets, hold down the Control key while entering the first digit.

µ Choose the screenset from the Screenset menu.

µ Use the Next Screenset or Previous Screenset key commands.
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Note: Screensets 1 to 9 can be recalled by freely defined key commands, not only the
number keys on your computer keyboard. This allows you to use the number keys for
other purposes, such as opening or closing windows. The 1 to 9 key commands are called
Recall Screenset 1–9 in the Key Commands window.

To switch a screenset automatically
1 Select the MIDI region into which you want to insert the meta event.

2 Set the playhead to the point where you want the screenset to change.

3 Click the Create button in the Event List, then click the Meta Events button.

The inserted meta event has a default value of 50 (Project Select).

4 Alter the number in the Num column from 50 to 49.

This changes the name to screenset.

5 Enter the screenset number in the Val column.

You can stop screenset switching by muting the MIDI region that contains the meta 49
event.

Protecting, Copying, Renaming, and Deleting Screensets
Logic Pro allows you to protect, copy, rename, and delete a screenset, making it easy to
manage them.

To prevent the current screenset from being altered
µ Choose Screensets > Lock from the main menu bar (or use the Lock/Unlock Current

Screenset key command).

A bullet appears in front of the screenset number to indicate that it is locked. Reuse the
key or menu command to unlock the screenset.
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Important: The File > New command deactivates all screenset locks.

To copy screensets
1 Switch to the screenset you want to copy, and choose Screensets > Duplicate from the

main menu bar (or use the Duplicate Screenset key command).

The Duplicate Screenset dialog appears.

2 Enter the target screenset number (the screenset number that you want to copy to), and
type a name.

3 Click OK.

To rename the current screenset
1 Choose Screensets > Rename from the main menu bar (or use the Rename Screenset key

command).

The Rename Screenset dialog appears.

2 Do one of the following:

• Type a new name.

• Click the Auto Name button to automatically name the screenset. This defaults to the
visible window names (“Arrange/Piano Roll” or “Arrange/Mixer” as examples). The name
is automatically updated whenever a window or view is opened or closed.

This names the screenset automatically, defaulting to the visible window names
(“Arrange/Piano Roll” or “Arrange/Mixer” as examples). The name is automatically
updated whenever a window or view is opened or closed.

3 Click OK.
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To delete the current screenset
µ Choose Screensets > Delete from the main menu bar (or use the Delete Screenset key

command).

Importing Screensets from Another Project
You can import screensets from another project.

To import all screensets from another project
1 Do one of the following:

• Choose File > Project Settings > Import Project Settings (or use the corresponding key
command, default assignment:  Option-Command-I).

• Click the Settings button in the Arrange toolbar, then choose Import Settings from the
pop-up menu.

• Choose the Media > Browser pane.

2 Navigate to, and select, the project file that you want to import screensets from.

3 Click the Import button.

Note: If accessing this feature via the Media > Browser pane, you also need to click the
Import Settings button, which appears after clicking the Import button.

4 In the Import Settings dialog, click the Screensets option.

5 Click the Import button.

The settings are imported into the active project.

Reverting to Saved Screensets
You can easily revert to saved screensets.

To revert to saved screensets
µ Choose Screensets > Revert to Saved from the main menu bar (or use the Revert to Saved

Screenset key command).

This resets your screen to its original state—prior to changing any aspect of the current
screenset.
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Logic Pro offers a number of project playback and navigation controls. You can use the
Transport bar, key commands, and the Bar ruler, and can also take advantage of markers
to tag sections of your project, and quickly move between them. The playhead indicates
the current playback position.

This chapter concentrates on the use of the Transport bar and Bar ruler for navigation.
Information on the use of markers can be found in Working with Markers.

This chapter covers the following:

• Setting the Playhead Position (p. 120)

• Using the Transport Buttons (p. 123)

• Using Transport Key Commands (p. 124)

• Using Transport Shortcut Menus (p. 125)

• Using Apple Remote (p. 126)

• Using Cycle Mode (p. 127)

• Using the Chase Events Function (p. 133)

• Customizing the Transport Bar (p. 135)
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Setting the Playhead Position
The playhead is a vertical line that indicates the current position in all horizontal,
time-based windows. It is positioned:

• In the lower half of the Bar ruler when one ruler is displayed

Playhead

• At the top of the Bar ruler when two rulers are displayed

Playhead

For more information about changing the number of rulers used, see Adjusting the Bar
Ruler Display.

To place the playhead in the Bar ruler
Do one of the following:

µ When one ruler is displayed, click a position in the lower half of the Bar ruler.

µ When two rulers are displayed, click a position in the top half of the Bar ruler.
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Setting the Playhead with the Position Display
The Transport bar’s Position display shows the current playhead position in two formats:

• SMPTE Time: The upper row displays the playhead position in SMPTE time format—hours
:  minutes :  seconds :  frames / subframes.

• Musical division of time: The lower row displays the playhead position in bars, beats,
division, and ticks.

A beat corresponds to the denominator in the time signature.

The division value is set in the Transport bar, below the time signature.

Division value

A tick is the smallest possible bar subdivision. It is equal to 1/3840th of a note.

To set the playhead position in the Position display
Do one of the following:

µ Click-hold any of the numbers in the Position display, and move the mouse up or down.

µ Double-click either display field, and then type in a new position.

The playhead moves to match the display position.

Adjusting the first number in the Bar display moves the playhead by bars, and by hours
in the SMPTE display.

Adjusting the second number moves by beats in the Bar display, and by minutes in the
SMPTE display, and so on at increasingly small divisions with the other values shown in
the Position display.
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When typing in a full position using the Bar display, for example, you should type in the
following manner:

• 3 Space 3 Space 2 Space 2, Return key to exit text entry mode.

• 3.3.2.2, Return key to exit text entry mode.

If you simply type in 3322, followed by the Return key, the playhead moves to bar 3322,
rather than bar 3, beat 3, division 2, tick 2. This allows you to quickly navigate to the
beginning of a bar by inputting the first digit.

Setting the Playhead at a Marker
If you have labeled a passage with a marker, you can use this marker to set the playhead
position.

To set the playhead at the start of a marker
µ Click anywhere on the marker while holding down the Option key.

To begin playback at the start of a marker
µ Command-double-click the marker, while Logic Pro is stopped.

Note: This only works with a marker in the Bar ruler.

Adjusting the Size of the Playhead
You can adjust the thickness of the playhead in the General Display preferences.

Default playheadThick playhead

To adjust the playhead display
1 Open Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).
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• Click the Preferences button in the Arrange toolbar, then choose Display from the
menu.

2 Click the General tab, and select the Wide Playhead checkbox.

Using the Transport Buttons
You can use the transport buttons in the Transport bar to control playback, or to set the
playhead position. You can click the buttons to activate or deactivate functions, or better
yet, make use of the corresponding key commands (computer keyboard shortcuts) to
speed up your workflow.

Note: The image below shows all transport buttons. The buttons available in the Transport
bar of your project may differ, as you can customize the Transport bar. For further
information, see Customizing the Transport Bar.

The following is a description of the transport buttons, from left to right:

• Go to Beginning: Moves the playhead to the beginning of the project.

• Go to Position: Opens a dialog that allows you to type in a playhead (target) position
numerically.

• Go to Left Locator: Moves the playhead to the left locator position.

• Go to Right Locator: Moves the playhead to the right locator position.

• Go to Selection Start: Moves the playhead to the start point of the first selected region
or event in the active window. Default key command assignment:  Shift-Return.

• Play from Beginning: Starts playback at the beginning of the project.
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• Play from Left Window Edge: Plays from the leftmost point of the visible display area in
the active window.

• Play from Left Locator: Moves the playhead to the left locator position, and begins
playback.

• Play from Right Locator: Moves the playhead to the right locator position, and begins
playback.

• Play from Selection: Moves the playhead to the start point of the selected regions or
events, and begins playback. Default key command assignment:  Shift-Return.

• Rewind/Fast Rewind: A single click moves the playhead one bar backward.
Command-clicking moves the playhead to the previous marker. Click-holding fast
rewinds. Click-holding and dragging to the left or right shuttles forward or backward.

• Forward/Fast Forward: A single click moves the playhead one bar forward.
Command-clicking moves the playhead to the next marker. Click-holding fast forwards.
Click-holding and dragging to the left or right shuttles forward or backward.

• Stop: Stops recording or playback. Clicking the Stop button a second time moves the
playhead to the project start point, or to the left locator position if Cycle mode is active.
Default key command assignment:  Return.

Note: You can Control-click (or right-click) the Stop button and define the action that
this button triggers:  Stop, Stop and Go to Left Locator, Stop and Go to Last Locate
Position.

• Play: Starts playback at the current playhead position, or from the left locator position
when in Cycle mode. Default key command assignment:  Return. Control-click or
right-click the button to open the Play menu.

• Pause: Pauses recording or playback, until you click either the Pause or Play button.

• Record: Click to begin recording (if a track is record-enabled). Default key command
assignment:  Asterisk (*).

Note: You can Control-click (or right-click) the Record button and define the action
that this button triggers:  Record, Record/Record Toggle, Record/Record Repeat.

• Capture Recording: Allows the most recent performance to be kept, even if Logic Pro
was not in record mode while you were playing.

Using Transport Key Commands
There are a number of transport functions that are only available as key commands. Most
of the key commands for these functions are not assigned by default, so you will need
to set up key commands for them. See Assigning Key Commands to Computer Keys.

• Play or Stop: Switches between playback and stop, depending on the play or stop status
when the command is used. Default key command assignment:  Space bar.
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Tip: The Space bar can be used to start or stop playback of audio files or regions in the
Sample Editor, Audio Bin, and Loop Browser, when these windows have key focus.

• Play from Previous Bar: Starts playback at the start of the previous bar.

• Stop or Play from Last Position: Stops playback at the current playhead position, or starts
playback from the last playhead position, depending on the play or stop status when
the command is used.

• Stop and Go to Left Locator: Stops playback, and moves the playhead to the left locator
position.

Note: You can assign this command directly to the Stop button, by Control-clicking
(or right-clicking) the Stop button and choosing the setting in the menu.

• Go to Last Locate Position: Moves the playhead to the last position reached with a
positioning command, or direct positioning of the playhead, using the mouse or ruler.

• Stop and Go to Last Locate Position: As above, but stops playback.

Note: You can assign this command directly to the Stop button, by Control-clicking
(or right-clicking) the Stop button and choosing the setting in the menu.

• Play or Stop and Go to Last Locate Position: Starts playback at the current playhead
position, or stops playback and moves the playhead to its last position, depending on
the play or stop status when the command is used.

• Stop and Go to Beginning: Stops playback and moves the playhead to the project start
position.

• Shuttle Rewind and Shuttle Forward: Repeated key presses increase the winding speed.
Repeated presses of the opposing shuttle key slow down the shuttle speed, and
eventually change the winding direction. Shuttle disables Cycle mode. Shuttling is
halted by the Stop command.

• Go to Selection End: Moves the playhead to the end of the first selected region or event
in the active window.

Note: There are also a large number of Go To key commands for markers available. For
further information, see Navigating with Markers.

Using Transport Shortcut Menus
There are a number of transport functions that are only accessible from shortcut menus.

The following functions are available from the Stop button shortcut menu.

• Jump Between Marquee- and Project Start if stopped: Toggles the playhead between the
marquee start position and the project start position, when Logic Pro is stopped. Only
applies if there is an active marquee selection.
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• Jump Between Cycle- and Project Start if stopped: Toggles the playhead between the
cycle area start position and the project start position, when Logic Pro is stopped. Only
applies if there is an active cycle area.

• Jump Between Selected Region- and Project Start if stopped: Toggles the playhead between
the start position of the first selected region and the project start position, when
Logic Pro is stopped. Only applies if a region or folder is selected.

• Jump Between Last Locate Position- and Project Start if stopped: Toggles the playhead
between the last locate position and the project start position, when Logic Pro is
stopped.

To access these Stop button transport functions
µ Control-click (or right-click) the Stop button in the Transport bar.

The following functions are available from the Play button shortcut menu.

• Play Marquee Selection: Starts playback within a marquee selection, with playback taking
place once unless Cycle mode is turned on.

• Play Cycle: Starts playback from the left locator position when Cycle mode is turned
on.

• Play From Selected Region: Starts playback from the start of the first selected region.

• Play From Last Locate Position: Starts playback from the last playhead position.

To access these Play button transport functions
µ Control-click (or right-click) the Play button in the Transport bar.

Using Apple Remote
You can use your Apple Remote to control Logic Pro from a distance. A short click offers
the following functions:

Rewind

Play or Stop

Forward

Next track

Record

Previous track
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A long click offers the following functions:

Fast Forward
Stop

Fast Rewind

Note: The Apple Remote is compatible with Apple products that have a built-in Infrared
(IR) receiver. Front Row is not available while Logic Pro is open.

Using Cycle Mode
You can use Cycle mode to repeatedly play a selected passage. This is useful for:

• Composing a section of a project (a verse or chorus, for example)

• Practicing, before making a recording

• Recording individual tracks consecutively

• Editing events

• Recording multiple takes

Cycle area

Left locator Right locator

When Cycle mode is active, a green stripe is displayed:

• In the top half of the Bar ruler when one ruler is displayed

• In the middle part of the Bar ruler when two rulers are displayed
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The cycle area is defined by the position of the left and right locators. When Cycle mode
is disabled, the left and right locators disappear and the cycle area is dimmed.

To turn Cycle mode on and off
Do one of the following:

µ Click the Cycle button in the Transport bar (or use the Cycle Mode key command, default
assignment:  C).

µ Click the top part of the Bar ruler (on the gray locators stripe).

In Cycle mode:

• The playhead jumps from the end of the cycle to the beginning.

• The Play command starts playback from the beginning of the cycle.

• To start playback from another position, click Pause twice, or Pause and then Play.

• At the cycle jump point, you can use the Chase Events function:  File > Project Settings
> MIDI > Chase > Chase on Cycle Jump. For more information about chasing events,
see Using the Chase Events Function.

• You can determine the way recording works in Cycle mode, by using the various options
in the File > Project Settings > Recording pane.

Defining a Cycle in the Bar Ruler
You can define, move, and resize a cycle in the Bar ruler.

To define a cycle
µ Drag the mouse from left to right in the top part of the Bar ruler.

The cycle area appears as a green stripe in the Bar ruler, and Cycle mode is automatically
turned on.

To move a cycle
µ Grab the green cycle stripe in the middle (the pointer turns into a hand), and drag it to

the left or right.

Two lines extend down the screen from the beginning and end points of the cycle. These
make it easy to align the cycle with regions in the Arrange area, or events in the Piano
Roll Editor.
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To resize a cycle
µ Grab the handles (triangles) at either end of the cycle to move the start or end points

(you can even do this while Logic Pro is open).

Note: You can set either the start or end point of a cycle (whichever is closest) by
Shift-clicking a position in the Bar ruler. This works even when the stripe is outside the
visible range, or Cycle mode is turned off.

When you set the size of a cycle graphically in the Bar ruler, its start and end points (and
therefore, overall size) is quantized to the setting chosen in the Snap menu. For more
information, see Snapping Region Edits to Time Positions.

Defining a Cycle with Locator Positions
You can enter the locator positions—therefore setting the cycle boundaries—numerically
in the Transport bar Locator display. The locators are shown to the right of the Position
display. The top value denotes the left locator position, and the bottom one, the right
locator position.

Right locator

Left locatorPosition display

To define the locator positions in the Transport bar
Do one of the following:

µ Double-click either locator display field, and enter a left or right position value.

Type in all bar, beat, sub-beat, and tick values (using space or a period between numbers),
and press Return to close the entry box and set the locator.

Note: You can quickly set the locator to the beginning of a bar by simply inputting the
first digit.

µ Click-hold any of the left or right locator number fields in the Transport bar, and move
the mouse up or down.

The corresponding cycle boundary (if shown in the Bar ruler) moves to match.

You also have the option of displaying the locator positions as SMPTE values, or as musical
positions.

To change the display of locator positions
Do one of the following:

µ Control-click the display area of the Transport bar, and choose Display Locators as Time.
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This has no impact on the Bar ruler display mode.

µ Click the small down arrow icon to the right of the Bar ruler, and choose either Bar mode
or Time mode.

This updates the Transport bar Locator display accordingly.

Using the Shortcut Menu to Define a Cycle
You can access a shortcut menu from the Cycle button in the Transport bar. This shortcut
menu provides the following options:

• Auto Set Locators: Choose to automatically set the Locators by Selection whenever a
new selection (according to the following three options) is created.

Note: The symbol on the Cycle button indicates the current status of the
Auto Set Locators menu item:

Auto Set Locators 
menu item is unselected.

Auto Set Locators 
menu item is selected.

• by Marquee selection: Auto Set Locators keeps the cycle range exactly around the
marquee-selected area.

• by Region selection: Auto Set Locators keeps the cycle range exactly around the outer
borders of all selected regions or folders.

• by Note selection: Auto Set Locators keeps the cycle range—rounded by bars—around
all selected note events.
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Using the Transport Bar Mode Buttons to Define Locators
You can use the following commands, available as Transport bar buttons, to define the
locator positions. You can click the buttons to activate or deactivate functions, or better
yet, make use of the corresponding key commands (computer keyboard shortcuts) to
speed up your workflow.

Note: The screenshot below shows all relevant buttons. The buttons available in the
Transport bar of your project may differ, as you can customize the Transport bar. For
further information see Customizing the Transport Bar.

• Set Left Locator and Set Right Locator: These allow you to directly enter either of the
locator points in a dialog. Also available as key commands.

• Set Left Locator by Playhead and Set Right Locator by Playhead: The current playhead
position is used to define the left or right locator value. Also available as key commands.

• Move Locators Forward by Cycle Length and Move Locators Backwards by Cycle
Length: Move the cycled passage by its own length. Also available as key commands.

Defining a Cycle with Regions or Events
You can use the following key commands to set the locators at the start and end points
of selected regions or events:

• Set Locators by Regions/Events: Sets the locators at the start and end points of the
selected regions or events.

• Set Locators and Play: Sets the locators at the start and end points of the selected regions
(or events) and starts playback.

• Set Rounded Locators by Regions/Events: Rounds the position of the locators to the
barline that is nearest to the beginning and end points of the selected regions or events.

• Set Rounded Locators and Play and Set Rounded Locators and Record: Rounds the position
of the locators to the barline that is nearest to the beginning and end points of the
selected regions or events, and starts playback or recording.

• Set Rounded Locators and Cycle Play and Set Rounded Locators and Cycle Record: Rounds
the position of the locators to the barline that is nearest to the beginning and end
points of the selected regions or events, and switches to cycle play or record mode.
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Defining a Cycle with Markers
Dragging a marker into the top part of the Bar ruler creates a cycle with the marker’s
length. Details on creating and using markers is covered in Working with Markers.

You can also use one of the following key commands:

• Set Locators by Marker and Enable Cycle: Sets the cycle to the currently selected marker
and activates Cycle mode. The length of the cycle is determined by the marker length.

• Set Locators by Next Marker and Enable Cycle: Sets the cycle to the next marker and
activates Cycle mode.

• Set Locators by Previous Marker and Enable Cycle: Sets the cycle to the previous marker
and activates Cycle mode.

Note: These commands are ideally suited for repeating passages during live performances.
Define markers for all parts of the project that you might want to repeat in this way during
your performance.

Using Skip Cycle
You can skip a passage in playback mode, which is useful for trying out the musical effect
of various transitions from one project section to another, without needing to physically
move regions. This is a very handy feature when arranging.

Skip cycle is also useful when editing, to leave out parts of the project that you don’t
want to be affected by the edit.

To set up a skip cycle
Do one of the following:

µ Drag the skip cycle area from right to left in the Bar ruler.

µ If a (normal) cycle area already exists, you can swap the left and right locator by clicking
the Swap Left and Right Locators button in the Transport bar (or using the Swap Left and
Right Locator key command).
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The skip cycle area is shown as a green candy-striped area in the Bar ruler.

When the playhead reaches the right locator position, it skips to the left locator (in essence,
the right and left locators swap positions).

Using the Chase Events Function
If you start playback in the middle of a project, some events might not be heard (such as
notes, sustain pedal events, and pitch bend events that start before the point where
playback begins). Using the Chase Events function, you can have Logic Pro analyze the
project and include some or all of these events when the project plays back.

To set up the Chase Events function
1 Open the MIDI project settings by doing one of the following:

• Choose File > Project Settings > MIDI (or use the Open MIDI Project Settings key
command).

• Click the Settings button in the Arrange toolbar, then choose MIDI.
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2 Click the Chase tab, then select the checkboxes of all events that the Chase Events function
should look for before the playback start point.

See Chase Settings for full details.

There is a potential problem when chasing notes that are used to trigger a drum loop in
a sampler. Unless you are lucky enough to start the MIDI region precisely at the beginning
of the sample loop, the sample will be triggered at the wrong time and will play out of
sync with other regions (at least until the next trigger note).

The problem occurs because most samplers can only play samples from the beginning,
and cannot synchronize them to the beat when started in the middle.

To avoid triggering a sampler’s drum loops when chasing note events
1 Activate the No Transpose parameter of your drum loop instrument, in the Track Parameter

box of the Inspector.

2 Turn off the In ‘No Transpose’ Instrument Channel Strips option in the Project Settings >
MIDI > Chase pane.

These settings prevent your sampler’s drum loops from playing until they reach the next
trigger note, whenever the project jumps to a new position.
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The No Transpose parameter actually prevents transposition by the region playback
parameters, which is also not desirable for drum sounds or loops.

Customizing the Transport Bar
The Transport bar offers a default set of buttons, displays, and sliders. These are the most
commonly used, and most useful, options for the majority of users.

You, however, may need to regularly access particular functions that are not part of the
default set, due to:

• The type of project you are working on; a film soundtrack, for example

• A unique working style

• A desire to have everything at your fingertips

Whatever the motivation, you can easily customize the Transport bar to meet your needs.

Showing and Hiding Transport Bar Functions
You can show or hide different parts of the Transport bar independently. This, in turn,
allows you to control the width of the Transport bar.

You should limit the Transport bar to functions you actually need to access regularly, or
better yet, configure and memorize all of the corresponding transport or mode key
commands. This will allow you to expand the display area of the Transport bar, providing
more at-a-glance information.

If you want all commands and options to be visible in the Transport bar, you will need
either a second computer monitor, or a single monitor with an exceptionally high
horizontal resolution.

Tip: Logic Pro allows an unlimited number of Transport bar windows to be opened
simultaneously. Additional Transport bar windows can be individually customized, allowing
you to view and access additional functions that will not fit on the standard Transport
bar at the bottom of the Arrange window. Customized Transport bars (and other windows)
can be saved as part of a screenset.

To customize the Transport bar
1 Control-click (or right-click) the Transport bar, and choose Customize Transport Bar from

the menu.
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2 Turn on or turn off individual functions by selecting the checkboxes in the Customize
dialog.

3 Choose the appropriate option, as follows:

• Click the Cancel button to cancel the action.

• Click the OK button to confirm the action.

• Click the Save As Default button to save your current user layout, which is then applied
whenever you create an empty new project, open a new Arrange window, or click the
Restore Defaults button.

• Click the Restore Defaults button to apply your saved user layout.

• Option-click the Restore Defaults button to apply the Transport bar’s original factory
layout.

Getting to Know the Transport Bar Functions
This section describes the buttons, the display area, and the modes and functions found
in the Transport bar. You can control the width of the Transport bar by showing or hiding
different parts of the Transport bar independently. For further details about customizing
the Transport bar, see Showing and Hiding Transport Bar Functions.
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Transport Buttons
This area of the Transport bar contains buttons that literally transport the playhead
through the project.

For an explanation of the individual functions and commands, see Using the Transport
Buttons.

Display Area
This area of the Transport bar primarily informs you of the playhead and locator positions,
but can also be used to navigate through the project.

• Positions (SMPTE/Bar): The top row indicates the current position of the playhead in
SMPTE format (hours :  minutes :  seconds :  frames), the bottom row in bars, beats,
divisions, and ticks.

• Locators (Left/Right): The top row indicates the left locator position, the bottom row
the right locator position. Locators are used to define a particular section of the project
for a number of recording or playback tasks. You can display locators in the Transport
bar in terms of Bar or Time, by Control-clicking (or right-clicking) the display area and
turning on/off the Display Locators as Time option. In Transport views which are part
of Arrange windows, this option should automatically follow the Ruler mode.

• Sample Rate or Punch Locators: The display shows the current project sample rate, or
punch recording in/out locators (when punch recording mode is enabled). As with
other Transport bar display fields, you can set the sample rate or punch locators with
the mouse or via direct numerical entry.

• Varispeed: The Varispeed display allows you to speed up or slow down a project between
–50% and +100% (which equals between 50% and 200% of the original tempo). The
top row indicates the Varispeed mode (Speed Only, Varispeed, Varispeed and MIDI),
the bottom row the Varispeed value and unit.

• Tempo/Project End: The Tempo display indicates the current playback or recording
speed. The Project End display shows the total number of bars. It behaves as stop
playback/recording marker for the project.
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• Signature/Division: The (Time) Signature display indicates the current playback or
recording time signature in a standard musical format; 4/4, 5/4, and so on. The Division
display determines the current display (and editing) resolution. A value of /16 means
that a 4/4 bar is divided into 16 sub-sections, or 4 sub beats for each beat in the bar.

• MIDI Activity (In/Out): The display indicates incoming and outgoing MIDI data. The MIDI
In display (top) will show chord names for incoming MIDI note data.

• Load Meters (CPU/HD): Click this display to show CPU load and hard disk throughput
load meters. Double-click to open the load meters as a separate window. Alternatively,
you can choose Options > Audio > System Performance from the main menu bar (or
use the Open System Performance key command, default assignment:  Option-X).

Modes and Functions
The mode buttons and Master Volume slider in this area of the Transport bar are used
for several advanced recording and playback functions, including repeating project
sections, soloing, and punch recording. The buttons do not immediately trigger an action.
Rather, they switch operating states. The relevant button illuminates to indicate that the
mode is activated.

• Varispeed: Enables Varispeed mode, allowing you to alter playback speed (keeping the
original pitch) or playback speed and pitch, or to transpose classic MIDI output.

• Software Monitoring: Enables software monitoring, allowing you to process external
sources via Logic Pro effects. It also allows you to hear external sources while recording.

• Auto Input Monitoring: Automatically allows you to hear external sources at the audio
inputs.

• Pre Fader Metering: Switches all of the mixer channel strip meters between pre-fader
(the Volume fader on each channel strip) and post-fader modes (when turned off ).

• Low Latency Mode: Enables Low Latency mode, allowing you to limit the amount of
delay (latency) caused by some effects.

• Set Left Locator by Playhead and Set Right Locator by Playhead: Allow you to use the
current playhead position to define the left or right locator value.

• Set Left Locator Numerically and Set Right Locator Numerically: Allow you to enter either
of the locator points in a dialog. Also available as key commands.

• Swap Left and Right Locators: Allows you to reverse the location of the left and right
locators. For further details, see Using Skip Cycle.
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• Move Locators Backwards by Cycle Length and Move Locators Forward by Cycle
Length: Retains the existing cycle, but moves it to the left or to the right by the cycle
length. For example, if the cycle is 4 bars long, and spans bars 12 to 16, using the Move
Locators Backwards by Cycle Length command moves the cycle four bars to the left,
resulting in a cycle from bar 8 to 12.

• Cycle: Enables or disables repeated playback or recording over a project section. The
cycle boundaries are reflected (or set) by the left and right locator values.

• Autopunch: Enables or disables a recording start and end point. It is commonly used
in conjunction with the left and right autopunch locators to automatically record over
a particular project section. This method is often used to fix a mistake in a vocal or
instrumental recording.

• Set Punch In Locator by Playhead and Set Punch Out Locator by Playhead: Allow you to
use the current playhead position to define the punch in or punch out locator value.

• Replace: Enables a new recording to overwrite an existing recording.

• Solo: Only selected regions are played; all other regions are muted.

• Sync: Activate to synchronize Logic Pro with an external source (make Logic Pro the
synchronization slave to another device). Control-click or click-hold this button to open
the Synchronization menu.

• Click: Used to turn the Logic Pro internal metronome on and off. Control-click or
click-hold this button to open the Metronome menu.

• Master Volume: Click to display a volume slider at the right of the Transport bar. This
slider is directly tied to the Master channel strip in the Mixer, and acts as a master
volume control for all audio and software instrument tracks.

Using a Giant SMPTE or Bar Display
You can configure the Transport bar to display a giant SMPTE or bar display in place of
the standard Transport bar display area.

Alternately, you can spawn a new giant SMPTE or Bar Display window.

To replace the standard Transport bar display area with a SMPTE or bar display
µ Control-click (or right-click) the Transport bar display area, and choose Big Bar Display or

Big SMPTE Display, as required.

The Transport bar display area is replaced with the chosen big display.

Repeat the step above to return to the standard display.
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To open a new SMPTE or Bar Display window
µ Control-click (or right-click) the Transport bar display area, and choose Open Giant Bar

Display or Open Giant SMPTE Display, as required.

A new, floating window opens.

This window can be freely positioned and resized.

Tip: Control-clicking the window allows you to quickly select the option to switch between
the Giant Bar Display and Giant SMPTE Display, as required.

To resize the SMPTE or Bar Display window
Do one of the following:

µ Position the mouse pointer over one of the window edges (right, left, or bottom edge).
When the mouse pointer turns into the Resize pointer, drag in the desired direction.

µ Drag the lower-right corner of the window.

To close the chosen giant display, click the close icon at the top-left corner of the window.

Note: Logic Pro allows an unlimited number of Transport (and Giant SMPTE or Bar Display)
windows to be opened simultaneously.

Using SMPTE View Offset
You can configure any open Transport bar display area or Giant SMPTE Display window
to show SMPTE time with or without SMPTE view offset.
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To access the Use SMPTE View Offset setting on an individual basis
Do one of the following:

µ Control-click (or right-click) any open Transport bar display area.

µ Control-click (or right-click) any open Giant SMPTE display area.

Customizing the Bar, SMPTE, and Tempo Display
You can customize the Bar, SMPTE, and Tempo display in the Display preferences.

To customize the Bar, SMPTE, or Tempo display
1 Open General Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
menu.
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2 Choose one of the following settings in the Clock Format menu:

• Clock Format:  1 1 1 1

• Clock Format:  1. 1. 1. 1

• Clock Format:  1 1 1 0

• Clock Format:  1. 1. 1. 0

• Clock Format:  1 1 _1

• Clock Format:  1. 1. _1

• Clock Format:  1 1 _0

• Clock Format:  1. 1. _0

3 Choose one of the following settings in the Display SMPTE menu:

• With Bits: Subframes (SMPTE bits 0 to 79) are shown.

• Without Bits: Subframes are not shown.

• With Quarter Frames: Quarter frames are shown.

• As Feet Frames, 35 mm film: The display is displayed in feet and frames, for 35mm film.

• As Feet Frames, 16 mm film: The display is displayed in feet and frames, for 16mm film.

• With Milliseconds: The frame fractions are displayed in milliseconds instead of SMPTE bits
(also called subframes). Don’t forget that this value is dependent on the frame rate:  at
25 fps, a frame is 40 milliseconds long, at 30 fps, approximately 33 ms.

• With Samples: Frame fractions are shown as sample values.

• With Frames and Samples: Both fractional frame and sample values are shown.

4 Select the “Zeros as spaces” checkbox if you want zero values to appear as blank spaces,
rather than the number 0 in SMPTE time displays.

5 Choose one of the following settings in the Display Tempo As pop-up menu:

• Beats Per Minute (BPM, Maelzel): Beats per minute, to four individually adjustable decimal
places.

• BPM without Decimals: Beats per minute, with no decimal places.

• Frames Per Click with Eights: Frames per beat with eighths. After the value, you will see
fpc.

• Frames Per Click with Decimals: Frames per beat, to four decimal places. Take care, as
this display can easily be confused with the bpm display.
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The main purpose of markers is to tag different parts of a project, and to enable the quick
selection of these parts for playback, editing, and arranging. Markers serve as a kind of
project road map, representing the form of a project graphically. Apart from the text
functions, markers can also be regarded as storage areas for locator positions—each of
which can be individually named.

This chapter covers the following:

• Opening Marker Areas and Windows (p. 144)

• Creating Markers (p. 146)

• Copying Markers (p. 149)

• Selecting Markers (p. 149)

• Deleting Markers (p. 149)

• Naming Markers (p. 150)

• Changing the Appearance of Marker Text (p. 153)

• Editing Markers (p. 154)

• Navigating with Markers (p. 156)

• Switching Between Marker Alternatives (p. 158)

• Customizing the Marker Display in the Marker List (p. 158)

• Importing, Removing, and Exporting Marker Information (p. 158)
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Opening Marker Areas and Windows
There are many ways to interact with, create, and delete markers in Logic Pro. You can
see and edit markers in the following window areas:

Marker Text area

Marker ListMarker track

• Marker track: Displays markers as (optionally) colored sections. If the Marker track is
hidden, you can see markers as short text strings in the Bar ruler of all linear editing
windows. The main advantage of the Marker track over the marker display in the Bar
ruler is that it allows you to select, copy, move, or resize markers directly with the mouse.
Click the disclosure triangle in the upper-left corner of the Marker track name column
to expand the track height, thereby displaying additional controls. You can freely adjust
the lower border of the Marker track by dragging it up or down with the mouse.

• Marker List: Lists the names of all markers, inclusive of bar position and length
information.

• Marker Text area and Marker Text window: Show text associated with a marker. This
makes markers suitable for use as notepads, allowing text comments to be saved with
the project. Marker text can be typed in, and edited, as you would in any text editor.
The Cut, Copy, Paste, Clear, and Select All commands can be used to import or export
text to and from other software applications (such as word processors).

To open the Marker track
1 Click the disclosure triangle in the Global Tracks header area.

2 Click the disclosure triangle for the Marker track.

You can also assign, and use, the Toggle Marker Track key command.
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To open the Marker List as a tab in the Arrange window
µ Click the Lists button at the top-right corner of the Arrange toolbar, then click the Marker

tab (or use the Toggle Marker List key command, default assignment:  K).

To open the Marker List as a separate window
Do one of the following:

µ Choose Options > Marker > Open Marker List (or use the Open Marker List key command,
default assignment:  Option-M).

µ Drag the Marker tab, which changes to the Marker List window as you drag it.

To open the Marker Text window
Do one of the following:

µ Option-double-click any marker in the marker track with the Pointer tool. The clicked
marker is selected in the list.

µ Choose Options > Marker > Open Marker Text (or use the Open Marker Text key command,
default assignment:  Option-').

The Marker Text window is also available at the bottom of the Marker List window. It is
known as the Marker Text area in the Marker List window.

Tip: Many marker selection, editing, and other commands can be accessed by
Control-clicking (or right-clicking) anywhere in the marker areas. Make use of this technique
to accelerate your workflow. Note that the right-click shortcut menu can only be accessed
if the Right Mouse Button:  Opens Shortcut Menu pop-up menu option is chosen in the
Logic Pro > Preferences > General > Editing pane.

145Chapter 6 Working with Markers



Creating Markers
You can create markers at any project position. This section describes all marker creation
options.

Tip: You can use the Create Marker key commands to add markers on the fly during
playback.

To create a marker at the beginning of the nearest bar
Do one of the following:

µ In the Marker track:

• Set the playhead to the desired position, then click the Create button.

• Select the Pencil tool, and click the desired position.

µ In the Bar ruler:  Place the pointer over the lower part of the Bar ruler, and
Option-Command-click the desired project position. This only works if the Marker track
isn’t displayed.

µ In the Marker List:

• Choose Options > Create.

• Select the Pencil tool, and click in the Marker List.

• Click the Create button in the Marker List.
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µ In any window:  Choose Options > Marker > Create from the main menu bar (or use the
Create Marker key command, default assignment:  Shift-Command-').

The marker is created at the beginning of the nearest bar. If a marker already exists at a
bar position (or up to a quarter note before or after it), no new marker is created.

The length of the marker automatically extends to the start point of the next marker, or
to the end of the project or folder, if no ensuing markers exist.

To create a marker that is not rounded to the nearest bar
Do one of the following:

µ In any window:  Choose Options > Marker > Create Without Rounding (or use the Create
Marker without rounding key command, default assignment:  Command-').

µ In the Marker List:  Choose Options > Create Without Rounding.

To create a marker and determine its position
µ Click the beginning or end of the Marker List’s marker area with the Pencil tool, then

input the desired position in the position input field.

To create markers at the positions of all currently selected regions
Do one of the following:

µ In the Marker track:  Click the From Regions button, or drag a region from an arrange
track onto the Marker track.

µ Choose Options > Marker > Create by Regions from the main menu bar (or use the Create
Marker by Regions key command, default assignment:  Command-Up Arrow).
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Markers created in these ways are automatically assigned the names, bar position, length
and color of the regions they are derived from.

To create a marker that corresponds exactly to the length and position of a cycle
µ Drag the cycle down into the Marker track or into the lower third of the Bar ruler.

Dragging the cycle in the Bar ruler is limited to either horizontal or vertical movements.
This ensures that you do not accidentally:

• Move the cycle when creating markers (by dragging the cycle into the lower third of
the Bar ruler or into the Marker track).

• Create markers when moving the cycle area.

The following explains how marker movements and the cycle interact:

• When dragging the cycle to the marker area in the Bar ruler, the pointer turns into a
hand with up/down arrows. As soon as you move the pointer horizontally in the marker
area of the Bar ruler, the pointer becomes a hand (without arrows). The Copy Cycle to
Marker action is canceled.

• If you first move the cycle horizontally, and then try to drag it to the marker area of the
Bar ruler, no Marker is created.
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• When you hold Shift, after click-holding the cycle, the cycle can be moved horizontally,
and then dragged to the marker area in one go.

Note: When you hold Shift, before clicking the cycle, the nearest cycle border is set to the
clicked position.

Copying Markers
This section describes the copy marker options.

To copy a marker
Do one of the following:

µ In the Marker track:  Option-drag the marker, or use the standard Copy (Command-C) and
Paste (Command-V) commands.

µ In the Marker List:  Use the standard Copy and Paste commands.

Selecting Markers
You can use the usual selection techniques to select markers. For more information, see
Using Selection Techniques.

Deleting Markers
You can delete markers at any time. Once deleted, they no longer appear in the Bar ruler,
Marker track, Marker List, or Marker Text window.

To delete markers
Do one of the following:

µ In the Marker track or Marker List:

• Click the markers with the Eraser tool.

149Chapter 6 Working with Markers



• Select the markers, then choose Edit > Delete (or use the corresponding key command,
default assignment:  Delete).

µ In the Bar ruler:  Hold down Command, grab the marker you want to delete, and drag it
out of the Bar ruler. Release the mouse button when the pointer turns into a hand holding
two arrows.

µ At the current project position:  Choose Options > Marker > Delete (or use the Delete
Marker key command, default assignment:  Command-Down Arrow).

Naming Markers
Newly created markers are automatically named “Marker ##” (unless derived from regions,
as described above). The “##” indicates a numerical value that reflects the order of
appearance of the markers along the Bar ruler (resulting in “Marker 1,” “Marker 2,” and so
on). The allocated number is dependent on the actual order of all markers in the project,
including markers that have been renamed.

Automatically assigned names can be changed directly in the Bar ruler, Marker track,
Marker List, or in the Marker Text window.

The length of the name displayed in the Marker track, Bar ruler, and Marker List depends
on available screen space, or the position of the following marker.

If you want to edit a marker name when creating it, hold Control-Option-Command while
clicking the desired Marker track position. A text field opens, allowing you to type the
new name. Press Return to complete the naming operation. You can also
Control-Shift-Command-double-click the Bar ruler (if the Marker track isn’t visible).

To edit a marker name in the Bar ruler
1 Do one of the following:

• Choose Options > Marker > Rename Marker (or use the corresponding key command,
default assignment:  Command-Return).

• Option-double-click the marker.
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2 Type the marker name in the text field.

To edit a marker name in the Marker track
1 Do one of the following:

• Choose Options > Marker > Rename Marker (or use the corresponding key command,
default assignment:  Command-Return).

• Select the Text tool, then click a marker.

• Double-click the marker.

2 Type the marker name in the text field.

To edit a marker name in the Marker List
1 Do one of the following:

• Select the marker name and click the Marker Text Edit button.

• Select the marker name and double-click in the Marker Text area.

• Double-click the marker in the Marker Name column.
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2 Type the new marker name in the Marker Text area.

To edit a marker name in the Marker Text window
1 Open the marker in the Marker Text window.

2 Do one of the following:

• Click the Marker Text Edit button.

• Double-click in the Marker Text area.

3 Type the new marker name in the Marker Text area.

The first paragraph in the window is used as the marker name.
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Note: If you use Return to create paragraphs in the Marker Text window or area, the first
paragraph of the text is displayed in a separate title line (of the marker) in the Marker
track.

Unlike the marker display in the Bar ruler, all text below the first paragraph is also displayed
in the Marker track, depending on available space. (You might want to change the height
of the Marker track to view all text.) This can be used for musical or technical notes, for
example. In this scenario, the marker color is only shown in the title line, with the remaining
text displayed white on gray.

Changing the Appearance of Marker Text
You can change the appearance of marker text in the Marker Text window and area. You
can assign a different font, size, and style to any selected portion of the marker text. All
fonts installed on your system can be used. Different colors can be assigned to all, or
selected parts, of the text, and to the Marker Text window and area background.

To change the appearance of marker text
1 Select the marker text you want to change.

2 Click the Font button in the Marker Text window or Marker Text area of the Marker List
window.
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3 Choose settings in the Font window.

Editing Markers
Markers can be edited in various ways. Common tasks include changing marker positions,
coloring markers, and adjusting marker lengths.

To change the position of a marker
Do one of the following:

µ In the Marker track:  Drag it to the left or right.

µ In the Bar ruler:  Command-drag the marker to the left or right.

µ In the Marker List:  Use the mouse as a slider on the bar Position display, or double-click
a position value and enter the new value with the computer keyboard.

Note: The smallest movements that can be achieved in the Marker track and Bar ruler
depend on the division setting in Transport area, the Snap menu setting, and the horizontal
zoom level (including sample-accurate placement at the highest zoom levels). Watch the
help tag for precise feedback on movements. The alternative for fine position adjustments
is the Marker List.

There are times when you will want to protect markers from being moved. Logic Pro has
a feature that preserves the absolute time position of events.

To protect the position of selected markers
µ Choose Options > Lock SMPTE Position in the Marker List (or use the corresponding key

command).
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This locks (fixes) the SMPTE position of markers. To indicate this status, a lock symbol is
displayed at the beginning of the marker name.

These markers always retain their absolute time position:  if the project tempo is changed,
the bar positions will change to keep the markers at the same SMPTE positions.

Tip: You can also lock/unlock the SMPTE positions of markers from the Arrange area’s
Region menu, and the Functions menu of the Piano Roll Editor and Hyper Editor, if you
enable the display of global tracks.

To unprotect the position of selected markers
µ Choose Options > Unlock SMPTE Position in the Marker List (or use the corresponding

key command).

Note: You cannot unlock the SMPTE position of scene markers. See Working with Movie
Scene Markers.

To change the length of a marker
µ In the Marker track:  Place the pointer over the marker border. When the pointer changes

to a Resize pointer, drag the marker border to the new position.

µ In the Marker List:  Use the mouse as a slider on the bar Position display, or double-click
a position value and enter the new value with the computer keyboard.

The marker border can also be the beginning of the subsequent marker, especially if the
length of the second marker hasn’t been defined. Markers cannot overlap.
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To adjust a marker to fit a cycle
µ Drag a cycle onto an existing marker (with a right or left border—or both—that falls

inside the cycle boundaries).

Dragging the cycle area in the Bar ruler is limited to either horizontal or vertical
movements. This ensures that you do not accidentally:

• Move the cycle when creating markers (by dragging the cycle into the lower third of
the Bar ruler or into the Marker track).

• Create markers when moving the cycle.

Tip: When you hold Shift, after click-holding the cycle, the cycle can be moved horizontally,
and then dragged onto a marker in one go. When you hold Shift, before clicking the cycle,
the nearest cycle border is set to the clicked position.

To assign a color to a marker
µ Select a marker in the Marker track, choose View > Colors, then click a color in the palette.

If dark colors are used, the marker text is automatically shown in an inverse color. If you
create markers from regions, the corresponding marker uses the region color.

Navigating with Markers
You can navigate through your project with markers. This is useful when you want to
quickly jump to, and edit, regions or events at a specific project position, for example.

To move the playhead to a marker
Do one of the following:

µ In the Marker track:  Press Option and click the marker.

µ In the Bar ruler:  Press Command and click the marker.

µ In the Marker List:  Click a marker with the Finger tool.

Tip: If you press Option and click a marker in the Marker List with the Finger tool, the
locators are set to the beginning and end points of the selected marker.
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µ Use the Go to Marker Number 1 to 20 key commands (20 different commands).

The marker numbers in these commands refer to the (serial) order of all markers in the
project.

µ Use the Go to Marker key command to open a window that allows you to type in any
marker number.

This moves the playhead to the beginning of the chosen marker.

To move to the next or previous marker
µ Use the Go to Previous Marker and Go to Next Marker key commands.

The locators are set to the beginning and end points of the selected marker.

To start playback at a marker start position
Do one of the following:

µ In the Bar Ruler:  Command-double-click a marker.

µ In the Marker List:  Click-hold a marker with the Finger tool.

Logic Pro continues playing until the mouse button is released.

To create a cycle from a marker
Do one of the following:

µ Hold down Command, and drag the marker up into the top part of the Bar ruler.

This sets a cycle with the same position and length as the marker. If Logic Pro is stopped
when performing this action, the playhead is placed at the start point of the cycle.

µ Select the marker, then use one of the following key commands:

• Set Locators by Marker and Enable Cycle

• Set Locators by Previous Marker and Enable Cycle

• Set Locators by Next Marker and Enable Cycle
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Switching Between Marker Alternatives
You can use up to nine different marker variations per project.

To switch between the different marker alternatives
Do one of the following:

µ Choose Options > Marker Alternatives in the Marker List, then choose a Marker List.

µ Choose a number from the Alternative pop-up menu in the Marker List.

µ Choose a number from the Alternative pop-up menu in the Marker track.

Customizing the Marker Display in the Marker List
There are two display options for marker position and length in the Marker List:

• View > Event Position and Length in SMPTE Units: Switches the marker position and
length display between bar positions and SMPTE time positions.

• View > Length as Absolute Position: Switches the marker length display between actual
(relative) length and (absolute) display of the marker’s end position (shown as a bar
position).

Importing, Removing, and Exporting Marker Information
When you record or bounce an audio file, the current Marker List is added to the resulting
file. In some situations, you may want to import marker information from an audio file
that was recorded in a different project. This is possible within the borders of any selected
audio region of that file in the Arrange window.

To import marker information from an audio file
µ Choose Options > Marker > Import Marker from Audio File.

You can also export the current Marker List within the borders of any selected Arrange
audio region to an audio file. However, you should first remove any marker information
that exists in the audio file.

To remove marker information from an audio file
µ Choose Options > Marker > Remove Marker from Audio File.

Then you can export the current marker information to the audio file.

To export marker information to an audio file
µ Choose Options > Marker > Export Marker to Audio File.
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Logic Pro projects provide flexible options for storing and retrieving your music
productions. This chapter will provide you with information on all aspects of creating and
handling Logic Pro projects.

This chapter covers the following:

• Learning About Projects (p. 159)

• Creating Projects (p. 160)

• Opening Projects (p. 163)

• Opening and Creating Projects Automatically (p. 166)

• Previewing Projects with Quick Look (p. 166)

• Importing Data and Settings from Other Projects (p. 167)

• Checking and Repairing Projects (p. 174)

• Setting Project Properties (p. 175)

• Managing Projects (p. 183)

• Saving Projects (p. 186)

• Closing and Quitting (p. 189)

Learning About Projects
Logic Pro requires a project to be opened or created before you can begin working. This
is similar to using a word-processing application, which requires a document to be opened
before you can begin typing. Logic Pro, like word processors, also allows you to have
multiple documents (projects) open simultaneously.

A project file is the main Logic Pro document type. It contains all MIDI events and
parameter settings (apart from the preferences and key commands) plus information
about the audio and video files to be played. It is important to note that a project file
points to your audio and video files, which are stored as separate entities on your hard
disk. The audio and video files are not saved with the project.
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When you create a new project (or use the Save function, in general), you can choose to
also save all associated files (assets).

Logic Pro creates a project folder that contains the project file, along with separate folders
for files used in the project (audio files and so on).

Saving projects without assets minimizes the memory requirements for project storage,
allowing you to transport them easily to other Logic-based studios—either physically or
as email attachments. This also means that the project will not be able to load the
referenced audio and video files when moved, unless these other file types are also moved
(the project is saved with its assets, in other words).

Project folders help you to keep track of your work:  they ensure that all files related to a
particular project are neatly saved in one location. This makes it easy to back up and
transfer projects between computers or disks, and helps to avoid embarrassing problems
such as missing audio files, or samples that you need to search for, or reconstruct, in the
studio.

Creating Projects
You start working in Logic Pro by creating a new project.

To create a project
1 Choose File > New (or use the corresponding key command, default

assignment:  Command-N).
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2 Choose a template in the Templates dialog.

The Templates dialog is broken down into two areas:  Collection and Template.

• Click a collection folder to display the associated template in the Template area.

• Click a template to load it. A Save As dialog opens automatically.
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3 Browse to the location where you want to store the project, then type a name for the
project in the name field.

4 Select the Include Assets checkbox if you want to include the audio and other files in the
project folder. (See Handling Project Assets.)

Tip: It is recommended that you select the Include Assets checkbox, as this makes the
project “safe,” allowing you to move or copy the project folder without losing any file
references that point to items within the folder.
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5 Click the Advanced Options disclosure triangle to view and choose the file types you
want to save in the project folder.

You can change these settings at any time by choosing File > Project Settings > Assets.
Details on these project assets are found in Handling Project Assets.

6 Click Save.

• A named folder—containing several sub-folders, depending on selections made in
steps 3 and 4—is created at the target location.

• By default, an Audio Files sub-folder is created within the project folder, even if you
have not selected the Include Assets checkbox. This folder is used for any new audio
recordings.

• Also by default, the audio recording path is automatically routed to the new
Project/Audio Files sub-folder.

If you decide not to create a project folder in the first instance but want to at a later stage,
simply choose the Save As command.

Tip: You can quickly create an empty default project by holding down Option while
choosing File > New.

Opening Projects
Logic Pro requires a project to be opened before you can begin working.

A project can also consist of data created in other applications, including songs from
earlier versions of Logic Pro or Final Cut Pro XML files, for example.

To open an existing project
1 Choose File > Open (or use the corresponding key command, default

assignment:  Command-O).
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If a project is already loaded, you are asked if the currently loaded project should be
closed or not. You can disable this prompt by deselecting the Logic Pro > Preferences >
General > Project Handling > “When opening a project, ask to ‘Close current project(s)?’”
option.

The Open dialog features a File Type pop-up menu, which allows you to choose from the
following options:

• All Logic Document Types: Displays all document types supported by Logic Pro.

• Logic Projects: Projects created with current or earlier Logic versions.

• GarageBand Projects: Projects created in GarageBand.

• Notator SL Songs: Songs created in C-Lab/Emagic Notator or Creator SL.

• MIDI Files: Standard MIDI files in either format 0 or 1.

• OMF Interchange Files: Open Media Framework files used by other DAW applications
such as Pro Tools.

• AAF Files: Advanced Authoring Format used by other DAW applications such as Pro Tools.

• OpenTL Files: OpenTL (Open Track List) files used in devices such as Tascam hard disk
recorders.

• XML (Final Cut Pro): An open source standard, supported by Final Cut Pro and
Soundtrack Pro.

For more information about the individual file types, see Project and File Interchange.

2 To limit your view to certain file types, choose a file type in the File Type pop-up menu.
Choose All Logic Document Types to see, and access, all supported file types.
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3 Browse to and select the file, then click Open.

To open a recent project
µ Choose the project name directly from the File > Open Recent menu.

This bypasses the Open dialog. You can clear all items in the Open Recent menu by
choosing Clear Menu.

Tip: If you set the Startup Action in the Project Handling preferences to the Open Most
Recent Project option, Logic Pro loads your last project automatically on startup. See
Opening and Creating Projects Automatically.

Opening Projects Using Drag and Drop
Projects and Standard MIDI files can be opened by dragging them from the Finder into
the Arrange area. The mouse pointer position—when the mouse button is
released—determines the placement of the imported file.

This includes the position (rounded to the nearest bar) and destination of the first track.
For more information about Standard MIDI files, see Working with Standard MIDI Files.

You can also open a Logic Pro project or MIDI file by dragging it onto the Logic Pro icon
in the Dock.

Opening Projects from Earlier Logic Pro Versions
You can open Logic Pro 5, Logic Pro 6, Logic Pro 7, and Logic Pro 8 projects in Logic Pro 9.
When loading a project created in an earlier version of Logic Pro, the format is converted
to the version 9 format.

You may find some changes to your channel strip output routing when you open a project
that was created in an earlier version of Logic Pro. For full details about channel strip
output routing, see Defining a Channel Strip’s Stereo Output.

Important: Projects saved in Logic Pro 9 are not backward-compatible with earlier Logic Pro
versions.

Switching Between Multiple Projects
You can open several projects simultaneously, allowing you to copy or move data between
them, or to compare different versions of one project.

To switch between projects
µ Choose the project name at the bottom of the Window menu—the active project is

marked with a tick.
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Opening and Creating Projects Automatically
You can configure Logic Pro to open or create projects automatically on startup by
choosing a startup action in the Logic Pro > Preferences > General > Project Handling
pane.

• Do Nothing: Logic Pro opens and requires you to create a new project, or open an
existing project or template.

• Open Most Recent Project: Opens the project you were working on when you last closed
Logic Pro.

• Open Existing Project: Shows the Open dialog, allowing you to browse for an existing
project.

• Create New Project from Template: Opens the Templates dialog.

• Create New Empty Project: Loads an empty project and opens the New Tracks dialog,
allowing you to specify the number and type of new tracks to be created.

Note: You can also use the New Empty Project key command.

• Create New Project Using Default Template: Opens the default template and the Save
As dialog, allowing you to name and save your project.

To determine the default template
1 Click the Choose button below the Default Template field in the Project Handling

preferences pane.

2 Browse to and choose a template (or project).

The full path and name of the chosen template or project is displayed in the Default
Template field. You can assign any template or project as the default template.

Previewing Projects with Quick Look
Logic Pro saves a thumbnail image with every project. This allows you to view the contents
of a project using Quick Look, without having to open the project. The image is saved
each time the project is saved.

166 Chapter 7 Working with Projects



To preview a project with Quick Look
Do one of the following:

µ Browse to a project file in the Finder, then click the Quick Look button.

µ Browse to a project file in the Browser tab of the Media area, then choose Quick Look in
the Actions menu.

µ Browse to a project file in the Browser tab of the Media area, Control-click (or right-click)
the file, then choose Quick Look from the shortcut menu.

A thumbnail image of the selected project file is displayed in Quick Look.

Importing Data and Settings from Other Projects
You can import the following data from another project:

• Track region or folder content

• Plug-ins (including settings)

• Sends (including level, routing, and destination channel strips)

• Input/Output assignments

• Automation data

• Track notes

For details, see Importing Data from Another Project.
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You can also import the following settings from another project:

• Screensets

• Transform sets

• Hyper sets

• Score sets

• Score staff styles

• Score text styles

• Score settings

• Sync settings

• Metronome settings

• Record settings

• Tuning settings

• Audio settings

• MIDI settings

• Video settings

• Asset settings

For details, see Importing Settings from Another Project.

Importing Data from Another Project
You have two options when importing data from another project:

• You can import the data to new tracks in your current project.

• You can replace data in your current project with the imported data.

168 Chapter 7 Working with Projects



You choose the data to be imported from the source project using the following Track
Import view, which is displayed in the Media Browser tab.

169Chapter 7 Working with Projects



Tip: You can customize the column view by Control-clicking (or right-clicking) the table
header, then disabling or enabling the columns. You can also change the column order
by dragging the column headers. These settings are automatically stored in the Preferences
when Logic Pro is closed, and apply to all projects.

• Num: Displays the track number for all tracks available in the Arrange area. Remains
empty for those channel strips that are not part of the Arrange track list. Folder tracks
are also displayed with an entry such as 3-1, where 3 is the track number and 1 is the
folder number. You can double-click a folder track to reveal its contents at the next
level. Note that take folder tracks behave like ordinary tracks, and they are imported
as they are, with all takes and comps.

• Name: Displays the track or channel strip name as defined in the source project.

• Type: Displays the track or channel strip type.

• Content: Allows you to import the region or folder contents of a track. In the case of
folder tracks, you can double-click a folder to access its individual tracks.

• Plug-ins: Allows you to import any plug-ins, and their settings, inserted in a channel
strip. The plug-ins are listed according to insertion order, from the top down.

Note: In the case of software instrument channel strips, instrument plug-ins are also
imported.

• Sends: Allows you to import any sends inserted in a channel strip, including level,
routing, and all destination channel strips.

• I/O: Allows you to import the I/O settings of a channel strip.

Note: In the case of software instrument channel strips, this does not include the
instrument plug-in. See the Plug-ins entry above.

• Auto: Allows you to import track automation data.

• Notes: Allows you to import track-specific notes.

• Global, Audio, Inst, Aux, I/O, MIDI: Click these filter buttons to hide or show the track or
channel strip types shown in the track import table.

To import data from another project
1 Do one of the following:

• Click the Browser tab in the Media area.

• Choose File > Import (or use the corresponding key command, default
assignment:  Command-I).
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2 Navigate to, and select, the required project file.

• If using the Browser tab, an Import button appears at the bottom-right corner of the
tab.

Note: You can use the Quick Look feature to preview the selected project file. For
details, see Previewing Projects with Quick Look.

• If using the Import dialog, the Import button becomes active.

3 Click the Import button, or double-click the project file.
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The Browser tab updates to show a track import view.

4 Select the data that you want to import by selecting the relevant checkboxes.

Tip: Press the Right Arrow key to select all checkboxes of the selected line, or the Left
Arrow key to deselect them.
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5 Do one of the following:

• Click the Add button to add the selected data to the current project (or hold down the
Command key while pressing the Down Arrow key).

The tracks are added below the selected track in the Arrange area.

• Click the Replace button to replace the data of the currently selected track with the
selected data from the other project.

Note: The Replace function only works when data on a single row is selected—not
with multiple row selections.

Importing Settings from Another Project
The following image provides an overview of the settings that can be imported from one
project to another.

There are a number of different ways to import settings from other projects.

To import settings from another project
1 Do one of the following:

• Choose File > Project Settings > Import Project Settings (or use the corresponding key
command, default assignment:  Option-Command-I).
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• Click the Settings button in the Arrange toolbar, then choose Import Project Settings.

• Click the Browser tab in the Media area.

2 Navigate to, and select, the required project file.

Note: If navigating in the Browser tab, you can use the Quick Look feature to preview
the selected project file. For details, see Previewing Projects with Quick Look.

3 Click the Import button.

Note: If accessing the settings from the Browser tab, you also need to click the Import
Project Settings button, which appears after you click the Import button.

4 In the Import Settings window, select the settings you want to import by selecting the
relevant checkboxes.

5 Click the Import button.

The settings are imported into the active project.

Checking and Repairing Projects
On occasion, you may need to know how many regions are in a project, how much
memory is being used, and so on. This data is available in the Project Information window.
Very rarely, a project may become corrupted due to driver or memory conflicts, or may
feel sluggish. Should any corruptions occur, a warning message advises you of the
existence and nature of the problem. These problems can generally be rectified in the
Project Information window.

To open the Project Information window
µ Choose Options > Project Information from the main menu bar.

The Project Information window also provides the Reorganize Memory function which
allows you to increase the amount of free memory, and to rectify a number of potential
project corruptions or problems.
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To reconfigure the memory
µ Click the Reorganize Memory button in the Project Information window.

At the same time, the current project is checked for any signs of damage, structural
problems, and unused blocks.

If any unused blocks are found—which normally shouldn’t happen—you will be able to
remove these, and repair the project.

Note: This reorganization is also carried out automatically after saving or loading a project.
A common (and good) use of this feature is to free up memory after closing a project, if
two or more projects were open prior to the close operation.

Setting Project Properties
Following the creation of a project, a number of project properties should be checked,
and changed if necessary. This is a great working practice as it will limit any morning-after
corrections that will need to be made later, such as sample rate conversions on a hundred
or more audio files. This section outlines the project properties that you should take into
consideration before beginning any work.

Setting the Sample Rate
The project’s sample rate determines the number of samples Logic Pro uses for audio
playback. When you add or record audio files to your project, the sample rate of these
files is automatically matched to the project sample rate.

Important: The “Convert audio file sample rate when importing” project setting must be
active for automatic sample rate matching. You can turn on this setting in the File >
Projects Settings > Assets pane.

To set the project sample rate
Do one of the following:

µ Choose File > Project Settings > Audio (or use the Open Audio Project Settings key
command), then choose the a sample rate from the Sample Rate menu.
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µ Click the Sample Rate display in the Transport bar, then choose a sample rate from the
pop-up menu.

Note: If your Transport bar does not include the Sample Rate display, Control-click it and
choose Customize Transport Bar from the shortcut menu. Select the Sample Rate or Punch
Locators checkbox in the Customize Transport Bar dialog.

You may find that audio files in your project do not match the newly selected sample
rate. The playback of files that do not match the project’s sample rate is slower (file’s
sample rate is higher) or faster (file’s sample rate is lower) than it should be.

To match a file’s sample rate with the project sample rate
µ Use the Audio Bin’s Copy/Convert File(s) command (which is also available by

Control-clicking the Audio Bin or using the corresponding key command), then replace
the file in the project.

Logic Pro performs a real-time, native sample rate conversion. Any sample rate available
in Logic Pro (via Audio > Sample Rate) can be used for the conversion—even if your audio
hardware does not support the selected sample rate.

The native software sample rate conversion function matches the sample rate of any
audio hardware, thereby allowing the playback of projects on virtually any audio system,
even if the hardware is—in sample rate terms—not compatible. Nothing is lost in the
process. Any internal processing and bouncing is always performed at the original sample
rate, and at the highest quality, even in cases where the hardware does not support a
particular sample rate. This feature allows you to work on projects originally created on
high-end audio systems, with lower-end setups.

For example, imagine a project was created with audio hardware set to operate at 96 kHz.
Moving this project to a notebook computer, or setup that does not support the original
project’s sample rate, will commonly result in the wrong playback speed. The native
real-time sample rate conversion function will counteract this effect, allowing correct
playback of the project on the portable computer, at any sample rate.

Note: High sample rates not only use up disk drive space, but also result in a higher
processing load.

Setting the Project Tempo
You can set the basic project tempo in the Transport bar, the Tempo track, or the Tempo
List. Logic Pro displays tempo as quarter notes per minute, or beats per minute (bpm). It
ranges from 5 to 990 bpm, and is adjustable to four decimal places after the whole value.
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To set the project tempo
Do one of the following:

µ In the Transport bar, do one of the following:

• Click-hold the tempo value, and drag up or down.

• Double-click the tempo value, and type a new value in the text field.

µ In the Tempo List, do one of the following:

• Click-hold the tempo value, and drag up or down.

• Double-click the tempo value, and type a new value in the text field.

µ Open the Tempo track, and drag the tempo line up or down with the Pointer tool.

For more information about advanced tempo operations, see Advanced Tempo Operations.

Setting the Project Time Signature
The time signature defines how many beats a bar contains in the Bar ruler and what note
value constitutes one beat.
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Time signatures do not affect the playback of your project, but determine the editing
grid in the Arrange area and MIDI editors as you can see in the following images. Both
show the same MIDI region, with the first at a time signature of 2/8, and the second at
6/8.
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You can set the time signature of the project in the Transport bar, the Signature List, or
the Signature track. The Transport bar displays the time signature in the following
format:  numerator :  bar denominator :  division value.

Bar denominatorNumerator

Division value

The division value defines the division in all position displays (such as in the event editors),
and forms the grid for various length and placement operations. The division value is
normally set to 1/16 notes, but has a value range of 1/4 to 1/192 note. If the note value
of the division is equal to or greater than the bar denominator, the third value of the
position display is automatically removed.

Tip: You can use the Set Next Higher/Lower Division key command to switch to the next
highest or lowest division.

The tempo indicator in the Transport window always relates to quarter notes, even if
eighth notes are chosen as the denominator for the time signature.

To change the time signature
Do one of the following:

µ In the Transport bar:

• Click-hold either of the time signature values, and drag up or down.

• Double-click the numbers in the field, and type a new value in the text field.

µ In the Signature List:

• Click-hold the time signature value, and drag up or down.

• Double-click the time signature value, and type a new value in the text field.

179Chapter 7 Working with Projects



µ Open the Signature track, and double-click the value shown. Set the Numerator and
Denominator values (and other settings, if desired).

For more information on time signatures, refer to Working with Time and Key Signatures.

Setting the Start and End Points of a Project
A project normally starts at position 1 1 1 1. You can move the project start point to an
earlier position, allowing upbeats or program change commands to be played before the
first downbeat.

To define a project’s start point
µ Drag the project start marker in the Bar ruler to the left or right.

To define a project’s end point
Do one of the following:

µ Drag the project end marker in the Bar ruler to the left or right.
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µ Set the value in the Transport bar’s numerical Project End display (by click-dragging or
double-clicking the value).

Project End display

Note: If your Transport bar does not include the Project End display, Control-click it and
choose Customize Transport Bar in the shortcut menu. Select the Tempo/Project End
checkbox in the Customize Transport Bar pane.

As soon as Logic Pro reaches the project end point, it stops automatically, except when
recording. In this situation, the project end point is automatically moved to the end of
the recording.

Setting the Basic Project Playback Volume
You can set the basic project playback volume by dragging the Master Volume slider
found at the right of the Transport bar. This slider is directly tied to the Master channel
strip in the Mixer, and acts as a master volume control for all audio and software instrument
tracks.

Important: This slider not only sets the playback volume of your project, but also affects
the overall volume of your mix.

Click the Reset Master Volume button to the right of the Master Volume slider to set the
slider to 0 dB.
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Click the Dim Master Volume button to the left of the Master Volume slider, or the Dim
button in the Master channel strip, to turn on Dim Volume mode. This sets the playback
volume to the Dim value set in the Logic Pro > Preferences > Audio > General pane.

Click the button again to deactivate Dim Volume mode, and set the playback volume to
the current Master Volume slider, or Master channel strip, value.

Adjusting Project Settings
The project settings encompass a number of options that can have a dramatic impact
on the behavior of Logic Pro. Project settings are saved independently with each project,
which means that different projects can have different project settings. You can change
project settings at any time, but it is generally best if you start off with the required
settings, as this will make your workflow smoother.

To open the project settings
Do one of the following:

µ Choose an item from the File > Project > Settings (Synchronization, MIDI, Score, and so
on) menu (or use the corresponding key command).

µ Click the Settings button in the Arrange toolbar, then choose a menu item.

Detailed information on all project settings can be found in Project Settings in Logic Pro.

Handling Project Assets
The project settings also include an Assets pane. If you saved your project with its assets,
you can use this pane to determine how files imported from external locations (locations
outside the project folder) should be handled.

To open the Assets project settings
Do one of the following:

µ Choose File > Project Settings > Assets (or use the Open Assets Project Settings key
command).
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µ Click the Settings button in the Arrange toolbar, then choose Assets from the pop-up
menu.

• Select any of the copy checkboxes to copy the respective file types into the project
folder.

• Select the “Convert audio file sample rate when importing” checkbox to automatically
convert the sample rate of all imported files (with a different sample rate) to match the
project sample rate.

• If you deselect the “Copy EXS samples to project folder” option, only EXS instrument
files are copied to the project folder when saving, not the samples associated with the
EXS instrument files.

Files are only copied into the project folder when the project is saved.

Once saved, the project is “safe,” allowing you to move or copy the entire project folder
without losing any references that point to files within the folder.

Managing Projects
This section outlines some housekeeping activities that may be required to keep your
projects in order.

Copying or Moving a Project Folder
A project folder can be copied or moved to another location by using any of the standard
operating system methods. This is great for the archiving and transport of projects to
other studios or facilities.
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The following should be taken into account when copying or moving project folders:

• When a project is saved with Include Assets selected, and the recording path is pointing
to a location inside the project folder, the recording path is relative. This means that
the recording path for the audio data moves with the project, making it possible to
move the project folder in the Finder or use the Save As command.

• When manually setting a recording path (File > Project Settings > Recording >
Core Audio Recording Folder) outside the current project folder, the recording path is
absolute. This means that the recording path for the audio data always remains the
same, even after using the Save As command to save as a new project or when moving
the project file in the Finder. This is important if you prefer to record all audio data into
a single location outside the project folder.

Cleaning Up Projects
If there are any unused project files in your project folder, make use of the File > Project
> Clean Up command. If any unused files are found, the following dialog is displayed:

Select the checkboxes in the first column to choose files for removal. The name and path
of the file to be deleted is shown in the last two columns.

Only files with active checkboxes in the first column are deleted. All unselected entries
remain as they are.

If multiple rows are selected, a click in any checkbox switches all selected rows to the
new state (either selected or unselected).

Note: The Clean Up command only deletes unused files (all types, except movie files).
Clean Up takes into account the project currently loaded, and all other Logic Pro project
files in the project folder. Only files that are not used by any of these projects are displayed
in the Clean Up list.

Consolidating Project Settings
If your project contains files that are not in the correct sub-folders within the project
folder, you can use the Consolidate command to automatically organize them into the
standardized project file structure.
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To consolidate your project
1 Choose File > Project > Consolidate (or use the Consolidate Project key command).

2 Choose a menu option for the different file types in the Consolidate dialog, to either
move, leave, or copy the existing files.

The two buttons in the lower-left corner of the window make project consolidation quick
and easy.

• Click “Copy all” to set all menus to the Copy option.

• Click “Move all” to set all menus to the Move option.

3 Select the “Delete empty folders after moving” checkbox to remove the empty folders in
the source project, after files have been moved to the target project.

4 Select the “Create folders for audio file groups” checkbox to create group folders within
the Audio Files sub-folder of the target project.

The groups must first be created in the Audio Bin of the source project. See Grouping
Files in the Audio Bin.

5 Click OK when you’re done.

ReCycle Import Handling in Projects
EXS instruments created via a ReCycle import are placed in a Sampler Instruments/ReCycle
sub-folder of the project folder. All audio data generated by a ReCycle import is placed
in the ReCycle Audio folder, alongside the project file.

Note: This happens automatically and can’t be changed. If no project folder exists, ReCycle
files are saved in ~/Music/Logic/ReCycle Audio.
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Saving Projects
When you choose File > Save (or use the corresponding key command, default
assignment:  Command-S), the current project is saved with its current name intact.

If you don’t want to overwrite the most recent version of the project file saved with this
name (which will happen if you use File > Save or Command-S), make use of the File >
Save As or File > Save a Copy As commands. In the dialog that appears, you can enter a
new name for the project, set assets, and select a new directory or even create a new
folder.

• File > Save As: The next time you save using the straight Save (Command-S) command,
the new filename and path are used. If you use this command to save your project to
a new location (outside the current project folder) and select the Include Assets
checkbox, the new project folder will contain all audio files used in the “old” project’s
Arrange area.

• File > Save a Copy As: The next time you save with the straight Save (Command-S)
command, the existing filename and path continue to be used. The copy is a replica
of the existing project, stored in a different location. It does not update the file save
path. Save a Copy As is ideal for archiving and moving data.

Automatic Backup Files
When you save a project, Logic Pro automatically saves up to one hundred backup copies
in the project folder’s Project File Backups folder. The backup files are named after the
project file, with the number (00, 01, 02, and so on) appended to the project name.
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You can define the number of project backups you want to keep by changing the Auto
Backup setting in the Logic Pro > Preferences > General > Project Handling pane.

Your choices are:

• Off

• Last Project Version

• Last 3 Project Versions

• Last 5 Project Versions

• Last 10 Project Versions

• Last 30 Project Versions

• Last 50 Project Versions

• Last 100 Project Versions

Reverting to the Saved Version
Any time you make a mistake, you can undo it by choosing Edit > Undo (or use the
corresponding key command, default assignment:  Command-Z).

If you have made some really serious blunders (as unlikely as that may be), or you decide
that in the 15 minutes since you last saved, your creative efforts have resulted in material
too unpleasant to describe politely, you may find the File > Revert to Saved function (or
the corresponding key command) very helpful. This replaces the current project with the
previously saved version.
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Saving a Project as a Template
You can save a project as a template, creating starting points for new projects. Not all
projects have the same needs, so customizing several projects to meet these needs offers
an ideal starting point for different jobs. For example:

• A template that is software instrument–focussed, for dance music projects. This would
feature 32 software instrument tracks, and maybe 8 audio tracks.

• An audio track–centric template, featuring 64 audio tracks, would be ideal for live
recording.

• A specific live performance template that makes the job of quickly switching between
parts faster, or perhaps makes heavy use of Environment processing.

• Several scoring templates for choirs, a rock band, symphony orchestra, string quartet,
jazz combo, and so on.

• A template containing modified synchronization settings for control of ADAT hardware.

• A template for video work. This would typically contain a video track plus specific
dialogue, Foley, and music tracks.

• A second video template could be used for jobs where the video is running on an
external videotape machine that is synchronized with Logic Pro via SMPTE.

Screensets can be customized for each template, or you can make use of the various
Import Settings commands to copy them between templates. For details, see Importing
Settings from Another Project.

To save a project as a template
µ Choose File > Save as Template (or use the corresponding key command), then type in

a name.

The project is saved in the ~/Library/Application Support/Logic/Project Templates folder.
The next time you open the Templates dialog, you will see your template in the My
Templates collection, below the factory template collections.

You can create collections under My Templates by creating sub-folders in the
~/Library/Application Support/Logic/Project Templates folder. This can be done in the
Finder, or with the Create Folder button in the Save As Template dialog. When all user
templates are placed in sub-folders, the sub-folder names are shown below the factory
collections.

Tip: You can add descriptive text to your templates by adding a comment to the project
file in the Finder. The Templates dialog displays the icon assigned to a template file,
making it easy for you to change a template’s icon. For more information on how to add
a comment to a file, or change the icon of a file, see Mac Help.
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Closing and Quitting
The following tasks describe how to close an open window, an active project, or the entire
Logic Pro application.

To close an open window
µ Choose File > Close (or use the corresponding key command, default

assignment:  Command-W).

Only the uppermost window closes, not the whole project. The project is only properly
closed when all windows are closed.

To close the currently active project
µ Choose File > Close Project (or use the corresponding key command, default

assignment:  Option-Command-W).

If you have made any changes since the last Save operation, Logic Pro prompts you to
save the project before closing, to preserve any changes you have made.

Important: The Close Project without Saving key command closes the currently active
project without saving it—and you will not be asked to do so. This command was included
at the request of many experienced Logic Pro users. Only use it if you’re sure that this is
what you want to do.

To quit the application
µ Choose Logic Pro > Quit Logic Pro (or use the corresponding key command, default

assignment:  Command-Q).

If you’ve made changes, but haven’t saved them, you are asked if you want to do so
before quitting (press Return to save).

If multiple projects are open, you are asked if you want to review any changes, or simply
close and discard any changes.
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There are a number of techniques to choose from when making selections and editing
items in Logic Pro. In this chapter, you’ll learn about basic operating, selection, and editing
techniques, as well as a number of shortcuts and features that help to accelerate your
workflow.

This chapter covers the following:

• Using the Mouse (p. 191)

• Entering Numerical Values (p. 192)

• Entering Text (p. 193)

• Working with Key Commands (p. 194)

• Working with Tools (p. 202)

• Working with Help Tags (p. 209)

• Using the Shortcut Menu (p. 210)

• Using Selection Techniques (p. 211)

• Working with the Clipboard (p. 216)

• Undoing and Redoing Edit Operations (p. 217)

Using the Mouse
Mouse use in Logic Pro differs from mouse use in other applications.

Clicking
Place the mouse pointer on the element (region, event, button, menu, input field, and
so on) and press the mouse button once.

Double-Clicking
The same as clicking an element, but you press the mouse button twice—in quick
succession. You can set a suitable interval between clicks in the System Preferences
(Keyboard & Mouse pane).
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Grabbing or Clicking and Holding
The same as clicking an element, but you keep the mouse button held down.

Moving or Dragging
Grab the element and move the mouse (keeping the mouse button held down) to the
desired position.

Right-Clicking
The same as clicking, but you press the right mouse button, if available. This opens a
shortcut menu, the Tool menu, or selects an assigned tool.

Modifier-Clicking or Dragging
Many commands, functions, additional tools, or finer adjustments are accessed by holding
down a modifier key—Control, Shift, Option, or Command—while clicking or dragging.
For example, Option-dragging a region copies it. Option-clicking a fader or knob resets
it to its default, or centered, value.

Mouse Wheel Events
You can use the mouse wheel to scroll vertically in Logic Pro. There are also some modifiers
supported:

• If you press Command, the mouse wheel scrolls horizontally.

• If you press Option, the mouse wheel zooms in or out vertically.

• If you press Option-Command, the mouse wheel zooms in or out horizontally.

• If you press Option-Control, the mouse wheel zooms in or out in both directions.

Note: Logic Pro also supports mice that feature an x and y axis on one scroll wheel (such
as the Apple Mighty Mouse). On a 2-axis mouse, the Command modifier (that switches
a single-axis mouse between horizontal and vertical orientation) is not used.

Mouse as a Slider
You can set most numerical parameters (even note values or names) by grabbing the
parameter value, and moving the mouse up or down. If the parameter consists of several
separate numbers (project position, for example), you can adjust each number individually
using this method.

Entering Numerical Values
You can use numerical input in many areas of Logic Pro. Double-clicking a numerical
parameter value opens an input field. The existing value is highlighted, and ready to be
overwritten by a new entry. This method is ideal for quickly setting a parameter value in
the Inspector, or instantly navigating to a bar, when used in the Transport bar.

To quickly navigate to a bar, using numerical input in the Transport bar
1 Double-click the Position display in the Transport bar.
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2 Type in 45, followed by the Return key.

The playhead moves to the beginning of bar 45.

You can also use the mouse to make a partial selection in an input field, so that only the
highlighted part is overwritten. As long as the input field is open, the computer keyboard
can only be used for data entry, and cannot be used for key commands (with the exception
of the main menu functions).

Discrete Values
Using numerical input, you can type in:

• Decimals: 1, 01, 2, 3, 4, 127, …

• Hexadecimals: $1, $01, $2, $3, $A, $0A, $7F

• Notes: “C3,” “C#3,” “Cb3,” “C##2” (equivalent to D2), “Dbb2” (equivalent to C2). If you
double-click the note “E3,” you can enter a decimal value such as “64” or a hex value
of “$40” instead of the note name.

• ASCII Code: You can also input numbers as ASCII code:  just place a ` or " in front of the
selected key, and the ASCII code is input as a number. For example, "! results in a value
of 33; "a results in a value of 97. This function is particularly useful for entering text in
SysEx strings.

Arithmetical Operations
In many parts of Logic Pro, mathematical operations can also be used to change values.
For example:

• You can subtract from the existing value by entering “−5.”

• You can sum two values by entering “38+17.”

• You can multiply two values by entering “7*8.”

• You can divide two values by entering “80/5.”

Canceling Numerical Input
You can cancel numerical input by entering no text at all, and pressing the Return key.

Entering Text
You can input text names in the same way as numbers, but you only need to click a name
field once to allow input. You can directly click a region (or Mixer channel strip) with the
Text tool to rename it.
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Any number of selected objects (such as regions) can be assigned the same name. If the
name ends with a number, this number is automatically incremented by 1 for each
subsequent object. This allows you to quickly, and uniquely, name all of the regions on
a track, for example.

Note: To turn off automatic numbering, place a space after the number at the end of the
name you type in. All selected objects will then end with the same number. This may be
useful for identifying all main vocal regions recorded in another session, for example
(rename to “mainvox 030707,” followed by the space, to identify the regions by date).

Working with Key Commands
You can execute nearly every Logic Pro function with a key command or MIDI message.
Whenever this documentation mentions a key command, this refers to a function,
command, or option that can be accessed by either a computer keyboard keystroke (or
keystroke combination—such as Option-R—which opens the Recording project settings)
or a MIDI message.

Use of key commands, rather than the mouse, can greatly accelerate your workflow.
Throughout this documentation, you will encounter many practical usage examples,
often in step form, that include the default key command assignments for particular
functions.

Tip: It is recommended that you use these default key commands while getting to know
the application. Not only will this help you to remember them, but will also aid in
developing good (and faster) working practices from the outset.

Once you have a good understanding of Logic Pro fundamentals, and how you like to
work, you can freely assign your own key command set for functions that you use most
often.

Note: A number of functions are only available as key commands. Some of these may
not have a default key command assignment. In such cases, you will need to create a
suitable key command, in order to make use of the function.

Getting to Know the Key Commands Window
You will use the Key Commands window to assign Logic Pro functions to computer
keyboard keys or MIDI messages. This allows you to completely customize the application
to suit your working style.

To open the Key Commands window
Do one of the following:

µ Choose Logic Pro > Preferences > Key Commands (or use the Open Key Commands key
command, default assignment:  Option-K).
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µ Click the Preferences button in the Arrange toolbar, then choose Key Commands from
the shortcut menu.

Tip: Holding down Control while choosing a command in a menu opens the Key
Commands window, with the respective command selected. This also works with shortcut
menus.

Key combination area

Search fieldKey Commands list

Learn buttons

Learn button
Delete assignment 
button

Assignments area

Delete button

Key and Assignment 
columns

• Key Commands list: Lists all available key commands. The bullet indicates key commands
that are not available as menu items.

• Key and Assignment columns: Show the currently assigned key, and MIDI message (if
applicable).

• Search field: Use this to find key commands by name or partial name.

• Key combination area: Displays the key combination associated with the selected key
command. Note that this area, along with the modifier checkboxes, is always dimmed.
These fields are display-only fields and cannot be edited directly. Use the Learn buttons
when you need to change a key command assignment.

• Assignments area: Displays the control surface assignment associated with the selected
command.

• Learn buttons: Use these to teach Logic Pro to use a particular key, or key combination,
to perform a function.

• Delete buttons: Use these to delete the key assignment of the selected command, or
to delete the selected assignment.
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Understanding Key Command Groups and Hierarchies
The global key commands are always functional, regardless of the currently active window.
Non-global commands require the corresponding window to have key focus (in the
foreground, or on top of other windows). This allows you to assign the same key command
(or combination of keys) to different functions in different windows.

Important: There is a hierarchy of key command classes, which are not merely separated
into global and local key commands. For example, there is a key command class that
applies to all windows that display regions. This class has higher priority than global key
commands, but a lower priority than local window (Arrange, Score, Piano Roll, and so on)
key commands.

Choosing Key Command Sets
The Options menu offers commands that allow you to switch between key command
sets, or import and export them. This is particularly useful if you need to work temporarily
on another user’s Logic Pro system; you can use your personal key assignments, without
altering the settings of the other system.

• Options > Preset menu: Displays all key command sets saved in the ~/Library/Application
Support/Logic/Key Commands folder, allowing you to quickly switch between key
command sets.

• Options > Import Key Commands: Opens a dialog, allowing you to import key command
sets from any folder location. The existing file (on the target system) is automatically
saved as a *.bak file. This file contains the old key commands. You don’t need to restart
Logic Pro to begin using the new key command set.

• Options > Export Key Commands: Opens a dialog, allowing you to save the current key
command assignments to any location. It is important to carry out this command
whenever you make changes to your personal key command set. For further details,
see Saving Key Command Sets.

Saving Key Command Sets
When you save key commands, your user key assignment sets are stored in a separate
file located in ~/Library/Application Support/Logic/Key Commands.

To save a key command set
1 Choose Options > Export Key Commands in the Key Commands window.

A dialog opens, pointing to the default folder location:  ~/Library/Application
Support/Logic/Key Commands.

Note: It is also possible to save the key command set to another location by browsing
to it.

2 Do one of the following:

• Overwrite an existing key command set: Select the file, then click the Save button.

196 Chapter 8 Basic Operations



• Save a new key command set: Enter a new filename in the Save As field, then click the
Save button.

Note: All key command sets are available from the Options > Presets menu, if you saved
them to the default location.

Saving key commands is also recommended for backup purposes. Following are some
recommendations for when you might want to do this:

• Export your user key command set (using the above procedure) whenever you make
changes to it. Changes to key commands are not automatically saved to the selected
key command set.

• Make a backup of your user key command set at another hard disk location before
changing any key commands.

• Make a backup on removable media (a CD-ROM or USB flash drive, for example), or on
a networked Mac (using Bonjour) or a MobileMe account (see Sharing Logic Pro Data
over a Network). These backup options make it easy to transfer your key commands
when using Logic Pro on another computer.

Whenever you install Logic Pro updates, your personal key commands remain unaltered.

Note: Almost all key commands are user-definable. Some of the default assignments for
standard commands such as Undo, Save, Quit, New, Open, Cut, Copy, and Paste follow
Mac OS X conventions, and probably shouldn’t be altered. Some keys are “hard-wired”
to specific functions or commands, and cannot be changed. These are dimmed in the
key command listing, to indicate this fixed status.

Browsing Key Commands
Key commands are grouped in various categories. You can extend or collapse groups by
clicking the respective disclosure triangle.

The Options > Expand All command displays the contents all key command groups.
Options > Collapse All hides the contents of all key command groups.

When you expand key command groups, your key command selection may no longer
be visible. You can quickly return to the selected key command by choosing Options >
Scroll to Selection. When the list has key focus, you can use a key command (or key
command combination) to select the associated function in the list.
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Finding Key Commands
You can use the Key Command window’s search field to find key commands by name or
partial name:

• The search is performed as you enter text. There is no need to press the Return key,
unless you want to retain a history of key command searches.

• The Cancel button to the right (that appears as soon as any text is entered) clears any
entered text, and displays all key commands.

• The Search menu to the left (the magnifying glass) retains a history of recently used
search terms. The Clear menu item erases the Find history.

Note: The Find history is limited to searches that were completed by pressing the Return
key.

Using Special Keys in Key Commands
Some keys have special functions:

• The Shift, Control, Option, and Command modifier keys can only be used in conjunction
with other keys.

• The Delete key has the fixed “delete selected objects” function. It can only be assigned
to another function in conjunction with the modifier keys.

• The key combinations assigned to the commands in the main menu bar can be
reassigned, but it is generally recommended that you leave them at their defaults. The
key command assignment is displayed after the main menu items. For example,
Command-1 opens the Arrange window, Shift-L locks the current screenset.

• The Plus and Minus keys are assigned to the Increase/Decrease Last Parameter by 1
key commands. As the name suggests, this will increase or decrease any selected
parameter value in single units.

• Using Shift in conjunction with the Plus and Minus keys accesses the Increase/Decrease
Last Parameter by 10 key commands.
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Assigning Key Commands to Computer Keys
This section shows you how you assign particular computer keyboard keys to Logic Pro
functions.

To assign a function to a key
1 Select a command in the Command column.

2 Click the Learn by Key Label button.

3 Press the desired key, along with the desired modifier key or keys (Shift, Control, Option,
or Command).

4 If you want to make another assignment, repeat steps 1 to 3.

5 Click the Learn by Key Label button again.

The Learn by Key Position function works in the same way, but differs in that it’s not just
a reference to an ASCII code that is stored, but the actual scan code of the key that is
pressed.

In practice, this means that you can, for example, assign different commands to the
number keys on the numeric keypad and the number keys above the keyboard.

This also means that the key position remains the same if you switch between different
operating system language settings, or different keyboards. For example, using a scan
code for a function assigned to the Y key on an English keyboard would function in the
same way if you switched to a German keyboard—which has a Z key in the same position
as the Y key on an English keyboard.

The only disadvantage is that the key code (a number), rather than the ASCII symbol, is
displayed in the Key Commands window. The ASCII symbol is more useful for reference
purposes.

To clarify the difference between these two functions, here’s a short comparison:

• If you use the Learn by Key Label function, and define only one key command for the
key, it will be used, no matter which of the two keys (either number 7 key, for example)
is pressed.
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• If you use the Learn by Key Position function, and define two key commands (one for
the alphanumeric keyboard, one for the numeric keypad), then the appropriate key
command will be used (one for each number 7 key, for example).

In circumstances where an existing local key command combination is used, when
assigning a new global key command, a warning message appears. This warning message
explains where the existing local key command combination is used and whether it has
a higher or lower priority than the one you are trying to assign. You have the following
options:

• Cancel: Press this button if you do not want to alter existing assignments.

• Replace: Press this button if you want to replace the existing shortcut (assigned to the
chosen key command combination) with the selected function.

• OK: Press this button if you want to assign the key command combination to the
selected function, while retaining the existing key command or function.

To delete key assignments
1 Select the relevant command (with a key assignment that you want to delete).

2 Do one of the following:

• Click the Learn by Key Label or Learn by Key Position button, then press Delete.

• Click the Delete button.

The key assignment of the selected command is deleted.

3 To erase more assignments, repeat the first and second steps.

4 Click the Learn by Key Label or Learn by Key Position button again (if you activated them).

Assigning Key Commands to Control Surfaces
The Learn New Assignment button allows you to assign control surface messages to
particular commands—effectively teaching Logic Pro to understand these messages.

To learn a controller assignment
1 Click the Learn New Assignment button.

2 Select the command in the Command column.

3 Send the desired MIDI message from your controller.
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The Assignments field displays the learned assignment. This may show one or all of the
following:

• The name of the control surface—or the MIDI string, if the assignment is from an
unsupported control surface.

• The name of the control.

• The zone and mode that the assignment belongs to, if applicable.

Note: The Learn New Assignment button is automatically turned off when the entire
message has been received. This avoids reception of further messages (that may be) sent
by the device when you release the button. To ensure reliable reception, hold the button
for a short period before releasing it.

4 If you want to make another assignment, repeat steps 2 and 3.

If you want to assign functions—other than key commands—to a control surface, you
use the Controller Assignments window. Open this window by double-clicking a row in
the assignment section, or by choosing Logic Pro > Preferences > Control Surfaces >
Learn Assignment for “destination parameter” from the main menu bar (or use the Open
Controller Assignments key command, default assignment:  Command-K). For details, see
the Logic Pro Control Surfaces Support manual.

Initializing Key Command Assignments
You can reset all key commands to their default assignments. You will lose your existing
key command assignments, so make sure that you have created a copy of your key
commands file before doing so.

To initialize all key command assignments
µ Choose Options > Initialize all Key Commands in the Key Commands window.
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Printing a Key Command List
You can use the Options > Copy Key Commands to Clipboard function to copy your key
command assignments into the Clipboard as text. From here, it’s a simple matter of
pasting the results into any word processor, formatting as desired, and printing them.

The Copy to Clipboard command only copies the currently visible key command
assignments. You could, therefore, export a certain group of key commands (those
containing a particular character string, for example). What you see in the window display
is exactly what’s exported.

The Copy to Clipboard 
command only copies the 
currently visible key 
command assignments 
into the Clipboard.

Working with Tools
Each working area in Logic Pro provides its own set of tools, suitable for the tasks
performed in that area. Each toolset, therefore, is only effective in the working area in
which it is located.

A tool (the Scissors, for example) basically affects the regions or events that you click. If
multiple regions are selected, they are all affected by the tool (the Scissors would cut all
selected regions at the same playhead position).
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Tools are accessed in the Tool menus, found in the upper-right corner of all windows that
allow direct region, event, or file editing and handling operations.

Assigning the Left-Click and Command-Click Tools
You can freely assign tools to the Left-click and Command-click Tool menus. The mouse
pointer adopts the shape of the active tool, allowing you to instantly identify it by looking
at the pointer graphic.

Left-click Tool menu Command-click Tool menu

The Command-click Tool menu is located on the right, by default, but is located in the
middle when a third (Right-click) tool is assigned. For full details about the Right-click
tool, see Assigning the Right Mouse Button.

To assign the Left-click tool
µ Click the Left-click Tool menu to open it, then choose a tool.

The Left-click tool is available when the left mouse button is pressed while editing.

To assign the Command-click tool
µ Click the Command-click Tool menu, then choose a tool.
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The Command-click tool is available when the Command key is pressed while editing.
Release the Command key to revert to the Left-click tool.

Assigning the Right Mouse Button
If you have a suitable mouse, you can also assign the right mouse button to any of the
following:

• A third tool (Right-click tool)

• Tool menu

• Shortcut menu (default setting)

To set the behavior of the right mouse button
1 Open General preferences by doing one of the following:

• Choose Logic Pro > Preferences > General (or use the corresponding key command).

• Click the Preferences button in the Arrange toolbar, then choose General from the
pop-up menu.

2 Click the Editing tab, then choose a setting from the Right Mouse Button pop-up menu.

• Is Assignable to a Tool: When this option is chosen, a third Tool menu (Right-click Tool
menu) appears to the right of the Left-click and Command-click Tool menus. Choose
the appropriate menu item to assign the tool, which is available when the right mouse
button is pressed while editing.

 Left-click Tool menu

Command-click Tool menu

Right-click Tool menu
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• Opens Tool Menu: Right-clicking in the working area of the active window opens the
Tool menu with the Pointer tool (and not the currently selected tool) located under
the mouse pointer position. Choose a tool by clicking it. When the Tool menu is open,
you can also use the key shown next to a tool to select it.

Note: When you choose a tool from the Tool menu by right-clicking, the tool is assigned
to the left mouse button. Right-double-clicking in the working area of the active window
resets the assigned tool to the Pointer tool.
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• Opens Shortcut Menu: Right-clicking in the working area of the active window displays
a menu that offers a number of area-specific selection and editing commands. See
Using the Shortcut Menu for details.

Setting the Pointer Tool Behavior
You can set two different behaviors for the Pointer tool when using it in the Arrange
window.

To set the behavior of the Pointer tool in the Arrange window
1 Open General preferences by doing one of the following:

• Choose Logic Pro > Preferences > General (or use the corresponding key command).

• Click the Preferences button in the Arrange toolbar, then choose General from the
pop-up menu.

2 Click the Editing tab, then select the checkboxes of the required Pointer Tool in Arrange
settings.

• Fade Tool Click Zones: When this checkbox is selected, placing the mouse pointer over
the upper-left and upper-right edges of a region activates the Fade cursor and behavior.
The Loop cursor and behavior can still be accessed in these click zones by holding
down Option.
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• Marquee Tool Click Zones: When this checkbox is selected, placing the mouse pointer
over the lower half of a region (with the exception of the lower-left and lower-right
edges) activates the Marquee cursor and behavior.

Using Key Commands to Select Tools
You can also use the following key commands to select tools:

• Set Next Tool and Set Previous Tool: Switch to the neighboring tool in the active window.

• Show Tool menu: Open the Tool menu at the pointer position. When the Tool menu is
open, you can also use one of the number keys shown next to a tool to select it (default
key command assignment:  Esc).

• Set X tool (where X refers to the tool): You can select each tool via a specific key command.
Key commands assigned to a specific tool switch between this tool and the previously
selected tool.

Learning About Common Tools
The following section describes the most common tools available in Logic Pro. Tools that
are specific to particular editing windows are covered in the respective chapters.

Pointer Tool
The Pointer is the default tool when Logic Pro is first opened. The mouse pointer also
takes on this shape outside the working area, when making a menu selection or entering
a value.
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Within the working area, you can use the Pointer tool for:

• Selecting individual or multiple events, regions, or other elements by clicking them.
See Using Selection Techniques.

• Moving (by grabbing and dragging).

• Copying (by Option-dragging).

• Changing lengths (by grabbing the bottom-right or bottom-left corner and dragging).

• Looping regions (by grabbing the upper-right corner and dragging).

Pencil Tool
The Pencil tool is used to add new regions or events. You can also select, drag, loop
regions, and alter the length of regions or events while the Pencil tool is active.

Eraser Tool
The Eraser tool deletes selected regions or events. When you click a region or event with
the Eraser, all of the currently selected regions or events are deleted (as if you had used
Delete). The Eraser can also delete an unselected region or event by clicking it.

Text Tool
The Text tool is used to name regions, or add text to a musical score.

Scissors Tool
The Scissors tool is used to split regions and events, allowing individual sections to be
copied, moved, or deleted.

Glue Tool
The Glue tool performs the reverse operation of the Scissors tool. All selected regions or
events are merged into a single region or event.

Solo Tool
Click-holding a region with the Solo tool allows you to listen to the selected region or
event in isolation. Moving the mouse horizontally also outputs (scrubs) any events the
pointer touches.

Mute Tool
Clicking an event or region with the Mute tool prevents it from playing. You can unmute
the region or event by clicking it a second time with the Mute tool. If multiple regions or
events are selected, the mute state of the clicked region or event applies to all selected
regions or events.

Zoom Tool
The Zoom tool allows you to zoom (up to the full window size) by dragging to select a
specific region. You can revert to the normal zoom level by clicking the window
background with this tool. You can also access the Zoom function—even when other
tools are active—by holding down Control-Option.
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Flex Tool
The Flex tool provides you with quick access to fundamental flex editing functionality,
without having to turn on Flex view in the Arrange window.

Working with Help Tags
A help tag appears just below the mouse pointer position—for as long as the mouse
button is held down—when using many of the tools. The help tag provides useful feedback
on the operation you are performing.

Note: You must turn on the Logic Pro > Preferences > Display > General > Show Help
Tags option in order to view help tags during edit operations.

During operations involving regions, the help tag looks something like this:

From left to right (and from top to bottom), the values indicate:

• Name of the operation

• Mouse (or region) position

• Region/event name

• Track number

• Length of the region

During operations involving events, the help tag looks something like this:
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From left to right, the values indicate:

• Name of the operation

• Mouse (or event) position

• Event type

• Event MIDI channel

• First data byte (note pitch, for example)

• Second data byte (note velocity, for example)

• Event length (note length, for example)

Using the Shortcut Menu
Control-clicking anywhere in the Arrange window, Piano Roll Editor, and all List Editors,
opens a shortcut menu (also known as a contextual menu) that can be used for a number
of selection and editing tasks.

The shortcut menus differ between (and within) windows, based on both the selection
status of events or regions within the window, and also the type of information that the
editor deals with.

The items that appear in the menu update to reflect the current context. For example, in
the Arrange area:

• With no regions or no selected regions in the Arrange window:  A number of Select
and Paste commands, plus Scroll in Play are available.

• With one or more regions selected in the Arrange window:  Cut, Copy, and Delete,
Nudge, Lock/Unlock SMPTE Position and Region Name and Color commands become
available.

Note: You can always access a shortcut menu with a Control-click, but you can also make
use of the right mouse button to open it. To do so, make sure that the Right Mouse
Button:  Opens Shortcut Menu pop-up menu item is chosen in the Logic Pro > Preferences
> General > Editing pane.
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Using Selection Techniques
Whenever you want to perform an operation on one or more regions or events (or other
elements, such as Mixer channel strips), you first need to select them. Selected elements,
regions, or events are displayed in an inverted color scheme with a highlighted name, or
in a user-assigned selection color.

A region or event selected in one window is also selected in all other windows that display
that region or event. For example, a note event selected in the Piano Roll Editor is also
selected in the Score Editor and Event List. The region that contains the selected event
is also selected in the Arrange area.

Changing the window with key focus doesn’t affect the selection (as long as you don’t
click the window background, which deselects everything). Be sure to click window title
bars when switching between windows.

Tip: Don’t forget about the Zoom functions when making your selections, as high zoom
levels can make precise selections much simpler.

Selecting Individual Elements
You can select individual regions or events (or other elements, such as Mixer channel
strips) by clicking them with the Pointer tool.

You can deselect them by clicking the window background, or by selecting another
region, event, or element.

The Select Next Region/Event, or Set Marquee End to Next Transient key command (default
assignment:  Right Arrow key) and the Select Previous Region/Event, or Set Marquee End
to Previous Transient key command (default assignment:  Left Arrow key) provide a quick
way to step between (and individually select) regions or events.

In the Arrange area, pressing any letter key selects the first region with a name that begins
with the chosen letter (as in the Finder), provided that no key command is assigned to
the key.
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Selecting Multiple Elements
You will often need to select multiple regions, events, or other elements, in order to move,
process, or copy them, for example.

To select or deselect all elements in a window
Do one of the following:

µ Choose Edit > Select All (or use the corresponding key command, default
assignment:  Command-A).

µ Choose Edit > Deselect All (or use the corresponding key command, default
assignment:  Shift-Command-A).

Note: When a marquee selection is active, using this key command deselects all current
selections, including the marquee selection.

To select several consecutive elements in a window
µ Click the background and drag over them.

All elements touched, or enclosed, by the selection rectangle (shaded area) are selected.

To select several noncontiguous elements in a window
µ Shift-click them, one-by-one.

As subsequent elements are selected, the previous selections are retained.

Making Horizontal Selections
Horizontal selections can be made in a number of editing windows, allowing you to
quickly select all elements that are horizontally aligned on a lane.

Note: When a marquee selection is active, using this key command extends the marquee
selection—over all tracks within a marquee selection—to the project end point.

To select all regions on a track in the Arrange area
Do one of the following:

µ Click the track name in the track list.

µ Choose Edit > Select All Following of Same Track (or use the corresponding key command).
All regions following (after) the selected region are selected.
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To select all events (of a specified event definition) in the Hyper Editor
Do one of the following:

µ Click the event definition name.

µ Choose Edit > Select All Following of Same Track (or use the Select All Following of Same
Track/Pitch key command, default assignment:  Option-Shift-F). All events after the selected
event are selected.

To select all notes of a certain pitch in the Piano Roll Editor
Do one of the following:

µ Click the relevant key on the Piano Roll keyboard.

µ Choose Edit > Select All Following of Same Track (or use the Select All Following of Same
Track/Pitch key command, default assignment:  Option-Shift-F).

Important: The selection techniques covered above only affect regions or events that
fall within the cycle area defined in the Bar ruler, when Cycle mode is on.

Switching the Selection Status of Elements
When you make any selection (by dragging or horizontal selection) while holding down
the Shift key, the active selection status of the elements is reversed.

You can also reverse the selection status of all elements by using Edit > Invert Selection
(or use the corresponding key command, default assignment:  Shift-I).

For example, if you want to select all regions in a project, with the exception of a few,
you can first select the regions that you do not want to choose, and then use the Invert
Selection command.
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Selecting Following Regions or Events
To select all regions or events that follow the currently selected region or event (or, if
none are currently selected, to select all regions or events after the playhead position),
choose Edit > Select All Following (or use the corresponding key command, default
assignment:  Shift-F).

Note: When a marquee selection is active, using this key command extends the marquee
selection—over all tracks within a marquee selection—to the project end point.

To add the following region or event to your selection
µ Use the Toggle Next Region/Event, or Set Marquee Start to Next Transient key command

(default assignment:  Shift-Right Arrow).

To add the previous region or event to your selection
µ Use the Toggle Previous Region/Event, or Set Marquee Start to Previous Transient key

command (default assignment:  Shift-Left Arrow).

Selecting Regions or Events Within the Locators
Choose Edit > Select Inside Locators (or use the corresponding key command, default
assignment:  Shift-L) to select all regions or events lying wholly, or partly, inside the locator
positions.

Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.

Edit > Deselect Outside Locators (or the corresponding key command) deselects all regions
or events outside the locators. Region or event selections within the locator boundaries
are unchanged.

Note: When a marquee selection is active, using this key command removes the portion
of the marquee selection that does not fall within the locators.

Selecting Specific Regions and Events
You can use the following commands to select regions or events that match a specific
condition, or have a particular characteristic.

• Edit > Select Empty Regions: Use to select all empty regions (or use the corresponding
key command, default assignment:  Shift-U).

• Edit > Select Overlapped Regions: Use to select all overlapping regions or events (or use
the Select Overlapped Regions/Events key command).

• Edit > Select Muted Regions: Use to select all muted regions or events (or use the Select
Muted Regions/Events key command, default assignment:  Shift-M).
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• Edit > Select Equal Colored Regions: If you have selected a region or event of a certain
color, you can use this command to select all regions or events of the same color (or
use the Select Equal Colored Regions/Events key command, default assignment:  Shift-C).
This is a useful option when replacing song sections and other group editing tasks.

• “Deselect All Regions except on selected Track” key command: Deselects any regions not
on the currently selected track. This command is especially handy when used after
other special selection commands—limiting the effects of ensuing commands to the
recording track.

Selecting Similar or Identical Objects, Regions, or Events
If you have selected an Environment object, region, or event, you can use the Edit > Select
Similar Regions function to select all similar objects, regions, or events (or use the Select
Similar Regions/Events key command, default assignment:  Shift-S).

You can use the Edit > Select Equal Regions function to select all identical regions, events,
or objects (or use the Select Equal Regions/Events key command, default
assignment:  Shift-E).

The table outlines the differences between similar and identical (equal) objects.

IdenticalSimilarElement

• MIDI regions:  Identical
content and size

• Audio region:  All regions of
the same length and position

Region type (audio or MIDI)Region

Controller number and data byte
(control value) equal

Controller number equal, any
data byte (control value)

Controller events

Note and octave equalNote equal, any octaveNote event

Same fader type (for example
text)

Same object type (for example
fader)

Environment object

Selecting Events with the Same MIDI Channel
Following selection of an event, you can select all other events that share the same MIDI
channel by using the Edit > Select Equal Channels function (or use the corresponding
key command, default assignment:  Shift-H).

For example, imagine you’re editing a MIDI region that contains volume and pan controller
information for 16 MIDI channels.

To select all events on channels 1 and 3
1 Shift-select one event on channel 1 and another event on channel 3.

2 Choose Edit > Select Equal Channels (or use the corresponding key command, default
assignment:  Shift-H).
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All other events on these two channels are selected.

Selecting Regions or Events with an Equal Subposition
You can select all regions and events with a certain relative position, such as all snare
drums on the off-beat. Select a region or event at the desired relative position, and choose
Edit > Select Equal Subpositions (or use the corresponding key command, default
assignment:  Shift-P). All regions or events with the same relative position are selected.

Accelerating Edit Operations with Selection Commands
There are many different ways to make selections, based on different criteria. These can
be used to speed up many editing operations, in conjunction with key commands. Here
are a few examples:

If you want to delete all similar regions, events, or objects, make your selection and use
the Delete Similar Regions/Events key command.

Conversely, if you want to keep all similar regions, events, or objects, and delete all others,
use the Delete but Keep Similar Regions/Events key command.

You can use the Event Channel +1 key command or the Event Channel −1 key commands
to alter the channel number of the selected event (or events) by one, making it easy to
reassign it or them to another MIDI channel.

Working with the Clipboard
The Clipboard is an invisible area of memory into which you can copy selected information
(such as regions or events), allowing them to be pasted to a different location.

The Clipboard is universal, which means that it can be used to exchange information
between projects.

All of the following options are available in the Edit menu.

Cut
All selected elements are removed from their current position, and placed in the Clipboard.
Any existing content in the Clipboard is overwritten in the process (default key command
assignment:  Command-X).

Copy
A copy of all selected elements is placed in the Clipboard. The selected elements are left
in place. As with Cut, the contents of the Clipboard are overwritten (default key command
assignment:  Command-C).

Paste
All content from the Clipboard is copied into the window with key focus. The Clipboard
contents are not erased in the process (default key command assignment:  Command-V).
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Paste at Original Position
This command works in a similar way to Paste, but the regions or events in the Clipboard
are always pasted to the position they were originally cut from, regardless of the current
playhead position (which is where regions or events would be placed with the standard
Paste function).

Paste Replace
This function only works in the Arrange window and editors. It resembles Paste, but all
existing regions or events in a given location are replaced by the regions or events being
pasted.

Warning: When using this function, all regions or events that lie within the time period
occupied by the regions or events on the Clipboard are erased.

Undoing and Redoing Edit Operations
A simple change of mind or editing mistake is an inevitable part of music production.
Fortunately, you can backtrack your edits easily in Logic Pro by using the Undo command
to reverse your previous edit operation.

To undo your last step
µ Choose Edit > Undo (or use the corresponding key command, default

assignment:  Command-Z) immediately after making the error.

Virtually all edits, including moves, deletions, renaming, parameter changes, creation of
new events, regions, or channel strips, and more, can be undone.

The Number of Undo Steps setting in the Logic Pro > Preferences > General > Editing
pane determines the maximum number of possible undo steps.
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To open the Undo History window
µ Choose Edit > Undo History (or use the corresponding key command, default

assignment:  Option-Z).

The Undo History window shows you a list of all actions that can be undone. The most
recent step (editing operation), which will be the first to be undone, is selected.

To undo or redo multiple steps
µ Click any entry to undo or redo all steps between the clicked and highlighted entries.

To undo or redo an isolated step
µ Command-click the step.

This will undo or redo an isolated step without influencing all steps between the clicked
and highlighted entries.
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To erase the Undo History
µ Choose Edit > Delete Undo History.

Warning: Take care with this command. No undos or redos are possible for the deleted
steps, once the Undo History has been erased.
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Tracks contain the audio regions and MIDI regions of a project. This chapter provides
information on all aspects of creating and handling tracks in Logic Pro.

This chapter covers the following:

• Understanding Tracks and Channel Strips (p. 222)

• Configuring the Track Header (p. 224)

• Reclaiming Workspace Used by the Track Header (p. 226)

• Creating Tracks and Channel Strips (p. 227)

• Creating Tracks Only (p. 232)

• Deleting Tracks in the Arrange Area (p. 234)

• Selecting Tracks in the Arrange Area (p. 235)

• Rearranging Tracks in the Arrange Area (p. 235)

• Naming Tracks in the Arrange Area (p. 236)

• Assigning Tracks in the Arrange Area (p. 239)

• Zooming Tracks in the Arrange Area (p. 240)

• Assigning Track Icons in the Track Parameter Box (p. 242)

• Muting Tracks in the Arrange Area (p. 243)

• Soloing Tracks in the Arrange Area (p. 245)

• Record-Enabling Tracks in the Arrange Area (p. 246)

• Freezing Tracks in the Arrange Area (p. 246)

• Hiding Tracks in the Arrange Area (p. 250)

• Protecting Tracks in the Arrange Area (p. 251)

• Using Track Button Slide Activation (p. 252)

• Drum Replacement or Doubling in the Arrange Area (p. 252)

• Bouncing Regions and Tracks in Place (p. 255)
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Understanding Tracks and Channel Strips
Tracks are listed from top to bottom in the Arrange track list and extend horizontally
across the Arrange area in lanes.

Each track is assigned to a particular channel strip in the Mixer. In other words, the output
of a track is sent to a channel strip. If a track is not sent to a channel strip, regions on it
will not be heard.

Note: The exception to this rule is folder tracks. For more information, see Working with
Folders.

Once assigned to a particular channel strip type in the Mixer, the behavior of the track is
limited as follows:

Track used forAssigned to MixerTrack type

Playback, recording, and automation of audio
regions.

Audio channel stripsAudio

Playback, recording, and automation of MIDI data
sent to software instruments.

Instrument channel
strips

Instrument

Playback, recording, and automation of MIDI data
sent to external MIDI devices.

MIDI channel stripsMIDI

222 Chapter 9 Working with Tracks



Track used forAssigned to MixerTrack type

Used as lanes for folder regions. Folder regions
are simply containers for other regions and are
not assigned to a Mixer channel strip.

Not assignedFolder

As you can see, each track type handles different sorts of data and has a special purpose.
This is due to the routing of each track to a specific channel strip type in the Mixer.

The parameters of a track are displayed in the Inspector’s Track Parameter box.

Track Parameter box

Important: The parameters belong to the channel strip (or object) the track is routed to,
not to the track per se, so if you alter the parameters in the Track Parameter box, all tracks
assigned to this channel strip are affected.

Most of the functions described in this chapter are identical for external MIDI, software
instrument, and audio tracks.

In addition to these track types, there are also tracks with very specific functions, such as
global tracks. Global tracks—found at the top of linear editing windows—are used to
view and edit global events, such as tempo, which affect all tracks in the arrangement.
For information about these tracks, see Global Tracks.
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Configuring the Track Header
The track header of each track (shown in the Arrange area’s track list) displays a number
of buttons beside the track name and icon. By default, these include the Record Enable,
Mute, and Solo buttons on all tracks; audio tracks also display the Input Monitoring button.

Node button

Record Enable button
Solo button
Mute button

Track Color barInput Monitoring button

Freeze button Protect button

You can use the shortcut menu to show or hide these buttons, or you can use the Track
Header Configuration dialog to show or hide these buttons, along with other track header
elements.

To configure the track header using the shortcut menu
µ Control-click (or right-click) any track header in the track list, then choose the options

you want from the shortcut menu.

To configure the track header using the Track Header Configuration dialog
1 Open the Track Header Configuration dialog by doing one of the following:

• Choose View > Configure Track Header in the Arrange area (or use the corresponding
key command).

• Control-click (or right-click) any track header in the track list, then choose Configure
Track Header from the shortcut menu.

2 Select the track header elements you want in the Track Header Configuration dialog.

3 Click Done.
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The Track Header Configuration dialog offers the following elements:

• Control Surface Bars checkbox: Select this checkbox to view the control surface bars in
the track header. These bars indicate tracks that are accessed by control surfaces
connected to your system. Each control surface can be assigned a different color in the
Device Parameter box. For more information, see the Logic Pro Control Surfaces Support
manual.

• Track Numbers/Level Meters checkbox: Select this checkbox to display a track’s number.
During playback, a small level meter replaces the track number. For external MIDI or
software instrument tracks, this meter indicates the velocity of the recording, and turns
red to denote a maximum velocity value. For audio tracks, the level meter denotes the
output level.

• Track Icons checkbox: Select to display or hide the track icons in the track header.

• Allow Large Icons: Select to display large track icons in the track header when you
increase the vertical zoom of the Arrange area.

• Names section: Use the pop-up menus in this section to determine the names displayed
in the track header. For more information, see Naming Tracks in the Arrange Area.
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• Buttons section: Select the checkboxes of the buttons you want to display in the track
header.

• Track Color Bars checkbox: Select this checkbox to show a thin color strip at the right
edge of each track. This is a visual aid that can help you to keep track of regions that
have been moved between tracks.

Reclaiming Workspace Used by the Track Header
Displaying all of the buttons, icons, track names, and so on can result in a lot of information
being shown in the track header.

To see all of this information, you can resize the track list.

To resize the track list
1 Position the pointer over the dividing line between the track list and the composition

area.

2 When the pointer changes to the Resize pointer, drag the line to the right (increasing the
size of the track list area) or to the left (reducing the size of the track list area).

Resize pointer

The downside of increasing the size of the track list area is that it reduces your working
space in the Arrange window and editors.

To reclaim a little more room to move, you can hide the entire Inspector area to the left
of the Arrange window and editors, providing more workspace for regions, events, and
other data.
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To hide or show the Inspector in the Arrange window
Do one of the following:

µ Choose View > Inspector (or use the Hide/Show Inspector key command, default
assignment:  I).

µ Click the Inspector button in the Arrange toolbar.

Creating Tracks and Channel Strips
If you want to record or play back MIDI, software instrument, or audio data in Logic Pro,
you must first create a track. Corresponding channel strips are automatically created in
the Mixer.

If channel strips of a particular type (audio channel strips, for example) already exist in
the Mixer, newly created tracks are assigned to those matching channel strips.

Important: Some of the track creation options create new channel strips, and others do
not. Each is used for a different type of task. These commands are separated by a line in
the Track menu of the application.

To explain a little further:

• Suppose you create 8 new audio tracks in the Arrange area of a project that has 24
audio channel strips already set up in the Mixer. These new audio tracks are assigned
to audio channel strips 1 to 8 in the Mixer. You create 16 more audio tracks as your
project develops. These are assigned to audio channel strips 9 to 24 in the Mixer.

• If there are no, or not enough, channel strips of the matching type in the Mixer, they
are automatically created when you create new tracks. For example, suppose you need
a further 8 audio tracks to complete your project, but have used all 24 Mixer audio
channel strips. Simply create the extra 8 audio tracks, and Logic Pro automatically
generates the corresponding audio channel strips in the Mixer. These tracks (25 to 32)
are automatically assigned to audio channel strips 25 to 32.

The automatic creation of corresponding channel strips applies to all track types, up to
the maximum allowable number of channel strips. This restriction is in the hundreds for
audio and instrument channel strips, and in the thousands for MIDI channel strips. Your
computer is likely to run out of processing power well before you reach this limit for each
channel strip type.

Tip: Given the simplicity and speed of creating new channel strips—by creating
tracks—there’s no need to create hundreds of channel strips of each type in the Mixer
before you start making music.
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To create one or more new tracks (and channel strips)
1 Do one of the following:

• Choose Track > New in the Arrange area’s local menu bar (or use the New Tracks key
command, default assignment:  Option-Command-N).

• Click the Create Track button above the track list in the Arrange area.

2 In the New Tracks dialog, enter the number of tracks you want to create, then choose
the type.

3 Select the Open Library checkbox (if not already selected) to automatically open the
Library tab in the Media area. This allows you to immediately select settings for your
chosen track type.

4 Click Create.

The new track is created at the currently selected track position, and all ensuing tracks
(below it) are moved down the track list.

Tip: By double-clicking the empty space below the track header of the last track, you can
quickly create a new track matching the type chosen in the New Tracks dialog.
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Using the New Tracks Dialog
The options in the New Tracks dialog vary, depending on the type of track that is being
generated.

Audio Tracks
You can modify the following parameters in the New Tracks dialog when creating new
audio tracks:

• Driver pop-up menu: This pop-up menu allows you to select the audio hardware driver
to use for your newly created tracks. If you use only one hardware playback device, this
pop-up menu won’t appear.

• Format pop-up menu: Choose Mono, Stereo, or Surround in this pop-up menu, to create
multiple mono, stereo, or surround audio tracks.

• Input pop-up menu: Choose the input or input pair. Choose Surround if you want to
record in one of the available surround formats.

• Ascending checkbox: Select this checkbox to assign these inputs—in order, from lowest
to highest—to each track, when multiple tracks are created. This option has no effect
when a single track is created. If you create more tracks than you have inputs—creating
8 tracks, when using a 4-input device, for example—tracks 1 and 5 are assigned to
Input 1, tracks 2 and 6 are assigned to Input 2, tracks 3 and 7 are assigned to Input 3,
and tracks 4 and 8 are assigned to Input 4.

• Output pop-up menu: Choose the output or output pair. Choose Surround if you want
to set the output to the project’s surround format.

• Input Monitoring and Record Enable checkboxes: Select to turn on the track’s Input
Monitoring and Record Enable buttons. This is handy if you intend to start recording
immediately after creating the track.

• Open Library checkbox: Select to automatically open the Library tab in the Media area.
This allows you to immediately select settings for your chosen track type.
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Software Instrument Tracks
You can modify the following parameters in the New Tracks dialog when creating new
software instrument tracks:

• Multi-timbral checkbox: Select to create up to 16 tracks with ascending MIDI channel
settings (starting from MIDI channel 1, on the first track, MIDI channel 2 on the second
track, and so on).

• These tracks are independent of the first track, and can be individually automated,
have different regions, and so on, but all tracks are associated with (and routed
through) the same instrument channel strip in the Mixer.

• As such, the software instrument inserted into the instrument channel strip must be
multi-timbral (capable of playing different sounds on different MIDI channels) for
this option to be useful. None of the included Logic Pro instruments are multi-timbral.

• Output pop-up menu: Choose the output or output pair. Choose Surround if you want
to set the output to the project’s surround format.

External MIDI Tracks
The New Tracks dialog offers no additional options if External MIDI is chosen, but the
following applies:

• A new MIDI multi-instrument object will be created in the Environment for the first
track, and the track will be assigned to sub-channel 1.

• Subsequent tracks will be assigned to sub-channels of the MIDI multi-instrument object
(up to the maximum of 16).

• If more than 16 External MIDI tracks are created, they will automatically roll around to
channels 1, 2, 3, and so on. These can be freely reassigned to any sub-channel. If you
have more than one MIDI port available on your system, you can reassign additional
tracks (above the first 16) to a second MIDI multi-instrument object.

• A channel strip is automatically generated in the Mixer for each sub-channel of each
MIDI multi-instrument object.
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Tip: Once tracks are created, you can quickly reassign them to the sub-channels of any
MIDI multi-instrument object with the Library, or by Control-clicking (or right-clicking)
the track list, and making your choice from the Reassign Track shortcut menu.

Full details on setting up external MIDI sound modules and keyboards are found in Setting
Up External MIDI Instruments.

Transferring a Channel Strip Setting to a New Track
You can create a new track that uses the same channel strip assignment and settings as
the selected track. This is a quick and easy way to create a duplicate of an existing track
and channel strip, without replicating the data on the track.

To transfer the channel strip assignment to a new track
1 Select the source track (the one with the channel strip and settings that you want to

duplicate).

2 Do one of the following:

• Choose Track > New with Duplicate Setting in the Arrange area’s local menu bar (or
use the New Track with Duplicate Setting key command, default
assignment:  Command-D).

• Click the Duplicate Track button above the track list in the Arrange area.

Logic Pro creates a new track that uses the same channel strip assignments and settings
directly below the source track. The data on the track (if any exists) is not duplicated.

If you want to copy a track, inclusive of any data, but do not want to copy the channel
strip, see Copying Tracks and Moving Regions.

Creating Tracks by Adding Apple Loops
You can create tracks by dragging Apple Loops from the Loop Browser directly into the
blank Arrange area. A track and corresponding channel strip are automatically created,
and the Apple Loops file is loaded. For more details on adding Apple Loops, see Finding
Apple Loops in the Loop Browser.

Creating Tracks by Adding Audio Files
You can create tracks by dragging audio files from the Media Browser directly into the
blank Arrange area. A track and corresponding channel strip are automatically created,
and a region (that is the full length of the audio file) is added to the new arrange track.
The audio file (and corresponding region) is also automatically added to the Audio Bin.
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Creating Tracks Only
The commands and methods discussed in this section only create new tracks. The current
(selected track) channel strip is used as the target for the new track.

Creating a Track with the Same Channel Strip Assignment
There may be situations in which you want to have multiple copies of a track that address
the same Mixer channel strip.

For example, you may want to create multiple tracks that address a software instrument,
such as the EXS24 mkII, with a drum kit loaded. Each track can contain MIDI regions that
trigger individual drum sounds (kick, snare, hi-hat, and so on). Having a separate track
for each sound allows you to independently mute or solo sounds in the kit.

Tip: Use a multi-output version of the EXS24 mkII if you want to individually process each
sound in the drum kit with different effects.

To create a track with the same channel strip or instrument assignment
1 Select the track you want to copy.

2 Do one of the following:

• Choose Track > New with Same Channel Strip/Instrument (or use the corresponding
key command) to create a new track below the selected track.

• Option-click the Duplicate Track button above the track list in the Arrange area.

When Option-clicked, the button performs the New Track with Same Channel
Strip/Instrument function.

• Use the Append Track to Track List key command to create a new track at the bottom
of the track list.

Creating a Track with the Next Channel Assignment
The Track > New with Next MIDI Channel command (which has a corresponding key
command) creates a new track below the selected track, and assigns the next instrument
or MIDI channel to it. If the MIDI channel of the currently selected track channel is 16, the
first channel is reused.

This command is dimmed if audio tracks (or tracks that don’t provide a MIDI channel
parameter, such as those assigned to aux channel strips) are selected.
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Creating a Track with the Next Channel Strip/MIDI Channel
The Track > New with Next Channel Strip/Instrument command (which has a
corresponding key command) can either create a new track, or a new track and a new
channel strip. The behavior of the command is dependent on the selected track type:

• If the selected track is an audio or software instrument track, the command creates a
new track below the selected track, and assigns the next channel strip to it. If no next
channel strip exists, one is created automatically.

• If the selected track is a MIDI track, the command behaves exactly as Track > New with
Next MIDI Channel. A new track is created, and assigned to the next MIDI channel.

Copying Tracks and Moving Regions
Hold down the Option key when moving a track vertically (click-drag the track number)
to create a copy of the track at the destination position. All selected regions on the source
track are moved to the new track.

Note: If you hold down the Option key before grabbing the track number, no further
regions on the track are selected. If no regions were selected in the first place, an empty
track (assigned to the same channel strip as the original track) is created at the destination
position.

If the Cycle function is turned on, all regions within the cycle are moved from the old
track to the new track. The musical result is unchanged, as the new track is a copy, and
therefore inherits the channel strip output setting of the source track.

In other words, only one channel strip is used for multiple tracks. This allows you to
double-track parts to thicken them up. It also makes tasks such as creating unison voicings
(an octave apart) simple and quick for software or MIDI instrument tracks.

To do this, Option-drag the regions on the destination track to replicate/restore them on
the source track.

Note: Altering the level (or other parameters) of the channel strip, regardless of which
track is selected, affects all tracks routed to the channel strip.

Creating Tracks for Overlapping Regions
The Track > New for Overlapped Regions function creates new tracks for wholly or partly
overlapped regions. The regions are redistributed across the newly created tracks. The
number of new tracks is equal to the number of overlaps. All tracks use the same channel
strip assignment as the original track.

As above, only one channel strip is used for all tracks.
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Creating Tracks for Selected Regions
The Track > New for Selected Regions function creates a new track for the selected regions
on a track. The selected regions are moved to the new track, and removed from the source
track. All new tracks use the same channel strip assignment as the original track.

If you use this command when multiple regions are selected across several tracks, a new
track is created for each source track. For example:

• Two regions are selected on track a, one region is selected on track b, four regions are
selected on track c.

• Following use of the command, the two regions on track a are moved to the newly
created track a copy, the region on track b is moved to b copy, and the four regions of
track c to c copy.

• If you want to create individual tracks for the two track a regions (now on track a copy),
simply select the a copy track, which will automatically select all regions on the track,
and repeat the command.

Deleting Tracks in the Arrange Area
If you delete a track, the channel strip assigned to the track is also deleted, and removed
from the Mixer (unless assigned to another track that is in use).

To delete a track
Do one of the following:

µ Select the track, then choose Track > Delete (or use the corresponding key command).

Tip: If no regions are selected in the Arrange area, you can delete the selected track by
pressing the Delete key.

µ Grab the track, and remove it from the track list by dragging it to the left.

To delete all tracks that do not contain regions
µ Choose Track > Delete Unused in the Arrange area (or use the corresponding key

command).
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Selecting Tracks in the Arrange Area
You can select a track by clicking its name or icon in the track list.

This action selects all regions on the track (or selects the regions that fall within the
defined cycle, if Cycle mode is turned on).

Tip: If you Option-click a track, the track is selected without affecting the existing selection
of regions (on the selected track, or others).

You can also use the following two key commands to select the track above or below
the selected track in the track list:

• Select Next Track

• Select Previous Track

Rearranging Tracks in the Arrange Area
You may want to change the position of tracks in the track list, to visually group related
tracks (string section or percussion parts, for example).

To move a track in the track list
µ Move the pointer over the track number. When the pointer changes to a hand, click the

track number, and drag it up or down the track list. When you reach the new position,
release the mouse button.

Subsequent tracks (if any) are moved down the list.

You can also sort tracks by choosing one of the following options in the Track > Sort
Tracks By menu:

• MIDI Channel

• Audio Channel

• Output Channel

• Instrument Name

• Track Name
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Naming Tracks in the Arrange Area
You can use the Track Header Configuration dialog to determine which track names are
displayed in the track header.

To choose the track names you want to view
1 Open the Track Header Configuration dialog by doing one of the following:

• Choose View > Configure Track Header in the Arrange area (or use the corresponding
key command).

• Control-click (or right-click) any track header in the track list, then choose Configure
Track Header from the shortcut menu.

2 Choose the track name option you want in the first pop-up menu.

• Auto Name:  This option (the default) intelligently names the track, based on the
following actions, and order:

• If you enter a track name manually, the track name is displayed.

• If you loaded a channel strip setting or software instrument, the name of the channel
strip setting or software instrument is displayed.
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• If you did none of the above, the channel strip name is displayed.

• Track Name:  This option allows you to manually enter a track name in the track list.

• Channel Strip Setting Name

• Software Instrument Setting Name

• Channel Strip Name

• Channel Strip Type and Number

3 Select the Allow Two Lines checkbox if you want to view two track names in the track
header, then choose a name option from the second pop-up menu.

The option chosen in the first pop-up menu is always shown to the left if both names
are shown, divided by a line.

You can move this dividing line by dragging the mark at the top of the track list.
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To create a track name
Do one of the following:

µ Choose Track > Create Track Name, then enter a name in the text input field that appears.

µ Double-click the track name in the track list, then enter a name in the text input field that
appears.

Tip: Use the Tab key in the track list when you want to create several track names in a
row. After entering text in the text input field, you can press the Tab key to confirm the
current edit and activate the next track for editing. Using Shift-Tab confirms the current
edit and activates the previous track for editing.

µ Double-click the top line of the Track Parameter box in the Inspector, then enter the name
in the text input field that appears.

The new track name is displayed in place of the channel strip name, and is used as the
default name for newly recorded regions.

To delete a track name
Do one of the following:

µ Choose Track > Delete Track Name.

µ Double-click the track name to open the track name input box, then press the Delete
key.

The track (instrument or audio) channel strip name is then used as the default name
shown in the track list (and for newly recorded regions).

Important: AutoName must be selected in the Track Header Configuration dialog for this
functionality to work.
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Assigning Tracks in the Arrange Area
In general, you create new tracks when you want to record or play back new regions.
Corresponding channel strips are automatically created in the Mixer.

In some situations, however, you may want to reassign an existing track to a different
channel strip; for example, reassigning the output of a software instrument track to
another instrument channel strip. The MIDI regions on the track will be played back
through the inserted software instrument plug-in of the second channel strip.

To reassign a track to a specific channel strip
µ Control-click (or right-click) the track icon or name, then choose the destination for the

track in the hierarchical Reassign Track shortcut menu.

• If you want to use a track for audio region recording or playback, choose a Mixer >
Audio channel strip as the track destination.

• If you want to use a track for MIDI region recording or playback (via a software
instrument), choose a Mixer > Software Instrument channel strip as the track destination.

• If you want to use a track for MIDI region recording or playback (via a MIDI sound
generator), choose a MIDI Instr. > Model/Instrument name channel strip as the track
destination.

To globally reassign multiple tracks that share a channel strip destination
µ Hold down the Option key when reassigning a track channel strip, then confirm the dialog

by clicking the Reassign All Tracks button.

The new track destination (reassigned channel strip) will be used for every track that
shared the original track destination in the current project (including tracks in folders).
As an example:

• Tracks 1 to 4 are assigned to instrument channel strip 6.

• You use the Option key to reassign one of these tracks to instrument channel strip 15.

• Tracks 1 to 4 are reassigned to instrument channel strip 15.
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Assigning Tracks to Environment Objects
Strictly speaking, tracks don’t need to be routed to an instrument or audio channel strip,
as you can assign any Environment object as the track destination. The track data could
conceivably be sent to a fader object, or directly to a MIDI port, for example.

Environment objects are software representations of individual data-processing elements.
Some examples of Environment objects include arpeggiators, knobs, faders, chord
memorizers, and channel splitters. These individual objects can be connected with each
other, using virtual cables. The end result of cabling multiple objects is real-time processing
and manipulation of MIDI (and some audio) data. This can be as simple as a fader to
control the volume of a connected MIDI synthesizer, or as complex as a rhythm generator
or step sequencer (which exists as a virtual machine within the Environment). This machine
can be called into service whenever you need it. For more information, see Working in
the Environment.

Obviously, audio signals would not be understood by a MIDI sound module, so there is
no point in routing a track that contains audio regions to an instrument channel strip, or
vice versa.

Assigning Tracks to Special Destinations
In addition to the normal channel strips, there are two other possible track output
destinations:

• No Output: Tracks assigned as No Output send no data. This can be useful in situations
in which you want to store data (such as SysEx) that you don’t want to send from
Logic Pro.

• Folder: This setting is used when you want the track to play a folder region. (See Working
with Folders.) Normal regions will not play on a track set up for folder playback.

Zooming Tracks in the Arrange Area
Tracks in the Arrange area can be zoomed individually in conjunction with, or independent
of, the global zoom controls (and Waveform Zoom slider) for the window. There is a
default zoom setting for tracks, which is automatically chosen when a window is first
opened. This setting is a good compromise between visibility of text and regions, and
working space in the Arrange area.

To zoom in or out on a track
1 Move the pointer to the bottom-left corner of a track.
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The pointer changes to an index finger.

2 Click and drag to zoom in or out on the track.

The individual track zoom factor, compared to the overall window zoom level, is shown
in the help tag while the mouse button is held down.

Tip: You can zoom all MIDI or audio tracks of your project at the same time by holding
down the Command key while zooming. Pressing Shift while zooming a track resets all
tracks to the default zoom setting.

Zooming the Selected Track Automatically
You can use the View > Auto Track Zoom setting (or use the corresponding key command,
default assignment:  Control-Z) to automatically enlarge the currently selected track. Use
the technique described above to set the desired zoom level on a track. Any subsequently
selected track will automatically zoom to this level.

Zooming Tracks with Key Commands
You can assign, and use, the following key commands to zoom tracks:

• Individual Track Zoom In and Individual Track Zoom Out: Increases or decreases the
“individual track zoom” factor of the selected track by one.

• Toggle Individual Track Zoom: Switches the selected track between its individual zoom
level and the window zoom level. This option is useful for zooming in on a track to edit
its automation data. After editing, use the Toggle Individual Track Zoom key command
to return to the original zoom level.

• Individual Track Zoom Reset: Resets the selected track to the window zoom level.

• Individual Track Zoom Reset for All Tracks: Resets all zoomed tracks to the window zoom
level.
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Assigning Track Icons in the Track Parameter Box
Logic Pro offers high-resolution, scalable (from 128 x 128 pixels downward), and
user-definable track icons.

To assign an icon to a track
µ Click an existing track icon in the Track Parameter box, and choose the icon you want

from the grid.

You can create your own icons for tracks. User-created icons are saved in the following
folder:  ~/Library/Application Support/Logic/Images/Icons.

These icons must have the following attributes:

• 128 x 128 pixels in size

• An alpha channel for transparency

• Must be saved in the portable network graphics format (with the .png suffix)

• Must be given a filename that starts with a three-digit number

Note: If this number is identical to the number of one of the built-in Logic Pro icons, the
icon found in the user folder is given priority.
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You also have the option of directly replacing the built-in Logic Pro icons, which are found
in the /Contents/Resources/Images folder in the Logic Pro package.

To open the Logic Pro package
µ Control-click (or right-click) the Logic Pro icon in the Finder, then choose Show Package

Contents from the shortcut menu.

Muting Tracks in the Arrange Area
You can use a track’s Mute button to stop it from playing. Use the Track Header
Configuration dialog to show or hide the track Mute buttons.

Mute states can be independent for tracks and channel strips, through use of the respective
M buttons in the track header, or corresponding channel strip (Arrange or Mixer).

The behavior of these buttons depends on the Track Mute/Solo setting chosen in the
Logic Pro > Preferences > Audio > General pane:

• Fast (Remote Channel Strips): Clicking a channel strip’s Mute button switches the state
of the associated track button, and vice versa.

• CPU-saving (Slow Response): Choose this option to save processing resources, and to
make the track Mute buttons independent of the corresponding channel strips.

Note: The Mute states of multiple tracks that are routed to the same channel strip are
linked:  muting the channel strip mutes all associated tracks.

Muting Tracks When the Mute Buttons Are Hidden
If the Mute buttons are hidden—to save space—you can still mute a track to the left of
the track number.

To mute a track when the Mute buttons are hidden
µ Place the pointer over the left edge of the track list by the track number, then click when

the pointer turns into a hand.
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A bullet to the left of the track number indicates that the track is muted. A second click
cancels the mute state.

You can also use the Toggle Track Mute key command (default assignment:  Control-M)
to mute a track.

Muting Multiple Tracks in the Arrange Area
It is possible to mute multiple tracks at the same time.

To mute multiple tracks
Do one of the following:

µ Hold down the Command key while clicking a Track Mute button.

All Track Mute buttons that match the state (muted or unmuted) of the clicked button
are also switched. For example, if you click an unmuted Track Mute button, that track
and all other unmuted tracks are muted.

µ Click and hold a Track Mute button, then drag the pointer up or down.

The Mute buttons of all swiped tracks switch to the same state.

You can also use the Toggle Track Mute of all Tracks of Folder key command.

Muting Multiple Tracks with the Same Channel Strip Destination
It is possible to mute multiple tracks with the same channel strip destination.

To mute multiple tracks with the same channel strip destination
µ Hold down the Command and Option keys while clicking a Track Mute button.

All tracks assigned to the same channel strip destination (including those in folders) are
muted.

You can also use the Toggle Track Mute of all Tracks with Same Instrument of Project key
command.

Identifying Muted and Unmuted Regions on Muted Tracks
The following will help you to distinguish between muted and unmuted regions on muted
tracks:

• Muted regions are indicated by a dot that precedes the region name; the audio or MIDI
data section is displayed in gray.
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• Unmuted regions are indicated by a gray surrounding frame (no dot precedes the
region name).

Soloing Tracks in the Arrange Area
Both MIDI and audio tracks (and folders) offer Track Solo buttons. Soloing a track isolates
it while playing, and mutes all other tracks. Use the Track Header Configuration dialog
to show or hide the track Solo Buttons.

In a practical, musical situation, it can be useful to hear several tracks in isolation (bass
and drum parts, for example) to make it easier to fit other musical parts.

Connecting the Track Solo and Channel Strip Solo Buttons
Solo states can be independent for tracks and channel strips, through use of the respective
S buttons in the track header, or corresponding channel strip (Arrange or Mixer).

The behavior depends on the Track Mute/Solo setting chosen in the Logic Pro >
Preferences > Audio > General pane:

• Fast (Remote Channel Strips): Clicking a channel strip’s Solo button switches the state
of the associated track button, and vice versa.

• CPU-saving (Slow Response): Choose this option to save processing resources, and to
make the Track Solo buttons independent of the corresponding channel strips.

Note: The solo states of multiple tracks that are routed to the same channel strip are
linked:  soloing the channel strip soloes all associated tracks.

Soloing Tracks in CPU-Saving Mode
If the Track Mute/Solo preference is set to CPU-saving (Slow Response), activating any
Track Solo button enables Solo Lock mode, and adds all regions on that track to the Solo
Lock group. Solo Lock mode locks the solo status of all selected regions. For full details,
see Soloing Regions. The Transport Solo button turns yellow and displays a padlock icon
to indicate Solo Lock mode.

Deactivating a Track Solo button removes all regions on the track from the Solo Lock
group and—in cases where no other track’s Solo button is active—disables Solo Lock.

Disabling the global Solo (Lock) button on the Transport bar sets all individual Track Solo
buttons to the Off position.
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Soloing When the Track Solo Buttons Are Hidden
If the Track Solo buttons are hidden—to save space—you can still solo a track with the
Solo button on the Transport bar.

To solo a track when the Track Solo buttons are hidden
µ Click the Solo button on the Transport bar, then click the track.

Soloing Multiple Tracks in the Arrange Area
It is possible to solo multiple tracks at one time.

To solo multiple tracks
Do one of the following:

µ Click and hold a Track Solo button, then drag the pointer up or down.

The Solo buttons of all swiped tracks switch to the same state.

µ Hold down the Shift key while the Transport Solo button is active, then click the desired
track names.

Record-Enabling Tracks in the Arrange Area
You can use a track’s Record Enable button to arm a track for recording. For more
information, see Recording in Logic Pro.

Freezing Tracks in the Arrange Area
The Freeze function saves almost 100 percent of the CPU power required for software
instrument and effect plug-in calculations. You can individually freeze audio or software
instrument tracks, except when working with multi-output instruments (Ultrabeat, for
example). In this case, the Freeze function is not available.

Understanding the Freeze Function
Internally, Freeze performs individual offline bounce processes for each frozen track. All
plug-ins of a track (including software instrument plug-ins, if applicable, along with all
related automation data) are rendered into a freeze file.

As long as a track is frozen—following the freeze process—the freeze file will play back
in place of the original track (and its CPU-hungry plug-ins). The original track and plug-ins
are temporarily deactivated, and use no CPU resources.
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Tip: The Freeze function also works with DSP hardware such as the PowerCore, LiquidMix,
Duende, and UAD devices. This compatibility allows you to combine Logic Pro instruments
and effects with those provided by the DSP hardware, even if the processing capacity of
your computer, the DSP hardware, or both, are exceeded.

The Freeze function always bounces the complete channel signal. If you are using more
than one track for the same audio or instrument channel in the Arrange area, then all
(sub)tracks of this channel are frozen, and cannot be edited independently. In other words,
it is the channel strip that is frozen, not the track.

Knowing When to Freeze a Track
In real-world situations, Freeze allows you to:

• Use extra effect plug-ins or software instruments in additional audio or instrument
tracks, which would normally be impossible as it would exceed the CPU-processing
limits of your computer.

• Play back projects created on computers with greater CPU power.

Freeze is designed to circumvent very CPU-intensive processes, which are generally
outlined as follows (from highest to lowest demand):

• Software instruments with a complex voice architecture

• Plug-ins with a complex structure (reverbs, filter banks, or FFT-based effects)

• Software instruments with a simple voice architecture

• Software sampler with active filter

• Software sampler with inactive filter

• Plug-ins with a simple structure

If your computer is able to calculate all active processes in real time, it’s unnecessary to
freeze tracks.

Freeze is recommended whenever your system’s processing power runs short and one,
or multiple, existing tracks with CPU-intensive software instrument or effect plug-ins are
in a finalized state, or at least seem to require no further changes for the time being—in
other words, a close-to-final mix.

As long as a track is frozen, its CPU usage is reduced to that of a high-resolution audio
playback track with no effect plug-ins inserted, regardless of the number, or processing
demands, of the plug-ins that were originally used on the track.

Freezing a Track
It’s easy to freeze a track, using the Freeze button in the track header and the Freeze
mode parameter in the Inspector’s Track Parameter box.
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To freeze a track
1 Click the Freeze button in the track header.

Note: If the Freeze button is not visible, you can display it using the Track Header
Configuration dialog.

2 Choose the required Freeze Mode parameter in the Inspector’s Track Parameter box:

• Source Only: Freezes the track signal before it is fed into the first effect plug-in. Choosing
this mode turns the Freeze button blue.

Note: This Freeze Mode is useful when using CPU-demanding software instruments or
flex modes.

• Pre Fader: Freezes the track signal including all effect plug-ins. Choosing this mode
turns the Freeze button green.

Logic Pro will create freeze files after receiving the next Play command. This allows you
to activate the Freeze buttons of multiple tracks, and render their freeze files in one go.

Note: You can abort freeze processes by pressing Command-Period. In this scenario, the
portion of the frozen tracks that has already been rendered will remain in the freeze files,
and will be used for playback. Frozen tracks will remain silent beyond this point.

To change the freeze state of multiple tracks
Do one of the following:

µ Click and hold the Freeze button of one track, then drag the pointer up or down.

The Freeze buttons of all swiped tracks switch to the same state.
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Understanding the Freeze Process
During the Freeze process, the playhead follows the currently rendered position. A floating
progress bar window is also displayed.

Freeze files are always rendered between the project start and end marks. It is
recommended that you check the project end mark in the Bar ruler before starting a
Freeze process.

Tip: You should adjust the end mark of the project to include feedback-dependent delay
repetitions or reverb tails. Empty areas (digital zero) at the end of freeze files are
automatically removed after the Freeze process.

The Freeze process uses 100 percent of available CPU power. If, for example, a track uses
40 percent of the CPU for real-time plug-in calculations, its freeze file will be created
two-and-a-half times faster than the real-time playback speed. If the original track uses
100 percent of the CPU power, the Freeze process will happen in (approximately) real
time, even if offline bouncing is used.

Working with Frozen Tracks
Once a track is frozen:

• It is not possible to cut and rearrange freeze files in any way, nor is it possible to mix
the freeze files with their originals on a single track—you can use one or the other, not
both.

• It is not possible to record audio on frozen tracks. In fact, the Record Enable button is
hidden when a track is frozen.

• You cannot edit any instrument or plug-in parameters (or related automation data).

You can edit the following parameters of frozen tracks:

• Effect send levels and destinations

• Panorama and surround parameters

• Volume, mute, and solo

You can also edit the automation data for these parameters.

Whenever you try to edit forbidden parameters of frozen tracks, (such as plug-in
parameters that were rendered into the freeze file), Logic Pro asks if you want to unfreeze
the track.

To unfreeze and edit a track
µ Click Unfreeze to deactivate the Freeze button of the track.

The freeze file is deleted.

Note: The track now uses the amount of CPU-processing power that it originally required,
if you click Play.
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You can now perform your edits, and activate the Freeze button again, if required.

Working with Freeze Files
The temporary freeze files are saved in a folder named Freeze Files which is created in
the root directory of your project folder. You usually won’t need to access these freeze
files directly.

Logic Pro manages these freeze files automatically in the background. They are created
during the Freeze process, will play back in place of the original tracks (as long as these
tracks are frozen), and will be deleted as soon as the Freeze button of the corresponding
track is turned off.

Refreshing Freeze Files
The Options > Audio > Refresh All Freeze Files command refreshes the current freeze
files. This may become necessary when global changes are made that also affect the
playback of the frozen tracks (tempo changes, for example).

Hiding Tracks in the Arrange Area
If there are tracks in the Arrange area that do not need to be visible, you can use the Hide
Track function to hide them. This is useful when you are working on very large
arrangements, for example. Hidden tracks play back as usual.

There is a global Hide View button (H) in the upper-left corner of the Arrange area, to the
right of the Catch button.

To hide tracks
1 Click the Hide View button in the upper-left corner of the Arrange area to activate the

Hide Track function.

Small Hide (H) buttons appear on each track.

2 Click the Hide buttons on the tracks you want to hide.
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3 Click the global Hide View button, and all tracks whose Hide buttons have been activated
disappear from the Arrange window.

The H in the global Hide View button is highlighted, indicating that one or more tracks
(with active Hide buttons) are hidden.

To show hidden tracks
µ Simply reactivate the Hide View button when you want to see the hidden tracks again.

There are also a couple of menu functions and key commands that relate to the Hide
Tracks feature.

Even when the global Hide View button is deactivated, you can still hide an individual
track with the View > Hide Current Track and Select Next Track command (or use the
corresponding key command, default assignment:  Control-H).

The View > Unhide all Tracks command (or the corresponding key command) will reset
the Hide buttons of each track, making them all visible.

Note: Hiding tracks does not affect their playback in any way. You can also link the Hide
functions of all tracks belonging to a group by selecting Hide in the Group Property
Settings. (For more information on groups, see Working with Mixer Groups.) Keep in mind
that there is no Unhide Selected Arrange Track key command because there is no way
that you can select a hidden Arrange track.

Protecting Tracks in the Arrange Area
Tracks can be protected, to prevent any alterations. When a track is protected:

• Existing regions (and their contents) cannot be altered.

• No recording is possible.

• New regions cannot be created.

If the Track Protect button is not visible in the track list, you can display it using the Track
Header Configuration dialog.
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Clicking a Track Protect button toggles between Locked and Unlocked modes.

Command-clicking a Track Protect button in the track list protects all tracks in the currently
selected display level (or folder). If tracks were already protected, they will be unprotected.

Using Track Button Slide Activation
Track buttons on arrange tracks (Solo, Mute, Hide, Track Protect, Node, Freeze) support
slide activation, which is similar to running your finger across several channel strip buttons
on good hardware mixing consoles.

As a usage example of slide activation in Logic Pro, click and hold the Mute button of
one track, and drag the pointer up or down. The Mute buttons of all swiped tracks switch
to the same state.

Simply drag over the Mute buttons of the same tracks to undo the Mute.

Drum Replacement or Doubling in the Arrange Area
Logic Pro offers the drum replacement or doubling feature, which allows you to change
drum sounds on an audio track without having to rerecord the entire track. You can use
an audio track that contains a recorded single drum signal to create a software instrument
track with matching MIDI trigger notes, which is then played by the EXS24.

To replace or double a recorded drum signal
1 Select the track that you want to modify.

2 Choose Tracks > Drum Replacement/Doubling (or use the corresponding key command).
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The following changes take place in the Arrange window:

• All files on the selected audio track are analyzed for transients, if not previously done.
Detected transients are displayed as yellow lines. The selected track is vertically zoomed.

• A software instrument track is created below the selected audio track, and the EXS24
is inserted into the Instrument slot.

• The Library tab is opened in the Media area with the focus set to the EXS24, allowing
you to choose the sound that best matches the project.

• A MIDI region containing trigger notes based on the detected transients is created on
the software instrument track.

• A dialog containing parameters opens.
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3 Set the following parameters, as required:

• Instrument pop-up menu: Choose the instrument that you want to process from:  kick,
snare, tom, or other instrument.

• Mode buttons: Choose between the following two modes.

• Replacement: The new sound replaces the original, and all regions on the original
track are muted.

• Doubling: The new sound is added to the original, without muting the original.

• Relative Threshold slider: Define a threshold for generating transients. Trigger notes are
generated for transients above the designated value.

• Prelisten button: Click this button to start soloed playback of both tracks from the current
playhead position. You may want to set the playhead or activate the cycle area for a
part of the project that requires special attention for drum replacement. Click this
button a second time to stop playback, return the playhead to the previous play position,
and remove the solo state of both tracks.

• Trigger Note pop-up menu: Set the pitch of the trigger notes that are created on the
software instrument. The default setting AUTO sets the trigger note as follows:

• Kick = C1 (36)

• Snare = D1 (38)

• Tom = A1 (45)

• Other = C3 (60) and AUTO menu item dimmed

Note: Any changes to the trigger note do not change the instrument setting. However,
any changes to the instrument setting change the trigger note, either to Auto or C3
(60).
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• Timing Offset slider: Shift the position of trigger notes earlier (negative values move
them to the left) or later (positive values move them to the right). This value should
normally be set to 0.0 ms (which places the MIDI trigger notes exactly at transient
timing positions), but may need to be adjusted when using your own, or third-party,
instruments.

• “Set average attack time” button: Set the average slicing position offset of all regions
on the source audio track.

4 Click OK to confirm the action.

Clicking OK resets the vertical zoom of the original audio track, mutes its regions if you
selected the Replacement option, and deselects the track. MIDI trigger notes for the EXS24
are created on the software instrument track, and the track is selected.

5 Click the Cancel button to cancel the action.

Bouncing Regions and Tracks in Place
There are two different types of “in place” bounces that can be performed in
Logic Pro:  region-based bounces and track-based bounces. This allows you to bounce
selected material and place the result at its original position in the arrange timeline—in
other words, in place.

Using Bounce in Place, you can only process audio or software instrument tracks, or the
regions on those tracks. It is not possible to perform an in place bounce of a region routed
to a MIDI channel strip.

When bouncing in place, the audio file format of the bounce (sample rate and resolution)
is determined by your audio recording settings, and the bounce file is created in the
current recording folder.

The Bounce in Place function might, at first glance, seem similar to the Freeze function.
See Freezing Tracks in the Arrange Area. To clarify which function best fits which situation,
here’s a short comparison:

• Both save CPU power by rendering all effect (or instrument) plug-ins of a track.

• The Bounce in Place function makes it easy to access (and edit) the bounced audio file.

• Freeze allows you to return to the original MIDI programming (or audio regions) and
automation data.

• Freeze (in 32 Bit Float) safeguards against volume clipping.

Bouncing Regions in Place
You can render one or more selected regions on audio or software instrument tracks into
a new audio file, including all active plug-ins and automation data.
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To bounce regions in place
1 Select one or more regions on an audio or software instrument track.

2 Do one of the following:

• Choose Region > Bounce Regions in Place (or use the corresponding key command).

• Control-click (or right-click) the selected regions, then choose Bounce Regions in Place
from the shortcut menu.

The Bounce Regions in Place dialog appears.

3 Define the following parameters, as required.

• Name field: Define a name for the bounce file in the text field. The name defaults to
the region name of the first selected region, with the extension _bip added at the end.

• Destination buttons: Define the track on which the bounce file is placed. You have two
options.

• New Track: Creates a new audio track below the selected track, and places the bounce
file on that track.

• Selected Track: Places the bounce file on the selected track.

• Source buttons: Define what happens to the source regions after bouncing. You have
three options.

• Leave: Leaves the source region unaltered after processing the bounce file.
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• Mute: Mutes the source region after processing the bounce file.

• Delete: Deletes the source region from the original track after processing the bounce
file.

• Include Instrument Multi-Outputs checkbox: Select this checkbox to include aux channel
strips with multi-output signals of the software instrument in the bounce process.
Otherwise, only the channel strips of tracks with selected regions are bounced.

• Bypass Effect Plug-ins checkbox: Select this checkbox to disable all plug-ins on the source
track during the bounce process.

• Add Effects Tail to File checkbox: Select this checkbox to continue the bounce process
after the end of the bounce range—either to the end of the cycle or to the end of the
last selected region—until there is no longer a signal. Otherwise, only the bounce range
is bounced.

• Add Effects Tail to Region checkbox: Select this checkbox to include the entire bounce
file in the bounce region. Otherwise, the bounce region only includes the bounce range.

• Include Volume/Pan Automation checkbox: Select this checkbox to have volume and
pan automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

• Normalize pop-up menu: Choose between three states of normalization.

• Off: Turns off normalization.

• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

• Restore Defaults button: Click this button to set all parameters in the dialog to their
default settings.

4 Click OK to trigger an in place bounce of the selected region(s).

Note: When you click OK, the settings chosen above are stored in the preferences and
recalled when you next access the Bounce Regions in Place function.

Bouncing Tracks in Place
You can render one or more selected audio or software instrument tracks into a new
audio file, including all active plug-ins and automation.

To bounce tracks in place
1 Select the relevant audio or software instrument track.

2 Choose Track > Bounce Track in Place (or use the Bounce Track in Place key command).
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The Bounce Track in Place dialog appears.

3 Define the following parameters, as required.

• Name field: Define a name for the bounce file in the text field. The name defaults to
the region name of the first selected region, with the extension _bip added at the end.

• Destination buttons: Define the track on which the bounce file is placed. You have two
options.

• New Track: Creates a new audio track below the selected track, and places the bounce
file on that track.

• Replace Track: Replaces the existing track, and places the bounce file on it.

• Include Instrument Multi-Outputs checkbox: Select this checkbox to include aux channel
strips with multi-output signals of the software instrument in the bounce process.
Otherwise, only the channel strips of tracks with selected regions are bounced.

• As Additional Tracks checkbox: Select this checkbox to create additional bounce files
for every aux with any multi-output of the selected multi-output software instrument
as input source.

• Bypass Effect Plug-ins checkbox: Select this checkbox to disable all plug-ins on the source
track during the bounce process.

• Include Volume/Pan Automation checkbox: Select this checkbox to have volume and
pan automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

• Normalize pop-up menu: Choose between three states of normalization.

• Off: Turns off normalization.
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• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

• Restore Defaults button: Click this button to set all parameters in the dialog to their
default settings.

4 Click OK to trigger an in place bounce of the selected track(s).

Note: Following the in place bounce, the original track content (all regions, and all
automation data except for volume, pan, and sends) is lost and the original instrument
or track channel strip is reset. An Undo is always possible, of course.

Bounce-Replacing All Tracks
You can perform an in place bounce and replace for all audio and software instrument
tracks available in the Arrange window.

To perform an in place bounce of all tracks
1 Choose Track > Bounce-Replace All Tracks.

Note: This command only works if your Arrange area contains audio or software instrument
tracks.

2 You are prompted to save your project; click Yes or No, as appropriate.

The Bounce Replace All Tracks dialog appears.

3 Define the following parameters, as required.

• Bypass Effect Plug-ins checkbox: Select this checkbox to disable all plug-ins on the source
track during the bounce process.
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• Include Volume/Pan Automation checkbox: Select this checkbox to have volume and
pan automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

• Normalize pop-up menu: Choose between three states of normalization.

• Off: Turns off normalization.

• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

4 Click OK to trigger the in place bounce and replace for all tracks.
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Logic Pro offers an extensive range of software instrument and effect processing plug-ins
that are inserted into channel strips. You can also make use of external MIDI instruments
and effects units. This chapter covers all important steps required for instrument and
effect use in Logic Pro. Detailed coverage of the included instrument and effect
plug-ins—including the use of all plug-in parameters—can be found in the Logic Studio
Instruments and Logic Studio Effects manuals.

This chapter covers the following:

• Getting to Know the Arrange Channel Strips (p. 261)

• Working with Plug-ins (p. 266)

• Working with Channel Strip Configurations (p. 272)

• Opening, Closing, and Resizing Plug-in Windows (p. 277)

• Adjusting Plug-in Parameters (p. 279)

• Using Common Plug-in Window Functions (p. 281)

• Using the Library to Choose Plug-in Settings (p. 288)

• Understanding the Library Folder and Menu Structure (p. 289)

• Learning About Effect Routings (p. 290)

• Working with Instruments (p. 295)

• Working with ReWire Applications (p. 309)

• Working with External Audio Effects (p. 311)

• Using Plug-ins from Other Manufacturers (p. 313)

Getting to Know the Arrange Channel Strips
Before discussing the use of plug-ins, a basic understanding of some key channel strip
functions is required.
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The Arrange (and Mixer) channel strips deal with audio and instrument (software or MIDI)
tracks shown in the Arrange area, plus auxiliary (aux) and output channel strips. Each
track in the Arrange window is represented and controlled by a channel strip. Put another
way, the arrange tracks are routed to specific channel strips:

• Audio channel strips control the playback and recording of audio signals on audio
tracks.

• Instrument channel strips allow you to use and control software instruments.

• External MIDI channel strips control external MIDI tracks.

Note: Mixer channel strips are generated automatically when you create new audio,
instrument, or external MIDI tracks in the Arrange window.

The Arrange channel strips, shown at the bottom of the Inspector, display the audio or
instrument channel strip of the selected track on the left side, and the primary (first)
destination for this channel strip on the right side.

The destination will be either:

• An output channel strip, which represents the physical audio outputs of your audio
interface
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• An aux channel strip, which is used for a variety of signal routing purposes

For example, if Send slot 1 of the left channel strip is routed to Bus 4, the fourth auxiliary
channel strip is shown. Clicking Send slot 2 on the left channel strip (routed to Bus 7)
updates the right channel strip to show the seventh aux channel strip. Selecting a particular
output in the Output slot of the left channel strip displays the chosen output channel
strip to the right. If the left channel strip is simply routed to an output channel strip, the
output channel strip is shown by default.

You will perform most plug-in insertion, channel strip routing, and channel strip
configuration tasks as part of your creative workflow in the Arrange window. You should
use the Arrange channel strips for all related functions discussed in this chapter, rather
than accessing the Mixer. For details about working in the Mixer, see the Mixing chapter.

The following is an overview of the main elements in the Arrange channel strips:

Channel Strip Settings 
menu

Instrument slot
Output slot

Pan/Balance control

Volume fader

 Send slot

 Insert slot

Format button
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Setting Channel Strip Input Format
The channel strip input format determines the mono, stereo, or surround status of the
channel strip. Note that software instrument and external MIDI channel strips do not have
a format button.

Mono Stereo Left Right Surround

• Mono: One circle represents a mono input format. The level meter shows a single
column.

• Stereo: Two, interlocked circles represent a stereo input format. The level meter divides
into two independent columns when a stereo input format is chosen.

• Left: Two circles, with the left one filled, indicate a left channel input format. When this
input format is chosen, the channel strip only plays the left channel of an audio file.

• Right: Two circles, with the right one filled, indicate a right channel input format. When
this input format is chosen, the channel strip only plays the right channel of an audio
file.

• Surround: Five circles indicate the surround channel input format. The level meter
divides into multiple linked columns (the number matches the project surround format)
when the surround input format is chosen.

Your chosen input format for a channel strip impacts the following two areas:

• The plug-ins shown on the channel strip will be available as:

• Mono-to-mono or mono-to-stereo versions on mono channel strips

• Stereo-to-stereo versions on stereo channel strips

• Surround or multi-mono versions on surround channel strips

• The Pan control determines the position of the channel signal in the stereo field:

• On mono channel strips (this includes left and right input format channels), the Pan
control determines the left/right position of the signal.

• On stereo channel strips, the Pan control determines the balance between the left
and right channel signals.

Note: To access the Surround Panner, you must first set the channel strip output format
to Surround, via the channel strip’s Output slot.
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To set the channel strip input format for the selected audio track
µ Click-hold the button directly below the channel strip’s level meter, and choose the input

format from the menu that appears.

Tip: On a stereo or mono channel strip, you can simply click the button to switch between
mono or stereo.

Setting Channel Strip Volume Level and Pan/Balance Position
You can set a channel strip’s volume level and pan/balance position.

To set the volume level of a channel strip
µ Drag the channel strip’s Volume fader up or down.

Volume fader

The maximum boost is +6 dB. You can reset the Volume fader to 0 dB (90) by
Option-clicking it.
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To set the Pan or Balance position
µ Drag the control up or down or left or right.

Pan/Balance control

Option-click the Pan or Balance control to reset it to the centered (0) position.

When a channel strip output is set to Surround, the Pan or Balance knob is replaced by
a Surround Panner. Full details on using surround channel strips, effects, and the surround
panner are found in Working with Surround.

How Mono , Stereo, and Surround Effects Are Handled
You can insert mono, stereo, or surround instances of effects into channel strips.

Only versions of the plug-in that match the channel strip input format can be inserted
(mono-to-mono or mono-to-stereo plug-in versions in mono input format channels, for
example).

To insert plug-ins that do not match the channel format
µ Option-click a channel strip’s Insert slot.

The Plug-in menu displays all formats the plug-in has to offer, rather than being limited
to the matching format. Any down or up mixing that may be necessary happens
automatically.

Working with Plug-ins
Plug-ins are, broadly speaking, broken down into two categories:

• Software instruments, which respond to MIDI note messages

• Audio effects, which do not respond to MIDI note messages
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The Audio Units format also offers two further plug-in types:

• Generators

• MIDI-controlled effects

As the name suggests, Generator Audio Units plug-ins generate audio signals. In contrast
to software instruments, however, they do not require a MIDI note message to be
triggered.

Audio Units MIDI-controlled effects can be controlled via MIDI, unlike standard audio
effect plug-ins. As such, they are used differently.

Note: Logic Pro also supports the non-real-time AudioSuite plug-in format in the Sample
Editor. For details, see Using AudioSuite Plug-ins. Details on the use of TDM plug-ins can
be found in the Logic Pro TDM Guide.

Inserting, Removing, and Replacing Plug-ins
You can insert, remove, and replace plug-ins.

To insert effect plug-ins
1 Click a channel strip’s Insert slot.
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A menu appears, showing all available effect plug-ins, sorted into different categories.

2 Browse through the categories and choose a plug-in name by clicking it. A plug-in version
that matches the chosen channel strip input format is loaded.

You also have the option of choosing a mono or mono-to-stereo version of the plug-in,
for example, by clicking the appropriate entry.

Logic Pro effect plug-ins are displayed in various categories such as Delay and Reverb.
Further submenus, such as Audio Units and TDM, are also available if plug-ins in these
formats are installed on your system.
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To insert software instrument, Audio Units Generator, or MIDI-controlled effects
µ Click the Instrument slot of an instrument channel strip, then choose the software

instrument plug-in, Audio Units Generator, or MIDI-controlled effect (name and type)
from the Plug-in menu.

Tip: You can simply choose an instrument name to insert the instrument in stereo on a
stereo format channel.

The plug-in window of the chosen instrument, effect, or generator opens automatically.
If you don’t want the plug-in window to open automatically after insertion, deselect the
“Open plug-in window on insertion” preference in the Logic Pro > Preferences > Display
> Mixer pane.

You can adjust all plug-in parameters in the plug-in window. For more information, see
Adjusting Plug-in Parameters.

To remove a plug-in
µ Click the Insert or Instrument slot, then choose No Plug-in from the menu.

To replace a plug-in
µ Click the Insert slot, then browse to the appropriate plug-in type.

Moving Plug-ins
You can use the Hand tool to move instruments and effects between channel strips.
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To use the Hand tool in the Arrange channel strips, hold down the Command key when
the pointer is placed over an Insert or Instrument slot. To use the Hand tool in the Mixer,
hold down the Command key.

To move a plug-in to another Insert or Instrument slot
µ With the Hand tool selected, drag the plug-in name (blue label) in any used Insert or

Instrument slot to an unused target slot.

During the operation, the potential destination is highlighted using a colored rectangle
(empty slot) or a colored line (when placing an effect between two Insert slots).

To copy a plug-in to another slot
µ With the Hand tool selected, Option-drag the plug-in name from any used slot to an

unused target slot.

To swap an effect plug-in with another in the same channel strip
µ With the Hand tool selected, drag the effect plug-in name from any used Insert slot to

an unused target slot.

This action swaps the plug-in slot positions. For example, on a channel strip with a reverb,
chorus, and delay inserted into slots 1 through 3, respectively, dragging the slot 1 plug-in
to slot 3 places the reverb in slot 3, and the delay is moved to slot 1. Of course, altering
effects positions changes the sound of the signal on the channel strip.

Note: When the Hand tool is used to drag plug-ins between channel strips, the existing
plug-in on the destination channel strip is replaced, not swapped.

To place an effect plug-in between two Insert slots
µ With the Hand tool selected, drag the effect plug-in name of any used Insert slot between

two used Insert slots, and release the mouse button.

The effect is inserted into a newly created slot between the two used slots. The effects
below the drop position (new slot) are shifted down by one.

Note: If all 15 Insert slots are used, you cannot insert any more plug-ins into the channel
strip, unless you replace an existing plug-in.
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Knowing Where Different Plug-in Types Can Be Used
Keep the following in mind when inserting plug-ins into channel strips:

• Effect plug-ins can be placed in the Insert slots of all audio channel strip types (audio,
instrument, auxiliary, output).

• Software instruments can only be inserted into instrument channel strips. These channel
strips feature an Instrument slot, directly above the Output slot, which is used for
software instrument insertion.

• Audio Units Generators can only be inserted into instrument channel strips.

• Audio Units MIDI-controlled effects are inserted into the Instrument slot of instrument
channel strips. The audio signal that you want to process is then selected via the
plug-in’s Side Chain menu.

Using the Channel EQ
The Channel EQ is an insert effect, like any other. In most mixing situations, it is used as
the first effect on a channel strip, allowing you to sculpt the sound of the channel strip
signal before applying other effect types.

To insert the Channel EQ
Do one of the following:

µ On channel strips where Insert slot 1 is not used:  Double-click the EQ area on the upper
portion of the channel strip to place the Channel EQ in the first Insert slot.

The EQ area changes to a thumbnail view of the Channel EQ display. The thumbnails
provide an overview of the EQ settings used in each individual channel strip.
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µ On channel strips where Insert slot 1 is used:  Option-double-click the EQ area to insert
the Channel EQ as the first plug-in, and move all existing plug-ins of the channel strip
one slot down (and redirect their automation data accordingly, if necessary).

Double-clicking the EQ area on channel strips with an occupied Insert slot 1 inserts the
Channel EQ into the next available (unused) slot.

You can freely insert the Channel EQ into any Insert slot as you can other plug-ins. You’ll
find it in the EQ section of the Plug-in menu. Note that only the first (topmost) Channel EQ
is displayed as a thumbnail graphic in the EQ area.

More information about the parameters of the Channel EQ can be found in the Logic Studio
Instruments and Logic Studio Effects manuals.

Working with Channel Strip Configurations
Channel strip settings (CST files) are channel strip–type specific. Put another way,
instrument channel strips feature a number of instrument settings (or presets), such as
Bright Pop Piano and Hard Flanging Clav, separated into instrument, GarageBand, and
Jam Pack categories. Audio channel strips offer effect routings optimized for particular
instrument, vocal, and other processing tasks. Similarly, output and auxiliary channel
strips provide channel strip settings for particular mastering or sweetening processes.
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Loading or Removing Entire Channel Strip Configurations
The Library tab in the Media area allows you to load multiple plug-ins (inclusive of their
parameter settings) into a channel strip. You can also do the same thing by clicking the
Setting button at the top of channel strips.

You can use this function in a number of ways, such as:

• Setting up and storing complex multi-effect configurations, on any type of channel
strip

• Setting up particular routing configurations for use with multi-output software
instruments

• Copying a routing or effect configuration between projects

• Rapidly creating new project templates

To load a channel strip setting with the Settings menu
1 Click the Setting button at the top of a channel strip.

A menu appears, displaying all channel strip settings available for the channel strip type.

Note: Option-clicking the Setting button displays all channel strip settings available for
all channel strip types (shown at the bottom of the menu).

2 Browse to and select the setting by clicking its name.

To load a channel strip setting with the Library tab
1 Select the arrange track whose channel you want to use.

2 Click the Library tab in the Media area.
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The Library displays all channel strip settings available for the selected track or channel
strip, sorted into category menus.

3 Browse through the category menus, then click the setting name to insert all associated
plug-ins into the selected channel strip.

To return to the previously loaded channel strip setting
µ Click the Revert button at the bottom of the Library tab.

To select the next or previous channel strip setting
Do one of the following:

µ Click the Setting button at the top of a channel strip, then choose Previous or Next Channel
Strip Setting from the menu.

µ Use one of the following key commands:

• Next Channel Strip Setting of selected Track

• Previous Channel Strip Setting of selected Track
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• Next Channel Strip or Plug-in Setting or EXS Instrument

• Previous Channel Strip or Plug-in Setting or EXS Instrument

The previous or next channel strip setting shown in the list is loaded. This feature is handy
when trying to find the right delay or clavinet sound, for example.

To delete a channel strip setting
µ Click the Setting button at the top of a channel strip, then choose Delete Channel Strip

Setting from the menu.

To reset a channel strip setting
µ Click the Setting button at the top of the channel strip, then choose Reset Channel Strip

from the menu.

Copying, Pasting, and Saving Channel Strip Configurations
You can copy and paste, reset, and save channel strip configurations.

To copy and paste a channel strip setting
µ Click the Setting button at the top of the channel strip, then choose Copy or Paste Channel

Strip Setting from the menu, as applicable.

You can also use the Copy Channel Strip Setting and the Paste Channel Strip Setting key
commands.

Note: When you paste channel strips (instead of loading them), the Level fader, Panorama
Send Level, and all routing destinations are also set according to the channel strip setting
in the Clipboard.

To save a channel strip setting
1 Click the Setting button at the top of the channel strip, then choose Save Channel Strip

Setting As from the menu (or use the corresponding key command).

2 In the dialog that appears, select the appropriate sub-folder (if applicable), and type in a
name for the channel strip setting.

As there are different classes of channel strips, a number of channel strip–type specific
sub-folders are available in the Channel Strip Settings folder. These sub-folder structures
are reflected in the Settings menu for each type of channel strip.

Do not attempt to change the Channel Strip Settings folder structure. However, you can
create a new folder, and save into it. If no folder is selected, the saved channel strip setting
is shown directly in the Channel Strip Setting menu, below the functions.
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You can remotely switch between channel strip settings by sending MIDI program change
messages. This allows you to select your favorite sounds (consisting of a complete channel
strip setting that can contain a software instrument and effect plug-ins) by pushing a
button on your MIDI keyboard. This feature is named channel strip performances, and is
designed for live use of Logic Pro.

Important: Only program change messages sent on MIDI channel 1 will switch between
channel strip performances. All program change messages sent on other MIDI channels
are forwarded to Audio Units instruments, if applicable.

Channel strip performances can be used for all audio channel strip types. They are saved
in the Performances sub-folder (in ~/Library/Application Support/Logic/Channel Strip
Settings/Channel Strip name). The performance names start with the corresponding
program change number (for example, 001Piano, 045FlangeGuitar, 111ArcoCelloHall).
There are 128 performances (corresponding to 128 available program change events).

To create a performance setting
1 Configure a channel strip that you want to have available as a performance (by opening

a channel strip setting from the factory library and making changes according to your
needs, for example).

2 Click the Setting button at the top of the channel strip, then choose Save as Performance
from the menu.

3 In the dialog that appears, enter a performance name, choose a program change number,
and click OK.

4 Send the program change number from your MIDI controller.

When a channel strip receives a program change message (on MIDI channel 1) that
corresponds to an assigned performance number, it loads this performance.

Note: If an unassigned program change value is sent, the channel strip ignores the
message, and the currently loaded channel strip performance setting remains in place.
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All saved performance settings appear in the Performances folder of the Channel Strip
Settings menu.

Opening, Closing, and Resizing Plug-in Windows
Hands-on operation of plug-ins takes place in the plug-in window. This window allows
access to all plug-in parameters. Each instance of a plug-in has its own plug-in window,
allowing each to have discrete settings.
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The plug-in window opens automatically when you insert a plug-in. This behavior can
be overridden by deselecting the “Open plug-in window on insertion” checkbox in the
Logic Pro > Preferences > Display > Mixer pane.

To close a plug-in window
µ Click the close button at the top-left corner of the plug-in window.

Note: Closing the plug-in window does not deactivate the plug-in.

To open a closed plug-in window
µ Double-click an assigned Insert or Instrument slot. (The name of the plug-in is shown on

the slot.)

To hide or show all open plug-in windows
µ Use the Hide/Show All Plug-in Windows key command (default assignment:  V).

You can also adjust the size of plug-in windows, individually or globally.

To adjust the size of a plug-in window
Do one of the following:

µ Drag the lower-right corner of the plug-in window. This scaling applies to individual
plug-ins.

µ Choose the window size in the plug-in window’s View menu. This scaling applies to
individual plug-ins.
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µ Set the default size for plug-in windows in the Logic Pro > Preferences > Display > Mixer
pane. This scaling applies to all plug-ins.

Adjusting Plug-in Parameters
This section briefly describes common parameter elements you will find in Logic Pro
plug-in windows. Full details on the parameters of each individual plug-in can be found
in the Logic Studio Instruments and Logic Studio Effects manuals.

To switch plug-in window buttons
µ Click the button.

It switches to the next or previous option, or will be turned on or off.
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To adjust a parameter slider
Do one of the following:

µ Drag the slider vertically or horizontally.

µ Command-click anywhere in the slider’s value range to set it to the clicked value.

To adjust rotary knobs
Do one of the following:

µ Drag the rotary knob vertically.

µ Command-click anywhere in the value circle surrounding the knob to set it to the clicked
value.

To adjust numerical fields
Do one of the following:

µ Drag the field’s numerical value vertically.

µ Click (or double-click) in the numerical field, then type a new value using your computer
keyboard.

µ If there are up and down arrows alongside such panels, click them to increment or
decrement the value by one step.

µ If the numerical panel opens a pop-up menu of values, choose one.
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To reset any parameter to its default (or centered) value
µ Option-click the parameter.

To make finer parameter adjustments
µ Hold down the Shift key before dragging a control.

You can also use the mouse wheel to adjust Logic Pro plug-in parameters.

To adjust plug-in parameters with the mouse wheel
1 Select a Logic Pro plug-in parameter by clicking it.

2 Move the mouse wheel.

Tip: You can also use the trackpad of any portable computer instead of the mouse wheel.

Using Common Plug-in Window Functions
The header area at the top of the plug-in window is common to all plug-ins. It offers a
number of important functions for plug-in use.

To hide or show the plug-in window header
µ Click the icon at the top-right corner of the plug-in window.

Linking Plug-ins
The button to the extreme left of the plug-in window header (with a chain on it) is called
the Link button.

When the Link Button Is Switched On
• A single plug-in window is used to display all open plug-ins. Each time you open a new

plug-in, the window updates to reflect the newly chosen plug-in.

• Choosing a different arrange track updates an open plug-in window to display the
corresponding slot number of the newly selected track or channel strip. For example:

• Track 1, assigned to instrument channel strip 1, has an ES1 instance loaded (in the
Instrument slot).

• Track 11, assigned to instrument channel strip 2, has an EXS24 mkII instance loaded.

• Switching between tracks 1 and 11 automatically updates the plug-in window to
show the ES 1 or EXS24 mkII, respectively.
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When the Link Button Is Switched Off
You can open several plug-in windows simultaneously, and these do not update to reflect
any track or plug-in choices you may make. Each open plug-in window does, of course,
continue to show all parameter updates and changes.

Turning Link off is handy when you want to compare the settings of two plug-ins, or
adjust the parameters of several open plug-in windows at the same time.

Bypassing Plug-ins
If you want to deactivate a plug-in, but don’t want to delete it or remove it from a channel
strip, you can bypass it. Bypassed plug-ins do not drain system resources.

To bypass a plug-in
Do one of the following:

µ Click the Bypass button at the left side of the plug-in window header.

µ Option-click the appropriate Insert or Instrument slot on the channel strip.

The Insert slot of the bypassed plug-in turns from blue to gray, indicating that the plug-in
is currently bypassed.

Getting to Know the Settings Area
All current plug-in parameter settings are stored with the project file, and are automatically
recalled the next time it is loaded. You can also save and recall any changes you make
to plug-in parameters. These are stored and recalled as individual settings (or presets, if
you prefer) via the Settings area.
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The Settings area appears to the right of the Bypass button.

• Next and Previous Setting buttons: Click to load the previous or next plug-in setting.

• Settings field: Displays the name of the current plug-in setting. Click to access the
Settings menu.

• Compare button: Click to compare a changed plug-in setting with the setting saved
with the project.

• Copy and Paste buttons: Click to copy or paste a plug-in setting.

Using the Settings Functions
In this section, you’ll use the various functions available in the Settings area.

To load a setting
1 Open the Settings menu (of the plug-in window, not the channel strip Settings menu)

by clicking the Settings field.

2 Do one of the following:

• Browse to, and choose the setting you want to use from the menu or category
submenus.
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• Choose the Load Setting command. A dialog opens. Only settings for compatible plug-in
types are shown. Each plug-in has its own set of parameters, and therefore its own file
format.

Note: You can also choose plug-in settings from the Library tab of the Media area in the
Arrange window. See Using the Library to Choose Plug-in Settings.

To choose the next or previous setting
Do one of the following:

µ In the plug-in window header, click the left arrow to choose the previous setting, or the
right arrow to choose the following setting.

µ Make use of the following key commands:

• Next Plug-in Setting

• Previous Plug-in Setting

• Next Plug-in Setting or EXS Instrument

• Previous Plug-in Setting or EXS Instrument

• Next Channel Strip or Plug-in Setting or EXS Instrument

• Previous Channel Strip or Plug-in Setting or EXS Instrument

To replace a setting
Do one of the following:

µ Browse to, and choose the setting you want to use from the plug-in Settings menu.

µ Choose the Load Setting command, then choose the setting from the dialog.

To compare changed plug-in parameters with the original settings
1 Make adjustments to the plug-in parameters.

The Compare button turns blue (with white text), indicating that you have made changes
to the plug-in parameters, but have not saved the edited plug-in setting in the project.

2 Click the Compare button to listen to the setting that was originally saved with the project.

The Compare button turns black (with white text).

3 Click the Compare button again to switch back to the edited plug-in setting.

The Compare button again turns blue (with white text).

This feature allows you to audition your audio or instrument track playback through two
variations of a plug-in. The tweaked version can be saved as a new plug-in setting via
the Settings menu, if you decide to keep it. If you save it, the Compare button turns black
and is disabled.
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The Compare button compares the tweaked setting with the reference setting that was
stored when you last saved your project—even if you have saved the setting since opening
the project.

This approach means that you can quickly change the reference setting by saving the
project.

To revert to a plug-in’s factory default setting
µ Choose Reset Setting from the Settings menu.

To copy the current plug-in parameters
µ Click the Copy button in the plug-in window header (or choose Copy Setting from the

Settings menu).

This copies all parameter settings into a plug-in settings Clipboard, which is independent
of the global Logic Pro Clipboard.

To paste copied plug-in parameters
µ Click the Paste button in the plug-in window header (or choose Paste Setting from the

Settings menu).

Note: This option only works between plug-ins of the same type (two Compressor
instances, for example). Some plug-ins, such as the ES2 and some ES2-based GarageBand
instruments, have a number of shared parameters, allowing you to freely copy and paste
parameter settings between them. (See Switching the Contents of the Plug-in Window.)

To save a setting using the Settings menu
Do one of the following:

µ Choose Save Setting to save the current plug-in parameter values as the setting. This
action overwrites the existing setting.

µ Choose Save Setting As to name and save a setting, inclusive of a folder location. You
can also create a new folder in the Save As dialog, if you wish.

Note: The folder location (existing or newly created) must be in the associated plug-in
folder. For example, you could save a setting called Euro Lead in the Lead Synths sub-folder
of the ES2 folder.

To create a default setting
µ Save a setting called #default in the Settings folder of any plug-in type.

It will always be loaded when that plug-in type is opened. The #default setting is also
useful as a starting point when creating new plug-in settings, or as a fallback position
when you’ve been experimenting.

To delete a setting
µ Choose Delete Setting from the Settings menu.
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Replacing Setting-Compatible Plug-ins
When you replace a plug-in with another plug-in that is setting-compatible, the new
plug-in automatically uses the setting of the replaced plug-in.

For example, when you replace an ES2-based GarageBand instrument with the ES2, the
inserted ES2 uses the same setting as the replaced ES2-based GarageBand instrument. It
also works for most EXS-based GarageBand instruments, with two exceptions:  Hybrid
Morph and Hybrid Basic.

Switching the Contents of the Plug-in Window
You can reassign any open plug-in window in two different ways:  via the Show Channel
Strip menu and the Show Insert menu:

• Click the Show Channel Strip menu to switch the plug-in window between all channel
strips that use the same plug-in. If you have inserted the ES2 on tracks 1 and 6, for
example, you can switch between these channel strips and adjust the parameters of
each ES2 instance, respectively.

• Click the Show Insert menu to switch between the plug-in slots of the selected channel
strip. For example, if a particular channel strip uses an equalizer and an ES2 plug-in,
you can switch between these plug-ins.

Switching the Plug-in Window View Mode
Plug-in parameters can be viewed in two forms:  Controls view and Editor view. The Editor
view shows the plug-in’s graphical interface, if it offers one.

The Controls view displays all plug-in functions as a set of horizontal sliders, with numerical
fields to the left of each parameter. These fields are used for both the display and entry
of data values.

Controls view Editor view

To switch between view modes
µ Choose the Controls or Editor item in the plug-in window header’s View menu.
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Side Chaining Plug-ins
All plug-ins that support side chain inputs feature an additional Side Chain menu at the
right of the plug-in window header. This allows you to route any audio, input, or aux
channel strip into the plug-in, via a side chain.

To route an instrument channel strip as the side chain signal (alternative approach)
1 Click the instrument channel strip’s Send slot, and choose an unused Bus from the pop-up

menu.

This creates an aux channel strip.

2 Click the Output slot of the aux channel strip, and choose No Output from the pop-up
menu.

This turns off the output signal of the aux channel strip, which you don’t want to hear.

3 Open the required plug-in from the instrument channel strip, and choose the
newly-created aux channel strip from the plug-in’s Side Chain menu.

The plug-in processes the audio of the aux channel strip selected in the Side Chain menu,
and not the audio of the instrument channel strip that the plug-in is inserted into.

The signal peaks of the side chain input (the sent instrument signal), combined with the
Threshold parameter of the plug-in, determine when the plug-in is triggered.

The following are some side chaining examples:

• A sustained pad sound is sent through a noise gate, which is triggered by a drum track
being used as the side chain input signal. This results in a rhythmic pad sound which
follows the signal peaks of the drum track.

• A noise gate inserted into a bass guitar channel is triggered by the kick drum track via
the side chain. This can tighten the timing of the bass guitar, as it follows the kick drum
signal.

• Side chains can also be used to blend a music mix with a voiceover. To achieve this,
the mix needs to be routed through a compressor which, in turn, is side chained, using
the voice-over track. In this type of setup, the music becomes softer when the narrator
is speaking, and louder when not. The effect is also known as ducking. Note that in
order for this to function, the Automatic Gain Make-up or Auto Gain control (if applicable
to the Compressor plug-in) must be disabled.
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Hiding and Showing Extended Parameters
Some Logic Pro plug-ins may have additional parameters that don’t appear in the Editor
view (the graphical interface of the plug-in).

This is indicated by a disclosure triangle that appears at the bottom-left corner of the
plug-in window.

If no disclosure triangle is visible, the plug-in has no additional parameters.

To hide or reveal the extended parameters
µ Click the disclosure triangle at the bottom of the plug-in window.

Using the Library to Choose Plug-in Settings
An alternative to using the Settings menu (found in the plug-in window header) is the
Library tab of the Media area.

To load a plug-in setting from the Library
1 Click the Media button, then click the Library tab.

2 Select the arrange track that is routed to the channel strip whose settings you want to
adjust.
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3 Click the Insert or Instrument slot of the desired plug-in on the Arrange channel strip.

The Library displays all settings available for the chosen plug-in type, sorted into category
menus. Examples for the Compressor plug-in include Drum Compressors, Instrument
Compressors, and Vocal Compressors.

4 Click the appropriate category menu, then click a setting name to change the setting for
the selected plug-in.

Note: You can click the Revert button in the Library tab to return to the previous plug-in
setting.

5 Clicking further Insert or Instrument slots, if used, updates the Library tab to show all
settings for the chosen plug-in type.

6 If you click an unused Insert or Instrument slot, the Plug-in menu is shown, as usual.
Choose a plug-in and the Library tab updates to reflect your selection.

Understanding the Library Folder and Menu Structure
Each plug-in type has a specific sub-folder (named after the plug-in) that is automatically
created in the Plug-In Settings folder. Further sub-folders, used for categories, can be
created inside these sub-folders.

These folder structures are reflected in the Library tab (and Settings menu) for each
plug-in. The top-level Plug-In Settings folder is located in the following
location:  ~/Library/Application Support/Logic/Plug-in Settings. The following settings
are stored in this location:

• User-defined or edited plug-in settings

• Factory settings

Note: If a plug-in’s Factory folder contains sub-folders, the Factory folder is no longer
displayed. This allows you to directly access the factory settings from the sub-folders.

Plug-in settings are identified by the .pst file extension.
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Learning About Effect Routings
There are two ways of sending audio to effects:  via an insert, or via an aux send.

Using Insert Effects
When a plug-in is inserted directly into a channel strip, it is termed an insert effect.

All of the signal is processed, or, put another way, 100 percent of the signal flows through
the effect. This behavior is suitable for equalizers or dynamic effects, such as compressors.
If you have enough processing capacity, you can use up to 15 insert effects on each
channel strip.

By default, only two Insert slots are shown on channel strips. An extra blank Insert slot is
automatically created as soon as all of the currently displayed Insert slots are used, up to
the maximum allowed. So if you insert an effect plug-in into Insert slot 2, a third slot is
shown automatically. If you insert a plug-in into slot 3, a fourth is shown, and so on.

For more information about routing effect plug-ins in a series, see Routing Audio in the
Mixer via Insert Effects.
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Using Send Effects
When you use send effects, a controlled amount of the signal is sent to the effect. Sends
are typically used for effects that you want to apply to several signals at the same time.

Send effects are also called bus effects, bus send or bus returns, auxiliary send or auxiliary
returns, or simply send or returns.

In Logic Pro, the send effect is placed in an Insert slot of an aux channel strip. The signals
of the individual channel strips that you want to process are sent to this aux channel strip,
using a bus. The amount of signal is controlled by a Send knob on each channel strip.
The audio is processed by the effect inserted in the aux channel strip, and is mixed with
the stereo output.

The primary advantage of this approach (over inserting effects on tracks) is efficiency.
This method allows multiple channel strips to be processed by one inserted effect, which
saves vast amounts of processing power (and your time) when compared to the alternative
of inserting the same effect directly into multiple channel strips.

Another bonus is that you can quickly switch between wet and dry versions of all channel
strips that are sent to an aux channel strip, by simply bypassing the effect on the aux.
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Similarly, you can completely change the effects configuration for multiple sent channel
strips by choosing different effects for the aux channel strip.

For computationally intensive effects such as reverb, it’s always advisable to insert them
into an aux channel strip. Chorus, Flanger, and delay effects should also be inserted into
an aux, if they are going to be used on more than one track.

In some cases, however, it may make musical sense to patch an effect such as a delay or
chorus directly into the Insert slot of an individual channel strip. This allows you to use
precise settings, and colors, on individual elements of your mix.

The golden rule is that you should use whatever sounds right in your mix. There are no
restrictions as to where effects can be used in Logic Pro.

For more information about routing effect plug-ins in parallel, see Routing Audio in the
Mixer via Send Effects.

To send a channel strip signal to an aux
1 Click a Send slot (of an audio channel strip, for example), and choose a bus from the

menu.
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2 Drag the Send knob to set the amount of signal that you want to send to the aux channel
strip.

As you do so, the (send amount) value is shown on the Send slot.

The send amount, when set to 100%, routes the entire signal from the audio or instrument
channel strip to the aux channel. (See Using Pre Fader, Post Fader, and Post Pan Sends.)

3 Insert the effect plug-ins you want, and set the required level, pan, and output settings
for the destination aux channel strip.

To remove a send
µ Click an active Send slot, then choose No Send from the menu.

To bypass a send
µ Option-click the Send slot.

The Send slot background turns gray.

To normalize (reset) the send level
µ Option-click the Send knob.

This action resets the send level to 0 dB.

Using Pre Fader, Post Fader, and Post Pan Sends
Sends can be positioned either before (pre) or after (post) the (source) channel strip level
fader.
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A post fader signal level, routed to a send, changes along with Volume fader movements.
If you are using the send to route a signal from the channel strip to a reverb inserted on
an auxiliary channel strip, this means that the relationship between the original signal
and the effect signal remains constant. When you pull the channel strip’s Volume fader
all the way down, the reverb disappears as well. This setting is generally the most useful,
and is the default in Logic Pro.

If a send is set to Pre Fader mode, the level of the signal routed to the send remains
constant, regardless of any Volume fader movements on the source channel strip. The
signal is still fed to the selected aux channel strip—even if the source channel strip’s
Volume fader is completely pulled down. Pre fader sends are mainly used for monitoring
tasks:  headphone monitoring in the studio or foldback monitoring on stage. Pre fader
sends are also useful when you want to hear the effect signal in isolation (without the
original signal). The equalizer still affects the sends in Pre Fader mode (pre fader, post
EQ).

If you choose Post Pan, the signal is not only post fader, but also post pan. This means
that the pan position of the send signal on the aux (which needs to be stereo or
multi-channel) follows the Pan/Balance or Surround Panner position of the channel strip.

To select one of these options in Logic Pro
µ Click a used Send slot, then choose Post Pan, Post Fader, or Pre Fader at the top of the

menu.

Making Sends Low Latency Safe
If you activate Low Latency mode (see Working in Low Latency Mode), the signal paths
of all sends that create a latency that exceeds the set Low Latency mode limit are muted.

However, if you want to keep a particular send signal path open, you can switch it to Low
Latency Safe mode.

This setting is available in each individual Send menu of audio and software instrument
channel strips, and in aux channel strips that are hosting live input signals.
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To activate or deactivate the Low Latency Safe function for a particular send
µ Click-hold the appropriate Send slot, then choose Low Latency Safe from the menu.

Note that the signal path of the send signal (beyond the send) is not subject to low latency
processing, and will be delayed in accordance with the current plug-in latency
compensation setting. Given this behavior, use of the Low Latency Safe setting on sends
routed to effects such as distortion, modulation, or rhythmic delays is not ideal. It may,
however, be of particular use for reverbs—especially in cases where the current plug-in
compensation delay time falls within the range of a reverb’s pre-delay time.

When Low Latency mode is activated, it’s easy to recognize whether a send is switched
to Low Latency Safe mode or not.

• Sends that are low latency safe remain blue or green.

• Sends that are not low latency safe turn orange.

Working with Instruments
This section describes the use of software instruments and external MIDI sound generators.

Both software and external MIDI instrument tracks are handled in an almost identical
fashion. In fact, the MIDI regions on tracks routed to either type of channel strip (software
instrument or External MIDI) can be used interchangeably.

You can also completely reassign a track routed to an external MIDI synthesizer to one
using software instruments, or copy the data of an external MIDI track to a software
instrument track, resulting in layered playback of the part through both instruments.

Software instruments use instrument channel strips. MIDI instruments use External MIDI
channel strips.

ReWire instruments are handled through auxiliary channel strips. The setup and use of
ReWire instruments is described in Working with ReWire Applications.
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Tip: Many of the setup and routing tasks described in this section can be done once, and
saved with a template. This means that all of these preliminary tasks can be bypassed
the next time you load the template, so you can concentrate on creating music. For
details, see Saving a Project as a Template.

Setting Up External MIDI Instruments
There are several ways that you can set up and use external MIDI keyboards and modules
with Logic Pro. The best way to illustrate these is with working examples.

To create a new external MIDI instrument from the Arrange window
1 Click the New Tracks button (the plus sign above the track list) in the Arrange window.

2 In the New Tracks dialog, choose the External MIDI option, then click the Create button.

Note: The Open Library checkbox in the New Tracks dialog is selected by default. Leave
it selected, as the Library tab (that automatically opens) is very helpful during this
procedure.

A new track is created in the track list, assigned to GM Device 1. The Library tab shows a
list of your MIDI ports and other objects, the GM Device among them.

When you create a new External MIDI track in a project, Logic Pro automatically generates
a new External MIDI multi-instrument object. This is placed on the MIDI Instr. layer of the
Environment window.
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Choose Window > Environment (or use the Open Environment key command, default
assignment:  Command-8) to look at this object.

Another thing that happens in the background is the automatic creation of Mixer channel
strips for each of the multi-instrument sub-channels. Click the Mixer button at the bottom
of the Arrange window, and click the All button in the Mixer’s menu bar. You’ll see 16
channel strips, assigned to GM Device 1 to 16 (plus a couple of others for audio channel
strips).
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3 Click GM Device in the left column of the Library tab. Sixteen entries appear in the right
column:  1 (Grand Piano), 2 (Polysynth), and so on.
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4 Click the disclosure triangle to the left of the GM Device 1 entry in the Inspector to open
the Track Parameter box, if not already open.

There are two parameters of particular note here:  Port and Channel. (See Setting External
MIDI Channel Strip Parameters.)

5 Choose All from the Port pop-up menu.

All of your MIDI interface Out ports are listed; for example, Port 1 (Unitor 8), Port 2 (Unitor
8), MIDI1 (mLan Network). If you choose a specific Port—Port 1 (Unitor 8), for example—the
GM Device multi-instrument object is routed to this specific MIDI port. This mirrors the
port listing shown in the left column of the Library tab.

6 Note that the Channel parameter is set to 1. Create a few new External MIDI tracks by
following steps 1 and 2. These new tracks are called GM Device 2, GM Device 3,
GM Device 4, and so on. Click each of these tracks in the track list, and keep an eye on
the Channel parameter in the Track Parameter box of the Inspector. Each of these tracks
is routed to a sub-channel of the GM Device multi-instrument object. The selection of
each track is mirrored by the 16 sub-channel entries shown in the right column of the
Library tab.

When creating more than one new External MIDI track, Logic Pro does not create a new
multi-instrument object for each one. Rather, it assigns each subsequent track to
sub-channels of the GM Device multi-instrument object. You can create up to 16 tracks
that are assigned on a one-to-one basis with each sub-channel of a multi-instrument
object.

If you need more channels for more external MIDI synthesizers and modules, you have
a couple of options. The easiest way is to use the Library tab to reassign newly created
tracks to particular MIDI ports and channels.
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To reassign tracks to channels using the Library tab
1 Click the New Tracks button (the plus sign above the track list) in the Arrange window.

2 In the New Tracks dialog, enter a value greater than “1” in the Number field, choose the
External MIDI option, then click the Create button.

3 Select one of the new tracks, then choose a Port and sub-channel entry in the Library
tab.

• If you choose a sub-channel of the GM Device, you reassign the selected track to this
sub-channel.

• If you choose a sub-channel of a different MIDI Port, the track is reassigned accordingly
(Unitor 8 Port 5, sub-channel 4, for example). Take a look at the new multi-instrument
object (Unitor 8 Port 5) in the Environment.

Note: The first time you do this for each port or sub-channel, a new multi-instrument
object is created in the Environment (along with corresponding Mixer channel strips).
Once objects have been created for all ports, the reassignment of tracks to ports or
channels does not create new objects.

An alternative to using the Library tab for multi-instrument object creation is the
Environment.

To create a new external MIDI instrument in the Environment
1 Choose Window > Environment (or use the Open Environment key command, default

assignment:  Command-8).

2 If it does not default to the MIDI Instr. layer, click the down arrow to the left of the Link
button, then choose the MIDI Instr. entry.

3 Choose New > Multi-Instrument from the local menu bar.

The newly created multi-instrument object is called (Multi Instr.). You can rename it later
(usually after your synthesizer name:  JV5080, Microwave, and so on).
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Note: There are diagonal lines running through each of the 16 sub-channel boxes. The
Port and Channel parameters are shown to the left of the Environment window.

4 Click the Port pop-up menu, then choose a new MIDI Out port for the Multi Instr. object.
Make sure that this port is different from the one used by the GM Device object.

5 Activate each sub-channel by clicking each sub-channel box. As you do, the diagonal line
disappears from each.

6 Click the Mixer button at the bottom of the Arrange window, and you’ll see 16 new (Multi
Instr.) channel strips.

Tip: Once an object has been created in the Environment (using any of the methods
described), you can Control-click (or right-click) track names in the track list. Choose a
port and sub-channel from the Reassign Track menu to quickly reassign tracks.

Setting Parameters for Instrument Channel Strips
When you choose a track that is assigned to either a MIDI or software instrument channel
strip, the Inspector’s Track Parameter box displays the parameters outlined in this section.

Changes to these parameters affect the entire channel strip, and all tracks routed to the
channel strip are affected. This is an important distinction to make, as some parameters,
such as transposition, are available as both a track and region parameter. To put this into
context, imagine a project with six tracks routed to the EXS24 mkII (with a drum kit loaded)
on instrument channel strip 1. You want to transpose the snare drum part (played by
regions on track 2) by two semitones. This will trigger a different snare drum sample.

• If you use the Region Parameter box Transposition parameter for all regions on track
2, things will go according to plan.
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• If you use the Track Parameter box Transposition parameter, the entire EXS24 mkII
drum kit (instrument channel strip 1) will be affected. This will result in all regions on
the six tracks being played back by other drum samples.

Common Instrument Parameters
The following parameters are available for both software instrument and MIDI instrument
channel strips.

• Icon: The icon used by the instrument can be changed to suit your tastes or needs.
Click the icon, then choose another from the menu. A default icon is used for all internal
Logic Pro instruments when inserted, so you can instantly recognize an EXS24 mkII or
ES1 track.

• Transposition: The Transposition parameter allows you to define the number of
semitones that all note events are transposed by, on output. Negative values transpose
downward.

• Velocity: The Velocity parameter allows you to increase or decrease the note on velocities
of all note events by an amount between –99 and 99.

• Key Limit: The two note values of the Key Limit parameter define a pitch range. All
notes outside this range are ignored by the instrument.

• Vel Limit: The two values of the Vel Limit parameter define a velocity range. All notes
with a velocity that falls outside this range will not be played by the instrument.

• Delay: The Delay parameter allows you to compensate for any differences in reaction
time between your various MIDI devices, or to create offsets between channel strips.
The parameter contains a pop-up menu with the following two settings, common to
both software instrument and MIDI instrument channel strips:

• Delay in Ticks: Sets the instrument delay in ticks, with a range between –99 and +99.

• Delay in Milliseconds: Allows the user to set tempo independent delays (or pre-delays)
in steps of 0.1 milliseconds, with a range between –200 ms and +200 ms.

Note: If you want to create rhythmic delay effects on individual parts, use the Region
Parameter box Delay. This allows for longer delay times, and does not affect the channel
strip playback timing.

• No Transpose: Turn on the No Transpose parameter to protect all MIDI regions (on any
tracks routed to this channel strip) from transposition. In other words, the Region
Parameter box Transpose parameter is ignored. This is very useful for instruments
assigned to drum or other multi-timbral samples, as transposition will change the
sounds (rather than merely the pitches) of these instruments.
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• No Reset: Turn on the No Reset parameter to prevent reset messages from being sent
to this channel strip. This can be useful if controllers are being used for nonmusical
purposes, such as mixer automation. The Logic Pro > Preferences > MIDI > Reset
Messages pane determines what reset messages are normally sent, but these messages
are not sent to No Reset instruments.

• Style : Whenever a MIDI region is created on one of the tracks routed to a given channel
strip, it is assigned the staff style set in the Style pop-up menu. If Auto is chosen,
Logic Pro picks an appropriate style based on the pitch range of the notes in the region.

Tip: You can change a MIDI region’s staff style at any time in the Display Parameter
box of the Score Editor.

Setting Software Instrument Channel Strip Parameters
The following parameters are specific to software instrument channel strips.

• MIDI Channel: This parameter sets the MIDI channel strip used by the software
instrument.

• Freeze Mode: The Freeze Mode parameter allows you to define the point at which the
signal on the selected channel strip object is frozen:  before the signal is fed into the
first effect plug-in (Source Only) or the entire signal including all effect plug-ins (Pre
Fader).

Setting External MIDI Channel Strip Parameters
The following parameters are specific to External MIDI channel strips.

• Port: Defines the physical MIDI output that data is sent to. Your MIDI sound module is
connected to this MIDI output connector.

• Channel: Defines the channel used for MIDI output by the instrument track, allowing
your “real” instrument to receive the data.

You can also alter the MIDI channel of an external MIDI instrument part by choosing
another sub-channel of the current multi-instrument.

A sub-channel is one of 16 possible MIDI channels or parts that can be played by a
multi-instrument object. It goes without saying that the external MIDI synthesizer
(represented by the multi-instrument object) needs to be capable of playing on more
than one MIDI channel for sub-channel selection to be useful.

You can’t actually change the receive channel of a sub-channel in the multi-timbral
synthesizer. This is only possible in a few models (and is not particularly useful when
using Logic Pro, at any rate).

If the MIDI channel is set to All, you can edit the parameters of the whole
multi-instrument object. This is a useful feature for globally changing the MIDI port
(Port A, B, and so on), for example.
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• Program, Volume, and Pan: Transmit program changes, volume controller (CC #7), and
pan controller (CC #10) information. If the respective box is unselected, the default
value of the MIDI device itself is used.

A program change (a preset or patch number in your MIDI module) can be selected
on the right, via a pop-up menu. When dealing with multi-instrument sub-channels,
sounds can be selected from a pop-up menu by name.

As an alternative, you can double-click the track name (GM Device 1, for example). This
opens the Multi-Instrument window.

Click the name of the sound (synthesizer patch) that you want to use. Click the close
button at the top-left corner to close the window, or press Command-W. For further
details about this window, including customization of patch names, see The
Multi-Instrument Window.

To the right of the program number is an extra parameter that is used for Bank Select.
If your sound source receives Bank Select messages (MIDI controller #0 or #32—check
your synth manual for format details), you can switch between different banks, each
containing a maximum of 128 sounds.

For information on other instrument parameters, see Standard Instrument Objects.

• Delay > Auto Compensated Delay Offset: This is the same as the Delay > Delay in
Milliseconds setting, except that the current plug-in latency compensation plus the
audio hardware output delay is added to the MIDI data transmission. This setting is
ideal when the outputs of classic MIDI sound sources are mixed with Logic Pro’s outputs
using an external mixing desk. Using the Auto Compensated Delay Offset setting makes
sure that audio from Logic Pro and audio from the MIDI-controlled external hardware
appears on the external mixing desk at the same time. When this setting is chosen, the
parameter label changes from “Delay” to “Auto Delay.”
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Inserting Program Change, Volume, and Pan as MIDI Events
The MIDI > Insert Instrument MIDI Settings as Events command allows you to insert the
program change, volume, and pan settings (from the Track Parameter box in the Inspector)
as actual MIDI events into one or more selected MIDI regions. The events are placed a
quarter note before the beginning of the relevant MIDI regions. Only the activated
(selected) settings in the Track Parameter box(es) are added as events. If any events of
the same kind already exist in the region(s), they are overwritten.

The values of the Program, Volume, and Pan parameters are not updated every time such
control change events are played back. These parameters are initial values—when you
load a project, or choose the MIDI > Insert Instrument MIDI Settings as Events
command—before you begin to record mixer automation data.

Processing External MIDI Instruments with Effects
You can route external MIDI sound generators through the Logic Pro Mixer, allowing you
to process them with Logic Pro effects. This is achieved through use of the External
Instrument plug-in. Ideally, you use a multi-input and output audio interface, to avoid
constant repatching of devices.

To process external MIDI instruments with effects
1 Connect the output (or output pair) of your MIDI module with an input (pair) on your

audio interface.

Note: These can be either analog or digital connections if your audio interface and effects
unit are equipped with either, or both.

2 Create a software instrument track.

3 Click the Instrument slot of the software instrument channel strip, then choose External
Instrument from the pop-up menu.

4 Choose a multi-instrument sub-channel from the MIDI Destination pop-up menu.

5 Choose the input (of your audio interface) that the MIDI sound generator is connected
to from the Input pop-up menu.

6 Adjust the Input Volume, if necessary.
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7 Insert the effects in the Insert slots of the channel strip.

As the track is routed to an instrument channel strip (which is being used for an external
MIDI sound module), it behaves just like a standard software instrument track, which
means that you can record and play back MIDI regions on it—with the following benefits:

• You can take advantage of the sounds and synthesis engine of your MIDI module, with
no overhead on your system processor (apart from the effects used on the channel
strip).

• You can use insert effects, obviously, but can also use Send effects by routing the
instrument channel strip to aux channel strips.

• You can bounce your external MIDI instrument parts—with or without effects—to an
audio file, in real time. This makes the creation of a mix, inclusive of all internal and
external devices and tracks, a one-step process.

Note: You cannot use the Freeze function on such tracks, nor can you perform an offline
bounce.

Playing Software Instruments
Software instrument plug-ins respond to MIDI note messages, whereas effect plug-ins
do not.

The output signal of a software instrument is fed into the input (the Instrument slot) of
the instrument channel strip, where it can be processed via inserted effect plug-ins, or
sent to busses.

Logic Pro supports up to 255 discrete instrument channel strips. The number of software
instruments that you can run simultaneously depends on the computer-processing
resources available.

After an instrument plug-in is inserted, the instrument channel strip can be driven by a
recorded MIDI region, or direct MIDI input—playing your MIDI keyboard, in other words.

Understanding Live Mode
Live mode instruments need to stay in Live mode while the audio engine is running
(when Logic Pro is in playback or record mode), because switching a software instrument
track out of Live mode creates a gap (or noise) in the audio stream. Obviously, this is
unacceptable.

Software instruments that are live (ready for playing) require considerably more processing
power than those that are merely playing back existing regions. If selecting a software
instrument track automatically activates Live mode, switching between multiple instrument
tracks would compound the problem, possibly resulting in system overloads.
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The Record button of selected software instrument tracks gives visual feedback of the
current state of a software instrument:

Selected instrument, not 
yet in live mode

Instrument in live mode

Switching Instruments to Software Instrument Live Mode
When you select a software instrument track, it does not immediately switch into Live or
Performance mode. You must send a MIDI event before Live mode is activated, but this
takes around 100 milliseconds to engage, which is more than enough time to destroy
the timing of your first played note.

If you require perfect timing for the first played note, you need to send silent MIDI events
in advance; press the sustain pedal, or make a small move of the pitch bender or
modulation wheel, for example. This will turn on Live mode.

Saving Software Instrument Processing Resources
The Bounce function allows the entire instrument track to be recorded as an audio file.
This bounced audio file can then be used (as an audio region) on a standard audio track,
allowing you to reassign the available processing power for further software instrument
tracks. For more details, see Bouncing Your Project.

You can also make use of the Freeze function to capture the output of a software
instrument track, again saving processing power. For details, see Freezing Tracks in the
Arrange Area.
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Tuning Software Instruments
The File > Project Settings > Tuning > Software Instrument Pitch parameter remotely
controls the main tuning parameter for all software instruments (the ES1 or EXS24 mkII,
for example) by ±50 cents.

By default, it is set to concert pitch A at 440 Hz. Simply drag the slider to the value you
want. As you do, the cent and Hz values update.

Note: Some Audio Units instruments do not recognize this remote command.

Logic Pro allows all software instruments to be globally tuned to different tempered
scales, including Hermode Tuning. (See What Is Hermode Tuning?) However, there may
be occasions when you want individual software instruments to be exempt from this
global tuning system.

To exempt individual software instrument tracks from following the global Hermode
Tuning scale

1 Open Tuning project settings by doing one of the following:

• Choose File > Project Settings > Tuning (or use the Open Tuning Project Settings key
command).

• Click the Settings button in the Arrange toolbar, then choose Tuning from the pop-up
menu.
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2 Click the Hermode Tuning (HMT) button.

A No HMT checkbox appears in the Track Parameter box of all instrument channel strips.

3 Select this checkbox to prevent the selected software instrument track from following
the global Hermode Tuning scale.

This feature is ideal for an EXS drum kit that you don’t want tuned like your melodic
software instrument parts, for example.

Working with ReWire Applications
Logic Pro acts as a host for ReWire applications such as Propellerhead Reason.
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Important: Start Logic Pro first, then start your ReWire application(s).

When these applications are open alongside Logic Pro, synchronized audio information
is routed out of them into aux channel strips in the Logic Pro Mixer, where it can be
combined with other tracks, run through effects, and bounced to new audio files.

In essence, the output of these ReWire programs is handled in much the same way as
you handle internal Logic Pro audio data. Synchronization is automatic, so you don’t really
need to do much to ReWire the applications, beyond setting up aux channel strips, if
desired.

In addition to routing the outputs of ReWire applications into Logic Pro, you can also
directly play, record, and play back the software instruments available in these programs.
Propellerhead Reason, for example, is the software equivalent of a rack of synthesizers
and samplers.

You can directly play each synthesizer in the Reason rack, and can record these parts as
MIDI regions on Logic Pro tracks, much as you would with Logic Pro’s internal, or external
MIDI, instruments.

To access a ReWire instrument
1 Select an External MIDI track in the Arrange area.

2 Double-click the ReWire application name in the Library tab (Reason, for example).

The ReWire application opens, and a list of all available ReWire instruments appears in
the Library.

3 Click an instrument track in the Library.

To manually set up an aux channel strip for ReWire use
1 Click the Mixer button at the bottom of the Arrange window.
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2 Choose Options > Create New Auxiliary Channel Strips in the Mixer’s local menu bar.

3 Create as many aux channel strips as required, with the appropriate Format, Input, and
Output settings. For this example, create a stereo channel strip, routed to Input/Outputs
1–2.

4 Choose the ReWire channel in the Input menu of the aux channel strip.

Individual RW Channel entries are available in the Channel menu. These can be assigned
individually, to allow each ReWire channel to be routed to a particular aux channel strip
in the Logic Pro Mixer. This provides extended mixing and processing options.

To set the ReWire behavior
1 Open Audio preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, and choose Audio from the pop-up
menu.

2 In the Devices pane, choose one of the following from the ReWire Behavior pop-up menu:

• Playback Mode (Less CPU Load): Use this mode when streaming channels via ReWire.
This setting requires less processing power, and should be used when playing back
tracks in ReWire applications.

• Live Mode (Higher CPU Load): Use this mode when you want to play a ReWire instrument
(an instrument running in an external ReWire application) in real time. This setting
requires more system resources, but reduces latency, ensuring that the ReWire
instrument is playable.

Working with External Audio Effects
External audio effects units can be used similarly to the internal Logic Pro effects. You do
this with the I/O plug-in, in conjunction with a multi-input/output audio interface.

To integrate and use an external effects unit in Logic Pro
1 Connect an output (or output pair) of your audio interface with the input (pair) on your

effects unit.
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2 Connect the output (or output pair) of your effects unit with an input (pair) on your audio
interface.

Note: These can be either analog or digital connections if your audio interface and effects
unit are equipped with either, or both.

3 Click an Insert slot of the channel strip you want to process with the external effects unit,
then choose Utility > I/O.

4 In the I/O plug-in window, choose both the Output and Input (shown as numbers) that
your effects unit is connected to.

5 Adjust the Input or Output volume as required.

6 Click the Latency Detection (Ping) button If you want to detect, and compensate for, any
delay between the selected output and input.

When you start playback, the signal of the audio channel strip is processed by the external
effects unit.

Some audio interfaces feature their own routing software, which you may need to use
to set up the chosen inputs and outputs for this type of use. Consult the documentation
provided by your audio interface manufacturer.

Most hardware effects units are MIDI-controlled. If this is the case with your effects unit,
you can connect its MIDI input and output cables to your MIDI interface. This allows you
to choose effects presets, and may also allow you to remotely control, record, and
automate the parameters of the effects unit from Logic Pro.
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Using Plug-ins from Other Manufacturers
Logic Pro can act as a host for (compliant, correctly installed and authorized) Audio Units
effect and instrument plug-ins from other manufacturers. Logic Pro can also control TDM
plug-ins when Pro Tools audio hardware is used. Details on the use of TDM plug-ins can
be found in the Logic Pro TDM Guide.

Important: Logic Pro cannot act as a host for plug-ins in VST or RTAS format. There are,
however, utilities such as the VST to Audio Units Adapter (http://www.fxpansion.com),
that “wrap” Mac OS X versions of VST plug-ins to create virtual Audio Units. Once wrapped,
most of these plug-ins behave, and can be used, just like Audio Units.

Loading Presets
Many plug-ins from other manufacturers use a proprietary storage format for their presets
(the equivalent of Logic Pro plug-in settings).

In most cases, a separate Preset (or similarly named) menu will be available in the plug-in
interface. Once loaded, you can save any of these presets as a Logic Pro setting.

In all cases, the global Compare, Copy, and Paste options of the plug-in window header
will work as they do with the native plug-ins of Logic Pro.

Working with the Audio Units Manager
Logic Pro uses the Apple AU Validation Tool to ensure that only plug-ins that fully comply
with the Audio Units specification are used in Logic Pro. This minimizes problems that
may be caused by third-party Audio Units plug-ins.

The validation process takes place automatically when:

• Logic Pro is first opened.

• An updated version of Logic Pro is installed.

• You install new Audio Units plug-ins, or update existing ones.
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You can see the results of the validation scan (for all Audio Units and “wrapped” VST
plug-ins) in the Compatibility column of the Audio Units Manager window.

Important: The first thing you should do is check the manufacturer’s website for updated
versions of Audio Units plug-ins that fail validation.

To open the Audio Units Manager
µ Choose Logic Pro > Preferences > Audio Units Manager in the main menu bar (or use the

Audio Units Manager key command).

Manually Enabling Plug-ins
Audio Units plug-ins that fail the validation test can be manually activated by selecting
the checkboxes in the Logic and Nodes columns—but be aware that these plug-ins can
cause problems.
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If you encounter problems with manually activated failed plug-ins, click the Disable Failed
Audio Units button in the Audio Units Manager window.

Warning: Use of plug-ins that have failed the validation can negatively affect the test
results of subsequently scanned plug-ins. They can also prevent Logic Pro from opening,
cause it to quit unexpectedly, or even lead to data loss (destroyed project files).
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Disabling Plug-ins
The Audio Units Manager also allows you to disable Audio Units plug-ins that you don’t
want to use in Logic Pro, even if they pass the validation scan. Simply deselect the
corresponding checkbox in the Logic or Nodes column to disable any plug-in. You can
store your choice of Audio Units plug-ins by clicking the Done button.

Click the Reset & Rescan Selection button to rescan a selection of plug-ins after installing
plug-ins/updaters or moving components in the Finder, while Logic Pro or the Audio Units
Manager is open. They will be activated automatically, if they pass the validation scan.

Note: If you press Control-Shift while opening Logic Pro, the Audio Units Safe mode will
be used. Only plug-ins that pass the validation test will be available; manually activated
plug-ins that failed the validation test will not be available.
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Prerecorded media plays an important role in modern audio production. Combining
existing audio loops and other files provides a quick method for laying down project
foundations. Logic Pro comes with a large collection of audio loops, offering a great
starting point for many of your projects. This chapter explains how you can add
prerecorded media in Logic Pro, including audio and MIDI files, Apple Loops, and other
common loop formats.

This chapter covers the following:

• Learning About File Formats Supported by Logic Pro (p. 317)

• Accessing Media Files in the Browser (p. 319)

• Finding Apple Loops in the Loop Browser (p. 325)

• Adding and Removing Audio Files (p. 335)

• Adding MIDI and Project Files (p. 343)

Learning About File Formats Supported by Logic Pro
Logic Pro allows you to access any digitally stored audio recordings (audio files) on your
hard disks, in the most common Mac, and several other, file formats.

Audio files imported into a Logic Pro project can be at any supported bit depth and
sample rate. Logic Pro supports bit depths of 16, 20, and 24 bits, and sample rates of 44.1,
48, 88.2, 96, 176.4, and 192 kHz. Logic Pro can use the file’s sample rate, or can perform
a real-time sample rate conversion. See Setting the Project Tempo.

In addition to audio files, Logic Pro can also import MIDI and project information.

The following describes all file formats supported by Logic Pro:

WAVE and AIFF Files
Wave (WAV) and Audio Interchange File Format (AIFF) audio files are very similar. They
can be stored at different bit depths (16 and 24 bit are supported by Logic Pro), in mono,
stereo, or surround, and at sample rates up to 192 kHz.
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Logic Pro also supports Broadcast Wave files, which can contain timestamp information.
Files that provide timestamp information can be recognized by a clock symbol, shown
alongside the audio region name in the Audio Bin.

The file extension of broadcast wave files is .wav, allowing them to be read by any
application that supports the standard wave file format. In such programs, the additional
Broadcast Wave file information is ignored.

Core Audio Format Files
Core Audio Format (CAF) files are containers that support integer and float PCM formats,
A-law, u-law, and a number of others including AAC and the Apple Lossless Audio Codec
(ALAC). Unrestricted file sizes are possible, at high sample rates and bit depths.

Sound Designer Files
Sound Designer I and II (SDII) audio files are similar in structure to AIFF files, and can
contain timestamped region information. Use of Sound Designer format files can make
transfers between Logic Pro and Digidesign Pro Tools software more convenient.

MP3, Apple Lossless, and AAC Files
MP3 and AAC files contain compressed audio information. They are usually far smaller
than equivalent WAV, AIFF, or SDII files. This reduction in file size is due to different
encoding techniques that “throw away” some of the audio information. As a result, MP3
and AAC files do not sound as good as their WAV, AIFF, or SDII audio counterparts,
depending on the source audio material.

Apple Lossless files also contain compressed audio information. As the name suggests,
the compression used (ALAC) does not discard audio information in the same fashion as
MP3 files. The sound of the compressed audio file is identical to the original recording.

Apple Loops
Apple Loops are audio files that contain additional identification information:  time and
date, category, mood, key and tempo, amongothers. They also contain a number of
transient markers, which break them down into small time slices. The main advantage of
Apple Loops audio files is their ability to automatically match the tempo and key of a
Logic Pro project.

A second Apple Loops file type is also supported by Logic Pro. These contain MIDI note
information that triggers a musical phrase or riff. The motif will be played, as is, when
these types of Apple Loops are added to an audio track. When added to an instrument
track in Logic Pro, however, the MIDI note information can be edited, as you would with
any MIDI region.
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ReCycle Files
ReCycle (REX, RCY) files are generated in Propellerhead ReCycle software. These are similar
to Apple Loops audio files, in that they contain a number of slices, and match the project
tempo. When imported, a small folder that contains several regions—one for each slice—is
created. Each of these slice regions can be handled like any audio region. ReCycle files,
unlike Apple Loops files, do not follow the project key.

Standard MIDI Files
Standard MIDI files (SMF) are a standard file format used in MIDI sequencers. They can
be read and saved in Logic Pro. SMFs may contain note, lyric, controller, and SysEx data.
They are added to MIDI or software instrument tracks in Logic Pro.

Note: Logic Pro can also import GarageBand, OMF Interchange, AAF, OpenTL, and XML
files. These file types are usually used to exchange projects, however, and are therefore
outside the scope of this chapter. Full details on importing these file types can be found
in Project and File Interchange.

Accessing Media Files in the Browser
You first need to locate your audio and other files, before you can add them to your
projects. The Browser is your first port of call for browsing, previewing, and searching for
prerecorded media.

Note: While all supported media types can be accessed in the Browser, Apple Loops are
best handled in the Loop Browser. See Finding Apple Loops in the Loop Browser.

To access the Browser in the Arrange window
µ Click the Media button in the Arrange toolbar, then click the Browser tab (or use the

Toggle File Browser key command, default assignment:  F).
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Navigating in the Browser
You can switch the Browser between two views:  List view and Column view.

List view Column view

• List view displays folders and their contents in a list. You open a folder by double-clicking
it.

• Column view exposes the contents of a folder in new frames to the right of the selected
folder. You only need to click a folder once to open it.

To switch between List view and Column view
µ Click the List button to access List view. Click the Column button to access Column view.

Column buttonList button

Navigation in the Browser is much like using the Mac OS X Finder. The method of
navigation is the same for all file types. The bookmark buttons, Path pop-up menu, and
Back and Forward buttons aid navigation.
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To navigate in the Browser using the bookmark buttons
µ Click one of the bookmark buttons:  Computer, Home, or Project.

• Computer: Shows all volumes (hard disks, CDs, or DVDs) in, or attached to, the computer.

• Home: Shows all folders in your home folder.

• Project: Shows the contents of your project folder.

To navigate in the Browser using the Path pop-up menu
1 Click the Path pop-up menu to display the path taken to the current folder or file.

2 Click one of the entries in the Path pop-up menu to navigate back to the clicked folder.

To step backward or forward through the navigation history
µ Click the Back button or the Forward button.

Searching for Files in the Browser
The Browser tab features a very sophisticated (and fast) search feature. You can use it to
find any type of file supported by Logic Pro, on local or network attached storage devices.

To perform a basic search in the Browser
1 Click the Path pop-up menu (alone, or in conjunction with the bookmark buttons) to

determine what you want to search:  a particular folder, the entire hard disk, user root,
the computer, and so on.
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Restricting the search to a particular folder or volume speeds things up.

2 Type the search term into the search field and press Return.

Tip: For example, typing in “80s,” with Macintosh HD chosen in the Path pop-up menu,
results in a number of Apple Loops files being displayed in the view area.

To sort the search results
µ Click any of the column titles to sort the file list by name, date, or size.

You can resize columns by dragging the vertical lines between column titles.

To clear a search term
µ Click the small X icon at the right side of the search field.

To view recent search terms
1 Click the magnifying glass icon at the left side of the search field.
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2 Choose any search term from the menu to display the search results.

To clear all recent search terms
µ Click the magnifying glass icon at the left side of the search field, then choose Clear Recent

Searches from the pop-up menu.

To perform an advanced search
1 Click the Path pop-up menu (alone, or in conjunction with the Computer, Home, and

Project buttons) to determine what you want to search.

2 Click the plus (+) icon to the right of the search field.

This expands the search area. The pop-up menus shown in the expanded search area are
used to narrow down, or restrict, your search to specific file types, file formats, date, size,
and other criteria.

By default, the Match pop-up menu specifies that all of the advanced search conditions
that you specify must be met, in order to display matching files. You can set the Match
pop-up menu to “any” if you want to display all files that match one of the specified
conditions.

3 Click the File Type pop-up menu, and choose Format.

Note that the right pop-up menu updates (AIFF is displayed) to reflect the left pop-up
menu selection.

4 Click the + icon to the right of the pop-up menu displaying AIFF.

A further set of search condition pop-up menus is shown below.

5 Click the File Type pop-up menu in this second row of search conditions, and choose
Length.

The updated right field and pop-up menu displays 30.0 sec.

6 Highlight the 30.0 field, and type 8.

7 Now click the search field, input the search term, and press Return.

A much shorter list of AIFF files, with a length of 8 seconds, and a name that contains the
search term is shown.
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To remove a single advanced condition row
µ Click the minus (–) icon beside the row.

This feature is handy when you’ve been a little too specific in your searches, and have
received no search results.

Note: The row is hidden and deactivated, rather than removed completely. It can be
restored by clicking the + icon to the right of the row.

To return to a basic search, when several advanced condition rows are shown
µ Click the – icon to the right of the search field.

All advanced condition rows are hidden.

To restore all advanced search condition rows
µ Click the plus + icon to the right of the search field.

Refining Your Searches Using Conditions
Searching for a particular file in the Browser can be much faster than navigating to it. You
can define up to ten advanced condition rows to refine your searches. The search rows
offer the following conditions.

Additional pop-up menus/fieldsSecond menuFirst menu

Input fieldcontains, does not
contain, is, is not, starts
with, ends with

Comment

Pop-up menu, in which you can choose between
Audio, Movie, Project

is, is notFile Type
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Additional pop-up menus/fieldsSecond menuFirst menu

Pop-up menu, in which you can choose between
the following options:  AIFF, Apple Loops,
WAV (BWF), Apple Lossless, AAC, MP3, CAF,
Sound Designer I, Sound Designer II, Logic Project,
MIDI File, ReCycle, OMF File, AAF File, Open TL File,
XML File, Notator SL Song
Note that AIFF format searches do not include
Apple Loops.

is, is notFormat

• Numerical input field
• Additional pop-up menu in which you can

choose between seconds, minutes, and hours

is, is not, is less than, is
greater than

Length

Input fieldis, is not, after, beforeModified Date

Input fieldcontains, does not
contain, is, is not, starts
with, ends with

Name

Pop-up menu, in which you can choose between
the following options:  44.1 kHz, 48 kHz, 88.2 kHz,
96 kHz, 176.4 kHz, 192 kHz

is, is not, is less than, is
greater than

Sample Rate

• Input field
• Additional pop-up menu, in which you can

choose between bytes, kilobytes, megabytes,
gigabytes, terabytes

is, is not, is less than, is
greater than

Size

Pop-up menu, in which you can choose between
8 Bit, 16 Bit, and 24 Bit

is, is not, is less than, is
greater than

Bit Depth

Finding Apple Loops in the Loop Browser
The Loop Browser only displays Apple Loops format files. You can search for Apple Loops,
using keywords for instrument, genre, mood, and other descriptors. You can also browse
for Apple Loops in the Loop Browser.

In comparison with standard audio loops, Apple Loops have a significant advantage:  they
can contain additional information that Logic Pro uses for a variety of purposes, including
automatic time and pitch shifting, indexing, and searching.

Two important data types that Apple Loops may include are metadata tags and transient
markers. Logic Pro uses metadata tags to help locate files when using the Search features
of the Loop Browser. Transient markers indicate where beats occur in the file. Logic Pro
uses this information, in conjunction with the metadata tags, to match the file’s tempo
and key to the project tempo and key, thus ensuring the best possible playback quality.
This functionality allows you to play back several Apple Loops simultaneously, and have
them sound good, even if they have different tempos and keys.
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To access the Loop Browser in the Arrange window
µ Click the Media button in the Arrange toolbar, then click the Loop tab (or use the Toggle

Loop Browser key command, default assignment:  O).

Understanding Green and Blue Apple Loops
The Loop Browser contains two types of Apple Loops:  those featuring a blue sound wave
icon and those with a green note icon.

Green and blue Apple 
Loops in the Loop 
Browser

Both contain audio data, and both can contain additional information for time stretching,
transposition, indexing, and searching.
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Green and blue Apple Loops can be added to audio tracks, or directly to an empty Arrange
area or track. In the Arrange area, they look like normal audio regions, but can be easily
identified by the Apple Loops symbol in the upper-right corner. They differ from standard
audio regions in that they follow the project key and tempo.

Stereo Apple Loop 
symbol

Mono Apple Loop 
symbol

You can drag blue (audio) Apple Loops directly into a blank Arrange window (with no
tracks), or to a blank area below existing tracks. An audio track and corresponding channel
strip are automatically created, and the Apple Loops region (that is the full length of the
file) is placed on the track. In addition, the Apple Loops file is added to the Audio Bin,
and a corresponding region is automatically created.

Green Apple Loops are known as Software Instrument Apple Loops (SIALs). They differ from
the blue (audio) Apple Loops in that they also contain a MIDI region plus software
instrument and effect settings.

When Software Instrument Apple Loops are placed on instrument tracks, the region shown
in the Arrange area can be edited just like other MIDI regions, including individual note
editing.

Green Apple Loop placed on 
a software instrument track

If dragged onto a blank instrument track (one with an empty channel strip), the
corresponding instrument and effect(s) settings are automatically inserted.

You can also drag Software Instrument Apple Loops directly into a blank Arrange window
(with no tracks), or to a blank area below existing tracks. An instrument track and
corresponding channel strip are automatically created, and the Apple Loops file is loaded
(the instrument is inserted into the instrument channel, along with any effects, and the
Apple Loops region is placed on the track).
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When you place Software Instrument Apple Loops on audio tracks, they are imported as
audio regions (and behave like blue Apple Loops). The processing load is reduced when
green Apple Loops are added to audio tracks.

Note: Blue Apple Loops will not play if placed on instrument tracks.

Setting Limitations Before Browsing for Apple Loops
When thousands of loops are installed on your hard disks, finding a particular Apple Loops
file can be a rather daunting prospect. Fortunately, a number of options allow you to
restrict your searching or browsing results with a number of key criteria.

These can be used in conjunction with each other, and directly affect the results of the
browsing and search features available in the Loop Browser.

To limit the loop display to a particular Jam Pack or other category
µ Choose a setting from the View menu. You can choose between:

• Show All: Choose this default option to display all Apple Loops on your system. This
option is handy if you are unable to locate a loop that you know is installed and indexed
on your system, but do not know what Jam Pack it belongs to.

• My Loops: Choose this option to display all Apple Loops in the
~/Library/Audio/Apple Loops/User Loops/Single Files folder (~ denotes the username).

• Shared Loops on my Mac: Choose this option to display all Apple Loops in the
/Library/Audio/Apple Loops/User Loops/Single Files folders. This setting is only visible
if Apple Loops are shared with GarageBand on your system.

• GarageBand: Choose this option to display all Apple Loops installed with GarageBand.

• Jam Pack x: Choose this option to display all Apple Loops from a specific Jam Pack. Jam
Packs are professionally created genre or instrument-specific Apple Loops collections,
available from Apple.

• Vendor x: Choose this option to display all Apple Loops from a specific third-party
vendor.

• Other: Choose this option to display all loops that you manually added to the loop
library by dragging them into the Loop Browser.

To limit the Loop Browser display to a particular scale
µ Open the Scale pop-up menu, and choose from Any, Minor, Major, Neither, and Good for

Both.

Use of these options limits the search for Apple Loops to the selected scale type, within
the chosen category. For example, if Country, Acoustic, and Relaxed categories were
selected, you would be presented with 20 or so files that matched your choices. Selection
of the Minor Scale setting would reduce this list to ten possible Apple Loops, making the
task of auditioning and selecting the most appropriate material faster.
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To limit the Loop Browser display to a particular time signature
µ Choose a time signature from the Signature pop-up menu.

Browsing for Apple Loops
There are three browsing views available in the Loop Browser:  Column view, Music view,
and Sound Effects view.

To switch between browsing views
µ Click one of the view buttons at the top-right corner of the Loop Browser.

The left button activates Column view, the middle button activates Music view, and the
third button Sound Effects view.

Music view displays a matrix of 54 buttons, each featuring a musically related category.
Sound Effects view offers effect-related category buttons such as Explosions, Foley, or
People.

Music view Sound Effects view
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Column view offers a standard Mac OS X column file directory that is hierarchically
separated into All, By Genres, By Instruments, By Moods, and Favorites search criteria.

Category columns

To browse for Apple Loops in Column view
1 Click any of the category folders shown in the left column.

In this example, By Genres is chosen.

2 Click Electronic in the second column.

3 Click Beats in the third column.
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The value in brackets indicates the number of files that fall into this subcategory (Beats).
The files are shown in the file list below.

To browse for Apple Loops in Music view and Sound Effects view
1 Click any of the category buttons.

The file list displays all Apple Loops that fall into the chosen category. The number of
matching files is shown at the bottom of the Loop Browser.

2 Click another category button.

The file list updates to display all Apple Loops that fall into both categories.

3 Click another category button to further refine categorization.

The number of files that match all three criteria (Guitars, Acoustic, and Country) is further
reduced.

Note: A second click on any chosen category button deselects it.
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As you can see from this example, the use of multiple category buttons makes it easy to
restrict the number of Apple Loops that are shown in the file list. This, in turn, makes the
task of finding an Apple Loops file that has a particular vibe or flavor much simpler.

To clear all category selections
µ Click the Reset button to clear all selected category buttons.

You can replace a displayed category via the shortcut menu that opens when you
Control-click (or right-click) any category button.

To customize Music view or Sound Effects view
µ Control-click (or right click) any category button, then choose from:

• Genre: This submenu offers musical categories, such as Rock/Blues and Electronic.

• Instruments: Bass, FX, Vocals, and the Textures and Jingles settings are available, among
others.

• Descriptors: The items in this submenu cover the mood of Apple Loops, and include
Dark, Relaxed, Grooving, and others.

Auditioning Apple Loops
Regardless of the browsing (or searching) method used to find Apple Loops, you can
preview the results in the Loop Browser.

To audition Apple Loops
1 Click any filename in the Search Results list.

It starts playing automatically in a continuous loop.

2 Click another filename, and it starts playback.

The Apple Loops file that was playing stops. Only one Apple Loops file can be auditioned
at a time.

To adjust the playback level
µ Drag the level fader at the bottom of the file view area.

To adjust the playback key
µ Open the “Play in” pop-up menu to the right of the level fader at the bottom of the file

view area, and choose a key.
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This defaults to the project key, but you can also choose to audition the loop in its original
key or any key from C to B.

To stop playback
µ Click the speaker icon to the left of the selected Apple Loops filename.

Sorting Apple Loops
You can sort the results of your Apple Loops search or browsing using the following
categories:

• Name column: Displays Apple Loops by name.

• Tempo column: Displays Apple Loops by tempo.

• Key column: Displays Apple Loops by key.

• Beats column: Displays Apple Loops by beats.

• Match column: Displays Apple Loops as a percentage match between the project tempo
and the Apple Loops original tempo. For example, an Apple Loops file with an original
tempo of 100 bpm offers a match of 94% for a project tempo of 104 bpm.

• Fav column: Displays an active checkbox for those Apple Loops that are marked as
Favorites, and therefore part of your Favorites category.

To sort Loop Browser results
Do one of the following:

µ Click any of the column titles to sort the list of results by that column type.

µ Click the arrow in any selected column title to sort the list in ascending or descending
order (alphabetical, tempo, key, beat, match percentage, or favorite).

Tip: You can freely swap column positions by dragging the column name field, and
moving it left or right. Column widths can be resized by dragging the vertical lines that
separate the column name fields.
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Creating a Collection of Your Favorite Apple Loops
The Fav (Favorites) column offers a checkbox for every displayed loop. Simply select this
box to add the loop to the Favorites category.

This feature is ideal for compiling a collection of Apple Loops that you use regularly. As
a producer of dance floor music, you may often construct projects by starting with drum
loops. You could conceivably have a basic four on the floor kick pattern, eighth and
sixteenth note hi-hats, two or four beat snare or clap patterns, and so on, and use these
favorite loops as a groove construction kit—at least while creating your shell arrangement.

These loops can be replaced or added to easily as your project advances, but the use of
favorites may form a great starting point for many of your songs.

Searching for Apple Loops
The search field is used to find Apple Loops by name or partial name. It works in
conjunction with the options discussed in Setting Limitations Before Browsing for
Apple Loops.

Search menu

Cancel button

To search for an Apple Loops file
µ Enter a search term into the search field, and press the Return key.

The search term can be alphabetical or numerical. Any files that match your search term
are displayed in the file list.

The Cancel button to the right (which appears as soon as any text is entered) clears any
entered text. It also clears the search history.

The Search menu to the left (the magnifying glass) retains a history of recently used search
terms. Click it to select a previous search term.
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Adding and Removing Audio Files
You can add audio directly to the Arrange area, or to the Audio Bin, using any of the
methods covered in this section.

• The Audio Bin acts as a central repository for all audio files added to the project, whether
or not they are used in the Arrange area. This is useful for keeping all takes associated
with the project in one location, even if not all are actually used in the final production.

• When you add audio files to the Arrange area, they are automatically added to the
Audio Bin—and they appear as audio regions in your arrangement. These regions have
a default length that encompasses the entire audio file. You can resize, cut, and move
these regions in the Arrange area.

All methods outlined in this section can be used to import WAV, AIFF, CAF, MP3, SDII,
AAC, Apple Lossless, and Apple Loops files.

Apple Loops offer a few special features when added to your arrangement. For details
see Understanding Green and Blue Apple Loops.

ReCycle files are handled differently. See Adding ReCycle Files to Your Project.

Adding Audio Files to Your Arrangement
You can use any of the following methods to add audio files directly to your arrangement:

• Shift-click at any position on an arrange audio track with the Pencil tool.

• Use the Import Audio File command.

• Simply locate (browse to or search for) the specific filenames in the Browser, Audio Bin,
or Loop Browser—or the Mac OS X Finder—and drag them into the Arrange area.
Double-clicking a filename in the Browser adds the file at the current playhead position
on the selected arrange track.

To add audio files to your arrangement using the Pencil tool
1 Select the Pencil tool in the Arrange area.

2 Shift-click an audio track at the appropriate Arrange area position.

3 Browse to and select the file that you want to insert in the Open File dialog.

4 Click the Play button to preview the selected audio file.

The Play button is renamed Stop. Click it to halt playback.

5 Click the Open button to add the file to the selected track, at the clicked position, in the
Arrange area.

To add audio files to your arrangement using the Import Audio File command
1 Select an audio track in the Arrange area.

2 Choose File > Import Audio File (or use the corresponding key command).

3 Browse to and select the file that you want to insert in the Open File dialog.
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4 Click the Play button to preview the selected audio file.

The Play button is renamed Stop. Click it to halt playback.

5 Click the Open button to add the file to the selected track, at the playhead position, in
the Arrange.

To add an audio file to your arrangement by dragging
µ Drag the file directly onto an audio track in the Arrange area from either the Browser,

Loop Browser, or the Finder.

You can drag audio files onto all track types, but playback is only possible on audio tracks.

Note: You can drag audio files directly into a blank Arrange window (with no tracks), or
to a blank area below existing tracks. An audio track and corresponding channel strip are
automatically created, and an audio region (that is the full length of the file) is placed on
the track. In addition, the file is added to the Audio Bin, and the corresponding region is
automatically created.

To add multiple audio files to your arrangement by dragging
1 Shift-click contiguous files, or Command-click noncontiguous audio files in the Audio Bin,

Finder, or Browser.

2 Drag them to the Arrange area position, and release the mouse button.

Note: If adding files from the Audio Bin, you can also use the Audio File > Add File to
Arrange menu item. The playhead position determines where the first audio region is
created.

3 Select any of the following options shown in the Add Selected Files to Arrange dialog:

• Create new tracks: Creates new tracks (and audio channel strips) for each dragged file.

• Use existing tracks: Sequentially places the dragged files (as regions) onto existing tracks,
starting with the currently selected track. For example, if three audio files are dragged
into the Arrange area (where track 4 is selected), the first file is placed on track 4, and
the following two files are placed on tracks 5 and 6.

• Place all files on one track: All files are placed sequentially (one after the other) on the
track they are dragged to.
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• Copy audio file names to track names: Uses the filenames to rename tracks. This option
is only available when used in conjunction with the “Create new tracks” and “Use
existing tracks” functions.

• Create new audio regions: Adds the files to the Arrange area, and creates a new audio
region for each. A numeric value is appended to each audio region in the Arrange area,
and a new region is created for each file in the Audio Bin. For example, a region called
folk-04 will become a new region called folk-04.1. The original region will be retained
in the Audio Bin (and Arrange area, if used).

Adding and Removing Project Audio Files
The Audio Bin acts as a central repository for all audio files added to the project, whether
or not they are used in the Arrange area. This is useful for keeping all takes associated
with the project in one location, even if not all are actually used in the final production.

All audio file addition methods covered above will automatically place the files in the
Audio Bin. For methods that add files directly to the Arrange area, a region associated
with the file is automatically created in the Audio Bin.

The Audio Bin also provides functions that allow you to add files to your project (into the
Audio Bin), and from the Audio Bin into the Arrange area.

To use the Browser or Finder to add audio files to your project
1 Shift-click contiguous files, or Command-click non-contiguous audio files in the Finder

or Browser.

2 Drag them into the Audio Bin, and release the mouse button.

Note: If adding files from the Browser, you can also choose Add Selected Audio File to
Bin in the action menu.

To use the Audio Bin to add one or more files to your project
1 Choose Audio File > Add Audio File (or use the corresponding key command, default

assignment:  Control-F).
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The dialog below opens.

2 Browse to and select an audio file.

You can audition it by clicking the Play button.

3 Click the Add button.

The file is shown in the file view area below.

4 Browse to, and select, another audio file, and click the Add button.

5 Repeat the process until all desired files are in the file view area.

6 If you accidentally add a file, select it in the file view area, and click the Remove button.

Note: You can also add all files in a folder by selecting the folder and clicking the Add All
button. If you accidentally add all files from the wrong folder, press the Remove All button
to remove them from the list. This does not remove them from the hard disk.

7 Click Done to add the selected files to the Audio Bin.

Note: Files that have already been added to the Audio Bin are dimmed, and cannot be
selected. This helps to avoid confusion, and duplication.
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To remove one or more files from the current project
1 Select the filenames in the Audio Bin.

2 Press Delete.

The file is deleted from the project, but not from the hard disk. The only way that you can
totally remove an audio file from a project is in the Audio Bin. Removing an audio region
in the Arrange area (Eraser tool, pressing Delete) does not remove it from the project—it
merely removes the reference to the audio file.

Warning: Take extreme care when using the Audio File > Delete File(s) command (or
key command, default assignment:  Control-Delete). This not only deletes the selected
file from the project, but also from the hard disk. Deleted audio files are moved to the
Trash—where they remain until you empty the Trash.

Importing Compressed Audio Files
Logic Pro allows you to directly play back the following compressed audio file formats:

• AAC

• Compression format:  MPEG-4 AAC

• Sample rates:  8 kHz, 11.025 kHz, 12 kHz, 16 kHz, 22.05 kHz, 24 kHz, 32 kHz, 44.1 kHz,
48 kHz, 64 kHz, 88.2 kHz, or 96 kHz

• MP3

• 44.1 kHz files

• Stereo files encoded at 48 or higher kbps, mono files encoded at 32 or more kbps

• iTunes/Logic encoded files

• Apple Lossless files

These files are not automatically converted when imported into Logic Pro. The compressed
audio file is added to the Arrange area, and a region that encompasses the complete
audio file is created. You can edit this region in the same fashion as a normal audio region
in the Arrange area. You can cut it, loop it, rename it, and so on.

Note: It is not possible to assign fades to compressed audio files, nor can you destructively
edit them.
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Audio regions that point to compressed audio files are denoted by the following symbol:

Compressed audio file 
symbol 

To convert compressed AAC, MP3, and Apple Lossless audio files
Do one of the following:

µ Select the audio regions pointing to an audio file in the Arrange area, then choose Audio
> Convert Regions to New Audio Files in the local Arrange area menu (or use the Convert
Regions to New Audio Files key command, default assignment:  Option-Command-F).

The part of the audio file spanned by the audio region is converted to a new audio file.

µ Select the audio files in the Audio Bin, then choose Audio File > Copy/Convert File(s) in
the local Audio Bin menu (which is also available by Control-clicking the Audio Bin or
using the corresponding key command).

Important: Compressed audio files protected by the DRM (Digital Rights Management)
scheme cannot be opened in Logic Pro. Depending on the type of music you buy from
the iTunes Store, you may have the option of buying DRM-free songs. Some songs are
only available in a DRM-protected format, while others are available in both formats.

Overview Calculation
When you add an audio file to your project, Logic Pro automatically creates an overview
of the audio file. This is a graphic file that is used to display the waveform.

Waveform overview
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The calculation of audio file overview data is shown in a window. This calculation occurs
in the background, allowing you to continue working in Logic Pro.

Selecting the “Faster overview calculation” option considerably speeds up the calculation,
at the cost of slowing down other operations, but not blocking user interaction completely.
Logic Pro remembers the state of the “Faster overview calculation” option between
projects.

You can manually refresh the overview of selected files with Options > Audio > Refresh
Overview(s) in situations where you have replaced file recordings (and used regions), or
made edits in an external sample editor.

Adding ReCycle Files to Your Project
ReCycle is the name of a software application from manufacturer Propellerhead, which
mainly serves as an editing and production tool for loops (repeatedly cycled audio files).
ReCycle uses specific file formats that can be imported, and used directly by Logic Pro,
or ReCycle files can be converted to Apple Loops.

Note: You need to install the REX Shared Library © Propellerhead Software when using
ReCycle files within Logic Pro. For more information on ReCycle files, see the Propellerhead
website.

Logic Pro can import the following ReCycle file formats:

• Old ReCycle file: These files have the suffix .rcy. The abbreviation for this file type is
RCSO.

• Old ReCycle export file: These files have the suffix .rex. The abbreviation for this file type
is REX.

• ReCycle 2.0 file: These files have the suffix .rx2. The abbreviation for this file type is REX2.

To import a ReCycle file into the Arrange area
1 Select the ReCycle file you want to import by doing one of the following:

• Choose File > Import Audio File and select a ReCycle file instead of an AIFF, SDII, MP3,
or WAV audio file.

• Shift-click an audio track with the Pencil tool and select a ReCycle file.

• Drag a ReCycle file from the Finder onto an audio track.
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2 Choose settings in the Import ReCycle file dialog, then click OK.

• Don’t Fix: Imports the file as is. All slices of the file overlap, to match the tempo of
Logic Pro.

• Add tracks: Distributes the slices across multiple audio tracks, allowing you to adjust
the position or delete slices freely. The Number of Additional Audio Tracks field
determines how many tracks are used for the distribution of the slices. These tracks
are in addition to the original track that the ReCycle file was added to.

• Crossfade: All slices of the file are imported to the same track, and are automatically
crossfaded. The length of the crossfade is determined by the value (shown in
milliseconds) displayed in the Crossfade Length field.

• Render into single file: This function writes all ReCycle slices into a single audio file. The
current Logic Pro project tempo is used for the rendering process.

• Render to Apple Loop: Imports the ReCycle file as an Apple Loops file.

If you do not import the ReCycle file as an Apple Loops or audio file, Logic Pro creates a
ReCycle file folder on a folder track. This folder contains slices (you can view them as
miniature regions in the folder) of the ReCycle file at appropriate positions.

ReCycle slices

ReCycle folder

Each of these slices references the same audio file, which can be found in the Audio Bin.
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Note: If you move the ReCycle file folder to another audio track, the audio channel strip
destination (of the track inside the folder) does not change accordingly. You need to
open the folder and change the audio channel strip destination manually, to hear the
ReCycle audio data.

To convert a ReCycle file to an Apple Loops file
Do one of the following:

µ Use the Render to Apple Loop option in the ReCycle file import dialog.

µ Choose the Convert ReCycle Files to Apple Loops command in the Browser’s Tool menu.

Moving Audio Between Logic Pro and ReCycle
You can transfer data from Logic Pro to ReCycle, and back, without using any file selector
dialogs.

To copy audio regions into the Clipboard for use in ReCycle
1 Select an audio region in the Arrange area.

2 Choose Audio > Copy as ReCycle Loop in the Arrange menu.

The data of the selected audio region is copied into the Clipboard.

3 Use the “Paste as new Document” command in ReCycle to create a new ReCycle document
(containing the audio data selected in the Arrange area).

Note: The size of the transferred audio region is limited to 10 MB, which should be
sufficient for most ReCycle loops (an eight bar stereo loop in 4/4 at 70 bpm uses
approximately 5 MB, for example).

To paste ReCycle loops from ReCycle into the Arrange area
1 Use the Copy Loop command in ReCycle.

This copies the loop currently being edited in ReCycle into the Clipboard.

2 Choose Audio > Paste ReCycle Loop in the Arrange menu to paste this loop into the
Arrange area.

The result is the same as the ReCycle file import options.

Adding MIDI and Project Files
You can also add MIDI and project files (such as OMF Interchange, AAF, OpenTL, and XML
files) to your arrangement. These file types are usually used to exchange projects, however,
and are therefore outside the scope of this chapter. Full details on importing these file
types can be found in Project and File Interchange.
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When audio or MIDI files are added to or recorded in the Arrange area, they are displayed
as regions. This chapter describes the similarities and differences between audio and MIDI
regions, and provides advanced information on region handling. Details on using regions
to construct your projects can be found in Creating Your Arrangement.

This chapter covers the following:

• What Are Regions? (p. 345)

• MIDI and Audio Regions Compared (p. 348)

• Handling Regions in the Audio Bin and Sample Editor (p. 350)

What Are Regions?
Audio and MIDI data handling is very similar in the Arrange area, via rectangular blocks
called regions. These blocks are graphical representations of data. Audio regions represent
audio data. MIDI regions represent MIDI data.
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Audio Regions and Audio Files
Audio regions simply refer to (point to) an underlying audio file. Audio regions are merely
used as playback markers (start and end points) that can be as long as the entire audio
file, or may only be a few seconds long, playing a small portion of the audio file that the
(region) start and end markers encompass.

Audio region 1

Audio file

Audio region 2

Audio
region 3

Any audio file used in Logic Pro (added to the project, and therefore the Audio Bin) is
automatically linked to at least one audio region that defaults to the length of the entire
audio file.

Audio regions contain a temporal reference point called the anchor. When you move an
audio region, it’s not the start point that is displayed in the help tag (as with MIDI
regions)—it’s the anchor point.

You can freely create as many audio regions as needed. To give you an example of where
this may be useful, imagine a live stereo drum track that runs for the duration of your
project. During the second chorus, the drummer played perfectly, but was a little sloppy
during all other chorus sections.

Logic Pro allows you to create an audio region that points to the second chorus section
of the overall (drum track) audio file, and use this perfect take in multiple places in the
project.

You do this by creating one audio region (that points to chorus 2 in the drum track audio
file), and copying it to each position that the chorus occurs in the Arrange area.

A great benefit of working with audio regions, rather than audio files, is that they use
very little memory, whereas multiple copies of the same section of the audio file would
require a lot of hard disk storage space.
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It is, of course, possible to directly edit, copy, move, and manage audio files. You do this
in the Sample Editor and Audio Bin. Details can be found in Managing Audio Files.

MIDI Regions and Events
MIDI regions actually contain MIDI data events. They are not related to information stored
in external files. MIDI regions can be saved as individual files, but they can also be, and
generally are, stored with the Logic project.

The MIDI data events stored within MIDI regions can include note, controller, system
exclusive, and other information. These data events represent MIDI performances that
you have recorded or imported into Logic Pro. MIDI performances are generally created
with a MIDI keyboard, but can also be generated with MIDI controllers, MIDI guitars, your
computer keyboard, or the mouse.

MIDI data events can be affected as a group by processing the MIDI region that contains
them. Such processing—which takes place in the Inspector Region Parameter
box—includes transposition, quantization, timing delays, and more.

You can also edit individual events within a MIDI region. You do this by opening the
region in one of the MIDI editors available in Logic Pro. These editors allow you to precisely
alter the position, length, and pitch of MIDI note events. Other MIDI event types can also
be altered in various ways. You can also enter MIDI data with your MIDI keyboard, the
mouse, or computer keyboard in these editors.

Folder Regions
A folder is a region that can contain other regions, much like a folder in the Finder can
contain other folders or files.

One way to visualize a folder is as a project within a project. A folder can contain as many
tracks—featuring regions—as required.

A folder is placed on a track assigned to a folder in the track list, rather than an instrument
or audio track. Folder regions look like MIDI regions, but have a folder icon before the
folder name.
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When opened, folders look just like the Arrange area and track list of a project.

Alias and Cloned Regions
Aliases can be created for MIDI regions and folder regions. A MIDI or folder region alias
is like an alias in the Finder. It looks like a region, but contains no actual data. It is just a
reference to the data of the original region—a virtual reflection of the original. You can
easily recognize an alias because its name is written in italics.

If the data in the original (source) region is altered, all aliases of the region are affected
immediately. Each alias has independent region parameters, however.

Clones can be created for audio regions (by Option-Shift-dragging). These are comparable
to MIDI region aliases, but differ in that adjustments to the start or end point of any cloned
region affects all other cloned regions in the same way. Adjustments to the source region
do not affect clones.

You can, of course, create independent copies of audio regions (by Option-dragging),
which can be adjusted without affecting other copies or the source region.

See Creating Your Arrangement for further details.

MIDI and Audio Regions Compared
The following overview sums up the main differences between audio and MIDI regions.

Audio regionsMIDI regionsFeature

No. Audio regions are just references to parts of
audio files.

YesComposed of discrete
data

YesYesCan be named
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Audio regionsMIDI regionsFeature

Yes, for flex-enabled audio regions.YesQuantize parameter
available

Yes, for flex-enabled audio regions.YesQ-Swing parameter
available

YesYesLoop option available

No, but you can use the Time Machine and
Pitch Shifting functions (in the Sample Editor and
Arrange window). Audio Apple Loops can be
transposed.

YesTransposition
parameter available

YesYesDelay parameter
available

NoYesVelocity parameter
available

YesNoGain parameter
available

NoYesDynamics parameter
available

YesNoFade In/Speed Up
parameter available

NoYesGate Time parameter
available

YesNoCurve parameter
available

NoYesClip Length parameter
available

YesNoFade/Slow Down
parameter available

NoYesScore parameter
available

YesNoFollow Tempo
parameter available

YesYesCan be freely
positioned

Yes, and this affects the audio region, but not the
position of the audio waveforms relative to the
time axis of the sequencer.

YesLeft or right corner edit

Yes, creates a new audio region.YesCan be cut with the
Scissors tool

Yes, although these are known as cloned (audio)
regions, to differentiate them from alias (MIDI)
regions.

YesCan have aliases made
of them
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Audio regionsMIDI regionsFeature

YesNoLeft corner may be
dragged to conceal
data at beginning

Yes, a variable anchor. This affects all regions
derived from a given audio file, and can change
the position of the audio, relative to the time axis
of the sequencer.

NoHave a variable musical
reference point

YesYesCan be turned off with
the Mute function

YesYesCan be placed in folders

YesYesCan be soloed

Naturally, some of the Inspector playback parameters (such as Transposition) that can be
applied to MIDI events have no effect on audio signals. Equivalent operations for most
of these are available as destructive edit operations in the Sample Editor.

The fundamental functions (such as a freely determinable position and length, the ability
to create complex arrangements with the aid of folders, and the ability to name, mute,
and solo) are generally available to all types of regions (MIDI regions, audio regions, folder
regions, or copies of these, and alias or cloned regions).

Handling Regions in the Audio Bin and Sample Editor
You can use the Audio Bin to manage your regions and to make rough edits to the region
(or regions) associated with an audio file. The graphic display in the Audio Bin is optimized
for quick and simple organization of audio files and regions.

The finest resolution for positioning the region start and end markers, or the anchor, is
limited to 256 sample steps in the Audio Bin. This is usually adequate, particularly if Edit
> Snap Edits to Zero Crossings is turned on.

On occasion, however, you will need to make very accurate adjustments—down to the
individual sample word level. Drum loops are a good example. The Sample Editor is
best-suited to these types of precision editing tasks.

To open the Sample Editor for a particular region
µ Double-click the region in the Audio Bin or Arrange area.
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The Sample Editor opens, with the entire region selected.

Managing Regions in the Audio Bin
The Audio Bin lists all audio files and regions that have been added to, or recorded in,
your project.

This section covers region handling options available in the Audio Bin tab and the Audio
Bin window.

Note: The audio file operations and options of the Audio Bin are discussed in Managing
Audio Files, although some of the basics are covered here.
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The Audio Bin tab is ideal for quickly adding files to the Arrange area, as it doesn’t obscure
your workspace. A bar is shown for each audio file, which represents the overall length
of the file. A colored area within the bar represents the region length. Tasks such as
resizing or moving regions within the audio file cannot be performed in the Audio Bin
tab. If you need to make these types of adjustments, use the Audio Bin window.

Audio Bin tab Audio Bin window

The Audio Bin window, which can be freely resized, displays audio files as waveform
graphics. Regions within audio files are highlighted. Further file details, including the full
file path, are shown in the Audio Bin window. Also displayed is the Options menu, which
contains the Strip Silence command.

In short:

• The Audio Bin tab is best-suited to tasks such as adding audio files and regions while
creating your arrangement.

• The Audio Bin window is your first port of call for audio file and region management
tasks.

To open the Audio Bin tab
µ Click the Audio Bin tab in the Media area of the Arrange window (or use the Toggle Bin

key command, default assignment:  B).
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To open the Audio Bin window
µ Choose Window > Audio Bin (or use the Open Bin key command, default

assignment:  Command-9).

To view a region associated with an audio file
µ Click the disclosure triangle beside the audio filename.

All regions are listed below the parent audio filename.

• Regions that are used in the Arrange area are indicated by a colored bar to the right of
the region name. The bar color is derived from the Arrange region color. The length of
the region (colored section) is shown proportionately against the audio file bar.

• Regions that are not used in the Arrange area are gray.

To see all regions in the Audio Bin
Do one of the following:

µ Choose View > Show All Regions (or use the corresponding key command).

µ Option-click the disclosure triangle beside any audio file.

All regions of all audio files in the Audio Bin are displayed instantly.

Choosing View > Hide All Regions (or using the corresponding key command), or a second
Option-click (on any audio file disclosure triangle) hides all regions.

To sort an audio file’s regions
µ Select an audio file, then choose View > Sort Regions By:

• Start Point: The regions are sorted according to their time position in the audio file.

• Length: The regions are sorted according to their respective lengths.

• Name: The regions are sorted alphabetically. This is the default setting.

To change the length display of regions in the Audio Bin window
µ Choose one of the following settings in the View > Show Length As menu:

• None: The length is not displayed.

• Min :  Sec :  Ms: Displays the absolute time of the region in hours, minutes, seconds,
and milliseconds.

• Samples: Displays the number of sample words in the region.

• SMPTE Time: Displays the SMPTE length, which unlike absolute time, uses frames and
bits in place of milliseconds.

• Bars/Beat: The region is displayed in musical units:  bars :  beats :  divisions :  ticks. If the
project tempo, time signature, or division settings are altered, the display is automatically
recalculated.
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To check the number of times a region is used in your arrangement
µ Choose View > Show Region Use Count.

Creating and Removing Regions
When you add an audio file to your project, Logic Pro automatically creates a region that
encompasses the entire file length. You can create as many regions as you like from the
same audio file. There are no length limitations to regions, as long as they don’t exceed
the length of the source audio file.

Creating multiple regions from the same audio file is beneficial for many tasks, such as
using different portions of a vocal take that spans the length of the project, for example.

You can create regions in the Audio Bin, the Sample Editor, and the Arrange window.
This section concentrates on the Audio Bin and Sample Editor options.

Note: Full details on all Arrange window region editing options are found in Creating
Your Arrangement.

To create a region from an audio file in the Audio Bin
Do one of the following:

µ Select an audio file in the Audio Bin, then choose Audio File > Add Region (or use the
Add Region key command, default assignment:  Control-R).

µ Choose Edit > Copy (Command-C) in the main menu bar, then choose Edit > Paste
(Command-V).

The new region appears below the existing region(s) in the list.

Each region is assigned a unique numerical appendix. For example, organ.wav is the
parent audio file. The automatically created region is simply called organ, and newly
created regions are called organ.1, organ.2, and so on.

To create a region from an audio file in the Sample Editor
µ Choose Edit > Create New Region (or press Command-R).

The newly created region appears in the Audio Bin list.

To delete a region from the Audio Bin
µ Select one or more regions, and press Delete.

Removing a region does not remove the parent audio file.

To remove an audio file from the current project
1 Select the audio file name (not a region name) in the Audio Bin.

2 Choose Audio File > Delete Files (or use the corresponding key command).

This deletes the file from the project, but not from the hard disk.
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Warning: If any of the deleted regions exist in the Arrange area, they are removed as
well. You should therefore be careful when deleting a region (or parent audio file). The
Undo function is always available, however, should you inadvertently remove a required
region.

Auditioning Regions in the Audio Bin
The playback modes outlined below only apply to regions in the Audio Bin (when the
window has key focus), and have no effect on project playback.

To play an entire region
1 Highlight the region name in the list.

2 Control-click (or right-click) the Prelisten button at the bottom of the Audio Bin, and
choose an option from the shortcut menu:

• Auto-select Channel Strip: The audio channel strip assigned to the selected arrange track
is used for playback.

• Prelisten Channel Strip: The Environment’s Prelisten channel strip is used for playback.
You can access the Prelisten channel strip in the Environment’s Mixer layer. It is located
to the right of the highest numbered audio channel strip.

3 Click the Prelisten button (or press the Space bar) to start playback.

4 Click the Prelisten button (or press the Space bar) again to stop playback.

To loop region playback
µ Click the Loop Playback button (featuring the circular arrow symbols) at the bottom of

the Audio Bin. Click the button a second time to stop looped playback.

To play a region from a specific position in the Audio Bin window
µ Click-hold the region in the region display or with the mouse.

A speaker icon replaces the mouse pointer.
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Playback starts at the click point. This allows you to play specific sections. Playback stops
as soon as you release the mouse button.

Note: This only works in the Audio Bin window.

Resizing a Region
You can resize regions in the Audio Bin window, the Sample Editor, and the Arrange
window. This section concentrates on the Audio Bin and Sample Editor options.

Note: Full details on all Arrange window region editing options are found in Creating
Your Arrangement.

To resize a region in the Audio Bin window
µ Click-hold the lower third of the left or right region boundary, and drag to the left or

right.

To precisely resize a region
µ Drag the start or end points of regions in the Sample Editor, not the Audio Bin, when

accuracy is required. Make sure that Edit > Snap Edits to Zero Crossings is turned off for
the Sample Editor. (See Snapping Edits to Zero Crossings.)

The small markers on the lower edge of the Sample Editor’s waveform display provide
direct access to the boundaries of the region.

Region markers
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Snapping Edits to Zero Crossings
If Edit > Snap Edits to Zero Crossings is turned on, adjustments to the start or end position
of a region are snapped to the nearest point where the waveform crosses the zero axis.
Put another way, there are certain crossover points in a sample (a drum loop, for example)
that are closely matched in level to other points in a sample. If two closely matched points
are used for the start and end points of the sample, the loop plays back without noticeable
glitches in the audio.

When adjusting the start point, the area preceding the selected point is scanned for a
smooth crossover point. When adjusting the end point, the area that follows the region
is scanned for a smooth crossover point.

To snap audio edits to zero crossings
1 Click the title bar of either the Audio Bin or Sample Editor to give the window key focus.

2 Choose Edit > Snap Edits to Zero Crossings (or use the corresponding key command).

Note: The Snap Edits to Zero Crossings option can be set independently for the Sample
Editor and Audio Bin.

Moving a Region Within an Audio File
You can also move an entire region within an audio file in the Audio Bin window.

To move the region area within the audio file
1 Position the pointer over the center of a region.

2 When the pointer turns into a two-headed arrow, drag the region to the left or right.

Two-headed arrow cursor

Note: If you want to adjust the boundaries of the region without moving the anchor,
hold down the Option key during the operation. This applies to moving the start or end
point, as well as moving the whole region.

Editing the Audio Region Anchor
The anchor is the temporal reference point of an audio region. When you move an audio
region, it’s not the start point that is displayed in the help tag (as with MIDI regions)—it’s
the anchor point.
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In many cases, the anchor should be placed on the amplitude peaks, rather than at the
start of the sound’s attack phase. A good example is recordings of brass instruments,
which may take some time to build to a peak. Moving the anchor to these peaks forces
the region to snap to the grid of your arrangement, using the anchor as the pivot point.
The flexible zoom settings allow you to be as precise as needed, going right down to the
level of single bits, at the highest magnification factor.

As another example, to guarantee perfect synchronization between a one-bar drum loop
and MIDI regions, the anchor must be assigned to a well-defined musical point. If the
loop begins with a significant level peak (say a kick drum beat), set the anchor to the
point where the volume of that beat is at its precise peak.

Whenever you record audio or add an audio file, the anchor and region start points are
always at the beginning of the audio file. Moving the region start point also moves the
anchor, as the anchor cannot precede the region’s start position.

You can edit the anchor of a region in the Audio Bin window and Sample Editor. The
anchor is represented by a black indicator (orange in the Sample Editor) below the region
waveform.

Anchor Anchor

To move the anchor in the Sample Editor or Audio Bin window
µ Grab the small indicator below the region, then move the anchor.

Any changes to the anchor point change the relative position of the audio region in the
project. Given that the start point of a region is the default position for the anchor, you
must also take care when changing the region start point.

Protecting the Anchor Point When Moving the End Position
If you move the start or end point of a region past the anchor point, the anchor point
also moves. This is often not what you want to happen.

Hold down the Option key while moving the end marker to prevent the anchor from
moving.

Note: The anchor can never be to the left of (before) the region start point, so it will move
if you drag the region start past the anchor (to the right), even with Option pressed.
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Updating the Audio Region Arrangement Position
When you change the anchor point in the Sample Editor, you can use the Compensate
Region Position feature to ensure that the position of a given audio region stays at the
same place in the arrangement.

To turn the Compensate Region Position feature on or off
1 Click the title bar of the Sample Editor, to make sure that it has key focus.

2 Choose Edit > Compensate Region Position.

• If Compensate Region Position is active, moving the anchor won’t change the audible
result. Moving the anchor in the Sample Editor will lead to the same result as dragging
the region start point in the Arrange area.

• If Compensate Region Position is not active, moving the anchor changes the position
of audio regions in the Arrange area. The region will shift in relation to the time axis,
while the anchor remains tied to the same bar value, and is marked by a dotted line.

Protecting Audio Regions
You can protect regions against accidental alterations to start and end points, or the
anchor position, by locking them in the Audio Bin window.

To protect region start, end, and anchor positions
µ In the Audio Bin window, click the padlock icon beside a region to close (lock) it. Click a

second time to unlock the region.

Protected region

Unprotected region

If locked, you can play the region, but can’t edit it.

Warning: Don’t confuse this function with delete protection. A protected (locked) region
can still be deleted.
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Once you have added your audio and MIDI regions to the Arrange area, you can edit and
reorganize them to create an overall arrangement, or project. Most arranging and editing
techniques work identically for both audio and MIDI regions. Apple Loops are also handled
in a similar fashion. Where handling differs, variations are pointed out in the appropriate
sections of this chapter. Note that all operations described with a pluralized heading
(regions, for example), apply to one or more selected region(s).

This chapter covers the following:

• Getting to Know the Arrange Area (p. 362)

• Snapping Region Edits to Time Positions (p. 364)

• Using Drag Modes (p. 367)

• Scrubbing Your Arrangement (p. 369)

• Using Shortcut Menus (p. 370)

• Muting Regions (p. 370)

• Soloing Regions (p. 371)

• Naming Regions (p. 372)

• Assigning Colors to Regions (p. 375)

• Selecting Regions (p. 376)

• Adding, Recording, and Removing Regions (p. 380)

• Restoring Removed Regions (p. 381)

• Moving Regions (p. 382)

• Resizing Regions (p. 387)

• Cutting, Copying, and Pasting Regions (p. 393)

• Adding or Removing Arrangement Passages (p. 394)

• Creating Region Aliases (p. 398)

• Creating Region Clones (p. 401)

• Converting Regions to a New Sampler Track (p. 402)
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• Creating Multiple Copies of Regions (p. 404)

• Creating Region Loops (p. 404)

• Dividing Regions (p. 408)

• Demixing MIDI Regions (p. 411)

• Merging Regions (General Tools and Commands) (p. 412)

• Merging MIDI Regions (p. 413)

• Merging Audio Regions (p. 413)

• Working with Folders (p. 415)

• Creating Crossfades and Fades on Audio Regions (p. 419)

• Setting Region Parameters (p. 424)

Getting to Know the Arrange Area
The Arrange area provides a visual overview of your project structure. It shows when
audio and MIDI regions start to play, and their duration. You control when and how
regions play by moving, cutting, copying, resizing, and joining them in the Arrange area.

Regions are positioned horizontally—on track lanes that run from left to right in the
Arrange area. Their positions along these lanes determine when they play, aligned with
the Bar (and Time) ruler along the top of the window.

The track lanes are stacked vertically, creating a grid of track lanes and particular bar or
time positions.

To view the Arrange area grid
µ Choose View > Grid in the Arrange area’s local menu bar (or use the corresponding key

command, default assignment:  Control-G).

Arrange area with grid Arrange area without grid

You can enhance the grid contrast by altering the color of the Arrange area background.
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To alter the Arrange area background color
1 Open the Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
pop-up menu.

2 Click the Arrange tab, then choose Bright from the Background Color pop-up menu.

3 Alternately, choose Custom from the pop-up menu, then click the color field to the right.
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4 In the Colors window that opens, create a custom color by using the color palette wheel
and contrast and opacity sliders.

5 Click the close button at the top-left corner of the window to close the Colors window
and assign your custom Arrange area background color.

Snapping Region Edits to Time Positions
You move and resize regions in the Arrange area because you want them to start and
end at a specific point in time. For example, in a music-based project, you may want to
align the start points of regions with measures and beats.

Logic Pro offers a snap feature that automatically aligns region start and end points to a
selected grid value, when you move or resize them.

Tip: Turn on the View > Grid item in the Arrange area’s local menu bar, as this will help
you to visualize how the Snap pop-up menu items automatically align regions to specific
grid positions.
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To snap regions to a grid
µ Choose one of the following values in the Snap pop-up menu (at the top of the Arrange

area):

• Smart: Edit operations snap to the nearest bar, beat, sub beat, and so on, depending
on the current Bar ruler division value, and the zoom level.

• Bar: Edit operations snap to the nearest bar.

• Beat: Edit operations snap to the nearest beat in a bar.

• Division: Edit operations snap to the nearest division value. (This is the time signature
shown in the Transport and Bar ruler.)

• Ticks: Edit operations snap to the nearest clock tick (1/3840th of a beat).

• Frames: Edit operations snap to the nearest SMPTE frame.

• QF (Quarter Frames): Edit operations snap to the nearest SMPTE quarter frame.

• Samples: Edit operations snap to the nearest sample.

Note: Sample-accurate editing is directly tied to the zoom level. If the zoom level is
insufficient, sample-accurate edits are not possible. Make use of the Zoom slider at the
bottom of the Arrange window, and take advantage of the Save and Recall Zoom Setting
key commands to speed up your workflow.

The Snap functionality is relative, which means that the edit operation is snapped to the
nearest bar, beat, and so on, retaining the region’s distance from its original position. For
example, if a region is placed at position 1.2.1.16, and you move this region forward to
around bar 2 (with the Snap pop-up menu set to Bar), the region automatically snaps to
position 2.2.1.16, rather than 2.1.1.1 (the bar 2 start point). You can override relative snaps
with the Snap to Absolute Value option.

365Chapter 13 Creating Your Arrangement



To snap to an absolute, not relative, position
µ Choose the Snap to Absolute Value option from the Snap pop-up menu (at the top of

the Arrange area).

A tick appears to the left of this option when it is active. This feature works in conjunction
with the chosen snap grid division.

For example, if Bar is chosen in the Snap pop-up menu, when Snap to Absolute Value is
active, moving a region (from position 1.2.1.16) to around bar 2 results in the region being
snapped to position 2.1.1.1 (the bar 2 start point), rather than its relative position (2.2.1.16).

The Snap pop-up menu setting applies to the following edit operations:

• Moving and copying regions

• Resizing regions

• Cutting regions

• Moving, adding, and resizing markers

• Setting cycle boundaries

Overriding the Snap Grid
You can temporarily override the snap grid, allowing finer edits and adjustments.

To override the snap grid
Do one of the following:

µ Hold down the Control key while performing the editing operation:

• The division value chosen in the Transport bar (1/16, for example) determines the
editing grid scale at lower zoom levels (macroscopic or wide view).

• At higher zoom levels, (microscopic or close-up view), the editing grid scales by a certain
factor.

µ Hold down the Control and Shift keys while performing the editing operation:

• The editing grid switches to ticks if editing at lower zoom levels (macroscopic or wide
view).

• At higher zoom levels (microscopic or close-up view), the editing grid switches to
samples.

Understanding the Link Between Zoom Level and Snap Value
In cases where the zoom level is so high (microscopic), that the chosen Snap value would
result in extremely large movements or edits, the Snap value is temporarily dimmed, and
Smart snap is used instead.
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In cases where the zoom level is extremely low (macroscopic), and a fine Snap value (such
as Division or Frames) is chosen, normal mouse movements result in larger grid units. In
these situations, either alter the zoom level, or hold down the Control key to actually use
the chosen Snap value.

Using Control-Shift breaks the 1:1 relationship between the mouse and region (or edit
tool) movements. This means that you may need to move the mouse a long way
(horizontally) to make the region (or edit tool) move one pixel. Watch the help tag for
exact numerical readouts.

Imagine you want to shorten a region in a 4/4 bar so that the 4 is played, but not the “4
and” of the last bar.

To shorten a region by one division value when Snap is set to Beat
1 Horizontally zoom the screen display until you can see quarter notes in the Bar ruler.

2 Grab the bottom-right corner of a region, and move the mouse to the left, until the region
is shortened by one quarter note.

3 Press the Control key, and move the mouse carefully to the right, until the region becomes
one division longer.

While you’re doing this, the help tag shows the region start position, track number, and
the current length of the region in bars, beats, divisions, and ticks. The three numbers to
the right should be 3 1 0.

Using Drag Modes
Logic Pro provides several drag modes that determine the behavior of regions when you
edit them. You can set the drag mode in the Drag pop-up menu, available in the Arrange
area and several other editors.

Note: The Drag pop-up menu options discussed in this section refer to regions. The
behaviors outlined below (for regions) are identical for dragged events in the editor
windows. The Drag pop-up menu setting of the Arrange area and each editor window
is independent.
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To change the drag mode
µ Choose one of the following settings from the Drag pop-up menu (at the top of the

Arrange area):

• Overlap: This mode is the default, and allows you to drag a region over another one.
The original region borders are preserved.

• No Overlap: Use in situations where you don’t want regions to overlap. In this mode,
the first region (the one positioned earlier on the track) is reduced in length so that no
overlap occurs.

• X-Fade: In this mode, Logic Pro automatically crossfades two audio regions when they
are moved to an overlapping position.

Note: This option does not work for MIDI regions or Apple Loop regions.

• Shuffle L and Shuffle R: Choose to automatically align regions (to the left or right,
respectively) when you move, resize, or delete them.

• When you use Shuffle R (or Shuffle L), moving a region to the right (or left) aligns the
region end point with the start point of the following region, ensuring that there is
no space between the two regions.

• Regions that are dragged over each other swap positions.

• When deleting regions, the remaining regions (those to the left or right of the deleted
region) are moved to the left or to the right by the length of the deleted region.

• If a region is stretched or shortened when either Shuffle option is active, the other
regions on the track are moved to accommodate the new length.

• In Shuffle L mode, the right side of the region is stretched or shortened, and the
regions to the right of the edited region are moved.

• In Shuffle R mode, the left side of the region is stretched or shortened, and the regions
to the left of the edited region are moved. The regions that precede the edited region
can only be moved as far as the project start point. If the stretching of a region results
in preceding regions being forced to the project start point, and exceeding the space
available, the edited region overlaps the existing content.
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Note: Only one audio region can be played at a time through a track’s channel strip.
When two audio regions overlap each other on a track, the later region has priority.

Scrubbing Your Arrangement
Scrubbing allows you to hear the audio and MIDI signals of regions at the playhead
position, helping you to find a particular sonic event. This makes it easy to zero in on a
particular kick or snare hit, for example, before cutting an audio region.

Note: Before MIDI scrubbing can occur, you need to turn on File > Project Settings > MIDI
> General > Scrubbing with Audio in Arrange.

To scrub your project
1 Set a zoom level that provides the best view of the section you want to scrub.

2 Click the Pause button on the Transport bar.

3 Grab the playhead in the Arrange area or Bar ruler, and move it back and forth through
the parts of the project you want to hear, at the speed you want to scrub the section (or
use the Scrub Rewind and Scrub Forward key commands).

Audio and MIDI data playback is perfectly synchronized when scrubbing.

Note: Scrubbing is automatically activated when you divide regions (with the Scissors
tool) in the Arrange area, making it easier to identify the cut position.

Scrubbing Particular Regions
The following list outlines the relationship between scrubbing and region selection:

• If no regions are selected, all regions are scrubbed.

• If you select a specific audio region, only it is scrubbed.

• If you drag to select or Shift-select audio regions on different tracks, only the selected
audio regions are scrubbed.

• MIDI regions (software and external MIDI) are always scrubbed, regardless of the
selection status (provided that the Scrubbing with Audio in Arrange project setting is
active).

• The Mute or Solo status of all tracks and regions has an effect on what you hear when
scrubbing, so you can make use of them to scrub audio parts in isolation (or with
particular software or external MIDI instrument tracks).

MIDI-Controlled Scrubbing
The Scrub by MIDI value (-2-) function (available in the Controller Assignments window;
see the Logic Pro Control Surfaces Support manual) is designed to allow scrubbing via
external MIDI control. You can assign any MIDI controller number to this function. Data
bytes over 64 scrub forward, and those under 64, scrub backward.
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Using Shortcut Menus
Many selection, editing, and other commands can be accessed by Control-clicking (or
right-clicking) anywhere in the Arrange area. Make use of this feature to accelerate your
workflow.

Note: To use the Control-click (right-click) feature, choose Logic Pro > Preferences >
General > Editing pane and choose Opens Shortcut Menu from the Right Mouse Button
pop-up menu.

Muting Regions
Often, when arranging, you’ll want to test musical ideas by muting certain regions.

To mute or unmute individual or selected regions
Do one of the following:

µ Select the Mute tool from the Tool menu, then click the regions you want to mute with
the Mute tool.

Mute tool

µ Select the Pointer tool from the Tool menu, select the regions you want to mute, then
use the “Mute Notes/Regions/Folders on/off” key command (default assignment:  M).

Muted regions have three characteristics:

• A dot precedes the region name.

• The audio or MIDI data section is displayed in gray.

• The region is framed in the region color (making it easier to identify tracks or regions
associated with muted regions).

Clicking muted regions with the Mute tool, or selecting them and using the “Mute
Notes/Regions/Folders on/off” key command reverses this state (unmuting).
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Soloing Regions
Soloing allows you to hear one or more selected regions in isolation, making it easier to
identify particular elements that may need to be edited.

To solo a region with the Solo tool
µ Click and hold the region you want to solo with the Solo tool.

Solo tool

The region (outlined in yellow) is heard in isolation from the click point until you release
the mouse button, which stops solo playback.

To solo several regions with the Solo tool
1 Select the regions with the Pointer tool.

2 Click and hold any of the selected regions with the Solo tool.

To scrub with the Solo tool
1 Drag horizontally with the Solo tool.

2 Release the mouse button to end solo scrubbing.

To solo one or more regions using Solo mode
1 Click the Solo button in the Transport bar (or use the Solo Mode key command, default

assignment:  S).

Solo button

When the Solo function is activated, the Bar ruler is shaded in yellow, making it easy to
see that Solo mode is engaged.
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2 Drag to select or Shift-select the regions you want to solo with the Pointer tool. Selected
regions have a yellow outline.

Clicking the Solo button on the Transport bar again (or using the Solo Mode key command)
turns off Solo mode, allowing you to hear all regions again.

On occasion, you may want to lock the solo status of several regions. For example, this
would be especially useful when you want to make changes to the playback parameters
of a region, while listening to a specific group of soloed tracks.

To retain the solo status of several selected regions (can be done in Playback mode)
1 Select several regions with the Pointer tool.

2 Option-click the Solo button on the Transport bar (or use the Set Solo Lock Mode key
command, default assignment:  Option-S) to lock the soloed status of the selected regions.

The Transport Solo button displays a padlock icon to indicate Solo Lock mode.

Solo button indicating 
Solo Lock mode

The Reselect Solo-Locked Regions key command (default assignment:  Shift-Option-S)
selects all currently solo-locked regions. This command is very useful if you want to remove
several regions from your solo-locked selection.

Naming Regions
Identifying regions by name can make arranging much easier. This can be done on a
per-region basis, or you can name several regions simultaneously.
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To name a region with the Text tool
1 Select the Text tool.

Text tool

2 Click a region with the Text tool.

A text input box appears.

3 Type in a name and press Return, or click another region or the Arrange area background
to exit the text input box.

To name a region using the Region Parameter box
1 Double-click the top line of the Region Parameter box in the Inspector.

A text input field appears, allowing you to edit the region name.

2 Type in a name and press Return, or click anywhere outside the text input box.

373Chapter 13 Creating Your Arrangement



To assign the same name to multiple regions
1 Select a group of regions (drag to select or Shift-click) with the Pointer tool.

2 Do one of the following:

• Select the Text tool, then click any of the selected regions with the Text tool.

• Double-click the top line of the Region Parameter box (displaying x selected, with x
indicating the number of selected regions).

A text input box appears.

3 Type in a name and press Return, or click another region or the Arrange area background
to exit the text input box.

All regions are assigned the same name.

To assign a name with incrementing numbers to multiple regions
1 Select a group of regions (drag to select or Shift-click) with the Pointer tool.

2 Do one of the following:

• Select the Text tool, then click any of the selected regions with the Text tool.

• Double-click the top line of the Region Parameter box (displaying x selected :x indicates
the number of selected regions).

A text input box appears.

3 Type in a name, ending with a number.

4 Press Return or click another region or the Arrange area background to exit the text input
box.

All selected regions are assigned the same name, but are incrementally numbered.

To make all regions end with the same number
1 Select a group of regions (drag to select or Shift-click) with the Pointer tool.

2 Do one of the following:

• Select the Text tool, then click any of the selected regions with the Text tool.

• Double-click the top line of the Region Parameter box (displaying x selected: x indicates
the number of selected regions).

A text input box appears.

3 Type in a name, ending with a number followed by a space.

4 Press Return or click another region or the Arrange area background to exit the text input
box.

All selected regions are assigned the same name and end with the same number. This is
useful for identifying takes made on a particular date; for example, bassline 030806.

You can name regions after the track on which they are placed.
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To assign regions the name of their parent track
1 Select the track name in the track list.

All regions on the track are automatically selected.

2 Choose Region > Name Regions by Tracks/Channel Strips (or use the corresponding key
command, default assignment:  Shift-Option-N) in the Arrange area.

The track name is assigned to all selected regions.

Assigning Colors to Regions
Color is useful for identifying sections of your arrangement, or particular track types.
Newly recorded or added regions initially adopt the color of the track channel strip.

By default:

• Audio channel strips are blue.

• Software instrument channel strips are green.

• ReWire and external MIDI channel strips are red.

• Auxiliary, Input, and Output channel strips are yellow.

To change the color of one or more regions
1 Select the regions (drag to select or Shift-click, for example).

Note: If you select all regions on a particular track, and no regions on other tracks are
selected, coloring them alters the hue of all selected regions. This also changes the color
of the selected track’s channel strip.

2 Open the Color palette by doing one of the following:

• Click the Colors button in the Arrange toolbar.

• Choose View > Colors in the Arrange area (or use the Open Color Palette key command,
default assignment:  Option-C).

3 Click a color.

4 If you want to create a custom color:

a Double-click any color square in the Color palette to open the Colors window.

b Create a custom color using the color wheel and contrast and opacity sliders.
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c Click the OK button to replace the color square in the Color palette, and close the Colors
window.

Note: While custom colors are memorized for all projects, you can always reset the Color
palette to its original colors. To do this, Control-click the palette, then choose Reset Colors.

To assign channel strip colors to regions
1 Select the regions.

Tip: If all regions are on a single track, click the track name in the track list to select all
regions.

2 Choose Region > Color Regions by Channel Strips/Instruments in the Arrange area (or
use the corresponding key command, default assignment:  Shift-Option-C).

The colors of all selected regions are replaced with the colors of the corresponding channel
strips.

Tip: This feature is handy after copying or moving regions between tracks, when you
may find that the Arrange area resembles a patchwork quilt.

Selecting Regions
You need to select a region before you can perform any edits, functions, or operations
on it. You can select a single or multiple regions, including regions on different tracks
and of different types. When selected, a black bar runs across the upper portion of the
region to indicate its selected status.

Logic Pro provides a number of sophisticated selection methods. For more information
on this, see Using Selection Techniques.

376 Chapter 13 Creating Your Arrangement



Selecting Parts of a Region
You can select and edit parts of one or more regions, using either of the following:

• The Marquee tool, which looks like a crosshair

Marquee tool

• The Bar ruler marquee stripe, a thin marquee stripe shown at the top of the Bar ruler

Marquee stripe

Only the area that falls inside the marquee is selected. In other words, you can use the
Marquee tool or marquee stripe to make selections inside, or across portions of, existing
regions; your selection is determined completely by the selected marquee area. Within
the selected area, you can perform almost all Arrange editing options, including
deletions, moves, cuts, and copies.

Note: When using the Marquee tool or marquee stripe on a region, the selected area
becomes a new region once an operation is applied.

If your selected area falls between musically relevant values, the marquee selection
rectangle snaps automatically to the nearest musically relevant position. The snap
resolution is determined by the current Snap pop-up menu setting.

To make a marquee selection using the Marquee tool
1 Select the Marquee tool.
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2 Drag the marquee rectangle to make selections—independent of existing region
boundaries.

To make a marquee selection using the marquee stripe
1 Click the note icon at the right end of the Bar ruler, and choose the Marquee Stripe setting

from the pop-up menu.

2 Drag in this area of the Bar ruler to create a marquee stripe selection area (also shown
on selected arrange tracks).

To remove a marquee selection
µ Click outside the marquee selection.

To add or remove individual tracks from the marquee selection
µ Shift-click track names in the track list.

To change the marquee start or end point
Do one of the following:

µ Using the Marquee tool:

• Hold down the Shift key to alter the current marquee selection, from either the left or
right side, or up or down.

µ Using the marquee stripe:

• Use the Left Arrow key or Right Arrow key to modify the marquee end point.

There are the default Select Previous (or Next) Region/Event, or set Marquee End to
Previous (or Next) Transient key commands, which behave as described above,
depending on the type of region selected (when the marquee stripe is visible).

• Hold down the Shift key while using the Left Arrow key or Right Arrow key to move
the marquee start point.

There are the default Toggle Previous (or Next) Region/Event, or set Marquee Start to
Previous (or Next) Transient key commands, which behave as described when the
marquee stripe is visible.
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To move the entire marquee selection
Do one of the following:

µ Press Shift–Left Arrow key, the default Select First, or Shift Marquee Selection Left key
command.

µ Press Shift–Right Arrow key, the default Select Last, or Shift Marquee Selection Right key
command.

To snap to the finest possible resolution in the chosen Snap mode
µ Hold down the Control and Shift keys while making your marquee selection.

This action snaps to ticks or samples when editing MIDI or audio regions, depending on
the current zoom level. See Overriding the Snap Grid.

To snap to the division value shown in the Transport bar
µ Hold down the Control key while making your marquee selection.

This action snaps to ticks or samples when editing MIDI or audio regions, depending on
the current zoom level. See Overriding the Snap Grid.

To set locators with a marquee selection
µ Choose Region > Set Locators by Regions in the Arrange area (or use the Set Locators by

Regions/Events/Marquee key command, default assignment:  Control-=).

This action sets the locators to the marquee selection boundaries, rather than the whole
region.

To remove all parts of regions outside the marquee selection
µ Use the “Crop Regions outside Locators or Marquee Selection” key command (default

assignment:  Control-C).

This action removes all unselected areas from regions which are partly marquee-selected.

Playback with an Active Marquee Selection
Playback starts at the left border, and ends at the right border, of an active marquee
selection. If you create a marquee selection while Logic Pro is open, however, playback
does not stop at the end of the marquee selection.

Recording with an Active Marquee Selection
If you start recording when a marquee selection is active, the following happens:

• Autopunch mode is automatically activated, and the autopunch locators are set to
match the marquee selection. The marquee selection is removed (replaced by the
autopunch locators).

• All tracks within the marquee selection are record-enabled; all other tracks are
record-disabled.
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Using the Marquee Selection to Create Track Automation Nodes
When you edit automation data that is spanned by a marquee selection, two automation
nodes are automatically created at the left border, and two at the right border, of the
marquee selection. This provides a quick way to define and create automation data by
converting the marquee selection into automation nodes.

Adding, Recording, and Removing Regions
Adding and recording regions is essential for project creation.

For full details about the region and file import options available in Logic Pro, see Adding
Prerecorded Media.

For details about the various recording techniques that are possible in Logic Pro, see
Recording in Logic Pro.

As you work on a project, you may decide that a region no longer fits into your
arrangement. You can remove regions by deleting them from the Arrange area.

To remove a region from your arrangement
Do one of the following:

µ Click the region with the Eraser tool.

Eraser tool

µ Select the region with the Pointer tool, then choose Edit > Delete (or press the Delete
key).

To remove multiple regions from your arrangement
1 Select the regions with the Pointer tool.

2 Do one of the following:

• Click one of the selected regions with the Eraser tool.

• Choose Edit > Delete (or press the Delete key).

To remove all muted regions from your arrangement
1 Select all muted regions by choosing Edit > Select Muted Regions in the Arrange area

(or use the Select Muted Regions/Events key command, default assignment:  Shift-M).
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2 Do one of the following:

• Click one of the regions with the Eraser tool.

• Choose Edit > Delete (or press the Delete key).

To delete all selected regions, and automatically select the next one
1 Select the region (or regions) you want to delete.

2 Use the Delete and Select Next Region/Event key command.

All selected regions are deleted, and the next region is automatically selected.

Note: Removing audio regions and MIDI regions from the Arrange has different
consequences. See Restoring Removed Regions.

Restoring Removed Regions
Although handled similarly for most editing operations, audio and MIDI regions are treated
differently when removed from the Arrange window.

• Audio regions are only removed from the arrangement, not from the project. They
remain in the Audio Bin, and can be restored from there, or with the Undo function.

• MIDI regions are deleted. They can be restored by using the Edit > Undo History function.

When you remove an audio region that you have recorded since opening the project,
Logic Pro asks if you also want to delete the corresponding audio file. This avoids the
unnecessary use of hard disk space that would occur if bad takes and unwanted recordings
were retained.

If the recording was made beforehand (a prerecorded file), and imported into the current
project, this dialog does not appear. This prevents you from accidentally deleting valuable
recordings (that may be used in other projects).

Note: When you remove a prerecorded audio file from your project (by pressing the
Delete key in the Audio Bin), all regions that point to the file are also removed. The only
way to restore the file to the project is by manually adding it to the Audio Bin.
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To restore a deleted audio region
Do one of the following:

µ Choose Edit > Undo History, and click the appropriate step.

µ Manually add it back into the Arrange area from the Audio Bin.

Moving Regions
You can move regions horizontally on tracks, and vertically between tracks. You can also
move regions between two Arrange windows, or even between different projects.

To move one or more regions
µ Select the regions and drag them to a new position.

Dragged regions automatically snap to increments defined by the setting in the Snap
pop-up menu. (See Snapping Region Edits to Time Positions.) If dragged over other
regions, the setting in the Drag pop-up menu has an impact on behavior.

To move regions precisely (overriding the Snap pop-up menu setting)
Do one of the following:

µ Hold down the Control key while dragging regions, to move them in steps of one division
(in sixteenths, for example).

µ Hold down the Control and Shift keys while dragging regions, to move them by single
ticks or samples. (Remember that the maximum resolution depends on the zoom setting.)

Limiting Region Movements
You can limit the initial movement of regions to either the horizontal or vertical axis. To
do so, select the Logic Pro > Preferences > General > Editing > Limit Dragging to One
Direction In Arrange checkbox. If your first movement is to the left or right after grabbing
a region, you can only move it on the horizontal plane. If you want to move it between
tracks, release the mouse button, reselect the region, and drag it up or down.
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Note: You can override this direction-limiting preference by holding down the Shift key
while moving regions.

Changing the Playback Position of Regions Numerically
You can edit the playback position of a region (and its length) numerically. You do this
in the Event List, configured to view regions at the Arrange level. (See Changing the Event
List View Level.)

To move regions by adjusting positions in the Event List
1 Open the Event List by doing one of the following:

• Choose Window > Event List in the main menu bar (or use the Open Event List key
command, default assignment:  Command-0).

• Click the Lists button at the top-right corner of the Arrange toolbar, and click the Event
tab (or use the Toggle Event List key command, default assignment:  E).

• Drag the Event tab, which changes to the Event List as you drag it.

• Choose Options > Open Event Float (or use the Open Event Float key command). This
opens a new single line Event List, set to the Arrange level view.

2 Click the Hierarchy button in the top-left corner of the Event List (not applicable to the
Event Float window—a miniature Event List) to move up one level in the hierarchy.

3 Edit the region’s Position value. As you select regions in the Arrange area, the Event List
(or Event Float) window updates to reflect this selection.

Tip: You can instantly move a region start point to the beginning of a bar by entering a
value and pressing Return. For example, typing in 9 moves the selected region to the
beginning of bar 9. Typing in 112 moves the region to bar 112. Typing in 1 space 1 space
2 moves the region to bar 1, beat 1, sub-beat 2.

You can display the start position of regions as SMPTE values in the Event List and Event
Float windows. This is especially handy if you work with video or film.

To display region positions in SMPTE values
Do one of the following:

µ Click the note icon button to the left of the first (or only, in the case of the Event Float
window) region event.

The icon changes to a clock, and the SMPTE position and length of the event is shown.
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µ Choose the View > Event Position and Length in SMPTE Units setting in the Event List (or
use the corresponding key command, default assignment:  Shift-R).

This setting allows you to set the required SMPTE positions when synchronizing music
to picture.

You can also display, and adjust, the end points of regions as a SMPTE value.

To display, and adjust, the end points of regions as a SMPTE value
µ Choose View > Length as Absolute Position in the Event List (or use the corresponding

key command, default assignment:  Control-A).

Moving Regions to the Current Playhead Position
You can use the Pickup Clock (Move Event to Playhead Position) key command to move
the selected region (or the first of several selected regions) to the current playhead
position. If more than one region is selected, all subsequent regions are moved.

Note: If you use this command on audio regions, the anchor of the region is placed at
the current playhead position. (See Editing the Audio Region Anchor.)

Moving Audio Regions Back to Their Original Record Positions
You can move any selected audio region back to its original recorded position by choosing
Audio > Move Region to Original Record Position (or using the corresponding key
command, default assignment:  Shift-Command-R).

Note: This command only works if the audio file includes a timestamp. Examples of
timestamped files include those recorded in the current project, and imported Broadcast
Wave or SDII files. Timestamped files are indicated by a clock symbol in both the Audio
Bin window and tab.

Time stamped audio file
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Nudging Regions with Key Commands
By predefining a nudge value, you can move selected regions according to this value.
Set the nudge value using the following key commands:

• Set Nudge Value to Tick

• Set Nudge Value to Division

• Set Nudge Value to Beat

• Set Nudge Value to Bar

• Set Nudge Value to SMPTE Frame

• Set Nudge Value to 0.5 SMPTE Frame

• Set Nudge Value to 5 SMPTE Frames

• Set Nudge Value to Sample

• Set Nudge Value to 1 ms

• Set Nudge Value to 10 ms

To nudge selected regions using a predefined value
µ Hold down the Option key and press the Left or Right Arrow key.

You can also use the following key commands to nudge (move to the right or left) selected
regions by the corresponding grid amount:

• Nudge Region/Event Position Right by SMPTE Frame

• Nudge Region/Event Position Left by SMPTE Frame

• Nudge Region/Event Position Right by 1/2 SMPTE Frame

• Nudge Region/Event Position Left by 1/2 SMPTE Frame

• Nudge Region/Event Position Right by 5 SMPTE Frames

• Nudge Region/Event Position Left by 5 SMPTE Frames

• Nudge Region/Event Position Right by SMPTE Bit

• Nudge Region/Event Position Left by SMPTE Bit

• Nudge Region/Event Position Right by Tick

• Nudge Region/Event Position Left by Tick

• Nudge Region/Event Position Right by Division

• Nudge Region/Event Position Left by Division

• Nudge Region/Event Position Right by Beat

• Nudge Region/Event Position Left by Beat

• Nudge Region/Event Position Right by Bar

• Nudge Region/Event Position Left by Bar
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• Nudge Region/Event Position Right by Nudge Value

• Nudge Region/Event Position Left by Nudge Value

• Nudge Region/Event Position Right by Sample

• Nudge Region/Event Position Left by Sample

• Nudge Region/Event Position Right by 1 ms

• Nudge Region/Event Position Left by 1 ms

• Nudge Region/Event Position Right by 10 ms

• Nudge Region/Event Position Left by 10 ms

The selected regions are shifted one step right (+1) or left (–1), by whatever unit is referred
to in the particular command name.

Shifting the Playback Position of Regions
The Delay parameter in the Region Parameter box of the Inspector allows you to shift
the playback position of regions on a track. Positive values correspond to a delay (laid-back
playing style or dragging), and negative values cause a pre-delay (driving or rushing the
music).

To delay or advance all selected regions on a track
µ Set the Region Parameter box Delay parameter to the desired value.

It is possible to show the delay amount in milliseconds or note values, depending on the
“Delay in ms” setting.

To show the delay amount in milliseconds
Do one of the following:

µ Choose View > “Delay in ms” in the Arrange area (or use the corresponding key command).

µ Control-click (or right-click) the Inspector’s Region Parameter box, then choose “Delay in
ms” from the shortcut menu.
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The Delay parameter in the Inspector is mainly used for creative musical purposes, such
as rhythmically offsetting musical parts (regions). It can also be used to fix timing problems
that may occur for a variety of reasons. Some examples of these are:

• The attack phase of the sound is too slow. A good musician will automatically
compensate for this by playing the notes slightly early. With very slow sounds, you may
need a pre-delay of over 100 ms to even them out.

• The sound generator is reacting too slowly to the incoming note-on messages. Older
multi-timbral sound generators often take tens of milliseconds before outputting a
voice.

• The delay in output is not constant, as it is dependent on the order of notes arriving
at the external MIDI sound generator. You should therefore try pre-delaying rhythmically
important tracks by as little as one tick—it can work wonders on timing.

Moving Regions to a Track
The Region > Move Selected Regions to Selected Track command (also available as a key
command, default assignment:  Shift-Command-T) moves all selected regions (from
different tracks) onto the selected track. The time positions of all regions are retained.

Moving Regions Between Projects
If you move a region from one project into the Arrange area of another, the region is
automatically copied, in much the same way that Mac OS X automatically copies files
when dragged and dropped between hard disks.

Resizing Regions
You can reduce or extend the length of any region by dragging the start or end point of
the region, thus determining what part of the source (audio file or MIDI events) is played
back in your project.

The data in regions is never deleted when they are reduced in length; playback simply
stops at the end of the region.

To resize a region
1 Select the Pointer or Pencil tool, then place the mouse pointer over the lower-left or

lower-right corner of the region.

The pointer changes to a Resize pointer.

2 Drag the corner to the left or right.
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Note: If Hyper Draw or automation is activated, you need to grab the left or right side of
the region title area.

To simultaneously resize two adjacent regions
1 Select the Pointer or Pencil tool, then place the cursor over the upper-left or upper-right

corner of two side-by-side regions.

The cursor changes to the Junction pointer.

Note: If there is a gap between the regions, the Loop tool is shown when the mouse
pointer is moved over the upper-right corner of the earlier region.

2 Drag to the left or right.

Both regions are resized accordingly, with no gaps between them.

Note: You cannot make an audio region longer than the underlying audio file when using
either of the resize operations described above.

Adjusting the Start Point of Audio Regions
Adjusting the start point of an audio region may also move the region anchor point, thus
affecting its temporal reference point, and making it play back out of sync with other
tracks. It is better, and simpler, to move the entire region to the right, if you want playback
to start later.

If you want to remove the early portion of the region, you have several options, such as:

• Marquee selection and muting

• Cutting and muting or deleting

• Creating a new region, and resizing it in the Audio Bin window

• Using the Sample Editor to resize, and replace, the Arrange region
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To resize an Arrange audio region from the Sample Editor
µ Directly edit the start and end markers in the Region row at the bottom of the Sample

Editor.

This action affects the size of the corresponding Arrange region immediately.

To resize and replace an Arrange audio region from the Sample Editor
1 Select the portion of the audio file in the Sample Editor by dragging directly across the

waveform display.

2 Choose Edit > Selection > Region in the Sample Editor (or use the corresponding key
command).

This allows you to define an audio passage as a selection, and then convert it to a region,
in place of the originally selected region.

To resize the Sample Editor selection from the Arrange area
1 Select the region in the Arrange area (presumably of a different length than the current

Sample Editor selection).

2 Click the Sample Editor title to make sure that the Sample Editor has key focus.

3 Choose Edit > Region > Selection in the Sample Editor (or use the corresponding key
command).

If Audio > Search Zero Crossings is turned on, any length adjustments to audio region
start or end points snap to the nearest zero crossing point of the waveform.

The disadvantage of this option is that altered start or end points never land exactly on
the selected musical grid. If this causes a problem, you can simply turn off the Audio >
Search Zero Crossings setting. The primary reason for turning on this setting is that it
prevents clicks and pops at region start and end points.
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Adjusting the Start or End Point of MIDI Regions
You can move the left corner beyond the first event in a MIDI region. This action hides
events from the beginning of the MIDI region, but these hidden events will continue to
play back.

If you actually want to remove the information from the start of a MIDI region, you need
to cut it and mute or delete the new start segment (new MIDI region).

The hide facility is useful in situations in which you might want to trigger MIDI controller
events (such as sustain) before the musical phrase begins, but do not want to use a MIDI
region that doesn’t fit into the current Arrange area grid (based on bars), as this would
make arrangement far more complicated.

The Clip Length setting in the Inspector’s Region Parameter box determines whether:

• Notes sounding when the region ends are abruptly cut off (active).

• Notes should be played to their normal end point (inactive:  default), regardless of
where the region ends.

The point of this function is to allow you to alter the length of the last notes in a region
directly from the Arrange area, by adjusting the length of the MIDI region. Clip length
has no effect on folder regions.

Making Multiple Regions the Same Length
You can change the length of multiple regions to the same absolute amount, making
them the same length, even if they were originally a different size.

To make all selected regions the same absolute length
µ Hold Option-Shift while changing the length with the Pointer tool.

Setting Region Start and End Points to the Playhead Position
You can move the start or end point of a selected region to the current playhead position
with the following key commands:

• Set Region/Event/Marquee Start to Playhead Position

• Set Region/Event/Marquee End to Playhead Position

Note: The anchor point is also moved when using Set Region/Event/Marquee Start to
Playhead Position on an audio region.

Adjusting Region Lengths to Fit Other Regions
On occasion, you may want to reduce or extend the length of all regions on a track, or
between locators, ensuring that they directly adjoin each other without gaps.
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To reduce the length of overlapping regions on a track
1 Select the overlapping regions on a track, or select all regions on a track by clicking the

track name in the track list.

2 Choose Region > Remove Overlaps (or use the corresponding key command).

This function searches all selected regions on a track for overlaps. If an overlap is found,
the earlier (in time) region is reduced in length, thus removing the overlap.

You can extend selected regions, making them end exactly at the start point of the next
region on the track.

Note: You cannot make an audio region longer than the underlying audio file.

To extend regions (removing gaps between regions)
1 Select the regions you want to extend.

2 Choose Region > Trim Region End to Next Region (or use the corresponding key
command).

The selected regions are increased in length, making them end exactly at the start point
of the next region on the track.

You can limit the length change to all selected regions within the locator boundaries.

To extend selected regions between locators
1 Set the left and right locator positions by doing one of the following:

• Drag from left to right across a portion of the Bar ruler.
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• Set the value in the Transport bar’s Locator fields.

2 Select the regions within the locator boundaries.

Tip: You can quickly select all regions inside the locators by choosing Edit > Select Inside
Locators (or using the corresponding key command, default assignment:  Shift-L).

3 Choose Region > Trim Regions to Fill within Locators (or use the corresponding key
command).

This function lengthens all selected regions (within the locator boundaries), closing the
gaps between them. The last region on each track (within the locator boundaries) is not
affected.

Time Stretching the Contents of a Region When Changing Length
In normal use, the position of events within MIDI regions is not affected by changes to
the region length. Similarly, changes to audio region lengths have no impact other than
starting and stopping playback at particular project positions.

You can, however, time stretch or compress the contents of regions when altering their
length.

To time stretch or compress the position of events within a MIDI region
µ Option-drag the end of a MIDI region.

The events within the region are stretched or compressed, proportionately, by the amount
that the MIDI region is altered in length.

You can make a rhythmic MIDI region play in half-time by stretching it to twice the original
length, or in double-time by shortening it to half the original length.

To time stretch or compress audio regions
µ Option-drag the end of an audio region.

This action stretches or compresses the audio by the amount that the region is altered
in length, and replaces the original region with a new PCM audio file (in the original file
format, or AIFF, if the original was not PCM).

Note: The current setting in the Snap pop-up menu has an impact on length changes.

You can make an audio region play at half-speed by stretching it to twice the original
length, or at double-speed by shortening it to half the original length.
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You can choose the time stretching and compression algorithm used for this function in
the Arrange area’s Audio > Time Stretching Algorithm menu. Details on each algorithm
are found in Using the Sample Editor’s “Time and Pitch Machine.

Time Stretching Multiple Regions
Modifier keys have an impact on how time stretching or compression works when multiple
regions are selected. The following table outlines all modifier options, and their impact
(or otherwise) when multiple region lengths are changed:

ResultModifier

Same absolute length change; no time correctionNone

Same absolute end position; no time correctionShift

Same absolute length change, with time correctionOption

Same absolute region length, with time correctionOption-Shift

Can be used after clicking for finer resolution length changes, but
cannot be used in conjunction with Option; no time correction

Control

MIDI Region-Specific Length Change Operations
The following functions apply only to MIDI regions.

To round a MIDI region start point to a bar
µ Use the MIDI > Set Region Start to Bar command (or use the corresponding key command)

to round the start point of the selected MIDI region to the nearest bar.

The MIDI > Set Optimal Region Sizes Rounded by Bar command (or the corresponding
key command, default assignment:  Shift-Command-B) reduces or increases the length
of a selected MIDI region, making it just large enough to contain the events (or regions,
if a folder) within it. The region borders are rounded to the nearest bar.

Hold down the Option key when using this function to round the region borders to the
nearest denominator value (or use the Set Optimal Region Sizes Rounded by Denominator
key command).

Cutting, Copying, and Pasting Regions
You can select, remove, or replicate one or more regions from one part of an arrangement
to another. In fact, you can use the Cut, Copy, and Paste commands between the
arrangements of two projects, if you wish.

To cut a region
µ Select the region, then choose Edit > Cut (or use the Cut key command, default

assignment:  Command-X).

This action removes the region from the Arrange area and places it in the Clipboard.
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To copy a region (method 1)
µ Option-drag the region to the desired Arrange position.

If Hyper Draw or automation is activated, you need to grab the region name area in order
to copy it.

To copy a region (method 2)
1 Select the region, then choose Edit > Copy (or use the Copy key command, default

assignment:  Command-C).

This action copies the selected region to the Clipboard.

2 Set the playhead position by clicking the Bar ruler.

3 Choose Edit > Paste (or press Command-V) to paste the contents of the Clipboard into
the Arrange area. The paste occurs on the selected track at the playhead position.

If several regions are selected, their relative time and track positions are retained.

Copied regions are actually true, independent replicas of original regions. Changes made
to a parent region does not affect child copies.

If, instead, you do want this type of behavior—in which changes to the parent region
affect child regions—make use of the Loop function (see Creating Region Loops), or
create cloned or alias regions (see Creating Region Aliases).

When you copy an audio region, a new region is automatically created in the Audio Bin.
The new region retains the name of the original, with a sequential number added. For
example, kickingloop.1 will be the name of a region copy if the original region is called
kickingloop. A second copy will be named kickingloop.2, a third kickingloop.3, and so on.

To paste a region at the same position as the copied region
µ Select the track you want to paste the region into, then choose Edit > Paste at Original

Position (or use the corresponding key command).

Logic Pro inserts the copied region into the selected track, at the same position as the
source region. This is useful if you want to copy a region to the same spot on a different
track, to independently process or thicken the part, for example. This function is also ideal
for creating layered MIDI or software instrument parts.

Adding or Removing Arrangement Passages
There are times when you will want to remove an entire passage from an
arrangement—for example, a chorus or verse, which encompasses the regions of all tracks
between bars 16 and 20. All existing regions, bar changes, tempo changes, and global
score symbols (from bar 21 onward) are moved four bars to the left, closing the gap left
after the Cut operation.
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You can also insert a gap into your arrangement—creating several blank bars, for use as
a middle eight, to create space for another chorus or verse, or perhaps a bridge. As with
cutting time, all existing tempo changes and so on are moved accordingly (to the right
by the number of inserted bars).

You can also use the standard Edit menu commands—Cut, Copy, and Paste—to remove
or reuse a section of your arrangement, such as a chorus, from one location to another.

You can also limit changes to a few selected regions. If you do this, rather than moving
all regions within a project section, you are asked if you want to move global events such
as bar changes, tempo changes, and score symbols. This global edit is performed on all
regions, when used.

Important: The Arrange toolbar features a number of section editing buttons that can
be used to perform some of the operations described below. Whenever these toolbar
buttons are used, the operation affects all regions that fall between the locators, regardless
of the selection status of regions in this area. If you want to perform these operations on
selected regions within the locators, you should not use the Arrange toolbar buttons.
Instead, use the appropriate Region > Cut/Insert Time menu command (or key command),
after making your region selection.

To insert a gap into the arrangement using the locators (the cycle length)
1 Set the left and right locator positions by doing one of the following:

• Drag from left to right across the relevant portion of the Bar ruler.

• Set the values in the Transport bar’s Locator fields.

2 Select the regions you want to move by the cycle length. If no selection is made (or if
you use the Insert Silence button in a customized Arrange toolbar), all regions that fall
between the locators are affected.

3 Choose Region > Cut/Insert Time > Insert Silence Between Locators (or use the
corresponding key command).

• For selected regions that are longer than the cycle length:  This action cuts them at the
left locator position, and moves the second region (newly created from the cut) to the
right of the right locator position, creating a gap between the regions.

• For selected regions that fall wholly within the locators:  Regions which began at the
left locator position now begin at the right locator position.

• For a combination of partially and wholly selected regions that fall within the
locators:  The encompassed section is cut, and moved to the right locator position.

You can also remove empty space between selected regions, creating seamless joins
between them.
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To remove gaps between regions
1 Select the regions.

2 Choose Region > Tie Regions by Position Change (or use the Tie Regions by Position
Change key command).

The first region remains unchanged, and all subsequent regions are moved to the left.

To remove a section of your arrangement using the locators
1 Set the locators to span the section you want to remove (bars 5 to 8, for example).

2 Do one of the following:

• To cut all regions that fall between the locators:  Click the Cut Section button in the
Arrange toolbar, or use the Region > Cut/Insert Time > Snip:  Cut Section Between
Locators (or use the corresponding key command).
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• To cut selected regions that fall between the locators:  Choose Region > Cut/Insert
Time > Snip:  Cut Section Between Locators (or use the corresponding key command).

Any regions that span the cycle area (for example, a 16-bar long region that starts at bar
1 and ends at the start of bar 17) are cut.

The section between the locators (bars 5 to 8) is deleted from all selected regions. (In
fact, it is copied to the Clipboard and removed from the arrangement.)

All regions to the right of the right locator are moved to the left by the length of the cycle
(4 bars). This includes newly created regions that result from the operation.

In the case of the 16-bar region example, from above, it is cut into two regions:

• One spans bars 1 to 4.

• The other is now an 8-bar long region that is placed from bar 5 to the start of bar 13.

Tip: The Snip command is ideal for situations in which you want to remove an entire
section of your arrangement, such as a chorus.

To insert a cut section into your arrangement
1 Set the locators to span the section you want to remove (bars 5 to 8, for example).

2 Do one of the following:

• To cut all regions that fall between the locators:  Click the Cut Section button in the
Arrange toolbar, or use the Region > Cut/Insert Time > Snip:  Cut Section Between
Locators (or use the corresponding key command).

• To cut selected regions that fall between the locators:  Choose Region > Cut/Insert
Time > Snip:  Cut Section Between Locators (or use the corresponding key command).

3 Set the playhead to the position where you want to insert the cut section.

4 Either click the Insert Section button in the Arrange toolbar (to affect all tracks, regardless
of selection), or choose Region > Cut/Insert Time > Splice:  Insert Snipped Section at
Playhead.

397Chapter 13 Creating Your Arrangement



All selected regions are cut at the left locator, and a passage of one cycle length is inserted.
Regions currently in the Clipboard are then pasted at the playhead position.

Tip: The Splice command is perfect when you want to insert a part (a chorus, for example)
at another point in your arrangement. To ensure all tracks are shifted, including tempo,
time signature changes, and markers, make sure you select everything beforehand (using
Command-A or Shift-I).

To repeat a section of your arrangement using the locators
1 Set the locators to span the section you want to repeat (bars 5 to 8, for example).

2 Select the regions that you want to repeat. If no selection is made (or if you use the Repeat
Section button in the Arrange toolbar), all regions that fall between the locators are
affected.

3 Choose Region > Cut/Insert Time > Snip:  Repeat Section Between Locators (or use the
corresponding key command).

The portions of all regions that are wholly, or partially, encompassed by the locators are
copied and pasted to the right locator position.

Creating Region Aliases
An alias in Logic Pro is like an alias in the Finder. It looks like a region, but contains no
actual data. It is just a reference to the data of the original region—a virtual reflection of
the original.

398 Chapter 13 Creating Your Arrangement



Understanding the Parent-Alias Region Relationship
If the data in the original region is altered, all aliases of the region are affected immediately.
Aliases are useful in the following situations:

• If a riff or phrase reoccurs throughout an arrangement, it’s quicker to use aliases, rather
than creating copies of the original region.

• If a part is not quite right, you only need to alter the original, and the correction takes
effect automatically throughout the whole arrangement.

If, however, you want to alter a detail at one point in the arrangement (a pitch-shifted
verse, for example), you can turn that particular alias into an independent region (a region
copy).

Aliases do have a level of independence from their parent region:

• Aliases have their own set of region parameters.

• Aliases can be individually named. Alias region names are shown in italics. If you name
an alias region, its parent region name is shown below the alias name (provided that
the zoom level is adequate).

Any changes made to the parent region name are reflected on all alias regions.

Note: MIDI region aliases cannot be edited. If you double-click an alias, Logic Pro assumes
that you either want to edit the original, or turn the alias into a real region. You are asked
whether you want to create and edit a real copy, or to edit the original.

Creating MIDI Region Aliases
Aliases can be created for MIDI regions and folders. The term region refers only to MIDI
regions and folders in this section.

Note: Only cloned audio regions (or independent region copies) can be created for audio
regions. (See Creating Region Clones.)

To create an alias
Do one of the following:

µ Option-Shift-drag the region to the position for the alias.

µ Select the track you want to create the alias on, position the playhead, select the region
you want to create an alias from, then choose MIDI > Alias > Make (or use the Make Alias
key command).
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The alias appears on the selected track, beginning at the current playhead position.

If several regions are selected, their relative time and track positions are retained. The
selected track is the destination track for the first region along the timeline.

You can also use the Repeat Regions command. (See Creating Multiple Copies of Regions.)

Reassigning MIDI Region Aliases
You can assign a new original region to an existing alias. This is exceptionally handy for
arranging tasks where the structure is right, but the part is wrong. You can copy a region
to the appropriate position on a new track, create an alias, mute the existing region, and
click Play, or use the far simpler method below:

To reassign an alias
1 Select both the alias and the intended new original region.

2 Choose MIDI > Alias > Re-Assign (or use the Reassign Alias key command).

Searching for Original or Alias Regions
If you forget where the original is for a certain alias, you can search for it.

To find and select the original region of an alias
µ Select the alias, then choose MIDI > Alias > Select Original (or use the Find Original of

Alias key command).

To find any aliases you’ve made from a region
µ Choose MIDI > Alias > Select All Aliases of Region (or use the corresponding key command,

default assignment:  Shift-A).

All existing aliases are found, and selected.

Selecting and Deleting Orphan Aliases
If you delete a source region that one or more aliases was derived from, Logic Pro asks if
you want to convert the aliases to independent MIDI regions, or keep the aliases.

• Click Cancel to cancel the procedure.

• Click Convert to change all alias MIDI regions into real copies.

• Click Keep to delete the parent region, and retain all (orphaned) alias regions. Although
such orphan aliases serve no useful purpose, Logic Pro doesn’t automatically delete
them, as you might decide to reassign them to new originals at a later stage.

If your project file contains several unneeded aliases, you can quickly tidy up by selecting
and deleting all orphan aliases.

To select all orphan aliases
µ Choose MIDI > Alias > Select All Orphan Aliases (or use the corresponding key command).
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To delete all orphan aliases
µ Choose MIDI > Alias > Delete All Orphan Aliases (or use the corresponding key command).

Converting an Alias into a Real Region
You can use MIDI > Alias > Convert to a Region Copy (or the Convert Alias to a Region
Copy key command) to make a real region from an alias; its contents are identical to those
of the original region referenced by the alias, but its playback parameters are those of
the alias. As a real region, you can freely edit it (or the original parent region, without
affecting the new real region).

Note: You can also double-click an alias to open a dialog that asks whether you want to
create and edit a real copy, or edit the original.

Creating Region Clones
You can create another version of an audio region in the Arrange area—a cloned
region—which is comparable to a MIDI region alias.

To create a cloned region
µ Hold Option-Shift while dragging an audio region.

Whenever you adjust the start or end point of any of these cloned regions, all other cloned
regions are adjusted in the same way.

To make several cloned regions independent of each other
µ Select the (cloned) regions and choose Audio > Convert Regions to New Regions (or use

the corresponding key command, default assignment:  Option-Command-R) in the Arrange
area.

Cloned regions that are made independent in this way can have their start or end point
altered without affecting all other cloned regions.

To convert several selected regions into audio files
1 Choose Audio > Convert Regions to New Audio Files (or use the corresponding key

command, default assignment:  Option-Command-F).
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2 In the dialog that appears, set the sample rate, bit depth, file format, stereo conversion,
and dither type for the destination files.

The new audio files are created in the same folder as your original audio file. The files are
also added to the Audio Bin, and all references to these new arrange regions are changed
to correspond with the newly created files.

These newly created files can be edited independently, allowing you to reverse, time
stretch, and more, without affecting other regions based on the same original file.

Converting Regions to a New Sampler Track
You can convert one or multiple regions or tracks into one-note/one-sample zones of a
new EXS instrument. This EXS instrument is set up on a new software instrument track,
which contains trigger notes to play the zones at their original positions.

To convert a region, or regions, to a new sampler track
1 Select one or more audio regions in the Arrange area.

2 Choose Audio > Convert Regions to New Sampler Track (or use the corresponding key
command).
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The dialog that appears looks something like the following:

3 Choose whether you want to create zones from regions or transient markers:

• Regions: Converts the entire selected region, or regions, into an EXS zone.

• Transient Markers: Converts only those sections between transient markers into an EXS
zone.

Note: If you create zones from transient markers, a transient detection process is
performed on the audio region(s), if not previously done.

4 Enter the EXS instrument name in the text input field. The default is the name of the first
region selected.

5 Choose settings from the Trigger Note Range pop-up menus—the lowest and highest
note for the one-note zones created in the new sampler instrument.

6 Click OK to perform the conversion.

A new software instrument track is created, below the selected track, on which the EXS24
is inserted. MIDI regions with ascending trigger notes are created on this track. The new
track and regions are selected, while the processed regions are muted and deselected.
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Note: The EXS instrument is saved to the project folder, independent of the File > Project
Settings > Assets > “Copy EXS instruments to project folder” setting. The EXS samples,
however, are only saved to the project folder if the File > Project Settings > Assets >
“Copy EXS samples to project folder” setting is turned on.

Creating Multiple Copies of Regions
You can make multiple copies of both audio and MIDI regions using the Repeat Regions
command.

To make multiple copies of a region
1 Select the region you want to make multiple copies of.

2 Choose Region > Repeat Regions in the Arrange area’s local menu bar (or use the Repeat
Regions/Events key command, default assignment:  Command-R).

3 Set the following parameters in the Repeat Regions/Events window:

• Number of Copies pop-up menu: Choose the number of copies you want (excluding the
original).

• Adjustment pop-up menu: Choose whether you want to position the region copy at the
end of the selected regions (Auto), or snap the region copy to the chosen grid setting
(Bar, Beat, Division, 1/96, Seconds, Frames, Quarter Frames).

• As buttons: Select whether the repeats are copies, aliases (MIDI regions), or clones
(audio regions) of the original.

Creating Region Loops
The Loop function allows you to repeat a region automatically, without needing to copy
it. A looped region repeats until it encounters another region on the same track, or the
project ends. A loop also terminates at the end marker of a folder, if the looped region
is inside a folder. (See Working with Folders.)
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Loop repeats are displayed as extended segments of the original region, but are displayed
with less color. Each segment is the same length as the original region, and changes if
the length of the original region is changed.

Tip: If you want to create polyrhythmic structures, try experimenting with the length of
the original region.

To loop a region with the Loop parameter
1 Select the region in the Arrange area.
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2 Select (turn on) the Loop option in the Region Parameter box of the Inspector (or use the
“Loop Regions/Folders on/off” key command, default assignment:  L).

The region is looped until it encounters another region on the same track (or the project
or folder ends).

To turn off the Loop parameter
µ Select the Loop option in the Region Parameter box (or use the “Loop Regions/Folders

on/off” key command, default assignment:  L).

To loop a region with the mouse
1 Move the pointer to the end of the region that you want to loop.

The pointer changes into a circular arrow (the loop length editing tool) when positioned
in the upper area of the region.
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2 Drag the end of the region to the right to set the length of the looped region.

The loop repeats are shown as segments (of the same length as the original region) within
the overall looped region. The Loop parameter in the Region Parameter box is
automatically activated.

Note: Deactivating the Loop parameter resets the manually created loop length. The
next time the Loop parameter is used, the region is repeated until it encounters another
region on the same track or the end of the project (or folder) is reached.

The pointer only turns into the circular arrow (and offers the loop length editing functions),
when the track is of sufficient height. Use any of the zooming options to resize, if necessary.

If you want to select the looped region (to move it, for example), click in the lower half
of the looped area, or Shift-click in the upper loop area.

Note: Most of the other tools can also be used to set the loop length—they also take on
the circular arrow shape when held over the top-right area of regions. You should use
the Pointer tool, however, because clicking the wrong spot on a region when the Eraser
tool is selected will delete the region, rather than set the loop you intended to create.

Loop repetitions are merely pointers to the original region. They cannot be transposed
and don’t have any playback parameters in the Region Parameter box, shown in the
Inspector. Only a real region (or a copy) offers playback parameters and can be transposed.
If you want to use different playback settings for each of the loop repetitions, you need
to turn them into real copies.

To convert an existing loop into a real copy
1 Select the original region.

2 Choose Region > Loops > Convert to Real Copies (or use the Convert Loops to Real Copies
key command, default assignment:  Control-L).

New regions replace the loop repeat segments.

The advantage of real copies is that they can be independently resized. This may be useful
in situations when you want to resize a few loop copies among hundreds that span the
song length.

To convert a loop into aliases or clones
1 Select the original region.
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2 Choose Region > Loops > Convert to Aliases (or use the Convert Loops to Aliases key
command).

MIDI region loop repeats are converted into aliases. Audio region loop repeats are
converted into cloned audio regions.

As such, any alterations to the length of the original region affect all aliases and cloned
regions.

Dividing Regions
You can divide one or more selected regions with the Scissors tool.

To divide one or more regions
1 Select the regions you want to divide.

2 Select the Scissors tool.

3 Click-hold the regions you want to divide.

The help tag shows the current divide position.

4 Release the mouse button.

All selected regions are cut at the position shown in the help tag.

When selecting a cut point with the Scissors tool, you can move backward and forward
in steps of one division. The grid is based on the Snap pop-up menu setting.

To make finer resolution divisions (overriding the current Snap value)
Do one of the following:

µ Hold down the Control key after you select the region with the Scissors tool to divide in
the division value (1/16th, 1/32nd, and so on, as shown in the Transport bar).

µ Hold Control-Shift to divide regions with even more precision (ticks or samples).

The newly created segments of an audio region are named after the original, with a
sequential number appended to the end of the name.

Divided MIDI regions are named after the original, with no sequential numbering. Each
MIDI region resulting from the division is independent and contains data.
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To divide a region into several portions with the same length
µ Hold down the Option key while cutting a region with the Scissors tool.

A plus symbol appears next to the Scissors tool, and the help tag shows Divide Multiple.

The selected region is cut into several pieces—each the same length as the first segment.

For example, to divide a 16-bar region into eight 2-bar regions, cut the region at the start
of bar 3, while holding down the Option key.

To divide regions at the locator positions
1 Set the left and right locator positions where you want them.

2 Select the regions you want to divide within the locator boundaries.

3 Choose Region > Split > Split Regions by Locators (or use the Split Regions/Events by
Locators or Marquee Selection key command).

409Chapter 13 Creating Your Arrangement



All selected regions located wholly, or partly, between the locators are cut at the left and
right locator positions. All regions created between the locator positions as a result of
the Split operation are then automatically selected.

Tip: You can achieve the same effect by defining a cycle with the mouse in the Bar ruler,
while holding down the Command key.

To divide regions at the playhead position
1 Select the regions you want to divide.

2 Choose Region > Split > Split Regions by Playhead (or use the Split Regions/Events by
Playhead Position key command).

All selected regions are split exactly at the playhead location.

Tip: To cut at the nearest bar, use the Split Regions/Events by Rounded Playhead Position
key command.

Handling Overlapping Notes in Divided MIDI Regions
If any notes in a divided MIDI region overlap other notes by more than a 1/16 note, you
are asked if you want to keep, shorten, or split the notes.

• Click Keep to leave all notes unaltered. The MIDI region is cut as expected, but you can
end up with notes in the left half (earlier region) that are much longer than the MIDI
region containing them. Such notes play normally, unless Clip Length is activated. (See
Adjusting the Start or End Point of MIDI Regions.)

• Click Shorten to truncate all overlapping notes, so that they end at the point where
the original MIDI region was divided.

• Click Split to divide overlapping notes across the two MIDI regions; two notes are
created, with the same pitch and velocity as the original, and with the same total length
as the original note.

Important: The Audio > Snap Edits to Zero Crossings setting in the Arrange area’s local
menu bar has no effect when dividing audio regions, using any of the methods outlined
above. Audio > Snap Edits to Zero Crossings, when activated, only applies to alterations
of the start or end point of a region, not divide operations. If you want to automatically
divide an audio file into multiple regions, use the Strip Silence function.

Dividing Audio Regions with Strip Silence
The Audio > Strip Silence function in the Arrange area’s local menu bar opens a window
which allows you to slice an audio recording into different audio regions. This division is
based on analysis of amplitude levels within the audio file. A detailed description of this
function can be found in Removing Silent Passages from Audio Regions.
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Demixing MIDI Regions
You can split MIDI regions (or Standard MIDI File Formats 1 or 0) by event channels or
note pitches.

To split MIDI regions by event channels
1 Select the MIDI regions you want to split.

2 Do one of the following:

• Choose MIDI > Separate MIDI Events > by Event Channel (or use the Separate MIDI
Region by MIDI Channel key command).

• Control-click (or right-click) the MIDI region, then choose MIDI > Separate by MIDI
Channel from the shortcut menu.

Logic Pro searches the selected MIDI regions for events with different MIDI channels.

• A separate MIDI region, containing all matching events, is created for every MIDI channel
that is found.

• Each of these regions is created on a track with an instrument channel that matches
the MIDI channel.

• If no such tracks exist, new tracks are created for each channel.

To split MIDI regions by note pitches
1 Select the MIDI regions you want to split.

2 Do one of the following:

• Choose MIDI > Separate MIDI Events > by Note Pitch (or use the Separate MIDI Region
by Note Pitch key command).

• Control-click (or right-click) the MIDI region, then choose MIDI > Separate by Note Pitch
from the shortcut menu.

Logic Pro searches the selected MIDI regions for notes with different note numbers.

• A different MIDI region of the same length is created for every note number found.

• Tracks are created for these MIDI regions, and all are assigned to the same channel
strip as the original MIDI region.

This feature is especially useful for separating drum parts that have been recorded into
Logic Pro from a drum machine where all notes are on the same MIDI channel. Each note
region can then be assigned to another channel strip, or perhaps some can be deleted,
to thin out the original drum pattern.
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Merging Regions (General Tools and Commands)
You can merge two or more selected regions (of the same type—audio or MIDI) into a
single region, making region handling easier, or as a creative option.

To merge two or more regions with the Glue tool
1 Select the Glue tool.

Glue tool

2 Click the regions that you want to merge. (If necessary, use the Shift key during selection.)

To merge two or more regions with the Merge Regions command
1 Select the regions you want to merge with the Pointer tool.

2 Choose Region > Merge > Regions (or use the Merge Regions/Notes key command).

This action merges all selected regions, even those on different tracks, into a single region.

To create several merge files, each on their own track
1 Select the regions that you want to merge on each track with the Pointer tool.

Shift-clicking, dragging to select, or Command-A may be useful for this step.
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2 Choose Region > Merge > Regions per Tracks (or use the “Merge Regions per Tracks” key
command).

The selected regions are combined into one region per track. For example, if tracks 1 to
4 have regions that you want to merge, you can make your region selections in each
track lane, press Shift-J, and four merged regions are created—one for each track.

Merging MIDI Regions
When you merge MIDI regions:

• All events from each individual MIDI region retain their original time positions.

• The new (merged) MIDI region adopts the name and track of the first (along the timeline)
of the original MIDI regions.

• The Transposition, Velocity, and Dynamics region parameters—if not identical in all
selected regions—are normalized before the merge. This means that all parameter
values are written as data changes for each region before the merge. The parameters
of the newly created (merged) MIDI region are all set to neutral (default) values.

• If one of the region parameters (the Transposition value, for example) is set identically
in all selected regions, that value is preserved in the Region Parameter box for the
merged region, and the events remain unchanged from their original values.

Note: Be aware that the individual MIDI channels of events (if applicable) are replaced
by the MIDI channel of the current track Instrument channel strip.

Merging Audio Regions
Merging audio regions is a nondestructive operation because Logic Pro always creates a
new file for the merged audio material (sometimes called a mixdown).

This new audio file is stored (in the project folder) on your hard disk and is automatically
added to the Audio Bin. The merged region replaces the original regions.
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No Mixdown Situation
If there are several regions (mono or stereo) in a row on the same track that have been
cut out of one region with the Scissors tool, no mixdown happens. In this situation, a
single region is created over the entire area. This delivers the desired result, without using
any additional disk space.

Note: Logic Pro can recognize associated regions, even if there are gaps between them.
The determining factor is that the relative position of the regions in the Arrange area
corresponds to the relative position of the regions in the underlying audio file.

No mixdown occurs when you try to mix two regions on tracks that are panned to opposite
sides, as the two resulting mixdown files would be identical to the original audio files (in
the areas used for the regions).

Genuine Mixdown with Clipscan
If you combine audio data (in regions) from two or more tracks, the current pan and
volume values for the individual tracks will define the pan and volume settings in the
new audio file.

If you want to combine both sides of a stereo audio file (a mono channel on each of two
tracks), first set the pan controls of the component mono sides to hard left and hard right,
respectively.

Following the digital clipping scan (Clipscan) and completion of the mixdown, Logic Pro
replaces the previously selected regions with one region that contains the entire
mixed-down audio file.

You can use the Edit > Undo function (Command-Z) to restore the original audio regions,
if you change your mind about the mixdown. If you do so, you are asked if you want to
keep, or delete, the newly created mixed audio file. If you keep it, it remains in the Audio
Bin, and can be further used and processed.

During a mixdown, the 32-Bit resolution Clipscan function ensures that the highest
possible level is maintained, without clipping.

Mixdown of Audio Regions on a Track
If several overlapping audio regions are selected on a single track, no mixdown occurs.
You are asked to create a new audio file, which is named after the first region on the
track. The selected regions are then mixed together, with no changes to volume, and
without clip scanning.

If there are empty sections between two regions, these are added into the new audio file
as silent passages.

Audio Crossfades in Digital Mixdown
The Digital Mixdown supports crossfades between selected regions.
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The Crossfade parameters are defined in the General Audio preferences pane, which can
be opened either by choosing Logic Pro > Preferences > Audio > General (or use the
Audio Crossfade Options for Merge key command).

There are two faders:

• Crossfade Time [ms]: This is the length of the entire crossfade. To turn off the crossfade,
set this value to zero.

• Crossfade Curve: To obtain a linear crossfade, set this value to zero. Other values (positive
or negative), produce various exponential fades. The fade-outs and fade-ins are always
symmetrical, to avoid deviations in level. The preset values are Time = 0 ms, Curve = 0
(linear).

Working with Folders
A folder is a region that can contain other regions, much like a folder in the Finder can
contain other folders or files. In principle, you can edit folders as you would edit MIDI
regions.

One way to visualize a folder is as an arrangement within an arrangement. A folder can
contain as many tracks, featuring regions, as required. A closed folder looks like a MIDI
region, but is placed on a track assigned to a folder in the track list, rather than a channel
strip.
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When opened, folders look just like the Arrange area and track list in a project.

All regions in the folder are routed to, and played by, the channel strips set in the folder’s
track list, just as they would at the top level of the Arrange window.

Note: If you drag a folder to a track that is set to an instrument channel strip, its entire
contents (all MIDI regions within the folder) are played by that instrument. This usually
only makes sense if the folder contains tracks for a given instrument or instrument type,
such as a drum kit or generic string sound. This technique provides a quick way of listening
to a string arrangement, if some of the intended sound sources are unavailable, for
example.

For example, a brass section folder could contain trumpet, saxophone, and trombone
tracks, or perhaps 14 tracks of drum instruments, which you may want to treat as a single
drum pattern region.

In the same way, your entire project, including all tracks and regions, could itself be a
folder, appearing as a gray beam in an arrangement. In this way, you could arrange several
projects for a concert.

This is not all that folders can do. You can use folders to represent song choruses and
verses, for example. As in the Finder, you can place as many folders as you like within
other folders, and within yet more folders (for the instrument groups within the different
parts of the song, as an example), with no limit to the number of levels you can create.

Another possible use might be to store different arrangements of a project in different
folders, allowing you to switch between them rapidly.

Packing and Unpacking Folders
You can pack selected regions into a folder, or create an empty folder and add regions
to it.

To pack selected regions into a folder
1 Select the regions.

2 Choose Region > Folder > Pack Folder (or use the corresponding key command, default
assignment:  Shift-Command-F).

If all selected regions are located on different tracks, a new folder track is created.
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If all selected regions are located on the same track, the folder is created on that very
track, and not on a separate folder track.

Note: When moving a folder with just one content track between tracks of matching
type, the content always plays back via the channel strip of the hosting track.

If no region is selected, Logic Pro creates an empty folder. It contains no regions—just
tracks assigned to all channel strips from the current level.

To unpack a folder
1 Select the folder.

2 Choose one of the following commands:

• Choose Region > Folder > Unpack Folder.

The Arrange window updates to display the contents (the tracks and regions) of the
folder.

• Choose Region > Folder > Unpack Folders (Create New Tracks), or use the “Unpack
Folder to New Tracks” key command, default assignment:  Command-U.

Logic Pro creates new tracks on the same level that the folder was located on (below
the former folder track).

• Choose Region > Folder > Unpack Folders (Use Existing Tracks), or use the “Unpack
Folder to Existing Tracks” key command.

The regions contained within the folder are placed on tracks assigned to appropriate
channel strips.

Entering and Exiting Folders
Once you have packed a folder, you will generally enter and exit it to alter data, as your
arrangement grows. You can easily differentiate when you are inside or outside of the
folder display in the Arrange window:

• When at the top Arrange level (outside the folder), the folder itself is visible on a track,
the Arrange window title bar shows the project name, and the Hierarchy button is
dimmed.

• When inside a folder, the folder track can’t be seen, the Arrange title bar shows the
project name followed by the folder name (Untitled:  Chorus Folder, for example), and
the Hierarchy button is available.

To enter a folder
Do one of the following:

µ Double-click the folder region.

µ Select the folder you want to enter, then use the Go Into Folder or Region key command.
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You should ensure that the folder is selected before using the command. If a MIDI region
is selected, the Event List editor (showing the MIDI region content) is opened.

Double-clicking a folder track name in the track list opens the Mixer.

To exit a folder
Do one of the following:

µ Double-click the (folder) Arrange area background (or use the Go Out of Folder or Region
key command).

µ Click the Hierarchy button at the left end of the Arrange area’s local menu bar. The help
tag shows Leave Folder.

You move one level up the display hierarchy, and the contents of the Arrange window
(showing the closed folder) are visible.

Adding and Removing Regions from Folders
You can easily add regions to, or remove regions from, an existing folder. This is fairly
commonplace as you will often experiment with your arrangement, and find that you
need to add or remove parts.

To move regions into a folder
µ At the top level of the Arrange hierarchy (outside the folder) drag the regions onto the

folder, at the desired position.

If the folder does not already contain a track that uses the same channel as the source
region, Logic Pro creates one. If it does, this channel is used. When you enter the folder,
you see the dragged regions at the drop position.

To drag individual regions out of folders
1 Open a second Arrange window by choosing Window > Arrange in the main menu bar

(or using the Open Arrange Window key command, default assignment:  Command-1).
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2 Enter the folder that you want to remove the region from in one of the two Arrange areas.

3 Drag the region from the folder into the other Arrange area.

You can also cut a region from a folder, using the Edit > Cut command. This transfers the
region to the Clipboard. You can then copy the region to the desired Arrange area position
using the Edit > Paste command.

Creating an Alias Folder
You can create a copy of a folder that contains aliases and clones of the regions in the
original folder. The advantage is that, within this folder, you can (for example) mute
regions, and alter program, instrument, or playback parameters. This provides you with
an alternate mix folder—don’t forget that folders can be muted and soloed, like other
regions—allowing you to quickly switch between different arrangement versions.

To create an alias folder
1 Select a folder.

2 Choose MIDI > Alias > Make but Copy Folder.

Creating Crossfades and Fades on Audio Regions
You will often create fade ins or fade outs on audio regions, including Apple Loops audio
files, or use crossfades to smoothly segue between two adjacent (or overlapping) audio
regions on a track.

The latter type of fade, the crossfade, can be performed automatically on overlapping
audio regions using Logic Pro.

To enable automatic crossfades
µ Choose the X-Fade setting from the Drag pop-up menu. (See Using Drag Modes.)

You can also create crossfades manually—as well as fade ins and fade outs—using the
Fade tool, the Fade parameters in the Inspector’s Region Parameter box, or the shortcut
menu of an existing fade area.

Tip: You should make use of both methods, as each has advantages. When combined,
the process of creating and editing fades is quicker and easier.

You can simultaneously adjust the fade parameters for all selected audio regions.

Note: These fade parameters are nondestructive (they don’t change the original audio
file), as opposed to the fade functions available in the Sample Editor.
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Creating Fades
A fade in starts at the beginning of an audio region, and a fade out occurs at the end of
the region. Fades are only visible if you are sufficiently zoomed in to see the waveform
in the audio region. You can either use the Fade tool or the parameters in the Inspector’s
Region Parameter box to create fades.

To create a fade in or fade out with the Fade tool
1 Select the Fade tool.

Fade tool

2 Do one of the following:

• Drag over the start or end point of an audio region.

This creates a fade in or fade out. The length of the fade drag area determines the
length of the fade, so a longer drag area results in a longer fade time, and a shorter
drag area, a quick fade.

• Drag over the end point of one audio region and the start point of the following region.

This works, even if the two sections don’t directly adjoin each other.

To create a fade in or fade out using the Inspector’s Region Parameter box
1 Select one or more regions.
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2 Set the value for the Fade In or Fade Out setting in the Region Parameter box. Use the
mouse as a slider, or double-click and type in the value.

As you do so, a fade is created at the beginning or end of the selected regions.

Note: The fade value determines the length of the fade, so a higher value results in a
longer fade time, and a lower value, a shorter fade.

Editing and Deleting Fades
You can change an existing fade, the fade curve shape, the fade type, and the fade
playback speed. You can also delete fades.

Changing an Existing Fade
You can change an existing fade with the Fade tool, or by modifying the parameters in
the Inspector’s Region Parameter box.

To change an existing fade
Do one of the following:

µ Drag over the start or end point of a fade with the Fade tool.
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µ Select a region, then edit the Fade In or Fade Out value in the Region Parameter box.

When you change an existing fade, the curve shape of the previous fade is retained.

Changing the Fade Curve Shape
You can change the fade curve shape with the Fade tool, or by modifying the parameters
in the Inspector’s Region Parameter box.

To adjust the fade curve shape
Do one of the following:

µ Drag the curve line with the Fade tool.

µ Select a region, then edit the Curve value in the Region Parameter box.

In the example below, a positive curve is shown for both the fade in and fade out.

In the example below, a negative curve is shown for the fade in, and a linear fade (no
curve) is shown for the fade out.
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Changing the Fade Type
You can choose between four different fade types, in the Inspector’s Region Parameter
box or in the Arrange area:

• Out (Fade Out): Creates a standard fade out whenever the Fade tool or Fade parameter
is used.

• X (Crossfade): Crossfades the selected region with the following region when you use
the Fade tool or Fade parameter.

• EqP (Equal Power Crossfade): Results in an Equal Power crossfade. This minimizes volume
dips between audio regions, resulting in a more even crossfade between regions that
may be slightly different in level.

• X S (S-Curved Crossfade): Delivers an S-curved crossfade. The fade curve, as the name
suggests, is S shaped.

To change the fade type
Do one of the following:

µ Open the Fade Type pop-up menu in the Region Parameter box, then choose a fade type.

µ Control-click (or right-click) the fade or crossfade, then choose a fade type from the
shortcut menu.

Note: The latter three options can only be applied to two consecutive regions. Also note
that the Fade In (and corresponding Curve) parameters are made redundant when any
of the X, EqP, or X S options is chosen.

Changing the Fade Playback Speed
Logic Pro offers Speed Up and Slow Down parameters in the Inspector’s Region Parameter
box or in the shortcut menu of an existing fade area, allowing you to speed up or slow
down the playback speed of fades. In the Region Parameter box, the Speed Up and Slow
Down parameters share pop-up menus with the Fade In and Fade parameters.
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To change the playback speed
Do one of the following:

µ Choose the Speed Up parameter, and modify the value accordingly.

µ Choose the Slow Down parameter, and modify the value accordingly.

Deleting a Fade
You can delete a fade with the Fade tool, or by modifying the parameters in the Inspector’s
Region Parameter box.

To delete a fade
Do one of the following:

µ Control-click an existing fade area, then choose Remove Fade from the shortcut menu.

µ Option-click an existing fade area with the Fade tool.

µ Set the Fade In or Fade Out parameter in the Region Parameter box to 0.

Deleting Fade Files
Use of the Options > Audio > Delete All Fade Files command deletes the fade file. No
information will be lost by doing this, because Logic Pro automatically creates a new fade
file the next time playback is started, based on the fade parameters of each audio region.

Fading Apple Loops
You can apply fades to Apple Loops audio files. Fade parameters are displayed in the
Region Parameter box when an Apple Loops audio file is selected.

Setting Region Parameters
The parameters displayed in the Inspector’s Region Parameter box depend on the region
type selected in the Arrange area. Some parameters are:

• Available for audio and MIDI regions

• Only available for audio regions

• Only available for MIDI regions

Note: The MIDI region parameters also apply to folders, and globally affect all MIDI regions
within them.

Common Audio and MIDI Region Parameters
The following common parameters are available when either audio or MIDI regions are
selected.

• Quantize: All note events contained in the MIDI region are time-corrected to the
(quantize) grid format chosen in the menu. Full details on all quantization functions
available in Logic Pro are found in Quantizing Audio and MIDI.
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• Q-Swing: This percentage value alters the position of every second point in the current
quantization grid. Values over 50% delay the beats. Values under 50% pre-delay them.
The most practical settings fall between 50% and 75%, imparting a swing feel to strictly
quantized (or tightly played) audio or MIDI regions.

• Loop: The playback of all region types can be continuously repeated by selecting the
Loop checkbox, or through use of the Loop tool. (See Creating Region Loops.)

• Delay: The playback of all region types can be delayed or advanced (this can be a
positive or negative value) by ticks, or a musical format variable; for example, 1/96,
1/16, 1/192, and so on. (For more information, see Shifting the Playback Position of
Regions.)

• Advanced Quantization:  Q-Strength: This percentage value determines how far a note
is shifted toward the nearest grid position. 100% results in full quantization; 0% leaves
the note at its recorded position.

• Advanced Quantization:  Q-Range: Q-Range is a very musical quantization strategy that
requires a certain amount of technical musical prowess. It is ideal for recordings that
already have the right groove, but are too hurried or laid-back in places. It allows you
to retain the original feel, but positions the rhythmic center precisely in the groove. A
value of 0 means that every note is quantized. If you enter negative Q-Range values,
only notes that fall outside the set range are moved to ideal quantization grid positions,
while notes closer to an ideal position remain unquantized. This moves the most poorly
played notes (those outside the range) to perfect timing positions on the quantization
grid, or at least towards these positions, depending on the Q-Strength setting.

MIDI Thru:  MIDI Region Defaults
If no region is selected, the upper line of the Region Parameter box displays MIDI Thru.
Any live MIDI input (in Stop mode, as well as during recording or playback) is played with
the settings chosen here. When you record a new MIDI region, the settings in the MIDI
Thru Parameter box are carried across to the new MIDI region’s Parameter box. The MIDI
Thru Parameter box can be viewed as an adjustable default Parameter box.

The MIDI Thru parameters can be adjusted when no regions are selected. Click the Arrange
window background to deselect all regions.

Note: The Set Track and MIDI Thru Parameters by Region/Folder key command allows
you to set the MIDI Thru parameters to match those of a selected MIDI region. This action
also selects the region’s track.
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Editing Several Regions Simultaneously
If several regions are selected, the number of selected regions is displayed, in place of a
region name. If you alter any region parameter, all selected regions are affected. If a given
parameter is set differently in the individual regions, an asterisk (*) appears in the
Parameter field. You can alter this parameter for all selected regions, and the value
differential will be retained (relative alteration). If you want to set all selected regions to
the same value, hold down the Option key while changing the value (absolute alteration).

Audio Region Parameters
Audio region parameters vary, depending on the type of audio region selected:  basically,
this is broken down into standard audio regions and Apple Loops.

The Fade and Gain parameters are only available when standard audio regions are selected.

• Gain: This parameter adjusts the volume of individual audio regions by the chosen
amount.

• Fade In/Speed Up: This parameter allows you to switch between Fade In and Speed Up
parameters, where you apply fade values for volume and playback, respectively.

• Curve: This parameters adjusts the fade-in curve shape.

• Fade/Slow Down: This parameter allows you to switch between Fade Out and Slow
Down parameters, where you apply fade values for volume and playback, respectively.

• Curve: This parameters adjusts the fade-out curve shape.

When Apple Loops (either green or blue) are added to audio tracks, the Transposition
and Follow Tempo parameters are shown.

• Transposition: This parameter adjusts the pitch of the Apple Loops audio region up or
down by the chosen amount.

• Follow Tempo: This parameter (on by default) allows Apple Loops to follow the project
tempo.

MIDI Region Parameters
If you select a MIDI region (on a software or external MIDI track), the Region Parameter
box displays the following MIDI region–specific parameters.

These parameters are also shown when a green Software Instrument Apple Loops file is
added to a track routed to an instrument channel. (The Apple Loops instrument is loaded
into the Instrument slot of the channel strip.)

• Transposition: All note events contained in the MIDI region are transposed up or down
by the selected amount during playback. Even complete folders can be instantly
transposed in this way. If several individual MIDI regions within the folder have already
been transposed, the relative differences between them are retained.
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If you want to transpose by octaves, click the arrows to the right of the Transposition
parameter. A pop-up menu opens that allows direct octave transpositions.

To guard against drum notes and so on being transposed, an instrument channel’s
Parameter box contains a No Transpose checkbox. If you select this option, the Transpose
parameter is ignored in all MIDI regions played by this instrument channel strip
(including green Apple Loops added to tracks routed to instrument channels).

• Velocity: All notes in the relevant MIDI region are offset by the selected value. Positive
values add to the originally recorded velocity, and negative ones subtract from it,
although naturally it is impossible to go outside the limits defined by the MIDI Standard
(0–127). If you select a velocity offset that exceeds the maximum or minimum possible
value for a particular note, that note will play at the extreme possible range. For example,
a setting of +20 will cause a note with a velocity of 120 to play at 127.

• Dynamics: This parameter also affects the velocity values of notes, but instead of adding
or subtracting a fixed amount, the differences between soft and loud notes (the
dynamics) are increased or decreased. This works in a similar way to a compressor or
expander. Values above 100% expand the dynamics, thereby increasing the difference
between loud and soft, while values below 100% compress the dynamics, reducing
the differences between loud and soft.

The Fixed setting causes all notes to be transmitted at a velocity value of 64. When
used in conjunction with the Velocity parameter (see above), it is possible to set any
fixed velocity value.

• Gate Time: The term gate time stems from the technology used in analog synthesizers,
and refers to the time between pressing and releasing a key. This parameter affects
the absolute note duration or length. This should not be confused with the musical
note value, which normally refers to the amount of time until the next note. The practical
effect is to make the notes in the region more staccato or legato. The parameter range
is related to the original note lengths. Fix produces extreme staccato. Values below
100% shorten the note lengths. Values above 100% lengthen the notes. The “legato”
setting produces a completely legato effect for all notes, no matter what their original
lengths, eliminating all space between notes in the affected region. If this is used on a
folder, all notes in all MIDI regions in the folder are affected.

• Clip Length: The point of this function is to allow you to alter the length of the last
notes in a region directly from the Arrange area, by adjusting the length of the MIDI
region. When turned on, any notes sounding when the region ends are abruptly cut
off. When turned off, notes are played to their normal end point, regardless of where
the region ends.

• Score: The point of this function is mainly to prevent the score display of particular
regions—namely those that only contain MIDI events that can’t be displayed in the
score, such as controller or SysEx data. When turned off, the MIDI region is not displayed
in the score at all.
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• Advanced Quantization:  Q-Flam: Notes with the same time position (chords) are spread
out by this parameter. Positive values produce an ascending (upward) arpeggio; negative
values a descending (downward) arpeggio. The position of the first note (either the
bottom or top note, assuming all notes start at the same position) in the arpeggio is
unaltered.

• Advanced Quantization:  Q-Velocity: This parameter (expressed as a percentage)
determines the amount that the velocity values of quantized notes are affected by the
velocity values of a template MIDI region. At a value of 0%, the notes retain their original
velocity. At 100%, they adopt the velocity values of the template. Negative values alter
the velocity, making the deviation from the template even greater.

• Advanced Quantization:  Q-Length: This parameter (also expressed as a percentage
value) determines how the lengths of quantized notes are affected by the equivalent
note lengths (notes at the same position) of a template MIDI region. A value of 0% has
no effect, while at 100%, the notes adopt the exact note lengths of the template region.
Negative values alter note lengths further, resulting in a more significant deviation
from the template.

Fixing MIDI Region Parameters
You can normalize the MIDI region parameter settings of all selected MIDI regions and
folders with the MIDI > Region Parameters > Normalize Region Parameters command.

This means that all settings are actually written as data, and playback parameters revert
to normal values. The audible result remains the same. The Loop parameter and extended
MIDI region parameters are not affected. Use of this function is effectively like saying
“make these MIDI region/instrument parameter values permanent.” In most circumstances,
it is better not to do this, as leaving the original data untouched provides more flexibility.
This includes unlimited opportunities to change your mind about MIDI region edits.

Normalize and MIDI Channels
Like the Merge function and the Glue tool, the Normalize function is intelligent in the
way it handles stored MIDI channel numbers. If all stored events have the same MIDI
channel number, the channel is changed to that of the instrument assigned to the current
track. If the events are on different channels, Logic Pro asks whether or not you want to
convert the event channels.

The following Normalize options are also available in the MIDI > Region Parameters menu:

• Normalize without Channel: Leaves the stored channel number untouched.

• Normalize without Channel & Delay: Leaves the stored channel number and Delay
parameters untouched.

If the playback instrument has a channel setting of All, or you’re dealing with a completely
different type of Environment object (a channel splitter used as A-Playback, for example),
the stored MIDI channel numbers are also unaffected by the usual Normalize function.
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Note: If you’re editing MIDI regions that appear as notation on a polyphonic staff style,
it is recommended to use the Normalize without Channel function, as the event channel
is used to assign notes to individual polyphonic voices in the Score Editor.
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This chapter covers all aspects of audio and MIDI recording in Logic Pro. You’ll learn how
to make use of several workflow features—including take recording, multitrack recording,
and replace recording. You’ll also learn about Logic Pro’s MIDI step input features, which
allow you to insert MIDI notes when not in a real-time recording mode.

This chapter covers the following:

• Checking Hardware Connections and Settings for Recording (p. 432)

• Setting the Project Sample Rate (p. 432)

• Setting the Project Bit Depth (p. 433)

• Setting Up the Metronome for Recording (p. 435)

• Enabling Software Monitoring for Recording (p. 437)

• Setting the Monitoring Level for Recording (p. 439)

• Defining the Recording Folder (p. 439)

• Naming Audio Recordings (p. 440)

• Choosing the Recording File Type (p. 440)

• Setting the Recording Format (p. 442)

• Record-Enabling Tracks (p. 443)

• Getting to Know Audio Recording (p. 444)

• Audio Take Recording (p. 445)

• Audio Multitrack Recording (p. 451)

• Audio Punch Recording (p. 451)

• Audio Replace Recording (p. 454)

• Deleting Audio Recordings (p. 455)

• Getting to Know MIDI Recording (p. 455)

• MIDI Take Recording (p. 456)

• MIDI Multitrack Recording (p. 461)

• MIDI Merge Recording (p. 465)
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• MIDI Replace Recording (p. 466)

• Retrospective Recording of MIDI Regions (p. 467)

• Switching Instruments to Software Instrument Live Mode (p. 468)

• Filtering MIDI Events When Recording (p. 468)

• Turning MIDI Thru Off When Recording (p. 469)

• Using Advanced Recording Commands (p. 470)

• Coloring Takes While Recording (p. 470)

• Marking a Good Take While Recording (p. 472)

• MIDI Step Input Recording (p. 473)

Checking Hardware Connections and Settings for Recording
Prior to recording, make sure that any sound source you plan to use in your recording
session—a mixer, CD player, or microphone, for example—is connected to the audio
inputs of your system and is working properly.

You should also check the hardware settings that are important for recording—such as
the system memory requirement, I/O buffer size, and so on.

For details about hardware connections and settings, see Setting Up Your System.

Setting the Project Sample Rate
You should set the required sample rate when starting a project. The sample rate is the
number of times per second the audio signal is sampled. Recording at a sample rate of
44.1 kHz is recommended for most situations.

To set a project’s sample rate
Do one of the following:

µ Choose File > Project Settings > Audio (or use the Open Audio Project Settings key
command, default assignment:  Option-P), and choose the desired sample rate in the
Sample Rate pop-up menu.
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µ Click the Sample Rate display in the Transport bar, and choose the desired sample rate
from the pop-up menu.

Note: If you can’t see the Sample Rate display, you need to either turn off the Autopunch
button in the Transport bar or select the “Sample Rate or Punch Locators” checkbox in
the Customize Transport Bar dialog. To select the checkbox, control-click (or right-click)
the Transport bar, choose Customize Transport Bar from the shortcut menu, select the
“Sample Rate or Punch Locators” checkbox, then click OK.

When you add audio files to your project, their sample rate is automatically matched to
the project sample rate—if the “Convert audio file sample rate when importing” option
is selected in the File > Project Settings > Assets tab.

The Importance of the Project Sample Rate
Digital audio plays at a different speed when played at a nonmatching sample rate. For
example, when a file that was created at a sample rate of 96 kHz is played back at a rate
of 48 kHz, it will play back at half the speed. This is because only half of the available
samples are played back in the same time frame.

In general, any bounces created for use within a project should be at the project’s
original sample rate. You will gain nothing by bouncing at 96 kHz but then importing
and converting to 44.1 kHz.

Setting the Project Bit Depth
You should set the required bit depth when starting a project. The bit depth is the number
of digital bits each sample contains. Recording at a bit depth of 24 bits is recommended
for most situations and is the default setting in Logic Pro.

If you have suitable audio hardware, 24-bit recordings offer a significant improvement
in the available dynamic range. 24-bit files use one and a half times the disk space of
comparable 16-bit files.

To turn on or off 24-bit recording
1 Open Audio preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Audio from the pop-up
menu.

433Chapter 14 Recording in Logic Pro



2 Click the Devices tab, then click the Core Audio tab.

3 Turn on or off the 24 Bit Recording option.
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Setting Up the Metronome for Recording
If you would like to hear the metronome—which makes a regular click—while recording,
you can set this up in the Metronome project settings window.

MIDI Click object settings KlopfGeist settings

To open the Metronome project settings window
Do one of the following:

µ Choose File > Project Settings > Metronome (or use the Open Metronome Project Settings
key command).

µ Click the Settings button in the Arrange toolbar, and choose Metronome from the pop-up
menu.

µ Control-click (or right-click) the Metronome button in the Transport bar, and choose
Metronome Settings from the pop-up menu.
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The Metronome Project Settings window combines all settings for:

• KlopfGeist: This is a software instrument metronome sound source found in the plug-in
menu of Instrument slots. Logic Pro automatically creates instrument channel strip 256
(with KlopfGeist inserted) when the Software Click Instrument (KlopfGeist) checkbox
is selected. Deselect the checkbox to turn off the option. Theoretically, any other
Logic Pro or third-party instrument could be deployed as a metronome sound
source—using instrument channel strip 256. For more information about the KlopfGeist
instrument, see the Logic Studio Instruments manual.

• MIDI Click object: The Environment’s MIDI Click object (see MIDI Click Objects) is used
to create note events at bar, beat, and division intervals. These can be sent to either a
MIDI port or the internal speaker. To turn off the MIDI metronome output, choose “Off”
in the MIDI Port pop-up menu.

You can use these click sources in isolation or in combination with one another.

To set up the metronome for recording
1 Define when you want to hear the metronome click—on every bar, beat, or division—by

selecting the corresponding Bar, Beat, and Division checkboxes.

2 Turn on the “Click while recording” option. Also set the “Only during count-in” and “Click
while playing” options to meet your needs. It is suggested that you leave the “Polyphonic
Clicks” option enabled, as this allows for overlapping clicks.

3 Click the Recording button at the top of the Project Settings window, to open the
Recording pane.

4 Select the Count-in radio button.

5 Open the pop-up menu and choose the desired count-in period that will precede
recording:

• None: The recording begins with no count-in.

• n Bars: The recording begins after n bars of count-in.

• n/4: The count-in time signature may be set here. These settings are useful when the
count-in—and, presumably, the recording—falls across a bar line.
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For details about the Metronome project settings, see Metronome Settings.

Enabling Software Monitoring for Recording
The Software Monitoring function allows you to monitor incoming audio through any
effect plug-ins that are inserted into an armed audio channel strip. Audio inputs must be
assigned on the record-enabled channel strips for software monitoring to function.

It is important to note that the effect plug-ins are monitored but not recorded, which
can be useful during a recording session. For example, during vocal recording many
singers prefer to hear their performance with a little reverb, but the track is recorded
dry—without effects.

To monitor a track with effect plug-ins during recording
1 Open Audio preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command.

• Click the Preferences button in the Arrange toolbar, and choose Audio from the pop-up
menu.

2 Click the Devices tab and then the Core Audio tab.

3 Select the Software Monitoring option.
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4 Insert the desired effect plug-in into the audio channel strip, and start recording.

The effect will be part of the monitor mix, but it will not be recorded.

Using Auto Input Monitoring for Recording
If Auto Input Monitoring is turned on, you will hear the input signal only during the actual
recording—before and afterwards you’ll hear the previously recorded audio on the track,
while Logic Pro is running. This helps you to judge punch-in and punch-out points when
you are punch recording. If Auto Input Monitoring is turned off, you will always hear the
input signal.

To turn on auto input monitoring
Do one of the following:

µ Choose Options > Audio > Auto Input Monitoring from the main menu bar (or use the
Toggle Auto Input Monitoring key command).

µ Control-click (or right-click) the Record button in the Transport bar, and choose the Auto
Input Monitoring setting from the pop-up menu.

Your individual recording situations will determine whether or not to use auto input
monitoring. Consider the following examples:

• Singers cannot hear themselves while Logic Pro is in playback mode—all they can hear
is the old recording. In this case, turn off Auto Input Monitoring.

• The recording cannot be heard in playback mode. In this case, turn on Auto Input
Monitoring to hear audio on the track.

Using the Input Monitoring Buttons Before Recording
You can use the Input Monitoring buttons to monitor audio tracks that are not armed.
This is useful for setting audio levels or practicing parts before you commit to recording.

Simply enable the Input Monitoring button on an audio track—or a channel strip in the
Inspector or Mixer. This works when Logic Pro is stopped or playing.
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Tip: You can leave the Input Monitoring button turned on before, after, and during
recording. When the Input Monitoring button is turned on, the Record Enable button
and the Auto Input Monitoring feature do not affect software monitoring—that is, you
can always hear incoming audio. When you are punch recording, however, you should
use the Auto Input Monitoring feature rather than the Input Monitoring buttons.

Avoiding Latency Issues with Input Monitoring
Note that input monitoring always involves some latency. Latency is entirely dependent
on the audio hardware’s capabilities and the driver settings. In certain configurations, it
may be best to not monitor through Logic Pro at all, and thus obtain the best possible
timing. Route the signal you want to record directly to headphones or the monitoring
amplifier for monitoring purposes—and to the audio interface inputs, for recording. You
won’t accidentally overdrive your A/D converters, because the input level meters of
Logic Pro display a clip warning if an overload occurs.

Setting the Monitoring Level for Recording
If the Independent Monitoring Level (for Record Enabled Channel Strips) option in the
Logic Pro > Preferences > Audio > Devices > Core Audio tab is enabled, an independent
monitoring level is available when an audio channel strip is record enabled. After you
arm the track, set the fader to the desired level. The original playback level will be restored
when the channel strip’s Record button is disabled.

Note: The Volume fader controls only the playback (or monitoring) level, not the recording
level. You must set recording levels externally—on your mixer, or at the original sound
source. Take care when you set the input levels, because digital audio will clip when
overloaded. Clipping results in a particularly harsh, metallic distortion, so unless you have
a penchant for heavier musical styles, overloading the inputs isn’t recommended (see
Understanding a Channel Strip’s Peak Level Display).

Defining the Recording Folder
Although MIDI data is stored directly within the project file, audio data is not. Before you
record, therefore, you should define a target folder on your hard disk for audio data.

When you save a project with its assets, Logic Pro saves your project file in a project folder.
The project folder contains an automatically created Audio Files folder—which is used
as the default recording folder.

Note: The recording path to this folder is “relative,” meaning that it moves with the
project, making it possible to move the project folder in the Finder or use the Save As
command.
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You can set a different recording folder for each project. You can also define different
paths for each audio hardware system that is running. For example, Core Audio could
use the internal Macintosh hard disk and your DAE hardware could be set to use an
external FireWire hard drive.

Note: When you manually set a recording path outside the current project folder, the
recording path is “absolute.” This means that the recording path for the audio data always
remains the same, even after you use the Save As command to save it as a new project
or when you move the project file in the Finder.

To define the recording folder
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Click the Set button, browse to the desired recording folder, and click Choose.

Naming Audio Recordings
When you are recording, the track name is used as the default filename. Subsequent
recordings made on this track are assigned an ascending numerical suffix. “Audio 1” is
named “Audio 1_01,” “Audio 1_02,” and so on. If the track is not named, the name of the
channel strip that the track is routed to is used. You can rename tracks in the Arrange
track list and Mixer (see Naming Tracks in the Arrange Area and Renaming Tracks in the
Mixer).

Choosing the Recording File Type
You should choose the preferred file type—AIFF, WAV, or CAF—for audio data before
recording.
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To choose the recording file type
1 Open Audio preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, and choose Audio from the pop-up
menu.

2 Click the General tab.

3 Choose the file type in the Recording File Type pop-up menu.

There is a maximum recording size according to file type, as follows:

• AIFF: The AIFF file format cannot handle audio file recordings larger than 2 GB:

• For 16-bit, 44.1 kHz stereo files, this equals a recording time of about 3 hours and
15 minutes.

• For 24-bit, 96 kHz, 5.1 surround files, this equals a recording time of about 20 minutes.

• WAVE (BWF): The WAVE file format cannot handle audio file recordings larger than
4 GB:

• For 16-bit, 44.1 kHz stereo files, this equals a recording time of about 6 hours and
30 minutes.

• For 24-bit, 96 kHz, 5.1 surround files, this equals a recording time of about 40 minutes.

• CAF: If the size of your recording exceeds the above limits, choose the CAF (Apple
Core Audio Format) file format, which can handle the following recording times:

• About 13 hours and 30 minutes at 44.1 kHz

• About 6 hours at 96 kHz

• About 3 hours at 192 kHz

The bit depth and channel format—mono, stereo, or surround—do not affect the
maximum recording size of CAF files.
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Setting the Recording Format
Logic Pro allows you to set the recording format of channel strips, as follows:

Mono Left SurroundStereo Right

• Mono: One circle represents a mono input format. The level meter shows a single
column.

• Stereo: Two interlocked circles represent a stereo input format. The level meter divides
into two independent columns.

• Left: Two circles, the left one filled, indicate a left channel input format. When this input
format is chosen, only the left channel of a stereo audio file is played back. The level
meter shows a single column.

• Right: Two circles, the right one filled, indicate a right channel input format. When this
input format is chosen, only the right channel of a stereo audio file is played back. The
level meter shows a single column.

• Surround: Five circles indicate the surround channel input format. The level meter
divides into multiple, linked columns (the number matches the project surround format).

To switch the recording format of a channel strip
µ Select the channel strip’s Format button and hold down the mouse button, then choose

the desired format from the pop-up menu.
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Record-Enabling Tracks
You can make recordings only on record-enabled—or armed—tracks, irrespective of
which arrange track is selected in the track list. There are a number of ways to enable
tracks for recording. You can enable tracks individually, or you can enable tracks
collectively—if they each have unique inputs. You can also enable several tracks that are
routed to the same channel strip. On occasion, you may need to enable audio and MIDI
tracks simultaneously. Each track or channel strip has its own Record Enable button, which
is used to arm that track or channel strip for recording.

Note: If the Record Enable button is not visible in the track list, choose View > Configure
Track Header (or use the corresponding key command), and select the Record Enable
checkbox. If this checkbox is selected and the button is still not visible, activate the relevant
audio hardware in Logic Pro > Preferences > Audio > Devices.

Record-Enabling Audio Tracks
You can activate the Record Enable buttons only of audio tracks that have a unique input.
Simultaneous arming of multiple tracks that use the same input (chosen in the Input slot)
is not possible.

If several arrange tracks are routed to the same channel strip (“Audio 1,” for example),
the new audio file will be recorded to the selected track (routed to “Audio 1”). If none of
these tracks are selected, but they are record-enabled, audio will be recorded to the first
(the top) of these tracks.

Space is reserved on the hard disk for armed tracks, which will no longer be available for
Undo files. For this reason, Logic Pro automatically disarms audio tracks when you are
editing in the Sample Editor, or if the hard disk is nearly full.

To enable one or more audio tracks for recording
Do one of the following:

µ Click the Record Enable button on the desired track (or tracks) in the track list.

µ Click the Record Enable button on the desired channel strip (or channel strips) in the
Mixer.

µ Select the desired track (or tracks) in the Arrange area and use the Record Enable Track
key command, default assignment:  Control-R.
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To disable a record-enabled audio track
Do one of the following:

µ Click the (red) Record Enable button a second time—in either the track list or Mixer.

µ Use the Record Enable Track key command, default assignment:  Control-R.

To disable all record-enabled audio tracks
µ Option-click the (red/flashing) Record Enable button of any record-enabled audio track.

Record-Enabling MIDI Tracks
You can enable one or more software instrument tracks for recording.

To enable one or more software instrument tracks for recording
Do one of the following:

µ Click the Record Enable button on the desired track (or tracks) in the track list.

µ Click the track header of a software instrument track that is not record-enabled.

Note: This action turns off the record-ready state of any other software instrument tracks
that are already record-enabled.

To disable a record-enabled software instrument track
Do one of the following:

µ Click the (red) Record Enable button in the track list.

µ Use the Record Enable Track key command, default assignment:  Control-R.

Record-Enabling Audio and MIDI Tracks Simultaneously
There may be occasions when you want to simultaneously record audio and software
instrument tracks—perhaps to capture a live band recording with the keyboard player
using one or more Logic Pro software instruments.

Important: You can activate the Record Enable buttons only of audio tracks or channel
strips that have a unique input.

To enable multiple audio and software instrument tracks for recording
1 Click the Record Enable button on the audio tracks you want to record to.

2 Click the Record Enable buttons on the software instrument tracks you want to record
to.

Getting to Know Audio Recording
You have the following possibilities to choose from when recording audio material:

• Take recording: You can record a single audio take using basic recording commands,
and you can record multiple audio takes over the same section of the project. See Audio
Take Recording.
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• Multitrack recording: You can record audio to multiple tracks simultaneously. See Audio
Multitrack Recording.

• Punch recording: You can record audio at defined project positions—which is done by
setting manual or automatic punch-in and punch-out locators. See Audio Punch
Recording.

• Replace recording: You can replace an original recording, or a portion of it, with a new
recording—which is generally combined with punch recording. See Audio Replace
Recording.

Audio Take Recording
You can approach audio take recording in the following ways:

• By recording a single audio take: Creates a single audio region on the selected arrange
track.

• By recording multiple audio takes: Creates multiple audio regions over the same section
of the project, all packed into a single take folder.

• By recording additional audio takes: Creates a take folder or the addition of new
recordings to existing take folders.

To facilitate your workflow—in particular when editing audio take recordings at a later
stage—use Logic Pro’s take coloring and take marking features. See Coloring Takes While
Recording and Marking a Good Take While Recording.

Recording a Single Audio Take
When you record a single audio take—in other words, you make a basic audio
recording—recording starts at the playhead position and ends when you click the Stop
button (or press the Space bar). The following occurs on your system, and in Logic Pro:

• An audio file is created on the hard disk.

• An audio region, which represents the entire recorded audio file, is automatically created
on the selected arrange track.

• The audio file and the audio region are added to the Audio Bin.

To record a single audio take
1 Set the playhead to the point where you want recording to start.
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2 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

You will hear the count-in, if it is defined in File > Project Settings > Recording. During
recording, a progress indicator displays the remaining recording time and the elapsed
time.

3 Click the Stop button in the Transport bar (or press the Space bar) to stop recording.

The recording appears as a single audio region on the selected arrange track, with the
audio region displaying a graphical overview of the waveform. You can play the new
recording while the overview is being created.

Note: If you paused recording by clicking the Pause button in the Transport bar, you can
resume recording by clicking either the Pause or Play button. Recording resumes at the
current playhead position but in a new audio region. You can later select the regions,
then merge them using the Glue tool.

Recording Multiple Audio Takes
You can record multiple audio takes over the same section of your project. This allows
you to later choose the best take, or take regions, to create your final composition.
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Imagine a guitar solo being performed and recorded multiple times over the same section
of a project. The first recording appears as a single take region on the selected arrange
track—just like recording a single audio take. When a recording takes place over this
existing audio region, a take folder is created—occupying a single audio arrange
track—and both regions are added to this folder. Each subsequent recording over the
same section is added to the take folder. At the top of the take folder appears a composite
of the sections of take regions, which represent a combination of the multiple
takes—usually the best performances that can be used as the final version of your take.

Composited take 
sections

First recorded take

Last recorded take

To repeatedly record over the same section of a project, you need to turn on Cycle mode
and define a cycle area. For details, see Using Cycle Mode.

To record multiple audio takes
1 Turn on Cycle mode by doing one of the following:

• Click the Cycle button in the Transport bar (or use the Cycle Mode key command,
default assignment:  C).

• Click in the top part of the Bar ruler.
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2 Set a cycle area by doing one of the following:

• Drag the left and right locators in the top part of the Bar ruler.

• Use the locator fields in the Transport bar.

3 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

Note: Recording automatically starts at the beginning of the defined cycle area, so you
don’t need to set the playhead position.

Record as many cycle passes as you wish. When the second cycle pass ends and the third
cycle pass begins, a take folder is created on the selected audio arrange track. Each
subsequent cycle pass is then added to this take folder.

4 Click the Stop button in the Transport bar (or press the Space bar) to stop recording.

The selected audio arrange track contains a closed take folder, with each of the recorded
audio takes inside.
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5 Open the take folder by doing one of the following:

• Click the disclosure triangle in the top-left corner of the take folder (or use the
Un/disclose Take Folder key command).

• Double-click the take folder.

Recording Additional Audio Takes
After recording single or multiple audio takes to a single arrange track, you can continue
to record additional takes on the same track.

• You can record over an existing region, or regions.

• You can record over an existing take folder, or take folders.

Although this is not a recording function per se, you can also drag and drop other
recordings onto an existing take folder. Depending on the size of the recording, it will
be added as either a new take or a new comp, and the take folder will be resized
accordingly.

Note: Take folders are created only when a recording has been made. If you attempt to
drag a region onto another region that was originally imported (not recorded), this will
not create a take folder. You can, however, “pack” a take folder from any selected
regions—recorded or imported. For details, see Packing Regions into a Take Folder.

Recording over an Existing Audio Region
A take folder is automatically created when you record over an existing audio region.

To record over an existing audio region
1 Set the playhead to a position where the new recording will overlap the existing region

by a length that exceeds the count-in or pre-roll duration—which you have set in File >
Project Settings > Recording.

2 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

449Chapter 14 Recording in Logic Pro



An overlapping audio region is created in real time along the track until you stop recording.

3 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

The result is a closed take folder that contains both audio recordings on a single audio
arrange track. The longer of the two regions determines the take folder size.

When you record over multiple existing audio regions, a take folder is also created with
all regions packed inside.

Recording over an Existing Audio Take Folder
When you record over an existing take folder, the new recording is added to the take
folder and is selected for playback.

To record over an existing audio take folder
1 Set the playhead to a position where the new recording will overlap the existing take

folder.

2 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

An overlapping audio region is created in real time along the track until you stop recording.

3 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

The new audio recording is automatically added to the take folder.

The following will be taken into account:

• If the new recording starts earlier or ends later, the take folder extends to match the
size of the new recording.

• If the new recording starts later or ends earlier than the start and end points of the take
folder, a new comp is created consisting of the former take or comp supplemented by
the new recording.

When you record over multiple existing audio take folders—placed one after the other
on a track lane—the new recording is split between the take folders. Each section is
assigned as a new take in each take folder. Earlier take folders are extended in length
until they reach the start point of the ensuing take folder (if there is a gap between take
folders).
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Audio Multitrack Recording
You can record audio to multiple tracks simultaneously. This is done by record-enabling
the required arrange tracks, then starting to record. This allows you to record several
instruments at once, placing each instrument on a separate arrange track.

To record to multiple tracks simultaneously
1 Click the Record Enable button on each arrange track you want to record to.

Important: You cannot record-enable tracks that are set to the same input. Each track
needs to be set to a different input.

2 Set the playhead to the point where you want recording to start.

3 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

4 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

You now have a new audio region on each of the record-enabled tracks.

Audio Punch Recording
Punch recording is a technique that allows you to overwrite a portion of a previously
recorded track, during playback, without touching any of the recording before or after
that portion. You punch in to interrupt playback and make the recording, then punch
out to return to playback mode.

Logic Pro offers two methods of punch recording:

• Punch on the fly: Involves the use of a key command to start recording while in playback
mode.
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• Autopunch: Involves the use of predefined punch-in and punch-out points to start and
stop recording.

Note: Only record-enabled tracks are affected by punch recording.

Audio Punch Recording on the Fly
You can use a key command during playback to engage recording—in real time, or “on
the fly.” You use the key command again during recording to re-engage playback.

The advantage of punching on the fly is that you can hear the section that you want to
replace within the context of what comes before and what comes after.

Given that recording occurs in real time—hence, there is no room for delay when switching
between read and write modes—Logic Pro needs to be prepared for a recording at any
time. This is done by using “Punch on the Fly” mode.

In practice, when “Punch on the Fly” mode is turned on, recording occurs in the
background from the moment you start playback. If you don’t press Record, any recorded
data is discarded.

To record on the fly
1 Turn on “Punch on the Fly” mode by doing one of the following:

• Control-click (or right-click) the Record button in the Transport bar, and choose “Punch
on the Fly” from the pop-up menu.

• Choose Options > Audio > “Punch on the Fly” in the main menu bar (or use the “Toggle
Punch on the Fly” key command).

2 Click the Play button in the Transport bar, then use the Record Toggle key command
(default assignment:  Shift-*) at the point where you want to start recording.

Audio recording starts immediately.

3 Click the Stop button in the Transport bar, or use the Record Toggle key command a
second time to stop recording.

If you use the latter option, recording ends, but playback continues.

Note: You can also use the Record Toggle key command when Logic Pro is not in “Punch
on the Fly” mode, but this will cause a delay when you switch between playback and
record modes.

Preprogrammed Audio Punch Recording
Autopunch describes the automatic activation and deactivation of recording at predefined
positions. The advantage of the Autopunch feature is that you can concentrate on your
playing, rather than on controlling Logic Pro. Another advantage is that starting and
stopping recordings can be set far more precisely than would be possible if punching on
the fly.
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The Autopunch feature can be used for audio, software instrument, or MIDI tracks.

To record in Autopunch mode
1 Turn on the Autopunch button in the Transport bar.

The left and right autopunch locators serve as punch-in and punch-out points. The
autopunch recording area is indicated by a red stripe in the middle third of the Bar ruler.

If both Cycle and Autopunch modes are active, you see a pair of locators in the autopunch
area. Two stripes are shown in the Bar ruler:  the top (green) one represents the cycle
area, and the bottom (red) one represents the autopunch area. These can be adjusted
independently.

2 Set the autopunch area by doing one of the following:

• Use the autopunch locator fields in the Transport bar to set the autopunch area
numerically. Note that the Sample Rate or Punch Locators setting in the Customize
Transport Bar dialog must be active before you can see and set the autopunch locators
(to the right of the standard locators).

• Alter the Autopunch range graphically in the Bar ruler, just as you would with the cycle
area.

3 Place the playhead at any position before the punch-in point.

4 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

5 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

A region that exactly matches the length of the autopunch stripe will be created. Any
audio input received before the punch-in or after the punch-out points streams through
Logic Pro as usual, but is not recorded.
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Logic Pro will begin recording approximately one bar before the punch-in locator. This
allows the start point of the region to be adjusted later, enabling you to hear the lead-in,
if desired.

You can also recover the beginning of the recording if the performer slightly anticipates
the autopunch area. Any such adjustments to the lead-in portion of the region do not
change the position of the recording, relative to the time axis of the project.

Recording automatically begins at the punch-in locator, following the count-in, even if
the playhead is positioned after the right locator when recording starts.

If Autopunch is enabled during recording, the Record button will flash while the playhead
is outside the area encompassed by the punch-in and punch-out locators. This indicates
that no recording is currently taking place.

Combining Cycle and Autopunch Recording
If you want to improve a difficult part of a certain passage, you can use a combination
of the Cycle and Autopunch functions. Cycle mode recording allows you to practice as
many times as you like before performing the final take. On each cycle pass, only events
or audio that falls within the area defined by the autopunch locators is recorded. This
allows you to make use of the preceding song section to “get into the groove.”

Recording with Skip Cycle
If Skip Cycle is turned on, the cycle area is bypassed during recording.

Audio Replace Recording
In Replace mode, a new recording replaces the original recording, or a portion of it. The
newly recorded data is stored in a new region, as with standard recording. In addition,
any existing region on the destination track is cut at the punch-in and punch-out points
of the recording, and data between these points is deleted.

To record in Replace mode
1 Turn on the Replace button in the Transport bar.

2 Click the Record Enable button on the arrange track you want to record to.

3 Set the playhead to the point where you want recording to start.

4 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).
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5 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

When you are cycle recording in Replace mode, existing regions (or portions of them)
are deleted only during the first cycle pass—from the punch-in point to either the
punch-out point or the end of the cycle. When the second cycle pass begins, recording
continues, but no further regions (or portions of them) are deleted. If you want to replace
the end of an existing region, you don’t need to stop recording before the second cycle
pass begins—the start of the existing region remains intact.

When you are recording over an existing take folder in Replace mode, you can have either
of the following outcomes:

• If a comp is active: Recording takes place on a newly created take lane and the comp
is updated with the newly recorded material.

• If a take is active: Recording takes places in the active take lane, replacing any previously
existing take regions. Any comps that reference this take will continue to do so, using
the newly recorded material.

Deleting Audio Recordings
You can delete an audio region with files recorded in the current session, and you can
delete an audio region with files that are imported from an earlier session.

To delete an audio region that you have recorded since opening the project
µ Select the audio region, and press the Delete key.

A dialog asks if you also want to erase the corresponding audio file. This saves hard drive
space used by bad takes and unwanted recordings.

To delete an audio recording that was made before the current session
µ Select the audio region, and press the Delete key.

This will remove only the audio region from the arrangement, not the audio file (from
the Audio Bin). No dialog appears. This prevents you from accidentally deleting recordings
that may be used in other projects. If you actually want to delete the corresponding audio
file, you can do so by choosing Audio File > Delete File(s) in the Audio Bin. The deleted
audio files remain in the Trash until emptied.

Getting to Know MIDI Recording
You have the following possibilities to choose from when recording MIDI material:

• Take recording: You can record a single MIDI take, or you can record multiple MIDI takes
over the same section of the project. See MIDI Take Recording

• Multitrack recording: You can record MIDI to multiple tracks simultaneously. See MIDI
Multitrack Recording.
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• Merge recording: You can record over an existing MIDI region, merging the recordings
as one. See MIDI Merge Recording.

• Replace recording: You can replace an original recording, or a portion of it, with a new
recording. See MIDI Replace Recording.

MIDI regions are recorded in real time, or using a number of “step input” methods, on
software instrument and external MIDI tracks. For details about these methods, see MIDI
Step Input Recording.

MIDI Take Recording
You can approach MIDI take recording in the following ways:

• By recording a single MIDI take: Creates a single MIDI region on the selected arrange
track.

• By recording multiple MIDI takes: Creates multiple MIDI regions over the same section
of the project, all packed into a single take folder.

• By recording additional MIDI takes: Creates a take folder or the addition of new recordings
to existing take folders.

Recording a Single MIDI Take
When you record a single MIDI take, a MIDI region is automatically created on the selected
arrange track.

To record a single MIDI take
1 Select the instrument or external MIDI track that you want to record on.

Note: These track types are automatically record-enabled when selected.

2 Set the playhead to the point where you want recording to start.

3 If you would like to hear the metronome while recording, Control-click (or right-click) the
Metronome button in the Transport bar, and make sure the Click While Recording
command is chosen in the pop-up menu.

4 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

You will hear the count-in, if defined in File > Project Settings > Recording.

5 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).
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The recording appears as a single MIDI region on the selected arrange track, with the
data appearing instantaneously.

While recording, you can change the record track by selecting a new track with the mouse,
or using the Select Previous Track or Select Next Track key commands (default
assignments:  Up Arrow or Down Arrow).

Note: If you paused recording (by clicking the Pause button in the Transport bar), you
can resume recording by clicking either the Pause or Play button. Recording resumes at
the current playhead position.

Recording Multiple MIDI Takes
You can record multiple takes of a performance over the same section of a project. The
first recording appears as a single MIDI region on the selected arrange track, as with single
take recording. When a recording occurs over this existing MIDI region, a take folder is
created (occupying a single instrument arrange track), and both regions are added to
this folder. Each subsequent recording over the same section is added to the take folder.

To record multiple MIDI takes
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.
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2 Open the Overlapping Recordings pop-up menu and choose “Create take folders.”

3 Turn on Cycle mode by doing one of the following:

• Click the Cycle button in the Transport bar (or use the Cycle Mode key command,
default assignment:  C).

• Click in the top part of the Bar ruler.
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4 Set a cycle area by doing one of the following:

• Drag the left and right locators in the top part of the Bar ruler.

• Modify the locator fields in the Transport bar.

5 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

Record as many cycle passes as you wish. When the second cycle pass ends and the third
cycle pass begins, a take folder is created on the arrange track. Each subsequent cycle
pass is then added to this take folder.

Note: Each previous take track is automatically muted during recording. When you stop
recording, you can listen to the individual takes in the take folder by selecting them.

6 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

The result is a closed take folder that contains each of the recorded MIDI takes on a single
arrange track.

7 Open the take folder by doing one of the following:

• Click the disclosure triangle in the top-left corner of the take folder (or use the
Un/disclose Take Folder key command).
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• Double-click the take folder.

Recording Additional MIDI Takes
After recording single or multiple MIDI takes to an arrange track, you can continue to
record additional takes on the same track.

• You can record over an existing region, or regions.

• You can record over an existing take folder, or take folders.

Note: You need to choose File > Project Settings > Recording, then open the Overlapping
Recordings pop-up menu and choose “Create take folders.”

Recording over Existing MIDI Regions
A take folder is automatically created when you record over an existing MIDI region.

To record over an existing MIDI region
1 Set the playhead to a position where the new recording will overlap the existing region

by a length that exceeds the count-in (which you have set in File > Project Settings >
Recording).

2 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

An overlapping MIDI region is created in real time along the track until you stop recording.

3 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).

The result is a closed take folder that contains both MIDI recordings on a single arrange
track. The longer of the two regions determines the take folder size.

Recording over multiple existing MIDI regions will merge the regions—per track—before
creating the take folder. All existing MIDI regions will appear as the first take, and new
recordings will appear as the second take, third take, and so on.

Recording over Existing MIDI Take Folders
Recording over an existing MIDI take folder will add a MIDI take to it.

Recording over multiple existing MIDI take folders will flatten them individually, and
merge them per track, before creating a new take folder that spans the combined length
of all take folders. All material that existed prior to recording will appear as the first take,
with subsequent recordings appearing as the second take, third take, and so on.

Note: All takes that were not playing in the take folders (which existed prior to recording)
are lost unless you choose Edit > Undo right away.
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Only the actual recording of MIDI events qualifies them as overlapping. For example,
imagine that you are recording over existing take folders 1, 2, and 3. You don’t play any
MIDI events before the start, or after the end of take folder 2. This will result in the new
recording being added as a further take of take folder 2. Logic Pro will even tolerate
note-off events in the first bar of take folder 3, without merging take folders 2 and 3.

Note: MIDI take folders do not have the comping functionality available to audio take
folders. The MIDI Take Folder pop-up menu does not include the New Comp or “Flatten
and Merge” commands.

MIDI Multitrack Recording
Logic Pro offers two possibilities when recording multiple MIDI tracks:

• To record multiple MIDI tracks simultaneously

• To record multiple MIDI tracks successively (in Cycle mode)

Recording Multiple MIDI Tracks Simultaneously
You may occasionally want to record multiple MIDI tracks at the same time. Often this
will be data recorded from an external sequencer, or played from a keyboard that is split
across multiple MIDI channels.

You can also simply play the same MIDI channel information from your keyboard, but
record it to multiple tracks. One reason you would do this is to create layered instrument
parts.

To record to multiple tracks simultaneously
1 Click the Record Enable button on each arrange track you want to record to.

Note: Selecting an external MIDI or instrument track that is not record-enabled will turn
off the record-enabled status of all other external MIDI or instrument tracks.
Record-enabled audio tracks are not affected.

2 Set the playhead to the point where you want recording to start.

3 Click the Record button in the Transport bar (or use the corresponding key command,
default assignment:  *).

4 Stop recording by clicking the Stop button in the Transport bar (or press the Space bar).
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You now have a new MIDI region on each of the record-enabled tracks.

There are two operating modes available for simultaneous recording of multiple MIDI
tracks:  layer recording and multiplayer recording.

• When layer recording: Incoming MIDI events are sent to all record-enabled MIDI tracks.
You can listen to all selected instruments before, and during, recording.

• A MIDI region is created on the selected track after recording.

• Aliases of the MIDI region on the selected track are recorded on the other tracks.

The advantage of this approach is that any subsequent edits to the “parent” MIDI region
will affect all aliases, ensuring that all layered tracks remain identical.

• When multiplayer recording: Incoming MIDI events are distributed to the various
record-enabled tracks, in accordance with transmitted MIDI channel numbers.

• The channel of the incoming event must correspond to the channel of a
record-enabled track for this functionality to work.

• If no track with a corresponding channel number is found, the event will be routed,
and recorded, onto the selected track.

You should ensure that each of your MIDI controllers transmit on different channels. If
this is not possible, simply use different inputs on your MIDI interface and change the
MIDI channel of each input, using a transformer object between the Physical Input and
Sequencer Input (see Physical Input Objects and Sequencer Input Objects).

To switch from the Layer recording mode (default) to the Multiplayer recording mode
µ Choose File > Project Settings > Recording, and select the “Auto demix by channel if

multitrack recording” option.

Recording Multiple MIDI Tracks Successively
You can record several MIDI regions on individual tracks when in Cycle mode.
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To record several MIDI tracks in Cycle mode
1 Open the Recording project settings window by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Open the Overlapping Recordings pop-up menu and choose “Create tracks in Cycle
record.”

This will automatically create a new take track for each cycle repetition. Each previous
track plays while you are recording.

When you stop recording, you can work with each newly recorded region independently
of the others.
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You also have the option to mute each previous track while recording.

To record several MIDI tracks, and mute each previous track, in Cycle mode
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Open the Overlapping Recordings pop-up menu and choose “Create tracks and mute in
Cycle record.”

This will automatically create a new independent take track for each cycle repetition.
Each previous track is automatically muted while recording.
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When you stop recording, you can work with each newly recorded region independently
of the others.

MIDI Merge Recording
You can incorporate newly recorded data into an existing (and selected) MIDI region,
with the intention of combining the recordings.

To combine several recording takes into one MIDI region
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Open the Overlapping Recordings pop-up menu and choose “Merge with selected regions.”

To limit merge recording to Cycle mode
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).
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• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Open the Overlapping Recordings pop-up menu and choose “Merge only in Cycle record.”

MIDI region recording will behave as usual, with new regions created for each recording.
When the Transport bar’s Cycle button is turned on, however, all MIDI region recording
will result in a single, merged region.

MIDI Replace Recording
You can incorporate newly recorded data into an existing (and selected) MIDI region,
with the intention of replacing the recording—in part, or in full.

To replace the events in a MIDI region recording
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.
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2 Open the Overlapping Recordings pop-up menu and choose “Merge with selected regions.”

3 Click the Replace button in the Transport bar.

Tip: You can also use the Merge/Replace combination in conjunction with the Autopunch
and Cycle functions.

Retrospective Recording of MIDI Regions
If you played a great solo while playback was running, but you weren’t in record
mode—don’t worry. Simply use the “Capture as Recording” key command (default
assignment:  Control-*). All events you played (after the last playhead change) will be
added to the recorded MIDI region—just as if you had been in record mode.

Note: If you move the playhead before executing this command, the next incoming event
will delete all previously played events, and your solo will be lost forever.
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Switching Instruments to Software Instrument Live Mode
When you select a (software) instrument track, it does not immediately switch into live
or performance mode. You must send a MIDI event before live mode is activated, which
takes around 100 ms to engage, and this is more than enough to destroy the timing of
your first played note.

If you require perfect timing for the first played note, you need to send silent MIDI events
in advance—you can press the sustain pedal and make a small move of the pitch bender
or modulation wheel, for example. This will turn on live mode. For details, see
Understanding Live Mode.

Filtering MIDI Events When Recording
The MIDI protocol can contain a broad range of MIDI messages, beyond note-on and
note-off messages. These include controller information such as pitch bend, modulation,
and aftertouch (pressure) commands.

There may be situations where you don’t want to record all information being sent by
your MIDI controllers. In this case, you can use several “MIDI filters” that allow you to
define what event types will be accepted or rejected at the sequencer input.

To filter incoming MIDI events
1 Open the MIDI project settings by doing one of the following:

• Choose File > Project Settings > MIDI.

• Click the Settings button in the Arrange toolbar, and choose MIDI from the pop-up
menu.

2 Click the Input Filter tab.
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3 Select the checkboxes that correspond to the MIDI event types you would like to filter at
the Logic Pro sequencer input.

Turning MIDI Thru Off When Recording
When an External MIDI instrument track is selected in the Arrange area, its Record Enable
button is automatically turned on, and the instrument will pass events through the
computer (MIDI Thru function). You can turn off the MIDI Thru function by deactivating
the Record Enable button.

However, there are situations where you may want to record to a track that is not
automatically routed to a MIDI port, such as when you are performing a system exclusive
(SysEx) dump from a device. Although many MIDI devices require a bidirectional—in and
out—MIDI connection to allow this type of communication, some devices react strangely
to incoming data, sent from Logic Pro’s MIDI Thru function. This can result in loss of data,
devices not responding, and other unexpected behaviors.

If you want to record a memory dump from a device that is problematic when connected
bidirectionally, disable the instrument’s MIDI Thru function.

To assign an instrument with a permanently disabled MIDI Thru function
1 Open the MIDI project settings by doing one of the following:

• Choose File > Project Settings > MIDI.

• Click the Settings button in the Arrange toolbar, and choose MIDI from the pop-up
menu.

2 Click the General tab.
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3 Open the Instrument Without MIDI Thru Function pop-up menu, and choose the desired
instrument.

Using Advanced Recording Commands
You can use several advanced recording commands to speed up the recording process.

• Record/Record Toggle: When this command is used while recording (to toggle between
playback and record mode), recording is temporarily suspended, but playback continues.
Use it again to resume recording from the current playhead position.

• Record/Record Repeat: When this command is used while recording, the running recording
is deleted, the playhead is moved back to the (recording) start position, and a new
recording begins immediately.

• Discard Recording and Return to Last Play Position: When this command is used [while
recording], the running recording is deleted and the playhead is moved back to the
last play position. Unlike when you use Record/Record Repeat, you will need to manually
begin a new recording, using any Record command.

To access these advanced recording commands
Do one of the following:

µ Control-click (or right-click) the Record button in the Transport bar, and choose either
“Record/Record Toggle” or “Record/Record Repeat” from the pop-up menu (or use the
corresponding key commands).

µ For the “Discard Recording and Return to Last Play Position” feature, use the default key
command:  Command-Period.

Coloring Takes While Recording
When Logic Pro is recording, you can color take regions in an open or closed take folder,
and you can color audio takes automatically—just as you would do with standard regions
or folders. (You can also do this when Logic Pro is not recording.)

The following task describes how to color take regions manually while recording.
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To color a take in an open or closed take folder while recording
µ Click the desired color in the Color palette, which you access in one of the following ways:

• Choose View > Colors in the Arrange window (or use the Open Color Palette key
command, default assignment:  Option-C).

• Click the Colors button in the Arrange toolbar.

You can also color audio takes automatically while recording.

To color audio takes automatically while recording
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Select the Auto-Colorize Takes checkbox.
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When this setting is selected, audio take folders use the color chosen from the Color
palette for the first take, but different colors for each of the following takes in that take
folder. All colors used in an audio take folder are chosen from the same color row in the
Color palette, advancing by a predefined number of columns after each take.

Marking a Good Take While Recording
You can mark a good take during recording.

To mark a good take while recording
µ Use the “Select Previous Section for Realtime Comping” key command.

This places a tag in the current take, at the position the key command was used. All audio
that preceded the use of the key command is tagged as a good take, which will be used
in the final comp.
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MIDI Step Input Recording
The Step Input features allow you to insert MIDI notes when Logic Pro is not in a real-time
recording mode.

You can use Step Input to create note runs that may be too fast for you to play, or to
replicate sheet music that’s too difficult for you to play. You can use one or more of the
following for step entry:

• The Step Input Keyboard

• Step Input Keyboard key commands

• A MIDI keyboard

• The computer keyboard (Caps Lock Keyboard)

Notes are inserted at the current playhead position when using all non-real-time input
modes. You can and should combine methods to make full use of the features that each
option offers. For example, you can set the note length in the Step Input Keyboard window,
insert notes via a MIDI keyboard, and position the playhead with key commands.

Use the mouse while familiarizing yourself with the Step Input Keyboard. It is best to also
learn the Step Input key commands, which provide a number of navigation and note
entry options—such as “Step forward,” “Step backward,” and “Rest” insertion—that are
not available to the Step Input Keyboard. See Using Step Input Keyboard Key Commands.

Activating MIDI Step Input Mode
MIDI Step Input mode is available in the Event List, Piano Roll, and Score Editors.

To activate Step Input mode
µ Click the MIDI In button next to the local menu bar of the Event List, the Piano Roll Editor,

or the Score Editor.

Click the button again to exit Step Input mode.
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Using the Step Input Keyboard
You can open the Step Input Keyboard window by choosing Options > Step Input
Keyboard.

Note length buttons

Chord button
Sustain Inserted Notes 
button

Velocity buttons

Triplet buttonDot button

Keys

Quantize button

Channel pop-up menu

• Keys: Click to insert a note of the desired pitch. The insert range bar above the keyboard
updates to display the selected octave.

• Note length and velocity buttons: Determine the length or velocity of the inserted note.
There are eight velocity values—represented by the traditional volume indicators ppp,
pp, p, mp, mf, f, ff, and fff. These correspond to MIDI velocity values 16, 32, 48, 64, 80,
96, 112, and 127, respectively.

• Triplet button: Click to make the next three notes you enter a triplet group. The rhythmic
value of the triplets is based on the currently selected note value.

• Dot button: Works in a similar way to the Triplet button. A pair of complementary notes
will be inserted—a dotted eighth and a sixteenth note, for example.

• Sustain Inserted Notes button: Lengthens the selected (usually the most recently inserted)
note by the selected note length value (the active note length button).

• Quantize button: Quantizes the start of the next inserted note to the nearest bar or
beat line. Positioning of the playhead is critical when you use this option.

• Channel pop-up menu: Determines the MIDI channel of an inserted note. The channel
settings of individual notes usually have no effect on the playback channel, and therefore
the sound, of the MIDI region. The channel settings of individual notes are mainly used
for polyphonic score display.

• Chord button: When the Chord button is active, you can insert notes of different pitches
and lengths. These are “stacked” at the same position, resulting in a chord. The playhead
does not advance until the Chord button is deactivated.

To insert a note with the Step Input Keyboard
1 Open the MIDI region in the editor you wish to work in.

2 Move the playhead to an insert location.

3 Set the buttons for note length, velocity, and other parameters.
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4 Click a key in the Step Input Keyboard to insert a note of the key’s pitch.

A note of the chosen pitch, note length, and velocity is inserted, and the playhead
automatically advances to the end of the inserted note. The next note can be inserted
immediately, following the step above.

Chord mode prevents the playhead from moving after the insertion of a note, allowing
you to insert as many notes as desired at the same bar position.

To insert several notes at the same bar position
µ Turn on Chord mode by clicking the Chord button at the far left of the window (or use

the Chord Mode key command), then follow the procedure outlined above.

Before you insert the last note into the chord, click the Chord button again (or use the
Chord Mode key command) to deactivate Chord mode, and the playhead will advance
as usual after note insertion.

Using Step Input Keyboard Key Commands
Note input using Step Input key commands follows the same principles as note input
using the Step Input Keyboard, but there is one difference. Whereas you use Step Input
key commands for all functions, when you use the Step Input Keyboard you use the
mouse for some functions—such as choosing pitch, velocity, note length, and so on.

All step input key commands are user-definable. They can be found in the Step Input
Keyboard folder of the Key Commands window.

Note: You can also enter note data in real time with the computer keyboard (see Using
the Caps Lock Keyboard for MIDI Step Input).

Note Length and Velocity
Note Length and Velocity are determined before a pitch command is used to actually
insert a note. The currently selected values can be seen in the Step Input Keyboard
window.

Pitch Key Commands
The 12 “Note C” to “Note B” key commands insert a note of the selected pitch—with the
set length and velocity—at the current playhead position in the selected MIDI region.
Use the Chord Mode key command if you want to insert chords. You can disable Chord
mode with the same key command.

Rather than assigning key commands to all 12 pitches, you also have the option of defining
key commands for the 7 pitches of the C major scale. These can be used in conjunction
with the “Next note will be sharp” and “Next note will be flat” key commands, allowing
you to insert the other pitches.
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When you are creating a system for these key command assignments, consider the
following approaches:

• Lay out these commands on the computer keyboard to resemble a piano keyboard (C
D E F G A B in one row, next to each other, and C# D# F# G# A# above these at
corresponding positions).

• Assign alphabetical keys to pitches of the C major scale—in accordance with their note
names—especially when you are defining key commands for only the 7 pitches of the
C major scale as discussed above.

Octave Range Key Commands
The octave of an inserted note depends on the current position of the insert range bar.
There is a small horizontal bar that spans one octave above the piano keyboard in the
Step Input Keyboard. The chosen note will always be inserted inside the range indicated
by this bar.

This bar continuously changes its position in accordance with the last inserted note:  The
center of the insert range bar is always aligned with the last inserted note. The next note
is inserted within this octave range—unless the range bar is moved with key commands
or with the mouse.

For example, if you insert a G immediately after inserting a C, the G will be placed below
the C. Inserting the C places the insert range bar between G (the left end) and F# (the
right end), with the C in the center. Regardless of which note you choose next, it will
always be inserted inside this range. The range bar will move, however, as further notes
are inserted, with the range bar center always aligned to the most recently inserted note.

Further key commands allow you to place the range bar in different octaves:  Octave 0
to Octave 6, and also Octave +1/−1/+2/−2, which moves the range bar up or down 1 or
2 octaves. The range bar can also be moved with the mouse.

Rests, Stepping Forward and Backward, Corrections
The Rest key command moves the playhead forward (in accordance with the currently
set note value) without inserting a note, thereby creating a rest.

The Step Forward and Step Backward key commands also move the playhead forward
or back by the length of the selected note value.

The Delete key command deletes the most recently inserted note and moves the playhead
back to the position where the note (previously) began. This allows for quick
corrections—another note can be inserted immediately, replacing the erased one.
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Triplets, Dotted Note Groups
The “Next three notes are triplets” key command is self-explanatory. The rhythmic value
of the triplets corresponds to the currently selected note value in the Step Input Keyboard
window. If an eighth note is selected, an eighth-note triplet will be created. After three
notes have been inserted, binary values will be inserted, unless the command is reused.

The “Next two notes are a dotted group” key command works in a similar way, but it has
a special feature. When you use this key command, a pair of notes that complement each
other will be inserted—a dotted eighth and a sixteenth note, for example.

Interaction with Other Key Commands
When Step Input mode (the MIDI In button) is activated in the Score Editor, Piano Roll
Editor, or Event List, the Step Input key commands have priority over all other key
commands.

This means that you can assign keys or key combinations to these functions even if these
keys or key combinations are already assigned to other functions. As long as Step Input
mode is active, these key assignments will apply; if Step Input mode is turned off, other
assignments for the same keys will have priority.

Note: Because you can use key assignments that are already in use for other functions,
avoid using keys that are assigned to functions that you might also want to use when
working in Step Input mode. For example, the Space bar is used for Play/Stop/Continue,
so assigning it to Rest could be problematic.

Using a MIDI Keyboard for Step Input
Note input via MIDI works in the same way as input via the Step Input Keyboard (see
Using the Step Input Keyboard). One difference, of course, is that you press keys on your
real-world MIDI keyboard, rather than clicking onscreen keyboard notes.

MIDI note velocity information—how hard you strike the keys on your MIDI keyboard—is
sent when you use MIDI Step Input.

You can insert chords by simply playing the chord on the MIDI keyboard. You don’t need
to turn on Chord mode to insert a chord.

It is recommended that you keep the Step Input Keyboard window open when first using
these functions, to make the learning process easier. After you are familiar with it, you
can leave the Step Input Keyboard window closed, because it is just an aid for MIDI step
input, not a requirement.

It is also recommended that you use the Input key commands (see Using Step Input
Keyboard Key Commands) to quickly switch values such as the note length, or to determine
the insert position.
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Using the Caps Lock Keyboard for MIDI Step Input
The Caps Lock Keyboard enables you to use the computer keyboard as a real-time virtual
MIDI keyboard. You can also use it for MIDI Step Input. This makes it ideal for situations
where no external MIDI or USB keyboard is available, such as when you’re traveling with
your portable Mac computer.

The Caps Lock Keyboard spans more than ten octaves and even includes support for
sustain and velocity information.

To enable the Caps Lock Keyboard
µ Press the Caps Lock key on your computer keyboard.

A green dot on the key indicates that it is active.

Note that many keys have different functions that override their usual key command
assignments, while in this mode.

This is the English version of the Caps Lock Keyboard—another language version may
appear, depending on your Input Menu settings in International preferences.

The Escape key sends an All Notes Off command, should you encounter hanging notes.

The numeric keys (above the QWERTY keyboard) are used to define the octave for the
MIDI keyboard.

The two rows below the numeric keys function as counterparts for MIDI keyboard keys,
starting with the note C, assigned to the alphabetical A key (or Q, as would be the case
with a French keyboard, for example).

See the black and white keys in the figure above for details.

The lowest row of letter keys sets the velocity for MIDI notes. There are preset
values—ranging from pianissimo to forte fortissimo. Each value can be finely adjusted
with the two keys to the right of this row (these are assigned to the comma and period
keys on an English QWERTY keyboard). This keyboard configuration allows you to send
any MIDI velocity value from 1 to 127.
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The Space bar provides a Sustain function—played with your thumbs rather than your
feet. You can trigger new notes or switch between octave or velocity values while notes
are sustained.

The current octave and velocity values of MIDI notes are displayed at the upper edge of
the Caps Lock Keyboard window. A Transparency fader is also available for this window,
making visualization clearer or allowing the window to be “ghosted” over the background.

Caps Lock Keyboard Preferences
The “Enable Caps Lock keys” option allows you to completely enable or disable the Caps
Lock Keyboard functionality.

If you want to use the Space bar to start, stop, or continue Logic Pro playback—rather
than as the Sustain function for the Caps Lock Keyboard (when active)—you can deselect
the “Space bar acts as sustain pedal” option.

Additional Caps Lock Keyboard Information
Due to technical limitations of computer keyboards, you can play a maximum number
of six notes simultaneously, and there are additional limitations regarding timing precision
and playing certain unusual note clusters.

The original intention of this feature, however, was to be a useful aid for composing on
a train or plane—not a full-on replacement for a real MIDI keyboard.
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Imagine a scenario where you have recorded multiple performances of a vocal solo over
the same section of a project. In this chapter, you’ll learn how to select the best parts
from the different performances, piecing them together into a single master take. This
process of combining multiple take recordings into a single perfect composition is referred
to as comping and is achieved by using the Quick Swipe Comping feature. In this chapter,
you’ll also learn how to drag or cut the contents of take folders.

This chapter covers the following:

• Getting to Know Take Folders (p. 482)

• Previewing Take Folder Recordings (p. 482)

• Toggling Take Folder Editing Mode (p. 484)

• Creating Comps (p. 486)

• Editing Comps (p. 487)

• Resizing Take Regions (p. 492)

• Cutting Take Folders and Take Regions (p. 493)

• Moving Take Folders and Take Regions (p. 496)

• Duplicating Comps or Creating New Comps (p. 498)

• Renaming Takes or Comps (p. 500)

• Deleting Takes or Comps (p. 503)

• Exporting Takes or Comps to New Tracks (p. 507)

• Moving Takes or Comps to New Tracks (p. 511)

• Flattening and Merging Take Folders (p. 515)

• Unpacking Take Folders (p. 518)

• Packing Regions into a Take Folder (p. 522)

• Opening Take Folders in the Sample Editor (p. 523)
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Getting to Know Take Folders
You will typically encounter the following elements in an open audio take folder:

Comp sections

Quick Swipe Comping 
button

Take folderTake lane

Take

Disclosure triangle

Take Folder pop-up 
menu

• Take folder: Contains multiple take performances, which are recorded over the same
section of the project.

• Take lane: Contains a single take, which can be made up of one or more take regions.
The most recently completed take is located on the top take lane, just underneath the
take folder, and is selected by default.

• Take: Represents one or more take regions.

• Composite (comp) sections: Reflects the current comp selections.

• Disclosure triangle: Allows you to open or close the take folder.

• Take Folder pop-up menu: Allows you to access the majority of take folder editing
commands.

• Quick Swipe Comping button: Allows you to define the take folder’s editing mode.

Previewing Take Folder Recordings
The simplest way to preview take folder recordings is to open the take folder. You can
then select the individual takes for playback.
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To open a take folder and preview the recordings
1 Open the take folder by doing one of the following:

• Click the disclosure triangle in the top-left corner of the take folder (or use the
Un/disclose Take Folder key command).

• Double-click the take folder.

2 During playback, do one of the following:

• Option-click the header area of takes if the active take folder is in Quick Swipe Comping
editing mode.

• Click the header area of takes if the active take folder is not in Quick Swipe Comping
editing mode.

This allows you to preview the recordings on each individual take lane.

Note: You can open multiple take folders by Option-clicking the disclosure triangle in
the upper-left corner of one of the selected take folders.

You can also preview recordings in a closed take folder.

To preview recordings in a closed take folder
µ During playback, click the arrow in the top-right corner of the take folder, then choose a

take from the pop-up menu.
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The following key commands enable you to step through take recordings in an open or
closed take folder:

• Select Previous Take or Comp: Moves back through the selection of takes and comps as
listed in the take folder’s pop-up menu.

• Select Next Take or Comp: Moves forward through the selection of takes and comps as
listed in the take folder’s pop-up menu.

Note: These commands also work for multiple take folder selections.

Toggling Take Folder Editing Mode
You can switch individual take folders between two different editing modes. The active
editing mode determines the types of edits that can be made in the take folder.

The editing modes are as follows:

• Quick Swipe Comping: Activates quick swipe capabilities in the chosen take folder,
allowing you to create and edit comps.

The following provides an indicator of when a take folder is in Quick Swipe Comping
mode:

Quick Swipe Comping on

• Quick Swipe Comping off: Turns off quick swipe capabilities in the chosen take folder,
allowing you to cut, drag, and move take folder and take region elements.

The following provides an indicator of when a take folder is not in Quick Swipe Comping
mode:

Quick Swipe Comping off
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To toggle take folder editing mode
Do one of the following:

µ Click the arrow in the top-right corner of the take folder, then choose Quick Swipe
Comping from the pop-up menu (or use the Toggle Take Folder Quick Swipe Comping
Mode key command, default assignment: Option-Q).

µ Click the Quick Swipe Comping button in the top-right corner of the take folder.

Take Folder Editing Mode 
button
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Creating Comps
You can use quick swipe comping techniques to select the best parts from several take
recordings, combining these parts into one master take.

Note: Quick swipe comping is possible only if your chosen take folder is in Quick Swipe
Comping mode. For details, see Toggling Take Folder Editing Mode.

To combine sections of different take regions into a comp
µ Select take region sections by dragging over them with the Pointer or Pencil tool.

Selecting a section in one take region automatically deselects the same section in another
take region.
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The comp sections, located in the top lane of the take folder, reflect the combined
selections from all take regions. The vertical lines in the waveform overview indicate the
transitions between the different take region sections.

For details about how to edit your comps, see Editing Comps.

Editing Comps
You can edit comps by changing the start or end points of take region sections, by moving
a selected comp area to the left or right, or by alternating selected comp areas between
take lanes.

The tasks outlined in this section are possible only if your chosen take folder is in Quick
Swipe Comping mode. For details, see Toggling Take Folder Editing Mode.

Important: Before performing any edits on a comp, you should save it. Any subsequent
changes will automatically create a new comp. For details, see Duplicating Comps or
Creating New Comps.

To edit sections of different take regions
Do one of the following:

µ Place the pointer over the start or end point of a take region’s selected area, then drag
when the pointer turns into the length change icon.
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Extending a take region section (dragging the start point to the left or the end point to
the right) automatically shortens adjacent sections on other take regions. Shortening a
take region section (dragging the start point to the right or the end point to the left)
automatically extends adjacent sections on other take regions. This ensures that you do
not create silence between different take region sections.

µ Place the pointer over the start or end point of a take region’s selected area, then Shift-drag
when the pointer turns into the length change icon.

Shortening a take region section (dragging the start point to the right or the end point
to the left) does not extend adjacent sections on other take regions. This allows you to
create silence between different take region sections.
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To move a selected comp area to the left or right
µ Place the pointer over the center of a take region’s selected area, then drag when the

pointer changes to a two-headed arrow.

This moves the selection area, while at the same time extending or shortening any adjacent
take region selections.
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To alternate selected comp areas between take lanes
µ Click an unselected area of a take region to make that particular area active and part of

the comp.

This automatically deselects the same area in another take region. This is a quick way to
compare a comp area on one take region with the same comp area on another take
region.

You can remove take region sections, or entire take regions, from the comp sections at
the top of the take folder.
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To remove a take region section from the comp sections
µ Shift-click the take region section.

To remove an entire take region from the comp sections
µ Shift-click the take region header area.

Note: If the take region does not contain any comp selections, all unselected areas in
other take regions are selected in the take region you click.
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Resizing Take Regions
You can edit the start and end points of take regions, which allows you to remove the
bad part of an otherwise good take. You can do this when a take region is bordered by
an adjacent take region. Resizing a take region in this situation may also impact the length
of the adjacent take region.

To resize take regions, you need to make sure your chosen take folder is not in Quick
Swipe Comping mode. For details, see Toggling Take Folder Editing Mode.

To edit a take region’s start or end point
µ Place the pointer over the lower-left or lower-right edge of the take region, then drag

when you see the Resize pointer.

You can also edit adjacent take region borders using the Junction tool.
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To edit a take region’s start or end point when bordered by another take region
µ Place the pointer over the top-left or top-right edge of the take regions, then drag when

you see the Junction pointer.

Extending a take region (dragging the start point to the left or the end point to the right)
automatically shortens the adjacent take region. Shortening a take region (dragging the
start point to the right or the end point to the left) automatically extends the adjacent
take regions. This ensures that you do not create silence between different take region
sections.

Cutting Take Folders and Take Regions
You can cut take folders and take regions, and therefore have multiple take folders or
multiple take regions on the same take lane.

For cutting activities, your chosen take folder must not be in Quick Swipe Comping mode.
For details, see Toggling Take Folder Editing Mode.

493Chapter 15 Editing Audio Take Recordings



To cut a take folder
µ Click the take folder using the Scissors tool.

This cuts the take folder at the clicked position, while also cutting all takes inside the take
folder at the same position. Your track lane contains multiple take folders and your take
lanes contain multiple take regions, all of which can be edited independently of each
other.

To cut multiple take folders
µ Select multiple take folders, then click any one of them using the Scissors tool.

This cuts all selected take folders at the clicked position, while also cutting all takes inside
the take folders at the same position. Your track lanes contain multiple take folders and
your take lanes contain multiple take regions, all of which can be edited independently
of each other.
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To cut a take region
µ Click the take region using the Scissors tool.

You now have multiple take regions on the same take lane.

You can also make cuts of equal intervals across a single take region.

To make multiple cuts across a take region
µ Option-click the take region using the Scissors tool.
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The first cut occurs at the clicked position, with all further cuts occurring at equal intervals
up to the take region end point.

Another possibility is to slice or trim a take region at comp section borders.

To slice a take region at comp section borders
µ Control-click (or right-click) the take region, then choose “Slice at Comp Section Borders”

from the shortcut menu.

To trim a take region to active comp sections
µ Control-click (or right-click) the take region, then choose “Trim to Active Comp Sections”

from the shortcut menu.

You can also divide take folders and take regions using the following key commands:

• Split Regions/Events by Locators or Marquee Selection

• Split Regions/Events by rounded Playhead Position

• Split Regions/Events by Playhead Position

Moving Take Folders and Take Regions
You can move take folders and take regions around—within the same take lane, between
take lanes, and to other tracks.

Whether or not you have chosen Overlap or No Overlap in the Drag menu, take regions
inside take folders will always behave as if No Overlap is selected.

Note: For tasks that involve moving take folders and take regions, your chosen take folder
must not be in Quick Swipe Comping mode. For details, see Toggling Take Folder Editing
Mode.
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To move a take folder or take region within its own lane
Do one of the following:

µ Drag the take folder or take region to the new position.

µ Select the take folder or take region, then use one of Logic Pro’s nudge key commands.

You can also move take regions between take lanes.

To move take regions between take lanes
µ Drag the take region to another take lane.

Note: Empty take lanes are automatically removed.
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To create a new take lane for a take region
µ Drag the take region onto the take folder, at a position where it will overlap with a take

region in the currently active take.

Note: If the dragged take region does not overlap with a take region in the currently
active take, it will be added to the take lane of the active take.

A new take lane is created directly under the take folder, and the take region is added as
a new take.

Duplicating Comps or Creating New Comps
After creating a comp, it’s a good idea to save it so that you can easily return to it at a
later point.
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To save the current comp
µ Click the arrow in the top right of the take folder, then choose Duplicate Comp from the

pop-up menu (or use the Duplicate Comp key command).

This saves the current comp, adding it to the list of comps in the pop-up menu.

You can also create a new comp from the currently active take.
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To create a new comp from the active take
µ Click the arrow in the top right of the take folder, then choose Create New Comp from

the pop-up menu (or use the Create New Comp key command).

This saves the current take as a new comp named Comp X:  Comp X, adding it to the list
of comps in the pop-up menu.

By default, new comps are saved as Comp X:  Comp X. For details about renaming, see
Renaming Takes or Comps.

Renaming Takes or Comps
You can rename both takes and comps.
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To rename a take
1 Click the arrow in the top right of the take folder, then choose the take you want to

rename from the pop-up menu.

2 Click the arrow in the top right of the take folder, then choose Rename Take from the
pop-up menu (or use the “Rename Take or Comp” key command).
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3 Type the new name in the dialog that opens, then click OK.

Tip: You can also click a take region with the Text tool, and type a new name in the text
input field that appears.

To rename a comp
1 Click the arrow in the top right of the take folder, then choose the comp you want to

rename from the pop-up menu.
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2 Click the arrow in the top right of the take folder, then choose Rename Comp from the
pop-up menu (or use the “Rename Take or Comp” key command).

3 Type the new name in the dialog that opens, then click OK.

Deleting Takes or Comps
You can delete takes or comps from take folders at any time. When deleted, they no
longer appear in the take folder’s list of takes and comps. Any comp selections using
deleted takes are also removed.
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To delete a take
1 Click the arrow in the top right of the take folder, then choose the take that you want to

delete from the pop-up menu.

2 Delete the take by doing one of the following:

• Click the arrow in the top right of the take folder, then choose Delete Take from the
pop-up menu (or use the “Delete Take or Comp” key command).
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• Click the take using the Eraser tool.

• Press the Delete key.

To delete a comp
1 Click the arrow in the top right of the take folder, then choose the comp that you want

to delete from the pop-up menu.
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2 Click the arrow in the top right of the take folder, then choose Delete Comp from the
pop-up menu (or use the “Delete Take or Comp” key command).

You can also delete all comps in a take folder except the currently active comp.

To delete all but the current comp
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the comp that you want to keep.
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2 Click the arrow in the top right of the take folder, then choose “Delete all other Comps”
from the pop-up menu.

All comps, with the exception of the currently active comp, are deleted.

Note: This command is available only when a take folder contains more than one comp
and when a comp is active.

Exporting Takes or Comps to New Tracks
You can export an active take or comp from a take folder to a new track, leaving the
original take folder content intact.
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To export an active take to a new track
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the take you want to export.

2 Click the arrow in the top right of the take folder, then choose “Export active Take to New
Track” from the pop-up menu (or use the “Export Active Take or Comp to New Track” key
command).
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This copies the active take to a new track, which is created below the take folder track.
The exported take can be made up of one or more take regions. The content of the
original take folder remains intact.
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To export an active comp to a new track
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the comp you want to export.

2 Click the arrow in the top right of the take folder, then choose “Export active Comp to
New Track” from the pop-up menu (or use the “Export Active Take or Comp to New Track”
key command).
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This copies the active comp to a new track, which is created below the take folder track.
The content of the original take folder remains intact.

Moving Takes or Comps to New Tracks
You can move an active take or comp from a take folder to a new track, which removes
the take or comp from the original take folder.
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To move an active take to a new track
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the take you want to move.

2 Click the arrow in the top right of the take folder, then choose “Move active Take to New
Track” from the pop-up menu (or use the “Move Active Take or Comp to New Track” key
command).
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This moves the active take to a new track, which is created below the take folder track.
This take is no longer available in the original take folder.

To move an active comp to a new track
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the comp you want to move.
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2 Click the arrow in the top right of the take folder, then choose “Move active Comp to
New Track” from the pop-up menu (or use the “Move Active Take or Comp to New Track”
key command).
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This moves the active comp to a new track, which is created below the take folder track.
This comp is no longer available in the original take folder.

Flattening and Merging Take Folders
You can flatten a take folder, which replaces the take folder with multiple regions that
represent the current comp selections. All take region sections not used in the current
comp are deleted.
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To flatten a take folder
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the comp you want to keep.

2 Click the arrow in the top right of the take folder, then choose Flatten from the pop-up
menu (or use the Flatten Take Folder key command).
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This replaces the take folder with multiple regions that represent the current comp
selections.

You can also flatten a take folder and merge the results. This replaces the take folder with
a single region that represents the current comp selections. All take region sections not
used in the current comp are deleted.

To flatten and merge a take folder
1 Click the arrow in the top right of the take folder to open the pop-up menu, then choose

the comp you want to keep.
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2 Click the arrow in the top right of the take folder, then choose “Flatten and Merge” from
the pop-up menu (or use the “Flatten and Merge Take Folder” key command).

The take folder is replaced with multiple regions that represent the current comp
selections, and all take region sections not used in the current comp are deleted. The
new regions are then merged to create a new audio file in the Arrange area. The newly
created audio file matches the size of the take folder—independent of the start position
of the first region or the end position of the last region.

If you want to flatten a take folder without deleting the original take folder and its unused
content, see Exporting Takes or Comps to New Tracks.

Unpacking Take Folders
You can unpack take folders using the original channel strip for all new tracks, or you can
unpack take folders using different channel strips for each new track. Both methods
replace the selected take folder—or take folders—with new audio tracks for each take
and each comp. The first audio track reflects the active comp, followed by the takes and
remaining comps in the order they appear in the take folder’s pop-up menu.
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To unpack take folders
Do one of the following:

µ Choose Region > Folder > Unpack Take Folder in the Arrange area’s local menu bar (or
use the corresponding key command, default assignment:  Control-Command-U).

µ Control-click (or right-click) the take folder header area, then choose Folder > Unpack
Take Folder from the pop-up menu.

µ Click the arrow in the top-right corner of the take folder, then choose Unpack from the
pop-up menu.

Note: The latter option affects only the chosen take folder, not all selected take folders.
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This command—Unpack Take Folder, or Unpack—uses the original channel strip for all
new tracks. All takes and comps, with the exception of the currently active comp, are
muted. This ensures that the playback result remains unchanged. Any edits made to one
of these tracks will be reflected in all others.

To unpack take folders to new tracks
Do one of the following:

µ Choose Region > Folder > “Unpack Take Folder to New Tracks” in the Arrange area’s local
menu bar (or use the corresponding key command, default
assignment:  Control-Shift-Command-U).

µ Control-click (or right-click) the take folder header area, then choose Folder > “Unpack
Take Folder to New Tracks” from the pop-up menu.
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µ Click the arrow in the top-right corner of the take folder, then choose “Unpack to New
Tracks” from the pop-up menu.

Note: The latter option affects only the chosen take folder, not all selected take folders.
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This command—“Unpack Take Folder to New Tracks,” or “Unpack to New Tracks”—uses
different channel strips for each new track, but automatically assigns the original channel
strip setting to all of them. None of the takes or comps is muted. Edits can be made to
each of the tracks independently of the others.

Packing Regions into a Take Folder
You can select multiple regions and pack them all into a single take folder. Each region
appears as an individual take in the resulting take folder.

To pack selected regions into a take folder
Do one of the following:

µ Choose Region > Folder > Pack Take Folder in the Arrange area’s local menu bar (or use
the corresponding key command, default assignment:  Control-Command-F).

µ Control-click (or right-click) the selected regions, then choose Folder > Pack Take Folder
from the pop-up menu.

Note the following when packing regions into a take folder:

• If the selected regions are located on different tracks, the newly created take folder is
placed on the topmost track. This may change the playback result, because the take
folder uses a single channel strip, whereas previously the tracks may have used different
channel strips.
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• If the selected regions are placed one after the other on a single track, the newly created
take folder defaults to one automatically created comp.

• If only one region is packed into a take folder, it is selected as the take and no comp
is created.

Opening Take Folders in the Sample Editor
Although you can open take regions in the Sample Editor, the take regions are locked,
making it impossible to move the anchor or redefine start or end points. If you want to
perform fine edits of start and end points, you can do this in the Arrange area, when
zoomed in. The timing of individual sections can be adjusted after the take folder has
been “flattened.”
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Flex Time editing—similar to what is often referred to as elastic audio in other
applications—is a nondestructive form of audio editing in Logic Pro. It is a process that
allows you to correct a single note or the timing of an entire region, all within the Arrange
window. Flex Time editing greatly simplifies the process required for altering the timing
of audio material. It allows you to compress or expand the time between specified points
in an audio region without the need for more traditional processes like cutting, nudging,
and crossfading. This chapter introduces you to the techniques used for Flex Time editing
as well as the track-based settings that determine how the timing of your audio will be
altered—either by using time compression or expansion algorithms, by manipulating
invisibly sliced segments, or by speeding up or slowing down the material.

You edit the timing of audio material using flex markers. When you move a flex marker,
it time compresses or expands the area around it. The initial boundaries within which
this is done is determined by the transient markers. Transient markers denote significant
points—or transients—in an audio file. The audio on a track is analyzed for transients the
first time you enable that track for Flex Time editing. Any detected transients in the file
are marked with transient markers. You manipulate flex markers either in the Arrange
area’s Flex view, or invisibly using the Flex tool. You can create single or multiple flex
markers in an audio file, allowing you to manipulate the position of single notes or
complete phrases.

This chapter covers the following:

• Turning on Flex View (p. 526)

• Choosing Flex Modes (p. 526)

• Getting to Know the Flex Modes (p. 529)

• Getting to Know Transient, Flex, and Tempo Markers (p. 531)

• Working with Flex Markers (p. 532)

• Time Stretching Using Marquee Selections (p. 538)

• Time Stretching Using Region Borders (p. 539)

• Snapping Flex Markers to Transient Markers (p. 540)

• Splitting Audio Regions at Transient Marker Positions (p. 541)
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• Using the Flex Tool (p. 541)

• Using Varispeed to Alter Playback Speed and Pitch (p. 545)

Turning on Flex View
To edit the timing of your audio files, you need to turn on Flex view in the Arrange area.

To turn on Flex view
Do one of the following:

µ Choose View > Flex View in the Arrange area’s local View menu (or use the Hide/Show
Flex View key command).

µ Click the Flex View button in the Arrange toolbar (if visible).

Turning on Flex view displays the Flex Mode button in the track header of each audio
track in the Arrange area.

Flex Mode button

This button determines which flex mode, if any, is used for processing the audio material
on the selected track. For details, see Choosing Flex Modes.

Choosing Flex Modes
Flex modes are track-based settings that determine how the audio will be altered—either
by using time compression or expansion algorithms, by manipulating invisibly sliced
segments, or by speeding up or slowing down the material. Your first step is to assign a
flex mode to the audio track, which affects the entire contents of the track.
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To assign a flex mode to an audio track
Do one of the following:

µ Click the Flex Mode button in the arrange track list, then choose a mode from the pop-up
menu.

µ Select the Flex Mode parameter in the Track Parameter box, then choose a mode from
the pop-up menu.

The flex mode you choose is assigned to all audio regions or audio take folders across
the track.

Note: When you set the flex mode for a track, the Freeze Mode parameter in the Track
Parameter box switches from Pre Fader to Source Only. For details about the Freeze
feature, see Freezing Tracks in the Arrange Area.
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After assigning a flex mode to an audio track, you have the option of isolating individual
regions—or take regions in the case of take folders—from the effects of the chosen flex
mode algorithm. You do this by turning off the flex mode for the individual regions or
take regions.

To turn off the flex mode for individual regions, or take regions, on an audio track
µ Select a region or take region on the chosen track, then deselect the Flex checkbox in

the Inspector’s Region Parameter box.

This disables all Flex Time editing properties on the region or take region.

Flex checkbox

Note: Flex markers are disabled, but not deleted, and the region plays at its original speed.

You can also choose a flex mode and assign it to all audio tracks in the Arrange area.

To assign the same flex mode to all tracks
Do one of the following:

µ Hold down the Shift key while you open the Flex Mode pop-up menu in the arrange track
list and choose a mode.

µ Hold down the Shift key while you open the Flex Mode pop-up menu in the Inspector’s
Track Parameter box and choose a mode.

When you assign a flex mode to an audio track for the first time, all audio files on that
track are passed through a transient detection process. Audio files on the track are scanned,
transients in the audio material are detected and marked, and all information about
transient positions is stored in the audio files.

Note: Transient markers are identical in all audio regions that refer to the same section
of an audio file, and they are consistently present when you use that audio file in multiple
projects.
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Getting to Know the Flex Modes
Flex modes determine how the audio material is processed, and each flex mode is best
suited to a specific type of audio material. Rhythmic, Monophonic, and Polyphonic flex
modes are named based on the type of material they are best suited for. Slicing,
Tempophone, and Speed are so named to indicate the specialized process they apply.
When you choose one of these flex modes from the Flex Mode pop-up menu, the
parameters for that flex mode appear below it in the Inspector’s Track Parameter box.
You adjust these parameters by selecting a checkbox or by dragging the value vertically.

Flex modeFlex mode and 
parameters

You can choose from the following flex modes, and their respective parameters, for track-
and region-based Flex Time editing in Logic Pro:

Off
Disables all Flex Time editing properties on the audio track.

Note: If an audio track in this flex mode contains Apple Loops, they will follow the project
tempo unless the Follow Tempo checkbox is unselected in the Region Parameter box.

Slicing
Slices the audio material at transient markers, then shifts the audio while playing each
slice at its original speed. No time compression or expansion is applied to the shifted
audio. Any gaps that occur as a result of shifting the audio can be filled using the decay
function. Slicing is a good choice for drums and percussion.

• Fill Gaps: Turns the decay function on or off, allowing you to fill any gaps that occur
between sounds as a result of shifting the audio.

• Decay: Sets the decay time between sounds, because no time stretching takes place
to compensate for the gaps.

• Slice Length: Shortens each slice by a percentage value. Shortening slices can be helpful
for removing unwanted pre-attack sounds from the following slice, or to create a gated
effect.
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Rhythmic
Rhythmic flex mode time stretches the material, looping audio between slices in order
to fill any gaps. This mode is most suitable for nonmonophonic material, such as rhythmic
guitars, keyboard parts, and Apple Loops.

• Loop Length: Sets the length of the looped section at the end of a slice that is used for
time expansion.

• Decay: Defines a decay value for the looped area.

• Loop Offset: Allows you to move the looped area up to 100 ms to the left, preventing
pre-attack sounds from the following transient to appear in the looped and crossfaded
area.

Monophonic
Monophonic flex mode is designed to be used on melodic instruments only playing a
single note at a time, and is therefore good for solo vocals and monophonic solo
instruments—melody and bass lines, for example. When you use this flex mode, your
recording should be relatively dry, without audible reverberation. Otherwise, you may
want to try using Polyphonic.

Monophonic flex mode comes with a single parameter—percussive—that preserves the
area around transient markers to protect the percussive part of the sound. If selected,
allows better timing for all kinds of percussive monophonic tonal material, such as plucked
strings (guitar, bass) or tonal percussion. If unselected, prevents glitches on transient
markers in nonpercussive tonal material, such as bowed strings or wind instruments.

Polyphonic
Polyphonic flex mode time stretches material based on a process called phase vocoding—a
process which uses phase information to time stretch an audio signal without touching
its pitch. It is the most processor-intensive of all the flex modes, but it delivers high sonic
quality with suitable polyphonic material. It is recommended for complex polyphonic
material and is good for all kinds of chords—such as guitar, piano, and choir—and also
complex mixes.

Polyphonic flex mode comes with a single parameter—complex—that enables more
internal transients in the audio material.

Tempophone
Tempophone flex mode emulates the effect of a historical tape-based time-stretching
device known as a tempophone, and results in a mechanical sound with many artifacts
similar to those produced with granular synthesis techniques. It is intended to be used
creatively for special effects.

• Grain Size: Sets the size of the grains that are played or repeated in their original speed
and crossfaded to create time compression or expansion.
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• Crossfade: Adjusts the crossfade length from 0.00, which produces hard artifacts, to
the full grain length of 1.00, which tends to sound softer.

Speed
Speed flex mode time stretches material by playing the source material faster or slower,
including pitch change. Because of the pitch shifting, this flex mode is mainly useful for
percussive material, but it can be used on all material for interesting creative effects.

Getting to Know Transient, Flex, and Tempo Markers
You will encounter some or all of the following marker types when working on flex-enabled
audio regions:

Transient marker Tempo marker Tempo marker
(region end)

Quantize flex markerFlex marker

• Transient markers: Displayed as faded gray lines in the background of an audio region,
transient markers denote significant points in an audio file. Transient markers are
displayed after the audio on a track is analyzed for transients the first time you enable
that track for Flex Time editing. For details, see Using Transient Markers to Edit in the
Sample Editor.

• Flex markers: Displayed as white lines with orange handles, flex markers allow you to
alter the timing of audio material. By moving a flex marker, you time compress or
expand the area around it, but within the boundaries of the existing transient markers.
For details, see Working with Flex Markers.

• Quantize flex markers: Displayed as white lines, quantize flex markers—or simply quantize
markers—are created automatically during the audio quantization process. Quantize
markers indicate where audio has been time-stretched during the audio quantization
process. When you edit a quantize marker, it’s converted to a normal flex marker (with
an orange handle). For details, see Quantizing Audio or MIDI Regions.
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• Tempo markers: Displayed as blue lines, tempo markers denote a tempo change at that
point in the audio region and continue to maintain that tempo change during
time-stretching activities. A tempo marker located at the end of an audio region indicates
that the region follows the project tempo; changing the tempo does not change the
length of that region. For details, see Moving Flex Markers and Time Stretching.

Working with Flex Markers
Flex markers allow you to alter the timing of audio material. You can create them manually
(as discussed in this section) or they can be created automatically during the audio
quantization process (see Quantizing Audio or MIDI Regions).

You can create single or multiple flex markers in an audio file, which allows you to
manipulate whole or partial areas of the material. The following sections describe the
various ways to create, move, and delete flex markers.

Tip: You may find it useful to use the Zoom function in Logic Pro when creating, editing,
and deleting flex markers.

Creating Flex Markers
You can create flex markers within the body of an audio region, either between or directly
on top of existing transient markers.

Note: Make sure that Flex view is turned on and a flex mode is set for the track. For details,
see Turning on Flex View and Choosing Flex Modes.

To create a flex marker
µ Click the area in the upper half of the waveform body.

• If you click in the area on or beside an existing transient marker (note the change of
mouse pointer), the flex marker is created directly on top of the transient marker.
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• If you click in the area where a transient marker does not exist (note the change of
mouse pointer), the flex marker is created at the clicked position.

Note: You can drag a flex marker—and thereby edit the timing of the
material—immediately after you create it. This action alters the timing of the audio
material between that flex marker and the preceding and following flex markers, or the
region start and end positions if there are no preceding and following flex markers.

You can also create multiple flex markers in an audio region.

To create multiple flex markers
Do one of the following:

µ Click the area in the lower half of the waveform body.

Three flex markers are created, according to where you click:

• If you click in the area on or beside a transient marker (note the change of mouse
pointer), three flex markers are created in these positions:

• On the transient marker

• On the previous transient marker

• On the following transient marker
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• If you click in the area where a transient marker does not exist (note the change of
mouse pointer), three flex markers are created in these positions:

• At the clicked position

• On the previous transient marker

• On the following transient marker

µ Drag a selection in the region with the Marquee tool, then click it with the Pointer tool.

• If you click in the upper half of the selection area, four flex markers are created in these
positions:

• Two at the marquee borders

• Two outside the marquee selection at the previous and next transient positions

• If you click in the lower half of the selection area, three flex markers are created in these
positions:

• One at the clicked position

• Two at the marquee borders

534 Chapter 16 Flex Time Editing



Moving Flex Markers and Time Stretching
When you move flex markers, the audio material will be time-stretched, but the results
depend on which flex marker you move and where you move it.

Consider the following two examples:

• When you move a flex marker to the left: The audio material is time-compressed up to
the preceding flex marker, the preceding tempo marker, or the region start position.
The audio material is time-expanded up to the following flex marker or the following
tempo marker (which can also be the region end position).

• When you move a flex marker to the right: The audio material is time-expanded up to
the preceding flex marker, the preceding tempo marker, or the region start position.
The audio material is time-compressed up to the following flex marker or the following
tempo marker (which can also be the region end position).

Note: You can reset a flex marker by Control-clicking (or right-clicking) the flex marker,
then choosing Set To Neutral Position from the shortcut menu.
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If you move a flex marker to the left and the flex marker crosses the previous flex marker,
the previous flex marker jumps back to the previous transient marker. This allows you to
extend the Flex Time editing range to the left. The same behavior occurs if a flex marker
crosses a tempo marker.

If you move a flex marker to the right and the flex marker crosses the following flex marker,
the following flex marker jumps forward to the next transient marker. This allows you to
extend the Flex Time editing range to the right. The same behavior occurs if a flex marker
crosses a tempo marker.

When you move a flex marker, time stretching is highlighted with green, orange, or red.
If you click a flex marker, the area of the waveform that will be affected by time stretching
is highlighted with the relevant color. These colors are also used to represent areas where
the timing has been edited, as follows:

• Green: Time compression is shown in increasing shades of green, the more the audio
region section is compressed.

• Orange: Time expansion is shown in increasing shades of orange, the more the audio
region section is expanded.
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Note: Time compression or expansion may lead to reduced sound quality. However,
if Slicing mode is selected, the audio itself is never time-compressed or expanded, so
the sound quality is retained.

• Red: High-speed sections, where time compression equals or exceeds factor
8—time-stretching factor 0.125—turn from green to red and come with a warning.

Moving Flex Markers Without Time Stretching
You can change a flex marker’s position in an audio region without changing the timing
of the audio material before or after the flex marker.

To move a flex marker without time stretching
µ Hold down the Option key while you drag the flex marker.

When you drag a flex marker, you can press the Option key to turn time stretching off,
or release the Option key to turn time stretching on.

Deleting Flex Markers
When you delete a flex marker, any time alteration that took place in the area around it
is either removed—with the audio material reset to its original position—or reset according
to the time-stretching offset of the previous or following flex marker.

There are a number of methods you can use when deleting one or more flex markers,
including quantize markers.

To delete a flex marker
Do one of the following:

µ Double-click the flex marker.

µ Drag across the flex marker with the Eraser tool.

Important: Make sure to use the Eraser tool in the body of the waveform only. Clicking
the region header with the Eraser deletes the entire region.

µ Control-click (or right-click) the flex marker, then choose Delete Flex Marker from the
shortcut menu.
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To delete multiple flex markers
Do one of the following:

µ Drag across multiple flex markers with the Eraser tool.

Important: Make sure to use the Eraser tool in the body of the waveform only. Clicking
the region header with the Eraser deletes the entire region.

µ Control-click (or right-click) the region background, then choose Delete All Flex Markers
from the shortcut menu.

It is also possible to delete only those flex markers that were created manually, leaving
quantize markers intact.

To delete manually created flex markers only
µ Control-click (or right-click) the region background, then choose Delete Manually Created

Flex Markers from the shortcut menu.

Time Stretching Using Marquee Selections
You can drag a selection in a region with the Marquee tool and then click it with the
Pointer tool to create four flex markers—two at the marquee borders, and two outside
the marquee selection at the previous and next transient positions.

You can then time stretch the audio material outside of the marquee selection.

To edit the timing of audio material using a marquee selection
1 Drag a selection in a region with the Marquee tool.
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2 Click in the upper half of the selection area with the Pointer tool, then drag the highlighted
area—between the second and third flex markers—in either direction.

This process allows you to compress or expand the audio material between the first and
second flex markers or between the third and fourth flex markers. Nothing happens to
the audio material between the second and third flex markers.

If you move the marquee selection area to the left and the first flex marker crosses a
previous flex marker, the previous flex marker jumps back to the previous transient marker.
This allows you to extend the Flex Time editing range to the left.

If you move the marquee selection area to the right and the fourth flex marker crosses a
following flex marker, the following flex marker jumps forward to the next transient
marker. This allows you to extend the Flex Time editing range to the right.

Time Stretching Using Region Borders
You can apply equal time stretching across the body of an entire audio region. You do
this using the region borders.

To time stretch audio material using the region border
µ Hold down the Option key while you drag the region’s lower-right corner to the left or

to the right.
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This action time stretches the entire contents of the region equally, as follows:

• It compresses the audio material if you drag the region corner to the left.

• It expands the audio material if you drag the region corner to the right.

Snapping Flex Markers to Transient Markers
You can snap a flex marker’s position in one audio region to a transient marker’s position
in another audio region.

To snap a flex marker in one audio region to the transient marker in another audio
region

1 Click-hold the flex marker, and drag the mouse upward or downward over an adjacent
track.
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A yellow guideline appears in the other track region as you jump from transient to
transient.

2 Release the mouse button to snap the flex marker to the highlighted transient marker.

Splitting Audio Regions at Transient Marker Positions
You can split an audio region into multiple regions at its transient marker positions.

To split a region at transient marker positions
µ Control-click (or right-click) the region background, then choose Slice at Transient Markers

from the shortcut menu (or use the corresponding key command).

The selected region is split at every transient marker position.

Using the Flex Tool
You can use the Flex tool in the Arrange window’s Tool menu for quick access to basic
Flex Time editing functionality, without having to turn on Flex view using the View menu.

Note: If you try to use the Flex tool on a non-flex-enabled region, you are asked to choose
a flex mode for the region. Choosing a flex mode initiates a transient detection process
for any audio files that have not previously been analyzed.
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You can use the Flex tool for the following Flex Time editing activities:

To create flex markers and time stretch
Do one of the following:

µ Using the Flex tool, place the pointer over the region body, then drag when you see the
following pointer:

This creates three flex markers, as follows:

• On the transient marker

• On the previous transient marker

• On the following transient marker

The shaded area in the image shows the flex marker positions. You are compressing or
expanding the audio material between the middle flex marker and the other two.

Flex marker 
(on next transient)

Flex marker 
(on previous transient)

Flex marker (on transient)
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µ Using the Flex tool, place the pointer over the region body, then drag when you see the
following pointer:

This creates three flex markers, as follows:

• At the clicked position

• On the previous transient marker

• On the following transient marker

The shaded area in the image shows the flex marker positions. You are compressing or
expanding the audio material between the middle flex marker and the other two.

Flex marker 
(on next transient)

Flex marker 
(on previous transient)

Flex marker 
(at clicked position)
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µ Make a selection in the region with the Marquee tool, then drag it.

Flex marker 
(on next transient)

Flex marker 
(on previous transient)

Flex marker (at right 
marquee border)

Flex marker (at left 
marquee border)

This creates four flex markers, as follows:

• Two at the marquee borders

• Two outside the marquee selection at the previous and next transient positions

This allows you to edit the time position of the audio material between the first and
second flex markers or between the third and fourth flex markers. Nothing happens to
the audio material between the second and third flex markers.

To move a flex marker without time stretching
µ Hold down Option while dragging the flex marker.
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To time stretch using region borders
Do one of the following:

µ Drag the left or right edge of the region header.

µ Hold down Option while dragging the region’s lower-right corner.

Using Varispeed to Alter Playback Speed and Pitch
You can use the Varispeed mode to speed up or slow down a project between −50% and
+100%—which equals between 50% and 200% of the original tempo.

Note: Varispeed affects the entire project, not just the flex-enabled audio tracks.

Varispeed provides a way to speed up or slow down the entire project, similar to the
original varispeed feature of tape machines. The most practical use for this option is
checking how a project might sound at a faster or slower tempo, and for practicing and/or
recording a performance at a lower speed.
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To turn Varispeed mode on or off
µ Click the Varispeed button in the Transport bar (or use the Toggle Varispeed key

command).

When enabled, the Varispeed button and display glow orange.

Note: If you don’t see the Varispeed button and display, Control-click the Transport bar,
choose Customize Transport Bar from the shortcut menu, and select the Varispeed
checkbox in the Display section.

The Varispeed mode has the following controls:

• Varispeed button: Turns Varispeed mode on or off.

• Varispeed display and pop-up menu: The pop-up menu contains three Varispeed modes
and four options for the unit of measurement used to display the change in speed.
When you choose a mode, it appears in the top part of the display, and when you
choose a unit of measurement, it appears in the bottom part. You click the top part of
the display to open the pop-up menu, and you can drag the units in the bottom part
of the display to adjust them.

• Speed Only: Use this mode to pitch shift the master output signal to balance the
pitch change caused by varispeed. This mode changes only the speed, not the pitch.

• Varispeed (Speed and Pitch): Use this mode to emulate classic tape varispeed, where
the pitch changes to reflect the speed change.

• Varispeed and MIDI: This mode emulates classic tape varispeed and simultaneously
transposes non-drum MIDI tracks, quantized to semitones.

• Percentage: Displays the unit of measurement according to percentage.

• Resulting Tempo: Displays the resulting tempo, dependent on the current tempo,
which changes along with any tempo changes in the project. Note that the Tempo
display in the Transport bar always shows the original tempo value.

• Detune (Semitones.Cents): Displays the unit of measurement according to pitch
change.

• Tuning Reference (Hz): Displays the unit of measurement according to tuning reference.
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You can use the Arrange area or the Sample Editor to make incredibly fine adjustments
to audio files. In this chapter you will see why the Sample Editor is the ideal tool for
removing pops and clicks in audio material, setting accurate crossover points for looped
playback, correcting phase cancelation errors, and much more.

You will also take a look at transient markers, which denote significant points—or
transients—in an audio file. The audio on a track is analyzed for transients the first time
you enable that track for Flex Time editing. Any detected transients in the file are marked
with transient markers.

Finally, you will learn about some audio processing tools—collectively known as the
Digital Factory—that are unique to the Sample Editor. These include time stretching and
pitch shifting, audio quantization, and extraction of pitch and rhythmic information from
audio—which can be applied to other audio or MIDI parts.

Important: Most edits and functions performed in the Sample Editor are destructive. This
means the actual data of audio files is changed. Although you can undo edits and
processing commands, you should get into the habit of working on copies of your audio
files, rather than the originals. It’s better to be safe than sorry.

This chapter covers the following:

• Opening the Sample Editor (p. 548)

• Getting to Know the Sample Editor (p. 549)

• Playing Audio Files in the Sample Editor (p. 550)

• Navigating Audio Files in the Sample Editor (p. 553)

• Making Selections in the Sample Editor (p. 554)

• Audio Editing and Processing in the Sample Editor (p. 558)

• Adjusting the Project Tempo in the Sample Editor (p. 569)

• Using Sample Editor Loop Functions (p. 569)

• Undoing Edit Steps in the Sample Editor (p. 570)

• Creating Manual Backups in the Sample Editor (p. 570)
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• Customizing Waveform Amplitude Scale in the Sample Editor (p. 572)

• Customizing the Ruler in the Sample Editor (p. 572)

• Customizing Waveform Display in the Sample Editor (p. 574)

• Getting to Know the Sample Editor’s Digital Factory (p. 575)

• Using the Sample Editor’s “Time and Pitch Machine” (p. 576)

• Using the Sample Editor’s Groove Machine (p. 581)

• Using the Sample Editor’s Audio Energizer (p. 583)

• Using the Sample Editor’s Silencer (p. 586)

• Using the Sample Editor’s “Audio to Score” (p. 588)

• Using the Sample Editor’s Quantize Engine (p. 591)

• “Audio to MIDI Groove Template” (p. 593)

• Using an External Sample Editor (p. 593)

• Using AudioSuite Plug-ins (p. 595)

Opening the Sample Editor
There are several ways to open the Sample Editor in Logic Pro.

To open the Sample Editor as a pane in the Arrange window
Do one of the following:

µ Select an audio region in the Arrange area, then click the Sample Editor button at the
bottom of the Arrange window (or use the Toggle Sample Editor key command, default
assignment:  W).

µ Double-click an audio region in the Arrange area.

To open the Sample Editor as a separate window
Do one of the following:

µ Select an audio region in the Arrange area, then choose Window > Sample Editor (or use
the Open Sample Editor key command).
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µ Drag the Sample Editor button, which changes to the Sample Editor window as you drag
it.

Note: For the Sample Editor to always display the contents of the region selected in the
Arrange area, Content Link mode needs to be enabled. This is done by turning on the
Link button in the upper-left corner of the Sample Editor area or window.

Getting to Know the Sample Editor
This section provides an overview of the Sample Editor’s screen elements.

Waveform overview

Waveform display

Transient Editing Mode 
button

Playhead

Prelisten button

Cycle button Info display Ruler

Anchor

Amplitude scale

Region area

• Waveform overview: Displays a miniature view of the entire audio waveform.

549Chapter 17 Editing Audio in the Sample Editor



• Waveform display: Provides a detailed view of the waveform area selected in the
waveform overview.

• Transient Editing Mode button: Activates or deactivates Transient Editing mode. When
activated, the button glows orange and two further buttons appear to the right. It also
changes the default tool set for the Sample Editor.

• Prelisten button: Starts and stops playback.

• Cycle button: Loops playback of the selected area.

• Info display: Displays the start point and length of the selected area.

• Playhead: Reflects the current playback position.

• Region area: Indicates the length of the region. Edit this beam to adjust the region
length.

• Anchor: Indicates the absolute start point of the audio file.

• Amplitude scale: Indicates the amplitude of the audio waveform as a percentage or in
sample units.

• Ruler: Shows the position of the region in the arrangement. If you have not yet added
the audio file to the arrangement, the position marker lines are dotted, indicating no
time connection exists.

Playing Audio Files in the Sample Editor
This section outlines the various playback commands of the Sample Editor. Playback of
audio files in the Sample Editor occurs independently of the project playhead position.
With this in mind, you should simply use the Transport controls to hear the audio file in
the context of your arrangement.

Note: The Mixer’s Prelisten channel strip is used for monitoring in the Sample Editor. You
can access the Prelisten channel strip in the Environment Mixer layer. You can find it to
the right of the highest-numbered audio channel strip.

Using Basic Playback Commands in the Sample Editor
There are various ways to control audio playback in the Sample Editor.
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To control playback using the Prelisten button
1 Control-click (or right-click) the Prelisten button, and choose an option from the shortcut

menu:

• Auto-select Channel Strip: The audio channel strip assigned to the selected arrange track
is used for playback.

• Prelisten Channel Strip: The Environment’s Prelisten channel strip is used for playback.
You can access the Prelisten channel strip in the Environment’s Mixer layer. It is located
to the right of the highest numbered audio channel strip.

2 Click the Prelisten button (or use the Play/Stop Selection key command, default
assignment:  Space bar) to start playback.

3 Click the Prelisten button (or use the Play/Stop Selection key command, default
assignment:  Space bar) to stop playback.

To control playback using the ruler
µ Double-click the ruler at the point you want playback to begin. A second double-click

stops playback.

To control playback using the waveform overview
Do one of the following:

µ Click-hold at the point you want playback to begin. The pointer turns into a Prelisten icon.
Release the mouse button to stop playback.

µ Double-click at the point you want playback to begin. A second double-click stops
playback.

551Chapter 17 Editing Audio in the Sample Editor



To scrub audio
µ Click-hold the ruler and move the pointer.

The audio playback will follow the speed and direction of your pointer. This helps you to
quickly locate a particular position within an audio file.

To continuously repeat the selected area
1 Enable the Cycle button.

2 Enable the Prelisten button (or use the Play/Stop Selection key command, default
assignment:  Space bar).

You can change the start and end points of the selected area during looped playback.
This makes it easy to edit the start or end points of a drum loop, for example, until it loops
perfectly. When you’re satisfied with the loop, you can make the selected area a new
region.

Using Playback Key Commands in the Sample Editor
You can use the following key commands to enhance your playback options:

• Play/Stop All: Plays back the whole audio file, regardless of the selected area.

• Play/Stop Region: Toggles between playback of the audio file’s region start and end
points—regardless of the selected area.

• “Play/Stop Region to Anchor” and “Play/Stop Region from Anchor”: These key commands
allow you to check the region anchor position by listening to the parts just before and
after the anchor.
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Navigating Audio Files in the Sample Editor
The Sample Editor offers a number of navigation features that make it easy to move to
specific parts of an audio file—making selection and editing far simpler, faster, and more
accurate.

Clicking the waveform overview displays the selected area (surrounding the playhead
position) in the waveform display. The scroll bars and zoom controls are used in the same
way as in other windows.

Navigating to a Specific Position in an Audio File
The following commands enable you to quickly navigate to a specific position in an audio
file. They are available in the Sample Editor’s Edit menu, and as key commands.

• Go to Selection Start (or use the corresponding key command, default
assignment:  Control-Shift-Left Arrow)

• Go to Selection End (or use the corresponding key command, default
assignment:  Control-Shift-Right Arrow)

• Go to Region Start (or use the corresponding key command)

• Go to Region End (or use the corresponding key command)

• Go to Region Anchor (or use the corresponding key command, default
assignment:  Control-Down Arrow)

Navigating to the Loudest Point in an Audio File
The Sample Editor contains a feature that scans a selected audio file for its loudest point.
When it has located the loudest point, it positions the playhead at this point in the
waveform display.

To navigate to the loudest point in an audio file
µ Choose Functions > Search Peak (or use the corresponding key command, default

assignment:  Shift-P).

Navigating to Silent Passages in an Audio File
The Sample Editor contains a feature that scans a selected audio file, or a selection, for
sections containing silence. When it locates sections containing silence, it moves the
playhead to the start point of the first silent section.

To navigate to silent passages in an audio file
µ Choose Functions > Search Silence (or use the corresponding key command, default

assignment:  Shift-S).

This command can be used repeatedly to select and remove, or to modify, silent sections
in your audio files.
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Making Selections in the Sample Editor
Editing and processing audio in the Sample Editor is possible only after you select an
area within the waveform display. Any editing or processing you carry out will only affect
the selected area.

The start point and length of the current selected area are shown in the info
display—above the waveform overview. The format of the information is based on the
setting chosen in the View menu. For details, see Customizing the Ruler in the Sample
Editor.

Info display

For tips about how to accelerate selection, see Navigating to a Specific Position in an
Audio File.

Using Basic Selection Techniques in the Sample Editor
You can use basic selection techniques to select an entire audio file, or part of an audio
file, for editing purposes.

To select the entire audio file
µ Choose Edit > Select All (or use the corresponding key command, default

assignment:  Command-A).

554 Chapter 17 Editing Audio in the Sample Editor



To select a particular section of an audio file
µ Click-hold the start or end of the area you want to select in the waveform display, then

drag to the right or left.

The start point and length are displayed (as sample words) in a help tag while you make
your selection.

To extend an existing selection area
Do one of the following:

µ Choose Edit > Select All Previous (or use the corresponding key command).

µ Choose Edit > Select All Following (or use the corresponding key command).

To define the selected area using a region
1 Select a region in the Audio Bin or Arrange area.

2 Choose Edit > Region → Selection.

This function is useful if you want to reselect the entire region for cycled playback—after
performing a number of edits, for example.

The reverse can also be done, allowing you to redefine the length of an existing region
by choosing Edit > Selection → Region.

You can modify selections by changing their start or end points, or you can move the
entire selected area completely.

Note: If you choose Edit > “Snap Edits to Zero Crossings,” any length adjustments to
audio region start or end points will snap to the nearest zero-crossing point of the
waveform. For more information, see Snapping Edits to Zero Crossings.
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To change the start or end point of an existing selection
Do one of the following:

µ Shift-click in the waveform display to move the start or end point.

µ Shift-click-drag the start or end point of the selected area in the waveform display.

Using either method, the proximity of your click—to the start or end of the selected
area—determines whether you change the start or end point boundary. The closest one
wins …

Tip: If you hold down Option-Shift, the more distant selection boundary is changed (rather
than the nearer).

To move the selected area
µ Option-click (the pointer turns into a two-headed arrow), and drag to move the whole

selection, without changing its length.

Using Transient Markers to Make Sample Editor Selections
You can use transient markers to select part of an audio file for editing purposes.

Note: To do this, you first need to activate Transient Editing mode in the Sample Editor.
For details, see Using Transient Markers to Edit in the Sample Editor.
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To select a section of an audio file between two transient markers
µ Double-click the area of the waveform display between the two transient markers.

You can also use the following commands, available when you choose Edit > Set in the
Sample Editor:

• Selection Start To Previous Transient: The selection start is extended to the left, up to
the preceding transient marker.

• Selection Start To Next Transient: The selection start is shortened to the right, up to the
following transient marker.

• Selection End To Previous Transient: The selection end is shortened to the left, up to the
preceding transient marker.

• Selection End To Next Transient: The selection end is extended to the right, up to the
following transient marker.

• Selection Start and End to Previous Transient: The selection start and end are both moved
to the left, up to the preceding transient marker.

• Selection Start and End to Next Transient: The selection start and end are both moved
to the right, up to the following transient marker.

• Selection Start and End to Previous Transient and Play: The selection start and end are
both moved to the left, up to the preceding transient marker, then playback begins.

• Selection Start and End to Next Transient and Play: The selection start and end are both
moved to the right, up to the following transient marker, then playback begins.

• Region Anchor to Previous Transient: The region anchor is moved to the left, up to the
preceding transient marker.

• Region Anchor to Next Transient: The region anchor is moved to the right, up to the
following transient marker.
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Audio Editing and Processing in the Sample Editor
The following section covers the use of several standard audio editing and processing
commands or functions. For advanced audio processing options, see Getting to Know
the Sample Editor’s Digital Factory.

Most of the audio editing and processing activities in the Sample Editor are destructive.
Destructive activities modify the data of the original audio file, as opposed to just editing
its playback parameters. You do, however, have the possibility of using the Undo feature
(see Undoing Edit Steps in the Sample Editor).

Tip: While you can undo edits and processing commands, you should get into the habit
of working on copies of your audio files, rather than the originals. For details about creating
and restoring backups in the Sample Editor, see Creating Manual Backups in the Sample
Editor.

Using Edit Key Commands in the Sample Editor
You can use key commands to perform destructive sample editing functions. When doing
so, you will be asked to confirm your actions before making any changes and overwriting
the original audio file. You can, however, bypass this safety feature.

To disable the key command warning
µ Choose Logic Pro > Preferences > Audio > Sample Editor, and deselect the “Warning

before processing function by key command” checkbox.

Using Edit Commands in the Sample Editor
When you have selected an area of an audio file, you can use the usual Cut, Copy, Paste,
and Delete commands in the Edit menu to cut, copy, paste, or remove the selected area.

• Cut: Cuts a selected passage out of an audio file, and copies it to the Clipboard. All
following audio sections move forward—toward the start point of the audio file—to
fill the gap.

• Copy: Copies a selected passage to the Clipboard, leaving the selected area in its original
location. Unlike the other Edit menu commands, the Copy command is nondestructive.

• Paste: Inserts the contents of the Clipboard at the clicked position. All audio data that
follows the paste (insert) point is moved back—toward the end of the audio file—to
make room for the Clipboard contents.

Warning: Anything selected at the time of the paste is deleted—replaced by the
Clipboard contents.

• Delete: Erases the selection, without placing it in the Clipboard. All data beyond the
deleted passage is moved forward—toward the start point of the audio file—to fill the
gap.
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Using Transient Markers to Edit in the Sample Editor
You can use transient markers to edit selected areas of an audio file, or the entire file, in
the Sample Editor. For this you need to be in Transient Editing mode.

Note: When you are working in Transient Editing mode in the Sample Editor, the
Command-click tool changes default value, from the Hand tool to the Pencil tool.

To turn on Transient Editing mode
Do one of the following:

µ Choose Transient Editing Mode from the local View menu in the Sample Editor (or use
the Toggle Transient Editing Mode key command).

µ Click the Transient Editing Mode button in the Sample Editor.
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When you turn on Transient Editing mode, the audio file is analyzed for transient events,
and all detected transients are marked in the audio file.

Detected transients

The level of transient detection confidence is based on the clarity of the transients. If an
audio file does not have clear, sharp transients, transients will be detected with a lower
level of confidence. However, you can choose to display more or less transients using the
plus (+) and minus (−) buttons in the Sample Editor. These buttons are visible when you
are in Transient Editing mode.

• + button: Increases the number of transients in the selected area of the audio file, or
across the entire audio file. You can also use the “Increase Number of Transients” key
command, default assignment: Command-plus (+).
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• − button: Decreases the number of transients in the selected area of the audio file, or
across the entire audio file. You can also use the “Decrease Number of Transients” key
command, default assignment: Command-minus (−).

There may also be situations where you need to add or move transient markers within
audio files. The following explains how to create, move, delete, and detect transient
markers in the Sample Editor.

To create a transient marker in an audio file
µ Click the waveform display with the Pencil tool.

A transient detection process is started for the audio material around the clicked position,
and the transient with the highest energy becomes valid and is marked. If no transient
is found in the catch area, a transient marker is created at the clicked position.
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To move a transient marker in an audio file
µ Drag an existing transient marker to another position.

Note: The new position may or may not snap to zero crossings, depending on whether
“Snap Edits to Zero Crossings” is selected in the Edit menu. You can also Control-click (or
right-click) to open a shortcut menu and choose “Snap Edits to Zero Crossings.”

To delete transient markers from an audio file
Do one of the following:

µ Double-click individual markers with the Pointer or Pencil tool.

µ Click individual markers with the Eraser tool.

µ Drag over multiple markers with the Eraser tool.

µ Select an area of the audio file and press the Delete key.

This deletes all transient markers in the selected area.

Note: Transient markers are not actually deleted. Instead, their display threshold is set to
maximum, making them invalid. You can revalidate a transient marker using the plus (+)
button.

To detect transient markers in an audio file
µ Choose Audio File > Detect Transients (or use the “Detect Transients of Audio File” key

command).
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This detects transients across the audio file, overwriting (after you confirm the action)
any manually added or edited transients.

Note: You can also detect transients in factory audio Apple Loops. This saves a copy of
the audio Apple Loop to the project’s Audio Files folder.

Using the Pencil Tool to Edit in the Sample Editor
You can use the Pencil tool to correct clicks and pops in your audio, by drawing in the
waveform display.

You may find it useful to change the viewing mode of the waveform so that it shows the
data structure. For details, see Customizing Waveform Display in the Sample Editor.

To correct pops and clicks with the Pencil
1 Navigate to the desired section of the waveform.

Tip: Pops and clicks are often the loudest part of an audio file, so you may find the
Functions > Search Peak command useful when looking for them.

2 Use the zoom controls to magnify the section of the waveform that you want to correct.

3 Use the Pointer tool to scrub the audio around the pop or click.

This will help you to identify exactly where you need to draw.

4 Select the Pencil tool and drag from left to right (including up or down movements) to
draw in a new shape for the waveform spike.

The edges of drawn sections are automatically smoothed.

Press Option to affect both sides of stereo waveforms.
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As long as the mouse button is held down, the drawn waveform can be replaced by the
original waveform—by moving the pointer to the left.

Trimming Audio Files in the Sample Editor
The Trim function is used to edit areas of the audio file that are not selected.

You can use the Trim command to remove unimportant passages—generally
silence—from the start and end of your audio files. Trim can also be used to remove
portions of audio files that are not used by regions.

To erase all unselected portions of an audio file
µ Choose Functions > Trim (or use the corresponding key command, default

assignment:  Control-T).

Important: Make sure that the areas you are about to delete do not contain any regions
that you may need. Regions outside the selected area will be lost. Portions of regions
that fall partly outside the selected area are also removed, resulting in a length reduction
of the region. If any such regions are being used in the Arrange area, a warning dialog
will give you the option of canceling the trim command.

Silencing an Audio File Selection in the Sample Editor
You can use the Silence command to set all amplitude values to 0, rather than removing
(with Cut, Delete, or Trim) all data from the selected area of an audio file. This function is
generally used to silence unwanted background noise in quiet passages.

To silence the selected area of an audio file
µ Choose Functions > Silence (or use the corresponding key command, default

assignment:  Control-Delete).

Changing the Level of Audio Files in the Sample Editor
You can use the Change Gain command to change the level of an audio file. Typically
used on an entire audio file, this command can also be used to boost portions of it.

To raise or lower the level of the selected audio file (or area) by a specific amount
1 Choose Functions > Change Gain.
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2 Choose the desired settings in the Change Gain dialog:

• Set the required level change in the Change Relative fields by clicking the up or down
arrows in either field, or by directly typing values in either field. You can use the
percentage or decibel field to indicate the amount of increase or decrease you want.

• Click the Search Maximum button to search for the highest peak level. This automatically
sets a value that is used to alter the level of the audio file. The “Results in Absolute”
fields display the maximum level that will be achieved by changing the gain—by the
amount shown in the Change Relative fields.

3 Click Change to perform the gain change.

Important: You should never make a gain change that results in a value over 100%,
because this will result in digital clipping.

Normalizing Audio Files in the Sample Editor
Normalization is a process that raises the maximum level of a digital signal to a specified
amount—typically to its highest possible level without introducing distortion.

Tip: The start and end points for the section being normalized should generally not fall
within a continuous section of audio, as this will result in abrupt increases in volume after
normalization. The start and end points should therefore be located in sections that occur
just after, or before, musical gaps.

To normalize the selected area of an audio file
µ Choose Functions > Normalize (or use the corresponding key command, default

assignment:  Control-N).

Logic Pro locates the point with the highest volume in the selected area, and determines
how far this is from the maximum possible level. The level of the selected area is then
raised by this amount. The dynamic relationships of sample levels within the audio passage
remain unaltered.
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You can set the desired maximum level in the Function Settings window, which you can
open by choosing Functions > Settings (or by clicking the Settings button in the Normalize
dialog).

Set the desired maximum level (as a percentage or in decibels) in one of the “Peak at”
fields.

Tip: You should not choose 100% (0 dB) in these fields, as this may result in clipping
should you wish to increase the gain of the overall signal afterward, say with an EQ. A
good rule of thumb is to leave yourself at least 3-to-6 dB of headroom, to allow for further
audio processing tasks, such as mixing and effects processing.

These settings are automatically stored in Logic Pro preferences when Logic Pro is closed,
and they apply to all projects.

Fading Audio Files in the Sample Editor
You can destructively fade in or out on an entire audio file, or a selected area.

• Fade In: Volume is set to 0 at the start point of the selected area, and the fade-in occurs
over the length of the selection.

• Fade Out: Volume is set to 0 at the end point of the selected area, and the fade-out
occurs over the length of the selection.

The fade-in or fade-out time is determined by the selected area within the audio file.

To create a fade-in or fade-out
1 Use any of the selection techniques outlined earlier in the chapter to determine the length

of the fade-in or fade-out area.

2 Do one of the following:

• Choose Functions > Fade In (or use the corresponding key command, default
assignment:  Control-I) to create a fade-in.

• Choose Functions > Fade Out (or use the corresponding key command, default
assignment:  Control-O) to fade passages out automatically.
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Tip: If you use the Silence function (see Silencing an Audio File Selection in the Sample
Editor) to remove unwanted background noise from silent passages, small jumps in
volume can sometimes appear at the silence start and end points. If this happens, zoom
in and select a small area surrounding—just before and after—the start point of the
signal, and then use the fade-in function.

To adjust the fade curves
1 Open the Function Settings window by choosing Functions > Settings.

2 Edit the Curve value to change the shape of the fade-in or fade-out curve.

567Chapter 17 Editing Audio in the Sample Editor



3 Select the S Curve checkboxes if you want to create s-shaped curves.

These settings are automatically stored in Logic Pro preferences when Logic Pro is closed,
and they apply to all projects.

Tip: The Arrange window’s Fade tool offers a further, flexible, nondestructive fade option
(see Creating Crossfades and Fades on Audio Regions).

Reversing an Audio File Selection in the Sample Editor
The Reverse command is most commonly used on an entire audio file—to reverse a
cymbal sound, for example. It can also be used as a creative option on selected portions
of audio files. For example, the reverb tail at the end of a file can be reversed, copied, and
pasted to the beginning of the file.

To reverse the selected area of an audio file
µ Choose Functions > Reverse (or use the corresponding key command, default

assignment:  Shift-Control-R).

Reversing the Phase of an Audio File in the Sample Editor
You will find the Invert command extremely useful for correcting phase cancelation errors,
or when several out-of-tune signals (or several signals processed through chorus effects)
are to be mixed down to mono.

To reverse the phase of all selected audio material
µ Choose Functions > Invert (or use the corresponding key command).

All negative amplitude values become positive, and vice versa.

Note: This doesn’t audibly change the file, if heard in isolation.
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Tip: You can also use the Invert function to decode mono/stereo recordings, but it’s far
easier to use the Direction Mixer plug-in for this task. For more information about this
plug-in, see the Logic Pro Effects manual.

Removing DC Offsets in the Sample Editor
Some audio interface hardware can layer direct current (DC) over the audio signal. This
results in a vertical shift in the waveform position, which can be clearly seen in the Sample
Editor.

During playback, this can cause crackling sounds at the start and end of the audio region.

To center the waveform around the zero amplitude line
µ Choose Functions > Remove DC Offset.

Adjusting the Project Tempo in the Sample Editor
Just like automatic tempo matching functions in the Arrange area, the Functions > “Adjust
Tempo by Selection and Locators” command adjusts the project tempo, in accordance
with the current locator positions and selected area in the Sample Editor.

Although this operation is similar to the Arrange function (see Setting the Project Tempo
to Match an Audio Region), it applies only to the selected area of the audio file in the
Sample Editor, rather than to the overall length of the region.

Using Sample Editor Loop Functions
The Sample Editor Loop functions, available from the Edit menu, are ideal for use with
the EXS24 mkII sampler. For details about the EXS24 mkII, see the Logic Studio Instruments
manual.

You can also use these functions to generate audio files that contain the loop settings in
the file header. This allows you to make full use of these files in any application that can
read the loop information in the file header.

To use the Sample Editor Loop commands
1 Choose either of the following selection commands from the Edit menu:

• Sample Loop → Selection:  The loop area (defined by the loop start and end points) is
used to select a portion of the overall audio file.

• Selection → Sample Loop:  The selected area is used to set the loop start and end
points.

2 Choose Edit > Write Sample Loop to Audio File.

The new loop values will be written to the file header.
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Undoing Edit Steps in the Sample Editor
Most Sample Editor functions are destructive, changing the files stored on your hard
drive. You can, of course, use the Undo feature if things do not go your way.

To compare (or undo) your edits with the original audio file
µ Choose Edit > Undo (or use the corresponding key command, default

assignment:  Command-Z).

To cancel a destructive edit that is taking place
µ Press Command-Period.

The audio file will be retained in its original state, even if it appears that a portion of the
editing function has occurred.

You can configure the Sample Editor’s undo functionality in the Logic Pro > Preferences
> Audio > Sample Editor pane. For details, see Audio Sample Editor Preferences.

Creating Manual Backups in the Sample Editor
Although the Undo History and standard Undo functions are available, it’s good working
practice to create backups before processing or editing. This provides a safety copy of
your precious audio recordings should something unexpected happen, due to a processing
error or other unforeseen event.

You can make manual backups of the file you’re editing, or replace it with a backup
version at any time—using a variety of functions.

To duplicate the audio file you’re working on
µ Choose Audio File > Create Backup (or use the corresponding key command, default

assignment:  Control-B).

This creates a copy of the audio file (with the extension .dup) in the same folder as the
source file.

To revert to a backup file
µ Choose Audio File > “Revert to Backup” (or use the corresponding key command, default

assignment:  Control-Option-Command-B).

This function completely replaces the current audio file with the backup (provided one
exists, of course).

Important: You cannot reverse this function with Undo.

To save a copy with a different name—to the location of your choice
1 Choose Audio File > Save A Copy As.
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2 Choose the desired settings in the Save A Copy As dialog:

You can set the desired sample rate, bit depth, file format, stereo conversion, and dither
type for the destination file. The dialog also features an “Add resulting files to Bin” option,
allowing you to add the file to the Audio Bin, following the save.

3 Browse to the location (such as a hard drive and folder) that you want to store the audio
file in, then type a name for the audio file in the Save As field.

4 Click Save.

To save the selected area as a new audio file
µ Choose Audio File > Save Selection As (or use the corresponding key command, default

assignment:  Shift-Command-S).

The Save Selection As dialog includes the same file conversion choices as the Save A Copy
As dialog—and you can choose to add the file to the Audio Bin, following the save.
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Customizing Waveform Amplitude Scale in the Sample Editor
You can customize the waveform’s amplitude scale (plotted along the vertical axis) in the
Sample Editor, so that it is displayed in percentage units or sample units.

Percentage units Sample units

To display the amplitude scale in percentage units
µ Enable the View > Amplitude Percentage setting.

To display the amplitude scale in sample units
µ Enable the View > Amplitude Sample Value setting.

Tip: You can also open the amplitude scale shortcut menu by Control-clicking the
waveform amplitude scale itself.

Customizing the Ruler in the Sample Editor
The ruler in the Sample Editor can be displayed according to the following two modes:

• With reference to the time axis of the project (absolute mode)

• With reference to the beginning of the audio file (relative mode)

You can also customize the ruler so that it is displayed in samples, Min:Sec:Ms, SMPTE
Time, or Bars/Beats.

Switching the Ruler Between Absolute and Relative Mode
The scale units in the ruler are displayed with solid white lines when you view the time
scale according to its absolute position. When you view the time scale according to its
relative position, the scale units are dotted (indicating that no time connection exists).
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To enter relative display mode
Do one of the following:

µ Open the Sample Editor from the Audio Bin (double-click the region in the Audio Bin).

µ Click the Link button to activate Link mode in the Sample Editor, and select a region in
the Audio Bin.

The start position of the section is automatically assigned to the 0 value, or a value of 1
1 1 1 if set to Bars/Beats. The scale unit lines are dotted.

To enter absolute display mode
Do one of the following:

µ Open the Sample Editor from the Arrange window.

µ Activate Link mode in the Sample Editor, and select a region in the Arrange area.
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Time is measured from the start of the project, which is assigned a value of 0, or a value
of 1 1 1 1 if set to Bars/Beats. In this viewing mode, the absolute (project) time is shown
in the ruler.

Changing the Sample Editor Ruler’s Time Scale Display
Any changes you make to the ruler’s time scale display will also affect the info display.

To change the time scale
µ Choose one of the following scaling units from the View menu:

• Samples: Displays the number of sample words.

• Min:Sec:Ms: Displays the absolute scale in hours, minutes, seconds, and milliseconds.

• SMPTE Time: Displays the SMPTE scale in hours, minutes, seconds, and frames.

• Bars/Beats: Displays the scale in bars, beats, divisions, and ticks—just like the Bar ruler
in other windows.

Tip: You can also access these options via a shortcut menu by Control-clicking the ruler.

Customizing Waveform Display in the Sample Editor
You can switch the waveform from its usual representation to one that shows the structure
of the recorded digital data. This viewing mode is useful when you are eliminating clicks
and pops from your recordings, for example.

Normal waveform display
Waveform displayed as 
sample bits

To display the waveform as sample bits
µ Enable the View > “Show as Sample & Hold” setting.
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Note: You need to zoom the waveform display to high magnification levels for this to
work.

Getting to Know the Sample Editor’s Digital Factory
The Sample Editor has a number of audio processing tools, collectively known as the
Digital Factory .

The Digital Factory tools can be accessed through the Factory menu, which contains four
machine menu items in the upper part and three other items that are functions in the
lower part. When you choose a machine menu item, a window appears with tabs for the
four machines, and when you choose one of the three functions, a smaller window appears
with tabs for the three functions.

Machines Functions

Because each tool has its own tab, you can easily switch between machines or functions
by clicking the corresponding tab.

The Digital Factory tools have a number of common aspects, as follows:

• Digital Factory processes affect only the selected area of an audio file. The selected
area of the audio file is replaced with the processed audio material.

• You can play the audio file while a Factory process is taking place—which slightly slows
down processing. A progress bar is displayed during processing.
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Using the Sample Editor’s “Time and Pitch Machine”
You can use the “Time and Pitch Machine” to radically alter the time structure of audio
files, including time compression or expansion, and pitch transposition. When changing
the pitch, you can also correct any alteration of the formants—the vocal characteristics
of the pitch-shifted audio. Pitch shifting without formant correction causes a phenomenon
commonly known as the Mickey Mouse effect.

In the “Time and Pitch Machine,” time and pitch functions can be carried out together,
or can be performed independently of one another.

The Technology of the “Time and Pitch Machine”
The “Time and Pitch Machine” analyzes the spectral components and dynamics of the
digital audio material and processes the result. The algorithm endeavors to retain as
much spectral and dynamic information as possible, and minimizes phase variations.
In stereo files, the phase relationship between the left and right channels is fixed, and
not altered. Doubled sound events are kept to a minimum.

You should bear in mind, however, that apart from resampling (transposition), the “Time
and Pitch Machine” has to achieve the “physically impossible”:  When a sample is
lengthened, information needs to be invented. Equally, when a sample is shortened,
information has to be cut out. The process of lengthening is more difficult than
shortening, and if you have a choice, it’s better to speed up a drum loop than to slow
it down.

There’s always a small deviation between the set stretch factor and the actual result.
However, this deviation is only a few milliseconds or fractions of a bpm. Also, because
the absolute deviation is independent of the length of the processed section, it is no
greater in longer files.

Opening the Sample Editor’s “Time and Pitch Machine”
You need to select an area within an audio file before you can open the “Time and Pitch
Machine.”

To open the “Time and Pitch Machine”
1 Select the area of the audio region in the Sample Editor that you want to process through

the “Time and Pitch Machine.”

2 Choose Factory > “Time and Pitch Machine” (or use the corresponding key command,
default assignment:  Control-P).
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The “Time and Pitch Machine” contains Mode and Algorithm, Tempo, and Pitch parameters.

Mode and Algorithm

Tempo parameters

Pitch parameters

You don’t need to enter, or adjust, all of the “Time and Pitch Machine” parameters. Most
are linked, so an adjustment to the Tempo parameter will result in changes to the Length
values, and vice versa.

Setting Mode and Algorithm in the “Time and Pitch Machine”
The “Time and Pitch Machine’s” Mode and Algorithm menus define the operating mode
and algorithm used when performing the time stretch or pitch shift.

• Mode menu: You can choose between Free and Classic in the Mode menu.

• Free: In Free mode (the more common mode setting), you can make all pitch and
tempo adjustments independently of one another.

• Classic: In Classic mode, pitch and tempo are linked, so transposing a selected region
also affects its tempo. The resulting effect simulates the sound of changing tape
speed. The pitch increases as the tape speeds up, and it decreases as the tape slows
down.
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• Algorithm menu: You can choose the algorithm that is best suited to the audio material
you want to process:

• Version 5: Inherited from Logic 5, this algorithm can be used on most types of audio
material. It imparts a particular color on processed audio, which may be a useful
creative option.

• Any Material: Is able to handle most types of audio material.

• Monophonic: A specialized algorithm for monophonic material—an individual voice,
or brass or woodwind instrument, for example.

• Pads: Use on polyphonic material with harmonic content—choirs or string sections
are good examples.

• Rhythmic Material: Use on rhythmic material—can be drums and percussion, but
less obviously rhythm guitar, clavinet, and piano comp parts.

• Beats Only: Perfectly maintains the timing of percussive material. This algorithm
should be your first choice for all kinds of dry drum loops.

• Universal (default): This high-quality algorithm is able to handle any kind of audio
material and is generally recommended for most time-stretching tasks. The following
two algorithms can, however, deliver better results in cases where the audio material
exactly matches the outlined specifications.

• Complex: Choose this algorithm to obtain natural-sounding results when
time-stretching complex musical material—orchestral music or final mixes.

• Percussive: Perfectly maintains the timing of rhythmic material, making it a good
choice for drum loops and percussive, nonharmonic signals. In comparison to the
Beats Only algorithm, the Percussive algorithm is better suited for percussive material
that has been processed through a reverb (or contains a long tail). This may also
apply to percussive playing styles, such as staccato electric piano or clavinet parts.
Beats Only may be the better alternative for dry drum recordings.

Support of Third-Party Algorithms
Logic Pro allows you to access the pitch shift and time stretch algorithms of the following
third-party plug-ins in the “Time and Pitch Machine”:

• Serato:  Pitch ’n Time LE

• iZotope:  Radius

Note: These algorithms can be accessed in the “Time and Pitch Machine” only if the
corresponding Audio Unit plug-ins are installed and authorized on your system.
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Setting Tempo Parameters in the “Time and Pitch Machine”
The Tempo section is divided into two columns:  The Original column displays the current
values of the selected area in the audio file, and the Destination column is where you set
the desired tempo parameters.

• Tempo Change: Determines the tempo alteration, displayed as a percentage (no original
value is shown).

• Tempo: Displays the tempo in bpm (beats per minute). Make sure to set the right
length in bars, or the correct original tempo will not be shown on the left.

• Length in Samples: Displays the length of the selected area in samples.

• Length in SMPTE: Displays the length of the selected area in SMPTE time format.

• Length in Bars: Displays the length of the selected area in musical values (bars, beats,
divisions, and ticks). If you have already adjusted the project tempo to match the region
that you’re about to edit, the original value will automatically be set correctly. If not,
you need to manually enter the original length here.

Setting Pitch Parameters in the “Time and Pitch Machine”
The pitch parameters determine the amount of transposition in cents, and also the
strength of harmonic correction, if used.

• Transposition: Transposition of the sound material in 1/100 semitone units (cents). A
value of 100 results in an upward transposition by one semitone. A value of −1200
results in the audio material being transposed down an octave.
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• Harmonic Correction: When audio is transposed, not only is the fundamental pitch
transposed, but all of the formants are shifted as well—as though the whole instrument
or singer is being reduced or enlarged. This, of course, is not natural. Voices transposed
up will sound like Mickey Mouse, or like Darth Vader if transposed down. These artifacts
can be circumvented by using Harmonic Correction.

Select the Harmonic Correction checkbox to leave the formants in the transposed
material unchanged. This means that the original timbre (or the physical size of the
resonance body) is maintained, resulting in a more natural-sounding transposition. The
only trade-off is that calculation takes more time.

Note: The quality of Harmonic Correction is heavily dependent on the source material,
because the algorithm has to make intelligent decisions between tonal and atonal
components of the recording, and handle them separately. This is not an exact science
and is more accurate on monophonic material than on complex stereo material, but
you can certainly use it on a complete mix. The phase correlation of stereo recordings
is maintained.

You can also use Harmonic Correction to shift the formants without transposition. In
this way, you alter the physical size of the sound source’s resonance body—to give
female voices a male character and vice versa, for example—while keeping the pitch
in tune.

This effect (sometimes known as gender-bending) allows you to change sounds so
that they appear to have been made by unusually small or large instruments. It is useful
for beefing up thin or brittle sounding parts, such as guitars, or instruments and vocals
that were recorded through a microphone with a limited frequency response.

As a usage example on a vocal part:  If you set Harmonic Shift to −300, and the
Transposition value to 0, the sonic character of the singer will be changed as though
transposed three semitones down—but without an actual transposition in pitch. This
means that a musical C remains a C, but the timbre of the vocal becomes darker.

• Harmonic: If Harmonic Correction is turned on, you can also use the Harmonic (Shift)
parameter to independently alter timbre. The units are shown in 1/100 semitone units
(cents).

• If you select the same value in both the Harmonic and Transposition fields, no
correction occurs, and the result is as if Harmonic Correction is turned off.

• If you set Harmonic to 0, the formants don’t change. This prevents the unwanted
side effects of traditional pitch shift algorithms.

Tip: If you need to find the exact transpose value by trial and error, turn off Harmonic
Correction. As soon as you’ve found the right transposition value, do an independent
Harmonic Correction, with the same value, in a second step.
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Using the Sample Editor’s Groove Machine
You can use the Groove Machine to alter the feel, swing, or groove of digital audio material,
in percentage steps. In other words, this tool can quantize straight audio!

You can also strictly quantize audio that “grooves a little too much” with the Quantize
Engine (see Using the Sample Editor’s Quantize Engine).

Opening the Sample Editor’s Groove Machine
You need to select an area within an audio file before you can open the Groove Machine.

Important: Before you open the Groove Machine you should ensure that the tempo of
Logic Pro exactly matches that of the selected audio material, or the Groove Machine
won’t work accurately. You can, however, set the tempo and length directly in the Groove
Machine, using the “Corresponds with Tempo” and To Bar Length parameters.

To open the Groove Machine
1 Select the area of the audio region in the Sample Editor that you want to process through

the Groove Machine.

2 Choose Factory > Groove Machine (or use the corresponding key command).

Note: Any changes you make to the settings will be reflected in the graphical display.
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Setting Groove Machine Parameters
Here are the parameters in the Groove Machine:

• Swing: Sets the swing factor. At 50% there is no change—you generally achieve the
best results with values around 55% to 65%.

• Based on Period: You can determine whether the audio material should be quantized
on the basis of 1/8-note, or 1/16-note swing.

• Down Beat Level and Off Beat Level: Determine whether the down beats, or off beats,
in the audio material should be raised or lowered. Positive values increase the level,
and negative values reduce the level. Bear in mind that raising the level of normalized
audio material can cause distortions—particularly on the down beats, which are usually
louder.

• Corresponds with Tempo: If you change this value, you will set the project tempo at the
current playhead position.

• To Bar Length: Defines the length of the selected audio material in musical values—bars,
beats, divisions, and ticks.
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Using the Sample Editor’s Audio Energizer
You can use the Audio Energizer to increase the perceived volume of audio material while
altering the sound as little as possible, and without causing clipping. Digital distortion,
which would be the inevitable result of simply increasing the level, is prevented when
you use this algorithm.

You could compare the effect to an analog tape that has been saturated with a high
recording level. The distortion factor and effect on the audio material is much lower than
that of analog tape saturation, however.

For example, consider that you have processed a normalized audio file (audio data which
is already at the maximum dynamic range) using the Audio Energizer, and you are playing
it back through an audio channel strip. The channel strip’s meter will show a higher level,
indicating increased average energy in the signal, but the peak level display will not
change. This demonstrates that the maximum signal level has not been altered.

Note: If the material contains anomalies such as noise, these will also be increased and
can become audible. If necessary, you can process the energized audio file with the
Silencer—make sure to use a low setting—or use the Denoiser effect plug-in.

Opening the Sample Editor’s Audio Energizer
You need to select an area within an audio file before you can open the Audio Energizer.

To open the Audio Energizer
1 Select the area of the audio region in the Sample Editor that you want to process through

the Audio Energizer.
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2 Choose Factory > Audio Energizer (or use the corresponding key command).
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Setting Audio Energizer Parameters
Here are the parameters in the Audio Energizer:

• Factor: Sets the amount of average level boost. A value of 0% means no alteration,
while higher values produce an increase in energy. The setting you make here will
depend on the audio material, situation, and personal taste.

• Begin by trying values in the 40% to 100% range.

• Values below 10% will have little effect.

• Values over 100% can lead to undesirable alterations in the sound, depending on
the material.

• Values over 200% are not recommended with normalized files, because they will
have detrimental effects on the sound and its dynamics. They can also greatly increase
the required computation time. On non-normalized audio data, however, even high
values can be effective because the overall level is initially increased to its maximum,
without affecting the dynamic range.

• Attack and Decay: These parameters control the steepness of the algorithm’s filter. Try
values of 2-to-4 times the default, if the result sounds too digital or raw. This can happen
if smaller elements among the main events in the signal are boosted. For example, the
reverb portion of a sound can become louder.
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Using the Sample Editor’s Silencer
You can use the Silencer to perform two different functions, either separately or together.
These are:

• Spike Reduction: Identifies, and reduces, signals such as pops and clicks.

• Noise Reduction: Lowers the level of any noise in the signal, such as tape noise.

The Silencer function is optimized for normalized data. Low-level material should be
normalized before processing.

Tip: Don’t forget that pops and clicks can also be manually removed using the Pencil
tool, if the Silencer doesn’t produce satisfactory results (see Using the Pencil Tool to Edit
in the Sample Editor).

Opening the Sample Editor’s Silencer
You need to select an area within an audio file before you can open the Silencer.

To open the Silencer
1 Select the area of the audio region in the Sample Editor that you want to process through

the Silencer.

2 Choose Factory > Silencer (or use the corresponding key command).

Spike Reduction

Noise Reduction
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Applying Spike Reduction in the Silencer
The aim of Spike Reduction is to identify and reduce signals such as pops, clicks, or digital
spikes, in order to reconstruct a hypothetical original signal. You use the following
parameters to do this.

Note: When you are applying Spike Reduction, it is recommended that you turn off the
Noise Reduction function. This ensures that only the Spike Reduction function is used.

• Sensitivity slider: Determines the threshold level used for the recognition of spikes in
the audio file.

• Off: No edits will occur.

• Auto: Threshold is controlled automatically.

• Low: Most signal peaks are identified as spikes.

• High: Relatively small signal spikes are identified.

Note: You may need to experiment with the parameters. If the Sensitivity slider is set
to High (or close to it), there’s a danger that very sharp transients in the main signal
will be identified as spikes. Depending on the audio material, it’s sometimes impossible
for the Silencer to distinguish between signals you want to keep and signals you want
to eliminate. This is particularly the case if the decision between spike or main signal
is merely a matter of taste—with some click-like bass drum sounds, for example. The
attack phase of these sounds can have similar characteristics to static on vinyl records.

• Method slider: Determines how the identified spike points in the original signal are
processed.

• Gentle: Weakest algorithm, only slightly smoothing the original signal.

• Aggressive: Strongest algorithm, with a very noticeable impact on the audio.

• Re-build: Replaces the (often unusable) original signal with an artificially generated
estimate of the original signal, at the identified points. This synthesized signal is
created by analyzing the audio material surrounding these points.

Applying Noise Reduction in the Silencer
The purpose of Noise Reduction is to reduce the noise components of the signal, and
also to affect the main signal, particularly the high frequency elements.
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The process of Noise Reduction is single-ended, meaning it affects material that is already
recorded, and there is no need to decode the signal during playback. Even noise present
in the original signal can be processed.

Note: When you are applying Noise Reduction, it is recommended that you turn off the
Spike Reduction function. This ensures that only the Noise Reduction function is used.

• Strength slider: Determines the strength of the reduction level used on noise in the
audio file.

• Off: No edits will occur.

• Min: Smallest possible edit, with values closer to Min having a small effect.

• Max: Maximum possible reduction of the noise component.

Note: The “correct” value depends on the quality of the material, and your own personal
taste. Good-quality material should be edited using Min, or values close to it. You will
probably notice only minor changes in the sound. Bad-quality (noisy) material should
be processed at higher values, or even Max. If the setting is too high, the treble
component of the signal will be reduced.

Using the Sample Editor’s “Audio to Score”
You can use “Audio to Score” to transform a monophonic audio recording into musical
notation by creating a MIDI region that corresponds to the recorded melody.

Note: Good results can be achieved using clearly identifiable, monophonic audio material.
This function is best-suited to producing melody notes from a clearly sung non-legato
vocal line. It works best on unprocessed audio—that is, audio without effects.
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Opening the Sample Editor’s “Audio to Score”
You need to select an area within an audio file before you can open “Audio to Score.”

To open “Audio to Score”
1 Select the destination MIDI or software instrument track in the Arrange area.

The MIDI region generated by the “Audio to Score” function will be placed on this track.

2 Select the area of the audio region in the Sample Editor that you want to process through
“Audio to Score.”

3 Choose Factory > “Audio to Score” (or use the corresponding key command, default
assignment:  Control-S).
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Setting “Audio to Score” Parameters
Here are the parameters in Audio to Score. You may need to experiment with different
parameter values, and even make several attempts to determine the optimum settings
for a particular audio recording.

• Preset: Contains various presets for “Audio to Score” parameters, which are suited to
specific types of audio material. In addition to 11 presets, there are also 4 User presets.

• Granulation: Determines the time span of louder components in the audio material.
Logic Pro uses these peak signals (or transients) to discriminate between notes that it
should—or should not—analyze. The most useful values are usually between 50 and
200 ms, depending on the tempo of the audio material.

• Attack Range: Determines a suitable attack phase length for the audio material. For
example, drum and percussion instruments have short attack times (less than 20 ms),
whereas string instruments have longer attack phases. The best values for most
instruments are usually between 5 and 40 ms, with most around 20 ms.

• Smooth Release: Specifically designed to process audio material that contains sounds
with a long release or reverb tail. This makes it easier to convert these sounds to notes.
The value you choose here should generally be between 0% and 5%, except when you
are processing passages that contain sustained notes, distorted guitars, or similar
sounds.

Note: The quality of “Audio to Score” results will benefit from non-legato performances.
Therefore, you should try to avoid reverb or release tails in your audio material, or at
least keep them to a minimum.
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• Velocity Threshold: Sets the threshold level. All signals that fall below this value are
ignored. In most cases, you should choose a value of 1, except when processing very
dense, loud material with soft background noises.

• Minimum Quality: You can choose between normal and high-quality processing:

• Normal: Is more tolerant of audio trigger points that aren’t perfectly in tune, but it
can generate wrong notes.

• High: Accepts and uses only audio trigger points of a clearly identifiable pitch.
Indistinct trigger points are replaced by notes with a pitch of C3 and MIDI channel
3. These are labeled as an “undetected mark.”

When analyzing audio material that contains clearly identifiable pitches, you will find
that good results can be obtained using either setting.

• Time Correction: Compensates for any time delays that may occur when external
samplers or synthesizers are triggered by MIDI notes. These time delays are sometimes
very noticeable, particularly if the connected device is playing a MIDI region that was
generated by the “Audio to Score” function alongside the original audio material. You
should be able to compensate for this effect by using settings between −20 ms and
0 ms.

Using the Sample Editor’s Quantize Engine
You can use the Quantize Engine to quantize an audio recording, using a dynamic time
compression or expansion algorithm.

The function is similar to using the Groove Machine, except that the quantize template
can reflect values other than just 1/8-note or 1/16-note swing grooves. Even user-defined
MIDI grooves can be used.

Opening the Sample Editor’s Quantize Engine
You need to select an area within an audio file before you can open the Quantize Engine.

To use the Quantize Engine on an audio region
1 Select the area of the audio region in the Sample Editor that you want to process through

the Quantize Engine.
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2 Choose Factory > Quantize Engine (or use the corresponding key command, default
assignment:  Control-Q).

Setting Quantize Engine Parameters
The parameters in the Quantize Engine are almost identical to those in “Audio to Score”
(see Setting “Audio to Score” Parameters). This section describes only the parameters that
differ from the “Audio to Score” function.

• Preset: Choose a preset that best matches the characteristics of your audio material.
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• Quantize by: Open this pop-up menu to choose the required quantization grid. The
same values available for MIDI data (including user quantization templates) are found
here.

• Maximum Range: Sets the maximum time (in milliseconds) that an audio peak can
deviate from a quantization point—in the chosen quantization grid template (in the
“Quantize by” pop-up menu).

• Small values are suitable for quantizing audio material with a similar groove.

• Large values allow you to use a quantization grid that deviates more from the original
groove of the audio material. This, however, increases the risk of misinterpretation.

Start by experimenting with smaller values for the Maximum Range parameter—as
small as possible, and as large as necessary.

“Audio to MIDI Groove Template”
For information about the “Audio to MIDI Groove Template” function, see Creating an
Audio-to-MIDI Groove Template.

Using an External Sample Editor
You can configure Logic Pro to open an audio region or file in an external sample editing
application.

To use an external sample editing application
1 Open Audio Preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Audio from the pop-up
menu.
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2 Click the Sample Editor tab, then click the Set button below the External Sample Editor
section.

A dialog opens where you can find and select an external sample editing program.

To open a selected audio file in the external sample editor
µ Choose Options > Audio > “Open in [external sample editor]” (or use the corresponding

key command).

The external sample editor opens, allowing you to perform edits on the audio file.

To transfer audio edited in the external sample editor back to Logic Pro
µ Save the file in the external sample editor, then switch back to Logic Pro.

The edited audio will be updated in the Audio Bin and Arrange area, if regions based on
the audio file are in use.
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Using AudioSuite Plug-ins
The Sample Editor allows the use of AudioSuite plug-ins. These plug-ins work
destructively—the result of the editing process is written into the audio file.

Note: AudioSuite plug-ins can be used only with hardware addressed by the DAE
(Digidesign Audio Engine). Any properly installed AudioSuite plug-in will be displayed in
the AudioSuite menu.

When you choose AudioSuite > Buffer Size, you can set the buffer size of the Preview
mode. A smaller buffer size results in a faster response to plug-in setting changes while
previewing, but it requires more processing power.
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The length of imported audio regions and the project tempo are directly linked. If you
change the tempo at a particular project position, the length of regions at, and after, this
position changes. You won’t hear a difference in the playback speed of the imported
audio, but all MIDI or software instrument regions will be out-of-sync with all audio
regions. Audio regions that are lengthened (by increasing the tempo) may overlap with
other regions on the same track, resulting in the earlier region being played in full at the
expense of the beginning of the following region. All audio region loop lengths (set with
the Inspector Loop parameter) change, resulting in irregular loops and strange polyrhythms
between tracks. Fortunately, you can circumvent these problems with Logic Pro.

This chapter covers the following:

• Automatic Tempo Matching (p. 597)

• Setting the Project Tempo to Match an Audio Region (p. 599)

• Time Stretching Regions (p. 601)

• Using Beat Detection to Create Tempo Changes (p. 603)

• Importing, Removing, and Exporting Tempo Information (p. 605)

Automatic Tempo Matching
The following audio files automatically match the project tempo and will follow any
tempo changes made in the global Tempo track.

• Audio recordings made in Logic Pro (7.0 and later)

For example, if you record a bass solo at 100 bpm, you can change the project tempo
to 120 bpm and the bass solo automatically plays back at the new tempo.

Note: The function only works in the parent project (the project the audio files were
created in). If you drag a file recorded in a given project to another project using the
Finder, the file cannot follow the project tempo. However, files copied between two
projects are able to follow the project tempo.

• Apple Loops files

• Audio bounces made in Logic Pro (7.0 and later)
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Note: Bounced files can only follow the project tempo if the “Add resulting files to
Audio Bin” option was selected in the Bounce dialog, prior to the bounce or export.

• Audio files exported from Logic Pro (7.0 and later)

Note: Exported files can only follow the project tempo if the “Add resulting files to
Audio Bin” option was selected in the Export dialog, prior to the bounce or export.

Imported ReCycle files can also follow the project tempo. (See Adding ReCycle Files to
Your Project.)

Audio files that follow the project tempo (and first key signature) are flagged with the
Follow Tempo symbol, both in the Arrange area and in the Audio Bin tab.

Follow Tempo symbol Follow Tempo symbol

All other imported audio requires adjustment of either the region or the project tempo.

To make recorded audio files follow the project tempo (and first key signature)
µ Select the audio region in the Arrange area, and select the Follow Tempo option in the

Inspector’s Region Parameter box.

The Follow Tempo option is synchronized for all regions that make use of the same audio
file.
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Note: The Follow Tempo option does not create an Apple Loops file. Apple Loops follow
chord changes; if you record a solo over an arrangement consisting of Apple Loops with
transposition changes over time, you might want to select Follow Tempo for your solo,
but you won’t be happy with the double transpositions that will occur.

You also have the option of converting imported audio to Apple Loops.

To convert a selected audio region into an Apple Loops file
Do one of the following:

µ Choose Region > Add to Apple Loops Library in the Arrange area.

This method sets transients that are based on the project’s tempo information.

µ Choose Audio > Open in Apple Loops Utility in the Arrange area.

This method allows you to set the transients manually—independent of the project
tempo.

For more information about creating Apple Loops, see Creating Apple Loops in Logic Pro
and Creating Apple Loops in the Apple Loops Utility.

Setting the Project Tempo to Match an Audio Region
You can adjust your project’s tempo to match the tempo of an audio region. The length
of the region remains constant, but the project tempo is varied automatically.

Imagine you have imported a drum loop that does not match your project tempo.
Originally one-bar long, the drum loop adapts to your project tempo, becoming shorter
or longer than one bar. You can use the Adjust Tempo using Region Length and Locators
command to set the project tempo to match the original tempo of the drum loop.

To match the project tempo to an audio region
1 Select the audio region that you want to match the project tempo to, in the Arrange area.

2 Control-click (or right-click) the Cycle button in the Transport bar, and make sure the Auto
Set Locators by Region Selection option is not selected.

3 Set the left and right locator positions in the Bar ruler.
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The locator range should closely match the length of the region—usually to the nearest
bar.

4 Choose Options > Tempo > Adjust Tempo using Region Length and Locators (or use the
corresponding key command, default assignment:  Command-T).

A dialog asks if you want to change the tempo of the entire project, or create a tempo
change for the section of the project occupied by the selected region.

5 Do one of the following:

• Click Globally to adjust the tempo of the complete project to the audio region.

• Click Create to create a tempo change that spans the length of the audio region.

The project tempo is recalculated to conform with the audio length (and locators).
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Time Stretching Regions
Logic Pro allows you to time stretch audio regions directly in the Arrange area, using
menu or key commands. Time stretching an audio region changes its tempo and length,
but not its pitch.

When applying these functions to a region in the Arrange area, a new file—reflecting the
tempo and length changes—is created, leaving the original intact. Both new and old files
are accessible in the Audio Bin.

Logic Pro offers different time stretching and compression algorithms in the Arrange
area’s Audio > Time Stretching Algorithm menu. The different algorithms are best-suited
for particular types of musical material. For more information, see Using the Sample
Editor’s “Time and Pitch Machine.

Note: You can also time stretch selected audio regions directly in the Sample Editor, using
the Time and Pitch Machine.

To adjust the region length to match the locator positions
1 Select the audio region that you want to time stretch.

2 Control-click (or right-click) the Cycle button in the Transport bar, and make sure the Auto
Set Locators by Region Selection option is not selected.

3 Set the left and right locator positions in the Bar ruler.
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4 Choose Audio > Time Stretch Region to Locators to expand or compress the selected
audio region to fit between the locators.

The region start point is not changed by this function, so it doesn’t matter if the locators
are not directly above the region.

To adjust the region length to the nearest bar
µ Choose Audio > Time Stretch Region to Nearest Bar.

This command adjusts the length of the selected region to the closest whole bar.

This function is ideal for fitting previously trimmed drum loops into projects in which
there is a small tempo discrepancy between loop and project.
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Using Beat Detection to Create Tempo Changes
You can use beat detection to find the average tempo of one or multiple selected audio
or MIDI regions. The beat detection process detects a maximum of five tempi across the
region(s), providing an indication, from high to low, of the reliability of each estimate.
The most reliable value—at the top of the list—is selected by default. It is possible to
modify this average tempo value using a multiplier, divisor, or decimal rounding. You
also use this algorithm to decide how and where to apply the tempo change.

To adjust the tempo to the average of a region, or regions
1 Select one or more regions in the Arrange area.

2 Choose Options > Tempo > Adjust Tempo using Beat Detection from the main menu bar
(or use the corresponding key command).

603Chapter 18 Working with Tempo and Audio Regions



The selected regions are analyzed; the results appear in a dialog that looks something
like the following.

3 Set the following parameters, as required.

• Create Tempo Change radio button group: You have the following three options when
creating the tempo change.

• Globally: Uses the resulting tempo across the project.

• At Selection Start and End: Uses the resulting tempo up to the region selection end
point, then changes back to the previously valid tempo.

• At Selection Start Only: Uses the resulting tempo up to any previously existing tempo
change that follows the region selection end point, or to the project end if no tempo
changes exist.

• Nudge Regions to Beat checkbox: Select this checkbox to nudge the regions equally
until the first transient of the first region falls precisely on a whole beat of the Bar ruler.
The nudge direction is either left or right, whichever results in the smaller movement
range.
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4 Click the Advanced Options disclosure triangle and set the following parameters, as
required:

• Adjust Value By sliders: Define a ratio (multiplier and divisor) for the selected detection
result. A ratio of 2:1 multiplies the value by two, while a ratio of 1:2 divides the value
by two.

• Rounding pop-up menu: Choose one of the following rounding values:  Integer, 1
Decimal, 2 Decimals, 3 Decimals, or Off. This value is used to modify the Resulting
Tempo value.

5 Click the Prelisten button to preview playback using the Resulting Tempo value.

6 Click OK to perform the tempo adjustment (according to the above settings), or Cancel
to cancel the procedure.

Importing, Removing, and Exporting Tempo Information
When you record or bounce an audio file, the current Tempo List is added to the file. You
can then use the saved tempo information for importing or exporting purposes.

In some situations, you may want to import tempo information from an audio file that
was recorded in a different project. The tempo of the selected audio file is used in place
of the project tempo, but only within the borders (start and end points) of that file in the
Arrange area.

To import tempo information from an audio file
µ Choose Options > Tempo > Import Tempo Information from Audio File in the main menu

bar.

You can also export the current tempo value within the borders (start and end points) of
a selected audio file in the Arrange area. However, you should first remove any tempo
information that exists in the audio file.
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To remove tempo information from an audio file
µ Choose Options > Tempo > Remove Tempo Information from Audio File in the main

menu bar.

Then you can export the current tempo information to the audio file.

To export tempo information to an audio file
µ Choose Options > Tempo > Export Tempo Information to Audio File in the main menu

bar.

As an example: Imagine the situation where you have an audio recording that wasn’t
recorded to a metronome click, and therefore contains slight tempo variations. How do
you get this audio recording to follow the tempo of your current project? Your first step
is to beat map the track to make the display of the free recording rhythmically meaningful
(see Beat Mapping Audio Regions). Your next step is to remove the tempo information
from the audio file (see above). As a final step, export the current project tempo
information to the audio file (see above).
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You can use the Strip Silence function to automatically remove silent passages from audio
regions. The basic premise of the Strip Silence process is simple:  all amplitude values
below a threshold value are interpreted as silence, and removed. New regions are created
from the remaining passages. This process takes place in the Strip Silence window.

This chapter covers the following:

• Opening the Strip Silence Window (p. 607)

• Getting to Know the Strip Silence Window (p. 608)

• Removing Silent Passages from a Selected Region (p. 609)

• Automatic Anchor Creation (p. 610)

• Understanding How You Can Use Strip Silence (p. 610)

Opening the Strip Silence Window
There are several ways to open the Strip Silence window in Logic Pro.

To open the Strip Silence window from the Arrange area
1 Select an audio region.

2 Choose Audio > Strip Silence (or use the Strip Silence key command, default
assignment:  Control-X).

To open the Strip Silence window from the Audio Bin window
1 Select an audio region.

2 Choose Options > Strip Silence (or use the Strip Silence key command, default
assignment:  Control-X).
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Getting to Know the Strip Silence Window
The main parameters of the Strip Silence window are as follows:

• Threshold: Use to define the amplitude level that a passage must exceed, in order to
be defined as a region. In terms of the number and length of regions created by the
process, this is the most important parameter. As a general rule:  a higher Threshold
value leads to numerous short regions. Low values create fewer large regions.

• Minimum Time to accept as Silence: Use to define the length of time that a section must
be below the Threshold value, before it is considered a gap. Very small values tend to
increase the number of regions, because even short dips in amplitude are interpreted
as silence. Higher values prevent sections of audio from being interrupted by fluctuating
amplitudes.

• Pre Attack Time: Use to add a defined amount of pre-roll to the beginning of all regions
created by the Strip Silence process. High threshold values prevent any amplitudes
with slower attack times from being chopped. This function is useful for nonpercussive
material such as vocals, wind instruments, strings, and so on. Overlaps are
permitted—the pre-delayed start point of a region can extend back to the end of the
previous region—but only if the Threshold value is not exceeded. The Pre Attack Time
doesn’t affect the anchor position, which means the absolute position of the audio
data (in the project) is retained.

• Post Release Time: Use to define an automatic release time for the end points of all
regions, avoiding abrupt cutoffs to amplitudes that fade out gradually (particularly if
you have set a high Threshold value); for example, cymbals, open hi-hats, snares with
long reverb tails, vocals, and so on. This parameter does not allow overlaps. This means
that region end points cannot extend beyond the start point of the following region.
The Post Release Time doesn’t affect the anchor position, which means the absolute
position of the audio data (in the project) is retained.
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• Search Zero Crossings: Select this checkbox to automatically snap the region start and
end points to the nearest waveform zero crossings.

Removing Silent Passages from a Selected Region
This section outlines the steps involved in the Strip Silence process. For full details about
the parameters, see Getting to Know the Strip Silence Window.

To remove silent passages from a selected region
1 Set the parameters in the Strip Silence window by using the mouse as a slider, entering

numerical values directly, or clicking the up and down arrows.

Note: Depending on the audio material, all parameters can have an effect on the number
and division of regions. You may need to experiment a little to obtain favorable results.
Every time you alter a parameter, the graphic display of the region changes accordingly.

2 Click OK.

If you selected a region that is used in the Arrange area, a dialog asks if you want to
replace the original region in the Arrange area with the new regions.

3 Do one of the following:

• If you want to replace the region in the Arrange area with regions created by the Strip
Silence function, click Replace or press Return. This ensures that the relative timing of
the individual audio segments remains unaltered.

• If you only want the new regions to appear in the Audio Bin, click No. You can then
add them to the Arrange window, using any of the methods available.
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Automatic Anchor Creation
When you create new regions with Strip Silence, a separate anchor—based on the division
value set in the Transport (1/16, 1/8, and so on)—is automatically created for each new
region.

These rounded anchor values are shown in the help tag when you move any of the newly
created regions, rather than an absolute anchor point that is placed at a particular sample
position.

If you require this sort of precision, open the regions in the Sample Editor, and adjust the
anchor point manually.

Understanding How You Can Use Strip Silence
Strip Silence is the ideal tool for the following tasks:

• Using Strip Silence to Remove Background Noises

• Using Strip Silence to Create Segments of Spoken Recordings

• Using Strip Silence to Create Segments for Drum Loops

• Using Strip Silence to Optimize Synchronization

• Using Strip Silence to Optimize Files and Regions

• Using Strip Silence to Extract Audio Files from a Disc

Using Strip Silence to Remove Background Noises
The most conventional use for Strip Silence is simulation of the classic noise gate effect.
When used on long recordings with numerous gaps—such as vocals or instrumental
solos—you can obtain better results by setting a low threshold value. Background noise
is removed, without affecting the main signal.

• For short percussive regions (drum loops), you can simulate time compression/expansion
by simply altering the tempo.

• You can even quantize the individual segments in an audio recording.

Using Strip Silence to Create Segments of Spoken Recordings
You can use Strip Silence to divide long spoken passages into several convenient segments,
like sentences, words, or syllables. For film synchronization or jingles, you can move or
reposition the speech segments by simply dragging them around in the Arrange area.

Tempo changes allow you to simulate a time compression or expansion effect, as the
syllables automatically move closer together, or farther apart.
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Using Strip Silence to Create Segments for Drum Loops
Dividing drum loops into small segments is a good way of perfectly synchronizing them.
For example, in audio passages where the bass drum and snare are completely separate,
you can often use Strip Silence to isolate each individual beat.

Using Strip Silence to Optimize Synchronization
Different computers, different synchronization sources (internal or SMPTE code), different
tape machines and—in theory—different samplers or hard disk recording systems will
exhibit slight variations in clock speed. Changing just one component can lead to a loss
of synchronization between recorded audio material and MIDI. This is particularly
applicable to long audio regions.

This is another situation where the Strip Silence function can help, by creating several
shorter audio regions, with more trigger points between the audio and MIDI events.

For example, you can use this method to roughly split up a whole audio file, and then
divide the new regions, using different parameters. The new regions can then be processed
again with the Strip Silence function—and so on.

Using Strip Silence to Optimize Files and Regions
You can use Strip Silence to automatically create regions from an audio file that contains
silent passages, such as a single vocal take that runs the length of a project. The unused
regions or portions of the audio file can be deleted, saving hard disk space, and simplifying
(file and) region management.

Using Strip Silence to Extract Audio Files from a Disc
Many sample library discs (CD or DVD) contain thousands of audio recordings stored as
AIFF or WAV files. Strip Silence can be used to split these into individual regions, which
can be used directly in the Arrange area. Regions can also be converted into individual
audio files (samples), which can be used in the EXS24 mkII.
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This chapter describes all audio file management functions available in Logic Pro. While
several individual file management functions are found in the Sample Editor and the
Arrange window, most audio file management takes place in the Audio Bin. These options
help you to keep track of your audio files, and make tasks such as file copying, moving,
renaming, and backing up both easy and efficient.

Details on audio region handling are found in Adding Prerecorded Media and Creating
Your Arrangement.

This chapter covers the following:

• Sorting, Grouping, and Renaming Files in the Audio Bin (p. 613)

• Moving Audio Files (p. 620)

• Copying or Converting Audio Files (p. 621)

• Deleting Audio Files (p. 623)

• Optimizing Audio Files (p. 623)

• Converting Regions into Independent Audio Files (p. 624)

• Exporting Tracks as Audio Files (p. 625)

• Exporting or Importing Region Information (p. 625)

• Finding and Replacing Orphaned Audio Files (p. 625)

Sorting, Grouping, and Renaming Files in the Audio Bin
The Audio Bin lists all audio files in your project, along with information about file sampling
rate, bit depth, format (mono/stereo), and size. It is the ideal place to sort, rename, copy,
or move your audio files.

Note: Detailed information on the methods used to add audio files to the Audio Bin (and
your project) are found in Adding and Removing Audio Files.
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Sorting Audio Files
Information on every currently loaded audio file is shown in the Info column of the Audio
Bin. You can switch this display on or off by choosing View > Show File Info.

To sort audio files
µ Choose any of the following View > “Files sorted by” criteria to reorganize the listing of

audio files:

• None: The audio files are listed in the order that they were loaded or recorded.

• Name: The audio files are listed in alphabetical order.

• Size: The audio files are listed by size, with larger files at the top of the list.

• Drive: The audio files are sorted by storage medium (the hard disk, removable drive,
or partition they are stored on).

• Bit Depth: The audio files are listed by it depth, in decreasing order.

• File type: The audio files are listed by file type (AIFF, WAV, SDII, MP3, and so on).

Tip: You can quickly sort all audio files by name by clicking the Name column header.
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Grouping Files in the Audio Bin
You can group audio files together, making handling of large numbers of files easier and
faster. In the following image, you see a Guitars and Vocals group, with several files in
each.

Guitars group

Vocals group

Separating files into categories simplifies handling, particularly if all files are similarly
named. For example, audio imported from another application may be named “audio01,”
“audio02,” “audio03,” and so on, regardless of whether a vocal, guitar, or drum part. When
creating a large arrangement, grouping files into categories can be a life-saver.

To group audio files
1 Select the files you want to group in the Audio Bin.
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2 Choose View > Create Group (or Control-click the Audio Bin or use the corresponding
key command).

3 Type a group name in the Group Name field (labeled “Enter name for new group”), then
press Return.

To group audio files by their location, attributes, or selection status
1 Select the files you want to group in the Audio Bin.

2 Do one of the following:

• Choose View > Group Files by > Location to create groups that are alphabetically sorted
by the names of the parent folders of selected files. These folder names are automatically
used as group names.

• Choose View > Group Files by > File Attributes to create groups based on the attributes
of selected files (file type, stereo/mono, bit depth). Group names are displayed as a
summary of the file attributes (“16 bit AIFF Stereo,” for example).

• Choose View > Group Files by > Selection In Arrange to create groups based on regions
selected in the Arrange area. Group names are based on the first of the selected regions.

Note: If existing groups have been created, a dialog asks if you want to add all files to
one of these groupings, thereby deleting the existing groups, or if you only want to add
files that are not yet group members. Click the appropriate button.
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To open or close one or more groups
Do one of the following:

µ Click the disclosure triangle to the left of a group name.

This expands or collapses the clicked group.

µ Option-click the disclosure triangle to the left of any group name.
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This expands or collapses all groups, including the audio files in the Option-clicked group.

To open or close all audio files in a group
µ Option-click the disclosure triangle to the left of any audio file within a group.
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This expands or collapses all audio files in the Option-clicked group, without affecting
other groups.

To select all files in a group
µ Option-click a group name to select all files in the group.

To delete a group
µ Select a group, then choose View > Delete Selected Groups (or press Delete).

The audio files of deleted groups reappear in the upper level of the Audio Bin list.

Renaming Audio Files
To rename audio files in the Audio Bin, double-click the filename in the list. A text input
box appears, allowing you to type in a new name.

Important: Before renaming audio files, you should check to see if the audio file that you
want to rename is used by another project. If it is, do not rename the file, or it won’t be
found or played by other projects that use the file.

Logic Pro helps you in these situations:

• Logic Pro alters the name of an audio file in all currently opened projects that use the
file.
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• If the file is half of a split stereo pair, Logic Pro automatically assigns the new name to
the other half of the stereo pair.

• Logic Pro also renames any backup files on the same disk drive.

If you rename a stereo file, Logic Pro automatically assigns the new name to up to five
files (the mono files used in Logic Pro, their backups, and the stereo file). In this situation,
it’s a good idea to store all files in the same location.

Note: You can freely rename regions whenever you like, but you should note that regions
named after their parent audio files automatically adopt the new name of renamed audio
files. This does not occur when regions have been given a new name.

Moving Audio Files
The Audio Bin’s Audio File > Move File(s) command (default key command
assignment:  Control-M) allows you to move selected audio files to another location on
your system.

If the source disk drive or partition is the same as the target drive or partition, the files
are simply moved to the other folder. This is a very quick and convenient way of organizing
the drive and the project.

This function is useful when you want to move all audio files used in a project to a new
folder, for example.

Tip: It may be useful to choose the Audio File > Show File(s) in Finder command (also
available by Control-clicking the Audio Bin or using the corresponding key command)
before moving any audio files. This command opens a Finder window that displays the
path and location of the selected files. The folder name or notes, or other files in the
folder, may provide clues as to whether or not it’s safe to move the files. If you’re not
sure, it’s better to use the Copy/Convert command (see Copying or Converting Audio
Files).

To move all used audio files to a new folder
1 Choose Edit > Select Used from the Edit menu.

This selects all audio files (in the Audio Bin) that are being used in the Arrange area.

2 Choose Audio File > Move File(s) in the Audio Bin menu.

An alert indicates the number of files to be moved.

3 Click the Move button.

4 In the dialog that appears, select a folder (or create a new one), then click Save. All audio
files used in the Arrange area are saved in the selected folder.

620 Chapter 20 Managing Audio Files



Logic Pro updates the path information for all open projects that use a given audio file.
This makes projects easier to manage when moving audio files. After you move files to
a new location, save each open project to update all audio file storage references.

Warning: Be very careful when using this function as files are removed from their original
location. Other projects may use the same audio files. This can lead to you being
prompted to search for the files that were moved when opening other projects (see
Finding and Replacing Orphaned Audio Files).

Copying or Converting Audio Files
You can create copies of audio files in a different hard disk (or other storage medium)
location. The source files remain in their original storage location (unlike the behavior
when the Move File(s) function is used).

To copy or convert audio files in the Audio Bin
1 Select the file or files.

Note: You cannot use this command to convert compressed multi-channel files (AAC,
ALAC, MP3).

2 Choose Audio File > Copy/Convert File(s) in the Audio Bin (or Control-click the Audio Bin
or use the corresponding key command).
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3 Choose settings in the “Copy/convert file as” dialog:

You can set the sample rate, bit depth, file format, stereo conversion, and dither type for
the destination file.

4 Browse to and choose the target folder for the new audio files. You can also create a new
folder, by clicking the New Folder button.

5 If you’re only copying one file, you can enter a name for the new audio file. When
simultaneously copying several audio files, existing filenames are used for the copies
derived from them. The Hide Extension checkbox hides or shows file extensions (.wav,
.aif, and so on) in the Save As field.

6 Click the “Change file reference in Bin” option to replace the audio file used in the project
with the copied file.

If unselected, both the copy and original audio file are shown in the Audio Bin (the original
is still used for any regions).

7 Click the Save button.
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Note: If a file of the same name exists in the target location, Logic Pro asks whether or
not you want to replace it. Click Replace to do so, or type in a different name, and click
Save.

To copy or convert audio files in the Sample Editor
1 Choose Audio File > Save A Copy As.

2 Choose settings in the Save A Copy As dialog.

You can set the sample rate, bit depth, file format, stereo conversion, and dither type for
the destination file. The dialog also features an “Add resulting files to Audio Bin” option,
allowing you to add the file to the Audio Bin, following the save.

3 Browse to the location where you want to store the audio file, then type a name for the
audio file in the name field.

4 Click the Save button.

Deleting Audio Files
Audio files are displayed and organized by Mac OS X in exactly the same way as all other
Mac files. You can therefore delete or copy them in the Finder. This has the following
disadvantages, however:

• You may not know if an audio file is needed in a project when using the Finder for
deletions.

• Deleted audio files cannot be found when you load a project. This results in orphaned
files (and regions) in the Audio Bin and Arrange area regions which refer to the missing
audio file (see Finding and Replacing Orphaned Audio Files).

Important: For these reasons, you should only perform audio file deletions in the Audio
Bin.

To delete audio files in the Audio Bin
1 Select the audio files that you want to delete.

2 Choose Audio File > Delete File(s) (or use the corresponding key command, default
assignment:  Control-Delete).

An alert message, informing you of the number of audio files about to be deleted, appears.

3 Click Cancel to abandon the deletion process, or click Delete to move the audio files into
the Trash.

Optimizing Audio Files
Beyond deleting unused audio files, Logic Pro also allows you to delete unused portions
of audio files. This usually frees up a lot of wasted space on the hard disk.
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To delete sections of audio files that are no longer used in the project
1 Select the audio files that you want to optimize in the Audio Bin.

The Edit > Select Used menu should be your first option. Optimize Files can be used on
any number of audio files.

2 Choose Audio File > Optimize Files (or use the corresponding key command, default
assignment:  Control-O) in the Audio Bin.

The following happens during the Optimize Files function:

• Logic Pro determines which (file) segments are not contained in any of the regions
used in the Arrange area.

• These segments are deleted, and the remaining portions of the audio file (those used
by regions) are retained. These file segments are aligned side-by-side in the file.

Note: For safety reasons, the Optimize Files function uses a pre- and post-roll area of
one second of audio data before and after each (used) region.

• The regions in the Audio Bin are redefined.

• The project is automatically saved.

Warning: As this process physically deletes data from the storage medium, it cannot
be undone.

Converting Regions into Independent Audio Files
You can create one (or more) independent audio files from selected regions in the Audio
Bin and Arrange area.

To convert selected regions into independent audio files
1 Do one of the following:

• Choose Audio File > Save Region(s) As in the Audio Bin.

• Choose Audio > Convert Regions to New Audio Files in the Arrange area (or use the
corresponding key command, default assignment:  Option-Command-F).

• Choose File > Export > Region as Audio File in the main menu bar (or use the
corresponding key command).

2 Choose settings in the dialogs that appear.

3 Browse to and choose the target folder for the new audio files. You can also create a new
folder, by clicking the New Folder button.

4 If you’re only saving one region, you can enter a name for the new audio file. The Hide
Extension checkbox hides or shows file extensions (.wav, .aif, and so on) in the Save As
field.

5 Click the Save button.
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Note: If you want to simultaneously save several regions as audio files, you should name
the regions before using the Save Region(s) as command, as existing region names are
applied to the audio files derived from them.

Exporting Tracks as Audio Files
It is also possible to export one or more tracks (all audio regions on tracks) to a new audio
file, or several audio files—one for each arrange track. For full details about these features,
see Exporting Individual or Multiple Tracks as Audio Files.

Exporting or Importing Region Information
The Audio Bin provides an overview of regions that are derived from individual audio
files. Logic Pro allows you to export this region information into the audio file, which you
can then choose to import if using the audio file in another project. This function works
with SDII, CAF, Wave, and AIFF audio file formats.

To export region information to an audio file
1 Select the audio file in the Bin.

2 Choose Audio File > Export Region Information (or use the corresponding key command,
default assignment:  Control-E).

The current region information for that audio file in the Bin is saved in the audio file. Any
existing region information is overwritten.

If using an audio file with saved region information in another project, you have the
possibility to import the region information into the project.

To import region information from an audio file
1 Add the audio file to another project.

2 Select the audio file in the Bin.

3 Choose Audio File > Import Region Information (or use the corresponding key command,
default assignment:  Control-I).

The saved region information for that audio file is displayed in the Bin. You can use this
information by dragging the regions into the Arrange area.

Finding and Replacing Orphaned Audio Files
Sometimes, Logic Pro can’t find a file that was previously used in the project. This could
be due to one of the following:

• You have not connected the relevant hard disk, or you have renamed the volume.

• You have stored the files in a different volume, or moved them to another volume.
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• You have renamed the files in the Finder, or renamed them in the Audio Bin of another
project.

• You have deleted the files.

In these situations, Logic Pro opens a dialog similar to this one:

You can respond in any of the following ways:

• Skip All: Click this button if you know that more than one audio file no longer exists,
or was renamed. Otherwise, you need to use the Skip button for each individual
missing/renamed file.

• Skip: Click this button if you know that the audio file no longer exists, or was renamed.

• Search: Click this button to make a search in the current volume. If the search is
unsuccessful, Logic Pro provides a file not found dialog.

• Locate: Click this button to manually define where to search for the file. A dialog,
containing the name of the audio file being searched for in the title bar, appears
onscreen.

If more than one file with a matching name is found, you can select the correct file in a
dialog.

If Logic Pro cannot find one or more audio files, the regions are shown as blank areas.

To assign a replacement file later
1 Do one of the following:

• Double-click the relevant region in the Arrange area.
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• Double-click the exclamation mark beside the audio filename in the Audio Bin tab.

• Choose Audio File > Update File Information in the Audio Bin.

2 Click Locate in the dialog, and another dialog opens (containing the name of the audio
file being searched for in the title bar), allowing you to locate and load the necessary
audio file.
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Quantization is the rhythmic correction of audio or MIDI to a specific time grid. Any
inaccurately played audio material—centered around transient markers—or MIDI notes
are moved to the nearest position on this grid, as shown below.

1 32 4 1 2 3 4

1 32 4 1 2 3 4

Unquantized note events

Quantized note events, aligned to the nearest beat position

This chapter covers the following:

• Understanding Region- and Event-based Quantization (p. 630)

• Understanding the Quantize Grid Options (p. 630)

• Fine-Tuning the Quantize Grid Options (p. 631)

• Quantizing Audio or MIDI Regions (p. 633)

• Quantizing Phase-Locked Audio Tracks (p. 635)

• Quantizing MIDI Regions Permanently (p. 637)

• Quantizing MIDI Events (p. 638)

• Working with Groove Templates (p. 640)
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Understanding Region- and Event-based Quantization
Region-based quantization is a process that affects all transient markers in an audio region
or all note events in a MIDI region. You have the choice of quantizing audio or MIDI
regions, or a mixed selection of audio and MIDI regions.

Note: Region-based quantization does not work on other MIDI data event types, such as
MIDI controllers.

Event-based quantization is the quantization of individual MIDI events (not only note
events) within a MIDI region. This is performed in the MIDI editors.

Important: Event-based quantization destructively alters the position of all MIDI event
types, except note events.

You can also create groove templates, which are quantization grids based on the rhythms
of other audio or MIDI regions.

Understanding the Quantize Grid Options
You can quantize selected audio or MIDI regions, including a selection of both, by changing
the value of the Quantize parameter in the Region Parameter box of the Inspector. This
parameter determines the division of the quantization grid.

Important: The region Quantize parameter is nondestructive. It adjusts the playback
positions of notes in the region on-the-fly when Logic Pro is in Playback or Record mode.
It does not actually move the notes permanently.

The settings in the Quantize pop-up menu in the Region Parameter box of the Inspector
can be roughly grouped into the following categories:

• Mixed quantization: The 8 & 12 setting corresponds to eighths and eighth triplets, 16 &
12 to sixteenths and eighth triplets, and 16 & 24 to sixteenths and sixteenth triplets.
Mixed quantization always applies to both note values, and requires greater playing
precision when recording.

• Odd quantization: The 9-Tuplet setting denotes novetuplets (1 bar = 9 beats), 7- Tuplet
is septuplets (1 bar = 7 beats), 5-Tuplet/4 is quarter quintuplets (1 bar = 5 beats), and
5-Tuplet/8 is eighth quintuplets (1 bar = 10 beats).
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• Swing quantization: The 8F Swing, 8E Swing, 8D Swing, 8C Swing, 8B Swing, 8A Swing,
and 16F-to-16A Swing settings delay the position of every second point in the
quantization grid by a fixed percentage. The 8 or 16 denotes an eighth- or sixteenth-note
quantize value. You can also manually alter the swing factor of any quantize value.

• Quantization off: The off (3840) setting plays the notes at the finest possible timing
resolution:  1/3840 note, which is unquantized playback, in practical terms.

• Normal quantization: The 1/1-Note, 1/2-Note, 1/4-Note, 1/8-Note, 1/16-Note, 1/32-Note,
and 1/64-Note settings quantize the MIDI region to the equivalent note value.

• Triplet quantization: The 1/3-Note, 1/6-Note, 1/12-Note, 1/24-Note, 1/48-Note, and
1/96-Note settings quantize the MIDI region to triplet note values. A 1/6 note is
equivalent to a quarter triplet, 1/12 note to an eighth triplet, 1/24 note to a sixteenth
triplet, and 1/48 note to a thirty-second triplet.

The Swing settings delay the position of every second point in the quantization grid by
a fixed percentage, as follows:

Swing percentageQuantize setting

71%8F Swing or 16F Swing

66%8E Swing or 16E Swing

62%8D Swing or 16D Swing

58%8C Swing or 16C Swing

54%8B Swing or 16B Swing

50%8A Swing or 16A Swing

Fine-Tuning the Quantize Grid Options
You can use the Q-Swing field and the advanced quantization parameters in the Region
Parameter box to fine-tune your quantization grid. These provide a number of additional
features that allow you to create and apply a swing or other quantize feel to your MIDI
and software instrument parts.
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The Q-Swing field is located just below the Quantize pop-up menu, and the rest of the
quantization options listed below are in the Advanced Quantization section. They can be
applied to any quantization value (except “off”).

Audio region advanced 
quantization parameters

MIDI region advanced 
quantization parameters

Q-Swing parameterQ-Swing parameter

Note: Not all advanced quantization parameters are available for audio regions.

• Q-Swing: Alters the position of every second point in the current quantization grid.
Values over 50% delay the beats; values under 50% pre-delay them. The most practical
settings fall between 50% and 75%, imparting a swing feel to strictly quantized (or
tightly played) regions.

• Q-Strength: Determines how far a note or transient marker is shifted toward the nearest
grid position. A value of 100% results in full quantization, and 0% leaves the note or
transient marker at its recorded position.

• Q-Range: A very musical quantization strategy that requires a certain amount of technical
musical prowess. Q-Range is ideal for recordings that already have the right groove
but are too hurried or laid back in places. It allows you to retain the original feel, but
positions the rhythmic center precisely in the groove. A value of 0 means that every
note or transient marker is quantized. If you enter negative Q-Range values, only notes
or transient markers that fall outside the set range are moved to ideal quantization grid
positions, whereas those closer to an ideal position remain unquantized. This moves
the most poorly played notes or transient markers—those outside the range—to perfect
timing positions on the quantization grid, or at least moves them toward these positions,
depending on the Q-Strength setting.
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Tip: To obtain the best Q-Range results, use a low, even quantize value, such as 1/4
note. Set the Q-Range parameter to compensate for the maximum error in the recording.

• Q-Flam: Spreads out notes with the same time position—chords. Positive values produce
an ascending (upward) arpeggio, negative values a descending (downward) arpeggio.
The position of the first note—either the bottom or top note, assuming that all notes
start at the same position—in the arpeggio is unaltered.

• Q-Velocity: Determines the amount that the velocity values of quantized notes are
affected by the velocity values of a template MIDI region. At a value of 0%, the notes
retain their original velocity. At 100%, they adopt the velocity values of the template.
Negative values alter the velocity, making the deviation from the template even greater.

• Q-Length: Determines how the lengths of quantized notes are affected by the equivalent
note lengths—notes at the same position—of a template MIDI region. A value of 0%
has no effect, whereas at 100% the notes adopt the exact note lengths of the template
region. Negative values alter note lengths further, resulting in a more significant
deviation from the template.

Quantizing Audio or MIDI Regions
You can quantize audio or MIDI regions, or a mixed selection of audio and MIDI regions.

Note: In order to use quantization on an audio region, you need to assign a flex mode
to the parent audio track, and select the Flex parameter in the Region Parameter box for
that region. For details, see Choosing Flex Modes.

To change the quantization grid division for selected audio and/or MIDI regions
µ Choose a value from the Quantize pop-up menu in the Inspector’s Region Parameter box.

You can also step through the available Quantize values, one at a time, with the “Set
Quantize Parameter to Next Value” and “Set Quantize Parameter to Previous Value” key
commands.

You can do this at any time, including when Logic Pro is in Playback or Record mode. The
new value is immediately used to alter note playback positions.
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You can also quantize sections of the same audio or MIDI region differently.

To quantize various parts of a region differently
1 Divide the region with the Scissors tool, and then use different quantization settings on

each segment—each new region.

2 Recombine the segments of the original region with the Glue tool.

This maintains the quantize values of each segment.

When you quantize audio, white lines are automatically added to the selected audio
regions. These white lines are called quantize flex markers—or simply quantize
markers—and their function is to correct the playback positions of transient markers
according to the setting chosen from the Quantize pop-up menu.

The quantization grid always begins at the start of a MIDI region. If the MIDI region does
not start at the beginning of a bar, neither does the quantization grid. If you alter the
start point of a MIDI region, you also alter the quantization grid.
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Important: Unlike other region playback parameters (Delay, Transposition, and so on),
the value chosen from the Quantize pop-up menu affects the way notes are displayed
in the MIDI editors. Thus you can see the effect of the chosen Quantize value by looking
at the note positions in the Piano Roll Editor, for example.

Quantized MIDI eventsUnquantized MIDI events

Region quantization affects the whole audio or MIDI region. An alternate method for MIDI
regions is to perform event-level quantization in the MIDI editing windows (see Quantizing
MIDI Events).

Quantizing Phase-Locked Audio Tracks
You can apply phase-locked quantization to audio regions on grouped tracks while
maintaining phase accuracy among the tracks. All transients in audio regions of grouped
tracks are taken into account and a quantize marker is added for the first transient in each
transient cluster. These quantize markers are then used to apply the chosen quantization
scheme to all regions.

Important: For phase-locked audio quantization to be possible, all audio regions on
grouped audio tracks must have the same start and end positions.

You first need to group the required audio tracks and enable them for phase-locked
editing. It’s advisable to do this before you record the tracks, but you can do this afterward
if necessary. However, you need to create the group before you start editing the tracks.

To create a group of audio tracks and enable that group for phase-locked editing
1 Select multiple audio channel strips in the Mixer.

2 Click the Group slot of one of the selected channel strips, and choose an unused group
from the pop-up menu.

This opens the Group Settings window.
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3 In the Group Settings window, select the Editing (Selection) checkbox, followed by the
Phase-Locked Audio checkbox.

The group is now enabled for phase-locked editing.

4 Close the Group Settings window.

When you enable a group of audio tracks for phase-locked editing, a Q button appears
in the track header of each track in the group. This button serves the same purpose as
the Q-Reference checkbox in the Inspector’s Track Parameter box. By turning on a Q
button, all regions on that track contribute their transients as reference points during the
quantization process. By turning off a Q button, you exclude all regions on that track from
contributing their transients as reference points during the quantization process.

To quantize a group of phase-locked audio tracks
1 Display Flex view in the Arrange area by doing one of the following:

• Choose View > Flex View in the Arrange area’s local View menu (or use the Hide/Show
Flex View key command).

• Click the Flex View button in the Arrange toolbar (if visible).

This displays the Flex Mode button in the track header of each audio track in the Arrange
area.

2 Set a flex mode for the grouped tracks by doing one of the following:

• Click the Flex Mode pop-up menu in the arrange track list, then choose the relevant
mode.

• Open the Flex Mode pop-up menu in the Track Parameter box, then choose the relevant
mode.

Your chosen flex mode is assigned to each of the grouped tracks. All audio files on these
tracks are analyzed for transients, adding a transient marker for each detected transient.

Tip: For the best results during the following steps, zoom in on the relevant regions.

3 Open one of the tracks you want to use as Q-reference in the Sample Editor, then check
the transients to make sure they are positioned correctly. You can add or remove transients,
or move incorrectly placed transients, in the Sample Editor. For details, see Using Transient
Markers to Edit in the Sample Editor.

4 Repeat step 3 for any other tracks you want to use as Q-reference.

Note: It’s not necessary to adjust the transients for tracks that are not used as Q-reference.
The timing of these tracks will be adjusted with sample accuracy based on the transients
in the Q-referenced tracks.

5 In the track header of the Arrange area, click the Q button for the tracks to be used as
Q-reference.
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This triggers a process where quantize markers are automatically placed on top of the
existing transient markers. You can easily differentiate between quantize markers and
normal flex markers, as quantize markers don’t have an orange handle at the top.

6 Remove tracks that shouldn’t be referenced for quantization by doing one of the following:

• Turn off the Q button in the track header.

• Select the track, and deselect the Q-Reference checkbox in the Inspector’s Track
Parameter box.

Although these tracks are still phase-locked with the other members of the group, their
transient markers will not be taken into account during the quantization process.

All tracks that are part of the edit group that have their Q button turned on will contribute
their transients for audio quantization. At this point, the position of the quantize markers
is the same in all tracks—meaning that the quantization will be phase-locked.

7 To complete the quantization process, open the Quantize pop-up menu in the Inspector’s
Region Parameter box, and choose a Quantize value.

Quantizing MIDI Regions Permanently
In the same way that other region parameters can be normalized, the quantization settings
can also be applied permanently to one or more regions. The Apply Quantization Settings
Destructively function is especially well-suited to pre-quantization.

For example, if a recorded MIDI region cannot be quantized to a 16D Swing value without
producing a few incorrectly timed notes, quantize it to 1/16 notes and then use Apply
Quantization Settings Destructively. You can now use swing quantization on this
cleaned-up version of the MIDI region.

Another example:  If you are recording a hi-hat pattern consisting of 1/16 notes and one
single 1/32 note, first play the rhythm (quantized to 1/16 notes) without the 1/32 note
and choose Apply Quantization Settings Destructively. You can now raise the Quantization
parameter value to 1/32-Note and add the extra note without incorrectly quantizing any
badly played 1/16 notes.

To permanently quantize a region
1 Choose the desired quantization settings—including extended region parameter quantize

options, if desired.

2 Choose MIDI > Region Parameters > Apply Quantization Settings Destructively (or use
the Apply Quantization Destructively key command, default assignment:  Control-Q).

Note: When this is done, it is impossible to revert to the original recording, unless you
use Undo immediately after performing the operation (or use the Undo History command).
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Quantizing MIDI Events
Event-based quantization can be applied to any individual MIDI event (not just note
events) within a MIDI region. Individual event quantization is performed in the MIDI
editors.

The menu bars of the Piano Roll Editor and the Event List include a Quantize pop-up
menu and a Quantize button. This is a separate quantization function, which can be
applied to selected events rather than entire regions.

Quantize pop-up menu Quantize button

The Piano Roll Editor also includes a Quantize tool.

Further quantize operations are also available in the Transform window. These can be
applied to events in one or more selected regions that match very specific criteria. For
details, see Editing MIDI Events in the Transform Window.

Note: Event-level quantization irreversibly alters the positions of all event types, with the
exception of notes. Note events can be returned to their original record positions.

A Special Note About Quantization in the Score Editor
The primary purpose of the Score Editor is to produce readable—and
printable—notation. Although you can certainly edit MIDI note data in the Score Editor,
and quantize it with the Quantize tool (or the Functions > Quantization commands), it
is best to perform individual note quantize operations in the Piano Roll Editor or the
Event List.

The Quantize pop-up menu shown in the Inspector of the Score Editor serves a purely
graphical function. It alters the way notes are displayed, but it does not affect note
playback in any way.

To quantize events in a region using the Piano Roll Editor or the Event List
1 Open the Quantize pop-up menu in the Inspector’s Region Parameter box, and choose

a quantization value.
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This pop-up menu contains the same grid values that are in the Quantize pop-up menu
of the Region Parameter box, shown in the Inspector.

2 Do one of the following, depending on the options available in the window:

• Choose Functions > Quantize Selected Events, or use the corresponding key command
(Score Editor, Piano Roll Editor, and Event List).

• Select the events that you want to quantize, then click the Quantize button (Piano Roll
Editor and Event List). The most recently selected (or active) quantize value is used on
all selected events.

• Select the Quantize tool, then click all notes you want to quantize (Score and Piano
Roll Editors). The most recently selected (or active) quantize value is used on all selected
notes.

To set a quantize value with the Quantize tool
1 Click-hold a single note (or a selected group of notes) with the Quantize tool to open the

Quantize shortcut menu.

2 Choose the desired quantization value for the events.

To select, and quantize, several note events at once in the Score or Piano Roll Editor
µ Drag across the desired notes with the Quantize tool to select them.

The most recently selected (or active) quantize value is used on all selected notes.

To return note events to their original positions
1 Select all the notes you want to undo the quantization for.
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2 Do one of the following, depending on the options available in the editor:

• Choose Functions > Undo Quantization, or use the corresponding key command (Score
Editor, Piano Roll Editor, and Event List).

• Choose the “off” setting in the Quantize pop-up menu, then click the Quantize button
(Piano Roll Editor and Event List).

• Option-click the Quantize button (Piano Roll Editor and Event List).

• Option-click one of the selected notes with the Quantize tool (Score and Piano Roll
Editors).

Important: Use of region-based quantization after you have individually quantized note
events within a MIDI region will override your event-based quantizations, so take care. It
may be worthwhile writing such changes into the region by following the instructions
outlined in Quantizing MIDI Regions Permanently. Then all your hard work creating a
number of individual event quantizations will not be lost by quantizing the wrong region.

Working with Groove Templates
You can create quantization grids based on the rhythms of other audio or MIDI regions.
These are referred to as groove templates. Groove templates make it possible to capture
the small timing deviations that give an audio or MIDI region its feel, and apply them to
other audio or MIDI regions.

You can even take the feel from an audio region and apply it to a MIDI region—helping
a MIDI clavinet part to sit well with a funk guitar Apple Loop, for example (see Creating
an Audio-to-MIDI Groove Template).

To create your own groove template
1 Select the audio or MIDI region you want to create a groove template from. (You can also

select multiple regions to create a groove template, and all of them will contribute their
transients or notes to the new groove template. When there are multiple transients or
MIDI notes around the same musical position, however, only the first will be evaluated
for the groove template.)
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Tip: Two-bar MIDI regions work particularly well as models for this function, but you can
use MIDI regions of any length. Make sure that the source MIDI region actually contains
a note at every desired quantization value.

2 Open the Quantize pop-up menu in the Inspector’s Region Parameter box, and choose
a quantization value.

3 Open the Quantize pop-up menu again, and choose Make Groove Template (or use the
corresponding key command).

The groove template, with the default name of the selected region, appears near the
bottom of the Quantize pop-up menu, and the Quantize parameter of the parent region
is set to it.

This function transforms the exact timing of transient markers or notes in the selected
audio or MIDI region into a groove template that can be accessed, and used, like any
value in the Quantize pop-up menu.
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Important: The source audio or MIDI region used for a groove template must remain in
your project if you want to use the groove template. If you delete the source region from
the project, the groove template name is not removed from the Quantize pop-up menu,
but you cannot use this quantization value. If you choose the groove template name
from the Quantize pop-up menu, nothing will happen.

To remove groove template entries from the Quantize pop-up menu
1 Open the Quantize pop-up menu of any region, in the Inspector’s Region Parameter box,

and choose the groove template.

2 Open the Quantize pop-up menu again and choose “Remove Groove Template from List”
(or use the corresponding key command).

This deletes the selected source region from the list of possible quantization templates,
removing it from the Quantize pop-up menu. It does not remove the region.

Without changing the actual quantization of that region (nor of any other region that
may use that groove template), the previously selected groove template is deleted, and
the region is set to the Quantize value “off (3840).”

Using Groove Templates Across Projects
You can create and retain a number of quantization templates for use in several projects.

To use a groove template in several projects
1 Copy or create your source regions in one project.

2 Name these regions with the Text tool.

3 Open the Quantize pop-up menu, and choose Make Groove Template for each source
region (or use the corresponding key command).

4 Pack all of these regions into a folder (and rename the folder to Grooves, for example).

5 Choose File > Save As Template.

Use this template as your project starting point whenever you wish to access these
quantization templates.

Importing Groove Templates
You can also import third-party groove templates, such as the DNA Groove Templates
made by the Canadian firm WC Music Research.

To import third-party groove templates
1 Choose File > Import (or use the corresponding key command, default

assignment:  Command-I).

2 Choose “DNA Groove Template files” from the Open File pop-up menu, select the file you
want to import, and then click Import.

The groove templates are added as MIDI regions on the selected Arrange track.
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3 To add them to the Quantize pop-up menu, select a groove template and then choose
Make Groove Template from the Quantize pop-up menu of the Region Parameter box.

Note: The quantization templates are saved with the project and can be used, even when
the project is played on another computer that doesn’t have the corresponding DNA
Groove Templates on its hard disk.

Creating an Audio-to-MIDI Groove Template
You can create MIDI groove templates from digital audio material. This allows you to
extract the feel from drum loops or rhythmic samples—such as Apple Loops—and use
the resulting groove template to quantize MIDI regions.

Note: Make sure to disable the Edit > “Snap Edits to Zero Crossings” setting in the Sample
Editor.

To extract a MIDI groove template from a one-bar drum loop
1 Add the drum loop audio region to the Arrange area (see Adding Prerecorded Media).

2 Double-click the region to open the Sample Editor, or select the Sample Editor tab at the
bottom of the Arrange window.

3 Choose Factory > “Audio to MIDI Groove Template” (or use the corresponding key
command, default assignment:  Control-M).

4 Select the desired settings in the “Audio to MIDI Groove Template” tab:

• Preset pop-up menu: Contains various presets for the “Audio to MIDI” parameters, which
are suited to specific types of audio material. You can use these presets as starting
points for your own processing.
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• Granulation (ms): Determines the time span of louder components in the audio material.
Logic Pro uses these peak signals (or transients) to derive information for velocity points
in the groove template. The most useful values are usually between 50 and 200 ms,
depending on the tempo of the audio material.

• Attack Range (ms): Tells Logic Pro how long the attack phases of the sounds in the
audio material are. For example, drum and percussion instruments have short attack
times of less than 20 ms, whereas string instruments have longer attack phases. The
best values for the majority of instruments are usually between 5 and 40 ms, with most
around 20 ms.

• Smooth Release (%): Specifically designed to process audio material that contains sounds
with a long release or reverb tail. This makes it easier to convert these sounds into
suitable quantization points. The value you choose here should generally be between
0% and 5%, except when you are processing passages that contain sustained notes,
distorted guitars, or similar sounds.

• Velocity Threshold: Sets the threshold level. All signals that fall below this value are
ignored. In most cases, you should choose a value of 1, except when you are processing
very dense, loud material with soft background noises.

• Basis Quantize pop-up menu: Enables you to add artificial trigger points at positions
where there are no trigger points present. Groove templates created with this method
are suitable in situations where you need more quantization points than are contained
in the audio material. The automatic identification of trigger points in the audio material
is not affected by this parameter.

• Time Correction: Allows you to compensate for any time delays that may occur when
external samplers or synthesizers are triggered by MIDI notes. These time delays are
sometimes very noticeable, particularly if the connected device is playing a MIDI region
(that was quantized with an audio-to-MIDI groove template) at the same time as the
original audio material. You should be able to compensate for this effect by using
settings between −20 ms and 0 ms.
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While the “Audio to MIDI Groove Template” tab is still open, notice that there are three
fields at the bottom of the Sample Editor—labeled Audio, Quantize, and Result.

• Audio: Displays the quantization points identified in the audio file.

• Quantize: Shows the quantization points selected in the Basis Quantize pop-up menu.

• Result: Shows the quantization positions in the new groove template, which are
produced by the combination of the two values above.

5 Click any audio trigger point to prevent it from being transferred to the template.

Manually selected (unused) points will be dimmed.

6 Click the Try button in the “Audio to MIDI Groove Template” tab to apply the new groove
template to all selected MIDI regions.

7 Listen to the results.

8 Adjust the parameters until you are happy with the resulting groove, and then click Use.

This saves the new groove template, and adds it to the bottom of the Quantize pop-up
menu. The quantize template name is derived from the audio file name.
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This chapter provides an overview of where you can best edit different types of MIDI
events in Logic Pro. Logic Pro offers several MIDI event editors:  the Score, Piano Roll, and
Hyper Editors, and the Event List and Transform window. Each editor provides a different
view of MIDI events and offers unique editing functions. These differences make particular
MIDI editing tasks easier, and you will often switch between multiple editors to get a part
just right.

Important: You cannot perform any event editing operations—in the Arrange area or
the editors—unless the MIDI data resides in a MIDI region that exists in the Arrange area.

This chapter covers the following:

• Getting to Know the MIDI Editors (p. 647)

• Opening the MIDI Editors (p. 648)

• Hearing MIDI Events When Editing (p. 651)

• Editing MIDI Events in the Arrange Area (p. 651)

• Monitoring and Resetting MIDI Events (p. 653)

Getting to Know the MIDI Editors
The following is a brief introduction to each of the MIDI editors:

• Score Editor: Used to create printed notation. Ideal if you like working with dots, dashes,
and lines.

• Piano Roll: Perfectly suited for making changes to the pitch and length of MIDI note
events. Note events are represented as horizontal rectangles on a grid. The length of
the rectangle is directly proportional to the note length. The pitch of the note is
indicated by the vertical position of the rectangle, with higher notes being placed
toward the top of the screen.

• Hyper Editor: Useful for creating MIDI drum parts, and altering the levels of individual
note events. It can also be used to create and edit MIDI controller information, allowing
you to draw curves that result in a filter sweep in an external synthesizer, for example.
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• Event List: Shows all MIDI event types as a list. This is the editor to use when you need
to make precise changes to any aspect of a MIDI event.

• Transform window: This is not really an editor, in the same way that the other windows
are. You use the Transform window for MIDI-processing tasks, using mathematical
variables. While this might sound a little overwhelming, you can use the Transform
window to create a crescendo in a region, double or halve the speed of notes in a
region, and more. Many processes are available as presets, and you can create your
own.

Opening the MIDI Editors
There are several ways to open the MIDI editors in Logic Pro.

To access the Piano Roll, Score, and Hyper Editor in the Arrange window
Do one of the following:

µ Click the appropriate button at the bottom of the Arrange window.

The contents (the events) of the selected MIDI region are shown in the selected editor
window.

µ Double-click a MIDI region.

µ Use the Toggle Piano Roll, Toggle Score Editor, and Toggle Hyper Editor key commands.
The repeated use of the key command opens or closes (toggles) the chosen editor at the
bottom of the Arrange window.

To access the Event List in the Arrange window
Do one of the following:

µ Click the Lists button at the right side of the Arrange toolbar, then click the Event List
tab.

µ Use the Toggle Event List key command (default assignment:  E).

µ Double-click a MIDI region.

The contents (the events) of the selected MIDI region are shown in the Event List, to the
right of the Arrange window.

When the editor’s Link button is:

• Enabled: Clicking a MIDI region once displays the region in the Arrange window editor.
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• Disabled: Double-clicking a MIDI region (either the same one or another) opens the
chosen editor in a separate window, displaying the newly clicked region.

In general, you access the editors directly in the Arrange window, but it can be useful to
have multiple copies of the same editor open at the same time; for example, two Event
Lists—one set to display at the Arrange level (showing regions), and the other displaying
events within the regions. When you click region names in the Arrange level Event List,
the contents of the selected region are updated and shown in the other Event List window.

To access the Score, Hyper Editor, and Piano Roll as a separate window
µ Choose the editor window name from the Window menu (or use the corresponding key

command):

• Score Editor: Command-3

• Hyper Editor: Command-5

• Piano Roll Editor: Command-6

µ Drag the appropriate button at the bottom of the Arrange window, which changes to a
separate window as you drag it.

To access the Event List as a separate window
µ Choose Window > Event List (or use the Open Event List key command, default

assignment:  Command-0).
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µ Drag the Event List tab in the Lists area, which changes to a separate window as you drag
it.

To access the Transform window
Do one of the following:

µ Choose Window > Transform (or use the Open Transform key command, default
assignment:  Command-4).

µ When in a MIDI editing window:  Choose Functions > Transform.

You can define which editor opens when you double-click a MIDI region.

To determine the editor accessed by double-clicking a MIDI region
1 Open General preferences by doing one of the following:

• Choose Logic Pro > Preferences > General (or use the Open General Preferences key
command).

• Click the Preferences button in the Arrange toolbar, and choose General from the
pop-up menu.
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2 Click the Editing tab, then choose the preferred editor from the “Double-clicking a MIDI
Region opens” pop-up menu.

Hearing MIDI Events When Editing
MIDI editing is made much easier if you can hear every event and edit you make, whether
you are scrolling through the Event List (automatic selection) or transposing a note by
dragging it.

To hear MIDI event edits in real time
µ Click the MIDI Out button at the top-left corner of each editor window.

This is an independent setting for each editor, which will transmit MIDI events whenever
they are added, selected, or edited.

Editing MIDI Events in the Arrange Area
You cannot perform any event editing operations—in the Arrange area or the
editors—unless the MIDI data resides in a MIDI region that exists in the Arrange area
(although you can use the Clipboard functions to create a MIDI region in the Arrange
area).
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To create an empty MIDI region
µ Click at the desired position on a software instrument track lane with the Pencil tool.

This inserts an empty MIDI region, allowing you to manually enter events into it.

You can use the Clipboard to add MIDI events directly to the selected track in the Arrange
area, at the current playhead position. This also works for events from another project.

To copy MIDI events in the Arrange area
1 Select the events you want to copy in one of the event editors.

2 Choose Edit > Copy (or use the corresponding key command, default
assignment:  Command-C).

3 Select the track (and MIDI region, if applicable) you want to copy the events to.

4 Choose Edit > Paste (or use the corresponding key command, default
assignment:  Command-V).

Logic Pro adds the Clipboard contents (MIDI events) to the selected MIDI region.

Note: If no MIDI region is selected, Logic Pro creates a new MIDI region on the selected
track, at the current playhead position.

In general, event-level editing cannot be performed on regions in the Arrange area, but
there are a few exceptions. In some cases, it may actually be more efficient to perform
your edits (or operations) on MIDI regions in the Arrange area, rather than in a MIDI editor.
For example:

• Altering note lengths by resizing the region (see Adjusting the Start or End Point of
MIDI Regions).
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• Deleting or moving portions of regions (and therefore the events) with the Marquee
tool.

• Adjusting the playback of all events in a region by altering the region playback
parameters.

Monitoring and Resetting MIDI Events
The top line of the Transport bar’s MIDI Activity display shows the last MIDI message
received. The bottom line shows the most recently transmitted MIDI message. The display
is mainly used for checking MIDI connections.

MIDI Activity display

When Logic Pro receives more than one MIDI note simultaneously; the respective, held
intervals (between notes) are interpreted and displayed as chords.

On occasion, MIDI modules continue to sound, even when no note data is being sent to
them. This indicates that your sound sources have not responded to the All Notes Off
messages sent by Logic Pro.

To turn off stuck notes
Do one of the following:

µ Click the lower MIDI Activity display section in the Transport bar.

µ Click the Stop button twice in rapid succession.

In both cases, reset messages are sent, as defined in Logic Pro > Preferences > MIDI >
Reset Messages.

To stop hung notes
µ Double-click the MIDI Activity display in the Transport bar (or use the Send discrete Note

Offs (Panic) key command).

Separate Note Off messages are sent for every note, on all channels of every MIDI port,
which should do the trick.

To stop unwanted modulation
µ Choose Options > Send to MIDI > Reset Controllers (or use the Send Reset Controllers

key command).
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This transmits control change message #121, with a value of 0 (reset all controllers), on
all MIDI channels and outputs used by defined instruments. This neutralizes all MIDI
controllers, such as modulation or pitch bends.

To set all MIDI channels to their maximum volume
µ Choose Options > Send to MIDI > Maximum Volume (or use the Send Maximum Volume

key command).

This transmits a control change message #7 (main volume), with a value of 127, on all
MIDI channels and outputs used by defined instruments.

To send all program, volume, and pan settings from all external MIDI instrument
Parameter boxes

µ Choose Options > Send to MIDI > Used Instrument MIDI Settings (or use the Send Used
Instruments MIDI Settings key command).

This resets your sound sources, if unexpected program changes occur mid-performance.

To automatically send instrument settings after loading a project
µ Turn on the Send After Loading Project:  Used Instrument MIDI Settings option, in the

File > Project Settings > MIDI > General pane.
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The Piano Roll Editor shows the note events of a MIDI region as horizontal rectangles.
This resembles the holes cut in paper pianola rolls. The Piano Roll Editor can display the
MIDI note events of one MIDI region, or all MIDI regions in a folder or project. (See
Displaying Multiple MIDI Regions in the Piano Roll Editor.) You will generally work on one
region at a time in the Piano Roll Editor, however.

This chapter covers the following:

• Opening the Piano Roll Editor (p. 655)

• Getting to Know the Piano Roll Editor (p. 656)

• Creating and Editing Note Events in the Piano Roll Editor (p. 659)

• Splitting Chords in the Piano Roll Editor (p. 674)

• Using Hyper Draw in the Piano Roll Editor (p. 675)

• Customizing the Piano Roll Editor (p. 677)

• Using Piano Roll Editor Shortcuts (p. 677)

Opening the Piano Roll Editor
There are several ways to open the Piano Roll Editor in Logic Pro.

To open the Piano Roll Editor as a pane in the Arrange window
µ Click the Piano Roll button at the bottom of the Arrange window (or use the Toggle Piano

Roll key command, default assignment:  P).
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To open the Piano Roll Editor as a separate window
Do one of the following:

µ Choose Window > Piano Roll (or use the Open Piano Roll key command, default
assignment:  Command-6).

µ Drag the Piano Roll button, which changes to the Piano Roll Editor window as you drag
it.

Getting to Know the Piano Roll Editor
MIDI note events are represented by horizontal rectangles, aligned on a grid of horizontal
and vertical lines.

MIDI note event

• The horizontal placement of note events indicates their temporal (bar, beat, and
sub-beat) positioning within the region, and project.
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• The vertical position of note events indicates their pitch, with those nearer the top of
the Piano Roll grid being higher in pitch. Chords are displayed as a vertical stack of
note rectangles. The alignment of notes in chords is not always identical, as not all
notes in a chord may be struck, or end, at the same time.

• The length of MIDI note events is directly related to the length of the rectangles, so
notes such as hemidemisemiquavers (1/64th note), quavers (1/8th note), crotchets (1/4
note), minims (1/2 note), whole notes, and so on can be easily recognized.

Using the Grid in the Piano Roll Editor
The grid provides a valuable reference for note lengths. You can see both the start and
end positions of note events, aligned with the time values shown in the Bar ruler. This
simplifies note length editing.

The default grid lines shown are:

• A black line at every bar and beat.

• A light gray line at every division value (you can alter the division value in the Transport
bar).

You can alter the appearance of this grid and other aspects of the Piano Roll Editor (see
Customizing the Piano Roll Editor).

The vertical keyboard on the left side of the Piano Roll Editor indicates note pitches.
Horizontal black lines run across the screen between notes B and C, and notes E and F.
These lines are very helpful when transposing notes by dragging them up or down.

Using the Info Display in the Piano Roll Editor
The Piano Roll Editor’s info display indicates the current position and pitch of the mouse
pointer within the region.

Info display

You should refer to this real-time display whenever making a selection.

Tip: Activate the MIDI Out button next to the Piano Roll Editor’s local menu bar to hear
your edits as you make them.
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Understanding Note Velocities
Each note event features a horizontal line that runs through the rectangle. The length of
the line—in relation to the total length of the note—corresponds to the velocity value
of the note (up to the maximum value of 127). Velocity denotes how hard the MIDI
keyboard was struck when the note was recorded. This also usually indicates how loud
the note is, within the range of 127 possible values, with 127 being the “loudest.”

The Piano Roll Editor also indicates note velocities with different colors.

High velocity Low velocity

This makes it very easy to see the overall range of (and individual note) velocities in a
MIDI region. As you change the velocity of MIDI notes, the color of selected notes changes
in real time.

For further details about color assignments in the Piano Roll Editor, see Changing Note
Color in the Piano Roll Editor.

Displaying Multiple MIDI Regions in the Piano Roll Editor
The Piano Roll Editor’s Link button can be used to simultaneously display the contents
of all MIDI regions in a folder, all regions in a project, or several selected MIDI regions.

You can freely select note events that belong to different MIDI regions, and process,
move, or resize them as required. A help tag indicates the number of selected events and
parent MIDI regions. For example, 8/2 means that eight notes are selected from two MIDI
regions.

When the Link Button Is Turned On
• Each time you select another region in the composition area, the Piano Roll Editor

updates to reflect the contents of this region.

• Selecting several regions simultaneously updates the Piano Roll Editor to display the
contents of all selected regions.

The start point of each MIDI region is indicated by a vertical line of the same color as the
MIDI region itself.

Double-click a note event to revert to a display of the contents of a single parent MIDI
region (the region that contains the note).
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When the Link Button Is Turned Off
You can select several regions, either one after the other or simultaneously, and the Piano
Roll Editor does not update to reflect the content of these regions.

Using the Shortcut Menu in the Piano Roll Editor
Many selection, editing, and other commands can be accessed by Control-clicking (or
right-clicking) anywhere in the Piano Roll Editor background area or directly on a MIDI
note event. Make use of this to accelerate your workflow.

These shortcut menus can only be accessed if one of the following options is chosen in
the Logic Pro > Preferences > General > Editing pane.

• Right Mouse Button:  Opens Shortcut Menu

• Right Mouse Button:  Opens Tool and Shortcut Menu

Creating and Editing Note Events in the Piano Roll Editor
Handling note events in the Piano Roll Editor is very similar to region handling in the
Arrange area. Many of the same techniques used to lengthen, cut, and move regions
apply to note events.

Snapping Edits to Time Positions in the Piano Roll Editor
You move and resize events in the Piano Roll Editor because you want them to start and
end at a specific point in time.

Logic Pro offers a snap feature that automatically aligns event start and end points to a
selected grid value, when you move or resize them.
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To snap events to a grid
µ Choose one of the following values in the Snap menu at the top of the Piano Roll Editor:

• Smart: Edit operations snap to the nearest bar, beat, sub beat, and so on, depending
on the current Bar ruler division value and the zoom level.

• Bar: Edit operations snap to the nearest bar.

• Beat: Edit operations snap to the nearest beat in a bar.

• Division: Edit operations snap to the nearest division (this is the time signature shown
in the Transport bar and Bar ruler).

• Ticks: Edit operations snap to the nearest clock tick (1/3840th of a beat).

• Frames: Edit operations snap to the nearest SMPTE frame.

The Snap functionality is relative, which means that the edit operation is snapped to the
nearest bar, beat, and so on—retaining the event’s distance from its original position.
For example, if an event is placed at position 1.2.1.16, and you move it to around bar 2
(with the Snap menu set to Bar), it automatically snaps the event to position
2.2.1.16—rather than 2.1.1.1 (the bar 2 start point). You can override relative snaps with
the Snap to Absolute Value option.

To snap to an absolute, not relative, position
µ Choose the Snap to Absolute Value setting in the Snap menu.

A tick appears to the left of the setting when it is chosen. This feature works in conjunction
with the chosen snap grid format.

To explain, if Bar is chosen in the Snap menu, when Snap to Absolute Value is active,
moving an event (from position 1.2.1.16) to around bar 2 results in it being snapped to
position 2.1.1.1 (the bar 2 start point), rather than its relative position (2.2.1.16).
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The Snap menu setting applies to the following edit operations:

• Moving and copying events

• Resizing events

• Cutting events

• Moving, adding, and resizing markers

• Setting cycle boundaries

You can temporarily override the snap grid, allowing finer edits and adjustments.

To override the snap grid
Do one of the following:

µ Hold Control while performing the editing operation.

The division value chosen in the Transport bar (1/16, for example) determines the editing
grid scale.

µ Hold Control-Shift while performing the editing operation.

The editing grid switches to ticks.

Selecting Notes in the Piano Roll Editor
You must select note events before you can edit them. The usual selection
methods—clicking, Shift-clicking, and dragging with the Pointer tool—also apply to the
Piano Roll Editor.

The following selection options—unique to the Piano Roll Editor—are also available:

To select all notes of the same pitch in a MIDI region
µ Click the corresponding key of the onscreen keyboard.

This is similar to selecting all regions on a track lane, by clicking the track name.

To select a range of note pitches in a MIDI region
µ Click-drag over the key range of the onscreen keyboard.

All MIDI notes that fall within this pitch range are selected.

The info display shows the number of selected notes. The MIDI region name is shown
beside the number of selected notes. For example, 3/Piano means three notes are selected
from a MIDI region called Piano.

When you select multiple overlapping notes, the info display shows the chord name.
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When no notes are selected, the info display shows the name of the most recently selected
MIDI region.

Creating Notes in the Piano Roll Editor
You will often create note events with the mouse in the Piano Roll Editor, to replace a
deleted note or to add a note to a chord or region. This feature is also handy when a
keyboard is unavailable, or even when one is available, because it’s faster to insert a note
with the mouse.

You can also create note events with your computer keyboard. For details, see Using the
Step Input Keyboard.

To create a note event
Do one of the following:

µ Control-click (or right-click) the Piano Roll Editor background, then choose Create Note
from the shortcut menu.

µ Select the Pencil tool, and click a position in the Piano Roll Editor background.

A MIDI note is created at the clicked position, with the note’s channel, velocity, and length
values matching that of the previously created or edited note event. The default values
when you start a new project are MIDI channel 1, velocity of 80, and length of 240 ticks.

Note: If using the Pencil tool to create a note event, you can change note length on-the-fly;
simply hold down the mouse key and drag to the left or to the right.

To create a note event of a specific length
µ Drag to the right or left with the Pencil tool.

A help tag indicates the length change in real time.

Finer adjustments can be made by holding down Option or Control while altering the
note length (see Snapping Edits to Time Positions in the Piano Roll Editor).

To replicate an existing note at another position or pitch
1 Do one of the following:

• Control-click (or right-click) the original note, then choose Define as Default Note from
the shortcut menu.
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• Click the original note with the Pencil tool.

Note: Editing an existing note also defines it as the default note.

2 Click a position in the Piano Roll Editor background with the Pencil tool.

The new note’s channel, velocity, and length are identical to the original (or edited) note.

Deleting Notes in the Piano Roll Editor
You can delete selected notes by pressing Delete, or clicking them with the Eraser.

To delete notes
Do one of the following:

µ Select the Eraser tool, then click the note you want to delete.

µ Select the notes you want to delete, then click one of the selected notes with the Eraser
tool (or press Delete).

This deletes all selected events.

To delete similar or equal events
1 Select one of the notes you want to delete.

2 Choose Edit > Select Similar Events or Edit > Select Equal Events (notes of the same pitch,
for example), and then delete the selected events by pressing Delete.

For more information about similar and equal events, see Selecting Similar or Identical
Objects, Regions, or Events.

You can also delete events by choosing one of the Delete MIDI Events commands from
the Piano Roll Editor’s local menu bar.

To delete doubled events
µ Choose Functions > Delete MIDI Events > Duplicates (or use the Delete Duplicated Events

key command, default assignment:  D).

Any events occurring twice or more at the same position (and pitch) are deleted, allowing
one to remain.

Duplicated events may have different second data bytes (velocity, aftertouch, or controller
values). Logic Pro only looks at the event type and position when determining whether
or not two or more events are duplicated.
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Events of the same type, but on different MIDI channels, are not viewed as being identical.

The “same time position” includes two notes that are output simultaneously because of
the current quantization setting. Full details on all quantization options are described in
Quantizing Audio and MIDI.

To delete events inside or outside the locators
1 Set the left and right locator positions as desired.

2 Do one of the following:

• Choose Functions > Delete MIDI Events > Inside Locators.

• Choose Functions > Delete MIDI Events > Outside Locators.

This deletes all events between or outside the locator positions.

When copying events or reducing the length of MIDI regions, events can sometimes end
up outside the limits of a MIDI region. These technically still belong to the MIDI region,
although they won’t be played or heard.

To delete events outside the MIDI region
µ Choose Functions > Delete MIDI Events > Outside Region Borders.

To delete unselected events within the selection
µ Choose Functions > Delete MIDI Events > Unselected Within Selection.

All unselected notes between the (start point of the) first and the (end point of the) last
selected note are deleted.

To delete all selected events and select the next one
1 Select the event you want to delete.

2 Use the Delete and Select Next Region/Event key command.

Restoring Deleted Notes in the Piano Roll Editor
Accidental deletions of one or more notes, or a simple change of mind or editing mistake
is an inevitable part of song creation. Fortunately, you can backtrack your edits easily in
Logic Pro. You also have the option of simply re-creating an event with the Pencil tool.

To undo the last note editing step or deletion
µ Choose Edit > Undo from the main menu bar (or use the corresponding key command,

default assignment:  Command-Z) immediately after making the error.

To undo or redo multiple steps
1 Choose Edit > Undo History. The Undo History window opens. The most recent editing

step (at the bottom of the list) is highlighted.

2 Click any entry to undo or redo all steps between the clicked and highlighted entries. All
steps are animated during this process.
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Important: A Redo list is not displayed until an Undo operation has been performed. The
Redo list appears below the Undo items. The first item that can be redone is indicated
by gray text.

To undo or redo an isolated step
1 Command-click the step. A warning dialog opens.

2 Click Apply to undo or redo the step. Click Cancel to abort the step.

This procedure will undo or redo an isolated step without influencing all steps between
the clicked and higlighted (most recent) entries.

Moving Notes in the Piano Roll Editor
You can move selected notes by grabbing them (near the middle) and dragging them.
If you move notes vertically, they are transposed, and if you move them horizontally, they
are moved in time.

The current position and pitch are shown in a help tag while dragging. The deviation
from the original pitch is shown as a positive or negative number of semitone steps at
the bottom left of the help tag. The original pitch remains in the info display of the Piano
Roll Editor.

When you move notes horizontally, they snap to the division defined in the Snap menu
(you can alter this setting at any time).

To make finer adjustments
1 Select the notes.

2 Press Control, and drag the notes to the new position.

The resolution of the drag steps depends on the current Snap menu setting and zoom
level (see Snapping Edits to Time Positions in the Piano Roll Editor).

Alternately, you can follow the procedure above, but press Control-Shift as you drag to
move the notes in tick steps, completely overriding the Snap menu setting.

To limit note movements to one direction
1 Open the General preferences by doing one of the following:

• Choose Logic Pro > Preferences > General (or use the Open General Preferences key
command).

• Click the Preferences button in the Arrange toolbar, and choose General from the menu.
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2 Click the Editing tab, then select the Limit Dragging to One Direction in Piano Roll and
Score checkbox.

When active, this option helps you to avoid accidental transpositions of notes when
moving them horizontally, or changing the position of notes when you’re trying to change
their pitch. The initial movement—vertical or horizontal—restricts further movements
to this plane, while the mouse button is held. Release the mouse button and click the
event to move in the other direction.

Moving Events via Key Commands
Editing can be greatly accelerated by assigning, and using, the following key commands
to move one or more events.

• Nudge Region/Event Position Right by SMPTE Frame

• Nudge Region/Event Position Left by SMPTE Frame

• Nudge Region/Event Position Right by 1/2 SMPTE Frame

• Nudge Region/Event Position Left by 1/2 SMPTE Frame

• Nudge Region/Event Position Right by 5 SMPTE Frames

• Nudge Region/Event Position Left by 5 SMPTE Frames

• Nudge Region/Event Position Right by SMPTE Bit

• Nudge Region/Event Position Left by SMPTE Bit

• Nudge Region/Event Position Right by Tick

• Nudge Region/Event Position Left by Tick

• Nudge Region/Event Position Right by Division

• Nudge Region/Event Position Left by Division

• Nudge Region/Event Position Right by Beat

• Nudge Region/Event Position Left by Beat

• Nudge Region/Event Position Right by Bar
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• Nudge Region/Event Position Left by Bar

• Nudge Region/Event Position Right by Nudge Value

• Nudge Region/Event Position Left by Nudge Value

• Nudge Region/Event Position Right by Sample

• Nudge Region/Event Position Left by Sample

• Nudge Region/Event Position Right by 1 ms

• Nudge Region/Event Position Left by 1 ms

• Nudge Region/Event Position Right by 10 ms

• Nudge Region/Event Position Left by 10 ms

The selected events are shifted one step right or left, by whatever unit is referred to in
the particular command name.

Including Non-Note MIDI Events
Turn on the Functions > Include Non-Note MIDI Events setting to tie other data (such as
pitch-bend, modulation, aftertouch, or poly pressure) in a region to the region’s notes.
This may be useful when a region contains note-related controller data that you want to
copy or move.

Changing Note Length in the Piano Roll Editor
You can use the Pointer, Finger, or Pencil tool to alter note lengths.

Tip: It’s advisable to use the Pointer or Finger tool, as these avoid the accidental creation
of new notes, which is possible with the Pencil tool.

To alter the end point (and length) of a note
µ Position the Pointer, Finger, or Pencil tool over the lower-right edge of a note event, then

drag when the tool icon changes to the length change icon.

A help tag informs you about the precise end point and length of the note while dragging.

Tip: It can sometimes be difficult to grab the bottom-right corner of very short notes. In
this situation, you should use the Finger tool, which allows you to grab notes anywhere,
in order to alter their end point (and therefore, length).
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To change the start point (and length) of a note
µ Position the Pointer or Pencil tool over the lower-left edge of a note event, then drag

when the tool icon changes to the length change icon.

A help tag informs you about the precise start point and length of the note while dragging.

Note: The original end point of the note is retained when adjusting the start point.

Altering the Lengths of Several Notes Simultaneously
You can adjust the lengths of several selected notes at once (in a chord, for example), by
simply altering the length of one of them. The relative differences between the (selected)
note lengths are maintained.

To set the same end point for several notes
µ Press Shift while altering the length of one of the selected notes.

To make several notes the same length
µ Hold Option-Shift while dragging one of several selected notes.

Setting Note Start and End Points to the Playhead Position
You can move the start or end point of one or more selected notes to the playhead
location with the following key commands:

• Set Region/Event/Marquee Start to Playhead Position

• Set Region/Event/Marquee End to Playhead Position

Advanced Note Length Functions
The Functions > Note Events submenu in the Piano Roll Editor menu bar contains
commands that change the length of selected notes. These changes are influenced by
the notes surrounding or overlapping them. This is ideal for tidying up the start and end
points of notes.

To remove note overlaps
1 Select the notes you want to affect.

2 Choose one of the following commands in the Functions > Note Events submenu (these
commands are also available as key commands):

• Note Overlap Correction (selected/any): This command removes overlaps for all selected
notes, regardless of whether the following overlapped notes are selected or not.

• Note Overlap Correction (selected/selected): This command removes overlaps for all
selected notes, but only if the following overlapped notes are selected.
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• Note Overlap Correction for Repeated Notes: This command removes overlaps for all
selected notes, but only if the following overlapped notes have the same note number
(are of the same pitch).

The Overlap Correction functions view vertically stacked notes (notes in the same location,
but of different pitches) as a chord. A dialog indicates that the overlapping notes appear
to be part of a chord, and you are asked to choose one of the following options:

• Keep: Simultaneously sounding notes are reduced in length (moved to the same end
point).

• Delete: Simultaneously sounding notes are removed, leaving a monophonic line behind.

• Shorten: Simultaneously sounding notes are individually reduced in length, resulting
in a number of short notes in a monophonic line remaining.

To make notes legato
1 Select the notes you want to affect.

2 Choose one of the following commands in the Functions > Note Events submenu:

• Note Force Legato (selected/any): This command forces legato for (lengthens) all selected
notes, regardless of whether the following note is selected or not.

• Note Force Legato (selected/selected): This function forces legato for all selected notes,
but only if the following note is selected.

The end of the MIDI region is treated as an unselected note:

• Note Force Legato (selected/any) lengthens the last note to the end point of the MIDI
region.

• Note Force Legato (selected/selected) does not alter the length of the last note.

3 If Logic Pro finds chords, it asks if you want to delete them or shorten overlapped notes.

• Click the Delete button to erase any incorrect notes in a poorly played monophonic
line.

• Click the Keep button to even out (shorten) the start points and durations of all
(intentionally played/recorded) notes in chords.

To convert sustain pedal events to note lengths
µ Choose Functions > Note Events > Sustain Pedal to Note Length.

All sustain pedal events (controller #64) used on selected note events are analyzed, and
the note events are actually increased in length. This increase matches the controller #64
(sustain pedal) off message position.

The pedal events (controller #64 on and off ) are erased after use of this command.

Copying or Moving Notes in the Piano Roll Editor
There are a number of ways to copy or move notes in the Piano Roll Editor.
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To copy or move notes
Do one of the following:

µ Hold down Option while dragging the notes to the new position.

Tip: You can use this method to copy or move notes between two Piano Roll Editor
windows (showing different regions, for example), or even between the Piano Roll Editor
windows of different projects.

µ Use one of the following clipboard commands:

• Edit > Copy (or Command-C) to copy notes into the Clipboard.

• Edit > Cut (or Command-X) to move notes into the Clipboard.

• Edit > Paste (or Command-V) to paste notes at the current playhead position, at their
original pitch.

Advanced Note Copy and Move Options
You can also perform advanced copy and move operations within the Piano Roll Editor.
These allow you to directly swap events, or to merge a group of notes from one section
of a region to the same, or another, region, for example.

To copy or move a range of MIDI events
1 Define the area that you want to move or copy with the left and right locators.

As an optional step:  Select the track you want to copy the events to, if you want to copy
or move the events to another track.

2 Set the playhead to the insert position.

3 Choose Functions > Copy MIDI Events. The Copy MIDI events dialog opens.

4 Choose settings in the Copy MIDI Events dialog.

See the following section for a detailed description of the settings.
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Using the Copy MIDI Events Settings
The following describes the settings found in the Copy MIDI Events dialog.

• Mode pop-up menu: Determines how MIDI events are copied or moved. You can choose
from the following options:

• Copy Merge: The copied data is blended with any data present at the destination
position.

• Copy Replace: The data at the destination position is deleted, and replaced with the
copied data.

• Copy Insert: All data at the destination position is moved to the right, by the length
of the source area.

• Move Merge, Move Replace, Move Insert: These three modes work similarly to the Copy
modes, but actually move the selected events, removing them from their original
positions.

• Rotate: The source events are moved to the destination position. The data that was
previously at the destination position, and the data that falls between the source
and destination positions are all moved toward the source position. This rotates the
data around a central pivot point (halfway between the source and destination
positions).

• Direct Swap: Exchanges the source data with data of the same length, starting at the
target position. This allows you to swap the notes in bar 1 of a four-bar MIDI region
with the notes in bar 3 of the same region, for example.

• Remove: Removes the MIDI data from the source region, but leaves the region at its
original position.

• Left Locator and Right Locator: Allow you to edit the source area you defined with the
left and right locators.

• Destination: Defines the destination position independently of the playhead position.

• Number of Copies: Defines the number of copies.

• “Create new region” checkbox: When selected, a new MIDI region is created at the
destination position. It contains the copied (or moved) events.
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Protecting the Position of Events in the Piano Roll Editor
There are times when you will want to protect certain events from being moved. For
example, several note events may be used to trigger footstep samples that match an
actor walking down a corridor, in a video soundtrack.

You have already created the music for this scene, but have been asked to increase the
tempo to match several cuts of different camera angles in the corridor. Obviously, a
change in the tempo will move the events, resulting in out-of-sync footstep samples.
Fortunately, Logic Pro has a feature that preserves the absolute time position of events.

To protect the position of one or more selected events
µ Choose Functions > Lock SMPTE Position (or use the corresponding key command).

This ensures that events that fall at a particular absolute time position—1 hour, 3 minutes,
15 seconds, 12 frames, for example—remain at this position when tempo changes are
made.

To unprotect the position of one or more events
µ Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Changing Note Velocity in the Piano Roll Editor
Note velocity is usually tied to the level of the note, and given the use of color to indicate
different velocities, you can quickly identify the “loud” and “soft” notes in a region.

Note: Velocity can also be used as a controller for other synthesizer parameters, such as
filter resonance or cutoff, either alone or in conjunction with level. As such, you may find
that changes to note velocity not only affect the level of the note, but also tonality.

To alter the velocity value of a note
µ Drag a note vertically with the Velocity tool.

A help tag indicates the velocity value of the note you clicked, with the value changing
as you drag. The color of the note event changes and the horizontal line inside the event
either lengthens or shortens.

If the MIDI Out function is turned on (and it should be), the note is output as you alter
the velocity.

All selected notes can be altered simultaneously; the differences in their respective velocity
values are retained. If the velocity value of any of the selected notes reaches an extreme
value (0 or 127), none of the other selected notes can be adjusted further.
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You can override this behavior by holding Option while dragging. This allows you to
continue altering the velocity values until the selected (clicked) note reaches an extreme
value. Of course, this will alter the velocity relationship of this note to the other notes.

To assign the same velocity value to all selected notes
µ Hold down Option-Shift while dragging one of the notes with the Velocity tool.

Muting Notes in the Piano Roll Editor
The Piano Roll Editor features a Mute tool that allows specific notes in a MIDI region to
be muted.

To mute/unmute a note
µ Click the note with the Mute tool.

Muted notes are grayed out (shown without color).

To mute or unmute all notes of a particular pitch in a MIDI region
µ Click a piano key to the left of the Piano Roll Editor with the Mute tool.

This mutes or unmutes all notes of that particular pitch, which is ideal for muting the
hi-hats in a MIDI region that is triggering an entire drum kit, for example.

To mute or unmute multiple notes
µ Select the notes, then click one of the selected notes with the Mute tool.

The Select Muted Regions/Events key command is also available in the Piano Roll Editor.
It allows the selection of all muted notes in a MIDI region. The next logical operation
would be to delete these muted notes by pressing Delete.

Changing Note Color in the Piano Roll Editor
You can change the color of notes in the Piano Roll Editor, according to the following
options:

• Velocity Colors: Applies color in accordance with MIDI note velocity.

• Region Colors: Applies color in accordance with the color of the MIDI region that contains
the notes.

• MIDI Channel Colors: Applies color in accordance with the MIDI channel that processes
the notes.
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To change the color of notes
Do one of the following:

µ Choose the required color assignment from the Piano Roll Editor’s View menu.

µ Control-click (or right-click) the Piano Roll Editor’s background, then choose the required
color assignment from the shortcut menu.

Splitting Chords in the Piano Roll Editor
The following functions divide chords horizontally (by pitch), making the Piano Roll Editor
the ideal place to perform chord-splitting tasks.

To select the top or bottom note of one or more selected chords
Do one of the following:

µ Choose Functions > Note Events > Select Highest Notes to select the highest notes in
the chords.

µ Choose Functions > Note Events > Select Lowest Notes to select the lowest notes in the
chord(s).

The latter command may be perfect for separating a walking bass line in a piano region,
for example. Once separated, the lowest notes can be cut and pasted into a new region,
which is played on a track assigned to an EXS24 mkII Upright Bass instrument channel.

Note: Select Highest Notes and Select Lowest Notes are purely selection commands,
which can be used in conjunction with any of the editing commands, such as Cut, to
move a voice into another MIDI region, as per the example above.

To assign individual note pitches to different MIDI channels
1 Select the note pitch(es) you want to affect by clicking the Piano Roll keyboard.

• Shift-click to select multiple noncontiguous pitches.

• Drag across the keyboard to select a range of contiguous pitches.

2 Choose Functions > Note Events > Voices to Channels.

Logic Pro assigns MIDI channel numbers (in ascending order) to individual note pitches
in the selected MIDI region. The highest note pitch in each chord is assigned as MIDI
channel 1, the next note down in each chord channel 2, and so on.

Note: Use of these commands results in changes to the MIDI region, which will contain
information spread across multiple MIDI channels, following the operation.

Regions split in this way allow you to create a new MIDI region for each note by using
the Region > Split/Demix > Demix by Event Channel menu option in the Arrange window.

Each region created from this process can then be assigned to a different track (and
channel), allowing different instruments to be assigned for each voice.
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For more information on the Functions > Note Events > Assign Channels Based on Score
Split command, see Using a Split Point.

Using Hyper Draw in the Piano Roll Editor
You can directly create and edit MIDI controller information in the Piano Roll Editor. These
types of edits are made easier when you can see the notes that will be affected.

To view and create controller events
1 Open a Hyper Draw display in the Piano Roll Editor by doing one of the following:

• Choose a View > Hyper Draw command.

• Click the Hyper Draw button at the lower-left corner of the Piano Roll Editor, then
choose a MIDI controller by clicking the arrow button to the left.

The selected controller type (volume, for example) is shown in a gray field below the
Piano Roll grid.
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2 Click at different points in the gray area to create Hyper Draw nodes.

A connecting line is automatically created between the nodes.

To resize the Hyper Draw area
µ Grab, and vertically move the dividing line that separates it from the Piano Roll grid area.

For more information, see Using Hyper Draw in the Arrange Area.
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Customizing the Piano Roll Editor
You can customize the appearance of the Piano Roll Editor by modifying Piano Roll Display
preferences—such as background color, brightness, line display, and so on.

To open Piano Roll Display preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command), then click the Piano Roll tab.

µ Click the Preferences button in the Arrange toolbar, choose Display from the pop-up
menu, then click the Piano Roll tab.

µ Choose View > Piano Roll Colors in the Piano Roll’s local menu bar.

For full details about the Piano Roll Display preferences, see Piano Roll Display Preferences.

Using Piano Roll Editor Shortcuts
The Piano Roll Editor also provides a way to “quick-launch” the Event List and Score Editor.

To quickly open the Event List
µ Double-click any event.

The Event List is shown in the Media area to the right of the Arrange window. If already
open, the contents of the parent region (of the note selected in the Piano Roll Editor) are
displayed.
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Note: If using an independent Piano Roll Editor window, double-clicking an event opens
an independent Event List window.

To quickly open the Score Editor
µ Option-double-click any event.

The Score Editor opens in a new window. The Piano Roll Editor remains docked in the
Arrange window’s editing area.
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The Hyper Editor is a graphical editor that can be used to create or edit MIDI note and
controller data. In this chapter, you’ll learn how to use the Hyper Editor to view and edit
different MIDI event types, shown as vertical beams along a timeline within a region.

This chapter covers the following:

• Opening the Hyper Editor (p. 679)

• Getting to Know the Hyper Editor (p. 681)

• Creating and Editing Events in the Hyper Editor (p. 681)

• Working with Event Definitions (p. 691)

• Using the Event Definition Parameter Box (p. 696)

• Working with Hyper Sets (p. 699)

Opening the Hyper Editor
There are several ways to open the Hyper Editor in Logic Pro.

To open the Hyper Editor as a pane in the Arrange window
µ Click the Hyper Editor button at the bottom of the Arrange window (or use the Toggle

Hyper Editor key command, default assignment:  Y).

To open the Hyper Editor as a separate window
Do one of the following:

µ Choose Window > Hyper Editor (or use the Open Hyper Editor key command, default
assignment:  Command-5).
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µ Drag the Hyper Editor button, which changes to the Hyper Editor window as you drag
it.
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Getting to Know the Hyper Editor
The main elements of the Hyper Editor are as follows:

Event Definition 
Parameter Box

Event

 Event definitions

Hyper Set menu

• Event: Each beam displayed in the Hyper Editor represents an event. The value of the
event is denoted by its height, providing an at-a-glance view of one, or dozens, of
different events and their values. For full details, see Creating and Editing Events in the
Hyper Editor.

• Event definition: Each MIDI event type, be it a note or MIDI controller, is arranged from
top to bottom in horizontal lanes—event definitions—much like the track lanes shown
in the Arrange area. The type of event shown, and controlled, on each lane is freely
configurable. This is done by setting an event definition for each lane in the Inspector.
For full details, see Working with Event Definitions.

• Event Definition Parameter box: This is used to alter the settings of the selected event
definition. For full details, see Using the Event Definition Parameter Box.

• Hyper Set menu: You can save groups of event definitions (several lanes that you have
defined) as hyper sets, which are accessed via the Hyper Set menu in the Inspector.
For full details, see Working with Hyper Sets.

Creating and Editing Events in the Hyper Editor
The Hyper Editor, like the other MIDI editors, can be used for event input duties. In some
situations, manual entry of note and controller events is more efficient than performing
and recording them. One example would be the creation of 1/16th note hi-hats in a
region when the tempo is 160 bpm, which would be difficult to play.
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You can, of course, record events with a MIDI keyboard, and then refine your performances
in the Hyper Editor.

Changing the Grid and Beam Display
The Grid parameter in the Event Definition Parameter box of the Inspector is important
when creating events in the Hyper Editor. Newly created events are automatically added
at grid positions. This makes it easy to create a drum pattern, with 4 divisions on one
lane, 8 divisions on another lane, and 16 divisions on another lane; assigned to kick, snare,
and hi-hat sounds, for example.

To define the Grid value for the selected event definition lane
µ Choose a grid type from the Grid pop-up menu in the Event Definition Parameter box.

Any events that you add snap automatically to the nearest grid position. The positions
of existing events are not affected.

Tip: When editing or constructing complex rhythm patterns, it can be useful to create
several event definitions (see Selecting and Creating Event Definitions) for one drum
note, each with a different quantization grid. For example, if there are two lanes for a
snare drum, one with a 1/16th and the other with a 1/96th grid, you can use the Pencil
tool to add individual hits in the coarser grid, and drum rolls in the finer grid.

When defining the Grid parameter to add a succession of controllers, use the motto, “as
coarse as possible, and as fine as necessary” to minimize data output. Logic Pro can handle
very large amounts of data, but unfortunately the same cannot be said of MIDI.
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You can also alter the width and style of event beams to make event creation and editing
easier.

To set the width of event beams
µ Choose a Pen Width value in the Event Definition Parameter box.

The exact event position is always marked by the left edge of the beam, regardless of the
beam width.

When you set the Pen Width parameter to Note Length, note event beams are displayed
at their actual length. The Status parameter must be set to Note for this to work.

To change the style of beams displayed
µ Choose a setting in the Style menu.

• No Frames: Shows the value of the event as a colored beam.
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• Framed Values: Shows a hollow frame beam that is the full height of the event definition
lane. The value of the event is displayed as a colored beam within the frame beam.

No Frame event

Framed Value event

Creating Events
The Hyper Editor provides several unique methods for the creation (and editing) of MIDI
events.

To add an event
1 Select the Pencil tool.

2 Click a time position on the appropriate event definition lane.

3 Drag up or down to alter the event value before you release the mouse button.

To add multiple events
µ With the Pencil tool, drag horizontally over the time position on the appropriate event

definition lane.

This results in a freehand curve of new events that follows the (vertical and horizontal)
Pencil tool movements in the lane.
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To create multiple events in a linear fashion
1 Select the Line tool.

Line tool

2 Click a position on the appropriate event definition lane.

A help tag appears, showing the exact position and event value in the top line.

3 Move the mouse to the desired end point of the line (to the right or left).

As you do so, you see the line trailing behind the Line tool pointer, with the exact position
and event value shown in a help tag.

4 Click the end point to create several event beams, aligned along the line.

New events are created at each grid position (in accordance with the Grid parameter),
within the line start and end points.

To create or alter a linear series of events in sections
1 Select the Line tool.

Line tool

2 Click a position on the appropriate event definition lane.

A help tag appears, showing the exact position and event value in the top line.

3 Move the mouse to the desired end point of the line (to the right or left).
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As you do so, you see the line trailing behind the Line tool pointer, with the exact position
and event value shown in a help tag.

4 Shift-click the end point.

This immediately draws another line from the end point of the original line.

To create new events when other events already exist in a lane
1 Select the Line tool.

Line tool

2 Click a position on the appropriate event definition lane.

A help tag appears, showing the exact position and event value in the top line.

3 Move the mouse to the desired end point of the line (to the right or left).

As you do so, you see the line trailing behind the Line tool pointer, with the exact position
and event value shown in a help tag.

4 Option-click the end point.

The values of existing events in the area between the line start and end points are aligned
along the line (creating a crescendo, for example). New events are created at every
(unoccupied) grid value.

You can also assign a fixed value when creating events. The Fix Value checkbox in the
Inspector, when selected, prevents any event value from being altered with the Pointer
or Pencil tool.
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This is ideal when adding events with the Pencil, as all are assigned the value of the
previously selected event. This allows you to draw a succession of events with the same
value—perfect for drawing in a row of 16th note hi-hats, for example.

To assign a fixed event value
1 Select the Fix Value checkbox in the Inspector.

2 Click any existing event with the Pencil tool to use its value as a preset.

In Fix Value mode, it is impossible to alter an event value by clicking it.

Note: When adding events with the Line tool in Fix Value mode, the preset value is always
used as the starting value of the line.

You can use the Length parameter to change the length of events (this primarily applies
to note events) to be added, measured in divisions (the left number), and ticks (the right
number). You should avoid the use of small tick values. Many MIDI devices do not respond
quickly enough when note on/note off messages are sent in quick succession, resulting
in no note being heard.

Selecting Events
You can use any of the usual selection techniques (see Using Selection Techniques), with
the following differences:

To select individual events
µ Hold Shift, and click the events.

To select several contiguous events
µ Hold Shift, and drag to select the events.

Make sure that you do not click any events. If you simply click or drag with the Pointer
tool, the selected event values are changed, so make sure Shift is held down.

To select all events on a lane
µ Click the event definition name.

To select all events on multiple lanes
µ Shift-click the appropriate event definition names.

Deleting Events
Events can be deleted individually by clicking them with the Eraser tool. The following
techniques cover deletion of multiple events.

To delete several contiguous events in a lane
µ Drag across the events with the Eraser tool.

To delete several noncontiguous events
µ Select the events you want to remove, then press Delete.
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To delete similar or equal events
1 Select one of the notes you want to delete.

2 Choose Edit > Select Similar Events or Edit > Select Equal Events (notes of the same pitch,
for example), and then delete the selected events by pressing Delete.

For more information about similar and equal events, see Selecting Similar or Identical
Objects, Regions, or Events.

You can also delete events by choosing one of the Delete MIDI Events commands from
the Hyper Editor’s local menu bar. For further information, see Deleting Notes in the Piano
Roll Editor.

Restoring Deleted Events
Accidental deletions of one or more events, or a simple change of mind or editing mistake
is an inevitable part of song creation. Fortunately, you can backtrack your edits easily in
Logic Pro. You also have the option of simply re-creating an event with the Pencil tool.

To undo the last event editing step or deletion
µ Choose Edit > Undo from the main menu (or use the corresponding key command, default

assignment:  Command-Z) immediately after making the error.

To undo or redo multiple steps
1 Choose Edit > Undo History.

This opens the Undo History window. The most recent editing step (at the bottom of the
list) is highlighted.

2 Click any entry to undo or redo all steps between the clicked and highlighted entries.

All steps are animated during this process.

Important: A Redo list is not displayed until an Undo operation has been performed.

The Redo list appears below the Undo items. The first item that can be redone is indicated
by gray text.

To undo or redo an isolated step
1 Command-click the step.

A warning dialog opens.

2 Click Apply to undo or redo the step. Click Cancel to abort the step.

This will undo or redo an isolated step without influencing all steps between the clicked
and higlighted (most recent) entries.

Changing Event Values
Events can be altered individually or as a group. When adjusted as a group, the absolute
differences between the event values remain constant.
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To alter individual event values
µ Grab the event beam (with the Pointer or Pencil tool), and drag vertically.

The current value is shown in a help tag as you drag.

To alter several contiguous event values
µ Drag across the events with the Pointer tool.

The current value is shown in a help tag as you drag across each event.

To alter the values of multiple events
1 Use any selection technique to select the events you want to edit.

2 Grab one of the grouped (and highlighted) beams, and drag vertically.

The values of all events are adjusted. If any of the beams in the group reaches the
maximum or minimum value, you can’t go any farther in that direction.

To adjust event values when one grouped event has reached an extreme value
µ If you hold Option while doing so, you can keep raising or lowering the values of all events

in the group, until the grabbed event beam reaches the maximum or minimum value.

Moving and Copying Events
Events can be moved or copied to other positions in the same, or other, lanes. When
moved or copied between lanes, the event values are retained, but are converted to the
target event definition. For example, moving several events from the Volume lane into
the Pan lane results in the volume values being used for pan position changes.

To move selected events
µ Hold Shift, and drag to the new position and lane.

As you do so, a help tag informs you of the position, event definition type, and value (if
applicable).

To copy selected events
µ Hold Option, and drag to the new position and lane.

As you do so, a help tag informs you of the position, event definition type, and value (if
applicable).
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Moving Events via Key Commands
Editing can be accelerated by assigning, and using, the following key commands to move
one or more events.

• Nudge Region/Event Position Right by SMPTE Frame

• Nudge Region/Event Position Left by SMPTE Frame

• Nudge Region/Event Position Right by 1/2 SMPTE Frame

• Nudge Region/Event Position Left by 1/2 SMPTE Frame

• Nudge Region/Event Position Right by 5 SMPTE Frames

• Nudge Region/Event Position Left by 5 SMPTE Frames

• Nudge Region/Event Position Right by SMPTE Bit

• Nudge Region/Event Position Left by SMPTE Bit

• Nudge Region/Event Position Right by Tick

• Nudge Region/Event Position Left by Tick

• Nudge Region/Event Position Right by Division

• Nudge Region/Event Position Left by Division

• Nudge Region/Event Position Right by Beat

• Nudge Region/Event Position Left by Beat

• Nudge Region/Event Position Right by Bar

• Nudge Region/Event Position Left by Bar

• Nudge Region/Event Position Right by Nudge Value

• Nudge Region/Event Position Left by Nudge Value

• Nudge Region/Event Position Right by Sample

• Nudge Region/Event Position Left by Sample

• Nudge Region/Event Position Right by 1 ms

• Nudge Region/Event Position Left by 1 ms

• Nudge Region/Event Position Right by 10 ms

• Nudge Region/Event Position Left by 10 ms

The selected events are shifted one step right (+1) or left (−1), by whatever unit is referred
to in the particular command name.

Using the Clipboard to Copy and Move Events
You can also use the Clipboard to copy and move events:

• Edit > Copy (or Command-C) copies events into the Clipboard.

• Edit > Cut (or Command-X) moves the events into the Clipboard.
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• Edit > Paste (or Command-V) pastes the events at the current playhead position, at
their original pitch.

You can also perform advanced copy and move operations within the Hyper Editor. These
allow you to directly swap events, or to merge a group of events from one section of a
region to the same, or another, region, as examples. For more information, see Advanced
Note Copy and Move Options.

Protecting the Position of Events
There are times where you will want to protect certain events from being moved. For
example, several note events may be used to trigger footstep samples that match an
actor walking down a corridor, in a video soundtrack. You have already created the music
for this scene, but have been asked to increase the tempo to match several cuts of different
camera angles in the corridor. Obviously, a change in the project tempo will move the
events, resulting in out-of-sync footstep samples. Fortunately, Logic Pro has a feature
that preserves the absolute time position of events.

To protect the position of one or more selected events
µ Choose Functions > Lock SMPTE Position (or use the corresponding key command). This

ensures that events that fall at a particular absolute time position—1 hour, 3 minutes,
15 seconds, 12 frames, for example—remain at this position when tempo changes are
made.

To unprotect the position of one or more selected events
µ Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Working with Event Definitions
The event definition determines the event type shown on each Hyper Editor lane. Events
are shown as vertical beams on each lane, aligned with a particular time position in the
Bar ruler.

There are many ways of altering the way the beams are displayed, making it easier to
create or adjust particular event types (see Changing the Grid and Beam Display). You
can also alter the grid resolution for each event definition lane in a hyper set, which is
very useful when creating drum patterns. The height and horizontal size of the lanes is
adjusted with the zoom bars.
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Selecting and Creating Event Definitions
You can select an event definition by clicking the name column with the Pointer or Pencil
tool.

This allows you to create new definitions, and to view and change the event definition
parameters in the Inspector (see Using the Event Definition Parameter Box).

You can quickly move between event definitions using the Select Next Hyper Definition
or Select Previous Hyper Definition key commands.

To select multiple event definitions
µ Shift-click each event definition with the Pointer or Pencil tool.

You can make concurrent changes to the parameters of several selected event definitions
(see Adjusting Multiple Event Definitions Simultaneously).

To create a new event definition
1 Select an event definition lane by clicking one of the names shown.

The selected lane is highlighted.

2 Choose Hyper > Create Event Definition (or use the corresponding key command, default
assignment:  Option-Command-N).

This creates a new event definition lane. The original, and all subsequent, event definition
lanes are moved downward. The new event definition parameters are identical to the
originally selected event definition.

3 Adjust the event definition parameters in the Inspector.

You can use the Auto Define feature to automatically create event definitions for specific
event types in your project.

To create an event definition for a specific event
1 Select an event type (controller #71 Resonance, for example) in one of the other MIDI

editors.

Tip: The Event List is highly recommended for this task as it can display all MIDI event
types.
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2 Select the Auto Define checkbox in the Hyper Editor’s Inspector (or use the Toggle Auto
Define key command, default assignment:  Control-A).

3 Choose Hyper > Create Event Definition in the Hyper Editor (or use the Create Event
Definition key command, default assignment:  Option-Command-N).

If the hyper set already contains a matching event definition (controller #71 Resonance,
from the example), Logic Pro won’t create a superfluous double definition. The existing
event definition is moved into the visible area of the Hyper Editor in this situation.

Note: Don’t forget to deselect Auto Define immediately after completing your input. If
you don’t, you may inadvertantly select an event type in another editor, and this will be
used as the basis for new event definitions. This could be frustrating, and surprising, when
using the Control-Return key command, in particular, to create new definitions.

To create several event definitions at once
1 Select the events that you want to create event definitions for in one of the other MIDI

editors.

As above, the Event List is recommended.

2 Do one of the following

• Choose Hyper > Create Multiple Event Definitions (or use the corresponding key
command), then click the Selected button in the dialog.

• Choose Hyper > Create Hyper Set for Current Events (or use the corresponding key
command).

This creates a new hyper set that contains event definition lanes for each of the selected
event types. This is especially useful for quick hyper set creation of all Hyper Draw (MIDI
controller) events in a region. Open the Event List, filter the note events, select all
remaining events, and use Hyper > Create Hyper Set for Current Events.

To create event definitions for all event types in a region
1 Select the region.

2 Choose Hyper > Create Multiple Event Definitions (or use the corresponding key
command).

3 Click the All button in the dialog to confirm that you want to create event definitions for
all types of events in the region.
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Tip: It’s a good idea to create a new hyper set before creating a group of new definitions.
For more information, see Creating a Hyper Set.

Copying, Deleting, and Rearranging Event Definitions
The following procedures make the creation and organization of hyper sets much easier
and faster.

To copy an event definition between two hyper sets
1 Select the event definition that you want to copy.

2 Choose Hyper > Copy Event Definition (or use the corresponding key command, default
assignment:  Control-C).

3 Switch to the destination hyper set, by choosing the hyper set name in the pop-up menu
at the top of the Inspector.

4 Choose Hyper > Paste Event Definition (or use the corresponding key command, default
assignment:  Control-V).

To delete event definitions
µ Select the event definitions, then choose Hyper > Delete Event Definition (or use the

corresponding key command, default assignment:  Control-Delete).

694 Chapter 24 Editing MIDI in the Hyper Editor



To rearrange the order of event definition lanes
µ Grab the name of the event definition you want to move, and drag it (vertically) to the

new position.

Converting Event Definitions
You can redefine an event definition (along with all events). The values of the events are
retained, but the event type is changed to the new event definition.

To convert an event definition and all events
1 Select the event definition you want to convert.

2 Do one of the following:

• Choose Hyper > Convert Event Definition (or use the corresponding key command).

• Double-click the name column of the event definition that you want to convert.

3 Choose settings in the Convert Definition dialog, and click the Convert button.
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On the left (Convert), you can see the parameters of the selected event definition, and
on the right you can define the parameters of the destination event type. The current
settings (of the source) are used as default values for the destination.

Select the Quantize Events checkbox to quantize the event positions to the Grid value
chosen in the right parameter field. If any Delay value is shown on the right, this is taken
into account by the quantization.

If you simply open the Convert Definition dialog, change the Grid value in the right field,
select the Quantize Events checkbox (and make no further alterations), the event positions
of the selected event definition lane will be quantized.

Using the Event Definition Parameter Box
You use the Event Definition Parameter box in the Inspector to alter the settings of the
selected event definition lane. The most important parameters are Status (and First Data
Byte). All display-related parameters are covered in Changing the Grid and Beam Display.

Altering the Event Status
The event status determines the type of event controlled by each event definition lane.
Click-hold the arrows to the right of the Status line, and choose one of the following from
the pop-up menu:

• Fader: To define a fader event lane. Fader event data can be used to control any possible
parameter (except channel volume and pan, which use controllers). Fader data can
also be used to create meta events.

• Meta: To define a meta event lane. Meta events are internal Logic Pro commands that
can perform tasks such as screenset switching.

• Note: If you want to define a lane for a particular note pitch (perfect for drum
programming).

• Control: If you want to define a MIDI controller lane.
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• C- Press (Channel Pressure): To define a lane for channel pressure (also known as
aftertouch, a feature of many synthesizers that adds vibrato, for example, when you
press down on MIDI keyboard keys that are already held).

• P-Press (Polyphonic Pressure): As above, but each note can be independently modulated.

• Program Change: To define a lane that is used to create and send MIDI program change
events, allowing you to switch between sounds (electric piano and clavinet, for example)
midway through a region.

• Pitch Bend: To define a lane for pitch bend information.

Important: The choice made in the Status line directly affects the behavior (and
appearance) of the First Data Byte parameter.

For example, if Note is chosen in the Status parameter line, you can use the first data byte
to determine the pitch (MIDI note number) of the selected event definition lane. If the
MIDI region is played by a mapped instrument, a pop-up menu of input note names
(drum sound names) appears here.

Using the First Data Byte Parameter
The First Data Byte checkbox and menu appears on the bottom row of the Event Definition
Parameter box in the Inspector. You use them to determine the value of the first data
byte (of the displayed event type).

First Data Byte checkbox 
and menu

The First Data Byte checkbox determines whether or not events with the defined first
data byte should be displayed (if selected), or whether the setting should be ignored (if
unselected). In the case of note events, the velocity values of all notes (regardless of pitch)
would be displayed in the relevant event definition lane.

The name of the First Data Byte parameter reflects the chosen Status parameter, as follows:

• Fader, Meta, Control, Program: Number is shown as the First Data Byte.

• Note, P-Press: Pitch is shown as the First Data Byte.

• C-Press and PitchBd: The First Data Byte is dimmed, as it has no function.
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If Control is chosen in the Status line, you can use a pop-up menu shown in the First Data
Byte parameter line to determine the controller type (controller number).

Similarly, if Meta or Fader is chosen in the Status line, the First Data Byte pop-up menu
determines the meta or fader event type (meta or fader message number).

If channel aftertouch (C-Press), or program change events (Program) is chosen in the
Status line, the First Data Byte parameter setting is ignored, and the first data byte is
displayed as a beam height.

When pitch bend data (PitchBd) is chosen in the Status line, the First Data Byte parameter
setting is also ignored, because both data bytes are used to display the beam height.

Naming an Event Definition
The name of the selected event definition is shown beside the disclosure triangle in the
Event Definition Parameter box in the Inspector. This is mirrored in the name column in
the Hyper Editor.

To name an event definition
µ Double-click the name to open a text entry field, type in a name, then press Return.

Note: If you define a named MIDI controller, or a note from a mapped instrument in the
Status and First Data Byte parameter lines, the relevant name is offered as a preset. Altering
a note name in the event definition also alters the corresponding note name in the
mapped instrument.

Delaying an Event Definition
The Inspector’s Delay parameter is very useful for drum programming (flams, for example),
as only individual event types or note numbers are affected. It is also useful for tightening
up or sliding notes in a region, without resorting to quantization.

To delay or advance the selected event definition
µ Set the Delay parameter to the desired value.

Position changes are immediately reflected by the events in the lane. New events (inserted
when a grid was active) are offset from the grid positions by the Delay parameter value.

Tip: In general, you should transmit controller data slightly before or after note events,
to improve the timing of notes. In other words, place controllers before (use a negative
Delay value) the grid positions of the notes lying exactly on the grid positions.
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Setting the MIDI Channel Number
A checkbox appears to the right of Channel. To the right of this checkbox you can set a
MIDI channel number, by dragging vertically. If you select this box (turn it on), the display
is restricted to events on the set channel. If the box is unselected, the channel parameter
is ignored, and matching events on all channels are displayed.

Adjusting Multiple Event Definitions Simultaneously
Just as you can adjust the parameters for several MIDI regions at once, you can set the
parameters of several event definitions simultaneously. Select several event definitions
in the name column, by holding down Shift and clicking them. You can also use Hyper
> Select All Event Definitions to select all event definitions, and then deselect some of
them by Shift-clicking them.

Any alterations you make in the Event Definition Parameter box affect all selected event
definitions.

Working with Hyper Sets
You can store a combination of simultaneously displayed event definitions as a hyper
set. When a hyper set is saved, the vertical zoom setting of the Hyper Editor is stored.
(This determines the number of event definitions that can be displayed simultaneously.)
You can save as many hyper sets as you need in each project.

The Hyper Set commands are available directly in the Hyper Set menu, shown in the
Inspector. Simply click the Hyper Set menu, and choose a command to create or clear
hyper sets.

Using the Default Hyper Sets
The Hyper Editor features two default hyper sets:  MIDI Controls and GM Drum Kit.

• MIDI Controls: Provides hyper definition lanes for Volume, Pan, Modulation, and several
other commonly used controller types.
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• GM Drum Kit: Offers lanes that match the note names of the General MIDI (GM) drum
map. This is perfect for creating drum (or other instrument) parts, by penciling or
drawing in note events. This is similar to the use of pattern-based drum machines,
where each beat is manually entered on a grid.

To switch between the MIDI Controls and GM Drum Kit hyper sets
µ Choose a hyper set from the Hyper Set pop-up menu in the Inspector.

This is also how you switch between any hyper sets that you create. Each hyper set can
be named, making it easy to select the one you need.

These event definition and hyper set functions allow you to customize the Hyper Editor,
with only the required MIDI event types being displayed. For example, imagine you have
recorded a synthesizer lead MIDI region. You could create a hyper set that contained
several customized event definition lanes for the note events in the region.

Each note event lane in the example is restricted to the display and control of a single
note pitch. By default, each beam that represents note events can be adjusted in level,
by dragging vertically with the Pointer tool. Within the same hyper set, you could create
two event definition lanes that control the filter cutoff and filter resonance parameters
of the lead synthesizer, allowing you to create or precisely edit filter tweaks.
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Creating a Hyper Set
To create a new hyper set, choose Hyper > Create Hyper Set (or use the Hyper Set menu,
or corresponding key command). The preset event definition in the new hyper set is the
Volume controller (#7). Any alterations that you make, such as adding or redefining event
definitions, or adjusting the vertical zoom setting, are automatically stored in the current
hyper set (as with screensets).

Choose Hyper > Create Hyper Set for Current Events (or use the Hyper Set menu, or
corresponding key command) to create a new hyper set, consisting of the currently
selected event types.

Creating a GM Drum Hyper Set
General MIDI has an established keyboard assignment pattern (a MIDI note map) for drum
and percussion sounds. This mapping standard is often followed in non-GM, GS, or XG
compliant sound modules, samplers, and synthesizers. In some cases, however, you will
need to make a few changes.

As the Hyper Editor is ideally suited for drum track creation and editing, you may want
to create a hyper set that is specifically tailored for your drum sets, including the correct
drum names and hi-hat modes.

To create a hyper set for a GM drum kit
µ Choose Hyper > Create GM Drum Set (or use the Hyper Set menu, or respective key

command).

You can change the names, positioning, and hi-hat modes of each event definition (drum
or percussion lane) in the hyper set. See Naming an Event Definition, for information on
renaming each drum sound in your kit, if it doesn’t match the GM mapping standard.

Using Hi-Hat Mode
In hi-hat mode, event definitions can be grouped together. Only one event from each
group can be played at any Bar ruler position. This function is typically used to prevent
different hi-hat notes (open, closed, pedal) from being inserted at the same time position.
This mirrors the real-world behavior of hi-hats, which can’t be simultaneously opened
and closed.

To define a hi-hat group
1 Click the dot shown to the left of a name column (kick 1, for example).

2 Click the dot shown to the left of other (adjacent) name columns (kick 2, for example).
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A dotted line links the two instrument lanes in the the left edge of the column.

3 Click the dots of each lane to turn off hi-hat mode.

All lanes in a hi-hat group must be vertically adjacent to each other. If you want to group
several events in nonadjacent lanes, simply move them by dragging the names up or
down the Hyper Editor window.

If you add an event to any lane in a hi-hat group, all existing events at this time position
are deleted.

You can create as many hi-hat groups as needed in a hyper set, but they must all be
separated by at least one line in which hi-hat mode is turned off.

Naming a Hyper Set
By default, a new hyper set is named MIDI Controls or GM Drum Kit.

To rename a hyper set
µ Click the name shown in the Hyper Set menu of the Inspector, type in the new name,

and press Return.

Clearing or Deleting a Hyper Set
Clearing a hyper set resets a hyper set to its default, containing the preset event definition
for the Volume controller.

To clear the current hyper set
µ Choose Hyper > Clear Hyper Set (or use the corresponding key command).

µ Choose Clear Hyper Set from the Hyper Set pop-up menu in the Inspector.

To delete the current hyper set
µ Choose Hyper > Delete Hyper Set (or use the corresponding key command).
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µ Choose Delete Hyper Set from the Hyper Set pop-up menu in the Inspector.

Loading a Hyper Set
You can switch the Hyper Editor display to the desired event types by loading a saved
Hyper Set.

To load a hyper set
µ Choose a hyper set from the Hyper Set pop-up menu in the Inspector.
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The Event List is the most powerful, flexible, and complete MIDI editor in Logic Pro. All
MIDI event types are displayed as an alphanumerical list in the Event List. All aspects of
events—start and end points, length, channel, and values—can be altered in this window.
You can view all events in a region, and can filter the list to restrict this view to one or
more event types, such as notes, pitch bend events, or both, for example. This makes the
selection and editing of events faster and simpler.

This chapter covers the following:

• Getting to Know the Event List (p. 706)

• Selecting and Creating Events (p. 711)

• Editing Events (p. 714)

• Deleting and Muting Events (p. 717)

• Soloing and Renaming Regions or Folders (p. 718)

• Learning About Event Types (p. 718)

• The Event Float Window (p. 724)
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Getting to Know the Event List
All functions and options are shown at the top of the Event List area. The events
themselves are shown in the list area below.

To open the Event List as a tab in the Arrange window
µ Click the Lists button at the top-right corner of the Arrange toolbar, and click the Event

tab (or use the Toggle Event List key command, default assignment:  E).

To open the Event List as a separate window
Do one of the following:

µ Choose Window > Event List (or use the Open Event List key command, default
assignment:  Command-0).
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µ Drag the Event tab, which changes to the Event List window as you drag it.

Changing the Event List View Level
By default, the Event List shows all events in the selected MIDI region.
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The Event List can also display a list of all regions (and folders) in the Arrange window.

To view a list of Arrange regions (and folders)
µ Click the Hierarchy button at the top-left corner of the Event List window.

This button is only accessible when the Event List view is showing the contents of a region
(it’s showing events, in other words).

To view the events within a region
µ Double-click the name of the region with the Pointer tool.

Its contents (the events) are shown in the list.

The Event List is not capable of showing the events of a multiple region selection. When
Content Link mode is turned on, the Event List always shows the events of the last selected
region (also when selecting multiple regions via Shift-click). In the case of a rectangular
selection, the Event List shows the events of the first selected region.

Note: It is possible to pack folders within folders in the Arrange window. Simply use the
procedures outlined above multiple times to navigate up or down through the most
complex folder hierarchy.

Filtering Event Types
When viewing events in the selected MIDI region, you can make use of the event type
buttons to filter the display. These buttons hide specific event types from the list below,
thus limiting the view to events that you want to edit.
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As a practical example of where these facilities could be used:  Imagine a lead synthesizer
solo that spans eight bars. You went crazy with the pitch bend while recording, but have
found that every pitch bend event with a value of 55 sounds out of tune with the pad
sound on another track. Filter the view so that only pitch bend events are visible, select
one of the events with a value of 55, and choose Edit > Select Equal Regions (or use the
Select Equal Regions/Events key command, default assignment:  Shift-E). All pitch bend
events with a value of 55 are selected, allowing you to simultaneously change their values,
or delete them.

Important: All selection and editing functions performed in the Event List only affect the
displayed events, which protects any invisible events from changes you may make.

To filter the event view
1 Click the Filter button to turn on Filter mode.

2 Click the the event type buttons you want to filter by (Notes, Pitch Bend, and so on).

Events that match the active buttons disappear from the list display.

Enhancing the Display of Events
The Event List display is normally restricted to one line per event. When the Additional
Info button is on, however, all information stored along with the event is also shown.
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This is particularly important for editing SysEx messages. When examining note events
in the Event List, you will also notice Rel Vel (release velocity or note off messages), which
can be edited directly.

Score layout information is also included in the list when additional info is shown. You
can edit this in the Event List if you like, but it is handled far more efficiently in the Score
Editor.

Note: The Additional Info button is only visible when the Filter button is on. Once
activated, the enhanced Event List is shown (in Filter or Create mode) until the Additional
Info button is turned off.

Viewing Events Outside the Display Area
You will often find that the number of events shown in the list exceeds the amount of
screen space. The list scrolls automatically when you click the Play button on the Transport
bar, and the event at (or nearest to) the playhead position during playback is indicated
by a white line.

Playhead position

Note: The Catch button must be turned on for the Event List to automatically scroll
through events during playback or recording.
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To view events outside the display area
Do one of the following:

µ Use the event type buttons to filter the list, thus reducing the number of displayed events.

µ Drag the scroll bar to the right of the list area.

µ Choose View > Scroll to Selection (or use the corresponding key command).

Note: When a marquee selection is active, using this key command moves the visible
section of the edit window to mirror the marquee selection.

Using the Shortcut Menu
Many selection, editing, and other commands can be accessed by right-clicking anywhere
in the Event List. Make use of this technique to accelerate your workflow.

Note: The right-click shortcut menu can only be accessed if the Right Mouse Button:  Opens
Shortcut Menu option is chosen in the Logic Pro > Preferences > General > Editing pane.

Selecting and Creating Events
You can use any of the standard selection techniques in the Event List:  individual selection
by clicking events, multiple selection by dragging, or both of these (without altering the
previous selection), in conjunction with the Shift key. Full details on all selection techniques
are discussed in Using Selection Techniques.

Tip: When selecting events with the Pointer, you should click the event name in the
Status column, to avoid any unintentional parameter alterations.

To select an event, and navigate the list, with the arrow keys
µ Press the Left Arrow key to select the previous event, or the Right Arrow key to select the

next event. Hold down the respective arrow key to scroll through the list.

To select multiple events with the arrow keys
µ Hold Shift and press the Left or Right Arrow key. Keep the arrow key held down to select

multiple events (with Shift held).

Note: If the MIDI Out button is turned on (it is on by default), every newly selected event
is played. This allows you to scroll (or play) through the list and audibly monitor events
as they are selected.

Refining Event Selection
Using the event type buttons to filter the list of displayed events makes selection faster
and easier.
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You can use these filter buttons alone, or in conjunction with, specific selection commands
available in the Edit menu and as key commands. These include:

• Select All (default key command assignment:  Command-A): Selects all visible events.

• Select All Following (default key command assignment:  Shift-F): Selects all events after
(below) the currently selected event.

Note: When a marquee selection is active, using this key command extends the marquee
selection—over all tracks within a marquee selection—to the project end point.

• Select Inside Locators (default key command assignment:  Shift-L): Selects all events that
fall within the locator boundaries.

Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.

• Select Overlapped Regions/Events: Selects all events that overlap one another. This is
usually the end of one event, and the start of the following event.

• Select Muted Regions/Events (default key command assignment:  Shift-M): Selects all muted
events. This selection command is usually a precursor for deletion (Delete).

• Select Similar Regions/Events (default key command assignment:  Shift-S): Selects all C#3
note events, for example.

• Select Equal Regions/Events (default key command assignment:  Shift-E): Selects identical
events (same event type, and value).

• Select Equal Channels (default key command assignment:  Shift-K): Selects events on the
same MIDI channel.

• Select Equal Subpositions (default key command assignment:  Shift-P): Selects events that
start at the same position.

Details on what constitutes equal or similar events can be found in Selecting Similar or
Identical Objects, Regions, or Events.

Creating Events
The Event List accepts real-time and step recording of MIDI events, as described in
Recording in Logic Pro. As with the other MIDI editors, you can also create events directly
in the Event List.

To add an event manually
1 Move the playhead to the insert position.

The current playhead position is used as the insert position if it is not moved.

2 Click the Create button.

3 Click an event type button.

The event is added at the playhead position, and is automatically selected.
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Important: Events can only be created in an existing region. If no region is selected, or
exists, on the selected arrange track, an alert appears.

To duplicate an existing event
1 Click the original (source) event name in the Status column with the Pencil tool.

2 An input box appears. Use it to enter the position for the duplicate event. If you press
Return, the duplicate appears at the same position as the original.

The Duplicate function is useful for creating a copy of an event with a different value; for
example, creating one or more notes of a particular length and velocity at the same
position as another note. You could then alter the Pitch (Num column) of the duplicate
notes to create a chord, or a new chord voicing.

To add one or more events from the Clipboard
1 Following a copy operation from another editor, choose Edit > Paste (default key command

assignment:  Command-V).

2 A position input box appears, allowing you to type in a destination position for the first
event. If you press Return, the original position of the first event is retained and used. The
relative positions of other copied events are maintained.

Important: The position input box is unique to the Event List. Pasted events are not
automatically added at the playhead position, as is the case in the graphical editors.

Copying and Moving Events
You can perform advanced Copy and Move operations within the Event List. These allow
you to directly swap events, or to merge a group of notes from one section of a region
to the same, or another, region. For more information, see Advanced Note Copy and
Move Options.
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Protecting the Position of Events
There are situations when you will want to protect certain events from being moved. For
example, several note events may be used to trigger footstep samples that match an
actor walking down a corridor, in a video soundtrack.

You have already created the music for this scene, but have been asked to increase the
tempo to match several cuts of different camera angles in the corridor. Obviously, a
change in the project tempo will move the events, resulting in out-of-sync footsteps.
Fortunately, Logic Pro has a feature that preserves the absolute time position of events.

To protect the position of one or more selected events
µ Choose Functions > Lock SMPTE Position (or use the corresponding key command).

This ensures that events that fall at a particular absolute time position—1 hour, 3 minutes,
15 seconds, 12 frames, for example—remain at this position when tempo changes are
made.

To unprotect the position of one or more events
µ Choose Functions > Unlock SMPTE Position (or use the corresponding key command).

Editing Events
The list area features several columns:  Position, Status, Ch(annel), Num(ber), Val(ue), and
Length/Info. These columns display all details of all event types. In most cases, you can
directly edit the data displayed (with the exception of the Status column, which merely
indicates the event type).

Not all columns are used for every type of event. For example, system exclusive messages
are not MIDI-channel specific, so the Ch(annel) column is unused. Channel and polyphonic
pressure messages have no length, so the Length/Info column is left blank.
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In some instances, clicking the information in the Num(ber) or Val(ue) column opens a
pop-up menu, allowing you to choose an option. For example, clicking the Num(ber)
column of a MIDI controller event (Control is shown in the Status column) opens a pop-up
menu of numbered and named standard MIDI controller types. These include Controller
numbers 3 = Solo, 7 = Volume, 10 = Pan, and so on.

Full details on the different event types, the parameters shown in the columns, and the
impact of changes—on both the event itself and other columns—is found in Learning
About Event Types.

Changing the Position and Length of Events
The units shown in the Position and Length/Info columns represent bars, beats, divisions,
and ticks. Counting begins at 1 for each unit (first bar, first beat, first division, first tick:  1
1 1 1), and continues until it is carried over to the next largest unit.

Numerical input starts from the left (which means you can simply enter the bar number,
and press Return, if you want to move an event to the beginning of a specific bar, when
typing in a value). The units can be separated by either spaces, dots, or commas, allowing
you to type 3.2.2.2 or 3, 2, 2, 2 or 3 space 2 space 2 space 2.

Note: For the sake of clarity, when the length begins with one or more zeros, a period
(“.”) is used in place of the zeros. The minimum possible length is 1 tick (. . . 1) not 0 ticks,
as simultaneously switching a note (or other event) on and off wouldn’t make sense.

To move an event in time
Do one of the following:

µ Double-click the position indicator (in the Position column), and type in a new value.
Press Return to exit the position entry field.
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µ Click-hold the specific position unit, and drag vertically. Release the mouse button when
you’re done.

If another editor, such as the Piano Roll Editor, is open, you will see the note event move
as you change the value. As soon as you alter the position of an event, the list is
automatically resorted. The currently selected event remains highlighted.

To change the length of an event
Do one of the following:

µ Double-click the length/info indicator (in the Length/Info column), and type in a new
value. Press Return to exit the length entry field.

µ Click-hold the specific length/info unit, and drag vertically. Release the mouse button
when you’re done.

If another editor, such as the Piano Roll Editor, is open, you will see the note event change
in length as you change the value.

Changing the Appearance of the Position and Length Columns
Not every project is bar/beat oriented. These View menu commands may make changing
the position and length of events much easier when you’re working with film or video,
for example.

• View > Event Position and Length in SMPTE Units: Choose to display the position and
length columns in SMPTE units.

• View > Length as Absolute Position: Allows you to make the length display show the
absolute position of the note off event, rather than its length from the note on position.

• View > Relative Position: If active, the event positions don’t refer to their absolute location
within the project, but to their relative positions within the MIDI region (their distance
from the start of the MIDI region).

Altering Event Values
Event parameter values can be changed by using the mouse as a slider or with text input,
as per changes to position or length, on the values shown in the Val(ue), Num(ber) or
Ch(annel) column.

You cannot directly alter the event type in the Status column.

To alter the event type
Do one of the following:

µ Choose Functions > Transform to open a Transform window, and transform the event.

See Editing MIDI Events in the Transform Window.

µ Add an event of the new type, and delete the original event.
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If a parameter of one of several selected events is altered, it affects the same parameter
in all events within the selection group. When you alter parameter values in a group of
selected events, the relative differences between parameter values remain unchanged.

Parameter values can only be altered until the (same) parameter value of one of the
selected events has reached its maximum or minimum value.

To override the maximum or minimum value limitation
µ Option-drag the value, or press Return to confirm a numerical input.

This allows you to continue altering a parameter value in a multiple selection, even when
one of the selected events has reached its maximum or minimum value.

To set a parameter to the same value for all selected events
µ Hold Shift-Option while using the mouse as a slider, or press Return to confirm a numerical

input.

Note: It is possible to select different event types, and simultaneously alter the Num(ber)
or Val(ue) parameters. Needless to say, this can lead to unexpected, and disastrous, results.
It is highly recommended that you make use of the event filtering buttons to hide
nonmatching event types. The enhanced selection functions may also be of use when
creating or editing groups of events.

Deleting and Muting Events
These two functions go hand in hand, since you will often want to remove events that
you have muted.

To mute or unmute a note event
µ Click a note event with the Mute tool.

A dot appears in the Status column of muted note events.

The Edit > Select Muted Regions/Events command is also available in the Event List. It
allows the selection of all muted notes in a MIDI region, making them easy to delete.

To delete events
Do one of the following:

µ Click them with the Eraser tool.

µ Select the events, and press Delete.

µ Choose one of the commands in the Functions > Delete MIDI Events menu.

• Duplicates (default key command assignment:  D): Erases all duplicate events.

• Inside or Outside Locators: Erases all MIDI events within/outside the locators.

• Outside Region Borders: Erases all MIDI events that completely fall outside the region
borders, which can happen when regions are resized.
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• Unselected Within Selection: Erases all unselected MIDI events within a selection, such
as between locators.

Soloing and Renaming Regions or Folders
Although the Solo tool can be used to hear events in isolation, it is most useful when
viewing a list of Arrange window regions or folders (Event List at Arrange-level view).

To solo a region, folder (or event)
µ Choose the Solo tool from the Tool menu, and click-hold the region or folder name (or

event) in the Status column.

The playhead automatically jumps to the beginning of the selected region or folder (or
event), and soloed playback starts.

To rename a region or folder
1 Choose the Text tool from the Tool menu, and click the region or folder name in the

Status column.

2 Type in a new name, and press Return to exit the text field.

The corresponding region or folder is renamed in the Arrange window.

Note: The Text tool has no effect on events, as these cannot be renamed.

Learning About Event Types
This section covers the different types of events that can be viewed, and changed, in the
Event List.
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Note Events
Note events are used to trigger (play) software instruments and external MIDI sound
modules or keyboards.

• Num(ber): MIDI note number (or pitch). The range is from C −2 (note #0) to G8 (note
#127). Middle C is note #60. It’s known as C3 in MIDI terminology. On some keyboards
and synthesizer modules (notably those made by Korg and Roland), the note range is
from C −1 (note #0) to G9 (#127). Middle C is called C4 on such devices. The Display
Middle C As pop-up menu in the Logic Pro > Preferences > Display pane allows you to
alter the display to match your device.

• Val(ue): Velocity of a note from 1 to 127. The zero value (0) acts as a note off message,
and cannot be used.

• Length/Info: Length of the note. Although MIDI can only transfer note on or note off
messages, Logic Pro actually stores the position and length of all notes, which makes
them easier to access musically. The note off message is generated automatically during
playback.
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Mapped Instrument Notes
If the edited MIDI region is played through a mapped instrument, the names defined for
each individual note appear in the Status column. A small note symbol to the left of each
name aids in identifying these named events as note events.

Viewing and Changing Note Release Velocity
You can edit the release velocity of a note event when the Additional Info button is active.

To view release velocity data
µ Click the Additional Info button (only available in filter mode).

Control Change Events
These event types are used to transfer MIDI controller information (modulation, sustain,
volume, and pan, for example) to software instruments or external MIDI keyboards and
modules.

• Num(ber): The number of the controller. Each MIDI controller (such as the modulation
wheel or sustain pedal) is assigned a specific Continuous Controller (CC) number (CC#1
or CC#64 respectively). This can vary from device to device. Several controllers (apart
from the two above) are defined in the same way by most manufacturers; these
standardized controllers include volume (CC#7) and pan (CC#10).

• Length/Info: Shows the name of standardized controllers defined in the MIDI
Specification.

720 Chapter 25 Editing MIDI Events in the Event List



• Val(ue): Value of the controller. Continuous controllers have a range of 0 to 127. Switch
controllers (CC#64-CC#90) transfer two states:  off (val = 0) and on (any value between
1 and 127).

Pitch Bend Events
Pitch bend events are used to continuously vary the pitch. They are usually generated
by a centered pitch bend wheel or joystick on your keyboard.

• Num(ber): Fine pitch bend division (LSB:  Least Significant Byte). Many keyboards transmit
a value of 0. If the pitch bend wheel has an 8-bit resolution, you see values of 0 or 64
in this column.

• Val(ue): The effective pitch value (MSB:  Most Significant Byte), ranging from 0 to 127.
A value of 64 corresponds to the half-way setting of the wheel.

• Length/Info: The 14-bit value is displayed in this column as a decimal figure ranging
from −8192 to 8191 (if your keyboard transmits 14-bit pitch bend data). The value in
this column can be edited in the usual ways.

Program Change Events
Program change events transmitted to connected MIDI devices are used for patch (preset
or setting) selection. These may be sounds in a synthesizer, programs in an effects unit,
or snapshots in an automated mixing desk, for example.

• Val(ue): A program number between 0 and 127.

• Some manufacturers (such as Yamaha) number the programs in their devices from
1 to 128, not 0 to 127. If you have devices that follow this numbering protocol, you
need to subtract 1 from the program number shown on the device itself, when
adding or altering a program change event.
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• Other manufacturers use various methods of dividing internal memory locations into
groups (or banks) and sounds. The most common is divisions into 8 groups of 8
sounds, each numbered 1 to 8. These devices respond to program numbers 0 to 63
by addressing storage locations 11 to 88. The instruction manuals for these devices
should contain conversion tables to assist you.

• Num(ber): Bank select. Normally you will see this symbol (-), which means no bank
select message will be sent. If you assign a number between 0 and 126, a bank select
event is sent before the program change event.

This allows you to address the different sound banks (preset, internal, card, and so on) of
connected MIDI keyboards and modules. The synthesizer must be able to recognize
controller 32 as bank select, but unfortunately this standard is not used by all
manufacturers.

If you have any problems with bank select, check your synthesizer’s manual to see whether,
and how, it responds to bank select commands.

Note: You can change the type of bank select messages sent by Logic Pro (see Custom
Bank Selects), if necessary for your devices.

Aftertouch Events
Aftertouch (or channel pressure) events are generated by a mechanical pressure sensor
beneath some MIDI keyboards. These events can be used to modulate the synthesizer
sound. All note events on a particular MIDI channel are affected. This means that applying
pressure to one note in a held chord affects all notes in the chord.

• Num(ber): This column is unused, as aftertouch events only have one data byte.

• Val(ue): Displays the amount of pressure on the keyboard (0 to 127).
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Poly Pressure Events
Poly(phonic) pressure events are generated by mechanical pressure sensors beneath
each individual key on some MIDI keyboards. The resulting sound modulation only affects
the particular note that is pressed harder (after the initial keystrike). Only a few keyboards
offer this capability.

• Num(ber): Displays the MIDI note name (C3, G4, and so on).

• Val(ue): Displays the amount of pressure on the key (0 to 127).

SysEx Events
System exclusive data (SysEx) is unique to individual MIDI devices. You can record these
events by using the dump utilities of your synthesizers. This allows you to save patch
information, or other data, outside of the MIDI device (in a Logic project or MIDI file). The
arrows in front and behind EOX are used to add or remove bytes.

Warning: Editing SysEx Events requires a thorough understanding of the data format
used by the MIDI device in question. Incorrect edits can lead to the corruption, or loss,
of sound or other data.

SysEx Data in Hex Format
You can choose whether SysEx data is displayed in hexadecimal or decimal, in the Event
List or the SysEx fader editors, with the View > SysEx in Hex Format command.

Hexadecimal digits are preceded by a $ symbol in Logic Pro.

For more information on manually programming a SysEx message, see Working with
SysEx Faders.
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Meta Events
Meta events are control messages that are specific to Logic Pro. They are used to automate
specific Logic Pro functions, and to organize and arrange Score Editor elements (particular
notation symbols and formatting) which can’t be represented by MIDI events.

The Num(ber) determines the meta event function, and Val(ue) determines the value that
is sent. You should only ever insert and edit the following Num(ber) column values in the
Event List.

• Num = 47 (Send Byte to MIDI): This sends the track instrument any byte value (Val)
between 0 and 255 ($00-$FF). As a usage example of this meta event:  if you send 246
as the byte, this is equivalent to a MIDI tuning request message. The display will show
Send Byte $F6. Only use this meta event if you know what you’re doing—if you don’t,
your sound modules and synths may start to behave very oddly.

• Num = 48 (Switch Fader): This sends MIDI events to a particular output number (Val)
on a cable switcher. You first need to connect a cable between a track instrument and
the cable switcher in question. For full details about cable switchers, see Cable Switchers.

• Num = 49 (Go to screenset): This event selects a screenset. Val determines the screenset
number.

• Num = 50 (Project Select): This event switches projects on a MIDI data filer or player. Val
determines the stored project number.

• Num = 51 (Go to Marker): When this event is sent, playback jumps to another marker.
Val determines the marker number.

• Num = 52: This meta event stops playback.

Meta events can also be generated by fader objects in the Environment.

The Event Float Window
The Event Float window provides information on the currently selected event (or region),
and can be compared to a single line of the Event List. You can edit the following
parameters in this window.

• The start point of the selected event or region in bars, beats, divisions, and ticks
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• The type or name of the selected event or region

• The recorded MIDI channel and first data byte (if an event), the name of notes, and the
second data byte (if it exists for the event type)

• Length of the selected event or region in bars, beats, divisions, and ticks

To open an Event Float window
µ Choose Options > Event Float in the main menu bar (or use the Toggle Event Float key

command, default assignment:  Option-E).

To switch the Event Float between SMPTE time and the bar/beat display
µ Click the note symbol (to the right).
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The Transform window allows you to define a set of conditions and operations that are
used to select and alter specific MIDI events.

This chapter covers the following:

• Getting to Know the Transform Window (p. 727)

• Choosing and Using Transform Sets (p. 728)

• Learning About the Transform Presets (p. 729)

• Using the Transform Window Parameters (p. 740)

• Creating Your Own Transform Sets (p. 746)

• Importing Transform Sets From Other Projects (p. 747)

• Usage Examples (p. 747)

Getting to Know the Transform Window
The Transform window is so-named because it transforms MIDI events—based on
conditions, operations, and values you choose—into different types of events, or events
with different values.

The Transform window is extremely powerful, and is the ideal tool for edits that would
otherwise be impossible (or at least, incredibly tedious). For example, imagine an orchestral
project that has been sent to you for editing. The individual violin and viola parts were
recorded with a different string library, and feature aftertouch information (in 200 MIDI
regions) that introduces a weird pitch modulation, and some sample layer switching
artefacts when played with your string samples. After looking at this aftertouch
information, you discover that only a small range of values are causing the problem. You
have a few options:  edit your sampler instruments, manually strip out all aftertouch
information (region by region, or globally, thus losing the performance benefits that the
aftertouch information provides) or alter the problematic values in the Transform window.
Option three sounds like the way to go.
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A number of preset transform sets are available for many common editing tasks. These
may be all you’ll ever require, but should the need arise, you can freely create and save
your own transform sets, and recall them later.

Tip: The Environment contains a similar transformer object that you can use for real-time
transformations of MIDI events. For details, see Transformer Objects.

To open the Transform window
Do one of the following:

µ Choose Window > Transform from the main menu bar (or use the Open Transform key
command, default assignment:  Command-4).

µ If you want to transform events (that you have selected in one of the MIDI editors) choose
a preset from the Functions > Transform menu.

You can certainly choose the Window > Transform command while you are in a MIDI
editor, but you will need to manually select a preset.

Choosing and Using Transform Sets
At the top-left corner of the Transform window you’ll find the Presets menu. The first 17
items in the menu are write-protected presets. These presets provide templates for
common editing tasks, such as creating crescendos or fixing note lengths.

You can temporarily change the used parameters of a preset, but all changes are discarded
when you exit the preset.
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Depending on your needs, it may be worthwhile spending some time creating your own
transform sets. These can be freely configured and saved as part of a project. (Doing this
in your template projects makes your transform sets available in all projects.) Your
transform sets will appear at the bottom of the Presets menu (see Creating Your Own
Transform Sets).

To use a transform preset
1 Select the MIDI regions or events that you want to transform.

2 Click the arrow button to the right of the Presets menu, and choose a transform set from
the pop-up menu.

Note: You can create a new transform set by choosing **Create Initialized User Set!** in
the Presets menu. For details, see Creating Your Own Transform Sets.

3 In the Mode menu, choose how you want to transform the selected events within the
regions.

4 Set the selection conditions.

5 Define the operations you want to perform.

Note: You can deselect the “Hide unused parameters” checkbox (turn it off ) to show all
conditions and operations, allowing you to make more advanced choices.

6 Do one of the following:

• Click the Select Only button to select all events that meet the selection conditions. The
events will not be transformed. You can use this option to refine your selection, and
make sure that your conditions only affect the events that you truly want to transform.

• Click the Operate Only button to transform all selected events, in accordance with the
operations settings. (The selection conditions have no effect.) This is useful if you want
to edit events that you’ve already selected manually.

• Click the Select and Operate button to select all events that match the conditions, and
transform them as per the Operations settings.

Note: The number of selected regions and events (that match the conditions) are
displayed above the selection and operation buttons.

Learning About the Transform Presets
This section describes the purpose of the 17 transform presets, and provides tips on their
use.
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Random Pitch
Sets a random pitch for note events.

Change the Pitch condition values to alter your selection range.

Random Velocity
Sets a random velocity for note events.

Change the Velocity condition values to alter your selection range.
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Random Pitch, Velocity, Length
Sets a random pitch, velocity, and length for note events.

Change the Pitch, Velocity, and Length condition values to alter your selection ranges.

Crescendo
Used to gradually increase the velocities of a group of notes from low to high values (or
vice versa—decrescendo or diminuendo).

• Select the area (Position column) that contains the note events that you want to perform
a crescendo on.

• Set the velocity values in the Operations area, ranging from 1 to 127.
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• If you want a less dynamic crescendo, set a smaller value range.

• To perform a diminuendo, set a higher value in the top Velocity field, and a lower value
in the bottom field.

Scale 14 Bit PitchBd
Scales pitch bend data, keeping the 14-bit information intact. The length of pitch bend
events is expressed as a decimal value ranging from −8192 to 8191, and this is the 14-bit
information that is retained.

• Choose the multiplication factor for the fine pitch bend (LSB) and effective pitch values
(MSB) in the top value field shown in the Operations area.

• Set the (14 bit) value in the lower field, which is then added to the scaled (multiplied)
events.

Double Speed
Doubles the tempo by halving event positions and lengths. By default, the Div(ision)
value fields for the Position and Length operations are set to 2.0000.

Change the values in both fields to 4.000 to quadruple the tempo.
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This preset is a great creative option for drum regions. The following example assumes
that a “four-on-the-floor” kick, snare, hi-hat, and other percussion sounds region is being
viewed in the Hyper Editor.

To experiment with the Double Speed preset in the Hyper Editor
1 Click the name column of one of the drum sounds.

This selects all note events of a particular pitch in the region.

2 Change the Length field to a value that does not match the Position field, or vice versa.

3 Repeat the steps with other drum or percussion sounds.

This can lead to interesting polyrhythms that you may not have thought of.

As you can see from this example, you can use the same transform operation multiple
times on the same region, and can also combine the different transform presets to achieve
an end result, by using them one after the other.

Half Speed
Halves the tempo by doubling event positions and lengths. The Mul(tiply) value fields
for the Position and Length operations are set to 2.0000 by default.

Set both Mul operation value fields to 1.5000 to reduce the tempo by around one-third.
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Humanize
Adds a random value to the position, velocity, and length of selected note events. This
preset is useful on rhythmic parts, such as clavinet or piano accompaniments, and drum
and percussion regions (or events). It can add life to strictly quantized material, or notes
that were manually entered (see MIDI Step Input Recording).

Alter the values for Position, Velocity, or Length to increase or decrease the random factor
for each of these event parameters.

Reverse Position
Reverses the positions of events (usually notes) within a section.

Change the Position condition values to alter your selection range.
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Reverse Pitch
Inverts the pitch of all note events.

Change the Flip operation value to set a pivot point note number, around which note
event pitches will be reversed.

Transposition
Transposes all note events.

• Change the Add operation value to the desired amount (in semitone steps).

• You can achieve downward transpositions by setting a negative value in this field.
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Exponential Velocity
Alters the scaling of the velocity curve. This preset is of particular use on software or MIDI
instrument parts. Velocity is generally used to control the initial volume of instruments,
but is often used to trigger filter envelopes, making the sound brighter or darker.
Transforming regions is much faster than changing the velocity scaling or filter parameters
of your MIDI or software instruments.

Change the Velocity value field in the Operations area to change the velocity curve. This
is instantly reflected in the map area below.
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Velocity Limiter
Limits the velocity to a maximum value. This is perfect for transforming instrument parts
that are too strident, by limiting the velocity.

Change the Max operation field value to limit the velocity to a maximum value. This is
instantly reflected in the map area below.

Fixed Note Length
Creates constant note lengths. Useful on many instruments, particularly drums and other
rhythmic parts, such as pianos, clavinets, and basses.

Change the Length value field in the Operations area to change the lengths of all selected
events to the chosen length. Both shorter and longer events are changed to match the
length value you have defined.
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Maximum Note Length
Sets the maximum length of all note events.

Change the Length value field in the Operations area to define the maximum note length.
Existing note lengths—which are shorter than the length defined here—are retained.
Events that are longer than the defined value are shortened.

Minimum Note Length
Sets the minimum note length.

Change the Min value field in the Operations area to define the minimum note length.
Existing note lengths—that are longer than the length defined here—are retained. Note
events that are shorter than the defined value are increased in length.
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Quantize Note Length
Quantizes the note length. This preset actually quantizes the note end position.

Change the Length value field in the Operations area to define the length that note end
positions will be quantized to.
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Using the Transform Window Parameters
This section discusses the use of the individual Transform window elements, providing
an overview of what each option does. Examples toward the end of the chapter (see
Usage Examples) give you an idea of how each can be used, but these are only the tip
of the iceberg. Ultimately, your imagination and creativity are the only restrictions on
how MIDI events can be manipulated in the Transform window.

Mode menuPreset menu

Operations area

Selection Conditions area

Map

Defining Global Parameters
These parameters globally affect the Transform window appearance and operating mode.

• Mode menu: Choose one of the following menu options to determine how events are
transformed.

• Apply operations to selected events: Choose this mode to apply the operations to all
selected events. The selected events are determined by the selection conditions.

• Apply operations and delete unselected events: Choose this mode to transform the
selected events, and delete all unselected events. Only events that match the selection
conditions remain after the transform operation. This mode allows you to use the
Transform window as a programmable filter, where only events that match the
conditions survive.
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• Delete selected events: Choose this mode to delete selected events. This mode allows
you to use the Transform window as a programmable erase function. All events that
match the conditions are deleted, and all other events remain unchanged. The
operation settings are irrelevant in this mode.

• Copy selected events, then apply operations: Choose this mode to retain the selected
events in their original form, copy them, and apply the operations.

• Presets menu: Choose one of the transform presets or one of your own transform sets.

• “Hide unused parameters” checkbox: Hides all unused menus in the Selection Conditions
and Operations areas. This provides a better overview of the settings in use. It also
prevents you from making accidental alterations.

Defining Selection Conditions
You can define conditions that determine which events are selected for transform
operations. This is done in the Selection Conditions area of the Transform window.

Each column represents a different MIDI event parameter.

• Position: Determines the time position of the event, referenced to the start point of
the MIDI region (not the start point of the project).

• Status: Determines the event type.

• Channel: Recorded MIDI channel of the event

• Data Byte 1/Pitch: First data byte (controller number) or note pitch

• Data Byte 2/Velocity: Second data byte (controller value) or note velocity

Note: The parameters displayed in the Data Byte fields are dependent on the chosen
Status menu setting. Certain Status menu settings will not show the Data Byte fields
at all.

• Length: Length of the note or event

• Subposition: Time position of the event, within a bar

The condition is considered to be fulfilled when an event matches the defined effective
range, and values, of all event parameters. These ranges and values are determined in
the pop-up menus and fields found under each of the event parameter columns.

To choose the event type
µ Click the Status pop-up menu to determine which events will be selected. You have a

choice of two settings:

• All: All event types fulfill the condition.

• =: A further pop-up menu is displayed below the Status pop-up menu, in which you
can define the desired event type. These include note, poly pressure, control change,
program change, channel pressure, pitch bend, meta, and fader.
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To set all other selection conditions
µ Click the pop-up menus (in each column that is needed) to define the selection criteria

for events.

One or two value fields appear below the pop-up menu, unless Map is chosen. You can
assign one of the following value conditions for each of the parameter columns:

• “=”: The event must be equal to the value in the field, for the condition to be fulfilled.
For example, only note C#3 events will meet the condition.

• Unequal: The event must not be equal to the value in the field, for the condition to be
fulfilled. All events that are not C#3 will meet the condition, for example.

• Smaller/Equal (<=): The event value must be less than, or equal to, the value in the field
(a note velocity less than, or equal to 98, for example) for the condition to be fulfilled.

• Larger/Equal (>=): The event value must be larger than, or equal to, the value in the
field (a note pitch higher than, or equal to C#3, for example), for the condition to be
fulfilled.

• Inside: The event must fall within the value range (of event positions or note pitches,
for example) of both fields, for the condition to be fulfilled.

• Outside: The event must be outside the value range (of event positions or note pitches,
for example) of both fields, for the condition to be fulfilled.

• Map: Most conditions are numerical relationships, and the condition is met if the
incoming MIDI event value satisfies the condition. The last condition, Map, works a
little differently. Two numerical parameters are specified, and the incoming value is
first converted by the map, to create a mapped value. The mapped value is then
compared with the two parameters to see if it falls inside them. Incoming events with
a mapped value that falls within the range will fulfill the condition—all other events
will not fulfill the condition (see Using the Map).

To set the values for a selection condition
µ Use the mouse as a slider, or type a value directly into the field.

Defining Operations
The Operations area is used to define the changes you want to make to events that meet
the selection conditions. As with the selection condition pop-up menus, you choose an
operation in the appropriate event parameter columns. One or two value fields may
appear, depending on the chosen operation.

To define the operation for the status event parameter column
µ Click the pop-up menu, and choose one of the following operations for the Status

condition:

• Thru: The event type passes through unaltered.
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• Fix: The event type is altered. Choose a new event type in the pop-up menu that
appears below the Status Operations menu. Choices include fader, meta, note, poly
pressure, control change, program change, channel pressure, or pitch bend. This
effectively converts one type of event to another.

Note: When you convert note events, two events are created:  one for the note on
event, and one for the note off event.

• MapSet: Choosing this setting means that events that match the Status condition (note
events, for example) are used to control the map of a subsequent operation—in the
Channel, Data Byte 1, Data Byte 2, and Length columns.

• The Data Byte 1 value selects the position in the map.

• The Data Byte 2 value determines the value at this map position.

Internally, Logic Pro sends a meta event pair:  #123 for the position, and #122 for the
value at this position. These types of meta events can also be created in other ways.

To define the operation for all other event parameter columns
µ Choose one of the following operations for the Channel, First or Second Data Byte, and

Length columns (as required). One or more value fields will appear below the respective
operations pop-up menus.

• Thru: The event passes through unaltered.

• Fix: Fixes the event parameter to the set value. You could use this to set the pitch of
all note events to a specific note value, making it easy to convert a bass groove into a
hi-hat pattern, for example.

• Add: Adds the value to events. For example, a value of 8 could be added to all incoming
note velocity events, thus making the notes louder.

• Sub: Subtracts the value from events. You could use this to reduce all controller 10
(Pan) events, thereby narrowing the stereo spread of an electric piano part, for example.

• Min: Parameter values lower than the defined value are replaced (by this value). Larger
parameter values are not altered. You could use this to replace all note velocity messages
below 45, thereby reducing the dynamic range of a MIDI region—or put another way,
making the soft notes louder.

• Max: Parameter values that exceed the set value are replaced by it. Smaller event
parameter values remain unaltered. This could be used to restrict filter resonance
modulation events above a value of 100, for example, resulting in a softer filter sound.

• Flip: All parameter values that match the conditions are reversed around a pivot point
(the value defined here). Events above this value are moved by the same distance
below it and vice versa. For example, you could move a note from E3 to G#2, if the
pivot point value was set to C3. Effectively, the E3 event, which is 4 (pitch) values above
the C3 pivot point is flipped to 4 values below (G#2). This can also be used to reverse
selected note positions around a particular bar or beat, as another example.
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• Mul: The parameter value is multiplied by the set value (accurate to four decimal places).
The effect, and use, of this operation is best illustrated by the Half Speed preset.

• Div: The parameter value is divided by the set value (accurate to four decimal places).
The effect, and use, of this operation is best illustrated by the Double Speed preset.

• Scale: The parameter value is multiplied by the top value, and the bottom value is then
added. This is a combination of Mul and Add. If you enter a negative number here,
values can be subtracted from—rather than added to—the value resulting from the
multiplication.

• Range: Parameter values outside the set value range are replaced by the values of the
(range) limits (combination of Min and Max).

• Random: Random values are generated within the set limits.

• +-Rand.: A random value between zero and the set value (positive or negative) is added.

• Reverse: The parameter value is reversed within its value range (no value can be set
here).

• Quantize: The parameter value is quantized to a multiple of the set value.

• Qua & Min: Like Quantize, but the quantization does not fall below the set value (a
combination of the Quantize and Min functions, with the same set value).

• Expon.: The parameter value is scaled exponentially. The extreme values (0 and 127)
remain unaltered. The set value determines the shape of the curve. Positive values
result in the exponential scaling of data (increasing input values remain lower for longer,
and then rise quickly), and negative values result in the logarithmic scaling of data
(decreasing input values remain higher for longer, and then drop off more quickly).

• Crescendo: This only works if the Inside Position selection condition is selected
(crescendos need start and end points). Crescendo creates a smooth alteration of the
current parameters, between the set value boundaries.

• Rel.Cres: This only works if the Inside Position selection condition is selected. The effect
is similar to that achieved by Crescendo, but the previous values of the parameters
being altered are taken into account when the crescendo is created, preserving the
relative feel of the original.

• Use Map: The set map will be used when this operation is selected (see Using the Map).

To set the values for an operation
µ Use the mouse as a slider, or type a value directly into the field.
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Using the Map
128 vertical bars reflect the full MIDI value range (from 0 to 127), and provide a visual
overview of the transformation.

Essentially, each bar represents a particular MIDI value, which can be mapped to a different
value. The type of event, and operations, are determined in the Selection Conditions and
Operations areas.

For example:

• Each of the bars could represent a MIDI note number (from 0 to 127) value.

• By default, there is a 1:1 relationship for each bar, where value 1 = value 1, value 15 =
value 15, and so on, throughout the 128 bars. Applying this to MIDI note numbers,
bar 60 = C3 (middle C), bar 61 would represent C#3, bar 62 = D3, and so on.

The default and mapped values are shown in the two fields to the lower left of the map
area.

• You can alter these values directly in the fields, or by dragging any of the bars vertically.
As you do so (using either method), the corresponding field or bar is updated.

• If you alter the bar 60 (middle C) value to show 72 in the “mapped to” field, this value
is remapped accordingly when the transform operation is applied.

This results in all MIDI note number 60 messages being transformed into MIDI note
number 72 messages (effectively transposing all C3 notes to C4).

Some Points to Note About the Map
The map is only visible when chosen in one of the Operations pop-up menus. Appropriate
selection conditions must also be set, or the map does not appear.

The map is universal, which means that it remaps one MIDI value to another.

It does not know what type of MIDI data is sent to it. It is only concerned with the value
of the data.

This means that one map can be used to simultaneously alter the pitch, velocity, and
length values of incoming note events, for example.
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Exchanging Parameter Values
You can reroute the value of each of the three event parameters—Channel, Data Byte 1,
and Data Byte 2—to the value of a different parameter from this group.

To replace the source (Condition value) with the target parameter value
µ Click the dots on the lines between the Selection Conditions and Operations areas.

Repeated clicks cycle between different targets.

Note: The value is exchanged before the operation is performed.

Creating Your Own Transform Sets
You can store your own transform settings in a user transform set.

To create a user transform set
1 Choose **Create Initialized User Set** from the Presets pop-up menu.

2 Set conditions.

3 Set operations.

4 Select the “Hide unused parameters” checkbox. This helps to avoid changes to conditions
and operations that aren’t required for (or may disturb) your transform set.

5 Click New Parameter Set (Number) in the Presets menu. Type in a new name for your
transform set.
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This transform set now appears at the bottom of the Presets list in all Transform windows
for this project. You should consider saving your user transform sets in one or more
template projects. This way, they will always be available to you in all future projects.

Tip: Renaming an existing transform set creates a new transform set that is identical to
the original. The existing (source) transform set is retained.

Importing Transform Sets From Other Projects
You can import transform sets from other projects, allowing fast access to a transform
preset you created earlier. This function also makes it easy to add existing transform sets
to new template projects.

To import all transform sets from another project
1 Choose File > Project Settings > Import Project Settings from the main menu bar (or use

the corresponding key command, default assignment:  Option-Command-I).

2 Deselect all checkboxes—except Transform Sets—at the bottom of the Import Settings
dialog.

3 Browse to, and select, the project that contains the transform sets you want to import.

4 Click the Open button, and the transform sets are imported into the current project. The
names of these imported transform sets are retained, and added to the bottom of the
Presets list.

5 Repeat the steps above to import transform sets from other projects.

6 Save your project or template.

Usage Examples
The following section provides several usage examples for the Transform window.
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To add a mod wheel controller event (#1) with a value that matches the note’s velocity
1 Choose the following settings in the Transform window:

• Mode menu:  Copy selected events, then apply operations.

• Selection Conditions area:  Set Status to Note.

• Operations area:

• Set Position to Add and enter a value of 1 in the field below it.

• Set Status to Fix and choose Control in the menu below it.

• Set Pitch to Fix and enter a value of 1 in the field below it. This means “the first data
byte receives the value of 1” (the first data byte defines the controller number for
controller events, and mod wheel events happen to be #1).

Note: When you convert MIDI note events to controller events, two controller events
are created:  one for the note on event, and one for the note off event.

If you analyze these settings, you’ll see that all note events are selected for operation.
A copy of each is made, then moved 1 tick later than the original, and converted to
CC#1 (mod wheel), with a value that corresponds to the velocity of the original note.
This is because the second data byte (Vel) is left unaltered.

2 Click Select and Operate.

This is automatically placed one tick after each note start and end, thus avoiding potential
conflicts with the note events themselves.

To create a transform set that fixes all note velocities to a defined amount
1 Select **Create Initialized User Set** from the Presets pop-up menu.

2 Set the Status menu in the Selection Conditions area to “=.”

3 Choose Note from the pop-up menu below.

4 Choose the Fix setting in the Velocity menu of the Operations area.

5 Change the amount to 127 in the value field below the Velocity menu.
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To convert MIDI note events to MIDI controller 1 events
1 Choose the following settings in the Transform window:

• Mode menu:  Apply operations to selected events.

• Selection Conditions area:  Set Status to Note.

• Operations area:

• Set Status to Fix, and choose Control in the menu below it.

• Set Pitch to Fix, and enter a value of 1 in the field below it.

Note: When you convert MIDI note events to controller events, two controller events
are created:  one for the note on event, and one for the note off event.

2 Click Select and Operate.

To randomly change the pitch of MIDI note events
1 Choose the following settings in the Transform window:

• Mode menu:  Apply operations to selected events.

• Selection Conditions area:  Set Status to Note.
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• Operations area:  Set Pitch to +-Random, and set the max deviation from the root note
in the field below. If you set a value of 12, you’ll achieve a deviation of one octave up
and one down (two octaves, around the root note, in other words).

2 Click Select and Operate.

Tip: To restrict the randomness to one direction—up or down, as opposed to both—use
the other Random Option, which limits the range that notes fall into.

To make note selections for edit operations
1 Choose the following settings in the Transform window:

• Selection Conditions area:

• Set Status to Note.

• Set Position to Inside, and choose the range.

2 Click the Select Only button.

All notes in the defined range are selected for you to cut, move, or otherwise modify.

To delete volume events (MIDI CC#7) from a MIDI region
1 Choose the following settings in the Transform window:

• Mode menu:  Delete Selected Events.

• Selection Conditions area:

• Set Status to Control.

• Set Data Byte 1 to a value of 7.
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2 Click Select And Operate.

To delete all controller events from a region
1 Choose the following settings in the Transform window:

• Mode menu:  Delete selected events.

• Selection Conditions area:  Set Status to Control.

2 Select the MIDI region you want to transform, then click Select and Operate.

To create an ascending pitch pattern from notes of one pitch
1 Choose the following settings in the Transform window:

• Mode menu:  Apply operations to selected events.

• Selection Conditions area:

• Set Status to Note.

• Set Position to Inside, and define the range. (Cresc. only works if the Inside Position
selection condition is chosen, as crescendos need start and end points.)

• Operations area:  Set Pitch to Cresc., and enter a value of D0 and G6 in the fields below.

2 Click Select and Operate.
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The Mixer is an area in Logic Pro where you refine the sound of each musical element in
your project, creating a unified mix. This chapter covers how to control the sound, level,
and positioning of channel strip signals in the Mixer. It also briefly discusses automation,
an integral part of Logic Pro’s mixing features. For details, see Working with Automation.

This chapter covers the following:

• Opening the Mixer (p. 754)

• Getting to Know the Mixer (p. 756)

• Understanding Channel Strip Types in the Mixer (p. 757)

• Understanding Channel Strip Controls in the Mixer (p. 758)

• Understanding the Basic Mixing Stages (p. 760)

• Working with Mixer Groups (p. 761)

• Muting Channel Strips (p. 765)

• Soloing Channel Strips (p. 766)

• Setting Channel Strip Levels (p. 767)

• Setting Pan, Balance, or Surround Position in the Mixer (p. 772)

• Adding and Routing Effects in the Mixer (p. 773)

• Controlling Signal Flow in the Mixer (p. 776)

• Using Surround Panning in the Mixer (p. 784)

• Using Binaural Panning in the Mixer (p. 785)

• Working with MIDI Channel Strips in the Mixer (p. 791)

• Customizing the Mixer (p. 795)

• Using the I/O Labels Window (p. 800)

• Adjusting Mixer Channel Strips in Record or Playback Mode (p. 801)

• Copying Entire Mixer Setups (p. 801)

• Adjusting Elements of Multiple Mixer Channel Strips (p. 802)

• Navigating Within the Mixer (p. 805)
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• Assigning Colors to Channel Strips in the Mixer (p. 806)

• Renaming Tracks in the Mixer (p. 806)

• Linking Control Surfaces to the Mixer (p. 807)

Opening the Mixer
There are several ways to open the Mixer in Logic Pro.

To open the Mixer as a pane in the Arrange window
µ Click the Mixer button at the bottom of the Arrange window (or use the Toggle Mixer

key command, default assignment:  X).

To open the Mixer as a separate window
Do one of the following:

µ Choose Window > Mixer (or use the Open Mixer key command, default
assignment:  Command-2).

754 Chapter 27 Mixing



µ Drag the Mixer button, which changes to the Mixer window as you drag it.
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Getting to Know the Mixer
The main elements of the Mixer are as follows:

Channel strips and 
channel strip controls View buttons Filter buttons

• Channel strips: Use to process audio or MIDI information that is routed from Arrange
tracks. For more information, see Understanding Channel Strip Types in the Mixer.

• Channel strip controls: Use to adjust the level and other aspects of the audio signal
played through the channel strip. For details about the different controls, see
Understanding Channel Strip Controls in the Mixer.

• View buttons: Use to switch the Mixer between the Single, Arrange, and All views,
limiting the Mixer view to channel strips required for the task at hand. For details, see
Customizing the Mixer.

• Filter buttons: Use to filter the display of specific channel strip types. For more
information, see Using Filter Buttons in the Mixer.
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Understanding Channel Strip Types in the Mixer
The Mixer displays the following channel strip types:

Audio channel strips MIDI channel strips Master channel strip

Instrument channel strips Aux channel strips Output channel strip

• Audio channel strips: Control the playback and recording of audio signals on audio
tracks. All data on the audio track is automatically routed to the audio channel strip
assigned in the Arrange track list.

• Instrument channel strips: Allow you to use and control software instruments. Software
instrument plug-ins are inserted into the channel strip’s Instrument slot. The instrument
channel strip can then be driven by a recorded MIDI region, or by direct MIDI
input—playing your MIDI keyboard. For details about instrument channel strips, see
Working with Instruments.

• Aux (Auxiliary) channel strips: Used for a variety of signal routing purposes. They are
used to set up send returns, where a channel strip signal is routed to an aux channel
strip for effects processing. Aux channel strips are also used for grouping purposes and
for distributing a signal to multiple destinations via sends. There are several ways to
create aux channel strips. For details, see Creating Aux Channel Strips in the Mixer.

• Output channel strips: Represent the physical audio outputs of your audio interface.
These channel strips are used to adjust the overall level and stereo balance—or pan
position, in the case of mono output channel strips—of all audio, instrument, or aux
channel strips routed into them. The number of available output channel strips is
determined by the audio interface in use.
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• Master channel strip: A global level control for all output channel strips. The master
channel strip changes the gain of all output channel strips without affecting the level
relationships between them. This is very helpful as a proportional output volume control
and is particularly useful in Logic Pro surround mode where you can use it to create
fades in the complete surround mix.

• MIDI channel strips: Control external MIDI tracks. MIDI data on these tracks is routed to
a MIDI output port and channel, for control of MIDI sound modules and keyboards. For
details, see Working with MIDI Channel Strips in the Mixer.

Note: Additional channel strip types, such as bus and input channel strips, can be created
and used. However, their inclusion is primarily for compatibility with projects created in
earlier versions of Logic Pro.

Understanding Channel Strip Controls in the Mixer
The controls displayed on a channel strip vary according to the channel strip type:

Channel Strip Settings 
menu

Channel EQ

Input slot

Volume fader

Send level knob

Group slot
Peak level display

Level meter

Solo button
Record Enable button
Input Monitoring button

(Input) Format button

Automation Mode menu

Mute button

Bounce button

Output slot

Pan/Balance knob

Insert slots

Send slots

• Channel Strip Settings menu: Allows you to load and save the entire routing configuration
of a single channel strip, including all loaded plug-ins and settings. For details, see
Working with Channel Strip Configurations.
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• Channel EQ: Allows you to add an EQ effect to sculpt the sound of the channel strip
signal before applying other effects. You double-click the EQ area to insert the
Channel EQ in the first Insert slot.

• Insert slots: Allow you to insert up to 15 effect plug-ins into each audio, instrument,
aux, and output channel strip.

• Send slots: Used to route a channel strip’s signal to an aux channel strip. Sends are
commonly used to apply the same effect or effects to several signals.

• Send level knob: Used to control the amount of signal sent to an aux channel strip. This
knob appears when a Send slot is activated.

• Input slot: Sets the channel strip’s input source. Depending on the channel strip type,
it can be a physical input, a bus, or a software instrument plug-in—in this case it is
known as an Instrument slot.

• Output slot: Sets the channel strip’s output path. It can be a physical output or a bus.

• Group slot: Controls a channel strip’s group assignment and provides access to the
Group Settings window.

• Peak level display: Updates during playback to show the highest peak level reached.

• Pan/Balance knob: On a mono channel strip, the Pan/Balance knob controls the position
of the signal in the stereo image. On a stereo channel strip, it controls the relative level
of the left and right signals at their outputs.

• Level meter: Displays a channel strip’s playback or input monitoring level.

• Volume fader: Sets a channel strip’s playback or monitoring volume.

• Solo button: Solos and unsolos the channel strip.

• Mute button: Mutes and unmutes the channel strip.

• (Input) Format button: Defines a channel strip’s input format (mono, stereo, or surround).
For details, see Setting Channel Strip Input Format.

• Input Monitoring button: Allows you to hear incoming audio on audio tracks that are
not armed for recording. See Enabling Software Monitoring for Recording.

• Record Enable button: Arms a channel strip for recording.

• Bounce button: Bounces the output of any output channel strip to an audio file.

• Automation Mode menu: Sets a channel strip’s automation mode.

Tip: You can hide or show channel strip elements in the Mixer (EQ Thumbnails, Inserts,
Sends, I/O, Type and Number Label, Track Name, Track Number, Control Surface Bars,
Notes) by disabling and enabling their settings in the View menu.
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Understanding the Basic Mixing Stages
Although there are no rules for mixing—except those learned from experience and a
good ear—mixing generally takes place in the stages listed below. The structure of the
sections in this chapter follows the same basic workflow. You may, however, find yourself
moving back and forth between stages as you work on the mix.

Stage 1: Making Preparations
Take some time to prepare and preview your arrangement before you start mixing.

• Preview the tracks in your arrangement to see if you can group some of them in a
logical manner. If you have lots of drum tracks, for example, it can be useful to group
these tracks and link some of their parameters, which you can then adjust for the whole
group at once. For details, see Working with Mixer Groups.

• Preview the tracks in your arrangement using the mute and solo functions. See Muting
Channel Strips and Soloing Channel Strips.

Stage 2: Setting Volume Levels
Set the relative levels for each channel strip, to control the volume relationships between
your project’s parts. See Setting Channel Strip Levels.

Stage 3: Setting Pan, Balance, or Surround Position
Set the pan/balance/surround for each channel strip, to control their positions in the
stereo or surround field. See Setting Pan, Balance, or Surround Position in the Mixer.

Stage 4: Adding and Routing Effects
After the basic sound and levels are the way you like them, you can add some effects,
such as reverb or chorus, to your musical parts. You also need to look at how you route
your audio to these effects. See Adding and Routing Effects in the Mixer.

Stage 5: Controlling Signal Flow
There are many ways to control the signal flow in your mix, using inputs/outputs, aux
channel strips, output channel strips, multiple instrument outputs, and so on. See
Controlling Signal Flow in the Mixer.

Stage 6: Automating the Mix
Some parts of your project may benefit from real-time changes to levels, effects, or
instrument settings. This is best achieved with track automation. See Working with
Automation.

Stage 7: Bouncing the Project
The last phase—which is not a mixing task, per se—is to render or bounce your project
to one or more files. See Bouncing Your Project.
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Working with Mixer Groups
Prior to mixing, you may find it useful to define some logical channel strip groups. Logic Pro
allows you to create a maximum of 32 groups and it’s possible for a channel strip to be
a member of multiple groups. You could, for example, group all drum channel strips
under one drum group. This would enable you to control the group meters (volume, pan,
and so on) using a single control, while still maintaining the relative parameter values of
each channel strip.

Note: Another way to do this is to create subgroups using aux channel strips. For more
information, see Creating Mix Subgroups.

Getting to Know the Mixer Group Settings
You use the Group Settings window to define the behavior of each group.

To open the Group Settings window
Do one of the following:

µ Assign a channel strip to an inactive group.

µ Click the Group slot of a channel strip, then choose Open Group Settings.

Note: Clicking the disclosure triangle in the Group Settings window hides or reveals the
settings. You can also resize the window, both vertically and horizontally.
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The Group Settings window contains the following settings:

• “Groups active” checkbox: Enables all groups.

• On checkbox: Enables a particular group.

• Name field: Double-click to enter the name of the selected group.

• H checkbox: Hides all tracks belonging to a particular group.

Note: If the Hide Track buttons of grouped tracks are in different states, the H checkbox
displays “–”.

• Editing (Selection) checkbox: Selecting a region in the Arrange area selects the same
horizontal region range of all channel strips in the group.

• Phase-Locked Audio checkbox: Defines whether an edit group is phase-locked or
independent when quantizing audio.

• Automation Mode checkbox: Changing the automation mode of one channel strip
changes the automation mode of all channel strips in the group.

• Volume checkbox: Changing the Volume fader of one channel strip changes the volume
level of all channel strips in the group.

Note: The channel strips continue to maintain their relative volume levels.

762 Chapter 27 Mixing



• Mute checkbox: Changing the mute state of one channel strip changes the mute state
of all channel strips in the group.

• Input checkbox: Changing the input state of one channel strip changes the input state
of all channel strips in the group.

• Pan checkbox: Changing the pan control of one channel strip in the group changes
the pan control of all channel strips in the group.

Note: The channel strips continue to maintain their relative pan positions.

• Solo checkbox: Changing the solo state of one channel strip changes the solo state of
all channel strips in the group.

• Record checkbox: Changing the record-enable state of one channel strip changes the
record-enable state of all channel strips in the group.

Important: Multiple channel strips can be simultaneously record-enabled only if they
use different inputs.

• Send 1 to 8 checkboxes: Links the Send knobs individually for Send slots 1 to 8, while
still maintaining the relative positions between them.

• Color checkbox: Changing the color of one channel strip assigns this color to all channel
strips in the group.

• Track Zoom checkbox: Zooming a region in the Arrange area zooms the regions of all
channel strips in the group.

• Hide Track (H) checkbox: Selecting the Hide Track button of a grouped track selects the
Hide Track buttons of all tracks in the group.

Editing Mixer Group Membership
This section explains how to assign channel strips to groups, how to remove channel
strips from groups, and how to disable all group parameter links.

Assigning Channel Strips to Mixer Groups
You can assign a channel strip to single or multiple groups.

To assign a channel strip to a group
1 Click the channel strip’s Group slot to open the Group menu.

2 Choose one of the 32 groups.
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When you choose an inactive group, the Group Settings window opens automatically. If
you choose a group that is already in use, the Group Settings window does not open (see
Getting to Know the Mixer Group Settings).

To assign a channel strip to multiple groups
µ Press Shift while choosing a group in the Group menu.

The Group slot displays the channel strip’s group membership.

To quickly assign the most recent group setting to another channel strip
µ Press Option and click the Group slot of the channel strip.

The most recently accessed group setting—including overlapping groups—is applied to
the current channel strip.

Removing Channel Strips from Mixer Groups
You can also remove a channel strip from single or multiple groups.

To remove a channel strip from a group
1 Click the Group slot to open the Group menu.

2 Choose the Group that you want to remove the channel strip from.

To remove a channel strip from all groups
1 Click the Group slot to open the Group menu.

2 Choose No Group.

Disabling Mixer Groups
You can temporarily disable all group parameter links—applying a group clutch—to
change the volume of an individual channel strip, for example.

To temporarily disable all groups
Do one of the following:

µ Choose Options > Group Clutch (or use the Toggle Group Clutch key command, default
assignment:  Command-G).

µ Deselect the “Groups active” checkbox in the Group Settings window.
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While Group Clutch is activated, all Group slots change color—from yellow (normal) to
a light gray (all groups temporarily disabled).

Automating Mixer Groups
When you are automating your mix functions (volume, pan, mute, and so on), any channel
strip group member can act as the mix automation master for that group. When you use
that group member to write an automation parameter value, it is also written for the
other group members, depending on their automation mode.

The data is written individually for each channel strip. As a result, you can disable the
group later without affecting the automation of any group member—and you can edit
or change channel strips individually when they are removed from the group.

For details about automation, see Working with Automation.

Muting Channel Strips
Use the channel strip mute function to remove individual channel strips from the main
signal flow (turning off the channel strip) or to remove any unwanted region sections.

The channel strip mute function is also useful when you are setting channel strip levels
and setting the Pan, Balance, or Surround Position.

To mute a channel strip
µ Click the channel strip’s Mute button (marked with an M).

Click the button a second time to restore the channel strip to its previous level.

Note: When Track Mute/Solo is set to Fast (in the General pane of Audio preferences),
clicking a channel strip’s Mute button always activates the corresponding Track Mute
button in the Arrange area. See Muting Tracks in the Arrange Area.
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Soloing Channel Strips
Use the channel strip solo function to play a channel strip, or several channel strips, in
isolation. This enables you to check for issues such as clicks, pops, or overload.

Note: The channel strip solo function is also useful when you are setting channel strip
levels and setting the Pan, Balance, or Surround Position.

To solo a channel strip
µ Click the channel strip’s Solo button (marked with an S).

The Solo button turns yellow, along with the Solo buttons of tracks with the same channel
strip assignment. The Mute buttons of all unsoloed channel strips will flash, with the
exception of external MIDI channel strips.

Note: When Track Mute/Solo is set to Fast (in the General pane of Audio preferences),
clicking a channel strip’s Solo button always activates the corresponding Track Solo button
in the Arrange area. See Soloing Tracks in the Arrange Area.

To solo a channel strip, when another channel strip is already soloed
µ Option-click an unsoloed channel strip. This solos the selected channel strip and

deactivates the solo state of all other channel strips.

To disable the solo state of one or more channel strips
Do one of the following:

µ Click the channel strip’s active Solo button.

µ Option-click any active Solo button. This disables the solo state of all channel strips.

If you want to hear the signal of a soloed channel strip, including its send effects, you
cannot mute the aux channel strip used for the sends, because it constitutes part of the
signal path. The same applies when you solo an aux channel strip. All channel strips fed
into the aux channel strip are muted, but their send effects remain open, ensuring that
the effect continues to receive a signal. This behavior is indicated by a flashing Solo button
on each of the channel strips that feed into the aux channel strip.
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Logic Pro intelligently scans the entire signal path, leaving the aux channel strip open.
This automatic mute suppression applies only to internal send effects. If you are using
external effect units via aux channel strips, the scan will keep effect master sends open.
Logic Pro, however, cannot know which of the channel strips you are using as send effect
returns for external effect units. You must manually switch these channel strips to
solo-safe—preventing them from being muted when you solo another channel strip.

Better yet, make use of the I/O plug-in when you want to use external effects units. This
allows you to use external effects just as you would use internal ones. For more
information, see Working with External Audio Effects.

To make a channel strip solo-safe
µ Control-click an inactive Solo button.

A red slash across the Solo button indicates that the channel strip is solo-safe. The channel
strip will not mute when you solo another channel strip.

Control-click again to deactivate the channel strip’s solo-safe state.

Setting Channel Strip Levels
You are probably familiar with setting and adjusting channel strip levels, from creating
your arrangement. You set and adjust channel strip levels, several times during the mixing
process, to control the volume relationships between your project’s parts.
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When setting channel strip levels, you use the following channel strip elements:

Peak level display

Volume fader

Level meter

• Peak level display: Numerical display that updates during playback to show the highest
peak level reached.

• Volume fader: Sets a channel strip’s playback or monitoring volume.

• Level meter: Displays a channel strip’s playback or input monitoring level.

Note: Metering plug-ins—such as the Level Meter and the MultiMeter—are also available
if your needs extend further than the channel strip controls.

Understanding a Channel Strip’s Peak Level Display
The peak level display is a numerical display located above the level meter.

Peak level display

It updates during playback to show the peak level reached. The peak level display shows
the highest peak level after the entire signal has been played through to the end, and
provides a guide that should be used to set the Volume fader.
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Signal clipping occurs when too loud a signal is fed through the output channel strip,
thereby exceeding the limit of what can be accurately reproduced, resulting in distorted
sound. When a signal clips, the value shown in the peak level display is highlighted in
red.

Peak level display 
showing signal clipping

Note: It is not a problem if individual channel strips show evidence of clipping, as long
as the output channel strip (which is the summed level of all channel strips in the signal
flow) does not indicate clipping.

To eliminate clipping, you need to bring down the Volume fader by the same value that
is shown in red in the peak level display. For more information, see Using a Channel Strip’s
Volume Fader.

To reset all clip indicators
µ Click any clip indicator (or use the “Clear Overload Flag in Audio Channel Display” key

command).

Using a Channel Strip’s Volume Fader
You use the Volume fader to set a channel strip’s volume level.

Volume fader

To set the volume level of a channel strip
µ Drag the channel strip’s Volume fader up or down.

The maximum boost is +6 dB. You can reset the Volume fader to 0 dB (90) by
Option-clicking it.

Note: If the “Independent Monitoring Level for Record Enabled Channel Strips” checkbox
is selected (in the Core Audio pane of the Devices pane of Audio preferences), an
independent monitoring level is available when an audio channel is record-enabled. For
more information, see Setting the Monitoring Level for Recording.
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To avoid clipping
1 Check the red value shown in the peak level display of the channel strip, which indicates

clipping.

In the figure below, 1.7 dB is shown in the clip indicator when the Volume fader is set to
a value of 2.2 dB.

2 Drag the Volume fader down to a value of 0.5 or so.

Tip: You may find, however, that a Volume fader value of −1.2 sounds best in the context
of the overall mix, and clips only once (by 0.3 dB) during playback. If this is the case, it is
nothing to worry about. Use your ears rather than your eyes as a guide.
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Understanding a Channel Strip’s Level Meter
All channel strips feature segmented level meters that display the playback or input
monitoring level. The input monitoring level is displayed when you arm an audio track
in preparation for recording.

The colors of the level meter segments provide an at-a-glance overview of individual
channel strip monitoring levels:

• Amber and yellow: These signals are safe, and will not clip the channel strip output.

• Red: These signals are considered “hot” levels, but the occasional peak is nothing to
worry about unless the clip indicator is continually or regularly lit.

Customizing a Channel Strip’s Level Meter Scale
You can customize the level meter using two different scales.

Exponential scale Sectional dB-linear scale
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To change the level meter scale
1 Open Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
pop-up menu.

2 Click the Mixer tab, then choose a value in the Scale pop-up menu.

• Exponential: Provides higher display resolution in the upper range.

• Sectional dB-linear: Provides the best possible display resolution across the entire level
range.

Switching Between Channel Strip Volume Levels
You can use the following key commands to quickly switch between two different volume
levels on a channel strip:

• Toggle Level of Audio Channel Strips

• Toggle Level of Auxiliary Channel Strips

• Toggle Level of Output Channel Strips

• Toggle Level of Input Channel Strips

• Toggle Level of Bus Channel Strips

To switch between two volume levels
1 Select an audio channel strip, for example.

2 Set the Volume fader to the required level.

3 Use the “Toggle Level of Audio Channel Strips” key command.

Note that the channel strip’s Volume fader is all the way down.

4 Set the Volume fader to an alternative level.

The “Toggle Levels of Audio Channel Strips” key command now toggles between the
two volume levels. It does so for all channel strips of the same type at once, allowing you
to create two different mixes from one set of channel strips.

Setting Pan, Balance, or Surround Position in the Mixer
Rather than having instruments compete with one another in your mix, you can separate
elements by positioning audio and instruments in the stereo mix from left to right.
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For example, imagine the concert stage in front of you. Where are the key
players—drummer, bass player, singer, and so on—positioned? Begin by placing your
channel strip signals in the positions you would normally hear them at a concert. This
should be your starting point, even though you may move the players around later in
the process. The main objective is to place the instruments out of each other’s way so
they can be heard.

Mono channel strips feature a Pan control, which determines the position of a signal in
the stereo image. At the center pan position, the channel strip sends equal amounts of
the signal to both sides of the stereo image. If you were to increase the pan position on
the left side and decrease it on the right, the sound would move to the left.

Stereo channel strips display Balance controls. The Balance control differs from the Pan
control in that it controls the relative levels of two signals (Left and Right) at their outputs.

To set the Pan or Balance control
µ Drag the control vertically or horizontally.

Pan/Balance control

Option-click the Pan or Balance control to reset it to the centered (0) position.

When a channel strip output is set to Surround, the Pan or Balance control is replaced by
a Surround Panner. For details about using surround channel strips, effects, and the
surround panner, see Working with Surround.

Adding and Routing Effects in the Mixer
You add effects to channel strips in the Mixer in the same way as in the Arrange
window—using a channel strip’s Insert slot.

There are two different ways to use effects:

• As (insert) effect processors: To add effects directly to a channel strip’s main signal.

• As send effects: To isolate effects from a channel strip’s main signal or to send several
signals to the same effect.
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The following sections explain how you can route effects in many different ways, enabling
you to create complex mixing scenarios.

Sonically, the result of using effects as effect processors sounds nothing like the result of
using send effects. Take the example of using a common effects combo, such as
Reverb-Chorus-Delay. Inserting the effects directly into the channel strip signal results in
a very different sound when compared to adding an effect send/return loop to the channel
strip signal.

Routing Audio in the Mixer via Insert Effects
You use insert effects when you want to add effects directly into the channel strip’s signal
flow. In this way, the channel strip’s entire signal is processed by the effect plug-in.

When multiple effect plug-ins are routed into a channel strip via inserts, they are said to
be routed in series. In this type of configuration, the output of one effect is added to the
incoming signal and becomes the input of the next effect in the chain.

The figure below illustrates this process:

On this channel strip, the 
effect plug-ins 
(Compressor, Chan EQ,  
Tape Delay) are routed in 
series.
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Routing Audio in the Mixer via Send Effects
You use send effects when you want to isolate effect plug-ins from a channel strip’s signal
flow, or when you want to use the same effect on more than one channel strip.

By creating a send, you split the channel strip’s signal in two. The channel strip’s main
signal continues its route to the chosen output. The other part of the signal is routed
down a parallel path, via a bus to an aux channel strip. You use the Send level knob to
control the amount of the signal sent via the bus. This is known as parallel routing.

You can choose to route the signal back into the main signal flow at a later point, or you
can choose to output the signal from the aux channel strip.

The following example shows a channel strip routed to multiple aux channel strips via
sends—with reverb, chorus, and delay effects assigned to aux channel strips 1, 2, and 3,
respectively.

On this channel strip, the 
effect plug-ins are routed 
in parallel, via sends.

The effect plug-ins 
(Reverb, Chorus, Delay) 
are assigned to aux 
channel strips 1, 2, and 3.

The channel strip’s signal is split and routed to three separate effects, one on each aux
channel strip. These three independent signals are then sent back from the respective
aux channel strips and combined into an output stream from the original channel strip.
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You can create up to eight sends on each audio, instrument, or aux channel strip. The
behavior of sends is the same across Mixer and Arrange channel strips. For details about
working with send effects, see Using Send Effects.

Controlling Signal Flow in the Mixer
You can control signal flow in the Mixer using aux channel strips, output channel strips,
or multi-output instruments.

You use aux channel strips to create subgroups or to route a signal to multiple destinations.
You use output channel strips for subgrouping purposes. You use multi-output instruments
to individually process sounds and outputs.

Creating Aux Channel Strips in the Mixer
Aux channel strips can be used as send returns, as subgroups, to route a signal to multiple
destinations, and as additional destination channels for multi-output instruments.

Typically, you create aux channel strips as you need them. There are three ways to do
this:

• An aux channel strip is created automatically when a send assignment is made from a
channel strip, except when the chosen bus is already in use as an input source on
another channel strip.

• When a multi-output instrument such as the EXS24 mkII is inserted into an instrument
channel strip, several aux channel strip assignments are made “behind the scenes.”
You then must create the required number of aux channel strips by clicking the Add
(+) button at the bottom of the instrument channel strip. Each time you click it, a new
aux channel strip is created (and automatically assigned to particular instrument
outputs).

• The third way to create aux channel strips is by clicking the Add (+) button at the left
side of the Mixer, or by choosing Options > Create New Auxiliary Channel Strips. Both
methods open the following dialog:
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Enter a number, then choose settings from the Format, Input, and Output pop-up menus,
and click Create.

Using Aux Channel Strips in the Mixer
You use aux channel strips to create subgroups, for submixing purposes. You also use
them to route a signal to multiple output destinations.

For details about how to create aux channel strips, see Creating Aux Channel Strips in
the Mixer.

Creating Mix Subgroups
You can group several channel strips and route them via a single bus to a single aux
channel strip. This provides you with one set of controls over the entire group.

For example, your mix contains multiple drum tracks that you want to manage using a
single set of channel strip controls; or you want to put a compressor across the whole
drum kit. You can do this by sending each of the drum tracks to the same bus, which in
turn sends their signals to the same aux channel strip. You might then route your vocal
tracks to a second aux channel strip, providing a separate group control for these channel
strips. Finally, you have the option to output both subgroups (drums and vocals) to the
same destination or to separate destinations.

There is no restriction on the number of channel strips you can send to a subgroup.

Note: There are some similarities between using aux channel strips as subgroups and
working with Mixer groups (see Working with Mixer Groups). You can control the
group/subgroup properties from one set of channel strip controls. However, Mixer groups
are used to control channel strip group properties, and not the signal flow.

To create a subgroup using an aux channel strip
1 Select multiple channel strips by doing one of the following:

• Shift-click the required channel strips.

• Drag over the background of the required channel strips (drag horizontally across
multiple channel strips over the word Inserts, or I/O text, for example).

2 Point to the Output slot of any selected channel strip, hold down the mouse button, and
choose the required Bus (Bus 1, for example).

The Output slots of all selected channel strips change to Bus 1.

A new aux channel strip is created, except when the chosen bus is already in use as an
input source on another channel strip. Its Input slot contains the channel strip signal flow
coming via Bus 1.

3 Open the Output slot of the aux channel strip to choose the output destination for the
main mix.
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4 Use the aux channel strip controls to process the submix—adding inserts, setting level
and pan, and so on.

Sending Signals to Multiple Destinations
You can route a signal to several output destinations, using aux channel strips.

For example, you might have a main signal with the output destination set to external
speakers. At the same time, you would like to hear the signal as a separate headphone
mix, including some additional effects. To do this, you would set up two separate output
destinations for your signal, with the aux channel strips controlling the headphone mix,
including the additional effects.

To output a single channel strip to two destinations
1 Open the channel strip’s Output slot, then select the main output destination for the

mix—such as speakers.

2 Open the channel strip’s Send slot, then select the bus to send the separate signal to.

An aux channel strip is created automatically. Your chosen bus is reflected in the aux
channel strip’s Input slot.

3 Open the aux channel strip’s Output slot, then select the second output destination for
the mix—such as headphones.

Your signal flow is now routed to two separate output destinations. The main signal flow
to the speakers is heard in its “dry” state. The second signal flow—via a bus to the aux
channel strip, and output to headphones—can be modified and heard in its “wet” state.

Using Multi-Output Instruments in the Mixer
There are two reasons to use multi-output instruments in your mix:  to individually process
each sound in a drum kit, for example, with different effects; to route the different virtual
instrument outputs to different outputs on your audio interface. All of this is done using
the aux channel strip.
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Logic Pro supports the multiple outputs of the EXS24 mkII, Ultrabeat, and all Audio Unit
instruments. One or more multi-output options may be displayed in addition to the mono
and stereo versions shown in the instrument plug-in menu.

The plug-in menu offers additional information about an output configuration, such as:

• Instrument Name:  Multi Output (2 x stereo, 4 x mono)

• Instrument Name:  Multi Output (4 x stereo)

Note: Not all instruments (Logic Pro or software from another company) are multi-output
capable. If the instrument does not provide a multi-output option, it is not equipped with
multiple output facilities.

To insert and set up a multi-output instrument
1 Choose the multi-output instance in the plug-in menu.

The first two outputs of a multi-output instrument are always played back as a stereo
pair by the instrument channel strip that the plug-in is inserted into.

Additional outputs (3 and 4, 5 and 6, and so on) are accessed via aux channel strips.
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2 Within the instrument interface, you need to set up the output routing for individual
sounds or samples. This is generally done using a menu with entries such as Main, 34,
56, and so on.

3 In the Mixer, click the Add (+) button of the instrument channel strip that you have
inserted the multi-output instrument in—such as Ultrabeat.

Note: The Add button (+) appears only on multi-output instrument channel strips.
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An aux channel strip appears to the right of the instrument channel strip, already assigned
to the inserted multi-output instrument.

4 Repeatedly click the Add button (+) to create more aux channel strips, for all stereo or
mono outputs available to the instrument plug-in.

You should create only as many aux channel strips as required for the number of outputs
used by the multi-output instrument.

Following the creation of the first aux channel strip for your multi-output instrument, a
Delete button (–) appears beside the Add button (+).

Click the Delete button (–) to remove aux channel strips.

Using Output Channel Strips in the Mixer
You use output channel strips to assign submixes to physical hardware outputs of your
interface. You do this by routing multiple channel strips to a common output path via
their Output slots.
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When using output channel strips in this way, you cannot apply any further send effects
to the signal flow, as you would using aux channel strips. You can, however, control
settings and insert effect plug-ins using the individual controls of the output channel
strip.

Unlike aux channel strips, 
output channel strips do 
not have Send slots.

In some cases you might want to prevent individual output channel strips from being
controlled by the master channel strip—outputs used as send effects to external hardware
devices, for example. Simply switch such output channel strips to Solo-Safe mode by
Control-clicking their Solo button and they won’t be affected by the master channel strip.
See Soloing Channel Strips.

The Insert slots of output channel strips allow signal processing during the mastering
process, as well as during normal playback. Typical mastering tools are the compressors,
deessers, and equalizers. Due to technical reasons, you can only use plug-ins that don’t
require mono to stereo conversions. In other words, you can use stereo to stereo plug-ins
on stereo output channel strips, and mono to mono plug-ins on mono output channel
strips. Surround (or multi-mono) versions of plug-ins can be used on mono or stereo
output channel strips. Mono to multi-mono variants can be used on mono output channel
strips. Stereo to surround, stereo to multi-mono, and true surround versions of plug-ins
are accessible in stereo output channel strips.

Defining a Channel Strip’s Stereo Output
In Logic Pro you can choose the physical output pair on which the stereo output is played.
By default, it is played on Stereo Output (Output 1-2). But what if you are exchanging
projects with another studio that uses a different output pair when stereo monitoring,
for example? You can simply change the stereo output preference.
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To define the stereo output
1 Open Audio preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Audio from the pop-up
menu.

2 Click the I/O Assignments tab, then the Output tab.

3 Choose an output pair from the Output pop-up menu in the Stereo section.

The Mirroring checkbox becomes available for all chosen output pairs, with the exception
of Output 1-2.

4 Do one of the following:

• Deselect the Mirroring checkbox to have the output signal routed to the chosen output
pair (Output 3-4, for example).

• Select the Mirroring checkbox to have the output signal routed to the chosen output
pair (Output 3-4, for example), as well as to the physical outputs (Output 1-2). This is
useful when feeding the signal to a second pair of monitors, for example.

You can also define the output pair for individual channel strips in the Mixer.

To define a channel strip’s output pair
µ Open the Output slot of a channel strip, and choose an output pair from the Output

pop-up menu.

Defining a Channel Strip’s Mono Output
You can define a channel strip’s mono output setting directly from the channel strip’s
Output slot.
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To define a channel strip’s mono output
µ Open the Output slot of a channel strip, and choose the required mono output from the

Output > Mono pop-up menu.

Using Surround Panning in the Mixer
Logic Pro allows mixdowns in several surround formats, even if your audio hardware
offers only two outputs. Because it would be difficult to mix or record in surround format
without being able to hear the result, it is best to not select this option if you’re monitoring
or mixing through stereo speakers.

All audio, instrument, and aux channel strips can be individually set to different surround
formats.

To set a channel strip output to surround
µ Open the Output slot of a channel strip, and choose Surround in the pop-up menu.

The Pan control is replaced by a Surround Panner. The loudspeakers are represented by
colored dots, and the pan position is indicated by a white dot that can be dragged.

Surround Panner

For details about the use of the Surround feature, see Working with Surround.
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Using Binaural Panning in the Mixer
Binaural panning allows the direction of a signal source to be recognized—in front,
behind, above, below, and to the left or right of the listening position—by means of a
standard stereo signal. This emulates human hearing, which is capable of interpreting
positional information—where a sound is coming from—despite the fact that only two
“receivers” (your ears) are used to capture the sound. Use binaural panning as part of
your audio signal mix to place individual sound sources at different spatial positions. For
background information, see Binaural Hearing—Binaural Recording—Binaural Panning.

In Logic Pro, it is possible to set the channel strip output to Binaural. You can then use
the Binaural Panner window to position the signals on the panning plane.

The signal that results from Binaural Panner use is best suited for headphone playback.
You can, however, process the Binaural Panner output with the Binaural Post-Processing
plug-in. This enables you to play back the binaural pan effect through loudspeakers. For
more details, see Using the Binaural Post-Processing Plug-in.

To open the Binaural Panner window
1 Choose Binaural from a channel strip’s Output slot pop-up menu (on mono or stereo

channels).

The Binaural Pan control replaces the Pan/Balance control on the channel strip.
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2 Double-click the Binaural Pan control to open the Binaural Panner window.

This window behaves much like a plug-in window; it can be closed by clicking the close
button in the top-left corner, and it can be linked using the Link button.

Note: The Binaural Panner window is available only in mono to stereo and stereo to stereo
format.

786 Chapter 27 Mixing



Getting to Know the Binaural Panner Window
You control the panning effect in the Binaural Panner by positioning the panning pucks
on the panning plane at the top of the window, and by adjusting some additional
parameters. Following are descriptions of the window’s main elements.

Panning plane

Pucks

Mode buttons

Size field

Doppler button

Extended parameters
Click the disclosure 
triangle to reveal these 
extended parameters.

3D image

• Angle, Elevation, Distance: Information fields that adjust automatically when changes
are made to the puck positions.

• Spread: Information field that adjusts automatically when changes are made to the
puck positions. You can also interact directly with it by dragging its numerical value
(making changes here also affects the left and right puck positions).

• Panning plane: Area for positioning the signals—using the pucks—in the stereo image.

• Pucks: Used for positioning the signals on the panning plane—pan and direction.

• 3D image: Represents the resulting position of the audio signal. This is purely a visual
aid, which cannot be interacted with directly.

• Mode buttons: Determine the virtual shape of the panning plane, which can be planar
or spherical.

• Size field: Determines the size of the plane or sphere, expressed as the radius of the
circular plane.
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• Doppler button: Enables or disables the Doppler effect—a change in the pitch of a
signal perceived by a person who is moving relative to the source of the signal.

• Extended parameters: Click the disclosure triangle to reveal additional parameters for
headphone playback and for when you are in Planar mode.

Using the Binaural Panner Window
This section describes how to use the Binaural Panner window.

To control the binaural pan position in the Binaural Panner window
1 Drag the left or right puck (panning pucks) to make the stereo image wider or narrower.

The pucks also work on a second axis—up and down—relative to the third puck.

2 Drag the third puck (the direction puck) to determine the forward and backward direction.

As you adjust the direction puck, the two panning pucks move accordingly. The Angle,
Elevation, Distance, and Spread values also change.

3 Select the Mode (virtual shape) of the planning plane:

• If set to Planar, the panning results are shown on a flat circular plane.
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• If set to Spherical, the results are placed on a virtual sphere. If it helps, imagine the
sphere as a virtual head. When the “direction puck” is placed in the top half of the
circular plane, the sound is in front of the listener. As the direction puck is moved toward
the lower half of the plane, the sound passes up, and over your head, and ends up
behind you.

4 Set the size of the plane or sphere by doing one of the following:

• Drag the Size field value up or down.

• Double-click the Size field, then type a new value.

• Option-click the Size field to reset it to its default value (1.50m).

5 Click the Doppler button to enable or disable the Doppler effect.

6 Select the Diffuse-Field checkbox in the Extended Parameters area to ensure a neutral
sound for headphone playback, utilizing diffuse-field compensation.

Note: When using multiple Binaural Panners on several channel strips, turn this option
off and route the output of the Binaural Panners to an aux channel strip, in which you
insert the Binaural Post-Processing plug-in. The Binaural Post-Processing plug-in allows
you to apply diffuse-field compensation to all Binaural Panner outputs at once, saving
CPU power.

7 If in Planar mode, use the Extended Parameters sliders to control the vertical offset and
tilt of the circular plane—watch the 3D image when changing them to get a clear idea
of their functions.
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Using the Binaural Post-Processing Plug-in
The Binaural Post-Processing plug-in is available in aux and output channel strips. This
plug-in allows you to apply various compensation modes on a stereo bus or
output—through which several, or all, binaural signals are routed. This saves CPU power
and makes it easy to switch between compensation modes.

For details about this plug-in, see the Logic Pro Effects manual.

Binaural Hearing—Binaural Recording—Binaural Panning
An important part of mixing audio signals is the placement of individual sound sources
at different spatial positions. Most common recording and mixing techniques simply send
a given signal at different levels to the available loudspeakers—two for stereo, or more
for quadraphonic or surround setups—to create a virtual sound stage.

This approach is somewhat flawed, however, as human beings are able to locate sound
sources at different positions with just two ears. Virtually all spatial information for all
sounds is included in the two signals arriving at the two eardrums. From these signals,
human beings can determine characteristics such as inter-aural time and level differences
and—based on the listening experience—information about the spatial origin of the
sounds being heard. Are they coming from in front or behind, from the left or right, or
above or below? This ability to perceive where a sound originates from is referred to as
binaural hearing.

In theory, the spatial positioning of any sonic experience can be reproduced during
playback, so no special techniques need to be employed during recording. There is,
however, one drawback to this approach:  every person has differently shaped ears and
different body and head proportions, all of which influence the way sound signals arrive
at the eardrum—not to mention aspects such as hearing loss, subjective responses to
the sounds being heard, and so on. Given these physical differences, each person listening
to the same sound source, while standing or sitting in the same position, will hear slightly
different binaural signals.

Therefore, perfect reproduction would only be possible if you could make a recording
with tiny microphones placed inside your auditory canals. Because this is impractical,
binaural hearing has been emulated in sound laboratories by using mannequin heads
with built-in microphones. This approach has led to binaural recordings to fit the average
person, which are more or less compatible with the way most people hear.

Playback of binaural recordings is best suited to headphones, ideally combined with
signal conditioning (processing) that ensures the signals are accurately reproduced. Given
a specialized listening environment, it is also possible to reproduce these signals with
loudspeakers, utilizing a process known as crosstalk cancellation.
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As you are unlikely to have the technology required to make binaural recordings, your
best chance of simulating binaural signals is by processing the sound signal on playback.
This is known as the head-related transfer function (HRTF), which approximates the change
that a signal undergoes on its way from the source to the eardrum.

Working with MIDI Channel Strips in the Mixer
This section deals with the MIDI channel strips of the Mixer, as well as those of the
GM Mixer (see GM Mixer Objects).

The MIDI channel strips work as remote controls for the mixing parameters of your
MIDI-controlled sound modules and synthesizers, such as volume and pan.

Note: The controls send MIDI control change messages. They do not control any audio
signal flow within Logic Pro.
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Open the View menu in the Mixer and choose MIDI Channel Strip Components, then
choose all of the items that appear in the submenu—Instrument Name, Program, Bank,
Assign 1 to 5—so you will be able to see all of the parameters described below. The basic
channel strip Level, Pan, and Mute controls are always shown on MIDI channel strips.

Program

Bank

Assign 1 to 5

• Bank fields: If your sound source “understands” bank select events, you can choose the
bank number for each of the MIDI channel strips. The lower value sends controller value
32, and the upper value sends controller value 0; this is for MIDI instruments that have
127 x 127 banks. You can use several different bank select formats (see Custom Bank
Selects) if your device does not use the standard controller 0/32 messages. Remember
that not all synthesizers support bank select events.
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• Program button: Allows you to select a sound by name—click it to open a menu that
contains either GM sound names (the default setting) or sound names created or
imported by the user. Each channel strip has its own menu, whose content can vary
depending on the Bank number selected in the Bank fields.

• Assign 1 to 5: Choose to display up to five knobs that you can freely assign to any MIDI
controller number.

Adjusting Elements of MIDI Channel Strips
This section looks at how to adjust the volume level and pan position on MIDI channel
strips, as well as how to control MIDI data transmission and assign controller data.

Note: Option-clicking a fader or knob resets the value to its default value. The default
value is 0 for all controls, with the exception of Volume (Controller #7), which has a default
value of 100.

The Volume fader controls the output volume level of a MIDI channel strip. Adjusting it
sends controller #7 via your MIDI interface.

To adjust the volume of a MIDI channel strip
µ Drag the Volume fader up or down.

The Pan control allows you to directly control the pan position of the sound. Controller
#10 is sent via your MIDI interface.

To control the pan position of a sound
µ Drag the Pan control vertically or horizontally.

The knob moves according to the mouse position.

The Mute button controls the sending of MIDI data from the corresponding external MIDI
channel strip. When the Mute button is turned on, the external MIDI channel strip stops
sending MIDI data.

To stop or start the sending of MIDI data from the external MIDI channel strip
µ Click the Mute button.

You can use each of the Assign 1 to 5 knobs to send MIDI controller data to the external
MIDI instrument, allowing you to remotely control parameters such as volume, balance,
pan, and chorus.
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To assign a controller to one of the knobs
1 Click the label above the knob.

2 Choose a controller from the menu.

Saving and Restoring MIDI Channel Strip Settings
MIDI channel strip settings in the Mixer directly affect the Track Parameter box in the
Arrange window’s inspector. The current settings of all channel strips are saved with the
project.

If the active settings of your sound module are not maintained when you switch it off
(some devices reset to default values), any Logic Pro Mixer settings that affect the unit
will be lost. Fortunately, Logic Pro Mixer settings are automatically restored and transmitted
to all MIDI devices when you reload the project.

On occasion, however, this may not happen, due to MIDI communication issues with
some devices. In this situation, you can manually resend the Logic Pro MIDI channel strip
settings by choosing Options > Send All MIDI Mixer Data.

Using Extended GM:  GS and XG Functions in the Mixer
In addition to the General MIDI (GM) standard, GS and XG formats are extended standards
created by Roland and Yamaha respectively.

GS and XG modes allow you to select different effect programs and to control the level
of the reverb and chorus effects.

To display the GS or XG effects
µ Open the Mixer’s View menu and choose Add GS/XG Effects.

The GS/XG configuration control is displayed on the right of the Mixer, allowing you to
select different effect programs.
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To configure GS or XG effects
1 Choose a standard from the pop-up menu.

Depending on your selection, other pop-up menus and fields for the extended effects
appear.

2 Select a reverb or chorus effect from the second pop-up menu.

3 Drag the Time field vertically to set the reverb or delay time.

Customizing the Mixer
You can customize the Mixer in a number of ways to suit your own mixing needs.

You can switch the Mixer between three different views, and refine these views even
further using Filter buttons. You can also view each of the following:  Mixer channel strips
associated with folder tracks, track notes associated with Mixer channel strips, and control
surface bars.

Switching Between Mixer Views
You can choose between three different Mixer views:  Single, Arrange, and All. These
views allow you to restrict the Mixer to display only those channel strips that you actually
need for the current mixing task. This accelerates and simplifies your workflow.

To switch between Mixer views
µ Click the Single, Arrange, or All button in the Mixer’s menu bar (or use the Cycle Through

Mixer Modes key command).

View buttons

Using Single View
Single view limits the Mixer display to a single channel strip—the track selected in the
Arrange area—and its signal flow.

The signal flow may contain some or all of the following, laid out from left to right:

• The original channel strip assigned to the selected Arrange area track

• Aux channel strips—used for individual output signals of multi-output
instruments—shown to the right of the instrument channel strip, and in ascending
order

• Aux channel strips—used as send destinations for the original channel strip—shown
in ascending order
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• Output channel strips—used as a routing destination for the original channel strip (or
for other displayed channel strips)—shown in ascending order

• The master channel strip

Using Arrange View
In Arrange view, the Mixer displays all channel strips that correspond to tracks—audio,
instrument, or external MIDI—used in the Arrange window, and their signal flow.

Note: The signal flow is visible only if the Add Signal Flow Channel Strips command is
chosen from the Mixer’s View menu.

The entire signal flow is laid out from left to right, as follows:

• All channel strips that are assigned to Arrange area tracks, shown in ascending order

• Aux channel strips—used for individual output signals of multi-output
instruments—shown to the right of the instrument channel strip, and in ascending
order

• Aux channel strips—used as send destinations for all channel strips (or for other
displayed aux channel strips)—shown in ascending order

• Output channel strips—used as a routing destination for all channel strips in the
Mixer—shown in ascending order

• The master channel strip

You can choose the following two items from the Mixer’s View menu to further refine
the Arrange view:

• Other Tracks: Enable to show (or disable to filter) track channel strips that do not offer
any mixing parameters, such as volume or pan control. These other tracks include the
No Output and Metronome tracks. This is useful for setting the level and routing
assignment for the Metronome. (The latter option is handy if you need to provide a
click track to a specific output—for a musician or for purposes of synchronization.)

• Same Instrument Tracks: Enable to show (or disable to filter) Arrange window tracks
that address the same instrument channel strip. These tracks have redundant settings
for volume, pan, and so on—because they address the same channel strip—so it’s
usually unnecessary to display more than one channel strip for each track.

Using All View
In All view, the Mixer displays all channel strips available in the project, including those
that don’t have a corresponding track in the Arrange area.

Aux and output channel strips are examples of channel strips that don’t have a
corresponding track in the Arrange area. You can, however, create tracks for such channel
strips.
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To automatically create a track for a selected channel strip in the Arrange area
µ In the Mixer, choose Options > “Create Arrange Tracks for Selected Channel Strips.”

Note: This function cannot be used to duplicate Arrange tracks. If the selected channel
strip is already available as an Arrange track, the Arrange track will be selected and shown
in the visible window area.

Using Filter Buttons in the Mixer
You can use the channel strip filter buttons in conjunction with the Arrange and All views
to refine the Mixer display even further. These filter buttons enable you to limit the Mixer’s
display to particular channel strip types.

Channel strip 
filter buttons

You can use different filter button settings for both views:

• Click a button to enable or disable the view of this channel strip type.

• Option-click a button to enable it, and to disable all other buttons (all other channel
strip types).

Viewing Mixer Channel Strips Associated with Folder Tracks
If the Arrange area contains a folder track, this folder track is displayed in the Mixer.
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Note: To view channel strips associated with folder tracks, make sure Folder Tracks is
chosen in the Mixer’s View menu.

Folder track

To enter the folder track
Do one of the following:

µ Double-click the folder track in the Mixer.

µ Double-click the folder region in the Arrange area.

µ Select the folder, then use the “Go Into Folder or Region” key command.

The Mixer now displays only those channel strips that are in the folder track.

To exit the folder
Do one of the following:

µ Click the Hierarchy button at the left side of the Mixer.

µ Click the Hierarchy button at the left side of the Arrange area.

µ Double-click the Arrange area background (or use the “Go Out of Folder or Region” key
command).

The Mixer now displays all the channel strips in the Arrange area, including the folder
track.
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Viewing Track Notes in the Mixer
Track-specific notes can be viewed, created, and edited in the Mixer area, as well as in
the Notes area (see Working in the Notes Area).

Unlike track notes in the Notes area, however, track notes in the Mixer area cannot be
changed in regard to formatting. And only the first line of text from a track note in the
Notes area is displayed in the Mixer area. You cannot view or edit any text after the first
line break.

To switch on the Notes feature in the Mixer
Do one of the following:

µ Choose View > Notes.

µ Click the Notes button at the bottom left of the Mixer area.

µ Control-click (or right-click) the Mixer area, and choose Notes from the shortcut menu.

The Notes area is displayed at the bottom of the Mixer and can be enlarged by dragging
the dividing line between the Notes area and the channel strips.

To edit, delete, or create track notes in the Mixer
µ Double-click the Notes area at the bottom of the Mixer, and edit, delete, or create text.

The track notes in the Notes area are also updated accordingly.

Viewing Control Surface Bars in the Mixer
You can view which tracks are accessed by control surfaces connected to your system.

To view control surface bars in the Mixer
µ Choose View > Control Surface Bars.

Each control surface can be assigned a different color in the Device Parameter box. For
more information, see the Logic Pro Control Surfaces Support manual.
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Using Link Modes in the Mixer
The Link mode options—No Link, Same Level Link, and Content Link—allow you to define
how information is displayed in the Mixer when working with folder tracks in the Arrange
area.

To set any of these modes
µ Control-click (or right-click) the Link button in the Mixer, then choose the mode you want

from the shortcut menu:

• No Link: The Mixer does not follow display level changes when selecting, entering, or
exiting folder tracks in the Arrange area.

• Same Level Link: The Mixer follows display level changes when selecting, entering, or
exiting folder tracks in the Arrange area.

• Content Link: The Mixer displays the track list inside a folder when selecting a folder track
in the Arrange area.

Using the I/O Labels Window
You can use the I/O Labels window to define names for all channel strip Input, Output,
and Send menu items, which can be used in place of defaults such as “Input 1” or “Output
8.”

To open the I/O Labels window
Do one of the following:

µ Choose Options > Audio > I/O Labels in the main menu bar.

µ Choose Options > I/O Labels in the Mixer.

Choose a device from the Device pop-up menu, if you have multiple audio interfaces.
I/O labels can be individually defined for each hardware driver type, such as Core Audio
or DAE, but are valid for all projects. These labels are stored in a separate file, located in
the ~/Library/Application Support/Logic folder. The file is called “IOLabels xxx” (where
xxx is the name of the hardware type).
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To create new I/O labels for the Input, Output, and Send menus of channel strips
1 Click the button in the User column, aligned on the Channel row (Output 12, for example).

2 Double-click the “-” in the Long (name) column and type a new name for Output 12
(MLAN 12, for example). Click outside the row, or press Return.

3 Repeat the process for the Short (name) column (type 12, for example).

The short name is used in the Send slots.

Output 12, if used, will be replaced with MLAN 12 in the Output menu slot of all channel
strips.

To revert to default channel I/O labels
Do one of the following:

µ Click the corresponding button in the Channel column.

µ Open the Reset pop-up menu and choose a command to reset the following channel
strip types to their “default” names (as shown in the Channel column):

• All Labels

• Input Labels

• Output Labels

• Bus Labels

To use the I/O labels provided by the hardware driver
µ Click the corresponding button in the “Provided by Driver” column.

Adjusting Mixer Channel Strips in Record or Playback Mode
You can adjust a channel strip in recording or playback mode, but first you need to prevent
the track selection from changing. This allows you to adjust a particular Mixer channel
strip, even if a different track is being recorded.

To prevent the track selection from changing when recording
µ Make sure the “Change Track in Record Mode” command is not chosen in the Mixer’s

Options menu.

To prevent the track selection from changing when playing back your project
µ Make sure the “Change Track in Playback Mode” command is not chosen in the Mixer’s

Options menu.

Copying Entire Mixer Setups
You can copy and paste entire mixer setups between projects.
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To copy a mixer setup
1 Select the project that contains the setup you want to copy.

2 Open the Mixer.

3 Choose Options > Copy Audio Configuration.

To paste a mixer setup
1 Select the target project.

2 Open the Mixer.

3 Choose Options > Paste Audio Configuration.

Adjusting Elements of Multiple Mixer Channel Strips
You can select multiple channel strips in the Mixer, thereby creating a temporary group
so that you can quickly adjust a number of settings for all selected channel strips at one
time. These selection methods work on all channel strip types.

Logic Pro also offers the group functionality for channel strips (see Working with Mixer
Groups), but selecting multiple channel strips in the Mixer is much quicker for many
operations than setting up groups.

Tip: As with individual controls on a single channel strip, Option-clicking a fader or knob
resets the control to a default value.

To select multiple channel strips
Do one of the following:

µ Choose one of the following menu items from the Mixer’s Edit menu.

• Select All

• Select Audio Channel Strips

• Select Instrument Channel Strips

• Select Auxiliary Channel Strips

• Select Output Channel Strips

• Select MIDI Channel Strips

• Select Equal Colored Channel Strips

• Select Muted Channel Strips

µ Shift-click the channel strips.

µ Click a channel strip background and drag over the channel strips (drag horizontally
across multiple channel strips over the word Inserts, or I/O text, for example).
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To deselect multiple channel strips
Do one of the following:

µ Choose the Deselect All command from the Mixer’s Edit menu.

µ Click any unselected or selected channel strip in the Mixer.

The clicked channel strip is then selected.

µ Click the Mixer background.

µ Click a track in the Arrange area that is not already selected in the Mixer.

The clicked track is then selected in the Mixer.

Adjusting Mixer Parameter Controls
You can adjust some parameter controls on several channel strips simultaneously.

To adjust the Volume fader on all selected channel strips
µ Drag the Volume fader of any selected channel strip.

All level changes are relative and logarithmic. Movements are dB-proportional, with the
mix ratio of the selected channel strips remaining constant. For example, if channel strip
1 is set to 90 dB and channel strip 2 is set to 60 dB, reducing either Volume fader will
retain the relative distance between the channel strips:

• At half the original level, channel strip 1 will be at 45 dB and channel strip 2 at 30 dB.

• At a quarter of the original level, channel strip 1 will be at 22.5 dB and channel strip 2
at 15 dB; the mix ratio thus remains constant until both channel strips simultaneously
arrive at 0 dB.

• When either channel strip is returned to its original value, the 60/90 dB relationship in
this example is restored.

To adjust knobs on all selected channel strips
Do one of the following:

µ Drag the Pan/Balance knob on any selected channel strip.

All Pan or Balance knobs change accordingly (the changes are relative).

µ Drag the Send level knob on any selected channel strip.

All Send level knobs change accordingly (the changes are relative).

To adjust buttons on all selected channel strips
Do one of the following:

µ Click the Mute or Solo button on any selected channel strip.

The buttons of all selected channel strips mirror the status of the clicked button.

µ Click the Record Enable button on any selected channel strip.
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The Record Enable buttons of all selected channel strips (typically, audio channel strips)
switch to the new mode.

Note: Only channel strips with different input sources can be record-enabled
simultaneously.

Adjusting Mixer Plug-in Settings
You can adjust some plug-in settings on several channel strips simultaneously.

To choose an effect or instrument for all selected channel strips
µ Click an unused Insert or Instrument slot on any of the selected channel strips, and make

your choice from the list.

The selected effect or instrument will be inserted into the corresponding slot on all
selected channel strips, if their corresponding slots are empty. Existing plug-ins on other
channel strips are not changed.

To replace a plug-in for all selected channel strips
µ Click a used Insert or Instrument slot on any of the selected channel strips, and make your

choice from the list.

The selected effect or instrument will be inserted into the corresponding slot on all
selected channel strips, even if their corresponding slots are empty.

To remove a plug-in for all selected channel strips
µ Click a used Insert or Instrument slot on any of the selected channel strips, and choose

“No Plug-in” from the list.

The selected effect or instrument will be removed from all corresponding slots on all
selected channel strips.

To insert the Channel EQ for all selected channel strips
Do one of the following:

µ On channel strips where Insert slot 1 is not used:  Double-click the EQ area on the upper
portion of the channel strip to place the Channel EQ in the first Insert slot.

The Channel EQ will be inserted in the first empty slot of all selected channel strips.

µ On channel strips where Insert slot 1 is used:  Option-double-click the EQ area to insert
the Channel EQ as the first plug-in and move all existing plug-ins of the channel strip one
slot down.

The Channel EQ will be inserted into the first Insert slot of all selected channel strips,
moving any existing plug-ins one slot down.

Adjusting Mixer Routing, Automation, and Group Settings
You can adjust some routing, automation, and group settings on multiple channel strips
simultaneously.
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To adjust the send destination of all selected channel strips
µ Click an unused Send slot on any of the selected channel strips, and choose from the list

of Bus destinations (aux channel strips).

The corresponding Send slots of all selected channel strips will be routed to the chosen
destination.

To adjust the input or output routing of all selected channel strips
µ Click the Input or Output slot on any of the selected channel strips, and choose a setting

form the menu.

All selected channel strips will be set to the chosen input or output.

Note: Inputs are changed only on selected channel strips of the same status:  mono,
stereo, or surround. This feature allows you to easily select a common input source for
all selected stereo audio tracks, for example.

To assign ascending input or output routing to all selected channel strips
µ Hold down the Option key while clicking the Input or Output slot on any of the selected

channel strips, and choose a setting from the menu.

The leftmost selected channel strip will be assigned the chosen input or output setting,
with the input or output increasing from left to right.

To adjust the automation mode of all selected channel strips
µ Click the Automation Mode button on any of the selected channel strips, and choose a

setting from the menu.

All selected channel strips will be switched to the chosen setting.

To adjust the group setting of all selected channel strips
µ Click the Group slot on any of the selected channel strips, and choose a setting from the

menu.

All selected channel strips will be switched to the chosen setting.

Navigating Within the Mixer
You can quickly move to the next or previous channel strip in the Mixer using the following
key commands:

• Select Next (Right) Channel Strip (default assignment:  Right Arrow key)

• Select Previous (Left) Channel Strip (default assignment:  Left Arrow key)

When multiple channel strip types are visible in the Mixer, you can choose a command
to jump to a particular channel strip type. This feature is handy when your Mixer view
contains dozens, or hundreds, of channel strips.
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To move to a specific channel strip type
µ Open the View menu and choose Scroll To, then choose a command from the submenu

(Outputs, for example).

The entire Mixer view will shift to display the first of these channel strips at the right of
the visible Mixer area.

Tip: When you double-click the Output slot of any audio channel strip, you jump to the
assigned Output channel strip fader, thus accelerating navigation in the Mixer.

Assigning Colors to Channel Strips in the Mixer
The Colors item in the View menu opens a Color palette that allows you to assign colors
to channel strips. These color assignments are also reflected by Arrange window regions,
and simplify the task of mixing—particularly the task of mixing groups.

To assign a color to a selected channel strip
µ Choose View > Colors, and click a color in the palette.

Close the palette by clicking the close button at the top left.

You can define custom colors by double-clicking any color in the palette. A Color wheel
will open, allowing you to define the hue. Click OK to replace the selected color square
of the palette.

Renaming Tracks in the Mixer
Make sure that Track Name is chosen in the Mixer’s View menu, then double-click the
display of the track name (or channel strip name, which is used as the default track name)
to open a text input field. Type a new name, or change an existing one, and press Return
to confirm the entry.

To rename several tracks in a row
Do one of the following:

µ Enter text in the text input field, then press Tab to confirm the entry and activate the next
track name for editing.

µ Enter text in the text input field, then press Shift-Tab to confirm the entry and activate
the previous track name for editing.

To rename multiple tracks
1 Select multiple channel strips in the Mixer.

2 Double-click the track name of one of the selected channel strips, and enter text in the
text input field.

3 Press Return to confirm the entry.
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The new name is applied to all selected channel strips.

Note: If the track name ends with a number, this number will automatically be incremented
by 1 for each subsequent channel strip. To turn off automatic numbering, place a space
after the number at the end of the name you type. All selected channel strips will then
end with the same number.

Linking Control Surfaces to the Mixer
Control surface groups follow changes in the Mixer, including changes to the Mixer view,
when the Link Control Surfaces setting is enabled in the Mixer.

To link control surfaces to the Mixer
µ Open the View menu and choose Link Control Surfaces if it is not already selected (or use

the corresponding key command).

For details, see the Logic Pro Control Surfaces Support manual.
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Logic Pro features a sophisticated, yet simple-to-use, track-based automation system that
allows you to create and play back fully automated mixes. Mix automation refers to
recording, editing, and playing back the movements of faders, knobs, and switches on a
mixing console—providing real-time control of volume, pan, EQ, and aux send controls,
among others. You can automate all mix functions in Logic Pro, without restriction. This
also applies to all plug-ins—the parameters of all effects and software instruments. All
third-party plug-ins can be totally automated (with one or two exceptions, such as several
Space Designer parameters, which cannot be automated in real time).

Automation is independent of MIDI and audio regions, and takes place on Arrange window
tracks. Automation is also independent of the play or record status of Logic Pro, allowing
you to create automation at any time.

The Logic Pro track automation system is sample-accurate, which is precise, but very
processor-intensive. You can partially or completely turn off the sample-accurate mode
in the Sample Accurate Automation pop-up menu of the Logic Pro > Preferences > Audio
> General pane.

Note: You can also use MIDI controller values to automate parameters. This is done on
a per region basis in the arrange area, and is known as Hyper Draw.

This chapter covers the following:

• Displaying Track Automation (p. 810)

• Setting an Automation Mode (p. 814)

• Writing Track Automation Data (p. 817)

• Selecting Automation Nodes and Lines (p. 818)

• Creating Automation Nodes (p. 819)

• Deleting Track Automation Data (p. 820)

• Copying and Moving Automation Data (p. 821)

• Editing Track Automation Data in the Track Header (p. 823)

• Snapping Automation to Grid Positions (p. 824)
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• Offsetting Automation (p. 824)

• Editing Track Automation Data in the Event List (p. 826)

• Writing Track Automation with External Controllers (p. 826)

• Using Hyper Draw in the Arrange Area (p. 828)

• Conversion of Automation Data (p. 832)

Displaying Track Automation
Track automation data is displayed on a transparent gray shaded area—an automation
track—that runs the length of your project. The audio waveforms of audio regions, and
notes in MIDI regions, can be seen at a reduced contrast level in the shaded area.

The automation data is represented by colored curves, dots (known as nodes) and lines
that are shown in the gray area.

Numerical values are also automatically displayed at each node on automation tracks.
Numerical values are context-sensitive, which means the centered pan position is displayed
as 0 (not 64), and volume is displayed in dB, for example.

To display track automation in the Arrange area
Do one of the following:

µ Choose View > Track Automation in the Arrange area (or use the Hide/Show Track
Automation key command, default assignment:  A).

µ Click the Automation button in the Arrange toolbar (if visible).
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The gray automation area appears on all tracks, and the Automation Parameter menu is
displayed in the track header. This allows you to choose the visible automation parameter.
It is automatically set to Volume.

Automation Parameter 
menu

Automation can only be displayed when a track is of a sufficient height. Turning on track
automation automatically sets a suitable vertical zoom level.

To resize one or more tracks
µ Drag the lower-left corner of a track header (in the track list) to resize it. Alternately, you

can use the vertical zoom bars to resize all tracks, if automation is not visible.

This can happen if you have manually resized a track, or changed the zoom level after
activating automation.

Displaying Different Automation Parameters
You can choose the parameter that you want to view and edit in the Automation
Parameter menu. This appears below track names in the Arrange track list.
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This can be the Volume fader, pan pot, or any other parameter of the track’s channel strip.
The parameters are represented by the following preset colors when displayed as a curve
in the automation track:

• Yellow for Volume automation

• Green for Pan automation

• Yellow for Solo automation

Only parameters that actually control something in the selected track’s channel strip (or
its plug-ins) are displayed in the Automation Parameter menu. Parameters that already
exist in the track (as automation data) are displayed in bold lettering in the menu.

To choose an automation parameter
µ Click the Automation Parameter menu, and choose a parameter.

A submenu is shown for each plug-in inserted in the channel strip. These are numbered
and named after the slot position and plug-in (1 EXS24, for example). Further submenus
may be shown inside the Plug-in menus. Volume, Pan, Solo, Mute, and Bypass are shown
in the Main submenu.

To hide all automation parameters on a track
µ Click the Automation Parameter menu, and choose Display Off.

To hide all automation parameters on all tracks
Do one of the following:

µ Choose View > Track Automation in the Arrange area (or use the Hide/Show Track
Automation key command, default assignment:  A).

µ Click the Automation button in the Arrange toolbar (if visible).

Viewing the Automation Data of Multiple Parameters
The automation track shows all automation data (not only the currently active parameter)
at a lower contrast level. Volume is a muted yellow, Pan is a muted shade of green, and
so on.

To change the transparency level of regions and automation data
1 Open Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
pop-up menu.
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2 Click the Arrange tab, then adjust the Regions and Other Data sliders in the Automation
Transparency section.

You also have the option of viewing each automation parameter on its own subtrack,
making it easier to see what is being controlled.

To view automation data on subtracks
µ Click the disclosure triangle to the lower left of a track name.

This opens a separate automation sub-lane, below the track.

Logic Pro automatically sets the automation parameter type of the new automation lane
to a type that’s already recorded, but not currently shown. The active automation
parameter remains on the top track. Repeated clicks on the disclosure triangle open
further automation subtracks.
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To view all recorded automation data on subtracks
µ Option-click the (closed) triangle to open up to 30 automation subtracks, which will

display existing (already recorded) automation data.

Only as many automation subtracks as required will open, so if you have recorded
automation data for ten parameters, nine subtracks will open. The active automation
parameter remains on the top track.

Option-click the open triangle to collapse all automation subtracks. The automation data
remains active, and will play if the automation mode of the main track is not set to Off
or Write—even if the track is not visible.

Setting an Automation Mode
Automation modes determine how automation tracks are handled. Essentially, automation
is either off, being read, or being written. You can independently choose the automation
mode for every channel strip.

To set the automation mode for a track
Do one of the following:

µ Choose a mode in the track header’s Automation Mode menu.

µ Choose a mode in the Automation Mode menu on a channel strip in the Mixer or Arrange
channel strip.
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To set the same automation mode for all tracks
µ Press Option, and choose an automation mode in the Automation Mode menu in the

Mixer or Arrange channel strip.

To set the same automation mode for selected channel strips
1 Choose channel strips by Shift-clicking their names in the Mixer.

2 Choose an automation mode in the Automation Mode menu of one of the selected
channel strips.

Setting the Automation Mode via Key Commands
You can also set the automation mode with the following key commands:

• Toggle Current Track Automation Off/Read

• Set Current Track to Automation Read

• Toggle Current Track Automation Touch/Read

• Toggle Current Track Automation Latch/Read

• Toggle Current Track Automation Write/Read

• Set All Tracks to Automation Off (default assignment:  Shift-Control-Command-O)

• Set All Tracks to Automation Read (default assignment:  Shift-Control-Command-R)

• Set All Tracks to Automation Touch (default assignment:  Shift-Control-Command-T)

• Set All Tracks to Automation Latch (default assignment:  Shift-Control-Command-L)

• Set All Tracks to Automation Write

Choosing Automation Modes
You can choose from the following automation modes in any channel strip:

Off
Off disables the current track automation data without deleting it. No automation data
is written, read, or played back. If the current automation mode is Off, any edits to track
automation data in the Arrange area automatically switch the automation mode to Read.
This ensures that the data, as currently edited, will be played.

Given that track automation can be recorded during playback mode, Off is the default
setting, as any mix automation recording may prove disconcerting while arranging.

Read
Read mode automates the current track, using the existing automation data.

The data cannot be changed by moving the channel strip controls, or using an external
automation controller, when in Read mode.

Touch
Touch mode plays back automation data in the same fashion as Read mode.
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If a channel strip or an external (touch-sensitive) automation controller is touched, the
existing track automation data of the active parameter is replaced by any controller
movements—for as long as the fader or knob is touched. When you release the controller,
the automation parameter returns to its original (recorded) value. The time required by
a parameter to return to its previously recorded setting is set via Logic Pro > Preferences
> Automation > Ramp Time.

Touch is the most useful mode for creating a mix, and is directly comparable to “riding
the faders” on a hardware mixing console. It allows you to correct and improve the mix
at any time, when automation is active.

Latch
Latch mode basically works like Touch mode, but the current value replaces any existing
automation data after releasing the fader or knob, when Logic Pro is in playback (or
record) mode.

To finish, or to end parameter editing, stop playback (or recording).

Write
In Write mode, existing track automation data is erased as the playhead passes it.

If you move any of the Mixer’s (or an external unit’s) controls, this movement is recorded;
if you don’t, existing data is simply deleted as the playhead passes it.

Warning: Be careful with Write mode (and its settings), to make sure that you don’t
erase your pan, bus, and plug-in automation data by mistake, if your intention was only
to erase Volume fader information.

To determine the type of data that should be erased
1 Open Automation preferences by doing one of the following:

• Choose Logic Pro > Preferences > Automation (or use the Open Automation Preferences
key command).

• Click the Preferences button in the Arrange toolbar, then choose Automation from the
pop-up menu.
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2 Select checkboxes in the “Write Automation for” section.

The Write Mode Changes To menu determines the mode that Logic Pro switches to after
a Write operation has been executed.

You’ll rarely need the Write mode when working with the track automation features of
Logic Pro. It’s mainly there to complete the selection of automation modes. It’s easier to
erase automation data by choosing Track > Track Automation > Delete all Automation
on Selected Track (or Delete All Automation, respectively).

In earlier analog mix automation systems, Write mode was the only way to erase
automation data from tape when beginning a new project. The Track > Track Automation
> Write to End and Write to Right Locator commands are self-explanatory. One writes
track automation data to the end of the project, and the other to the right locator position.

Writing Track Automation Data
You have the following write options for track automation data:

• Move any fader or control of the selected channel strip with the automation mode set
to Touch, Latch, or Write. In real-world usage, you’ll rarely (if ever) use the destructive
Write mode, which erases all automation data. The standard write modes are Touch
and Latch.
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• Choose a parameter in the arrange track list, and move the value slider to the right of
the track list, with one of the write modes turned on.

• Move the faders or knobs of a connected hardware controller, with one of the write
modes turned on. See Writing Track Automation with External Controllers.

• Use the Pointer tool or Pencil tool to draw your automation data.

When one of the write modes is active, you can record track automation data when
Logic Pro is in record or playback mode. The Arrange window track selection or audio
record ready status is irrelevant. Whatever you touch or move is recorded when a channel
strip is set to one of the write modes. The movement of Mixer controls (when in a write
mode) can be used to overwrite or edit existing automation data, in real time.

When Logic Pro is in stop mode, the automation write modes are ignored, and no data
is written if the fader is moved. There is, however, one exception:  If there are no dynamic
changes (no automation data), the current fader setting becomes valid for the whole
project. This is the default behavior for all mix parameters, when you start a fresh project.

Selecting Automation Nodes and Lines
You can use the Automation Select tool to drag to select any selection (of nodes) in the
automation data.

Automation Select tool

• Click a region to select all currently visible automation events that fall within the region
borders.

• Shift-click to select other areas, in addition to an existing selection. This allows you to
simultaneously edit noncontiguous selections.

• Shift-click a node—in front, or following a selected area—to extend the current selection.

You can also select nodes with the Pointer tool:

• Shift-click a node to toggle selection (of the node).

• Shift-click a line to toggle selection (of the line).
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• Click outside of all track automation lanes (on the Arrange area background) to deselect
all automation data.

• Drag a selected area to move all selected nodes (and connecting lines). Moved
automation data automatically erases any data that exists in the destination area.

• Shift-dragging allows a rectangular selection. The selected area will toggle.

• Option-clicking, when no automation data is selected, selects all data behind (following)
the current mouse position, allowing you to drag this selection.

• Option-double-clicking, when no automation data is selected, will select all data.

There are two choices available when changing the values of several selected nodes:

• Clicking a line or node allows you to change all values by the same absolute amount.

• Clicking outside a line, within the selected area (a node or outside a node), changes all
values proportionately, by a percentage value.

Creating Automation Nodes
You can create automation nodes using a variety of different methods.

To create automation nodes
µ Click on, or just outside, an automation line (not on a node) with the Pointer tool or Pencil

tool to create a new node.

The very first click in an empty automation track creates a new node at that position, and
another node at the beginning of the track. This ensures that you can’t create parameter
controls with gaps in the middle of a region, and have full control over the parameter
from the beginning of the automation track.

Note: Creating an automation node on a grouped track, and with the relevant checkboxes
selected in the Group Settings window (volume, pan, sends), will also create automation
nodes on other tracks in the group. Their placement will take the relative parameter
values of each track into account.

To freely draw automation
µ Draw automation lines (and curves) with the Pencil tool.
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Nodes will be created along the line.

You can create one or two nodes on each side of a rectangular selection area.

To create one node on each side of a rectangular selection area
µ Hold down the Option and Shift keys while dragging with the Pointer tool to make a

rectangular selection.

To create two nodes on each side of a rectangular selection area
µ Hold down the Option, Control, and Shift keys while dragging with the Pointer tool to

make a rectangular selection.

One or two nodes can also be created at region borders.

To create one node at each region border
Do one of the following:

µ Select the region, then choose Track > Track Automation > Create Nodes at Region
Borders.

µ Select the Automation Select tool, then Option-click the region header area.

To create two nodes at each region border
Do one of the following:

µ Select the region, then choose Track > Track Automation > Create Two Nodes at Region
Borders.

µ Select the Automation Select tool, then Control-Option-Shift-click the region header area.

Deleting Track Automation Data
You can choose one of the following commands in the Track > Track Automation menu
(or the corresponding key command) to delete track automation data:

• Delete Visible Automation on Selected Track: Removes the active automation parameter
data (default key command assignment:  Control-Command-Delete).
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• Delete All Automation on Selected Track: Removes all types of automation data from the
selected track (default key command assignment:  Shift-Control-Command-Delete).

• Delete Orphaned Automation on Selected Track: Removes all orphaned automation data
from the selected track. Automation data can be orphaned when copied between
tracks.

• Delete All Automation: Removes all types of automation data from all tracks.

You can also delete multiple nodes by doing one of the following:

• Shift-Option-double-click anywhere on an automation track to open a dialog that allows
all automation data (of the current type) to be deleted. This is as per the Delete All
Automation Data of Current Track command.

• Press Delete to delete a selection of automation nodes. Make sure that no regions are
selected when using this function. Any selected regions are also deleted.

To delete a single node
µ Click it with the Pencil tool or Eraser tool.

Copying and Moving Automation Data
After you create or select automation nodes and lines, you can easily change things to
meet your needs.

To copy automation data within a track
µ Select the nodes or lines you want to copy, then Option-drag the selection to a different

location on the track.

Any existing nodes in the destination area are deleted.

To copy automation data between tracks
1 Hold down the Shift key while dragging a selection within the automation area.

2 Choose Edit > Copy (or using the corresponding key command, default assignment:
Command-C.

3 Select the track you want to copy the automation data to.

4 Choose Edit > Paste (or using the corresponding key command, default assignment:
Command-V.

To move automation data
Do one of the following:

µ Select the nodes or lines you want to move, then drag them horizontally or vertically.

Any existing nodes in the destination area are deleted.

µ Hold down the Control key while dragging automation nodes or lines vertically.
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This allows fine adjustment of the automation node or line value.

Note: Moving automation data that resides on a grouped track, and with the relevant
checkboxes selected in the Group Settings window (volume, pan, sends), will also move
automation data that exists in the same area on other tracks in the group. The relative
parameter values of each track are maintained.

You can move regions with, or independent from, track automation data.

To move regions with, or without, automation data
µ Choose a Move Automation with Regions option in Logic Pro > Preferences > Automation.

• Never: Does not move automation when you move regions.

• Always: Always moves automation when you move regions. The automation data area
encompassed by the region boundaries is moved.

• Ask: A dialog prompts you to move the automation data—or leave it where it
is—whenever you move a region.

You can also move part of a region with its automation data, using the Marquee tool.

To move a region selection with its automation data
1 Drag across the region with the Marquee tool.

2 Use the local Arrange menu Edit > Copy command.

3 Select the track you want to copy the automation data to.

4 Move the playhead to the insertion point.

5 Use the local Arrange menu Edit > Paste command.

The region selection, along with its automation data, is copied to the target track at the
playhead position.

To copy or convert the automation data of one parameter to another
1 Select the automation parameter that you want to copy, or convert, in the Automation

Parameter menu.

2 Command-click the Automation Parameter menu and choose a destination parameter.
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A dialog asks if you want to convert, or “copy and convert,” the source parameter data
into automation data for the destination parameter. The “copy and convert” option results
in the source parameter automation data being retained, and replicated for the destination
parameter.

You can use the Automation Curve tool to bend the line between two nodes, or any
selection.

Automation Curve tool

To bend an automation line
µ Drag an automation line with the Automation Curve tool.

Tip: This function is also available when using the standard Pointer tool, by pressing
Control-Shift.

Editing Track Automation Data in the Track Header
You can use the Pointer tool to adjust the track automation data for an entire automation
lane in one go.

Note: If the track is part of a track group, and if the relevant checkboxes are selected in
the Group Settings window (volume, pan, sends), track automation data across all tracks
in the group will adjust accordingly. However, the relative parameter values of each track
are maintained.
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To adjust the track automation data for an entire automation lane
Do one of the following:

µ Hold down Command while dragging vertically in the numerical value display.

µ Hold down Command while dragging vertically in the value slider.

Note: When you hold down Command, a short-click in the numerical value display or
the value slider selects the current parameter automation data on that track. If the track
is part of a track group, a long-click selects the current parameter automation data on all
tracks in the group.

Snapping Automation to Grid Positions
You can snap both track-based and Hyper Draw (region-based) automation to grid
positions.

To automatically snap automation nodes to the chosen Snap grid value
µ Choose Snap Automation in the Snap menu.

Note: Automation edits always snap to an absolute position, regardless of whether or
not the Snap to Absolute Value option is enabled.

Offsetting Automation
Although automation in Logic Pro can be sample-accurate, it may be affected by audio
hardware latencies, excessive processor loads, or plug-in delays. To ensure that your
automation happens “on-the-money,” you can move it slightly forward or backward in
time (if Snap Automation is enabled).
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To offset your automation when Snap Automation is active
1 Open Automation preferences by doing one of the following:

• Choose Automation Snap Offset in the Snap menu.

• Choose Logic Pro > Preferences > Automation (or use the corresponding key command).

• Click the Preferences button in the Arrange toolbar, then choose Automation from the
menu.

2 Adjust the Snap Offset parameter in tick values (these can be either positive or negative).

All automation, on all tracks (or regions containing Hyper Draw automation), will be offset
by the chosen number of ticks.
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Editing Track Automation Data in the Event List
Logic Pro allows track automation data to be altered in a dedicated Event List window,
which can only be opened via the Automation Event List key command (default
assignment:  Control-Command-E).

Each automation event is displayed as a MIDI controller event, and can be adjusted in
length, value, and so on.

Tip: If you open another Arrange window (Command-1) while the Automation Event List
window is open, you will see all automation data as folder regions in a separate Arrange
window. These can be handled just like MIDI regions, but only affect automation data.
This functionality generally won’t be required in most automation editing situations, but
it’s there if you need it.

Writing Track Automation with External Controllers
Logic Pro provides support for a number of dedicated control surfaces that make writing
and editing track automation data fast, efficient, and easy. Depending on the facilities
available, you can simultaneously write automation data for several channels, or multiple
plug-in parameters. Full details on all supported devices can be found in the Logic Pro
Control Surfaces Support manual.

Any MIDI controller—such as the modulation wheel, or a front panel slider or knob on
your MIDI keyboard—can be used to write automation data. You can use one such
controller for all automation writing duties (see Using Automation Quick Access), or can
assign individual controllers (if available on your MIDI keyboard) to different parameters
(see the Logic Pro Control Surfaces Support manual).
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Using Automation Quick Access
The Automation Quick Access feature makes track automation extremely fast and simple
if you only have one hardware MIDI controller available (one fader on your MIDI keyboard,
or maybe just the modulation wheel). You can use this single hardware controller to
access (and automate) the currently active automation parameter of the selected track
in the Arrange window.

To set up Automation Quick Access
1 Open Automation preferences, by doing one of the following:

• Choose Logic Pro > Preferences > Automation (or use the Open Automation Preferences
key command, default assignment:  Option-A).

• Click the Preferences button in the Arrange toolbar, and choose Automation from the
menu.

2 Turn on Automation Quick Access, by clicking the On button in the Automation Quick
Access section.

A dialog prompts you to assign a controller.

Tip: You can quickly turn on the Automation Quick Access setting via the local Track >
Track Automation menu (or use the Toggle Automation Quick Access key command,
default assignment:  Control-Option-Command-A).

3 Click the Assign button and slowly move the hardware controller that you want to use
for Automation Quick Access. Make sure that it’s moved through its entire range.

4 Confirm your selection by clicking the Done button below the Off/On buttons in the
Automation Quick Access section.

The Done button turns into a Learn Message button. Clicking the Learn Message button
allows you to assign a new controller for Automation Quick Access.

Clicking the Edit button opens the Controller Assignments window, where you can assign
the controller manually. See the Logic Pro Control Surfaces Support manual for more
information.

Once set up, you will have hardware control over the active automation parameter on
the current arrange track.
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Enabling and Disabling Automation Quick Access
If you choose the modulation wheel for Automation Quick Access, you might want to
switch between using it for Automation Quick Access and normal modulation wheel
duties—as MIDI controller 1.

This is most efficiently done with the Toggle Automation Quick Access key command
(default assignment:  Control-Option-Command-A).

Using Hyper Draw in the Arrange Area
Hyper Draw works much like track automation, with a couple of key differences:

• Hyper Draw data is restricted to MIDI regions.

• Hyper Draw data uses MIDI controller values (rather than the internal meta events used
by the track automation system), which are represented as lines between nodes.

You can edit nodes and lines in a similar way to track automation data.

You can record MIDI controller events in real time on MIDI tracks, or use Hyper Draw to
create and edit controller events in the Arrange area, Piano Roll, and Score Editor. The
Hyper Editor is purpose-built for MIDI controller editing, providing more precision and
flexibility than the Hyper Draw options of other windows.

Numerical MIDI controller values are automatically displayed as Hyper Draw nodes. These
values are context-sensitive—the centered pan position is displayed as 0 (not 64), and
volume is displayed in dB, for example. If no events exist, Logic Pro automatically creates
a horizontal line (of the current value, if available).

You can use any of the 127 MIDI controller values to automate parameters such as volume
or pitch, for example.
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To activate Hyper Draw for the currently selected regions or events in the Arrange
area, Piano Roll, or Score Editor

µ Choose an event type directly from the View > Hyper Draw menu.

The chosen event type is displayed as a controller number, or by name, in the upper-left
corner of the Hyper Draw area. You can choose different Hyper Draw parameters for each
MIDI region in the Arrange area, if needed. You can use multiple types of Hyper Draw
information for each region.

If activated in the Piano Roll Editor or Score Editor, a gray Hyper Draw section is displayed
below the editing area.

Hyper Draw button

Hyper Draw menu

The Piano Roll Editor and Score Editor feature a Hyper Draw button at the lower-left
corner. Click this button to open or close the Hyper Draw section. When the gray Hyper
Draw area is visible, you can choose the controller type from the menu (Down Arrow)
shown to the left of the Hyper Draw scale.

To turn off Hyper Draw
µ Choose View > Hyper Draw > Off.
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To set the MIDI Channel
µ Choose a channel number from the View > Hyper Draw > Channel submenu.

The chosen channel number is also displayed alongside the event type.

To define other MIDI controllers in Hyper Draw
µ Choose View > Hyper Draw > Other, and select the number of the controller and the MIDI

channel in the Hyper Draw window.

Use this option if you want to use Hyper Draw to edit a controller that isn’t directly
available in the Hyper Draw menu.

Using the Autodefine Mode
The Autodefine mode sets the Hyper Draw parameters automatically, making the first
event in the region visible.

Autodefine is not limited to switching the Hyper Draw display to the first incoming
controller; it can also respond to other types of events. It responds in this order:

• Controller

• Aftertouch

• Pitch Bend

• Program Change

• Note Velocity

Recording MIDI Automation Data
You can record MIDI automation just like regular MIDI events. Logic Pro must be in record
mode to capture this type of automation.

To record MIDI automation data
Do one of the following:

µ Move any Environment fader to record the fader’s MIDI events to the currently selected
track. For more information see Recording and Playback of Fader Movements.

µ Record events via external MIDI controllers, such as the modulation wheel or filter cutoff
control of your MIDI synthesizer.

Editing MIDI Automation Data
As MIDI automation data consists solely of MIDI events, you can edit it just like any other
MIDI events, using the Event List, Hyper Editor, or the Transform window.

Using the Note Velocity Mode
Hyper Draw offers the Note Velocity mode, which is perfect for creating crescendos or
diminuendos across a range of notes. You can use it at any point in a region (on a note
in the Piano Roll window, for example).
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To use the Note Velocity mode
1 Choose View > Hyper Draw > Note Velocity.

Piano Roll Editor in Note 
Velocity mode

2 Click and hold until you see the (Start Line) help tag, and release the mouse button. The
(End Line) help tag is shown, along with a green line, which can be visually positioned
onscreen. Keep an eye on the help tag while moving the line.

3 Click an end point—both vertical and horizontal—to automatically scale all note velocities,
aligned with the inserted line.

Note: Use of this mode only makes sense when the region actually contains notes.

The Note Velocity Line tool works in different modes:

• Absolute: With no modifier key pressed, the velocity of notes is changed to match the
values of the line.

• Relative: Using Command-click, the original and new note velocity are analyzed. The
resulting velocity is an average of both values.

• Just Selected: With Option pressed, only selected notes are affected.

Both Relative and Just Selected modes can be combined.

Using Hyper Draw Key Commands
The following Arrange window key commands can speed up use of Hyper Draw:

• Hyper Draw:  Disable

• Hyper Draw:  Volume

• Hyper Draw:  Pan

• Hyper Draw:  Modulation
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• Hyper Draw:  Pitch Bend

• Hyper Draw:  Note Velocity

• Hyper Draw:  Other

• Hyper Draw:  Autodefine

Conversion of Automation Data
You can convert track automation data into MIDI controller events (Hyper Draw data, in
other words), and vice versa. This allows you to move control data from regions in the
Arrange area to the track-based automation system, or the reverse. This is useful for
mirroring the Hyper Draw information—being used to control filter cutoff (on an external
MIDI synthesizer)—with an identical automation curve that controls the Intensity
parameter of a Flanger plug-in on an Apple Loops drum track, for example.

To convert region controller events to track automation
1 Select the region.

2 Choose one of the following commands in the Track > Track Automation menu:

• Move Visible Region Data to Track Automation: Moves the currently visible MIDI controller
data (volume, for example) of the selected region to the track automation system.

• Move All Region Data to Track Automation: Moves all MIDI controller data of the selected
region to the track automation system.

To convert track automation data into controller events
1 Select the region that you want to copy the controller events into.

2 Choose one of the following commands in the Track > Track Automation menu:

• Move Visible Track Automation to Region: Converts the active track automation parameter
into MIDI controller events, and copies it to the selected region.

• Move All Track Automation to Region: Converts all track automation parameters into
MIDI controller events, and copies them to the selected region.

Note: Only track automation data that falls within the boundaries of the selected region
is converted.
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You can render all or specific channels to one or more audio files, and even burn directly
to a CD or DVD with the Bounce function. The Bounce process allows you to create an
audio file (in several different file formats simultaneously), or multiple surround audio
files, based on all channel strips routed to the selected output channel strip. All parameters,
including volume, pan, and effects, are recorded as part of the bounce file. Automation,
if used, also impacts the resulting bounce file. Bouncing takes place in either real time,
or faster than real time (offline bounce).

Once bounced, files can be reused in Logic Pro, either creatively, or to save processing
resources by replacing (or bypassing) the regions, instruments, and effects on source
channels. Bounced files can also be used in other applications or devices. This makes it
easy to send your files to mastering facilities, use them on the Internet (on webpages, or
in the iTunes Store, for example), or even upload them to your iPod. Another option is
to burn bounced files to a CD or DVD. This can be done directly from the Bounce window,
making bouncing and burning a one-step process.

This chapter covers the following:

• Creating a Bounce (p. 833)

• Routing Channel Strips to an Output (p. 834)

• Defining the Bounce Range (p. 835)

• Defining Parameters in the Bounce Window (p. 836)

• Setting the Bounce Filename and Folder (p. 846)

• Bouncing and Dithering (p. 846)

Creating a Bounce
This section outlines the basic steps required to create a bounced audio file.

Stage 1: Route Channel Strips to an Output
Route all channel strips that you want to bounce to a particular output channel strip. See
Routing Channel Strips to an Output.
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Stage 2: Define the Bounce Range
Define the bounce range. See Defining the Bounce Range.

Stage 3: Set the Bounce Parameters
Set the parameters in the Bounce window. See Defining Parameters in the Bounce Window.

Stage 4: Set the Bounce Filename and Folder
Enter a destination name and folder for the bounce files. See Setting the Bounce Filename
and Folder.

Stage 5: Perform the Bounce
Click the Bounce (or Bounce & Burn) button in the Bounce window.

Note: Mono bouncing is possible when the output channel strip is set to mono. In this
situation, a mono audio file is generated.

Routing Channel Strips to an Output
You can route a single channel strip or multiple channel strips to an output channel strip.

To route a channel strip to an output channel strip
µ Click and hold the Output slot of the channel strip, then choose the appropriate output

from the pop-up menu.

To route multiple channel strips to an output channel strip
1 Drag to select (or Shift-select) the channel strips.

2 Click and hold the Output slot of one of the selected channel strips, then choose the
appropriate output from the pop-up menu.

All selected channel strips are routed to the chosen output channel strip.
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Defining the Bounce Range
Before bouncing, it is best to define the range of the project that you want to bounce.

The default values for the Start and End position fields in the Bounce window encompass
the entire Logic Pro project if no regions are selected, or if the Cycle function is inactive.

• If the Cycle function is engaged, the bounce start and end positions match the locator
positions.

• If a selection (of one or more regions) is made in the Arrange window, the bounce start
and end positions match the selected area.

Note: You can manually set the bounce start and end positions by changing the Start
and End parameters in the Bounce window, if none of the options above are appropriate.
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Defining Parameters in the Bounce Window
After routing channel strips to an output (see Routing Channel Strips to an Output) and
defining a bounce range (see Defining the Bounce Range), you should define the bounce
parameters in the Bounce window.

To open the Bounce window
Do one of the following:

µ Choose File > Bounce from the main menu bar to bounce output channel strips 1 and 2.

µ Click the Bounce button on the relevant output channel strip.
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Setting Global Parameters in the Bounce Window
Several global options are available in the Bounce window, regardless of the file types
being bounced.

• Destination pane: You activate an option in the Destination pane by clicking its name
and selecting its checkbox. You can select multiple checkboxes, if you like. If you do
so, multiple files are created, with the appropriate file extension:  filename.aif,
filename.mp3, filename.m4a. You can choose from several destination file formats for
your audio bounce:

• PCM file (SDII, AIFF, (Broadcast) Wave, or CAF format)

• MP3 file

• M4A:  AAC file

• Burn:  CDDA file

If you click the Destination file format name, rather than select the file format checkbox,
you can set a number of preferences in the area to the right (preferences change based
on your chosen Destination file format). For example:

• PCM, MP3, and M4A: AAC files can be individually bounced and added to the iTunes
library if the “Add to iTunes library” checkbox is selected (for each format).

• PCM files in SDII, AIFF, Wave, or CAF format: Can be added to the Audio Bin if the “Add
to Audio Bin” checkbox is selected.
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• Start and End fields: These fields define the boundaries of the project segment that you
want to write to the bounce file. The defaults for these fields are set in the following
way:

• If the Cycle function is engaged, the boundaries are set to the locator positions.

• If a selection is made in the Arrange window, the boundaries are set to the selected
area.

• If neither of the above is valid, the boundaries encompass the entire Logic Pro project.

In any case, you can adjust the start and end positions manually—for example, if you
want to take into account a MIDI sound module (mixed via an aux channel strip) that
falls outside the bounce start and end positions.

Tip: It’s often a good idea to set the end position of the bounce a little bit past the end
of the last region. This ensures that reverb tails and echoes from delay plug-ins are not
chopped off. The amount of extra time needed depends on the effect settings used.

As you adjust the Start and End position parameters, you are shown the hard disk space
requirements for the bounced file above the Cancel and Bounce (Bounce & Burn)
buttons.

• (Bounce) Mode buttons: You can create the bounce file in real time or offline:

• Realtime: Creates the bounce file in real time. Use this setting when you want to
bounce audio and instrument tracks, plus external MIDI sound sources that are routed
into the Logic Pro Mixer via aux channels.

• Offline: Accelerates the bounce process, depending on the complexity of your
arrangement and available system processing power. This setting also allows you to
bounce arrangements that would normally exceed the processing power of your
system, if trying to play them in real time. Offline bouncing is limited to internal
sources (audio or instrument tracks). External MIDI tracks and audio channel inputs
are deactivated during offline bounces. The Offline Bounce mode is only available
to the output channels of devices that use native audio driver systems (Core Audio).
DSP-based audio hardware cannot make use of offline bouncing due to the nature
of its stream-oriented technology. (In other words, these devices only work in real
time.) Other software applications that are fed into your Logic Pro Mixer via ReWire
can be bounced offline.

• Bounce 2nd Cycle Pass checkbox: The bounce process takes two repetitions of the cycle
range into account, with the creation of the bounce file starting at the second repetition.
This is useful if you want effect tails (from the first cycle pass) to be added to the start
of the bounce file.

• Include Audio Tail checkbox: The bounce file is extended as far as necessary to include
any instrument release and effect tail.
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• Normalize pop-up menu: You can choose between the following three states:

• Off: Normalization is turned off.

• Overload Protection Only: Downward normalization takes place in case of overloads
(levels above 0 dB, which would lead to clipping), but no normalization takes place
for lower levels.

• On: The incoming audio is scanned for the highest amplitude peak. The level of this
peak is increased to the maximum possible level (without clipping), and all other
incoming audio is increased by this amount.

Setting PCM Options in the Bounce Window
Click the PCM name and select its checkbox in the Destination pane to access the following
options:

• “File format” pop-up menu: Allows you to choose from SDII, AIFF, (Broadcast) Wave, or
CAF format. PCM files in these formats can be automatically added to the Audio Bin
by selecting the Add to Audio Bin checkbox.

• Resolution pop-up menu: Allows you to define the resolution of the bounce file. The
options are 16 Bit (for CD delivery), 8 Bit (for multimedia productions,) or 24 Bit (for
mastering to DVD).

• Sample Rate pop-up menu: Allows you to choose the sample rate for your bounced
audio file(s). Options range from 11,025 to 192,000 Hz, and include the three most
commonly used sample rates:  44,100 (CD-DA), 48,000 (DAT), and 96,000 (DVD).

• File Type pop-up menu: Allows you to choose between Split (for use in Digidesign
Pro Tools), or Interleaved (for further use in Logic Pro, or for CD writing software).

Note: Choosing Split disables Burn, if chosen in the Destination pane.
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• Dithering pop-up menu: Dithering is recommended when bouncing 24-bit recordings
into 16-bit files.

• Surround Bounce checkbox: Select this checkbox to bounce all outputs in the project
surround format (File > Project Settings > Audio > Surround Format).

Each surround channel is bounced to a separate file.

All surround outputs are bounced simultaneously, regardless of which output channel’s
Bounce button is clicked (or if the Bounce window was opened via File > Bounce).

The Logic Pro > Preferences > Audio > I/O Assignments pane gives you access to the
surround settings.

• You can determine the stereo and surround output formats in the Output pane.

• The Bounce Extensions pane displays the extensions that are added to the filenames
resulting from a stereo or surround bounce. Click the various fields to edit the
extensions.

• You can determine the stereo and surround input formats in the Input pane.

Note: Selecting the Surround Bounce option deselects the MP3, M4A:  AAC, and Burn
checkboxes in the Destination pane (following a warning message).

• Add to Audio Bin checkbox: Select to add the bounced PCM file to the Audio Bin.

• Add to iTunes library checkbox: Select to add the bounced PCM file to the iTunes library.

Note: iTunes does not support SDII or CAF format files. If the File Format menu is set
to SDII or CAF, this checkbox is dimmed, and cannot be used.

Setting MP3 Options in the Bounce Window
Logic Pro allows the bouncing of MP3 (MPEG-2, Audio Layer 3) format files. This well-known
data reduction format for digital audio signals was developed by the Fraunhofer Institute,
and allows high compression rates while maintaining reasonable audio quality (depending
on the compression rate). MP3 is a widely used standard for audio file exchange via the
Internet.

Because encoding an MP3 file equates to a loss of audio quality, you should not use MP3
files during production if you have access to the same audio data in linear formats such
as AIFF, WAV, or SDII.

Bounced PCM files are also used for encoding to MP3/M4A:  AAC. Note that this occurs
before dithering takes place.

Note: If the selected sample rate is higher than 48 kHz, a temporary copy of the bounced
PCM file is created (with an automatic sample rate conversion to 48 kHz) before encoding.
This conversion takes place because the MP3 format does not support sampling rates
higher than 48 kHz.
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If the PCM option is unselected in the Destination pane, a temporary PCM file is bounced
as a source for encoding to MP3/M4A:  AAC or burning to a CD, according to the options
selected in the PCM pane.

Selecting the MP3 option in the Destination pane automatically disables the PCM >
Surround option (following a warning message). This is because the MP3 format does
not support surround. Split Stereo format is, however, possible, even if the encoded MP3
file is set to Joint Stereo mode.

Select the MP3 name (and select its checkbox) in the Destination pane to access the
following options:

• Bit Rate (Mono/Stereo) pop-up menus: MP3 bit rates are available between 32 kbps and
320 kbps, but default to 80 kbps mono, and 160 kbps stereo. These rates offer acceptable
quality and good file compression.

To enhance audio quality, provided you can afford the extra file size, choose:

• 96 kbps for mono streams

• 192 kbps for stereo streams

You can choose higher rates, but the quality improvement afforded by bit rates above
96/192 kbps is nominal.

• Use Variable Bit Rate Encoding (VBR) checkbox: Variable Bit Rate encoding compresses
simpler passages more heavily than passages that are (more) harmonically rich, generally
resulting in better-quality MP3 files.

Unfortunately, not all MP3 players can accurately decode VBR-encoded MP3s, which
is why this option is turned off by default. If you know that your target listeners can
decode VBR-encoded MP3s, you can turn this option on.
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• Quality pop-up menu: Keep this set to Highest (the default) whenever possible. Reducing
the quality accelerates the conversion process, but at the expense of audio quality.

• “Use best encoding” checkbox: Like the Quality parameter, if you deselect this option,
you gain encoding speed at the price of audio quality. This should always be selected,
unless conversion time is an issue.

• “Filter frequencies below 10 Hz” checkbox: When this option is selected (the default),
frequencies below 10 Hz (which are usually not reproduced by speakers, and are not
audible to human ears at any rate) are removed. This leaves slightly more data
bandwidth for the frequencies that are audible, resulting in an improvement of the
perceived quality. Only deselect this option if you’re experimenting with subsonic test
tones.

• Stereo Mode pop-up menu: You can choose Joint Stereo or Normal stereo mode.
Depending on the original file, these settings may (or may not) offer any audible
difference. Experiment with both settings to determine your preference.

• “Write ID3 tags” checkbox: Select this option to write ID3 tags to the file.

• ID3 Settings button: Click this button to open a dialog where you can edit and configure
ID3 tags.

All entries are made by double-clicking the Content column fields to the right of the
corresponding ID3 Frame column entry, and typing in your text.

842 Chapter 29 Bouncing Your Project



Select the “Use default values” checkbox to display default settings for certain Content
column entries. For example, the Project Title and Tempo (Beats Per Minute) are
automatically filled in.

Selecting the “Use default values” checkbox also sets the Initial Key pop-up menu to
the first entry shown in the global Signature track. This is “default:  C” if no key has been
set for the project. You can choose another key from the menu.

• “Add to iTunes library” checkbox: Adds the encoded MP3 file to the iTunes library.

Setting M4A:  AAC Format Options in the Bounce Window
Click the M4A:  AAC name and select its checkbox in the Destination pane to access the
following options:

• Encoding pop-up menu: Choose Advanced Audio Codec (AAC) or Apple Lossless to
determine how your .m4a (commonly referred to as MP4) file will be encoded. Both
encoding algorithms provide high-quality audio; the AAC format uses a higher
compression ratio, resulting in smaller file sizes.

• Bit Rate pop-up menu: You can choose a rate between 16 kbps and 320 kbps.

Note: This parameter is only available when the AAC codec is chosen.

• “Encode with variable bit rate (VBR)” checkbox: Variable Bit Rate encoding compresses
simpler passages more heavily than passages that are (more) harmonically rich, generally
resulting in better-quality files.

Unfortunately, not all media players can accurately decode VBR-encoded files, which
is why this option is turned off by default. If you know that your target listeners can
decode VBR-encoded files, you can turn this option on.

Note: This parameter is only available when the AAC codec is chosen.
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• “Add to iTunes library” checkbox: Adds the encoded file to the iTunes library.

Choosing the M4A:  AAC option in the Destination pane disables PCM > Surround
(following a warning message). Split Stereo is, however, possible.

If the selected sample rate is higher than 48 kHz, a copy of the bounced PCM file is
created (with an automatic sample rate conversion to 48 kHz) before encoding. This
conversion takes place because the M4A:  AAC format does not support sampling rates
higher than 48 kHz.

Setting Burn Options in the Bounce Window
Choose the Burn:  (CDDA or DVDA) name (and select its checkbox) in the Destination
pane to access the following options:

Logic Pro can directly burn Red Book audio to blank CDs or DVD-Audio to blank DVDs.

• When CDDA is chosen: If the selected sample rate (chosen in the PCM pane) is higher
than 44.1 kHz, a copy of the bounced PCM file is created (with an automatic sample
rate conversion to 44.1 kHz) before encoding. This conversion takes place because the
CD Audio format (Red Book) does not support sampling rates higher than 44.1 kHz.

• When DVDA is chosen: Any sample rate up to 192 kHz can be used for stereo files, and
up to 48 kHz for surround files.

Note: Enabling the Burn option automatically disables the PCM > Surround and Split
Stereo options (following a warning message). This is because CD or DVD-Audio only
makes use of interleaved stereo files.
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Simulate Write Only
The “Simulate write only” option, as the name suggests, simulates a CD/DVD burn, but
does not write data to the blank media. This can be used either alone or in conjunction
with the “Write as multi session” option (if burning a CD).

Write As Multi Session
The “Write as multi session” option is only available when CDDA is chosen in the Mode
pop-up menu. This option allows you to add a data session to the same CD at a later
date—to add the project folder, for example.

Device
This pop-up menu allows you to choose between any recognized CD/DVD burners
connected to your system.

Note: If your system contains multiple burners, the first one detected is chosen as the
default.

Speed
The first time you use the Speed pop-up menu, a request is made to the burning
mechanism, which may take a while. Once the scan is complete, you can choose from
the available speeds.

Dithering
The Dithering pop-up menu is only available when CDDA is chosen in the Mode pop-up
menu. Use of the Dithering parameter is recommended when bouncing 24-bit recordings
into 16-bit files.

Note: If you attempt to switch the PCM Resolution to 16 Bit when in DVDA Burn Mode,
DVD burning is automatically disabled (following a warning).

Bounce & Burn
Clicking the Bounce & Burn button initiates the bounce, and burns the audio to a CD or
DVD.

Note: Following confirmation of the file location(s), you may see further dialogs that ask
if you want to overwrite existing files. Use these as necessary.

Media Status and Information Fields
The Media Status field indicates the type of media chosen in the Device pop-up menu.

The field below indicates the current PCM pane settings (if applicable).

A further field, above the Cancel and Bounce & Burn buttons, indicates the amount of
disk space required, and the time (length, shown in hours, minutes, and seconds) of the
bounce area.

Note: You cannot directly alter any information shown in these areas.
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Setting the Bounce Filename and Folder
By default, bounce files are:

• Named after the chosen output channel strip (the Bounce button you clicked), or Output
1-2, if the Bounce window was opened with the File > Bounce command.

• Saved in the Bounces sub-folder of the project folder, but you can choose any folder
on any volume.

To set the bounce filename and folder
1 Type a new filename in the Save As field to change the default filename.

2 Click the New Folder button in the lower-left corner of the Bounce window to create a
new folder, if you like.

3 Click the Bounce (or Bounce & Burn) button.

All files (if multiple files are created) are saved in the chosen folder, and assigned the
name you entered, with appropriate file extensions:  .wav, .aif, .m4a, and so on.

Bouncing and Dithering
Logic Pro provides you with the professional POWr (Psychoacoustically Optimized
Wordlength Reduction) and UV22HR dither algorithms, designed to convert 24-bit
recordings to 16-bit files (as required for CD burning, for example).

POWr dithering can be applied when:

• Bouncing audio files to disk

• Exporting OMF files (See Exporting OMF Files.)

• Exporting AAF files (See Working with AAF Files.)
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You can choose between the following dithering modes:

• None: No dithering is applied.

• POWr #1 (Dithering): A special dithering curve is used to minimize quantization noise.

• POWr #2 (Noise Shaping): Additional noise shaping is used over a wide frequency range,
which can extend the dynamic range of the bounce file by 5–10 dB.

• POWr #3 (Noise Shaping): Additional, optimized noise shaping is used, which can extend
the dynamic range by 20 dB within the 2–4 kHz range—the range the human ear is
most sensitive to.

Note: Noise Shaping minimizes the side effects caused by bit reduction. It does this by
moving the quantization noise spectrum to the frequency range above 10 kHz—the
range the human ear is least sensitive to. Technically, this process is known as spectral
displacement.

• UV22HR: Allows for the best possible sound resolution when bouncing 24-bit recordings
into 16-bit files.

The dithering mode that sounds best to you is primarily dependent on the audio material,
and your personal taste. Audition the audio material with each of the dithering modes
to determine the right setting. In some cases, you may find that the best results are
achieved by using no dithering at all.

Important: Dithering the same audio signal multiple times should be avoided.
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You can save both audio and software instrument regions as Apple Loops in Logic Pro.

For audio regions, a default set of transients—based on the project’s tempo
information—is automatically created. You can also use the Apple Loops Utility to create
Apple Loops from audio regions. The Apple Loops Utility is a companion application to
Logic Pro that allows you to manage metadata tags and transients in audio files. The
Apple Loops Utility offers sophisticated tag editing functions for audio files. You can, for
example, set the transients manually—independent of the project tempo. The Apple Loops
Utility does not allow you to create Software Instrument Apple Loops (SIALs).

You use the Apple Loops creation utilities available in Logic Pro to create any of the
following files: an Apple Loops file based on an audio file that matches the project tempo,
a Software Instrument Apple Loops (SIAL) file, or a nonlooped Apple Loops file based on
an audio file that does not match the project tempo. Nonlooping Apple Loops (or
one-shots) do not follow the project tempo and key. This is useful if you want to add
discrete, nonmusical sounds (such as sound effects) to the loop library, which should not
be altered by the tempo and key properties.

If you want to create a looped Apple Loops file based on an audio file that does not match
the project tempo, use the Apple Loops Utility.

This chapter covers the following:

• Creating Apple Loops in Logic Pro (p. 850)

• Creating Apple Loops in the Apple Loops Utility (p. 853)

• Converting ReCycle Files into Apple Loops (p. 854)

• Adding Apple Loops to the Loop Browser (p. 856)

• Adding Acid Loops to the Loop Browser (p. 857)

• Using Global Tracks with Apple Loops (p. 857)

• Converting Apple Loops to Audio Files (p. 859)

• Converting the Sample Rate of Apple Loops (p. 860)
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Creating Apple Loops in Logic Pro
When you save a region as an Apple Loops file in Logic Pro, the region is added to the
loop library and appears in the Loop Browser, allowing it to be used in other projects.
The tempo information of the project is used to tag the transients of user-created
Apple Loops. This function works best if your audio files match the project tempo as
precisely as possible.

Note: User-created Apple Loops behave exactly like the Apple Loops that come with
Logic Pro, GarageBand, and Jam Packs. They follow the project tempo and match the
project key (as defined by the initial key signature). Apple Loops will also follow any chord
transpositions in the Chord track. For further information, see Using Global Tracks with
Apple Loops.

To create an Apple Loops file in Logic Pro
1 Do one of the following:

• Select an audio or software instrument region in the Arrange area, and choose Region
> Add to Apple Loops Library in the local Arrange menu (or use the Add Region to
Apple Loops Library key command).

• Drag an audio or software instrument region into the Loop Browser.

2 In the Add Region to Apple Loops Library dialog that appears:

• Type in a name for the loop and choose the scale, genre, instrument category,
instrument name, and appropriate mood descriptions to simplify searches.

850 Chapter 30 Creating Apple Loops



• Set the file type, which can be One-shot or Looped. If the length of the audio file is not
precisely trimmed to contain a number of whole bars, One-shot is selected automatically,
and the file type buttons are dimmed (and inaccessible).

Note: One-shots do not follow the project tempo and key. This is useful if you want to
add discrete, nonmusical sounds (such as sound effects) to the loop library. It would
generally not be desirable to have such sounds affected by the tempo and key properties
of the project. These types of loops still contain metadata tags, allowing easy searching
and categorization in the Loop Browser.

3 Click Create.

The loop is added to the Loop Browser. It will be stored in
~/Library/Audio/Apple Loops/User Loops/SingleFiles. You can find it by using the category
buttons, menus, or by typing the (whole or partial) name in the search field. If you drag
the loop into the Arrange area, the Apple Loops symbol is shown beside the filename.
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Because one-shots are handled like normal audio files, the usual stereo or mono region
symbol is shown alongside the filename (rather than the Apple Loops symbol).

If you want to create a looped Apple Loops file from an audio file that does not match
the project tempo, you should use the Apple Loops Utility. The Apple Loops Utility allows
you to define the intended length of the loop, regardless of the project tempo, by manually
setting the Number of Beats and Time Signature tags.

Note: The Apple Loops Utility only works with audio regions—not with MIDI regions on
instrument tracks. For further information, see Creating Apple Loops in the Apple Loops
Utility.

Adjusting the Project Tempo to an Audio file
You can also adjust the project tempo to the file length. Logic Pro offers an automatic
function that matches the length of an audio region with the intended musical length.
The length of the region remains constant, but the sequencer tempo is varied
automatically, with the region playing back at the intended length. For full details, see
Setting the Project Tempo to Match an Audio Region.

Re-creating Effects in Software Instrument Apple Loops
If you create a Software Instrument Apple Loops (SIAL) from a region on a software
instrument track that uses sends to bus effects, and then drag the saved loop to another
(empty) instrument track, the new loop will sound different from the original source
region. This happens because the effects sends in the original track are not saved with
the loop.

Logic Pro does not automatically assign effects to busses, because doing so would
potentially interfere with bus configurations that you’ve already set up in your project.
Effects that are inserted directly into the software instrument channel strip will, however,
be automatically recalled when the loop is dragged into the Arrange area from the Loop
Browser.
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You can use one of the following options to ensure that loops created from software
instrument regions will sound the same as the original regions:

• Drag your SIAL (the original of which was assigned to bus sends) to an audio track
instead of an instrument track. When you create a software instrument loop, the audio
file that is rendered will include any bus processing. This will sound identical to the
original.

• When creating a loop from a software instrument region, you should directly insert all
effects needed to reproduce the desired sound into the instrument’s channel strip. This
will allow all sound elements to be faithfully re-created when you add the loop to an
instrument track.

• When using SIALs on an unassigned channel strip, manually set up the sends and bus
effects needed to reproduce the sound of the original region.

Reindexing the Apple Loops User Library
There may be occasions when you need to reindex your Apple Loops user library—after
you move loops from the User Loops folder to another hard disk, for example.

To reindex the Apple Loops user library
µ Control-click (or right-click) the Loop Browser’s search results area, then choose Reindex

Apple Loops User Library from the shortcut menu.

Creating Apple Loops in the Apple Loops Utility
The Apple Loops Utility provides sophisticated functions for creating Apple Loops from
audio regions. It can detect transients present in an audio file, and you can add markers
for additional transients. You can also move these transient markers to new locations.

To create an Apple Loops file in the Apple Loops Utility
1 Select an audio region in the Arrange area.

2 Choose Audio > Open in Apple Loops Utility from the local Arrange menu (or use the
corresponding key command).

If the length of your audio file does not match the bars or beats, the following dialog
appears:
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There are two possible reasons for the wrong length:

• The audio recording was recorded at the project tempo, but not cut correctly. In this
situation, you can reduce the length of the recording using the Shorten button. The
purpose of the Shorten button is to cut off small areas before the first bar/beat and
after the last bar/beat of a region. For example, if your recording (without a defined
cycle area) starts at 1 4 4 200 and stops at 5 1 1 180, using the Shorten button
automatically shortens the region to start at 2 1 1 1 and to stop at 5 1 1 1.

Note: The Shorten button does not shorten the region to the entered number of bars
or beats.

• The loop uses a different tempo. In this case, you can set the length of the audio loop
in the “Loop length” box and choose “Use set length.”

For more information about the Apple Loops Utility, see the Apple Loops Utility User Manual.

Converting ReCycle Files into Apple Loops
Logic Pro allows you to convert ReCycle files into Apple Loops. You can either import
ReCycle files as Apple Loops or convert multiple ReCycle files with the Batch Convert
function found in the File Browser.

To import single ReCycle files as Apple Loops
1 Initiate a ReCycle import by doing one of the following:

• Choose File > Import Audio File (or use the corresponding key command), and select
the ReCycle loop in the dialog that appears.

• Shift-click an audio track with the Pencil tool (or Command-Shift-click with the Pointer
tool), and select the ReCycle loop in the dialog that appears.

• Drag the ReCycle loop from the Browser onto an audio track.

• Drag the ReCycle loop from the Finder onto an audio track.

2 Choose the Render into Apple Loop setting in the Fix Method pop-up menu of the
“ReCycle file import” dialog, then click OK.
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3 In the Add Region to Apple Loops Library dialog that appears:

• Type in a name for the loop, choose the scale, genre, instrument category, instrument
name, and appropriate mood descriptions—to simplify searches.

• Set the file type, which can be One-shot or Looped. If the length of the audio file is not
precisely trimmed to contain a number of whole bars, One-shot is selected automatically,
and the file type buttons are dimmed (and inaccessible).

Note: One-shots do not follow the project tempo and key. This is useful if you want to
add discrete, nonmusical sounds (such as sound effects) to the loop library. It would
generally not be desirable to have such sounds affected by the tempo and key properties
of the project. These types of loops still contain metadata tags, allowing easy searching
and categorization in the Loop Browser.

4 Click Create.

The ReCycle loop is converted to an Apple Loops file (the slice points are converted to
transient positions) and copied to the ~/Library/Audio/Apple Loops/User Loops/SingleFiles
folder. The Apple Loops file is added to your Logic Pro project and you can find it in the
Audio Bin. If the “Copy external audio files to project folder” setting in Asset project
settings is turned on, the Apple Loops file is also copied to a new ReCycle Audio folder
inside the project folder.
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As an alternative, you can use the Batch Convert function found in the Browser to
simultaneously convert multiple ReCycle files into Apple Loops.

To convert multiple ReCycle files into Apple Loops
1 Select the ReCycle files in the Browser.

2 Open the action menu, and choose Convert ReCycle Files to Apple Loops.

3 In the dialog that appears, select a location for the converted files.

The ReCycle files are converted to Apple Loops (the slice points are converted to transient
positions) and copied to the chosen location.

Adding Apple Loops to the Loop Browser
Logic Pro must index Apple Loops before they are shown in the Loop Browser. Loops can
reside in any directory, but you need to tell Logic Pro where to find them.

To add Apple Loops to the Loop Browser
1 Open a Finder window alongside Logic Pro.

2 Navigate to the folder that contains the Apple Loops.

3 Select the Apple Loops in the folder and drag them into the Loop Browser.

The loops are added to the Apple Loops library and indexed. When this process is finished,
the loops are directly available in the Loop Browser.

If you drag a single loop to the Loop Browser, the loop will be copied to
~/Library/Audio/Apple Loops/User Loops/SingleFiles.

If you drag a folder of loops that are located on the same drive and partition as the Loop
Browser, the loops will be left at their current location, and an alias of the folder will be
created in ~/Library/Audio/Apple Loops/User Loops.

If the loops are located on a different drive or partition, you are asked whether you want
to copy them to the loop library, or index them at their current location (loops added
from optical media are always copied).

• If you choose to copy them, the folder containing the loops are copied to
~/Library/Audio/Apple Loops/User Loops/.

• If you choose to index them at their current location, an alias to the folder is created
in ~/Library/Audio/Apple Loops/User Loops/.
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Adding Acid Loops to the Loop Browser
The Loop Browser also displays Acid Loops. Acid Loops don’t contain tags like Apple Loops.
In Acid Loops, this information is derived from the surrounding folder structure (especially
the names of folders), which must comply with certain standards. This means that it’s not
possible to drag an individual Acid Loops file into the Loop Browser.

As such, you need to drag the entire CD (or folder) that contains the Acid Loops into the
Loop Browser.

Using Global Tracks with Apple Loops
You can use the global tracks to change global events such as time signature and key
during a project. The following section summarizes how these changes in the global
tracks affect the playback of Apple Loops. Exceptions are the Tempo and Beat Mapping
Tracks, as Apple Loops adjust automatically to the tempo of these tracks.

Using the Signature Track with Apple Loops
Apple Loops can contain information about their original key, and can be transposed
automatically. They are played back at the project key by default, which is defined by the
first key signature event. No distinction is made between major and minor keys for these
global transposition functions; in fact, only the root of the initial key signature is relevant
for playback of Apple Loops.

Note: When you change the key signature after importing Apple Loops, the playback of
SIALs is not affected. They behave like normal MIDI regions. The playback of MIDI regions
is not affected by key signature changes, only the display in the Score Editor.

The playback transposition for Apple Loops is controlled by the root note of chords in
the Chord track. These root notes determine the global playback transposition—relative
to the current key signature—shown in the Signature track. If no chords are available in
the Chord track, the global playback key for Apple Loops is determined by the very first
key signature in the Signature track (default:  C major).

Using the Chord Track with Apple Loops
The root notes of chords in the Chord track determine the transposition (pitch shifting)
of all Apple Loops.
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The Change Display Only mode does not work with Apple Loops used on audio tracks.
This shouldn’t pose a problem, as you won’t normally need this function when working
with Apple Loops. There is one exception, however:  some Apple Loops contain chord
progressions. These chord progressions are not displayed in the Chord track. Unfortunately,
you can’t use the Chord track’s Change Display Only mode to match the displayed chords
to what is actually being heard. All changes in the Chord track affect the transposition of
(audio, not instrument) Apple Loops. Activating the Change Display Only option doesn’t
help.

To work around this problem
1 Cut the (audio) Apple Loops file at the precise positions of any chord changes.

2 Match the chords displayed in the Chord Track with the chord progression in the cut
Apple Loops files by manually entering the chords of each section in the Chord track. The
individual Apple Loops parts will then be transposed accordingly.

3 Enter the inverted Transposition values of the chord root note changes in the Region
Parameter box of each section, so that playback of the Apple Loops parts will match the
original Apple Loops file.

For example, assuming a default project key of C:

• The (audio) Apple Loops file contains a chord progression with root notes of C, F, G,
and C. Cut it at these chord change positions. This will result in four regions.

• Enter C, F, G, and C at the corresponding positions in the Chord track. Assuming the
original key is C, this is equivalent to a transposition of the second region by +5 and
the third region by +7 semitones. If you played the entire part at this point, the original
audio material would be transposed by the amounts just entered in the Chord track,
which isn’t what you want.

• Set the Transposition value of the second region to −5, and of the third region to −7
in their respective Region Parameter boxes.

Playback of the whole part will now sound as it did before the cuts, and the correct chords
are displayed in the Chord track.

Using the Transposition Track with Apple Loops
Transposition events are closely linked to the progression of the chord root notes in the
Chord track:  Changing a chord root will be reflected in the Transposition track, and vice
versa. Any alteration or creation of a transposition event will generate or alter the
corresponding chord in the Chord track. All Apple Loops and MIDI regions will be
pitch-shifted accordingly.

Note: Standard audio regions (audio regions that are not Apple Loops) will not be affected.
Nor will Apple Loops that do not have a Key definition (drum loops, for example).
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The global Transpose track transposes Apple Loops used on audio tracks by a maximum
of that great when transposed over a greater range. This is also true for the Transposition
parameter of the Region Parameter box.

Apple Loops Transpose to the Wrong Octave
Transposing an Apple Loops file to a higher pitch may result in the loop being played
back at a lower pitch, and vice versa.

For example, if an Apple Loops file is transposed to sound seven semitones higher, it will
actually play back five semitones lower. This is harmonically correct transposition, but it’s
probably not to the intended octave.

Transposing audio material is a technically complicated process that always implies a
certain loss in quality. The greater the transposition range, the more significant the loss
in quality. This is why Apple Loops are always transposed by the smallest possible value.

You should note that sound quality is dependent on the transposition amount of the
Apple Loops file’s original key—not the project key, which defines the zero line of the
Transposition track. For example, if the project key is already five semitones above the
original key of an Apple Loops file, setting the transposition value to +2 will transpose
the Apple Loops file downwards by ten semitones. This is because the transposition value
is only five semitones below its original key (rather than seven semitones above it).

In the classical European music system, an octave is divided into 12 semitones. As
+7 semitones is harmonically equal to −5 semitones, a value of −5 is used as the
transposition amount. The same happens with other settings:  A transposition value of
−9 will result in +3, and +12 will result in ± 0. The use of the nearest harmonically equal
transposition option is based on delivering the best sonic results, with smaller
transpositions being desirable.

Converting Apple Loops to Audio Files
When you convert an Apple Loops file into an audio file, the resulting file may not play
at the project’s current tempo and key settings. Rather, the new audio file will play at the
original tempo and key of the Apple Loops file.

This happens when you select an Apple Loops file and choose Audio > Convert Regions
to New Audio Files from the local Arrange menu, and change the File Format parameter
in the ensuing window to AIFF. This creates a copy of the original Apple Loops file, but
without the transient and category tags. The lack of these tags restricts file playback to
the originally recorded tempo and key of the Apple Loops file—not the tempo and key
of the project.
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If you want to turn an Apple Loops file into an audio file that uses the project’s tempo
and key settings, select the loop (or loops) and choose File > Export > Region as Audio
File. Be sure to select the “Add resulting files to Audio Bin” checkbox to use the new file
in your current project.

This will export the Apple Loops file as a new audio file with all plug-in effect processing
of the track/channel on which the Apple Loops file is placed. To export the Apple Loops
file without these effects, bypass them before exporting the region.

You should note that although this new file will play at your project’s current tempo and
key, it can’t follow subsequent tempo or key changes like other Apple Loops; such files
are fixed at the project tempo and key that was in use when the file was exported.

Tip: If you enable the Follow Tempo option for the audio file, it will follow the project
tempo and the first key signature set in the global tracks. For further information, see
Automatic Tempo Matching.

Converting the Sample Rate of Apple Loops
The method used to convert the sample rate of audio files also applies to Apple Loops.

To convert the sample rate of an Apple Loops file
1 Select an Apple Loops file in the Audio Bin.

2 Do one of the following:

• Choose Audio File > Copy/Convert File(s) from the Bin’s local menu bar (or use the
corresponding key command).

• Control-click (or right-click) the Audio Bin, and choose Copy/Convert File(s) from the
shortcut menu.

3 Choose a sample rate (and all other file conversion settings) in the ensuing dialog, select
the folder location, then click Save.

The file is converted based on the originally recorded tempo and key of the Apple Loops
file—not the tempo and key of the project.

Note: If a new Apple Loops file is created, it needs to be indexed to make it visible in the
Loop Browser. Loops can reside in any directory, but you need to tell Logic Pro where to
find them.

You will probably not need to convert Apple Loops as often as standard audio files when
working with Logic Pro, as Apple Loops offer a major advantage:  if the sample rate of
your project is changed, the playback speed of all Apple Loops currently used in the
project is automatically adapted to the newly selected sample rate.
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The Score Editor allows you to view and edit MIDI regions as traditional music notation.
This chapter will not teach you music theory, nor how to read or write music notation.
Its purpose is to introduce you to the way Logic Pro allows you to create, edit, lay out,
and print music—in notation form.

This chapter covers the following:

• Opening the Score Editor (p. 862)

• Getting to Know the Score Editor (p. 864)

• Understanding the Basic Scoring Stages (p. 864)

• Entering Notes and Symbols in the Score Editor (p. 868)

• Working with the Part Box (p. 874)

• Learning About Part Box Groups (p. 877)

• General Editing in the Score Editor (p. 889)

• Editing Notes in the Score Editor (p. 896)

• Creating and Inserting Rests in the Score Editor (p. 902)

• Editing Clefs in the Score Editor (p. 904)

• Editing Slurs and Crescendi in the Score Editor (p. 905)

• Editing Repeat Signs and Bar Lines in the Score Editor (p. 908)

• Working with Standard Text (p. 909)

• Working with Automatic Text (p. 916)

• Working with Lyrics (p. 917)

• Working with Chords (p. 918)

• Working with Chord Grids (p. 921)

• Working with Tablature Markings (p. 943)

• Working with Time and Key Signatures (p. 944)

• Transcribing MIDI Recordings (p. 951)

• Default Settings for New MIDI Regions (p. 951)
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• Selecting Multiple Regions in the Score Editor (p. 952)

• Display Parameters (p. 953)

• Hidden MIDI Regions (p. 958)

• Using Note Attributes to Change Individual Notes (p. 958)

• Working with Staff Styles (p. 964)

• Using Score Sets to Create Scores and Parts (p. 985)

• Preparing the Score Layout for Printing (p. 991)

• Exporting the Score as a Graphic File (p. 996)

• Customizing the Score Editor’s Appearance (p. 997)

Opening the Score Editor
There are several ways to open the Score Editor in Logic Pro.

To open the Score Editor as a pane in the Arrange window
Do one of the following:

µ Click the Score button at the bottom of the Arrange window (or use the Toggle Score
Editor key command, default assignment:  N).

µ Double-click a MIDI region.

Note: In order for this option to work, you need to choose the setting “Double-clicking
a MIDI region opens:  Score” in the Logic Pro > Preferences > General > Editing pane.

To open the Score Editor as a separate window
Do one of the following:

µ Choose Window > Score (or use the Open Score Editor key command, default
assignment:  Command-3).
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µ Drag the Score button, which changes to the Score Editor window as you drag it.

µ Hold down the Option key and double-click any event in the Piano Roll Editor.
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Getting to Know the Score Editor
The main elements of the Score Editor are as follows:

Event parameter box

Display parameter box

Part box

• Display Parameter box: Allows you to modify the rhythmic display of MIDI regions,
without altering playback.

• Event Parameter box: Allows you to change the appearance and positioning of objects.

• Part box: Contains groups of objects that can be inserted into the score.

Understanding the Basic Scoring Stages
This section provides an overview of how you would approach the creation of a musical
score in Logic Pro.

• Stage 1: Getting Notes into the Score

• Stage 2: Using Display Settings to Create Readable Notation

• Stage 3: Editing Note Events
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• Stage 4: Inputting Events, Symbols, and Text

• Stage 5: Editing the Whole Score

• Stage 6: Printing a Score

Stage 1: Getting Notes into the Score
There are basically three ways you can do this:

• Real-time recording from your MIDI keyboard. (See Entering Notes and Symbols Using
Real-Time Recording.)

• Step recording, using either your MIDI keyboard or the Caps Lock keyboard. (See
Entering Notes and Symbols Using Step Input.)

• Manual entry with the computer keyboard or mouse. (See Entering Notes and Symbols
Using Mouse Input.)

The Score Editor displays the contents of MIDI regions, which act as containers for note
(and other) events. You need to create, and select, a MIDI region in the Arrange area if
you want to work in the Score Editor.

Note: Double-click the background of the Score Editor (with the Pointer tool) if you want
to see the regions of all MIDI tracks (software and external MIDI) as staffs.

Stage 2: Using Display Settings to Create Readable Notation
Logic Pro interprets MIDI regions for the score display, using a variety of user-defined
methods.

Note events are represented as crotchets, quavers, and so on. Spaces between notes are
represented as rests. Sustain pedal data can also be represented in your score.

Your goal should be to retain the feel of real-time recordings (if this is how you added
note data to Logic Pro), while still rendering a score that is readable by other musicians.

If you like the sound of playback, but not the way the score looks, you can usually obtain
the preferred results by changing a few settings in the Display Parameter box and the
overall Score project settings. (See Transcribing MIDI Recordings.)

• Display Parameter box: The parameters of the Display Parameter box mainly affect the
rhythmic display of selected MIDI regions. They only apply to the score display, and do
not affect the playback of MIDI regions. They can be different for each region. Some
of these (region-based) parameters can be overridden for individual notes, by using
note attributes.

• Project settings: You can set general display options that affect the whole project in the
Score project settings window. (See Score Settings.) These options include spacing
between notes, page margins, line thickness, display of instrument names, bar and
page numbers, and more.
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Important: Score display parameters have absolutely no effect on MIDI playback, just on
the way MIDI data is shown in the Score Editor. This separate notation display system
allows you to adjust the look of the notation, without changing the original MIDI region
data (and therefore, the performance).

You can further control the display by selecting or creating staff styles, text styles, and
score sets, that best fit your music.

• Staff styles exist for most common single and multi-staff types, and can be chosen from
the Display Parameter box’s Style menu. These include Piano, Guitar, Horn in Eb, Organ,
and even Drum styles. Choose the one that best represents the instrument part as
notation. If none of the existing styles is appropriate, you can easily create your own.
(See Working with Staff Styles.)

Single staff style

Staff style consisting of 
two staffs

• Score sets allow you to determine which instruments are displayed (and printed) in a
score. You can include as many (or few) of the existing track instruments into a score
set as you like. (See Using Score Sets to Create Scores and Parts.) This makes it easy to
create separate sheet music for the violinists, or French horn players, for example.

• Text styles are used to control several different text elements of your score, such as the
title, lyrics, copyright information, instrument names, and so on. Each of these text
elements can be assigned a font style, size, and more within the overall text style. (See
Working with Standard Text.)

Stage 3: Editing Note Events
Even with all of the display options available when working in the Score Editor, you may
need to adjust the appearance of some notes. You can do this using the functions in the
Note Attributes menu. These commands let you adjust individual note events, allowing
enharmonic shifts, accidentals, ties, beaming, and much more.
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This function can also be used on multiple selected notes, which is useful on those rare
occasions when the display settings don’t deliver acceptable results.

Stage 4: Inputting Events, Symbols, and Text
Few scores consist solely of note (and rest) events.

The Part box contains a number of symbols (pedal markings, slurs, and so on) that can
be inserted into the score by dragging them into position with the mouse. The Part box
also contains all types of note events, clefs, bar line markers, and more. Again, these can
easily be added by dragging and dropping. (See Working with the Part Box.)

Rests are usually displayed automatically in Logic Pro, and don’t need to be inserted
manually, but can be, if needed, from the Part box. (See Creating and Inserting Rests in
the Score Editor.)

The entry of lyrics, title, and other text elements is also done via the Part box, or with the
Text tool. (See Working with Standard Text.)

Stage 5: Editing the Whole Score
Once you’ve recorded or inserted all (or most) of the notes and symbols into your score,
and edited individual elements, the next step is to polish the score’s layout.

This process typically includes using tools to reposition staffs, and changing the Score
project settings to adjust the number of bars per line, set page margins, and more. All
project layout options are discussed in Score Settings.

Layout work is done in Page Score view, which displays as many facing pages as possible
(depending on the size of the Score Editor window and current zoom level).
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To switch between the default score display (called the Linear Score view) and Page
Score view

µ Click the Page View button (to the left of the Layout menu button).

Tip: You should use Linear Score view for editing, as screen redraws are much faster,
especially on slower computers. Page Score view should only be used for layout work, in
preparation for printing. Further details on Page Score view can be found in Customizing
the Score Editor’s Appearance.

Stage 6: Printing a Score
The last step is printing your score. The printed result always corresponds to what you
see in the Score Editor window. (Page Score view must be turned on.)

To print the score
1 Choose File > Print (or use the corresponding key command, default

assignment:  Command-P).

The Print dialog opens.

2 Choose printing options (including printing to PDF), and click the Print button.

Before printing, you may want to turn on Print view, which shows the page margins
onscreen.

To turn on Print view
µ Choose View > Page Display Options > Print View (only accessible when Page Score view

is active).

More information can be found in Printing the Score.

Entering Notes and Symbols in the Score Editor
You can add notes and symbols in the following ways:

• Real-time MIDI recordings (notes and sustain pedal markings only)

• MIDI step input (notes only). This can be done with the computer or a MIDI keyboard.

• Dragging notes or symbols from t7he Part box to the staffTo copy or convert audio
files in the Sample Editor Choose Audio File > Save A Copy As. Choose settings in the
Save A Copy As dialog.
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• Fast input of symbols by assignment to selected notes with key commands. These are
available for some symbols that are attached to notes (accents, jazz symbols, and so
on), and slurs or crescendi.

• Hyper Draw allows you to insert and edit MIDI events that aren’t normally displayed in
the Score Editor, such as continuous controller data (volume, pitch bend, and so on).
See Creating and Editing Controller Events Using Hyper Draw for more information.

The display of input notes (and symbols) depends on the Score Editor’s display settings
(especially those in the Display Parameter box), and the note attributes. (See Transcribing
MIDI Recordings and Using Note Attributes to Change Individual Notes.)

MIDI playback is also influenced by the settings in the Region Parameter box and Track
Parameter box. Settings in the Environment may also affect MIDI playback, if configured
to do so.

Entering Notes and Symbols Using Real-Time Recording
Although real-time MIDI recordings are usually made in the Arrange area, you can also
start recording directly from the Score Editor. You must first select the destination track
in the Arrange area’s track list. You can do this directly from the Score Editor, by clicking
a staff associated with the track. If no MIDI regions exist on the track, you need to switch
to the Arrange area for recording, because the track won’t be displayed in the score. (The
Score Editor only shows regions and folders.) For more information about MIDI recording,
see Getting to Know MIDI Recording.

Entering Notes and Symbols Using Step Input
Step input in the Score Editor works in the same way as in other editor windows. (See
MIDI Step Input Recording.)

However, the Score Editor (and Piano Roll Editor) allows the content of several regions
to be displayed, and edited, at the same time. This feature results in a few differences
regarding step input:

• The MIDI region that you want to insert notes into must be selected. (Click the staff.) If
no staff is visible, you must first create an empty MIDI region in the Arrange area.

• Simultaneous step input into several regions is not possible. If more than one MIDI
region is selected, the notes are only inserted into one of them.

• If several MIDI regions follow one another on the same arrange track (even those with
gaps in between them), you can step input notes from one MIDI region to the next. As
soon as the playhead reaches the beginning of the next MIDI region, Logic Pro
automatically inserts the notes into it.

To prepare for step input
1 Make the following adjustments to the display settings for the selected MIDI region:

• Interpretation should be turned off. (See Interpretation.)
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• The Display Quantize setting should be set to the smallest note value that you intend
to insert. (See Quantize.)

2 Set the first playhead insert position by Option-clicking the staff at the appropriate point.
The selected position is displayed in the help tag while the mouse button is pressed.

This function is especially helpful in Page Score view, where no Bar ruler is displayed.

Note: You can only set the playhead position when Logic Pro is stopped.

Entering Notes and Symbols Using Mouse Input
A staff must exist before notes, symbols, and text elements (called objects in the following
sections) can be inserted. Each staff (including empty staffs) represents one or more
regions.

To input notes or symbols with the mouse
1 Select an object in the Part box. (See Selecting Part Box Objects.)

2 Do one of the following:

• Drag it to the staff, then release the mouse button.

• Select the Pencil tool in the Tool menu, then click a staff position.

As a positioning aid, a help tag appears while the mouse button is held down. Drag until
the correct position is shown in the help tag, then release the mouse button. The help
tag is especially important for positioning when working at smaller zoom levels.
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When working in Full Score view (when more than one MIDI region is displayed), and
inserting objects between the staffs (such as dynamic symbols), you should make sure
that these symbols have been inserted into the appropriate MIDI region. The target MIDI
region is automatically selected (green staff lines) once the object has been inserted. You
can also see the name of the selected region in the top line of the Display Parameter box.

Tip: It’s generally better to change to single staff display (Linear Score view) when inserting
objects that are positioned between staffs—especially lyrics.

Although it doesn’t matter which MIDI region (staff ) an object belongs to in Full Score
view (as they stay where they are placed), such objects can be displayed with the wrong
instrument when single instrument parts are later displayed and printed.

To switch to single region display
µ Double-click the MIDI region (staff ).

To switch back to the full score display
µ Double-click in the empty space below or above the staff.

This displays the full score, including all MIDI regions in the project.

For full details on all Part box objects and features, see Working with the Part Box.

MIDI Channel and Velocity of Inserted Objects
The MIDI channel and velocity of objects inserted with the mouse are determined by the
Insert Defaults settings in the Event Parameter box. These are visible (and can be edited),
when no object is selected.
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To display the Insert Defaults settings
µ Click anywhere in the background of the working area.

When inserting events into a staff that uses a polyphonic staff style, only MIDI channels
that correspond to those of the voices can be used. (See Adding Staffs to a Staff Style.)

Many symbols display a MIDI channel in the Event List. For most objects, the MIDI channel
determines the staff (theoretically, up to 16) that the symbol belongs to, in polyphonic
staff styles.

Note: If this parameter is set to a value that exceeds the number of staffs in the staff style,
the symbol disappears.

Insert Quantization
To make positioning of notes and symbols easier, objects can only be inserted at certain
bar positions:

• There is an invisible note positioning grid. Imagine that the whole bar—beginning at
beat one—is filled with notes of the chosen value. For example, in an empty 4/4
measure, half notes can only be inserted on beats one and three, eighth note triplets
only on the first, second, or third eighth note triplet of every beat.

• All binary and dotted values can be inserted at any position of an automatically displayed
rest. This means that if there is an eighth note on (count) one, you can insert a quarter
or a dotted quarter note at the second eighth’s position. In this situation, Interpretation
must be turned off in the Display Parameter box, to allow the display of the eighth note
rest on the “and” of beat one. (See Interpretation.) The Syncopation setting determines
how the inserted note is displayed, in this example.

• Symbols (except those directly attached to notes) can be inserted at any Quantization
parameter grid position. For hybrid quantization values (such as 8,12), the insert
quantization is determined by the binary value (1/8 in this example).

Simultaneous Input of Objects into Several Regions
Press Shift to insert an object from the Part box into all currently selected regions, at the
same position. (The help tag shows Insert Multi while you’re performing this action.) This
technique allows you to insert notes, symbols, and even text elements into several regions
at once.
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You can make the multiple MIDI region selection in either the Arrange area or the Score
Editor. Shift-click (or drag to select) all applicable regions or staffs.

Following selection, the top line of the Display Parameter box indicates the number of
staffs (regions) that have been chosen.

Note: Key changes, signature changes, and global signs are automatically inserted into
all staffs of the project, and cannot be inserted into individual, selected staffs.

Creating and Editing Controller Events Using Hyper Draw
You can directly create and edit MIDI controller information in the Score Editor. These
types of edits are made easier when you can see the notes that will be affected.

To view and create controller events
1 Open a Hyper Draw display in the Score Editor by doing one of the following:

• Choose the appropriate View > Hyper Draw command.

• Click the Hyper Draw button in the lower-left corner of the Score Editor, then choose
a MIDI controller by clicking the arrow button to the left.

The selected controller type (volume, for example) is shown in a gray field below the
Score Editor area. An event value scale is displayed in the instrument name column if
View > Instrument Names is activated.

2 Click at different points in the gray area to create Hyper Draw nodes.

A connecting line is automatically created between the nodes.
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To resize the Hyper Draw area
µ Grab and vertically move the dividing line that separates the Hyper Draw area from the

Score Editor area.

For more information, see Using Hyper Draw in the Arrange Area.

Note: Hyper Draw can only be used in Linear Score view, and when a single MIDI region
is displayed. If you switch to another view (Page Score view, or Full Score view), the Hyper
Draw area disappears. The view settings are stored, however, so when you return to single
MIDI region and Linear Score view, the previous Hyper Draw setting is recalled.

Working with the Part Box
The objects available in the Part box (notes, symbols, text objects) are organized into
groups. The top section contains small squares, with each representing a group. You can
view this as the Part Box Group menu, if you like. All group elements are shown in a panel
below—called the Part Box Elements display.

Group elements

Part Box Group menu
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To change the arrangement of groups
µ Click one of the squares in the Part Box Group menu.

The corresponding group moves to the top of the panel, allowing easy access to its
elements.

Note: Any element can be selected and inserted from any group panel, at any time. The
group rearrangement function simply makes it easier to work with the Part box, especially
on smaller screens, or when using small Score Editor windows.

To lock Part box group positions
µ Choose View > Partbox > Lock Group Positions.

Choose the command a second time to unlock group positions.

To show only the symbols of the currently selected group in the Part box
µ Turn off the View > Partbox > Show All Groups setting.

Selecting Part Box Objects
You can select any Part box object (a note, slur, clef, and so on) by clicking it. If a particular
object group isn’t visible in the Part box, click the corresponding square in the Part Box
Group menu to move the object group to the top of the panel.

To select an object directly from the Part Box Group menu
µ Hold down the mouse button on one of the squares in the Part Box Group menu, then

choose an object from the menu that appears.

To open a small Part box group window
µ Double-click one of the group menu squares.

A small floating window, called a palette window, opens. It contains all objects in the
group, and can be freely moved. Objects can be dragged directly from palette windows
into any position in the score. You can simultaneously open as many palette windows as
needed.

Note: Unlike the regular Part box, the selected object is not highlighted in the palette
window.
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The palette windows can have different shapes, depending on the modifier key you hold
down while double-clicking a Part Box Group menu square:

• Normal (Control key)

• Vertical (Option key)

• Horizontal (Command key)

The default shape of palette windows (opened with a simple double-click) can be
predefined in the Logic Pro > Preferences > Score > Floating Palette View pop-up menu.

Selecting Part Box Objects with Key Commands
The following unassigned key commands select the corresponding note values in the
Part box. These note values can then be quickly inserted with the Pencil tool:

• Partbox:  1/1 Note

• Partbox:  1/2 Note

• Partbox:  1/4 Note

• Partbox:  1/8 Note

• Partbox:  1/16 Note

• Partbox:  1/32 Note

If you execute any of these key commands more than once, the following applies:

• Twice in succession, the corresponding triplet value is selected.
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• Three times selects the dotted value.

• Four times returns to the original value.

Further key commands can also change the selection inside the Part box:

• Next Partbox Symbol and Previous Partbox Symbol: The Next Partbox Symbol key
command selects the symbol to the right of the selected object. The Previous Partbox
Symbol key command selects the object to the left. When the last object in a group is
reached, selection cycles back to the first object in the group.

• Next Partbox Group and Previous Partbox Group: The Next Partbox Group key command
selects the object group below the current (selected) one. Previous Partbox Group
moves one group up. The most recently selected object within each group is retained
when switching between groups.

Note: As the group display can be reordered, the current display order of groups
determines the previous and next group.

Learning About Part Box Groups
The following section provides a basic overview of the individual Part box groups. Detailed
information on note and other object editing (as applicable) is found in General Editing
in the Score Editor.
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Note Objects in the Part Box
The Part Box Group menu square that represents notes, in the top section of the Part
box, is divided into three parts:  notes, dotted notes, and triplet notes. These correspond
to three note object groups.

To move the note, dotted note, or triplet note group to the top of the group panel
µ Click the corresponding symbol (note, dot, or 3) within the note square.

Inserting any of these symbols creates a MIDI note event, of the exact note length value.
For display purposes, however, all of these MIDI notes are interpreted by Logic Pro as if
they were recorded in real time.

Adjust the Display Parameter box settings to correctly display inserted notes. See the
Display Parameter box section in Transcribing MIDI Recordings.
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Sustain Pedal Symbols in the Part Box
These two symbols are the only score symbols—apart from notes—that directly represent
MIDI events (MIDI controller #64, sustain pedal on and off ), and thus affect MIDI playback.
Logic Pro intelligently inserts the on or off version of the symbol, depending on the status
of the type that preceded it. (A sustain off always follows a sustain on, and vice versa.)

Clef Objects in the Part Box
The clefs in the Part box are generally intended for clef changes in the middle of a part,
for a short section of the music; for example, cello or bassoon parts, when the part changes
to a higher register. Inserted clefs change the score display, starting at the precise insert
position (which can even be in the middle of a bar).

Note: You shouldn’t use the Part box clefs to change the clef of a whole MIDI region. In
this situation, choose an appropriate staff style for the region. See Working with Staff
Styles.
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Dynamic Symbols in the Part Box
Dynamic symbols can be inserted at any position in the score. They are purely graphic
symbols, and have no effect on the playback of regions they are placed in.

Note Head Symbols in the Part Box
If you drag one of these symbols onto a note, the note head changes to that of the
selected symbol. If multiple notes are selected, dragging the note head onto any one of
the notes attaches it to all notes in the selection. Altered note heads do not affect MIDI
playback.

If you want to return an altered note head to a standard display, use the same method,
with the black, round note head selected.

880 Chapter 31 Working with Notation



The gray note head makes a note’s head, and associated ties, invisible. This note is
displayed with a gray note head onscreen, allowing further edits. Nothing but the stem
is visible in the printout.

Invisible note head

If you combine this feature with the Attributes > Stem > Hide command, you can
completely hide these notes in the printed score.

Symbols Attached to Notes in the Part Box
This group contains symbols that usually only refer to one note at a time. This includes
fermatas, accents, phrasing symbols, and bow markings, for example. (Trills are in a
separate group.)

To assign any of these symbols to a note
µ Drag the symbol onto a note head. (Watch the help tag to ensure accurate placement.)

These symbols are automatically positioned when assigned to a note. They also move
with their parent notes, when transposed or otherwise graphically altered.

To insert a symbol that remains independent of any note
µ Press the Option key during insertion.

This technique allows you to place a fermata above an automatically created rest, for
example.

881Chapter 31 Working with Notation



Note: The symbols in this Part box group can affect the velocity and playback length of
notes they are assigned to.

To make these symbols affect playback
µ Define the effect of each symbol, separately, in the File > Project Settings > Score > MIDI

Meaning pane. (See MIDI Meaning Settings.)

Slurs and Crescendi Objects in the Part Box
These symbols are graphic only, and have no impact on MIDI playback.

To insert a slur or crescendi object
1 Drag the object to the intended (left) starting point.

After insertion, the object remains selected, and small black square handles are visible at
its end points (or along its length, in the case of slurs).

2 Drag these handles to change the object’s shape.

You can also use several key commands to quickly input slurs, crescendo, and decrescendo
symbols. For details on these, and editing options, see Editing Slurs and Crescendi in the
Score Editor.
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Key Signature Symbols in the Part Box
Key signatures inserted in the Score Editor (or global Signature track or Signature List)
affect all instruments on all display levels. This is reflected both visually and in MIDI
playback.

Natural symbols are automatically displayed with a new key signature, when necessary
(when changing from A flat major to F major or A major, for example).

The display of key signatures and key signature changes depends on:

• The Score project settings in the Clefs & Signatures pane (see Clefs & Signatures Settings).

• The Key parameter in the Staff Style window (for each staff style).

Detailed information about key signatures can be found in Working with Time and Key
Signatures.

Time Signature Symbols in the Part Box
Time signatures inserted in the Score Editor globally affect all MIDI regions, on all display
levels. Time signature changes affect the display, but not playback.
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Apart from 2/4, 3/4, 4/4, 6/8, and the alternative display options for 4/4 and 2/2, there
are also Part box objects for freely definable time signatures (A/B), and compound time
signatures (A+B/C). When you insert one of these objects, the Time Signature dialog
opens, allowing you to set the time signature. For more information see Working with
Time and Key Signatures.

Repeat Signs and Bar Lines in the Part Box
These objects can be inserted at any visible bar position (at the position of any graphically
displayed note or rest). Usually, however, these objects are inserted at the beginning or
end of bars. These symbols are purely visual, and have no impact on MIDI playback.

In this situation, they replace the regular bar line (except first and second ending symbols).
They are global symbols, and are displayed in all staffs, on all display levels.

Details on editing these symbols are found in Editing Repeat Signs and Bar Lines in the
Score Editor.

Trills and Tremolo Symbols in the Part Box
The symbols in this group can be positioned anywhere, and are not attached to notes.
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The trill line and arpeggio lines can be set to any length, by dragging their end points.
The trill line can also span line breaks.

The accidental symbols in this Part box group are purely graphical, and do not affect the
MIDI playback of notes. They are mainly intended as a supplement to trill symbols.

Rests and Bar Repeat Signs in the Part Box
Rests are displayed automatically in Logic Pro.

Existing notes and automatic rests always add up to complete bars, which match the
given time signature.

Note: The only exception is when a staff style with a deactivated rest display (Hide Rest)
or with beat slashes (instead of rests) is used.

In certain situations, you might want to insert rests manually. These manually inserted
rests (also called user rests) can be used if you don’t like the way a particular automatic
rest is displayed. See Creating and Inserting Rests in the Score Editor.

Text Objects and Chord Symbols in the Part Box
Descriptions of the extensive range of text objects and chord symbols can be found in
Working with Standard Text.

885Chapter 31 Working with Notation



D.S., D.C., Segno, and Coda Signs in the Part Box
These symbols can be inserted at any position in the score.

They are graphic symbols, and do not affect MIDI playback. They can be resized with the
Resize tool.

Tempo and Swing Symbols in the Part Box
You can insert these symbols at any position.

The font, size, and style of the tempo indicator is determined in the Text Style window.
(See Working with Text Styles.)

The tempo indicator value is automatically derived from the playback tempo at the
corresponding bar position.
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Note: The tempo indicators in the Transport bar and the Tempo List always refer to quarter
notes, even if a time signature with another denominator is used. As such, the displayed
tempo differs, depending on the symbol being used.

Jazz Symbols in the Part Box
Jazz symbols, as the name suggests, are typically used for jazz notation. They generally
indicate a particular playing technique or style, emphasis, or mode.

To assign any of these symbols to a note
µ Drag the symbol onto a note head. (Watch the help tag to ensure accurate placement.)

These symbols are automatically positioned when assigned to a note. Additional space
is created as needed, to avoid overlaps with other notes or symbols. Jazz symbols also
move with their parent notes, when transposed or otherwise graphically altered.

Jazz symbols can also be inserted with the Attach Symbol:  Jazz 1–6 key commands. The
numbers (1 to 6) indicate the positions of the symbols in the Part box (from the top-left
corner to the bottom-right corner).

To insert a jazz symbol that remains independent of any note
µ Press the Option key during insertion.

These unattached symbols can be moved freely, and unlike normally inserted jazz symbols,
do not affect the spacing of notes.
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Page and Line Break Symbols in the Part Box
Break symbols (and No Line Break and No Page Break objects) can be inserted as events.
Once inserted, they cannot be moved automatically (when you alter the Layout project
settings, resize the window, and so on).

You can overrule the Line Break, Page Break, No Line Break, and No Page Break events
with the Layout tool.

Line breaks and individual staff margins can be determined for each score set, and also
for each of the extracted parts.

Chord Grid and Tablature Symbols in the Part Box
Chord grid symbols (available in three different sizes) and tablature markings are used
for guitar notation. The Part box provides access to these symbols and markings to use
in your score.

For full details, see Working with Chord Grids and Working with Tablature Markings.
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General Editing in the Score Editor
This section covers basic editing methods that are used in the Score Editor. For general
MIDI editing information, see Introduction to MIDI Editing.

Using Shortcut Menus in the Score Editor
Many selection, editing, and other commands can be accessed by Control-clicking in the
Score Editor. Make use of these shortcut menus to accelerate your workflow.

Note: Shortcut menus can also be accessed with a right-mouse click if the Right Mouse
Button:  Opens Shortcut Menu option is chosen in the Logic Pro > Preferences > General
> Editing pane.

The contents of a shortcut menu change when different objects are clicked. The Score
Editor provides the following shortcut menu types:

• Notes

• Tablature

• Clefs

• Key signatures

• Time signatures

• Bar lines

• Background

Changing Multiple Objects in the Score Editor
If several objects are selected, the Event Parameter box title line contains “X
Notes/Symbols/Events/Texts/Chords selected.” “X” indicates the number of selected
objects. The terms Notes, Texts, and Chords are only used if the current selection is limited
to objects of that particular type.

If, as in most cases, parameter fields are visible while multiple events are selected, all
corresponding values can be edited simultaneously. When the “*” value is shown, it
indicates that the selected objects have different values for that particular parameter.
There are different options for changing these values:

• Relative change (preserving differences): Grab the “*” with the mouse, and use the mouse
as a slider. The value shown during this process belongs to the first of the selected
objects. The other objects are altered by the same amount (while retaining their relative
values). You can also double-click the value, and insert the change (a number with a
plus or minus in front of it) in the entry field.
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• Absolute Change (all values set to an equal value): Hold down Option while grabbing
the “*” with the mouse, and use the mouse as a slider. As soon as you move the mouse,
the parameter is set to the same value for all selected objects. This allows you to set
all notes of a chord to the same length or velocity, or set all selected objects to the
same height (Vertical Pos), for example.

To set the vertical and horizontal position of all selected objects to the same value
µ Use any of the following key commands:

• Align Object Positions Vertically

• Align Object Positions Horizontally

• Align Object Positions (affects both parameters)

These key commands set all objects to the value of the first selected object. If only one
object is selected when you use one of these key commands, a dialog asks if the
parameters of all similar objects should be set to the same value.

All displayed regions and instruments are affected.

Tip: This technique is very useful for aligning lyrics and chord symbols.

Moving or Copying Objects in the Score Editor with the Mouse
You can move or copy notes and symbols with the mouse, just as you can in the Piano
Roll Editor.

Note: It’s easy to unintentionally change a symbol’s bar position with the Pointer tool.
Choose the Layout tool to limit changes to an event’s vertical and horizontal position.
See Changing the Graphical Position of Objects in the Score Editor.

To move a note or symbol with the mouse
µ Select one or more notes or symbols, then drag it to the new position.

To copy a note or symbol with the mouse
µ Select one or more notes or symbols, hold down Option, then drag it to the new position.

Watch the help tag during this process. It shows the operation (drag or copy), the current
difference from the original position (transpose and time shift), and the current cursor
position (bar position and—for notes—pitch).

You can simultaneously move or copy objects from different regions or staffs. Each event
is moved or copied to its new position, within the original (source) MIDI region.

Note: You cannot use the Option-drag method to copy or move events between MIDI
regions in the Score Editor. You can, however, copy and paste between regions and staffs.
(See Copying Objects in the Score Editor via the Clipboard.)
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To restrict movement to one direction (vertical or horizontal)
µ Hold down the Shift key while dragging.

There is also a general preference for this constraint:  Logic Pro > Preferences > General
> Editing > Limit Dragging to One Direction In:  Piano Roll and Score.

The Impact of the Display Quantization Parameter
Movement along the time axis (horizontal) is affected by the display quantization grid
(Quantize) setting.

If a hybrid quantize value is selected (16, 24 for example), the grid corresponds to the
binary value (16, in this example).

• If note positions are not aligned with this time grid (because they were recorded in
real time), their relative offset is retained when they are moved or copied.

• You can move or copy unquantized passages within the Score Editor, without losing
the original feel of the performance.

Moving Global Symbols and Symbols Attached to Notes
You cannot copy or move the following symbols in the Score Editor:

• Global symbols, such as repeat signs, time and key signature changes—except in the
Signature List and Signature track—and global text elements (headers and so on). (For
additional information, see Working with Time and Key Signatures.)

• Symbols directly attached to notes, such as accents, fermatas, note heads, and so on.

Moving Objects in the Score Editor with Key Commands
A group of key commands is found in the Nudge Region/Event Position section of the
Key Commands window. These functions move all selected objects (by various steps)
along the time axis. The following Nudge commands are the most useful for score work:

• Nudge Region/Event Position Left by Bar and Nudge Region/Event Position Right by
Bar: Move the selected notes forward or back one bar.

• Nudge Region/Event Position Left by Beat and Nudge Region/Event Position Right by
Beat: Move the selected notes forward or back one beat.

• Nudge Region/Event Position Left by Division and Nudge Region/Event Position Right by
Division: Move the selected events forward or back one division step (as set in the
Transport bar).

Copying Objects in the Score Editor via the Clipboard
When you copy objects via the Clipboard, the first object is pasted at the target bar
position. The relative positioning of other copied objects (to the first object) is retained.

You can simultaneously paste the Clipboard contents into several regions, at the original
position.
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To paste the Clipboard contents into several regions
1 Select all appropriate regions (either in the Arrange area or Score Editor) by Shift-clicking

the staffs/regions, or dragging to select adjacent regions.

The Display Parameter box title line always indicates the number of regions that are
currently selected. (See Transcribing MIDI Recordings.)

2 Choose Edit > Paste Multiple (or use the Paste Multiple key command.)

Automatic Insert Quantization
When you paste (or paste multiple) objects from the Clipboard, the position of the first
inserted event is automatically quantized, in accordance with the current division value
(set in the Transport bar). For example, if the current bar position is 4.1.1.37, and the
division value is set to 1/16, the pasted object is inserted at position 4.1.1.1, whether it’s
a note or a symbol. When the Clipboard contains more than one object, their relative
positions from the first object are retained.

If you don’t want this behavior (because you want to preserve the unquantized timing
of the original), you are better served by other copy methods.

Pasting Passages at the Same Time Position
You can use the Paste at Original Position and Paste Multiple at Original Position
commands to quickly copy passages from one MIDI region to another, at the same time
position. No insert position is required, and no automatic insert quantization takes place.

To copy an entire musical passage to the same time position in another region
1 Select the notes and symbols of the passage.

2 Select the staff you want to paste the passage to.

3 Choose Edit > Paste at Original Position (or use the Paste at Original Position key
command).

The notes and symbols are pasted at the position they were originally copied from,
regardless of the current playhead position.

The Paste Multiple at Original key command works in a similar way, but allows you to
paste a musical passage to the staffs of other instruments. All destination staffs need to
be selected before the Paste Multiple command is executed.

Tip: You can use these commands in combination with the Select Similar function, to
quickly copy all dynamic symbols from one staff into other staffs or instruments, for
example.

Deleting Objects in the Score Editor
You can only delete events that are actually displayed in the Score Editor. For example,
if you erase notes from a real-time recording in the Score Editor, MIDI controller events
or pitch bend data that was recorded with these notes is not deleted.
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To delete an object
Do one of the following:

µ Select the object, then choose Edit > Delete (or press the Delete key).

µ Click the object with the Eraser tool.

Note: Repeat signs and special bar lines cannot be selected. They can only be deleted
with the Eraser tool.

Repeating Events in the Score Editor
The Repeat Events command is especially useful for copying complete bars (or multiple
copies), without setting any bar positions.

To copy a bar that begins with a rest on one
1 Select all notes and symbols.

2 Choose Edit > Repeat Events (or use the Repeat Regions/Events key command).

3 In the Repeat Regions/Events dialog, insert the number of copies, choose Bar from the
Adjustment pop-up menu, then click OK.

For more information on the Repeat Events command, see Creating Multiple Copies of
Regions.

Working with Aliases in the Score Editor
Alias is a term used for dependent MIDI regions and folders in the Arrange area. Alias
regions mirror other MIDI regions and folders at different positions. Wherever an alias
exists, it acts as a playback marker that points to the parent (original) MIDI region or folder.
It is actually the parent region (or folder)—and not the alias—that is played back.

Displaying Aliases
Aliases are also displayed in the Score Editor, and can be printed. The display of aliases
can be turned on in the Global pane of the Score project settings (File > Project Settings
> Score > Global).
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An alias can be assigned a staff style different from its parent region. (For information on
staff styles, see Working with Staff Styles.) For example, imagine a melody that you want
to be played in unison by several instruments:

• You can set up a melody to be played in unison by several instruments by creating
several aliases of a regular MIDI region (the melody).

• Different staff styles can be used for each of the different instruments, including
transposing staff styles (for example, Horn in Eb, Alto Sax, and so on).

• If you decide to change something in the melody, you don’t need to edit all copies
(aliases) of it. Just make the change in the parent MIDI region, and the change is reflected
automatically in all aliases.

Editing Aliases
You can directly edit the notes and symbols in an alias if the Allow Alias Editing checkbox
in File > Project Settings > Score > Global is selected.

Note: Changes to aliases alter the data of the original MIDI region (and all aliases created
from it), because only the original region can actually contain MIDI data.

If Allow Alias Editing is turned off and you try to edit an alias, you will be asked to either
enable alias editing or create a copy of the region. Choose the appropriate option, as
follows:

• Cancel: The aliases and original MIDI region are not changed.

• Enable Alias Editing: Alias editing is allowed; remember that this actually edits the parent
MIDI region.

• Create a Copy: A copy of the original MIDI region replaces the selected alias. You can
edit the notes independently of the original MIDI region, as the selected alias is now a
real region.

Changing the Graphical Position of Objects in the Score Editor
You can change the graphical position of objects to improve the layout of your score (by
creating space for a grace note, for example).
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Using the Layout Tool
The Layout tool (located in the Score Editor’s Tool menu) is used to graphically move
events in the Score Editor, in order to optimize the display without altering the timing of
MIDI events.

• Symbols and text: When symbol or text objects are moved with the Layout tool, the
bar position is retained. The Horizontal Position and Vertical Position parameters,
however, are changed (as indicated in the help tag during the process).

• Notes: The Layout tool can only edit the horizontal position of a note in relation to its
bar position, not its vertical position. Dragging the note to the right or left changes the
displayed distance from the adjacent notes or rests. The bar position (and playback) is
unaltered.

Note: The bar position determines playback timing, as this is the actual MIDI event position.
Remember that the Score Editor is primarily designed to deliver notation, and that most
(but not all) editing functions are graphical, rather than physical, in nature.

Using the Event Parameter Box
You can change the graphical position of Score Editor symbols and text in the Event
Parameter box by editing the Vertical Position and Horizontal Position parameters.

• Vertical Pos.: Determines the vertical position (height) above or below the staff. Zero
means a position exactly on the top line of the staff, in most cases. Positive values are
above, negative values below it. In staff styles with more than one staff, the Staff
parameter determines the staff that the Vertical Position parameter refers to.

• Horizontal Pos.: Determines the horizontal offset of the object’s bar position. A value
of zero corresponds to the left edge of a note, at that particular position.

Tip: To adjust a number of selected symbols to the same height above (or below) the
staff, use the Align Object Positions Vertically key command.

Using Key Commands
You can use the following key commands to move any score symbol that can be positioned
independently of notes or staffs, as well as text events and chord symbols:

• Nudge Position Up

• Nudge Position Down

• Nudge Position Left

• Nudge Position Right

These functions do not alter the bar position of the affected symbols and text events.
They alter the Horizontal Position and Vertical Position parameters by ±1.
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Resizing Notes and Symbols in the Score Editor
You can change the size of any notes, and most symbols, with the Resize tool (located
in the Score Editor’s Tool menu).

To change an object’s size
µ Grab the object with the Resize tool, and move the mouse up or down.

To reset an object to its original size
µ Double-click it with the Resize tool (and click OK in the dialog).

Editing Notes in the Score Editor
Given the different types of notes (tuplets, dotted, grace notes, and so on), this section
outlines a number of note-related editing operations that will help you get your score
looking just right.

Note: If your editing requirements extend beyond those covered in this section, see Using
Note Attributes to Change Individual Notes.

Editing Note Velocity, Length, or Pitch in the Score Editor
You can edit the velocity, length, or pitch of one or more selected notes in the Score
Editor.

To change a note’s velocity
Do one of the following:

µ Select the note, then edit the Velocity parameter displayed in the Event Parameter box.
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µ Grab one (or several) notes with the Velocity tool, and move the mouse up or down.

The value change can be seen in the help tag, and can also be heard if the MIDI Out
button is activated.

Tip: Grabbing a note with the Pointer tool—while holding down the Option and Control
keys—activates the Velocity tool, saving you a trip to the Tool menu. Once you release
these modifier keys, the pointer returns to its previous shape and function.

To change a note’s length
µ Select the note, then do one of the following:

• Edit the Length parameter in the Event Parameter box (shown as bars, beats, and ticks).

• Use one of the Nudge Region/Event Length key commands.

To change a note’s pitch
µ Select the note, then do one of the following:

• Drag it to the appropriate staff line (keep an eye on the help tag).

• Edit the Pitch value in the Event Parameter box.

• Use the Event Transpose +1 or the Event Transpose –1 key command.

Allowing Diatonic Input in the Score Editor
If your composition falls into a consistent key, you should turn on the Diatonic Insert
feature. This feature helps you to place notes at the correct pitch by limiting input to
notes that are diatonically correct for the current key.

To turn on the Diatonic Input feature
µ Choose Edit > Diatonic Insert in the Score Editor.

Notes can be altered chromatically, once they have been inserted.

Note: If you protect (lock) your screensets, this function’s setting is also locked.
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Creating and Editing Tied Notes in the Score Editor
Notes that are displayed as several graphical notes, connected with ties, only represent
one actual MIDI note event.

Ties cannot be inserted directly into Logic Pro, but are created and displayed automatically,
according to the length of the MIDI note. As such, you need to approach the creation of
ties as follows:

To create tied notes
1 Insert a note value that is shorter than the one you want to insert.

2 Change the note length in the Event Parameter box, the Event List, or the Event Float
window.

Tip: You can also use duration bars to graphically edit note length. See Displaying Duration
Bars and Changing the Length of Duration Bars.

To change the tied note display with a user rest
µ If you don’t like the way particular tied notes are displayed, you can change the display

by inserting a user rest at the position you want to see a graphic note.

The rest’s length is not important, but you should use a shorter one (an eighth note rest),
if possible. Watch the help tag, for exact positioning. As soon as the rest is inserted, it is
no longer visible in the score display, but the note display changes accordingly.

Note: If you want to delete or change the position of a (now invisible) user-inserted rest,
use the Event List.

To change the up or down direction of a tie
µ Choose a setting in the Attributes > Ties menu.
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Creating and Editing N-Tuplets in the Score Editor
The symbol for N-tuplets is found in the triplet group. N-tuplets are groups of notes that
are evenly spaced (by condensing or expanding them) over a specific time period. The
most common tuplet is the triplet, a group of three notes; for example, a group of three
eighth notes played within the space of one quarter note.

N-tuplet symbol

Depending on the situation, Logic Pro usually recognizes and notates regular triplets
correctly. (You need to choose an appropriate display quantize value in the Display
Parameter box. See Quantize.) You need to use the N-tuplet object for the display of other
N-tuplets.

To change the display of existing notes
1 Drag the N-tuplet symbol onto the first note.

The target note must be indicated in the help tag before you release the mouse button.
The Tuplet window opens, allowing you to define the N-tuplet attributes:

• Tuplet note number: The number of tuplet notes is defined in the upper-left field.

• Tuplet denominator: The value shown in the upper-right numerical field.
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• Tuplet note values: Choose from 1/8, 1/16, 1/32 (and so on) tuplets.

• Hide Bracket: The bracket is not displayed.

• Hide Numbers: The N-tuplet’s number will not be printed. It will, however, be displayed
in parentheses. This is necessary for further edits to the N-tuplet.

• Show Denominator: The N-tuplet display also contains the denominator (the second
number in the dialog). This is 5:4 in the example above.

• Direction: The direction of the bracket and number. Auto refers to the setting in the
staff style being used.

• Allow Double Values: If this option is selected, N-tuplets can contain note values that
are twice as long as the regular tuplet value.

• Allow Half Values: If this option is selected, N-tuplets can contain note values that are
half the length of the regular tuplet value.

Tip: Most changes made to the parameters listed above are reflected in the tuplet
graphic.

2 Define the required settings in the Tuplet window.

In the example above, five tuplet eighth notes should be displayed, in place of four regular
eighth notes.

3 Click OK.

In the score, the above example would look like this:

To insert N-tuplets with the mouse
1 Insert the first note at the appropriate position.

2 Drag the N-tuplet symbol onto it.

If you hold down the Option key as you insert the N-tuplet symbol, the most recently
inserted N-tuplet settings are used, without the dialog opening.

3 Define the required settings in the N-tuplet window.

The display will initially show a series of rests, the number of which corresponds to the
N-tuplet value. You can insert other notes at these rest positions. To do so, select a note
value that approximately matches the length of the desired N-tuplet notes.

If you want to hear these notes played back with legato phrasing and the notes are too
long or too short, you need to change their (MIDI) lengths. The fastest way to do this is
to select all notes and then choose Functions > Note Events > Note Force Legato
(Selected/Any). You can also use the corresponding key command.
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The method described above also allows you to create N-tuplets which contain rests or
syncopated note values (double length).

Tip: If you want an N-tuplet to begin with a rest, you first need to insert a user rest from
the Part box, then drag the N-tuplet symbol onto the rest. Automatically displayed rests
cannot function as starting points for N-tuplets.

To edit tuplets
µ Double-click the N-tuplet number, then select settings in the Tuplet window.

To delete a tuplet
Do one of the following:

µ Click the tuplet number with the Eraser tool.

µ Double-click the N-tuplet number, then click the Delete button in the Tuplet window.

Using Artificial N-Tuplets to Bypass Display Quantization
You can bypass the display quantization value by using hidden, artificial N-tuplets.

For example, if there is a single 32nd note run in a MIDI region that otherwise contains
only eighth notes or longer values, you can set (Display) Quantize to 1/8, and drag the
N-tuplet symbol onto the first note of the 32nd figure.

In the resulting dialog, use the 8:8/32 setting, with Hide Brackets and Hide Numbers
selected. The number (8) will be visible onscreen, but not in the printout.

Although this is not the way that tuplets are normally used, it is a handy way to force the
display of runs (of shorter notes—1/32nd notes, in this case), with a display Quantize
value set for longer note values (1/8 notes, in this example).

Creating Grace and Independent Notes in the Score Editor
Independent notes are notes that aren’t included in the automatic rhythmic (and graphic)
display calculation of a measure, but are still played back via MIDI. There are two types:

Independent note Independent grace note

• Independent: These are displayed at their original length, as long as they are binary or
dotted note values that can be displayed as a single (not tied) note. After insertion, you
can change the stem direction, enharmonic interpretation, accidental distance, and
note head, using the Note Attributes functions. (See Using Note Attributes to Change
Individual Notes.)
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• Independent Grace: These are always displayed as miniature eighth notes, with a slash
across the stem, and a tie. The tie direction, stem direction, enharmonic interpretation,
accidental distance, and note head can be changed.

Both types of independent notes can only appear as single notes, without beams to other
notes.

To convert regular notes to independent notes (and vice versa)
µ Select the notes, then choose Attributes > Independent > Independent or Independent

Grace, or use the corresponding key commands.

Choose Attributes > Independent > Not Independent to convert independent notes back
into regular notes.

To insert an independent note directly
µ Hold down Option while selecting a note in the Part box, then drag it to the desired

position.

Independent grace notes cannot be inserted directly. They need to be created by
converting regular or independent notes.

In most situations, you will need to create additional space between the grace note and
the note it is associated with. The best way to do this is with the Layout tool, which can
be used to move the main note away from the grace note. (See Using the Layout Tool.)

Tip: If you want to create beamed grace notes, try using a polyphonic staff style with no
rests displayed for the second voice. Assign the grace notes to the second voice, and
resize them with the Resize tool. (See Adding Staffs to a Staff Style for more information
on staff styles.)

Creating and Inserting Rests in the Score Editor
In certain situations, you may want to insert rests manually. These manually inserted rests
(also called user rests) can be used if you don’t like the way a particular automatic rest is
displayed; for example, to avoid dotted rests, or for the syncopated display of rests, even
when Syncopation is turned off. (See Syncopation.)

In rhythmic display terms, user rests behave like notes, with enabled Syncopation and
disabled Interpretation parameters. (See Interpretation.) User rest interpretation is affected
by the display quantize setting just as notes are. (See Quantize.)

Other properties of user rests are as follows:

• They replace automatic rests, but unlike automatic rests, are listed as events in the Event
List. These events have a MIDI channel and a velocity value. The velocity value
determines their vertical position in the staff. (Normal middle position is achieved with
velocity value 64.)
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• They can be moved vertically. Automatic rests cannot be moved.

• They can be resized with the Resize tool. Automatic rests cannot be resized.

Using Multi Bar Rests in the Score Editor
Rests with a duration of several bars can be indicated by these two symbols.

Church restModern rest

These are most suitable for single instrument parts.

Note: In the Full Score view (where multiple regions or staffs are displayed), they are only
visible when all staffs contain multi bar rests at the same position.

To insert modern or church rests
Do one of the following:

µ Choose the rest type from the Rests Part box, then click the desired position with the
Pencil tool.

µ Drag the rest type (from the Part box) to the appropriate position.

Church rests (the older form of display) default to a length value of two bars.

The default length of normal multi bar rests is Auto (a value of 0 in the Event List). The
duration of the rest is automatically calculated with respect to the position of the next
note, user rest, or global symbol (repeat signs, double bar lines, and so on).

To change the rest type or duration
µ Double-click the rest symbol in the score with the Pointer tool.

In the dialog that opens, choose the shape (modern or church) and select or deselect the
automatic length function. You can only determine the length (in the Bars field), if Auto
Length is unselected.
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Note: Church rests cannot be longer than nine bars. If this length is exceeded, the modern
symbol automatically replaces the church rest.

Multi bar rests cannot be moved with the mouse. You can, however, change their bar
position in the Event List or Event Float window. You can also alter the length of the rest
(shown in the VAL column) in these windows.

Using Beat Slashes in the Score Editor
Beat slashes can be used in place of automatic rests, or they can be manually inserted.
Both single and double slashes (commonly used to indicate a pause) are available in the
Part box.

You can freely place slashes on top of the staff.

Editing Clefs in the Score Editor
The clefs in the Part box are intended for clef changes in the middle of a part, for a short
section of the music. Inserted clefs change the score display, starting at the precise insert
position (which can even be in the middle of a bar).

Note: If you need to change the clef of the entire region, choose an appropriate staff
style. (See Working with Staff Styles.)

When you insert a C-clef, watch the help tag carefully, as this clef can be positioned at
five different heights, depending on the register (alto, tenor clef, and so on).

The four symbols below the clefs do exactly what you expect them to do:  they mark a
section to be played either one or two octaves higher (or lower). The length of the section
can be edited after insertion, by grabbing the end of the line and moving it horizontally.

To change an existing clef
1 Double-click the clef.

2 Select a clef in the Clef Selector dialog that appears, then click OK.

Note: The same applies to the basic clef of a region, but changing this clef affects the
staff style itself, as well as all regions that use the same staff style.
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To change the size of clef changes
1 Open the Clefs and Signatures project settings by doing one of the following:

• Choose Layout > Clefs and Signatures (or use the Settings:  Clefs and Signatures key
command).

• Choose File > Project Settings > Score (or use the corresponding key command), then
click the Clefs and Signatures tab.

• Click the Settings button in the Arrange toolbar, choose Score from the menu, then
click the Clefs and Signatures tab.

2 Choose a value in the Smaller Clef Changes pop-up menu.

All clefs, except the first one in every staff, will be reduced in size, depending on the value
chosen here. This happens regardless of whether the clef changes are the result of a
different staff style in the same staff, or clefs have been inserted from the Part box.

Editing Slurs and Crescendi in the Score Editor
Given their nature, slur and crescendi objects are edited very differently than other Part
box symbols.

Fast Slur and Crescendo Input with Key Commands
You can use the following key commands to quickly input slurs, crescendo, and
decrescendo symbols:

• Insert:  Slur Up

• Insert:  Slur Down

• Insert:  Crescendo

• Insert:  Decrescendo
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These commands place the corresponding object below or above (Slur Up) the currently
selected notes. The start point is determined by the first selected note; the length of the
object, by the most recently selected note. The shape and vertical position of each object
is determined by the settings of the most recently edited object of the same type.

Changing the Position of Objects in the Score Editor
All Slurs and Crescendi can be moved by dragging the mouse from the object’s leftmost
starting point. The last six objects in the group are moved by dragging each of their
corners (handles) separately.

Changing the Length of Symbols in the Score Editor
All Slurs and Crescendi can be as long as you want them to be, and can be displayed (in
several parts) across line and page breaks.

• For example, if you want to extend a slur to a position that is not visible in the Score
Editor (in Linear Score view), you can grab its right end, and pull the cursor to the right
border of the Score Editor. The score scrolls automatically. As soon as the end position
for the slur appears in the window, move the mouse a little to the left, to stop scrolling.
Now position the end of the slur. It is important that you do not release the mouse
button during the entire process.

• In Page Score view, you can simply drag the right end to the desired destination in one
of the lower staffs. The slur is displayed in several sections. The same principle applies
to the other symbols in this group.

• The length of these objects can also be changed in the Event List or Event Float window,
by changing the numerical length parameter. The end point is moved horizontally by
this procedure. Slanted objects, such as arrows, are displayed at a correspondingly
varied angle.

• The length can exceed the end of the MIDI region. It’s possible to drag the right end
of a crescendo object to a position in the next MIDI region on the same track.
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Particular Attributes of Certain Symbols
Certain symbols contain particular attributes:

• Crescendo: The tip determines the general position. At the upper-right end, length and
opening angle can be adjusted. At the lower-right end, length and overall angle can
be altered.

• Decrescendo: At the upper-left end, you can alter the bar position, and opening angle.
At the lower-left end, bar position, and overall angle can be set. At the tip (right end),
vertical position and length are adjusted.

• Lines and arrows: Can be moved (in their entirety) by dragging the start point. At the
other end, length and overall angle can be altered. The slanted line symbol denotes a
line that can be altered freely. The other two line objects (vertical and horizontal) can
only be extended in the corresponding direction.

• Slurs: Slurs have five editing points, used to change their shape. The last two slur
symbols in the slur group are mainly intended for slurs across staffs (in piano parts).

Note: These are slurs, not ties. Ties cannot be inserted manually, but are displayed
automatically if a MIDI note’s length requires it. For more information, see Creating and
Editing Tied Notes in the Score Editor.
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Editing Repeat Signs and Bar Lines in the Score Editor
Repeat signs and bar lines cannot be moved with the mouse. You can, however, move
these symbols (along with time and key signatures) to a certain extent, in the Arrange
window.

Once a region is selected in the Arrange window, alterations to its end point (or position)
will affect existing repeat signs and bar lines in the score. Inserting, deleting, and moving
key or time signatures in the Arrange window global tracks also have an impact on these
score elements.

To delete repeat signs and bar lines
µ Click them with the Eraser tool.

Hidden Bar Lines
The hidden bar line symbol is not visible when you print the score.

Normal bar line

Hidden bar line

Using hidden bar lines in conjunction with hidden time signature changes allows you to
create bars and musical passages that don’t seem to have a fixed meter. Another use for
the hidden bar line symbol is to force a graphical split of a note into two notes connected
with ties—in all staffs of a score simultaneously—if it is inserted in the middle of a bar.

Logic Pro includes a preference to hide all automatically displayed bar lines. Manually
inserted bar lines, double bar lines, and so on will still be displayed and printed, regardless
of the preference setting.

To hide all automatically displayed bar lines
µ Select the Hide Bar Lines checkbox in the File > Project Settings > Score > Clefs and

Signatures pane.
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1st and 2nd Endings
Following the insertion of one of the repeat endings, text entry mode is automatically
activated. The default text is “1.” and “2.” If suitable, confirm with Return. If unsuitable,
you can freely enter any text into these brackets. The bracket that defaults to “2.” is
open—without a vertical end line, like the “1.” ending.

Because the text can be changed, you also can create a 2nd ending with a vertical line,
for example. The font, text size, and style of these numbers or text elements is set in the
Text Styles window. (See Working with Text Styles.) To edit the text, double-click it.

A 1st or 2nd ending can be moved by dragging its upper-left corner. The length can be
changed by dragging the right end. If a repeat ending is selected, it can be deleted by
pressing the Delete key.

First and second endings are only displayed on staffs with bar lines that aren’t connected
to the staff above.

The Alternate Repeat Symbols (for the whole project) option in File > Project Settings >
Score > Global activates a real book style display of repeat signs.

Bar Repeat Signs
The one- or two-bar repeat symbols replace all notes and rests in the corresponding
measures. All other symbols remain visible. This does not affect MIDI playback, so hidden
notes can still be heard. These signs can only be moved in the Event List or Event Float
window.

Double Repeat Sign
The double repeat sign behaves as expected, unless it is positioned at a line break. In this
situation, it is automatically displayed as two back-to-back repeat signs.

Working with Standard Text
You can use standard text objects in the Part box to add standard text. The basic functions
for moving the pointer, deleting parts of the text, and so on, are the same as they are for
most word-processing applications.

Inserting Text
You can add text in the same way as you add other score symbols:  by dragging the object
from the Part box to the score. Alternately, you can use the Text tool to enter text.
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To insert text in the score
1 Select a text object in the Part box.

2 Do one of the following:

• Drag the text object to the desired position.

• Select the Text tool (or use the Set Text Tool key command), then click the position
where you want the text to appear.

An insertion point appears at the target position. (If you choose one of the automatic
text objects, the respective text is inserted automatically.)

3 Enter text with the computer keyboard.

As long as you are in text entry mode (indicated by the blinking insertion point), you can
click any position in the text field. You can select parts of the text by dragging the mouse
in the text field, and apply the usual Cut, Copy, or Paste commands. Press Return, or click
anywhere outside the text field, to exit text entry mode.
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Each text object (except text in the header, or at or outside of the page margins) is saved
as a meta event within a particular MIDI region, at a certain bar position. This position
can be seen in the help tag as you insert the text object. Text events are also visible in
the Event List, allowing you to change their position, but not the text itself.

Score text event

Tip: You can simultaneously add text to several staffs. This is handy if you want to insert
the text “accelerando al fine,” for example, into all instruments. You can enter text into
several staffs at once just as you can other objects. (See Simultaneous Input of Objects
into Several Regions.)

Editing Text
In general, you edit text objects in the same way as other objects (see General Editing in
the Score Editor). If a text object is selected, you can set its parameters in the Event
Parameter box. If you want to edit the text itself, either click it with the Text tool, or
double-click it with the Pointer tool. The blinking insertion point appears.

To set the selected text font, size, and face
µ Choose Text > Fonts, then choose settings in the Fonts window.
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Setting Special Text Object Parameters
You can set the following options for the selected text object in the Event Parameter box:

• Staff number value: Only relevant in multiple staff styles. It determines the staff that
the text object is assigned to. The Vertical Pos. parameter indicates the vertical distance
to the top line of the staff. The Horizontal Pos. indicates the graphical horizontal
deviation of the selected text object from its actual bar position (also in relation to the
Align parameter).

• Lyric checkbox: Defines the text object as a lyric event (song text). If a lyric event is
placed at the same bar position as a note (above or below it), the horizontal distance
to the previous and subsequent notes or rests is automatically expanded, providing
enough space for the text.

• Style pop-up menu: Determines the text style of the selected text object.

• Align pop-up menu: Determines the horizontal alignment of a text object. The first three
settings relate to the bar position, the last five to the position on the page.

Using Musical Symbol Fonts
Musical symbol fonts do not contain letters. They only contain musical symbols (such as
special percussion symbols). You can use text objects (set to a musical symbol font) to
freely create, and position, musical symbols anywhere in the score.

Learning About Text Styles
All text elements refer to user-definable format settings called text styles. A text style
contains all text attributes, such as font, size, and style, which saves you the time and
effort of manually setting them whenever you insert a new text object.

About the Text Styles Window
All text styles used in a project are listed in the Text Styles window. This window allows
you to edit existing text styles, or create new ones.
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To open the Text Styles window
µ Choose Text > Text Styles in the Score Editor.

The first 15 lines contain the default text styles, which exist in every project (but can be
edited, according to your needs). Below these are user-created text styles. User text styles
are saved with the project file, allowing them to be different for each project.

Each line shows the name, and an example, of the text style. Double-clicking the Example
line opens the Font window, allowing you to edit both the default and user text styles.
Any fonts installed on your system can be used.

About the Default Text Styles
The default text styles have been designed for specific text elements, and are automatically
assigned when inserted.

• Plain Text: This is the default setting for regular text.

• Page Numbers, Bar Numbers, Instrument Names: The text styles for automatic page and
bar numbering, and display of instrument names (see Numbers & Names Settings).
These styles can also be edited in the Numbers & Names pane of the Score project
settings (File > Project Settings > Score). Changes in either window automatically
update the settings in the other window, and affect the entire project.

• Tuplets: This text style is used for triplet and other tuplet numbers.

• Repeat Endings: The text style for anything written into the repeat ending boxes (usually
just numbers, but text can also be entered).

• Chord Root, Chord Extension: Used for the display of chord symbols. The Root covers
the root and (optional) extra bass note in chord symbols. The Chord Extension is used
for everything else.

• Multiple Rests: The text style for the number above multiple rests.

• Tablature: Used for the display of fret numbers in guitar tablature. (See Tablature
Settings.)
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• Tempo Symbols: Used for the display of numbers in tempo symbols. (See Tempo and
Swing Symbols in the Part Box.)

• Octave Symbols: Used for the display of octave symbols. (See Clefs & Signatures Settings.)

• Note Heads: Used for the display of note heads.

• Guitar Grid Fingerings: Used for the display of guitar grid markings.

• Guitar Markings: Used for the display of guitar markings.

• Fingerings: Used for the display of fingering markings.

Working with Text Styles
You can create, assign, and import text styles.

To create a new text style
µ Choose New > New Text Style in the Text Styles window.

A new line appears below the bottom text style entry, allowing you to define the attributes
of the new text style. The names of any new style can be edited in the text entry field,
which opens when you double-click the name of the text style.

To assign a text style to a text object
1 Select the text object.

2 Choose a text style from the Style pop-up menu in the Event Parameter box.

To import text styles from another project
1 Do one of the following:

• Choose File > Project Settings > Import Project Settings (or use the corresponding key
command, default assignment:  Option-Command-I).

• Click the Settings button in the Arrange toolbar, then choose Import Project Settings.

• Click the Browser tab in the Media area.

2 Navigate to, and select, the required project file.

3 Click the Import button.

Note: If accessing the settings from the Browser tab, you will also need to click the Import
Project Settings button, which appears after you click the Import button.

4 In the Import Settings window, select the Text Styles checkbox.

5 Click the Import button.

Text style settings are imported into the active project.

Working with Global Text
Global text objects appear in all score sets of a project (score, parts, and so on), although
they are inserted just once.
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Score sets determine which instrument tracks are included in the score display. Each
project can contain as many score sets as required. Full details on score sets can be found
in Using Score Sets to Create Scores and Parts.

The position of global text does not relate to bar positions (unlike regular text objects),
but is defined as a graphic position on the page. Given this behavior, global text can only
be inserted and seen in Page Score view. The most obvious example of a global text
object is a song name (in the page header).

To create global text
µ Insert text into one of the following areas of the page:

• In the header space (set in Layout > Global Format).

• Outside, or directly on, any of the page margin lines.

Text objects inserted in one of these areas are automatically made global.

After being inserted into one of the margin areas, global text can be moved anywhere
on the page.

To position global text
Do one of the following:

µ Use the Layout tool to move global text objects both vertically and horizontally.

µ Use the Pointer tool to move global text objects vertically.

µ Hold down the Shift key, then use the Pointer tool to move global text objects both
vertically and horizontally.
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When a global text object is selected, the Event Parameter box contains some additional
parameters:

• Align pop-up menu: Although alignments relating to bar positions are shown in the
pop-up menu, they cannot be chosen here.

• Pages pop-up menu: Defines the pages that the global text object will be displayed on.
You can choose between the following options:

• 1: The text will only be displayed on the first page.

• 2: The text will be displayed on all pages except the first one.

• Odd: The text will be displayed on all pages with odd numbers.

• Even: The text will be displayed on all pages with even numbers.

• All: The text will be displayed on all pages.

• Zone pop-up menu: The margin area that the text belongs to or is associated with. You
can choose between Top, Header, Side, and Footer.

Working with Automatic Text
The text group in the Part box contains four objects that represent names that are
automatically displayed, if inserted:

• REG (Region/Folder): Displays the name of the current display level. This can be a MIDI
region, a folder, or even the name of the project file (on the highest level).

• INSTR (Instrument): Displays the name of the currently displayed instrument or score
set. (See Using Score Sets to Create Scores and Parts.)

• SONG: Displays the name of the project file.

• DATE: Displays the current date (at the time of printout).
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These automatic text objects can be inserted as both global text (in the margin areas),
or as text objects that are related to a bar position (in one of the staffs or regions). For
example, you can insert the INSTR object as a global object to display the name of the
current score set on all pages. The appearance, and exact positioning, of these objects
can be set in the Event Parameter box.

Working with Lyrics
You can use the lyric object to quickly add lyrics to a song. The cursor position is
automatically moved from note to note.

Creating Lyrics
The text group in the Part box contains an object named LYRIC, which allows you to
create lyrics aligned to note events. When you use the LYRIC object to input text, pressing
Tab moves the text cursor to the beginning of the next MIDI note.

To create lyrics
1 Do one of the following:

• Drag the lyric object below the first note of the melody.

• Select the lyric object in the Part box, then click the position of the first note with the
Text tool.

Note: Watch the help tag:  each lyric object must be at the same bar position as the note
it belongs to (taking display quantization into account).

2 Enter the text for the first note—and press Tab, not Return—to automatically move the
text cursor to the beginning of the next MIDI note.

If a MIDI note is displayed as several tied (graphic) notes, press Shift-Tab to move the
cursor to the next graphic note. This method allows you to write several syllables below
one longer note, and lets you enter all lyrics in one process, although each syllable is
saved as an independent lyric object.

Editing lyrics is just like editing regular text. The Event Parameter box displays the same
parameters (the Lyric checkbox is selected).

Apart from the fact that cursor movement is bound to notes in lyric input mode, the only
difference between regular text objects and lyric objects is that the latter affects the
distance between the notes they are assigned to. This provides enough space for the text
to be displayed properly, without overlapping. If the text (or text style) is changed later,
the note distance is recalculated accordingly.

To convert a standard text object to lyrics
µ Select the text, then select the Lyric checkbox in the Text Event Parameter box.
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Setting All Words and Syllables to the Same Height
If you don’t enter the lyrics in one continuous process, it is unlikely that the lyric objects
will be set to the same vertical position. (They won’t be aligned.)

To quickly align all lyric objects
1 Select at least one lyric object.

2 Choose Edit > Select Similar Objects, to select all lyric objects.

3 Use the Align Object Positions Vertically key command.

Note: You don’t want to use this method if there are multiple lines of lyrics for different
verses. Doing so would set them all to the same height.

Assigning Multiple Lyric Objects to the Same Note
You can assign multiple lyric objects to the same note, allowing you to insert several
verses for a song, one below the other.

To create several verses for the same note
1 Drag the first lyric object to the position of the note, then input the first verse.

2 Drag the second lyric object to the same note position below the first verse, and type
the second verse.

As long as you remain in fast lyric input mode, all lyric objects for the second verse stay
at the same height as the initial object—in this case, the first word of the second verse.

Working in Single MIDI Region Display Mode
It’s important that lyric objects are assigned to the right MIDI region, if you’re working in
a full score display. (Remember:  selected staffs are displayed with blue staff lines.) It’s
generally recommended that you insert lyrics in Linear Score view and single MIDI region
display mode—especially if inserting more than one verse. Linear Score view also makes
it easier to select several lyric objects by dragging, to change their positions, for example.

Working with Chords
Chord symbols are text objects designed for fast chord entry. Logic Pro uses special text
attributes to display chord symbols, and also offers additional editing tools.

To create a chord symbol
1 Do one of the following:

• Drag the chord symbol from the Part box to a position in your score.

• Select the chord symbol in the Part box, then click a position with the Text tool.

• Select any text symbol in the Part box, then Option-click a position with the Text tool.

Note: Make sure that you insert chord symbols at the correct bar position. Watch the
help tag while inserting the chord object.
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2 Enter the text for the chord.

A chord symbol can include a root note, a separate bass note, and two lines of extensions.
As you enter the text for the chord in the Score Editor, you can influence the way the
inserted text is distributed:

• First, enter the root, then the extensions, then—after typing a slash—the (optional)
additional bass note.

• As soon as you enter a number, everything following it is placed in the upper extension
line. If you write “G7(b9/b13),” the whole “7(b9/b13)” is placed in the upper line, and
the lower line remains blank.

• If you write letters before a number (FMAJ7/9, for example), Logic Pro places the letters
in the lower line, and everything after the first number, in the upper line.

• You can influence this automatic placement by entering a comma in the text:  everything
before the comma is placed in the lower line, and everything after it, into the upper
line. Only one comma can be used. Blank spaces can be entered, to create additional
horizontal space between the extension and the root.

To edit a chord symbol
Do one of the following:

µ Double-click the root, then edit the chord symbol in the Chord Symbol dialog.

There are four entry fields for the different parts:  one for the root, one for an additional
bass note, and two for extensions, which are placed above each other.
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µ Double-click one of the extensions.

An insertion point appears in the extension line, allowing you to edit the extension the
same way you do regular text.

The appearance of chord symbols can be edited in the Text Styles window by changing
the text styles assigned to the chord root and extensions. (For more information about
text styles, see Working with Text Styles.)

To change the appearance of chord symbols
1 Open the Text Styles window by choosing Text > Text Styles in the Score Editor.

2 Edit the text style for the chord root (named Chord Root) and for the extensions (named
Chord Extensions).

Inputting Several Chord Symbols
If you want to insert several chord symbols into the same staff, there is a shortcut (similar
to the lyric input mode) available. After you enter text for the first chord, press Tab, rather
than Return. The insertion point automatically moves to the position of the next (displayed)
note or rest. Enter the desired chord and repeat the process, or press Tab several times,
to move to the target position for the next chord symbol.

Tip: If you want to insert one chord per bar into a very busy part, it’s much faster to create
an empty MIDI region, and enter chords into it. (The insertion point moves to the next
bar when you press Tab in empty regions.) After you enter chords, you can either merge
the MIDI region with the original MIDI region in the Arrange area, or copy and paste all
chords at once.

Enharmonically Changing Chord Symbols
You can change the roots of chord symbols enharmonically. Only additional bass notes
need to be edited directly in the Chord Symbol window. When changing a chord
enharmonically, the chord’s spelling changes, but the pitches of the chord notes remain
identical. For example, when changing the “Gb7” enharmonically, it becomes “F#7.”

To enharmonically change the root of chord symbols
1 Select the chord.

2 Do one of the following:

• Choose Attributes > Accidentals > Enharmonic Shift:  # (or use the Enharmonic Shift:  #
key command, default assignment:  Shift-Page Down).

• Choose Attributes > Accidentals > Enharmonic Shift:  b (or use the Enharmonic Shift:  b
key command, default assignment:  Shift-Page Up).
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Transposing Chord Symbols
Chord symbols inserted into transposing staff styles are transposed automatically, just
like notes. Furthermore, if the Transposition parameter (for playback transposition) in the
Region Parameter box is changed, all chord symbols in the MIDI region are affected
accordingly.

Displaying German Chord Symbols:  H Instead of B
If you choose one of the German Chord Symbol settings in the Chord Symbol Language
pop-up menu of the Score project settings Global pane, the note B in all chord symbols
is displayed with its German name H. The English B flat is written as B or Bb, when German
chord symbols are displayed.

Note: The German (H, B, F#) setting is activated automatically, as soon as the letter H is
used during chord symbol input.

Setting the Graphical Position of Chord Symbols
Each chord symbol is stored at a certain bar position in a MIDI region. (Often there will
also be a note at that same bar position.)

The Event Parameter box Align option determines which part of the chord symbol is
aligned to the bar position:  the left edge, center, or right edge of the letter representing
the chord root. The setting for newly inserted chord symbols is always “def.” This default
alignment matches the setting chosen in the Chord Symbol Alignment pop-up menu,
found in the Layout pane of the Score project settings.

Creating Rhythm Section Parts
Typically, rhythm section parts are notated with chord symbols and beat slashes. If you
want to create this type of part, choose a staff style with a Rest parameter set to Slash.
For more information about the Rest parameter, see Changing Staff Style Parameters.

Working with Chord Grids
You can review and edit existing chord grid libraries and chord grids, as well as create
your own, in the Chord Grid Library.
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The Chord Grid Library window consists of two or three tabbed pages, depending on
which method you use to open the window. These tabbed pages are the Instrument
Editor, Chord Grid Selector, and Chord Grid Editor.

To open the Chord Grid Library
Do one of the following:

µ Choose Logic Pro > Preferences > Chord Grid Library in the main menu bar.

µ Click the Preferences button in the Arrange toolbar, then choose Chord Grid Library from
the pop-up menu.

µ Choose Layout > Chord Grid Library in the Score Editor’s menu bar.

µ Drag a chord grid symbol from the Part box into the score.

µ Double-click an existing chord grid symbol in the score.

Note: The Instrument Editor tab is only available if you use one of the first three methods
to open the Chord Grid Library.
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Getting to Know the Instrument Editor
The Instrument Editor pane allows you to view, create, and edit instrument tunings and
chord grid libraries. You can also import and export chord grid libraries. The Instrument
Editor pane includes the following parameters:

• Name column: Displays the instrument tuning name. Can be edited by double-clicking.

• Library column: Displays the chord grid library name. Can be edited by double-clicking.

• Tuning column: Displays the instrument tuning.

• Strings column: Displays the number of strings.

• Chords column: Displays the total number of chords.

• Basic Chords column: Displays the number of basic chords.

• Import button: Allows you to import a library to the Instrument Editor.

• Export button: Allows you to export a library from the Instrument Editor.

• Delete button: Allows you to delete a tuning or library from the Instrument Editor.

• Create button: Allows you to create a library in the Instrument Editor.
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Getting to Know the Chord Grid Selector
The Chord Grid Selector allows you to select and filter individual chord grids from your
instrument tunings and chord grid libraries. This pane includes the following parameters:

Instrument Parameters
• Name pop-up menu: Choose the name of the instrument tuning you want to use.

• Tuning field: Displays the default tuning for the chosen instrument.

• Number of Strings field: Displays the default number of strings for the chosen instrument.

• Capo pop-up menu: Choose the fret on which to place the Capo. Choose “0” to play at
the original chord, “1” to place a Capo on the first fret, and so on.

Filter Parameters
• Root Note pop-up menu: Filter the chord grids according to root note.

• Bass Note pop-up menu: Filter the chord grids according to bass note.

• Chord Type pop-up menu: Filter the chord grids according to chord type.

• Difficulty pop-up menu: Filter the chord grids according to difficulty.

• Favorites checkbox: Filter the chord grids according to those tagged as favorites.

• Library pop-up menu: Filter the chord grids according to library (those libraries that are
linked to the chosen tuning).

• No Transpositions checkbox: Filter the chord grids according to transposition.

View Parameters
• Number of Frets pop-up menu: Choose the number of frets (four, five, or six) shown in

the chord grid view.
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• Left-Handed checkbox: Change the chord grid view to suit left-handed users.

Other Parameters
• Playback button: Click to listen to a selected chord grid.

• Action pop-up menu: Choose how the chord grid strings are played back and at what
tempo.

• Chord: All strings are played back simultaneously.

• Arpeggio Up, Arpeggio Down: Each string is played back one after the other.

• Slow, Medium, Fast: Playback tempo.

• Delete button: Click to delete a non-factory chord grid.

• New button: Click to create a new chord grid. Clicking this button opens the Chord Grid
Editor pane and shows an empty chord grid.

• Edit button: Click to edit a selected chord grid. Clicking this button opens the Chord
Grid Editor pane and shows the selected chord grid.

Note: This same edit action can be triggered by double-clicking a chord grid in the
Chord Grid Selector.

Getting to Know the Chord Grid Editor
The Chord Grid Editor allows you to create or modify chord grids. This pane includes the
following parameters:

Instrument Parameters
• Name pop-up menu: Choose the name of the instrument tuning in which to add or

replace the chord grid.

• Tuning field: Displays the default tuning for the chosen instrument.
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• Number of Strings field: Displays the default number of strings for the chosen instrument.

• Capo pop-up menu: Choose the fret on which to place the Capo. Choose “0” to play at
the original chord, “1” to place a Capo on the first fret, and so on.

Chord Parameters
• Name field: Enter a name for the chord grid.

• Root Note pop-up menu: Choose a root note for the chord grid.

• Bass Note pop-up menu: Choose a bass note for the chord grid.

• Chord Type pop-up menu: Choose a chord type for the chord grid.

• Difficulty pop-up menu: Choose a difficulty level for the chord grid.

• Favorite checkbox: Tag the chord grid in your favorites.

• Highest Fret pop-up menu: Choose the highest fret for the chord grid.

View Parameters
• Number of Frets pop-up menu: Choose the number of frets (four, five, or six) shown in

the chord grid view.

• Left-Handed checkbox: Change the chord grid view to suit left-handed users.

Other Parameters
• Playback button: Click to listen to the chord grid.

• Action pop-up menu: Choose how the chord grid strings are played back and at what
tempo.

• Chord: All strings are played back simultaneously.

• Arpeggio Up, Arpeggio Down: Each string is played back one after the other.

• Slow, Medium, Fast: Playback tempo.

• Reset/Clear toggle button: Click the Reset button to set the chord grid back to its original
state (showing either open strings, a new chord grid, or the selected chord grid) within
the Chord Grid Selector tab. Click the Clear button to clear the chord grid, providing
you with a clean template to work on.

• Target Library pop-up menu: Choose the library in which to add the new or edited chord
grid.

• Replace button: Click to replace an existing chord grid.

• Add button: Click to add a chord grid to your chosen library.

Inserting and Editing Chord Grid Symbols in the Score Editor
There are a number of ways to insert chord grid symbols into your score.
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To insert a chord grid symbol
1 Do one of the following:

• Drag a chord grid symbol from the Part box into the score.

• Choose a chord grid symbol in the Part box, then click within the Score Editor with the
Pencil tool.

Either technique opens the Chord Grid Selector pane in the Chord Grid Library window.

2 Select the chord you want to insert.

3 Click OK.
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After inserting chord grid symbols in your score, you can edit their size and position
accordingly.

To change the scale of a chord grid symbol
µ Control-click (or right-click) a chord grid symbol, then choose one of the following from

the shortcut menu:

• Scale:  reduced

• Scale:  normal

• Scale:  enlarged

The scaling values are based on the Grid scaling and Chord scaling settings in the File >
Project Settings > Score > Chords & Grids pane.
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To align selected chord grid symbols vertically
µ Select multiple chord grid symbols, Control-click (or right-click) any one of them, then

choose Align Object Positions Vertically.

The selected chord grid symbols are aligned vertically.

To align all chord grid symbols vertically
1 Control-click (or right-click) a chord grid symbol, then choose Align Object Positions

Vertically.

You are asked if you want to align all similar objects to this one.

2 Click OK.

All chord grid symbols are aligned vertically.

You can easily copy an existing chord grid symbol in the Score Editor.

To copy an existing chord grid symbol
µ Hold down the Option key while dragging an existing chord grid, then release when you

reach the desired position.

You have the option to hide or show the chord name on a chord grid symbol.

To hide the chord name
µ Control-click (or right-click) a chord grid symbol, then choose Hide Chord Name from the

shortcut menu.
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To modify the chord of an existing chord grid symbol
µ Double-click the chord grid symbol, choose another in the Chord Grid Selector, then click

OK.

Creating and Editing Chord Grids in the Chord Grid Editor
You have many possibilities when creating new chord grids from scratch, or when
modifying existing chord grids.

For full details about any of the parameters mentioned in this section, see Getting to
Know the Chord Grid Editor.

To create a new chord grid in the Chord Grid Editor
1 Click the Clear button in the Chord Grid Editor tab.

The chord grid display is cleared, allowing you to create a new one from scratch.

Note: Clicking the Clear button changes it to the Reset button.

2 Set the Chord and View parameters according to your requirements.

3 Click the Add button.

The Chord Grid Selector pane opens, with the new chord grid added to your chosen
library.

To edit an existing chord grid in the Chord Grid Editor
1 Double-click a chord grid in the Chord Grid Selector tab.

The chord grid opens in the Chord Grid Editor tab.

2 Set the Chord and View parameters according to your requirements.

3 Click the Add or Replace button.

The Chord Grid Selector pane opens, with the edited chord grid added or replaced in
your chosen library.
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To display higher frets in the chord grid view
µ Click 1st to open a pop-up menu, then choose another fret number.

Creating, Editing, and Deleting Fingering Dots
You can create, edit, and delete fingering dots on a chord grid.

To create a fingering dot
µ Click the string and fret.

A black dot is created.
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To move an existing fingering dot
Do one of the following:

µ Click another fret on the same string.

µ Drag the dot to a new fret position.
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To define the finger number on a fingering dot
µ Control-click (or right-click) a dot, then choose a number between 0 and 5.

To create an optional fingering dot
Do one of the following:

µ Option-click a string to create an optional dot. If another real dot exists on the same
string, the real dot remains.
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µ Option-click an existing dot to change it to an optional dot. An empty string is shown as
a result.

To delete a fingering dot
Do one of the following:

µ Select a dot so that it turns green, then press the Delete key.
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µ Click the area at the top of the string.

The result is the same using either approach:  the string is open.

Creating, Editing, and Deleting Barres
You can create, edit, and delete barres on a chord grid.
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To create a barre
Do one of the following:

µ Drag the left or right edge of an existing dot to the right or left.

µ Place the pointer over a string, then drag to the left or right.

To move an existing barre
µ Drag the barre to a new fret position.
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To delete a barre
µ Select a barre so that it turns green, then press the Delete key.

Muting and Unmuting Strings
You can mute and unmute strings on a chord grid.

To mute a string
µ Click the area at the top of the string.
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The string is muted.

To unmute a string
µ Click the area at the top of the string.
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The string is open.

Creating, Renaming, and Deleting Chord Grid Libraries
You can create a new chord grid library for an existing instrument tuning, or you can
create a new chord grid library for a new instrument tuning. You do this from the
Instrument Editor tab.

To create a new chord grid library for an existing instrument tuning
1 Open the Instrument Editor pane by doing one of the following:

• Choose Logic Pro > Preferences > Chord Grid Library in the main menu bar, then click
the Instrument Editor tab.

• Click the Preferences button in the Arrange toolbar, choose Chord Grid Library from
the pop-up menu, then click the Instrument Editor tab.
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• Choose Layout > Chord Grid Library in the Score Editor’s menu bar, then click the
Instrument Editor tab.

2 Click the Create button.

3 In the Create Library dialog that appears, define the following parameters:

• Library Name field : Type in a name for the chord grid library.

• Tuning pop-up menu: Choose the instrument tuning in which you want to add the
library.

• Number of Strings pop-up menu: Leave this at the default setting.

4 Click Create to add the new chord grid library to the chosen instrument tuning.

To create a new chord grid library for a new instrument tuning
1 Open the Instrument Editor pane by doing one of the following:

• Choose Logic Pro > Preferences > Chord Grid Library in the main menu bar, then click
the Instrument Editor tab.

• Click the Preferences button in the Arrange toolbar, choose Chord Grid Library from
the pop-up menu, then click the Instrument Editor tab.

• Choose Layout > Chord Grid Library in the Score Editor’s menu bar, then click the
Instrument Editor tab.

2 Click the Create button.
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3 In the Create Library dialog that appears, define the following parameters:

• Library Name field: Type in a name for the chord grid library.

• Tuning pop-up menu: Leave this at the default setting.

• Number of Strings pop-up menu: Choose the number of strings.

4 Click Create to add a new instrument tuning, also containing the newly created chord
grid library.

You can also rename and delete chord grid libraries.

To rename a chord grid library
µ Double-click the name in the Library column, then type a new name in the text input

field.

To delete an instrument tuning or chord grid library
µ Select the instrument tuning or chord grid library that you want to delete, then click the

Delete button.

If you selected an instrument tuning, the entire tuning and its chord grid libraries are
deleted. If you selected a chord grid library, only that library is deleted (unless it is the
only library within a tuning; then the instrument tuning is also deleted).
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Importing and Exporting Chord Grid Libraries
You can import and export chord grid libraries from the Instrument Editor tab.

To import a chord grid library
1 Open the Instrument Editor pane by doing one of the following:

• Choose Logic Pro > Preferences > Chord Grid Library in the main menu bar, then click
the Instrument Editor tab.

• Click the Preferences button in the Arrange toolbar, choose Chord Grid Library from
the pop-up menu, then click the Instrument Editor tab.

• Choose Layout > Chord Grid Library in the Score Editor’s menu bar, then click the
Instrument Editor tab.

2 Click the Import button.

3 Browse to the location of the library you want to import.

To export a chord grid library
1 Open the Instrument Editor pane by doing one of the following:

• Choose Logic Pro > Preferences > Chord Grid Library in the main menu bar, then click
the Instrument Editor tab.

• Click the Preferences button in the Arrange toolbar, choose Chord Grid Library from
the pop-up menu, then click the Instrument Editor tab.

• Choose Layout > Chord Grid Library in the Score Editor’s menu bar, then click the
Instrument Editor tab.

2 Select the library you want to export.

3 Click the Export button.
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4 Enter a name for the library, and browse to the location in which to save it.

5 Click Save.

Working with Tablature Markings
The following is an overview of the tablature markings that you can use in your score.
These are located in the Part box.

• Hammering: Placement is at the top of the tablature view.

• Pull-off: Placement is at the top of the tablature view.

• Tap: Placement is at the top of the tablature view.

• Slide: Placement is at the top of the tablature view.

• Bending: Placement is at the top of the tablature view.

• Muted dot/string: Placement is within the tablature view (shown as a dot).

• Harmonic diamond: Placement is within the tablature view (shown as a diamond).
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• Up/Downstroke: Placement is at the top of the tablature view.

• Ties: Placement is within the tablature view.

• Line Up/Down: Placement is within the tablature view.

• Slide Up/Down: Placement is within the tablature view.

• Bend Up/Down: Placement is within the tablature view.

• Pluck fingers (right hand): Placement is at the bottom of the tablature view.

• Palm Mute: Placement is at the bottom of the tablature view.

• Let Ring: Placement is at the bottom of the tablature view.

• Slap: Placement is at the bottom of the tablature view.

Working with Time and Key Signatures
Signatures are global events and affect all tracks in your project. You can view and edit
time and key signatures in the Signature track, in the Signature List, and in the Score
Editor.

Note: The Signature track must be visible—and must not be protected—in order to select
and copy signatures.

To view the Signature track
µ Choose View > Global Tracks.

By default, the global Marker, Signature, and Tempo tracks are visible when you turn on
the display of global tracks. If the Signature track is not visible, Control-click (or right-click)
anywhere in the global tracks header area, then choose Signature from the shortcut
menu.
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To view the Signature List
Do one of the following:

µ Choose Options > Open Signature List.

µ Shift-double-click in the Signature track.

The Signature List displays time and key signatures in a list style editor, along with other
global score symbols such as repeat signs, double bar lines, and so on.

Time Signatures
A time signature determines the number of beats in a bar (shown in the Bar ruler), thus
defining the editing grid in the Arrange area and MIDI editors. A time signature does not
affect the playback of audio or MIDI regions.

Time signatures do, however, affect the score display. All functions that rely on the chosen
time signature and bar positions (such as MIDI metronome click or Transform window
functions) are affected if bar positions are used to restrict a function to a certain part of
the project.

Key Signatures
Key signature changes only affect the display of MIDI notes in the Score Editor—they do
not have an effect on MIDI playback. The first key signature, however, affects the playback
of audio Apple Loops. For more information, see Using Global Tracks with Apple Loops.

You can create as many key signatures as you like. If your project already contains other
key signature changes, any newly inserted key signature changes the key from the insertion
point forward, until the next key signature change is reached.

You can store up to nine signature alternatives, which are reflected in the Signature track,
Signature List, and Signature window.

Creating Time Signatures
You can create as many time signatures as needed in a project.

To create a time signature
Do one of the following:

µ Move the playhead to the target bar, and set the new time signature in the Transport
bar.

µ In the Score Editor, drag the time signature from the Part box to the target bar position.

µ Set the Signature track to a sufficient height, so that it displays both the key and time
signature areas. Click the target bar in the Signature track’s time signature area with the
Pencil tool, then choose your settings in the Time Signature dialog.
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Note: If you perform this procedure when the track height is reduced, a time signature
change is created.

• The Beat Grouping text field allows you to determine the grouping of beats in
compound time signatures. It is sufficient to enter the numbers—223, for example.
This becomes “2+2+3” automatically. The total number of beats in the bar is calculated
automatically by the sum in this field. The Print Compound Signature checkbox needs
to be selected in order to display the defined grouping as the nominator. If not selected,
only the total sum is displayed as the numerator. Beat Grouping, however, affects the
way the notes are beamed together (in both cases). You can also change the automatic
beaming in normal time signatures. In 4/4-time “1+1+1+1” produces four beamed
groups (one for every beat), instead of the two groups displayed as a default.

• Select the Hide Signature checkbox to hide the corresponding time signature change
in the printout. The signature is still displayed onscreen, but is crossed out, and won’t
be included in the calculation of spacing between notes and symbols. As a result,
signatures may overlap notes on the screen, but not in the printout. This function can
be used for notating cadenza-like passages, which contain more notes than would
normally fit the time signature.

µ Click the Create Time Signature button in the Signature List.

Creating Key Signatures
You can create as many key signatures as needed in your project.
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To create a key signature
Do one of the following:

µ Click a position in the Signature track’s key signature area with the Pencil tool, then choose
a key in the Key Signature window.

Note: You can disable the use of double flats and sharps by deselecting the “Disable bb,
x” checkbox.

µ In the Score Editor, double-click a staff between the clef and time signature, then choose
a key in the Key Signature window. You can also drag the key signature from the Part
box to the appropriate bar position.

µ Click the Create Key Signature button in the Signature List.

Selecting Signatures
You can select signatures in the Signature List and Signature track by clicking them.
Multiple selections are possible by Shift-clicking.

In the Signature track, you can even select multiple signatures in conjunction with regions,
a technique that is very useful when you want to copy or move complete parts of a song
(along with signature changes). The Edit > Select Inside Locators command can be helpful
in this situation.

Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.
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Copying Signatures
You can copy time signatures and key signatures in the Signature List or Signature track.
You can also copy all time and key signatures from one project to another.

Subsequent signatures are inserted at bar positions that correspond to their original
distance from the first copied signature.

To copy signatures in a project via the drag and drop method
µ Press Option, then drag the signature (in the Signature track) to the target bar position.

To copy signatures in a project via the Clipboard
1 Select the time and key signatures in the Signature List or Signature track by clicking

them. (Shift-click for multiple selections.)

2 Choose Edit > Copy (or press Command-C) to copy them to the Clipboard.

3 Do one of the following:

• In the Signature track:  Move the playhead to the insert position, then choose Edit >
Paste (or press Command-V).

• In the Signature List:  Choose Edit > Paste (or press Command-V), type a bar value in
the Position text input field, then press Return.

To copy signatures between projects
1 Select signatures in the Signature track or Signature List.

2 Choose Edit > Copy (or press Control-C).

All signature changes of the source project are copied to the Clipboard.

3 Switch to the target project.

4 Activate the Signature track or Signature List, then choose Edit > Paste (or press Control-V).

The copied meter changes are pasted into the target project.

Note: Because any copied time and key signature changes are mixed with those of the
destination project when pasted, this procedure should only be used to copy such changes
to a blank project (one that contains no time and key signature changes, except the initial
settings).

Editing Signatures
You can edit existing signatures in the Score Editor and Signature track by double-clicking
them. The Time or Key Signature window appears, allowing you to make changes. Moves
are achieved by selecting, and dragging, signatures.

You can use the Scissors tool in the Signature track to cut bars. For example, to divide
one 5/4 measure into a 3/4 and a 2/4 measure, cut it at the fourth beat of the 5/4 bar.
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If you make a cut in the middle of a bar—in a section where the time signature doesn’t
change—two corresponding shorter measures are inserted, with the original time signature
resuming after the cut.

Likewise, it is also possible to merge two subsequent measures into one longer measure,
by using the Glue tool in the Signature track.

Deleting Signatures
You can delete all signatures in a project, except the initial time and key signature.

To delete a signature
Do one of the following:

µ Select the signature in the Score Editor, Signature List, or Signature track, then choose
Edit > Delete (or press Delete).

Tip: To erase all time signature events, choose Edit > Select Similar Objects after selecting
a signature, then press Delete.

µ Click the signature with the Eraser tool in the Score Editor, Signature List, or Signature
track.

Creating and Choosing Signature Alternatives
Signature alternatives are just that:  alternative versions of all signatures in the Signature
List or Signature track.

To create signature alternatives
Do one of the following:

µ Choose Options > Signature Alternatives in the Signature List, then choose a Signature
List.
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µ Choose a number from the Alternative pop-up menu in the Signature List.

µ Choose a number from the Alternative pop-up menu in the Signature track.

For full details about inserting signatures, see Creating Time Signatures and Creating Key
Signatures.

To switch between signature alternatives
µ Choose the appropriate number from the Alternative pop-up menu in the Signature track

or Signature List.

All MIDI regions are affected, resulting in the appropriate changes to your score.

950 Chapter 31 Working with Notation



Transcribing MIDI Recordings
Traditional music notation is only an approximate description of the musical content in
a piece. The actual performance depends heavily on the interpretation of notes by
musicians. Quarter notes, for example, are hardly ever held for exactly one beat.

The rhythmic interpretation of MIDI regions (recorded in real time, to a metronome click)
presents a similar problem, especially when you consider that Logic Pro records MIDI
events at a resolution of 960 ticks per quarter note. Nobody will play a downbeat at the
exact time of the metronome click.

The Score Editor’s display parameters allow you to adjust the appearance of notation,
without changing the playback (and feel) of the original MIDI region. You can use different
display settings for each region.

As such, it’s important that you have some idea of what your printed music should look
like. This will help to determine the display settings that will best fit your music.

If you can’t seem to find the appropriate display parameters for a particular MIDI region,
divide the region with the Scissors tool. This leaves MIDI playback unaltered, but allows
you to assign different display parameters (display quantization) for each of the shorter
regions that result from the Cut operation.

Even though these divided regions are separate, they adjoin each other, and are displayed
as a continuous staff in the score.

As a general working tip, you should merge MIDI regions (or insert blank regions) to fill
the gaps between MIDI regions before altering the display settings. The Score Editor
displays nothing if no region is present, resulting in blank spaces in your score.

Default Settings for New MIDI Regions
If a new MIDI region is created with the Pencil tool in the Arrange area, or through MIDI
recording, Logic Pro applies a set of default parameters to it. These defaults can be seen
and edited in the Display Parameter box, when no MIDI region (no staff ) is selected. The
title line shows Insert Defaults to indicate this status. These settings remain as set until
you quit Logic Pro, but can be changed at any time.

Click any empty spot in the Score Editor background to display the Insert Defaults. Edit
any of the parameters as desired—set Quantize to the value that you use for most regions
in the project, for example. From this point on, all new regions automatically use these
settings when created. If Quantize is set to “default,” the display Quantize setting of newly
recorded or created regions matches the division value shown in the Transport bar.

Note: The default setting for staff styles (Style) is not defined here. This is separate for
each track, and is set in the bottom line of the Arrange area’s Track Parameter box.
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When simultaneously changing the settings of several selected MIDI regions, the top line
of the Display Parameter box indicates the number of regions or objects (if the selection
includes folders) currently selected (“3 Regions sel.,” for example), instead of the MIDI
region name. If these regions have differing values for any of the parameters, a “*” is
displayed in the corresponding parameter line. If you change this value, all selected
regions are set to the same value for that particular parameter.

Selecting Multiple Regions in the Score Editor
You can use two special functions to select multiple regions in the Score Editor:

• Click the title line in the Display Parameter box to select all regions that are visible in
the current display.

• Click an instrument name, in the column between the parameters and score, to select
all regions for that particular instrument track (even regions spread across different
tracks that are assigned to the same software or MIDI instrument channel), at the current
display level. Remember, the instrument name column is only displayed if View >
Instrument Names is activated.
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Display Parameters
This section outlines all of the display parameters available in the Score Editor. To reiterate
the point, these only affect the appearance of events in the score, not the playback of
events.

Quantize
This parameter applies visual quantization to notes:  it determines the shortest note value
that can be displayed in the currently selected MIDI region. (The exception is artificial
N-tuplets; see Creating and Editing N-Tuplets in the Score Editor.)

For example, if you insert a short note, such as a 32nd note, it can only be displayed at
its original length if Quantize is set to 32 or shorter. If Quantize is set to 8, the 32nd note
is displayed as an eighth note (although it will still be played back as a 32nd note).

You choose the Quantize value from a pop-up menu, which contains all available display
quantization options.

Among the options are binary quantizations (displayed as one binary value—16 or 128),
and hybrid quantizations (two values combined, a binary and a ternary value—16,24 or
32,96, for example).

Binary values always correspond to the note value with the same denominator; for
example, 32 corresponds to thirty-second notes, and so on. Ternary values refer to triplets.
Here is a list of the ternary values, and their corresponding triplet values:

Corresponding note lengthQuantize setting

1/2-note triplets3

1/4-note triplets6

1/8-note triplets12

1/16-note triplets24

1/32-note triplets48

1/64-note triplets96
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Corresponding note lengthQuantize setting

1/128-note triplets192

1/256-note triplets384

When binary display quantizations are used, automatic triplets are not displayed at all
(except for triplets inserted with the mouse, using an N-tuplet object).

Important: A hybrid quantization value must be assigned to the Quantize parameter, to
enable the automatic display of triplets.

Quantize Default Setting
The Quantize parameter’s Default option can only be set with the Insert Defaults. (See
Default Settings for New MIDI Regions.) It cannot be set to its Default value in existing
regions. If Default is chosen, the Quantize setting of any new MIDI region is dependent
on the current division value in the Transport bar. In this situation, the Quantize value is
always a hybrid value. In the case of a binary division value, the Quantize value is the
division value currently set in the Transport bar plus the next highest ternary value. In
the case of a ternary division value, it is the division value currently set in the Transport
bar plus the binary value, which is divisible by that particular ternary value.

For example, a global division value of 1/8 results in an 8,12 Quantize setting for new
regions, a global division value of 1/12 becomes a 4,12 Quantize value, a global division
value of 1/16 results in a Quantize value of 16,24, 1/24 in 8,24, and so on.

Note: If a particular Quantize value has already been set in the Insert Defaults, all new
regions are assigned this value, regardless of the division value in the Transport bar. You
may, of course, change any of these values at any time.

Choosing a Quantize Value for Swing Notation
For regular swing notation, 8,12 should be used as the Quantize parameter. This enables
the display of eighth-note triplets, and also displays two uneven notes on one beat (dotted
eighth and sixteenth), as regular eighth notes.

For double-time passages containing sixteenth notes, you need to either:

• Cut the MIDI region in the Arrange area, and assign a higher quantize value to the new
MIDI region (that contains the double-time figure).

• Use hidden artificial N-tuplets for the sixteenth notes. (See Creating and Editing
N-Tuplets in the Score Editor.)

For swinging sixteenth notes (shuffle funk, hip hop, and so on), the same principle applies.
In this case, Quantize would be set to 16,24.
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Fixing the Score Quantize Value
The Functions > Quantization > Fix Displayed Note Positions and Fix Displayed Note
Positions and Durations commands can be used to fix the display quantization of all MIDI
events in the project. These commands may be useful for exporting projects (complete
with display Quantize settings) to other notation programs that don’t feature display
quantization.

Interpretation
If Interpretation is enabled, notes are generally displayed with longer length values than
their actual length, in order to avoid short rests. Short notes on a downbeat in 4/4 time,
for example, are displayed as quarter notes. The score becomes less precise as a result,
but is easier to read.

If Interpretation is disabled, note lengths are displayed as closely as possible to their real
values, as determined by the Quantize value. In the following example, the same MIDI
region is shown twice, the first with Interpretation disabled, the second enabled:

The Interpretation function is intended to produce an easy-to-read score display of
real-time recordings. You should usually turn it off when using step or mouse input.

You can use note attributes to turn Interpretation on and off for each individual note,
overriding the Display Parameter box setting. (See Using Note Attributes to Change
Individual Notes.)

To turn interpretation on or off for a selected note
Do one of the following:

µ Choose Attributes > Interpretation, then choose the appropriate setting.

µ Double-click the note, then choose the appropriate setting in the Note Attributes window.

µ Use one of the following key commands:

• Default Interpretation

• Force Interpretation
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• Defeat Interpretation

Syncopation
If Syncopation is enabled, each (MIDI) note is notated as one graphic note (not displayed
as several tied notes), regardless of position—if possible. (This also depends on the Max.
Dots setting—see Max Dots.) If this isn’t possible, the note is graphically divided into the
minimum possible number of notes, connected by ties.

This function is usually used for the display of syncopated notes. The following example
shows the same two bars displayed differently, the first with Syncopation disabled, then
enabled:

Syncopation can also be enabled and disabled for each note, independent of the Display
Parameter box setting. This can be done via note attributes. (See Using Note Attributes
to Change Individual Notes.)

If an unwanted display of ties and notes results from the Syncopation function, it is
possible to change the graphic display of notes connected with ties.

• Insert a user rest from the Part box (preferably a short one, but the length isn’t important)
at the bar position where you want the tie subdivided.

Once the rest is inserted, it disappears, but the note display changes. The inserted rest
can only be seen and edited in the Event List.

This trick works for all notes, not just syncopated ones. (See Creating and Editing Tied
Notes in the Score Editor.) In polyphonic staff styles, the MIDI channel of the rest and the
corresponding note must be identical.

No Overlap
No Overlap, when turned on, prevents the overlapped display of notes in melodies that
are played with an exaggerated legato. The displayed length of notes is truncated
(shortened) to the beginning of the next note (unless a polyphonic staff style is used—see
Working with Staff Styles for details). Notes beginning simultaneously (chords, in other
words) are displayed with the (note) length of the shortest note in the chord.
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When set to off, the score display shows the lengths of the notes fairly precisely. The
music is definitely harder to read this way, however.

The effect can be seen in the following example, which shows the same MIDI region, first
without, then with, overlap correction:

No Overlap should only be deactivated in rare cases. If, for example, a piano player
arpeggiates a chord and holds the notes, the score displays the following result with No
Overlap on:

Although you can’t see that all notes continue to sound here, the result looks like this if
No Overlap is deactivated:

The solution typically involves turning No Overlap on and using sustain pedal markings.
Logic Pro automatically displays pedal markings if notes are recorded in real time with a
MIDI keyboard and sustain pedal.

Max Dots
This parameter determines the maximum number of dots that Logic Pro allows for the
display of single notes. Unwanted dotted notes or rests can be changed by inserting user
rests (which remain invisible, if notes). See Creating and Editing Tied Notes in the Score
Editor for information on changing the way notes with ties are displayed).
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Score
This parameter is accessed via the Inspector’s Region Parameter box. If Score is turned
off here, the MIDI region is not displayed in the score at all. This is mainly used to prevent
the score display of particular regions—namely those that only contain MIDI events which
can’t be displayed in the score, such as controller or SysEx data.

Hidden MIDI Regions
In some situations, certain MIDI regions will not be displayed in the Score Editor.

• Muted MIDI regions, if Hide Muted Regions is selected in the Global pane of the Score
project settings.

• MIDI regions on muted tracks, if Hide Muted Tracks is selected in the Global pane of
the Score project settings.

• MIDI regions whose Score parameter is turned off in the Inspector’s Region Parameter
box.

Using Note Attributes to Change Individual Notes
You can use note attributes to set individual display parameters for each note, regardless
of the settings in other windows and boxes.

You can set the following note attributes:

• Form of the note head, and note size

• Horizontal position

• Change of accidental distance

• Enharmonic changes

• Settings for interpretation and syncopation, independent of the settings in the Display
Parameter box

• Stem direction, tie direction, and beaming, independent of the settings in the staff
style being used

• Display as an independent note, which excludes the note from the measure’s overall
rhythmic calculation

You can change note attributes in the Note Attributes window, via the Attributes menu,
or with the respective key commands.

Note: Make sure that the Note Attributes setting is chosen in the “Double-click note to
open” menu of the Logic Pro > Preferences > Score window. It is on by default.
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To change note attributes
Do one of the following:

µ Double-click note head to open the Note Attributes window.

Only one note can be changed at a time in the Note Attributes window.

µ Select one or more notes, then choose the appropriate command from the Attributes
menu.

The Attributes menu (and corresponding key commands) allows a group of selected notes
to be assigned new attributes.

You can also change specific note attributes via the Part box, and with tools.

Changing Note Heads
The default setting for note heads is normal (round and black).

To change the attributes of a note head
Do one of the following:

µ Drag a note head from the Part box to the respective note.

µ Choose a note head from the Note Head pop-up menu in the Note Attributes window.

Changing Note Sizes
The default note size is set with the Size parameter in the Staff Style window.

To change a note’s size
Do one of the following:

µ Drag the note upward (increase) or downward (decrease) with the Resize tool.

µ Choose a size from the Size pop-up menu in the Note Attributes window.
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Changing the Horizontal Position of Notes
You can set the horizontal position of each note, individually.

To change a note’s horizontal position
Do one of the following:

µ Drag the note horizontally with the Layout tool.

µ Choose a value from the Horizontal Position pop-up menu in the Note Attributes window.

Changing the Position of Accidentals
This note attribute defines the deviation from the Acc./Note Distance value, chosen in
the Layout pane of the Score project settings.

To change the accidental distance from the note
µ Choose a value from the Accidental Position pop-up menu in the Note Attributes window.

Changing the Display of Accidentals
By default, the display of accidentals depends on the chosen key signature.

To change the display of accidentals
Do one of the following:

µ Choose a value from the Enharmonic Shift or Accidental Type pop-up menu (see list of
settings below) in the Note Attributes window.

µ Choose a value from the Attributes > Accidentals menu.

You can choose between the following display options:

• Default Accidental: The display of accidentals depends on the chosen key signature.

• Enharmonic Shift#: Converts G flat to F sharp, or F to E sharp, for example.

• Enharmonic Shiftb: Converts D sharp to E flat, or B to C flat, for example.

• Flats To Sharps: Similar to Enharmonic Shift #, but leaves notes without flats unaltered
(useful for multiple selection).

• Sharps To Flats: Similar to Enharmonic Shift b, but leaves notes without sharps unaltered
(useful for multiple selection).

• Force Accidental: Forces the display of accidentals (and naturals).

• Hide Accidental: Displays the note without accidentals. (MIDI playback is not affected.)

• Guide Accidental: Forces the display of the accidentals (and naturals) in parentheses.

µ Use one of the following key commands:

• Default Accidentals

• Enharmonic Shift:  #

• Enharmonic Shift:  b
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• Flats To Sharps

• Sharps To Flats

• Force Accidental

• Hide Accidental

• Guide Accidental

Changing the Stem Direction and Length
By default, a note’s stem direction and length depends on the respective setting in the
Staff Style window.

To change a note’s stem direction and length
Do one of the following:

µ Choose a value from the Stem Direction pop-up menu in the Note Attributes window.

Note: The stem length cannot be changed in the Note Attributes window.

µ Choose the respective item in the Attributes > Stems menu.

• Default: The stem direction is set in accordance with the default (staff style) setting.

• Up: The note’s stem is forced upward.

• Down: The note’s stem is forced downward.

• Hide: Hides a note’s stem, and the corresponding beam or flag.

• Stem Position:  Default: Default setting.

• Stem Position:  Center: Moves the stem to the center.

• Stem Position:  Side: Moves the stem to the side.

• Stem Position:  Automatic: Moves the stem to the side.

• Stem End:  Default Length: Default setting.

• Stem End:  Move Up: Moves the stem end upward. Depending on the direction, this
shortens or lengthens the stem.

• Stem End:  Move Down: As above, but moves the stem end downward.

µ Use one of the following key commands:

• Stems:  default

• Stems:  up

• Stems:  down

• Stems:  hide

• Stem End:  Default Length

• Stem End:  Move Up

• Stem End:  Move Down
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Changing the Beaming of Notes
By default, the beaming of notes depends on the chosen time signature, the Beat Grouping
setting in the Time Signature dialog, and the staff style’s Beam parameter.

To change the beaming of notes
Do one of the following:

µ Choose one of the following items in the Attributes > Beaming menu:

• Beam Selected Notes: Forces a beam to the following note.

• Unbeam Selected Notes: Interrupts the beam to the following note.

• Default Beams: Uses the default setting.

µ Use one of the following key commands:

• Beam Selected Notes

• Unbeam Selected Notes

• Default Beams

Changing the Voice or Staff Assignment
You can change the voice or staff assignment for cross staff beaming in the Attributes >
Ties menu. (See Cross Staff Beaming.)

You can choose between the following options (requires a polyphonic multi staff style):

• Default Staff: According to voice assignment.

• Staff Above Voice: Moves the selected notes to the staff above the assigned voice.

• Staff Below Voice: Moves the selected notes to the staff below the assigned voice.

Changing the Tie Direction
By default, the tie direction is set in accordance with the setting in the Staff Style window.

To change a note’s tie direction
Do one of the following:

µ Choose a setting from the Attributes > Ties menu.

µ Choose a tie direction from the Tie Direction pop-up menu in the Note Attributes window.

µ Use one of the following key commands:

• Ties:  default

• Ties:  up

• Ties:  down

962 Chapter 31 Working with Notation



Changing the Syncopation of Notes
By default, note syncopation is set in accordance with the setting in the Display Parameter
box.

To change a note’s Syncopation setting
Do one of the following:

µ Choose a setting from the Attributes > Syncopation menu.

µ Choose a setting from the Syncopation pop-up menu in the Note Attributes window.

µ Use one of the following key commands:

• Default Syncopation

• Force Syncopation

• Defeat Syncopation

Changing the Interpretation of Notes
By default, note interpretation matches the setting chosen in the Display Parameter box.

To change a note’s interpretation setting
Do one of the following:

µ Choose a setting from the Attributes > Interpretation menu.

µ Choose a setting from the Interpretation pop-up menu in the Note Attributes window.

µ Use one of the following key commands:

• Default Interpretation

• Force Interpretation

• Defeat Interpretation

Changing the Independent Status of a Note
Notes are not displayed as independent notes by default.

To change the independent status of a note
Do one of the following:

µ Choose a setting from the Attributes > Independent menu:

• Independent Grace: The note is displayed as a single (independent) grace note.

• Independent: The note is displayed independent of the rhythmic context.

• Not Independent: The note is displayed in the regular rhythmic context.

µ Use one of the following key commands:

• Not Independent

• Independent
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• Independent Grace

Changing the Color of a Note
You can assign different colors to individual notes, in accordance with the three color
palettes.

To assign a color to a note
1 Select the note.

2 Choose one of the 16 colors in the Attributes > Colors menu.

You can also enable the Velocity or Pitch Color mode in this menu. Pitch colors can be
diatonically or chromatically mapped. Note velocity colors match particular MIDI velocity
ranges.

You can edit the 16 color options of the Attributes menu, the velocity colors, and the
pitch colors in the Color pane of the Score project settings. For more information, see
Color Settings.

Note: As note attributes, these settings have priority over the staff style settings, but they
only apply if the color mode is set to Normal in the Score Editor’s View > Colors menu.

Resetting Note Attributes
You can reset all note attributes to their default settings by choosing Attributes > Reset
All Attributes (or using the Reset Note Attributes key command).

Warning: Take care when doing this:  all symbols directly attached to notes (accents,
fermatas, jazz symbols, and so on) are deleted when you reset note attributes.

Working with Staff Styles
Staff styles store multiple attributes, such as the clef, staff size, vertical distance between
staffs, instrument transposition, and so on. It’s simply a case of choosing a new staff style
to alter the score layout of any existing, or newly created, MIDI region. The chosen staff
style has no effect on MIDI playback. It only affects the way Logic Pro displays the score.

On occasion, the included set of predefined staff styles may not meet your needs, and
you will need to create your own. You do this in the Staff Styles window. (See Creating
Staff Styles.)

Staff styles are saved with the project file, allowing different staff styles in different projects.

Tip: Create some empty template projects with (among other things) the staff styles, and
other score settings, that you would normally use as a basis for your work.
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Assigning Staff Styles to MIDI Regions
You can assign a different staff style to each individual MIDI region. In most circumstances,
the predefined staff styles will meet your needs (see Knowing the Predefined Staff Styles).
Changing staff styles allows you to quickly:

• Create parts for transposing instruments.

• Display the same MIDI region at different sizes—perhaps to print a full score, and
individual parts for the different instruments.

• Change between different display forms in one staff. You do this by cutting a MIDI
region, and assigning different staff styles to the resulting shorter regions. This might
be used to alternate between passages that are completely transcribed, and improvised
passages—using only beat slashes and chord symbols, for example.

To assign a staff style (predefined or user-created) to a MIDI region
1 Select the MIDI region.

2 Choose a staff style from the Style parameter pop-up menu in the Display Parameter box.

You can also simultaneously assign a staff style to several selected regions.

Assigning Staff Styles Automatically
When you create a new MIDI region, either by making a real-time recording or with the
Pencil tool in the Arrange area, the MIDI region is assigned the staff style selected in the
bottom line of the Track Parameter box.

When you create template projects, or begin work on a new project, you may want to
change these settings for tracks that are likely to use a specific staff style. This ensures
that regions recorded on these tracks are immediately displayed with the correct staff
style.

If Auto Style is chosen in the bottom line of the Track Parameter box, every new MIDI
region is automatically assigned a staff style that fits the register of the recorded notes.
In other words, a Bass staff style is selected automatically if your region consists of notes
played in a low octave. Similarly, two-handed parts are assigned a Piano staff style.
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Note: Auto Style can only be chosen in the Arrange area’s Track Parameter box, and does
not appear in the list of staff styles in the Score Editor’s Display Parameter box.

Knowing the Predefined Staff Styles
Logic Pro contains a number of predefined staff styles. The table lists them all, and their
parameters:

TranspositionClef typeStaff style

-Bass clefBass

-Treble clefLead Sheet

-Treble/Bass clefPiano (two staffs)

-Treble clefTreble

+1 octaveTreble (−8) clefTreble −8

−1 octaveTreble (+8) clefTreble +8

Eb (+9)Treble clefAlto Sax

Eb (+21)Bass clefBaritone Sax

+1 octaveBass (−8) clefContrabass

-Tablature displayGuitar

-Tablature display/Treble (−8) clefGuitar Mix (Tablature display and
one staff )

-Treble (−8) clef/Tablature displayGuitar Mix 2

Eb (−3)Treble clefHorn in Eb

F (+7)Treble clefHorn in F

-Treble/Bass/Bass clefOrgan 1/1/5 (3 staffs)

-Treble/Bass/Bass clefOrgan 1/3/5 (3 staffs)

-Treble/Bass/Bass clefOrgan 1/3+4/5 (3 staffs)

-Treble/Bass/Bass clefOrgan 1+2/3/5 (3 staffs)

-Treble/Bass/Bass clefOrgan 1+2/3+4/5 (3 staffs)

-Treble/Bass clefPiano 1/3 (2 staffs)

-Treble/Bass clefPiano 1/3+4 (2 staffs)

-Treble/Bass clefPiano 1+2/3 (2 staffs)

-Treble/Bass clefPiano 1+2/3+4 (2 staffs)

−1 octaveTreble clefPiccolo

Bb (+2)Treble clefSoprano Sax

Bb (+14)Treble clefTenor Sax

A (+3)Treble clefTrumpet in A

Bb (+2)Treble clefTrumpet in Bb
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TranspositionClef typeStaff style

-Alto clefViola

-Bass clefVioloncello

MappedPercussion Clef# Drums

Getting to Know the Staff Style Window
The main elements of the Staff Style window are as follows:

Tools

Voice parametersStaff parameters Assign parameters

Hierarchy button

Link button

Name box

• Link button: If the Link button is activated while the Staff Style window is open, you
always see the parameters of the currently selected MIDI region’s staff style. If you
switch to a different MIDI region, the Staff Style window reflects the new selection.

• Hierarchy button: Click to switch the Staff Style window between Single staff style view
and List views. (The latter shows a list of all available staff styles.)

• Tools: Contains the Pointer tool, the Pencil tool (for creating new staffs and voices),
and the Eraser tool (for deleting staff styles, staffs, or voices).

• Name box: The field shows the name of the selected staff style. Click the arrow button
next to it to open a pop-up menu that lists all styles available in the current project.
Switch to another staff style by choosing a different entry.

• Staff parameters: The parameters for staffs. Each line below the word Staff represents
one staff in the score display.
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• Voice parameters: The parameters for independent voices. Each line below the word
Voice represents one independent voice. The term voice only relates to the simultaneous
display of rhythmically independent, polyphonic passages in the music—not the number
of notes that can be displayed simultaneously. One voice can consist of as many
simultaneous notes (chords) as you like. Only notes that should be displayed as
rhythmically independent (of the other notes in the same staff ) need to be assigned
to separate voices.

• Assign parameters: The parameters for the assignment of notes to the different voices.
Every staff can contain several independent voices (up to 16), but one voice cannot be
displayed across different staffs. Therefore, a staff style must contain at least as many
voices as staffs.

To open the Staff Style window
µ Choose Layout > Staff Styles (or use the Open Staff Style Window key command).

The Staff Style window features the Single staff style view shown above, and List view.
List view is mainly intended for copying staff styles between projects, or for deleting
styles.

To switch the Staff Style window to List view
Do one of the following:

µ Double-click in the empty space below the parameters to switch to List view.

Another double-click on one of the listed staff styles switches to the Single view of that
particular style.

µ Click the Hierarchy button to the left of the menu line.

Creating Staff Styles
You can create new staff styles, and edit, delete, and duplicate existing staff styles in the
Staff Style window.
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A staff style includes the following editable parameters:

• Number of staffs (for the display of one MIDI region)

• For polyphonic, multiple staff styles:  Configuration of brackets and bar lines that connect
the staffs

• For every staff:  Staff size, distance to the next (higher and lower) staffs, number of
independent (polyphonic) voices in the staff, clef, display transposition, key signature
on/off

• For every independent (polyphonic) voice:  Automatic rest display on/off, stem direction
of notes, tie direction, direction of N-tuplet brackets and numbers, beaming

• MIDI channel assignment for the voice, or definition of a split point pitch, for separation
of the different voices, note color, number of staffs used to display a MIDI region (usually
one, but two when using the Piano styles, and three when using the Organ styles), the
clefs, and display transposition

In Single view, you can create a new staff style by choosing New > Single Staff Style or
New > Dual Staff Style. The parameters of styles created this way are very basic, and need
to be edited to meet your requirements, in most cases. For details, see Changing Staff
Style Parameters.

The default name of styles created in this fashion is *New Style. Double-click the name
box to open a text entry field, in which you can enter a new name.

Creating Staff Styles Based on Existing Ones
You’ll often need a new staff style that is almost identical to an existing one. In this
situation, make a copy of the existing style, and edit the copy.

To copy a staff style
Do one of the following:

µ Choose New > Duplicate Style in the Staff Style window’s Single view.

µ Click the arrow button next to the Staff Style window’s Name box, then choose
****DUPLICATE!**** from the pop-up menu.

You can also copy the current staff style and assign it to a selected MIDI region at the
same time.
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To copy a staff style and assign it to a selected MIDI region
1 Select a MIDI region in the Score Editor.

2 Click the Style parameter in the Display Parameter box, and choose ****DUPLICATE!****
from the pop-up menu.

Any of these methods results in a new style, named after the staff style it is derived from,
with “*copied” appended to its name. This text can be edited in the name box of the Staff
Style window.

Adding Staffs to a Staff Style
You can add a staff to your staff style. This allows you to create a two-staff piano style
from a single staff style, for example.

Each staff is represented by a number in the first column. These numbers are assigned
automatically, and cannot be changed.

To add a staff to a staff style
µ Determine the staff insert position by clicking in the narrow column to the left of the staff

numbers in the Staff Style window, then choose New > Insert Staff.

The new line is inserted at the insert mark (>) position.

Adding Voices to a Staff Style
You need polyphonic staff styles (staff styles with independent voices) to display
rhythmically different melodic lines in the same staff (typical for choirs). Theoretically,
you can create up to 16 independent voices in a staff style.

To add a voice to a staff style
µ Choose New > Insert Voice.

The newly inserted voice inherits the parameters of the voice above it. These can be freely
edited. The staff field in the first column remains empty.

The new voice is inserted at the insert mark (>) position, set with a click in the narrow
column to the left of the staff numbers. (This is important if you want to insert a new
voice between existing voices.)

The default project contains a number of polyphonic staff styles for piano (Piano 1+2/3+4,
for example) and church organ (Organ 1+2/3+4/5, with three staffs, for example).
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Copying Voices or Staffs into Other Staff Styles
You can copy one (or several) voices and staffs, inclusive of their parameters, into other
staff styles.

To copy a voice or staff into another staff style
1 Select the voices or staffs you want to copy, by dragging vertically in the margin column

to the left of the staff numbers.

The selection is indicated by a dark gray vertical beam.

2 Choose Edit > Copy (or use the corresponding key command, default
assignment:  Command-C).

3 Switch to the target staff style that you want to paste these voices into. (This also works
between different projects.)

4 Set the insert mark, then choose Edit > Paste (or use the corresponding key command,
default assignment:  Command-V).

Note: If a voice is selected in the destination staff style (indicated by a black beam in the
left column), it is replaced by the pasted voices.

Copying Staff Styles Between Projects
At some point, you’ll probably want to use staff styles that already exist in another project.

To import all staff styles from another project
1 Do one of the following:

• Choose File > Project Settings > Import Project Settings (or use the corresponding key
command).

• Click the Settings button in the Arrange toolbar, then choose Import Settings.

• Click the Browser tab in the Media area.

2 Navigate to and select the appropriate project file.

3 Click the Import button.

Note: If accessing the settings from the Browser tab, you also need to click the Import
Settings button, which appears after you click the Import button.

4 In the Import Settings window, select the Staff Styles checkbox (and deselect all other
settings that you don’t want to import).

971Chapter 31 Working with Notation



5 Click the Import button.

All staff styles from the other project are imported into the current one.

To copy particular staff styles from other projects
1 In the project that contains the staff styles you want to copy, open the Staff Style window.

(Single view is displayed.)

2 Double-click in the space below the staff style parameters to display a listing of all staff
styles.

3 Select the staff styles you want to copy.

4 Choose Edit > Copy (or use the corresponding key command, default
assignment:  Command-C).

5 Open the Staff Style window in the target project.

6 Choose Edit > Paste (or use the corresponding key command, default
assignment:  Command-V).

Note: If you copy a MIDI region from one project to another, and the staff style used by
the original MIDI region doesn’t exist in the target project file, it is automatically copied,
along with the MIDI region.

Deleting Voices or Staffs from a Staff Style
To delete voices or staffs from a staff style, select them and press Delete, or choose Edit
> Delete.

Deleting Staff Styles
You can delete staff styles in both Single view and List view. The latter allows you to
select, and delete, several staff styles simultaneously.

To delete a staff style in Single view
µ Choose New > Delete Style.

To delete multiple staff styles in List view
µ Shift-click the staff styles you want to remove, then choose Edit > Delete (or press the

Delete key).

Tip: In List view, you can use the Edit > Select Unused command, to select all staff styles
that are currently not assigned to any regions or track instruments in the project.

Changing Staff Style Parameters
Once you have created or imported a staff style and set the number of voices and staffs,
you can edit the following parameters in the Staff Style window.
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Name
Double-clicking in the name box to the left of the Staff and Voice columns allows you to
enter a new staff style name.

About Key Range
Notes that fall outside the key range (defined to the left of the Staff Style window) are
not displayed in the Score Editor. This allows you to hide notes that are used for
key-switching duties (for example, VSL sample libraries loaded into the EXS24 mkII).

Brackets and Bar Line Connections
You can only edit this parameter in styles with multiple staffs:  it lets you determine which
staffs are bracketed (two bracket types are available) or connected by bar lines (only at
the beginning of each staff line, or at every bar line). Drag in the corresponding column
until you see the appropriate display for any of these connections.

If a staff style consists of more than two staffs, the brackets and bar lines can be set to
connect only certain parts of the overall staff style—they can be interrupted in between
staffs. If you want to delete any connections, grab the symbol at its end (bottom), and
drag it up, until it disappears.

Space
These values determine the distance to the next (higher and lower) staff, or the page
margins, for the top and bottom staffs in a full score.

The first value increases or decreases the space above staffs, and the second value, the
space below staffs.

This parameter is helpful when you need to create additional space above or below a
staff, allowing symbols to be inserted between staffs.

You can also change the vertical distance above the staff directly in the score, by dragging
the staff up or down (at the clef ).

The distance below the staff can also be edited in the score, but only for the bottom staff
in the score display, or if one staff is displayed. You drag the bottom line of the score
display with the mouse.

These editing procedures change the settings of the corresponding staff style. All regions
that use the same staff style are affected.
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Size
Use this parameter to determine the size of the staff, and the notes and symbols (including
slurs and ties) it contains.

There are 16 sizes available (0–15). Here are some size recommendations:

• For regular instrument parts and lead sheets, use size 7 or 8.

• The staff size you should use in full scores depends on the number of staffs in the score,
and the size and format of the paper being used. When using A4 or US letter paper:  full
orchestra:  2, big band:  3, wind quintet:  4.

Note: The size of all staffs in a score set can also be affected by the Scale parameter in
the Score Set window. (See Using Score Sets to Create Scores and Parts.) This makes it
possible to use the same sizes for both the whole score, and parts of a piece.

Clef
You can choose the clef to be used in the staff style from a pop-up menu. This pop-up
menu offers some special options, in addition to the usual clefs:

• Drum.0 to Drum.8: Staffs with 0 to 8 lines and a neutral percussion clef. The relationship
of MIDI note pitches to the top line of all staffs corresponds to the top line in a regular
bass clef (A2). No accidentals are displayed in these drum staffs. Drum.0 also omits any
ledger lines. These clefs are often used in mapped drum styles, where the vertical
position of a note on the staff doesn’t correspond to pitch, but is determined by different
drum map parameters. See Using Drum Notation with Mapped Staff Styles for more
information on mapped drum styles.

• no clef.0 to no clef.8: Is like the Drum.0 to Drum.8 staffs, but without a clef.

• TAB Guitar and TAB Bass: Twelve different options for displaying notes as guitar or bass
tablature. Tablature tuning sets are defined and edited in the Tablature window (Layout
> Guitar Tablature).

Transpose
The display transposition, measured in half steps up or down. This parameter does not
affect MIDI playback. If a staff contains chord symbols, these are also transposed
accordingly. If the Automatic Key Transposition project setting, in the Clefs & Signatures
pane, is activated (which is the default), key signatures are also transposed (with one
exception—see “Key,” next).

Key
If this parameter is set to Hide, the corresponding staff is displayed without a key signature.
All sharps and flats are indicated directly beside notes. This parameter is usually set to
show the key signature. The Hide option is mainly used for transposed French horn parts,
which are sometimes written without a key signature.
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Note: The Automatic Key Transposition project setting affects the whole project, but still
indicates the nontransposed basic key signature. Hide Key suppresses any key signature
display.

Rest
The automatic rest display can be turned off (Hide), or set to display beat slashes (slash)
instead of rests. This is useful for rhythm section parts, and improvised solos. In this
situation, the number of slashes per bar is determined by the nominator in the time
signature (4 slashes in 4/4-time, 6 slashes in 6/8-time, and so on). Inserted notes and
symbols are still displayed, but automatic rests are shown only if shorter than one beat.
You can insert user rests manually, to replace individual beat slashes, if needed.

Stem
This controls the direction of stems. The default setting is Auto. Up or Down forces all
stems, regardless of pitch, in the corresponding direction. Hide makes all stems (and
beams and flags) invisible.

Tie
Determines the vertical direction of automatically displayed ties. The default setting is
Auto. Up or Down forces all ties in the corresponding direction.

Tuplet
Controls the direction of N-tuplet brackets and numbers. The default setting is Auto. Up
or Down forces all N-tuplet brackets and numbers in the corresponding direction. Hide
prevents the automatic display of triplet brackets and numbers. In this situation, the
numbers are still displayed in brackets on the screen, to allow edits to these triplets. These
bracketed numbers do not appear, however, on the printout.

If you set this parameter to Hide, you can still make particular triplets visible:  Double-click
the bracketed number (3) to open a tuplet dialog. If you close this dialog by clicking OK,
you convert the automatically displayed triplet to a forced triplet, which is displayed in
accordance with the parameters set in the dialog.

Beam
Controls the appearance of beams. The default Slant setting allows slanted beams. Horiz.
only allows horizontal beams. Vocal prevents the display of beams, as is typical in classical
vocal parts, where notes are only displayed with flags.

Color
Sets the color of the voice’s notes. The color options are Black (“---”), Pitch, Velocity, and
the 16 colors of the user palette. (See Color Settings.)

These settings only affect regions if the View > Colors > Normal item is chosen in the
Score Editor (default setting).
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Head
Controls the appearance of note heads. You can choose to display note heads as normal,
show note names or finger names, or hide the note heads completely.

Assign Parameters
The Chan and Split parameters of the Staff Style window are covered in detail in Assigning
Notes to Voices and Staffs.

Assigning Notes to Voices and Staffs
You can use two different methods to assign notes to voices and staffs:  define a fixed
split point, or use MIDI channels for each voice of a staff.

Using a Split Point
You can use a fixed split point to assign notes to voices. This is a defined pitch, which
determines the absolute border between two voices. Notes above it, or at the same pitch,
are assigned to the upper voice. Notes below it are assigned to the lower voice. Quite
often, in real-life situations, the border between voices needs to be flexible. A piano
piece’s right-hand part may dip below middle C (the defined split point), or the left hand
may go above. It’s not possible to notate this properly using a fixed split point, but you
can use this feature to create an “almost right” version.

To separate voices by split point
µ In the Staff Style window’s Split column, choose a note pitch.

Using MIDI Channels
You can use MIDI channels (Chan) to assign notes to voices. Every note belongs to the
voice that “owns” its MIDI channel. The different MIDI channels have no impact on MIDI
playback, as the playback channel is determined by the Track Parameter box setting (in
the Arrange window). Given the use of MIDI channels for voice assignment, notes that
aren’t assigned to channels are not displayed at all. This can, however, be used to your
advantage, as it allows you to exclude certain notes from the display (improvised parts,
trill notes, and so on).

To separate voices by MIDI channel
µ In the Staff Style window’s Chan column, assign a MIDI channel to each voice.

When you use MIDI channels to assign notes to staffs or voices:

• You can edit the MIDI channel in the same way you do all other events:  by selecting
the events and changing the MIDI channel in the Event Parameter box or the Event
List.

• You can quickly change the MIDI channel of selected note events with the Event Channel
+1 and Event Channel −1 key commands. These can be especially useful when used
in combination with the Select Next Region/Event, or Set Marquee End to Next Transient
key command and the Select Previous Region/Event, or set Marquee End to Previous
Transient key command, which allow you to move the selection from note to note.
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In addition, you can also use Score Editor functions designed to speed up the process of
changing the MIDI channel settings of notes, in order to assign them to the specific voices.
These include the Auto Split preference and the Voice Separation tool.

Splitting MIDI Channels Automatically
If you record polyphonic voices as separate passes in real time, you can set your keyboard
or MIDI controller to the appropriate MIDI channel for each voice. This saves you from
editing the channels after the fact. The same applies to step input.

Alternately, you can automatically split MIDI notes using the “Auto split notes in multi
staff chord styles” Score preference.

If this preference is turned on, and the default staff style in the selected Track Parameter
box is a polyphonic style, all played notes are automatically assigned MIDI channels that
match the staff style’s voice assignments. Notes at, and above, the split point are assigned
the channel of the first voice. Notes below are assigned the second voice’s channel. (This
feature only works for two voices at a time.) This creates a rough, but usable, voice
assignment, which can be edited later.

To split regions that have already been recorded
1 Select the region.

2 Choose Functions > Note Events > Assign Channels based on Score Split (or use the
corresponding key command).

The region’s notes are assigned to voices in the staff style, according to the Auto Split
pitch in the Score preferences.

Using the Voice Separation Tool
The Voice Separation tool allows you to draw a separation line between notes on a staff,
thereby assigning them to the MIDI channels of the voices. MIDI channels have to be
predefined for each of the voices that you want to separate. This is because Logic Pro
needs to know which MIDI channels are assigned to each note.

To use the Voice Separation tool to change the MIDI channel of notes
1 Select the Voice Separation tool.
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2 Draw a line (between notes) where you want to separate the voices.

Notes below the line are moved to the MIDI channel below their current assignment.

3 If you make a mistake, move the mouse back slightly to the left.

The separation line is erased to the right of the tool, allowing you to try again.

Staff Style Examples
The following sections illustrate how you can use the staff style features to meet specific
notation needs.

Creating a Staff Style for Two Independent Voices
If there are two independent voices throughout the piece, the parameters might be set
as follows:  stem, tie, and N-tuplet direction are set to Up for the top voice and Down for
the bottom voice. Note that even with these general parameters, note attributes can be
changed for each note. (SeeUsing Note Attributes to Change Individual Notes.) Both
voices are displayed with automatically displayed rests (Rest parameter:  Show).

Creating a Single Staff Style with Optional Polyphony
Sometimes you need to add a second voice to a staff that usually only requires one voice,
in order to properly notate a short, rhythmically independent passage. This is not
uncommon with orchestral scores, in which the unison part for a group of instruments
is temporarily separated from the other parts.
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One solution is to use a staff style with a main voice and a secondary voice. The parameters
for the main voice should be set as you would a nonpolyphonic style. The secondary
voice is set to channel 16, and is displayed without automatic rests:

• The stem, tie, and tuplet directions for the main voice are set to Auto, which is necessary
for the proper notation of unison parts. No MIDI channel is defined for the main voice,
so all notes with a channel other than 16 are assigned to the main voice. As long as no
notes or rests with MIDI channel 16 are used, the score display looks the same as with
a simple, nonpolyphonic staff style.

• For the second voice, the stem, tie, and tuplet direction parameters are set to Down,
and the automatic rest display is turned off (Hide). Only MIDI channel 16 note events
are assigned to this voice.

The following additional steps are necessary to improve the score’s appearance:

• Rests in the second voice need to be inserted manually where needed. The MIDI channel
of inserted rests must match the second voice’s channel (16, in this case). You can edit
this in the Event List.

• In the polyphonic passages, the stems of the main voice need to be forced upward by
selecting the corresponding notes, and changing their individual stem parameters.
SeeUsing Note Attributes to Change Individual Notes.

An advantage of this approach is that you don’t need to worry about MIDI channels
during recording or input, and notes won’t disappear unintentionally. There is, however,
the disadvantage that the Voice Separation tool cannot be used to assign notes to voices.

Other applications for this method would include the display of beamed grace notes,
occasional polyphony in a guitar part, or the indication of rhythmic accents above or
below beat slashes in rhythm section parts.

Don’t forget that you can add further voices to a staff, to display more complex parts (up
to 16).

Using Mouse Input in Polyphonic Staff Styles
Mouse input into polyphonic staff styles is very easy, if you turn on View > Explode
Polyphony (also available as a key command). This forces all voices to be displayed on
separate staffs, regardless of staff style settings. (The other voice parameters remain valid.)

If you insert a note into a staff style that uses MIDI channels for voice separation, it is
automatically assigned the corresponding MIDI channel (of the staff that you add the
note to). Following input, turn off the Explode Polyphony setting. All voices are displayed
correctly in one staff, as per the staff style settings.

979Chapter 31 Working with Notation



You can, of course, also insert notes directly into polyphonic staffs without turning on
the Explode Polyphony setting. In this situation, inserted notes are assigned the MIDI
channel set in the Insert Defaults of the Event Parameter box (but only if that particular
channel is used by one of the voices in the staff ).

Changing the Staff Assignment of Symbols
There is a Staff parameter in the Event Parameter box for most symbols inserted into
multiple staff styles. This parameter determines which staff the symbol belongs to.

Cross Staff Beaming
Music for keyboard instruments or harp (which is notated in two staffs) sometimes contains
passages where notes in the upper and lower staff (played by the left and right hand)
are connected with a beam, to emphasize the continuing musical phrase.

Cross staff beamed notes

In the Score Editor, notes can only be connected with beams if they belong to the same
voice. Notes that belong to the same voice, however, are displayed in the same staff. You
need to use the Score Editor’s Staff Assignment commands to display the same voice
notes in separate staffs.

For example, the following screenshot depicts a piano passage, displayed in the Piano
staff style. The notes in the upper staff belong to voice one, using MIDI channel one. The
notes in the lower staff belong to voice two, using MIDI channel two. Imagine that you
want to connect the eight notes in the first bar with beams, to emphasize the continuing
musical phrase.
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To beam notes that do not belong to the same staff
1 Change the voice assignments for the notes that you want to connect with beams (in

the lower staff ) by doing one of the following:

• Draw a line below these notes with the Voice Separation tool.

• Select all notes, and change their MIDI channel to match that of the upper voice (in
the Event Parameter box).

All notes are displayed in the upper staff, probably accompanied by a lot of ledger lines.

2 Select the notes that you want to define a beaming connection for, then choose Attributes
> Beaming > Beam Selected (or use the corresponding key command).

3 Select the notes that you want displayed in the bottom staff, and choose Attributes >
Voice/Staff Assignment > Staff below Voice (or the corresponding key command).

All selected notes are moved down to the lower staff, although they still remain part of
the upper voice.

You can also use the reverse approach, first assigning all notes to the lower voice, then
moving some notes to the upper staff with Attributes > Voice/Staff Assignment > Staff
Above Voice.

To display all selected notes in their original staff, use Attributes > Voice/Staff Assignment
> Default Staff.
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Note: As always, rests are displayed automatically in Logic Pro, as per the Rest settings
in the staff style. Given the cross staff beaming situation described above, however, most
(or all) notes belong to the voice of the top staff, and the lower staff will contain
rests—some even at positions occupied by notes. To avoid this potential issue, use a staff
style where the automatic rest display is deactivated for the bottom staff’s voice. Wherever
rest display is desired, insert it or them from the Part box, with the mouse.

Using Drum Notation with Mapped Staff Styles
In MIDI regions that are assigned to drum instruments, each MIDI note usually triggers a
different sound. If such MIDI regions are displayed with a regular staff style, you see notes
with no apparent relationships to the sounds represented by them.

If you want to notate these musically meaningless pitches as a readable drum part—which
uses special percussion note heads—you should use mapped instruments and mapped
staff styles.

Mapped staff styles allow you to assign individual voices to drum groups. Drum groups
use specific drum notation head shapes to display note events. You can define the
respective drum note head shapes in a Mapped Instrument window.

The best way to create drum notation for an existing MIDI region is to open the Score
Editor (to display the MIDI region), the Mapped Instrument window, and the Staff Style
window. This way, you can directly see how parameter changes affect the score display.
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Prior to defining the details of a mapped staff style, you should set up all drum groups,
note head shapes, and relative note position parameters in the Mapped Instrument
window.

To create a mapped staff style for drum notation
1 Create a mapped instrument in the Environment, then double-click its icon. For details

about creating mapped instruments, see Mapped Instrument Objects.

The Mapped Instrument window opens. Its default settings correspond to the General
MIDI drum note assignments, but they can be edited.

In the columns to the far right are three parameters relevant to notation.

2 In the Head menu, choose the shape of the note head for notes triggered by this particular
pitch.

A note must be assigned to a drum group to be displayed in a mapped staff style. If it’s
not, it won’t be visible.

3 Choose a drum group in the Group menu.

A number of groups are predefined for the most commonly used drum sounds (Kick,
Snare, Hi-Hat, Toms, Cymbals, and so on).

Note: If you want to define a new drum group for another instrument sound (such as
tambourine), choose New Group from the pop-up menu, and double-click the entry to
name the new drum group.

4 Set the Rel. Pos. (relative position) parameter.

The Rel. Pos. parameter assigns the note to a line in the staff. The note position is relative
to the top line of the staff. Integer values make the note fall on a line; fractional values
result in a note position between two lines.

Note: Positions can also be influenced in the Staff Style window, but this affects all notes
of a particular drum group.
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These options allow you to have two different MIDI notes (different bass drum sounds,
for example) displayed in the same way in the score, or on the same line, but with different
note heads.

5 Create a new mapped staff style by choosing New > Mapped Style in the Staff Style
window, and inserting all staffs, voices, and drum groups as described above, and in
Working with Staff Styles.

• Staff section: Everything is identical to nonmapped staff styles (with the exception of
the missing Transpose and Key parameters, which wouldn’t make sense here).

• Voice section: Below Voice (in the top header line), is a separate Voice column, where
the different voices are numbered automatically. The staff style shown above contains
one staff with five independent voices.

• Horizontal lines: Display the Staffs-Voices-Drum Groups hierarchy, indicating the borders
between these elements. Each drum group belongs to the voice at the same horizontal
position.

• Pos parameter: Affects the vertical positioning of all notes in the corresponding drum
group. The value shown here is an offset that is added to, or subtracted from, the
relative positions (if defined for individual notes in the Mapped Instrument window).

Mapped staff style names are preceded by the # character in the Staff Styles window.

If you are using several MIDI instruments with different drum assignments, you can create
a separate drum map (in the Mapped Instrument window) for each instrument. The list
of drum groups, however, is the same for all instruments in a project. This allows you to
display different drum tracks with the same mapped staff style. All snare drums, for
example, will be displayed in the same way.

To override this behavior
1 Create additional drum groups (Kick2, Snare2, and so on).

2 Create a second mapped staff style to display these drum groups.
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Using Score Sets to Create Scores and Parts
You can use score sets to determine which instrument tracks should be included in the
score display. Each project can contain as many score sets as required. Score sets allow
you to:

• Produce both the full score and individual parts (such as particular groups of
instruments).

• Arrange the (vertical) order of instrument tracks in the score, independent of the order
of tracks in the Arrange area.

• Assign a name (and, optionally, an abbreviated name) to each instrument track, which
will be displayed and printed as instrument names in the score.

• Determine which staffs will be connected by brackets or bar lines.

• Exclude the display of tracks that are only relevant for playback, but not for the score
(tracks that only contain MIDI controller data, for example).

• Simultaneously reduce or enlarge all staffs in each staff set, by using the Scale parameter.
This allows you to use the same staff styles for printout of full scores and individual
parts.

• Select from two different parameter sets (Score or Part) for page margins, header space
height, vertical distance between staff systems, and the maximum number of bars per
line.

The Relationship Between Score Sets and Display Modes
A score set is only shown as defined if an appropriate display mode is chosen. Content
Link and Content Catch only allow the display of one MIDI region at a time, making them
unsuitable for work with score sets. It’s usually best to deselect Link, once the desired
score set is fully displayed. If only one MIDI region is displayed, double-click below the
staff, which displays the full score; then deselect Link.

Tip: It is possible to work with several open Score Editor windows, each showing different
display levels or different score sets.

Choosing a Score Set
You choose a score set in the Inspector’s Score Set pop-up menu.

Click the menu to show all available score sets. New projects only show the All Instruments
score set, which displays all instruments, depending on the display level.
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Getting to Know the Score Set Window
You can create and edit score sets in the Score Set window.

To open the Score Set window
Do one of the following:

µ Choose the Open Score Set window command in the Score Set menu (or use the Open
Score Set Window key command, default assignment:  Control-Option-Command-I).

µ Choose Layout > Score Sets in the Score Editor.

Note: If you open the Score Set window when the default All Instruments score set is
chosen, a warning indicates that the All Instruments score set cannot be edited.

Name of Score Set
You can edit the name of a score set by double-clicking the name in the left column of
the Score Set window, which opens a text entry field.

Insert Mark
The narrow column to the left allows you to set an insert mark (>) with a mouse click, or
make multiple selection marks by dragging vertically.

Instrument
This column is used to determine which instruments are included in the score set, and
their (vertical) order of appearance in the score. Track instrument icons are also displayed
in this column, at the highest zoom level.
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Full Name
Click any line in this column to open an entry field that contains the default “@(reference).”
If you don’t change this, the name of the track’s instrument is used as the name for the
instrument in the score. As the track’s instrument name is often identical to the
corresponding synthesizer patch (Solo Strings High, for example), you’ll probably want
to assign another name here. This name is automatically displayed in the score as the full
name:  “Violin 1,” for example. Display parameters for instrument names are set in the
Numbers & Names pane of the Score project settings. (See Numbers & Names Settings.)

Short Name
You can also define an abbreviated name for each instrument, which is used if Short
Names is chosen in the 1st Staff and Other Staffs pop-up menus of the Numbers & Names
pane, in the Score project settings.

Brackets and Bar Lines
You can define which staffs in the score set are connected by brackets or bar lines (either
at the beginning of each staff, or throughout), in the last four columns. Any of these
connections can be set by dragging vertically in the column, until you see the appropriate
display.
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Brackets and bar lines can also be interrupted between staffs, allowing you to form groups
of connected instruments in a score. If you want to delete a line or bracket, grab the
corresponding symbol at its end point (bottom), and drag it upward, until it disappears.
You can use the same method to shorten lines.

Bar line connections can also be edited directly in the score. Click the upper end of a bar
line to connect it to the next (higher) staff. Repeating the procedure disconnects the bar
lines.

Creating and Deleting Score Sets
When you open a Score Editor window while several regions are selected in the Arrange
area, Logic Pro automatically creates and displays a score set that only contains the
instruments of the selected regions.

You can also use one of the following methods to create a score set manually.

To create an empty score set
µ Choose New > New Empty Set in the Score Set window.

You can insert instruments into the empty score set, one by one.

To create a copy of the currently selected score set
µ Choose New > Duplicate Set in the Score Set window.

To create a score set for all selected instruments
1 Select at least one MIDI region for all instrument tracks you want to include in the score

set.

2 Choose Layout > Create Score Set from Selection (or use the corresponding key command)
in the Score Editor.

Logic Pro creates and displays a new score set, which consists of all instruments used by
the currently selected MIDI regions.

Score sets created this way are automatically named after the instruments they contain.

To create a score set that contains all instrument tracks used in the Arrange window
µ In the Score Set window, choose New > New Complete Set.

Tip: If several instruments or staffs use the same MIDI sound for playback (with the same
MIDI channel on the same MIDI instrument), and you want to display these staffs with
different instrument names in the score, you need to create a separate track instrument
for each staff, in the Arrange area.

All score sets are saved with the project file.

To delete a score set
µ Select the score set in the Score Set window, then choose New > Delete Set.
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Editing Score Sets
Once you have created a score set, you can change the assignment of instrument entries,
add instruments, or change their order.

To assign another instrument to an existing score set entry
µ Click-hold the name of the instrument you want to replace in the Instrument column,

then choose an instrument from the pop-up menu.

To add an instrument to the middle of the list
µ Set the insert mark to the desired position, then choose New > Add Instrument Entry.

A new instrument entry is added at the insert mark.

To add an instrument at the bottom of the list
µ Double-click below the instrument list.

A new instrument entry is added at the bottom of the list.

You can use the usual Cut, Copy, and Paste commands to reorder the instrument entries
in a score set. If pasted, they are placed at the insert mark position, which must be set
beforehand.

Scaling Score Sets
You can scale any score set to a size between 50 and 200 percent of its original size.

To scale a score set
µ Select the score set in the Score Set window, then set the Scale parameter to a new value.

The Scale parameter affects:

• All staffs

• The distance between the staffs

• All symbols associated with staffs (all notes, rests, and other symbols)

• All local text, including lyrics

• Slur and Tie thickness

The Scale parameter does not affect global text objects (header text, text inserted outside
the margins) and text such as page numbers.
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Scaling doesn’t take place on instrument parts that were created by Option-clicking the
Score Set pop-up menu and choosing the instrument from the pop-up menu (as described
below; see Filtering Single Instruments from the Score). As such, you can use the same
staff styles for full scores and parts:  in extracted parts, the staffs appear at their original
size; in the full score, their size is defined by the Scale parameter.

Note: The All Instruments set cannot be edited (and therefore, cannot be scaled), so you
need to create a dedicated score set for the full score, in most cases.

Creating Separate Layouts for Full Score and Parts
You can set separate layout parameters for the full score and parts in the Global pane of
the Score project settings. The Format parameter in the Score Set window determines
which layout parameters a score set uses.

To create separate layout parameters for the full score and parts
1 Open the Global Score project settings by choosing File > Project Settings > Score (or

using the Open Score Project Settings key command), then click the Global tab.

The Global pane offers separate page layout parameters for score and parts.

2 Set the separate score and part layout parameters.

To determine the layout parameters used by a score set
µ In the Score Set window, choose a setting from the Format pop-up menu.
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For the default All Instruments set, the score settings are always used, except when a
single MIDI region is displayed. In this situation, the part settings are used.

Filtering Single Instruments from the Score
You can quickly extract a single instrument from the score, by choosing it from the pop-up
menu that appears when you Option-click the Score Set pop-up menu.

This way, you don’t need to create a score set for every instrument in order to produce
parts. You should note, however, that only the track instrument names are used as
instrument names in the score. So, if you use this method for printout of your parts, you
see the real instrument names of the Arrange window track instruments.

Importing Score Sets from Other Projects
You can import score sets from other projects.

To import score sets from other projects
1 Do one of the following:

• Choose File > Project Settings > Import Project Settings (or use the corresponding key
command).

• Click the Settings button in the Arrange toolbar, then choose Import Settings.

• Click the Browser tab in the Media area.

2 Navigate to, and select, the required project file.

3 Click the Import button.

Note: If accessing the settings from the Browser tab, you also need to click the Import
Settings button, which appears after you click the Import button.

4 In the Import Settings window, select the Score Sets checkbox (and deselect all other
settings that you don’t want to import).

5 Click the Import button.

All score sets are imported from another project into the current project.

Preparing the Score Layout for Printing
This section outlines a number of changes you can make to the overall score layout. These
primarily involve display customizations, and use of the Score project settings or
preferences. For full details, see Score Settings and Score Preferences in Logic Pro.

Understanding the Page Display Options
You should use Page Score view for layout work when preparing for printing. In Page
Score view, Logic Pro automatically displays as many facing pages as possible, depending
on the size of the Score Editor window and current zoom level.
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To switch to Page Score view
Do one of the following:

µ Choose View > Page View in the Score Editor (or use the corresponding key command).

µ Click the Page View button in the Score Editor’s upper-left corner.

You should use Linear Score view for editing, as screen redraws are much faster, especially
on slower computers.

You can jump directly to any page using the View > Go to Page menu item (or
corresponding key command), when working in Page Score view. The playhead is
automatically set to the beginning of the selected page, unless the sequencer is running
when you choose the command. In this situation, Catch mode is turned off.

The View > Page Display Options menu item offers a number of additional settings that
are useful for printing or layout tasks.

• Print View: Print view shows the score as it will be printed. Print view can only be turned
on when Page Score view is active.

• Show Margins: Displays page margins onscreen. These are not printed.

• Show Pages in Pairs: Shows facing pages. This setting depends on the zoom settings
and score scale.

• Show Page Rulers: Displays a horizontal and vertical ruler (in centimeters or inches) that
makes precise layout tasks easier.

Note: The yellow area on the screen represents the printable area (which also depends
on the printer being used), not the actual sheet of paper. The grayish-yellow area
surrounding the page—in Print view—shows how the page will actually be printed.

Setting Line Breaks
You can set line breaks individually for each score set, and also for each of the extracted
parts. Logic Pro saves breaks with the project file.

The automatic line break calculations are based on the Spacing and Maximum Bars/Line
settings in the Global Score project settings. The Maximum Bars/Line project setting
determines the maximum number of bars Logic Pro will allow in one staff or staff system.
You can override the automatic line break with the Layout tool (when in Page Score view).
You can also create a line break by inserting the Link Break symbol in any view mode,
using the standard insert methods.

For example, you can set Maximum Bars/Line to 6, and still move additional bars into a
line with the Layout tool. Any subsequent lines will contain no more than six bars. The
full number of bars set here is only displayed if the spacing settings are low enough to
allow the proper display of that many bars.
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Note: If you drag more bars into a line than would be displayed when employing the
automatic line break function, overlapping notes and symbols may result.

To move one or more bars of a staff system down into the next staff
µ In Page Score view, grab the bar with the Layout tool and drag it down (the pointer

changes to a hand with a downward-pointing thumb), then release the mouse button.

The bar is moved to the next staff system, and the remaining bars in the line are distributed
evenly over the entire width of the page.

You can also move the first bars of a staff upward into the preceding staff, by dragging
them up with the Layout tool.

When you move a bar with the Layout tool, all manually edited line breaks in subsequent
lines are deleted, and the (automatic) line breaks are recalculated from that line downward.
If you want to prevent this behavior, perhaps because you only want to change one detail
and keep the other staffs as they were, hold down the Option key while moving the bars
with the Layout tool. Line breaks edited in this way only affect the two (directly concerned)
staff systems. All other staff systems are unchanged.

Setting Page Breaks
You can set page breaks individually for each score set, and also for each of the extracted
parts. Logic Pro saves breaks with the project file.

You can use the Page Break symbols to insert a page break. This technique moves all bars
that follow the page break insertion point to the following page. All preceding, and
following, bars are automatically adjusted in accordance with the Score project settings
(discussed in the Setting Line Breaks section). All staffs in the score are affected.
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Editing Local Margins
You can move the left and right margin of each individual staff system with the Layout
tool, so that they do not align horizontally with the page margins. Like manual line breaks,
these local margins are also saved as part of the current score set, allowing different
settings for each score set.

To move the left and right margin of a staff system
1 Turn on the following settings in the Score Editor’s View menu:

• Page View

• Page Display Options > Print View

• Page Display Options > Show Margins

2 Click-hold (with the Layout tool) a little inside the beginning or end of the staff, and drag
to the left or right.

During this process, Left/Right Staff Margin appears in the help tag.

Note: When altering margins, Logic Pro automatically adapts the number of bars per line
(unless you have manually adjusted line breaks beforehand). If the line is shortened, bars
may be moved down to the next line, depending on the Spacing parameters in the Global
pane of the Score project settings. (See Global Score Settings.)

To realign a changed staff margin with the other staffs
µ Double-click at its end (or beginning) with the Layout tool.

To delete all line breaks and (locally) changed margins in the current score set
µ Choose Layout > Reset Line Layout.

Changing the Margin and Header Values (Page Print View)
You can change the Margin and Header Space project settings directly in Page Print view.

To change the margin and header space values
1 Choose the following settings in the Score Editor’s View menu:

• Page View

• Page Display Options > Print View
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• Page Display Options > Show Margins

2 Set the margin values by dragging the orange lines.

3 Set the header space value by dragging the purple line.

Only the setting (score or part) that is currently displayed is affected.

Using External Symbol Fonts for Display and Printout
You can use the Sonata font from Adobe, the Jazzfont, and the Swingfont (not included
with Logic Pro), instead of the internal Logic Pro score font, for display and printout of
notes and symbols. The external font must be properly installed on your system. Choose
Logic Pro > Preferences > Score > “Use external symbol font (if available),” then choose
the font you want to use from the corresponding pop-up menu.

Printing the Score
The printout of scores created in Logic Pro is identical to the Score Editor’s Page Score
view display. The following items are not printed, but are visible onscreen:

• The dashed lines that represent page and header margins, and borders between staff
systems

• Mouse pointer and playhead

• Colors (page margins, staff lines of selected MIDI regions)

• Hidden time signature changes

• Hidden note heads (displayed in gray on the screen) and their ties

• Hidden bar lines (displayed as grayed-out lines on the screen)

• Hidden N-Tuplet numbers

To print your score
1 Choose the appropriate paper size and format in the File > Page Setup window.

2 Make sure that the Score Editor (containing the intended Print view) is the active window.
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3 Start printing by choosing File > Print (or using the corresponding key command, default
assignment:  Command-P).

A dialog, which may vary slightly from printer to printer, is shown. Choose from the
available options, such as which page numbers you want to print, the number of copies,
or click the PDF button to “print to” (Save as) a PDF file.

4 Make your selections, then click the Print button.

You should work at high zoom levels when doing layout work that requires precision,
such as positioning symbols and text elements.

It’s very easy to switch back and forth between a normal and enlarged view of the display,
by using the Zoom tool (shortcut:  drag to select while holding down Control, to enlarge
the selected area).

Exporting the Score as a Graphic File
You can save a part of a Logic Pro score page (or a whole page) as an image (PDF format),
or copy it to the Clipboard. This allows you to paste it into graphics-editing programs, or
documents created in word-processing or desktop-publishing applications.

Preparing the Score for Export
Before you export the score as an image, choose the appropriate Camera Tool settings
in the Logic Pro > Preferences > Score pane.

• “Write to” buttons: Allow you to choose between the following two options:

• Clipboard: The image is copied to the Clipboard, and can be pasted directly into
other applications, without saving it as a separate file.

• PDF File: The image is saved as a PDF file. A dialog allows you to assign a filename
and path (when the Camera tool is used to take a snapshot of the score).

Exporting the Score
You use the Camera tool to export the score as an image file.
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To export the score as an image
1 Select the Camera tool.

2 Drag across the part of the score section you want to export. A selection rectangle appears
as you do this.

As soon as you release the mouse button, Logic Pro creates a PDF file (or copies the
selection to the Clipboard, depending on the Camera Tool setting you chose),
encompassing the area you dragged the Camera tool over.

Note: This function is only available in Page Score view.

Customizing the Score Editor’s Appearance
Various options are available for changing the general appearance of the Score Editor.
The different view modes can accelerate editing, or are required for particular operations.

Choosing a Color Mode
The settings in the Score Editor’s View > Colors menu determine the color mode for the
active Score Editor window. These settings have priority over all other color settings.

• Normal: Colors are assigned in accordance with the color settings in staff styles and
note attributes. As long as these settings haven’t been changed in new projects, the
result is a regular black-and-white printout, and black notes on a yellow background
onscreen.

• Show Pitch: Applies colors in accordance with note pitches. The colors of notes can be
edited in the Layout > Colors window. This window also allows you to determine
whether notes with accidentals match the color of those without accidentals, or if each
note in the chromatic scale has its own color.

• Show Velocity: Applies eight different colors, in accordance with MIDI velocity. These
colors can also be edited in the Layout > Colors window.

• Show Voice Assignment: Assigns different colors to different voices. This only makes
sense in staff styles that contain more than one voice. This mode employs the colors
of the user palette, which can also be found and edited in the Layout > Colors window.

• Force Black & White: Does exactly what the name implies. This mode is useful when
color options have been used in staff styles, or have been assigned to notes using note
attributes, but you want to print a regular black-and-white score and then return to
the colored display.

997Chapter 31 Working with Notation



Displaying Folders
If the current display level allows more than one MIDI region to be viewed simultaneously
(linked or unlinked), the View > Explode Folders setting affects how things are shown.
Unlike the other editors, the Score Editor can display (or even print) the contents of
different display (Folder) levels at once.

If the current display level contains folders, their contents are also displayed in the score.

Note: If this setting is not selected, folders appear as gray beams in Linear Score view,
and aren’t shown at all in Page Score view.

Displaying Global Tracks
Choose the View > Global tracks setting to view the global tracks in the Score Editor. You
can only choose this setting in Linear Score view. The Configure Global Tracks command
allows you to choose which global track types are shown.

Displaying Instrument Names
Choose the View > Instrument Names setting to show the names of (used) track
instruments, to the left of the score display.

Displaying Duration Bars
You can show a graphical representation of a note’s duration by displaying duration bars
in the Score Editor.

To display duration bars in the Score Editor
µ Choose View > Duration Bars, then choose one of the following display modes:

• Off: Turns off all duration bars.

• Selected Notes: Turns on duration bars for selected notes only.

Note: Duration bars for selected notes are displayed according to the Selection Color
setting in Logic Pro > Preferences > Score.

• All Notes: Turns on duration bars for all notes.

Note: You can also use the Toggle Duration Bar Display key command, which toggles
between Off and the last selected display mode.
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Changing the Length of Duration Bars
You can change the length of duration bars displayed in the Score Editor.

To change the length of duration bars
µ Place the pointer over the end point of the duration bar, then drag horizontally when

the pointer turns into the length change icon.

Displaying Guide Lines
You can show an object’s exact time position by displaying guide lines in the Score Editor
(show exactly the relation of symbols, staves, and time positions).

To display guide lines in the Score Editor
µ Choose View > Guides, then choose one of the following display modes:

• Off: Turns off guides.

• Dragged Objects: Turns on guides while dragging objects.

• Selected Objects: Turns on guides for selected objects only.

Note: Guide lines for selected notes are displayed according to the Selection Color
setting in Logic Pro > Preferences > Score.

• All Objects: Turns on guides for all objects.

Note: You can also use the Toggle Guide Lines Display key command, which toggles
between All Objects and the last selected display mode.
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Moving project data between programs and devices in your own or external studios is
commonplace these days. Unfortunately, not every application or device talks the same
language. Logic Pro is compatible with a huge number of applications and devices,
courtesy of advanced export and import features that allow you to use parts of, or entire,
projects in other applications, such as Final Cut Pro, Soundtrack Pro, and Pro Tools. Even
hardware devices, such as workstation keyboard sequencers and digital recorders, are
supported.

Logic Pro makes it easy to create a complete project archive. This simplifies transfers to
other storage media, and transport to other users or facilities—either physically or via a
network. You can also share settings information with other Logic Pro users on a local or
remote network.

This chapter covers the following:

• Sharing Logic Pro Data over a Network (p. 1002)

• Backing Up Audio Files (p. 1006)

• Backing Up and Sharing Projects (p. 1007)

• Working with Standard MIDI Files (p. 1008)

• Working with GarageBand Projects (p. 1011)

• Working with OMF Files (p. 1012)

• Working with OpenTL Files (p. 1013)

• Working with AAF Files (p. 1015)

• Working with Final Cut Pro XML Files (p. 1016)

• Working with Soundtrack Pro STAP Files (p. 1017)

• Exporting Individual Regions as Audio Files (p. 1018)

• Exporting Individual or Multiple Tracks as Audio Files (p. 1020)
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Sharing Logic Pro Data over a Network
Logic Pro allows you to share or back up your data over a network, making it easier to
collaborate on projects with other Logic Pro users. This can be:

• Via a local network—using Bonjour

• Over the Internet—using MobileMe (requires a MobileMe account)

You can share and back up the following data types:

• Plug-in settings

• Channel strip settings

• Key command sets

Note: Due to potential licensing issues with sample libraries, you cannot share EXS
instruments, Ultrabeat, or Space Designer settings.

Setting Sharing Preferences
You use the Sharing preferences to define which settings you want to share, and to back
up your data on MobileMe.

To open the Sharing preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Sharing.

µ Click the Preferences button in the Arrange toolbar, then choose Sharing from the menu.

µ Click the Action menu at the bottom of the Library and choose Sharing Preferences.
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Sharing is essentially broken down into two tasks:

• Data Access: Browse your, or other user, data on a local network or a MobileMe account.

• Data Sharing: Share your data over a local network or via a MobileMe account.

You can access data shared on a MobileMe account even when the user who provided
the data is not online.

When data is shared over a local network, the user who provided the data—or more
accurately, the computer (user account) that the shared data originated from—must be
online.

To share your data
µ Select the appropriate checkboxes in the Bonjour or MobileMe column.

• Bonjour column: All settings of the enabled type in the corresponding
~/Library/Application Support/Logic folders are shared.

• MobileMe column: All settings of the enabled type on your personal iDisk in
/Public/MusicAudioData are shared.

Note: Your MobileMe URL can be accessed through a web browser, if you want to browse
outside of Logic Pro. Typically, this address will take the following form:
http://idisk.mac.com/MOBILEMEUSERNAME/Public/MusicAudioData

To access shared data on the local network
µ Select the “Look for shared data on the local network” checkbox.

This will automatically search the local network for the ~/Library/Application Support/Logic
folders of all networked computers.

To create a backup of your personal data on your MobileMe account
µ Select the “Backup all my settings on MobileMe” checkbox.

This creates a copy of all of your settings data on MobileMe, as a personal backup solution.

Note: The sharing master can be different from the one used for backups. For example,
you may have a studio computer that is the master for backups, and also use a MacBook
to share (and edit) data while on the road.

Backup (and sharing) via MobileMe uses a simple and straightforward push/pull
concept:  data being backed up (or shared) always overwrites the data that exists on the
MobileMe account.

• When you back up to MobileMe for the first time, the computer being used becomes
the master of the MobileMe content.
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• When you try to back up/share data from another computer, a warning dialog explains
that only the master computer can “push” data. This dialog includes an option to make
the current computer the new master.

• When you deselect the “Backup all my settings on MobileMe” preference on the master
computer, all backup data is removed from MobileMe and the “master” is set as
undefined.

To restore a backup of your personal data
1 Click the Restore Backup button.

A confirmation dialog opens.

2 Click the Restore button to replace your existing settings and key commands with the
MobileMe backup.

Note: If the Restore process is interrupted for some reason (network problems), the
pre-restore data is retained, ensuring that you don’t wipe out all of your settings, or end
up with a partially restored collection. The same behavior occurs when one of the folders
on the MobileMe account is empty.

Sharing Settings Data in the Library
When you share plug-in settings or channel strip settings by selecting the appropriate
Sharing preferences checkboxes, additional indicators are displayed in the Library tab, to
the left of folder and setting file icons:

• MobileMe sharing is indicated by a blue dot.

• Bonjour sharing is indicated by a red dot.
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By default, all items of the matching data type (plug-in or channel strip settings) are
marked as shared.

To disable or enable sharing on a per setting or folder basis
µ Control-click individual settings or folders, and turn on or off the Share via MobileMe and

Share via Bonjour options as applicable.

Note: When the sharing status of a folder is turned on or off for either Bonjour or
MobileMe, all items in the folder are switched to the same state.

Settings shared by other users appear as follows in the Library:

• Bonjour folder: Shows all shared settings on the local network.

• MobileMe folder: Shows all settings of MobileMe accounts you are connected to.

To connect to a MobileMe account
1 Choose Connect to MobileMe in the Action menu of the Library.

2 Do the following in the Connect to MobileMe dialog:

• Select the MobileMe account you want to connect to.
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You have the choice of your own account (this accesses the backup folder) or another
account (which accesses the Public folder).

• Input the name of the MobileMe account.

Tip: You can access your own public MobileMe folder by choosing another account,
and typing in your own username.

3 Click OK when you are done.

Note: Data accessed through MobileMe is downloaded in an on-demand fashion, and is
only stored (on the local hard disk) if you decide to do so. This is similar to settings that
exist in a project, but are not saved as files on the hard disk.

To disconnect the active MobileMe account
µ Choose “Disconnect MobileMe accounts” in the Action menu of the Library.

This allows you to connect to another account, or to perform a local refresh or other
operation, without impacting the MobileMe data.

To refresh the Library
µ Choose Refresh Library in the Action menu of the Library.

This refreshes both the local library and the MobileMe accounts you are connected to.

Sharing Key Commands
You can access shared key command sets in the Key Commands window.

To browse for shared key command sets
µ Choose Options > Presets, then browse the MobileMe or Bonjour folder.

Backing Up Audio Files
The backup functions available in the Audio Bin and Sample Editor create a duplicate of
the selected audio file (or files) in the same storage location as the originals. Backup files
inherit the name of the source file, and are easily identified by the “.dup” file extension.

To create a backup of one or more selected files in the Audio Bin
1 Choose Audio File > Backup File(s) (or use the corresponding key command, default

assignment:  Control-B).

2 Click the Duplicate button in the dialog.

Note: Backup (duplicate) files can be directly added to the Audio Bin (or Arrange window),
just as you would with the original audio files.

To create a backup of the selected file in the Sample Editor
1 Choose Audio File > Create Backup (or use the corresponding key command, default

assignment:  Control-B).
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2 Click the Create button in the dialog.

Note: Use this feature before performing a destructive editing operation in the Sample
Editor, as it provides a “fallback” position if the audio processing produces unfavorable
results.

To restore the backed-up file in the Sample Editor
1 Choose Audio File > Revert to Backup (or use the corresponding key command, default

assignment:  Control-Option-Command-B).

2 Click the Paste button in the dialog.

Backing Up and Sharing Projects
Project folders help you to keep track of your work:  they ensure that all files related to a
project are neatly saved in one location. This makes it easy to back up your projects and
enables easy transfer between computers. This avoids problems such as missing
instruments, audio files, or samples that you need to search for, or reconstruct, in the
studio.

The File > Save as Project function allows you to save a project with all associated files.
These are collectively known as the project assets.

Selecting the Include Assets checkbox in the Save As dialog will include the file types
chosen in the Advanced Options.

The Advanced Options checkboxes determine how files imported from external locations
(locations outside the project folder) should be handled.
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They either:

• Stay where they are (if the respective “Copy” checkbox is deselected).

• Are copied into the project folder (if the “Copy” checkbox is selected).

To choose project assets
µ Select the “Copy external audio files to project folder” checkbox to create copies of these

files in your project folder.

µ Select the “Copy EXS instruments to project folder” and “Copy EXS samples to project
folder” checkboxes to do just that. If you deselect the “Copy EXS samples to project folder”
option, only EXS instrument files are copied to the project folder when saving, not the
samples associated with the EXS instrument files.

µ Select the “Copy Ultrabeat samples to project folder” and “Copy SpaceDesigner impulse
responses to project folder” checkboxes to create copies of these files in the project folder.

µ Select the “Copy movie files to project folder” checkbox if you want to copy the QuickTime
movie used in the project.

Files are only copied into the project folder when the project is saved.

Once saved, the project is “safe,” allowing you to move or copy the entire project folder
without losing any references that point to files within the folder.

To access the project asset checkboxes at any time
Do one of the following:

µ Choose File > Save As.

µ Choose File > Project Settings > Assets (or use the Open Assets Project Settings key
command).

µ Click the Settings button in the Arrange toolbar, then choose Assets from the menu.

Working with Standard MIDI Files
Standard MIDI files are not specific to a particular sequencing program, hardware
sequencer, or type of computer. They contain the following information:

• MIDI events, including time positions and channel assignments

• Names of the individual tracks

• Names and positions of markers

• Tempo changes

• Copyright marks

Logic Pro allows you to import, open, and export Standard MIDI file formats 0 and 1:

• Format 0 contains all data in one track.
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• Format 1 can contain multiple tracks, each with independent data.

Neither format recognizes any division of a track (into several MIDI regions, for example).

Importing Standard MIDI Files
An import only loads MIDI region data (notes, controller, SysEx, pitchbend, specific meta
events) into an opened project, with global data (such as tempo events, signatures, chords,
track names, SMPTE start, and so on) being ignored.

Important: To import the global data, you must open the MIDI file. See Opening Standard
MIDI Files for further details.

To import a MIDI file at the playhead position
Do one of the following:

µ Choose File > Import from the main menu bar (or use the corresponding key command,
default assignment:  Command-I), then select a MIDI file in the dialog that appears.

µ Locate and select the MIDI file in the Browser, then click the Import button.

The MIDI file is placed at the playhead position, rounded to bars.

To import a MIDI file at the mouse position
µ Drag a MIDI file from the Browser or Finder into the Arrange area.

The mouse position—when the mouse button is released—determines the position
(rounded to the nearest bar) and destination of the first track in the imported file.

Opening Standard MIDI Files
If you want to load all information contained in a MIDI file—both MIDI region and global
data—you must open it.

To open a MIDI file
1 Choose File > Open from the main menu bar (or use the corresponding key command,

default assignment:  Command-O), then select a MIDI file in the dialog that appears.

Note: If you choose the MIDI files option in the File Type pop-up menu, only MIDI files
are displayed in the dialog.

If a project is loaded, a dialog asks if you want to create a new environment or copy the
current environment for the MIDI file.

2 Do one of the following:

• Click Copy to replicate the existing environment. The tracks of the MIDI file are
automatically assigned to suitable instruments.

• Click New to load the environment of the default project template.
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The MIDI file is loaded as a new project that contains all MIDI events—inclusive of time
positions and channel assignments, names of individual tracks, names and positions of
markers, tempo changes, and copyright marks. The copyright mark is read as marker text.

Note: As a default behavior, Logic Pro automatically creates software instrument tracks
for each MIDI track, and assigns an appropriate GarageBand instrument to each, when
you open a MIDI file. If you want to use external MIDI tracks for each MIDI track, press
Option while opening the MIDI file.

Saving Standard MIDI Files
If you want to play a Logic MIDI project on another sequencer, you can do so by saving
it as a Standard MIDI file. Consult the manual of the other sequencer to determine what
Standard MIDI file formats it supports.

Due to limitations of the Standard MIDI file format (in comparison to the Logic project
format), you need to prepare your Logic project for export by following these steps:

To prepare all MIDI regions for a Standard MIDI file export
1 Select all MIDI regions by choosing Edit > Select All (or using the Select All key command,

default assignment:  Command-A).

2 Normalize all playback parameters by choosing MIDI > Region Parameters > Normalize
Region Parameters in the Arrange area (or use the Normalize key command, default
assignment:  Control-N).

3 Convert all playback quantization by choosing MIDI > Region Parameters > Apply
Quantization Settings Destructively (or use the corresponding key command, default
assignment:  Control-Q).

4 Convert all aliases into real copies by choosing MIDI > Alias > Convert to a Region Copy
(or using the Convert Alias to a Region Copy key command).

5 Convert all loops into real copies by choosing Region > Loops > Convert to Real Copies
(or using the Convert Loops to Real Copies key command, default assignment:  K).

6 Convert all MIDI regions on each track into a continuous MIDI region by choosing Region
> Merge > Regions per Tracks (or use the Merge Regions per Tracks key command).

Note: Because Standard MIDI file type 0 format files can only save one MIDI region, you
must also merge all MIDI regions into one if you want to export in file format 0. You can
do this by choosing Region > Merge > Regions.

7 Insert all instrument MIDI settings as events by choosing MIDI > Insert Instrument MIDI
settings as Events.

To save MIDI regions as a Standard MIDI file
1 Select all of the required MIDI regions.

2 Choose File > Export > Selection as MIDI File (or use the Export Selection as MIDI File key
command, default assignment:  Option-Command-E).
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3 Choose the destination directory, enter a name, then click Save. The selected MIDI regions
are saved as a Format 1 MIDI file.

Note: Remember that most hardware sequencers can only read MS-DOS formatted disks,
so limit your filename to an 8.3 character name; for example, “proj0001.MID.”

To save a MIDI region in file format 0
µ Select the “‘Export MIDI File…’ saves single MIDI Regions as Format 0” checkbox in the

Project Handling tab of the General preference pane (Logic Pro > Preferences > General).

When this preference is turned on, choosing File > Export > Selection as MIDI File when
only one MIDI region is selected automatically exports the region as file format 0 MIDI
file.

Working with GarageBand Projects
You can open a GarageBand project in Logic Pro just as you would open a Logic Pro
project. The GarageBand project translates 1:1 into Logic Pro:

• Logic Pro automatically creates the required number, and type, of tracks to mirror those
used in the GarageBand project.

• The project uses the tempo of the GarageBand project.

• The initial key signature is set in accordance with the “project key” of the GarageBand
project.

• Software instrument parts are played by GarageBand instruments in Logic Pro.
GarageBand instruments are automatically installed with Logic Pro. Any mixing data
and effects (plus their settings) used by software instruments or Apple Loops-based
tracks in GarageBand are also imported into Logic Pro.

• The Channel Strip settings of GarageBand translate 1:1 into Logic Pro—with the nice
exception that you can now access the individual plug-ins that are inserted into a
GarageBand channel strip.

• All channel strip objects are routed to Stereo Out (default stereo output pair), and
immediately play out according to the Stereo Output preference chosen in the Logic Pro
> Preferences > Audio > I/O Assignments > Output pane.

• The two bus effects of GarageBand (Reverb and Echo) are also translated when opened
in Logic Pro. They are replaced by the PlatinumVerb and Echo on busses 1 and 2.

Once the GarageBand project is loaded into Logic Pro, you can freely change parts, mixing
levels, instrument, and effect parameters as in any Logic Pro project.

Note: You cannot open Logic Pro projects in GarageBand, nor can you export a Logic Pro
project in a format that can be read by GarageBand (except as an audio file).
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Working with OMF Files
The OMF (Open Media Framework, also known as OMFI—Open Media Framework
Interchange) file format is typically used to exchange data with Digidesign Pro Tools
software. The OMF format only supports the exchange of audio data (audio media and
the use of this audio media in a project)—MIDI and automation data is ignored when
using the export functions.

Exporting OMF Files
To export the current project as an OMF file, choose File > Export > Project as OMF File
(or use the Export Project as OMF File key command).

Choose the required options in the dialog that opens:

• OMF File Version: You can choose to export the file in OMF Version 1 or Version 2 format.
You will usually choose Version 2. Version 1 is only useful for backward compatibility
with older software versions.

• Include audio: Turn this on to integrate all exported audio files into the OMF file itself.
This can result in a very large file, and can make file export times lengthy. Deselect this
checkbox to only write file references to the OMF file.

Note: If the latter option is chosen and you want to copy the OMF file to another hard
disk, you need to ensure that all referenced audio files are also copied.

• Convert interleaved to split stereo: As some applications don’t support interleaved stereo
files, Logic Pro can convert interleaved stereo files to split stereo (when exporting an
OMF file for a Pro Tools session, for example). Select this checkbox if this is the desired
behavior.

Note: This only works if the “Include audio” option is turned on.

• Convert 24 bit files to 16 bit: Select this option to convert all 24-bit files to 16 bit, using
the chosen dithering type. This might be necessary when using older versions of
Pro Tools.

• Dither Type: Choose None or any of the four dither algorithms (see Bouncing and
Dithering).
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Importing and Opening OMF Files
The following procedure is identical for both importing and opening OMF files. Importing
a file copies the OMF data into the current project, whereas opening an OMF file creates
a new project.

To import or open an OMF file
1 Do one of the following:

• Choose File > Import (or use the corresponding key command, default
assignment:  Command-I).

• Choose File > Open (or use the corresponding key command, default
assignment:  Command-O).

• Locate the OMF file in the Browser, then click the Open button.

2 Choose an OMF file from the dialog.

Tip: If you choose the OMF files option in the File Type pop-up menu, only files with the
“.TL” extension are shown.

After choosing and confirming the file import, another dialog allows you to define the
target location for audio data extracted from the OMF file.

3 Choose an existing folder (this defaults to the open project folder), or create a new one.

The OMF file is imported into the currently open project. New audio tracks are generated
for every track contained in the OMF file, and the audio parts are placed appropriately
on these tracks (as regions).

Working with OpenTL Files
The OpenTL (Open Track List) format is mainly used for data exchange with Tascam hard
disk recorders, such as the MX2424. It only supports the exchange of audio data (audio
media and the use of this audio media in a project). MIDI and automation data is ignored
when using the export functions.

Exporting OpenTL Files
The following procedure explains how to export an OpenTL file.

To export an OpenTL file
1 To export the current project’s audio in the OpenTL format, choose File > Export > Project

as OpenTL File.

2 In the dialog that opens, specify the destination folder and filename of the resulting
OpenTL file. After confirming this dialog, Logic Pro asks if you want to create a dedicated
folder for the OpenTL export.
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3 Click Create to have all exported files placed in one folder, which is named after the
exported file. This is the convention used by the Tascam MX recorders, so it is
recommended.

4 Next, Logic Pro asks if the project’s SMPTE start time should be added to event start
positions. In this scenario, audio parts in the resulting OpenTL file will have the same
SMPTE start time as in the Logic project. If you click Don’t Add, the part positions are
calculated relative to the project start position (an audio part that starts at bar 1 will have
a start time of 00:00:00:00.00).

5 Next, Logic Pro asks if a copy of all audio files should be made. You should choose Make
Copy if you want to copy the resulting OpenTL file, including all audio data, to another
hard disk.

Logic Pro then creates two sub-folders in the folder that contains the OpenTL file:  Audio
Files and Track Files (which is the suggested structure for OpenTL exports). The Audio
Files folder contains copies of all exported audio files. If you choose Don’t Copy, the file
references in the OpenTL file points to the original audio files.

Opening and Importing OpenTL Files
The following procedure is identical for both importing and opening OpenTL files.
Importing a file copies the OpenTL data into the current project, whereas opening an
OpenTL file creates a new project.

To import or open an OpenTL file
1 Do one of the following:

• Choose File > Import (or use the corresponding key command, default
assignment:  Command-I).

• Choose File > Open (or use the corresponding key command, default
assignment:  Command-O).

• Locate the Open TL file in the Browser, then click the Open button.

2 Choose OpenTL files from the dialog. Note that if you choose the OpenTL files option in
the File Type pop-up menu, only files with the “.TL” extension are shown.

3 Depending on where the first event in the imported project starts, one of the following
dialogs appears:

• If the first event in the imported project starts at a time greater than one hour:

Set SMPTE start time of project so that events start at the same SMPTE time as they do in
the imported project?

Choose Set if you want the SMPTE start time of the project to be changed accordingly,
or click Don’t Set if you don’t want to change the SMPTE start time of the project.

• If the first audio part found by the OpenTL import has a start time greater than zero
(less than zero is impossible), but less than one hour:
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Set the start time of first imported event to start of project?

If you choose Set, the first audio part imported is placed precisely at the project start
position.

This solves the problem of the project on the Tascam machine starting at a large time
value, but less than one hour (such as 59 minutes). In this situation, you can’t immediately
see the imported audio parts because they may be imported beyond the project’s end
point, and almost certainly outside the visible window area.

Working with AAF Files
AAF (Advanced Authoring Format) is used by other DAW applications such as Pro Tools.
You can use it to import multiple audio tracks, inclusive of references to tracks, time
positions, and volume automation.

To export the current project as an AAF file
1 Choose File > Export > Project as AAF File (or use the Export Project as AAF File key

command).

2 In the Save AAF File As dialog, choose the following pop-up menu options:

• Sample Rate: Choose 44.1 kHz, 48 kHz, 88.2 kHz, or 96 kHz.

• Bit Depth: Choose either 16 or 24 bit.

• File Format: Choose WAVE or AIFF.

• Dither Type: Choose None or any of the four dither algorithms (see Bouncing and
Dithering).

3 Choose a location, enter a name for the file, then click OK.

The export includes all used regions, inclusive of track and position references, and volume
automation.
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To import an AAF file
Do one of the following:

µ Choose File > Import (or use the corresponding key command), then choose the AAF file
in the Import dialog.

µ Locate the AAF file in the Browser, then click the Open button.

To open an AAF file
1 Choose File > Open.

2 Choose the AAF file in the Open dialog.

Working with Final Cut Pro XML Files
The Final Cut Pro XML format is used to import and export audio data between
Final Cut Pro and Logic Pro. The Final Cut Pro XML format supports automation data.

To export the current project as a Final Cut Pro/XML file
µ Choose File > Export > Project to Final Cut Pro/XML.

A standard dialog opens, allowing you to name the export file.

Note: Audio Instrument tracks are always bounced to audio files. MIDI tracks are ignored.
Bouncing will automatically switch to real-time mode, if necessary (such as when an I/O
or External Instrument plug-in is used).

To import Final Cut Pro XML files
Do one of the following:

µ Choose File > Import, then choose the file in the Import dialog.

µ Locate and select the file in the Browser, then click the Open button.

The XML import procedure allows you to change or retain the sample rate of audio files
used in your Final Cut Pro sequences. If you import sequences that use audio files with
different sample rates, you are given the following options:

• To alter the sample rate of your Logic Pro project to match all imported Final Cut Pro
sequence audio files.

• To retain the sample rate of your Logic Pro project. All Final Cut Pro sequence audio
files that use a sample rate that differs from the selected one are converted.

Note: A Final Cut Pro sequence is an arrangement of video, audio, and graphics clips, edit
information, and effects. When combined, they create a movie. Use of XML to import
Final Cut Pro sequences into Logic Pro allows you to exchange multiple audio tracks, with
all positional region information, region names, and volume and pan automation data,
retained.
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Working with Soundtrack Pro STAP Files
Soundtrack Pro can be used as an alternative to the internal Sample Editor of Logic Pro.

To edit audio files in Soundtrack Pro
1 Open Audio Preferences by doing one of the following:

• Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Audio from the pop-up
menu.

2 Click the Sample Editor tab, click the Set button below the External Sample Editor section,
then choose Soundtrack Pro.

3 Select an audio file in the Arrange area, then Choose Options > Audio > Open in
Soundtrack Pro (or use the corresponding key command, default assignment:  Shift-W).
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The audio file is opened as a new audio file project in Soundtrack Pro. The new audio file
project is automatically named after the original audio file, with the file extension .stap.

4 Edit the audio file in Soundtrack Pro.

Note: Do not flatten the file.

5 Save the file to your chosen location, specified in the Save dialog.

Soundtrack Pro saves both an STAP file and a flattened version of the file in the original
location.

6 Switch back to Logic Pro.

Logic Pro notices that the flattened file has changed and updates accordingly.

For any future editing to this audio file in Soundtrack Pro, Soundtrack Pro opens the STAP
project instead of the flattened audio file.

Exporting Individual Regions as Audio Files
You can export an audio or MIDI region as a new audio file.

Note: Rendering with no volume and pan automation is generally desirable, as the export
functions are most commonly used to transfer your tracks or regions to an external
application for processing, mixing, or editing.

To export an audio or MIDI region as an audio file
1 Click a region in the Arrange area.

2 Choose File > Export > Region as Audio File.
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3 Define the following parameters, as required.

• Save As: Enter a name for the new audio file.

• File selector: Browse to, and choose the target folder for the new audio file.

• New Folder: Click this button to create a new folder.

• Hide Extension: Select this checkbox to hide file extensions—.wav, .aif, and so on.

• Save Format: Choose a file format for the new audio file—SDII, AIFF, or WAVE.

• Bit Depth: Define the bit depth for the new audio file—8 Bit, 16 Bit, 24 Bit, or 32 Bit
(float).

• Multi-Output Software Instruments: Choose between the following two options (only
available for regions on software instrument tracks that have multi-output software
instruments inserted).

• One File per Track: Mixes the multi-output signals with the main output into one
bounce file, for each multi-output software instrument track. In situations where
multiple arrange tracks use the same multi-output software instrument channel strip,
one file is created for each arrange track.
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• One File per Channel Strip: Creates additional bounce files for each aux channel strip
that has a multi-output of the selected track’s multi output software instrument as
Input source.

• Bypass Effect Plug-ins: Select this checkbox to disable all plug-ins on the source track.

• Include Audio Tail: Select this checkbox to extend the length of the created file to include
any instrument release and potential effect tail (reverb, delay, and so on).

• Include Volume/Pan Automation: Select this checkbox to have volume and pan
automation performed on export, with their result influencing the created file. Otherwise,
the volume and pan automation is simply copied, but not performed.

Note: Rendering with no volume and pan automation is generally desirable, as the
export functions are most commonly used to transfer your tracks or regions to an
external application for processing, mixing, or editing.

• Normalize: Choose between three states of normalization.

• Off: Turns off normalization.

• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

• Add resulting files to Audio Bin: Select this checkbox to add the created file to the Audio
Bin.

4 Click the Save button.

Exporting Individual or Multiple Tracks as Audio Files
You can export all audio or MIDI regions on a track as a new audio file, or you can export
all audio or MIDI regions on multiple tracks as new audio files—one for each track.

To export all audio or MIDI regions on a track to a new audio file
1 Click a track in the Arrange area.

2 Choose File > Export > Track as Audio File.
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3 Define the following parameters, as required.

• Save As: Enter a name for the new audio file.

• File selector: Browse to, and choose the target folder for the new audio file.

• New Folder: Click this button to create a new folder.

• Hide Extension: Select this checkbox to hide file extensions—.wav, .aif, and so on.

• Save Format: Choose a file format for the new audio file—SDII, AIFF, or WAVE.

• Bit Depth: Define the bit depth for the new audio file—8 Bit, 16 Bit, 24 Bit, or 32 Bit
(float).

• Multi-Output Software Instruments: Choose between the following two options (only
available for regions on software instrument tracks that have multi-output software
instruments inserted).

• One File per Track: Mixes the multi-output signals with the main output into one
bounce file, for each multi-output software instrument track. In situations where
multiple arrange tracks use the same multi-output software instrument channel strip,
one file is created for each arrange track.
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• One File per Channel Strip: Creates additional bounce files for each aux channel strip
that has a multi-output of the selected track’s multi output software instrument as
Input source.

• Bypass Effect Plug-ins: Select this checkbox to disable all plug-ins on the source track.

• Include Audio Tail: Select this checkbox to extend the length of the created file to include
any instrument release and potential effect tail (reverb, delay, and so on).

• Include Volume/Pan Automation: Select this checkbox to have volume and pan
automation performed on export, with their result influencing the created file. Otherwise,
the volume and pan automation is simply copied, but not performed.

Note: Rendering with no volume and pan automation is generally desirable, as the
export functions are most commonly used to transfer your tracks or regions to an
external application for processing, mixing, or editing.

• Normalize: Choose between three states of normalization.

• Off: Turns off normalization.

• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

• Add resulting files to Audio Bin: Select this checkbox to add the created file to the Audio
Bin.

4 Click the Save button.

To export all audio or software instrument tracks to several new audio files
1 Choose File > Export > All Tracks as Audio Files.

Note: No track selection is required.
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2 Define the following parameters, as required.

• Save As: Enter a name for the new audio file.

• File selector: Browse to and choose the target folder for the new audio file.

• New Folder: Click this button to create a new folder.

• Hide Extension: Select this checkbox to hide file extensions—.wav, .aif, and so on.

• Save Format: Choose a file format for the new audio file—SDII, AIFF, or WAVE.

• Bit Depth: Define the bit depth for the new audio file—8 Bit, 16 Bit, 24 Bit, or 32 Bit
(float).

• Multi-Output Software Instruments: Choose between the following two options (only
available for regions on software instrument tracks that have multi-output software
instruments inserted).

• One File per Track: Mixes the multi-output signals with the main output into one
bounce file, for each multi-output software instrument track. In situations where
multiple arrange tracks use the same multi-output software instrument channel strip,
one file is created for each arrange track.
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• One File per Channel Strip: Creates additional bounce files for each aux channel strip
that has a multi-output of the selected track’s multi-output software instrument as
Input source.

• Bypass Effect Plug-ins: Select this checkbox to disable all plug-ins on the source track.

• Include Audio Tail: Select this checkbox to extend the length of the created file to include
any instrument release and potential effect tail (reverb, delay, and so on).

• Include Volume/Pan Automation: Select this checkbox to have volume and pan
automation performed on export, with their result influencing the created file. Otherwise,
the volume and pan automation is simply copied, but not performed.

Note: Rendering with no volume and pan automation is generally desirable, as the
export functions are most commonly used to transfer your tracks or regions to an
external application for processing, mixing, or editing.

• Normalize: Choose between three states of normalization.

• Off: Turns off normalization.

• Overload Protection Only: Allows downward normalization in case of overloads—levels
above 0 dB, which would lead to clipping—but no normalization in case of lower
levels.

• On: Allows full bidirectional normalization.

• Add resulting files to Audio Bin: Select this checkbox to add the created file to the Audio
Bin.

3 Click the Save button.
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Logic Pro provides several different tools and methods for creating and editing tempo
events. Tempo can be changed or edited in the Transport bar, the global Tempo track,
the Tempo List (in the Lists area), with a tempo fader in the Environment, or with the
Tempo Operations window. In most cases, the global Tempo track or Tempo List will be
your first port of call. This chapter discusses these tools, and describes the relationship
between tempo events and MIDI and audio regions.

This chapter covers the following:

• Using the Tempo Display in the Transport Bar (p. 1025)

• Using the Tempo Track (p. 1026)

• Recording Tempo Changes in Logic Pro (p. 1031)

• Adjusting the Tempo to Fit Audio Regions (p. 1031)

• Using the Tempo List (p. 1032)

• Using the Tempo Operations Window (p. 1035)

• Using the Tempo Interpreter Window (p. 1037)

• Using the Tempo Fader (p. 1040)

Using the Tempo Display in the Transport Bar
The current tempo (at the playhead position) is always displayed on the Transport bar,
even if you’re using programmed tempo changes or external synchronization.

Tempo display

To set a constant project tempo
Do one of the following:

µ Drag the Tempo display vertically.

µ Double-click the Tempo display, type in a new value, then press Return.
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To change the format of the tempo display
1 Open Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
pop-up menu.

2 Choose an option from the Display Tempo As pop-up menu in the General pane.

Using the Tempo Track
Tempo changes are controlled by tempo events, which are stored in a special Tempo
track. This track can be displayed in the Arrange window, Piano Roll Editor, Hyper Editor,
and Score Editor. The Tempo track applies to the whole project. The tempo track also
determines the relationship between incoming time code and the current playhead
position.

To view the Tempo track
Do one of the following:

µ Choose View > Global Tracks (or use the corresponding key command, default
assignment:  G).

µ Click the disclosure triangle to the left of the Bar ruler in any of the linear editing windows.

Note: By default, the global Marker, Signature, and Tempo tracks are visible when you
use any of the methods above to open the global tracks lanes. If the Tempo track is not
visible, you can configure the global track display to fit your needs. For further details,
see Displaying Global Tracks.
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The Tempo track displays tempo changes as nodes:  dots connected by lines. By default,
these dots are followed by horizontal lines that continue to the next node, which is aligned
with a project position (shown in the Bar ruler). At this point, a vertical line is connected
to the node of the ensuing tempo change. This creates a series of hills and valleys that
represent the project tempo.

Note: The tempo is indicated numerically (in bpm) alongside each node, if the vertical
height of the Tempo track is adequate.

Creating and Deleting Events in the Tempo Track
You can create tempo change events by inserting them into the Tempo track at the
desired project position.

To insert a tempo change event
Do one of the following:

µ Double-click at the desired position with the Pointer tool.

µ Click at the desired position with the Pencil tool.

Keep an eye on the help tag when using the Pencil tool, and don’t release the mouse
button until the intended tempo and position are indicated. No help tag appears when
double-clicking with the Pointer tool.

µ Hold Control-Option-Command and click at the desired position in the Tempo track.

A text field opens, allowing you to type a bpm value. Press Return, and a tempo event of
this value is created.

To delete a tempo change event
Do one of the following:

µ Select it, by either clicking the node itself or the line to the right, then choose Edit >
Delete (or press the Delete key).

µ Double-click the node with the Pointer tool.

µ Click the node with the Eraser tool.
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Creating Tempo Curves in the Tempo Track
To create a continuous transition between two tempi, click-hold and drag the tip of the
right angle line (the corner) above or below the second node.

A curve or diagonal line results (a Move Curve Node help tag is shown), which can be
dragged—horizontally or vertically—to alter the curve shape. You’ll find that this is quite
similar to drawing track automation curves with the mouse.

To make a tempo curve more, or less, precise
µ Choose a value from the Resolution pop-up menu in the Tempo track to define the

number of tempo changes that are actually performed when using curves.

When set to 1/16, there are four tempo changes per quarter note; 1/1 only generates one
tempo change per bar, which will result in a coarser transition. A different resolution can
be defined for each node.

To delete a tempo curve
µ Click the handling node (at the tip of the right angle) with the Eraser tool, or double-click

it with the Pointer tool.

Moving, Altering, and Copying Events in the Tempo Track
To move a tempo change event, grab the node (or the line to the right) and drag it left
or right.

To make finer tempo change movements
µ Hold Shift while dragging a node left or right.

To move the selected tempo change event to the current playhead position
µ Use the Pickup Clock (Move Event to Playhead Position) key command.

To move the selected tempo change event, replacing the previous one
µ Control-click (or right-click) a node, then choose Extend Left from the shortcut menu.

This moves the selected tempo event left to the position of the previous tempo event,
which is replaced by the moved one.

Note: This menu item is dimmed for the first tempo event.

To change the value of a tempo change event
µ Drag the node (or line) vertically. A help tag displays the tempo value.
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The display range (the scale shown to the left) of the tempo track is automatically adjusted
when you choose a value that exceeds the current minimum or maximum value.

Note: To prevent unintentional changes, nodes are restricted to either vertical or horizontal
movement for each operation. Put another way, you can either change the value of a
tempo change event or the position of a tempo change event, but not both at once.

To create a constant tempo across multiple tempo events
µ Control-click (or right-click) a Tempo track selection (containing multiple tempo events),

then choose Replace By Average from the shortcut menu.

To copy a tempo change event
Do one of the following:

µ Hold Option while dragging a node.

µ Use the standard Copy and Paste procedure (via the Edit menu or the corresponding key
command). The playhead determines the target position for the first pasted event.

To copy or move multiple tempo change events
µ Shift-click or drag to select (while pressing Control), and drag all nodes to the target

position.

Note: Any tempo change events at the target positions are replaced by the moved or
copied events.

Adjusting the Display Range in the Tempo Track
The display range for tempo events is adjusted automatically. Dragging a node beyond
the current maximum or minimum scale boundaries results in an automatic adjustment
of the range.

To manually define the maximum and minimum ranges of the tempo display
Do one of the following:

µ Grab the maximum and minimum values in the tempo scale and drag them vertically.
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µ Double-click either range value and type a numerical value into the text field.

These user-defined values are displayed in yellow. If you want to return to the automatic
scaling mode, use the procedure described above, and leave the text fields empty.

Switching Between Tempo Alternatives in the Tempo Track
The Alternative pop-up menu in the Tempo track allows you to switch between different
tempo maps. Put another way, you can create up to nine different tempo track versions
per project, and switch between them.

The original tempo track is automatically assigned to Alternative 1.

To create an alternate tempo map
µ Choose an unused number (2 through 9), and create the tempo events.

This will be a blank tempo map, that contains one tempo event at the beginning of the
project.

To copy all tempo events from one tempo alternative to another
µ Hold Option, and choose the target tempo alternative from the pop-up menu.

This creates a replica tempo map, which can be adjusted slightly, allowing you to
experiment with small tempo variations, while retaining a fallback map.

Relationship Between Tempo and Beat Mapping Tracks
Actions performed in the Beat Mapping track result in changes to the Tempo track. These
include alterations to existing tempo change events, or the creation of new, tempo change
events.
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Given this behavior, you should avoid making changes in the Tempo track after using
Beat Mapping functions. If you do so, the timing derived from the Beat Mapping functions
will be destroyed. For more information about the Beat Mapping track, see Beat Mapping
Regions.

Recording Tempo Changes in Logic Pro
All tempo changes made when Logic Pro is in record mode are automatically stored as
tempo events on the Tempo track. These events can be created with external MIDI
controllers, the Environment tempo fader, or external synchronization signals. You can
edit recorded tempo events in the Tempo track or using one of the tempo editors—Tempo
List, Tempo Operations window, Tempo Interpreter window, or Tempo fader.

To enable tempo change recording
1 Open the Recording project settings by doing one of the following:

• Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default assignment:  Option-*).

• Click the Settings button in the Arrange toolbar, and choose Recording from the pop-up
menu.

• Control-click (or right-click) the Record button in the Transport bar, and choose
Recording Settings from the pop-up menu.

2 Select the “Allow tempo change recording” checkbox.

Adjusting the Tempo to Fit Audio Regions
The Options > Tempo > Adjust Tempo using Region Length and Locators command
adjusts the project tempo by creating a tempo change event at the start point of the
selected audio region. This ensures that the length of the selected audio region matches
exactly the distance between the locators.

For more information on this function, see Setting the Project Tempo to Match an Audio
Region.
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Using the Tempo List
The Tempo List displays all tempo events in your project. You can open the Tempo List
as a tab in the Arrange window, or as an independent window.

To open the Tempo List as a tab in the Arrange window
µ Click the Lists button at the top-right corner of the Arrange toolbar, and click the Tempo

tab (or use the Toggle Tempo List key command, default assignment:  T).

To open the Tempo List as a separate window
Do one of the following:

µ Choose Options > Tempo > Open Tempo List (or use the corresponding key command).
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µ Drag the Tempo tab, which changes to the Tempo List window as you drag it.

Creating and Editing Events in the Tempo List
The layout and use of the Tempo List are very similar to those of the Event List. The
following section only outlines the most important Tempo List operations. For more
information on general (and identical) Event List operations, see Editing MIDI Events in
the Event List.

To create a tempo event in the Tempo List
1 Move the playhead to the desired project position.

2 Click the Create button, or click below the bottom tempo event with the Pencil tool.

A tempo event (which uses the current project tempo value) appears. You can alter the
value in the Tempo column.

To delete a tempo event in the Tempo List
Do one of the following:

µ Click the tempo event with the Eraser tool.

µ Select the tempo event, and choose Edit > Delete (or press Delete).

To change the position of a tempo change event
µ Use the mouse as a slider, or double-click and directly enter values in the Position or

SMPTE column.

To move any selected tempo event to the current playhead position
µ Use the Pickup Clock (Move Event to Playhead Position) key command.
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To copy tempo changes from a passage
1 Set the locators to the passage containing the correct tempo change.

2 Choose Edit > Select Inside Locators.

Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.

3 Copy the tempo events to the Clipboard (default key command assignment:  Command-C).

4 Deselect all tempo events (by clicking the background).

5 Paste the tempo events from the Clipboard (default key command
assignment:  Command-V).

6 The paste position defaults to the current playhead position, but this can be changed. A
position input box appears alongside the first of the pasted tempo events, allowing you
to alter the bar position. If the first tempo change is not at the start of the bar in the
passage, be sure to alter the bar number, and leave the beat, sub beat, and frame or tick
values unaltered.

7 Press Return.

The copied tempo changes are selected, and you can undo the operation if necessary.

Displaying Additional Tempo Information in the Tempo List
Creating a tempo curve can lead to the creation of numerous tempo change events.
These tempo change events can be viewed in the Tempo List.

To display additional events in the Tempo List
µ Click the Additional Info button.

All tempo events, including those located on the tempo curve are displayed in the Tempo
List.

Using the Shortcut Menu in the Tempo List
Many selection, editing, and other commands can be accessed by Control-clicking (or
right-clicking) anywhere in the Tempo List. Use this technique to accelerate your workflow.

Note: Control-click (or right-click) functionality is dependent on the Right Mouse
Button:  Opens Shortcut Menu option being chosen in the Logic Pro > Preferences >
General > Editing pane.

Switching Between Tempo Alternatives in the Tempo List
You can use up to nine different Tempo List variations per project. This is useful in projects
with tempo changes, as it allows you to:

• Temporarily slow down the tempo when recording MIDI regions

• Temporarily disable tempo changes
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• Try out different tempo variations

To switch between the different Tempo Lists
Do one of the following:

µ Choose Options > Tempo Alternatives, and choose a Tempo List.

µ Choose a Tempo List from the Alternative pop-up menu.

Using the Tempo Operations Window
The Tempo Operations window is used to edit existing tempo changes, and to create
new ones. The window automatically displays the area you’ve selected for editing, and
changes are displayed graphically, in real time, as the tempo curve is processed, so you
can see what’s happening.

To open the Tempo Operations window
Do one of the following:

µ Choose Options > Tempo > Tempo Operations from the main menu bar (or use the Open
Tempo Operations key command.

µ Control-click the Sync button in the Transport bar (if visible), and choose Open Tempo
Operations from the shortcut menu.
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Creating Tempo Curves in the Tempo Operations Window
The Create Tempo Curve operation lets you create numerous tempo change events with
just a few parameters, and provides a smooth overall change in tempo.

To create a tempo change in the Tempo Operations window
1 Use the Position or Time field to define the area that the tempo change should take place

across:  the left field sets the curve start point and the right field, the curve end point.

2 Enter start and end tempos in the Tempo line.

3 Select a curve type.

Three kinds of tempo curves are available from the Curve Type pop-up menu. Each of
these offers a Curvature parameter (the field to the right of the Curve Type pop-up menu),
which determines if the tempo should speed up or slow down, depending on whether
positive or negative curvature values are entered.

4 Adjust the Curvature parameter.

5 Alter the concentration of graphical tempo events with the Density parameter.

Values of 1/8 and finer should only be used if really necessary (with very slow or fast
tempo changes, for example). Don’t select a resolution higher than 1/8 or finer, just to
make the curve look smoother. This results in an unnecessary amount of processing, and
the creation of more tempo events than are needed.

As you change the values, the displayed tempo curve (which is calculated from the tempo
settings you’ve made) is shown in red.

Note: The “Continue with new Tempo” checkbox determines whether the original tempo
resumes after the tempo curve ends (unselected), or the new tempo (the last tempo
change event in the curve) is maintained (selected).

6 Click Apply when you are done.

Creating Constant Tempo in the Tempo Operations Window
The Create Constant Tempo operation creates a constant tempo in any selected area.
The default setting assigns an average tempo for the selected project section (based on
existing tempo change events).

If you want to remove all tempo variations between two points, without changing the
SMPTE time for the rightmost position, click the Apply button.

Don’t forget the “Continue with new Tempo” checkbox, which retains the new tempo or
returns to the initial tempo.
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Scaling Tempo Changes in the Tempo Operations Window
The Scale Existing Tempo operation alters existing tempo changes proportionally (scales
them). This allows you to speed up an entire project section, without losing the
relationships between any subsequent tempo changes within the area. Scaling is done
by percentage. Positive percentage values speed up sections, and negative ones slow
them down.

Stretching Tempo Curves in the Tempo Operations Window
The Stretch Existing Tempo Curve operation stretches or compresses an existing tempo
curve. The Position or Time parameter is used to define the start point of the area that
you want to change. You can then enter either the new end point of the tempo curve as
a bar position or SMPTE value, or set a Stretch value for the curve (as a percentage).

Reducing Tempo Changes in the Tempo Operations Window
The Position or Time field defines the start and end points of the area to be processed.
Density determines the number of tempo events that remain per bar after processing.
You can select values between one tempo change event per bar (1/1) and 32 per bar
(1/32).

Randomizing Tempo in the Tempo Operations Window
Use the Position or Time parameter to define the start and end points of the area to be
processed. Use Randomize to determine the amount of deviation from the current tempo,
in beats per minute (bpm).

Density defines how often the new tempo events occur. You can select values between
one per bar (1/1), and 32 times per bar (1/32).

Using the Tempo Interpreter Window
You can use the computer keyboard or incoming MIDI events to set the project tempo.
Put another way, Logic Pro will chase a manual synchronization signal (also known as
human sync). This method of synchronization is fairly loose, in that if the manual sync
impulses stop coming in, Logic Pro continues at the last tempo it received.

You use the Tap Tempo command to generate tempo timing events, by literally tapping
a computer or MIDI keyboard key.

To enter manual synchronization mode
Do one of the following:

µ Choose Manual in the Sync Mode pop-up menu of the File > Project Settings >
Synchronization > General pane.

µ Select the “Auto enable external sync” checkbox (on by default) in the Project Settings >
Synchronization > General pane.
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If Logic Pro “hears” a Tap Tempo command, it automatically follows this tempo.

The parameters that control how Logic Pro responds to tap tempo commands can be
found in the Tempo Interpreter window.

To open the Tempo Interpreter window
Do one of the following:

µ Choose Options > Tempo > Tempo Interpreter (or use the Open Tempo Interpreter key
command).

µ Control-click the Sync button in the Transport bar (if visible), and choose Open Tempo
Interpreter from the shortcut menu.

Note: Only the selected software instrument track, and all external MIDI tracks, can play
when the Tempo Interpreter window is open.

The following parameters are in the Tempo Interpreter window.

• Tap Step: This parameter sets the note value that Logic Pro assigns to manual taps. You
will achieve the best results with larger, rather than smaller, values. 1/4 note usually
works well.

• Window: This parameter determines the time span (or window) that tap notes can be
entered (set in ticks, or 1/3840 note). Only taps made within this time window are used
to determine the tempo. Any taps outside it are ignored.

• The narrower the window, the more effectively Logic Pro is able to withstand the
influence (on the tempo) of any taps that fall between the note values—set with the
Tap Step parameter.

• The larger the window is set, the easier it becomes to create drastic tempo changes.

• If you set the window parameter to 0, the tap window disappears altogether, and
all taps are accepted as tempo-determining information. Logic Pro also comes to a
halt, if taps are not generated.
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• Tempo Response: This parameter sets the sensitivity to tempo changes:  the larger the
value, the greater the sensitivity. You should set this value to 4, for most situations. If
you find that your tap timing is imprecise, but want Logic Pro to play at a relatively
constant tempo, reduce this value to 2 or so.

• Max. Tempo Change: Use this parameter to set the maximum tempo change possible
per tap (in bpm). To obtain the most regular, or even tempo curve, follow this rule:  set
the smallest possible value (in other words, only as large as necessary).

• Tap Count-In: This sets the number of taps used as a count-in. Logic Pro starts following
the tempo on the first tap after the count-in taps.

• Smoothing: Turning on this function smooths out jumps in tempo, resulting from
incoming taps (which could prove useful when using Logic Pro live). You should turn
it off if you want Logic Pro to follow your taps precisely and quickly.

• Tempo Recording: The Tempo Recording function creates a tempo list that follows your
taps, when in record mode. This Option should normally be turned off.

• Pre and Post: These are the ways your tap signals are displayed:

• Pre: Displays every incoming tap.

• Post: Displays every accepted tap that occurs within the time window (as defined by
the Window parameter), or close to, or on, a tap step.

The Pre/Post tap signals flash yellow if the taps are within the allowed range, and red
if they are out of range.
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Using the Tempo Fader
You can create a real-time tempo fader in the Environment window by choosing New >
Fader > Specials > Tempo Control. This fader can control the project tempo (using Meta
event #100). There is no need to connect this fader to anything, unless you want to record
its output.

A tempo fader has a range of possible values from 50 to 177 bpm. External MIDI data can
be used to control it, with an input value of 0 resulting in a tempo of 50, and an input
value of 127, resulting in a tempo of 177.

If you place a tempo fader between the Physical Input and Sequencer Input objects in
the Environment, you will be able to:

• Record tempo changes

• Control the tempo with any desired MIDI event types

This way, new Tempo track data can be recorded intelligently. The original tempo data
is only erased in areas that actually contain tempo changes.

If a tempo fader is moved during playback or recording, all data defined in the Tempo
List is turned off, until Logic Pro is stopped.

Movements of a tempo fader are ignored when external SMPTE sync is active. A tempo
fader can therefore be used to deactivate the sync reference during playback or recording,
if you wish.

Note: The tempo fader’s Parameter box displays pitch bend events as the Input definition
(by default). This allows control of the project tempo with your keyboard’s pitch bend
wheel.
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You will generally play to a metronome click when recording in Logic Pro. There are,
however, instances when you’ll want to record without a click, playing rubato, or at least
not at a strict same tempo throughout. Another situation may be when you have an
existing audio recording—that wasn’t recorded to a metronome click, and therefore
contains slight tempo variations—that you want to add additional tracks to. In this
scenario, the Beat Mapping track helps to make the display of these free recordings
rhythmically meaningful. It does this by defining the bar positions of existing musical
events, without changing their absolute time position, thereby preserving the audible
result with its original timing.

Note: Musical events, in this context, refer to MIDI notes in MIDI regions or transients in
audio regions—which correspond to the beginning of strongly accented notes.

This chapter covers the following:

• Understanding the Concept of Beat Mapping (p. 1041)

• Beat Mapping MIDI Regions (p. 1042)

• Beat Mapping Audio Regions (p. 1044)

• Automatic Beat Mapping of Regions (p. 1045)

• Beat Mapping to Scene Markers (p. 1047)

• Beat Mapping to Markers (p. 1047)

Understanding the Concept of Beat Mapping
Beat mapping involves two steps:  first, you graphically connect musical events to the
appropriate bar positions in the Beat Mapping track, by drawing lines between them with
the mouse. Logic Pro will automatically insert a tempo change event for each of these
bar position locations. This results in the note/event being played at its previous absolute
time position, despite its altered bar position. A beat mapped Logic Pro project will contain
the same tempo variations as the original recording.
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Assuming accurate beat mapping, everything will be in time with the metronome tempo,
affording you a number of advantages for further project development:

• The metronome click can be used when recording additional regions.

• Quantize functions can be applied to newly recorded regions.

• Loops (both MIDI and Apple Loops) will automatically adjust to the tempo when used
in the arrangement.

• MIDI regions recorded without a click will be displayed in a musically meaningful way
in the Score Editor.

• Additional MIDI regions can also be created via the Step Input function, without
sounding too stiff. This looser feel is due to the parts being played back with all of the
tempo changes created by the beat mapping process.

By default, the global Marker, Signature, and Tempo tracks are visible when you enable
the display of global tracks. If the Beat Mapping track is not displayed, choose View >
Configure Global Tracks, and select the Beat Mapping checkbox. For detailed instructions,
see Hiding or Showing Global Tracks.

Beat Mapping MIDI Regions
The following section takes a look at the beat mapping procedure in the Arrange window.
Beat mapping is also possible in the Piano Roll Editor, Score Editor, and Hyper Editor,
where you have the added advantage of directly seeing the corresponding notes. To use
(or test) beat mapping, you’ll need at least one MIDI region that doesn’t fit the current
tempo. You can simply record one without a metronome click, if none are available.

In the upper part of the Beat Mapping track, you can see a ruler which contains a graphical
representation of musical bars, beats, and subdivisions. These reflect the division value
set in the Transport bar (and are also dependent on the current zoom level).

To allocate note events to particular bar positions
1 Select the regions that you want to use for beat mapping.
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Once selected, short horizontal lines appear at the lower edge of the Beat Mapping track.
These represent the notes in the selected regions.

2 Starting from the left, click-hold the first bar position in the Bar ruler that you want to
assign to a MIDI note.

A yellow vertical line appears.

3 With the mouse button still held, drag the cursor down toward the line that represents
the chosen note.

A second, slightly darker, yellow line—which is still connected to the same position in
the Bar ruler—appears. This line follows the movement of the mouse cursor into the
lower part of the track, forming an angle. Once this line is connected to the desired note,
release the mouse button.

Logic Pro automatically calculates, and inserts, a tempo change, which can be seen in
the Tempo track. This ensures that the allocated note (and all other notes) will be played
back at the same absolute time position as before, despite their altered bar positions.

4 Move from left to right, adjusting further events along the time axis, to obtain the best
beat mapping results.

If you make a mistake, you can erase any beat allocation by double-clicking it, using the
Eraser tool, or by selecting it and pressing the Delete key. Take care when using the Delete
key, to avoid the accidental deletion of other currently selected events or regions. To
erase all beat allocations, click anywhere in the track header of the Beat Mapping track
(except on the buttons and menus). This selects all data in the track, allowing you to press
the Delete key to delete all events.

Note: If you want to draw a connecting line from a bar position to a particular position
in the original recording—where no note exists—hold down Control while drawing the
connecting line with the mouse. This will allow the line to snap to any subdivision.
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Beat Mapping Audio Regions
Beat mapping audio regions works in a similar fashion as it does for MIDI regions. The
main difference is that Logic Pro must first analyze audio regions in order to find
rhythmically prominent spots, which can subsequently be linked to a bar position.
Logic Pro searches for transients when analyzing audio regions. Transients are positions
where the audio recording becomes a lot louder—over a very short time span (a signal
spike, in other words). This is typical of drum recordings, but the analysis of other
instruments or complete mixes (depending on the musical context), can also produce
usable results.

To detect transients in audio regions
Do one of the following:

µ Select the regions that you want to analyze, and click the Detect button in the track
header of the Beat Mapping track.

µ Drag the regions onto the Beat Mapping track.

Following analysis, the transients are displayed as small vertical lines at the bottom of
the Beat Mapping track.

Tip: It can sometimes be difficult to identify transients, due to the waveform overview
being too small. In this situation, you should use the Waveform Zoom button, found to
the left of the horizontal zoom control in the Arrange area. This allows you to visually
resize the waveform in the Beat Mapping track.

The remaining steps of the beat mapping procedure are as described for MIDI regions.
For details, see Beat Mapping MIDI Regions.
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There are a number of ways to improve the beat mapping accuracy of audio regions.
When you click the Detect button in the Beat Mapping track, detected transients are
displayed above a certain visibility threshold. It is possible to adjust this threshold using
the − and + buttons in the Beat Mapping track.

• Clicking the − button decreases the number of displayed transients.

• Clicking the + button increases the number of displayed transients.

A high number of transients can be useful if dealing with less distinct accents in the
music—such as soft drums in a loud mix. On the other hand, such a setting might lead
to the display of transients that have no meaning for the rhythmic structure of a region.
In general, you should begin with a lower setting, and only switch to a higher setting if
obvious rhythmic elements in the music aren’t recognized correctly.

On occasion, your recordings may contain (MIDI note) events that fall onto musically
useful positions, and should remain there when beat mapping is used for audio recordings.
Such situations are catered for by the inclusion of the Protect MIDI option, found in the
track header of the Beat Mapping track. Simply activate this option to keep existing MIDI
events at their current Bar ruler positions when beat mapping.

You can also make beat mapping easier by moving one or multiple selected audio regions,
so that the first transient marker in any of the regions is located on the nearest whole
beat position.

To move the first transient marker in a region selection to the nearest whole beat
position

µ Control-click (or right-click) the beat mapping header, and choose Move Selection with
First Transient to Nearest Beat from the shortcut menu (or use the corresponding key
command).

This moves the first transient marker in the region selection to the nearest whole beat
position, with all selected regions moving with it.

Automatic Beat Mapping of Regions
The Beats from Region button in the Beat Mapping track header activates an automatic
Beat Mapping method that uses a self-recorded metronome region.
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To use the automatic Beat Mapping feature
1 Select the region you want to make the project tempo display to, then click the Beats

from Region button in the Beat Mapping track.

The Set Beats by Guide Region(s) dialog opens.

2 Choose the most appropriate note value in the Note Value pop-up menu.

The Note Value defines the timing resolution that is used to create the map.

3 Choose between the following two algorithms:

• Tolerate missing or additional events: This algorithm only uses tempo-relevant transients
for the beat mapping process (selection is based on the project’s current time signature).
This avoids drastic tempo changes, which are usually undesirable. You should use this
algorithm for audio regions.

Note: When using this algorithm, you will achieve the best results with reasonably tight
percussive material. The algorithm will not work well on recordings of performances
that have been played too far off the bar, or provide inconsistent tempo information.
The same is true for very complex, layered drum tracks or melodic material that doesn’t
provide enough transient information.

• Use exactly all existing events: This algorithm uses every detected transient for the
automatic beat mapping process. You’ll only get usable results when using this algorithm
to analyze (MIDI) regions that provide an event for each tempo-significant transient.

4 Click OK to perform the automatic beat mapping process.

Logic Pro scans the region based on your chosen algorithm and performs the beat
mapping process.
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Tip: If using the “Tolerate missing or additional events” algorithm, assign the respective
transient manually before using the Beats from Region function, as this will ensure that
a certain beat is always part of the beat mapping process. The resulting map will always
contain this manually mapped position. If Logic Pro is not able to find a consistent tempo,
you should try the following:  Manually map (up to) two significant beats and click the
Beats from Region button again. The two manual mapping points define a resulting
tempo that will be used as the basis for automatic beat mapping. If this method fails,
record a MIDI region which contains synchronized regular notes, and use this as a guide
region.

To beat map audio material that contains tempo changes
1 Cut the audio material at the precise position of any tempo changes.

2 Lock the SMPTE position of each audio region.

3 Select the first region and perform the automatic beat mapping process as already
described.

4 Continue with all following audio regions.

Beat Mapping to Scene Markers
If the global Video track is visible, a QuickTime movie is loaded, and the Detect Cuts
function (in the Video track) is used, the detected scene markers appear as available
mapping positions (vertical lines) at the bottom of the Beat Mapping track. You can easily
define a scene cut position as the first downbeat of a bar—by allocating it to the bar
position, as described above.

Beat Mapping to Markers
If the Marker track is visible, you can use the desired marker as a mapping position (vertical
line at the bottom of the Beat Mapping track) by clicking it. Shift-click to assign multiple
markers as beat mapping positions. Once done, you can hide the Marker track.
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You can use the Chord and Transposition tracks to edit the playback transposition of MIDI
events and Apple Loops over time.

The Transposition track contains nodes that are connected by vertical and horizontal
lines. Each node represents a global transposition event, which determines the global
transposition value until the playhead reaches the next transposition event during
playback.

Transposition events are closely linked to the chord root notes in the Chord track. If you
create or alter a transposition event, the amount of pitch shift is immediately reflected
by the the chord root notes in the Chord track—and vice versa.

The zero position of the Chord and Transposition tracks is determined by the current key
signature in the Signature track. If the key signature changes during a project, the zero
position of the Chord and Transposition tracks changes accordingly.

This chapter covers the following:

• Opening the Chord and Transposition Tracks (p. 1050)

• Understanding How MIDI Events and Apple Loops Are Transposed (p. 1051)
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• Creating and Editing Transposition and Chord Events (p. 1052)

• Using the Chord Track to Analyze MIDI Regions (p. 1054)

Opening the Chord and Transposition Tracks
The Chord and Transposition tracks are opened in the global tracks area. If these tracks
are not visible, see Displaying Global Tracks.

To open the Chord track
1 Click the disclosure triangle in the Global Tracks header area.

2 Click the disclosure triangle for the Chord track.

You can also assign, and use, the Toggle Chord Track key command.

To open the Transposition track
1 Click the disclosure triangle in the Global Tracks header area.

2 Click the disclosure triangle for the Transposition track.

You can also assign, and use, the Toggle Transposition Track key command.
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Understanding How MIDI Events and Apple Loops Are
Transposed
Transposition events (and their chord counterparts) pitch-shift MIDI events and
Apple Loops.

MIDI Events
Transposition events change the actual MIDI events themselves. For example, if you create
a MIDI region that contains a C3 note event, copy the MIDI region, and then create a
transposition event of +2 at the start of the copied MIDI region, the transposition event
changes the note event to a D3.

Despite this data change to events, the Transposition track works nondestructively, as
you can change the transposition of MIDI events multiple times. Imagine you copy the
D3 of the example above to a position where the Transposition track is set to +2; the
MIDI event will be played back as D3. But if the Transposition track is set to a different
playback interval at the target position, the MIDI event will be pitch-shifted to the new
playback transposition.
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Transposition events only affect MIDI events already in your project. They do not affect
MIDI events that you create or record after editing the transposition events.

MIDI events will only be transposed if the No Transpose checkbox is unselected in the
respective Track Parameter boxes.

Apple Loops
Apple Loops can contain information about the key they are in, and can be transposed
automatically. Regular audio regions (audio regions that are not Apple Loops) are not
affected, nor are Apple Loops that do not have a key definition (drum loops, for example).
For full details, see Using the Chord Track with Apple Loops.

Creating and Editing Transposition and Chord Events
Creating and editing transposition events works similar to standard MIDI events.

To create a transposition event in the Transposition track
Do one of the following:

µ Click a position in the Transposition track with the Pencil tool.

µ Hold Control-Option-Command, click a position in the Transposition track, enter a
transposition value in the text field, then press Return.

A transposition event of the typed value is created at the clicked position.

To change the transposition value of a transposition event
µ Drag the event vertically.

1052 Chapter 35 Editing Transposition with the Chord and Transposition Tracks



To create a chord event in the Chord track
µ Click a position in the Chord track with the Pencil tool, and define a chord symbol in the

Define Chord dialog.

To edit a chord event
µ Double-click the event, and make changes to the chord symbol properties in the Define

Chord dialog.

To select a chord or transposition event
µ Click the chord or transposition event with the Pointer tool.

Use Shift-click or drag to select multiple events.

To move a chord or transposition event along the timeline
µ Drag the event horizontally.

Watch the help tag during this procedure to see the exact transposition value and bar
position of that particular event.

To delete a transposition or chord event
Do one of the following:

µ Click the event with the Pointer tool, and press the Delete key.
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µ Click the event with the Eraser tool.

Transposition events can be copied using the standard Copy and Paste procedures or by
dragging them with the mouse while holding Option.

You can also copy or move multiple transposition events simultaneously, which can be
useful for repeated project sections.

Using the Chord Track to Analyze MIDI Regions
You can use the Analyze button in the Chord track to analyze the chords in a MIDI region.
Select a MIDI region (preferably one containing complete chords) and click the Analyze
button in the Chord track header. The MIDI region is analyzed, with the resulting chords
appearing in the Chord track. This also works for several subsequent regions. Alternatively,
you can drag the regions onto the Chord track.

Note: Keep in mind that the chords in the Chord track are events, they affect the playback
transposition of MIDI events and Apple Loops. Make sure that you only use the Chord
track if you really want to use it consequently; once you use it, it always affects your
composition. As an example:  When you analyze your project, then copy a region without
copying the chord track events …; you should not use it if you only want to display the
chords in your project; use the Marker track then—or the Score Editor text chord symbols.

Working in the Change Display Only Mode
You might come across situations in which there are incorrect or missing chords in the
Chord track. For example, you record a MIDI region, select it and use the Chord track’s
Analyze button. Normally this should work fine, as the analysis algorithm is rather
intelligent and knows all about harmonics. If the result of the analysis process unexpectedly
doesn’t comply with your recording, Logic Pro provides you with an easy solution:  the
Chord track’s Change Display Only mode. If you activate this mode by clicking the Change
Display Only option in the Chord track, you can adjust the chords to match what you’re
actually hearing (the transposition events in the Transposition track are adapted
accordingly). All changes applied to chords in the Chord track while the Change Display
Only mode is active will have no result on the playback of the corresponding MIDI
regions—these changes will only adapt the chords displayed in the Chord track to match
the chords played in the MIDI region.

The Change Display Only mode does not work with Apple Loops used on audio tracks.
For full details, see Using the Chord Track with Apple Loops.

Inserting Chord Symbols in the Score
The chord symbols displayed in the Chord track can be inserted into the Score Editor
(and printed):
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To insert chords from the Chord track into the Score Editor
µ Select the staff that you want to use for the chord symbols in the Score Editor, then choose

Functions > Insert Chords From Global Chord Track.

Inserted chord symbols are displayed in blue (printout will be black), and can only be
moved within the boundaries of the chord on the Chord track. Double-clicking such a
chord opens the Define Chord dialog of the Chord track.
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It is not essential to know about—or even open—the Environment window in order to
make music with the instruments of Logic Pro or your external MIDI sound generators
and keyboards. When you create new instrument or external MIDI tracks (as discussed in
Working with Instruments), Logic Pro automatically generates Mixer channel strips, and
also creates and configures any Environment objects that are needed for basic input and
output.

Note: This is also true of audio channel strips (and other channel strip types, such as aux
and output channel strips), but you will rarely need to access these objects in the
Environment, as you have full control over the channel strips in the Mixer and Arrange
window.

This chapter outlines all general concepts and techniques needed to use the Environment.
Ultimately, it’s up to you to decide how to, or indeed if, you use any of the Environment’s
facilities

For detailed descriptions of the Environment objects, see Environment Objects Reference.

This chapter covers the following:

• Opening the Environment (p. 1057)

• Getting to Know the Environment (p. 1058)

• Working with Layers (p. 1059)

• Working with Objects (p. 1062)

• Creating Your MIDI Signal Path (p. 1066)

• Exchanging Environments (p. 1074)

• Customizing the Environment Display (p. 1077)

Opening the Environment
The Environment can only be opened as a separate window.
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To open the Environment window
µ Choose Window > Environment (or use the Open Environment key command, default

assignment:  Command-8).

You can also use the Toggle Environment key command to:

• Bring an open Environment window to the front.

• Open an Environment window.

• Close an Environment window, if it is the active window.

Getting to Know the Environment
The Environment refers to the virtual environment of Logic Pro inside your computer. It
was developed to allow complete control over your MIDI setup.

The Environment window provides a virtual view of your MIDI studio, and it includes the
following objects:

• Physical Input and Sequencer Input objects, which represent the physical MIDI inputs
of your MIDI interface and the Logic Pro input.

• Instrument objects, which are virtual representations of each MIDI device (synthesizers
and samplers, for example) in your MIDI rig.

• Numerous other objects, such as faders, knobs, switches, arpeggiators, and more. These
are used to create new data, or to control and modify the MIDI signal flow in real time.
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You determine the MIDI signal flow by connecting Environment objects with virtual
cables. For full details, see Creating Your MIDI Signal Path.

The connection of objects with virtual cables makes it easy to follow the signal flow, but
also allows near limitless routing and MIDI data processing possibilities. Use your
imagination, and logically plan (and implement) the signal path, to take advantage of
the functionality offered by each object type. If you can think of a way to manipulate
your MIDI data, you can do it in the Environment.

Most objects can be remotely controlled by other MIDI events (using the sliders or
modulation wheel of your keyboard, for example). You can even record these movements,
if you wish.

In addition, there are specialized objects that can split a MIDI signal into different channels,
make preprogrammed alterations, or even reroute the signal path. These allow you to
use the same MIDI data (note events, for example) for several processes, or can be used
to provide controller keyboard functionality to the most basic MIDI keyboard.

As you might imagine, the Environment can quickly fill up with a large number of objects.
To keep things organized, you can assign them to different display levels, referred to as
layers. Think of these layers as being different, partial views of the overall Environment.
Naturally, you can easily connect objects between different layers.

Working with Layers
Layers are display levels of the Environment window. They allow you to view and work
with specific groups of related objects (all instrument objects, for example), rather than
dealing with all Environment objects at the same time. The name of the current layer is
displayed in the Layer menu.

Layer menu

The distribution of objects across different layers has no effect on their functionality—it’s
simply a better way to organize (potentially thousands of ) objects. There are two
exceptions:

• Objects in the Global Objects layer also appear on all other layers.

• The All Objects layer shows a list of all Environment objects.
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Understanding Protected Layers
The position (and existence) of the first two layers—All Objects and Global Objects—is
protected, and they cannot be deleted.

• All Objects: This layer displays all objects in the Environment. The objects in this layer
are normally shown as a list. You can choose the Options > Go to Layer of Object
command, in the Environment menu, to switch to the selected object’s layer.

• Global Objects: You can place objects that you want to be visible in all layers in the
second layer from the top. These will appear at the same position in all layers. It is
recommended that you place as few objects as possible on this layer, due to the
onscreen clutter that global objects can create.

Creating, Naming, and Deleting Layers
You can create, name, and delete layers in the Environment.

To create a new layer
Do one of the following:

µ Choose Options > Layer > Create (or use the Create Layer key command).

µ Choose Create Layer from the Layer pop-up menu.

The new, empty layer called “(unnamed)” is inserted above the currently selected layer.

To name a layer
1 Click the Layer Name field, and type in a name.
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2 Press Return to confirm the new name.

To delete a layer
1 Do one of the following:

• Choose Options > Layer > Delete (or use the Delete Layer key command).

• Choose Delete Layer from the Layer pop-up menu.

An alert appears, to warn against the unwitting deletion of all objects on the layer.

2 Click Delete to complete the operation.

Switching Between Layers
You can switch between layers and switch back to the most recently opened layer.

To switch between layers
µ Click the arrow button next to the Layer menu, and choose a layer from the menu.

To switch back to the most recently opened layer
µ Choose Options > Go to Previous Layer (or use the Go to Previous Layer key command)

in the Environment.
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Working with Objects
As with all windows, you interact with onscreen elements and data by using different
tools. The Environment window Tool menu offer the standard Pointer, Pencil, and Eraser
tools found in other windows. These are used to select, create, and delete objects in the
Environment. In addition, the following tools are available in the Environment:

• Text tool: Clicking an object with the Text tool allows you to rename it. Click anywhere
outside the text field, or press Return, to complete the naming operation.

• MIDI Thru tool: Clicking an object in the Environment with the MIDI Thru tool assigns
the object to the selected track in the Arrange window.

Creating and Deleting Objects
You can create and delete objects.

To create objects
Do one of the following:

µ Choose an object type from the New menu to create an object of this type on the current
layer.

µ Click a layer background with the Pencil tool to create a new instrument object.

To delete objects
Do one of the following:

µ Click the object with the Eraser tool.

µ Select all objects you want to delete, and choose Edit > Delete (or press Delete).
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Moving Objects
You can move objects by grabbing their icon or name, and dragging them to a new
position on the layer. The surface of keyboard and fader objects is used for their operation.
You must therefore either grab the name (if available), or the positioning bar to the right
of the object in order to move them. If you hold down Shift, you can also grab keyboard
or fader objects by their surface.

Positioning bar

Note: You can Shift-click any Environment object to select and move it. When doing so,
remember to first deselect any other selected objects by clicking the layer background,
to avoid moving them as well.

You can use the Layer menu and the Clipboard to move objects between layers. You can
also open a second Environment window and drag the objects to a different layer.

To use the Layer menu to move objects to a different layer
1 Select the objects.

2 Hold down Option, and select a layer in the Layer menu.

The selected objects are moved to the chosen layer.

To use the Clipboard to move objects to a different layer
1 Select the objects that you want to move and choose Edit > Cut (or use the corresponding

key command, default assignment:  Command-X).

2 Switch to the destination layer.

3 Make sure that no objects are selected (by clicking the layer background).

4 Choose Edit > Paste (or use the corresponding key command, default
assignment:  Command-V).

Note: If any objects are selected when attempting to paste objects to the current layer,
a dialog asks if you want to “Replace current selection? No/Replace.” If you press Return
or click Replace, the selected objects are replaced by the objects in the Clipboard. The
existing cabling remains intact.

To drag objects to a different layer
1 Open a second Environment window that displays the target layer.
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2 Select the objects you want to move in the first Environment window, and drag them
from one window to the other.

Tip: You can also use this method to copy objects between layers (by holding Option).

Copying Objects
You can copy an object on a layer by Option-dragging it with the Pointer tool.

To copy an object between layers using the Clipboard
1 Select the objects that you want to move and choose Edit > Copy (or use the

corresponding key command, default assignment:  Command-C).

2 Switch to the destination layer.

3 Make sure that no objects are selected (by clicking the layer background).

4 Choose Edit > Paste (or use the corresponding key command, default
assignment:  Command-V).

Cabling is preserved, so groups of objects copied in this way are connected in the same
way as the originals. (When you copy a single object, only its output cables are preserved.)

Note: If any objects are selected when attempting to paste objects to the current layer,
a dialog asks if you want to “Replace current selection? No/Replace.” If you press Return
or click Replace, the selected objects are replaced by the objects in the Clipboard. The
existing cabling remains intact.

To use drag and drop to copy objects to a different layer
1 Open a second Environment window that displays the target layer.

2 Select the objects you want to copy in the first Environment window, press Option, and
drag them from one window to the other.

Adjusting the Position of Objects
Objects can be freely placed, which is flexible, but can lead to overlaps or
misalignments—particularly when pasting between layers. Fortunately, you can quickly
clean up object positions.

To snap objects to a grid
µ Choose View > Snap Positions to align the objects to an invisible grid.

It’s a good idea to leave Snap Positions turned on. You only need to turn it off if you want
to manually move an object by a few pixels.

You can also use the following key commands to move all selected objects one pixel in
the relevant direction, even when the grid is turned on:

• Object move left

• Object move right
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• Object move up

• Object move down

To align several selected objects horizontally or vertically
µ Choose Options > Clean up > Align Objects (or use the corresponding key command).

The top-left object stays where it is. The position of the next object determines whether
the objects are aligned in a column or a row. If it is to the right of the top-left object, all
objects are aligned horizontally (row). If it is below the top-left object, all objects are
aligned vertically (column).

To align selected objects to the invisible grid
µ Choose Options > Clean up > Positions by Grid.

Adjusting the Size of Objects
You can adjust the size of fader, keyboard, and monitor objects by grabbing and dragging
the bottom-right corner (just as with windows).

Changing sizes when multiple objects are selected (by dragging to select or Shift-clicking)
alters each object’s size, while preserving their sizes, relative to each other.

To set the size of the selected object to its default value
µ Choose Options > Clean up > Size by Default.

You can also use the following key commands to decrease or increase the width or height
of all selected objects by 1 pixel:

• Object Width −1 Pixel

• Object Width +1 Pixel

• Object Height −1 Pixel

• Object Height +1 Pixel
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Using Advanced Selection Commands
You can make moving and copying tasks faster and easier by using the selection
commands outlined below.

• Selecting All Used Instruments: The Edit > Select Used Instruments function selects all
objects that are assigned to the selected track in the Arrange window (or tracks that
contain regions), or are connected to such objects via cables.

• Selecting All Unused Instruments: The Edit > Select Unused Instruments function selects
all objects that are neither used in the Arrange window (as tracks which contain regions),
nor connected to any such objects via cables.

• Selecting Cable Destination or Origin Objects: The Edit > Select Cable Destination
command highlights the destination object of a selected cable connection. This is
particularly useful in two cases:

• The destination object is on a different layer. You can use the function to select and
display the destination object (and layer).

• When in the list display (View > By Text), you can locate the destination object of a
source object, because selecting the source object also selects its cable connections.

This function allows you to follow the cabling from one (serially cabled) object to the
next. If several objects are connected in parallel, or several cable connections are
selected, the path of the top cable is followed.

The Edit > Select Cable Origin command essentially performs the reverse task, where
the MIDI signal flow is back-tracked to the source (or origin) object. This is particularly
useful for troubleshooting, or when you want to make changes to a number of serially
cabled objects (by changing the original).

• Toggling Your Selection: Just as in the Arrange window and editors, you can change
the status of any selected objects in the current layer by choosing Edit > Toggle
Selection.

Creating Your MIDI Signal Path
Before any MIDI events received at your computer’s MIDI inputs can be recorded by
Logic Pro, there must be a connection between two Environment objects:

• Physical Input object: This represents the MIDI In port(s) of your MIDI interface.
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• Sequencer Input object: This represents the door into Logic Pro for incoming MIDI events.

In Logic Pro, incoming MIDI events (which arrive at the Sequencer Input object) are always
directed to the selected track in the Arrange area’s track list, where they can be recorded
in MIDI regions.

The events played by the track region are mixed with incoming events (if any), and sent
to the Environment object that the track is routed to.

From here (the multi-instrument object), the events are directed to a MIDI output (see
Creating Direct Output Assignments).

You can insert objects into the signal path between the Physical Input object and the
Sequencer Input object if you wish (a MIDI monitor object, for example, which allows you
to see incoming MIDI events).

You can also insert objects between the arrange track and its destination object, enabling
other Environment processing. The arrange track itself is not represented by an
Environment object, but you can use the Track Assignment menu to route the track’s
output to an Environment object.
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For example, the output of an arrange track (the note events in a MIDI region) routed to
(software) instrument channel 1 can be arpeggiated. To do this, you would create an
arpeggiator object (this will be easiest on the Mixer layer of the Environment), assign the
arpeggiator to the arrange track (Control-click the track header to access the Track
Assignment menu, and browse to the arpeggiator object), then cable the arpeggiator
out to instrument channel 1.

On playback, the note events in the region will be processed by the arpeggiator object,
and routed (via the cable) into the instrument channel, which plays back the processed
(arpeggiated) MIDI note data.

Creating Direct Output Assignments
You can create a direct output connection to a physical MIDI output from any of the
following object types:

• Instrument

• Multi-Instrument

• Mapped Instrument

• Touch Tracks

• GM Mixer

• MIDI Metronome Click
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To make a direct output connection
µ Click the Port menu in the object’s Parameter box, and choose a MIDI output.

The Port menu lists all MIDI Outputs, plus the following options:

• The Off setting completely disables the connection to the MIDI interface port.

• The All option routes the object’s output to all available MIDI ports. This may be useful
if the device is sending a pulse, for example.

Note: If you have a MIDI interface with more than one output port (or even several
interfaces that can be stacked), you can set up a direct connection to one of the individual
ports (1 to 63) of that (or those) interfaces.

Any object with a directly assigned output is indicated by a white triangle on its right
side. The triangle is hollow when there is no direct assignment.

Object with direct output 
assignment

Object without direct 
output assignment
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Cabling Environment Objects
The cabling between Environment objects provides control over the entire MIDI signal
path. A cable is normally shown as a gray or colored line between a source and destination
object.

Cables are assigned the same color as the source object, which makes following the signal
path much easier. You can, however, turn off cable coloring, and render them in gray
with the View > Colored Cables function.

Objects always have an (invisible) input on the left, and an output on the right side. The
output of an object is shown as a small triangle, pointing to the right.

To make a connection between two objects—method 1
1 Click-hold the triangle of the source object.

The mouse pointer turns into a plug (patch cord) that represents a cable connection
coming from the object’s output.

2 Move the cable plug over the destination object, and release the mouse button when
the object is highlighted (this happens automatically when you touch it).

A cable connection is created between the two objects.

If the source object has already been directly assigned to a MIDI output port, a dialog
asks if you want to replace the direct assignment. You have three options:

• Cancel: The connection is not made, and the direct output assignment of the source
object remains intact.
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• No: Your cabling takes place, but the direct output assignment remains intact. This
means that the source object is connected to two destinations—one to another object
via the cable, and one via the direct output assignment.

• Remove: Your cabling occurs, and the direct output assignment is removed. (This is
the default selection, because you generally won’t want an object connected to two
different destinations.)

To make a connection between two objects—method 2
1 Option-click the triangle, which opens a hierarchical menu.

2 Browse to the layer that the destination object is on, and choose the object name.

A cable connection is created between the two objects.

This method is ideal for creating connections between layers, but can also be useful when
a large number of closely spaced objects exists on a single layer.

You can also open a second Environment window (showing the destination layer), and
connect the objects graphically between the windows.
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A cable connection to another layer looks like this:

To remove a cable connection
Do one of the following:

µ Click the cable with the Eraser tool.

µ Select the cable and press Delete.

µ Grab the cable, and plug it back into (drag it over) the triangle of the source object.

µ Use Edit > Clear Cables Only to remove all selected cables, without also clearing any
objects that happen to be selected.

This is handy when you want to clear all cables leading to (or from) one or more objects,
given that selecting objects also selects all associated cable connections.

Making Multiple Cable Connections
There is no limit to the number of cables that you can plug in to a destination object. All
MIDI signals are mixed at the object’s input.

To make multiple output connections from an object
1 Connect the object to a destination object.

Once an output from an object is used (cabled to another object), another output triangle
automatically appears.

2 Use the second output triangle to create a second cable connection to a further destination
object.

Once this is done, a third output triangle appears, and so on.

Some objects have special outputs, and are exceptions to the previous task. One example
is channel splitter objects (see Channel Splitter Objects), which feature several (functionally
different) outputs. Other special objects include cable switchers (see Cable Switchers)
and the Physical Input object (see Physical Input Objects). In these objects, each output
can only be used once.

1072 Chapter 36 Working in the Environment



To route the signal of special output objects (outlined above) to several destinations
1 Create a monitor object (see Monitor Objects) by choosing New > Monitor.

2 Plug the cable from the desired object output into the monitor object.

3 Cable from the monitor object to as many other destinations as you’d like.

The monitor object allows you to view the MIDI events flowing through it.

To select a common destination for several existing cables
1 Select the cables.

Tip: If the cables are already connected to a common destination, the simplest way of
doing this is to select the destination object.

2 Grab one of the cables, and plug it into the new destination object.

You are asked if you want to connect all selected cables with the new destination.

3 Click Connect, or press Return.

Cabling Objects Serially and in Parallel
You can cable objects in series or in parallel. Cabling objects in series is handy for quickly
connecting groups of faders used to control a MIDI mixing console, for example.

To cable a group of objects serially
µ Select all objects you want to cable, then choose Options > Cable serially.

The objects are cabled in series, starting with the top-left object.

To cable a group of the same type of object (transformers, faders, and so on) to a
common destination

1 Cable one of the source objects to the destination.
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2 Select the destination object and choose Edit > Copy.

3 Select the other objects that you want to connect to the same destination, and choose
Options > Apply Buffer Template to > Cable(s).

You can copy more complex cabling configurations this way, too. Just ensure that the
type(s) of objects in the group that you want to copy matches the type(s) of objects in
the group that you apply the buffer template to.

Exchanging Environments
One of the main advantages of the Environment is the ability to customize Logic Pro to
fully control your MIDI studio. This can, however, present a problem when sharing projects
with other musicians, or using different studio setups.

It also presents a problem when you return to older projects after you’ve changed your
studio. Logic Pro offers several functions to make these transitions as easy as possible.

Whenever you want to exchange Environments between projects, there is a source project
containing the desired Environment, and a destination project with an Environment that
you want to change.

The destination Environment must be in memory, and must be the active project (one
of its windows must be active). The source project can also be in memory, or it can be a
file on your hard disk (or any other media).

• If there are two projects in memory, Logic Pro assumes the active project is the
destination, and the other project is the source.

• If there are more than two projects in memory, Logic Pro assumes the active project is
the destination, and the most recently active of the other projects is the source.

• If there is only one project in memory, Logic Pro opens an Open dialog, allowing you
to select the source project when importing an Environment.

Importing Single Purpose Environments
A single purpose Environment patch might be an editor for a specific piece of MIDI
equipment, an Environment for a single MIDI processing task (such as a MIDI LFO), or a
complex arpeggiator/delay line configuration.

To import an Environment patch contained on a single layer
1 Choose Options > Import Environment > Layer.

2 Choose a layer in the dialog that appears.

This layer—inclusive of all objects on the layer—is inserted in the destination project, at
the same layer position (the same place in the Layer pop-up menu) that it occupied in
the source project. Any existing layers are shifted as needed.
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You can also move selections of Environment objects (inclusive of cabling) between
projects by dragging or copy and pasting. This is made even simpler by first combining
the objects into a macro.

To import an Environment patch that is spread across several Environment layers
µ Choose Options > Import Environment > Merge.

All Environment objects from the source project are added to the Environment of the
destination project.

Merged objects are placed on the same layer as their source. This can create a mess if
objects already occupy that layer in the destination project.

To avoid this issue, create blank layers (in the destination project) at the same layer
positions of the source project, before importing.

Something to be careful of in both cases is the treatment of unique objects in the
Environment, including the Physical Input and Sequencer Input objects. If imported, they
will replace their counterparts in the destination Environment and any cables leading into
them will be lost.

It is best to temporarily delete these from the source Environment, before importing.

Another thing to be aware of is that when you import an object, all objects cabled from
the imported object are also imported.

Updating an Older Environment
If you have only added things to the Environment, but not deleted anything, you can
update older projects by choosing Options > Import Environment > Update.

Only the new objects will be imported—the older objects (along with their cabling and
track assignments) will remain in place.

Swapping Environments
In the complex situation where you want to swap the Environment of one MIDI setup
with the Environment of another, Logic Pro offers three options:

• Replace by Port MIDI/Channel: This option replaces all objects in the destination project
with objects that address the same port and MIDI channel in the source project.

• Replace by Name: This option replaces all objects in the destination project with objects
of the same name in the source project. This affords you some degree of control, by
renaming objects in the source project accordingly.

• Total Replace: This completely replaces the destination project’s Environment with the
source project’s Environment. If you use this option, you’ll have plenty of work to do,
including reassigning Arrange window tracks to objects, but sometimes it’s the only
way.
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Note: This complex task involves a lot of guesswork on the part of Logic Pro, and the
results almost always require some manual fine-tuning on your part.

Replacing Environments by Assignment
The most flexible (and most time consuming) method of exchanging Environments is to
manually choose whether each Environment object is kept, deleted, or replaced. If you
choose to replace an object, you must also define the replacement object. This method
is accessed via Options > Import Environment > Custom.

When you choose custom import, an Environment window listing all objects in the
destination Environment is shown in a column on the left, and the chosen action for each
object is shown in a column on the right.

You can assign the replacements one at a time, by clicking items in the list on the right
and choosing the replacement object from a pop-up menu. This pop-up menu includes
all objects in the track list of the source project.

Alternately, you can select one or more rows in the list, and make a choice from the Import
menu. In addition to keep and delete, this menu offers several automated selection
techniques, as described below.

The first Import menu option is “Import Environment using current Assignment.” No
importing can take place until you make this selection. The other choices (including the
pop-up menus in the right column) determine how things will be imported.

Import Options
The last two items in the Import menu provide additional options for the import process:

• Import > Copy Layer Names: The layer names of the source (second) Environment are
transferred to the current one.

• Import > Copy selected Objects from 2nd Environment: All objects selected in the source
Environment are copied into the destination Environment, even if they don’t appear
on the assignment list.

Automatic Assignment Functions
The assignment functions described below are immediately applied to all selected rows
in the import list. The assignments appear in the right column, and all rows are then
deselected.

• Import > Assign as ‘Keep’: These objects are unaltered.

• Import > Assign as ‘Delete’: These objects are deleted.

• Import > Assign by Identical: These objects are assigned to objects from the source
project that match the type, icon, name, port, and MIDI channel. Objects with the same
Unique ID have priority.
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Logic Pro maintains an internal list of all Environment objects. An object’s position in the
list is its Unique ID; as long as the object is not deleted, its Unique ID never changes.

When objects are deleted, their position in this list becomes available for a new object.

Whenever an object is added to the Environment, it is placed in the first available position
on the list. (If there are no empty positions, it is added to the end of the list.)

• Import > Assign by Unique ID: Objects are assigned to objects from the source project
with the same Unique ID. This option is useful for updating an Environment when
objects have only been added.

• Import > Assign by Port/MIDI Channel: Objects are replaced by objects with the same
Port/MIDI channel. If a match can’t be found for an object, an object set to Port 0 and
the same MIDI channel is assigned. If a match still can’t be found, an object with the
same MIDI channel is assigned.

• Import > Assign by Name: Objects are replaced by objects with the most similar name.
(At least 80 percent of the name must be the same.)

• Import > Assign by Icon/Name: As above, except the object icons must also match.

Customizing the Environment Display
You can customize the display of the Environment, using the options in the View menu.

To hide the Inspector, which contains the Layer menu and Object Parameter box
µ Choose View > Inspector (or use the Hide/Show Inspector key command, default

assignment:  I).

This creates more room onscreen for the Environment workspace display.

To view objects graphically or as a list
µ Choose View > By Text to switch between the graphical display of objects to a listing.

Cables are not shown in the list display. This type of display is most useful in the All
Objects layer.

Customizing the Display of Cables
You can arrange your Environment objects more clearly by hiding cables, or coloring
them.

To hide or show cables
µ Choose View > Cables to display or hide cables between objects.

This also hides or shows the positioning bar (used for moving and resizing) to the right
of some object types.
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Tip: You can prevent the accidental alteration of the position, size, and cable connections
of all objects by choosing View > Protect Cabling/Positions.

If the cabling and object positions are protected, and the cables are hidden, the
background color changes. This usually looks better for virtual mixing desks and fader
setups.

To view colored cables
µ Choose View > Colored Cables.

Cable colors are derived from the color of the source object (the object that the cable
runs from, into another object).

To assign a color to the selected object
µ Choose View > Colors (or use the Open Color Palette key command, default

assignment:  Option-C), and click a color in the Color palette.

Double-click any color in the palette to open the Colors window, which allows you to
define custom colors.

These color edits are stored in the preferences file, and are available for all projects. The
color of an Environment object is used as the default color for any newly created region
in the Arrange window.

Viewing a Frameless Environment Window
There may be occasions when you would like to have access to particular Environment
objects while working in the Arrange window; for example, a few buttons that are used
to control a tape machine.

Rather than opening (or indeed viewing) a full Environment window every time you need
to control the tape machine, you can create a mini window that floats on top of other
windows.

To create a mini floating window (the following is a typical approach)
1 Create a new layer.

2 Create the objects, cable them if necessary, and adjust their parameters as needed.

3 Reposition the objects, and resize the Environment window so that it is just large enough
to accommodate the objects.

4 Choose View > Frameless Floating Window.
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This creates the mini Environment window, which floats above other windows.

5 Position it as desired (above the Arrange window would be the most obvious use), and
press Shift-L to lock this as a screenset.

6 Choose this screenset to access the tape controls whenever you need them.
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This chapter is designed as a reference to help you learn about the different Environment
objects you can use in Logic Pro. You’ll learn about each type of Environment object,
what each one is designed to do, and how to use the parameters of the object.

Note: If you need information about the general concepts and techniques required to
use the Environment, see Working in the Environment.

This chapter covers the following:

• Opening the Object Parameter Box (p. 1082)

• Getting to Know Common Object Parameters (p. 1082)

• Standard Instrument Objects (p. 1084)

• Multi-Instrument Objects (p. 1086)

• Mapped Instrument Objects (p. 1090)

• Touch Track Objects (p. 1095)

• Fader Objects (p. 1099)

• Alias Objects (p. 1116)

• Ornament Objects (p. 1118)

• GM Mixer Objects (p. 1118)

• MMC Record Buttons Objects (p. 1121)

• Keyboard Objects (p. 1122)

• Monitor Objects (p. 1122)

• Macro Objects (p. 1123)

• Arpeggiator Objects (p. 1125)

• Transformer Objects (p. 1127)

• Delay Line Objects (p. 1133)

• Voice Limiter Objects (p. 1134)

• Channel Splitter Objects (p. 1135)
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• Chord Memorizer Objects (p. 1135)

• Physical Input Objects (p. 1138)

• Sequencer Input Objects (p. 1139)

• MIDI Click Objects (p. 1140)

• Internal Objects (p. 1142)

• Channel Strip Objects (p. 1144)

Opening the Object Parameter Box
There are several ways to open the Object Parameter box in the Environment.

To open or close the Object Parameter box
Do one of the following:

µ Click the triangle at the top-left corner of the Object Parameter box to hide all parameters,
except for the object name and type. This reduces the box to its minimum vertical size.

µ Choose View > Inspector (or use the Hide/Show Inspector key command, default
assignment:  I).

Getting to Know Common Object Parameters
Each Environment object has several parameters that control its operation. These
parameters can be viewed and changed in the Object Parameter box, shown in the
Environment window Inspector when an object is selected.

The Object Parameter box also appears in the Arrange window Inspector when you select
a track assigned to the object. These are the same parameters—changes in one location
are reflected in the other. There is one type of object, however, that differs slightly in this
regard:  the audio channel strip.
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An Object Parameter box containing a reduced parameter set is shown for audio channel
strips when displayed in the Arrange window. The full parameter set for these objects is
only available in the Mixer layer of the Environment window. There are two main reasons
why the Arrange window and Environment representations of audio channnel strips
differ:  to save onscreen space, and to provide the tools you need for music creation,
rather than setup tasks.

This separation is made even clearer—for all audio, instrument, and external MIDI channel
strips—by the use of two terms throughout the manual:

• Track Parameter box (in the Arrange window, to illustrate that the channel is controlling
the corresponding track)

• Object Parameter box (in the Environment, where you are interacting with the underlying
object)

The following parameters are shared by all object types:

Name
The name of the object is shown next to the triangle, and can be selected for editing by
clicking it. You can also edit the name by clicking the object with the Text tool.

Object Type
The object type is shown in brackets, and cannot be edited.

Display Filter for the Track Assignment Menu
Select the checkbox beside Icon to make the object visible in the Arrange area’s Track
Assignment menu. (See Assigning Tracks to Environment Objects.) This is obviously useful
for instrument objects, but can also be handy for other objects such as arpeggiators,
touch tracks, and chord memorizers.

Once made visible, you can Control-click an arrange track, and reassign the track to one
of these objects. The object, in turn, can be routed into an instrument channel, for example.

The upshot of this is that selecting an arpeggiator object (routed into a software instrument
channel) in the track list results in a real-time arpeggiation of the instrument sound when
you play chords on your keyboard while Logic Pro is open.

Objects not in the Track Assignment menu can still be assigned to tracks by dragging
them from the Environment onto the track list, or by using the Environment’s MIDI Thru
tool.

If you move a multi-instrument object into the track list, the selected sub-channel is set
as the track instrument. If no sub-channel is selected, all initialized sub-channels
(sub-channels that are not crossed out) are set for the destination track, and the tracks
below that. If there are no tracks below the destination track, new tracks are automatically
created and assigned to sub-channels of the multi-instrument object.
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If the checkbox is not selected, the object and its icon will still appear in the Environment.
You should only select the Icon checkbox if the object will be used as a track destination.

Icon
Click the icon (next to the checkbox) in the Object Parameter box to choose an icon to
represent the object in the Environment and Arrange window track list.

Standard Instrument Objects
Logic Pro provides standard instrument objects to handle MIDI devices that only use one
MIDI channel (typically, older synthesizers, MIDI-controlled effect units, or drum machines).
Standard instruments transmit MIDI data on a single MIDI channel.

To create a standard instrument
Do one of the following:

µ Choose New > Instrument (or use the New Standard Instrument key command).

µ Click the Environment background with the Pencil tool.

The Standard Instrument Parameter Box
When a standard instrument is created, the following parameters are displayed in the
Object Parameter box.

• Port: Use to set a direct connection to one of your MIDI output ports. Remember that
you can also directly cable an instrument object to (or from) other Environment objects,
allowing MIDI processing.
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• Channel: Sets the MIDI channel for the instrument’s output. If you set this parameter
to All, all events are sent with their original channel settings.

• Program, Volume, and Pan: The Program, Volume, and Pan parameters transmit program
changes, volume controller (#7), and pan controller (#10) data.

No data is sent until you select the corresponding checkbox. If the box is already
selected, any value alterations are sent immediately, and the values are also sent
whenever the track is selected.

To the left of the program number, directly to the right of the checkbox, is the Bank
Select parameter. If your MIDI sound source recognizes bank select messages (check
the device manual), you can switch between sound banks. If your sound source responds
to the standard Bank Select message (Controller #32), you can use this parameter
directly. If not, you can define your own Bank Select commands (see Mapped Instrument
Objects).

• Transposition: Defines the number of semitones that all note events are transposed by,
on output. Negative values transpose downward.

• Velocity: Allows you to increase or decrease the note on velocities of all note events,
by an amount between –99 and 99.

• Key Limit: The two note values of the Key Limit parameter define a pitch range. All
notes outside this range are ignored by the instrument when it plays a MIDI region. In
other words, this range of notes will not be played.

• Vel Limit: The two values of the Vel Lim parameter define a velocity range. All notes
with a velocity that falls outside this range are not played by the instrument.

• Delay: The Delay parameter causes all MIDI events to be sent early or late. This allows
you to compensate for any differences in reaction time between your various MIDI
devices. Use the region Delay parameter (in the Inspector’s Track Parameter box shown
in the Arrange window) to create rhythmic delay effects, as this allows longer delay
times.

• No Transpose: If the No Transpose parameter is active, all regions on any tracks played
by this instrument object are protected from transposition. In other words, the Transpose
Region parameter is ignored. This is very useful for instruments assigned to drum or
other samples—mapped across the keyboard on a single MIDI channel—as transposition
will trigger different sounds (rather than pitches) in these instruments.
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• No Reset: If the No Reset parameter is active, no reset messages are sent to the
instrument. This can be useful if controllers are being used for nonmusical purposes,
such as when using the instrument object for Mixer automation tasks. The Logic Pro >
Preferences > MIDI > Reset Messages settings determine what reset messages are sent.
These messages are not sent to No Reset instruments.

• Style: The Style parameter can be set to any of the available staff styles. Whenever a
region is created on one of the instrument’s tracks, it is assigned the staff style displayed
here. If the Auto style is chosen (the default), Logic Pro picks an appropriate style based
on the pitch range of the notes in the region. For more information on staff styles, see
Working with Staff Styles.

Multi-Instrument Objects
A multi-instrument is like a collection of 16 standard instruments Opening the Object
Parameter Box in one package.

Each of the 16 standard instruments provides a separate MIDI channel (mirroring the 16
MIDI channels), and is therefore called a sub-channel. The multi-instrument’s interface
includes a numbered square (button) for each sub-channel. Clicking any of these numbered
squares selects the corresponding sub-channel, and displays its parameters in the Object
Parameter box.

Each sub-channel has a complete set of instrument parameters (identical to those outlined
in The Standard Instrument Parameter Box).
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You will generally use multi-instrument objects to address multi-timbral hardware
synthesizers or samplers. A multi-timbral sound module is one that can receive on several
MIDI channels at once, playing back a different sound on each channel simultaneously.

As most modern MIDI devices are multi-timbral, the multi-instrument will probably be
the most commonly used instrument object in your Environment.

To create a new multi-instrument object
µ Choose New > Multi-Instrument (or use the New Multi-Instrument key command).

The Multi-Instrument Parameter Box
The multi-instrument object parameters are a shorter set of the standard instrument
object parameters (see Opening the Object Parameter Box). The settings you make in the
multi-instrument Parameter box apply globally to all sub-channels.

To view the multi-instrument Parameter box
µ Click the icon at the top of the multi-instrument object.

The whole multi-instrument object is selected, allowing you to set the Port parameter,
for example.

The Multi-Instrument Window
Double-clicking a multi-instrument opens the Multi-Instrument window:

Device Name and Short Device Name
At the top-left corner of the window, you can enter the full name of the multi-instrument
in the Device Name input field. You can also enter a short name for the multi-instrument
in the Short Device Name input field. This short name is used in the Arrange window
track list, when the program name is displayed.

Depending on whether or not you have activated the sub-channel’s Program parameter,
the following information appears in the Arrange area’s track list:

• The name of the multi-instrument and channel number (if the parameter is not activated)

• The short name, channel number, and program name (if the parameter is activated)
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Program Names
There are 128 program names in the Multi-Instrument window. A total of 15 banks of
128 program names are available. There are several ways of entering program names:

• By double-clicking the name (via the text input field).

• By copying (via the Clipboard) from a different multi-instrument, or from a
word-processing program. The Clipboard functions for a whole sound bank are available
in the Options pop-up menu.

• First, copy the program numbers or General MIDI names to the Clipboard, and add
them to a word-processing document.

• You can then edit the names and copy the whole section back again.

• If you want to use program numbers instead of names, choose Init Names as Numbers
from the Options pop-up menu.

• If you want to use General MIDI program names, choose Init General MIDI Names. If
the Use GM Drum Program Names for Channel 10 checkbox, at the bottom of the
window, is activated, the standard GM drum set names are shown in the Program menu
of the Parameter box for sub-channel 10.

If the Program box in the selected sub-channel’s Parameter box has a checkmark in it,
you can send a program change message by selecting a program name in the
Multi-Instrument window.

Bank
The Bank pop-up menu allows you to choose one of 15 available sound banks (0 to 14).
The top item—”No Bank specified. Names of Bank 0 used.”—can be used if your sound
generator does not understand bank select messages, or only has 128 sound programs.

• Bank 0 is always initialized.

• The first time you choose one of the banks numbered 1 to 14, you are asked whether
or not you want to initialize this bank.

• Non-initialized banks use the names of the equivalent program numbers from bank 0.

Note: You should only initialize additional banks if you want to enter program names for
those banks, because each initialized bank uses more memory.

Bank Message
The Bank Message pop-up menu allows you to define the MIDI events that are sent when
you switch between the banks of the multi-instrument.

Different bank select formats are used by different MIDI instrument manufacturers. Refer
to your MIDI instrument’s manual to see whether or not it supports bank select messages,
and if so, what format it uses.
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With modern synths, there’s a good chance the format will match one of the top items
in the menu:  either controller #32 or controller #0. There are also presets to accommodate
several of the more common types of synths. If your synth doesn’t use one of the formats
listed, you can define your own bank select messages (see Custom Bank Selects).

Working with Sub-Channels
To select a sub-channel (to address a specific MIDI channel number within the
multi-instrument), click the appropriately numbered square (button) on the
multi-instrument object. The first time you click it, the sub-channel is activated, making
it available in the Track Assignment menu of the arrange track list (accessed by
Control-clicking a track). To avoid menu clutter, you should only activate as many
sub-channels as you actually need, or as many as the external MIDI device supports.

As with any other Environment object, you can remove sub-channels from the Track
Assignment menu by deselecting the Icon checkbox in the Object Parameter box. The
button for the sub-channel appears with a diagonal line through it when deactivated.

In the above image, sub-channel 1 is selected, sub-channels 1 to 8 are activated, and
sub-channels 9 to 16 have been removed from the Track Assignment menu.

The Sub-Channel Parameter Box
Each sub-channel has a complete set of instrument parameters, identical to those for
standard instruments. (See The Standard Instrument Parameter Box.) The only parameter
you cannot change is the MIDI channel. If you attempt to change the channel, you are
asked to select another sub-channel, or select the multi-instrument itself to change the
common driver destination.

You can, however, change the channel in the Arrange window’s Track Parameter box to
any sub-channel of the multi-instrument, and the track will be assigned to the selected
sub-channel. This allows you to redirect the (regions on the) track to another sub-channel,
making it easy to play multiple parts with a particular channel/sound.

Note: If you change the Output port parameter of any sub-channel, the entire
multi-instrument and all other sub-channels are affected.
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Cabling Directly to a Sub-Channel
To connect the output of an Environment object directly to the input of a sub-channel,
Option-click the source object’s output triangle and choose the sub-channel in the
Reassign Track Object menu. (See Cabling Environment Objects.)

Note: You cannot drag a cable to a sub-channel. Any dragged cables can only be
connected to the entire multi-instrument object, not one of its sub-channels.

Mapped Instrument Objects
A mapped instrument is particularly useful for drum instruments or any drum-mode MIDI
device. A drum-mode device has different sounds assigned to different MIDI notes, but
only uses a single MIDI channel; for example, a drum kit loaded into the EXS24 mkII, or
MIDI channel 10 of a GM-compliant sound module, or a drum machine.

To create a new mapped instrument
µ Choose New > Mapped Instrument (or use the New Mapped Instrument key command).

A mapped instrument is used just like a standard instrument, but each individual input
note can be:

• Named (snare, hi-hat, and so on)

• Mapped to an output note

• Given a velocity offset

• Assigned its own MIDI channel
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• Sent to one of up to 16 output cables (This allows you to create a single instrument
that addresses multiple sound sources.)

• Given its own notation parameters:  note head shape, relative vertical position in the
staff, and drum group assignment (See Using Drum Notation with Mapped Staff Styles.)

The Mapped Instrument Parameter Box
The mapped instrument’s parameters are a subset of the standard instrument parameters.
The missing settings are available on a note-by-note basis in the Mapped Instrument
window. For details, see Opening the Object Parameter Box.

The Mapped Instrument Window
Double-clicking a mapped instrument icon opens the Mapped Instrument window. The
rows correspond to input notes, and the columns contain the various parameters available
for each note. The window opens automatically when a new mapped instrument is
created.

Keyboard (Selecting Notes)
The keyboard on the left represents the input notes. It can be played by clicking it. You
can also select individual notes or note ranges by dragging the mouse over the notes
you want to use. To select multiple notes, Shift-click them. Any value alterations apply to
all selected notes.

Input Name
In the first column, you can click the input note name (E6, for example), and type in a
name of up to 12 characters. Press Return or click outside the text entry field to confirm
the new name.

You can initialize the names of the selected notes to:

• Pitch descriptions (C#3, for example) by choosing Names as Notes from the Initialize
pop-up menu.
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• The names of GM Standard drum sounds by choosing Initialize > Names as General
MIDI.

If a MIDI region (on a track routed to a mapped instrument object) is displayed in the
Piano Roll Editor, the names of the notes being played appear on the vertical keyboard.

Output Note
This column is used to set the output note. This is done by either:

• Double-clicking the note description and editing the text

• Dragging the beam to the right of the output note name

MIDI notes are sent while the value is being changed, allowing you to hear what you’re
doing.

Use the Initialize > Output Notes command to match the output notes of the selected
pitches to the input note pitches.
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Velocity
Use to set a velocity offset that is added to, or subtracted from, the velocity of the incoming
note. Drag the number vertically to create a velocity offset. You can also click the specific
point on the beam.

The Initialize > Output Velocities command resets all velocity offsets to 0 (no offset).

Channel
Use to set the MIDI channel of individual notes. This allows you to play individual sounds
from different drum sets in the same sound generator.

You will normally use the Base setting. This means that the notes are sent on the channel
set in the mapped instrument’s Parameter box. If you choose All in the Parameter box,
the channel information of the incoming notes is used. This is useful if you want to place
the mapped instrument after a multi-instrument or standard instrument in the signal
path.

To set all selected notes to Base, choose Initialize > Output Channels.

Cabling Mapped Instruments
You can send individual notes from a mapped instrument object to (up to) 16 different
output cables, allowing you to play sounds from different sound sources. If you select a
cable that doesn’t exist, the note will not be sent out.

The Initialize > Output Cables command resets all cables to #1 (the top outlet of the
Mapped Instrument).

Notation Parameters
The last three columns define the notation parameters of individual notes.

• Head: This pop-up menu allows you to change the note head.

• Rel. Pos.: This field is used to alter the relative position of the note on the staff. This
does not alter the pitch, only the vertical positioning of the note head on a staff in the
Score Editor. Drag vertically to alter the note position.

• Group: As the mapped instrument object is typically used for percussion instruments,
click-holding the Group field opens a menu of grouped drum families:  Kick, Snare, and
so on. MIDI sound modules can have drum sounds mapped across 127 possible notes,
which would result in an interesting staff (to say the least). Assign several related
percussion sounds (tom drums, for example) to the Toms group to place all related
sounds on a single staff line. As with the relative position, the pitch of grouped notes
is not affected by grouping them on a single line.

Choosing Initialize > Score Parameters neutralizes the settings of the Head, Rel. Pos., and
Group parameters.
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Custom Bank Selects
Logic Pro provides 15 bank numbers (0 to 14) for each standard instrument,
multi-instrument (including sub-channels), or mapped instrument object. You can create
custom lists, consisting of as many events (of any kind, even SysEx) as you like, for each
of these banks.

Whenever you change the bank manually, or send a standard bank change message from
Logic Pro, the entire list for that bank is transmitted to your sound module.

To set up custom bank select messages
1 Select the instrument you want to define bank select messages for.

2 Choose Options > Define Custom Bank Messages.

A window similar to the Event List opens, with a single, default bank select message for
banks 0 to 15. (The default used is a MIDI controller #0 message, with a value equal to
the bank number.)

You can create MIDI events here as you would in the Event List, by cutting, copying,
inserting, and editing. (See Editing MIDI Events in the Event List.) The only difference is
that you enter a bank number, rather than a time position.
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The letter in parentheses next to the bank number allows you to control the order of
transmission when a bank select requires more than one message.

If there are no events defined for a particular bank, a standard bank select message is
sent for that bank.

For bank messages that need a channel (MIDI controller messages, for example), the
channel of the instrument is used. This feature is especially useful for multi-instruments,
as you only need to create one set of bank messages for all 16 sub-channels. If an
instrument’s channel is set to All, channel 1 is used.

Note: The custom bank select information becomes part of the instrument, and is
automatically copied with it, if you replicate the instrument object.

Touch Track Objects
A touch tracks object allows you to trigger MIDI regions or folders with single notes. This
can be used to create a new arrangement in real time, ideal for live performances.

You cannot use touch tracks to trigger audio. In the following section, any references to
regions mean folders and MIDI regions, not audio regions. Despite this limitation, you
could conceivably load your audio regions (as files) into the EXS24 mkII, and trigger it
with a touch tracks object.

To create a touch tracks object
Do one of the following:

µ Drag a MIDI region or folder from the Arrange area into the Environment.
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µ Choose New > Touch Tracks from the Environment menu.

To use a touch tracks object
Do one of the following:

µ Assign the touch tracks object to an arrange track.

µ Place the touch tracks object anywhere in the MIDI signal path.

Here are some things to remember:

• Only the touch tracks input has meaning—trigger notes must appear here. Although
the object features an output triangle, it has no use, as events never appear here.

• MIDI regions and folders triggered by touch tracks play exactly as they would from the
Arrange window—they play back through the instruments assigned to their tracks.

• Logic Pro must be open for touch tracks to work.
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The Touch Tracks Window
Double-clicking a touch tracks object opens the Touch Tracks window.

This window is similar to the Mapped Instrument window. The input note is selected via
the keyboard on the left, and the output region assignment and parameters are set in
the columns of the corresponding row. For details about mapped instruments, see Mapped
Instrument Objects.

A vertical gray line means that the setting is the same as the line above. If you change a
vertical gray line that is above another vertical gray line, the lower one changes to display
its previous value. (It is no longer the same as the line above.)

Region Note Assignment
Dragging a MIDI region or folder into the Environment automatically creates a touch
tracks object. All notes (initially) trigger this region. Middle C plays the region or folder
at its original pitch, and all other notes transpose it, relative to middle C.

In the Input Name column, you can see the input notes, and to the right, in the
Region/Folder column, the names of the assigned regions or folders. On the vertical
keyboard to the left, you can select individual notes or pitch ranges by dragging across
several keys. If you then drag a MIDI region or folder from the Arrange window, it will
only be assigned to the selected note (or note range).

Group
Groups behave as they do in the Hyper Editor. When you trigger a region, any other
(currently playing) region in the same group stops.

The Off setting means that the region is not assigned to any group.
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Transpos (Transposition)
When you drag a region to a key in the Touch Tracks window, that key triggers the region
at its original pitch (without transposition). If you want to transpose the region, you can
set the amount in the Transpos column.

If a key range is selected when you drag the region into the Touch Tracks window,
incremental transpositions are set automatically for adjacent keys (within the key range).

When you create a touch tracks object by dragging a region into the Environment, C3
triggers the region at its normal pitch, and all other keys trigger it (transposed relative to
C3).

Velocity
In the Velocity column, you can set the sensitivity of regions to the velocity value of the
trigger note:  by 100% (very sensitive), 50% (somewhat sensitive), or off (not
velocity-sensitive).

Trigger Modes
The Trigger column determines how region playback is handled:

• Multi: Playing the trigger note starts the region. Playing it again restarts the region,
without stopping playback of the originally triggered version.

• Single: Playing the trigger note once starts the region. Playing it again stops playback,
and restarts the region.

• Gate: The region plays until the trigger note is released (or until the region ends).

• Gate Loop: The region loops until the trigger note is released.

• Toggle: Playing the trigger note starts the region. Playing it again stops playback.

• Toggle Loop: Playing the trigger note starts region looping. Playing it again stops
playback.

Start
This column allows you to quantize region start and stop. Free means no quantization.
The Next 1/16, Next 1/4, or Next 1/1 settings start or stop the region at the next 1/16 or
1/4 note, or at the beginning of the next bar, when a trigger note is played.

Delay
This column allows you to assign a delay to the region start point. The delay is set on the
right side of the column in ticks, or on the left side in note values.

You can use both Delay and Start to make regions start at any position in the measure.
For example:  Set Start to 1/1 and Delay to 480 ticks to commence playback at the second
8th note in the measure.
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Fader Objects
Faders are used to send MIDI events by clicking or dragging them. Faders come in different
forms (knobs, sliders, numerical, and buttons). Fader objects respond to incoming MIDI
events.

To create a new fader
µ Choose New > Fader.

A submenu appears, in which you select the style of fader you want. There’s also a
submenu at the bottom named Special, used to select various special fader types (cable
switcher, meta-fader, and so on).

The style of a fader determines its onscreen appearance (slider, knob, menu, numerical),
and how it responds to the mouse (click and drag, double-click and type a number, click,
and choose from a menu).

 Horizontal fader

Vertical fader Button Knob

The auto style fader—the default style if you create a fader with a key command—changes
styles as you alter its shape and size.

The type of fader determines what events the fader sends out and responds to. In two
cases, however, the fader doesn’t send out events at all:

• The cable switcher routes events to its different outputs. Clicking a cable switcher object
makes it step sequentially through the outputs.

• The alias assigner changes the references (to an original, or parent object) of fader
aliases.

In general, a fader’s style is completely independent of its type. A cable switcher can look
like a button, a knob can send out MIDI or meta or SysEx events, and so on. The one
exception is the vector style fader—these behave in a special way, by sending out two
(or four, in special cases) messages at a time, depending on the mouse location within
their 2-dimensional, vector window.
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Don’t worry about choosing the wrong fader style or type from the New menu; you have
complete control of a fader’s style and type via the Object Parameter box.

Using Faders
Normally, you grab the surface of a fader and drag it vertically or horizontally, depending
on its style. When using the fader itself as a slider, you may notice that values jump in
larger increments, depending on the size of the fader and dragging speed. You can also
change values in single steps by dragging the slider or knob while holding down the
Control key.

Some of the fader styles have numerical displays. In these cases, double-click in the
numerical field and enter a value. When you drag any of the sliders or knobs, the series
of values that are sent out depends on the fader size and scrolling speed—not every
consecutive value is sent out at smaller sizes. If you drag slowly in the numerical field,
however, you will send consecutive values.

Knobs can be dragged either vertically or horizontally.

Buttons only send two values, the lowest and highest of their range set in the Object
Parameter box. You change a button’s state by clicking it.

The default appearance of the text fader is like a value field that can be scrolled.
Double-click to open a window that allows you to enter text for each menu position.
Select the Behaves as Menu checkbox to use the text fader as a pop-up menu.

A vector fader allows you to scroll in two directions, and sends out two values:  one
corresponding to the vertical position, and the other to the horizontal position.

Recording and Playback of Fader Movements
As with the channel strips in the Mixer, you can record fader object movements to tracks,
and play them back.
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Recording Fader Movements
You don’t need any special cabling to record the data generated by a fader. All data
generated by faders is recorded on the selected track when Logic Pro is in record or
record/pause mode.

Playing Back Fader Movements
Any fader will react to incoming events that match its Input definition. The fader must,
of course, be in the MIDI signal path.

Typically, you would accomplish this by cabling the track instrument into the fader.

For fader object automation tasks, however, it is useful to create a new (standard)
instrument for the sole purpose of fader automation. Ensure that the instrument:

• Has no direct MIDI output

• Uses the Channel setting All

• Is connected to the first fader in any chain of serially cabled faders (if cabled this way)

Working with Object Groups
When building a virtual mixing desk or synthesizer control panel in the Environment, you
often need to work with large groups of fader objects that have the same size, regular
spacing, or a similar definition.

To save time on the definition and alignment of these groups, you can choose (one or
more) objects as prototypes (templates) by copying them into the Clipboard. (Choose
Edit > Copy.) You can then apply certain characteristics of these template objects to
selected objects.

To transfer the size of the prototypes to the selected objects
µ Choose Options > Apply Buffer Template to > Size.

To transfer the alignment template of selected objects
µ Choose Options > Apply Buffer Template to > Position.

The selected target objects are positioned at the top-left corner of the Environment layer,
in accordance with the layout of the template.

The Options > Apply Buffer Template to > Position and Size command combines both
of the above functions.

• Definition: The following describes the definition characteristics that can be transferred
to selected objects.

• The Options > Apply Buffer Template to > Definition function transfers the parameters
of a copied template to all selected objects. If several templates of the same type are
available, the one that is closest in size is used.
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• The Options > Apply Buffer Template to > “Definition, channel increment” increases
the channel number from object to object, beginning with the top-left object. It is
not necessary for the selected objects to have the same Input or Output definition
as the template.

• The Options > Apply Buffer Template to > “Definition, number increment” increases
the first data byte of the definition (controller number, for example).

• Cabling Serially: The Options > “Cable serially” function connects all selected objects
in series, beginning with the object at the top left.

• Names with Numbers: If you name one object in a selected group of objects with a
name that ends in a numeral, the remaining objects will adopt the name, but with
sequentially increasing numbers. For example, selecting several objects and naming
one of them “Object 1” results in the ensuing objects being renamed “Object 2,” “Object
3,” “Object 4,” and so on.

Fader Styles
A fader’s style is shown in the line under the icon. It can be changed by selecting the
current style name and choosing a new style from the pop-up menu.

Remember that a fader’s style does not usually affect its function—you can select the
most convenient style for the intended use of the object.

Some of the fader styles are described below.

Vertical/Mute
This is exactly like the Vertical 4 fader style, with an added Mute button.

When you click the Mute button, the fader sends an event (with a value of 0) that matches
the Output definition.

• The fader’s movements are not sent while the Mute button is on.

• The current fader value is sent when you turn the Mute button off.
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Buttons
Button style faders can only send two possible values:  the minimum and maximum values
of their range.

• When on, the maximum value is sent.

• When off, the minimum value is sent.

If the minimum and maximum range parameters are set to the same value, the button
sends this value each time it is clicked.

Text
Text faders function like numerical faders, but can display text for each of the 128 possible
MIDI values (0 to 127). Double-clicking the surface of a text fader opens the Text Fader
window.

• Click a position in this window to send the corresponding fader value. (This is similar
to selecting programs by name in the Multi-Instrument window.)

• Double-click a position in the window to enter new text. By default, when you create
a text style fader, the text positions contain numerical values. You can use this feature
to create numerical style faders with colored backgrounds.

You can modify the following parameters in the Text Fader window:

• Clipboard Functions: The Options pop-up menu at the top-right corner of the Text Fader
window provides Cut, Copy, and Paste functions. You can use these operations to
transfer the entire list of names to a text editor, for more convenient editing.

• Empty lines (and lines that only contain spaces) are ignored.

• If you want to insert blank positions in the list, use Option-Space bar.
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• Behave as Menu: Select the Behave as Menu checkbox to make the text fader act like
a pop-up menu. When this box is unselected, the text fader acts like a scrolling menu.

• Text Fader Range: The Range parameter determines the number of names that can be
entered into a text style fader object. If you set a text style fader’s range to “0, 1” you
can only enter two values.

You should always set the minimum necessary range for a text fader, as this saves
memory. In any case, remember that the first name corresponds to the lowest value
in the range (not necessarily 0), and the last name corresponds to the highest value
(not necessarily 127).

If you force a text fader to a value outside its range (with MIDI input) it displays “---”
for values below its range and “+++” for values above. The one exception is when the
fader’s range is 0/1; in this case, all values above 1 display the name for value 1.

Fader Functions:  MIDI Events
Each fader has an Input definition and an Output definition.

• The Input definition determines the types of MIDI events that can remotely control the
fader (the event types it reacts to).

• The Output definition determines the types of MIDI events the fader sends out.

A fader can, therefore, convert one type of MIDI event to another.

Most MIDI events consist of three bytes:

• The first byte indicates the type and channel of the MIDI event (a note on channel 3,
for example).

• The second byte indicates the first data value (the pitch of a note event, for example).

• The third byte indicates the second data value (the velocity of a note event, for example).

A few MIDI events only use two bytes (program change and aftertouch). Some objects,
such as Faders (and Transformers) always provide for three bytes, with the second byte
being discarded when these special, 2-byte messages are received.

Fader parameters are provided for setting the message type, MIDI channel, and the first
data value. Note that the message type and MIDI channel are actually combined in the
resulting MIDI event. The second data value is determined by the fader setting, or if the
fader is being remotely MIDI-controlled, by the incoming MIDI event.

Input and Output Definition Parameters
These are used to define the Input and Output parameters:

• Output (or Input): Defines the event type.

• Channel (1 to 16): Defines the MIDI channel of the event.
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• -1- (0 to 127): Defines the first data byte of the event. In some cases, such as pitch bend,
this is an actual data value. In other cases (MIDI controllers), this indicates the controller
type (volume, pan, and so on). In other cases, such as aftertouch, this byte is unused.

Setting the -1- Parameter and Fader Position
This section outlines each of the -1- parameter options, and explains how the fader
position affects them (for both the Input and Output definitions).

• Note On: The -1- parameter sets the pitch, and the fader position sets the velocity. This
is most useful as an Input definition, for trapping specific notes and converting them
to other MIDI events, or simply monitoring their velocity. If you move a fader with an
Output definition set to Note On, a note off MIDI event immediately follows the note
on. This might be useful for creating onscreen drum pads from button style faders, for
example.

• P-Press: The -1- parameter sets the pitch, and the fader position sets the amount of
Poly Pressure (key pressure or polyphonic aftertouch).

• Control: The -1- parameter sets the MIDI controller number (the controller type), and
the fader position sets the controller value. The controller type can actually be selected
by name, via the pull-down menu that appears when you click-hold the 1- parameter.

• Program Change: The -1- parameter is ignored. The fader position determines the
program number.

• C-Press: The -1- parameter is ignored. The fader position sets the channel pressure
(monophonic aftertouch) amount.

• PitchBd: The -1- parameter sets the pitch bend LSB, and the fader position sets the
MSB. Typically, you would set the -1- parameter to 0, and use the fader to control the
coarse pitch bend amount. A -1- setting of 0, and a fader position of 64, results in no
pitch bend.

SysEx and Switcher/Meta are special functions of the faders.

Fader Functions:  Range, Value As
These parameters determine the minimum and maximum values of a fader, and how the
fader displays these values.

Range
The range parameter contains two numbers—the left one sets the lowest possible fader
value, and the right one sets the highest. Note that these limits can be exceeded by MIDI
remote control. When the fader style is a button, the range determines the in and out
position values of the button.

For text style faders, the first name always corresponds to the low end of the range, and
subsequent names correspond to incremental range values, up to the top range. The
number of names that can be entered into the window is limited by the range.
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Value As
This parameter determines the way that numerical values are displayed by the fader.

• Number: The fader value is displayed as a number (0 to 127).

• Pan: Fader value 64 is displayed as “0”; smaller values appear as negative numbers and
larger values as positive numbers (–64 to 63).

• Hz, Octave, dB, ms: These display formats are tailored to various DSP functions.

• bpm: An offset of 50 is added to the fader value. This displays the correct tempo settings
for the Special > Tempo Control fader.

If none of the above formats is suitable, consider using a text style fader, and entering
the display values you want as text. Examples include percentages, note names, and
program names.

Fader Functions:  Filter
This parameter provides various filtering options for MIDI events:

• Off: All incoming MIDI events are allowed to pass through. All events that match the
input definition are converted, in accordance with the output definition.

• Other: All MIDI events that do not correspond to the input definition are filtered. All
events that match the input definition are converted in accordance with the output
definition, and allowed to pass through.

• Match: All MIDI events that match the input definition are filtered; all others are allowed
to pass.

• All: All incoming MIDI events are filtered.

• Thru: All MIDI events coming from the Physical Input object are filtered. This is the
same as turning off all events coming from Logic Pro (from regions or the Environment).

Use this filter mode to prevent MIDI feedback by blocking incoming MIDI events from
being sent back out.

• Shot: When the fader is moved with the mouse, only the final value (the value when
the mouse button is released) is sent.

• 14 Bit: The result of using this filter setting depends on how it is used.

• Used in conjunction with pitch bend, this allows 2-byte (fine-tuning) pitch bend
events.

• Used with controller messages, this causes the fader to send two MIDI controller
messages:  one for the MSB (Most Significant Byte) and one for the LSB (Least
Significant Byte).

Note: The fader’s Input and Output definitions must be the same or the 14 Bit setting
will not work.
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For controllers, the MSB uses the Input definition controller number, and the LSB uses
the controller number 32 or higher. This conforms to the MIDI standard for sending
14-bit controller data.

When this filter setting is chosen, the fader’s Range can be set to a maximum value of
16,383. A fader value of 8192 represents no pitch bend.

• Feedback: When the Feedback parameter is turned off (unselected), the fader
automatically prevents feedback loops resulting from circular cabling. (The fader
remembers when a specific MIDI event has passed through it and will not allow it to
pass through again.)

In some instances, you may want to enable feedback—to allow a MIDI event to change
a cable switcher’s position after it has passed through the switch, for example. Selecting
the Feedback checkbox will allow this.

Vector Fader
Vector faders function like joysticks. They can be moved in two dimensions:  up and down
and left and right. Each dimension generates its own MIDI events, so each time you
change the position of the crosshair with the mouse, two MIDI events are sent.

Most faders have Input and Output definitions, which determine the MIDI events sent by
the fader (Output), and those it reacts to (Input). (See Fader Functions:  Range, Value As.)

The vector style fader replaces these with Vert and Horz definitions, which determine the
MIDI events that correspond to vertical and horizontal motion. If corresponding MIDI
events are received by the vector style fader, its crosshair display updates accordingly.
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4-Channel Vector Mode
If you set a vector fader’s Vert and Horz definitions to the same MIDI event (the same
MIDI controller and channel), the vector fader sends out four MIDI events each time the
crosshair is moved.

These are the same MIDI event (a controller, for example), sent on four consecutive MIDI
channels, starting with the channel set in the Vert definition.

• Upper-left for the lowest channel (channel 3, for example)

• Upper-right (channel 4)

• Lower-left (channel 5)

• Lower-right (channel 6)

The values of these MIDI events correspond to the proximity of the crosshair to the vector
fader’s four corners:

• In the center, all channels receive a value of 32.

• At the corners, the corresponding channel receives a value of 127 and all remaining
channels receive a value of 0 (if using the default range of 0 to 127).

If you alter the range, the center and corners behave differently, with the four values
always totalling 125.

Special Faders Overview
The Environment provides a number of special fader objects that are purpose-built to
perform certain functions.

Cable switchers, alias assigners, and meta messages are types of faders that do not
generate MIDI events. They share the same Output definition type, either SwitchGM Mixer
Objects or Meta, depending on the current -1- value setting:

• If the -1- value is 48, the fader is a cable switcher.

• If the -1- value is 46, the fader is an alias assigner. (See Meta Event Faders.)

• If the -1- value is any other value, the fader sends out meta messages of a type that
corresponds to the -1- value. (See Meta Event Faders.)

To create a cable switcher
Do one of the following:

µ Choose New > Fader > Specials > Cable Switcher.

µ Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 48.

To create an alias assigner
Do one of the following:

µ Choose New > Fader > Specials > Alias Assigner.
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µ Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 46.

To create a meta type fader
Do one of the following:

µ Choose it from the New > Fader > Specials menu.

µ Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to the
desired meta event number.

Cable Switchers
Cable switcher objects route events, rather than generate them. Any kind of MIDI or meta
event can be routed by a cable switcher. The only exception is events that match the
cable switcher’s Input definition. These events will change the switch position (the routing),
rather than pass through the cable switcher.

A cable switcher can be assigned to any fader style. It is practical to use the text fader
style, as it allows you to label the switcher’s various routes. Use the auto style to actually
display the switch routing, as shown here.

A cable switcher can have up to 128 separate cable outputs—a new output is generated
each time an existing output is cabled to another object. You can click an auto style cable
switcher to step through the outlets (including the last, uncabled one).

Incoming events that match the cable switcher’s Input definition change the switch
position to that of the incoming data value. (If the data value is greater than the number
of switch positions, the last, uncabled outlet is selected.)
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Data values of 126 and 127 have a special effect.

• An event with a value of 127 increases the output number. If you’re on the switcher’s
last output when this event is received, you’ll jump back to the first output. This is just
like clicking the fader.

• An event with a value of 126 decreases the output number. If you’re on the switcher’s
first output when this event is received, you’ll jump to the last output.

Meta Event Faders
Meta faders generate special meta events, which are used to control certain Logic Pro
functions, but have no MIDI meaning, and are never sent to the MIDI output.

In some cases (such as Go to Screenset, Go to Project, and so on), you do not need to
cable meta faders into another object for them to work. Even in these cases, you can use
cabling to process meta events in the Environment, and alter their effect.

However in the majority of cases (Set fader range minimum, Bang!, Set Transformer
Operation Minimum, and so on), the meta fader must be cabled to the object being
affected.

Here’s a quick summary of the currently implemented meta events that can be generated
by faders:

Controlled Logic Pro functionMeta event

Assign Alias46

Go to Screenset49

Go to Project50

Go to Marker51

Stop Playback52

Set fader range minimum96

Set fader range maximum97

Set the fader value without sending98

Bang! Causes the fader to resend its current value. The bang data
value can be used to make the fader increment-without-rollover
(127), decrement-without-rollover (125), increment-with-rollover
(123) or decrement-with-rollover (121). Use values one less than
those shown to have the bang passed through to all connected
faders.

99

Tempo Control (See Using the Tempo Fader.)100

Set transformer map value for the currently selected map position122

Select transformer map position123

Set transformer condition maximum (bottom) parameter, if any.
(This applies to all conditions not set to All.)

124
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Controlled Logic Pro functionMeta event

Set transformer condition minimum (top) parameter, if any. (This
applies to all conditions not set to All.)

125

Set transformer operation maximum (bottom) parameter, if any.
(This applies to all operations not set to Thru.)

126

Set transformer operation minimum (top) parameter, if any. (This
applies to all operations not set to Thru.)

127

For more about meta events 124 to 127, see Using Meta Events to Control Condition and
Operation Values.

Go to Marker
Choosing New > Fader > Special > Go to Marker creates a fader that allows you to enter
a marker number (meta event 51).

The playhead moves instantly to the chosen marker number. Markers are numbered
sequentially, throughout the project, even if you have renamed them (from the default
numbers assigned when each marker was created).

Go to Screenset
Choosing New > Fader > Special > Go to Screenset creates a Screenset fader (meta event
49), allowing you to switch to the screenset number chosen with the fader.

Meta event 50 has no effect within Logic Pro, but you can use it to switch between songs
on an external hardware sequencer.

Meta event 52 allows you to interrupt playback at any position.

Note: To make the most efficient use of these faders, limit the value range to suit your
particular circumstances. For example, limit the faders to the number of markers or
screensets you’re actually using.

Working with SysEx Faders
The SysEx fader type is slightly different from other fader types. It allows you to create a
list of MIDI events that will be sent whenever the fader is moved or controlled remotely.
You can enter the messages that you want to send in a window that resembles the Event
List.

To open the SysEx Fader window
Do one of the following:

µ Set a fader’s Output or Input definition to SysEx.

The SysEx Fader window opens automatically.

µ Double-click the word SysEx in the fader’s parameter box.
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The positions of events in the list only control the order in which they are sent—they are
not sent at specific times, nor with any delay between them.

The SysEx fader type is primarily designed to send MIDI System Exclusive (SysEx)
messages—messages that are exclusive to individual manufacturers’ MIDI devices. There
are a number of features in the SysEx fader window that facilitate the creation of SysEx
messages.

Note: SysEx faders can actually be used for any kind of MIDI event, making them handy
for sending ordered batches of messages, such as Mixer or control panel snapshots, with
one click of the mouse.

You can also specify SysEx as an Input definition, but this has limited usefulness because
the incoming message (presumably SysEx) must be very short in order to be recognized.
(Because SysEx messages can be of any length, Logic Pro must break them into small
packets to avoid interrupting other MIDI activities.)

An important thing to remember about the SysEx fader is that only selected events will
have their value altered by the fader value when the SysEx fader window is closed. Events
that are not selected will be sent exactly as they appear in the window.

The value shown in the Val column (of selected events) is altered, if normal MIDI events
(controllers, program change, aftertouch, and so on).

For SysEx messages, you can determine:

• Which bytes are altered

• The format (MSB/LSB, BCD, nibbles, and so on) of the value

You can also specify a checksum format, if necessary.

Working with SysEx Messages
There are two ways of entering SysEx messages in the SysEx fader window. One way is
to have the fader learn the SysEx string.

To teach the fader to learn a SysEx string
1 Click the MIDI In button at the top-left corner of the SysEx window. If the button is pressed,

it is ready to receive incoming MIDI data.

2 Alter the parameter on your device.
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The corresponding SysEx message is displayed and the MIDI In button turns off
automatically.

A second way of entering SysEx messages in the SysEx fader window is to type the SysEx
string into the Event List. (Consult your MIDI device manual for SysEx documentation.)

To manually enter SysEx strings
µ Click the Create button, then click the SysEx button.

A generic SysEx message appears.

• The first data byte in the top line (directly after the word SysEx in the Num column) is
the manufacturer’s ID. This may be several data bytes long (as there are more than 128
manufacturers of MIDI devices).

• The manufacturer’s ID is usually followed by a device type ID, an individual device ID,
a data type ID (which could be several bytes) and, if necessary, the number of the
multi-timbral sub-channel, and the identification number(s) of the sound parameters
plus the value of the sound parameter. There are no uniform standards that apply here.

• Data bytes are normally input as decimal numbers. To enter them in hex, place a $ in
front of values when you type them. Choose View > SysEx in Hex Format to see all
values in hexadecimal.

• The last data byte (the EOX indicating the end of the SysEx message) is entered
automatically by Logic Pro. The number of data bytes in the SysEx message can be
decreased or increased by clicking the plus and minus symbols before and after the
word <EOX>.
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Although you can have any number of messages (of any kind) in the SysEx fader’s Event
List, there is only one fader value, and all selected messages adopt this value.

You can use a similar method to create any kind of MIDI or meta event in the SysEx fader
window. Command-clicking any of the eight event type buttons (Note, Program Number,
Pitch Bend, Controller, Channel Pressure, Poly Pressure, SysEx, and Meta Event) creates a
new event of that type. Meta events can be created by using the expanded view button,
featuring the 0’s and 1’s on its face.

The terms SUM (for the checksum) and VAL (for the fader value) being sent are displayed
within the SysEx string.

To set the checksum and value of a SysEx event
1 Select the events you want to alter.

2 Choose options from the Checksum and Value menus (found in the lower-right corner
of the window) to set the format of these bytes.

Checksum Format
A checksum can be created in any of the following formats:

• Roland

• Yamaha

• Regular Checksum

• 2’s complement

• 1’s complement

If you don’t know which one works with your MIDI device, try “off” (= no checksum) first
or “2’s complement.”

Value Byte Position
Position allows you to determine the position of the value byte. This position is specified
in bytes, counted from the end of the message:  “last” refers to the position directly before
the EOX byte, “Last-1” indicates the byte before that, and so on.

Auto ensures that the value byte is inserted at the last position in the SysEx string if no
checksum was selected, or—if a checksum value was entered—that the value is inserted
as the second-to-last byte.

Value Byte Format
The following table outlines the resulting data format of the value option you send:

ResultValue option

The value is sent as one byte if the value range maximum is 127 or
less. If the maximum is higher than 127, the value is sent as two
bytes, the MSB (most significant byte) first.

Auto
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ResultValue option

The value is sent as one byte.One Byte

The value is sent in two bytes, with the MSB (most significant byte)
first.

MSB/LSB

The value is sent in two bytes, with the LSB (least significant byte)
first.

LSB/MSB

The value is sent as Binary Coded Decimal in four bytes, in the order
1, 10, 100, 1000.

BCD 4 LSB

The value is sent as Binary Coded Decimal in four bytes, in the order
1000, 100, 10, 1.

BCD 4 MSB

The value is sent in two nibbles, with the least significant nibble
first.

2 Nibbles L

The value is sent in three nibbles, with the least significant nibble
first.

3 Nibbles L

The value is sent in four nibbles, with the least significant nibble
first.

4 Nibbles L

The value is sent in two nibbles, with the most significant nibble
first.

2 Nibbles M

The value is sent in three nibbles, with the most significant nibble
first.

3 Nibbles M

The value is sent in four nibbles, with the most significant nibble
first.

4 Nibbles M

The value is sent in two nibbles, the most significant nibble first;
the nibbles are sent in ASCII format for the hex value. For example,
the value $7F (= 127 in decimal) will be transmitted as a 7 and F.

2 ASCII M

Same as 2 ASCII M, but in 3 nibbles.3 ASCII M

Same as 2 ASCII M, but in 4 nibbles.4 ASCII M

The unused bits of the transfer in nibbles (X in 0XXXNNNN) are sent with the information
at the relevant positions of the SysEx strings. If you want to transfer these deleted bits,
you need to enter zeros in the SysEx string.

Special Functions
Several behaviors and commands enhance the use of fader objects.

Temporarily Grouping Faders
If you drag to select or Shift-click to select several faders and move one of them, all
selected faders move proportionately.

As long as all faders remain selected, their relative positions are retained (even after one
or more of the faders has reached its minimum or maximum position).

• Option-dragging any fader in the group changes all values in a linear fashion. (The
absolute value differences are maintained.)
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• Shift-Option-dragging any fader in the group changes all faders to the same value.

Sending Fader Values
You can use Options > Send All Fader Values (or use the Send All Current Fader Values
key command) to make all fader objects send their current values.

Use Options > Send Selected Fader Values (or use the corresponding key command,
default assignment:  Control-V) to make all selected fader objects send their current values.

Use of these commands in conjunction with the Record/Pause mode allows you to record
a snapshot of all current fader positions. This is especially useful for virtual mixing desks,
or synthesizer panels.

The File > Project Settings > MIDI > General > “Send After Loading Project:  All fader
values” option automatically sends all fader values after a project is loaded.

Resetting Fader Values
Choose Options > Reset Selected Faders to set all selected fader values to zero, and
transmit the data.

Alias Objects
You can create an alias of any Environment object, and it will behave exactly like the
original. In the case of faders, the alias has its own value (which can be different from the
value of the original object). This is particularly useful if using text faders, as they consume
a lot of memory. If you need several text faders of the same name, make several aliases
of one original object.

To create an alias of any object
µ Select the object, then choose New > Alias.

Aliases can be reassigned with meta events. You use a special fader, known as the alias
assigner (which works something like the cable switcher), to accomplish this.

To create an alias assigner
µ Choose New > Fader > Specials > Alias Assigner.
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This creates a meta fader, with a -1- definition set to 46.

To use the alias assigner, cable its top output to the alias, and cable subsequent outputs
to the various originals that you want to assign to the alias. If you set the alias assigner’s
maximum range to match the number of originals and its minimum range to 1, you can
then connect the next cable to a new alias, and subsequent cables to originals for the
alias. In this way, the alias assigner can be used to assign multiple aliases simultaneously.

One situation in which you might use an alias assigner is when switching a delay line
alias between different originals (different delay line objects), each set to different delay
times. This method is one of several ways to provide MIDI control over delay time.

If you copy an alias, you create a new alias of the same original. If you select and copy
both an alias and its original, you create a copy of the original with its own, separate alias.

Alias Parameters
Aliases share the parameters of their parent (original) objects, but they also have their
own, special parameters.

Reference
The Reference menu is used to select the original on which the alias is based.

Channel
The Channel parameter rechannelizes all events (except fader events), leaving the alias
to the selected channel. If the Channel setting is All, existing channelized events are not
changed.
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For faders, the Channel parameter causes the alias to act as if the original fader’s Input
and Output definitions are both set to the specified channel. (An All setting results in no
change.)

Share Name and Share Size
When selected, the alias shares the size and name of the original. If unselected, it can be
resized and given its own name.

Ornament Objects
Ornaments are simply solid backgrounds behind other Environment objects. An ornament
never covers other objects, so you can select multiple objects by dragging them without
selecting the ornament itself.

To create an ornament
µ Choose New > Ornament.

GM Mixer Objects
The GM mixer is a collection of 16 fader modules, configured to emulate a virtual mixing
desk for 16 MIDI channels. Each module includes controls for volume, mute, preset, and
bank, and four assignable knobs (one of which is typically used for pan). There are optional
controls for standard XG and GS effects.

To create a new GM mixer
µ Choose New > GM Mixer.
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The GM mixer is intended for controlling the 16 channels of a MIDI device which conforms
to the GM, XG, or GS standard. This includes the GM set of 128 program names (with
variation banks for XG or GS), MSB/LSB bank select messages, and standard controller
names (#1 for mod wheel, #2 for breath, #7 for volume, #10 for pan, #11 for expression,
and so on).

The Parameter Box of the GM Mixer
Most of the GM mixer’s setup is done in the mixer itself, but there are also a few parameters
in its Parameter box.

Port and Channel
Like the instrument and multi-instrument objects, the GM mixer can also have a direct
MIDI output connection. It is set with the Port parameter.

The Channel parameter determines the channel number of the lowest GM mixer module.
You can use this (coupled with resizing the GM mixer) to create sub-mixers for any
continuous string of MIDI channels (1 to 4, for example).

Legend
The Legend parameter turns the display of the legend along the left edge of the GM mixer
off and on.

The legend indicates what the rows of controls do, and is also used to set the function
of the top four rows of knobs. After the GM mixer is set up, you can hide the legend to
save space.
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Bank
The Bank parameter hides or shows the bank MSB/LSB display at the bottom of the
GM mixer. You can save space by hiding the bank display, unless you need to select
program banks numerically.

Working with the GM Mixer Channel Strips
The MIDI channel strips work as a remote control for the mixing parameters of the
controlled sound modules and synthesizers (volume and pan, for example).

Choosing a Program or Bank
If your sound source understands bank select events, you can choose the bank number
with the Bank parameter field at the bottom of each channel strip (only visible if the Bank
parameter in the Object Parameter box is selected). Remember that not all synthesizers
support bank select events. You can use several different bank select formats (see Mapped
Instrument Objects).

The Program button allows you to select a sound by name. Click it to open a menu that
contains all GM sound names. Each channel has its own menu.

Adjusting the Level of a Channel
The Level fader controls the output level of a MIDI channel. Adjusting it sends controller
7 via your MIDI interface.

To adjust the output level of a channel
µ Drag the Level fader up or down.

Muting a Channel
The Mute button switches the volume of the channel between zero and the current Level
fader position. In practice, this means that if the button is down, the channel is muted.
If you turn the Mute button off, the current Level fader position (and value) is used.

To mute or unmute a channel
µ Click the Mute button of the channel.

Assigning the Knobs to Controllers
You can assign any controller to each of the knobs.

To assign a controller to one of the knobs
1 Click the label next to the knob.

1120 Chapter 37 Environment Objects Reference



2 Choose the controller you want from the menu that appears.

Extended GM, GS, and XG Functions
In addition to the GM Standard, there are extended standards created by Roland (GS) and
Yamaha (XG).

GS and XG mode allow you to select different effect programs, and to control the level
of the reverb and chorus effects.

To display the GS or XG effects
µ Choose GS/XG Effect Controls from the local View menu in the Mixer.

The GS/XG configuration control is displayed in the upper-right corner of the Mixer,
allowing you to select different effect programs.

To configure GS or XG effects
1 Choose the standard you want from the first pop-up menu in the upper-right corner of

the Mixer.

Depending on your selection, the controllers for the extended effects appear.

2 Select the reverb or chorus effect from the second pop-up menu.

3 Program the reverb or delay time by double-clicking the Time parameter, then entering
a value in the input field.

Reseting All Controllers
The Reset button transmits a GS On or XG On command, and resets all controllers to
neutral positions. This allows you to reset all connected sound modules to their standard
settings, and begin a mix from scratch.

MMC Record Buttons Objects
The MMC record buttons object allows you to control the record-enable status of external
MMC-compatible recording devices. (See MIDI Machine Control.)

To create an MMC record buttons object
µ Choose New > MMC Record buttons.

Resizing the object allows you to determine the layout and number of track record buttons.

Select the Extra checkbox in the Parameter box to display the “V TC A1 A2” extra tracks:

• V for Video

• TC for Timecode

• A1 for Aux Track 1 (or A)

• A2 for Aux Track 2 (or B)
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Keyboard Objects
You can use a keyboard object to create notes with the mouse. A keyboard object also
displays all notes passing through it. In this sense, you can think of it as a real-time, MIDI
note on monitor. Although you can record the output of the keyboard in Logic Pro, its
main purpose is for testing and monitoring in the Environment.

To create a keyboard object
µ Choose New > Keyboard (or use the New Keyboard key command).

Apart from the Icon parameter, you can also set the following in the Object Parameter
box:

• Channel field: Sets the MIDI channel for the keyboard’s output.

• Velocity field: Determines a fixed velocity value for all notes.

• Lowest field: Defines the octave of the lowest note on the keyboard object. You can
resize the keyboard to control its range above the lowest note.

Monitor Objects
A monitor object displays all events (MIDI and meta) passing through it. It remembers
the last 32 events, with the newest events shown at the bottom of the list. You can resize
it to show from 1 to 32 events. Clicking anywhere in the body of the monitor clears all
events.
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To create a monitor object
µ Choose New > Monitor (or use the New Monitor key command).

Monitors are useful as both testing and branching devices. When coupled with objects
that have functionally different outputs (channel splitters and mapped instruments, for
example), monitor objects can be used to attach more than one output cable to the same
function.

Macro Objects
Macros are not actually Environment objects. Rather, they are collections of other
Environment objects and their cabling.

To create a new macro
µ Select all Environment objects that you want to include, then choose New > Macro.
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Logic Pro encloses all selected objects in a frame with a gray background.

If some of the objects selected when a macro is being created have cables leading to
unselected objects, these cables are deleted when the macro is created. A warning notifies
you of this. In this situation, the macro is made from a copy of the original selection of
objects, and the original collection of objects remains unchanged.

Macros are limited in size. The limit depends on the memory usage of the individual
objects within the macro. This limit is typically between 100 and 200 objects.

You can nest macros—a macro can contain other macros as objects.

To unpack a macro
µ Double-click any empty (blank) section of the macro object.

The macro reverts back to its component objects and cables.

Macros have a lot in common with standard Environment objects—you can connect
cables to and from them, they can be resized, they have their own parameters and icons,
they can be chosen as destinations in the Arrange window track list, and they can be
copied or dragged between Environment layers (including between projects).

Defining a Macro’s Input and Output
Because a macro is a collection of objects, individual objects need to be specified as the
macro’s input and output. This can be done in two ways:  by name or by default.

• If you name one object “Macro-In” and another “Macro-Out,” these will automatically
become the macro’s input and output.

• If there is no object named “Macro-In,” the upper-leftmost object becomes the macro’s
input.

• If there is no object named “Macro-Out,” the lower-rightmost object becomes the
macro’s output.

Cables leading into the macro deliver events to the macro’s input object, and cables
leading from the macro’s outlets carry events leaving the macro’s output object.
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Macro Parameters
Macros have the following parameters:

• Auto Fader checkbox: If you select a group of faders and create a macro from them,
selecting this box makes them behave as if they were cabled serially.

• Show All checkbox: This checkbox determines which objects remain visible when
integrated into a macro. When selected, all objects are visible (assuming the macro is
not resized to hide some of them). When unselected, only fader, monitors, ornament,
and keyboard objects are visible. You can change this checkbox at any time.

• No Reset checkbox: This checkbox, when active, prevents the macro from responding
to reset messages (set in Logic Pro > Preferences > MIDI > Reset Messages).

• Protected checkbox: Activate to protect a macro. Protected macros cannot be unpacked,
so make sure you’ve made a copy of the objects and cabling before creating a protected
macro.

Arpeggiator Objects
An arpeggiator object turns chords into arpeggios. It plays the currently held
notes—individually—in a selectable pattern (up, down, random, and so on), and at a
selectable speed that ranges between whole notes and 768th notes.

To create a new arpeggiator
µ Choose New > Arpeggiator (or use the New Arpeggiator key command).
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An arpeggiator features parameters for direction, velocity, speed (Resolution), note length,
start quantize (Snap), repeats, octaves, and velocity offset (Crescendo). All parameters
can be MIDI-controlled in real time, which adds immensely to its versatility.

To use an arpeggiator object, you must place it in the MIDI signal path, and Logic Pro
must be open. (For technical reasons, the arpeggiator resets on cycle jumps.)

Typically, you would assign an arpeggiator to an arrange track, and cable its output to
an instrument. You can, of course, insert it where needed in the MIDI signal path.

Once set up, you can use the arpeggiator with live MIDI input, or for MIDI region playback.
You can also record the output of the arpeggiator by cabling it into the Sequencer Input
object. If you do this, be sure you either record to a no output track, or break the
arpeggiator’s connection to a MIDI output.

The Arpeggiator Parameter Box
The Parameter box of an arpeggiator contains the following parameters:

• Direction: Determines the direction of the arpeggiated chord. You can choose between
the following settings:

• Up: Lowest note to highest note

• Down: Highest note to lowest note

• Up/Down: Up and down; highest and lowest notes repeat

• Auto: Up or down, depending on whether the second chord note arrived before, or
after, the first chord note.

• Up/Down2: Up and down; highest and lowest notes don’t repeat.

• Random: Notes play in random order.

• All: All notes play at once (useful when Repeat is on).

• Velocity: Determines the velocity values of the arpeggiated notes. You can choose
between the following settings:

• 1 to 127: Fixed velocities

• Original: The velocities of the recorded notes are retained.

• Random: Random velocities between 1 and the original value

• Key Limit: Defines the pitch range for the chord arpeggiation. Any chord notes outside
this range are passed directly to the output. This is useful when you want to solo above,
or play a bass line below an arpeggiated chord.

• Resolution: Sets the rhythmic note value (the speed in note divisions) of the arpeggio.
The None setting deactivates the arpeggiator.

• Length: Defines the length of the arpeggiated notes. The Original setting retains the
lengths of incoming (or recorded) notes.
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• Snap To: Unless this value is set to None, the arpeggiator waits for Logic Pro to reach
the next indicated note division before starting the arpeggio. This is useful for
rhythmically synchronizing the arpeggio with other MIDI data.

• Repeat : Selecting this option continues the arpeggio for as long as the chord is held
down. If the option is unselected, the arpeggio only plays through once.

• Octaves : The arpeggio can be repeated over 1 to 10 octaves.

• Crescendo: The velocity value set here is added every time the arpeggio is repeated (if
the Repeat parameter is turned on).

• Controller Base: All ten parameters of the arpeggiator object can be controlled with
MIDI continuous controller events. The Controller Base parameter determines the
controller number for the first parameter (Direction). The other parameters are controlled
by subsequent controller numbers.

When Controller Base is set to Off, MIDI control of the arpeggiator is disabled.

Transformer Objects
You can use a transformer object to select, filter, and alter MIDI events in real time.

Transformers can also process meta events, as long as they are not the meta events that
affect transformers. These particular meta events change the transformer, rather than
being processed by it. For more information, see Using Meta Events to Control Condition
and Operation Values.

To create a new transformer object
µ Choose New > Transformer (or use the New Transformer key command).

How the Transformer Object Works
A transformer object checks whether or not an incoming event matches certain conditions.
If it does, then certain operations are carried out.
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Events that do not meet the conditions may pass unchanged to the output, or may be
discarded.

The transformer can also make copies of matching events before altering them, and can
split the selected (matching) events from the unselected ones, via its two top cables.

You must place the transformer in the MIDI signal path in order to use it.

To alter the output of an instrument
1 Cable the instrument output into the transformer (removing the instrument’s internal

port assignment in the process).

2 Choose New > Instrument to create a new instrument, and assign it to the appropriate
MIDI output port.

3 Cable the output of the transformer object into this newly created instrument (which, in
essence, is simply acting as a MIDI output port.
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Configuring a Transformer Object
Double-clicking a transformer icon opens the Transformer window, where you can set
the conditions and operations.

Setting the Operation Mode
Use the pop-up menu at the top of the Transformer window to define how a transformer
handles MIDI events. You can choose between the operation modes outlined below.

Apply Operation and Let Non-Matching Events Pass Thru
MIDI events that match the condition are processed. MIDI events that don’t conform to
the condition are passed through.

Apply Operation and Filter Non-Matching Events
MIDI events that conform to the condition are processed. MIDI events that do not conform
to the condition are not passed through.

Filter Matching Events
All MIDI events that match the condition are filtered out. MIDI events that don’t conform
to the condition are passed through.

Copy Matching Events and Apply Operation
All MIDI events that conform to the condition are copied, and the copy is processed. The
original and transformed copy (plus any MIDI events that don’t conform to the condition)
are passed through. The unchanged original is parsed (processed) before the transformed
copy.
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Copy Matching Events and Apply Operation (Reverse Order)
This is the same as above, except the original is parsed after the processed copy. You
might want to use this when converting note events to pan controllers, for example. This
causes the pan message to be sent before the note. (Many synths don’t alter the pan
position of notes that are currently playing.)

Condition Splitter (True → Top Cable)
Events that match the conditions are altered by the operations, and sent to a transformer’s
top output. Events that don’t match the conditions are sent, unaltered, to a transformer’s
second output. Do not use the other outputs as nothing ever appears there.

Alternating Split
Events entering the transformer are alternated between the top two outlets. No conditions
or operations apply.

SysEx Mapper (Data Byte 1 → Position, Data Byte 2 → Value)
This transformer mode is used to create and edit SysEx messages. The Transformer window
operations are replaced by value fields that allow you to enter the structure of the SysEX
message including its length, whether or not a checksum is required, and the values of
bytes you don’t want to change in real time.

In the Conditions area, you select the type of MIDI event that will affect the data bytes
in the SysEx message. (Typically, you’ll use MIDI controller events.) Incoming MIDI events
will then change the SysEx message data bytes, according to the following rules:

• The data byte 1 value sets the position of the data byte.
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• The data byte 2 value sets the value of the data byte.

• The channel controls the action to be taken:

• Channel 1: The changed SysEx message is sent.

• Channel 2: The changed SysEx message is not sent.

• Channel 3: The unchanged SysEx message is sent.

• Channels 4 to 16: No meaning (reserved for future use).

The “Filter non-matching” checkbox prevents incoming MIDI events (that don’t control
the SysEx message) from being passed through. Typically, you’ll want this feature turned
on, to prevent interloping controller data from invading the SysEx data stream.

Track Automation Splitter (True → to Cable)
If the condition matches, incoming events are sent to the track automation of the object
connected to the top cable of the transformer, after passing through the Operation field.
With the appropriate Operation field settings, incoming MIDI data is transformed into
Fader event data, allowing the automation of any possible parameter of the connected
mixer object. Exception:  Channel volume and channel pan uses Control events.

Defining Conditions and Operations
The conditions and operations are the same as those found in the Transform window.
For more information, see Editing MIDI Events in the Transform Window. The only
differences arise from the fact that a transformer object works in real time and therefore
position and note length have no useful meaning.

Editing Pitch Bend Events
A transformer object can process 14-bit pitch bend events, which contain two discrete
data bytes:  if byte 1 is changed (by addition or scaling with the -1- operation), the change
also affects the second byte.

Set the Data Byte 2 operation to Thru to ensure that 14-bit pitch bend data is processed
properly.

Using Meta Events to Control Condition and Operation Values
You can control the values of any transformer conditions or operations by using meta
events. Meta events are internal Logic Pro messages—their form is similar to MIDI controller
events, but they have no MIDI meaning, they never leave Logic Pro, and they control
internal Logic Pro parameters.

Like MIDI controller events, meta events have two data values:  the first one indicates the
type of meta event (49 to 127, but not all are used), and the second one is the event value
(0 to 127).
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Meta events 122 to 127 affect transformer parameters.

• Meta event #127 sets the first (top) operation value.

• Meta event #126 sets the second (bottom) operation value (if available).

• Meta event #125 sets the first (top) condition value.

• Meta event #124 sets the second (bottom) condition value (if available).

Note: Transformers can also process meta events, as long as they are not the meta events
listed above.

Note that all numerical condition and operation parameters used (conditions not set to
All and operations not set to Thru) will be affected by the same meta event. The status
condition and operation are not affected by meta events.

If you want to set numerical parameters individually, or leave some fixed, use separate
transformers in series.

• Meta event #123 sets the transformer map position.

• Meta event #122 sets the transformer map value for the current map position. (Use
meta event #123 to set the position first.)

Note: You can use a transformer’s Map Set operation to create these two meta events
simultaneously. When the operation status is set to Map Set, the Data Byte 1 parameter
specifies the map position, and the Data Byte 2 parameter specifies the map value at that
position. (A meta event #122 is sent with the Data Byte 1 value, followed by a meta event
#123 with the Data Byte 2 value.)

You can create meta events with a fader object, you can transform MIDI events into meta
events with a transformer, and you can add meta events to a MIDI region from the Event
List. When you use a fader, set the Output definition to meta, then set the Data Byte 1
value to the meta event number.

You can remotely control any fader by changing its Input definition, allowing you to use
faders (as well as other transformers) to convert MIDI events to meta events for the remote
control of transformers.
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Delay Line Objects
A delay line object repeats (echoes) MIDI events passing through it, at intervals ranging
from one tick to 256 whole notes.

To create a new delay line object
µ Choose New > Delay Line.

As with the arpeggiator, you need to place a delay line object in the MIDI signal path,
and Logic Pro must be in playback mode. The echoes of each incoming event are sent,
sequentially, to each cabled output of the delay line object:  event 1 to cable 1, event 2
to cable 2, and so on. Obviously, if only one cable is connected, then all events are sent
to that output.

The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 whole
notes. You can also suppress the original note events.

The Delay Line’s Parameter Box
The delay line’s Parameter box offers the following parameters:

• Thru Original checkbox: If this parameter is turned on, the original events are passed
thru. If the parameter is turned off, the original events are suppressed (which means
that only the echoes will be heard).

• Repeats field: Defines the number of event repeats. The 0 setting turns the delay line
off.

• Delay field: The delay time between the individual repeats. The left value is in divisions,
and the right value in ticks.
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• Transposition pop-up menu: Defines the transposition of note events per repeat.

• Velocity field: Defines the change in the velocity values of note events per repeat.

Voice Limiter Objects
A voice limiter object restricts the number of MIDI notes (1 to 32) that can be held
simultaneously.

It does this by note stealing—newly arriving notes cause (some of the) currently held
notes to be turned off, once the voice limit is reached.

To create a new voice limiter
µ Choose New > Voice Limiter (or use the New Voice Limiter key command).

Normally, you assign a voice limiter to an arrange track, and cable its output to the
instrument object that you want to voice limit. Alternately, you can cable it between the
instrument object that you want to voice limit and an instrument object used to represent
a MIDI Out port.

The Voice Limiter Parameter Box
The voice limiter’s Parameter box offers the following:

• Voices field: Defines the maximum number of voices that can be played simultaneously.

• Priority pop-up menu: Defines which notes are stolen (turned off ) when the number of
held notes exceeds the limit (determined by the Voices parameter).

• Last: The earliest notes (those played first) are turned off first.

• Top: The lowest (pitched) notes are turned off first.

• Bottom: The highest (pitched) notes are turned off first.
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Channel Splitter Objects
A channel splitter routes MIDI events by channel. Every MIDI event received at the channel
splitter input is automatically routed to the output that corresponds to its MIDI channel.

If no cable is connected to the corresponding output channel, the event is rerouted to
the SUM output (at the top).

To create a new channel splitter object
µ Choose New > Channel Splitter (or use the New Channel Splitter key command).

Chord Memorizer Objects
A chord memorizer maps individual notes to chords. You can assign one chord to each
pitch class (to C, C#, D, and so on).

The octave of the incoming note determines the octave of the resulting chord. A chord
can have 0–12 notes in it. (Zero and one-note chords can be useful for creating scale-filters
and scale-correctors).

The easiest way to use a chord memorizer is to connect its output to the instrument that
you want to play the chords through, and assign it to an arrange track. You can, of course,
place it anywhere else in the MIDI signal path.
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To create a new chord memorizer
µ Choose New > Chord Memorizer from the local Environment menu (or use the New Chord

Memorizer key command).

The Chord Memorizer Parameter Box
You can set the following parameters in a chord memorizer’s Object Parameter box:

• Channel field: All chord notes are sent to the defined channel.

• Key Limit field: Notes within this range are mapped to chords. Notes outside the range
are passed through unaltered.

• Transposition pop-up menu: The output chords are transposed by the amount set here.
For example, if you map C to a chord consisting of CEG, and set Transposition to 1,
then C is mapped to C#FG#.

• Key field: The entire chord map is transposed by the amount set here. For example, if
you map C to CEG, and set Key to 1, then C# is mapped to C#FG#.

• Cable Split checkbox: Select to send all notes triggered by a chord assignment to different
chord memorizer object outputs (different cables).
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Working in the Chord Memorizer Window
Double-clicking a chord memorizer opens the Chord Memorizer window, where you can
set up chord definitions.

The top keyboard is used to input and display the incoming note, and the lower keyboard
is used to input and display the assigned chords. Notes can be entered with the mouse,
or a MIDI keyboard.

Remember to only use notes that fall within the key limit range on the top keyboard.
Also remember that you can only define one chord for each of the 12 pitch classes (C,
C#, D, and so on). If necessary, you can use more than one chord memorizer object to
define more chord types for each pitch class.

To enter chords with the mouse
1 Click the input note on the top keyboard.

All notes in the associated chord are inverted on the bottom keyboard.

2 Click notes on the bottom keyboard until the inverted notes of the desired chord are
shown.

You don’t need to stay within the same octave as the input note.

When you’ve entered the notes for your chord, select another input note (on the top
keyboard), or close the Chord Memorizer window.

To enter chords from your MIDI keyboard
1 Play the input note.
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2 Select the Listen checkbox in the Chord Memorizer window.

The lower keyboard is inverted, indicating its readiness to record.

3 Play the notes of the desired chord.

You can play them one at a time, or as a chord. If you make a mistake, deselect the Listen
checkbox, then select it again to start over.

When you’ve entered the notes for your chord, deselect the Listen checkbox and play a
new input note, or close the Chord Memorizer window.

Physical Input Objects
The Physical Input object represents the physical inputs of your MIDI interface. You can
only have one of these objects in the Environment.

The Physical Input object receives MIDI signals from the inputs of the MIDI interface(s)
connected to your computer. This object has a total of 65 outputs.

The outputs follow the input assignment of all connected MIDI interfaces. The top output
(SUM) carries the MIDI events for all individual outputs that are not cabled separately.

Remote control events are intercepted at the Physical Input object, and are not passed
through to its outputs. Because of this interception, remote control events will not reach
the Environment, or be recorded on Arrange window tracks.
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To create a Physical Input object
µ Choose New > Physical Input.

To make use of an existing object, drag it onto the relevant layer. This does not affect its
cabling.

Sequencer Input Objects
The Sequencer Input object represents the MIDI input of Logic Pro. You can only have
one of these objects in the Environment.

MIDI events arrive at Arrange window tracks through the Sequencer Input object. If
nothing is cabled into the Sequencer Input object, nothing can be recorded in Logic Pro.

Typically, the Physical Input object is cabled directly to the Sequencer Input object but
other objects can be inserted between them. Candidates include a monitor, keyboard,
or cable switcher object (feeding various processors such as an arpeggiator, a delay line,
and so on).

You can also cable the output of simple or complex Environment processes into the
Sequencer Input object, in order to record the processed signal.
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By default, the Sequencer Input object records on the MIDI channel (or channels) that
the keyboard or MIDI controller (which is sending the MIDI events) is set to.

If you turn on the Sequencer Input object’s Channelize parameter, the MIDI channel
assigned to the MIDI object (of the selected arrange track) is used, and recorded. This
effectively means that if your keyboard is set to MIDI channel 7, and the arrange track
object is set to MIDI channel 3, all incoming data is channelized to (and recorded on)
MIDI channel 3.

To create a Sequencer Input object
µ Choose New > Sequencer Input.

To make use of an existing object, drag it to the relevant layer. This does not affect its
cabling.

MIDI Click Objects
The MIDI Click object is used to create note events at bar, beat, and division intervals.
These can be sent to either a MIDI port or the internal speaker.
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To create a MIDI Click object
µ Choose New > MIDI Metronome Click.

Each project can have only one MIDI Click object. You only need to create a MIDI Click
object if the one that existed when the project was created has been deleted.

There is a button on the Transport bar that turns the MIDI Click on and off.

Control-click this button, then choose Metronome Settings from the shortcut menu. This
opens the Metronome project settings. For details, see Metronome Settings. In this pane,
you can also set the MIDI Click to play during recording or playback. This dialog mirrors
the settings in the Parameter box of the MIDI Click object:  checkboxes for Bar, Beat, and
Division allow you to generate note events separately for bars, beats, and divisions. The
Channel, Note, and Velocity parameters define the MIDI channel, note number, and
velocity of generated notes. The MIDI Port parameter allows you to set a direct output
port for the metronome.
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Internal Objects
Internal objects include instruments located inside your Mac computer (such as software
synthesizers and other musical applications). Although communication with sound sources
inside the computer does not actually use MIDI, it still conforms to the MIDI communication
protocol.

Internal objects have an input, but no output. They therefore act like extra output ports,
which are hard-wired to the relevant sound generator (software instrument or application).

Apple QuickTime
The QuickTime system extension offers a software-based GM sound generator. The
QuickTime Musical Instruments file must be present on your system.

To create a virtual representation of the QuickTime synth
µ Choose New > Internal > Apple QuickTime from the Environment’s local menu bar.

This software synth is 16-part multi-timbral. As usual, you can switch sounds via program
changes; these are arranged according to the GM table. Channel 10 is always set to drum
sounds, with GM key assignments. The QuickTime synthesizer reacts to notes and program
change commands, as well as to pitch bend (volume controller #7).

The first note is used to initialize the relevant MIDI channel of the QuickTime synthesizer,
and is not played.

ReWire
You can use ReWire objects to send MIDI data to ReWire-compatible applications and
their software instruments. To connect to a ReWire-compatible software instrument, first
open Logic Pro and then the ReWire application. When shutting down, first quit the
ReWire application, then Logic Pro.

You can use the Library to create ReWire objects automatically. (See Working with ReWire
Applications.)
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To manually create a ReWire object in the Environment
µ Choose New > Internal > ReWire.

Apart from common parameters, the Rewire object offers three settings:

• Device pop-up menu: This setting refers to the ReWire application(s) that Logic Pro can
connect to. If one or more ReWire applications are open, the Device parameter displays
the names of these applications.

• Bus pop-up menu: Lets you choose the ReWire bus from all available ReWire busses. If
a ReWire application provides bus names, they are shown. If using Reason, the names
of the instruments available in the Reason Rack are shown from Bus 6 upward, in place
of numbers.

• Channel pop-up menu: Sets the MIDI channel of the ReWire object.
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Channel Strip Objects
The Environment’s channel strip object is the building block of the Environment’s Mixer
layer, the Mixer, and the Arrange channel strips. For details about channel strip types, see
Understanding Channel Strip Types in the Mixer.

Mixer layer channel strip 
object

Arrange channel strip 
object

Mixer channel strip 
object

The audio and (software) instrument tracks you see in the Arrange window are actually
routed to channel strip objects on the Environment Mixer layer.

The Mixer channel strips and Arrange channel strips are simply remote controls for the
underlying channel strip objects in the Environment Mixer layer. Their inclusion in these
other windows makes your workflow faster and easier.
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The Arrange channel strips contain a reduced parameter set of the corresponding channel
strip objects in the Environment. The channel strips shown in the Mixer window are more
configurable, but the only place you can access all channel strip options is the Environment
Mixer layer.

Important: If File > Project Settings > Audio > Automatic Management of Channel Strip
objects is active (it is on, by default), you cannot create channel strips in the Environment.
This setting, when active, means that use of the track and channel creation options in
the Arrange window will automatically create a corresponding channel strip object in
the Environment (and therefore, remote control channel strips in the Mixer and Inspector).

In a general music-making sense, you do not need to access the underlying channel strips
shown in the Environment. In fact, the only time you will open the Environment Mixer
layer is when you need to reconfigure channel strips at a system level, rerouting them to
different audio hardware, or perhaps to other applications.

Although channel strip objects are not part of the MIDI signal flow, they still allow MIDI
messages to control aspects of audio and software instrument playback in Logic Pro. Any
MIDI object can be cabled into a channel strip object, thereby feeding control data into
it.

Channel Strip Parameters
When you click a channel strip of any type (audio, instrument, aux, output, master, input,
or bus), the following common parameters are accessible:

Icon
Select the checkbox to make the channel strip accessible in the Arrange Track Assignment
menu (Control-click the track list).

Choose an icon for the channel strip from the menu that appears when you click the icon.

Device
Click the visible device name (Core Audio, for example) to reassign the selected channel
strips to a different hardware device.

Channel
Click the visible channel name (Audio 1, for example), and choose the channel strip type
from the submenus. This is how you can reassign a (newly created or existing) channel
strip object (an audio channel strip is the default for new objects) to other channel strip
types. You can choose from:

• Audio: The default channel strip type, used as the destination for arrange audio tracks.

• Input: Primarily used for compatibility with projects created in earlier versions of
Logic ProInput Channel Strip.
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• Aux: Auxilliary channel strip, used as send returns for all channel strips (via Sends), as
subgroup channels, and as individual output destinations for multi-channel software
instruments (EXS24 mkII, for example).

• Instrument: Used as the destination for arrange (software) instrument tracks.

• Output: These channel strips represent the physical outputs of your audio interface.
You can choose either mono or stereo (paired) outputs.

• Bus: Primarily retained for compatibility with projects created in earlier versions of
Logic Pro. The functions of bus objects are now performed with (the more flexible) aux
channel strips in Logic Pro.

• Master: Only one master channel can exist in a project. This is the master volume control
for all channel strip types (except external MIDI channel strips).

MIDI Channel
Allows you to choose a MIDI channel that can be used to control the channel strip.

Q-Reference
Allows you to use the transients of regions on the channel strip for audio quantization,
if part of an Edit Group. Otherwise, the checkbox is unavailable.

Flex Mode
Allows you to choose a time-stretching algorithm that can be used to process the audio
material on the selected channel strip.

Show Options
Select the corresponding checkbox to show EQs, Inserts, Sends, and I/Os on the selected
channel strip(s).

Input Channel Strip
You can only create input channel strip objects in the Environment. In general, you will
not need to do so, as all audio hardware inputs are automatically seen by audio channel
strips, and can be monitored and recorded.

Input channel strips are primarily included for compatibility with earlier versions of
Logic Pro, and for use with certain audio hardware devices. The input channel strip allows
you to directly route and control signals from your audio hardware’s inputs. Once an
input channel strip is assigned to an audio channel strip, it can be monitored and recorded
directly into Logic Pro, along with its effect plug-ins.

The signal is processed, inclusive of plug-ins even while Logic Pro is not playing. In other
words, input channel strips can behave just like external hardware processors. Aux sends
can be used pre- or post-fader.
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Input channel strips can be used as live inputs that can stream audio signals from external
sources (such as MIDI synthesizers and sound modules) into a stereo mix (by bouncing
an output channel strip).

Note: An alternative to using input channel strips in this way is the use of the I/O plug-in;
you can also click the Input Monitoring button on an audio channel strip and choose the
input(s) you want to monitor or record via the Input slot.

Bus Channel Strip
You can only create bus channel strip objects in the Environment. In general, you will not
need to do so, as all audio bussing (send/return routing via the Send slots of channel
strips) is handled by aux channel strips.

Bus channel strips are primarily included for compatibility with earlier versions of Logic Pro,
and for use with certain audio hardware devices.

Note: File > Project Settings > Audio > Automatic Management of Channel Strip Objects
must be unselected if you want to create input channel strips. (It is on, by default.)

Prelisten Channel Strip
The Environment’s Prelisten audio channel strip is used for monitoring in the Sample
Editor, Audio Bin, Loop Browser, and Browser. It is created automatically in each
project—you can find it to the right of the highest-numbered audio channel strip.
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Logic Pro allows QuickTime movie files to be synchronously viewed, making film and TV
scoring quick and easy.

This chapter covers the following:

• Opening a Movie (p. 1149)

• Using the Movie Window (p. 1151)

• Using the Video Track (p. 1152)

• Working with Movie Scene Markers (p. 1153)

• Handling QuickTime Movie Audio Tracks (p. 1155)

Opening a Movie
You can open a QuickTime movie in a separate Movie window, or can display the single
frames of a QuickTime movie in the global Video track. When a movie is opened in a
project, the upper part of the Inspector shows a closed Movie area, which can be opened
by clicking the disclosure triangle.

Movie playback follows the playhead position, and vice versa, in the Inspector Movie area,
and the Movie window.
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Note: You will need a fast hard processor to ensure smooth movie playback. If you want
to record and edit your own QuickTime movie (using iMovie or Final Cut Pro or
Final Cut Express) from a video recorder or digital camera, you may need specialized
hardware.

Important: You cannot record or edit video in Logic Pro. You can, however, replace the
soundtrack of a movie file with music, Foley, and dialogue arranged in Logic Pro.

To open a QuickTime movie
Do one of the following:

µ Choose File > Open Movie from the main menu bar (or use the corresponding key
command, default assignment:  Option-Command-O).

µ Click the Open Movie button in the global Video track.

µ Control-click (or right-click) the global Video track area, and choose Open Movie from
the shortcut menu.

µ Click any position on the Video track with the Pencil tool.

µ Locate and select the movie file in the Browser, then click the Open button.

The video is opened in the floating Movie window, in its correct aspect ratio.

Note: Only one QuickTime movie can be opened in a project. Using the Open Movie
command in a project that already contains a movie reopens a Movie window with the
same video clip. This is particularly useful if you want to open the video clip in a different
screenset. Choosing the command while the Movie window is open opens a dialog,
allowing you to choose a new movie file.

To remove a movie from a project
Do one of the following:

µ Choose File > Remove Movie from the main menu bar (or use the corresponding key
command).

µ Control-click (or right-click) the global Video track area, and choose Remove Movie from
the shortcut menu.

All references to the movie are deleted from the project.
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Using the Movie Window
You can drag the position slider at the bottom of the Movie window, or use the QuickTime
transport buttons to the right, to navigate to any position in the video file. Logic Pro (the
playhead) will “chase” to the corresponding project position. All QuickTime transport
functions interact with those of Logic Pro.

To resize the Movie window
Do one of the following:

µ Drag its lower-right corner.

µ Control-click the movie (the actual image), and choose one of the following image formats
from the shortcut menu.

• 0.5 Size: Reduces the movie to half its original size.

• Original Size: Displays the movie in its original size.

• 2x Size: Expands the movie to twice its original size.

• 3x Size: Expands the movie to three times its original size.
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• Fullscreen: Expands the Movie window to fill the full screen.

• Keep Aspect Ratio: If enabled, the proportions of the image are retained when resizing
the Movie window.

• Center: Choosing this option places the video image in the center of your screen.

Using the Video Track
The global Video track displays the loaded QuickTime movie as thumbnails. If the Video
track is not visible, see Displaying Global Tracks.

The number of frames displayed in the Video track depends both on the track height and
the zoom level of the window. All frames are aligned left, with only the very last frame
aligned to the right. This guarantees that you can always see at least the first and last
frames of a video, independent of the current zoom level. Given the left alignment of
frames, the left margin of a frame will always be displayed at the exact position of that
particular frame (except the very last frame in the movie).
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Video track settings can be adjusted in the Video preferences window.

For further details about these preferences, see Video Preferences in Logic Pro.

Working with Movie Scene Markers
Scene markers are SMPTE-locked markers:  they remain at the same absolute time position,
regardless of any tempo changes, and they are automatically deleted if the current movie
is removed from the project. Scene markers are identified by a movie frame symbol.

Creating and Deleting Movie Scene Markers
You can use the Create Movie Scene Markers function to search the movie for significant
content changes (scene cuts), and automatically generate scene markers for each of them.

The Create Movie Scene Markers function uses a fixed threshold value, which works quite
well for most types of movies (cartoons, real life, CGI, and so on).
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To search a movie for scene cuts
µ Choose a movie range in the Options > Marker > Create Movie Scene Markers menu.

The Auto Range setting follows the decision path outlined below, when determining
which part will be evaluated:

• Marquee selection

• Cycled project part

• Selected regions

• All—if none of the above criteria are met

To quickly search a movie for scene cuts, using the Auto Range setting
Do one of the following:

µ Click the Detect Cuts button in the Video track.

µ Use the Create Scene Markers (Auto Range) key command.

To remove scene markers
Do one of the following:

µ Choose the relevant option in the Options > Marker > Remove Movie Scene Markers
menu.

µ Use the Remove Scene Markers (Auto Range) key command.

Converting Movie Scene Markers
You can use the Marker List to convert a scene marker into a standard marker, and vice
versa.

To convert a scene marker into a normal marker
µ Select the scene marker in the Marker List, and choose Options > Convert to Standard

Marker.

To convert a normal marker into a scene marker
µ Select the marker in the Marker List, and choose Options > Convert to Scene Marker.
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Handling QuickTime Movie Audio Tracks
Once a movie has been opened in a project, you can make use of the Import Audio from
Movie or Export Audio to Movie commands, found in the File menu.

You can adjust the audio level and output device in the Video project settings (see Video
Project Settings).

Importing Audio Tracks From QuickTime Movies
You can import audio from QuickTime movies to your project.

To import audio from a movie
1 Select the required audio tracks.

2 Do one of the following:

• Choose File > Import Audio from Movie from the main menu bar (or use the
corresponding key command).

• Control-click (or right-click) the global Video track area, and choose Import Audio from
Movie from the shortcut menu.

3 Click OK in the dialog that appears.

The selected audio tracks are bounced to an AIFF file, and placed in the Audio Bin. A new
audio track is also created at the top of the Arrange area, and the imported audio from
the movie is added to this track. The movie name is retained and used for the resulting
audio files.

Exporting Audio Tracks to QuickTime Movies
You can export audio from the part of your project that is encompassed by the QuickTime
movie to the movie file itself, effectively overwriting the original movie soundtrack. This
is useful for sending a rough mix of your film soundtrack to other members of the
production team, for example.

To export your project to the QuickTime movie
1 Open the Sound Settings dialog by doing one of the following:

• Choose File > Export Audio to Movie from the main menu bar (or use the corresponding
key command).
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• Control-click (or right-click) the global Video track area, and choose Export Audio to
Movie from the shortcut menu.

2 Choose format options for the bounced audio file, and click OK.

3 In the dialog that appears, enter a name and target folder for the movie, and click Save.

Another dialog opens, allowing you to choose which of the original movie’s audio tracks
should be used in the new movie.

4 Select the audio track that you want to retain in the new movie, and click OK.

The QuickTime movie is exported to the selected folder; it contains all selected audio
tracks, plus the part of your project that is encompassed by the start and end points of
the QuickTime movie.
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Logic Pro offers extensive surround processing and mixing functions, for all major surround
formats. All audio signals can be positionally mixed, allowing you to place them anywhere
in the surround field. You can insert surround plug-ins into audio and instrument channel
strips, which can be routed to surround auxes or outputs.

Logic Pro records incoming multi-channel audio as interleaved multi-channel files, when
creating a surround project. Imported split multi-channel files are converted automatically.
You can also upmix or downmix non-matching signals (mono-to-multi-mono, or
stereo-to-surround, as examples), allowing the use of any audio material in your surround
projects. In most cases, the upmixing or downmixing is automatic, but it can be performed
manually, if needed. You can bounce multi-channel projects as split and interleaved
surround files.

Surround encoding or decoding does not take place in Logic Pro. The Logic Studio package
does, however, include Compressor, which allows you to encode surround files. See the
Compressor documentation for more information.

Important: To work with surround in Logic Pro, you will need an audio interface that has
the number of output channels required by the chosen surround format; for example,
six outputs if the 5.1 surround format is used. You will also need the same number of
speakers (along with appropriate amplification) to hear the channels when mixing.

This chapter covers the following:

• Knowing the Surround Formats Supported by Logic Pro (p. 1158)

• Understanding the Channels Used by Surround Formats (p. 1161)

• Configuring Logic Pro for Surround (p. 1162)

• Setting the Project Surround Format (p. 1168)

• Setting the Input Format of Channel Strips (p. 1169)

• Setting the Output Format of Channel Strips (p. 1170)

• Changing the Appearance of Surround Level Meters (p. 1172)

• Working with the Surround Panner (p. 1173)

• Inserting Surround Effect Plug-ins (p. 1177)
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• Using the Down Mixer Plug-in (p. 1178)

• Working with Multi-Channel Effects (p. 1179)

• Working with the Surround Master (p. 1182)

• Bouncing Surround Audio Files (p. 1182)

• Positioning Your Speakers (p. 1184)

• Encoding Surround Bounce Files (p. 1187)

Knowing the Surround Formats Supported by Logic Pro
This section outlines the supported surround formats.

• Quadraphonic Surround Format

• LCRS Surround Format

• 5.1 (ITU 775) Surround Format

• 6.1 (ES/EX) Surround Format

• 7.1 (3/4.1) Surround Format

• 7.1 (SDDS-Sony Dynamic Digital Sound) Surround Format

Quadraphonic Surround Format
The quadraphonic surround format consists of four full-bandwidth channels, arranged
as front left and right and rear left and right (left surround and right surround). It is an
old format used for music delivery. Mike Oldfield’s “Tubular Bells” is probably the most
popular release in this format.
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LCRS Surround Format
LCRS stands for left, center, right, and surround channel. This is the original Dolby Pro Logic
format. The surround channel (placed directly behind the listener) is a bandwidth-limited
(the treble content is reduced) monophonic channel.
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5.1 (ITU 775) Surround Format
5.1 (ITU 775) is used for a few surround standards. This is the most common of the surround
formats, and is the one you are most likely to use. The 5.1 channels are left, center, right,
left surround (left rear), right surround (right rear), and LFE.
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6.1 (ES/EX) Surround Format
The 6.1 (ES/EX) format is used for Dolby Digital EX or DTS ES. The 6.1 channels are left,
center, right, left surround, surround (rear center), right surround, and LFE.
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7.1 (3/4.1) Surround Format
7.1 (3/4.1) uses the same speaker configuration as 5.1, but adds two additional side
channels (left mid and right mid), placed directly to the left and right of the listening
position. It is designed for a big cinema, in other words.
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7.1 (SDDS-Sony Dynamic Digital Sound) Surround Format
7.1 (SDDS—Sony Dynamic Digital Sound) adds two additional speakers to 5.1 (left center
and right center). As with the other 7.1 format, this is designed for use in a large cinema,
equipped with Sony decoding and playback hardware.
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Understanding the Channels Used by Surround Formats
This section provides details on the channels used by each of the supported surround
formats.

Channels usedSurround Format

L - R - Ls - RsQuadraphonic

L - C - R - SLCRS (Pro Logic)

L - C - R - Ls - Rs - LFE5.1 (ITU 775)

L - C - R - Ls - S - Rs - LFE6.1 (ES/EX)

L - C - R - Lm - Rm - Ls - Rs - LFE7.1 (3/4.1)

L - Lc - C - Rc - R - Ls - Rs - LFE7.1 (SDDS)

Table Key
µ L = (Front) Left

µ Lc = Left Center

µ C = Center

µ Rc = Right Center

µ R = (Front) Right

µ Lm = Left Mid

µ Rm = Right Mid
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µ Ls = Left Surround (Rear Left)

µ S = Surround (Rear Center)

µ Rs = Right Surround (Rear Right)

µ LFE = Low Frequency Effects

Configuring Logic Pro for Surround
Before you can create a project in surround, you need to tell Logic Pro which outputs of
your interface are connected to which speaker. If actually recording in surround, you’ll
also need to define what inputs of your audio interface will be used. This is done in the
Output and Input panes of the Audio > I/O Assignment preferences.

Opening the Surround Preferences
There are a number of ways to open the I/O Assignment Preferences in Logic Pro.

To open the I/O Assignment preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Audio, then click the I/O Assignments tab (or use the
Open Surround Preferences key command).
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µ Click the Preferences button in the Arrange toolbar, choose Audio from the menu, then
click the I/O Assignments tab.
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Setting the Surround Preferences
The I/O Assignments tab features three sub-tabs:  Output, Bounce Extensions, and Input.
All three tabs are linked, but can be adjusted independently.

Note: As a general rule, the default settings for each surround format should meet your
needs in all but the rarest circumstances.

To set the surround channel assignment
1 Click either the Output or Input tab.

1164 Chapter 39 Working with Surround



2 Choose the surround format you want to work in from the Show As pop-up menu.

This automatically sets the input and output channel pop-up menus in the assignment
sections of both the Output and Input tabs.

Note: The surround format chosen here only alters the layout/routing of channels to
speakers in the assignment section. The actual project surround format is determined by
the Surround Format setting in Audio project settings (see Setting the Project Surround
Format).

To determine which speakers the Logic Pro outputs are sent to in the Output tab
Do one of the following:

µ Choose the output of your audio interface from each of the active pop-up menus:  Left,
Center, Right, and so on.

You can choose outputs that don’t exist for your hardware, allowing you to work on, or
create, a surround project with a computer that is not equipped for surround playback.
These are shown in parentheses. As examples:  (Output 17) or (Output 32).
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µ Click one of the three Initialize buttons below the Show As pop-up menu.

• Default: Click to activate the default setup of Logic Pro. For example, for the 5.1 format,
this means that output 1 is routed to the left speaker, output 2 to the right one, output
3 is assigned to left surround, output 4 to right surround, output 5 to the center speaker,
and output 6 to the LFE channel.

• ITU: Click to assign the International Telecommunications Union standard, used by
many professionals.

• WG 4: Click to use the WG4 standard, set by the DVD Forum for DVD-Audio.

To determine which inputs are used for each surround channel
Do one of the following:

µ Choose the input of your audio interface from each of the active pop-up menus:  Left,
Center, Right, and so on.
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µ Click one of the three Initialize buttons below the Show As pop-up menu.

• Default: Click to activate the default setup of Logic Pro. For example, for the 5.1 format,
this means that input 1 is routed to the left speaker, input 2 to the right one, input 3
is assigned to left surround, input 4 to right surround, input 5 to the center speaker,
and input 6 to the LFE channel.

• ITU: Click to assign the International Telecommunications Union standard, used by
many professionals.

• WG 4: Click to use the WG4 standard, set by the DVD Forum for DVD-Audio.
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To change the bounce extensions
1 Click the Bounce Extensions tab.

2 Enter a new extension name in any of the active fields.

For example, the default left extension “.L” could be renamed to “.Left,” or the left surround
extension “.Ls” could be changed to “.LSurr.” Don’t forget the period before the extension.

If you change your mind, click the Reset Extensions button to revert to default entries.

Note: Changing the extension has no impact on the files—it simply makes them easier
to identify. If you find the defaults clear enough, there’s no need to change them.

Setting the Project Surround Format
You can determine the surround format you want to use for a project in the Audio project
settings. By default, a new project is set to 5.1.
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To determine the project surround format
1 Open the Audio project settings by doing one of the following:

• Choose File > Project Settings > Audio (or use the Open Audio Project Settings key
command, default assignment:  Option-U).

• Click the Settings button in the Arrange toolbar, and choose Audio from the pop-up
menu.

2 Choose a format from the Surround Format pop-up menu.

Tip: Save a project that has been set up for surround format work as a template. This way
you won’t have to set the surround format every time you want to create a new surround
project. Start with the included templates, modify them as necessary, and save them as
your own templates.

Setting the Input Format of Channel Strips
The channel input format determines the mono, stereo, or surround status of the channel
strip.

The symbol on the button indicates the current status as follows:

Mono LeftStereo Right Surround

• Mono: One circle represents a mono input format. The level meter shows a single
column.
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• Stereo: Two interlocked circles represent a stereo input format. The level meter divides
into two independent columns when a stereo input format is chosen.

• Left: Two circles, left one filled, indicate a left channel input format. When this input
format is chosen, only the left channel of a stereo audio file is played back. The level
meter shows a single column.

• Right: Two circles, right one filled, indicate a right channel input format. When this
input format is chosen, only the right channel of a stereo audio file is played back. The
level meter shows a single column.

• Surround: Five circles indicate the surround channel input format. The level meter
divides into multiple linked columns (the number matches the project surround format)
when the surround input format is chosen.

To set a channel strip’s input format
µ Click-hold the button directly below the level meter on the Arrange channel strip, and

choose an input format from the pop-up menu.

Setting the Output Format of Channel Strips
You can manually set the output of all audio, instrument, aux, and output channel strips
to the chosen project surround format. Logic Pro also has a set of rules for automatically
determining the output format of specific channel strip types.

Manually Setting the Output Format of Channel Strips
You can set the output format for individual or multiple selected channel strips to surround
(or other formats).
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To set a channel strip’s output format to surround
µ Click-hold the Output slot of the channel strip, and choose Surround from the pop-up

menu.

The Pan control of the channel strip is replaced by a two-dimensional surround control.
The loudspeakers are represented by colored dots and the pan position is indicated by
a white dot that can be grabbed and moved.

To set the output format of multiple channel strips to surround
1 Select all channel strips that you want to set to surround output.

2 Click the Output slot of one of the selected channel strips, then choose Surround from
the pop-up menu.

Automatically Setting the Output Format of Channel Strips
Logic Pro automatically sets the output format of specific channel strip types, based on
a set of rules for each.

Audio Channel Strips
The channel strip of an empty audio track is automatically set to the format of the first
audio file added to it.
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If you add an audio file to a track assigned to a different output format (adding a stereo
file to a track routed to a surround output, for example), the audio file is automatically
up- or downmixed to match the output format of the channel strip.

Note: The highest possible surround format is determined by the project surround format.

Instrument Channel Strips
Instrument channel strips automatically adopt the channel format of the inserted
instrument.

If you insert a stereo instrument, the channel strip output will be stereo.

If you insert a surround instance of a software instrument (ES2 or Sculpture, for example),
the channel strip output will match the project surround format.

Aux Channel Strips
Automatically created aux channel strips adopt the format of their input source (if a stereo
channel is routed to an aux channel strip, the channel strip will be stereo). If you manually
change the output format of an aux channel strip, Logic Pro automatically upmixes or
downmixes the signal to the required format.

Changing the Appearance of Surround Level Meters
You can use the Channel Order menu in the Mixer Display preferences to determine the
order of channels in multi-channel (surround) level meters. You can choose between the
following options.

Meter 6Meter 5Meter 4Meter 3Meter 2Meter 1
Channel
order

LFECenterR SurroundL SurroundRightLeftInternal

R SurroundL SurroundLFECenterRightLeftITU

LFER SurroundRightCenterLeftL SurroundCentered

LFER SurroundL SurroundRightCenterLeftLCR
Grouped

To change the multichannel level meter order
1 Open Display preferences by doing one of the following:

• Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

• Click the Preferences button in the Arrange toolbar, then choose Display from the
pop-up menu.
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2 Click the Mixer tab, and choose an option from the Channel Order pop-up menu in the
Level Meters area.

Note: The setting you choose here does not apply to metering plug-ins, such as the
Levelmeter or Multimeter.

Working with the Surround Panner
You use the Surround Panner to place track output signals at specific speaker positions.
You can manipulate the Surround Panner directly in the Mixer or Arrange channel strip,
but it is far better to open it in a separate window.

To open the Surround Panner window
µ Double-click the Surround Panner of a channel strip.

The Surround Panner window provides a magnified view of the channel strip’s Surround
Panner, and contains additional parameters.

It is possible to open multiple Surround Panner windows simultaneously, and to save
them in screensets. The Surround Panner window also provides a Link button. If enabled,
the window updates to reflect the surround settings of the selected channel strip.

The Surround Panner offers different functionality in mono-to-surround and
stereo-to-surround channels. When used on surround-to-surround channels, it acts as a
balance control.
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Using the Mono-to-Surround Panner
If the source input is set to mono, the Mono-to-Surround Panner appears.

The most obvious element of the Surround Panner window is the surround field. You can
use it to control the surround routing of the input signal to the speaker outputs. The level
sliders and fields (shown below the surround field) provide independent control of the
Center and LFE channel levels. The extended parameters allow you to precisely control
the separation between channels.

Extended parameters

Level controls

Surround field

Surround Field
The surround field consists of the following:

• Two real time display fields, for angle and diversity. You can directly interact with these
fields by using the mouse as a slider.

• A circular grid, comprised of four concentric circles, divided into eight segments, each
of 45 degrees. The outer circle represents the minimum amount of diversity, with the
center circle representing the maximum amount of diversity.

• A further circle encloses the grid. This is actually the Diversity/Angle display (or meter,
if you prefer). As the diversity (or angle) changes, a portion of the diversity display is
highlighted.

• A square is overlaid on the grid. This is an indicator of the separation between left and
right channels, and also front and rear (surround) channels. You can directly interact
with the corners or edges of this separation square by dragging them. Alternately, you
can use the sliders or display fields in the lower section of the Surround Panner window.
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• A number of speaker icons surround the circular grid. You can change the channel
surround format directly in the Surround Panner window by clicking the speaker icons.
This activates or deactivates the respective channels. Blue speakers indicate active
channels, and gray speaker icons denote inactive channels.

• The blue dot controls the routing of the signal to the speaker outputs. You can drag
the blue dot in the surround field.

The movement of the surround position (indicated by the blue dot) is made easier with
these functions:

• Hold Command to lock diversity.

• Hold Command-Option to lock the angle.

• Option-click the blue dot to reset angle and diversity.

Level Controls
The Center Level slider and field determine the volume relationship of the (front) center
channel—typically used for dialogue in film and TV productions.

The LFE Level slider and field control the volume of the LFE output. The abbreviation
stands for Low Frequency Enhancement or Low Frequency Effects, as the LFE output is most
commonly sent to a subwoofer channel. The use of a subwoofer speaker is not mandatory.

Tip: If you only want low frequency signals to reach the output, insert a multi mono
surround EQ into the surround master channel. Use this to set the LFE (or subwoofer)
output. A cutoff frequency of 120 Hz is standard for most surround applications.

Separation Controls
The sliders in the lower section of the Surround Panner window determine the amount
of separation between various channels. As you alter these parameters away from values
of 1.00, the separation square changes (to a trapezoid or rectangle) in the surround field,
providing visual feedback on how the channel is being affected.

• Separation XF: Applies to the Left and Right (front) channels. Reducing Separation from
1.00 down to 0.00 mixes the right signal into the left channel, and vice versa, until both
channels output a mono signal.

• Separation XR: Applies to the Left and Right Surround (rear) channels. Works as above,
for the surround speakers.

• Separation Y: Affects the mix relationship of the front and rear channels (in front or
behind the listening position, in other words). It mixes the Left/Left Surround and
Right/Right Surround channels. When Separation Y is set to 0.00, the front and rear
channels output in mono.
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The separation square is visible if the extended parameter section is open. If the extended
parameter section is closed, it remains visible if any of the separation values does not
equal 1.00. It also stays visible when the default values are reached by editing the square
graphically. Closing the extended parameter section (with all separation values at 100%)
makes the square disappear.

You can Option-click the value field or sliders shown in the extended parameters (or on
the separation square lines) to reset them to default values.

Note: In 7.1 ITU surround formats, the Separation of Left Middle and Right Middle is
determined by the average separation value of the Front and Rear channels.

Using the Stereo-to-Surround Panner
If the source input is set to stereo, the Stereo-to-Surround Panner appears.

It is similar to the Mono-to-Surround Panner, but features three pan pucks:  a puck for
the L(eft) signal, a puck for the R(ight) signal, and a third puck, which controls both the
L and R pucks as a group. It also offers a Spread field in the upper-right corner, which
controls the stereo width of the signal.

Moving the L or R puck in the surround field moves the second puck in a symmetrical
fashion. Dragging the third puck moves both the L and R pucks, while maintaining a
given spread.

A left/right movement changes the angle of both, an up/down movement changes the
diversity. The circular bars around the panner indicate which speakers will carry the
respective signal source; the closer to the center a puck is moved, the wider the
corresponding bar gets (the greater the diversity, in other words).
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Using the Surround Balancer
If the source is set to surround, the Surround Panner acts as a Surround Balancer control.

Source channels are passed on to their respective output channels without any
cross-panning or mixing. The pan control is represented by a single puck, which affects
the multi-channel source signal as a whole. In other words, only the relative volume
balance of the source signal is changed.

The separation parameters are not available in this Surround Panner mode.

Inserting Surround Effect Plug-ins
Logic Pro offers a number of surround effect plug-ins, and also includes surround versions
of the Sculpture and ES2 synthesizers. Your Audio Units instruments and effects may also
work in surround.

Important: The project surround format determines the surround format of plug-ins.

To insert a surround effect plug-in
1 Set the channel strip’s output to Surround.

2 Click any Insert slot, then browse to the Mono → Surround (on mono channels), Stereo
→ Surround (on stereo channels), or Surround version (on surround channels) of the
desired plug-in.

As an example on a stereo format channel strip, navigate to Delay > Delay Designer >
Stereo → 5.1 (ITU 775). If the project surround format is set to 7.1 (SDDS), the Plug-in
menu of a stereo channel strip is displayed as follows:  Delay > Delay Designer > Stereo
→ 7.1 (SDDS).
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Tip: It is possible to release the mouse pointer on the plug-in name, instead of navigating
all the way through the hierarchy to the channel format. This automatically opens the
plug-in using the default channel strip format.

To insert plug-ins that do not match the channel format
µ Option-click a channel strip Insert slot.

The Plug-in menu displays all formats the plug-in has to offer, rather than being limited
to the matching format.

Any down- or upmixing that may be necessary will happen automatically.

• The default format of software instruments is stereo (if available). Mono and the project
surround format are offered as additional formats.

• The default format of effect plug-ins is the current channel strip format (at the insert
point in the signal path).

• In addition, all plug-in format variations (based on the current channel strip input
format, and all available plug-in output formats) are offered, up to the maximum allowed
by the project surround format.

• Logic Pro effect plug-ins can also be operated in a multi-mono configuration, based
on the project surround format.

Logic Pro automatically performs surround down and upmixes whenever the format of
the input and output channels don’t match. For example, if you insert a quad plug-in
into a 5.1 bus, Logic Pro performs a downmix from 5.1 to Quad, followed by an upmix
back to 5.1.

Using the Down Mixer Plug-in
You can use the Down Mixer plug-in to adjust the input format of the surround master
channel strip. This allows you to quickly check the surround mix in stereo, for example.
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Channel mapping, panning, and mixing are handled behind-the-scenes. You do, however,
have some control over the mix:

• Dest Format pop-up menu: This pop-up menu allows you to choose the surround
destination format:  To Quad, To LCRS, To Stereo.

• Generic level sliders: These sliders control the respective channel levels. The number,
and names, of sliders depends on the chosen plug-in format.

Working with Multi-Channel Effects
Effects that are not available as true surround effects can be inserted as multi-channel
effects on surround channels:  Logic Pro matches the surround format of a channel by
automatically providing the required number of stereo and mono instances of the plug-in.

Learning About the Advanced Plug-in Header
Multi-channel effect plug-ins offer an advanced plug-in header.

It can include a tab for each effect instance, an LFE tab, and a Configuration tab. The
effect tab labels indicate if effect instances are loaded in stereo or mono. Channels joined
with a “-” are loaded as a stereo instance. Channels separated with a “|” are mono. To
explain:

• L-R|Ls-Rs|C denotes left/right stereo, left/right surround stereo, and mono center.

• L-R|Rs|C (a separate left surround tab is shown) denotes left/right stereo, mono right
surround, mono center.
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• LR, C, and Ls-Rs shown on three separate tabs denotes left/right stereo, center mono,
left/right surround in stereo.

Each effect tab is, in essence, a discrete effect unit for each channel (or channel pair). As
such, you can have different plug-in parameters for the LR tab, the C tab, the Ls-Rs tab,
and the LFE tab. When you save plug-in settings, the parameter values of each tab are
saved.

You can assign these different mono or stereo configurations in the Configuration tab.

Configuring Multi-Channel Effects
The Configuration tab allows you to determine how parameter changes affect the plug-in
instances.

 Link menu Bypass button

• Link menu: Determines which effects are linked. If you link effects, parameter changes
apply to all effects in the linked group. You can choose between three groups:  A, B,
and C. Channels set to none (“-”) operate independently. Each group features its own
tab.

• Bypass button: Click to bypass the channel:  It is routed around the effect. This is useful
when individual channels should be exempt from processing by a particular plug-in.

Note: If the Bypass button of a grouped channel is clicked, all channels in the group are
routed around the effect.
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When a multi-channel plug-in is first inserted into a surround channel, it is automatically
preconfigured to match the channel’s surround format, and to make the best use of the
plug-in’s capabilities. For example, a plug-in with mono and stereo capabilities is inserted
into a 5.1 bus. It is preconfigured as two stereo pairs, with the addition of a mono center
and mono LFE channel. The necessary links and tabs are created automatically.

When you link channels, keep the following in mind:

• If you link two channels as a stereo pair, the left channel is always assigned as the
master.

• If one or more channels are added to an existing group, the new members adopt the
values of the group.

• If you assign several channels to an unused group, the setting of the (front) Left channel
is used for all group members.

Working with Side Chains
When inserting a side chain–capable plug-in, the side chain source (selected in the plug-in
header) is routed to all surround instances.

The detection circuits of grouped plug-in instances are linked, and react as one unit. This
ensures that the spatial surround image is not skewed or deformed.

Note: This is also true when no side chain input is selected. In this case, the group’s
combined individual inputs are used to feed the linked detection circuit—effectively
acting like a side chain source.
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Working with the Surround Master
When you set the output of a channel strip to surround, a surround master channel strip
is automatically created in the Mixer. The surround master channel strip processes the
signals routed to the outputs, as configured in the Surround preferences (taking the
project’s surround format into account, of course).

You can insert surround effect plug-ins into the master channel strip.

Important: As soon as the master channel strip appears, the Insert slots of the individual
output channels are hidden, and any existing effects in the Insert slots (of output channel
strips) are no longer processed. Logic Pro remembers the Insert configuration, so when
you remove all surround outputs, the original output channel configuration is restored.

Bouncing Surround Audio Files
Bouncing a surround mix can create more audio files than your usual stereo bounce. Each
file is identified by a unique extension.
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Note: Use the Bounce Extensions preference tab to define filename extensions that will
be added to the files resulting from a surround bounce. For further details, see Setting
the Surround Preferences.

To perform a surround bounce to CDDA (CD Digital Audio)
1 Do one of the following:

• Click the Bounce button at the bottom-right corner of any output (or the surround
master) channel strip.

• Choose File > Bounce from the main menu bar (or use the corresponding key command).

All outputs selected in the surround settings are bounced simultaneously, regardless
of which output channel strip Bounce button is clicked.

2 Select the Surround Bounce checkbox, below the Dithering pop-up menu in the Bounce
window.

3 Select the Burn:  CDDA checkbox in the Destination pane.

4 Select the other bounce settings, as required.

5 Click the Bounce button.

Note: You cannot use the Bounce command to create compressed surround files (AAC,
ALAC, MP3).

Logic Pro can burn a surround mix of the current project to a DVDA (DVD-Audio) disc.
This can be:

• As many as 6 channels (5.1) at 24-bit depth, and 48 kHz sampling rate

• High definition stereo at 24-bit depth, and 192 kHz sampling rate

To perform a surround bounce to DVD-A
1 Do one of the following:

• Click the Bounce button in the bottom-right corner of any output (or the surround
master) channel strip.

• Choose File > Bounce from the main menu bar (or use the corresponding key command).

All outputs selected in the surround settings will be bounced simultaneously, regardless
of which output channel strip Bounce button is clicked.

2 Select the Burn:  CDDA checkbox in the Destination pane.

3 Choose DVD-A from the Mode pop-up menu.

4 Choose the other bounce settings, as required.

5 Click the Bounce & Burn button.

For full details about bouncing, see Bouncing Your Project.
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Positioning Your Speakers
The physical positioning of speakers is key to creating mixes that translate well to other
surround playback systems. As the 5.1 format is the most widely used, this section will
only cover 5.1 speaker placement. Much of this information can be applied to the other
formats.

Positioning the Front Speakers
The International Telecommunications Union (ITU) created a 5.1 definition that states
that the front speakers should be arranged left, center, and right, with the angle between
the left (or right) and center speakers being 30 degrees.

A narrower angle of 22.5 degrees has been suggested for use in cinematic systems to
comply with another requirement that the left and right speakers should be within four
degrees of the edge of the screen.

The ITU standard is primarily aimed at music-only systems, but you should consider using
the wider 30 degree angle, even if scoring for film. Use of this angle also allows stereo
signals to be auditioned correctly using just the left and right speakers, without resorting
to moving them around each time you switch between stereo and surround jobs in the
studio.

The three front speakers—left, center and right—should be placed in an arc (not a straight
line) at an equal distance from your listening position. In other words, the center speaker
should be set back slightly from an imaginary line drawn between the left and right
speakers. If this isn’t possible, ensure that you don’t place the center speaker closer to
the listening position than the left and right speakers.

If possible, your listening environment should also include a spot where the left and right
speakers are at an angle of 45 to 60 degrees from the ideal central “viewing” position.

An angle nearer to 45 degrees is preferred if watching movies, as it approximates the
circumstances in which film soundtracks are mixed and monitored. A wider angle, with
the left and right speakers farther apart, is recommended if you generally use your system
for listening to music, rather than watching movies.

This doesn’t have to be in the studio. If you’ve got a home theater setup, make your
surround mix in the studio, and listen to it/watch the DVD in your theater room (which
presumably has all speakers in “ideal” positions for film viewing).

The three front speakers should be as close as possible to the same height, at or near ear
level. Because it is often easiest to place the center speaker on top of the TV set at a fixed
height, consider mounting the left and right speakers on adjustable stands so that you
can match their height to that of the center speaker.
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Positioning the Surround Speakers
The rear speakers (surround channels) should ideally be placed at the same distance from
your listening position as the front speakers, at an angle of around 110 degrees from the
front center speaker. This angle is a compromise between producing an all-encompassing
sound stage (at 90 degrees) and the best rear-quadrant imaging (at 135 degrees).

The surround speakers should be placed alongside and slightly to the rear of (but not
behind) the listening position, well above ear level, to help minimize localization effects.
They should be aimed across the listening area, not directly at the listening position.

This positioning creates a broad surround sound field throughout the listening area,
which approximates cinema speaker systems. If the speakers are placed too far forward,
you won’t get sufficient rearward effect, and if the speakers are too far back, the surround
information will not be integrated with the overall sound field.

Your studio may not have walls in the perfect place to mount surround speakers. If this
is your situation, try these options:

If you’re in a rented space, place the surround speakers on stands above ear level.

Generally, placing surround speakers on the wall directly behind the listening position is
not ideal. If you have no other choices, mount them well above ear level, and try aiming
them at each other, toward the front, or to reflect off the side walls.

You can also try placing them to the sides or rear aimed upward, either on the floor, or
a couple of feet off the floor.

Experiment with placing and aiming the speakers until the surround sound field seems
to “wrap around” you, rather than seeming to come from behind you.

Positioning the LFE (Subwoofer) Speaker
If you mix “traditionally,” by sending the bandwidth-limited LFE signal (all frequencies
below 120 Hz from all channels) to a subwoofer in your surround speaker setup, you don’t
need to concern yourself too much with its placement.

Bass frequencies travel much slower than higher frequencies, and aren’t very “directional,”
so placing the subwoofer under the desk or to the left or right of the room (but in front
of the listening position) will be fine.

Speaker Timing and Levels
You may or may not have wondered why the front speakers are ideally arranged in an
arc, why the subwoofer positioning isn’t too important, and why specific angles are better
than others for surround speakers.
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The reason, put simply, is due to the way human beings “hear.” Most people with
undamaged hearing can easily identify where a sound is coming from:  to the left, right,
in front, or behind them.

Certain sounds, however, are very difficult to “position,” in relation to the listening position.
For example:

• A gunshot or car backfiring:  These are hard to place because the sound is both loud
and quick. You may initially be able to tell that it came from your left or right, but your
brain will become confused as to where, specifically, to the left or right it came from.
This is because early reflections (reverberations) rapidly build up and diffuse, making
them hard to discern, directionally, from the initial sound peak.

• Aircraft jet engines:  In general, this is just a low rumble that is hard to place, until the
plane flies directly overhead. When it does, the sheer volume of the sound, and the
higher frequencies of the jet engines enable you to hear it moving from left to right
or front to back.

Sounds that are easier to place include:

• Trucks, cars and motorbikes:  As these move, a constant combination of low- and
high-frequency sound is heard, allowing you to track their movement.

• Human voices:  This is the sound that human beings are most familiar with, and contain
a lot of high-frequency content. Interestingly, grouped human voices, such as a crowd
in a sporting stadium become very nondirectional. This is due to the reflections and
reverberation of the arena.

As an individual creating a sound mix, you can try to approximate the “real-world”
characteristics of certain sounds, or artificially enhance them, as heard in many Hollywood
blockbuster films.

Whichever approach is taken, a certain amount of “lag time” (latency) is perceived between
speakers, in relation to the listening position.

To compensate for this perceived lag time, most surround amplifiers offer a calibration
routine that allows you to set different levels and different delay times for each speaker.

Care must be taken with this, as level—in particular—can alter your perception of how
“close” a sound is, so you should ideally set the same level for the left and right speakers.
The front left and right speakers are usually used for “incidental music/effects” tracks and
the “main score,” and also often carry an amount of the “dialogue” track (at a slightly
lower level than the center speaker). They may also be used for “surround effects,” such
as crowd noise or ambience in a scene where the main actors are in the center of a group
of people.
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The center speaker is usually used for “dialogue,” and “incidental music/effects,” tracks
in films. Its level should be fairly close to that of the left and right speakers, but can be
increased a little to enhance the intelligibility of dialogue.

In general, you should aim to have the sound from all front speakers arriving “evenly” at
the listening position at the same time.

The level of surround speakers and the subwoofer (LFE) is also critical. You want to set
these levels to be “immersive,” and part of the surround stage, rather than “additions” to
the front speakers. In general, surround speakers are used for “surround effects,” “main
score” and “incidental music/effects” tracks.

Also critical for the surround and subwoofer channels is the delay time. Unfortunately,
there’s no formula that will work for every listening situation, due to a range of factors,
such as surround speaker distance from the listening position, among others.

Assuming that the levels of all speakers are suitable, the timing of the surround (and LFE)
speakers may seem slightly “out” in comparison to the front speakers. Most surround
amplifiers allow you to negatively or positively adjust the “delay” of these speakers.

When mixing in Logic Pro, you should aim to strike the right balance between all of the
factors discussed.

The surround encoding process—performed in Compressor—writes “surround encode
flags” for the surround speakers, depending on the chosen format. These “flags” are
understood by surround decoders (AV receivers, decoding software or surround amplifiers).

There’s no need to worry about setting slight delays between tracks when working in
Logic Pro. The surround encode flags are designed to handle this.

Encoding Surround Bounce Files
Logic Pro surround bounces are not encoded. Surround bounce files can, however, be
encoded in Compressor, which is included in the Logic Pro package. See the Compressor
documentation for instructions on surround encoding.

Dolby Digital
Dolby Digital (also known as AC3) includes the LFE channel. It is a compressed format,
commonly used for DVDs and digital terrestrial or satellite TV broadcasts. It is also widely
used for computer game soundtracks.

DVD-A
DVD Audio format, used for music delivery. Supports 24-bit, 96 kHz playback of up to 6
channels (5.1). 24-bit, 192 kHz mono or stereo is also supported by the format.
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SACD:  Super Audio Compact Disc
Basically, the Sony-Philips version of DVD-A. SACD audio is stored in a format called Direct
Stream Digital, which has a sampling rate of 2.8224 MHz. SACD discs must contain a stereo
mix, but usually also offer a 5.1 mix (although this is optional).

Pro Logic II
Pro Logic II uses two full-range rear channels, unlike the original Pro Logic (LCRS) format.
It does not, however, use the LFE channel. In other words, this is a 5.0 format, so simply
disable the LFE channel in Logic Pro if you want to deliver a Pro Logic II soundtrack.

DTS (Digital Theater Systems)
Soundtracks generally sound better than Dolby Digital EX equivalents because they use
a 3:1 compression ratio, whereas Dolby uses a 12:1 ratio. Less compression obviously
means more storage space is required on the delivery medium.
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Logic Pro can be synchronized with external hardware and software via a number of
different synchronization protocols. In this chapter, you’ll take a detailed look at these
protocols.

This chapter covers the following:

• Understanding the Synchronization Protocols (p. 1189)

• The Synchronization Master and Slave Relationship (p. 1190)

• Using External Synchronization (p. 1190)

• Displaying and Using SMPTE Positions (p. 1192)

• MIDI Machine Control (p. 1194)

• Synchronization Problems and Solutions (p. 1196)

Understanding the Synchronization Protocols
Logic Pro supports the following synchronization protocols:

• MIDI Time Code (MTC): Translation of a SMPTE time code signal into a MIDI standard
time code signal.

• MIDI Clock: Short MIDI message for clock signals. It is used to provide a timing pulse
between MIDI devices. Logic Pro can send MIDI Clock signals to synchronize external
devices. It cannot receive MIDI Clock synchronization signals.

• SMPTE time code: An audio signal that is translated into MTC by some MIDI interfaces,
such as the Unitor8.

• Word Clock: This is a signal that is carried by all digital audio interface formats (ADAT,
FireWire Audio, S/P-DIF, AES-EBU, T-DIF). It is used to maintain the timing integrity of
sample words in audio signals that are transmitted digitally between Logic Pro and
external hardware or software.

• ReWire: Logic Pro can act as a ReWire host. It acts as the master synchronization source
for ReWire-enabled applications such as Reason and Ableton Live. This chapter does
not cover the use of Logic Pro as a ReWire host (see Working with ReWire Applications).
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Tip: Logic Pro also supports manual or “human” sync, when slaved. This is not a
synchronization protocol per se, but enables Logic Pro to follow tempo changes in real
time. As an example, it could chase a live drummer. See Using the Tempo Interpreter
Window.

The Synchronization Master and Slave Relationship
In all synchronization situations, regardless of the simplicity or complexity of your studio
configuration, the following rules apply:

• There can only be one synchronization master.

• The synchronization master sends time code information (synchronization signals) to
one or more synchronization slaves.

Logic Pro is capable of acting as master or slave, as are many devices.

Important: In many (if not most) cases, you will need to manually set each
synchronization-capable device—including Logic Pro itself—to act as master or slave. If
you don’t do this, there will be multiple master devices in your system, which will result
in synchronization errors.

Using External Synchronization
When you first open Logic Pro, manual synchronization mode is automatically turned off,
and Logic Pro is in Internal Sync (master) mode. Activating the Transport bar’s Sync button
synchronizes Logic Pro to the chosen synchronization source.

If Logic Pro is running by itself (no devices or applications capable of synchronization are
in use), or is acting as the synchronization source, it is the synchronization master device.
In this situation, the Transport bar’s Sync button should not be activated.

The Transport bar Sync button is not displayed by default.

To view the Transport bar Sync button
1 Control-click the Transport bar, then choose Customize Transport Bar from the shortcut

menu.

2 Select the Sync checkbox toward the bottom of the Modes and Functions column (right
column), and click OK.
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Using the Sync Button
You can use the Sync button to turn external synchronization on or off at any time, without
changing the selected synchronization source. This allows you to temporarily disengage
Logic Pro (running as a slave) from an external synchronization master device. This could
prove useful if you need to quickly edit a MIDI region while the external synchronization
source (tape machine, VTR, and so on) is still running, for example.

When Logic Pro Is Running as a Slave
The Transport bar Sync button is lit/depressed, when active.

Click the upper (MIDI In) section of the MIDI Activity display—while receiving an external
synchronization signal—to view the frame rate of incoming MIDI time code.

Note: When you click the Record button during external synchronization, Logic Pro enters
record mode, but does not actually start recording until it detects an external time code
signal.

Accessing Synchronization Settings with the Sync Button
Control-click the Transport bar Sync button to open a shortcut menu, where the following
options are available:

• Setting the type of external synchronization.

• Determining whether or not MMC commands (see MIDI Machine Control) should be
transmitted by the Transport buttons of Logic Pro, allowing remote control of
MIDI-controlled tape machines.

• Direct access to the Synchronization settings.

• Direct access to the tempo editors (see Advanced Tempo Operations).

MTC Interpretation
As the MIDI standard only supports four of the six commonly used time code formats
(the 30 fps and 29.97 fps formats are not differentiated in the MIDI specification), Logic Pro
needs to decide which format is intended, when it encounters incoming time code.

Incoming MTC (MIDI Time Code) is interpreted as follows:

• 24 fps is interpreted as 24 fps.

• 25 fps is interpreted as 25 fps.

• 30 fps drop frame is interpreted as 29.97 drop fps.

• 30 fps is interpreted as 29.97 fps.
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You can, however, manually set the format in the File > Project Settings > Synchronization
> General > Frame Rate pop-up menu.

Note: MIDI Time Code (MTC) is the MIDI equivalent of the audio-based SMPTE (Society
of Motion Picture and Television Engineers) time code format.

Displaying and Using SMPTE Positions
The Bar ruler of each linear editing window can independently display a SMPTE time ruler
or bar/beat ruler. For further information, see Adjusting the Bar Ruler Display.

Choosing View > Event Position and Length in SMPTE Units in the Event List switches the
display of all positions and lengths to SMPTE times, rather than bar/beat values.

Positioning Objects to Frames (Pickup Clock)
You can use the Pickup Clock (Move Event to Playhead Position) key command to move
selected objects (an individual event, tempo event, or a region, for example) to the current
playhead position.

To position objects to frames
1 Set the playhead position to the required SMPTE time, by going to a specific frame of the

film in the Video track, for example.

Note: In addition to the usual position commands, you can also use the Rewind One
Frame and Forward One Frame key commands to move one frame backward or forward.

2 Select the object that you want to place at this time position.

3 Use the Pickup Clock (Move Event to Playhead Position) key command to align the start
point of the object with this time position.

The Pickup Clock & Select Next Event key command selects the next object, after the first
object is moved.
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Note: When using Pickup Clock with audio regions, it is the region’s anchor (not the
region start point) that is moved to the playhead position.

Fixing Objects to Frames
In situations where you’re working with synchronized film, you often want specific sound
effects to play at a specific SMPTE time, rather than a particular bar position.

If the tempo of the piece needs to be altered at a later stage, the SMPTE time location of
events that have already been positioned will change. The Lock SMPTE Position function
prevents this from happening.

You can SMPTE-lock individual events in the Event List, or entire regions (along with all
events they contain). Objects locked to a SMPTE position display a small padlock symbol
in front of their name.

To lock an object to its current SMPTE position
1 Select the object.

2 Do one of the following:

• In the Event List, Hyper Editor, and Piano Roll Editor:  Choose Functions > Lock SMPTE
Position.

• In the Arrange window:  Choose Region > Lock SMPTE Position.

• Use the Lock SMPTE Position key command.

Note: Copies of locked objects do not preserve their locked status, whether copied or
pasted via the Clipboard, or by Option-dragging.

To unlock the SMPTE position of a locked object
1 Select the object.

2 Do one of the following:

• In the Event List, Hyper Editor, and Piano Roll Editor:  Choose Functions > Unlock SMPTE
Position.

• In the Arrange window:  Choose Region > Unlock SMPTE Position.

• Use the Unlock SMPTE Position key command.

All selected objects that were locked to their SMPTE position are now fixed to their current
bar position, just like normal events. This means they can be shifted by any future tempo
changes. The padlock symbol in front of the name disappears.

Positioning Bars to Frames
If you want a particular bar in the project to coincide with a specific SMPTE time, you
need to alter the tempo of the preceding passage.
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To avoid having to do this by trial and error
1 Open the Tempo List (see Using the Tempo List).

2 Create a tempo event at the desired bar position.

3 Set a time position for this tempo event in the SMPTE Position column.

The preceding tempo event is automatically adjusted, to generate the correct bar and
time position for the inserted tempo event.

4 If you want to keep the same tempo for the following passage, delete the tempo event
you inserted.

MIDI Machine Control
MMC is a set of MIDI commands that Logic Pro uses to control the transport functions of
any MMC-capable tape machine. The recording process can also be controlled and
automated from Logic Pro via MMC. This tape machine then provides the SMPTE signal
that Logic Pro uses as a synchronization source (with Logic Pro as the slave).

You can control connected devices from Logic Pro by using the normal transport functions
(including direct positioning and cycle jumps). Don’t forget that Logic Pro needs to wait
for the connected device to finish rewinding or forwarding. If MIDI Machine Control is
enabled, dragging the playhead will send MMC Locate commands continuously, until
the mouse button is released.

To turn on MMC
Do one of the following:

µ Control-click the Transport bar Sync button and choose the MIDI Machine Control (MMC)
setting in the shortcut menu.

µ Choose File > Project Settings > Synchronization, and choose the Transmit MMC option
in the MIDI tab.

Logic Pro supports up to 64 MMC tracks, allowing devices such as the Alesis ADAT to be
operated via MIDI machine control.
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Each arrange track can act as a tape (control) track, by selecting an instrument with the
tape deck icon (#305).

You only need to create one instrument with the tape deck icon, and you can then assign
that same instrument to as many tracks as needed, to control your external recorder. It’s
a good idea to group these tracks together in their own folder. These tracks must be
placed at the top of the Arrange window track list. If you pack them into a folder, this
must be the first track in the list.

The tape deck icon is the only icon that actually affects the way an object behaves. All
other icons are purely graphical in nature.

If the tape track is the current record track, the following functions apply:

• Selecting the tape track switches the corresponding track on the tape machine to
record ready, and deactivates the record ready status of any other tracks. To select
several tracks for recording, use Shift when clicking.

• The Record button in the Transport bar sends the record strobe command to the tape
machine. This also puts Logic Pro into MIDI record mode, and sends an MMC Play
command to the tape machine. Logic Pro doesn’t start until it receives time code back
from the MMC device.

• If you use the Autopunch function, the tape machine goes into record mode at the
punch in locator, and stops recording at the punch out locator positions.

• If you click any track—not just a tape track—while holding down Control-Shift, you
can individually toggle the record ready status for each track of the tape machine
(selected tracks are switched on, and unselected tracks are switched off ). Control-clicking
a track switches all other tracks out of record ready mode. If the current record track
was assigned a tape deck icon (see above), you must not use the Control modifier.

• The Record Toggle key command is used to toggle record status, if a tape track is the
currently selected record track.
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• Following an MMC-controlled recording, Logic Pro automatically creates an empty MIDI
region on the tape track. This is to let you know that a recording has taken place on
the tape machine. This applies to all MMC recordings, including those controlled by
the Autopunch function. If you activate several tape tracks (by Shift-clicking), the
corresponding number of regions are created. If a MIDI region with an identical start
point already exists on a tape track, no new MIDI region is created on that track. This
avoids overlapping regions.

• A double stop command sets the project back to the beginning.

The MMC Record buttons also offer you a simple way to arm tracks on your tape machine
with Logic Pro (see MMC Record Buttons Objects).

You should finish all MMC-controlled recordings with Stop or Space. Some tape machines
react differently to a series of MMC Record commands. Sometimes, this can result in
Logic Pro showing a track as recording, when the tape is actually playing back (or even
worse, the opposite situation). As such, you should always finish a recording with Stop
or Space, just to be on the safe side.

Synchronization Problems and Solutions
Given the number of different synchronization types that are available, and different
implementations by various manufacturers, you may occasionally encounter timing issues
when running Logic Pro synchronously with other devices or applications. This section
will help you to overcome some common synchronization problems.

Faulty Digital Synchronization
If Logic Pro is synchronized to external Word Clock (Audio Sync Mode:  External or Free),
you must ensure that a valid digital signal is always available. If you encounter error
messages such as “Sample Rate xxx kHz recognized” it may be that the DAT recorder (or
whatever clock source you have connected to your audio hardware’s digital input) does
not transmit Word Clock in stop or pause mode (or has switched itself off ).

Faulty Synchronization to an External Tape Machine
Create a new project, make a new recording, and see if that does the trick. Why? If an old
recording on tape was not properly synchronized to time code, you won’t be able to use
it. One basic rule:  the playback situation must be identical to the recording situation.

If everything is working fine with the new recording, this means the present setup is OK.
Next, check whether anything has changed in your global setup. Has the frame rate
changed? Has the tape speed changed? If you have changed a 30 fps setting, try variations
such as 30 drop or 29.97.
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If MIDI and Audio Are Not Synchronized
Open the File > Project Settings > Synchronization > Audio tab and select the MTC
Continuous or MTC Trigger + Auto Speed Detection mode.

If your audio hardware doesn’t support either mode, you should cut extremely long
regions into shorter sections.

If MIDI and SMPTE Are Not Synchronized
Check all frame rate settings. The frame rate of all connected devices must be identical,
including the time code on the tape machine, the synchronizer, and in Logic Pro itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation, open the
Tempo Editor, turn off the Detect option, and set the correct frame rate manually.
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Audio processed through plug-ins is subject to small timing delays, known as latency.
Fortunately, Logic Pro provides a number of advanced features that can compensate for
these timing differences, ensuring that all track and channel strip output is perfectly
synchronized. This chapter discusses the technical aspects of plug-in latency, and how
to circumvent these timing anomalies in Logic Pro.

This chapter covers the following:

• Understanding Plug-in Latency in Logic Pro (p. 1199)

• Working in Low Latency Mode (p. 1200)

• Working with Plug-in Latency Compensation (p. 1201)

Understanding Plug-in Latency in Logic Pro
Each digital process—plug-in processing, changing the volume or pan level, and so
on—adds an amount of latency (a small delay). Each of these processing latency values
is added to each other.

To explain, a software instrument running inside Logic Pro will only have an output
latency, because it is generated inside the application. An audio recording that is being
monitored in real time will have both an input, and an output, latency. These two values
are summed, resulting in an overall monitoring latency figure.

Each process—such as the use of an effect plug-in, for example—will also add an amount
of latency, which is combined with the input and output latency figure, depending on
whether a software instrument or audio channel strip is in use. For example, if a recorded
vocal is routed through a compressor effect (with a 10 millisecond latency) and the audio
interface output latency is 40 milliseconds, the total latency figure would be 50 milliseconds
(10 + 40 = 50). If three plug-ins (reverb, chorus, and compressor, for example) that also
introduced a 10 millisecond latency were used for this track, the latency would be
70 milliseconds (10 + 10 + 10 + 40 = 70).
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The audio interface input and output latency is handled by the settings in the Logic Pro
> Preferences > Audio > Devices pane (see Configuring Your Audio Hardware). Internal
latencies introduced by plug-ins are dealt with in a different way, which is the focus of
this chapter.

Working in Low Latency Mode
Low Latency mode allows you to limit the maximum delay time caused by plug-ins.
Plug-ins will be bypassed to ensure that the maximum delay that can occur across the
entire signal flow (of the current track) remains under the chosen value. The Low Latency
mode is extremely useful when you need to play a software instrument (or to monitor
through an audio channel) when plug-ins with high latencies are already in use—at any
point in the signal flow for the selected track/channel.

To activate Low Latency mode
Do one of the following:

µ Click the Low Latency Mode button in the Transport bar.

µ Select the Low Latency Mode checkbox in the General Audio preferences pane (Logic Pro
> Preferences > Audio > General).

This limits the latency generated by plug-ins to the value set with the Limit slider. Plug-ins
will be bypassed, ensuring that the maximum delay that can occur across the entire signal
flow (of the current track’s signal path) remains under the Limit slider value.

• Bypassed plug-ins may be on the selected track, any auxes in the signal path, or even
output channels.

• Plug-ins with the highest latencies are bypassed first.

Note: The sound may change in Low Latency mode. Depending on the plug-ins in use,
the changes can be anything from subtle to dramatic. If plug-ins being used do not
exceed the total latency limit, there will be no audible difference.

To set the maximum delay time allowed in Low Latency mode
1 Choose Logic Pro > Preferences > Audio, then click the General tab.
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2 Set the Limit slider to the desired value.

Working with Plug-in Latency Compensation
The Compensation pop-up menu in the Logic Pro > Preferences > Audio > General pane
allows you to either disable or activate plug-in latency compensation (also called plug-in
delay compensation) for:

• Audio and software instrument tracks

• All channels (audio, instrument, aux, output, bus, and ReWire)

Understanding Plug-in Latency Compensation
Logic Pro provides plug-in latency compensation for all channels:  If activated, Logic Pro
compensates for latency introduced by plug-ins, ensuring that audio routed through
such plug-ins is synchronized with all other audio.

Logic Pro achieves this by calculating the amount of latency caused by plug-ins, and then
delaying audio streams by an appropriate amount—or shifting instrument and audio
tracks forward in time. The compensation method depends on the type of channel that
the latency-inducing plug-in is inserted into.

• If latency-inducing plug-ins are inserted into aux or output channels (or ReWire channels,
if used), Logic Pro delays all other audio streams by an appropriate amount.

• If latency-inducing plug-ins are inserted into audio or instrument channels, Logic Pro
automatically shifts these tracks forward in time. The advantage of this method is that
other channels (that do not contain latency-inducing plug-ins) do not need to be
delayed.
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As an example:  Imagine a simple song with a few bass, guitar, vocal, and drum tracks.
The bass track is routed through an audio channel that contains an effect that introduces
a latency of 10 ms. All guitar tracks are routed to an aux channel that contains several
inserted effects. The combined latency introduced by these effects is 30 milliseconds (ms).
The vocals are routed through another aux channel that has a set of effects that introduce
15 ms of latency. The drum tracks are routed straight to the main outputs, without being
routed through any effects. If latencies were not compensated for, the drum tracks would
play 30 ms ahead of the guitar tracks. The bass track would play 20 ms ahead of the guitar
track, but 10 ms behind the drums. The vocals would play 15 ms before the guitar track,
but 15 ms behind the drums and 5 ms behind the bass. Needless to say, this isn’t ideal.

With plug-in latency compensation set to All, Logic Pro shifts the bass track forward by
10 ms, thus synchronizing the bass and drum tracks. Logic Pro will then delay both streams
routed to the output channel by 30 ms, aligning them with the guitar tracks. The aux
channel that the vocals are streamed to is also delayed by 15 ms, aligning it with the
drum and guitar streams (in other words, the 15 ms delay is increased to 30 ms). The
precise calculations required for each stream are handled automatically.

CompensatedUncompensatedTrack

10 ms → (audio channel) then
← 30 ms (output channel)

10 ms delayBass (effect directly inserted in
audio channel)

Not changed30 ms delayGuitars (routed to aux 1)

30 ms ← (output channel)No delayDrums (direct to output)

15 milliseconds ← (aux channel
2)

15 ms delayVocal (routed to aux 2)

As you can see in the table, all output is effectively delayed by 30 milliseconds, to match
the largest amount of compensation required (by the effects in aux channel 1, which the
guitar tracks are routed to). This has the effect of perfectly aligning all tracks routed to
the output, and circumventing any delays introduced by plug-ins, regardless of where
they are used in the signal path.

Knowing the Limitations of Plug-in Latency Compensation
Plug-in latency compensation works seamlessly during playback and mixing. The delay
that is introduced—to compensate for latency-inducing plug-ins in output and auxiliary
channels—can be applied to non-delayed streams, before they are played back. Instrument
and audio tracks (that contain latency-inducing plug-ins) can also be shifted forward in
time, before playback starts.
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There are, however, some limitations if you use plug-in latency compensation with live
tracks. Shifting prerecorded instrument and audio tracks forward in time is possible when
the audio is streaming live. So, recording while plug-in latency compensation is set to
instruments and tracks will work fine—as long as you do not try to record through
latency-inducing plug-ins:  A live track cannot be shifted forward in time (as Logic Pro
can’t position live audio before it happens).

Important: Delaying a live stream, in order to synchronize it with other delayed audio
channels is not possible.

This may lead to problems if you decide to make further recordings after setting plug-in
latency compensation to All, and inserting latency-inducing plug-ins in auxes and outputs.
If Logic Pro needs to delay streams to compensate for plug-in latencies, you will be
listening to delayed audio streams while recording. As such, your recording will be late
by the number of samples that the audio streams were delayed by.

For these same reasons, you may encounter increased latency if playing software
instrument tracks live, when plug-in latency compensation is set to All. This issue can be
mitigated to some extent by using the Low Latency mode (see Working in Low Latency
Mode).

Dealing with Latency Issues
To avoid these potential pitfalls, you should try to complete any audio and software
instrument recording before inserting latency-inducing plug-ins. If you need to record a
software instrument or audio track after setting up a latency-inducing signal routing, the
following procedure will help you to get around any possible problems.

To record after setting up a latency-inducing signal routing
1 Switch the plug-in latency compensation setting from All to Audio and Software Instrument

Tracks in the Logic Pro > Preferences > Audio > General pane.

You can also use the Toggle Plug-in Latency Compensation:  All/Audio and Instrument
Tracks key command to quickly switch compensation between All or only Audio and
Software Instrument Tracks.

The Audio and Software Instrument Tracks plug-in latency compensation method shifts
tracks that contain latency-inducing plug-ins forward in time-so any audio and instrument
tracks that contain such plug-ins will be synchronized with non-delayed tracks. There is
only one exception:  Live tracks can not be shifted forward in time.

The next step is to eliminate any latency introduced by plug-ins in your recording track.

2 Bypass any latency-inducing plug-ins on the recording track by Option-clicking the
respective Insert slots.

In the Audio and Software Instrument Tracks plug-in latency compensation mode,
bypassing plug-ins eliminates the latency that they create. Latency caused by plug-ins in
audio and software instrument tracks is compensated for.
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The last thing to do is to get around the latency introduced by plug-ins on aux and output
channels.

3 Bypass any latency-inducing plug-ins on auxes and outputs.

At this point, all audio streams will be synchronized, allowing you to proceed with your
recording.

When you’ve finished recording, reenable all latency-inducing plug-ins, and switch the
latency compensation setting to All.

Note: In the All mode, bypassing plug-ins on busses, auxes, and outputs will not eliminate
the latency that they create. You must actually remove these plug-ins from the Insert
slots to eliminate latency.

If you are recording audio, another strategy would be to deselect the Software Monitoring
checkbox in the Logic Pro > Preferences > Audio > Drivers pane. This would necessitate
monitoring your recording via an external mixer. When Logic Pro is not providing software
monitoring of incoming audio, it can correctly position audio recordings—even when
full latency compensation is active. Obviously, you can’t use external monitoring when
recording software instruments.

Note: As Logic Pro has no direct control over the audio outputs of external devices, plug-in
latency compensation cannot work for MIDI tracks that trigger external sound modules.
If you activate full plug-in latency compensation and insert latency-inducing plug-ins,
external MIDI signals will be out of sync with the delayed audio streams. Logic Pro allows
you to circumvent this issue with the External Instrument plug-in:  Insert it (as you would
insert a software instrument plug-in on instrument channels) to route the audio outputs
of your external MIDI devices to the inputs of your audio hardware—and monitor them
through Logic Pro. This allows you to compensate for the delays of any audio streams
coming from MIDI devices during playback.
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You can store multi-channel audio as interleaved or split channel audio files.

An interleaved audio file contains all channel information, stored in an alternating single
“stream.”For stereo files, this would be left channel, right channel, left, right, and so on.
For surround files, this would be channel 1, channel 2, channel 3, and so on, then back
to channel 1. Put into the context of a 5.1 surround mix:  left, center, right, left surround,
right surround, LFE (then back to left, center, and so on) in a 6 channel interleaved file.

Split channel audio files couple separate audio files, allowing you to deal with each channel
(file) independently. For stereo files, two separate files are created, where one file contains
the left channel samples, and the other file contains the right channel samples. The files
are generally identified by a .L and .R suffix. The two files are linked, and are edited as a
pair. You can, however, disconnect them (in the Audio Bin), allowing each to be handled
independently. For multi mono (or split surround) files, multiple mono files are
created:  one for each surround channel. As with split stereo, each file is identified by a
suffix. This is commonly as follows for a 5.1 surround mix:  .L, .C, .R, .Ls, .Rs, and .LFE. Each
file is independent.

Logic Pro, and most other audio applications, support the import and recording of
interleaved files when using Core Audio hardware.

A handful of audio applications (including Pro Tools) only support split file formats, and
will automatically separate interleaved files when you import them. This is also true of
Logic Pro when importing interleaved stereo files using DAE/TDM hardware (Logic Pro
does not support split surround files).

Tip: You should use interleaved audio files if your audio hardware supports them. Split
channel audio files require significantly more hard disk I/O performance.

This chapter covers the following:

• Importing Split Channel Files (p. 1206)

• Working with Split Stereo Files (p. 1206)

• Exporting Split Channel Files (p. 1207)

1205

Working with Split Channel Audio
File Formats 42



Importing Split Channel Files
Nothing special needs to be done to import either split or interleaved files into Logic Pro.
What happens when you import such files differs slightly, depending on the audio interface
hardware in use.

• If You Are Using Core Audio Hardware in Logic Pro: When split channel files are imported,
they are automatically converted to interleaved files. If you want to add several split
channel files simultaneously, Logic Pro asks whether all files should be converted at
once.

• If You Are Using DAE/TDM Hardware in Logic Pro: When split stereo files are imported
into Logic Pro, they are used as is. Split surround files are not supported.

Working with Split Stereo Files
Logic Pro treats audio files with a name that ends in .L or .R as stereo files. This applies to
all file management functions, such as Rename, Create, or Revert to Backup. The following
list outlines how split stereo files are handled in Logic Pro:

• When you select an independent mono file (one side of a split stereo file “pair”) in the
dialog, both channels are imported. Split stereo regions are indicated by the stereo
symbol:  two adjoining circles.

• You can see both files in the Audio Bin. They have the same name—apart from the
channel suffix (L and R). If you rename one channel of a split stereo audio file, the other
channel file is automatically renamed as well. This also applies when renaming regions
associated with the files.

• File edits performed in the Sample Editor apply equally to both files.

• If you use the Add Region command to create a new region, Logic Pro does this for
both audio files.

• Any alteration made to either region is automatically mirrored by the other. This applies
to region start point, end point, and anchor position changes.

• If the region of either file is moved into (or within) the Arrange area, the other region
is also moved.

Disconnecting Split Stereo Files
Both sides of a split stereo file are normally edited together. On occasion, however, you
may need to edit one side individually.

To disconnect a split stereo file
1 Select (either side of ) the split stereo file in the Audio Bin.

2 Choose Edit > Disconnect Selected Split Stereo File.

1206 Chapter 42 Working with Split Channel Audio File Formats



You can now edit both sides of the recording as individual mono files. This function only
disconnects one split stereo file at a time.

Important: If you want to reconnect the files, don’t define any new regions.

To reconnect all split stereo files in your project
µ Choose Edit > Reconnect All Split Stereo Files in the Audio Bin.

Logic Pro reconnects all disconnected stereo files in the project. Only files that were
previously part of a split stereo “pair” are reconnected.

Converting Split Stereo Files to Interleaved Stereo
You can convert two (split stereo) audio files into an interleaved stereo file in the SDII,
AIFF, or WAV format. This is useful if you want to use a split stereo file in another
application, such as the WaveBurner CD mastering software, which only supports
interleaved files.

To convert split stereo files into interleaved stereo files
1 Select the audio files in the Audio Bin.

2 Choose Audio File > Copy/Convert File(s) from the local menu (which is also available by
Control-clicking the Audio Bin or using the corresponding key command).

3 Choose Split to Interleaved in the Stereo Conversion pop-up menu.

4 Type in a filename, browse to a folder location, then click Save.

Note: This only works for split stereo files. You can’t use these commands to combine
two mono files into a stereo file.

Exporting Split Channel Files
You can bounce stereo files from Logic Pro in interleaved or split stereo formats. Surround
files can be bounced as interleaved, or multiple mono files.

Essentially, there are only two parameters of importance for creating split format files in
the Bounce window:

• File Type pop-up menu: Choose Split.

• Surround Bounce checkbox: Select when performing a surround bounce (either
interleaved or split).

Full details on all Bounce window options are found in Bouncing Your Project.
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Interleaved or Split Bounce File?
In some cases you might need to bounce to a different format than the one you’re
working with.

• Interleaved bounce: Bounce to Interleaved when you want to use the file in another
audio application that supports interleaved files (most audio applications or devices
do).

• Split channel bounce: Perform a split channel bounce when you want to use the file
in Pro Tools software, or another application that only supports the “split stereo”
format.
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The Project Settings window allows you to define many of the basic operating parameters
of Logic Pro. This chapter explains each of these options.

Note: Unless otherwise indicated, the descriptions of the various parameters apply when
the selection box beside the option is selected (in other words, when it’s active).

This chapter covers the following:

• Accessing Project Settings (p. 1209)

• Saving Project Settings (p. 1211)

• Synchronization Project Settings (p. 1211)

• Metronome Settings (p. 1222)

• Recording Settings (p. 1224)

• Tuning Settings (p. 1226)

• Audio Settings (p. 1232)

• MIDI Settings (p. 1234)

• Score Settings (p. 1238)

• Video Project Settings (p. 1261)

• Assets Project Settings (p. 1263)

Accessing Project Settings
There are several ways to access project settings in Logic Pro.

• Via the File > Project Settings menu

• Via the Settings button in the Arrange toolbar

• Via local menus (in the Score Editor, for example), buttons on the Transport bar, or
shortcut menus

These and several other access methods are outlined throughout the chapter.
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The Project Settings window features a number of icons and tabbed panes. These behave
much like menus and submenus. To adjust a given setting, select the icon you want, then
the appropriate tab. Once the pane or window is shown, activate or deactivate the setting,
or make your selection from a pop-up menu. Close the window once you’ve made your
selections.

In some instances, you’ll find a button that links to related parameters in the Preferences
window, and vice versa. Clicking this button opens the Preferences window, and
automatically selects the relevant pane. For example, the File > Project Settings > Score
> Global pane features a Score Preferences button. Clicking this button opens the
Preferences > Score pane.

Both the Project Settings and Preferences windows can be visible at the same time,
making setup of operating parameters faster and clearer.
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Saving Project Settings
Project settings are saved with each project, which means that different projects can have
different project settings. You can save your preferred settings in a default template,
which can be used to automatically create a new project when you open Logic Pro. For
full details, see Opening and Creating Projects Automatically.

Project settings can be transferred between projects, through the use of several import
functions. You can use these to accelerate template creation, or when you want to
integrate aspects (such as score text styles) from another project into the one you’re
currently working on. For details on all project import options, see Importing Data and
Settings from Other Projects.

Synchronization Project Settings
Synchronization project settings consist of the following four tabs:  General, Audio, MIDI,
and Unitor.
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To open the Synchronization project settings
Do one of the following:

µ Choose File > Project Settings > Synchronization (or use the Open Synchronization Project
Settings key command, default assignment:  Option-Y).

µ Click the Settings button in the Arrange toolbar, then choose Synchronization from the
pop-up menu.

µ Control-click the Sync button in the Transport bar, then choose Synchronization Settings
from the shortcut menu.

General Synchronization Settings
The General pane of the Synchronization project settings offers the following
synchronization parameters, which are used when running Logic Pro as a slave.

• Sync Mode pop-up menu: This parameter defines the master (time code type) that
Logic Pro is synchronized to:

• Internal: The internal timer of Logic Pro. Logic Pro is the master. External devices can
be synchronized via MIDI Clock or MTC. (The relevant settings are made in the MIDI
pane.)

1212 Chapter 43 Project Settings in Logic Pro



• MTC: MIDI Time Code mode. Logic Pro runs as a slave. MIDI time code can either
arrive at a MIDI In port, or be generated by a MIDI interface that translates it from
incoming SMPTE time code (the Unitor8, for example).

• Manual: Tempo Interpreter mode. Logic Pro runs as a slave to impulses that are
recognized as valid beats by the Tempo Interpreter. The Tempo Interpreter can be
controlled by MIDI events, or a key on the computer keyboard. See Using the Tempo
Interpreter Window.

• “Auto enable external sync” checkbox: When this option is activated, Logic Pro runs as
the master (Internal sync mode), until it receives a synchronization signal—either in
the form of MTC, or from the Tempo Interpreter.

Logic Pro automatically locks to the first synchronization signal it receives.

Important: Ensure that different synchronization signals don’t arrive
simultaneously—remember that there can only be one time code master.

• Frame Rate pop-up menu: Choose the frame rate (in fps, frames per second). This frame
rate applies to both transmitted and received time code.

Note: In drop frame formats, certain frames are left out. (This follows a regular pattern.)
To distinguish between formats, those without dropped frames are sometimes referred
to as “nd” or “non drop.”

• 24 fps: Film, high definition video

• 25 fps: PAL video/television broadcasts

• 30 fps (drop frame): NTSC video/television broadcast; rarely used

• 30 fps: High definition video; early black-and-white NTSC video; older rate that is
rarely used today

• 29.97 fps (drop frame): NTSC video/television broadcasts

• 29.97 fps: Standard definition NTSC

• 23.976 fps: 24 fps running at 99.9%, which facilitates easier transfer of film to NTSC
video

• “Auto detect format of MTC” checkbox: This checkbox, when active, analyzes the incoming
time code and automatically sets the correct frame rate. You should generally leave
this option selected.

Note that it is not possible to automatically distinguish between the 29.97 and 30 fps
MTC frame rates:

• The MTC standard does not allow a distinction.

• A measured rate of 30 fps could also be 29.97 fps time code running too fast, and
vice versa.
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Logic Pro automatically interprets frame rates of “approximately 30 fps” as either 29.97
(drop frame) or 30 fps (non drop), depending on whether or not the drop frame format
is used. This interpretation will usually be correct, because these two formats are used
as a standard.

The “Auto detect format of MTC” option only switches to 29.97 (drop frame) or 30 fps
(non drop) if one of the other conventional formats was previously set. If you want to
synchronize Logic Pro to one of these unconventional frame rates, you need to define
the format manually. This setting will not be altered by the “Auto detect format of MTC”
function.

• Validate MTC pop-up menu: The Validate MTC pop-up menu allows you to specify how
often Logic Pro checks for incoming time code, in order to ensure synchronization
integrity. In general, you should leave this option on the “always” setting.

There are some devices that generate time code pulses that may require a specific
number of frames to be set, in order to maintain synchronization. The “never, Jam Sync”
setting basically sets Logic Pro to free-wheel if the synchronization signal is lost. In
other words, Logic Pro will run on its own internal clock (at the most recently received
tempo) if the synchronization pulse is lost. This approach ensures that recording will
continue, even if the incoming timing pulse fails.

• SMPTE Offset (Top Bar Position Row): This is where you set the SMPTE offset for the
project. As songs don’t always need to start precisely at bar 1, you can select any bar
position to be played at the set SMPTE time.

The default is Bar Position:  1 1 1 1 plays as SMPTE 01:00:00:00.

The SMPTE offset of 01:00:00:00 (one hour) is normally used, because it allows you to
pre-roll an amount of time code.

• Enable Separate SMPTE View Offset checkbox: Select this if you want to see the absolute
time from the start of the project in the time display, rather than the actual SMPTE
time.

• SMPTE View Offset (Lower Bar Position Row): These fields become available if you select
the Enable Separate SMPTE View Offset checkbox. Choose Bar Position 1 1 1 1 displayed
as SMPTE 00:00:00:00 (preset). If necessary, you can set other view offset values here.

The Tempo List always shows the real SMPTE time, never the SMPTE View Offset. The
SMPTE View Offset is used in all other windows (including the Transport bar).

Tip: It is common practice in many video (and audio) post-production houses to set a
one-hour SMPTE offset (01:00:00:00). This avoids a problem commonly referred to as
midnight, where a pre-roll passes through SMPTE time 00:00:00:00, which causes issues
with some tape machines (such as the ADAT).
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Audio Synchronization Settings
Use the parameters in the Audio pane of the Synchronization project settings to keep
your audio and MIDI tracks synchronized.

Current Sync Status Settings
• MTC slider: This real-time display shows the deviation between the incoming MTC and

its nominal frame rate. If the deviation is significant, make sure that the right frame
rate is set in the General pane of the Synchronization project settings. If in doubt, set
the frame rate to 24 fps and select “Auto detect format of MTC.” If the frame rate is
correct, you can use this display to adjust the tape speed of the master machine to the
nominal value (the same speed used when the time code was recorded). Adjust the
varipitch control on the master machine, until the slider is centered.

• Sample Rate slider: This display shows the deviation of the sample rate from its nominal
value. Note that some audio hardware does not allow any variation in the sample rate.
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• Deviation slider: This display shows the current phase deviation of the Word Clock from
the time code master—in other words, the deviation between audio and MIDI. Varying
time code signals shown in this display indicate how Logic Pro regulates the sample
rate of the hardware when in MTC Continuous sync mode. Even large time code
variations result in no deviation between audio and MIDI synchronization. Your audio
hardware must be capable of continuously variable sample rates for this to function.
Small deviations between audio and MIDI are unavoidable, because MIDI can (and
should) follow the time code master directly.

Note: The real-time sample rate conversion feature of Logic Pro allows it to follow an
external MTC signal (MTC Continuous), while maintaining the correct audio playback
pitch and speed. This feature even works when recording in MTC-slave mode.

Audio Sync Status Settings
• Core Audio pop-up menu: This is where you define how your Core Audio hardware is

synchronized to an external time code master.

• MTC Continuous: Audio regions are started in sync, and the sample rate is continuously
regulated to match variations in the time code master signal. Even very long audio
regions stay in sync in this mode.

• MTC Trigger + Auto Speed Detection: Similar to MTC Trigger (see below), but the tempo
of the time code master is constantly monitored while Logic Pro is open. The next
time you start Logic Pro, it will use an adapted sample rate. This mode keeps long
regions in better sync with the time code master, although not as closely as MTC
Continuous. It does, however, use a constant sample rate, which is not affected by
variations in the time code master signal.

• MTC Trigger: Audio regions are started in sync, but are then played at a constant
sample rate, regardless of any variations in the time code master signal. Logic Pro
always uses the set nominal sample rate (44.1, 48, 88.2, 96, 192 kHz). This mode is
suitable when it is vital to retain the absolute pitch of a recording. If the speed of the
time code master deviates from the nominal value, you may need to split long audio
regions into shorter sections.

• External or Free: Logic Pro has no influence on the sample rate. The audio hardware
is responsible for ensuring that the position and sample rate of audio regions match.
This mode is only advisable if you are sure that the Word Clock and time code master
are running in sync—by using an external SMPTE or Word Clock synchronizer, for
example.

• DAE/TDM pop-up menu: This is where you define how your DAE or TDM hardware is
synchronized to an external time code master.

• MTC Continuous: Audio regions are started in sync, and the sample rate is continuously
regulated to match variations in the time code master signal. Even very long audio
regions stay in sync in this mode.
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• MTC Trigger + Auto Speed Detection: Similar to MTC Trigger (see below), but the tempo
of the time code master is constantly monitored while Logic Pro is open. The next
time you start Logic Pro, it will use an adapted sample rate. This mode keeps long
regions in better sync with the time code master, although not as closely as MTC
Continuous. It does, however, use a constant sample rate, which is not affected by
variations in the time code master signal.

• MTC Trigger: Audio regions are started in sync, but are then played at a constant
sample rate, regardless of any variations in the time code master signal. Logic Pro
always uses the set nominal sample rate (44.1, 48, 88.2, 96, 192 kHz). This mode is
suitable when it is vital to retain the absolute pitch of a recording. If the speed of the
time code master deviates from the nominal value, you may need to split long audio
regions into shorter sections.

• External or Free: Logic Pro has no influence on the sample rate. The audio hardware
is responsible for ensuring that the position and sample rate of audio regions match.
This mode is only advisable if you are sure that the Word Clock and time code master
are running in sync—by using an external SMPTE or Word Clock synchronizer, for
example.

• Digital: Similar to External or Free, but the DAE/TDM hardware is also set up to
synchronize to the sample rate of the incoming digital signal.

• SSD/VSD Type: Exactly the same as Digital, but a SMPTE Slave Driver (SSD) or Video
Slave Driver (VSD) is used in addition, to synchronize with the sample and frame rates
used in Logic Pro. (The SMPTE Slave Driver is a device which synchronizes Pro Tools
hardware to incoming time code or Word Clock signals.)
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MIDI Synchronization Settings
The MIDI pane configures Logic Pro to send time code via MIDI, when it is in playback or
record mode. This pane lets you synchronize external slave devices to Logic Pro, which
acts as the master.

MIDI Clock Settings
• Transmit MIDI Clock:  Destination 1 checkbox: Allows you to activate MIDI Clock

transmission.

Every time you start, a Song Position Pointer (SPP) message is also sent. Because not
all devices can process SPP, the MIDI system real-time Continue message is also sent.
The exception is when you start at position 1 1 1 1. In this situation, the real-time Start
message is sent.

MIDI Clock can easily be sent with other normal MIDI events (notes and controllers, for
example). When using multi-port MIDI interfaces (such as the Unitor8), better timing
is achieved by sending MIDI Clock to All ports, rather than to several individual ports.

If MIDI Clock is transmitted to all ports, the events are only sent once from the computer
to the interface. If you address individual ports, one event needs to be sent for each
port, placing a higher strain on the bandwidth of all ports.
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• Transmit MIDI Clock:  Destination 1 pop-up menu: Allows you to determine the first
discrete MIDI output port for the MIDI Clock signal.

• Transmit MIDI Clock:  Destination 2 checkbox: Allows you to activate MIDI Clock
transmission. See further details above.

• Transmit MIDI Clock:  Destination 2 pop-up menu: Allows you to determine the second
discrete MIDI output port for the MIDI Clock signal.

• “Delay transmission by” slider: Allows you to delay the transmission of MIDI Clock signals.
Negative values mean that the MIDI Clock signal is transmitted earlier. This allows you
to compensate for any reaction delays in external MIDI Clock slaves.

MIDI Time Code (MTC) Settings
• Transmit MTC checkbox: Activates the transmission of MIDI time code.

• Transmit MTC pop-up menu: Determines the MIDI output port for the MTC signal.

Note: If you can avoid it, you shouldn’t send MTC to all ports, as it is very data-intensive.
If possible, use a MIDI port that isn’t being used for anything else.

MIDI Machine Control (MMC) Settings
• Transmit MMC checkbox: Select this checkbox to enable transmission of MIDI Machine

Control (see MIDI Machine Control). These commands are then sent whenever you
operate the transport functions (Start, Stop, Rewind, and so on) of Logic Pro.

MMC is normally used when Logic Pro is running as a slave to an external master (such
as an ADAT), and you want to control the external master’s transport functions from
Logic Pro. Logic Pro therefore acts as MMC master and MTC slave simultaneously. If
you want to use the external master’s transport controls, you don’t need to use MMC.
In this situation, Logic Pro follows the MTC master as a slave. You can also use MMC to
place tracks on the MMC slave device into Record-Enabled mode.

• Listen to MMC Input checkbox: Select this checkbox to control Logic Pro by MMC (MIDI
Machine Control) and so-called Full Frame Messages.

Logic Pro recognizes these commands when listening to MMC Input:

• Play

• Deferred Play

• Stop

Deferred Play is a special command for mechanically slow synchronization slaves such
as reel-based tape recorders. Rather than having the machine play immediately, it is
asked to reach the desired SMPTE position before playback is started. There is no
noticeable difference in the response of Logic Pro to the Play and Deferred Play
commands, as Logic Pro can locate to any position almost instantly.

Logic Pro ignores these messages when incoming external MTC (MIDI time code)
commands are detected.
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Logic Pro also obeys Full Frame Messages, and sets the playhead to a new location,
without starting playback. Once again, incoming MTC data has higher priority, if
conflicting information is received.

Some synchronizers send Full Frame Messages (instead of MTC) to locate the slave
device (Logic Pro in this case) to a new position, without implicitly starting playback.
This is useful when in Slow Shuttle or Single Frame Advance mode with video machines,
because the slave device is perfectly located, without being in playback mode.

Other MIDI Settings
• MIDI Sync Preferences button: The MIDI Sync Preferences button opens the Sync pane

of the MIDI preferences. (See MIDI Preferences in Logic Pro.)

Unitor Synchronization Settings
The Unitor pane of the Synchronization project settings is used to set the major
synchronization parameters for the Unitor8 MIDI interface.

General Settings
• SMPTE Mode buttons: You can instruct the Unitor8 to read or write SMPTE data.

• Read: Select to read SMPTE data.

• Generate: Select to write SMPTE data.
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• SMPTE Mode Refresh checkbox: Activates Refresh mode, where fresh time code is
generated, in sync with received time code. Refresh mode works with both VITC and
LTC (see below). You should always use Refresh mode whenever you need to copy an
LTC track, because you cannot directly copy LTC without a considerable loss of quality.
When copying entire multitrack tapes, you should patch all tracks directly, but refresh
the time code track via the Unitor8.

Note: You should only use Refresh mode if you are copying time code.

• SMPTE Type buttons: This is where you define the SMPTE format that you want to use.

• LTC: Longitudinal (also called Linear) Time Code is written to a tape track.

• VITC: Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a
video tape.

• Off: No time code is written.

• Freewheel slider: You can set the freewheel time (in frames) for LTC and VITC. The
freewheel parameter affects the SMPTE reader, and specifies how long the synchronizer
continues transferring MTC to the sequencer, after time code ceases to be read.

Long freewheel times can maintain synchronization, even if there are dropouts in the
time code, but they also increase the reaction time of Logic Pro after the time code
master stops. In practice, you should set a value that is as large as necessary (for
sustained operation), and as small as possible (to reduce waiting times).

• TV Format pop-up menu: Allows you to define the television format for time code
burn-in.

• PAL: The video format used in Europe, South America, most Asian and African
countries, and Oceania. If you are working with video in SECAM format (used in
France and French-speaking nations in Africa), choose PAL.

• NTSC: The video format used in the USA, Central America, Japan, and Canada.

• VITC Line 1 and VITC Line 2 pop-up menus: VITC is written into two lines of the video
picture, which are normally invisible. The lines should not be adjacent, and are usually
situated between 12 and 20.

If the Scan option is enabled, the VITC lines are automatically recognized. You should
only enter the lines manually if there are problems with Scan mode.

Visible Timecode Display Settings
• Visible Timecode Display:  Size pop-up menu: Allows you to set the size of the time code

counter window, which is burned into the video picture.

• Visible Timecode Display:  Style pop-up menu: Allows you to set the style of the time
code counter window, which is burned into the video picture.

• Horizontal Position and Vertical Position sliders: Allows you to set the position of the
time code counter window, which is burned into the video picture.
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Metronome Settings
The Metronome project settings combine all parameters for speaker click, MIDI click, and
KlopfGeist—a virtual metronome sound source. KlopfGeist can be used in addition to, or
in place of, the speaker and MIDI click sources.

Note: KlopfGeist is a software instrument found in the Plug-in menu of instrument channel
strips. KlopfGeist is inserted into instrument channel 256 by default. Logic Pro automatically
creates instrument channel 256 (and inserts KlopfGeist) when the Software Click Instrument
(KlopfGeist) checkbox is selected. Theoretically, any other Logic Pro or third-party software
instrument could be used as a metronome sound source on instrument channel 256. For
full details about KlopfGeist, see the KlopfGeist chapter in the Logic Studio Instruments
manual.

To open the Metronome project settings
Do one of the following:

µ Choose File > Project Settings > Metronome (or use the Open Metronome Project Settings
key command).

µ Click the Settings button in the Arrange toolbar, then choose Metronome from the pop-up
menu.

µ Control-click the Metronome button in the Transport bar, then choose Metronome Settings
from the shortcut menu.
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MIDI Click Settings
• Bar checkbox: Select to generate separate note events for bars.

• Beat checkbox: Select to generate separate note events for beats.

• Division checkbox: Select to generate separate note events for divisions.

• Channel fields: Define the MIDI channel of generated notes.

• Note fields: Define the note number of generated notes.

• Velocity fields: Define the velocity of generated notes.

• MIDI Port pop-up menu: Allows you to choose a direct MIDI output port (or all ports)
for the metronome.

Software Click Instrument (KlopfGeist) Settings
• Software Click Instrument (KlopfGeist) checkbox: Activates or deactivates the KlopfGeist

metronome.

• Bar checkbox: Select to generate separate note events for bars.

• Beat checkbox: Select to generate separate note events for beats.

• Division checkbox: Select to generate separate note events for divisions.

• Note fields: Define the note number of generated notes.

• Velocity fields: Define the velocity of generated notes.

• Tonality slider: Changes the sound of the virtual metronome from a short click to a
pitched percussion sound, similar to a wood block or claves.

• Volume slider: Sets the output level of the virtual click sound.

• Output pop-up menu: If the audio hardware used by Logic Pro offers more than two
outputs, this pop-up menu allows you to route the KlopfGeist metronome sound to a
different set of hardware outputs.

Other Metronome Settings
• “Click while recording” checkbox: The metronome click is automatically turned on for

recording. This is the same as activating the Metronome button in the Transport bar
during recording.

• “Only during count-in” checkbox: When this option is active, the recording click is only
audible during the project count-in, and is then turned off.

• “Click while playing” checkbox: The metronome click is automatically turned on for
playback. This is the same as activating the Metronome button in the Transport bar
during playback.

• Polyphonic Clicks checkbox: The metronome sends notes, as defined for bars, beats, and
divisions. For example, two or three notes may be sent simultaneously at the beginning
of each measure. If this option is unselected, the metronome only transmits one note
at a time.
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Recording Settings
The Recording project settings determine how Logic Pro responds while in record mode.

To open the Recording project settings
Do one of the following:

µ Choose File > Project Settings > Recording (or use the Open Recording Project Settings
key command, default:  Option-*).

µ Click the Settings button in the Arrange toolbar, then choose Recording from the pop-up
menu.

µ Control-click the Record button in the Transport bar, then choose Recording Settings
from the shortcut menu.

General Recording Settings
• When Beginning buttons: Allow you to choose between a count-in or pre-roll period

when starting to record.

• Count-in: If the button is selected, the Count-in pop-up menu (see below) allows
you to set the count-in period that precedes a recording.

• Record Pre-Roll: If the button is selected, this parameter allows you to set a pre-roll
time in seconds and milliseconds. When recording, this value is deducted from the
current project position.

• Count-in pop-up menu: Allows you to set the count-in period that precedes a recording.

• None: The recording begins with no count-in.
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• x Bar: The recording begins with a count-in of between 1 Bar and 6 Bars (chosen
from the pop-up menu).

• x/4: The count-in’s time signature can be set here. These settings are useful when
the count-in falls across a bar change.

• “Allow tempo change recording” checkbox: All tempo changes made while in record
mode are recorded. For details on editing these tempo recordings, see Advanced Tempo
Operations.

• Auto-Colorize Takes checkbox: When this setting is selected, take folders use the color
chosen from the Color palette for the first take recording, but different colors for each
of the following recorded takes in that take folder. All colors used in a take folder are
chosen from the same color row in the Color palette, advancing by a predefined number
of columns after each take.

MIDI Recording Settings
• Overlapping Recordings pop-up menu: Allows you to set the behavior when your MIDI

recordings overlap.

• Create take folders: A new take folder is created when recording over an existing MIDI
region.

• Merge with selected regions: Newly recorded data is merged with all selected regions,
to form a single region. This takes place after each recording is completed.

• Merge only in Cycle record: When recording in Cycle mode, this function merges the
data recorded in all cycle passes into a single region. If not in Cycle mode, each newly
recorded MIDI region will be independent (not merged).

• Create tracks in Cycle record: When recording in Cycle mode, this function automatically
creates a new take track for each cycle repetition. Each previous track plays while
you are recording.

• Create tracks and mute in Cycle record: When recording in Cycle mode, this function
automatically creates a new take track for each cycle repetition. Each previous track
is muted while recording.

• “Auto demix by channel if multitrack recording” checkbox: This setting switches between
the Layer Recording and Multi-Player Recording modes. See Recording Multiple MIDI
Tracks Successively.

• “MIDI data reduction” checkbox: Controller events are thinned out during recording, to
reduce the data load on the MIDI bus during playback. This improves the timing of
dense arrangements when using interfaces with only a few MIDI ports. The function
actually reduces the duration of controller events, using an intelligent algorithm which
retains the value at the end of a series of controller messages.

1225Chapter 43 Project Settings in Logic Pro



Core Audio Recording Settings
• Recording Folder file path: Enables you to record all audio data into a single location. If

your working methods are geared toward projects, all recordings (and other project
assets) are saved in the project folder itself.

• Set button: Click to set a universal recording folder, and choose or create a new folder
location in the dialog.

Tuning Settings
Logic Pro includes a real-time tuning system, for use with the included software
instruments. You can configure the tuning system in the Tuning project settings.

To open the Tuning project settings
Do one of the following:

µ Choose File > Project Settings > Tuning (or use the Open Tuning Project Settings key
command).

µ Click the Settings button in the Arrange toolbar, then choose Tuning from the pop-up
menu.
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Software Instrument Pitch Settings
• Tune slider: Determines the global tuning of all software instruments. The default is

concert pitch A (440 Hz). Detuning is in cent (1/100th of a semitone) steps.

Software Instrument Scale Settings
• Software Instrument Scale buttons: Select the appropriate button in the Software

Instrument Scale section to activate alternate tuning scales. The selected tuning scale
is saved with the project when saved, and reloaded the next time the project is opened.

• Equal Tempered: Disables any tuning, and uses an equal tempered scale.

• Fixed: Activates a number of fixed tuning scales and keys. Fixed Tuning mode tunes
musical keys (to different degrees) for scaled tuning systems, and delivers a key
signature character. When playing mostly white keys (in the Pure setting, and with
C as the root key), C major is the main focus, and tuning is scaled to that chord. An
A major chord that is played immediately after a C major (and is therefore subject
to C major scaled tuning) is affected somewhat by the scaled tuning effect, but will
not sound completely tempered. If you normally play polyphonic music, this mode
(when using the Pure setting) will sound most pleasing to your ears. The Fixed Tuning
scales are ideal for a number of Baroque and Medieval instruments and styles of
music.

• User: Allows you to detune (move away) each semitone in steps.

• Hermode Tuning (HMT): As all tuning requirements cannot be satisfied simultaneously
with any one Hermode Tuning setting, allows you to set different Hermode Tuning
modes and degrees of effect.

• Fixed:  Type pop-up menu: Offers the most important historic tuning scales, as well as
a few others.

• Fixed:  Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen
scale. This provides an easy way to reference the chosen scale to any root note.

• User:  Semitone boxes: Detune each semitone in steps, by dragging vertically in each
semitone box until you reach the value you want. Alternately, you can double-click in
each semitone box, and type in a value. Press Return or click in another box to exit text
entry mode.

• User:  Reset button: Resets all of your tuning adjustments to their default values.

• User:  Upper slider: Determines the deviation (from the equal tempered scale) in the
treble end of the sound. The higher the value, the farther down the low notes are tuned.
A setting of 0 results in an equal tempered scale tuning.

• User:  Stretch Lower slider: Determines the deviation (from the equal tempered scale)
in the bass end of the sound. The higher the value, the further down the low notes are
tuned. A setting of 0 results in an equal tempered scale tuning.
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• User:  Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen
scale. This provides an easy way to reference the chosen scale to any root note.

• Hermode Tuning:  Type pop-up menu: Allows you to set different Hermode Tuning modes.

• Classic (3/5-all): This mode provides a broad and regular tuning of pure 5ths and
3rds. In cases of conflict, the degree of purity is temporarily reduced. This mode can
be used for all types of music. The value of the Depth parameter indicates the degree
of the 5th and 3rd purity. A setting of 100% determines maximum purity. A 10%
value is the lowest purity setting. Off sets the tuning to an equal tempered scale.

• Pop/Jazz (3/5/7-all): 5ths, 3rds, and 7ths are changed in this mode. It is great for Pop
and Jazz styles, especially when using sustained chords. It is less suitable for
polyphonic music, as the detuning of the natural 7th is significant. This mode should
always be used with a Depth of 90% or 100%, as other values will render the natural
7th acoustically ineffective.

• Baroque (3/5-adaptive): This mode tunes pure 5ths and 3rds (with changing
characteristics). In tonal music, with a clear harmonic center, the middle chords are
tuned very purely, whereas more distant chords are tuned with less purity. If the
harmonic center becomes unclear, all chords are tuned with equal purity. As with
the other mode parameters, a Depth value of 100% determines the highest purity,
and a value of 10%, the lowest purity.

• Hermode Tuning:  Depth slider: Allows you to set degrees of effect between 0% and
100%.

About Tuning
The following sections provide some background information about tuning.

About Alternate Tunings
The 12 tone scale used in Western music is a development that took centuries. Hidden
in between those 12 notes are a number of other microtones—different frequency
intervals between tones.

To explain, by looking at the harmonic series:  Imagine that you have a starting (or
fundamental) frequency of 100 Hz (100 vibrations per second). The first harmonic is double
that, or 200 Hz. The second harmonic is found at 300 Hz, the third at 400 Hz, and so on.
Musically speaking, when the frequency doubles, pitch increases by exactly one octave
(in the 12 tone system). The second harmonic (300 Hz) is exactly one octave—and a pure
fifth—higher than the fundamental frequency (100 Hz).

From this, you could assume that tuning an instrument so that each fifth is pure would
be the way to go. In doing so, you would expect a perfectly tuned scale, as you worked
your way from C through to the C above or below.
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To simplify this example:  Imagine that you are tuning an instrument, beginning with a
note called C at a frequency of 100 Hz. (A real C would be closer to 130 Hz.) The first fifth
would be tuned by adjusting the pitch until a completely clear tone was produced, with
no beats. (Beats are cyclic modulations in the tone.) This would result in a G at exactly
150 Hz, and is derived from the following calculation:

• The fundamental (100 Hz) x 3 (= 300 Hz for the second harmonic).

• Divided by 2 (to drop it back into the same octave as your starting pitch).

This frequency relationship is often expressed as a ratio of 3:2.

For the rest of the scale:  Tune the next fifth up:  150 x 3 = 450. Divide this by 2 to get 225
(which is more than an octave above the starting pitch, so you need to drop it another
octave to 112.5).

The following table provides a summary of the various calculations.

NotesFrequency (Hz)Note

x 1.5 divided by 2.100C

Divide by 2 to stay in octave.106.7871C#

Divide by 2 to stay in octave.112.5D

Divide by 2 to stay in octave.120.1355D#

Divide by 2 to stay in octave.126.5625E

135.1524F (E#)

Divide by 2 to stay in octave.142.3828F#

(x 1.5) divided by 2.150G

160.1807G#

168.75A

180.2032A#

189.8438B

202.7287C

As you can see from the table above, there’s a problem.

Although the laws of physics dictate that the octave above C (100 Hz) is C (at 200 Hz),
the practical exercise of a (C to C) circle of perfectly tuned fifths results in a C at
202.7287 Hz. This is not a mathematical error. If this were a real instrument, the results
would be clear.

To work around the problem, you need to choose between the following options:

• Each fifth is perfectly tuned, with octaves out of tune.

• Each octave is perfectly tuned, with the final fifth (F to C) out of tune.
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Detuned octaves are more noticeable to the ears, so your choice should be obvious.

The Comma
The difference between a perfectly tuned octave and the octave resulting from a tuned
circle of fifths is known as the comma.

Over the centuries, numerous approaches have been tried to solve this mystery, resulting
in a range of scales (before arriving at equal temperament—the 12 tone scale).

Other historical temperaments that have been devised emphasize different aspects of
harmonic quality. Each compromises in some way or another. Some maximize pure thirds
(Mean Tone) while others emphasize pure fifths at the expense of the thirds (Kirnberger
III, for example).

Every temperament has its own character, and a given piece of music may sound fine in
one key but awful in another. Transposing a piece to a new key can completely change
its character.

Careful attention must be paid to the selection of temperaments for authentic
performances of historic keyboard music. The wrong choice could result in an
unsatisfactory and historically inaccurate musical experience.

About Equal Temperament
Equal temperament takes the tuning error (the comma), and spreads it equally between
each step of a chromatic scale. The result is actually a scale of equally mistuned intervals,
with no interval grossly out of tune, but none in perfect tune. Equal temperament has
become the de facto standard for two main reasons:

• Convenience: Retuning an instrument to a temperament that is better-suited for a
particular piece of music is a hassle. Many instruments are not capable of being
alternately tuned (fretted string instruments, for example).

• Portability: All Western musical pieces can be performed (adequately) on an instrument
tuned to equal temperament. Obviously, some of the nuances may be missing in pieces
that were originally performed in another temperament.

What Is Hermode Tuning?
Hermode Tuning automatically controls the tuning of electronic keyboard instruments
(or the Logic Pro software instruments) during a musical performance.

In order to create clear frequencies for every fifth and third interval in all possible chord
and interval progressions, a keyboard instrument would require far more than 12 keys
per octave.
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Hermode Tuning can help with this problem:  it retains the pitch relationship between
keys and notes, while correcting the individual notes of electronic instruments, ensuring
a high degree of tonal purity. This process makes up to 50 finely graded frequencies
available per note, while retaining compatibility with the fixed tuning system of 12 notes
per octave.

How Hermode Tuning Works
Frequency correction takes place on the basis of analyzed chord structures.

The positions of individual notes in each chord are analyzed, and the sum of each note’s
distance to the tempered tuning scale is zeroed. In critical cases, different compensation
functions help to minimize the degree of retuning, at the expense of absolute purity, if
necessary.

For example:

• The notes C, E, and G form a C Major chord.

• To harmonically tune these, the third (the E) needs to be tuned 14 cents higher (a cent
is 1/100th of a tempered semitone) and the fifth (the G), needs to be 2 cents higher.

It should be noted that Hermode Tuning is dynamic, not static. It is continuously adjusted
in accordance with the musical content. This is done because, as an alternative to
tempered, or normal, tuning, fifth and third intervals can also be tuned to ideal frequency
ratios:  the fifth to a ratio of 3:2, the major third to 5:4. Major triads will then sound strong.

With clean (scaled) tuning, Hermode Tuning changes the frequencies to values that are
partly higher or partly lower.
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Audio Settings
The Audio project settings determine audio-specific project parameters.

To open the Audio project settings
Do one of the following:

µ Choose File > Project Settings > Audio (or use the Open Audio Project Settings key
command, default assignment:  Option-U).

µ Click the Settings button in the Arrange toolbar, then choose Audio from the pop-up
menu.

• Automatic Management of Channel Strip Objects checkbox: Makes setting up and using
tracks and channel strips a transparent experience. It automatically creates and manages
channel strips when new tracks are created. You should only deactivate this setting
when you need to make manual changes to channel strips in the Environment window.

• Automatic Naming of Channel Strip Objects checkbox: This option (active by default in
Logic Pro 9 projects) allows the automatic naming of channel strips according to the
last loaded setting (CST, SI PST or EXS Instrument—whichever was loaded last), until
the user enters a channel strip name manually (in the track header, Arrange channel
strip, Mixer, or Environment).
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• Playback Pre-Roll checkbox: When this option is selected, all start commands force
Logic Pro to start playback a little earlier (shifted to the left). The exact pre-roll value
depends on the current delay compensation value for plug-ins. This option ensures
that transients that fall exactly on the start position are played back correctly. If this
option is unselected, transients that fall precisely on the start position can be missed,
or seem to fade in.

• Sample Rate pop-up menu: Allows you to choose the sample rate for the project.

• Surround Format pop-up menu: Allows you to choose the surround format for the
project.

• Pan Law pop-up menu: Signals panned to the center position may sound louder than
signals panned hard left or right. The Pan Law value determines the amount of volume
reduction on signals that are panned to the center position. You can choose from the
following settings:

• 0 dB: With no change to the volume level, signals will seem louder when panned to
the center position, in comparison with extreme left or right pan positions.

• –3 dB: A full scale signal (0 dBfs) will have a level of –3 dB when panned to the center
position.

• –3 dB compensated: A full scale signal (0 dBfs) will have a level of 0 dB when panned
to the center position (or +3 dB when panned to extreme left or right positions).

• Apply Pan Law Compensation to Stereo Balancers checkbox: Applies Pan Law
compensation to Stereo Balance controls.

Note: For compatibility purposes, this checkbox is selected by default for all older
projects opened in Logic Pro 9.
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MIDI Settings
The MIDI project settings determine the behavior of the MIDI inputs and outputs. The
MIDI project settings comprise the General, Input Filter, and Chase panes.

To open the MIDI project settings
Do one of the following:

µ Choose File > Project Settings > MIDI (or use the Open MIDI Project Settings key
command).

µ Click the Settings button in the Arrange toolbar, then choose MIDI from the pop-up menu.
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General MIDI Settings
The following parameters are available in the General pane.

Miscellaneous Settings
• Send After Loading Project:  “Used instrument MIDI settings” checkbox: Sends the active

instrument MIDI settings automatically after loading a project. (See Inserting Program
Change, Volume, and Pan as MIDI Events.)

• Send After Loading Project:  “All fader values” checkbox: Sends all Environment fader
values automatically, once a project is loaded.

• Scrubbing with Audio in Arrange checkbox: Activate this setting if you want to
simultaneously scrub MIDI and audio regions in the Arrange window.

MIDI Thru Settings
• SysEx with MIDI Thru Function checkbox: Incoming SysEx messages are passed through

the computer to the MIDI outputs, along with other MIDI data. This is particularly
important when using hardware programmers, as you can immediately monitor
parameter changes to the synthesizer you are editing.

If you want to record SysEx dumps, do not select this checkbox. It rarely makes sense
to divert dumps through the computer unless you want to record a dump and
simultaneously transmit it to a second device of the same type.
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• Instrument Without MIDI Thru Function pop-up menu: The instrument selected here will
not pass events through the computer when the instrument is assigned to the selected
arrange track. Normally, you would set the No Output instrument here (chosen by
default).

If your master keyboard does not have a Local Off setting, you can use this feature to
avoid unwanted note doubling when recording:

• With multi-timbral sound sources, assign the instrument (usually channel 1) that
plays the part that is heard when playing with the computer turned off.

• With mono timbral sound sources, assign the instrument that represents the
sound-generating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard
whenever you are recording tracks for any other instrument.

It is possible to disable MIDI Thru for any MIDI track in the Arrange window, by simply
disabling the Record Enable button beside the track name.

Input Filter Settings
The Input Filter pane is used to screen certain event types at the sequencer input. For
further information on the individual checkboxes, see Filtering MIDI Events When
Recording.
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Chase Settings
If you start playback in the middle of a project, some events might not be heard (such as
notes, sustain pedal events, and pitch bend events that start before the point where
playback begins). Using the Chase Events function, you can have Logic Pro analyze the
project and include some or all of these events when the project plays back.

The Chase MIDI project settings pane offers the following checkboxes that determine
which event types are chased:

• Notes checkbox: Any notes due to start playing at the playback start point.

• Notes:  Sustained checkbox: Any notes that are still playing at playback start point (due
to a sustain pedal event).

• Notes:  In “No Transpose” Instrument Channel Strips checkbox: Instrument channel strips
(particularly drums) can be assigned No Transpose status in the Inspector. This is a
playback parameter that is ignored if the region containing the instrument notes is
started midway through.

• Program Change checkbox: Any program changes in regions that fall across the playback
start point will be sent.

• Pitch Bend checkbox: Pitch bend events that immediately precede the playback start
point will be sent.
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• Control Changes, 0-15, 64-71, and All Other checkboxes: Select to search for continuous
controllers 0 to 15, continuous switch controllers 64 to 71, or all other controllers.

• Aftertouch checkbox: Looks for monophonic (channel) aftertouch messages.

• Polyphonic Aftertouch checkbox: Scans for polyphonic aftertouch messages.

• System Exclusive checkbox: The most recent SysEx message before the playback start
point is transmitted.

• Text Meta Events checkbox: The most recent Text Meta Event message before the
playback start point is transmitted.

• “Chase separate channels in ‘All Channels’ instruments” checkbox: Multi-instruments
(found in the Environment) have a global channel, and can have up to 16 MIDI
sub-channels. Select this option to scan for events on each MIDI sub-channel, rather
than the global multi-instrument channel.

• “Chase on Cycle Jump” checkbox: Scans for, and sends, all event types if the cycle start
and end points fall across regions.

• Chase on Cycle Jump:  Notes checkbox: Limits cycle jump scan to note events.

• “Send full MIDI reset before chasing” checkbox: Sends a MIDI reset message before chasing,
ensuring that all MIDI devices being triggered are set to their defaults.

Score Settings
There are eight panes of score-related project settings. You can switch between these
and other project settings by using the tabs at the top of the Project Settings window.

These settings affect the whole project (in all score sets). They are saved with the project
file, allowing each project to have different settings.

To open the Score project settings
Do one of the following:

µ Choose File > Project Settings > Score (or use the Open Score Project Settings key
command).

µ Click the Settings button in the Arrange toolbar, then choose Score from the pop-up
menu.
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Global Score Settings
The Global Score project settings define global formatting options such as page margins,
spacing between notes, bars per line, and more.

Distance values can be displayed in inches or centimeters in the Global Score settings
pane.

To switch the distance value display between inches and centimeters
µ Choose cm or inch from the pop-up menu at the top of the Global Score settings pane.

Settings that affect the general page layout (margins, for example) can be set
independently for the full score or just a part or it, indicated by the two input boxes. This
allows you to print out single voices with a page layout that differs from the full score.
(See Creating Separate Layouts for Full Score and Parts.)
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The following describes the global Score settings in detail.

• Top, Bottom, Left, and Right Margin fields: These values show the margin distances to
the outer border of the printable area on the page. A “Top Margin 0.0 inches” value
means that printing will start as close to the top of the paper as the selected printer
driver will allow. This also means that the size of the printable area can vary between
printers, although the difference should be minimal.

Margins are only visible in Page Print view, where they are displayed as orange lines
on the screen. (These lines are not printed.) It is also possible to change them directly
in the score, by dragging them with the Pointer or Layout tool.

• Add Bracket Space checkbox: Creates additional space between the left margin line and
the beginning of staffs, for braces and brackets. If this option is unselected, staffs are
aligned directly along the left margin line.

• Alternating Margins checkbox: If selected, the left and right page margin settings are
swapped on every second page. This can be useful if a score is going to be bound as
a book:  the inner margin usually needs to be a little bigger than the outer one. It’s
possible that the opposite might be preferable, in cases where extra space is needed
for remarks that may be added to the score at a later date.

• Header Space field: Defines the height reserved for headers, between the top margin
of the first page and the top margin of the first staff on the page (as per the assigned
staff style).

Note: Text objects inserted directly into this area automatically become global text
elements (see Working with Global Text), and are displayed as headers in all score sets
(full scores and parts).

This value can also be changed directly in the score, by dragging the purple line above
the first staff.

• Line Distance field: Defines additional vertical distance between staff systems (single,
multiple, or bracketed staffs can constitute a system) on the same page. It applies to
full scores, as well as single staff parts.

• Maximum Bars/Line field: This parameter can be useful when using small spacing values
(see below), to prevent too many bars from being displayed on one line. The number
set here limits the number of bars that can be displayed per line.

Note: This setting can be overridden when using the Layout tool to change line breaks.
(See Setting Line Breaks.)

• Constant Spacing and Proportional Spacing fields: These parameters determine the
amount of horizontal distance between notes.

• Constant Spacing affects the distance from note to note, regardless of rhythmic value.

• Proportional Spacing takes the note durations into consideration.
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If you only use Proportional Spacing (and set Constant to 0), every bar receives (more
or less) the same amount of (horizontal) space. A whole note uses as much space as
four quarter notes. In the opposite situation (high constant value, proportional value
set to 0), the distance from one note to the next is always the same, regardless of note
duration. A half note takes the same amount of space as an eighth note. Other factors,
such as accidentals, ties, and so on, are also considered for note distance calculations.

The settings you use depend on both your personal preference and the style of the
piece. You should aim for a good balance between these two parameters, so try different
combinations when working on the final score layout.

• Slash Spacing field: This is the distance parameter for slashes (used in staff styles that
display beat slashes instead of automatic rests). This is especially important when
inserting notes into staffs that display slashes. For example, musical styles such as funk
use a lot of sixteenth notes, so you are likely to choose a higher slash distance than
you would for music that doesn’t go beyond eighth notes. This way, the proper
relationships between notes and passages (containing only slashes and chord symbols)
can be maintained.

• Beaming Slant Factor, Minimum Slant, and Maximum Slant fields: These three parameters
affect the slant angle of beams. As with the Spacing parameters, these parameters work
together. Appropriate settings need to be found by trying different combinations. The
final settings will vary, depending on the style of the music and on personal preference.

• Beaming Slant Factor: Determines the general amount of beam slanting, in relation
to the intervals of the notes connected by beams.

• Minimum Slant: Determines the minimum interval of notes that causes beams to be
slanted.

• Maximum Slant: Determines the maximum beaming slant angle.

These parameters work relatively to a particular scoring situation, which is why no
explicit settings can be given. Again, it is essential to try different combinations when
working on the final layout of a piece.

• Default Pedal Position field: This determines the vertical position of automatic pedal
symbols (those created when you use the MIDI sustain pedal during a real-time
recording). If this parameter is set to zero, recorded MIDI sustain pedal events are hidden
in the score. Pedal marks that you manually insert from the Part box are not affected
by this parameter.

• “Open” Single Staffs checkbox: Displays single staffs without vertical lines at their start
point (left side of the clef ).

• Justify Last Staff checkbox: Lengthens the last line (the last staff system, in full scores)
to the right page margin.
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• Hide Muted Regions checkbox: Excludes muted regions from the score display. If the
option is not selected, muted regions are displayed in the score, even though they
won’t be heard during MIDI playback.

• Hide Muted Tracks checkbox: Excludes muted tracks from the score display. If the option
is not selected, muted tracks are displayed in the score, even though they won’t be
heard during MIDI playback.

• Hide Muted Notes checkbox: Excludes muted notes from the score display. If the option
is not selected, muted notes are displayed in the score, even though they won’t be
heard during MIDI playback.

• Show Alias checkbox: Switches the display of aliases in the score on or off. (See Working
with Aliases in the Score Editor.)

• Allow Alias Editing checkbox: Switches alias editing on or off. (See Working with Aliases
in the Score Editor.)

• Alternate Repeat Symbols checkbox: If this option is selected, all repeat signs in the
project are displayed with real book-style brackets.

• Breve pop-up menu: Switches between four different shapes of breve notes, as well as
the default no breve setting (which disables any breve notes).

Numbers & Names Settings
These settings affect the automatic display of page numbers, bar numbers, and instrument
names in the score.
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Note: For each of these options, you can set the font, size, and face by clicking the Choose
button.

Page Numbers Settings
• Page Numbers checkbox: Select to turn on the display of page number parameters.

• Horizontal Position pop-up menu: Alters the horizontal alignment on the page. Choose
from:

• Alternating: Alternating, beginning on the right side.

• Left, Right, or Centered: These are self-explanatory.

• Rev. Alternating: Alternating, beginning on the left side.

• Vertical Position pop-up menu: Alters the vertical alignment on the page. You can choose
either Top or Bottom.
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• Page Offset field: This value is added to each actual page number, for display purposes.
This can be useful when writing a piece consisting of several parts, which are saved as
separate project files. To retain continuous page numbers throughout the score, you
can set this parameter to the number of pages contained in all preceding parts (project
files).

• Horizontal Distance field: The horizontal distance from the outermost printing position
on the page. This is only relevant for page numbers with the Horizontal Position
parameter set to Alternating or Rev. Alternating.

• Vertical Distance field: The vertical distance to the highest or lowest printing position
on the page (depending on whether Vertical Position is set to Top or Bottom).

• Hide 1st Page Number checkbox: Prevents the display (and printout) of the page number
on the first page. (All others are displayed and printed.)

• Prefix checkbox: Allows you to enter text which will be displayed with every page
number.

For example, if you use the prefix Page, the word Page, followed by a space and the
actual page number, is displayed on each page. This means that page three will display
Page 3. If you want the page number in the middle of the prefix, you need to use the
# symbol as a variable for the page number. For example, “- pg.# -” on the second page
prints as “- pg.2 -.”

You can also use the following text symbols to include automatically generated text
in the prefix:

• “\ i” for the score set name

• “\ n” for the project (file) name

• “\ s” for the name of the currently shown display level, which can be the MIDI region
or folder name (or even the project name, on the highest level)

• “\ d” for the current date (at the time of printout)

Bar Numbers Settings
• Bar Numbers checkbox: Select to turn on the display of bar number parameters.

• Horizontal Position pop-up menu: Choose either At Bar Line or At Bar Center.

• Vertical Position field: The height above the staff. If a negative value is set here, the bar
numbers are placed below the staff.

• Step field: This value controls the interval (in bars) between the display of bar numbers.
A value of 4, for example, results in bar numbers at the first, fifth, ninth bar, and so on.
If you only want bar numbers to be displayed at the beginning of each staff line, set
this parameter to 0.

• Bar Offset field: This value is added to all actual bar numbers, for display.

• Start with field: Automatic numbering begins at the bar indicated here.
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• Hide Bar Numbers in Linear View checkbox: Linear view refers to non-Page view.

• Follow Staff Size checkbox: Displays bar numbers according to staff size.

• Count Multiple Rests checkbox: Displays the first and last bar number below multiple
rests. This makes sense if a negative Vertical Position value is chosen, causing bar
numbers to be shown below staffs.

• Show at Double Bars checkbox: Displays bar numbers at every double bar line and repeat
sign, independent of the chosen Step setting. For example, if Step is set to 0 (and
Double Bars is activated) bar numbers are displayed at the beginning of each staff line,
and above or below all double bar lines and repeat signs.

• “Top/Bottom Staff only” checkbox: In full scores, the bar number is only displayed above
the top staff, if this option is selected. (A negative Vertical Position value results in the
number being shown below the bottom staff.)

Instrument Names Settings
• Instrument Names checkbox: Select to turn on the display of instrument name

parameters.

• Position pop-up menu: Choose from Above Staffs or Beside Staffs.

• Align pop-up menu: This refers to the space preceding staffs. Choose either Left (at the
left margin) or Right (at the right margin).

• 1st Staff pop-up menu: Choose one of the following to display the instrument name at
the first staff:  No Names, Short Names, or Full Names.

• Other Staffs pop-up menu: As above, for other staffs.

Tablature Settings
Guitar tablature is an alternative method of notating music for fretted string
instruments—especially for guitar and electric bass—but also for other fretted instruments,
with four to six strings (or courses of strings).

In this system, the horizontal lines represent the strings of the instrument. Notes are
always written on the line/string at which they are played. The fret numbers are shown
instead of regular note heads.
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Logic Pro automatically converts notes into tablature, if a staff style containing a Clef
parameter set to one of these tuning sets, is used. The exact characteristics of these tuning
sets are determined in the Guitar Tablature pane.

Twelve different tuning sets can be defined. Each of them corresponds to one line in this
pane. The regular guitar and bass tunings are already included as defaults (first line and
last five lines), as are some of the more common guitar tunings.

Tuning Set Parameters
• Name field: Double-click the Name field to change the name in the text entry field.

• Strings pop-up menu: Choose the number of strings (between three and sixteen).
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Note: Up to eight strings are shown directly within the pane. If more than eight are
selected, you can move the visible section by clicking the arrows, or dragging the
scroller.

• Assign pop-up menu: Select the method for automatically assigning notes to strings
(see Determining the Assign Method).

• 1 to 16 fields: Double-click to type, or drag vertically to select, the pitch that the open
strings are tuned to.

Common Parameters
• Head Style button group: Allows you to choose between the following four head styles:

• Numbers Only

• Numbers in Circle

• Circle 1/1, 1/2 Notes Only

• Black and White (1/1, 1/2 Notes) Circles

• Bass String buttons: Click to determine the display of the lowest string. It may be the
same as other strings, or slightly thicker.

• Up- and Down Strum buttons: Click to change the style of the Up- and Down Strum
objects displayed in the Chord Grid and Tablature Markings part box.

TAB Marking Parameters
• Palm Mute field: Customize the name, font, and size of the Palm Mute object in the

Chord Grid and Tablature Markings Part box.

• Let Ring field: Customize the name, font, and size of the Let Ring object in the Chord
Grid and Tablature Markings Part box.

• Slap field: Customize the name, font, and size of the Slap object in the Chord Grid and
Tablature Markings Part box.

• Line pop-up menu: Adjust the line:  solid, dashed, or dotted.

Determining the Assign Method
As most notes can be played at different positions (frets) on different strings, the Assign
parameter performs an essential role. In most cases, the MIDI channels of the individual
notes determine the string assignment.

Note: The MIDI channel parameter of an individual note has no impact on MIDI playback.
The playback channel is determined in the track instrument’s Parameter box in the Arrange
window.

Click in the Assign column (for the corresponding Tuning Set), and choose from the
following string assignment options:
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Pitch
Logic Pro assigns each note to the string on which it is playable, at the lowest possible
position. In order to influence the string assignment, there is a rule (in Pitch mode only)
that a note’s fret position cannot be lower than its MIDI channel.

This method is generally used when notes are recorded from a MIDI keyboard:

• An A3 (on MIDI channel 1) is displayed on the second fret of the G string. If you want
the note to be displayed at a higher position (to correctly display the proper fingering
of a passage), you need to set its channel to 3 or higher. This means that the fret position
cannot be lower than 3, so the note will be displayed at the D string’s seventh fret.

• If the channel is between 8 and 12, the A3 is assigned to the A string on the 12th fret,
and to the low E string (17th fret) for channels 13 to 16.

If you want to force even higher positions, you need to use one of the other assignment
modes.

Channel
In this mode, the number of the string (1 to 6, counted from the lowest string) corresponds
to the MIDI channel. Channels 7 to 16 are assigned to the highest string.

Inv. Channel
Like Channel, but counted from the highest string (1) to the lowest (6 and above). This
way of numbering the strings is generally used in traditional guitar literature.

Note: As most Guitar-to-MIDI Converters send notes (played on different strings) on
different MIDI channels, the Channel and Inv. Channel modes are suitable if you’re using
a MIDI guitar to record MIDI regions. The tablature notation is displayed exactly as the
music was played during recording.

Inv. Ch–1 and Inv. Ch–2
These modes should be used when recording and notating electric bass parts with
Guitar-to-MIDI Converters.

• “−1” is designed for five-string bass (with an additional high B string).

• “−2” is designed for four-string bass.

The principle is the same as Inv. Channel mode, but the number of the MIDI channel is
reduced by 1 or 2, in order to properly convert the channels for bass string assignment.

The string assignment for a four-string bass will be 3 to 6, and 2 to 6 (counted from highest
to lowest string in both cases) for a five-string bass, just as with guitar strings that sound
one octave higher. Notes on channel 1 will be assigned to the highest string.

Further Information on Tablature Notation
In all of these Assign modes, notes below the lowest string are not displayed at all.
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A further point to note is that notes can generally only be assigned to strings on which
they are actually playable (F2 can only be played on the lowest string of a guitar, so the
channel assignment is completely ignored in this case).

You can create a two-staff style that displays the MIDI region twice:  once using regular
music notation, and once as tablature. The indicated split point can be ignored in this
situation. A default style for this (named Guitar Mix) is found in the Logic Pro default
project.

You cannot insert clef changes in tablature staffs. If you want to change between tablature
and regular notation in the same staff, you need to cut the MIDI region, and assign the
specific staff styles to the resulting regions.

Guitar tablature relates to a regular treble clef. If you use the octave-transposing treble
clef (Treble8) for guitar notation (as done in most guitar music), you need to set the
tablature’s Transpose parameter to +12 in the Staff Style window.
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Chords & Grids Settings
These are general display options for chords and chord grids.

Chords Settings
• Root Font field: Defines the font for the chord symbol’s root note.

• Extension Font field: Defines the font for the chord symbol’s extensions.

• Follow Staff Size checkbox: Displays chord symbols according to staff size.

• Slash Note Position pop-up menu: Defines the position of the slash note.

• Accidental Scale field: Changes the accidental size, in relation to the font size
setting:  Positive values result in an increased size, negative values in a diminished size
of chord symbol accidentals.

• Language pop-up menu: Allows you to choose between seven chord symbol languages.
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• Alignment pop-up menu: Determines the general horizontal alignment of chord
symbols—with an Align parameter set to def (default)—in relation to their bar position.

Grids Settings
• Grids Font field: Sets the general grid font.

• Grid Scaling: Reduced field: Sets the size of the first chord grid when added in the Score
Editor.

• Grid Scaling: Normal field: Sets the size of the second chord grid when added in the
Score Editor.

• Grid Scaling: Enlarged field: Sets the size of the third chord grid when added in the Score
Editor.

• Chord Scaling: Reduced field: Sets the size of the chord on the first chord grid when
added in the Score Editor.

• Chord Scaling: Normal field: Sets the size of the chord on the second chord grid when
added in the Score Editor.

• Chord Scaling: Enlarged field: Sets the size of the chord on the third chord grid when
added in the Score Editor.

• Show Fingering checkboxes: Select these to show the fingering numbers on the chord
grid symbols in the Score Editor.

• Minimum Number of Frets field: Defines the number of frets (four, five, or six) on chord
grids.

• Barre buttons: Defines the Barre style on chord grids, whether Tie or Block.

• Thumb buttons: Defines the representation of the Thumb fingering marking on chord
grids. It can be represented by a “5” or a “T.”

• Left-Handed checkbox: Changes the chord grid orientation for a left-handed user.
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Clefs & Signatures Settings
These are general display options for clefs, key signatures, and time signatures.

Clefs Settings
• Clefs pop-up menu: Allows you to choose between the following clef display

parameters:  Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide All.

• Display Warnings at Line Breaks checkbox: Causes warning clef changes to be displayed
at the end of a staff or staff system (if the actual change is at the beginning of the
subsequent staff or staff system).

• Smaller Clef Changes pop-up menu: Clef changes (whether caused by a change of staff
style, or by a new clef inserted from the Part box) can be displayed at a smaller size
than the clefs at the beginning of staffs, depending on this setting.
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Key and Time Signatures Settings
• Key Signatures pop-up menu: Allows you to choose between the following key signature

display parameters:  Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide
All.

• Display Warnings at Line Breaks checkbox: Causes warning key signature changes to be
displayed at the end of a staff or staff system (if the actual change is at the beginning
of the subsequent staff or staff system).

• Automatic Key Transposition checkbox: This setting enables the automatic transposition
of key signatures in transposing staff styles. It is usually selected. An exception is for
the notation of atonal music. If unselected, all sharps and flats are displayed directly
with the notes.

Note: There is a similar option in the Staff Style window (Key parameter), which allows
you to turn off the key signature for individual staff styles, or even for individual staffs
in multistaff styles.

• Minimize Transposed Accidentals checkbox: This allows the use of enharmonically changed
key signatures, if this results in a signature with fewer accidentals. For example, if a
piece is written in B major (5 sharps), the Bb instruments are notated in Db major (5
flats) instead of C# major (7 sharps).

Note: Logic Pro does not display key signatures with more than seven flats or sharps,
whether or not this option is activated.

• Show Naturals checkbox: Select this checkbox to display naturals at key signature
changes, where preceding accidentals are no longer valid (when changing from E major
to G major, or to C minor, for example).

• Show Grace Accidentals checkbox: If this option is activated, courtesy accidentals are
automatically displayed. This means wherever a diatonic note is altered by an accidental,
another accidental (a natural symbol, in many cases) is displayed when that note appears
(unaltered) in a subsequent bar.

• Time Signatures pop-up menu: Allows you to choose between the following time
signature display parameters:  Every Staff, First Staff on Every Page, First Staff on Page
1, and Hide All.

• Display Warnings at Line Breaks checkbox: Causes warning time signature changes to
be displayed at the end of a staff or staff system (if the actual change is at the beginning
of the subsequent staff or staff system).

• Size pop-up menu: Alters the appearance of the meter (often much larger, for conducting
purposes) on the staff. It is expressed as regular and percentage values. Single systems
will show both numbers (4/4, for example) on the system. Double systems will show
the upper number on the upper system, and the lower number on the lower system.

• Hide Bar Lines checkbox: Allows you to hide all bar lines, which can be useful for
educational material, gregorian plain chant notation, and other special situations.
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Note: Only automatically displayed bar lines are hidden, so it’s still possible to insert
bar lines from the Part box, including the regular bar line, which will be displayed and
printed.

Octave Symbols Settings
• +8, –8, 0, +15, –15 fields: Allow you to edit the text string (and text formatting) of the

different octave symbols. Click the appropriate field, and enter the text.

• Choose button: Click to select a different font, font face, or size.

• Follow Staff Size checkbox: Displays octave symbols according to staff size.

• Line pop-up menu: Adjust the line:  solid, dashed, or dotted.
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Layout Settings
The Layout pane is where you can define a number of display settings for the whole
project, such as staff line thickness, stem length, distance between notes and ties, or
notes and dots, and so on.

Line Thickness Settings
• Line Thickness parameters: This group of parameters determines the line thickness of

the following objects:  staff lines, stems, ledger lines, bar lines, repeat and end lines,
tuplet brackets, text boxes (for boxed text styles), crescendi/decrescendi (also affects
line objects and arrows), ties, and slurs.
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Note: If you have a high-resolution printer, try to use smaller line thickness settings (2,
or maybe even 1). Smaller staff lines, in particular, look much better. The other parameter
settings are more a matter of personal preference. These changes are only visible at
high zoom levels on the screen. To really judge the results, try some printouts with
different settings. The Slur and Tie Thickness parameters are affected by the Scale
parameter in score sets, and the Size parameter in staff styles.

Spacing Settings
• Bar Start Spacing and Bar End Spacing fields: Changes the relative distance between the

first and last note of a bar, and the preceding or subsequent bar line. Keep in mind that
changing the default settings of these parameters only makes sense if rather extreme
values have been chosen for the general Spacing parameters in the Global Score project
settings pane.

• Dot to Note Distance and Dot to Dot Distance fields: Determine the distance between
the note heads and dots, for dotted notes. Dot/Dot Distance refers to double dotted
notes.

• Accidental to Note Distance field: Allows you to globally alter the horizontal distance of
accidentals from the corresponding note heads. The default setting should only be
changed if very small values are used for the Spacing parameters, which results in a
tiny distance between notes. This global setting can also be combined with the
Accidental Distance parameter of individual notes, in the Note Attributes window.

• Accidental to Accidental Distance field: Allows you to globally alter the horizontal distance
between several accidentals, in chords.

Other Settings
• Stem Length field: Determines the default setting for stem length.

• Horizontal Tie Position and Vertical Tie Position fields: Determine the distances between
note heads and related ties (which are displayed automatically).

• Factory Defaults button: Click to reset all parameters to their default settings.
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MIDI Meaning Settings
The settings in the MIDI Meaning pane determine if, and to what extent, the insertion of
the listed symbols affect the MIDI playback of notes (that these symbols are attached to).

The above symbols change the MIDI output of all notes they are attached to. Two
parameters can be determined for each symbol:  velocity and length.

The MIDI Meaning functions are most useful when you’re inserting notes with the mouse.
This makes it possible to work as if writing music on paper.

• First, you write/insert the notes. They will all have the same velocity, and identical
rhythmic note values will have exactly the same length.

• Accents and phrasing marks are then attached to some of the notes, which changes
the velocity and (playback) length of these notes.
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This makes playback sound much more realistic and alive.

The default settings in the MIDI Meaning pane (in new projects) are 0 for velocity, and
100% (no change) for length. If you don’t change these values, the symbols remain purely
graphical, and do not affect MIDI playback.

If you record your regions in real time (from a keyboard), it’s better to leave these settings
at the defaults, as the notes probably already sound the way you want them to.

Important: If you do use MIDI Meaning, you need to adjust the settings before you begin
to insert accents and so on. This is because the settings have no influence on accents
and phrasing marks that have already been inserted.

Once set, the velocity and length of notes will be changed as soon as you attach one of
these symbols to a note. When you delete the symbol, note velocity and length are reset
to their initial values.

• Velocity: This value is added to, or subtracted from, the original velocity value of the
corresponding note.

• Length: The original note length is shortened by the percentage chosen here. This only
affects the playback of the note, not the score display. The note length change can be
seen in the Event Parameter box or in the Event List.
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Color Settings
The Colors pane determines the color palette for the currently active project.

The color palettes are used by different color modes. (See Choosing a Color Mode.) Clicking
any color opens the standard Colors window, allowing that particular color to be changed.

Colors are saved with the project, and can be different for each project.

There are three palettes, and some additional options in this pane.

Pitch Colors Settings
• Pitch Color Type buttons: Each note of the octave is assigned a color. They are arranged

like piano keys. You have the following two choices when it comes to pitch color:

• Diatonic: Allows you to use seven different colors.
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• Chromatic: Allows you to use twelve different colors.

• Pitch Color buttons: Click any color to open the standard Colors window and change
that particular color.

Velocity Colors Settings
• Velocity Colors buttons: These eight colors are applied in accordance with the MIDI

velocity of notes, from left (minimum) to right (maximum). Click any color to open the
standard Colors window and change that particular color.

Note Color Options
• Accidentals checkbox: Determines whether accidentals are displayed in color (according

to their note associations), or in black.

• Dots checkbox: Determines whether dots are displayed in color (according to their note
associations), or in black.

• Rests checkbox: Determines whether rests are displayed in color (according to their
note associations), or in black. Rest colors only apply to user rests, which are mainly
used in polyphonic staff styles.

User Palette Settings
• User Palette Color buttons: These colors can be freely edited and named. Click any color

to open the standard Colors window and change that particular color. Double-click the
text entry boxes to edit the names. These names are displayed as color options in
different color selection menus (staff styles, note attributes).

Other Settings
• Factory Defaults button: Click to reset all changes you have made in the Colors pane.
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Video Project Settings
In the Video project settings, you can define the video output, determine the video sound
output, and offset the video from the project.

To open the Video project settings
Do one of the following:

µ Choose File > Project Settings > Video (or use the Open Video Project Settings key
command, default assignment:  Option-V).

µ Click the Settings button in the Arrange toolbar, then choose Video from the pop-up
menu.

µ Control-click the Movie window, then choose Video project settings.

• External Video Output checkbox: Select to turn on external video output to your video
monitor.

• Video Output pop-up menu: Allows you to choose from the following output modes:

• DVCPRO HD: Choose this option to output the QuickTime video file to a DVCPRO HD
device that is connected to your system.

• Digital Cinema Desktop: Choose this option to preview your video on any available
display unit that is connected to an AGP graphics card. (Displays connected to a PCI
graphics card cannot be used by Digital Cinema Desktop.) If you have two computer
displays, one can be used to view the Logic Pro interface, while the other can be
used as a dedicated video monitor. When you select this option, the Anamorphic
checkbox appears. In some rare cases (such as when a 4:3 video signal contains a
16:9 picture), Logic Pro may not recognize the video format automatically. You should
select this checkbox if your video appears horizontally compressed or stretched.
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• FireWire: Choose this mode to output QuickTime movies from your project to a
FireWire device. (Your FireWire DV device must be connected at the time.) For
technical reasons, only QuickTime movies in DV format are supported.

• Video Format pop-up menu: When either the Digital Cinema Desktop or FireWire option
is chosen from the Video Output pop-up menu, the Video Format pop-up menu
becomes available.

• Digital Cinema Desktop offers three choices:  Preview, Full Screen, and Raw.

• FireWire offers several PAL and NTSC format options, at different frame rates and
resolutions. Choose the most appropriate format for your project.

• Sound Output pop-up menu: Offers three choices:

• Mute: The audio track of the video file is disabled.

• System Sound: The audio track of the video is played through the System Sound
device (as defined in the Audio MIDI Setup utility).

• External Device: Choose this option to route the audio track of the video file to an
external device. In general, you would be most likely to use this option when FireWire
is selected in the Video Output pop-up menu.

• Movie Start field: You can enter the SMPTE offset value directly in the Movie Start field.
This is independent of the SMPTE offset for the project. This allows you to work from
bar one (1 1 1 1 in the Transport bar), even if the video time code—at a particular point
in the video—is several minutes into the movie file. Put simply, this makes your life
easier when creating a soundtrack for all, or part of, a movie file. You can fine-tune the
offset of internal and external video in Video preferences, which affect global projects.
(See Video Preferences in Logic Pro.)

• Movie Volume slider: Sets the level of the video file audio track.

• Follow Tempo checkbox: Select to make the QuickTime movie run at the chosen tempo
value (see Basis Tempo field below) until it receives a tempo change message from the
Tempo track.

• Basis Tempo field: Set a tempo value for the QuickTime movie.
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Assets Project Settings
The project assets refer to all audio files, EXS instruments, and other data associated with
the project. Ideally, you should save all project assets with the project file, but on certain
occasions you may prefer not to.

To open the Assets project settings
Do one of the following:

µ Choose File > Project Settings > Assets (or use the Open Assets Project Settings key
command).

µ Click the Settings button in the Arrange toolbar, then choose Assets from the pop-up
menu.

• “Copy external audio files to project folder” checkbox: Copies the audio files to your project
folder.

• “Convert audio file sample rate when importing” checkbox: Converts the sample rate of
all imported files (with a different sample rate) to match the project sample rate.

• “Copy EXS instruments to project folder” checkbox: Copies EXS instruments to your project
folder.

• “Copy EXS samples to project folder” checkbox: Copies EXS samples to your project folder.
If you turn off this option, only EXS instrument files will be copied to the project folder
when saving, not the samples associated with the EXS instrument files.

• “Copy Ultrabeat samples to project folder” checkbox: Copies Ultrabeat samples to your
project folder.

• “Copy SpaceDesigner impulse responses to project folder” checkbox: Copies SpaceDesigner
impulse responses to your project folder.

• “Copy movie files to project folder” checkbox: Copies the QuickTime movie used in the
project to your project folder.
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Preferences allow you to define many of the basic operating parameters of Logic Pro.
This chapter explains each of these preferences.

Note: Unless otherwise indicated, the descriptions of the various parameters apply when
the selection box beside the option is selected (in other words, when it’s active).

This chapter covers the following:

• Accessing Preferences (p. 1265)

• Saving Preferences (p. 1266)

• General Preferences in Logic Pro (p. 1267)

• Audio Preferences in Logic Pro (p. 1275)

• MIDI Preferences in Logic Pro (p. 1290)

• Display Preferences in Logic Pro (p. 1295)

• Score Preferences in Logic Pro (p. 1300)

• Video Preferences in Logic Pro (p. 1302)

• Automation Preferences in Logic Pro (p. 1303)

• Control Surface Preferences in Logic Pro (p. 1305)

• Sharing Preferences in Logic Pro (p. 1307)

Accessing Preferences
There are several ways to access preferences in Logic Pro.

• Via the Logic Pro > Preferences menu

• Via the Preferences button in the Arrange toolbar

• Via local menus (in the Score Editor, for example), buttons on the Transport bar, or
shortcut menus

Tip: You can also use the Open Preferences key command to open the Preferences
window. (The most recently accessed preference pane is displayed.)
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These and several other access methods are outlined throughout the chapter.

The Preferences window features a number of icons and tabbed panes. These behave
much like menus and submenus. To adjust a given preference, select the icon you want,
then the appropriate tab. Once the pane or window is shown, activate or deactivate the
preference, or make your selection from a pop-up menu. Close the window once you’ve
made your selections.

In some instances, you will find a button in the Preferences window that links to related
parameters in the Project Settings window, and vice versa. Clicking this button opens the
Project Settings window, and automatically selects the relevant pane. For example, the
Logic Pro > Preferences > MIDI > Sync pane features a MIDI Sync Project Settings button.
Clicking this button opens the Project Settings > Synchronization > MIDI pane.

Both the Preferences window and the Project Settings window can be visible at the same
time, making setup of operating parameters faster and clearer.

Saving Preferences
Preferences are automatically saved whenever you quit Logic Pro. The settings made in
the Preferences window are saved in a general preference file, stored in the
~/Library/Preferences folder. It is named com.apple.logic.pro.plist. Preference settings
apply to all projects.
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A separate preference file, also stored in the same location, is made for control surfaces.
It is named com.apple.logic.pro.cs.

Note: You can’t open either preference file directly. Any changes must be made in
Logic Pro.

If you accidentally or intentionally erase a preference file, Logic Pro creates a new one
the next time it is opened. All parameters will be reset to their default values.

To initialize all preferences (but not your key commands) directly in Logic Pro
Do one of the following:

µ Choose Logic Pro > Preferences > Initialize All Except Key Commands (or use the
corresponding key command).

µ Click the Preferences button in the Arrange toolbar, then choose Initialize All Except Key
Commands from the pop-up menu.

General Preferences in Logic Pro
General preferences consist of the following tabs:  Project Handling, Editing, Cycle, Catch,
and Caps Lock Keys.
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To open General preferences
Do one of the following:

µ Choose Logic Pro > Preferences > General (or use the Open General Preferences key
command).

µ Click the Preferences button in the Arrange toolbar, then choose General from the pop-up
menu.

General Project Handling Preferences
Project Handling preferences determine how Logic Pro handles projects.

• Startup Action pop-up menu: The Startup Action pop-up menu allows you to choose
from a number of project options that happen automatically when Logic Pro is opened.
You can choose from:

• Do Nothing: Nothing happens when Logic Pro is opened; you need to create a new
project, or open an existing project or template.

• Open Most Recent Project: Opens the project you were working on when you last
closed Logic Pro.

• Open Existing Project: Shows the Open dialog, allowing you to browse for an existing
project.

• Create New Project from Template: Opens the Templates dialog.

• Create New Empty Project: Loads an empty project and opens the New Tracks dialog,
allowing you to specify the number and type of new tracks to be created.
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• Create New Project using Default Template: Opens the default template and the Save
As dialog, allowing you to name and save your project.

• Ask: Opens a Startup dialog, offering each of the above options.

• Default Template field: You can determine the default template by clicking the Choose
button below the Default Template field. The full path and name of the chosen template
or project is displayed in the Default Template field. You can assign any template or
project as the default template.

• “When opening a project, ask to ‘Close current project(s)?’” checkbox: Whenever you load
a new project before closing the old one, a dialog appears, asking whether or not the
current project should be closed. If this option is left unselected, you are not asked the
question, and the current project remains open.

• “‘Export MIDI File’ saves single MIDI Regions as Format 0” checkbox: If only one MIDI region
is selected when you use the File > Export > Selection as MIDI File command, the
contents of the region are saved in MIDI file format 0. This file format is guaranteed to
be compatible with every MIDI file player.

• Auto Backup pop-up menu: Sets the number of backup copies for the project.
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General Editing Preferences
The Editing pane contains the following preferences:

• Right Mouse Button pop-up menu: Determines the right mouse button behavior
(assuming you have a suitable mouse).

• Is Assignable to a Tool: A third Tool menu (Right-click Tool menu) appears to the right
of the Left-click and Command-click Tool menus. Choose the appropriate menu item
to assign the tool, which is available when the right mouse button is pressed while
editing.

• Opens Tool Menu: Opens the Tool menu with the Pointer tool (and not the currently
selected tool) located under the mouse pointer. Simply choose the tool you want by
clicking it. When the Tool menu is open, you can also use the key shown next to a
tool to select it.

• Opens Shortcut Menu: Displays a menu that offers a number of area-specific selection
and editing commands.

• Opens Tool and Shortcut Menu: Opens the Tool menu as well as the shortcut menu,
which offers a number of area-specific selection and editing commands.

• Pointer Tool in Arrange Provides:  Fade Tool Click Zones checkbox: When this checkbox is
selected, placing the mouse pointer over the upper-left and upper-right edges of a
region activates the Fade cursor and behavior. The Loop cursor and behavior can still
be accessed in these click zones by holding down the Option key.
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• Pointer Tool in Arrange Provides:  Marquee Tool Click Zones checkbox: When this checkbox
is selected, placing the mouse pointer over the lower half of a region (with the exception
of the lower-left and lower-right edges) activates the Marquee cursor and behavior.

• Limit Dragging to One Direction In:  Piano Roll and Score checkbox: When this checkbox
is selected, you can only move notes in one direction (horizontally or vertically), per
operation, when editing in the Piano Roll or Score Editor. This means that a note may
be either transposed, or moved in time, but not both at once. This prevents accidental
alterations of one or the other parameter.

• Limit Dragging to One Direction In:  Arrange checkbox: This option restricts the direction
you can move regions (including folders) in the Arrange area, in a similar way to the
option above.

• Double-clicking a MIDI Region Opens pop-up menu: Determines the editor that is opened
when you double-click a MIDI region in the Arrange area.

• Score: Opens the Score Editor.

• Event List: Opens the Event List.

• Piano Roll: Opens the Piano Roll Editor.

• Hyper Editor: Opens the Hyper Editor.

• Number of Undo Steps field: Determines the number of undo steps.

• Add ‘Last Edit Function’ to Region Name checkbox: After performing any edit operation
(cutting, for example), the description of the edit operation is added to the name of
the region (or resulting regions).

• “’Living Groove’ connection” checkbox: Select this checkbox to make sure that editing
an original region also alters any quantization template derived from that region. Leave
the checkbox unselected to make sure that the groove template remains as created.
This allows you to edit the region without affecting the quantization template.

• “SmartLoop handling of Scissors and ‘Split by Playhead’” checkbox: This option determines
how Logic Pro handles the cutting of looped regions.

• If you select this option, you can cut the looped area of regions (using the Scissors
or Marquee tool, or Split by Playhead command). Logic Pro automatically creates
regions after—and, if necessary, before—the cut, ensuring that these areas remain
identical. This allows you to split looped regions without altering playback in the
looped area.

• If the “SmartLoop handling of Scissor and Split by playhead” option is not selected,
you cannot cut looped areas. Cutting the looped region itself deactivates the Loop
parameter in the Region Parameter box.
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• “Select Regions on Track selection” checkbox: When this checkbox is selected, selecting
a track automatically selects all regions on the track lane (or regions within the cycle
or autopunch area if Cycle or Autopunch is enabled). Turn off the preference if you
don’t want regions to be automatically selected when the track header is chosen. When
the preference is disabled:

• Option-clicking the track header or associated channel strip continues to select the
track and all associated regions.

• Option-Shift-clicking adds the selected track’s regions to the current selection.

General Cycle Preferences
The Cycle pane contains the following preferences:

• Cycle Pre-Processing pop-up menu: In order to ensure a smooth cycle jump (from the
end point of a cycle back to the start point of a cycle), the cycle jump is processed
slightly before its actual position. This preference allows you to change the
pre-processing time. A value of 1/96 is chosen by default, which should be suitable for
most uses.
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• Smooth Cycle Algorithm checkbox: This option improves the timing of cycle jumps,
making it easier to set the length of sample loops while in Cycle mode—although this
is somewhat mitigated through the use of Apple Loops. If your computer has a very
slow processor, this setting reduces the processing requirements for graphics operations.
In general, you want to keep this on whenever possible, especially if you’re working in
a style that involves frequent cycling of musical sections. If you find that your cycled
sections are not as smooth as you’d like (assuming that your loops are actually perfect),
you might achieve better results by deselecting this parameter.

General Catch Preferences
The Catch pane contains the following preferences:

• “Catch when Logic starts” checkbox: Every time you start playback (including paused
playback), the Catch function is turned on automatically, in all windows.

• “Catch when moving playhead” checkbox: Selecting this option ensures that whenever
you move the playhead, the Catch function is turned on automatically. This makes it
easier to perform edits, as moving the playhead in the Arrange area is reflected in the
open editor window, and vice versa.

• “Catch content by position if Catch and Link are enabled” checkbox: If the Catch and Link
buttons are active (Content Catch mode), the contents of the region at the current
playhead position are shown. If this option is turned off, the window view still follows
the playhead position within the displayed region, but does not update to show the
contents of subsequent regions as the playhead passes them (in playback or record
mode).

1273Chapter 44 Preferences in Logic Pro



General Caps Lock Keys Preferences
The Caps Lock Keys pane contains the following preferences:

• Enable Caps Lock Keys checkbox: Allows you to completely enable or disable the Caps
Lock Keyboard functionality.

• “Space bar acts as sustain pedal” checkbox: If you want to use the Space bar key command
to start, stop, or continue Logic Pro playback, rather than as the Sustain function for
the Caps Lock Keyboard (when active), you can deselect the “Space bar acts as sustain
pedal” option.
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Audio Preferences in Logic Pro
Audio preferences consist of the following tabs:  Devices, General, I/O Assignments, Sample
Editor, MP3, Reset, and Nodes.

To open Audio preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences key
command).

µ Click the Preferences button in the Arrange toolbar, then choose Audio from the pop-up
menu.
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Core Audio Device Preferences
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the
default settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio
MIDI Setup). However, it can be advantageous to optimize the settings for your individual
hardware setup, particularly if you use several audio interfaces or a multiple input/output
device.

• Enabled checkbox: Select this checkbox to enable the Core Audio driver.

• System Memory Requirement display: Indicates the amount of free RAM required (outside
of memory assigned to Logic Pro). The requirement value changes as you alter the
parameters described below.

• Output Device pop-up menu: Allows you to choose between any installed Core Audio
device, including the internal sound hardware. This also includes aggregate audio
devices, consisting of several audio interfaces. See the Audio MIDI Setup Help for
information on aggregate devices.
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Note: When setting an output device which also provides inputs, the Input Device
setting changes accordingly. If choosing a different input device, you will be
recommended to use a common Word Clock for both audio devices, in order to ensure
the best sound quality.

• Input Device pop-up menu: Allows you to choose between any installed Core Audio
device, including the internal sound hardware. This also includes aggregate audio
devices, consisting of several audio interfaces. See the Audio MIDI Setup Help for
information on aggregate devices.

• I/O Buffer Size pop-up menu: This parameter determines the size of the buffer used by
the audio hardware for both input and output. The smaller the buffer size, the less
latency you will encounter when monitoring while recording, or using software
instruments.

Some points to note:

• As this parameter value is reduced, it places a higher strain on your system’s processor
or processors.

• There may be a point where the selected I/O buffer size is too small for your system,
and begins to affect playback. This usually takes the form of clicks, pops, and crackles
in your audio.

• You should aim for the lowest possible I/O buffer size value that doesn’t introduce
clicks, pops, and crackles in your audio.

Tip: If you find that a higher I/O buffer size setting provides suitably low latency during
record monitoring and software instrument playback, you should use it. This will
minimize the impact on your system’s processor or processors.

• Resulting Roundtrip Latency/Resulting Output Latency display: Displays either the resulting
roundtrip latency or the resulting output latency for the current I/O buffer size. Click
the display to toggle between the two values.

• Recording Delay slider: Allows you to delay the recording of audio by a certain fixed
value, helping you to compensate for any information delays that are caused by the
audio driver.

Note: You should not normally need to touch this parameter.

• Universal Track Mode checkbox: Universal Track Mode is turned on by default. It allows
you to play back stereo and mono regions on a single track. It should be left on.

You should only turn off Universal Track Mode if using DAE or TDM hardware. For more
information, see the Logic Pro TDM Guide.

• 24 Bit Recording checkbox: When this setting is turned on, Logic Pro can record 24-bit
files. 20- or 24-bit recordings offer a significant improvement in the available dynamic
range, but require high-quality peripheral components such as microphones and
pre-amps, not to mention high-quality analog-to-digital/digital-to-analog converters.
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20- and 24-bit files use one-and-a-half times the disk space of comparable 16-bit files.

Note: Turning on this parameter only makes sense if you are using a 20- or 24-bit
interface.

• Software Monitoring checkbox: This option allows you to turn Software Monitoring
(listening to the actual input signal) on or off. In most situations, you should leave it
on.

Note: When Software Monitoring is on, the audio signal is processed via software, and
a certain amount of audible delay (commonly referred to as latency) is inevitable.

If you are listening to the recorded signal through your mixing console, or your audio
interface supports hardware monitoring, you should turn this option off.

• Independent Monitoring Level (for Record Enabled Channel Strips) checkbox: Select this
checkbox to allow the use of an independent monitoring level for record-enabled audio
channel strips. After record-enabling a track, you can adjust the fader to the level you
want. The original level will be restored when you turn off the record-enable button.

Note: Adjustments to the fader do not affect the recording level; they only affect the
monitoring level.

• Process Buffer Range pop-up menu: This parameter determines the size of the buffer
used to compute mixes and effects. You can choose between Small, Medium, and Large
buffer sizes.

Note: Larger buffer sizes increase latency. Depending on the speed of the processor,
buffer sizes that are too small might compromise real-time audio processing.

• ReWire Behavior pop-up menu: Use this pop-up menu to configure the ReWire behavior
when sending MIDI data to a ReWire-compatible software instrument:

• Playback mode: Use when playing back MIDI tracks via ReWire. This setting requires
less processing power.

• Live mode: Use when playing a ReWire instrument live. This setting uses more
processing resources, but has lower latency.

• Maximum Scrub Speed pop-up menu: This pop-up menu allows you to set the maximum
scrubbing speed. You can choose between the following options:

• Normal: The normal playback speed is used for scrubbing.

• Double: The scrubbing playback speed is twice as fast.

• Scrub Response pop-up menu: The options in this pop-up menu let you set the reaction
time for audio scrubbing. Choose the value that works best for your system
configuration. Options are Slow, Normal, Fast, and Faster.

DAE Device Preferences
DAE Device preferences can only be set after activating the DAE (Digidesign Audio Engine).
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For full details about activating DAE and setting preferences, see the Logic Pro TDM Guide.

Direct TDM Device Preferences
TDM Device preferences can only be set after activating TDM (Time Division Multiplexing).

For full details about activating TDM and setting preferences, see the Logic Pro TDM Guide.

Audio General Preferences
The General pane contains the following preferences:

• “Display audio engine overload message” checkbox: If unselected, playback will simply
stop in an overload situation instead of displaying an alert message.

• Track Mute/Solo pop-up menu: Lets you determine the linking relationship of the Track
Mute and Solo buttons with the corresponding channel strip buttons.

• Fast (Remote Channel Strips): Clicking a channel strip’s Mute or Solo button switches
the state of the associated track button, and vice versa.
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• CPU-saving (Slow Response): Choose to save processing resources, and to make the
Track Mute and Solo buttons independent of the corresponding channel strip buttons.

• Sample Accurate Automation pop-up menu: As the name implies, sample-accurate
automation is the most precise type of automation. It places higher overheads on
system resources, which may affect performance (depending on the nature of your
projects, and available computing power). This is most likely to happen during heavy
project sections where a lot of software instruments and effects are in use. Logic Pro
offers three settings:

• Off: Minimal overhead on system performance for automation playback. Automation
is less precise when this setting is active.

• Volume, Pan, Sends: Only these parameters are automated with sample accuracy.

• Volume, Pan, Sends, Plug-in Parameters: All of these parameters are automated with
sample accuracy. Not all Audio Units plug-ins can be automated in this way.

• Recording File Type pop-up menu: Lets you determine the file type for recorded audio.
The settings are:

• AIFF: The AIFF file format cannot handle audio file recordings larger than 2 GB.

• WAVE (BWF): The most common audio format on Windows PC computers. Files are
stored as Broadcast Wave files, which contain timestamp information in the file
header. The WAV file format cannot handle audio file recordings larger than 4 GB.

• CAF: Choose this setting if you are going to record files larger than 4 GB in size. For
more information, see Choosing the Recording File Type.

• DIM Level slider: This slider lets you set a discrete level for the Dim function. You can
set a dim level from 0 dB to –30 dB. The level chosen here is used when the Dim button
is activated, either from the Master Volume slider on the Transport bar or from the
Master channel strip.

• Plug-in Latency Compensation pop-up menu: Plug-in latency compensation (also called
plug-in delay compensation) is useful for software effect plug-ins, and is particularly
important for DSP (digital signal processing) accelerator hardware (for example,
TC PowerCore and Universal Audio UAD1). It compensates for audio delays that can
be introduced when using plug-ins.

The pop-up menu allows you to activate plug-in latency compensation for either:

• Audio and software instrument tracks

• All (Audio, instrument, auxiliary, and output channels)

You can also turn off compensation entirely. For details, see Working with Plug-in
Latency Compensation.
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• Low Latency Mode checkbox and Limit slider: You need to select the Low Latency Mode
checkbox in order to activate Low Latency mode and use the Limit slider. The Limit
slider lets you determine a maximum amount of allowable delay that can be caused
by plug-ins when Low Latency mode is enabled (by clicking the Low Latency Mode
button on the Transport bar). In Low Latency mode, plug-ins are bypassed to ensure
that all delays (across the entire signal flow of the current track) remain under the Limit
slider value. This is useful when you want to play a software instrument with several
latency-inducing plug-ins inserted in the channel. For more information, see Working
in Low Latency Mode.

• Crossfade Time slider: Lets you determine a default time value for all crossfade operations
in the Arrange area.

• Crossfade Curve slider: Lets you determine a global curve type for all crossfade operations
in the Arrange area.

Audio I/O Assignment Preferences
The I/O Assignments pane offers three further tabs:  Output, Bounce Extensions, and
Input.
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Output Pane
The Output pane consists of the following preferences:

• Stereo Output pop-up menu: Allows you to choose the physical output pair on which
the stereo output is played.

• Mirroring checkbox: Becomes available for all chosen output pairs, with the exception
of Output 1–2. Deselect to have the output signal routed to the chosen output pair
(Output 3–4, for example). Select the checkbox to have the output signal routed to the
chosen output pair (Output 3–4, for example), as well as to the physical outputs (Output
1–2).

• Surround Show As pop-up menu: Allows you to choose the surround format you want
to work in. This choice you make automatically sets the output channel pop-up menus
in the assignment section of the pane.

• Surround Initialize buttons: Allows you to choose between the default setup of Logic Pro,
the ITU (International Telecommunications Union) standard, and the WG-4 standard.
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Bounce Extensions Pane
The Bounce Extensions pane consists of the following preferences:

• Stereo Left and Right fields: Allow you to set the bounce extension.

• Surround Show As pop-up menu: Allows you to choose the surround format you want
to work in. The choice you make automatically sets the channel pop-up menus in the
assignment section of the pane.

• Surround Initialize button: Allows you to reset the bounce extension to its default value.
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Input Pane
The Input pane consists of the following preferences:

• Surround Show As pop-up menu: Allows you to choose the surround format you want
to work in. The choice you make automatically sets the input channel pop-up menus
in the assignment section of the pane.

• Surround Initialize buttons: Allow you to choose between the default setup of Logic Pro,
the ITU (International Telecommunications Union) standard, and the WG-4 standard.
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Audio Sample Editor Preferences
The Sample Editor pane contains the following preferences:

• “Warning before processing function by key command” checkbox: Select this option if you
want to be warned before carrying out a destructive edit in the Sample Editor using a
key command. This gives you the opportunity to cancel the edit operation, before
altering the data.

• “Clear Undo History when quitting” checkbox: Select this option to automatically delete
the Undo History for all edited audio files, when you close Logic Pro.

• “Record selection changes in Undo History” checkbox: Select this option if you want to
undo and redo changes to selected areas in the Sample Editor.

• “Record Normalize operations in Undo History” checkbox: Deselect this setting if you don’t
want to create undo files when the Normalize function is used.

• Number of Undo Steps field: Lets you determine the maximum number of undo steps
that are retained.
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• “Store undo files in project folder” checkbox: Activate this preference if you want the
edited audio files to be stored in a sub-folder of the current project. This is selected by
default if the project is saved with its assets.

• Global Undo File Path field: All files (used by the Undo History) are saved into a global
location—a user-defined folder—if the “Store undo files in project folder” option is not
selected. Click the Set button, and navigate to the appropriate folder.

• External Sample Editor field: You can use an external application for sample editing
operations, effectively replacing the Logic Pro Sample Editor. Click the Set button, and
navigate to the application you want to use.
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Audio MP3 Preferences
The MP3 pane contains the following preferences:

• Bit Rate (Mono/Stereo) pop-up menus: You can choose bit rates between 32 kbps and
320 kbps, but the defaults are 80 kbps mono and 160 kbps stereo. These rates offer
acceptable quality and good file compression. If you can afford the increased file size,
you should choose 96 kbps for mono and 192 kbps for stereo streams. These settings
will deliver better audio quality. You can, of course, choose even higher rates, but the
quality improvement in bit rates above 96/192 kbps is minimal.

• Use Variable Bit Rate Encoding (VBR) checkbox: Variable Bit Rate (VBR) encoding
compresses simpler passages more heavily than harmonically rich passages, generally
resulting in better-quality MP3s. Unfortunately, not all MP3 players can accurately
decode VBR-encoded MP3s, which is why this option is off by default. If you know that
the audience for your MP3 files can decode VBR-encoded MP3s, you can turn this option
on.
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• Quality pop-up menu: Keep this set to Highest whenever possible. Reducing the quality
accelerates the conversion process, but at the expense of audio quality. This option is
only accessible when the “Use Variable Bit Rate Encoding (VBR)” checkbox is selected.

• Use Best Encoding checkbox: Like the Quality parameter, if you deselect this option, you
will gain encoding speed at the price of audio quality. This should always be left on,
unless conversion time is an issue.

• Filter Frequencies Below 10 Hz checkbox: When this option is selected, frequencies below
10 Hz (which are usually not reproduced by speakers, and are not audible to human
ears at any rate) are removed, leaving slightly more data bandwidth for the frequencies
that humans can hear, resulting in an improvement in perceived quality. Only deselect
this option if you’re experimenting with subsonic test tones, or exporting MP3s for
whales.

• Stereo Mode pop-up menu: You can choose between Joint Stereo or Normal Stereo in
this pop-up menu. Depending on the original file, these settings may or may not offer
any audible difference. Experiment with both settings to determine your preference.

Audio Reset Preferences
The Reset pane enables you to send reset messages of a specified type to all active
instrument channels. This can be useful if you are encountering hung notes, or are finding
that controller settings are incorrect when in Cycle mode (or when returning to the
beginning of a section or the project start point).

• “Control 64 off (Sustain)” checkbox: Sends “Control 64 off (Sustain)” reset messages.

• “Control 1 (Modulation) to zero” checkbox: Sends “Control 1 (Modulation) to zero” reset
messages.

• “Pitch Bend to center position” checkbox: Sends “Pitch Bend to center position” reset
messages.
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Audio Nodes Preferences
The Nodes pane gives you the option of enabling distributed audio processing—allowing
you to expand the processing capacity of your Logic Pro system. For details, see Enabling
Distributed Audio Processing.

• Enable Logic Nodes checkbox: Displays a list of those computers that have the Logic Pro
Node application installed, along with an identical plug-in set.
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MIDI Preferences in Logic Pro
MIDI preferences consist of the following tabs:  Reset Messages, General, and Sync.

To open MIDI preferences
Do one of the following:

µ Choose Logic Pro > Preferences > MIDI (or use the Open MIDI Preferences key command).

µ Click the Preferences button in the Arrange toolbar, then choose MIDI from the pop-up
menu.

MIDI Reset Message Preferences
The preferences in this pane are only included for compatibility with older MIDI hardware.
Logic Pro handles MIDI reset messages automatically and intelligently, so you should
generally make sure that all of these options are unselected. (This the default.)
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All selected checkboxes will send a reset message, for the selected controller type, to all
MIDI outputs. This reset message is sent on cycle jumps and when playback begins, but
the use of these options shouldn’t be necessary.
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MIDI General Preferences
The General (MIDI) pane contains the following preferences:

• “External stop message ends recording” checkbox: If you are using external synchronization,
and the timecode stops while recording, record mode is turned off. If this checkbox is
unselected, Logic Pro stops, but remains in record mode (record mode is paused).

• “Always stop when opening project” checkbox: With this setting on, a project will always
be opened in stop mode, even if it was saved in playback mode.

• Reset All MIDI Drivers button: Click to reset all MIDI drivers. This can help if you experience
MIDI communication problems.
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MIDI Sync Preferences
The Sync pane contains the following preferences:

• All MIDI Output: Delay field: Delays or advances the MIDI output for all ports, allowing
you to compensate for any timing differences between MIDI tracks and audio or
(software) instrument tracks.

• MIDI Clock: “Allow to send Song Position Pointer while playing” checkbox: Song Position
Pointer (SPP) data is not normally sent while the sequencer is in Playback mode. (This
is in accordance with the MIDI Standard.) This option allows Logic Pro to send SPP data
while the sequencer is running. The advantage is that external devices can also follow
Logic Pro in Cycle mode. If your external devices cannot process SPP, you should turn
this option off. If your devices can follow MTC (MIDI Time Code), you should leave this
option unselected, and use the MTC functions of Logic Pro.
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• MTC Pickup Delay field: This parameter should generally be set to zero, to ensure the
quickest possible pickup time while Logic Pro is in MTC (MIDI Time Code) Sync mode.
There are, however, some devices that seem to transmit imprecise MTC commands
when first started. As a result, synchronization may be unreliable, and there could be
an offset every time synchronization is established. In such situations, you can set a
delay time before incoming MTC is picked up. Essentially, Logic Pro will ignore the
incoming MTC commands that occur in this time period. A (frame) value of 25 to 30
corresponds to a delay of about one second, depending on the frame rate. Use this
parameter when synchronized to hard disk recorders and other devices, if
synchronization doesn’t appear to be consistent.

• Delay MTC Transmission By field: This parameter allows you to delay the transmission
of MIDI timecode. Negative values result in MTC being transmitted earlier. This enables
you to compensate for any reaction delays (to incoming MIDI timecode) in external
MTC slave devices.

• MMC Uses pop-up menu: Choose between the following settings:

• MMC standard messages: The MIDI MMC specification is strictly followed.

• Old Fostex Format: The old Fostex format is used for MIDI Machine Control.

• Output ID (Transport) checkbox: The All checkbox sends MMC to all ports. The field to
the right allows you to specify an output port ID.

• Input ID (Transport) checkbox: The All checkbox sends MMC to all ports. The field to the
right allows you to specify an input port ID.

• Transmit Locate Commands When: “Pressing Stop twice” checkbox: Enables transmission
of MMC Locate commands when the Stop command is pressed twice (using the Stop
button in the Transport bar, or using the Stop key command).

• Transmit Locate Commands When: “Dragging regions or events” checkbox: If this option
is enabled and Logic Pro is stopped (not in Playback or Record mode), MMC Locate
commands are sent with the position of a region that is dragged in the Arrange area.

• “Transmit Record enable commands for audio tracks” checkbox: If this option is selected,
MMC Record Enable/Disable commands are also sent when audio tracks are
record-enabled (armed) or disabled. In addition, any received MMC Record Enable
commands will set the record-enable status of audio tracks.

• MIDI Sync Project Settings button: Click this button to open the MIDI Sync Project Settings
window.
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Display Preferences in Logic Pro
Display preferences consist of the following tabs:  General, Arrange, Mixer, and Piano Roll.

To open Display preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

µ Click the Preferences button in the Arrange toolbar, then choose Display from the pop-up
menu.

1295Chapter 44 Preferences in Logic Pro



General Display Preferences
This pane allows you to alter the appearance of several onscreen components that are
used throughout the program.

• “Large local window menus” checkbox: The title and items of the local menus are
displayed in the normal system font. If unselected, a smaller font is used.

• Wide Playhead checkbox: A thicker playhead is used in all windows.

• Show Help Tags checkbox: This enables help tags throughout Logic Pro. When you hold
the mouse pointer over parameters and tools, a small pop-up description (and/or value)
of the item appears onscreen. When editing, the function name, region or event
name/number, position, and parameter values are shown.

• “Show default values” checkbox: When selected, this option displays default values for
parameters in help tags. This makes it easier to determine the amount of variance from
the default value.

• Display Middle C As pop-up menu: This pop-up menu affects the description of notes in
the editors. The bottom C on a five-octave keyboard (note # 36) is labeled C1, and
middle C (note # 60) is labeled C3. According to this standard, the lowest MIDI note
(note # 0) is called C–2. This is the official standard used by most manufacturers. Use
of the C3 (Yamaha) setting will set Logic Pro to this standard mode. If you select the
C4 (Roland) setting, the bottom C on a five-octave keyboard is labeled C2, and middle
C is labeled as C4. In this standard, the lowest MIDI note is C–1.
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• Display SMPTE, Display Tempo As, and Clock Format pop-up menus: You can use these
pop-up menus to customize the Bar, SMPTE, and Tempo display in the Transport bar.
For further details, see Customizing the Bar, SMPTE, and Tempo Display.

Arrange Display Preferences
These preferences specifically affect the appearance of the Arrange area.

• Background Color pop-up menu: Choose one of three Arrange background color
settings:  Dark, Bright, and Custom. When the latter is chosen, you can set the custom
color by clicking the color field to the right. This opens the Colors window, where you
can define a custom color for the Arrange background.

• Automation Transparency: Regions slider: Higher values increase the color intensity of
regions (in comparison to the track automation lane).

• Automation Transparency: Other Data slider: Brightens the display of (inactive) automation
data. Note that this functionality is dependent on the zoom level of the region.
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Mixer Display Preferences
These preferences specifically affect the appearance of the Mixer area.

• “Open plug-in window on insertion” checkbox: With this checkbox selected, the window
of an effect or software instrument plug-in is automatically opened after inserting it in
the appropriate channel strip slot.

• Default Size pop-up menu: Determines the default size of effect or software instrument
plug-in windows. Can be set between 100% and 200% in increments of 25%.

• Level Meters Scale pop-up menu: Switches level meters between a Sectional dB-linear
scale and an Exponential scale.

• Exponential: Provides higher display resolution in the upper range of the meter.

• Sectional dB-linear: Provides the best possible display resolution across the entire
level range.

• Level Meters Channel Order pop-up menu: Determines the order of channels in
multichannel (surround) level meters.
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Piano Roll Display Preferences
These preferences specifically affect the appearance of the Piano Roll area.

• Background Type buttons: These buttons allow you to choose between a dark or bright
color set in order to edit the color setup.

• White Keys and Black Keys fields: Double-click the color field to open the Colors window.
Select or determine the color for the grid lines, aligned with the white keyboard keys.
Do the same for the black keyboard keys.

• C, D, E Key Brightness slider: Allows you to intensify the brightness of these specific keys
in all octaves, making transposition easier by providing a consistent reference point.

• Bar Lines slider and Dotted checkbox: The Bar Lines slider determines the transparency
of the bar lines. The Dotted checkbox changes the appearance of the solid bar line to
a dotted line.

• Beat Lines slider and Dotted checkbox: The Beat Lines slider determines the transparency
of the beat lines. The Dotted checkbox changes the appearance of the solid beat line
to a dotted line.

• Division Lines slider and Dotted checkbox: The Division Lines slider determines the
transparency of the division lines. The Dotted checkbox changes the appearance of
the solid division line to a dotted line.

• Reset button: Resets all user changes to default values.
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Score Preferences in Logic Pro
Score preferences consist of the following parameters:

To open Score preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Score (or use the Open Score Preferences key command).

µ Click the Preferences button in the Arrange toolbar, then choose Score from the pop-up
menu.

µ Choose Options > Open Score Preferences in the Score Editor.

• “Show region selection colored” checkbox: If this option is activated, the staff lines of the
currently selected MIDI region are displayed in color (blue). All other regions are
displayed with black staff lines. This can be useful when changing the display parameters
of regions, as the parameters in the Inspector’s Region Parameter box only affect the
currently selected regions. If this option is turned off, all staffs are displayed in black,
whether selected or not.

• “Display distance values in inches” checkbox: This setting relates to the measurement
units in the project settings and page rulers (Page view only), which can be in inches
or centimeters. If not selected, the Page view defaults to centimeters.
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• Floating Palette View pop-up menu: Defines the default shape of the Part Box Elements
display when opened as a floating window (see Selecting Part Box Objects).

• “Double-click note to open” pop-up menu: Determines the window that opens when
you double-click a note head:  Note Attributes, Event List, Hyper Editor, or Piano Roll
Editor.

• Selection Color field: Allows you to choose the color of selected objects in the Score
Editor. A Reset button also provides quick access to the default color (if it has been
changed).

• “Use external symbol font (if available)” checkbox: Enables the use of external fonts in
the score. (See Printing the Score.)

• Choose Font pop-up menu: Allows you to choose from any installed scoring (symbol)
fonts, such as the Sonata font.

• Camera Tool:  Write To buttons: Choose either the Clipboard or a PDF File as the
destination for image exports with the Camera tool. (See Exporting the Score as a
Graphic File.)

• “Auto split notes in multi staff chord styles” checkbox and “Split notes At” slider: The “Auto
split notes in multi staff chord styles” preference is only relevant if the chosen default
staff style (on the recording track) is polyphonic, and is using MIDI channels for voice
assignment. In this situation, newly recorded notes are automatically saved with the
different MIDI channels used in the corresponding staff style. They are allocated as per
the split point set with the “Split notes At” preference.
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Video Preferences in Logic Pro
Video preferences (such as how Logic Pro handles video memory, video hardware settings,
and timing adjustments) consist of the following parameters:

To open Video preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Video (or use the Open Video Preferences key
command).

µ Click the Preferences button in the Arrange toolbar, then choose Video from the pop-up
menu.

• Video to Project slider: A global setting for fine-tuning the start point of a movie.

• External Video to Project slider: The same setting as above, but for external FireWire
video devices. This setting compensates for the latency of the video hardware in use,
if applicable.

• Cache Resolution pop-up menu: Resolution of the thumbnails kept in the temporary
internal memory (cache). Higher resolutions display more detail, but take up more
space in the cache.

• Maximum Cache Size slider: Amount of memory reserved for the thumbnail cache. Forty
Megabytes is recommended for medium resolution. For higher resolutions use a higher
value. This section of reserved memory will only be occupied when actual movie data
is displayed.

• “Release output device in background” checkbox: Select this checkbox to release the
chosen output device (set in the Video project settings), when it is not being used in
Logic Pro.

• Video Project Settings button: Click to open the Video Project Settings window.
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Automation Preferences in Logic Pro
Automation preferences consist of the following parameters:

To open Automation preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Automation (or use the Open Automation Preferences
key command, default assignment:  Option-A).

µ Click the Preferences button in the Arrange toolbar, then choose Automation from the
pop-up menu.

• Move Automation with Regions pop-up menu: Determines what happens to track
automation data when you move regions.

• Never: Does not move automation when you move regions.

• Always: Always moves automation when you move regions. The automation data
area encompassed by the region boundaries is moved.

• Ask: A dialog prompts you to move the automation data—or leave it where it
is—whenever you move a region.

• “Include trails, if possible” checkbox: Includes the automation trails of regions (automation
parameter movements in the empty space that follows a region) with all copy or move
actions that are performed via the Clipboard or graphical editing.

• Snap Offset field: This parameter allows a specific number of ticks to be added to, or
subtracted from, the current snapped position of all automation data (as set in the
Arrange window Snap menu).
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• Ramp Time field: Determines the time required by a parameter to return to its previously
recorded setting.

• ‘Write’ Mode Changes To pop-up menu: Determines the mode that faders automatically
switch to once track automation data recording has been completed.

• Write Automation For checkboxes: The checkboxes in this section determine the types
of track automation data that can be written in Touch, Latch, and Write modes.

• Automation Quick Access buttons: These parameters are discussed in detail in the
Automation Quick Access section. (See Using Automation Quick Access.)
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Control Surface Preferences in Logic Pro
Control Surfaces preferences consist of the following tabs:  General and Help Tags.
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To open Control Surfaces preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Control Surfaces (or use the Open Control Surfaces
Preferences key command).

µ Click the Preferences button in the Arrange toolbar, then choose Control Surfaces from
the pop-up menu.

These preferences are discussed in detail in the Logic Pro Control Surfaces Support manual.
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Sharing Preferences in Logic Pro
Sharing preferences consist of the following parameters:

To open Sharing preferences
Do one of the following:

µ Choose Logic Pro > Preferences > Sharing (or use the Open Sharing Preferences key
command).

µ Click the Preferences button in the Arrange toolbar, then choose Sharing from the pop-up
menu.

These preferences are discussed in detail in Setting Sharing Preferences.
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AAC Abbreviation for Advanced Audio Codec. A compression and decompression algorithm
and file format for audio data.

AAF Abbreviation for Advanced Authoring Format. A cross-platform project exchange file
format that you can use to import multiple audio tracks, inclusive of references to tracks,
time positions, and volume automation.

accelerando A gradual increase in tempo (see tempo).

AD converter or ADC Short for analog-to-digital converter; a device that converts an
analog signal to a digital signal.

ADAT Abbreviation for Alesis Digital Audio Tape. The ADAT is an eight track digital
multitrack cassette recorder that uses an S-VHS video tape to record audio at 16 or 20 bit
depth.

ADAT optical Optical interface for parallel transmission of eight audio channels via
fiber-optic cable. It is a well-established standard for digital multi-channel interfaces.

AES/EBU Short for Audio Engineering Society/European Broadcasting Union. This association
has a standard transmission format for professional stereo digital audio signals called
AES/EBU. The format is similar to S/P-DIF, but uses balanced line drivers at a higher voltage.
Depending on the type of devices involved, AES/EBU and S/P-DIF coaxial interfaces can
communicate directly.

aftertouch MIDI data-type generated by pressure on keys after they have been struck.
There are two types:  Channel aftertouch, the value of which is measured by a full length
keyboard sensor. It affects all played notes. Polyphonic aftertouch (rare) is individually
measured and transmitted for each key. Aftertouch is also known as key pressure or
pressure sensitivity.

AIFF Abbreviation for Audio Interchange File Format. A cross-platform file format supported
by a large number of digital audio and video editing applications. AIFF audio can use a
variety of bit depths, most commonly 16 and 24 bit.

AKAI Common sample data format that the EXS24 mkII is compatible with.
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ALAC Abbreviation for Apple Lossless Audio Codec, an encoding/decoding algorithm that
delivers lossless audio compression.

alias A pointer to a MIDI region in the Arrange area. An alias does not contain any data.
It simply points to the data of the original MIDI region. You can create an alias by
Shift-Option-dragging the original MIDI region to a new location. An alias cannot be
edited directly. Any change to the original region will be reflected in the alias.

aliasing A digital artifact that occurs when the sample material contains frequencies
higher than one-half of the sample rate.

allpass filter A filter that allows all frequencies to pass, providing only phase shift or
phase delay without appreciably changing the amplitude characteristic.

amplifier Device that increases the level of a signal.

amplitude This term is used to describe the amount of a signal. If you have an audio
signal, amplitude refers to the volume of the sound, measured in decibels (dB).

amplitude peak The loudest point of an audio signal.

analog signal A description of data that consists of an endlessly varying voltage level
that represents audio information. Analog signals must be digitized, or captured, for use
in Logic Pro. Compare with digital.

anchor point The start point of the audio file that an audio region is based on. Also see
Sample Editor.

Apple Loops An audio file format, commonly used for recurring rhythmic musical elements
or elements suitable for repetition. Apple Loops contain tags and transients that are used
by Logic Pro for time stretching and pitch shifting tasks. These tags also allow you to
quickly locate files by instrument, genre, or mood in the Loop Browser.

Apple Loops Utility The Apple Loops Utility allows you to create your own Apple Loops.
To use the Apple Loops Utility, select an audio region in the Arrange area and choose
Audio > Open in Apple Loops Utility.

Arrange area The primary working space of Logic Pro. It is used to record, edit, move,
and arrange the audio and MIDI regions of a project. Also used for automation recording
and playback.

Arrange window The primary working window of the application. It also shows the
Arrange area (see above), and can incorporate all other working areas and editors.
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ASCII Acronym for American Standard Code for Information Interchange. Standard computer
character set, allowing computers to deal with text characters. When you type ASCII
characters from the keyboard, the computer interprets them as binary so they can be
read, manipulated, stored, and retrieved. Also see scan code.

attack Start phase of a sonic event. Also part of an envelope. See envelope.

attenuate The act of lowering the level of an audio signal (see boosting and cutting).

Audio Bin Window (or tab in the Media area of the Arrange window) used for project
audio file and region management and conversion tasks. See Media area.

audio channel strip Channel strip in the Mixer, used as a target for audio tracks in the
Arrange area. All data on the audio track is automatically routed to the audio channel
strip that was assigned in the Arrange track list.

audio file Any digital recording of sound, stored on your hard disk. You can store audio
files in the AIFF, WAV, Sound Designer II (SDII), and CAF formats in Logic Pro. All recorded
and bounced WAV files are in Broadcast Wave format.

audio interface Device used to get sound into and out of your computer. An audio
interface converts digital audio data, sent from your computer, into analog signals that
speakers can broadcast. In the other direction, an audio interface converts analog signals
(such as a vocal performance) into digital audio data that can be understood by your
computer.

Audio MIDI Setup (AMS) The Audio MIDI Setup (AMS) utility is used to configure the
audio and MIDI input and output devices connected to your computer. Logic Pro uses
the settings defined in the Audio MIDI Setup utility, which can be found in the
Applications/Utilities folder.

audio region Chosen area of an audio file that can be placed on audio tracks in the
Arrange area, just like a MIDI region can be placed on MIDI tracks. Audio regions are
aliases (or pointers) to portions of audio files. They can be as short as a single sample, or
the full length of the underlying audio file. Logic Pro allows you to edit audio regions
without affecting the original audio file. Also see region and MIDI region.

audio track A track in the Arrange window that is used for playback, recording, and
editing of audio regions. It is routed to an audio channel in the Mixer.

Audio Units (AU) Audio Units is the standard Mac OS X format for real-time plug-ins. It
can be used for audio effects, software instruments, and Generators. The Audio Units
format is incorporated into the operating system, and installed Audio Units plug-ins can
be simultaneously accessed by all applicable programs. Logic Pro supports all Audio Units
format plug-ins.
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Auto Track Zoom Function in the View menu that automatically enlarges the currently
selected track.

automation Automation is the ability to record, edit, and play back the movements of
all knobs, controls, and buttons, including volume faders, pan, EQ, and aux send controls,
plus most effect and instrument plug-in parameters.

Autopunch button Button (with the up/down arrows) in the Transport bar, used to
activate the Autopunch function.

Autopunch function Autopunch refers to an automatic entry and exit of record mode
at predefined positions. Autopunch mode is most commonly used to re-record a badly
played section of an otherwise flawless recording. The advantage is that you can
concentrate on playing, not the mechanics of driving Logic Pro. Autopunch is activated
by clicking the Autopunch button in the Transport bar.

aux channel (strip) Aux channels are found in the Mixer (and to the left of the Arrange
window), and can be used as send/returns (buses) and sub-group controls.

Balance control Rotary knob directly above the Level fader of stereo channels. It controls
the relative level of the left and right signals at their outputs.

band rejection filter This filter cuts the frequency band centered around the cutoff
frequency, while allowing the frequencies that lie further away to pass. The mid-range
frequencies will become softer and the lows and highs remain unchanged.

bandpass filter This filter only allows the frequency band centered around the cutoff
frequency to pass, while frequencies that lie further away (the lows and highs) are filtered
out. A sound that contains a lot of mid-range frequencies is the result. Also see filter.

bar In musical notation, a bar is a measure that contains a specified number of beats,
and establishes the rhythmic structure of a musical piece.

Bar ruler Ruler found at the top of the Arrange window and the Piano Roll Editor, Hyper
Editor, and Score Editor. It displays musical time units, including bars, measures, beats,
and beat divisions. It is used to set and display the project position, the cycle and
autopunch locators. Also see playhead, Cycle function, and Autopunch function.

batch tagging The process of simultaneously tagging (marking) several audio files in the
Apple Loops Utility.

bass A musical instrument. The term also refers to low-frequency sounds or components
within a sound. See frequency.

beat A musical time interval. Usually a quarter note.
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Beat Mapping track Global track used to analyze audio or MIDI regions, and create tempo
events based on note or transient events in these regions. This allows you to more easily
synchronize existing free recordings (those made without a metronome click) in other
projects.

beats per minute See bpm.

Bezier curve A curve created from a line that contains two points. These points affect
the line, allowing it to be pulled into a curve. In a computer application, Bezier curves are
created by moving handles at these two points, thus adjusting the curve shape. Named
after Pierre Bezier, who discovered the mathematical formula for these curves. In Logic Pro,
Bezier curves are used to adjust automation curves, for example.

binaural hearing A description of the way human beings process audio positioning
information, allowing the direction of a signal source to be recognized (in front, behind,
above, below, and to the left or right of the listening position).

binaural panning A process that emulates binaural hearing.

bit depth The number of bits used by a digital recording or digital device. The number
of bits in each sample determines the (theoretical) maximum dynamic range of the audio
data, regardless of sample rate.

bit rate Bit rate, when talking about MP3 files, refers to the transfer bit rate at which the
files are encoded. Conversationally, the term is more often used to describe the relative
quality of the file, with lower bit rates resulting in less defined audio.

bit resolution Alternative term for bit depth. See bit depth and sample rate entries.

blue noise Highpass-filtered white noise, which sounds like tape hiss.

boosting The act of raising an audio level (see cutting).

bounce To process MIDI or audio regions with any applied effects, such as delay or
compression, and combining them into one audio file. In Logic Pro, you can choose
between real-time and offline bouncing. Offline bouncing is faster, but doesn’t allow you
to apply live automation or record real-time audio input. You may also bounce to several
files when performing a Surround bounce. See surround.

Bounce button You can bounce the output of any output channel to an audio file by
clicking the Bounce button. Also see bounce.

bpm Abbreviation for beats per minute, a measure of the tempo of musical piece. As an
example:  120 bpm means that in one minute, there will be 120 musical beats (quarter
notes).

Broadcast Wave See Wav, Wave.
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Browser A tab in the Media area of the Arrange window used to browse, select, and
manage all media types supported by Logic Pro. Also see Media area.

bus Busses are used to send audio to aux channel strips for processing or submixing
tasks.

bus channel strip The bus channel type is primarily included for backward compatibility
with older Logic Pro versions. The bus channel strip functions of earlier versions are
performed with aux channel strips in Logic Pro 8.

bypass To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In
Logic Pro you can bypass a plug-in by either clicking its Bypass button in the plug-in
window or by Option-clicking the appropriate plug-in slot of a channel strip.

cable In Logic Pro, the term is used to describe the virtual cables that represent a MIDI
connection between Environment objects.

CAF Abbreviation for Core Audio Format. This file format can be used as a container for
compressed or uncompressed audio files of (almost) any size, sample rate, or bit depth.
The CAF file format can handle audio recordings of around 3 hours in length (at a 44.1 kHz
sample rate—shorter at higher sample rates).

Camera tool The Camera tool is used to select, and export, sections of the Score Editor
display as PDF files.

Caps Lock Keyboard Logic Pro function that allows the use of the computer keyboard
as a real-time MIDI keyboard. It is primarily intended for use while travelling with a portable
Macintosh.

carrier In FM synthesis, the carrier is the equivalent of an analog synthesizer oscillator
that is producing a sine wave. The carrier frequency is modulated by the modulator.

Catch button The button at the top-left corner of most windows featuring the running
man icon. Activate this button to enable horizontal scrolling during playback. This ensures
that the area of the project that surrounds the current playhead position is always visible.

CD Audio Short for Compact Disc-Audio; a standard for stereo music CDs:  44.1 kHz
sampling rate and 16-bit depth.

cent A tuning division of a semitone. There are one hundred cents in a semitone. Many
of the Logic Pro software instruments contain a Fine parameter that allows sounds to be
tuned in cent steps.
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channel strip A channel strip is a virtual representation of a channel strip on a mixing
console. Each channel strip contains a number of similar controls, which can include some
or all of the following:  a Mute button, Level fader, Pan/Balance control, Input slot, Output
slot, Send slots, Insert slots, Format button. The channel strips shown to the left of the
Arrange window, and in the Mixer window, are used to process audio or MIDI information
that is routed from arrange tracks.

channel strip setting Logic Pro allows the routing of a channel strip, including all inserted
effects or instruments (plus their settings) to be saved and recalled. This simplifies the
task of re-creating complex serial effect routings between channels or projects.

checkbox A small box. You click a checkbox to select or deselect (or turn on/off ) an
option.

Chord track One of the global tracks. Contains chord symbols that can be derived from
MIDI regions or created with the mouse. These chord symbols may also be inserted into
the score. The root note of the chords determines the transposition (pitch shifting) of all
Apple Loops, and can also affect the playback of MIDI regions.

chorus effect Effect achieved by layering two identical sounds with a delay, and slightly
modulating the delay time of one, or both, of the sounds. This makes the audio signal
routed through the effect sound thicker and richer, giving the illusion of multiple voices.

click Metronome, or metronome sound.

Clipboard The Clipboard is an invisible area of memory, into which you cut or copy
selected data, using the Edit menu. Data stored in the Clipboard can be pasted to different
positions. In Logic Pro, the Clipboard can be used to exchange data within a single project
or between projects.

clipping (in digital recording) Feeding too much signal through a channel strip, thereby
exceeding the limit of what can be accurately reproduced, results in a distorted sound
known as clipping. Logic Pro audio channel strips feature a clip detector, which indicates
signal level peaks above 0 dB.

clock Electrical synchronization impulse, transmitted every 1/96 note. Was used in older
drum machines before the advent of MIDI. (MIDI Clock is a modern implementation of
simple clock signals. It runs at 24 ppqn—pulses per quarter note—or 96 pulses per note.)

cloned audio region A cloned audio region is a pointer to the original region. Whenever
you adjust the start or end points of any of these cloned regions, all other cloned regions
will also be adjusted in the same way.

comb filter effect A short delay of feedback that emphasizes specific harmonics in a
signal is generally termed a comb filter. The name is derived from the appearance of a
frequency spectrum graphic, which resembles the teeth of a comb.
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comping A process where multiple recording takes are combined into a single perfect
take. See takes.

compressor An effect that restricts the dynamic range of an audio signal (also see
expander).

Content Link mode The chain link button found at the top-left corner of most Logic Pro
windows features three modes. Content Link mode is useful for situations where multiple
MIDI regions are horizontally aligned along a single track, and you are viewing the MIDI
region contents in the Piano Roll Editor, for example. In this scenario, the Piano Roll Editor
will only show the contents of the selected MIDI region. Should you wish to view the
contents of each MIDI region (selected or not) in the Piano Roll Editor as the project plays,
you will need to activate Content Catch mode.

controller MIDI data type. As examples:  sliders, pedals, or standard parameters like
volume and panning. The type of command is encoded in the first data byte, the value
being sent or received is encoded in the second data byte.

control surface A hardware device that communicates with Logic Pro via MIDI (or USB,
FireWire, or via a networking connection). It can be used to write automation data and
control Logic Pro parameters, such as mixing levels and panning, effects and instruments,
plus transport and navigation functions, amongst others.

Controls view All Logic Pro plug-ins (and Audio Units) offer a non-graphical alternative
to the Editor views of effect and instrument parameters. The Controls view is accessed
via the Controls item in the plug-in header’s View menu at the top of each plug-in window.
This view is provided to allow access to additional parameters and to use less onscreen
space.

Core Audio Standardized audio driver system for all Macintosh computers running
Mac OS X version 10.2 or later. Core Audio is an integral part of Mac OS X, allowing access
to all audio interfaces that are Core Audio compatible. Logic Pro is compatible with any
audio hardware that offers Core Audio drivers/support.

Core MIDI Standardized MIDI driver system for all Macintosh computers running Mac OS X
version 10.2 or later. Core MIDI is an integral part of Mac OS X, allowing the connection
of all MIDI devices that are Core MIDI compatible. Logic Pro is compatible with any MIDI
hardware that offers Core Audio drivers/support.

count-in Beats heard prior to the start of a recording (or playback).

cueing Monitoring (hearing playback) while fast-forwarding or rewinding.

cutoff frequency Frequency at which the audio signal passing through a low or highpass
filter is attenuated by 3 dB.
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cutting The act of reducing a level, or frequency, when using EQ or other filters. Also
used to describe physically dividing and removing sections of files, regions, and so on
(see boosting and attenuate).

Cycle function A function in Logic Pro that constantly repeats the area between the
locator positions. To turn on Cycle mode, click the Cycle button in the Transport bar. The
Cycle function is useful for composing a part of a project or editing events, as examples.
The cycle area is shown as a green stripe in the top part of the Bar ruler.

DA converter or DAC Short for digital/analog converter; a device that changes an analog
signal into a digital signal.

data bytes These define the content of a MIDI message. The first data byte represents
the note, or controller number; and the second the velocity, or controller value.

DAW Acronym for Digital Audio Workstation. A computer used for recording, mixing, and
producing audio files.

dB Abbreviation for decibels, a unit of measurement that describes the relationships of
voltage levels, intensity, or power, particularly in audio systems.

DC offset An error that can result in direct current (DC) being layered over the audio
signal, resulting in a vertical shift in the waveform position shown in the Sample Editor.

decay An envelope parameter that determines the time it takes for a signal to fall from
the maximum attack level to the sustain level. See envelope.

deesser A signal processor that removes hissing or sibilance in audio signals.

default The preset parameter value.

delay In the Environment, an object that can create a series of repeats. In the Arrange
window, a region parameter that can delay or advance a selected region by a given
number of milliseconds. Delay is also an effect process that delays the incoming audio
signal, resulting in subtle chorusing effects through to endless repeats of the signal.

destructive Destructive audio processing means that the actual data of an audio file is
changed, as opposed to just editing peripheral or playback parameters.

Devices pane In Logic Pro, the Logic Pro > Preferences > Audio > Devices pane is used
to select and configure your audio hardware devices. In essence, you are altering the
driver configuration of your devices when using the Devices pane parameters. Also see
driver.
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DFS An abbreviation for Digital Full Scale. Sometimes expressed as 0 dB DFS. This (zero
dB—as shown on the Logic Pro channel strip level meters) is the maximum theoretical
level that a digital signal can reach before clipping and other types of distortion may be
introduced.

dialog A window containing a query or message. You must interact with it (by clicking
a button) before you can continue.

digital A description of data that is stored or transmitted as a sequence of ones and zeros.
Most commonly, refers to binary data represented by electronic or electromagnetic signals.
All files used in Logic Pro are digital. Also see analog for comparison.

Digital Full Scale See DFS.

disclosure triangle A small triangle you click to show or hide details in the user interface.

distortion The effect that occurs when the limit of what can be accurately reproduced
in a digital signal is surpassed, resulting in a sharp, crackling sound.

division value Adjustable value (shown in notes) for the grid used in displays and
operations. Third number displayed in the Transport bar’s Position display. The division
value is set in the Transport bar, below the time signature.

drag and drop Grabbing objects with the mouse, moving them, and releasing the mouse
button.

drag editing A Take Folder Editing mode where you use the mouse to cut, drag, and
move take folder and take region elements. See quick swipe comping.

Drag pop-up menu A pop-up menu found in the local menu of linear editing windows.
It determines the behavior of regions or events when dragged to an overlapping position.

driver Drivers are software programs that enable various pieces of hardware and software
to be recognized by computer applications. If the proper driver is not correctly installed
for your audio hardware, your computer may not recognize or work properly with it. See
Devices tab.

DSP (digital signal processing) In Logic Pro, the mathematical processing of digital
information to modify a signal. An example is the Insert slot of channel strips, which
assigns DSP effects such as dynamic compression and delay to a channel signal. Even
simple operations such as changing volume and pan are DSP calculations.

dynamic range The dynamic range is the difference in level between the highest signal
peak that can be reproduced by an audio system (or device in the system) and the
amplitude of the highest spectral component of the noise floor. Put another way, the
dynamic range is the difference between the loudest and softest signals that the system
can reproduce. It is measured in decibels (dB). See dB.
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dynamics Refers to changes in volume, or other aspects of a piece of music, over time.

editor Window for editing MIDI or audio data. Logic Pro offers the Hyper, Piano Roll,
Event List, and Score editors for MIDI event data, and the Sample Editor for audio data.
The Event List can also be used for region editing and positioning tasks.

Editor view Almost all Logic Pro plug-ins (and Audio Units) offer a graphical view of effect
and instrument parameters. The Editor view is the default, but can be accessed via the
Editor item in the View menu at the top of each plug-in window, should the Controls
view be visible.

effect A type of software algorithm that alters the sound of an audio signal in a variety
of ways. Logic Pro includes a set of EQ, dynamics, time-based, modulation, and distortion
effects in the Logic Pro native and Audio Units plug-in formats.

envelope The envelope graphically represents the variation that a sound exhibits over
time. An envelope, used as a controlling device, basically determines how a sound starts,
continues, and ends. Synthesizer envelopes usually consist of attack, decay, sustain, and
release phases.

Environment The Logic Pro Environment graphically reflects the relationships between
hardware devices outside your computer and virtual devices within your computer.
Beyond basic input and output handling, the Environment can be used to process MIDI
data in real time, and can even be used to create processing machines, such as virtual
rhythm generators and step sequencers or complex synthesizer editors.

Environment layer A page in the Environment, used to organize objects. Objects of the
same type (MIDI objects, for example) are generally placed on the same layer, making
usage easier.

Environment Mixer See Mixer layer.

EQ Shortened form of equalizer. Equalizers are used to boost or cut frequencies in an
audio signal. There are several types of EQ available in Logic Pro.

equalization See EQ.

Eraser A tool used for deleting items. Click a selected item to delete it. All other currently
selected items are also deleted.

event Individual MIDI command, such as a note on command. Continuous controller
movements (modulation wheel, for example) produce a quick succession of individual
events—each with an absolute value.

event definition Parameters used to define the event type displayed in the lanes of the
Hyper Editor (also see hyper set).
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Event List A list that shows all events or regions in a project. It allows you to directly
manipulate events and regions in a precise, numerical way. It also allows you to add
different types of events.

expander An effect process that increases the dynamic range of an audio signal. It is the
antithesis of the compression effect (see compressor).

export To create a version of a file, such as a Logic Pro project, in a different format that
can be distributed and used by other applications.

Fade tool Tool in the Arrange area, used to create a cross-fade.

Filter button Buttons in the Event List and Mixer that allow you to hide or show specific
event types or channel strip types.

filter effect Filters are effects designed to reduce the energy of a specific frequency within
a signal. The names of the individual filters illustrate their function. As an example:  A
lowpass filter allows frequencies that are lower than the cutoff frequency to pass (see
cutoff frequency).

filter slope The filter slope is the steepness, or severity, of filter attenuation (level
reduction). As examples, a filter slope of 6 dB per octave would sound much softer than
a filter slope of 12 dB per octave.

Finger tool Tool (as used in the Piano Roll Editor, for example) that looks like a hand with
an extended index finger. This tool allows you to manipulate the length of events or
perform other operations in other areas of the program.

FireWire Apple trademarked name for the IEEE 1394 standard. A fast and versatile serial
interface, often used to connect audio interfaces, and audio processing units to computers.
FireWire is well suited to applications that move large amounts of data, and can be used
to connect hard disks, scanners, and other kinds of computer peripherals. There are two
versions of FireWire:  FireWire 400 and FireWire 800. The latter is a faster variant, which
uses a different connector type. Use of FireWire 400 devices on a FireWire 800 port is
possible with suitable cabling, but it effectively halves the bandwidth to all devices on
the port (also see M-LAN).

flanger The flanger effect is similar to the chorus effect, where a slightly delayed signal
(which is shorter than that of the chorus) is fed back into the delay line input. Flanging
makes a sound thicker, and slightly out of phase.

flex marker A marker that you drag in order to alter the timing of audio material.

flex mode A track-based setting that determines how the timing of your audio will be
altered.
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flex time editing A process that allows you to edit the timing of single or multiple audio
regions.

Flex tool A tool that allows you quick access to the basic flex time editing functionality,
without having to turn on Flex view in the Arrange area. See Flex view.

Flex view An Arrange area view that allows you to edit the timing of audio material.

float window See window type.

folder A folder is a container for regions in the Arrange area. It can contain other folders
or regions, much like a folder in the Finder can contain other folders or files. You can
imagine a folder as a project within a project. The inside of a folder looks just like the
Arrange area and track list in a project.

Format button Button on audio channel strips (below the level meter), used to indicate
the input format of the channel strip. Click-hold this button to access the format menu.

frame Unit of time. A second in the SMPTE standard is divided into frames that correspond
to a single still image in a video file or on video tape.

Freeze function The Freeze function performs individual offline bounce processes for
each frozen track, saving almost 100% of the processing power used for software
instruments and effect plug-ins. All plug-ins of a track (including software instrument
plug-ins, if applicable, along with all related automation data) are rendered into a freeze
file.

frequency The number of times a sound signal vibrates each second, measured in cycles
per second, or Hertz (Hz).

global tracks Global tracks are available at the top of all linear editing windows. They
allow you to view, create, and edit markers, tempo events, and key changes, plus beat
mapping and other operations.

Glue tool This tool can be used to merge regions or events by simply clicking on two (or
more) of them.

GM Abbreviation for General MIDI. A standard for MIDI sound modules that specifies a
uniform set of instrument sounds on the 128 program numbers, a standardized key
assignment for drum and percussion sounds on MIDI channel 10, 16-part multi-timbral
performance and at least 24 voice polyphony. The GM specification is designed to ensure
compatibility between MIDI devices. A musical sequence generated by a GM instrument
should play correctly on any other GM synthesizer or sound module.

grab (an object) Positioning the mouse cursor over an object, then pressing and holding
the mouse button down.
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grid The Logic Pro grid is represented by vertical lines that are used to indicate the
positions of measures, beats, and sub-beats in various editors.

GS Extended GM standard developed by Roland Inc.

Hand tool A tool used to move regions in the Arrange area or events in editors, or plug-ins
between Insert slots in the Mixer. It automatically appears when the mouse cursor is
placed over a region or event while the Pointer tool is selected.

headroom A specified range (safety margin, measured in decibels) between the actual
audio level and the maximum permitted level (0dBfs) that allows for unexpected signal
peaks.

help tag A small text window that appears when the mouse cursor is placed over an
interface element. It indicates the name or value of the element. When editing operations
such as moving or cutting a region are performed, a larger help tag will display the current
(and starting) position of the region or function—in real time.

hierarchical menu Structured menus that open cascading submenus when an individual
entry is chosen at a higher level.

Hierarchy button In the top-left corner of many Logic Pro windows, you will find a button
featuring an upward pointing, right-angled arrow. Clicking this Hierarchy button takes
you to the next, higher display level (one level up, in other words). As an example, if you
are looking at the events of a MIDI region inside a folder, clicking the Hierarchy button
will switch the display to a view of the MIDI region in the parent folder. A further click
will take you up to display the folder itself.

high cut filter A high cut filter is essentially a lowpass filter that offers no slope or
resonance controls. As the name suggests, it attenuates frequencies above the cutoff.

highpass filter A highpass filter allows frequencies above the cutoff frequency to pass.
A highpass filter that offers no slope or resonance controls is generally known as a low
cut filter.

Hyper Draw function This function allows you to record, manually create, and edit
controller data graphically. Hyper Draw data appears as a set of points (or nodes), which
are connected by lines. Hyper Draw can be used in the Arrange area and MIDI editors.

Hyper Editor Graphical editor that can be used to create or edit MIDI note and controller
data. The Hyper Editor is ideal for drawing drum parts and creating crescendi, amongst
other tasks. See entry below and also see event definition.

hyper set All simultaneously displayed event definitions in the Hyper Editor are collectively
referred to as a hyper set. Also see event definition.

icon Small graphic symbol. In Logic Pro, an icon may be assigned to each track.
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importing The process of bringing files of various types into a Logic Pro project. Imported
files can be created in another application, captured from another device, or taken from
another Logic Pro project.

In button Button used to activate Step Input mode in the editors. Also see Step Input
function.

input channel strip Channel strip type in the Environment Mixer layer that is included
for backward compatibility with projects created in older Logic Pro versions. An input
channel strip represents the physical inputs of your audio interface and directs input from
your audio interface into Logic Pro. In general, you will not need to access this channel
strip type in Logic Pro.

input monitoring This function allows you to hear incoming audio, when audio tracks
are playing, record-enabled, or recording. Simply click the Input Monitoring button on
Arrange audio tracks to enable or disable input monitoring.

Insert slot A panel on Logic Pro channel strips where you can patch in (insert) an effect
plug-in.

Inspector Area at the left edge of the Arrange window and editors, containing the
Parameter boxes and channel strips (Arrange) of the selected track. The Inspector area
updates to reflect the parameters relevant to the window with key focus. Also see
Parameter box.

instrument channel strip Logic Pro supports the use of software-based instruments.
Software instrument plug-ins are inserted into the Instrument slot of instrument channel
strips. Software instrument recording takes place on instrument tracks in the Arrange
area. Playback of these tracks is routed via the instrument channel strip shown in the
Mixer (or to the left of the Arrange window).

instrument object An object in the Logic Pro Environment designed to communicate
with a single-channel MIDI device. An instrument object represents a physical or virtual
device that handles MIDI information. Also see multi-instrument object.

interface 1) A hardware component such as a MIDI or audio device that allows Logic Pro
to interface (connect) with the outside world. You need an audio or MIDI interface to get
sound or MIDI into and out of your computer. Also see audio interface. 2) A term that is
used to describe graphical elements within Logic Pro that you can interact with. An
example would be the Arrange area, where graphical interface elements such as regions
are interacted with to create a project, within the overall Logic Pro interface.

interleaved audio file Logic Pro typically handles multi-channel (stereo or surround)
audio files as interleaved (unless using DAE hardware). Edits to interleaved files affect
both (or all, if surround) channels equally. Also see split channel audio files.
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key The scale used in a piece of music, centered around a specific pitch. The specified
pitch is called the root of the key. Can also refer to a black or white key on a musical (MIDI)
keyboard.

key command Function that can be executed by pressing a specific key (or key
combination) on your computer keyboard or MIDI controller.

Key Commands window The Key Commands window is used for the assignment of key
commands to computer keys or to MIDI messages.

key focus The selected, active window, is said to have key focus in Logic Pro. Many key
commands will only function when a window has key focus. The Inspector also updates
to reflect the parameters of a window with key focus.

latency You may notice a delay between playing your keyboard and hearing the sound.
This is a form of latency. A variety of factors contribute to latency, including the audio
interface in use, audio and MIDI drivers. One factor under your control, however, is the
I/O buffer size, which is set in the Devices preferences.

legato Method of musical performance that smoothly connects one note to the next.

level meter A meter that monitors audio input or output levels to or from your computer.
You use the level meters in Logic Pro when recording, arranging, and editing audio files,
and when creating a mix.

LFO Abbreviation for Low Frequency Oscillator. An oscillator that delivers modulation
signals below the audio frequency range—in the bandwidth that falls between 0.1 and
20 Hz, and sometimes as high as 50 Hz or 400 Hz.

Library Window (or tab in the Media area of the Arrange window) used to handle all
settings files for channel strips, effects, and instruments.

Link button Button in the top-left corner of most Logic Pro windows that features the
chain link icon. It controls the linking between different windows.

Lists area Area in the Arrange window, providing four independent tabs that show a
listing of the following types of data:  events, regions, markers, tempo changes, and
time/key signatures.

local menu bar Menu in a window that only contains functions that are relevant to that
particular window.

Local Off mode Operating mode on a MIDI keyboard where the keyboard does not
directly play its own integrated sound generator. This is useful when using it as a master
keyboard for Logic Pro.
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locators Lower two sets of numbers, displayed to the right of the position indicators in
the Transport bar. The number on top is the left locator; the number below is the right
locator. The left and right locators define the cycle time-range, useful for cycle or skip
playback operations and cycle recording. The locators are also used to define the editing
area for certain functions.

loop An audio file that contains recurring rhythmic musical elements, or elements suitable
for repetition. Logic Pro supports Apple Loops, amongst other file formats.

Loop Browser A tab in the Media area of the Arrange window used to access and manage
Apple Loops and ReCycle files.

Loop function The Loop region parameter in Logic Pro that creates loop repeats for an
audio or MIDI region. These repetitions will continue until the project end point is reached,
or another region or folder (whichever comes first) is encountered on the same track in
the Arrange area.

low cut filter A low cut filter is essentially a highpass filter that offers no slope or resonance
controls. It attenuates all frequencies below the defined cutoff.

lowpass filter The lowpass filter defines the maximum frequency that can pass through
without being affected, thus controlling the brightness of the sound. Every signal above
this frequency will be cut. The higher the cutoff frequency, the higher the frequencies
that can pass through. A lowpass filter that offers no slope or resonance controls is a high
cut filter.

main menu bar The bar at the top of the screen, offering global functions such as opening,
saving, exporting, or importing projects. It does not offer access to local window functions.
It does, however, contain an Edit menu—with commands that apply to the window with
key focus.

marker A marker is an indicator, or bookmark, that is tied to a specific time position in a
project. It can contain text that act as notes for different versions of a project, for example.
Markers can also be used for a number of selection and navigation tasks.

Marker List Window (or tab in the Lists area of the Arrange window) that shows an
alphanumeric listing of all marker events. It also includes a Marker Text area that allows
you to add text information (notes) to particular marker events.

marker text Text information (notes) attached to particular marker events. Added in the
Marker Text window or Marker Text area of the Marker List.

Marker track One of the global tracks, used for the creation, editing, and display of marker
events.

Marquee tool Crosshair-shaped tool in the Arrange Tool menu, used to select and edit
parts of audio and MIDI regions.
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master channel strip Channel strip in the Mixer that acts as a separate attenuator stage,
changing the gain of all output channel strips without affecting the level relationships
between them.

Media area Area shown at the right-hand side of the Arrange window when the Media
button is clicked in the Arrange toolbar. Contains the Bin, Loops, Library, and Browser
tabs, providing access to all media types supported by Logic Pro.

merge Mix, or combine, two or more MIDI events or regions into a single event or region.

metadata Metadata is additional descriptive information that is stored in the file header
of a number of file types (AAF, for example). It is used to reference external media, to
simplify searches, and more.

metronome A device that produces a sound that taps out the beat. In Logic Pro, it can
be configured in the Metronome project settings.

MIDI Abbreviation for Musical Instrument Digital Interface. Standardized, asynchronous,
serial, event-oriented hardware and software interface for electronic musical instruments.
MIDI is an industry standard that allows devices such as synthesizers and computers to
communicate with each other. It controls the pitch, length, and volume of a musical note
event, among other characteristics.

MIDI channel A MIDI channel is a “tube” for MIDI data, which flows through MIDI ports.
Up to 16 separate MIDI channels can pass through a port simultaneously. Tracks recorded
in Logic Pro can be directed to different tubes (channels), which can contain different
information, and play back through different sounds, assigned to each channel. As
examples, channel 1:  piano, channel 2:  bass, channel 3:  strings, and so on. This assumes
that the receiving devices are capable of receiving data on more than one channel, and
that they are capable of playing back different sounds simultaneously (see multi-timbral).

MIDI Clock Short MIDI message for clock signals. It is used to provide a timing pulse
between MIDI devices. It is accurate to 24 ppqn (pulses per quarter note), although some
devices interpolate these pulse values, resulting in a more precise clock signal if each
device is capable of interpreting this additional information correctly. Also see SPP.

MIDI message A message transmitted via MIDI that consists of one status byte and none,
one, two, or many data bytes (with system exclusive commands). See event.

MIDI Multi mode Multi-timbral operating mode on a MIDI sound module where different
sounds can be controlled (polyphonically) on different MIDI channels. A multi mode sound
module behaves like several polyphonic sound modules. General MIDI describes a 16-part
multi mode (the ability to control 16 different parts individually). Most modern sound
generators support multi mode. In Logic Pro, multi mode sound modules are addressed
via multi-instrument objects. This MIDI mode and multi mode sound modules are generally
referred to as multi-timbral (see multi-timbral).
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MIDI region Data container for MIDI events, shown in the Arrange area as a named
horizontal beam.

MIDI Time Code (MTC) Translation of a SMPTE time code signal into a MIDI standard
time code signal. MTC is used to synchronize Logic Pro with MIDI devices, other sequencers,
video and audio tape or hard disk machines that support MIDI Time Code. MTC determines
absolute time positions and supports start, stop, and continue messages.

mixdown A term commonly used to describe either bouncing (see bounce) or merging
of tracks (see merge).

Mixer The Mixer window displays all (or the desired) track, instrument, and MIDI channel
strips. These channels allow you to control all aspects of track output and processing,
including level, panning, effect and instrument processing, routing, and more.

Mixer layer An Environment layer that shows all channel strips in a project (except MIDI
channel strips). In general, you will not need to access this Environment layer as all mixing
duties can be performed in the Mixer window.

mixing The process of shaping the overall sound of a project by adjusting the volume
levels, pan positions, adding EQ and other effects, and using automation to dynamically
alter these and other aspects.

M-LAN A Yamaha-designed variant of the FireWire interface. It enables Yamaha digital
mixers and other devices to be directly connected to a Macintosh FireWire port (see
FireWire).

modifier key Computer keyboard keys used in conjunction with alphabetical keys to
change functionality. Modifier keys include Control, Shift, Option, and Command.

modulation Generally, a slight, continuously varying change. Many Logic Pro effects and
synthesizers contain modulators.

modulation amount The strength, or intensity, of modulation.

modulation matrix The EXS24 mkII (and some other Logic Pro instruments) contains a
grid that allows you to vary a number of target parameters, such as pitch, with a number
of modulators (modulation sources). This grid is referred to as the modulation matrix in
the EXS24 mkII.

modulation path A modulation path determines which target parameter will be affected
by a specific modulator (modulation source).

modulation wheel A MIDI controller found on most MIDI keyboards.
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mono Short for monophonic sound reproduction. The process of mixing audio channels
into a single track, using equal amounts of the left and right audio channel signals.
Compare with stereo.

movie See video.

MP3 Abbreviation for MPEG-2 Audio Layer 3. A compressed audio file format, frequently
used to distribute audio files over the Internet.

MTC See MIDI Time Code.

multi-instrument object An object in the Logic Pro Environment that represents a
multi-timbral hardware or software device that reacts to MIDI. The multi-instrument object
is essentially 16 instrument objects rolled into a single package. Each of these, called
sub-channels, has a fixed MIDI channel. All sub-channels share the same MIDI port. All
other parameters can be set individually. The purpose of the multi-instrument object is
to address multi-channel MIDI devices, which can receive MIDI data (and play different
sounds) on separate MIDI channels.

multi-timbral This term describes an instrument or other device that can play several
different sounds at the same time, using multiple MIDI channels. See MIDI Multi mode.

Multi Trigger mode This term is associated with synthesizers such as the ES1. In this
mode, a synthesizer envelope is usually retriggered by each incoming note event.

mute Turn off the audio output of a channel or track. You can mute a track or channel
by clicking the Mute button in the track list or at the bottom of the channel strip.

Mute tool This tool allows you to stop a region or events from playing, by clicking it or
them.

native Native refers to host-based processing of effects and software instruments in
Logic Pro. The computer processor natively calculates the effects and instruments. Native
also refers to the internal Logic Pro plug-in format, which differs from the Audio Units
format. Logic Pro native plug-ins only work in Logic Pro.

nodes Positions in Hyper Draw and automation tracks that mark the beginning or end
of data manipulation. Occasionally referred to as (automation) points.

Nodes Refers to additional Macintosh computers that are used as external processing
nodes, effectively increasing the processing resources of your main Logic Pro computer.

normalize This function applies the current Parameter box settings to the selected MIDI
events (by altering the actual events themselves), and clears existing parameter settings.
When it comes to audio, a different Normalize function raises the volume of a recorded
audio file to the maximum digital level, without altering the dynamic content.
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notch filter This filter type cuts the frequency band directly surrounding the cutoff
frequency, allowing all other frequencies to pass.

note attributes Describes functions found in the Attributes menu of the Score Editor.
These determine aspects such as the stem direction, color, enharmonic position, and
further options for the display (and printing) of note events.

note number Pitch of a MIDI note, controlled by the first data byte of a MIDI note event.

object The term is used to refer to the graphical representation of elements in the
Logic Pro Environment. These elements can be used to create and process MIDI data in
real time, and can even be used to create processing machines, such as virtual rhythm
generators or step sequencers. Examples of Environment objects include instruments,
multi-instruments, faders and arpeggiators, amongst others. The Environment Mixer layer
contains objects that process audio data.

Object Parameter box The Object Parameter box displays the properties of any selected
Environment object.

offset The playback point in a source audio file can differ from the start point (anchor)
of the file. This is known as an offset or start point offset. Offset is also used in conjunction
with video time code, where the start time of the Logic Pro project and QuickTime movie
file can be offset (different) from each other. A further use of the term is when the
amplitude of a waveform is off-axis from the center line (due to a recording error caused
by hardware). This can be rectified with the DC Offset function in the Sample Editor. See
DC Offset.

OpenTL Abbreviation for Open Track List. This file format, typically used for data exchange
with Tascam hard disk recorders, such as the MX 2424, can be imported and exported by
Logic Pro. The OpenTL file format only supports the exchange of audio data (audio regions,
inclusive of track position information). MIDI and automation data are ignored when
using the Logic Pro OpenTL export function.

option Alternative function, often in the form of a checkbox, sometimes also available
as a menu entry.

Option Modifier key, also known as the Alt key in MS Windows.

oscillator A synthesizer oscillator generates an alternating current, using a selection of
waveforms that contain different amounts of harmonics.

output channel strip Channel strip type in the Mixer that controls the output level and
pan/balance for each physical output of your audio interface.

Page view Score Editor view displaying notation as it will appear on the printed page.
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pan, pan position The placement of mono audio signals in the stereo field, by setting
different levels on both sides (see Balance).

Pan control Rotary knob (directly above the Level fader) on mono channel strips, that
determines the position of the signal in the stereo image.

Parameter box Field on the left side of Logic Pro windows (or in the Inspector). It is used
to adjust the parameters of the selected track, regions, events, or objects. Also see
Inspector.

peak 1) The highest level in an audio signal. 2) Portions of a digital audio signal that
exceed 0 dB, resulting in clipping. You can use the Logic Pro level meter facilities to locate
peaks and remove or avoid clipping. The Search Peak command in the Sample Editor
Functions menu searches for the sample bit with the greatest amplitude value.

peak level display A digital audio meter that displays the absolute volume of an audio
signal as it plays. So named because every peak in the signal can be accurately seen.

Pencil tool Tool used to create empty MIDI regions in the Arrange area. It can also be
used to add audio regions to the Arrange area, when used in conjunction with the Shift
key. In the Sample Editor, the Pencil can be used to draw out transient signal spikes (pops
and clicks) in signals.

Piano Roll Editor A MIDI event editor that displays note events as horizontal beams.
Events can be cut, copied, moved, and resized in a similar fashion to regions in the Arrange
area.

pink noise A harmonic noise type that contains more energy in the lower-frequency
range.

pitch The perceived highness (treble) or lowness (bass) of a musical sound. Corresponds
to the frequency of the sound wave.

pitch bend message MIDI message transmitted by the pitch bend wheel of a MIDI
keyboard.

playback Playing an audio or MIDI region, an audio file, or an entire arrangement, allowing
you to hear it.

playhead The playhead is a vertical white line that indicates the current playback position
in all horizontal, time-based Logic Pro windows (the Arrange area, for example). The
playhead can be directly grabbed and moved with the mouse (see scrubbing).

plug-in Software application that enhances the functionality of the main program (in
this case, Logic Pro). Logic Pro plug-ins are typically software instruments or effects.
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plug-in window A window that opens when a plug-in is inserted, or the Insert/Instrument
slot is double-clicked. Allows you to interact with the plug-in parameters.

Pointer tool Tool used to select or edit regions, events, menu or interface items, and
more in Logic Pro.

post fader Sends in analog mixers are positioned either before (pre) or after (post) the
fader. Post fader means positioned after the Volume fader in the signal flow, with the
level of a signal going to the send changing along with the fader movements.

pre fader Sends in analog mixers are positioned either before (pre) or after (post) the
fader. Pre fader means positioned before the Volume fader in the signal flow, so the level
of a signal routed pre-fader to a send remains constant, regardless of any fader movements.

Preferences window A window that is accessed via the Logic Pro > Preferences menu.
All Logic Pro preferences can be set in this window.

preset Set of plug-in parameter values that can be loaded, saved, copied, or pasted via
the Settings menu in the plug-in window header. See setting and Settings menu.

pressure See aftertouch.

project A Logic document. It contains all MIDI regions and references to the audio files
to be played back. A project file is saved within a project folder—which can contain the
project’s audio files and other assets (such as video, sample files, and so on). Saving a
project with assets simplifies archiving and exchanging projects, but increases the project
folder’s size.

project folder In Logic Pro, the top-level folder that can contain all media associated
with a project, including audio files, sampler instruments and samples, video, and other
data.

project settings The project settings are a collection of program settings that are specific
to the current project. These are different from the global preferences that affect all
Logic Pro projects (see Preferences window).

protected track A protected track cannot have its contents moved or changed.

punch in, punch out Going into and out of record to replace a section of an existing
recording. This process can be automated in Logic Pro. Also see Autopunch function.

PWM Pulse Width Modulation. Synthesizers often feature this facility, where a square
waveform is deformed by adjusting its pulse width. A square waveform usually sounds
hollow, and woody, whereas a pulse width modulated square wave sounds more reedy
and nasal.
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Q factor A term generally associated with equalizers. The Q factor is the quality factor of
the equalization, and is used to select a narrower or broader frequency range within the
overall sonic spectrum of the incoming signal.

quantization Time-correction of note positions by moving them to the nearest point on
a selectable grid (this is chosen in the Quantization menu). When quantization is applied
to any selected event or region, Logic Pro will move all note events to align perfectly with
the nearest grid position. Logic Pro quantization is a non-destructive playback operation,
allowing different quantize values to be auditioned while listening to your music.

Quantization menu Menu found throughout Logic Pro that determines the current
quantization grid. See entries below.

Quantize button Button labeled with a Q. Performs the quantize operation (chosen in
the Quantization menu) on selected events. Also see Quantize tool and quantization.

Quantize tool Tool labeled with a Q. It is used to apply quantization to specific (selected)
events, using the quantize value specified in the Quantization menu of the Piano Roll
Editor or Event List.

quick swipe comping A Take Folder Editing mode where you swipe across take sections
with the mouse to create and edit comps. See drag editing.

QuickTime QuickTime is an Apple cross-platform standard for digitized, data-compressed
video playback and encoding. QuickTime movies can be run in a Logic Pro window or
on a global Video track, in sync with the project. Whenever you move the playhead, the
film follows and vice versa.

RAM Abbreviation for random-access memory. Computer memory capacity, measured in
megabytes (MB), determines the amount of data the computer can process and temporarily
store at any given moment.

real-time effects Effects that can be applied to regions in real time, during playback.
Real-time effects can be used on any Macintosh computer qualified to run Logic Pro.

record-enable Audio tracks must be manually armed (record-enabled) before you can
record on them. MIDI and software instrument tracks are automatically record-enabled
when selected.

recording The act of capturing a performance as audio or MIDI data into Logic Pro. The
term is also commonly used when referring to the actual data (in Logic Pro, this is
delineated by the use of the words region or file to make things clearer when discussing
recordings).

ReCycle ReCycle is the name of an application from software manufacturer Propellerhead,
which mainly serves as an editing and production tool for loops (repeated audio samples).
ReCycle uses specific file formats (.rex) which can be imported by Logic Pro.
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region Regions can be found on arrange tracks:  They are rectangular beams that act as
containers for audio or MIDI data. There are three different types of regions:  audio regions,
MIDI regions, and folder regions (usually referred to as folders). Also see audio region,
MIDI region, and folder.

Region Parameter box Box in the upper-left corner of the Arrange window, used to
non-destructively set the playback parameters for individual regions, including
quantization, transposition, velocity, compression, and delay. These parameters do not
alter the stored data. Rather, they affect how the events are played back.

release An envelope parameter that determines the time it takes for a signal to fall from
the sustain level to an amplitude of zero when the key is released. See envelope.

Replace mode A type of overwrite recording mode where the currently specified audio
region in the Arrange area is replaced with the incoming signal. To activate Replace mode,
click the Replace button in the Transport bar.

resonance A term generally associated with filters, particularly those of synthesizers.
Resonance emphasizes the frequency range surrounding the cutoff frequency. See cutoff
frequency.

reverb Reverb(eration) is the sound of a physical space. More specifically, the reflections
of sound waves within a space. As an example, a handclap in a cathedral will reverberate
for a long time as sound waves bounce off the stone surfaces within a very large space.
A handclap in a broom closet will hardly reverberate at all. This is because the time it
takes for the sound waves to reach the walls and bounce back to your ears is very short,
so the reverb effect will probably not even be heard.

ReWire An audio streaming and synchronization technology from Propellerhead software.
The output of ReWire applications can be routed into (and processed with) the Logic Pro
Mixer. Logic Pro can also control the transport operations of ReWire programs. Further
to these functions, Logic Pro instrument tracks can drive the software instruments of
ReWire applications.

ritardando A gradual slowdown of tempo (see tempo).

routing Generally refers to the way audio is sent through processing units. Also often
used to describe specific input and output assignments.

sample A digital recording of a sound at a particular instant in time.

Sample Editor The Logic Pro Sample Editor allows audio files to be destructively cut,
reversed, shortened, changed in gain, and processed in a number of other ways. It allows
editing of individual samples within an audio file consisting of thousands, or millions, of
samples. The Sample Editor also provides access to a number of special sample processing
tools, collectively known as the Digital Factory.
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sample rate When an analog audio signal is converted to a digital signal, this term refers
to the number of times per second the audio file is sampled. Logic Pro can record and
edit audio at sample rates ranging from 44.1 kHz (44,100 times per second) up to 192 kHz
(192,000 times per second).

sample rate converter Device or algorithm that translates one sample rate to another.

sampler Device used for sampling. In Logic Pro, this generally refers to the EXS24 mkII
software-based sampler.

sampling The process of converting analog audio into digital information. The sample
rate of an audio stream specifies the number of samples that are captured per second
(see sample rate). Higher sample rates yield higher-quality audio.

saturation A term most commonly associated with a slight tape distortion or the
characteristics of tube amplifiers. It basically describes a very high gain level that causes
a slight distortion of the incoming signal, resulting in a warm, rounded sound.

scale A group of related musical notes (or pitches) that forms the basis of the melody
and harmony in a piece of music. The most common scales are the major scale and minor
scale.

scan code Each key on a computer keyboard has a scan code rather than an ASCII symbol
associated with it. As an example:  The Plus and Minus keys on the numeric keypad and
the corresponding keys above the keyboard have a different scan code, but use the same
ASCII symbol.

scene marker Logic Pro can automatically extract information from (abrupt) transitions
in QuickTime movie files, and create a marker, making the process of scoring to film much
faster and easier. Such transitions in video generally indicate a scene change.

Score Editor Logic Pro editor that deals with standard musical notation. MIDI note events
are represented as quavers, crotchets, minims, and so on. The Score Editor allows you to
adjust and edit the layout of the score, and print it.

score set A collection of various staff styles, staffs, and other elements shown in the Score
Editor can be saved as a score set. This facility allows you to quickly switch between (and
edit and print) different portions of the score, such as a brass section, in isolation to the
entire score. It also simplifies experimentation with different layouts.

screenset A layout of various windows, inclusive of all display parameters (zoom, position,
size of each window, and so on) is called a screenset. You can swap between different
screensets, much as you might swap between different computer monitors.

scroll bar and scroller Gray beam at the edge of a window. A movable box inside the
beam is used to select the displayed project section in the window.
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SDII Sound Designer II audio file format. Very similar in structure to the AIFF file format.

search field In many Logic Pro windows you find a field with rounded corners and a
magnifying glass to the left. This field allows you to perform text searches. As examples,
the search fields in the Key Commands window or Loop Browser.

self-oscillation Self-oscillation is a typical characteristic of analog filter circuits. It occurs
when the filter, at high-resonance values, feeds back into itself and begins to oscillate at
its natural frequency.

semitone Smallest interval between two pitches in the standard diatonic scale, equal to
a half tone. A semitone is also called a half step or half tone.

send Abbreviation for auxiliary sends. An output on an audio device used for routing a
controlled amount of the signal to another device. Sends are often used to send several
signals to the same effect, which is useful for computationally intensive effects such as
reverb.

Send slot A panel shown on mixer channel strips that enables you to send (via a bus) a
portion (or all) of the audio signal to an auxiliary channel strip. You may use multiple
sends on channels.

sequencer A sequencer is these days considered to be a computer application that allows
you to record both digital audio and MIDI data and blend the sounds together in a
software mixing console. In earlier times, a sequencer controlled synthesizers via a series
of control voltages and gates, or via MIDI only. No audio recording or control was available.

setting 1) A parameter value. 2) A set of plug-in parameter values that can be loaded,
saved, copied, or pasted via the Settings menu. A plug-in setting is also known as preset.
Also see preset and Settings menu.

Settings menu Found in the gray header at the top of all plug-in windows. Allows you
to save, load, copy, and paste settings:  the parameter values of effects and software
instruments.

sharing Channel strip settings, plug-in settings, and key commands can be stored and
accessed (shared) on a local network or MobileMe account.

shelving EQ EQ type that allows the frequency range above or below the specified
frequency to be increased or decreased.

side chain A side chain is effectively an alternate input signal—usually routed into an
effect—that is used to control an effect parameter. As an example, you could use a
side-chained track containing a drum loop to act as the control signal for a gate inserted
on a sustained pad track, creating a rhythmic gating effect of the pad sound.

Signature List A Logic Pro window that lists all time and key signatures of a project.
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Signature track Global track that shows all time and key signatures of a project.

Single Trigger mode This term is associated with synthesizers such as the ES1. In this
mode, envelopes are not retriggered when tied (legato) notes are played.

SMF See Standard MIDI File.

SMPTE Abbreviation for Society of Motion Picture and Television Engineers. The organization
responsible for establishing a synchronization system that divides time into hours, minutes,
seconds, frames, and subframes (SMPTE time code). SMPTE time code is also used for
synchronizing different devices. The MIDI equivalent of SMPTE time code is MIDI Time
Code (MTC). See MTC.

SMPTE ruler In addition to the standard bar/beat display, the Logic Pro Bar ruler can
display time units in SMPTE format:  hours, minutes, seconds, and frames, and can display
time code if a video is imported into the project.

Snap pop-up menu A pop-up menu found in the local menu of linear editing windows.
It determines the behavior of regions or events when edited; lengths and cuts will snap
to the nearest possible position (as determined by the chosen Snap menu value), for
example.

software instrument Software counterpart to hardware samplers or synthesizer modules,
or acoustic sound sources such as drumkits or guitars. The sounds generated by software
instruments are calculated by the computer processor, and played via the audio interface
outputs. Often colloquially called softsynths or softsamplers.

solo A way to temporarily highlight one or more tracks or regions or events, allowing
them to be heard in isolation.

Solo tool Click-holding individual regions or events with the Solo tool temporarily allows
them to be heard in isolation. All other objects are muted.

S/P-DIF Short for Sony/Philips Digital Interface, a standard transmission format for
professional stereo digital audio signals. The format is similar to AES/EBU, but uses 75 ohm
coaxial or optical connectors and cabling. Depending on the type of devices involved,
AES/EBU and S/P-DIF coaxial interfaces can communicate directly. Most digital audio
interfaces available today will feature S/P-DIF connectors.

split channel audio files Each channel of multi-channel audio files (stereo or surround)
are usually dealt with together. These files are said to be interleaved. Edits to one channel
will affect the others equally. Logic Pro allows you to separate these files, making them
split channel audio files, enabling independent edits to each. Also see interleaved audio
file.
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SPP Abbreviation for Song Position Pointer, a MIDI clock timing pulse sub-message that
indicates the current “song” (project) position. It is accurate to bars (and beats for some
devices), but is not as accurate as MIDI Time Code (MTC). If you have a choice of these
two when synchronizing Logic Pro, choose MTC (see both the MIDI Clock and MTC entries).

staff style A staff style determines the appearance of notation on a musical staff. You
can define note sizing and spacing, number of staff lines, fonts, and more for each staff
style.

Standard MIDI file (SMF) Standard file format for exchanging songs between different
sequencers or MIDI file players. Standard MIDI files are not specific to a particular sequencer
program, type of computer, or device. Any sequencer should be able to interpret at least
the type 0 MIDI file format. Standard MIDI files contain information about MIDI events,
including time positions and channel assignments, names of individual tracks, instrument
names, controller data, tempo changes, and more.

status byte First byte in a MIDI message, which determines the type of message.

Step Input function The Step Input function allows you to insert MIDI notes—one at a
time—into a MIDI region, when Logic Pro is not in a real-time recording mode. This allows
you to input notes that may be too fast for you to play, or may be useful if replicating
sheet music, but you don’t sight read. Step input can be performed onscreen with the
mouse or with the computer or MIDI keyboard, or any combination of these devices. Also
see In button.

step sequencer While all sequencers, including Logic Pro, step through a series of events,
this term is used to describe a device from the seminal years of analog synthesizers.
Essentially, two rows of knobs (usually 8) were individually adjusted to control the gate
time (note length) and pitch of a connected synthesizer. The sequencer would step
through these knob settings once, or repeatedly. Many modern software instruments,
particularly drum synthesizers, include an integrated step sequencer that synchronizes
with Logic Pro playback. Ultrabeat incorporates a step sequencer which is considerably
more flexible than its ancient analog cousins.

stereo Short for stereophonic sound reproduction of two different audio channels.
Compare with mono.

subframe A sub-division of a SMPTE frame, corresponding to the individual bits of a
SMPTE frame. One frame consists of 80 bits.

surround Surround indicates playback systems that make use of multiple speakers. The
most common surround format is 5.1 channels (front left, front center, front right, left
surround, right surround, and an LFE, or subwoofer, channel), typically used in home
theater systems and in cinemas. Logic Pro supports all common surround formats, and
provides surround recording, plug-in, and mixing facilities.
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Surround Panner Replaces the standard Pan/Balance control of channel strips, set to
Surround in the Output slot. Allows you to control the relative positioning of the channel
signal between the speakers available (in the chosen project surround format).

sustain An envelope parameter that sets the steady amplitude level produced when a
key is held down. See envelope.

sustain pedal A momentary footswitch that is connected to MIDI keyboards. It transmits
MIDI controller number 64, which is recorded and played back by Logic Pro.

Swing parameter Alters the rigid timing of a quantization grid by delaying every other
note of a specified sub-division by a definable amount.

Sync button This button, found on the Transport bar, activates/deactivates external
synchronization mode.

synchronization Method of keeping several recording or playback devices time-locked
with one another. In virtually all synchronized setups, there will be one master device
and one or more slave devices that derive their synchronization clock from the master.

synchronizer Central unit used to control the synchronization of several devices. In most
situations, Logic Pro will act as the master synchronizer.

synthesizer A device (hardware or software) that is used to generate sounds. The word
is derived from early attempts with mechanical and electronic machines to emulate (or
synthesize) the sounds of musical instruments, voices, birdsong, and so on. Logic Pro
features several software synthesizers, including the ES1, ES2, EFM 1, ES E, ES P, and ES
M.

SysEx Abbreviation for System Exclusive data. SysEx data forms the top tier in the hierarchy
of MIDI commands. These messages are tagged with an identification number for each
manufacturer (the SysEx manufacturer ID number). The actual contents of these MIDI
commands is left to the manufacturer. SysEx data is often used to transfer individual (or
banks of ) sound programs or system settings, or to address individual sound generation
or signal processing parameters.

take folder A container for multiple take recordings.

takes A take, put simply, is a recording. Logic Pro allows you to create several takes, one
after the other, without leaving record mode. These takes can then be compiled into a
super take (see comping).

template A project that contains settings and preferences that you have defined.
Templates serve as a starting point for new projects (scoring tasks, audio only projects,
MIDI only projects, and so on, as your personal needs require). Any project can be used
as a template, and you can create and save multiple templates.
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tempo The playback speed of a piece of music, measured in beats per minute. Logic Pro
allows you to create and edit tempo changes in the Tempo track.

tempo change An event inserted into the Tempo track (as a node) that indicates a change
in tempo at a particular bar/beat position.

Tempo track One of the global tracks that displays tempo changes as nodes.

tick The smallest unit of timing resolution in a MIDI sequencer. In Logic Pro, this is 1/3840th
of a note. Logic Pro can go down to single sample accuracy (at sufficient zoom levels) for
edits and positioning, but the MIDI protocol is not fast enough to support this.

time code A format (and signal) for assigning a unique, sequential time unit to each
frame of video or project position. The SMPTE time code format, for example, is measured
in hours :  minutes :  seconds :  frames and subframes.

timing Measure of the ability to play notes at the right time. Timing can also refer to
synchronization between events, regions, and devices.

toggle To switch between two states such as on or off (applies to windows, parameter
values, and so on).

Tool menu Available in the local menu bar of a window, containing tools for editing,
zooming, cropping, and otherwise manipulating items in the window.

toolbar The top of the Arrange window features the toolbar, which is used to access or
hide certain onscreen areas, such as the Media or Lists area or Inspector. It also contains
a number of buttons for key functions, such as Locking/Unlocking SMPTE positions. You
may freely customize the toolbar to meet your needs.

track A horizontal row in the Arrange area that contains either audio or MIDI regions that
can be played back over time. Each track has a specified destination (a channel strip) that
data is routed to. Logic Pro allows hundreds of tracks to be used in a project.

track arming See record-enable.

track list Situated to the left of the Arrange area. Displays the channel strips assigned to
various tracks as well as Track Solo, Mute, and other buttons.

Track Parameter box See Object Parameter box.

Track Protect button The button featuring the lock icon, shown in the Arrange track list,
protects or unprotects tracks from further editing. Also see protected track.

transform set A collection of transform operations (performed in the Transform window)
can be saved as a transform set. Saved transform sets can be quickly accessed via the
Presets menu at the top-left corner of the Transform window. You may also import
transform sets from other projects. See entry below.
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Transform window Logic Pro editor that lets you define a set of conditions and operations
that are used to select and manipulate specific MIDI events.

transient Position in an audio recording where the signal becomes a lot louder—over a
short time span (a signal spike, in other words). As this is typical for drum recordings,
transients can be used to indicate where beats occur in an audio signal.

transient detection A process where audio files are analyzed for transients the first time
you enable a track for flex time editing. See flex time editing.

transient marker A marker that denotes a significant point or peak in an audio file.

Transport bar A field shown at the bottom of the Arrange window, used to control
recording and playback functions. The Transport bar offers Record, Pause, Play, Stop, and
Rewind/Forward buttons plus other functions. You can also open independent Transport
bar windows by choosing Window > Transport (Command-7).

transposition Transposition is the act of changing the pitch of an audio or MIDI region
(or event) by a number of semitones.

Transposition track Global track component that shows transposition events.

treble Refers to high-frequency sounds or components within a sound. See frequency.

Undo function Function that reverses the previous editing operation. The Undo History
allows multiple undo steps to be made.

unicode Fundamentally, computers just deal with numbers. They store letters and other
characters by assigning a number for each one. Unicode provides a unique number for
every character, no matter what the platform, no matter what the program, no matter
what the language.

varispeed A way of speeding up or slowing down the entire project, similar to the original
varispeed feature of tape machines.

velocity Force at which a MIDI note is struck; controlled by the second data byte of a
note event.

Velocity tool This tool, found in the Logic Pro MIDI editors, allows the velocity of individual,
or grouped, note events to be adjusted.

Video track A global track component that allows the viewing of video clips.

virtual memory Area of the hard disk used as an extension of RAM memory by the
computer. The disadvantage is its very slow access time, in comparison to physical RAM.
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Voice Separation tool You can separate polyphonic voices onto different staffs in the
Score Editor by drawing a dividing line with the Voice Separation tool (provided you are
using a polyphonic staff style).

VU meter Abbreviation for Volume Unit meter. An analog meter used to monitor audio
levels.

WAV, WAVE The primary audio file format used by Windows-compatible computers. In
Logic Pro, all recorded and bounced WAV files are in Broadcast Wave format, which
includes high-resolution timestamp information that stores positional information. This
makes it easy to align these files in other audio and video applications.

waveform A visual representation of an audio signal. Waveform graphics run from left
to right, and are centered on a horizontal line. Louder portions of the waveform (amplitude
peaks) are indicated as taller spikes or higher curves in the waveform.

wet/dry mix Refers to the ratio of a signal that effects have been added to (wet), and the
original, unprocessed signal (dry).

white noise Noise type that consists of all frequencies (an infinite number) sounding
simultaneously, at the same intensity, in a given frequency band. Its name is analogous
to white light, which consists of a mixture of all optical wavelengths (all rainbow colors).
Sonically, white noise falls between the sound of the consonant F and breaking waves
(surf ). Synthesis of wind and seashore noises, or electronic snare drum sounds, requires
the use of white noise.

window type Status of the window as a float window or a normal window. Float windows
always float in the foreground and cannot be hidden by normal windows. Also see float
window.

Word Clock Clock signal required by digital audio interfaces to ensure the sampling rates
of connected devices run synchronously. When two devices are connected via a standard
digital audio interface (such as S/P-DIF or ADAT optical), Word Clock is transmitted via
the audio circuit. If you want more than two digital audio devices to communicate with
each other, you will need to use separate Word Clock ports for synchronization, in most
cases.

word length See bit depth.

XG Extended General MIDI standard from Yamaha, compatible with Roland GS.

zero crossing A point in an audio file where the waveform crosses the zero amplitude
axis. If you cut an audio file at a zero crossing there will be no click at the cut point.
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zoom An action that enlarges (zooms in on) or shrinks (zooms out from) the display in
a Logic Pro window. The Zoom tool, and the zoom controls found in the lower-left and
upper-right corners of windows, are both used for zooming tasks. Also see zoom control
and zoom level.

zoom control The control that appears at the bottom-right corner of some windows,
such as the Arrange area. The zoom control slider allows you to navigate through the
entire length of the currently displayed project. The lines on the left and right of the slider
can be clicked to zoom in and out by a fixed percentage.

zoom level The amount that window contents (tracks and regions, for example) are
magnified. Zooming in to a high level allows you to make more precise edits. Conversely,
you can zoom all the way out to see the entire project and work on very large sections.

Zoom tool This tool allows you to zoom in on any part of the active Logic Pro window.
You can choose this tool from the Toolbox, or activate it when using other tools by holding
down the Control key and clicking.
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