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Overview

Welcome

Thank you for purchasing a DeckLink broadcast video card. 

We hope you share our dream for the television industry to become a truly creative industry by 
allowing anyone to have access to the highest quality video.

Previously high end television and post production required investment in millions of dollars of 
hardware, however with DeckLink cards, even 10 bit uncompressed is now easily affordable. We 
hope you get years of use from your new DeckLink card and have fun working with some of the 
world’s hottest television and design software!

This instruction manual should contain all the information you’ll need on installing your DeckLink 
capture card, although it’s always a good idea to ask a technical assistant for help if you have not 
installed hardware cards into computers before. As DeckLink uses uncompressed video and the 
data rates are quite high, you’ll need fast disk storage and a high-end Mac.

We think it should take you approximately 10 minutes to complete installation.  Before you install 
DeckLink, please check our website at www.blackmagic-design.com and click the support page to 
download the latest updates to this manual and DeckLink driver software. Lastly, please register 
your DeckLink when downloading software updates. We would love to keep you updated on new 
software updates and new features for your DeckLink. Perhaps you can even send us your latest 
show reel of work completed on your DeckLink and any suggestions for improvements to the 
software. We are constantly working on new features and improvements, so we would love to hear 
from you!

Grant Petty

CEO Blackmagic Design
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Before installing a DeckLink card

PCI slots and DeckLink cards

The PCI slots found in many modern computers allow users to add hardware such as DeckLink 
cards. Computers have become faster over time and so too have the types of PCI slots used in 
computers. DeckLink cards are available for computers with PCI, PCI-X and PCI Express (PCIe) slots. 
If you already know which kind of PCI slots are in your Mac, you can skip this section.

The following information should help you to identify which kind of PCI slots are in your computer 
and which DeckLink cards are compatible with your computer.

History

DeckLink cards were originally designed for compatibility with the PCI slots in Power Mac G4 
computers. Current DeckLink cards and drivers are no longer tested with Power Mac G4 computers 
and support is no longer provided for Power Mac G4’s. However the current DeckLink drivers and 
cards may well work fine with the older computers.

Power Mac G5 computers with PCI-X slots

When Apple introduced the Power Mac G5 series of computers, they introduced a new and faster 
PCI bus named PCI-X. These slots support DeckLink PCI-X cards and also provide backward 
compatibility for DeckLink PCI cards.

Within each new generation of Power Mac G5’s, there was usually a “Good, Better and Best” model 
of G5. The “Good” model was the base model in each generation of G5’s and featured the older 
33 MHz PCI slots. Unfortunately these PCI slots run too slowly and so the “Good” Power Mac G5 
models are not compatible with DeckLink PCI cards.

The “Better” and “Best” models of G5’s contained PCI-X slots. These slots support DeckLink PCI-X 
cards and also provide backward compatibility for DeckLink PCI cards. We recommend that the top 
slot, slot 4, be used for the DeckLink PCI-X or DeckLink PCI card. This slot is on an independent 133 
MHz PCI-X bus and is perfect for use with the demands of uncompressed video through DeckLink 
cards.

Slots 2 and 3 of the “Better” and “Best” models of G5’s share a common 100 MHz PCI-X bus. While 
either of these slots are suitable for use with a DeckLink PCI-X or DeckLink PCI card, it is best to 
leave the other 100 MHz PCI-X slot unused to avoid inadvertently slowing down the entire shared 
bus. For example, if a 33 MHz PCI SCSI card was installed in slot 2 and a DeckLink HD Pro PCI-X 
card in slot 3, the entire bus would be slowed down to the speed of the SCSI card. The DeckLink HD 
Pro PCI-X card would run too slow to support high definition video but would probably still support 
standard definition video. For this reason, we recommend leaving the second 100 MHz slot free or 
preferably use the 133 MHz slot for the DeckLink card.

Before installing a DeckLink Card
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Before installing a DeckLink card

Power Mac G5 computers with PCI Express (PCIe) slots

The Late 2005 generation of Power Mac G5 computers introduced a new and faster PCI bus named 
PCI Express (PCIe). PCIe slots are physically different to earlier slots and do not provide backward 
compatibility. PCI and PCI-X cards cannot be used with PCI Express slots. DeckLink PCIe cards are 
fully compatible with PCI Express slots. 

Which PCI slots are in my Power Mac G5?

Go to the Apple menu and choose “About This Mac”. Click on the “More Info” button and the 
System Profiler will open. Click on the Hardware category in the Contents pane and the Hardware 
Overview will appear in the right pane. Verify the Model Name is “Power Mac G5”.

Under the hardware category, click on Memory. The right pane should show the number of memory 
slots in the Power Mac G5. If only four memory slots are displayed, the Power Mac G5 contains PCI 
slots and cannot be used with DeckLink cards. If eight memory slots are displayed, the Power Mac 
G5 contains either PCI-X or PCIe slots. Eight memory slots are pictured here.

If the Power Mac G5 contains eight memory slots, check whether it has one or two Ethernet 
networking ports. If your G5 is in a location where you cannot physically see the Ethernet ports, click 
on Network in the Contents pane of System Profiler and the networking ports will appear in the 
right pane. If one Ethernet port is displayed, the G5 contains PCI-X slots. If two Ethernet ports are 
displayed, the G5 contains PCI Express slots. Two Ethernet ports are pictured here.

You can confirm your model of Power Mac G5 online by copying & pasting your G5 serial number, 
from the Hardware Overview information in System Profiler, in to the “Find by Serial Number” 
field at http://support.apple.com/specs/. Then review the resulting information in the section “PCI 
expansion”.

Count the number of memory slots

Verify the Model Name is “Power Mac G5”

Count the number of ethernet ports

Before installing a DeckLink Card
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Before installing a DeckLink card

Mac Pro with PCI Express (PCIe) slots

The first generation of Mac Pro computers introduced the Intel processor and continued to use 
PCIe slots. DeckLink PCIe cards are fully compatible with the Intel-based Mac Pro’s and with PCIe 
slots. We recommend that the top slot, slot 4, be used with DeckLink PCIe cards for maximum 
reliability. The number of PCI Express lanes available to each PCIe slot is configurable using Apple’s 
Expansion Slot Utility which should automatically appear upon startup after a PCIe card has been 
installed. The second PCI Express Profile should be chosen in the Expansion Slot Utility for use with 
DeckLink cards, ie: x16 Lane Graphics Slot + Two x4 Lane and One x1 Lane Slots

The Early 2008 generation of Mac Pro computers introduced PCI Express 2.0 slots as well as 
retaining the original PCI Express slots. DeckLink PCIe cards should be used in slots 3 or 4 (the 
top two slots) of these Macs. Slots 1 and 2 are PCI Express 2.0 slots which are usually reserved for 
graphics cards and should not be used with DeckLink PCIe cards. The Expansion Slot Utility does 
not apply to the Early 2008 generation of Mac Pro’s as the number of lanes is permanently set for 
each slot. If you attempt to open the Expansion Slot Utility on this generation of Mac Pro, an error 
message will appear stating, “Expansion Slot Utility is not intended to run on this system”. You can 
confirm your model of Mac Pro online by copying & pasting your Mac Pro serial number, from the 
Hardware Overview information in System Profiler, in to the “Find by Serial Number” field at http://
support.apple.com/specs/.

Regardless of which generation of Mac Pro you have, slot 4 can always be used with DeckLink PCIe 
cards.

Expansion Slot Utility

Before installing a DeckLink Card
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Installation

Installing a DeckLink PCI or PCI-X card in a Power Mac G5 with PCI-X slots 
 
Please review the section in your G5 user manual entitled “Installing a PCI Expansion Card or 
Replacing the AGP Card” for information on how to safely install PCI and PCI-X cards, including 
your DeckLink card.

Before commencing this procedure, you will need to verify that your Power Mac G5 contains PCI-X 
slots. Please refer to the earlier section “Which PCI slots are in my Power Mac G5?” for help in 
identifying the type of PCI slots in your Mac.

1.	 Remove the power plug from the back of your Mac. This is a safety precaution before opening 
	 your computer. Ensure that you are statically discharged by using a static strap.

2.	 Remove the side cover of your Mac to gain access to the PCI slots. 

3.	 Remove your DeckLink card from the protective static bag making sure you don’t touch the 
	 gold connectors on the base of the card. These precautions should be taken when handling any 
	 PCI card.

4.   Find a spare PCI-X slot, preferably slot 4.

	 Slot 4 is usually the best PCI-X slot to use with DeckLink PCI and DeckLink PCI-X cards  
	 as it is the fastest slot and is on an independent 133 MHz PCI-X bus. Slot 4 is the top slot in a  
	 Power Mac G5. 

5.   Remove the metal port access cover, and screw, from the back of your Mac.

6.	 Insert your DeckLink card and ensure that it clicks firmly into place. G5’s seem to have tight slots 
	 so make sure the DeckLink card is firmly seated in to place.

7.	 Secure the card by the screw. 

8.	 The procedure for installing a RAID controller card is similar to the above.

9.	 Now replace the side cover of your Mac. Reconnect the power and start up the computer.

If you find the job of installing a “DeckLink” or “DeckLink HD Pro PCI-X” card in the top slot to be 
too tricky, simply install it in one of the 100 MHz slots (slots 2 or 3). It is much easier to fit the card 
in to these slots and we have verified that the card runs fast enough in the 100 MHz slots. Avoid 
placing a slower PCI card in the other 100 MHz slot as both slots will be reduced to the speed of 
the slower card.

Installation
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If you decide to install a DeckLink or DeckLink HD Pro PCI-X card in the top slot of a G5,  
you will need to carry out the following procedure:

Lie the G5 on its side to make it easy to insert the DeckLink card.1.	

Loosely seat the card in position in the top slot.2.	

Press the back end of the card in to the slot, i.e. the end that does not have BNC connectors.3.	

Tilt the top of the card towards the top of the G5, i.e. towards the bay that can hold the two 4.	
hard disks.

While tilting the card on this angle, you should be able to press down carefully on the front of 5.	
the card and it will slide down in to the slot. You will need to be careful while doing this as the 
metal BNC connectors on the DeckLink card will press against a black, plastic plug. The plug 
will flex slightly as you slide the DeckLink card in to position.

This procedure does not require much force. If you find yourself having to use too much force, or 
feel at all uncomfortable with this procedure, use one of the 100 MHz slots instead and you will find 
that you can install your card easily.

Installation

Installation
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Installing a DeckLink PCIe card in a Power Mac G5 with PCIe slots

Please review the section in your G5 user manual entitled “Adding PCI Express Cards” for information 
on how to safely install PCI Express cards, including your DeckLink card.

Before commencing this procedure, you will need to verify that your Power Mac G5 contains PCIe 
slots. Please refer to the section “Which PCI slots are in my Power Mac G5?” for help in identifying 
the slots in your Mac.

1.	 Remove the power plug from the back of your Mac. This is a safety precaution before opening 	
	 your computer. Ensure that you are statically discharged by using a static strap.

2.	 Remove the side cover of your Mac to gain access to the PCIe slots. 

3.	 Remove your DeckLink PCIe card from the protective static bag making sure you don’t touch 
	 the gold connectors on the base of the card. These precautions should be taken when handling 
	 any PCI card.

4.   Find a spare PCIe slot and any of PCIe slots 2, 3 or 4 can be used. Remove the metal port access 
	 cover and screw from the back of your Mac.

5.   Insert your DeckLink PCIe card and ensure that it clicks firmly into place.

6.   Secure the card by the screw. 

7.   The procedure for installing a RAID controller card is similar to the above.

8.   Now replace the side cover of your Mac. Reconnect the power and start up the computer.

Installation

 

Installation
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Installing a DeckLink PCIe card in a Mac Pro

Please review the section in your Mac Pro user manual entitled “Adding PCI Express Cards” for 
information on how to safely install PCI Express cards, including your DeckLink card.

Slot 4 is the recommended slot for DeckLink cards in the first generation of Mac Pro’s.

Slot 3 or 4 (the top two slots) are the recommended slots for using a DeckLink PCIe card in an Early 
2008 model Mac Pro.

Please refer to the earlier section “Mac Pro with PCI Express (PCIe) slots” for help in identifying your 
model of Mac Pro. Alternatively you can confirm your model of Mac Pro online by copying & pasting 
your Mac Pro serial number, from the Hardware Overview information in System Profiler, in to the 
“Find by Serial Number” field at http://support.apple.com/specs/.

After installing your DeckLink PCIe card and closing the door on your Mac Pro, attach the supplied 
DeckLink breakout cable to to the external multi-pin connector on your DeckLink card. Some card 
models ship with both professional and consumer breakout cables for connecting to different video 
hardware. Attach the appropriate breakout cable for your needs.

Installing the HDMI bracket in a Mac Pro

The DeckLink HD Extreme 2 includes an HDMI bracket. After installing the DeckLink HD Extreme 2 
card in slot 4, you will need a spare slot to install the HDMI bracket. The Mac Pro has a double-width 
graphics slot in slot 1. If you have a regular-width graphics card in slot 1, you can install the HDMI 
bracket in the spare port which would have been used by a double-width graphics card.  If that port 
is already occupied by a double-width graphics card, use a spare slot to install the HDMI bracket. If 
you don’t need HDMI input and output, there is no necessity to install the HDMI bracket.

The Mac Pro includes a PCI bracket with two captive screws which is designed to secure all PCI 
Express cards. The Mac Pro PCI bracket does not seem to firmly secure the HDMI bracket and so we 
have included 6 screws with your DeckLink HD Extreme 2. Use these screws, in place of the Mac Pro 
PCI bracket, to firmly secure all your PCI Express cards, port access covers and the HDMI bracket 
belonging to DeckLink HD Extreme 2.

After installing and securing the HDMI bracket, loop the included HDMI cables around any other 
installed cards and plug them into the rear of the DeckLink HD Extreme 2 card. HDMI input is the 
lower connector and HDMI output is the upper connector. You may wish to secure any excess cable 
length by using a cable tie to neatly hold it in place.

Installation

Install any model of DeckLink PCIe card in slot 4 
as shown in the above picture. The DeckLink HD 
Extreme 2 also has an HDMI bracket, which installs 
in any spare port, and connects to the rear of the 
card with the supplied HDMI cables.

Attach the supplied DeckLink breakout cable to the 
DeckLink card. The DeckLink HD Extreme 2 card 
also includes a HDMI bracket as pictured above.

Installation
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Installation

Installing the software

Contents

The DeckLink software installer will install the following components for you:

Blackmagic DeckLink drivers��
Blackmagic Deck Control application��
Blackmagic System Preference��
Blackmagic QuickTime�� ™ codecs
Final Cut Pro�� ™ Easy Setups, presets and enablers
Blackmagic Disk Speed Test��
Blackmagic FrameLink��
DeckLink Utility��

Note: Before installing any software or hardware you will need administrator privileges.

DeckLink software

1.	 The CD supplied with the DeckLink contains the DeckLink software. Before you install, ensure 
you have the very latest driver. Visit www.blackmagic-design.com/support

2.	 Open the “DeckLink Installer” folder and launch the “DeckLink Installer” application.

3.	 Click Continue, Agree and Install buttons and the drivers will be installed on your system.

4.	 Now restart your machine to enable the new software drivers.

Automatic firmware updating

After your Mac has restarted, the software will talk to the DeckLink to see what firmware is running 
in it’s hardware. If the firmware is not the same as the DeckLink software requires, you’ll be asked 
to download the correct version. This is automatic, and all you need to do is plug in the USB cable, 
then click OK to start the update. After the firmware updates, shut down your computer and power 
off the DeckLink. Power on the DeckLink, and then start up the computer.

Programmable firmware let’s us release new features and we can also update your DeckLink for 
greater compatibility with latest third party software tools.

Follow install prompts.

Select Destination.

Installation
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Installation

Testing your installation

Testing

To check the installation has been successful:

1.	 Go to the Apple menu and choose System Preferences. Click on the Displays icon and 
then on the Arrangement tab. You should see an extra display which represents the extended 
desktop feature of your DeckLink. The size of the DeckLink display will appear differently to your 
computer display, and may be in 2K, HD or SD resolution. Depending on the model of your 
DeckLink card.

2.	 Select where Mac OS X™ sounds are routed and change this to use DeckLink audio outputs. To 
do so, go to the Apple menu and choose System Preferences. Click on the Sound icon and 
then on the Output tab.

3.	 Select Mac sound to output via DeckLink by selecting the DeckLink Audio on the Output tab.

Selecting DeckLink Audio will now direct all your Mac sounds to the audio outputs on DeckLink. 
Try playing some music in iTunes, checking to see if you can see the desktop video out on all 
video outputs, and hear the music on all the audio outputs. 

The DeckLink HD Extreme 2 has SDI, Component analog, Composite analog and HDMI video 
outputs as well as SDI, HDMI, XLR analog and AES digital audio outputs. Other models of 
DeckLink cards have some but not all of these video and audio outputs.

4.	 Check all of the DeckLink outputs for desktop video.

Note: You won’t see any video on the composite analog NTSC/PAL outputs if the desktop is set to 
HD or 2K modes. You won’t see any video on the component analog outputs if the desktop is set 
to 2K modes. A 2K monitoring solution, such as HDLink Pro and a 30” monitor, is required to view 
2K-SDI video output from hardware such as DeckLink HD Extreme 2 and Multibridge Eclipse.

5.	 Check audio output channels 1 & 2 for the iTunes playback. The same audio should be heard 
on all the audio outputs provided on your model of DeckLink card, eg: analog XLR, AES/SPDIF, 
HDMI and SDI.

If this is all working well, you know your DeckLink is working correctly.

Display arrangement

Display settings.

Audio settings.

Installation
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Blackmagic Software

Using Blackmagic Deck Control

Blackmagic Deck Control is an easy to use utility, used for frame accurate capture from and recording 
to your tape deck. It is controlled via RS-422 and uses the Sony™ RS-422 protocol.

It’s great for use with applications such as Adobe After Effects™ that don’t include their own deck 
control capabilities.

Pixel formats supported by Blackmagic Deck Control are:

Blackmagic QuickTime�� ™ RGB 10 bit uncompressed
Apple QuickTime�� ™ 10 bit uncompressed
Apple QuickTime�� ™ 8 bit uncompressed
Apple QuickTime�� ™ PhotoJPEG compressed
Apple QuickTime�� ™ DV compressed

This utility can capture or play back one video clip at a time. The application has two displays used 
for viewing clips in playback, or viewing the video input. The left window is the clip playback window 
and the right is the capture window.

Setting up

1.	 Double click the Blackmagic Deck Control icon on your desktop to open the application.

2.	 Open Edit > Preferences and select one of the Easy Setups from the drop down menu.

3.	 Select your disk array as the capture location, and the easy setup for your capture format.

4.	 Click OK

Playback

1.	 Select File > Open and choose the video file you wish to playback. If you have added 
Blackmagic Deck Control to your Dock, you can also drag a movie file onto the Blackmagic Deck 
Control icon to open it. The file will appear in the playback window.

2.	 Click the Play triangle below the clip. 
	 (You can also scrub the clip just like the QuickTime™ player.)

Note: Make sure the files you wish to play back are TV-formatted QuickTime™ files otherwise they 
will not appear on the DeckLink output. Computer resolutions such as 1920 x 1200 and 800 x 600 
are not TV formats and are not supported.

Deck Control preferences.

Deck Control interface.

Blackmagic Software
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Blackmagic Software

Using Blackmagic Deck Control

Features
Loop playback
Loop back and forth
Grab frame (to Adobe Photoshop™ file)

Copy and paste (just like QuickTime™ player)

Inserting to Tape

1.	 Open the clip that you require to print to tape.

2.	 Enter the timecode of the desired in-point. Deck Control will use the clip duration to automatically 
calculate the out point.

3.	 Click Put Clip

Capturing clips

There are two ways to capture clips:

1.	 Capture Now
	 Captures video and audio instantly. (Command + k)

2.	 Get Clip
	 Captures frame accurate timecode, video, audio to “in” and “out-points” set by the user. 

(Timecode will only be available if RS-422 is connected.)

Note: Your video deck will respond to the standard keys used for Deck Control, i.e. “<spacebar>”, 
“j”, “k” and “l” keys. “In and Out points” can be set using the “i” and “o” keys while playing 
the tape.

AppleScript

Blackmagic Deck Control supports AppleScript™ commands for starting and stopping video 
capture. The status of the capture can also be requested via AppleScript™ for confirmation that 
capture has started or stopped.

Deck Control “Capturing to Disk“.

Blackmagic Software
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Blackmagic Software

Using Blackmagic FrameLink

Blackmagic FrameLink™ provides seamless DPX support using uncompressed QuickTime™ movies. 

The key to understanding FrameLink, is when you mount a QuickTime™ movie with FrameLink it 
appears as a virtual drive full of DPX frames from the movie. This virtual drive acts as a container for 
the DPX sequence. Any frames modified will be automatically written back into the movie when the 
frame is saved.

FrameLink totally eliminates the time wasted using simple movie to image-sequence conversion 
utilities. FrameLink is great for using software that only supports still frames, or simply open individual 
media file frames in Photoshop™ for dirt and scratch removal, then save the frames back into the 
movie file for instant playback. 

Note: If an audio track is included with the media that you are converting to a DPX sequence, the 
length of the sequence cannot be modified. To add and remove DPX frames from a sequence, the 
audio tracks should be removed and restored later in your NLE.

Supported file formats

Apple™ and Blackmagic™ uncompressed QuickTime™ files can be used with FrameLink, including 
8-bit & 10-bit YUV HD and SD, as well as 10-bit RGB 4:4:4 HD and 2K.

Mounting a FrameLink volume

Drag the QuickTime™ movie onto the FrameLink application icon. A volume will appear on your 
desktop and in the side panel of the Finder window. This volume will contain all the frames of the 
QuickTime™ movie in DPX format.

Creating a new movie from DPX files

1.	 Double click on the FrameLink application icon and enter the desired movie type you want to 
create. (Match the resolution of your existing DPX sequence.). A disk will mount on the desktop.

2.	 Copy the DPX file sequence to the virtual disk, and as the frames are copied, they are written 
into the QuickTime™ movie file automatically.

Note: You can save your DPX files from any application to the FrameLink volume, or simply drag 
and drop the files into the FrameLink volume.

Unmounting a FrameLink volume

Simply eject the mounted drive. (Command + e). 

Mounted FrameLink volume.

FrameLink volume with DPX sequence.

Blackmagic Software
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Blackmagic Software

Setting Blackmagic Preferences

DeckLink preferences are located in your Mac’s System Preferences in the “Other” category. 
Different DeckLink models have some different features. Any preferences not available to your 
DeckLink card will be grayed out and unavailable. The following preferences contain options for 
setting up your DeckLink.

Settings

Input and Output connections��

NTSC Setup��

Field Jitter��

4:4:4 color mode��

Black reference output during capture��

DeckLink Extended desktop��

Reference Output Timing (Genlock)��

Processing

Down conversion��

Up conversion��

Lookup Table��

VITC Reader A Frame - 3:2 Pulldown Removal��

VANC input��

Video Levels

Calibrate Analog Video In��

Calibrate Analog Video Out��

Betacam/SMPTE level switch��

Audio Levels

HiFi/Professional Audio Levels��

Analog Audio Input Levels��

Analog Audio Output Levels��

AES/EBU Input Reference Level��

AES/EBU Output Reference Level��

DeckLink preferences.

System Preferences.

Blackmagic Software
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Blackmagic Software

Setting Blackmagic Preferences

DeckLink video and audio output connections

All of the video and audio outputs of DeckLink cards are active all of the time and the only choice 
you need to make on some models is between component (Y,R-Y,B-Y) analog video, S-Video or 
composite NTSC/PAL analog video as they use shared connectors.

The SDI, HDMI and component (Y,R-Y,B-Y) analog video outputs support HD and SD video. 
S-Video and composite analog video do not support high definition video and so you will not 
see video on these outputs when working with HD video.

S-video is supported on some HD models of DeckLink cards and may require the use of an 
inexpensive S-video adapter cable. See the connection diagrams for S-video towards the end 
of this manual.

DeckLink video and audio input connections

Your DeckLink model may support some or all of the following combinations:

SDI Video & SDI Audio��

SDI Video & AES/EBU Audio��

SDI Video & Analog XLR Audio��

HDMI Video & HDMI Audio��

HDMI Video & AES/EBU Audio��

HDMI Video & Analog XLR Audio��

Y, R-Y, B-Y Video & AES/EBU Audio��

Y, R-Y, B-Y Video & Analog XLR Audio��

NTSC/PAL (Y In) & AES/EBU Audio��

NTSC/PAL (Y In) & Analog XLR Audio��

S-Video & AES/EBU Audio��

S-Video & Analog XLR Audio��

Video and Audio output connections.

Video and Audio input connections.

Blackmagic Software
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Blackmagic Software

Setting Blackmagic Preferences

Reference Output Timing

Genlock, also known as black burst, reference or house sync is used to lock various equipment in 
your facility to the same timing point. When two or more video devices are connected to the same 
sync signal, their video signals can be switched without jumping or rolling. This is critical when 
connecting equipment in large post production facilities and broadcast stations.

To change video to reference timing:

1.	 Go to the Mac’s System Preferences and click the DeckLink control panel.

2.	 Select the Settings tab and adjust the Set reference output timing for timed output 
until the picture locks and is no longer rolling on the display.

HDTV Up/Down Conversion

The Mac OS X™ software drivers included with DeckLink, can be used to downconvert high definition 
to NTSC or PAL video in real time during capture or playback. They also provide upconversion on 
capture. Select the desired option from the output or input processing menus under the Processing 
tab.

Output Processing
HD to SD Letterbox 16:9��

HD to SD Anamorphic 16:9��

720p HD to 1080i HD��

Input Processing
1080i HD to SD Letterbox 16:9��

1080i HD to SD Anamorphic 16:9��

720p HD to SD Letterbox 16:9��

720p HD to SD Anamorphic 16:9��

SD Letterbox 16:9 to HD��

SD Anamorphic 16:9 to HD��

Genlock timing adjustment.

HDTV Up/Down Converter preferences.

Blackmagic Software
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Blackmagic Software

Lookup Tables (LUT’s) in DeckLink HD Extreme 2 for Mac OS X

DeckLink HD Extreme 2 can use 1D or 3D LUT’s during playback. Lookup tables can be used for 
standard definition and high definition video as well as 2K film.

1D LUT’s are useful for altering the brightness of an image but do not affect color. They are often 
used when working with log video so that the image can be displayed on screen as normal linear 
video. Built-in 1D LUT’s are provided for log to linear conversion when playing video captured from 
Panasonic Cinegamma™ and Viper Filmstream™ cameras.

3D LUT’s provide the ability to increase and decrease the amount of color in each color channel, 
independently from brightness. This allows for precise color grading to ensure a video monitor 
matches the color printed to tape or film.

How to use Lookup Tables in DeckLink

When the System Preferences are opened to access the DeckLink lookup table settings, your 
broadcast monitor will usually stop showing any video being played and instead will show an 
extended desktop. It is possible to replace the extended desktop, with the last played frame of 
video, so that adjustments to lookup tables can immediately be seen on the frame of video.
To use this feature, open the System Preferences and click on DeckLink. Under the Settings tab, 
look for, “When not playing video, send ... to all the video outputs.” This setting is usually set to 
Extended Desktop or Black depending upon your personal preference. Switch it to “Last Played 
Frame” and then restart the computer.

After the computer has restarted, use your preferred video software application to play some 
video and then open the System Preferences in Mac OS X. The last played frame of video should 
remain on your broadcast monitor. Click on the DeckLink icon in System Preferences and then click 
on the Processing tab. A Lookup Table button is available for output processing and this can be 
used even when all other processing functions are set to “Off”. Click on the output Lookup Table 
button and then activate the Enable Lookup Tables checkbox.

The lookup table interface in DeckLink can be adjusted using a method similar to that used for 
image adjustment with the Curves feature in Adobe Photoshop™. The horizontal axis of each 
graph represents the original color input values and the vertical axis represents the new colour 
output values. When first opened, each lookup table displays a straight diagonal line because the 
color values have not yet been changed.

Changes made to the lookup tables can immediately be seen on all SDI, analog and HDMI outputs 
of the DeckLink card. Changes are saved to the DeckLink preferences by clicking the OK button. 
Lookup tables can be reset to original values by clicking the Reset Unity button. Lookup table 
processing can be disabled by deselecting the Enable Lookup Tables checkbox.

Enable Last Played Frame.

Click on the Lookup Table button.

Blackmagic Software
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Importing and exporting 3D LUT’s

DeckLink HD Extreme 2 supports the popular Autodesk .3dl, IRIDAS .itx and IRIDAS .cube lookup 
table formats when importing 3D LUT’s.

3D LUT’s can also be exported from DeckLink in the .cube format. DeckLink uses the .cube format 
to store 3D LUT’s internally as this is a most memory efficient way to store complex lookup tables. 
Both 3D LUT’s created with curves in the lookup table interface, and 3D LUT’s imported from .3dl, 
.itx and .cube files, are exported from DeckLink in the .cube format.

The .cube file format is fully compatible with the following Blackmagic Design products which share 
the same LUT format: DeckLink HD Extreme 2, Multibridge Eclipse, Multibridge Pro (October 2007 
model) and HDLink Pro.

Importing and exporting 1D LUT’s

DeckLink HD Extreme 2 can import 1D LUT’s. The 1D file format is any tab-delimited text file with 
red, green and blue values for each record and the first line (title line) is skipped. Lookup tables 
need to be 1024 records long with the first line reserved for the title line.

1D LUT’s can also be exported from DeckLink HD Extreme 2 in the same text format mentioned 
above. Both 1D LUT’s created with the curves in the lookup table interface, and 1D LUT’s imported 
from text files, are exported from DeckLink in the same text format.

The 1D LUT text file format is fully compatible with the following Blackmagic Design products 
which share the same LUT format: DeckLink HD Extreme 2, Multibridge Eclipse, Multibridge 
Pro (October 2007 model), Multibridge Extreme (DVI output), HDLink Pro, HDLink and  
DeckLink HD Pro 4:4:4 (PCI-X).

Load Lookup Table from File.

Load Built-In Lookup Table.

Lookup Table interface.

Blackmagic Software
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Setting Blackmagic Preferences

Black Video Output

This setting allows DeckLink to output a stable black signal on one video output, while outputting 
video on the other output. Black Video Output is used for video referencing an SDI deck when 
you don’t have a sync generator available. This allows the stable black video output to connect 
to the deck, and then by setting the deck to “input reference” you can operate without a sync 
generator. If you’re not an SDI deck, or you’re not using this mode, disable this setting to enable 
audio monitoring during capture. 

NTSC setup

The NTSC composite video used in the USA, and some other countries uses 7.5% setup. However 
setup is only used in composite video, but is never used in SDI video. Your DeckLink will handle 
adding and removing setup from NTSC video automatically for you. The USA and countries that use 
7.5% setup should enable this setting; if you’re working in Japan and countries that don’t use this 
setup, leave this set to 0 IRE setup. The PAL and high definition standards do not use this setup.

Video Desktop

This setting allows DeckLink to act as a display device with the desktop appearing out of the video 
outputs. This setting allows the desktop mode to be turned on and off and any change requires a 
restart. It’s important that you set the desktop mode to the same standard as your video capture and 
playback, or you will get slower switching between capture and playback modes, as the monitors 
need to re-lock.

If you don’t want to use the Extended Desktop feature, set this option to Black and then restart  
the Mac.

If you adjusting LUT’s on some DeckLink models, set this option to Last Played Frame so you can 
observe the effect of any adjustment to LUT’s.

NTSC Setup.

Video Desktop.

Black Video Output.

Blackmagic Software
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Setting Blackmagic Preferences

Video Output Behavior

Remove Filter Jitter
“Remove field jitter when video is paused” allows DeckLink to display only a single field when 
paused, while turning this mode off will display a complete frame in pause. Single field is similar to 
how Betacam SP decks work when paused, eliminating field flicker from paused images. 

If you’re doing work without interlaced video, such as animation, then you can turn this mode off  
so you can see both fields in full resolution for best quality. Regardless of this setting, you always  
get the correct full frame dual field output when in playback mode, as this setting only effects 
paused video. Video Output Behavior.

Blackmagic Software
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Setting Blackmagic Preferences

Preserving Blanking Data or VANC

This feature lets you use up to 3 video lines at the top of a captured QuickTime™ movie file to store 
any 3 lines from vertical blanking. This allows 3 line timecode, VITC (vertical interval test signals) 
subtitle info or any other VANC data to be preserved during capture. These lines are then inserted 
back into the video blanking when the file is played back.

To preserve VANC data:

1.	 Go to the Mac’s System Preferences and click the DeckLink control panel.

2.	 Select the VANC and 3:2 Pulldown tab and tick the On check box for video line 1, 2 or 3 
depending on how many blanking lines you want to capture.

	 Note: Video file line 1 needs to be enabled for lines 2 and 3 to work.

Because these lines can be passed to the application, a developer could write software to read the 
VANC data and use it for various purposes, e.g. 3-line timecode and audio chasing, or other uses.

An example of VANC data is 3-line timecode, which uses lines 18, 19, and 20 in NTSC or lines 19, 
20 and 21 in PAL. 3-line timecode, as used in AATON™ equipped telecine suites, featuring audio 
timecode and keycode information along with the normal timecode numbers.

VANC preferences.

Blackmagic Software
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Blackmagic Disk Speed Test

If you want to check your disk array speed, Blackmagic Disk Speed Test can be run to check the array 
speed, and to provide the results in video frame rates. This makes it much easier to understand 
how various disk arrays will handle video capture and playback at various video resolutions and 
frame rates.

Disk Speed Test provides more accurate results for large disk arrays, as often the manufacturer 
provided speed results only check small data blocks, so you only get an indication of the cache 
speed of the disk and not the sustained data rate of the disk. Video uses sustained data rates and 
only Disk Speed Test provides a long burst of data for more accurate results. 

When using Disk Speed Test, you need to account for disk seeking, so it’s best to add a healthy 
margin to the results. If a disk array tests at 32 frames per second HD 1080, it doesn’t mean you can 
do 29.97 HD capture and playback, as the margin is too tight. However it should do 24 fps ok.

Apple Xserve RAID preferences.

Apple Xserve RAID disk arrays

The Apple Xserve RAID works great for both SD and HD when fully populated with 14 disks and 
at least 512 MB of RAM for each RAID controller. We tested an Apple Xserve RAID™ with the 
new Apple Power Mac G5. For maximum performance and stable capture and playback with 
uncompressed video we recommend the following settings:

Check Use Controller Write Cache
Uncheck Allow Host Cache Flushing
Check Use Drive Write Cache
Uncheck Use Steady Streaming Mode
Set “Read Prefetch” to 128 Stripes (8 MB/disk)

These are the settings we have found delivers stable capture and playback with uncompressed 10 
and 8 bit video. However we have found uncompressed 10 bit 4:4:4 RGB is still not possible on a 
single Xserve RAID. Other settings might also provide optimal performance and we recommend you 
check with your local reseller before changing settings if you’re unsure of what these controls do.

Disk Speed RAID results after testing a disk array.

Blackmagic Software
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Apple Final Cut Pro

Apple Final Cut Pro™ is a powerful real-time video and audio non-linear editing application. In 
conjunction with your new DeckLink, Final Cut Pro will allow you to work in every video standard, 
from DV up to uncompressed 4:4:4 RGB high definition and even 2K for film work.

“Easy Setups” for Final Cut Pro will have been added automatically during the DeckLink installation 
process if Final Cut Pro is previously installed. Its important to install Final Cut Pro before installing 
the DeckLink software.

Setting up

1.	 Launch Final Cut Pro.

2.	 The Easy Setup window will appear.

3.	 Click on the popup menu and select a relevant Blackmagic Easy Setup. For each TV format 
(NTSC, PAL and HDTV) you will find a range of compressed and uncompressed file formats 
you can choose. For example, if you are working in NTSC format, you could choose one of the 
following “Easy Setups”:

Blackmagic NTSC - 10 Bit��
Blackmagic NTSC - 8 Bit��
Blackmagic NTSC - Apple ProRes (HQ)��
Blackmagic NTSC - DV��
Blackmagic NTSC - DV50��
Blackmagic NTSC - IMX MPEG (50 Mb/s)��
Blackmagic NTSC - JPEG��

The “Easy Setup” you choose will be dictated partly by the speed of your disk array and partly by 
whether you already have movie clips in a particular format. If you have a fast disk array, you can 
choose a 10 bit format and the quality will be very high and visually stunning. If you only have a 
single disk for storage, you could choose either DV, DVCPRO HD, JPEG or ProRes. ProRes is a good 
choice as it is a full resolution, 10-bit, compressed codec and supports RT Effects. Most compressed 
codecs are 8-bit which can sometimes lead to some color banding.

4.	 Click on the popup menu named Primary Scratch Disk and select your disk array from the 
popup menu. Then click OK

5.	 Final Cut Pro will appear.

Final Cut Pro.

“Easy Setup” options.

Third Party Applications
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Apple Final Cut Pro

Playback

As a quick test to make sure everything is connected correctly, use the Blackmagic test media (bars 
and tone) which can be found on the installer CD. Find a test clip which matches the format of your 
project, e.g. NTSC 8 bit, and copy it to your disk array. Import this clip into your Final Cut Pro project 
and drop it into the timeline. You should now see the image on both your computer desktop and 
your DeckLink output.

If you can’t see any video on your DeckLink output, check the connections again and ensure you 
have the correct output settings configured within Final Cut Pro by going to the View > Video 
Devices In the same menu, make sure “External Video” is set to “All Frames”.

Note: SDI, HDMI and analog outputs are always active with DeckLink, however the NTSC/PAL 
composite output will be disabled when running in high definition formats.

Capture

To capture, go to and choose File > Log & Capture. (Command + 8)

Your video deck will respond in the same way as a clip in the timeline, via the “<spacebar>”, “j”, 
“k” and “l” keys.

It is important to set the correct tape number for your clip as this will allow you to find the same 
frame off tape at any time in the future.

To immediately capture, click the Capture Now button. 

If you wish to log the clip, enter the desired “in” and “out” points using either the “i” and “o” keys 
on your keyboard, or manually by typing in the timecode and clicking Log Clip. If you have the 
“Prompt” checkbox selected, Final Cut Pro will now ask you to name the clip. Name it and click OK; 
the clip will appear in your browser with a diagonal red line indicating that it’s “offline”. Repeat this 
until you have logged all of the clips you wish to capture in a batch.

Note: When logging sequential clips from tape, Final Cut Pro will automatically suggest a name 
for each clip based on the previous clip. So, if your first clip is called “Mary, MCU”, Final Cut Pro 
will suggest the next clip be called “Mary, MCU 01” etc. This can make the logging large numbers 
of clips much faster.

Log and Capture.

Logging a clip.

Third Party Applications
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Apple Final Cut Pro

Batch Capture

Select the clips you wish to capture by drag selecting or shift-click. Go to and choose  
File > Batch Capture or click on the Batch button in the “Logging” tab of the “Log & Capture“ 
window. (Control + C)

To set handles on the clips, go to and choose File > Batch Capture (Control + C). Enable the 
“Add Handles” box to capture additional frames (“handles”) before and after the “In” and “Out” 
points of a clip.

RT Extreme Real Time Effects 

Real Time Effects are one of the great features of Final Cut Pro, and with your DeckLink you are fully 
compatible with Apple’s RT Extreme™. Be sure to select Effects Handling to Final Cut Pro Internal.

Recording to Tape

Once you have captured your clips, edited them and applied any effects, you will want to record the 
completed project to tape. One easy method is to go to and choose File > Print to Video  
If you want to perform precise insert and assemble edits onto a timecode striped tape, go to and 
choose File > Edit to Tape

Batch Capture.

Edit to Tape.

Third Party Applications
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Apple Final Cut Pro

Capture from non-controllable devices 
Video sources including AVCHD cameras, VHS tape players and security cameras do not provide 
any method of device control and are classified as non-controllable devices. For this reason, 
after selecting a Blackmagic Easy Setup, Final Cut Pro will sometimes warn that device control  
is set to “non-controllable device”. This is as expected. Click OK and then create a project with 
these settings.

To capture video from a non-controllable device, choose File > Log & Capture. (Command 
+ 8). Press play on your video source and then press the Now button in the Log and Capture 
window. Final Cut Pro will show you a preview of the video you are capturing. Press the ‘esc’ key 
at the top left of your keyboard when you wish to stop capturing. 

Configuring FireWire-controllable devices
DeckLink and Multibridge hardware include built-in RS-422 device control. If you are capturing 
from a deck or camera which does not support RS-422, you might be able to perform batch 
captures using FireWire device control. FireWire device control is provided by Final Cut Pro 
and is independent of Blackmagic hardware. No support is provided by Blackmagic Design 
for FireWire device control problems. Questions relating to FireWire device control should be 
referred to Final Cut Pro support and the relevant camera and deck vendors.

DV cameras include FireWire device control which can be enabled in the Audio/Video Settings 
> Device Control Presets of Final Cut Pro 6.0. Select a preset by clicking in the far left column 
so that a checkmark appears next to FireWire NTSC or FireWire PAL. Click OK . Open the 
“Log and Capture” window and you should now be able to control the tape in the DV camera via 
FireWire and capture video and audio via your DeckLink or Multibridge.

HDV cameras include FireWire device control. However Final Cut Pro 6.0 only enables the use 
of HDV FireWire device control when HDV video is being captured via FireWire. Fortunately 
the following method can be used to control most HDV cameras which support HDV>DV down 
conversion on their FireWire output. Set the HDV camera to output standard definition DV on its 
FireWire output. This can be achieved using the “i.LINK CONV” setting on Sony cameras and 
the “DV LOCKED” setting on the Canon HV20.

In Final Cut Pro, go to Audio/Video Settings > Device Control Presets. 
Select a preset by clicking in the far left column so that a checkmark appears 
next to the desired preset. Choose the FireWire NTSC preset if you are working  
in HD720p59.94 or HD1080i59.94 video. Choose the FireWire PAL preset if you are working  
in HD720p50 or HD1080i50 video. Click OK. Open the Log and Capture window and you should 
now be able to control the tape in the HDV camera via FireWire and capture video and audio via 
your DeckLink or Multibridge.

Log and Capture.

Logging a clip.
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Apple Final Cut Pro

The Sony HVR-M25U deck can be controlled and used with a DeckLink or Multibridge using the 
same instructions detailed above for HDV cameras.

Capture from FireWire-controllable devices
To capture, choose File > Log & Capture. (Command + 8) Your video deck or camera will 
respond in the same way as a clip in the timeline, via the “<spacebar>”, “j”, “k” and “l” keys. 
It is important to set the correct tape number for your clip. To immediately capture, click the 
Capture Now button. 

If you wish to log the clip, enter the desired “in” and “out” points using either the “i” and “o” 
keys on your keyboard, or manually by typing in the timecode and clicking Log Clip. If you have 
the “Prompt” checkbox selected, Final Cut Pro will now ask you to name the clip. Name it and 
click OK ; the clip will appear in your browser with a diagonal red line indicating that it’s “offline”.  
Repeat this until you have logged all of the clips you wish to capture in a batch. 

Note: When capturing sequential clips from tape, Final Cut Pro will automatically suggest a name 
for each clip based on the previous clip. So, if your first clip is called “Mary, MCU”, Final Cut Pro 
will suggest the next clip be called “Mary, MCU 01” etc. This can make logging large numbers  
of clips much faster.

Batch Capture 

Select the clips you wish to capture by drag selecting or shift-click. Choose File > Batch Capture  
or click on the Batch button in the “Logging” tab of the “Log & Capture“ window. (Control + C) 

To set handles on the clips, go to and choose File > Batch Capture (Control + C). Enable the  
“Add Handles” box to capture additional frames (“handles”) before and after the “In” and 
“Out” points of a clip.

Third Party Applications

Batch Capture.
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Adobe After Effects

It’s very easy to set up playback and rendering in Adobe After Effects™ for a complete broadcast 
and design workstation that connects direct to decks for capture and playback of clips. DeckLink 
also supports real time preview while working on your compositions. 

First, open Adobe After Effects and select the television standard frame size and frame rate you 
wish to work with.

How to use DeckLink as a preview output frame buffer

To allow your Adobe After Effects composition to be displayed in real-time from your DeckLink, 
go to Edit > Preferences > Video Preview. Select Blackmagic Video Output and 
the appropriate video standard. This lets you view your Adobe After Effects compositions in video 
colorspace on your broadcast monitor as you work. This means you will always see the correct color 
and interlace when working, and you don’t have to wait until your composition is rendered to see 
what it looks like when output as video.

Create a New Composition

Go to the “Composition” menu and select Composition > New Composition. (Command + n)  
In the dialogue box, select an appropriate television standard from the pulldown menu. Click OK

For NTSC 720 x 486, select lower field first��
For PAL 720 x 576, select upper field first for uncompressed video��
For PAL DV, select lower field first��
For HD 1080i select 1920 x 1080, select upper field first��
For HD 1080 PsF select 1920 x 1080, select No Fields��
For HD 720p select 1280 x 720, select No Fields��

Rendering

When you have completed your composition, you will need to render to a pixel format supported 
by DeckLink. Below is a list of supported codecs:

Blackmagic QuickTime�� ™ RGB (10 bit uncompressed)
Blackmagic QuickTime�� ™ (10 bit uncompressed)
Blackmagic QuickTime�� ™ (8 bit uncompressed)
Apple QuickTime�� ™ PhotoJPEG (compressed)
Apple QuickTime�� ™ DV - NTSC (compressed)
Apple QuickTime�� ™ DV - PAL (compressed)

Launching After Effects.

“Video Preview” preferences.

“Composition Settings” options.

Third Party Applications



31

Third Party Applications

Adobe Photoshop

DeckLink includes Adobe Photoshop™ plug-ins, so you can directly capture and output still frames 
from within the Photoshop application itself.

If you’re working with 10 bit HD/SD-SDI, you can even import and export 16 bit Photoshop images 
for full quality.

Import an image into Photoshop

1.	 From Photoshop select File > Import > Blackmagic Image Capture

2.	 Select the “Video Input Format” and the “Image Bit Depth” and select Capture Image

Export an image from Photoshop

1.	 Select File > Export > Blackmagic Image Export 

2.	 Select Video Output Format and then Output Image

Note: Once you have set the options in the “Import” or “Export” windows, each Import and Export 
after will not display the window, so you can grab and output frames much faster. However if you 
would like to change your import or export formats, hold the Option key, when selecting import 
or export.

Image Capture.

Image Export.

Third Party Applications
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Supported File Formats

Uncompressed data rates for capture and playback

The data rates for uncompressed video are quite high, and listed below are minimum recommended 
disk requirements for uncompressed standard definition and high definition video.

Uncompressed 10 bit YUV (4:2:2)

Standard Definition

Frame Size MB per second MB per minute GB per hour

720x486/29.97fps 27 1 600 94

720x576/25fps 26 1 582 93

High Definition

1280x720p/60fps 141 8 438 494

1920x1080/24PsF 127 7 594 445

1920x1080/50i 132 7 910 463

1920x1080/60i 158 9 482 556

Uncompressed 10 bit RGB (4:4:4)

High Definition

1280x720p/60fps 211 12 656 742

1920x1080/24PsF 190 11 391 667

1920x1080/50i 198 11 865 695

1920x1080/60i 237 14 238 834

Due to disk seeks, when calculating the data rates required for your disk system, it is a good idea 
to add a safety margin due to fluctuations in disk speed. Disk speeds can be increased by adding 
more disks.

Serial ATA (SATA) disks can reduce to half their speed as they become full, so in a 2-disk SATA array 
you should aim for a 100% safety margin. In an 8-disk SATA array, a 30% safety margin should be 
adequate. SCSI disk arrays seem to display less fluctuation and so a 20% safety margin should be 
adequate for an 8-disk SCSI array. Generally the more disks in the array, the better.

Note: Although other vendors and third parties may provide different data rates for uncompressed 
video, the above recommendations are tested for use with DeckLink.
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Troubleshooting Video Capture and Playback

Using your DeckLink as a capture and playback solution when connected to a computer is exciting, 
but also complex due to the huge range of different software applications. Video data rates are 
also very high, so the disk array you use for video storage can have a big impact on your system’s 
performance.

Information about a wide range of disk array solutions and compatible application software would 
be outside the scope of this manual, however there are three ways to get more information.

There are four steps to getting help.

1.	 Check out the Blackmagic Design website www.blackmagic-design.com/support for the latest 
support information. We have a huge number of technical notes covering all the common 
questions we are asked.

2.	 Call your reseller. Your reseller will have the latest technical updates from Blackmagic Design 
and should be able to give you immediate assistance. We also recommend you check out the 
support options your dealer offers as they can arrange various support plans based on your 
workflow requirements. Your reseller will also understand your disk array configuration, and as 
disk array problems account for around 90% of support questions with NLE systems, your reseller 
or disk array vendor will be able to provide expert help.

3.	 The next option is to email us with your questions using the web form at 
	 http://www.blackmagic-design.com/support/contact

4.	 Phone a Blackmagic Design support office. Please check our web site for current support phone 
numbers in your area. http://www.blackmagic-design.com/company/.

Note: Please provide us with as much information as possible regarding your technical problem and 
system specifications so that we may try to reproduce your problem quickly. Also please let us know 
how to reproduce any problem you’re having, so we can try it on our test systems before replying 
to your email.
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Connection Diagrams

Connection Diagrams

Connecting to a Betacam SP analog deck

This example shows DeckLink HD Extreme 2 connected to an analog deck for capture and playback 
to the deck. The HDMI and SDI outputs can be used for local monitoring.

2 3 4 5 6 7 8 9 10 11 12 13 14 15

2 3 4 5 6 7 8 9 10 11 12 13 14 15

DeckLink HD Extreme  

Professional Breakout Cable

Cards which can be used in this workflow

DeckLink SP

DeckLink SP PCIe

DeckLink Extreme

DeckLink Extreme PCIe

DeckLink HD Extreme

DeckLink HD Extreme 2
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Connection Diagrams

Connecting to an SDI digital deck

This example shows DeckLink HD Extreme 2 connected to a digital deck in 4:2:2 SD mode for 
capture and playback to the SDI deck. The HDMI, spare SDI and analog outputs can be used for 
local monitoring.

2 3 4 5 6 7 8 9 10 11 12 13 14 15

2 3 4 5 6 7 8 9 10 11 12 13 14 15

DeckLink HD Extreme  

Professional Breakout Cable

Cards which can be used in this workflow

DeckLink

DeckLink Pro

DeckLink Extreme

DeckLink Extreme PCIe

DeckLink HD Pro PCI-X

DeckLink HD Pro PCIe

DeckLink HD Extreme

DeckLink HD Extreme 2
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Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:2:2

This example shows DeckLink HD Extreme 2 connected to a Sony HDCAM SR™ series digital 
deck in 4:2:2 HD mode for capture and playback to the HD-SDI deck. The HDMI, spare SDI and 
component analog outputs can be used for local monitoring of 4:2:2 HD video.

2 3 4 5 6 7 8 9 10 11 12 13 14 15

2 3 4 5 6 7 8 9 10 11 12 13 14 15

DeckLink HD Extreme  

Professional Breakout Cable

Cards which can be used in this workflow

DeckLink HD Pro PCI-X

DeckLink HD Pro PCIe

DeckLink HD Extreme

DeckLink HD Extreme 2
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Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:2:2

This example shows DeckLink HD Pro PCIe connected to a Sony HDCAM SR™ series digital deck in 
4:2:2 HD mode. In this case, 2 HD-SDI connections are used for HD-SDI 4:2:2 video in and out. The 
component analog output can be used for local monitoring of 4:2:2 HD video.

DeckLink HD Pro 

Breakout Cable

Cards which can be used in this workflow

DeckLink HD Pro PCI-X

DeckLink HD Pro PCIe

DeckLink HD Extreme

DeckLink HD Extreme 2

2 3 4 5 6 7 8 9
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Connection Diagrams

Connecting to a Sony HDCAM SR deck in 4:4:4

This example shows DeckLink HD Pro PCIe connected to a Sony HDCAM SR™ series digital deck in 
4:4:4 HD mode. In this case, 4 HD-SDI connections are used for dual-link HD-SDI 4:4:4 video in and 
out. The component analog output can be used for local monitoring of 4:4:4 HD video.

DeckLink HD Pro 

Breakout Cable

Cards which can be used in this workflow

DeckLink HD Pro PCI-X

DeckLink HD Pro PCIe

2 3 4 5 6 7 8 9
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Connection Diagrams

Connecting to an NTSC/PAL monitor

This example shows DeckLink HD Extreme 2 connected to a standard definition Sony PVM monitor 
via composite analog video. Connect a BNC cable from DeckLink’s Y output cable to the composite 
analog video input of the Sony PVM monitor. You can use this for SD capture and playback monitoring 
with analog, SDI and HDMI video sources.

2 3 4 5 6 7 8 9 10 11 12 13 14 15

2 3 4 5 6 7 8 9 10 11 12 13 14 15

DeckLink HD Extreme  

Professional Breakout Cable

Cards which can be used in this workflow

DeckLink SP
DeckLink SP PCIe
DeckLink Pro
DeckLink Extreme
DeckLink Extreme PCIe
DeckLink HD Pro PCI-X
DeckLink HD Pro PCIe
DeckLink HD Extreme
DeckLink HD Extreme 2
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Connection Diagrams

Connection Diagrams

DeckLink HD Extreme 2 - connecting to S-Video

DeckLink HD Extreme  
Consumer Breakout Cable

3
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B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 

This example shows the DeckLink HD Exteme Consumer Breakout Cable connecting to S-video 
adapter cables. The Professional Breakout Cable can also be used with S-video adapter cables. The 
numbering on the cables is the same on both the Consumer and Professional Breakout Cables so 
it’s easy to use either cable.
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B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 

B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 
B-Y Input

Y Input

S-Video 

Connection Diagrams

DeckLink HD Extreme - connecting to S-Video

DeckLink HD Extreme  
Consumer Breakout Cable
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This example shows the DeckLink HD Exteme Consumer Breakout Cable connecting to S-video 
adapter cables. The Professional Breakout Cable can also be used with S-video adapter cables. The 
numbering on the cables is the same on both the Consumer and Professional Breakout Cables so 
it’s easy to use either cable.
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IN

OUT

IN

OUT

Connection Diagrams

Connecting to a YUV component monitor

This example shows DeckLink HD Extreme 2 connected to a multiformat Sony BVM monitor via 
component analog video. Connect three BNC cables from DeckLink’s Y, B-Y and R-Y output cables 
to the corresponding component analog inputs of the Sony BVM monitor. You can use this for SD 
or HD capture and playback monitoring with analog, SDI and HDMI video sources.
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2 3 4 5 6 7 8 9 10 11 12 13 14 15

DeckLink HD Extreme  

Professional Breakout Cable

Cards which can be used in this workflow

DeckLink SP
DeckLink SP PCIe
DeckLink Pro
DeckLink Extreme
DeckLink Extreme PCIe
DeckLink HD Pro PCI-X
DeckLink HD Pro PCIe
DeckLink HD Extreme
DeckLink HD Extreme 2
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AUDIO OUT

DIGITAL OUT
(OPTICAL)

AUDIO

VIDEO

S VIDEO

R

L

R

L
AUDIO

R

L

PR

PB

Y

L

R

IN

RGB

PC IN
AUDIO

HDMI
IN AUDIO

CONTROLS

VIDEO IN HD/DVD IN
IN OUT

HDTV with HDMI

Connection Diagrams

Connecting to an HDTV

This example shows DeckLink HD Extreme 2 connected to a consumer HDTV via HDMI. Connect a 
HDMI cable from DeckLink’s HDMI output to the HDMI input of the HDTV. You can use this for SD 
or HD capture and playback monitoring of analog, SDI and HDMI video sources.

2 3 4 5 6 7 8 9 10 11 12 13 14 152 3 4 5 6 7 8 9 10 11 12 13 14 15

Cards which can be used in this workflow

DeckLink HD Extreme 2
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Connection Diagrams

HDTV

Camera Outputs

Connection Diagrams

HDMI Workflow

DeckLink HD Extreme 2 can use HDMI for connecting video cameras, televisions and projectors 
to your computer for use with popular editing and design applications. DeckLink HD Extreme 2 
captures video in real-time directly from the HDMI output on HDV cameras, and will play back 
directly to large screen HDTVs or HD projectors for client-monitoring and editing.

Cards which can be used in this workflow

DeckLink HD Extreme 2
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NTSC/PAL

NTSC/PAL

4:3

16:9
Desktop

High Definition Desktop

1080i
720p

Connection Diagrams

DeckLink HD Extreme 2 - monitoring via HDMI
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Connection Diagrams

30 inch

2K-SDI video 
3 Gb/s 4:4:4

Dual link DVI-D connection 
direct to LCD monitor

Connection Diagrams

DeckLink HD Extreme 2 - 2K Monitoring with HDLink Pro
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Connection Diagrams

Connection Diagrams

DeckLink HD Extreme 2 and Professional Breakout Cable
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DeckLink HD Extreme  

Professional Breakout Cable

2
3

4
5

6
7

8
9

10
11

12
13

14
15

2

3

4

5

6

7

8

9

10

11

12

13

14

15

2.	 Deck Control

3.	 R-Y Out

2K/HD/SD-SDI Monitoring Output

2K/HD/SD-SDI Output (to deck)

2K/HD/SD-SDI Input (from deck)

HDMI Output

HDMI Input

4.	 Y Out

5.	 B-Y Out

6.	 Ref In

7.	 R-Y In

8.	 Y In

9.	 B-Y In

10.	 AES/EBU Out

11.	 AES/EBU In

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Connection Diagrams

Connection Diagrams

DeckLink HD Extreme 2 and Consumer Breakout Cable
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3.	 R-Y Out

2K/HD/SD-SDI Monitoring Output

2K/HD/SD-SDI Output (to deck)

2K/HD/SD-SDI Input (from deck)

HDMI Output

HDMI Input

4.	 Y Out

5.	 B-Y Out

7.	 R-Y In

8.	 Y In

9.	 B-Y In

10.	 AES/EBU Out

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Connection Diagrams

DeckLink HD Extreme and Professional Breakout Cable
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2.	 Deck Control

3.	 R-Y Out

HD/SD-SDI Monitoring Output

HD/SD-SDI Output (to deck)

HD/SD-SDI Input (from deck)

4.	 Y Out

5.	 B-Y Out

6.	 Ref In

7.	 R-Y In

8.	 Y In

9.	 B-Y In

10.	 AES/EBU Out

11.	 AES/EBU In

12.	 Audio Out Left

13.	 Audio Out Right

14.	 Audio In Left

15.	 Audio In Right

The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Connection Diagrams

DeckLink HD Extreme and Consumer Breakout Cable
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3.	 R-Y Out

HD/SD-SDI Monitoring Output

HD/SD-SDI Output (to deck)

HD/SD-SDI Input (from deck)

4.	 Y Out

5.	 B-Y Out

7.	 R-Y In

8.	 Y In
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14.	 Audio In Left

15.	 Audio In Right
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The cable numbering is the same on both the Professional and Consumer Breakout Cables so it’s 
easy to use either cable. For example, component video output uses cables 3, 4 and 5 on both 
breakout cables.
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Connection Diagrams

DeckLink HD Pro PCIe

2.	 Deck Control

HD/SD-SDI Monitoring Output Ch A 

HD/SD-SDI Output (to deck) Ch B 

HD-SDI Input for 4:4:4 Ch B

HD/SD-SDI Input (from deck) Ch A

3.	 R-Y/R Monitor Out

4.	 Y/G Monitor Out

5.	 B-Y/B Monitor Out

6.	 Ref In

7.	 SPDIF/AES Out

8	 SPDIF/AES In

9.	 Wordclock Out
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DeckLink HD Pro Breakout Cable
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Connection Diagrams

DeckLink HD Pro PCI-X
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2.	 Deck Control

HD/SD-SDI Monitoring Output Ch A

HD/SD-SDI Output (to deck) Ch B

HD-SDI Input for 4:4:4 Ch B

HD/SD-SDI Input (from deck) Ch A

3.	 R-Y/R Monitor Out

4.	 Y/G Monitor Out

5.	 B-Y/B Monitor Out

6.	 Ref In

7.	 SPDIF/AES Out

8.	 SPDIF/AES In

9.	 Wordclock Out

DeckLink HD Pro Breakout Cable
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Connection Diagrams

DeckLink Extreme
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2.	 AES-S/PDIF Output
	 (monitoring)

3.	 (L) Audio Output 
	 (balanced analog)

6. 	 (R) Audio Input 
	 (balanced analog)

9. 	 R-Y Input
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DeckLink Extreme  
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16
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2. 	 AES-S/PDIF Output
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3. 	 (L) Audio Output 
	 (balanced analog)

6. 	 (R) Audio Input 
	 (balanced analog)

9. 	 R-Y Input

4. 	 (R) Audio Output 
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15. 	SD-SDI Input

DeckLink Extreme  

Breakout Cable

Connection Diagrams

DeckLink Extreme PCIe

16. 	Deck Control RS-422
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15.	 Deck Control RS-422

Connection Diagrams
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Connection Diagrams

DeckLink SP PCIe
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Connection Diagrams

DeckLink Pro

7ft break-out cable
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	 (Monitoring)
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SD-SDI Input 

Connection Diagrams

DeckLink
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Developer Information

Blackmagic 2K Format

The latest Blackmagic Design products use the new 3 Gb/s SDI video, which allows twice the data 
rate of traditional HD-SDI video. We thought it would be a really nice idea to add 2K film support, via 
this new 3 Gb/s SDI technology, so we could simplify feature film workflows. With the popularity of 
Blackmagic Design editing systems worldwide, now thousands of people can benefit from a feature 
film workflow revolution.

This information includes everything product developers need to know for building native 2K SDI 
equipment. Of course, all Blackmagic products can be updated, so if the television industry adopts an 
alternative SDI-based film standard, we can add support for that too!

Frame Structure

Transmitted at 23.98 or 24 frames per second as a Progressive Segmented Frame. ��
Active video is 2048 pixels wide by 1556 lines deep. ��
Total lines per frame : 1650��
Words per active line. One word consists of a sample on both data streams: ��
3072 (2048*3/2). See following page.
Total active lines : 1556��
Words per total line : 3750.��
Fields per frame : 2, 825 lines each��
Active lines located on lines 16-793 (field 1) and 841-1618 (field 2).��

Transport Structure

Based on SMPTE S425M mapping structure 2.��

Timing reference signals, line number and line CRC insertion is the same as above.��

Optional ancillary data is inserted into both virtual interfaces.��

At present, only audio data is included: as per standard HD audio insertion (SMPTE S299M) the audio ��
data packets are carried on data stream two and audio control packets are carried on data stream one.

During active video, 10-bit Red, Green and Blue data is sent in the following sequence:��

	 Data stream1: Green_1, Red_1, Green_2, Green_3, Red_3, Green_4,…,Green_n-1, Red_n-1, Green_n.

	 Data stream 2: Blue_1, Red_2, Blue_2, Blue_3, Red_4, Blue_4, …,Blue_n-1, Red_n, Blue_n.

Diagrams on the following page show the vertical timing details with line numbers and Field, Vertical and 
Horizontal bits for the Timing Reference Signal codes. 

Final diagram shows the data stream formats around the optional ancillary data section of the horizontal 
line. Note that each active pixel takes up three samples.
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Warranty

3 Year Limited Warranty

Blackmagic Design warrants that this product will be free from defects in materials and workmanship 
for a period of 36 months from the date of purchase. If a product proves to be defective during this 
warranty period, Blackmagic Design, at its option, either will repair the defective product without 
charge for parts and labor, or will provide a replacement in exchange for the defective product. 

In order to obtain service under this warranty, you the Customer, must notify Blackmagic Design 
of the defect before the expiration of the warranty period and make suitable arrangements for 
the performance of service. The Customer shall be responsible for packaging and shipping the 
defective product to a designated service center nominated by Blackmagic Design, with shipping 
charges pre paid. Customer shall be responsible for paying all shipping changes, insurance, duties, 
taxes, and any other charges for products returned to us for any reason. 

This warranty shall not apply to any defect, failure or damage caused by improper use or improper 
or inadequate maintenance and care. Blackmagic Design shall not be obligated to furnish service 
under this warranty: a) to repair damage resulting from attempts by personal other than Blackmagic 
Design representatives to install, repair or service the product, b) to repair damage resulting from 
improper use or connection to incompatible equipment, c) to repair any damage or malfunction 
caused by the use of non Blackmagic Design parts or supplies, or d) to service a product that has 
been modified or integrated with other products when the effect of such a modification or integration 
increases the time or difficulty of servicing the product. THIS WARRANTY IS GIVEN BY BLACKMAGIC 
DESIGN IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR IMPLIED. BLACKMAGIC DESIGN 
AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE. BLACKMAGIC DESIGN’S RESPONSIBILITY TO REPAIR OR 
REPLACE DEFECTIVE PRODUCTS IS THE WHOLE AND EXCLUSIVE REMEDY PROVIDED TO 
THE CUSTOMER FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES 
IRRESPECTIVE OF WETHER BLACKMAGIC DESIGN OR THE VENDOR HAS ADVANCE NOTICE 
OF THE POSSIBILITY OF SUCH DAMAGES. BLACKMAGIC DESIGN IS NOT LIABLE FOR 
ANY ILLEGAL USE OF EQUIPMENT BY CUSTOMER. BLACKMAGIC IS NOT LIABLE FOR ANY 
DAMAGES RESULTING FROM USE OF THIS  PRODUCT. USER OPERATES THIS PRODUCT AT 
OWN RISK. 

Copyright 2008 Blackmagic Design. All rights reserved. ‘Blackmagic Design’, ‘DeckLink’, ‘HDLink’, 
‘Workgroup Videohub’, ‘ Videohub’, ‘DeckLink’, ‘Intensity’ and ‘Leading the creative video 
revolution’ are registered trademarks in the US and other countries. All other company and product 
names may be trade marks of their respective companies with which they are associated.
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