LyricX
User Guide

Version 4.6

© CHYRON-HEGO



Table of Contents

Table of Contents

Introduction/Overview
Related Documents

Getting Started
Setting Up
Creating Scenes

Animating in LyricX

About Transitions

Saving, Recalling and Playing Scenes
Using Data in Lyric

Scripting in Lyric

Docking Panes

Project Folder (Directory)
Canvas

Transitions

Playout - Read, Record and Play

View Menu
Workspaces
Toolbars
Alternate Canvas
Auto Follow

Auto Follow Diagnostics
Auto Hide

Auto Spacing

Browsers

Conditional Transitions
Console

Effects

Event Properties
Font Style Properties
General Properties
Hotspots

Keyframe Graph
Macros

Masking

Metrics

Parameters List

Playlist

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/

LyricX 4.6 User Guide
Page 2


http://chyronhego.com/

Playout Panel
Rendering
Scene Assets

Scene Graph
Scene Properties

Scene Tree

Status Bar
Surface Properties
Template Update
Timeline Editor
Transform

Update Ordering

Virtual Output
Undo and Redo List

Configuration Menu
Save/lLoad Settings
Input/Output Devices
Canvas and Channel Settings
Preferences
Safe Title Adjust
Default Effect
Automation
Intelligent Interface
External Connection Manager
Global GPIs
License Code
Enable Modal Suppressor
Logger
Reset Keyboard
Keyboard Codes
Keyboard/Mouse Shortcuts
Clone Canvas

Edit Menu
Group/Ungroup

File Menu
Backup
Restore
Message Info
Save As
Save With Options

Help Menu

Tools Menu

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/

LyricX 4.6 User Guide
Page 3


http://chyronhego.com/

LyricX 4.6 User Guide
Page 4

2D Text
3D Text

3D Object
3D Object Primitive

Video Object
Image

Media/Movies

Flipbook

Data Object
Trigger Track
Lights

Camera

3DO

FBX Import
Color Palette
Internal Properties
DB Linking
XMP Metadata

Scripting
Pre-Process Data Scripting

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 5

Introduction/Overview

Lyric is ChyronHego’s world-leading graphics and playout platform. Its flexibility, ease of
use and speed makes Lyric paramount to every aspect of broadcasting graphics.

As a fully featured application, Lyric caters to both designers and operators by providing a
seamless workflow between design and playout.

Lyric's extensive feature set includes a Data Object that allows for integration with an
extensive range of data sources, scriptless logic for sophisticated Scene to Scene
interaction, and a powerful API that yields complete control.

For more information or inquiries, please visit www.chyronhego.com or contact customer
support at +1-631-845-2132 (Americas, Asia) +44-208-8679-055 (Europe, Middle East,
Africa).

Related Documents

This guide contains the software functions within Lyric, the Data Object guide is included as
a separate document in the Lyric Start Menu folder. For Hardware setup configuration
please refer to the hardware documentation that will be included with the system. The Leif
(Lyric’s API) Help guide can be accessed from the Help menu.

Getting Started
Setting Up

The Docking Panes interface allows for flexible layouts within Lyric, which enables users to
set up their workspace as they see fit. Panels can dock alone, float, tab, or be pinned.
For more details see Docking Panes.

Customizing the Interface for Different Workflows - Workspaces
Workspaces are screen layouts that can be saved and recalled. Found under View >
Workspaces, Lyric comes with default workspaces that can be modified and saved. Users
can create new, import, and delete screen layouts.

[View| Config Tools Help

Waorkspaces 4 MNew Workspace
Toolbars » Design
Browsers » Lyric Pro
Playout
v | Scene Properties
v Scene Graph B Save Workspace
v | Scene Tree Fa Delete Workspace
Impert Workspace
¥ Timeline Editor

Hide Disabled Panes

¥ Transition Properties

The generated workspaces files are located in C:\ChyronHego\Lyric\Workspace.

See View > Workspaces for more details.
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Creating or changing Projects

A Project Folder, or Directory, is the hierarchical Windows folder structure that contains all
elements related to a project.

Any show or “look” should be organized within a project folder to ensure that it can be
moved between devices in a simple fashion.

There are recommended Windows file structures for use with Lyric, however these are
loose guides and can be adjusted to suit production needs.

Creating and selecting Projects is done via Config > Preferences > Project Folder or by

. . Project Folder . .
selecting the Project folder button —J (View > Toolbars > Project Tools)

| CG Preferences I Interface I Impart /Export I Language‘ Project Folder |Tima|ine I Diagnoshcx|

| Select or Create Project Folder |

Asset Type Default Path

Messages IProject Folder'Messages
[ Templates I\Project Folder Templates
Images IProject Foldermages
Playlists IProject FolderPlaylists
Effects IProject Folder'Effects
Clip Files I\Project Folder'Clip Files
3D Objects 1"Project Folder'3D Objects
Movies 1*\Project Folder\Movies
Forts I*\Project Folder\Forts

« [ m

[¥]{8iways Browse To Spectied Pathi

The Project Folder sets the default folder location for all asset types, which means when an
asset type is recalled it will open from that file path. Additionally, when a file is saved it will
offer to save to the default path. a

Saving and loading settings

Application settings (such as Canvas and Channel Settings, intelligent interface,
preferences, etc.) can be saved to and loaded from a file.

- A
Save Settings M

[7] Application Settings

File Name:

I:\Project Folder\Operator . xml

————————
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Settings are saved and accessed via Config > Save Settings and Config > Load Settings.

Creating Scenes

A Lyric scene (.lyr), also referred to as a composition or message, is a compilation of all
graphic elements added to the Canvas. All elements are listed and accessed in the Scene
Graph. Elements are animated in the Timeline. Scenes can also include multiple
animations (Transitions). Lyric Scenes are played in real time to the output of a Lyric
device.

To create a new scene, clear the current canvas (Ctrl+Q) or go to File > New Scene

=

(Ctrl+N) or click the New Scene button (View > Toolbars > Windows Tools)

See Canvas and Channel Settings to set the screen resolution and Canvas for panning,
zooming and selecting.

Importing Elements Into a Scene

To add elements to the scene, go to the Tools menu and Scene Tools toolbar icons (View >
Toolbars > Scene Tools).

Oun
File Edit View Config [Tools| Help
3D Object b
Text k

Image

Media
Flipbook
Data Object
Trigger Track

Group Ctrl+G
Ungroup Ctrl+U

Video Capture

AR OB EEY 0 I

All elements added to the Lyric Canvas are displayed on the Scene Graph. The General
Pane (View Menu > General Properties) displays contextual Properties for each element
added to a composition.

Adding Text to a Scene

Text is added by selecting Tools > Text and choosing from the available options,
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) -
File Edit View Config l Tools | Help
3D Object v |
Text k 3D Text
Irage 2D Text Window
Media 2D Text Ternplate
Flipbook 20 Text Crawl
Data Object 2D Text Roll
Trigger Track 2D Text Type On
Group Ctrl+G 2B em Clock
Ungroup Ctrl+L 2D Teel Tt
or by clicking al from the Scene Objects and choosing from the available options.

For details on Creating 2D text (including templates) see 2D Text.

For details on Creating 3D text templates see 3D Text.

All Text and Template properties are adjusted via the General Pane (View > General
Properties). A template must be selected to view the General Properties.

Moving and Manipulating Objects

An element's opacity, position, rotation and scale on Lyric’s three dimensional canvas is
adjusted using Transform Properties via View Menu > Transform Properties, on the
Timeline, or directly on the canvas using the transform tools.

Updating and editing replaceable elements

Text, objects, and keyframes can be updated quickly via the Template Update Tool, which
can be accessed using the keyboard shortcut Alt + T. This tool is ideally used for frequently
replaced elements. Updatable items include text, images, movies, imported 3d objects, 3d
object textures, and keyframes.

Enabling an item for Template Update

Setting an object as updateable by Template Update is done via View>Update Ordering.
Keyframes values are enabled for Template Update by right clicking the keyframed attribute
on the timeline track and selecting Data Binding > Updateable. See Timeline, Databinding
Keyframes for more details

Animating in Lyric
Elements are animated in Lyric using the timeline. The keyframe graph is a different view of

the timeline that can be used to create splines. Relevant topics for more details are Timeline
Editor, Keyframe Modes, Interpolation Modes, Keyframe Graph and Inherit State.
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About Transitions

Transitions are individual animation timelines within a scene. They are used to create
different animations to be played back at different times. Intelligent Transitions (Effect
In/Out and Update In/Out) are pre-defined transitions with logic built into them for seamless
interaction between scenes that are played back to back.

Conditional Transitions take Intelligent transitions one step further by allowing the user to
create a list of rules that determine which transitions will execute when set conditions are
met.

More information can be found in Transitions.

Saving, Recalling and Playing Scenes

Saving

Scenes or Messages can be saved numerically using the numeric keypad (Num Lock must
be enabled). The Message Number that will be saved to is displayed via View > Toolbars >
Message Number.

500
Save a Lyric message: Type in a number using the numeric keypad and hit the Record

Key (ChyronHego Keyboard) or the Minus Key (-) (PC Keyboard). The message saves to
the set Default Messages folder and the status bar displays the file operation and details.

Messages can also be saved as a file name (alphanumeric) See Read, Record and Play.
See also details on Template Data Messages and embedding macros.

Reading/Opening

Recalling messages is often referred to as reading a message.

Using the number pad, type the number and hit the Enter Key on the numeric keypad. The
message is read to the canvas. Messages can also be read from the File Menu>Open
Playing

Play a message: A Lyric message can be played by hitting Ctrl + Play (ChyronHego
Keyboard) or Ctrl + Alt + Page Up (PC Keyboard) Or via the Playout Pane found in View >
Playout Panel.
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Using Data in Lyric
Integrating data into Lyric can be achieved several ways:

e The Data Object is a data binding tool comprising multiple data source formats.
Additionally, the Data Object can trigger Actions, either when data Events occur
(e.g. End of Data) or at Data Binding keyframes.

DB linking allows for binding to ODBC data sources.
XMP can be used be used as a data source. XMP from .jpeg and .tif image formats
are supported. Validation rules can also be added to allow or deny update.

e |Intelligent Interface protocol allows users to control the update and display of
graphics and text through an ASCII-based command set transmitted over a serial
port or network connection.

e Parameters are global or scene based values that can be used/accessed by the
Data Object, Intelligent Interface, macro script or an external application via LEIF
commands.

Scripting in LyricX

Lyric’s scripting language is VBScript. Macros can be inserted and auto-run in Lyric
messages (using a variety of methods) or executed manually by the operator. The API to
Lyric is LEIF (Lyric Extended Interface Framework). LEIF is used to create external
applications to control Lyric. The LEIF Help file can be accessed from the Lyric Help Menu >
LEIF Documentation or opened directly from inside the Program Folder in which Lyric is
installed. If using Windows 7 you will need to run the update that appears as an error. The
software development kit can be requested by contacting ChyronHego
(http://chyronhego.com/broadcast-graphics/lyric-sdk)

e Macro Pane (View > Macros) This is where macros can be written and tested as
well as executed. Macros can be saved into the application directory, or as .lyr files
or can be assigned to a hotkey or accessed by messages.

e Embedded Macros Macros can be embedded within a scene and execute when the
message is read. See Save with Options / Record Only for details on embedding
macros. Embedded Macros can also execute when the Template Update dialog if
updated if the execute macro button is enabled.

e Keyframe Macros Macro scripts can be triggered as part of the Timeline via
keyframed Actions added to Trigger Tracks

e Pre-Process Scripts are scripts that are attached directly to nodes (Text, Images
and Media) and execute on Update.

e Intelligent Interface Intelligent Interface E commands containing macros can be
transmitted over a serial port or network connection to Lyric using an ASCII-based
command set.

e Sendkeys are Ul keystrokes that can be used in macros.
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Docking Panes

Panes can be positioned anywhere in the user interface providing a completely
customizable working area. All panes are found in the View menu. Panels can dock alone,
float, tab or be pinned. The Canvas is considered special and cannot be docked with any
other panes or hidden.

As the panes are moved, highlighted drop zones appear.

)=
L E —
For example, users can move a pane into a drop zone area. If a panel is dragged to an

area that is not a drop zone, the panel floats freely in the workspace.

Playout =)
XFER e -I FB 2 |

Frame Buffer 1

Untitled

Transitions for Untitled
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Toolbars can be embedded in many of the dockable panes, both horizontally and vertically.
Simply arrange before docking.

al dw T8 E

- Y 0 =3

Ol amogepumy o 3
L e s
=

B B

Y99 3

0

I5 |

Hide Disabled Pane Mode

This option is found in View > Workspace > Hide Disabled Panes.

There are two modes for displaying panes: Always show all open panes or Hide
Disabled Pane. The latter will only offer the panes applicable to the selected Object and
reduces clutter within the interface. For example, the global light cannot be moved and
does not have a surface, and therefore neither Transform nor Surface panes are available.

Navigating Panes

To help with locating panes and toolbars, there is an option to highlight the location of a
panel with a border when hovered. The option is found in Config > Preferences >
Interface > Highlight Pane on Hover.

Wiew Menu

Highlight Pane on Hover

Highlights location of pane in the Ul when selected in the View menu l
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Below, Rendering Properties is selected in the menu and the bottom right pane has a purple

highlighted edge.

Browsers »
V| Scene Properties

V| Scene Graph B
¥ | SceneTree ]
¥ | Timeline Editor

Transition Properties

General Properties
Transform Properties
Surface Properties
Rendering Properties
Timeline Track Properties
v | Events Properties

v | Font Style Properties

¥ | Alternate Canvas

Auto Follow

Auto Hide
Auto Spacing
Conditional Transition
v | Effects
Hotspots
Keyframe Graph
Masking

<

Macros | Keyframe Graph | Playlist | Parameters
Macros

Parameters List

4T > i MW M coo0oasz)

g

<fiter transition>

o1:00 0200

Playlist
o

IR

Playout Panel Countries

Template Update Alt=T

Update Ordering 5
v | Virtual Output i
Iy mgneT T
1)} Global Light i

fnigeria

B o

G+ "ORESWOW YT WY W W UYWL ae)
File Edit [View] Config Tools Help i
E) Workspaces » | o e ED il e 7] a8 B PR |
Tl b A -Eicbs_sports_mosaic\Messages Frame Buffer 1 2

Virtual Output | Alternate Canvas | Surface | < ¥

2
Transform | £ 4 ¥

General

General | Font Siyle | Effeds

3D Object > peru
4Node Info
MNode Name peru

Description

4File Path

]

[T Maintain surfaces on replace
fFile Info

Embed

Triangles 515

Size onDisk 7956 KB

4Geometry

Smoothing 15000 |5

4Data

DElinking

For Help, press F1
-

Version: 1.0 3060

ML WS = 1.053 Y100

In the View menu (illustrated above), right clicking on Rendering Properties sets the focus
on Rendering Properties in the tabbed group.

Accessing Panes via shortcut

Using macros, panes can be accessed using hotkeys. For example the script code will give

focus to the panes:

ActivateFrame "General"
ActivateFrame "Transform"

Where the text in quotes is the name of the pane.
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Project Folder (Directory)

A Project Folder, or Directory, is the hierarchical Windows folder structure that should
contain all elements related to a project.

They are recommended Windows file structures for use with Lyric, however they are loose
guides and can be adjusted to suit production needs.

Creating a Project Folder

. Froject Folder .
1. Click the Toolbar shortcut, Project Folder button (View > Toolbars
> Project Tools) or access the same menu via Config > Preferences > Project

Folder.

|CG Preferences | Interface | Import/ Export | Language| Project Folder |Tu‘neline I Diagnostics|

E Select or Create Project Folder i

Asset Type  Default Path

Mezsages |:\Project Folder'\Messages
[ Templat... I:\Project Folder\Templates
Images I\Project Folder\mages
Playlists  |\Project Folder.Playlists
Effects |\Project Folder'\Effects
Clip Files  |\Project Folder'Clip Files
30 Obje... |\Project Folder\3D Cbjects
Movies |\Project Folder'\Movies
Fonts |:\Project Folder'\Fonts

[¥] Aways Browse To Specified Path

2. Click the Select or Create Project Folder button
3. Create a Windows Folder. This folder is the root folder created to contain all of the
element subfolders.
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Below a Folder named “Project Folder” has been created.

O smamcor NN

- @& m-

Recent Places

||

| Desktop

&

Libraries

iy

Computer

4. Double Click the desired Root Folder or Select and hit OK

CEST=TEE ]
Roo > (R Y-t

Mo items match your search,

Libraries

Iy

Computer
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5. Once opened, click OK. The desired project folder MUST be opened in order for
subfolders to be created within it. Default Lyric Subfolders are created. Click Yes to
each prompt to create all desired subfolders.

[ Create this directory? I‘L M

@ I\Project Folder\Messages

Ves | No || Cancel |

P ———
6. The Project Folder, containing all subfolders, is created. This becomes the default
path for all asset types.

| CG Preferences | Interface | Import/Export | Language | Project Folder | Timeline | Diagnostics |

| Sselect or Create Project Folder |

Asset Type Default Path

Messages I\Project Folder\Messages
Templates 1\Project Folder' Templates
Images I\Project Folder\Images
Flaylists I\Project Folder'\Flaylists
Effects I\Project Folder\Effects
Clip Files 1\Project FolderClip Files
30 Objects I\Project Folder’ 30 Objects
Maovies I*\Project Folder\Movies
Fonts I\Project FolderFants

4 i

[]iAlways Browse To Specified Pathi

Default Folder Paths for any Asset Type are changed by double clicking the Default Path
and browsing to a new location.
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Always Browse To Specified Path - when enabled, this function ensures that Lyric will
open the default file path set. When disabled (unchecked) Lyric opens the most recently
accessed file location.

lllustrated below is the project folder, and subfolder, in Windows Explorer.

eSS ===
=

= . v Computer » Local Disk () » Pro}ectFoFder 3 - | | Search Project Folder yel

File _I__Edil View Tools ﬂelp

Organize » Include in library = Share with » Burn Mew folder == .Eﬂ ® I
ok Favorites e MName @ Date modified Type Size '

M Desktop . 3D Objects 11/10/2016 3:27 PM  File folder

%% Dropbox Ju Clip Files 11/10/2016 3:27 PM  File folder

‘i-'-ﬂ_ Recent Places . Effects 11/10/2016 3:27 PM  File folder

L Screencaps . Fonts 11/10/2016 3:27 PM  File folder

& Downloads 1/ Images 11/10/2016 3:27 PM  File folder

1. My Skype Received Files ). Messages 11/10/2016 3:27 PM  File folder

1/ Movies 11/10/2016 3:27 PM  File folder

B Desktop . Playlists 11/10/2016 3:27 PM  File folder

il Libraries . Templates 11/10/2016 3:27 PM  File folder

@ Documents -
9 items
!

Additional Folders can be created to hold User Settings, Databases, Lyric Backups, Custom
Lyric Nodes, Macros, etc.
The default Project Folder appears on the Canvas.

FB1 - 2 Line_Lower Third - L'Project Folder\Messages

All messages are saved and opened at this location by default.
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To Select a Project Folder

Project Folder |
1. Click the Toolbar shortcut Project Folder button (View > Toolbars >
Project Tools) or access the same menu via Config > Preferences > Project Folder.

e =

| CG Preferences | Interface | Import/Export | Language | Project Folder | Timeline | Diagnostics |

E Select or Create Project Folder 1

Aaset Type  Default Path

Meszages |\Project Folder'Messages
[] Templat... I:\Project Folder\Templates
Images I*\Project Folder\Images
Playlist=  |\Project Folder\Playlists
Effects I\Project Folder\Effects
Clip Fles  1'\Project Folder\Clip Files
30 Obje... I\Project Folder’\30 Objects
Mavies I\Project Folders\Movies
Forts I*\Project Folder\Forts

Always Browse To Specified Path

2. Click the Select or Create Project Folder button

3. Navigate the desired folder, click OK to open and OK to exit.

4. Once the Project Folder has been created and set as the default, users can save
the project folder settings for fast recall. See details in Save Settings.
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Canvas

Lyric's Canvas is the 3D space in which all composition and animation takes place. The
composition is seen through the Camera lens.

Create a New Scene

A new scene is created via File > New Scene (Ctrl + N), or by clicking the button - on
the Toolbar. Hold shift while opening the new Scene to keep any existing open Scenes.
Alternatively, a scene can be erased (Ctrl + Q), which leaves Lyric with a blank canvas
ready for a new composition.

The canvas, when empty, always contains: a Camera, A Global Light source and one
movable Light. When objects are added to the Canvas, they appear in a list on the Scene

Graph.

Scene Graph @

MName bt ,7
. “: 3.’
/ Global Light
L |8y Cameral

Canvas and Channel Settings

Canvas and Channel Settings settings DO NOT affect the signal being produced by your
system's frame buffer boards. These settings only configure the Canvas resolution for
composition of Lyric messages. Setting the broadcast format of your system's outputs is
accomplished in Lyric's Configuration menu.

To configure the canvas resolution see Config > Canvas and Channel Settings.

Alternate Canvas

Alternative Canvas allows for an additional canvas' to be opened to correspond to external
Frame Buffers that may be available.

Panning and Zooming on the Canvas

The view of the canvas is controlled via the scroll wheel on the mouse. Zooming is
performed by scrolling forward and back. Panning is controlled by holding the middle
mouse button down while moving the mouse in all directions.

The Reset Zoom button on the Scene Settings (View > Toolbars > Canvas Settings)

F.A
"

indicates when a zoom or pan has been performed by turning red. . Click to reset.
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Selecting Objects on the Canvas

Lyric objects can be selected via the canvas. To do so, simply click and drag around the
object you wish to select. When you release, all items inside the lassoed area will be
selected.

Line one of text
Line two of text

Line three of text
Line four of text

Selecting Overlapping Objects on the Canvas (ALT + Click)

When canvas objects overlap, it may be difficult to select the one you wish to work with
through lassoing. An alternative method is to position your cursor over the overlapping
objects, and hold down the ALT key while clicking with the mouse. Each item under the
mouse will be selected. Continue clicking until the Scene Graph and Timeline indicate that
the desired object has been selected.
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Transitions

Standard Transitions
e Default - Basic timeline view of all objects on the Canvas. New messages contain

only the Default transition, and have no Intelligent Transitions until added by the
user. The Default is always playing in any scene along with any triggered transition.
As object timelines exist inside the Default transition, as well as other transitions,
the Default animations for that object is always overridden by the currently triggered
transition. When an Update In/Out occurs, any looping animation is seamlessly
matched between the two messages.

Intelligent Transitions

Intelligent Transitions allow intelligent message interaction between graphics on a single
frame buffer. Specific transitions (Effect In, Effect Out, Update In and Update Out) are
automatically executed when played to output via Lyric's native logic. Messages can be
played in any order, and when using the Intelligent Transition logic the message will perform
the appropriate transition based on what is active on output.

Adding an Intelligent Transition to the Lyric Timeline
Click the Add Transition button and selected the desired transition from the dropdown.

_'ﬁmeﬁne

|| Defauit | IETIERET | i,

Effect In
Show Al Eeact Out
Update In
Update Cut X

When a Transition is added to the scene, a new tab is added to the Timeline and Playout
Pane.

Types of Intelligent Transitions

e Effect In - Executes when the message is first played to output, where no message
exists on output with the same name as defined by the Scene Properties Pane >
Name field.

e Effect Out - Animates the on air message off output when a new message, with a
different scene name, is played to the same output. Persistence impacts Effect Out
behavior, further details below.

e Update In/Update Out - These transitions are triggered when the incoming
message and outgoing message have the same scene name. This allows for a
different animation on an update of the same type of graphic. The scene on the
output runs the Update Out while the scene on canvas runs its Update In animation.
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Any message with Intelligent Transitions could perform any of the transitions at any given
time and are completely nonlinear.

For instance: A message named 'Lowerthird' played to an output that does not contain a
message named 'Lowerthird' will execute its Effect In. If another message named
'Lowerthird' is played (this is typically the same message played again with different
content), the Update transitions are executed. When a message that is not named
'‘Lowerthird' is played, the 'Lowerthird' will execute its Effect Out transition and be removed
from the output.

Persistence and Effect Out

Messages can be configured to be persistent (see Scene Properties), meaning they will
remain on the output as other messages (with different names) are sent to the same output.
The result is multiple messages on a single output frame buffer. Persistent messages can
be triggered off by a macro, assigning a Shortcut key (See Timeline Editor) or an incoming
message with Triggers (External) or Conditional Transitions (Keyframe Trigger) configured
to do so.

Playout - Read, Record and Play

Lyric has multiple ways to operate for live playout situations, accommodating a variety of
workflows. As speed is so important to live operation, there are multiple options for
shortcuts and file conventions.

This section is an overview of the most common live operations:

e Read (Load) e Erase
e Record (Save) e Effect Out
e Play e Delete

A comprehensive list of shortcuts is listed in Keyboard/Mouse Shortcuts.
Also see Record Only and Template Data Messages

Message file conventions
Lyric Messages can be saved for keyboard recall Numerically or Alphanumerically.

e Numerically - 00000500.lyr

e Alphanumerically - 100_Lowerthird 1.lyr
The fastest way to read and record messages is by using the Numeric Keypad (Num Lock
must be enabled). In order to take advantage of numeric keypad entry in Alphanumeric
message recall, files can be saved with a preceding number as shown above.
On a ChyronHego keyboard, Num Lock is under the number pad Ctrl key. Activate it by
pressing the FN key (next to the shift key on the right hand side of the keyboard).

The default message convention is Numeric. Alphanumeric Messaging is enabled in Config
> Preferences > CG Preferences > Use Alphanumeric Messaging.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 23

Message Number

The message number a message will be recorded to or read from is displayed in the
Message Number (View> Toolbars > Message Number)

500

100 _Lowerthird 1

Messages read via the numeric keypad are accessed from the default message folder path
and displayed at the top of the Canvas (along with the currently active message.) Similarly,
messages are recorded to the Message Number in the default message folder path

The message folder default path is configured in Config > Preferences > Project Folder or
by clicking the Project Folder Toolbar tool (View > Toolbars > Project Tools).

FB1 - 500 - ["Project Folder'Messages

The Message Number can be set to auto increment after reading and recording
(Configured in Config > Preferences > CG Preferences). If enabled, the Message Number
will display the next sequential number after read or record.

To clear the Message Number tool click on the numeric keypad, press the Del key
(ChyronHego Keyboard) or the ‘. key (Decimal/Del key on PC Keyboard)

Reading Messages

Numeric Messages

Using the numeric keypad, type the message number (eg: “500”) and hit the Read key
(Chyronhego Keyboard) or the Enter key (PC Keyboard).

Even though the file was saved as 00000500.lyr, only 500 needs to be typed when entering
the Message Number as preceding zeroes are ignored.

Alphanumeric Messages

If the Alphanumeric file begins with a number, type the number using the numeric keypad
before advancing the message number display using Ctrl + < for the reverse direction or
Ctrl + > for the forward direction. The files are navigated in alphabetic order. Once the file
has been located and is displayed in the Message Number tool, hit Read (Chyronhego
Keyboard) or the Enter Key on the numeric keypad (PC Keyboard) to open. Alphanumeric
messages can also be opened via File > Open.

Messages can also be loaded in the following ways. These methods do not rely on numeric
file naming.
e Browser - Double Click a message from the browser
e Read Next - Ctrl + Enter key on the numeric keypad finds and recalls the next
message from within a range.
e Read Previous - Alt + Enter key on the numeric keypad finds and recalls the
previous message from within a range.
File Menu - Open
Playlist - First Take to read, second Take to play.
Recalling a Scene Tree (See Record Only)
Reading Multiple Messages to Canvas
In a normal operation, reading a new message will replace the current message on the
Canvas. To read additional messages to the Canvas, hold the Shift key while performing a
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Read, Browser or Flle > Open action. The messages appear in a list on the Scene Tree as
illustrated below.

Scene Tree E
| |

- 5 - (Clock)
-0 100 - (Live Bug)
-0 200 - (Lowerthird)

Preview Frame

The Preview Frame of a message is the frame that is displayed on Read. It is assigned in
View > Scene Properties and then enabled for Preview upon reading a message via
Config > Preferences > CG Preferences > Show Preview Frame.

Recording Messages

Numeric Messages

Using the numeric keypad only, type the message number (eg: “500”) and hit the Record
key (ChyronHego Keyboard) or the Minus key (-) on a PC Keyboard. In this example, the
file will save as 00000500.lyr.

Resave Numeric Messages

With the message open, it can be resaved using Alt + Record key (ChyronHego Keyboard)
or Alt + Minus key (-) on a PC Keyboard - the equivalent of Ctrl + S.

Saving Alphanumeric Messages

Must be saved via the File menu > Save As.

Resave Alphanumeric Messages

With the message open, it can be resaved using Alt + Record key (ChyronHego Keyboard),
Alt + Minus key (-) on a PC Keyboard- the equivalent of Ctrl + S.

Additionally the following methods can be used to record messages. These options do not
rely on numeric file naming:
e Browser - Add to Browser. Saves the message to the Browser and Disk.
e Ctrl + Record - Ctrl + Minus key (-) on the numeric keypad. Selective Recording
Options such as saving Template Data Messages and Messages open on the
Scene Tree.
File > Save As
File > Save

Playing Messages

Messages with an Effect In transition will automatically run upon play. Different transitions
can be triggered manually by clicking on them (transition tabs on canvas, playout panel
transition buttons on output).
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Play to Canvas
Previewing messages is done on the canvas by pressing the Play button on the

»

ChyronHego keyboard or on the Play button
> Transport Control)
Play to Output
Messages can be played to output by several methods. Discussed here is manual operator
playout as opposed to automatically from external devices.
e Ctrl + Play - (Ctrl + Alt + Page Up on PC Keyboard) Plays the selected message to
Output

on the transport control (View > Toolbars

Ctrl + Play button > on transport control

Playout Panel

Playlist

Autoplay on Read and Prompt to Play - These options are enabled in Config >
Preferences > CG Preferences > Options.

Completion Mode

Messages are configured to either return to canvas or be erased (deleted) once the next
message is played to output. This is configured via Config > Preferences > CG Preferences
> Completion Mode.

Switching and Selecting Frame Buffers

If more than one frame buffer is available users can open an_Alternate Canvas alongside
the Canvas. The Playout Tools and keyboard shortcuts can be used to switch the focus
between frame buffers to the main canvas.

Users can alternate between the two canvases using the Change key (ChyronHego
keyboard) or the * key on the numberpad (PC Keyboard ). Or select the desired frame
buffer by using the shortcut keys Ctrl + F1 and Ctrl + F2 or by clicking on FB1 or FB2 on the
Playout Tools toolbar.

XFER 4 'Fs1' FB 2

Selecting either the Canvas or Output can be done via the Playout Panel or Scene Tree.
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Removing Messages

Erase
An erase command merely clears the canvas or output and does not delete the files.
Similar to a cut, it is an immediate action.

Canvas
e Erase or Ctrl + Q (PC Keyboard)
e Shift + Erase or Shift + Ctrl + Q - Erases only the selected message on the canvas
e Ctrl + E - invokes specialty Erase Options dialog
Output
Alt + Erase or Alt + Ctrl + Q (PC Keyboard) - Erases all frame buffers
Ctrl + Alt + Erase or Ctrl + Alt + Shift + Q - Erases only the selected framebuffer
Ctrl + E - Invokes specialty Erase Options dialog
Xfer, Transfer Button on the Playout Panel or / key (PC numeric keypad), while
output message is selected in Scene Tree, will immediately cut a message off
output and transfer it back to the canvas

Effect Out

Effect Out is an Intelligent Transition. Its role is removing Lyric messages from output via a
keyframed animation. (See Intelligent Transitions.)

Messages that have not had Persistence applied (View > Scene Properties > Persistent)
will automatically trigger an Effect Out when a Scene containing a different Scene Name is
played to output. (See Intelligent Transitions > Persistence and the Effect Out.)

Ways of removing messages via their Effect Out include:

Play or Xfer blank message to output.

Shortcut key assigned to every Effect Out transition timeline (See Timeline Editor)
An Effect Out macro assigned to a hotkey. (See Macros)

Triggers (Activation) from the internal message. (See Triggers)

Triggers (External) from an External Message. (See Triggers)

Keyframe Trigger using Conditional Transitions. (See Conditional Transitions)

Deleting Messages

Methods for deleting messages;
e Delete key inside Windows Explorer
e Browser, Right Click menu, Delete, from the prompt Click Yes, “Delete from
Browser” and Yes “Delete from Disk”
e Delete Msg or Alt +F5 (PC Keyboard), Deletes Message displayed in Message
Number Tool
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View Menu

Workspaces

Opening a Workspace
View > Workspaces > Select workspace from the list.
['\ﬁew Config Tools Help

‘ Workspaces L Design
Toolbars » e Een
Playout
v Alternate Canvas
Auto Follow Save Workspace
Auto Hide Delete Workspace
AditoSuoeing Import Workspace
Browsers L Hide Disabled Panes

Lyric comes with three default example layouts:
1. Design - An example layout that enables the tools and panes used during
design/scene creation.
2. Lyric Pro - Based on the general layout of LyricPro and helps with transitioning to
the new LyricX User Interface.
3. Playout - This layout enables the tools and panes used during Playout.

Saving a Workspace
View > Workspaces > Save Workspace. Then, name the Workspace and hit “Save”

Save Workspace L g

Warkspace Mame  Custom Workspace 1

[ Save ] [ Cancel ]

Saved Workspaces will appear at the top of the list, above the three default layouts, when
accessing View > Workspaces.

[ View | Config Tools Help

Workspaces » Custom Workspace 1

Toulbars » Custom Workspace 2
v Alternate Canvas Hesighn

Auto Follow St

Auto Hide Heyout

Auto Spacing Save Workspace

Browsers k Delete Workspace

To modify an existing workspace, save it with the same name and confirm when prompted.
The Workspace file is saved by Lyric as an .xml file in a common file location. This file is
located at: C:\ChyronHego\Lyric\Workspace.
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Deleting a Workspace

After selecting ‘Delete Workspace,’ highlight the workspace that is to be deleted and click
Delete. To delete all user defined workspaces, select All User Workspaces. To Delete all
the default workspaces (Design, Lyric Pro and Playout), select All Default Workspaces.

Delete Warkspace 1‘& u

Workspace | Custom Wl 13 CE

Custom Workspace 1
Custom Workspace 2
Design

S —LY/[1C PO

Playout

All User Workspaces
All Default Workspaces

Importing a Workspace
View > Workspaces > Import Workspace. Navigate to the file location and click Open.

Once imported, the file is copied to the workspace folder (C:\Chyronhego\Lyric\Workspace).
If a workspace of the same name already exists, it must be overwritten. The workspace
now appears in the View > Workspaces selection list.

Orprvae -
v L. » Computer » Local Disk (C) » ChyronHego » Lyric » Workspace » - |$,J| Search Workspace 2 |
= e - - e =5
Organize = New folder = » & @
-~ = L "
ok Favontes *  Name Date modified Type <?xm] _Ver‘§1 on= EII..O
) _ encoding="UTF-8"7> @
B Desktop = 1. Protected 6/7/2016 3:38 AM File folder <Wo r.k space>
;} Dropbox | 2] Custom Workspace 1.xml 6/21/201612:59 PM XML Docu <Reg-i st ry> |F
‘E:-‘l Recent Places |Z| Custom Workspace 2.xml 6/21/2016 1259 PM XML Docu <SOFTWARE>
| | Downloads <Chyron>
I Deskiop <Lyric>
4 Libraries
9 Documents <Workspace>
Jﬁ Music
: <MDITabbedDocument>
[ Pictures
BE Videns A <1 i | A [ ey 4 T
b File narme: Custom Workspace 1xml - [Wolkspacs (*.XML) ']
|
L I Open |v| ’ Cancel I |

Workspaces can also be saved with the user preference settings. This can be done through
Config > Save Settings. See Save/Load Settings for further info.
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Toolbars

Opening a Toolbar
From the View dropdown menu, select Toolbars.
I‘\_ﬁew Config Tools Help

Workspaces »
Henibas * | v Project Tools
Alternate Canvas v | Windows Tools

v Auto Follow v Scene Objects

v | Auto Hide v Scene Tools

v Auto Spacing v | Canvas Settings
Browsers . v Transform Tools
Conditional Transition ¥ Group/Ungroup

v Console ¥ | Keyframing

v | Effects v Playout Tools

v Events Properties v | Live Edit

v Font Style Properties ¥ Transport Control

v General Properties v Message Number

Many of the toolbars can be moved around the workspace, and floated or ‘docked’ to
different panes. Toolbars can be docked to panes that are tabbed, and therefore may not be
visible in the Ul. Right-click on the toolbar item in the View Menu to bring the pane back
into focus.

Toolbars can be adjusted to be vertical or horizontal by resizing the toolbar when floated.

Project Tools

Project Folder

Displays as a button in the Lyric Toolbar (directly under the file menu bar)

Allows for fast access to change/select a Project Folder/Directory. When clicked the Config
> Preferences > Project Folder dialog is opened allowing for adjustments to the Project
Folders default path(s).

Windows Tools
ke OHER 4 0O D &

Displays as multiple standard icons in the Lyric Toolbar (directly under the file menu bar)
Standard Windows tools available for use within Lyric. These include:
New Scene, Clear Scene, Open File, Save, Copy, Cut, Paste, Delete, Undo, Redo.

Scene Objects
ﬂﬁ@ﬂﬁﬁv‘ 1 @i__

Allows for importing Scene objects into the Lyric Canvas. These include:
Text, Image, 3D Objects, 3D Primitives, Media files, Video Objects, Lights, Triggers, Data
Objects.
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Scene Tools

o v B ki e @)

These tools allow for manipulation of objects within a scene including:
Masking, Auto Follow, Auto Space, Auto Hide, Conditional Transitions, Hotspots, Macros

Canvas Settingsout
- - om0

Canvas settings includes Toggle Canvas Background Color, Safe Title, Alignment Grid,
Selection Guides and Reset Zoom (position).

Transform Tools

% [S)N = k-
Position, Rotation, Scale, Center of Rotation and Coordinate Space view of the Object
Manipulator.

Group/Ungroup

Allows for objects to be grouped and ungrouped together for manipulation.

Keyframing
Global keyframing is used when animating. It determines whether a new keyframe will be

created or whether all existing keyframes are modified. This can be toggled on and off using
this button.

0
*=1 | When green, Global Keyframing is off. Automatic keyframing is active.

=
e When red, Global Keyframing is on. Any change will be made to every keyframe.

For more information on how Global Keyframing can be used when creating animations see
the Keyframing section of the Timeline Editor guide.

Playout Tools

XFER 4 =Fﬂ-‘l FB 2

Allow for Transferring a message to output, swapping messages to available
canvas/outputs and selecting available frame buffers

Live Edit

LIVEEDIT | (LSl

Live Edit mode displays canvas operations immediately or ‘live’ to the selected frame buffer.
This mode is intended as an editing tool to enable the scene to be seen on output while
being created and modified. This mode should only be used for designing and editing
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purposes and not during on-air playout. Live edit will not work when “Show Preview Frame”
is enabled in Preferences.

Transport Control
M & 14 1i4 B Mi Bl M W ocooccocoo

The Transport Controls provide navigation and playback control of the current animation.
Grey indicates the loaded message has no animation, or the canvas is empty
Blue indicates the loaded message animates.

Message Number

The message number can either be numeric or Alphanumeric. By default message recall is
numeric. To set it to Alphanumeric Config > Preferences > CG Preferences > Use
Alphanumeric Messaging. The illustration below shows the message indicator with both
numeric display and alphanumeric display. For more information on reading and recording
messages see Read, Record and Play.

500

104_Lowerthird 1

Alternate Canvas

Alternate Canvas allows users to view the canvas for the inactive frame buffer when two
channels are enabled.

All editing and message recall occurs on the canvas for the frame buffer with focus. The
alternate canvas allows monitoring (but not editing) of the other frame buffer’s canvas.

Opening an Alternate Canvas
Navigate to View > Alternate Canvas.

FB2 - Untitled @

If no additional frame buffers are available, Alternate Canvas is disabled and the following
message is displayed.
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Alternate Canvas @
Alternate Canvas is disabled. Frame Buffer 2 is unassigned.
This image displays two frame buffers side by side:
FB1 - Untitled - I'\Lyric-HD Demo 2\Messages FB2 - Untitled a @

ol

46 LIVE EDIT

The Canvas reflects the currently selected frame buffer (allowing for normal canvas
operations), while the Alternate Canvas displays the non-selected frame buffer.

For details on switching and selecting frame buffers see Read, Record and Play.

Auto Follow

A node can automatically adjust its position or size by following another node’s position
and/or scale. Auto following rules restrict some nodes from being followed or from following
other in order to maximise scene performance and prevent unexpected results. See
restrictions outlined further down this document.

Auta Fallow ] e T =

Selected Mode E 1B

Group Bars

Reference Node Offset I-J.-J-J-J :
Unattached]} - 3 IW—
Enabled 7 I_—-J.-J-ZI-ZI :

Scale
Enable X Y 7 Timing
ety =EE ored | INIEITEIEN -
i Pixels/s IU-UUU =
; Options
Position First Frame Cinly
& .
Enable X ¥ i Tracking
anchors Selected Reference Lock Hierarchy [deprecated)
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e Size - A background object changes its size to match the size of the contents within
a text template.

e Position - A country flag adjusting its position to be directly next to an athlete’s
name, or a shaped object adjusting its position to follow a background object.

e Selected Node - The node that will adjust its position/size (in other words the
follower).

e Reference Node - The node that will have its position or size followed (in other
words the leader). Select from the available Scene nodes or type directly into the
window. The Previous Node (on the scene graph) or the Next Node (on the scene
graph) can also be selected.

A selected node can only be attached to a single Reference Node. To detach and
remove all Auto Follow settings previously applied, select ‘Unattached’ from the
dropdown.

Auto Follow B

Selected Node
End Cap

Reference Node
{Unattached; -

{Previous Node}

{Next Mode}

Cameral

Light 1

Bar

30 Template 1 ¥

e Enabled - As soon as Reference Node is selected from the dropdown, Enabled
becomes checked. This must be checked in order for the Auto Follow settings to be
active. It may be desirable while adjusting compositions to temporarily disable Auto
Follow settings. Check/Uncheck Enabled to enable/disable without losing
previously applied settings,

Scale

A Selected Node can adjust its size on the X, Y and Z axis to match the size of the
Reference Node. Additional scaling, i.e. padding, can be applied to each axis if needed.

In the example below, changes to the length of a 3D text template’s content varies the width
of a 3D bar that serves as a backdrop. A padding amount has also been applied to the
width to create visual padding around the text region.
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| Auto Follow E.l

~| Selected Node
Bar

Reference Node
3D Template 1 -

4| [¥] Enabled

Seale

| Enable @x [y [z

| Padding Im%‘
i (H] |0.000 B
(o] |0.000 =

The point from which the scale occurs is determined by the Axis Center point, as shown by
the object manipulator. In the example, the object scales on the X axis from its bottom left
corner.

Position

The position anchors can be applied for both the Selected Node and the Reference Node
on the X, Y and Z axis. The anchors connect the Selected Node and the Reference Node
together via these points.

For instance, the middle of one object can follow the middle of another object, or the top of
one object can follow the bottom of another and so on.

e Enable X, Y, Z: Each axis is enabled independently to allow for the Selected Node
to follow along that axis. When an axis is enabled, the respective anchor points
become available for selection.

e Anchors: Selected - The anchor point of the Selected Node determines from
which axis point the auto following will occur.

e Anchors: Reference - The anchor point of the Reference node determines which
axis point will be followed.

e Offset: Each enabled axis can have a positive or negative value applied to the
Selected Node

Anchors - XYZ available selections

e X Axis: Left, Middle or Right (L, M, R) - Anchor points are applied to the X axis
(horizontal) to determine the point on a Selected Node and the Reference Node that
serves as its anchor. The X axis offset can be varied for fine positional adjustments
of the Selected Node.

e Y Axis: Top, Middle or Bottom (T, M, B) - Anchor points can be applied to the Y
axis (vertical) to determine the point on a Selected Node and the Reference Node
that serves as its anchor. The Y axis offset can be varied for fine positional
adjustments of the Selected Node.

e Z Axis: Front Middle or Back (F, M, B) - Anchor points can be applied to the Z axis
(depth) to determine the point on a Selected Node and the Reference Node that
serves as its anchor. The Z axis offset can be varied for fine positional adjustments
of the Selected Node.

Example:
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A 3D bar has been configured as the backdrop to a text template. To demonstrate Auto
Follow positioning, a rounded End Cap will follow the 3D background bar. For
demonstration purposes, it is shown as disabled. The End Cap is set to follow the right side
of the Bar with its left anchor point on the X-Axis.

Selected MNode
End Cap

Reference Mode
Bar -

Enabled

Scale

Enable Fx [Ey [Flz

Padding

O

(6 = &
LREE
]

£

B

0.000

Scale to text size

Position

Enable x ¥

Anchors Selected

Ky
()0 Ce]
(FJm]Ce]

]

z

Reference

(1)(m)E&J
(T](m](e]
(FJ(m](e]

Below it is shown as Enabled. The left side of the End Cap adjusts its position to sit
perfectly against the right side of the Bar (no offset is added). This example demonstrates
that an object that follows another object may appear to be a single object. As the text and
background increase, the End Cap will adjust its X position to follow.

Auto Follow

(=]

Selected Node

End Cap

Reference Node

:Enabled
-
Padding . .
- (1] [o
Scale to text size Ol

Pasition
Enable x ¥

Anchors Selected

(e(a](=)
(FJa]Ce]

Fz
Reference
(L]m](&]
(FJ{m](e]

Below is the same example with less text content.
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T B
Selected Node
End Cap

Reference Node

Bar -

Enabled

Scale

Enable Fx [Ely Bz

Padding
(] [po T
(o] oo [E]

Position

Enable  Mlx [y [z

Anchors Selected Reference
mi(r] []m)ER)
(r](m](e]
(F](m](e]

Timing

The Timing control enables the selected node to resize, to an updated reference node in an
Update In and Out. This is most commonly used for text banners where the updated
message displays a different length of text (reference node), and the banner (selected
node) must expand or shrink to fit the new text.

The Timing determines the speed at which the Selected Node changes on Output to match
the length of a text string within a Reference Node. If no timing is set, the Selected Node
will immediately snap to the changed size of the Reference Node, making a visually abrupt
change on-air.

Fixed timing, dictates the amount of time in which the background object animates to its
new required size. The Pixels Per Second option sets a rate of change in size until the
background object grows to the required size. For this timing to function correctly, the
selected node should have inherit state active in the update transitions. The node inheriting
the state must have the node and scene identified in the inherit state tool.

Options

First Frame Only and Tracking refer to the way the Reference Node is updated in the
message. It may be likened to Global Keyframing when animating. Tracking is the most
commonly used Auto Follow option and is the default setting.

e First Frame Only - This option will apply the Auto Following resize/move to only the
first keyframe of the default timeline It will evaluate and execute whenever text is
changed, elements are moved or transitions are triggered. In all other transitions,
the selected node will retain its original size/position - including any keyframed
animations.

e Tracking - When active, the Selected Node’s size and position will be globally
changed in the message through every timeline. However, all keyframes will remain
and will now reflect the new size/position of the object.

e Lock Hierarchy - When checked the parents of the Auto Follow node cannot be
adjusted. When unchecked, the parents of the AutoFollow node can be adjusted
(i.e. any group that contains the Auto Following node).
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Looping Chains

When nodes are organized into groups, the base nodes become known as the child(ren)
nodes of the group. The node grouping of these is called the parent node. Objects are
contained within a hierarchical grouping structure, and these are often referred to as
parents and children. An auto follow chain should not end up back at itself or back at an
ancestor (Parent group above itself) or descendant (child group below itself).

A parent to child relationship is considered part of the same chain and could therefore end
up continually following itself in a loop. Nodes can directly follow an ancestor/descendant or
indirectly by following a node that is following ancestor/descendant. For best scene

performance avoid looping within chains. Node relationships are indicated when attaching a
reference node;

e Looping (following a node that is already following the selected node)
e Directly or indirectly following a Descendant
e Directly or indirectly following an Ancestor

Selected Mode
Text

Reference Made

{Urnattached} E
{Mext Made} -
Cameral

Glabal Light [Unfollowable]
Light 1

Elue Bar [Laaping]

Text [Looping)

Group Text and Bar [Ancestor]

m

D |n.nuu .

Auto Follow Diagnostics

Auto Follow Diagnostics is a tree-style view of all the Auto Follow Chains contained within a
scene. Looping chains are indicated in red (see above). Looping chains should be avoided
to maximise scene performance and avoid undesired results. A node can either track
another node continually (follow adjustments at every frame) or follow another node on the
first frame only. An Auto following node that is set to Tracking is indicated with a » and an
Auto Following node that is set to follow the First Frame Only is indicated with a ® (See Auto
Follow Options above).
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Auto Follow Diagnostics

B Chain #1
El Group Text
- @ Blue BKG
Ef ...... - Chain #2
- [ Group Blue BKG
: " » Group Right End Cap
‘E},,. ........ Chain #3

(= Group Blue BKG

‘. » Group Left End Cap

Example

In this example Blue BKG is following Group Text on the X scale. The Group containing the
left and right end caps are following the group containing the Blue BKG on the left and right
X positions.

Line one text

Line two text is this long
Scene Graph I:I
=
Name AV I l |

M&, Line 2
Ma, Line 1

M@ Blue BKG
O Light1

4 Global Light

8 Cameral

Viewing chains

Chains will turn red when a loop is detected. The reason for the loop will be listed in
parentheses and the node where the loop occurs is listed in square brackets eg [Blue
Brackets]
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Auto Follow Diagnostics x |
B Chain #1 [Ancestor] [Blue BKG]

B Group Blue BKG
= » Group Left End Cap
=l ® Group Text

v ® Blue BKG

In this example Blue BKG is following Group Text, which is following Group Left End Cap,
which is following Group Blue BKG (Which is the parent aka Ancestor or Blue). It is easiest
to track chains starting with the node where the loop occurs.

Highlight in all chains

Nodes can be isolated in order to see all the chains it exists in.

Right click and select > Highlight in all chains
Right click and uncheck to return to standard view.
Auto Follow Diagnostics

Group Blue BKG

et~ Highlight in all chains

Group Blue BKG

i » Group Right End Cap

e - Group Blue BKG

el uy

View entire cycle

Chains can be viewed in an entire cycle. Eg: Right end Cap follows Group Blue BKG. Then
Blue BKG follows Group Text. An entire cycle contains nodes that are not directly part of the

chain but have an indirect relationship that affects the nodes in the chain.

Auto Follow Diagnostics *g
(- Chain #1 (Ancestor] [Blue BKG]

. [Zh-- Group Blue BKG
i [ > Group Text

- @ Blue BKG

Chain #2 (Looping) [Group Bluegsdss

» Group Text View chain only
@ Blue BKG . Wiew entire cycle

—e Group Blue BKG
: g™ Group Right End Cap
(- Chain #3 (Looping) [Group Blue BKG)
i Group Blue BKG
B Group Left End Cap
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Auto Hide/Show

Auto Hide enables selected nodes to turn off and on, hide and show when an associated
template object meets a set of conditions. This feature evaluates with 2D and 3D text
templates as well as images and movies. Auto Hide or show is a per node setting which
can be applied to an object node or a group node.

Applying Auto Hide/Show to a Node

Select the node to be hidden or shown and open the Auto Hide Pane via View > Auto Hide.

Select Hide or Show from the drop down list. Click #4dd | {5 add condition parameters. To

remove conditions click the =™  to the left of each condition.
Auto Hide % |
Group > Group LOGO
[ Show when v‘ gk Add
= hogo v} | Does Not Contain | | BLANK

Conditions

Begins With

Contains

Does not contain

Ends With

Exact Match

Has any content (does not apply to Images or Movie file paths)
Is Empty (does not apply to Images or Movie file paths)

Multiple conditions

Click ‘444 {5 add condition parameters. Applying more than one condition to a node
requires an AND or an OR statement.

Auto Hide x|
Group > Group News Bug
| Hide when| v| % add
= |BUGTEXT v | [ 15 Empty v|  NEWS TITLE HERE OR v
— [BUGTEHT vl | Exact Match v | | BREAKING NEWS [lor o
= |BUGTEN v | | Exact Match v | | NEws aLerT |

All statements are combined to form a single “Condition” that will evaluate to “True or
False”.
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Auto Spacing

Auto Spacing allows users to dynamically space a group of nodes in a chosen direction
within a defined area. The spacing and distance between the nodes is calculated using the
sum of the extents of the nodes within a user defined area. This feature behaves in a
similar way to Auto Follow.

Using Auto Spacing
From the View menu, select Auto Spacing. With a parent group (containing the objects to
be spaced) selected, check Enabled.

Auto Spacing can only be applied to objects within a group. The Auto Space function is
activated on the Parent group, but not the child nodes (or nodes to be spaced).

._-Autu Spacing E:

Group
Enable

Direction/Alignment

@ Harizontal m@@

() Vertical [T ][]l B

Bounds

@) Pixels

) Object

[] Hide Excess Elements
Show Area Guides

Spacing Range
Default |u.uuu =]
[ Minimum | {0000 /2]

Actual 0.000

Options
() First Frame

@ Tracking
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For example, the graphic below has room for 4 headshots. Using Auto Spacing and the
Auto Hide feature, the headshots space evenly within a defined area whether 1, 2, 3 or 4
headshots are made visible.

ddd

PERSON 1
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Auto Spacing Dialog Settings

Enable
Auto Spacing @

Group
[¥] Enable

Auto Spacing is performed on a group of objects, When Enabled, the group will be
converted to an auto spacing group and all the direct children nodes of this group will be
spaced out evenly based on the set parameters. Any previous spacing or positioning will be
disregarded when the axis to Auto Space (X or Y) is selected.

The scene graph order of the nodes within the group will determine their spacing order.
This is determined by the Scene Graph order from bottom to top. For example, a group of
four lines set to Auto Spacing is shown below.

Line one Scene Graph =

Line two
[ g

Line three =

I, S e -
Line four
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Direction/Alignment

Direction/Alignment

@ Horizontal m@@

(™) Vertical THE;-M E

Direction in which the nodes will space:
e Horizontal - on the X axis.
e Vertical - on the Y axis.

Alignment of the nodes determines the anchor or origin point from which the objects will
space:

e Left, Middle and Right

e Top, Middle and Bottom

For example: When set to T (top), the objects will start at the top of the area bounds; when
set to M (middle), the spacing group will be vertically centered. L (left) will begin the spacing
at the left side.

Bounds
Bounds defines the boundaries of the region in which the spacing is calculated. Bounds
are indicated by green dashed lines on the Canvas (Area Guides).

Bounds

@) Pixels L |00 [

) Object i -
[] Hide Excess Elements
Show Area Guides

Bounds are executed the following ways:

1. Pixels through using number entry in the Ul, typing directly in the entry windows,
using the arrows or clicking inside the input field and sliding left (to make value
smaller) or right (to make value bigger) with the mouse.

2. A single Object node in the scene tree (The area cannot be defined by a group).
Select the desired scene object from the dropdown.

3. By dragging the area guides on the Canvas.

The bounds will either be Top and Bottom (T and B) when set to vertical, or Left and Right
(L and R) when set to Horizontal.
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Hide Excess Elements

In the case that the total size of the spacing objects are greater than the specified area
bounds, the elements will overflow by default. This means the objects will push beyond the
area bounds. The direction of the overflow is based on the selected alignment. As the
order of the children nodes is from bottom to top, this determines how Auto Spacing works
with excess objects in the scene.

For example, if there is a vertical alignment set to middle, it will push out top and bottom
equally. If set to top, it will push out the bottom.

If Hide Excess Elements is enabled, any overflowing elements will be hidden. When the
overflow element is hidden, the remaining elements will be respaced in the boundary areas.

Spacing Range
Spacing Range

Default | [0.000 |

Minimum | Iﬂ'-ﬂ'm:I Ir':"-

Actual 0.000

Default spacing is the maximum amount of space between the nodes.
Minimum spacing is the minimum space between nodes. The Minimum must
always be less than the Default.

e Actual spacing displays the current spacing between the nodes.

Using Minimum and Default together allows for variable spacing when there are less or
more groups/objects to be spaced.

For example, a table allows for up to 8 bars. When only 4 bars are needed, the designer
requires more space between the bars when there are 8. To determine an appropriate
Default value, display the minimum number of rows that will be see (but more than 1) and
define the ideal value for that spacing.

If variable spacing is not required, set the default and minimum to the same value.

Options

Options
() First Frame
@ Tracking

e First Frame spacing occurs on the first frame of the default only.
e Tracking spacing continually executes on the group and disregards all keyframes.
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Limitations of the Auto Spacing Feature
Using 2D text in Auto Spacing groups could yield unpredictable results and is not
recommended.

Any animation that affects the direction of autospacing nodes, may exhibit unexpected
results. For example, if a rotation on a bar takes up more vertical space at the point where
it is rotated 45°, if the spacing is set to vertical -T all the other bars below that bar will move
down when the bar is rotated, and then up again when the rotation completes.

The AutoSpace group and the direct nodes beneath should exist in the Default transition
only.

Browsers

Browsers are collections of images, messages, or fonts that can be saved into a database,
also called data source. A browser is stored in either a Microsoft Access or SQL Server
database.

Browsers contain a pointer to the scene, image file paths and font attributes about each
asset, but not the asset itself.

Users can create and configure custom browser databases. The browser displays only one
asset type at a time - which is selectable from the asset tools on the browser toolbar. Up to
3 browsers can be opened at once, which allows the user to simultaneously view available
fonts, scenes and images from different databases.

The terms “database” and “data source” are used interchangeably throughout Lyric
documentation.

Opening the Browser Pane
Browsers are displayed by selecting them from the View > Browsers menu. The following
options are displayed:

Show All Browsers

Hide All Browsers

1: Mo Browser Source Selected
2: Mo Browser Source Selected

3: Mo Browser Source 5Selected

Show All Browsers

This will open all 3 available browser windows. The listed browsers will be opened in Lyric,
and each browser pane can be docked to an area of the workspace. See Docking Panes for
more information on how to position browsers and other menus.

Hide All Browsers
Hides the current browser(s) from the Lyric application.
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Individual Browser Selection
Individual Browsers can be displayed or hidden by selecting them from the 3 options. If
open in Lyric, they will appear with a check beside them.

Show All Browsers

Hide All Browsers

¥ 1: Browser

21 Mo Browser Source Selected

3: Mo Browser Source Selected

If No Browser Source Selected displays in the browser title bar, then no database is loaded
and no assets can be stored or recalled.

'3: Mo Browser Source Selected

Asset Tools

@O =

Using the Asset Tools, the 3 different asset types (fonts, messages and images) can be
viewed and edited. Assets can only be added to the database when the associated asset
type is selected in the browser (i.e. to add a font to the browser the font assets must be
selected in the browser). Edits are immediately saved to the database.

Font assets &
Clicking on the Font asset button will display the library of fonts associated with the browser.

Message assets O
Clicking on the Message asset button will display the library of messages associated with
the browser.

Bitmap (Image) assets i
Clicking on the Image Asset button will display the library of images associated with the
browser.
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Browser/Database Management Tools
EERA D

Browser Management Tools are use to change/select, delete, search and refresh the
browser database, as well as to add a message, image or font. Not represented in the
toolbar buttons are the delete, update, and copy assets functions.

Selecting or creating a browser source =

Browsers are created through the Windows Control Panel (ODBC), or directly through the
Browser. For more information on creating a browser through the control panel refer to the
registering ODBC documentation.

Creating a browser

To create a new browser click on Create, or select the browser source button = in the
browser toolbar. This will open the Select Data Source menu.

- ™

Mame Filename

Browser C:\Program Files (x8a)\ChyronLyric 7. 1\Browser.mdhb
Elections Browser I:h iDatabases\Elections Browser.mdb
Mews Browser I:} \DatabasesMews Browser.mdb

Create New...| | mmport.. || Delete

From the Select Data Source window, click the button. The Create Data

Source menu will open. Users choose to create a MS Access database or a SQL
database.
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Creating a MS Access database

r i '
oot e

M3 Access |sq_sgvﬂ-|

Marme:

Path: C:'Program Files\ChyronHego\Lyrick2.0.C E]

1. Enter a name for the Data Source into the Name field and navigate to a location to
store the database file.

i '
e e

MS Access |5q_5;en..ef|

Mame: Browser for Documentation

Path: I:'Project Folder'\Databases D

2. Click OK to create the Database and display it in the available database field of the
Select Data Source menu.
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Creating a SQL database

T = '
e

MS Access

DSM:
Server:
User:

Password:

Database:
Import:

SOL Server

Data Source Mame

Computer (Local or Remote Name/TF)

User Login

Database MName

If information is required about your SQL Server configuration, see your Network
Administrator.
e DSN - Enter the Data Source Name (DSN) that has been created, by an
Administrator, for the SQL data source.
e Server - Enter the name or IP of the machine running SQL. This can be a local or
remote machine.
e User - Enter the user login for the machine running SQL. This user should have
access to modify the SQL database.
Password - Enter the password associated with the above user login.
Database - This is the name of the SQL database to be created on the SQL server.
Import - When import is checked, an existing database can be selected from the
available list. The list is associated with the DSN, Server, User and Password
entered above.
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Once configured, click OK to add this new source to the available database list in the Select
Data Source menu.

f '

Mame Filename
Browser C:\Program Files (x86)\Chyron\Lyric 7.1\Browser.mdb
Browser for Docum... I:\Project Folder\Databases\Browser for Documentation.mdb
Elections Browser L: \Databases'Elections Browser.mdb
Mews Browser I:y \Databases\News Browser,mdb

I Set Source I Frows&r for Documentation

[Createh.lew...] [ Impart... ] [ Delete ] [Adumd l [ QK l [ Cancel

Loading the browser
Once the browser is created, select it from the available databases and click Set Source.
This will populate the name of the browser into the Set Source data field.

Click OK to close the Select Data Source menu and return to the browser with the new data
source active.

The name of the data source will be visible in the View > Browsers selection as well as on
the Browser title bar along with the browser number (1 - 3).

To use different font, images or message browser sources simultaneously, open multiple
browsers with a different source. They can be docked together as required.

Removing a browser source =

To remove the current browser database from the browser window, click the Remove
Browser Source button. A dialog will display the name of the selected browser database
and request confirmation that the browser should be removed from the window.

Click OK to remove the browser database source from the currently selected browser
window.

Adding an asset to the browser e
The Add to browser button will add the currently active message, image or font to the
browser. The type of asset that will be stored is based on the currently active asset type.

Image and Scene assets can be dragged and dropped into the browser from Windows
Explorer.

When a Lyric message (scene) is dragged into the browser from Windows Explorer, it will
first load the message to the canvas as it is added to the browser database.
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Searching the browser Q

The search button will open the search dialog for the selected asset type. Images and
messages have the same search panel, while fonts have slightly different searchable
attributes.

T
e . e (o .
Can Must MustNot
Contain Contain Contain Csﬂaigin Cﬁ:isati"p‘élﬁ‘;f‘t
Spe ® Author: @
Type Face: @ s S
Comments: & & & oo
| k| £ L Comments: 7 @
Keywords: @
Keywords: @
Height: @ b @
Edge Type: ® ® Subject: @
LastModified: @ Before () After (O Between @& () Last Modified: @ Before © After  ()Between @ ()
New Search ] [R.Efne Search I [ Reset Search I Close | [ New Search ] [ Refine Search ] [ Reset Search
|

The font browser can search on a user configured Style Name, Comments and Keywords.
The Type Face, Size, Edge Type and modified date are defined by Lyric and are not
editable.

The message and image browser can search by user configured Author, Title, Comments,
Keywords and Subject. The modified dates is determined by Lyric and are not editable.
Can Contain

Will return any results that may or may not have the entered string.

Must Contain

Restricts the search results to only those assets that contain the search string in the
specified attribute.

Must Not Contain

Restricts the search results to only those assets that do not contain the search string in the
specified attribute.

Last Modified Date

A search can retrieve assets that were modified before a date, after a date, or between two
dates. If Between is specified, a second date field is displayed. The search is inclusive of
the entered date(s). The date(s) should be formatted as follows: mm/dd/yyyy (US date
format).

The Can Contain/Must Contain/Must Not Contain could be used with the Last Modified to
cancel out a range or search only within the range.

Refreshing the browser &

Clicking the refresh button will ensure that the latest assets and edits are visible in the
browser window.
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View/Sort tools

= =004 « (@8

The display and order of assets in the browser can be configured to the user’s preference.
The View/Sort tools offer different ways of viewing the assets.

Asset View

Image and Message Assets are automatically titled with the asset filename. A font does not
have a style name when loaded into the browser. Titles and style names can be added or
edited

Icons only e
Displays the thumbnail of the font, message or image in a tile format. The size of the
thumbnail is configurable.

Icons and Text 2=
Included in the text detail is the metadata, either automatically associated with the asset or
manually added. The thumbnail size for this view type is not editable.

Text Only
The metadata is visible, and by clicking the titlebar for the metadata (i.e. Title, File, Subject,
Style Name, Modified Date) the assets can be sorted (alphabetically
ascending/descending).

Sort order
8 %3

Asset display order can be changed using the sort order buttons. This alphabetical sort
applies only to the title of the asset. When using the Icon only or Icon and Text asset views,
these are the only sorting options. The sort order also sorts on the title in the Text only
view. However, the column headers for each type of metadata can also be used to sort
alphabetically on the selected metadata.

Icon Size

l[i].

The size of assets icons (when in Icon only view) can be configured to small, medium or
large icons. This option is greyed out in Text only view, and Icon and text view.

Browser navigation tools
i€ € > M

The browser navigation tools enable a user to move ahead or back a page, or go to the first
or last page.
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Right click on browser asset

The browser database can be edited by right clicking on an asset in the asset pane. When
right clicking, there are 3 options that are displayed for image, message and font assets.
They are Edit, Delete and Update. Messages also offer an update thumbnail option, while
fonts offer a create RGB font option.

Edit...
Delete
Update

Create RGE Font

Import RGE Font T Edit...
Style: Delete Delete
; Update Update
T}fp eface: Arial Update Thumbnail
Comments: Comments:
Comments: Blue look, News, plu
Keywords: Keywords: . Keywords: .

Editing an image or message

The user can type any required metadata into the 5 editable fields (Author, Title, Comments,
Keywords and Subject). The Last Modified date is not editable. The filepath is editable,
however care should be taken when editing this to ensure that the message exists in the
newly selected folder. If the message doesn’t exist the browser will recognize this deficient
asset and display it as deficient in the browser. See missing assets previously in this
document.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 55

Editing a font
When edit is selected on a font right click, the following menu will appear.

I ™
Font Information “‘ u

Stle Mame:  FS Body fort

Type Face:  Anal

Comments:  |Use for FS quote and all body tet =

Keywaords: FS
Height: 100

Edge Type:  Mone

Last Modified: Movember 08,2016

Huotloey: [.Nt +0 v]

oK ] | Camesl | | View Detis... |

Users can type any metadata into the 3 editable fields (Style Name, Comments and
Keywords). Many attributes are assigned as it is saved to the browser and are not editable.

If the associated TrueType font is not installed on the Lyric device, the browser will
recognize this and display it as deficient in the browser.
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The Hotkey dropdown offers the ability to associate this specific font with a designated
keyboard shortcut. This can make accessing a font very fast when creating new messages.
To associate a font with a hotkey, press the key combination or click the hotkey dropdown
and select from the available shortcut options. Hotkeys available from the drop down are
equivalent to the Font Keys on a ChyronHego keyboard. Alt + 1 through Alt + 8, are
assigned to Fonts Keys 1 - 8 and Alt + Shift + 1 through Alt + Shift + 8 are assigned to
Fonts Keys 9 - 16. Alt + 0, Alt + 9, Alt + Shift + 0 and Alt + Shift + 9 have no dedicated
ChyronHego Keyboard keys. To remove a Hotkey association return to the font edit menu
and hit the Spacebar or select None from the hotkey dropdown.

None
Alt =1

At +2
At +3
At +4
At+5
At +6
At +7
At+32
At +9
Alt + Shift + 0
Alt = Shift + 1
Alt + Shift + 2
Alt + Shift +3
Alt + Shift + 4
Alt + Shift + 5
Alt + Shift + 6
Alt + Shift + 7
Alt + Shift + 8
Alt + Shift + 9

Delete an image or message

An image or message asset can be deleted from the browser by selecting delete from the
right click menu.

A confirmation dialog will request confirmation that the asset should be deleted from the
database. Selecting Yes will delete the asset from the browser database.

( Lyric ﬁw

@ Delete "Mews Lower Third" from browser?

A

| Yes | ’ Mo

—
If the deletion of the asset from the browser was confirmed, the software will ask if the
source asset (base file) should also be deleted. Answering YES to this will delete the
asset from it folder and it will no longer be available for use in Lyric or any other
application. Assets deleted from the Disk are deleted permanently and do not go to the
Trash folder.
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Selecting No confirms that the asset will be removed from the browser’s database, but will
not be deleted from its file location.

( Lyric ﬁw

.
@ Delete "INProject FolderMessages\D0000001.lyr" from disk?

| ] |

Deleting a Font
A font asset can be deleted from browser by selecting Delete from the right click menu. A
dialog will request confirmation before the font is deleted.

[ Lyric ﬁw

—
@ Delete this font from browser?
b

Ly JL N |

Update

Clicking Update will replace the selected scene, or font asset, with a new asset that is
currently the focus. If the font assets are active, the browser font will be updated to reflect
the font. If the message is active in the browser, the message on the canvas will replace the
selected message in the browser. Update does not work with images.

Update Thumbnail (Messages only)

Update Thumbnail will generate a new icon for the browser using the current frame of
animation.

Create RGB font (Fonts only)

Custom image based fonts can be created by selecting Create RGB Font. Images from a
local file path can be assigned a character, and used in a 2D text box or in 3D space.

An example is creating a RGB font with red (assigned to character D - for down) and green
(assigned to character U - for up) arrows for financial boards. When the letter U is typed
into a template with the RGB font, it will automatically use the green up arrow image.
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Double Clicking Assets
To load an asset, double click the desired asset when the browser has focus.

e When a font is double clicked in the browser, it is loaded into the font style
properties. Text selected on the canvas will be immediately updated. A 2D template
will not set the font style to the template unless the Apply to Template button is
pressed
When an image is double clicked in the browser, it will be added to the scene.
When a message is double clicked in the browser, it will be loaded to the canvas.

Drag and Dropping Assets
Assets can be dragged and dropped from the Browser:
e Images
o To the Lyric Canvas
m If dragged on top of another image, the original image will be
replaced. (Holding Control while dragging and dropping will respect
the aspect ratio of the new image).
m If dragged into an empty area of the canvas, the image will be added
as a new image.
o To Texture Chip in Surface Properties (e.g. 3D object surface).
o To another browser’s Image assets
e Scenes/Messages
o To the Lyric Canvas
o To the File Name field in the Playlist.
o To another browser’s Scene assets
e Fonts
o To the General Properties > Template Properties thumbnail
o To another browser's Font assets

Image and Scene assets can also be dragged and dropped into the browser from Windows
Explorer. As a Lyric message is dragged into the browser database from Windows
Explorer, it will first load the message to the canvas so that a thumbnail of the scene can be
generated.
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Missing Deficient assets

When the browser has an asset that has been deleted from the file path (or the font has
been uninstalled), but the browser still has a record to an asset, it will display a deficient
asset. If the base asset is restored, the red strike will be removed and the asset will be
accessible once again.

Mews Lower

The deficient browser asset can be deleted from the browser by right clicking and selecting
Delete.

Page Size (CG Preferences)

Page Size refers to the amount of entries displayed per page in the Browser. When set to
Auto, Lyric will display as many as possible given the window and tile size. When Page
Size is checked, a value can be entered to determine the amount designated per Browser
page. The default amount is 100.

Conditional Transitions

The Conditional Transitions panel allows for the creation of rules that execute specific
transitions when certain conditions are met. These conditions can include comparisons
between content inside text templates, file paths, the number of templates and/or check for
the existence of a scene, node or active transition state.

Opening the Conditional Transition Pane

From the View menu, select Conditional Transition or click the 2 icon from the Scene

Tools Toolbar.

There are 3 distinct areas of the Conditional Transition pane:
1. Rules
2. Conditions and their parameters
3. Response (transitions to execute)

- — - ==
[wéi_ = | ——— --..]
Selectzd R Nam [C.aﬂe‘.hen ________________ 2‘2 ____________________ ] [wa.ﬂe_mﬂss ...... A ]
Evaluate Rule On: Cendition Parameters Stop On Response
B it Select Candition Type -
Rea Keyframe Trigger
= humber of Tempiates  + Seenes o Check EffectIn Update In
[Cpiay [ content Update [Cinternal [ External st =
DNetwork Conditions
. Effect Cut Update Out
Simple Number of Templates Template Names. Text Compare Function o -
Complex By Name “ [anythng [Nothing
Rules e
[BdlRule 0) urnamed) Priority sl Eapei olch Esgeﬁ'ect In Update In
[uplicate | T
- _ Filepath Template List Content L
. i EffectOut Update Out
() Changed
’l Pricrity
Up ) Not Changed
Down | immediate
Internal Scene Transform External Scene Transform
|
[ Test all Frame Buffers
[ =
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Rules
There are 4 different instances to choose from for when a rule is evaluated.

e Read - Executes rule evaluation on message read.

e Play - Executes rule evaluation when played to output.

o Keyframe Trigger - Executes rule evaluation when the timeline encounters a
conditional evaluation keyframe trigger (via keyframe trigger).

e Content Update - Executes rule evaluation when an update occurs via ALT + T or Il
update.

e Network - Executes rule evaluation between external devices across a network.
Only Read, Keyframe Trigger or Content Update rule evaluations will work (Play
rules are not available).

How to Use the Rules

Rules are evaluated in listed order from the top down. Multiple rule types can be selected
for each rule, so rules may execute multiple times per message. The checkbox next to the
rule list determines whether it is active or not. If a box is unticked, the rule will be skipped.

To add a rule, press the Add button. To Rename the selected rule, type new text into the
Selected Rule Name box.

Press Duplicate to replicate all the Conditions and Rule Responses.
Press Remove to delete the rule from the list permanently.

The Priority of rules is changed using the Priority Up/Down buttons. Keep in mind that
rules execute from top to bottom.

To test only the selected rule, press the Test button. To test all rules in the list, press the
Test All button. This will show the rule evaluation and preview which will be the rule to
return true and run its response. Testing all frame buffers will test Trues and Falses on both
channels at once.

Save and Load allows the user to save and load a list of rules as a .ctm (Conditional
Transition File) file. This file can then be loaded into another message.

Conditions

Each rule may have multiple conditions. For a rule to execute a response, all the conditions
for that rule must resolve true. If any condition returns false, the next rule in the list is
evaluated.

There are two places that conditions are checked: the Internal scene or the External scene.

Scenes to Check
Scenes to Chedk
[[Jinternal [ | External

In many of the conditions, users must specify whether to check the condition of the Internal
or External scenes. The Internal scene refers to This scene - the scene that contains This

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 61

rule that is being evaluated. External scenes are any scenes that are NOT the scene that
exists on the output. Some conditions are restricted to checking the External scene only.

When both Internal and External is checked as part of the same set of condition
parameters, it will resolve true for either case. To resolve true only when parameters are
true for both Internal and External scenes, two separate conditions must be added.

Text Compare Function

Text Compare Function
[T]anything [ Mathing

Begins With

Ends With
Contains

Does Mot Contain

In addition to checking the Internal and External scenes, there is also a function specifying
how the condition parameter is to be compared. This function compares Contents (2D and
3D Templates), Filepaths (Image and Media Objects) and Names (Scene, Template and
Nodes). The comparison can be specific, such as an Exact Match, Begins With, Ends With,
Contains or Does Not Contain, However, there is a less specific option of checking for
Anything or Nothing. In the case of content, this would be a check for any content, or no
content, and in the case of Scene Names, it would be any Scene on output or No scene on
output.

Condition Types
There are 3 condition types:
1. Content
2. Number of Templates
3. By Name
Condition

Select Condition Type

Mumber of Templates

By Mame | Duplicate
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Content Conditions
Content type conditions compare text, image and media content across scenes.

There are 4 different kinds or parameters for evaluation:

1. Content
2. Filepath
3. Changed

4. Not Changed

Content

This refers to the content within text templates only (2D or 3D). Selecting the template from
this list will enter it into the Template Names box. Only Templates in THIS (internal)
message will appear in the Template List. You can also manually add template names into
the Template Name box that will exist in other messages, provided you follow the
convention of “Template Name {Node Name of 2D Text Object}” for 2D Text Templates, and
“Name of 3D Template” for 3D Text Templates.

Commas reference an OR operator, not and AND.
Condition Parameters
Scenes to Check
[internal [ External

Template Names Text Compare Function

SUTemplate 1; 5 Anvthi Mothi
Template#1 {20 Tex - ElAnything. [ =

(@ Content L ——— ’ExactMabdq v]

(2 Filepath Template List Content
—_—

) Changed reaking, Mews Alert

(7} Mot Changed
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Filepath

Refers to Images or 3D objects only, not text. Selecting the object from the Asset List will
enter into the Asset Names. The Text Compare Function is used to enter a file path it has
to match exactly match, have a partial match or set to have ‘Anything’ in the file path.
‘Nothing’ in the file path is valid when a field is linked to a data object which could pass in a
blank path for a missing file.

Condition Parameters
Scenes to Check
Internal [ |External

Asset Mames Text Compare Function
Logo “  [Clanything [ Nothing
) Content y b | Contains -
@) Filepath Asset List Content
("1 Changed Logs
(7 Mot Changed
Changed/Not Changed

Refer to Images, Media, 3D Objects and 2D/3D text templates. Selecting the object from
the list of Candidates will enter it into the Names area. It will then compare the Internal
scene to the External scenes on the output for a Read or Play rule. Then, it will compare
the old text values to the new text values in a Continuous Update rule. Changed and Not
Changed will not work with Keyframe Triggers.
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Number of Templates Conditions

This is not a heavily used condition type. It counts the number of templates on the Internal
and External states, and executes the set Transition from that count. The correct number of
templates (0-n) can be put in the internal and external scene counts, and they will be
compared. Users can also put -1 in the scene count to yield a true regardless of true

template count.

Condition
Condition Parameters
Select Condition Type
[Ni..II'I'IbEf of Templates v] Add
Conditions
= Text Compare Function
Mumber of Templates Duplicate Internal Scene Count
| e = nal
1
Mame Match Portion
Priority External Scene Count
Up | -1
. | Template List
Template#1
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Condition
Condition Parameters
Select Condition Type i b ChEck
[ByNa'ne - ]l Add | =
|| External
Conditions
Dupli
- Comparison Type Scene Mames
Remove cene Name. o 3
Scene Mame -
Active Transition Name 4 .
Priority Mode Mame
_Llp .. Template Mame
> Scene Description
Down | [CTAnything [ TNothing
|Exact Match -

Scene Name - Allows users to search for the existence of a scene on the output by its
name. This only works to check the Scene Name of an external scene. Users can also
check for the existence of any/no scene on output by enabling the corresponding checkbox.

Caondition
Condition Parameters
Select Condition Type
lEy Mame v] Add
Conditions
Dup
. Comparison Type

[Scene Mame -
_ Priority
[ uwp | Text Compare Function
[ Down [[Janything [ Nothing

Begins With

Ends With
Contains

Does Not Contain
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Active Transition Name - Users can check on the External scene for a specific transition to
be Active (running on the output at the time of the execution of whichever rule is being
evaluated). Users can choose a Transition from the scene in which a rule is being created
by selecting it from the Transition List, or by typing a Transition Name into the Transition
Names Box. Typically, as the transition exists in an external scene, it will need to be typed
into the Transitions Names Box. The below example looks for the Active Transition Names

‘In High’ or ‘Move Up.’

Condition
Condition Parameters
Select Condition Type e
[By Name v)[ add ]
|| External
Conditions
i
Comparison Type Transition Mames
| Active Transition Name »| InHigh, "
Mowve Up L
1 ¥
_Priority
SRS S Text Compare Function Transition List
T e [Janything [ Nothing Default
Ml EffectIn
|Exact Match v| |Effectout
Update In
Update Out

Node Name - Users check on either the Internal or External scenes, for any node to exist,
using any of the Text Compare functions.

Condition
Condition Parameters
Select Condition Type
Scenes to Check
| content ~|[ Add
[T internal External
Conditions
i
Comparison Type Mode Mames
lNode Mame v] 2D Text 1, &
Logo =
4 p
_ Priarity
[ Up Text Compare Function Mode List
[ Down | [T Anything  []Nothing Cameral
| DOWR Glabal Light
|Exact Match »|  |ught1
3D Template 1
2D Text 1
Logo
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Template Name - Users check the Internal or External scene for a specific template name.
Naming conventions must be observed. A 3D template is referred to by its template/node
name, and a 2D template must be listed as “Template Name {Node Name}”

Condition
Condition Parameters
Select Condition Type e b Chek
| Content -] add
[Tl internal External
Conditions
Dupli
Comparison Type Template Mames

Remave [Tmate Name v] 3D Template 1, =
Template#1 {20 Text 1}

1 b

_ Priority
[ b Text Compare Function
.II.)D';-.'n : ] Anything  [|Mothing 30 Temple!_te 1

|Exact Match -|

Template List

Scene Description - Similar to Scene Name, the Scene Description in an external
Message can also be evaluated.

Condition
Condition Parameters
Select Condition Type i s i
| Content ~|[ Add
[ | External
Conditions
ByName ([P0
Comparison Type Scene Description
[Scene Description = | Lowerthird -
4 ]
Priority
[ Up Text Compare Function
[ Down | [Clanything [~ Nothing
|Exact Match -

Rule Response
This are the transitions that will execute when all of a rule’s conditions resolve true. When a

Read or Play rule resolves true, the ‘If and/or ‘Else’ responses are used (Effect In/Out or
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Update In/Outs where appropriate). When a Keyframe Trigger or Content Update rule
resolves true, the result is to activate an Immediate transition response either in the Internal
scene, the External scene or both.
If and Else Response (Read and Play Rule Evaluations)
Read and Play rules response with either the If or Else transition selections, and activate
Effect In/Outs and Update transitions.

Evaluate Rule On:

Read [] keyframe Trigger

Flay [7] content Update

Rule Response
Stop On Response
If
_EFFect In i _L_.I_|:ldate In
- Text Only In -
Effect Out ) Update Out
- Text Only Out -
Else
e
- A” In -
Effect Out it Update Out
- A“ Cut -

Putting Effect and Update responses together is an option, such as when intelligent
transition rules around Name/Description are being used. If the name is shared, an
updated will be executed. If not, the Effect In/Out will be executed. A general best practice
is to separate the two for clarity and flexibility, e.g. they can be named, ordered and
clustered together as needed in the rule list.

If an Else rule response is being used, it will execute every time - except in the case that the
rule is true. Therefore, rules that contain Else responses should be the last rule to be
executed.
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Immediate Response (Keyframe Trigger and Content Update Rule
Evaluations)

When the Keyframe Trigger or Content Update rule resolves true, the ‘Immediate’
transitions are used. Internal and External scene transformations are not interchangeable
with Effect/Update In/Out responses, as they will not replace a scene on the output
automatically. They will have to be taken off the output, similar to an Intelligent Transition.
Users are tied to one update priority, where the internal scene transformation is behind the
external scene transformation. The option of Swap Update Priority is not available.

Immediate
Evaluate Rule On; Internal Scene Transform External Scene Transform
[|read keyframe Trigger Flares - Move Down -

[T Play Content Update

Keyframe Triggers

Keyframe triggers added to Lyric timelines via 0 or Tools > Keyframe Triggers are able
to trigger the Conditional Transitions RUIles to evaluate. This means that if a message
encounters a keyframe trigger with the action set to Conditional Transitions, it will evaluate
all rules with Keyframe Trigger enabled, invoking an immediate response.

‘General EN=)

Trigger = Triggers

4Mode Info

Mode Mame  Triggers

Drescription

4 Actions

Action Type Properties

Transition
Transition (Savels)
Transition (External)
Transition (Network)

i

Macro

External Connection
Conditional Transition
GPI

Update DB Link

When triggering Immediate responses, users may want multiple or all true conditions to
activate. By default ‘Stop on Response’ is checked, which means that the list stops
evaluating when it finds the first true result. To ensure all desired true responses activate
an immediate transition response, uncheck ‘Stop on Response.’

Rule Response

D Stop On Response
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Content Update

Content update rule evaluations execute an update either via ALT + T or Intelligent Interface
content updates. Content can be 2D and 3D text templates, Image and Movie files or 3D
object nodes. As soon as the update is applied, an immediate response is invoked. For all
true Content Update rules to execute, ‘Stop on Response’ must be unchecked.

Rule Response
|:| Stop On Response

Network Rules

Network rules execute across different systems connected via a Network. The different
machines must be on the same version of Lyric to be able to communicate with each other.
Network settings are enabled via Config > Network Settings > Enable Network Transitions.
Listening Ports are also configurable here, with up to 4 available.

-
Configure Network _‘_ M

[¥|Enable Metwark Transitions:

Listening Ports

Py P P =
a1l M2 M3 g
- L L, o,

Port 1 48873

ok J[ conce

There are 2 ways to perform condition evaluations:
1. Simple - A simple network checks all of the conditions of that rule on the Remote
Machine via an IP address, or computer name entered next to the rule checkbox.
2. Complex - A complex rule can check the specific condition of a rule on the Remote
machine. This allows for a combination of local conditions and remote conditions to
be tested in a single rule. It also allows for the testing of remote conditions on
several different remote machines.
The best practice is to have a message check a remote condition and then activate a local
transition. However, it is possible to check conditions and activate a transition on the
remote machine. In order to do this, the path to enter into the External Scene Transform
box is: \RemoteMachineName or IP\FBALL\MessageName\TransitionToActivate.

Immediate
Internal Scene Transform External Scene Transform
- VYWRemoteMachineMar
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Tips and Tricks
e The more conditions, the higher up the rules list that rule needs to be.
e To run an Effect In, users can choose the Scene Description/Name that does not
contain, and add the Name/Description of the internal message.
e Users can also specify an OR condition by using a comma. In the example below, if
the Active Transition Name is Move Up or In High, then the rule resolves true.

Condition
Condition Parameters
Select Condition Type eEnes by Chedk
[By Name '] Add =
|| External
Conditions
i
Comparison Type Transition Mames
[Acﬁve Transition Name hd In High, -
Move Up i
4 b
_ Priarity
Up | Text Compare Function Transition List
i [TJanything  [~| Nothing Default
lhils EffectIn
|Exact Match v|  |Effectout
Update In
Update Out

e For an AND rule, condition A must be true and Condition B simply adds another
condition parameter to the Conditions list.

e Practice caution when entering text freeform into template names, transitions,
conditions or rule responses. Text must match exactly with no extraneous spaces.

e If there is more than one message on the output, that may interfere with the rule
checks as it progresses down the scene tree and stops at the first true, unless Stop
on Response is deselected.

e When creating Read or Play rules that will result in an Update In/Out response, it may
help to add the scene name as a condition, especially if there will be multiple scenes
on the output.

e An approach to Multiple Effects out:

o Have a single Effect Out Transition

o Put a Conditional Evaluation Keyframe Trigger on frame 1 of the Effect Out

o Create keyframe trigger rules for all desired Effects Out
Please note, having too many transitions could slow load times and lead to a message too
complicated to edit.
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Console

The Console is a pane that gives run time system and scene feedback to the user. Message
categories are color encoded as defined below:

» this is some information Display " Timestamp
» this is a warning Clear Auto Scroll

» this is a diag

Console

Information

Warnings

Exceptions
Diagnostics
Workflow

Exceptions (red)

Exceptions provide information about failures on file load or application-wide issues.
Examples would be when unembedded files in a message fail to be loaded or a message
will not be read onto canvas.

Warnings (orange)

Missing fonts and deprecated features will show up as warnings. Additionally, errors with
frame buffers and licensing, or content issues that will give diminished performance or not
behave as expected will receive warnings.

Info (white)

Info messages serve to update the user on successful operations or procedures such as
‘Save as movie completed’ and message record success.

Diagnostics (green)

Green diagnostics messages give information on diagnostic tools referenced in Preferences
> Diagnostics.

Workflow (purple)

Workflow messages reference operations that have been carried out on the graphic in
preview or on output, such as macros and data object, or auto follow or spacing activity.

Console Options

The context (right-click) menu provides the ability to filter what messages are shown based
on category, to show/hide the timestamp for each entry, toggle auto scrolling to last line
added and to clear the console.

Using the console for diagnostics

Messages can be written to the console for debugging via Leif. The function
ConsoleMessage "hello" would display
2 » hello
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Effects

2D and 3D nodes can have a variety of applied effects. Each one differs in properties and
settings, depending on the style of the effect. It is possible to apply multiple Effects to an
object node, however some are not compatible for simultaneous use. With the exception of
Soft Mask, all effects must be applied directly to the node itself. Effects can only be
animated on only a single timeline.

Opening the Effect’s Pane

1. Navigate to View > Effects.
2. Select the desired 2D or 3D node to apply effects and adjust relevant effect controls.

Available effects for 2D Objects (Images, Media, 2D Text Windows):

e 3D Edge Border (Shader Effect) e Glow

e Assemble e |eaf

e Bulge e Magic Trail (Particle Effect)
e Burst (Particle Effect) e Matrix

e Crumble e Page Roll

e Curtain e Page Turn

e Detonate e Page Wipe

e Explosion e Pixie Dust (Particle Effect)
e Fire (Particle Effect) e Ripple

e Fire + Smoke (Particle Effect) e Slide

e Flag e Smoke (Particle Effect)

e Flipboard e Snow (Particle Effect)

e Focus e Soft Mask (Shader based Effect)
e Frost (Particle Effect) e Venetian

e Glitter (Particle Effect) e Warp Clip

e Globe e Zoom

Available effects for 3D Objects (3D Text, 3D Primitives and 3D Imported Objects):

e 3DEdge - Border (Shader based Pixie Dust (Particle Effect)

Effect) Refraction
Burst (Particle Effect) RTT (Render to Texture)
Fire (Particle Effect) Sketch

Fire + Smoke (Particle Effect)
Frost (Particle Effect)

Glitter (Particle Effect)

Magic Trail (Particle Effect)
Metallic Paint

Smoke (Particle Effect)

Snow (Particle Effect)

Soft Mask (Shader based Effect)
Warp Clip

Once the desired parameters are set, effects can be previewed by dragging the cursor on
the Lyric Timeline or with animation transport controls. The effect is applied to the object for
the duration specified in the Effect Length display.
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Effect Duration

For effects in the forward direction:
e If the effect duration is shorter than the object duration on the Timeline, the effect
begins at the frame calculated as: End Frame - Effect Duration.
o For example, if the object duration is 3 seconds and the effect duration is 1
second, the effect begins 2 seconds into the object’s duration.
o The exceptions are Assemble, Bulge and Zoom. These begin at the Start
Frame of the object’s duration and end at the effect's End Frame.
o The object remains on-screen until the End Frame of the object’s duration
on the Timeline.
e If the effect duration is longer than the object duration on the object’s Timeline, the
timeline will lengthen to accommodate the Effect duration.
For effects in the reverse direction:
e If the effect duration is shorter than the object duration on the Timeline, the effect
begins at the Start Frame of the object’s duration on the timeline.
o For example, if the object duration is 3 seconds and the effect duration is 1
second, the effect begins 2 seconds into the object’s duration.
o The exceptions are Assemble, Bulge and Zoom. These begin at the Start
Frame of the object’s duration and end at the effect’s End Frame.
o The object remains on-screen until the End Frame of the object’s duration
on the Timeline.
e |If the effect duration is longer than the object duration on the object’s Timeline, the
timeline will lengthen to accommodate the Effect duration.
The effect parameters are edited by returning to this panel. Applying a new effect to the
same object replaces the previous effect.
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2D Object Effects

All of the effects share these controls:

Add/Remove - The user can designate one or more effects to the selected object.
Use this to move effects from the selected object’s Available list to its Active list, and
vice-versa.

Several of the effects have a number of parameters in common, as well as parameters
specific to the individual effect. The common parameters are as follows:

Enable - It may be advantageous to set up an effect, but not enable it to execute at
a particular time. Checking Enable allows the effect to execute; unchecking Enable
preserves the setup parameters, but does not allow the effect to execute.

Fade - Checking Fade fades the effect out; unchecking Fade executes the effect at
full video throughout the duration of the effect.

Reverse Play - Checking Reverse Play executes the effect in reverse; disabling
Reverse Play executes the effect in the forward direction.

Ease - When selected, the Ease Options dialog box opens, allowing the selection of
Ease Type: No Ease, Ease In, Ease Out, Ease In/Out. Additionally, the Ease is
executed over the time specified in the Ease Time. This dialog box is accessed
through clicking the Ease checkbox, or by clicking the Options button once Ease is
enabled.

Effect Length - Determines the duration of effect execution. If the Effect Length is
shorter than the duration of the object on the Timeline, the effect executes to the
specified Effect Length, but the object remains on screen for the duration specified
by its Timeline.
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Particle Effects
The particle effects all share the controls described below. Particle Effects are available on
both 2D and 3D object nodes.
e Size - Varies the size of each individual particle as it moves away from, or around,
the emitting object.
e Decay - Varies the rate at which each individual particle fades out as it moves away
from, or around, the emitting object.
Count - Varies the number of particles produced by the emitting object.
Velocity - These controls vary the speed of the particles as they move along the X,
Y and Z axis away from, or around, the emitting object. The direction of the
particles’ travel along the axis is determined by setting a positive or negative value.

Each axis’ Velocity control is accompanied by a +/- checkbox. If selected, the
particles move in either direction arbitrarily along that axis. With the checkbox
selected, the numerical value is applied, but since the movement’s direction is
arbitrary, any plus or minus shown is ignored by the system.

e External Force - Best compared to wind or gravity acting upon the particles being
emitted by the selected object. For example, positive X values tend to “blow”
particles to the viewer’s right, positive Y values would blow particles upward and
positive Z values would blow particles toward the Camera.

e Emitter - Refers to the object upon which the effect is acting.

o Render Emitter - Unchecking makes the emitting object invisible in the
composition. However, under this condition, the effects particles continue to
be displayed and execute their animation.

o Height, Width - These controls vary the size of the region or point on (or
within) the emitting object from which particles emanate.

o X, Y and Z Offset - Used to move the emitting region or point around, on or
within the emitting object.

o Enable - De-selecting this option decreases the alpha value of the effect’s
particles until the value reaches zero at the end of the animation. The time
at which the decrease begins is the point within the animation when the
option is displayed. Therefore, de-selecting the checkbox at 00:00:02:15 in
a 5 second animation would produce a 2% second "fadeout”, ending when
the animation completes.

e Appearance - Allows the user to vary the look of the particles. Source allows
substitution of a selected bitmap image for each particle emitted. Color opens a
standard dialog, from which the user can set a color for the surface of the particles.
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Shader Effects

3D Edge — Border
3D Edges - Borders can be applied to any 2D or 3D node, and are created from solid or
ramp colors and/or source images. Variables are key-frameable and the edges produced
can be offset and scaled.
e Steps - Varies the application of blurring effects along horizontal and vertical axis.
e Strength - Varies the intensity of the Edge effect. At low values, any assigned
texture fades to gray, and at zero, becomes invisible. When an Edge/Border effect
is centered behind the parent object and scaled 1:1, increasing the Strength setting
may give the appearance of an edge growing around the parent object.

e Softness - Controls the definition of the Edge/Border Effect, from sharper (lower
values) to blurrier. Below, 3D text is pictured with a color-only edge and a 0
Softness setting; the effect’s Offset values are exaggerated to make the effect
plainly visible. Softness can create the appearance of a shadow.

e Taps - This dropdown varies the precision with which the texture source is
processed. 3 settings are offered: Three, Five and Seven. The default is five. The
Samples setting varies the quality of Edge and texture mapping effects. These may
have an impact on system resources.

e Size - Similar to a DPI value in image-editing software, this setting varies the
number of pixels being processed in the total area of the texture source material.
This setting has a discernible effect on the sharpness of an edge effect’s borders.
The dropdown offers 5 values: 256x256, 384x384, 512x512, 768x768 and
1024x1024. The default is 512x512. The highest settings produce the sharpest
border edges, but also impacts system resources.
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Offset - The position and scale controls are used to move or resize an Edge/Border
along the X, Y or Z axis. Below, an example with elevated values is shown to
emphasize possible effects. The maximum Size value of 1024x1024 should be
used with consideration.

Texture

Color - The square selection tile is always active, with the default color setting
white. Clicking the tile opens the color selection dialog, which allows the choice of
solid or ramped colors for application to the Edge/Border. When the selection has
been made, the tile displays the color scheme that has been set.

Image - Application of an image texture to Edge/Border effects can be enabled or
disabled completely. The square selection tile opens a texture source selection
dialog, allowing a choice of bitmap images for application to the Edge/Border.
When the selection has been made, the tile displays the texture source image that
has been set.

Options

Apply Texture - When checked, adjustments made to these properties only affect
Edge effects, and not the object(s) to which the surface textures have been
mapped.

Enabled at Frame - Allows effects to be applied, varied and turned off at
user-specified keyframes along the Lyric Timeline. By extension, any Lyric
Transition’s Timeline can manipulate effects in this manner.

Blend Parent Alpha - Selecting this option multiplies the alpha value of the parent
object by the alpha value of the Edge effect being created. The result is an
apparent darkening of the object to which the Edge effect is applied.

Enable Image - Allows an image to be used as the Edge/Border. Application of an
image texture to Edge/Border effects can be enabled or disabled completely. The
square selection tile opens a texture source selection dialog, allowing a choice of
images. When the selection has been made, the tile displays the texture source
image that has been set.

Fix Obtuse Angle - can be enabled to correct the undesired appearance of sharp
angles in the 2D text edge effects on certain fonts. An example using the font
Stencil BT is shown below. The Threshold control varies the degree of correction.
Lowering the value increases the degree of correction
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RTT (Render to Texture)

Render to texture renders nodes to a texture map, making them available to be textured
onto surfaces of other nodes.

The resolution of the resulting texture is always the same resolution as the canvas.

Below is an example of a pod (on the left) textured with an RTT group node made up of
3 tori.

Setup
From the Effects Pane, apply the RTT effect to the selected node. Only renderable or
group nodes are available for RTT.
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To apply the texture, select the target surface from the surface property pane of an
object and select ‘RTT Node’ from the source list. A popup will appear with all available
RTT nodes in the scene.

4 Material 4 Texture Layers
=]
Diffuse Specular Opacity  Shininess -5 MEmbed All
= - Select An Object Te... )
Master Group
4 Texture Layers

i Master Group |
Image

Media
Text

Color/Ramp
Plugin
RTT Node. Lok | [ conel |
lng
Scene Graph o @ FB1 - 2* -I\ChyronHego Lyric Demo'\Messages

’ -
& M8 oTs Mask
8 B oS Hilite
-
W 7| Text Group
U OTS Blue Foreground3
) 0TS BG
s | | 015 BG
I katrina Anchor BG smaller
O Light1
¥ Global Light
B4 Camera
3 LIVE EDIT
Playout R [@ Diagnostics

Master Group set as a RTT effect and surfaced to pod

Show Source
Will hide the Object RTT is applied to, while showing the resulting texture
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Soft Mask (Deprecated)

This option provides a simplified method of creating hard or variably soft-edged mask
regions that affect a single layer in the composition. The layer to which the soft mask is
applied can consist of multiple canvas objects, as well as multiple groups of objects. All of
the adjustments are keyframeable.

Smooth Settings

All smooth settings are keyframeable.

Progress allows the user to position the leading edge of the Soft Mast anywhere on the
parent object.

Width varies the hardness of the edge. The lowest setting is 0, making for a hard edge.
Raising the value of this setting increases the edge’s fuzziness.
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Direction controls the angle of the mask’s travel. Similar to how the Progress value
determines how far the mask’s edge has traveled across the region containing the parent
object.

X Center and Y Center values determine the beginning points of a mask’s movement.
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Blank moves the leading edge of a mask toward or away from the center of the parent
object, along the path determined by the Direction setting.
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Jump Settings
These settings are also keyframeable, but do not produce the kind of gradual effects that
can be created with the Smooth settings.

Invert flips the mask area along the axis of its travel in an animation, as defined by the
direction setting. The left image is before checking Invert, and the right image is after
checking invert.

Mirror doubles the area of the originally configured Soft Mask. The area of mask effect is
duplicated directly opposite the original mask area.
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The Mirror and Invert effects can be used to modify each other, as seen below:

Options

Enabled at Frame - Allows the effect to be applied, varied and turned off at
user-specified keyframes along the Lyric Timeline.

Average Scene Color - Offers a choice of Cardinal, Ordinal or Compass. These
options vary the manner in which the edge of a mask is rendered, for a variety of
blurring effects.

Force Optimal Depth - When selected, Lyric reproduces a real-world interaction
between a Soft Masked object and other objects in a scene. Other objects may
cover the selected object, and selected objects may cover other objects. This
option momentarily turns on Lyric’s Depth Writing and Depth Test functions, whether
or not they have been enabled on the Rendering Properties menu. When selected,
Force Optimal Depth is active only when the Soft Masked object is being rendered.
Composite Scene Depth - When selected, a Soft Mask will function with proper
depth in respect to the rest of the scene.

Post Render - Causes a Soft mask to respect the depth information in the scene.
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Warp Clips

“Warp Technology,” is an advanced and unique feature which allows users to create and
import animated clip effects created in After Effects, 3D Studio and other 3D design tools.
These effects can be imported into Lyric for use with real time updateable content.

For information on how to create a Warp clip, see the document titled “Creating Warp Clips
in After Effects”

To add a Warp Clip Effect:

1. Select a node or group of nodes. View > Effects > Warp Clip. Navigate to the .gtc
file.

Effects

Available Arctive

| HEHEEEE
- -

Offset: IU EID E
Scale: II-UUU EII.DDD E
Clip: | L:vWWarpicloth. gbc | E

N

*
w X

1
-\

* *

* *

»

I Frame: 1&

| In | |Loop Framel | ook |
o 0 [ o | [ = |

Note: A single WARP clip per node can be applied
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Event Properties

Events happen asynchronously. When an Event is detected scripts or actions can
perform automatically. Types of Events include:
e Content is updated (Text content, or Image and Media object filepaths)
e A node ends or loops (Media/lImage/Text/3D Object etc reaches the node animation
length or loop point)
e Data Object events occur - End of Data, Data Change

On Update Script Processor

When an update occurs a VBScript executes allowing the user to modify and evaluate data
before the object (Text, Movie or Image) is rendered and displayed on output. Pre-Process
Script Events execute immediately on update of the content or filepath.

An example is raw financial data entering Lyric from a website. The script can process to
change the text color to green if a positive change in value, or red if negative change in

value.

For more information see Scripting in Lyric

Events and Actions

When the event is detected the specified action occurs. Events are specific to the node
selected.

Events include:

e On Node Animation End (All nodes excluding the Data Object) - triggers the set
action/s when the node animation length on the timeline is reached.

e On Node Animation Loop (All nodes excluding the Data Object) - triggers the set
action/s when the node reaches the loop point on the timeline.

e On Movie End Frame (Media files only) - triggers the set action/s when the Media
file reaches the End Frame defined in Media properties

e On Movie Loop (Media files only) - triggers the set action/s when the Media file
reaches the specified loop point defined in Media Properties
On Text Changed (3D text only) - Triggers the set action/s when text is changed.
Data functions (Data Object only) For instance: Move next, end of data, refresh of
data or clear data functions could execute an action such as triggering a transition.
An example is a crawl scene’s data file reaches its end (end of data) and then
triggers an action to trigger the Effect Out timeline. For more information see the
Data Object User Guide via the LyricX Help Menu.

Actions Include:

Transition
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Transition (Save AS)
Transition (External)
Transition (Network)
Pause

Macro

External Connection
Conditional Transition
GPI

Movie Control

The actions are the same as offered in the Trigger Track Tool, but differ in that they are not
keyframeable. Instead they execute when the specified event performs (asynchronously).
See Triggers for action explanations.

General Properties

The general pane is contextual based on which object is selected, and contains an Object’s
unique properties
E-'Ge'nem’l E

Flipbook = Flipbook--

4Mode Info

MNode Mame Flipbook--

Description

Node Info

e Node Name is the node name as represented in the Scene Graph.

e Node Description is entered here.
Both Node Name and Description can be utilised by additional Lyric features including
Inherit State and Conditional Transitions.
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Font Style Properties

Font Style Properties can be set for both 2D and 3D Text.

2D Font Style

Font Formats

TrueType® and OpenType® fonts with TrueType® subsets are supported by Lyric. Lyric
does not support PostScript® fonts.

Opening a Font Style

Navigate to View > Font Style Properties.

Font Style =]
4 Character Style |
Arial -
Regular - ’,‘:"l [
Size 100 |2 Leading © =
Space 31 -f_l-l Kerning O E
=
Aspect 1.000 E Rotation 0 =

HShear 0000 [5 VShear 0000 |+

|

Lexa|

i"l

HFiter 0 5] VFilter 0

4 Edge o [ @

Face

Fill

Blur o B

Opacity 100 %

Apply to Selection |

e Font Selection - Displays the currently selected Font and lists all Fonts available to
the system. Select from the list or type into the selection window.

e Font Variation - Use this area to select Font Variation from the available variations
for the select font: Regular, Bold, Italic, etc. Font variations are specified to the fonts
themselves. Thus, one font may be available in Regular, Bold, Italic and Underline,
while another may offer some of these options.

e TrueType® Font Preview - Enables the user to quickly review the available
characters in a font, change the current font or select a character (including
Unicode) to add to the Canvas at the current cursor position.

e Size - Sets the current font size in scanlines.
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Aspect - Adjusts the aspect ratio (width:height) for the selected text (Range: 0.001 to 10.00
units). The Font Sample area reflects changes in Aspect Ratio in real time.

d A

Low (0.26) Normal {1.00) High (2.50)

e Kerning - Adjusts the horizontal spacing of the selected characters in pixels
(Range: -25 to 25 pixels).

e Space Width - Adjusts the length of the selected Font's Space Character Width
(Range: 0 to 50 pixels).
Leading - Adjusts inter-line spacing (Range: -75 to 75 scanlines).
Shear (Horizontal and Vertical) - Adjust Shear along the horizontal, vertical or both
axis (Range: -5.00 to 5.00). The Font sample area reflects changes in Shear in real
time.

o d

H-Shear

2 Q

V-Shear

e Rotation - Adjusts the rotation of characters on display. The Font Sample area
reflects rotation in real time.

e Filter (Horizontal and Vertical) - These filters are provided to enhance the quality
of text display during Roll animations in HD or PAL operations.

e Font Sample Area - Displays sample characters for the selected Font, with Font
and Edge properties applied. The sample that is displayed in the Font Sample area
does not reflect the actual size of the font. Rather, the two red lines to the left of the
characters span what represents a 50 scanline height. The icons below show the
positioning of the red lines for a 50-scanline font, where they span the full height,
and a 150-scanline font, where they span one-third of the height. If the TrueType®
font on which a Lyric font is based is not available a red slash is displayed across
the Font Sample.
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Adding Edges to 2D text

To add an edge, click the i Edge  pytton. Up to 6 edges can be applied.

The components of the font are displayed in the window shown below. To edit, select an
option from the list. Edges can be copied and pasted, and also cut, from the list.

@ Edge 4o [ B

Face Orifset
Edge, Border
Edge, Shadow Shadow

| Border

’ -
Blur 0 Edge Size 5
Opacity 100 Angle 135

Edge types include: Offset, Shadow and Border (illustrated below).

aada

The Fill (solid or ramp color), Blur, Edge Size, Opacity and Angle options are all adjustable.

All font style attributes are applied to the text or template using the respective buttons.

[ Apply to Selection ] [ Apply to Template]
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Truetype Font Preview (Character Map)

The Character Map allows for TrueType® font characters to be previewed. This enables
the user to quickly review the available characters, change the current font or select a
character (including Unicode) to add to the Canvas at the current cursor position.

Accessing the Character Map

—
Click the button in the Font Style Pane (View > Font Style Properties). The
TrueType® Font Preview dialog is displayed.

Truetype Font Preview - ‘ M

Sample Keyboard Code: 32°° Fort

e =l AR Fomm 1 Heavy i
I - | | | AR Roman1 Kai Bold
# $ AR Roman Kai Light
AR Roman1 Kai Medium
AR Roman Light
i AR Roman1 Medium |
% & ( ) AR Roman1 SHS Light |
AR Roman?2 Ultra

AR Script1 Bold
5 AR Script1 Light

+ - : AR Script? Medium
AR Script3 Bold
AR Script Bold
AR Scripté Bold
f‘ 0 1 2 3 arabella
Arabic Transparent
Arabic Typesetting
Architecture
4
Arial Baltic e
4 L F

........................

Min Char ID
Unicode

L . >

In the Sample Area, the entire character set for the current font is displayed.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 93

Applying a New Font to Selected Characters
1. Select the 2D or 3D characters to which to apply the new font.
2. Open the TrueType Font preview dialog box, then select a font from the Font list.
3. Click Apply to apply the selected font and remain in the dialog box, or OK to apply
the selected font and exit the dialog box.
The new font also becomes the new current font, retaining the font attributes.

Adding a Character to the Canvas
1. Place the cursor at the point on the Canvas where the character is to be inserted.
2. If the cursor is inside of a 2D text window, a 2D character will be inserted at the
cursor location.
3. Open the TrueType Font Preview dialog box.
4. Inthe sample area, click the character that is to be placed on the Canvas.
5. Click Add.

Setting a New Current Font
1. Select the desired font from the Font list.
2. Click Apply to select the font and remain in the dialog box, or OK to select the font
and exit the dialog box.
The new font also becomes the new current font, retaining the font attributes. Its ASCII
code or Unicode, followed by the character, is displayed directly above the Sample Area

About ASCII and Unicode Characters

There are 2 sets of characters that may be displayed in the Font sample area: ASCII and
Unicode.

Visible characters in an ASCII font set are coded from 32 to 255. There are other
specialized and non-visible characters coded from 0 to 31. The ASCII code and the
character name of the currently selected are displayed above the top right of the sample are
of the TrueType Font preview dialog box.

The Unicode set of characters is an extended set of characters that includes the ASCII set.

To display the ASCII set, leave the Unicode checkbox unchecked. To display the Unicode
set, check the Unicode checkbox.

The Min Char ID and Max Char ID determines the range of codes from which a character
may be selected for placement on the Canvas. The most common setting for Min Char ID
is 32; for Max Char it is 255. This does not have an affect on the availability of characters
once the dialog box is exited.
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If the Max Char ID is changed to a higher number, the following occurs depending on
whether ASCII or Unicode is active:

e If ASCIl is active, duplicate ASCII sets appear in the Sample Area in intervals of
256. For example, if the Max Char ID is set to 1000, the character A would appear
at 65, 321, 577 and 833. Any one of the A characters can be placed on the Canvas.

e If Unicode is active, the Unicode character set is displayed.

A number of the character slots display rectangles instead of characters. In the case of
Unicode characters, there may be characters assigned to those slots which are not
rendered to the Sample Area. If this appears to be the case, use the Windows Character
map to locate these characters and paste them to the Canvas.

ASCIl/Keyboard Code
The Keyboard code for any selected character is displayed at the top center of the
TrueType Preview Dialog. Below illustrates the keyboard code for the © symbol in font Arial

Keyboard Code: 1659 2"

3D Font Style

3D text is extruded text comprised of 3 surfaces (Face, Sides and Bevels). Similar to 2d
Text, it has Font Size, Kerning, and Leading properties that can be edited as part of the Font
Style. As it is also a 3D object, Font Color, texture layers, and specular can be applied via
the Surface properties Pane. All other properties pertaining to the template are found in
General properties.

Formats
TrueType® and OpenType® fonts with TrueType® outlines are supported by Lyric. Lyric
does not support PostScript® fonts.
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Opening a Font Style for 3D Text
1. Select 3D Template.
2. Navigate to View > Font Style Properties.

Font Style x|
4Character Style
|ial v]
@
B 7
Size 100 % Lleading 0.000

QBIRE

Space 24395 5 Kerning 0.000

Text here

4Extrusion
Depth 0.000

Smoothness 3

Front (O Back (O Both @

~

Width 0030 <

..“’
0l
<
> P 2

Users can enter text directly into the template on the Canvas, but this requires placing the
cursor at the exact intersection of the displayed X and Y axis before typing. Improper
placement of the cursor could take focus off the template, reverting the Timeline/Scene
Graph’s active element to the Global Light. ChyronHego recommends entering text into the
input field on the Font Style tab or via Template Update. Input text will appear immediately

on the Canvas.
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Style Adjustments
IMPORTANT - When editing Font Styles, make sure to select the text in the Text Input Area
to ensure changes are implemented.

4 Character Style
Arial -
B 7 {al
Size 278 Leading ©0.000
Epace Eﬂ.lﬂﬂ Kerning -lﬁ.zﬂﬂ

| ext is selected

Making Font Style and Alignment Changes to Multiple Templates

On the Scene Graph or Canvas:
e Click one of the desired nodes.
e Control + Click on the other node(s) that are to be modified.

The cursor in the first template selected must be at the end of the template’s text before
selecting subsequent templates. By default, when a text template is first selected, its cursor
is situated at the end of the text it contains.

Starting the selection process with the first template’s cursor elsewhere in its text will cause
it to be omitted from changes made to the multiplate templates’ Font Style and Alignment
properties.

Character Style
Font Selection

Displays the currently selected Font and lists all Fonts available to the system. Select from
the dropdown list or type into the selection window.
Font Variation

Bold and or Italic can be applied to the font selection
Size

Sets the current Font Size in Scanlines. Size settings are reflected in real time in the Font
Sample area.
Leading

Adjusts interline spacing (leading). (Range: -999 to 999 scalines).
Space Width

Adjusts the length of the selected Font’s Space Character Width. (Range: 0 to 999 pixels).
Kerning

Adjusts the horizontal spacing of the selected characters in pixels. (Range: -999 to 999
pixels).

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

) CHYRON-HEGO

LyricX 4.6 User Guide
Page 97

Cache Font

Given Lyric’s routine method of creating 3D characters from scratch as glyphs, of the same
nature as other Lyric produced 3D objects, it is desirable to minimize the processing power
and memory required by these operations.

Lyric’s Font Cache Memory Manager is activated by clicking Cache. Glyphs for 3D
characters not already present in the system are created normally and stored by the Font
Cache Memory Manager. The dialog box shown below opens when the Cache button is
clicked, allowing users to select and deselect the types of special characters that will be
needed for a given composition. This option allows users to limit the large set of symbols,
diacritical marks and other special characters associated with most fonts.

Using this option to minimize required processing power and memory may greatly increase
the speed with which users input 3D text. The Unicode Subrange Cache Selection dialog
shown below shows all available glyphs for the font Arial.

IMPORTANT - Font Cache memory manager is only active for fonts which have no
character depth or bevel properties.

Unicode Subrange Cache Selection {Arial) ﬂ
Arvailable Unicode Subranges Cache These Subranges
Basic Lakin - = | Basic Latin -
Latin-1 Supplement Latin-1 Supplement
Latin Extended-A - | Latin Extended-aA
Latin Extended-& Latin Extended-B
IPA Extensions IP& Extensions
Spacing Modifier Letkers Spacing Modifier Letters

{_ombining Diacritical Marks
areek. and Coptic

Cyrillic

Hebrew

Arahic

Latin Extended Additional
General Punckuation
Superscripts and Subscripks
Currency Svmbols

Letterlike Symbols

Mumber Forms

AFrows

Mathematical Cperators
Miscellaneous Technical

Box Drawing

Block Elements

Geometric Shapes
Miscellaneous Svrbals

Private Use (Plane 0)
Alphabetic Presentation Forms

Arabic Presentation Forms-4 5 |
Arabic Presentation Forms-B
Specials j e | ;I

Selecting one of the Unicode Subranges in the "Available" list and clicking the Ll button
will add that selection to the list of those Subranges to be cached. Conversely, a Subrange

selection is removed from the Cached list by use of the Ll button. All contents of the

Available or Cached lists is added or removed, by use of the il or il buttons,
respectively.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 98

Text Input Area

With a 3D Text Template set upon the Canvas, text intended to populate the Template is
entered here. Text input to this field honors carriage returns, creating a new line in the
Template.

Truetype Font Preview (Character Map)

The Character Map allows for TrueType® font characters to be previewed. This enables
the user to quickly review the available characters in a font, change the current font or
select a character (including Unicode) to add to the Canvas at the current cursor position.

To access the character map: Click the button in the Font Style Pane (View > Font
Style Properties). The TrueType® Font Preview dialog is displayed.

4% Character Map - — L= |
ot I — ==
L{" | #|S(%| & "| (| )™+ ,|-|-|F(D1|2 3 4
56?89:;«::}?@ABCDEFGH|_I
| KILIMNIOIPIQIR|S|ITIUIVIWX|Y|Z|[]|)
]1* _| " |a|blc|d|e|f|g|h|i|]J|k{]l|{m{n|o|p
q|ris|t|ufv|w(x|y|Z|[{|]|}~ R AR -
:§"@aﬂ_'—®_°i23 u“ 1
°|»|va|ve|%| ¢ |A|A|A|A|AIA|E|C|IE|E|E|E|T]]
T|T|P|N|O|O|0O|0|O|x|@®|0|U|0|0U|Y|P|R|a|a
dlé|é|alee|c|&|é|&|&|i|i|T|T|O|A|O|6|0|D
| |o|=|e|olajalu|y|b|v|Ala|Aja|Ala|C|¢|C|E]| .
|
Characters to copy : I Select ~ Copy
[T] advanced view
| U+0021: Exclamation Mark

Selecting a Character - Click it on the font samples window, and hit select.
Adding a Character to a 3D template - Once a selected character is inside the
Characters to copy box, the character can be copied using the Copy button. The
character is now able to be pasted.

Advanced view allows for advanced searching. If the unicode key is known, if can be typed
into the Go to Unicode search box. Likewise if the name is known.
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Font : O.ﬂ\rial v
@a«—‘_@,_oizs |-|1] }10»1/4,
%% ¢ |A|A|AAIAAECIEE|E[E|T[T]|T[T]D]—
N O[O|0|0|0|=|@|U|U|0|0|Y|b|R|a|ala|éd|a
alee|g|é|é|&|e|i|i|T|T|0|f|o|6|6|G|o|+|a
ulalala|y|p|y|AlalAlalAlalCle|C|e|Cle|C
¢|D|d|P|d|E|&|E|&|E|e|E|e|E|8|G|g|G|a|G
glGlg|A{A[H{A|T{T{T|T|T|7|L|i|T]|W]ij]|J
TIK[k{&|C{T{L{I{E]P|L|F|E]H|N|A|N|n|N|f
niNin|0|o|0|6|0|6|CElee|R|F|(R|[T|RIF|IS|S|S
s|S|s|S|s|T|t|T|t|F|¢+|0a|0|a|0|aUal0]|.
Characters to copy : I@ [ Select ][ Copy ]
Advanced view
Character st : [Unicode ']Gobognimde: 00AS
Group by : [AJI v]
Search for : copyright [ Reset ]
| U+D0AS: Copyright Sign Keystroke: Alt+0165

LyricX 4.6 User Guide
Page 99

Additionally users can refine search parameters via Character Set or Character Groupings

Advanced view

Character set :

0S: Greek
DOS: Hebrew

DOS: Turkish
DOS: United States
DQOS: Western Europe
Windows: Arabic
Windows: Baltic
Windows: Central Europe
Windows: Cyrillic
Windows: Greek
Windows: Hebrew
Windows: Japanese
Windows: Korean
F Windows: Simplified Chinese

i B i MW Windows: Thai
Windows: Traditional Chinese
Windows: Turkish
Windows: Viet Nam
Windows: Western

‘_L.Irimde 'i Go to Unicode :  00AS

Group by : DOS: Arabic
DOS: Baltic
Search for : DOS: Central Europe
B DOS: Cyrillic
[U+00AS: Copyright Sign gos: Cyrillic IT

Reset

L _

Korean Hanja by Hangul
Simplified Chinese by PinYin

Traditional Chinese by Bopomofo

Unicode Subrange

Advanced view
Character set : [Unicode '] Go to Unicode :  00AS
Group by : All -
Search for ; Ideographs by Radicals Reset
e ___Japanese Kanli by Hiragana - R
| | U+00AS: Copyright Sign  Japanese Kanli by Radical Keystroke: Alt=0169
! Japanese Shift-1IS Subrange —

Reset returns the Character Map back to it original state.

ASCIl/Keyboard Code

The keyboard code for any selected character is displayed at the bottom right of the
Character Map Dialog. Below illustrates the keyboard code for the symbol in Arial font.
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Keystroke: At=0169

Unicode Character Reference and name is also displayed on the bottom left of the
Character Map dialog

00 G

Extrusion

3D characters in Lyric are extruded from 2D characters. 3D characters have most of the
same characteristics as other Lyric 3D objects. A 3D character is comprised of three
Surfaces elements.

e Faces: The Front and Back faces represent the information that comprises the 2D
character in its original font, from which the 3D character is built. The character
Face is always present.

e Sides: The sides are an optional second set of surfaces created by Lyric to give the
3D character depth. Until sides are created by raising the Character Depth setting
above "0", 3D characters remain two-dimensional.

e Bevels are an optional third set of surfaces created by Lyric, which connect the
faces and sides of 3D characters. Their shapes, angles and sizes is set by the user.
They can be turned on and off, and like Faces and Sides, be mapped with textures.

Apply any colors and textures to the various surfaces through the Surface Properties
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Depth, Smoothness and Bevel attributes are set as seen below. Refer to Surface
Properties for additional information on applying colors and textures to characters' faces,
bevels and sides.
4 Extrusion
Depth 0.000
smoothness 3

Bevel

LYLYLY

Front ) Back (&) Both @
Width 0.030
Depth

Sets the depth of the selected 3D character(s).
To set Character Depth, enter an integer from 0.000 to 2.000 into the entry box.

Smoothness

This adjustment varies the number of triangles comprising the character primitive being
rendered, with a direct effect on the quality of the character's appearance. Value range is
between 1 to 10, with the default at 5.

FOR MORE INFORMATION VISIT:
HTTP://ICHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 102

Bevel
Lyric's 3D character Bevel function is turned on by selecting among the bevel options
illustrated. The first option circled at top left, is the Square option which is effectively no

bevel.

(AIARA
LY LY LY

Bevel Types

Including Square (or no bevel) there are six Bevel Types.

Examples of the different Bevels are shown below. Figure (below) and button (above)
positions correspond to each other.

45° Angle Outer Rounded

Inner Rounded E Step Down Step Up

To apply a Bevel Type:
1. Select the 3D characters to which to apply the Bevel.
2. Click on the desired Bevel Style button. The Bevel is applied to the text.
3. Vary the Depth and Front/Back/Both options as desired.

Bevels can be added to the Front, Back or both faces of a 3D character via the radio button
selection.

FOR MORE INFORMATION VISIT:
HTTP://ICHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 103

Width
Sets the depth of the Bevel effect. Values are from 0 to 1.000. The illustration at left shows
a bevel depth of 0.025 and 0.035 at right.

Hotspots

Hotspots in Lyric allow for touchscreen control of messages. Using a suitable ChyronHego
system and appropriately-equipped touch screen, on-air talent can touch user-defined
hotspots mapped to objects in Lyric, and trigger a variety of actions. Touches can include
single taps and dragging gestures. Gestures can be set to trigger an action upon
“touchdown” or “liftoff” of the finger at designated hotspots.

Hotspots can be set to almost any node, including text templates, imported bitmaps and 3D
objects. Nodes can also include invisible objects such as empty text templates and
keyframe triggers. Video object regions can be mapped with hotspots, but other plugin
nodes such as hardware based Clips and mixes cannot.

There are 3 reaction types available:

e Conditional Rules Manager - Initiates the Conditional Transition evaluation, which
is Lyric’s mechanism for evaluation the satisfaction of multiple conditions and
subsequent response. See Conditional Transitions.

e Activation - Hotspots can trigger transitions. An example would be calling up an
athlete's statistics when the headshot is touched.

e Trigger Macros - When setting up a hotspot’s reaction, choosing Macro opens the
Macro Dialog. Here, new macro code can be entered, or any existing macro script
pasted.

Adding a touch screen device to your ChyronHego system will likely require driver
installation. Follow the device manufacturer’s instructions.

Hotspot Dialog

Keep in mind that the term "Node" refers to any single entry on the Lyric Scene Graph. This
includes 'real' objects, such as text boxes, templates, images and 3D objects, but also
Events and Groups of objects.
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- _
HotSpot Dialog: 'Defau|t- [
Available Nodes Related Hotspots
| Add |
[ Remove ]
([Reactions ]
Toggle Bounds Edit
Globals []Follow Mode
) On Liftoff []Use Mode Extents
) On Touchdown
Configure = Gestures
L1 e e
g CInw [N [Ine
Assodate Screen
- =
[ Disable 7]} LI LIE
Secondary
Monitor CIsw [Is [se
[ Enable Mouse
of GPU FB

L e

General Settings

e Available Nodes - Lists all of the nodes to which hotspots can be assigned in the
selected transition.

e Related Hotspots - Lists the established hotspots. When one is highlighted, its
coordinates are displayed below the list box.

e Add - With a node from the Nodes In (Transition Name) list selected, clicking Add
inserts a sequentially named hotspot in the Related Hotspots listbox.

Remove - Deletes the highlighted hotspot from the Related Hotspots list.
Reactions - Opens a dialog which allows the user to precisely designate what will
happen when an action connected to a hotspot is performed.

e Toggle Bounds Edit - Permits the user to draw a hotspot region, around a specific
node in most situations, on the Canvas.

o Start & End Coordinates - Displayed when the user has chosen Toggle
Bounds Edit. Specifies the X and Y coordinates, respectively of the
hotspot’s upper left and lower right corners.

e Follow Node - When unchecked, a given hotspot remains in its original location
and, controls the actions of its assigned node as determined by the animation in its
transition. When checked, a hotspot will move around the canvas with its assigned
object/node, so the transition’s defined reaction can be triggered by touching the
object wherever it currently appears.

o Always in effect when Use Node Extents is used to define a hotspot. Follow
Node is optional when Toggle Bounds Edit is in use.

e Use Node Extents - When a hotspot is added for a node, this option automatically
creates a hotspot defined by the canvas object’s bounding box.

Use Gestures - Unchecking this limits operation to finger touches.
Disable Secondary Monitor - Prevents the mouse from being able to travel to, or
put applications, on the secondary monitor.
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e Enable Mouse of GPU FB - Allows users to use the mouse to simulate touches on
a GPU FB.
Global settings
e On Liftoff - When selected, a hotspot’s reaction occurs when a finger is withdrawn
from contact with the touch screen.
e On Touchdown - When selected, a hotspot’s reaction occurs when a finger makes
contact with the touch screen.

The On Liftoff and On Touchdown settings are persistent, and not recorded with Lyric
messages.

Single touches on a Hotspot's equipped display can be comprised by multiple fingers
landing on the screen in a single motion. The touch screen averages the coordinates of
each finger's contact with the screen for interpretation as a single touch, or as part of a
Gesture.

3oreen text

Setting Up a Hotspot

Hotspots are limited to rectangular shapes.

To define a hotspot corresponding to a node in a transition:
1. Click on the desired Transition on the Timeline.

2. Open the Hotspots Pane via the View Menu or via the Hotspots icon B fom the
Scene Tools toolbar, then click Config Hotspots. The Hotspot Dialog, as explained
in the section above, appears. In the Nodes field being edited, the object to which
the hotspot is assigned appears.

3. Click Add. “Hotspot 0” appears in the Related Hotspots field (Hotspot numbering
begins with “0”).
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Option 1 - Bounds

Click the Toggle Bounds Edit button and use the mouse to draw the hotspot region. As
the mouse is defining the regions, the outlines are green. Upon completion, the outlines
turn yellow and the coordinates are displayed in the dialog.

Hotspot Region HotSpot Dialog: "Default” | =

Available Nodes Related Hotspots

30 Template 1
Headhot_Image HokSpat 1

Remave

Toggle Bounds Edit

&I

Skart Coords
Globals (1.#9,-1.47)
71 O Lifkaff End Coords
Sk (1.47,-1.47)
71 on Touchdown
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Option 2 - Node Extents

Use Node Extents automatically creates a hotspot defined by the canvas object’s bounding
box. Keep in mind that any canvas object occupies a rectangular region, regardless of the
visible object’s rotation or other appearance affecting variations.

Below, a 3D text template and entire bitmap object have been assigned hotspots
conforming to their rectangular regions.

HotSpot Dialog: "Default” | =]
Available Modes Related Hotspots
30 Template 1 HotSpot 0 | add |
Headhot_Image HotSpot 1

Toggle Bounds Edit
Follow Mode
Use Node Extents

Globals
() ©n Liftaff

(71 on Touchdown

Configure Gestures

Setting a Hotspot's Reaction

With a hotspot selected in the Related Hotspots listbox, click the Reactions button. The
Reactions dialog opens:

Reactions ﬂ

Reaction Type

L 7

Conditional Rules Mar

Ackivati

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

) CHYRONHEGO

LyricX 4.6 User Guide
Page 108

Use the Reaction Type dropdown to select Conditional Rules Mgr, Activation or Macro.

If you wish to set up a hotspot reaction using Conditional Rules, click here for more on the
Conditional Transitions dialog, and its operation.

If you wish to use Activations, refer to Keyframe Triggers.

Reactions | 2 |
|
fi -
Reaction Tyvpe Activations u

[.ﬁ.ctivatiun b ]

Byvailable Transitions Transitions ko Ackivake
Headshot On

Reactions

Fxn 0, Activation add
e —

E
(]
un
(1]

Feactions |i| Macro Dialog M

¥* Enter yvour Macro Code here,
Reaction Type S | s Chrl-Enber For linefeeds |

[Macru b

Reactions

Fxn 0, Activation add
Fxn 1, Activation

Fucn 2, Conditional Ruh
—— |

Close
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Touch Screen Set Up Tutorial

Lyric has added support for all Windows 7 compliant touch screen devices in order to make
its touch capabilities available to a wider range of users. Universal Touch Screen requires a
secondary monitor connection to enable touch input for Lyric using the Windows 7 API. It
uses the same techniques for setting up hotspots as in previous versions of Lyric, but with a
few extra functions as outlined below.

Setup
In Windows 7 Touchscreen set ups, there are four separate connections that must be made.

1. Connection from the Lyric device to the primary monitor that displays the Lyric UI.

2. Connection of the SDI output from the Lyric device to the output monitor.

3. USB connection from the touch device to the Lyric device to communicate touch
information.

4. A secondary monitor connection from the Lyric device to either a different input
connection of the primary Lyric Ul monitor or output monitor to translate for
Windows 7 the pixel recognition data coming in from the touches over the touch
screen USB connection.

5. The secondary monitor connection will have a gray screen with HID Touch Screen
Monitor written on it. It will only be used for touch input.

HID TOUCH SCREEN MONITOR

There are two different ways that this secondary connection can be set up.
1. The secondary monitor connection as an additional connection to the primary Ul
monitor in a secondary input
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LYRICUI
WINDOWS 7

PN Touch Screen
USB

VGA Unused
Primary Secondary
Display Touch Layer OQUTPUT
Connection Connection

DISPLAY

LYRIC DEVICE
SDI Output

OUTPUT

4

For example, if the primary monitor is connected to the computer using the VGA port, users
can connect the secondary monitor connection using either the previously unused and
available DVI or HDMI connections in the primary monitor.

2. The secondary monitor connection can alternately be made as an additional
connection to the output monitor in a secondary and previously unused input (vga,
dvi, or hdmi, depending on what is available in the output monitor.)

LYRIC Ul
WINDOWS 7 Unused
Secondary
Touch Layer
Connection

VGA
Primary
Display
Connection

OUTPUT

DISPLAY

Touch Screen
USB

LYRIC DEVICE

SDI Output
OUTPUT
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After making this second connection to either monitor, please right click on the desktop,
choose Screen Resolution, then make sure your primary monitor is labeled "1" in these
settings and secondary monitor is labeled “2”.

Change the appearance of your displays

—

Display: [1. Mabile PC Display. =
Besclution: 1930 = 1080 {recammended) -
Orientation: Landscape

Multiple displays: | Extend these desplays z|
A You must select Apply before making additional changes.

lake this my main display Mdvanced settings
Connect to a projector (or press the B key and tap P)
Bgphoe bext and obher vt langer or smaller

‘What duplay settings thowld | choose?

[ox [ Conca ][ apety |

The Lyric Ul must be hooked up to one monitor only - the second display monitor in this set
up is only used to communicate touch data coming in from the output touch monitor. User
should not use secondary monitor for any application or move application windows to the
secondary monitor.

Still in Windows, go to Control Panel > Tablet PC Settings to ensure the correct screen is
associated as the touch device. It is advisable to test and configure the touch settings here
before Lyric is opened by clicking the Calibrate button and testing the touch response.
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Display | Other

o Tablet PC Settings

Configure

displays.

Display:

Details:

Configure your pen and touch

Display options

[ @ Setup...

1. synchMaster P2370HD(Digital)

Single Touch Input Available

[

) Calibrate...

¥/ Reset...

Choose the arder in which your screen rotates,
Go to Orientation

Ok

][ Cancel

Apply

Touch Screen Initial Setup - Calibration
A touch-calibration procedure must be performed before use. With the display and overlay
device connected, follow the procedures outlined below.
1. Navigate to View > Hotspots. This dialog will initially be labeled or a Default
Transition, but may be disregarded for purposes of this procedure. All Nodes and
hotspots fields will be empty.
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r =
HotSpot Dialog: 'Defauu- 5
Available Modes Related Hotspots
| Add |
:“ Remowve |
[[Reactions |
Toggle Bounds Edit
i. =
Globals [] Follow Mode
@) On LiftafF [ ] Use Node Extents

(71 On Touchdown

Configure @ Gestures
Clnw [N [Ine
Wl ]
[ Dizable 7] L 158 LIE
Secondary
Monitar Csw [Is [se
[ Enable Mouse (5
of GPU FB

Close I
— /)

2. Click the Associate Screen button. The Touch Config Dialog will appear.

Configure _
)

| Associate Screen |

[ Disable (7]
Secondary
Manitor

[] Enable Mouse
of GPU FB
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Touch Config Dialeg @
Frame Buffers
FrameBuffer 1

Serial:  AS01237
Type: DSXLE3/22/200C*

Touch Screen

flone| ~| [

HID: DISPLAY 1{IVC21D0), 1 |

| Calibrate |

3. From the Frame Buffers dropdown, choose the output device.From the Touch
Screen dropdown, choose the touch monitor that will be used.

4. Click the Calibrate button. The following message will appear on the touch monitor:

Please touch the red marker in the Top Left.
The white markers should be within the red marks

after all four are selected.
Note: Point visualization affected by all others.

At the same time, the Touch Calibration dialog will appear on the Lyric interface.
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Touch Calibration 3

Please Calibrate your touch panel by touching the 4 corners
In order from Top Left to Top Right to Bottom Left to Bottom Right
Top Left Top Right Bottom Left  Bottom Right
@) Point 1 Point 2 Point 3 Point 4
Undefined Undefined Undefined Undefined

Fine Tuning
X Y
Undefined Undefined
D ESRES N

0.01 0.01

6. Follow the instructions that appear on the touch screen monitor and the Touch
Calibration dialog. On the Touch Calibration dialog, the corresponding radio button
for each calibration point becomes active as it is touched on the monitor surface.

The objective of this procedure is to define the Canvas boundaries on the touch screen
monitor (not to be confused with Lyric's variable Safe Title regions).

When the procedure has been accomplished successfully, each corner marker's white
figure should be situated inside the red outline thusly:

ml

Fine Tuning adjustments can be performed for precise alignment of the calibration markers
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The Keyframe Graph Editor represents object property values using a two-dimensional
graph, with time represented horizontally (from left to right), and a vertical representation of

changing values.

Opening a Keyframe Graph

Navigate to View >Keyframe Graph.

The Keyframe Graph displays information for the parameter(s) of the selected object(s).
The example below demonstrates the relationship between the animation on the Canvas

and its representation on the Keyframe Graph.

FB1 - Untitled* - I'\Project Folder\Messages
o
i

Keyframe Graph

SR

=
=

(G- &

Jo M@ 14 14 @ > bl M Pp M oo0ooo0 .
Timeline

Timeline | Parameters | Macros

Defaut [

v

Show All 152 ) ﬂl‘s uzls
4 Sphere [ =
XPosition F119 T =
YPosition 4511 =

Navigating the Keyframe Graph

03s
i

Frame Buff

=]

Show Grid
Change Bkg Color

Show graph for:
KPosition
YPosition
ZPosition
XRotation

[ [
YRotation
ZRotation - 40pacity
KScale A 100
YScale
AXYZ

ZScale 1@

XCoiter Paosition
YCenter b
ZCenter | 06:.| Rotation

| st
Transparency “ X 0.000

To step through an animation in forward or reverse, use one of the following methods:

Press the < or — cursor keys.
Click and drag the green time indicator.

Click on the Keyframe Graph Ruler running along the bottom of the Keyframe
Graph, and then press Page Down to go forward half a second, or Page Up to go in

reverse half a second.
voz:m
1 |
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To zoom in or out of the Keyframe Graph Ruler:

e Right-click on the Keyframe Graph Ruler, and then select one of the four zoom
options from the context menu: Zoom Timeline 2x; Zoom Timeline 4x; Zoom
Timeline 8x; Reset Zoom, Zoom to Animation Length. The Keyframe Graph Ruler
corresponds to the Timeline Ruler on the Timeline.

0200 (e ] 04:0 050 {005 T
| 1 |

Modify Anirnation Length

Zoom Timeline 2x
Zoom Timeline 4x
Zoom Timeline 8x
Reset Zoom i

Zoom to Animation Length

Modify Animation Length
Modify Animation Length is accessed by right-clicking the Keyframe Graph Ruler and

selecting Modify Animation Length.

Enabling Proportional Scaling will adjust keyframes proportional to the timeline length.
Disabling Proportional Scaling will not adjust keyframes while modifying the length of the
timeline track.

Modify Animation Len... SRESS

Animation Length

Proportional Scaling

(") Scale Selected Objects
@ Scale All Objects

ok || cancel
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Simultaneously Viewing More Than One Attribute
1. Expand the Timeline and select the first attribute to be displayed.
2. Then, press Ctrl while clicking the other attributes to be displayed.
3. When the Keyframe Graph is viewed, all selected Timeline attributes are displayed.

The Keyframe Graph can only display attributes of the same type simultaneously. In other
words, several Position attributes may be compared, but not a Position attribute and a
Rotation attribute.

Keyframe Graph @

Show Grid
Change Bkg Color

Show graph for:
#Position

YPosition

Displaying Keyframe Information
Right clicking on the Keyframe displays a context menu with a variety of display options.

v | Show Gnd
Change Bkg Color

XPosition of Bar

One Keyframe selected at 02:24

Interpolation Maode (Linear)
Add Keyframe

Delete Keyframe
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Interpolation Modes
Lyric provides a choice of Interpolation Mode settings which determine how an animation
transitions through each Keyframe. Refer to Interpolation Modes for details.

Spline animations can be adjusted using the handles on the keyframes. Stretch and shrink
the handles as well as rotating them to adjust the curve size and shape. The below
illustrations show two spline paths of a bouncing ball.

Keyframe Graph - Sphere [ YPosition]

Wi 46 14714 @ > PIi M1 P W 000000060

Timeline ‘ Parameters

L]
o Olf ].lllf Z?f EEIJF 4?1’ SllJf Glllf T?f ﬁtIJf SllJf 1t.’|‘0f 11‘0f 12‘0f ].3|0f
Sphere i B} 0 0 8] 0
Keyframe Graph - Sphere [ YPosition] @
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Moving Keyframes
To adjust a Keyframe on a Keyframe Graph, click and drag it with the mouse.

Adding a Keyframe

To add a new Keyframe to the current Keyframe Graph:

Right-click on the Keyframe Graph where the new Keyframe is to be positioned. Lyric
displays a context menu: Select Add Keyframe.

Deleting a Keyframe

To delete a Keyframe, right-click on the Keyframe and then select Delete Keyframe from
the context menu.

Keyframe Graph Attributes
Right-click on the Keyframe Graph to display a context menu enabling you to change the
Background Color, or to show/hide the Keyframe Graph's grid lines.
[T
v Show Grid

Change Bkg Color

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 121

Macros

Macros are VB Scripts that can be triggered by events or keyframes within the scene.
VBScripts can also be directly attached to nodes, see Pre-Process Data Scripting.

Macros can be accessed and managed at the application level (Global) and the scene level
by embedding scripts within the scene. Additionally scene macros can also execute global
macros, see Scene Macros below.

Refer to LEIF Help for additional information about the LEIF APIl. Open the LEIF.hlp file in
the program folder in which Lyric is installed.

Opening the Macro Pane
Navigate to View > Macros > Global

?IMac'ms
|
Macro Hotkey File Description |5Cl'iPt IGIobaJs|
.
L T ;
2 v r
2 P @® o= = C

The Macro List (left) displays the following information for each macro:
e The name of the macro.
e The hotkey, if specified, that executes the macro.
e The file path of the macro once it has been saved.

The right pane displays three tabs:

e Description - Displays a short description of each macro.

e Script - Displays the VB Script for the selected macro. Macro scripts can be input
in a variety of manners: Typing a script directly into the Script tab, opening an
existing macro file and recording keyboard/mouse activity.

e Globals - Displays a list of Global Variables available for use by any of the macros.

There are also a set of icons at the bottom left of the dialog box, which execute a variety of
functions.
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Creating a Macro

Click the Add icon ¥ to create a new macro file. Type the macro into the Script tab.
Recording a Macro

Click the Record icon 2 to begin recording and the Stop L icon to end recording.
During macro recording, the Macro symbol next to the default filename blinks and the letter
M in the Status Bar turns red.

Most actions involved in creating a Lyric scene can be recorded as part of a macro. Actions
not directly related to the creation of the scene, such as clicking on a window to make it
active, are generally ignored. Refer to Specifying Characters Using SendKeys Commands
for additional information.

In this example, Ctrl+Alt+Page Up has been pressed while recording in order to create a
play to output operation.

_.Macrus @
Macro Hotkey  File | Description | 5Tipt | Globals | P
? [new] ActiveCanvas.5cene.Play PlayOutput, PlayWait ~| 1§

L I I

2 BPO®s =C

The Macro symbol 7 does not stop flashing until the current macro is saved or
abandoned.

Executing a Macro

Click the Play icon » or double-click the macro name.
A macro can also be executed by pressing a hotkey combination. See Setting Hot Keys.

Saving Macros

Macros that are listed in the Macros dialog box can be saved individually or together when a
Save is executed. Macros can be saved in two different formats:

*.Imx:

e The *.Imx format is a file consisting solely of ASCII text. This allows the file to be
opened in any text editor. Files of this format can also be used in programs outside
of Lyric.

Opened in Lyric via the file menu, macro(s) populate the macro pane.

Macros will be loaded automatically to the macro pane when Lyric is launched if
the file is named Lyric.Imx and saved into the program folder; C:\Program
Files\ChyronHego\[Version of Lyric]
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*lyr:

e The *.lyr format is executable only from Lyric. This format allows one individual
macro to automatically execute upon reading the macro file. The *.lyr format also
allows the file to be read as a Lyric message by entering the Message Number, then
pressing Read.

To save a single macro as an *.Imx file or .lyr file:
e Highlight the macro in the Macro List, right click to invoke the contextual menu and
select Save Macro.

To set a macro to auto execute (available for .lyr files) select the desired macro from the
Auto Execute drop down box and hit Save.

To save a group of macros as an *.Imx file or .lyr file:

e Click Save All Macros to File icon ¥~ or press Ctrl + S to save all macros
displayed in the Macros dialog box. The Save As dialog opens.
In the Save In field, navigate to where macro file is to be saved.
In the Save as Type drop-down list box, select Lyric Macro Files (*.Imx) or Lyric file

(.lyr). Enter a File Name and click Save.

To save Global Variables, select the Save Globals check box. Global Variables are covered
later in this section.

Opening/Reading a Macro

Macro files in the *.Imx and *.lyr formats can be opened by double-clicking or from File >
Open

Macro files in the *.lyr format can also be read as any other Lyric message. Any macro
opened in Lyric will appear in the Macro Pane and, if selected to Auto Execute, will run on
read.

Opened macros that have duplicate names as another macro in the macro list will be
overwritten. This does not affect the original macro files that have been previously saved. If
a macro in the Macros pane has not yet been saved, the overwrite would erase it.

Deleting a Macro/All Macros

Macros can be deleted individually, or as a group, from the Macros dialog box. Global
Variables are not deleted by either operation.

To delete an individual macro, right-click the macro name in the Macros dialog box.
Select Delete from the context menu or press the Delete key and confirm.

To delete all macros click the Clear All Macros icon *

Editing Macros

Macros can be edited in the Script tab or the Script editor window
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Script Tab

To edit, select the macro name to load into the Script area. The script can be tested for
errors via the play button.

Script Code Window

Each individual macro, whether saved individually or as a group, is identified as a
subroutine in the VB Script. Script from any of the subroutines can be edited.

To edit, select Script Code from the macro list context menu.

Script Editor . £

13

Sub Macrol

'"DESC:-10:42:4¢ ©Oct 04, 20l&

'ICON:WHITE

"HEE¥:

LotiveCanvas.Scene._ Play Playlutput, PlayWait
End Sub

4 k

Global Variables
A Global Variable is a value that is available to all macros. It can be an absolute value or it
can be determined by input from another source (such as another macro.)

Global Variables are written in the Globals tab of the Macros dialog box. Each Global
Variable must be preceded by the word “public”, which indicates that it is available to all
macros.

Global Variables remain active until deleted or reset.
Resetting the Macro Engine and Global Variables

Clicking ¢ removes all macros from the list and resets the VB Script processor to its
initial state. This is recommended when work with one set of macros is complete and a new
set is to be opened. In addition, if a macro exhibits unexpected behavior or newly created
macros are retaining and executing previously created scripts, resetting the macro engine
can restore proper functionality.

Executing a reset also clears macros that have been created and sent via Intelligent
Interface (which do not appear in the Macros dialog box.) After a reset, it may be necessary
to resend the macros to Lyric.

Generally, it is desirable not to reset the Global Variables, in order to leave them available
for the next set of macros.

To Reset Macros Only: Click Clear all Macros .
To Reset Macros and Global Variables: Click the Reset Macro Engine and Globals icon

¢
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Macro List Context Menu

The macro list context menu accesses functions that allow the user to edit, delete, save, set
a hotkey or rename a macro.

To display, right-click a macro name. Script Code will be disabled unless the selected macro
has already been saved.

fﬁ.aﬂns
Macra Hotkey File [E

[mew]
Seript Code...
Delete...
Save Macro...
Hot Key...
Rename

Setting Hot Keys and Macro Symbol Colors
Hotkeys (keyboard shortcuts) can be assigned to each macro. A color can also be
assigned to the Macro symbol for easy recognition.

To set a hotkey and a macro color:
Right-click the macro name in the Macros dialog box, select Hot Key from the context

menu, type the desired shortcut, and apply.

To remove hit the spacebar <None>.

Macro Short Cuts &
Icon Hot Key
¥ red -] F
£ aqua
¥ ook ||
£ white -

Renaming a Macro
Individual macros can be renamed by right-clicking the macro name in the Macros dialog
box and selecting Rename. Type the new name of the macro.

Macro names containing spaces or punctuation characters are invalid and will be rejected.
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Description, Script and Globals Context Menu
To display this menu, right-click in the Description, Script or Globals tab of the Macros
dialog box.

-~
—— —4

ctiveCanvas.5cene.Play Pla

Cut
Copy

Paste

Delete
Select All

Right to left Reading order
Show Unicode control characters

Insert Unicode control character k

Open IME

Reconversion

Standard Windows text editing functions such as Cut, Copy, Paste, Delete and Select All
are available from this menu. If certain language packages are installed, three additional
items are displayed:

Right-to-Left Reading Order: Right-justifies the text, and specifies that the text should be
read from right-to-left. To toggle on/off, click Right-to-Left Reading Order. When active, a
check is displayed next to the menu item.

Unicode Show/Insert: Currently not supported

IME: Input Method Editors are accessed from the Windows Language bar.

See Scripting for more details.

Scene Macros

Previously Scene macros have been confined to a single script embedded in the message
that auto executes when the message is read. Scene Macros have now been expanded to
allow for a single embedded script as well as the option to execute multiple scripts loaded
into the global macro pane. The scripts can be viewed in a dockable pane. They can be
enabled and disabled at any time.
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Opening Scene Macros
Navigate to View > Macros > Scene
‘Sumlhcms x|
Macro Enabled Hotkey Script
Set sc = ActiveCanvas.Scene
TitleLoge M ctis If sname = "MEDIA Then
DATA_UPDATE %] W=
HEADSHOT_TOGGLE_MULTIPLE [
Fori=1to20
ScoresON [ T

If sc.Exists["GP ANSWER "8 i) Then
Set & = sc.Template("ANSWER VALUE - * & i].Text
End If

If sc.Exists["BAR - " &) Then
scElement("BAR - " & i].KeyFrame kfxScale, 0, A*.01
End If

Next

e B 0 IE

Each scene has an embedded macro script that is saved with the scene which cannot be
deleted. It can be enabled and disbaled to execute from the Scene Macros pane and on
message read. Scene macros will also run on Alt+T when enabled.

Additional to the embedded macro is the ability to add call macros. These are macros that
are stored in the Global Macro Pane (see above)

Call macro’s are referenced by name only and the script is maintained via the global macro
pane. They are read only and cannot be edited via the Scene Macro Pane.

To add a macro call click the & add button. A list of all macros loaded into the global
macro window appear for selection

Scene Macros

| Macro Enabled Hotkey

Titlelogo M e
DATA_UPDATE %]
HEADSHOT_TOGGLE_MULTIPLE M ez
ScaresON E|

Alt+9
-

ARROWS_OFF
ARROWS_ON
BG_REPLACE
CLEARFE
CLIP_REPLACE
CLOCK_START
DATS,_UPDATE

The macros execute in order of the list. They can be reordered by dragging them up and
down the list. Duplicates are permitted.
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The list can be enabled and disabled quickly by left clicking and dragging down the Enabled
column

Right Click on the Column title area to hide and show columns.

P

, | Scrint
Name of macra |

1

If checked, macro is executed during read and template update

TitleLogo
DATA_UPDATE
HEADSHOT TOGGLE MULTIPLE

Macro hotkey

[JLes]

Remove macro from call list

@ P s

The Scene Macro controls are:

Add: Inserts a macro from the global maco pane
Play: Plays the selected macro

Play All: Plays all macros in the Scene Macros Pane

Remove All: Clears all call macros from the list
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Masking

Any visible Lyric Object Node (with the exception of 2D Text Windows) can serve as Mask
Objects, including groups.

Any visible Lyric Object Node can serve as a Mask Target.

Masks can either be based on the alpha/opacity of the mask source, or the luminance
values (grayscale) of the source.

To Open Mask Properties

Navigate to View > Masking.

Masking

1 [ 23 [a]s[6]7 &9 [0 [12]13]1s]15]16]
4Mask

| Available || Mask Objects Ll ‘!:'|

Katrina Anchar BG smaller = || OTS Mask
OTS BG Base [

0TS BG Buildings

0TS BG Buildings Yellow

0TS BG

QTS Blue Foreground3

Mesh_Pattern_Small2 -

Iﬂ Add Qi Remove @ Remowve All

4Target

| Available || Mask Targets d FlFl|

Katrina Anchaor BG smaller = | | Blurred Big [ AR
OT5 BG Base |:| OT5 Movie [ AR
OT5 BG Buildings OT5 Hilite [ AR
0TS BG Buildings Yellow

0TS BG

(TS Blue Foreground3

Mesh_Pattern_Small2 -

B Add 4@ Remove 4@ Remove All

Masking Terms
Mask Objects - The element(s) that will be used as a mask

Mask Targets The element(s) that will be masked
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Mask Layer A mask object and target must be on the same layer to interact with each
other. Objects and Targets can be assigned to multiple layers.

All sources and targets can have one or more specified layers. Child objects inherit
ancestors (group parents) layers, while also maintaining their own layer assignments.

Options

Invert 4
The mask layer will be inverted for the selected target. If an ancestor (parent/grandparent)
group node is inverted in any layer, all children will also be inverted.

Luma Mask E

Used in situations where the user wishes to create a Soft or Shaped Mask using a 24-bit
black & white image. The gradient from black to white will create a Soft Mask. 32-bit Images
with Alpha can also be used. If an ancestor (parent/grandparent) group node is set to luma
in any layer, all children will also be luma masks.

Show @/
When an object is set as a Mask Object, it is not rendered to the Canvas. The Show option
displays a proxy of the object, for reference, during the composition of the Lyric message.

A Mask Object uses the alpha information to determine the masking amount applied to the
target. This means a mask that has 100% alpha masks its target by 0% (no masking
occurs), a mask with 50% alpha masks its target by 50%, a mask that has 0% alpha masks
its target by 100% (total masking occurs) and so on. See illustration.

Mask Object Opacity set to 50% Mask Object Opacity set to 0%
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Alpha is not automatically applied to the Mask Object. Therefore as Mask Objects are not
visible on the canvas in 3.0 it may seem that your mask is not being applied. To rectify,
adjust the alpha value via the Transform pane to apply the desired masking amount.

An image or media file that contains a shape or gradient uses the embedded alpha (or black
for Luma masks) as the masked area. Again, the opacity of the mask object needs to be set
to 0%

Gradient image Gradient image as a Mask Object

Grouping and Inheritance

Nodes inherit the Mask Object or Target settings from any ancestors. In other words adding
a group as a Mask or Target means the children automatically inherit and discard a parent's
masking information when it is either added or removed from a group. Child nodes inherit
the settings of their ancestors however they are no longer added to the right side column on
the masking pane. The exception to the above is 2D Text windows will not inherit a Parent
Groups Mask Object settings - because 2D text cannot be a Mask Object.

Layers

All Mask objects and targets can have one or more specified layers. Child objects inherit
their ancestors layer assignments and also maintain their own.

Luma E
Mask Object setting
Child objects will inherit this setting from their ancestors.

Invert
Target setting
Child objects will inherit this setting from their ancestors.

Anti Aliased

Antialiasing improves the quality of the masked edge. By default, mask targets are not
antialiased in order to prefer performance. Antialiasing should always be disabled if the
mask source has only straight edges as it gives no benefit.
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Antialiased Non-antialiased
Masking @

1|2 |3[a4]s5]6 |7 |89 |10[11]122[13]14][25]16]

4 Mask

| Available || Mask Objects Ll $|
Katrina Anchor BG smaller Ml 075 Text Bar Mask B
0TS B Base

TS5 BG Buildings

OT5 BG Buildings Yellow

OTS BG

(TS Blue Foreground=
Mesh_Pattern_Small2 -

E} Add Cﬁ Remove @ Remove All

4 Target

| Available || Mask Targets Ld P"’I|

Katrina Anchaor BG smaller = | | Flares for Effect In Animation AR
OT5 BG Base

QTS BG Buildings

QTS BG Buildings Yellow

0TS B

0TS Blue Foreground3

Mesh_Pattern_Small2 -

= Add %@ Remove 4@ Remaove All

Ul

When a node is selected, if it is assigned to a layer, a blue line will appear on the layer tab
for that layer. Layers that have targets or mask objects assigned to them will be bold.

In the example above, ‘OTS Text Bar Mask’ is active in both Layer 2 and 4. Layers 1, 2 and
4 have got active masks or targets on them.
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Masking Performance Tips

Antialiasing
Only use Antialiasing if required, there will be a performance hit.

Layers
A mask ‘bank’ is a collection of 4 mask layers. Layers 1-4 define bank 1, layers 5-8 define
bank 2 etc. (16 layers create 4 mask banks)

For maximum performance, it is advised to try and keep each mask target in the minimum
number of banks possible. For example, if you need a target at 3 distinct layers, choose
layers that are all in the same bank, when possible. There is a slight performance hit for
each additional bank a target is in after the first.

Metrics

View > Metrics.

The Metrics Pane displays the time (in milliseconds) to render frames. It is only active when
playing scenes to output (or virtual output). The Metrics Pane will display the metrics for the
currently active FB. In other words, if you're playing out to 2 FBs at once, when you activate
a FB (click the FB button on the Playout pane), the Metrics Pane will update with the
metrics for that FB.

Warning: The Metrics Pane should not be open during on air playout as it uses system
rendering resources.

For smooth playout (no stream errors), the frame times must be no greater than 16.67
milliseconds for progressive standards and 33.34 milliseconds for interlaced standards. The
line graph above will shift towards a red color when approaching this limit.

The results are dependent upon the system the messages are played out from. Results will
vary between systems and between output standards.

Options

Clear Data

The data can be cleared by right-clicking inside the pane and clicking ‘Clear Data’. This
allows for resetting the min/max and average timings in order to recalculate these metrics
for subsequent scenes sent to air.
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Parameters List

Parameters are considered storage containers for data values. Parameter data values can
be used in Lyric Scenes, Data Object Sources, Data Object Filters, Macros and are

accessi

ble through LEIF. Parameters can be available to all scenes (Application

Parameters) and or a single scene (Scene Parameters). The Parameters pane allows

parame
also be

ters to be created, modified, deleted and bound to Lyric elements. Parameters can
created and modified through a Macro, LEIF or Intelligent Interface.

Application parameters are global and available to all scenes.
Scene parameters are saved with a scene, and available only when that scene is recalled.

Creat
Navigat

Parameters @

Parameters | Timeline

Application Scene

op Add == Remove

ing and Modifying Parameters from Lyric
e to View > Parameters List.

Mame Value Eindings Type

Sub Line 5ub Line Text -
Extra Crawling Text Extra Crawling Text = Text -
0TS Maovie I\ChyronHego Lyric Demao\Maovies... | OTS Mavie * Maovie -
OTS Main Text {OTS Main Text} Top Line OTS Text OTS Main Text {OTS Main Text} * | Text 2
Parameter Text -

Name - |dentifies the specific parameter when fetching the value.

Value - A string of text, such as text content, or a file path.

Bindings - Lyric element(s) in the scene that are bound to the Parameter. In the
case of Application, all the bound elements in currently open scenes
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e Type - Is a optional field that is stored to determine the type of element bound. In
most case this field is not used.
The above Parameters List shows 3 parameters. The Names of these (Team Home, Team
Away and innings) are identifiers and will not change. However, the Value for these
parameters are dynamic and will change every game and innings.

Adding, editing and deleting Parameters

Parameters can be added manually using the ‘Add’ button, or by dragging directly from the
Update Ordering list

Binding Parameters to Updateable fields
Parameters are bindable directly to any updateable scene element. The Bindings field can

be typed in, clicked on to present a dropdown of all the updateable elements in the scene,
or elements can be dragged

[ Parameters E .Upnlate Ordering EE

| Application | Scene 30 Template = Sub Line Show -

'::'} Add == Remaove

T | Mode Mame Path

Mame “Walue Bindings

+" Sub Line haster Group=

Paramter 1 Factory Blast OTS Main Text {OTS Text} =

Parameter 2 | IANChyronHego L., | OTS Image *
haster Group=1

haster Group=1

Bl |
& <%
[ ]
7 B
- E
=
453 ™
(1l

7

B

into the bindings field from the Update Ordering Pane.

Binding Keyframes
Attribute keyframes can also be bound by by ALt+Ctrl clicking and dragging to the

Parameters pane or by marking as updateable, and then they will be available in the
Parameters dropdown.

Timeline R [B] Parameters 1=
W T4 T4 @ > Ml M W WM 00006175 D, | Application | Scene |
"DeT'T‘ 7v oh Add = Remove
Show Al 353 !f 130t Y I‘ Name Value  Bindings Type
4 |pod—| Pod Default XPositio... | -1.1754 Pod Default XPosition KI )

¥Position 1175 ] Pod Default YPositio... |0.6376 Pod Default YPosition KF2 = Text -

YPosition 0.638
ZPosition 2
¥Rotation i}
YRotation i}

@
@
L
L
L
ZRotation i 00:01:57.23
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Updating Values

When an element is bound to a parameter, either the parameter or the element will inherit
the value from the other. A parameter with no value will inherit the value of the object it is
first bound to. Conversely If a Parameter already has a value, when bound the Object it is
bound to will inherit the Parameter Value instead.

Macros and Parameters

Macros can be used to create, edit and delete parameters. This can be very useful when
content is shared to new machines that don’t have the parameters already configured, and
will ensure the Name of the Parameter is consistent as it is referenced in the Data Objects.

Macro to add a Parameter to the list
'Fetch the Parameter List
Set PList = ActiveCanvas.Scene.GetParameterList
'Add the listed parameter
PList. AddParameter "Test Parameter" , "Here is the Value"

Macro to edit a Parameter with a Pop Up to ask operator for new

value.
'Fetch the Parameter List
Set PList = ActiveCanvas.Scene.GetParameterList
‘Set the Parameter
Set Param = PList. GetParameterByName("Test Parameter”)
'‘Create an input box to ask for the new value
a = InputBox ("Enter New Value Here")
'Display the value back to the operator to check
msgbox a
‘Change the Test Parameter to the new entered value
Param.Value = a

Macro to delete a Parameter to the list
'Fetch the Parameter List

Set PList=ActiveCanvas.Scene.GetParameterList
'Remove the listed parameter

PList.DeleteParameter "Test Parameter”

Using Parameters as Data Object Queries or Source

A parameter can be used to in the place of a query or a URL in the Data Object.
Application and Scene parameters can be used. The syntax follows:

For a Scene Parameter - {Scene::ParamName}
For an Application Parameter - {ParamName}
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Using a Parameter in the Place of a URL

E& Add x Remowve

Mame Value

AirportCode hitp /w1 weather.gov. sml/cument_obs/display php Tstid=KJFK

— e —

. Source

[@] Web 45 Back
URL { '{scenenflirportCode} }
Table web "

web/current_obsenvation
web/current_observation/copyright_url
web/current_observation/credit
web/current_observation/credit_LRL
web/current_chservation/dewpoint_c
web/current_cbservation/dewpuoint_f

-
D et e S i i T et R T

Using a Parameter in place of a portion of a query

Parameters a E

Keyframe Graph | Playlist Parameters |Timeline |

lf} Add x Remove

’ MName Walue
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Filter =
Column Edit
) Use All Rows

) All Rows Where Column

@ Custom Query

~ |is

message/ Title/Medal Count/Medal_Count_Listing "\a‘ledal_Count_Country:'{Scene::CountryParam}']
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Playlist

The Playlist is composed of a list of messages to be played out with parameters that control
the playout of each item. When a message completes playout, the Playlist proceeds to the
next specified message.

The playlist plays scenes to the output(s) from a single control. Playlists can be automated
or controlled manually. Additionally, they allow for adding prebuilt animation Effects between
messages.

When used in conjunction with MOS newsroom applications, a Playlist can be remotely built
and edited. If necessary, Playlist execution can be manually overridden.

Playlist? - Stonped | Current Take Line: 0 | Current Air Line: N/A

| Channel | File Name | 22:29:47:18

Line | Control | Parameter | Effect |Speed

| Stop |

TC Relative To

Configuration

wlo|~w ol |bs|lw mie|o

A Playlist can consist of up to 500 lines. Each line specifies the playout parameters of a
Lyric message, including file name, Output Channel and transition effect.

Opening a Playlist

1. Navigate to File > Open

2. Navigate to the .ply file

3. Click Open.
If a Playlist pane is already opened, it will populate. If not, Lyric opens the pane and
populates the playlist.

Line | Control | Parameter | Effect |Speed |Channel| File Name: | [22:44:32:07

| 0 Timecode 00:00:00:00 - i I:\Project Folder\Messages\Mews\10_Breaking Mews. lyr =
| 1 Delay 00:00:00:00 - i I:'\Project FolderMessages\ews\100 _Live Bug.lyr D
| 2 Wait For Key H I:\Project Folder\Messages \News\200_Lawerthird.lyr _
. 3 Wait For Key I : I:\Project Folder Messagesews\300_Headshot. lyr | AL

4 Goto H : I:'Project Folder Messages\Wews\5_Clock_and_Weather. lyr [ TC Relative To

5 GPI H I:\Project Folder\Messages ews '\ 700_Bullet Points. lyr

& Loop 000,000 1 Configuration

7 skip [ ]

8 =

9 [ e

Playlists have their own folder in Lyric's Default Project Folder.
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Clearing the Playlist
1. Right Click over the Playlist Lines.
2. Select New Playlist.
3. Alternatively, open a new playlist file.

Saving a Playlist

1. Set focus on the Playlist pane.

2. From the File Menu select, Save As.
The playlist saves as a .ply format.

Navigating the Playlist

Click the Line number to highlight an entire line.

Right Click in the line area to invoke the contextual menu. This allows the list to be edited.
Lines can also be a manipulated using the shortcuts in this menu. Details about New
Playlist, Effect Properties and Set as Default are detailed further in this document.

1_ ew fi
1_ Undo Ctrl+Z E
Z Cut Ctrl+X E
| Copy Ctrl+C E
1_ Paste Ctrl+V %
= Delete Del -
| Insert Ins
— Apply Ctrl+A  —
= Add Offset Ctrl+0 S
Swap Ctrl+W

Effect Properties

Set As Default

Use the cursor keys 1|«— to navigate. When using the «— — keys to navigate and the
cursor reaches a field that accepts text entry, the cursor steps through the text before
proceeding to the next field.

When the cursor is in a Line, Control, Effect or Channel field, press Page Up or Page Down
to navigate up or down in five-line increments.

Press Home to move to the top of the playlist. End moves the cursor to the next instance of
an End control, or to the final line of the Playlist that contains an entry.

The Take key can be assigned to a hotkey via Configuration.

The Playlist scrolls when in use, based on a fixed number of lines or a percentage. This
value is set in the Playlist Configuration dialog box.

Esc halts playlist execution and exits the Playlist.
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Playlist Columns

B Current Message on Output Indicator

The currently displayed message in the Playlist is indicated by the green square B located
at the left side of the Playlist. During playout, the indicator proceeds line-by-line through the
Playlist.

During Playlist execution, the Playlist automatically scrolls to display upcoming events.

M Current Take Line Indicator

The Current Take Line Indicator Il identifies the Playlist line that will be executed next.
When a line is executed, the Current Message on Output Indicator moves to the same line
as the Current Take Line Indicator, and the two indicators are briefly positioned on the same
line M . The Current Take Line Indicator then moves to the following line.

The Current Take Line Indicator can be moved to a different line using one of the following
methods:
e Click to the left of a line.
e Ctrl + 1 or Ctrl + | to move the Current Take Line Indicator up or down in one-line
increments.
e Ctrl + Page Up or Ctrl + Page Down to move the Current Take Line Indicator up or
down in five-line increments.
Ctrl + Home to move the Current Take Line Indicator to the first line of the Playlist.
Ctrl + End to move the Current Take Line Indicator to the next instance of an End
(control event) or to the final line of the Playlist.
e Trigger a GPI to move the Current Take Line Indicator up or down in one-line
increments.

Line
The number in the Line column identifies the Line number for each event on the Playlist
from 0-499.

Control

Control determines how the message is triggered. This field cannot be set until a File Name
field is entered.

To select a Control, use one of the following methods:
e Click the Control field, then the Spacebar to toggle through the Event options.
e Press the first letter of the name of the Control.

Types of Control:

e Wait for Key pauses the playlist until the user presses any key, excluding Esc. The
Status Bar displays the prompt “Waiting for Keypress” until a key is pressed to
execute the message. Wait for Key does not use a Parameter setting. Pressing the
Esc key stops Playlist execution.

e Delay pauses after the completion of the execution of the previous Line for a
duration set in the parameter column. The current line is then executed after the
specified Delay duration.
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e Loop causes the Playlist to return to a line specified in the Parameters field for a
specified number of iterations. Two values are entered in the Parameters field. The
format of the field is 000,000. The Line number to which the Loop should return is
entered in the three-digit area to the left of the comma. The iterations, or number of
times the message should loop, is entered in the three-digit area to the right of the
comma.

In the following illustration, Line 5 loops back to line 4, and repeats this loop 3 times,
as specified by the Parameter setting 004,003. List execution resumes after the
specified number of loop iterations.

Line | Control I Parameter I
0 GPI
1 Timecode 00:00:00:00
2 Delay 00:00:00:00
3 Wait For Key
4 Delay 00:00:00:00
5 Loop 004,003

Timecode specifies a Timecode at which to trigger the execution of the line.

Skip causes the Playlist to skip the Line on which it appears, and move to the next

line.

e End control causes the Playlist to halt and the Current line indicator to return to line
0. Aline containing the End control is automatically added after the last valid line in
the Playlist. Any Message listed in the “File Name” field on the same line as an End
control is not played to output.

e GoTo specifies a skip to a specified line in the Playlist. The line number is entered
in the Parameter field. Any Message listed in the “File Name” field on the same line
as a Goto control is not played to output.

e GPI The Playlist can trigger output of a GPI to an external system, or cause the

system to await input of a GPI signal before continuing with subsequent events. It is

recommended that a GPI, which is already assigned as a Global GPI, not be
assigned to trigger a Playlist event, as it could cause a potential conflict. Set the

GPI number in the Parameter field.

A number of the Control functions require additional Parameters, such as number of Loops,
Delay duration, Timecode times, etc.

Effect
Effect sets a transition effect that executes at the beginning of the message.
e Click inside the Effect column on the desired line,
e Right Click and Select Effect Properties, or press the first letter of the name of the
Effect.

Playlist Effect settings override Default Effect settings specified in the Config menu.
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File Name

File Name specifies the file to be recalled. Accepted files are Lyric files and Auto
Executable Macro files saved as .lyr.

Files other than graphics and Macros files that have the .lyr extension, such as Default
Effects, should not be used in a Playlist. Macro files with the . Imx extension can not be
used.
Entering Files in the Playlist
To enter a File Name, choose one of the following methods:

e Type the File Name and include, if necessary, the full filepath.

e Drag-and-drop the file from the Browser or a Windows Explorer-type window. The

full filepath is automatically entered in the File Name field.

After the file name is entered, the Enter key advances the cursor to the File Name field for
the next line.

Recalling Numeric Messages from the Default Message Path

If the File Name is completely numeric, (no decimals or other symbols or letters) only the
Message Number needs be entered. The leading zeros and the extension can be omitted.
Example: 35849.

Numbers must be entered from the keyboard, not the number pad.

If the File Name is alphanumeric, (contains numbers and/or symbols and/or letters), only the
File Name and the extension must be entered, not the entire filepath.
Example: 2003_Sports_Intro.lyr

Recalling Messages from a location other than the Default Message Path
If the File Name is completely numeric (no decimals or other symbols or letters), the entire
filepath, including leading zeroes, must be entered.

Example: [:\\News_Graphics\000358490.lyr

If the File Name is alphanumeric, (contains numbers and/or symbols and/or letters), the
entire filepath must be entered.
Example: |\ News_Graphics\Election_Coverage Opening.lyr

Channel

Channel specifies the output channel on which the effect will execute. Type the desired
Channel Number to assign.

If a Channel is not assigned to a Playlist line, the message does not play to output!
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Timecode Display Indicator

The Timecode Display, located at the top right of the Playlist, displays the current Timecode.
The Timecode is by default, time from the system's or PC's clock, unless the system is
connected to an external source of Timecode. To use an external Timecode source, the
ChyronHego hardware must be configured.

Playlist Buttons

Ll executes the entire playlist at the location of the Current Take Line Indicator.
Take

A keyboard shortcut can be set to execute a Take.

In the Take Keyboard Shortcut area, enter a key in the Key field. F5 is the default setting. If
desired, select (click) the Ctrl, Alt and/or Shift checkboxes.

Clicking Take preloads the next message in the Playlist. Clicking Take again plays the
message to air as programmed in the Playlist, and simultaneously preloads the following
message. The Take button behaves like the Read Next function.

Typically, when using Take to move through a Playlist, the Control specified in a Playlist line
should be Delay set to 00:00:00:00. This means the message executes to air immediately
when Take is clicked.

The Take button appears red until clicked the first time.

If Play is used to execute the playlist, Take cannot be used unless Playlist execution is first
stopped by pressing the Stop key. When the Take button is unavailable, it is grayed out.
The Take button is also grayed out when a Playlist line is in progress, or the system is
waiting for a Keypress.

- The Take button appears green when it becomes available for use.

$|The Take button appears yellow when Cue Clip is enabled, and a Clip
programmed into the Playlist is ready to play. Refer to Playlist Configuration, later in this
section , for information on Cue Clip.

The Take button can be assigned a GPI Shortcut or a Keyboard Shortcut, eliminating the
need to use the mouse to execute a Take during execution. Refer to Setup Take later in this
section , for details on setup.

Ll halts Playlist execution. Playlist execution can be resumed at the current
Line by pressing Play or Take. The Stop button is available only when execution of a
Playlist line is in progress. It otherwise appears grayed out.

A Playlist can also be stopped in order to read messages that are not in the Playlist.
Playlist execution can be resumed as just described.
TC Relative To

See Using Timecode in a Playlist below for details.
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Playlist Configuration
Playlist parameters (such as GPIs, Take hotkey, default settings and other options) are set
in the Playlist Configuration dialog box, which is accessed by clicking the Configuration

button.
F ™
.
Playlist GPIs Take Keyboard Shortout
I_.ine g GF‘I:.. Key E
l v| | MoValid GPIs Available .
: ] el
Line Dowen GPT:
; : 7] alt
| | | Mo valid GPIs Available
; T [] shift
Take GFI
—mm 1 Clip Player Options
+ [ Mo Yalid GPIs available
3 [ cue Clip
Default Playlist Line
e s e T e
Scroll Offset Preview Options
_5(_]_ @ Lines ["] Enable Preview
() Percent i oK, ] [ Cancel ] ,
|:| Auto Preview
A
|
I
Playlist GPIs

GPls can be used to move the Current Take line up or down, and to execute a Take. Before
a GPI can be specified in the Playlist Configuration dialog box, it must be configured via
Config > Hardware.

Once the GPIs have been configured, it can be specified in the Playlist Configuration dialog

box.
Flaylist GFls
Line Up GPI:
1 - Playlist Line Up
Line Down GPI:
2 ne Playlist Line Diovn
Take GFI:

3 = Playlist Take

e The Line Up GPI moves the Current Take Line Indicator up one line.
e The Line Down GPI moves the Current Take Line Indicator up one line.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 146

e The Take GPI executes a Take at the line at which the Current Take Line Indicator is
positioned.

Clip Player Options

Cue Clip enables the first frame of a clip to display when a message containing the clip is
read from the Playlist using the Take function. The clip behaviour however is best controlled
via the Clip settings settings within each message.

Default Playlist Line

To facilitate the setup of Playlist entries, default values can be set for Control, Parameter,
Speed, Effect and Channel. A default setting can be set or modified for one, more than one
or all parameters. The Default Playlist Line area in the Playlist Configuration dialog box is
composed of display-only fields that cannot be edited from within the dialog box.

To set default values for the Playlist:

1. In the Playlist, enter a filename in the File Name field. The File Name can be typed,
or dragged from the Browser or a Windows Explorer-type window. A file name must
be in the File Name field in order for the default setting to be saved.

2. Set the Control, Parameter, Speed, Effect and Channel parameters as desired.

3. Highlight the desired columns, If setting or modifying all parameters, click the Line
Number of the line from which the parameters are to be saved. The entire line
should be highlighted, Or hold down the Ctrl key while clicking the desired columns.

4. With the columns highlighted, Right-click to display the Playlist context menu.

5. Select Set as Default. Whenever a new file is added to the Playlist, the default
settings automatically populate the fields.

Scroll Offset

When the Playlist executes, the Current Message on Output Indicator and the Current Take
Line Indicator progress through the Playlist. The view of the Current Take Line, i.e., the line
that is to be executed next, can be set to display a set number of lines from the top of the
Playlist, or as a set percentage of total lines from the top of the Playlist.

For example:

If the Scroll Offset is set to 4 lines, then the Current Take Line Indicator always displays at
the fourth line from the top of the Playlist.

If nine lines are currently displayed in the Playlist, and Scroll Offset is set to 30%, then the
Current Take Line Indicator displays at third line down from the top of the Playlist.

Preview Options
Enable Preview:
e When Enable Preview is active (checked), the Playlist transfers the display frame of
the message to the Preview Channel when the message is read to the Canvas.
Auto Preview:
e When Auto Preview is enabled (checked), automatically loads the next message in
the canvas when the Current Take Line Indicator changes position
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e \When Auto Preview is disabled (unchecked), does not automatically load the next
message in the canvas when the Current Take Line Indicator changes position

Using Timecode in a Playlist
Timecode can be referenced by the Playlist in three different manners:

e System Timecode - The Playlist line executes when the System Timecode
matches the Timecode specified in the Control Parameter. To execute Playlists in
this manner, TC Relative To should be disabled (unchecked).

When the TC Relative To checkbox is unchecked, the Timecode is the same as System
Timecode. The Timecodes Relative To dialog, when checked, allows for 2 options:

e Relative to Play - The Playlist sets its own starting timecode as 00:00:00:00 for
each execution. All Timecode Control Parameter settings within the Playlist are
calculated from the 00:00:00:00 starting timecode.

o Relative to Start Time - The Playlist adds the Start Time set in the Timecodes
Relative To dialog box to all of the Timecode Control Parameter settings in the
Playlist. The Playlist waits for the System Timecode to match the recalculated
Timecode in each Playlist line that has a Timecode Control before executing the
line.

[ Bl
Timecodes Relative ... M

) Play

[ ok || cancel ]m

To set a Timecode Control for a Playlist line

1. Atthe desired line, select Timecode in the Control field.

2. In the Parameter field, enter the Timecode at which the line should execute.

3. When the Playlist is executed, the line executes at the point where the System
Timecode matches Timecode as set in the Control field, or it reaches a specified
relative Timecode as set in the TC Relative To area at the right of the Playlist.

If Timecode is set 5 minutes or less ahead of the current System Timecode or specified
relative Timecode, the line executes immediately when it is reached.

If Timecode is set earlier than 5 minutes ahead of the current System Timecode or specified
relative Timecode, the line delays execution until the System Timecode matches the set or
relative Timecode.
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Playout Panel
Opening the Playout Panel

Navigate to View > Playout Panel. The Playout window is displayed:

Playout B

Frame Buffer 1

Transitions for 400 - (Lowerthird)

Opening Playout Tools

Navigate to View > Toolbars > Playout Tools. The following window is shown:

xwer <« (EEH| re2

When using multiple frame buffers, ChyronHego recommends incorporating the playout
tools in conjunction with the playout panel in order to playout messages across all frame
buffers in the system. The below shows the Playout Tools docked within the Playout Panel.

Playout E

. XFER HFBZ

Frame Buffer 1

Transitions for 400 - (Lowerthird)
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Controls On the Playout Tab

The Playout Panel contains Transfer and Play buttons, as well as groups for each available
frame buffer and a group detailing the available Transitions in the currently selected
message.

Playout =

. XFER 4 FB1 '

Frame Buffer 1

Frame Buffer 2

Transitions for 45 - Game Show Score

| Defak | | EfectOu | [ OFF |

| ON | [ Resetway | |Update Aw..|

| Update Aw... | | Reset Home | | Update Ho... |

| Update Ho... | | TimerOFF | | TimerON |
| Efeath | [ GPI | | TimerStan |
Play Button

The play button sends a message from the Canvas to the output. Play uses the Effect In
transition (when available) or the Default transition.

The Play button toggles to Stop, and changes to red, once a selected message has been
played. Stop ends the message rendering/playing on output. It does not remove it from the
output.

Transfer Button

The transfer button sends a message from the Canvas to the output via the Default
transition, but does not render it (i.e. not playing). Likewise, a message that is on output
can be transferred back to the canvas. Again, the message is delivered back to the Canvas
and does not play its Effect Out (if available).

Frame Buffers
Each button inside a frame buffer group is labeled with its corresponding message. A
message is selected by clicking the desired frame buffer, and then clicking the desired
message button.
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Available Transitions

When a message is selected, all transitions defined for that message are displayed. A
Transition is triggered by clicking on the desired Transition button.

The order of the transition buttons directly relate to the order that they are displayed in the
Timeline Editor.

:I Effect Out I

Add Transition
Rename Transition
Delete Transition

Copy Transition

Prevent Reactivations

Show on Playout Panel

Shortcut @ MN/A [

Any Transition in any of the active messages can be executed, in any order, using these
buttons.

Message Color Code

Red = On Output

Green = On Canvas

Yellow = Message Pause State
Black = No Framebuffers

Frame Buffer 1 Frame Euffer 1 Frame Buffer 1

Transitions For 400 - (Lowerthird) Transitions For 400 - {Lowerthird) Transitions For 401 - (Lowerthird)

Buttons shown in red are on the system's Output, and those in green are on the Lyric
Canvas.

A message whose playout has reached a programmed pause will show yellow for the
duration of that Pause. An animation can be resumed by clicking the Yellow button.

Buttons marked "Untitled" indicate an available blank or unnamed Canvas.
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Rendering

Rendering settings allow the user to determine exactly the way an object in a Lyric
composition is rendered.

Rendering E
3D Object = Bar AS

4 Blending
Default -
4 Back Faces
Enabled Dizabled
4 Lighting

Enabled Disabled

Separate Specular

Enabled Disabled

4 Polygon
Display Mode
Wireframe Paints
Winding
Clockwise I Counter Clock
4 Anti Aliasing
on on
4 Object Intersection
Drepth Testing
Dizabled .
Depth Writing

Enabled Disabled

Compaosite Transform

Enabled Disabled

Blending

The interaction between color and alpha values of objects on the canvas can be handled in
several ways by different Blending functions.

In each of the illustrations below, the teapot in the foreground is being added to a scene
containing existing content, using the different Blending methods.
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The blending options available are Default (none), Additive, Subtractive, Reverse
Subtractive, Multiplicative or Reverse Multiplicative.
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Backfaces
This option allows the operator to limit Lyric's allocation of resources for the complete
rendering of 3D objects, 3D characters, 2D text, imported bitmaps and Media.

Any of these objects can be manipulated on X, Y and Z axis in Lyric's three-dimensional
workspace. Therefore, certain surfaces of an object may move in and out of view within a
composition. Where rear surfaces of a given object are not seen in a composition, the
operator can save computational resources by disabling the Draw Backfaces option. All
objects have back faces disabled by default.

T
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Lighting

Lighting determines if the global and individual light sources affect the selected object.
When lighting is disabled, an object displays no reflected light from the Global light or the
Individual lights. The default setting is Enabled.

With Lighting enabled, 3D characters and 3D objects are affected by all light sources, global
and individual, in all circumstances.

With Lighting enabled, 2D text can be affected by only the Global light source, and 2D
bitmap objects can be affected by any of Lyric's light sources.

Separate Specular

This option is used primarily when textures are applied to 3D objects. With the Separate
Specular option turned on, Specular lighting effects are applied to the 3D object after the
texture is applied. (In other words, the application performs the calculations taking into
account the texture image)
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Polygon
There are 4 types of display modes:

e Solid - Displays 3D characters and objects in the normal manner.

e Wireframe - Displays the polygons comprising a 3D character or object. The
displayed outlines of the polygons reflect any colors and mapped textures intrinsic
to the unseen solid surfaces, along with current Shininess and Alpha values.

e Points - Displays only the mathematical points situated at the intersection of the
lines comprising each polygon.

The following illustration shows a 3D object globe rendered in Solid, Wireframe and Points
mode; we have modified the illustration to faintly show the polygons defined by those points.
Points mode actually displays only points.

e Winding - The triangles or quads comprising the front faces of three-dimensional
shapes in Lyric are, by default, drawn in counterclockwise order. The Polygon
Winding adjustment is used to correct imported 3D objects whose polygons are
presented to Lyric in clockwise order.
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Antialiasing

Antialiasing is another means of combating the 'stair-stepping' or 'jaggies' symptom
sometimes seen on 3D objects. Default leaves the state of the selected object up to the Full
Scene setting mentioned above. This setting affects the object currently selected in the
composition, as opposed to the adjustable Full Scene Antialiasing selections on the
Config>Canvas and Channel Settings menu.

Object Intersection

When Depth Writing and Depth Testing are enabled for the two rotated 2D bitmaps, they
intersect with each other and the 3D cube. There may be occasions where it is desirable to
set Depth Testing Enabled and Depth Writing Disabled for an object, depending on how
objects are to interact.

Depth Testing/Depth Writing

The Depth Testing setting determines if an object can be covered by another object when
the objects intersect in Z-Space. Normally, even if they are rotated in Z-Space, and points
on each object share the same Z-Position, 2D objects simply lie one on top of the other,
without intersecting.

If Depth Testing is enabled, then another object can cover the selected object.
If Depth Testing is disabled, then another object cannot cover the selected object.

The Depth Writing setting determines if the selected object can obscure another object
when they intersect in Z-Space.

If Depth Writing is enabled, the object is allowed to cover another object.

If Depth Writing is disabled, the object cannot cover another object, even if Depth Testing is
enabled on the other object.

For objects to intersect and order properly, both Depth Testing and Depth Writing should be
enabled.
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Depth Writing and Depth Testing are enabled for the two rotated 2D Images, as shown in
the following illustration, all objects intersect as expected.

Depth Writing and Depth Testing are disabled for the two rotated 2D Images, as shown in
the following illustration, there is no intersection between each of them and any other object.

However, if an object has an alpha component, enabling Depth Writing may unintentionally
prohibit objects behind the alpha object from showing through. In this instance, disable
Depth Writing or position the object further back on the Z-Axis until corrected.
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Composite Transform

Corrects the rendering order of objects in groups when the group transformed. When
Composite Transform is enabled/disabled on the group node, it is also applied to all the
objects contained within.

An example of when users may need to enable Composite Transform is when the objects
are rendering correctly if the group is rotated in one direction (transformed), but incorrectly if
rotated in the opposite direction.

This is due to the group of objects 3D spatial relationship being affected by the rotation (e.g.
objects that were behind now appear in front). In the below illustration, a group of logos
display correctly from the front view with no rotation applied, but, when rotated 180° to show
the back view, has issues with the alpha areas not displaying images behind. The second
illustration shows composite transform enabled, which corrects the issue.
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Rendering Order

Rendering order can be manipulated to suit the desired appearance. Rendering order can
become particularly applicable when items with transparency overlay opaque objects. Lyric
must render all screen pixels in a determined order. So the when objects occupy the same
pixel, priority needs to be determined. When transparent pixels are rendered before opaque
pixels, the result is the transparent area cuts through the opaque area.

There are two ways Lyric rendering order is determined.

1. Scene Graph order. When two objects are at the same position on the z-axis, Lyric
renders objects in Scene Graph order from the bottom to top.

2. Z-axis as soon as objects are positioned along the z-axis at different positions, the
rendering order is determined by the the z-axis from the back of the scene to the
front. In other words, the objects are rendered in order from farthest to nearest the
camera.

The more complicated the composition the more likely it is that rendering order will be
determined via the z-axis

The example below shows a 2D image with transparency (alpha) and a 3D Cube. They both
occupy the same position on the z-axis (-2.000). The 2D image is being rendered before the
cube resulting in the area behind the image not being rendered. This gives the appearance
of the image cutting a hole in the area the cube occupies behind it.

. Transform E.I

Image = MysteryMan
40padity
Ao |3

AXYZ

Position

| %0000 [2 voooo [z 2000 2

Rotation
| x o000 [ v oo z 0000 [2]

Scale

X 1000 3 v 1000 (2 zZ 1000 [2@

Center

%0000 (2] voooo [2z o000 [

LMR TMEB FMEB

Both methods are demonstrated below.
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Scene Graph - To render the cube before the image, drag the image above the cube on the
Scene Graph. This results in the rendering order to be cube, then image.

orm EI
4 Opacity
Aoz 2
MName - | 1 .k AXYZ
i | : . Position
'- x 0000 [3 vyoooo [z -zooo &
7]y Global Light = Rotation

%0000 2 vooo0 %]z o000

| Scale

L] x1000 B vicee Eziew E@

Center

X 0000 [3f voooo [5]zooo0 [

LMR TMB FMEB

Z-Axis - To render the cube before the image, position the cube further back on the Z-axis.
Here it is moved to -2.002. This results in the rendering order to be cube, then image. At
this point the Scene Graph order becomes irrelevant.

Scene Graph

Mame - I

Position

x 0641 [ v 007 [ z ENOH [

Rotation
x 0000 [ v 28000 [+ 2 0.000 [2]

Scale

x 0433 [ voa3 [ zoan E@

Center

X 0000 [5 ¥ 0000 (5 Z 0000 (2

LMR TMEBE FMEB

IMPORTANT - Grouping does not affect rendering order. It is determined by node position
only. So in order to force rendering order, without compromising an object's position in
relation to other objects, position the object to the desired z-axis value (in order to render in
the desired order), then use a group to position it back to compensate for the adjustment.
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Scene Assets

Scene Assets allows the user to view and manage all assets contained within the Lyric
Message. The list indicates both existing and missing elements or fonts. Important file
details are also listed, including the file path, how many times it is used and which elements
reference it in the scene. Files can be located, moved, refreshed or replaced, exported to
Camio or synced to HubDrive when configured. Fonts can be viewed and located as well as
exported to Camio or synced to HubDrive when configured. (Camio Export is not yet
available)

Opening Scene Assets
Navigate to View > Scene Assets.

Scene Assets -I\2017 Lyric Sports - SandyZeonPablo.lyr EI

@ Export To Camio - @ HubDrive ~ |o Scene &AII Assets
MName Type Folder Used Count References Size Modified
Missing Files
0 scenegraph.png PNG image cwusershchyronhego'\pictures 1 ScenelGraph
Existing Files
e pablo sandoval.png PNG image 2017 yric sportsimages’teamel... 1 Pablo Sand... 558 KB
& refresh_16.png PNG image hyronhego\documerts 1 refresh_16 45 B
Q sandy leon.png PNG image 7 hyric sportstimagesiteam el... 1 Sandy Leon 1MB
Existing Fonts
True Type fort file C\Windows'\Forts 30 Templat

Details
e Name: The file name of the asset.
e |con: Indicates the state of the asset.

0 Red Cross Icon indicates the assets is missing.

o Green Check Icon indicates:
- Asset exists (HubDrive not running)
- Assets exists and in HubDrive Sync Folder( HubDrive running)

TN Yellow Warning Icon indicates HubDrive is running and asset not in sync folder

e Type: The file type of the asset.
e Folder: The complete path to the folder containing the asset.
e Used Count: The number of times this asset is referenced in the scene.
e References: The names of all nodes in the scene that reference the asset. The
tooltip lists all nodes, surfaces and texture layers the asset is used on.
References N
Ab Mask Cube:FRONT:0
Cube (6) | Sphere (2) |aNs  [REELELZAEEY
Cube (6] Cube:LEFT:0

Cube:RIGHT:0
Cube:TOP:0
Cube:BOTTOM:0
Sphere:Outside:0
Sphere:Inside:0
ANA:Image:0

e Size: The file size of the asset.
e Modified: The last time the asset file was modified.
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The Red Cross or Green Check icons will update automatically should the asset state
change on disk (i.e. existence). Icons will also update if HubDrive status or sync folders are
refreshed.

Selecting Assets

Selecting a row in the asset list will automatically select all nodes in the Scene Graph that
are referencing the selected asset.

Single or multiple files can be selected and the path or containing folder path located or
redirected. Multiple items can be selected via typical Windows methods such as Shift or Ctrl
+ left click or by clicking on the corresponding asset title i.e “Missing Files”.

Managing Missing Assets
The Missing Asset context menu is evoked by right clicking on the selected asset/s

MName Type
Missing Files

ﬁ channel news logo* Trza Gl
Existing Files Find File

@ aa mask.tga Cpen File Location

@ asp flare 01.tga Change Folder Path

@ flare 300mm zoom 02 smallZ.tga TGA File

e Find File: Allows the user to browse for the new location of the file. Alternatively, the
user can browse for an entirely new asset altogether to replace the missing one.
This option is not available on missing font assets, as they need to be installed.

e Open File Location: Opens an explorer window in the folder that the asset would
have been located (indicated by the ‘Folder’ column).

e Change Folder Path: Allows the user to select a new folder where the asset/s
exist. This is similar to ‘Find File’ but rather enables just selecting a new containing
folder. This option is not Available on Missing font assets, they are only available in
Windows Font folder.

Managing Existing Assets
The Missing Asset context menu is evoked by right clicking on the selected asset/s

£ doublee.. TGAFie i-chyronhego lyric demo‘images'news
@ double e... TGAFIe i:\chyronhego hyric demo‘images news

r\images‘news

Change File .
phimages news

Open File blimages'news
Open File Location bimagesnews

Missing F
£ Klavika

Existing f Move To HubDrive Folder
g arial.ttf TueTyp... CWindows'Fonts
6 klavikam... OpenTyp... C:‘Windows"Fonts

Change Folder Path

Mave File

3

e Change File: Allows the user to browse to new file in order to replace the existing
file. This option is not available on Existing Font assets, they cannot be swapped
with a different font.

e Open File: Will open the file with the default viewing application, for example
Windows Photo Viewer.
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Open File Location: Will open the containing folder and highlight the asset.
Change Folder Path: Will attempt to discover the asset at the new path. If the
asset is there, the asset path will be changed to the new folder (this does not move
the original asset). This option is not available on Existing Font assets, they are only
available in Windows Font folder.

e Move File: Moves the asset file to the newly specified folder. This option is not
available on Existing Font assets, they cannot be moved from Windows Font folder

e Move To HubDrive Folder: Moves the asset file to the selected HubDrive Folder
configured as the “Move To HubDrive Folder’ Menu item.

Exporting to Camio (Not currently supported)
Export to Camio becomes available on the Scene Asset toolbar when Camio servers are
configured. Assets can be sent directly to the Camio via the dropdown menu.

Syncing to HubDrive
[El

.0 Scene /14 All Assets

HubDrive allows control of syncing scene assets across devices. The menu is located on
the Scene Assets toolbar.

fﬂ‘ HubDrive Green check icon indicates that HubDrive is connected.

Fﬁ HubDrive Red Cross icon indicates it is not connected

HubDrive Dropdown menu items:
e Sync Scene: Syncs the scene and its assets to HubDrive. This option is disabled if
the scene is not saved or HubDrive is not running
e Sync Folder: Lists all the sync folders. Clicking on a SubMenu Item, opens the
sync folder in explorer.
o Refresh: Updates HubDrive state and Sync Folders

Scene:
The Scene Indicator alerts the user about the Scene status. The indicator is disabled when
hubdrive is not running or the scene is not saved.

@ Green Check indicates Hubdrive is running and scene is in HubDrive sync
folder

a9 Red Cross indicates the currently open scene is not in HubDrive sync folder
All Assets:

The All Assets Indicator alerts the user of the overall synchronization status to HubDrive.

@ Green Check indicates no assets are missing and all assets are in HubDrive
sync folder
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a Red Cross indicates assets are missing or all assets are not in HubDrive sync
folder

Scene Graph

The Scene Graph is a list of all objects in a message/composition. It is used for selecting,
filtering, renaming and ordering all nodes in a Lyric composition.

Opening the Scene Graph

Navigate to View > Scene Graph.

The creation of a new scene is automatically accompanied by the creation of a Scene
Graph. This includes a Camera, a Global Light source and one movable Light Source .

Scene Graph @
==
Mame hd
O [Light1 |
'/ Global Light
B4 Cameral

Objects are added to the Scene Graph via the Tools Menu and the Object Toolbar.

The illustration below shows objects added to the Scene Graph. The icon next to the object
node helps to identify the object type.

Scene Graph a @
=5
Mame -

4 B | Media—-A20007.avi |
O Light2
ﬂ Palygon
bl frame_small
[, 3D Template 1
8k Pod
O Light1
'y Global Light
ﬂ Cameral

The checkbox next to each element determines if the object is active in the canvas (and
accessibility for editing). Unchecking an object makes it not visible, or inactive (for objects
that are not visible such as Data Object/Triggers) in all transitions. The exception to this is
mFX Objects which can be made active/inactive per transition.
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Filtering

Scene Graph n &

R
Type - ~ N

Top Group |
Hilite Top Left 1
Hilite Bottom Left 1

Away Color Hilite

Home Colar Hilite
Home City Mame Text
#\, Home Nickname Text
Away City Mame Text
?31'[;. Away Nickname Text
Sports Lower Flare 01

ARANANAN NN

+ Title
+ Bottom Live Bar
1, Light1

Global Light

Bad Camera

Filtering gives the user the ability to find items in complicated scene graphs. The
drop-down menu allows items on the Scene Graph to be filtered by Name, Type or
Property. Iltems matching the filtering criteria are shown in bold. To disable all filtering click
the box to the right of the filtering controls.

ey sy

Filter by Name
Filters on all, or part, of the node name.

Filter by Type

This option specifies the node type. When filter by the type of object, the user selects from
the asset types in the dropdown list. The filter node types are: 3D Text, 2D Text, Image,
Media, 3D Object, 3D Primitive, Video Object,Group, Data Object, Trigger Object,
Flipbook, Light, MFX.

Filter by Property
This filters items based on a property that is enabled on the node. The available properties
that can be filtered are:

e Auto Hidden - node is auto-hidden if a template is empty.
e Auto Followed - node is a reference for an auto-follow node.
e Auto Following - node is following another node.
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e DB Linked - node is DBLinked. This means the image, 3D text or 2D geometry is
linked. Any surface texture is linked, or for 2D text windows, any 2D template is
linked.

e DO Linked - node is a target of any of the Data Objects in the scene. This means
the image or 3D text is linked. Any surface texture is linked, or for 2D text windows,
any 2D template is linked.

Mask Source - node is nominated as a mask source
Mask Target - node is nominated as a mask target

Preview Only Nodes

Accessed via the right-click menu on a selected node, Preview Only will ensure the node is
visible on the canvas only as a preview and is not rendered to the output. This can be
applied to any visible node such as Text, Media, 3D Obijects etc. The option to disable
displaying preview nodes can be set in Preferences>CG Preferences ‘Show Preview
Frame’.

Color Coding Nodes on the Scene Graph

Any object can be color-coded on the Scene Graph to help with identification and
organization. Via the right-click menu, select Color Code and then select the desired color.

Renaming Scene Graph Nodes

Object names are changed in the Scene Graph by double clicking, as well as from General
Properties > Node Name.

To rename multiple objects quickly in the Scene Graph highlight the object name in the
Scene Graph. While it is highlighted, use the up/down arrows on the keyboard to skip to the
object above or below while the edit input box is still open.

Expanding and contracting Groups

Groups can be expanded and collapsed 3 ways

1) =5 The toolstop button, this will expand or collapse the whole tree
2) Right click on the +/- to the left of the node, this will expand/contract all descendents
3) Using the arrow keys on the keyboard. The — (left) collapses, — (right) expands.

Cut, Copy, Paste and Delete Scene Graph Nodes

Nodes can be moved, cut/copied and pasted anywhere in the scene graph, they will paste
above the node that is currently selected. They can be handled in multiples or individually.

IMPORTANT - All Copy and Paste functions should be done with the Default Transition
timeline active. A node can only be deleted, or cut, from the scene via the Default timeline.
If a Transition other than the Default is active when a node is deleted (or cut), then the item
will only be removed from the active transition, and still exists in the composition. When
objects are pasted into transitions other than the Default transition, the node will be
available in the Default transition, but the transform properties are set to default values and
opacity is set to 0.
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These functions are Windows functions, and are accessed via the Windows Toolbar (View >
Toolbars > Windows Tools), shortcut keys and also via the Edit Menu.

Shortcut Keys are often the quickest method. When using these functions in the Scene
Graph, the shortcuts for Cut, Copy, Paste and Delete are:

Cut-Ctrl+ X
Copy -Ctrl+C
Paste - Ctrl + V
Delete - Ctrl + Del

The Global Light and Camera are required in every scene, and can not be deleted.

Moving and Ordering of Scene Graph Nodes

Object nodes can be dragged and dropped up and down the Scene Graph respectively.
They can also be dragged in and out of groups individually or in multiples. This may be
done for ordering and display purposes.

Display Priority
Moving objects up and down the Scene Graph affects the object ordering on the canvas,
when those objects are positioned at the same value along the Z-axis.

When objects are positioned at the same value along the Z-axis, the priority for display (i.e.
which objects overlaps the other) is determined by the Scene Graph order. Objects that are
on top of the Scene Graph will appear above objects that are below them on the Scene
Graph.

Scene Graph

Mame

Positioning the objects on the Z-axis will override the Scene Graph priority display. See
Transform for more details.
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Scene Properties

The Scene Properties contains the editable properties of a composition/message/scene,
which include: Scene Info, Priority, Background, Preview Frame and Rendering.

To open the Scene Properties, navigate to View > Scene Properties. The following
window will appear:

Scene Properties n
4Scene Info

Name 2 Line Lowerthird

Description Lowwerthird
Persistent B 00

4 Priority

3 % Scene Order D Update In Swap
4linked Scene

[ Preview

4Background
(@ NoBackground

o =]
O color

4Preview Frame

Transition Frame Number
Default v | 00000105 5

4Rendering
2-Pass Rendering (Depth/ Blend)

[ Enabled I Disabled J

Legacy Z Ordering

| Enabled Disabled )

»Advanced Keyboard

Scene Info

e Name - The titles given to messages in this field are user-defined; however, they
are more than just an identifier for the user - Lyric identifies 'like' messages by the
name. Messages with the same name can 'update' between when aired
consecutively, instead of animating on and off. This is called Intelligent Transitions.
The name may also be used by Conditional Transitions to offer multiple ways for a
message to update dependent on the content and other configurable parameters.
Messages intended to directly replace each other via Update In/Out, or Conditional
Transitions, must have precisely the same text entered in this field. See Intelligent
Transitions. The Scene Name can also be used by other features in Lyric,
including: Triggers, Inherit State and Macros.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 169

e Description - This field may be used as a description for the user, as well as the
features that apply to the Name field. If the description has a value, that value will
take precedence over the Name value and will be displayed in the Scene Tree and
Playout Panel.

e Persistent - Selecting this checkbox causes the message to remain on Output as
succeeding messages are called up and played to output. Persistent messages on

Lyric's Scene Tree are designated with the 00 symbol. When Persistent is
unchecked, a succeeding message with a different name will automatically remove
any non-persistent message from output, and play the succeeding message to
output.

Priority

e Scene Order - Multiple Persistent messages can play on the Output simultaneously.
In this situation, some visual elements of multiple messages on the Output may
overlap; their priority determines which element is on top. Therefore, each message
intended for simultaneous display on Output can be assigned a Scene Priority. A
message with a Scene Priority value of '1' would be at the top, and one with a value
of "10"' would be at the bottom. When two messages have the same Scene Priority
value assigned, the messaged called up most recently is on top.

e Update In Swap - This setting is only relevant to messages intended to
replace/update another message that is already on Output. When using the term
'Update’ it refers to the Intelligent Transition updating capabilities inherent to Lyric.

In situations where one message is set to update with another via intelligent
transitions, Lyric's default operation is that the outgoing message's Update Out
transition has visual priority over the incoming message's Update In transition.
Selecting the Update In Swap option in the incoming message's 'Update In' taking
place in front of the outgoing message.

Linked Scene

A scene can be linked to another scene for simultaneous read and play to output. The
linked scene becomes tied to the parent scene for read and play operations only and
remains a separate scene for all other purposes.

Scene Tree E1| SceneTree al
[=)-o Canwas [=)-- Canvas
W 50() Quote - (Quote) o —
« Output ...00 Background - (Background)
200 Quote - (Quote) = Output
.00 Background - (Background) j— 200_Quote - (Quote)

00 Background - (Background)

Linked Scene on canvas collapsed Linked Scene on canvas expanded
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Use case: a foreground scene can have a linked background scene. They play
simultaneously to output appearing as a single scene, however the foreground scene can
be updated and removed from output independently while the background scene persists
for use with other scenes.

Enable Preview: The parent scene can enable the preview frame of the linked scene. This
combines both scenes for preview purposes.

4Priority
2 E Scene Order [ ] Update In Swap

4dlinked Scene

[I:\li...\Background Blue.lyr ] |

[~] Preview

Scene Hierarchy: The scene displays in a collapsed hierarchy on the canvas. After being
played to output the scenes are no longer tied to each other and are both displayed and
treated as separate scenes (see image above)

Scene behavior: As both scenes are separate on output. They Effect In, Update and Effect
out as per existing logic with one exception. The exception being that a parent scene and or
it's linked child scene can be non persistent. This allows either or both of scenes to be
replaced by an incoming scene but not removed by each other.

Scene Priority: If a parent scene and a linked scene share the same scene order priority
(see Scene Priority above) the parent scene will appear in front. It is best practice however
to put them on separate scene priorities to ensure they display and update as desired. A
parent scene and a linked scene cannot have the same name and description.

Removing Linked Scenes:: A linked scene can be removed by it's parent scene using
existing Lyric methods for example: assigning the same hotkey to the Effect Out, via an
Event Activation or Macro etc.

Editing Linked Scenes: To edit the elements of the linked scene the canvas hierarchy
needs to be expanded and the linked child scene selected and adjusted as normal. The
linked scene must be saved in order to retain it's changes. Saving the parent scene after
making changes to the child/ linked scene will not save the changes made to the child
scene. This is because the parent scene only saves the path of the linked scene to be
recalled. The child is an independent scene simply being recalled/referenced by the parent
scene. Note that it is not recommended or supported to link a scene that contains a linked
scene.

Macros and Linked Scenes: It may be desirable to update elements in a linked scene
hierarchy based on content from either scene. Macro’s that set and query parameters could
help achieve this. The order in which messages and embedded macro’s execute are: The
parent scene is read, it's onRead macro is run, then the child scene is read and its onRead
macro is run.
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Background

When adding backgrounds to Lyric messages, exercise caution. Backgrounds can not be
adjusted or animated. Additionally, they may cause issues with intelligent transitions.
Adding backgrounds is only recommended for messages that have no interaction with other
messages. The best practice is to add an object node so that can be manipulated on the
canvas as part of the Lyric scene.

e No Background - Select this option to remove a background. This is the default
setting.
File Picker - Select this option to specify a background file.
Color - Select this option to select a background color/ramp.

Preview Frame

Each message is created with a preview frame set to frame 0 of the Default transition. This
preview frame is ONLY used in the canvas preview, and has no effect on the output
animation. This preview frame can be modified if a different frame is desired to be
displayed when a message is recalled on the Canvas. Show Preview Frame must be
checked in Config > Preferences > CG Preferences > Options.

e Transitions - Specifies the desired transition for previewing.
e Frame Number - Specifies the desired frame of the transition that is to be shown as
the message preview.

Rendering

Rendering settings are specified for each individual node on a per node basis. The
Rendering discussed here affects the entire scene.

2 Pass Rendering (Depth/Blend)

With 2-pass rendering enabled, Lyric only renders the opaque objects in the composition.

2-Pass renders from the furthest object on the z-axis, to the closest object, and then again
from the closest object to the furthest. A 2-pass render may be used to correct any
rendering issues with overlapping objects, particularly those with transparency/alpha
channels. 2-pass rendering should be used when other techniques have not resolved the
render issue.

When 2-pass rendering is disabled, Lyric renders all pixels, including those with an Alpha
value of less than 100%, in order of farthest to closest. Therefore, the transparent pixels in
an object will obscure an object located behind it.
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Scene Tree

The Scene Tree gives the user a list view of the messages that are playing on the Output,
and messages that have been read to the Canvas. For this reason, it is made up of 2
components: Canvas and Output. When a system has multiple frame buffers, the Scene
Tree only reflects the Canvas and Output of the selected frame buffer. Multiple messages
can exist on the Output and Canvas.

Opening the Scene Tree

Navigate to View > Scene Tree.

Scene Tree
[ereveeen Canvas

------------ 500 - (Bullet Point)
- Output

-8 5 - [(Clock)

-4 100 - (Live Bug)

-0 200 - (Lowerthird)

e Canvas - Shows a list of all Messages currently available on the Canvas. Use +/- to
collapse/expand.
e Output - Shows all Messages currently active on Output. More than one Message

can be displayed on a single Output. The symbol G indicates that a Message
is persistent, as designated by the Scene Properties. Use +/- to collapse/expand.

Navigating the Scene Tree

Holding the Shift key while opening a message will add the new message to the Canvas
without removing the previously loaded message. The key combination Shift + Read
(ChyronHego Keyboard) or Shift + Enter is used to load multiple messages to the Canvas.

Users can use the keyboard to switch focus between the Canvas the Output by pressing
Ctrl + Alt + Change (ChyronHego keyboard) or Ctrl + Alt + *. With focus set, use the Up
and Down arrows.
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Status Bar

The Status Bar provides a live status update for many Lyric operations and software states.
The Status Bar is located at the bottom of the Lyric interface. It cannot be repositioned.

It is explained here in four segments: Left, Middle, Right and Far Right.

Left

The left of the Status Bar displays a description of each Toolbar icon as the mouse moves
over it, or the name of the currently selected object. In the below example, it shows that
Object 'Cube 1', which is a 3D Object, is currently selected.

| 3D Object ‘Cube 1' selected

The left side also displays status information such as Record confirmation, Delete
confirmation, Read Next Loaded, and VGA Preview, which are displayed in green in the
Status Bar. The following illustration shows a Record confirmation.

Additionally it displays when prompts (dialogue boxes) have been suppressed. See Enable
Modal Suppressor.

Prompt suppressed: The following 2 images for “Loweithird” could not be located: |
Middle

This area displays trigger prompts such as Paused for Keypress, Paused for Delay and
Waiting for Timecode, which are displayed in red and in the middle of the Status Bar. The
following illustration shows a Pause for Keypress.

Right

This shows the version of Lyric Software, operations and coordinate details.

YWerzion: 2.0 020 M L M5 “World: [ 0420 w0290 | Screen: [w 469, w 175]

M the letter M displayed here turns red during a Macro Record operation.

L Turns red when the Logger has been enabled.

MS Turns red when the Modal Suppressor is enabled.

World/Screen The XY coordinates of the currently selected object, are displayed in both
World and Screen coordinates. However, when a 2D Text Window is selected and the
cursor is on a row, the Row Number and the Screen position of the Cursor at it's current
location is displayed.

#EB20 Y:867 Fow:l

Far Right

To the right side of the Status Bar is a group of panes that displays the active/inactive status
of various functions. When the function is active, the pane displays black lettering. When
the function is inactive, the pane is grayed out. Number lock is also highlighted.
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TRH: cOL Lock car MBI ovr

Intelligent Interface

II-# indicates that no serial ports are available for Intelligent Interface connection.

II-1 indicates that Intelligent Interface is enabled for transmission on Serial Port 1.

I1-2 indicates that Intelligent Interface is enabled for transmission on Serial Port 2.

II-D indicates that Intelligent Interface is enabled for transmission on both Serial Ports 1 and
2.

II-T indicates that Intelligent Interface is enabled for transmission via Telnet.

Note: Does not apply to the Automation Plugin

Translation Mode (TRNS)

Allows typing of Alt characters in 2D text windows.

Press Ctrl plus - (minus) sign to type multiple Alt characters.
Press Ctrl plus = (equal sign) to type a single Alt character.

Tab Column Mode (COL)

Allows for the use of text in column editing and typing.

Press Alt + M or select Tab Column Mode from the Right Click menu on a 2D Text Window
to toggle on and off.

Lock Mode (LOCK)

Allows the locking of 2D text rows so that they shift as one group when applying ALT + up
and down arrow keys. It does not apply to shifts by clicking and dragging the 2d text row.
Press Ctrl + L to toggle on and off.

Caps Lock Mode (CAP)
When active, all characters are typed as uppercase.
Press the Caps Lock key to toggle on and off.

Num Lock Mode (NUM)

When active, the numeric keypad at the right of the keyboard types numbers.
When inactive, pressing the numeric keypad keys shifts cursor position,
activates/inactivates Insert Mode, or deletes the selected 2D text character.

Overwrite/lnsert Mode (OVR)
When active, a newly-typed character replaces the existing character. When inactive, the
newly-typed character is inserted at the cursor position without replacing a character.
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Surface Properties

The appearance of 3D Objects, 3D Text, Images and the Video Object can all be adjusted
via Surface Properties.

3D Objects Surfaces

Select the 3D object (Imported 3D Objects, 3D primitives or 3D Text) and from the View
Menu, select Surface Properties.

Surface

30 Object = Cube 1

Surface  All -

4 Material

Diffuse Specular Opacity  Shininess
100 65

Y Y

- -

4 Texture Layers

Add Texture (] Embed All

L
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Surface

A 3D object can be comprised of several individual surfaces. All the object's surfaces can
have their properties changed at once, or be selected individually for adjustment in the
Surface dropdown menu.

Imported 3D object surfaces are defined in the object’s creation software.
Surface &)

3D Object > Cube1l |

Surface m | i '
I

4 Material Cubel:Top
) Cubel: Btm
Diffuse  Cyubel: Left

Cubel: Right
- = (Cubel: Front
Cubel: Back

4 Texture Layers

Add Texture E| Embed All

Texture layers

Images have a single texture layer that can be manipulated. Texture layers for 3D
characters and 3D objects can be added to a Surface. As many as 4 Textures can be
applied to each individual surface.

3D object textures can be texture mapped with

e Images

e Media files

e 2D and 3D text

e solid or ramp colors
e video input (plugin)
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To add a texture layer - Click Add Texture in the texture layers window, then select the
texture type from the popup menu. The respective file open dialog is invoked.

Surface ::'*jﬁﬂacr
3D Object = Cube 1 _EZ3D Ohject = Cube 1
Surface  All - Surface Al -
«Material 4Material
Diffuse Specular Opacity  Shininess Diffuse Specular  Opacity  Shininess
L I Jw Hes B | | o0 B s
4 Texture Layers A Texture Layers
Add Texture N [] Embed &1l T | Embed Al
Add Texture
hdedia
Text
Colat/Ramp
Flugin

When the first texture is added, the option of adding Texture 2 becomes available, with up to
4 textures available to each surface.

Embed All - Includes the texture layers as part of the saved Lyric file. The size of the saved
file is increased, but eliminates any danger of not locating a texture source file if the
message (but not the referenced textures) is moved to a new device.

To Remove/Delete a texture layer click the X

4 Texture Layers

'Field.ipg =[] Embed &1
| Ramp 2

iWine-nics.mw ' m
| Add Texture

To Reorder textures drag them up and down the list

dTexture Layers

Field.jing ™1 [ Embed A&l
Ramn 3 m
Wipe-pics.mav

To Replace a texture and return to the file browse dialog, reselect the texture and click the
preview window, or right click the texture and reselect its source type.
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Applying Specific Texture Sources

Image
An alternative method of applying an image texture (in effect replacing the image) is
dragging and dropping an image from the Browser onto the asset preview window.

Media
Media files can be mapped to the surfaces of 3D Text or 3D objects. Set the Properties as
normal through the Media Properties dialog.

Looping both the object and the Media file may cause a conflict if the loop points are
different durations.

Text (2D Text Windows and 3D Text)

The contents of 2D text windows and 3D Text Templates can be mapped to 3D object
surfaces. However, an animating 2D text window (Roll, Crawl, Type On) will lose its
animation.

When Text is selected as the source, a popup window appears with all available text
objects.

[ Select An Obiect Te.. || |

2D Text1
30 Template 1

[ 4 ] [Cancel ]

—

' - -

When text is mapped to a 3D object, it is turned off on the Scene Graph. It can be turned
back on for editing or display, but will require being re-mapped.

Color/Ramp
Choosing this option opens a standard Color Select dialog which allows for an overlay of
surface color.

Plugin
Allows for mapping live video to 3D objects. Refer to relevant Hardware documentation for
details on texturing Live Video on the Video Object.
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Texture Layers
Texture Mapping
Texture Transform
Texture Filtering

Data Linking/Metadata

Image
Material (Color)

Texture Transform
Texture Filtering

Material (Diffuse, Specular, Opacity, Shininess)

Texture Mapping (Wrap Mode and Projection)
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Data Linking/Metadata is available on Images through the General properties tool.

When on a Image or a texture applied to a 3D object, options for adjusting the texture become
available. The illustration below shows an Image’s Surface Properties on the left and a 3D Object’s

Surface Properties on the right.

Surface @ |

| Image > Color bars

4 Material
Color
4 Texture Mapping
Wrap Maode Repeat v
Projection Nane >
4 Texture Transform
Position X 0000 2] v 0000 [5]
Scale X 1000 [5] v 1000 2
Center X 0000 | v ooo0 |
Rotate 0.000
4 Texture Filtering
Minify Bilinear hd
Magnify Linear -
Anisotropy I;Jone >
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30 Object = Cube 1

Sutface  All -

4Material

Diffuse Specular  Opacity

100
4Texture Layers
] Embed
| Add Texture E|
4Texture Mapping
Blend Mode Decal -

Wrap Mode Repeat = F %ﬂ

Prajection Mane -

4Texture Transform

Position ¥ 0.000 2] ¥ 0.000
Scale ® 1,000 | ¥ Lo0n
Center X 0,000 '_ ¥ 0.000
Ratate noon =

ATexture Filtering

Minify Eilinear =
hagnify Linear -
Anisotropy  Mone -

4Texture DatafhMetadata

DE Linking
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Material
Diffuse and Specular can be thought of as the predominant and highlight colors of a given Surface.

e Diffuse/Color - The color applied to the selected surface. If the Diffuse/color is white, the
appearance of an applied texture will not be affected by color.

e Specular (3D Objects only) - The color reflected by the object surface when it is struck by
light. Therefore, Light sources in the scene and the Shininess of the object will also have an
impact on the effect of the Specular. A black specular renders no reflection from the surface

e Opacity (3D Objects only) - The opacity of a 3D Object Surface can be set from
completely transparent (0) to completely opaque (100).

e Shininess (3D Objects only) - Determines the reflectivity of the 3D Surface. The range is
from 0 (flat matte) to 100 (most reflective).

Texture Mapping
This control offers three options for how a Texture is superimposed on a Surface.

Blend Mode (3D Objects only)

Determines how multiple texture layers are superimposed on 3D Object Surfaces.

e Decal - Adds the texture over the object surface

e Blend - The texture blends all layers on the Surface. When the texture contains Alpha
information, this is blended across all layers and the area containing alpha becomes
transparent.

e Fade - The texture is superimposed on the surface with the option of varying the Alpha
level of the texture (via the Alpha control that appears when Fade is selected).

e Replace - Ignores all other texture layers below it, as well as the Diffuse and Specular.
Alpha is respected. The object it is applied to will not be able to have its opacity altered in
this mode.

Decal Example 2 Images mapped to a 3D Pod Primitive

..S.urface
............................... | 3D Primitive = Pod = Pod

|| H E NN EENENENNBNE®RNEM®N I :
HE B EEEEEEEEEEEDN S e
|| H E NN NEENENENENNBNE®RNEM®N .

HE N NN EEEEENEENEE N

|| 0 BB B B Diffuse  Specular Opadty  Shininess
HE B EEEEEEEEEEDN ] w2 oee [

4 Texture Mapping
Blend Mode  Decal

Wrap Mode Repeat v G0 B

I Projection Maone -

I 4Texture Transform

| Position X 0.000 |

Scale H 1.600

Center ¥ 0,000
Rotate w000 5

Blend Example 2 Images mapped to a 3D Pod Primitive
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Surface  All

4Material

Diffuse Specular Opacity  Shininess

--100 B e H

4Texture Layers

wric Demailmagest...

Embed All
Iilyric Demoima

Add Texture

4Texture Mapping -

Blend -

Elend Mode
Wrap

Projection Mone

4 Texture Transform

Position ¥ 0,000 voooon [
Scale X W i W 8
Center }{ ¥ -
Rotate o002

Surface Al -

4Material

Diffuse

Specular Opacity  Shininess

. -

ATexture Layers

Thlyric Demoimagesh, Embed Al

IhLyric DemotImagesiT...
Add Texture

ATexture Mapping

Fade * 50,000

Elend Modd

Wrap Mode  Refree®

i

Projection Mane -

aTexture Transform
Position X 0,000 ¥ o000

Scale X 1000 ¥ 1000 a
Center ¥ 0.000 ¥ o000
Ratate 0000 5

Replace Example 2 Images mapped to a 3D Pod Primitive (below image ignored)

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 182

~ 3D Primitive > Pod = Pod
surface Al -

4Material

Diffuse Specular  Opacity  Shininess

| e

. aTexture Layers

Ihlyric Dematmagest,.,

il qesiT...
re

\Lyric De
Add Textul

4Texture Mag g
Blend Mofle  [EEEERS
Wirap Mode 2, ‘ ;ﬁ

Projection Mane -

4Texture Transform

Position X 0.000 (5 ¥ 0000 [
Scale X 1000 (3 v 1om 2 8

Center % 0000 2] v oom [Z]
oo o

H

Wrap Mode

e Repeat - Causes multiple iterations of a texture to repeat across the surface.

e Clamp - Causes one iteration of the texture. When a texture is clamped and moved with
the texture transform controls, any remaining space on the selected surface is filled with
repeating iteration of the edge pixels. To avoid the edge pixel being repeated, the texture
needs at least 3 pixels of alpha at its edges.

e Mirrored - Alternates repeating iterations in opposite orientations.

UVW mapping from external 3D programs is respected on 3D Objects. The textures can also be
retained if the texture from the 3D program can be accessed at the same file location by Lyric.

Projection

e Reflective - When enabled, the surface acts as a mirror reflecting the texture. Depending
on the location and angle of the object surface, different areas of the texture are reflected.

e Sphere Map - Similar to Reflective projection, where the object acts as a mirror, however
the texture is wrapped around a sphere. This provides reflective texture mapping that is
optimized for three-dimensional objects with curved surfaces. Depending on the location
and angle of the object surface, different areas of the texture are reflected.

e Masked - The texture is mapped to the Canvas, and the surface reveals it as it passes over
it. If the texture does not cover the area of the Canvas, it is repeated.

Projection is applied to all surfaces of 3D text

Flip

Click to invert 3D object textures (and its iterations) 180° horizontally and or vertically.
—_— e
d =
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Texture Transform
All changes in orientation are relative to the texture, not the object.

Position (X,Y)
These settings allow horizontal (X) and vertical (Y) offset of the applied Texture. The range

of the settings is from -100.000 to 100.000. O for both of the above settings centers the
Texture map on the surface.

Scale (X, Y)

The texture can be scaled on the X and Y axis with a range of -100.000 to 100.000. The
number refers to the amount of times the texture is repeated across the surface. A texture
with no scale applied has a value of 1, meaning 1 iteration of the texture. A value of 10
means the surface has been scaled 10 times to fit (making it 10 times smaller). To scale the
texture larger than the surface, the value needs to be less than 1.

Center (X, Y)

This is the center point from which a texture scales and rotates. A value of 0.5 on the X and
Y sets the center point directly in the center of the texture. This means an X a value of 0
sets the center point at the left hand edge, 0.5 is in the center and 1 is at the right hand
edge of the texture. Likewise, a value of 0 on the Y sets the center point at the bottom edge,
0.5 is in the center and 1 is at the top edge. The center point range is from -100.000 to
100.000.

Rotate

Allows rotational adjustment of the texture. Range is from -360.000° to 360.000°.

All texture transforms can be keyframed for animation. Primitives additionally allow you to
animate the surface geometry via General Properties.

In this example, 2D Texture has been transformed on the X position at right.

Surface
HEEEE NN N
.. H B EE B |1mage>MrslewMal\

Wrap Mode Clamp -

|
|| 4Texture Mapping
Projection it -
| aTexture Transform
|| position v 0000 %]
T
Scale X To0r=TT v 1.000 lf.j‘

Center X 0000 [ vooo0 [
Rotate 0000 [

Projection Mone -

aTexture Transform
Fosition X 0000 (3] Y0000

Scale x 1000 [ vio0 2@

Center X 0000 [ v o000 2]

Rotate 0000 [+

4 Texture Filtering

. Minify Bilinear +
Magnify Linear -

aTexture Filtering

| Miniy Bilinear =
Magnify Linear -

Anisotropy  Mone - Anisatropy ~ None A

Texture Filtering

This part of the panel offers a variety of options for improving the appearance of surfaces.
Minify

Recommended for use when scaling down an object or moving it further away from the
Camera on the Z axis. Three modes are offered for mitigating 'blockiness'. Experimentation
with the settings is suggested to achieve the best results.
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e Bilinear - The default setting (sometimes called resampling in other graphics
programs).
Pixelate - Pixelates the texture
Trilinear - Useful for smoothing or blurring the appearance of textures (including
Images) that have been scaled down considerably.

Images have an additional adjustment control for Pixelate and Trilinear settings, this value
can be keyframed.
Magnify
e Nearest and Linear - This filter can be used to smooth the appearance of small
details in parts of an image that have been moved away from the Camera. The
Linear setting will almost always yield the best results.
Anisotropy
In scenes where perspective is being modified, this setting can be changed to vary the
effect of the Minify and Magnify filters across the textured area.
Texture Data/Metadata (3D Objects Only)
This is only available to textures mapped to 3D surfaces.

e DB Linking - Texture layers mapped to 3D surfaces can be DB Linked.
e Metadata - Becomes active when metadata is present in the mapped texture.
Metadata is available on individual surfaces only.

3D Text

All of the above mentioned surface properties apply to 3D Text, with an additional Text Tiling
dropdown menu for determining how textures will be mapped to its surfaces. Color and/or
Textures can be applied independently to each surface. However, Projection is applied
across all surfaces.
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Texture Mapping - Text Tiling

Texture sources can be tiled across character faces, sides and bevels, as well as 3D edge.
The source textures can be repeated on each character, word, line, the entire template or
on user-selected portions of the template text.

Pictured below is the Tiling dropdown, with all its options displayed.
4 Texture Mapping
Blend Mode EBlend -
Wrap Mode Repeat 'E %ﬂ

Projection Maone -

Text Tiling |;'

4Texture Transt By Char

By Wword =
Position ¥ By Line ¥oo.ooo =

Template -
Scale X |Unscaled ¥ 1000 [ @

Selection |
enter b4 Sel By Char Y 0,000 =
Rotate Sel By Word

Sel By Line

In the titling examples below, this image of color bars is the surface texture.

e Off - This is the default setting. This setting produces the same effect as the By
Char option.
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e By Char - The texture is mapped across each individual character. See the
following illustration.

e By Word - With this option, the texture source is mapped across every word. See
the following illustration.
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e By Line - The texture is mapped across every line in the template. See the following
illustration.

e Template - The texture is mapped across the entire template. See the following
illustration.
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e Unscaled - Lyric does not scale the texture source image to the template or its
characters. The source image, at its native size , is mapped on the template’s
contents with no regard for portions of the image that fall outside of the mapped
area. See the following illustration.

3 In Lyric
oOulle B
Pr. erties

e Selection - With a given Tiling effect set across the entire template, the remaining
selection modes (Sel By Char, Sel By Word, Sel By Line) allow the user to select
portions of the template content as the region across which the texture source is
mapped.

In the following illustration, the word “Surface” has been selected, and then the
option “Selection” chosen. The template’s contents that are not selected are treated
in the same manner as with the “By Char” option. The user-selected part of the
template (the word “Surface”) becomes a separate region across which the texture
source is mapped. See the following illustration.

LD Y i
\J--_..'flace
23023
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Template Update

The Template Update feature is a quick way to view, modify or replace any of
Template-updateable objects.

Opening Template Update

View > Template Update or use the key combination ALT + T

Template Update
Text

~ Main Title 2

EREAKING NEWS

Top Text 0
|COHING up:

Bottom Text 1
|NE:-:T:

Updatable items include: Text, Image file paths, Movie file paths, Imported 3d object file
paths, Texture Layers and Keyframes

Enabling an Iltem for Template Update

Objects intended for Template Update are enabled via Update Ordering. See Update
Ordering for more details.

Keyframe values are enabled for Template Update by right clicking the keyframed attribute
on the timeline track and selecting Data Binding > Updateable.

Template Update field order
The order in which updatable items appear in the Template Update list is also determined
via Update Ordering list.

Operations
e Alt + T open Template Update
Tab key toggles the cursor through the fields on the selected tab
Shift + Tab moves the cursor through the fields in the reverse direction
Ctrl + Tab moves through updatable tab categories (Text, Images, Media etc)
Shift + Enter forces a carriage return into a text template field
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e Enter key applies change
|
° applies change
° Execute Macro option when enabled (green) will execute an embedded

onread macro on Enter or when ‘Apply’ is pressed.

(=]
e Use the [=] resize arrows to adjust the size of the entry fields

e To discard changes, close the Template Update Pane.

Updating
Updating Text can occur on the canvas or the output. To do so, Continuous Update
must be enabled.

Image, Movie or 3D Object can be replaced by direct entry of a new filename. However,
many operators elect to use the familiar browse button to navigate to desired file.

Texture Layers are also available for update via Template Update and appear in their
respective category, so images appear in the images tab and Media files in the Media tab.

Timeline Editor

The Timeline Editor is used to create animations within a Lyric scene. A scene can have
multiple different animations, each contained within a ‘“Transition’. A Transition contains
nodes and their respective animation tracks with all associated keyframes. Each Animation
Track is made up of Attribute Tracks which hold the keyframes of one specific attribute, i.e.
Xposition, or YRotation. Each animation track also has properties specific to that transition
such as looping and hold last frame.

Transitions can be played in a nonlinear fashion. See Transitions for more information.
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Navigating the Timeline Editor
It may be useful to dock both the transport controls and the keyframing tool into the Timeline
Editor toolbar.
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The Transport Control and Keyframing Mode Tools can be docked anywhere in the
workspace and can be found in View>Toolbars.

Timeline Tree keyframe controls

4©) 4 Group Bullet 3 M

"o [y YPostion 0844 [

Each node in the list has a set of controls that are visible around the node Name.
From left to right:

1.

w

Prev Keyframe - Moves the selected frame cursor to previous available Keyframe
(kf) on that track.

Add/Remove Keyframe - Adds or removes a keyframe at the current frame cursor.
Shows hollow (grey) keyframe icon if keyframe is not present and yellow keyframe
icon if keyframe is present.

Next Keyframe - Moves the selected frame cursor to next available kf on that track.
Expand/Collapse arrow (Only on animation tracks) - Shows or hides the attribute
tracks for particular node. Double Clicking on a node will also expand and close the
attribute tracks.

Name - Shows node name for animation tracks and attributes names(indented) for
attribute tracks

Attribute value edit field(only visible on attribute track) - Shows the attribute
value for particular selected frame. The value can be changed by typing in it the
field or using by left/right dragging.

Inherit State button - If selected on the attribute track, inherit state is enabled for
that attribute. See Inherit State for more information.

TImeline Tree Filter Buttons
Show All - Filtering Attribute Tracks

ol

_ IEMWA” | aee
Position s m XPosition |
Rotation 3 ?Posi[&m
Center L4 ZPosition
Scale r
Show All

The Show All button at the top of the Timeline Tree can be used to filter particular animation
attribute tracks for all the nodes in the current transition.
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Show Animated Tracks Only

Show Animated Track Only reduces the number of attribute tracks that are visible by
showing only tracks with keyframes beyond frame O.
Effect In | Defaul | Efect Out | Bulet 1 | Bulet 2 | Bulet 3 .malﬂ% | =

Show Al 350 6f af 12f l‘Sf 1z|sf af z-‘n 27% 30f

40} b Group Bulet Ta 1|
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ZRotation
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Timeline View

f 4f af af 10f 12 141 16 18 20f 22f 241
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The main body of the Timeline Editor. It consists of a ruler at the top, track representation of
the nodes in the Timeline Tree - Attribute Tracks and zooming tools at the bottom.
Ruler - Setting duration indicator

# if 2 3f 4 S5F ef 7f 8 Of 10f 11f 12f 13f 14f 1Sf 16f 17f 18F 19f 20f [2AF| 22f 23f 24f 2I5F 26f 27f 2BF 29f 301
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To select a particular frame on the ruler, left click on a new frame with the mouse or left click
and drag the current frame arrow.

The ruler can be viewed in either timecode or frames. Using timecode 1 second 15 frames
would be displayed as 01:15f. In Frames it would be displayed as 45f. Right click to set.
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Zooming and panning
The track area of the timeline can be zoomed in for a closer view of keyframes or zoomed
out for a complete transition view.
|rr'r | 00:00:10:00
I

The Timeline Work Area defines the maximum the timeline can be zoomed. To change the
value, type a new time into the time-code area or click and slide.

Zoom in/out on the timeline by one of the following methods:
1. When focused on the Timeline Editor, use the scroll wheel.
2. By dragging the right side of the scroll bar. Additionally this bar can also be used to
view different areas of the timeline by clicking and sliding.

[mr |

3. Clicking the zoom to fit button ¥+ or by moving the slider tool = = 1 * will
make the tracks fit the width of the window. This width is retained even when longer
or shorter transitions are selected. The zoom can be fine tuned further by clicking
the + and - next to the slider tool.

Transitions

Defautt | sk

Transitions are a way of creating different animations within a scene. There is a Default
Transition in every scene. Transitions can be used to play back different animations in a
nonlinear sequence.

Creating a Transition

Default | g

A new transition can be creating by using one of the following methods:
e Left click the Add New Transition Tab to add an empty transition.
e Right click the Add New transition tab to add a transition that includes all currently
selected nodes.
e Dragging selected nodes from the Scene Graph onto the Add New Transition tab
adds a transition that includes the selected nodes.
Deleting a Transition
Right click and select Delete Transition.
Renaming a Transition
Right click, or double click to rename.
Reordering Transition Tabs
The Transition Tabs will be displayed from Left to Right in the order in which they were
created. These can be re-ordered by dragging and dropping the timeline tab to a new
position. The order of the transition tabs is reflected in the Playout Panel.
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Adding/Removing Nodes to transitions
Adding nodes to a Transition

Users can add nodes by dragging the node from the Scene Graph to the Timeline Tree
Panel, or by right clicking in the Scene graph and selecting ‘Add to Current Transition’.

Removing nodes from a Transition

Selected nodes and node attributes can be deleted from any Transition (including the
Default) by right clicking on them and selecting the Delete option, using the Control + Delete
shortcut or the Windows Delete tool.

& Group Bullet 3 O
o Group B——= i
_i}—ﬁu_ﬁaﬁ il}‘ Delete Ctrl+X —H- A
& Template 3 g B

If the Default Timeline is selected these methods will delete the node from the composition
not just the Transition.

Transition Picker/Filter

S
| Default _%

Effect In
Update In
Effect Out
Update COut
EBullet 1
Bullet 2
Eullet 3
EBullet 4

This combo box, to the right of the Timeline Tabs, enables a user to quickly locate
transitions via the drop down. Transitions can also be filtered by entering text into the
combo box. In the example above entering “Bullet” would display: Bullet 1, Bullet 2, Bullet 3
and Bullet 4. To remove the filter simply clear the text entry from the combo box.

Transition Context Menu

Add Transition
Rename Transition
Delete Transition

Copy Transition

Prevent Reactivations

Show on Playout Panel

Shortout : N/A 3

Right clicking on an existing transition will open the transition options for the selected
transition.
e Rename Transition - Show Rename Text Box to rename the transition
e Delete Transition - Deletes the Transition tab from the composition
e Copy Transition - Create a new Transition tab with all the current transitions nodes
and animation. Also copies transition settings such as Prevent Reactivations, Show
in Playout Panel, and Shortcut.
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e Prevent Reactivation - Prevents the most recently executed transition from being
retriggered. This is not active by default and until checked transitions can be
reactivated.

e Show in playout panel - Displays the transition in the playout panel for manual
triggering. This is active by default.

e Shortcut <Existing shortcut or N/A if none> - A shortcut can be configured for
the transition to be triggered manually when playing on output.

Transition Shortcut configuration

- ™
Transiticn 'flares and loops’ Hotkey Cﬁ{ﬁgurati... u
g

Take Keyboard Shortout

Key | Clear
Flew  [at [Flshift

Event GPI

Mo Walid GPIs Available

To configure a manual shortcut key to trigger a transition,click inside the field box and hold
down the keys desired as the short cut.

To configure a GPI that will trigger the transition, select a GPI from the dropdown.

Triggering Transitions

Transitions can be triggered automatically by Intelligent Transitions, Conditional
Transitions, keyframed actions on Trigger Tracks and Macros, or manually triggered
by the operator via a user defined hotkey, a global macro or button on the playout panel.

Previewing Transitions

When scrubbing to preview Transitions on the Canvas, users may need to click on the
Default transition in between previewing alternate transitions. The transition preview
concatenates previously scrubbed transitions to demonstrate the effect if triggered together.
This may result in a false preview for the selected transitions, if the desire is to preview it in
isolation. Simply clicking the Default timeline resets the preview to display only the next
selected transition.

Transition Indicator
When a transition shows a blue line along the top, it means the selected node exists in that
transition

| Default | UpdatelnBN | UpdateInElect | EffectinBN |
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Animation and Attribute Tracks

Nodes are keyframed along the timeline’s animation track. An animation track can be
expanded to show Attribute tracks. The Animation Track displays a representation or
summary of all the keyframed attributes.

3D Template 1 M '

] ¥Position 0 [ @ ] ]

] YPosition 0 [ @ 4] ]

] ZPosition 2 [ @ 4] ]

@ ARotation 766 [|® B @ @

o YRatation 0 [ @ o @

o ZRatation 0 [ @ o @

o e

Manipulating Animation Tracks
Animation tracks can be adjusted in length, looped, have the first and last frame held, be
set to inherit state, and have all their attributes copied and pasted over other tracks.

Right Clicking on a track, when a keyframe is not selected, opens the track options.

Copy Animation State
Paste Animation State
Add Keyframe

Paste Keyframes

= o $

Copy Track
Paste Track
Select All Keyframes

Extend Track k
Stretch Track k
Trim To Current Frame

Reverse

Loop
Hold First Frame

RS

Hold Last Frame

e Copy Animation State - Copies the animation parameters of the selected node and
the current frame.

e Paste Animation State - Pastes the last copied Animation State parameters at the
current frame and creates a keyframe.

e Add Keyframe - Automatically adds a keyframe to the selected node. This
keyframe will be added to every attribute of the node.

e Paste keyframes - Paste keyframes becomes available when keyframes have
been cut or copied. Selecting this will paste these keyframe(s). To cut and copy
keyframes refer to the Keyframe Right Click Options.

e Copy Track - Copies the node’s transition attributes including all keyframes and
properties such as hold first frame, loop, inherit state and hold last frame.
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e Paste Track - Pastes the node current transition attributes including all keyframes
and properties such as hold first frame, loop, inherit state and hold last frame.
Select All Keyframes - Selects all the keyframes on the selected track.

Extend - Scales the selected Animation track without moving keyframes.
Stretch - Scales the selected Animation track and moves the keyframes
proportionally.

e Trim to Current Frame - Trims the selection animation track so that it ends at the
current frame
Reverse - Reverses the Animation Track including all the keyframes..

Loop - The Loop selection will loop the selected Animation Track continuously until
a new transition containing that node and track is triggered.

e Hold First Frame - The first frame of the Animation Track will adopt the attributes of
the first keyframe if the track is moved up the timeline.

e Hold Last Frame - The last frame of the node will keep its final position after the
track ends. With this inactive the node will become visually inactive (become
invisible) after the end of the track.

Copying/Pasting Tracks
To copy a track, right click and select the copy option, or click on the node and Ctrl+C.

To paste the copied track, right click and select the paste option, or click the node you wish
to have the same property and Control+V.

Any properties and keyframes the node used to contain will be removed.

Modifying Animation Track Durations

Track durations can be modified individually using the mouse, or by right clicking on the
animation track. The duration of all tracks in a transition can be modified by right clicking on
the ruler.

e Click and drag from the right end of the track to change the duration by extending
or shortening the Track. If a keyframe is on the track, it cannot be trimmed to the left
of the keyframe.

e Ctrl+Click +Drag will trim or extend the track and remove any keyframes that get in
the way.

e Alt+Click+Drag will shrink or stretch the timeline and change the position of all the
keyframes on the track proportionally to match.

Adjusting All nodes in the Transition
Right Click on the Ruler, select the desired option and adjust the value from the pop out
menu. This will affect all the nodes as a unit.

_ Frames I} ?|f B|1= 9‘|

i Timecode

Extend All  » | 00000500/~ I:
Stretch All 3

|

Keyframing
The Animation Track is a summary of all the keyframes in the attribute tracks for a node,
therefore the operations available for either will differ slightly.
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Adding Keyframes
Add keyframes by one of the following methods:
e Toggle Keyframe in the Timeline Tree. This adds and deletes keyframes at the
current frame.
e Right click on the Animation track and select Add Keyframe. This adds a keyframe
to every attribute track for that node.
Right click on the Attribute track and select Add Keyframe
Change the value of the attribute track via the Timeline Tree/Transform
Properties/Canvas with Transform Tools.
When creating animations, a keyframe will be added to the Animation Track and Attribute
Track when attribute parameters are changed.

Selecting Keyframes
Click or lasso to select a single keyframe. Selecting the Animation track keyframe will
automatically select all the attribute keyframes below it.

To select more than one keyframe Control Click on them or, with the node attributes
expanded in the keyframe panel, lasso the desired keyframe tracks.

Deleting Keyframes
Use the keyframe Right Click menu or delete key to delete keyframes.

Cut/Copy/Paste Keyframes
Selected keyframes can be cut or copied.
Pasting those keyframes will insert the keyframe(s) from that frame on.

Moving Keyframes

Select and drag them on the timeline. To proportionally change the distance in time between
the keyframes, hold down Alt and click and drag.
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Right Click Context Menu for Keyframes
The context menu is different for the Animation track vs. the Attribute track.
Right clicking on a keyframe on the Animation Track opens the keyframe option menu.

Cut
Copy
Delete

Linear
Spline

Jump

Ne 8¢ $§+

Ease 3

Interpolation Modes

@ Linear

Linear progresses an object in an animation at constant speed from keyframe to keyframe.

@ Spline

Spline provides the ability to vary the speed and path the object follows during the
animation which is adjusted using the Keyframe Graph.

@ Jump

Jump causes the animation to jump between Keyframes, without showing any interpolation.

& Fase

Ease Interpolation creates a smooth transition into the keyframe.

There are 3 selections with Ease.

e Ease In ( &2]) will ease into the selected keyframe over the defined number of
frames.

e Ease Out ( 22) will ease the animation from the selected keyframe over the defined
number of frames.

e Ease In/Out ( %) will ease the animation into and out of the selected frame using
the defined number of frames for the in and the out.

To apply and modify an Ease, Right-click on the Keyframe in the timeline or Keyframe
graph, select Ease. Select an Ease Type from the Ease Type drop-down list box.

Ease InCut -

00:00:00:00 =
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Changing Keyframe Interpolation modes
Keyframe interpolation can be edited by selecting one of the other types from the keyframe
right click options, or by shift clicking on the selected keyframe.

The interpolation can be edited for the node track (every attribute track will inherit the new
interpolation), or by expanding the node track and selecting the attribute keyframes
individually. Each attribute at a specified time can have different interpolation settings.

When a node’s attributes have multiple interpolation modes, the node track keyframe will

display as an arrow pointing downward [, indicating that the node’s track should be
expanded.

Keyframe Color Code

The color of the keyframe will change dependent on keyframe status
Grey: Unselected

Yellow: Selected

Blue: Data bound and unselected

Aqua: Data bound and selected

Binding Data to Keyframes

Attribute keyframes can be made ‘updateable’ to accept data via Template Update, DB
linking or the Data Object.

Right click on the attribute keyframe and select 'Data Binding." There are 2 options:
Updateable and DB Link.

A Data Bound Keyframe will appear as blue in the timeline.

wa s of 120  240f 380f  480f 600f 720f B40f  960f

Show All - o [ ! [ [ [ [ | [ [
4 Gyinder [ cucms

#Position 1 & <

YPosttion [ @ q% Cut

ZPosition & |@ copy

#¥Rotation [ & @ Delete

*Rotation [ &

ZRotation [ & Linear

#S5cale [ & B spline

Scale [ &

Z5cale [1 & Y dungs

HCenter [l |& Ease 3

= 1 @ |e» DataBinding b [xPosition_kr_t

Zlenter [1 @ S——————

Transparency e Updateable

Tessellation A Set DB Link
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Keyframe Modes
Keyframing can be performed in two modes. Auto Keyframing and Global Keyframing

Global Keyframe Toggle

=) 0

When green, Auto keyframing is on. Moving to a new point of the timeline and
transforming a node will result in a keyframe automatically being added. Any animation
modifications to the object (i.e. surface, xyz properties) will only affect the selected
keyframe.

When red, Global Keyframing is on. Moving to a new point of the timeline and
transforming a node will modify all existing keyframes within that transition.

Any global keyframe animation modification of an object in the Default Transition will
modify all keyframes across all timelines for that object. If an object is adjusted on any
other Transition’s timeline, then only the active timeline’s keyframes will be globally
adjusted, all other Transition’s keyframes will be unaffected.

Global Keyframe Indicator

There is an optional indicator that changes the ruler bar of the keyframe panel to red when
Global Keyframing is on. This can be enabled via Config > Preferences > Timeline > Global

Toggle Keyframe Indicator.

T ir X 3 & 5 ef 7 & of 10f 11f 13 13f 14f 15f 16f 17f 18F 197 20f 22f 23f 24f 25f 26f 27 28f 29 300
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

rlfﬂ 3f 4 5f ef T7f 8f 9f 10f 11f 12f 13f 14f 15f 1ef 17f 18f 19f 20f 21f 22f 23f 24f 25Ff 26f 27f 28f 29f
TS T T T TR T (R S R TR (TR (A [ R R

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 202

In the following example, a message was created with a 3D cube animation from the bottom
left to bottom right of the screen. In the diagrams the 0 and 15 frames are displayed in red.
To demonstrate the Global keyframing, the keyframes at 15 frames were moved up on the Y
axis position.

I i Frame 15

Frame 0

Frame 07 Frame 15

Inherit State

Inherit State allows a Node's start frame to inherit/adopt animation attributes currently
playing or previously played. The node inherits the set values before animating to its end
frame.

A node can inherit from its own scene or a different scene. It can also inherit from a defined
node or itself (from a previously run Transition).

An example of this would be a Map that can animate to different regions (end locations).
Timelines can be created with an Inherit State keyframe at the head of each timeline and
the desired location at the end of the timeline. Inherit State allows for animating to any of
the 3 locations in any order as the first keyframe inherits always inherits from the last.
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This can be done on the Node track, which will inherit all animation properties of the node.
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When all properties are inherited, the node track will display with the inherit all symbol (H ).

4 p a4 Group Map of States =
& #Position 1] =
& fPosition 1] =
& ¥Scale 1 %
& fScale i b
o Z5cale 1 b

When only select attributes are set to inherit state, the node track will display with the inherit

some symbol (E).

4 |Cylinder
¥Position
Position
ZPosition
#Fotation
fRaotation
ZRotation

| .2 W

== = =11 R 1

Inherit Texture frame is also available for movies. This allows a movie to inherit another
movie’s playback frame, rather than restarting the movie from the beginning

Inherit state will work with transitions in the same message or between scenes.To configure
Inherit State between messages, right click on the Inherit State icon which opens a “From

Node” and “From Scene” selection tool.

© 4 Group Map of States b - - 2
@ YPosition 0 b | ¥| FromScene » @ Name © Description &
& ¥5cale 1 T " @
o ‘Scale 1 b @ by’ @
o Z5cale 1 = &)

Enter the case sensitive name or description of the node that should be followed and what

scene it will follow from.

When removing the Inherit State, link to a specific node or scene, remove the Scene
reference first by deleting the text in the input field, then delete the Node reference.

Inherit State can be previewed on the canvas when inheriting from the same scene (play
scene and execute transitions), however previewing inheriting state between different

scenes can only be viewed on output.
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Transform

Objects can be transformed in 3 Dimensional space, including Position, Scale, Rotation and
Center of Rotation. Additionally, users can also transform the Opacity (Alpha) on an object
node.

Transform operations can be done via the Transform Properties Pane, on the timeline (via
object expansion) or by directly dragging the object manipulator on the canvas (for Position,
Rotation, Scale and Center only).

Transform Axes XYZ

Objects can be transformed (positioned, rotated and scaled) along the XYZ axes.
e X s the horizontal axis and indicated in red
e Y is the vertical axis and indicated in green
e Zis the spatial/depth axis indicated in blue

The currently selected axis is displayed in Yellow.
Y axis A a

3 ©

Z axis E@

[ L4
| l X axis
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Opening Transform Properties
Navigate to View > Transform Properties.

Transform E
I:ED Primitive » Cylinder = Cylinder

AXYT

Position
X 0000 [ v o000 [

|
-1
fd
[ )
=
&
sl
1L L3
il 1l

x 0000 [£ voo00 [£zooo0 [
¥ & 10 "% & 45 %

Center
X 0000 (5 v o000 [3]z o000 [
L MR THME F-M B
Opacity

Alpha (A) for a Surface can be set from completely opaque (100) to completely transparent
(0). This sets a transparency for the object as a whole.

When an object is set to 0 Alpha, it is no longer being rendered. Occasionally, the object
may need to be rendered, but unseen. In these instances set the Alpha to 1.
XYZ
e Position on the X, Y and Z axes. Objects by default are positioned in the center of
the Canvas at X0, Y Oand Z -2.
e Rotation settings specify how an object rotates about its X, Y and Z axes.
Molohowt,
o |

X 0000 [2] ¥ 0000 [& Z 180.000 %]

£ 10 % £ 10 % £ 45 té

o Rotation can be adjusted incrementally by adjusting the value and clicking
the direction arrows below each axis. Left arrows adjust the rotation in a
negative direction while right arrows adjust the rotation in a positive
direction.

e Scale settings specify how the object is scaled in relation to its original size.
Scaling is applied to the X, Y and Z axes (where applicable). Settings can be
individually applied to each of the axes, or can be evenly applied to the X and Y
axes in order to maintain the aspect ratio of the object.
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o I8 If Lock Aspect Ratio is not depressed, the value for each of the axes

can be individually set. i) If Lock Aspect Ratio is enabled (depressed),
any change to the X value is reflected in the Y value, and vice versa.
e Center settings specify the center point about which an object rotates and from
which it is scaled. The center value can be adjusted dynamically or set automatically
using the buttons below the X, Y and Z entry windows.

Center
X 0000 5 v 0000 [3]z 2000 [
L ME TME F M B

o X(L, M, R) Left, Middle, Right
Y (T, M, B) Top, Middle, Bottom
Z (F, M, B) Front, Middle, Back

Resetting Transform Properties

Reset the desired axes by clicking on the word (e.g. Position, Rotation, Scale) or letter next
to the value. Resetting restores all XYZ values for the selected object(s) to default settings.
Increments

Right clicking inside the input fields allows for adjusting the transform increments

AXYZ

Paosition

X 0000 =1 v nnon =1 7 2000 =]
Drefault Increment T

Rotat 0100 ] -

X 25| Alt Key Increment {0.000 !_::J?

e oot0

X E Ctrl Key Increment lﬁ_j‘!
1.000

Center

x 0000 [£ voooo [zoo00 [£

L MR T MEB FMEB

e Default Increment is the amount the arrows will adjust by.

e Alt Key Increment is the amount of adjustment applied when holding the Alt+Key,
while holding the left mouse button down and sliding the mouse left and right (slider
adjust). This operation is usually set for fine adjustments.

e Ctrl Key Increment is the amount of adjustment applied when holding the Ctrl+Key,
while holding the down the left mouse button and sliding the mouse left and right
(slider adjust). This operation is usually set for large adjustments.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 207

Object Manipulator

The manipulator displays the XYZ axes. They can be viewed in either in a Local View or
View (World View).

In order to view the manipulator the Selection Guides must be enabled.

Quick Transform Selection

With the exception of Alpha and Transparency, Objects can be transformed directly on the
canvas. Selecting the desired transform property can be done via the manipulator right
click menu or via the transform tools

Transform Tools

% DN = -

In order from left to right: Translate (Position), Rotate, Scale and Center of rotation and
Coord Space. Also accessible by right clicking on the manipulator.

Translate
Rotate
Scale
Center

Coord Space

Manipulator
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Arrows

Rotate

Circles

Scale

Squares

Center

Targets
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Transforming Objects on the Canvas using the Manipulator

After selecting the desired transform method, select the desired axis, then hold the left
mouse button down while dragging in the desired direction on the canvas. The below
illustration shows the translate tool with the X axis selected on left, Y axis in the middle and
Z axis on right.

Local View

The local view displays the axes manipulator local to the object. This means as the object is
rotated, so will the manipulator. As it always stays local to the object it shows the direction
of the axes as relevant to the object.
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View
Shows the object selected with the manipulator in a world view, i.e. the axes are not
relevant to the object and manipulator faces the front of the object.

Manipulator
The manipulator can be viewed with with or without the Ends or the Multi Axis.

¥ Translate
Rotate
Scale

Center

Coord Space

Manipulator Ends
¥ Multi Axis

e Ends of the Manipulator, which display the currently selected transform property for
the object.
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e Multi Axis is the transparent square in the center of the Manipulator. It makes it
easier to visually reference the object in 3D space on the X,Y and Z axes via Red,
Blue and Green sides and also to invoke the right click menu of the object
manipulator. When disabled (unchecked) right click on the axis lines of the
Manipulator to invoke the right click menu.

Update Ordering

The Update Ordering Pane gives complete control over the order of all replaceable fields in
Lyric for both Intelligent Interface and Template Update. All elements that are replaceable
by Intelligent Interface and LUCI are available in the list and can be marked for update
and/or ID’s assigned. Items in the list are dragged and dropped to alter the order.

Viewing Update Ordering
Navigate to View Menu > Update Ordering.

Update Ordering i

Image > Image Show =
T|ID | I Node Mame Path

- Image Group 1

3,§_|:T| 0 % 0 Templ {2D Text Templates} Group 1

i',zl_ﬁ‘| |2 % 1 Temp2{2D Text Templates} Group 1

A, 20 Title BGD

a1 Info BGD

#A, |4 &2 3DTemplatel Group 1

W v Cube:FRONT:0 Group 1

The following operations will honor the order of elements in this list:
e Template Update (Alt-T)
e Intelligent Interface
e Template Data Message (Record Only/Ctrl-record)
e Tabbing in the canvas

Components of the Update Ordering list
The list of available columns in the Update Ordering list is invoked by right-clicking on the
Column Name headers.
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Icon

Legacy ID

Mode Mame
Hierarchical Path

GUID
II Update and # Position

[<]

External Update

[«]

Template Update

Icon - Indicates the element type.

ID - Same as Template Legacy ID from older versions of Lyric. This is only useful
for Macros, or LEIF, accessing this field. It has no impact on the order of the fields
in the scene.

EXT - Enable for External Update (Il is automatically enabled).

Il - Enable for Intelligent Interface and Number Position. The number portion
indicates the W command field number. This number will automatically change if a
ll-update able element is dragged above another during reordering.

e Node Name - The node or template name. For 3D surfaces, the surface name and
texture layer appear next to the node name. For 2D text templates, the name of the
text window is shown in curly braces beside the 2D text template name.

Path - Shows the location in the Scene Graph (hierarchical path).

GUID - A unique identifier which may assist with diagnostics.
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Managing the Update Ordering list

Moving Items
Selecting the desired item(s) and drag upwards or downwards. A thin blue line indicates
the new position for the item being moved.

|Ui§ﬂé¥£'ﬂfﬂbﬁﬁg_’ =
i]mage > MysteryMan Show -
T|ID (I Mode Mame Path

.0 |0 3D Templatel

#, %1 | 1 3DTemplate 2

| Mysteryhan
(7|« Bar A1 X
B Media--Amin_in.avi §;§

Enabling Items
Click any of the checkmark columns and, while holding left click, drag the column in the
desired direction to quickly enable/disable a sequence of items for that option.

Ordering Columns

Columns can be resized and/or hidden by right clicking on the column name header. They
can also be reordered by dragging the header left or right. Any customization is saved in
the workspace file and will persist between Lyric sessions.

Filtering Items
The fields displayed can be narrowed with the ‘Show’ filter. Click the Show dropdown on
the right side of the Updated Ordering Pane.

(Show 7|
Unchecked
¥ Template
v I
External

The Unchecked option shows everything in the scene that can be marked for update.
Exercise caution when reordering items, as this may impact hidden items.
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**IMPORTANT - Ordering for Lyric Legacy Messages**

Updateable Objects may be ordered differently in older versions of Lyric. Lyric versions 8
and older use Classic ordering where groups are ignored. Non Classic Ordering will order
based on the Scene Graph order with groups. The ordering method is only important when
opening a legacy message, or importing an LNO into LyricX for the first time. Once the
scene is saved, this dialog is no longer relevant and all ordering is managed by the Update
Ordering Pane.

The order type must be determined before reading the scene. The setting to specify
Classic or Non Classic ordering is found in Config > Intelligent Interface Settings > On Read
Legacy Ordering.

Intelligent Interface

W, U\, V and R commands adhere to the order specified in the list and the position of the
updateable field is denoted by the number next to the check mark. For these Il commands,
the legacy number has no impact on positioning.

Update Ordering Clear Macro

If a Lyric legacy message was inadvertently saved in the wrong order, the list can be
cleared using the following macro. Run the macro and save the message. When
re-opened, it will be regenerated according to the selected Import/Export ordering option
enabled.

propname =" TemplateOrderXML"

set n = ActiveCanvas.Scene.Element("Global Light")
set p = n.Properties( "Chyron.Lyric::Internal Properties")
x = p.Value(propname)

p.Value(propname) =™

set p = Nothing

There is also LEIF for retrieving the ordered list.

g ="

for each fld in activecanvas.scene.GetTemplateOrder(0)
s =s & fld.name & vbcr

next

msgbox s
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Virtual Output allows Lyric messages to be viewed as they would appear on the output of a
ChyronHego graphics system. Multiple Virtual Outputs can be added or removed via Config

> |nput and Output Settings

Sophisticated compositions using Persistent Messages, Triggers and other Transition
Effects can be previewed via a Virtual Output. Clocks and Timers will update in real time
when seen on the Virtual Output. The Virtual Output does not display hardware produced

media.

Opening the Virtual Output Window

From the View Menu, Select Virtual Output. Select from available outputs list.

Scene Tree Fg
Status Bar

Surface Properties

Template Update Alt+T
Timeline Editor

Transform Properties

Update Ordering

Video Capture

Wirtual Output >

AR CECE OGS

‘ Frame Bufferl

Show All Virtual Outputs
Show Active Virtual Outputs
Hide &ll Virtual Outputs

Output - Frame Buffer 1
Output - Frame Buffer 2

Clone Preview - Frame Buffer 1
Clone Preview - Frame Buffer 2
Virtual Output - Unassigned
Virtual Output - Unassigned

[E]

Cloned Canvases are also viewable via the virtual output menu if enabled in Config
Preferences > Interface > Clone Canvas Window

Playing Messages to the Virtual Output
Methods for initiating playout on the Virtual Output are identical to those used with
Play-to-Output. Using Lyric’s Playout Tools, Playout Panel, CTRL + the play key on the
transport controls, or key combination CTRL + ALT + Page Up will play a message to the
Virtual Output. Additionally, pressing the “/” key on the numerical keypad will activate the

“Xfer” function.
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Undo and Redo List

Undo and Redo functions are achieved via the Edit Menu > Undo or Redo, the shortcut

g

keys CTRL + Z and CTRL + Y and View > Toolbars > Windows Tools > Undo and

Redo R .

Additionally, Undo and Redo actions are be viewed in a list, which shows Canvas editing
steps, arranged from earliest to most recent, in chronological order. Lyric cannot maintain
an infinite number of editing steps and only the most recent edits are be stored on the Undo
and Redo lists.

Undo List

Navigate to View > Undo.

wov e

Undoable States

Created Light 1

Created 30 Template 1

Created MystenyMan

Created Bar Al

Muodified Bar A1 Position at frame 0
Modified Bar A1 Position at frame 0
Modified MysteryMan Position at frame 0
Modified 30 Template 1 Position at frame 0
Modified 30 Template 1 Position at frame 0

The most recent edit is highlighted at the bottom of the list. Lyric cannot undo a single step
in the middle of the Undo List, however users can undo a range of edits.

To undo a range of edits, select the step and click the Undo To button. The selected edit,
and all subsequent edits, are undone.
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Redo List

Modified Bar A1 Position at frame 0
Modified MysteryMan Position at frame 0
Modified 30 Template 1 Position at frame 0
Modified 30 Template 1 Position at frame 0

Also available from the View menu, undone edits appear on the Redo List.

To redo the most recent undone edit, select the first item on the Redo List and click the
Redo To button.

To redo a range of undone edits, select the step and click Redo To. The selected step, and
all more recently undone edits, will be redone.
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Configuration Menu
Save/Load Settings

Not to be confused with Workspaces, Settings are software configuration settings. Being
able to Save and Load software settings allow the customized default software settings, and
make it easy to switch back and forth between settings depending on the need.

Settings, previously User Profiles in Lyric Pro, have been expanded and categorized to
allow for more selective settings to be saved.

To Save Settings

1. Navigate to Config Menu > Select Settings

2. Enter a desired name for the XML file, and click Save

3. A Save Settings options dialog appears. Select the desired options to be saved as
part of the XML, and click OK.

”
Save Settings u

.-[¥] Application Settings
-.[J|Browsers

.|V Diagnostics
-.[¥|Hardware
-.[¥|Project Folder

t...[] Workspace

File Mame

I:\Project Folder\Operator, xml

[ ok | cancel |

The options available to be saved are as follows:
e All - Saves all options from the hierarchy selection.
e Application Settings - Saves all Application settings which includes:

e Color Palettes e Language

e CG Preferences e Timeline

e Interface e Canvas and Channel
e Import/Export Settings
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e Safe Title (Size and e Network Settings
Position) e Global GPIs
e Current Default Effect e Current Button States

Browsers - All currently open Browser sources

Diagnostics - Diagnostic settings under Config > Preferences > Diagnostics
Hardware - All Hardware Settings under Config > Hardware

Project Folder - The currently selected Project Folder

Workspace - The current positions and open/closed/pinned/docked states of the

panes and toolbars

The last loaded Settings remain in effect until new Settings are loaded.

Settings (User Profiles) from previous versions of LyricX are not compatible. Settings must
be re-configured and saved in LyricX.

To Load Settings

Previously saved settings may be loaded to adjust Lyric configurations to suit user
preference. Even if a Settings XML file has been saved with ALL settings checked, the user

can still select which settings to apply when Loading.

1. Navigate to Config Menu > Load Settings
2. Navigate to the desired XML file and click Open.

e —
Lookin: || Project Folder - @F = E-
(= . 3D Objects
= .. Clip Files
RecentPlaces || Effects
= . File Sequences
-' . Fonts
) .. Images
=y 1. Messages
e . Movies
| J!g . Mew folder
Libraries . Modes
. Playlists

mk“!' . Templates

2] Designer.xml
=
=] Late News.xml

@_ ig‘ Operator.xml i

MNetwork
File name: Operator xml - | Open I

i Computer

Files of type: [XML Data iles (*aami) -] [ Ccancel |

A Load Settings dialog box appears. Select the desired options to be loaded, and click OK.
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.
Load Settings u

[“]an

-[/] Application Settings
--Browsers
--Diagnosﬁcs

File Name

I:\Project Folder\Operator. xml

Input and Output Devices

The Input and Output (I0) Configuration dialog allows users to configure the desired standards
for video Input and Output Channels. For information on specific settings for Graffiti, Mosaic or
HX/MX systems, please refer to the separate Platform Guide documentation that is installed with
your system (or contact support).

System Configuration

On the left side panel, the Input and Output Configuration tabs for accessing the current Input
and Output Channels are selectable. The user can use these tabs to Add or Remove Channels,
as well as set the Video Standard for each Channel.

Configure Input and Dutput Devices =5}
Dnatpat Configusrat 2ad Outpur » ] Cutpet 1 = [ Outps? -
Inpul Configuration DSHIES £ 00 18200 Diisplay Matiis
Dieckdink 501 150,94 =| [1o80i /5984 -|
Display Matnx o F
Live Composfar 1 L WVideo: Manitor 1
HOT EI Rute
Virtual Outpat H - [ritemal
Gerlodk Timing
Preview Channsl [Hn Preview = | |Nn Preview ']

DSKLEAA4S100 2 Im2 Cut 8 InvOut

DeckLink DT 4004 Oul
Display Matnx 4 Dut

Live Composhar 2 Out —

MO 2 out Configuration modified, Changes must be apglied | Apply | | Cose
Virtual Outeut 4 Cut

A system with LyricX Framebuffer Plugins installed (supporting Matrox DSX and Blackmagic DeckLink
devices). The user has selected to Add an Output and is presented with available devices, Display Matrix,
Live Compositor, NDI, Virtual Output (for Offline Systems), the installed DSX Device, and the installed
Blackmagic Device.
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On the bottom panel, all installed devices are visible. The corresponding total available Channel
(or Connector count for SDI devices) is also listed, as well as the reconfigurable Firmware
Configuration (for SDI Devices). The user can not add more Channels for a Device than are
supported by the Device’s Channel count. If the device is reconfigurable, then the device either
prefers Input or Output Channels, and this must be configured before starting Lyric. Refer to the
LyricX MX/HX Platform Guide for details on Firmware Configuration.

After all Input and Output Channels have been added and standards selected, the user
configures the system by selecting Apply. At this point connector and licensing validation occurs,
and any warnings about the configuration are presented to the user.

Errors are reported when adding an Input or Output Channel if there are no free connectors,
when connector licensing fails, or the number of connectors have been exceeded (for example
by selecting a UHD configuration). Errors will be reported to the left of the Apply button.

Current Platform Support

As of LyricX 4.0, the following Platforms are supported:

e HX/MX (SDI Input in Fill or Fill/Key configurations and SDI Output in Fill/Key
configurations) for MX and HX Online Hardware Platforms. Refer to the LyricX IO User
Guide. This plugin is not included within the LyricX installer; it requires a separate 10
Driver and Framebuffer Plugin installer.

e Graffiti Blackmagic Decklink (SDI Input in Fill or Fill/Key configurations and SDI Output
in Fill or Fill/Key configurations) for Graffiti and Mosaic XL Online Hardware Platforms.
This plugin is not included within the LyricX installer; it requires a separate 10 Driver and
Framebuffer Plugin installer.

e Mosaic Matrox LE3 (SDI Input in Fill or Fill/Key configurations and SDI Output in
Fill/Key configurations) for Mosaic and Mosaic XL Online Hardware Platforms. Refer to
the LE3 User Guide. This plugin is not included within the LyricX installer; it requires a
separate |0 Driver and Framebuffer Plugin installer.

e Mosaic XL As for Mosaic, Matrox LE3 is supported. Additionally, Blackmagic Decklink
(SDI Input and Output in Fill configurations) is supported for Input and Preview.

e Virtual Output for Offline Installations and Graffiti, Mosaic, MosaicXL, MX and HX
Online Hardware Platforms
Display Matrix for MX and HX Online Hardware Platforms
NDI Newtek NDI Output in Fill/Key configuration.

Live Compositor Integration with ChyronHego’s Live Compositor video switcher.

Porting Hardware Settings between Systems

The System Configuration can be imported or exported through the Config -> Save and Load
Settings dialog by selecting the Hardware checkbox option. If Hardware settings are imported
which are not supported on the current system, it will be ignored and the Hardware settings will
not be merged into the current LyricX instance’s Settings XML file.
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Output Configuration

Output Channels have one Device per Channel, and may be configured for either Air or Preview.

The user can add an Output channel by selecting the Add Output dropdown, which will present
the user with a dropdown selection of each supported Output Device.

Once a Channel has been added, various settings are presented, of which Video Standard can
be configured.

The Output Device’s name to be used for this Output Channel

Video Standard sets the standard for all Input and Output processing by the device. All
common SD/HD/UHD broadcast standards are supported. For physical devices, the
frame rate family must match for all Channels. Therefore, frame rates of 23.98,
29.97, and 59.94 may be mixed, 25 and 50 may be mixed, or 24, 30, and 60 may be
mixed. If input and output are not the same frame rate, output will run at the rate of
input, causing dropped frames on output. Drop frame conversions (eg 24 HZ in 60
HZ mixed) are not yet supported in the renderer.

Output Type determines the video and key planes presented. For physical devices,
such as SDI, this determines the number of physical connectors required. For Fill and
Key in SD/HD. this requires 2 available connectors per Channel, and 8 available
connectors for UHD. Both Fill and Key connectors must be cabled and properly
genlocked together for Video to be present in the Input Channel. Fill, requiring only 1
available connector per Channel (4 for UHD), is only supported for Input. Both Fill and
Key connectors must be cabled and properly genlocked together for audio and video to
be routed to the Input Channel. If Key is not required, then Fill only should be selected.
The Connector Label is also presented in order to simplify the hardware installation.
This presents the user with which Output Window or physical connector will output the
Video and Key planes. A channel that fails to create because of a lack of free
connectors will have a N/A (not applicable) Connector Label, and will fail with an error
when Applied. Note that some firmware configurations have gaps in the connector labels
eg a DSXLE4 /4 configured as a 2 In 2 Out has connector pair 1/5 for Input and 2/6 for
Output

For NDI Outputs, an NDI Source Name is configurable as a Unicode text string. An NDI
viewer, such as Newtek Studio Monitor, will see the source as a combination of the
Machine’s Name and configured NDI Source Name. The default NDI Source Names are
NDI Output 1, and NDI Output 2, respectively.

Audio Format determines the number of Audio Channels to be embedded /
de-embedded alongside the video plane. In earlier LyricX versions, 16 Channels of
audio were automatically embedded on SDI Output. De-embedding from SDI Input was
not previously supported.

Genlock Control determines the configuration of the device’s genlock clock. With
Internal, the device generates its own clock approximating the Video Standard. This is
sufficient for testing, but not for broadcast. With Video Input, the device uses the first
SDI Input connector for the device as the clock. With Reference Input, the device uses
the Reference Input connector as Analog Blackburst or HD/Tri-level from an external
sync generator for its corresponding video standard. In earlier versions of LyricX,
Reference Input was the default. If not properly cabled, the system will effectively be
genlocked as Internal until a proper cable configuration is connected. The system must
be properly genlocked for Input and Output to function in a stable manner.

Preview Channel determines whether or not an Output should be instead considered
as a Preview of another Output. The respective Output must be enabled. A Preview will
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automatically display any scene read to canvas. This is typically used for monitoring
over SDI by a secondary user.

e The Advanced settings option provides access to hardware specific workflow settings.
This is supported for Mosaic and Mosaic XL Platforms using DSXLES3 IO hardware, as
well as Graffiti Platforms using DeckLink 10O hardware.

SDI Devices are automatically genlocked to Analog Blackburst (or HD/Tri-level) Reference Input
from an external sync generator for its corresponding Video Standard. This is automatically
detected. If not properly cabled, the system will be in Free Run and output according to an
internal clock approximating the Video Standard. The system must be properly genlocked for
Input and Output to function in a stable manner.

Note when using Input with Virtual Output, its rendered output will be rate limited to that of Input,
rather than its specified Video Standard.

Configure Input and Output Devices

Qutput Configuration Add Output -

Input Configuration
Qutput Device
Video Standard
Qutput Type
Connector Label
Audio Format
Genlock Source

Genlock Timing

]
Qutput 1 = Qutput 2 = Preview 1 = Preview 2 =
XMIO3L/8/100 XMIO3L/E/100 XMIO3L/8/100 XMIO3L/8/100
(10801 / 52.94 v| [10801/59.24 | [10801/59.94 | [10801/5954 -
Fill+Key Fill+Key Fill+Key Fill+Key
Video: 1 Key: 5 Video: 2 Key: 6 Video: 3 Key: 7 Video: 4 Key: 8
[16 Channels V] [16 Channels v] [16 Channels V] [16 Channels V]
[Reference Input '] [Reference Input '] [Reference Input v] [Reference Input 'I

H: 0 = V0

H: 0 = \V: 0

= H 0 = v: o = H o0 = v: 0 =

Preview Channel Output for Preview 1 Output for Preview 2 [PreviewforOutputl v] [PreviewforOutputZ 'I
Display Matrix 4 0ut
Virtual Output 4 Qut Apply Ll
XMIOSL/8/100 0 In8 Out & In/Out :
An 8 Output HX system configured for 2 Outputs and 2 Previews.
Configure Input and Output Devices @

Output Configuration Add Output -

Input Configuration Qutput Device
Video Standard
Qutput Type
Connector Label
Audio Format
Genlock Source
Genlock Timing

Preview Channel

DSXLE4/4/100 21In2 Out 8 In/Out

DeckLink SDI 4In4 Out
Display Matrix 4 Out
NDI 2 Out
Virtual Cutput 4 Out

Qutput 1
NDI

Qutput 2
NDI

1080 / 59.34

(1080 / 59.34

Fill = Key
Source MDIQutputl

Fill = Key
Source WDIQutput 2

[16 Channels

[16 Channels

Internal

Internal

[ No Preview

[ Mo Preview

Configuration modified. Changes must be applied Apply

A system configured for 2 NDI Outputs. The NDI Source Names are configured as NDI Output 1 and NDI

Output 2, respectively.
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Input Configuration

Input Channels have one Device per Channel, and are shared amongst all Output Channels.
This infers that output is to be rate limited by the performance of the input, so that their sample
rates must match and all Devices must be properly genlocked for a video workflow.

The user can add an Input channel by selecting the Add Input dropdown, similar to adding an
Output Channel. Refer to the Output Configuration section above for a description of all Channel
settings.

All Input Channels are available for all Output Channels on Output and on Canvas Play. Refer to
the Video Object feature for rendering the Input Channel within a Lyric scene.

Note that system performance is directly related to the number of Input and Output Channels
configured on the system. Further, Input and Output must be the same sample rate, otherwise
Output will have time aliasing artifacts as it passes Input through to Output at the lower Input
rate.

Configure Input and Output Devices E
Output Configuration Add Input Channel = - -
Input Configuration
Input Device XMIO3L/8/100 ¥MIO3L/B/100
Video Standard [1080i/ 59.24 -] (1080 /5934 -
Channel Type Video and Key Video and Key
Connector Label Video: 1 Key: 5 Video: 3 Key: 7
Virtual Qutput 1 Out
XMIO3L/8/100 41In4 Out 8 In/Out Configuration modified. Changes must be applied

A 4 Input and 4 Output HX system configured for 2 Input Channels.

Advanced Settings Dialog
Refer to the Platform specific guide for information on hardware specific settings

GPI Devices

A GPI, or General Purpose Interface, provides Lyric with the ability to transmit and receive
triggers for internal and external events. GPI triggers can be executed from your
Chyronhego system to Lyric, from the system to external devices, or from external devices
or Master Control switchers, to your Chyronhego system.

A GPI can have a wide variety of uses, among them:
e Triggering a Playlist event.
e Triggering a Transition
e Releasing a Pause
e Turning on and off a tally light.

The hardware discussed herein may require installation of driver software outside of Lyric.

Information pertaining to older systems can be accessed via older versions of the help file
or by contacting ChyronHego customer support.
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Each Bank of GPIs on the optional hardware provides up to 8 pins/GPls.

- ] Description

From Board Genenic GFI (1) Direction [ Chput

GPIO Mumber 1 E}Tﬁu t{rE:_‘llSE

Current Assignment

Supported External Hardware
Contec Microelectronics board supported with installation of 64-bit OCX

GPI Dropdown
Use this field to designate the Bank of GPlIs, or the specific, individual GPI.
e Direction - Determines whether the designated port is to receive the incoming pulse
(INPUT) or send an outgoing pulse (OUTPUT).
e Output Pulse Width (ms) - Pulse Width defines the output pulse width in
milliseconds.
From Board
One or more boards that offer GPI connections may be installed in your system. The From
Board indicator distinguishes between boards when more than one is present.

ON GENERIC GPI BOARDS, THE DIRECTION AND PULSE WIDTH ARE SET FOR EACH
BANK OF GPIs. THE PROPERTIES CANNOT BE SET FOR EACH INDIVIDUAL GPI.

Individual GPI Configuration

GPI | +>Pn TonBank 1 -1 ¥ | Descrption  1- Trigger Effect Olt

From Board  Generic GPI (1)

GPID Mumber 1

Cusrent Assgnment

GPI 1: Unassigned or Assigned to Pause

Jest
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e Description - A descriptive name can be entered in this field. If no text is entered
by the user, the GPI number populates the field by default.

e Current Assignment - This (non-editable) field displays a detailed description of
the action associated with the selected GPI.

e GPIO Number - Where more than one board providing GPIs is present, this item
indicates which one of the available GPIs on a given board is being configured. This
display numbers GPIs beginning with the first one listed (see above) and continuing
through the GPIs on successive boards. The distinction between boards is made
above in the From Board display.

e Test - Click this button to verify that the GPI is working. A pulse will be generated if
the GPl is set as an input pin or detected if the pulse is set to an output pin.

Canvas and Channel Settings

Canvas Resolution determines the software resolution, or television standard, that
graphics are to be created in.

The canvas resolution settings and Video Output standard are set independently. The best
practice is to create and playout using the same resolution.

Each canvas and output frame buffer can have different settings.

Setting the Canvas Resolution

From the menu, select Config Menu > Canvas and Channel Settings. The Channel
Settings window will open.
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Channel Settings ?

=

Selected Channel: EFBl [HD) o
Canvas Resalukion

| Match Qutput - 1030 f 50

Width | 1920 Frame Rate | 25.00

Height | 1030 | Pixel Aspect | 1,000

Save Delete

II L%

Impork Settings
Import Graphics at 1:1 Pixel Aspect

[+] Enable Auto Standards Conversion

Render Settings

Full Scene Antialiasing | 4:x e
Apply apply Al I
concel |
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The following options are configurable

e Selected Channel - Use this dropdown menu to select the frame buffer that will be
configured. To apply the settings to all frame buffers simultaneously click Apply All.

Settings For: iFEi E—E! v,i

FB1 (HD

Resolution: [ 1080i { 59.94 - ]

Llpu:_late. | Delete

e Match Output Will set the canvas resolution and frame rate to match the hardware
output configuration per Framebuffer
e Canvas Resolution - Several presets are provided in the dropdown.

Canvas Resolution &lg

Settings For: | FB1 (HD) -

Resalution: ‘ 1020i { 59,94 - I

=10 H ~
TR D1 525 g
= D1 625
16:9 525
16:9 625
Width Heig HC"
g . 10801 { 60
1920 10f
10801 | 50
[luse 1:1 Pixel 720p /&0
720p | 59,94
[ |Enable Auto: 720p /50

720p | 30
Full Scene Ar 720p | 29,97

Maode: |4x 7elp f 25
720p | 24
720p | 23.98
1080p | 60

i 8] 1080p | 59,94

1080p / 50
1080p | 30
Zancel 1080p J 29,97
1080p | 25
1080p | 24
1080p | 23.95
UHD:
Z2160p (4K J 60
2160p (4K [ 59,94
Z160p (43 [ 50
2160p (4K J 30
Z160p (4K) | 29,97
1080p (4K} | 25
1080p (4K | 24
1080p (43 [ 23,98
Cuskom:
Crefault B

m
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Canvas Resolution settings DO NOT affect the signal being produced by
your system's frame buffer boards. These settings only configure the
Canvas for proper visualization and composition of Lyric messages. Setting
the broadcast format of your system's outputs is accomplished in Lyric's
configuration menu (Config > Hardware).

1:1 Pixel Aspect for Graphics Import - This option compensates for the
difference between the square-shaped pixels used by Windows graphics
applications, and the rectangular shaped pixels used by the Lyric
application. In the left illustration, the Use 1:1 Pixel Aspect for Graphics
Import option is active, and the original appearance of the imported object
has been preserved.

In the right illustration, the option is not active and the proportions of the imported
object are distorted. An imported image's pixel aspect can be adjusted
retrospectively via View > General Properties > Pixel Aspect, or via the Right
Click Menu > Internal Properties > Pixel Aspect

e Enable Auto Standards Conversion - When this function is enabled, 4:3 SD
messages may be imported into a 16:9 HD Canvas, and vice versa, while aspect
ratio and size are maintained.

For example, a page is created in Lyric with the Canvas set to D1 525 (4:3 - 720 x
486)
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The Canvas Resolution is then changed to 16:9 525; the pixels are still at 720 X
486. If the same page is read to the 16:9 Canvas without the Auto Conversion
enabled, it would appear horizontally stretched.

e With Auto Conversion enabled, the page created with the Canvas set to D1 525
would now retain the proper aspect ratio when read to the 16:9 canvas, and there
would be no need for rescaling.

FOR MORE INFORMATION VISIT:
HTTP://CHYRONHEGO.COM/


http://chyronhego.com/

) CHYRONHEGO

LyricX 4.6 User Guide
Page 231

e Background clips are stretched to fill the entire screen when converting from 4:3 to
16:9.

e When Auto Standards Conversion is used in the reverse situation, pages created in
16:9 HD format are shown with the correct aspect ratio when read into a 4:3
Canvas. However, the left and right edges of a graphic created to fit a 16:9 Safe
Title area are clipped when reading into the 4:3 canvas. The interior outline above
shows the 4:3 Safe Title area within a 16:9 Safe Title area.

e To view the Resolution of an existing graphic, see File > Message Info > Native
Resolution.

e Full Scene Antialiasing - This setting applies to both the canvas and the output
Framebuffer

e The degree of the Antialiasing effect may be set to 2 samples per pixel (2x), 4
samples per pixel (4x) or turned off. When a value is chosen, the Full Scene
Antialiasing checkbox becomes available. When selected, the checkbox sets the
value previously determined in the combo box as the Canvas' default antialiasing
value.

Full Scene Antialiasing

Hode:
Off
Apply

2%
et
e Lyric's Full Scene Antialiasing applies this correction to all nodes, or Primitives, in a
given scene. Antialiasing for individual objects are set from the View > Rendering
Properties menu. Individual objects set to "Default" on the Rendering Properties
menu are given the degree of antialiasing set above.
e The higher the anti-aliasing factor the more resources the scene will consume.
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Preferences

The Preferences Menu allows the user to determine the default state of many of Lyric's
software settings. This includes: CG Preferences, Interface, Import/Export, Language,
Project Folder, Timeline and Diagnostic Settings. These, and other user defaults, can
be saved and recalled via Config > Save Settings and Load Settings.

CG Preferences

Preferences E
CG Preferences | Interface I Import/Epart I Language | Project Folder I Timeline I Diagnnstics|

Read/Record Play
Track Message Mumber Per FB [ Retum to Canvas ]
lUse Alphanumeric Messaging [l Prompt to play an Hardware =
Auto-Increment on Read/Record AutoPlay On Read =
Confirm On Delete Msg (Clips Honor Pause at Start |
Corfirm On Ovenwrite Keyboard
Show Preview Frame O Enable Mumeric Keypad [l
Read Nest Range 10 lUse English Keyboard for Menu Input =
Release Key Pause Browser
Scene h Release GPI Pause [ [7] File Save Adds to Browser

[] Page Size Auto

Read/Record

e Track Message Number Per FB (two channel systems only) - When selected,
the Message Number can be different on each frame buffer. When unchecked, both
channels share the same Message Number for read and record.

e Use Alphanumeric Messaging - When this option is checked, Lyric allows
Alphanumeric file names to be recalled, rather than the default numeric file names.
When in Alphanumeric mode, the Number Keypad number keys may still be used to
enter Message Numbers. However, the focus must be on the Canvas. To quickly
return focus to the Canvas, either click on the Canvas or press F6. Use Shift + Ctrl
+ <; and Shift + Ctrl + > to navigate through alphanumeric files. More info HERE.

e Auto Increment on Read/Record - When Auto-Increment is enabled, the displayed
message number is set to increment by 1 every time a Lyric message is read, or
recorded, and saved with a numeric file name. This is helpful when recording a
series of messages, as it prevents the accidental overwrite of a previously saved
message. When Auto-Increment is disabled, the displayed Message Number does
not advance after a read or record.
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Confirm on Message Delete - When enabled, deleting a Lyric message (Delete
Message key or Alt + F5) activates a popup prompting the user to confirm the
message is to be deleted. This also affects deleting messages from the Browser.
Confirm on Message Overwrite - When enabled, a popup will appear to confirm
that the message is to be overwritten.

Show Preview Frame -If selected (checked), the Preview Frame nominated via
Scene Properties > Preview Frame is displayed when read. If a frame has not been
specified as a Preview Frame when the message was saved, the last frame of the
Default Transition is displayed. If Show Preview Frame is not selected (unchecked),
then the first frame of the Default Transition is displayed on the Canvas when the
message is read. Show Preview Frame does not affect animation execution; the
animation still executes from the first frame. See Scene Properties for more details.
Read Next Range - The read next/read previous functions allow for Lyric to find the
next available message within the specified range. The default range is set to
search for the next 10 available messages. To invoke a Read Next or Read
Previous, input the assigned buttons on the ChyronHego dedicated keyboard, or
use the shortcut keys Ctrl + Enter (Read Next) and Alt + Enter (Read Previous).

Release Key/Pause
Lyric allows a variety of options for the use of keystrokes in the release of programmed
animation pauses. These options are presented in a dropdown menu.

Play

Scene - When enabled, pauses in the currently selected message, located on the
Scene Tree, will be released by a keystroke.

Current FB - When enabled, pauses in any message associated with the active
frame buffer (on Output or available for Xfer from the Canvas), will be released by a
keystroke.

All FBs - When enabled, pauses in messages associated with all frame buffers will
be released by a keystroke.

Release GPI Pause - When enabled, the operator can use a keystroke to release a
pause that was originally configured to await GPI input.

Return to Canvas - Determines what happens to messages that are no longer
required on output. This is at the conclusion of the Effect Out transition, or when a
message is replaced or updated by a subsequent message. When enabled
(checked) the message will return to the Canvas. If unchecked the message is
removed from the output.

Prompt to Play on Hardware - Before executing the animation on output, Lyric can
request confirmation. If Prompt to Play on Hardware is selected (checked), Lyric will
request confirmation from the user before executing the animation to output. The
screen position of the prompt on the VGA is saved as part of the Config > Settings,
S0 re-positioning is not required each time the prompt is displayed.

Auto Play on Read - Causes animation playout to automatically begin when a
message is called up, without the need of a play command.

Clips Honor Pause at Start - Plugin based background clips (such as mFX) will
Pause if there is a Pause Event at the start of the message.

Keyboard

Enable Numeric Keyboard - There are two sets of number keys on the
ChyronHego keyboard, and on PC keyboards. They are as follows:

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 234

e Alphanumeric number keys are located in a row towards the top of the
keyboard, above the letter keys. These keys are used to type numbers on
the Canvas, and enter numeric values in the various numeric fields located
within dialog boxes, frame counters, etc. The alphanumeric number keys
cannot be used to enter Message Numbers (l.e. file numbers) for Read and
Record purposes.

e Numeric keys are located in the numeric keyboard, located on the right side
of the keyboard. In order to use the numeric keypad, Num Lock must be
enabled. When enabled, NUM appears in black type on the Lyric Status
bar. When disabled, NUM is grayed out. For user convenience, especially
during content creation, the Numeric keypad number keys may be used in
either Message Number Entry mode or Alphanumeric Entry mode.

o Message Number Entry - File ID numbers are entered to Read and
Record messages, and for other file ID functions. When in Message
Number mode, the numeric keypad number keys may be used only
for Message Number entry. It is not necessary for the focus to be on
the Canvas in order to enter a message number, as entering a
message number automatically returns focus to the Canvas. This is
the ChyronHego recommended mode for when the system is on-air.

o Alphanumeric Entry - The number keys are used in the same
manner as the alphanumeric number keys described above. When
in Alphanumeric mode, the numeric keypad number keys can still be
used to enter message numbers, but the focus must be on the
Canvas. To quickly return focus to the canvas, either click it or press
F6.

e When Enable Numeric Keypad is disabled (unchecked), the numeric keypad is in
Message Number Entry mode. When disabled, the numeric keypad is in
Alphanumeric Entry mode.

e Use English Keyboard for Menu Input - This option enables standard Lyric
Keyboard shortcuts to be used when a language other than English has been
selected for text composition. When selected, the keyboard functions in the
selected non-English language while focus is on the Canvas. When Focus is not on
the Canvas, the keyboard reverts to English output, allowing immediate use of Lyric
keyboard shortcuts without resetting the Windows Language Bar. When focus is
returned to the Canvas, the keyboard immediately resumes functioning in the
language selected for composition.
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Browser

e Page Size - Refers to the amount of entries displayed per page in the Browser.

e Auto, Lyric will automatically display as many as possible

e File Save adds to Browser the primary browser will have a message saved to it
(Primary browser is determined by the label on the browser header

1: ChyronHego Lyric Demo [PRIMARY] |t#|

e Page Size determines the amount designated per Browser page. The default
amount is 100.

Best Practices
To allow for the fast recall of Alphanumeric messages, ChyronHego recommends users to
use a number before the alphanumeric info.

For example: "200_Name of File."

This also allows for easier navigation through Lyric message file names. When recalling,
use the numeric keypad to first type the number, and then the Lyric shortcut keys of Shift +
Ctrl + < and Shift + Ctrl + > to move to the next and previous files as determined
alphabetically in Windows. Hit enter to then read to the Lyric canvas. Make sure the focus
is set to the Canvas, so that messages can be read.

Interface

-
Preferences E

Ci5 Preferences | Interface | Import/Bxport | Language I Project Folder I Timeline | Diagnostics

Canvas Status Bar Info

Safe Tile Update During Playback
4.3 Title in 16:9 O
2D Text Frames View Menu
Selection Guides Highlight Pane on Hover
Ohject Manipulat

: AripHiEer @ VIGA Preview
30 Text Manipulator

[7] Clone Canvas Windaw

Cptions
Disable Undo for 20 Text [l

Shift Page
Selected Objects @ Al Objects ()
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Canvas

Safe Title - Displays on the Canvas when checked. This option is also available as

-

a toggle button as part of the Canvas Settings.

4:3 Title in 16:9 - Displays both a 16:9 standard Safe Title Area and 4:3. This is
also a selection available from the drop down section of the Safe Title toggle. The
size, proportions and position of the Safe Title Area may be adjusted to aspect
ratios other than 4:3 and 16:9. Refer to Safe Title for additional information on
adjusting the Safe Title.

2D Text Frames - When checked, all 2D Text frames used as part of the Lyric
composition will be displayed. When unchecked, only the currently selected 2D
Text Frame will be displayed.

Selection Guides @ T _The X,Y and Z axis of each 2D and 3D object, and 3D
Text on the Canvas may be displayed, along with a bounding box showing the
boundaries. This can be toggled on and off here by either checking the Selection
Guides checkbox in Preferences, or by the toggle button as part of the Toolbar
Canvas settings. The selection guide appears yellow when active and red with
inactive. An active selection guide is when the object is selected in the Scene
Graph, and available on the current timeline.

Object Manipulator & Text Manipulator - Refers to the axis point of an object and
text, and is represented as a blue cross section. The checkbox allows them to be
enabled or disabled.

Selected 3D Surface - toggle the surface highlight of a 3D objects selected surface
(found in surface properties)

Options

Disable Undo for 2D text - When checked, Lyric will no longer record message
composition manipulation steps. If unchecked, steps are recorded into memory, and
message adjustments may be undone and redone via Edit > Undo (Ctrl + Z) and
Edit > Redo (Ctrl + R). The last 99 manipulation steps are recorded. A Undo/Redo
list is available via View > Undo List, and View >Redo List. Disabling undo frees up
programming memory, so if it is not required by the user it is advantageous to
disable.
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Shift Page

Refers to a set of shortcut keys available for transforming objects and text on the X and Y
axis of the Lyric Canvas. Shift page operations (Ctrl + Alt + 1|«—) can either affect the
selected objects on the Scene Graph or Timeline, or all objects.

If Selected Objects is enabled, only the objects selected on the Scene Graph or Timeline
are shifted when a Shift Page operation is executed. If All Objects is enabled, all objects on
the Canvas are shifted when a Shift Page operation is executed, whether or not they are
selected.

Status Bar Info

e Update During Playback - This enables and disables Lyric's Status Bar
co-ordinates found on the bottom right of the screen during playback.

View Menu

e Highlight Pane on Hover - When enabled, a purple border is shown around the
currently selected option via the View Menu. This allows for ease when locating
Lyric panels in the Ul.

Frame Buffer 1 1 B

Virtual Qutput | Alternate Canvas

Transform Properties

Update Ordering

: ¥ Scene Graph F2

| ¥ Scene Properties

. v Scene Tree F8
v | Status Bar

j v | Surface Properties

| ¥ Template Update Alt+T

| Timeline Editor

| ¥

| v

|

Virtual Cutput
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VGA Preview

e Clone Canvas Window - ChyronHego systems' graphic cards can deliver a clone
of the Lyric Canvas to a second monitor, in addition to the one being used by the
Lyric operator. Enabling Clone Canvas Window is typically used for control room
preview. Keep in mind that this display shows the Canvas that is currently active for
editing, and is NOT equivalent to any real or simulated output signal from the
system's frame buffer, or via the Virtual Output on the Lyric interface. Setting up this
function involves settings to your system's graphics card.

Import/Export

Node Export

These options are applicable when exporting an .Ino (Lyric Node Object) file, or when
copying/pasting objects/nodes between scenes.

e Current Transition - will include the Animation Tracks for the selected node/s in the
currently selected transition only.

e All Transitions - will include the Animation Tracks for the selected node/s in all the
applicable Transitions in the scene

.
Preferences u

C(5 Preferences I Interface | Import /Export | Language | Project Folder I Timeline I Diagnostics

MNode Export
() Currert Transition

@ All Transitions

[] Embed 30 Textures By Default

Embed Images By Default

e Embed 3D textures by default - sets the embed textures checkbox in the Surfaces
pane to ‘on’ for 3D objects/primitives when they are imported/created
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Embed images by default - sets the Embed checkbox in the General pane for 2d
image Objects

Language

Lyric supports Unicode and Complex Scripting. Language options settings specify how
characters from various languages are displayed.

-

Preferences @

™

CG Preferences | Interface | Import/Export | Language | Project Folder | Timeline | Diagniostics

Language Options

Unicode Only for 20 Text
Complex Scripting for 2D Text
lsing Extemal IME

Digit Substitution for 20 Text
RTL Input Mode for 2D Text
Unicode DBLink

Enable Ligatures For 30 Text

OOoO

EO

Default Languaage -

2D Text User Dictionary

Change Dictionary

Unicode Only for 2D Text - Many Asian, as well as other languages, require that
Unicode Only be enabled to be properly displayed in Lyric. All Complex Scripting
languages require that Unicode Only be enabled, but not all Unicode languages are
Complex Scripting languages. If Unicode Only is enabled, all 2D/3D text entry and
editing in the Canvas will use the Unicode character set, and is designed to work
with unicode fonts. Although this is not the default mode, it is required if any Asian
language (Korean, Chinese, Japanese, etc.) is selected.

Complex Scripting for 2D Text - Languages such as Thai, Arabic, Hebrew,
Vietnamese, Hindi, and Georgian require Complex Scripting be enabled to be
properly displayed in Lyric. This allows bi-directional text and character substitution
to occur during 2D text entry.

Using External IME - Enabling this option helps to minimize the anomalies that
may occur when working with third-party Input Method Editors (IME). IME's are
typically used for entering text in Indic languages such as Hindi, Tamil and Urdu.
Digit Substitution - Numerals can be displayed in what are commonly known as
Arabic numerals (e.g. 1, 2, 3, etc.), or in the language's own numeric characters. To
display the language's own numeric characters, enable Digit Substitution. To
display Arabic numerals, disable Digit Substitution. "Arabic-Language" numerals
are different from the commonly known "Arabic" numerals. Digit substitution must be
enabled to display Arabic-Language numerals (e.g. ¢ ,¥,Y ).
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e RTL Input Mode - Used for inserting left-to-right text (such as English) into a Lyric
message that is primarily composed of a right-to-left language. This option dictates
whether the overall context of a paragraph is right-to-left (RTL Input Mode checkbox
selected), or left-to-right.

e Enable Ligatures for 3D Text - Disables and enables ligatures for 3D text

Project Folder

e . =

| CG Preferences | Interface | Import/Export | Language | Proiect Folder | Timeline | Diagnostics |

I Select or Create Project Folder I

Asset Type Default Path

Messages |\Project Folder\Messages
Templates  |"\Project Folder\Templates
Images | \Project Folder'lmages
Playlists |\Project Folder'\Playlists
Effects I*\Project Folder\Effects
Clip Files I*\Project Folder\Clip Files

30 Objects  1\Project Folder’\3D Objects
Movies I*Project Folder\Movies
Forts |\Project Folder'Fonts

<

Always Browse To Specified Path

e Select or Create Project Folder - Allows the user to select an existing Project

Folder/Directory, or create a brand new one.

Asset Type - The folder containing the equivalent assets.

Default Path - The default path Lyric will use to access elements, as well as read
and record Lyric messages (.lyr files). Default paths can be changed by
double-clicking on the default path of any asset type.

e Always Browse to Specified Path - When checked, this option will open the
default path for that asset type when browsing. For example, when importing
images, the browse window defaults to the specified location. When unchecked,
the browse window will open at the last accessed file path.
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Timeline

P
Preferences |

| CG Preferences I Interface I Import/Export I Language | Project Folder | Timeline | Diagnostics
Default Mode Length

[coooTosTo o

Default Interpalation
Linear ~ |oofooosfo1
Default Work Area Length

ool oo o}

Options
[T Global Toggle Keyframe Indicator
[ Scroll To Selected Mode

Default Node Length - The default length of any node added to the Lyric timeline.
Default Interpolation - The default interpolation of all keyframes added to the
timeline. By default, this option is set to Linear. The dropdown allows the user to
select between: Spline, Jump, Ease IN, Ease Out and Ease In/Out. Selecting an
Ease option evokes the timecode editor to allow for the setting of the desired ease
duration.

Default Interpalation

x] [00f00f00f00
Spline
E.J|Jm|::|
Ease_In '
[Ease_OLrt me Indicator
Ease_InOut
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e Default Work Area Length - The work area of the timeline applied to the start of
each Lyric session. The application requires a restart to apply changes.

e Global Keyframe Toggle Indicator - When checked, Lyric will indicate to the user
when Global Keyframing adjusting has been activated. This is activated using the

0 ==
Auto/Global Keyframe Toggle "™* | M2l |5cated in View> Toolbars >
Keyframing. The global keyframe toggle determines whether keyframe adjustments
that are made to an object's transform properties (XYZ) affect a single keyframe, or
all the keyframes of the selected object. The green down arrow specifies single
keyframe editing mode, while the red horizontal arrow specifies global keyframe
editing mode. When global keyframe adjusting has been invoked (button
depressed), this mode is indicated via a red color on the timeline. When in single

keyframing editing mode, the time resembles the current Windows appearance.

[E) W E > WM W W ooceonzt 0

Timeline

Timeline | Macros | Keyframe Graph | Playlist | Parameters |

Show Al 3a:
I+ Image
|» Light 1
|> Global Light
» Cameral

EEEE

e Scroll to Selected Node - The timeline will scroll to the selected node when not
currently visible in the timeline.

Diagnostics

The Diagnostics tab in Preferences contains settings for investigating exceptions, or
unexpected errors that occur during processing that may cause Lyric to behave erratically or
even exit abruptly. If an operation in Lyric triggers an exception, it will write out, or "dump”,
the state of the code at that point to a file on disk.

The default settings on this tab should not be modified unless under the guidance of
ChyronHego Customer Support.

e Enable Dump Files - checkbox indicating whether dump files are generated when
an exception occurs. Default is enabled.

e Dump Folder - the location of the dump files. The default is the designated TEMP
folder on the system. To navigate to this folder, type % TEMP% into the address
bar of an Explorer window and hit Enter. The user can also enter a different path if
desired but this is not recommended; Customer Support will look first in the TEMP
folder for dump files and may not be aware that a different folder has been chosen.
Existing dump files can be erased by pressing the Clean button.

e Dump Level/Dump Flags - The dump flags indicate what information is included
and will affect the resulting size of the file. The Default level specifies "Dump Data
Segments" only.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 243

e Prevent Duplicate Dumps - sometimes a single exception can result in multiple
files; enabling this option will prevent only but the 1st file from being generated.

e Dump Triggers - dictates what type of exceptions will result in the generation of a
dump (1st column) and whether Lyric will automatically exit on that exception (2nd
column). There really are no circumstances in which Lyric should automatically exit
so nothing in the Exit column should be checked by default.

SR

| CG Preferences | Interface | Import/Export | Language | Project Folder | Timeline | Diagnostics

Enable Dump Files
Dump Falder
C:\Users\CHYRON™1.000"App Data'Local\Temp" (]
Dump Level Dump Triggers Dump Bt
Diefault - Any Win32 Bxception =
Unhandled Win32 Exception =
Unhandled C++ Exception B |
; it Pure Virtual Function Call B B
Dump Full Memary CRT Invalid Parameter
Dump Handle Data Memary allocation failure
Filter Memony A ; =
Scan Memary Abnomal Temination Signal
Dump Unloaded Modules Floating Poirt Exception Signal
Eﬁmpwlﬂgirledpﬁifﬁmﬂes llegal Instruction Signal [l
iter Module Paths ]
.| Btemal Intemupt Signal |
o Eimoses o Hotn Segmentation Fault Signal |
Prevent Duplicate Dumps Temination Request Signal |
ok || Hep
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Safe Title Adjust

The Safe Title Area is generally used to delineate the area on the Canvas where it is "safe"
to place objects, so that they will be seen on most televisions. Lyric has built-in default
settings for each Canvas Resolution, so graphics placed within the Safe Title Area, they are
unlikely to be cropped by a viewer's television.

Lyric's Safe Title Area display can be adjusted to any size, proportion and position on the
Canvas. A resized Safe Title Area can be used as a crop area when using File > Save As
Menu, and selecting "Clip to Safe Title."

FB1 - Untitled* - I\Project Folder\Messages

Safe Title Area

4:3in 16:9
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Adjusting Safe Title Area Settings

Navigate to the Config menu and select Safe Title Adjust. The Safe Title Adjust dialog box
is displayed. If no modifications have been made, the default settings for the current
Canvas Resolution, as set in Config Menu > Canvas and Channel Settings, is displayed.

r =
e e

e X & Y Dimensions and Position - For positioning, the Safe Title XY coordinates
(0,0) specify the upper left corner of the Canvas. For resizing on the width and
height coordinates, the Safe Title area is anchored from the bottom left corner.
There are no negative coordinates for Safe Title. X determines the horizontal
coordinate of the upper left corner of the Safe Title Area. Y specifies the vertical
coordinate of the upper left corner of the Safe Title Area.

e Width - Specifies the width of the Safe Title Area. A change of Width results in an
adjustment to the right border of the Safe Title Area, and is reflected in the Width %.

e Height- Specifies the height of the Safe Title Area. A change of Height results in an
adjustment to the right border of the Safe Title Area, and is reflected in the Height
%.

e Width % - Specifies the percentage of the width of the Canvas where the Safe Title
should be set. A change to the Width % is reflected in the Width.

o Height % - Specifies the percentage of the height of the Canvas where the Safe
Title should be set. A change to the Height % is reflected in the Height.

e Save - After settings are finalized, click Save. The Save Safe Title dialog box is
displayed. The default location for the Safe Title File (.saf) is the Default message
Directory, as set in Config Menu > Preferences > Directory, but may be saved
elsewhere. Enter a filename, and then select Save. The file has now been saved
for future recall.

e Center - When a Safe Title Area of any size has been moved off-center, this button
is used to restore it to the default locations.

e Recall - To recall a previously saved Safe Title Area, select Recall and then find the
desired .saf file.

e Reset - Select Reset to reset the Safe Title Area to the default settings for the
current Canvas Resolution as set in Config Menu > Canvas and Channel Settings.
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Default Effect

Effects such as: Dissolve, Hinge, Page Turn, Push and Wipe can be set up as a Default
Effect. These Default Effects are automatically used by Lyric Messages sent to the output
via a transfer. Default effects will NOT execute when sent via a Play to output. For this
reason, Default Effects work best with graphics that do not animate or have an 'Effect In'
transition. As the message does not play, a static frame is transferred to output using the
current selected Default Effect. With messages containing an 'Effect In," the first frame
frame, which is typically blank, is transferred. Messages without an 'Effect In' will be
transferred using the first frame of the Default transition. Default Effect can produce a
preset 'Effect In and Out' where none is present.

Navigate to the Config Menu > Default Effect. The following window is displayed:

Effect In EffectIn

lNone v] | Configure .. L:J _g_nnﬁg_ure

Dissolve

Effect Qut et O —

[None v] Configure Page Turn Configure [
B Push ) ]

Static

Record Record Wipe

Eename: T:VProject Folder\es...\D00D030 Liyr Filename: T:\Project Folder ies...\J000030 Liyr

Cod o] ——

The button for the 'Effect in' and "effect Out' opens the Primary Message Effect Setup and
the Secondary Message Effect Setup dialog boxes respectively. Here the parameters
specific to a selected effect are configured. The illustration above shows the Default Effect
dialog box, as it appears on opening, with the 'In' dropdown menu displayed.
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Configuring a Default Effect

Here is where the 'Effect In' and 'Effect Out' is configured with the desired animation style.
All options are unique to the 'Default Effect" being set, but most contain 'Ease' and 'Fade'
options. The below configuration shows an example of "Wipe' options.

Effect MDOg - Creee

|:| Ease Options|

Edge Size :

[

Wipe From :

i7) Top
i) Left ) i@ Right
() Bottom

ok |

Once the desired settings are determined, click 'OK' to save them.
The settings in these dialog boxes will be applied across all boards available to Lyric.

When executing the effect on a single board, set the 'OUT' effect to 'No Effect' to cut directly
from the current graphic using the selected 'IN' effect.

If in this configuration, and the 'OUT" effect is set to an effect other than 'None' or 'Static,’
the current graphic transitions out using the selected 'OUT" effect, followed by the new
graphic appearing using the 'IN' effect.

The 'IN' or 'OUT' effect can be designated to Render Last with the checkbox seen above.
This can affect the manner in which the two effects seem to overlap. Both 'In' and 'Out' offer
the same effects.
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Saving a Default Effect

After creating a Default Effect, Lyric returns to the Default Effect dialog box. In the Record
section, type the Lyric number or alphanumeric name in the Filename textbox and click
Record. If saving as a number for fast recall, ensure there are a total of 8 digits. The
message must be saved with the .lyr extension.

Record

Filename: I:\Project FolderiMes. .. \D0OD0001.lyr | Record

Coc ] [oma

The status bar indicates that the Default Effect has been saved.

Likewise, when a new Default Effect is recalled the status bar indicates that the Default
Effect has been updated.

Executing a Default Effect
The Default Effect executes when a message is transferred to the output.

Default Effects settings can be saved as .lyr files using the Record Only menu. When the
message containing the Default Effects setting is played, it will change the global Default
Effects setting for Lyric in the Preferences.

The effects offered in the Playlist are similar to those describe here. Refer to the section on
Playlists for additional details.
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Automation

Lyric Automation allows unlimited serial and network Intelligent Interface or PBus
connections. This allows for multiple clients to make connections to Lyric at a time.

Lyric can be controlled via Intelligent Interface commands along with support for Pbus.
Intelligent Interface connections can take advantage of a built in "Rules Engine," which
provides customizable control over how an automation system communicates with Lyric.

Automation Settings @
Connections W Intelligent Interface PBus ‘ Edit Rules Delete | Enahle Disable
Type Marne Part Encoding Enable On Startup Status
@ IntelligentInterface 1 49528 Unicode v = aiting For Cannection ...
@@ Lyric TCOML COML Western Eurapean (Winda... @ Connected
@@ Lyric TCOM? COoM2 Western Eurapean (inda... D Disabled
@ LyricITelnet 3 “Western European (Windo... ) Disabled
Automation Log ~ [] Show Data @l ClearLog
Titne Connection Command Response Duration

Intelligent Interface 1 Waiting For Connection ... 11:53:40 M

Intelligent Interface

Intelligent Interface is a ChyronHego created industry standard command protocol that is
used across its graphics systems, and with non-ChyronHego graphics and automation
systems as well.

Intelligent Interface provides a mechanism for controlling the update and display of graphics
and text through an ASCII-based command set transmitted over a serial port or network
connection. The command set is outlined further in this document.

Many programs, including newsroom automation systems, have been written to support this
protocol, and many programmers in the television broadcast industry are familiar with the
command set and its functionality. In addition, commands for changing text properties and
running animations can also be exchanged via the serial link.

For Enabling Lyric Objects for update via Intelligent Interface
See Update Ordering

Intelligent Interface is set up in two places Config> Intelligent Interface Settings and
Config> Automation.
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PBus

The PBus is a one-way serial interface which provides control over client devices from a
switcher or other controlling device. It enables the controlling device to cue and play
scenes and execute transitions or macros on the client using a register mapping
scheme to select the target files for playout.

Adding an Intelligent Interface connection
Click the Intelligent Interface icon which is located in top toolbar.

Intelligent Interface Connection Types

There are two types of Intelligent Interface connections:

e Network - Provides an Intelligent Interface connection via a network, i.e. Telnet

connection.
r ™
Add Intelligent Interface Connection M
W Properties
Mame Intelligent Interface 1
Connection ’ Metwork -
Port 49528
Encoding ’WStem European (Windows) -

Connect on Startup

Options [] Transmit Pro Events
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e Serial - Provides an Intelligent Interface connection via a serial connection.

[ Add Intelligent Interface Connection - uw
W Properties
Mame Intelligent Interface 1
Connection ’Seriai v]
Port COM4 -

Baud Rate
Data Bits

Parity

Stop Bits

Encoeding letem European (Windows)

Connect on Startup

[] Transmit Pro Events

Lyric can receive Intelligent Interface signals from the decoder over a dedicated serial
connection or over a TCP/IP network connection. Choose the connection type, and then
modify the configuration parameters to match what the Intelligent Interface device (generally
an automation system) transmits.

Properties

Name - The name of the connection.
Connection Type - Specify whether or not the connection will be through a serial
port or a TCP/IP address. A port may only be used by one interface at a time.

e COM Port Settings - Specify the Baud Rate, number of Data Bits, number of Stop
Bits and Parity.

e Command Encoding - Specifies the text encoding in which received commands
should be interpreted, and sent commands transmitted.

e Connect on Startup - Specifies whether or not the connection will be attempted
upon startup.

Options

e Transmit Pro Events - Sends v commands for the current transition when changing
transitions in Lyric, and sends Frame Notify events in its responses.

In other words when a Lyric Transition is activated on Output, Lyric issues

notification to the external system that initiated the event, that the event has finished
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playing on Output. Notification is formatted similarly to an Intelligent Interface V
command; an example is seen below:

V\01\T\Default\\\9¢c

In the above example, “01” denotes that the Transition event occurred on the
playout system’s frame buffer 1, and “Default” identifies the name of the Transition
in the message.

Enabling Intelligent Interface operation via serial port(s)

Serial port configuration must be performed first from the Windows Control Panel, then from
within the Lyric Config menu. The system running Lyric must be connected via serial port(s)
to the system(s) sending commands.

Enabling Intelligent Interface operation via Telnet

The system running Lyric must be on a network unless commands are sent from the local
system (the same system running Lyric). The system must be configured from within Lyric
to communicate via Telnet.

Intelligent Interface Settings in Lyric

The settings in this dialog are global to the application, applicable to both manual recall and
recall via automation.

r '
Intelligent MEHM |23 |

On Read Legacy Ordering

|§|
() Mon-dlassic
[T respect 30 Text Mumbering
fr'
[7] suppart Embedded Commands
[T tndude the 30 Text Template ID# in the % Command l

Available Connections

Connection Mame ¥ Cmd Message Path
Lyric IT COM1 & C:\Users\chyron
Lyric IT COM2 ] C:\Users'chyron

) Ci\Users\chyron

Lyric II Telnet [
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On Read Legacy Ordering

Intelligent Interface Ordering In LyricX is stored in each scene. Ordering for previous
versions of Lyric ordering was determined by an application configuration setting and could
be alterered.

This setting is for migration of scenes from versions of Lyric8 and previous, and is applied
on read.

When opening a legacy message or importing an LNO into LyricX for the first time, the order
type must be determined before reading the scene or importing the nodes. This determines
the order that they appear in View > Template Update. Once the scene is saved in LyricX
these options will not affect the ordering, as it will be managed by the Update Ordering
Pane.

To ensure a seamless migration, select the option that matches the settings in the version
that is being migrated from.

e Classic legacy ordering (in order by creation) is used. (Camio uses this)

e Non-Classic Grouped based ordering is used (in order of how nodes are grouped
in the Scene Graph, from top to bottom). For example, if all of the groups on the
Scene Graph of a given message were expanded to display all nodes in that
message, then the order in which any updateable elements appeared would dictate
the order of Update

e Respect 3D Text Numbering When checked, 3D text templates are ordered by
number in any ordering scheme.

Support Embedded Commands

Allows the use of specialized text strings, for instance a field update in a V/R/W/U
command, or template data message, could contain color and/or font changes which are
determined using keyboard codes that are in the ASCII range 160 and above. This
prevents characters in that range, such as the English pound sign £ (ASCII 163), from being
processed properly. Disabling this setting allows the characters to be parsed properly as
text.

Include the 3D Template ID number in the X command

When checked 3D template ID numbers are included as part of the X command. (2D
Template ID numbers are always included). See command set below for full details.

Available Connections
e Connection Name - Enumerates all the connections available in the Automation
Manager
e X command - determines which connection will receive the X command when a
scene with external update fields is read up.
e Message Path - Lists each connection’s current message path.
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For more information on setting up Intelligent Interface see additional ChyronHego
documentation which can be supplied by, contacting ChyronHego Customer Service at +1
631 845 2132 or +44 208 996 9933.

Command Set Overview

The Intelligent Interface commands are invoked by an identifying letter followed by a set of
parameters. The table below outlines the command letters.

Command [ Description

C Change color of specified field.

E Define Macro to read message.

F Change font of specified field.

M Set disk drive and message directory
Q Resend previous response.

U Update one field

\ Special Effects and Control.

w Write to Template Data message
Xand R Requests External Update and responds to Update Request.
Y Assorted.

Command Syntax

Commands for Intelligent Interface consist of bidirectional data exchange between the host
computer and the system. The protocol consists of a group of single-letter commands,
which are followed by various modifiers and data as required.

Intelligent Interface Rules Engine

The Rules Engine allows for control over an automation systems communication with Lyric.
Lyric can be controlled via Intelligent Interface command syntax it already understands
(outlined above), however, via the Rules Engine any command sent from an automation
system can be configured into Lyric operations.

Terminology

Behavior refers the Lyric operations to be performed, such as open or play scene. Typical
automation system interactions with Lyric take the form of requesting that these behaviors
be executed in some sequence: open scene 1000, play scene 1000, etc.

A Command is the Intelligent Interface string sent by an automation system for example
PLAY\1000\\.
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A Pattern is the combination of literal characters and keywords designed as placeholders
for parameters that match the incoming Intelligent Interface command String for example
PLAY\<Sceneld>\\

Parameters are considered a variable, for example <Sceneld> which may or may not be
required as defined by the needs of each particular command.

A Rule is simply a means of matching a command string to one or more Lyric behaviors.

Adding Rules

From the Config Menu, select Automation then highlight the desired Intelligent Interface
connection from the Automation list. Click the Rules button on the Main User Interface
toolbar or right click and select Customize Rules. Each connection maintains a separate list:

Intelligent Interface 1' Rules 3|

g Add Rule Change Rule (g Delete |ﬁ1mport W Export

Rule Title Pattern

iClose L\CL\=SceneMame =1}
Open LVOPY<SceneMame =1,
Flay L\PL\=SceneMame =1

[] Ignore All Unmatched Rules [ Respond Immediately (Before Processing)

Changes to Play finalized.

Customizing Behavior
Click Add Rule to configure behavior.

The Title and Pattern are editable, as is the list of behaviors that constitute the rule.

It is important to note that patterns are matched from left to right, with the leftmost character
necessarily equivalent to the first character of an incoming command. Patterns are not
case-sensitive.

Drag and drop the desired behaviors from the right column to the Behavior list on the
lefthand side. Right click to move the behavior up and down the list or to remove it from the
rule.

Double-clicking on one of the behaviors in the list will change the view to an editor for that
rule.
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‘Intelligent Interface 1° Rules E
i Add Rule Change Rule @@ Delete | g Import 8 Export
Configure Rule
Title: Close
Pattern: LVCL\<SceneMame =4}
Customize behaviar by dragging operations from the right column to the left.
=2-fk Behavier || e k| Change
L Cose ] e o Ignore
...... E Erase &% Open
[éj L Play
..... E@ Respond
..... i@ Script
..... i:ﬁ Stop
-4 Transfer
----- 1% Transition
Simple Protocol
[7] Enabled Character Count: |1 v
Reset [ Save ] [ Cancel ]

Behaviors
Each unique behaviour may only appear once in the behavior list.

e Change - Change to the selected frame buffer, which must be provided as the
parameter <Channel>. Example: Test\Change\<Channel>\\

e Close - Closes/erases/clears a particular scene or collection of scenes. The Scene
name may be provided as the parameter <SceneName>, otherwise the default
<SceneName>, if any, will be used. The special scene collections $ALL, SCANVAS,
$OUTPUT, $SEL will close all scenes in the frame buffer, all scenes in the canvas,
all scenes on output or just the selected scene respectively. Example:
Test\Close\<SceneName>\\

e Erase - Erase the graphics on the output of the selected frame buffer. This must be
provided as the parameter <Channel>. Example: Test\Erase\<Channel>\\

e Ignore - Causes all subsequent behaviors to be skipped, and allows Intelligent
Interface to disregard unsupported command strings without returning an error.

e Open - Opens a Lyric scene from storage. The scene name must be provided as
the parameter <SceneName>. Example: Test\Open\<SceneName>\\

e Play - Play a Lyric scene, or collection of scenes, to the output of the current frame
buffer. The scene or collection must be provided as the parameter <SceneName>.
The scene name may either refer to the message number of the scene, or the
scene name on the Transition page. The special scene collections $ALL,
$CANVAS, SOUTPUT will play all scenes in the frame buffer, all scenes in the
canvas or replay all scenes on output respectively. Example: L\CL\<SceneName>\\
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e Respond - Send a response back to the Automation client. If the response is
earlier in the list than the behavior, then the response is just a notification to the
client that the command has started processing. Otherwise, it contains the status of
the previous behavior. Double click to customize.

Edit Response Behavior - - M

You may customizethe behavior of a response by modifying the values below. All responses
are automatically appended with the carriage return and line feed necessary to properly
terminate an Intelligent Interface response. Success/Failure messaj} may include awild-
card (####) to represent the placement of an error code.

On Success: *

On Failure:  ####

[] utilize compatibility modeerrar codes only.[ | Send custom message.

[] Include checksum.

e Script - Executes Lyric macro code. The macro must be provided in the <Script>
parameter, and may either reference the name of a saved Lyric macro, or may
contain inline LEIF VBScript code. Example: Test\Script\<Values>\\

e Stop - Stop animating a particular scene, or collection of scenes, on the current
frame buffer. The Scene or collection must be provided as the parameter
<SceneName>. The special scene collections $ALL, SCANVAS, SOUTPUT will
stop all scenes in the frame buffer, all scenes in the canvas, or all scenes on output
respectively. Example: Test\Stop\<SceneName>\\

e Transfer - Transfer a particular scene or collection of scenes on the current frame
buffer to output or back. The Scene or collection must be provided as the parameter
<SceneName>. The special scene collections $ALL, SCANVAS, SOUTPUT will
toggle all scenes in the frame buffer, transfer all canvas scenes to output, or transfer
all output scenes to the canvas respectively. Example: L\CL\<SceneName>\\

e Transition - Execute a transition on a particular scene or collection of scenes on
the current frame buffer. The transition name must be specified in the <Transition>
parameter, and the scene or collection must be specified in the <SceneName>
parameter. The special scene collections $ALL, $CANVAS, SOUTPUT will execute
the transition in all scenes in the frame buffer, all scenes playing in the canvas, or all
scenes playing on output respectively. Example: L\CL\<SceneName>\<Transition>\\

Configure Rule
Title: ANIMATE

Pattern:  L\<SceneName>\<Transition >\\

The above rule uses the parameters <SceneName> and <Transition>. Below is the ii
command sent to trigger the transition ‘animate’ in scene ‘test’. You could use this to
Trigger ‘Effect Out’ in scene ‘Bug’

| \testhanimatehh,
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‘Intelligent Interface 2° Rules @

i Add Rule Change Rule {g Delete | g Import (@@ Export

Configure Rule
Title: ANIMATE

Pattern:  L\<SceneMame=\<Transition:=1}

Customize behavior by dragging operations from the right column to the left.

=&z Behavier e [ Change
Transion fe ] Close
Respond e | Erase
----- i Ignore
..... ..‘-‘é' Open
.,ig Play

..... |@ Seript
..... ‘:-f Stop

i Transfer

Simple Protocol
[] Enabled Character Count: |1

The following is an example response.
g | zg

Edit Response Behavior . J

You may customize the behavior of aresponse by modifying the values below. &ll responses
are automatically appended with the carriage return and line feed necessary to properly
terminate an Intelligent Interface response. Success/Failure messages may include awild-
card (##%#) to represent the placement of an error code.

On Success: =

On Failure: 5000

[77] utilize compatibility modeerror codes only.[ ] Send custom message.
[7] Include checksum.

Reset Cancel

External Connection Manager

The Lyric Connection Manager contains user defined external connections allowing
remote control of external devices. Devices like routers, Channel Box, PowerClips,
switchers, or any network or serial connected device can be triggered from a keyframe on
Lyric’s timeline.
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Port Ercoding Erable On Hartup

@ Conmacion | Fer TR TR Watoon (uopien (W = B Sornetaon non o conmacion comkd b misds

Comraition ][] Conricton Goge  Thes ot "COMY doois s it 1000 AN

The Connection Manager is capable of sending strings of text via network or serial
transmission. By specifying the proper connection parameters and adding commands

to the Command list, Lyric can be programmed to send a command to a connected device
(ChyronHego or non) from any point in your scene.

The External Connection Manager is where the connections and commands for other
devices are configured. The External Connection Manager is accessible from Config >
External Connection Manager.

Once configured the connections to the external devices are active. Previously created
connections are active on Lyric startup if configured. The Connection Manager XML
Configuration file is stored in C:\ChyronHego\Lyric\ConnectionManager folder, and can be
imported or exported to maintain consistent connections across multiple Lyric devices.
Connections are not contained in Lyric LBU files.

Connection Manager Main User Interface

e Name - Description of Connection

e Connection Type - Specify either a TCP/IP address or a serial port. A port can
only be used by one interface at a time.

e COM Port Settings - Specify Baud Rate, number of Data Bits, number of Stop Bits,
and Parity.

e Command Encoding - Specifies the text encoding in which received commands
should be interpreted and sent commands transmitted. Users can choose whether
or not the connection will be attempted upon startup.

Default commands for each connection can be entered here. They can be accessed
via Trigger Track > External Connection Actions. See the trigger track
documentation for more information.
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Add Message Interface Connection =
o Properties
MName Connection 1
Connecticn [Senal vl
Baud Rate 9600 -
Data Bits
Stop Bits
Enceding [Westem European (Windows} b

Connect on Startup

Header . -
Default
Command
Terminator -
ok || cancel |
 Add Message Interface Connection ==
W Properties
Mame Connection 1
Connection MNetwork v
Address 127001
Port 49528
Encoding ’Wv?stem European (Windows) -

Connect en Startup

Header =
Default
Command
Terminator hd
[ ok || Cancel

Specialized Command Tags

The External Connection supports common non-printing codes, hex values, and plain text.
Codes and hex values need to be surrounded in a tag (angle brackets < and >) to be
interpreted correctly. Plain text can be written anywhere and does not require tags. If a tag
is not recognizable, then it will be left untouched. If necessary, angle brackets can be
escaped with a leading backslash (\< or \>):

\<TOM\> will be replaced with <TOM>
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<LF> will be replaced with the line feed character

<TAB> will be replaced with the tab character

<EOT> will be replaced with the end of transmission character
Hex examples:

<A> will be replaced with the line feed character

<41> will be replaced with the A character

<7D> will be replaced with the } character

External Connection formatting also applies to the Header and Terminator properties.

All available codes:

"<NUL>", "<SOH>", "<STX>", "<ETX>", "<EQOT>", "<ENQ>", "<ACK>", "<BEL>", "<BS>",
"<TAB>",

"<LF>" "<VT>", "<FF>", "<CR>", "<SO>", "<SI>", "<DLE>", "<DC1>", <DC2>", "<DC3>",
"<DC4>", "<NAK>", "<SYN>", "<ETB>", "<CAN>", "<EM>", "<SUB>", "<ESC>", "<FS>",
"<GS>",

"<RS>", "<US>"

Command Encoding
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Add Message Interface Connection |
B  Properties
Name Connection 4
Connection Metwork hd
Address 1270041
Port 49528
Enceding Western i =
US-ASCH
Hesder Unicode
Dot e e
Unicode (UTF-8)
Terminator -

Connection Manager Command List

‘o Commands

i Add [ Edit J{ Delete | & Import & Export

Mame Command

iBlack Magic Router <A>0 5<A> <D= < A>VIDEQ OUTPUT LOCKS: < A5 U<A» < Ax <D» <A

< 1 | r

The command List is a name/value pair dictionary.

To add a new command, press the "Add" button and enter the name of the command as
well as the actual command string.

Any commands added will be available to be executed at a keyframe added in the Events
tab of the Properties window.

The command must be first added to the command list before it will be available in

the Events Command External Connections list.
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Adding a External Connection action in a trigger track

See the Trigger track documentation for information on adding External Connection actions
to trigger tracks in Lyric.

Commands for External Devices

Devices that can be controlled include any that can receive any external command
(routers, clip players, switchers, branding devices). Check your device's users guide
for its protocol.

Devices that require only VDCP may not work.

Connections through LEIF

Connections can be made through LEIF to be done on read with Embedded macros as well.
Please check the LEIF Help file for syntax and command examples.

Global GPlIs

Users can assign a .lyr file (scene or macro) to a Global GPI

The Configure Global GPI dialog only displays GPI numbers configured to input in the
Config > Hardware > Setup GPI.

Configure Global GPI's
From the Config Menu, Select Global GPI's

" Configure Global GPIS,

GPI File
17 I:W¥mio Demo Messages \Messages 00000002, yr

|:| 18:
] 1s:
20: 20- I:Wmio Demo Messages\Messages 00000003, lyr
[ 21
|:| 22
|:| 23
] 24

e GPI displays GPI number and description
e File displays the associated .lyr file
Lyric must be relaunched to apply settings.

Make sure that the GPI that is assigned as a Global GPI is not already assigned to be used
in another capacity (for example, in a Playlist or to trigger as there may be a conflict when
the GPI or Global GPI is triggered.

When a GPl is assigned as Global you cannot assign it to any other GPI function and it is
no longer visible in the GPI dropdowns in Lyric (i.e. Triggers etc)
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License Code

From the Config Menu > License Code

Activation

v Locking Code B MNERUOGORT GMDbsd iR MIWDMEy THDA [P Copy Email

License y A -
S - T Paste
- e sgn - e g gn g gl ey

- o gl e A L e L T
- Flge ) - - gt
Skatus @ Walid, never expires
‘Website httpf e, chyronheno, com Activate J I Exit

To activate a license code:
1. Copy or email the system's unique Locking Code to support@chyronhego.com.
2. ChyronHego will return a license code that is to be pasted in the License text box.
3. Select Activate to activate the code.
4. The Status will display the validity of the code.

To view the Licensed features, click Details. This dialog displays all of the Licensed
Features, as well as Unlicensed Features and User Data.

To view plugin details and Lyric System info, refer to Help > About Lyric
call

Licensed Features
Feature 1: Online
Feature 3: ThreeDObject
Feature 4 hedia
Feature 5: DBLink
Feature 6: AutoFormatting
Feature T: XMP
Feature 8: AdvancedTransitions
Feature 9: HotSpots
Feature 10: WideoOhject
Feature 11: DataOhbject
Feature 12: Macros
Feature 13: Intelligentinterface
Feature 14: Wirtual Output
Feature 15: Awvid
Feature 16: AdvancedTextEffects
Feature 17: AdvancedimageEffects
Feature 18: Clips
Feature 19: EnabledllFeatures
Feature 20: LyricVersion2
Feature 22: LN Os

Unlicensed Features
Feature 2: Offline
Feature 21: LyricVersion3
Feature 23: ServerCnly

User Data
Decklink=FFFFFFFF
MatroxL E3=FFFFFFFF
MatroxD SX=FFFFFFFF
LyricIP=FFFFFFFF

Video and Audio Video Codec Licensing
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Video and Audio codec support for encode/decode clip formats is determined by hardware
licensing SKU. The SKU of the board may be determined in the Lyric Hardware
Configuration Dialog under Board Type.

Enable Modal Suppressor

This option is intended for use with automation products such as ISQ or CAMIO. When
Lyric's Modal Suppressor is enabled, it prevents dialog boxes requiring an operator's "OK"
from interrupting playout operations.

Lyric M

o Thefollowing 1 images for "5500" could not be located:
i &
I\Project Folder\Images\textures\Flare 01.tga

! -

This is important when systems are being driven by ISQ or CAMIO. Warnings of missing
texture files, missing clips, prompt-to-play messages and overwrite prompts are dismissed.
This permits the playout of the current message to proceed without the missing
components or delays due to other less-than-critical problems. When a prompt has been
suppressed, Lyric displays a red status bar message.

Prompt suppressed: The following 1 images for "5500" could not be located Luri - Chyron Corp =

To enable the Modal Suppressor,
1. Navigate to Config > Modal Suppressor.
2. Select the Modal Suppressor to enable/disable the Modal Suppressor.
[Cunfig] Tools  Help
Load Settings

Save Settings

Hardware

Canvas Resolution
Preferences

Safe Title Adjust
Default Effect

Automation

Intelligent Interface

External Connection Manager
Metwork Settings

Global GPIs

License Code

v Enable Modal Suppressor
Logger 4
Reset Keyboard
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Logger

Logging in Lyric enables the user to view and retain a record of Lyric operations in a text
document. Lyric log files use the extension .log and the file name reflects the date and time
the log was started. Windows will identify a Lyric.log file as a Text document under "type."

-

Logger v Enable Logger

Reset Keyboard View Log

View Log Folder

Logging is enabled when the Enable Logger option is checked. This setting does not
persist, and will not be enabled, when Lyric is closed and restarted.

Specifics about the manner in which the Lyric.log file writes and stores information may be
altered by opening the ClientConfig.icf file in Windows Notepad. For instance, the log
information may be saved as a HTML or XML, or the frequency with which the log is
updated may be varied.

Viewing the Log File
From the Config Menu > Logger > View Log

e N . s

v |, « CHYRON~1.000 » AppData » Local » Temp » Stdlog S [Fee vaie P

Eile Edit View Tools Help
Organize « || Open Share with = Burn Mew folder 4=z il @

.. Stdlog = Mame Date modified Type
| TCDDF4Etmp
| TCDDF4F tmp
. TCDDF50.tmp
| TCDDF&1tmp

. TCDESF&.tmp
. TCDE926.tmp

| 2016.08.26.09.52.34.663.log 8/26/2016 9:53 AM  Text Document
| 2016.08.24.00.54.50.121.l0g 8/24/20161:05 AM  Text Document
| | 2016.08.16.12.59.48.012.l09.2016-08-16  8/16/2016 3:48 PM  2016-08-16 File
L 2016.08.16.12.59.48.012.log B/A7/201612:23 AM  Text Document

All previously generated logs are found in this location.

Reset Keyboard

Reset ChyronHego Keyboard releases any keys that the system interprets as being
engaged.
1. Navigate to the Config Menu, and select Reset Keyboard.
2. If the keyboard does not start operating as expected, check that any cables or
extenders being used are compatible with ChyronHego hardware.

Keyboard Codes

If the ASCII or Keyboard code is known for any text/special characters, they can be entered
directly from the keyboard.
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Typing Characters Using ALT + ASCII Codes

Characters with ASCII codes from 0 through 255 may be typed on the Canvas by pressing
and holding the Alt key while entering the ASCII code padded out to four digits. The
numbers must be entered on the numeric keypad, not the alphanumeric keys located
along the top of the keyboard. This method works for both TrueType ® and RGB Fonts.

For example, to type the character ©, which is code 169 in the Arial font:

e Press and hold the Alt key while entering 0169 on the numeric keypad.

Typing Text in Lyric - Standard and Translation Modes

For the most part, typing 2D or 3D text on the Canvas is performed in the same manner as
typing text using a word processor. Most characters are typed in Standard Mode. However,
Alt characters, which are produced by key combinations that include the Alt key, must be
typed in Translation Mode. This is due to the fact that pressing the Alt key in combination
with alphanumeric keys activates Lyric functions such as font and menu selection. There
are 2 translation modes:

e Locked Translation Mode - This mode activates Translation mode until turned off.
Toggle it on and off by pressing and holding the Ctrl key, and then pressing the
hyphen key on the keyboard. Do not mistakenly use the Minus key on the
numerical keypad, whose use is largely devoted to Message Record functions.

e Single-Stroke Translation Mode - This mode activates Translation Mode for typing
one character only. Toggle it on and off by pressing and holding the Ctrl key, and
then pressing the = key.

The Alt key is not needed once Translation Mode is activated. Simple press the key that
makes up the remainder of the Alt keystroke combination.

Key Showing the Four Possible Keystroke Combinations

As shown in the figure, there are four possible key combinations that can be produced by
the keycap A:

e A - Sends Code 97 to the system. To type A, the system cannot be in Translation
Mode.

e Shift + A- Send Code 65 to the system. To type Shift + A, the system cannot be in
Translation Mode.

e Alt+ A - Sends Code 150 to the system. To type Alt + A, activate Translation
Mode, and then type A.

e Alt + Shift + A - Sends Code 149 to the system. To type Alt + Shift + A, activate
Translation Mode, and then type Shift + A.

Translation Mode also offers a convenient way to use all four of the ASCII codes that Lyric
assigns to each key of a PC or ChyronHego keyboard. While helpful for access to
nonstandard characters, this feature is especially useful with the RGB Font function. Some
production situations, such as sporting events, require quick recall of a large number of
bitmaps linked to keystrokes. The Translation Mode allows the use of the Alt keystroke
combinations to access RGB Font characters.

When Translation Mode is inactive, TRNS on the Lyric Status Bar is grayed out.
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Keyboard/Mouse Shortcuts

Lyric offers a variety of keyboard/mouse shortcuts. Many of the keyboard shortcuts work on
both ChyronHego keyboards and conventional PC keyboards. Differences between the two
keyboards are indicated.

Menu items can also be executed by first clicking Alt and then the underlined letters for the
desired Menu and item. Menu item shortcuts are indicated.

Assigned Hotkeys override Lyric shortcuts.

Help
ChyronHego Description
Keyboard/PC
Keystroke(s)
F1 Help
Interface
ChyronHego Description
Keyboard/PC
Keystroke(s)
B3 Shifts focus to the Scene Graph Pane
F4 Shifts focus to the last selected Browser
F6 Shifts focus to the Canvas
F8 Shifts focus to the Scene Tree

Right Click View Right Click any opened item in the View Menu to set focus on that pane or
Menu Item toolbar tool

Shift F10 Equivalent to a Right Click to open contextual menu
Mode Select - Switches among open applications

ChyronHego

keyboard

Alt + Tab -

PC Keyboard

Alt + F4 Exits Lyric

Canvas View

Mouse Wheel Description

Spin Zooms into/out from the Canvas
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Ctrl + Spin

Zooms into/out from the Canvas more quickly

Shift + Spin

Zooms into/out from the Canvas more slowly

Press + Move

Pans around the scene.

Editing Objects

ChyronHego Description
Keyboard/PC

Keystroke(s)

Ctrl+ Z Undo

Alt + Backspace

Ctrl +Y Redo

Ctrl + left click

Multiselect items on the Scene Graph or on the Timeline

Alt + Click Cycles object selection under the mouse when clicked on the Canvas
Ctrl + Delete Deletes selected objects from the Scene Graph and Canvas

Ctrl+ C Copy

Ctrl + Insert

Ctrl + X Focus inside 2D Text Window or 2D Text Template: Cuts selected text.
Shift + Delete Focus on Scene Graph or Timeline: Cuts selected items.

Ctrl +V Paste

Shift + Insert

Ctrl + 1 Paste in place

Shift Page (Moving objects using the keyboard)

Shift Page allows for moving objects using the keyboard. It can move All Objects or Selected
Objects depending on the setting applied in Preferences:
Config > Preferences > Shift Page:

Selected Objects enabled: Moves selected objects only
All Objects enabled: Moves all objects

ChyronHego
Keyboard/PC
Keystroke(s)

Description

Ctrl + Alt + 71—

Shift Objects incrementally up/down/left/right:

Shift + Ctrl + Alt +

Shifts Objects in 10-scanline/pixel increments up/down/left/right:
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ChyronHego
Keyboard/PC
Keystroke(s)

PC Keystroke(s)

Description

New Canvas

Ctrl + O Ctrl + O Invokes the File Open Dialog

Erase Canvas

Ctrl + E Ctrl + E Erase: Prompts the user to choose from among several
options

Erase Ctrl + Q Erases all scenes on the Canvas Scene Tree.

Shift + Erase

Shift + Ctrl + Q

Erases only the selected Scene on the Canvas Scene
Tree

Message Number (Clear)

numeric keypad

ChyronHego PC Keystroke(s) Description

Keyboard

Keystroke(s)

Del . (Decimal/Del) Clears the Message Number display.all
key on the

Opening Lyric Messages (Read)

Read Previous

numeric keypad

ChyronHego PC Keystroke(s) Description

Keyboard

Keystroke(s)

Read Enter on the Read message to Canvas.
numeric keypad

Ctrl + Read Ctrl + Enter on Read Next. Reads the next message found within the

Read Next the numeric Read Next Message range set in Config > CG
keypad Preferences

Alt + Read Alt + Enter on Read Previous. Reads the previous message found

within the Read Next Message range set in Config >
CG Preferences

Alt + Ctrl + Read
Alt + Read Next

Alt + Ctrl + Enter

Finds the next blank numeric message number
(Displays number in the Message Number tool)

Shift + Read

Shift + Enter on
numeric keypad

Reads additional Scene to Canvas
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Ctrl + Shift + Ctrl + Shift + Reads a message and ignores the Embedded Macro
Read Read script
Ctrl + <> Ctrl + <> Navigates Alphanumeric Scenes alphabetically when

Use Alphanumeric Messaging Preference is
selected. Config > CG Preferences

Use preceding numerals for easier navigation: eg
200 PlayerName

Saving Lyric Message Files (Record)

the numeric
keypad

ChyronHego PC Keystroke(s) Description

Keyboard

Keystroke(s)

Record Minus key (-) on Records message at displayed message number.

Same functionality as File > Save As

Alt + Record or
Ctrl + S

Alt + Minus key (-)
on the numeric
keypad or Ctrl + S

Overwrites the current message. Same functionality
as File > Save

Record Only (Selective Recording)

Selective Recording - The Record Only Menu allows for specialist Record functions

Ctrl + Alt + Record (ChyronHego keyboard) and Ctrl + Alt + Minus key (-) on the numeric
keypad (PC keyboard) key combinations can be used to overwrite the currently loaded
message, without prompting for an overwrite confirmation.

ChyronHego
Keyboard
Keystroke(s)

PC Keystroke(s)

Description

Ctrl + Record T
Enter

Ctrl + Minus key
(-) on the numeric
keypad T Enter

Records All Text in selected 2D Text Window. See
Record Only > Pop On Messages

Ctrl + Record E
Enter

Ctrl + Minus key
(-) on the numeric
keypad E Enter

Records Cursor to End of text in selected 2D Text
Window. See Record Only > Pop On Messages

Ctrl + Record R
Enter

Ctrl + Minus key
(-) on the numeric
keypad R Enter

Records Current Row of text in selected 2D Text
Window. See Record Only > Pop On Messages

Ctrl + Record D
Enter

Ctrl + Minus key
(-) on the numeric
keypad D Enter

Records Template Data Message.
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Ctrl + Record X
Enter

Ctrl + Minus key
(-) on the numeric
keypad X Enter

Records XML Data Message.

Ctrl + Record S
Enter

Ctrl + Minus key
(-) on the numeric
keypad C Enter

Records only Scenes open on the Canvas

Ctrl + Record M
Enter

Ctrl + Minus key
(-) on the numeric
keypad M Enter

Records only Macro information in the .lyr format to
the Default Message Directory. The file format is the

same as that recorded from Macros > H
when the Macro is saved in the .lyr format.

> Save,

Ctrl + Record F
Enter

Ctrl + Minus key
(-) on the numeric
keypad F Enter

Records only Default Effect information in the .lyr
format. The file format is the same as that recorded
from Config Menu > Default Effect > Save.

Ctrl + Record P
Enter

Ctrl + Minus key
(-) on the numeric
keypad P Enter

Records the only the Playlist information in the .ply
format to the Default Playlist Directory similar to File
menu Save As .ply file format

Delete Message

ChyronHego PC Keystroke(s) Description

Keyboard

Keystroke(s)

Delete Msg Alt + F5 Deletes message file of the message displayed in

the Message Number toolbar; requests confirmation
from operator.

Canvas and Output (operations)

ChyronHego PC Keystroke(s) Description

Keyboard

Keystroke(s)

Ctrl + F1 Ctrl + F1 Activates Frame Buffer 1

Ctrl + F2 Ctrl + F2 Activates Frame Buffer 2

Xfer / key on the numeric Transfers frame 0 of the Default Timeline of
keypad active Frame Buffer to Output.

Swap Ctrl + / Swaps content of the Scene Tree (Canvas) to

alternate Frame Buffer
Alt + Xfer Alt + / Transfers the contents of the current Canvas to

the alternate Frame Buffer without changing the
active Frame Buffer.
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Chng * key on the numeric Activates inactive frame buffer.
keypad
Ctrl + Chng Ctrl +* Activates next scene in selected section
(canvas or output) in Scene Tree
Ctrl + Alt + Chng | Ctrl + Alt + * Toggles between canvas and output scenes in
SceneTree
Play Alt + Page Up Plays a Scene on the Canvas
Ctrl + Play Ctrl + Alt + Page Up Plays a Scene to Output
Esc Esc Stops the animation.
Ctrl + Alt + Erase | Ctrl + Alt + Shift + Q Erases the active output.
Alt + Erase Ctrl + Alt + Q Erases all outputs
Effect Out Ctrl + Alt + Page Down | Runs the Effects Out for non persistent
message on output
Live Edit
ChyronHego Keyboard [ PC Keystroke(s) | Description
Keystroke(s)
Ctrl + Fn + F6 Ctrl + F11 Toggles LIVE EDIT button on and off.

Previewing (Canvas)

Keystroke(s) Description

Alt + Next icon Advance to next keyframe of selected object.

Pl on Canvas
Transport Controls

Alt + Previous icon | Return to previous keyframe of selected object.

fi4 on Canvas
Transport Controls
Alt + Home Go to beginning of animation.
Alt + End Go to end of animation.

Timeline Editor

Mouse/Keyboard Description
Action

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 274

Left Click Drag
Keyframes

Moves the selected keyframe(s) along the mouse location. Dragging the
first keyframe adjusts the track start. Track length is extended when
keyframe(s) are moved beyond the track end

Left Click Drag
Animation Track
End

Expand or trim selected track(s). Track length is not permitted before the
last keyframe when trimming. Will not delete keyframes.

Ctrl + Left Click
Drag Animation
Track End

Expand or trim selected track(s). Allows deletion of any keyframes when
trimming.

Alt + Left Click
Drag Keyframes
or Animation Track
Start/End

Stretch or shrink selected track(s) or keyframes; keyframes adjust
proportionately. Animation tracks are adjusted by dragging the start or
end of the track. Stretching and shrinking selected Keyframes is adjusted
by dragging the first selected or last selected keyframe.

Shift + Left Click
Drag Animation
Track Start/End

Expand or trim selected track(s). The first/last keyframe moves along with
the end of the track when trimming. If other keyframes are encountered
while trimming, the one closest to the start/end of the track will overwrite
any other keyframes shared attributes.

Middle Mouse Pan

Holding down the middle mouse button and moving pans around the
Timeline track area in horizontal and vertical directions

Middle Mouse Scrolling the middle mouse button forward and backward zooms the
Scroll timeline track area in and out.

Ctrl + X If selected on the Default Timeline, cuts selected node from the scene. If
Ctrl + Delete selected on a Timeline other than the default, the selected node is

removed from the active timeline and remains in the Scene.

Shift + Left Click

Holding Shift while Left clicking on a keyframe cycles through
interpolation modes

Right Click

Right Click add Timeline tab i to add currently selected nodes

Scrubbing forward
and back

Scroll Wheel or keyboard arrows moves forward and back on the timeline
when focused on the time indicator

Navigate up and
down pane view

Scroll Wheel moves up and down the timeline pane when focused on the
right side scroll bar

Scene Graph

ChyronHego Description

Keyboard/PC

Keystroke(s)

Right Click Right Click the + next to any group to expand and collapse all groups
contained within.

Ctrl+ G Group selected nodes
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Ctrl+ U Ungroup node
Ctrl + X Cuts selected node(s) from the Scene
Template Update
ChyronHego Description
Keyboard/PC
Keystroke(s)
Alt+T Opens Template Update Pane from which instant updates can be
executed
Tab Toggles the cursor through the fields on the selected tab
Shift + Tab Moves the cursor through the fields in the reverse direction
Ctrl + Tab Toggles through the updatable categories (Text, Image, Media etc)
Shift + Enter Inserts a carriage return character into a text template field
Enter Applies Change and closes pane
Esc Cancels changes and closes pane
Browser
Mouse/Keyboard | Description
Action
F4 Switches focus to last selected Browser

Click-and-Drag

Image assets from the Browser window to the Lyric Canvas. May be
dropped onto the Canvas or into a Text Template or 2D Text Window

Click-and-Drag

Image assets from the Browser Window to Texture Chip in View > Surface
Properties

Click-and-Drag

Lyric Message/Scenes from the Browser window to the File Name field in
the Playlist.

Click-and-Drag

Assets from one Browser window to another Browser window.

Click-and-Drag

Lyric messages and graphics from Windows® Explorer®-type windows
into Lyric Browser Message/Scenes and Image Asset Browser windows,
respectively.

—1—] Moves the Browser cursor from item to item in the Browser Window.
Home Moves the scroll bar to the top of the Browser Window.
End Moves the scroll bar to the bottom of the Browser Window.
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Enter or
Double-Click

When a Browser item is highlighted, press either Enter key to open the
selected item. Double-clicking the item also opens the item on the
canvas

First letter or
number of file
name

Typing any character key finds the next Browser entry with a title that
starts with that character.

Alt + Keys 0
through 9

Alt + Shift + Keys
0 through 9

Accesses user-defined fonts in the Font Asset Browser.

Playlist

ChyronHego
Keyboard/PC
Keystroke(s)

Description

Playlist Navigation

e Press the cursor keys 1|«—to navigate up, down, left and right. When
using the «—— keys to navigate, when cursor reaches a field that accepts
text entry, the cursor steps through the text first before proceeding to the
next field.

Page Up When the cursor is in a Line, Control, Effect or Channel field, press Page

Page Down Up or Page Down to navigate up or down in five-line increments. If the

cursor is in the Line column, the entire line is highlighted.

Click Scroll Bar
Track

In the Scroll Bar, click above or below the scroll box to page backwards or
forwards, respectively, through the Playlist.

Click Scroll Bar
Arrow

In the Scroll Bar, click the up or down arrow to scroll the Playlist one line
up or one line down, respectively.

End

Press End to move the cursor to the next instance of End or to the final
line of the Playlist that contains an entry.

variety of methods.

Current Take Line Indicator Placement : In the event that non-sequential execution of the
Playlist is necessary, the Current Take Line Indicator can be moved to a different line using a

Click Click to the left of a Playlist line to move the Current Take Line Indicator to
the line.
Ctrl + 1] Press Ctrl + 1 or Ctrl + | to move the Current Take Line Indicator up or

down in one-line increments.

Ctrl + Page Up
Ctrl + Page Down

Press Ctrl + Page Up or Ctrl + Page Down to move the Current Take Line
Indicator up or down in five-line increments.

Ctrl + Home

Press Ctrl + Home to move the Current Take Line Indicator to the first line
of the Playlist.
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Ctrl + End Press Ctrl + End to move the Current Take Line Indicator to the next
instance of End or to the final line of the Playlist that contains an entry.
GPI Triggers a GPI to move the Current Take Line Indicator up or down in

one-line increments. The GPI is set up in the Playlist Configuration dialog
box. A GPI can also be used to execute a Take.

Playlist Editing

Ctrl+ C Copies selected fields to the paste buffer.

Ctrl + X If the Speed or File Name field(s) is highlighted, cuts the contents of the
field(s) to the paste buffer.

If the entire line is highlighted, cuts the contents of the line to the paste
buffer.

Ctrl + V Pastes contents of the paste buffer to the Playlist in the line in which the
cursor is positioned.

Insert Inserts a blank line directly above the line in which the cursor is
positioned.

Delete If the Speed or File Name field is highlighted, deletes the contents of the
field.

If the entire line is highlighted, deletes the line.

Ctrl + W Swaps the contents of the line on which the cursor is positioned with the
line directly following. The cursor must be in the Line field and the entire
line must be highlighted for the Swap to execute.

Ctrl + Z Cancels the last edit applied in the Playlist. Reverts the Playlist to the

state directly previous to when the edit was applied.

File Operations

Ctrl + O Displays the Open dialog box from which a file can be selected to open.
Files of Type is automatically set to Playlist Files (*.ply) if the Playlist
window is active.

Ctrl + S Displays the Save As dialog box from which the currently displayed

Playlist can be saved. The Playlist window must be active for Ctrl + S to
save to a Playlist.

Playlist Execution

Esc

Stops Playlist execution.

Font Style Selection (Color/Font)

ChyronHego

Keyboard/Keystroke(s)

PC Keystroke(s) | Description

Color Keys 1 -8

Ctrl + 1 through Selects entries 1 - 8 in the Color Select dialog
Ctrl + 8 box.
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No corresponding Ctrl +9 Selects Palette Positions 9 and 10 respectively
keystrokes. Ctrl+0 in the Color Select dialog box.
Color Keys 9 - 14 Ctrl + Shift +1 Selects entries 11 - 16 in the Color Select
(Shift + Color Keys 1 - 6) | through Ctrl + dialog box.
Color Keys 15 and 16 Shift + 6
are not operational.
Font Keys 1 - 8 Alt + 1 through Selects fonts 1 - 8 as assigned to ChyronHego
Alt + 8 system Font Keys (2D or 3D text).
Font Keys 9 - 16 Alt + Shift + 1 Selects fonts 9 - 16 as assigned to
(Shift + Font Keys 1 - 8) | through Alt + ChyronHego system Font Keys (2D or 3D text).
Shift + 8
No corresponding Alt+ 0 Hotkeys for four additional fonts. Do not have
keystrokes. Alt +9 corresponding dedicated ChyronHego
Alt + Shift + 0 keyboard keystrokes.
Alt + Shift + 9
Color Font Key Alt + F12 Picks up color and font of the currently selected
character.
e Place cursor on text, then press the
Color Font key or Alt + F12.
Subsequent typing reflects the Font Style
2D and 3D Text
ChyronHego Description
Keyboard/PC
Keystroke(s)
Content Review
Ctrl + H Find/Replace
F7 Spell Check

Standard Text Editing - Cut, Copy, Paste, Delete, Erase, Insert, Enter

Ctrl + Z Undo

Ctrl+Y Redo

Ctrl + A Selects all in 2D Text Window or Text Template

Delete Deletes selected text in 2D Text Window or 2D Text Template. Selected
text not stored in Clipboard.

Ctrl+ C Copies selected text

Ctrl + Insert

Ctrl + X Cuts selected text

Shift + Delete
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Ctrl +V Pastes selected text at cursor position.

Shift + Insert

Ctrl + Alt + V Paste Unicode Text: Pastes Unicode text that was previously cut or
copied from another document.

Enter Add Row: Adds new row below current row

Shift + Enter Inserts a line break inside a Text Template

Cursor Positioning

Home Moves cursor to beginning of selected row or Template

End Moves cursor to end of selected row or Template

Ctrl + Home Moves cursor to beginning of active 2D Text Window or selected Text
Template.

Ctrl + End Moves cursor to end of last row of active 2D Text Window or selected Text
Template.

2D Text Only

ChyronHego Description

Keyboard/PC

Keystroke(s)

Ctrl + 1 Paste in Place: Pastes contents of Clipboard on top of and exactly in the
same position as cut/copied text (2D Text Windows only).

Alt + F7 Moves the cursor to the beginning of the next word in a 2D Text Window.

Alt + F2 Center page: Centers text inside 2D text Windows

Alt + Shift + F7

Moves the cursor to the beginning of the previous word in a 2D Text
Window.

Shift + Backspace

Erase All (2D Text Templates only): To erase all text from the selected 2D
Text Template:
e Place the cursor in the 2D Text Template, and then press Shift +
Backspace.

Pressing B increases the size of the selected text (size increases
proportionally). Hold Shift + B for larger increments

Pressing S decreases the size of the selected text (size decreases
proportionally). Hold Shift + S for larger increments

Ctrl + Alt + |

To change the increment by which text is resized:
1. Press Ctrl + Alt + |. to invoke the Scaling Increment Dialog Box
2. Enter a new value and then click OK.

Arrow keys

Using the arrow keys on selected text or templates will resize in all
directions.
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End/Home

Removes the Bounding Box from selected text, and leaves the cursor in
place.

2D Windows Only

Selecting a 2D Text Window

Ctrl + W

Toggles among 2D Text Windows in the order of their creation.

Shift + Ctrl + W

Toggles among 2D Text Windows in opposite order of their creation.

2D Windows Only

Row Edit Functions

Ctrl + L

Lock Mode: Allows locking of 2D Text rows so that they shift as one
group. To toggle on and off:
e Press Ctrl + L or select Row Shift Locked from the Edit menu to
toggle on and off.
When Lock Mode is active, LOCK is not grayed out on the Status Bar.

Alt + Insert

Inserts row above cursor position in 2D Text Window or 2D Text
Template.

Alt + Delete

Deletes selected row in 2D Text Window or 2D Text Template.

Shift + Enter

Inside a 2D Text Window, moves the portion of a 2D Text Window or 2D
Text Template row located to the right of the cursor to the next row.

Cursor at end of
Row, then press
Delete

Pull up Word (2D Text Template Only): Pulls up a word from the following
row to the row on which the cursor is positioned.
e Place the cursor at the end of a row, and then press Del. If there
is room on the current row, the first word from the next row is
moved up to the current row.

Word Wrap must be enabled in the 2D Text Template dialog box for this
to work in a 2D Text Template.

Ctrl + B

Swap Row Up: Swaps row up in a multi-row 2D Text Window or 2D Text
Template. Equivalent to selecting 2D Text Window or 2D Text Template
Context (Right-Click) Menu > Swap Row Up.

Ctrl + F

Swap Row Down: Swaps row down in a multi-row 2D Text Window or 2D
Text Template. Equivalent to selecting 2D Text Window or 2D Text
Template Context (Right-Click) Menu > Swap Row Down.

Alt + P

Swap Row Priority Up: Swaps priority with the 2D Text Window or 2D
Text Template row behind the row on which the cursor is positioned.

Alt +N

Swap Row Priority Down: Swaps priority with the 2D Text Window or 2D
Text Template row on top of the row on which the cursor is positioned.

2D Text Only - Row Tab Functions

Ctrl+ T Add Row Tab Marker
Alt + <, Alt + > Select Previous, Select Next Tab
Alt + M Tab Column Mode
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2D Text Only - Squeeze/Expand Text or Templates

Shifts execute in 1-scanline (up/down) or one-pixel (left-right) increments.
Super Shift moves characters/rows 10 scanlines/pixels at a time instead of by single
scanlines/pixels: Hold Shift while pressing the below keystrokes to invoke a Super Shift

ChyronHego Keyboard/PC Description

Keyboard Keystroke(s)

Shift Character + Ctrl + | —— Shift Character Up/Down/Left/Right

e 2D Text Window: Shifts selected character(s)

up/down or left and right.

Shift Row + 1] Alt+ 1] Shifts Row Up/Down

Modes

Mode are toggled on and off and their active state is indicated at the bottom left of the

interface.

ChyronHego Keyboard/PC Description

Keyboard Keystroke(s)

Ctrl + Alt + U Ctrl + Alt + U When typing in a Text Template, All Caps can be
toggled between enabled and disabled, without
opening the General Properties Pane. This toggle
affects typing in Text Templates in which All Caps is
enabled. Additionally, it does not disable the All
Caps setting in the General Properties.

Fn + Num Lock Num Lock Toggles Num Lock Mode on and off

(same keycap as
Ctrl on the
numeric keypad)

e When active, the numeric keypad at the
right of the keyboard types numbers into the
Message Number pane.

Fn + Insert (same
keycap as Delete
Row)

OR

With Num Lock
inactive, press Ins
(0) on numeric
keypad

Insert (located
above the Delete
key on the PC)
OR

With Num Lock
inactive, press Ins
(0) on numeric
keypad

Toggles between Overwrite and Insert Mode

Ctrl plus - (minus
sign)

Ctrl plus - (minus
sign)

Toggles Locked Translation Mode on and off.
Locked Translation Mode enables typing of Alt and
Alt + Shift characters (including RGB Font).

When Locked Translation Mode is active, TRNS in
the Status Bar is on.

Ctrl plus = (equal
sign)

Ctrl plus = (equal
sign)

Toggles Single-Stroke Translation Mode on and
off. Single-Stroke Translation Mode enables typing
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of Alt and Alt + Shift characters (including RGB
Fonts).

When Single-Stroke Translation Mode is active,
TRNS in the Status Bar is on.

Single-Stroke Translation Mode is active for typing
only one character.

Alt+ M Alt + M Tab Column Mode

Data

ChyronHego Description
Keyboard
Keyboard/PC
Keystroke(s)

Alt +U Disables interface fields (for use with Intelligent Interface).
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Clone Canvas

The Clone Canvas option creates a duplicate of the Lyric Canvas that can be moved to
additional monitor/s. Cloning the Lyric canvas is typically used as previews for control room
productions. Frame Buffers 1 and 2 can be cloned. Setting up the Clone Canvas Window
function involves setting your system's graphics card to multiple displays and enabling Lyric
Preferences.

Lyric Clone Canvas Window Setup
Configure additional display monitors from within the systems graphics card (Nvidia
settings). For more information please contact ChyronHego Customer Support.

1. Click the Config menu and select Preferences.
2. On the Interface tab, check Clone Canvas Window

Preferences X

CG Preferences Interface  |mport/Export  Language Project Folder Timeline Diagnostics

Canvas Status Bar Info

2afe Tt U Update During Playback
43Titlein16:3 [l .

2D Text Frames i s

Bl Bk Highlight Pane on Hover
Object Manipulator YGEA Preview

3D Text Manipulator [~] Clone Canvas Window

Options

) Scene Graph
Disable Undo for 2D Text

[ Scroll To Selected Node

Y

Shift Page
Selected Objects @ Al Objects O Template Update

[] &pply and Close on Enter Key

3. Click OK. When configured for multiple outputs, selecting this option will create two
clone canvases.
4. To view the cloned canvases, click on the View Menu and select Virtual Output
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. . }
SteneTree F8 Show All Virtual Outputs

Status Bar Show Active Virtual Outputs
Surface Properties Hide &ll Virtual Outputs
Template Update Alt+T Output - Frame Buffer 1
Timeline Editor ~  Output - Frame Buffer 2
Transform Properties + Clone Preview - Frame Buffer 1
Update Ordering ~  Clone Preview - Frame Buffer 2
Video Capture ~  MVirtual Output - Unassigned
Virtual Output > « \Virtual Output - Unassigned

The popout menu shows all available Offline outputs with the option to open and close and
hide all and show all as desired.

5. Drag the canvas-only window across your extended desktop, onto the newly
connected second monitor. This clone of the Canvas will include only the Canvas’s
title bar, and no other portions of the Lyric interface. If the Clone Canvas window
initially displays only gray or is frozen, open a new message or type a character on
the Canvas to refresh.
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Edit Menu

Undo Ctrl+Z
Redo Ctrl+Y
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+4/
Paste in Place Ctrl+|
Paste Special Ctrl +AlL+Y
Delete Templates/Leave Text

Delete Del
Group Ctrl+G
Ungroup Ctrl+U
Select All Ctrl+4
Find/Replace... Ctrl+H
Spell Check F7
Disable Il Fields Alt+U
Disable DBLink Fields

Update DBLink Fields

Update Data Object Fields

Enable All Scene Cameras

Disable All Scene Cameras

Embed Assets >
Unembed Assets >

Undo/Redo

Cut

Copy

Paste

Paste In Place

Paste Special

Delete Templates/Leave Text
Delete

Group/Ungroup

Select All

Find/Replace

Spell Check

Disable Il Fields disables Intelligence Interface fields
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e Disable DBLink Fields disables the DBLink attribute for all Templates and Objects
in the message. The database links remain as set, however linked items do not
update from a database when the message is read or Update DBLink Fields is
selected.

To re-enable DB Linking: Select a Template or Object, then via the General
Properties (View > General Properties) Click DB Linking and check the Enable
checkbox and click OK. The check mark on the DB Linking button is green when
links are enabled.

e Update DBLink Fields updates all DBLink fields with the latest data from the data
source without having to save and re-read the message

e Update Data Object Fields updates all Data Object fields with the latest data from
the data source without having to save and re-read the message

e Enable/Disable All Scene Cameras - Enables or disables the Scene Camera on
all 2D Text Windows within the scene.

e Embed/Unembed Assets - embeds and unembeds all assets within the selected
scene. Images/Textures; refers to imported images and images surfaced to
geometry. Images and Geometry can be set to be embedded or unembedded by
default in Config>Preferences>Import/Export (Note that Media files are
unembedded by default and do not have the option to be embedded.)

Embed Assets > Images/Textures
Unembed Assets > Geometry N

Paste Special

Occasionally, a Lyric composition will require nonstandard characters or characters not
commonly occurring in the user's native language. Lyrics Paste Special option is used to
copy these characters from other applications, such as word processors. Lyric supports
double-byte characters if the Windows® operating system supports double-byte characters.
Examples include Chinese, Japanese and Korean Windows.

Pasting into the Template Update window could result in unformatted text. To paste in
formatted text use Edit > Paste Special or the key combination of Ctrl + Alt + V.
The rich text formatting features that are respected are font type and justification only.

It is possible that the Unicode character from the source document is not available in the
font set selected in Lyric. Although the most widely used font sets contain a standard set of
Unicode characters, it is recommended that the font used in Lyric either matches the font
from the source document or that it is confirmed that the Lyric font contains the Unicode
characters. This is especially important when a Template is updated with Unicode
characters. The Characters can also be copied and pasted directly from the Windows
Character Map.
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Group/Ungroup

Groups are a way of containing nodes for animation and organizational purposes. Groups
of groups may be used in order to achieve specific animations of some objects, and not on
others. Grouping, combined with Intelligent transitions, allows for easy and flexible
message creation. One or more items may be grouped.

To Group Objects

1. Select the desired objects. For multiple objects, Ctrl + Click each item in the Scene
Graph, or lasso on the Canvas.

2. From the Edit menu, select Group (Ctrl + G) or press the group icon i, (View >
Toolbars > Group/Ungroup).

3. Expand/Contract the group by left clicking the +/-, and right clicking on the +/- will
expand/contract all child nodes.

Scene Graph ’ @

Marme - |

G All
-?‘ 30 Template 1
£l P

To Ungroup the Objects

Select the grouped object in the unexpanded view, or select any object in the expanded

view, and then select Ungroup (Ctrl + U) from the Edit menu or click the Ungroup icon
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General Properties

Node names and descriptions can be applied to groups, which allows for the use of
Conditional Transition, Auto Hide and Auto Follow features.

_ —
| General E

Group = G_All

4Mode Info
Mode Mame  G_All
Drescription

Best Practices

e It's typically best practice to create groups in the Default timeline. Creating a group
in a transition that is not the Default assumes that you want the group to be visible
in that transition only. This means the group is set to 100 opacity in the transition it
was created in, but 0 opacity in the Default timeline. To correct simply reset the
opacity back to 100 in the Default.

Groups can be used to quickly turn on and off nodes in the scene graph

When selected on a node inside a group while using the Canvas tools, any
transform will apply to the group. To apply transforms to the selected item only hold
the Shift key while using the canvas tools.

e Animation is best performed on groups (even a single grouped object) as this gives
the user ultimate flexibility for future adjustments. For Instance: Additional
animations and objects can be added or removed from the group quickly and easily
at anytime.

Any item added to a group assumes the parent behavior/s of that group.

The base nodes can be adjusted without affecting any of the animation that is
applied to parent groups. This is particularly useful when groups are used in multiple
timelines.

Groups are can be used for the purpose of animating in specific timelines.

Objects when grouped have 0,0,0 XYZ transform properties which allows for the
group to always return to this zeroed state after any manipulation.
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File Menu

[File| Edit View Config Tools Help

Mew Scene Ctrl+M
Open... Ctrl+0
Save Ctrl+5
Save As...

Save With Options...

Export Selected Nodes

Impert Nodes From File

Backup...
Restore...

Message Info...

1 Lync. b

2 Playlistl.phy
3 font test.lyr
4 (0000003 hyr
500000002 byr
6 00000010, byr
7 00000008, by
& 00000020, byr

Eat

New Scene - adds a new empty scene to the Scene Tree

Open - allows for the navigation to Lyric Files only. For opening specific Lyric
objects, see Tools.

Save - allows for a previously saved Lyric file (.lyr) to be re-saved.

Save As- allows for the saving of various file formats.

Save with Options- Also known as Record Only, allows the saving of specific
elements in a scene.

Export Selected Nodes

Import Selected Nodes

Backup
Restore

Message Info
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Importing and Exporting Nodes

Lyric Nodes .Ino (Lyric Node Object) files can be saved and recalled for use in other
messages or as a permanent record. This can be handy for reusing grouping structures,
trigger tracks or prebuilt animations or objects. This is different to saving a Lyric file .lyr in
that it only saves the selected nodes.It creates the ability to permanently make a library or
prebuilt nodes ready to be imported into any Lyric message.

Exporting Selected Nodes
In the Scene Graph or Timeline select the Node to be exported. For multiple nodes use
Ctrl+Click to select.

With desired node/s selected from the File Menu > Export Selected Nodes.

File | Edit View Config Tools Help
MNew Scene Ctrl+MN
Open... Ctri+0
Save Ctrl+5
Save As...

Export Selected Modes
Import Modes from File

Users can now decide whether to include ALL Transitions or only the currently selected
Transition when exporting to an .Ino (Lyric Node Object) file. When checked Export All
transitions will also save all associated transitions with the node. When unchecked only the
current transition will be saved.

r
Export Lyric Node Object

bV | Export all Transitions

Savein: | Nodes - & [’? 7
(P Name : Date modified Type Size
""‘} Mo iterns match your search,

Recent Places

|
Desktop

=

—==

1 |.|.
Libraries

&k;

Computer

Metwaork

File name: Spinning Logol

Save as bype: [Lyric Node Object File (*Ino)

Name the .Ino file and Click Save.
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A global preset option for Node Export is available via the checkbox seen in the CG
Preferences Interface Tab. Select Config > Preferences> Interface > Node Export. This
function also affects the what is copied via a windows copy function, Edit > Copy (Ctrl+C).

Tip When Exporting, select at a frame in the timeline you would like to be the preview
frame for the .Ino. A snapshot is taken at the time the .Ino is saved and this becomes the
preview for the node when importing.

Importing Selected Nodes

From the File Menu > Import Nodes from File

File | Edit View Config Tools Help
Mew Scene Ctri+M
Open... Ctrl+0
Save Ctrl+5
Save As...

Export Selected Nodes
Import Nodes from File

Navigate to file, select and click Open.

"

Cpen

u =]

D Merge Layers

Look in: , Nodes - ] . g
’ @‘ : . Preview
T= Marme Type
ehebo i |Spinning Loge.Ino LMO File

Recent Places

|

Desktop
Libraries
L
Computer
4| mn
Metwork
File name: Spinning Logo Ino -
Flesoftype: Ly Node Obiect Fie (*Ino) ~|
Apply to Background
Size to Fit Center
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Backup

Lyric provides a Backup Utility for the various types of files use by Lyric, as well as Browser
databases. Beginning at LyricX version 3.1, Backup files can now exceed 2-3 GB.

The Backup Utility is used to zip Message Assets (components such as Media files, bitmap
images and fonts), other relevant file types such as Playlists and Macros, and Browser
Assets. Backup files can be restored to different drives and file paths.

The type of files to be backed up are individually selectable, which enables the user to
minimize the amount of data contained in created backup files. For example, fonts created
for a specific show may be needed on a different system. The fonts can be selected as the
sole type of asset needing backup. Which could then be restored to the other system. Files
and Browser databases are restored using Lyric's Restore Utility. See also Restore.

To Access the Backup Utility

From the File menu, select Backup. The Lyric Backup Utility dialog box opens.

Message Assets From

e @ Directory ©) Browser ) Specy Files

Flipbooks

Video Clips = E]
Audio Clips =

[¥] True Type Fonts Fle:

Data Sources = E]

File Types
Messages Status
Playlists
Macros
User Profiles
All Cther
Recursive

Browser Assets
Messages
Bitmaps
Faonts

|
Stop Cloze | |

Backup Directory

When Directory is selected, the dropdown list box becomes a field into which a directory

path may be entered. A navigation button E] appears next to the field. A
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directory/Project Folder is also selected by clicking the navigation button, and then
navigating to a directory in the Browse for Folder dialog box.

The Browser Assets area at the left of the dialog box is grayed out. When the backup is
generated, it includes the selected Message Assets and File Types, as well as any fonts
that are necessary for restoring backed-up messages. The Recursive option must be
checked in order to back up sub-directories within the selected directories.

Backup Browser

When Browser is selected, the dropdown list box in the From area displays a list of Lyric
Browsers from which a backup can be generated. The File Types area at the left of the
dialog box is grayed out. When the backup is generated, it includes the selected Message
Assets and browser Assets, as well as the Browser database itself. Where applicable,
images that are part of RGB Fonts are included as well.

Backup Lyric Message(s)

When Specify Files is selected, all Message Assets and File Type check boxes remain
available. However, only Lyric message files with the .lyr extension, and their constituent
assets, can be backed up by this method. (You may find that the File Types check boxes
are available; disregard them and use the Backup operation only with .lyr messages)

& L =
N
Message Assets From

Bitmaps/Geometry

Flipbooks

Video Clips

yric Backup Utility

Directory Browser (@ Specify Files

nnnnnnn

Audio Clips
True Type Forts File:

Data Sources |:"Project Folder\Message 11 backup lbu

File Types
Mezszages Status
Playlists Scanning message |:\Project Folder'Messages 00000011 yr BackupRestare
Macros ...contains asset |\Project Folder\images‘textures'tx gradient 3tga
5 _..contains asset C:\windows"\Forts'arial_1 #tf
User Profiles ...contains asset |\Project Folder’3D Objects*\30S Object Library"Bars'.Bar F5.30
Al Cther ...contains asset |\Project Folder\lmages'\Generic Hements\White Circle png J_\ 5 files in archive
2 Backup started : Thursday, October 13, 2016 02:58:33 FM re 1
Recursive Plugin Version 5.0.0.0 Build 500 Lyric Version 2.0.0 Build 28
Compressing |:\Project Folder\Images'textures'tc gradient 3tga
Browser Assets Compressing C:'windows"Fortsarial_1 tf
Compressing |:\Project Folder'30 Objects’3DS Object Library.Bars®Bar F5.305
Messages Compressing |:"\Project Folder'Images'Generic Blements\White Circle png
Bit Compressing |:\Praject Folder\Messages 00000011 | i
i i e p——
Fonts
Start Close
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Message Assets

The checkboxes at upper left, specify which assets should be included in a backup file. For
instance, if you are certain that a large video clip file will already be present on another
machine playing this message, you might choose to omit the clip file to minimize the size of
the Lyric message file being backed up.

Bitmap Fonts are the same as Lyric RGB Fonts and Data Sources are data files such as
Microsoft Excel spread sheets which are references by Lyric messages. They are not to be
confused with Browser databases.

File Types
A list of file types from which can be selected any or all for backup. Selecting (checking) a
file type includes all files of that file type from the selected directory in the backup.

e To: The destination file for the backup is entered in the To field. A file can also be

selected by clicking the navigation button E] , and then navigating to a directory in
the Save As dialog box and entering a file name. The file is saved with the
extension *.Ibu, which is a Lyric Backup File format.

Start: Starts the backup process.

Stop: Stops the backup process.

Close: Closes the Lyric Backup Utility dialog box.

The Status window displays the progress of the backup as the information is
simultaneously recorded to a log file with the same name as the backup file.

The Status window may indicate that elements such as images are missing from a
message. When the backup is complete, a prompt appears specifying the number of files
that have been archived.

Both the backup and log files are saved to the directory specified in the File field. The
backup file (*.Ibu) is accessed by Lyric's Restore Utility to restore Lyric files. The log file
(<backup file name>_Ibu_backup.log) can be viewed by double-clicking on its listing or icon
in its directory. It can also be opened in a text editor.
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Lyric's Restore Utility provides the ability to retrieve files and Browser databases that have

been backed up using Lyric's Backup Utility.

Accessing the Restore utility

From the File menu, select Restore. The Lyric Restore Utility dialog box opens.

;

Restore From

Backup File  1"\Project Folder\Message 11 backup Jbu

Restore Options
(@) Preserve Original Paths

(7 Specify New Root Drive

Restore Original Date/Time Stamp

-G

() Specify New Root Drive and Path &

() Specify New Path for each Asset

Messages

Bitmaps

3D Objects

Flipbooks

Video Clips

Data Sources

Bitmap Forts

Playlists

1 Macro Files

User Profiles

|
|
|
|
|
Audio Clips |
|
|
|
|
|
|

All Cther

- [t ] (50 ] [(Coe ]

e Restore From - The source file for the restore operation is entered in the From
field. Only files with the *.Ibu extension can be selected here.

e Restore Options: Files can be backed up to either a specified root drive or to a
specified path for each type of asset or file type.

e When Specify New Root Drive is selected, the dropdown list box in the Restore
To area displays a list of available drives to which the files can be restored. The

filepath fields are grayed out.

When a restore is executed to the same drive as the backed-up files, the files are

restored to their original locations.
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When a restore is executed to a different drive from the original, the assets specified
for restoration, the Browser database (if specified) and the directory structure
containing the specified assets are copied to the new drive.

Regardless of the destination of the restored Browser and its assets, all TrueType®
fonts associated with the Browser are restored to a RestoredFonts directory that
Lyric creates in the Lyric installation directory on the system. This may be different
from the drive specified as the destination. If these fonts are not present in the
Windows Fonts directory, they must be copied into the directory to ensure that the
restored Lyric messages display properly.

e Specify New Root Drive and Path: This function works in the same manner as
Specify New Root Drive, but allows the operator to move the assets in each source
folder designated in the file path, to a new drive and new folders that can be created
simply by entering their names in this field.

When a Restore operation's destination is a folder hierarchy that is different from the
original location, the assets specified for restoration, the Browser database (if
specified) and the directory structure containing the specified assets are copied to
the new folder hierarchy.

For example, when the source path for a specific file is: D:\Old Primary\Old
Secondary\Old Tertiary\Old Final ,

and the operator enters C:\New Primary\New Secondary ,

the destination path will be C:\New Primary\New Secondary\Old Tertiary\Old Final .
Each file included in the backup operation will be treated similarly.

e \When Specify New Path for Each Asset is selected, the filepath fields become
active, and separate filepaths can be entered for each file or asset type. When a
Restore is executed, the selected groups of files are restored to the specified
directories. If a file type is selected (checked), but no path is entered, the files of
that type are copied to the same location as the backup file from which the
restoration is generated.

Important: When restoring message files to new file paths, any element that is embedded
into a Lyric message (eg Embed is checked on the objects’ General Properties) retains the
file path as per the original message. New file paths are only created for elements that are
not embedded (eg Embed is unchecked) within the Lyric message file.
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Status Window

If the Restore operation encounters a file with the same name in the destination directory as
a file it is about to restore to the directory, an overwrite prompt is displayed. Click Yes to
overwrite the file; Yes to All to overwrite all files with duplicate file names; No to prevent
overwrite of the file, or No to All to prevent overwrite of all files with duplicate file names.
The Status window indicates when the Restore is complete. The BackupRestore prompt is
displayed, indicating how many files were restored from the archive.

If No or No to All is selected, the Restore operation still decompresses all of the files,
although it does not overwrite the indicated files.

If a Browser is being restored, the New Browser Name window is displayed. Enter the
name of the new Browser, then click OK.

e Start: Starts the Restore process.

e Stop: Stops the Restore process.

e Close: Closes the Lyric Restore Utility dialog box.

| Restore From

Backup File ||:"'-.iject Folder\Message 11 backup lbu - !I o)

|
Restore Options

@ Preserve Original Paths [] Restore Original Date/Time Stamp

1

l Specify New Root Drive ;C o

I Specify New Root Drive and Path || ”j
Specify New Path for each Asset

[¥] Messages | |,_ |

[V] Bitmaps | |I_|

[7130 Objects | -]

[V] Flipbooks

BackupRestore |

I [V] Audio Clips

E 5 of 5 files restored from archive

[¥] Data Sources
[7] Bitmap Fonts
[V] Playlists

[¥] Macro Files _
[¥] User Profiles ’7”___'

[7] All Other | |

Restore started : Thursday, October 13, 2016 03:15:58 PM

5files found within archive

Decompressing tx gradient 3tgato |\Project Folder'\Images‘textures’.

Decompressing anal_14f to C:\Users\chyron CHY-APAC-KRISTY.000"Documents\Restored Fonts'\
Decompressing Bar F5.305 to |:\Project Folder3D Objects"305 Object Librany"Bars'
Decompressing White Circle png to |:\Project Folderimages'Generc Elements'.

Decompressing 00000011 yr to |:\Project FolderMessages®

5 of 5files restored from archive

.Start![.‘itop][[lose]
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Font Copy Prompt

If necessary, copy the fonts from the Restored Fonts directory to the Windows Fonts
directory. The messages are now ready to display.

i N
BackupRestore M

X Font files were written to
i_l-ﬁ. Ch\Users\chyroni\Documents\RestoredFonts
They need to be manually copied to your Windows font folder

Message Info

Message Info is a way to see all the information pertaining to single message file. This can
assist with troubleshooting or viewing when a message was last saved or accessed. A
message must be saved first in order to view the Message Information.

bessage Information et

General

Locakion: I'\Project¥imask syd cube, lvr

Size 5703 KB (8492540 bytes)

Created; TI29 2017 12:52:57 AM

Modified: 7I29f2017 12:52:58 AM

[ aaa—". 7129/2017 12:52:57 &M
Lyric

Last Saved 3.0.0 (Buid 25)

Mative Resolution: 1920 x 1080 ok

Pixel Aspeck: 1.000

Frame Rate; 29,97 fps
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Saving Files

There are many saving options in Lyric. Including save options for exporting media files,
saving scenes with OnRead macros, saving only the text or the updateable data with
Template Data messages, as well as saving playlists, macro files, Effects. (See also
Exporting Lyric Nodes and Lyric 3D Object Format (.3DO)).

For saving Lyric message files, see Reading and Recording Messages.

Save As Dialog (For exporting media files and still images)
From the File menu, Select Save As. The Save Animation dialog box opens. Select the
desired format from the Type Dropdown:

-
Save Animation g
Start Frame 0O Image Width Create Matte File || Save Alpha
S Shape Videa Invert Alpha
End Frame 150 Image Height | 1080 clip to Safe Title Field Render
Follow Activation Invert Fields
Use RLE
Savein: 4 Libraries - @‘ Ij =¥ '
@ Documents

=
m‘ﬁ Eﬂ Drophbox
Recent Places Ji Music
[ Pictures

E Videos

Computer

Metwaork

File name: Urtitled hyr

Save as bype:

AVI Files (" awi)

BMP (*bmp)

DCX (" dex)

Digital Picture Bxchanage (~.dpx)
JPEG (ipa)

PICT {* pict)

PCX " pcx)

PNG ("png)

PSD (" psd)

SGI1 (" =gi)

Targa (“iga)

Tiff (“tif)

Quick Time / MOV " maov)
All Files {*%)
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Save As Options

Different file formats offer different options and parameters.

Start and End Frame: A start and End frame can be set for any save operation
(except .ply). These values default to the full length of the timeline selected when
saving to Lyric or or other popular animation formats such as .avi. Saving as an
image file assumes a single frame is to be saved. Adjust values to save file
sequences (Flipbooks)

Image Width and Image Height: Controls the dimensions of the still image or
animation produced by the Save As operation. See also Clip to Safe Title.

Create Matte File: Creates a separate file, written with the .matte extension, which
stores the alpha information as an RGB channel for keying.

Field Render: This option interleaves the odd scan lines from Field 1 with the even
scanlines from Field 2 to create a single video image per frame. It is used for
creation of animations (such as AVI) that are to be displayed on interlaced video
outputs (such as the Matrox clip player), and will give smoother output on those
systems because each frame contains inter-field motion. However, such inter-field
motion will cause the animation to display incorrectly on progressive video outputs
(such as VGA). If an animation is saved with Field Render enabled (checked), the
odd and even fields of the TGA (or other image file) are displayed alternately to
create a single video frame.

Clip to Safe Title: Lyric's adjustable Safe Title region can be used as a cropping
tool when saving to most formats. If Clip to Safe Title is enabled, only message
content within the Safe Title Area is included in the Save As operation. The Safe
Title Area can be adjusted in the Safe Title Adjust dialog box, accessed from Config
Menu > Safe Title Adjust. If Clip to Safe Title is not selected, the contents of the
entire Canvas are saved.

Follow Activation: This must be enabled for animations that require Transition
(Save As) Triggers to execute. See Triggers for more details.

Use RLE: Run-Length Encoding data compression is available when saving .tif files.
Save Alpha: Alpha information is always saved with exported animations. The
Alpha setting is also available for those file formats where the Alpha (transparency)
information can be saved as part of the graphics file (such as Adobe Photoshop's
*.PSD, Tga, Tif and .Png files). Codec settings for saving media will need to also be
set.

Invert Fields: This option switches the odd-even order of interlaced fields in Field
Render "Save As" operations. The "Invert Fields" checkbox only appears when the
Field Render checkbox is selected. This option may be useful in correcting visible
stuttering and other artifacts in animations saved from Lyric messages.

Shape Video: This option attenuates Input Video to the Key signal, so that color
components do not exceed the key level. Un-check this option to leave the signal
unattenuated. This can result in a cleaner key signal on files containing alpha.
Invert Alpha: Given that some software products consider both Fill and Alpha
values as 255, and some systems regard both these values as 0, this option allows
the ability to reverse both sets of values.
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When saving a Lyric message as an media file, multiple timelines can be included as part of
the saved animation. Transition (Save As) Triggers can be added to the scene which direct
the animation to the desired timelines during the save operation. This mimics the triggering
of timelines when playing messages. Transition (Save As) Triggers are only respected when
saving to an .avi file. See Triggers > Transition (Save As) for more details.

The currently active Timeline is saved when not using Transition (Save As) Triggers.

Saving an *.Auvi file
Select the compression type in the dropdown. For no compression select Full Frames
(uncompressed).

-

Videc Compression =

Intel YUV codec Configure...
Logitech Video (I420)

X¥Pression Video Codec 5.7 -—,n.bgm
Matrox Uncompressed S0
[r—

| Matrox Uncompressed HD

; Matroe Uncompressed S0+ Alpha
Matrox Uncompressed HD + Alpha

Matrox MPEG-2 [frame HD

Matrow MPEG-2 [frame + Alpha

Matrooe MPEG-2 [frame HD + Alph:

Matrooe DVCPRO HD

Matrooc DWADWVCAM

Matrox DVCPRO

Matroo: DVCPROSD

Matrox MPEG-2 [frame

Matroe Offline HD

Full Frames (Lincompressed)
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Saving a *.mov file

i .
Media Exporter Cptions | % |
Compression Type [Quidc‘l'lme Animation (RLE) video v]
Frames Per Second [| | 59.54 e
Cality
Loy Medium High
Pixel Format [REEI 24bit (Millions of Colors) - ]
ok || cancal |
L -

Compression Type Select desired codec from the list, currently available are QuickTime
Animation, Apple ProRes, PNG, Targa, Tiff, and Uncompressed.

Apple ProRes

PMG H
Targa

TIFF

Uncomoressed RGE 10-hit i

Additional formats include DNxHD and H.264. These require specific codecs and/or installs
from ChyronHego. For assistance contact support@chyronhego.com

Frames Per Second will use settings from the Lyric canvas. If the Checkbox is checked,
the user can override this setting with a value in the dropdown list, or choose a custom
value. Disabling the checkbox will ignore the value and use the Lyric canvas fps.

Quality will be enabled for lossy codecs. High quality will result in higher file sizes.
Pixel Format is a dropdown list of supported formats for that codec. If “save alpha” has

been specified in the previous Lyric dialog, then the first alpha supported codec will be
selected when choosing a codec.
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Save with Options / Record Only

The Record Only Menu allows specific properties or pieces of a message to be saved. It
has different purposes depending on the section referenced.

e Text: This area allows users to save only specific text or replaceable elements to a
message or Template Data Message. They can then be recalled to solely populate
templates with the data they contain.

e Panel: Saves tool specific files for saving Default Effects, Macros, Playlists and
Scene Trees. It is only the specific properties or macro script contents that are
recorded.

e Message with Options : Gives the ability to add an Embedded macro to the
scene that executes automatically when the message is read. (This macro can also
be optionally triggered from the Template Update pane whenever ‘Apply’ is
executed.)

Record Only Menu
The Record only Menu can be opened using the below methods:

e File>Save with Options will open the menu

e Save a new file: Ctrl + Record (ChyronHego keyboard); Ctrl + numeric keypad

Minus (-) key (PC keyboard).

To overwrite an existing file: Ctrl + Alt + Record (ChyronHego keyboard); Ctrl + Alt +
numeric keypad Minus (-) key (PC keyboard). This is equivalent to a Windows Save
operation.

e Use the browse button to change the save file destination if required.

e Click Record button to Save/Record the file

0 - Record Only: X

Filename

L:\Morning Mews\Messages\00000000. lyr ] I... I

Text Panel (®) Message, With Options
(O All Text In Window (O Default Effects Scene Macros Pane
() Cursor to End () Macros
() Current Raow (O Playlist {.phy)

Template Daka Message O Scene Tree

XML Data Message
Record Cancel
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Text

When a Lyric message is saved, many different elements and properties are saved. These
include text, graphics, timeline information, template information, backgrounds, and more. It
is possible, however, to save specific elements from the Lyric composition, so that they can
be easily read into other Lyric compositions. These are known as Pop On Messages. See
2D Text, Pop On Messages for details.

The first three options: All text in Window, Cursor to End and Current Row, records only the
text data from the active 2D Text Window (excludes Clock and Timers) to a Pop-On
message. Once recorded, the text can be recalled into a different 2D Text Window in
another message as an update. The text will pop on at the size and font they are recorded
in. These options are recorded as in the *.lyr format.

e All Text (Hotkey: Ctrl + Record T Enter): Records all text in selected 2D Text
Window. Empty lines on a Pop-On message are ignored. For example, if a
three-line Pop-On is recorded, and the middle line is empty, the Pop-On is read
back as a two-line Pop-On, and replaces (or adds) two consecutive rows of text.

e Cursor to End (Hotkey: Ctrl + Record E Enter): Records all text from the
beginning of the row on which the cursor is positioned to the end of the text in the
window. Empty lines on a Pop-On message are ignored.

e Current Row (Hotkey: Ctrl + Record R Enter): Records only the text on the current
row.

Template Data Messages and XML Data Messages

Template Data Messages (.lyr) and XML Data Messages (.xml) are small instructional Lyric
files. They allow for replaceable template data (text, image paths, and media file paths) to
be saved as data only messages, which then update replaceable elements in Lyric
compositions when recalled. This saves duplication of large files that use the same scene
but with different content.

As both Template Data Messages and XML Data Messages accomplish the same goal, the
only difference between them is that Template Data Messages use Intelligent Interface W
commands to update data, while XML Data Messages use the more universal XML format.
Template Data Message (Hotkey: Ctrl + Record D Enter): Records a Template Data
Message based on the currently Il enabled templates.
e XML Data Message (Hotkey: Ctrl + Record X Enter): Records a XML Data
Message based on the currently |l enabled templates.

Panel
A Panel selection records tool-specific files.

e Default Effects (Hotkey: Ctrl + Record F Enter): Records currently selected
Default Effects in Config > Default Effects. This is the same as what is recorded
through the Default Effects Dialog.

e Macros (Hotkey: Ctrl + Record M Enter): Records only Macro information in the
dyr format. The file format is the same as that recorded from Macros >Save icon,
when the Macro is saved in the .lyr format. Refer to Macros for additional
information.
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e Playlist (Hotkey: Ctrl + Record P Enter): Records only the Playlist information in
the .ply. The file format is the same as that recorded from File Menu > Save As,
where Playlist Files (*.ply) is selected as the file format. Refer to Tools Menu:
Playlist for additional information.

e Scene Tree (Hotkey: Ctrl + Record S Enter): Saves all messages that have been
Shift + Read into the Canvas section of the Scene Tree (not on the output) to a
single message file (.lyr). This means multiple files can be loaded onto the canvas
by opening a single Lyric message. See Reading and Recording messages.

Message, with Options
Embedded Macro

The macros are now available in their own dockable window and can be accessed by
clicking the Scene Macros button or by View Menu > Macros > Scene Macros

Macro scripts can be saved with a Lyric file and can automatically executed when the file is
read. Additionally embedded macros can be executed when Applying a Template Update.
Or by playing them from the Scene Macros pane. See Template Update and Scene Macros
for more details

Note: Any errors or missing macros will invoke an error pop up.

Template Data and XML Data Messages

Standard Lyric messages can be quite large in file size as they are storing all graphic data
(fonts, images, animation and trigger data etc).

Template Data and XML Data messages are different in that they are instructional
messages. When recalled, these messages load the base message (original message they
were saved from), then populate it with updated content (text, images, textures and
movies). Template Data and XML Data messages are very small in file size and because of
this are perfect for quick transfer to other Lyric devices.This saves duplication of large files
that use the same scene but with different content. Also, as they refer to the original base
message, if a font change or animation edit is required only the original base message
needs to be edited.

How are they used?

Template data messages and XML Data messages are typically used in automated
environments although they work well in manual build and playout environments too.

As both Template Data Messages and XML Data Messages accomplish the same goal, the
primary difference between them is that Template Data Messages use Intelligent Interface
W commands, while XML Data Messages use the more universal XML format. Also,
Template Data messages are saved as .lyr files while XML Data Messages are saved as
xml files.
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Case Studies

Template Data and XML Data messages have many uses. Outlined below are some of the
more common applications for Template Data and XML Data Messages.

Newsroom application

CAMIO newsrooms use a tool called LUCI to build graphics for playback on air. This LUCI
tool is available to the newsroom producers in the newsroom application (such as iNews or
ENPS). LUCI references Lyric Base Messages and after the Producers/Reporters have
input new content, a new message is saved. This is a template data message that will be
sent to all associated playout devices.

3rd Party Developers

The XML Data Message feature allows third party developers to create template data
messages from previously designed and XML saved base messages. These are saved in
the . XML format programmatically, without the need of having a Lyric device or the use of
Intelligent Interface.

Manual

Manually, template data messages can be useful when building out content in a look that is
not finalized or subject to change. If the base message is created, template data messages
can then be built from the base message. If/When the graphic style or animation is edited,
only the base message needs to be modified and all template data messages can remain
unchanged. As template data messages always recall the base message they will
automatically display the modifications. However, care should be taken to ensure the
structure of the messages (ordering of templates and images - see Update Ordering) stays
the same when any base message is edited.

Saving Template Data Messages

For a base message to work when creating template data messages all updateable
elements (templates, images, 3D object surfaces and movies) must be identified as Il
(Intelligent Interface) update enabled in the Update Ordering. As a default, all text templates
are automatically Il enabled whereas images, movies and 3D Object surfaces are |l
disabled. For more information on configuring this see the Update Ordering topic.

To save a template data message manually, recall the base message, modify the content,
then click control+record (Ctrl+Alt + (-) Minus on a PC numberpad). The Record Only dialog
opens. Ensure the Template Data Message radio button is selected and enter a new
number in the filename field for the template data message to be stored. Click Record. The
new template data message is quickly saved. These are saved in .lyr formats and cannot be
edited in other software.

e Template Data Message (Hotkey: Ctrl + Record D Enter): Records a Template
Data Message based on the currently Il enabled templates.
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Filename
I:Project Folder Messages 0000150 1. lyr E

Text () Message, With Options

() All Text In Window [ Embedded Macro

() Cursor to End | - | [7] save Name Only
() Current Row =
/@ Template Data

~ Message

() XML Data Message

Panel

() Default Effects

) Macros

(©) Playlist {.ply)

() Seene Tree

. ;
_

If the location that the template data message is being saved to is not the currently
configured message directory (Config > Preferences > Project Folder) an error message will
appear asking that the file save path be changed to that of the Project Folder preferences.

I ==

Template Data Messages must be recorded to the current Intelligent
L Interface Message Path

Change path of filename to "E\Lyric Demo'\Messages\"?

File Structure and Template Data Messages

Template Data Messages are very simple messages that carry only the base message
number that they are linked to and not the filepath. Replaceable images, 3D object surfaces
and movies however have absolute file paths in the template data message.

When Template Data Messages are read, they locate and recall the base message using
the following order:
1. A configured Templates folder. This can be configured in Config > Preferences >
Project Folder. This folder must be enabled (checked).
2. It will then look to the folder the Template Data Message was recalled from.
3. Lastly it will look to the same location as the Template Data Message. This is
configured in the Config > Preferences > Project Folder.
If no base message is found, an error message will display with the filepath where the
message was not found.
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l; I\Project Folder\Messages\00000501.lyr was not found.

Recalling Template Data Messages

Template data messages are recalled in the exact same manner as standard lyric
messages (either through the keypad, File > Open, Macro, Playlist, Leif etc). When this
message is recalled the top menubar of the canvas will display the template data message
number followed with the base message number in parenthesis (i.e.
TemplateDataNumber(BaseNumber) or 1502(501)).

FB1 - 1502 (501) - I\Project Folderi\Messages

Saving XML Data Messages

XML Data messages also refer to a base message. The base message must be first saved
in Lyric (as an .lyr file) then an XML Data Message can be generated by clicking the
Control+Record (Ctrl+Minus (-) on a PC numberpad). From the Record Only menu select
XML Template Data. When the XML data message is generated it will create a .xml file.
This can be opened and edited in other applications (such as notepad) or 3rd Party
Developers can create tools to automatically generate .xml files with new content. These
edited messages are then stored as new .xml file. As the base .lyr message number is
embedded in the XML file it will always refer back to that message.

XML Data messages identify all updateable objects within the scene through a GUID, care
should be taken when modifying the base message not to replace any of the objects with Il
active in the Update Ordering.
e XML Data Message (Hotkey: Ctrl + Record X Enter): Records a XML Data
Message based on the currently Il enabled templates.

MName Type Size
0 00000040, yr Lyric Document 1,101 KE
2| 00000040 xrml XML Document 1 KB

Recalling XML Data Messages

These messages can be called up in Lyric manually (File > Open), by automation, macro or
LEIF. 3rd Party Developers can create tools to recall the XML files. They cannot be recalled
using the keypad
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Help Menu

Searchable User Guides and Leif documentation are accessible from the help Menu. This
guide can be accessed via Alt H U or F1

_Help |
Lyrick User Guide
Data Object User Guide

LEIF D'ocumentation

More Info ...

About Lyrick

More Info displays contact details to assist with finding more information regarding
Chyronhego systems and products. Click links to be directed to the web for more
information. Can also be accessed via Alt H M

G

Website
Contact: http:/fchyronhego.com/contact-us
Sales: http: fchyronhego. com/contact-sales
Dealer:  http:/fchyronhego. comjcontact-reseller
Products: http:/jchyronhego.com/#

Mews:  htip:/jchyronhego. com/press-release

Technical Support
Americas, Asia Europe, Middle East, Africa
+1631845 2132 +44 208 8673 051
+1631845 1267

support@chyronhego. com emeasupport@chyronhego. com
htip:/fchyronhego. com/support/overview |

About Lyric displays details about the system. Including software version number and
location, plugins, frame buffers and license agreements. Can be accessed via Alt H A.

Lyrick on Mosaic
Copyright © 1998 - 2016 ChyronHego

‘Wersion 2.0.0 (Build 200 BETA
branch: RELEASE/[Z.0 sha: fdeb?f17

C:\Program Files\ChyronHegoLyric2.0.0,20BETA

|Jses libraries From the FFmpeq project under the LGPL w2, 1
IUses Freelmage open source libraries under the FIPL +1.0

Plugins shows all plugins installed within the Lyric software. Click about E] for plugin
details including version number.
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IUses libraries from the FFmpeg project under the LEPL «2.1

[ Plugins
IJses Freelmage open source libraries under the FIPL w1.0

[ Frame Buffers ]

[ Licenses ]

Plugin Wendor About
M atrow Device Chyran e
LyricThurnbPlugin Chyron ]
Backup Restore Chyron o
Chyron,Lyric.Autormation Chyron e

Frame Buffers shows all available frame buffers with board number. Click E] to see
details regarding the installed plugin running the frame buffer.

[ Plugins ] IJses libraries fram the FFmpeq project under the LEPL w21
IJses Freelmage open source libraries under the FIPL wi1.0

[ Frame Buffers ]

[ Licenses ]
FrameBuffer Count About
DEXLEF 2252000 1 |

Licenses shows the licenses required to run Lyric software including the agreements.

License agreements can be viewed by clicking E] .

Uses libraries from the FFmpeg project under the LGPL v2.1

[ Plugins
Uses Freelmage open source libraries under the FIPL w1.0

[ Erame Buffers ]

[ Licenses i

Project
Boost

GLEW
Irnagebdagick
lib3ds
LogdMet
Lyric

Copyright

License

1L bb]
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Tools Menu
2D Text

2D Text Windows are 2 dimensional regions where text, templates and images can be
entered. To be used in 3D space, the Scene Camera setting must be applied.

Unlike 3D Text, which appears as a template, 2D text templates need a 2D Window inserted
and templates created inside that window. 2D text types include, a static 2D Text Window,
2D Text Crawl, 2D Text Roll, 2D Text Type On, 2D Text Clock and 2D Text Timer.

Supported formats

TrueType® and OpenType® fonts containing TrueType® subsets. Lyric does not support
PostScript® fonts

For Unicode and Complex Scripting languages, it is recommended to use 3D Text for
complete and comprehensive language support.

Creating 2D Text

From the Tools menu, select Text > 2D Text Window

[ Tools | Help
3D Object v |
Text 3 3D Text
Image 20 Text Window
Media 20 Text Template
Flipbook 2D Text Crawl
Data Object 2D Text Roll
Trigger Track 20 Text Type On
Group Ctrl+G el T Liork
Ungroup Ctrl+U o e et
Video Capture

v 1 Canvas
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or click the al

selection

AR I EEY U I

3D Text —

20 Tedt Window

icon from the Scene Tools toolbar and select 2D Text Window from the drop

20 Text Template
20 Text Crawl

2D Text Roll

2D Text Type On
2D Text Clock

2D Text Timer

An empty 2D Text Window is inserted. Start typing text to insert a line.

Resizing/Repositioning the Window

To resize a 2D Text window, click/drag the window corners to the desired size. To reposition
the 2D Text window, drag the window's Title Bar or any of its corners (a cross-hair cursor
will appear when your mouse is properly positioned on the title bar or in the window to
perform the move).

When Word Wrap is enabled, text wraps to the next line when typing reaches the end of
the row. When Word Wrap is disabled, text types beyond the border of the 2D Text Window.

Press the Enter key to add new lines or right click and select Insert Row. Delete Row is also
available.
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Creating, Editing and Updating 2D text template contents
Creating a 2D Text Template can be done with or without text. The text size, font style and
position may be adjusted. The template size and attributes can be adjusted at any stage.
Typing Text

Left-click in the 2D Text window to establish the position of the first character to be typed.
When the first character is typed, a green baseline appears. Once typed, text can be
selected for further editing, and changes to font style, size, and other attributes can be
applied.

Normal windows operations apply such as Insert/Overwrite Mode, cut, copy, paste and
holding shift to select. Lyric supports the Windows® Clipboard, so that text from any
Windows application can be cut or copied and then pasted. Text editing functions are
available from the Edit Menu, as well as from the 2D Text Context Menu.

Selecting Text

There are two ways to select text:

1. Move the cursor to just outside the upper-left corner of the 2D Text to be selected.
Click/hold the left mouse button, dragging the cursor down and to the right. A
dotted box appears around the text; keep dragging until the 2D character(s) are
entirely inside this box. Release the mouse button. A Bounding Box appears
surrounding the item.

Iype textto insertling =

2. Place the cursor at the left or right end of the text that is to be selected. Hold the
Shift key while using the arrow keys «— or — to extend the Bounding Box around

the text. Handles
et é ____________________________ # —
-Sample’ Text-
|

The Bounding Box is the area around the highlighted 2D Text. When text is selected (in a
Bounding Box), you can quickly apply changes in font style, attributes, etc. To select all 2D
Text in a window click Select All in the Edit menu, or press Ctrl + A.
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Creating a 2D Text Template
1. Right Click and select Create Template.

Create Template

Color code Object k

Uze Scene Camera

2. Click the al button and select 2D Text Template from the options.
A 708 -y 0 -3

3D Text —

2D Text Window

2D Text Termnplate

2D Text Crawl

20 Text Roll

20 Text Type On

20 Text Clock

20 Text Timer

Lyric creates a Template over the selected 2D text. Inter-row spacing is maintained, but any
deviation in inter-character spacing is not. The Default Template Font is taken from the
leftmost character in the selection rectangle (usually the first character on the line).

Once a Template is created in this manner, Template attributes can be set/modified as
usual.

Type text t

Text does not have to be selected in order to create a template. In this case, an empty text
template will be inserted using the last known Font Style.

2D Text
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Editing a 2D text Template Size and Position

Select the template in the same manner as described above (either by dragging around or
by shift and arrows), or Ctrl+Left Click inside the template. For the template to be selected
the handles must be visible. If not, only the text content is selected and NOT the template.

To resize the template, drag the mouse horizontally to the new size (smaller or larger) and
release or hold an arrow key until it reaches the desired size.
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Updating Template Contents

1. Type text directly into the template on the canvas
or

2. Use Template Update (Alt+T).

Template Update @
Text

-

b D

New texd

Type the text and Click Apply or Enter Key to insert text/changes. 2D text templates are
automatically enabled for update. Click for more information regarding Template Update.
Deleting a Template

1. Select a text template in the method described above.

___________ || R ———

My Template

mw=—---"""""- m--——"""""""" Ll

2. Click Delete on the keyboard, or from the Edit Menu select Delete or Delete
Templates/Leave Text.

[Edit | View Config Tools Help

Undo Ctrl+Z
Redo Cirl+Y
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Paste in Place Ctrl+I
Paste Special Ctrl+Alt+V
Delete Templates/Leave Text

Delete Del

Delete Templates/Leave Text will remove the templates only leaving the text in place
whereas Delete removes both the template and containing text.
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General Properties and Setting Template Properties

Node Info
e Node Name is the name as represented in the Scene Graph.
e Node Description is entered here. Both Node Name and Description can be
utilized by additional Lyric features including Inherit State and Conditional
Transitions.

General rﬂ

20 Text = 2D Text 1

4Node Info
Mode Mame 2D Textl
Description

4 Properties
Justify

Template Properties
The template properties appear when selected on a 2D Template.

General E
2D Text = 2D Text 1

4 Node Info
Mode Mame 20 Text1

Description
4 Template Properties
Name Title

[

Text Rows 1 =
Background l:l
Alignment H = o=

Center Vert O] Word Wrap

[
Size to Fit 1
O

Mumeric &l
Auto Erase [ All Caps
Auto Follow [T

=

0 ~

Current Style

4 Data

DB Linking  +

e Name of the template which appears in Update Ordering and Template Update
(when enabled for update).

e Text Rows determines the number of Text Rows in the 2D Text Template. A new
line can also be added to the 2D Text Template by placing the cursor at the end of a
line, then pressing Enter. To set Text Lines, enter a number or click the arrows.

e Background A solid color, ramped color or graphic Background can be applied to a
2D Text Template. A sample of the currently set Background is displayed in the
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Background Sample Area. Click the background button, and then select Solid/Ramp
Color or Graphic File from the displayed menu.

Set a color or ramped color or select a file to use as the Background.

To delete a Background from a Template, Click the background button, and then
select Delete from the displayed menu.

Alignment H determines how the aligns horizontally inside the Template.

o = Left: The text justifies horizontally to the left.
o = Center: The text justifies horizontally to the center.
o Right: The text justifies horizontally to the right.

Center Vert enables the text to align vertically to the center. The Horizontal
alignment is determined by Alignment H. lllustration shows Center Vert Alignment
enabled with all 3 horizontal options.

Word Wrap when enabled allows text to wrap to new rows either when text
overflows a row or it encounters a line break character. Wrapped text outside the
defined bounding area will not be visible unless size to fit is enabled.

Numeric determines how numbers are justified in a template.

When Numeric is disabled, numbers are not monospaced and do not properly align
if the numbers are of different widths. If Numeric is enabled, only numbers typed on
the alphanumeric keyboard, the dollar sign ($), the comma (,), and the period (.)
characters can be typed in the template in addition to numeric characters. Numbers
are monospaced instead of kerned so that multi-row numbers vertically align.

To ensure vertical alignment of the numbers, make sure that each number in the
template contains the same number of digits following the decimal point.
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e Size to Fit The Size to Fit setting determines whether or not text that is too long to
fit on one row of the Template is squeezed to fit on the row.

If Size to Fit is disabled, text that is too long to fit on a row types beyond the border
of the Template, or, if Word Wrap is enabled, wraps to the next line.

If Size to Fit is enabled, text that is too long to fit on a row is squeezed horizontally
(the width) to fit on the row of the Template. This can sometimes result in an
unsatisfactory appearance if it is squeezed too much. If so, extend the length of the
Template or perhaps use a 3D text template where there are more size to fit control
options.

e Auto Erase When enabled, Auto Erase sets the text template to automatically
erase its contents when new text is typed in the template. To enable/disable Auto
Erase, check the Auto Erase checkbox.

When a template is updated via DB Link, Intelligent Interface or Template Update,
the contents of the template are always completely replaced by the new contents,
regardless of the Auto Erase setting.

e All Caps when enabled, all text in a 2D text template appears upper-case. All Caps
can also be used to quickly change all text in a text template to all uppercase
characters.

When typing in a 2D Text Template, All Caps can be toggled by pressing Ctrl + Alt +
U. When first pressed, the following appears in the Status Bar:

AllCaps Override Enabled
When Ctrl + Alt + U is pressed again, the following is displayed:
AliCaps Override Disabled

e Auto Follow can be used to maintain a user-defined gap between 2D text
templates on a given row. The Auto Follow value is set for any template following
the first template in a row. The Auto Follow value is measured in pixels.

e Current Style The Font Sample Area shows a sample of the current Default Font
for the Template.

e Data (DB Linking) allows a text template to be automatically populated and
updated from a database.
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Contextual Menu, 2D Text Windows and Templates
Create Template

Preview Only
Color code Object >
Add To Current Transition

Use Scene Camera

Copy Animation State

Paste Animation State

Make Full Screen

Enable Word Wrap
~ 2D Frames On

Squeeze/Expand

Insert Row Alt+Insert
Delete Row Alt+Delete
Swap Row Up Ctrl+B
Swap Row Down Ctrl+F
Swap Row Priorities Up Alt+P
Swap Row Priorities Down Alt+N

Row Alignment

Insert Tab Ctrl+T
Delete Tab

Select Next Tab Alt+)
Tab Column Mode Alt+M

Tab Alignment

Pick up Color/Font Alt+F12
Set Current Color/Font

Template Lock On
Position Lock On

Continuous Update

Internal Properties

Create Template inserts a 2D template.
Preview Only enables a node to be viewed on the canvas as a preview only and is
not rendered to output. A preview only node is italicized in the Scene Graph and a P
is inserted next to the node.

e Color Code Object enables the object listing in the Scene Graph to be displayed
with colored text in order to make it easier to quickly identify.
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e Use Scene Camera - Lyric's Scene Camera can be applied to a 2D Text Window
(including 2D Roll, 2D Crawl and 2D Type On Windows) in order to display any
scale or rotation in 3D space on the XYZ axes. Use of Scene Camera can be
enabled or disabled for individual 2D Text Windows.

2D Text Window. No Rotation

S —
2D Text Window. With Rotation

. 2D Text Window. With Rotation
and Use Scene Camera enabled

. |

The top illustration shows a normal 2D Text Window, The middle illustrates that 2D
Text Window has rotation applied, and the yellow is to alerts the user that a 3D
transform exists, but remains in the 2D state until Use Scene Camera is enabled.
The third example shows the 2D Text Window with “Use Scene Camera” enabled.

e Copy/Paste Animation State - Animation attributes such as Position, Rotation,
Scaling, etc., can be copied from one object and pasted to another.

e Make Full Screen - Make Full Screen enlarges the active 2D Text window to the
dimensions of the Canvas.

e 2D Frames On - 2D Frame On turns on/off the display of all 2D Text Window and
2D Text Template frame on the Canvas, facilitating preview of the composition.

e Squeeze/Expand - Squeeze/Expand provides a quick method of adjusting space
between 2D characters, 2D Text Templates or rows in a 2D Text window or selected
area. The scale of the characters does not change when Squeeze/Expand is
performed.

e Insert Row/Delete Row - Insert Row creates a new row at the cursor location, or
inserts a row into the current Template at the cursor location (2D text only). Delete
Row deletes the row at the current cursor location. (2D text only). If in a Template,
this function deletes a Template row.

e Swap Row Up/Swap Row Down - Rows can be swapped up and down through a
2D Text Window. The row on which the cursor is currently located changes places
with the row above (Swap Row Up) or below (Swap Row Down) respectively. Short
cuts for Swap Row Up/Down are Alt+F and Alt+B. If Swap Row Up is attempted on
the top row in a window, there is no effect. Likewise, if Swap Row Down is
attempted on the bottom row in a window, there is no effect.
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e Swap Row Priorities Up/Down - The display priority of 2D text rows can be
adjusted in compositions where rows overlap. The Swap Priority Up/Down
operations are similar to Bring Forward and Send to Back operations found in
graphics programs such as Adobe® Photoshop®. Shortcut keys for Swap Row
Priorities Up/Down are Alt+P and Alt+N.

2D Text 1

e Pick Up Color/Font, Set Current Color/Font - Font Style and color characteristics
from 2D text can be easily "picked up" and applied/set to other 2D text or 2D
Template. Pick Up Color/Font and Set Current Color/Font work similarly to the
Color/Font key on the Chyronhego keyboard.

e Row/Tab Alignment - The justification properties of rows and Row Tabs, also
known as Tab Stops or just Tabs, are for alignment purposes only and do not allow
for quick updating via Template Update. More information about Row Tabs here.
Templates on a row tab can each have their own justification setting for text within
the Template's borders, but the Templates' placement on the row is set by Row/Tab
Properties.

e Row Alignment

2D Text 1

T NONE .
BE. — )

NONE - Text appears where typed.
Center - Text is centered on row.
Left - Text is typed from left end of row.
o Right - Text is typed from right end of row.
In the above example, the last row shows a cursor at the center, indicating that the
row justification is set to Center.
Insert Tab/Delete Tab inserts and deletes row tabs.
Select Next Tab selects the next row tab. To move through row tabs use Alt+< and
Alt+>,

o O O
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Tab Column Mode allows tabs to lock together for repositioning.
Template Lock On - Prevents movement of the Template within the text window. If
the 2D text window is moved, the template will move along with it.

e Position Lock On - The Position Lock On setting specifies whether or not a 2D Text
Window can be moved on its X, Y or Z axes, as well as rotated, scaled or have its
center of rotation changed by means of the mouse to prevent unintentional
changes. Deliberate changes via the Transform Properties are permitted.

e Continuous Update - Enables the selected text window to receive Intelligent
Interface U commands or Update commands for updating text content on output.
Check this option to apply Updates directly to output via Template Update (Alt+T).

e Internal Properties - The Internal Properties accessed from this menu are applied
to the selected 2D Text Window.

e |

Property Value |

KeyboardLayout | 0

Pre-process Data Script
XMP Rules

Lo (o] [conw]

Editing Text
2D Text Editing Tips

e Typing a character in a 2D text window establishes the first row and its baseline.

e \When pressing the Enter key on the keyboard from an existing row the text cursor
will move to the beginning of the next row. If no next row exists one will be created.

e Holding the Shift key while pressing Enter will cause a row split; all characters to the
right of the cursor will be moved to the beginning of the next row (but only if the next
row has been previously established).

e When text is selected on a row it can be moved by dragging. Lyric will try to snap
the text to the baseline of the row nearest destination defined by release of the
cross-hair "move" cursor. If no baseline snap is desired hold down the Ctrl key
before releasing the mouse button and the text will be positioned where the mouse
button is released; the text will still be attached to the same row.
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Resizing Selected Text
The corner handles of a Bounding Box resize the selected text proportionately.. To adjust
the size of any selected object(s), Left-click/drag a handle in the desired direction.

When a character or word is selected for resizing and the top handle is dragged, the
characters enlarge above the baseline of the row and leaves the baseline of the row
unchanged. If the bottom handle is dragged, the text grows and moves the baseline of the
row down to accommodate the text's new size, moving the rest of the text on the row with it.
When Template (Row-Based) text is selected, no handles appear.

Resizing Text via Keyboard Shortcuts

Keyboard shortcuts are available as an alternative to using the mouse. Refer to
Keyboard/Mouse Shortcuts - 2D Text.

Moving Text and Text Windows Using the Keyboard

Shift Character (Ctrl+Arrow Keys)

Click on a character, then press Ctrl plus «1—| keys to shift the selected character
horizontally one pixel at a time, or vertically one scanline at a time. If shifting characters
horizontally, the characters to the right of the selected character are also shifted.

Shift Row (Alt+Arrow Keys)

Click on a character within the desired row, then use Alt plus the «1—| keys to shift the
selected row horizontally one pixel at a time, or vertically (along with all lower rows) one
scanline at a time.

Shift 2D Text Window/Object (Ctri+Alt+Arrow Keys)

Select the desired 2D Text Window/s to be selected then use Ctrl+Alt plus the «—1—| keys
to shift to the new position on the canvas. When shifting multiple Windows and/or Objects,
they will retain their respective position to each other but be moved incrementally together.
Super Shift

Hold the Shift key while performing one of the above mentioned character, row shift or
object shift to move the item(s) 10 pixels/scanlines at a time instead of by single
pixels/scanlines.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 325

Row Shift Locked/Unlocked

When a row of text is shifted using the keyboard (Alt + | or Shift + Alt + 1), only the selected
row shifts. This is known as Unlocked Mode. The rows beneath the shifted row are not
affected. Locked Mode allows the shifted row to also shift the selected row and all rows
below, so that the rows shift as a block. Ctrl + L toggles Locked/Unlocked mode. The word
LOCK will appear on the status line when the Lock feature is activated.

To activate/deactivate Locked mode
e Press Ctrl + L.
e Locked Mode is indicated bold LOCK text on the Status bar, View > Status Bar

NS [EOL [LOCK [Car NUM [ovET| 2
i

Squeeze/Expand Characters, Templates or Rows

Squeeze/Expand provides a quick method of adjusting the space between 2D characters or
Templates or rows/lines in a 2D Text window.

E Squeeze/ Expa... u

Waord Row

|; I "_] E:ESqueeze

Equeeze Expand || Ernal

L] .

Squeeze/Expand Dialog Box
Right-click the 2D Text Window then select Squeeze/Expand. Highlight the text to be
adjusted and press the applicable buttons,

Squeeze/Expand Using the Keyboard
Squeeze/Expand Word: Ctrl + 4, Ctrl + 6 on Numeric Keypad
Squeeze/Expand Row: Ctrl + 8, Ctrl + 2 on Numeric Keypad

In order for this to work properly, Num Lock must be active, or the text will just be moved in
the direction of the arrow printed on the number key.

Word (Horizontal spacing between letters)

If no text is selected, the text on which the cursor is positioned is squeezed or expanded to
the right. In this instance, the cursor must be positioned inside the word, not before the first
character.

Row (space vertically between lines)

If the space between all rows is to be expanded, place the cursor anywhere in the 2D Text
window. Otherwise highlight the rows that are to be squeezed/expanded.

The topmost row stays in position as the rows squeeze/expand up/down.
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Row Tabs

Setting up a Row Tab
Row Tabs, used to produce columns in 2D Text windows and Roll, Crawl and Type On
(Slow Reveal) windows, are similar to ordinary tabs in a traditional word processor. The
term Row Tabs is used to distinguish this function from Template Fields (in the context of
Intelligent Interface and External Update) and the use of Tab keys in keyboard shortcuts.
Each Row Tab's attributes are individually set (font style is not determined by the tab). To
set attributes, a Row Tab must be established in a 2D Text window on the Canvas.
1. For this example, add a 2D Text window.
2. Right-click on the 2D Text window context menu, and then select Insert Row to
create the Canvas's first row without typing text.
3. Click anywhere on the baseline of the first row and press Ctrl + T to set a tab stop.
A red Row Tab Marker appears (see figure below).

2D Text 1

4. Click and drag Row Tabs to adjust their locations on the row's baseline. Whenever
a Row Tab is selected, it turns red. When it is not selected, it is green. When its
properties are being set, it turns purple (see next step).
Row Tab Added to Canvas
Right-click on the marker to display the context menu, then select Tab Alignment. The Row
Tabs Properties dialog box is displayed and the Row Tab marker turns purple.

Fow Tabs Properties ﬁ

Justification
7 NONE

() Right

(71 Mumeric

) Decimal

[7] Auto Erase
¥ Position: 627

Tab Column: 0

Select the Alignment Properties:
e None - Text appears where typed.
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Center - Text centered on Row Tab marker.
Left - Left end of text stays at Row Tab marker.
Right - Right end of text stays at Row Tab marker.
Numeric - Right end of number stays at Row Tab marker. Use with whole
(non-decimal) numbers. Two examples are shown below.
Decimal - Decimal point stays at marker.
Auto Erase - When Auto Erase is enabled, text is automatically erased when new
text is typed. The row tab must be selected (red). Use one of the following methods
to access the Row Tab in order for this to work. Just typing in the column does not
erase the existing text.

o Press Alt + J, Alt > or Alt <.

o Click the Row Tab marker with the mouse before typing

o Right Click menu > Select Next Tab
X Position: Reflects X Position of the Row Tab relative to the left border of the 2D
Text window. This value can be changed in this field.
Tab Column: Reflects the column number. The Row Tab columns are
automatically numbered in order of their creation, starting at 0. This value cannot
be changed.

About Row Tabs

Each Row Tab's properties are set individually, but may affect other Row Tabs if
working in Tab Column Mode (see "Working with Tab Columns," below).

Templates that are attached to a Row Tab have their own justification for text within
the Template borders, but their placement on the row is set by Row/Tab Properties.
In the preceding example, a Row Tab was created without first inputting text. To
create a Row Tab in existing text:

Position the cursor where the Row Tab is to be inserted, then click the Ctrl + T key
combination or 2D Text Windows right click menu and select Insert Tab.

When a Row Tab is established, text is "attached" to it. All text attached to a Row
Tab remains so until the text or Row Tab is deleted, or the text is selected and
repositioned using the mouse.

Row Tab Navigation, Selection and Deletion

Select Next Tab - To move among the tab stops on a single row, Select Next Tab
from the Right Click menu, or press Alt + J, Alt > or Alt <.

Navigating Among Row Tabs - To move left-to-right/top-to-bottom or vice-versa
among Row Tabs on different rows, Press Alt plus the < or > keys.

Moving Row Tabs - To move all the Row Tabs to the right of a selected Row Tab,
press the Alt key while clicking and dragging a Row Tab.

Delete Row Tab - Select the Row Tab marker, then press the Delete key; or
left-click on the Row Tab marker, then hold down the left mouse button and press
Delete.
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Tab Columns and Using Tab Column Mode
Row Tabs can be used to create columns in Lyric, making alignment of text columns easy.
1. Select Tab Column Mode press Alt + M. This puts Lyric into Tab Column Mode.

TRWCCOCROCK C4F M OvF!

2. Open afull-screen 2D Text window. Access, 2D Text Windows right click menu >
Insert Row to create a row on the Canvas.

3. Click at a second location on the baseline of the row, then and press Ctrl + T to set
a second tab stop. A second Row Tab marker appears.

2D Texrt 1

Director _Joan Smith|

Adding a Second Row Tab

1. Press Enter, and a second row is created, containing the same tab stops. The
columns are numbered in the order of their creation. Tab column numbers cannot
be changed.

2. Click at the Row Tab marker for the first column on the first row and begin inputting
text. If you press Enter, the cursor will move to the beginning of the same column
on the next row. Pressing Enter when the cursor is in the last row on the Canvas
adds a new row(s).

Adjusting Row Tabs Properties while in Tab Column Mode:

e Setting the Row Tab Properties of one Row Tab in any row affects the properties of
all Row Tabs in the same column.

e Selecting a Row Tab and repositioning it moves all Row Tabs in the same column in
the following rows.

e Selecting a Row Tab and sliding it past another previously repositioned Row Tab(s)
in the same column and below it "picks up" the repositioned Row Tab and brings it
into alignment with the moving Row Tab above.

To exit Tab Column Mode:
e Press Alt + M. Tab Column Mode is now disabled.
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Pop-On Messages

A 2D Text Only message, also known as a Pop-On message, can be recorded and read
back into a message containing 2D Text Window/template to replace existing text. Pop on
messages can be text contents or 2D text templates only.

When read into a message, the Pop-On message replaces the new text at the current
cursor position on a row in the 2D Text Window.

A Pop-On message is row-based. To ensure proper Template height, include a space
character in the selected text.

Example:
Text only recorded message:

2D Texrt 1

Current opened message with 3 lines, cursor positioned on the line 2

2D Text 1

. lextMessage Line1... . . >
JextMessage Line?2| ... _

» lext Message Line3.... ... ... a2
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Text Only Pop On message is read. Pop On message text replaces text on line 2.

ZD Text 1

L lext Message L_|_n_e___1 ___________________________________________ a

[Fext Message Llne__3 __________________________________________ _

2D Text Animation Windows, Crawls, Rolls and Type Ons

From the Tools menu, select Text > 2D Text Window.

'Tr:H:LI5| Help

3D Object el

Text b 3D Te

Irnage 20 Text Window
Media 20 Text Template
Flipbook 2D Text Crawl
Data Object 2D Text Roll
Trigger Track 20 Text Type On
Grong Ctrl+ G 2D Text Clock
e i Cirla U 20 Text Timer

Video Capture

¥ 1 Canvas

or click the a icon from the Scene Tools toolbar and select 2D Text Roll/Craw/Type On

from the drop selection.

2D Text animating windows look like regular 2D text windows, except for the Crawl/Roll
window's scroll bar that allows for additional text entry.
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Animation Properties
The Animation Properties are set from the General Pane. The animation can be set by
using either the Duration, speed or rate.

4 Animation Properties

& |

Duration &) 00:00:0501 7%
Speed # @ 1 :_
Rate @ 0010 8

|

Duration sets the animation to a fixed completion time
Speed # sets the animation to a defined speed preset where 1 is slow and 10 is
fast. The timeline duration will adjust with the amount of text

e Rate sets the animation to calculate a rate of characters per second. The timeline
duration will adjust with the amount of text

2D Text Clocks

2D Clocks can be added to Lyric messages and manipulated the same way as other 2D
Text Windows. Clocks are time of day format, as opposed to Timers which are counting up
or down functions. 2D Text Clocks use the Windows CPU clock for its reference. The Clock,
composed of 2D text, can be displayed in a TrueType® or RGB Fonts, in a variety of
hour-minute-second formats.

From the Tools menu, select Text > 2D Text Clock.

'Tools | Help
3D Object v |
Text 3 3D Text
Image 20 Text Window
Media 20 Text Template
Flipbook 2D Text Crawl
Data Object 20 Text Roll
Trigger Track 2D Text Type On
Group Ctrl+G Do Lk
Ungroup Ctri+U Rt Dt

Video Capture

¥ | 1 Canvas

al

or click the
selection

icon from the Scene Tools toolbar and select 2D Text Clock from the drop
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A 2D Clock Window is inserted onto the canvas. The format for the clock can be set from a
list of presets or customized using the Clock formatting codes.

General @
20 Text Clock > Clock 1

10:33:09 AM

4 Node Info

Mode Name Clock 1

Description
dType
@ Clock @) TimerUp () Timer Down
romat | IR )
WM D hh:mm N
M D, ¥¥ hh:mm M
OHH:mm
Ohh:mm
hh:mm M
OHH:mm:ss
Ohh:mm:ss
Type
The clock function can be changed to a timer up/down function.
Format

Common formats are available in the dropdown, but users can customize to any format that

uses the system's specifiers properly.
e WW Full current weekday (for example, Friday)

W Abbreviated weekday (Fri)

MM Full current month (August)

M Abbreviated month ( Aug)

DD Current day of month (1-31; if this field is preceded by a ‘0’, then the day will be

displayed with a leading zero)

YY Full current year (2016)

Y Abbreviated 2-digit year (99)

hh Current hour in 12-hour format; if this field is preceded by a ‘0’, then the hour will

be displayed with a leading zero

e HH Current hour in 24-hour format; if this field is preceded by a ‘0’, then the hour will
be displayed with a leading zero.

e mm Current minute (0-59; if this field is preceded by a ‘0’, or a previously specified *
hh’, then the minute will be displayed with a leading zero)

e ss Current second (0-59; if this field is preceded by a ‘0’, or a previously specified
‘mm’, then the second will be displayed with a leading zero)
N Meridian specifier (AM/PM) for 12-hour clocks
+ hh:mm Optional time zone offset which will be added to current time before
display (for example +5 , +11)

e - hh:mm Optional time zone offset which will be subtracted from current time before
display (for example -2 ,-12, -5)

e B Current month as an integer (1-12)

Leading Zeros One common format is hh:mm:ss, which displays hours, minutes
and seconds in 'leading zero' fashion when the values are less than ten (02:09:07),
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and the "hh" specified is preceded by a "0". To strip leading zeroes from a Clock or
Timer display, add -0 at the beginning of the format specification. The " - " character,
or any other entry of user-defined formats can be typed directly into the Format text
field. Meridian specifiers are invalid for 24-hour formats

Additional customized Text user-typed characters can be added to the clock or
timer display’s automatically generated characters. These characters must be input
by the user in quotation marks and will appear exactly as input. For example, a
clock might be modified hh:mm: ss "EDT". A timer display could be formatted
hh:mm: ss "Quartz-Precise Timing". Editing is done directly into the Format
dropdown.

4Type
@ Clock ) TimerUp ) Timer Down
Format OHH:mm "E5T" -

Flexible Display Formatting

To facilitate international display of time and date, clock and timer fields can be specified in
any order and separated by any of the following delimiter characters: space, period (" . "),
comma (", "), semicolon (" ; "), colon (" : ") or forward slash (" / "). Editing is done directly
into the Format dropdown.

Rules for clock use

Multiple clocks with multiple formats can be added to messages.

A leading zero can only be applied to the first specified time field ( hh, mm or ss).
To strip leading zeroes from a Clock display, add -0 at the beginning of the format
specification.

Except for literal fields (those enclosed in quotation marks), each format specifier
can be used only once.

With the exception of the space quotation characters, formats cannot end with a
field delimiter character.
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2D Timers can be added to Lyric messages and manipulated exactly the same way as other
2D Text Windows. Timers count up or down from zero, as well as have events associated
with them to trigger actions at specified times. The Timer, composed of 2D text, can be
displayed in a TrueType® or RGB Fonts, in a variety of hour-minute-second-frame formats.
From the Tools menu, select Text > 2D Text Timer.

?Toois] Help
3D Object v |
Text 3 3D Text
Image 20 Text Window
Media 20 Text Template
Flipbook 2D Text Crawl
Data Object 2D Text Roll
Trigger Track 20 Text Type On
Group Ctrl+G Do ik
Ungroup Ctri+U ARt e

Video Capture

¥ | 1 Canvas

al

or click the
selection

icon from the Scene Tools toolbar and select 2D Text Timer from the drop

A 2D Timer Window is inserted onto the canvas. The timer type can be set to Timer Up or

Timer Down.

2D Text Timer = Timer 1

4 Mode Info
Mode Mame Timer1

Drescription

4Type

©) Clock @ Timer Up

[

() Timer Down

Format mm:ss|
i Start 0:00
4 Properties

Justify o

-
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Timer functions can be controlled via macro scripts or via the Triggers > Timer actions.

General _
Trigger = Triggers

4 Mode Info
Mode Mame Triggers
Description

4 Actions

Action Type Properties

Timer Timer 1 -

Action oggle Start [:J
Start
Sto
T
Reset
Show
Hide
Toggle Show
Reset Time
Format

Formats

e d Total days (0-9). If this field is preceded by a' 0, then the days will be displayed
with a leading zero.

e h Total hours (0-9). If this field is preceded by a' 0 ', then the hours will be displayed
with a leading zero.

e hh Total hours (0-99). If this field is preceded by a' 0 ', then the hours will be
displayed with a leading zero.

e hhh Total hours (0-999). If this field is preceded by a ' 0 ', then the hours will be
displayed with a leading zero.

e m Total minutes (0-9). If this field is preceded by a' 0 ', then the minutes will be
displayed with a leading zero. If an hour field has been added, this format is invalid.

e mm Total minutes (0-99). If an hour field has been specified, then the minutes in the
hour (0-59) will be displayed. Otherwise, if this field is preceded by a'0 ', then the
minutes will be displayed with a leading zero.

e mmm Total minutes (0-999). If this field is preceded by a' 0 ', then the minutes will
be displayed with a leading zero.

e s Total seconds (0-9). If this field is preceded by a' 0 ', then the seconds will be
displayed with a leading zero. If a minute field has been specified, this format is
invalid.
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ss Total seconds (0-99). If a minute field has been specified, then the seconds in the
minute (0-59) will be displayed with a leading zero. Otherwise, if this field is
preceded by a' 0", then the hours will be displayed with a leading zero.

sss Total seconds (0-999). If this field is preceded by a' 0 ', then the seconds will be
displayed with a leading zero.

f Fractional tenths of a second (0-9). This field is always displayed with a leading
zero.

ff Fractional hundredths of a second (0-99). This field is always displayed with a
leading zero.

Rules for Timer Use

Except for user-typed text, each format specifier can be used only once.

A leading zero can only be applied to the first specified time field.

To strip leading zeroes from a Clock display, add -0 at the beginning of the format
specification.

Only the first specified time field can have 3-digit precision ( hhh, mmm or sss).

With the exception of the space and quotation characters, formats cannot end with a
field delimiter character.

Timer Functions

Start Starts updating the timer. If the timer is off the Canvas or otherwise hidden,
the Start command does not display it.

Stop Stops updating the timer. If the timer is shown, the Stop command does not
hide it.

Toggle Start Cycles between Start and Stop.

Reset Reset the timer to a previously defined reset value.

Show Makes the timer visible. If the timer is stopped, the Show command will not
start it. Timers appearing alone on the Lyric Canvas can be used for keying over
other video sources.

Hide Makes the Timer invisible. If the Timer is running, the Hide command will not
stop it.

Toggle Show Cycles between Show and Hide.

Reset Time Change reset time to that specified.

Format Change format to that specified

Tip - To control Timer Functions (Actions) via Playout Panel buttons, create Transitions
containing Trigger Tracks and add the desired action (eg Toggle Start). Assign a hotkey to
the Transition for quick execution.
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Timer Events

An action can be configured to occur when a running 2D text timer displays a specified time.
For example, when a timer reaches 10 seconds, you could start a new timer or trigger a
macro that changes the text color to Red, or trigger a transition that animated the text to be
larger.

H

20 Text Timer = Timer 1

4 Event

Properties Adtions

At Time 00:00:00:00.00 Transition
Add Event
4 Actions
Action Type Properties

Flash -

In this example, at when the selected timer reaches time 00:00:00:00.0 a transition called
‘Flash’ will execute.

Creating a timer event

Add a 2D text timer
On the Events pane View>Events, click ‘Add Event’ in the event section

Click into the timecode to change the time at which the action(s) should occur.

Click the Add button under the Action grid to add one or more actions. Available actions are
shown below:
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Action Type Properties

Transition

Transition (External)
Transition (Metwork)
Macro

External Connection

il

Conditional Transition
GPI
Tirner

Update DE Link

Timer Internal Properties
Access the Internal Properties via From the right click menu on a 2D Text Timer > Internal
Properties

Gl]rrnn Lynm—ﬁ
| Property Value
Global Timer False

Maintain Baseline True

Pre-process Data Script
AMP Rules

e Global Timing. A timer can either be set to False or True for Global timing. By
default this option is set to false. This means that a timer will restart anytime the
message is read. A true timer will inherit the time from any timer with the same
name. Thus timers can be consistent among messages or during update in/out
transitions

e Maintain Baseline a font change does not shift the baseline if maintain baseline is
enabled.

See XMP _and Pre-Process Scripting for further details.
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By default, 3D Text appears as a template. This differs to 2D text where a window is
inserted and templates created inside that window. Types of 3D text include, Static text,
Crawls, Rolls and Type Ons. All 3D text is first inserted as a static 3D text then the Type is
adjusted via General Properties > Type

Supported

Lyric provides maximum creative flexibility with its support of TrueType®, OpenType®, as
well as Unicode (Chinese, Japanese, Cyrillic, etc.). Lyric does not support PostScript®

fonts

Creating 3D Text

From the Tools menu, select Text > 3D text.

| Tools | Help

3D Object
Text

Image

Media
Flipbook
Data Object
Trigger Track

Group
Ungroup

Video Capture

al

or click the
selection

AR g HE Y U 3

Ctrl+G
Ctrl+LU

3D Text

20 Text Window
2D Text Template
2D Text Crawl

20 Text Roll

20 Text Type On
2D Text Clock

2D Text Tirner
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Editing and Updating 3D text template contents
There are 3 methods for typing text into a 3D Text Template.

1. Directly into the Template on the canvas

2. Into the Text Input Area inside the Font Style Pane

3. Inside the Template Update Pane (Alt+T)

- 3D Text typed on the canvas

Type and Click Apply to insert text/changes. 3D text is automatically enabled for update.
More information regarding Template Update here

Template Update @
Text I

~ 30 Template 1 0

3D Text typed in Template Update

For editing font appearance see Font Styles.

For editing font color and texture see Surfaces

For editing template ordering and selecting which templates are available for update see
Update Ordering
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Setting Template Properties
All of the Node Info, Template Properties (including Type i.e Static, Type on, Roll, Crawl),
Rendering, Language and Data (DB Links) are set in the General Properties Pane.

General B
3D Template > 3D Template 1 A
4Node Info
MNode Name  |3D Template 1
Description
4Template Properties
Type |static v
Clip Bounds [
Size w o2 P Ho B
Max Rows = Actual 1
Wrap
Size to fit H [
Min % =
Alignment E = M
Numeric O [[] vertical
Auto Erase &~ [] AN Caps
Fit Bounds To [  []Small Caps
Glyphs « o B
4Rendering
Fix Overlap D
outlineAa [
Quality 1x "
4language
Keyboard EN
Default
Digit Sub
4Data
DB Linking
v
Node Info

e Node Name is the node name as represented in the Scene Graph and what
appears in Update Ordering and Template Update (when enabled for update).
Name enables a given template to be named for easy recognition.

e Node Description is entered here. Both Node Name and Description can be
utilized by additional Lyric features including Inherit State and Conditional

Transitions.
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Template Properties
e Type The following text options are available in the Type dropdown box on the 3D
text template dialog. When a selection other than Static is set additional Animation
Property become available allowing the animation attributes to be determined.

4 Template Properties
Type -
Clip Bounds Crand]
Size Roll
Type On

1. Static: The default selection. Applies no animation to the selected 3D text
template.

2. Crawl: This option automatically creates an animation which moves text
horizontally or vertically across the Canvas (dependent on your alignment
settings). The Crawl animation's default length is the same as the currently
set Default Node Length. Various options for modifying the 3D text Crawl are
detailed below

3. Roll: This option automatically creates an animation which moves text
vertically on the Canvas. The Roll animation's default length is the same as
the currently set Default Node Length. Various options for modifying the 3D
text Roll are detailed below

4. Type On: This option produces an animation that mimics the look of a
typewriter "typing" text on the screen. Soft option.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 343

Animation Options (Crawls, Rolls and Type Ons)

4 Animation 4 Animation
Direction @ L &R Direction @ T B
Duration @ 00:00:0500/% | Duration @ 000005007
Rate (unitstgy () 0.0015 Rate {units/f  (7) 0.0015
Rate (3% CB/M () 08710 Rate (% CB/ff () 0.8710 i
Preserve Rate [ Preserve Rate [
Bounds Clip Bounds Clip
4 Template Properties 4 Template Properties
Type Crawl - Type .Ra | =
4 Animation
Duration @ 00:00:0500 %]
Rate (units/fy () 0.0015

Rate % CBM (O 03710
Preserye Rate |:|
Bounds Clip

4 Template Properties

Type Type On -

e Direction is available for Rolls and Crawls. Crawls have the option of L (Left) and R
(Right). Select the desired radio button to set the crawling direction. Likewise Rolls
have a T (Top) and a B (Bottom) direction radio button to set the desired Rolling
direction.

There are 3 options for setting the speed of the animation:
e Duration sets a fixed time that the animation must be completed by. The speed/rate
of the animation will vary to accommodate this. It's a good idea to preview your work
in this case.

e Rate (units/f) selecting rates in units will result in a set speed of the animation but a
varying duration depending on content. When Rate (units/f) is modified, End Frame
and Duration are automatically updated. The Units are Scanlines/Field for Rolls,
Pixels/Field for Crawls and Characters/Second for Type Ons. Range is 0.000000 -
50.000000.

e Rate (% CBI/f) this is a rate specified as a percentage value of the Clip Bounds area
and is not determined by the length of text contents.
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e Preserve Rate: Moving the initial position of a 3D text animation, or changing the
Width or Height of its Clip area (see below) will alter the amount of Canvas space
that the animated text must travel. This can effectively alter the speed at which the
text moves through its Roll, Crawl or Type On region. Selecting this option causes
Lyric to recalculate the point on the Canvas at which moving text disappears from
view, so as to maintain the speed at which the characters move from their point of
origin. Be careful to preview messages to which this option is applied after initial
composition, as there may be a dramatic effect on the appearance of the finished
product.

e Bounds Clip: With this option enabled, the boundaries of a 3D text template's
visible regions are displayed to the user on the Canvas. This feature is particularly
useful for sizing the area through which Crawls and Rolls visibly move. Normally,
displayed Bounds Clip restrictions are not visible on output and have no effect on
setting the Bound controls. However, the effect of the bounds clip option CAN be
seen on Output when the Live button is enabled, so caution should be exercised in
those rare instances when Live Output is in use.

Template Properties (All types)

e Clip Bounds when enabled sets restrictions on the size and wrapping behaviour of
the text area.

e Size defines the Width and Height of a text template bounding area, determining the
size of the template's visible area. (Bounds are initially set by the height of the text's
tallest character and the width required by the number of characters and spaces in
the template). The size of the template bounds can be increased beyond the area
occupied by the text, or narrowed to restrict the visible area.

e Max Rows limits the number of rows available in a multiline template. Actual shows
the true amount of rows without max row limitations.

e Wrap when enabled allows text to wrap to new rows either when text overflows a
row or it encounters a line break character. Wrapped text outside the defined
bounding area will not be visible unless size to fit is enabled.

e Size to fit Text will resize on either its Height or Width or both to fit the template
bounding area. A minimum percentage for the sizing can be set to ensure the text
does not shrink down to an unreadable size. Once the minimum size is reached text
outside the set limits will not appear.
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e Link Size to Fit opens a dialog box which allows you to nominate 3D text
templates that will scale together. For templates that have size to fit enabled, often it
is desirable for different text templates to have the same size text- for example, in
the case of bulleted text. This ensures all templates will size to the smallest of all
linked templates. W and/or H must be selected on all the nominated templates.

Link Size To Fit

Available Linked
Title Row 4
Raow 3

HH

e Alignment - Text will retain the previously selected alignment for all newly inserted
templates. Newly-placed 3D Templates are automatically positioned so that the first
letter in the first row is situated at "0" on all three spatial axes. The axis does not
move but rather the text moves around the axis, so it’s best practice to set the
alignment before moving the text into position or you will need to reposition after
adjusting the alignment. See examples below.

The first option for alignment within the template is horizontal alignment (text
positions around the Y axis).

Alignment = M

Mumeric £ Left
Auto Erase Center
Right
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The second option is vertical alignment

The First Line option positions the X axis on the baseline of the template's first

line/row.

Alignment = @ L&l

Mumeric F | = Top

Auto Erase ] | = Middle
= Bottom

4 Rendering = ; .

= First Line
Fix Creerlan e

Align Boftom. Align First Line]

The third option is text orientation such as left to right M and right to left T for
right to left languages.

e Numeric The Numeric setting determines how numbers are justified in a template.
When Numeric is not enabled, numbers are not monospaced, so they do not
properly align if the numbers are of different widths. If Numeric is enabled, only
numbers typed on the alphanumeric keyboard, the dollar sign ($), the comma (,),
and the period (.) characters can be typed in the template. Numbers are
monospaced instead of kerned so that multi-row numbers vertically align. When
Right Justification is set, the numbers justify to the right. To ensure vertical
alignment of the numbers, make sure that each number in the template contains the
same number of digits following the decimal point.

e Auto Erase Auto Erase sets the text template to automatically erase its contents
when new text is typed in the template. Template contents updated via DB Link,
Intelligent Interface or Template Update are always completely replaced by the new
contents, regardless of the Auto Erase setting.

e All Caps Select this option changes all lower-case or mixed-case template contents
to all upper-case.

e Fit Bounds to Glyphs when checked the template bounding box is the actual size
of the text it contains. When unchecked the bounding area is set to the maximum
size for any character within the font set. Text contained within the template bounds
will shift accordingly if using alignments other than first line justify.
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fit bounds to glyphs fit bounds to glyphs
enabled (default) disabled

XXXXX

The left template uses the ‘fit bounds to glyphs’ method to calculate the bounding
region. The right template has opted to disable fitting of the bounding region to the
glyphs. Notice that there is room to accommodate both characters that extend into
the ascent region of the font (lower case ‘h’ for example) or into the descent region
of the font (lower case ‘gQ’).

e Small Caps Select this option for all lower-case characters to be inserted as smaller
upper-case characters. Adjust the size from General properties.

Small Caps

-

% 69 =

e Vertical Toggles between typing conventionally on a Horizontal baseline, and
tipping the baseline -90° on its Z axis, effecting a Vertically oriented baseline.
Vertical mode not reflected in the Transform Properties. The text selected for editing
will also rotate clockwise in the Text input field on the Font Styles menu.

T

BonIo

=
21 1z
®
g1}
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Rendering

e Fix Overlap In languages such as Hindi and Arabic, unwanted bright spots may
occur where characters overlap by design. This option normalizes such bright spots
without disturbing the desired overlap of those characters.

e Outline AA will render a fine outline around each character. This additional outline
will assist in smoothing out aliasing however the characters will appear ‘bolder’. The
illustration below shows the polygon points rendered when Outline AA is disabled
(left) and enabled (right).
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Language
Keyboard shows what input language is currently set. It can be adjusted here as well as
the normal windows language selections. The template is not locked to this language. All
templates will input whatever language is currently active on the keyboard.

dlanguage {

Keyboard @]

o 1 v EM English {United States)
Digit Sub Mo
TH Thai (Thailand)
4Data PR Dari (Afghanistan)
DE Linking CH Chinese (Simplified) (Pecple's Republic of China)
ZH Chinese (Traditional} (Hoeng Keng 5.4.R.)
EM English (Australia)

Digit Substitution
This option allows the user to switch easily between numerical characters in the 'native

tongue' of the message being composed, or in foreign-language characters that are most
common for displaying numbers in that language

Data (DB Linking)
DB Linking allows a text template to be automatically populated and updated from a

database. See DB Linking.
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3D Text Contextual Menu

Preview Only

Color code Object >
Add To Current Transition
Position Lock On

Copy Animation State

Paste Animation State
Motion Path >

Insert Row
Delete Row

Continuous Update

Internal Properties

e Preview Only Enables the node to be viewed on the canvas as a preview only and
is not rendered to output. A preview only node is italicized in the Scene Graph and a
P is inserted next to the node.

e Color Code Object: Enables the object listing in the Scene Graph to be displayed
with colored text in order to make it easier to quickly identify.

e Position Lock On: The Position Lock On setting specifies whether or not a
template can be moved on its X, Y or Z axes, as well as rotated, scaled or have its
center of rotation changed by means of the mouse to prevent unintentional
changes. Deliberate changes via the Transform Properties are permitted.

e Copy/Paste Animation State Animation attributes such as Position, Rotation,
Scaling, etc., can be copied from one object and pasted to another.

e Insert Row/Delete Row: Inside a Template, this function deletes or inserts a
Template row.

e Continuous Update: Enables the selected Template to receive Intelligent Interface
U commands or Update commands for dynamically updating text content on output.
Check this option to apply Updates directly to output via Template Update (Alt+T).

e Internal Properties: The Internal Properties accessed from this menu are applied
to the selected template. Keyboard layout See more details on Pre-Process Data
Scripting and XMP
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3D Object Import

3D Obiject files can be imported into a Lyric scene. They can be moved, scaled and
transformed through 3D space. Imported 3D objects can also be deconstructed and
reconstructed. Note: for FBX import use the File Menu.

Supported Files
.3ds, .prj, .obj, .3do

.3do is a proprietary Lyric Object file. For more information see Save As
Importing a 3D Object

1. From the Tools menu, select 3D Object > Import 3D Object or click the ﬁ] icon
from the Scene Tools toolbar

2. Navigate to and select an Obiject file. Click Open.

Checking the Preview option shows an animated display of the object moving on all three

axes
- -
Import 3D Object ﬁ et
Lookin: || 3D5 Object Lib - (¥ @~
: 3 Lot ﬁ = . [¥] Preview
T MName Type Size =
bl | |Cube13Ds 3DS File 3KB
REcETt EeEsll [} e 2305 305 File 4KB |
-1 ! Cube3.3Ds 2D5 File 9KE i~
|| Cylinder 1305 305 File 17 KB
Desktop | |Helix1.3DS 305 File 6 KB
|| Helix2.305 305 File I5KB
u;a | |Pill13D5 305 File 24 KB
Libraries | pill2.3Ds 305 File 6 KB
- || Pyramid.3DS 305 File 2KB
|y | |QUAD1.3Ds 305 File 3KB
Computer | |QUAD23D5 305 File 8 KB
| |Rectangle11x1.305 305 File IKB
| @ || Rectangle11x2.3D5 305 File IKB
Nefiiark Rertannls 7 1+7 AN NS File - 2KR
File name: Cube 3.3D5 -
Files of type: All supported files (*.3ds;" pri:" obj;".3do) v] [ Cancel ]
(|  Apply to Background
Size to Fit Center
— —
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General Properties

General o |3

3D Object > Cube 3

4Mode Info

Mode Mame Cube 3

Description
4 File Path

[E\Project Folden3D Ob...\Cube 3.305 [[o ]

E| Maintain surfaces on replace

4 File Info
Embed

Triangles 204
Size on Disk 2151 KB

4 Geometry
smoothing 15000 [%]

4 Data

[ DE Linking -y]

Node Info
e Node Name is the node name as represented in the Scene Graph and what
appears in Update Ordering and Template Update (when enabled for update).
e Node Description is entered here. Both Node Name and Description can be
utilized by additional Lyric features including Inherit State and Conditional
Transitions.
File Path

This displays the file path of the Image file and allows for browsing via E] to replace.
Maintain Surfaces on Replace maintains any applied textures or colors when replacing an

object via the browse button. Substituting objects with less surfaces results in textures being
lost and likewise when replacing with objects with more surfaces default states will be used.

File Info

Embed when checked ensures the 3D object geometry is embedded into the .lyr file when
saved. This means if the object source file path is lost the object data is retained within the
Lyric message file. (Embedding 3D object texture layers is enabled in Surface Properties).

File Info displays all relevant file information including; 3D Object size in Kilobytes.
Geometry

Smoothing controls the effect lighting has on the 3D objects polygons. The example
below, 0 is no smoothing applied, 15 is the default value and 100 is the maximum. The
mechanism behind this adjustment involves Lyric moderating the effect of lighting on those
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polygons in the object whose cross-product is less than or equal to the value set on the
Smoothing Angle

0.000 15 000 100. 000
e i

1

DB Link
See DBIlinking.
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3D Object Primitive

3D object Primitives are basic 3D shapes with attributes that can be customized. Their
attributes are keyframeable.

Importing a 3D Primitive Object

1. From the Toolbar Tools Menu > 3D Object > 3D Object Primitive or Click the B
button.

2. A 3D Primitives Object selection dialog opens (illustrated below)

3. Select desired 3D Primitive and click OK

S
__CONE | _ CUBE |

Cone

C
[CYLINDER| i P
Cylinder P

ube
ob |
od

. SPHERE | . TORUS |

Geometry

3D Primitive object's geometry and other properties can be altered via the General Pane,
View > General Properties. Geometry is unique to each primitive with the one common
property to all objects being Tessellation

Tessellation varies the number of triangles comprising the object being rendered. Any 3D
primitive requires a certain minimum number of triangles to successfully produce the
desired shape. Varying the Tessellation value has a dramatic effect on the quality of the
shape. The base of any shape is always present and the number of triangles specified by
the user is in addition to the base surface.

Torus has tessellation broken into Rings and Sides where both can be adjusted
independently of the other.
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CONE
Tessellation: Minimum value, 3 ; default value, 30 ; maximum value, 100. The Minimum
setting of 3 produces only 3 triangular sides in addition to the base, forming a tetrahedron
rather than the desired cone. With progressively higher settings, the shape looks more like
a cone with the expected smooth surfaces. The illustration shows tessellation values from
left to right ; 3, 9, 13 and 100.

Height and Width: Default value, 0; maximum value, 5. The height and width varies the
dimensions of the Cone shape in the same manner as adjusting the X and Y Scale
transform properties.

Cube

CUBE

Tessellation: Minimum value, 1 ; default value, 1 ; maximum value, 100.

Bevel: Minimum value, 0 ; default value, 0; maximum value, 0.5. With this control set at "0"
the cube's sides meet at 90° angles. As with 3D objects and Lyric-produced 3D characters,
this control introduces an additional surface connecting the 6 sides that comprise the
shape's most basic form. Left image shows no bevel while right image shows a bevel of
0.045

FOR MORE INFORMATION VISIT:
HTTP://CHYRONHEGO.COM/


http://chyronhego.com/

LyricX 4.6 User Guide
Page 356

Cylinder

-

CYLINDER

Tessellation: Minimum value, 3 ; default value, 20 ; maximum value, 100. The default value
produces a shape whose individual sides are barely visible. As with other curved shapes,
increasing the tessellation will result in a smoother appearance. The below image illustrates
the Cylinder with tessellation from left to right set to 3, 6, 16 and 100.

Height: Minimum value, 0 ; default value, 1; maximum value, 5.

Diameter: Minimum value, 0 ; default value, 1; maximum value, 5.

Start Angle: Minimum value, 0; default value, 0; maximum value, 360. This setting allows
the user to set the initial position from which animated movement, or changes to the shape,
begin.

Angle Size: minimum value, 0 ; default value, 0 ; maximum of 360. With this adjustment set
at 360°, the cylinder's bases describe closed circles, and its sides an unbroken surface.
Decreasing the Angle Size value cuts a 'slice' into the shape, as seen below: Angle size
from left to right is set to 360°, 270°and 90°
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Hole: Minimum value, 0 ; default value, 0; maximum value, 5. Hole opens a hole through
the center of the object. Be careful of setting the hole value too high, as it can 'consume' the
base of the shape completely. Below illustration shows the Hole set at 0.7; both with and
without a bevel.

Bevel: Minimum value, 0 ; default value, 0; maximum value, 2.5. Again, Bevels introduce an
additional surface connecting each of the basic object's original sides. The cylinder
illustrated below shows Bevel settings: At from left to right, 0.125, 0.3 and 0.4.

The variation on the right is rotated on its X axis to show the effect of high Bevel settings on
the object as a whole.
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Pod

I A

L _POD |

Tessellation: Minimum value, 0 ; default value, 20 ; maximum value, 100. As with other
shapes, setting this value below a certain number creates too few constituent triangles to
successfully form the shape.

An example Wireframe is seen below: Left: Pod Tessellation value set at 3, creating only the

front and back of the object.
At right, Tessellation is set at 4, enabling all the object's sides.

Depth: Default value, 0; maximum value, 5. When a Pod is first created on the Lyric
Canvas, it appears as a simple square, without sides that give the appearance of three
dimensions. The Pod can be shaped and given depth by adjusting the depth value. This
setting is a variable in the software's initial extrusion of the object on the Z scale. Visually, it
has the same effect as increasing an imported 3D object's, or a 3D character's scale on the
Z axis. To be able to scale on the Z axis using Lyrics transform properties the pod must first
be given a depth value other than 0.

Skew: Minimum value, -1 ; Default value, 0; maximum value, 1. Distorts the Pod shape (see
illustration below). Seen from the front, decreasing and increasing the Skew value causes
the shape to lean to left and right. Negative values lean left while positive values lean right.

NN/ /
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Maintain Shape checkbox preserves the angles created when the Skew control is used to
modify a Pod, regardless of changes in the Pod's size. This feature can be vital in
maintaining the proper appearance of a Pod when, for example, it is serving as the
backdrop to an updaetable text template using the Auto Follow and Size feature. Using this
feature, skewed angles in the design are maintained so that the text does not outgrow the
shape's apparent size as the width and height of the shape's surface vary with the number
of characters in the text.

Skew Textures Checkbox Enabling this option subjects any surface textures or images to
the same angling effect as that imposed on the shape with the Skew control. Skew textures
is unchecked left and checked at right.

Corner Settings

Each of the Pod's four corners (Upper Left, Upper Right, Lower Left and Lower Right) is
varied by these controls:

Size: Default value, 0; maximum value, 0.5. Increasing the Size value decreases the
selected corner's distance from the object's center.

Smoothing: Default value, 0.5; maximum value, 1. Raising the Smoothing value increases
the curve applied to the selected corner. Lowering the Smoothing value can reduce the
curve to a flat surface.

At left, Pod with Upper Right Corner Smoothing set at 0.05. At right, the Smoothing value is
set at 0, producing a flat surface. In both examples, the corner's Size setting is 0.03.
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Polygon

POLYGON|

The polygon primitive allows the creation and import of arbitrary shapes with an optional
extrusion and bevel. Shapes can be created using curve data or imported via an .svg
file. As the curve data from the .svg file is exposed the polygon points can be edited via
the General pane.

Curve Data: Curve data is a list of commands that the geometry is constructed from.
Curve data can be directly typed into the entry window or imported via a .svqg file.

* A command list starts with command type and two numerical coordinates for the X, Y.
* A command type is specified as a single character S, L or C (outlined below)

» All command types and numbers are separated by a single space.

» Each command can be listed or typed continually in a single string.

* The curve data must have at least 3 points to form a polygon.

Command Types:
S - start of new curve (X, Y)
L - linear vertex (X, Y)

C - spline vertex (X, Y) (achieving a C-spline segment requires 4 control points. The start,
followed by 3 defined coordinates. To continue the curve, the last control point in the
previous command is also the first control point of the next C-Spline segment).

Polygon command syntax examples:
Square

S-11

L 11

L 1-1

L -1-1

Square with hole
S 050

L 50 50

L 500

L 0O

S 1030

L 3030

L 3010

L 1010
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Circle
S 10C 1 055181 C 0.55181 1
C 01C-0.551811 C -10.55181
C-10C-1-0.55181 C-0.55181 -1
C0-1C 0.55181-1 C1-0.55181
C10

Canvas Width

Canvas Width specifies the units from the curve data to the units in Lyric.
If Canvas Width is set to 1, there is no unit conversion.

However, most svg content is made with a larger coordinate system, such as screen
pixels.

If a width attribute is detected, it will be loaded from the file. If there is a ViewBox
attribute, this will override the width.

<SVG width="640px” height="480px">

Or
<SVG width="640px” height="480px” viewBox="0 0 20 15”

SVG width=640px

.

| 640 |

The larger the number, the smaller the shape in Lyric.
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Parameters

Quality

Controls the quality of the curve approximation of the outlines.

Al

0.0 0.5 (default) 1.0

0.0 minimum. Linear segments
0.5 default

1.0 maximum subdivisions

Extrusion Settings

Extrusion is enabled and disabled via the checkbox

Depth

Controls the amount of extrusion from the outline.
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Extrusion Style

None Chamfer Custom

e None - Extrude only
e Chamfer - Extrude and Bevel at 45°
e Custom - Extrude and apply bevel with additional settings

Bevel Size
Depth

Controls the depth of the bevel along the extrusion. This value is clamped by the
extrusion depth.

Chamfer 1.00 Chamfer 2.00

Width

Controls the width of the bevel out from the outline. Results in pushing out the sides.
Note: High values might result in undesired spikes.

FOR MORE INFORMATION VISIT:
HTTP://CHYRONHEGO.COM/


http://chyronhego.com/

) CHYRON-HEGO

LyricX 4.6 User Guide
Page 364

Tessellation

Controls the tessellation of the bevel. The value is the number of subdivisions on the
contour curve.

1 3 8

Smooth

Enables Smoothing of the normals on the contour.

disabled enabled
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Curve

Controls the curvature of the bevel.

1.0 0.0 1.0 (default)

1.0 Convex
0.0 Linear
-1.0 Concave

Scale

Controls the scale of the bevel curve. The origin of the scale is the bevel depth away
from the outline.

1.0 (default) 1.0 curve 0.5 scale 1.0 curve 0.0 scale 1.0 curve

0.5 scale 0.0 curve 0.25 scale -1.0 curve 0.1 scale -1.0 curve
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Back

Enables Beveling the back of the extrusion. Note: If using the Bevel Style:Chamfer, the
back will always be beveled.

disabled enabled

Attribute Tracks

All parameters are animatable.

4 |Polygond2
XPosition

N | | | o

@

&

- YPosition i}
& ZPosition 2
O ¥Rotation 74
43 YRotation 4
o ZRotation
o ¥Scale

o Y¥Scale

& Z5cale

o XCenter
o YCenter

o ZCenter
o Transparency
&
O
o
@
@
&
&
o
o
@
@
&

Depth

Depth Enabled
Bevel Type

EBevel Depth
Bevel Width
Curve Cuality
Smooth

Bevel Curve
Bevel Scale

Bevel Tessellation

Bevel Back

=Rl LN LR =R =R =N LR =R = == = L L =

Eevel Hole
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Polygon Surfaces

Surfaces are accessed via the Surfaces Pane.
There are 5 surfaces that materials can be applied to.

e Front

e Back

e OQutside
e Inside

e Bevel

Front - (red), Back - (not shown), Outside - (yellow), Inside - (magenta), Bevel - (cyan)

UV Mapping

Front and Back have Planar UV coordinates. The range is based on the worldspace
units of LyricX

Inside, Outside, Bevel have a projection of U that runs along the length of the outline,
and V is the distance along the extrusion/bevel contour.

SVG Import

Curves can be imported from SVG files. SVG is a large canvas rendering specification
(Scaleable Vector Graphics). Only an extremely limited subset of the specification is
parsed and used in the import process.

No additional information like color or pattern fill mode is imported. Just the path
geometry.
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Additional Notes

e External Namespace References will not be resolved and may interfere with
import.

e Path winding directions can affect extrusions.

e Unknown Xml attributes, tags may affect import

SPHERE
Tessellation, Minimum, 3 ; default value, 30; maximum value, 100. lllustration shows
Sphere from left to right at 3, 16 and 100.

Open Angle: Minimum value, 0 ; Default value, 0; maximum value, 360. This setting can
create, and vary the size of, a slice taken out of the sphere. The Inside surface of the
Sphere is thus exposed. The Inside and Outside are two distinct surfaces that can be
treated with different color and Texture (Surface Properties) settings. Below, the object is
shown is rotated to show the exposed Open Angle.

Stretch Texture to Fit (checkbox): If an image mapped to either of the available surfaces is
too small to cover that surface in its entirety, the image is stretched to cover the entire
surface.
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Torus

TORUS
Tessellation for the Torus is broken into two components: Rings and Sides detailed below.
Rings: Minimum value, 3 ; default value, 20; maximum value, 200. Varies the number of
concentric circles conjoined to form the Torus's surface. lllustration at top set at 3. At
bottom, set at 24.

Sides: Minimum value, 3 ; default value, 40; maximum value, 200. As with the Cylinder, a
minimum number of sides are required to successfully form the desired shape.
From left to right Sides are set at, 3, 12 and 120.
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Outer Radius: Minimum value, 0 ; default value, 100; maximum value, 1000. This control
varies the overall size of the Torus. The "hole" in the object ("Inner Radius") varies in direct
proportion to the Outer Radius unless it is adjusted separately. At left, a Torus at its default
Outer Radius setting of 100. At right, the Outer Radius is set at 200.

Inner Radius: Minimum value, O ; default value, 30; maximum value, 1000. Inner radius
determines the size of the hole in the Torus. Varying combinations of Outer and Inner
Radius values can have some extreme effects as shown in the following illustration. In both
these examples, the Outer Radius is set at 200. At left, the Inner Radius is set at a value of
150; at right, it is set at a value of 2.
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Open Angle: Minimum value, O ; default value, 0; maximum value, 360. Varying the Open
Angle can take a 'slice' out of the shape. lllustration shows an Open Angle of 100°
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Deconstruct
This option turns all imported 3D object surfaces into separate elements on the

Canvas/Timeline/Scene Graph. Deconstructing a 3D object gives much more flexibility and
allows for moving parts animation of an otherwise singular object.

1. Import a 3D Object onto the Lyric canvas. Supported files include: .3ds, .obj, .prj
and .3do.
2. With the object selected, right click and select Deconstruct.

Color code Object
Positien Lock On

Copy Animation State
Paste Animation State

Mask Object

Soft Mask
Mask-To Layer
Mask Inside

Alpha Trim Object
Motion Path

Save As...

Deconstruct

Internal Properties

3. All object sides are separated and grouped together on the Scene Graph. The
below example shows a Pyramid .3ds file deconstructed. The surfaces and names
are respected from the 3D creation software, in this case 3D studio Max.

Mame - I
-

¥ Bottorn
I Left
¥ Back
[¥]7) Right

----- ¥ Front
[y Lightl
-[T]'y Global Light
- | gy Cameral

4. Each side is now treated as a separate 3D object, and can be animated
independently. Deconstructing an object increases the polygon count, and will be
more intensive for Lyric to process than the original 3ds file. Detailed 3D objects
may contain hundreds of surfaces, which could impact message performance.
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Reconstruct

A 3D object that has been deconstruct can also be reconstructed. The sides of an object
can be transformed. Any animation applied to an individual side will be lost as the object
reconstructs.

1. Right click on the group and select Reconstruct. In this example, the sides of the
deconstructed pyramid have been repositioned.

Seene Graph

Name M
5
V) Front
[ZI9 Right
[FI] Back
I Left
¥ Bottom
[y Lightl
[y Global Light
- [C|g@ Cameral

Color code Object
Copy Animation State
Paste Animation State
Metion Path
Ungroup

Reconstruct

Internal Properties

2. The deconstructed group of 3D objects will reconstruct to a single node on the
scene graph, while respecting the previously applied transformations.

Mame - I

) Global Light

The desconstructed object can be saved out as a Lyric 3D object file. This is done via the
Right Click Menu > Save As. Alternatively it can be exported as a Lyric node, which
includes Groups, other elements, transitions and animations.
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Image

Image files can be imported into a Lyric scene as 2D objects.

Importing an Image

1. From the Tools menu, select Image or click the - icon from the Scene Objects
toolbar

2. Navigate to and select an Image file. Click Open.
Supported Files
Bitmap files (*.bmp), DCX files (*.dcx), DPX files (*.dpx), GIF files (*.gif), JPEG (*.jpg,
*.jpeg), PhotoCD files (*.pcd), PICT files (*.pct), PCX files (*.pcx), PNG files (*.png),
PhotoShop files (*.psd), SGI files (*.sgi, *.rgb), Targa files (*.tga) Tiff files (*.tif, *tiff)

Imported *.psd files respect layers and positions. Check the Merge Layers on the import
dialog to merge layers when importing.

General Properties

Image = HEADSHOT

4Node info

Mode Name HEADSHOT

Description
4File Path

I\Lyric Demo\L.AHEADSHOT.tga | .. :
4File Info

Embed O

Size H 112 W 554

Bit Depth 32-bit

AGeomelry
[] Resize geametry on texture change

Resize to boundary

Boundary W 554 2 H 112 (2

Fit boundary
Actual Size  H 112 W 554

Scaled Size  H 112.000 W 554,000
Pixel Aspect 1,000

Data / Metadata
DB Linking Metadats

Node Info

e Node Name is the node name as represented in the Scene Graph.
e Node Description is entered here.
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Both Node Name and Description can be utilized by additional Lyric features including
Inherit State and Conditional Transitions.

File Path
This displays the file path of the Image file and allows for browsing via E] to replace.

-
Images are refreshed via the refresh button * back to the source file which ensures any
changes made to that file are reimported into the Lyric composition.

File Info

Embed when checked ensures the image is embedded into the .lyr file when saved. This
means if the image source file path is lost the image data is retained within the Lyric
message file.

Displays all relevant file information including; Height and Width in pixels and Bit Depth.

Geometry

Resize geometry on texture change

Images and movies are are textures mapped to rectangular geometry. When an image or
movie is changed, the geometry has options for how it will be sized as follows:

|:| Resize geometry on texture change

i@ Resize to new texture size

Resize to Doundary parameters

Boundary W 100 EH 100 E

Disabled/unchecked the new image will take on the dimensions of the image it is replacing.

Resize geometry on texture change

@ Resize to new texture size

i7) Resize to boundary parameters

Boundary W 100 EH 100 E

Fit boundary v|

Enabled/checked the new image will maintain its aspect ratio and the geometry is sized
using one of the following resizing options;

e Resize to new texture size - The geometry is sized to match the new
image/movies dimensions.

Resize geometry on texture change

() Resize to new texture size

@ Resize to boundary parameters

Boundary W 100 [£{H 100 [4]

Fit boundary -
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e Resize to boundary. This will resize the new image to the defined blue boundary
using one of 4 methods;

Example:

Fit Boundary - will proportionally scale the image (maintaining aspect) to fit
entirely within the boundary region.

Fill Boundary - will proportionally scale the image such that the boundary
region is entirely filled. As a result, the image’s width or height may extend
outside of the boundary region.

Fit Boundary Height - The incoming image’s height is scaled such that it
matches the boundary region’s height. The image’s width is then also
proportionally scaled to maintain aspect. This mode guarantees the image
will fill the boundary region height.

Fit Boundary Width - The incoming image’s width is scaled such that it
matches the boundary region’s width. The image’s height is then also
proportionally scaled to maintain aspect. This mode guarantees the image
will fill the boundary region width.

The below example demonstrates the results of a rectangular image (left) replacing a
square image (right).

Left: Sports logo native size, Right: Replaceable white square image native size
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Resize geometry on texture change -
Unchecked

Logo scaled to fit the white square image’s native size

Resize geometry on texture change -
Resize to new texture size

Logo scaled to its native size

Resize to boundary parameters -
Fill boundary

Logo resized to fill the blue boundary
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Resize to boundary parameters -
Fit boundary

Logo resized to fit within boundary

Resize to boundary parameters -
Fit boundary Height

Image resized to fit within boundary height

Resize to boundary parameters -
Fit boundary Width

Image resized to fit within boundary width

Actual Size Is the pixel dimensions of the unscaled image.
Scaled Size displays the amount of scaling applied if scaling has occurred.
Pixel Aspect This option can compensate for the difference between the square-shaped
pixels in an image and rectangular pixels used by the Lyric application. If 1:1 Pixel Aspect
for Graphics Import option is active the original appearance of the imported object is been
preserved. The global setting is found in Config > Canvas and Channel Settings > Use 1:1
Pixel Aspect for Graphics import.
e [f enabled in Canvas Resolution, Pixel Aspect is set at 1:1 - meaning no
compensation is applied.
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e If disabled in Canvas Resolution, Pixel Aspect applies compensation based on the
current screen resolution.
The setting can also be adjusted retrospectively by adjusting the setting between 1.000 and
0.900 where 0.900 is the compensation value.

DB Link/Metadata

See DBIlinking and Metadata. Metadata allows access to metadata which may exist within
the file of the 2D object in use. The Metadata button only appears if the selected image
contains Metadata. See Lyric's XMP Facility for more information

Best Practices
e Even though Lyric can import .psd files with respective layering this is generally not
the most efficient option for image files. Better formats include .png files and .tga
files.
e Tifs and .jpgs support Metadata functionalities with .tifs having the added benefit of
also carrying alpha information.
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Media

Animation files can be imported into a Lyric scene as Movie/Media objects. As the Movie
object plays its own animation, it can be moved, scaled and transformed through 3D space.
Imported Movie objects require access to the source file(s), they are not embedded in the
message when saved.

Importing a Media Object

1. From the Tools menu, select Media or click the H icon from the Scene Objects
toolbar

2. Navigate to and select a Media file (*.avi, *.mov), AVI (*.avi) or Quicktime (*.mov)
file. Click Open.

Supported Files
24-bit or higher Media file, AVI (*.avi), Quicktime (*.mov) file, mp4 (*.mp4)

Important: FFmpeg playback and FFmpeg (3.0) software must be installed. All Video for
Windows (VFW) CODECS loaded in Windows are supported. Any animation file that uses
compression will need to also have the necessary codecs installed on the system to ensure
playback.

Audio output is supported for QuickTime movies with 16-bit, 48Khz and mp4 with 44.1
bitrate (with FFmpeg version (2.2.23)). When Media files with supported audio are added to
a Lyric message the audio will play to the SDI output.

Alpha support for Media files
.avi files affords two options for keying.

1. 32-bit uncompressed .avi movie files containing alpha/key information can be
imported into Lyric compositions.

2. A separate .avi file can be used to represent a movie's matte channel (key
information). The naming convention is Name.avi for the video channel file and
Name.matte.avi for the matte channel file. The matte file is loaded automatically
when a "regular" .avi file with a "matching” name is manually selected and loaded.

32-bit Quicktime movies may contain alpha information for keying. Upon loading, Lyric
automatically distinguishes between 24-bit and 32-bit Quicktime files.
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General

' Media > Media--Paperd_Brown_out.avi

4Node Info

MNode Name |Media--Paperd_Brown_out.

Description

4File Path

I\Chyron Tr...\Paper4_Brown_out.avi | ..

4File Info

Size H 170 W 500
Bit Depth 32-bit

Video Rate 29.97 fps

Audio Rate  N/A

Channels MN/A
Fields Mot Reported
Codec raw video

Pixel Format bgra

4 Geometry
[[] Resize geometry on texture change

Boundary W 500 = H 170

Fit boundary

Actual Size H 170 W 500

Scaled S5ize  H 170.000 W 500.000

4lmport
Auto Trim
4Playback
Field Setting | Progressive(None) v

[] 1gnore Pauses Loop

. 00:00:00.00 =
In Loop Point Out
00:00:00.00 00:00:00.00 00:00:00.29

4Data

DB Linking
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Node Info

e Node Name is the node name as represented in the Scene Graph.

e Node Description is entered here.
Both Node Name and Description can be utilized by additional Lyric features including
Inherit State and Conditional Transitions.

File Path

This displays the file path of the Media file and allows for browsing via E] to replace.

File Info
Displays all relevant file information including; Size in pixels, Bit Depth, Video Rate in
Frames per second, Audio Rate in Htz, Channels, Fields, and Codec.

Geometry
Resize geometry on texture change
Go to image properties for more information on this feature

Import

Audio Extract when checked plays audio to the SDI output. See Supported Files for
information on supported Audio file types

Auto Trim when checked trims the Media file on update to the respect the length of the
existing Media node on the timeline. When unchecked the Media file will adjust the node on
the timeline to match the native duration of the incoming Media file

Playback

Field Setting allows for switchable interlacing modes. Filtering the dominant field for Media
interlacing allows the the best possible playout results required for the media file(s) you are
using. The selectable options are Progressive(None), Upper or Lower dominance.

Ignore Pauses when checked ensures the Media file does not stop on any Pause Event
keyframes.

Loop when checked allows the file to play continuously. In, Out and a Loop Point can be set
allowing for 3 point loops.

DB Link
See DBIlinking.

Exporting a Media file

See Save As
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Flipbook

Image file sequences are imported into a Lyric composition as Flipbook animations.

Flipbooks should be reserved for quick and small file sequences only. Media files such as
.mov and .avi use less system resources, and therefore are preferred for larger sequences.
To save a Flipbook animation as a Media file see Save As

Supported Files
.bmp, .tga .tif

Importing a Flipbook
1. From the Tools menu, select Flipbook
2. Navigate to and select the first Image file in the sequence. Lyric will automatically
assume the last file (browse to adjust).

3. Click Open.
Filenames in the sequence must be the same length. E.g. Arrow_000.tga to Arrow_105.tga
A& [ FRpbook Fenmn | = |

First File:
I:'Project Folder\File Sequences‘\Arrov | Browse...

42»—'—«‘ Last File:

I:\Project Folder\File Sequences\Arrav

|j| Loop |:| Ignore Pauses
L []Embed Image Data On Save | |Play to End

[ | compress Image Data [ Field Based Render

[ o ] | conce |

Enable Loop for the Flipbook to loop the duration of the Lyric animation
Enabling Embed Image on Save saves the Flipbook image data in the Lyric
message. Disabling Embed Image on Save allows Flipbook messages to be saved
without embedded image data, in order to minimize the resulting size of the
message. However, the Flipbook images must be re-read from disk during
message Read, which increases recall time.

e Enabling Compress Image Data compresses the image texture when the Flipbook
is saved, resulting in smaller Flipbook a file. Preview this type of playback before
playing to air. When Compress is enabled, a 4:1 compression is imposed.
Compressing texture saves Read and Record time.

e Enabling Ignore Pauses allows the Flipbook animation to continue running through
a programmed Pause. If Ignore Pauses is not enabled, a Flipbook pauses at
established Pause points in animation playout. Additionally, the Play to End
checkbox becomes available. With Play to End enabled, the Flipbook plays to the
end.

e Field Based Render causes the animation to render every field
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Data Object

The Data Object is a powerful feature that binds data to objects in a Lyric Scene. The Data
Object can retrieve data at a specified interval, based on scene events or can be timeline
driven using keyframe commands. Data sources include Text, XML, RSS, Web, JSON,
Excel, Access and Google Docs. This data can also be filtered/formatted using easily
configurable options within the Data Object editor.

More information can be found in the separate Data Object User Guide.

Trigger Track

Keyframe Triggers are keyframes that trigger specific actions when the timeline passes
them.

A keyframe trigger can only be put on a the Trigger Track Object, which is added to the
scene from the Tools menu or toolbar.

Actions that can be triggered are:

e Pause

e GPI Out

e Transition in same scene

e Transitions in a different scene that is currently on output

e Transition of a scene that is currently on output of another Lyric Device
e Macro

e Update of DB link fields

e External Connection Command

e Movie Control

Additionally, Transition triggers that are respected exclusively when a scene is saved out as
a movie file can be set also.

Adding a Trigger Track to an animation

Trigger tracks are added to the transitions of a scene in Lyric. A Trigger track must be

present at the time marker to add a Trigger keyframe.
a A single trigger keyframe can have multiple Actions defined to it. Multiple trigger
keyframes can be added to a single Trigger Track. A Trigger Track can also be added
to multiple transitions within a composition.

Trigger nodes can be made inactive in the scene graph by clicking on the checkbox beside
the trigger name and icon. When the trigger node is inactive none of the keyframe triggers
will be executed in any transition it belongs to.

Depending on the desired functionality it may be easier for operation if Trigger tracks are
added for each stage of an animation. For example, in a full screen Bullet Point reveal, the
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pause keyframes for each bullet that will appear might be each created on a different trigger
track (called Pause Releases). They would then be easily turned on and off when more or
less bullets are required.

Trigger Tracks can be added to the composition directly into they transition they are
required in, however, like all other nodes, they will be present in the default transition. If a
trigger track is required in more than one transition of a composition it can be dragged from
the scene graph into the timeline editor or if a trigger is being defined in a transition the
track is not present in, a pop-up will ask for confirmation before adding the trigger track to
the active transition.

@ "Trigger Bullet1" is not in transition "Bullet 3", Add it?
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General Properties of Trigger Tracks

The General Pane is where trigger keyframes actions are defined. It is also the location of
the Node information on the trigger track.

To display the General Properties of a Trigger Track ensure that the Trigger Track node is
selected in the Scene Graph or Timeline Editor.

Node Info

e Node Name - is the node name as represented in the Scene Graph.
e Description - Description currently has no functional use for Triggers.
General a @

Scene Properties  General | Transform | Surface |

Trigger = Triggers 1

4Mode Info
MNode Mame Triggers 1

Drescription

4 Actions

Action Type Froperties

Adding Actions

4 Actions

] Action Type Properties i
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Actions are added to the current frame of the active transition by clicking the +Add button.
This will open a list of different available actions.

Transition

Transition (SaveAs)
Transition (External)
Transition (Network)
Pause

Macro

External Connection
Conditional Transition
GPI

Update DB Link

Movie Control
Selecting an action will offer additional configuration settings directly below the Action
window. If the trigger track is not in the current transition a dialog will appear requesting
confirmation to add it to the active transition.
When an action is selected a keyframe is added to the trigger track.

Transition

Transition Triggers enable a different transition of the same message to be triggered at a
keyframe.

M

Bullet 2
Bullet 3
Bullet 4
Effect In
Effect Qut
Default

Select the desired transition from the list.

Multiple transition actions can be associated with the same keyframe of the same trigger
track by adding another Transition action and selecting another transition to be executed
simultaneously.

Transition (Save As)

Transition (Save As) is a method of directing the animation when saving to a .mov or .avi
file. They mimic the Transition Trigger above, but will only be respected when saving to a
movie file.

Intelligent transitions will not be respected (as it is not being sent to an output). Timing and
execution of all other transitions can be configured through the addition of Transition (Save
As) actions.

The Transition (Save As) will not affect the video output progression of transitions.
e Transition: Dropdown to select the internal transition to trigger.
e Time Offset: A delay to offset triggering of the selected transition.

Transition Default -

Time Ofiset  00:00:00:00 %
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Transition (External)

Transition External works in a similar way to Transition, however it will trigger a transition in
an message already playing to an output of the device.

The Transition (External) action should be configured with the Scene Description and
Transition(Name) to trigger on the external (already on output) message.

e Scene Description defines which message this trigger will react with. The external
message(s) must have a Scene Description defined. Options are ‘Exact Match’,
‘Begins With’, ‘Ends With’ or ‘Contains’. The input field is case sensitive and the
string (or portion thereof) must match the string in the description of the external
message exactly.

e Transition to Trigger defines the name of the transition on the external message
that should be executed. Options are ‘Exact Match’, ‘Begins With’, ‘Ends With’ or
‘Contains’. The input field is case sensitive and the string (or portion thereof) must
match the string exactly.

Current FB Defines if just the current FB this message is on will be queried
All FB Defines all FBs will be queried

Scene Description
Exact Match *

Transition to Trigger
Exact Match -

@ Current FB ) Al FB

A single Transition (External) action can be configured per keyframe.
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Transition (Network)

Transition (Network) Trigger Keyframe enables a message to trigger a transition on an
external message playing on a different device across the same network.

Transition Effect Out

Scene Live Bug
Host [P address]
Target FB & FB1 & FB2 @ All

‘WP address\FEALL\Live Bug\Effect Out

e Transition The name of the Transition you want to trigger in the external network
message
Scene The Scene Name of the external network message
Host Set to the IP address of the machine that will be controlled.
Target FB determines which frame buffer on the other system the command will be
sent to.

A single Transition (Network) action can be configured per keyframe.

Pause
The Pause Action is used to pause the animation of the elements in the transition currently
playing.

Type Timeout -
Phuabion 00:00:00:00 %
Ease None = bﬂ:uu:m:uﬂ_g—i

e Type - How the pause will be released, the options are:

o Keystroke - Released by pressing a key on the keyboard

o Timeout- The pause will release after a set duration.

o GPI - The pause will wait for a GPI trigger. To assign a GPI to the Pause
release the GPI hardware must be configured. Once configured the GPI
dropdown will offer the available GPIs.

e Ease - Ease In, Ease Out or Ease In/Out is defines the animation options into
and/or out from the Pause keyframe
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Playout with Pauses
When a message is in a Paused state the Playout Panel will display the animating message
in Yellow.

Frame Buffer 1

Any type of Pause (Keystroke, GPl and Timeout) can be released by pressing the yellow
button on the Playout Panel.

When a message is in a Paused state the status bar at the bottom of Lyric will display a red
Pause indicator. This will notify the user that the message is at a pause and the method
which it has been configured for release.

A single Pause action can be configured per keyframe.

When a message is at a Pause the escape key can be pressed to ignore the pause release
and any further triggers on the current transition. This is a way to cleanly stop a pause
release transition.

Macro

The Macro will execute a macro when the animation reaches the keyframe. This can be
used to query content on the output or extract a variable from the output animation for use
in other macros.

The Macro is simply typed into the text field.

Pacro text goes here

A single Macro action can be configured per keyframe.

External Connection

An external connection action enables Lyric to send a command to a configured device .
The device connection and commands are configured in the External Connection Manager
(Config > External Connection Manager).

e Connection: The device the command should be sent to.
e Command: The string that will be sent, it will be displayed in the gray field directly
below the command dropdown.

Connection Connected Device -

Command Command Mame -

This is the command string

A single External Connection action can be configured per keyframe.
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Conditional Transition

Conditional transition rules that are configured as Keyframe Triggers will execute with the
Conditional Transition Trigger. For information on configuring Conditional Transitions to be
evaluated by a keyframe trigger action see the Conditional Transition documentation.

GPI

Attach GPI triggers by selecting from dropdown menu. All configured GPI outputs will be
displayed.

DB Link

This action will update all templates/images/keyframes that are linked to a Database using
DB linking. There is nothing to be configured as it updates all DB Linked fields.

Movie Control

This action triggers specific control of media files. Including; Play, Pause, Restart, Twice
Speed and Half Speed.

Deleting Actions

Actions can be deleted by clicking on the grey X to the right of the listed action in the list. All
actions, at a particular keyframe, can be deleted by deleting the keyframe from the trigger
track. All actions associated with a trigger track can be deleted by deleting the trigger track
node from the composition.

Similar to all nodes in a scene, trigger tracks can be unchecked in the scene graph. This will
deactivate them without deleting them from the scene.
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Lights

A maximum of 6 lights can be added to Lyric messages. They can be transformed and
animated in 3D space. Lights can be Flood lighting or Spot lighting. There is one flood light
(Light 1) and one Global Light included by default on as part of every Scene. This Light 1
and any additional lights can also be adjusted or deleted, however the Global Light is
responsible for Scene visibility and therefore cannot be deleted or turned completely off.

9

From the Tools menu, select Light or click the
> Toolbars >Scene Tools)

Select a Light from the Scene Graph to adjust the General Properties (View > General
Properties)

[Cenert E

Light > Light 2

icon from the Scene Tools toolbar (View

4MNode Info

Node Mame Light 2

Description

4Type
Enable
Spot @) Flood i@

Color

Intensity
Attenuation 0 =]

Angle 0 }é_-j.

4 Per Node Lighting
[] Erable

To show the icon of the light source, simply check the desired Light in the Scene Graph. It
will not display on Output.

‘Scene Graph B

(5

YT Global Light
L@y Cameral

5 -:i

gl

Enable each light can be enabled (checked) and disabled (unchecked) in order to view its
effect on objects more clearly.

Type
Each Individual Light be set as either a Flood Light or a Spot Light.
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e Flood Lights radiate light in all directions, thus they can only be moved in XYZ and
not rotated. The attenuation and Angle are also not relevant.
e Spot Lights radiate in one direction, with variable angle and attenuation.

o Attenuation control varies the light's intensity as measured at the source
rather than at the edges of the cone-shaped area being illuminated (see
icon illustration below). A value of Zero (0) Attenuation indicates that there
will be no decrease in illumination at the edges of the illuminated area.
Values greater than zero appear to soften the illumination as it angles
outward.

o Angle varies the cone-shaped area of illumination.

e Color Click the Color tile to open a color selection dialog.
e Intensity adjusts the intensity of the Light source

Global Light

The Global Light is ambient light which comes from all directions equally, it illuminates all
objects in the scene so that they are visible. Along with the Lyric Camera, it is present in all
Lyric scenes by default and cannot be deleted. The intensity may be varied but it cannot be
completely turned off.

Per Node Lighting

When the Per Node Lighting checkbox is Enabled, a list of all nodes/objects in the scene
appears in the Included list at right. By default, every lightable node in the scene is affected
by every light source. The user can select which of the light sources affect which
nodes/objects in the scene. The selections are made for each light source; the operator
selects one light for modification, and then dictates which nodes that light illuminates, using
the Add and Remove buttons. Object Nodes shown in the Included column will be affected
by the selected light source and object nodes in the Available column will not be affected by
the selected light source

4 Per Mode Lighting

Emable
| Available || Included
30 Template 1 | aphere
|| Cube
Cone
& Add 4@ Remove
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2D objects have lighting disabled by default in their Rendering settings, so even though they
can placed in the Included column to be affected by lighting, they remain unaffected until
Lighting is Enabled via the Rendering pane

Not all types of nodes in a Lyric composition respond to lighting. "Physical' items including
3D objects, text and image regions may be noticeably illuminated, but Timeline nodes such
as Triggers have no relevance to lighting.

Video Object

The Video Object is a 3D Object that allows full raster live video to be surfaced to it and
animated as part of a scene.

The Video Object supports full frame video texture sample matching for seamless switching
between video passing through the hardware and video passing into the renderer. Please
refer to relevant hardware documentation for configuring the Video Object.

General q
Video Object > Video Object
4 MNode Info
Mode Mame  Video Object
Description
4 Geometry
Video Mode  Match Canvas -
Actual Size  H 1080 W 1920
Scaled Size H 1080 W 1920
Node Info

e Node Name is a user-defined name given to the Video Object.
e Description is a user-defined description given to the Video Object

Geometry

Video Mode will resize the Video Object specified size. Match this option to your selected
Output standard for seamless full frame video.
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Camera

The Camera establishes a viewer frame of reference, where the viewer is represented by a
Camera. All objects in the composition are seen through the Camera lens. Thus, every
Lyric message contains a Camera by default, and it can be selected via the Scene Graph.
The Camera can be repositioned, animated and its focal length adjusted.

To Adjust the Camera Settings

Select the Camera in the Scene Graph. Then, from the View menu, select General
Properties. The following window will appear:

General E

Camera > Cameral

4 Node Info
Mode Mame  Cameral
Description

4Type
i@ Free Form (&) Target

4 Projection
(@ Perspective (7} Orthographic

4 Camera Data
ROV
Aspect
Mear Clip

Far Clip 100,000

Node Info

e Node Name is a user-defined name given to the Camera.
e Description is a user-defined description of the Camera.

Type

e Free Form sets the Camera's traditional behavior, as explained above.
e In the Target mode, the Camera tracks a designated target in the Lyric composition.
The target is visible on the Lyric canvas as a blue dot.
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Projection

Perspective projection differs from Orthographic projection in that there is always a
vanishing point. As a result, objects further away from the camera position tend to
reduce in size until the Vanishing Point is reached. Adjustments in the Camera
Lens affects the viewer perception of where the Vanishing Point is located. A
Perspective projection acts as you would expect in a real 3D world. In other words,
the Camera and view of objects behave in the same manner as objects do to the
human eye.

Orthographic projection views the object as if it was placed on a 2D drawing plane
perpendicular to both the viewer and the lines of projection. An Orthographic
camera is fixed in space, and renders objects at an absolute size on a flat plane.
When Orthographic projection is selected, and rotated objects are viewed, they are
displayed as isometric projections. Camera Lens adjustments are not available
when Orthographic projection is selected.

The figure below demonstrates a rotated cube shown in Perspective mode (left) and
Orthographic mode (right). Orthographic projections can be useful for spherical
shapes that warp when positioned away from the center of the canvas.

Camera Data

FOV is only available when Perspective projection is selected. The lens control
adjusts the magnification of the Camera, and the apparent distance between the
Field of View and the objects. The range of Camera Lens adjustment is from 0
(objects are closest) to 1803 (objects are furthest away); the default value is 45.
Aspect adjusts the X value of the scene's aspect ratio, and affects the Lyric
composition both on the Canvas and Outputs. This feature will be primarily used for
making alterations to scenes imported into Lyric from other 3D composition
programs.

Near Clip/Far Clip controls the Z axis position of the Near and Far clipping planes.
Clipping planes restrict the visible and editable area of a scene. The Near clipping
plane may be thought of as a wall that may be moved into the Lyric composition
from the viewer's/Camera's position along the Z axis.
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The Far clipping plane may be thought of as a wall that may be moved toward the
viewer's/Camera's position from behind the objects in the scene, also along the Z
axis. Like the Aspect control, this feature will be primarily used for making
alterations to scenes imported into Lyric from other 3D composition programs.
Although invisible, clipping planes will obscure any element in the Lyric composition.
The figure below illustrates the effects of no clipping (left), Near clipping (middle)
and Far clipping (right).

Transforming the Camera

The camera may be panned and tilted by using the position and direction controls in the
Transform Properties. The Camera may be animated the same as any other Lyric Object.

To transform the Camera, select the Camera in the Scene Graph. Then from the View
Menu, select Transform. The following window will appear:

Transform @

Camera = Cameral

AXYZT

Position

X (0000 B ¥ 0000 B Z 0000 =
Direction

X|0.000 B Y 0000 B Z 0000 B

- -

TIP - To set different camera angles and positions, add the camera into different transitions
and adjust accordingly. By activating each transition, the composition will appear to cut
between cameras.
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3DO

Lyric is able to save an imported 3D object that has been modified with any texture
attributes added (and embedded) by the user. (For more information on working with
surface textures see View > Surface Properties). To save the 3D object with grouping,
animations and/or timelines, the object can be exported as a Lyric Node (*.Ino).

Saving a 3DO Format
1. Import a 3d Object and modify accordingly (see Import 3D Objects and Surface

Properties).
2. Right click the modified 3D Object on the Canvas.

3. Select Save As...

Color code Object L

Position Lock On

Copy Animation State

Paste Animation State

Mask Object

Soft Mask

Mask-To Layer L
Mask Inside

Alpha Trim Object

Motion Path 3
Wi o000 i

Save As...
nsole Deconstruct

Internal Properties

4. Name and Save the .3DO

Saving the user modified 3D object in ChyronHego's .3do format preserves texture data.
Textures can also be embedded on 3D surfaces when saving Lyric messages by enabling
the Embed All checkbox found in the Surface Properties. When used in another
composition, the newly created 3D object retains the textures with which it has been
"customized." The file size of a 3D object is increased when it incorporates texture data.
The preview of a customized .3do object displays its original appearance without the added
texture information.
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FBX Import

FBX files can be imported via File > Open. Animation, models, camera and lighting with the
exception of spot lights and target cameras are supported with varying results. FBX files
created in Cinema 4D have the best results.

Color Palette

Color selection is available for various Lyric nodes by clicking on the color chip in the
respective pane.

Color Select also allows for setting ramps or gradients as well as accessing and creating
color palettes

Color Select
Below are just two examples of ways to access the Color Select Dialog.

Select 2D Text. View > Font Styles, right click the Fill color chip, select Solid/Ramp Color.

4 Edge o [ @

T || Solid/Ramp Color N

i

Graphic File

Blur ] EI

Opacty 100 [

Apply to Selection |

Select 3D Text, View > Surfaces, Left Click Add Texture, Select Color/Ramp.
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3D Text can also be colored via the Material Color Chip. This method by comparison does

not allow for adding ramps or using palettes.

Color Select Dialog

() Ramp (@ Solid Color

Ramp [ Gradient
o

Palette 1 E"Il ity __ = Elge;
Ciet £ 10 1 1 I8
I_---I_--“E [ Hot Color Test

[AdchEaethe] [Sagepalethe...] [Pid_cUp::olor]

=)
(etroete | [rectpaens | [ mwy |

Colors can also be set by

e Entering values in the Hue, Saturation, Luminance or RGB fields.

e Use the + slider in the Color Window and the Luminosity slider.

Changes to these settings are reflected in the Color Preview Window
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Pick Up Color enables a color to be "picked up" and used as the currently selected color.
1. Click Pick Up Color. Lyric’s cursor takes on the appearance of an eyedropper.
2. Click on any point on the Canvas or the Ramp/Gradient window. The hot area of
this cursor is the bulb of the eye-dropper, not the tip. Click to pick up the desired
color.

Opacity can also be applied to both solid colors and individual ramp anchors

Hot Color Test tests the color for settings which fall outside of NTSC and PAL standards.
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Ramps

Color Gradients (Ramp) is available on some nodes, such as Backgrounds, 2D Text font
Styles, as a Texture Layer on 3D Text and Objects, 3D Edge borders.and Effects where
applicable.

In the Mode area, select Ramp.

[~ l
cosers SR\

Mode Color
@ Ramp i Solid Color

Ramp / Gradient
@ g o

& o | 160 255

Red:

Don't tie color to buddy P pererer
= | 0 Green: 255

Remowve anchor v
Palette 1 fm: 240  Blue: 255

el 1 | Copy anchor color
Past h I
aste anchor color
I_ - - - DHut Color Test

| AddToPalette | | Save Palette... | | Pick Up Color | E
(rriee ] (v ] [y ]

Multiple anchors can be added to the Ramp/Gradient map by right-clicking along its
borders.

The Color Anchor appears at that position, as well as at the opposing position. On creation,
the anchors are always tied to each other. To remove or untie the Anchor simply right click it
and select from the menu.

Color Palettes
There are 7 available palettes, each containing 16 colors. Palettes can be saved, recalled
and reset.

Palette colors can be accessed by clicking the desired color chip on the dialog or by
Keyboard shortcut. See Keyboard/Mouse Shortcuts for details

To add custom colors to a palette, first select the desired color chip position, set color as
desired and click Add to Palette.
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Internal Properties

Internal Properties both display and set specific properties for an object or a message. They
override default values. Internal Properties can be applied to a specific node or message.

Internal Properties will vary depending on node type. Property settings discussed here refer
to Images and Media files. This covers all properties for the various text and object types as
well as Internal Properties applied to the Scene.

Object Nodes
Select a Lyric Node, Rick Click and Select, Internal Properties
- [V
Q Lig Color code Object 3
@ Gle Position Lock On
Copy Animation State

Paste Animation State

Mask Object

Soft Mask

Mask-To Layer 3
Mask Inside

Alpha Trirn Object

Motion Path 4

Internal Properties

Image Internal Properties
Chyron.Lyricdnternal Properties =

Property Value | '
Pixel Aspect i 1

Pre-process Data Script |

Raw XMP Data |

XMP Rules |
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Pixel Aspect (2D Objects Only)

The Pixel Aspect setting determines the Pixel Aspect at which a 2D object is imported.
This option compensates for the difference between square-shaped pixels used by
Windows graphics applications and rectangular pixels used by the Lyric application.
The default pixel aspect is determined by the setting 7:1 Pixel Aspect for Graphics Import
applied in Config > Canvas and Channel Settings
e If enabled in Canvas and Channel Settings, Pixel Aspect is set at 1:1 - meaning no
compensation is applied.
e Ifdisabled in Canvas and Channel Settings, Pixel Aspect applies compensation
based on the current screen resolution.
The Pixel Aspect setting in Internal Properties can be changed for an individual 2D Object.
This setting can also be accessed via View > General Properties on the 2D Object.

e Pre-Process Data Script Displays the name of any Pre-Processed Scripts attached
to the node. Visual Basic Scripts can be attached for Pre-Processing data before
being displayed. See Pre-Processing Scripts and View > Event Properties
Raw XMP Data Displays XMP raw data in XML format for embedded images.

XMP Rules Displays data in XML format when rules are have been applied. See
XMP Metadata
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Media file Internal Properties

Displays the properties that apply specifically to Movies files. These can all be set from the
General properties pane. See Image Internal Properties above for all other property
definitions.

Chyronlyric:Intenal Properties @l
Property | Value

Movielnterlacing |0
Pixel Aspect . 1
Pre-;rocgss Data Script [
TemplateHeight 170
TemplateWidth [500

KMP Rules

e Movie Interlacing This displays the Field Setting. 0 is Progressive, 1 is Upper, 2 is
Lower. It defaults to progressive, however this setting can be written into the XMP
area of the movie so that it will import with the desired setting. This setting can be
adjusted via the Field Setting dropdown in View > General Properties

e Template Height and Width The size of the template region can be adjusted. This
is suitable for Media file replacements with varying aspects and sizes. Save and
recall message to reflect adjustments made to Template Height and Width.
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Message Internal Properties
The Internal Properties of a Scene can be accessed by Right Clicking on either Global Light
or Camera. All Internal Properties in this dialog are applied to the Scene.

Chyron.LyriczInternal Properties =y
Property Value et
Group Priority Level Mested X
Masking Mode Lyric & LI
MessageParameters FaTumnl version="1.0" enco...
Pre-process Data Script
Preview Frame -1 =
Preview Transition Default |

| Render Version 1

Rendering Mode Mormal LI
TwoPassBlendMode Standard LI
Use Group Pricrity 1 B
Use Quaternions 0

Wiew Frustum Culling ] i
#MP Rules

onRead Macro
[

Loc | [y | [conce

Group Priority Level
e Off No Group Priority is used
e Root For legacy messages only
e Nested This is the correct Group Periority level for nesting groups, i.e groups within
groups.
e Masking Mode Mask Objects may be rendered differently in legacy versions of
Lyric. Legacy Masking selections are available.

Masking Mode Lyric 8 =
MessageParameters Default
Pre-process Data Script i

Lyric&
——— I —

e Message Parameters Displays Parameters applied. See View > Parameters List
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Preview Frame The Preview Frame is the frame of an animation which displays on the
Browser thumbnail and when the animation message is read. This should be set from View
> Scene Properties. For the Preview Frame setting to be viewed on message recall, the
Show Preview Frame setting in Config Menu > CG Preferences > Show Preview Frame
must be enabled (checked).

The default setting for Preview Frame is -1, which specifies that no Preview Frame is set.

Preview Transition This is the transition to be used as the preview. The Default timeline is
set by default. This should be set in View > Scene Properties.

Rendering Mode can be set for an individual message. In addition, depending on the
system and the graphic boards, one Rendering Mode may be more suitable than another
for playback. The Rendering Modes are the same as those in View > Scene Properties.

e Default Rendering plays back animations using Lyrics normal rendering process.

e Depth (2 Pass) corrects the rendering of 2D objects, that have transparency, and
that either intersect in 3D space or that overlap. While rendering in this mode is
slightly slower, it usually unnoticeable, due to the high rendering speed of current
graphics cards. See Scene Properties > Rendering Mode for more details.

TwoPassBlendMode If 2Pass Rendering is being used it can be set to legacy or standard.

TwoPassBlendMode Standard -

Use Group Priority Lega
Iea M h

atarminnc
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Use Group Priority

The Group Priority can be either set to 1 (True) or 0 (False) priority.
e A true group priority reflects the grouped objects as they appear in the scene graph
from top to bottom
e A False group priority reflects the grouped objects as they appeared in the scene
graph before the group was created.

lllustration shows 4 numbers in the scene, with 4 having the top priority down to number 1

Scene Graph

Mame - I
....?;D 4

....:-;D 3

[, 2

@1

[Ty Light1
B

-T]88y Cameral

If 2 and 4 are grouped together the group appears at the top of the Scene Graph and
displays them over the top of 1 and 3. This is a True (1 setting) group priority setting. What
the Scene Graph displays is reflected by the Scene.

Scene Graph

-1y Lightl
-[T]% Global Light
- |@y Cameral
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When the Group Priority is set to false (0 setting), 2 and 4 now reflect the priority they had
before the group was created.

View Frustum Culling For scenes where nodes animate outside of the viewing region,
enabling this setting can improve performance. Set to 0 for off, 1 for on.

onRead Macro

Enabling onRead Macro allows a macro that is recorded with a message to execute when
the message is read. The name of the macro can be entered. A corresponding macro must
exist in the Macro Pane, View > Macros. Alternatively the macro name or script can be
embedded via the Record Only dialog box. Refer to Save with Options / Record Only >
Embedded Macros.

DB Linking

Text Templates, 2D Objects (Images and Media files), Texture Layers (3D Surfaces) and
Keyframed attributes can update from any ODBC-accessible database that is available to
the system on which Lyric is running.

In addition to DB Linking Lyric can update content via the Data Object, Intelligent Interface
and by user input using Template Update

IMPORTANT: The ODBC file must be registered with Windows to enable Lyric access.
See Registering an ODBC source outlined further in this document.

Microsoft Excel Database example:

A2 (@ £ | NEXT
|
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Lyric Message Example:

NEXT
FINANCE

DB Linking Text and Objects
Select Text Template, 2D Object (Images and Media files), View > General Properties press
DB Linking

4 Data

DB Linking

The DB Linking button for Texture Layers is found in View > Surfaces, whilst selected on
the desired layer.

Once the DB Linking button has been activated, the process of attaching a Data Link is the
same for all nodes.

The full file path must be entered in the database for 2D Objects.
1. The DB Link dialog box opens.

DB Link [
Data Source |Promo v|
Table |Sheet15 v|
Field |Gfx -]
Gfx I
Record Yo
Tite Two |
Mumeric
Decimal I.:. :
Flaces :
[ Ok ] | Cancel
= -
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2. In the Data Source field, enter the name that has been given to the database you
will be accessing. This dropdown menu can be used to select any registered
database.

3. Designate the database Table and Field from which you wish to link via the
drop-down menus. Defining Names in your document may make it easier to locate
desired cells.

DB Link R . L2 [ |
Data Source [Prornn "]
Table [ShEEtﬂ *]
Field ['I'lﬂe One v]
Record 1 Enable [V] h
[ Mumeric Template Mumber

Decimal I 0 . = |
Places z [ 2]

[ seaty | [_oc ] [ concel |

4. Designate the number of the Record. Database programs can vary in the ways they
determine the numbering scheme for their entries, so some experimentation may be
needed. For instance, the first available record in an Excel document is row 2,
therefore Lyric sees this as Record 1.

5. Be sure to check the Enable checkbox, and then click the Next Template arrows,
Apply or OK to exit.

The Green Tick on the DB linking button indicates the object is databound.

4Data

DE Linking 4"

Repeat this procedure for each desired link. The data will not be reflected immediately.

Numeric Checkbox

The display of decimal places can be controlled to force the display of trailing zeroes that
are mathematically unnecessary but desirable in many situations as a matter of style.

By enabling the Numeric checkbox and specifying the desired number of decimal places,
the data can be configured to display correctly.
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Displaying DB Linked Data
e Save and recall the message
e Set a Trigger to Update DB Link intervals (see Triggers)
e From the Edit Menu > Update DBLink fields

Disable DB link command is also available on the Edit menu, as illustrated

Disable II Fields Alt+U
Disable DELink Fields

Update DELink Fields

Update Data Object Fields

Microsoft Excel documents require the workbook to be shared if multiple users are accessing
the file. From the Excel Document, Select the Review Tab > Share Workbook.

Registering an ODBC Datasource
Databases are available in a wide variety of flavors, from complex Microsoft Access table
structures to simple Comma Separated Value files.

Registering databases via the ODBC Data source Administrator enables Chyronhego and
non-Chyronhego software to read and work with these databases.
A number of Chyronhego applications require the use of ODBC-registered databases:
e Lyric's DB Linking
e Chyronhego MOS Newsroom Solutions access Lyric assets catalogued in
ODBC-registered Lyric Browser data sources.

The ODBC datasource Administrator is used to register the datasource. It can be accessed
through Lyric or Windows

Access through Lyric: on the Browser hit Create/Select Database, then Click Advanced.
Access through Windows: From the Start button, Control Panel > Administrative tools > Data
Sources (ODBC).
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The following example shows a Microsoft Excel Datasource. Refer to Windows help for
registering other types of datasources.

1. With the The User DSN tab of the ODBC Data Source Administrator displayed.
Click Add.

= oo S e

| | User DSN | System DS | File DSN | Drivers | Tracing | Connection Pooling | About |

User Data Sources:

Mame Driver = [L]
Blection messages Microsoft Access Driver (" mdb)
= Remove
Elements Microsoft Access Driver ("mdb) U _
Excel Files Microsoft Bxcel Driver ("ads, *xd=e, * Corfigure...
forts Microsoft Access Driver ("mdb)
F5 Done Microsoft Access Driver (*.mdb)
F5 final Microsoft Access Driver (" mdb)
F5todo Microsoft Access Driver (" mdhb) i
M GT'_ - i .n.l RN .
%  An QDBC User data source stores information about how to connect to

| ==-]2|  theindicated data provider. A User data source is orlly visible to you,
and can only be used on the cument machine.

2. Highlight the entry for the required driver. Click Finish.

ot I

Select a driver for which you want to set up a data source.

MName Vers
Microsoft Access dBASE Driver (".dbf, “nde, “mdx) 14.0
Microsoft Access Drver ("mdb, ~.accdb) 140
Microsoft Access Text Driver ("hd, ~.csv) 140

Microsaft Excel Driver (s, “xdsx, “xdsm, *xdsh) 140
S0L Mative Client

SCL Server

SQL Server MNative Client 10.0

4 1 |

<Back || Finish
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3. From the ODBC Microsoft excel Setup, Name the Datasource and click Select
Workbook. Locate the Datasource and click OK to exit all windows.

-

~ W, e[ - 3
ODBC Microsoft Excel Setup (e |
Data Source Name: Promo QK
st
Database
.
Version: | Excel 12.0 - - " - .
Workbook Select Workbook l [
[ Select Workbook... ] Databass Name Directories:
Promao xdsx i-\project folder’data
oo NER y
————— = [=> Project Folder
2= Data -Help
Read Only
List Files of Type: Drives:
| Excel Files ("ds7) +| = « | Metwork..

4. The datasource is now registered and can be accessed by Lyric DB Linking

5 oo s s S e

User DSN | System DSN | File DSN | Drivers | Tracing | Connection Pooling | About |

User Data Sources:

MName Diriver = [L]
. Painted Microsoft Access Driver (" mdh) Fr—
| Painted*_D1_| Microsoft Bxcel Driver (*xds)
i PATRIOTS_NFL Microsoft Bxcel Driver (" xds) Corfigure...
Pats_PreSeason_| Microsoft Access Driver (" mdb) D
Pie Microsoft Bxcel Driver (" xds)
Premiership Football Table Microsoft Bxcel Driver (" xds)
Microsoft Excel Driver (s, *xsx, * _
h : | rFr nLa- L ) l"|| e LI P

%  An ODBC User data source stores information about how to connect to
] E the indicated data provider. A User data source is only visible to you,
— and can only be used on the cument machine.
ok ] [Cancal ][ oy |
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XMP Metadata

XMP metadata when present in Lyric supported image file formats (.jpeg and .tif), can be
utilized in Lyric Messages by automatically populating text content.

XMP Rules can also determine acceptable and unacceptable conditions within the Lyric
message, for instance, the user can allow or prohibit the replacing of elements.

Using XMP Metadata functionality within Lyric can improve speed and accuracy when
updating templates.

About XMP Metadata

Adobe's Extensible Metadata Platform (XMP) adds information to files that may be used in
the indexing, searching and retrieval of those files. Many file-types are capable of
containing XMP and other types of metadata. Not all image formats importable by Lyric are
XMP-capable, currently Lyric supports .jpeg and .tif formats. Adobe offers extensive XMP
information at http://www.adobe.com/products/xmp/.

Photoshop's File Info selection on the File menu gives access to metadata that can be
contained in a given image.

Description IPTC IPTC Extension Camera Data Video Data Audio Data Mobile SM b | v

Document Title: |SIDMEY CROSBEY
Authar: | Pittsburgh_H
Auther Title: | NHL

Description: | PITTSBURGH PENGUINS FORWARD

Rating: W Jr A W W
Description Writer:

Keywords:

(i) Semicolons or commas can be used to separate multiple values

Copyright Status: | Unknown v

Copyright Notice:
Copyright Info URL: | GoToURL.. |
Created: 10/28/2010 — 9:34:14FM Application: Adobe Photoshop CS5 Windows
Modified: 11/3/2016 — 11:52:57 AM Format: image/tiff

Preferences ] [Import... |'J | [0]4 “ Cancel
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Using Metadata in Lyric

When images are added or replaced within a composition, text within the image's metadata

can be assigned to populate and update text templates in the message.

Accessing Metadata

Select the Image, from the View Menu, select General Properties, then Click Metadata
4Data / Metadata

| DBLnking || Metadata

If the Metadata button is unavailable, Metadata is either not present or not supported for the
file type. When the metadata is in use with a template the checkmark is green.

Lyric Message Example:

SIDNEY CROSBY
PITTSBURGH PENGUINS FORWARD
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Metadata Dialog:
o scin: N ==

Object Name: NHL - CROSBY SIDNEY
Tags: Action: Parameters:

amp (hitp://ns adobe . comAaps” » Push -
- ModifyDate {21]16—11-03T'I|:

. CreatorTool {Adobe Photos [ Is Validation Rule Templates Assigned:

. MetadataDate (2016-11-02| ~ || -

- CreateDate (2010-10-28T2 LEAGUE (2)
dc (http://purl org/dc/elements/

- desecription (PITTSBURGH

= title (SIDNEY CROSBY)

- creator (Pittsburgh_H)

- format (mage Aiff) e
' T b

Add |: Remove
Rules:

Data from tag "detitle” to template "NAME (0)"

Adding Rules

Select the desired Tag and Action from the dropdown menu, then assign the desired
Template, Click Add. A Rule is inserted.

In the example illustration the data from the tag “title” is pushed into the the Template
“NAME”". The result is the text SIDNEY CROSBY is automatically populated into the NAME
template.

Actions

Action:
Fguals|

Push

Mot Equal
Cortains
Doesn't Cortain
ls One Of

e Push Places the contents of the metadata tag into the target Template,
unconditionally.

e Equals Creates the requirement that the selected tag's text content is identical to a
text string defined by the user in the Parameters field

e Not Equal Creates the requirement that the selected tag's text content does not
match the text string defined by the user in the Parameters field.
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e Contains Creates the requirement that the selected tag's text content includes text
defined by the user in the Parameters field

e Doesn’t Contain Creates the requirement that the selected tag's text content does
not include text defined by the user in the Parameters field

e Is One Of Creates the requirement that the selected tag's content is equal to one of
the text strings that is present in a Comma Separated Value (CSV) list of items. For
example: NHL, NBL, NFL

If a rule fails the conditions defined, the status bar alerts the user. The image is replaced.

Validation Rules
Validation rules MUST be valid in order for the image replacement to occur.

Action:
Equals -

|z Validation Rule

If a rule is enabled as a Validation Rule and the rule conditions are not met, the image
replacement is denied and the user is alerted via a prompt

& KMP Validation failed.
é Rule Type: Is not the same as string
Tag: AuthorsPosition, Mamespace:
http://ns.adebe.com/photoshop/1.0/
Reason: Value specified in tag matches string specified
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Example:
Metadata Actions ;‘ =
Ohject Mame: NHL - CROSBY SIDMEY
Tags: Action: Parameters:
xmpMM fhttp://ns.adobe. com - Equals - NHL
- History { g - o ;
. InstancelD fanp iid:-9A1BE; ls Validation Rule Templates Assigned:
DocumertID {amp did: C2FF NAME ()

POSITION (0
- OgialDoctmertID ap.d e — I

photoshop (http://ns.adobe. .com
- ICCProfile (Adobe RGB (15| -
- DocumentAncestors famp.c 7
- ColorMade (3)
- AuthorsPosition (MHL) £

L T 3

E Add i [ Remove ]

Rules:

Data from tag "dc title” to template "NAME (0"

Data from tag "dc:description” to template "POSITION (0)"

Data from tag "photoshop:AuthorsPostion” to template "LEAGUE (2)"

Check to see if tag "photoshop:AuthorsPosition™ is the same as "MHL" (Validation Rule)

L

In this example the data from the Tag “AuthorsPosition” must Equal “NHL”. If an image with
the respective Tag contained the Metadata “NFL” the rule fails, therefore the image is not
replaced and the above prompt appears.
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Scripting

VBScripts are used in several ways throughout Lyric. The API to Lyric is LEIF (Lyric
Extended Interface Framework). LEIF is used to create external applications to control Lyric.
The LEIF help file can be found inside the Program Folder in which Lyric is installed. The
software development kit can be requested by contacting ChyronHego. The LEIF help file
contains details on how to declare Lyric property values and functions when scripting. The
below illustration shows how to access a 2D Object file name and includes an example.

r IEI ™
&> LEIF/Macros Help for Lyric v8.x E‘_Ig

File Edit Bookmark Q-pt'rons Help
Help Topics Back | Erint Exit | €< |

P

FileName property
Applies to
2D00jElement

Declaration
property object.FileName (Filename)

Description
Gets/sets the filename, if applicable, of the image ||

Parameter Description |
Filename String. Imponrs the file given

|| Returns
Filename - String. Filename corresponding to the current image
Remarks
WBScript example to change the path to ateam logo
set obj = ActiveCanvas.Scene Element"TEAM LOGO™).Element(0)
sContents = UCase (obj filename)
‘theck the file's path for home or away and switch folder to other set
if InStr (sContents, "HOME”™) = 0 then
‘change to away
sContents = Replace (sContents, "HOME™, "AWAY™)
elseif In5tr (sContents, "AWAY™) = 0 then
sContents = Replace (sContents, "AWAY", "HOME™)
end if

obj.Filename = sContents

Lo ;

SendKeys can also be included in scripts to simulate keystrokes.
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Executing Scripts

There are several ways Scripts can be executed:
e Played from the macro pane, via a hotkey, or on message read when set to Auto
Execute.
e On Read of a message, embedded in the scene (it will execute on read or on
update of the Template Update dialog if selected)

e Triggered on a keyframe from the timeline.
e Upon update of an object with a pre-process script assigned to it.
e Via a Hotspot reaction
e Sent to Lyric from an external device via Intelligent Interface®. Refer to Intelligent
Interface.
Macro Pane

Editing, testing and playing scripts is often done in the macro pane. See Macro Pane.

On-Read

A macro script can be embedded with a Lyric file and automatically executed when the file
is read, or re-run when performing a Template Update. The macro must be embedded in the
Record Only menu for that message, which can be accessed through Ctrl + Record
(ChyronHego keyboard) or Ctrl + Minus sign (-) on the numeric keypad. See Record Only
for more details

Keyframed Trigger

When a Macro action is added to the Trigger Track > General Pane, a Macro script is
entered in the large window below. The script associated with the trigger is recorded with
the message, and will execute when the message is played and the trigger is executed. See
Triggers

Hotspots Reaction
Macros can be executed as a reaction to pressing a hotspot on a touchscreen. See
Hotspots.

Event Driven
Macro scripts can execute on update of an object via pre-processed scripts. These scripts
are attached through the Events Pane on the selected node.

Intelligent Interface - E Command
Refer to additional ChyronHego Intelligent Interface documentation for full details.
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Using SendKeys to Specify Keystrokes in a Macro Script
SendKeys simulate keystrokes and send them to the currently active window. They can be
used to execute macros utilizing keystroke shortcuts available in Lyric.

To specify a single keyboard character, use the character itself.
To represent more than one character, append each additional character to the one
preceding it.

To specify non-display characters such as Enter or Tab and keys that represent actions
rather than characters, use the codes shown below, enclosed in braces.

Keystroke Sendkey Keystroke Sendkey

Backspace {backspace}, {bs} or | Ins or Insert {ins} or {insert}
{bksp}

Break {break} Left Arrow {left}

Caps Lock {capslock} Num Lock {numlock}

Del or Delete {del} or {delete} Page Down {pgdn}

Down Arrow {down} Page Up {pgup}

End {end} Print Screen {prtsc}

Enter {enter} or ~ Right Arrow {right}

Esc {esc} Scroll Lock {scrolllock}

Help {help} Tab {tab}

Home {home} Up Arrow {up}

Brackets ([ ]) have no specialized function with SendKeys, but they must be enclosed in
braces. To specify brace characters, use {{} and {}}.
Function keys F1 through F12 are specified as {F1} through {F12}

To specify any combination of keys using Shift, Ctrl or Alt, precede the key code with one or
more of the following codes:

e Shift -+
e Ctrl-~
[ ] A|t - 0/o

To specify that any combination of Shift, Ctrl, and Alt should be held down while several
other keys are pressed, enclose the code for those keys in parentheses. For example:
To hold down the Shift key while E and C are pressed, specify +( EC).

To hold down Shift while E is pressed, followed by C without Shift, specify + EC.
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In certain situations, SendKeys may not work properly with certain Windows dialog boxes,
such as File Save and File Open. You can circumvent this problem by using a wait (0)
command after the dialog box is opened or by using the more robust LEIF api to accomplish
the same tasks. It's advisable to attempt recording your task in the macro pane.

For example, the following macro opens the Lyric Save As dialog box, and saves the
composition to a file named test:

set WshShell=CreateObject ("WScript.Shell")
WshShell. SendKeys "{F6}"

WshShell. SendKeys "%FA"

wait(0)

WshShell. SendKeys "test”

WshShell. SendKeys "{enter}"

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/


http://chyronhego.com/

() CHYRONHEGO LyricX 4.6 User Guide

Page 424

Pre-Process Data Scripting

Pre-Processing Data using a VBScript, evaluates and modifies an object's data before it is
passed to the Lyric Objects property, rendered and displayed on output.

PreProcess Data Scripts can be used on text templates, 2D text windows, images and
movies. They will execute immediately on update of the content or filepath.

Inserting Pre-Process Data Scripts
Select object. From the View Menu go to Event Properties. From the On Update Script
Processor, browse to the script file (.vbs).

The script file must be accessible on every device the scene will be loaded on. It must
reside in the configured filepath.

Ewents ' E

30 Template > Current Value

40n Update Script Processor

FontColor.vbs . [z]

On Update Pre-Processing
The advantage of attaching pre-process scripts directly to the node is that the script runs
only when that object is updated.

The Data Pre Processor will execute when screen objects are being updated from the Data
Object, Data Linking, Intelligent Interface, Alt “T”, LEIF and Continuous update.
The Data Pre Processor will NOT execute when typing in the canvas.

The Data Pre Processor will not execute if the object is being updated by another script.

Script errors are logged in the Lyric logger.
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Pre-Process Scripts can also be seen attached to the internal properties of an object. On
the Template or Object Node, right click and select Internal Properties > Pre-Process Script.
Scripts cannot be associated with an object from the internal properties. This is a reference

view only.

Color code Object
Position Lock On

Copy Animation State

I Chyron.Lyric:Internal Propa‘gei E .

Paste Animation State

Mask Object
Soft Mask

Mask-To Layer
Mask Inside
Alpha Trim Object

Motion Path

Insert Row

Delete Row

Continuous Update

Internal Properties

Property Value
Pre-process Data Script FontCelorwvbs
#MP Rules

Pre Processing Script Examples

Code Snippet

Function

PreProcessData.ltem("CurrentValue")

This stores the current value

PreProcessData.ltem("Object").Name

Use this for 2D text templates

PreProcessData.ltem("Node").Name

Use this for 3D Text and all nodes

PreProcessData.ltem("Scene").Name

Use this to get the scene name

PreProcessData.ltem("ObjectType")

Returns the object type

For all components, Object returns the appropriate Element interface as defined in LEIF and

Node returns the appropriate Node interface.

FOR MORE INFORMATION VISIT:
HTTP://[CHYRONHEGO.COM/



http://chyronhego.com/

LyricX 4.6 User Guide
Page 426

E.g. in a macro, a node interface is returned by ActiveCanvas.Scene.ActiveObject and
then adding .Element(<index>) to that to get the element interface. So for a 2D
template, Object gets you the element interface for the template and Node would
provide the node for the text window.

Code Examples :

Display Celsius Template Value as Fahrenheit
CurrentValue=PreProcessData.ltem("CurrentValue")
If isNumeric(CurrentValue) Then
CurrentValue = formatNumber(((9*CurrentValue)/5) + 32,0) & " °F"
End If
PreProcessData.ltem("CurrentValue")=CurrentValue
Add a degree symbol
PreProcessData.ltem("CurrentValue")=PreProcessData.ltem("CurrentValue") & Chr(176)
Display "Up" and "Down" in Different Colors:
CurrentValue=PreProcessData.ltem("CurrentValue")
FontTable="{\rtf1\ansi\ansicpg1252\deffO\deflang1033{\fonttbI{\fO\fswiss\fprq2\fcharsetO0 DIN
-Black;}{\f1\fswiss\fprq2\fcharsetO0 DIN-Bold,}{\f2\fswiss\fcharsetO Arial;}}{\colortbl ;\red255\
green0\blue255;\red100\green100\blue0;\red0\green256\blue0;\red126\green0\blue255;}"
Red="\cf2 \f1"
Green="\cf3 \f0"
If CurrentValue = "Up" Then

CurrentValue=Green & CurrentValue
Elself CurrentValue= "Down" Then

CurrentValue=Red & CurrentValue
End If
PreProcessData.ltem("CurrentValue")=CurrentValue
Round Number Up to a Whole Number:
CurrentValue=PreProcessData.ltem("CurrentValue")
If IsNumeric(CurrentValue) Then
CurrentValue=FormatNumber(CurrentValue,0,0)
End If
PreProcessData.ltem("CurrentValue")=CurrentValue
Display All Text as Uppercase
PreProcessData.ltem("CurrentValue")=UCase(PreProcessData.ltem("CurrentValue"))
Compare old and new data in a 3D text template to determine if it’s

changed
newValue = PreProcessData.ltem("CurrentValue")
nodeValue = PreProcessData.ltem("Node").Element(-1).text

If newValue = nodeValue Then
MsgBox "not changed"

Else
MsgBox "changed"

End If
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For hardware related topics, refer to hardware documentation.
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