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SHOUT User Guide  

1. Introduction  

Chyron’s SHOUT application aggregates posts from multiple user defined social media services, such as Twitter, 
Facebook, Instagram, RSS feeds, and Mass Relevance streams. These posts can be moderated by the SHOUT 
operator and output to a Chyron playout system. A wide variety of filters and search criteria may be applied by 
the operator to manage the content and appearance of posts that reach Air/production output. SHOUT operates 
on any Windows machine and can control Chyron’s Channel Box platform or any system running Lyric software, 
such as HyperX or LEX.  

Alternately, SHOUT-produced content may be output to a file for use in editing sessions and other post-
production operations. 

Moderation options include creation of multiple, application-wide moderator messages, which appear as 
customized posts. 

SHOUT’s main window is seen in Figure 1. The window consists of five menus and two buttons: 

 The File menu allows the operator to add, import, and close tabs, as well as exit the application. 

 The Edit menu allows the operator to edit, move, and delete posts. 

 The View menu allows the operator to refresh the tabs, view the available requests, and view the logs. 

 The Tools menu allows the operator to enter the Global Preferences, the Tab Settings for the current tab, 
and the Device Manager. 

 The Help menu provides information about the application and its licensing agreement, as well as the ability 
to activate and deactivate license keys. This user guide can also be found in the Help menu. 

 The Add Tab button allows the operator to add a new tab. 

 The Refresh All button allows the operator to refresh all the tabs at once. 

Where an information icon  appears on the interface, additional information about the feature with which 
you are working is available. Help text will appear upon mouse-hover.  

 

Figure 1. SHOUT main window 



 

2 

2. SHOUT’s Global Preferences 

SHOUT’s global preferences consist of application-wide settings that affect all of the tabs. The Global 
Preferences dialog can be launched from the Preferences menu item under Tools. The Global Preferences dialog 
contains ten sections: Accounts, Search, Filter Out, Find and Replace, Playback, Logos, GPI, Appearance, 
Language, and Internet.  

2.1. Accounts 

The Accounts section of the global preferences is used to add, remove, and authenticate different social media 
accounts that can be used in various tabs. SHOUT currently supports the following social media data sources: 
Twitter, Twitter Lists, Facebook, Facebook Pages, RSS Feeds, YouToo Feed, Mass Relevance Streams, SHOUT 
Tabs and Instagram Accounts. 

 

 

Figure 2. Accounts preferences and the available social media account types 

To add an account, use the Add                dropdown to select the desired account type. Depending on the 
account type, the operator will be prompted for information associated with that account. To authenticate an 
account at a later time, select it from the list, and click the Authenticate button. To remove an account, select it 
from the list, and click the Remove button. Multiple accounts may be authenticated or removed at once by 
selecting multiple accounts and taking the desired action. 

2.1.1. Adding a Twitter Account 

1. To add a Twitter account, select Twitter from the Add dropdown.  

 

Figure 3. Username of the Twitter account being added 
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2. In the Account Credentials dialog, enter the username associated with the account. 

3. Click OK. The Authorize Account windows seen in Figure 4 will appear, presenting the opportunity to 

authenticate your account.  

Twitter accounts are required to be authenticated in order for SHOUT to properly refresh any data sources that 
are using that account as a parent authenticator. This means that you must add at least one authenticated 
Twitter account in order to properly download posts and images from Twitter lists and search terms. 

To authenticate your Twitter account: 

4. Enter your username and password and click “Authorize app.”  

5. Once logged in, you will be prompted with a PIN number. This number is automatically copied into the 

text box seen at right in Figure 4. 

6. Verify that the pin numbers match and click the OK button to complete the authentication process.  

 

Figure 4. Authorization for using SHOUT with a Twitter account 

 

2.1.2. Adding a Twitter List 
 

Twitter lists can also be used in SHOUT as data sources.  

To add a Twitter list: 

1. Select Twitter List from the Add dropdown.  

2. Type in the full URL of the list or the List Owner and List Name, as seen in Figure 5. Note that the          

List Owner and List Name must be entered exactly as registered.  

3. Select the parent account that this list will be authenticated under. 

4. Press OK. 
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If no authenticated Twitter accounts exist, the Add dropdown’s Twitter List selection will be disabled until one is 
added. 

 

  

Figure 5. On the left, a Twitter list added by entering URL.  
On the right, a Twitter list added by entering List Owner and List Name. 

2.1.3. Adding a Facebook Account 
 

Adding a Facebook account is similar to adding a Twitter account: 

1. Select the Facebook item from the Add dropdown. 

2. In the Account Credentials dialog, enter the username associated with the Facebook account. 

3. Press OK. 

 

Figure 6. Username of the Facebook account being added 

Next, you will have the option to authenticate the account. Like Twitter accounts, Facebook accounts must be 
authenticated to work with SHOUT. If an unauthenticated Facebook account is added to a tab, it will fail to 
retrieve its posts.  

To authenticate a Facebook account: 

4. Enter the account’s Email and Password as seen in Figure 7. 

5. Press Log In. 

6. Press Go to App. (Also, note the Terms of Service and the Privacy Policy links at the bottom of this page.) 

See Figure 8.  

7. Press Allow as seen in Figure 9. 

8. The Facebook Authentication window will automatically close. 
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Figure 7. Facebook account authentication process, Steps 4 and 5 

 

 

Figure 8. Facebook account authentication process, Step 6 
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Figure 9. Facebook account authentication process, Step 7 

When authenticating a Facebook account, SHOUT receives an access token from Facebook that gives SHOUT 
permission to access the account’s data. In some cases, the access token may expire after approximately 60 
days. At that point, the account will need to be re-authenticated. If a refresh fails due to an expired or invalid 
access token, SHOUT will display a notification (Figure 10) at the top of the window to alert the operator. The 
operator can click the label link to authenticate the accounts, or close the notification using the X on the right. 
Once the notification is closed, it will not reshow for those accounts.  The notification will automatically hide 
after those accounts have been re-authenticated. 

 

Figure 10. Expired or invalid Facebook access token notification 
 

2.1.4. Adding a Facebook Page 
 

Facebook pages can also be used in SHOUT as data sources.  

To add a Facebook page: 

1. Select the Facebook Page item from the Add dropdown.  

2. Type in the name of the page (in this example, “chyronmelville”). 

3. Select the parent account under which this page will be authenticated. 

4. Press OK. 
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If no authenticated Facebook accounts exist, the Add dropdown’s Facebook Page selection will be disabled until 
one is added. If a Facebook account is removed after a Facebook page is added, the Facebook page may still 
remain authenticated unless the account owner manually removes the SHOUT application from their Facebook 
settings. 

 

Figure 11. Name of the Facebook page being added 

2.1.5. Adding an RSS Feed 
 

SHOUT also supports RSS feeds as data sources. The RSS feeds must conform to the RSS Specifications. 

To add an RSS feed: 

1. Select the RSS Feed item from the Add dropdown. 

2. Enter the URL for the RSS feed. The Title and Description of the feed will fill in automatically if the URL 

contains a valid RSS feed. The Name of the RSS feed will only fill out automatically if it does not contain a 

custom name. 

3. Optional: Customize the Name of the RSS feed. This is used by SHOUT to uniquely identify the RSS feed. 

4. Press OK. 

 

Figure 12. Adding a valid RSS feed 

If the URL entered contains an invalid RSS feed, an error will be indicated and the text in the Title and 
Description fields will be automatically removed. If the text in the Name field was not customized, then it will 
also be removed.  
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Figure 13. Invalid RSS feed URL entered 

An RSS feed can be invalid for the following reasons: 

 The URL entered is in an invalid format 

 The URL entered does not exist 

 The URL entered does not contain an RSS feed 

 The URL entered contains an RSS feed that does not conform to the RSS Specifications 

See “RSS Sample.xml” file in the installation directory for more information on how to format your RSS feed. 

2.1.6. Adding a Mass Relevance Stream 
 

SHOUT also supports Mass Relevance’s public streams as data sources.  

Mass Relevance aggregates posts from multiple social media services, such as Twitter and Facebook, into one 
stream. Therefore, the posts that populate the input and output lists from a Mass Relevance stream will be 
marked with an icon (see page 36) depending on their original source.  

To add a Mass Relevance stream: 

1. Select the Mass Relevance item from the Add dropdown. 

2. Enter the stream’s owner (this is typically your account name) and the stream’s name. 

3. Press OK. 

 

Figure 14. Adding a Mass Relevance stream 

2.1.7. Adding an Instagram Account 

Adding an Instagram account is similar to adding a Facebook account: 

1. Select the Instagram item from the Add dropdown. 

2. In the Account Credentials dialog, enter the username associated with the Instagram account. 

3. Press OK. 
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Figure 15. Username of the Instagram account being added 

Next, you will have the option to authenticate the account. Like Facebook and Twitter accounts, Instagram 
accounts must be authenticated to work with SHOUT. If an unauthenticated Instagram account is added to a 
tab, it will fail to retrieve its posts.  

To authenticate an Instagram account: 

4. Enter the account’s Username and Password as seen in Figure 16.Figure 7 

5. Press Log In. 

6. Press Authorize as seen in Figure 17. 

7. The Instagram Authentication window will automatically close. 

  

Figure 16. Instagram account authentication process, Steps 4 and 5 
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Figure 17. Instagram account authentication process, Step 6 

 

Note 

In order for Instagram search terms to work, there must be at least one authenticated Instagram account. 

 

 

2.1.8. Adding a YouToo Feed 
 

SHOUT also supports YouToo feeds as data sources. YouToo feeds work like RSS feeds and must conform to the 
RSS Specifications.  

NOTE: For more information on how YouToo feeds work with SHOUT and additional templates with polling 
capabilities, please contact YouToo Tech Support at http://www.youtootech.com/bgintegration.  

To add a YouToo feed: 

1. Select the YouToo item from the Add dropdown. 

2. Enter the URL for the YouToo feed. The Title and Description of the feed will fill in automatically if the 

URL contains a valid RSS feed. The Name of the YouToo feed will only fill out automatically if it does not 

contain a custom name. 

3. Optional: Customize the Name of the YouToo feed. This is used by SHOUT to uniquely identify the 

YouToo feed. 

4. Press OK. 

http://www.youtootech.com/bgintegration
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Figure 18. Adding a valid RSS feed 

If the URL entered contains an invalid RSS feed, an error will be indicated and the text in the Title and 
Description fields will be automatically removed. If the text in the Name field was not customized, then it will 
also be removed.  

 

Figure 19. Invalid RSS feed URL entered 

An RSS feed can be invalid for the following reasons: 

 The URL entered is in an invalid format 

 The URL entered does not exist 

 The URL entered does not contain an RSS feed 

 The URL entered contains an RSS feed that does not conform to the RSS Specifications 

2.1.9. Adding a SHOUT output 

SHOUT supports adding outputs from other tabs as data sources. This enables users the ability to create multiple 
topic specific tabs and then aggregate them into one. Note that the search functionality also supports searching 
other tabs’ output posts. To add a SHOUT tab as a data source, simply select SHOUT tab from the add account 
drop down and select the desired tab. 

 

Figure 20. Select Shout Tab dialog 
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2.2. Search 

The Search section of the global preferences (Figure 21) is used to add, edit, and remove different Instagram, 
Facebook, SHOUT Tab and Twitter search terms that can be used in various tabs.  

To add a new search term, click the Add button and start typing. Various Twitter search operators can be used 
concurrently to retrieve desired results. To view a list of these search operators, hover over the blue question 
mark, circled, in the top right corner. To edit a search term, double click it or select it and press the Edit button. 
To remove search terms, select them and click the Remove button.  

SHOUT tab search terms search other tabs’ output posts and aggregate them into one input data source. SHOUT 
will attempt to match on text occurrences in the post’s message. It will also attempt to match on exact 
usernames. This enables the ability to aggregate all posts from a specific user into one data source. 

Note: There must be at least one authenticated Twitter account (see Section 2.1.1, “Adding a Twitter Account”, 
page 2) for Twitter search terms to refresh properly and at least one authenticated Instagram account for 
Instagram search terms to refresh properly. Some Facebook search terms will refresh without an authenticated 
Facebook account, but it is recommended to authenticate at least one Facebook account for better results. 

 

Figure 21. Editing, adding and removing search terms. 

2.3. Filter Out 

The Filter Out section of the global preferences is used for defining words and phrases whose appearance will 
cause automatic exclusion of  incoming posts in which they are contained.  

Unlike the Find and Replace feature described below, this feature will completely hide the post from the 
operator. Adding, removing, and editing words in the Filter Out section work similarly to the same tasks in the 
Search section.  

The Filter Out feature removes input posts that were added before and after a new filter word is added. If a 
filter word is removed from the list, any previously filtered posts may be visible to the operator again. This 
feature will look at both the post’s username and message to determine if that post should be excluded. Thus, 
the operator can exclude all posts by a specific user by adding their username as a Filter word.  
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Figure 22. Editing, adding and removing filters 

2.4. Find and Replace 

The Find and Replace section of the global preferences is used for defining words and phrases that will be 
automatically replaced with new text. Adding and removing new terms works in the same way as the Filter Out 
and Search sections do.  

To edit a Find and Replace term, select it from the list of terms and enter the new text into the provided text 
boxes. Similar to the Filter function, the Find and Replace function will replace text in input posts that were 
added before and after a new term is added. However, unlike the Filter function, the Find and Replace function 
does not restore previous text when a term is removed. To remove a word or a phrase from a post, leave the 
Replace column empty. 

 

Figure 23. Setting Find and Replace terms 
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2.5. Playback 

The Playback section of the global preferences is used for defining various settings that affect playback on all 
tabs.  

 

Figure 24. Global playback preferences 

The Playback section allows the operator to do the following: 

 Toggle the tab’s layout between:   
o Moderator And Playback – The normal default view of the input and output lists with the 

playback controls in the top right corner. This option is selected by default. 
o Moderator Only – The normal default view of the input and output lists without the playback 

controls in the top right corner. This option is forced for evaluation copies. 
o Playback Only – This view replaces the input list with large playback controls and removes the 

playback controls from the top right corner.  

 

Figure 25. SHOUT’s User Interface when the Tab Layout option is set to Playback Only. 
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 Determine whether all outgoing posts will use the default image (with the exception of moderator 
messages). 

 Select the Image Repository. This folder is the centralized location for Shout’s images. This folder can be 
set to a remote location to improve performance when sharing tabs across multiple instances. 

 Download high resolution avatars using the Download Large Images checkbox. 

 Select how long images will remain in the image repository. This option defaults to 48 hours. This option 
should be set to a low value to maintain a low image repository disk usage. 

 Select the destination folder for output images that are sent to a playout device. This location must be 
accessible by both SHOUT and the playout device. 

 Select a default image that will be used for incoming posts with no image and outgoing posts that use 
the Application Default image. This option has been moved to the tab’s output setting. Values selected 
here will be used as the defaults for new tabs.  
Define the size of the output images that will be used for playback. SHOUT will automatically save the 
images at this size, rescaling when necessary. 

2.6. Logos 

The Logos section of the global preferences allows the operator to define social media-specific logos. Similar to a 
user’s profile image (<image> format tag), these logos can be used to update fields in a scene using the <logo> 
format tag. SHOUT will automatically create a default logo for each social media data source type, as well as a 
default logo for moderator messages. These default logos will only be created once by SHOUT. The operator can 
hover over the icon for a better preview of the logo. The specified location of each logo must be valid and can 
exist anywhere on the system that is running SHOUT. This will ensure that SHOUT can properly save the images 
into the tab’s output image location (see Section 3.3, Output Settings) for playback. 

   

Figure 26. Social media specific logos and the hover-over popup preview 

2.7. GPI 

The GPI section of the global preferences is used for setting up and enabling GPI controls through a serial port. 
The operator can control SHOUT by sending Load, Play and Stop commands to the tab which has focus. The 
operator has the ability to select which serial port will be used and the bounce time between similar commands. 
In addition, the operator can also select to automatically enable GPI control on application startup.  
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Figure 27. GPI settings  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

When GPI control is enabled, there will be a serial port icon in the bottom right corner of the main window. The 
tooltip for this icon shows which port is currently being used.  

 

Figure 28. GPI indicator in the bottom right corner of the main window 

 

2.8. Appearance 

The Appearance section of the global preferences is used for customizing the styles of both the Input and the 
Output lists. For each list, the operator can customize the background color, the text’s color, the text’s font type, 
size, and style, and the number of lines per post. Changing the font of the Input list will also change the font of 
the textbox in the Edit Post dialog. The Reset to Default button does not reset the number of lines per post. 

The operator can change the text and back color of special output posts, such as moderator messages, on air 
posts, and cued posts, to match their preferences. In addition, the operator can customize the tab header’s font 
type, size, and style. 

Pin # Command 

1 Load/Reload – CD (Carrier Detect) 

6 Play – DSR (Data Set Ready) 

8 Stop – CTS (Clear to Send) 
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Figure 29. Font type and size, text color and background color selections 

2.9. Language 

The Language section of the global preferences is used for manually selecting the language of the application. 
SHOUT currently supports twelve different languages: Arabic, German, English, Spanish, French, Hebrew, Hindi, 
Italian, Japanese, Korean, Portuguese and Russian. The operator can either select a specific language or have 
SHOUT use the current system language. The Use System Language option is selected by default. 

NOTE: SHOUT must be restarted for language changes to take effect.  

 

Figure 30. Language selection screen with Use System Language selected 

2.10. Internet 

The Internet section of the global preferences is used for putting SHOUT in offline mode and configuring SHOUT 
to use a proxy server.  
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When offline mode is enabled, SHOUT will not attempt to perform any operations that require the internet. 
These operations include: 

 Authenticating new and existing accounts. 

 Downloading new posts for accounts and search terms. 

 Downloading images for existing posts. 

An icon symbolizing whether SHOUT is or is not in offline mode can be found on the bottom right corner of the 
main window. 

                                        

Figure 31. On the left, Offline mode is disabled. On the right, Offline mode is enabled. 

SHOUT can also be set up to use a proxy server when retrieving data from the internet. The use of a proxy server 
is disabled by default.  

To disable the proxy server, select DO NOT use a proxy server. To enable the proxy server and use the settings 
found in Internet Explorer, select Use the proxy server settings from Internet Explorer. To enable and use a 
custom server, select Use a custom proxy server and enter in the address and port of the server. If the server 
requires authentication credentials, enter them into the username and password fields. 

Note: If the Use the proxy server settings from Internet Explorer option is selected and no server information is 
entered into Internet Explorer, then no proxy server will be used. Similarly, if the Use a custom proxy server 
option is selected and no server information is entered, then no proxy server will be used. However, if invalid 
server information is entered, SHOUT will fail to refresh.  

 

Figure 32. Internet section with Offline mode disabled and a custom proxy server 
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3. New Tab Wizard 

In SHOUT operation, the term “Tab” refers to a pool of posts that will be moderated and sent to a playout 
device. As many tabs as needed may be created, each connected to and controlling a different device. 

Note that any one tab can control only one playout device.    

Multiple tabs may contain the same posts, but each tab operates independently of the others. 

After configuring the global settings, the next step necessary to start using SHOUT is to start adding new tabs.  

To open the New Tab Wizard and to add a new tab, select the Add Tab menu item under the File menu, or click 
the Add Tab button on the main window.  

From the New Tab Wizard, you can configure a new tab in its entirety. The wizard is split up into four categories: 
General, Input, Output, and Playback.  

3.1. General Settings 

  

Figure 33. General settings, New Tab Wizard 

 Name: This is the unique name of the new tab. Note: Unless the folder name has been manually changed, 
changing the name of a new tab will automatically update its folder location. 

 Location: This is the working directory of the new tab. All the configuration files that are associated with this 
tab can be found here. This location needs to be accessible by all the systems that are going to moderate 
this tab. 
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 Direct to Air mode: When this option is enabled, all newly downloaded posts will automatically be added to 
the output list. Only use this option if you trust your data sources. 

 Download new posts when output drops below (X) posts: This option can only be enabled if Direct to Air 
mode is enabled. The option automatically causes the tab to refresh when the output post count drops 
below the specified limit (X). Note: Only one auto-refresh option can be enabled at a time. 

 Download new posts every (X) seconds: When this option is enabled, the tab will automatically refresh 
itself every X seconds, where X is the specified number of seconds between refreshes. Note: Only one auto-
refresh option can be enabled at a time. 

 Download only the latest (X) posts: This option allows the operator to define how many posts should be 
downloaded per account or search term during a refresh. The maximum value is 100. 

 Only keep the latest (X) incoming posts: This option places a throttle on the maximum number of posts (X) 
that can be in the incoming list at any given time. SHOUT will automatically remove the oldest posts when 
this throttle is reached. The maximum value is 2000. Note: The output list is automatically throttled at 1000 
posts. 

 Download only (X) statuses per Facebook account: This option only applies to Facebook accounts and 
pages. It specifies how many of the account’s newest statuses should be converted to lists. When a status is 
converted to a list, it will have its own item in the Search drop down on the main window and the comments 
for that status will be downloaded as posts. The maximum value is 25. 

 Remove URLs from posts that are moved to output: This option automatically removes URLs from posts 
when they are moved to the output list. This option does not affect posts that are added using Direct to Air 
mode. 

 Restore URLs for posts that are moved back to input: This option automatically restores URLs to posts that 
are moved back to the input list. This option can only be enabled if the Remove URLs from posts that are 
moved to output option is enabled. 

 Show refresh controls on toolbar: Allows the operator to show or hide the Auto-refresh after (X) seconds 
and the Download only the latest (X) posts options on the tab’s toolbar, which are accessible from the main 
window. 

 Show the post’s time instead of the time elapsed: Allows the operator to show the time of the posts, rather 
than the time since the post was created. 

 Show character count: Allows the operator to show/hide the character count of posts in both the Input and 
Output lists. 

 Show play count: Allows the operator to show/hide the play count of posts in both the Input and Output 
lists. Note: Play count will only display in the Input list for posts that have been played at least once. 

 Hide post images/videos: Allows the operator to disable the preview of images/videos that are attached to 

posts. If this option is enabled, a camera icon ( ) will appear next to the username to indicate that this post 
contains an image. 

 Only show posts containing Post Images/Videos: When this option is checked, only posts that contain Post 
Images/Videos will be displayed. 

 Show the posts owner’s name dropdown: Allows the operator to determine if post owners’ usernames, real 
names or both should be visible in the header portion of each post. 
 
 

  

Figure 34. Example post with character count and play count enabled. 
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3.2. Input Settings 

 

Figure 35. Input Settings on New Tab Wizard 

 Allows the operator to select which accounts and search terms will be used to retrieve posts.  

 The operator can add and remove accounts and search terms directly from this portion of the wizard. 

 To select an account, click the checkbox next to the desired item. 

 To select a search term, click the data source icon(s) next to the desired item. The same search term can be 
used in multiple data sources (see the #chyron item in Figure 35). 

 Multiple accounts and search terms can be selected per tab. 

3.3. Output Settings 

The two Scene Types offered at the top of this dialog enable different options for formatting posts. See Figure 
36 and Figure 37. 

 Scene type: Allows the operator to define the scene type with which the output will be used. 

 Data output: Allows the operator to define the output file type (Txt or Xml), as well as the tab’s output 
image location. The output image location must be accessible by both SHOUT and the playout device. Note: 
Different scene types using the same file type will format the data differently. 

 Maintain Aspect of Post Images: Allows the operator to maintain the aspect ratio of post images by 
specifying the Width and Height of the image object in the scene. When this option is enabled, post images 
will be rescaled to fit into the given size while maintaining their aspect ratio. Images that are smaller than 
the given size will not be scaled up. Instead, they will be inserted into an image that has the same aspect 
ratio as the given size by surrounding the original image with empty pixels.  

Format tags are used in both page and crawl scenes and they are replaced with the post’s content during 
playback. Available format tags are listed in the table that follows: 
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Tag Value definition 

<username> The username of the post’s owner. 

<realname> The real name of the post’s owner. 

<message> The message belonging to the post. 

<date> The date the post was originally created. 

<time> The time the post was originally created. 

<elapsed> The elapsed time since the post was originally created. (e.g. 5 minutes ago) 

<image> The avatar belonging to the post’s owner. 

<logo> The social media logo defined in the Logos section of Preferences. See Section 2.6. 

<postimage> The image attached to a post. Note: not all posts may have an image attached to them. 

<postvideo> The video attached to a post. Note: Supports Instagram videos only and not all posts 
may have a video attached them.  

 

3.3.1. Crawl 

This setting places viewer and moderator messages in a traditional animated movement across the screen. 

Format and Style: This is only used with a Crawl scene type. It allows the operator to define the output format 
for the posts. From here, the operator can select from a number of tags that will be replaced with the post’s 
content. The operator can format the message using color, bold, italic, and underline font properties. The 
operator can also define the number of pixels by which to offset images on the Y-axis. In addition, the operator 
has the ability to disable the use of RTF tags and send the post’s content in plain text. This means that the 
formatting of the crawl will be inherited from the scene itself. For post tags, hover over the blue question mark.   
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Figure 36. Output settings, configured for the scene type Crawl.  

3.3.2. Page 

Page scenes typically populate a lower-third text window, or in rare instances, a full-screen template, with 
SHOUT content. 

Columns: This is only used with a Page scene type. It allows the operator to define the name of the objects in 
the scene that will be updated, and what part of the post’s content will update those objects. The Name column 
is the name of the object in the scene, and the Format column is the data that will update that object. For post 
tags, hover over the blue question mark.  

Example 

There are four rows in Figure 37: Username, Message, Image and Time Elapsed. This means that the scene to be 
used with this tab must have three updatable text objects and one updatable image object. The names of these 
four objects must correspond to the names provided in the Name column. Each of these objects will be updated 
with the translated text found in their respective Format column. The format column can contain plain text, as 
well as format tags. For instance, Username contains @<username>, this means that every time the Username 
text object is updated in the scene, it will contain the @ symbol followed by the post owner’s username.  
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Figure 37. Output settings configured for the scene type Page.  In this type of scene, formatting and style 
are dictated by the scene originally composed in Lyric or Channel Box.  

As mentioned above, the overall design of a page scene is initially created in Lyric or Channel Box composition 
software. However, fine detail regarding SHOUT column content (the poster’s name or pre-set alias, in-line 
image substitutions, etc.) can be adjusted in the Columns section of the Page tab dialog seen in Figure 37. 
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3.4. Playback Settings 

Basic device settings and playback options are established in this dialog.  

 

Figure 38. Sample Playback settings dialog. In this example, Channel Box operation has been selected. 

 Scene Type: Discussed in Section 3.3. 

 Playback Controls: Allows the operator to connect to either a Channel Box or Lyric device, and set up the 
necessary information needed for playback. Note: For either Channel Box or Lyric device operation, 
encoding of communication between SHOUT and your hardware system must match. Read on. 

 Device Specific Options: Allows the operator to configure device-specific options for Channel Box or Lyric 
devices (HyperX, LEX). Depending on the selected device, different playback control options become 
available on this dialog. Refer to Section 6 for details on Channel Box operation, and Section 7 for Lyric 
operation. Details in these sections include hardware communication and encoding settings. 

 The Posts Per Page is available for both Channel Box and Lyric devices and it allows the operator to specify 
how many posts the scene contains.  

 The Advance Pages is also available for both Channel Box and Lyric devices and it allows the operator to 
specify if the sequence will iterate through the output posts automatically or manually (user operated). If 
automatically is selected, then the operator can specify the time (in seconds) each set of posts will be on air. 
See 13 for shortcuts associated with this option. 

 Time on Air: The operator can use this feature to dynamically configure how long each set of posts will 
remain on air depending on the posts’ maximum character count. To open the Time on Air option, click the 
clock icon ( ). Changing the default Seconds Per Post option will automatically reflect the Time in Seconds 
column for all Time on Air rows. The Time on Air feature creates a range of characters for each row to 
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determine how long each set of posts will remain on air (see Figure 39). If more than one post is used per 
page, then the post with the largest character count will be used to determine the time on air. 

 

  

 

Figure 39. On the left, time on Air option with 5 rows.  
On the right, interpretation of the Time on Air option. 

Note: As shown in the table above, if the character count is larger than the largest available Time on Air option, 
then the largest available Time on Air’s Time in Seconds will be used. 

Playback Options include: 

 Delete posts after airing: When enabled, this option automatically deletes posts from the output list after 
they are sent to the playout device. 

 Loop playback: With this option enabled, playback does not stop when the last post in a list is aired.  Rather, 
the list will continue to play from the first post.  

 When complete, play tab: Allows the operator to select the next tab to be automatically played once this 
one has completed. This option can only be enabled when Loop playback is disabled. 

 Force a stop before the next tab is played: Allows the operator to specify that this tab should execute a stop 
before starting playback in the next tab. This option can only be enabled when the When complete, play tab 
option is enabled. This option is usually used with persistent scenes that do not automatically come off the 
air when a new scene is played or if the next tab is controlling a different device and a stop on the current 
device is needed. 

 Move posts to input after playing X times: Allows the operator to specify how many times a post will be 
played before it automatically gets moved back to the input list. Once a post reaches this limit, it will be 
moved to the top of the input list. If that post is dragged back to the output list, its play count will reset to 0.  

 Scroll with the On Air indicator: When enabled, this option automatically scrolls the output list so the On Air 
indicator is always visible.  

Note 

Clicking the Finish button finalizes the tab creation process. If a tab with the same name is found in the same 
location, the operator will be prompted to overwrite the existing tab, import the existing tab, or cancel the new 
tab action. 

Range of 
Character Count 

Time on Air 
(seconds) 

0-50 5 

51-100 6 

101-150 7 

151-200 8 

201-250 9 

+250 9 
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3.5. Tab Settings 

If necessary, once a tab is created, its settings may be changed in the Tab Settings window, which is accessed 
through the Edit menu. The following illustrations show variations to existing tabs previously created in the New 
Tab Wizard; see Section 3. The available adjustments are identical, although the title and appearance of the 
dialogs vary slightly.  

  

Figure 40. Available adjustments in the General section of the Tab Settings dialog 

  

Figure 41. Available adjustments in the Input section of the Tab Settings dialog 
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Figure 42. Available adjustments in the Output section of the Tab Settings dialog 

 

Figure 43. Available adjustments in the Playback section of the Tab Settings dialog 
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4. Available Requests 

The Available Requests dialog displays the number of remaining requests for each Twitter account. There are 
three types of Twitter requests, and each type of request is limited to a maximum number of requests per 15 
minutes.  This means that if the maximum number of requests has been reached within a 15 minute time 
period, then future requests will fail until the 15 minute time period has expired. The table below illustrates 
each request type and its maximum number of requests. 

 

 

 

 

 

The Available Requests dialog can be used to help ensure that SHOUT is not making too many requests too 
frequently, which can result in Twitter data sources failing to refresh.  

Note the Always on top of main window option at the bottom. Selecting this checkbox will ensure that the 
dialog is always visible and on top of the main window. This is helpful if the operator wishes to place the 
Available Requests dialog over the main window and retain the ability to interact with the main window.  

As illustrated in Figure 44, the cells of the number of available requests change color as the number of requests 
get closer to 0. The cell will turn yellow when the number of requests drops below 30%, orange when the 
number of requests drops below 20%, red when the number of requests drops below 10% and grey (with N/A as 
the value) when the number of requests has not been determined yet. This can occur if the request type for that 
account is not being used. 

      

Figure 44. On the left, Available Requests dialog with a high number of requests remaining.  
On the right, Available Requests dialog with a low number of requests remaining. 

 

 

 

  

Request Type Maximum Number of Requests 

Twitter Account 180 

Twitter Search Term 180 

Twitter List 180 



 

30 

5. Device Manager 

The device manager allows the operator to easily configure multiple devices that can be used within the tabs. 
The device manager can be accessed from the Tools menu or the Playback section of the Tab settings dialog. 
Multiple tabs can use the same device, but only one tab can control playback to that device at a time. The 
operator can configure as many devices as necessary. The commands portion of the Device Manager will show 
all the commands sent and the responses received from all the devices. The list of commands can be copied or 
cleared using the right-click menu. Once a device is created, it can be edited by double-clicking or selecting it 
and clicking the Edit toolbar button. Only devices that are not currently connected can be edited. 

 

Figure 45. Device Manager with a Channel Box and 2 systems running Lyric 

5.1. Configuring a Channel Box Device 

Configuring a new Channel Box device is very simple. 

1. Click the toolbar’s Add Channel Box button. 

2. Enter a Name to uniquely identify this device. 

3. Select the Connection type: 

a. Network 

 Enter the Address of the Channel Box device 

 Enter the Port of the Intelligent Interface that was set up on the Channel Box device (see 
Section 6). 

b. Serial 

 Select the COM Port that is going to be used. This is not the port that is set up on the 
Channel Box device. Instead, this is the port on the system running SHOUT in which the 
serial cable is connected to. 

 Select the desired Baud Rate, Data Bits, Parity, and Stop Bits. These should match the 
settings that were set up on the Channel Box device. 
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4. Select the Encoding that matches the Intelligent Interface that was set up on the Channel Box device 

(see Section 6).  

                     

Figure 46. Left: Channel Box using Serial connection. Right: Channel Box using Network connection. 

5.2. Configuring a Lyric Device 

1. Click the toolbar’s Add Lyric button. 

2. Enter a Name to uniquely identify this device. 

3. Select the Connection type: 
a. Network: Enter the Address of the Lyric device. Note: The Port of Lyric devices is always 23. 
b. Serial 

 Select the COM Port that is going to be used. This is not the port that is set up on the Lyric 
device. Instead, this is the port on the system running SHOUT in which the serial cable is 
connected to. 

 Select the desired Baud Rate, Data Bits, Parity, and Stop Bits. These should match the settings 
on Lyric’s COM port. 

4. Select the Encoding matching the Lyric device (see Section 7). Note: If Unicode I/O is checked in the Lyric 
Telnet Config window (see Section 7), SHOUT’s Encoding should be set to Unicode. Otherwise, if 
Unicode I/O is not checked, SHOUT’s encoding should be set to Western European (Windows). 

5. Select the number of Available Frame Buffers for this device. If 1 (the default value) is selected, the 
select frame buffer command will be ignored. Else, the select frame buffer command is sent. Ignoring 
the select frame buffer command may potentially speed up the play to air time. 

                                                          

Figure 47. On the left, a Lyric device using a Serial connection.  
On the right, a Lyric device using a Network connection. 
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6. Playback with Channel Box 

SHOUT supports playback to Channel Box systems using the Intelligent Interface protocol. Channel Box playback 
settings must be set to ensure that Intelligent Interface is enabled and listening to incoming commands.  

To enable Intelligent Interface on a Channel Box device: 

1. From the Tools menu, select the Configuration menu item. The Configuration menu is seen in Figure 48.  
2. Expand the Automation section on left, right-click on Intelligent Interface, and in the context menu, 

click Add. 
3. The Command Encoding and Connection Type settings are available until the Interface Enabled 

checkbox near the top of the dialog is selected. Select the desired Encoding (this must match SHOUT’s 
encoding) and specify a TCP/IP port OR a Serial Port. If Serial Port is selected then change the COM Port 
Settings to match your preferences (these can be left at default). 

4. Click the Interface Enabled checkbox. Encoding and other connection settings are now unavailable as 
seen below.  

5. Press OK. 

 

Figure 48. Intelligent Interface settings on Channel Box 

Next, connect to your device from SHOUT: 

1. In the Playback section of the Tab Configuration dialog, check Enable Playback Control (Figure 43). 

2. In the Device dropdown, select a Channel Box device. 

3. If the device is not already connected, click the Device Manager button and connect your device. 

If connection to your Channel Box device is successful, the Scene list will automatically populate with scenes 
from your device. You will also notice a green icon next to the word “Connected” on the tab’s toolbar.  
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Note 

If you are not able to connect, verify that your device is reachable (whether it is running locally or on the correct 
network) and that the specified IP address, port number, and encoding type are correctly matched with your 
device. 

4  

Figure 49. SHOUT configured for Channel Box playout. 

 Select the desired scene from the Scene List, and the Play and Stop actions associated with that scene.  

 In addition, select the desired number of Posts Per Page and choose Automatic or Manual playback.  

If you are using more than one post per page, the scene objects on your device must conform to the correct 
naming format. For example, if a “Username” row is added in the Columns setting, then the scene must contain 
two text objects, “Username 1” and “Username 2.” There should only be one row in the Columns table per set 
of similar objects. 

At the time of this writing, March 2013, SHOUT does not support Channel Box crawl scenes. To use SHOUT with 

a Channel Box crawl scene, the operator must link the crawl object within the scene to the output.txt file found 

in the tab’s working directory. The output.txt file is created when the tab’s data output type is set to Text. See 

Section 3.3. 
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7. Playback with Lyric 

SHOUT also supports playout on Lyric devices such HyperX and LEX, using the Intelligent Interface protocol. 
Intelligent Interface must be enabled on your Lyric device, as seen below. Connection with these devices is 
similar to connection with a Channel Box system.  

1. Launch Lyric and select the Intelligent Interface menu item under Config. 

2. For Network connection, verify that Enable Telnet is checked. For Serial connection, verify that either 

Enable Serial Port 1 or Enable Serial Port 2 is checked. 

3. Press OK. 

 

Figure 50. Lyric’s Intelligent Interface settings on Chyron systems such as HyperX or LEX. 

4. In the Playback Control section of the Tab Settings dialog (Figure 51 and Figure 52) check Enable 

Playback Control. 

5. In the Device dropdown, select a Lyric device. 

6. If the device is not already connected, click the Device Manager button and connect your device. 

Once connected, enter the ID of the Lyric message that SHOUT will be updating. SHOUT will automatically 
remove any leading 0s (if necessary) and the .lyr extension that are entered. 

You may also elect to provide a Lyric message directory. If no directory is provided, then the default directory 
set in Lyric’s Default Paths Preferences will be used.  

For Page scenes, enter the desired Posts Per Page value, as well as the playback type (Manual or Automatic).  

Selecting the Execute the embedded macro after each update option will cause SHOUT to automatically 
execute the message’s embedded macro after each update. 

Additionally, the output on Lyric’s canvas can be previewed before take, using the Preview before take feature. 
This feature can only be enabled for Page playback. When this feature is enabled, a Cue button is added to the 
tab’s toolbar. This button allows the operator to cue up and preview any number of posts before selecting one 
for air. A post can also be cued by right clicking it and selecting Cue Post. 

When updating page templates in Lyric, SHOUT will attempt to update text templates that correspond to the 
Columns provided in the Output section (see Section 3.3.2). If no text template with the corresponding name is 
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found, SHOUT will attempt to update a node in the message’s Scene Graph. For SHOUT to properly update the 
message as expected, all text templates and nodes must have a unique name. 

If you are using more than one post per page, the scene objects on your device must conform to the correct 
naming format. For example, if a “Username” row is added in the Columns setting and the posts per page option 
is set to 2, then the scene must contain two text objects, “Username 1” and “Username 2.” There should only be 
one row in the Columns table per set of similar objects. 

For Crawl scenes, enter the desired Crawl Object Name, Post Spacer, and Seconds Per Post values.  

Note: You may set the Seconds Per Post to ‘0’ (zero) if you wish to only use the Post Spacer.  

   

Figure 51. SHOUT’s Scene Type page, configured for operation with a Chyron system running Lyric 

 

Figure 52. SHOUT with scene type Crawl, configured for operation with a Chyron system running Lyric 



 

36 

8. Controlling Tabs 
Once a tab is created, it is automatically added to SHOUT’s main window. Each tab is independent from the 
others and can be controlled from its own Settings dialog and toolbar. A tab page contains various controls that 
allow the operator to moderate, edit, and select posts. 

Tabs can be reordered by dragging their headers and dropping them in the desired location. 

The tab page is split into two main sections. The left section is used to view and control incoming posts, and the 
right section is used to view and control outgoing posts. The right section also includes playback controls and 
displays connection status.  

Posts that have an attached image or videos will have a second image next to the avatar. Posts with a video will 
also have a green play icon above the image. This image/video can be removed and restored using the Edit Post 
dialog (Section 8.3). The operator can hover over the image for a better preview. If the post contains a video, the 
operator will have the ability to preview the video before selecting it for output.  

In both lists, posts are marked with an icon indicating the social media data source from which they originate. 

Social Media Data Source Icon 

Twitter  

Facebook  

Instagram  

 YouToo  

RSS  
 

 

8.1. Controlling Incoming Posts 

SHOUT affords simple control of incoming posts with these options available on the toolbar’s left side: 

 Selection of the posts to be viewed, using the Search dropdown. The operator can elect to view all 
posts, only moderator messages, or individual accounts and search terms. The operator can also 
add new search terms manually by typing them directly into the Search dropdown. This action adds 
the new search term to the present tab’s list, selects it from the list for current use and creates the 
new search term in SHOUT’s global preferences.  

In addition, the operator can select an existing Search dropdown item by manually typing it into the dropdown 
box. Each item in the Search drop down is marked with an icon that symbolizes the social media data source 
from which it originates. 
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Filter Type Icon 

All Posts  

Moderator Messages  

Twitter Account  

Twitter List  

Twitter Search Term  

Facebook Account  

Facebook Page  

Facebook Status  

Instagram Account  

Instagram Status  

Instagram Search Term  

Mass Relevance Stream  

YouToo  

RSS Feed  

 

 The tab can be reconfigured using the Tab Settings window, which is accessed via the Tools menu or the 
Tab Settings button on the main window. It can also be accessed using the shortcut Ctrl + T. 

 Closing a tab will remove it from the main window, but will not delete any of the tab configuration files 
found in the tab’s working directory. These files can be used to import the tab back into SHOUT in the 
future.  

 Clicking the Refresh button refreshes the current list. 

 If a Facebook account or page is used, the operator will need to do a refresh on the All Posts item from 
the Search drop down in order to download and convert the account’s latest statuses into lists. This will 
also download the latest comments for those statuses.  

 Selected posts may be moved to output by clicking the Move to Output button, or by right-clicking on 
the post(s) and selecting the Move to Output option. Both methods will move the post(s) to the bottom 
of the output list.  

 Note that the operator can also drag posts from the Incoming list and drop them anywhere in the 
output list. 

 Selected posts may be edited by clicking the Edit Post button, or by double-clicking the post, or by right-
clicking the post and choosing the Edit Post selection. For more information, see Edit a User Post, 
Section 8.3. 

 The rate at which new posts are pulled can be varied by clicking the Refresh Every checkbox and 
selecting a value in the time control. 

 The operator can blacklist users directly from the incoming list. Blacklisting a user will delete all their 
posts and add them to the Filter Out section of the Global Preferences so new posts by that user will not 



 

38 

show up. To remove a user from the blacklist, simply remove their username from the Filter Out list. To 
blacklist users, right click on the desired posts and select the BlackList User option (Figure 53). 
 

 

Figure 53. Incoming list context menu with Blacklist User option selected. 

Note 

Posts in the Incoming list can be temporarily rearranged by dragging and dropping. However, once the list is 
refreshed or a new Search view is selected, the posts re-sort themselves chronologically (newest posts on top).  

 

Figure 54. Incoming Posts pane 

8.2. Controlling Outgoing Posts 

Controlling outgoing posts is similar to incoming posts, with these options available on the toolbar’s right side: 
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 Selected posts may be moved back to the Incoming Posts list by clicking the Move Back button, or by 
right-clicking on the post(s) and selecting the Move Back option, or by dragging posts from the Outgoing 
list and dropping them into the Incoming list. 

 Selected post(s) may be deleted by clicking the Delete button, by clicking the Delete key on the 
keyboard, or by right-clicking on the post(s) and choosing the Delete selection. Note: Deleted posts will 
be added to a blacklist and remain deleted for 24 hours. This means that after a post is deleted, it will 
not reappear in the input list until 24 hours have passed. This only applies to posts that have been 
manually deleted. Posts deleted using the Delete After Air feature will not get blacklisted. 

 The operator can reset the play count for posts by using the Reset Play Count (Figure 53) option in the 
context menu that is found in both the Input and Output lists. 

 Scenes configured with the Playback settings (Section 2.5), may be loaded by clicking the Load button. 

 The loaded scene may be played by clicking the Play button. This will trigger the scene’s Play Action if 
one has been defined. 

 The scene currently playing may be stopped by clicking the Stop button. This will trigger the scene’s Stop 
Action if one has been defined. 

 The operator can connect and disconnect from the configured device by right clicking the connection 
status.  

 The operator can view the current connection status of the device. Note: The connection status for each 
tab can also be found in the tab’s header. 

Connection Status Icon 

Connected  

Disconnected  

Connecting  

Connection Error  

 

The operator can rearrange output posts as needed. Rearranging output posts is permanent and will be 
reflected in both the saved data file and the playback order. In addition, the operator can also rearrange posts 
during playback, including the post currently on-air (which is highlighted in green during playback). Additionally, 
the operator can add new posts for output during playback. 
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Figure 55. Outgoing Posts pane 

8.3. Edit a User Post 

A user post can be edited only if the post is in the Input list. To edit a post, double-click it or select it and click 
the Edit Post button in the tab’s toolbar. The operator can also access the Edit Post dialog by right-clicking a post 
and selecting the Edit Post option. Only one post at a time may be edited. In the Edit Post dialog, the post’s text 
content and avatar may be edited. If there is no application default image defined in the global preferences and 
the Application Default option is selected, then no image will be used. The character count for the post being 
edited is shown on the right, below the post text box. 

The Edit Post dialog has two different views. The first view (Figure 56) is for posts without a post image, and the 
second view (Figure 57) is for posts with a post image. The operator can also remove and restore the post’s 

attached image. If the attached image is removed, then a camera icon ( ) will be shown next to the username 
to indicate that the post contains an image.  

From the Edit Post dialog, the post can be sent directly to output by clicking the To Output button. This will save 
any changes done to the post, close the edit post dialog, and append the post to the bottom of the output list. In 
addition, a post can be reverted to its original message, avatar, and attached image (if exists) by clicking the 
Revert button. 

  

Figure 56. Edit Post dialog without a post image 
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Figure 57. Edit Post dialog with a post image. 
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9. Moderator Messages 

Moderator messages allow the operator to create application-wide messages that may be used between 
viewers’ posts, to provide extra information, such as legal notices. Moderator messages may be created from 
any tab, and once a message is created, it is available on all tabs. 

To create a moderator message: 

1. Select the Moderator Messages list from the Search dropdown list. 

2. Press Add Message from the tab’s toolbar. 

3. Fill in the desired username, post, and image locations. 

4. Press OK. 

 

Figure 58. The Edit Moderator Post dialog 

To delete a Moderator message, select it from the list and click the Delete key on your keyboard or the Delete 
Message button located on the tab’s toolbar. 

Notice that multiple instances of the same Moderator message can be placed in the output list, and that 
Moderator messages are highlighted in pale yellow. See Figure 59. The yellow highlighting on screen is not easily 
visible in this illustration, but in operation will be easily seen. 
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Figure 59. Moderator Messages (created at left) interspersed with User Posts, as seen at right.  

 

10. Favorites List 

The Favorites list is a global list that is shared across all tabs. It allows the operator to mark posts as Favorite, 
which can then be used in other tabs or at a later time. Similar to the Moderator Messages, the Favorites list can 
be found under the Filters drop down.  

There are three ways to add a post to the Favorites list:  

1) Hover over the post and click on the Star that is found on the right side. (See Figure 60) 
2) Right click a post and select “Favorite”. This operation can be used on multiple posts at once. Note: This 

button will toggle the state of the post. (E.g. if there are 3 posts selected, posts 1 and 2 are already in 
the Favorites list and post 3 is not, and the Favorite button is clicked then it will remove posts 1 and 2 
from the Favorites list and add post 3 to the Favorites list.) 

3) Drag and drop a post into the Favorites list. This operation can be used on multiple posts at once. 

There are three ways to remove a post from the Favorites list: 

1) Click the yellow Star that is found on the right side. (See Figure 60)  
2) Right click a post and select “Favorite”.  
3) Select a post from the Favorites list and press Delete.  

 

The input and output list will display a yellow star to the right of the post if it is in the Favorites list. If the 
operator hovers over a post that is not in the Favorites list, a gray star will be displayed to the right. When this 
gray star is hovered over, it will turn yellow. If the star is clicked, then the post will be added to the Favorites list. 
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Figure 60. The top post (yellow star) is marked as Favorite. The middle post (gray star) is not marked as 
Favorite but the mouse is over it. The bottom post (no star) is not marked as Favorite and the mouse 

is not over it. 

 

11. Multi-User Control 

Multiple instances of SHOUT running on separate computers are capable of controlling the same tab. E.g. Two 
instances can moderator incoming posts from different (or the same) lists and select posts for output, while a 
third system controls the playback to a Chyron device.  

 

Figure 61. Two SHOUT moderator computers and one SHOUT playout computer controlling  
a Chyron device. 

For this scenario to work, all of the computers involved will need to have access to a shared folder. This shared 
folder can be on one of the computers running SHOUT, on the Chyron device, or a completely different 
computer on the network. 

Follow these steps to set up a multi-user scenario with SHOUT: 

1. Ensure that all SHOUT instances and the Chyron device are on the same network. 
2. Create a new tab on one of the computers running SHOUT: 

a. Set the Tab’s Location (under the General section) to a shared folder accessible by all SHOUT 
instances. 

b. Set the Tab’s Image Output Location (under the Output section) to a shared folder accessible by 
all SHOUT instances and the Chyron device, usually a subfolder in the tab’s location (assuming 
the Chyron device has access to it) or a shared folder on the Chyron device. 

c. Configure the rest of the tab to match your preferences. 
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3. On all the other SHOUT instances, import (File->Import) the tab-details file that was created with the 
new tab.  

All instances of SHOUT are now controlling the same tab. This means that if any of the tab’s settings are 
changed, it will be reflected in all instances. In addition, any operations performed on the input and output lists 
will be reflected in all instances (for example, adding posts, deleting posts, re-ordering posts, editing posts, etc.). 
Although only one instance can control the playback for the tab, Cued (yellow by default) and On Air (green by 
default) posts will be visible on all instances. 

Note: The Moderator Messages list is still global to each instance and it will not be transferred to the other 
instances. However, moving a moderator message to the output list will be reflected in the other instances. 

 

12. Logging 

SHOUT uses a third party application called ITechLogger to log various operations. The easiest way to reach the 
logs is through the SHOUT interface. From SHOUT’s View menu, the operator can select either to view the 
Current Log or the Log Folder. Selecting the Current Log option launches the ITLogBook with the current log. 
Selecting the Log Folder option opens the folder containing all the log files. Since SHOUT uses the ITech Logger 
Service, all SHOUT runs are stored in the same log file. Once the log file has reached its maximum size of 5mb, a 
new one is created for future log entries.  

Commonly logged operations: 

 On start-up, SHOUT logs the running version, the current license status, and tabs that fail to load. 

 Whenever an automatic refresh occurs, the reason is also logged. 

 During playback, SHOUT logs various operations: 

 Whenever a device is connected to or disconnected from, including any connection errors. 

 Whenever a scene is loaded, played, cleared, or stopped. Both the Scene and Device names are 
logged. 

 All the information about every post that is sent to the play-out device is logged. This includes 
Username, Real Name, Aired Message, Original Message, Time Created, Post Type, Post Id, 
Character Count, Post Image Location, Video Image Location, Image Type and the Image Aired. 

 SHOUT logs any web and I/O errors. These errors include: 

 Images that fail to download or save, and the reason they failed. 

 Files that fail to save, and the reason they failed. 

 Accounts or Search Terms that fail to refresh, and the reason they failed.  

 Adding and removing devices. 

 Any application exceptions that occur in SHOUT during operation are automatically logged and the user 
may be prompted with an exception dialog. If this occurs, it is strongly recommended to email Customer 
Support with a screenshot of the exception dialog. 

 Whenever Offline Mode is enabled/disabled.  

 On shut-down, SHOUT logs the running version and if it successfully closed. 

Note 

Other operations that are not listed above that may help troubleshoot common problems may also be logged. 
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13. SHOUT’s Global Keyboard Shortcuts 

SHOUT supports a number of useful global shortcuts that can help speed up moderation. 

Key Combination Action 

Ctrl + N Add a new tab 

Ctrl + O Import a tab 

Ctrl + W Close the current tab 

Ctrl + G Move selected posts to output 

Ctrl + H Move selected posts to input 

Ctrl + E Edit the selected post 

Ctrl + Q* Clear scene objects for the current tab 

In Lyric, this will delete all the templates from 
the canvas 

In Channel Box, this will remove the data from 
all the fields that are used for playback 

Ctrl + Alt + Q* Stop playback for the current tab 

Pause* Triggers a pause release to a Lyric device for 
the current tab 

F4 Toggles the current tab’s advance page 
playback option to Automatic. 

F9 Toggles the current tab’s advance page 
playback option to Manual. 

Del Delete the selected post(s) 

Ctrl + A Select all the posts in the focused list 

Ctrl + F5 Refresh the current view for all tabs 

F5 Refresh the current view for the current tab 

Ctrl + T Open the current tab’s settings dialog 

Ctrl + P Open SHOUT’s global settings dialog 

F1 Open SHOUT’s About dialog 

Space/Enter* Triggers the Play button. 

Alt + F4 Exit SHOUT 

 

*These operations will only work after SHOUT has been connected to the device, and the Load button has been 
pressed
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