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Legal Notices
Product specifications are subject to change without notice and do not represent a commitment on the part of Avid Technology, 
Inc.

This product is subject to the terms and conditions of a software license agreement provided with the software. The product 
may only be used in accordance with the license agreement.

Avid products or portions thereof are protected by one or more of the following United States Patents: 5,267,351; 5,309,528; 
5,355,450; 5,396,594; 5,440,348; 5,467,288; 5,513,375; 5,528,310; 5,557,423; 5,577,190; 5,584,006; 5,640,601; 5,644,364; 
5,654,737; 5,724,605; 5,726,717; 5,745,637; 5,752,029; 5,754,851; 5,799,150; 5,812,216; 5,828,678; 5,842,014; 5,852,435; 
5,986,584; 5,999,406; 6,038,573; 6,061,758; 6,069,668; 6,141,007; 6,211,869; 6,532,043; 6,546,190; 6,596,031; 6,636,869; 
6,747,705; 6,763,523; 6,766,357; 6,813,622; 6,847,373; 7,081,900; RE40,107; 7,403,561; 7,433,519; 7,671,871; D352,278; 
D372,478; D373,778; D392,267; D392,268; D392,269; D395,291; D396,853; D398,912. Other patents are pending.

Avid products or portions thereof are protected by one or more of the following European Patents: 0506870; 0635188; 
0674414; 0752174; 1111910; 1629675. Other patents are pending.

This document is protected under copyright law. An authorized licensee of Deko may reproduce this publication for the 
licensee’s own use in learning how to use the software. This document may not be reproduced or distributed, in whole or in 
part, for commercial purposes, such as selling copies of this document or providing support or educational services to others. 
This document is supplied as a guide for Deko. Reasonable care has been taken in preparing the information it contains. 
However, this document may contain omissions, technical inaccuracies, or typographical errors. Avid Technology, Inc. does not 
accept responsibility of any kind for customers’ losses due to the use of this document. Product specifications are subject to 
change without notice.

Copyright © 2010 Avid Technology, Inc. and its licensors. All rights reserved.

The following disclaimer is required by Apple Computer, Inc.:
APPLE COMPUTER, INC. MAKES NO WARRANTIES WHATSOEVER, EITHER EXPRESS OR IMPLIED, REGARDING 
THIS PRODUCT, INCLUDING WARRANTIES WITH RESPECT TO ITS MERCHANTABILITY OR ITS FITNESS FOR ANY 
PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE 
ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. 
THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE.

The following disclaimer is required by Sam Leffler and Silicon Graphics, Inc. for the use of their TIFF library:
Copyright © 1988–1997 Sam Leffler  
Copyright © 1991–1997 Silicon Graphics, Inc.

Permission to use, copy, modify, distribute, and sell this software [i.e., the TIFF library] and its documentation for any purpose 
is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of 
the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any 
advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon 
Graphics.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR 
OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT 
OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, 
DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF 
LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

The following disclaimer is required by the Independent JPEG Group:
This software is based in part on the work of the Independent JPEG Group.

The following disclaimer is required by Paradigm Matrix:
Portions of this software licensed from Paradigm Matrix.
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The following disclaimer is required by Ray Sauers Associates, Inc.:
“Install-It” is licensed from Ray Sauers Associates, Inc. End-User is prohibited from taking any action to derive a source code 
equivalent of “Install-It,” including by reverse assembly or reverse compilation, Ray Sauers Associates, Inc. shall in no event be 
liable for any damages resulting from reseller’s failure to perform reseller’s obligation; or any damages arising from use or 
operation of reseller’s products or the software; or any other damages, including but not limited to, incidental, direct, indirect, 
special or consequential Damages including lost profits, or damages resulting from loss of use or inability to use reseller’s 
products or the software for any reason including copyright or patent infringement, or lost data, even if Ray Sauers Associates 
has been advised, knew or should have known of the possibility of such damages.

The following disclaimer is required by Videomedia, Inc.:
“Videomedia, Inc. makes no warranties whatsoever, either express or implied, regarding this product, including warranties with 
respect to its merchantability or its fitness for any particular purpose.”

“This software contains V-LAN ver. 3.0 Command Protocols which communicate with V-LAN ver. 3.0 products developed by 
Videomedia, Inc. and V-LAN ver. 3.0 compatible products developed by third parties under license from Videomedia, Inc. Use 
of this software will allow “frame accurate” editing control of applicable videotape recorder decks, videodisc recorders/players 
and the like.” 

The following disclaimer is required by Altura Software, Inc. for the use of its Mac2Win software and Sample 
Source Code:
©1993–1998 Altura Software, Inc.

The following disclaimer is required by Ultimatte Corporation:
Certain real-time compositing capabilities are provided under a license of such technology from Ultimatte Corporation and are 
subject to copyright protection.

The following disclaimer is required by 3Prong.com Inc.:
Certain waveform and vector monitoring capabilities are provided under a license from 3Prong.com Inc.

Attn. Government User(s). Restricted Rights Legend
U.S. GOVERNMENT RESTRICTED RIGHTS. This Software and its documentation are “commercial computer software” or 
“commercial computer software documentation.” In the event that such Software or documentation is acquired by or on behalf 
of a unit or agency of the U.S. Government, all rights with respect to this Software and documentation are subject to the terms 
of the License Agreement, pursuant to FAR §12.212(a) and/or DFARS §227.7202-1(a), as applicable.

Trademarks
003, 192 Digital I/O, 192XD I/O, 888 I/O, AirPlay, AirSPACE, AirSPACE HD, AirSpeed, ALEX, Alienbrain, AniMatte, 
AudioMarket, AudioPages, AudioSuite, AudioVision, AutoSync, Avid, Avid Advanced Response, Avid DNA, Avid DNxcel, 
Avid DNxHD, AVIDdrive, Avid DS Assist Station, Avid EditStar, Avid Learning Excellerator, Avid Liquid, 
Avid Liquid Chrome Xe, Avid MEDIArray, Avid Mojo, AvidNet, AvidNetwork, Avid NewStar, Avid Remote Response, 
AVIDstripe, Avid Unity, Avid Unity ISIS, Avid VideoRAID, Avid Xpress, AVoption, AVX, Beauty Without The Bandwidth, Boom, 
C|24, CaptureManager, ChromaCurve, ChromaWheel, Command|24, Conectiv, CountDown, DAE, Dazzle, 
Dazzle Digital Video Creator, Deko, DekoCast, D-Fi, D-fx, DigiDelivery, Digidesign, Digidesign Audio Engine, 
Digidesign Intelligent Noise Reduction, DigiDrive, DigiLink, DigiMeter, DigiSerial, DigiStudio, DigiStudio Control, 
Digital Nonlinear Accelerator, DigiTranslator, DINR, DNxchange, do more, DVD Complete, D-Verb, Eleven, Equinox, 
EveryPhase, ExpertRender, Fastbreak, Fast Track, FieldPak, Film Composer, FilmScribe, Flexevent, FluidMotion, FXDeko, 
G7, G-Rack, HD Core, HD Process, HDPack, HYBRID, HyperControl, HyperSPACE, HyperSPACE HDCAM, IllusionFX, 
Image Independence, iNEWS, iNEWS Assign, iNEWS ControlAir, Instantwrite, Instinct, 
Intelli-sat Broadcasting Recording Manager, Intelli-Sat, InterFX, Interplay, inTONE, Intraframe, iS9, iS18, iS23, iS36, ISIS, 
IsoSync, KeyRig, KeyStudio, LaunchPad, LeaderPlus, Lightning, ListSync, Lo-Fi, Magic Mask, Make Anything Hollywood, 
make manage move | media, Marquee, M-Audio, M-Audio Micro, Maxim, Mbox, MCXpress, Media Browse, Media Composer, 
MediaDock, MediaDock Shuttle, Media Fusion, Media Illusion, MediaLog, Media Reader, Media Recorder, MEDIArray, 
MediaShare, MediaStream, Media Suite, Meridien, MetaFuze, MetaSync, MicroTrack, Midiman, MissionControl, Mix Rack, 
MixLab, Moviebox, Moviestar, NaturalMatch, Nearchive, NetReview, NewsCutter, Nitris, NRV-10 interFX, Octane, OMF, 
OMF Interchange, OMM, OnDVD, Open Media Framework, Open Media Management, Palladium, Pinnacle, 
Pinnacle DistanTV, Pinnacle Geniebox, Pinnacle HomeMusic, Pinnacle MediaSuite, Pinnacle Mobile Media, Pinnacle Studio, 
Pinnacle Studio MovieBoard, Pinnacle Systems, ProEncode, ProServices, ProSessions, Pro Tools, QuietDrive, Recti-Fi, 
Reel Tape Delay, Reel Tape Flanger, Reel Tape Saturation, RetroLoop, rS9, rS18, Salesview, Sci-Fi, Scorch, Scorefitter, 
ScriptSync, SecureProductionEnvironment, Session, Show Center, Sibelius, SIDON, Soft SampleCell, Soft-Clip Limiter, 
Sound Designer II, SPACE, SPACEShift, SpectraGraph, SpectraMatte, Sputnik, Starplay, SteadyGlide, Streamfactory, 
Streamgenie, StreamRAID, Strike, Structure, Studiophile, SubCap, Sundance Digital, Sundance, Symphony, SYNC HD, 
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SynchroScience, SynchroScope, Syntax, TDM FlexCable, Thunder, Titan, Titansync, TL Aggro, TL AutoPan, TL Drum Rehab, 
TL Everyphase, TL Fauxlder, TL In Tune, TL MasterMeter, TL Metro, TL Space, TL Utilities, Torq, Torq Xponent, Transfuser, 
Trigger Finger, Trillium Lane Labs, TruTouch, UnityRAID, Vari-Fi, Velvet, Venom, VideoRAID, Video Slave Driver, VideoSPACE, 
VideoSpin, Vortx, Xdeck, X-Form, Xmon, Xponent, and X-Session are either registered trademarks or trademarks of Avid 
Technology, Inc. in the United States and/or other countries.

Adobe and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States 
and/or other countries. Apple and Macintosh are trademarks of Apple Computer, Inc., registered in the U.S. and other 
countries. Windows is either a registered trademark or trademark of Microsoft Corporation in the United States and/or other 
countries.

iNEWS, iNEWS ControlAir, and Media Browse are either registered trademarks or trademarks of iNews, LLC.

All other trademarks contained herein are the property of their respective owners.

Footage
Arri — Courtesy of Arri/Fauer — John Fauer, Inc. 
Bell South “Anticipation” — Courtesy of Two Headed Monster — Tucker/Wayne Atlanta/GMS. 
Canyonlands — Courtesy of the National Park Service/Department of the Interior. 
Eco Challenge British Columbia — Courtesy of Eco Challenge Lifestyles, Inc., All Rights Reserved.  
Eco Challenge Morocco — Courtesy of Discovery Communications, Inc. 
It’s Shuttletime — Courtesy of BCP & Canadian Airlines.  
Nestlé Coffee Crisp — Courtesy of MacLaren McCann Canada.  
Saturn “Calvin Egg” — Courtesy of Cossette Communications.  
“Tigers: Tracking a Legend” — Courtesy of www.wildlifeworlds.com, Carol Amore, Executive Producer. 
"The Big Swell" — Courtesy of Swell Pictures, Inc. 
Windhorse — Courtesy of Paul Wagner Productions.

Arizona Images — KNTV Production — Courtesy of Granite Broadcasting, Inc.,  
Editor/Producer Bryan Foote. 
Canyonlands — Courtesy of the National Park Service/Department of the Interior. 
Ice Island — Courtesy of Kurtis Productions, Ltd. 
Tornados + Belle Isle footage — Courtesy of KWTV News 9. 
WCAU Fire Story — Courtesy of NBC-10, Philadelphia, PA. 
Women in Sports – Paragliding — Courtesy of Legendary Entertainment, Inc.

News material provided by WFTV Television Inc.

GOT FOOTAGE?
Editors — Filmmakers — Special Effects Artists — Game Developers — Animators — Educators — Broadcasters — Content 
creators of every genre — Just finished an incredible project and want to share it with the world?

Send us your reels and we may use your footage in our show reel or demo!*

For a copy of our release and Avid’s mailing address, go to www.avid.com/footage.

*Note: Avid cannot guarantee the use of materials submitted.

Avid Deko Products User’s Guide • 0130-07482-01 Rev D • July 2010

This document is distributed by Avid in online (electronic) form only, and is not available for purchase in printed 
form.

http://www.wildlifeworlds.com
http://www.avid.com/footage
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Using This Guide

Congratulations on your Deko® purchase. Deko is an award-winning product line of 
full-color video character generators. Almost any graphic you can imagine for television can 
be created with a Deko. Deko is used worldwide for news and sports broadcasting by art 
directors, designers, and on-air operators.

This guide contains all the task-oriented instructions, conceptual information, and reference 
material you need to use the effects and titling features of your Deko application.

This guide is intended for all users, from beginning to advanced.

Unless noted otherwise, the material in this document applies to the Windows® operating 
system.

n The documentation describes the features and hardware of all models. Therefore, your 
system might not contain certain features and hardware that are covered in the 
documentation.

About this Guide

The Deko Products User's Guide is designed to be a learning tool for those new to Deko, as 
well as a handy reference for experienced operators. This user's guide offers step-by-step 
instructions and general information.

Experienced operators might not want to read the entire manual, but can refer to the contents 
or index for specific information. We are constantly improving the Deko family, so you 
might find some changes since you last used Deko.

If you are new to Deko products, especially if you are new to using a character generator, 
your best bet is to read this manual in order and familiarize yourself with all of the tasks 
presented. An investment of time now might save a lot of time later. Once you reach the 
“Create Useful Graphics on the Job” and “Create Useful Animated Graphics” chapters, you 
will be well prepared to create the graphics you need.
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If you’re familiar with other Windows applications, we think you’ll find using Deko easy 
and natural. If you’re new to Windows, we suggest that you pick up a book on the subject to 
familiarize yourself with basic Windows concepts. This user’s guide assumes a working 
knowledge of Windows.

Keyboard Abbreviations

Using one, two, or three keystrokes instead of using the mouse pointer to interact with the 
user interface is called a shortcut. Shortcuts for standard keyboards are marked SK. 
Shortcuts for the FastAction Keyboard are marked FAK.

Symbols and Conventions

Avid documentation uses the following symbols and conventions:

Symbol or Convention Meaning or Action

n A note provides important related information, reminders, 
recommendations, and strong suggestions.

c A caution means that a specific action you take could cause harm to 
your computer or cause you to lose data.

w A warning describes an action that could cause you physical harm. 
Follow the guidelines in this document or on the unit itself when 
handling electrical equipment.

> This symbol indicates menu commands (and subcommands) in the 
order you select them. For example, File > Import means to open the 
File menu and then select the Import command.

This symbol indicates a single-step procedure. Multiple arrows in a list 
indicate that you perform one of the actions listed.

(Windows), (Windows 
only), (Macintosh), or 
(Macintosh only)

This text indicates that the information applies only to the specified 
operating system, either Windows or Macintosh OS X.

Bold font Bold font is primarily used in task instructions to identify user interface 
items and keyboard sequences.

Italic font Italic font is used to emphasize certain words and to indicate variables.

Courier Bold font Courier Bold font identifies text that you type.

Ctrl+key or mouse action Press and hold the first key while you press the last key or perform the 
mouse action. For example, Command+Option+C or Ctrl+drag.



If You Need Help

33

If You Need Help

If you are having trouble using your Avid product:

1. Retry the action, carefully following the instructions given for that task in this guide. It 
is especially important to check each step of your workflow.

2. Check the latest information that might have become available after the documentation 
was published:

- If the latest information for your Avid product is provided as printed release notes, 
they ship with your application and are also available online.

If the latest information for your Avid product is provided as a ReadMe file, it is 
supplied on your Avid installation CD or DVD as a PDF document 
(README_product.pdf) and is also available online.

You should always check online for the most up-to-date release notes or ReadMe 
because the online version is updated whenever new information becomes 
available. To view these online versions, select ReadMe from the Help menu, or visit 
the Knowledge Base at www.avid.com/readme.

3. Check the documentation that came with your Avid application or your hardware for 
maintenance or hardware-related issues.

4. Visit the online Knowledge Base at www.avid.com/onlinesupport. Online services are 
available 24 hours per day, 7 days per week. Search this online Knowledge Base to find 
answers, to view error messages, to access troubleshooting tips, to download updates, 
and to read or join online message-board discussions.

How to Order Documentation

To order additional copies of this documentation from within the United States, call Avid 
Sales at 800-949-AVID (800-949-2843). If you are placing an order from outside the United 
States, contact your local Avid representative.

Avid Training Services

Avid makes lifelong learning, career advancement, and personal development easy and 
convenient. Avid understands that the knowledge you need to differentiate yourself is always 
changing, and Avid continually updates course content and offers new training delivery 
methods that accommodate your pressured and competitive work environment.

To learn about Avid's new online learning environment, Avid Learning Excellerator™ 
(ALEX), visit http://learn.avid.com.

http://learn.avid.com
http://www.avid.com/readme
http://www.avid.com/onlinesupport
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For information on courses/schedules, training centers, certifications, courseware, and 
books, please visit www.avid.com/training or call Avid Sales at 800-949-AVID 
(800-949-2843).

http://www.avid.com/training


1 Getting Started with Deko

Once your Deko workstation has been set up and configured for your site, you need to learn 
how to get started with using the Deko software. In order to do so, you must understand the 
basics of what Deko has to offer, the options that may be available for your model, how to 
switch between SD and HD with Deko Hybrid models, and how to start and exit your 
software. In addition, you need to know how to use your keyboard, and set your save 
preferences.

The following topics describe how to get started with Deko:

• Welcome to Our Product

• Verifying Your Equipment

• About Deko Options

• Determining Enabled Options for Your Model

• Switching Between SD and HD with Deko Hybrid Products

• Availability of Features

• Starting Your Software

• Using Your Keyboard

• Setting your Save Preferences

• Using Other Applications without Exiting Deko

• Exiting Deko
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Welcome to Our Product

Congratulations on your Deko purchase. Deko is an award-winning product line of full-color 
video character generators. Almost any graphic you can imagine for television can be 
created with a Deko. Deko is used worldwide for news and sports broadcasting by art 
directors, designers, and on-air operators. 

Deko offers many capabilities:

• Like a word processor, Deko offers a variety of tools for typing text and for selecting 
fonts and styles.

• Like a page layout program, Deko allows total flexibility in positioning text and 
full-color graphic elements on the screen.

•  Like a presentation program, Deko plays back a series of graphic pages using a wide 
range of real-time effects.

• Deko provides up to three output channels and a powerful Motion Editor, for the most 
variety available in creating and playing motions.

• Graphics and sequences that you create on a Deko can easily be exported for playback 
to other Deko products.

• Graphics created on other products can be easily imported for use in the 
Deko environment.

• Deko graphics can easily incorporate other graphics, motions, and effects, saving time 
and allowing convenient, multiple uses of your graphics library.

Based on the Windows operating system, Deko offers unprecedented performance in a 
broadcast-quality character generator, including:

• The highest picture quality currently available for television graphics

• The ease of use and the networking capabilities of Windows 

PostDeko Lite is a full-color video-character generator provided as a graphics creation tool 
for DekoCast. Although PostDeko Lite does not support motions such as a cel animation 
player, it does have all of the power of Deko 3000 for building text and graphic layers. 
Graphic files built in PostDeko Lite (.dko files) can be used seamlessly in other Deko 
products.

PostDeko Lite controls the default directories for the Deko graphics files used by DekoCast.
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Verifying Your Equipment

Your Deko turnkey system includes:

• A computer, consisting of internal hardware components, with the Deko software 
installed.

• A mouse, to select or click items in the Deko interface.

• Either a standard keyboard or a FastAction Keyboard (optional). The FastAction 
Keyboard (FAK) is specially designed for Deko to promote speed and ease of use. For 
more information on the FAK, see “About the Optional FastAction Keyboard” on 
page 46. For information on using the FastAction Keyboard, see “Using FastAction 
Keyboard Functionality” on page 773.

About Deko Options

Deko options can provide additional functionality to your Deko system. The following 
topics contain more information on some of the available Deko options:

• “Automation” on page 37

• “DekoObjex” on page 38

• “DVE Effects Group 2” on page 38

• “Make DekoMovie” on page 38

• “SportsWare” on page 38

• “StillDeko” on page 38

• “Timeline” on page 38

• “Aston Import” on page 39

• “Chyron Import” on page 39

Automation

The Automation option includes I.I.I. protocol for reading non-Deko files, both serial and 
network; Timecode Control, allowing control of sequences via SMPTE timecode; and 
Database Connection. For more information, see “Using Automation” on page 753.

ClipDeko

Import and play video clips with your Deko. For more information, see “Using the ClipDeko 
Option” on page 436.
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DekoObjex

DekoObjex gives the ability to define and playback individual objects (or groups of objects) 
with actions independent of any other element or effect on the screen. Examples include 
video squeezeback or persistent objects like clocks or crawls. Author these objects in an 
easy-to-use environment that does not require programming skills. For more information, 
see “About DekoObjex” on page 769, and your Deko Objex User’s Guide.

DVE Effects Group 2

DVE Effects Group 2 offers additional motion effects, accessed just as other effects, 
including Page Scroll, Cylinder, Magic Carpet, Accordion, and 3D Ripple. For more 
information, see “DVE Effects” on page 499.

Make DekoMovie

The Make DekoMovie option makes it possible for the Deko Sequencer to render Deko 
effects to create AVI files or TARGA® files. You can then import these files into the Clip 
Editor, use them in Cel Animations, or play them on other devices. For more information, 
see “Playing Sequences as Clips with Make DekoMovie” on page 517.

SportsWare

The SportsWare option includes two powerful features to quickly modify graphics, Pops, 
and Macro Autoplay. With Pops, create and “pop” a text selection onto an open graphic. 
With Macro Autoplay, enable macros to play automatically when opened. For more 
information, see “Creating and Using Partial Graphics with the SportsWare Option” on 
page 384.

StillDeko

Access and title stills in a Thunder Database. For more information, see “Managing Stills 
with StillDeko, and Thunder” on page 432.

Timeline

Timeline allows you customize motions in Deko’s Motion Edit window. Define changes 
over time to a graphic element’s position, size, rotation, or opacity. The resulting effect is 
similar to DVE keyframing. For more information, see “Adjusting Motion Parameters with 
the Timeline Option” on page 541.
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Aston Import

Import files created in the Aston environment and use them with your Deko. For more 
information, see “Aston Import Option” on page 429.

Chyron Import

Import files created in the Chyron® environment and use them with your Deko. For more 
information, see “Chyron Import Option” on page 430.

Determining Enabled Options for Your Model

Your Deko came with some options that were enabled on it. There might also be options that 
are available for your Deko model, but were not enabled. And, there might be options that 
are not available for your Deko model.

To see if an option is available for your system:

t See the Features and Options Matrix located on the Avid Knowledge Base at 
www.avid.com/onlinesupport.

To see which options are enabled on your system:

1. Select Options > Enabled Options.

A dialog box opens. A check mark next to an option indicates that it is enabled on your 
system.

2. Click OK to close the dialog box.

To use an enabled option:

t For options that are integrated into the Deko, but offer separate interfaces (for example, 
Rocket and DekoObjex), see the appropriate User Guide. 

n These options are introduced in this User’s Guide, but each is covered in detail in its own 
Guide.

To add an option not currently enabled on your system: 

t Contact Avid Sales at 800-949-AVID (800-949-2843).

http://www.avid.com/onlinesupport
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Switching Between SD and HD with Deko Hybrid 
Products

The purpose of the Deko1000 and Deko3000 Hybrid products is to enable you to switch 
between native high-definition (HD) and native standard definition (SD) operating modes. 
Using these new Deko Hybrid products, broadcasters can support both SD and HD 
production needs using a single system and user interface, minimizing equipment, 
installation, retraining and production costs while expanding HD services.

Deko 1000/Hybrid and Deko 3000/Hybrid support a wide variety of live sports, 
entertainment and newsroom environments. Both hybrid products generate graphics, process 
video and deliver output for native NTSC / PAL SD resolutions and native 720 / 1080 HD 
resolutions.

In an SD/HD world, broadcasters must contend with multiple versions of their graphics 
assets. Deko 1000/Hybrid and Deko 3000/Hybrid dramatically improve management with 
tools to simplify the process of working with 4:3 and 16:9 aspect ratio elements and layouts. 

Both hybrid models deliver the full functionality of their single format counterparts. For 
example, Deko 3000/Hybrid delivers the feature set of Deko 3000 when in SD mode and the 
feature set of Deko 3000 HD when in HD mode.

Availability of Features

Most features and functions presented in this guide are available on all Deko models. 
However, some features are available only on certain models, or optionally at an additional 
cost.

Starting Your Software

This topic contains information on how to get started with using your Deko.

• “Starting Windows” on page 41

• “Starting Deko” on page 41

• “Adding a Deko Icon to your Desktop” on page 41

• “Starting Deko Automatically” on page 42

• “Locating the Deko Application” on page 42

• “Once you Start Deko” on page 43
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Starting Windows

To start Windows:

1. Turn on the power to the Deko system.

The VGA monitor shows a series of diagnostic screens, then displays the Windows 
startup screen.

2. Press Ctrl+Alt+Delete to log on.

3. Type your user name and password, and then press Enter. If you don’t have a user name, 
log on as user “Deko.” This user name is factory installed and does not require a 
password.

n Once you log on, you see the Windows desktop, from which you can launch any application 
program, including Deko. You might need to be privileged as a Power User to run Deko. 
Check with your system administrator for details. For more information about Windows, 
refer to the Windows documentation.

Starting Deko

To start Deko, do one of the following:

t Double-click the Deko program icon.

t Click the Start button, and then select Programs > the name of your Deko application 
(such as, Deko3000, PostDeko, and so on.)

n If you do not see the Windows desktop with various program icons, it might be because 
another program is running. Close or minimize any open program.

Adding a Deko Icon to your Desktop

To place the Deko icon (shortcut to Deko) on the Windows desktop if it is not there:

1. Right-click the icon and select Create Shortcut. 

A copy of the application appears with (2) appended to it.

2. Drag the copy to the desktop.

Checking Your Desktop Settings

In order to operate sufficiently, Deko requires particular desktop settings. 

To check or change desktop settings:

1. Right-click on the desktop and select Properties. 

The Display Properties dialog box opens.
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2. Click the Appearance tab, and make sure the Font size is set to Normal.

3. Click the Settings tab, and make sure the settings are set as follows:

- Color quality: Highest (32 bit)

- Screen resolution: 1024 by 768 pixels

Starting Deko Automatically

To start Deko automatically, every time you log on:

1. From the Windows taskbar at the bottom of your screen, click the Start button and select 
Settings > Taskbar and Start Menu. 

The Taskbar and start menu dialog box opens.

2. In the window that appears, select the Advanced tab.

3. Click Add, and then click Browse.

4. Locate your Deko program, and then double-click it. 

5. Click Next, and then double-click the StartUp folder.

The name of your Deko program should appear in the field. 

6. Click Finish.

7. If Windows prompts you to select an icon, click one, and then click Finish.

Locating the Deko Application

To find Deko if you do not see it on the desktop or in the Program list:

1. Click the Start button and select Search > For Files or Folders.

2. Click All Files and Folders.

3. Type the name of your Deko (for example, Deko1000, Deko3000 HD, or PostDeko) in 
the “All or part of the filename” text box.

4. Click Search. 

A description of the Deko filename along with a path that indicates its location appears.

5. Click the file name in the list and drag it to the desktop.

This creates a shortcut so you can start Deko from the desktop.

6. To start Deko, double-click on the filename in the list or on your new desktop shortcut.
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Once you Start Deko

As Deko starts, you might be prompted to hide the Windows taskbar so the Deko windows 
display properly.

Hiding the Windows Taskbar

To hide the Windows taskbar:

1. Right-click the taskbar at the bottom of your screen. 

A menu opens.

n Make sure that you do not click on any buttons on the taskbar. 

2. Click Properties.

A dialog box opens.

3. Click Auto-hide the taskbar. 

After closing Deko, you may click this choice again to turn off the auto-hide option.
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Initial Deko Desktop Appearance

Once you start Deko, you see the Deko desktop. The appearance of the desktop varies, 
depending on the layout selected. Unless you have changed settings, as discussed later in 
this guide, the desktop initially displays the Style Edit layout.

n The Deko interface is discussed further in subsequent chapters. 
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Using Your Keyboard

Your Deko is equipped with either a standard keyboard or the optional FastAction Keyboard. 
Throughout this manual, keyboard shortcuts for performing tasks in Deko are labeled SK for 
standard keyboards and FAK for FastAction keyboards.

The following topics contain more information about using your keyboard:

• “About the Enhanced Keypad Feature” on page 45

• “Enabling or Disabling the Enhanced Keypad” on page 46

• “About the Optional FastAction Keyboard” on page 46

About the Enhanced Keypad Feature

The Enhanced Keypad feature is available even without the FastAction Keyboard option. 
With this feature, the numeric keypad can provide quick access to reading files. Just be sure 
the NumLock key is enabled on the keypad. Otherwise, the next sequential file just reads. 
For example, with NumLock off, if you type 165 (and 165 airs), then type 170 (and the next 
sequential file 166 airs). However, with Numlock on, you can type 165 (and 165 airs) 170 
(and 170 airs), and 166 (and 166 airs).

To call up graphics with numerical file names:

1. Type the file name on the numeric keypad.

2. Do one of the following:

t Press Read.

t Press Enter.

n It is recommended to leave NumLock on and use the keys at the top of the main keyboard 
for numerals.

Deko displays a text box on the menu bar. The alphanumeric display in the text box 
shows the file name as it is being typed, then advances to display the next sequential file. 
To use this feature, you need to enable the enhanced keypad. For more information, see 
“Enabling or Disabling the Enhanced Keypad” on page 46.

n To use your numeric keys for other purposes, you may decide to disable this feature. But, 
make sure if you turn it off, you notify other operator that may be using this Deko. If not, they 
may think the enhanced keypad is broken.
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Enabling or Disabling the Enhanced Keypad

To enable or disable the enhanced keypad:

1. Select Options > Preferences.

The Preferences dialog box opens. 

2. Click the Common tab.

3. In the Keyboard area, select or deselect Enhanced Keypad. 

4. If you are enabling the Enhanced Keypad, press the NumLock key on the keyboard to 
turn it on.

5. Click OK. 

About the Optional FastAction Keyboard

The FastAction Keyboard (FAK) enables you to perform common Deko tasks with a single 
keystroke. It is designed for use in real-time on-air environments, where speed is critical. 

The FAK is based on a standard keyboard and functions as such when using applications 
other than Deko. Like a standard keyboard, the FAK provides:

• The standard PC 101 keyboard layout

• Function keys (F1-F12)

• A numeric keypad
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The FAK also provides:

• Additional keys for single-keystroke access to many of Deko’s functions

• An alphanumeric display so you can enter or view the filename of the next graphic to be 
read

• Additional functionality of the F1-F12 keys

You can enable the function keys to access the functions engraved on the keycap (such as, 
F9=Bold, F12=Spellcheck, and so on). When enabled, the function keys mirror the text bar 
functions on the Deko desktop. When disabled, you can use them as you would on a 
standard keyboard for important command functions. It is recommended that you enable 
your keyboard for FAK and disable it for SK. For more information, see “Enabling and 
Disabling the FastAction Keyboard” on page 47.

You can also enable FastAction Lights, allowing use of the dedicated Style and Color keys. 
For more information, see “Enabling or Disabling the Enhanced Keypad” on page 46.

FastAction Keyboard shortcuts are found throughout this guide and are designated FAK. 
The FastAction Keyboard is described in detail in “FastAction Keyboard Commands and 
Keys” on page 774.

Enabling and Disabling the FastAction Keyboard

To enable or disable FastAction function keys (F1 - F12):

1. Select Options > Preferences.

The Preferences dialog box opens to the Common tab.

2. In the Keyboard area, click FastAction Function Keys. A check mark appears when the 
option is enabled.

3. Click OK.

For a complete list of tasks performed by the function keys when enabled, see “Using a 
Standard Keyboard (SK) to Perform Formatting Commands” on page 783.

Enabling and Disabling FastAction Lights

To enable or disable FastAction Lights:

1. Select Options > Preferences.

The Preferences dialog box opens to the Common tab.

2. In the Keyboard area, click FastAction Lights. A check mark appears when the option is 
enabled.

3. Click OK.
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Setting your Save Preferences
To have Deko remind you to save your work before exiting:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Click the Prompts tab.

3. Select either or both of the following:

t Prompt to save before closing a window (This choice is NOT recommended for 
on-air situations where speed is critical.)

t Prompt before exiting Deko.

4. Click OK.

Using Other Applications without Exiting Deko
To use other applications without exiting Deko, do one of the following:

t Click the minimize icon at the right end of the Deko application title bar.

t Move the mouse pointer to the bottom of your screen to reveal the Windows taskbar. On 
the taskbar, click the Deko button.

t Hold Alt down and press Tab repeatedly to switch to other open applications.

n When you are ready to return to Deko, move the mouse pointer to the bottom of your screen 
to reveal the Windows taskbar. On the taskbar, click the Deko icon on the Windows desktop.

Exiting Deko
To exit Deko, do one of the following:

t Click the close button at the right end of the Deko title bar.

t Select File > Exit.

t Press Alt+F4 (SK).

n After you exit Deko, files on your Deko may still be accessed from other networked 
workstations as long as the system is on, even if your Deko is logged off of Windows.

To shut down the Deko system:

1. Exit the Deko software as described above.

2. Do one of the following:
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t Press Ctrl+Alt+Delete, and then select Shut Down.

t Click the Start button, and then click Shut Down.

A dialog box opens. 

3. Select Shut down, and then click OK. Don’t turn off the power to your system. It turns 
off automatically or displays a message on the screen when it is OK to do so. Once shut 
down, the system must be restarted before you or another user can log back on. While 
the system is shut down, files stored on your Deko are not accessible from other 
networked workstations. 
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2 Deko Overview 

In order to begin to feel comfortable using Deko, you need to learn how to adjust the 
appearance and function of your desktop. This involves learning how to select a layout, 
navigate, adjust Preferences to suit your work style, fix mistakes, type and select text, and 
create and save a graphic.

The following topics provide an overview of Deko:

• Desktop Appearance

• Setting Preferences

• Fixing Mistakes

• Typing Text

• Using an International Character Set

• Creating Graphics

• Saving Deko Graphics

Desktop Appearance

When your Deko is running, the screen of your VGA monitor is called the desktop. The 
appearance of the desktop depends on:

• The current layout, as selected from the Window menu or created by opening windows 
from the View menu. Each layout includes some of Deko's windows and is suitable for 
specific tasks. All standard layouts include a Menu Bar, a Status Bar, and a 
Command Bar.

• The currently active window. Items displayed on the menu bar, the associated menus, 
and controls displayed in other windows might change according to the tasks associated 
with the active window.

The following topics contain more information on desktop appearance:

• “Style Edit Layout” on page 52

• “Using Other Layouts for Other Tasks” on page 53

• “Navigating the Deko Desktop” on page 56
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Style Edit Layout

Initially, you should see the Style Edit layout. This is the preferred view for graphic creation 
and the most important one to learn first. The Style Edit layout is discussed fully in 
“Designing and Applying Styles” on page 77. The Style Edit layout includes the Program 
window, surrounded by (counterclockwise, from left) the Style window, Current Style 
window, Preset Style window, Shader window, and Tools window.

To open the Style Edit layout if you do not see it:

t Do one of the following:

- Select Window > Select Layout > Style Edit.

- Press Alt+F11 (SK).

Tools window

Style 
window

Shader 
window

Current Style 
window

Preset Style window
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Using Other Layouts for Other Tasks

Deko offers several standard layouts, each with the appropriate windows for different tasks. 
The three most frequently used layouts other than the Style Edit layout include the Sequence 
Playback, Effect Playback, and Motion Compose layouts.

To see other layouts:

1. Select Window > Select Layout.

A list of all layouts opens.

2. Select a layout.

Sequence Playback Layout

To create a playback sequence of graphics:

t Use the Sequence Playback layout by doing one of the following:

- Press F11 on the SK.

- Press Seq Edit on the FAK.

This layout includes the Preview window, the Program window, and the 
Sequence window.
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Effect Playback Layout

To set up and play back single effects

t Use the Effect Playback layout by doing one of the following

- Press Shift+F11 on the SK.

- Press Effect on the FAK.

This layout includes the Preview window, the Program window, and the Effect Playback 
window.
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Motion Compose Layout

To create a variety of complex on-screen moves and 3D effects:

t Use the Motion Compose layout by pressing Shift+Ctrl+M.

You can apply these effects to any elements of a graphic, providing very sophisticated 
and exciting on-screen moves. This layout includes the Preview window, the Program 
window, Timeline, Current Style window, and Tools window.

More Layouts

Other standard layouts are available. The standard layouts provide tools you need to create, 
edit, and play graphics and macros. You can also design and save custom layouts to suit your 
work style. For information about customizing layouts, see “Creating Custom Layouts” on 
page 678. 
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Navigating the Deko Desktop

You can create and play Deko graphics using the mouse and keyboard to interact with the 
various controls, menus, and windows on Deko’s desktop. Deko's menus work like those in 
other interfaces on Windows systems. Accessing files and functions with the mouse or 
keyboard is called navigating.

The following topics contain more information on navigating the Deko desktop:

• “Accessing Functions with the Menu Bar and the Mouse” on page 56

• “Accessing Functions with the Menu Bar and Alt Key” on page 57

• “Accessing Functions with Keyboard Shortcuts” on page 58

• “Accessing Functions by Pressing Alt and Another Key” on page 58

• “Accessing Windows and Layouts” on page 59

Accessing Functions with the Menu Bar and the Mouse

To access functions with the menu bar and the mouse:

1. Click any menu heading on the Deko menu bar to reveal a menu of more selections.

2. Click an item in the menu to open a dialog box or activate a function. 

3. To cancel the view of a menu, click anywhere outside the menu.
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4. To close a dialog box, click the Close button.

For example, selecting File on the menu bar reveals the File menu. Selecting File > 
Open, opens the Open dialog box that allows you to open a file.

Accessing Functions with the Menu Bar and Alt Key

To access functions with the menu bar and the Alt key:

1. Press Alt to turn on this function.

On the menu bar, File appears as a raised button.

2. Use the Right and Left arrow keys to move across the menu bar and select a 
different menu.

That menu button then appears raised.

3. Use the Down arrow to open a selected menu and scroll down its list of items.

4. Press Enter to activate a selection.

Close button
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5. Press Esc or Alt to switch off this selection process.

Accessing Functions with Keyboard Shortcuts

Many functions available through the menu bar can also be accessed by one, two or three 
simple keystrokes, called shortcuts. Learning shortcuts can save time. Shortcuts can be 
found in this documentation as well as in each menu.

In the preceding example, F9 is the keyboard shortcut to open a file. Instead of selecting File 
> Open, you could press F9 to open the Open dialog box with the SK if the FastAction 
Function keys are disabled. For the FAK, you can press Clear, Read, Ctrl+O, or Alt+F+O.

n Some function keys on your FAK are not available for standard use if you have activated 
them as FAK special function keys by selecting Options > Preferences, and then on the 
Common tab of the Preferences dialog box, selecting FastAction Function Keys.

Accessing Functions by Pressing Alt and Another Key

To access functions by pressing Alt and another key:

1. Look at the menu bar.

2. Press and hold down the Alt key, and notice which letter is underlined in the menu 
heading for the menu you wish to open. Then, press and release the key of the 
underlined letter. Do not release Alt. 

3. Press the key of the underlined letter in the item you would like to select from the menu.

Shortcut for Open function
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Accessing Windows and Layouts

The View Menu (Alt+V) provides access to all of the tools available. Selecting an item 
switches it into view (indicated by a check mark) or out of view. 

The Window Menu (Alt+W) provides access to the various layouts. 

Setting Preferences
With Preferences settings, Deko allows you to select how the user interface works. For more 
information, see “Specifying User Preferences” on page 681. Initially, you might want to 
determine a starting layout, the look and behavior of your cursor, and the color for 
transparent areas of your graphic. 

You can work with either an I-beam or a box cursor. An I-beam cursor appears to the left of 
the space where a typed character appears. A box cursor appears around the space where a 
typed character appears. 

You can also define how the cursor behaves when you press the Home or the End keys. 
Home and End key cursor behavior might be either as in typical Windows applications or as 
in conventional character generators.
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Some users want to adjust Color used where graphic is transparent. With the default setting, 
dark gray might make it difficult to tell if you are looking at a keyed transparent background 
or a black background. Choosing a color, such as dark green, helps clarify what is 
transparent in the background. The color is not displayed on the video output.

For more information, see “Determining the Look and Behavior of your Cursor” on page 60.

Determining the Look and Behavior of your Cursor

To determine the look and behavior of your cursor:

1. Select Options > Preferences.

The Preferences dialog box opens.

Dark gray default background Dark green background
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2. Click the Cursor tab.

3. In the Text cursor style area, select I-beam or Box. 

n If you are accustomed to working in a Windows environment, you might prefer an I-beam 
cursor. If you are accustomed to other character generators, you might prefer a Box cursor.

4. In the Home and End key behavior area. Do one of the following:

t Click Windows to specify that:

- Home moves the cursor to the beginning of a line.

- End moves the cursor to the end of the line.

- Ctrl + Home moves the cursor to the beginning of a text field.

- Ctrl + End moves the cursor to the end of a text field.

t Click Character generator to specify that:

- Home moves the cursor to the beginning of a text field.

- End moves the cursor to the end of a text field.

- Ctrl + Home moves the cursor to the beginning of a line.

- Ctrl + End moves the cursor to the end of a line.

5. Click OK.

6. Click Options on the menu bar.
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7. Deselect Save Settings On Exit in the Options menu. 

Generally, this option should be off to prevent unwanted saving. Deliberate saving, by 
checking Save Settings Now in the Options menu is a better practice.

8. To save your settings, select Options > Save Settings Now. 

To specify Starting layout and other Common Preferences:

1. Select Options > Preferences.

2. Click the Common tab.

3. Select a layout from the Starting layout menu. Style Edit is a good starting choice. 
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4. Click the color button under Color used where graphic is transparent. A color picker 
opens.

5. Click the desired color or use the panel to create a custom color. A medium green is a 
good choice. 

6. Click OK.

7. Depending on what type of keyboard you are using, do one of the following:

t If you’re using a FastAction Keyboard (FAK), enable Enhanced Keypad, 
FastAction Function keys and FastAction lights and enable Numlock on the keypad.

t If you’re using a Standard Keyboard (SK), enable Enhanced keypad, enable 
NumLock on the keypad, and disable FastAction Function keys. FastAction Lights 
become unavailable.

n If Enhanced Keypad and FastAction Function Keys are unavailable and cannot be selected, 
you might need to install the appropriate drivers. For more information on how to do this, 
contact Technical Support.

Some function keys on your FAK are not available for standard use if you have activated 
them as FAK special function keys by selecting Options > Preferences. On the Preferences 
dialog box, select the Common tab and select FastAction Function Keys.
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8. You might want to select the following:

t Use ‘explorer’ style file open if you want to view you graphics in a Windows 
Explorer 

t If you have ClipDeko, the second selection is Display clip representative frame. 
When selected, if you have a clip in the background or layer, a representative frame 
appears in the Program and Preview windows.

t Automatically play macros when opened if you would like commands in a macro to 
be executed when you open the macro. For more information on Macros, see 
“Streamlining Your Work with Macros” on page 713.

t  Automatically play associated effects to automatically play motion effects that you 
have associated with a graphic when you open that graphic. For more information 
on Associated effects, see “Motion Effects” on page 501.

9. Click OK.

10. To save your settings, select Options > Save Settings Now.

Fixing Mistakes
Deko allows you to undo actions one by one, beginning with the most recent. Enabling the 
Undo function allows you to undo actions, but requires more memory. Current systems, 
however, have sufficient memory to use Undo without compromising performance.

The following topics contain more information on fixing mistakes:

• “Undoing Previous Actions” on page 64

• “Deleting Text” on page 65

• “Deleting Text” on page 65

• “Clearing the Program Window” on page 65

Undoing Previous Actions

To enable or disable Undo:

t Select Edit > Enable Undoer.

n Enable Undoer is disabled as the Factory default. So, if you want the ability to use the Undo 
function, it’s a good idea to enable it.

So, they might not realize they have undo.
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To Undo the previous action(s): 

1. Do one of the following:

2. With Undo enabled, select Edit > Undo.

3. Press Ctrl+Z.

4. Press Undo (FAK).

5. Repeat for each action that you want to undo. 

n You can only undo actions performed since Deko was launched with Undo enabled.

Redoing Undone Actions

To redo undone actions:

t With Undo enabled, select Edit > Redo (Ctrl + Y). Repeat for each action that you want 
to redo.

n Deko also allows you to select and delete text or layers, or clear an entire Program or 
Preview window. 

Deleting Text

To delete text:

t Select the text, and then press the Delete key.

Clearing the Program Window

To clear the Program window:

t Do one of the following:

- Alt+F8 (SK). 

- Press F8 twice.

- Press Clear Program (FAK).

n This clears the currently active Program or Preview window. If no Program or Preview 
window is active, this clears the most recently used Program or Preview window.  
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Typing Text

You can type text in a Program window or a Preview window. When Deko is launched, the 
Preview window is underneath the Program window. Move the window slightly so you can 
see it. 

To open either a Program or Preview window

t Do one of the following:

- Press F5 on SK (if Function keys are disabled in Preferences).

- Press the Program key (FAK). 

- Press the Preview key (FAK). 

You can open and edit an existing text file. 

Typically, the Style Edit layout is preferred for typing and editing text. As text is typed, it 
appears in the current style, indicated in the Current Style window. The current style 
includes the typeface, size, color, details, and other qualities of the text. 

Changing the current style does not change previously typed text. However, you can select 
text to apply changes. For more information, see “Designing and Applying Styles” on page 
77.

All typed text appears in a text layer, sometimes called a text field. By default, a new Deko 
graphic has one text layer. For information on adding text layers and specifying text layer 
properties, see “Building Graphics with Layers” on page 151.

The following topics contain more information on typing text:

• “Confirming you are Using the Style Edit Layout” on page 67

• “Enabling or Disabling Word Wrap” on page 67

• “Selecting a Style for Your Text” on page 67

• “Adjusting Text Size” on page 68

• “Typing Text” on page 68

• “Remembering Cursor Position” on page 68

• “Changing the Home Position of the Cursor” on page 69

• “Positioning the Cursor to Edit Text” on page 69
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Confirming you are Using the Style Edit Layout

To confirm that you are using the Style Edit layout:

1. Select Window > Select Layout.

2. Select Style Edit.

Enabling or Disabling Word Wrap

There might be instances where you want to have word wrap enabled or disabled.

To enable/disable word wrap:

1. Click Text on the menu bar.

2. Click Word Wrap. Word wrap keeps your text in the appropriate area with automatic 
returns.

n The default is that Word Wrap is automatically enabled in Preferences so every text layer 
has word wrap. You can disable Word Wrap in Preferences by selecting Options > 
Preferences > Advanced.

Selecting a Style for Your Text

To select a style for your text:

t Click one of the preset buttons in the Preset Style window, or do nothing to use the style 
displayed in the Current Style window. 

For more information about determining the appearance of your text, see “Designing 
and Applying Styles” on page 77. You can create an infinite variety of styles.
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Adjusting Text Size

To adjust text size:

t Do one of the following:

- On the text bar, double-click the Size text box. With the FastAction Function (FAK) 
keys enabled, press F2. Then, type the new size, and press Enter. 

- Click the Up and Down arrows to incrementally increase or decrease the size.

- Click and hold the Up arrow or the Down arrow to continuously increase or 
decrease the size. Release the mouse button when the size you want is displayed.

- Triple-click the size text box to return to the default setting.

Typing Text

The cursor appears where you click in the window. However, clicking anywhere in the 
window can cause unwanted rows or spaces in your graphic. The best practice is to click the 
Title bar or press the Program key (or press F5 on a SK) and immediately begin typing, so 
the cursor appears in the home position. You can also enable “Remember cursor position” in 
the Preferences dialog box, so the cursor appears in the Home position for new graphics. 
Home is the starting place for text to begin in the layer, typically at the top left.

To type text:

1. Activate a Program or Preview window by doing one of the following:

t Click a Program window or a Preview window.

t Press F5 (SK).

t Press Program or Preview (FAK).

2. Click the Layer tab in the Style window and verify that Word wrap is selected. If not, 
select it.

3. Begin typing as with any Windows-based program.

Remembering Cursor Position

To have the cursor appear in its most recent position, or in the home position for new 
graphics:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Select the Cursor tab, and select Remember cursor position.

3. Click OK.
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Changing the Home Position of the Cursor

To change the home position of the cursor:

1. Click the Justify Text button on the toolbar.

A dialog box opens.

2. Select the arrow indicating how you want text to be justified, and click OK.

Positioning the Cursor to Edit Text

To position the cursor to edit text:

t Do one of the following:

- Position the mouse pointer to the desired place and click.

- Press the Left Arrow key or the Right Arrow key to move the cursor one space at a 
time.

- Press the Up Arrow key or the Down Arrow key to move the cursor one row at a 
time.

- Press Ctrl+Left or Ctrl+Right to move the cursor one word at a time.  

Using an International Character Set

Because some languages require characters not used in other languages, you might need to 
specify a character set when typing in a language other than English. A character set is a set 
of 256 characters in a TrueType® or PostScript® font. A font might contain more than 256 
characters, but Windows can access only 256 at a time. By choosing a character set, you are 
choosing which 256 characters you wish to use. Not all character sets are supported by every 
font.  A character set can be used for storing unique symbols that are not on your keyboard, 
such as Copyright, trademark, Euro, and so on A character set can also be used to store 
common language symbols like the Spanish tilde. Even if you are working in English, some 
Spanish symbols might be necessary from time to time.
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To type a character from an international character set:

1. Select View > International. 

The International window opens.

2. Click the Character Set menu, then select a character set from the menu.

3. In the Program window, position the insertion point where you wish to insert 
the character.

4. Click the desired character in the International window.

n Not all TrueType fonts include every character in every character set. The International 
window displays a small box in place of any character that is not available in the 
current font.

For more information, see “Changing the Keyboard Layout” on page 71.
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Changing the Keyboard Layout

To change the current keyboard layout:

1. Select View > Style.

2. In the Style window, select Font, then click the Keyboard menu.

3. Type or scroll to the new keyboard layout.

Deko automatically picks up the keyboard layout used to create the open graphic.

n Any keyboard layout installed in Windows is automatically available in Deko. On the 
Windows desktop, click the Start button, then select Settings > Control Panel > Regional 
Settings. For more detailed information, see the Windows documentation.

Deko supports most alphabet-based languages as well as several ideographic languages. 
For the following languages, you must install a version of Windows that supports the 
language: Arabic, Chinese, Hebrew, Japanese, Korean, and Thai.

Creating Graphics

The main function of Deko is the creation and display of graphic files. You create a Deko 
graphic, including text and background elements, in either a Preview or Program window. 
Once created, a graphic can be saved on disk in a graphic file. For more information, see 
“Managing Files” on page 389.

A graphic consists of one or more layers and a background. Each layer can be text or a 
geometric shape—a rectangle or an ellipse. You can edit selected text or entire layers. Deko 
provides a variety of tools for typing, justifying, positioning, sizing and otherwise editing 
text and shapes. For more information, see “Editing Text and Layers” on page 191.

Each character of text is rendered in a particular style, which specifies its font and look. 
Each geometric shape is rendered in a particular look. For more information, see “Designing 
and Applying Styles” on page 77.

You can also animate your graphics, by either applying Deko effects or creating your own 
motions. For more information, see “Creating Animated Graphics” on page 601.

You can recall Graphic files from disk individually. In Windows terminology, this is called 
opening a file. You can play back a series of graphic files by entering them into a sequence. 
For more information, see “Using Effects and Sequences” on page 495.
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Following are brief, introductory instructions for creating and saving graphics. If you have 
some experience with Windows, Character Generators, or both, and want to get going 
quickly, you might find these instructions useful. If you need more detail, everything in this 
section is covered more thoroughly in other chapters.

To create a Deko graphic:

1. Activate a Program or Preview window by clicking on the title bar. If desired, clear any 
previous graphic by doing one of the following:

t Press F8 (SK with FastAction Function keys disabled) once to clear all layers but 
not the background.

t Press F8 twice or press Alt+F8 to clear the layers and the background. (SK).

t Press Clear Program or Clear Preview (FAK).

The cursor should be in the Home position.

2. Type any desired text. 

3. Select the text by pressing Ctrl+Shift+A.

The text appears in the style displayed in the current style window.

4. Use any of  Deko’s compositional tools to select fonts and styles, add geometric shapes 
or text layers, position layers, and so on.

5. Save the graphic by doing one of the following:
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t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK).

Saving Deko Graphics

Every Deko system hard drive is partitioned into two drives: C and D.  The C:\ drive is 
labeled as the C:\SYSTEM drive since it is meant to store all programs that are installed on 
the system. The D:\GRAPHICS drive is larger and the best place in which to store all 
Graphic directories. Use the D:\ drive for creating new file directories is recommended. 

To save a graphic under a new name:

1. Activate the graphic window by doing one of the following:

t Click on the title bar of the window.

t Press F5 (SK).

t Press Program or Preview (FAK) to indicate where the graphic is currently 
displayed.

2. Do one of the following:

t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK).

The Save Graphic As dialog box opens.
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3. Navigate to the drive and directory where you want to store the file. Typically, you want 
to use the following drives for the following types of media:

- C: drive is for applications.

- D: drive is for graphics and static elements (.tif, .tga, .psd, and so on.).

- E: drive is for clips and audio files.

n Select Preferences > Paths for the default directory settings.

4. Type a new file name in the File Name text box, then click OK. 

n Deko automatically attaches “. dko” to the file name. Do not type a different extension.
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To save a modified graphic:

1. Activate the Graphic window.

2. To replace the previous version of the .dko file, do one of the following:

t Select File > Save Graphic. 

t Press Ctrl+S or Alt+F12 (SK).

t Press Alt+Save File (FAK).
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3 Designing and Applying Styles

Deko offers numerous ways to control and enhance the appearance of your text, including:

• Specifying a particular font.

• Adding details to your font to create a unique look.

• Filling in those details with color, ramp, texture, cel animation player, or keyhole 
shaders.

• Saving and using preset styles, including styles with fancy frames.

• Selecting and modifying existing text.

• Copying and pasting style elements.

The following topics describe how to design and apply styles:

• Styles for New or Existing Text

• Defining the Current Style for Typing Text

• Using a Preset Style

• Creating Styles

• Saving and Reusing the Styles You Create

• Working with Text and Styles
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Styles for New or Existing Text
A style is created by doing the following:

1. Choosing a  font, comprised of a typeface and its size and other specifications.

2. Composing a unique look for the font by doing the following:

a. Adding details, including frames, underlines, edges, faces, or shadows.

b. Filling in those details with shaders, which might be colors, textures, or animations, 
or  keyholes (cutouts that allow live video or other fill to show through).

Usually you define a style, labeled as the Current Style, before typing text. An 
example of the current style is displayed in the Current Style window. The current 
style is applied to any text that you subsequently type. You might, however, select 
existing text and alter its style.

When creating styles, Avid recommends that you use the Style Edit layout.

To confirm that you are using the Style Edit layout:

t Do one of the following:

- Press Alt+F11 to select the Style Edit layout.

- Select Window > Select Layout. Select a Style Edit menu item to enable it. 

For more information about styles for new or existing text, see “Style Edit Layout Windows 
and Tools” on page 79.
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Style Edit Layout Windows and Tools

The following illustration is an example of the windows and tools available in the Style Edit 
Layout.

Style window Menu bar
Text bar

Program 
window

Tools window

Current Style 
window

Preset Style window Status 
bar

Command 
bar

Shader 
window
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The following topics provide more information about Style Edit layout windows and tools:

• “Menu Bar” on page 80

• “Text Bar” on page 80

• “Style Window” on page 81

• “Program Window” on page 81

• “Tools Window” on page 81

• “Shader Window” on page 81

• “Command Bar” on page 82

• “Status Bar” on page 82

• “Preset Style Window” on page 82

• “Current Style Window” on page 82

Menu Bar

The Menu bar opens in all layouts and is useful for finding available functions. Menu 
selections vary depending on the currently active window. 

Text Bar

The Text bar is available in all layouts. The Text bar allows you to:

• Select text

• Size text

• Format text

• Justify text

• Access shaders

• Activate shaders 

For more information on Shaders, see “Using Preset Shaders” on page 134. Tools on the 
right side of the text bar are for recording macros. For more information, see “Streamlining 
Your Work with Macros” on page 713.
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Style Window

Style attributes of text and graphic elements are defined in the Style window. Pressing each 
of the four tabs at the top of the window accesses different controls. The tabs are as follows:

• Font - Provides font formatting including size, width, kerning and leading.

• Look - Allows the addition of details such as a face, an edge, a shadow, an underline, 
and a frame.

• Layer - Sets layer attributes including word wrap, scaling, and layer justification. 
Initially, there is one layer for typing text in the Program window, but you can create 
additional layers. For more information, see “Editing Text and Layers” on page 191. 

• Graphic - Allows you to link effects files and clips (with the ClipDeko option) to 
associated graphics. For more information on using files, see “Managing Files” on page 
389.

Program Window

Graphics created or opened in the Program window are simultaneously displayed on the 
video monitor. For more information about the display on your video monitor, see “Working 
with Video Input and Output” on page 699. The Program window displays the cursor, the 
safe area, carriage returns, and tab stops. These markers help you place text and other 
graphics appropriately; they do not appear on the video monitor and are not part of the video 
output.

Tools Window

The Tools window contains a palette of tools for creating, moving, and altering the shape of 
text layers and graphic elements. Many of the tools have shortcut keys that you can 
memorize so you can work faster.

Shader Window

Use the Shader window to shade, or fill in, a detail specified with the Look tab of the Style 
window. The appropriate Shader window for the currently highlighted detail opens. 
Depending on the detail selected, you see one of the following titles displayed on the Shader 
window title bar:

• Face Shader 

• Edge Shader

• Shadow Shader

• Underline Shader
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• Frame Shader

• Background Shader

Shading Details

The Shader window provides a choice of five sources for shading details:

• Color - Presents a color picker for choosing a solid color fill

• Ramp - Presents a gradient that uses different colors of your choice

• Texture - Accesses a graphic file to use as a texture fill

• Keyhole - Presents a key cutout for external fill

• CAP - Allows fill from sequential animation files

Command Bar 

The Command Bar is for playing macro files. For more information, see “Streamlining Your 
Work with Macros” on page 713.

Status Bar

The Status Bar provides useful information about the graphic in current view, including 
cursor screen position, layer selected, layer position, positioning mode status, 
insert/overwrite mode status, number lock status, file size, and time.

Preset Style Window

The Preset Style window displays samples of eight styles that you can quickly select and 
use. You are not limited to these styles only. You can create any style combination you wish. 
You can assign your own styles to the Preset Style palettes and save them as .pst files. Only 
one Preset Style window may be active at one time. The FAK Style keys refer to the active 
Preset Style window. Using the Preset Style window is discussed in “Using a Preset Style” 
on page 85.

Current Style Window

The Current Style window provides a sample of the current style selection or the style at the 
current cursor position. As text is typed, it appears in this style. In the default mode, the style 
is presented with an upper and a lower case “Aa,”  but you can alter this.
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Defining the Current Style for Typing Text

The quickest way to define a style is to select a preset style from the Preset Style window. 
You can also use controls in the Style window and the Shader window to create a style. Any 
text you subsequently type is rendered in the current style, is shown in the Current Style 
window.

This window shows sample text in the current font and look, in the actual size it would 
appear if typed in the Program window. If you are creating a style with a very large font, you 
can enlarge the window to accommodate the larger sample characters. 

By default, Deko displays samples as upper and lower case letters “Aa.” You can change 
what sample text is displayed. 

The following topics provide more information about defining the current style for 
typing text:

• “Moving the Current Style Window” on page 83

• “Resizing the Current Style Window” on page 84

• “Changing the Letter Used as Sample Text in the Current Style Window” on page 84

Moving the Current Style Window

The Current Style window can be moved anywhere on the desktop.

To move the Current Style window:

1. In the Window menu, make sure Freeze is not selected.

2. Move the mouse pointer over the window’s title bar.

3. Click the window and drag it anywhere on the desktop.
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Resizing the Current Style Window

The Current Style window can be resized to meet your needs.

To resize the Current Style window:

1. In the Window menu, make sure Freeze is not selected.

2. Move the mouse pointer anywhere over the border of the window. 

The pointer becomes a sizing tool.

3. Drag a sizing tool on the border to change the window’s size.

To return the Current Style window to its original position:

1. Move the mouse pointer over the window’s title bar.

2. Drag the window offscreen left. 

The window pops back to its original spot in the lower left corner.

Changing the Letter Used as Sample Text in the Current Style Window

Deko enables you to change the letter used as sample text in the Current Style window.

To change the letter used as sample text in the Current Style window:

1. Click to activate the Style window. 

2. Click the Font tab.

3. Click the Browse button to open the Typeface Browser window.

4. Select File > Select Sample Text.

A dialog box opens. 

5. Type new sample text.

6. Click OK or press Enter. 

The Typeface Browser, the Current Style window, and Preset Style windows display the 
first two characters that you typed. 
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Using a Preset Style

Preset styles are displayed in the Preset Style window. Although you can create any style 
you wish, using a Preset style automatically specifies the typeface, details, and all aspects of 
the Current Style, and the keyboard layout for the Style 1-8 keycaps. Once selected, a Preset 
style can be modified. If you create a new style, you can save it as a Preset style. 

To select a Preset style for typing:

1. Activate the Preset Style window (Alt+F7).

2. Do one of the following:

t Click one of the eight preset styles. 

t Press Style 1-8 (FAK).

t Press Shift+F1-F8 (SK).

That style is now the current style and appears in the Current Style window.

For more information about using a preset style, see “Using a Modified Version of a 
Preset Style” on page 85.

Using a Modified Version of a Preset Style

To use a modified version of a Preset style:

1. Press Ctrl+Shift+A to select all of the text and the endmarker you want to apply the 
Preset Style to.

n Ctrl + Shift selects all text across all layers (not usually what you want).

2. To change the font size of the style, do any of the following:

t Click on the Style window to activate it.

t Click the Font tab.

t Click the Up or Down arrows by the Size field to adjust the height of the font.



3  Designing and Applying Styles

86

3. Change any other attribute of the style. For more information, see “Creating Styles” on 
page 86.

n Style attributes can be altered at any time, in any order. 

4. To replace the original preset style with your modified version, right-click the preset 
style you want to replace. Otherwise, skip this step to keep the original preset style.

Creating Styles

Instead of using a preset style, you can create a style. Creating a style is a multi-step process 
using the Style dialog box.

To create a style:

1. Highlight the text by pressing Ctrl+Shift+A.

2. Adjust size, justification, bold, and italic specifications for your typeface.

3. Add details to your typeface, such as a face, edge, shadow, underline, or frame. 

4. Fill in each detail with a color, a ramp, a texture, a cel animation player, or a keyhole 
shader. 

Font tab

Click down arrow to reveal 
list of typefaces 

Click to reveal typeface browser, displaying 
samples of available typefaces

Click to turn on/off 
Bold or Italic

Adjust font size

Choices for typing in other 
languages

Click down arrow to reveal 
choices for automatic 
capitalization
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The style you create defines the current style and appears in the Current Style window. 
Text that you subsequently type appears in this style. You can save this style or apply it 
to one of the Preset Style buttons to use later.

n You cannot name the eight styles in the Preset Style window.  However, if you modify a style, 
name it, and then assign it to a Preset Style file, the Preset Style appears with the Style name 
under it.

The following topics provide more information about creating styles:

• “Selecting and Adjusting a Typeface” on page 87

• “Adjusting Size, Bold, Italic, and Justification Rules to the Current Style” on page 89

• “Applying Rotate, Skew, Kerning and Leading to the Current Style” on page 90

• “Adjusting the Display of Capitalization, Quotes and Spacing” on page 90

• “Typing in a Language other than English” on page 90

• “Controlling the Typeface in the Style Window” on page 91

• “Adjusting the Sharpness of a Font” on page 93

• “Adding Details to a Font” on page 93

• “Adjusting Details” on page 97

• “Applying Color, Ramp, Texture, CAP, or Keyhole to a Style Detail” on page 106

• “Using Preset Shaders” on page 134

Selecting and Adjusting a Typeface

You can select and adjust a typeface for your text.

To select a new typeface for your text:

1. Select the text by pressing Ctrl+Shift+A. 
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2. Do one of the following:

t Use the menu on the text bar.

t From the Style window, select the Font tab, and click the Typeface box to call up a 
list of available typefaces. 

t From the Style window, select the Font tab, click Browse or Press Typeface 
Browser (FAK) to open the Typeface Browser window, and type the first one or two 
letters of the typeface name to jump to that typeface or use the scroll bar.

3. Double-click a typeface sample to select it.

The typeface appears in the Current Style window.
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For more information about selecting and adjusting a typeface, see “Installing Additional 
Fonts” on page 89.

Installing Additional Fonts

Your Deko software includes a variety of standard and specialty fonts. You can install 
additional fonts at any time. 

To install fonts:

t Select Start > Control Panel > Open Fonts > File > Install New Fonts.

Adjusting Size, Bold, Italic, and Justification Rules to the Current 
Style

To adjust size, bold, italic, and justification rules of the current style:

1. Select the text by pressing Ctrl+Shift+A. 

2. Do one of the following:

t Use the text bar to select size, bold, italic and justification rules.

t Use the Style window (Font tab), to control all aspects of the current font.

n The Face, Edge, Shadow, Underline and Frame buttons are switches. If a Style does not have 
a Face, clicking the Face button adds one. If a Style has a Face, clicking the Face button 
deletes it.

Justifying text as you define a style determines how the text is justified within its layer. 
However, entire layers can also be justified. For more information, see “Moving Text and 
Layers” on page 219.

Font size Turn on Bold 
or Italic

Menu for typeface 
selection

Display lower case 
as small caps

Justification

Face 
Edge 

Shadow

Underline
 Frame
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Applying Rotate, Skew, Kerning and Leading to the Current Style

You can make adjustments to the Current Style using controls in the Style window, Font tab. 

To rotate, skew, or apply kerning and leading to the current style:

1. Select the text by pressing Ctrl+Shift+A.

2. In the Style window, Font tab, change the values in the Leading, Kerning, Rotation, 
and/or Skew fields to change your current style as desired. For more information, see 
“Controlling the Typeface in the Style Window” on page 91.

n Please note that style characteristics can be applied to an entire text layer. The result of 
applying these characteristics to the current style, or text, might be very different than 
applying them to a layer. To fully understand how to achieve the result you want, see 
“Editing Text and Layers” on page 191.

Adjusting the Display of Capitalization, Quotes and Spacing

To adjust the display of capitalization, contextual quotes, and spacing:

1. Select the text by pressing Ctrl+Shift+A.

2. Use the appropriate controls in the Style window, Font tab. For more information, see 
“Controlling the Typeface in the Style Window” on page 91. 

n Please note that style characteristics can be applied to an entire text layer. The result of 
applying these characteristics to the current style, or text, might be very different than 
applying them to a layer. To fully understand how to achieve the result you want, see 
“Editing Text and Layers” on page 191.

Typing in a Language other than English

To type in a language other than English:

1. From the Style dialog box, Font tab, select a language from the Keyboard menu. 

2. Select the appropriate Orientation (left to right, top to bottom, and so on.).



Creating Styles

91

Controlling the Typeface in the Style Window

The Style window Font tab provides the controls typeface information.

Style Window  
Font Tab Option Description 

Typeface Names the current typeface. Select a typeface from this menu. The list 
includes TrueType and Postscript fonts and Deko Custom Typefaces. The 
latter are indicated by the word “(Deko)” after the typeface name. 

Browse Opens the Typeface Browser window, showing a sample of each available 
typeface. Type the first one or two letters of the typeface name to jump to 
that typeface. Double-click a typeface sample to select it. 

Bold Selects a bold version of the current typeface. If no bold version is 
available, this item is dimmed. Select or deselect to turn on or off.

Italic Selects an italic version of the current typeface. If no italic version is 
available, this item is dimmed. Select or deselect to turn on or off.

Size Shows the height of the current font, in screen units. Click the Up and 
Down arrows or type a number in the text box. For more information, see 
“Working with User Preferences” on page 667.

Width Shows percent of normal width. Type a percent less than 100 to condense 
the font, or greater than 100 to expand it. Click the Up and Down arrows 
or type a number in the field.

Capitalization Displays a menu for changing the way Deko displays the case of typed 
characters:

• Normal - Deko displays the case of all characters as typed.

• Smallcaps - Deko displays lower case characters as small capital  
characters.

• Allcaps - Deko displays all characters as capital characters.

• Allsmalls - Deko displays all characters as lower case characters.

• Words - Deko displays the first character of each word as a capital 
character (title  case). 

Contextual Quotes Displays typed quotation marks as “true” opening and closing quotes 
based on this style.

Leading Determines row spacing by the leading value of the style applied to the 
new line character. A value of zero produces the default row spacing. 
Values greater than zero increase the space between rows; values less than 
zero decrease it.
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n For many typefaces, there is no difference between “proportional” and “digits” spacing 
because the fonts were designed with monospaced digits.

For more information about controlling the typeface in the Style window, see “Restoring a 
Numeric Parameter to Its Default Value” on page 92.

Restoring a Numeric Parameter to Its Default Value

To restore any numeric parameter in the Style window to its default value:

t In the Style window, triple-click the parameter you want to restore to its default value.

n This is true of many controls in Deko.

Kerning Controls the spacing between characters. A value of zero produces the 
default kerning. Values greater than zero increase the space between 
characters; values less than zero decrease it. 

Rotation Controls the angle of the baseline, in degrees. 

Skew Controls the amount of skew, or slant, applied to the characters. This is 
independent of the italic setting. 

Filter Controls blurring of the font. Select Hard, Medium, Soft, or Very Soft to 
blur the font, diminishing jagged lines caused by aliasing. 

Medium is the default setting. Soft makes the font blurrier. Hard makes it 
less blurry.

Spacing Selects the type of character spacing for the font:

• Proportional - characters are spaced according to their widths.

• Monospace - all characters are forced to have the same widths.

• Digits - the digits 0-9 are monospace, but all other characters are 
proportional. 

Keyboard Selects the language. Keystrokes on the keyboard correspond to 
characters in this language. 

Orientation Determines field orientation, that is, left-to-right, right-to-left (for Arabic 
and Hebrew) or top-to-bottom (for Eastern Asian languages).

n Some orientations might not be available in all languages.

Prerendered style Indicates that this style was previously rendered and saved so it can be 
rendered more quickly. 

Style Window  
Font Tab Option Description (Continued)
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Adjusting the Sharpness of a Font

Like any television or computer graphic created with pixels, some text might display 
unwanted jagged edges, or artifacts called “jaggies.” You might want to adjust the sharpness 
of your text, blurring it slightly to avoid the appearance of jaggies. Jaggies might be more 
noticeable with some fonts than others. They are more likely to be prominent with the color 
red and with smaller text.

To adjust sharpness or blurring of a font:

1. Select one of the following:

t Text

t A layer, to change all text in the layer

t Nothing, to change the current style.

2. In the Style window, click the Font tab.

3. In the Filter menu, select a Filter option. See the following table.

Adding Details to a Font

Once you have defined a font for the current style, you can add details to the font to create a 
unique look. A detail can be a face, an edge, a frame, a shadow, or an underline. You can 
adjust the size, shape, and blurring of each detail. Each detail has a shader, defining how it is 
filled. Add, remove, or prioritize details using the Look tab in the Style window. A style can 
have an unlimited number and combination of details.

The following topics provide more information about adding details to a font:

• “Displaying the Look Tab in the Style Window” on page 94

• “Adding a Face, Edge, Frame, Shadow, or Underline to the Current Look” on page 95

• “Removing a Face, Edge, Frame, Shadow or Underline from the Current Look” on page 
96

Filter Option Description

Hard Hard makes the font less blurry, but might allow some effects of 
aliasing to appear.

Medium Medium is the default setting.

Soft Soft makes the font blurrier, diminishing jagged lines.
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Displaying the Look Tab in the Style Window

To display the Style window, Look tab:

1. Access the Style Window by doing one of the following:

t Select > Style.

t Press F6 (SK).

t Press Look key (FAK). 

2. From the Style window, display the Look tab by doing one of the following:

t Click the Look button.

t Press Alt+L (SK).

t Press  Look (FAK).

n To restore any numeric parameter in the Style window to its default value, triple-click 
the parameter.

Click the Add 
button to reveal a 
list of details

Bottom area of window 
varies depending on detail 
selected in Details list 

Click the More button to 
reveal additional controls
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Adding a Face, Edge, Frame, Shadow, or Underline to the  
Current Look

To add a face, an edge, a frame, a shadow, or an underline to the current look:

1. Select the text (Ctrl+Shift+A).

2. Do one of the following:

t Use the text bar detail buttons to add the first face, edge, shadow, underline, and 
frame of a look. This method can only be used to add one of each type of detail. 
Clicking any detail buttons after the first time removes that detail.

t From the Style window:

a. Click the Look button. 

b. Click the Add button. A menu opens, enabling you to select which kind of detail to 
add (face, edge, shadow, underline, frame). 

Style Window  
Look Tab Control Description 

Details The list of details for the current look. The selected detail is highlighted, and its 
attributes are displayed in the lower half of the window. Types of details include:

• Face -the face of the characters. Most looks have only a single face, usually 
the first detail in the list of details.

• Edge - an edge around each character. The edge is based on details preceding 
it in the list of details, or a selected detail.

• Shadow - a shadow of each character. The shadow is based on details 
preceding it in the list of details, or a selected detail.

• Underline - an underline following the characters.

• Frame - a frame behind the characters.

Add Adds a new detail to the current look. A menu lets you select which kind of 
detail to add. The new detail is added after the selected detail.

Delete Deletes the selected detail.

Controls in the bottom half 
of the window

Controls vary, depending on the type of detail selected in the Detail list. Use the 
controls to modify the selected detail.
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c. Select the new detail from the list. The new detail is added to the bottom of the 
Details list or after the detail in the list that is selected. You can use this method to 
add as many of each kind of detail as you like.

t With the FastAction function keys enabled, press any of the following:

- F4 to add a Face

- F5 to add an Edge

- F6 to add a Shadow

- F7 to add an Underline

- F8 to add a Frame

You can use this method to add one of each type of detail. Pressing any detail 
buttons after the first time removes that detail.

Removing a Face, Edge, Frame, Shadow or Underline from the  
Current Look

To remove a face, an edge, a frame, a shadow, or an underline from the current look:

1. Select the text (Ctrl+Shift+A).

2. Do one of the following:

t Use the text bar Detail buttons to remove the first face, edge, shadow, underline, and 
frame, of a look. You can use this method only to remove one of each type of detail. 
Clicking any detail buttons removing that detail applies the detail again.

t From the Style window, click the Look button. In the Details list, click a detail to 
select it, then click Delete. You can use this method to delete as many of each kind 
of detail as you like.

t With the FastAction function keys enabled, press any of the following:

- F4 to delete a Face

- F5 to delete an Edge

- F6 to delete a Shadow

- F7 to delete an Underline

- F8 to delete a Frame

You can use this method only to delete one of each type of detail. Pressing any 
detail buttons after deleting the detail adds that detail.
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Adjusting Details

To adjust the dimension, shape, definition, or priority of a detail: 

1. Click on the Style window to activate.

2. Select the text (Ctrl+Shift+A).

3. Do one of the following:

t Click the Look tab at the top of the Style window.

t Press Alt+L (SK).

t Press Look (FAK).

4. In the Details list, click the Detail you want to adjust to select it. Deko displays 
attributes associated with the detail in the lower half of the Style window. You can use 
the associated controls, described in the following sections to adjust the detail you 
select.

The following topics provide more information about adjusting details:

• “Adjusting Face Detail Attributes” on page 98

• “Adjusting Edge Detail Attributes” on page 99

• “Adjusting Shadow Detail Attributes” on page 101

• “Adjusting Underline Detail Attributes” on page 103

• “Adjusting Frame Detail Attributes” on page 105
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Adjusting Face Detail Attributes

To adjust Face detail attributes, use the controls in the lower half of the Style window, Look 
tab. Face Detail attributes are only available when Face is selected in the Details List.

Hide face

Adjust blur

Opens face shader 
window/see sample

Click More to reveal 
additional controls

Controls to position 
detail relative to other 
details

Face Detail Attribute Description 

Hide Select this option to hide the face. A hidden face can still affect other details, based 
on its Priority and the “From previous detail” settings of other details. 

Shader Opens the Face Shader window. Use the Face Shader to apply a color, ramp or 
texture to the face. For more information, see “Shader Window” on page 81.

Blur Controls the amount of blur, from 0 (no blur) to 100.

Priority

(click More to display)

Determines whether the face appears in front of or behind other details. By default, 
Deko assigns a priority to the details so that they render from front to back, in the 
order in which they appear in the Details list. Use Priority to change the rendering 
order. Priority ranges from 0 (closest to viewer) to 1000 (farthest from viewer).

Priority also controls the rendering order of overlapping details from 
different styles.
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Adjusting Edge Detail Attributes

To adjust Edge detail attributes, use the controls in the lower half of the Style window, Look 
tab. Edge Detail attributes are available only when Edge is selected in the Details List.

Edge Detail Attribute Description 

Hide Hides the edge. A hidden edge can still affect other details, based on its Priority 
and “To next detail” settings. 

Shader Opens the Edge Shader window. Use the Edge Shader to apply a color, ramp or 
texture to the edge. For more information, see “Shader Window” on page 81.

Blur Controls the amount of blur, from 0 (no blur) to 100.

Shape Specifies the shape of the edge:

• Round - creates a rounded edge.

• Square - creates a rectangular edge.

Adjust priority 
among other details

Click More to turn 
to additional 
controls

Specify round or 
square edge

Adjust thickness 
of the edge

Open the Edge 
shader window/ 
see sample

Hide 
edge
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Type Specifies the type of edge:

• Outer - creates an edge that extends outward from the outer border of the 
edged detail.

• Inner - creates an edge that extends inward from the outer border of the edged 
detail.

• Border - creates an edge that extends both outward and inward from the outer 
border of the edged detail.

• Filled - creates an edge that extends outward from the outer border of the 
edged detail; the inside is filled with the edge color.

Size Controls the size of the edge, from 0 (no edge) to 100 (very large edge). 

Priority

(click More to display)

Determines whether the edge appears in front of or behind other details. By 
default, Deko assigns a priority to the details so that they render from front to 
back, in the order they appear in the Details list. Use Priority to change the 
rendering order. Priority ranges from 0 (closest to viewer) to 1000 (farthest from 
viewer).

Priority also controls the rendering order of overlapping details from different 
styles.

From previous detail Specifies which other details in the look provide the shape on which this edge is 
based:

• Face - produces an edge based only on the face detail.

• Frame - produces an edge around the first frame detail preceding the edge in 
the Details list.

• Previous - produces an edge based on the “To next detail” setting of the detail 
immediately preceding the edge in the Details list.

• Underline - produces an edge around the first underline preceding the edge in 
the Details list.

Edge Detail Attribute Description (Continued)

Outer Inner Border Filled
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Adjusting Shadow Detail Attributes

To adjust Shadow detail attributes, use the controls in the lower half of the Style window, 
Look tab. Shadow Detail attributes are only available when Shadow is selected in the 
Details List.

To next detail Determines what this edge sends to the detail immediately following it in the 
Details list:

• Previous - sends whatever was sent to the edge from the detail preceding it.

• Merged - sends the combination of the edge and whatever was sent to the edge 
from the detail preceding it.

• This - sends the edge only.

Edge Detail Attribute Description (Continued)

Hides the 
shadow

Controls blur 

Select Drop 
or Deep 
Shadow

Adjusts the distance 
of shadow from 
shadowed item

Adjusts the angle 
of the shadow

Click More to reveal 
additional controls

Controls the 
position relative 
to other details 
with Priority 
controls

Activates the Shadow 
window/see sample
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Shadow Detail 
Attribute Description 

Hide Hides the shadow. A hidden shadow can still affect other details, based on its 
Priority and “To next detail” settings. 

Shader Opens the Shadow Shader window. Use the Shadow Shader to apply a color, ramp 
or texture to the shadow. For more information, see “Shader Window” on page 81.

Blur Controls the amount of blur, from 0 (no blur) to 100.

Angle Controls the angle that the shadow is offset from the detail(s) being shadowed. An 
angle of zero produces a shadow directly preceding the shadowed detail.

Type Determines the type of shadow:

Drop - creates a single shadow of the detail being shadowed.

Deep - creates a thick shadow, as if the detail were extruded.

Size Controls the distance of the shadow, from the shadowed details.

Priority

(click More to display)

Determines whether the shadow appears in front of or behind other details. By 
default, Deko assigns a priority to the details so that they render from front to 
back, in the order they appear in the Details list. Use Priority to change the 
rendering order. Priority ranges from 0 (closest to viewer) to 1000 (farthest from 
viewer).

Priority also controls the rendering order of overlapping details from different 
styles.

From previous detail Specifies which other details in the look provide the shape on which this shadow 
is based:

• Face - produces a shadow based only on the face detail.

• Previous - produces a shadow based on the “To next detail” setting of the 
detail immediately preceding the edge in the Details list.

• Frame - produces a shadow around the first frame detail preceding the shadow 
in the Details list.

• Underline - produces a shadow around the first underline preceding the 
shadow in the Details list.

drop deep
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Adjusting Underline Detail Attributes

To adjust Underline detail attributes, use the controls in the lower half of the Style window, 
Look tab. Underline Detail attributes are only available when Underline is selected in the 
Details List.

To next detail Determines what this shadow sends to the detail immediately following it in the 
Details list:

• Previous - sends whatever was sent to the shadow from the detail preceding it.

• This - sends the shadow only.

• Merged - sends the combination of the shadow and whatever was sent to the 
shadow from the detail preceding it.

Shadow Detail 
Attribute Description (Continued)

Hide the 
Underline

Adjust the 
Priority of the 
Underline 
among other 
details

Adjust distance from text

Blur the 
Underline

Adjust thickness

Open the 
Underline Shader 
window/see 
sample

Specify square or 
rounded corners

Click More to reveal 
other controls

Extend 
beyond text
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Underline Detail Attribute Description 

Hide Hides the underline. A hidden underline can still affect other details, based 
on its Priority and “To next detail” settings. 

Shader Opens the Underline Shader window. Use the Underline Shader to apply a 
color, ramp or texture to the underline. For more information, see “Shader 
Window” on page 81.

Blur Controls the amount of blur, from 0 (no blur) to 100.

Shape Specifies the shape of the underline:

• Round - produces an underline with rounded corners.

• Square - produces an underline with rectangular corners.

Height Controls the height of the underline. The default value is 100 percent

Width Specifies an additional amount of underline that extends beyond the width 
of underlined text. A value of zero produces an underline that exactly 
matches the width of underlined text. 

V offset Specifies a vertical offset from the underline’s normal position. Negative 
values move the underline down, and positive values move it up. 

Spaces Underlines the spaces between words.

Priority 

(click More to display)

Determines whether the underline appears in front of or behind other 
details. By default, Deko assigns a priority to the details so that they render 
from front to back, in the order they appear in the Details list. Use Priority 
to change the rendering order. Priority ranges from 0 (closest to viewer) to 
1000 (farthest from viewer). 

Priority also controls the rendering order of overlapping details from 
different styles.

To next detail Determines what this underline sends to the detail immediately following it 
in the Details list:

• Previous - sends whatever was sent to the underline from the detail 
preceding it.

• This - sends the underline only.

• Merged - sends the combination of the underline and whatever was sent 
to the underline from the detail preceding it.
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Adjusting Frame Detail Attributes

To adjust Frame detail attributes, use the controls in the lower half of the Style window, 
Look tab. Frame Detail attributes are only available when Frame is selected in the 
Details List.

Blur the 
frame

Click More to 
reveal additional 
controls

Select 
rounded or 
square 
corners

Adjust priority 
among other 
details

Adjust 
height and 
width of 
frame

Frame Detail Attribute Description 

Hide Hides the frame. A hidden frame can still affect other details, based on its 
Priority and “To next detail” settings.

Shader Opens the Frame Shader window. Use the Frame Shader to apply a color, ramp 
or texture to the frame. For more information, see“Applying Color, Ramp, 
Texture, CAP, or Keyhole to a Style Detail” on page 106. 

Blur Controls the amount of blur, from 0 (no blur) to 100.
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Applying Color, Ramp, Texture, CAP, or Keyhole to a Style Detail

Deko allows you to fill, or shade, details in several ways. You can apply any one of the 
following to any detail in your style:

• A color shader, to paint the detail with a single, solid color.

• A ramp shader, to paint the detail with a four-color ramp (gradient) and an optional 
highlight.

• A texture shader, to paint the detail with a texture from another graphic file. Textures 
can be .dko files as well as other graphic files including .jpg, .tga, .bmp,  and .tif files.

Shape Determines the shape of the frame:

• Round - creates a frame with rounded corners.

• Square - creates a frame with angular corners.

Height Specifies the height of the frame.

Width Specifies the width of the frame.

H offset Offsets the frame horizontally, left or right,  relative to the detail being framed.

V Offset Offsets the frame vertically, up or down,  relative to the detail being framed.

Descenders Lowers the bottom of the frame to accommodate lowercase descender characters 
like g, j and y.

Spaces Frames the spaces between words.

Priority (click More to 
display)

Determines whether the frame appears in front of or behind other details. By 
default, Deko assigns a priority to the details so that they render from front to 
back, in the order they appear in the Details list. Use Priority to change the 
rendering order. Priority ranges from 0 (closest to viewer) to 1000 (farthest from 
viewer).

Priority also controls the rendering order of overlapping details from different 
styles.

To next detail Determines what this frame sends to the detail immediately following it in the 
Details list:

• Previous - sends whatever was sent to the frame from the detail preceding it.

• This - sends the frame only.

• Merged - sends the combination of the frame and whatever was sent to the 
frame from the detail preceding it.

Frame Detail Attribute Description (Continued)
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• A CAP (cel animation player) shader, to paint the detail with an animation. You can play 
cel animations only within the context of a motion. For more information on Custom 
motions, see “Creating Custom Motions” on page 521. Your Deko must have the CAP 
Option to use this type of shader.

• A keyhole shader to produce a detail with keyed video. 

When a detail is selected in the Style window, you adjust how it is filled in the Shader 
window. In the Style Edit layout, the Shader window is on the right side of the desktop in its 
default position. Its appearance varies according to the detail to which you are applying a 
shader.

To apply a color, ramp, texture, animation, or keyhole shader to any detail in your 
style:

1. Select the text (Ctrl+Shift+A).

2. Activate the appropriate Shader window (see instructions in “Activating a Shader 
Window for the Current Look’s First Detail” on page 108). Each detail in a look (face, 
edge, frame, shadow or underline) has its own Shader window. Only one Shader 
window may be active at a time. 

3. Use the controls in the Shader window to apply one of the five shader types described in 
the previous sections.

n You cannot use a keyhole shader in an effect. You can however, specify an entire layer as a 
keyhole on the Layer tab of the Style window, and use this keyhole layer in an effect.

With Deko1000 and Deko550, when you use a keyhole layer in an effect or a motion, the 
layer does not cut a keyhole. The layer renders as if Keyhole was not specified, but does 
perform the specified effect or motion.

Any detail can have any kind of shader. For example, a face can have a color shader, an 
edge a ramp shader, a shadow shader, and a texture shader, all within a single look. 
Multiple occurrences of the same type of detail within a look do not have to have the 
same type of shader. For example, a look with three edges can have a different shader 
for each edge. You can use the same type of shader on multiple details within a graphic. 
For example, a face, an edge, and a shadow could all have texture shaders.

In addition, each graphic’s background has its own shader. Using the background 
shader, you can make a solid, ramped or textured background for any graphic. You 
cannot apply a CAP or Keyhole shader to a background. For more information on 
Backgrounds, see Editing Text and Layers.

Any shader can be stored as a preset shader. The preset shaders can be saved in a .shd 
file for future use.
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n If Save Settings Now is selected, any current preset shader is recalled when you restart 
the program.

The following topics provide more information on applying color, ramp, texture, Cel 
animation player, or keyhole to a style detail:

• “Activating a Shader Window for the Current Look’s First Detail” on page 108

• “Activating the Shader for Any Detail in the Current Style” on page 109

• “Applying or Changing the Color of a Detail” on page 109

• “Selecting Colors using the Color Picker” on page 111

• “Selecting a Color Using the Eyedropper” on page 112

• “Creating Color Gradients Using the Ramp Shader” on page 113

• “Applying a Ramp to a Detail” on page 113

• “Applying Highlighting to a Ramp” on page 116

• “Previewing a Ramp” on page 117

• “About the Texture Shader” on page 118

• “Specifying a Default Texture” on page 119

• “Using Associated Files in the Texture Shader Dialog Box” on page 121

• “Creating Texture Shadows” on page 127

• “Using the CAP Shader Option” on page 129

• “Playing a Cel Animation” on page 134

Activating a Shader Window for the Current Look’s First Detail

To activate a Shader window for the current look’s first face, edge, shadow, underline, 
or frame:

t Click the appropriate detail shader button on the text bar. 

The title bar of the Shader window displays the appropriate name (for example, Face 
shader, Edge shader, and so on).

n If you click the shader button for a detail that is not in the Details list, Deko automatically 
adds that detail to the look of the Current Style.

Shadow Underline FrameFace Edge
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Activating the Shader for Any Detail in the Current Style

To activate the shader for any detail in the current style:

1. Activate the Style window. Do one of the following:

t Click the Look tab at the top of the Style window.

t Press Alt + L (SK).

t Press Look (FAK).

2. Click the desired detail in the Details menu to select it. Do one of the following:

t In the Style window, click the Shader button. 

t Press Shader (FAK).

The title bar of the Shader window displays the appropriate name (that is, Face shader, 
Edge shader, and so on).

Applying or Changing the Color of a Detail

To apply a solid color to, or change the color of, a detail:

1. Highlight the text (Ctrl+Shift+A).

2. Activate the detail’s shader.

3. At the top of the Shader window, select Color. The Color button near the top of the 
window displays the detail’s current color.

4. Use the color picker to pick a color. For more information, see “Selecting Colors using 
the Color Picker” on page 111.
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5. When you are satisfied with the color displayed in the bar beneath the color picker, 
right-click the Color button to set the detail’s shader to that color. The color is 
automatically applied to the detail.

See current color here.
Right click here to apply color 
shown below color picker.

See color selected here
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Selecting Colors using the Color Picker

Use the Color Picker to select colors for the color shader and ramp shader.

Color Picker with HSV as 
selected color space

Color Picker with RGB as 
selected color space

Selected Component

Unselected 
Components 

Legalize color 
button

Current Color Eyedropper

Color Picker 
Option Description 

RGB button The RGB button is used to select the RGB color space. 

Click a color on the palette, or enter numerical values up to 100 percent for each of 
Red, Green and Blue.

HSV button • Hue - The spectral shade of the color, represented by an angle (0-360) around the 
color wheel or vector scope.

• Sat - The color’s saturation, its percentage of pure color. Black, white and gray 
have zero saturation. A 100 percent saturated color is pure color—it contains no 
white or gray.

• Value - The brightness of the color (0-100),  represented by the maximum of red, 
blue or green.  While not a true luminance amount, Value is closely related to the 
brightness of a color
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To select a color using the Color Picker:

1. Select a color space by selecting RGB (Red, Green, Blue) or HSV (Hue, 
Saturation, Value).

2. Use the color picker to pick a color, or enter numerical amounts for Red, Green and 
Blue or Hue, Saturation and Value. 

3. Enter an amount for Opacity, if desired. 

4. To deposit the color into a color shader or ramp shader, right-click one of the color 
buttons near the top of the Shader window.

Selecting a Color Using the Eyedropper

The Eyedropper enables you to select a color directly from the desktop. 

To select a color from anywhere on the desktop:

1. Move the mouse pointer over the eyedropper button, then click and hold the left mouse 
button. The mouse pointer changes to an eyedropper.

2. Continuing to hold the left mouse button down, move the eyedropper anywhere on the 
desktop. With the eyedropper over the desired color, release the mouse button.

Opacity button The Opacity button controls the translucence of the color. An opacity of zero 
produces a completely transparent color, while 100 percent is completely opaque.

Selected Component Selects the color component RGB or HSV to display in the Selected Component Bar. 
In the preceding illustration, Value is the selected component. If Opacity is selected, 
Deko displays a gray scale in the Selected Component Bar.

Unselected 
Components

The large square displays the two unselected RGB or HSV components. If Value is 
the Selected Component, this square shows Hue along the vertical axis and Saturation 
along the horizontal axis. If Opacity is the Selected Component, Deko displays a gray 
scale in this square.

Current Color Shows the selected color, the color whose numerical values appear above.

Legalize Color This button turns red to warn that you have selected a color that cannot be accurately 
replicated on air. This might occur if you have chosen a very brilliant color. Click this 
button to automatically adjust your color to a legal for air color. The button then 
returns to green. 

Color Picker 
Option Description (Continued)
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Creating Color Gradients Using the Ramp Shader

The Ramp Shader allows creation of color gradients with or without highlight details. The 
four buttons represent the individual color quadrants of the gradient. In addition, an option 
with a fifth color box lets you create a highlight detail across the gradient. Color selection 
works the same as with the Color Shader.

Applying a Ramp to a Detail

To apply a ramp to a detail:

1. Activate the detail’s shader.

2. At the top of the Shader window, click Ramp. The Sample box near the top of the 
window displays the detail’s current ramp.

3. For each of the four colors in the ramp, click the color button, use the color picker, 
described in “Selecting Colors using the Color Picker” on page 111, to pick a color, then 
right-click the color button to set it to that color.

n Clicking one of the color buttons sets the color picker to that color.

Color buttons to set 
the colors for the 
four quadrants of 
the ramp.

Ramp Sample 
Box

Click to add highlight.

Click to turn on 
Ramp or Hilite 
Options

Ramp button
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4. Select the Options button and specify ramp options as desired.

5. From the Group menu, select how the ramp should be applied. In the following samples, 
the ramp is red in the top left quadrant, yellow in the top right, green in the bottom left, 
and blue in the bottom right.

t Letter applies the ramp so that all four color quadrants are represented in each letter.
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t Word applies the ramp so all four color quadrants appear in each word.

t Row applies the ramp to each row of text.
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t Page applies the ramp to the entire page of text.

6. In the Opacity text box, type a value for ramp opacity from zero (transparent) to 100 
percent (opaque). Opacity controls overall transparency of the ramp, in addition to any 
transparency in the individual colors of the ramp. 

n Make sure that you right click in the Color box to apply the Opacity to the Color or Ramp.

7. In the H Scale field, determine the width of the ramp relative to the group. 

n A setting of 100 percent matches the entire ramp to the group. For settings less than 100 
percent, the ramp is applied to only that percentage of the group. Settings greater than 100 
percent in effect enlarge the ramp, relative to the group, effectively applying only part of the 
ramp to the group. 

8. In the V Scale field, determine the height of the ramp relative to the group. 

n A setting of 100 percent matches the entire ramp to the group. For settings less than 100 
percent, the ramp is applied to only that percentage of the group. Settings greater than 100 
percent in effect enlarge the ramp, relative to the group, effectively applying only part of the 
ramp to the group.

Applying Highlighting to a Ramp

To apply highlighting to a ramp:

1. Follow the preceding instructions for applying a ramp.

2. Select the Hilite box.
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3. Use the color picker to pick a color for the highlight. 

n You can right-click the Hilite color button to set the color picker to the current highlight’s 
color.

4. When you are satisfied with the color, right-click the Hilite color button to set it to that 
color.

5. Select Options in the Shader window, and specify highlight options as desired. 
Options include:

- Highlight Size - specifies the size of the highlight relative to the height of the ramp, 
up to 100 percent. 

- Highlight Angle - specifies the angle (-360 to 360) of the highlight. An angle of 
zero produces a horizontal highlight. 

- Highlight H Offset - specifies the horizontal position of the highlight in the ramp. 
Negative values offset the highlight to the left, positive values to the right. 

- Highlight V Offset - specifies the vertical position of the highlight in the ramp. 
Negative values offset the highlight down, positive values up. 

Previewing a Ramp

To preview a ramp's appearance: 

t Look at the Ramp Gradient Sample box, near the top right of the Ramp Shader window.

All of the controls that affect the way a texture is applied are located in the Texture 
Shader dialog box. When a graphic is saved and opened on another machine (or even on 
the same machine), it looks the same.

Ramp Gradient 
Sample box
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About the Texture Shader

Textures are commonly applied to a rectangle layer as a way of incorporating design 
elements from a variety of sources into a Deko graphic.

The Texture shader allows application of a graphic file, rather than a color or a ramp, to a 
detail, or to the background. Textures can be .dko files as well as other graphic files 
including .jpg, .tga, .bmp, .tif, and .psd files. Any graphic can be applied as a texture.

n Only .tga and .tif files with alpha channels and .psd files can be imported into Deko and used 
as keyable elements.

A texture file is referred to by the file name on disk, and multiple Deko graphics can use the 
same texture file. The texture name appears in the “File name” control.

A texture is applied to a single “detail” of a “look” that is used on an object (rectangle, 
ellipse, character, or background). The texture is applied according to the controls in the 
texture shader. The controls determine grouping, scaling, positioning, and opacity.

For a rectangle or ellipse, the normal choice for group is “letter.” This ensures that, as the 
rectangle is scaled or repositioned, the texture follows. 

To use a texture as a “cutout” from the original, select page as the group. Now, when the 
rectangle is repositioned, you get a different portion of the texture. 

For text, you can group characters by word, row, or (individual) character. 

For a “cutout” effect, select page as the group. 

For a background texture, it is sometimes useful to break the link to the named texture file.  
This is done by deselecting the File name control. Deko then indicates that the texture is 
“unnamed.” When the graphic is saved, the bitmap from the original texture file is included, 
so that the original named file is no longer important for this graphic. The size of the graphic 
increases to accommodate this bitmap.

If a texture cannot by found by name, Deko displays black in its place. You can, however, 
specify a default texture to be displayed any time that Deko cannot find an associated 
texture.

You can add a texture shadow. See “Creating Texture Shadows” on page 127.
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Specifying a Default Texture

Texture files are referred to by the file name on disk.

To specify a default texture to display in place of missing texture files:

1. Open or create the graphic you wish to use as a default texture.

2. Save it in your current graphics directory as txtr_not_found.tga.

3. To apply a texture to a detail:

a. Activate the detail’s shader.

b. Click the Texture button at the top of the Shader window. The Texture Shader 
opens.

4. Do one of the following:

t In the File text box (in the Shader window), type the name of the texture file.

t In the Shader window, press Browse, then double-click a thumbnail in the Texture 
Browser. 

t Select File > Open, and navigate to the file you want.
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You see a sample of the file you selected in the Shader window.

5. In the Shader window, specify texture options as desired. For definitions of texture 
options, see “Creating Color Gradients Using the Ramp Shader” on page 113.

6. From the Group list, select letter to make the texture “stick” to the layer regardless of 
screen position. This is especially useful if, for example, you are using rectangle layers 
displaying headshots or banners as their textures. If you need to move the layer, for 
example to allow space for a lower third crawl, the texture sticks to the layer. 

Click Browse to activate 
Texture Browser
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Using Associated Files in the Texture Shader Dialog Box

The Texture Shader dialog box includes functionality for working with non-Deko files (for 
example, .bmps, .tif, .tga, .psd, and so on.). When you open a non-Deko graphic in the 
graphic window, it becomes an unnamed texture in the Background of the graphic. If you 
select the Filename option, the original filename can be found and referenced. Now, the two 
files are associated but separate files. Any edits made to this texture automatically update in 
the Deko graphic. In this way, many Deko graphics could reference one texture and a single 
edit of the texture would update to all graphics that reference that texture.

Only the Background Shader is able to embed a texture file. Since textures in layers are 
always Associated files, any changes to those Associated files automatically update the 
master graphics that use them. If the Associated files are deleted, any graphics that use those 
files do not air properly. For more information, see “Changing the Pixel Aspect of the 
Source Graphic (for Non-Deko Texture Files)” on page 125.

To access the Texture Shader dialog box:

1. Select View > Shader.

2. Click the Texture button.
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3. Click the Source, Usage, or Shadow button. See the following tables for details on the 
options available.

The following table describes the options in the Source area of the Texture Shader 
dialog box.

Texture Shader 
Source Option Description 

File name Displays the name of the texture file. If the File Name option is selected (the default), 
Deko saves only the name of the texture file when saving the graphic. Any changes you 
make to the texture file are reflected in the graphic, as well. When you open an imported 
graphic as a Texture in the Background Shader window, it becomes a named texture and a 
check mark appears in the File name field. With the selected file name enabled, the texture 
is referenced. Any changes to the referenced texture file automatically updates any 
graphics that use it. These are referred to as Associated files. To embed the texture 
permanently, deselect the File name box. 

For a background texture, you can deselect File Name to have Deko save the bitmap from 
the original texture as part of the graphic. The word “unnamed” appears in the File Name 
text box to indicate that the texture is being stored with the graphic. The graphic increases 
in size by approximately the size of the texture file. Any subsequent changes you make to 
the original texture file do not affect the texture bitmap saved with the graphic.

Auto Replace This option, when selected, tags the texture for replacement with a user-specified texture 
when the replace_texture command is issued or via Automation.
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The following table describes the options in the Usage area of the Texture Shader dialog 
box.

Pixel Aspect Enables you to specify the pixel aspect of a non-Deko texture file. When using a .dko file 
as a texture, the Pixel aspect field is not available.

• Square(1.0) - select this if the original file has square pixels. This is appropriate for 
most “computer - generated” files (.bmp, and so on.) as well as files created in most 
HD resolutions (1080i, 720p, and so on.)

• NTSC(.9) - select this if the original file uses NTSC pixels. This is appropriate for 
most files that have dimensions of approximately 720 x 486 and are intended for use at 
a 4 x 3 screen aspect. 

• AL(1.07) - select this if the original file uses PAL pixels. This is appropriate for most 
files that have dimensions of approximately 720 x 576 and are intended for use at a 4 x 
3 screen aspect. 

• NTSC_Wide(1.2) - select this if the original file uses NTSC wide pixels. This is 
appropriate for most files that have dimensions of approximately 720 x 486 and are 
intended for use at a 16 x 9 screen aspect. 

• PAL_Wide(1.42) - select this if the original file uses PAL wide pixels. This is 
appropriate for most files that have dimensions of approximately 720 x 576 and are 
intended for use at a 16 x 9 screen aspect. 

• 1035i(.96) - select this if the original file uses 1035i pixels. This is appropriate for files 
created at the 1035i resolution (rare).

Texture Shader 
Source Option Description (Continued)

Texture Shader 
Usage Option Description 

Group Specifies how the texture should be applied:

• Letter - applies the texture individually to each letter (or rectangle/ellipse). This 
choice is preferred to make the texture “stick” to the object.

• Word - applies the entire texture graphic individually to each word.

• Row - applies the entire texture graphic individually to each row of text.

• Page - applies the texture as an entire page. Use this choice when you want to cut out 
a different piece of the texture, based on the object position.
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Auto Scale Automatically scales texture based on the object (rectangle, ellipse, character) and its 
grouping (letter, word, row, page). Select a scaling method from the menu:

• None - specifies that the texture is not autoscaled.

• Fit - scales the texture to fit the dimensions of the object.

• Preserve - preserves the image’s aspect ratio, but pads the top and bottom or the right 
and left sides to fit the dimensions of the object.

• Crop - preserves the image’s aspect ratio, but removes part of the top and bottom or 
part of the left and right sides to fit the dimensions of the object.

• Fullscreen - displays the graphic at full screen size by positioning the center of the 
texture over the center of the object without zooming. This allows you to move the 
layer to select the portion of the texture that will be scaled to full screen.

• Zoom - select this option for working with the rectangle in its default (hidden) state.

• Zoom_Show - select this option for working with a visible rectangle (displaying in 
semi-transparent red.)

• Zoom_Edit - select this option to see the entire background texture on the screen, 
without zooming. This allows you to move the layer to select the portion of the 
texture that will be scaled to full screen. 

Opacity Controls the texture’s opacity, from zero (transparent) to 100 (opaque). Make sure that 
you right-click in the Color box to apply the Opacity to the Color or Ramp.

H Scale Scales texture horizontally based on user-specified value. H Scale works in addition to 
the Autoscale feature.

V Scale Scales texture vertically based on user-specified value. V Scale works in addition to the 
Autoscale feature.

H Offset Offsets the texture relative to its horizontal alignment.

V Offset Offsets the texture relative to its vertical alignment.

H Alignment Specifies how the original texture is aligned with the selected detail(s), depending on the 
Group setting:

• Left - aligns the left edge of the texture with the left edge of the group.

• Center - aligns the center of the texture with the center of the group.

• Right - Aligns the right edge of the texture with the right edge of the group.

• Left+Right - aligns the left edge of the texture with the left edge of the group and the 
right edge of the texture with the right edge of the group. You can use this setting to 
make “fancy” frames. For more information, see “Creating Styles with Fancy 
Frames” on page 358.

Texture Shader 
Usage Option Description (Continued)
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The following topics provide more information on using associated files in the Texture 
Shader dialog box:

• “Changing the Pixel Aspect of the Source Graphic (for Non-Deko Texture Files)” on 
page 125

• “Changing the Auto Scale Parameters” on page 125

• “Filling a Detail with Keyed Video” on page 126

• “Creating Texture Shadows” on page 127

Changing the Pixel Aspect of the Source Graphic (for Non-Deko Texture Files)

To change the pixel aspect of the source graphic, select the pixel aspect you want to change 
to from the Pixel Aspect menu. See the table in “Using Associated Files in the Texture 
Shader Dialog Box” on page 121 for more information.

n This feature is only available for non-Deko texture files. 

Changing the Auto Scale Parameters

To change the Auto Scale parameters, select the item that best meets your needs. Options are 
as follows:

• Fit - If Fit is selected, the graphic is stretched in both directions to fit in the box you are 
applying it to.

• Crop - If Crop is selected, when the graphic is placed in a box, it is cropped in one 
parameter (top, or bottom, or left or right) while maintaining the aspect ratio of the 
original image.

% from left Used for the H Alignment “Left+right” only. Specifies the portion of the object that is 
textured from the left edge of the texture; the remaining portion is textured from the 
right edge of the texture. 

V Alignment Specifies how the original texture is mapped onto the selected detail(s), depending on 
the group setting:

• Top - aligns the top of the texture with the top of the group.

• Middle - aligns the middle of the texture with the middle of the group.

• Baseline - aligns the middle of the texture with the baseline of the group.

• Bottom - aligns the bottom of the texture with the bottom of the group.

Texture Shader 
Usage Option Description (Continued)



3  Designing and Applying Styles

126

• Preserve - If Preserve is selected, Deko makes sure you can fit the entire area of the 
image in the box. However, if it doesn’t fit exactly, the image shows an extra transparent 
padding on the top and bottom (for 16:9 to 4:3 conversions, also called “Letter boxing”), 
or left and right sides (for 4:3 to 16:9 conversions, also called “Pillar boxing”) while 
maintaining the aspect ratio of the original image. You do not lose any of the image.

• None - If none is selected, the graphic is brought in at the current size.

Filling a Detail with Keyed Video

Using the Keyhole Shader allows you to apply a key cutout to a detail. By applying an 
external fill source, you can fill a detail element with live video. For more information, see 
“Working with Video Input and Output” on page 699.

n With Deko1000 and Deko550, when you use a keyhole layer in an effect or a motion, the 
layer does not cut a keyhole. The layer renders as if Keyhole was not specified, but does 
perform the specified effect or motion.

To apply keyed video to a detail:

1. Activate the detail's shader.

2. At the top of the Shader window, select Keyhole. The Current Style window displays the 
detail with a keyhole fill pattern indicating the key. The detail Shader button on the text 
bar  displays it as well. The text detail appears in the Program window as the color you 
have selected in the Preferences dialog box to represent transparencies. The keyhole 
cuts through everything behind it, creating a transparent hole in your graphic. In your 
output monitor, the detail displays video from Deko's current input source. 
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n Make sure the Video Input plane is turned on to see this in your output.

Creating Texture Shadows

The Texture Shadow feature allows a shadow to be dynamically added to a texture. Texture 
shadows work by using a texture bitmap to create a monochrome, blurred shadow, which is 
composited behind the texture. 

Controls for direction, distance, blur, color, and opacity are available.

Texture Shadows are primarily used on textures with key (that is, head shots, station logos, 
and so on). 

n For optimum viewing of the shadow, either turn on a video input or select a background 
color that best contrasts with the shadow color.

Keyhole design indicates where  video 
will show through.
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To create add a shadow to a texture:

1. Select View > Shader. 

A dialog box opens.

2. Click the Texture button.

The Texture options appear.

3. Click Shadow.

4. Select the Add Shadow option to enable the shadow. 

5. (Option) To disable the shadow, deselect the option.

6. Determine the direction that you want the shadow to appear in relation to the texture by 
typing the numerical value that is equivalent to the following directions.

Shadow Direction Direction value

North 0
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7. Change the distance of the shadow in relation to the texture by typing the numerical 
value that is equivalent to the distance that you want the shadow to be offset from the 
texture. 

8. Change the amount of blur you want the shadow to display by typing a value in the Blur 
text box.

- 0 = no blur

- 100 = heavy blur

9. Change the color of the shadow using the eyedropper to select a color from the presets, 
or anywhere on the desktop.

The shadow color changes.

10. (Option) For opacity control, use the eyedropper over a preset that contains opacity.

Using the CAP Shader Option

n To see if this option is enabled on your system, select Options > Enabled Options.

CAP stands for Cel Animation Player. The CAP Shader allows you to apply prebuilt 
animation sequences to a detail. Animation sequences are built from a series of individual 
graphic files, such as .tga files. The files are played rapidly in sequence creating the illusion 
of motion like pages in a child's flipbook.

A typical way to use the CAP shader is to create a shape layer and select CAP for the shape's 
face shader. The CAP element does not appear until it is triggered in a Motion. For more 
information, see “Building Graphics with Layers” on page 151.

North East 45

East 90

South East 135

South 180

South West 225

West 270

North West 315

North 360

Shadow Direction Direction value
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When a CAP is applied to a detail, Deko reads in the CAP file series and displays the first 
one as a static graphic on the detail. Deko only plays the cel animation in the context of a 
motion.

n A graphic can accommodate more than one animation. Performance might degrade as Deko 
encounters large animations or a lot of details in a graphic. A rough limit for the size of an 
individual frame for a CAP shader that plays in real time is approximately 1/9 of the screen 
size in NTSC (if this is the only motion playing). So, since NTSC is 720 x 486 = 350,00 
pixels, the file size of an individual frame should be no more than about 39,000 pixels (x 4 
bytes per pixel = 156 kilobytes, uncompressed).

To see if your Deko has the CAP Shader Option enabled: 

t Select Options > Enabled Options. 

A check mark next to an option indicates that it is enabled on your system.

To apply a cel animation (CAP) to a detail:

1. Open the detail’s shader.

2. At the top of the Shader window, select CAP.
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3. Specify CAP options as desired.

The following table describes the Source options in the CAP Shader dialog box.

Cap Shader 
Source Option Description

File Name Indicates the first file name of the animation. Each file (cel) within the animation should 
be named with successive cel numbers, for example, globe001.tga, globe002.tga, 
globe003.tga, and so on. There are two File Open options:

• Square Pixels Preserve Height - Adjusts the width to maintain the aspect ratio of 
pixels assumed square.

• No Scaling  - specifies square pixels without any scaling.

Images Displays the number of cels (files) to play. Deko defaults to a number based on the 
assumption that the animation ends when it encounters a file name that breaks the 
sequence of numbers. 
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The following table describes the Usage options in the CAP Shader fields.

Open This button displays the Select CAP File dialog box for you to open the graphic file you 
want to use for the animation.

Pixel Aspect Enables you to specify the pixel aspect of a non-Deko image file. 

• square(1.0) - select this if the original file has square pixels.  This is appropriate for 
most “computer - generated” files (.bmp, and so on.) as well as files created in most 
HD resolutions (1080i, 720p, and so on.)

• ntsc(.9) - select this if the original file uses “ntsc” pixels. This is appropriate for most 
files that have dimensions of approximately 720 x 486 and are intended for use at a 4 
x 3 screen aspect. 

• pal(1.07) - select this if the original file uses “pal” pixels. This is appropriate for most 
files that have dimensions of approximately 720 x 576 and are intended for use at a 4 
x 3 screen aspect. 

• ntsc_wide(1.2) - select this if the original file uses “ntsc wide” pixels. This is 
appropriate for most files that have dimensions of approximately 720 x 486 and are 
intended for use at a 16 x 9 screen aspect.  

• pal_wide(1.42) - select this if the original file uses “pal wide” pixels. This is 
appropriate for most files that have dimensions of approximately 720 x 576 and are 
intended for use at a 16 x 9 screen aspect.  

• 1035i(.96) - select this if the original file uses “1035i” pixels. This is appropriate for 
files created at the 1035i resolution (rare).

Cap Shader 
Source Option Description

Cap Shader 
Usage Option Description

Forward/ Backward Specifies in which direction the animation plays.

Oscillate Reverses direction of the animation each time it plays.

Rate (per sec) Defines the rate of animation playback in images per second.

Continuous Plays cel animation through any pause in the motion. Automatically puts a pause at the 
end of the motion so that the animation continues when the motion ends.
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n When you use a CAP shader in a motion, it continues to play for the full duration of the 
motion (by looping back to the beginning, if necessary). If you selected the Continuous 
option, the system automatically inserts a pause at the end of the motion and loops 
continuously. If you want the motion to stop, you need to trigger it to stop.

The following table describes the Playback options in the CAP Shader fields.

Cap Shader 
Playback Option Description

Auto Scale Automatically scales texture based on the object (rectangle, ellipse, character) and its 
grouping (letter, word, row, page). Select a scaling method from the menu:

• None - specifies that the texture is not autoscaled.

• Fit - scales the texture to fit the dimensions of the object.

• Preserve - preserves the image’s aspect ratio, but pads the top and bottom or the right 
and left sides to fit the dimensions of the object.

• Crop - preserves the image’s aspect ratio, but removes part of the top and bottom or 
part of the left and right sides to fit the dimensions of the object.

• Fullscreen - displays the graphic at full screen size by positioning the center of the 
texture over the center of the object without zooming. This allows you to move the 
layer to select the portion of the texture that will be scaled to full screen.

• Zoom - select this option for working with the rectangle in its default (hidden) state.

• Zoom_Show - select this option for working with a visible rectangle (displaying in 
semi-transparent red.)

• Zoom_Edit - select this option to see the entire background texture on the screen, 
without zooming. This allows you to move the layer to select the portion of the 
texture that will be scaled to full screen. 

Opacity Controls the image’s opacity, from zero (transparent) to 100 (opaque). 

H Scale Scales image horizontally based on user-specified value. H scale works in addition to the 
Autoscale feature.

V Scale Scales image vertically based on user-specified value. V scale works in addition to the 
Autoscale feature.

H Offset Offsets the image relative to its horizontal alignment.

V Offset Offsets the image relative to its vertical alignment.
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Playing a Cel Animation

You can play your cel animation using the windows and tools described in “Creating 
Animated Graphics” on page 601. 

To keep a cel animation playing once a motion ends:

t In the Shader window, under CAP shader options, select Continuous. 

Deko automatically puts a pause at the end of the motion so that the animation continues 
when the motion ends.

Using Preset Shaders

Instead of using the controls to custom define a shader, you can use any of the 18 Preset 
Shader buttons appearing at the bottom of the Shader window. You can also assign a shader 
that you have defined to one of the preset buttons. Any type of shader can be assigned to any 
preset.

To use a Preset Shader:

1. Select the text or layer you want to apply the Preset shader to.

2. Do one of the following:

t Click on one of the 18 Preset shader windows.

t Use the 8 FAK Color keys to apply the first 8 preset shaders.

t Press Alt+F (SK).

The following topics provide more information on using Preset shaders:

• “Opening a Preset Shader File” on page 135

• “Applying a Preset Shader to a Detail” on page 135

• “Assigning the Current Shader to a Preset Shader Button” on page 135

• “Saving the Current Preset Shaders” on page 135

• “Resetting the Preset Shader Factory Defaults” on page 136

Left-click to use 
a preset shader.

Right-click on a preset 
style button to assign a 
current shader style to a 
preset. 
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Opening a Preset Shader File

To open a Preset shader file:

1. Select the text or shape.

2. Activate the Shader window.

3. Select File > Open.

4. In the File Open dialog box, make sure the List Files of Type menu is displaying 
SHADER (*.shd). Navigate to the Preset shader file you want. 

5. Click OK. Your Preset shaders display in the Preset shader section of the 
Shader window.

Applying a Preset Shader to a Detail

To apply a Preset shader to a detail:

1. Activate the detail’s shader.

2. In the Shader window, click the Preset button.

Assigning the Current Shader to a Preset Shader Button

Assigning a Preset shader to a Preset shader button, replaces the shader currently assigned to 
the button you select. 

To assign the current shader to a Preset shader button:

t Do one of the following:

- Right-click the Preset shader button.

- Activate the Shader window (F7), then select Preset Shader Set from the Shader 
menu and select a preset shader from the menu.

Saving the Current Preset Shaders

To save the current Preset shaders:

1. Activate the Shader window by doing one of the following:

t Press F7 (SK).

t Press Shader (FAK).

2. Do one of the following:

t Save preset shaders under the current .pst file name, by selecting File > Save Preset 
Shaders.
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t Save preset shaders, assigning them a new name by selecting File > Save Preset 
Shaders As.

3. If saving under a new name, do the following in the Save As dialog box:

a. Navigate to the drive and directory where you want to store the file.

b. Type a name in the File Name text box.

c. Click OK or press Enter. 

n When you save a Preset shader file, Deko automatically attaches “.shd” to the file name. Do 
not type a different extension.

Resetting the Preset Shader Factory Defaults

To reset the Preset Shader factory defaults:

1. Activate the Shader window.

2. Select Shader > Reset to Defaults.

Saving and Reusing the Styles You Create

Once you have selected a preset style, modified a preset style, or created a new style, you 
can use the style in the graphic you are creating. You might also want to save the style for 
future use so that you do not need to recreate it.

If you plan to use a style frequently, you might want to assign it to a Preset style button. 
Groups of up to eight styles that you often use together can be assigned to a Presets file. You 
can have as many Preset Style windows as you like.

Any style can be saved as a .sty file for later use. 

n Some users prefer to save complicated styles as prerendered styles. This ensures that they 
appear quickly if typed “on the fly.” However, with substantial improvements in Deko 
software and hardware, current releases perform well when displaying styles that are 
not prerendered.



Saving and Reusing the Styles You Create

137

Assigning the Current Style to a Preset Style Button

To assign the current style to a preset style button:

1. If the Preset Style window is not visible, select View > Preset Styles (Alt+F7).

2. Right-click a Preset style button. The Current Style is assigned to that button, replacing 
its existing style. 

n If Save Settings Now is selected, any current preset shader is recalled when you restart the 
program.  

Create Style in the Style 
window. 

See sample of the style in 
the Current Style window

Right click on a preset style 
button to assign Current 
style to that button.
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Saving Styles

Deko provides you with many options for saving the various types of styles. 

The following topics provide more information on saving styles:

• “Saving Modified Preset Styles” on page 138

• “Saving the Eight Preset Styles in a new Presets File” on page 138

• “Saving or Renaming a Style” on page 139

• “Saving a Modified Style” on page 139

• “Saving the Current Style as a Prerendered Style” on page 139

Saving Modified Preset Styles

To save modified preset styles:

1. Activate the Preset Style window by pressing Alt+F7 (SK).

2. Select File > Save Preset Styles. 

Deko replaces the previously saved version of the file.

Saving the Eight Preset Styles in a new Presets File

To save the eight preset styles in a new Presets file:

1. Activate the Preset Style window by pressing Alt+F7 (SK).

2. Do one of the following:

t Select File > Save Preset Styles As.

t Press F12 (SK).

t Press Save File (FAK).

3. In the dialog box, navigate to the drive and directory where you want to store the file.

4. Type a new file name in the File Name text box, then click OK or press Enter.

n When you save a preset style file, Deko automatically attaches “.pst” to the file name. Do 
not type a different extension.
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Saving or Renaming a Style

To save an unnamed style or to rename a style:

1. Activate the Style window (F6).

2. Do one of the following:

t Select File > Save Style As.

t Press F12 (SK).

t Press Save File (FAK).

3. In the dialog box, navigate to the drive and directory where you want to store the file.

4. Type a file name in the File Name text box.

n You can also name a Style, then assign it to the Preset Style window. A custom name appears 
in the Preset Style window.

5. Click OK or press Enter.

n When you save a style file, Deko automatically attaches “.sty” to the file name. Do not type 
a different extension.

Saving a Modified Style

To save a modified style:

1. Activate the Style window (F6).

2. Do one of the following:

t Select File > Save Style As.

t Press Ctrl+S or Alt+F12 (SK).

t Press Save File (FAK).

  Deko replaces the previously saved version of the file. 

Saving the Current Style as a Prerendered Style

To save the current style as a prerendered style:

1. Activate the Style window (F6).

2. From the File menu, select Render and Save Style, then navigate to the drive and 
directory where you want to store the file.

3. Type a file name in the File Name text box, then click OK or press Enter.
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n When saving a prerendered style, Deko renders each character in the style’s font, using the 
style’s look. For complicated styles, this can take several minutes.

A prerendered style file occupies more disk space than a normal style file. However, when 
you type prerendered characters, they appear more quickly than characters that must be 
rendered “on the fly” as they are typed. Prerendered styles are indicated at the bottom of the 
Style/Font window by a check next to Prerendered Style, and in the Preset Style window by 
an (R) in front of the typeface name.

Retrieving Styles

Deko enables you to retrieve a style from either a Preset (.pst) file, or Style (.sty) file.

To retrieve a style from a preset styles (.pst) file:

1. Press Alt+F7 to activate the Preset Style window.

2. Open the File Open dialog box by doing one of the following:

t Select File > Open.

t Press Ctrl+O or F9 (SK).

t Press Clear+Read (FAK).

The dialog box opens.

3. Navigate to the drive and directory that contain the preset styles file.

4. Type the file name in the File Name text box or select it from the File Name menu, then 
click OK or press Enter.

5. In the Preset Style window, click a Preset button. That preset is now the current style.

To retrieve a style from a style (.sty) file:

1. Activate the Style window (F6).

2. Open the Open File dialog by doing one of the following:

t Select File > Open.

t Press Ctrl+O or F9 (SK).

t Press Clear+Read (FAK).

The dialog box opens. 

3. Navigate to the drive and directory that contain the style file.

4. Type the file name in the File Name text box or select it from the File Name menu.

5. Click OK or press Enter. 

The style in the .sty file is now the current style.
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Working with Text and Styles

You can change any style attributes of text in the Program window. If you typed text or 
opened a file into the Program window, you can select some or all of the text and apply the 
desired changes.

n If you change text properties without selecting any text, you change the Current Style. This 
affects the next characters typed, but not the existing text.

The following topics provide more information on working with text and styles:

• “Selecting Text” on page 141

• “Deselecting Text” on page 143

• “Modifying Selected Text” on page 143

• “Deleting and Clearing Text or Program Window” on page 146

• “Cutting, Copying, and Pasting Details and Styles” on page 147

Selecting Text

In Deko there are many different ways to select text.

The following topics provide more information on selecting text:

• “Selecting a Block of Text” on page 141

• “Selecting Multiple Blocks of Text” on page 142

• “Selecting a Word” on page 142

• “Selecting all Text in a Row” on page 142

• “Selecting all Text in a Text Layer” on page 142

• “Selecting all Text Characters in a Graphic” on page 143

• “Selecting all Text Characters in the Current Style” on page 143

Selecting a Block of Text

To select a block of text:

t Do one of the following:

- Click and drag the mouse across, then down or up the text you want to select.

- Use the arrow keys to move the cursor to the beginning or end of the text block, then 
hold Shift and press arrow keys as necessary.
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Selecting Multiple Blocks of Text

To select multiple blocks of text:

t Do one of the following:

- Hold Ctrl as you drag the mouse across, then down or up the text you want to select.

- Select Edit > Select More. 

- For each block of text, use the arrow keys to move the cursor to the beginning or 
end of the text block, then hold Shift and press the arrow keys to select the block.

Selecting a Word

To select a word:

t Do one of the following:

- Double-click the word.

- Use the arrow keys to move the cursor to the beginning or end of the word, then 
hold Shift and press the Right arrow or the Left arrow.

Selecting all Text in a Row

To select all text in a row:

t Triple-click anywhere in the row.

Selecting all Text in a Text Layer

To select all text in a text layer:

t Do one of the following:

- From the top left of the text, drag the mouse across, then down the text you want to 
select.

- Press Ctrl+Shift+A (recommended).

- Verify that you are in Insert mode by looking at the bottom right of your desktop for 
the letters INS. If you see OVR instead, click to turn it to INS. Then, press the Tab 
key to move to the text layer. 

- Select Edit > Select Field.
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Selecting all Text Characters in a Graphic

To select all text characters in a graphic:

t Do one of the following:

- Select Edit > Select All.

- Press Ctrl+A.

Selecting all Text Characters in the Current Style

To select all text characters in the current style:

t Select Edit > Select Style.

Deselecting Text

To deselect text:

t Do one of the following:

- Click anywhere in the text layer.

- Press any arrow key.

Modifying Selected Text

To modify selected text in any way:

t While the text is selected, use the same procedures as you would to make the desired 
changes to the Current Style. 

n The end of row marker must be selected with the text for the layer to respond to style 
changes. 

While the text is selected, the Current Style is not affected.

The following topics provide more information on modifying selected text:

• “Applying a Font to a Typeface” on page 144

• “Changing Normal Text to Bold” on page 144

• “Changing Normal Text to Italic” on page 145

• “Underlining Text” on page 145

• “Changing how Selected Text displays the Case of Typed Characters” on page 145
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Applying a Font to a Typeface

To apply a font or typeface:

1. Select the text to which you want to apply to the new typeface. If no text is selected, 
Deko applies changes to the current style.

2. Do one of the following:

t Select View > Browser, then select File > Browse Typefaces.

t Press Browse Typefaces (FAK).

t On the text bar, click the Typeface menu.

t In the Style window, select Font, then click Browse.

t In the Style window, select Font, then click the Typeface menu.

3. Double-click a typeface on the browser, click the menu, or type the name of the typeface 
in the text box.

n If you select a custom typeface, Deko automatically sets the font to the size at which no 
scaling occurs. You can then select any font size.

Changing Normal Text to Bold

To change normal text to bold:

1. Select the text to be changed, or select nothing to change the current style.

2. Do one of the following:

t Press the Bold button on the text bar (Ctrl+B).

t Activate the Style window, select Font at the top of the Style window, then select 
Bold. 

t Press Bold (FAK).

3. To change text back to normal, click the bold button (Ctrl+B) or deselect Bold.
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Changing Normal Text to Italic

To change normal text to italic:

1. Select the text to be changed, or select nothing to change the current style.

2. Do one of the following:

t Press the Italic button on the text bar (Ctrl+I).

t Activate the Style window, select Font at the top of the Style window, then select 
Italic. 

t Press Italic (FAK).

3. To change text back to normal, click the Italic button (Ctrl + I) or deselect Italic.

Underlining Text

To underline text:

1. Select the text to be underlined, or select nothing to add an underline to the current style.

2. Do one of the following:

t Click the Underline button on the text bar (Ctrl+U). 

t Press Underline (FAK).

3. To change text back to normal, click the Underline button (Ctrl + U). 

n An underline might also be added as a style detail in the Look tab of the Style window. For 
more information, see “Adding Details to a Font” on page 93.

Changing how Selected Text displays the Case of Typed Characters

To change the way selected text displays the case of typed characters:

1. Select the text to be changed.

2. Open the Style window and click the Font button.

3. Under Capitalization, select one of the following from the menu:

t Normal - Deko displays the case of all characters as entered.

t Smallcaps - Deko displays the case as all small caps.

t Allcaps - Deko displays the case as all capital letters.

t Allsmalls - Deko displays the text as all lower case characters.

t Words - Deko displays the first character of each word as a capital character (title 
case).
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To quickly change current style or selected text to display lower case as small caps:

t Click the Small Caps button on the text bar.

Deleting and Clearing Text or Program Window

As you experiment with styles and typing text, you might want to delete some text or clear 
the entire Program window.

The following topics provide more information on deleting and clearing the Text or 
Program Window:

• “Deleting Text” on page 146

• “Clearing the Program Window” on page 146

Deleting Text

To delete any text:

t Select the text to delete and press the Delete key.

Clearing the Program Window

There are two ways to clear the Background window. You can either clear the active or most 
recently used Program window including the Background, or without the Background. See 
the following procedures.

To clear the active or most recently used Program window (including the 
Background):

t Do one of the following:

- Press Clear Program (FAK).

- Press F8 twice or Alt + F8 (SK).  

You lose any unsaved work.

To clear the active or most recently used Program window (except for the 
background):

t Press F8.
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Cutting, Copying, and Pasting Details and Styles

In addition to creating a style or using a preset style, you can borrow styles and details from 
other graphics by copying and pasting.

The following topics provide more information about cutting, copying, and pasting details 
and styles:

• “Cutting or Copying a Detail” on page 147

• “Pasting a Detail into the Details Look” on page 147

• “Copying and Pasting a Look” on page 148

• “Copying and Pasting a Font” on page 148

• “Copying and Pasting a Style” on page 148

• “Selecting a Style from a Graphic and Assigning it a Preset Style Button” on page 148

• “Selecting Multiple Styles from a Graphic and Assigning them to Preset Style Buttons” 
on page 149

• “Selecting a Typeface from a Graphic” on page 149

Cutting or Copying a Detail

To cut or copy a detail:

1. Activate the Style window.

2. Select Look at the top of the Style window.

3. In the Details list, select the detail you wish to cut or copy.

4. Do one of the following:

t To remove the selected detail from its current position, select Edit > Cut Detail, or 
click the Cut button in the Tools window.

t To copy and leave the selected detail intact, select Edit > Copy Detail, or click the 
Copy button in the Tools window.

Pasting a Detail into the Details Look

To paste a detail into a Details list:

1. If necessary, open the Style file into which you want to paste the detail.

2. Select the detail in the Details list immediately preceding where you want to insert the 
cut or copied detail.

3. Select Edit > Paste Detail (Ctrl+V), or click the Paste button in the Tools window.
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Copying and Pasting a Look

To copy and paste a look:

1. Select text whose look you wish to copy.

2. Select Edit > Copy > Look. 

3. Select the text or position the cursor where you want to apply the look.

4. Select Edit > Paste (Ctrl+V), or click the Paste button on the text bar.

n When you copy a look, it is saved in the Windows clipboard.

Copying and Pasting a Font

To copy and paste a font:

1. Select text whose font you wish to copy.

2. Select Edit > Copy > Font. 

3. Select the text or position the cursor where you want to apply the font.

4. Select > Edit > Paste (Ctrl+V), or click the Paste button on the text bar.

n When you copy a font, it is saved in the Windows clipboard.

Copying and Pasting a Style

To copy and paste a style:

1. Select text whose style you wish to copy.

2. Select Edit > Copy > Style. 

3. Select the text or position the cursor where you want to apply the style.

4. Select Edit > Paste (Ctrl+V), or click the Paste button on the text bar.

n When you copy a style, it is saved in the Windows clipboard.

Selecting a Style from a Graphic and Assigning it a Preset Style  
Button

To select a style from a graphic and assign it to a preset style button:

1. Activate the Program or Preview window with the graphic open and select the character 
in the desired style.

2. Select Text > Pick Style. The style of that character is now the current style.

n If “Moving cursor sets font and look” is selected in the Options > Preferences > Cursor 
dialog box, you can omit this step.
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3. Right-click the Preset button.

Selecting Multiple Styles from a Graphic and Assigning them to Preset  
Style Buttons

To select (Pick) multiple styles from a graphic and assign them to preset style buttons:

1. Activate a Graphic window.

2. Select Text > Pick Presets. 

Deko assigns the first style in the graphic to the first preset button, the next style to the 
second preset button, and so on.

Selecting a Typeface from a Graphic

To select (pick) a typeface from a graphic:

1. Move the text cursor immediately to the right of a character in the desired typeface.

2. Select Text > Pick Font.

n If you select “Moving cursor sets font and look” in the Options/Preferences/Cursor dialog 
box, the current style always shows the style of the character to the left of the text cursor, 
unless a text character or layer is selected.
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4 Building Graphics with Layers

In Deko, it is very important to learn how to refine your graphic design skills and build 
graphics with layers. 

The following topics describe how to build graphics with layers:

• Understanding Layers and Backgrounds

• Working with Backgrounds

• Adding Layers

• Using Layers to Display Other Files

• Modifying Layers and Text

• Using the Layer Browser

• Pasting Layers to the Background

• Loading and Clearing Associated Clips

Understanding Layers and Backgrounds
As you begin creating styles or typing text, you can think of your graphic as analogous to a 
single sheet of paper. Typing text and seeing it appear in the Program window seems similar 
to typing or writing and then seeing words appear on the paper. 

However, every Deko graphic potentially can be more like any number of clear plastic pages, 
layered on top of one another. Think of transparencies on an overhead projector. Those 
transparencies could be moved or rotated independently of one another, and you could 
rearrange their order in the stack. Imagine that you could also stretch, shrink, or skew each 
one, and you will begin to understand the flexibility Deko offers for building graphics.
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Each graphic consists of a background and one or more layers. By default, a new graphic has 
a transparent background and one layer. A graphic can have as many layers as needed. Each 
layer is one of two types:

• Text Layer (sometimes called a text field)—This type of layer contains text or other 
characters. A graphic can have any number of text layers. Each layer can be moved, 
resized, edited, or animated independently of other layers. A solid white box with 
handles indicates a selected text layer. If no layers are selected, the current text layer is 
indicated by a solid white box, while a dotted white box indicates other text layers.

• Rectangle or Ellipse Layer—This type of layer is useful for adding design that can be 
layered or animated independently of text. These layers can be used in several ways:

- Styles consisting of detail filled with colors, ramps, textures or animations can be 
applied to this type of layer in the same way they are applied to text. Applying a 
texture to a layer allows you to associate another graphic file with that layer. The 
associated file might contain text, graphics, or both.

- You  use this type of layer for cutting a keyhole where live video can show through 
this layer and those behind it. A solid contrasting box with handles indicates a 
selected rectangle or ellipse. 

- A rectangle layer can be filled with a clip.
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n To see if clip playback is enabled on your system, select Options > Enabled Options.

When more than one layer of any kind are selected, handle markers indicate the most 
recently selected layer. Unselected layers are indicated by a dotted line. Layers can be 
scaled, skewed, rotated, or justified within the graphic. Layers are rendered in order from 
front to back, starting with the first layer, but can be reordered or hidden.

Graphic with Rectangle Layers

Graphic with Ellipse Layers 



4  Building Graphics with Layers

154

Behind the final layer of every Deko graphic is the background, a full-screen rectangle that 
is either off or on. 

• When off, the background is effectively transparent. “Live video” shows through when 
Deko graphics are keyed over external video.
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• When on, the background’s shader determines its appearance. The background can be a 
solid color, a ramp, or a texture. A background shader cannot be a keyhole or cel 
animation. 

n Although the background shader cannot be a keyhole, the background itself is normally fully 
keyed and allows keyed graphics as well.
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Working with Backgrounds

You can do many different things you can do with backgrounds in Deko. This section 
contains information on how to turn your background on and off, apply colors, ramps or 
textures to a background, opening graphics into the background, turning the background into 
a layer, and replacing the background with luminance from a graphic file.

The following topics contain more information on working with backgrounds:

• “Turning the Background On or Off” on page 156

• “Applying a Color, Ramp or Texture to the Background” on page 156

• “Opening a Graphic Directly into the Background” on page 157

• “Opening a Graphic into the Background Using a Browser” on page 158

• “Turning the Background into a Layer” on page 158

• “Replacing the Background with Luminance from a Graphic File” on page 158

Turning the Background On or Off

To turn the background on or off (allowing live video to show through):

t Do one of the following:

- Click the background button on the text bar.

- In the Layer menu, select or deselect Show Background.

- With the FAK function keys enabled, press F3.

You can specify a color that does not show in the video output to show where the 
graphic is transparent while you are working. For more information, see “Determining 
the Look and Behavior of your Cursor” on page 60.

Applying a Color, Ramp or Texture to the Background

To apply a color, ramp or texture to the background:

1. Follow the instructions in “Turning the Background On or Off” on page 156 to turn on 
the background.

2. Activate the Background Shader window by doing one of the following:

t Press Ctrl+F7.

t Click the background color (shader) button (Ctrl+F7) on the text bar.
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t Click color, ramp, or texture to select a shader. Apply the shader to the background 
as you would to a text detail. For more information, see “Applying Color, Ramp, 
Texture, CAP, or Keyhole to a Style Detail” on page 106. Although the background 
itself is normally fully keyed, backgrounds might not have keyhole or CAP shaders.

Opening a Graphic Directly into the Background

To open a graphic directly into the background:

1. Activate a Program or Preview window.

2. Select File > Replace Background (Ctrl+F9).

The Replace Background dialog box opens.

3. Navigate to the drive and directory that contain the file.

4. Do one of the following:

t Select File Name > filename. 

t Type the file name in the File Name text box.

5. Click OK.
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Opening a Graphic into the Background Using a Browser

To open a graphic into the background using a Browser:

1. Activate a Program or Preview window.

2. Do one of the following:

t Select View > Browser.

t Press Ctrl+L (SK).

t Press Browse Graphics (FAK).

3. Select File > Browse Backgrounds. 

A Browser window opens, displaying thumbnail images of available graphic files.

4. In the Browser window, double-click the thumbnail you wish to use for the 
background texture.

Turning the Background into a Layer

To turn the background into a layer:

t Select Layer > Background to Layer. 

The background turns into a full-screen rectangle, but keeps the shader it had as a 
background. The graphic now has a transparent background.

n If the background is an unnamed texture, you cannot turn it into a layer.

Replacing the Background with Luminance from a Graphic File

Luminance is the amplitude (brightness) of the gray scale portion of the television signal, the 
Y signal, or the range of brightness from black through gray to white in a video picture. 

n This is useful if your graphic has a “companion” graphic in which the luminance represents 
the key of the original.

To replace the background key with luminance from a graphic file:

1. Activate a Program or Preview window.

2. Select File > Replace Background Key.

3. The Replace Background Key dialog box opens.

4. Navigate to the drive and directory that contain the graphic file.
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5. Do one of the following:

t Select File Name > filename. 

t Type the file name in the File Name text box.

6. Click OK or press Enter.

Adding Layers

A common component of a graphic is one or more layers.

n Some menu items refer to a “text field.” A Text field is another name for text layer.

The following topics contain more information on adding layers:

• “Adding a Text Layer to a Graphic” on page 159

• “Typing Text in a Newly Added Text Layer” on page 160

• “Creating New Layers for Selected Text” on page 160

• “Adding a Rectangle to a Graphic” on page 162

• “Adding an Ellipse to a Graphic” on page 165

Adding a Text Layer to a Graphic

To add a text layer to a graphic using the menus:

t Select Layer > Add Text Field. 

Deko adds a text layer based on the boundaries of the safe title area.

To add a text layer to a graphic, using the mouse:

1. Click the Add text layer button in the Tools window.

In the graphic, the pointer becomes a text layer pointer.

Add text layer button



4  Building Graphics with Layers

160

2. Drag the pointer to define the text field box. 

n Ctrl+click and drag the pointer to maintain a square field box. 

Deko adds any new layer as the frontmost layer.

Typing Text in a Newly Added Text Layer

To type text in a newly added text layer:

1. Position the cursor in the text layer and click.

2. Begin typing your text in the new text layer. 

Text appears in the Current style, as displayed in the Current Style window. For more 
information, see “Designing and Applying Styles” on page 77.

Creating New Layers for Selected Text

To create a new layer or layers for selected text:

1. Select the text you want to move to a new layer or layers.
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2. Do one of the following:

t To put selected text into a single new layer, select Text > Text to Field.

n Whenever you use Text to Field, the revised layer is automatically sent to the lowest layer 
priority (bottom or highest numbered layer) and any Layer ID priority setting is set to 0.  
This is particularly significant with templates designed for automation or DekoMOS.

t To create a new layer for each row of selected text, select Text > Text to Multiple 
Fields.
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You can now position or edit the new field independently of the original.

Adding a Rectangle to a Graphic

When adding a rectangle to a graphic, you should know that a rectangle, in addition to being 
a shape that you can manipulate the size, color, edging, and so on, is also where charts and 
graphs are displayed when using the Chart Designer Tool.

For more information on using the Chart Designer dialog box to create charts and graphs to 
be displayed in the Preview or Program windows of Deko, see “Working with Charts and 
Graphs” on page 247.

To add a rectangle to a graphic:

1. Do one of the following:

t Select Layer > Add Rectangle. 

t Press Alt+L+R. 
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A rectangle layer is added at the center of the screen. The rectangle appears with the 
details and shaders of the Current Style.
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2. Press Alt+V+S+M. 

The Rectangle dialog box opens to the Layer face.

3. Tab to the Left, Top, Width, and Height fields. 

4. Type the appropriate values for your rectangle.

To add a rectangle to a graphic using the mouse:

1. Click the rectangle button in the Tools window. 

In the graphic, the pointer becomes a rectangle pointer. 

2. Drag the pointer to define the rectangle.

The rectangle appears with the details and shaders of the Current Style. 

n Ctrl+click and drag the pointer to maintain a perfect square. Deko always adds a new layer 
as the frontmost layer.
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Adding an Ellipse to a Graphic

To add an ellipse to a graphic using the keyboard:

t Select Layer > Add Ellipse. 

An ellipse layer is added at the center of the screen. The ellipse appears with the details 
and shaders of the Current Style.

To add an ellipse to a graphic using the mouse:

1. Click the ellipse button in the Tools window. 

In the graphic, the pointer becomes an ellipse pointer. 

2. Drag the pointer to define the ellipse. 

The ellipse appears with the details and shaders of the Current Style.

n Ctrl+click and drag the pointer to maintain a perfect circle. Deko always adds a new layer 
as the frontmost layer.

Using Layers to Display Other Files

File association is a useful technique for reducing production preparation time and making 
the most of your graphics files. File association means that Deko graphics can reference 
other files, including both Deko and non-Deko files.

The following topics contain more information on using layers to display other files:

• “Creating a Layer with a “Sticky” Texture” on page 166

• “Creating Clip Filled Layers” on page 169
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Creating a Layer with a “Sticky” Texture

To create a layer to display another graphic file (creating a layer with “sticky texture”): 

1. Create a rectangle layer or an ellipse layer.

2. In the Style window, click the Look tab. 

3. In the Details list, select Face. If there are additional details that you do not want 
displayed, you can delete them. 

4. With Face selected in the Detail list, click the Shader window.
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5. Click Texture, then specify the file you want to display by doing one of the following:

t Type the name of the file in the File Name text box and press Enter.

t Click Open to display the Open dialog box. Navigate to the file, select it, and click 
OK.

t Click Browse to see a Browser displaying thumbnails of graphic files. Double-click 
an image in the browser to open the file.

6. Specify the pixel aspect of the source graphic or non-Deko texture file. 

Pixel Aspect 
Option Original File Uses Description

square(1.0) Square pixels Appropriate for most “computer - generated” files (.bmp, for 
example) as well as files created in most HD resolutions (1080i, 
720p, and so on.)

ntsc(.9) NTSC pixels Appropriate for most files that have dimensions of approx. 720 x 
486 and are intended for use at a 4 x 3 screen aspect.

pal(1.07) PAL pixels Appropriate for most files that have dimensions of approx. 720 x 
5766 and are intended for use at a 4 x 3 screen aspect.

NTSC_wide(1.2) NTSC Wide pixels Appropriate for most files that have dimensions of approx. 720 x 
486 and are intended for use at a 16 x 9 screen aspect.

PAL_wide(1.42) PAL wide pixels Appropriate for most files that have dimensions of approx. 720 x 
5766 and are intended for use at a 16 x 9 screen aspect. 

1035i(.96) 1035i pixels Appropriate for files created at the 1035i resolution (rare).
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7. Scale or position the graphic within the layer. This can be done by using the following 
controls in the Shader window: 

- Autoscale 

- H Scale

- V Scale

- H Offset

- V Offset

- H alignment

- V alignment

8. In the Shader window, select Group > letter.

This choice makes the graphic as a whole appear in the layer and is sometimes referred 
to as creating a layer with “sticky” texture. 

n Other choices might display only part or none of the graphic in the layer and do not cause 
the graphic to move as the layer is repositioned.
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9. Use the H Scale, V Scale, H Offset and V Offset fields to further position or scale your 
graphic within the layer.

Creating Clip Filled Layers

In Clip filled layers, the clip is automatically cropped to fit in the layer. On your VGA 
monitor, the Clip filled layer appears filled with a dot pattern.

To create a Clip filled layer:

1. Create a rectangle layer. The Current Style is irrelevant because all details are obscured 
by the clip.

2. In the Style window, do the following:

a. Click the Layer tab.

b. In the Clip text box, type the name of the clip. 

n If you do not see the Clip field, click the More button at the bottom of the window, or click 
Select to browse for a clip. 

a. Click View to see the clip.

n In order to view the clip on your output monitor, the graphic must be in a Program window, 
and the Bkgd Clip plane tab (top right of window) must be turned on.

3. Alternatively, you might want to do the following:

a. Place the graphic in the Program window (not Preview). 

b. Select View > Clip Editor (or Ctrl+e) to open the Clip Editor.

c. Load and drag the clip to the layer.

Select Group > letter to create a 
layer with “sticky texture.”

Use Scale, Offset, and 
Alignment controls to position or 
scale the graphic in the layer.
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n To see if clip playback is enabled on your system, select Options > Enabled Options.

The following topics contain more information on creating clip filled layers:

• “Playing a Motion on a Graphic with a Clip Filled Layer” on page 170

• “Associating a Clip with an Entire Graphic” on page 170

Playing a Motion on a Graphic with a Clip Filled Layer

To play a motion on a graphic with a clip filled layer, that layer must be explicitly identified 
in the motion. For more about identifying layers in motions, see “Using the Motion Timeline 
Editor to Create Motions” on page 525.

Associating a Clip with an Entire Graphic

In addition to creating a clip filled layer, you can associate a clip with an entire graphic. For 
more information, see “Automatically Displaying Clips with Deko Graphics” on page 465. 
For complete information about using the ClipDeko option, see “Using the ClipDeko 
Option” on page 436.

Modifying Layers and Text

To apply properties to a layer, you have to select that layer. Some properties can be applied 
to entire layers or to text only. To apply properties to text only, select just the text, not 
the layer. 

To review how to select text, see “Working with Text and Styles” on page 141.

The following topics contain more information on modifying layers and text:

• “Selecting Layers” on page 171

• “Specifying Layer Properties” on page 175
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Selecting Layers

When selecting layers, you must first know which layers are already selected. Once you 
know how to determine that, there are many different ways to select layers.

The following topics contain more information on selecting layers:

• “Determining Which Layers are Selected” on page 172

• “Selecting a Layer in the Active Graphic” on page 174

• “Selecting a Layer in Front of the Current Layer” on page 174

• “Selecting the Layer Behind the Currently Selected Layer” on page 174

• “Selecting All Layers in the Active Graphic” on page 174

• “Selecting Multiple Layers in the Active Graphic” on page 174

• “Deselecting All Selected Layers” on page 175
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Determining Which Layers are Selected

Layer markers show at a glance what layers are selected:

• If no layers are selected, the current text layer is indicated by a solid white box, while a 
dotted white box indicates other text layers.

• A solid white box with handles indicates a selected text layer.

Current text layer

Other text layer

Selected text layer
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• A solid contrasting box with handles indicates a selected rectangle or ellipse.

• When more than one layer are selected, the most recently selected layer is indicated 
with handles.

Selected rectangle or 
ellipse

Handle, indicating most 
recently selected layer



4  Building Graphics with Layers

174

Selecting a Layer in the Active Graphic

To select a layer in the active graphic:

t Do one of the following:

- Click an ellipse, a rectangle, or the box around a text layer.

- Press Page Up or Page Down to navigate to the layer.

- Select View > Layer Browser, then click the thumbnail image of the layer in 
the browser.

- Select the layer from the list at the bottom of the Layer menu.

Selecting a Layer in Front of the Current Layer

To select the layer in front of the current layer:

t Do one of the following:

- Activate the Graphic window and press Page Up.

- Select Layer > Select Previous Layer (Alt+Page Up).

Selecting the Layer Behind the Currently Selected Layer

To select the layer behind the currently selected layer:

t Do one of the following:

- Activate the Graphic window and press Page Down.

- Select Layer > Select Next Layer (Alt+Page Down).

Selecting All Layers in the Active Graphic

To select all layers in the active graphic:

t Do one of the following:

- Press Shift+Ctrl+L.

- Select Edit > Select Layers.

Selecting Multiple Layers in the Active Graphic

To select multiple layers in the active graphic:

t Do one of the following:

- Select Edit > Select More. Use one of the methods in “Selecting Layers” on 
page 171 to select each layer individually.

- Ctrl+click the boundary of each layer you want to select.
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Deselecting All Selected Layers

To deselect all selected layers:

t Press the Escape key.

Specifying Layer Properties

Once you have selected or created a layer, you can specify the layer properties. Layer 
properties control the appearance of the layer and might affect the appearance of text within 
a layer. Following is a general description of applying layer properties. For specific 
instructions on how to apply certain properties to text or layers, see “Editing Text and 
Layers” on page 191.

To specify layer properties:

1. Select the layer.

2. Do one of the following:

t Select Layer > Properties. The Style dialog box opens.

t Open (F6) or activate the Style dialog box and click the Layer button at the top of 
the window.

The Style dialog box contains two different interfaces (one to specify properties relating 
to text only, and the other to specify text, ellipse, and rectangle properties). 

3. Click the More button at the bottom of the dialog box to access the second interface to 
specify the additional properties.
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4. Specify layer properties as desired.

Click here to access 
more options

Click again to access 
previous interface

Specify Text Layer 
only properties here

Specify Text, ellipse, 
and rectangle 
properties here

Text Layer Only 
Property Description

n Text Layer properties are available for text layers only in addition to those properties available for all 
types of layers.

Justification Specifies default justification for text within the layer:

• Horizontal - Justifies text between the left and right edges of the text layer.

• Vertical - Justifies text between the top and bottom of the text layer.

• Spread % - When Horizontal justification is set to “spread,” specifies how 
much additional space to add between the letters within a word, compared to 
the space added between words.

Word wrap Automatically wraps words to the next row, as necessary, to keep text within the 
text layer box. You can set a word wrap default preference by selecting Options > 
Preferences > Advanced.
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Auto-scaling Specifies automatic text scaling for the field. You can set an auto-scaling default 
preference by selecting Options > Preferences > Advanced tab.

• None - No automatic text scaling.

• Limit_to_layer - Limits text to the size of the layer. Does not shrink or go 
beyond the layer boundary.

• Scale_to_fit - Scales text up or down to exactly fit the text layer.

• Shrink_to_fit - Scales text down, if necessary, to fit within the text layer.

Max # of chars Enables you to specify that you want the text to only perform the desired scaling 
(shrink_to_fit) option when the text is longer than the number of characters 
defined in this field. This allows the text to always fit within the text layer, and 
keeps it at the normal size until the number of characters added is greater than the 
maximum number you have specified.

Auto-Update Specifies how the text layer is filled in via automation. For more information, see 
“Using Automation” on page 753.

None  - Specifies that there is no automation for the text field.

String - A text string can be typed in the box following the Auto-Update options. 
The text string displays in the field.

Clock - Specifies a clock ID. Click the View Clocks button to view clock 
parameters for the specified clock.

Macro - Specifies that the field reference a macro. The file name and update 
frequency can be typed in the box following the Auto-Update options.

Query  - Causes the Automation interface to request updates from the host at 
user-specified intervals. Type a string, ID, and update frequency.

Replace  - Specifies this field as a Replace field. Texture graphics or clips can be 
replaced. Deko replaces the graphic’s replace fields with the data in the .aut or 
.atx file. 

SQL - Specifies this field as an SQL field. Deko requests data from the specified 
database.

Chart - If this is selected, and then the View button is clicked, it opens the Chart 
Designer dialog box, enabling you to create charts and graphs that are displayed 
within a rectabgle layer. for more information, see “Working with Charts and 
Graphs” on page 247.

Text Layer Only 
Property Description
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ID By default, this field is Off. Off means that the layer number indicates the order in 
which external data is entered into the layers. Click the Up arrow to specify an ID 
number. This number indicates the order in which external data is entered into 
layers.

For clock, the ID controls which clock configuration is linked to that layer. For 
example, you could have 5 clocks configured (ID 1 is a countdown clock and ID 
2 is a time-of-day clock). If Clock is selected as auto-update, you must decide 
which clock (ID1, ID2, and so on.) to link to that layer.

For Query and Replace, the automation brings information to the graphic in a 
precise order. For example: name, position, hometown. The layer order is used 
appropriately if name is in layer 1, position in layer 2, and hometown in layer 3. 
However, if you want the layer priority to be overwritten for the sake of matching 
automation fields, you can set ID, and the automation presents the first data to 
ID=1, regardless of the actual layer priority.

Process update result This field is used in conjunction with database retrieval. If the Auto-update type 
is set to SQL (to retrieve data from a database), a macro can be placed in this field 
to process or modify the information before displaying it in the layer. The field 
post processes the result of a layer after the layer retrieves the information from 
the data source but before it displays the data in the corresponding layer. For 
example, if a data source value is 100, a macro could be placed in this field to add 
a percentage sign to that value and display 100% in the layer.

Text, Ellipse, and 
Rectangle Property Description

Name The user-specified name of the layer. This is especially useful if you plan to apply 
effects or motions to individual layers.

Box Defines the dimensions of the layer. All values refer to the original layer dimensions, 
before any transformation — scaling, rotation, or skewing.

Left, Top Specifies the positions of  the left and top edges of the layer, in screen units.

Width, Height Scales the width and height of the layer.

 Aspect The ratio of width to height. For a perfect circle or square, this should be 1.

Fixed aspect Maintains layer aspect ratio whenever width or height changes. The shape of the 
layer does not change. When one dimension is changed, the other changes 
proportionally.

Text Layer Only 
Property Description
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The following topics contain more information on 

• “Moving the Layer Using the Keyboard” on page 179

• “Moving the Layer Using the Mouse” on page 179

Moving the Layer Using the Keyboard

To move the layer using the keyboard:

1. Do one of the following:

t From the Options menu, select Transform/Move.

t Press Ctrl+M (SK).

t Press Move (FAK).

2. Select Options > Transform.

3. Set the increment of change to either Coarse (10 pixels) or Fine (1 pixel).

n Press Ctrl+spacebar to switch between Coarse and Fine.

4. Select a layer.

5. Hold the Alt key down and press the arrow keys to move the text field box up, down, left 
or right.

Moving the Layer Using the Mouse

To move a layer using the mouse:

1. Click the move button in the Tools window.

2. Select a layer.

Transform Defines how the layer is transformed from its original position:

• H Scale, V Scale - Horizontal and vertical scale factors.

• Rotation - Layer rotation in degrees.

• Skew - Layer skew amount.

• H Origin, V Origin - The center of rotation.

Merge With Previous Specifies that the current layer appears in the same plane as the layer in front of it. In 
other words, Deko renders this layer as if it were part of the layer in front of it.

Text, Ellipse, and 
Rectangle Property Description
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3. Position the pointer near the border or a handle of the field, so that the pointer becomes 
the Moving tool.

4. Drag to move the layer.

n Ctrl+clicking allows you to drag the layer either vertically or horizontally, assisting in more 
precise alignment. 

Using the Layer Browser
The Layer Browser shows a thumbnail image of each layer in the current graphic and 
displays the layer’s name and order. The Layer Browser can be used to rename, reorder, 
select, or delete layers.

The following topics contain more information on using the Layer Browser:

• “Opening the Layer Browser” on page 180

• “Locating a Thumbnail Image in the Browser” on page 181

• “Selecting a Layer Using the Layer Browser” on page 181

Opening the Layer Browser

To open the layer browser:

t Do one of the following:

- Select View > Layer Browser.

- Press Shift+Ctrl+B .
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Layers in the current graphic are shown in the order in which you have placed them in 
the graphic. If you have not named the layers, they are assigned numbers, but you can 
rename them.

Locating a Thumbnail Image in the Browser

To go to a thumbnail image in the browser:

t Do one of the following:

- Use the scroll bar or the Up and Down arrows on the side of the Layer browser.

- Type the first few letters of the layer name.

Selecting a Layer Using the Layer Browser

You can select a layer using the Layer browser.

To select a layer using the Layer browser:

t Click the thumbnail image of the layer. 
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Using Layer Browser Tools to Facilitate Your Work

A layer might be visible in the Program window or hidden. A layer can be locked so that it 
cannot be altered or moved. In the Layer browser, a layer might be magnified, making it 
easier to distinguish smaller layers.

Viewing or Hiding a Layer

To view or hide a layer:

1. In the Layer Browser, select the layer.

2. Click the Show Layer button or Hide Layer button to switch between visible (indicated 
by an open eye), or hidden (indicated by a closed eye).

Locking or Unlocking a Layer

To lock or unlock a layer:

1. In the Layer Browser, select the layer.

2. Click the Lock Layer button or the Unlock Layer button at the top of the browser.

Zooming In and Out on a Layer

To zoom in on a layer: 

1. In the Layer Browser, select the layer.

2. Click the Zoom button in the browser.

n The Zoom button does not increase or decrease the scale of the actual graphic for editing it. 
It displays the layer full screen in the picon so you can more easily view tiny layers in the 
Layer browser.

Show / Hide Layer

Lock Layer buttonUnlock Layer button

Show Normal Perspective buttonZoom button
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To return to normal view:

t Click the Show Normal Perspective button.

Naming Layers

Layers can be named. It is a good idea to assign names to your layers, especially if you want 
to add motions to your graphic at a later date. You should select meaningful names that 
readily identify the layer (title, weather logo, news anchor, and so on). 

A group of related layers might be given related names. For example, a table of election 
results could use the following layer names:

Related layers could be quickly identified using an asterisk (*) as a wildcard symbol. Elect 
one* would refer to all layers in column one. Elect *a would refer to all layers in the top row. 
Application of related layer names is discussed further in “Adjusting Motion Parameters 
with the Timeline Option” on page 541.

The following topics provide more information on naming layers:

• “Naming a Layer in the Style Window” on page 183

• “Naming or Renaming a Layer in the Layer Browser” on page 183

Naming a Layer in the Style Window

To name a layer in the Style window:

1. Select the layer.

2. Activate the Style window and click the Layer button.

3. Type the layer name in the Name text box. 

n To see this field, you might need to click the More button at the bottom of the Style window. 

Naming or Renaming a Layer in the Layer Browser

To name or rename a layer in the Layer browser:

1. Click on the layer's thumbnail image in the browser.

2. Verify that the layer is now selected in the graphic, indicating that you clicked the 
correct thumbnail.

Elect 1a Elect 2a Elect 3a

Elect 1b Elect 2b Elect 3b

Elect 1c Elect 2c Elect 3c
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3. Right-click the thumbnail, and select Rename.

The Name field following the thumbnail appears highlighted.

4. Type the desired name.

5. Click anywhere outside the name field.

Reordering Layers

When you have more than one layer, you can drag and drop them into the order you want.

To drag and drop your layers in the order to want:

t Do one of the following:

- Select View > Layer Browser. 

- In the browser, drag and drop thumbnail images to reorder layers as desired.

n Deko indicates where you are about to drop an image by highlighting the edges of the image 
before and the image after.

To reorder your layers based on how they are positioned on the screen (horizontally, 
or vertically):

t Select Layer > Reorder Layers > Horizontally or Vertically. 

n Reorder works best with layers placed in a grid fashion. Randomly placed layers do not 
respond predictably to Reorder Layers.

- If you selected Horizontally:

Deko renumbers layers based on their positions on the screen from left to right, then 
top to bottom. For example, six layers in three rows of pairs would be numbered:

1   2

3   4

5   6

- If you selected Vertically:

Deko renumbers layers based on their positions on the screen from top to bottom, 
then left to right. For example, six layers in three rows of pairs would be numbered:

1  4

2  5

3  6
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n Deko renumbers layers based on their positions on the screen. The layer nearest the top of 
the screen becomes the frontmost layer. 

To swap one layer at a time, or send a layer to the back or front:

1. Select the layer. 

2. From the Layer menu, select one of the following:

t Send Back One Layer (Ctrl+-) - Swaps the layer with the layer behind it.

t Bring Forward One Layer (Ctrl++) - Swaps the layer with the layer in front of it.

t Send to Back (Alt+-) - Makes the layer the backmost layer, just in front of 
the background.

t Bring to Front (Alt++) - Makes the layer the frontmost layer.

Appending a Graphic to a Second Graphic

To append one graphic to another graphic:

1. Open the first graphic file.

2. Select File > Append Layers (Alt+F9).

The Append Layers dialog box opens.

3. Navigate to the drive and directory containing the second graphic file.
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4. Do one of the following: 

t Select the file from the File Name menu. 

t Type the name in the File Name text box.

5. Click OK or press Enter. 

Deko appends the second graphic’s layers behind those of the first. The second graphic’s 
background is not used.
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Pasting Layers to the Background
To paste all layers in the active graphic to the background:

1. Select Layer > Layers to Background.



4  Building Graphics with Layers

188

n Deko copies the layers to combine them in the background. The original layers remain until 
you select Edit > Clear Layers (F8).

Loading and Clearing Associated Clips

Deko enables you to associate a clip with a graphic, by either letting you:

• Load a new clip (thus replacing the old clip with the new one).

• Clear the old clip and not replace it. The graphic continues playing.

To associate a clip with a graphic:

1. Select View > Style. 

The Text/Style dialog box opens.
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2. Click the Graphic button. 

The Text dialog box opens as follows:

3. Select one of the options from the Action field of the Linked Bgd Clip section of the 
Style dialog box:

t No action - If you select this option, when you load a clip with an associated 
graphic, any clip that’s currently playing continues to play.

t Load clip - If you select this option, when you load a clip with an associated graphic 
(by selecting from the Clip name menu), it replaces the old clip with the new clip 
you have selected.

t Clear clip - If you select this option, it clears the old clip and doesn’t load the new 
clip. The clip is cleared.

4. Close the dialog box when you’re done.

Select one of the following from 
the Action field
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5 Editing Text and Layers

Editing text and layers in your graphics is something that Deko operators do quite often. 

The following topics describe how to edit text and layers:

• Modifying Text

• Manipulating Text or Layers

• Cutting and Pasting Text or Layers

• Typing on a Curve

• Using Tab Stops

Modifying Text

When modifying or editing text, most modifications can be applied to both selected text and 
selected layers. Some modifications, however, only affect text.

The following topics provide more information about modifications that only affect text:

• “Changing Text Case” on page 192

• “Changing Character Spacing (Kerning)” on page 195

• “Changing Row Spacing (Leading)” on page 196

• “Changing Character Width” on page 197

• “Finding and Replacing Text” on page 199

• “Checking Text Spelling” on page 201
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Changing Text Case

To change the first character of each word to upper case:

1. Do one of the following:

t Select the text to be changed.

t Select nothing to change all text in the current layer.
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2. Select Text > Capitalize.

The first character of each word changes to uppercase.

To change selected text to upper case:

1. Do one of the following:

t Select the text to be changed.

t Select nothing to change all text in the current layer.
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2. Select Text > Upper Case.

All characters change to upper case.

To change selected text to lower case:

1. Do one of the following:

t Select the text to be changed.

t Select nothing to change all text in the current layer.
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2. Select Text > Lower Case.

The selected text changes to lower case.

Changing Character Spacing (Kerning) 

Kern refers to the amount of space between characters. This space can be increased, moving 
characters further apart, or decreased, making them closer together. With default kerning, the 
Kerning value displayed in the Font tab of the Style window is zero.

To kern text using the keyboard:

1. Do one of the following:

t Select Options > Transform > Kerning & Leading .

t Press Ctrl+K (SK).

t Press Kern (FAK).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the characters you want to kern.
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4. Press Alt and do one of the following:

t Press the Right arrow to widen the space between selected characters.

t Press the Left arrow to reduce character spacing.

To kern text using the mouse:

1. Click the Kerning/Leading button in the Tools window.

2. Select the characters to kern.

3. Move the pointer to a handle at either side of the selected text. 

The pointer becomes the kerning tool.

4. Drag the handle outward to widen spacing between characters and inward to decrease 
character spacing.

To specify a numerical value for kerning:

1. Select the characters to kern. If no text is selected, Deko applies changes to the current 
style.

2. Click in the Style window and click the Font button.

3. Double-click or Tab to the Kerning text box, then type or scroll to the desired value. 

A positive kerning value increases space between characters; a negative value decreases 
the space. 

4. To use default kerning, specify a value of zero.

Changing Row Spacing (Leading)

Leading refers to the amount of space between rows of text. This space can be increased, 
moving rows further apart vertically, or decreased, making them closer together. With 
default leading, the Leading value displayed in the Font tab of the Style window is zero.

To change leading using the keyboard:

1. Do one of the following:

t Select Options > Transform > Kerning & Leading.

t Press Ctrl+K (SK).

t Press Kern (FAK).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the text for leading.
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4. Press Alt and do one of the following:

t Press the Right arrow to increase the space between rows of selected text.

t Press the Left arrow to decrease the space between rows of selected text.

To change leading using the mouse:

1. Click the Kerning/Leading button in the Tools window.

2. Select the text for leading.

3. Move the pointer to a handle preceding or following the selected text, so that the pointer 
becomes a leading tool.

4. Drag the handle downward to increase the space between rows, or upward to reduce row 
spacing. 

To specify a numerical value for leading:

1. Select the text for leading. 

If no text is selected, Deko applies changes to the current style.

2. Click in the Style window.

3. Click the Font button at the top of the Style window.

4. Double-click the Leading text box, then type or scroll to the desired value. 

A positive value increases the space between rows; a negative value decreases it. The 
default value is zero.

Changing Character Width

To change character width:

1. Do one of the following:

t Select Options > Transform/Scale & Width.

t Press Ctrl+W (SK).

t Press Scale (FAK).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the characters to change.

4. Press Alt and do one of the following:

t Press the Right arrow to increase the character width.

t Press the Left arrow to decrease the character width.
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To change character width using the mouse:

1. Click the Scale button in the Tools window.

2. Select the characters to change.

3. Move the pointer to a handle on either side of selected text, so that the pointer becomes 
the widening tool.

4. Drag the handle either outward to widen characters or inward to decrease character 
width.

To specify a numerical value for character width:

1. Select the characters to change. If no text is selected, Deko applies changes to the 
current style.

2. Click in the Style window.

3. Click the Font button at the top of the Style window.

4. Double-click or tab to the Width % text box, then type or scroll to a percentage of 
normal character width. 
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Finding and Replacing Text

To find text within a graphic:

1. Select Edit > Find (Ctrl+F).

2. In the Find dialog box, type the text in the Find What text box.

3. (Option) Select Match Case or Match Whole Word Only.

4. Click Find Next (Ctrl+G) to find and select the next occurrence of the text.

5. Click Cancel to close the dialog box.
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To find and replace text within a graphic:

1. Select Edit > Replace (Ctrl+H).

2. In the dialog box, type original text in the Find What text box.

3. Type replacement text in the Replace With text box.

4. (Option) Select Match Case or Match Whole Word Only.
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5. Do one of the following:

t To find and select the next occurrence of original text, select Find Next (Ctrl+G). 
Then select Replace to remove and replace the selected text, or Find Next to skip to 
the next occurrence of original text.

t To find and replace all occurrences of original text, select Replace All.

6. Click Cancel to close the dialog box.

Checking Text Spelling

To spell check text in the current graphic:

1. Do one of the following:

t Select Text > Spell Check.

t Click the Spell Check button on the text bar.

t With the FAK function keys enabled, press F12.

2. Use dialog box options to ignore or change reported errors until the spell check is 
complete, or click Cancel to end the spell check at any time.

To change spell check options:

1. Do one of the following:

t Select Text > Spell Check. 

t Click the Spell Check button.

The Spell Check dialog box opens.
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2. Click the Options button. 

The Options dialog box opens.

3. Select options as described in the following table.

Spell Check Option Description

Ignore capitalized words Ignores all capitalized words, such as names of people or places.

Ignore all-caps words  Ignores words in all upper case, such as acronyms like “ASAP.”

Ignore words with numbers Ignores words that contain numbers, such as “Deko3000.”

Ignore words with mixed case Ignores words containing upper and lower case, such as “DekoObjex.”

Report doubled words Reports double occurrence of the same word, such as “the the.”

Case sensitive Reports a distinction between capitalized and non-capitalized words, such 
as “Canada” and “canada.”

Phonetic suggestions Makes suggestions based on phonetic (sounds-like) similarity to the 
misspelled word.

Typographical suggestions Makes suggestions based on typographical (looks-like) similarity to the 
misspelled word.

Suggest split words Suggests two separate words as a replacement for a misspelling containing 
two joined words, such as “isthe” and “is the.”

Match case in replacement Suggests replacements for misspelled words that use the same letter-case 
pattern as the misspelled word.
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Manipulating Text or Layers

Before you are in a situation where you must edit quickly, you should try to thoroughly 
familiarize yourself with the difference between editing text and editing layers. 

Selected text and layers can be rotated, skewed, or scaled. By applying any of these types of 
editing to a layer, you also affect the text within the layer. That effect is not the same as if 
you apply the editing directly to the text instead of the layer. 

You can also move, cut, or paste text or layers. Applying these types of editing to text affects 
the text's position in a layer. Applying these types of editing to layers affects the layer's 
position in the graphic. 

You can apply justification to selected text or to a layer to justify all text in the layer.

Other modifications have different effects depending on whether they are applied to selected 
text or to the layer. 

The following topics provide more information about manipulating text or layers:

• “Rotating Text or Layers” on page 204

• “Skewing Text or Layers” on page 208 

• “Scaling Text or Layers” on page 211 

• “Moving Text and Layers” on page 219

• “Justifying Text and Layers” on page 224

• “Deleting Text and Layers” on page 228

• “Cutting or Copying Text or a Layer” on page 230

• “Pasting Text” on page 230

• “Pasting a Layer” on page 231

AutoCorrect Automatically changes words defined in auto-change dictionaries to their 
specified replacements.

Suggestions Determines the speed and accuracy of the initial search for suggested 
replacements for misspelled words.

Spell Check Option Description
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Rotating Text or Layers

You can rotate selected text or layers by any of several methods. As shown in the following 
illustrations, applying exactly the same degree of rotation to text or layer has different 
results:

Text selected in original position

Result of text rotation
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Text returned to original position, layer rotated

To rotate selected text or layer:

1. Select Options > Transform > Rotate & Skew (Ctrl+R).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the text or layer to rotate.

4. Press Alt and do one of the following:

t Press the Down arrow to rotate the selected text or layer clockwise.

t Press the Up arrow to rotate counterclockwise.

To rotate selected text or layer using the mouse:

1. Click the Enable Rotation/Skewing button in the Tools window.

2. Select the text or layer to rotate.

3. Move the pointer near the dotted line surrounding selected text, or the solid line with 
handles around a selected layer. 

Enable Rotation/Skewing button
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The pointer becomes the rotation tool.

4. Drag to rotate the selected text or layer.

To specify a numerical value for text rotation:

1. Select the text to rotate. 

Changes are applied to the current style and any selected text. If there is no text selected, 
changes apply to the current style only.

2. Click in the Style window.

3. Click the Font button at the top of the Style window.

4. Do one of the following:

t Type a number in the Rotation text box, and press Enter.

t Scroll to a value.

Negative values set counterclockwise rotation by degrees of the selected text, and 
positive values set clockwise rotation.

Rotation, in degrees, specified here
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To specify a numerical value for layer rotation:

1. Select the layer.

2. Click in the Style window.

3. Click the Layer button at the top of the Style window. 

4. If you do not see the Rotation text box, click More, near the bottom of the window.

5. Do one of the following:

t Type a number in the Rotation text box, and press Enter. 

t Scroll to a value. 

Negative values set counterclockwise rotation by degrees of the selected text, and 
positive values set clockwise rotation.

Rotation of Layer, by degrees, specified here
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Skewing Text or Layers

You can skew selected text or layers by any of several methods. As shown in the following 
illustrations, applying exactly the same degree of skew to text or a layer has different results:

Original text, selected

Text skewed

Original layer, selected
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Layer skewed

To skew selected text or layer:

1. Select Options > Transform > Rotate & Skew (Ctrl+R).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the text or layer to skew.

4. Press Alt and do one of the following:

t Press the Right arrow to skew the selected text or layer clockwise.

t Press the Left arrow to skew counterclockwise.

To skew selected text or layer using the mouse:

1. Click the Enable Rotation/Skewing button in the Tools window.

2. Select the text or layer to skew.

3. Move the pointer over the top right corner handle of the selected text or layer, so that the 
pointer becomes the skewing tool.

4. Drag the handle to skew selected text or layer.

The following topics provide more information about skewing text or layers:

• “Specifying a Numerical Value for Skewing Text” on page 210

• “Specifying a Numerical Value for Skewing a Layer” on page 210

Enable Rotation/Skewing button
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Specifying a Numerical Value for Skewing Text

To specify a numerical value for skewing text:

1. Select the characters to skew. If no text is selected, Deko applies changes to the 
current style.

2. Click in the Style window.

3. Click the Font button at the top of the Style window.

4. Double-click the Skew box, then type or scroll to a value. 

Negative values skew text counterclockwise. Positive values skew text clockwise.

n Skew can be used to italicize text to angles different from the default italic angle.

Specifying a Numerical Value for Skewing a Layer

To specify a numerical value for skewing a layer:

1. Select the layer.

2. Click in the Style window.

3. Click the Layer button at the top of the Style window.

4. Double-click the Skew box, then type or scroll to a value. For text layers, click More to 
show the Skew box.
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Scaling Text or Layers

Text or layers can be selected and scaled in any of several ways. How layer scaling affects 
the size of text in the layer depends upon choices for Auto-scaling in the Style window, 
Layer tab.

To determine how layer scaling affects text size:

1. In the Style window, click the Layer button. 

The Text dialog box opens.
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2. In the Auto-scaling area, do one of the following:

t Select None to specify that text is scaled with the layer, shrinking or enlarging to 
remain the same relative to layer size.

t Select Scale_to_fit to specify that the text will enlarge to fill the layer.
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t To specify text size decreasing to remain within layer, select Shrink_to_fit.

The following topics provide more information on scaling text or layers:

• Limiting Text Renderings to a Fixed Number of Characters

• “Limiting Text Layer Renderings to the Layer Boundary” on page 214

• “Changing the Size of a Layer without Changing the Text Size” on page 214

• “Scaling Selected Text or Layers Using the Keyboard” on page 216

• “Scaling Selected Text Using the Mouse” on page 217

• “Specifying Numerical Values for Font Size” on page 218

• “Specifying Numerical Values for Layer Scaling” on page 218

Limiting Text Renderings to a Fixed Number of Characters

This feature is typically used by art departments to set a maximum character count within a 
text layer and as part of the template to maintain aesthetic guidelines for font size, and so on. 
This is most useful in an automated workflow when the operator can preview the graphic. 
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To limit text layer renderings to a fixed number of characters:

t Type a value in the Max # of chars field. When the total number of characters exceeds 
the limit, the text is no longer visible.

Limiting Text Layer Renderings to the Layer Boundary

This option is helpful if you want to type only the amount of text that fits into a defined text 
layer. It helps to avoid shrinking text which can compromise artistic guidelines.

To limit layer renderings to the Layer boundary:

t Select Autoscaling > limit_text_to_layer. 

c When you type text, you must be careful to not type too many words, because the text 
does not shrink to fit the box. Type only the amount of text that fits into a defined 
text layer.

Changing the Size of a Layer without Changing the Text Size

To change the size of a layer without changing the size of the text:

1. Select the layer, and position the mouse pointer at one of the layers corners so it 
becomes a double arrow.

2. Activate the Move tool by pressing Ctrl+M (SK) or press Move (FAK).

n If you leave the Scale tool on by mistake, the text scales. If the Kern tool is left on, nothing 
happens.
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3. Click the layer and drag it to resize. You can reposition the text to fit in the layer.

Layer Resized to Fit Text on One Line
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Layer Resized to Fit Text on Two Lines

Scaling Selected Text or Layers Using the Keyboard

To scale selected text or layers using the keyboard:

1. Select Options > Transform > Scale & Width (Ctrl+W).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the text or layer for scaling.

4. Do one of the following:

t To increase layer height and width, maintaining aspect ratio, hold down Alt and 
press either the Up arrow key or the Down arrow key. This also increases or 
decreases font size.

t To increase or decrease layer width only, hold down Alt and press the Right arrow 
key or the Left arrow key to increase or decrease text or layer width. 
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Scaling Selected Text Using the Mouse

To scale selected text or layers using the mouse:

1. Click the scaling button in the Tools window.

2. Select the text or layer for scaling.

3. Move the pointer to a handle on any side or corner of the selected text, so that the 
pointer becomes one of the scaling tools.

4. Do one of the following:

t Drag a handle outward to increase text or layer size.

t Drag a handle inward to decrease text or layer size.

Corner handles control height and width together; middle handles on the right or left 
control width only; and middle handles on the top or bottom control height only.

5. Press Ctrl and drag a corner handle to preserve the aspect ratio of the text so that height 
and width scale together.

n When you size the text layer with Scaling enabled, Deko scales the text along with the layer, 
but keeps the values. The text does not remain the same size. 

When you size the text layer with Moving enabled, Deko does not scale the text along with 
the layer but keeps the values. The text remains the same size but wraps differently to fit 
within the layer.

Enable Scaling button
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Specifying Numerical Values for Font Size

To specify a numerical value for font size:

1. Select the text you want to scale. If no text is selected, Deko applies changes to the 
current style.

2. Do one of the following:

t On the text bar, double-click the Size text box.

t In the Style/Font window, double-click the Size text box.

3. Type or scroll to a new font size.

4. Press Enter to apply the new size.

Specifying Numerical Values for Layer Scaling

To specify a numerical value for layer scaling (this scales all text in the layer):

1. Select the layer.

2. Click in the Style window.

3. Click the Layer button at the top of the Style window.

4. In the Style window, type values for H Scale and V Scale. 
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For text layers, click the More button to show the H Scale and V Scale value fields.

n When you scale a text layer, Deko scales all text within the field. To change the size of the 
layer without scaling the text, change the height and width values under Box value in the 
Layer tab of the Style window.

Moving Text and Layers

Deko provides many ways to move or position text and layers.

The following topics provide more information about moving text and layers:

• “Moving a Layer Using the Mouse” on page 222

• “Positioning Layers by Specifying Numerical Values” on page 222

• “Moving Text Using the Keyboard” on page 223

• “Moving Text Using the Mouse” on page 224

To move text or layers:

1. Do one of the following:

t Select Options > Transform >Move.

t Press Ctrl+M (SK).

t Press Move (FAK).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.
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3. Do one of the following:

t Select the layer.

Layer Selected

t Select text.

Text Selected
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4. Press Alt and use the arrow keys to move the selected layer or text up, down, left 
or right.

Selected Layer Moved
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Selected Text Moved

Moving a Layer Using the Mouse

To move a layer using the mouse:

1. Click the Move button in the Tools window.

2. Select the layer.

3. Position the pointer near the border of the layer, so that the pointer becomes the moving 
tool.

4. Drag to move the layer in any direction.

Positioning Layers by Specifying Numerical Values

To position layers by specifying numerical values:

1. Select the layer.

2. Click in the Style window.

3. Click the Layer button at the top of the Style window.
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4. In the Style window, type values for Left, Top, Width and Height. For text layers, click 
the More button in the Style window to show Left and Top value fields.

Moving Text Using the Keyboard

c Although it is possible to move text using the following instructions, this typically is not 
done. Moving text within a layer can cause problems with baseline and home position 
recognition. Layers replaced via automation or pops do not maintain moved text 
position. Generally, you should not move text in a layer. Either move the layer itself or 
use justification tools.

To move text using the keyboard:

1. Do one of the following:

t Select Options > Transform > Move. 

t Press Ctrl+M (SK).

t Press Move (FAK).

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Select the text to move or position the cursor according to the rules in the following step.
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4. Press Alt and use the arrow keys to move selected text up, down, right or left. If no text 
is selected:

- Alt+Down arrow moves the cursor row and all lower rows down.

- Alt+Up arrow moves the cursor row and all lower rows up.

- Shift+Alt+Up arrow exchanges the cursor row with the row preceding it.

- Shift+Alt+Down arrow exchanges the cursor row with the row following it.

- Alt+Right arrow moves all characters from the cursor to the end of the row (or tab 
field) to the right.

- Alt+Left arrow moves all characters from the cursor to the end of the row (or tab 
field) to the left.

Moving Text Using the Mouse

To move text using the mouse:

1. Select the text to move.

2. Click the Move button in the Tools window.

3. Move the pointer near the dotted line surrounding the selected text. 

The pointer becomes the moving tool.

4. Drag to move selected text in any direction.

n Unlike cutting and pasting text, moving text does not change the location of the text cursor. 
When you cut and paste text, the cursor follows the text, but when you move text, the cursor 
appears in the original location of the text even after the text has been moved.

Justifying Text and Layers

Deko provides several ways to justify text and layers.

The following topics provide more information about justifying text and layers:

• “Justifying Text Using the Mouse” on page 224

• “Justifying Text Using the Keyboard” on page 227

• “Justifying a Rectangle, Ellipse, or Text Layer” on page 227

Justifying Text Using the Mouse

To justify text using the mouse:

1. Select the text, or select nothing to justify all text in the active layer.
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2. Do one of the following:

t On the text bar, click the appropriate justification button to alter horizontal 
justification, vertical justification, or both, then select the desired setting.

t Select Text > Justify, then select a setting for horizontal justification, vertical 
justification or both.

Full horizontal justification makes selected text, except any row with a new line 
character (hard return), flush with the left and right sides of the text field box.

Justify

Vertical Justify

Horizontal Justify
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Full vertical justification makes the top and bottom lines of selected text flush with 
the top and bottom of the field box.

Spread justification makes all lines of selected text flush with both the left and right 
sides of the text field box. To do this, space is inserted between words and between 
letters, as controlled by the Spread % in the Style/Layers window.
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Justifying Text Using the Keyboard

To justify text using the keyboard:

1. Select the text, or select a layer to justify all text in the layer.

2. Press Ctrl and one of the numbers on the numeric keypad to justify selected text in the 
corresponding position of the selected text field.

n If you select only some of the text in a field, that text is justified in a separate field.

Justifying a Rectangle, Ellipse, or Text Layer

To justify a rectangle, ellipse, or text layer:

1. Select the rectangle, ellipse, or text layer.

2. Do one of the following:

t On the text bar, click the appropriate justification button to alter horizontal 
justification, vertical justification, or both, then select the desired setting.

t Select Text > Justify, then select a setting for horizontal or vertical justification or 
both.
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t Press Ctrl and one of the numbers on the numeric keypad to justify the rectangle or 
ellipse in the corresponding position of the Program window.

Deleting Text and Layers

Deko provides many ways to delete text and layers, as well as clear the background (and 
layers) from an active graphic.

The following topics provide more information about deleting text and layers:

• “Deleting Text” on page 228

• “Deleting All Text Within a Layer Without Deleting the Layer” on page 229

• “Deleting One or More Layers” on page 229

• “Deleting All Layers (but not the Background)” on page 229

• “Clearing the Background from the Active Graphic” on page 229

• “Clearing the Layers and the Background from the Active Graphic” on page 229

• “Having Deko Prompt You to Save Modified Files before Clearing Them” on page 230

Deleting Text

To delete text:

1. Select the text to be deleted.

2. Do one of the following:

t Select Edit > Delete.

t Press Delete.
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Deleting All Text Within a Layer Without Deleting the Layer

To delete all text within a layer without deleting the layer:

1. Select a text layer.

2. Do one of the following:

t Select Layer > Clear Text.

t Press Shift+Ctrl+T.

The emptied layer remains in the graphic.

Deleting One or More Layers

To delete one or more layers:

1. Select the layer(s). 

n The best way to select multiple layers is to launch the Layer Browser and use the Ctrl+Shift 
keys to highlight multiple layers. 

2. Click in the Program window and do one of the following:

t Press Delete.

t Select Layer > Delete Layer.

Deleting All Layers (but not the Background)

To delete all layers but leave the background intact:

t Select Edit > Clear Layers (F8). 

Clear Layers replaces all the layers in the graphic with a single, empty text field. The 
Background remains intact.

Clearing the Background from the Active Graphic

To clear the background from the active graphic:

t Select Edit > Clear Background (Ctrl+F8).

Clearing the Layers and the Background from the Active Graphic

To clear the layers and the background from the active graphic:

t Do one of the following:

- Select Edit > Clear All.

- Press Alt+F8 or press F8 twice in rapid succession (SK).
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- Press Clear Program or Clear Preview (FAK).

Having Deko Prompt You to Save Modified Files before Clearing  
Them

To have Deko prompt you to save modified files before clearing them:

1. Select Options > Preferences. 

The Preferences dialog box opens.

2. Select Prompts.

The Prompts dialog box opens.

3. Select Prompt to save before clearing or opening a window.

Cutting and Pasting Text or Layers

You can cut, copy, and paste text or layers.

The following topics provide more information about cutting and pasting text or layers:

• “Cutting or Copying Text or a Layer” on page 230

• “Pasting Text” on page 230

• “Pasting a Layer” on page 231

Cutting or Copying Text or a Layer

To cut or copy text or a layer:

1. Select the text or layer to be cut or copied.

2. Do one of the following:

t To cut the selected text or layer, select Edit > Cut (Ctrl+X), or click the Cut button 
on the text bar.

t To copy the selected text or layer, select Edit > Copy (Ctrl+C) > Selected, or click 
the Copy button on the text bar.

Pasting Text

To paste text:

1. Position the cursor where you want to insert the most recently cut or copied text.

2. Select Edit > Paste (Ctrl+V), or click the Paste button on the text bar.



Typing on a Curve

231

n When you cut or copy text, it is saved in the Windows clipboard. Unlike moving text, cutting 
and pasting text changes the location of the text cursor. When you move text, the cursor 
appears in the original location of the text even after the text has been moved. When you cut 
and paste text, the cursor follows the text.

Pasting a Layer

To paste a layer:

1. If you are moving the layer to a different file, open the destination file.

2. Select any layer in the graphic where you want to paste the layer.

3. Select Edit > Paste (Ctrl+V), or click the Paste button on the text bar. 

Deko pastes the most recently cut or copied layer directly in front of the selected layer. 
You can then move or rearrange layers as described in “Moving Text and Layers” on 
page 219.

Typing on a Curve
A baseline determines how characters are positioned one after another. By default, the 
baseline for typing text is a straight horizontal line. Using Deko's Baseline Edit feature, you 
can edit the current baseline to type text on a curve or reposition the baseline for existing 
text.
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You can use a circle or an ellipse as a baseline. 

Your baseline can be a rectangle.
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You can draw and edit any kind of curve for your baseline. 

Controlling the Placement of Text Within a Graphic

Deko contains the following features for controlling the placement of text in your graphics:

• “Controlling the Placement of Text Within a Graphic” on page 233

• “Editing a Baseline” on page 237

Creating a Baseline

Deko enables you to create the following types of baselines:

• Curve

• Ellipse

• Rectangle

• Line segment

The following topics provide more information about creating baselines:

• “Creating a Curve, an Ellipse, or a Rectangle Baseline” on page 234

• “Drawing a Line-Segment Baseline” on page 236
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Creating a Curve, an Ellipse, or a Rectangle Baseline

To create a curve, an ellipse, or a rectangle baseline:

1. Select the layer for your baseline, or simply activate and clear the Program window to 
apply the baseline to the default layer. 

If text is already typed in the layer, it is positioned on the baseline after completing all 
the steps in this process. Any new text typed in the layer after this process displays on 
the baseline.

2. Select Layer > Edit Baseline to activate the Baseline Edit window and show Baseline on 
the Menu bar.

3. Do one of the following:

t Select Baseline > Draw Curve. The mouse pointer becomes a drawing tool.

t Click the curve drawing tool, the ellipse tool, or the rectangle tool button in the 
Tools window.

4. Position the drawing tool. 
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5. Drag the mouse to draw the baseline.

n If you clicked the ellipse or rectangle drawing tool, holding Ctrl as you drag the pointer 
maintains a perfect square or circle.

6. Once you have drawn the baseline as you want it, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.
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Text in the layer is positioned on the baseline. Text subsequently typed in the layer is 
also positioned on the baseline.

Drawing a Line-Segment Baseline

To draw a line-segment baseline:

1. Select the layer whose baseline you want to modify.

2. Activate the Baseline Edit window.

3. Do one of the following:

t Select Baseline > Draw Curve.

t Click the drawing tool button in the Tools window.

4. Click and release to make one endpoint of the line. 

5. Move the mouse (you do not have to click and hold) to move the line tool to the other 
endpoint and click. Repeat this step as desired to draw multiple line segments. To break 
the line, move the cursor out of the Baseline Edit window. 

6. Once you have drawn the baseline as you want it, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.
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t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Editing a Baseline

Once you have created a baseline, you can do any of the following to modify it:

• “Deleting or Inserting a Point on a Baseline” on page 237

• “Reversing the Direction of the Baseline” on page 239

• “Changing the Type of Point on the Baseline” on page 240

• “Adjusting the Continuity Between Two Bézier Curves” on page 242

• “Reshaping a Baseline by Moving the Points” on page 242

• “Cancelling Changes to a Baseline” on page 243

Deleting or Inserting a Point on a Baseline

To delete or insert a point on a baseline:

1. If you are not already in the Baseline Edit mode, select Layer > Edit Baseline.

2. Select Baseline > Edit Curve.
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3. Do one of the following:

t Click the point you want to delete, then select Baseline > Delete Selected Point 
(Delete).

t Select Baseline > Insert Point (Insert), and then click on the curve where you want 
to insert the point.

The baseline changes shape according to the point deleted or inserted. 
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4. Once you have edited the baseline as desired, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Reversing the Direction of the Baseline

To reverse the direction of the baseline:

1. If you are not already in the Baseline Edit mode, select Layer > Edit Baseline.

2. Select Baseline > Reverse Baseline.
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3. Once you have edited the baseline as desired, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Changing the Type of Point on the Baseline

To change the type of a point on the baseline:

1. Select Baseline > Edit Curve.
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2. Click the point to select it. 

The selected point displays red.

3. In the Baseline menu, do one of the following:

t Select Move To for a point that begins a new section of the baseline.

t Select Line To for a point connected to the previous point by a straight line.
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t Select Bezier for a point connected to the previous point by a Bézier curve.

n Illustrations reflect changes after applying the menu choice as described in Step 4.

4. Once you have edited the baseline you want, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Adjusting the Continuity Between Two Bézier Curves

To adjust the continuity between two Bézier curves:

1. Select Baseline > Edit Curve.

2. Click the point shared by the two curves.

3. In the Baseline menu, do one of the following:

t Select Cusp for no continuity. The control points on either side of the shared point 
move independently.

t Select Smooth for C1 continuity.

t Select Symmetric for C2 continuity.

4. Once you have edited the baseline as desired, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Reshaping a Baseline by Moving the Points

To reshape a baseline by moving the points:

1. Click a point and drag it.
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2. Once you have edited the baseline as you want, do one of the following:

t To apply the baseline and remain in Baseline Edit mode, select Baseline > Apply 
Baseline, or press Enter.

t To apply the baseline and close the Baseline Edit window, select Baseline > Accept 
Baseline, or press Alt+Enter.

Cancelling Changes to a Baseline

To cancel changes to a baseline:

t Do one of the following:

- To cancel all changes and exit the Baseline Edit window, select Baseline > Cancel.

- If Undo is enabled, you can select Edit > Undo (Ctrl+Z) for each change you want 
to undo. 

- To clear the baseline, select Edit > Clear Baseline (F8).

Using Tab Stops

Tab stops are an effective way to organize columns of information in a graphic; they allow 
you to: 

• Easily replace data or text in the graphic

• Rearrange rows of text in a graphic

For more information, see “Creating and Using a Leaderboard” on page 366.

The following topics provide more information about using tab stops:

• “Setting Tab Stops” on page 244

• “Clearing Tab Stops” on page 244

• “Finding Tab Stops” on page 244

• “Moving Tab Stops” on page 245

• “Cutting or Copying Tab Stops” on page 245

• “Pasting Tab Stops” on page 245

• “Changing the Decimal Tab Character” on page 245

• “Displaying or Hiding Tab Markers” on page 246
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Setting Tab Stops

To set a tab stop:

1. Position the cursor in the text where you want to insert the tab stop.

2. Do one of the following:

t Select Text > Tab Set.

t Press Alt+T+T (SK).

t Press Tab Set (FAK).

3. Select an alignment (Right, Left, Center or Decimal) from the menu.

The current tab settings for a text field are displayed at the bottom of the text field box, 
using the following markers:

Whenever you Tab to a tab stop, a similar tab marker is displayed to the left of the first 
character at the tab stop.

Clearing Tab Stops

Deko enables you to clear a selected tab stop or all tab stops.

To clear a selected tab stop:

1. Tab to the tab stop.

2. Select Text > Tab Clear.

To clear all tabs within a layer:

t Select Text > Tab Clear All.

Finding Tab Stops

To find a tab stop:

t Do one of the following:

- Locate the tab stop to the right of the last character typed in the previous column.

- For the first column, locate your tab stop, with the cursor in the column, by pressing 
the Home Key.

- Confirm that your cursor is on a tab by seeing the word “Tab” on the left side of the 
status bar at the bottom of your screen. 
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Moving Tab Stops

To move a tab stop:

1. Position the cursor to the left of the tab stop.

2. Set the increment of change by doing one of the following:

t Select Options > Transform > Coarse. 

t Select Options > Transform > Fine.

3. Do one of the following:

t Select Options > Transform > Move.

t Press Move (FAK).

t Click the Move button in the Tools window.

4. Press Alt and use the Right or Left arrow keys to move the tab stop.

Cutting or Copying Tab Stops

To cut or copy a tab stop:

1. Select the tab stop you want to cut or copy.

2. Do one of the following:

t To remove the selected tab stop from its current position, select Edit > Cut (Ctrl+X), 
or click the Cut button in the Tools window.

t To copy and leave the selected tab stop intact, select Edit > Copy (Ctrl+C) > Tabs, 
or click the Copy button in the Tools window.

Pasting Tab Stops

To paste a cut or copied tab stop:

1. If necessary, open the file into which you want to paste the tab stop.

2. Position the text cursor where you want to insert the cut or copied tab stop.

3. Select Edit > Paste (Ctrl+V), or click the Paste button in the Tools window.

Changing the Decimal Tab Character

To change the decimal tab character:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Click the Common tab.
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3. In the Decimal tab char text box, type a new decimal tab character.

4. Select OK or press Enter.

Displaying or Hiding Tab Markers

To display or hide tab markers:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Click the Markers tab.

3. Select or deselect Tab stops from the Show area.

4. Select OK, or press Enter.
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Deko enables you to create your own charts and graphs using the Chart Designer dialog box. 
The Chart Designer dialog box enables you to add a series, and assign data to your chart.

The following topics describe how to access the Chart Designer and to create charts and 
graphs:

• “Accessing the Chart Designer” on page 247

• “Basic Procedure for Creating Charts” on page 248

• “Working with Advanced Controls” on page 255

Accessing the Chart Designer

A chart is displayed within a rectangle layer in the Preview or Program window. This topic 
shows you how to access the Chart Designer.

To access the Chart Designer:

1. With a Preview or Program window open, in the Face Shader dialog box, select Texture. 

2. Click on the Rectangle in the Tools dialog box.

The Rectangle dialog box opens, and the cursor turns into a rectangle tool. 

3. With the cursor, draw a rectangle in the Preview or Program window to the approximate 
size you want your chart to fit in. For more information on creating rectangles, see 
“Adding a Rectangle to a Graphic” on page 162.

n This can be resized at any time.

4. In the Rectangle dialog box, click the Layer button.

5. In the Auto-Update (Texture) area, select Chart from the Source field.

When you select Chart from the list, the Frequency field appears. This field enables you 
to select how often (in seconds) you want the chart to render (refresh).

6. Use the arrows in the Frequency field to select how often (in seconds) you want the 
chart to render (refresh).



6  Working with Charts and Graphs

248

7. Click the View button to display the Chart Designer dialog box. This enables you to set 
up the type of chart you want to create.

The Chart Designer dialog box opens.

8. Next you can use the Chart Designer dialog box to add a series, and assign data to your 
chart.

For more information on using the Chart Designer in both Deko and DekoCast, see 
“Basic Procedure for Creating Charts” on page 248.

Basic Procedure for Creating Charts

The Chart Designer enables you to create custom charts from information that is populated 
in your database. The database must be linked to your Deko or DekoCast system. When 
creating a chart, there are three required tasks you must perform:

• Create (or add) a Series. A Series is the type of chart you want to create. Examples 
include Bar series, Pie series, Line series, and so on. For more information, see 
“Creating a Series” on page 249.

• Assign data to your chart. For more information, see “Assigning Data to a Series” on 
page 253.
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Creating a Series

When working in the Chart Designer, the first task you must perform is to create a Series, 
which is the type of chart you want to create. There are a number of different charts and 
variations that you can choose from. Examples are Bar chart, Pie chart, Line chart, and so 
on. 

To create a series:

1. Access the Chart Designer dialog box. For more information, see “Accessing the Chart 
Designer” on page 247.

The Chart Designer dialog box opens.

2. If not already selected, select Series in the left column. 

n The Appearance tab should be preselected by default.

The Series > Appearance page appears. The Series Selection area displays the current 
series. As shown in the preceding example, this is Series 1.

3. In the Series Type field, select the Series type from the drop down list. 

This is the type of chart that you want to make. Options are: Area, Bar, Line, Pie, and so 
on.

4. Select whether you want your chart to be two dimensional or three dimensional by 
clicking on the appropriate option. Choices are 2D or 3D.
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5. Select the presets for the type of series you selected by clicking on one of the presets to 
view what your series will look like with these presets applied. 

The Series Presets area contains various presets for the series you selected. In the 
previous example, a Bar chart was selected, therefore, the presets listed all apply to a 
Bar Chart. 

n You can try different presets until you find the right one for your series.

6. (Optional) If you want to add another series, do the following:

a. Select Series List in the second column from the left.

b. Type a name for the new series in the bottom row of the Series List table.

c. Press the Add button.

7. Select attributes for your chart by clicking the Attributes tab. You can then change 
certain attributes for your series.

The attribute information that you can change is different based on the type of chart you 
selected.

8. Click Save and Exit to save your changes and close the Chart Designer.

9.  Next, you can use the Chart Designer dialog box to configure chart settings. For more 
information, see “Configuring Chart Settings” on page 250.

Configuring Chart Settings

The second required task when creating a chart in the Chart Designer is to assign visual 
effects to your series (chart). The Jitter is especially important to set. Jittering is a special 
visual effect that enables you to anti-alias the whole scene. The idea behind it is very simple: 
the control renders several samples of the image, each with a small offset in the X and Y 
directions. These samples are then added together to produce the final image. 

n Note that jittering slows down the rendering speed. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To assign visual effects:

1. Select Configuration in the left column. 

The Configuration > Chart Settings page displays enabling you to assign visual effects 
to the selected series.

2. In the Chart Antialias Properties area, the Enable Antialiasing check box by default is 
selected. If you do not want to enable anti-aliasing, deselect it.

3. In the Chart Jitter Properties area, do the following:

a. If you want to turn jittering on, select the Enable Jittering check box to turn jittering 
on. The Jittering Steps field becomes active.

b. In the Jittering Steps area, click the arrow, and from the list, select the number of 
sample (steps) of jittering you want to apply to your chart.

c. Use the Jittering Deviation slide bar to control the maximum offset along the X and 
Y directions of the generated samples relative to the original image.

4. In the Chart Blend Properties area, select the Enable Double Pass Blending check box if 
you want to enable double pass blending.

5. Click Save and Exit to save your changes and close the Chart Designer. Your next step is 
to determine interactivity for a series. For more information, see “(Optional) Assigning 
Interactivity for the Mouse” on page 252.
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(Optional) Assigning Interactivity for the Mouse

An optional task you can perform now when creating a chart in the Chart Designer is to 
determine what the mouse controls when it is moved over the Preview window. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To determine interactivity for the mouse:

1. Select the Interactivity submenu from the Configuration tab. 

The Configuration > Interactivity page displays enabling you to determine the what the 
mouse controls when it is moved over the Preview window.

2. In the Interactivity Properties area, select the mode that reflects what you want the 
mouse to control when it is moved over the Preview window. Options include the 
following:

t Disabled - Mouse movements over the Preview window will have no effect on the 
chart.

t Rotate - Mouse movements over the Preview window will modify the 
View/Projection Rotation and Elevation values of the chart. This option only works 
for 3D charts.

t Zoom - Mouse movements over the Preview window will modify the 
View/Projection zoom value of the chart. This option only works for 3D charts.



Basic Procedure for Creating Charts

253

t Offset - Mouse movements over the Preview window will modify the View/Margin 
values of the chart.

n The left mouse button must be held down during mouse movements over the Preview window 
for any parameter modifications to take place.

3. Click Save and Exit to save your changes and close the Chart Designer. Your next step is 
to assign data to a series. For more information, see “Assigning Data to a Series” on 
page 253.

Assigning Data to a Series

The third required task when creating a chart in the Chart Designer is to assign data to your 
series (chart). The data you assign comes from an existing ODBC database that you must 
select. This procedure assumes that you have already added a series as described in 
“Creating a Series” on page 249.

To assign data to a series:

1. Select Series, then select the Import submenu. 

The Series > Import page enables you to select your database, connect to a database, and 
import data.

2. In the Series Selection area, select the series for which you want to assign data to. 
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3. In the Database Selection area, do the following: 

a. Select the database you want to connect to for this series from the Database drop 
list. When you click the drop down arrow, a list of currently defined ODBC 
databases appears. 

b. In the UserID field, type the username to access the selected database.

c. In the Password field, type the password for the user.

4. In the Database Connection area, select the check box that indicates how you want to 
load the data. Options are:

a. Static Binding - Select Static Binding if you want to load the data now, without 
updates.

b. Dynamic Binding - Select Dynamic Binding if you want to continually load the 
data, and update the chart when the data changes. 

n You will not see the chart update when looking in the Chart Designer window. In Dynamic 
Binding mode, the chart will update in the Deko or DekoCast application windows when the 
data changes. 

5. Select the Data Import button. The dialog box changes to enable you to select the 
Database Table, and Data Series Assignments. Do the following:

n Make sure you click on the database that contains the data you want to use.

a. In the Current Database Table drop down list, select the database table that you 
want to use.

b. In the Data Series Assignments drop down list, do the following in the Database 
Column for each Data Series: 

t Select the values you want to use in your series. These values are graphically 
represented as points on the chart.

t Select the labels you want to use in your series. These are typically represented 
as names (such as Company names, and so on).

t Select the Fill effects you want to use in your series.

t (Optional) Select the line properties you want to use in your series.

6.  Select the View Database button to view the information in the database.

7.  Select the Import button to import the information from the database into the selected 
Data Series.

8.  Repeat Steps 1-5 for each Series you create.

9. Click Exit Data Import to close the Data Import screen, then click Save and Exit to save 
your changes and close the Chart Designer.
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Working with Advanced Controls

This section contains information regarding Advanced Controls that are available for use in 
the Chart Designer. Advanced Controls are the remaining controls in the Chart Designer that 
you can use to tweak your charts to a more precise degree than you can using the “Basic 
Procedure for Creating Charts” on page 248 presented previously in this chapter.

In this section, we organized the Advanced Controls by their Menu order. Therefore, see the 
following sections for more information on the Advanced Controls that you are interested in 
changing for your series (chart):

• Using Series Controls

• Using Axes Controls

• Using Background Controls

• Using Labels Controls

• Using Legend Controls

• Using Walls Controls

• Using Watermarks Controls

• Using Lighting Controls

• Using View Controls

• Template Configuration Controls

Using Series Controls

This section contains information on using the Series Controls to further adjust the look of 
your series.

Procedures for Series Appearance, and Series Import are described in the section “Basic 
Procedure for Creating Charts” on page 248.

For more information on setting specific axes controls, see one of the following topics:

• “Setting the Series Attributes” on page 256

• “Setting the Series Data Labels” on page 259

• “Setting the Series Data Points” on page 262

• “Setting the Series Legend” on page 263

• “Setting the Series Markers” on page 264

• “Modifying the Series List” on page 265
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Setting the Series Attributes

This procedure contains information on how to set the series attributes (attributes, style and 
text) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the series attributes:

1. Select Series in the left column, and then select the Attributes submenu.

The Series > Attributes page displays enabling you to set the series attributes, style, 
Properties and Dimensions for the selected series.

2. In the Series Style area, click the arrow in the Fill Mode field, and from the list, select 
the Fill mode (Series, Data Points or Pre defined) you want to apply to your series.

3. Click the Fill Effect button. 

The Fill Effect Editor dialog box opens, allowing you to change the fill effect for your 
chart.

4. Click the arrow in the Border Mode field, and from the list, select the Border mode 
(Series, Data Points or Pre defined) you want to apply to your chart.

5. Click the Border button. 

The Line Properties Editor dialog box opens, allowing you to change the line properties 
for your chart.
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6. Click the Shadow button. 

The Shadow Editor dialog box opens, allowing you to change the shadow properties for 
your chart.

7. Use the slider to get to the next page. 

The Series Properties area displays, allowing you to change the series properties for 
your chart.

 Do the following to change your series properties:

- In the Multi Bar Mode drop list, if you have created more than one series, select the 
series you want to modify attributes for.

n This list box is always disabled on the first series. If you have only created one series, it will 
always be disabled. If you have created more than one series, and all of the series are the 
same type (e.g. all are Bar series or all are Area series), it will be enabled.

- In the Style drop list, select the type of series.

- Select the Has Top Edge check box if you want the series to have a top edge.

- Select the Has Bottom Edge check box if you want the series to have a bottom edge.

- Use the Edge Percentage slider to determine the percentage of the edge of the 
series.

- Select the Inflate Margins check box to make the margins larger.
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8. Use the slider to get to the next screen. 

The Series Dimensions area displays, allowing you to change the series dimensions for 
your chart.

 Do the following to change your series dimensions:

- (Optional) If the Use Origin Value check box is selected, it indicates that the 
"Origin Value" slider below it should be used to control the origin value, instead of 
defaulting to begin at the minimum series value.

- Use the Origin Value slider to control the origin value of the series.

- Use the Gap Percentage slider to control the gap percentage of the series.

- Use the Width Percentage slider to control the width percentage of the series.

- Use the Depth Percentage slider to control the depth percentage of the series.

9. Use the slider to return to the initial Series Attributes page.

10. Click Save and Exit to save your changes and close the Chart Designer.
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Setting the Series Data Labels

If you want, you can then set the series data label properties for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the series data label properties:

1. Select Series in the left column, then select the Data Labels submenu.

The Series > Labels page displays enabling you to set the series data labels for the 
selected series.

2. In the Series Selection area, select the series you want to change from the list.

3. In the Data Label Properties area, click the arrow in the Mode list box, and select the 
mode that you wan to use. When you select the Every option, the Draw Every field 
becomes enabled. If you select the Subset option, the Subset List becomes enabled.

4. If you selected Every, do the following:

a. In the Draw Every field, type the number that represents how often/quickly you 
want the Chaert Designer to control how often the labels are re-drawn. 

n If the "Every" field is set to N, then the labels are drawn on every Nth data point.

b. If you want to change the arrow properties for your chart, click the Arrow 
Properties button. The Line Properties Editor dialog box opens. Make your changes 
and click OK to save and close the dialog box.
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c. If you want to change the text properties for your chart, click the Text Properties 
button. The Text Properties Editor dialog box opens. Make your changes and click 
OK to save and close the dialog box.

5. Use the slider to get to the next page. The Data Label Format area displays.

 Do the following to format your data label:

a. In the Data Label Text field, select the parameters (e.g., <value>, <label>, etc.) for 
your data labels.

b. Use the Format drop list to select a predefined format for the data labels.

c. (Optional) In the Custom format text box, select a custom format for the data labels. 
If the Format drop-down box is set to "Custom Number" or "Custom Date/Time", 
then the "Custom Format" textbox is enabled. 

For more information regarding the format specifier that you can use in the Custom 
format text box, refer to the “Formatting Types” section of the .NET Programming 
Guide.
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6. Use the slider to get to the next page. 

The Data Label Position area displays.

 Do the following to position your data label:

a. In the Vertical Alignment drop list, select the vertical alignment (Top, Center, or 
Bottom) for your data label.

b. Use the Arrow length slider to control the arrow length you want to use for the data 
labels.

7. Use the slider to return to the initial Series Data Labels page.

8. Click Save and Exit to save your changes and close the Chart Designer.
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Setting the Series Data Points

If you want, you can then set the series data point properties for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the series data point properties:

1. Select Series in the left column, then select the Data Points submenu.

The Series > Data Points page displays enabling you to set the series data point 
properties for the selected series.

2. In the Series Selection area, select the series you want to change from the list.

3. In the Data Table area, the following fields appear in the table. Edit any of these fields 
by either typing in a new value or label, or clicking on a fill effect, or line property to 
bring up the associated dialog box.

4. Click Save and Exit to save your changes and close the Chart Designer.
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Setting the Series Legend

If you want, you can then set the series legend properties for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the series legend properties:

1. Select Series in the left column, then select the Legend submenu.

The Series > Legend page displays enabling you to set the series legend for the selected 
series.

2. In the Series Selection area, select the series you want to change from the list.

3. In the Legend Properties area, click the arrow in the Mode list box, and select the mode 
that you wan to use. When you select the Data Points option, the rest of the screen 
becomes active.

4. In the Data Label Text field, do the following:

a. Select the parameters (e.g., <value>, <label>, etc.) for your Legend.

b. Use the Format drop list to select a predefined format for the Legend.

c. (Optional) In the Custom format field, to select a custom format for the Legend.

5. Click Save and Exit to save your changes and close the Chart Designer.



6  Working with Charts and Graphs

264

Setting the Series Markers

This procedure contains information on how to set the series markers (attributes, style and 
text) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the series markers:

1. Select Series in the left column, and then select the Markers submenu.

The Series > Markers page displays enabling you to set the marker Style, and 
Dimensions for the selected series.

2. In the Series Selection area, select the series you want to change from the list in the 
Current Series list box.

3. In the Marker Style area, click the arrow in the Shape field, and from the list, select the 
shape of the marker you want to apply to your chart.

4. Click the Fill Effect button. 

The Fill Effect Editor dialog box opens, allowing you to change the fill effect for your 
marker.

5. Click the arrow in the Vertical Alignment field, and from the list, select the type of 
vertical alignment (Top, Center, Bottom) you want to apply to your marker.
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6. Click the Border button. 

The Line Properties Editor dialog box opens, allowing you to change the line properties 
for your chart.

7. In the Marker Dimensions area, do the following: select the series you want to change 
from the list in the Current Series list box.

a. Use the Width slider to change the width of the marker.

b. Use the Height slider to change the height of the marker.

c. Use the Depth slider to change the depth of the marker. (for 3D charts only).

d. Select the Auto Depth check box if you want to depth to set automatically (for 3D 
charts only).

8. Click Save and Exit to save your changes and close the Chart Designer.

Modifying the Series List

This procedure contains information on how to modify the series list.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To modify the series list:

1. Select Series in the left column, and then select the Series List submenu.

The Series > Series List page displays enabling you to modify the series list.
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2. In the Series List area, select the series you want to modify, and do one of the following:

t To add another series to the list, click the Add button. This copies the existing 
series.

t To modify a series, click the Modify button. This modifies the title of the series. For 
example, if the series is called “Series 1” and you want to change it to be “Bar 
Series”, you select “Series 1” in the Series List, then type “Bar Series” in the edit 
box (just above the Modify button), then press the Modify button.

t To delete a series from the list, click the Delete button.

3. Click Save and Exit to save your changes and close the Chart Designer.

Using Axes Controls

This section contains information on using the Axes Controls to further adjust the look of 
your series.

For more information on setting specific axes controls, see one of the following topics:

• “Setting the Axes Appearance” on page 267

• “Setting the Axes ConstLines” on page 268

• “Setting the Axes Gridlines” on page 270

• “Setting the Axes Labels” on page 271

• “Setting the Axes Paging” on page 272

• “Setting the Axes Position” on page 274

• “Setting the Axes Stripes” on page 275

• “Setting the Axes Ticks” on page 277

• “Setting the Axes Title” on page 278
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Setting the Axes Appearance

This procedure contains information on how to set the axis appearance (attributes, style and 
text) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes appearance:

1. Select Axes in the left column.

The Axes > Appearance page displays enabling you to set the axis attributes, style and 
text for the selected series.

2. In the Axis Attributes area, select the Axis that you want to change from the list. 
Available options are described below:

- Vertical Axes - The Vertical axes are named PrimaryY and SecondaryY and are 
positioned on the left and right side of the chart. The PrimaryY axis is displayed on 
the front, and the SecondaryY axis is displayed on the back.

n The vertical axes are used to scale the series in the Y dimension. By default, all series are 
scaled on the PrimaryY axis. The SecondaryY axis is, by default, not visible.

- Horizontal Axes - The Horizontal axes are named PrimaryX and SecondaryX and 
are positioned on the top and bottom sides of the chart. The PrimaryX axis is 
displayed on the front while the SecondaryX axis is displayed on the back. 
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n The horizontal axes are used to scale the series in the X dimension. By default, all series are 
scaled on the PrimaryX axis. The SecondaryX axis is, by default, not visible.

- Depth Axis - The Depth axis (there is only one) is by default displayed on the 
bottom right-hand chart edge. It is used to scale the series along the chart depth 
dimension. All chart series are scaled on the depth axis.

- Special Axes - Two special axes are available. These (called Radar and Polar) can 
be used by the Radar and Polar Series.

3. Select or deselect the Visible check box depending on whether you want the number on 
the selected axis to be visible.

4. In the Axis Style area, click the arrow in the Shape field, and from the list, select the 
shape (Line, Bar or Tube) you want to apply to your chart.

5. In the Axis Text area, click the Text Properties button, and change the text properties for 
your chart.

6. Use the Jittering Deviation slide bar to control the maximum offset along the X and Y 
directions of the generated samples relative to the original image.

Setting the Axes ConstLines

ConstLines stands for Constant Lines and are lines that are drawn at constant axis values (X, 
Y or Depth axis) of a chart. These lines are used to ponit out particular axis values. Besides 
being able to specify the axis value for the constline, one can also specify properties of the 
line including thickness and color.

If you want, you can then set the axes Constlines (attributes, Line List, Line Style, and Line 
values) for your chart. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the axes Constlines:

1. Select Axes in the left column, and then select the ConstLines submenu.

The Axes > ConstLines page displays enabling you to set the Axis attributes, Line List, 
Line style, and Line values for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. Select or deselect the Visible check box depending on whether you want the number on 
the selected axis to be visible.

4. In the Line List area, click the Add button to add the amount of Line numbers you want 
to display in your chart. The rest of the dialog box becomes enabled.

5. In the Line Style area, click the arrow in the Shape field, and from the list, select the 
shape (Line or Plane) you want to apply to your chart. 

t If you selected Line from the Shapelist, click the Line Properties button, if you want 
to change the Line properties for your chart.

t If you selected Plane from the Line Style area, in the Axis Text area, you can click 
the Fill Effect button if you want to change the Fill effect for your chart.

6. Use the Constant Value slide bar to control the location of the line along the X and Y 
directions.

7. If you want to change the Begin value or End value for a Line, select the Enable 
Begin/End check box, and then use the appropriate slide bar to change the location. 

These only work when the “Current Axis” is set to “PrimaryY”. They do not work for 
the “PrimaryX” axis.
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Setting the Axes Gridlines

If you want, you can then set the axis Gridlines (attributes, major and minor gridlines) for 
your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes Gridlines:

1. Select Axes in the left column, and then select the Gridlines submenu.

The Axes > Gridlines page displays enabling you to set the axis attributes, and major 
and minor gridlines for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. In the Major Gridlines area, do the following:

a. Select or deselect the check box to reflect which major gridlines you want to be 
visible.

b. If you want to change the line properties for the selected major gridlines, click the 
Line Properties button, and make your changes in the Line Properties Editor dialog 
box.
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4. In the Minor Gridlines area, do the following:

a. Select or deselect the check box to reflect which minor gridlines you want to be 
visible.

b. If you want to change the line properties for the selected minor gridlines, click the 
Line Properties button, and make your changes in the Line Properties Editor dialog 
box.

5. Click Save and Exit to save your changes and close the Chart Designer.

Setting the Axes Labels

If you want, you can then set the axes labels (attributes, list, text, and position) for your 
series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes labels:

1. Select Axes in the left column, then select the Labels submenu.

The Axes > Labels page displays enabling you to set the axis attributes, label list, label 
text, and label position for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. Select or deselect the Visible check box depending on whether you want the number on 
the selected axis to be visible.
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4. In the Label List area, click the Add button to add the amount of Line numbers you want 
to display in your chart. The rest of the dialog box becomes active.

5. In the Label Text area, do the following:

a. Type the label text you want to appear for the selected label list.

b. If you want to change the text properties for your chart, click the Text Properties 
button. The Text Properties Editor dialog box opens. Make your changes and click 
OK to save and close the dialog box.

c. If you want to change the line properties for your chart, click the Line Properties 
button. The Line Properties Editor dialog box opens. Make your changes and click 
OK to save and close the dialog box.

6. In the Label Position area, do the following to position your label:

a. Use the Position Value slide bar to control the location of the selected label along 
the X or Y axes.

b. Use the Offset Value slide bar to control the location of the selected label. The 
Offset value will move according to how the angle is set, whereas, the position 
value will not. If you have the angle value set to 0, the Offset and Position values 
will appear to do the same thing.

c. Use the Angle Value slide bar to control the angle location of the selected label.The 
Angle Value slider allows you to control the direction of the offset specified by the 
Offset value.

7. Click Save and Exit to save your changes and close the Chart Designer.

Setting the Axes Paging

If you want, you can then set the axis paging (attributes, Page mode, and Current page) for 
your series. 

Axis rulers can be configured to work in paging mode. When operating in Paging mode, the 
axis shows only a fraction of the total axis scale or, one of the several axis pages. By default 
rulers do not use paging. 

Before you enable paging in your chart, you must first determine how you want to specify 
the ruler page size. You can do this in two ways: 

• Specify the total number of pages that the ruler will possess regardless of the axis scale.

• Specify a fixed scale size for the axis page and let the page count vary depending on the 
total axis scale.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the axes paging:

1. Select Axes in the left column, then select the Paging submenu.

The Axes > Paging page displays enabling you to set the axis attributes, style and text 
for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. In the Page Mode area, do the following:

a. Select the option on how you want to display the page (Disabled, Fixed Page Count, 
Fixed Page size). If you select anything other than disable, the remainder of the 
dialog box becomes active, and you can change parameters for the page count or 
page size.

b. Use the Page Count slider to specify how many pages the axis should have. The 
page size is automatically calculated.

c. Use the Page Size slider to specify the size of the pages. The actual page count is 
determined automatically.
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4. In the Current Page area, select the option on how you want to display the page (Index 
mode or Value Mode):

 If you select anything other than disable, the remainder of the dialog box becomes 
active, and you can change parameters for the page count or page size. Once you have 
chosen the paging mode, you must specify the currently shown page of the axis. This 
can be achieved in two ways: either specify the exact index of an axis page, or simply 
specify a beginning value.

a.  Index Mode: In this mode, you specify the page index of the currently visible page 
with the "Current page index" scroller.

b. Value Mode: In this mode, you specify the value at which the currently displayed 
axis should begin using the "Current page value" scroller.

c. Use the Current Page Index or Current Page Value slide bar to control the currently 
displayed axis page.

5. Click Save and Exit to save your changes and close the Chart Designer.

Setting the Axes Position

If you want, you can then set the axes position (attributes, and position) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes position:

1. Select Axes in the left column, then select the Position submenu.



Working with Advanced Controls

275

The Axes > Position page displays enabling you to set the axis attributes, and position 
for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. Select or deselect the Visible check box depending on whether you want the number on 
the selected axis to be visible.

4. In the Axis Position area, click the arrow in the Home field, and from the list, select the 
home position (FrontBottom, FrontTop, or BackTop) you want to apply to your chart.

5. Use the Offset slide bar to control the offset along the X or Y directions of the generated 
axis relative to the original image.

6. Click Save and Exit to save your changes and close the Chart Designer.

Setting the Axes Stripes

If you want, you can then set the axis stripes (attributes, style and text) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes stripes:

1. Select Axes in the left column, then select the Stripes submenu.
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The Axes > Stripes page displays enabling you to set the axis attributes, stripe list, stripe 
style, and stripe values for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. In the Stripe List area, click the Add button to add a stripe number to the chart.

4. In the Stripe Style area, do the following:

a. Select the check box that best denotes where you want the stripe to be visible.

b. If you want to change the color of the stripe, click the Fill Effect button. The Fill 
Effect Editor dialog box opens. Make your changes and click OK to save and close 
the dialog box.

c. If you want to change the line properties for your chart, click the Line Properties 
button. The Line Properties Editor dialog box opens. Make your changes and click 
OK to save and close the dialog box.

5. In the Stripe Values area, use the Begin Value and End Value slide bars to control the 
location of where the stripe begins and ends.

6. Click Save and Exit to save your changes and close the Chart Designer.
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Setting the Axes Ticks

If you want, you can then set the axis ticks (attributes, major ticks (outer and inner), and 
minor ticks) for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes ticks:

1. Select Axes in the left column, then select the Ticks submenu.

The Axes > Ticks page displays enabling you to set the axis attributes, major tick (inner 
and outer), and minor ticks for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. Select or deselect the Visible check box depending on whether you want the ticks on the 
selected axis to be visible. 

4. In the Major Ticks (Outer) area, do the following:

a. Click the Line Properties button. The Line Properties Editor dialog box opens. 
Make changes to the line properties of the Major outer ticks, and click OK to save 
your changes and close the dialog box.

b. If you want to change the length of the ticks, use the Length slide bar to change the 
length of the ticks as they appear in the selected axis.
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5. In the Major Ticks (Inner) area, do the following:

a. Click the Line Properties button. The Line Properties Editor dialog box opens. 
Make changes to the line properties of the Major inner ticks. and click OK to save 
your changes and close the dialog box.

b. If you want to change the length of the ticks, use the Length slide bar to change the 
length of the ticks as they appear in the selected axis.

6. In the Minor Ticks area, do the following:

a. Click the Line Properties button. The Line Properties Editor dialog box opens. 
Make changes to the line properties of the Minor ticks. and click OK to save your 
changes and close the dialog box.

b. If you want to change the length of the ticks, use the Length slide bar to change the 
length of the ticks as they appear in the selected axis.

7. Click Save and Exit to save your changes and close the Chart Designer.

Setting the Axes Title

If you want, you can then set the axis title for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the axes title:

1. Select Axes in the left column, then select the Title submenu.
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The Axes > Title page displays enabling you to set the axis titles for the selected series.

2. In the Axis Attributes area, select the axis you want to change from the list.

3. Select or deselect the Visible check box depending on whether you want the selected 
axis to be visible.

4. In the Axis Title area, do the following:

a. In the Text field, type the text for the title you are adding to the selected axis of the 
chart.

b. Click the Text Properties button. The Text Properties Editor dialog box opens. Make 
changes to the text properties title, and click OK to save your changes and close the 
dialog box.

c. If you want to change the length of the ticks, use the Length slide bar to change the 
length of the ticks as they appear in the selected axis.

5. Click Save and Exit to save your changes and close the Chart Designer.
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Using Background Controls

This section contains information on using the Background Controls to further adjust the 
background of your series.

For more information on setting specific background controls, see one of the following 
topics:

• “Setting the Background Appearance” on page 280

• “Setting the Axes ConstLines” on page 268

• “Setting the Axes Title” on page 278

Setting the Background Appearance

If you want, you can then set the background appearance for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the background appearance:

1. Select Background in the left column.

The Background > Appearance page displays enabling you to set the background style 
for the selected series.
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2. In the Background Style area, select the frame type you want for this series. Options are:

t None - If selected, you cannot make any changes, other than Fill Effect, to the 
background of this series.

t Basic - If selected, you can access the Basic Frame submenu to further modify the 
Basic frame style border, color, bevel properties, and size.

t Image - If selected, you can access the Image Frame submenu to further modify the 
image frame style, corner widths, tube sizes, edge rounding, and light properties.

3. (Option) In the Background Style area, select the Transparent checkbox if you want the 
background of the chart to be transparent.

4. Click the Fill Effect button. 

The Fill Effect Editor dialog box opens.

5. Make changes in the Fill Effect Editor dialog box to select the desired fill effect for the 
background of your chart.

6. If you selected:

t Basic in the Frame Type drop list, the dialog box shows the Basic Frame Style 
Presets. Select the preset frame style that you want to use for the background of 
your chart. Once you save your changes, you can click on the Basic Frame submenu 
and follow the instructions in the topic “Setting the Basic Frame Background” on 
page 281.

t Image in the Frame Type drop list, the dialog box shows the Image Frame Style 
Presets. Select the preset frame style that you want to use for the background of 
your chart. Once you save your changes, you can click on the Image Frame 
submenu and follow the instructions in the topic “Setting the Image Frame 
Background” on page 283.

7. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Basic Frame Background

If you want, you can then set the appearance for a Basic Frame background for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the Basic Frame background:

1. Select Background in the left column, then select the Basic Frame submenu.

The Background > Basic Frame page displays enabling you to set the basic frame 
background style for the selected series.

2. In the Basic Frame Style area, do the following:

a. If you want to change the line properties for your frame border, click the Border 
button. The Line Properties dialog box opens. Set the line properties for the frame 
border, and click OK.

b. If you want to change the color of the area between the outer and inner bevels, click 
the Interbevel Color button. The Color dialog box opens. Make your color 
selections, and click OK.

3. In the Basic Frame Bevel Properties area, do the following:

a. In the Outer Type field, select the type of Outer bevel you want for your frame. 
Options are (None, Raised, or Sunken).

b. To change the dark color of the Outer bevel, click the Dark Color button below the 
Outer Type field, and select the color. 

c. To change the light color of the Outer bevel, click the Light Color button below the 
Outer Type field, and select the color.

d. In the Inner Type field, select the type of Inner bevel you want for your frame. 
Options are (None, Raised, or Sunken).
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e. To change the dark color of the Inner bevel, click the Dark Color button below the 
Inner Type field, and select the color.

f. To change the light color of the Inner bevel, click the Light Color button below the 
Inner Type field, and select the color.

4. In the Basic Frame Size area, do the following:

a. Use the Bevel Distance slider to change the bevel distance.

b. Use the Beval Width slider to change the bevel width.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Image Frame Background

If you want, you can then set the appearance for a Image Frame background for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the Image Frame background:

1. Select Background in the left column, then select the Image Frame submenu.

The Background > Image Frame page displays enabling you to set the Image frame 
background style for the selected series.
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2. In the Image Frame Style area, do the following:

a. In the Type drop list, select the type of frame.

b. If you want to change the fill effect for your frame, click the Fill Effect button. The 
Fill Effect Editor dialog box opens. Set the fill effect for the frame border, and click 
OK.

c. If you want to change the shadow of the frame bevel area, click the Shadow button. 
The Shadow Editor dialog box opens. Make your shadow selections, and click OK.

d. If you want to change the border for your frame, click the Border button. The Line 
Properties dialog box opens. Set the line properties for the frame border, and click 
OK.

e. If you want to change the background color of the frame, click the Bkgnd Color 
button. The Color dialog box opens. Make your background color selections, and 
click OK.

3. In the Image Frame Corner Widths area, do the following:

a. In the drop list, select the image frame corner width you want to change. Options 
are (All Corners, Left Corner, Right Corner, Top Corner, and Bottom Corner).

b. Use the slider beneath the drop list to adjust the corner(s) you selected. 

4. In the Image Frame Tube Sizes area, do the following:

a. In the drop list, select the image frame tube you want to change.

b. Use the slider beneath the drop list to adjust the tube you selected. 

5. Click the More button.
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The Background > Image Frame page displays more information enabling you to set the 
Image frame edge rounding and light properties for the selected series.

6. In the Image Frame Edge Rounding area, do the following:

a. Use the Inner Edge Percent slider to adjust the inner edge of the image frame.

b. Use the Outer Edge Percent slider to adjust the outer edge of the image frame. 

7. In the Image Frame Light Properties area, do the following:

a. If you want to change the light color of the image frame area, click the Light Color 
button. The Color dialog box opens. Make your light color selections, and click OK.

b. If you want to change the shadow color for your image frame, click the Shadow 
Color button. The Color dialog box opens. Make your shadow color selections for 
for the image frame, and click OK.

c. Use the Light Size slider to adjust the light size of the image frame background 
border. 

8. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Using Labels Controls

This section contains information on using the Labels controls to further adjust the look of 
your series.

For more information on setting specific labels controls, see one of the following topics:

• “Setting the Label Appearance” on page 286

• “Setting the Label Format” on page 288

• “Setting the Label Position” on page 289

• “Creating the Label List” on page 291

Setting the Label Appearance

If you want, you can then set how labels appear in your series. 

Before you can set the appearnce of a label, you must add a label in the Labels > Label List 
page as described in the topic “Creating the Label List” on page 291.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the label appearance:

1. Select Label in the left column.

The Label > Appearance page displays enabling you to set the label attributes, and style 
for the selected series.

2. In the Label Selection area, select the label you want to modify or create from the 
Current Label list.

3. In the Label Text area, type the text you want to appear on the label.

4. In the Label Style area, do any of the following to modify the appearance of your label: 

a.  If you want to change the color of the area within the label, click the Fill Effect 
button. The Fill Effect Editor dialog box opens allowing you to select your color. 
Click OK to save your selections and close the dialog box.

b. If you want to change the border style of the label, click the Border button. The Line 
Properties dialog box opens. Set the line properties for the label border, and click 
OK. 

c. If you want to change the shadow of the area within the Label, click the Shadow 
button. The Shadow Editor dialog box opens. Make your shadow selections, and 
click OK.

d. If you want to change the font of the area within the Label, click the Font button. 
The Font dialog box opens allowing you to select your color. Click OK to save your 
selections and close the dialog box.
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e. If you want to change the backplane of the area within the Label, click the 
Backplane button. The Backplane Object Editor dialog box opens allowing you to 
change the backplane properties of the label. Click OK to save your selections and 
close the dialog box.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Label Format

If you want, you can then set the format properties for the labels in your series. 

Before you can set the label format, you must add a label in the Labels > Label List page as 
described in the topic “Creating the Label List” on page 291.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the label format:

1. Select Label in the left column, then select the Format submenu.

The Label > Format page displays enabling you to set the format properties for your 
label.

2. In the Label Selection area, select the label you want to modify from the Current Label 
list.

3. In the Label Text area, type the text you want to appear on the label.
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4. In the Format Properties area, do any of the following to modify the appearance of your 
label: 

a. In the Text Type drop list, select one of the following text type options:

t Simple - Used for normal text that is displayed as the label.

t XML Formatted - XML formatted text that can set the font, fill effect, border 
and shadow of the text on a per-character basis is desired. 

b. In the Tab Size field, type a number indicating the size of the tab. This field 
specifies how many spaces actually replaces the tab if the Replace Tabs box is 
checked.

c. If you want to replace tabs, select the Replace Tabs check Box. Otherwise, leave it 
blank. 

If a Tab is included in the text (such as, the Tab key on the keyboard was pressed, 
this setting specifies whether to replace the tab with spaces. 

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Label Position

If you want, you can then set the position of the labels in your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the label position:

1. Select Label in the left column, and then select the Position submenu.

The Label > Position page displays, enabling you to set the position properties for the 
label.

2. In the Label Selection area, select the label you want to set position properties for from 
the Current Label list.

3. In the Position Properties area, do any of the following to modify the position properties 
of your label: 

a. If you want to change the horizontal alignment of the label, select the type of 
horizontal alignment you want to use from the Hoirizontal Alignemnt list. Options 
are Center, Left, and Right.

b. If you want to change the vertical alignment of the label, select the type of 
horizontal alignment you want to use from the Vertical Alignment list. Options are 
Center, Top, and Bottom. 

c. Use the Horizontal Offset slider to change the horizontal offset of the label.

d. Use the Vertical Offset slider to change the vertical offset of the label.

e. Use the Orientation slider to change the orientation of the label.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Creating the Label List

This topic contains information on how to add labels to your series. Once you have added a 
label, you can change it’s appearance, format, and position properties.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To create the label list:

1. Select Label in the left column, and then select the Label List submenu.

The Label > Label List page displays enabling you to add or delete labels for the 
selected series.

2. In the Label List area, do one of the following:

t To add a label, click the Add button.

t To delete a label, select a label, and click the Delete button.

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Using Legend Controls

This section contains information on using the Legend controls to further adjust the look of 
your series.

For more information on setting specific legend controls, see one of the following topics:

• “Setting the Legend Appearance” on page 292

• “Setting the Legend Layout” on page 293

• “Setting the Legend Marks” on page 295

• “Setting the Legend Position” on page 296

• “Setting the Legend Titles” on page 298

Setting the Legend Appearance

If you want, you can then set the Legend appearance for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the legend appearance:

1. Select Legend in the left column.

The Legend > Appearance page displays enabling you to set the legend attributes, and 
style for the selected series.
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2. In the Legend Attributes area, select the Legend Mode you want to use from the list. 
Options are: The legend can operate in three modes: Disabled, Automatic, and Manual. 

t Disabled - In disabled mode the legend is not displayed.

t Automatic - When you set the mode to Automatic, the legend data is supplied by 
the series of the charts associated with the legend.

t Manual - In manual mode, you control the displayed legend data items through the 
MarkList under the Marks sub-tab.

3. In the Legend Style area, do the following:

a. Click the Text Properties button, and change the text properties for your chart. The 
Text Properties Editor opens. Make your changes, and click OK.

b. Click the Backplane Props button, and change the backplane properties for your 
chart. The Backplane Properties Editor opens. Make your changes, and click OK.

c. Use the Text Offset slide bar to control the text offset for the Legend.

d. Use the Mark Size slide bar to control the mark size for the Legend.

4. In the Legend Presets area, select the button to indicate where you want the preset to 
appear on your chart. 

n Automatic must be selected for the Legend Presets area to be available.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Legend Layout

If you want, you can then set the Legend layout and cell properties for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the legend layout:

1. Select Legend in the left column, and then select the Layout submenu.

The Legend > Layout page displays enabling you to set the legend layout and cell 
properties for the selected series.

2. In the Layout Properties area, do the following:

a. In the Expand Mode drop list, select the Expand mode you want to use for the 
layout of this chart. 

- Selecting the Rows Fixed option enables the Row Count slider. 

- Selecting the Columns Fixed option enables the Column Count slider.

b. Use the Row Count slider to adjust the number of rows in the layout.

c. Use the Column Count slider to adjust the number of columns in the layout.

d. Use the Inflate Cell Width slider to adjust the width of the cells in the layout

e. Use the Inflate Cell Height slider to adjust the height of the cells in the layout

3. In the Cell Line Properties area, do the following:

a. If you want to change the horizontal grid lines for your chart, click the Horiz Grid 
Lines button. The Line Properties Editor opens. Make your changes, and click OK.

b.  If you want to change the vertical grid lines for your chart, click the Vert Grid Lines 
button. The Line Properties Editor opens. Make your changes, and click OK.

c. If you want to change the horizontal outline for your chart, click the Horiz Outline 
button. The Line Properties Editor opens. Make your changes, and click OK.
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d. If you want to change the vertical outline for your chart, click the Vert Outline 
button. The Line Properties Editor opens. Make your changes, and click OK.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Legend Marks

If you want, you can then set the Legend marks for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the legend marks:

1. Select Legend in the left column, then select the Marks submenu.

n Manual must be selected in the Legend > appearance page for the Marks submenu to be 
active.

The Legend > Marks area displays enabling you to set the Mark list, and Mark style for 
the selected series.
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2. In the Mark List area, do the following to add legend text to your chart:

a. Type any text you want to appear in the legend in the box directly above the Add 
button.

b.  Click the Add button, to add the text to the legend of your chart. 

n If you want to modify or delete information already added to a legend, click the Modify or 
Delete buttons.

3. In the Mark Style area, do the following:

a. Select the mark shape (the shape that appears directly in front of the Legend text) 
you want to use from the list.

b. If you want to change the color of the area within the Legend mark, click the Fill 
Effect button. The Fill Effect Editor dialog box opens allowing you to select your 
color. Click OK to save your selections and close the dialog box.

c. If you want to change the line properties of the Legend mark, click the Line 
Properties button. The Line Properties Editor dialog box opens allowing you to 
select your color. Click OK to save your selections and close the dialog box.

d. If you want to change the Line properties item data, click the Item Properties 
button. The Line Properties Editor dialog box opens allowing you to select your 
color. You have to increase the “Item Properties” width value in order to see 
anything. Click OK to save your selections and close the dialog box.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Legend Position

If you want, you can then set the Legend position for your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.



Working with Advanced Controls

297

To set the legend position:

1. Select Legend in the left column, and then select the Position submenu.

The Legend > Position area displays enabling you to set the legend position properties 
for the selected series.

2. In the Position Properties area, do the following:

a. In the Horizontal Alignment drop list, select the area where you want to align the 
Legend horizontally (Left, Center, or Right).

b. In the Vertical Alignment drop list, select the area where you want to align the 
Legend vertically (Top, Bottom, or Center).

c. In the Horizontal Margin slider to adjust the location of the legend horizontally 
along the chart.

d. In the Vertical Margin slider to adjust the location of the legend vertically along the 
chart.

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the Legend Titles

If you want, you can then set the Legend titles for your chart. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the legend titles:

1. Select Legend in the left column, and then select the Titles submenu.

The Legend > Titles area displays enabling you to set the legend attributes, and Legend 
text, and Legend footer for the selected series.

2. (Option) In the Legend Header area, do the following to add legend title header text 
(appears above the legend) to your chart:

a. Type any text you want to appear as a title for the legend in the Text field directly 
above the Text Properties button.

b.  Click the Text Properties button if you want to change the formatting and position 
of the text.

The Text Properties dialog box opens allowing you to adjust your text formatting. 
Click OK to save your selections and close the dialog box.
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3. (Option) In the Legend Footer area, do the following to add legend title footer text 
(appears beneath the Legend) to your chart.

a. Type any text you want to appear as a title to appear below the legend in the Text 
field directly above the Text Properties button.

b.  Click the Text Properties button if you want to change the formatting and position 
of the text.

The Text Properties dialog box opens allowing you to adjust your text formatting. 
Click OK to save your selections and close the dialog box.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Using Walls Controls

This section contains information on using the Walls controls to further adjust the look of 
your series.

For more information on setting a specific wall style for a series, see the following topic:

• “Setting the Wall Appearance” on page 299

• “Setting the Wall Size” on page 301

Setting the Wall Appearance

If you want, you can then set the appearance of the walls for your chart. If you are working 
on a 2D chart, you can only set the Wall style for the Back wall of the selected series. If you 
are working on a 3D chart (as selected in the Series > Appearance tab), you can set the wall 
style for the Back, Floor, Front, Left, Polar, Radar, and Right wall of the selected series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the Walls style:

1. Select Walls in the left column.

The Walls > Appearance area displays enabling you to set the Wall Style for the selected 
series.

2. In the Wall Selection area, do the following: 

a. In the Current Wall drop list, select the submenu for the Wall style you want to 
change. 

n For 2D charts, the only submenu available is Back. For 3D charts, available submenus 
include Back, Floor, Front, Left, Polar, Radar, and Right.

b. Select the Visible check box for the wall style if you want the wall style to be 
visible. If not, deselect the Visible check box.

3. In the Wall Style area, do the following: 

a. Click the Fill Effect button to change the color between the lines for the part of the 
chart you have selected. The Fill Effect Editor dialog box opens. Click OK once you 
have made your changes.

b. Click the Border button to change the line properties for the part of the chart you 
have selected. The Line Properties Editor dialog box opens. Click OK once you 
have made your changes.

c. Click the Shadow button to change the shadow properties for the part of the chart 
you have selected. The Shadow Editor dialog box opens. Click OK once you have 
made your changes.
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4. (Optional) If working with a 3D chart, repeat Steps 2-3 for any other Wall Styles you 
want to change.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Wall Size

If you want, you can then set the size of the walls for your chart. If you are working on a 2D 
chart, you can only set the Wall size for the Back wall of the selected series. If you are 
working on a 3D chart (as selected in the Series > Appearance tab), you can set the wall size 
for the Back, Floor, Front, Left, Polar, Radar, and Right wall of the selected series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the Walls size for a chart:

1. Select Walls in the left column, and then select the Size submenu.

The Walls > Size area displays enabling you to set the Wall size and thickness for the 
selected series.



6  Working with Charts and Graphs

302

2. In the Wall Selection area, do the following: 

a. In the Current Wall drop list, select the submenu for the Wall style you want to 
change. 

n For 2D charts, the only submenu available is Back. For 3D charts, available submenus 
include Back, Floor, Front, Left, Polar, Radar, and Right.

b. Select the Visible check box for the wall if you want the wall to be visible. If not, 
deselect the Visible check box.

3. In the Wall Size Properties area, use the Thickness slide bar to control the thickness of 
the selected wall.

4. If working with a 3D chart, repeat Steps 2-3 for any other Wall Styles you want to 
change.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Using Watermarks Controls

This section contains information on creating and using the Watermarks controls to further 
adjust the look of your series.

For more information on setting a specific watermark style for a series, see the following 
topics:

• “Setting the Watermark Appearance” on page 302

• “Setting the Basic Frame Watermarks” on page 304

• “Setting the Watermark Position” on page 305

• “Creating the Watermark List” on page 307

Setting the Watermark Appearance

If you want, you can then set the appearance of Watermarks in your chart. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249, and also added a Watermark to the list, as described in “Creating the 
Watermark List” on page 307.
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To set the Watermark appearance for a chart:

1. Select Watermarks in the left column, the select the Appearance tab.

The Watermarks > Appearance page displays enabling you to set the Watermark 
appearance for the selected series.

2. In the Wartermark Selection area, select the watermark you want to change the style and 
dimensions for from the Current Watermark drop list.

3. In the Watermark Style area, do the following:

a. Click the Fill Effect button to change the color between the lines of the warteramrk. 
The Fill Effect Editor dialog box opens. Click OK once you have made your 
changes.

b. Select the Overlap Image check box if you want the watermark to be visible on top 
of the chart. If not, deselect the Overlap Image check box.

4. In the Watermark Dimensions area, do the following: 

a. Use the Horizontal Custom Size slide bar to control the horizontal (width) of the 
watermark.

b. Use the Vertical Custom Size slide bar to control the vertical (height) of the 
watermark.

c. Select the Use Custom Size check box if you want to use the custom size the for the 
watermark. If not, deselect the Use Custom Size check box.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the Basic Frame Watermarks

If you want, you can then set the Basic Frame style and size for Watermarks.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249, and also added a Watermark to the list, as described in “Creating the 
Watermark List” on page 307.

To set the basic frame watermarks for a chart:

1. Select Watermarks in the left column, and then select the Basic Frame submenu.

The Watermarks > Basic Frame page displays enabling you to set the basic frame style 
for selected watermarks.

2. In the Watermark Selection area in the Current Watermark drop list, select the 
watermark for which you want to change the basic frame style and properties.

3. In the Basic Frame Style area, do the following:

a. If you want to change the line properties for your watermark frame border, click the 
Border button. The Line Properties dialog box opens. Set the line properties for the 
watermark frame border, and click OK.

b. If you want to change the color of the watermark frame bevel area, click the 
Interbevel Color button. The Color dialog box opens. Make your color selections, 
and click OK.
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4. In the Basic Frame Bevel Properties area, do the following:

a. In the Outer Type field, select the type of Outer bevel you want for your watermark 
frame. Options are (None, Raised, or Sunken).

b. To change the dark color of the Outer bevel, click the Outer Dark Color button 
below the Outer Type field, and select the color. 

c. To change the light color of the Outer bevel, click the Outer Light Color button 
below the Outer Type field, and select the color.

d. In the Inner Type field, select the type of Inner bevel you want for your frame. 
Options are (None, Raised, or Sunken).

e. To change the dark color of the Inner bevel, click the Inner Dark Color button below 
the Inner Type field, and select the color.

f. To change the light color of the Inner bevel, click the Inner Light Color button 
below the Inner Type field, and select the color.

5. In the Basic Frame Bevel Size area, do the following:

a. Use the Bevel Distance slider to change the bevel distance.

b. Use the Beval Width slider to change the bevel width.

6. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Watermark Position

If you want, you can then set the position of the watermark on your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.
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To set the watermark position:

1. Select Watermarks in the left column, and then select the Position submenu.

The Watermarks > Position page displays enabling you to set the position of the 
watermarks for the selected series.

2. In the Watermark Selection area in the Current Watermark drop list, select the 
watermark for which you want to change the position properties.

3. In the Position Properties area, do the following:

a. In the Horizontal Alignment drop list, select the area where you want to align the 
watermark horizontally (Left, Center, or Right).

b. In the Vertical Alignment drop list, select the area where you want to align the 
watermark vertically (Top, Bottom, or Center).

c. Use the Horizontal Margin slider to adjust the location of the watermark 
horizontally along the chart.

d. Use the Vertical Margin slider to adjust the location of the watermark vertically 
along the chart.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Creating the Watermark List

This topic contains information on how to add watermarks to your chart. Once you have 
added a watermark, you can change it’s appearance, format, and position properties.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To create the watermark list:

1. Select Watermark in the left column, and then select the Watermark List submenu.

The Watermark > Watermark List page displays enabling you to add or delete 
watermarks for the selected series.

2. In the Watermark List area, do one of the following:

t To add a watermark, click the Add button.

t To delete a watermark, select it and click the Delete button. 

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Using Lighting Controls

This section contains information on creating and using the Lighting controls to further 
adjust the look of your series.

For more information on setting a specific lighting style for a series, see the following 
topics:

• “Setting the Lighting Appearance” on page 308

• “Setting the Basic Frame Watermarks” on page 304

• “Setting the Watermark Position” on page 305

• “Creating the Watermark List” on page 307

Setting the Lighting Appearance

This topic contains information on how to set the appearance, including properties and 
presets for light sources in your chart. 

n This is only available for 3D charts.

You must have added at least one Light source to be able to use this submenu. For more 
information, see “Creating the Lighting Source List” on page 314.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the Lighting appearance for a chart:

1. Select Lighting in the left column.
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The Lighting > Appearance page displays enabling you to set the lighting appearance 
for the selected series.

2. To enable the fields in the Appearance submenu, you must select the 3D option in the 
Global Lighting Properties area.

3. Select the Enable Lighting check box to enable the lighting properties to be visible. If 
not, deselect the Enable Lighting check box.

4. Select the Local Viewport check box if you want the local viewport to be visible. If not, 
deselect the Local Viewport check box.

5. Click the Ambient Color button to select the color between the lines. The Color dialog 
box opens. Click OK once you have made your changes.

6. In the Lighting Presets area, select the lighting preset(s) that you want to apply to your 
chart.

7. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the Lighting Attenuation

If you want, you can then set the Lighting Attenuation for your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the lighting attenuation for a chart:

1. Select Lighting in the left column, and then select the Attenuation submenu.

The Lighting > Attenuation page displays enabling you to set the lighting attenuation 
for the selected series.

2. In the Light Source Selection area in the Current Source drop list, select the light source 
for which you want to change the attenuation properties.

3. In the Light Source Attenuation Properties area, do the following:

a. Use the Constant slider to adjust the location of the constant attuenuation 
properties.

b. Use the Linear slider to adjust the location of the linear attenuation properties.

c. Use the Quadratic slider to adjust the location of the quadratic attenuation 
properties.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the Lighting Attributes

If you want, you can then set the attributes of the lighting for your chart.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the lighting attributes:

1. Select Lighting in the left column, and then select the Attributes submenu.

The Lighting > Attributes page displays enabling you to set the attributes of the light 
source style and properties for the selected series.

2. In the Light Source Selection area, select the light source you want to change from the 
Current Source list.

3. In the Light Source Style area, do the following:

a. In the Source Type list, select the source type for the light source style.

b. Click the Ambient Color button to change the ambient color of the light source.

c. Click the Diffuse Color button to change the diffuse color of the light source.

d. Click the Specular Color button the change the specular color of the light source.

4. In the Light Source Spotlight Properties area, do the following:

a. Use the Cutoff slider to change the light source spotlight cutoff values.

b. Use the Exponent slider to change the light source spotlight exponent values.
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5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Lighting Direction

If you want, you can then set the direction of the lighting on your chart.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the lighting direction:

1. Select Lighting in the left column, and then select the Direction submenu.

The Lighting > Direction page displays enabling you to set the position of the 
watermarks for the selected series.

2. In the Light Source Selection area, select the light source you want to change from the 
Current Source list.

3. In the Light Source Direction Properties area, do the following:

a. Use the X Direction slider to change the light source X direction values.

b. Use the Y Direction slider to change the light source Y direction values.

c. Use the Z Direction slider to change the light source Z direction values. For 3D 
charts only.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the Lighting Position

If you want, you can then set the position of the lighting on your chart.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the lighting position:

1. Select Lighting in the left column, and then select the Position submenu.

The Lighting > Position page displays enabling you to set the position of the lighting for 
the selected series.

2. In the Light Source Selection area, select the light source you want to change from the 
Current Source list.

3. In the Light Source Position Properties area, do the following:

a. Use the X Position slider to change the light source X position values.

b. Use the Y Position slider to change the light source Y position values.

c. Use the Z Position slider to change the light source Z position values. For 3D charts 
only.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Creating the Lighting Source List

This topic contains information on how to add a Lighting source to your chart. Once you 
have added a Lighting source, you can change it’s appearance, attenuation, attributes, 
direction, format, and position properties.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To create the Lighting Source list:

1. Select Lighting in the left column, and then select the Source List submenu.

The Lighting > Source List page displays enabling you to add or delete lighting sources 
for the selected series.

2. In the Light Source List area, do one of the following:

t To add a light source, click the Add button.

t To delete a light source, click the Delete button. 

n Light sources are deleted from the list in reverse order. For instance Light Source 3 is deleted 
before Light Source 2, and so on.

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Using View Controls

This section contains information on creating and using the View controls to further adjust 
the margins, projection, size and text for your chart.

For more information on setting a specific lighting style for a series, see the following 
topics:

• “Setting the Global Setup View” on page 315

• “Setting the View Margins” on page 317

• “Setting the View Projection” on page 318

• “Setting the View Size” on page 319

• “Setting the Text Size” on page 320

Setting the Global Setup View

This topic contains information on how to set the appearance, including properties and 
presets for light sources in your series. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the Global setup view:

1. Select View in the left column.
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The View > Global Setup page displays enabling you to gloablly set the view for the 
selected series.

2. To enable the fields in the Projection Type submenu, you must select the 3D option in 
the View Properties area.

3. In the Projection Type field, select the projection type from the drop down list. 

This is the type of view that you want to change projection presets for. 

4. Select the presets for the type of series you selected by clicking on one of the presets to 
view what your view will look like with these presets applied. 

The Projection Presets area contains various presets for the series you selected.

n You can try different presets until you find the right one for your series view.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the View Margins

If you want, you can then set the view margins for your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the view margins:

1. Select View in the left column, and then select the Margins submenu.

The View > Margins page displays enabling you to set the view margins for the selected 
series.

2. In the Margin Properties area in the Mode drop list, select the mode for which you want 
to change the margin properties.

3. In the Margin Properties area, do the following:

a. Use the Left Margin slider to adjust the location of the left margin properties.

b. Use the Right Margin slider to adjust the location of the right margin properties.

c. Use the Top Margin slider to adjust the location of the top margin properties.

d. Use the Bottom Margin slider to adjust the location of the bottom margin properties.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the View Projection

If you want, you can then set the view projection for your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the view projection:

1. Select View in the left column, and then select the Projection submenu.

The View > Projection page displays enabling you to set the orthogonal projection 
properties for the selected series.

2. In the Orthogonal Projection Properties area, do the following:

a. Use the X Rotation slider to set the projection properties for the X rotation.

b. Use the Y Rotation slider to set the projection properties for the Y rotation.

c. Use the Z Rotation slider to set the projection properties for the Z rotation.

d. Use the Zoom slider to set the zoom.

e. Use the Perspective angle slider to set the perspective angle properties.

f. Use the X Depth slider to set the projection properties for the X depth.

g. Use the Y Depth slider to set the projection properties for the Y depth.

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Setting the View Size

If you want, you can then set the view size for your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the view size:

1. Select View in the left column, and then select the Size submenu.

The View > Size page displays enabling you to set the size of the view for the selected 
series.

2. In the Chart Size area, do the following:

a. Use the Chart Width slider to change the width of the chart.

b. Use the Chart Height slider to change the height of the chart.

c. Use the Chart Depth slider to change the depth of the chart. For 3D charts only.
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3. In the Image Aspect Ratio area, do the following:

a. Select the radio button that you want to set for the aspect ratio of the chart. Options 
are:

t 1x1

t 4x3

t 16x9

t Custom (If selected, the Custom Value slider is enabled.)

b. (Optional) If you selected Custom for your aspect ratio, use the Custom Value slider 
to change the aspect ratio of the chart.

4. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Setting the Text Size

If you want, you can then set the size of the text for your series.

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To set the text size:

1. Select View in the left column, and then select the Text submenu.

The View > Text page displays enabling you to set the text size for the selected series.



Working with Advanced Controls

321

2. In the Text Properties area, use theText Zoom slider to change the text size for your 
chart.

3. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.

Template Configuration Controls

This section contains information on controls used to configure your templates.

For more information on configuring tamplates, see the following topics:

• “Configuring Chart Settings” on page 250

• “(Optional) Assigning Interactivity for the Mouse” on page 252

• “Configuring Your Templates” on page 321

Configuring Your Templates

This topic contains information on how to load and save various Chart Designer templates. 

This procedure assumes that you have already added a series as described in “Creating a 
Series” on page 249.

To configure your template:

1. Select Configuration in the left column, then select Templates.

The Configuration > Templates page displays enabling you to load and save templates.
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2. In the Template Loading area, select components that you want to load in your template. 

To select all components, click the Check All button.

To deselect all components, click the Uncheck All button.

3.  When you have selected the components you want to include, click the Load Template 
button.

The Load Chart Designer Template dialog box opens. Navigate to the location where 
you want to load your Chart Designer template, and click the Open button.

4. In the Template Saving area, click the Save Template button.

The Save Chart Designer Template dialog box opens. Navigate to the location where 
you want to save your Chart Designer template, and click the Save button.

5. Click Save to save your changes, or click Save and Exit to save your changes and exit 
the Chart Designer.
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Custom Typefaces allow you to access graphic IDs, logos and other graphic content with a 
single keystroke. Deko enables you to:

• Assign a graphic to a Custom Typeface.

• Access that graphic just as you would any font or typeface.

The following topics describe how to create custom typefaces:

• Creating a Custom Typeface

• Accessing Graphics Assigned to a Custom Typeface with a Single Keystroke

Creating a Custom Typeface

Once you create a Custom Typeface, you can access it and give it details and shaders just 
like any other typeface. Creating a Custom Typeface is a simple process:

1. In the Custom Typeface window, you can assign graphics to a letter or number key. You 
typically assign similar or related graphics to a series of keys. 

2. You then name the Custom Typeface window. You can create as many different Custom 
Typeface windows as necessary.

3. Once a custom typeface is created, you can access the typeface elements as you would a 
regular typeface or font. The name of that custom typeface appears in the menu of 
available typefaces.

The following topics provide more information about creating custom typefaces:

• “Opening a Custom Typeface Window” on page 324

• “Importing an Active Graphic as a Character into a Custom Typeface” on page 324

• “Importing a Graphic from a File as a Character into a Custom Typeface” on page 325

• “Changing Pin Location and Set Width of a Character” on page 327

• “Specifying Custom Typeface Properties” on page 328

• “Saving a Custom Typeface” on page 329
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Opening a Custom Typeface Window

To open a Custom Typeface window:

t Do one of the following:

- Select Window > Select Layout > Typeface Edit.

- Select View > Custom Typeface.

- Select File > Open, then navigate to the drive and directory containing an existing 
custom typeface, and press Enter or click OK.

Importing an Active Graphic as a Character into a Custom Typeface

To import an active graphic as a character into a custom typeface:

1. Create a graphic or activate the Program window and open the graphic you want to 
import as a character.
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2. Do one of the following:

t Open the custom typeface, and click or use arrow keys to select the character, then 
select File > Import Character From Current Graphic.

t On the command bar, type cface import [code], where code specifies the 
character (the default is 97, specifying a lower case “a”). Code=0 uses the 
current selection.

Importing a Graphic from a File as a Character into a Custom Typeface

To import a graphic from a file as a character into a custom typeface:

1. Open the custom typeface.
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2. Do one of the following:

t Click or use arrow keys to select the character, then select File > Import Character 
From File. In the Import graphic file into the selected character dialog box, navigate 
to the file and select it or type it in the File Name text box, then click OK or press 
Enter.

t On the command bar, type cface importfile [code] [name], where code specifies 
the character (the default is 97, code=0 uses the current selection), and name 
specifies the filename to import. 
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Deko copies the file into the selected character.

n In addition to Deko (.dko) graphics, Deko can import several file types to use as textures, 
including: Bitmap (.dib, .rle), Windows Bitmap (.bmp), Photoshop (.psd), TIFF (.tif), 
TARGA (.tga), JPEG (.jpg), Pinnacle Systems (.g) files created in Thunder, FlashFile, or 
Genie. 

Changing Pin Location and Set Width of a Character

To change pin location and set the width of a character:

1. Open the Custom Typeface window by doing one of the following:

t Select Window > Select Layout > Typeface Edit.

t Select View > Custom Typeface.

t Select File > Open, then navigate to the drive and directory containing an existing 
custom typeface, and press Enter or click OK.

2. In the Custom Typeface window, double-click the character you want to edit. 

Deko displays the character in its own window.
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3. In the Character window, type or scroll to X and Y values for the character’s pin 
location.

4. Type or scroll to a Width value for the character’s set width.

5. Close the Character window by double-clicking its control icon. 

n Multiple Character windows can be open at one time by pressing Ctrl+N.

Specifying Custom Typeface Properties

To specify custom typeface properties:

1. Activate the Custom Typeface window and open the custom typeface.

2. In the Custom Typeface window, click Properties. 

The Custom Typeface Properties dialog box opens.

3. Edit properties as desired, then click OK.

n Undo does not undo changes to a custom typeface.
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Saving a Custom Typeface

To save a Custom Typeface:

1. Assign graphics to characters in a Custom Typeface window as described in “Importing 
an Active Graphic as a Character into a Custom Typeface” on page 324. 

In the following sample, “Good Morning,” “Good Afternoon,” and “Good Evening” are 
assigned to the keys “1,” “2,” and “3.” 
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2. While the window is still active, do one of the following to open the Save Face As 
dialog box:

t Select File > Save.

t Press F12 (SK).

t Press Save File (FAK).

3. Type the name of your choice in the File name text box. 

Deko automatically assigns the file name a .fac extension. 

4. If the directory path shown is not where you want to place your Custom Typeface file, 
navigate to the correct directory. 

5. Click OK.
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Accessing Graphics Assigned to a Custom 
Typeface with a Single Keystroke

To access graphics assigned to a Custom Typeface with a single keystroke:

t From either the Text Bar or the Style window, type the name of your Custom Typeface 
or select it from the menu of available typefaces.

When you type a single key in a Program or Preview window with the Custom Typeface 
selected as the current style,  the graphic assigned to that key appears.

n Custom typefaces can also be assigned to Preset styles for faster access. To do so, place a 
representative image in the A or in a position so the face can be identified easily in the 
Current Style window or Preset Style window.
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8 Creating Useful Graphics

Previous chapters of this manual describe how to perform most of the tasks that are building 
blocks for creating the graphics you want to present on-air. You can use Deko to create lower 
thirds, fancy frames for your text, clocks, leader boards, full-screen bulleted lists, templates 
for interfaced data (such as DekoMOS), and Pops, for quickly popping partial graphics 
(available with the SportsWare Option) onto a master graphic.

Before beginning a project that you want to save, you might want to set up a file directory 
structure for saving and retrieving your work. For more information, see “Managing Files” 
on page 389.

The following topics describe how to create useful graphics:

• Creating and Using Lower Thirds

• Creating Graphics for Multiple Formats

• Applying Fancy Frames for Your Text

• Creating and Using Real-Time Clocks

• Creating and Using a Leaderboard

• Creating and Using a Full Screen Bulleted List

• Creating a Template for Interfaced Data Applications such as DekoMOS

• Creating and Using Partial Graphics with the SportsWare Option
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Creating and Using Lower Thirds
The term “lower third” refers to a format typically used in news or sports broadcasting. 
Viewers see video of a reporter or an event on approximately the top two-thirds of their 
screen. Information such as the reporter's name, the broadcast location, the network logo, 
date, event statistics, or any other relevant text, appears on the lower third. 

A graphic consists of one or more layers and a background. When you view a lower third, 
the background or video showing through the background is what you see on the top 
two-thirds of  your video monitor. The contents of the layers are the lower third.

You can create a template for a lower third and reuse it whenever you want. A template 
graphic contains text layers, with a style applied, ready to be filled. When you are ready to 
use your template, all you need to do is type in the text. The template can also contain a 
background image. You can fill in the template and save that as another file, keeping the 
original blank template for reuse.

For more information about creating and using lower thirds, see “Building Lower Thirds” on 
page 334.

Building Lower Thirds

There are several techniques for building lower thirds. 

• If you are working “on the fly” and speed is critical, see “Building a Simple Lower 
Third Template” on page 334. 

• If you have more time, and want to create a more elaborate lower third with a variety of 
styles, see “Custom Designing a Lower Third” on page 338. 

This section also includes instructions for using a lower third graphic as a template and for 
building a lower third with a background. 

Building a Simple Lower Third Template

To quickly build a simple lower third template:

1. Press Clear Program (FAK) or Alt+F8 (SK) to clear the Program window.
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2. Select a style from the Preset Style window. 

The style you select displays in the Current Style window.

3. In the Style window, click the Font button. 

4. Adjust the size of the current style font.

5. Set focus to the Program window. 

6. Type a label for a layer, such as “Name” or “Athlete,” then press Enter. Repeat for other 
desired layers, such as “Profession” or “Position.” (A second layer telling something 
about the person named in the first layer is sometimes called a “hero line”.)

Style selected in this example

Style you select appears here
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7. To move your text to the lower third position, do one of the following:

t Press Lower Third (FAK).

t Press Ctrl+Numeric 2 (SK).

t Click a corner of the default text layer to select it. (This layer is in the same position 
as the safe title area.) Small squares should appear at the sides and corners of the 
layer to indicate that it is selected. Click one of the squares at the top of the layer to 
resize the layer, positioning your text in the lower third. Make sure the mouse 
pointer displays as a resizing tool, not a moving tool.

8. Select all text. For more information, see “Working with Text and Styles” on page 141.

Click on any of the 
squares to resize
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9. Select Text > Text to Multiple Fields. 

Each line of text is now in its own layer, making future editing easier.

10. To open a dialog box for saving your new template, do one of the following:

t Press Save File (FAK).

t Press F12 (SK).

t Click File > Save graphic as. 

The Save Graphic As dialog box opens.

11. Navigate to the folder you want to use, and double-click to open it.

12. Type a name for your template in the File Name text box.

13. Select List Files of Type menu > .dko.

14. Click OK.



8  Creating Useful Graphics

338

Custom Designing a Lower Third

To custom design a lower third:

1. Press Clear Program (FAK) or Alt+F8 (SK) to clear the Program window.

2. Click the Program window. 

There is a default layer based on the size of the safe title layer. 

3. Click the edge of the default layer to select it. 

You know that this layer is selected when you see small squares at each corner and side 
of the safe title area. 

4. Press Delete to delete this default layer. 

5. From the Tools window, click the Add Text Layer button.

6. With the mouse, position the tool where you want a layer's upper left corner.

Default layer selected 
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7. Click the top and drag it to the position where you want the layer's lower right corner. 

8. Activate the Style window and click the Layer button. 

The Text dialog box opens.

9. Deselect Word wrap and select shrink_to_fit in the Auto-scaling section of the window. 

Your text conforms to the boundaries of this layer.

Drag from 
here

To here.
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10. Define the style for text in this layer. Either select a style by clicking on a Preset Style 
window or create a style. To create a style:

a. Click the Font button in the Style window and use the controls in that window to 
select a font, determine its size, and apply kerning, leading, rotation, or skew. 

b. Click the Look button in the Style window and apply details (faces, underlines, 
frames, shadows, and edges) to your style. With a detail selected, adjust its blur, 
position, and dimension in this window. By default, your style has a face. 

In this example, the font is rendered with an edge, a shadow, a face, and another 
shadow.
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c. With a detail selected in the Style window Look tab, activate the Shader window to 
apply color, ramp, texture, Keyhole, or CAP to the detail. 

In this example, a ramp is chosen for the face.

Your style, with details and shaders you select, appears in the Current Style window.

For more information, see “Designing and Applying Styles” on page 77.

11. Click the Program window. 

Right-click here 
to apply color 
shown below to 
a quadrant of 
the ramp.

First, click to 
select desired 
color here.

The color selected 
displays here.

Click Options to display 
choices for applying the 
ramp.

Ramp sample 
displayed here.
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12. Type text in your layer.

13. To create additional layers, repeat steps 5 - 9. 

In this example, a text layer is drawn below the first text layer. 



Creating and Using Lower Thirds

343

- In the Text/Style window, Layer tab, Word wrap is deselected, and shrink_to_fit 
is selected.

- In the Style window, font tab, Arial Narrow is selected from the Typeface menu.

- In the Style window, Look tab, the style has a face, a frame, and an edge. The Frame 
detail is selected. Its shape is normal with height set to 65 and width set to 20.
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The Frame shader is activated and the Eyedropper is used to select the color from the 
edge of the style in the other layer. This color is used as the face shader in this layer.

Color selected with the eyedropper is shown in the shader window and is applied to the 
frame of the current style. Other details are shown with shaders applied also. 

Click and drag eyedropper. 
Release on color you want to 
select from desktop.
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Text is typed in the layer in the specified style. 

14. To save your graphic, do one of the following:

t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK).

15. Navigate to the appropriate folder, and do the following:

a. Type a name in the Name text box.

b. Verify the file type.

c. Click OK to save. 

Building a Lower Third Template with a Background

To build a Lower Third template with a background:

1. Press Clear Program (FAK) or Alt + F8 (SK) to clear the Program window.

2. Click the Program window. 

3. Open the Open dialog box by doing one of the following:

t Press Clear Read (FAK).

t Press F9 (SK).

t Select File > Open.
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The Open dialog box opens.

4. (Option) Select a different file name extension from the List files of type menu. 

5. Navigate to the file you want to use and double-click it. 

Deko loads the file you select as a background in the Program window.

6. From the Tools window, click the Add Text Layer button.  

7. With the mouse, position the tool where you want your layer's upper left corner. 
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8. Click the layer’s upper left corner, and drag it to the position where you want the layer's 
lower right corner. 

n If you need to adjust the layer, select the Move tool so you do not accidentally scale the text 
and the layer.

9. Click the Style window and click the Layer tab.

10. Deselect Word wrap and select shrink_to_fit in the Auto-scaling section of the window. 
This enables your text to conform to the boundaries of this layer.

11. Select a style from the Preset Style window. If you want to select from a different preset 
style window, select File > Open (F9) and navigate to the desired file. 

The style you select appears in the Current Style window.

12. Click the Program window to activate it. 
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13. Type text in your layer.

14. To create additional layers, repeat steps 5 - 9.



Creating and Using Lower Thirds

349

15. The default layer is based on the size of the safe title layer. Use the Page Up or Page 
Down keys to move among your layers to the default layer.

You know that this layer is selected when you see small squares at each corner and side 
of the safe title area. 

16. Press Delete to delete this default layer. 

17. To save your graphic, do one of the following:

t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK). 

18. Navigate to the appropriate folder, type a name in the Name text box, and verify the 
file type.

19. Click OK to save. 

Creating Graphics from a Template

To create graphics from a template:

1. With the Program window selected and cleared, do one of the following:

t Select File > Open.

t Press F9 or Ctrl+O (SK).

t Press Read (FAK).

2. Navigate to your template graphic and double-click it.

3. Press Insert on your keyboard to switch Insert/Overwrite to OVR. 

On the status bar, near the bottom of the desktop, you should see OVR near the right 
side. If you see INS instead, press Insert again. 

4. Select a layer and type in your text. 

5. Tab to additional layers and type in additional text.

n The current style box should change when you tab to layers with different styles. If not, make 
sure the cursor preference is set for “Moving cursor sets font and look.”

6. Once you have filled in your template, save it by doing one of the following:

t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK).
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7. To preserve the original template file, save this file under a different name. 

n Save your file with a name followed by the numeral “1.” Once you have created a name, 
Deko automatically increments the number at the end for successive files (such as title1, 
title2, title3, and so on.)

Using an Existing Graphic as a Template for a Similar Graphic

To use an existing graphic as a template for a similar graphic with new text:

1. Select and clear the Program window.

2. Do one of the following to display the File Open dialog box:

t Select File > Open.

t Press F9.

t Press Ctrl + O (SK) or Press Read (FAK).

3. Select a file and press OK.

4. Press the Insert key to toggle Insert/Overwrite to OVR. 

n Check the status bar near the bottom of your screen to make sure that OVR mode is on, not 
INS mode.  

5. Select a layer and type in text. 

6. Tab to additional layers and type in text. 

The current style box should change when you tab to layers with different styles. If not, 
make sure the cursor preference is set for Moving cursor sets font and look.
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You can change your original graphic as often as necessary, as shown in the following 
illustration.

7. If you want to change styles, giving your text a different appearance, select the text, 
including the end of row marker, and click a preset style or use the controls in the Font 
tab and Look tab of the Style window. 

8. Once you have filled in your template, save it by doing one of the following:

t Select File > Save Graphic As.

t Press F12 (SK).

t Press Save File (FAK).

9. To preserve the original template file, save this file under a different name. 

n Save your file with a name followed by the numeral “1.” Once you have created a name, 
Deko automatically increments the number at the end for successive files (such as title1, 
title2, title3, amd so on).
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Creating Graphics for Multiple Formats

Using the Multi-Format Compose feature, Deko lets you create graphics for multiple 
formats (such as SD and HD; and even 4:3 and 16:9 aspect ratios). Multi-format compose is 
a means of reducing production effort (workload) when creating graphics for multiple 
formats. With multi-format compose, you no longer need to create separate graphics for SD 
and HD formats. Instead, you can create multiple versions of one graphic, saved as one 
filename. The proper version is recalled based on the Playback system’s hardware setting.

n Multi-Format Compose is only available when you are in a Preview/Program channel 
configuration. If you are running a Dual Program configuration, switch to a 
Preview/Program configuration before using Multi-Format Compose. For more information 
on switching hardware configurations, see “Switching Between Video Standards” on page 
705.

For more information, see the following topics:

• “Setting Up for Creating Multiple Format Graphics” on page 352

• “Creating and Saving an Alternate View Layout” on page 353

• “Creating Multiple Format Graphics” on page 354

• “Playing Back Multiple Format Graphics” on page 355

Setting Up for Creating Multiple Format Graphics

To set up for creating multiple format graphics:

1. Select Options > Preferences. 

The Preferences dialog box opens. 
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2. Click the Alt Compose tab.

3. In the Alt video standard menu, select the alternate video standard that you want to 
compose graphics for (NTSC, 1080i, 59.94, and so on).

4. (Option) If you want to create graphics with the same video standard, but with different 
properties (such as different languages, for example, one in English, and one in 
Spanish), you can type identifying names in the Standard tag and Alternate tag fields to 
distinguish the Alternate graphic from the Standard graphic. For example, type English 
in the Standard tag text box, and Spanish in the Alternate tag text box.

5. If you want to change the Safe Title Areas for the Alternate Video standard, you can 
change the values by typing new values in the appropriate text boxes.

n By default, the Safe title areas are 10 percent from the Top, Bottom, Left, and Right. 

6. Click OK to close the dialog box.

7. Select Options > Save Settings Now to save your settings.

Creating and Saving an Alternate View Layout

It’s very helpful if you create a layout that includes the appropriate views that you will need 
when creating multiple format graphics.

To create and save an Alternate view layout:

1. Select Window > Select Layout > Style Edit. 

The Style Edit layout opens.

2. Select View > Alternate. 

The Alternate window opens in front of the Program window. 

Alt Compose tab
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3. Move and resize the Alternate window and Program window so you can see both the 
Program window and the Alternate window on the screen.

4. When you size and place the windows the way you want, save this as a Window Layout 
by selecting Window > Save Layout As. 

The Save Layout dialog box opens.

5. Type a name for this layout (such as Alt Window), and click Save. 

This Layout is saved for you to use whenever you want to create Alternate graphics.

6. Select Options > Save Settings Now to save your settings.

Creating Multiple Format Graphics

Deko knows to create a multiple format graphic when both a Program graphic and an 
Alternate graphic are showing on your screen.

Before you begin creating multiple format graphics, you must have both a Program window 
and an Alternate window open. For more information, see “Creating and Saving an Alternate 
View Layout” on page 353. 

To create Multiple Format Graphics:

1. Bring up the Alternate layout window you have created by selecting Window > Select 
Layout, and then select your Alternate layout. 

n If you haven’t created an Alternate layout, either create one now, or select View > Alternate. 
The Alternate window opens. Move and resize the Alternate window and Program window, 
so you can see both the Alternate and Program windows.

2. Create the Primary graphic in your Program window, and create the Alternate graphic in 
your Alternate window. 

n You can use the Copy/Paste feature to copy and paste parts of your graphic from one window 
to another.

If you have a graphic that you have already created for HD, you can copy and paste all 
layers to the alternate canvas. You can then use the additional space HD affords you to help 
define the look, add additional layers, and so on. This enables you to create unique looks for 
SD and HD.

3. Click the Program window, and select File > Save Graphic as. 

The Save Graphic As dialog box opens. 

n When you save the graphic, you only save one file instance of the graphic.
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4. Navigate to the location in which you want to save the graphic, type a name for the 
graphic in the File name field, and click Save. The filename appears in both Program 
and Alternate windows.

n For playout, only the graphic that shares the same video standard (SD or HD) as what is 
currently set up on your machine appears in the Program window. The alternate version 
does not appear.

5. When you are done creating Alternate graphics, close the Alternate window.

Playing Back Multiple Format Graphics

When opening a multiple format graphic, Deko attempts to select the appropriate graphic to 
read. However, it is important to note the following:

• If the graphics were created in different video standards, Deko, by default, selects the 
graphic that matches or most closely matches your current video standard. 

• If the graphics were created in the same video standard, you can use the Standard Tag 
and Alt Tag fields in the Preferences dialog box, Alt Compose tab (select Options > 
Preferences, then click the Alt Compose tab), to specify your current situation. 
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For example, if the graphics were both in the same video standard, but one had a tag of 
English, and the other Spanish, and you are opening the graphic in a Spanish 
environment, you can switch the Standard tag to Spanish, and the Alternate tag to 
English, and save your settings.

• If you want Deko to read back the graphic based on tags that have been created for the 
graphic (and ignore the video standard), select Use tag first.

n The Use tag first option is helpful if you want to create graphics that are “HD ready,” but 
you still want to air them in an SD format. If you select Use tag first, Deko checks the tag 
first before comparing video standards. In the case of a playback machine running in NTSC, 
and the multi-format graphic having been created in 1080i and NTSC, it would be a way of 
saying you want to override the video standard and read in the 1080i version if the current 
tag preference matches one of the tags.

Applying Fancy Frames for Your Text
When you apply a frame to your style for typing text, sometimes this frame is the same from 
end to end. The following Current Style and the text “Key Memorial Stadium” have a simple 
frame with a single color shader.

Simple Frame and Single Color Shader Example

However, you might want to apply a fancy frame to your text. A fancy frame is not the same 
throughout. The ends might appear different from the middle or from one another one. The 
following style, with the text “Key Memorial Stadium,” has a fancy frame. 



Applying Fancy Frames for Your Text

357

Fancy Frame Example

As you type, Deko automatically stretches or shrinks the frame, allowing both ends and 
center to remain as designed, as shown in the following illustration.

Fancy Frame (stretched to fit text)

Selecting and Using a Preset Style with a Fancy Frame

To select and use a preset style with a fancy frame:

1. Activate the Preset Style window. 

2. Select one of the default Preset styles with fancy frames.

3. Click the title bar of the Program window. 
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4. Position the cursor and begin typing. 

The frame automatically sizes horizontally with the letters you type. 

Creating Styles with Fancy Frames

Before you create styles with fancy frames, you must create graphics that can be applied as a 
texture shader to the frame. For more information, see “Creating a Graphic to Use as a 
Shader for a Fancy Frame” on page 360. 

To create styles with fancy frames:

1. Add a frame to your style. For more information, see “Adding Details to a Font” on page 
93.

2. With the frame selected in the Details list (Style window, Look tab), click the Shader 
window to activate the frame’s shader.

3. At the top of the Shader window, select Texture.

4. Do one of the following:

t Type the name of the texture file in the File Name text box.

t Click Browse, then select a thumbnail in the Texture Browser or navigate to the file 
you want to use. 

The graphic you select appears in the chiclet next to the Face shader button on the text 
bar and the Shader sample box in the Style window.

A sample also appears near the bottom of the Shader window.
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5. In the Shader window, select Left+right for H Alignment. This aligns the left edge of the 
texture with the left edge of the group and the right edge of the texture with the right 
edge of the group.

6. Select how you want the frame applied from the Group menu:

t Letter - applies the texture individually to each letter.

t Word - applies the texture to each word.

t Row - applies the texture to each row of text.

t Page - applies the texture to the entire page of text.

7. Use the texture options H scale, V scale, H offset, V offset, and V Alignment to specify 
how the frame should be positioned relative to the text. As you make adjustments, you 
can preview the frame's appearance in the Current Style window. 

n Initially,  you might not even see the texture or graphic you want to apply to your frame in 
the Current Style window. If the design you are looking for takes up a relatively small space 
in the whole graphic, you might need to make significant adjustments before it appears 
where you want it.  

8. Save your style. If you plan to use it often, assign it to a Preset style button. For more 
information, see “Creating Styles” on page 86.

Specify Texture 
as the type of 
shader.

Name of file to be 
used as frame 
shader.

Specify H Alignment 
left+right here.

Use Scale, Offset, and V 
Alignment to position 
graphic with text (see 
sample in Current style 
window).

Thumbnail of file 
named above. 
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To use a style with a fancy frame:

t Type or apply as with any other style. Your frame is applied automatically. For more 
information, see “Using a Preset Style” on page 85.

Creating a Graphic to Use as a Shader for a Fancy Frame

To create a graphic to use as a shader for a fancy frame:

1. Create your graphic sized as you intend to use it.

Graphics can be Deko graphics, created with shape layers, bitmaps, or any other type of 
graphic file.

n In addition to Deko (.dko) graphics, Deko can import several file types to use as textures 
including: Bitmap (.dib, .rle), Windows Bitmap (.bmp), Photoshop (.psd), TIFF (.tif), 
TARGA (.tga), JPEG (.jpg), Avid (.g) files created in Thunder, Lightning, FlashFile, or 
Genie, as well as many others.

2. Place several designs in one graphic file. 

3. Open the file as a texture shader. One of the designs appears in the Current Style 
window. This makes it easier to position the graphic appropriately.  

4. Use V Offset in the Shader window to position the graphic.

5. Once your style with a fancy frame is positioned as you want it in the Current Style 
window, you can save it as a Preset style for easier reuse. 
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Creating and Using Real-Time Clocks
Using Deko’s built-in clock feature involves two processes:

1. Define the clock in the clock list. 

Your Deko maintains a list of user-defined clocks. You can define clocks in the list as 
time-of-day clocks, or countdown or countup timers. You can select whether hours, 
minutes, or seconds are displayed. For time-of-day clocks, you can specify a difference 
(offset) from the current time of your Deko’s internal clock. For countdown clocks, you 
can specify number of hours, minutes, and seconds from which to count. You can 
display a clock from the clock list in any text layer, using any style. Each clock in the list 
is assigned an ID number (1, 2, 3...).

2. Display the clock in its own text layer. 

You must specify that the clock auto updates the layer. The clock can be displayed in 
any font or style you wish. A clock can be used an indefinite number of times in the 
same or different graphics, and in different styles.

For more information, see the following topics:

• “Defining a New Clock or Editing an Existing Clock” on page 361

• “Displaying a Clock in the Current Graphic” on page 364

• “Starting the Countdown or Countup Timer” on page 365

• “Resetting the Countdown or Countup Timer” on page 365

• “Preventing Digits from Shifting as the Clock Advances” on page 366

• “Starting, Pausing, Resuming or Resetting a Clock from the Command Bar” on page 
366

Defining a New Clock or Editing an Existing Clock

To define a new clock or edit an existing clock:

1. Do one of the following to open the Clock List dialog box:

t Select View > Clocks. 

t Activate the Style window by clicking the Layer tab. Then, under Auto Update, 
select Clock, and click the View Clocks button. 
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The Clock List dialog box opens.

2. Do one of the following:

t If you are adding a new clock, click Add, and specify a clock ID.

t If you are editing an existing clock, specify the clock ID or click the clock name in 
the list, then, click Configure. The following illustrations show the dialog boxes for 
adding time of day or Countdown and Countup timers. The Configure Clock dialog 
boxes, for editing existing clocks, appear the same.
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3. Select options as described in the following table.

4. Click OK.

Add Clock Option Description 

Clock Type Select one of the following:

• Time of day

• Countdown

• Countup

Format Set the timing format for the Clock Type you selected (Time of day, 
Countdown, or Countup.)

Time Offset field Set an offset for the time output, from your system clock time (useful 
for time zone shifts).

Hour Format Specify 12-hour or 24-Hour display

Append AM/PM Add an AM or PM to 12 hour output.

Keep leading zeros 
option

Select to keep the zero in place for timers, such as 01:25 PM.

Separators Select colons, semicolons, or commas as separators for Hr/Min, and 
Min/Sec.

Tenths display In the section, select Display tenths if you want to display tenths.
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Displaying a Clock in the Current Graphic

To display a clock in the current graphic:

1. With the text layer tool, draw a text layer for your clock. Only the clock occupies this 
layer.

2. With the layer still selected, do one of the following:

t Apply any style for displaying your clock by clicking a Preset style button in the 
Preset Style window.

t Create a new style. 

For more information, see “Creating Styles” on page 86. The style you select or create 
appears in the Current Style window.

3. In the Style window, click the Layer button. 

4. Deselect word wrap.

5. Select shrink_to_fit from the Autoscaling menu so your clock conforms to the size of 
the layer.
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6. In the Auto Update section, click the Clock button.

7. Beneath Auto update, type in the clock ID, or click the Up or Down arrows to select the 
clock ID. 

The clock appears in the layer in the style you specified.

Starting the Countdown or Countup Timer

To Start the Countdown or Countup timer to begin the count:

1. Display the Clock List by doing one of the following:

t Click the Style window. Click the Layer tab. Under Auto Update, click the Clock 
button. Click View Clocks. 

t Select View > Clocks.

2. Click the Start button on the Clock List.

Resetting the Countdown or Countup Timer

To reset a Countdown/Countup timer:

1. Display the Clock List by doing one of the following:

t Activate the Style window. Click the Layer tab. Under Auto Update, click the Clock 
button. Click View Clocks. 

t Select View > Clocks.

2. Click the Reset button on the Clock List.
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Preventing Digits from Shifting as the Clock Advances

To prevent digits from shifting left and right as the clock advances: 

t In the Font tab of the Style window, select monospace or digits rather than proportional 
spacing. 

Starting, Pausing, Resuming or Resetting a Clock from the  
Command Bar

To start, pause, resume, or reset a clock from the command bar:

1. Type one of the following commands in the Command Bar:

clock_start

t clock_pause

t clock_resume

t clock_reset

2. Press Enter.

Creating and Using a Leaderboard
A Leaderboard is useful for displaying a list of individuals, teams, candidates or companies, 
and one or two statistics for each, such as rank, score, votes, value, hometown, and so on.

Within a single layer, one name is separated from its accompanying statistics with tab stops. 
As rank changes, rows of information can be rapidly moved up or down the list.

The following topics provide more information about creating and using a leaderboard:

• “Creating Leaderboards” on page 367

• “Changing Information on a Leaderboard” on page 371
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Creating Leaderboards

To create a Leaderboard

1. Click the Program window.

2. Select the default layer by clicking the edge of the safe title area to display small squares 
at the corners and edges.

3. Press Delete to delete the default layer.

4. From the Tools window, click the Add Text Layer tool.
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5. To create a text layer for your title line, position the tool near the top left of the safe area 
and drag to the bottom right corner of where you want your title. 

Instead of steps 3 through 5, you might want to simply resize the default layer.

6. In the Text/Style window, do the following:

a. Click the Layer tab.

b. Specify shrink_to_fit.

c. Click Word Wrap to turn it off.

d. Specify Horizontal Justification.

7. Select a style from the Preset Style window or create a style. For more information, see 
“Creating Styles” on page 86.

8. Select a size for the font. 

9. Click to activate the Program window and position your cursor. 
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10. Type your title. 

11. In the Tools window, do the following: 

a. Click the Add Text Layer Tool. 

b. Position the Add Text Layer Tool near the lower left of your previous layer and drag 
toward the lower right of your safe area to create a layer for items on your 
leaderboard. 
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12. In the Style window, do the following:

a. Select the Layer tab.

b. Specify Shrink to fit box.

c. Click the Word Wrap option to deselect it.

13. Select a style from the Preset Style window or create a style. For more information, see 
“Creating Styles” on page 86.

14. Select a size for the font.

15. Click the Program window and position the cursor.

16. Type the first row of text for your leaderboard. 

n As you type, do not use the space bar to create columns. Instead, insert tab stops. For the 
number columns, Decimal or Right tabs are recommended to justify the number correctly. 
For more information about tab stops, see “Using Tab Stops” on page 243. 

17. When you have typed the entire row, press Enter to begin a new row. 

n You do not need to specify shrink to fit and word wrap off each time. Tab stops are saved as a 
text layer parameter. When you create a new layer, tab stop settings of the last active layer 
are applied to the new layer. 

18. Select File > Save. 

The Save Graphic As dialog box opens. 

19. Type a name for your leaderboard in the File Name text box and click OK.
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Changing Information on a Leaderboard

To change information on a leaderboard:

1. Open a leaderboard file in the Preview or Program window.

2. Press the Insert key to switch on Overwrite mode. Look at the status bar near the bottom 
of your screen to see OVR, indicating Overwrite mode is on. Typing in Insert mode 
rearranges the tab stops. If you see INS instead of OVR, press Insert again.

3. Press the tab key to place the cursor immediately to the left of the information you want 
to change to select it. 
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4. Type your new information.

Moving a Row Up or Down the List

To move a row up or down the list: 

1. Set the cursor anywhere within a row of content you wish to move. 

2. Do one of the following:

t Press Shift+Alt+Up Arrow to move the row up the list, one row at a time. 

t Press Shift+Alt+Down Arrow to move the row down the list, one row at a time.  
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Changing the Font or Look of a Column

To change the font or look of an entire column:

1. Set the cursor anywhere within the desired Tab column.

2. Do one of the following:

t Select Edit > Select at tab.

t Press Shift+Alt+T to select all the Tab's text.

3. Click a Preset Style.

Creating and Using a Full Screen Bulleted List
When presenting a list of people, topics, things, or points in an argument, you might want to 
emphasize each item with a bullet. A bullet can be any graphic element such as a dot, square, 
sphere, or arrow. A bulleted list is useful in many situations such as supporting an interview 
or investigative report, listing pros or cons of an issue, or listing nominees or candidates. 

Typically, the bulleted points appear one by one, either from a Deko, or from a still store. If 
the images come from a still store, you must save them as multiple graphics, one for each 
bulleted point. If the images come from a Deko, you can save a single copy and use a 
layer-based transition to bring it on screen.  

The background for a list can be a solid color, a ramped color, or a graphic file. 

With Deko, you can create a full screen list with graphic layers or with custom typefaces.

The following topics provide more information about creating and using a full screen 
bulleted list:

• “Creating a Bulleted List” on page 374

• “Designing a Background for Your Bulleted List” on page 380

• “Saving your Bulleted List” on page 381



8  Creating Useful Graphics

374

Creating a Bulleted List

To create a bulleted list using graphic layers:

1. Activate the Program window.

2. Select the default layer.

3. Press Delete to delete the default text layer.

4. From the Tools window, click the Add Text Layer tool.
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5. To create a text layer for your title line, position the tool near the top left of the safe area 
and drag to the bottom right corner of where you want your title. 

n You can resize the default layer vertically and skip steps 3 through 5.

6. In the Style window, do the following:

a. Select the Layer tab.

b. Select Autoscale > shrink_to_fit.

c. Deselect Word Wrap. 

d. Set justification to Horizontal Center.

7. Select a style from the Preset Style window or create a style. 

8. Select a size for the font. 
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9. You can also change the look of your font by adding or removing details or changing 
shaders. For more information, see “Designing and Applying Styles” on page 77. Any 
changes are displayed in the Current Style window.

10. Activate the Program window. 

11. Select your title layer and type a title in the layer.
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12. If you want to scale the title to better fill in the title layer, do the following:

a. Select the layer. 

b. Click the Style window.

c. Click the Layer button. 

13. Click Scale to fit to turn on the button.

n The Scale to fit option manipulates the shape of your characters.

14. Position the Add Text Layer Tool near the lower left corner of your first layer and drag 
to the lower right of your safe area to create a layer for your bulleted items.
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15. Select Autoscale > shrink_to_fit, and deselect Word Wrap. 

16. Select a style from the Preset Style window or create a style. 

17. Select a size for the font.

18. Position the cursor in your second layer. 

19. Type text for your bulleted points. 

20. Keep each item in the list to one line, and press Enter between items.

21. Press Shift+Ctrl+A to select all text in the list (not the title).

22. Select Text > Text to Multiple Fields to create a separate layer for each item in the list.



Creating and Using a Full Screen Bulleted List

379

23. Position the layers on the screen as you want them to appear. 

t To move layers, see “Specifying Layer Properties” on page 175.

t To evenly align layers, activate the Style window, Layer tab. Under Box, Left field 
should display the same number for each layer. Top field should display numbers 
equally spaced.

24. From the Tools window, click the Add an Ellipse button. Your cursor changes 
accordingly.

25. To create a bullet, press Ctrl, and drag the cursor until your bullet is the desired size. 

n Instead of using the Ellipse tool to create a circle, you can use any character or graphic 
image as your bullet.

Add an Ellipse button
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26. With the circle still selected, select a style from the Preset Style window or create your 
own style. For more information, see “Creating Styles” on page 86.

27. With the circle still selected, press Ctrl+C  to copy, then Ctrl+V to paste. 

You do not see your copy, because it is directly over the original.

28. To move the copy, press Ctrl+M to enable moving, then press the Alt key and the Down 
arrow until the second circle is positioned next to the second point.

29. Repeat steps 18 and 19 to create a bullet for each item in your list. 

30. Position the bullets with the Top and Left controls in the Box section of the Layer tab in 
the Style window. 

Designing a Background for Your Bulleted List

Your bulleted list can have any background you want, including a solid color, a ramp (a 
four-cornered gradient with separate colors applied), or a texture from a file. Your list can 
also have the background turned off, allowing live video to show through. For more 
information about backgrounds, see “Understanding Layers and Backgrounds” on page 151.
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Saving your Bulleted List

Like any other graphic created in Deko, you can save your bulleted list. 

To save your bulleted list:

t Do one of the following:

- Select File > Save As.

- Press F12 (SK).

- Press Save File (FAK).

For more information, see “Saving Files” on page 403.

Creating a Template for Interfaced Data 
Applications such as DekoMOS

DekoMOS is a plug-in for other newsroom applications. DekoMOS allows a reporter or an 
editor to access graphic templates created in Deko and replace certain text, images, or clips 
in those graphics. You do not need to have the DekoMOS option to create templates for 
DekoMOS or other interfaced data applications. Any Deko graphic can be used as a template 
if the following conditions are met:

• Appropriate layers are designated as replaceable. 

• Replaceable layers are properly identified, ordered and named.

• Default playout channel is designated.

For more information about DekoMOS, see the DekoMOS user documentation.

The following topics provide more information about creating a template for interfaced data 
applications such as DekoMOS:

• “Creating a Replaceable Text Layer” on page 381

• “Creating a Replaceable Still Layer” on page 382

• “Creating a Replaceable Clip Layer” on page 383

Creating a Replaceable Text Layer

If you want your graphic template to be able to be used in DekoMOS with the ability to 
replace certain text, images, or clips, you must create a replaceable text layer in your 
graphic template.
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To create a replaceable text layer:

1. Do one of the following:

t Select File > Open (Ctrl+O) and navigate to the graphic file you want to use as a 
template. Open the file into the Program window. 

t Clear the Program window and create a new graphic with one or more text layers. 
For more information, see “Building Graphics with Layers” on page 151.

2. Select a text layer that you want to be replaceable. 

n Remember, a selected layer is indicated by a solid box with handles on each side and corner 
of the layer box.

3. In the Style window, click the Layer button.

4. In the Auto-Update section of the Style window, click Replace to accept external data 
into the currently selected layer.

n The ID, near the bottom of the Style window, by default is Off. Off means that the layer 
number indicates the order in which external data will be entered into the layers. 

5. Click the Up arrow to specify an ID number. This number indicates the order in which 
external data is entered into layers.

6. Click the More button on the Style window to reveal additional controls, such as the 
Name text box. 

7. Type a name in the Name field that identifies the kind of text required for the Reporter 
or Producer. This name will appear in the DekoMOS Newsroom Client interface.

8. Save your graphic.

n To use a graphic with replaceable fields, select Options > Preferences. Click the Common 
tab and make sure “Use bitmap, if available, rather than rerendering” is not selected.

Creating a Replaceable Still Layer

To create a replaceable still layer:

1. Create a rectangle layer with a texture for the face. 

2. In the Shader window, Texture tab, do the following:

a. Select a default texture.

b. Select the Auto Replace option.

c. In the Auto Scale menu, select either Fit or Preserve.



Creating a Template for Interfaced Data Applications such as DekoMOS

383

3. In the Layer tab of the Style window in the Auto-Update section, select Replace. 

n The ID, near the bottom of the Style window, by default is Off. Off means that the layer 
number indicates the order in which external data will be entered into the layers. 

4. Click the Up arrow to specify an ID number. 

This number indicates the order in which external data is entered into layers.

5. Click the More button on the Style window to reveal additional controls including the 
Name field. 

6. Type a name in the Name field that identifies the kind of image required for the Reporter 
or Producer. 

This name displays in the DekoMOS Newsroom Client interface.

7. Save your graphic.

Creating a Replaceable Clip Layer

To create a replaceable clip layer:

1. Create a rectangle layer. 

The Current Style is irrelevant because all details will be obscured by the clip.

2. In the Layer tab of the Style window, type the name of a clip in the Clip text box. 

n If you do not see the Clip field, click the More button at the bottom of the window, or, click 
Select to browse for a Clip. 

3. In the Layer tab of the Style window, in the Auto-Update section, select Replace.

n The ID, near the bottom of the Style window, by default is Off. Off means that the layer 
number indicates the order in which external data will be entered into the layers.

4. Click the Up arrow to specify an ID number. 

This number indicates the order in which external data will be entered into layers.

5. Click the More button on the Style window to reveal additional controls, including the 
Name text box. 

6. Type a name in the Name text box that identifies the kind of clip required for the 
Reporter or Producer. 

This name displays in the DekoMOS Newsroom Client interface.

7. Save your graphic.
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Creating and Using Partial Graphics with the 
SportsWare Option

n To see if this option is enabled on your system, select Options > Enabled Options.

The SportsWare option includes two powerful features to quickly modify graphics, Pops, 
and Macro Autoplay. For more information, see “Streamlining Your Work with Macros” on 
page 713. Partial graphics (POPs) allow you to create and “pop” a text selection onto an 
open graphic. Pops might be used, for example, to quickly add a player’s picture or statistics 
to an existing graphic.

The following topics provide more information about creating and using partial graphics 
with the Sportsware option:

• “About Pops” on page 384

• “Creating Pops” on page 385

• “Using Pops in Graphics” on page 387

About Pops

Text for a pop is saved as a text file or as a special graphic file, usable like any other graphic 
file. There are three ways to pop text onto a graphic: 

• Text Pop - A Text Pop pops in text only (from a .txt file) at the cursor position. Text is 
rendered in the current style. For example, during a baseball game, you can pop stats 
into a lower third.

• Style Pop - A Style Pop pops in text and font at the cursor position. This works like a 
text pop, except it renders text in the stored style associated with the pop rather than the 
current style.

• Place Pop - A Place Pop pops in text and style at a specific position in the graphic, 
regardless of cursor position. For example, pop “Final Results” in the center of an on-air 
election graphic, even if the cursor is at the top of the page.

Using pops is a twofold process:

1. Create a text or graphic file to “pop” into a graphic.

2. Access the graphic and pop in the file you created.
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Creating Pops

There are three types of pops you can create. 

• Text Pops

• Style Pops

• Place Pops

The following topics provide more information about creating Pops:

• “Creating a Text Pop” on page 385

• “Creating a Style Pop” on page 386

• “Creating a Place Pop” on page 386

Creating a Text Pop

A Text Pop pops in text only (from a .txt file) at the cursor position. Text is rendered in the 
current style. For example, during a baseball game, you can pop stats into a lower third.

To create a text pop:

1. From your Windows desktop, select Start > Programs > Accessories > Notepad. 

2. Type the text.

3. Navigate to the drive and directory where you want to store the file and save the file as a 
text (.txt) file.

n If you save the .txt files using numeric names, you can recall the files via the numeric keypad 
for faster recall. However, they must be unique numbers (not the same as those used to save 
DKO files. 100.dko airs before 100.txt. The same method applies with all pops and macros 
named as numbers.
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Creating a Style Pop

A Style Pop pops in text and font at the cursor position. This works like a text pop, except it 
renders text in the stored style associated with the pop rather than the current style.

To create a style pop:

1. Activate a Program or Preview window.

2. Select a Preset style or create a new style for the text. For more information, see 
“Creating Styles” on page 86.

3. Type the text.

4. Select the text, not the layer.

5. Navigate to the drive and directory where you want to store the file, and type a name in 
the File name text box.

6. Click the Save Selection button.

Creating a Place Pop

A Place Pop pops in text and style at specific position in the graphic, regardless of cursor 
position. For example, pop “Final Results” in the center of an on-air election graphic, even if 
the cursor is at the top of the page.

To create a place pop:

1. Activate a Program or Preview window.

2. Create a layer for the text or use the default layer.

3. Select a preset style or create a new style for the text.

4. Type the text.

5. Select the layer, not the text.
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6. Navigate to the drive and directory where you want to store the file, and type a name in 
the File name text box.

7. Select Save Selection. 

When you use Save Selection to save a graphic, the Graphic browser indicates next to 
the graphic file name that the graphic is a “pop” file. Likewise, the File Info section of 
the File Open dialog box tells you if a file is a pop file.

Using Pops in Graphics

To Pop Text Onto a Graphic Using a Text Pop or Style Pop:

1. Open the graphic file and position the cursor or select the layer where you want to pop 
in the text.

2. Do one of the following:

t Select File > Open.

t Press Clear Read (FAK).

t Press F9 (SK). 

The Open dialog box opens.

3. Navigate to the drive and directory containing the text pop (.txt) or style pop (.dko) file.

4. Select the file from the File Name list or type it in the File Name text box, then click OK 
or press Enter. 

Deko pops the text or style into the current or selected layer of the graphic, then 
automatically selects the next layer behind it. It does not create a new layer for the pop.

Graphic Browser and File info: 
section of File open dialog box 
indicates “pop” graphic.
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To Pop Text onto a Graphic using a Place Pop:

1. Open the graphic file in which you want to pop the text.

2. Do one of the following:

t Select File > Open.

t Press Clear Read (FAK).

t Press F9 (SK). 

The Open dialog box opens.

3. Navigate to the drive and directory containing the place pop (.dko) file.

4. Select the file from the File Name list or type it in the File Name text box, then click OK 
or press Enter. 

Deko creates a new layer for the place pop in front of the current or selected layer, then 
automatically activates the layer behind the previously current or selected layer.
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Once you begin creating and editing graphics, you need an organized system for storing and 
retrieving those graphics. You might also need to access graphics from elsewhere in your 
network. 

The following topics describe how to manage your files:

• Organizing Files

• Opening Files Using the Open Dialog Box

• Opening Non-Deko Files

• Opening Files in Windows Explorer

• Saving Files

• Adding File Properties to a Graphic

• Viewing File Information for Associated Clips and Macros

• Closing Files and Exiting Deko

• Moving or Renaming Multiple Files

• Deleting Files

Organizing Files

Storing and retrieving information from Deko's hard drive is much like storing and retrieving 
information from a room with several filing cabinets. Navigating to a drive and directory is 
like finding the right filing cabinet and the right drawer. Like files in a room, you want to 
keep your computer's files well organized. Before beginning a project, it is a good idea to set 
up a directory structure for saving files. 

Every Deko system hard drive is partitioned into three drives: C, D, and E. The C:\ drive is 
labeled as the C:\SYSTEM drive because it is meant to store all programs that are installed 
on the system. The D:\GRAPHICS drive is larger and is the best place in which to store all 
Deko Graphic directories (including all .dko, psd, and .tif files). The E:\CLIPS drive is even 
larger and is used to store all clips (including all .mot, .tga, .avi, and .M2V files). 
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The default directories in PostDeko Lite point DekoCast to directories for Deko graphics 
and all components of Deko graphics at render time. The PostDeko Lite application controls 
the default directories in DekoCast for the following kinds of files:

• Graphics and automation

• Styles, preset styles, and shaders

• Macros

• Custom typeface files

n Avid recommends that you use the same directory for all types of Deko files and their 
components. If you use many custom typefaces, you might want to set up a separate 
directory for custom typefaces.

The following topics provide more information about organizing files:

• “Creating File Directories (Folders)” on page 390

• “Telling your Deko Where to Save and Find Files” on page 392

Creating File Directories (Folders)

File Directories (folders) are created in Deko. For more information, see “Creating a New 
Directory for Saving Files” on page 404.

The following topics provide more information about organizing files:

• “Best Practice for Storing Custom Typefaces” on page 390

• “Best Practice for Storing Design Elements” on page 391

• “Best Practice for Organizing News Graphics” on page 391

• “Best Practice for Organizing Sports Graphics” on page 391

• “Best Practice for Organizing Postproduction Graphics” on page 392

Best Practice for Storing Custom Typefaces

Custom Typefaces are images used as logo elements in a graphic. They are given a character 
key assignment and stored in a single Custom Typeface (.fac) file. For more information, see 
“Creating a Custom Typeface” on page 323. Avid recommends that all custom typefaces be 
stored in a single folder separate from all air graphics. This is most efficient in case multiple 
shows need to call for the same logo. In this case, only one Custom Typeface file is required. 
Avid suggests the following directory path:

D:\Typefaces
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Best Practice for Storing Design Elements

Design elements used in a graphic can be organized into a separate folder allowing more 
than one show directory to use these elements. This also can be useful if the look of a show 
changes. Design elements can be banners, plates, headshots or logos. They are typically 
individual graphics or imports and are resources for multiple graphics. The graphic page 
applies the design element as a texture layer. For more information, see “About the Texture 
Shader” on page 118. The following directory path is also suggested:

D:\Elements

Best Practice for Organizing News Graphics

In a news environment, it is common to create individual folders for each newscast or 
program that airs. This is especially true if the design or the staff varies for each program.

For example, if the 5:00 a.m. newscast incorporates a lower third news crawl but the noon 
newscast does not, positioning of graphics differ. Or, the director on the noon newscast 
might prefer a different font color than the director on the evening newscast. There are many 
possible scenarios. To best organize in this environment, store graphics in multiple folders. 
The following is a useful sample directory structure.

• D:\5am

• D:\noon

• D:\5pm

• D:\6pm

• D:\11pm

• D:\TodaysPolitics

• D:\NightTalk

If interfaced to an automation system, commonly the newsroom system knows about 
multiple graphics directories. The newsroom system rundown is then sent to the Deko in the 
form of automation (.aut) files and is put into the appropriate folder. Deko directory paths 
must be set to the correct folder to see the automation files that are sent. For more 
information, see “Best Practice for Organizing Sports Graphics” on page 391.

Best Practice for Organizing Sports Graphics

There are varied approaches for setting up a file directory in a sports environment. If the 
sporting event uses only one design format, the best approach is to create everything inside 
one folder. For example:

D:\FrenchTennis
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If the event has several venues that require a different look and format, each venue should 
have its own show directory. You might even want to create sub directories for better 
organization. For example:

• D:\Games\Skiing

• D:\Games\Hockey

• D:\Games\Bobsled

If a studio program exists, broadcasting highlights of the day’s events, you can create an 
additional directory:

D:\Studio

Best Practice for Organizing Postproduction Graphics

The most common way to create directories in a postproduction environment is for every 
client to have its own directory. Always consider ways to create better organization. For 
example:

• D:\Domestic\PearlFurniture

• D:\International\GermanImports

Avoid multilevel directories that make the directory path name too long, for example:

D:\International\Europe\Germany\CarSales\GermanImports

Telling your Deko Where to Save and Find Files

Deko uses a variety of file types to save various kinds of data. When you save a file, Deko 
automatically attaches the appropriate three-letter extension.

• .aut/.atx – Automation file, opened or saved from the Automation or 
Database window.

• .dko – Graphic file, opened or saved from the Program or Preview window.

• .efx – Effect file, opened or saved from the Effects window.

• .fac – Custom typeface, opened or saved from the Custom Typeface window.

• .mcr – Macro file, opened or saved from the Macro editor.

• .pst – Preset Style file, opened or saved from the Preset Style window.

• .mot – Motion file, opened or saved from the Timeline Motion editor.

• .seq – Sequence file, opened or saved from the Sequence editor.
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• .shd – Shader file, opened or saved from the Shader window.

• .sty – Style file, opened or saved from the Style window.

Once you have set up your folders, you can set Paths Preferences to tell Deko where to 
automatically save certain types of files, and where to look to open certain types of files.

The Paths tab (Options > Preferences) allows you to assign preferred directories to save 
various files used by the system. The directories are assigned a path from a root directory or 
drive, with the paths noted on the Paths tab of Preferences. 

You can set these paths to preferred directories for Deko to use upon program startup. 
Preferred directories can be changed at any time while operating the system. 

To change a preferred directory:

t Do one of the following:

- Select File > Open. Navigate to a new directory menu.

- If you are currently viewing an active browser window, select File > 
Change Directory.

Opening Files Using the Open Dialog Box

There are many ways to open files in Deko, including non-Deko files. The Open dialog box 
enables you to open both Deko and non-Deko files.

The Open dialog box opens when you type or click a command instructing Deko to open a 
file. The Open dialog box provides the tools for finding and opening files in the Deko 
interface, and also enables you to:

• View thumbnails of your .dko graphics.

• Preview the image that is currently selected.

• Select how you want to open non-Deko files.
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To access the Open dialog box:

t Select File > Open.

 is an example of the Open dialog box:

Open Option Description 

Look in Provides the path from the root Drive directory to your file directory. 
Double-clicking on a folder in the path displays a list of all folders and 
files stored in that folder. Double-clicking until you reach the folder you 
want creates a path that is placed in your Paths file of preferences.

Look in list

File name 
text box

Files of 
type list

Image 
Properties 
area

Preview 
area

File 
Selection 
list
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The following topics provide more information about opening files:

• “Opening a Graphic File” on page 395

• “Opening a File From a Browser” on page 396

• “Opening a New Window” on page 396

• “Viewing Thumbnails of your Graphics in Windows Explorer” on page 397

• “Viewing a Preview of Your Image” on page 399

• “Viewing a Key Signal or Alpha Channel of an Image” on page 399

• “Viewing Image Properties” on page 400

Opening a Graphic File

To open a graphic file:

1. Do one of the following:

t Select File > Open. 

t Press Ctrl+O (FAK or SK).

t Press F9 (SK).

The Open dialog box opens.

File Selection List Provides a list of all available files for you to open in a selected 
directory.

File name Displays the name of a selected file.

Files of type Acts as a filter, showing files of only selected types. Click on the down 
arrow to select from a menu.

My Network Places 
Button

Opens a dialog to map a path to other servers or Deko systems on your 
network.

Image properties Provides information about the selected file.

• Horizontal pixels - The number of horizontal pixels in the image 
(width).

• Vertical pixels - The number of vertical pixels in the image (height).

• Video standard - The video standard for the image (for example, 
NTSC, PAL, HD1080I, and so on). 

Preview area list 
suboptions

Determines whether you want to view a thumbnail of an image in the 
lower right hand corner of the dialog box.

Open Option Description (Continued)
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2. Navigate to the drive and directory that contains the file.

3. Do one of the following:

t Select the file from the File name menu.

t Type the file name in the File Name text box. 

4. Click OK or press Enter.

n The next time you display the Open dialog box, Deko prompts you with the name of the next 
file in the current directory. Use the Up Arrow key and Down Arrow key to scroll through 
other file names.

In addition to Deko (.dko) graphics, Deko can import several file types, including: Bitmap 
(.dib, .rle), Windows Bitmap (.bmp), Photoshop (.psd), TIFF (.tif), TARGA (.tga), JPEG 
(.jpg), Pinnacle Systems (.g) files created in Thunder, Lightning, FlashFile, or Genie, and 
many others, to use as textures. For more information, see “Importing Still Images and 
Clips” on page 413.

Unlike many Windows applications, Deko does not always open a new window when you 
open a file. If a Graphic (Program or Preview) window is already open, Deko opens a 
graphic into that window, replacing the previous file. Be sure to save any modified file before 
opening another file in the same window.

Opening a File From a Browser

To open a file from a browser:

1. Open the Browser by doing one of the following:

t Select View > Browser.

t Press Ctrl+L (SK).

t Press Browse Graphics (FAK).

2. Scroll to the thumbnail of the file you want to open and double-click it. 

The file opens in the Graphic window.

Opening a New Window

You can open a multiple instances of the following windows:

• Preset Style

• Graphic

• Sequence
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• Effect

• Macro

To open a new window:

1. Activate a window for the type of file you want to duplicate.

2. Select File > New (Ctrl+N). 

This command varies depending on the type of window that is active. For example, if a 
Preset Style window is active, press Ctrl+N to open a second Preset Style window. 

n When you open a new window, the original window remains opened behind the new window.

To reopen the current file or the graphic file in the active window:

t Select File > Revert.

To open one of the four most recently opened files:

t Select a file from the list near the bottom of the File menu.

Viewing Thumbnails of your Graphics in Windows Explorer

To view thumbnails of your graphics in Windows Explorer:

1. Select File > Open.

The Open dialog box opens.

2. Locate your graphics folder.

3. Click on the Views button, and select Thumbnails. 
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All Deko (.dko), TARGA (.tga), and Thunder/Lightning (.g) files are displayed in a 
thumbnail image.

Click the 
Views 
button and 
select 
Thumbnails

Preview 
menu
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Viewing a Preview of Your Image

When you select an image, you can preview the image as a thumbnail in the Preview area of 
the Open dialog box (lower right hand corner). 

To view a preview of your image:

1. Select an image.

2. Select Preview > Preview picture. 

To turn preview off:

t Select Preview > Do not show preview.

Viewing a Key Signal or Alpha Channel of an Image

When you select an image, you can view the key signal or Alpha channel in the Preview area 
of the Open dialog box (lower right hand corner). 

To view the key signal or alpha channel of the image in the Open dialog box, 

1. Select an image.
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2. Select Preview > Preview alpha.

Viewing Image Properties

Deko enables you view the image properties of a selected image in the Open dialog box.

You can view the following properties:

• Horizontal pixels - The number of horizontal pixels in the image (width).

• Vertical pixels - The number of vertical pixels in the image (height).

• Video Standard - The video standard for the image (such as, NTSC, PAL, HD1080I, and 
so on). 

n The Video Standard is displayed only for Deko (.dko) files.

Preview menu

Image 
properties 
area

Image preview 
area
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Opening Non-Deko Files

For any image files that are not Deko (.dko) files, you can specify the pixel aspect of the 
source file. This is very helpful to know when importing these images into a Deko Graphic. 
For more information, see “Importing Still Images and Clips” on page 413.

To open a non-Deko file:

1. Select File > Open.

2. Double-click a non-Deko file.

The following two menus appear in the Open dialog box:

- Pixel aspect of source file

- Auto scale

3. In the Pixel aspect of source file menu, select the pixel aspect pertaining to the non Deko 
texture file. For more information, see “About the Texture Shader” on page 118.

Pixel aspect of 
source file 
area

Auto scale 
menu
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4. Select the Auto scale method for the image. For more information, see “About the 
Texture Shader” on page 118.

5. Click Open.

Opening Files in Windows Explorer

Deko enables you to open files in Windows Explorer. You can select Deko (.dko) files, 
TARGA (.tga) files, or Lightning (.g) files. They appear as graphics when you click the 
Views button and select Thumbnails from the menu. 
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Saving Files

When you click or type a Save command, Deko always saves the file in the active window. 
An asterisk (*) next to a file name on a window’s title bar indicates that the file has been 
modified since it was last saved.

Deko automatically attaches the standard extension to the file name. For example, a graphic 
file named myfile is saved as myfile.dko.

The following topics provide more information about saving files:

• “Saving an Untitled File or Saving a File Under a New Name” on page 403

• “Creating a New Directory for Saving Files” on page 404

• “Saving an Existing File” on page 404

• “Saving a Graphic in a Different Video Standard” on page 404

• “Specifying Whether to Save Character Glyphs” on page 405

• “Saving a Fully Rendered Bitmap with a Graphic File” on page 405

• “Saving a Graphic with an Automatic Comment” on page 406

Saving an Untitled File or Saving a File Under a New Name

To save an untitled file or to save a file under a new name:

1. Do one of the following:

t Select File > Save As. This command varies depending on what type of window is 
active. For example, if a Preset Style window is active, the command is Save Preset 
Styles As.

t Press F12 (SK).

t Press Save File (FAK).

The Save File As dialog box opens.

2. Navigate to the drive and directory where you want to save the file.

Deko prompts you with the name of the most recently saved file and appends a numeric 
suffix.

3. Use the Up arrow or the Down arrow to increase or decrease this number.

4. (Option) Type a new file name in the File Name text box.

5. Click OK or press Enter.
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n When you navigate to a new directory, the new directory automatically becomes the default 
directory in Preferences for that file type.

Creating a New Directory for Saving Files

To create a new directory for saving files:

1. Select File > Create Directory. The Browse for Folder dialog box opens.

2. Navigate to the drive and directory where you want to add the new directory.

3. Do one of the following:

t Type a directory name in the Folder text box.

t Click the Make New Folder button, and type a name for the new folder.

4. Click OK or press Enter.

n When you create a new directory, the new directory does not automatically become the 
current directory.

Saving an Existing File

To save an existing file:

t Do one of the following:

- Select File > Save.

- Press Ctrl+S or Alt+F12 (SK).

- Press Alt+Save File (FAK).

 Deko replaces the previous version of the file.

Saving a Graphic in a Different Video Standard

n Graphics must be saved in a format compatible with the video standard where they will be 
broadcast. In the United States, the video standard is NTSC. PAL is a video standard used in 
Europe, most areas in Asia (including Russia), the Middle East, Latin America, South 
Africa, and Australia.

To save a graphic under a different video standard for use in other countries:

1. Select File > Save Graphic As (F12).

The Save Graphic As dialog box opens.

2. Select Options.

3. In the Video Standard text box, do one of the following:
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t Select NTSC.

t Select PAL.

t Select Custom, then enter Horizontal pixel and Vertical pixel values.

4. Click OK or press Enter.

Specifying Whether to Save Character Glyphs

n Graphic files that include a large font or complicated look occupy more disk space when 
saved with character glyphs, but can be retrieved faster.

To specify whether or not to save character glyphs for quicker retrieval:

1. Select File > Save Graphic As (F12). 

The Save Graphic As dialog box opens.

2. Select Options.

3. Select when to save graphic files with prerendered glyphs. Options are:

- Always

- Never

- If not already in prerendered style 

n Avid recommends selecting Never.

4. Click OK or press Enter.

Saving a Fully Rendered Bitmap with a Graphic File

n Graphic files that are saved with prerendered bitmaps occupy more disk space, but can be 
retrieved much faster.

c Do not use this feature for graphics with replaceable text or textures. Graphics saved 
this way always display the original text or texture.

To save a fully rendered bitmap with a graphic file for faster recall:

1. Select File > Save Graphic As (F12).

The Save Graphic As dialog box opens.

2. Select Options.

3. Select Save rendered bitmap for faster recall.

4. Click OK or press Enter.
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Saving a Graphic with an Automatic Comment

In order to easily identify your graphics, Deko enables you to enter a comment to your 
graphic before saving it.

To save a graphic with an automatic comment:

1. Select File > Save Graphic As (F12).

The Save Graphic As dialog box opens.

2. Select Options.

3. Select Add automatic comment. 

Deko automatically fills in the comment field with the characters from the graphic’s first 
text field.

4. Click OK or press Enter.

Adding File Properties to a Graphic

Deko now enables you to add file properties to a graphic. This information is stored in the 
file system.

To add file properties to a graphic:

1. Navigate to your graphics folder.

2. Right-click a graphic, and select Properties.

3. Add information to the file such as Author, Title, Subject, keywords, and so on.

4. Click OK to close the dialog box.

You can now view this information in Windows.
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Viewing File Information for Associated Clips and 
Macros

You can view the information about a .dko file. The information includes associated clips 
and macros that identify unique components of a graphic.

To view file information:

1. Open a graphic.

2. Select File > Information. 

The following window opens.
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Closing Files and Exiting Deko
There are several ways to close files and exit Deko. 

The following topics provide information about the different ways to close files and exit 
Deko:

• “Closing a File in the Active Window” on page 408

• “Closing all Open Files and Exiting Deko” on page 408

• “Having Deko Prompt You to Save Modified Files Before Closing Them” on page 409

• “Having Deko Prompt You to Save Before Exiting” on page 409

Closing a File in the Active Window

To close a file in the active window:

1. (Option) Save the file.

2. Do one of the following:

t Double-click the control icon in the upper left corner of the active window.

t Select File > Close (Ctrl+F4). This command is different for each type of file. For 
example, if a Macro window is active, the command is Close Macro.

n If you close the Macro window, the opened macro appears again when you reopen the 
window. You can also play back the active macro even when the macro window is closed. For 
more information, see “Streamlining Your Work with Macros” on page 713.

Closing all Open Files and Exiting Deko

To close all open files and exit Deko:

1. (Option) Save any files.

2. Do one of the following:

t Double-click the control icon in the upper left corner of the Deko application 
window.

t Click the X icon in the upper right corner of the Deko application window.

t Select File > Exit (Alt+F4).
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Having Deko Prompt You to Save Modified Files Before Closing Them

n Avid does not recommend this choice for on-air situations, where speed is critical.

To have Deko prompt to save modified files before closing them:

1. Select Options > Preferences.

The Deko Preferences dialog box opens.

2. Select Prompts.

3. Select Prompt to save before closing.

4. Click OK or press Enter.

Having Deko Prompt You to Save Before Exiting

To have Deko prompt you to save before exiting the Deko application:

1. Select Options > Preferences.

The Deko Preferences dialog box opens.

2. Select Prompts.

3. Select Prompt before exiting Deko.

4. Click OK or press Enter. 

Moving or Renaming Multiple Files

Deko’s Block File Utility looks for files based on user-specified criteria, so that you can 
copy, rename, or move large groups—or blocks—of files that might or might not be 
sequential.

However, sequences and macros can be designed to access certain files by name or location. 
If you rename or move a file included in a sequence or macro, Deko does not know where to 
find the file and the sequence or macro is rendered useless. If you are certain a file is not 
needed by an existing sequence or macro, you might want to rename or move it. Otherwise, 
if you want to access a file by a new name or in a new location, copy the file first, leaving the 
old name and location intact.

To copy, move, or rename a group of files:

1. Select File > Block File Utility.

The Block File Utility dialog box opens.
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2. In the Input section, specify the following:

- Prefix - Deko looks in the input folder for all file names that begin with a number. If 
you enter a text prefix here, Deko looks for all file names that begin with this prefix 
immediately followed by a number.

- Extension - Specify an Extension to limit the search to files of a certain type.

- Folder - Select the input folder that contains the files.

Deko displays a list of all files that match your Input criteria.

3. In the Output section, select options as described in the following table:

4. Select the file(s) you wish to copy or move from the Input list.

n To select a range of files, Shift+click the file names. To select random files, Ctrl+click the file 
names.

The Output section displays a list of what the corresponding file names are.

5. Do one of the following:

Output Option Description 

Prefix If you want to change the prefix for the copied or moved files, enter 
the new prefix here. Otherwise, select Same As Input.

First Number If you want to renumber the output files, type a number that replaces 
the current first number of the input files. Deko renumbers the files 
sequentially based on this first number.

Remove Gaps Select this option to renumber nonsequential files to remove gaps 
between file numbers.

Add Leading Zeros To adjust file names so that they all have the same number of digits, 
add leading zeros.

• Auto - Determines the number of digits needed to fit the highest 
numbered output file, and adds leading zeros as needed to adjust 
each filename to have that number of digits.

• Number of digits - Enables you to enter a specific number of 
digits for output files. If you select a number that is too small, 
Deko does not truncate the filenames. For example, 100.dko 
remains 100.dko, even if you set Number of digits to 1.

Same As Input Folder Select this option if you want the output files to be copied into the 
same folder that contains the input files. Otherwise, type an output 
folder name in the text box.
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t Click the Copy button to copy the input files to the output folder. 

t Click the Move/Rename button. If the output folder is the same as the input folder, 
Deko simply renames the files. Otherwise, Deko renames the files and moves them 
into the output folder.

n Click Copy, rather than Move/Rename, unless you are certain that the files are not 
referenced by an existing macro or sequence.

6. Click Exit to close the Block File Utility dialog box.

Deleting Files

w This procedure permanently erases files from your computer’s disk drive.

To delete a file:

1. Select File > Delete File (Ctrl+Delete). 

The Delete File dialog box opens.

n If you use the Delete File key on the FAK, it deletes the file in queue, not in the Program 
window. However, it does display the Delete File dialog box so you can confirm which file to 
delete. Make sure you are deleting the correct file.

2. Navigate to the drive and directory that contain the file.

3. Select the file from the File Name list box or type the file name in the File Name text 
box.

4. Click OK or press Enter.

A confirmation dialog box opens.

5. Click Yes or press Enter to confirm the deletion.
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10 Importing Still Images and Clips

In addition to creating graphics with your Deko, you can also import graphics (including still 
images and clips) from other sources. Another powerful Deko option to understand is how to 
use ClipDeko to record, import, create and open clip databases, and play digital video clips, 
with or without key. Once imported, you can edit, loop, trim, and browse these clips.

The following topics describe how to import and work with still images and clips:

• Understanding Computer Graphics

• Creating Graphics in Other Applications and Importing to Deko

• Importing Adobe Photoshop Layers as a Deko Graphic

• Importing Graphics from Legacy Systems

• Managing Stills with StillDeko, and Thunder

• Using the ClipDeko Option

• Recording Clips Using the Clip Record Interface

• Importing Clips

• Using Static Mattes

• Using ClipAutoUpdate

• Preparing to Play a Clip

• Playing a Clip

• Stopping Clip Playback

• Using Power Clips (Deko 3000 SD/HD/HY only)

• Playing a Thunder Sequence from Deko
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Understanding Computer Graphics
Understanding computer graphics in general might help you determine how and when to use 
various types of files. 

The following topics provide more information about computer graphics:

• “File Formats” on page 414

• “About Key Channels” on page 415

• “Saving TIFF and TARGA Files with File Compression” on page 416

File Formats

There are many file formats currently used in computer graphic applications. Formats are 
identified by three letter extensions to the file name, such as .dko, .tga, .bmp, and so on 
Although Deko graphics are saved as .dko files, Deko supports a variety of still image and 
clip formats.

Supported File Type File Extension 

Still images • .tga

• .tif (TIFF)

• .bmp

• .pcd

• .g

• .jpg

• .pcx

• .pct (PICT)

• .psd

• .wmf

• .dib

• .rle

• .pct (Deko does not see alpha channels in this format.)

• .png (Deko does not see alpha channels in this format.)

Clips .dv

.mov

.mxf



Understanding Computer Graphics

415

About Key Channels

In addition to carrying RGB color values, graphic files used with Deko might include a Key 
Channel. An key channel contains gray scale information used to mask or hide part of the 
graphic, and allows images, clips or video to show in that space. An application, such as 
Adobe Photoshop, is required to create a key channel.

Example A, in the following illustration, shows a graphic image. Example B shows the key 
channel (mask). When the mask is combined with the photo, as in example C, the muted 
color area is cut from the image when it is displayed within Deko, as shown in Example D.

n Other terms for key channel include: alpha channel, key, mask, or matte.

Not all formats can carry alpha channels. Deko can read the alpha channels of only Deko 
(.dko), Pinnacle Systems (.g), Pict (.pct), TARGA (.tga) Photoshop (.psd), and 
TIFF (.tif) files. 

If you have a file saved in another format, you can use an existing alpha channel, or create a 
new one.
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To use an existing alpha channel or create a new one:

t From a Paint program, save the file with the alpha channel as a Pict, TIFF, TARGA. or 
Photoshop file.

Saving PICT, TIFF, and TARGA Files with Alpha Channel Within Deko

To save PICT, TIFF, and TARGA files with alpha channel within Deko:

1. Select File > select Save Graphic As (F12). The Save Graphic As dialog box opens.

2. Select Options.

3. If you are saving PICT, TIFF and TARGA files, select Save with alpha channel (32-bit).

4. Click Save.

Saving TIFF and TARGA Files with File Compression

Some file formats compress bitmap image data to reduce the amount of required storage 
space. Lossless compression techniques compress image data without removing detail. 
Lossy techniques compress image data by removing detail. Understanding types of 
compression might help you select the most effective formats for your needs. 

To use file compression when saving TIFF and TARGA files:

1. Select File > Save Graphic As (F12). The Save Graphic As dialog box opens.

2. Select Options.

3. If you are saving TIFF and TARGA files, select Use file compression.

4. Click Save.
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Creating Graphics in Other Applications and 
Importing to Deko

Graphics created in other applications can be imported into Deko. This section discusses 
principles you should consider before importing graphics into Deko.

The following topics provide more information about creating graphics in other applications 
and importing them to Deko:

• “Importing Deko and Non-Deko Graphics” on page 417

• “Pixel Shape, Aspect Ratio, and Graphic Size” on page 419

• “Creating and Importing Full Screen PhotoShop Images into Deko” on page 422

• “Using Photographs or Continuous Tone Graphics” on page 426

• “Importing Deko and Non-Deko Graphics” on page 417

Importing Deko and Non-Deko Graphics

When importing Deko and non-Deko graphics, you are basically opening them in Deko. 
Therefore, the Open dialog box opens. The Open dialog box provides the tools for finding 
and opening files in the Deko interface, and also enables you to:

• view thumbnails of your .dko graphics, and preview the image that is currently selected, 
and

• select how you want to open non-Deko files.

When importing non-Deko files (.psd, Tif, and so on), you can specify the pixel aspect of the 
source of any image files that are not Deko (.dko) files. For more information on using other 
aspects of the Open dialog box, see “Opening Files Using the Open Dialog Box” on 
page 430.
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To import Deko and non-Deko files:

1. Select File > Open. The Open dialog box opens.

2. In the Look in menu, navigate to the drive and folder containing your Deko or 
non-Deko file.

3. In the Files of Type menu, select the file format for your Deko (.dko) or non Deko (.psd, 
.tif, and so on) graphic. 

This filters the view to only include those files.

Select the pixel 
aspect of the 
source file.
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4. Do one of the following:

t Click the appropriate file to select it.

t Select the desired file from the File name menu. 

When you open a non-Deko file, the following two fields appear in the Open dialog box 
that do not appear for Deko graphics:

- Pixel aspect of source file

- Auto scale

5. If you are importing a 

t Deko file, go to Step 8.

t non-Deko file, go to Step 6.

6. In the Pixel aspect of source file menu, select the pixel aspect pertaining to the 
non-Deko texture file. For more information, see “About the Texture Shader” on 
page 135.

7. Select the Auto scale method for the image. For more information, see “About the 
Texture Shader” on page 135.

8. Click Open to open the file in Deko.

Pixel Shape, Aspect Ratio, and Graphic Size

Previously, images created in a square-pixel environment (most desktop creation 
applications such as Photoshop) had to be created and converted for a rectangle-pixel 
environment (such as Standard Definition broadcast video). In Deko, this conversion process 
is no longer necessary for images to display nondistorted.   Images created in paint 
applications, such as Photoshop can now be used in PC applications (also a square-pixel 
shape) and in Deko (with the square-pixel shape source as the import selection). However, 
there are some guidelines that you need to follow.

The following topics provide more information about pixel shape, aspect ratio, and 
graphic size:

• “Recommendation for Images that are not Full Screen” on page 420

• “Recommendation for Full Screen Images” on page 420

• “Traditional Method of Adjusting Pixel Shape for Square to Rectangle” on page 420
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Recommendation for Images that are not Full Screen

When creating or importing images that do not need to be full screen (such as logos, banners 
or art elements), the main concern of the designer is that the image retains its aspect ratio (or 
displays in broadcast nondistorted). Smaller aspect ratios for logos or art elements, such as 
100x100, can be created on a square-based application, such as Photoshop, and imported 
with the Pixel Aspect Source of Square and No Scaling. The result is the original image 
shape (Deko alters the size automatically to maintain aspect ratio), nondistorted, in 
Photoshop and Deko output. 

All supported HD formats are square; set the Pixel Aspect Source to Square and No Scaling 
(unless other needs dictate a specific AutoScaling setting other than none, such as Fit for 
template design).

Recommendation for Full Screen Images

When creating full screen images in Photoshop for import to Deko, there are three objectives 
you want to achieve:

• You want an import with the best resolution.

• You don’t want to lose any of the image.

• You want to maintain the image aspect ratio (non-distorted).

Even though Deko can now adjust for square shape pixels and display them correctly in 
Deko’s output, care must be taken to create an image that does not cut off the sides or tops of 
the image.

The recommended procedure is to follow the process described “Creating and Importing 
Full Screen PhotoShop Images into Deko” on page 422.

Traditional Method of Adjusting Pixel Shape for Square to Rectangle

There are actually two “traditional” methods of adjusting Pixel Shape from square to 
rectangle based on whether the image is 4 x 3, or 16 x 9.

When creating 4 x 3 images with Photoshop or other square pixel paint programs:

1. Determine the Video Standard you want to create the image for, and make your image 
size as follows:

- For NTSC use 720 x 540

- For PAL use 768 x 576

n This is a 4 x 3 aspect ratio in square pixels. However, some paint programs allow you to 
select video as a file resolution which automatically compensates for rectangle pixels.
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2. Save a copy of the image at this size in case you need to edit it later. 

3. Just before you are ready to export your file to Deko, resize the image to 720 x 486 (for 
NTSC) and save the image as a .tga, .tif, or .psd file. 

n Use 486 because Deko's video buffers are exactly 486 lines tall. The resized image appears 
geometrically distorted on your computer monitor, but displays correctly when imported by 
Deko.

4. In Deko, import that image with Pixel Aspect Source set to NTSC(.9) and Auto-scaling 
set to none (unless other scaling options are needed, such as Fit to resize the image to a 
layer dimension).

When creating 16 x 9 images with Photoshop or other square pixel paint programs:

1. Determine the Video standard you want to create the image for, and make your image 
size as follows:

- For NTSC, use 864 by 486

- For PAL, use 1024 x 576

2. Scale down to 720 x 486 before saving the file. 

n By using the 864 pixel count, you have an image that is in the 16 x 9 aspect ratio, and you 
are scaling down before saving. Do not use a 720 x 405 image because you would have to 
scale up when changing to video resolution, thus reducing image quality.

3. In Deko, import that image with Pixel Aspect Source set to NTSC wide (1.2) and 
Auto-scaling set to none (unless other scaling options are needed, such as Fit to resize 
the image to a layer dimension).

4. Since this process prepares the image for proper display in television, import the image 
into Deko by selecting the Pixel Aspect Source for which it was prepared and set 
Auto-Scaling to None. 

n For example, an NTSC 4:3 image prepared as above would be imported into Deko as Pixel 
Aspect Source set to NTSC (.9) and Auto-Scaling to none (unless other needs dictated a 
specific AutoScaling setting other than none, such as Fit for template design).
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Creating and Importing Full Screen PhotoShop Images into Deko

Depending on how the image was created, and which version of Photoshop it was created 
with determines how to best import the image into Deko. There are three main ways to 
create and import Photoshop images into Deko. 

The following topics provide more information about creating and importing full screen 
Photoshop images into Deko:

• “Creating and Importing Images Created in an Old Version of Photoshop” on page 422

• “Creating and Importing Images Created in Photoshop Using Square Pixels” on 
page 424

• “Creating and Importing Images Created in Photoshop CS2 or Later” on page 425

• “When to use Pixel Aspect Source Set to NTSC, NTSC Wide, PAL, or PAL Wide” on 
page 426

• “Auto-Scaling Options Override Pixel Aspect Source” on page 426

Creating and Importing Images Created in an Old Version of Photoshop

Use the following table when creating and importing full screen images that were created in 
an old version of Photoshop (version 7.0 or earlier) into Deko.

The procedures described in the following table handle the conversions necessary to move 
between square-based applications and rectangle-based pixels in Broadcast. If these 
conversions have been used for your images, import them with the Pixel Aspect Ratio set to 
the video standard for which the conversion process was made.
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If your facility is using graphics that have already been converted for square-to-rectangle 
pixel aspect ratios, the following table describes the technique that was used and how they 
should be imported into Deko.

Video Standard In PhotoShop In Deko 

NTSC 1. Compose on 720 x 540 canvas  
(4 x 3, square pixels).

2. Save File at 720 x 486.

1. In the Pixel aspect of source file menu, 
select NTSC (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSC, and 
Autoscale - None.

PAL 1. Compose on 768 x 576 canvas  
(4 x 3, square pixels).

2. Save File at 720 x 576.

1. In the Pixel aspect of source file menu, 
select PAL (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - PAL, and 
Autoscale - none.

NTSC 16 x 9 1. Compose on 864 x 486 canvas  
(16 x 9, square pixels).

2. Save File at 720 x 486.

1. In the Pixel aspect of source file menu, 
select NTSCW (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSCW, and 
Autoscale - none.

PAL 16 x 9 1. Compose on 1024 x 576 canvas  
(16 x 9, square pixels).

2. Save File at 720 x 576.

1. In the Pixel aspect of source file menu, 
select NTSCW (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSCW, and 
Autoscale - none.
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Creating and Importing Images Created in Photoshop Using Square Pixels

Use the following table when creating and importing full screen images that were created in 
Photoshop using square pixels into Deko. 

n The procedures in the following table apply only for images that were not converted for the 
square-to-rectangle pixel aspect ratio.

Video Standard In PhotoShop In Deko 

NTSC 1. Compose on 720 x 480 canvas 
(4 x 3, square pixels).

2. Save File at 720 x 480.

1. In the Pixel aspect of source file menu, 
select Square.

2. In the Auto scale menu, select None.

3. Click Open.

PAL 1. Compose on 768 x 576 canvas  
(4 x 3, square pixels).

2. Save File at 768 x 576.

1. In the Pixel aspect of source file menu, 
select Square.

2. In the Auto scale menu, select None.

3. Click Open.

NTSC 16 x 9 1. Compose on 864 x 486 canvas  
(16 x 9, square pixels).

2. Save File at 864 x 486.

1. In the Pixel aspect of source file menu, 
select Square.

2. In the Auto scale menu, select None.

3. Click Open.

PAL 16 x 9 1. ompose on 1024 x 576 canvas  
(16 x 9, square pixels).

2. Save File at 1024 x 576.

1. In the Pixel aspect of source file menu, 
select Square.

2. In the Auto scale menu, select None.

3. Click Open.
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Creating and Importing Images Created in Photoshop CS2 or Later

Use the following table when creating and importing full screen images that were created in 
Photoshop CS2 or later into Deko.

Video Standard In PhotoShop In Deko 

NTSC 1. Compose on 720 x 486 canvas 
(4x3, NTSC pixels).

2. Save File at 720 x 486.

1. In the Pixel aspect of source file menu, 
select NTSC (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSC, and 
Autoscale - None.

PAL 1. Compose on 768 x 576 canvas 
(4x3, PAL pixels).

2. Save File at 720 x 576.

1. In the Pixel aspect of source file menu, 
select PAL (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - PAL, and 
Autoscale - none.

NTSC 16x9 1. Compose on 720 x 486 canvas 
(16x9, NTSCW pixels).

2. Save File at 720 x 486.

1. In the Pixel aspect of source file menu, 
select NTSCW (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSCW, and 
Autoscale - none.

PAL 16x9 1. Compose on 720 x 576 canvas 
(16x9, NTSCW pixels).

2. Save File at 720 x 576.

1. In the Pixel aspect of source file menu, 
select NTSCW (or any).

2. In the Auto scale menu, select 
Fullscreen-scale to fullscreen.

3. Click Open.

n Or, select Pixel aspect - NTSCW, and 
Autoscale - none.
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When to use Pixel Aspect Source Set to NTSC, NTSC Wide, PAL, or PAL Wide

If you have library images (either full screen or less than full screen dimensions) that were 
already created with the square-to-rectangle conversion process defined above, select the 
Pixel Aspect Source for which they were intended.

• For NTSC 4:3, import Pixel Aspect Source = NTSC(.9)

• For PAL 4:3, import Pixel Aspect Source = PAL (1.07)

Similarly, if you are using images from one video standard to use in another video standard, 
specify the Pixel Aspect source file of the original image. For example, images created in 
Deko NTSC 16 x 9 can be imported into Deko HD 1080i properly by selecting NTSC (.9) as 
the Pixel Aspect source file.

Auto-Scaling Options Override Pixel Aspect Source

Some Auto-scaling options override the Pixel Aspect Source selection. For instance, 
Auto-scaling as FullScreen or Fit often makes any Pixel Aspect Source irrelevant. Deko 
forces the image to FullScreen or Fit regardless of the Pixel Aspect Source designation.

Deko handles import options in this order:

1. Pixel Aspect Source shape

2. Auto-Scaling

3. Other scaling or attribute settings in the Shader window (that is, H/V Scaling)

A combination of these settings allow Deko operators to make infinite adjustments to air 
images with a wide range of options.

Using Photographs or Continuous Tone Graphics

As discussed in previous chapters, Deko graphics consist of one or more layers and a 
background. Layers might contain text or shapes. Backgrounds might be transparent, or 
“painted” with solid colors, ramp shaders, or textures. Deko can create rectangular or 
ellipsoidal shapes. Complex looks can be applied to fonts and shapes.    

Photographs or continuous tone graphic elements such as team logos or station IDs might 
also be included in your Deko graphic. You must import these elements from another 
application. Deko allows imports from a variety of sources.

Deko can use imported files as backgrounds or to supply texture fills to any font or shape 
with a Texture Shader. You can use imported graphics to create a Custom Typeface. Custom 
Typefaces are ideal for handling frequently used logos or IDs. For more information, see 
“Creating Custom Typefaces” on page 353.
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Importing Adobe Photoshop Layers as a Deko 
Graphic

This feature enables the import of Adobe Photoshop (.psd) layers, individually or as an 
entire image directly into a Deko graphic. 

n Due to differences between Deko and Photoshop in how rendering is performed, a 
Photoshop graphic imported as layers might appear slightly different from the same file 
imported “flat”, as a background.

To import Adobe Photoshop layers as a Deko graphic:

1. From Adobe Photoshop, build your graphic as you normally would, but consider that 
Photoshop layer names are preserved on import to Deko, so it is recommended that you 
select layer naming conventions that enable easier Motion creation. 

For example – animating layers of a leaderboard can be time consuming if each layer 
has its own Action. Name layers smartly, and the Motion build can be reduced to only 
seconds. In the following image, all like layers that might animate together are grouped 
by their names... “ots_topbar”… “ots_midbar”… “ots_bak”, and so on. When the 
Motion is created, only one Action is needed for ots*.

n Alpha channels are also preserved. Layer order might occasionally be off due to the 
blending that takes place. Keep this in mind on import.

2. To rename Photoshop layers, double-click on the name in the Layers tree 
within Photoshop.
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To import ALL .psd layers into Deko:

1. Set focus to the graphic window. 

2. Select File > Append Layers. 

The Append Layers dialog box opens.

n Be sure to set you Scaling Options as desired.

3. Navigate to the Photoshop file for import then click Open. 

Individual layers display in your graphic window. 

4. Page Up/Down to locate the layers. 

n Look at the status bar for layer names and layer number.

To import INDIVIDUAL .psd layers into Deko:

1. Click on the Background button to enable the Background Shader menu.

2. From the Background Shader menu, click on Texture. 

3. Click Open and navigate to the desired Photoshop file.

4. Click OK.

The entire Photoshop image displays as a Background Texture (flattened, no layers). 

n The Layer field to the right of File name indicates 0, which displays the entire flattened 
image.

5. To specify an individual layer, either click the up/down arrows in the Layer field or type 
in the Layer number. 

Opacity levels can also be applied.



Importing Graphics from Legacy Systems

429

Importing Graphics from Legacy Systems

Deko provides a couple of options for importing different types of graphics (the Aston 
Import option, and the Chyron option.) 

n Some import options might require the use of an external drive connected via a USB port.

The following topics provide more information about importing graphics from legacy 
systems:

• “Transferring GF/Halo/Kseries/Presto Images to Deko” on page 429

• “Aston Import Option” on page 429

• “Chyron Import Option” on page 430

Transferring GF/Halo/Kseries/Presto Images to Deko

To transfer a GF/Halo/Kseries/Presto image to Deko:

1. Record the GF/Halo image as a still or Kseries/Presto as ppic.

2. Insert a compatible disk formatted for DOS into one of the GF/Halo drives.

3. Do a dos export. Export the GF/Halo still to the DOS disk as a DOS file with a .gf 
extension for GF or .20k for Kseries/Presto.

4. Remove the disk from the GF/Halo drive and insert it into a drive of your Deko system.

5. Select File > Open. The Open dialog box opens.

6. Navigate to the drive and directory that contain the .gf file or .20k file.

7. Select the file from the File Name menu or type the file name in the File Name text box.

8. Click Open or press Enter.

n You can reverse this process to transfer graphics from Deko to GF/Halo. Only graphic files 
(still, TARGA, tiff and dko, g and bmp) can be shared. Text files are not compatible.

Aston Import Option

n To determine whether this option is enabled on your system, select Options > Enabled 
Options.

The Aston Import option gives you the ability to read Aston files and work with them in the 
Deko environment.
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To open the Aston Import window:

1. Insert the Aston disk into the appropriate drive and close the drive door.

2. Activate a graphic window.

3. Select View > Aston Import.

To convert an Aston file to a Deko file:

1. In the Aston Import window, navigate to the directory that contains the Aston file, and 
click the file to select it.

2. Click the Convert button. 

Deko converts the file and opens it in the active graphic window.

n Once you have converted an Aston file, you can use it just as you would any other Deko 
graphic, and you can save it as a .dko file.

To map an Aston font to a TrueType font:

1. In the Font Mapping section of the Aston Import window, find the Aston font in the 
left-hand column. 

n Deko automatically maps Aston fonts into default fonts supported by Deko.

2. Double-click the corresponding Deko font and select a new font from the menu.

Chyron Import Option

n To see if this option is enabled on your system, select Options > Enabled Options.

The Chyron Import option gives you the ability to read Chyron Infinit family files and work 
with them in the Deko environment. The members of the Infinite family include Maxine, 
Max, Winfinit, and Infinit. These files come in two types:

• Message - Message directories contain message and RGBA files that Deko can read into 
a Program or Preview window. These files usually refer to fonts, which you can 
associate with TrueType fonts for viewing and editing within Deko.

• Machine - Machine directories contain logo font files that Deko can convert into Deko 
custom typeface (.fac) files.

To open the Chyron Import window:

1. Insert the Chyron disk into the appropriate drive and close the drive door.

2. Click in a Program or Preview window.
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3. Select View > Chyron import.

To import a Chyron message file:

1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the message file.

3. Double-click the file name to open the file in the active Program window.

n Once you have imported a Chyron message file, you can save it as a Deko (.dko) file. 

To map a Chyron bitmap font onto a TrueType font:

1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the message file. 

3. Click the file name to open its Font Mapping list in the window.

4. Double-click an item in the Font Mapping list to open the list of available fonts.

5. Select a TrueType font, then click Accept.

The font is added to the mapping file for the current Deko session.

To save the current font mapping file for future Deko sessions:

1. In the Chyron Import window, click the Details button. 

2. Click Save.

3. Enter a name for the mapping file, then click Save.

4. Click OK or press Enter. 

Deko saves the font mapping file as a text (.txt) file.

To open a font mapping file:

1. In the Chyron Import window, click the Details button.

2. Click Open, then navigate to the mapping file.

3. Double-click the file name, or click Open.

4. Click OK or press Enter.

To convert a Chyron logo font into a custom typeface:

1. Open the Chyron Import window.

2. Navigate to the drive and directory that contain the machine file. 

The file description displays.

3. Double-click the file name to open and import the file into a Custom Typeface window.

4. Select File > Save Custom Typeface As.
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5. Navigate to the drive and directory where you want to store the file.

6. Type a new file name in the File Name text box, then click Save or press Enter.

Managing Stills with StillDeko, and Thunder

n To determine whether options are enabled on your system, select Options > Enabled 
Options.

As you use Deko more and more, you need to keep track of your still images before they get 
too difficult to manage. Deko offers the following tools to help with managing stills.

The StillDeko option offers efficient integration of your still store with the Deko. With 
StillDeko you can store, recall, and title stills.

StillDeko uses ThunderBrowse software to integrate Thunder databases with Deko. Thunder 
is a high performance, network based, clip and image storage and management system, used 
in on-air broadcast and production.

With the ThunderBrowse software, you can:

• Open and edit a Thunder image in Deko.

• Associate a Thunder clip with a Deko graphic.

• Store Deko files in a Thunder database on your Deko’s hard drive.

• Fully utilize StillDeko and ClipDeko.

n To install ThunderBrowse, refer to the Avid OAG Setup and Configuration Guide.

The following topics provide more information about managing stills with StillDeko, and 
Thunder:

• “Connecting to an Existing Remote Database” on page 433

• “Setting Up a Database on Deko” on page 433

• “Using Thunder Browse with StillDeko” on page 434
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Connecting to an Existing Remote Database

To access databases on another system in your network, you must first make sure you are 
connected to that system. Once connected, the other system always appears in the Thunder 
Browser Tree.

n If your Deko is not networked, check with your network administrator.

To connect to a remote database:

1. Open Thunder Browse.

2. In Thunder, select File > Open.

3. In the Look In field at the top of the Open dialog box, select Network Neighborhood.

4. Select the remote system name.

5. Select the exported drive (usually D).

6. Select the Thunder directory.

7. Select the database (.pff) file you want to open.

Setting Up a Database on Deko

When setting up a database on Deko, you must first set up file sharing for the drive where 
the database resides. You can then create a new database and open it. You can also set a 
default database.

To set up file sharing on the hard drive:

1. At the bottom left corner of the desktop, select Start > Programs > Windows Explorer.

2. Right-click the drive where you want to store Thunder databases (generally databases 
are stored on the D: drive).

3. Select Sharing.

4. Under the Sharing tab, click the New Share button.

The New Share dialog box opens.

5. Type the drive designation letter, such as D, in the Share Name text box.

6. Click OK twice.

To create and open a database:

1. Open Thunder Browse.

2. Select File > Advanced > Create New Database.

3. Select Thunder as the Database Type.
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4. Enter a Database name.

5. In the Path field, type a Database Path that is unique to the new database and contains 
the full path name of the directory where the new database resides.

6. In the Database Type field, select the Video Standard you are working in. The default 
setting is 525 (NTSC). For PAL, select 625.

Once selected, Thunder automatically enters other field values for you.

7.  Click Create.

8. In Thunder Browse, select File > Open.

9. Navigate to the new database (.pff) file, and click Open.

To set a default database:

1. Open the database, as described above, so that it shows up in your Thunder 
Browse Tree. 

n You can select any database as the default database. It can be a database on your hard 
drive, or anywhere on the network.

2. In the Thunder Browse Tree, navigate to the database, then right-click the 
database name.

3. In the menu, click Set Default Database.

Using Thunder Browse with StillDeko

Deko enables you to open still images or clips in Thunder Browse, and then bring them into 
Deko for editing. Once an image has been edited in Deko, it becomes a Deko graphic. 
Thunder marks the upper right corner of the thumbnail image of the graphic with the 
Deko logo.

The following topics provide more information about Using ThunderBrowse with StillDeko:

• “Opening a Still Image from Deko” on page 435

• “Browsing for Images in Thunder Browse” on page 435

• “Opening a Still Image in Thunder Browse and Editing it in Deko” on page 435

• “Playing a Thunder Sequence Directly from Deko” on page 493

• “Associating a Thunder Clip with a Deko Graphic (for Use in a Deko)” on page 494

• “Saving a Deko Graphic in a Thunder Database” on page 436
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Opening a Still Image from Deko

To open a still image from Deko:

1. In Deko, click anywhere on the Program or Preview window.

2. Select File > Open From Thunder.

Depending on what you selected, either the Open From Thunder dialog box opens.

3. Double-click anywhere on the image data line.

n You can re-sort images alphanumerically by StillNum, Date, Title, Category, User, or Memo, 
by clicking the appropriate sort button.

Browsing for Images in Thunder Browse

To browse for images in Thunder Browse:

t Press Alt+Tab to find Thunder, then release the Alt key to open Thunder Browse. 

Thunder Browse has a variety of View menu options, to display exactly the information 
you want. Refer to the Avid Thunder Products User Guide and online help for 
more details.

Opening a Still Image in Thunder Browse and Editing it in Deko

To open a still image in Thunder Browse and edit it in Deko:

1. Do one of the following:

t Right-click the still, and select Title from the menu.

t Left-click the still, then press F9.

t Use the numeric keypad to type the number of the still, then press F9.

You are switched to the Deko application. The image you selected opens into the 
Preview or Program window (whichever was active).

n If Deko is already open, you can drag and drop an image from Thunder Browse to the Deko 
Preview or Program window.

2. With the image now in Deko, edit the image like any other Deko graphic.

Once you edit and save a graphic in Deko, Thunder marks the upper right corner of the 
thumbnail image of the graphic with the Deko logo.

You can associate a clip with a Deko graphic. For more information, see “Associating a 
Thunder Clip with a Deko Graphic (for Use in a Deko)” on page 494.

n Thunder marks thumbnail images of clips with a small film clip in the upper right corner.
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Saving a Deko Graphic in a Thunder Database

To save a Deko graphic in a Thunder database:

1. Open the graphic in an active Program or Preview window.

2. Select File > Save To Thunder. 

The Save to Thunder dialog box opens.

n In the Save To Thunder dialog box, you can edit any of the file details, which default to the 
details of the last saved image. Deko automatically picks an available, empty number for 
you. We recommend against changing the number, to avoid overwriting an existing still.

3. Click OK. 

The image is stored in the Thunder database, and shows up in the Browse window if you 
Alt+Tab to the Thunder Browse application.

n You can also drag and drop images from Windows Explorer into the Thunder Browser.

Using the ClipDeko Option

n To determine whether this option is enabled on your system, select Options > Enabled 
Options.

The ClipDeko option enables Deko to record, import, and play digital video clips, with or 
without key. You can edit, loop, trim, and browse these clips. 

With ClipDeko, you can play animated backgrounds without a separate DDR (digital disk 
recorder) or clip store. And, you can associate any clip to any Deko graphic or use a clip to 
fill a rectangle layer within a graphic.

ClipDeko supports several compression formats and clip file formats depending on 
your model.

For TARGA Standard Definition (SD) systems, the following formats are available:

• DV25 (.dv) at 25 Mbps.

• DV25 (.avi) at 25 Mbps

• MPEG-2 IBP (.mxf) at up to 50 Mbps
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For Corsica SD and HD systems, the following format is available:

• MPEG-2 I-Frame (.mxf) at up to 100 Mbps.

All Deko products are built on top of Avid’s object-based video processing engine that is 
designed to support a wide range of broadcast functionality, including clip record and 
playback, real-time effects generation, and graphics display. 

If you have the Make DekoMovie option, your Deko can create clips from Deko motions and 
effects, which can then be used by other applications. For more information on Make 
DekoMovie, see “Playing Sequences as Clips with Make DekoMovie” on page 517. 

Once recorded or imported, clips are organized alphabetically by clip name in a database. 
The priority can be changed by simple drag and drop operations. 

n The CG plane can only be in the foremost or backmost priority position relative to Bkg 
Clips, DekoObjex and Video In planes.

The following topics provide more information about using ClipDeko:

• “About the Clip Edit Window” on page 437

• “Accessing the Clip Edit Window” on page 438

About the Clip Edit Window

The Clip Edit window includes the following:

• Clip Edit buttons, allowing you to import, record, play, trim, and loop your clips, as well 
as assign key clips to fill clips, and align a fill clip with its associated key. 

• A Clip Browser, offering thumbnail images for fast access as well as clip association 
control for linking your clips to specific graphics. 
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n The Clip Edit window also allows you to associate Thunder clips for control of a Thunder 
from your Deko.

Accessing the Clip Edit Window

To view a clip in Output:

t Click on the appropriate Output View button at the top of the Deko application. For 
more information on using the Output View buttons, see “Determining Output View 
Priority” on page 749.

To open the Clip Edit window:

t Select View > Clip Edit (Ctrl+E).
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Creating and Opening Clips Databases

The Clip Edit window enables you to easily create new clips databases, or open existing 
clips databases.

To create and open Clips databases:

1. In the Clip Edit window, select the Clips button.

The Open Clip Database dialog box opens.

2. Navigate to an existing database and select it from the list, or click the New database 
button to create a new database.

3. With the database you want to open selected (highlighted), click the Open button to 
open the selected database.
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Recording Clips Using the Clip Record Interface

The Clip Record interface offers greater functionality and performance for capturing live 
material directly into your Deko system.

Clip Record allows you to capture whatever is being displayed on your Program output 
channels (Video or Key). The material that is captured can include live video streams, Deko 
graphics, clips, or DekoObjex elements – it all depends on how your Program window or 
Video Output tabs are configured (turned on or off) or what selections are made in the 
Record Clip window. To capture from the live video (or key) inputs directly, be sure to clear 
all other elements out of the selected Program channel prior to calling up the Clip 
Record window.

The following topics provide more information about recording clips:

• “Accessing the Record Clip Window” on page 440

• “Setting Up Your Clip Record Parameters” on page 441

• “Recording Your Clip” on page 441

Accessing the Record Clip Window

To access the Record Clip window:

1. Do one of the following:

t Press the Record button in the Clip Edit window.

t Select View > Record Clip. 
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Setting Up Your Clip Record Parameters

To set up your clip record parameters:

1. Set focus on the Program Channel that you want to record before opening the Record 
Clip window. 

2. In the Channel to record section, verify that the proper Program Channel is active.

3. In the Output to record menu, select whether you want to record the Video or 
Key output.

4. In the Graphic planes to capture section, select the planes that you wish to include in 
your recording from. 

n To record only the live input, deselect all of the planes other than Video In. 

5. In the Audio Channels to Record menu, select the number of audio channels that you 
want to record. 

6. In the Compression Format menu, select the file format that you would like to record.

7. If you selected the MPEG-2 format, select the appropriate bit rate that you want to 
record from the menu.

n Higher bit-rates produce higher quality clips, but overall performance of the system might 
be reduced when playing back the clips with Deko graphics. 

Recording Your Clip

To record your clip:

1. Set the path and directory to where you want to record your clips by clicking the Select 
Folder button.

2. In the Filename field, type the name of the file that you want to record.

3. If you want to change the maximum duration for the clip, type it in the Maximum 
Duration field. 

4. Press the Record button to start your recording at the appropriate time.

5. Press the Stop button to stop your recording.

6. PRess the Done button to close the dialog box.
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Importing Clips
You can import clips of different formats into Deko. Once imported, clips are organized 
alphabetically by clip name in the browser. You can type a letter to jump forward or 
backward through the browser alphabetically.

The following topics provide more information on importing clips:

• “Importing Clips to the Browser Database” on page 442

• “Renaming Clips” on page 445

• “Deleting Clips From the Browser Database” on page 445

• “Using Clips with Key” on page 446

• “Importing MPEG-2 (MXF) Clips into Deko” on page 447

• “Clip Formats and QuickTime” on page 449

• “Importing .MOV Files into Deko” on page 453

Importing Clips to the Browser Database

To import a clip to the browser database:

1. Copy the clip to the E drive/directory.

2. Select View > Clip Edit.

The Clip Edit window opens.

3. Click the Import button.



Importing Clips

443

The Import Clip dialog box opens.

4. In the Import Clip dialog box, navigate to the directory that contains the clip you want 
to import.

5. Select the file name. Notice that the File Properties tab displays information pertaining 
to that file, including the name, compatibility, size, frames, FPS (frames per second), 
GOP, format, bitrate, and whether the clip includes audio.

6. Select the appropriate radio button based on how you want to use the clip. Do one of 
the following:

t If you want to create a new clip, click the “Create a new clip” button.

t If you want to use the clip as a key clip in the currently loaded clip, click the “Use as 
key in currently loaded clip” button.
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7. If the clip you selected is being used to create a new clip, you can select the Clips tab to 
see if there are any fill files or key files associated with this clip.

8. For more options, select the Options tab.

9. If you want to:

t have the clip loop continuously, select the Loop continuously box.

t have the clip sync with effect, select the Sync with effect box.

10. If you want to make all currently selected options the default for other clips you will be 
importing, click the “Make current the default” button. Clicking this button enables you 
to import multiple clip files simultaneously and have the fill and key files automatically 
match up.

11. To change conversion settings for a clip you are importing, click the .MXF Options 
button. For more information, see “Importing .MOV Files into Deko” on page 453.
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12. To preview the clip, do the following:

a. Select an option other than “Do not show preview” from the Preview list.

b. Click the Play button.

13. Once you have selected your clip and any options for the import, click the Open button 
to import the clip to the location you selected.

Renaming Clips

Once, you have imported clips, you can rename them.

To rename a clip:

1. Do one of the following:

t In the Clip Edit window, click the clip name to highlight it, then click it again.

t Select the clip, then right-click and select Edit Clip Name from the menu.

2. Type a new clip name, and press Enter.

Deleting Clips From the Browser Database

Deko enables you to delete clips from the Browser database.

To delete a clip from the browser database:

1. Open the Clip Edit window and click the clip to select it.

2. Click the Delete button. 

Deko displays a message box asking if you want to delete the .avi file, .dv file, or 
.mxf file. 

3. Click Yes or No. 

4. If you selected Yes, the clip is deleted.

c Deleting the file erases the file completely from disk.

Play button



10  Importing Still Images and Clips

446

Using Clips with Key 

To use a clip with key, you must use two separate clips, one for the fill, and one for the key. 
You can then import them to use as one combined clip. For more information, see 
“Importing a Fill Clip and Its Associated Key” on page 446. The database displays one 
picon with a key symbol. 

You can import them individually and later link the fill to the key. For more information, see 
“Assigning a Key Clip to a Fill Clip” on page 446.

The following topics provide more information on using clips with key:

• “Removing the Key Assignment From the Current Clip” on page 447

• “Aligning a Key Clip with a Fill Clip” on page 447

Importing a Fill Clip and Its Associated Key

To import a fill clip and its associated key:

1. Import the fill clip to the browser database as described in “Importing Clips to the 
Browser Database” on page 442.

2. In the browser, double-click the thumbnail of the desired clip to load it. 

3. Import the key clip. For more information, see “Assigning a Key Clip to a Fill Clip” on 
page 446.

n Be sure to select Use as key in currently loaded clip in the Import Clip dialog box before you 
click Open.

Assigning a Key Clip to a Fill Clip

To assign a key clip to a fill clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Double-click the fill clip thumbnail to load it as the current clip.

3. Click the key clip thumbnail to select it. 

n The key clip must already be in the database.

4. Click the Assign Key button. 

Deko displays a key icon in the corner of the fill clip’s thumbnail image.
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Removing the Key Assignment From the Current Clip

To remove the key assignment from the current clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Click the Delete Key button.

Aligning a Key Clip with a Fill Clip

To align a key clip with a fill clip:

1. Click the CG Output View tab at the upper right of the screen and drag it to the far right 
of the other tabs so that Deko is under the Video In plane. For more information, see 
“Determining Output View Priority” on page 749.

n For FX Deko and Classic models, select Channel > Keying and Routing. Verify that Deko 
Under Video is selected.

2. Create a solid color background that contrasts with the clip color and with black.

3. Select View > Clip Edit.

The Clip Edit window opens.

4. Open a fill clip that has been assigned a key clip.

5. Click the Scrub Key button.

6. Use the thumbwheel or the double arrow keys to align the key clip with the fill clip.

7. Click Set Offset button. 

The key clip is now aligned with the fill clip.

Importing MPEG-2 (MXF) Clips into Deko

Expanding Deko’s clip format support to include .MXF files opens the door for file sharing 
and interoperability with other broadcast systems that support the MXF format. 

The following topics provide more information about importing MPEG-2 (MXF) Clips 
into Deko:

• “MPEG-2 Compression Format” on page 448

• “MXF File Compatibility with Liquid Editing Products” on page 448
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MPEG-2 Compression Format

With the MXF file format, Deko users now have greater flexibility in the size and quality of 
the clips that are used with the ClipDeko option.

n While clips encoded at higher bit rates (33 – 50 MBits/sec) produce higher quality results, 
they might affect the overall performance of your Deko system when used in a heavily loaded 
graphics sequence. Going beyond the performance capabilities of your Deko could result in 
glitching on the output of your system. Quality vs. Performance trade off should be analyzed 
when putting together your graphics and clips. 

MXF File Compatibility with Liquid Editing Products

The latest version of Avid’s editing systems, Liquid Blue and Liquid Chrome (Liquid 
Version 5.6 and newer) support the same MXF file format as Deko3000. 

Any MXF file captured in Deko3000 can now be easily imported into a Liquid Chrome or 
Liquid Blue project. In addition, any Liquid Chrome of Liquid Blue project can be exported 
into an MXF file that can be directly imported into the ClipDeko database and integrated 
into your Deko graphics.

The following steps must be taken with Liquid Chrome and Liquid Blue to properly export 
projects to be compatible with Deko3000. 

1. After your project is complete, Select Liquid Tools > Export Sequence As.

2. From the Export Sequence window, select MPEG MXF. 

3. From the Export Sequence window, press the Options button to open the MXF Settings 
window. 
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4. Select the desired bit rate from the Bit Rate selection list. 

5. In the Audio Video Stream section, select Multiplexed to properly embed the audio into 
the MXF file for playback within Deko.

6. Copy the resultant .MXF file and .FT file (Frame Table) to the Deko system. 

Clip Formats and QuickTime

Apple® QuickTime® now expands compatibility options for a wide range of clip formats to 
work with ClipDeko. 

n Apple QuickTime version 7 must be installed on your Avid Deko for the *.mov format to be 
accepted in Deko. The QuickTime Player is a free download from the Apple Web site. 

However, if the clip contains an alpha or key channel that you want to transfer, you must 
download Apple QuickTime Pro 7.

For more information, see www.apple.com/quicktime.

ClipDeko accepts the following clip formats:

• .avi

• .dv

• .dif

• .mxf

• .tmf

n HD clips must be created and rendered from the original file for the standard and frame rate 
in which it airs. 

ClipDeko also accepts .mov files, immediately converting them to a .mxf file with the 
settings selected under Conversion Settings. 

For more information on importing .MOV files into Deko, see “Importing .MOV Files into 
Deko” on page 453. 

The compression formats that Deko supports for .mov (.mxf) files are:

• DV25

• MPEG2 4:2:2

• MPEG2 4:2:0
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n If the advanced settings are set for a specific compression format, you must reset it to import 
at a new compression format. For instance, if you are set for MPEG 2 and need to import a 
dv format, you must reset the Advanced Settings to recognize the dv compression format.

Converting Clips Using QuickTime Pro

Any clip format that QuickTime Pro recognizes can now be converted to work in Deko.

To convert a clip using QuickTime Pro:

1. Launch QuickTime Pro 7.

2. Select File > Open File.

The Open A File dialog box opens.

3. Select the file you want to open, and click the Open button to open the file in 
QuickTime.

4. Select File > Export.

The “Save exported file as:” dialog box opens.

Options 
button



Importing Clips

451

5. Click the Options button.

The Movie Settings dialog box opens.

Settings 
button
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6. Click the Settings button in the Video section.

The Standard Video Compression Settings dialog box opens.

7. Use the following Video settings to export a compatible *.mov file for Deko:

- In the Compression Type field, select Animation.

- In the Depth field, select either Millions of Colors+ if the clip has an alpha or key 
channel, or Millions if the clip is a full screen clip with no alpha or key.

8. Click OK to accept the settings and close the dialog box.

9. Click OK to close the Movie Settings dialog box.

10. In the “Save exported file as:” dialog box, make sure the correct destination folder is 
selected in the Save In field (in your clips folder on the E drive).

11. Click Save.

12. Launch Deko in the video standard desired. 

13. Launch the Clip Editor and import the clip and key into the clip database as normal.

n If a key file is involved, import and link the key file as normal.
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Importing .MOV Files into Deko

Deko enables you to import .mov files. Before you import .mov files into Deko, you must 
download and install QuickTime on your Deko. 

If you are importing .mov files into Deko for the purpose of using them as Power Clips, see 
“Creating Power Clips in QuickTime Pro” on page 474.

To import .mov files into Deko:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Click on the Import button.

The Import Clip dialog box opens.

3. In the Files of type list, select “Import video clip (*.m2v, *.vbs, *.mov).”
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4. Navigate to the location where the .mov clip that you want to import is stored, and 
select it.

5. Click one of the following radio buttons depending on how you want to import the clip:

t Create new clip.

t Use as key in currently loaded clip.

n If the .mov file you are importing already has video and key, Deko automatically imports 
both and links them together in the database.

6. (Option) Do one of the following:

t Change your conversion settings before you import the selected clip, click on the 
Options tab, and then click on the .MXF Options button in the Conversion settings 
area, and go to the next step.

t Import the clip with the current conversion settings, go to Step 16.

7. The MXF File Compression Format dialog box opens.
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8. Select a compression format that you want the clip to be imported with. If you select:

t DV25, click OK, and go to Step 15.

t MPEG 4:2:2, or MPEG 4:2:0, the dialog reveals more editable fields. Go to the 
next step.

9. Select a bit rate in the Bitrate (MBits/sec) field.

10. Select a GOP size or keep the default of 1 in the GOPSize field. 

n In HD systems, the GOP size must be set to 1. In SD systems, you can change the GOP Size.

11. Select a PicRef in the PicRef field.

12. Select a mode in the Mode field. Options are:

- Variable

- Constant

13. Select a Source. Options are:

- Interlaced

- Progressive

14. Click OK.

15. Click Open. 

The clip appears in the Clip Browser in the Clip Edit window. 

16. Double-click the clip to play it.
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Using Static Mattes

Static Mattes allow you to associate a single .tga file to apply an alpha channel to a fill clip.

To associate a single .tga file:

1. Create your matte varieties (lower third, OTS left, OTS right, and so on.) and save them 
as .tga files with or without alpha channels. 

2. Select View > Clip Edit.

The Clip Edit window opens.

3. Load the fill clip by double-clicking the picon.

4. Click on the Link button in the Mask section. 

The Open dialog box opens:

5. Navigate to your .tga files.
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6. Click on the .tga for association to the fill file and click Open. 

The Mask icon displays in the upper right corner of your clip and the path to that file 
displays in the Clip Edit window.

7. Repeat this process for as many Masks as you need. 

Using ClipAutoUpdate

ClipAutoUpdate is designed to automatically add a clip to Deko's clip database. 
ClipAutoUpdate monitors a specified folder for video files in .avi, .dv, .mxf, .mov, and/or 
.tmf formats. When a file is copied to the monitored folder, ClipAutoUpdate automatically 
adds the clip to the Deko clip database using the filename's base as the database name.

For example, if a file named “MyClip.dv” is copied into the monitored folder, 
ClipAutoUpdate adds an entry into the Deko clip database named “MyClip”, which 
references MyClip.dv.

n Please note that since ClipAutoUpdate uses the base filename for the database entry, two 
clips with the same name cannot be inserted into the database (that is, “MyClip.dv” and 
“MyClip.tmf”).

Additionally, ClipAutoUpdate looks for matching key files based on the clip's base name. If 
the base name ends with “_key”, ClipAutoUpdate automatically assumes that the file is a 
key file for use with a clip matching the base name without the “_key” name.

Mask icon

Original full screen clip Same clip with link to matte_l3rd.tga
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For example, if a file named “MyClip_key.dv” is imported, ClipAutoUpdate assumes that 
this is a key file for use with a file named “MyClip.dv”. 

If “MyClip.dv” is:

• Already present in the Deko clip database, then “MyClip_key.dv” is set as the file's key. 

• Not present in the Deko clip database, then ClipAutoUpdate automatically associates 
the key file if “MyClip.dv” is later added.

For more information about ClipAutoUpdate, see “Configuring ClipAutoUpdate” on 
page 458.

Configuring ClipAutoUpdate

When configuring ClipAutoUpdate, you first need to launch Deko, and then set up folders to 
automatically monitor new or changed clips. Once these folders are set up, they 
automatically add any new or changed clips to the Clips database.

To configure ClipAutoUpdate to monitor folders and update the Clips database:

1. Locate the ClipAutoUpdate executable on your system. It is located in 
C:\Dekoxxx\Utilities\clipautoupdate.exe.

2. Double-click on clipautoupdate.exe to launch the application.

The Clip Watcher dialog box opens:

When minimized, the application resides in the task bar. To launch it, double-click on 
the ClipAutoUpdate icon
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3. In the Folder to monitor field, type in the path and folder name that you want 
ClipAutoUpdate to look for changes in. You can also click on the Browse button to the 
right of this field to navigate to the folder.

4. In the Database to update field, type in the path and folder name of the clip database 
used by Deko that you want ClipAutoUpdate to look for files to update when changes 
are made. You can also click on the Browse button to the right of this field to navigate to 
the folder.

5. In the File types to monitor section, select the file extensions that you want 
ClipAutoUpdate to watch for changes.

6. In the Default import parameters section, select any of the following import parameters 
that you want to set for this folder:

- Set all imported clips to 'Looping' - If selected, all imported clips are automatically 
set to loop.

- Set all imported clips to 'Sync with effect' - If selected, automatically turn on the 
'Sync with effect' option in the clip database.

- Automatically track changes to clip file names - If selected, if the file name of a clip 
changes, ClipAutoUpdate automatically changes the database name of the clip 
within the Deko database.

- Automatically remove deleted clips from database - If selected, this allows 
ClipAutoUpdate to remove files from the database when the associated clip 
is deleted.

7. Click the Close button to save your changes and close the Configuration window, or 
click on the Exit button to save your changes and exit the application. 

n ClipAutoUpdate does not update the database for existing files in the directory when it is 
launched.

8. Copy your files into the target directory after ClipAutoUpdate is configured.

Preparing to Play a Clip
When preparing to play a clip, it’s important to understand the following:

• When you play a clip, the clip plays in the Preview and Program Output (SDI) Monitors. 
Just select Options > Preferences > Common. Then, from the Preferences dialog box, 
select Display clip representative frame.

• For Standard Definition Deko products, the first time you play a clip, it is important to 
specify the genlock source. Genlock circuitry synchronizes the television signal source 
of two or more devices.



10  Importing Still Images and Clips

460

• You can preview a clip in the Clip Viewer, a box in the Clip Edit window.

• A clip can be trimmed in the Clip Edit window, to start after the beginning of the clip 
and stop before the trimmed end of the original clip. 

• Sometimes, it might be useful to play a clip from the beginning, but to loop only a 
portion of the clip. For example, a globe flies on screen from left to right, then spins 
around. You would like it to continue spinning on repeatedly without flying. This is 
called three point looping: the clip has a starting point, an ending point, and a point 
somewhere in the middle where the loop begins. 

• For Power Clips and CAP Shaders, you can click the Play at Action Start button in the 
Motion Timeline to start playing the clip at the beginning of the action, rather than the 
beginning of the motion.

The following topics provide more information about preparing to play a clip:

• “Specifying the Genlock Source” on page 460

• “Previewing a Clip” on page 461

• “Trimming the Beginning or Ending of a Clip” on page 461

• “Finding the Nearest Point in the Clip” on page 462

• “Looping Clip Playback” on page 462

• “Implementing Three Point Looping of a Clip” on page 462

• “Synchronizing Clip Playback with Effect Playback” on page 463

• “Adjusting the Volume of Embedded Audio” on page 463

Specifying the Genlock Source

To specify the genlock source:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Click the Settings button. 

The Settings dialog box opens.

3. Click the Playback tab.

4. Under Genlock Source, select Reference Input (signal present).
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Previewing a Clip

To preview a clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Select the clip you want to preview. 

Deko displays the clip in the Clip Viewer, a box in the lower left corner of the window.

n The name of the current clip file and the name of each of the files for the fill and for the key 
appear below the Clip Viewer. The format of the file displays next to the file name. If no clip 
is selected, the Clip Viewer is grayed out.

Trimming the Beginning or Ending of a Clip

To trim the beginning or ending of a clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. If you want the clip to start at some point after its beginning, do one of the following:

t Type a time in the In field. 

t Scrub to the desired In point and click the In button.

3. If you want the clip to stop at some point before its end, do one of the following:

t Type a time in the Out field. 

t Scrub to the desired Out point and click the In button.

Clip Viewer



10  Importing Still Images and Clips

462

4. Click one of the following buttons:

t Edit in to out - When Edit In to Out is selected, when an In point and/or an Out 
point is specified, Deko begins at the In point and ends at the Out point whenever 
you scrub through the clip.

t Edit full clip - If Edit full clip is selected, Deko plays the clip from beginning to 
end, ignoring the In and Out points, allowing you to scrub through the whole clip.

Finding the Nearest Point in the Clip

To find the nearest point (In, Out, Beginning, or End) in the clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Do one of the following:

t Use the double left arrows to jump to the nearest point backward in the clip (Out, In, 
or beginning).

t Use the double right arrows to jump to the nearest point forward in the clip (Out, In, 
or end).

Looping Clip Playback

Deko enables you to loop clip playback. When looping clip playback, you can set the entire 
clip to be looped or you can play the clip from beginning to end, then loop from a point 
within the clip to the end (three point looping.) For more information on three point looping, 
see “Implementing Three Point Looping of a Clip” on page 462.

To loop clip playback:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Load the clip.

3. Click the Loop button. When you play the clip, the clip plays from beginning to end, 
then repeats.

Implementing Three Point Looping of a Clip

Three point looping enables you to play the clip from beginning to end, then loop from a 
point within the clip to the end (three point looping.)

For example, you can have a clip showing an object flying on screen, then spinning in place. 
This three point looping allows the object to continue spinning.
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To implement three point looping of a clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Load the clip by double-clicking the picon.

3. Do one of the following:

t In the Loop section, type the time (in hours, minutes, seconds, frames) from the 
beginning of the clip where you want the loop to begin once the clip has played 
through to the end. 

t Use the scrub bar to scrub to the point in the clip where the loop should begin and 
click the Loop Start button.

The Loop start time displays below the Loop Start button.

4. Click the Loop button.

Synchronizing Clip Playback with Effect Playback

ClipDeko enables you to begin clip playback simultaneously with any effect played on a 
selected graphic.

To synchronize clip playback with effect playback:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Select Synch with effect. ClipDeko begins clip playback simultaneously with any effect 
played on a selected graphic. If the option is not selected, the clip starts to play as soon 
as the graphic is recalled.

n If a graphic is associated with a clip, Deko displays a bracketed remark in the title bar of the 
Graphic window, telling you the clip filename.

Adjusting the Volume of Embedded Audio

To adjust the volume of embedded audio:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Do one of the following:

t Use the Volume control slider to adjust volume from 0-100%.

t Type a number from 0 to 100 in the Volume text box.

t Click Mute to disable the Volume control.
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n Any newly recorded or imported clip that has embedded audio is unmuted and at 100% 
volume. If a clip does not have audio information, the Volume and Mute controls 
are disabled.

Playing a Clip

One of the most important features of ClipDeko is using the Clip Edit window to play a clip.

To play a clip:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Select a clip.

3. Prepare the clip for playback using any of the features described in the 
preceding section.

4. Do one of the following:

t Select Clip > Play.

t In the Clip Edit window, click the Play button under the thumbwheel.

Stopping Clip Playback
To stop clip playback:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Do one of the following:

t Select Clip > Stop.

t Click the Pause button under the thumbwheel.

t Clear the Program graphic.

The following topics provide more information about stopping clip playback:

• “Clearing or Hiding a Clip Loaded in the Clip Player” on page 465

• “Automatically Displaying Clips with Deko Graphics” on page 465
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Clearing or Hiding a Clip Loaded in the Clip Player

Deko enables you to clear a clip or hide any clip currently loaded in the Clip Player.

To clear a clip from the clip player:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Load a clip.

3. Do one of the following:

t Click the Clear button.

t Press Shift+Alt+C

To hide a clip, but keep it loaded in the clip player:

t Press Ctrl+Alt+C. 

Automatically Displaying Clips with Deko Graphics

There are two ways to automatically display a clip with a Deko graphic:

• For Background clips - the clip might be associated with the graphic. When you 
associate a clip with a graphic, Deko displays a bracketed remark in the title bar of the 
Graphic window, telling you the clip filename. ClipDeko plays the clip whenever you 
open the graphic in the Program window, swaps the graphic to the Program window, or 
plays an effect on the graphic. Both the clip and the graphic appear at their 
original scale.

• For clip layers - The clip might be incorporated into the graphic as the fill for a rectangle 
layer. The clip is automatically cropped to fit the layer.

The following topics provide more information about automatically displaying clips with 
Deko graphics:

• “Associating a Clip with a Graphic” on page 466

• “Breaking a Link Between a Clip and a Graphic” on page 466

• “Creating a Graphic with a Clip Filled Layer” on page 466
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Associating a Clip with a Graphic

To associate a clip with a graphic:

1. Open the graphic in a Program window.

2. Select View > Clip Edit.

The Clip Edit window opens.

3. Scroll through thumbnail images to find the clip that you want to associate with 
the graphic. 

4. Select the clip picon.

5. Do one of the following:

t Drag and drop the clip from the Clip Edit window onto the graphic.

t Click the Link button in the Clip Edit window, then select View > Program.

t Select the clip from the menu in the Style dialog box.

n You cannot load a clip into the Preview window (although a representative frame appears in 
the Preview window once a clip is embedded in a graphic.)

Breaking a Link Between a Clip and a Graphic

To break a link between a clip and a graphic:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Scroll through thumbnail images to find the clip that you want to unlink from 
the graphic. 

3. Select the clip picon.

4. Click the UnLink button. 

Creating a Graphic with a Clip Filled Layer

To create a graphic with a clip filled layer:

1. In a new or existing graphic, create a rectangle layer.

The Current Style is irrelevant because all details are obscured by the clip.

2. In the Style dialog box, click the Layer tab, and select the name of the clip in the Linked 
Clip menu. 

n If you do not see the Clip menu, click the More button at the bottom of the dialog box. Or, 
click the Select button to browse for the clip.
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3. To view the clip, select View > Clip Edit. The Clip Edit window opens.

4. Play the clip. For more information, see “Playing a Clip” on page 464.

Using Levels and Keys to Adjust Shaped or Unshaped Clips

Key and Level adjustments can be made to clips that are either created with Shaped or 
Unshaped (also known as Pre-multiplied or Straight) keys. This enables you to import clips 
of all varieties and play them back flawlessly.

Once a clip has been imported into the ClipDeko database, you can select the color-space 
and key method that the clip was created with, allowing Deko to interpret the clip correctly 
for playback.

To adjust shaped or unshaped clips:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Load your clip.

At the bottom right of the Clip editor, you’ll see a menu for Fill type and source. The 
choices available are grouped by key method.

3. Select from any of the gamma/alpha combinations to adjust the keying properties of the 
clip.
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Creating Clip Transitions

Clip Transitions can be applied to “background” and “layer” clips in a graphic. This feature 
lets you animate clips back to back using a default transition or custom Motion effect, 
instead of an abrupt cut of one clip to another during playout. There are three ways to handle 
clip transitions.

• Embed clip as a “background” element into a graphic and play back with a default 
transition.

• Embed clip as a “background” element into a graphic and apply a Motion.

• Add clip as a “layer” into a graphic and apply a Motion.

n Using a clip as a “layer” allows the clip to be re-sized and saved this way in the graphic. 
Using a clip as a “background” does not allow for scaling of the clip as part of the saved 
graphic, but it can be scaled with a Background Clip action in a Custom motion (with 
timeline option).

The following topics provide more information about creating clip transitions:

• “Creating and Playing “Background” Clips with Default Transition” on page 469

• “Creating and Playing “Background” Clips with Motion” on page 471

• “Creating Clip Layers” on page 472
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Creating and Playing “Background” Clips with Default Transition

To create and play “Background” clips with default transition:

1. Embed the clip to the graphic by doing one of the following:

t Drag the clip from the Clip Editor and drop it in the Graphic window.

t Click on the Graphic tab in the Style window, and then select the clip.

2. Once the clip is linked, save the graphic.

Your title bar displays the name of the embedded clip file. 
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3. Play back your graphics with confidence that your clip will transition during playback. 
Your embedded clip (if different on the transitioning graphic) dissolves on air. If the clip 
is identical in the transitioning graphic, no effect takes place and the clip continues 
playing.

n A default dissolve performs unless there is also an embedded effect on the graphic. In that 
case, the clip cuts to air. The default transition for all embedded background clips is a 
dissolve.

4. To modify the duration of this dissolve, select Options > Preferences > Advanced. 

The Preferences dialog box opens to the Advanced tab.
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5. In the Duration of clip dissolve text box, enter the desired clip dissolve duration 
in seconds.

6. Click OK.

7. Select Options > Save Settings.

Creating and Playing “Background” Clips with Motion

To create and play “Background” clips with motion:

1. Embed the clip to the graphic by doing one of the following:

t Drag the clip from the Clip Editor and drop it in the Graphic window.

t Click on the Graphic tab in the Style window, and then select the clip.

2. Once the clip is linked, save the graphic. 

Your title bar displays the name of the embedded clip file.

3. From the Motion editor, apply an effect to your background clip by adding a standard 
Action to the Motion.

4. From the Object menu, specify Background Clip (not Background).

5. Apply effects as desired. Parameters for your effect include X and Y Position, X and Y 
Scale and Opacity. 

n 3D effects (aka OGL effects) are not available on Background Clips.

Select Background Clip
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Creating Clip Layers

Clip layers, for the most part, are handled in the same way text or shape layers are handled. 
They playout to air based on the priority setting of the Clip Output View plane setting. Even 
though it is a Layer, if a clip is in the layer, that layer's priority is tied to the Clip tab priority. 
It could be in front of the other tabs or behind them. The layer can then be sized and 
positioned as desired. 

n One exception is that details such as shadows and edges cannot be applied to Clip Layers.

To create a Clip Layer:

1. Draw a rectangle layer in your graphic. 

2. Eliminate all details but the Face. 

n It is always recommended that you name your layers.

3. With the rectangle layer selected, in the Style dialog box (named Rectangle), select the 
Layer tab, and select Linked Clip from the menu.

4. Click the Select button.

All clips currently loaded in your Clips database appear.

5. Select the desired Clip. 

It displays with the respective key in your output. Your status bar indicates the Layer 
number/name and name of the linked clip.
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6. Continue building the remaining elements of your graphic. 

n Clip Layers can be ordered in any manner, but display based on the priority setting of the 
BGD Clip tab.

7. From the Motion editor, apply an effect to your Clip Layer by adding a standard Action 
to the Motion. 

8. Specify the Layer number and/or name and animate as you would a standard layer.

n Rotation and Origin controls are not available for Clip Layers. Parameters turn red to 
indicate this. The number of simultaneous clips supported varies depending on your Deko 
model. Refer to the Avid Deko Feature matrix in the Avid Knowledge Base: 
www.avid.com/onlinesupport.

Selecting a Frame (Frame Grab) from a Clip

Deko enables you to select a frame from any clip that is stored on the ClipDeko database and 
use it as a background in your graphic window. This process is called a “frame grab.”

To frame grab from a clip:

1. Load and play a Clip.

2. Select Channel > Frame Grab. The frame image displays as a background in your 
Graphic window.

Using Power Clips (Deko 3000 SD/HD/HY only)
The Power Clips feature is an enhancement to the existing ClipDeko option and provides the 
ability to play multiple smaller-sized clips such as “moving headshots” and other animating 
treatments such as traveling flares and highlights.
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Power Clips are a way to use clips in a more integrated manner. As technology improves, 
clips have become a more common tool in graphic creation. Any place where you would 
have previously used a static image (texture), you can now use a clip. 

Power Clips have their own database separate from the Standard clip database, making it 
possible for you to use identical clip names for either clip type. This allows automation 
systems to populate layers with the same data without regard to the clip context that was 
chosen by the graphic creator. 

The workflow involved in using Power Clips involves the following:

• “Creating Power Clips in QuickTime Pro” on page 474

• “Creating a Power Clips Database in Deko” on page 480

• “Importing .mov Files into Deko as Power Clips” on page 481

• “Creating Graphics Using Power Clips” on page 484

• “Power Clip Playback During Effects” on page 485

• “Composing for Power Clip Playback in Motion Edit” on page 486

Creating Power Clips in QuickTime Pro

Power clip creation can be accomplished on third-party clip software such as After Effects® 
or any application that can create a QuickTime movie or a series of image (.TGA, .BMP, 
.DIB, or .TIF) files. QuickTime movies should be uncompressed, with or without alpha, and 
sized appropriately for playback. QuickTime movies can be compressed only if the codec 
used to decompress them is installed on the Deko machine at the time the QuickTime file is 
imported into Deko.

n If you are using a third-party application that is capable of exporting to QuickTime, you can 
create “ready-to-import” movies. If not, you need to conform the QuickTime file to Power 
Clip specifications.

Before you can import the movie into Deko, you must use QuickTime Pro to export the .mov 
clip at the correct size for Deko. 

To create Power Clips in QuickTime Pro:

1. Start QuickTime Pro 7.

2. Select File > Open File. 

The Open a File dialog box opens.

3. Select the .mov file you want to use for your power clip, and click the Open button to 
open the file in QuickTime Player.

4. Select Window > Show Movie Properties.
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The Properties dialog box for the selected movie opens.

5. Highlight the Video Track row.



10  Importing Still Images and Clips

476

6. Click the Visual Settings tab.

7. Change the Current Size values to 320 x 356 or a similar size.

n The size of the clip impacts performance. Avid recommends that you keep the size of the clip 
as small as possible.

8. Click the close button close the dialog box.
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9. Select File > Export in the Apple QuickTime window. 

The Save exported file as dialog box opens.

10. Select Export > Movie to QuickTime Movie.

11. In the File name text box, type a new name for the movie.
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12. Click the Options button. 

The Movie Settings dialog box opens.

Settings 
button
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13. Click the Settings button in the Video area. 

The Standard Video Compression Settings dialog box opens.

14. Select the following options to export a compatible *.mov file for use in Deko as a 
Power Clip: 

t Select Compression Type > Animation.

t In the Compressor area, select Depth > Millions of Colors+ if the clip you are 
converting has an alpha or key channel, or Depth > Millions if the clip is a 
full-screen clip with no alpha or key.

15. Click OK to accept the settings and close the dialog box. 

16. Click OK again to close the Movie Settings dialog box.

17. In the Save exported file as dialog box, make sure the correct destination folder is 
selected in the Save In text box (in your “Clips” or “Power Clips” folder on the E: 
drive).

18. Click Save. 

The .mov file is converted to the new format and can now be imported into Deko. 
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For more information, see “Importing .mov Files into Deko as Power Clips” on 
page 481.

Creating a Power Clips Database in Deko

After Deko installation, a default Power Clips database exists called DekoPowerClips.mdb. 
However, you can also create additional PC databases for individual shows.

To create a Power Clips database in Deko:

1. Launch Deko in the desired video standard.

2. Launch the Clip Editor by selecting View > Clip Edit.

The Clip Edit window opens.

3. In the Context area, select Type > Power.

4. Click the Clips button.

The Open power clip database dialog box opens.
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5. Click the New database button. 

The new Power Clips database is created. 

6. Edit the name of the new database as desired.

Importing .mov Files into Deko as Power Clips

Once you have a .mov file that has been set up to the correct specifications to be imported as 
a Power Clip, you must import the .mov clip into Deko.

To import .mov files into Deko as Power Clips:

1. Launch Deko in the desired video standard.

2. Launch the Clip Editor by selecting View > Clip Edit.

The Clip Edit window opens.

3. In the Context area, select Type > Power.

4. Click the Import button to import the clip into the Clips database.
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The Import clip dialog box opens. 

n The Import Clip dialog box provides descriptive properties information when a .mov file is 
selected, or when the first file in a series of .TGA files is selected.

5. In the Files of type list, select Video clip (*.mxf, *.mov).

n QuickTime Pro or QuickTime player must be installed on Deko for the Files of Type list to 
display *.mov file types.

6. Navigate to the location where the .mov clip that you want to import as a Power Clip is 
stored, and select it.
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7. Select one of the following options depending on how you want to import the clip:

t Create new clip (default).

t Use as key in currently loaded clip.

Deko plays .mov files without conversion, including any key that is present in the file.

8. (Option) Select the Clips tab, and assign a new name for your Power Clip by typing the 
new name (such as MyPowerClip) for your clip in the Clip Name text box. 

n All clip database entries can be given an alias at the import step. Typically, you would want 
to assign a name based on the media file name.

9. (Option) Click the Options tab to adjust any miscellaneous settings. The user interface 
changes.

10. (Option) Adjust the Power Clip in/out, loop, and other pertinent playback parameters in 
the Clip Edit window. 

11. Click the Open button. 

The .mov file appears in the Clip Edit window.

Interlaced option
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12. After the clip is in the Clip editor, you can do any of the following:

t Edit the clip name.

t Assign a key file (where applicable).

t Designate as Interlaced.

t Set In, Out, and Loop.

t Scrub the clip in the Clip Viewer.

t Play the clip in the Clip Viewer.

t Switch between standard clips and Power Clips using the context menus.

c If the clip is in an Interlaced format, you must select the Interlaced option. The clip 
might play back at the wrong speed if you do not specify the Interlaced format.

The following controls are not supported for Power Clips: 

- Fill type and source

- Audio controls

- Mask controls

Creating Graphics Using Power Clips

Once you have imported the .mov files into Deko as Power Clips, you are ready to create 
your graphics using Power Clips.

To create graphics using Power Clips:

1. Open a graphic view.

2. Add a rectangle layer.

3. Associate the Power Clip with the face of a rectangle by doing one of the following:

t Drag the Power Clip from the Clip editor and drop it onto the Rectangle layer in the 
Graphic window.

t Select Face Shader > Clip. 

n You can also associate a Standard clip with the face of a rectangle by selecting View > Style 
> Layer or by dragging a Standard clip into the Rectangle layer.

For more information, see “Associating a Clip with a Graphic” on page 466.
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Additional controls are available in the Clip Shader window area to change scaling. 

4. Reposition or resize the rectangle as necessary by dragging it in the graphic view.

n A clip assigned to a Deko rectangle should use a look that has only a face detail. A rectangle 
with more than one detail results in static frame playback. 

5. (Option) If you are working with multiple Power Clips to appear on the screen at one 
time, repeat this procedure for each additional Power Clip you add.

Power Clip Playback During Effects

If you have followed the steps until now, you have imported a clip, associated it to a 
rectangle, and now are ready to see it play on the video output using the Motion Editor. 

n Power Clips play during motion playback only where the motion contains an action for 
the rectangle. 
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Composing for Power Clip Playback in Motion Edit

You can scrub a Power Clip on the video output along with other graphical elements using 
the Motion Editor. 

To compose for Power Clip Playback in Motion Edit:

1. Select View > Motion.

The Motion Edit window opens.

2. Add an action for the Rectangle layer containing the Power Clip.

3. Select Play-on as the Graphic type.

4. Scrub or play the motion to see the Power Clip, including other graphical elements, on a 
video output monitor. 

By default, the clip starts playing at the beginning of the action.

5. (Option) To start the clip at the beginning of the motion, deselect the Play Clip at Action 
Start button.

Play Clip at Action Start button
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6. When you have achieved the results you want, save the motion by selecting File > Save 
Motion.

n When you use a Power Clip in a motion, the system automatically inserts a pause at the end 
of the motion. If the clip is looping or is of a longer duration, it continues to play past the 
normal duration of the motion. If you want the motion to stop, you need to trigger it to stop.

Playing a Thunder Sequence from Deko
Using the Clip Edit window, you can play a Thunder sequence from your Deko. Before you 
can play a Thunder sequence from Deko, your Thunder and Deko must be configured 
correctly to communicate through the ThunderNet protocol with GPI triggers. This section 
covers how to configure both Thunder and Deko for ThunderNet Protocol and GPI Triggers.

n The following information is for Thunder version 5.2 or later.

The following topics provide more information about playing a Thunder sequence 
from Deko:

• “Configuring Thunder - ThunderNet Protocol” on page 487

• “Configuring Thunder - GPI Triggers” on page 488

• “Configuring Deko - ThunderNET Protocol” on page 490

• “Configuring Deko - GPI Triggers” on page 492

• “Playing a Thunder Sequence Directly from Deko” on page 493

Configuring Thunder - ThunderNet Protocol

To configure Thunder - ThunderNet protocol:

1. From Thunder, select File > Preferences > Protocol setup.

The Protocol Setup dialog box opens.

2. Select ThunderNET as the protocol for the channels you want to control.



10  Importing Still Images and Clips

488

3. Select Sequence Playback.

4. Select File > Preferences > Channel Configuration.

The Channel Configuration dialog box opens.

5. Select the ThunderNet protocol in the menu above the third column.

6. Click in the boxes in this column for each hardware channel you wish to control. 

n Software channels cannot be controlled.

7. Select File > Preferences > Channel assignments > Link channel assignments.

8. Close and restart Thunder for your changes to take effect.

Configuring Thunder - GPI Triggers

To configure Thunder – GPI Triggers:

1. From Thunder, select File > Preferences > Enable GPI triggers.
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2. Select File > Preferences > Assign GPIs. 

The Assign GPI Triggers dialog box opens.

3. Select Play Next Event as the action to be performed when a GPI trigger is encountered.

This causes the Thunder sequence to advance to and play the next event when your 
Deko sends a GPI trigger. Deko can only send one GPI trigger.

4. Open the sequence in Thunder that you want to be run from the Deko. This is done by:

- Clicking on the + next to the database in the Network Tree View (left pane), that the 
Deko is viewing to expand the contents.

- Double-clicking on any item named *.seq in the Network Tree View to open 
the sequence. 

n The database Deko is using was selected in the Protocol setup dialog box. 
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5. Click on the GPI button in the tool bar to make sure the sequence has the GPI turned on.

The Setup GPIs for Sequence dialog box opens.

6. Select the appropriate GPI.

Configuring Deko - ThunderNET Protocol

n You must be logged into the machine as user Administrator on the local machine. The 
version of the ThundNet.DLL file, usually found in the WinNT\System32 directory, must be 
the same version as the same file on the Thunder clip server.

To configure Deko - ThunderNet protocol:

1. From Deko, do one of the following:

t Select Options > Configure Clip Servers. 

t From the Clip Edit window, click the Configure button.
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The Clip Server dialog box opens.

2. In the Name text box, type the name you want to use to refer to this server.

3. In the Protocol menu, select ThunderNET Local.

4. In the ServerID box, enter any number not being used by any previously 
configured servers.

5. Click the Insert button to add the new server to the list.

6. Click OK to accept the changes and close the dialog box.
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7. Click Properties to configure the server. The Thunder Network Protocol Setup dialog 
box opens.

8. In the Video Type menu, select the video standard that Thunder is running.

9. In the Type section, click the Network COM radio button to select it.

10. In the Settings section, click in the Codec menu to select which hardware channel you 
want to control on Thunder.

11. Click on the ... button next to the Server edit box to browse for Thunder on the network.

12. Click on the Test button to verify that Deko and Thunder can communicate.

13. When the Test Status reports that the Thunder has been successfully initialized, 
click OK.

Configuring Deko - GPI Triggers

To configure Deko – GPI Triggers:

1. From Deko, select View > Sequence.

The Sequence window opens.

2. Click on the Sequence window to set focus to that window.



Playing a Thunder Sequence from Deko

493

3. Select Sequence > GPI settings. The GPI Trigger Settings dialog opens.

4. Select GPI Enabled.

5. In the Com port list, select which communications port you want to use to send the 
GPI triggers.

6. Click OK to save your changes and close the dialog box.

Playing a Thunder Sequence Directly from Deko

Deko enables you to play Thunder sequences directly from Deko’s Clip Edit window.

n Both the Thunder and the Deko must have correctly configured ThunderNet protocol and 
GPI triggers. If you have not done so already, see “Playing a Thunder Sequence from Deko” 
on page 487.

To play a Thunder sequence:

1. Select View > Clip Edit.

The Clip Edit window opens.

2. Click the Thunder button next to the Servers field. 

A list of files in your Thunder server displays. At the beginning of the list, you see the 
names of available Thunder sequences.

3. To load and begin playing a sequence, do one of the following:

t Double-click the sequence name or picon.

t Click to select a sequence, then click Load.

After each event in the sequence, playback stops. 

4. To resume playback, click Play in the Clip Edit window. For more information, see 
“Using the ClipDeko Option” on page 436.
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Associating a Thunder Clip with a Deko Graphic (for Use in a Deko)

You can associate a Thunder clip with a Deko graphic. Then, when you recall the graphic in 
a Deko sequence, Thunder plays the clip simultaneously with the graphic. The clip’s name is 
displayed in the graphic’s title bar.

n Thunder marks thumbnail images of clips with a small film clip in the upper right corner.

To associate a Thunder clip with a Deko graphic:

1. In Deko, open the graphic in a Program or Preview window. 

n The window must be active.

2. Drag and drop the clip from the Thunder browser.

n If a graphic is associated with a clip, Deko displays a bracketed remark in the title bar of the 
Graphic window, telling you the clip filename.

Thunder and Deko must have an active network connection to trigger the Thunder clip.
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Effects cause text and other graphics to appear, disappear, or move in a specified manner. A 
sequence is an organized playlist of graphics and associated effects. Sequences are 
commonly used for rundowns, weather pages, credits, or other situations requiring graphics 
and effects in the same order on multiple occasions. 

The following topics describe how to use effects and sequences: 

• Layouts for Working with Effects and Sequences

• Using Deko Effects

• Playing a Single Effect

• Creating Sequences

• Editing a Sequence

• Playing a Sequence

• Pausing Sequence Playback

• Stopping Sequence Playback

• Playing Sequences as Clips with Make DekoMovie

Layouts for Working with Effects and Sequences

There are two common layouts you use when you are working with effects and sequences. 
For more information, see:

• “Effect Playback Layout” on page 496

• “Sequence Playback Layout” on page 497

Both layouts include Program and Preview windows. For more information, see “Program 
and Preview Windows” on page 497.
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Effect Playback Layout

The Effect Playback layout enables you to play single effects on the current graphic, or 
associate an effect in a graphic file. This layout is useful if graphic playout is not in an 
orderly sequence. The Effects layout includes a Preview and Program window, and the 
Effect Playback window as shown in the following illustration, and described in “Program 
and Preview Windows” on page 497. 

Effect Playback Layout

• For information on playing single effects, see “Playing a Single Effect” on page 501.

Effect 
Playback 
window
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Sequence Playback Layout

The Sequence Playback layout is where you can build and play sequences that include many 
effects. The Sequence window includes a Preview and Program window and a Sequence 
Playback window as shown in the illustration.

Sequence Playback Layout

n With either the Effect Playback or Sequence Playback layout, if you are working in dual 
channel output mode, you might want to open an additional Program window. For more 
information on dual-channel output, see “Determining Output View Priority” on page 705.

Program and Preview Windows

The Effect Playback layout and the Sequence Playback layout include a Preview window 
and a Program window. Graphics can be created in the same manner in either window.

The Preview window shows a graphic that is not yet playing on-air. As an effect or sequence 
plays, the graphic in the Preview window is transferred to the Program window.

The Program window shows the current on-air graphic. The contents of this window match 
Deko's video output, and also includes a cursor, safe-title lines, and other markers. 

Sequence 
Playback 
window
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You can have the same graphic open in both the Preview and the Program windows, change 
text in the Preview graphic, then swap the two to change the on-air text. For more 
information, see “Switching Preview and Program Graphics” on page 498. 

You can also copy a graphic from the Preview window to the Program window and from the 
Program window to the Preview window. For more information, see “Copying a Graphic 
from Preview to Program” on page 498, and “Copying a Graphic from Program to Preview” 
on page 498.

n Deko allows viewing up to two Program windows and one Preview window.

Switching Preview and Program Graphics

To switch the Preview and Program graphics:

t Do one of the following:

- Select Channel > Swap. 

- Press F3 (SK).

- Press Swap (FAK).

Copying a Graphic from Preview to Program

To copy a graphic from Preview to Program:

t Select Channel > Preview to Program (Ctrl+F3).

Copying a Graphic from Program to Preview

To copy a graphic from Program to Preview:

t Select Channel > Program to Preview.

Using Deko Effects

You can play graphic files individually or in series, using a variety of predesigned motions 
called effects. The following topics provide more information about Deko effects:

• “Transitional Effects” on page 499

• “DVE Effects” on page 499

• “Control Effects” on page 500

• “Text Effects” on page 500

• “Motion Effects” on page 501



Using Deko Effects

499

Transitional Effects

A Transitional effect replaces the on-air (Program) graphic with another (Preview) graphic. 
The following are some transitional effects:

• Altpush - Pushes the Preview graphic’s rows on screen alternately from the left or right.

• Climb - Each row of the Preview graphic rolls on screen from the bottom of the row.

• Crawlpg - All layers (including shapes) crawl as one to the left or right.

• Cut - The Preview graphic replaces the Program graphic.

• Dip - The graphic fades to black. It remains black for the specified number of frames, 
then the new graphic fades in. 

n The Dip effect is not available on all models. 

• Dissolve - The Program graphic fades out as the Preview graphic fades in.

DVE Effects

The following DVE effects are available:

• Folds - A user-specified number of sections peels off from the center of the object, or 
peels on from the outer edges of the object.

• Page Turn - Peels the entire object on or off.

• Ripple - Creates a water ripple effect on the object as it fades in (on) or out (off).

• Shards - Sections of the object move outward from the center of the object’s bounding 
box and apart (off), or inward, convening at the center of the bounding box (on).

• Tiles - An array of rectangular “tiles” of the object randomly fall off a “wall” (off), or 
the tiles randomly rearrange themselves to form the object (on).

• Page Scroll (DVE Group 2) - The object “rolls up” (off) or unrolls (on).

• Cylinder (DVE Group 2) - The object rolls into a cylindrical shape and rolls off or 
unrolls from a cylinder and rolls on.

• Magic Carpet (DVE Group 2) - The object undulates from a specified fixed point as it 
fades off or on. Deko controls opacity to enhance this effect unless you specify opacity 
separately.



11  Using Effects and Sequences

500

• Accordion (DVE Group 2) - Forms pleats on the object, which fold and unfold from a 
specified fold axis as the object fades off or on. Deko controls opacity to enhance this 
effect unless you specify opacity separately.

• 3D Ripple (DVE Group 2)  - Creates a 3D water ripple effect on the object as it fades off 
or on. Deko controls opacity to enhance this effect unless you specify opacity 
separately.

n Available only with the DVE Effects Group 2 option, the following effects can be used just as 
any other effect. To see if this option is enabled on your system, select Options > Enabled 
Options.

• Push up/down/left/right - The Preview graphic pushes the Program graphic offscreen.

• Repeat thru (available only in the Sequence Edit window, not the Effect window) - 
Repeats the previous effect on each subsequent file up to the specified file.

• Slide up/down/left/right - The Preview graphic slides on top of the Program graphic.

• Slideoff up/down/left/right- The Program graphic slides off to reveal the Preview 
graphic.

• Wipe up/down/left/right - The Program graphic is wiped off in place, revealing the 
Preview graphic.

n Reveals are available with limitations on some models. 

Control Effects

The following Control effects are available:

• Clear - Clears the layers, background, or the entire Program graphic.

• Command - The macro specified in the File Name column plays during sequence 
playback.

Text Effects

Text effects operate primarily on text fields. The following Text effects are available:

• Roll - Text scrolls continuously up the Program graphic, bottom to top.

• Crawl - Text moves continuously across the Program graphic, right to left.

• Reveal -Text is typed onto the Program graphic, one character, word, or row at a time.



Playing a Single Effect

501

Motion Effects

In addition to using Deko’s predesigned effects, you can create a motion script to customize 
effects. Customized effects are called motions, are created in the Motion Edit window, and 
are saved as .mot files. The .mot file does not need to be based on a specific graphic, 
although it might be created with a specific graphic in mind. You can specify .mot files 
within a sequence, just as you would any other effect. 

You can also associate a motion with a specific graphic, so the motion plays automatically 
when the graphic is opened. For more information, see “Creating Custom Motions” on page 
521.

n This feature is not available on all models.

Playing a Single Effect

Use the Effect layout to open a graphic, select a single effect, and play that effect to cause 
your graphic, or an individual layer, to move. Bringing graphics to air with single-effect 
playback is useful in unpredictable situations where the graphic you need to play can change 
at a moment’s notice. For fastest recall of a graphic with an effect, you can associate the 
effect with the graphic, so it plays automatically when the graphic is opened. 

n With Deko1000 and Deko550, when you use a keyhole layer in an effect or a motion, the 
layer does not cut a keyhole. The layer renders as if Keyhole was not specified, but does 
perform the specified effect or motion.

The following topics provide more information about playing a single effect:

• “Opening the Effect Layout” on page 501

• “Playing a Single Effect on the Current Graphic” on page 502

• “Associating an Effect with a Graphic” on page 503

• “Making Sure Associated Effects Play Automatically” on page 503

• “Playing an Associated Effect without Reloading the Graphic” on page 504

Opening the Effect Layout

To open the Effect layout:

t Do one of the following:

- Select Windows > Select Layout > Effect Playback.

- Select View > Effect Playback (Shift+F11).
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The Effect Playback window opens.

Playing a Single Effect on the Current Graphic

To play a single effect on the current graphic:

1. Click the Effect Playback window.

2. From the Channel menu, select the channel for playback output.

3. From the Effect menu, select the Deko effect to be played on the current graphic.

4. From the Layers menu, select the graphic element, (such as, layers, background, row, 
and so on) on which you want to perform the effect. Options depend on the specified 
effect. 

n Don’t select anything from the Layers menu to apply the effect on the entire graphic.

5. In the Rate text box, type the numerical value for the rate at which you want Deko to 
perform the selected effect, as expressed in the type of unit displayed in the Units menu. 

n Deko displays a default rate and type of units appropriate for the selected effect; you can’t 
change the defaults.

6. From the Units menu, select the unit of measurement for rate. Choices include the 
following:

- Lines per frame

- Frames

- Pages per second

- Seconds

7. Select the Hold option if you want Deko to load the graphic and wait for a trigger to play 
the effect.
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8. If you want to save the effect as a .efx file, do the following: 

a. Select File > Save Effect As. 

The Save Effect As dialog box opens.

b. Navigate to the location where you want to save your effect (.efx) file, type a 
filename, and click Save.

The effect is saved in the location you specified with the name you entered.

9. Click the Play button in the Effect Playback window to play the effect.

Associating an Effect with a Graphic

Deko enables you to associate an effect with a graphic and automatically play the effect 
when the graphic is opened.

To associate an effect with a graphic (automatically playing the effect when the 
graphic is opened):

1. Open a graphic in the Preview window.

2. Select View > Style (F6).

3. In the Style window, click the Graphic button.

4. In the Linked Efx/Motion area, click the Select button and navigate to the effect (.efx) 
file or the motion (.mot) file.

5. Save the graphic. 

The Preview window title bar displays a bracketed remark next to the file name, telling 
you which effect is linked with the graphic.

6. Open the graphic in the Preview window.

If you selected the “Automatically play associated effects” option, Deko automatically 
plays the associated effect. For more information, see “Making Sure Associated Effects 
Play Automatically” on page 503.

If Deko cannot find the linked effect or motion file in the designated directory search 
path, it prompts you to browse for the file.

n For other ways to associate motions with graphics, see “Using Auto-Motions” on page 584.

Making Sure Associated Effects Play Automatically

To make sure associated effects play automatically:

1. Select Options > Preferences.

2. Click the Common tab.
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3. Make sure the “Automatically play associated effects” option is selected.

4. Click OK.

Playing an Associated Effect without Reloading the Graphic

To play an associated effect without reloading the graphic:

1. With the graphic already open in the Preview window, click the Preview window. 

2. Do one of the following:

t On the command bar, type play_associated_effect. Then click the Play button 
on the command bar to play the effect.

t Press Control + Play (FAK).

Creating Sequences

You can organize multiple graphic files and effects into a sequence for immediate or future 
playback. This is sometimes called creating a playlist. Create a sequence, or playlist, 
whenever you want to use graphics in a predictable order. A playlist is especially useful for 
any regular program that typically uses the same graphics in the same order. Sequences can 
be saved as .seq files.

The following topics provide more information about creating sequences:

• “Opening a Sequence” on page 504

• “Creating a Sequence” on page 505

• “Adding a Sequence” on page 507

• “Saving a Sequence” on page 507

• “Appending a Sequence to the Active Sequence” on page 508

• “Controlling Sequences Using Timecode Control” on page 508

• “Using Rolls and Crawls in Your Sequence” on page 511

• “Using Command Event to Include Macros in Your Sequence” on page 511

Opening a Sequence

To open a Sequence window:

t Do one of the following:

- Select Windows > Select Layout > Sequence Playback.

- Select View > Sequence (F11).
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The Sequence window opens.

Creating a Sequence

To create a sequence:

1. Activate the Sequence window.

2. Click Sequence > Clear Sequence, if necessary, to clear all events.

3. Use the Tab or Arrow keys to move to each text box, and enter the following information 
for each event in the sequence:

Sequence 
Window Option Description 

File Name The name of the graphic file on which to perform the effect. Press 
Ctrl+L or click the Browse button to select the file from the Graphic 
Browser window.

Effect Select the effect you want from the menu. For descriptions of effects, 
see “Using Deko Effects” on page 498.

Layers The graphic element, for example, layers, background, row, and so on, 
on which to perform the effect. Options depend on the specified effect. 
Don’t select anything from the menu to apply the effect on the entire 
graphic.

Rate Numerical value of the rate at which Deko performs the effect. The 
type of units for measuring rate is entered in the Units text box.

Units Controls the unit of measurement for the selected rate. Select from the 
menu.
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Control/time Controls the timing of the event:

• (blank) - Starts as soon as the previous event is done.

• pause - Waits for a GPI trigger, right mouse click, or a Pause 
Sequence (Pause) or Play Sequence (Alt+Enter on the SK, Play on 
the FAK) command before playing.

• hold - Displays the first frame of the effect, then waits for a trigger 
before continuing.

• delay - Pauses “Time” fields before playing. Delay is expressed in 
fields. There are two fields per frame, thirty frames per second, and 
therefore sixty fields per second.

• stop - Stops the sequence, returning control to the user. To resume 
playback, select Play Sequence (Alt+Enter).

• tcode - Starts event playback based on input and output times, 
using a timecode reader. If Deko does not detect a connected 
timecode reader, it triggers tcode events based on the system clock. 
For more information, see .

• skip - Skips to the next event. This is useful for inserting a 
comment.

• loop - Repeats subsequent events “Time”  number of times, until an 
“end” is encountered. Loops can be nested.

• end - Ends the current loop.

• go to - Skips to event number in “Time” field. If the Time field is 
blank, Go to skips to the beginning of the sequence.

In Time/Out Time Uses a timecode value to begin an effect. If no timecode is detected by 
the system, the computer system clock is read. For more information, 
see “Controlling Sequences Using Timecode Control” on page 508.

Sequence 
Window Option Description (Continued)
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Adding a Sequence

Once you have created a sequence, you can browse through your graphic files to add to 
a sequence.

To add to a sequence:

1. Click in the Sequence window (F11).

2. Do one of the following:

t Select Sequence > Browse for Files (Ctrl+L).

t Select View > Browser (Ctrl+L).

3. Double-click a thumbnail to enter it into the sequence.

To automatically advance to the next event while browsing for graphics to put into a 
sequence:

1. Click the Sequence window (F11).

2. Select Sequence > Auto Advance From Browser.

n If the next event is empty, Deko duplicates the last event. You might want to set up a default 
event before adding files from the browser. 

Saving a Sequence

To save a sequence:

1. Click the Sequence window.

2. Select File > Save Sequence As (F12). 

The Save Sequence As dialog box opens.

3. Navigate to the drive and directory where you want to store the file.

4. Type a file name in the File Name text box, and then click Save.

n When you save a sequence, Deko automatically attaches “.seq” to the file name. Do not type 
a different extension.
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Appending a Sequence to the Active Sequence

Deko enables you to append an additional sequence to the Active sequence.

To append a sequence to the active sequence:

1. Activate the Sequence window in which you want to insert the second sequence.

2. Select File > Append to Sequence.

The Append Sequence dialog box opens.

3. Navigate to the drive and directory that contain the sequence (.seq) file you want to 
append.

4. Select the file from the File Name list or type it in the File Name text box, and then 
click Save.

Controlling Sequences Using Timecode Control

An additional sequence feature, timecode control, is available with the Automation option. 

n To see if the Automation option is enabled on your Deko, Click Options > Enabled Options.

Timecode control allows you to control sequences via SMPTE timecode. SMPTE timecode 
is an internal counter analogous to one you might see on a tape deck, only more precise. 
With this level of precision, you have the control you need, for example, to add subtitles to 
English tapes.

If your Deko is not connected to a timecode reader, Deko by default allows you to trigger 
sequence events using your system clock.

The following topics provide more information about controlling sequences using timecode 
control:

• “Specifying Timecodes to Begin and End an Effect” on page 509

• “Setting Intime to Outtime” on page 509

• “Setting Outtime to Intime” on page 509

• “Offsetting In and Out Times” on page 510

• “Finding the Event Closest to the Current Output Timecode” on page 510

• “Specifying Timecode Settings” on page 510
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Specifying Timecodes to Begin and End an Effect

To specify timecodes to begin and end an effect:

1. Open the sequence file.

2. In the Control menu, select tcode.

3. In the In Time text box, do one of the following:

t Press Alt+Shift+I to enter the current input timecode.

t Type a timecode.

4. (Option) Set an Out time. An out time causes the graphic to disappear until the next in 
time. To set an out time, in the Out Time column do one of the following:

t Press Alt+Shift+O to enter the current output timecode.

t Type a timecode.

Setting Intime to Outtime

To set intime to outtime: 

1. Open the Sequence file.

2. In the Sequence window, select the event.

3. Select Timecode > Set Intime to Outtime.

Setting Outtime to Intime

To set outtime to intime:

1. Open the Sequence file.

2. In the Sequence window, select the event.

3. Select Timecode > Set Outtime to Intime.
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Offsetting In and Out Times

To offset In or Out times:

1. Open the sequence file.

2. Select Timecode > Add Offset to In/Out Times.

The Add Offset to Effect In/Out Times dialog box opens.

3. Enter the amount of time to add or subtract.

4. Click the appropriate button (Add or Subtract) to add or subtract the offset time.

5. Click OK or press Enter.

Finding the Event Closest to the Current Output Timecode

To find the event closest to the current output timecode:

1. Open the Sequence file.

2. Select Timecode > Find Event Closest to Timecode.

Specifying Timecode Settings

To specify timecode settings:

1. Select Timecode > Timecode Settings.

A dialog box opens.

2. Change Com Port and Drop Frame Mode settings as desired.

3. Click OK or press Enter.
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Using Rolls and Crawls in Your Sequence

Rolls and crawls are frequently used motion effects. For more information, see “Creating 
Rolls and Crawls” on page 608.

n Some types of rolls and crawls are not available on all models.

Using Command Event to Include Macros in Your Sequence

An additional sequence feature, command event, is available with the Automation option. 

n To see if the Automation option is enabled on your Deko, select Options > Enabled Options.

Command event allows you to include a single command or a macro in your sequence. A 
macro is a series of commands instructing your Deko to perform certain tasks. For more 
information, see “Streamlining Your Work with Macros” on page 713.

To include a command or macro in your sequence with the command event feature:

1. In the File Name column of the Sequence window, type the command or macro you 
want to play. If you’re not sure of the command, click the Browse button to navigate to 
the location of the file, and select it.

2. Select Effect > Command.

Editing a Sequence

When editing a sequence, you must first select one or more events that you want to add to or 
delete from the sequence.

The following topics provide more information about editing a sequence:

• “Selecting Events” on page 512

• “Cutting, Copying, and Pasting Events” on page 513

• “Inserting and Deleting Events” on page 513
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Selecting Events

To edit an event, the event must be selected.

To select a single event:

t Do one of the following:

- Double-click the event number.

- Use the Arrow keys to position the cursor on the event, and then press Shift and the 
Down Arrow key.

To select multiple events:

t Do one of the following:

- Drag the mouse across the event numbers.

- Use arrow keys to position the cursor on the first or last event you want to select, 
then press Shift and the Up Arrow key or the Down Arrow key to highlight the 
events.

To select all events from the current event to the first event:

t Do one of the following:

- Press Shift+Home.

- Press Ctrl+Shift+Home.

n This choice depends on how you have Home and End key behavior set in Options > 
Preferences > Cursor.

To select all events from the current event to the last event:

t Do one of the following:

- Press Shift+End.

- Press Ctrl+Shift+End.

n This choice depends on how you have Home and End key behavior set in Options > 
Preferences > Cursor.



Editing a Sequence

513

Cutting, Copying, and Pasting Events

To cut or copy an event or group of events:

1. Select an event or group of events.

2. Do one of the following:

t To cut events, select Edit > Cut Events (Ctrl+X), or click the Cut button on the text 
bar.

t To copy events, select Edit > Copy Events (Ctrl+C), or click the Copy button on the 
text bar.

To paste events into a sequence:

1. Position the cursor at the event where you want to insert cut or copied events. Pasting 
replaces the existing event at that position.

2. Do one of the following:

t Select Edit > Paste Events.

t Press Ctrl+V.

t Click the Paste button on the text bar.

Inserting and Deleting Events

To insert a blank event above the selected event:

t Select Sequence > Insert Event (Alt+Insert).

To delete the selected event:

t Select Sequence > Delete Event (Alt+Delete).

To delete a group of events:

1. Select the group of events to be deleted. For more information, see “Selecting Events” 
on page 512.

2. Press Delete.
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Playing a Sequence

When playing a sequence, you first need to specify the starting (current) event. Once, you 
have done that, you can play the sequence, pause the sequence, use GPI triggers, and stop 
the sequence.

To specify the starting (current) event:

1. Click the Sequence window.

2. Create a sequence or open a .seq file.

n Deko always begins playing a sequence with the current event. 

3. Specify the current event by doing one of the following:

t Press the Up Arrow or Down Arrow to move the cursor to an event. 

t Use the Home or End key to move to the first or last event. 

t Move to a specific event by holding down Alt and typing the number using the 
numbers above the alphabetic keys.

To play a sequence:

1. Activate the Sequence window.

2. Create a sequence or open a .seq file.

3. If you do not want to start playback with the first event, specify the starting event as 
described above. 

4. Do one of the following:

t Click the Play button in the Sequence window.

t Select Sequence > Play Sequence.

t Press Alt+Enter (SK).

t Press Play (FAK).

In the Sequence window, the Play button lights up and turns green to indicate that 
sequence playback is in progress.

n Undo is disabled during motion edit, motion playback, and sequence playback. When you 
play a motion or a sequence, Deko resets the Undo buffer so that no previous actions can 
be undone.
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Pausing Sequence Playback

Once a sequence is playing, you can pause sequence playback at any time. Once paused, you 
can then resume sequence playback.

To pause sequence playback:

t Do one of the following:

- Click the Pause button in the Sequence window.

- Select Sequence > Pause Sequence (Pause).

- Press Pause (FAK).

The play button light goes off and the pause button lights up and turns yellow to indicate 
that a sequence has been paused. The Motion pauses, but the graphic remains visible.

To specify a pause in a sequence:

t Do one of the following:

- Select Control > pause. During playback, Deko reads the next file into the Preview 
window, then pauses the sequence and displays the message “Sequence paused. 
Press Alt+Enter to continue.”

- Select Control > hold. Deko displays the first frame of the effect, then waits for a 
trigger.

To resume a paused sequence:

t Do one of the following:

- Right-click the mouse.

- Click the pause button in the Sequence window.

- Select Sequence > Pause Sequence (Pause).

- Select Sequence > Play Sequence.

- Press Alt+Enter (SK).

- Click the Play button in the Sequence window.

- Use a GPI trigger. For more information, see “Using a GPI Trigger” on page 516.

The Pause button light goes off and the Play button lights up and turns green.

For more information about pausing sequence playback, see “Using a GPI Trigger” on 
page 516.
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Using a GPI Trigger

A GPI (General Purpose Interface) trigger is a device that can be physically connected to 
your Deko. The device can then be selected to send certain commands to the Deko.  

To connect a GPI trigger:

1. Connect the triggering device to an available COM port, if it is not already connected. 

2. Restart Deko.

To enable GPI triggering:

1. Click the Sequence window (F11).

2. Select Sequence > GPI Settings.

The GPI Trigger Settings dialog box opens.

3. Select GPI Enabled.

4. Select the COM port where your GPI trigger is connected (such as, COM2).

5. Click OK.
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Stopping Sequence Playback
To stop sequence playback:

t Do one of the following:

- Press Esc.

- Click the Stop button in the Sequence window.

- Select Sequence > Stop Sequence Playback. 

- Press Ctrl+Pause (SK).

- Press Stop (FAK).

Playing Sequences as Clips with Make DekoMovie

The Make DekoMovie option enables you to render unique Deko effects to an extended list 
of video formats or series of TARGA files (TGAs) for:

• Uploading.

• Transferring to an NLE.

• Playing back.

• Sharing with other Deko systems. 

If the effect you are rendering has an associated clip, it renders the associated clip with key 
also.

To play back sequences as clips with the Make DekoMovie option:

1. Go to the Sequence layout (F11).  

2. In the Sequence window, insert your effects and graphics, and the effect duration that 
you want to be rendered to a video file or TARGA series. For more information, see 
“Editing a Sequence” on page 511.

n You can render multiple events of a Sequence. Be sure to place events in the desired order.
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3. With focus on the Sequence window, select Sequence > Make DekoMovie from 
Sequence. 

The Make DekoMovie dialog box opens.

4. In the Folder text box, either type the path to the folder where you want to save the file, 
or use the Browse button to navigate to the folder.

5. Type a name in the Base file name text box, or use the Browse button to navigate to a file 
name that you want to overwrite.
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6. Select the format in which you want to save the file as. Options include:

- AVI

- DV

- MOV

- MXF

- BMP

- DIB

- TGA

- TIF

n The Fill file name text box and the Key file name text box appear with default names if there 
are associated fill or key files. For TARGA files (TGAs), if you want to create a cell 
animation (a series of individual graphic files that hold video and key) that is designed to be 
animated as a series of files, adjust the resolution. Typical settings for creating a series of 
TGA files for replay in Deko are to use a resolution of 160 x 120 (to maintain 4:3 ratio), and 
select Interleave fields, Reverse fields, Shape fill data, and Render for looped playback.

7. If you want each file to contain two interleaved fields, select the Interleave fields. 
Otherwise, each file contains a full frame.

8. If you selected Interleave fields, and you want to control the order of the two fields in 
the frame, select Reverse fields.

9. Do one of the following:

t If you selected Interleave fields, and want to use the TGA files in a “looped” 
fashion, select Render for looped playback.

n Both the first and last frames contain motion between the fields, so that the clip plays 
properly when looped.

t If you do not want to use the TGA files in a looped fashion, deselect Render for 
looped playback.

The first and last frames do not contain motion between the fields, so that there is no 
interlace flicker at the start or end of the clip. Deselect this option causes the duration of 
the clip to be two frames longer than the duration of the effect.

10. If you do not want this clip to generate a key frame, select Do not generate key.

11. If you want to shape fill data, select Shape fill data.

12. If you want to render the audio data, select Render audio data.
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13. To change the resolution of the TARGA files produced, type the new resolutions in the 
Horizontal resolution text box and the Vertical resolution text box, as desired. The 
following should be considered with regards to setting the horizontal and vertical 
resolutions.

- Make DekoMovie renders the full screen source file to normal resolution. For 
rendering a series of .tga files to replay as a Deko CEL, the resolution size needs to 
be set to meet the CEL standards. For more information, see “Using the CAP 
Shader Option” on page 129. When resolution is lowered, the full screen image 
renders smaller. 

- You cannot define an area of the screen to render. Keep this in mind when designing 
your source files, you might want to design them larger and in the center of the 
screen.

- As the resolution decreases, the sharpness of the image decreases. When creating 
TGA files with Make DekoMovie, the files are created with square-shaped pixels. 
To insure the image maintains the correct aspect ratio, set the h resolution and v 
resolution with a 4:3 relationship, that is, 640 x 480, 320 x 240, 160 x 120, 80 x 60 
and import into the Deko CAP layer setting the pixel aspect shape to square. For 
information on creating a CAP layer, see “Applying Color, Ramp, Texture, CAP, or 
Keyhole to a Style Detail” on page 106. For information on playing a CAP, see 
“Playing a Cel Animation” on page 134.

14. Click OK.

The file is rendered in the format you selected. You can now go to the folder where you 
saved the DekoMovie file and open it.
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In addition to using Deko's pre designed effects, you can customize your own motions. 
Typically, motions are created for a specific graphic. However, motions do not have to be 
used with specific graphics. Once you have created a motion script and saved it in a motion 
file, you can specify the file within a sequence to play on any graphic, just as you would any 
other effect.

n Motions are not available on all Deko models. Some models offer motions with certain 
limitations.

The following topics describe how to create custom motions:

• Tools for Creating Motions

• Using the Motion Timeline Editor to Create Motions

• Using the Basic Timeline Editor to Create Basic Motions

• Using Motion Behaviors

• Playing Motions

• Creating 3D Animated Objects Using Depth Rotation

• Making a Zoom Motion

• Using Auto-Motions

• Using Motion-in-Motion

• Assigning Content-Independent Sound Effects to Deko Motions

Tools for Creating Motions

Motions are created with the Deko Motion Edit window. The Motion Edit window is 
included in the Motion Compose layout. A series of one or more actions in the Motion Edit 
window is called a motion script. The motion script is saved in a motion (.mot) file. 
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To open the Motion Compose layout:

t Do one of the following:

- Press Shift+Ctrl+M.

- Select Window > Select Layout > Motion Compose. 

A Preview window, a Program window, and a Timeline Motion window open.

To activate a Motion window with any layout:

t Select View > Motion.

For more information about tools for creating motions, see “Using the Motion Edit 
Window” on page 523.
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Using the Motion Edit Window

Creating motions is a multi-step process involving all of the areas in the Motion Edit 
window. When creating motions, you typically complete the areas in left-to-right order for 
each action in the Motion.

The following procedure is an overview of how the Motion Edit window is used. For specific 
instructions, see “Using the Motion Timeline Editor to Create Motions” on page 525.

To create motions:

1. Actions are listed and named in the Action list area. You add an item to this list for each 
action you intend to define. You can rename actions in the list. For each action listed, 
you assign the following:

- An effect

- The object that you want the effect to move or change

- Certain parameters for that effect

The effect, object, and parameters are specified in the other areas.

n With Deko1000 and Deko550, when you use a keyhole layer in an effect or a motion, the 
layer does not cut a keyhole. The layer renders as if Keyhole was not specified, but does 
perform the specified effect or motion.

Action List Effect/Object List Parameters Timeline graph Motion Timing bars
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In the Effect/Object area, an effect and an object for the effect to act is assigned to the 
action. An Object is specified for every Action in the Action list. Your Actions play in 
either the Preview or Program window. 

2. Select Play-on or Play-off from the Graphic menu. Objects can be as follows:

- The entire graphic

- The background

- All layers together

- An individual layer or layers

- Rows

- Words

- Individual characters

3. Select Object is Parent to indicate that all subsequent actions will be children of the 
above action. 

4. Select a Layer number to indicate location of the specified Object.

5. Select Force Play if the Action is to definitely play, even if there is no change to the data.

n For more information on Force Play and Play as Group, see “Using Differential Motions” 
on page 581.

6. Select 2D Effects or 3D Effects. Your chosen effect performs based on your definition of 
an Object. DVE effects include Page Turns, Ripples and other editable 3D effects. To 
edit and optionally save parameters of an Effect, click the Edit button.

Parameters including object position, size, opacity, and rotation are assigned in the 
Parameters area. 

n DVE Effects are not available if “Object is Parent” is selected.

n Deko3D is explained in “Using the Deko3D Feature” on page 622

7. To enable a parameter, select it. 

The more Parameters you specify, the more complex the movement. The Position 
Selector displays a list of position choices and is used only with the Position Parameter. 
Position choices and view of the Graph depend upon the Parameter currently selected. 

8. Edit your Parameters by degree of position, scale, rotation, kern, skew and opacity.

With the Timeline option enabled, the Motion Editor provides a Timeline graph to 
display the selected motion parameter as y and the time (or duration), for the motion 
as x. Units of measurement of motion or time change to suit selected motion parameters. 
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9. Click the Scrub Handle and drag it across the Timeline Graph to preview the entire 
Motion in your video output. 

10. Adjust timing (duration, start and end relative to other actions) with the Timing bars. For 
every Action in the Action List, a corresponding Timing bar appears. Grab handles at 
either end to adjust In or Out Timing of Actions.

In the Effect/Object area, if you define an Object as a character, word, or row, a Sub-bar 
appears and is tied to the Timing Bar above it for that Action. 

11. Click the round Offset control and drag it to adjust Timing delay. Offset control is only 
valid for certain graphic objects, such as row, word or letter.

Using the Motion Timeline Editor to Create 
Motions

If available on your Deko model, the Motion Timeline Editor provides more flexibility and 
features when creating motions.

If you do not have the Motion Timeline editor on your model, you can still create basic 
motions with the Basic Timeline Editor. For more information, see “Using the Basic 
Timeline Editor to Create Basic Motions” on page 529.

Building a Motion Script

n This feature is not available on all models. Some models have this feature with certain 
limitations.

c This process clears the Motion window. If you have been working in the Motion 
window, be sure to save your work in a .mot file before proceeding.

To define actions in a motion script:

1. Activate the Motion window.

2. Select Motion > Clear Motion.
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3. Focus your attention on the left side of the Motion edit window, in the Action list area. 
Do one of the following:

t Click an Action to select it from the Action list on the left side of the Motion 
Edit window.

t Right-click anywhere in the Action list, then select Insert action.

t Click the Add Action button on the Motion Edit toolbar.

4. In the Effect/Object area (second from left), select Graphic > Play-on or Graphic > 
Play-off to specify whether Deko applies the motion to the Play-on graphic or to the 
Play-off graphic.

Click an Action

Right-click and select Insert action

Add Action button
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5. In the Effect/Object area, select an object from the Object menu to specify the graphic 
element(s) on which Deko applies the motion. If you set up two actions for the same 
object, Deko performs the actions on alternate characters, words, or rows. You can 
perform multiple actions on any object except a background. If you set up a second 
background action, this action is ignored during motion playback. The following Action 
types are available:

- Graphic - Moves all layers and the background.

- All Layers - Moves all layers.

- Background - Moves the background.

- Layer - Moves each layer specified.

- Row - Moves each row in the layer(s) specified.

- Word - Moves each word in the layer(s) specified.

- Character - Moves each character in the layer(s).

- Background Clip - Moves the background clip.

n Actions might not act on all types of objects on all models.

6. In the Layer name or number field, select the layer name or number for the 
selected object.

Deko supplies a menu of layer names and numbers for the selected Play-on or Play-off 
graphic. A numbered list of layers also appears at the bottom of the Layer menu.

7. (Option) You can specify a wildcard layer for similarly named layers. For example, in a 
graphic with the layers Rectblue, Rectgold, Rectgreen, and Rectpink, you can designate 
Rect* as the layer name to apply the effect to all four layers.

If you specify a hidden layer either explicitly or with a wildcard, the layer is shown 
during the motion. You can use opacity controls to keep it hidden or somewhat 
transparent. This is useful for creating a “travelling glow” in the motion.

If you specify All Remaining, the motion is applied to each layer that is not explicitly 
specified in the motion script. Both wildcards and All Remaining allow you to create 
actions for groups of layers. Even for groups, you can set up the action to happen with a 
delay between the objects in the group using the Offset control on the Timing bar.

n Layers (including the background) not explicitly specified in the motion are considered static 
(no motion). Deko treats adjacent static layers as a single object. It is generally a good idea 
to place static portions of a graphic in the back layers. You do not have to make them part of 
the background.



12  Creating Custom Motions

528

8. Specify an Effect for the selected Action by selecting an effect from the Effect menu. 
Select the effect that you want to perform on a graphic element that you will specify in 
the next step. The following effects include standard effects plus effects available only 
with the DVE Effects Group 2 option:

2D Effects:

- Screenmove - Moves the object relative to the screen boundary. Object disappears 
beyond screen boundary.

- Layermove - Moves the object relative to its layer’s bounding box. Objects are 
visible beyond the layer boundary.

- Layermove (crop) - Moves the object relative to its layer's bounding box, however 
objects beyond the layer boundary are not visible.  By default, a pause will be added 
to the end of this effect.

- Objectmove - Moves the object relative to its bounding box. Object disappears 
beyond its own boundary.

- Objectwipe - Wipes the object relative to its bounding box.

- Screenwipe - Wipes the object relative to the boundary of the screen.

3D Effects:

- Folds (DVE effect) - A user-specified number of sections peel off from the center or 
on from the outer edges of the object.

- Page Turn (DVE effect) - Peels the object on or off.

- Ripple (DVE effect) - Creates a water ripple effect on the object as it fades in (on) or 
out (off).

- Shards (DVE effect) - Sections of the object move outward from the center of the 
object’s bounding box and apart (off), or inward, convening at the center of the 
bounding box (on).

- Tiles (DVE effect) - An array of rectangular “tiles” of the object randomly fall off a 
“wall” (off), or the tiles randomly rearrange themselves to form the object (on).

n To see if the following effects are available on your system, select Options > Enabled 
Options. See if DVE Effects Group 2 is selected.

- Page Scroll (DVE Effects Group 2) - The object “rolls up” off or unrolls on.

- Cylinder (DVE Effects Group 2) - The object rolls into a cylindrical shape and rolls 
off or unrolls from a cylinder and rolls on.

- Magic Carpet (DVE Effects Group 2) - The object undulates from a specified fixed 
point as it fades off or on. Deko controls opacity to enhance this effect unless you 
specify opacity separately.
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- Accordion (DVE Effects Group 2) - Forms pleats on the object, which fold and 
unfold from a specified fold axis as the object fades off or on. Deko controls opacity 
to enhance this effect unless you specify opacity separately.

- 3D Ripple (DVE Effects Group 2) - Creates a 3D water ripple effect on the object as 
it fades off or on. Deko controls opacity to enhance this effect unless you specify 
opacity separately.

Deko3D:

- For more information on Deko3D, see “Using the Deko3D Feature” on page 622.

9. Sound File - Attach a .wav file to the graphic/object.  The sound can be delayed, by 
entering an amount into the noted  field.

10. Repeat steps one through eight to add other actions to your motion script. To adjust 
timing or parameters of an action, see “Adjusting Timing of an Action” on page 535.

Using the Basic Timeline Editor to Create Basic 
Motions

If your Deko does not have the Motion Timeline option, you can still create basic motions. 
This topic guides you through the process for creating motions with the Basic TimeLine 
Editor (Basic Motion Compose layout). If your Deko supports Motion Timeline editing, see 
“Using the Motion Timeline Editor to Create Motions” on page 525.

The following topics provide more information about using the Basic Timeline Editor to 
Create motions:

• “About the Basic Timeline Editor” on page 529

• “Creating Motions Using the Basic Motion Editor” on page 530

About the Basic Timeline Editor

The Basic Timeline editor is similar to the Timeline Motion editor. The panels have many of 
the same functions. The parameter panel and control of the parameters is the major 
difference between the Basic Timeline editor and the Timeline Motion editor.
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Basic Timeline Editor Compared to Motion Timeline Editor

The following compares the Basic Timeline editor to the Motion Timeline editor:

• No Scrubbing of the motion in the Basic Timeline editor.

• No ability for keyframing in the Basic Timeline editor. The only keyframe that can be 
controlled is the start position of the object.

• All ending positions are ‘home.’ The motion always lands in its home position. You can 
control how the parameter begins, but not how it ends.

• No variable flight path. Since there are no keyframe controls, the motion cannot scale up 
to 150% then back to 100%. 

• Smart naming conventions and wildcards are useful in both editors.

• The Basic Timeline editor allows separate actions for Backgrounds and layers giving a 
wider range of customization than the Motion editor.

• Timing Bars work the same in both versions.

• The Opacity range is 0 - 100 in the opacity parameter field (not 0 to 1). Fifty percent 
opacity is 50.

• The Scale range is 0 - 100 in the scale parameter field (not 0 to 1). Fifty percent scale is 
50, not .5.

Creating Motions Using the Basic Motion Editor

You can use the Basic Motion Editor to create basic motions. When creating basic motions, 
you need to create actions as described in the following topics:

• “Creating an Action for the Veil Layer” on page 531

• “Creating an Action for the Captions Layers” on page 533

• “Creating an Action for the Picture Layers” on page 534
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Creating an Action for the Veil Layer

To create an action for the Veil layer:

1. Open a .dko graphic in the Preview window.

2. Select View > Motion to open the Motion Editor.

3. Set the Motion in the toolbar to 2 seconds (or however long you want the motion to be). 

4. Select File > Save Motion As. The Save Motion As dialog box opens.

5. Name the motion, and make sure the file extension is .mot. 

6. Click the Save button to save the motion as a .mot file.

7. Create a new Action.

8. Select Graphic > Play-on.

9. Select Object > Layer.

10. Select Effect > Screenmove.
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11. In the Position area, select Ease > Ease In (rather than ignore), then select Horizontal > 
Left to Home.

n The parameter fields control the starting value of the object; the ending value is 
always home.

12. In the Opacity area, do the following: 

a. Leave the Opacity parameter as 0.

b. Select Ease > Ease in and out. 

n Since you want the layer to begin at zero opacity, leave the setting as 0. The finish setting is 
always 'home' and is not controllable in this interface.
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n Activate a parameter by choosing an attribute other than ignore. Then, enter the beginning 
value in the parameter field.

Opacity values range from 0 - 100. 100 is full opacity.

13. In the Timing area, drag the ending triangle to :20 frames.

n The timing area controls when the Action occurs within the Motion. The timing panel works 
the same in both interfaces. 

14. Drag the start or end triangle to change the duration and drag the center of the timing bar 
to change when it occurs within the motion.

15. With the graphic in the Preview window, play the motion to Program.

Creating an Action for the Captions Layers

To create an action for the Captions Layers:

1. Swap the graphic to the Preview window before continuing.

2. Create an Action for all the layers that begin as Caption:

- Caption Frame

- Caption Line 1

- Caption Line 2

3. Select Graphic > Play-on.

4. Select Object > All Layers.

5. Set to Caption* (the asterisk is a wild card including any layer names that begin as 
‘caption.’).

6. Change the Opacity from Ignore to Ease In and leave the starting value as 0.

Drag ending 
triangle
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7. Change the Vertical Size (Y Scale) from Ignore to Ease In and leave the starting value 
as 0.

8. Set the timing bar to begin around :10s and end at approximately 1:00s. 

The Caption Action appears as follows:

9. Save the motion.

Creating an Action for the Picture Layers

To create an action for the Picture layers:

1. Swap the graphic to the Preview window before continuing.

2. Create an Action for all the layers that begin as Picture. (Picture and Picture Frame).

3. Select Graphic > Play-on.

4. Set to Object > Layer.

5. Set Layer name or Layer number to Picture*.

6. Change the Horizontal Size from Ignore to Ease in.

7. Set the Horizontal Size to begin as 50 (50% of original).

8. Change the Vertical Size from Ignore to Ease in.

9. Set the Vertical Size to begin as 50 (50% of original).

n Horizontal and Vertical Size (X and Y Scale) have a range of zero to 100, with 100% being 
the original size.
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10. Set the Opacity to Ease in with a start value of 0.

11. Set the Timing Bar to begin just as the last Action is ending. 

The Picture Action appears as follows.

12. Save the motion. For information on adjusting your motion, see “Adjusting Motion 
Parameters Using the Basic Timeline Editor” on page 537.

Adjusting Your Motion Script

Once you have created a motion, you can adjust your motion script to make it flow better.

If you have the Motion Timeline Editor, see the following topics:

• “Adjusting Timing of an Action” on page 535

• “Allowing Time at the Beginning or End of a Motion” on page 536

If you have the Basic Timeline Editor, see “Adjusting Motion Parameters Using the Basic 
Timeline Editor” on page 537.

Adjusting Timing of an Action

The first step in adjusting your motion script is to adjust the timing of an action.

To adjust timing of an action:

1. Select an Action in the Action list. Look for a light gray highlight behind the Timing Bar 
(in the right area) of the corresponding Action.

2. Click and hold either end of an offset bar to view the current in or out time for the 
corresponding action.
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3. Drag the offset bar to change the in and out times equally, or drag only one end of the 
offset bar right or left to adjust the in or out time.

n To adjust them as a group, you can select multiple timing bars by holding Ctrl and clicking 
the end of each bar.

Allowing Time at the Beginning or End of a Motion

The next step in adjusting your motion script is to allow some time at the beginning or end of 
a motion for additional actions, while maintaining the relationship between the existing 
timing bars.

To allow time at the beginning or end of a motion:

1. On the command bar, type motion_scale, then click the Prompt button. 

The motion_scale dialog box opens.

2. Select “Scale from start of motion” option to scale the motion from its start. Deselect the 
option to scale the motion from its end.

3. In the Scale amount text box, type a percentage to scale motion timing.

4. Click the Play button on the command bar to scale the motion based on the percentage 
value in the Scale amount box.

5. Click OK.
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Adjusting Motion Parameters Using the Basic Timeline Editor

If you do not have the Timeline option on your Deko, you can adjust the motion parameters 
with the Basic Timeline Editor.

n To adjust motion parameters with the Timeline option, see “Adjusting Motion Parameters 
with the Timeline Option” on page 541.

To adjust motion parameters using the Basic Timeline Editor (without the 
Timeline option):

1. Working in the Parameters area (third from left), select an option from the Ease menu to 
refine the rate at which motion or change of size or opacity occurs, to keep it constant 
throughout, or cause it to slow down or speed up.

Ease enables you to refine the rate at which the horizontal, vertical or opacity motion 
occurs. The following options are available:

- Ignore - Disables the horizontal, vertical effect.

- Constant - Moves or changes at a constant rate.

- Ease in - Moves or changes slowly and accelerates to full speed.

- Ease in fast - Moves or changes slowly and accelerates up to full speed, faster than 
ease in.

- Ease in and out - Accelerates, then decelerates.

- Ease out - Moves or changes at full speed and decelerates.

- Ease out fast - Moves or changes at full speed and decelerates, faster than ease out.

- Ease out and in - Decelerates, then accelerates.
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2. Click on the corresponding Position parameter (Horizontal or Vertical) and select a 
motion path from the menu. The Position parameter determines how Objects move. 
Generally, Objects begin movement from somewhere offscreen and end in the home 
position. 

n Home is the original position of the object in the graphic.

- Horizontal - This specifies the horizontal path of the motion from the object’s 
starting position to its home position. If you do not specify an X Position, the 
object(s) does not move horizontally. 

- Vertical - This specifies the vertical path of the motion from the object’s starting 
position to its home position. If you do not specify a Y Position, the object(s) do not 
move vertically. 

3. Change the Horizontal or Vertical values in the Size section of the dialog box to specify 
the width or height of the object throughout the selected motion. 

- Horizontal - This specifies the width of the object throughout the selected motion, 
in arbitrary units from 0.00 to 10.0 (full width).

- Vertical - This specifies the height of the object throughout the selected motion, in 
arbitrary units from 0.00 to 10.0 (full scale).

n If you do not specify a size value, (OVR) might appear next to the parameter to indicate that 
Deko is overriding standard sizing to enhance the current DVE effect (this only happens with 
some DVE effects).

4. In the Opacity section, change the opacity of the selected object(s) throughout the 
motion, in arbitrary units from 0.0 (zero opacity) to 1.0 (full opacity). 
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n If you do not specify an opacity value, (OVR) might appear next to the parameter to indicate 
that Deko is overriding standard opacity to enhance the current DVE effect (this only 
happens with some DVE effects).

Editing Motions

There are many different way you can edit motions. The following topics provide more 
information about editing motions:

• “Deleting Selected Actions” on page 539

• “Appending a Motion to the Active Motion” on page 539

• “Saving a New Motion Script” on page 540

• “Opening a Motion File” on page 540

• “Creating a Motion to Play a Cel Animation” on page 540

Deleting Selected Actions

To delete the selected Action:

t Do one of the following:

- Right-click anywhere in the Action list, and select Delete.

- Click the Delete Action button on the Motion Edit toolbar.

Appending a Motion to the Active Motion

To append a motion to the active motion:

1. Click in the Motion window.

2. Select File > Append to Motion.

The Append Motion dialog box opens.

3. Navigate to the directory that contains the motion (.mot) file to append to the open file.

4. Select the file from the File Name list or type it in the File Name text box, then click OK 
or press Enter.
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Saving a New Motion Script

To save a new motion script:

1. Click the Timeline Motion editor, and then do one of the following:

t Select File > Save Motion.

t Select File > Save Motion As.

t Press F12 (SK).

t Press Save File (FAK).

The Save Motion As dialog box opens.

2. Navigate to the drive and directory where you want to store the .mot file.

3. Type a new file name in the File Name text box, then click OK or press Enter. 

Deko automatically adds the .mot extension to the file name. Do not type a different 
extension.

n When you save a motion script, Deko automatically attaches “.mot” to the file name. Do not 
type a different extension.

Opening a Motion File

To open a motion file:

1. If there is a graphic in the Program window, click on the window to set focus.

2. Clear the graphic so the window is blank by pressing F8 twice (SK) or Clear 
Program (FAK).

3. Select File > Open Motion to activate the Motion window.

4. Navigate to the drive and directory that contains the file.

5. Double-click the file name to open the file.

Creating a Motion to Play a Cel Animation

To create a motion to play a cel animation (graphic with a CAP shader):

1. Open the graphic that includes the CAP shader in the Preview window.

2. Click in the Motion window. 

3. Select Motion > Clear Motion, if necessary, to restore default settings to the Motion 
window.

4. Click the second default action to select it from the action list on the left side of the 
Motion window.

5. Click the arrow next to the Object text box and select Layer from the menu.



Using the Basic Timeline Editor to Create Basic Motions

541

6. Type the layer number of the layer that contains the CAP shader in the Layer number 
text box.

7. Specify other action parameters as desired.

8. View the cel animation by playing the motion or, if you have the Timeline option, scrub 
through the Timeline.

n A graphic can accommodate more than one animation. Performance might degrade as Deko 
encounters large animations or a lot of details in a graphic.

Adjusting Motion Parameters with the Timeline Option 

Defining an Action with an effect as described in “Using the Motion Timeline Editor to 
Create Motions” on page 525, creates motion off screen to on screen, or on screen to off 
screen. With the Timeline option, you can also create multiple point-to-point actions within 
the screen and as part of a single motion. Once a motion is created you can edit the action 
with the Timeline. For more information, see “Editing an Action with the Timeline” on page 
549.

n This offers an effect similar to keyframing with a DVE.

An object can move in different ways. The following illustration shows a simple move:

An object can also move as shown in the following illustration:

Home PositionStart offscreen Home Position

Start offscreenGo here

End here
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In addition to multiple points for position, you can create multiple points for any other 
parameter. An object might, for example, begin at 0% of its original size, scale to 150%, 
then scale to 100% of its original size. 

If your Deko has the Timeline option, the Timeline appears as an area in the Motion Edit 
window. The Timeline is a representation of the parameter selected in the parameter list. It is 
important to understand that the Timeline is not a drawing or mirror image of what happens 
on screen. It is a graphical representation of how the selected parameter varies over time 
from start to end position.

You can use the Timeline tools in the Motion Edit window toolbar to select, edit, add, delete, 
or move points on the Timeline. Adjust points for curved, linear, cusp, smooth and 
symmetrical movement.

Parameter List Timeline

Edit Points Delete Points Smooth       Reset

Insert Points

Move 

Cusp Symmetrical

Curve

(New Action Line

Delete Action

Clear Motion
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The following topics provide more information about the motion parameters with the 
Timeline graph:

• “Position (X Position, Y Position, and Z Position)” on page 544

• “Scale” on page 547

• “Rotate” on page 548

• “Skew” on page 548

• “Kern” on page 548

• “Opacity” on page 548

• “Blur Face” on page 549

• “Origin” on page 549

Timeline Tool 
Icon Description 

The New Action button enables you to add a new action to the motion.

The Delete Action button enables you to delete a selected action from the motion

The Clear Motion button clears the entire motion.

The Edit points button enables you to change the type of the selected point.

The Insert points button inserts one or more points. Click on the Timeline to 
insert a point. Hold Ctrl key as you click on Timeline to add additional points.

The Delete points button deletes the selected point.

The Next point button selects the next point.

The Previous point button selects the previous point.

The Move button enables you to move the selected point.

The Line / Curve / Cusp / Smooth / Symmetrical buttons determine the nature of 
the point. The Curve button is shown.

The Reset graph button resets the Timeline graph to its default shape. 
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Position (X Position, Y Position, and Z Position)

If selected, this option enables the X, Y, and Z Position options. Each is described.

The X position option enables you to specify the horizontal path of the motion from the 
object’s starting position to its ending (home) position. If you do not specify X Position, the 
object(s) do not move horizontally. Click the path indicator arrow to the left of the Timeline 
to select a horizontal path:

Horizontal path choices include:

• Left to Home

• Offset

• Center to Home

• Absolute

• Right to Home

• Absolute to Home

• Left to Right
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The Y Position option enables you to specify the vertical path of the motion from the 
object’s starting position to its ending (home) position. If you do not specify Y Position, the 
object(s) do not move vertically. Click the path indicator arrow to the left of the Timeline to 
select a vertical path:

Vertical path choices include:

• Top to Home

• Offset

• Center to Home

• Absolute

• Bottom to Home

• Absolute to Home

• Top to Bottom
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The Z Position option enables you to specify the distance from the “camera,” that is, from 
the eye of the viewer. 

n Certain illustrations of the user interface in this document might not display the 
Z Position option.
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Scale 

The Timeline expresses X scaling and Y scaling of the object throughout the selected 
motion, in arbitrary units with 1.00 representing full scale. If you do not specify scaling 
values, (OVR) might appear next to the parameter to indicate that Deko is overriding 
standard sizing to enhance the current DVE effect (this happens only with some DVE 
effects).
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Rotate

The Timeline expresses rotation of the object throughout the motion, in degrees, on the X-, 
Y-, or Z-axis. 

Skew

The Timeline expresses skewing of the object throughout the motion, in negative (leftward 
skewing) or positive (rightward skewing) arbitrary units. (Zero is no skewing.)

Kern

The Timeline expresses kerning of the object throughout the motion, in negative (inward 
kerning) or positive (outward kerning) arbitrary units. (Zero is no kerning.) This parameter 
applies only to motions on characters.

Opacity 

The Timeline expresses opacity of the selected object(s) throughout the motion, in arbitrary 
units from 0.0 (zero opacity) to 1.00 (full opacity). If you do not specify an opacity value, 
(OVR) might appear next to the parameter to indicate that Deko is overriding standard 
opacity to enhance the current DVE effect (this only happens with some DVE effects).
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Blur Face

The Timeline expresses X blurring and Y blurring of the face of a character throughout the 
motion, in arbitrary units from 0.0 to 1.00. This parameter applies only to motions on 
characters. Deko overrides standard opacity and scaling to enhance blurring, unless you 
specify opacity and scaling separately.

Origin

The Timeline expresses Origin points by enabling you to define the origin point in X, Y, and 
Z space for Scale and Rotation parameters. For more information, see “Defining the Motion 
Origin Point” on page 578.

Editing an Action with the Timeline

To edit an action with the Timeline:

1. With an action selected in the Action list, select the parameter you want to edit. 
Options include the following:

- Position

- Scale

- Rotate

- Skew

- Kern

- Opacity

- Blur Face

- Origin

The graph associated with the parameter you select displays in the Timeline graph 
section.

n Motion parameters are listed next to the Timeline graph. 

2. Click once on the Insert point icon in the Timeline toolbar. Your mouse pointer displays 
a + sign.

3. Position your mouse in the graph where you want to insert a point on the Timeline. 

4. Click once to insert a red Bézier Point with two purple handles at opposite ends. 

The red Bézier point acts as a keyframe for repositioning. 
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5. (Option) You can assign a level of continuity by choosing one of five Continuity Tools 
in the Timeline Toolbar (see above). Deko defines continuity as a degree of smoothness 
from Point to Point. To assign continuity to Point 2, the Point must be selected 
(indicated in red.) 

6. Click the handles and drag them on the point to reposition it. 

7. Click and hold the scrub bar arrow (time thumb) and drag the scrub bar across the 
Timeline in either direction on the X-axis. This enables you to see what the motion 
looks like on your monitor. 

8. If you want to add or move a point, use the scrub bar to see or mark a position on the 
Timeline where you would like to add or move the selected point.

Scrub bar

X Position Y Position
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In the previous example, a point has been added to the Timeline for the X position. Its 
position specifies that the object will travel from left to the home position, reaching the 
home position before the end of the motion and remaining there. A point has also been 
added to the Timeline for Y position and positioned to specify that the object remains in 
the home position vertically until the middle of the motion, and then moves the 
home position. 

For a graphic like the previous one, if you specified word as the object for the motion to 
act upon, the motion path would be as shown in the following illustration.

9. Repeat steps 3-7 to create additional points for this parameter. 

10. Repeat all steps to edit other parameters.

Start offscreenGo here

End here
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Using Motion Behaviors

You can use Deko Motion Behaviors to produce attention-drawing effects with very little 
effort. 

n Deko Motion Behaviors are available on Deko 3000 models only. 

There are two types of Motion Behaviors:

• Local Behaviors.

• Targeted Behaviors.

A Local behavior is used to apply a cyclical variation to a motion parameter. It operates on 
the elements described by the Motion Action.

A Targeted behavior is used when one element of a graphic causes a change to a motion 
parameter on other elements of a graphic, based on proximity. The Targeted behavior is 
specified in a motion action (the “Actor” element) and causes a change in other motion 
actions (the “Target” elements). The closer the “Actor” is to a “Target”, the stronger its affect 
on the motion parameter.

Multiple Local behaviors and multiple Targeted behaviors might be applied in a single 
motion action. The effects of these behaviors are applied in addition to the effects caused by 
the normal motion parameters. Like all Deko Motions, behaviors are content independent, 
which means that the text remains independent from the Motion script, so no matter what the 
character count, the effect always works.

n Local and Targeted behavior effects are separate effects for animating Deko elements.  An 
element can have normal effects only, local effects only or Targeted behavior effects only or 
a combination of the three effects.

The following topics provide more information about using Motion behaviors:

• “Adding a Local Behavior” on page 553

• “Adding a Targeted Behavior” on page 559
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Adding a Local Behavior

To add a Local behavior:

1. Open the Motion Compose layout (Shift+Ctrl+M).

2. With an Action selected in the Action list, compose your motion as you normally would. 
For more information, see “Building a Motion Script” on page 525.

3. Click the Local Behaviors button in the Parameter list. 

4. Select the parameter that you want to be modified by the behavior:

- X posn

- Y posn

- Z posn

- Scale

- X Scale

- Y Scale

- X Rot

- Y Rot

- Z Rot

- Skew

- Opacity

- Glow

- Glint

For more information, see “Adjusting Motion Parameters with the Timeline Option” 
on page 541.
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5. Adjust the controls in the Local Behavior control panel:

The control panel interface varies slightly, depending on the chosen behavior.

Local behavior control 
panel for X Posn

Local behavior control 
panel for Glow
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The table describes the controls in the Local Behavior Control Panel.

Local Behavior 
Options Description 

Definition Parameters Specifies the maximum amplitude (amount) of the behavior. 

• Distance is specified by “percent of screen height.”

• Scale is specified by “percent of object size.”

• Rotation is specified by degrees.

• Skew is specified by degrees.

• Opacity is specified by percent.  

• Intensity is specified by percent.

n For example, a Distance set to 15 causes a maximum movement of 
15% of the height of the screen. 

n For Z Position, a positive value/interval will move the object away 
from the user. A negative value/interval will move the object 
towards the user. A negative Z Position that is too large will have 
the effect of the object flying off the screen.

• Start – The home position/starting point/starting value of the object 
being affected by the local behavior.

• Max – The Maximum value of the object’s motion/opacity/intensity.

• Min – For certain behaviors, when Full Range is checked, a 
Minimum value parameter will be visible. The minimum value will 
be calculated automatically from the Start and Max values. It cannot 
be adjusted by the user. For example, an X position cycle with a Start 
value of 0 and a Max value of 5 will generate a Min value of -5.

• Full Range – For certain behaviors, a checkbox for Full Range is 
available. It will give you the full range of the effect for that 
behavior. For example, a Z rotate with a Reflect pattern, a Start value 
of 0 and a Max value of 45 will give you a 45 degree rotation of the 
object to the right. If Full Range is checked, the object will do the 45 
degree rotation to the right, then a 45 degree rotation to the left of its 
start point. A pendulum swing would be a good visual example of 
Full Range.
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Glow For Glow, you can define an Outer edge and an inner Full parameter for 
the Glow Effect.  As a default, the Outer is blue and the Full is white.  
Color can be changed by clicking on the color chicklets as follows:

• One Left Click – Brings up the Face Shader and deposits the color of 
the Glow chicklet into the Face Shader.

• One Right Click – Deposits the color from the Face Shader chicklet 
to either Glow chicklet.

• Double Left Click – Returns the Glow chicklets to their default blue 
and white.

• Size – Sets the size of the edge/full for the Glow elements, from 0 to 
100.

• Blur – Sets the amount of Blur on the Glow elements, from 0 to 100.

Glint For Glint, you can define a Face for the Glint Effect.  As a default, the 
Face is a gray ramp with a white hilite.  Color can be changed by 
clicking on the color chicklets as follows:

• One Left Click – Brings up the Face Shader and deposits the color of 
the Glint chicklet into the Face Shader.

• One Right Click – Deposits the color from the Face Shader to the 
Glint chicklet.

• Double Left Click – Returns the Glint chicklet to its default gray and 
white ramp.

• Size – Sets the size of the edge/full for the Glint elements, from 0 to 
100.

Local Behavior 
Options Description (Continued)
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Pattern The Pattern menu specifies how the behavior “cycles.” It contains the 
following choices:

• Cycle – Accelerates and decelerates throughout each cycle of the 
behavior (slowing down at the extremes).

• Reflect – Maintains a constant speed throughout each cycle of the 
behavior. Does not slow down or speed up.

• Bounce – Creates a bouncing effect by slowing down at the “top” of 
each cycle and abruptly reversing direction at the “bottom” of each 
cycle.

• Loop 1 – Plays at a constant speed from the starting value to the 
ending value, then loops back to the starting value. Especially useful 
for rotations of 360 degrees.

• Loop 2 – Plays with acceleration and deceleration from the starting 
value to the ending value, then loops back to the starting value.

• Random – Uses a different random value (not greater than the 
maximum) for each cycle.

• Random2 – The same as Random, but contains more possible 
choices for the random values.

• Toggle – Alternates between the starting value and the maximum 
value on successive cycles (that is, switches back and forth). This 
effect is especially useful when you apply the behavior to the 
Opacity parameter. 

• Flash – For certain behaviors, the Flash checkbox will be visible. 
When checked, it applies the behavior for the particular pattern for 
only an instant of each cycle. For example, the Toggle pattern with 
Flash checked will react as same as the Toggle pattern, but with the 
maximum value applied only for an instant (for each cycle).

Local Behavior 
Options Description (Continued)
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Timing Parameters The Timing parameters (Continuous and Action) are described as 
follows:

Continuous – If selected, the behavior timing is tied to the motion 
timing, (that is, the cycles are timed to the total duration of the motion). 
At the end of the motion, the behavior continues until triggered to stop. 

Action – If selected, the behavior timing is tied to the action timing. You 
can select one or more of the following options for Continuous or 
Action:

• Cycle Time – The number of seconds to complete one full cycle.

• Active % – The percentage of the cycle time that the behavior is 
active. Percentages less than 100% will result in an inactive period 
between the cycles. For example, a glow with a 4 second cycle time 
that is 50% active will result in a glow that takes 2 seconds to play 
out, and has a 2 second inactive period, before starting the cycle 
again.

• Cycles – Designate the number of cycles that the local behavior is to 
perform.  This parameter applies only when Timing - Action is 
selected.

• Wait for Action Start – Holds the start of the behavior so that it syncs 
up with the start of the motion effect.

• Amplify – If this option is selected, the behavior gradually increases 
in amplitude (as the motion plays), from 0 up to the specified 
Distance, Scale, Rotation, Skew, Opacity, Glow, or Glint.

• Attenuate – If this option is selected, the behavior gradually 
decreases in amplitude (as the motion plays), from the specified 
Distance, Scale, Rotation, Skew, Opacity, Glow or Glint down to 0.

• Accelerate – If selected, the cycles start out slower and get faster 
over the time of the action.

• Decelerate – If selected, the cycles start out faster and get slower 
over the time of the action.

• Ease in – If selected, there is very subtle acceleration at the 
beginning of the first cycle (the behavior eases into the first cycle). 
This is useful when you want to prevent a “jarring” start to the 
behavior.

• Ease out – If selected, there is very subtle deceleration at the end of 
the final cycle (the behavior eases out of the final cycle). This is 
useful when you want to prevent a “jarring” end to the behavior.

Local Behavior 
Options Description (Continued)
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Adding a Targeted Behavior

In order to create a Targeted behavior, you need an action for one element (the Actor), and 
an action for the other element (the Target). The closer the Actor element is to the Target 
element, the greater the effect is on the Target element.

n When you add a Targeted behavior, the “actor” must be a single layer. Each “target” must 
be a layer (or a group of layers with common names). The actor acts on each target layer, or 
the elements (words, characters, and so on) within each target layer.

The motion must contain a “target” action for the element or detail that the actor affects. For 
example, if the Actor's Targeted behavior action is to affect an object (such as, characters, 
rows, words, and so on) of Detail 3 in a layer named “Title”, a matching action for the object 
(that is, characters, rows, words, and so on) of Detail 3 for “Title” layer must exist as a 
separate action in the motion, whether it has an effect applied to it or not. 

Basically, you cannot have an Actor affect Detail 3 of the Targeted layer, unless Detail 3 is 
actually defined in a separate Targeted layer action. It doesn't have to actually do anything 
(such as, dissolve, pageturn, and so on), but it must exist in the Action so the Actor can find 
it. Likewise, if the Actor is to affect the Targeted element character-by-character, then the 
Targeted element must have a character object assigned to an action in the motion.

Overlap Parameters These parameters are available only when Timing - Continuous is 
selected.

• Auto – Deko will calculate automatically the behavior overlap based 
on your existing behavior options, such as cycle time and objects 
specified in the motion (i.e. character, word, row, etc.), creating a 
“domino effect”.

• Manual – Allows you to set your own overlap settings for the cycle..

• Forward – Plays the overlap progression in a left-to-right direction.

• Backward – Plays the overlap progression in a right-to-left direction.

• % Overlap – When Manual Overlap is selected, enter the percentage 
of overlap for the behavior effect here.

Local Behavior 
Options Description (Continued)
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To add a Targeted behavior:

1. Create an action for the Target layer(s), specifying how the object is animated (object 
field set to layer, words, rows, or characters) and if a specific detail is to be affected.  

n An action must exist for the object and detail to be affected by the Actor.

2. Open the Motion Compose layout (Shift+Ctrl+M).

3. Create an Action for the Actor element in the Action list, and compose your motion as 
you normally would. For more information, see “Building a Motion Script” on page 
525.

n The Actor element must be a single, specific (Text or) shape layer designated by layer 
number or name. For example, the Object cannot be character, row, graphic, all remaining 
layers, all layers, or background).

4. Add a Targeted Behavior for the Actor element by doing the following:

a. Click on the Targeted Behaviors button in the Parameter list.

b. Select a behavior by clicking on one of the following options as described in the 
following table.

Motion Behavior 
Option Description 

Repel The Target is pushed away from the Actor as the Actor approaches the 
Target (cannot be used with the Z position option).

Attract The Target is pulled toward the Actor as the Actor approaches the 
Target (cannot be used with the Z position option).

Grow The Target gets bigger as the Actor approaches.

Shrink The Target gets smaller as the Actor approaches.

Rotate The Target rotates as the Actor approaches.

Skew The Target gets skewed as the Actor approaches.

Brighten The Target gets brighter as the Actor approaches. To be effective, you 
must lower the opacity of the Targeted element in the Motion.

Dim The Target gets dimmer as the Actor approaches.
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n System performance is affected more by the number of parameters and targeted elements 
that you select than by the maximum bounding value, distance, or scale. Selecting repel, 
grow, and dim use more system resources than if you just select repel. So, if you are creating 
a Targeted behavior through 8 lines of text and your system performance is slow, try 
reducing the lines of text or the Area amount.

5. Adjust the controls in the Targeted Behavior Control Panel.
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The following table describes the controls in the Targeted Behavior control panel.

Targeted Behavior 
Option Description 

Direction (Repel, Attract 
Grow, Shrink Only

Specifies the direction in which the targeted elements are affected. 
Select from the following:

• Vt - Vertically only.

• Hz - Horizontally only.

• Vt+Hz - The behavior grows in both directions together.

• Vt/Hz - Both vertically and horizontally, independently.

Repel / Attract / Grow / 
Shrink / Rotate / Skew / 
Brighten / Dim

The “strength” of the actor. 

• Repel and Attract are specified by “percent of screen height” 
(cannot be used with the Z position option). 

• Grow and Shrink are specified by “percent of object size.”

• Rotate and Skew are specified by degrees.

• Brighten and Dim are specified by percent.  

For example, a “Repel” set to 15 causes a maximum movement of 
15% of the height of the screen (when the Actor is very close to 
the Target).

Amplify If this option is selected, the Actor gradually increases in strength 
(as the motion plays), from 0 up to the specified Repel / Attract / 
Grow / Shrink / Rotate / Skew / Brighten / Dim.

Attenuate If this option is selected, the Actor gradually diminishes in 
strength (as the motion plays), from the specified Repel / Attract / 
Grow / Shrink / Rotate / Skew / Brighten / Dim to 0.

Area The distance around the actor element that is affected. This 
number is specified as a percent of the screen height.

For example, 10 defines a small area around the actor (10% of 
screen height), while 100 defines a wide area (100% of screen 
height). 

Target layer name or 
number

Enables you to select the Target layer by name, number, or 
Wildcard. This functionality is the same as selecting a Graphic 
layer.
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Playing Motions

The Motion window provides tools for specifying playback rate and playing the motions in 
the current .mot file. This allows you to preview your motion during the creative process.

n Undo is disabled during motion edit, motion playback, and sequence playback. When you 
play a motion or a sequence, Deko resets the Undo buffer so that no previous actions can be 
undone.

To play a motion on air, you must specify the motion as an effect, in either the Effect 
window or the Sequence window, just as you would play any other effect.

How Deko Determines Which Motion or Effect to Use

Transition Logic is the method by which Deko decides how to play graphics and motions. If 
you always want a specific effect when transitioning from a lower third graphic (such as 
L3rd.dko) to an over-the-shoulder graphic (such as OTS.dko), but not when transitioning to 
other templates, this is an easy way to do it.

Here’s how it works behind the scenes:

1. When you load a graphic into the Preview window (on a channel that is enabled for 
effects), Deko looks at the names of the templates loaded in both the Preview window 
and Program window.

2. Deko looks in the Motions folder for a file formatted as either: 

- <Pvw.dko>-<Pgm.dko>.mot

- <Pvw.dko>-<Pgm.dko>.efx. 

3. If an .efx or .mot file is found, Deko applies the motion or effect to the template, 
overriding its existing motion or effect.

Detail If the actor must act on a target that specifies a detail range, an 
action must exist in the motion specifying a matching detail range 
for the target. 

For example, in order for the Target layer's detail 3 to be accessed 
as a Targeted behavior, an action for Target detail 3 must exist 
including the Actor's Targeted behavior setting that specifies 
Target as the layer and 3 in the Detail field.

Targeted Behavior 
Option Description (Continued)
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For example, if you have a graphic called “L3rd.dko” loaded in the Program window, 
then you load “OTS.dko” into the Preview window, Deko looks for “OTS-L3rd.efx” in 
the Program window.

- If the .efx file is not found, Deko looks for “OTS-L3rd.mot”. 

- If either the .efx or the .mot file is found, Deko associates that file to the template in 
Preview, so when you press “Play Next”, it plays “OTS-L3rd.efx/mot”.

- If the Program window was clear, Deko looks for “OTS-.efx/mot”.

The following topics provide more information about playing motions:

• “Ability to Handle Motions Created on More Capable Deko Models” on page 564

• “Playing Motions in the Motion Edit Window” on page 565

• “Playing a Motion within a Sequence” on page 569

• “Playing a Motion as a Single Effect” on page 569

• “Associating a Motion with a Graphic” on page 569

Ability to Handle Motions Created on More Capable Deko Models

Deko enables you to play back motions created on a more capable model even though some 
of the effects might not be available on a less capable model. Previously, if you had an entry 
level model, like the Deko 550, and you tried to play a motion that was created on a more 
capable Deko model, you would not have been able to play the motion at all. For example, if 
the motion that was created on the more capable Deko model contained some 3D open GL 
effects, when that motion is opened on a less capable Deko model, those effects no longer 
appear in the graphic motion. The effect(s) are eliminated and the motion plays in a modified 
form. 

A message appears in the Status bar (bottom of screen) that informs you that the effect will 
play in a modified form, along with some indication of which effect is not available.
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Playing Motions in the Motion Edit Window

The following topics provide more information about Playing Motions in the Motion 
Edit window:

• “Manually Playing the Motion” on page 565

• “Specifying the Playback Rates of Motions” on page 565

• “Pausing Motions” on page 566

• “Playing Selected Motions” on page 566

• “Pausing and Resuming Motions During Playback” on page 566

• “Stopping Motions During Playback” on page 566

• “Playing Motions Using the Scrub Bar” on page 567

• “Synchronizing a Clip with a Motion Scrub” on page 567

• “Playing Clips Associated with a Graphic and Linked to a Motion or Effect” on page 
567

• “Pausing and Holding Effects (at Start)” on page 568

Manually Playing the Motion

To manually play the motion: 

t Click the scrub bar arrow (time thumb) and drag it across the Timeline in either 
direction on the x-axis. Stop at any point in the motion.

Your motion displays on your monitor so you can see what your motion will look like. 
This is called scrubbing through the motion. 

n You can use the scrub bar to see or mark a position on the Timeline where you would like to 
add or move a point.

Specifying the Playback Rates of Motions

To specify the playback rate of motions in the current .mot file:

1. Enter a numerical value in the Playback rate box on the Motion Editor toolbar.

2. Click the arrow to the right of the Units of playback rate box and select seconds or 
frames. This rate applies to playback from the Motion Edit window only. It is not saved 
with the .mot file. 

n Rates for on-air playback are set in the Effect or Sequence window and override those set in 
the Motion window.
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Pausing Motions

To specify a pause:

1. Click Pause for the action. 

During playback, Deko pauses the motion at the specified time. 

2. Click Play to resume playback. 

If you use a CAP shader with the Continuous option selected, Deko automatically 
pauses, or autopauses, the end of the motion for the following reasons:

- If the graphic contains a Power Clip (that is played by the motion)

- If the graphic contains a CAP shader marked as Continuous (that is played by the 
motion)

- If the motion contains a local behavior with Continuous timing

- If a Play-on action has a parameter whose ending value causes the final motion to 
look different than the preview graphic (for example, the ending opacity is less than 
100%, the ending scale is not 1.0, and so on)

- If a Play-off action has a parameter whose ending value causes the final motion to 
display the program graphic (for example, the ending opacity is greater than 0%, the 
ending scale is not 0, and so on)

Playing Selected Motions

To play the selected motion:

t Do one of the following:

- Click the Play button on the Motion Editor toolbar.

- Press Shift+Alt+P.

Pausing and Resuming Motions During Playback

To pause and resume a motion during playback:

1. Click the Pause button on the Motion Editor toolbar to pause a motion during playback.

2. Click the Pause button again to resume the motion.

Stopping Motions During Playback

To stop a motion during playback:

t Click the Stop button on the Motion Editor toolbar.
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Playing Motions Using the Scrub Bar

To play a motion using the scrub bar:

t Click the scrub bar arrow (time thumb) and drag it across the Timeline in either 
direction on the x-axis.

n You can edit a motion with the scrub bar enabled, but you cannot edit a motion 
during playback.

Synchronizing a Clip with a Motion Scrub

To synchronize a clip with a motion scrub:

t In the Clip Editor, in the Effect area, select Synch with Effect. This enables you to scrub 
through a clip (such as one associated with the graphic) and an effect together.

n If a graphic is associated with a clip, Deko displays a bracketed remark in the title bar of the 
graphic window telling you the clip filename.

Playing Clips Associated with a Graphic and Linked to a Motion or  
Effect

The default behavior of a clip associated with a graphic and linked to a motion or effect is 
that when you recall the graphic to the Preview channel to prepare to air, if a pause or hold is 
not enabled, the graphic element with its linked effect and the clip plays to air, immediately 
overwriting whatever clip might be playing. 

In this case, the Play Setup and the Play Effect are identical and occur instantaneously. No 
setting is enabled that allows you to first see the graphic or clip and then play at a precise 
time to air. It just plays. Effect Setup shows that it sets up with the operator recalling it to 
preview. Effect Playback shows that it plays to air forthright.
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The following table describes how and when a clip plays to air based on which Pause, Hold, 
and Synch with effect settings are selected.

Another alternative is to create a specific action in a custom motion to control how and when 
the layer and/or background clip of a graphic are played to air.

Pausing and Holding Effects (at Start)

Clips can now be associated with a graphic to play to air with a range of behaviors in regard 
to when the clip plays to program in relationship to the effect.

For more information, see “Playing Clips Associated with a Graphic and Linked to a Motion 
or Effect” on page 567.

Pause/Hold Synch with effect Description

None Enabled If Synch with effect is enabled, and there is no Pause or hold enabled, the 
graphic elements with its linked effect and the clip plays to air, 
immediately overwriting whatever clip might be playing. 

None Disabled If Synch with effect is disabled, and there is no Pause or hold enabled, 
the graphic elements without its linked effect and the clip plays to air, 
immediately overwriting whatever clip might be playing. 

Pause Disabled If Pause is enabled, and Synch with effect is disabled, when you recall 
the same graphic and the Effect has a Pause enabled, the graphic and clip 
are recalled to the Preview window.  The clip waits to air. You must press 
Play to play the clip and press Play again to play the graphic effect.

Pause Enabled If Pause is enabled, and Synch with effect is also enabled.  The clip waits 
to air. Press Play once and the effect and clip play together.

Hold Disabled If Hold is enabled, and Synch with effect is disabled, the graphic and clip 
are setup to play from the Preview window. Press Play and the clip plays 
to air. Press Play again and the graphic plays to air. 

Hold Enabled If Hold is enabled, and Synch with effect is also enabled, press Play. The 
first frame of the (frozen) clip plays to air waiting for you to trigger the 
rest of the graphic elements. Press Play again to trigger the clip to begin 
playing and the motion to effect on. 

n This can be tricky to show if the effect selected is not suitable to 
airing a visible first frame of video. Consider a dissolve; the first 
frame is zero opacity. So, even though Hold is really showing the 
first frame, it is not visible because of the particular effect 
selected.
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To pause effects at start:

t Click the Pause at start button. 

The effect is set up without changing the current output. A trigger (For example, Effect 
Playback) then plays the effect. The first frame of your effect does not display. You see 
whatever is currently aired in the Program channel.

To hold effects at start:

t Click the Hold at start button. 

The first frame of your effect is set up and displays the first frame of your effect on the 
Output. A trigger (For example, Effect Playback) then plays the effect.

Playing a Motion within a Sequence

A motion can be played within a sequence or as a single effect. A motion might also be 
associated with a specific graphic, playing whenever the graphic is opened.

To play a motion in a sequence event:

1. In the Sequence window, move the cursor to the event.

2. Select Effect > Motion in the Effect column, then select the current motion or a saved 
motion (.mot) file from the menu. The rate you set for the motion in the Sequence 
window overrides the rate specified in the Motion window. For more about sequence 
playback, see “Playing a Sequence” on page 514.

Playing a Motion as a Single Effect

To play a motion as a single effect:

1. Open the Effect Playback layout.

2. Open the desired graphic in the Preview window. 

3. Select Effect > Motion, then select the current motion or a saved motion (.mot) file from 
the menu. For more information on single effect playback, see “Playing a Single Effect” 
on page 501.

Associating a Motion with a Graphic

To associate a motion with a graphic:

1. Open a graphic in the Preview window.

2. If the Style window is not open, select View > Style (F6) to open the Style window.

3. In the Style window, click the Graphic button.

4. Do one of the following:



12  Creating Custom Motions

570

t In the efx / motion text box, type in the name of the .mot file you want to associate 
with the graphic. 

t Click the Select button, and navigate to the .mot file you want to use. 

5. Save the graphic. 

The Preview window title bar now displays a bracketed remark next to the file name, 
telling you what motion is associated with the graphic. When you open the graphic in 
the Preview window, Deko automatically plays the associated motion if the Play 
Associated Effects preference is selected.

Creating 3D Animated Objects Using Depth 
Rotation

Animating with 3D gives you control over your objects. Depth Rotation gives you fine 
control over the Z Rotation Motion parameter enabling animations with depth and 
perspective. Images from one side of an element can flip with depth to reveal another side 
easily, producing a 3D appeal. You can use layers to “construct” objects that appear to be 
3D. For example:

• Two layers can be used to construct a “slab-like” object that has a different image on 
each side.

• Four layers can be used to create a “cube-like” object that has a different image on 
each side.
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When creating a 3D graphic, you need to understand the X (left to right), Y (top to bottom), 
and Z-Depth (back to front) parameters. To create a 3D box-effect graphic, you are basically 
creating a graphic to represent a side of a box (Side 1, Side 2, and so on.), and then placing it 
in a certain manner to create the 3D effect. These graphic elements should be identically (or 
similarly) sized in your Preview and Program windows.

The following topics provide more information on creating 3D animated objects using 
Depth Rotation:

• “Creating a Cube-like Motion with a Graphic on Two Sides” on page 571

• “Creating Motions on Large Images for Real-time Playback (Pan & Scan)” on page 574

Creating a Cube-like Motion with a Graphic on Two Sides

To create a “cube-like” motion with a graphic on two sides:

1. Create two identically sized graphics. Create Side 1 in your Program window, and create 
Side 2 in your Preview window.

Side one (Program)Side two (Preview)
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2. Create two actions, one for Play-off and one for Play-on. Each action should have 
identical timing for the full duration of the Motion. Each action should have a Y Rotate 
parameter set as follows:

a. On the Program window graphic element (Side 1), the Y action should be 0 to +90 
degrees.

n For a “slab-like” motion, the Y action should be 0 to +180 degrees.

b. On the Preview window graphic element (Side 2), the Y action should be -90 to 
0 degrees.
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n For a “slab-like” motion, the Y action should be -180 to 0 degrees.

3. To control the depth, select the Z origin parameter for both actions. It must also have 
identical attributes to control the “seams” of the box.

4. Position the cursor in the Timeline Graph, in the center of the yellow Bézier handle, and 
drag the handle upward to adjust the degree of depth that you want. 

n The position of this handle varies based on the size of your text, but this Z Origin position 
should be identical for both Program and Preview Actions.

The following illustration shows what your final product should look like in the 
Output window.
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Creating Motions on Large Images for Real-time Playback 
(Pan & Scan)

Pan & Scan allows you to create Motions on large images for real-time playback, 
eliminating rendering time and allowing you to get graphics to air faster. 

To create motions on large images for real-time playback:

1. From the Background Shader dialog box, open your high resolution image.

2. Select Auto Scale > zoom.

3. Set the pixel aspect to indicate the pixel aspect ratio of the image file.

4. Draw a rectangle on the screen to be used as a “viewport” to control which portion of 
the high resolution image is visible. This layer is where you zoom into an area of the 
image. To insure that there is no distortion of the image (maintain the original aspect), 
make sure that the rectangle has the same proportions as the full screen (for example, 
4:3 or 16:9). 

5. In the Style (Rectangle) window, click the Layer button.

6. In the Use Rectangle as: menu, select zoom viewport.

n Delete extra details such as edges, shadows, and so on, and make sure that the rectangle has 
a “Face” detail.

7. From the Background Shader, to view the image in an “editing mode,” select Autoscale 
> zoom_edit. This allows you to see the entire image, and displays the “viewport” as a 
semitransparent rectangle.

8. Move and size the viewport so that it contains the portion of the image that is shown at 
the end of the motion.

9. In the Background Shader window, select Auto Scale > zoom. This enables you to see 
the viewport area of the image expanded to fill the full screen. The types of zoom 
options are described:

- Fullscreen enables you to see the entire background texture on the screen, without 
zooming. This allows you to move the layer to select the portion of the texture that 
will be scaled to full screen.

- Zoom enables you to work with the rectangle in its default (hidden) state.

- Zoom_Show enables you to work with a visible rectangle-displaying in 
semi-transparent red.
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- Zoom_Edit enables you to see the entire background texture on the screen, without 
zooming. This allows you to move the layer to select the portion of the texture that 
will be scaled to full screen.

n You can move and size the viewport rectangle while in zoom mode (when resizing with the 
mouse, hold the Control key down to maintain aspect). The visible portion of the high 
resolution image changes interactively.

zoom_show mode is the same as zoom, except that the viewport rectangle is displayed in a 
semi-transparent color.

c When you save your graphic, it always saves in the zoom state.

Click here and 
then select one of 
the Zoom items.
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Making a Zoom Motion

A Zoom motion gives an effect of zooming in on the graphic.

To make a Zoom motion:

1. Type a name for your zoom layer (for example, zoom). This makes identifying it easier, 
especially if you have other layers in your graphic.

2. From the Motion editor, add a Play-on Action and specify the layer name.

n It’s OK, and even recommended, to keep the default Play-off Action.

3. Enable both X and Y Scale Parameters.

4. Add another Play-on Action.

5. For the new Play-on action, select Object > Background. This is required.

n You might want to deselect the opacity parameter on that object, so that it does not fade in as 
the motion is played.

6.  Play the Motion.

The start of the Motion is zoomed IN because your Zoom Layer is scaled small, 1 pixel 
x 1 pixel (Image A). The Motion zooms OUT to end in the (home) state of your Zoom 
Layer (Image B).
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n Because this motion is scaling the Zoom layer (not the Background), it is important to 
remember that the smaller the size of the Zoom Layer, the more the Background is zoomed.

7. To change the start position for your Motion, do the following:

- Enable Position parameters on the zoom layer Action.

- Click the menu in the graph view.

- Select the screen position for your Motion to start from (for example, Center to 
Home).

8. Set the last point to Home position for both X and Y Position Parameters.

9. Play the Motion.

Image A Image B
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10. Make your zoom more interesting by adding additional layers, such as a text overlay and 
Cel Animation, to indicate a location. Experiment with Deko’s 3D effects for a more 
interesting perspective. Any opacity control and 3D effects (such as Tiles, Page Scroll, 
and so on) should be applied to the Background Action.

n 3D Effects look best if the zoom rectangle starts at a large size (that is, scale of 3 or 10), so 
that the entire high resolution image is visible at the start of the motion.

The following topics provide more information about making a zoom motion:

• “Defining the Motion Origin Point” on page 578

• “Using Differential Motions” on page 581

Defining the Motion Origin Point

Deko provides you with control over how your graphics are displayed. This is done by 
letting you define the Origin point in X, Y, and Z space for Scale and Rotation parameters. 

To define the motion origin point:

1. Open any full screen graphic to the Preview channel.

2. From the Motion Editor, click the Play-on Action button.

3. Select the Y Rotation Parameter. 
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4. Scrub your Motion and look at your output. 

The default location for the Origin point is the center of the screen. 

5. To modify the location of the Origin point, select the X Origin parameter. 

6. A yellow horizontal line appears in the Graph view as your control handle as well as a 
small menu for choosing a reference point for the origin.

X Default origin point
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7. Select one of the following options from the menu:

t Offset Center uses the center of the object as a reference point.

t Offset Left uses the left side of the object as a reference point.

t Offset Right uses the right side of the object as a reference point.

If you selected Offset Left, your output should resemble Image A in the following 
illustration. If you selected Offset Right, your output should resemble Image B in the 
following illustration. 

8. Click the yellow control handle and drag it upward or downward for tighter (finer) 
control of the origin location.

Click the 
arrow to 
display the 
menu

Image A Image B
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9. If you want your Origin point to change over time, insert key frames along your Motion 
Timeline. For example, the following graph view indicates an Origin point that begins at 
the Center of the Object’s X Origin, then moves Right, then Center again.

Using Differential Motions

Differential Motion can be used to draw more attention to on-screen information that is 
changing (updating), by inhibiting the motion when the data is not changing. Using this 
feature, only text or images that have been updated will animate or transition on screen.

Normally, each play-on motion specifies "Force Play", which causes the action to play 
regardless of whether the data is changing.  To inhibit the action in cases where the data in 
the Play-on (Preview) graphic matches the data in the Play-off (Program) graphic, uncheck 
"Force Play".  This causes the data to be compared, playing the action only if the data is 
changing.

Differential Motion can be applied to a single Layer, a Layer Group (via the wildcard 
naming convention), Background or Background Clip.
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Differential motions work only on unique layers. You can build your graphics with 
individual layers that you want Deko to compare for the transition, such as the leader board 
image.

n Avid always recommends that you name your layers and order them appropriately for fast 
Motion creation and Automation control.

To use differential motions:

1. In the Motion Editor, create two actions (a Play-off Action, and a Play-on Action).

2. For both Actions, select Object > Layer.

3. Select Layer name or number > All Remaining.

4. Click on the Play-on Action.

De-select Force Play

Select Play-on

Select All Remaining



Making a Zoom Motion

583

5. Deselect the Force Play check box. 

This distinguishes the Action as Differential.

6. Apply some effects to your transition. 

n The Play-off Action can be different from the Play-on Action.

7. Place the same graphic on both Preview and Program Channels. 

8. Edit the layers in Preview and play your Motion to see the ease of animating only the 
data that changes.
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Using Auto-Motions
The Auto-Motion feature enhances Deko’s play-on/play-off transition workflow by enabling 
a more “automatic” way of animating graphics back to back. This is done by allowing you to 
select predefined transitions between graphics. By predefining graphic classifications, every 
graphic can be assigned a certain classification during preproduction, so that during playout, 
the proper transition is automatically applied without user intervention.

See the following topics:

• “Understanding Motion Playback Compared with Auto-Motions” on page 585

• “Motion and Auto-Motion Terminology” on page 585

• “Triggering Associated Effect Playback” on page 586

• “Determining the Associated Effect” on page 586

• “Determining if Auto-Motion Is Available” on page 587

• “Determining Which Auto-Motion Is Used” on page 587

• “Viewing Selected Motions and Graphics for a Graphic Class” on page 590

• “Checking Auto-Motion Files” on page 591

• “Checking Auto-Motions” on page 591

• “Saving an Auto-Motion File with a New Name” on page 591

• “Saving an Auto-Motion File” on page 591

• “Opening an Auto-Motion File” on page 592

• “Editing a Graphic Class” on page 592

• “Deleting a Graphic Class” on page 593

• “Setting a Graphic’s Class in a Graphic” on page 593

• “Effect Playback and Auto-Motions” on page 594

• “Play-On and Play-Off Motions” on page 595
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Understanding Motion Playback Compared with Auto-Motions

To use Auto-Motions, you should first understand how motion playback worked in previous 
versions of Deko. Deko’s motion playback was designed to play actions contained in a 
single motion file. In this file, you specified actions for graphical elements known to exist in 
both Preview and Program channels at the time of playback. This method was and is useful 
for scripted situations. 

However, for situations where you want graphics to play in near-random order, Avid 
recommends that you use the Auto-Motion feature. This feature allows you to create a 
motion file for play-on actions and another motion file for play-off actions. At motion 
playback time, the play-on actions associated with the Preview graphic are combined with 
the play-off actions associated with the Program graphic. Creating the association between 
individual motion files and their graphics is done through graphic classes. Each graphic class 
has an associated play-on file and play-off file, as well as an optional update motion file. The 
Auto-Motions method reduces the number of motion files because the play-on actions are 
defined separately from the play-off actions.

Motion and Auto-Motion Terminology

In order to include Auto-Motions into the existing motion playback method, some of the 
terminology used in previous versions of Deko has been changed to make the enhancements 
to Deko’s Motion features more clear. This shift in terminology also allows additional terms 
to be added to Deko’s vocabulary.

Motion Term Description

Play-On Action 
(formerly Preview 
Action)

Play-On Action was previously referred to as Preview Action. It refers to an 
action that affects graphical elements contained in the preview document. It is 
used to transition these elements “on-air”.

Play-Off Action 
(formerly Program 
Action)

Play-Off Action was previously referred to as Program Action. It refers to an 
action that affects graphical elements contained in the program document. It is 
used to transition these elements “off-air”.

Play-On Motion The motion file contains play-on actions only.

Play-off Motion The motion file contains play-off actions only.

Update Motion The motion file contains play-on actions and play-off actions. This motion is 
intended for transitioning between graphics that are of the same graphic class. 



12  Creating Custom Motions

586

Triggering Associated Effect Playback

Deko uses several methods to trigger an associated effect. These include the following:

• Pressing the FastAction Keyboard keystroke combination Ctrl + Play.

• Playing a sequence where the effect column is set to associated.

• Using a single-effect playback view where the effect is set to associated.

• Executing the macro command “play_associated_effect” either from the command bar 
or from a user-defined macro.

• Using certain external playback controllers like Avid Command or Avid Deko Playback 
Controller.

• Reading a graphic into Preview when the option “Automatically play associated effects” 
is selected. This includes manually reading the graphic by selecting File > Open, 
reading the graphic via keyboard, or automation systems reading the graphic.

Determining the Associated Effect

When an associated effect is triggered to play, Deko determines the effect as follows:

• If the preview graphic has a linked .efx or .mot file, that is the associated effect.

• Otherwise, if there is an Auto-Motion, that is the effect.

• Otherwise, a cut is the associated effect.

Graphic Class Used to define a group of graphics that have a common function. For example, a 
lower-third Reporter class could include all graphics of that type. When a 
transition is invoked, the Graphic Class determines the play-on, update, and 
play-off motions, as well as the base graphic.

Enabled Check the Enabled box to activate Auto-Motion for the specified class.

Base Graphic The base graphic is a .dko file that is used as an alternative to a blank screen. It 
automatically opens in the preview window when Deko infers that you want to 
transition to a clear graphic.

Default Class A graphic class that applies when no other graphic class is assigned. The 
Default class allows you to specify generic play-on and play-off motions that 
are appropriate for a wide variety of graphics. This class also allows a base 
graphic.

n The Default class does not allow update motions.

Motion Term Description



Using Auto-Motions

587

Determining if Auto-Motion Is Available

Auto-Motion is available if the current Auto-Motion table (.amt file) is enabled and the 
Preview graphic or the Program graphic has a graphic class or if the default class is enabled.

Determining Which Auto-Motion Is Used

The Play-on class is the graphic class of the Preview graphic and the Play-off class is the 
graphic class of the Program graphic. 

n If the default class is enabled, it is the Play-on or Play-off graphic class. That is, if no other 
class has been specified for the graphic.

The Auto-Motion is constructed as follows:

• If the Play-on class and the Play-off class match, the Auto-Motion is the Update Motion 
for that class.

• Otherwise, if the Play-on class and the Play-off class do not match, the Auto-Motion is 
created by combining the Play-On motion of the Play-on class (with the Play-off motion 
of the Play-off class).

• Otherwise, if there is a Preview class and no Program class, the Auto-Motion is the 
Play-On motion for the Preview class.

• Otherwise, if there is a Program class and no Preview class and the Preview graphic is 
empty, the Auto-Motion is the Play-Off motion for the Program class.

• Otherwise, the Auto-Motion is a cut effect.

• If the Preview graphic is erased (empty), the base graphic (specified in the graphic class 
of the Program graphic) is loaded into Preview. If this base graphic has a linked .efx or 
.mot file, that is the Auto-Motion. Otherwise, we used the rules stated above.

Adding a Graphic Class

Deko enables you to add a graphic class, including its name and its relationship to the 
motion files (play-on, update, and play-off).

To add a graphic class:

1. Select View > Auto-Motion.
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The Auto-Motion window opens, enabling you to set the relationship between a Graphic 
Class and its motions from a centralized location.

n Graphic Classes cannot be reordered (for ease of grouping) at this time.

2. To enable auto motions on this system, select the Enable Auto-Motion check box. 
Deselecting this option causes Auto-Motion to be ignored during Motion Playback even 
if the individual classes are selected.
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3. Click the Add Class button. 

The Add Graphic Class dialog box opens.

4. Type a name for the new graphic class in the Graphic Class Name text box.

5. In the Play-On Motion text box, click the Browse (...) button to navigate to and select a 
Play-On motion for this Graphic Class. This motion plays when the Preview channel 
contains a graphic belonging to this graphic class. It should contain Play-on (formerly 
known as Preview) actions only. All others are ignored.

6. In the Update Motion text box, click the Browse (...) button to navigate to and select an 
Update motion for this Graphic Class. This motion plays when the Preview and Program 
channels contain graphics belonging to the same class. The motion should contain 
Play-on (formerly known as Preview) and Play-off (formerly known as “Program”) 
actions.

7. In the Play-Off Motion text box, click the Browse (...) button to navigate to and select a 
Play-Off motion for this Graphic Class. This motion plays when the Program channel 
contains a graphic belonging to this graphic class. It should contain Play-off (formerly 
known as Program) actions only. All others are ignored.

n The Auto-Motion feature combines separately saved Play-On and Play-Off motions at the 
moment the associated effect is triggered to play. Auto-Motion playback uses the same 
keystrokes required for playing associated effects.
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8. (Option) In the Base Graphic text box, click the Browse (...) button to navigate to and 
select a Base graphic for this Graphic Class. The base graphic can contain elements such 
as a station logo or number.

9. Click OK. 

A new class is added to the bottom of the table.

10. Once you have added a graphic class, you can edit or delete it.

t To edit an existing graphic class, click the Edit Class button. For more information, 
see “Editing a Graphic Class” on page 592.

t To delete a graphic class, click the Delete Class button. For more information, see 
“Deleting a Graphic Class” on page 593.

Viewing Selected Motions and Graphics for a Graphic Class

Once you have added a graphic class, you can view the graphic class motions and graphics 
that you have selected for that graphic class. This includes Play-On motions, Update 
motions, Play-Off motions, and base graphics.

To view selected motions and graphics for a graphic class:

1. Select View > Auto-Motion.

The Auto-Motion dialog box opens, enabling you to set the relationship between a 
Graphic Class and its motions from a centralized location.

2. Do one of the following:

t To view the Play-on Motions, click the View Play-On Motion button. The motion 
window opens with your selected Play-On motion loaded. Make changes to the 
motion as desired.

t To view all available Update motions, click the View Update Motion button. The 
motion window opens with your selected Update motion loaded. Make changes to 
the motion as desired. 

t To view all available play-off motions, click the View Play-Off Motion button. The 
motion window opens with your selected Play-Off motion loaded. Make changes to 
the motion as desired. 

t To view the base graphic of the selected graphic class, click the View Base Graphic 
button. The Base graphic opens in the Preview window.
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Checking Auto-Motion Files

To verify that Deko can find all files in the Auto-Motion window: 

1. Click the Check Files button. 

A message box opens if files are missing. 

2. To browse for missing files, click Yes and then navigate to the file you want.

Checking Auto-Motions

To see which motion files would be used for a particular transition:

1. Open the current on-air graphic into Program.

2. Open the next graphic to be displayed into Preview.

3. Click the Check Auto-Motions button.

A message box opens reporting the motion file names that will be used for the 
transition.

4. Click OK.

Saving an Auto-Motion File with a New Name

To save an auto-motion with a new name:

1. Select File > Save As.

The File Save Auto-Motion As dialog opens and populates the directory path with the 
current motion path.

2. Select the Auto-Motion file you want to save with a new name.

3. Type a new name for the file, and click Save.

A new .amt file is created with the new name.

Saving an Auto-Motion File

To save an auto-motion:

t Select File > Save.

Changes to the .amt file are saved.
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Opening an Auto-Motion File

In order for you to see the available graphic classes in the Graphic Class field in the Style 
dialog box, graphic classes must be defined.

To open an Auto-Motion file:

1. Select View > Auto-Motion.

2. Select File > Open. 

The Open dialog box populates the directory path with the current motion path. 

3. Select the .amt motion file you want to open, and click Open.

Editing a Graphic Class

Once you have added a new graphic class, you can edit it. However, you cannot edit a 
graphic class name.

To edit a graphic class:

1. Select the graphic class you want to edit from the list.

2. Click the Edit Class button.

The Edit Graphic Class dialog box opens to the graphic class you selected.
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3. Change information for any of the following:

t If you want to change the Play-On motion for this graphic class, click the Browse 
(...) button next to the Play-On Motion text box, and navigate to and select a 
different Play-On motion for this Graphic Class.

t If you want to change the Update motion for this graphic class, click the Browse 
(...) button next to the Update Motion text box, and navigate to and select a different 
Update motion for this Graphic Class.

t If you want to change the Play-Off motion for this graphic class, click the Browse 
(...) button next to the Play-Off Motion text box, and navigate to and select a 
different Play-Off motion for this Graphic Class.

t If you want to change the Base graphic for this graphic class, click the Browse (...) 
button next to the Base Graphic text box, and navigate to and select a different Base 
graphic for this Graphic Class. 

n The base graphic can contain elements such as a station logo.

4. Click OK. 

The graphic class is modified.

Deleting a Graphic Class

Once you have added a new graphic class, you can delete it.

n The Default Class cannot be deleted.

To delete a graphic class:

1. Select a class you want to delete from the list.

2. Click the Delete Class button.

Deleting the selected class removes the selected graphic class from the list. 

Setting a Graphic’s Class in a Graphic

When you create or change a Graphic Class in the Graphic Class Transition table, those 
changes are reflected in the Style Menu, Graphic Class list. 

To set a graphic’s class in a graphic:

1. Do one of the following:

t Select View > Style/Layer/Graphic

t Select Graphic > Properties
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2. Click the Graphic button. 

The dialog box opens.

3. Select a Graphic Class that you want to associate with this graphic from the Graphic 
Class list. 

4. Save the graphic with the new Graphic Class associated.

n Linked effects that are associated with a graphic override graphic classes.

Effect Playback and Auto-Motions

There are two ways of triggering an Auto-Motion. Auto-Motions play back automatically 
via the DekoPBC, Command, or third-party controllers when you select Options > 
Preferences. On the Common tab, select the “automatically play associated effects” option. 
Make sure that you have the Preview window selected before playing back an Auto-Motion.

Auto-Motion playback uses the same keystrokes required for playing associated effects.

To play back Auto-Motions:

t Do one of the following:

- From the FAK, select a Preview channel, and press Ctrl+Play.

- From a Standard keyboard, type the command “play_associated_effect” command 
in the command line.
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Play-On and Play-Off Motions

To understand how Deko uses Play-On and Play-Off motions, see the following examples. 

The following screen example shows the “UpperLeft_on.mot” in the Motion Editor. Note 
the .5 second duration. 

n Actual operation does not require the Motion Editor to be open.

The following screen example shows “Locator_Off.mot” in the Motion Editor. Note the 
1-second duration.

The following screen uses the Deko Motion Editor to illustrate how Deko combines the 
Play-on and Play-off motions into one. 
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Consider the following whenever combining motions:

• Whenever Auto-Motions are triggered, the combined motions replaces whatever actions 
were in the Motion Editor. This allows you to see what files are being combined, but 
removes existing actions in the editor. 

• The overall motion duration is set to whichever motion is longer between the current 
Play-Off and Play-On motions. 

Using Motion-in-Motion
The Motion-in Motion feature allows motion actions to treat graphic layers as a hierarchical 
group in terms of transformation and timing. “Parent” motion actions are applied in addition 
to “child” motion actions on the same graphical object or objects. 

n Motion-in Motion does not apply to non-CG elements (Background Clips, Input Video, 
DekoObjex).

Specifying Parent Motion Actions

n Certain user interface illustrations in this document might not display the Is Parent option.

To specify parent motion actions:

1. Select View > Motions to activate the Motion Edit window. 

2. Insert an action.

3. Specify the action as a parent action by clicking the Is Parent option.

Object is Parent option
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4. Consider the following about parent and child actions:

- Parent actions can be paused at the end to allow Behaviors, CAPS, and Power Clips 
to persist before the effect ends.

- When parent actions are present, multiple selection of actions are not allowed.

- DVE Effects are not allowed on parents.

- Sound effects are allowed on parent and child actions.

5. Specify the type of parent object that you want to use for this motion by selecting one of 
the following options:

t Graphic (entire graphic, including the background)

t All layers (entire graphic, excluding the background)

t Layer (user-specified group of layers using a wildcard name that cause child layers 
to be treated as a group)

6. Specify the timing of the action.

n The timing of the child action is scaled into the timing of the parent action. A child action’s 
In and Out times cannot exceed those of its parents. 

7. (Option) To scale the timing of a motion, add an “entire graphic” action, make it a 
parent, and then change its In and Out times. This replaces the motion_scale 
command.

8. (Option) To scale the timing of certain motion actions, add a layer action, make it a 
parent, enter a wildcard name that groups desired child actions in the motion, and then 
change its In and Out times.

n A single motion file can contain one play-on graphic parent, one play-on all-layers parent, 
and several play-on layer parents. Additionally, it can contain one play-off graphic parent, 
one play-off all-layers parent, and several play-off layer parents. A layer parent is treated as 
a child of the all-layers parent or the graphic parent. The all-layers parent is treated as a 
child of the graphic parent.

For more general information on creating Motions, see “Creating Custom Motions” on page 
521. 

Using Differential Motion with the Motion-in-Motion Feature

When using the Motion-in-Motion feature, a Parent can specify that it's children “Play as 
Group”. This means that if any child will play (due to Force Play or changing data) then 
every child will play the Parent's Action, but not it's own action. A child will play it's own 
Action only if designated to Force Play or it's data is changing.
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Assigning Content-Independent Sound Effects to 
Deko Motions

Content-Independent sound effects allow audio (.wav) files to be integrated with Deko 
Motions (Actions). 

To assign content independent sound effects to Deko motions:

1. Place your .wav files in a folder on your system.

2. From the Motion Editor, create an Action that references a layer of a graphic. 

3. Select Object > Layer.

4. Select > Effect > Screenmove. 

Additional fields display in the Motion Editor.

5. In the Sound file area, click the navigation ... button.

The Select sound file dialog box opens.

Navigation button
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6. Locate and select your .wav file.

n Sample bit rate on .wav files must be 48khz.

Since this .wav file is linked directly to the Action, it behaves as your animation 
behaves. For example, if the Object menu is set to Layer, then the .wav file plays only 
once. If the Object menu is set to Row, then the .wav file plays for each row in your 
Layer. If the Object is set to Word, it plays for each Word in your Layer. And the same 
logic applies for Characters.

7. To refine this sound effect, add some delay to the start of your sound file by typing or 
using the arrows next to the Delay start of sound by field in frames and seconds. 

8. To raise or lower the volume, drag the Volume slider to the left to raise the volume, or to 
the right to lower the volume.

Applying Sound Effects to Motions Exercise

To test how sound effects work when they are applied to motions:

1. Type 2 rows of text in a single layer. 

2. Apply a sound effect. For more information, see “Assigning Content-Independent 
Sound Effects to Deko Motions” on page 598.

3. Select Object > Layer.

4. Play your Motion. 

The sound should play only once.

5. Select Object > Row.

6. Play your Motion. 

The sound should play twice (once for each row).

7. Select Object > Word.

The sound should play for each word you typed in your graphic.

8. Select Object > Character. 

Volume slider
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The sound should play for each character you typed in your graphic.



13 Creating Animated Graphics

Any Deko graphic can be animated using the techniques discussed previously. However, 
here you are provided with specific instructions for creating some typical on-the-job 
animations, including:

• Animating a bulleted list, so the bulleted items appear one by one.

• Creating and playing a credit roll or other type of roll.

• Creating and playing a crawl.

• Creating a 3D scene, exporting it as a Deko3D (D3D) file (via the Deko3D Exporter), or 
as .dae (COLLADA) files (via the 3D Studio MAX FBX plugin), importing it into the 
Deko Motions directory, and playing it in Deko.

The following topics describe how to create animated graphics:

• “Animating Layers in a Graphic” on page 602

• “Creating Rolls and Crawls” on page 608

• “Creating Glows and Blurs” on page 617

• “Using the Deko3D Feature” on page 622
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Animating Layers in a Graphic 

Individual layers in a graphic can be animated so they appear at different times, from 
different directions, and with a different effect. 

For information on animating layers in a graphic, see “Adding Motion to Your Bulleted List” 
on page 602. Although the procedure refers to a graphic that is a bulleted list, the concept 
applies to any Deko graphic with multiple layers.

Adding Motion to Your Bulleted List

In Creating and Using a Full Screen Bulleted List, we discussed how to create a full screen 
bulleted list. If you have created and saved such a graphic, open it now, and follow the 
instructions for adding motion to it.

Once you have a bulleted list open in your Program window, you need to name the layers of 
the list and add motion to the list (so the bullet points appear one by one.) 

The following topics provide more information about adding motion to your bulleted list:

• “Naming the Layers of the Bulleted List” on page 602

• “Adding Motion to the Bulleted List” on page 604

Naming the Layers of the Bulleted List

To name the layers of the list (preparing for motion):

1. Open the graphic in the Program window.

2. Open the Layer Browser by doing one of the following:

t Select View > Layer Browser.

t Press Shift+Ctrl+B.

3. Select the layer for the first bullet point. 

When you have highlighted the layer in the browser, selection points surround the layer.
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4. Right-click the Layer browser picon and select Edit layer name.

5. In the Name text box, type a name for your first layer.

6. Click anywhere on the screen to accept the change.

7. Select the remaining bullet point layers to name them. 

n To make it easy, name each layer with the same name, but use sequential ending numbers 
(such as place1, place2, place3, and so on.)

8. Select the title layer. 

n Use the title, or an abbreviation as the title layer name.

9. Save your graphic.

10. Add motion to your graphic. For more information, see “Adding Motion to the Bulleted 
List” on page 604.

Right click the Layer 
Browser picon.

Select this menu item.

Type the name here.
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Adding Motion to the Bulleted List

After the layers of your bulleted list are named, you can add motion to the bulleted list to 
make the bullets appear one by one.

To add motion to the bulleted list: 

1. Select Motion layout by doing one of the following:

t Select View > Motion.

t Press Shift+Ctrl+M.

2. Click on the Preview window to set focus to it. 

3. Open a file containing a bulleted list.

4. If you have just built a list in the Program window, place your graphic in the Preview 
window by doing one of the following:

t Select Channel > Program to Preview. 

t Press F3 (SK).

t Select Motion layout, and press Program to Preview (FAK).

5. In the Motion window, click the Clear Motion button.
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6. In the Effect/Object area, select Graphic > Prv (Preview). 

7. In the Effect/Object area, select Object > Background. 

Select Preview
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n If you are repeating this step as specified in Step 12, select layer and specify the next layer 
you want to move.

8. In the Parameters section, do the following:

- Select Position.

- Select X Position. 

9. Under Timeline Graph, click the Down arrow to select how you want your text to move.

n Right to Home is the typical choice for items in a list. 

Select Background

Click here.

Select Right to Home.
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10. Above the Timeline Graph, specify the length of time (in seconds or frames) for the 
motion. 

11. In the Timing section, click the Out point (caret or triangle) for the bottom timing bar, 
and drag it to the left until it displays an appropriate Out time.

12. Click the New Action button.

13. Select Object > Layer.

14. From the Layer name or number menu, select the name of your Title layer. 

15. Repeat Steps 4 - 11, above, for each layer in the graphic.

16. In the Timing section, do the following:

t Click the In point and drag it for each timing bar. 

n The Out point of the previous action is a good choice for this In point. 

t Click the Out point and drag it for each timing bar.

n An Out time that is one second higher and ten frames more than the previous is a good 
choice. 

17. Set the offset to Sequential for each Action.

18. Click the Play button to preview your graphic with motion. 

19. Edit (tweak) your motion as desired. 

Use the arrows to select a 
length of time

Click and drag the 
Out point
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20. Select File > Save Motion As. 

The Save Motion As dialog box opens.

21. Type a name for your motion file in the File name text box. 

22. Click Save to save the motion.

Creating Rolls and Crawls

A roll is text moving vertically, line by line, usually from the bottom of the screen to the top. 
Credit rolls are a staple of television production. Occasionally rolls are used in other 
situations, such as displaying background story information.

n Inherently, moving video text up or down produces interlace artifacts, giving the text in rolls 
a jagged appearance. Deko provides a built-in solution to always produce the smoothest roll 
possible. 

A crawl is text moving horizontally across the screen. Crawls are typically used for 
displaying information that interests viewers only selectively, such as stock prices, school 
closings, or scores of all teams playing on a given afternoon.

Deko crawls can be used in any combination of typefaces. The default position of the crawl 
is at the bottom of the screen, but this can be easily changed. You can have up to four 
different crawl lines on the screen, each going at a different speed.

The following topics provide more information about creating rolls and crawls:

• “Creating and Playing Rolls” on page 609

• “Creating and Playing Crawls” on page 613
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Creating and Playing Rolls

When creating and playing rolls, you need to first compose a graphic for the roll effect. Once 
the graphic is composed, you need to add and run the roll effect in the Sequence window. 
You can also specify to roll text within a layer, and adjust the duration or spacing of the roll 
for smooth playback, and import a text file for a roll.

n This feature has limitations on some models.

The following topics provide more information about creating and playing rolls:

• “Composing a Graphic for a Roll Effect” on page 609

• “Running a Roll Effect” on page 610

• “Rolling Text within a Layer” on page 610

• “Adjusting Duration or Spacing for Smooth Roll Playback” on page 611

• “Importing a Text File for a Roll” on page 611

• “Changing Speed During Roll Playback” on page 612

• “Embedding Speed Changes in a Roll Graphic” on page 612

Composing a Graphic for a Roll Effect

To compose a graphic for a roll effect:

1. Using the Style Edit layout, click a Graphic window (F5). 

2. Select a style.

3. Select Text > Vertical Scrolling. A scrollable graphic can be higher than one screen 
high. A scroll bar appears on the Graphic window, allowing you to move through the 
roll file.

4. Compose the text for the roll, scrolling down as necessary. If you want the last line of 
text to roll completely off the screen, press Enter several times after the last line of text 
to provide a blank screen at the end of the roll.

5. Save the graphic by doing one of the following:

t Press F12 (SK).

t Press Save File (FAK).
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Running a Roll Effect

To run a roll effect:

1. To activate the Sequence window, do one of the following:

t Press F11(SK).

t Press Seq Edit (FAK).

The Sequence window opens.

n If there is already an open Sequence window, select Sequence > Clear Sequence to clear it. 

2. In the File name field, either type the graphic’s file name, or click the Browse button to 
locate the file. Once entered or selected, the file name appears in the File name field.

3. Select Effect > Roll.

4. In the Rate text box, type a playback rate. 

5. To run the effect, do one of the following:

t Press Alt+Enter (SK).

t Press Play (FAK).

Rolling Text within a Layer

To roll text within a layer:

1. Set focus to either the Sequence or Effect window by clicking on the title bar. If using 
the Sequence window, click the event that specifies the roll.

2. Click the Options button for the effect.

3. Select In Layer. Rather than rolling text down the center of the screen, Deko confines 
this roll to the bounding box of the layer.

n When you specify a roll “In Layer”, Deko clears the Program graphic before playing the 
roll.
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Adjusting Duration or Spacing for Smooth Roll Playback

To adjust duration or spacing for smooth roll playback:

1. Activate the Sequence window (F11).

2. Select Sequence > Smooth Roll Playback Adjustment, and then select one of the 
following:

t None - Turns off Smooth Roll Playback Adjustment. Deko does not suggest any 
adjustments.

t Full and Half Vertical Resolution Rates - Deko suggests adjustments based on 
acceptability of full and half vertical resolution rates. Allows some aliasing.

t Only Full Vertical Resolution Rates - Deko suggests adjustments based on 
acceptability of full vertical resolution rates only. Allows only clean rates.

3. Click OK or press Enter.

n When you enter a playback rate for a roll effect, Deko displays any suggested adjustments in 
a dialog box. You can decide to decrease or increase duration of the roll or original line 
spacing of the graphic. Line spacing adjustments are not offered when they would not be 
effective, for example, if the document is non-scrollable or if you select a page-per-second 
rate. 

Importing a Text File for a Roll

To import a text file for a roll:

1. Clear the Program window.

2. Select Text > Vertical Scrolling. 

The Text dialog box opens.

3. Select Word Wrap to turn word wrap on.

4. Select the style and font size you want to use.

5. To specify justification, make sure NumLock is on and use the numeric keypad for the 
following shortcut key combinations:

- Press Ctrl+7 to justify the text top, left.

- Press Ctrl+8 to justify the text top, center.

- Press Ctrl+9 to justify the text top, right.
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6. Open the file you want to import. For more information about opening files, see 
“Opening Files Using the Open Dialog Box” on page 393. 

The imported text appears with the justification, style, and size you just specified.

7. Select File > Save Graphic As. 

The Save Graphic As dialog box opens.

8. Save your new file as a .dko file.

Changing Speed During Roll Playback

To change speed during roll playback:

t Press the + and – keys.

Embedding Speed Changes in a Roll Graphic

n This feature is not available on all models.

To embed speed changes in a roll graphic:

1. Position the cursor where you would like the speed change to occur.

2. Select Text > Insert Speed.

3. Click Pause or select a speed from the menu. You can specify speed changes in 1/10 
page increments up to 1 page per second. 

Deko inserts a visible marker to show where the embedded change is.

n Leave space between changes for smooth ease in and out.

To edit embedded speed changes:

1. Select the marker for the embedded speed change you would like to edit. You can see 
the speed change in the lower left corner when you have selected the marker.

2. Do one of the following:

t Press the Delete key to delete the embedded speed.

t Select Text > Edit Speed, then click Pause or select a speed from the menu.
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Creating and Playing Crawls

A crawl is text moving horizontally across the screen. Crawls are typically used for 
displaying information that interests viewers only selectively, such as stock prices, school 
closings, or scores of all teams playing on a given afternoon.

Deko crawls can be used in any combination of typefaces. The default position of the crawl 
is at the bottom of the screen, but this can be easily changed. You can have up to four 
different crawl lines on the screen, each going at a different speed.

The following topics provide more information about creating and playing crawls:

• “Composing a Graphic with Crawling Text” on page 613

• “Running a Crawl Effect:” on page 614

• “Crawling Text Within a Layer” on page 614

• “Crawling Text Across a Specific Row” on page 614

• “Crawling Entire CG Pages” on page 615

• “Running a Continuous Crawl” on page 615

• “Changing Speed During Crawl Playback” on page 616

• “Embedding Speed Changes in a Crawl Graphic” on page 616

Composing a Graphic with Crawling Text

To compose a graphic with crawling text:

1. Select the Style Edit layout and click a Graphic window (F5).

2. Select Text > Horizontal Scrolling. 

A horizontal scroll bar appears at the bottom of the window, allowing you to move 
forward and backward in the crawl text.

3. Compose the text for the crawl. If you are composing more than one row of text to 
crawl, use the Enter key to create up to three additional rows. 

n Do not use the Enter key if you are composing a single row of crawling text.

4. Select File > Save Graphic As to save the graphic.

n You can create multi-row crawls of up to four rows of text.
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Running a Crawl Effect:

To run a crawl effect:

1. Click the Sequence window (F11) or the Effect window.

2. Do the following:

t Type the file name for the graphic.

t Specify “crawl” as the effect, and enter a playback rate.

3. Press Alt+Enter to run the effect. For more information, see “Creating Sequences” on 
page 504.

n By default, text composed without selecting horizontal scrolling crawls across the bottom of 
the screen. You can change the position of such a crawl by crawling text within a layer or by 
crawling text across a specific row, as described.

Crawling Text Within a Layer

To crawl text within a layer:

1. Click the Sequence window or the Playback window. If you are working in the 
Sequence window, click the event that specifies the crawl.

2. Click the Options button for the effect.

3. Select In Layer. 

Rather than crawling text across the entire width of the screen, Deko confines this crawl 
to the bounding box of the layer.

Crawling Text Across a Specific Row

To crawl text across a specific row of the screen:

1. Compose a graphic for a “crawl” effect. For more information, see “Composing a 
Graphic with Crawling Text” on page 613.

2. Before you save the graphic, do one of the following:

t Move the cursor to the top row of text. Press (Alt+hyphen) to move the text down to 
the desired screen location.

t Move the bottom edge of the layer’s bounding box.

3. Run the crawl effect. For more information, see “Running a Crawl Effect:” on page 614.

n The crawl effect operates on a single layer of text. If you wish to crawl an entire graphic, 
including shapes and text, use the crawlpg (crawl page) effect. For more information, see 
“Crawling Entire CG Pages” on page 615.
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Crawling Entire CG Pages

n This feature is not available on all models.

To crawl entire CG pages:

1. When inserting the graphics into a sequence, or setting up an effect, select the crawlpg 
effect.

2. Do one of the following:

t To crawl text from right to left (normal for reading left-to-right text), select left.

t To crawl text from left to right (normal for right-to-left text), select right.

Running a Continuous Crawl

n This feature is not available on all models.

To run a continuous crawl:

1. Select View > Automation.

2. In the Automation window, specify the following:

t Select Type > I.I.I.

t Select Automation Enabled.

t Select Default Doc > Preview.

3. Select View > Effect Playback.

4. Press Play to start the crawl.

5. In the Effect Playback window, do the following:

t Select Effect > Crawl.

t Click the Options button.

The Crawl options dialog box opens.
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6. Select Continuous, and click OK. 

n This option is not available for all models.

7. Send crawl text via the Y command. The format for the Y command is: 

Y\Keyboard chars\\<CR><LF>

8. Press the Esc key to stop the crawl.

n You can change preset style during your continuous crawl by sending Y\<ESC>S1Keyboard 
chars\\<CR><LF> for Preset style 1 “S2” for Preset style 2, and so on.

Changing Speed During Crawl Playback

To change speed during crawl playback:

t Press the + and – keys.

Embedding Speed Changes in a Crawl Graphic

n This feature is not available on all models.

To embed speed changes in a crawl graphic:

1. Position the cursor where you would like the speed change to occur.

2. Select Text > Insert Speed.

3. Click Pause or select a speed from the menu. You can specify speed changes in 1/10 
page increments up to 1 page per second. 

Deko inserts a visible marker to show where the embedded change is.

n Leave space between changes for smooth ease in and out.

To edit embedded speed changes:

1. Select the marker for the embedded speed change you would like to edit. You can see 
the speed change in the lower left corner when you have selected the marker.

2. Do one of the following:

t Press the Delete key to delete the embedded speed.

t Select Text > Edit Speed, then click Pause or select a speed from the menu.
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Creating Glows and Blurs

Use Deko’s Timeline Motions to enhance your on-air look with attention-drawing effects 
that are easy to create. Deko animations can be performed full page, by row, by word or by 
character and even by character details. By hiding blurred text details and revealing them in 
the Motion, glows and blurs become very easy to incorporate into your on-air look.

To create glows and blurs, you must have the Motion Timeline interface. Select Options > 
Enabled Options to determine if this feature is turned on.

n There is a single-click process to add a Glow or Glint. For more information, see “Adding a 
Local Behavior” on page 553.

To create hidden details:

1. Create a text Style with one white face and one black shadow, then type some sample 
text.

2. Select your text and add an extra white face and white edge details at the top of the 
detail list. 

3. Set both details to blur by entering a value of 25 in the Blur box, then Hide the face and 
edge detail, keeping the face and shadow details revealed. 
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Your text might now look like this:

To animate hidden details:

1. Swap your sample text to the Preview window.

2. From the Motion Editor, click the Preview Action button. 

3. Select Object > Layer, and specify the Layer number (likely 1).

4. Enable both Scale parameters then scrub to see the effect. The Text layer should grow 
from 0 to 100% in size.

5. In the Detail range text box, specify the text details for this Action to affect. Type 3-4 
which applies to the visible details of your text. At this point, you do not see any 
changes in the effect. 

6. Copy and paste the Preview Action.

7. Select the second Action in the list. 

8. Type 1-2 in the Detail range text box, which applies to details 1 and 2 (hidden) of your 
text. 

9. Deselect both Scale parameters for this same Action. If you scrub your Motion, at this 
point you see the blurred details. 
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10. In the Timing Section, drag the In handle on the second timing bar out; and drag the Out 
handle on the third time bar in to produce a similar sequence as shown in the following 
illustration. They should only slightly overlap.

11. With the second Action selected, select Object > Character.

12. On the Timing bar for the second Action, click and drag the round offset control to 
create a time delay between each object (Character).

13. In the Graph area, click the word Opacity to reveal the relative graph, then click and 
hold the end point (keyframe) on the Bézier curve.
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14. Drag the point to the zero opacity value.

15. At the top of the Motion window, click the Insert Points tool.

16. Click in the middle of the yellow Bézier curve of the Opacity parameter. This inserts a 
middle keyframe (in red).
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17. Click the middle point and drag it to the top of the graphic to the 100% Opacity position.

18. Scrub your Motion to reveal a traveling glow across each character of your text.

You should see an image similar to the one shown in the following illustration. 

19. Adjust the effect as desired.
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Using the Deko3D Feature

With Deko3000, you can combine 3D modeling and animation power into your Deko 
graphics with real time data integration and image playback. The picture below shows a 3D 
model with real time text and images as played back in Deko. The text and images animate 
with the model as if they were created in a 3D program, but they are actually live and 
editable components of the graphic, with no pre-rendering time needed. This allows for 
greater flexibility and streamlined workflow when used with newsroom automation and 
sports interfaces for data.

The following topics provide more information about using the Deko3D feature:

• “Deko Compatibility Requirements for 3D Applications” on page 623

• “Deko3D Limitations” on page 623

• “Installing and Using the Deko3D Converter” on page 624

• “Building a 3D Studio MAX Scene” on page 629

• “Guidelines for Creating 3D Models for Use in Deko” on page 637

• “Exporting the Scene From 3D Studio MAX to D3D File Format” on page 638

• “3D Scene Checklist Before Exporting to FBX File Format” on page 639

• “Exporting the Scene From 3D Studio MAX to FBX File Format” on page 639

• “Exporting the Scene From XSI to FBX File Format” on page 640

• “3D Scene Checklist Before Exporting to COLLADA File Format” on page 643

• “Exporting the Scene From 3D Studio MAX to COLLADA File Format” on page 643
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• “Exporting the Scene From XSI to COLLADA File Format” on page 646

• “Importing the 3D Scene File into Deko” on page 649

• “About the Deko 3D Layer Mapping Table” on page 651

• “Using the Deko3D Layer Mapping Table” on page 653

• “Creating a Deko Graphic for Use with a Deko3D Motion” on page 663

• “Setting Up the Auto-Motion Table for Deko3D” on page 664

• “Playing a Deko Graphic with a Deko3D Motion Using Auto-Motion” on page 665

Deko Compatibility Requirements for 3D Applications

The Deko 3D feature supports three different file types currently:  .d3d, .dae and .fbx. The 
.d3d file format is native to Deko; .dae and .fbx file formats are non-native. Deko 3000 
systems are compatible with the following 3D modeling applications:

• For use with .d3d files, 3ds max version 2009 is supported.

• For use with .dae (COLLADA) or .fbx files, 3ds max version 2009 with FBX plugin 
2009.1 and Cinema 4D version 11 are supported.

• For use with .dae (COLLADA) or .fbx files from the XSI Application, XSI version 7.0 
or higher with Crosswalk version 3.2 or higher are supported.

Deko3D Limitations

Deko3D real-time performance might vary depending on the complexity of your scene, your 
system hardware, and whether or not anti-aliasing is enabled. 

In HD, the Deko3D graphic should not include more than one third of the screen covered. 
This includes textures that are being overlapped by other layers or textures. 

n The Deko3D feature is available on all models of Deko 3000. However, in HD, it is only 
supported on Model C or newer chassis. If you are unsure of your chassis type, please 
contact Avid Broadcast Support.
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Installing and Using the Deko3D Converter

The Deko3D Converter allows the graphic artist to preview the 3D scene with animation on 
the system that contains their 3D modeling application. The preview can include graphic 
files mapped to the replaceable layers of the 3D model, for a clearer, visual representation of 
the 3D scene as it would look during playout on a Deko system.

Also, the Deko3D Converter enables you to automatically convert .dae and/or .fbx files to 
native Deko .d3d files, via a designated watch folder. The Deko3D Converter monitors a 
specified folder for .dae and .fbx file formats. When a file is copied to the monitored folder, 
Deko3D Converter automatically converts it to the .d3d file format.

To install the Deko3D Converter on your 3D Studio MAX system:

1. On the application CD, browse to the Deko3D Converter folder and double-click the 
Deko3D_Converter_setup.exe file to start the installer. 

 The Deko3D InstallShield Wizard opens.

2.  Read the License Agreement, choose Accept and click Next to continue.

The Avid Deko3D Converter Setup Wizard opens.

3. Click Install to proceed. 

The Desktop Shortcut option opens.

4. Determine whether you want to create a shortcut on the desktop.

t If you want to create a shortcut on the desktop, select the option. 

t If you do not want to create a shortcut on the desktop, go to the next step.

5. Click Next to continue.

The Select Installation Folder window opens.
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6.  Choose the default location or browse to a different location, and click Next to 
continue.

 The Confirmation Installation window opens. The Installer is now ready to install 
Deko3D Converter on your computer. 

7.  Click Next.

Once the installation is finished, the Installation Complete window appears, stating that 
the installation was successful.

8. Click Close to Exit.

You are now ready to configure the Deko3D Converter. For more information, see 
“Configuring the Deko3D Converter” on page 626.
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Configuring the Deko3D Converter

Launch the Deko3D Converter to set up folders to monitor new or changed 3D files. Once 
these folders are set up, files that are copied or saved into the Source Folder will 
automatically be converted to .d3d files in the Destination Folder. There is also the option to 
track files in the Source Folder and, if they are updated, deleted and/or renamed, the Deko3D 
Converter will track these changes in the Destination Folder.

To configure the Deko3D Converter to monitor folders and update the file to D3D 
format:

1. Go to Start -> Programs -> Deko3D Converter to launch the application.

The Deko3D Converter opens in Preview mode the first time it is launched. Subsequent 
launches will start in whichever mode was active upon exit. All settings in the Deko3D 
Converter are saved when you exit the application, so any adjustments that were made to 
the settings will be preserved for the next launch.
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2. To open, import or save the 3D model, do one of the following:

t Select File > Open if you want to open a .d3d file (native to Deko).

t Select File > Import if you want to open and import a .dae or .fbx file (non-native to 
Deko).

t Select File > Save As if you want to save the 3D model as a .d3d file.

3. Use the Preview Options section to adjust the preview of the 3D model as follows:

t Duration – Type the number of fields in the Duration field when you want to adjust 
the length of the 3D animation preview, by a number of fields.

t Antialiasing – Select the type of anti-aliasing from the drop-down menu. 

t Aspect Ratio – Select an aspect ratio from the drop-down menu. Options are 16x9 
or 4x3.

n The Preview Options only affect the Preview of the 3D model. These options do not modify 
the model permanently.

4. Use the Actions section to control the playback of the 3D model for preview:

t  Play Once – Click the Play Once button to play the preview of the 3D model once 
with animation in the Preview window.

t Play Looping – Click the Play Looping button to loop the preview of the 3D model 
with animation in the Preview window until stopped.

t Stop – Click the Stop button to stop the animation in the Preview window from 
playing or looping.

5. The field in the Effect Layer Mapping section (similar to the Effect Layer Mapping 
Table in the Deko Application) lists the following information:

t  Deko 3D Object – The object name in the 3D model.

t  Deko 3D Material –  The material name in the 3D model.

t  Src ID –  The Source ID in the 3D model.

t Mapped to –  A temporary default file name.

n When previewing the 3D animation, it may be helpful to see an actual image where a 
“replaceable material” has been designated. To do that, supply some image file name (.bmp, 
.jpg, etc.) in the “Mapped to” field by double-clicking on the specific field to be changed. In 
the Open File dialog box, browse for the desired image file and click open. The graphic file 
name will now be displayed in the “Mapped to” field. Click Play Once or Play Looping to 
see a preview with the selected image displayed where the Deko layer will appear (during 
playback on a Deko system).
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6. Use the Deko 3D Converter to convert your files.

For more information, see “Using the Deko3D Converter” on page 628.

Using the Deko3D Converter

This topic contains information on how to use the Deko3D Converter.

To use the Deko3D Converter to monitor folders and update the file to D3D format:

1. From the Menu Bar, select Mode > Convert to switch to the Convert mode.

The Deko3D Converter opens in Convert mode.

2. In the Source Folder for Conversions field, type the path to the folder that you want the 
Deko3D Converter to monitor. Click on the Browse button to the right of this field to 
navigate to the folder.

3. In the Destination Folder for Conversions field, type the path to the folder that the 
Deko3D Converter will place the converted files. Click on the Browse button to the right 
of this field to navigate to the folder.

4. In the File Types to Convert section, select the file extensions that you want the Deko3D 
Converter to monitor, such as .d3d, .dae, or .fbx formats.

5. In the Monitor Tracking Options section, select all changes to the files that the D3D 
Converter should watch for. Options are: 

t  Track updating of source files

t  Track renaming of source files

t  Track deleting of source files
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6. In the Synchronize section, click the Start Synchronize button to initiate the D3D 
Converter to search the Source Folder for files that have been changed or deleted, and 
convert all appropriate files to corresponding .d3d files in the Destination Folder. The 
File Types to Convert section affects how Synchronize operation behaves. Synchronize 
will run the search one time then stop.

7. In the Monitor section, click the Start Monitor button for the Deko3D Converter to 
continuously monitor the Source Folder for files convert. The File Types to Convert 
section and the Monitor Tracking Options section affect how the Monitor operation 
behaves. Monitor operation will continue to search until the Stop Monitor button is 
clicked or the application is exited.

8. View the Convert Log section to see which 3D files have been changed and updated in 
the Destination Folder.

9. To exit the Deko3D Converter, select Exit from the menu. The Deko3D Converter 
remembers all of the settings (i.e. mode, aspect ratio, duration, file types to monitor, 
etc.) for the next time that it is launched.

Building a 3D Studio MAX Scene

In order to build your scene for composition with live, editable layers inside the Deko 
system, you must follow the steps in this topic. Once the scene is built in 3D Studio MAX, 
you can export it as either a .d3d, .fbx, or .dae file.

To build a 3D Studio MAX scene for import into Deko:

1. In 3D Studio MAX, select Customize > Units setup. 
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The Units Setup dialog box opens.

2. In the Display Unit Scale section, click on the Metric radio button to change the unit 
scale to Metric.

3. Click on the System Unit Setup button. 

The System Unit Setup dialog box opens.

4. Change 1.0 Units to equal 1 Meter, and click OK.

Change 1.0 Units to equal 1 Meter
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5. Open your scene and note the following guidelines:

- All objects in the scene should be within 1000 meters of the camera at all times.

- The camera should point down the Y axis, and objects should appear in the XZ 
plane (Front View).

n Any objects with Deko3D replaceable materials should be last within their parenting group 
or last in the scene, whenever possible. 
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6. Select Rendering > Environment. 

The Environment and Effects dialog box opens.

7. Click the Color button. 

The Color Selector dialog box opens.
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8. Set the RGB Ambient Lighting Value to (80,80,80) as shown in the following example.

n Ambient lighting information is not placed correctly in a COLLADA file by 3D Studio MAX.  
As a result, Deko will not be able to create any ambient lights that were placed in the model 
when saved/exported as a .dae file.

9. Access the Material Editor dialog box, and in the Specular Highlights section, set the 
value in the Specular Level field to zero (0), as shown in the following illustration. 

Set the RGB Ambient 
Lighting Value to 80, 
80, 80.
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n For best results, all replaceable materials should have specular reflexion turned off.

Specular Level field to zero (0)
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10. For Deko to recognize that a material on an object is “replaceable” (that is, that the 
material can be replaced at run-time in the Deko application), the name of the material 
must contain the string “Deko3D” followed by at least one numerical digit. The number 
immediately following the “Deko3D” string represents the “Source ID” that Deko will 
use to map one of its layers to the replaceable material in the 3D Scene. “Deko3D1”, 
“Deko3D001”, and “Deko3D001_TeamName” all specify “Source ID” 1. 

We recommend using names like “Deko3d001”, “Deko3d002, etc. to avoid confusion. 
Note that the names are not case sensitive. 

n Important:  The material itself must have a texture associated with it, and that texture must 
be assigned to the diffuse channel of the material. 

n Caution should be exercised when scaling or cropping a “replaceable” material.  In 
general, the size of the Deko layer that will “replace” the material should match its use in 
the 3D Studio MAX scene.

n Deko uses metadata to try to determine the type of Deko layer (text, image, or clip) to map 
onto the object in the 3D Scene. If the object name (or the material name) contains the 
letters “text”, “txt”, or “name”, the Deko layer is assumed to be Text (i.e. a Deko text 
layer”).  If the name contains “image”, “img”, “pic”, “logo”, or “headshot”, the Deko 
layer is assumed to be Image (i.e. a Deko “rectangle” with a “texture shader”). If the name 
contains “clip”, the Deko layer is assumed to be PowerClip (i.e a Deko “rectangle” with a 
“clip shader”).  If none of the above are found, the Deko layer is assumed to be Text.
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11. If you rotated an object around more than one axis, you need to make sure the Euler 
Parameters in 3D Studio MAX are set to YXZ. To set this parameter, go to the Motion 
Panel and do the following:

a. Click the Parameters button.

b. Click the Rotation button.

c. In the Axis Order menu, select YXZ.

You can now export your scene from 3D Studio MAX to your Deko. For more 
information, see “Exporting the Scene From 3D Studio MAX to D3D File Format” on 
page 638.

Select YXZ
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Guidelines for Creating 3D Models for Use in Deko

Here are some guidelines to follow when creating 3D scenes for use in Deko:

• It’s best to use fewer lights with higher intensities.

• It is recommended that you name all objects with unique names. This will help identify 
objects used in message logs.

• You can use Omni, Directional, and Spot lights in a scene. Animation of light 
attributes/positioning is supported by Deko3D.

• You can use basic material properties such as Faceted/Smooth, Diffuse color, Specular 
color, Specular highlight values, and Opacity. However, only a single texture mapped on 
the Diffuse color channel is currently supported by Deko3D.

• Animations of material colors is supported by Deko3D. Material texture animations are 
not.

• The following properties are not currently supported: Skinning, Morphing, Physics, 
Pixel Shaders, Animation Clips, Pivot Points, Skeletons, IK, particle systems, reflection 
mapping, hair, and other advanced features.

• (For .d3d files only) All spline-based objects (NURBS, and so on) will be converted to 
polygon meshes when exported to Deko3D. 

• (For .d3d files only) When exporting “replaceable” materials, the 3D Studio MAX 
Material Editor does not include cropping information.  In general, the size of the Deko 
layer that will “replace” the material should match its use in the 3D Studio MAX scene.

• (For .dae and .fbx files only) The following properties are supported currently:  
Transforms, Textures (stills), Materials, Exactly One Camera, Lights (spotlight, 
directional and omni) and Animations. 

Such a scene might look like this leader board example:
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Exporting the Scene From 3D Studio MAX to D3D File Format

After you have composed your scene in 3D Studio MAX, you have several choices as to 
which file format you will export it to. This section describes how to export your scene to the 
.d3d file format. 

n Exporting .d3d files requires that your models are created in 3D Studio MAX version 2009 
and that you have installed the Deko3D .d3d file converter, as described in “Installing and 
Using the Deko3D Converter” on page 624.

To export the scene from 3ds max to .d3d file format:

1. In 3D Studio MAX, select File > Export.

The Select File to Export dialog box opens.

2. Select Save as type > Deko3D Exporter (*.D3D).

3. Navigate to the folder and click the Deko3D (.D3D) file you want to export. 

The name displays in the Filename field.

4. Click the Save button. 

5. Your file has been saved as a .D3D file, and you can now import it into Deko. 

For more information, see “Importing the 3D Scene File into Deko” on page 649.
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3D Scene Checklist Before Exporting to FBX File Format

The following table provides a checklist of tasks that must be performed before exporting 
your scene to .fbx file format.

Exporting the Scene From 3D Studio MAX to FBX File Format

After you have composed a scene in 3D Studio MAX, you have several choices as to which 
file format you will export the scene to. This section describes how to export the scene from 
3D Studio MAX as an .fbx file. 

To export the scene from 3D Studio MAX to FBX file format:

1. In 3D Studio MAX, select File > Export.

Make sure you have placed only one camera in the scene.

All of the texture files needed to reproduce the scene must be transferred to the Deko, and 
the directory structure must remain the same.  For example, if an FBX model uses 
textures on the machine that is running 3D Studio MAX, and these textures are in the 
folder C:\Textures, then the texture must be transferred to Deko and placed in the folder 
C:\Textures on Deko. 

When the FBX export dialog appears, make sure to select geometry, cameras, lights and 
animations for export.
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The Select File to Export dialog box opens.

2. Select Save as type > Autodesk (*.FBX).

3. Navigate to the folder and click the 3D model (.FBX) file you want to export. 

The name displays in the File name field.

4. Click the Save button. 

5. Your file has been saved as an .FBX file, and you can now import it into Deko. 

For more information, see “Importing the 3D Scene File into Deko” on page 649.

Exporting the Scene From XSI to FBX File Format

This section describes how to export the scene from XSI to the .fbx file format. 

To export the scene from XSI:

1. In XSI, select File > Crosswalk > Export FBX.
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The Export FBX dialog box opens.

2. Choose the drive where you want to save the scene to (such as C:, or D:).

3. Type in the name that you want the scene file to be saved as in the File Name section at 
the bottom of the dialog box.

The name displays in the File name field.
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4. Click OK. 

The FBX Exporter dialog box opens.

5. Make sure that the settings shown are exactly the same as those in the above dialog box 
example.

6. Click OK.

7. Your file has been saved as an .FBX file, and you can now import it into Deko. 

For more information, see “Importing the 3D Scene File into Deko” on page 649.
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3D Scene Checklist Before Exporting to COLLADA File Format

The following table provides a checklist of tasks that must be performed before exporting 
your scene to COLLADA (.dae) file format.

Exporting the Scene From 3D Studio MAX to COLLADA File Format

After you have composed your scene in 3D Studio MAX, you have several choices as to 
which file format you will export the scene to. This section describes how to export your 
scene from 3D Studio MAX to the .dae (COLLADA) file format. 

To export the scene from 3ds max:

1. In 3D Studio MAX, select File > Export.

Make sure you have placed only one camera in the scene.

3D Studio MAX has some known problems when exporting COLLADA files, that have 
been fixed by a recent software update.  Make sure that the FBX plugin to your version of 
3D Studio MAX is version 2009.1 or greater.  To obtain the most recent FBX plugin, 
contact AutoDesk or visit the download section of their website.

All of the texture files needed to reproduce the scene must be transferred to the Deko, and 
the directory structure must remain the same.  For example, if a COLLADA model uses 
textures on the machine that is running 3D Studio MAX, and these textures are in the 
folder C:\Textures, then the texture must be transferred to Deko and placed in the folder 
C:\Textures on Deko. 
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The Select File to Export dialog box opens.

2. Select Save as type > Autodesk Collada (*.DAE).

3. Navigate to the folder and click the COLLADA (.DAE) file you want to export. 

The name displays in the File name field.
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4. Click the Save button. 

The “FBX Export (Version: 2009.1)” dialog box opens.

5. In the Include section, make sure that the Animation, Cameras, and Lights options are 
checked.

6. In the Advanced Options section, there is a Collada section.  Make sure that the 
Triangulate option is checked and that the value in the Frame Rate field matches the 
frame rate used by Deko.

7. Your file has been saved as a .DAE file, and you can now import it into Deko. 

n You need to transfer all of the texture files needed to reproduce the scene to Deko in the same 
directory as well
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For more information, see “Importing the 3D Scene File into Deko” on page 649.

Exporting the Scene From XSI to COLLADA File Format

After you have composed your scene in XSI, you have several choices as to which file 
format you will export the scene to.  This section describes how to export your scene from 
XSI to the .dae (COLLADA) file format. 

To export the scene from XSI:

1. In XSI, select File > Crosswalk > Export.

The Export Crosswalk Options dialog box opens.

2. Check that “Crosswalk 3.2” or later is shown in the Export tab of the dialog box. If not, 
you must upgrade your version of Crosswalk by clicking the Check for Updates button.

3. In the Crosswalk File Type menu, select COLLADA 1.4.1.
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4. Select the file name by clicking on the “...” button.

The Select File dialog box opens.

5. Navigate to the COLLADA Files folder, or type in a new name for the COLLADA file. 

For example:  C:\Collada_Files\sports.dae.

6. Select the Settings tab in the Crosswalk window.

7. Make sure of the following:

t The Convert Meshes To Triangles option is checked.

t The Export XSI Extra option is unchecked.
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The remainder of the settings may be checked or unchecked.  We recommend the 
settings shown in the following example:
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8. Click the Export button.

9. Your file has been saved as a COLLADA file, and you can now import it into Deko. 

For more information, see “Importing the 3D Scene File into Deko” on page 649.

Importing the 3D Scene File into Deko

Now that you have exported your scene as a .d3d, .fbx, or .dae file, copy the 3D scene file to 
your Deko Motion directory.

n When a COLLADA or an FBX file is imported into Deko, a constrainer is invoked to filter 
out any unsupported COLLADA/FBX functionality.  This constrainer will log any relevant 
information to the Deko log file.

To import the 3D scene file into Deko:

1. Open the Motion Editor.

2. Click the Effect drop-down menu to display a list of 2D effects, 3D effects, and Deko3D 
effects.
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3. Under Deko3D, select the .d3d file from the list.  Only .d3d files in the current Motion 
folder appear in the list. 

t If the file is not in the current Deko3D folder, you can use the Browse button to 
navigate to the desired folder.

t If the file is .fbx or .dae, you can use the Import button to convert the file to a .d3d 
file. 

The Deko 3D Layer Mapping table opens.

4. Play or scrub the Motion to view the 3D scene in your output video. If you want, you 
can set the duration of the motion to the length that you desire.

5. (Optional) Save the Motion for later recall.

6. Now you can create the Deko motions that map Deko layers to objects that specify 
“replaceable materials” in the 3D scene.
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About the Deko 3D Layer Mapping Table

Before beginning the mapping process, you should familiarize yourself with the Deko3D 
Layer Mapping Table.

The Deko3D Layer Mapping Table is used to specify how Deko layers will be mapped to 
objects that need a “replaceable material” in the 3D scene. Each row of the Mapping Table 
shows an object in the 3D model, and the corresponding Deko layer that will be mapped 
onto that object.

Element Definition

Deko3D Effect The file name of the Deko3D scene.

Deko3D Object The object name in the 3D scene.

Deko3D Material The material name of the “replaceable material” in the 3D scene.

Src ID The Source ID in the 3D scene.

Deko Layer The name of the Deko Layer that will be mapped onto the 3D object.  The Deko 
Layer name defaults to the Deko3D Object name.  You can change this name as you 
desire.  Click once to select the row of the table that you want and click again in the 
Deko Layer column to change the name.
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n Deko uses metadata to try to determine the type of Deko layer (text, image, or clip) to map 
onto the object in the 3D model. If the object name (or the material name) contains the 
letters “text”, “txt”, or “name”, the Deko layer is assumed to be Text (i.e., a Deko “text 
layer”). If the name contains “image”, “img”, “pic”, “logo”, or “headshot”, the Deko 
layer is assumed to be Image (i.e., a Deko “rectangle” with a “texture shader”). If the object 
name contains “clip”, the Deko layer is assumed to be PowerClip (i.e., a Deko “rectangle” 
with a “clip shader”). If none of the above are found, the Deko layer is assumed to be Text. 

Layer Type The type of Deko layer (Text, Image, or PowerClip) that will be created using 
“Create compatible Deko Layers”. Double-click on the layer type to change it.

Layer Source Specifies which Deko graphic (Preview, Program, or None) will supply the Deko 
Layer for the 3D object at playback time.

Create compatible Deko 
Layers

Creates a template graphic with the layers as specified.

View layer browser Opens the layer browser, for easy viewing of each individual layer.

Play-On Specifies that this motion will be used to “Play-on” the 3D model. Clicking Play-On 
ensures that all Deko layers will be supplied by the Preview graphic.

Update Specifies that this motion will be used to “update” (transition) the 3D model. Half of 
the layers should be designated to come from the Preview graphic and half of the 
layers should be designated to come from the Program graphic.

Play-Off Specifies that this motion will be used to “Play-off” the 3D model. clicking Play-Off 
ensures that all Deko layers will be supplied by the Program graphic.

Reverse Reverses all choices in the Layer Source column, i.e. all Preview layers become 
Program layers and all Program layers become Preview layers.

Close Closes the Deko 3D Layer Mapping table.

n To re-open the mapping table, click the Edit button under the Effect file name 
window in the Motion Editor.

Element Definition
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Using the Deko3D Layer Mapping Table

You can use the normal Deko “Preview/Program” operation to display and transition your 
3D models, taking advantage of Deko’s AutoMotion functionality. This results in simpler 
Deko graphic templates, and the ability to call up Deko3D graphics in random order at 
playback time. 

To do this, three motions must be created:

• a “Play-On” motion

• an “Update” motion (optional)

• a “Play-Off” motion. 

The “Play-On” motion is used to play the 3D model onto the screen. 

The “Play-Off” motion is used to play the 3D model off of the screen. 

The optional “Update” motion is used if the model does a transition from one set of data 
to another set of data.

In the Layer Mapping Table, the following applies: 

• “Play-On” specifies that, for this motion (the “Play-On” motion), all Deko layers will be 
supplied by the Preview graphic (so that the Preview layers “play on” to the screen). 

• “Update” specifies that, for this motion (the “Update” motion), half of the Deko layers 
will be supplied by the Preview graphic and half will be supplied by the Program 
graphic (so that the model will show a transition from the Program layers to the Preview 
layers).

• “Play-Off” specifies that, for this motion (the “Play-Off” motion), all Deko layers will 
be supplied by the Program graphic (so that the Program layers “play off” of the screen).
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We will use an election graphic as an example to walk through all three motions.

In the example being discussed, we assume that there is a single Deko3D file that contains 
the animation that Plays-On, Updates,  and Plays-Off the 3D model. We call this a “unified” 
3D scene.

n In some cases, you may have separate Deko3D files for Play-On, Update, and Play-Off.

The animation for this model consists of 3 parts:

• The first part (“Play-On”) “flies” the model onto the screen and stops as shown in the 
image above.

• The second part (“Update”) of the animation flips the boxes over, revealing a new set of 
data and stops as shown in the image above.  

• The third part of the animation (“Play-Off”) “flies” the model off of the screen.

n Note that if the “Play-On” is exactly the reverse of the “Play-Off”, part 1 of the animation 
can be used for the “Play-Off” motion as well.

Notice that the image above shows 13 “replaceable materials” – the Title, and an Image, 
Name, Vote Count, and Vote Percentage for each of three candidates. In reality, there is 
another complete set of “replaceable materials” (on the flip side, or the “B” side) which will 
display the next set of data. 
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So, for this model, there are 26 “replaceable materials”. They are all listed in the “Deko3D 
Layer Mapping” table below.  Notice that the “Src ID” column shows IDs 1 through 26.

Creating the Play-On Motion

This topic contains information on creating the play-on motion.

To create the play-on motion:

1. Make sure that you have already imported the “unified” 3D scene. If no “unified” scene 
is available, import the “Play-On” 3D scene. 

n Notice that the “Play-On” radio button is selected (by default).

2. In the “Layer Source” column, double-click the source for each of the 13 Deko “_B” 
Layers to change their designation from “Preview” to “None”.  These 13 layers are not 
used in the “Play-On” motion. 

3. Remove the “_B” tags (if any) at the end of each layer name in the “Deko Layer” 
column. 

To do so, click once to select the row of the table that you want and click again in the 
Deko Layer column to change the name. 
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4. Check the “Layer Type” for each row.  For any layers that show the wrong type, double 
click until the correct type is displayed (Text, Image, or PowerClip).

5. Click the “Create compatible Deko layers” button.  All of the Deko layers needed for the 
“replaceable materials” will be displayed in the Preview window.  Note: 

n For text layers, you may want to adjust the font and look, as well as other properties, such as 
auto-scaling, justification, etc.

6. Save the graphic in Preview (e.g. as “Election_template.dko”).  This will be used as the 
“template” for any election graphics that use this 3D model. 

n You may reposition, resize and change the contents of any layers in this graphic, but do not 
change any layer names.  Make sure that all layers stay completely on-screen.

7. If you are using a “unified” 3D scene, click the Effect Progress parameter check-box. 
Otherwise, go to step 10.  

8. Do the following:

a. Drag the scrubbing tool all the way to the right

b. Click on the right control point (turns red) 

c. Use the up arrow/down arrow controls to lower that control point to the position 
where you see the final frame of the “Play-On” portion of the animation (just prior 
to the “Transition” portion).

This is the ending point for your “Play-On” motion.

9. (Optional) If there is some “dead air” at the start of the animation, you can adjust the left 
control point so it is at the frame just prior to the first visible on-screen frame.

This will reduce any apparent latency when the motion is played.
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10. Set the desired duration for the motion. 

The duration does not need to match the original duration for this portion of the original 
animation.

The “Play-On” motion has now been defined. You can now play or scrub the motion to 
make sure the motion is set as desired. 

n If scrubbing, turn off scrubbing before proceeding.

11. With focus on the Motion Edit Window, select File > Save Motion As and save this 
“Play-On” motion as a .mot file.

Creating the Update Motion

This topic contains information on how to create the update motion.

To create the update motion:

1. Make sure that you are using a “unified” 3D scene. If no “unified” scene is available, 
import the “Update” 3D scene. 
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2. Click the “Update” option in the Layer Mapping table.

Notice that in the “Layer Source” column, each layer that was marked as “Preview” has 
been changed to “Program”, and each layer that was marked “None” has been changed 
to “Preview”. When the “Update” motion is played, the original set of layers will come 
from the “Program” graphic, and a new set of layers (the “_B” set) will come from the 
“Preview” graphic. 

3. Clear the Preview and Program windows.

4. Click the “Create compatible Deko layers” button. 
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You will have one set of Deko layers in the Preview window and an identical set of Deko 
layers in the Program window. If this is not the case, make the appropriate changes in 
the Deko3D Layer Mapping table and click “Create compatible Deko layers” again. 

n For identification purposes, the text layers in the Preview window are displayed in white, 
while the text layers in the Program window are displayed in pink.

5. Click the Effect Progress check-box.

6. Do the following: 

a. Drag the scrubbing tool all the way to the left.

b. Click on the left control point (turns red) and use the up arrow/down arrow controls 
to raise that control point to the position where you see the final frame of the 
“Play-On” portion of the animation (just prior to the “transition” portion). 

This is the starting point for your update motion. The “Program” layers (“pink”) should 
be visible at this point.

7. (Optional) If your animation contains a “Play-Off” portion (i.e. the “Play-Off” will not 
simply be the reverse of the “Play-On”), then do the following:

a. Drag the scrubbing tool all the way to the right.

b. Click on the right control point (turns red) and use the up arrow/down arrow 
controls to lower that control point to the position where you see the final frame of 
the “Transition” portion (just prior to the “Play-Off” portion).

This is the end point for your update motion. The “Preview” layers (“white”) should be 
visible at this point.
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8. Scrub the motion to view the 3D animation.  Verify that the Program layers transition off 
and the Preview layers transition on. To try again, click “Create compatible Deko 
layers”, if necessary.

The update motion has been defined. Turn off scrubbing.

9. With focus on the Motion Edit window, go to File > Save Motion As and save this 
update motion as a .mot file.

Creating the Play-Off Motion

This topic contains information on how to create the play-off motion.

To create the play-off motion:

1.  Open the “Play-On” motion (previously saved). 

If no “unified” scene is available, and there is a separate “Play-Off” scene, import that 
scene.
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2. Click the “Play-Off” radio button in the Layer Mapping table. 

Notice that in the “Layer Source” column, each layer that was marked as “Preview” has 
been changed to “Program”. When the “Play-Off” motion is played, these layers (which 
originally “played-on” from the “Preview” graphic) will “play-off” from the “Program” 
graphic.

3. Clear the Preview and Program windows.

4. Click the “Create compatible Deko layers” button. 

 You will now have one set of Deko layers in the Program window.

5. Notice that the Effect Progress check-box is already checked.
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6. Depending on whether the Play-off motion is the reverse of the Play-on motion, 
determines what you must do next. 

If the “Play-Off” motion is:

t The reverse of the “Play-On” motion, swap the values of the 2 control points.

For example, if the left point was at zero and the right point was at 0.50, move the left 
point 0.50 and move the right point to zero.

You have now reversed the direction of the animation so that it can be used for 
“Play-Off”.

t Not the reverse of the “Play-On” motion, do the following:

- Drag the scrubbing tool all the way to the left. 

- Click on the left control point (turns red) and use the up arrow/down arrow controls 
to raise that control point to the position where you see the final frame of the 
“Transition” portion (just prior to the “Play-Off” portion). This is the starting point 
for your “Play-Off” motion.

- Drag the scrubbing tool all the way to the right, and click on the right control point 
(turns red) and use the up arrow/down arrow controls to raise that control point to 
the top (which is the final frame of the “Play-Off” portion). This is the ending point 
for your “Play-Off” motion.

7. (Optional) If there is some “dead air” at the end of the animation, you can adjust the 
right control point so it is at the frame just after the last visible on-screen frame.  This 
will reduce any apparent latency at the end of the motion.
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8. Scrub the motion to view the 3D animation, and verify that the Program layers transition 
off. To try again, click “Create compatible Deko layers”, if necessary. 

The play-off motion has now been defined. Turn off scrubbing.

9. With focus on the Motion Edit window, select File > Save Motion As and save this 
play-off motion as a .mot file.

Creating a Deko Graphic for Use with a Deko3D Motion

This topic contains information on how to create a Deko graphic for use with a Deko3D 
motion.

To create a Deko graphic for use with a Deko3D motion:

1.  Open the graphic template file created in Step 6 of “Creating the Play-On Motion” on 
page 655.

2. For each Deko layer, replace the text, images or power clips with the actual data that you 
want to appear on the 3D model. 

Make sure that you replace only the actual text, image, or power clip, not the Deko layer 
itself. 

n The data for a layer can be defined by using the layer’s “Auto-Update” properties, or via 
external automation.
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3. You can change the size, position, and attributes of the Deko layer or its contents. 

n Be careful not to change the name of the Deko layer.

4. The graphic is now ready to be used with a Deko3D Motion. This can be accomplished 
by doing one of the following:

t Play the motion directly

t Link the  motion to this graphic

t Define a “Graphic Class” and add the motion to the Auto-Motion table

5. When you are finished, save the graphic. 

You may create as many graphics as needed using this method.

Depending on the configuration of your Deko system, there is a difference in the way a 
3D model behaves once in the Program window. For more information, see the 
following table for details:

Setting Up the Auto-Motion Table for Deko3D

This topic contains information on how to set up the Auto-Motion table for Deko3D.

To set up the Auto-Motion table for Deko3D:

1. Open the “Auto-Motion” table.

2. Define a class for the Deko3D Scene (for example “Election”).

3. In the “Election” class, define the “Play-On”, “Update”, and “Play-Off” motions using 
the names of the Motion files created above.

4.  In each Deko Graphic that will use these motions, make sure you have defined the 
“Graphic Class” as “Election”.

5.  In “Options / Preferences”, select “Automatically play associated effects”.

Targa-based Systems Corsica-based Systems C Chassis Systems

Deko3D in SD only Deko 3D in SD only Deko3D in SD or HD

Model persists - text can 
transition back to back.

Model does not persist.  
Requires model animations for 
back to back transitions.

Model does not persist.  Requires 
model animations for back to back 
transitions.
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Playing a Deko Graphic with a Deko3D Motion Using Auto-Motion

This topic contains information on how to play a Deko graphic with a Deko3D Motion using 
Auto-Motion.

To play a Deko graphic with a Deko3D Motion using Auto-Motion:

1. Clear Program (to make sure there is no “Election” graphic in Program).

2. Open a Deko “Election” graphic file into Preview. 

The “Election” “Play-On” motion (from the “Auto-Motion” table) will automatically be 
played, so that the 3D Scene plays the model (with data from the Deko graphic) 
“On-Air”.

3. Open the next Deko “Election” graphic file into Preview. 

The “Election” “Update” motion (from the “Auto-Motion” table) will automatically be 
played, so that the 3D Scene updates the model (transitioning from the data currently 
displayed to the data from the new Deko graphic).

4. Open a “blank” graphic file into Preview. 

The “Election” “Play-Off” motion (from the “Auto-Motion” table) will automatically be 
played, so that the 3D Scene plays the model (with the currently displayed data) 
“Off-Air”.
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14 Working with User Preferences

It is important to understand and be able to adjust your Deko system according to you own 
personal preferences or task requirements, including:

• Desktop layouts

• Video standard

• Color where graphic is transparent

• Format for saving and re-rendering graphics

• Keyboard functionality

• Prompts

• Paths for saving and searching for graphics

• Cursor appearance and behavior

• Markers displayed in the Program or Preview window

• Screen resolution

• Text appearance specifications

The following topics describe how to work with user preferences for Deko: 

• Arranging the Desktop

• Customizing Your Deko Desktop

• Changing the Video Standard or the Aspect Ratio

• Specifying User Preferences

• Saving or Resetting Preferences
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Arranging the Desktop
Deko offers eight standard layouts for creating, editing, and playing back graphics 
and macros.

The following topics provide more information about using Standard Layouts to arrange 
your desktop:

• “Graphic Compose Layout” on page 669

• “Style Edit Layout” on page 670

• “Effect Playback Layout” on page 671

• “Sequence Playback Layout” on page 672

• “Macro Edit Layout” on page 673

• “Macro Record Layout” on page 674

• “Motion Compose Layout” on page 675

• “Typeface Edit Layout” on page 676
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Graphic Compose Layout

The Graphic Compose Layout is used to compose text and graphics. This layout is suitable 
for editing existing graphics or using preset styles.

To access the Graphic Compose layout:

t Select Window > Select Layout > Graphic Compose.
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Style Edit Layout

The Style Edit Layout is used to create and edit styles. This is the default layout when you 
start Deko.

To access the Style Edit layout:

t Select Window > Select Layout > Style Edit.
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Effect Playback Layout

The Effect Playback layout is used to play a single effect. 

To access the Effect Playback layout:

t Select Window > Select Layout > Effect Playback.
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Sequence Playback Layout

The Sequence Playback layout is used to control the playback of a series of graphic files.

To access the Sequence Playback layout:

t Select Window > Select Layout > Sequence Playback.
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Macro Edit Layout

The Macro Edit layout is used to create and edit macros. 

To access the Macro Edit layout:

t Select Window > Select Layout > Macro Edit.



14  Working with User Preferences

674

Macro Record Layout

The Macro Record layout enables you to record macros. The Macro Record layout is used to 
view a macro as it is being recorded. 

To access the Macro Record layout:

t Select Window > Select Layout > Macro Record.
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Motion Compose Layout

The Motion Compose layout is used to create and edit motions. 

To access the Motion Compose layout:

t Select Window > Select Layout > Motion Compose.
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Typeface Edit Layout

The Typeface Edit layout is used to create and edit user-defined custom typefaces. 

To access the Typeface Edit layout:

t Select Window > Select Layout > Typeface Edit.
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Customizing Your Deko Desktop

To best accomplish the tasks you are working on, you can rearrange the desktop in any of the 
following ways:

• Change from one standard layout to another.

• Open additional windows with a standard layout.

• Close windows you do not want to view.

• Resize windows to a size that works for you (larger or smaller).

• Reposition windows to a location on the desktop that works for you.

Once you have rearranged the desktop how you want it, save that arrangement as a custom 
layout. Your custom layout can then be conveniently recalled just as any of the 
standard layouts.

You can also change your preference for which layout appears automatically when you start 
Deko.

The following topics provide more information on customizing your Deko desktop:

• “Changing from One Standard Layout to Another” on page 677

• “Showing or Hiding Desktop Objects” on page 678

• “Closing, Resizing or Repositioning Deko Windows” on page 678

• “Creating Custom Layouts” on page 678

• “Saving a Layout as the Starting Layout” on page 680

• “Resetting Windows in the Current Layout to Default Positions” on page 680

• “Freezing Windows” on page 680

Changing from One Standard Layout to Another

To change from one standard layout to another:

1. Select Window > Select Layout. The current layout has a check mark next to it.

2. Select the layout of your choice from the list of available Deko layouts. 
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Showing or Hiding Desktop Objects

You can show or hide windows, toolbars, or the Status bar.

To show or hide a desktop objects:

t In the View menu, select an unchecked item to show it, or select a checked item to hide 
it.

Closing, Resizing or Repositioning Deko Windows

To close, resize, or reposition Deko windows:

t Do so as in any Windows application. See your Windows documentation.

Creating Custom Layouts

Deko enables you to create your own custom layouts

To create a custom layout:

1. From the View menu, open any window you want.

2. Size, and position the window in any configuration you like. The following layout, 
including a Preview window, a Program window, a Current Style window, Tools, an 
Effect window, and an Automation window, is useful if you are on-air:

Preview 
window

Program 
window

Current 
Style 
window

Tools 
(toolbar)

Automation 
window

Effect 
window
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3. Select Windows > Save Layout As.

The Save Layout dialog box opens.

4. Type a name for the layout, and then click OK or press Enter. 

The layout name appears with the standard layouts when you select Windows > Select 
Layout.

New Custom layout
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Saving a Layout as the Starting Layout

A starting layout is the layout that appears every time you start Deko. Deko enables you to 
save any layout (even a Custom layout) as a starting layout.

To save a layout as the starting layout:

1. Select Options > Preferences.

The Preferences dialog box opens. 

2. Select the Common tab.

3. In the Starting layout menu, select the layout name that you want to use as your 
starting layout.

4. Click OK or press Enter.

5. Select Options > Save Settings Now.

Resetting Windows in the Current Layout to Default Positions

To reset windows in the current layout to default positions:

t Select Window > Reset.

Freezing Windows

To freeze windows so they cannot be moved or sized:

t Select Window > Freeze Windows.

Changing the Video Standard or the Aspect Ratio

The Deko default video standard is NTSC, suitable for broadcast in the United States. In 
other areas, you might need to change the video standard to PAL.

You can create Deko graphics in the standard 4x3 aspect ratio or in the wider 16x9 aspect 
ratio used for some feature films, music videos, and commercials. For more information on 
aspect ratio, see “Creating Graphics in Other Applications and Importing to Deko” on page 
417.

The following topics provide more information about changing the video standard or 
aspect ratio:

• “Changing the Current Aspect Ratio” on page 681

• “Changing the Current Video Standard” on page 681
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Changing the Current Aspect Ratio

To change the current aspect ratio:

1. Select Options > Hardware Settings.

2. Select the 16x9 aspect ratio to change the current aspect ratio (4x3) to 16x9.

Changing the Current Video Standard

n This feature is not available on all models.

To change the current video standard:

1. Select Options > Hardware Settings.

2. Select the video standard you want to use from the list.

n When you change the video standard, Deko automatically changes related input and output 
settings (number of scan lines, pedestal, blanking width, and so on).

For more information regarding changing your video standard or aspect ratio, see 
“Switching Between Video Standards” on page 705.

Specifying User Preferences

With the Preferences dialog box, you control numerous settings that tell your Deko how to 
function. Many of these settings are covered throughout this manual, in the applicable 
context. As a convenient reference, all available Preference settings are described in the 
following procedure.

To access the Preferences dialog box:

1. Select Options > Preferences.

The Preferences dialog box opens.
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2. Select the tab for the type of preferences you want to specify: 

- Common

- Prompts

- Paths

- Cursor

- Marker

- Advanced

- Alt Compose

n Hardware settings are described in the Avid On-Air Graphics Setup and Configuration 
Guide.

Unsaved settings are returned to the default settings each time you restart Deko. 

The following topics provide more information about specifying user preferences:

• “Specifying Common Preferences” on page 682

• “Specifying Prompts Preferences” on page 685

• “Specifying Paths Preferences” on page 687

• “Specifying Cursor Preferences” on page 688

• “Specifying Marker Preferences” on page 690

• “Specifying Advanced Preferences” on page 692

• “Specifying Alt Compose Preferences” on page 694

Specifying Common Preferences

Common Preferences enable you to determine how you want Deko to look and act when 
using it.

To specify common preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.
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2. Select the Common tab (if it’s not already displayed).

The following table provides information on the fields in the Common tab of the 
Preferences dialog box.

Preferences 
(Common Tab) 
Option Description 

Starting Layout The desktop layout that appears each time you start Deko. You can 
specify any standard or custom layout as your Starting Layout.

Restrict Graphics to Restricts graphics to the type you select. The default setting is Native, 
allowing you to create any graphics that could be used on your 
machine. Other settings are useful if you want to limit your graphics 
(number of layers, styles) to be compatible with certain older machines.

Color used where 
graphic is transparent

The color Deko uses to fill all transparent areas of a graphic (areas 
filled with live video when the Deko keyer is turned on).The default 
color is dark gray. To select a new color, click the color button. In many 
cases, this makes transparent areas easier to distinguish from areas that 
are a dark color. For more information, see “Setting Preferences” on 
page 59.

Decimal tab character The character that Deko uses as a decimal point when decimal-aligning 
rows of text. The default decimal tab character is a period.
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Use ‘explorer’ style 
file open

File open with the Windows Explorer look and functionality. It is also 
an expanded view that shows the original source dimensions and video 
standard of the source file as well as import options. The expanded 
view also shows the Preview picture and Preview alpha picons.

Display clip 
representative frame

A clip representative frame appears in Graphic picons, desktop graphic 
view, and Preview and Program output.

Use bitmap, if 
available, rather than 
rerendering

When you attempt to open any graphic that was previously rendered 
and saved as a bitmap, Deko automatically opens the bitmap rather than 
re-rendering that graphic. This setting is necessary for a Thunder server 
to detect Deko graphics. This setting is useful with older, slower 
hardware, to quickly present an image. However, in most cases, where 
it is best to see the actual graphic, this setting is not desirable. 

n Do not use this feature if you want to replace referenced texture 
files since the graphic are rerendered with the original graphic. 

Automatically play 
macros when opened

A macro begins executing when it is opened.

Automatically play 
associated effects

Enables automatic play of an effect or motion associated with a graphic 
when that graphic is opened.

On re-boot, 
automatically log on 
to Windows

Deko automatically starts whenever you re-start Windows. 

You must enter your password for this feature to work properly.

Keyboard Enables the FastAction Function Keys or uses the function keys as on a 
standard keyboard. You can also turn FastAction Lights on or off. For 
more information, see “Using FastAction Keyboard Functionality” on 
page 773.

You can enable the Enhanced Keypad for FastAction access to graphic 
files. The enhanced numeric keypad is available even without the 
FastAction Keyboard option. Deko displays the enhanced keypad 
counter on the desktop. For more information, see “About the 
Enhanced Keypad Feature” on page 45.

Preferences 
(Common Tab) 
Option Description (Continued)
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Specifying Prompts Preferences

Prompts Preferences enable you to determine whether you want Deko to prompt you in 
certain circumstances.

To specify prompts preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Select the Prompts tab (if it’s not already displayed).

The following table provides information on the fields in the Prompts tab of the 
Preferences dialog box.

Preferences (Prompts 
Tab) Option Description 

Prompt to save before 
clearing or opening a 
window

Prompts you to save a modified graphic or macro before clearing 
it or opening a file into it. This might be too time consuming in an 
on-air situation.

Prompt to save before 
closing a window

Prompts you to save any modified file before closing its window 
or exiting Deko. This might be too time consuming in an on-air 
situation.
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Prompt if file component 
not found (recommended)

Displays an error message any time Deko cannot find a graphic, 
style, or custom typeface file used in a graphic. If this option is 
not selected, Deko skips missing files during sequence playback, 
and displays solid black or a default texture in place of missing 
textures.

Prompt before exiting Deko 
(recommended)

Prompts you for verification each time you attempt to exit 
the program.

Prompt on file open if name 
matches but extension does 
not

Prompts you to verify that you want to open a file if the file name 
you entered has an extension that does not match the file type for 
the currently active window.

Prompt if a graphic is being 
converted from a different 
video standard or file format

Displays a message any time you try to open a graphic file 
recorded in a different resolution. This can happen if the graphic 
was recorded under a different video standard (PAL, NTSC, PAL 
16x9, or NTSC 16x9) or imported from another file format 
(Windows bitmaps, TARGA files, and so on.)

n Although Deko automatically converts these graphics to 
the current resolution, the conversion process takes time, 
which can slow recall time and sequence playback. You 
might want to rerecord these files in the current resolution 
by selecting File > Save As, pressing F12 (SK), or pressing 
Save File (FAK).

Prompt if encounter a 
database error

Displays a message if Deko encounters a database error.

Preferences (Prompts 
Tab) Option Description (Continued)
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Specifying Paths Preferences

Paths Preferences are an important tool for saving and retrieving files. For more information, 
see “Organizing Files” on page 389.

To specify paths preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Select the Paths tab (if it’s not already displayed.)

The following table provides information on the options in the Paths tab of the 
Preferences dialog box.

Preferences (Paths 
Tab) Option Description 

Current Directory Specifies the five current directories based on file types:

• Graphics (.dko), Sequences (.seq), Effects (.efx), Automation 
(.atx)

• Styles (.sty), Preset Styles (.pst), Shaders (.shd)

• Macros (.mcr)

• Motions (.mot)

• Custom Typefaces (.fac)
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Specifying Cursor Preferences

Cursor Preferences enable you to determine how you want the cursor to look, move and 
behave.

To specify cursor preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Select the Cursor tab (if it’s not already displayed).

Search Path Tells Deko where to search for files you have saved. Specifies the 
four directory search paths based on file types: 

• Graphics (.dko), Sequences (.seq), Effects (.efx), Automation 
(.atx)

• Styles (.sty), Preset Styles (.pst), Shaders (.shd)

• Macros (.mcr)

• Motions (.mot)

Preferences (Paths 
Tab) Option Description (Continued)
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The following table provides information on the fields in the Cursor tab of the 
Preferences dialog box.

Preferences (Cursor 
Tab) Option Description 

Text cursor style Select the appropriate button to controls how the text cursor is 
displayed (I-Beam or Box). Does not affect how the cursor moves.

Cursor movement Select the appropriate button to determine how the cursor moves.

• By pixels - The cursor moves in 1-pixel (fine) or 10-pixel 
(coarse) increments. The status bar displays current dot and line 
position with the origin at the top left corner. The number of 
pixels on the full screen depends on the video standard: 
720x486 for NTSC or 720x576 for PAL.

• By screen units - The cursor moves in screen units. Increments 
are independent of the current video standard, and equal either 
1/500 (fine) or 1/50 (coarse) of screen height. The status bar 
displays current x and y coordinates, with the origin at the 
center of the screen.

n To select “coarse” or “fine”, select Options > 
Transform/Coarse or Fine (Ctrl+Spacebar).

Show text cursor Shows or hides the text cursor.

Moving cursor sets font 
and look

Automatically changes the current style, whenever you move the 
text cursor, to reflect the style of the character to the left of the 
cursor.

Remember cursor position Deko remembers cursor position when you set focus on another 
window, then returns focus to the original window. Deko 
“remembers” where you left the cursor in the original window.

If this option is not selected, a single click to refocus on the window 
also places the cursor anew.

Home and End key 
behavior 

Determines whether the Home and End keys behave as they 
typically do in Windows applications, or as they do in a traditional 
television character generator. For more information, see the 
following table.

Box cursorI-Beam cursor
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The following table describes the Home and End key behavior in Deko based on the 
Windows or Character generator selection in the Preferences dialog box - Cursor tab.

Specifying Marker Preferences

Marker Preferences enable you to specify whether you want to display or hide the following 
markers:

• Safe title area

• Tab stops

• Text field box

• Hard return

This dialog box also enables you to specify the top, bottom, right, and left edges of the safe 
title area.

To specify markers preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

Home or 
End Key

Character Generator Selection - 
Description Windows Selection - Description

Home Sends the cursor to the beginning of a text 
field.

Sends the cursor to start of a row.

Shift+Home Selects text from the cursor to the beginning 
of the text field.

Selects text from the cursor to the beginning of 
the row.

Ctrl+Home Sends the cursor to the beginning of the row. Sends the cursor to the beginning of the text 
field.

End Sends the cursor to the right of the last 
character in the text field.

Sends the cursor to the end of the row.

Shift+End Selects text from the cursor through the last 
character in the text field.

Selects text from the cursor through the end of 
the row.

Ctrl+End Sends the cursor to the end of the row. Sends the cursor to the right of the last character 
in the text field.
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2. Select the Markers tab (if it’s not already displayed).

The following table provides information on the fields in the Markers tab of the 
Preferences dialog box.

Preferences 
(Markers Tab) 
Option Description 

Show Specifies whether to display (selected) or hide (unselected) the 
sub-options:

• Safe title area

• Text field box

• Tab stops

• Hard returns

For more information on these items, see the screen example following 
this table.

Safe title area (% 
from edge of screen)

Specifies the top, bottom, right and left of the safe title area. Values 
represent a percentage of the distance from the specified edge of the 
screen to the opposite edge.
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Example of Various Markers in Deko

Specifying Advanced Preferences

Advanced Preferences enable you to do the following:

• Specify resolution (screen height in units).

• Specify a time limit for text rendering.

• Enable word wrap.

• Set default preferences for auto-scaling text layers.

• Determine how you want to base font size (Cap height or Row Height).

• Determine whether you want to have sample text in the Presets box display in actual or 
standard font sizes.

To specify advanced preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

Safe title area

Tab stop

Text field box 
(layer boundary)

Hard return
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2. Select the Advanced tab (if it’s not already displayed).

The following table provides information on the fields in the Advanced tab of the 
Preferences dialog box.

Preferences 
(Advanced Tab) 
Option Description 

Resolution Specifies screen height units, the number of vertical measurement units 
per screen. Typical (but not mandatory) settings are 486 for NTSC and 
576 for PAL. 

n This is a reference number only, not related to the pixel 
resolution of the output frame buffer. You can set it to any 
convenient value.

Text rendering Specifies a time limit for Deko to render text. If Deko is unable to fully 
render text within this time, it automatically substitutes low resolution 
text.

Low-resolution text appears jaggy on the desktop monitor, without 
details (such as edges and shadows).

Once Deko has finished rendering, it replaces the low-resolution text 
with the fully rendered text.

n Deko never displays low-resolution text on video output, only on 
the desktop.
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Specifying Alt Compose Preferences

Deko enables you to create graphics for multiple formats (such as SD, HD, and 4:3 and 16:9 
aspect ratios). The Alt Compose tab enables you to set up graphics for performing 
multi-format compose.

Multi-Format Compose is a means of reducing production effort (workload) when creating 
graphics for multiple formats. With multi-format compose, you no longer need to create 
separate graphics for SD and HD formats. Instead, you can create multiple versions of one 
graphic, saved as one file name. The appropriate version is recalled based on the Playback 
system’s hardware setting. For more information, see “Creating Graphics for Multiple 
Formats” on page 352.

n Multi-Format Compose is only available when you are in a Preview/Program channel 
configuration. If you are running a Dual Program configuration, switch to a 
Preview/Program configuration before using Multi-Format Compose. For more information 
on switching hardware configurations, see“Switching Between Video Standards” on page 
705.

Fast Desktop Render 
(lower quality)

As a result of using better resizing, typing may be somewhat slower.  To 
increase typing output speed on the VGA, check the box for Fast 
Desktop Render. It will reduce the quality of the output on the VGA, but 
not the playback to air.

Word wrap enabled Enables word wrap automatically for all new text fields.

Scaling Specifies your default preference for auto-scaling text layers.

• None - No automatic text scaling.

• Scale to fit box - Scales text up or down to exactly fit the text layer.

• Shrink to fit box - Scales text down, if necessary, to fit within the 
text layer.

Font size based on Allows you to specify whether to base font size on row height or cap 
height.

Clips Specifies default preferences for Clip dissolve duration and Clip record 
duration.

Motions Specifies default preferences for Motion fade in/out.

Preferences 
(Advanced Tab) 
Option Description (Continued)
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Alt Compose Preferences enable you to do the following:

• Specify an alternate video standard used when creating an alternate version of a graphic.

• Specify a standard tag name for the graphic.

• Specify an alternate tag name for the alternate graphic.

• Specify the top, bottom, right, and left edges of the safe title area for the alternate 
graphic.

To specify Alt Compose preferences:

1. Select Options > Preferences.

The Preferences dialog box opens.

2. Select the Alt Compose tab (if it’s not already displayed).
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The following table provides information on the fields in the Alt Compose tab of the 
Preferences dialog box.

Preferences (Alt 
Compose Tab) 
Option Description 

Alt video standard The alternate video standard that you want to compose graphics for 
(NTSC, 1080i 59.94, and so on).

Standard tag The graphic you want to be read back from another Deko (Playout) 
system. 

For example, to create graphics with the same video standard, but with 
different properties (such as different languages) one in English, and 
one in Spanish, you can type identifying names in the Standard tag and 
Alternate tag fields to distinguish the Alternate graphic from the 
Standard graphic. For example, type English in the Standard tag field, 
and Spanish in the Alternate tag field.

Alternate tag Type the name of a graphic you want to be used as an alternate.

Use tag first Deko reads back the graphic based on tags that have been created for 
the graphic (and ignores the video standard).

n The Use tag first option is helpful if you want to create graphics 
that are “HD ready,” but you still want to air them in an SD 
format. If Use tag first is selected, Deko checks the tag first 
before comparing video standards. In the case of a playback 
machine running in NTSC, and the multi-format graphic having 
been created in 1080i and NTSC, it would be a way of saying 
you want to override the video standard and read in the 1080i 
version if my current tag preference matches one of the tags.

Safe title area (% from 
edge of screen)

Specifies the top, bottom, right and left of the safe title area. Values 
represent a percentage of the distance from the specified edge of the 
screen to the opposite edge.
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Saving or Resetting Preferences

Once you have changed any of your preferences, you must save them. You can also have 
Deko automatically save your current preferences each time you exit Deko. If you are not 
satisfied with your saved settings, Deko provides you with the ability to reset your 
preferences to the factory default settings.

The following topics provide more information about saving and resetting preferences:

• “Saving Current Preferences” on page 697

• “Automatically Saving Current Preferences Upon Exiting Deko” on page 697

• “Resetting Preferences to Factory Defaults” on page 697

• “Resetting All Preferences, Hardware and Software Settings” on page 698

Saving Current Preferences

To save current preferences:

t Select Options > Save Settings Now.

Automatically Saving Current Preferences Upon Exiting Deko

To automatically save current preferences each time you exit Deko:

t Select Options > Save Settings on Exit. 

n Use this setting with care, as you might save unwanted preferences.

Resetting Preferences to Factory Defaults

If you are not satisfied with the changes you have made to your settings, Deko provides an 
easy way to reset your preferences to the factory default settings. 

To reset preferences to factory default settings:

1. Select Options > Preferences.

The Preferences dialog box opens.
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2. Select the tab type for the preference you want to change back to the factory default 
settings.

- Common

- Prompts

- Paths

- Cursor

- Markers

- Advanced

- Alt Compose

3. Click “Reset this page to defaults”.

4. Click OK or press Enter.

Resetting All Preferences, Hardware and Software Settings

If for some reason you need to reset all of your preferences (including Hardware settings and 
software settings) to the factory default, Deko provides you with the option to do this.

w Resetting to Factory Defaults, especially Hardware Settings, might render your Deko 
inoperable if the settings are incompatible with the given television facility. 

To reset all preferences, hardware settings, and software settings to factory defaults:

1. Select Options > Factory Defaults. 

The Factory Default Settings dialog box opens.

2. Select the type of settings you want to change. Options are:

- User preferences (as set in Options > Preferences.)

- Hardware Settings (as set in Options > Hardware Settings.).

- Software Settings, which includes all program settings not explicitly set in 
Hardware Settings or Preferences (such as current preset styles and shaders, 
window freeze status, and so on.)

3. Click OK or press Enter.



15 Working with Video Input and Output

Your Deko accepts video input and can produce video output. In addition, the following 
information is important to understand, and explained in the following topics:

• How to direct signal paths for routing video input, Deko graphics, and other signals to 
video output.

• How to use the Hardware Settings dialog box to configure your Hardware settings.

• How to switch between video standards.

• How to control whether video input, Deko graphics, or other options are visible in the 
video output.

• Tips for working in dual-channel output mode.

• Using frame grabbing.

The following topics describe how to work with video input and output:

• Directing Signal Paths

• Configuring Hardware Settings

• Determining Output View Priority

• Displaying a Test Pattern

• Working in Dual Channel Output Mode

• Using Frame Grabbing
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Directing Signal Paths

Internally, the Deko system generates Deko graphics. With the appropriate options, the Deko 
system might also process clips and DekoObjex scenes. The Deko system accepts video and 
key signals through inputs on the back of the computer. Multi-channel Deko systems can 
accept two video inputs and two key inputs. Depending on the system, input signals can be 
digital or analog. You must tell your Deko how to combine and output all of these signals by 
configuring keying and routing.

The following topics provide more information about directing signal paths:

• “About Keying and Routing” on page 700

• “Specifying Output Channels” on page 700

About Keying and Routing

Routing means you are directing the route, or path, of input signals and internally generated 
signals to output. At the simplest level, you might want to output only Deko graphics. At a 
more complex level, for example, you can direct one video input to be processed with a 
DekoObjex scene, including a clip, and Deko graphics, then sent to one output, while 
another video input is processed with Deko graphics and sent to another output. 

Keying means you are telling Deko when and how to mix signals. Keying selection depends 
upon whether you expect the output of the Deko to be the final signal to air, or to be 
combined further with other signals before going to air.

Specifying Output Channels

In multi-channel systems, output Channel 1 is designated as a Program channel, the signal 
that goes to air. In Dual Program mode, with two signals going to air, Channel 1 output is 
Program A. Channel 2 can either be an additional Program channel (Program B) or a 
Preview channel, sending a signal to a preview monitor rather than to air. In three channel 
systems, Channel 3 is designated as a Preview channel.
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Configuring Hardware Settings

Deko3000, Deko3000 HD, Deko3000 Hybrid, Deko1000, Deko1000 HD, Deko1000 
Hybrid, and Deko550 are built on a hardware platform that is different from older Deko 
products. This hardware platform makes it easier to customize the product for your facility.

The following topics provide more information about configuring hardware settings:

• “Using the Hardware Settings Dialog Box” on page 701

• “Switching Between Video Standards” on page 705

Using the Hardware Settings Dialog Box

The Hardware Settings dialog box provides a list of parameters that can be configured to 
customize the integration of a workstation into your facility.

To access the Hardware Settings dialog box:

t Select Options > Hardware Settings. 

The Hardware Settings dialog box opens.
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The following table describes the fields on the Hardware Settings dialog box.

Hardware 
Settings 
Option Sub-Option Description 

Which Channel The Deko system can be configured in either a single, dual, or triple 
channel configuration. Depending on how your system is configured, you 
have the option of configuring each channel through the Which Channel 
menu.

Video 
Characteristics

Genlock 
Present

If a genlock signal is active, it is automatically detected by the software 
and the Genlock present option in the Hardware Settings window displays 
a check mark. If no genlock signal is detected, the option is deselected.

n If the state of the input signal cannot be determined, the controls 
appear disabled.

Video Standard Select the format from the Video Standard menu. 

Standard Definition (SD) Deko products use the following NTSC or PAL 
video standards.

• NTSC (4x3)

• NTSC (16x9)

• PAL (4x3)

• PAL (16x9)

High Definition (HD) Deko products, such as the Deko3000 HD and 
Deko1000 HD, can be configured to run in several HD formats, such as:

• 1080i/59.94

• 1080i/60

• 1080i/50

• 720p/59.94

• 720p/60

The Deko Hybrid products, such as Deko 3000 Hybrid and Deko 1000 
Hybrid, have the ability to select from both Standard Definition and High 
Definition video standards.
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Output video as The final Video Output of the Deko system can be either “shaped” or 
“unshaped.” The default setting for this option is Shaped. When this 
option is set to Shaped, the video is pre multiplied by the key. This is the 
native format for Deko. When this option is set to Unshaped, the video is 
unaltered by the key. Select Unshaped if your switcher is not capable of 
receiving Shaped inputs. For more information, “Using Shaped And 
Unshaped Keying” on page 787.

Output H 
timing

The horizontal output timing of each Deko system channel can be 
adjusted in half-pixel increments relative to the analog reference input 
(House Reference). The range of available adjustment is between -300 
usec and 300 usec. 

Preserve lines When you are using a live video input as a background on your Deko 
system, vertical interval data (such as Close Captioning and VITC) can be 
preserved and passed through to the video output. To use this feature, 
select the range of lines to preserve in the Preserve Lines menu. Only the 
region from SAV to EAV is passed through.  The HANC data is not 
passed through with the VANC.

n Select this option only when necessary, as using it consumes a 
portion of the total pixel processing power of the system.

Audio 
characteristics

Enabled 
channels

The Deko system supports up to 8 channels of embedded audio for each 
Video and Key. Audio channels can be used for live passthrough, clip 
record, clip playback or sound effects insertion. The Enabled channels 
menu allows you to control which embedded audio channels are used. 
Channels used for SD and HD include the following:

For Standard Definition (SD) systems, the choices are:

• None

• Channels 1 and 2

• Channels 1 through 4

• None

• Channels 1 and 2

• Channels 1 through 4

• Channels 1 through 8

Hardware 
Settings 
Option Sub-Option Description (Continued)
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Video A Input

 
Video present 

Video is

 
 

Embedded 
audio

The parameters in this section provide configuration controls for the 
Video A input on each channel. 

If an SDI video signal is active, it is automatically detected by the 
software, and the Video settings box in the Hardware Settings window 
displays a check mark. If no video signal is detected, the box is 
deselected.

When used with a corresponding live key input, this parameter sets 
whether the Video signal is Shaped or Unshaped. 

n If this parameter is not set properly, improper keying through the 
Deko system might result.

This parameter controls whether embedded audio is used on the Video 
input channel. If Yes is selected, the audio channels selected in the Audio 
Characteristics menu are used.

Key / Vid B 
Input  

Video Present

Use this input?

 
 
Use this input 
as

Embedded 
audio

The parameters in this section provide configuration controls for the Key 
input on each channel. 

If an SDI video signal is active, it is automatically detected by the 
software and the Video settings box in the Hardware Settings dialog 
displays a check mark. If no video signal is detected, the box is 
deselected.

You must select disable if the Key input on each channel is not used or if 
there is no valid signal attached to the physical connector. 

n Improper operation results if this parameter is enabled without a 
valid input attached. 

When used with the DekoObjex feature, the Key input can be repurposed 
as a second Video input for each channel.

This parameter controls whether embedded audio is used on the Key (or 
second) input channel. If Yes is selected, the audio channels selected in 
the Audio Characteristics menu are used.

Changes to be 
made after restart

Provide an overview of any changes that you have made in this session.

n The Deko application must be closed and reopened for most of 
these changes to take effect. Controls marked with a * take effect 
automatically without requiring a restart. 

Restore factory 
defaults

If you want to restore any setting changes that you have made to the 
original factory defaults, click this button.

Hardware 
Settings 
Option Sub-Option Description (Continued)
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Switching Between Video Standards

Deko enables you to easily switch between video standards. 

n If your Deko is a Hybrid system, you can switch between SD and HD settings.

To switch between video standards:

1. Select Options > Hardware Settings. 

The Hardware Settings dialog box opens.

2. In the Video Standard menu, select the video standard you want to switch to. 

3. Click OK.

4. Restart your computer for the new settings to take effect.

Determining Output View Priority

Typically, video output that is shown on the video monitor matches the contents of the 
Program window. However, you can allow video input, an open scene in DekoObjex, or an 
open Clip file to have priority in the output. To determine this priority, use the Output View 
buttons on the Deko toolbar. 

Output View buttons are present on Deko1000, and Deko550 whenever Channel 1 input is 
digital.

n DekoObjex is a powerful option for creating scenes. For more information, see “About 
DekoObjex” on page 769, or see the DekoObjex User’s Guide.

The default Output View priority order is:

1. DekoObjex

2. Clip

3. Video Input

The priority can be changed by moving the buttons. Left to right order of the buttons 
indicates output priority. If the left item is active, it is seen in the output. The middle 
item is only visible to the extent that the left item is transparent. The right item is visible 
only to the extent that both of the others are transparent.

If a DekoObjex scene is not currently open, when you open a clip file, or input, the 
corresponding button is dimmed and not active.
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The following topics provide more information about determining Output View priority.

• “Viewing the Status of a DekoObjex Scene, a Clip, or Video Input” on page 706

• “Turning On or Off a DekoObjex Scene, a Clip, or Video Input” on page 708

• “Determining the Name of a DekoObjex Scene or an Open Clip” on page 708

• “Reordering Output View Priority” on page 708

Viewing the Status of a DekoObjex Scene, a Clip, or Video Input

DekoObjex and Clip can be in one of three states. The three states are indicated by the 
appearance of the buttons. In the following example, DekoObjex is drawn flat and gray, Clip 
is drawn in 3D and gray, and Video is drawn in 3D and white. 

Output View Button Status

The following apply:

• If a button is drawn flat, it cannot be clicked.

• If a button is drawn gray, the item is not visible in the video output.

• If a button is drawn white, the item might be visible in the video output, but cannot be 
seen if it is behind another item, if the opacity of the item is set to zero, or if the item is 
positioned off screen.

The following table describes what the different button states mean for each Output 
View button.

Output View buttons

Flat and gray 3D and gray 3D and white
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Output View 
Option Description

CG The following applies to the CG button:

• If the CG button appears flat and gray, it indicates that there is no Deko graphic open 
and it is not visible. CG stands for Character Generator. Clicking the button does 
nothing. 

• If the CG button appears 3D and gray, it indicates that there is a Deko graphic open and 
it is not visible. Clicking the button makes the graphic visible. 

• If the CG button appears 3D and white, it indicates that there is a Deko graphic open and 
it is visible. Clicking the button makes the graphic invisible. 

DekoObjex The following applies to the DekoObjex button:

• If the DekoObjex button appears flat and gray, it indicates that there is no scene open 
and it is not visible. Clicking the button does nothing. 

• If the DekoObjex button appears 3D and gray, it indicates that there is a scene open and 
it is not visible. Clicking the button makes the scene visible. 

• If the DekoObjex button appears 3D and white, it indicates that there is a scene open and 
it is visible. Clicking the button makes the scene invisible. 

Clip The following applies to the Clip button:

• If the Clip button appears flat and gray, it indicates that there is no DekoObjex clip open 
and it is not visible. Clicking the button does nothing.

• If the Clip button appears 3D and gray, it indicates that there is a DekoObjex clip open 
and it is not visible. Clicking the button makes the DekoObjex clip visible.

• If the Clip button appears 3D and white, it indicates that there is a DekoObjex clip open 
and it is visible. Clicking the button makes the DekoObjex clip invisible.

Video These choices refer to video from the input labeled Channel 1 digital video.

• If the Video button appears 3D and gray, it indicates that input video is not visible. 
Clicking the button makes it visible. 

• If the Video button appears 3D and white, it indicates that input video is visible. 
Clicking the button makes it invisible. 
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Turning On or Off a DekoObjex Scene, a Clip, or Video Input

To turn on or off a DekoObjex scene, a Clip, or video input:

t Click the Output View button that you want to turn on or off. 

The DekoObjex scene, clip, or video input is added to or removed from the video 
output, seen on your video monitor. A white button indicates the item is on. A gray, 
three-dimensional button indicates the item is off. A flat gray button indicates there is no 
open item available to turn on or off.

Determining the Name of a DekoObjex Scene or an Open Clip

To determine the name of an open DekoObjex scene or an open Clip:

t Position the mouse so the pointer appears over the appropriate Output View button.  

The name appears in a ToolTip.

Reordering Output View Priority

To reorder output view priority:

t Click the Output View button you want to move, and drag it to a new position on the 
toolbar. The leftmost button indicates the output.

c Deko requires exclusive use of your system’s OpenGL® subsystem to produce video 
output. To prevent disruption of Deko’s video output, do not run any other OpenGL 
applications or screen savers.

Displaying a Test Pattern
To display a test pattern of color bars:

t Select Channel > Color Bars.
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Working in Dual Channel Output Mode

In some situations, you might want to output different graphics simultaneously. To do so, 
you must have a Dual Channel Deko system and be set up to work in Dual Channel 
Output mode.

n This feature is not available on all models.

To specify dual program output:

t Select Channel > Dual Program.

To specify single program plus preview output:

t Select Channel > Program to Preview.

To arrange the desktop for dual channel on-air operation:

1. From the View menu, open the windows that you find helpful. A typical Dual Channel 
layout would have the following windows open:

- Preview window

- Two Program windows

- Current Style window

- Tools

- Effect or Sequence window

- Automation window

To save your layout:

1. Select Window > Save Layout As.

The Save Layout dialog box opens.

2. Type a name for the desktop layout in the field.

3. Click Save. 

The layout you saved is added to the menu. 

To select this new layout:

1. Select Window > Select Layout.

2. Select the new layout from the menu.
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Using Frame Grabbing

Frame grabbing allows you to capture a still picture from video input. Before grabbing a 
frame of video, you must set grab options. You might also want to suppress motion during 
frame grabbing for better results, particularly if the action in the video you are grabbing 
from is relatively fast. However, if you suppress motion, you capture only every other scan 
line. The missing lines of the picture might be filled in by interpolating or duplicating scan 
lines. Although this might work fine, there is a chance that it might result in an inaccurate 
recreation of the original image.

n Frame grabbing with key is not available on all models.

The following topics provide more information about using Frame Grabbing:

• “Setting Grab Options” on page 710

• “Grabbing a Frame of Video” on page 710

• “Applying Motion Suppression” on page 711

Setting Grab Options

To set grab options:

1. Enable the keyer and make your selection with full key. For more information, see 
“Using the Hardware Settings Dialog Box” on page 701.

2. Select Channel > Grab Options.

3. Select an option from the menu, or click the option again to deselect it.

n A check mark next to an option indicates that it is selected.

Grabbing a Frame of Video

To grab a frame of video:

1. Connect an input signal for your Deko. For more information, see “Video Inputs” in the 
Avid On-Air Graphics Setup and Configuration Guide.

2. Select Channel > Frame Grab.

n Use a digital input source for the highest quality frame grabbing.
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Applying Motion Suppression

You can apply motion suppression to the current background when frame grabbing.

The following topics provide more information on applying motion suppression:

• “Applying Motion Suppression When Frame Grabbing” on page 711

• “Applying Motion Suppression to the Current Background” on page 711

• “Specifying Motion Suppression Options” on page 711

Applying Motion Suppression When Frame Grabbing

To apply motion suppression when frame grabbing:

1. Select Channel > Motion Suppress.

2. Select Motion Suppress When Grabbing.

Applying Motion Suppression to the Current Background

To apply motion suppression to the current background:

1. Select Channel > Motion Suppress.

2. Select Motion Suppress Now.

Specifying Motion Suppression Options

To specify motion suppression options:

1. Select Channel > Motion Suppress.

2. Do one of the following:

t Select Interpolate Scan Lines to specify interpolation between every other scan line.

t Select Duplicate Scan Lines to specify duplication of every other scan line.

3. Specify which field’s scan lines to interpolate or duplicate by doing one of the 
following:

t Select Preserve Field 1 (odd field).

t Select Preserve Field 2 (even field).
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16 Streamlining Your Work with Macros

Macros are a powerful tool for performing multi-step tasks with a single command or 
keystroke. To get the most out of your Deko, it is important to know:

• What macros are

• How to automatically create macros with the Macro Recorder

• How to play a macro

• How to create macros from existing graphic, sequence, or motion files

• How to write and edit macros using the Deko Macro Programming language   

The following topics describe how to use macros to streamline your work:

• Introduction to Macros

• Recording Macros

• Playing Macros

• Converting a Graphic or Sequence into a Macro

• Writing and Editing Macros

• Saving Macros

• Executing Deko Macros in External Applications
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Introduction to Macros

Like all computers, Deko performs specific functions in response to specific commands. You 
can invoke a command in either of two ways:

• With the Deko user interface (menus, shortcut keys, and so on), every time you strike a 
key or select a menu item, you invoke a command that directs Deko to perform a 
function.

• Explicitly, if you know the command name, type it in the Command bar, and click Play.

For example, the command to clear the current graphic is clear_graphic. 

To execute a command, do the following:

1. Press F4 to select the Command bar.

2. Type clear_graphic in the Macro or command name text box.

3. Press Enter.

A macro is a logical sequence of commands. You can name and store a macro by saving 
it in a file. 

If you routinely execute a task involving a number of commands, you can save time by 
creating a macro. By simply typing the macro name on the Command Bar and pressing 
Enter, Deko executes all of the commands, in sequence. 

To further save time if you have a FastAction Keyboard, you can assign your macro to a 
Preset Macro key for single keystroke access. You no longer need to press a key or click 
on a menu item for each step of your process. 

To create a macro:

t Do one of the following: 

- Turn on the macro recorder and perform the steps you usually perform with the 
keyboard or mouse. Deko records these steps as a macro that you can save, name, 
and recall. See “Recording Macros” on page 716.

- Convert an existing graphic, sequence, or motion file into a macro that recreates the 
graphic, sequence, or motion. See “Converting a Graphic, Sequence or Motion into 
a Macro” on page 720.

- Using Deko’s macro language, write and edit macros directly in the Macro window. 
See “Writing and Editing Macros” on page 721.
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n Macros created by any of these methods can be edited by inserting or deleting commands 
directly in the Macro window.

For more information, see “A Simple Macro Example” on page 715.

A Simple Macro Example

Suppose that you have created a Lower Third template. To create a simple macro, follow 
these steps:

1. Open the file.

2. Toggle INS/OVR to Overwrite mode.

3. Select “Name.”

Name selected Overwrite mode onLower third graphic open in Program window
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n After this, the process varies, depending upon the name you want to type in. However, those 
first three steps are the same every time. By turning on the macro recorder, and executing 
those steps you create a macro that executes those steps for you.

This macro opens the graphic, toggles on overwrite, and selects “Name.”

4. Type the name of your macro on the command bar and click Play.

n If you have a FastAction Keyboard, you can assign the macro to a Preset macro key for 
single keystroke access. Detailed instructions are found in the following sections.

Recording Macros

Even without any knowledge of Macro Programming language, you can create macros with 
the Macro Recorder.

To record a macro:

1. Turn the macro recorder on, by doing one of the following:

t Click the Record button at the far right end of the text bar.

t Select Record Macro (Ctrl+F2) from the Macro menu. 

On the text bar, the button lights up red to indicate that the macro recorder is on.

2. Use the keyboard and/or mouse to perform the sequence of actions that constitute the 
macro.

3. Turn the recorder off, by doing one of the following:

t Click off the record button on the text bar.

t Select Record Macro (Ctrl+F2) from the Macro menu.

t Press F2 to turn the recorder off and activate the Macro window.
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To view and save the macro you just recorded:

1. Do one of the following:

t Select Window > Select Layout > Macro Edit.

t Select View > Macro (F2).

All of the commands in your macro are displayed in Programming Language. You can 
edit this macro as you would any other. For more information, see “Writing and Editing 
Macros” on page 721.

2. Save the macro by doing one of the following:

t Press F12 (SK).

t Press Save File (FAK).

3. Play the macro. For more information, see “Playing Macros” on page 717.

Playing Macros

Deko offers a few different ways to play macros.

The following topics provide more information about playing macros:

• “Playing Macros Using the Play Button” on page 717

• “Recalling and Playing Macros with a Single Keystroke (FAK only)” on page 718

• “Using Macro Autoplay with the SportsWare Option” on page 719

Playing Macros Using the Play Button

If there is a macro currently displayed in the Macro window, you can play the macro from 
either the Text bar, or the Macro menu.

To play the macro currently displayed in the Macro window:

t Do one of the following:

- Click the Play button near the right end of the text bar.

- Select Play Macro (Alt+F2) from the Macro menu. 

On the text bar, the Play button lights up green to indicate that a macro is playing.

n The name of the macro that is currently playing appears in the status bar. If neither the 
Macro or Sequence window is active, Deko plays the macro in the most recently activated 
Macro window. If you close the Macro window, the opened macro appears again when you 
reopen the window. You can  play back the active macro even when the Macro window 
is closed.
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To play a macro file if the Command bar is not visible:

1. Do one of the following:

t Select View > Command Bar.

t Press F4 (SK).

t Press Command (FAK).

2. Click the text box on the Command Bar.

3. Type the macro file name. You do not have to type the .mcr extension.

4. To specify macro parameters, click the Prompt button and edit the parameters in the 
dialog box.

5. Click the Play button or Press Enter.

Recalling and Playing Macros with a Single Keystroke (FAK only)

For repetitive tasks, you can create macros, assign them to Preset Macro keys and access 
each one with a simple keystroke.

To assign a macro to the Preset Macro key:

1. With the macro displayed in the Macro window, press the Preset Macro key on the 
bottom left of your FastAction Keyboard. 

The Preset Macro window opens. 

n You can enter up to twenty-six macros as character assignments. 

2. Scroll to the desired key assignment and click on the key.

3. Press the Select File key. 

The Select Preset Macro dialog box opens.

4. Navigate to the desired Macro file.

5. Select the file and click OK. 

The Macro is assigned to the desired key.

6. Click Close to accept the assignment.

7. To keep assigned Preset macros, select Options > Save Settings now.

To play a Preset macro:

t Press the Preset Macro key + the assigned letter key.
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Using Macro Autoplay with the SportsWare Option

Macro Autoplay, available with the SportsWare option, automatically plays macros when 
they are opened. Autoplay macros have as their first line:

#autoplay

n To see if this option is enabled on your system, click Options>Enabled Options. Look for a 
check mark next to SportsWare.

If you have the SportsWare option, when you open one of these macros, it plays 
automatically. If you want Deko to automatically play any macro that you open, all you have 
to do is follow a one-time process to enable macro autoplay.

To enable Macro Autoplay:

1. Select Options > Preferences. 

The Preferences dialog box opens. 

2. Click the Common tab. 

3. Select Automatically play macros when opened.

4. Click OK or press Enter.

5. Select Options > Save Settings Now.

Pausing, Advancing, and Stopping Macro Playback

Once a macro is playing, you can pause it, advance the paused macro one step, resume a 
paused macro, and cancel macro playback.

To pause a macro:

t Do one of the following:

- Click the Pause button near the right end of the text bar.

- Select Macro > Pause Macro (Pause). 

On the text bar, the play button light goes off and the pause button lights up yellow to 
indicate that a macro in progress has been paused.

To advance a paused macro one step:

t Do one of the following:

- Click the Play button at the right end of the text bar.

- Select Macro > Play Macro (Alt+F2).

n The blinking cursor in the Macro window indicates where the macro is paused.
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To resume a paused macro:

t Do one of the following:

- Click the pause button near the right end of the text bar.

- Select Macro > Pause Macro (Pause). 

On the text bar, the pause button light goes off and the play button lights up green.

To cancel macro playback:

t Do one of the following:

- Click the Stop button near the right end of the text bar.

- Select Macro > Stop Macro Playback (Ctrl+Pause).

Converting a Graphic or Sequence into a 
Macro

When converting a graphic or sequence into a macro, Deko needs to determine the 
sequence of macro commands needed to recreate the graphic or sequence, and insert 
them into the active macro. If no macro is active, this process creates a new macro.

To convert a graphic or sequence into a macro:

1. Open the graphic or sequence file you wish to convert.

2. Do one of the following:

t Select Macro > Convert Graphic to Macro.

t Select Sequence > Convert Sequence to Macro.

To view and save the macro:

1. Do one of the following:

t Select Window > Select Layout > Macro Edit.

t Select View > Macro (F2).

n You see all of the commands in your macro, in Programming Language. You can edit this 
macro as you would any other, as described in “Editing Macros” on page 742.

2. To save the macro, do one of the following:

t Press F12 (SK).

t Press Save File (FAK).
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Writing and Editing Macros

Deko enables you to write a new macro or edit an existing macro.

To write a new Macro file:

1. Do one of the following:

t Select Window > Layouts > Macro Edit.

t Select View > Macro (F2).

The Macro window opens.

2. Select File > New Macro (Ctrl+N).

To open an existing macro:

1. Select File > Open (Ctrl+O or F9). 

The Open dialog box opens.
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2. Navigate to the drive and directory that contain the macro file.

3. Select the macro from the File Name menu or type the macro name in the File Name 
text box, then click Open or press Enter.

w Unlike many Windows applications, Deko does not automatically open a new window 
when you open an existing macro. If the Macro window is already open, the macro is 
opened into that window, replacing any previous macro. Be sure to save any modified 
macro before opening another macro in the same window.

About the Deko Macro Programming Language

You can write macros directly in the Macro window using the Deko Macro 
Programming Language.

The Deko Macro Programming Language combines many of the features of Visual C and 
Visual BASIC. It supports many standard programming constructs such as real and integer 
arithmetic, variables, arrays, objects, loops, conditional statements and subroutines.

Every command recognized by Deko is listed and described in detail in the Deko Command 
Reference section of the Deko Online Help.

Some commands have user-defined parameters. The Prompt button on the Command Bar 
opens a Command Prompt dialog box where you can specify parameter values. A Defaults 
button in the Command Prompt dialog box resets a command’s parameters to their default 
values.

If you have some programming experience, a quick review of this section might be all you 
need to start writing your own Deko macros.
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The following topics provide more information about the Deko Macro 
Programming Language:

• “Commands” on page 723

• “Parameters” on page 724

• “Variables” on page 728

• “Operators” on page 730

• “Comments” on page 734

• “Conditional Commands and Loops” on page 734

• “Subroutines” on page 738

• “Return Values” on page 739

• “Objects” on page 740

• “Data Type Conversions” on page 741

Commands

Commands are the basic building blocks of any macro. A command is a direct instruction to 
Deko to perform a function. A Deko command might include alphanumeric characters and 
underscores (_). The first character may not be a number. A few examples of valid 
commands are:

• justify

• rotate

• str2num

• edge_shader

Deko commands fall into several categories. Some categories correspond directly with items 
on the Deko menu bar (such as, File, Edit, Channel, Layer, Macro, Sequence, and so on.) 
Other categories exist for commands that are language specific, such as program flow 
commands (such as, if, while, return) and mathematical functions (such as, 
sqrt, cosine).
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Parameters

Parameters modify a command. Each command’s parameters are specified in an order 
particular to that command. The example shows the usual order of parameters for the 
justify command:

justify [horizontal=] [vertical=]

In addition to a specific position, each parameter has a name, a keyword, such as 
“horizontal”, “vertical”, and so on. Because each parameter has a specific position in 
command declaration, however, using a keyword to assign a value is necessary only when 
the parameter is specified out of its usual order.

Even then, you can abbreviate a keyword only to as many characters as necessary to avoid 
ambiguity.

Here are several possible variations of the justify command:

Most parameters are optional parameters; they have default values and do not require 
specification unless you are assigning new values to them.

The justify command has two optional parameters.

justify [horizontal=] [vertical=]

n Brackets are a convention used throughout this manual and in on-line help to indicate that a 
parameter is optional. Do not use brackets when writing an actual macro.

A required parameter has no default value, so you must specify its value. The file_open 
command is a command with a required parameter:

file_open name=

You must supply the name of the file to satisfy the name parameter:

file_open myfile

Justify Command Variation Description

justify default (unchanged) justification

justify left bottom horizontal left; vertical bottom

justify vertical=top top vertical justification; horizontal unchanged

justify v=top top vertical justification; horizontal unchanged
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A command and its parameters normally occupy one line of a macro, and a space separates 
one parameter from the next. If a command and its parameters do not fit on one line, a 
backslash (\) at the end of the line indicates that the command continues on the next line:

file_save [name=] [comment=] [type=] [number=] \

[channel=] [-all] [glyphs=] [-bitmap] \

[-auto_comment] [-compress]

Note that the second and third lines are indented. This is just a matter of good penmanship; 
indentation and blank lines do not affect macro execution, but make the macro easier to read 
and edit.

Use semicolons (;) to separate multiple commands that appear on one line:

type “Hello there”;newline

As in the previous example, if a parameter value is a string that includes a space, enclose the 
value in quotation marks.

Parameters fall into several categories based on value type.

The following topics provide more information about parameters:

• “Real Parameters” on page 726

• “Integer Parameters” on page 726

• “Switch Parameters” on page 726

• “String Parameters” on page 726

• “Choice Parameters” on page 727

• “Object Parameters” on page 727

• “List Parameters” on page 728
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Real Parameters

A real parameter specifies any numeric value, whole or fractional, for example, 3, 9.7, -0.9, 
and so on Very large or small real values may be expressed in exponent form, for example, 
2.5e-10.An example of a real parameter is the input parameter of the sqrt (square root) 
command:

sqrt input=

Integer Parameters

An integer parameter specifies a whole number value, either positive or negative (such as, 3, 
12967, -14, 0, and so on.)

If you specify a real value for an integer parameter, Deko ignores the fractional component.

An example of an integer parameter is the number parameter of the select_style_preset 
command, which sets the current style from the list of preset styles:

select_style_preset [number=]

Switch Parameters

A switch parameter specifies a parameter that is either true or false. A true parameter is 
either preceded by a hyphen (-) or followed by =1, while a false parameter is either preceded 
by -no or followed by =0.

The following illustrates examples of the all switch parameter of the tab_clear 
command:

tab_clear -all or tab_clear all=1

tab_clear -noall or tab_clear all=0

String Parameters

A string parameter specifies one or more alphanumeric characters (for example, a letter, 
word or sentence).

A string that contains spaces or non-alphanumeric characters must be enclosed in quotation 
marks.

A typical string parameter is the name parameter of the file_open command, which opens 
the file specified by name:

file_open name=
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For example, to open the file named “my file”, the value of the parameter would be the 
string, “my file”:

file_open “my file”

Choice Parameters

A choice parameter specifies one item from a list of possible choices.

Both parameters of the justify command are choice parameters:

justify [horizontal=] [vertical=]

Possible choices for horizontal are: left, right, center, full, spread, off and 
unchanged; and for vertical: top, bottom, center, full, baseline, off and 
unchanged. 

Object Parameters

An object parameter specifies an object, a collection of values that is treated as a single item. 
Typical objects in Deko include colors, shaders, ellipses, rectangles, text layers, fonts and 
looks. 

The letter command, which adds a letter to a text layer, includes two object parameters, 
font and look:

letter [character=] [font=] [look=] [tx=]\

  [ty=] [code=] [insert=] [-show] [-attach]  

The font parameter specifies an object created by the font command, and the look 
parameter specifies an object created by the look command. 

You create an object with a command. For example, the rgb command creates a 
color object:

rgb red= green= blue=

The elements of an object correspond exactly with the command that created it. The 
parameters of the rgb command represent the amounts of red, blue and green that make up 
the color.

You can assign an object to a variable:

$gold = rgb 100 100 0
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You can specify an object parameter with an embedded command, using parentheses:

ramp top_left=(rgb 60 60 0)

List Parameters

A list parameter, also known as a repeating parameter, specifies a list of one or more values. 
Depending on the command, the values on the list might or might not be of the same type. A 
command can have no more than one list parameter, which is usually the last parameter.

The message command has a list parameter that specifies a list of strings to output on the 
Status Bar:

message list=

message “Enter” “file” “name” “of” $song

Variables

In Deko, a variable name can include any upper or lower case alphanumeric character as 
well as the special character, underline (_). The first character is always a dollar sign ($), and 
the character immediately after the dollar sign cannot be a number.

To make macros easier to read and understand, it’s a good idea to use variable names that are 
readily associated with the values they represent, for example:

$age

$name

$phone

You do not explicitly declare a variable’s data type; the data type is determined when a value 
is assigned to the variable.

The following examples illustrate how variable assignment determines data type:

Variable Assignment Data Type 

$i = 1 Integer

$XY = 3.5 Real

$message = “Goodbye Cruel World” String
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If you try to use an uninitialized variable, Deko stops executing the command or macro and 
displays an error prompt.

A variable might be an element of an array, in which case its name is the name of the array 
followed by a subscript that identifies its location in the array. A subscript must be an integer 
or an expression that returns an integer.

For example, an array named $table might include the following elements:

$table[3]

$table[42]

$table[$count+1]

$table[9999] 

Deko allocates array elements as needed. The subscripted variables in the above example 
occupy only four variable slots, not ten thousand. 

By default, most variables are local variables. A local variable is allocated temporarily 
during macro playback, then deleted automatically when the macro stops. One macro cannot 
reference a second macro’s local variables, even if the second macro is a subroutine of 
the first.

Global variables must be declared with the global command, and can be shared among 
multiple macros. Once declared, a global variable remains until you either delete it by using 
the free command, or exit Deko.

Deko has a set of built-in global variables, known as system variables, which provide 
information about the state of your system. System variables are preceded by the at-sign 
symbol (@), and are often referred to as at-sign variables.

Some system variables are read-only; you cannot change their values. Examples of 
read-only system variables are @lines and @dots, which describe the current video 
standard, and the pre-defined colors @red, @blue and @green.

Other system variables might be assigned values. For example, the system variable 
@wordwrap can be set to 0 to disable word wrap, or 1 to enable it.
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Operators

In the previous topic, you saw that variable assignment is indicated by the equal sign (=), 
which is just one of many symbols, known as operators, that represent operations performed 
on data.

The Deko Macro Programming Language uses a subset of the operators available in C, as 
well as a few additions specific to Deko.

Arithmetic operators perform mathematical operations within expressions:

You can perform arithmetic operations on one-character strings by adding or subtracting 
integer values to the character. For example, the expression “A”+1 has the value “B”.

Using single quotation marks in an expression yields the numerical value of the character 
key. For example, ’A’+1 has the value 66.

Comparison operators compare values and determine whether an expression is true or false. 
An expression is any combination of variables, commands and operators that results in a 
single value.

Arithmetic 
Operator Expression Operation 

+  $a + $b adds $a and $b

-  $a - $b subtracts $b from $a

*  $a * $b multiplies $a by $b

/  $a / $b divides $a by $b

%  $a % $b calculates remainder of $a/$b

-  -$a negates the value of $a
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An expression is true if its value is non-zero; it is false if its value is 0.

There is one string operator, for concatenation of strings:

Strings can be compared for equality and inequality using the comparison operators == and 
!=. 

Additional string operations are performed by commands. 

The index and element operators allow direct access to values that are elements of arrays or 
elements of objects:

Comparison 
Operator Expression Value 

== $a == $b True if $a equals $b

> $a > $b True if $a is greater than $b

>= $a >= $b True if $a is greater than or equal to $b

< $a < $b True if $a is less than $b

<= $a <= $b True if $a is less than or equal to $b

!= $a != $b True if $a does not equal $b

! !$a True if $a is false (equals 0)

&& $a && $b True if both $a and $b are true

|| $a || $b True if either $a or $b is true

String Operator Expression Operation

%% %a%% $b joins string $b to the end of string$a

Index or Element 
Operator Expression Data Accessed 

[ ]  $a[$b] item $b of array $a

 :  $a:$b $b element of object $a
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Bitwise operators perform operations on integers based on bit position:

The assignment operator assigns a value to a variable, and might simultaneously perform 
other operations:

Bitwise Operator Expression Operation 

<< $a << 2 shifts $a left by 2 bit positions

>> $a >> 4 shifts $a right by 4 bit positions

~ ~$a complements 1 bits to 0; 0 bits to 1

& $a & $ bitwise AND of $a and $b

| $a | $b bitwise OR of $a and $b

^ $a ^ $b exclusive OR of $a and $b

Assignment 
Operator Expression Operation 

 =  $a = $b assigns the value of $b to $a

+=  $a += 1 adds 1 to $a, assigns total to $a

-= $a -= 5 subtracts 5 from $a, assigns total to $a

 *=  $a *= 2 multiplies $a by 2, assigns product to $a

 /= $a /= 2 divides $a by 2, assigns quotient to $a

%=  $a %= 3 divides $a by 3, assigns remainder to $a

 >>=  $a >>= 4 shifts $a right 4 bits

 <<= $a <<= 4 shifts $a left 4 bits

 %%= $a %%= “ok” concatenates “ok” to $a, assigns string to $a

 &=  $a &= 2 bitwise AND $a and 2, assigns result to $a

 |= $a |= 2 bitwise OR $a and 2, assigns result to $a

 ^=  $a ^= $b bitwise exclusive OR $a and $b, assigns result to $a
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Deko uses the same order of operator precedence used by C:

Use nested parentheses to avoid ambiguity in expressions. For example:

$inc = ( ($i+1) * ($j+1) ) / 100

Operator 
Precedence Operator Description 

1 [] subscript, element

2 () parentheses

3 ! ~ - logical not, one’s complement, unary minus

4 * / % multiply, divide, modulo

5 + - plus, minus

6 << >> left shift, right shift

7 %% concatenate strings

8 < <=  > >= comparisons

9 == != equality, inequality

10 & bitwise AND

11 ^ bitwise exclusive OR

12 | bitwise OR

13 && logical AND

14 || logical OR

15 = += -= and so on assignments
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Comments

A comment is text within a macro that does not affect the function of the macro. Comments 
make macros easier to analyze and edit, especially if the macro was written some time ago 
or written by another programmer. Many programmers consider a program incomplete 
without comments. You might find the same true of your macros.

A single-line comment starts with a pound sign (#). Deko ignores text to the right of the 
pound sign.

# This comment is on a line by itself.

command # This one shares a line with a command.

Another way to create a comment is to precede the comment with /* and close it with */. 
Deko ignores text between /* and */. This way, you can create multiple-line comments.

/* This is a multiple-line comment.

None of this text affects the function

of this macro; Deko ignores

every line of it */

Conditional Commands and Loops

Conditional commands instruct Deko to execute specific commands only under certain 
circumstances. Deko supports the conditional commands if, else and elseif.

The if command includes a test expression, which evaluates to zero (false) or non-zero 
(true). A list of one or more commands, then an end command, follows the if command:

if expression=

# commands

end

If the expression is true, Deko executes the commands between if and end. 
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The if command is often used with the else command:

if expression=

# commands

else

# commands

end

If the expression is true, Deko executes the commands between if and else; otherwise, the 
commands between else and end are executed.

You can introduce more conditional actions by nesting conditions, as shown:

if $a==1

type “Hello”

else

if $a==5

type “Good-bye”

else

type “Wish you were here”

end 

end

…or more elegantly by using the elseif command:

if $a==1

type “Hello”

elseif $a==5

type “Good-bye”

else

type “Wish you were here”

end 
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Notice how indentation makes conditional statements easier to read. Indenting the 
commands between if and its corresponding end is a good practice.

Loop commands instruct Deko to execute a series of commands multiple times. Loop 
commands include loop, while and for.

The easiest way to define a loop is to use the loop command and specify the number of 
iterations:

loop [count=]

# commands

end

The macro executes the command sequence between loop and end the number of times 
specified by the count parameter. After the loop, the macro continues with the first 
command after end.

If you do not supply a count, the loop goes on forever or until you cancel macro playback or 
use a conditional statement to end the loop.

The following macro types “hello” five times, then breaks out of the loop:

$a=1

loop

type “hello”;newline

$a = $a+=1

 if $a>5

   break

 end 
end

You also can break out of a loop with the continue command, which restarts a loop at the 
top without executing commands after continue.
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This macro uses such a loop to test for and skip odd numbers and, therefore, types only the 
even numbers from 1 through 10:

$a=0

loop 10

$a = $a+=1

 if $a&1

   continue # skip odd numbers

 end

type $a

end

Conditional loop commands define both the loop and its conditional test.

The while command continues looping as long as its test expression is true. Deko evaluates 
the test expression prior to each iteration of the loop, and as long as the result is true, 
continues the loop:

$a=1

while $a<=5

type “hello”;newline

$a+=1

end

The for command, for makes an incremental loop, such as the one above, more concise:

for $a=1 $a<=5 $a+=1

type “hello”;newline

end

The initial expression $a=1 is executed once. The test expression $a<=5 is evaluated prior to 
each iteration of the loop; if the test result is true, the loop continues. The increment 
expression $a+=1 is executed after each loop iteration.
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Subroutines

There is no practical difference between Deko’s built-in commands and the macros that you 
write and store under file names. You can have one macro run another macro, simply by 
using the macro file name in the same way you would use a command.

When one macro “calls” another, the second macro is considered a subroutine of the first. 
You can call an existing macro as a subroutine or create one within your macro.

The command command defines a local subroutine, which ends with the end command.

The following macro creates, then runs the macros “boy” and “girl” as subroutines.

command boy 
type “It’s a boy!” 
end

command girl 
type “It’s a girl” 
end

if $name == “Amy” 
girl 
elseif $name == “Meg” 
girl 
elseif $name == “Mickey” 
boy 
end

The subroutines “boy” and “girl” are local to this macro. When the macro ends, the 
subroutines, like the variables, vanish. 
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Return Values

The return command directs Deko to stop the current macro or subroutine and return the 
value of its expression parameter to the macro that called it.

return [expression=]

For example, you might have a simple command called test that returns 1 if successful, or 
0 if not:

command test 
if $name == “Amy” 
return 1 
else 
return 0 
end

The subroutine test can then be called from another macro:

$result = test 
if $result == 1 
type “It’s a girl” 
end

Here are a few examples of Deko commands that return values:

$squareroot = sqrt 4.

sqrt returns the real value 2.

$test = file_open “moon over miami” 

file_open returns 1 if Deko successfully opens “moon over miami”, or 2 
if not.

$color = rgb 0 0 100

The rgb command creates and returns a color object that is then assigned to the variable 
$color.
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Objects

An object is a data structure created by a command. Typical objects in Deko include colors, 
shaders, ellipses, rectangles, fonts and looks.

The elements of an object correspond exactly with the parameters of the command that 
created it. Consider the rgb command, which creates a color:

rgb red= green= blue=

The parameters represent the amounts (from 0 to 100) of red, blue and green that make up 
the color created by the rgb command.

You can assign an object to a variable:

$yellow = rgb 100 100 0

It is not necessary to assign objects to variables before passing them to other commands. 
You can specify an object parameter with an embedded command, indicated by parentheses:

ramp top_left=(rgb 100 100 0)

You can access any element of an object with the element operator (:), to edit the element’s 
value or to assign it to a variable for use elsewhere.

To edit $yellow to make it a little less green:

$yellow:green = 80.

The green level of $yellow was 100. It is now 80.

To assign the green element of $yellow to the variable $grn:

$grn = $yellow:green

To determine the data type of an object, use the objtype command:

objtype object=
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Data Type Conversions

You might encounter situations in which you must convert a value of one data type to 
another data type. Use the following processes to convert various types of data.

To convert an integer value to a real value:

t Add the integer to 0.0 or multiply it by 1.0.

$a = 123

$b = $a*1.0

$b equals 123.0

To convert a real value to an integer value:

1. Use the command: integer 

2. Deko truncates the real number. To round numbers accurately, add .5 to the real number.

$a = 12.7

$b = integer $a+.5

$b equals 13

To convert a number value to a string:

t Do one of the following:

- Use the command: num2str 

$a = 123.45

$b = num2str $a

$b equals “123.45”

- Concatenate a null string to the number

$a = 123.45

$b = $a%%””

$b equals “123.45”

To convert a string to its numeric equivalent:

t Use the command: str2num 

$a = “123”

$b = str2num $a

$b equals 123
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To convert a string (up to 4 characters) to ASCII code (integer):

t Use the command: str2ascii

$a = “a”

$b = str2ascii $a

$b equals 97

To convert ASCII code (integer) to a string:

t Use the command: ascii2str

$a = 97

$b = ascii2str $a

$b equals “a”

To convert an object to a string:

t Use the command: obj2str

$a = @black

$b = obj2str $a

$b equals “yuv 16 0 0”

Editing Macros

Once you have recorded or created a macro, you can edit the macro.

The following topics provide more information about editing macros:

• “Editing a Macro (.mcr) File” on page 742

• “Editing a Macro Using the Replace Dialog Box” on page 743

• “Editing Macro Parameters” on page 743

Editing a Macro (.mcr) File

To edit a macro (.mcr) file:

1. To open the Macro window, do one of the following:

t Select Window > Select Layout > Macro Edit.

t Select View > Macro (F2).

2. Select File > Open (Ctrl+O or F9).

The Open dialog box opens.

3. Navigate to the drive and directory that contain the macro file.
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4. Select the file from the File Name menu or type it in the File Name text box, then click 
OK or press Enter.

5. Edit the macro manually, or with the Replace dialog box.

6. Save the macro. For more information, see “Saving Macros” on page 744.

n You can import a text (.txt) file as a macro just by opening it in the Macro window.

Editing a Macro Using the Replace Dialog Box

To edit a macro using the Replace dialog box:

1. Press Macro Edit to view your macro.

2. Place the cursor at the top line.

3. Select Edit > Replace. 

The Replace dialog box opens.

4. Type the desired commands in the Find what and Replace with fields. 

5. Click Replace or Replace All.

6. Click the Close button to close the Replace window.

7. Save the macro. For more information, see “Saving Macros” on page 744.

Editing Macro Parameters

To edit macro parameters:

1. If the Command bar is not visible, select View > Command Bar (F4).

2. Click the text box on the Command bar.

3. Type the macro file name.

4. Click the Prompt button on the Command Bar.

5. Specify parameters in the dialog box, then click OK or press Enter.

6. Save the macro. For more information, see “Saving Macros” on page 744.
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Saving Macros

Once you have recorded or edited a macro, you must save your macro. You can either save a 
macro with a new name, or save a modified macro with the same name. You can also append 
a macro to the active macro.

The following topics provide more information about saving macros:

• “Saving a Macro with a New Name” on page 744

• “Saving a Modified Macro with the Same Name” on page 744

• “Appending a Macro to the Active Macro” on page 745

Saving a Macro with a New Name

To save a macro under a new name:

1. Open the Macro window.

2. Do one of the following to save the macro:

t Select File > Save Macro As. 

t Press F12 (SK).

t Press Save File (FAK).

3. In the dialog box, navigate to the drive and directory where you want to store the file.

4. Type a new file name in the File Name text box.

5. Click OK or press Enter.

n When you save a macro, Deko automatically attaches “.mcr” to the file name. Do not type a 
different extension.

Saving a Modified Macro with the Same Name

To save a modified macro:

1. Open the Macro window.

2. To replace the previous version of the .mcr file, do one of the following:

t Select File > Save Macro.

t Press Ctrl+S or Alt+F12 (SK).

t Press Save File (FAK).
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Appending a Macro to the Active Macro

To append a macro to the active macro:

1. In the active Macro window, position the cursor where you want to insert the 
second macro.

2. Select File > Append to Macro.

3. The Append Macro dialog box opens. 

4. Navigate to the drive and directory that contain the macro (.mcr) file you want 
to append.

5. Select the file from the File Name menu or type it in the File Name text box.

6. Click OK or press Enter.

n Undo does not undo changes to a macro.

Executing Deko Macros in External Applications

The integrated Deko Macro Server is designed to allow external applications to interface to 
Deko and execute Deko macros using TCP/IP.

The Deko Macro Server supports two formats for receiving macro commands. 

• Version 1.0 conforms to the stand-alone macro server previously available.

• Version 2.0 uses an XML format, which makes it extensible for more commands to be 
added in the future.

The following topics provide more information about executing Deko Macros in 
External applications:

• “Setting Up Your Macro Server Connection” on page 746

• “Sending Macros to the Macro Server” on page 747

• “Macro Command Format” on page 747

• “Macro Server Commands” on page 750
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Setting Up Your Macro Server Connection

Since the Macro Server receives commands via TCP/IP connection, you must have your 
Network Administrator connect your system using a TCP/IP connection. 

To enable the Macro Server in the Deko user interface:

1. Select View > Macro Server. 

The Macro Server window opens.

The table describes the options in the Macro Server window.

2. Select the version of Macro Server you want to use. Options are:

- Version 1.0

- Version 2.0

3. Select the port number of the COM port (communications port) or network pipe that the 
Macro Server uses to listen for connections.

Macro Server 
Option Description 

Version Select the version of Macro Server you want to use. Options are

• Version 1.0

• Version 2.0

Port The port number of the COM port (communications port) or network 
pipe that the Macro Server uses to listen for connections.

Status The current connection status and message history.

Clear button This button clears the data in the Status box.

CMD in Unicode Select this option only if you want to send commands and receive 
replies in Unicode.

MacroServer Enabled Enables/disables the Macro Server.
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4. Select Cmd in Unicode to send and receive commands in Unicode.

5. Select MacroServer Enabled to start the Macro Server.

Sending Macros to the Macro Server

To send a macro to the Macro Server, the controlling application first needs to make a 
TCP/IP connection to the port specified in the Macro Server configuration. The controlling 
application then sends macro commands in the correct command format. For more 
information, see “Macro Command Format” on page 747.

Macro Command Format

Currently, both version 1.0 and 2.0 accept the same set of commands. The main difference is 
the format in which the commands are submitted.

More information on macro commands and return codes can be found in the Deko Comand 
Reference section of the Online Help.

The following topics provide more information on the macro command format:

• “Macro Command Formats for Version 1.0” on page 747

• “Macro Command Formats for Version 2.0” on page 748

• “Macro Command Examples:” on page 748

Macro Command Formats for Version 1.0

In version 1.0, the commands are submitted as text, and terminated with a carriage 
return/line feed combination. The actual commands are case-insensitive. Replies are also 
sent as text, and carriage return/line feed terminated.

If the first word in the incoming data contains no recognized command, the incoming data is 
assumed to be the macro to run, and RunMacro is assumed to be the desired command.



16  Streamlining Your Work with Macros

748

Macro Command Formats for Version 2.0

Version 2.0 commands are case-sensitive. They are submitted in the following format:

<xml>

<command>Command</command>

<parameters>Additional Parameters</parameters>

</xml>

Replies in version 2.0 echo the submitted command, and add two result fields: <success> 
and <reply>:

<xml>

<command>Command</command>

<parameters>Additional Parameters</parameters>

<success>True or False</success>

<reply>The command's reply (if any)</reply>

</xml>

Macro Command Examples:

The following two examples write a W command to c:\100.atx and then recalls c:\100.atx

Version 1.0:

Command 1 - writes a 100.atx file to c:\:

runmacro writetext c:\100.atx where=replace W\100\c:/tmpl.dko\This is 
line one\\

Reply:

(none).

Command 2 - Calls up c:\100.atx written in Command 1:

runmacro file_open c:\100.atx

Reply:
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(none).

n Please note that the same results could be achieved by sending the macros without the 
runmacro command (since runmacro is implied if no command is given.)

Version 2.0:

Command 1 - writes a 100.atx file to c:\:

<xml>

<command>RunMacro</command>

<parameters>

writetext c:\100.atx where=replace W\100.atx\c:/tmpl.dko\This is line 
one\\

</parameters>

</xml>

Reply:

<xml>

<command>RunMacro</command>

<parameters>

writetext c:\100.atx where=replace W\100.atx\c:/tmpl.dko\This is line 
one\\

</parameters>

<success>True</success>

<reply></reply>

</xml>

Command 2 - Calls up c:\100.atx written in Command 1:

<xml>

<command>RunMacro</command>

<parameters>file_open 100.atx</parameters>

</xml>
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Reply:

<xml>

<command>RunMacro</command>

<parameters>file_open 100.atx</parameters>

<success>True</success>

<reply></reply>

</xml>

Macro Server Commands

The following is a list of Macro Server commands available. Keep in mind that in version 
2.0 the commands are case-sensitive.

• RunMacro

• SubmitMacro

• AreMacrosComplete

• GetMacroResponse

• CancelLastMacro

• CancelCurrentMacro

• CancelAllMacros

Macro Server 
Command Description Syntax Reply

RunMacro Executes the specified Deko 
macro command, waits for 
the macro to complete, then 
returns.

RunMacro <deko 
macro command>

None if successful, otherwise it 
returns any resulting error 
message from the Macro.

SubmitMacro Executes a macro command 
and returns immediately.

SubmitMacro <deko 
macro command>

None if successful, otherwise it 
returns the resulting error 
message.

AreMacrosComplete Asks Deko if there is 
currently a macro running.

AreMacrosComplete Returns 0 if Deko is currently 
running a macro, otherwise it 
returns 1.

GetMacroResponse Retrieves the response of the 
last macro executed.

GetMacroResponse Returns the response string (if 
any) of the last macro executed.
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CancelLastMacro Cancels the last macro cued 
for execution.

CancelLastMacro None.

CancelCurrentMacro Cancels any macro that is 
currently executing.

CancelCurrentMacro None.

CancelAllMacros Cancels all macros cued to 
execute.

CancelAllMacros None.

Macro Server 
Command Description Syntax Reply
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17 Using Automation

With the Automation option, your Deko can receive commands or information from other 
computers. 

The following topics describe how to use Automation with Deko: 

• About Automation

• Using Deko Graphics with Automation

• Querying a Database from Deko

About Automation
Automation enables you to control Deko from another computer program. Typically, the 
controlling program is running on a different computer, sending commands to Deko through 
a serial line or a network connection. However, since Deko runs on a Windows platform, the 
controlling program might be running on the Deko computer.

n To determine if this option is enabled on your system, select Options > Enabled Options.

The following topics provide more information on Automation:

• “How Automation Works” on page 754

• “Customizing Deko Using Automation” on page 756

• “Accessing the Automation Interface in Deko” on page 757
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How Automation Works

Automation systems send content (words) to the Deko, which causes ATX files to be 
created. ATX files refer to template DKO files, with replaceable layers. When the ATX files 
are read up, a CG page is created by putting the content into the format specified by the 
DKO file. The ATX file can be read manually or through automation (via a Y command, or 
control codes 01, 02).

The replaceable layers in the DKO file used as a template are usually setup with word wrap 
off and shrink to fit on. Shrink to fit, also called fit-to-fill, solves a problem in 
automation—how to make sure that a long name like “George Stephanopolous” fits on 
screen.

The template is a file created by the CG operator. The template determines the layout and 
style of the text. The actual text is sent to the CG by the Newsroom automation program and 
the CG stores it as an ATX file, which can be read using Notepad.

While many Newsroom Automation Systems limit themselves to “dumping data” to the CG, 
some systems also trigger the display of the CG page. These systems are generally referred 
to as “Controllers.” On Automation systems without controllers, the CG operator reads up 
the ATX files.

For traditional Automation you need the following:

• A Newsroom Automation System.

• A Deko (with the Automation Option).

• An RS-232 serial cable between the two.

• Templates on the Deko (with replaceable layers).

For information on Setting up your Deko for Automation, refer to the Avid On-Air Graphics 
Setup and Configuration Guide. 

For information on troubleshooting Automation issues, visit the online Knowledge Base at 
www.avid.com/onlinesupport. Online services are available 24 hours per day, 7 days per 
week. Search this online Knowledge Base to find answers, to view error messages, to access 
troubleshooting tips, to download updates, and to read/join online message-board 
discussions.

For more information, see “Example of Newsroom Automation” on page 755.

http://www.avid.com/onlinesupport
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Example of Newsroom Automation

Here is an example of automation at work:  

A journalist or producer types in the names of people who appear in a news story. Those 
names, along with the name or ID number of an existing template are sent to the Deko. 
Created by the Deko operator, the template is a file, including layout, graphics, and style of 
text. The names are automatically placed in blanks on the template for display during the 
appropriate news item. In this example, Deko is receiving data “pushed” to the Deko from 
the Newsroom system. 

Deko can also “pull” data, by querying the system for information. 

The Automation option includes the following:

• I.I.I. protocol (both serial and network)

• Timecode control

• A Database connection

The following table describes what a typical series of commands from an automation system 
might look like.

Automation 
Command Description 

 first command The first command changes the “message” directory to C:\NEWS7. This is the 
directory where the .ATX files are stored, and where .DKO files are read from. Deko 
also searches the current graphics directory for the .DKO file.

n The command uses forward slashes (/) to separate the directory from the drive 
name and no colon (:). Backslashes (\) are used to separate automation 
arguments. 

second command The second command creates a file called 100.ATX, which contains two “fields” 
worth of data. The first field is “John Cheever” and the second field is “Author.” This 
ATX file refers to a template file called 2000.DKO, which must have the first two 
layers set to be replaceable.

third command The third command displays file 100.ATX. If everything goes right, the Deko now 
shows file 2000.DKO, but with “John Cheever” in the first replaceable field and 
“Author” in the second. The formatting, font, position, and so on, are as specified by 
that template file, 2000.DKO. 
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Customizing Deko Using Automation

Automation also serves as a very flexible means of customizing the Deko product for 
specific applications. An extension to the automation protocol, the “K” command, is used to 
send macros to the Deko. This allows full control of the Deko from a customized 
application. Developers have created custom applications for Deko at horse tracks, cable 
head ends, sports stadiums, and so on. 

The program controlling Deko can send commands to the Deko through a serial line or a 
network connection.

With Deko, it is easy to create simple custom interfaces for data entry and update. The 
benefits are really quite amazing. A custom interface running on the Deko serves as 
pre-packaged access to the power of the machine. This allows a relatively untrained user to 
create quite sophisticated effects. The simplified interface also helps prevent errors by 
restricting the novice operator’s options. The experienced operator can always utilize the full 
power and flexibility of the Deko.

For more information, see “About the I.I.I. Protocol” on page 757.

fourth command The fourth command creates file 101.ATX, which has two different fields worth of 
data, based on the same template file as 100.ATX. And the last command displays 101.

M\C/NEWS7\\

W\100\2000\John Cheever\Author\\

Y\100<F8>\\

W\101\2000\Justice Brennan\U.S. Supreme Court\\

Y\101<F8>\\

The Deko acknowledges each correctly formatted command with an asterisk (*). A 
message can be correctly formatted, but not have the desired result. For example, a 
command to change to a directory that does not exist, or to read up a file that is 
missing.

Automation 
Command Description (Continued)
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About the I.I.I. Protocol

The I.I.I. protocol, developed to accept Chyron‰ files,  allows you to control Deko 
externally, in two ways:

• By any external computer, using a serial input port. You can use macro commands to 
input and output arbitrary bytes and strings.

• By a newsroom automation system, such as Avid iNEWS, Comprompter, AP ENPS or 
DCM.

Timecode control allows you to precisely synchronize graphics and sequences via SMPTE 
timecode. For more information, see “Controlling Sequences Using Timecode Control” on 
page 508.

n The Automation option is not necessary to control Deko externally using Grass Valley Group 
protocols EMEM and PEGS.

Accessing the Automation Interface in Deko

To open the Automation window:

t Do one of the following:

- Select View > Automation.

- Press Alt+V, then press A (SK). 

The Automation window opens:
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The following table describes the options in the Automation window.

For more information, see “Starting Automation Immediately Every Time You Start Deko” 
on page 758.

Starting Automation Immediately Every Time You Start Deko

Deko enables you to have the Automation interface open every time you start Deko.

To start Automation immediately every time you start Deko:

1. In the Automation window, select Automation Enabled.

2. Select Options > Save Settings now.

Now, every time you start Deko, the Automation window opens.

Automation Option Description 

Type Identifies the automation protocol used. Options are:

• None

• EMEM - The protocol used with the Grass Valley Group 200 and 
300 switchers.

• PEGS - The protocol used with Grass Valley Group editors.

• I.I.I. - The optional protocol for using non-Deko commands.

ID Identifies your Deko. If only one Deko is connected to the 
automation host, the ID setting is 1.

Port The name of the COM port (communications port) or network pipe 
used for the automation interface.

Status The current connection status and message history.

Clear button This button clears the data in the Status box.

CMD in Unicode Select this option only if you want to send commands and receive 
replies in Unicode.

Automation Enabled Enables/disables the automation interface.
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Using Deko Graphics with Automation
When using Deko Graphics with automation, you must define the graphic’s layers to accept 
text data from the automation host. Once layers are defined, you can create template files, 
with the first few layers set to replace.

The following topics provide more information about using Deko graphics 
with Automation:

• “Defining a Layer for Automation” on page 759

• “Creating Template Files for Automation” on page 760

• “Using a Template to Verify a Successful Connection” on page 762

• “Enabling Your FastAction Keyboard to Read Automation Files” on page 764

Defining a Layer for Automation

To use a Deko graphic with automation, you must define the graphic’s layers to accept text 
data from the automation host. There are three ways a layer can accept automation data:

• Replace - A replace field gets its data from an automation (.atx) file. When you read an 
.atx file, Deko replaces the graphic’s replace fields with the data in the file.

• Query - The query field causes the Automation interface to request updates from the 
host at user-specified intervals. For information about connecting to standard databases 
with Deko, see “Querying a Database from Deko” on page 764.

• SQL - An SQL database query accesses various kinds of databases, either on the same 
machine as Deko or on a network. For this to work, you must install the appropriate 
ODBC driver for the kind of database you are going to query.

To define a layer for automation:

1. Open the Automation window.

2. Deselect Automation Enabled, then close the window.

3. In Deko, open a graphic, and select the layer you want to define.

4. In the Style dialog box, click the Layer tab. 

n If the Auto Update selections are not visible, click More at the bottom of the window.
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5. Under Auto Update, do one of the following:

t If you want to have the automation interface check for updates within a specified 
timeframe, click the Query button, then enter an update frequency. The query 
update frequency specifies the number of seconds between requests to the 
automation host for updates. If update frequency is set to zero, the automation 
interface issues the request only once, when the file is opened.

t If you want Deko to replace the graphic’s replace fields with the data in the .atx file, 
click the Replace button.

t If you want Deko to request data from the specified database, click the Sql button. 
For more information, see “Querying a Database from Deko” on page 764.

Creating Template Files for Automation

Template files are simply Deko files that have the first few layers set to “replace.” There are 
two methods to create template files. This section describes one method of creating a 
template file, which is then completed by the Newsroom Computer System.

The following topics provide more information about creating a template file for 
automation:

• “Creating a Template File to be Filled in by Your Automation Interface” on page 760

• “Reassigning Order for Template Layers to Replace” on page 762

Creating a Template File to be Filled in by Your Automation Interface

If you are more familiar with Deko, you could create the file using text fields, rather than 
using Text To Field after layout is completed. If so, start on Step 3.

To create a template file to be filled in by your Automation interface:

1. Within Deko, design your look, selecting the fonts and colors. If you want, you can 
design it using just one layer, and type example text onto the screen.

n After you have designed and created your look, you are ready to create the text fields. Each 
text block that needs to be updated through automation must be put into its own layer. 

2. Repeat the following steps for each group of words:

a. Highlight the text.

b. Select Text > Text to Field. This makes the highlighted text its own layer.
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3. Change the properties of the layers that will be filled in by automation by selecting 
Layer > Properties. 

The Text dialog box opens with the Layer tab selected.

n The CG page can consist of both replaceable and non-replaceable layers. There are two 
screens for this window. 

4. Click the More button. 

The Text dialog box changes to show a Justification section at the top and an 
Auto-Update section at the bottom. 

5. For each text layer that will be filled in by Automation, do the following:

a. In the Auto-Update section, click the Replace button. The text you had typed into 
the layer is erased when you do this. This setting allows the layer to be updated 
through the Automation Interface.

b. Select shrink-to-fit.

c. Deselect Word Wrap. 

d. Optionally, you can select the alignment of text for the layer.

e. Press Alt+PageUp to move to the next layer.

n “Text field” and “layer” are two names for the same thing. Deko can also have graphic 
layers, which are rectangles. 

Although as a rule, the first few layers must be replaceable, you can play some tricks. For 
example, if you want to have a semi-transparent rectangle, or other graphic layer, or text 
layer with a logo, that appears on top of one or more of your replaceable layers, you must 
give it a lower layer number. Suppose you want one layer to appear on top of the rectangle, 
and the other two to be semi-obscured by the rectangle. 

The solution is easy: make layers 1,3 and 4 your replaceable layers, and set the rectangle as 
layer 2. Then, have your automation system send four fields of data. The second field is 
ignored by the non-replaceable layer, but the other three fields of data are accepted.

6. Reassign the layer order of the layers that are set to Replace starting with the first layer 
to be updated as layer one. To reassign the layer order, do the following for each layer:

a. Select each layer.

b. Press Ctrl+ to bring the layer forward or Ctrl- to bring the layer back. 

n Layer One receives the first set of data from the Automation Interface; Layer two gets the 
second, and so on.
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7. Record the file as a DKO file. 

n For most News systems, the template file must be a number. This file is your Template. 

8. To save the file, do the following:

a. Make sure the graphic window is selected.

b. Select File > Save Graphic As. 

The Save Graphic As dialog box opens. 

c. Type in the number that you have decided to assign to this template (such as 900), 
and press Enter.

When you are done with this procedure, you should have a file that has layer 1 set to 
“Replace.” And, optionally, layer 2, 3, and so forth.

n To use a graphic with replaceable fields, click Options > Preferences. Click the Common tab 
and make sure Use bitmap, if available, rather than rerendering is not selected.

Reassigning Order for Template Layers to Replace

To reassign order for template layers to Replace:

1. Select a Layer. 

2. In the Style window, click on the ID arrow under Auto-Update to assign priority order. 

Using a Template to Verify a Successful Connection

When a successful connection is made between the Deko and the external control program, 
data displays in the Automation window. When a complete command is sent to the Deko, it 
responds with an asterisk “*”.

For more information, see “Example of a Successful Connection” on page 763.
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Example of a Successful Connection

A Newsroom Automation system sends:

W\100\900\layer one text\layer two text\\<0D> <OA>

Deko responds:

*

You can see the messages in the display area within the Automation window:

In this example

• W = Write to layer

• 100 = Name of the ATX file where the transmitted text is stored

• 900 = Name of the template file

• Layer one text = transmitted text for the first layer (must be set to “Replace”)

• Layer two text= text for the second layer (must be set to “Replace”)

• \\ = Command terminator

• <OD> = Carriage Return 

• <OA> = Line Feed

In response to this command, the Deko creates a file called 100.ATX, which contains the 
two lines of text that were sent by this command. The name of the .dko file serves as the 
template— in this case, 900.DKO.

1. In Deko, select File > Open. The Open dialog box opens.

2. Type in the full name of the file (100.ATX) and press Enter.

3. The Deko looks into 100.ATX, to see which template file it refers to. File 900.DKO is 
read from disk, and its replaceable fields filled with the data in 100.ATX.

n Some automation systems also send commands that cause the Deko to display the CG page. 
For example Y\100<F8>\\ triggers the display of file 100.ATX.
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Enabling Your FastAction Keyboard to Read Automation Files

IF you have a FastAction Keyboard and you are using Automation, you should make sure 
that your keyboard is enabled to read Automation files.

To enable your FastAction Keyboard to read automation files: 

1. Select View > Browser.

2. Select File > Change Directory/File Type. 

The Change Directory dialog box opens.

3. From the List files of type menu, select All Deko Files, or any other choice that would 
include .atx files.

4. Click OK.

5. Select Options > Preferences. 

The Preferences dialog box opens.

6. In the Common tab, select Enhanced Keypad (if it is not already selected.)

Querying a Database from Deko
The Automation option includes a dynamic feature that enables Deko to read and display 
information from a database. This means you can set up a layer to query a database and 
display the value of a field within that database.

A database query differs from Deko’s existing query feature, which sends inquiries to a 
newsroom automation system. Database queries send inquiries to database files, which can 
be stored on a local system drive or accessed by a LAN or WAN.

To use the database connection feature, you must have the ODBC driver installed to support 
the database source. The ODBC driver is automatically installed during installation and 
setup of your database software package. You must also specify a data source name (DSN). 

The following topics provide more information about querying a database from Deko:

• “Viewing Installed ODBC Drivers” on page 765

• “Specifying a DSN” on page 765

• “Setting Up Layers to Query a Database” on page 766
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Viewing Installed ODBC Drivers

To view installed ODBC drivers:

1. Click Start at the bottom of your desktop.

2. Select Settings > Control Panel. 

3. In the Control Panel window, double-click the ODBC Data Sources icon.

4. In the ODBC Data Source Administrator dialog box, click the Drivers tab.

Specifying a DSN

To specify a DSN:

1. Click Start at the bottom of your desktop. 

2. From the menu, select Settings > Control Panel.

3. Select the ODBC icon to open the ODBC Data Source Administrator dialog box.

4. Select one of the following depending on how you want to create the data source:

t User DSN - creates a data source visible only to you and only usable on the 
current machine.

t System DSN - Creates a data source that is visible to all users on the 
current machine.

t File DSN - Creates a data source that enables you to connect to a data provider and 
which can be shared by multiple users who have the correct driver installed.

5. Click the Add button.

6. Select the driver for which you want to set up a data source.

7. Click Finish.

8. Type in a Data Source Name.

9. Click the Select button.

10. Navigate to the database file, then click OK. 

11. Click OK two more times to close the dialog box.
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Setting Up Layers to Query a Database

To set up a layer to query a database:

1. Select the layer.

2. Select View > Database. 

The Database dialog box opens.

3. Select a Database Name. Database names are defined in the ODBC Data Source 
Administrator. 

4. Select Connect. This enables Deko to connect to the specified database.

5. Select a table from within the database from the From Table menu.

6. Specify a record within that table by selecting a Record Number.

Select a Record number.

Select a table from the 
database.
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7. Type a value for the field in the Field Value field. This can be “hard-coded” as a specific 
value, or you can enter the variable, $FieldValue, then use the Command Bar to 
update the value of the variable. For more information, see “Using a Variable Field 
Value” on page 767.

8. In the Display Field field, select the field whose data you want to display in the layer.

9. Enter a value in the Frequency box to specify how many seconds to wait between 
requests to the data source for updates. If Frequency is set to zero, the Automation 
interface issues the request only once.

10. Click Create Query to associate this database query with the current layer.

n If you want the database to read the query associated with the current layer into the 
Database window, select a layer that has been previously set up for database query, then 
click Read Query to display options already specified for that layer in the Database window.

Using a Variable Field Value

To use a variable Field Value:

1. Select View > Command Bar.

The Command bar opens at the bottom of the desktop.

2. In the text box on the command bar, type $FieldValue=n (where n is the value).

3. Click Play to play the command.

4. Set up a graphic layer to query a database, and select $FieldValue in the Field Value in 
the Database window.

Setting and Using Global Field Values

To set a Global Field Value:

1. Select View > Command Bar to open the Command bar at the bottom of the desktop.

2. In the text box on the command bar, type global $FieldValue.

3. Click Play to play the command.

To use a Global Field Value:

1. Set layers Field Value to $FieldValue.

2. Click Create Query.

3. From the Command bar, type $FieldValue = n (where n is the value).

4. Play the command. All values should update.
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18 Accessing Optional Interfaces

Deko enables you to use two powerful, optional interface (DekoObjex). 

The following topics provide brief descriptions and access instructions for DekoObjex: 

• About DekoObjex

About DekoObjex

n To see if this option is enabled on your system, select Options > Enabled Options.

DekoObjex is a dynamic tool for incorporating real time data, audio and video playbacks, 
and cel animations in a master control environment. Use DekoObjex to:

• Create scenes comprised of layered visual and audio objects.

• Animate scenes by attaching actions to objects.

• Control the playback of objects in a scene.

For complete information, see the DekoObjex User's Guide or the DekoObjex Online Help.
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To access DekoObjex Controller for playback of scenes:

t From Deko, select View > DekoObjex Controller. 

The DekoObjex Controller opens:
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To access the DekoObjex Author for creating scenes:

t Do one of the following:

- Select View > DekoObjex Author.

- On the DekoObjex Controller, click the DekoObjex Author button.

The DekoObjex Author interface opens.

To return to Deko:

t Do one of the following:

- Click Close at the top right of your title bar if you are not planning to use 
DekoObjex again in this session.

- Click Minimize at the top right of your title bar to keep DekoObjex on while you 
use your Deko interface.

To return to the DekoObjex Controller from the DekoObjex Author:

t Click Minimize at the top right of your title bar to keep DekoObjex Author on the 
taskbar while you use the Controller interface.
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A Using FastAction Keyboard 
Functionality

The optional FastAction keyboard is designed to allow you to harness the power of Deko 
with as much speed as possible. For more information on the FastAction Keyboard, see 
“Using Your Keyboard” on page 45. Specific instructions for completing tasks with the 
FastAction Keyboard are found throughout this User’s Guide and are designated FAK. This 
appendix includes the following:

• An illustration of the FastAction Keyboard, showing location and description of 
all keys.

• An alphabetical listing and description of all FastAction Function keys.

• FastAction Keyboard tips.

• Information on how to Perform FastAction Keyboard Functions using a 
Standard Keyboard.

The following topics are included:

• FastAction Keyboard Commands and Keys

• FastAction Keyboard Tips

• Performing FastAction Keyboard Functions Using a Standard Keyboard
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FastAction Keyboard Commands and Keys

The following illustration includes callouts that point out where the various FastAction 
Keyboard Commands are located on the keyboard. The list following the illustration 
references the callouts with more detailed descriptions of the keys.

FastAction Keyboard (FAK) Quick Start Chart

The following topics provide more information about the FastAction Keyboard:

• “FastAction Keyboard (FAK) Callout Descriptions” on page 775

• “FastAction Keyboard Function Key Descriptions” on page 777
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FastAction Keyboard (FAK) Callout Descriptions

The following table provides descriptions for the FastAction Keyboard Chart.

FAK Callout Description 

A. Graphics Counter Use the graphics counter (alphanumeric display) to view the numeric location of a 
file as it is being typed. Press the Read key to recall the file to the currently selected 
window. The counter advances to display the next sequential file. Press the Prev (-) 
and Next (+) keys on the numeric keypad to cycle through all files (alpha and 
numeric) in the current directory.

B. The Numeric Keypad Press the Num Lock key to enable. A yellow light illuminates. This provides fast 
access to reading files. You can quickly call up graphics with numerical file names 
by typing the filename on the numeric keypad. Press the Read key to open to the 
currently selected window.

C. Read Type the numeric location or press the Prev (-) or Next (+) keys to display a file in 
the graphics counter. Press the Read key to open that file to the currently selected 
window. Pressing Clear, then Read displays the Open dialog box. You can navigate, 
then double-click on a filename to open into the currently selected window.

D. Smart Read Keys 
(Read Preview and Read 
Program)

These keys automatically open the entered filename to either the Preview or 
Program channel without changing focus of the current window. This allows 
random access to either channel with a single keystroke.

E. Playback and Macro 
Edit keys

Playback controls for sequences and single effects including Stop and Play. Pause is 
executed by pressing the Play key while an effect is in progress. Press the Macro 
Edit key to open the Macro Edit window in any layout. A combination of commands 
can be typed or recorded to this window, then saved as a *.mcr file. 

F. Text formatting tools These keys include Page Up/Down keys to select layers, Home/End keys to insert 
cursor inside layer, Delete key to delete selected items, and the Insert key to toggle 
INS and OVR modes of typing text. Layers and text can be manipulated on screen 
with Transform Tools. Controls for transforming can be accessed by pressing the Alt 
key down and the directional arrows.

G. Preset Macro key You can store macro to a character assignment and execute them by pressing the 
Preset Macro key and the desired character.

H. Tab Set Position your cursor and press the Tab set key to insert a Tab stop in the following 
formats: Left, Center, Right, and Decimal.

I. Undo/Redo keys You might want to Undo or Redo a particular action. Pressing the Undo key reverses 
keystrokes and mouse-clicks until you have reached a desired state. The Undo 
function must be enabled in the Edit menu and must have been enabled while you 
executed the actions you wanted to undo.
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J. Macro Record & Cmd 
key

Press the Learn key to turn on Macro Record. This records all keystrokes and mouse 
clicks to the Macro Edit window. Open this window to view the commands. Press 
the Cmd key and type the Macro filename to play a Macro.

K. Browse 
Graphics/Typefaces

Press the Browse Graphics key to open a window of thumbnail images displaying all 
graphic files for the current directory. Press the Browse Typeface key to display 
thumbnail images for all fonts loaded on the system.

L. Preset Style keys Select text, then press any one of eight Preset Style keys to load the look and font 
displayed in the same position of the Preset Style window, located at the bottom of 
the Style Edit layout.

M. Function keys Deko's twelve Function keys are enhanced with quick access to commonly used text 
functions. These include font selection, treatment, size, and spell check. To access 
additional functionality, select Options > Preferences > Common, then select 
FastAction Function Keys. Functions are listed in the following section.

N. Dual Channel 
Selection 

For multi-channel (2 program and 1 preview) systems, press the Pgm A or Pgm B 
keys for quick dual-channel selection.

O. Transform Tools Use these tools to manipulate layers and text on screen. They include Move, Scale, 
Rotate/Skew, and Kern/Lead. Hold down the Alt key and press the directional 
arrows to control transforming.

P. Clear Preview and 
Program 

Clear Preview and Program channels with a single keystroke. This reverts the 
graphic to a default state containing one default text layer.

Q. Delete Files and Save 
Files 

Delete files and save files rapidly by entering the numeric location. Press the Delete 
or Save key twice to execute that function. The graphic counter advances to the next 
sequential location.

FAK Callout Description (Continued)
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FastAction Keyboard Function Key Descriptions

The following table describes each FastAction function keys found on a FastAction 
keyboard. The table lists the keys in alphabetical order.

FAK Function Key Description

Browse Graphics Activates/deactivates the Graphic Browser window.

Browse Typeface Activates/deactivates the Typeface Browser window.

Center Row Toggles centering on current cursor row.

Char In conjunction with arrow keys, moves, scales, rotates, skews, or kerns characters, 
depending on which tool is selected.

Clear Clears the alphanumeric display.

Clear Preview Erases the graphic in the Preview window.

• Ctrl + Clear Preview - Clears layers in the Preview window.

• Shift + Ctrl + Clear Preview - Clears background in the Preview window.

• Alt + Clear Preview - Clears text in the Preview window. 

Clear Program Erases the graphic in the Program window.

• Ctrl + Clear Program - Clear layers in the Program window.

• Shift + Ctrl +Clear Program - Clears background in the Program window.

• Alt + Clear Program - Clears text in the Program window.

Cmd Activates the macro or command bar.

Color 1 - Color 8 Selects the face shader for the current style from the first eight preset shader 
chiclets.

Delete File Deletes file open in the active window.

Effect Activates single Effect Playback layout.

Font Activates the Style/Font window.

Help Activates Deko Online Help.

Justify Activates the Justify dialog box.

Kern Selects the kerning tool.

Layer In conjunction with arrow keys, this key moves, scales, rotates, skews or kerns 
layers, depending on which tool is selected.
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Learn Turns macro learn/record mode on.

Look Activates Style/Look window.

Lower Third Justifies text in current field as a lower third.

Macro Edit Activates the Macro Edit layout.

Move Selects the move tool.

Objex Hold this key down and press a number from the Number pad to select an action in 
the Open scene in the DekoObjex controller interface.

Alt+Objex - Open the DekoObjex Controller

Pause Pauses sequence playback.

Pick Style Picks up the style of the character at the cursor position.

Play Active window determines what plays. Sequences, effects, macros, and clips 
associated with a graphic can be played with this key. Ctrl+Play plays a Preview 
graphic’s associated effect.

Preview Activates the Preview window.

Preset Macro You can store macro to a character assignment and execute them by pressing the 
Preset Macro key and the desired character.

Print Screen Provided for standard PC keyboard to capture an image of the content on the VGA 
monitor. The image is recorded on the system’s internal clipboard and can be 
pasted to a bitmap in a Paint application.

Program A or  
Program B

Activates the Program window.

Ctrl+Prog - Places window in initial layout.

Read Reads in the file shown in the alphanumeric display or, if the display is cleared, 
activates the read dialog box. Functions as the Enter key when Enhanced Keypad is 
off.

Read Preview Reads the graphic whose filename appears in the alphanumeric display into the 
Preview window.

• Ctrl+Read Preview - Replace Preview window layers. 

• Shift+Ctrl+Read Preview - Replace Preview window background.

• Alt+Read Preview - Replace Preview window texture.

FAK Function Key Description
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Read Program Reads the graphic whose filename appears in the alphanumeric display into the 
Program window.

• Ctrl+Read Program - Replace Program window layers. 

• Shift + Ctrl + Read Program - Replace Program window background.

• Alt + Read Program - Replace Program window texture.

Redo Undoes Undo.

Rot/Skw Selects the Rotate/Skew tool.

Row In conjunction with the arrow keys, moves, scales, rotates, skews or kerns rows, 
depending on which tool is selected.

Save File Opens the Save file dialog.

Alt + Save File - Saves the file open in the active window.

Scale Selects the Scaling tool.

Scroll Lock Provided for standard PC keyboard.

Seq Edit Activates the Sequence Playback layout.

Shader Activates the current Shader window.

Stop Stops play of a sequence, an effect, a macro, a motion, depending upon the active 
window. If the Clip Edit window is open and a clip is playing, Stop pauses the clip. 
If the Clip Edit window is open and a clip is cued, Stop stops the clip.

Style 1 - Style 8 Selects preset styles from the currently active Preset Styles window.

Alt+Style 1-8 - Assigns current style to a preset style button in the currently active 
Preset Styles window.

Tab Set Sets a tab stop at the current cursor position.

• Ctrl + Tab Set - Clears a tab stop.

• Alt + Tab Set - Clears all tab stops.

Undo Undoes changes to the current graphic, style, style presets, shader, or sequence. If 
the most recent action is not reversible, Undo is unavailable.

FAK Function Key Description
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FastAction Keyboard Tips

Here are some FastAction keyboard (FAK) tips to help you perform some basic tasks using 
the keyboard.

The following topics provide some FastAction Keyboard tips:

• “Using the FAK to Get Random Graphics to Air” on page 780

• “Using the FAK to Get Sequential Graphics to Air” on page 780

• “Using the FAK to Call Up Files with Numerical Filenames” on page 781

• “Using the FAK to Read in Any Filename” on page 781

• “Using the FAK to Enable Reading Automation Files” on page 781

Using the FAK to Get Random Graphics to Air

Use the FAK to quickly get random graphics to air:

1. Press Num Lock to enable the numeric keypad. A yellow light comes on.

2. Press the Effect key to change layout displaying the Preview and Program channels.

3. Press Clear Preview and Clear Program.

4. Look at the graphics counter on the FAK. If a file location is displayed, press the 
Clear key.

5. Type a numeric file location.

6. Do one of the following:

t Press Read Preview or Read Program. The next file number in the series displays in 
the counter.

t Press Next (+) key to skip the next file in the series and advance to the one after that.

Using the FAK to Get Sequential Graphics to Air

Use the FAK to quickly get sequential graphics to air:

1. Press Clear Preview and Clear Program.

2. Type a file number.

3. Press the Read Preview key. Press the Read next key as many times as necessary to read 
all files. You see sequential files read into the Preview channel then swap to the Program 
channel all in a single keystroke.
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Using the FAK to Call Up Files with Numerical Filenames

Use the FAK to quickly call up files with numerical filenames:

1. Click in the window where you want the file to open. 

2. Type the filename on the numeric keypad.

3. Press Read. The display shows the filename as it is being typed, and advances to the 
sequential file when you press Read. The keyboard displays any alphanumeric filename, 
but only numeric filenames can be entered on the numeric keypad. 

Using the FAK to Read in Any Filename

Use the FAK to read in any filename:

1. Press Clear to clear the display

2. Press Read. 

The Read dialog box opens.

3. Type the filename.

n Occasionally, for technical reasons such as an incompatible cable extender, you might not 
want to send messages to the FastAction Keyboard. In this case, from the menu Options 
menu select Preferences, Common Page. Make sure FastAction lights is not selected. This 
prevents unwanted interference with certain keyboard extenders. When FastAction lights is 
deselected, the keyboard is not lighted and Deko does not present any keyboard display.

Automation files (.atx or .aut) can be read on the FAK just like other types of Deko files.

Using the FAK to Enable Reading Automation Files

Use the FAK to enable reading automation files: 

1. Select View > Browser.

2. Select File > Change Directory/File Type.

The Change Directory dialog box opens.

3. Select List files of type > All Deko Files (or any other choice that would include .aut or 
.atx files).

4. Click OK.

5. Select Options > Preferences. 

The Preferences dialog box opens.

6. In the Common tab, select Enhanced Keypad (if it is not already selected).
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Performing FastAction Keyboard Functions Using 
a Standard Keyboard

Even without a FastAction Keyboard, Deko enables you to perform some FastAction 
keyboard functions on a standard keyboard. 

This is done by enabling or disabling the FastAction Function keys within your Deko 
Preferences.

To make your function keys act as formatting keys rather than Command keys:

t Select Options > Preferences > Common tab, and then click on FastAction Function 
Keys to select it. For more information, see “Using a Standard Keyboard (SK) to 
Perform Formatting Commands” on page 783.

To make your function keys act as commands rather than formatting keys:

t Select Options > Preferences > Common tab, and then click on FastAction Function 
Keys. For more information, see “Using a Standard Keyboard (SK) to Perform 
Command Functions” on page 784.
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Using a Standard Keyboard (SK) to Perform Formatting Commands

If you are using a Standard Keyboard, you can enable the FastAction Function keys so they 
perform Formatting functions.

To make your function keys act as formatting keys rather than Command keys:

t Do the following:

a. Select Options > Preferences > Common tab.

b. Select FastAction Function Keys.

FAK Function Key Standard Keyboard Formatting Key Description 

F1 (Typeface) Accesses a list of typefaces in the Text Bar.

F2 (Size) Accesses the typeface size value in the Text Bar.

F3 (Bgd) Toggle to turn the background off and on.

F4 (Face) Toggle to add or delete the first face detail of a style.

F5 (Edge) Toggle to add or delete the first edges detail of a style.

F6 (Shdw) Toggle to add or delete the first shadow detail of a style.

F7 (Uline) Toggle to add or delete the first underline detail of a style.

F8 (Frame) Toggle to add or delete the first frame detail of a style.

F9 (Bold) Makes the current text selection bold.

F10 (Italic) Makes the current text selection italic.

F11 (Small Caps) Makes lower case letters in the current text selection appear as 
small capital letters.

F12 (Spell Check) Opens the Spell Check dialog and looks for edit of current text 
selection. 
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Using a Standard Keyboard (SK) to Perform Command Functions

If you are using a Standard Keyboard, you can disable the FastAction Function keys so they 
perform Command functions.

To make your function keys act as commands rather than formatting keys:

t Do the following:

a. Select Options > Preferences > Common tab.

b. Deselect FastAction Function Keys.

Item Standard Keyboard Command Shortcut

Layouts Style Edit Layout Alt+F11

Effect Layout Shift+F11

Sequence Layout F11

Motion Layout Ctrl+Shift+M

Macro Layout F2

Clip Editor Ctrl+E

Browsers Graphic Browser Ctrl+L

Layer Browser Ctrl+Shift+B

Transform Tools Move Ctrl+M / Arrows

Scale Ctrl+W / Arrows

Kern/Lead Ctrl+K / Arrows

Rotate/Skew Ctrl+R / Arrows

File Commands Open F9 or Ctrl+O

Save As F12

Overwrite Ctrl+S

Focus Program F5

Preview Alt+F5

New window, clockwise Ctrl+Tab

New window, counterclockwise Ctrl+Shift+Tab
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To Air Play Alt+Enter

Stop Pause

Read Next F10

Read F9 or Ctrl+O

Swap F3

Transfer Previous to Program Ctrl+F3

Transfer and Read Next F10

Function Keys in order Help F1

Macro F2

Swap F3

Command Bar F4

Graphic F5

Style F6

Shader F7

Clear F8

Read (Open) F9

Read Next F10

Sequence Layout F11

Record (Save) F12

Item Standard Keyboard Command Shortcut
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B Using Shaped And Unshaped Keying

Working with multiple sources in a video production environment requires a mixing 
operation to properly combine independent Video + Key elements. This operation is 
normally found in graphics systems, character generators, DVEs (Digital Video Effects) and 
switchers that are used for On-Air broadcasts. Traditionally, two different methods of keying 
have been used in this environment: “Shaped” and “Unshaped” Keying. These two methods 
cannot be used interchangeably and can sometimes lead to confusion and improper 
operation.

The following topic is included:

• Shaped vs. Unshaped Compositing

Shaped vs. Unshaped Compositing

In the broadcast environment, video and key signals are normally transported on two 
separate signals. The terms “Shaped” and “Unshaped” refer to how a separate key signal is 
used in conjunction with an associated video (or fill) signal to represent a 
non-opaque source. 

The following topics provide more information about shaped and unshaped compositing:

• “Shaped” on page 788

• “Unshaped” on page 789

• “Mathematical Equations” on page 790

• “Comparison Matrix” on page 791
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Shaped

“Shaped” refers to a video and key pair that has the key “pre-applied” (or pre-multiplied) to 
the video signal. This is most apparent on objects with a soft, semi-transparent border as 
shown in the following illustration. 

In this example, the letter “O” has a soft border that is apparent on both the video and key 
signals. Once this graphic is keyed, the background image shows through the 
semi-transparent border as shown in the following illustration. 

Shaped Video Signal Shaped Key Signal

Keyed Result
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Unshaped

“Unshaped” refers to a video and key pair that does not have the key “pre-applied” to the 
video. In this case, all transparency is represented by the key signal. The following 
illustration shows the same example in the unshaped environment.

Once this graphic is keyed, the background image shows through the semi-transparent 
border just as in the shaped case, as shown in the following illustration.

Unshaped Key SignalUnshaped Video Signal

Keyed Result
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Mathematical Equations

A keyer or switcher that combines two keyed sources must take into account their formats 
(shaped or unshaped). Two distinct mathematical functions are used depending on the 
format of the keyed inputs. The equations are as follows.

Unshaped Keying uses the following equations for mixing two Video + Key sources:

Kout = Kforeground + Kbackground * (1 – Kforeground)

Vout = Vforeground * KX + Vbackground * (1 – KX)

where KX = (Kforeground - Kforeground*Kbackground) / Kout 

Shaped Keying uses the following equations for mixing two Video + Key sources:

Kout = Kforeground + Kbackground * (1 – Kforeground)

Vout = Vforeground + Vbackground * (1 – Kforeground)

While the Key equation is the same in both cases, the Video equation is much simpler for 
Shaped Keying than for Unshaped. Having the Key pre-applied to the Video greatly reduces 
the computations required produce the combined result. It is for this reason that shaped 
keying has become standard in the world of graphics and multi-layer compositing.
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Comparison Matrix

Due to the simplified nature of working with multiple layers, graphics systems have relied 
on Shaped keying for all compositing functions. Conversely, live DVE systems have 
traditionally used unshaped keying as applying effects to full screen video is easier in 
this domain.

The following comparison matrix summarizes some of the main differences between 
working in the shaped and unshaped domain.

Function Shaped Unshaped

Keying Process Additive (Simple) Multiplicative (More complex)

Preview Previewing video properly displays 
transparency properties.

Previewing video does not display 
transparency properties (no soft borders).

Standardization Most graphics, compositing, and computer 
based systems use Shaped keying processes.

N/A

Production Switches Most modern switchers support Shaped 
keying. However, some older analog 
switchers only support Unshaped keying.

Most switchers support Unshaped 
keying.
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Symbols
.mov files

importing as Power Clips 481

A
Abbreviations

keyboard 32
Access

function with Alt key 57
Action

adjusting timing 535
deleting 539

Action List 523
Activate

Macro window 721
Motion window 522
shader 108
single effect 777

Active motion
appending a motion to 539

Add
details to a look 95
ellipse to a layer, using keyboard 165
ellipse to graphic, using mouse 165
rectangle to a graphic, using keyboard 162
rectangle to graphic using mouse 164
text field to a graphic 159

Adding
File properties to a graphic 406
Local behaviors 553
Targeted behaviors 560

Adjust timing
of an action 535

Adjusting
volume in imbedded audio 463

Advance a paused macro by steps 719
Air

graphics to, quickly 780
Aliasing

filtering fonts to prevent 93
Align

key clip with fill clip 447
Alignment

texture 126
Allcaps 145
Allsmalls 145
Alpha channel 415

saving TIFF and TARGA files with 416
Alt key 775

accessing functions 57
Append

graphic to another graphic 185
macro to the active macro 745
motion to active motion 539
sequence to another sequence 508

Apply
cel animation to a detail 130
color 109
detail to ramp 113
highlighting to a ramp 116
keyed video to a detail 126
Preset shader to a detail 135
texture to a detail 119
video to a detail 126

Arithmetic operator 730
Array

accessing elements of 731
subscripting elements of 729

ASCII
converting code from string 742

Aspect ratio 419
changing 681, 681

Index
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Assign
key clip to a fill clip 446
macros to preset macro key 718

Assignment operator 732
Associate

clip with a graphic 494
clip with graphic 466

Associated effect
determining 586
playback 586

Associated effects
playing automatically 503

Aston file
converting to Deko 430

Aston font
mapping to a TrueType font 430

Aston Import 430
At-sign variable 729
Audio volume

adjusting 463
Author 771
Automatic

playing associated effects 503
saving of preferences 697

Automatic comment
saving graphic with 406

Automation
creating template for 760
defining a layer for 759
defining layers for 759, 759
graphics 759
window 758

Automation option 753, 760
Auto-Motion

and effect playback 594
checking all files 591
checking for motion files 591
compared with Motion Playback 585
construction of 587
described 584
determining if available 587
opening 592
saving 591
saving with a new name 591
terminology 585
viewing motions and graphics in graphic class 590

B
Background 71

apply motion suppress to 711
applying color to 156
clearing from graphic 229
on or off 154
opening a graphic into 157
shader 156
turning into a layer 158

Baseline
aligning texture with 125
changing angle of 92, 206
editing 243

Bézier curve 242
Bitmap

saving a fully rendered 405
Bitwise operator 732
Block file utility 411
Blur

face 98
Blurring

frame 105
underline 104

Bold
applying or removing 144
version of current typeface 91

Break command 736
Brightness

color 111
Browse

for graphic files to add to a sequence 507
for images 435

Browse Graphics key 776, 777
Browse Typeface key 776, 777
Browser

clip 442
layer 180
texture 120, 359
typeface 91

Browser database
deleting clips from 445

Bulleted graphic 373

C
Cancel
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changes to a baseline 243
CAP shader 82, 107, 130
Cel animation 130

applying to a detail 130
playing 540

Cel animation player
shader 82, 107

Center Row key 777
Change

attributes of a look 95, 96
character width, using the keyboard 197
current font attributes 87, 89
decimal tab character 245
desktop layout 677
information on a leaderboard 371
leading, using the keyboard 196
leading, using the mouse 197
pin location of a character 327
set width of a character 327
speed during roll or crawl playback 612, 616
text case 192
text field box with keyboard 179
text field box with mouse 179
type of a point on a baseline 240
video standard 681, 681

Channel selection
dual 776

Char key 777
Character

baseline angle 92, 206
decimal tab 683
kerning 92, 196
pin location 327
scaling 218
set width 327
spacing 92, 195
style at cursor 778
typing from an international character set 70
width 198

Character glyphs
specify if saving 405

Character set
International 70
international 69

Chart and Graphs 247
Chart Designer

accessing 247

Charts
advanced controls 255

Child actions 596
Chyron bitmap font

mapping onto a TrueType font 431
Chyron Import option 430
Chyron logo font

converting to custom typeface 431
Clear

as a transitional effect 500
background from the active graphic 229

Clear key 777
Clear Preview key 776, 777
Clear Program key 776, 777
Climb

as a transitional effect 499
Clip

associating with a graphic 494
associating with graphic 466
deleting from the browser database 445
importing to browser database 442
playing 459, 464
previewing 461
renaming 445
synchronize playback with effect playback 463
with key, using 446

Clip browser 442
Clip editor

opening 438
ClipAutoUpdate

setting up 457
ClipDeko 436, 445
clocks 361
Close

file 408
Cmd key 776, 777
Color 82

applying to detail 109
background 156
edge 99, 102
face 98
frame 105
of starting layout where graphic is transparent 62
picking a 112
shader 111
specifying 112
underline 104
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where graphic is transparent 683
Color keys 777
Color picker 111
Color shader 106
Command

categories 723
conditional loop 737
syntax 723

Command bar 82, 714
Command command 738
Command event 511
Command key 776, 777
Comment 734
Comparison operator 730
Computer graphics 414
Concatenation 731
Conditional loop command 737
Conditional statement 734
Connect

GPI trigger 516
to a remote database 433

Contextual quotation marks 92
Continue command 736
Control

Deko from another computer program 753
Conversions

data type 741
Convert

ASCII code to string 742
Aston file to a Deko file 430
background to layer 158
Chyron logo font to custom typeface 431
integer value to real value 741
number value to a string 741
object to a string 742
real value to integer value 741
string to ASCII code 742
string to numeric equivalent 741

Copy
detail 147
event 513
events 513
font 148
group of files 409
layer 231
look 148
style 148

tab stop 245
tab stops 245
text 230

Crawl 511, 613
all layers of a page 499
text 500

Create
bulleted graphic 373
clock 361
custom typeface 323
database 433
directory 404
graphic 72
graphics 497
graphics from template 349
layer from background 158
leaderboard 366
list 373
lower third 334
motion script 525
new field for selected text 160
object with command 740
sequence 505
styles for text 78
template for automation interface 760

Creating Charts
basic procedure 248

Current graphic
playing a single effect on 502

Current layer
typing text in 68

Current style
assigning to preset button 137
changing with text cursor 689
picking from graphic 148
saving as prerendered 139
using a preset style as 85

Current Style window 82
move 83
resize 84

Cursor
box 689
hiding 689
i-beam 689
look and behavior 60
movement of 689
moving 69
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position 689
preferences 60

Custom layout
saving current as 678

Custom typeface
converting from Chyron logo font 431
importing active graphic into 324
importing graphic from file into 325
properties 328
specifying properties 328

Custom Typeface window 324
Cut

as a transitional effect 499
event 513
tab stop 245

Cutting and pasting
events 513
layer 231
tab stops 245
text 230

Cylinder 499

D
Data type conversions 741
Database

connection 764
creating and opening 433
creating for Power Clips 480
importing clips to 442
query, with a layer 766
set a default 434
setting up on Deko 433

Decimal tab character
changing 245

Default
database 434
resetting preferences to 697
resetting windows in current layout to 680

Default class 585
Define

layer for Automation 759
Deko file

converting from Aston file 430
Deko Objex 708, 769
Deko Objex Author 771
DekoMOS

creating a template for 381
Delete

action 539
clip from the browser database 445
details from a look 95
event 513
file 411, 777
layers 229
point on a baseline 237
text 228

Delete File key 777
Delete Files key 776
Delete points tool 543
Depth Rotation 570
Deselect

all selected layers 175
text 143

Desktop
overview of 56

Detail
applying cel animation to 130
applying color to 109
applying keyed video to 126
applying ramp to 113
applying texture to 119
copying 147
cutting 147
pasting 147

Directory
creating 404

Directory path 394
Disable

Enhanced Keypad 46
FastAction Functions Keys 47
Undo 64

Display
clock in current text layer 364
Style/Look window 94
tab markers 246

Disruption
of video output 708

Dissolve 499
DSN

specifying 765
Dual channel selection 776
Dual program

output 709



Index

798

DVE effects 38, 528
playing 500

E
Edge 95

changing color of 99, 102
hiding 99, 102
type 100

Edit
macro 742

Edit points tool 543
Effect

associated, playing automatically 503
crawl 614
embedding into a graphic 503
motion 501
playing on current graphic 502
roll 610
specifying timecodes for 509
synchronize playback with clip playback 463
text 500
transitional 499

Effect key 777
Effect Playback layout 671
Effects

playback and Auto-motions 594
playing back Power Clips during 485

Effects layout 496
opening 501

Ellipse
justify a layer 227

Else command 734
Elseif command 734
Embed

effect into a graphic 503
Embedded audio

adjusting volume 463
Embedded effect

playing, without reloading graphic 504
Enable

ClipDeko 438
Enhanced Keypad 46
FastAction Function Keys 47
GPI triggering 516
Macro Autoplay 719
Undo 64

End command 734, 738
End key 689
Enhanced Keypad 45

disable 46
enable 46

Enter key
Read key functioning as 778

Event
copying 513
cutting 513
cutting and pasting 513
deleting 513
finding closest to current output timecode 510
finding closest to current timecode 510
inserting 513
pasting into a sequence 513
selecting 512
specifying 505
specifying starting 514

Exit
Deko 48, 409

Export
graphics and sequences 36

Expression 739
Eyedropper 112, 112

F
Face 95

blurring 98
changing color of 98
priority among other details 98
shader 777

Factory defaults
resetting preferences to 697

Fancy frames 356
Fast Desktop Render 694
FastAction Function Keys

disable 47
enable 47

FastAction Keyboard 46
assigning macros to the preset key 718
function keys 777

File
browsing for 507
closing 408, 409, 409
copying, moving, or renaming a group 409
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delete 776, 777
deleting 411
graphic 71
importing from Chyron 431
Infinite 430
managing multiples 411
missing 686
opening 393
opening a motion 540
prompting to save 230
save 776
saving 406
saving from the active window 779
sharing 433

File association 165
File compression

when saving TIFF and TARGA files 416
Fill clip

aligning to key clip 447
assigning from a key clip 446

Filter
font 93

Find
Deko 42
event closest to current output timecode 510
nearest in, out, beginning, or end point in a clip 

462
tab stop 244
text in a graphic 199

Fixing mistakes 64
Font 81

bold 91
browser 91
changing attributes of current 87, 89
copying 148, 148
creating custom typeface 328
filtering 93
italic 91
mapping 430
pasting 148
selecting 144
selection 776
size 91, 218
size of custom typeface 176
size, specified with numerical value 218
specifying 328

Font key 777

For command 737
Formatting text 151
Frame 95

blurring 105
changing color of 105
height 106
hiding 105
offset 106
priority among other details 106
spaces between words 106
width 106

frames
fancy 356

Freeze
window 680

Full screen list 373
Function keys 776

FastAction Keyboard 777

G
Genlock source

specifying 460
Geometric shape layer 152
Global field value 767
Glow and Glint (Local Behavior) 553
Glows and Blurs 617
GPI trigger

connecting 516
using 516

Graphic 81
appending to another graphic 185
associate a clip with 494
associating with clip 466
Automation 759
browsing for 120, 359
bulleted 373
clearing background from 229
converting from different standard or format 686
converting into Macro 720
creating a 72
creating from template 349
files 71
imbedding an effect 503
importing into custom typeface 324
layers of 152
missing 686
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preview 497
program 497
rendering time limit 693
saving a 73
saving in Thunder database 436
select typeface from 149
size 419
to air, quickly 780
understanding in general 414
using as a texture 120, 359

Graphic class 585
adding

Auto-Motion
adding a graphic class 587

deleting 593
editing 592
setting in a graphic 593
viewing motions and graphics for 590

Graphic Compose layout 669
Graphic file

browsing for 507
opening 395

Graphics
creating using Power Clips 484

Grass Valley Group 757
Group of files

copying, moving, or renaming 409

H
Hardware settings

resetting 698
Height

frame 106
of text field box 178

Help 777
Help key 777
Hide

edge 99, 102
frame 105
layer 182
tab markers 246
underline 104

Highlight
applying to a ramp 116

Home key 689
Hue 111

I
I.I.I. protocol 757
If command 734
Image

browsing for 435
Import

active graphic into custom typeface 324
Chyron message file 431
clip to the browser database 442
fill clip and associated key 446
graphic from file into custom typeface 325
Halo images 429
text file for a roll 611

Importing
.mov files as Power Clips 481

Index operator 731
Infinit 430
Insert

event 513
layer

rectangle 162
text 159

point on a baseline 237
text field 159

Insert points tool 543
Integer value

converting to real value 741
International

character sets 70
International character set 69
Intime

offset 510
set to outtime 509

Italic
applying or removing 145
version of current typeface 91

J
Jaggies

preventing appearance with fonts 93
Justify

layer 227
text, using keyboard 227
text, using mouse 224

Justify key 777
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K
Kern key 777
Kerning 92, 776, 777

object in a motion 548
text, using the keyboard 195
to a specified numerical value 196
with Row key 779

kerning
using the mouse 196

Key
aligning clip with fill clip 447
assigning clip to a fill clip 446
channel 415
removing assignment from current clip 447
using clips with 446

Keyboard 32
change current layout 71
FastAction 46
Home and End key preferences 689
language 71

Keyboard Shortcuts 787
Keyed video

applying to a detail 126
Keyhole

shader 82, 107
Keying 700
Keypad

Enhanced 45
Keyword 724
Kseries 429

L
Layer 81

about 151
adding to graphic 159, 162
copying 231
cutting and pasting 231
defining for Automation 759
geometric shape 152
hiding 182
justifying 227
locking 182
pasting 231
pasting to background 187
position specified by numerical value 222

scaling 219
scaling to a numerical value 218
selecting 174
text 152
to query a database 766
typing text in the current 68
unlocking 182
viewing 182
with associated graphic 166

Layer browser 180
Layer key 777
Layout 51, 668

change current keyboard 71
changing 677
initial 683
keyboard 71
Motion Compose 522
opening the Effects 501
reset to default positions 680
saving current as custom layout 678
saving new starting layout 680
Style Edit 66

Leaderboard 366
Leading 91, 776

changing, using the keyboard 196
changing, using the mouse 197
to a specified numerical value 197

Learn key 778
Learn mode

macro 778
Line segment baseline 236
List 373
Live video

showing through background 154
Local behavior 552
Local variable 729
Lock

layer 182
Look

changing attributes of 95, 96
copying 148, 148
details 95, 99, 104, 105

adding 95
deleting 95
list of 95, 99, 104, 105

displaying Style/Look window 94
pasting 148
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Look key 778
Look style 81
Loop 736

clip playback 462
conditional 737

Lower third 334
Lower Third key 778

M
Macro

appending to another macro 745
assigning to the preset macro key 718
canceling 720
converting graphic into 720
editing 742, 743
file, opening 721
invoking 714
learn mode on 778
pausing 719, 719
playing 717, 718
programming language 722
recording 716, 720
resuming paused 720
saving 744, 744
single-stepping 719
used as subroutine 738
viewing 717, 720

Macro Edit key 778
Macro Edit layout 673

activating 778
Macro Record key 776
Macro Record layout 674
Macro window 714
Magic carpet 499
Make DekoMovie 517
Map

Aston font to TrueType font 430
Chyron bitmap font onto a TrueType font 431

Marker preferences 690
Max 430
Maxine 430
Menu bar 80
Mistakes

fixing 64
Monospace

characters 92

Motion
appending to active motion 539
creating 524, 567
effects 501
playback, pausing and resuming 566
playing 566
playing, using scrub bar 567
scrub, to synchronize a clip 567
suppressing 711
suppression options 711
timing, scaling 536
using in a sequence event 569

Motion behaviors 552
Motion Compose layout 675

opening 522
Motion Edit

composing for Power Clip playback in 486
Motion file

opening 540
Motion Playback

compared with Auto-Motion 585
Motion script

creating 525
saving 540

Motion window 522
Motion-in-Motion

described 596
specifying parent motions 596

Motions
Play-On and Play-Off 595

Move 776, 777
Current Style window 83
group of files 409
tab stops 245
text 224
text, using keyboard 223
text, using mouse 224
with Row key 779

Move key 778
Move selected point tool 543
Multi-format Compose 352, 694

N
Network connection 753
Next point tool 543
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NTSC 681, 681
Number

of cels to play in an animation 131
Number value

converting from string 741
converting to a string 741

Numerical value
for character width 198
for kerning 196
for layer position 222
for leading 197
for rotating a layer 207
for scaling a layer 218
for skewing a layer 210

O
Object 740

accessing elements 740
converting to a string 742
creating 740
Is Parent option 596

Objex 708, 769
Objex Author 771
ODBC drivers 764

view installed 765
Offset

frame 106
in/out times 510
of highlight in a ramp 117

Online help 777
Opacity

of a color 112
of object in a motion 548

Open
Aston Import window 430
Automation window 757
Chyron Import window 430
Clip editor 438
Custom Typeface window 324
database 433
Effects layout 501
files 393
font mapping file 431
from Thunder 435
graphic file 395
graphic into background 157

macro file 721
Macro window 721
Motion Compose layout 522
motion file 540, 540
Sequence window 504
still image 435
still image from Thunder Browse 435

Opening
Auto-Motion file 592

Operator 730
arithmetic 730
assignment 732
bitwise 732
comparison 730
index 731
string 731

Option
Aston Import 430
Automation 753, 760

database connection 764
Chyron Import 430
ClipDeko 436, 445
Deko Objex 769
see those enabled on your system 39
Timeline 524

Other applications 48
Output

dual program 709
single program, plus preview 709

Output channels 36
Outtime

offset 510
set to intime 509

Overview 51

P
Pad 124, 133
Page down key 775
Page Up key 775
PAL 681, 681
Parameter

categories 725
choice 724
integer 724
keywords of 724
list 724
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positional order of 724
real 724
string 724
switch 724

Parent Motion Actions 596
Paste

detail 147
events into a sequence 513
font 148
layer 231
layers to background 187
look 148
style 148
tab stop 245
text 230

Pause
macro 719
motion during playback 566
sequence 515
sequence playback 778
specifying 566

Pause key 778
Pay

imbedded effect, without reloading graphic 504
preset macro 718

Performance
degrading with large animations 130

Pick
colors 111

Pick Style key 778
Pin location

character 327
Play

active macro 717
cel animation 540
clip 464
clips 459
crawl 614
DVE effects 500
graphics to air, quickly 780
motion 566
motion, using scrub bar 567
roll 610
sequence 514
single effect on current graphic 502
Thunder sequence 487

Play Clip at Action Start button 486

Play key 778
Playback

effects and Auto-Motions 594
of a sequence, stopping 517
of associated effects 586
of clips, looping 462
of clips, stopping 464
of Power Clips during effects 485
Power Clips in Motion Edit 486
sequence 778
specify rate 565

Play-Off action 585
Play-Off motion 585
Play-Off motions 595
Play-On action 585
Play-On motion 585
Play-On motions 595
Point

nature of 543
Position (X, Y, and Z)

object in a motion 544
Power Clips

composing for playback in Motion Edit 486
creating a database in Deko 480
creating graphics using 484
creating in QuickTime Pro 474
described 473
importing .mov files as 481
playing back during effects 485

Preferences 59, 667
common 62, 683
marker 691
resetting 698
resetting to factory defaults 697
saving 697
specifying 681, 682, 685, 687, 688, 690, 692, 

695
starting layout color 62

Preset macro
playing 718

Preset Macro key 718, 775
Preset shader 777

applying to detail 135
assigning current shader to 135
saving 135
using 134

Preset style
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selecting 85
Preset style button

assigning a style to 137
Preset style file

retrieving styles from 140
Preset Style keys 776
Preset Style window 82
Preset window 779
Presto 429
Prevent digits from shifting as clock advances 366
Preview

clip 461
Preview key 778
Preview window 497

activating 778
Previous point tool 543
Print Screen key 778
Priority

of face among other details 98
of frame among other details 106
of underline among other details 104

Program key 778
Program window 81, 497

activating 778
Prompt 230, 409, 409

to save modified files before closing 409, 409
Properties

custom typeface 328
Push 500

Q
Query

by automation 755
database with a layer 766
for data 177

QuickTime Pro
creating Power clips in 474

Quotation marks 92

R
Ramp 82

applying to detail 113
background 156
highlighting 116, 117, 124, 133
shader 106, 111

Ramp See also Shader
Rate

of motion playback 565
Read dialog box 778
Read key 778
Read Preview key 775, 778
Read Program key 775, 779
Real value

converting from integer value 741
converting to integer value 741

Reassign
template layers for replacing via automation 762

Record
macro 716

Rectangle
adding to graphic 162
layer, justifying 227

Redo 65
Redo key 775, 779
Remote database

connecting to 433
Remove

key assignment from current clip 447
Rename

clip 445
group of files 409
style 139

Reorder
template layers for replacing via automation 762

Repeat
previous effect 500

Replace
text in a graphic 199
texture 122

Request data 177
Reset

preferences to factory defaults 697
timer 365
window in current layout to default positions 680

Reset graph tool 543
Resetting to factory defaults 698
Resize

Current Style window 84
Resolution

specifying 693
Resume

motion playback 566
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paused macro 720
paused sequence 515

Retrieve
style from preset styles file 140
styles from a style file 140

Return command 739
Return values 739
Reveal text 500
Reverse

direction of a baseline 239
direction of animation 132

Ripple 500
Roll 511

text 500
Rot/Skw key 779
Rotate 776, 777

layer, by numerical value 207
object in a motion 548
text 92, 206
text field, by degrees 179
text, to specified numerical value 206
text, using keyboard 205
text, using mouse 205
with Row key 779

Rotate/Skew key 779
Rotate/Skew tool

selecting 779
Routing 700
Row key 779
Row spacing 91, 197

S
Safe title area

defining 691
Saturation

color 111
Save

a macro 744
a style 139
bitmap with a graphic 405
current font mapping file 431
current layout as custom layout 678
current style as a prerendered style 139
Deko graphic in Thunder database 436
files 406
graphic 73

graphic with automatic comment 406
layout as starting layout 680
macro 744
modified preset styles 138
modified style 139
motion script 540
preferences 697
preset shaders 108, 135, 137
prompt before 230, 685
prompt to, before clearing 230
style 139
styles in a preset style file 138
to Thunder 436

Save File key 779
Save Files key 776
Saving

Auto-Motion file 591
Scale 776, 777

layer 219
motion timing 536
of an object in a motion 547
text 218
text field box 179
texture 124, 133
width of pixels in cel animation 131
with Row key 779

Scale key 779
Scaling preferences 694
Screen units 91, 95, 116, 117, 124, 132, 133, 177, 

178, 689, 693
Scroll Lock key 779
Scrub bar

synchronizing a clip 567
using to play a motion 567

See
options enabled on your system 39

Select
all layers in the active graphic 174
all text characters in a graphic 143
all text characters in the current style 143
all text in a row 142
all text in a text field 142
details 95, 99, 104, 105
events 512
font 144
layer behind currently selected layer 174
layer in front of current layer 174



Index

807

layer in the active graphic 174
multiple events 512
multiple layers 174
preset style 85
preset styles 779
single event 512
tab stop 244
text 141, 142
text, for a new field 160
typeface 144, 151
typeface from a graphic 149
word 142

Seq Edit key 779
Sequence

appending to another sequence 508
browsing for files to add to 507
converting to macro 720
creating 505, 513
deleting events 513
inserting events 513
pasting events into 513
pausing 515
pausing playback 778
playback 778
playing 514
resuming paused 515
specifying events of 505
starting event of 514
stop playback 779
stopping 517
Thunder, playing from Deko 487
using motion in an event 569

Sequence Edit key 779
Sequence layout 497
Sequence Playback layout 672

activating 779
Sequence window

opening 504
Sequential graphics

to air, quickly 780
Set

intime to outtime 509
outtime to intime 509
tab stops 244

Set up
database 433
file sharing 433

Settings
specifying for timecode 510

Shader
activating 108
background 156
CAP 107
color 106
edge 99, 102
face 98
frame 105
keyhole 107
preset See preset shaders
ramp 106
texture 106
types 107
underline 104

Shader key 779
shader See also Color, Ramp, Texture
Shader window 81

activating the current 779
Shadow 95

shape 97
Share

files 433
Shifting digits

preventing, as clock advances 366
Shrink

text to fit text box 177
Single effect playback 777
Single program output 709
Size

font or typeface 91
of custom typeface font 176
of highlight relative to ramp 117

Skew 776, 777
layer to specified numerical value 210
object in a motion 548
text field 179
text, to specified numerical value 210
text, using the keyboard 209
text, using the mouse 209
with Row key 779

Slide
as a transitional effect 500

Slide off
as a transitional effect 500

Smallcaps 145
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Smart read keys 775
SMPTE timecode 508
Software settings

resetting 698
Space

between characters 92, 195, 196
between rows of text 91
characters all the same width 92
framing, between words 106
underlining, between words 104

Specify
DSN 765
font size 218
genlock source 460
numerical value for rotating a layer 207
pause 566
pause in a sequence 515
playback rate of motions 565
preferences 681, 682, 685, 687, 688, 690, 692, 

695
resolution 693
starting event of a sequence 514
timecode settings 510
timecodes to begin an end an effect 509

specify
numerical value for scaling a layer 218
numerical value for skewing a layer 210

Speed
changing during a roll or crawl 612, 616
embedding changes in a roll or crawl 612
imbedding changes in a roll or crawl 616

Spell check 776
SQL

field 177
Start

Automation, immediately when you start Deko 
758

Deko 41, 684
timer 365
Windows 41

Starting layout
color 62

Status bar 82
Sticky texture 166
Still image

opening 435
Stop

clip playback 464
macro playback 720
sequence playback 517

Stop key 779
String

converting from a number value 741
converting from an object 742
converting to ASCII code 742
converting to numeric equivalent 741

String operator 731
Style

assigning to preset button 137
copying 148
creating, for text 78
pasting 148
picking up from graphic 148
renaming 139
retrieving 140
retrieving from a style file 140
saving 139
saving as prerendered 139
saving preset 138

Style 1 - Style 8 keys 779
Style Edit layout 66, 670
Style/Font window 777
Style/Look window

activating 778
Subroutine 738
Swap

program and preview graphics 498
Switch

program and preview graphics 498
Synchronize

clip playback with effect playback 463
clip with motion scrub 567

System variable 729

T
Tab markers

displaying or hiding 246
Tab Set key 779
Tab set key 775
Tab stop

changing the decimal tab character 245
clearing selected 244
set at the current cursor position 779
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setting 244
TARGA files

saving 416
Targeted behavior 552
Template

creating for automation interface 760
creating graphics from 349
for DekoMOS 381

Text
changing case 192, 192
copying 230
creating styles for 78
cutting and pasting 230
deleting 229
deselect 143
effects 500
finding and replacing 199, 201
justifying 176
justifying, using keyboard 227
kerning 92
kerning, using the keyboard 195
kerning, using the mouse 196
leading 91, 197
moving, using keyboard 223
moving, using mouse 224
pasting 230
rendering time limit 693
replacing 199
rotating 92
rotating, 205
scaling 218
scaling, using keyboard 216
selecting 141, 142
skewing 209
spell checking 201
typing and formatting 151
typing in the current layer 68
typing on a curve 231
underlining 145, 145

text
justifying, using mouse 224

Text bar 80
Text field

adding to graphic 159
justifying text within 176
rotation, by degrees 179
skewing 179

Text field box
change with keyboard 179
change with mouse 179
height 178
scaling 179
transforming 179
width 178

Text formatting tools 775
Text layer 152

justifying 227
Texture 82

alignment 126
applying to a detail 119
background 156
file name 122
replace 122
scale 124, 133
shader 106
sticky 166

Texture See also Shader
Thunder

playing from Deko 487
saving graphic in database 436

Thunder Browse
to open a still image from 435

TIFF files
saving 416

Time limit
text rendering 693

Time offset 363
Timecode

specifying for an effect 509
specifying settings 510

Timecode control 508
Timing

adjusting, of an action 535
Tools

Style Edit 79
Tools window 81
Transfer

graphics from Preview to Program 498
graphics from Program to Preview 498

Transform tools 775, 776
Transition Logic 563
Transitional effects 499
Translucence

of a color 112
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TrueType font
mapping from a Chyron bitmap font 431
mapping from an Aston font 430

Type
text 151
text in the current layer 68

type
on a curve 231, 243

Typeface
bold 91
browser 91
creating custom 328
italic 91
selecting 144, 151
size 91
using an international character set 71

Typeface Edit layout 676

U
Underline

as part of look 95
blurring 104
changing color of 104
hiding 104
priority among other details 104
spaces between words 104
text 145

Undo 64, 779
changes to a baseline 243
reversing 65

Undo key 775, 779
Unlock

layer 182
Use

motion in a sequence event 569
User preferences 667
Using

GPI trigger 516
Using other applications 48

V
Variable 728

assignment 728, 730
data type 728
global 729

local 729
subscripted 729
system 729
user-defined 728

Variable field value 767
Video

applying to a detail 126
output 700

Video output
disruption of 708

Video standard
changing 404
save graphic under a different 404

View
installed ODBC drivers 765
layer 182
macro 717, 720

Viewing
File information 407

Volume
adjusting in imbedded audio 463

W
While command 737
Width

character 327
frame 106
of text field box 178

Window
Aston Import 430
Automation 757
Chyron Import 430
clearing 685
closing 685
Current Style 82
Custom Typeface 324
freezing, to prevent moving or sizing 680
Motion 522
opening 685
Preset Style 82
program 81
reset to default positions 680
Sequence, opening 504
shader 81
style 81
Style Edit 79
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Style/Look 94
tools 81

Windows 32, 36
starting 41

Windows 2000 48
changing keyboard layout 71
clipboard 148, 231

Winfinit 430
Wipe

as a transitional effect 500
Word processor 36
Word wrap 176
Wrap

when scaling 217

X
X position

described 544

Y
Y position

described 544

Z
Z position

described 544
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