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Disclaimer
This manual and the information contained herein are the sole property of EVS Broadcast
Equipment SA and/or its affiliates (EVS) and are provided “as is” without any expressed or
implied warranties, including, but not limited to, the implied warranties of merchantability
and fitness for a particular purpose. In particular, EVS makes no warranty regarding the
use or the consequences of use of this manual and the information contained herein.
Furthermore, EVS may not be held liable for any direct or indirect, incidental, punitive or
consequential loss, damage, cost or expense of any kind whatsoever and howsoever
resulting from the normal or abnormal use of this manual and the information contained
herein, even if advised of the possibility of such loss, damage, cost or expense.

While every effort has beenmade to ensure that the information contained in this manual
is accurate, up-to-date and reliable, EVS cannot be held liable for inaccuracies or errors
that may appear in this publication. The information in this manual is furnished for
informational purpose and use only and subject to change without notice.

This manual cancels and replaces any previous versions thereof.

Copyright
Copyright © 2003-2020 EVS Broadcast Equipment SA. All rights reserved.

This manual may not be reproduced, transcribed, stored (in a database or a retrieval
system), translated into any language, computer language, transmitted in any form or by
any means – electronically, mechanically, printed, photocopied, optically, manually or
otherwise – in whole or in part without the prior written consent of EVS.

Trademarks
All product and brand names are registered trademarks and trademarks of EVS or of their
respective owners.

Improvement Requests
Your comments will help us improve the quality of the user documentation. Please send
improvement requests, or report any error or inaccuracy on this user manual by e-mail to
doc@evs.com.

Regional Contacts
Youwill find the full list of addresses and phone numbers on the following webpage:
http://www.evs.com/contact.

USER MANUAL IPDirector 7.90 IPLogger

I

mailto:doc@evs.com
https://www.evs.com/contact


User Manuals on EVS Website
The latest version of the user manual, if any, and other user manuals on EVS products can
be found at the EVS download center, on the following webpage:
https://www.evs.com/en/download-area.
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What's New?

In the User Manual, the icon has been added on the left margin to highlight
information on new and updated features.

The sections updated to reflect the new andmodified features in IPLogger version 7.90 are
listed below.

Automatic creation of clips based on logs

If a specific bin has been selected in the logsheet, clips will be automatically created when
a log is being created.

• See section "Step 1: Defining the Logsheet Characteristics" on page 16.

• See section "Logs Display" on page 7.

• See section "Creating Clips Automatically from a Log Entry" on page 45.
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1. Introduction

1.1. Product Overview
A log is a reference point to a specific frame in a video sequence. The log is identified by a
TC value, and relates to an action in a given event.

Adding logs tomedia is particularly useful to easily and quickly retrieve the interesting
moments of the recorded sequences.

Logs are related to a logsheet which is created for a given event and contains its own
metadata, previously defined in a logsheet profile.

Users have the possibility to create log entries directly during the event, or later on.

When logging LIVE actions, logs must be entered as soon as the action occurs to grab the
timecode corresponding to the action. This is called the LIVE logging hereafter.

When logging actions later on, on a previously recorded clip, users canmove through the
recorded clip. This is called the comfortable logging hereafter.

Log creation buttons and shortcuts are available to quickly add logs to amedia. Users can
associate metadata to the log, such as keywords, interest level, highlight color or a
description.

Clips containing the log timecode can be created by the users to protect the loggedmedia
or can be automatically detected by the system and associated to the log entries.

IPLogger does not interfere with, but complements a live production, while also producing
invaluable data for use of thematerial during or after the event.

Compared to conventional logging techniques, IP Logger has significant time-saving
benefits, and saving time is always critical in live production. By producing accurate logs,
and providing an efficient search engine, information is available faster to all EVS XNet
users for browsing, editing and archiving. Logs can be accessed by other users even while
they are being generated, and EVS media associated with the log can be cued and used
instantly.

1.2. Opening of IPLogger
To open IPLogger, select the corresponding icon on the IPDirector
Application bar. The IPLogger window will open.
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2. User Interface

2.1. Overview of the IPLogger Window

Illustration
The IPLogger window contains the areas highlighted on the screenshot below:

NOTE

From version 6.55, the interface skin has slightly changed, so the color shade
of some user interface elements (such as title bar, buttons) may differ from the
screenshots included in the current manual.
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Area Description
The table below describes the various parts of the IPLogger window:

Area Description

1. Toolbar The Toolbar provides functions for performing operations on logsheets
and buttons mainly for viewing options.
See section "IPLogger Toolbar" on page 3.

2. Logging
areas

The Logging areas are used to log events.
See sections "Logging Areas" on page 7 and "Adding Logs toMedia"
on page 26.

3. Log
Metadata
area

This area allows you to define values for the user fields from the log
metadata profile.
This area is only displayed if a profile for logmetadata has been
associated with the selected logsheet profile.
See sections "Create a New LogWindow" on page 34 and "Log
Metadata Profile" on page 38.

4. Logs grid This area displays all log entries in columns.
See section "Logs Grid" on page 7.

5. Associated
Channel
zone

This area provides information regarding the associated player
channel, if any.
When no channel is associated to IPLogger, No Channel is
displayed.
See section "Assigning a Player" on page 31 for more information on
how to assign a player channel.
If the selected player channel is connected to an IN port of a video
router, itself associated to OUT ports, the name of the router OUT port
(s) is displayed after the player channel name.

2.2. IPLogger Toolbar

2.2.1. File Menu
Clicking the File button displays the File menu.

The various menu items in the File menu are detailed in the table below:

Menu Item Description

New
Logsheet

Opens the Create a New Logsheet Wizard window to create a new
logsheet.
The logsheet creation process is described in detail in "Creating a
Logsheet" on page 15.

Open
Logsheet

Opens theOpen a Logsheet window which provides the list of existing
logsheets.
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Menu Item Description

Import Allows the users to import a logsheet.
See section "Importing a Logsheet" on page 56.

Export Allows the users to export a logsheet or a logsheet profile.
See sections "Exporting a Logsheet" on page 56 and "Exporting a Current
Logsheet Profile" on page 57.

Publish
logsheet

Opens the Publish a Logsheet window from which the selected logsheet
can be published, i.e. made available to selected groups of users, or to
selected individual users.
See section "Publishing Logs and Logsheets" on page 60.

Enter TC
Offset

Opens the Enter Logsheet Offset window from which you can set a
timecode offset when logs and clips are created on different machines,
with different timecode values.
See section "Entering a TimecodeOffset" on page 51.

Properties Opens the Update a Logsheet Wizard to check or update the information
previously entered.
You can also click theProperties button on the toolbar.

Print Opens the Print Logsheet window and allows the users to print the
logsheet.
See section "Printing a Logsheet" on page 62.

De-active
logsheet

Deactivates a logsheet. This can be done when it is completed to improve
the performance of the system. Once de-activated, a logsheet cannot be
modified and cannot be associated to clips. This permits to reduce the
network load and database activity.
See section "De-Activating a Logsheet" on page 54.

Re-active
logsheet

Re-activates a logsheet which has previously been de-activated.
See section "De-Activating a Logsheet" on page 54.

Exit
IPLogger Closes the IPLogger window.

2.2.2. Link to PC Timecode Button
When, for example, you want to log an event with just a laptop in a hotel room, watching
the event on a regular TV set, you can use the PC time as the timecode for the logs.

See section "How to Link Logs to PC Timecode" on page 27.
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2.2.3. View Button
Clicking theView button provides amenu listing two display options for the log entries
within the grid.

Simple List
With theSimple List option, log entries are shown as text-only narrow lines.

Simple List with Thumbnails
With theSimple List with Thumbnails option, log entries are shownwith a thumbnail,
making the entries easier to identify. The thumbnails are created automatically, based on
the log entry timecode.

In the collapsed view, the thumbnail matches the image recorded from the Preview
recorder's TC for each log entry.

They can be changed to show a different image. If you want to change the thumbnail,
right-click the log entry, click Grab Thumbnail on Recorder and select a recorder.

In the expanded view, a thumbnail is displayed for each recorder channel.
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2.2.4. Refresh Button

Clicking theRefresh button performs a refresh on the Logsheet grid.

2.2.5. Protect All Button
Using theProtect All command from the Toolbar will create a clip, on each recorder
channel selected from the list of relevant recorders, to ensure that A/V material
corresponding to all events logged is kept within a clip.

See section "ProtectingMedia" on page 41.

2.2.6. Display PM Coverage Button
Clicking theDisplay PM Coverage button on the Toolbar opens the Protect Media
Coverage window. You can check here whether all the relevant media is protected.

See section "Display Protect Media Coverage" on page 41.

2.2.7. Properties
Clicking theProperties button on the toolbar opens the Update a Logsheet Wizard
window. The properties entered at logsheet creation are displayed and can be edited from
this window.

2.2.8. Recreate all Thumbnails Button
A thumbnail is automatically generated on the preview recorder. If needed, all thumbnails
can be re-generated for a logsheet by clicking theRecreate All Thumbnails button.

2.2.9. Auto Scroll Button
This option is used tomake the log, just created by any user, visible in the Logsheet grid,
even if the log is inserted in a part of the grid previously not visible.

When themode is enabled, the system scrolls the grid to make the last created log visible,
would it be created by you or by any other user of the logsheet.

When themode is disabled, the system scrolls the grid only to make your own log visible.

The Auto Scroll mode is enabled or disabled by clicking theAuto Scroll button. When
enabled, the button background becomes highlighted.
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2.3. Logging Areas

2.3.1. Logging Buttons
TheNew button from the LIVE area is used when you log live actions. See section "Live
Logging" on page 26.

TheNew button from the Player area is used when you log actions from events recorded
earlier. In this case a player channel must be associated to IPLogger to preview the
recorded event. See section "Retroactive Logging" on page 31.

2.3.2. Timecode Fields Display
Information displayed in the Timecode fields from the Live Logging area and from the
Player Logging area can be changed as follows:

1. Right-click the Timecode field.

A contextual menu with the following options is displayed:

◦ Timecode

◦ Timecode and Date

2. Select one of the options.

3. When the date is displayed, clicking it in the Timecode field opens a calendar for date
selection.

2.4. Logs Grid

2.4.1. Logs Display

Introduction
The Logs grid represents the logsheet content, with one row representing one log and a
customizable set of columns to display log data.

The view can be expanded thanks to a small arrow at the beginning of each line. Different
kinds of elements can be displayed on separate lines.
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Log Entries
A log has been created on each relevant recorder channel defined at the logsheet creation.

See section "Step 3: Defining the Relevant Recorders" on page 22, and section "Adding
Logs toMedia" on page 26.

This displays as follows in the Elements grid:

Clips Created Automatically
The log has been dragged into a bin or a specific bin for automatic clip creation had been
selected in the associated logsheet. So, a clip has been automatically created by the
system.

The clip duration depends on theAutomatic Clip creation based on Logs setting,
defined under Tools > Settings > Clips > General.

See section "Creating Clips Automatically from a Log Entry" on page 45.

Protect Media Clips
A log has been protected by a user, so a clip has been created around the log timecode to
protect the A/V material.

See section "ProtectingMedia" on page 41.

This displays as follows in the Elements grid:
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Associated Clips
A clip containing a log timecode has been created by a user on the same recorder channel
as the log. So, the system has automatically detected it and associated it with the log.

This association is done provided that theAuto-associate clips to logs option has been
selected in the Remote Installer (Configure > General).

This displays as follows in the Elements grid:

2.4.2. Log Keywords and Profile Metadata Values
Some of the columns displayed the keywords assigned to the logsheet or to the log entries
and other columns relate to the values entered in themetadata profile user fields, as
explained below.

The following schema summarizes themeaning of these columns.
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Keywords

Keywords added to the log from the Create a New Log window.

Participants

Participant keywords added to the log from the Create a New Log window.
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Parent Keywords

Keywords associated with the logsheet during step 2 of logsheet creation.

Parent Participants

Participant keywords associated with the logsheet during step 2 of logsheet creation.

Profile

Name of the logsheet profile associated with the logsheet during step 1 of the logsheet
creation.

[User Fields from the Profile for Log Metadata]

The profile for LogMetadata which is associated with the logsheet profile selected at
logsheet creation is made up of a series of user fields. A column corresponding to each
user field is present in the Logs grid.

NOTE

These columns are not displayed if no logsheet profile is used with the
logsheet or if no "Profile for logmetadata" is associated with the
logsheet profile.

[User Fields from the Profile for Logsheet]

At logsheet creation, a logsheet profile can be selected. If a profile for Logsheet User
Fields has been associated with this logsheet profile from theMetadata Profile
Management window, a column corresponding to each of its user fields is present in the
Logs grid.

NOTE

These columns are not displayed if no logsheet profile is used with the
logsheet or if no "Profile for Logsheet User Fields" was present in the
logsheet profile.

2.4.3. Grid Header Contextual Menu
Right-clicking the grid header displays the grid contextual menu.

The options are described in the following table:

Option Description

Hide Hides the selected column.

Organize The Select Columns window opens and allows the users to select the
columns to display and their order.

Save grid
organization

Saves the organization of the grid as it is displayed (columns selection,
order and size). It is saved by each user. Therefore, this organization
will be retained the next time the user logs in and opens the application.

Reset grid
organization Sets back the grid to the default grid organization.
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2.4.4. Sorting the Elements in the Grid
At start of the application, items are sorted with most recent on top.

You can change the sort order of elements in the grid by clicking the column header for the
parameter according to which you want to sort the elements.

The column header which is used for sorting is highlighted in blue. The little triangle
indicates the sorting order. Clicking the column header again changes the sorting order
from ascending to descending or vice versa.

2.4.5. Organizing Columns
Columns can be resized and/or re-ordered. This new organization is automatically saved
and remembered. However, it is also possible to reset the column organization to the
default organization.

Resizing Columns
A column can be resized by placing themouse pointer over columns intersection and
dragging it to the right or to the left.

Selecting Columns to Display
To select the columns to display in the grid,

1. Right-click the column header area.

2. Select Organize.

The Select Columns window opens and the right pane shows the list of columns
currently displayed in the current order.

3. To select the column(s) you wish to add to the view, do one of the following actions:

◦ in the left pane, double-click the column(s) you wish to add to the view

◦ select them in the left pane and click the right arrow

◦ drag them onto the Visible Columns area.

UseCTRL + click to select a list of non-contiguous columns.

UseSHIFT + click to select a list of contiguous columns.

4. To select the column(s) you wish to remove from the view, do one of the following
actions:

◦ on the right pane, double-click the column(s) you wish to remove from the view

◦ select them on the right pane and click the left arrow

◦ drag them onto the left pane.
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UseCTRL + click to select a list of non-contiguous columns.

UseSHIFT + click to select a list of contiguous columns.

5. Click OK.

Ordering Columns
To change the columns order, proceed in one of the following ways

• Select a column header and drag it to the left or right to the required place:

OR

1. Right-click the column header area.

2. Select Organize.

The Select Columns window opens and the right pane shows the list of columns
currently displayed in the current order.

3. Drag the selected column to the required position in the Visible Columns pane.

4. Click OK.

Resetting the List of Columns back to the Default One
Users can reset the list of columns displayed in the grid to the default one.

1. Right-click the column header area.

2. Select Organize.

The Select Columns window opens.

3. Click Back to Default.

2.4.6. Log Entry Contextual Menu
The Log Entry contextual menu is available when right-clicking a log entry from the
collapsed view of the grid. It gives access to the actions that can be performed on logs.

Field Description

Edit Opens the Edit a Log window that allows users tomodify the log
metadata.
Youmay change some data, such as interest level, color,…, for
multiple logs at once: select all the lines to edit and choose the
data you want to associate to all of them in the Edit log window.

View and Edit Opens the Edit a Log window that allows users tomodify the log
metadata and loads the log at the log timecode position on the
player channel associated with the IPLogger window.
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Field Description

View Loads the log on the player channel associated with the IPLogger
window.

Delete Deletes the selected log entry(ies).

Synchronize this
log with the image
loaded on the
player

Synchronizes the log timecode with the timecode of the image
loaded on the player when, for example, the logs and the
recordings have beenmade in different locations or on two
different setups.

Grab Thumbnail
on Recorder

Manually re-generates the thumbnail on a relevant recorder of
user's choice.

Protect Selected
Logs

Allows creating clips for selected logs to ensure the protection of
corresponding A/V material.

NOTE

Right-clicking a protect media clip or an associated clip from the
expanded view of the log entry in the grid will display the Clip
contextual menu.

14 2. User Interface

EVSBroadcast Equipment SA Issue 7.90.B - June 2020



3. Creating a Logsheet

3.1. Introduction
To create a new logsheet for an event, click File > New Logsheet from themain toolbar.
This opens the Create a New Logsheet wizard.

You then have to define the parameters of the logsheet by completing the 3 steps of the
wizard:

1. logsheet characteristics

2. logsheet keywords

3. relevant recorders

Click the buttons to open the windows for steps 1 to 3.
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3.2. Step 1: Defining the Logsheet
Characteristics

Accessing the Logsheet Characteristics Window
Click the Logsheet Characteristics Definition button in the Create a New Logsheet
wizard to display the Logsheet Characteristics window:

Purpose
The Logsheet Characteristics window is used to define themain characteristics of the
logsheet: name, description, log directory, logsheet profile, values for the associated
profile for logsheet, and bin for the automatic creation of clips.

16 3. Creating a Logsheet

EVSBroadcast Equipment SA Issue 7.90.B - June 2020



Fields of the Logsheet Characteristics Window
The fields in the Logsheet Characteristics window are explained in the table below.

Complete at least themandatory fields and click OK. Step 1 will then appears as Defined
in the Create a New Logsheet wizard.

User Interface
Element Description

Name Name of the logsheet.
This is amandatory field.

Parent Name of the log directory from the tree structure of the Database
Explorer in which the logsheet will be placed.
Browsing in this field displays the folders already created in the Logs
section of the Database Explorer, allowing you to select the requested
folder:

Event Date Date when the logsheet is created or date of the logged event.
This is amandatory field.

Description Free text to add a description of the logsheet.
This is an optional field.

Logsheet
Profile

The first field displays the name of the selected logsheet profile. The
Logsheet profile menu provides the list of available logsheet profiles,
set from theMetadata Profiles Management window.
The second field gives the description of the selected logsheet profile.
See theGeneral Functions user manual

Automatically
Export Logs
to 3rd Party

Check this box to generate an xml file of the logsheet each time it is
modified (new log element, relevant recorders modified, etc.). The
IPScheduler service will create the xml file and send it to a dedicated
folder.
The option availability depends on the configuration defined in the
Remote Installer (Configure > IPLogger Export).
See the IPDirector Technical Referencemanual for more information.
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User Interface
Element Description

[Logsheet
Profile User
Fields]

As soon as a logsheet profile has been selected, the user fields from
the associatedProfile for logsheet user fields are displayed.

Values can be specified for all the user fields at the logsheet creation.
At this step, values can be defined for text, timecode, date and
number user's field types. Additional values can be defined for
predefined text values user field type.
The user field names can be displayed as columns in the Logs grid of
IPLogger.

Bin for the
automatic clip
creation

If a specific bin has been selected in the logsheet, clips will be
automatically created when a log is being created.
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Here is an example of a completed Logsheet Characteristics window:
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3.3. Step 2: Defining the Logsheet
Keywords

Accessing the Logsheet Keywords Window
Click the Logsheet Keywords Definition button in the Create a New Logsheet wizard to
display the Logsheet Keywords window:

Purpose
The Logsheet Keywords window is used to define keywords which will be associated to
the logsheet, and therefore automatically associated to all the log entries of the logsheet.

The keywords associated to the log in this way are called parent keywords as they are
defined at the logsheet level, valid for all log entries in the logsheet. Parent keywords that
are entered heremust therefore be relevant to all events in the logsheet.

Fields of the Logsheet Keywords Window
The table below describes the Logsheet Keywords Definition window.

Select keywords and click OK. Step 2 will then appears as Defined in the Create a New
Logsheet wizard.
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User Interface
Element Description

Search for
Keyword (left)

Search for a keyword in the Keyword List box, for example a keyword
you would like to add to the logsheet.
Type the beginning of the keyword and the first matching keyword in
the Keyword List will be highlighted.

Keyword List Displays all the keywords available in the IPDirector database.

Search for
Keyword
(right)

Search for a keyword in the Keyword Selection box, for example to
check whether this keyword is already in the selection.
Type the beginning of the keyword searched for and the first keyword
matching the search criteria will be highlighted.

Keyword
Selection

Displays the keywords that have been associated with the current
logsheet.

Add Button to add the parent keyword(s) selected in the Keyword List box
to the Keyword Selection box.

Remove Button to remove the selected parent keywords from the Keyword
Selection box.

Clear
Selection Button to clear all the keywords from the Keyword Selection box.
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3.4. Step 3: Defining the Relevant
Recorders

Accessing the Log Relevant Recorders Window
Click theRelevant Recorders Definition button in the Create a New Logsheet wizard to
display the Log Relevant Recorders window:

Purpose
The Log Relevant Recorders window is used

• to define the relevant recorders, which correspond to those feeds you are interested to
log: each recorder channel on any EVS video server within the XNet can be defined as
a relevant recorder,

• to set a recorder as preview recorder: The preview recorder provides the timecode
displayed in the LIVE area of the logsheet. It will also be the first angle selected to
view an event when an IPDirector operator loads a log.

• to select the association type between the log timecode and the recorder timecode.
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How to Select the Relevant Recorders
To select the relevant recorders, proceed as follows:

1. Select the relevant sources from the Network Channel Organization area.

2. Click Add.

NOTE

If a recorder channel is connected to anOUT port of a video router,
itself associated to an IN port, the name of the router IN port is
displayed after the recorder channel name in the Log Relevant
Recorders window.

How to Select the Preview Recorder
To define a preview recorder, proceed as follows:

1. Right-click the requested recorder channel in the Log Relevant Recorders Selection
area.

2. Select Preview Recorder from the contextual menu.

Preview is written next to the selected recorder.

NOTE

The preview recorder MUST be assigned to a recorder channel that is
managed with a RS422 link to the EVS video server the channel is on.
If not, the logsheet will NOT function correctly, and no LIVE timecode
will be displayed.

How to Associate the Log and Recorder Timecodes
When selecting a relevant recorder, the system will automatically consider the primary
table of the logsheet and the recorder as the relevant tables to calculate the clip/log
association.

It is however possible to change this association if necessary. To change the association,
proceed as follows:

1. Right-click the relevant recorder in the list.

2. Select the desired association type.
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NOTE

If you have different types of associations in the same logsheet, a warning
message is displayed.

This is just a warning which indicates you have different types of association in
your logsheet. Check that this scenario (rarely used) corresponds to your
workflow.

3.5. Logsheet Ready For Use
When the wizard is completed, it looks as follows:

Click Done at the bottom of the Create a New Logsheet wizard.

The name of the logsheet will be shown in the IPLogger window title bar and a running
timecode will appear in the LIVE area.
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NOTE

If there is no timecode in the LIVE area, this means that the preview
recorder is located on a server with no RS-422 connection to the
IPDirector network.
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4. Adding Logs to Media

4.1. Introduction
A log is a reference point to a specific frame in a video sequence. The log is identified by a
timecode value, and relates to an action in a given event. It can be associated tometadata
related to the event (keywords and/or a ranking, for example).

Adding logs tomedia is particularly useful to easily and quickly retrieve the interesting
moments of the recorded sequences.

Users have the possibility to create log entries directly during the event, or later on.

When users log LIVE actions, logs must be entered as soon as the action occurs to grab
the timecode corresponding to the action. This is called the LIVE logging hereafter.

When users log actions later on, users canmove through the selectedmedia: recorded
clip, loaded train. This is called the retroactive logging hereafter.

Log creation buttons and shortcuts are available to add logs to amedia, users will have to
manually associate metadata to the log, such as keywords, interest level, highlight color
or a description.

4.2. Live Logging

4.2.1. Possible Ways to Proceed
When users log LIVE actions, logs must be created as soon as the action occurs to grab
the timecode corresponding to the action.

Depending on the situations, the Live logging can be done with the timecode of an
EVS server recorder channel or with the PC timecode.

• When you work on an IPDirector workstation connected to an EVS video server, you
will log with the timecode of the preview recorder.

In this case, you need to first define the relevant recorders and to set the preview
recorder channel to be used for logging during the step 3 of the logsheet creation. See
section "Step 3: Defining the Relevant Recorders" on page 22.

• You will use the PC time as the timecode for the logs when, for example, you want to
log an event with just a laptop in a hotel room, watching the event on a regular TV set.

In this case, you will create a logsheet without defining any relevant recorder. Then
you will have to link the IPLogger window to the PC timecode, as described in section
"How to Link Logs to PC Timecode" on page 27.
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4.2.2. How to Link Logs to PC Timecode
To link IPLogger to the PC timecode, proceed as follows:

1. Click the Link To PC Timecode button.

The Logsheet Video Format window appears:

2. Select the appropriate video format.

Your PC timecode appears highlighted in the LIVE area and you can start making log
entries as described in "How to Log LIVE Action" on page 28.

The Link To PC Timezone button becomes highlighted.

To un-link logs to PC timecode, click the Link to PC Timecode button again.

NOTE

When a recorder is linked, you will not be able to click the Link To PC
Timecode button.
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4.2.3. How to Log LIVE Action

Prerequisites

Logging with Preview Recorder Timecode
Create a logsheet and define the relevant recorder channels and the preview recorder, as
described in section "Creating a Logsheet" on page 15.

The timecode displayed in the LIVE area of the IPLogger window is the timecode of the
preview recorder. It is not highlighted.

Logging with PC Timecode
1. Create a logsheet without defining any relevant recorder channels. See section

"Creating a Logsheet" on page 15.

2. Link IPLogger to PC timecode, as described in section "How to Link Logs to PC
Timecode" on page 27.
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The timecode displayed in the LIVE area of the IPLogger window is highlighted to warn the
users.

Complete Procedure
To create a new log entry in a selected logsheet, proceed as follows:

1. Open the selected logsheet from File > Open a logsheet.

2. (optional) Enter or modify the values in the LogMetadata area:
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3. Click theNew button in the LIVE area.

The Create a New Log window opens with the timecode grabbed from the preview
recorder or from the PC time:

See section "Create a New LogWindow" on page 34 for more information on the
fields.

4. (optional) Enter a free-text description for the log in theDescription field.

5. (optional) Select keyword(s) for the log from theKeywords field (Autocomplete list) or
from a keyword tool. For more information on how to assign keywords tomedia, see
the General Functions user manual.

The keyword appears in the Keywords list.

6. (optional) To keep the selection of keywords for the next log, select Follow previous
logs keywords.

7. (optional) Select an interest level for the log.

8. (optional) Select a highlight color for the log.

9. For an easy tracking of the logs, you can select a color for the log by clicking one of
the color buttons. If you want to create a series of logs with the same background
color, select theRemember Color Selection option.

10. Click the INSERT button.

The log entry is displayed in the Logs grid. A log is created on each relevant recorder
channel defined during step 3 of the logsheet creation:

11. Repeat the procedure to create as many logs as you want.
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4.3. Retroactive Logging

4.3.1. Context of Use
In someworkflows, logs will be added tomedia later than live.

This can be done on clips created earlier, sometimes just for a reason of easy retrieval of
archivedmaterial. In other cases, story editors reviewing the logged clips may decide to
addmore logs.

Users may also log a recorded train, for example during a session break, by rewinding and
browsing the train loaded on the Player.

To do so, you first need to assign a player channel to the IPLogger window and to load the
selected train on the player channel.

4.3.2. Assigning a Player

Introduction
There are several ways to assign a player channel or the Software Player to an IPLogger
window. See section "How to Assign a Player Channel or the Software Player" on page
31.

If a default player channel has been defined from the Channel Explorer, this channel will
automatically be assigned to IPLogger and the IPDirector main window when you open
the application.

See the Channel Explorer manual for more information on how to set and how to clear a
default player channel.

How to Assign a Player Channel or the Software
Player

From the Channel Explorer
Users can assign a player channel to a IPLogger window from the Channel Explorer. This
can be done in the following way:

• Drag a player channel from the Channel Explorer window and drop it on the IPLogger
window.

The name of the selected player is displayed in the Associated Channel zone.

When a channel is assigned to an application, thePlayer icon in the Channel Explorer
window changes from to .
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Additionally, thePlayer area of the IPLogger window becomes active and shows the
running timecode of the record train loaded on the associated player channel.

From the Associated Channel Zone Contextual Menu
Users will be able to select a player from the Associated Channel zone.

This can be:

• a player channel from an EVS video server

• the workstation channel, this means the player channel set as linked from the
IPDirector Configuration window of the Remote Installer

• the Software Player, if the workstation has a valid license for the OCX Software
Player, and if the Software Player is currently associated with a Control panel or a
Playlist panel.

To associate a player channel to the application, proceed as follows:

1. Right-click the Associated Channel zone at the bottom of the window.

A contextual menu is displayed.

2. Select a player from themenu.

The nme of the selected player is displayed in the Associated Channel zone.

If the selected player channel is connected to an IN port of a video router, itself associated
to OUT ports, the name of the router OUT port(s) is displayed after the player channel
name.

Additionally, thePlayer area of the IPLogger window becomes active and shows the
running timecode of the record train loaded on the associated player channel.

4.3.3. How to Log a Recorded Clip or Train

Prerequisites
1. Assign a player channel or the Software Player to a Control Panel

2. Assign the same player to the IPLogger window

3. Load the selected record train or recorded clip on the player
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Procedure
To create a new log entry in a selected logsheet, proceed as follows:

1. From the Control Panel, move through themedia until you find the event you want to
log.

2. (optional) From the IPLogger main window, enter or modify the values in the Log
Metadata area.

3. Click theNew button in the Player area.

The Create a New Log window opens with the timecode grabbed from themedia
loaded on the selected player:

See section "Create a New LogWindow" on page 34 for more information on the
fields.

4. (optional) Enter a free-text description for the log in theDescription field.

5. (optional) Select keyword(s) for the log from the Autocomplete list or from the keyword
grid(s). For more information on how to assign keywords tomedia, see the General
Functions user manual.

The keyword appears in the Keywords list.

6. (optional) To keep the selection of keywords for the next log, select Follow previous
logs keywords.

7. (optional) Select an interest level for the log.

8. (optional) Select a highlight color for the log.

9. For an easy tracking of the logs, you can select a color for the log by clicking one of
the color buttons. If you want to create a series of logs with the same background
color, select theRemember Color Selection option.

10. Click the INSERT button.

The log entry is displayed in the Logs grid.

11. Repeat the procedure to create as many logs as you want.
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4.3.4. Association Rule Between Clips and Logs
As far as the parameter as been configured in the Remote Installer, the system
automatically detects clips which are created and contain the timecode of an existing log,
and it associates both.

Generally, the users who create clips during an event are not the users who enter logs.
When a new clip contains a log timecode between its Protect IN point and its Protect OUT
point, i.e. guardbands included, the clip automatically appears in the Logs grid:

Keywords from the clip (standard keywords and participants keywords) are added to the
keywords of the log in theKeywords andParticipants columns.

4.4. Create a New Log Window

Window Overview
The Create a New Log window opens when one of theNew button is clicked to create a
log.
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The Create a Log window is divided into two panes:

1. The left pane contains the log information, i.e. general log data.

It is always displayed.

2. The right pane contains the user fields making up the profile for LogMetadata
associated to the logsheet profile selected at the logsheet creation.

It is displayed by clicking the right area in thePane Display button .

Fields in the Create a New Log Window

Log Information Pane
The Log Information pane contains the following user interface elements:

Log Timecode
This read-only field displays the log timecode of the current log. It is grabbed from the
preview recorder defined in step 3 or from the PC in case the Link to PC Timecode
button has been clicked
The timecode display can be changed by right-clicking this field and selecting an option
from themenu.

Interest Level buttons
The Interest Level buttons allow users to assign an interest rating to a log. Four interest
levels can be defined, from no star to 3 stars. The background of the button corresponding
to the selected interest level is blue. The default value is the no star level.

Tape ID
This identifies the tape on which the log information is stored.

Switch ENTER / CTRL + ENTER
This option determines the behavior of theENTER shortcut and the
CTRL+ENTER shortcut.
When the checkbox is selected:
• ENTER validates the log
• CTRL+ENTER goes to the next line in theDescription field.
When the option is not selected, the behavior of the two shortcuts is reversed.

Remember Color Selection checkbox
This checkbox is used to keep a selected color from one log to the next log created. When
the checkbox is selected, the focus will be placed by default on the selected color square
next time the Create a New Log window opens.

NOTE
Two users can work on the same logsheet at the same time with
different states of the Remember Color Selection checkbox and
different colors associated to the checkbox.

Follow Previous Logs Keywords checkbox
This checkbox is used to keep selected keywords from one log to another. When the
checkbox is selected, the keywords entered for a log are automatically kept for the next
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log created.

Highlight Colors
These buttons are a set of colors which can be used to categorize the logs. The gray
button lets the log without any associated color. The log line will be highlighted with the
selected color in the Logs grid and the Elements grid of the Database Explorer. The
operator can then search on the colors in the grids.

Description
This field is used to add a free text description to the log.
This will appear in theDescription column of the Logs grid for the corresponding log.

Keywords
This area allows you to assign up to fifty keywords to a log to qualify its content.
For more information on how to assign keywords tomedia, see the General Functions
user manual.

Log Metadata Pane
This pane displays the user fields making up the Profile for LogMetadata which is
associated to the logsheet profile selected at the logsheet creation.

See section "Step 1: Defining the Logsheet Characteristics" on page 16 for more
information on the selection of a logsheet profile.
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5. Using Keywords and Metadata
Profile with Logsheet and Logs

5.1. Parent Keywords

Definition
The parent keywords are keywords set at the logsheet level, and therefore associated
with all log entries of a logsheet.

Assignment
The parent keywords are defined when you create the logsheet, in step 2 of the Logsheet
wizard (the Logsheet Keyword Definition window).
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The parent keywords are automatically assigned to all log entries of a logsheet. They are
displayed in theParent Keywords column of the Logs grid. The parent keywords set as
Participants at keyword creation are displayed in theParent Participants column of the
Logs grid.

Modification
If you want to modify the parent keywords, you need to access the Logsheet Keyword
Definition window by clicking theProperties button from the Toolbar.

The parent keywords modified from this window will automatically bemodified in all log
entries of the logsheet.

5.2. Log Metadata Profile

Definition
Logmetadata can be attributed to log entries of a logsheet for predefined types of
information.

This is especially useful when tracking the pitcher in a baseball game, or a period of action
in a sports event, or program part of an entertainment event.

For example, youmay have defined a "period" field with a list of values such as "first half"
and "second half".

Logmetadata work like a sticky keyword that will persist through all new log entries made
until the value is changed in the LogMetadata pane.

Assignment
At step 1 of the logsheet creation, a logsheet profile can be assigned to the logsheet. In
case a profile for LogMetadata has been associated at creation of the logsheet profile, a
LogMetadata area is displayed in the IPLogger window.
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The user fields from the profile for LogMetadata are shown in this area:

Values can then be entered or selected in each field.

Each logmetadata type is displayed as a column in the Logs grid.

Each time a new log is created, it will receive these logmetadata values. If no value is
defined, the column remains empty.

Modification
Once a logmetadata value has been added to a log entry, there is no way tomodify or
delete it from the active system. If you have the required user right, you can only modify
the logmetadata values that will be associated to upcoming logs at any time in the way
described below.

Before creating a new log entry on which you want the logmetadata values to bemodified,
do one of the following:

• Tomodify a text field, timecode field or date field, select the value and/or type the new
value.

• Tomodify a value from a list, select the new value from the list.

• To add a new value in a drop-down list, select the + sign beside the field, enter the new
value in the Enter a New Value window

and click OK. Then, select the new value.

Any new log entry created afterwards will have the new values of logmetadata assigned
as they have beenmodified.
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5.3. Log Entry Specific Keywords

Definition
It is possible to assign keywords to individual log entries. To do so, it is necessary to have
previously set up a keyword list. One or more keyword grids or dictionaries may have been
set up and named for use with the logsheet. Once set up, as many keyword grids or
dictionaries can be used with a log as required.

Assignment
The log entry specific keywords can be assigned to each individual log entry when it is
created or edited.

This can done in various ways:

• You can start typing the keyword directly in theKeyword field of the Create [Media]
windowor Edit window and select a keyword proposed in the Autocomplete list.

• You can select keywords in a keyword grid, a dictionary or a cascading grid .

• You can type the number associated to a keyword in an open keyword grid or an open
cascading grid.

Relevant keyword grids or dictionaries are usually best prepared in advance of the logging
session although they could be produced and/or modified at any time. As many keyword
grids or dictionaries as required can be used with a logsheet.

See theGeneral Functions user manual for more details on the different procedures.

Standard keywords and participants keywords assigned to a log entry are displayed in the
Keywords andParticipants columns of the Logs grid.

Modification
A log keyword can bemodified from the Edit a Log window. See section "How to Edit Log
Metadata" on page 46 for more information.
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6. Protecting Media

6.1. Context of Use
At the end of a logging session, it is important to protect your media to ensure that the A/V
material corresponding to your log entries will still be available later.

To protect themedia, the system creates a clip which cannot thereafter be deleted, unless
it is previously unprotected.

The users can define a prefix to be applied to their protect media in Tools > Settings >
IPLogger > Protect Media Prefix. This setting is a user setting. By default, the prefix is
"PM".

6.2. Display Protect Media Coverage
You can check whether all the relevant media is protected in the Protect Media Coverage
window by clicking theDisplay PM Coverage button on the Toolbar.

This window displays a time line for each relevant recorder. The log entries are shown as
vertical lines.

If nomedia has been protected yet, the time lines are as follows:

A/V data that is protected is marked with a green background:
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If the Protect All command has been executed, all the A/V data is marked with a green
background:

6.3. How to Protect Selected Media
You can decide to only protect themedia corresponding to some of your log entries,
proceed as follows:

1. In the Logsheet grid, select the logs you want to protect. UseCtrl orShift keys for a
multiselection.

2. Right-click the selection.

The Log contextual menu is displayed.

3. Select Protect Selected Logs from the contextual menu.

The Choose Relevant Recorders window opens:

4. Select the recorders from which you want to protect the recordedmedia.

A clip, covering all the selected log timecodes, is created on each of the chosen recorders.
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Each clip is displayed in the expanded view of the log:

A/V data that is protected is marked with a green background in the Protect Media
Coverage window.

6.4. How to Protect All Media
To protect themedia corresponding to all the log entries of your logsheet at once, proceed
as follows:

1. Click theProtect All button from the IPLogger toolbar.

2. The Choose Relevant Recorders window opens:

3. Select the recorders from which you want to protect the recordedmedia.

A single clip, covering all the log timecodes, is created on each of the chosen recorders.

USER MANUAL IPDirector 7.90 IPLogger

6. ProtectingMedia 43



Each clip is displayed in the expanded view of the log:

In the Display PM Coverage window, all the A/V data is marked with a green background.

6.5. Protect Media Status
In the Log Relevant Recorders window, reachable via Properties > Step 3, the colors in
front of the Relevant Recorders in the selection indicate the protect media status:

Icon Color Protected Media Status

Green  All of themedia related to the logs on this recorder are protected.

Orange  Some of themedia related to the logs on this recorder are protected.

Red None of themedia related to the logs on this recorder are protected.
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7. Creating Clips Automatically
from a Log Entry
Introduction
A clip can be automatically created around a log timecode when it is sent to a bin in one of
the following ways:

• drag-and-drop of the log into a bin: the clip can be created on the record train selected
as the preview recorder or on all relevant recorders.

• preselection of a bin at logsheet creation: the clip will be automatically created on the
record train selected as the preview recorder as soon as the log is created, and the clip
will be sent the bin. The user does not have to do any additional operation.

Refer to the "Creating a Logsheet" section in the IPLogger user manual.

Prerequisites
• Pre-Mark and Post-Mark durations must have been set via theAutomatic Clip

Creation based on Logs setting in the Tools > Settings > Clips > General
category.

◦ Pre-Mark: duration between the clip IN point and the log timecode.

◦ Post-Mark: duration between the log timecode and the clip OUT point.

• A binmust have been selected in the Logsheet properties if you want the clip to be
created without drag-and-drop operation.

How to Create Clips Automatically from a Log Entry by
Drag-and-Drop
To automatically create a clip on the record train selected as the preview recorder,

1. Select the log line in the Database Explorer Elements grid.

2. Drag the log entry onto a bin in the Database Explorer tree or onto an open Bin
window.

A clip is automatically created.

To create a clip on all relevant recorders,

• hold theSHIFT key during the drag-and-drop operation.

Tomake the Save Clip window open and be allowed to name the clip and associate
metadata

• hold theCTRL key during the drag-and-drop operation.
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8. Editing and Viewing Logs

8.1. Introduction
Once created, the log entries can be viewed in a Video Display and/or edited.

You access theView andEdit options when right-clicking on a log entry and selecting one
of the View/Edit options displayed in the contextual menu. See section "Log Entry
Contextual Menu" on page 13 for a description of all the options.

8.2. How to Edit Log Metadata
To edit a logmetadata, proceed as follows:

1. Right-click the log entry you want to edit in the Logs grid.

The Log contextual menu opens.

2. Select Edit from the contextual menu.

The Edit a Log window opens allowing themodification of the logmetadata:

3. Once the log entry is modified, click theUPDATE button to confirm themodifications.

The log entries are updated.

NOTE

Youmay change some data, such as interest level, color,…, for
multiple logs at once: select all the lines to edit and choose the data
you want to associate to all of them in the Edit log window.
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8.3. How to Edit the Timecode of a Log
Entry
The timecode position can bemanually modified in the Timecode field of the Edit a Log
window.

To edit the timecode of the log entry, proceed as follows:

1. In the Logs grid, right-click the log entry for which the timecode has to be edited.

The Log contextual menu opens.

2. Select theEdit orView and Edit command.

TheEdit command displays the Edit a Log window.

TheView and Edit command also loads the log on the player channel associated to
IPLogger at the relevant timecode position.

3. Do one of the following:

◦ Type the new timecode for the log in the Timecode field of the Edit a Log window.

◦ Browse the loadedmedia to the new requested position and click theSet TC
button in the Edit a Log window. The new timecode is then displayed in the
Timecode field.

4. Click theUPDATE button to confirm the TC modification.

8.4. How to View a Log
To view an entry from a logsheet (i.e. load the log on the player channel at the log
timecode position), a player channel or the Software Player must have been assigned to
the IPLogger main window, and to a Control Panel to view it in the control Panel.

This can be a log set on a record train or a log contained in a clip. See section "Logs
Display" on page 7 for all the possible types of clips.
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Loading the Log from the Preview Recorder
The log created on the recorder selected as "preview"can be viewed in one of the following
ways:

• Double-click a log entry, as seen in the collapsed view of the Logs grid.

• Right-click the log entry (collapsed view) and select View from the contextual menu.

The log created from the preview recorder is loaded on the player channel or on the
Software Player at the log timecode.

Loading a Log from a Relevant Recorder
A log created on one of the relevant recorders can be viewed as follows:

1. Expand the log line to see all the log entries created from all the selected relevant
recorders.

2. Click one of the entries.

The log is loaded on the player channel or on the Software Player at the log timecode.

The log is loaded on the player channel or on the Software Player at the timecode of the
log entry on the record channel defined as the preview channel for the logsheet.
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9. Refreshing Associations
between Logs, Clips and
Keywords

9.1. Introduction
The LoggingManager provides options tomanage the links between the clips and the
logsheet.

It is accessed from the Tools menu of theMenu bar in the IPDirector main window.

WARNING

Please note that this function is only available for administrators and
should be used cautiously.

9.2. Refresh Operations
The operations available from the LoggingManager are explained hereafter.

Users must click Start to launch the refresh operation.

Refresh all Associations between Logs and Clips
This option refreshes all links for all logged events and clips present in the IPDirector and
XNet network.
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Refresh the Keywords Associated to the Clip for a Logsheet
When users select this option, they must then choose a logsheet from the list. This
refreshes any keywords that should be associated with a clip within the specified
logsheet.

Refresh the Association between Logs and Clips for a Logsheet
When users select this option, they must then choose a logsheet from the list. This
refreshes any association between logged events and clips within the specified logsheet.
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10. Entering a Timecode Offset

10.1. Context of Use
Imagine the logs and the recordings aremade in different locations or on two different
setups with a timecode offset between the two. For example, the images are recorded live
at the event while the loggers work in a studio, with IPLogger on their laptop. The log
entries receive the PC timecode of the laptop and the recordings have the actual live
timecode.

When the clips are associated to the logsheet, the timecodes of the clips and the logs will
not match and you need to enter an offset. This timecode offset will be applied when:

• importing a logsheet on a setup or

• importing all themedia related to a logsheet.

10.2. Limitations
The TC Offset is available only when:

• the logsheet is not locked

• the user has the appropriate rights to modify the logsheet

• there are log entries in the logsheet
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10.3. How to Define a Timecode Offset to
Synchronize Existing Logs and Clips
A tool is available to synchronize the timecode of the logs with the timecode of the clips
associated to the logsheet.

To enter a timecode offset between logs and clips, proceed as follows:

1. Click File > Enter TC Offset

The following window opens:

2. Enter a value in one of the TC fields and press ENTER.

3. The field is validated and the other TC values are recalculated.

4. Click OK to confirm orCANCEL to discard changes.

WARNING

In this case, new log entries, made after entering the offset, will not
have the offset applied to them. Entering the TC Offset should only be
done when the logsheet is completely finished.
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10.4. How to Synchronize a Whole
Logsheet from a Loaded Image
The users can apply an offset on a whole logsheet by synchronizing one of the logs to an
image loaded on a player channel. To do so, proceed as follows:

1. Associate a player channel to IPLogger. See section "Assigning a Player" on page 31.

2. Open a Control Panel and associate the same player channel to it.

3. Click the log to load it on the player channel.

4. Move through themedia until you reach the image actually corresponding to the log.

5. Right-click the log line in the Logsheet grid.

The Log contextual menu is displayed.

6. Select Synchronize this log with the image loaded on the player from themenu.

All the timecodes from the logsheet are reset.

10.5. How to Apply a Timecode Offset at
Log Creation
If the operators are slow or they are logging on a delayed feed, they can decide to apply an
offset at log entry. The offset is applied to the timecode when the user creates the log. To
do so, proceed as follows:

1. Select Tools > Settings > IPLogger.

2. In theApply a TC offset at log creation on a live feed field, enter a value in msec
for the offset.

3. Click OK.

Each time you will create a new log, the offset will automatically be applied to the log
timecode:

Log timecode = timecode when you have clicked theNew button – offset value

10.6. Applying a Timecode Offset at
Automatic Log Export
When defining a directory for automatic log export in the Remote Installer, an offset can be
specified. This could be, for example that the two setups are in different time zones. Refer
to the Technical Referencemanual for more information.
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11. De-Activating a Logsheet

11.1. Context of Use
While a logsheet is active, it generates database activity and network traffic. Whenever a
clip is created, for example, the database is searched and every logsheet that contains a
timecode that is in the clip will be updated.

De-activating logsheets when they are completed will improve the performance of the
system. Logsheets will nomore be processed in the database, which reduces the
database activity and network load. It is, however, possible to browse all its logs as usual.

11.2. How to De-Activate a Logsheet
To de-activate a logsheet,

1. Open the logsheet to be de-activated.

2. In the File menu, select De-activate logsheet.

The following warningmessage is displayed:

If you select the checkbox Do not show this message again, this warning will not
appear the next time you de-activate a logsheet.

3. Click Yes.

After a logsheet has been de-activated:

• the logsheet cannot be updated

• no new log entries can be added

• the logsheet offset cannot be changed

• the logsheet properties cannot be changed.

A deactivated logsheet is identified by a icon in the Tree view of the Database Explorer.

54 11. De-Activating a Logsheet

EVSBroadcast Equipment SA Issue 7.90.B - June 2020



11.3. Re-Activating a Logsheet
When a de-activated logsheet is opened in IPLogger, the File menu contains the
commandRe-Activate Logsheet. This will restore the logsheet to the active status.
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12. Importing and Exporting
Logsheet and Logsheet Profile

12.1. Importing a Logsheet

Context of Use
If a logsheet has been created on another unconnected IPDirector workstation in a
separate location (for example at a sports venue) and the logsheet is to be used on a
different system, (for example in a post production area), it can be imported from
IPLogger.

You need the following user right: Logsheet > Import from the Logging and Keywords tab
of the User Manager.

How to Import a Logsheet
1. From IPLogger, click File on the Toolbar.

2. Select Import > A logsheet... from the Filemenu.

The Import window opens.

3. Browse to the .xml logsheet file to import and select it.

4. Click Open.

The logsheet and its logs is imported into IPDirector.

It is then available from the Database Explorer from the Logs tree structure.

12.2. Exporting a Logsheet

Context of Use
A logsheet can be exported either in XML or in text format (CSV).

• XML files can be re-imported into another IPDirector workstation at a different
location.

• CSV files can be re-imported into software such as Microsoft Excel ® to produce a
printout.
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You are allowed to do the Export operation from different applications:

• Database Explorer: see the Database Explorer user manual for more information on
that function.see section

• Logsheet Manager tool: see section "Exporting Logsheets" on page 69 ("Managing
Logsheets from the Logsheet Manager Tool" on page 64).

• IPLogger.

How to Export a Logsheet
1. From IPLogger, click File on the Toolbar.

2. Select Export > Current logsheet... from the Filemenu.

The Export window opens.

3. Browse to the destination of your choice.

4. In theSave as Type field, select Logsheet file (*.xml) orCSV file (*.csv).

5. Click Save.

For a .csv file, you will have to select an export profile. See section "Exporting Logsheets"
on page 69 for the complete procedure.

12.3. Exporting a Current Logsheet Profile
To export the currently used logsheet profile as an .XML file,

1. From IPLogger, click File on the Toolbar.

2. Select Export > Current logging profile... from the Filemenu.

The Export Profiles window opens.

3. Browse to the destination of your choice.

4. Click Save.

Here is an example of an XML Profile.
<?xml version="1.0" encoding="UTF-8"?>

<MetadataDefinition Version="2.0.1">

..<LogsheetProfiles>

....<LogsheetProfile GUID="626b05230bd2422989e7e9a8d9b29812">

......<Name>2016 Show</Name>

......<Description/>

......<LogsheetProfile
GUID="977c4eaffbd041808b1dc09afe074614">Show</LogsheetProfile>

......<AutomaticKeywordProfile
GUID="da89e56e86274f858c200d8890848f91">Show_log
MD</AutomaticKeywordProfile>

</LogsheetProfile>
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..</LogsheetProfiles>

..<Profiles>

....<Profile GUID="da89e56e86274f858c200d8890848f91">

......<Header>

........<Name>Show_log MD</Name>

........<Description/>

......</Header>

......<UserFields>

........<UserField>

..........<Header>Artist Name</Header>

..........<Type>TEXT</Type>

..........<Description/>

........</UserField>

........<UserField>

..........<Header>Stage</Header>

..........<Type>COMBO</Type>

..........<Description/>

..........<Values UFSet="specific">

............<value>Red</value>

............<value>Blue</value>

............<value>Green</value>

............<value>Yellow</value>

..........</Values>

........</UserField>

......</UserFields>

....</Profile>

....<Profile GUID="977c4eaffbd041808b1dc09afe074614">

......<Header>

........<Name>Show</Name>

........<Description/>

......</Header>

......<UserFields>

........<UserField>

..........<Header>Date</Header>

..........<Type>DATE</Type>

..........<Description/>

........</UserField>

........<UserField>
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..........<Header>Camera</Header>

..........<Type>NUMBER</Type>

..........<Description/>

........</UserField>

........<UserField>

..........<Header>Logger ID</Header>

..........<Type>COMBO</Type>

..........<Description/>

..........<Values UFSet="common">

............<value>Logger A</value>

............<value>Logger B</value>

............<value>Logger C</value>

............<value>Logger D</value>

..........</Values>

........</UserField>

......</UserFields>

....</Profile>

..</Profiles>

</MetadataDefinition>
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13. Publishing Logs and Logsheets
Context of Use
A logsheet can be published from the File menu.

A log entry cannot be published. Only clips containing the log can be published. This is
done from the clip contextual menu in the Logs grid.

They can also be published from the Database Explorer.

Then, they aremade visible to members of the group(s), or to individual users, they are
published to.

How to Publish a Clip Containing a Log
To publish a clip containing a log to groups of users, or to individual users, from IPLogger,

1. Right-click the clip in the Logs grid.

2. Select Publish from the contextual menu.

The Publish window opens.

3. Select the user group(s), or the individual users, to which you want to publish the clip
in the Available Groups area on the left. KeepCTRL pressed to select multiple groups.

TIP

Use theSearch field to search for a group or to search for a user from the
corresponding lists.

4. Click theRight Arrow button tomove the selected groups from the Available Groups
to the Selected Groups area on the right.

5. Click thePublish button.
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When a user group has been selected, all users belonging to the selected user group and
having visibility rights on the clips will be able to view it.

To un-publish a logsheet to a group of users, or the individual users, repeat steps above
and perform the opposite operation: select the user group, or user, in the Selected Groups
area and click the Left Arrow button.

How to Publish a Logsheet
To publish a logsheet to groups of users, or to individual users, from IPLogger,

1. Select Publish logsheet from the File menu.

The Publish window opens.

2. Select the user group(s), or the individual users, to which you want to publish the
logsheet in the Available Groups area on the left. KeepCTRL pressed to select
multiple groups.

3. Click theRight Arrow button tomove the selected groups / users from the Available
Groups to the Selected Groups area on the right.

4. Click thePublish button.
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14. Printing a Logsheet
How to Print a Logsheet
To print a logsheet,

1. Open the logsheet via the File > Open Logsheetmenu.

2. Select Print from the File contextual menu.

The Print Logsheet window opens.

3. Set the print options.

4. Click thePrint button.

The logsheet is printed on the default printer.

Print Logsheet Window

The logsheet table is not automatically adapted for the printout. The printout reflects what
is displayed on the screen in the IPLogger window. This implies the following:

• The columnwidthmay have to be adapted on the screen.

• The column positionmay have to bemodified by a drag-and-drop operation of the
column heading to the requested position in the table.

• The columns which are not requested in the printout should be hidden. To hide a
column, right-click the column header and click Hide.

• If the value in a cell is displayed on two lines, only the first line will be printed. The
columnwidth should be adapted to have only one line per record.

The following table describes the available layout properties:
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Option Description Default

Logsheet fields
repeated for
every log

When this radio button is selected, the fields
specified in the logsheet header are repeated for
each log record.

Selected

Logsheet fields
only appear in
the header of the
page

When this radio button is selected, the fields
specified in the logsheet header are not repeated in
each log record.

Not
Selected

Print header on
every page

When this check box is selected, the logsheet
properties are printed on every page.

Cleared

Print column
header on every
page

When this check box is selected, the column
headers are printed on every page.

Selected

Print grid When this check box is selected, the grid lines are
printed.

Selected

Print new page
for each …

When this check box is selected, the user can select
a field in the drop-down list to start a new page in the
printout when the given field has a new value.
If a field in the logsheet specifies the sport name in
an athletics event, for example, you can specify to
have a new page started in the printout each time a
new sport is specified in this field.

Cleared

The following table describes the available print properties:

Option Description Default

Margins Top, left, right and bottommargins on the printed
output.

0

Comment Line Number of lines to be added for comments after
each log record.

0

Font Size Font size to be used in the printout. 8

Orientation Page orientation, landscape or portrait, to be used in
the printout.

Landscape
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15. Managing Logsheets from the
Logsheet Manager Tool

15.1. Logsheet Manager Tool

Possible Operations
The Logsheet Manager tool enables the export of one or several logsheets to a selected
destination.

A logsheet can be exported either in XML or in text format (CSV).

• XML files can be re-imported into another IPDirector workstation at a different
location.

• CSV files can be re-imported into software such as Microsoft Excel ® to produce a
printout.

Other operations can also be done from this tool. These are:

• creation of logsheet directory

• move of a logsheet or a log directory in another directory

• deletion of a logsheet or a log directory.

How to Open the Logsheet Manager Tool
To access the Logsheet Manager tool,

1. Click Tools from theMenu bar of the IPDirector main window.

2. Select Logsheet Manager from the Tools menu.

The Logsheet Manager window opens and displays the directories ( ) present in the
Logs tree view of the Database Explorer.
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3. If needed, click the arrow next to a directory to expand it and see its content (sub-
directories and the logsheets ( ) they contain).

15.2. Creating a Logsheet Directory

Prerequisite
You need the following user right: Logsheet > Create from the Logging and Keywords
tab.

How to Create a Logsheet Directory
1. Select the directory or the sub-directory line where you want to create a sub-directory.

The whole line is highlighted:
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2. Click theNew button.

The Log Tree Namewindow opens:

3. Enter a name for the log directory.

4. Click OK.

The log directory appears in the tree and a progress bar shows the job completion status at
the bottom of the window.

15.3. Moving a Logsheet or a Log Directory
in Another Directory

Prerequisite
You need the following user right: Logsheet > Modify set toAll from the Logging and
Keywords tab.

How to Move a Logsheet or a Log Directory in Another
Directory
From the Logsheet Manager tool, you canmove one or several logsheets, and/or one or
several log directories and the logsheets they contain, into another directory from the Logs
tree structure.
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1. Select the check box(es) next to the logsheets and/or the log directories you want to
move.

Example: 2 logsheets selected

Example: 1 log directory selected
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2. Click theMove button at the bottom of the window.

The logsheet tree is displayed on the right, in the Destination Tree pane:

3. Select a destination in the Destination tree.

4. Click OK.

The selected logsheets or log directories have beenmoved:

A progress bar shows the job completion status at the bottom of the window.
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15.4. Exporting Logsheets

Prerequisite
You need the following user right: Logsheet > Export from the Logging and Keywords
tab.

How to Export Logsheets in XML Format
From the Logsheet Manager tool, you can export one or several logsheets.

1. Select the logsheet(s) to export in one of the following ways:

◦ Click the check box(es) next to the individual logsheet(s)

◦ Click the check box(es) next to the log directory(ies) to select all the logsheets
it/they contain.

2. Click theExport button at the bottom of the window.

The Export a Logsheet window opens.

3. Browse to the destination of your choice.

4. In theSave as Type field, select Logsheet file (*.xml).

5. Click Save.

The directory(ies), and sub-directory(ies), are created in the selected destination
according to the Logs tree structure and the selected logsheet(s) is/are exported to this
destination.

A progress bar shows the job completion status at the bottom of the Logsheet Manager
window.

How to Export Logsheets in CSV Format
From the Logsheet Manager tool, you can export one or several logsheets.

1. Select the logsheet(s) to export in one of the following ways:

◦ Click the check box(es) next to the individual logsheet(s)

◦ Click the check box(es) next to the log directory(ies) to select all the logsheets
it/they contain.

2. Click theExport button at the bottom of the window.

The Export a Logsheet window opens.

3. Browse to the destination of your choice.

4. In theSave as Type field, select CSV file (*.csv)
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5. Click Save.

The Select csv Profile window opens.

◦ To create a csv export profile, proceed with steps 6 to 11.

◦ To select a profile and export the logsheet, proceed with steps 12 to 14.

◦ To delete a csv export profile, proceed with steps 15 to 16.

To create a csv profile,

6. Click Select.

The Choose Columns to Export window opens.

7. From the left pane, select themetadata types (columns) you want to export

8. Click the right arrow tomove them to the right pane.
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9. Click theSave Export Profile button.

The following window opens:

10. Enter a name for the export profile.

11. Click OK.

To select a profile and export the logsheet,

12. Select an export profile from theChoose csv profile field.

13. Click Select.

The Choose Columns to Export window opens and shows themetadata types
selected for the profile:

14. Click OK.

The directory(ies), and sub-directory(ies), are created in the selected destination
according to the Logs tree structure and the selected logsheet(s) is/are exported to
this destination.

A progress bar shows the job completion status at the bottom of the Logsheet
Manager window.
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To delete a csv export profile,

15. Select an export profile from theChoose csv profile field.

16. Click Delete.

15.5. Deleting Logsheets

Prerequisite
You need the following user right: Logsheet > Delete set toAll from the Logging and
Keywords tab.

How to Delete Logsheets
1. Select the logsheet(s) to delete in one of the following ways:

◦ To delete one or several logsheets, click the check box(es) next to the individual
logsheet(s).

◦ To delete a whole log directory, click the check box(es) next to the log directory
(ies). This will select all the logsheets it/they contain.

2. Click theDelete button at the bottom of the window.

3. Click Yes to confirm the deletion in the warningmessage.

The logsheets are deleted from the IPDirector database.
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16. IPLogger Shortcuts
Keyboard shortcuts are available to perform some operations.

They are listed in the Define Shortcuts windows which can be accessed by clicking the
Tools > Define Shortcuts option from themenu bar of the IPDirector main window and
then selecting the [Application Name] button on the left.

Some shortcuts can be redefined to suit individual preferences. They are displayed in
regular text. Other ones cannot bemodified. They appear as dimmed text.

See section "Shortcut Definition" in the General Functions user manual for more
information.

Description Current Value (editable)

New log from LIVE
+

New log from Player

Edit log
+

View and edit log
+

Play / Pause
+

Description Current Value (editable)

Play

Var Play
+

Change the speed of the on-air element

Fast Forward (FF)

Fast Reverse (FR)

E/E

Return

Sanp to LIVE
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Description Current Value (editable)

TAKE
+

Activate / deactivate 2nd controller

Mark IN

Clear IN
+

Goto IN

Mark OUT

Clear OUT
+

Goto OUT

Turn OSD ON or OFF
+

Lock / unlock channel
+

Change LOOP mode

Send clip to default bin
+

Append clip to default playlist
+

Send to archive (default XFile)
+

Save clip

Play backward
+

Play forward
+
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17. IPLogger Settings
You can define the settings for IPLogger from the IPDirector main window via Tools >
Settings > IPLogger.

Apply a TC offset at log creation on a live feed
To compensate for a delay in the logging relative to the image being viewed, you can enter
a timecode delay in milliseconds.

If you are for example logging a sports event in London, while the event is being recorded
in China, there could be a small delay between the clip and the timecode in your logsheet.

The TC delay may also be used to compensate for the reaction time of the logger, i.e. the
delay between the instant the action happens and when the logger clicks theNew button.

The offset valuemust be included in the range "0 – 3 600 000" msec.

Protect Media Prefix
Determines the prefix to be added to the clip namewhen clips are created using the
Protect Media feature.

Warning Messages
Determines whether or not warningmessages will appear when the following actions are
performed:

• adding a protect media to a logsheet

• deactivating a logsheet

Action of ENTER and CTL+ENTER shortcuts
Determines the behavior of theENTER shortcut and theCTRL+ENTER shortcuts.

When the checkbox is selected:

• ENTER validates the log

• CTRL+ENTER goes to the next line in theDescription field.

When the option is not selected, the behavior of the the two shortcuts is reversed.

Another setting exists under Tools > Settings > Clips > General for the automatic
creation of clips based on logs. Refer to the section "General Settings for Clips" in the
General Functions user manual.
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