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Disclaimer
This manual and the information contained herein are the sole property of EVS Broadcast Equipment SA
and/or its affiliates (EVS) and are provided “as is” without any expressed or implied warranties, including,
but not limited to, the implied warranties of merchantability and fitness for a particular purpose. In
particular, EVS makes no warranty regarding the use or the consequences of use of this manual and the
information contained herein. Furthermore, EVS may not be held liable for any direct or indirect,
incidental, punitive or consequential loss, damage, cost or expense of any kind whatsoever and
howsoever resulting from the normal or abnormal use of this manual and the information contained
herein, even if advised of the possibility of such loss, damage, cost or expense.

While every effort has been made to ensure that the information contained in this manual is accurate,
up-to-date and reliable, EVS cannot be held liable for inaccuracies or errors that may appear in this
publication. The information in this manual is furnished for informational purpose and use only and
subject to change without notice.

This manual cancels and replaces any previous versions thereof.

Copyright
Copyright © 2003-2024 EVS Broadcast Equipment SA. All rights reserved.

This manual may not be reproduced, transcribed, stored (in a database or a retrieval system), translated
into any language, computer language, transmitted in any form or by any means – electronically,
mechanically, printed, photocopied, optically, manually or otherwise – in whole or in part without the
prior written consent of EVS.

Trademarks
All product and brand names are registered trademarks and trademarks of EVS or of their respective
owners.

Improvement Requests
Your comments will help us improve the quality of the user documentation. Please send improvement
requests, or report any error or inaccuracy on this user manual by e-mail to doc@evs.com.

Regional Contacts
You will find the full list of addresses and phone numbers on the following webpage:
https://evs.com/contact/offices.

User Manuals on EVSWebsite
The latest version of the user manual and other EVS product documentation can be found on the
EVS documentation portal. The documentation portal can be accessed through the VIA Portal on the
following webpage: https://viaportal.evs.com/.
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What's New?
In the User Manual, the icon has been added next to the text to highlight information on new
and updated features.

The sections updated to reflect the new and modified features in the General Functions manual of
IPDirector version 8.06 are listed below.

Graphics settings

Some settings refer to the graphical display of the IPDirector main window and the module windows.
They are available from the View menu.

The Activate Magnet button from the Menu bar is used to activate a magnet effect when windows are
moved around.

• See section "View Menu" on page 17.

• See section "Activate Magnet" on page 24.

Metadata displayed on the Control Panel

The value of a selected metadata user field can be displayed on the Control Panel when the
corresponding metadata profile has been selected. The user field is selected from the New / Edit
Metadata Profile window.

• See section "New Profile Window" on page 47.
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1. Introduction

1.1. IPDirector Overview
IPDirector is an integrated suite of software applications designed to enhance the workflow of a
television production.

IPDirector uses its applications to control multiple channels from several EVS video servers connected to
the XNet SDTI network. The IPDirector system sees the XNet network as one large server whose
storage is divided into various sections accessible by any channel from any EVS server within the XNet
network.

The IPDirector suite allows:

• ingest control,

• metadata management,

• on the fly editing,

• playout scheduling,

• archiving.

All are managed from a single interface.

Together with XTAccess, EVS gateway software, media interchange is facilitated between EVS video
servers and third-party tools such as post-production, file-based camcorders, storage, etc.
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1.2. IPDirector Uses

Standalone Mode

Each IPDirector workstation can function as a standalone system while providing all applications for the
production, from ingest to playout.

Modular Mode

Several workstations can be used, running only the applications required for a specific task.

Each workstation is connected through Ethernet with a central Database.

When networked together, IPDirector Database information is available to all other workstations used in
different production areas while enhancing the overall production workflow.
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In this modular mode, the first IPDirector station commands the ingest and is able to control multiple
recordings and the digitization process of tapes into EVS servers.

This can be complemented with a logging module inside IPDirector which can associate data with each
recording. The logs created will be accessible by all other users on the different workstations.

Other IPDirector workstations dedicated to the production phase allow a control of media while making
clips, playlists, timelines, bins and logs. They also allow the transfer of media to third-party editing
systems for finalizing edits, for instance.

Once the edit has been finalized, it can be sent back for playback to an EVS server. At the end of the
production process, another workstation can allow the playback of any clips or playlists.
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It also allows Fill & Key playback with perfect timecode accuracy.

1.3. Managing Licenses

Licensing Process

Valid license keys must have been imported to XSecure on the workstation where the database is
installed.

1. Actually, when IPDirector is started, the system first checks whether a license for IPDirector Live
PAM Engine exists on the database.

This license is always a floating license (key 06). If there is no valid license, the user gets an error
message. If a valid IPDirector Live PAM Core license exists, it is used.

2. The system then checks whether a fixed license for IPDirector exists on the workstation (key 210). If
there is one valid fixed license, it is used.

3. If there is no fixed license, the system requests a floating license (key 211). If such a license is
available, it is used for that user.

4. If there is no floating license left at that time, the user gets an error message.

List of License Keys

Application Module Fixed (1) Floating (2)

30 - IPDirector IPDirector Live PAM Engine - 06

30 - IPDirector IPDirector 210 211

30 - IPDirector Archive/Restore Unlimited (3) 171 -

30 - IPDirector PUBLISH Add On - Facebook (4) - 180

30 - IPDirector PUBLISH Add On - Youtube (6) - 182

30 - IPDirector PUBLISH Add On - Generic CMS (7) - 183

(1) These licenses must be installed on the workstation where the application is installed.

(2) These licenses must be installed on the workstation where the database is installed.

(3) A valid Archive / Restore license is needed to use the archive/restore process. The fixed license
Archive/Restore Unlimited (key 171)must be imported to XSecure.
(4) (5) (6) (7) (8) A valid PUBLISH Add On license is needed to see the workflow targets created for the
corresponding social media or a generic CMS.
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License Validity Icon

An orange License icon is displayed in the Status bar of the IPDirector main window when one of the
IPDirector licenses will expire within two weeks.

How to Activate the License in XSecure
To activate the IPDirector license in XSecure,

1. In the Start menu, select Evs Broadcast Equipment > XSecure > XSecure Manager to launch the
XSecure application:

2. In XSecure, click the Request button in the Operations area at the bottom of the main window.

3. Store the .xml file generated by XSecure on your desktop and send it to the EVS Support.

4. When you receive the file containing the license keys from the EVS Support, open XSecure and click
the Import Key File button in the Operations area:

5. Select the file you have received and click Open.

The license key number(s) is/are imported into XSecure, and the new license module(s) is/are displayed
in the License List area in XSecure.
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1.4. Opening IPDirector

Starting IPDirector

To open IPDirector, select the application from Start > Programs > EVS Broadcast Equipment or click
the corresponding icon on the desktop.

Then, the next steps will depend on the authentication mode set.

Authentication Mode

The IPDirector workstation may be integrated, or not, into an Active Directory domain. This is
determined by the Authentication Mode parameter set in the Remote Installer, from the General tab of
the workgroup configuration window.

Authentication Mode: Active Directory

The user group the user belongs to in the Windows domain is linked to a profile in the User Manager.
This determines the set of user rights and user settings the user will have in the application. See the
IPDirector - User Manager Technical Reference for more information.

Connection by the user connected to the workstation

The user connected to the workstation may connect to IPDirector without entering any access code.
Starting the application automatically opens the IPDirector window.
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Connection by another user

To allow another user to log in to IPDirector,

1. The user connected to the workstation logs off from IPDirector.

See section "File Menu" on page 16

The following Login window is displayed.

2. The other user must:

a. In the Login window, selectManual authentication (AD users).

b. Enter their own credentials.

c. ClickOK.

The IPDirector window opens.

d. Log off when they have finished.

Re-connection by the user connected to the workstation

When the user connected to the workstation wants to reconnect after the other user has logged off or
has closed the IPDirector window:

1. In the login window, select Integrated authentication.

2. ClickOK.

The next time this user will close IPDirector and log in again on this workstation, the IPDirector window
will automatically open without any access code.

Authentication Mode: IPDirector

If the IPDirector workstation is not integrated into an Active Directory domain, a Login window will
always be displayed when IPDirector starts.
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Users must enter their own IPDirector username and password.

Auto Log Off Function

The Auto logoff parameter can be set at the workstation level or at the users level.

When both have been defined, the setting per workstation will take over the auto logoff management.

The configuration of the Auto logoff setting at the workstation level is done from the Remote Installer.

The configuration of the Auto logoff setting at the users level is done from the User Manager.

• If it is set to Global in the User Manager, the setting value will be common to all users and the users
will not be allowed to change it.

• If it is set to User in the User Manager, any user will be allowed to change the setting value for their
account from the General settings.

Summary of the Possible Options for Auto Logoff

Auto Logoff Remote Installer configuration User Manager
configuration

Behavior

at users
level, same
period for all
the users

Global + [0]
minutes

The users will never
be logged off.

Global + [1-720]
minutes

The users will be
logged off after same
period of inactivity [1-
720] minutes.

at the users
level, period
customized
by user

User + [0-720]
minutes (period
can be changed
by each user from
General Settings
in IPDirector)

each user will be
logged off after user-
defined period
[0=never to 720]
minutes.
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Auto Logoff Remote Installer configuration User Manager
configuration

Behavior

at the
workstation
level

Global or User

+ [0-720] minutes

the user logged on
this workstation will
never be logged off.

(from [1-720] minutes)

Global or User

+ [0-720] minutes

the user logged on
this workstation will
be logged off after [1-
720] minutes of
inactivity as defined in
Remote Installer.

1.5. IPDirector Applications

Production Workflow

There are several applications designed for use on a production. Each is integrated into the overall
package and is accessible via installed software licenses.

Each application can be used to perform different tasks.

The following diagram represents the production process and the role of every application.

Channel Explorer
The Channel Explorer provides a comprehensive overview of any device available on the media sharing
network, XNet2, including:

• EVS video servers, with their recorder channels and player channels,

• XF2 removable storage,
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• XStoreSE media storage,

• high resolution and low resolution streams,

• VTR devices,

From within the Channel Explorer window, any IPDirector workstation can take control of one or several
channels from different EVS servers connected to the XNet. When control has been taken, the selected
channels can be locked.

The flexibility of IPDirector allows multiple channels to be managed together in a variety of modes:

• Ganged channels: allowing simultaneous control of several channels from one control panel
(recorders or players)

• Fill and Key: allowing 2 clips to be linked in a Fill/Key pairing for playback to a vision mixer (switcher)
or keyable device.

• Program/preview: allowing the playout of audio and video transition effects between clips, playlist
elements or timeline elements.

• Lock Timeline: allowing two channels to be function as Timeline Engine for use with IPEdit.

• AB Roll Playlist: to control and play material on up to 4 channels at the same time.

Recorder Panel
The Recorder Panel is the graphical user interface used to control the recorder channels of an EVS video
server. The Recorder Panel shows the record status of a channel and allows to start or stop the
recording by a recorder channel. It provides the basic functions to create a clip.

Ingest Scheduler
The Ingest Scheduler is a visual tool that allows the creation, editing and view of scheduled ingests on
EVS video servers, or from the servers to files on storage via XTAccess. It provides a timeline view of
each recorder and stream configured through the Remote Installer and controlled by IPDirector.

The Ingest Scheduler is designed to control:

• ingests as a growing clip on any recorder channel of an EVS video server (high resolution or low
resolution) controlled by IPDirector.

The scheduled ingests are automatically saved as clip elements of XT Clip type.

• streams of the material ingested onto the recorders. The streams shown are virtual channels that are
automatically associated with each recorder if at least one XTAccess in the GigE network.

The streams are automatically saved to files and appear in IPDirector as clip elements of File type.

This module is used to schedule ingests in the future, but can also be used to immediately start a
recording. It is designed to schedule one-shot ingests or to schedule ingests repeated at regular
intervals (Repeat Every ingests) or repeated at a defined start time on selected days (Repeat ingests).

Ingests can be associated with a logsheet and automatically protected.
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IPLogger
IPLogger is used to create logs on a given event. A log is a reference point to a given timecode in a
record train and descriptive information can be associated with it. This aims to easily identify important
moments in an event and to create clips later on based on the logs.

Logs are related to a logsheet which is created for the event and contains its own metadata, previously
defined in a logsheet profile. Users have the possibility to create log entries directly during the event, or
later on.

Users can associate metadata to the log, such as keywords, interest level, highlight color or a
description.

Keyword Management
A set of applications is used to manage the keywords database, prepare grids and dictionaries for
logging, searching and browsing.

Using the Keyword Management tools, a keyword grid or dictionary content can easily be changed and
organized by the operator and production team to make it perfectly suited for any sport or live
production. An unlimited number of keyword grids, consisting of up to 300 words each can be managed
by IPDirector.

Keyword Management tools allows the addition of single keywords to the database and therefore to any
grid. It also allows the import of keyword grids generated by an EVS sever, keyword grids from other
IPDirector installations and even the integration of keywords and keyword grids from 3rd party
databases which may already exist such as competitor lists and team or event statistical databases.

Simple text files can also be easily imported into the Keyword Database making it easy to import data
from a web page or other document where words exist for your event.

Database Explorer
The Database Explorer is a central point in the IPDirector application to perform search on all the media
available on the network and to load media. It provides access to any high or low resolution media
available on the online production network, as well as nearline storage platforms. This includes clips (XT
clips and files), playlists, edits, timelines, and logs. It can also reference the list of off-line nearline media.

Bins can be created to organize clips, playlists, edits and timelines and bin rules can be defined to
automatically copy clips, playlists, edits or timelines within a bin based on predefined rules.

VTR Control Panel
The purpose of the VTR Control Panel is to control a VTR (Video Tape Recorder) from IPDirector. It is an
advanced remote control, from within the IPDirector application.

Apart from playback and record control, it also allows the extraction of clips from a tape to the EVS video
servers. This process can be done for a single clip or multiple clips can be "batch digitized".

The VTR Control Panel can be used according to 3 modes:

• Transport mode: the VTR Control Panel works as a remote control for the VTR, from within IPDirector.
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• Clip Digitize mode: one or several clips can be digitized from a single tape to a recorder channel on
an EVS video server.

• Batch Digitize mode: several clips can be queued in a Batch list, so that they can all be digitized in
one process run.

Control Panel
The Control Panel is the graphical user interface used to preview and manipulate:

• clips, record trains, playlists and timelines stored on an EVS video server when the Control Panel is
associated with a player channel,

• files stored on a nearline folder of the GigE network when the Control Panel is associated with the
OCX Software Player (if the workstation has a valid license for it).

It provides transport functions to play the media and clip creation functions to clip media or trim existing
clips.

Clips, playlists or timelines can be played out with transition effects between elements. To do so, special
channel modes must be enabled. Depending on several parameters on the EVS video server, a single
player channel could be used or two player channels must be dedicated to the playout of the loaded
item.

It also allows to:

• build and play clip-lists (simple playlists),

• play back media in loop or bounce-modes,

• synchronize playback on ganged channels.

Playlist Panel
The Playlist Panel allows the creation, modification and playout of multiple playlists on air using an
efficient and extremely flexible workflow.

A variety of playout effects can be defined, different stop or start options can be programmed, and tags
can be set to carry out specific audio or video actions during playout.

IPEdit
IPEdit allows complete timeline editing while maintaining the speed and power of the EVS servers
recorder and player channels. Drag-and-drop operations and keyboard shortcuts make it easy to
perform video and audio transition effects.

Video graphics and voiceovers can be added to the timelines. Up to two simultaneous timelines can be
created per EVS server. GPI Out allows for external device automation, and the ability to play out while
editing ensures a speed to air workflow.
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AB Roll Playlist
The AB Roll Playlist application is used to control and play material on a series of channels from a staged
playlist in the database. These channels load in a sequential manner as per a shows rundown or planned
sequence. These channels may be directly managed using the companion MPlay remote to manage up
to 4 player channels.

Playlists from any EVS interface or third party applications, or rundowns from NRCS (Newsroom
Computer Systems) can be used as input for the AB Roll Playlist application.

Director's Cut
The Director's Cut application is used in live or near-live post-productions.

Takes recorded from several camera angles at a time, as well as the director's cut created with a
switcher, are kept on the EVS video servers and streamed or written to a NLE. An EDL, using all the
switcher input change notifications that appears on the switcher when the director produces the show,
is exported to the NLE in native format and linked to the takes.
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2. IPDirector Main Window

2.1. Introduction
The IPDirector main window is the window which opens when IPDirector is started. By default the
IPDirector main window opens without any application window opened. However, specific layout of
windows display may have been assigned to a user or created and saved by the user, so this layout will
automatically be launched when the user opens IPDirector.

From this main window, the user can open one or several instances of the various IPDirector
applications.

2.2. Overview of the IPDirector Main
Window

The IPDirector main window contains the areas highlighted on the screenshot below:

Menu bar (1)
The Menu bar gives access to several menu commands.
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• The File, View,Windows and Layoutmenu commands allow the users to modify and customize the
IPDirector user interface in which they are working.

• TheMetadatamenu gives access to the options for managing the customer-defined data that can
be associated with clips, logsheets, playlists and timelines.

• The Toolsmenu gives access, among others, to the settings and shortcuts defined for the various
IPDirector applications as well as some additional options.

• The Pluginsmenu gives access to plugins, if any, defined in an XML file stored locally on the
IPDirector workstation or configured from the Remote Installer. See section "Plugins Management"
on page 40.

• The Helpmenu gives access to the application version, user manual, license information, etc.

See section "Menu Bar" on page 16 for more information on the menu commands.

Application bar (2)
The Application bar provides direct access to the various IPDirector applications. When the user clicks
the icon corresponding to a given application, the application opens in the workspace.

The Keyword icon gives access to a menu for the selection of the keyword tool to open.

Each application is widely described in separate chapters of the current user manual.

Buttons can also be available for plugins involving a URL and configured from the Remote Installer. See
section "Plugins Management" on page 40.

In the MediaCeption Signature solution, the VIA MAP apps that have been made available from the
Remote Installer can be accessed from the Application bar.

At any moment, you can customize your Application bar and select the module/app for which
you want a button to be displayed in the Application bar. See section "View Menu" on page 17.

Date and Time fields (3)
These fields are read-only and give information on the date and time of the SDTI network, if any, or of
the EVS video server in case of a standalone server.

Workspace (4)
The workspace is the central area used to display the IPDirector applications that the current user
opens. Application windows can be freely resized and organized in the workspace.

Status bar (5)
The Status bar contains icons and fields that provide information on the following elements: default
player channel, default bin, default playlist, loaded layout, minimized application windows, messages,
connection status of IPDirector processes and external components.

See section "Status Bar" on page 28 for more information on the elements available from the Status bar.
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Channel Status panel (6)
The Channel Status panel contains the Recorder Status and the Player Status tabs. They make it
possible to view the recorder and player channels connected to the XNet network, as well as status
information.

See section "Channel Status Panel" on page 25 for more information on the Channel Status panel.

Layout panel (7)
The Layout panel allows single-click access to your saved layouts.

The Layout tab is described in details in "Layout Management" on page 33.

2.3. Menu Bar

2.3.1. Introduction

The Menu bar gives access to a series of menus and buttons which provides various commands
described hereafter.

2.3.2. File Menu
Clicking the File option on the Menu bar displays the File menu with the following options:

Log Off User

Logs off the current user and displays the Login window.

See section "Opening IPDirector" on page 6.

Exit

Exits IPDirector.

Prior to log off or exit, it is best practice to save the current layout. The saved layout will
automatically be displayed the next time the user logs on to IPDirector.
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2.3.3. View Menu
Clicking the View option on the Menu bar displays the View menu.

Graphics Settings

This option opens a window with the following options.

Dual Screen Mode

Sets on which screen the main window will be displayed if you use 2 screens: Left Screen, Right Screen,
Dual Screen.

Display Mode

Sets how the main window will be displayed.

• Windowed: displayed as a window and can be moved on the screen.

• Full Screen: occupies the entire screen

• Full Screen (Task Bar visible): occupies the entire screen but the Windows task bar remains visible.

Allow Modules Outside

Allows you to move a module window outside of the main window. This can be useful if you use two
screens.

Magnet Power

Sets the power of the magnet effect when windows are brought closer once the Activate
Magnet option is enabled from the Menu bar.

Application Toolbar

Show/Hide

Displays or hides the Application bar.

Customize

Opens a window from which you can select the module / app buttons you want to see in the Application
toolbar.
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Status Panel

Displays or hides the Status bar at the bottom of the main window.

Layout Panel

Displays or hides the Layout tab on the left of the main window.

Green Information on VGA

Enables or disables the display of the green messages on the IPDirector main window when a specific
action has been performed, e.g. CLIP CREATED, CLIP DELETED…etc.

Message Box

Displays or hides the message boxes. If the option is not selected, no message box will be displayed on
the workspace. They will only be added in theMessage field. See section "Status Bar" on page 28 for
information on theMessage field.

2.3.4. Windows Menu
Clicking theWindows option on the Menu bar displays the Windows menu.

Close All Windows

Closes all the IPDirector applications opened in the current session.
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<Name of open IPDirector Application(s)>

Gives the focus on the application corresponding to the selected item and brings it to the front.

2.3.5. Layout Menu
The Layout menu gives access to various options for the layout management.

See section "Layout Management" on page 33 for the description of the different options.

2.3.6. Metadata Menu
The Metadata menu gives access to the single optionManage Profiles...which opens the window for
defining, importing, exporting and updating the metadata on clips, logsheets, playlists, timelines and
edits.

The management of metadata profiles is described in details in section "Metadata Profiles Management"
on page 43.

2.3.7. Tools Menu

Tools Menu Options
Clicking the Tools option on the Menu bar displays the Tools menu.

The following commands are listed in the Tools menu:

Settings

Opens the Settings window which gives access to all the categories of IPDirector settings.

Some categories relate to a dedicated application and are detailed in the chapter dealing with that
application. Other categories are general or common to several applications and are detailed in section
"Settings" on page 100.

Snapshots

Opens the Snapshots window from which users can create a snapshot of what is loaded on a set of
player channels, so that they can call it when needed.

See section "Creating a Snapshot of Loaded Clip" on page 20.

Logging Manager

Opens the Logging Manager window from which users can refresh associations between logs and clips.

See the IPLogger user manual for more information on that function.

Logsheet Manager

Opens the Logsheet Manager window from which users can export logsheet(s) to a selected
destination.
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See the IPLogger user manual for more information on that function.

Remote Control Manager

Opens the Remote Control Manager window.

When a MPlay Remote device or a BEPlay Remote device is connected to the IPDirector workstation,
you can configure it by selecting the Remote Control Manager option from the Tools menu. The MPlay
Remote and BEPlay Remote configuration is explained in details in section "Remote Control
Management" on page 121.

Recreate all Thumbnails

Used to request the creation of thumbnails from a particular EVS video server.

See section "Recreating all Thumbnails" on page 22.

Define Shortcuts

Opens the Define Shortcuts window which gives access to the different lists of keyboard shortcuts
defined for most of the actions possible in IPDirector.

Some lists relate to a dedicated IPDirector application and are detailed in the chapter dealing with that
application. Other lists are general or common to several applications and are detailed in section
"Shortcut Definition" on page 114.

Transfer Monitoring

Opens the Transfer Monitoring window that provides detailed information on the clip, playlist or
timelines transfers. Transfer monitoring is explained in section "Monitoring the Transfer Status" of the
Database Explorer user manual.

Workflow Monitoring

Opens the Workflow Monitoring window that provides detailed information on the scheduled, running
and completed transfers to workflow targets managed by the PUBLISH Add-On and the archiving /
restoring jobs managed by the ARCHIVE Add-On.

Workflow monitoring is explained insection "Monitoring the Workflows" of the Database Explorer user
manual.

Change Password

Allows the currently logged on users to change their own password.

Creating a Snapshot of Loaded Clip

Context of Use

The Snapshot tool is used to save a snapshot of selected player channel(s) with the clip(s) loaded on
it/them at current timecode position. This allows to easily recall the snapshot and quickly load the same
content on the saved player channels.

To access the Snapshots window, click Tools from the main Menu bar and select Snapshots from the
Tools menu.
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How to Create a Snapshot
1. Load the desired clip(s) on the player channel(s) at the timecode you want.

2. Open the Snapshots window.

3. Click the New button.

The left pane displays the list of the EVS servers and their player channels.

4. Enter a name for the snapshot in the Snapshot Name field.

5. Select the player channel(s) where clip(s) are loaded.

6. Click Save.

The snapshot is listed in the Snapshots window.
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How to Load the Clips Saved in a Snaphot
To load the clip(s) selected in a snapshot, at the selected timecode, on the selected player(s),

1. Open the Snapshots window.

2. Click the button next to the snapshot name.

How to Delete a Snapshot
1. Proceed in one of the following ways:

◦ Select a snapshot line from the Snapshots window and click Delete at the top of the window.

◦ Click next to the snapshot to delete.

2. Click Yes in the dialog box to confirm the deletion.

Recreating all Thumbnails

Context of Use

Please note that this function is only available for administrators and should be used
cautiously.

This option, available from the Tools menu, allows you to request the creation of thumbnails .

The creation of thumbnails works as a background process when there is an XML unit set to create
thumbnails. However, it is possible to request a manual initiation of that process if a system needs to
have its clip thumbnails recreated.
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How to Recreate all Thumbnails
1. From the Menu bar of the IPDirector main window, select Tools > Recreate all thumbnails.

The following window opens.

2. Select the EVS video server for which you want to recreate the thumbnails.

3. Click Recreate.

This will send XML files to the XFile3 or XTAccess on the network that will create thumbnails for the
IPDirector system.

2.3.8. Help Menu
Clicking the Help option on the Menu bar displays the Help menu.

The following options are available from the Help menu:

User Information

Gives information about the logged user, as well as group membership and details about the user rights,
as this has been defined from the User Manager. For more information about each tab, see the
IPDirector Technical Reference for User Manager.

License

Shows the licenses status of the applications.

User's manual

Gives access to the user manual.

About

Provides information about the IPDirector version number and gives a list of support phone numbers and
e-mail addresses.

Clip Manager Monitoring

Monitoring applications for the use of EVS Staff.
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2.3.9. Freeze Workspace
You can lock the IPDirector workspace to prevent from moving windows, resizing windows or opening a
new IIPDirector window.

To freeze the workspace,

• Click the Freeze Workspace button on the Menu bar.

The button background color turns to blue .

The operator can still open the layout shortcut panel and click a shortcut to change the layout.

To freeze the workspace,

• Click the button once again.

2.3.10. Lock Keyboard
You can lock the keyboard from use on the workstation.

To lock the keyboard,

• Click the Lock Keyboard button on the Menu bar.

The button background color turns blue and the title bar is highlighted in red to warn
the users:

The control of the workstation is still possible with a mouse or touchscreen.

To lock the keyboard,

• Click the button once again.

2.3.11. Activate Magnet
The Activate Magnet function is used to have a magnet effect when a window is dragged closer to
another one. So, they are automatically and quickly snapped and aligned one next to the other.

The power of the magnet effect is set from the Graphics Settings > Magnet Power option of the View
menu.

The button background color turns to blue when it is activated .
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2.4. Channel Status Panel

2.4.1. Introduction

Purpose

The Channel Status panel is made up of the Recorder Status panel and the Player Status panel. These
panels allow the user to monitor the status of requested recorder or player channels.

By default, the panels are minimized to small REC and PLAY tabs on the bottom left side of the
workspace as shown in the screenshot below.

How to Open and Close the Channel Status Panels
To open the Recorder Status panel or Player Status panel for the first time in a session,

1. Right-click the tab.

2. Select the View All Recorders or the View All Players option respectively.

The Recorder tab or the Player tab expands to the right:

To open the Recorder Status panel or the Player Status panel again during the same session,

• Just click the REC or PLAY tab.

To close the Recorder Status panel or Player Status panel,

• Click the REC or PLAY tab on the right side of the pane.
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2.4.2. Recorder Status Panel

Overview of the Recorder Status Panel

Depending on the EVS server configurations, up to 6 recorder channels can be displayed per server.

The Recorder Status panel provides the following information for each recorder channel displayed on
the panel:

• recorder channel name

• remaining capacity on the recorder

• recording status

◦ capacity information on a red background if the channel is recording

◦ capacity information on a gray background if the channel is not recording

• Lock icon next to the remaining capacity information, if the channel is locked

• Gang Group icon next to the remaining capacity information, if the channel is part of a
gang group.

Recorder Status Tab Contextual Menu

A contextual menu appears when you right-click the Recorder Status tab.

The following table describes the commands available from the contextual menu.

View Recorders

Expands the Recorder Status panel and displays the list of recorder channels as selected from the
Define the Recorder Channels window.

Add/Remove Recorders

Allows the user to add recorders to or remove recorders from the Recorder Status panel.

Selecting this item opens the Define the Recorder Channels window from which you can select the
recorders to be added to or removed from the Recorder Status panel.

View All Recorders

Expands the Recorder Status panel and displays all recorder channels available on the XNet network.

Recorder Channel Contextual Menu

A contextual menu appears when you right-click a recorder area.
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The following table describes the commands available from the contextual menu.

Open Recorder Panel

Opens the Recorder Panel window for the selected channel. See section the Recorder Panel user
manual for more information on that window.

Remove

Removes a given recorder from the Recorder Status panel.

2.4.3. Player Status Panel

Overview of the Player Status Panel

Depending on the EVS server configurations, up to 6 player channels can be displayed per server.

The Player Status panel provides the following information for each player channel displayed on the
panel:

• player channel name

• player status

◦ on air red icon if the player channel is on air

◦ off air gray icon if the player channel is off air

• Lock icon if the channel is locked

• Gang Group icon if the channel is part of a gang group or a Fill & Key association.
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Player Status Tab Contextual Menus

A contextual menu appears when you right-click the Player Status panel.

The following table describes the commands available from the contextual menu.

View Players

Expands the Player Status panel and displays the list of player channels as selected from the Define the
Player Channels window.

Add/Remove Players

Allows the user to add players to or remove players from the Player Status panel.

Selecting this item opens the Define the Player Channels window from which you can select the players
to be added to or removed from the Player Status panel.

View All Players

Expands the Player Status panel and displays all player channels available on the XNet network.

Player Channel Contextual Menus

A contextual menu appears when you right-click a player area.

The following table describes the commands available from the contextual menu.

Open Control Panel

Opens a Control Panel window with the selected player channel assigned to it. See the Control Panel
user manual for more information on that window.

Remove

Removes a given player from the Player Status panel.

2.5. Status Bar

From left to right, the following fields are displayed:

Default Player Channel
A default player can be defined from the Channel Explorer or from the IPDirector main window. It will
automatically be assigned to the IPDirector main window at opening, as well as to the Database Explorer
or the IPLogger.

If a default player channel has been defined, the Default Player Channel icon is green and is followed by
the name of the default player channel. A tooltip can be displayed by moving the mouse over the area.
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If no default player channel is defined, the Default Player Channel icon is orange and followed by None.

See the Channel Explorer user manual for more information on how to set and how to clear a default
player channel.

Default Bin
If a default bin has been defined, the Default Bin icon is green and is followed by the name of the default
bin.

If no default bin is defined, the Default Bin icon is orange and followed by None.

You can define a default bin in the Database Explorer, via the Set as Default Bin option available from
the Bin contextual menu.

To clear the default bin,

• Double-click the Default Bin field.

Default Playlist
If a default playlist has been defined, the Default Playlist icon is green and is followed by the name of
the default playlist. A tooltip can be displayed by moving the mouse over the area.

If no default playlist is defined, the Default Playlist icon is orange and followed by None.

You can define a default playlist in the Database Explorer, via the Set as Default Playlist option available
from the Playlist contextual menu. See the Playlist Panel user manual.

To clear the default playlist,

• Double-click the Default Playlist field in the Status bar.

Loaded Layout
If a layout is currently loaded in IPDirector, the Loaded Layout icon is green and is followed by the name
of the loaded layout.

If no layout is loaded, the Loaded Layout icon is orange and followed by No Layout.

See section "Layout Management" on page 33 for information on how to load a layout.
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You can clear the layout by double-clicking the Loaded Layout field.

Clearing the current layout will clear the entire user interface of all open windows.

Minimized Windows
TheMinimized field indicates whether windows have been minimized and allows the users to restore
the minimized windows.

When no window is minimized, theMinimized field has a gray background.

When one or more windows have been minimized, theMinimized field has an orange background.

To restore a minimized window,

• click theMinimized field and select the minimized display of the window you want to restore.

Message Pane

Purpose

TheMessage field displays the most recent message in the Status bar.
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The Message pane expands by clicking the arrow on the right of theMessage field. It provides a quick
display of the information, warning and error messages generated during the current session.

Messages Display

The messages include the following information:

• the date and time when the message was generated

• the message itself

The messages are highlighted on a different background color depending on the type of message.

• An information message is highlighted in green.

• A warning message is highlighted in orange.

• An error message is highlighted in red.

Message Acknowledgment

As soon as a message appears, the Acknowledge button turns red.

→

Users can acknowledge the message by clicking the button. This changes the background of the
message to gray.

This helps the users to distinguish the messages that have been dealt with from the ones that have not.

Messages Filter

Messages can be filtered acording to their type thanks to theMessage Type buttons displayed on the
top left corner of the expandedMessage field: Information,Warning, Error.

By default, all the filters are enabled and all the buttons have a blue background.

To disable a filter and remove the corresponding messages from the list, users must click theMessage
Type button for that filter. The button is then displayed on a gray background.
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Process Status Icons
The background color of the Status icons provides information on the status of the processes that run in
the background:

• When the background color is green, the process is running or the connection is established.

• When the background color is orange, the process is not running or the connection is not
established.

For more information on these processes, refer to the IPDirector Remote Installer Technical Reference
manual.

Icon Description

Status icon indicating that there is no conflict among the Multicam versions on the different
EVS video servers.

Status icon for the IPDirector Routing process.

Status icon for the database connection.

Status icon for the SynchroDB process.

Status icon for the IPScheduler process.

Status icon for the VTR Engine process.

Status icon for the EVS video server connection.

• green icon: the Routing process works (the IPDirector Routing process icon is green) and
there is at least one EVS server visible by IPDirector on the setup.

• orange icon: the Routing process works (the IPDirector Routing process icon is green) and
IPDirector does not detect any EVS server (possible causes: no SynchroDB process
managing the server, no EVS server physically connected to the setup,...).

• red icon: the Routing process does not work properly (the IPDirector Routing process icon
is red).

Status icon for the Router Control.

Status icon for the AB Roll process.
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3. Layout Management
Context of Use

Depending on the job content and personal preferences, most users have a preferred screen layout
(open windows and window positions).

The purpose of the Layout features in IPDirector is to present users their personalized screen layout
every time they log into IPDirector.

Pre-defined layouts, specifically dedicated to a category of users, are managed in the User Manager.
They can be assigned to a user by the system administrators. So, this layout becomes the default layout
for the user.

Depending on the user rights, a default layout will be assigned to the users or they will be able to create
their own layouts by themselves or to import a layout.

Shortcuts can be created for the existing layouts, so, a layout can be opened in one-click.

The layout shortcuts are defined and selected from the Layout pane.

To open the Layout pane, click the Layout tab on the left screen border.

Managing Layouts

Layout Menu

The following options are available from the Layout menu on the main Menu bar.

New

Opens the New Layout window to create a layout. See section "How to Define a Layout" on page 34.

Open

Opens the Load Layout window from which you can select an existing layout. This includes layouts
created by the user and imported layouts. The IPDirector windows associated with the selected layout
will then open on screen.

If the Freeze Workspace option was selected when the layout has been created, the
workspace will automatically be frozen and you will not be able to move or close any window
from the layout.

Save Layout

Saves the layout of the open windows with the name of the currently loaded layout, which is displayed in
the Status bar of the Main window. See section "How to Define a Layout" on page 34.
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Save Current Layout as

Opens the Save Current Layout As window to allow you to give a name to the current layout. See section
"How to Save a Layout with a New Name" on page 36.

Select and Delete

Opens the Delete Layout window from which you can select the layout(s) to delete.

Publish

Opens the Publish window from which you can publish a layout to selected users or groups of users.

Properties

Opens the Properties window from which you can

• change the name and/or the icon of the layout and the layout shortcut,

• publish the layout to selected users or groups of users,

• freeze / unfreeze the associated workspace.

Import

Allows to import a layout. The imported layout will therefore be available from the Layout menu.

Export

Allows to export a layout as xml file.

How to Define a Layout

This section describes the way to define a new layout, for users who have the appropriate user rights.

You can open and arrange the selected windows before creating the layout or you can first create the
layout and arrange the windows later on and save them with the layout name.

To define a layout,

1. Select New in the Layout menu of the IPDirector Menu bar.

The New Layout window opens.
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2. Enter a name for the layout.

3. (optional) To associate an icon with the layout:

a. Click the Select Icon button

The Open Icon window opens.

b. Select an icon file.

c. ClickOpen.

4. (optional) Select the Freeze Workspace option.

When such a layout will be loaded, the workspace will automatically be frozen and you will not be
able to move or close any window from the layout.

The option is only available to administrators and the layout owner.

5. ClickOK on the New Layout window.

The following message is displayed:

6. Click

◦ Yes if you want to start from a clean working area.

◦ No if you want to create a new layout based on your current working area.
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The layout name is displayed in the Status bar of the main window .

7. In case you have clicked Yes,

a. open and arrange the selected windows.

b. Select Save Layout from the Layout menu.

The current working area is saved with the name of the current layout.

How to Save a Layout with a New Name

Once you have arranged some windows in the way you want them to appear, you can save the current
layout with a new name.

1. Select Save current layout as from the Layout menu.

The New Layout As window appears.

2. Enter a name for the layout.

3. If you want to associate an icon to the layout:

c. Click the Select Icon button

d. Select an icon file from the Open Icon window

e. ClickOpen.

4. ClickOK.

The name of the new layout is displayed in the Status bar of the main window.
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Managing Layout Shortcuts

How to Create a Layout Shortcut

To create a layout shortcut, proceed as follows:

5. Click the Layout tab on the left screen border to open the Layout pane.

6. Click the Add Shortcut button from the Layout pane.

The Load Layout window opens:

7. Select a layout from the list.
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8. Click Load.

The Layout is loaded and its shortcut is available from the Layout pane:

Layout Shortcut Contextual Menu

A contextual menu is displayed when you right-click a Layout shortcut button in the Layout panel.

The following commands are available from the contextual menu.

Rename

Renames the layout shortcut in the Layout pane but does not rename the corresponding layout.

Delete

Deletes the layout shortcut but does not delete the corresponding layout.

Properties

Opens the Properties window from which you can

• change the name and/or the icon of the layout and the layout shortcut,

• publish the layout to selected users or groups of users,

• freeze / unfreeze the associated workspace.
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How to Open an Existing Layout

To open an existing layout from its shortcut,

1. Click the Layout tab on the left screen border to open the Layout pane.

2. Click the shortcut button corresponding to the layout you want to load.

The different windows corresponding to the selected layout open.
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4. Plugins Management
Introduction

Predefined external web pages or ActiveX can be called from the IPDirector main window. This is done
through Plugin configuration.

Plugins which do not refer to a URL are defined in an XML file stored locally on the IPDirector
workstation, as described in the next section. They are available from the Plugins option of the main
IPDirector Menu bar.

Plugins involving a URL are configured from the Remote Installer. In this case, the XML file is not taken
into account. They can be accessed either from the Plugins option of the main IPDirector Menu bar or
from a dedicated Plugin button on the Application bar. Refer to the Remote Installer Technical
Reference.

The called pages display in windows like other IPDirector modules and the windows can be saved in
layout.

The plugin works with IPDirector process, so it uses graphical resources. To use Xplore and
IPDirector, it is highly recommended to start Xplore from outside IPDirector rather than from
the plugin interface.

Plugins Configuration in XML Files

Plugin Definition

The non-URL plugin definition is described in an XML file stored locally on the IPDirector workstation in
one of the following directories:

• %appdata%\EVS Broadcast Equipment\IP-Director\PluginsConfiguration

• %programfiles%\EVS Broadcast Equipment\IP-Director\PluginsConfiguration (for 32bits platforms)

• %programfiles(x86)%\EVS Broadcast Equipment\IP-Director\PluginsConfiguration (for 64bits
platforms)

The XML file must contain:

• the plugin name (as it will be diplayed in the Plugins menu)

• the ProgID or ClassID of the ActiveX (if ActiveX)

• the maximum and minimum size of the plugin window

• the default size of the plugin window
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• the reference to the Plugin icon file which will be displayed in the Pluginsmenu. Icons files are
located in EVS Broadcast Equipment\IP-Director\PluginsConfiguration\IconSet.

• (opt) the group visibility:

◦ No group defined: visibility for all the groups

◦ Groups defined: visibility limited to defined groups

A plugin can be available from a dedicated labeled button from the Application bar rather than
from the Pluginsmenu. To do so, the plugin name, such as Xplore, must be written as the label
tag for button in the XML file.

The structure of the XML file is described in the plugin.xsd file that can be found in the same directory as
the XML file (Program Files (x86)\EVS Broadcast Equipment\IP-Director\PluginsConfiguration).

Example of a Plugins XML File
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User Rights

The Allow Using Plugins user right must have been selected for the user to have the Plugins button
displayed in the Application bar of the IPDirector main window.
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5. Metadata Profiles Management

5.1. About Metadata, Profiles, User Fields
Metadata is customer-defined data used to describe or classify A/V material.

A metadata profile is made of a set of user fields which are managed together.

A metadata profile can be associated with various items such as clips, playlists, timelines and edits and,
then, metadata values can be attributed to the item by entering specific values in the user fields.

Metadata user fields are created and associated into metadata profiles from the Metadata Profiles
Management window in IPDirector, or they can be imported into the system in the form of an .XML file.

The metadata from the metadata profile can be displayed as columns in the Elements grid of the
Database Explorer, so searches can be performed on the user fields values.

The profiles defined for logsheets slightly differ from profiles defined for other media items as two
profiles can be associated with a logsheet:

• a profile for the logsheet metadata

• a profile for the log metadata.

These two profiles are selected from the list of metadata profiles.

Depending on the user rights defined, the users will be allowed to manage profiles, or to choose a profile
at creation or edit of an item, or they will be forced to use the default profile imposed by the
administrator.

For more information on how to use the metadata in the IPDirector applications, refer to:

• the Control Panel user manual ("Metadata Tab")

• the Control Panel user manual ("Save Clip Window")

• the Playlist Panel user manual

• the Ingest Scheduler user manual

• the IPLogger user manual ("Step 1: Defining the Logsheet Characteristics")

• the IPLogger user manual ("Create a New Log Window")
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5.2. Metadata Profiles Management
Window

Accessing the Metadata Profiles Management Window

To access the Metadata Profiles Management window,

1. ClickMetadata on the IPDirector Menu bar.

2. SelectManage Profiles from the menu.

This window can only be accessed if you have the appropriate user right.

The window contains two tabs:

• The Profiles tab that lists all the created metadata profiles.

• The Logsheet Profiles tab that lists the profiles specifically dedicated to logsheets.

A File menu and an Edit menu are available and allow actions such as creation, edit, deletion, import, and
export of profiles.
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Profiles Tab

The Profiles tab gives the list of available profiles.

Creation of profiles and definition of the user fields to be present in each profile will be done from the
Profiles tab.

These profiles are intended to be attributed to clips, playlists, timelines or edits.

A search operation can be performed either on the profile name, on the profile description or on both by
entering a few letters in the Search field.

A profile can be set as the default profile from the Default column:

• This profile will be the default profile displayed at item creation for users who do not have the right to
choose a metadata profile.

• For users who have the right to choose a metadata profile, this profile will be displayed the first time
each user create an item. Afterwards, each user who will have chosen another metadata profile at
item creation will get this new current profile at creation of the next item.
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Logsheet Profiles Tab

This area manages the list of available logsheet profiles which can be associated with a logsheet.

A logsheet profile consists of the selection of two profiles available from the Profiles tab:

• a profile for logsheet user fields

• a profile for log metadata.

A search operation can be performed either on the logsheet profile name, on the logsheet profile
description or on both by entering a few letters in the Search field.

A logsheet profile can be set as the default logsheet profile from the Default column:

• The selected logsheet profile and its user fields will be applied by default to the new logsheets for
users who do not have the right to choose a metadata profile.

• For users who have the right to choose a metadata profile, this logsheet profile and its user fields will
be displayed the first time each user create a logsheet. Afterwards, each user who will have chosen
another metadata profile at logsheet creation will get this new current profile at creation of the next
logsheet.

5.3. Creating Profiles

5.3.1. Introduction
Creation of metadata profiles and definition of the user fields to be present in each profile will be done
from the Profiles tab.

A profile is a flat structure: there is no possibility to build trees with user fields under other user fields.
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When you create a new metadata profile, you will be able to choose existing user fields and/or to define
new user fields.

The user fields of each profile can then be displayed as columns in the Database Explorerr. Searches
could be performed on the metadata values. The name of the user field appears as heading of the
column in the Database Explorer.

A logsheet profile is created from the Logsheet Profiles tab. A profile is selected for logsheet user fields
and/or a profile is selected for log metadata.

5.3.2. How to Create a New Profile
To create a new profile,

1. In the Profiles tab, do one of the following:

◦ from the File Menu, select New

◦ right-click in the Profiles list and select New from the contextual menu.

The New Profile window opens. See section "New Profile Window" on page 47.

2. Enter a profile name.

3. (optional) Enter a description for the profile.

4. If the required user fields already exist, associate them to your profile by selecting them in the
Available User Fields area in one of the following ways:

◦ select the user field and then click the right arrow

◦ double-click the user field

◦ drag it onto the Selected User Fields area at the position where you want to drop it.

If you add a user field of type Predefined Text Values for which the I want to define specific
predefined values for my profile option had been selected at creation, you need to define
predefined values for the user field. See section "How to Create a User Field" on page 49.

5. If the required user fields do not already exist, you need to add new user field as described in section
"How to Create a User Field" on page 49.

All the added user fields are listed in the Selected User Fields area.

6. Re-order the user fields by drag-and drop operation in the way you want them to appear in the
metadata area related to the element.

7. Click Save.

The new profile is created and appears in the Profiles tab of the Metadata Profiles Management window.

5.3.3. New Profile Window
The Metadata Profiles Management window contains the areas highlighted on the screenshot below:
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General area (1)
From this area, you will define general information of the profile:

• the Name of the new profile

• a Description for the profile (optional)

• Control Panel Display field: (optional) you can select a user field for which the metadata value would
be displayed on the Control Panel when the corresponding metadata profile has been selected. Up
to 50 characters can be displayed.

Available User Fields area (2)
It gives the list of the available user fields, and their corresponding type, which can be selected and
associated with a profile.

It allows users to filter the list through the Filter field or to delete one or several user field(s) by clicking
the Delete Selected User Field button.
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Selected User Fields area (3)
It gives the list of the user fields selected for the new profile and their corresponding type. This list is
empty when creating a new profile.

It allows users to create a new user field and add it to the profile by clicking the Add New User Field
button.

5.3.4. How to Create a User Field
To create a new user field,

1. In the New Profile window, click the Add New User Field button. The Add New User Field window
opens.

2. Fill in the Name field.

3. (optional) Enter a description in the Description field

4. Choose a type for the new user field from the Type drop-down list.

Possible values are: Text, Predefined Text values,Memo, TC, Date, Number.

See section "User Field Types and Display" on page 51.

5. Define the list of values for the predefined lists.

In case you have selected the Predefined Text Values type, the Add New User Field window is
expanded to display more options.

You will then have to add the predefined values that will appear in a drop-down list in the user field,
in such a way that the user will have to associate one of these values to a media item.
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a. Select one of the following options:

I want to use the common set of predefined values: the set of values that you will define for
that user field will be kept each time you add this user field in another profile.

It is recommended to use the common set of predefined values when

• The metadata will be used in only one profile, or

• The metadata will be used in several profiles but the predefined values will always be the same.

I want to define specific predefined values for my profile: the set of values that you will define
for that user field will not be kept if you add this user field in another profile; you will have to
create a new set of values for each profile where you use that user field.

It is recommended to define specific predefined values when

• The metadata will be used in several profiles and the predefined values will differ depending on
the profile.

b. Define a predefined value that will be provided in a drop-down list from the user field:

1. Enter a value in the field above the list of values.
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2. Click Add.

The value is listed in the Value list.

c. Repeat step b. for all the values to be defined.

d. Define whether the users will be able to leave the user field empty:

• Tick the Allow empty value check box to allow the display and use of empty values in the list of
predefined values for this user field.

• Clear the Allow empty value check box to forbid the display, and use, of empty values in the
list of predefined values for this user field.

6. Click the Save button.

All the user fields selected and/or added to the new profile are listed in the Selected User Fields area of
the New Profile window.

5.3.5. User Field Types and Display
All the types of user fields are shown hereafter with the way they appear in the metadata area of the
media items.

Text (64 characters)

The Text user field type will appear on screen as a free-text field:

In such a field, you will be able to enter free text or a link to a website or to a file.

Memo (text, unlimited number of characters)

TheMemo user field type will appear on screen as a free-text field:

In such a field, you will be able to enter free text or a link to a website or to a file.
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Hyperlinks in Text and Memo User Fields

In a Text user field, or in aMemo user field, you will be able to enter a link to a website or to a file. This
link will appear as a hyperlink in the Elements grid.

TC (for Timecode)

The TC user field type will appear on screen as a timecode field:

Date

The Date user field type will appear on screen as a Date field with a Calendar button giving access to a
calendar to select a date:

Number

The Number user field type will appear on screen as a field with up and down arrows to increase or
decrease the value.

Predefined Text Values (64 characters)

The Predefined Text values user field type will appear on screen as a drop-down list displaying all the
values which have been created for the user field:

See section "How to Create a User Field" on page 49 to know how to define the list of values.
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5.3.6. How to Create a Logsheet Profile
To create a logsheet profile,

1. In the Logsheet Profiles tab, do one of the following:

◦ in the File Menu, select New, or

◦ right-click the logsheet profile list and select New from the contextual menu.

A new line appears in the list. It is highlighted and the cursor is placed in the Name field to allow the
user to enter a name for the logsheet profile.

2. Enter a profile name.

3. (optional) Enter a description for the profile.

4. Click at the right of the cell in the Profile for Logsheet User Fields column.

An arrow appears.

5. Click the arrow to display the list of available profiles.

6. Select a profile to be used as Logsheet User Fields profile.

7. Click at the right of the cell in the Profile for Log Metadata column.

An arrow appears.
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8. Click the arrow to display the list of available profiles.

9. Select a profile to be used for the Log Metadata.

5.4. Editing Profile and User Fields

Possible Actions

Once a profile has been created, it is still possible to edit it. The profile name or the profile description
can be modified. User fields can be added, removed, updated or re-ordered by a drag-and drop
operation.

Limitations

Adding a User Field to an Existing Profile

If a user field is added to an existing profile, it is added to the corresponding metadata profile associated
with existing elements and the user field will have an empty value.

Removing a User Field from an Existing Profile

If some A/V elements already reference the profile, a warning message is displayed.

Answering Yeswill remove the fields from the profile and all the previously entered data for that profile
will be cleared from the user fields table.

Editing a User Field of Type "Predefined Text Values"

• If the Allow empty value option was selected and the user field has already been used in this profile
with an empty value, it is not allowed to clear the Allow empty value check box.

• If the user field has a common set of predefined values and you add a value, the new value will be
added to the edited profile and to all the profiles containing this user field.

• If the user field has a specific set of predefined values and you add a value, the new value will only be
added to the edited profile.
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How to Edit a Profile
To edit a profile,

1. In the Profiles tab, select the profile you want to edit.

2. Do one of the following:

◦ Select Edit from the File menu.

◦ Right-click the profile line and select Edit from the contextual menu.

The Edit Profile window, similar to the Add New Profile window, opens.

3. Make the desired changes: add, remove, move user fields or rename the profile.

How to Edit a User Field
To edit a user field (name, description or type):

1. In the Selected User Fields area of the New Profile window, click the Edit button to the right of the
user field you want to edit.

The Edit a User Field window, similar to the Add New User Field window, opens.

2. Make the desired change (name, description or type).

3. Click Save.

5.5. Deleting an Available User Field

Rules and Constraints for the Deletion of a User Field

• If the user field is not present in another profile and if no element references the user field, the user
field is deleted.

• If the user field is present in a bin rule, a warning message is displayed.

• If some A/V elements already reference the user field, or

if the user field is present in the Selected User Fields list of another profile, even if it is not
referenced,

then, a warning message is displayed.

Answering Yeswill remove the fields from the profile and all the previously entered data for that
profile will be cleared from the user fields table.

How to Delete an Available User Field
The user can delete a user field from the list of available user fields either from the New Profile window
or from the Edit Profile window.
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1. In the Available User Fields list, select the user field to be deleted.

2. Click the Delete selected User Field button.

The user field is deleted from the Available User Fields list and will no longer be available.

5.6. Other Possible Actions on Metadata
Profiles and User Fields

How to Copy a Profile
1. Select the profile to be copied.

2. Do one of the following:

◦ Select Copy from the Edit menu

◦ Right-click the profile and select Copy from the contextual menu.

3. Enter a name for the new profile in the Enter New Profile Name window.

4. ClickOK.

The new profile is created with the same description and user fields as the original one.

How to Import a Profile
1. Select the profile or the logsheet profile to import.

2. Select Import Profiles from the File menu.

3. Select the .XML file that contains the metadata profile to import from the Import Profiles window.

4. ClickOpen.

When a profile is imported, the setting for the Allow empty value option is not kept in the
XML file. Therefore, all Predefined Text values-type user fields will allow empty values.

How to Export a Profile
1. Select the profile or the logsheet profile to export.

2. Select Export Selected Profiles from the File menu.
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3. Select the folder where you will export the file in the Save in field of the Export Profile window and
type a file name for the profile to export in the File Name field.

4. Click Save.

When a profile is exported, the setting for the Allow empty value option is not kept in the
XML file. Therefore, all Predefined Text values-type user fields will allow empty values.

How to Export the Default Profile
1. Select the profile to export.

2. Select Export Current Profiles from the File menu.

3. Select the folder where you will export the file in the Save in field of the Export Profile window and
type a file name for the profile to export in the File Name field.

4. Click Save.

How to Delete a Profile

A profile can be deleted only if it is not associated with A/V items, nor to a logsheet profile.

1. Select the profile to be deleted.

2. Do one of the following:

◦ Select Delete from the Edit menu

◦ Right-click the profile and select Delete from the contextual menu.

A profile deleted permanently disappears from the list.

A profile marked as deleted appears in an italic format; it is no more accessible but it could nevertheless
be recovered later.

A profile marked as deleted can be recovered in one of the following ways:

• select the profile and then select Undelete from the Edit menu,

• right-click the profile and select Undelete from the contextual menu.

How to Delete a Logsheet Profile

A logsheet profile used in a logsheet that has at least one log cannot be deleted.

1. In the Logsheet Profiles tab, select the logsheet profile to be deleted.

2. Right-click the logsheet profile.

3. Select Delete from the contextual menu.
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The logsheet profile is deleted from the list.
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6. Keyword Management

6.1. Introduction

About Keywords

Keywords are an essential element to the IPDirector system, bridging the gap between the EVS video
servers and a conventional database by allowing the user to search for material using keywords which
relate to the media rather than searching by storage locations.

Keywords allow you to perform searches in any type of media items (logs, clip elements,...) in a unified
manner. Every user can thus be certain that the media and logs are indexed in a structured manner so as
to provide accurate search results.

IPDirector provides tools to add data to the database. It allows the addition of individual words,
importation of existing keyword grids of up to 300 keywords, or the importation of 3rd party text data
into the IPDirector database. Using keyword management tools it is possible to create and edit keyword
grids, keyword dictionaries and also to import and export keyword files between different IPDirector
installations. Keyword files made on an EVS video server are also importable.

Dictionaries allow you to manage all your keywords in a structured hierarchy. This hierarchy allows for
similar items to be grouped under headings that are collapsible and expandable.

The Cascading Grid is a tool designed to guide the users, especially the loggers and ingest operators,
among the amount of keywords and to ensure that they easily and quickly find the information.
Cascading grids are build in such a way that a main set of keywords is displayed and, based on the
selected keyword, another set is proposed to the users at a second level.

The management of the different keyword tools is described in sections "Keyword List Tool" on page 61,
"Keyword Grid Tool" on page 67 and "Dictionary Tool" on page 76.

The assignment of keywords to the various media types is described in the corresponding chapters of
the IPDirector manual.

The Merge Keyword plugin is available from the Remote Installer to allow you to correct mistakes in
keywords and to merge different variants of the same keyword.
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Opening the Keyword Tools
The four keyword tools can be accessed from the Keywords menu of the main Application bar.

You may choose to open each of them individually or to display several tools (Keyword List, Keyword
Grid and Dictionary) next to each other.

The View All option will show three windows at once, either vertically or horizontally.

Keyword Types

A distinction can be made between standard keywords and participant keywords. The participant
keywords can be used for the competitor or player names. The standard keywords can be used for
actions.

By default, the keywords are defined as standard keywords.

The participant keywords are differentiated by a little blue icon next to the keyword in the keyword
tools.
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6.2. Keyword List Tool

6.2.1. Description
The Keyword List tool provides the list of all the keywords stored in the IPDirector database. It also
shows a flat view of the keywords present in each keyword grid or dictionary. This tool allows to create,
delete or rename keywords. It can be used as a source for the selection of keywords to be inserted into
a keyword grid or a dictionary.

The Keyword List tool can be accessed from the Keywords menu of the Application bar.

The keywords list is kept in the IPDirector database which means that you work with shared data. All
actions undertaken on keywords will have repercussions on each IPDirector of the same XNet network.

6.2.2. Overview of the Keyword List Window
The Keyword List window contains the areas highlighted on the screenshot below:

Toolbar (1)
The Toolbar mainly provides a Filemenu with import and export functions, and a Refresh button.
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Keyword List File Menu

See section "Managing Keyword Lists" on page 63 for the options available from the Filemenu.

Keyword List Refresh Button

Several users can add keywords from different IPDirector workstations at the same time. In some cases,
the list is not refreshed automatically.

You can force the refresh by selecting the Refresh button on the menu bar of the Keyword List tool.

Keyword Creation Area (2)
This area is used to enter new keywords in the keyword list.

See section "Creating and Renaming Keywords" on page 64.

Two types of keywords can be defined: standard or participants.

See section "Keyword Types" on page 60.

Keywords List (3)
This area shows all the keywords from the database, a selected keyword grid or a selected dictionary.

You can change the way the keywords are displayed in the list by selecting one of the following options
in the Keyword Source field:

• All Database Keywords (Alphabetic Order)

• All Database Keywords (Insertion Order)

• Participant Keywords (Alphabetic Order)

• Participant Keywords (Insertion Order)

• KG: Keyword Grid Name: this option only displays keywords and participant keywords from a specific
keyword grid.

• KD: Dictionary Name: this option only displays keywords and participant keywords from a specific
dictionary.
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Participant keywords are identified with a icon next to them.

Keywords already included in a keyword tool are dimmed: .

6.2.3. Managing Keyword Lists

Available Commands

Keyword List File Menu

The following options are available from the File menu:

Import

Allows the import of a keyword list from a file (.txt format).

Undo last import

Cancels the last import of keywords.

Export

Allows exporting keywords into a file (.txt format).

Delete all unused keywords

Allows deleting all keywords that are not associated with any clip element or log. See section "Deleting
Keywords" on page 65.

Keyword Contextual Menu

The Keyword contextual menu is available when right-clicking a keyword in the Keywords List.

Rename Keyword

Used to rename a keyword. See section "Creating and Renaming Keywords" on page 64.

Delete Keyword

Used to delete a keyword. See section "Deleting Keywords" on page 65.
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Define as Participant Keyword

Used to change a standard keyword to a participant keyword. The option is only available from standard
keywords.

Reset Participant Keyword

Used to change a participant keyword to a standard keyword. The option is only available from
participant keywords.

In this case, a warning message will be displayed asking you to confirm the action.

Creating and Renaming Keywords

How to Create Keywords
To create a keyword in the database,

1. Open the Keyword List tool.

2. Type the keyword in the Keyword field:

3. If you want to define the keyword as a participant keyword, select the Participant box.

4. Click the Add button.

The keyword is added to the Keyword list and could later be used in a Keyword Grid or a Dictionary.

How to Rename Keywords
To rename a keyword,

1. In the selected keyword list, right-click the keyword to be renamed.

2. Select Rename Keyword from the contextual menu.

The keyword name is highlighted:

3. Enter the new name in the Keyword field.

4. Press ENTER to validate your modification.

The system does not accept several keywords having the same spelling (case non sensitive).

If a keyword with the same spelling is already present in the list, a pop-up displays an error
message and does not allow you to rename the keyword.
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Deleting Keywords

Possible Actions

You have two options to delete keywords

• Delete selected keywords from the keyword list

• Delete all the unused keywords

How to Delete Selected Keywords
To delete one or more selected keywords,

1. In the Keyword List tool, select the keyword(s) to delete from the list.

Use CTRL + CLICK or SHIFT + CLICK for a multiple selection.

2. Right-click and select Delete Keyword from the contextual menu.

A popup is displayed:

◦ If the keyword is not already used:

◦ If the keyword is already used:

3. Click YES to delete the keyword.

The keyword is deleted.

USER MANUAL

IPDirector General Functions | 6. Keyword Management | 65



How to Delete All Unused Keywords
To delete all unused keywords in the database,

1. Click the File button to display the File menu.

2. Select Delete All Unused Keywords

Importing and Exporting Keyword Lists

Rules for Keyword File Import

Before importing the keyword file, check the file structure and the settings to ensure that the following
conditions are met:

• Each keyword in the keyword file must be on its own line within the file.

• The general IPDirector settings in the Remote Installer must be set to manage 64 character
keywords. Otherwise, the keywords will be truncated to 12 characters if they are longer.

• The text file does not contain extra characters, such as #, %, @, TABS, etc.

How to Import Keywords
Once you have checked that all the conditions are met to perform a proper keyword file import (see
previous section), you can import a keyword file with multiple keywords in it, for instance a team line-up
or squad.

To import keywords,

1. In the Keyword List, click the File button to display the File menu.

2. Select Import

The Keyword Import window opens.

3. In this window, select the .txt file that contains the keywords to import.

The keywords are imported in the general keyword list. Once the keywords have been imported in the
general keyword list, you can add them to a keyword grid or a dictionary.

How to Cancel the Last Keyword Import
To cancel the last import of keywords,

1. Click the File button to display the File menu.

2. Select Undo Last Import.

How to Export Keywords
To export the currently listed keywords (from the selected keyword source) into an external file,
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1. In the Keyword List, click the File button to display the File menu.

2. Select Export from the File menu

The Keyword Export window opens.

3. In the window, select the folder in which to export the .txt file.

4. Type a name for the .txt file.

5. Click the Save button.

The keywords are saved in the given .txt file stored in the specified folder.

This file can be used to transport a set of keywords between two IPDirector workstations in different
locations and not on the same IPDirectorr network.

6.3. Keyword Grid Tool

6.3.1. Description
The Keyword Grid tool allows the users to build groups of up to 300 keywords. These keyword grids will
be a source to associate keywords with the various types of media. Subsequently, keywords can be
used to search the metadata and retrieve the required media.

The Keyword Grid tool can be accessed from the Keywords menu of the Application bar. Then, a specific
keyword grid is opened from the File > Open option.
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6.3.2. Overview of the Keyword Grid Window
The Keyword Grid window contains the areas highlighted on the screenshot below:

Keyword Grid name (1)

The title bar gives the name of the open keyword grid.

Toolbar (2)

The Toolbar provides functions to perform operations on keyword grids.

See section "Managing Keyword Grids" on page 69.

Keyword Grid area (3)

This area shows all the keywords from the selected keyword grid.
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6.3.3. Managing Keyword Grids

Available Commands

Toolbar Options

The toolbar is located on the top of the window and provides the following options and menus.

File

Displays a menu with various options for the management of keyword grids.

The following options are available from the File menu:

New

Opens the Create Keyword Grid window to define a new keyword grid and optional description.

Rename

Allows the users to rename an opened keyword grid.

Open

Allows the users to select an existing keyword grid.

Publish

Allows the users to publish the opened keyword grid to predefined user groups, or to individual users.

Delete

Allows the deletion of the keyword grid from the database.

Import

Allows the import of a keyword grid from a file in one of two ways depending on the selection:

• Import in a new keyword grid

• Import into the current keyword grid

Choosing Import into the current keyword gridwill replace all the keywords in the current keyword
grid.

The file used to import a keyword grid must be a text file with a .xml or .kwd extension.

A line of text must have the following format:

Position = keyword

where the position is the location of the keyword on the grid.

Only one keyword per line of text should be used
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Example:

1 = Jones

2 = Touchdown

3 = Pass

Export

Opens a window to allow a file to be created with the currently selected keyword grid and to be stored
or exported to another database. This format is the same as for an EVS video server allowing the direct
import of the file to an EVS video server.

View

Displays a menu with various options regarding display.

The following options are available from the View menu:

Empty Position

Shows or hides the empty keywords cells.

Description

Shows the keyword grid description.

Keyword Numbers

Shows the index number of each keyword in a grid.

Edit

Clicking the Edit button displays the Editing area and enables the Edit mode for the management of
keywords in the keyword grid.

Editing Buttons

The table below describes the editing buttons.

Menu Item Description

Opens the New Keyword Grid window to create a new keyword grid.

Opens a keyword grid.

Inserts a page in the open grid.
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Menu Item Description

Appends a page at the end of the open grid.

Opens the Rename Page window to rename the selected page of the open keyword grid.

Deletes the selected page of the open keyword grid.

Clears a page, i.e. removes keywords from the selected page of the open keyword grid.

If the width of the keyword grid window has been changed, the above mentioned buttons may
not appear as visible. At this time, the user must select the arrow on the right of the Editing
Toolbar to display all the hidden icons.

Keyword Grid Layout Field

At any moment, you can change the layout of your keyword grid by selecting a predefined layout or a
custom one using the Customize option. This can be done from the Layout field in the Edit toolbar.

Clear Selection

This option is only available in Edit mode when a keyword is selected.

It is used to clear a selection of keywords.

Apply

This button is used when keywords are assigned to a media item from the Database Explorer. See
section "Assigning a Keyword from a Keyword Tool" on page 90.

Keyword Contextual Menu

The Keyword contextual menu is available when right-clicking a keyword in the Keywords Grid.

The following commands are available from the Keyword contextual menu:

Cut

Cuts the selected keyword.

Copy

Copies the selected keyword.
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Paste

Pastes the keyword which has just been cut or copied.

Clear Selected Position

Clears the selected keyword from the keyword grid.

Define as Participant Keyword

Used to change a standard keyword to a participant keyword. The option is only available from standard
keywords.

Reset Participant Keyword

Used to change a participant keyword to a standard keyword. The option is only available from
participant keywords.

In this case, a warning message will be displayed asking you to confirm the action.

Change Color

Used to change to foreground and/or background color of a keyword grid cell or of a keyword from a
dictionary. See section "Setting the Keyword Colors" on page 75.

Reset Color

Used to reset the foreground and/or background color of a keyword grid cell or of a keyword from a
dictionary. See section "Setting the Keyword Colors" on page 75.

Creating a Keyword Grid
To create a new keyword grid,

1. Open the Keyword Grid tool.

2. Select New from the File menu.

The New Keyword Grid window opens:

3. Type a name for the keyword grid in the Name field, and a description in the Description field, if
required.
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4. In the three following fields, specify the number of pages, rows in a page and columns in a page that
the keyword grid should contain.

5. ClickOK.

The empty keyword grid is created with the parameters specified. It opens automatically in Edit
mode.

Once the keyword grid is created, it becomes available in the Keyword List tool, from the Keyword
Source field, with "KG" in front of the keyword grid name.

Adding Keywords to a Keyword Grid

How to Add Keywords to a Keyword Grid from a Keyword List
To add keywords from a keyword list to a keyword grid,

1. Open the Keyword List and the Keyword Grid tools next to each other on your workspace:
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The Keyword List displays the keywords that have been entered in the database.

2. Select the Edit command in the toolbar of the Keyword Grid.

3. In the Keywords list, select the keywords to be added to the keyword grid. Click CTRL+CLICK or
SHIFT+CLICK for a multiple selection.

4. Drag the selected keywords in the first cell of the keyword grid where you want to copy the
keywords.

The keywords are added to the keyword grid.

The keywords added to the keyword grid have then a lighter foreground in the Keyword List.
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How to Add Keywords to a Keyword Grid from a Dictionary Branch
A part of a Dictionary tree can be used to populate a keyword grid.

1. Open the keyword grid you want to edit.

2. Open the dictionary containing the keywords. See section "Dictionary Tool" on page 76 for more
information.

3. Select the Edit command in the menu bar of both windows, so the buttons are highlighted.

4. In the dictionary, select the keywords you want to copy.

5. Drag these elements to the keyword grid.

All the elements of this branch are added to the keyword grid.

Setting the Keyword Colors

Context of Use

If you want to highlight some frequently used keywords or organize them visually in groups in a grid, you
can assign a background and/or foreground color to keyword cells of a keyword grid.

A background and/or foreground color can also be set for keywords from a dictionary. This will be
reflected in the related cascading grid.

How to Set the Keyword Colors
To set or modify the foreground and/or the background color of a keyword,

1. Open the keyword grid or the dictionary.

2. Select the Edit command in the menu bar, so the button is highlighted.

3. Right-click the keyword you want to edit.

4. Select Change Color from the contextual menu.

The Keyword Colors window opens:

5. To apply a foreground color,

a. Click the Define Foreground button.
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b. Select the color you want to apply from the palette.

c. ClickOK.

The sample field in the Keyword Colors window shows you an example of your selection:

6. To apply a background color,

a. Click Define Background button.

b. Select the color you want to apply from the palette.

c. ClickOK.

The sample field in the Keyword Colors window shows you an example of your selection:

7. Click the Close button.

The selected keyword displays your color selection:

• in the cell of a keyword grid, when set from a keyword grid:

• next to the keyword in a dictionary, when set from a dictionary:

• in the cell of a cascading grid, when set from the related dictionary:

To reset the Foreground or Background color, select Reset Color from the contextual menu.

6.4. Dictionary Tool

6.4.1. Description
The Dictionary tool allows the users to organize groups of keywords according to a tree structure. These
dictionaries will be a source to associate keywords with the various types of media. Subsequently
keywords can be used to search the metadata and retrieve required media.

The Dictionary tool can be accessed from the Keywords menu of the Application bar. Then, a specific
dictionary is opened from the File > Open option.
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6.4.2. Overview of the Dictionary Window
The Dictionary window contains the areas highlighted on the screenshot below:

Dictionary name (1)

The title bar gives the name of the open dictionary.

Toolbar (2)

The Toolbar provides functions for performing operations on dictionaries.

See section "Managing Keyword Dictionaries" on page 78.

Keyword Creation area (3)

This area is used to enter new or existing keywords in the dictionary.
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Keywords tree (4)

This area shows all the keywords from the selected dictionary.

6.4.3. Managing Keyword Dictionaries

Available Commands

Toolbar Options

The toolbar is located on the top of the window and provides the following options and menus.

File

Displays a menu with various options for the management of keyword dictionaries.

The following options are available from the File menu:

New

Opens the Create a New Dictionary window to define a new dictionary.

Rename

Allows the users to rename an opened dictionary.

Open

Allows the users to select an existing dictionary.

Publish

Allows the users to publish the opened dictionary to predefined user groups, or to individual users.

Delete

Allows the deletion of the dictionary from the database.

Import

Allows the import of a dictionary from a file (.xml format).

Export

Allows the export of a dictionary to a file (.xml format).

78 | December 2024 | Issue 8.06.B



View

The following option is available from the View menu:

Show Description

Shows the dictionary description which has been entered at the dictionary creation. It can be edited
when the Edit mode is enabled from the Edit button.

Edit

Clicking the Edit button displays the Editing area.

The Edit button is highlighted when the Edit mode is enabled.

This mode allows the user to add keywords via the Keyword field or to perform other actions on
keywords.

Clear Selection

This option is only available in Edit mode.

It is used to clear a selection of keywords.

Apply

This button is used when keywords are assigned to a media item from the Database Explorer. See
section "Assigning a Keyword from a Keyword Tool" on page 90.

Keyword Contextual Menu

The Keyword contextual menu is available when right-clicking a keyword in the Dictionary.

The following commands are available from the Keyword contextual menu:

Rename keyword

Used to rename a keyword.

Define as Participant Keyword

Used to change a standard keyword to a participant keyword. The option is only available from standard
keywords.

Reset Participant Keyword

Used to change a participant keyword to a standard keyword. The option is only available from
participant keywords.

In this case, a warning message will be displayed asking you to confirm the action.
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Remove a Keyword from a Dictionary

Removes the selected keyword from the open dictionary.

Change Color

Used to change to foreground and/or background color of a keyword grid cell or of a keyword from a
dictionary. See section "Setting the Keyword Colors" on page 75.

Reset Color

Used to reset the foreground and/or background color of a keyword grid cell or of a keyword from a
dictionary. See section "Setting the Keyword Colors" on page 75.

Creating a Dictionary
To create a new dictionary,

1. In the Dictionary tool, select New from the File menu.

The Create a New Dictionary window opens:

2. Type a name for the dictionary in the Name field, and a description in the Description field, if
required.

The name you give to your new dictionary will take place as the root of your keywords tree.

3. ClickOK.

The empty dictionary is created.
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Once the dictionary is created, it becomes available in the keyword list, from the Keyword Source field,
with "KD" in front of the dictionary name.

Adding Keywords to a Dictionary

How to Add Keywords by Direct Entry in the Dictionary
To add keywords by direct entry into a dictionary,

1. Open a dictionary via the File > Openmenu of the Dictionary window.

2. Click the Edit button to enable the Edit mode .

The Keyword field and the Add button are displayed at the top of the Dictionary window.

3. Select the position of the new keyword in the dictionary:

◦ To insert a child keyword, first select the parent keyword in the dictionary before typing the
keyword name

◦ To insert a keyword at the root of the dictionary, no previous selection is required
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4. Start typing the keyword into the Keyword field.

A list of proposals is displayed as soon as you start to type and it is refined as you go on typing.

5. If the required keyword already exists, select the line by using the mouse or the key.

The keyword is automatically added to the dictionary.

6. If the required keyword does not exist yet, type the entire word into the Keyword field and click Add.

You can add as many keywords as you want in any of the tree branches.

All new keywords added in a dictionary are automatically inserted in the database. They
immediately appear in the Keyword list and can be used in keywords grids or other
dictionaries.

How to Add Keywords in a Dictionary from a Keyword List
To add existing keywords from the keyword list into a dictionary,

1. Open the Keyword List and Dictionary tools next to each other on your workspace.

2. If you select All Database Keywords in the Keyword List, you will see all the keywords that have
been entered in the database.

3. Open the dictionary you want to edit.

4. Click the Edit button of the dictionary to enable the Edit mode.

5. In the keyword list, select the keywords to be added to the dictionary. Click CTRL+CLICK or
SHIFT+CLICK for a multiple selection.
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6. Drag the selected keywords to the dictionary, at the required position.

a. To add a keyword at the first level (parent level), drag it between two keywords or parent
keywords, the drop location is indicated by a light blue line:

The keyword is added to the dictionary:
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b. To add a child keyword, drag it onto another keyword (a parent keyword or a keyword which will
become a parent keyword). This latter will be highlighted purple.

The keyword is added to the dictionary:

How to Add Keywords to a Dictionary from a Keyword Grid
It is possible to copy keywords from a keyword grid to a dictionary and vice-versa. To do so,

1. Open both Keyword Grid and Dictionary tools.

2. In both windows, click the Edit button to active the Edit mode.

3. Select the keyword(s) in the keyword grid. Click CTRL+CLICK or SHIFT+CLICK for a multiple
selection.

4. Drag them to the dictionary, at the required position.

a. To move it/them between two keywords or parent keywords, the drop location is indicated by a
light blue line.

b. To move it/them under a parent keyword or to move it/them under a keyword which will become
a parent keyword, the parent keyword must be highlighted purple.
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Moving Keywords within a Dictionary
To move keywords from one place to another in a dictionary,

1. Open the dictionary.

2. Click on the Edit button to enable the Edit mode .

3. Select the keywords you want to move.

4. Drag them to the new location.

◦ To move it under a parent keyword, this latter must be highlighted purple.

◦ To move it between two keywords or parent keywords, the drop location must be indicated by a
light blue line

6.5. Cascading Grid

6.5.1. Description
A cascading grid is built upon a dictionary. The difference lies in the fact that the tree structure of the
dictionary is converted into several levels of keywords sets in the cascading grid. The keywords content
cannot be edited from a cascading grid. This must be done from the related dictionary.

A cascading grid displays sets of keywords according to a waterfall effect. Clicking a keyword button
from the first set displays a second set of keywords related to the parent keyword. Then, clicking a
keyword button from the second set displays a third set of keywords related to the second keyword,
and so on.

These cascading grids will be a source to associate keywords with the various types of media.

The cascading grid is not automatically refreshed when the dictionary is edited.

The Cascading Grid tool can be accessed from the Keywords menu of the Application bar. Then, a
specific cascading grid is opened from the File > Open option.
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6.5.2. Overview of the Cascading Grid Window
The Cascading Grid window contains the areas highlighted on the screenshot below:

Cascading Grid name (1)
The title bar gives the name of the opened cascading grid.

Toolbar (2)
The toolbar provides functions for performing operations on cascading grids.

See section "Managing Cascading Grids" on page 87.

Cascading Grid area (3)
This area shows the keywords from the selected cascading grid.

3a: 1st set of keywords. The keywords from the first set are always displayed. They correspond to the
1st level of keywords in the related dictionary.
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3b: 2nd set of keywords. They are only displayed when a keyword is selected in the 1st set. They
correspond to child keywords of the keyword selected in the first set.

3c: 3rd set of keywords. They are only displayed when a keyword is selected in the 2nd set. They
correspond to child keywords of the keyword selected in the second set.

Keywords assigned to a media item are highlighted (light blue).

A background and/or foreground color can have been set for keywords from the related dictionary,
which will be reflected in the cascading grid. See section "Setting the Keyword Colors" on page 75.

6.5.3. Managing Cascading Grids

Toolbar Options

The toolbar is located on the top of the window and provides the following options and menus.

File

Displays a menu with a single option.

Open

Opens an existing cascading grid, based on a dictionary.

View

The following option is available from the View menu:

Keywords Numbers

Shows the index number of each keyword in a grid.

Apply

This button is used when keywords are assigned to a media item from the Database Explorer. See
section "Assigning a Keyword from a Keyword Tool" on page 90.

Toolbar Buttons

The Toolbar also provides the following buttons:
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Button Description

Open Dictionary button: opens the dictionary associated with the current cascading grid.

Cascading Grid Display buttons: Four buttons are available to choose the size of the
keyword buttons displayed in the cascading grid.

6.6. Assigning Keywords to Media

6.6.1. Introduction

Possible Ways of Assigning Keywords

Keywords can be assigned to media (clip, ingest, playlist, timeline, edit, log, clip digitized from VTR) at
creation time or, later on, by editing the media item.

This can be done in various ways.

• By direct entry:

You can start typing the keyword directly in the Keyword field of the Create [Media] window or the
Edit window and select a keyword proposed in the Autocomplete list.

See section "Assigning a Keyword by Direct Entry" on page 89.

A Keyword field is also available from the Clip Information tab of the Control Panel or and the
VTR Control Panel.

• By selection from a Keyword tool:

You can select keywords from a keyword grid, a dictionary or a cascading grid.

• By using the keyword number:

You can type the number associated with a keyword in an opened keyword grid or an open
cascading grid.

When the media item is edited from the Database Explorer, the easiest way is to work in
Assign mode with a Keyword tool. You can also right-click the item in the Elements grid and
select Edit or Edit/Rename to access the Edit window.
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Conditions for the Use of a Keyword

The assignment of a keyword to a media item will only be possible if the following conditions are met.

• The maximum number of keywords which can be assigned to the item has not already been reached.

• The keyword typed in the Keyword field exists in the IPDirector database.

• An additional limitation exists for the use of cascading grids: It is not possible to select more than one
keyword per keywords level/set.

• When a Keyword tool is used, the Edit mode must be inactive (Edit button of the Keyword tool not
highlighted).

6.6.2. Assigning a Keyword by Direct Entry

How to Assign a Keyword to Media by Direct Entry
To assign a keyword to a media item by direct entry in the Keyword field,

1. Start typing a keyword in the Keyword field.

As soon as the users start typing in the Keyword field, the Autocomplete function provides a list of
matching keywords, standard and participant, beginning with the typed letters and existing in the
Keyword List of the IPDirector database. The list is refined as you go on typing.

The Add button next to a Keyword field becomes available when all the letters of a keyword
existing in the Keyword List of the IPDirector database have been typed in the Keyword field.

2. Select a line by using the mouse or the key.

3. Click Add or press ENTER.

The keyword is displayed in the list of keywords assigned to the item.
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How to Unassign Keywords
To remove a keyword assigned to the media item:

• click the X button next to the corresponding keyword.

To remove all the keywords assigned to the media item:

• click the Clear All button.

6.6.3. Assigning a Keyword from a Keyword
Tool

Displaying the Keyword Sources
To display one or several list(s) of keywords,

1. Select the keyword tool you want to work with from the Keywords menu of the main Application bar.

2. To open a specific dictionary, keyword grid or cascading grid,

a. select the File > Open option

The Open [Dictionary /Keyword Grid / Cascading Grid] from Database window opened.

b. select the required dictionary, keyword grid or cascading grid from the list.

You can open several windows with different dictionaries, keyword grids or cascading grids, if
needed.

3. When several keyword grids or cascading grids have been opened, make one of them active for
keyword selection in one of the following ways:

◦ Simply click the window

◦ Use the keyboard shortcut assigned to the window:

+ for the keyword grid or cascading grid open first

+ for the second one, and so on.

It is highly recommended not to use different Keywords tools to add or remove keywords to a
media item.
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Assigning Keywords to Media from a Keyword Grid
or Dictionary

How to Assign a Keyword from the Create Window or the Edit Window
To add a keyword from a keyword grid or a dictionary when a media item is being created or edited,

1. Open the relevant keyword grid or the relevant dictionary.

2. If you want to work with keyword numbers from the keyword grid, select View > Keyword Numbers

or click to view the numbers associated with each keyword.

3. Select the keywords you want to assign to the media in one of the following ways:

◦ click it in the keyword grid or in the dictionary.

◦ if the keyword numbers are displayed in the keyword grid, press the key number corresponding

to the requested keyword on the keypad and then press .

It is added to the Keywords area.

It is also highlighted in the keyword grid or dictionary .

How to Remove a Keyword
To remove a keyword, do one of the following actions:

• click the keyword in the keyword grid or dictionary

• click the X button next to the corresponding keyword in the Keywords areaof the Create [Media]
window or the Edit window.

• if the keyword numbers are displayed in the keyword grid, press the key number corresponding to

the requested keyword on the keypad and then press .

It is removed from the Keywords area and it is no more highlighted in the Keyword tool.
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To remove all the keywords:

• Click the Clear All button in the Keywords area.

How to Assign a Keyword in Assign Mode from the Database Explorer
To assign keywords to a media item in Assign mode from the Database Explorer,

1. Select an item in the Elements grid.

2. Click the Assign button. It becomes highlighted to indicate that the Assign mode is active.

3. Open a keyword grid or dictionary.

The keywords already assigned to the media item, if any, are highlighted as follows in the keyword

grid or in the dictionary .

4. Make sure that the Apply button of the Keyword tool is available

5. If you want to work with keyword numbers from the keyword grid, select View > Keyword Numbers

or click to view the numbers associated with each keyword.

6. Select the keywords you want to assign to the media in one of the following ways:

◦ click it in the keyword grid or in the dictionary.

◦ if the keyword numbers are displayed in the keyword grid, press the key number corresponding

to the requested keyword on the keypad and then press .

7. Click the Apply button.

Keywords are assigned to the item and appear in Keywords columns of the Database Explorer grid.

How to Remove a Keyword in Assign Mode from the Database Explorer
To remove a keyword,

1. Un-select it in one of the following ways:

◦ click it in the keyword grid or in the dictionary.

◦ if the keyword numbers are displayed in the keyword grid, press the key number corresponding

to the requested keyword on the keypad and then press .

2. Click the Apply button.
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Assigning Keywords to Media from a Cascading Grid

Introduction

A cascading grid displays sets of keywords according to a waterfall effect. The sub-sets of keywords
displayed will depend upon the keyword selected from the first set, the second set, and so on. It is not
possible to select more than one keyword per keywords level/set.

How to Assign a Keyword from the Create Window or the Edit Window
To add a keyword from a cascading grid when a media item is being created or when it is being created
or edited, and no keyword has been assigned yet,

1. Open the relevant cascading grid.

The cascading grid displays the first set of keywords.

2. If you want to work with keyword numbers from the cascading grid, select View > Keyword

Numbers or click to view the numbers associated with each keyword.

3. Select the parent keyword you want to assign to the media item in one of the following ways:

◦ click it in the cascading grid.

◦ if the keyword numbers are displayed in the cascading grid, press the key number corresponding

to the requested keyword on the keypad and then press .
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The parent keyword is added in the Keywords area and it is highlighted in the cascading grid.

The child keywords from the second set, if any, is displayed below the first set:

4. Select a keyword from the second set (click or keypad number).

The child keyword is displayed in the Keywords area and it is highlighted in the cascading grid.

The child keywords from the third set, if any, is displayed below the second set:
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5. Select a keyword from the third set (click or keypad number).

The child keyword is displayed in the Keywords area.

It is not possible to select more than one keyword per keywords level/set.

6. To remove a keyword, see the section below and the warning message.

7. ClickOK from the the Create [Media] window or the Edit window or click Update Clip in the Control
Panel to save the item.

How to Remove Selected Keywords
To remove a keyword and its child keywords, do one of the following actions:

• click the keyword in the cascading grid

• if the keyword numbers are displayed in the cascading grid, press the key number corresponding to

the requested keyword on the keypad and then press .

This automatically un-selects the keyword and its selected child keyword and collapses the cascading
grid to the level under the remaining selected keyword.

The same keywords are removed from the Keywords area of the as well.

Example: Clicking Brazil removes Brazil and Dida(1), and displays the sub-set of keywords related to
Teams.

Clicking the X button next to a selected keyword in the Keywords area of the media item leads
to a different result:

• the keyword is removed from the cascading grid, the cascading grid is collapsed and,
therefore, does not display its child keywords anymore.

• the keyword is removed from the Keywords area BUT its child keyword is not removed. In
the follwing example, clicking Brazil does not remove its child keyword Dida(1) from the
keywords area:
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To remove all the keywords, do one of the following actions:

• Click the Clear All button in the Keywords area.

• Click the highlighted parent keyword in the cascading grid.

How to Assign a Keyword in Assign Mode from the Database Explorer
This procedure describes the case when no keyword has been assigned to the media item yet.

To assign keywords to a media item in Assign mode from the Database Explorer,

1. Select an item in the Elements grid.

2. Click the Assign button. It becomes highlighted to indicate that the Assign mode is active.

3. Open the relevant cascading grid.

The cascading grid displays the first set of keywords.

4. If you want to work with keyword numbers from the cascading grid, select View > Keyword

Numbers or click to view the numbers associated with each keyword.

5. Select the parent keyword you want to assign to the media item in one of the following ways:

◦ click it in the cascading grid.

◦ if the keyword numbers are displayed in the cascading grid, press the key number corresponding

to the requested keyword on the keypad and then press .

The keyword is highlighted in the cascading grid. The child keywords from the second set, if any, is
displayed below the first set.

6. (optional) Select a keyword from the second set (click or keypad number).

It is highlighted in the cascading grid. The child keywords from the third set, if any, is displayed
below the second set.

7. (optional) Select a keyword from the third set (click or keypad number).

It is highlighted in the cascading grid. The set of child keywords from the fourth set, if any, is
displayed below the third set.

8. Click the Apply button.

Keywords are assigned to the item and appear in Keywords columns of the Database Explorer grid.
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How to Remove a Keyword in Assign Mode
To remove a keyword,

1. Select an item in the Elements grid.

2. Click the Assign button. It becomes highlighted to indicate that the Assign mode is active.

3. Open the relevant cascading grid.

All of the keywords already assigned to the media item from the current cascading grid are
highlighted in the cascading grid (light blue).

4. Un-select the keyword in one of the following ways:

◦ click it in the cascading grid.

◦ if the keyword numbers are displayed in the cascading grid, press the key number corresponding

to the requested keyword on the keypad and then press .

This automatically un-selects the keyword and its selected child keyword and collapses the
cascading grid to the level under the remaining selected keyword.

5. Click the Apply button.

Rules for the Display of Keywords in Cascading Grids

It is highly recommended not to use different Keywords tools to add/remove keywords
to/from a media item.
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Display of Keywords in an Cascading Grid

In case a media item has been assigned keywords only from a cascading grid and, later on, is being
editedor is loaded on the Control Panel, its associated keywords are highlighted in the cascading grid:

Rules for the Display of Keywords of a Media Item

Specific rules exist for the display of keywords in the Cascading Grid tool.

In case a media item has been assigned several keywords from different keywords assignment
processes (Keywords tools, direct entry), some of them could not be displayed in a cascading grid when
the media item is selected in the Database Explorer or when it is being edited.

The order according to which keywords have been assigned is taken into account.
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The media item ... ...the keyword(s) highlighted
in the cascading grid...

has several keywords from level 1 is the first one encountered in
the list, and its child keywords
if any

has one keyword from level 1 (KW1) and level 2 (KW2) but the KW2
had been selected before KW1 and appears before KW1 in the
Keywords area

...the keyword from level 1 is
the only one displayed

Rules for the Display of Keywords when Edited

The media item ... ...the edition of
keywords
consists of...

...the keyword(s) highlighted
in the cascading grid...

has one keyword from level 1, level 2 and level 3 selecting
another
keyword from
level 2 from the
cascading grid

the new keyword from level 2
is added to media and the
previous keywords from levels
2 and 3 are removed.

The keyword from level 1 is
still selected.

has one keyword from level 1 (KW1) and level 2
(KW2) but the KW2 had been selected before KW1,
so KW2 appears before KW1 in the Keywords area
and only KW1 is highlighted in the cascading grid

selecting the
KW2 from the
cascading grid

both KW1 and KW2 are
highlighted in the cascading
grid and KW2 appears after
KW1 in the Keywords area

has one keyword from level 1 (KW1), level 2 (KW2)
and level 3 (KW3.1) but the KW3.1 had been selected
before KW2, so KW3.1 appears before KW2 in the
Keywords area and only KW1 and KW2 are displayed
in the cascading grid

clicking
another
keyword from
level 3 from the
cascading grid
(KW 3.2)

The cascading grid highlights
KW1 and KW2 and the newly
selected KW3.2.

The Keywords area displays
KW1, KW 3.1, KW2 and at the
end of the list KW 3.2.

has several keywords from level 1, so both are
displayed in the Keywords area but only the first one
assigned to the media item is highlighted in the
cascading grid

clicking the
keyword not
highlighted

the "first assigned" keyword is
removed from the Keywords
area and the cascading grid
and the second one is appears
on both sides.
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7. Settings

7.1. Introduction
This section only describes the general and global settings applicable to several modules. For more
information on specific settings, refer to dedicated chapters:

• Playlists settings: detailed in the Playlist Panel user manual.

• Control Panel settings: detailed in the Control Panel user manual.

• Ingest Scheduler settings: detailed in the Ingest Scheduler user manual.

• IPEdit settings: detailed in the IPEdit user manual.

• IPLogger settings: detailed in the IPLogger user manual.

• AB Roll Playlist settings: detailed in the AB Roll Playlist user manual.

Settings are available from the Tools menu of the IPDirector Menu bar.

7.2. General Settings

Display XT Structure
The Display XT Structure setting makes it possible to display the server structure in different ways in the
various applications where it is available, e.g. in the Database Explorer, in the contextual menu of the
Control Panel.

Three possible displays are available:

Display Option Description

Do not display All elements are listed without displaying the server structure or the page
and bank organization.

Display XTs but not
Page/Bank

All elements are listed on the level down the server they belong to.

Display XTs, Page and
Bank

All elements are listed on the level down of the page/bank they belong to.
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Display File Directory Structure
The Display File Directory Structure setting makes it possible to display the file structure in different
ways in the various applications where it is available.

Three possible displays are available:

Display Option Description

Do not display
Directory Structure

All elements are listed without displaying the file directory organization.

Display Root
Directory Only

All elements are listed on the level down the first level of the file directory
structure (e.g. on-line nearline or media files, in the Database Explorer).

Display Full
Directory Structure

All elements are listed on the level down of the file directory they belong to.

Date Format Recognized in Text Searches
Two formats are available:

• dd/mm/yyyy

• mm/dd/yyyy

Free Text Search Behavior
When the users perform a search based on free text, the system may behave in two different manners.

Selected Option Operation Performed

Classic Full Text A search performed with a search string will return the list of results
corresponding to this string. See also the Database Explorer user manual.

With Thesaurus A search performed with a search string will return the corresponding synonyms,
provided that they have been defined in the SQL thesaurus file.
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Select a Way to Copy/Move Elements
Depending on the selected option, the copy and move operations could be performed in different ways:

Selected Option Operations performed

Windows Style Drag = move

CTRL + drag = copy

Google Style Drag = copy

CTRL + drag = move

Confirmation Style When dragging a clip, displays a popup window and asks the operator for the
operation to perform.

Action Taken when the Channel is Set to IDLE
Determines what the EVS video server does when the channel is set to idle:

• the video output is left as it is (= no action)

• the video output is reset to black

Key Default Output Color
This setting defines the output color on the Key channel when the user loads a Fill clip that is not
associated with a Key clip. The available options are Black andWhite.

Language
The language setting makes it possible to change the interface language to the selected language.

Automatic Logoff
This setting defines the inactivity period of time after which the current user will be logged off.

It is available only if the Auto logoff parameter has been set to User in the User Manager.

Possible values: [0 (Auto log off disabled) - 720 minutes]

Default value: 0

Any change from the IPDirector General settings will only be taken into account at the next user
connection.

If the Auto log off parameter has been set at the workstation level from the Remote Installer,
any Auto Logoff setting at the user level will be overwritten by the Remote Installer setting.
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7.3. Auto-Name Settings

Auto-Name Settings for Clips

Clip Name – Format String

Description

This setting allows the users to define auto-naming rules for new clips.

If the Save Clip window or the New Ingest window are not displayed at clip or ingest creation, the format
string defined in the Clip Name - Format String field will be used to create the clip name or ingest name.

The various possible format string options are listed with a brief explanation under the field.

Double-clicking an item appends it to the format string.

User Fields

Up to 10 user fields can be used in the clip name, provided that a metadata profile has been assigned to
the clip and that the selected user field number exist in the profile and has got a value.

For example, if %UF3 is used in the clip format string, the value entered in the third user field from the
profile will be used in the clip name. This could be text, timecode or date.

Keywords

Up to 5 keywords can be used in the clip name, provided that the corresponding keyword number has
been assigned to the clip.

For example, if %K2 is used in the clip format string, the second keyword assigned to the clip will be
used in the clip name.

Ganged Recorders

When clips are created from ganged recorders, the value used for some of the format string options in
the clip names may be different between linked clips.

These format string options are:

%COUNTER, %XTNAME, %XTNB and %CAMLBL.

For example, clips saved from 3 ganged recorders of a server can be distinguished one from each other
by using the recorder name specific to each linked clip (%CAMLBL) in their name: CamA, CamB, CamC.

Feed Name

The feed name usually corresponds to the name of the recorder channel rrecording the train.

When a recorder channel is connected to an OUT port of a video router, itself associated with an IN port,
the name of the router IN port is used as feed name.
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Clip Name Prefix – Format String

If the Save Clip window or the New Ingest window are displayed at clip or ingest creation, the format
string defined in the Clip Name Prefix - Format String field is automatically added as a prefix to the clip
/ ingest name.

If this field is left empty, the users will have the possibility to enter a name of their choice at clip creation.

The possible format string options are the same as for the clip name.

Double-clicking an item appends it to the format string.

The use of format string options related to user fields or keywords or specific to ganged recorders is the
same for prefix as for auto-names.

Clip Name Counter Value

In the Clip Name and Clip Name Prefix format strings, the user has the possibility to insert an integer
counter (%COUNTER). This setting allows the user to view or edit the next value of the counter, e.g. if
001 is entered in the field, the next counter value will be 001.

The number of digits entered in the Clip Name Counter Value field defines the format of the number.
For example, if 0001 is entered in the field, the counter will have 4 digits and the counter will loop from
0001 to 9999.

Auto-Name Settings for Files

Clip File Name – Format String

This setting will be used to name the files created when backing up clips using XFile or XTAccess. If left
empty, the default XTAccess or XFile settings will be used.

The various possible format string options are listed and explained under the field.

Up to 10 user fields can be used in the clip file name. .

Double-clicking an item appends it to the format string.

Stream File Name – Format String

This setting will be used to automatically name files when streaming using XStream or XTAccess.

The various possible format string options are listed and explained in the field.

Up to 10 user fields can be used in the stream file name. .

Double-clicking an item appends it to the format string.

Playlist File Name – Format String

This setting will be used to automatically name files created from consolidated playlists using XFile3 or
XTAccess.
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The various possible format string options are listed and explained in the field.

Up to 10 user fields can be used in the playlist file name. .

Double-clicking an item appends it to the format string.

Image File Name – Format String

This setting will be used to name the files created when capturing an image in Control Panel.

The various possible format string options are listed and explained in the field.

Up to 10 user fields can be used in the image file name. .

Double-clicking an item appends it to the format string.

7.4. Clips Settings

General Settings for Clips

Open Save Clip Window

If this checkbox is NOT selected, the clip will be made instantly when a new clip is created in the Control
Panel. The clip is stored in the next available location on the page designated for IPDirector clips in the
EVS server setup (default setting is page 6).

If this checkbox is selected, the Save Clip window will open when a new clip is created in the Control
Panel. The user can enter data on the clip in this window. See the Control Panel user manual.

Guardbands

The guardbands correspond to A/V material which is added on both sides of the clip boundaries when
the clip is created. They are defined in seconds in this setting field.

When a new clip is saved, the guardbands will automatically be added before the IN point of the clip and
after the OUT point of the clip.

This setting is used to define the guardband duration.

Default Clip Duration

The Default Clip Duration setting makes it possible to create a new clip with the default duration
specified in this setting when only the IN point or the OUT point has been defined and the NEW CLIP
button is clicked.

Create Clips on all Synchronized Recorders

When this setting is selected, clips will automatically be created on all recorders ganged to the recorder
on which the user creates a clip.
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Create Sub Clips on all Ganged Clips

If this setting is selected, when a user creates a sub-clip from one linked clip, sub-clips will automatically
be created from all the clips linked to that clip.

If this setting is not checked, a sub-clip will only be created on the selected clip.

Trim all Ganged Clips

If this setting is selected, when a user trims a linked clip, all the clips linked to that clip will automatically
be trimmed.

If this setting is not checked, only the selected clip will be trimmed.

Automatic Clip Creation based on Logs

A clip can be automatically created when a log is dragged into a bin or when a bin has been selected at
logsheet creation.

The current setting is used to define the duration between the clip IN point and the log timecode (Pre
Mark) and the duration between the log timecode and the clip OUT point (Post Mark).

Default values for the Pre Mark and Post Mark are 10 sec.

For more information on the creation of automatic clips, refer to the Database Explorer user manual.

Default Clip ID Display Mode

The clip ID mode determines which ID will be used by default in the display: Name, UmID or VarID.

Default XT for Partial Clip Restore

Clips published from XFile are displayed in the Database Explorer, and can be loaded to a Control Panel.
When the user creates a sub-clip from a file stored in XFile3 and published, IPDirector will save the sub-
clip on the EVS server specified in the option.

Force Same VarID on Ganged Channels

If this setting is selected, when linked clips are created from ganged channels belonging to different
servers, the same VarID will be allocated to all the linked clips. This occurs would the VarID be
automatically attributed by the system, or would it be written in the VarID field of the Save Clip window
by the user.

This is not possible if the ganged channels belong to the same server, as the VarID must be unique on a
same server.

If this setting is cleared, the linked clips will receive different VarID.
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Clear Metadata

If this setting is selected, when an ingest or a clip is created, the metadata profile selected for the
previous ingest or clip is not displayed.

Take Settings

Default Effect Type

The Default Effect Type setting allows you to define the default transition effect to be applied when you
use the Take function to shift from the PGM to the PRV channel. You can specify different transition
effects for the audio track and the video track.

Default Effect Duration

The Default Effect Duration setting allows you to define the duration of the transition effect to be
applied on the audio track and the video track when you use the Take function.

7.5. GPI Settings

7.5.1. Introduction

Context of Use

The GPI is the General Purpose Interface device that can be connected to the EVS video server. It allows
the operator to send commands directly to the EVS server. These commands need to be reflected in the
IPDirector applications.

The GPI keys first need to be configured in the Setup Configuration on the EVS server. The configuration
on the EVS server includes the following settings:

• The definition of the application that will manage the GPI keys. In this case, it would be IPDirector.

• The port on which the serial connection between the EVS server and IPDirector is defined.

• The actions assigned to the GPI keys.
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The settings which are defined in IPDirector specify the following:

• Which signal will trigger which action on which player channel of the EVS server when a given key is
pressed on a GPI device connected to this EVS server. These are the INPUT GPIs. The actions
triggered by the GPI need to be reflected in the IPDirector user interface. The INPUT GPIs actions are
set up in parallel on the EVS server.

• Which signal will be transferred by IPDirector via a given GPI key to a third device. These are the
OUTPUT GPIs.

These settings are defined in the Input GPIs and Output GPIs categories available from the Tools >
Settingsmenu.

XT Server Selection
In both the Input GPIs and Output GPIs Settings window, the Select an XT Server field displays all the
high resolution EVS servers available on all the network groups.

When an EVS server is selected in the field, the GPI parameters of that server are displayed. This will
allow the user to modify these settings for the selected server.

1. Select here the server to be configured.

2. Click Apply to XT to send the GPI settings to the server.

Use of TTL GPIs
Each EVS video server has 4 Input GPIs, 4 Output GPIs and 4 TTL GPIs which can be configured either as
Input GPIs or as Output GPIs. Depending on the option selected in the How to Use the TTL GPIs field, 4
or 8 GPIs will be displayed.

In the Input GPIs Settings window, changing the TTL configuration will result in the following behaviors:

• from Input GPIs to Output GPIs: the configuration of the last 4 Input GPIs is cleared.

• from Output GPIs to Input GPIs: a message will warn the user that the TTL GPIs may be used as
Output GPIs in playlist, playlist macro command or timeline macro command.

In the Output GPIs Settings window, changing the TTL configuration will result in the following
behaviors:

• from Output GPIs to Input GPIs: the configuration of the last 4 Output GPIs is cleared.

• from Input GPIs to Output GPIs: a message will warn the user that the TTL GPIs may be used as Input
GPIs in playlist, playlist macro command or timeline macro command.

7.5.2. Input GPIs Settings

Purpose

The Input GPIs settings make it possible to configure the action to be triggered on a given player
channel of the EVS server when a given key is pressed on a GPI device connected to this EVS server.
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Up to eight GPI inputs can be used on an EVS server.

For each Input GPI, the following information needs to be defined:

• the action triggered by the GPI key on the EVS server.

• the player channel on which the action needs to be executed.

• the type of trigger signal sent by the GPI to EVS server.

In the IPDirector workspace, the triggered action will be reflected in the open applications to which the
player channel has been assigned.

Only the GPI keys set up to be managed by IPDirector on the EVS server can be configured in the Input
GPIs Settings window. The other ones will be dimmed.

The GPIs IN to be used in IPDirector need to be assigned to the IPDP protocol Setup
Configuration module of Multicam (SHIFT-F2, Page 4). Otherwise, they cannot be defined in
IPDirector.

Example

In the above example, when the GPI key 1 is pressed on the EVS server 03_XT3, this triggers a playback
action on the PGM1 player channel of the XT3 server. The trigger signal is a rising edge pulse. With the
configuration defined above, the IPDirector will show the triggered action in any application that displays
the given player channel.

The following sections describe in details the various fields in the Input GPI Settings window.

Action
The Action field allows the user to define the action that will be triggered by the GPI key. The value
defined in the Action field for a GPI key is also defined in the Setup Configuration of the EVS server.
Modifying the action type on IPDirector will update the corresponding value in the EVS server Setup
Configuration and vice versa.

The following actions can be defined on a GPI key:

Action Description

PLAY Initiates a play command at 100% on the selected channel.

PAUSE Initiates a pause command on the selected channel.

RECUE Initiates a jump to the IN point of the on air element on the selected channel.

If this is a playlist, the jump is performed to the IN point of the first clip of the playlist.

PREVIOUS Initiates a command to go to the previous clip of a playlist on the selected channel.
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Action Description

NEXT Initiates a command to go to the next clip of a playlist on the selected channel.

SKIP Initiates a command to skip the clip being played on the selected channel.

TALLY Activates or deactivates the on-air flag on the selected channel.

EXITASAP Initiates a command to exit the loop as soon as possible without playing the current
element until its end and jump to the selected element.

EXITOUT Initiates a command to exit the loop as soon as the OUT point of the current element is
reached and jump to the selected element.

NONE No value is defined.

Channel
The Channel field allows the user to define the channel on which the GPI key action will be executed.
The possible values are:

• a channel of the EVS server to which the GPI is physically linked

• the None value.

Trigger Mode
The Trigger Mode field allows the user to define the type of trigger signal that will be sent by the GPI to
the EVS server. The following trigger modes can be defined:

Trigger Mode Description

Pulse Rising Edge The trigger is done on a rising edge pulse.

Pulse Falling Edge The trigger is done on a falling edge pulse.

Level High The trigger is done when the level changes to high level.

Level Low The trigger is done when the level changes to low level.

None No trigger mode is defined.

If the operator selects None for one of the fields, all three fields are reset to None. It is
considered that the GPI is not used.
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Delay
It is possible to specify a delay between the time the GPI key is pressed and the time the action will be
carried out on the EVS server.

7.5.3. Output GPIs Settings

Purpose

The Output GPIs are signals that are sent from an EVS server under the control of the IPDirector.

The Output GPIs are used to send a signal from the IPDirector to a GPI key at a given timecode of a
playlist played on a given player channel. This signal can then be used to trigger a record action of the
playlist from the given timecode by a third device, for example a VTR. Up to eight Output GPI commands
can be defined.

The Output GPI keys will be unavailable in IPDirector if they have been assigned to the Remote panel via
the Replace function defined on the Remote panel itself.

For each Output GPI, the output mode, the pulse duration and the offset value can be set when defining
the Output GPI. For more detailed information, refer to the Playlist Panel user manual.

The Output GPIs Settings window is used to determine how to use the TTL GPIs and to specify the
Advance value.

Advance
In the Advance field, you can specify how many seconds ahead of the timecode (on which the GPI tag is
defined) the Output GPI signal should be sent by the IPDirector.

7.6. OSD Settings

Purpose

The On-Screen Display settings allow the users to select the category of information to be displayed for
each playout channel. This does not apply to recorder channels or software player.

Select an XT Server
In the Select an XT server drop-down list, first select the EVS server for which you want to specify OSD
settings.

OSD Mode

Global OSD Mode
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This mode applies to clips, growing clips, trains, playlist elements and timelines loaded on the channel.
Two options are available.

• Basic

With this option selected, only the following information is displayed on screen:

◦ the current on-air timecode of the clip, growing clip or train loaded on the channel

◦ the on-air timecode of the playlist element loaded on the channel

◦ the on-air timeline track position of the loaded timeline.

• Detailed

This is the default value.

It gives detailed information about the loaded media.

OSD Info in Playlist Mode

This mode applies to playlists loaded on the player channel. Two options are available.

• Display Transition Information

When this mode is chosen, select which type of information to display on screen as Remaining Time:
time until next break or time until next available element.

• Display Playlist Elements

The OSD mentions the following information:

◦ Channel Name

◦ Previous Clip Name

◦ Current Clip Name

◦ Current Clip Name + 1

◦ Current Clip Name + 2

When this mode is chosen, select which type of information to display on screen as Clip Information,
Current On-Air Timecode and Remaining Time.

Clip Information
This setting defines which clip information will be displayed on screen: the Clip Name/VarID or the LSM
ID.

Display Current On-Air Timecode
This setting defines whether the current on-air timecode will be displayed or not.

Display Remaining Time
This setting defines how the remaining time information will be displayed on screen with playlists:
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• remaining time until next break

• remaining time until next transition (only with the Display Playlist Elements mode)

• remaining time until next unavailable element

7.7. Image Capture Settings

Default Path for Captured Images
This setting allows the operators to specify a destination folder where the captured images will be
stored. This path is used for the Grab to File actions.

• If the administrator has specified a path applicable to all users in the User Manager, you will see the
path in this setting but you will not be able to modify it.

• If the administrator has defined a default path in the User Manager, you can modify the path if
requested.

• If the administrator has not defined a default path, you can specify a path for captures images in this
setting. The path needs to point to a shared folder on the Gigabit Ethernet network and should have
the following pattern: \\<MachineName>\<SharedFolder>\.

Capture Images on all Ganged Recorders or Linked Clips
When this option is selected, the image grabbed on a clip will also be grabbed:

• on all the recorder channels ganged to the recorder channel from which the image is grabbed.

• on all the clips linked to the clip on which the image is grabbed.
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8. Shortcut Definition

8.1. Introduction
For each application in IPDirector, keyboard shortcuts are available to make operation faster to the
operator.

The list of shortcuts can be accessed by clicking the Tools > Define Shortcuts option from the Menu
bar of the IPDirector main window.

Some shortcuts can be redefined to suit individual preferences. They are displayed in regular text. See
section "Editing a Shortcut" on page 115. Other ones cannot be modified. They appear as dimmed text.

This section only describes the General and Channel Management Shortcuts, which are valid for several
applications. For more information on shortcuts specific to an application, refer to:

• the Channel Explorer user manual

• the Control Panel user manual

• the Database Explorer user manual

• the IPLogger user manual

• the Playlist Panel user manual

• the Recorder Panel user manual

• the VTR Control Panel user manual

• the Ingest Scheduler user manual

• the AB Roll Playlist user manual
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8.2. Editing a Shortcut
To change a shortcut default value, proceed as follows:

1. Select the Tools > Define Shortcut option from the User Manager Menu bar to open the Define
Shortcuts window:

2. Select the application in which you want to modify a shortcut by clicking the corresponding button
on the left. The General and Channel Management buttons include general shortcuts or shortcuts
valid for several applications.

The shortcuts usable in the corresponding application are displayed on the right pane.

3. Select the line corresponding to the function from the shortcut list. Only the shortcuts displayed in
regular text can be modified.

4. Strike the key or key combination to be used as the new shortcut.

Different cases can occur:

◦ If the new shortcut key is still available, it is automatically modified in the Current Value column.

◦ If the new shortcut key is already used in the same category, an error message is displayed.
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◦ If the new shortcut key is already used in another category, an warning message is displayed.

- Select Swap to swap the two shortcuts between the 2 functions.

- Select Apply and Clear other shortcut to apply the shortcut to the selected function and to
clear the shortcut for the other function.

- Select Cancel to cancel the operation.

5. SelectOK to confirm the change.

The change in the shortcut definition is saved and available in the application.

To restore the default values defined by EVS for an application, use the Back to Default Values button
at the bottom right part of the window.

8.3. General Shortcuts
All the general shortcuts items that are available are shown in the table below with their default values.
These shortcuts are global to the system and not specific to one application. They can be modified and
saved by the user if desired.

Description Current Value (editable)

Help
+

Open Channel Explorer
+

Open Control Panel
+

Open Recorder Channel
+

Open Database Explorer
+

Open IPLogger
+
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Description Current Value (editable)

Open keyword grid
+

Open keyword list
+

Open dictionary
+

Open Ingest Scheduler
+

Open Video Display
+

Open Playlist Panel
+

Open Timeline Display
+  +

Open VTR Control Panel
+  +

Select next window
+

Select previous window
+  +

Close active window
+ 

Select Control Panel #1

Select Control Panel #2

Select Control Panel #3

Select Control Panel #4

Select Control Panel #5

Select Control Panel #6

Select Control Panel #7

Select Control Panel #8

Select Control Panel #9
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Description Current Value (editable)

Select Control Panel #10

Select keyword grid #1
+

Select keyword grid #2
+

Select keyword grid #3
+

Select keyword grid #4
+

Select keyword grid #5
+

Select keyword grid #6
+

Select keyword grid #7
+

Select keyword grid #8
+

Select keyword grid #9
+

Select keyword grid #10
+

Select next ABRoll Playlist
+

8.4. Channel Management Shortcuts
All the Channel Management shortcuts are shown in the table below with their default values. They can
be modified and saved by the user if desired.

Description Default Shortcut

Play

Var Play
+

Change the speed of the on-air element

Pause
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Description Default Shortcut

Fast Forward (FF)

Fast Reverse (FR)

E/E

Return

Snap to LIVE

TAKE
+

Activate / deactivate 2nd controller

Mark IN

Clear IN
+

Goto IN

Mark OUT

Clear OUT
+

Goto OUT

Turn OSD ON or OFF
+

Lock / unlock channel
+

Change LOOP mode

Send clip to default bin
+

Append clip to default playlist
+

Send to archive (default XFile)
+

Save clip
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Description Default Shortcut

Play backward

Play forward
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9. Remote Control Management

9.1. Introduction

Remote Devices

Remote devices can be connected to IPDirector to perform specific actions.

The MPlay Remote is a Multi-Playout controller used to control the playout of subjects on up to 4
channels.

The BEPlay Remote is used for media browsing, editing and playout.

Opening the Control Manager Window

The configuration of the remote devices is performed through the Remote Control Manager window. It
can be accessed from the IPDirector main window, via Tools > Remote Control Manager.

The window displayed several tabs, one for each remote device assigned to a serial communication port
in the Remote Installer.

9.2. MPlay Remote

9.2.1. Introduction
The MPlay Remote is a simple interface dedicated to control the playout of clips, playlists or graphics. It
is designed to simultaneously control up to 4 player channels. Its buttons can be configured to perform
classic transport functions.
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9.2.2. MPlay Remote Configuration

Overview of the Remote Control Manager Window
You can access the Remote Control Manager window from the IPDirector main window, via Tools >
Remote Control Manager.

Then, select the tab corresponding to the MPlay Remote device.

Several MPlay remote devices can be connected. In this case, as many tabs are displayed as they are
devices. One of the devices is defined as Master, the other ones as slaves. This is done in the Remote
Installer. Refer to the IPDirector-Remote Installer Technical Reference manual.

You will be able to control up to four player channels with one device.
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Assigning Player Channels

How to Assign Player Channels from the Channel Name Contextual
Menu
To assign a player channel to the MPlay Remote from the Channel Name field of the Remote Control
Manager window:

1. In the Remote Control Manager window, right-click one of the Channel Name field. A contextual
menu is displayed:

2. Select a player channel.

3. Repeat steps 1 and 2 for all the channels you want to associate to the buttons.

The channel name is displayed in the Channel Name field.

How to Assign Players to Function Buttons from the Channel Explorer
To assign player channels to the MPlay Remote by a drag-and-drop operation from the Channel
Explorer:

1. Open the Channel Explorer.

2. Select the player channel and drag it to one of the four Channel Name field areas in the Remote
Control Manager window.
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The player channel name is displayed in the Channel Name field:

3. If needed, repeat these two steps for the three other Channel Name field areas.

Linked Channels

In case the player channel is linked to another one in a PGM/PRV mode, Fill and Key mode, or gang mode
the linked channels are listed in the Linked Channels box.

• PGM/PRV Mode:

• Gang Mode:

• Fill and Key Mode:
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Customizing Transport Buttons
To associate a transport function with one of the buttons:

1. In the Remote Control Manager window, right-click one of the buttons in the box you have assigned
a player channel to.

The contextual menu with all the transport functions available is displayed:

2. Select the function you want to assign to the button.

The action name is displayed in the button for the selected channel:

If the Apply function to all channels checkbox had previously been selected, when the
operator assigns a function to a button, it is assigned to all the corresponding buttons for the
player channels controlled by the remote. This modification is done on the selected tab only,
not on all the connected MPlay devices.
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9.2.3. How to Use the MPlay Remote
When you have assigned a player channel to the MPlay Remote and configured its buttons, you can use
the device to perform actions on that channel.

1. Associate the same player channel to an IPDirector module such as Control Panel, Playlist Panel,
Database Explorer or AB Roll Playlist interface. You can assign it to several windows at the same
time.

2. On the MPlay Remote, press the button corresponding to the action you want to apply.

The action is performed on the panel or window which is active at the moment you press the button.

9.3. BEPlay Remote Device
The BEPlay is a remote controller for browsing, editing and playing content.

It can be configured to control selected channels and to send media to predefined destinations.

The first sections of the current chapter are dedicated to the configuration and the description of the
various buttons.

The next sections provide procedures on the main functionalities which can be performed with the
remote.

9.3.1. BEPlay Remote Configuration

Introduction
The configuration of the BEPlay remote device is performed from the Remote Control Manager window.

You can access this window from the IPDirector main window, via Tools > Remote Control Manager.
Then, select the tab corresponding to the BEPlay Remote device. There can only be one BEPlay remote
per IPDirector workstation.

The remote configuration is linked to the workstation, not to the user.
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Overview of the Remote Control Manager Window
The BEPlay tab of the Remote Control Manager window contains the areas highlighted on the
screenshot below:

Channels Assignment area (1)
This area is used to assign channels to the remote Function buttons

See section "Assigning Channels to Function Buttons" on page 141.

Choose a Layout area (2)
This area is used to select a remote layout.

See section "Selecting a Remote Layout" on page 128.

Monitoring area (3)
This area is used to monitor the connection status.

See section "Monitoring the Connection Status" on page 128.
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Destinations area (4)
This area is used to define target destinations where the media will be sent to when using the Send to
button.

The available destination targets are the following:

• the user's default bin, if any

• the default playlist, if any

• a default archive target

• any target destination visible on the GigE network that has been defined in the Remote Installer
(CleanEdit targets, Avid targets, Final Cut Pro targets, File targets, XT targets).

• any target that has been defined in the connected VIA Xsquare.

• the EVS servers for which the user has visibility right.

• the bins configured in IPDirector and for which the user has write access right.

Monitoring the Connection Status
The BEPlay remote device can be connected to the IPDirector workstation through a RS422 port or a
USB port. The RS422 port must be configured in the Remote Installer.

The monitoring of the connection status between the BEPlay remote device and the IPDirector
workstation is performed from the Monitoring area of the Remote Control Manager window.

You can access this window from the main window, via Tools > Remote Control Manager.

When a serial port has been configured, the Link: RS422 information is displayed in the Monitoring area
and the system looks for a BEPlay remote on the serial port.

If no serial port has been configured, the system tries to detect a BEPlay remote on a USB port. If one is
found, Connected – Link: USB is displayed in the Monitoring area.

Selecting a Remote Layout

Only clips, playlists and timelines can be controlled by the device.
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Two modes are defined for using the BEPlay. So, two layouts are available from the Choose a Layout
field. The two layouts differ in two action buttons.

• The Layout with Split : will be preferably used with playlist elements

• The Layout with Grab

Clicking on the View button opens the Layout Form window which corresponds to the selected layout
and shows the name of the functions assigned to each button. No action can be performed from this
window.

All the functions linked to each button are described in  "BEPlay Remote Buttons" on page 129.

9.3.2. BEPlay Remote Buttons
The BEPlay remote device has different kinds of buttons. The device has labels on some of them for the
usual use with IPDirector.
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Overview of the BEPlay Remote Buttons

Function buttons (1)
Function buttons are used to control a recorder or a player channel, or the Software Player. See section
"Function Buttons" on page 131.

Special buttons (2)
4 buttons can be used alone or together with other buttons to perform specific actions. See section
"Special Buttons" on page 137.
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Action buttons (3)
14 buttons can all be used to perform two different actions, depending on whether the SHIFT button is
pressed prior to the button. The actions vary according to the selected layout. See section "Action
Buttons" on page 132.

Wheel Mode buttons (4)
Three buttons can be combined to provide 5 modes according to which the wheel will be used. See
section "Wheel Mode Buttons" on page 139.

Wheel (5)
The wheel is used to navigate through the loaded media. It can be used according to 5 different modes.
See section "Wheel Mode Buttons" on page 139.

Function Buttons
Function buttons are used to control a recorder or a player channel, or the Software Player. The section
"Assigning Channels to Function Buttons" on page 141 describes the possible ways to assign channels
to function buttons.

The LED of a function button gives indication on the channel assignment.

The LED of a
Function button…

…when

is green a player channel or the Software Player is assigned to the button.

flashes green the player channel or the Software Player assigned to the button is being
controlled by the Remote.

is red a recorder channel is assigned to the button

flashes red the record train from the recorder channel assigned to the button is loaded on
the player controlled by the Remote.

is not turned on • no channel is assigned to the button, or

• the user cannot see the recorder channel or control the player channel, or

• the Software Player is not opened.
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Action Buttons

Use of Action Buttons

The BEPlay Remote has 14 buttons which can all be used to perform specific actions.Their action will
depend upon several conditions:

• the button is pressed before the Action button or not

• the Layout selected from the Remote Control Manager window

• the media type (clip, playlist, train, playlist element or timeline) loaded on the channel controlled by
the remote.

The following tables gives a brief description of the action of each Action button. The media types on
which the Action button has an effect are mentioned in bold in the Description column.

Channel Management / Mode Selection

Action Button Description

SEL(ect) XT

,

Displays a list and allows

• to select the EVS server from which the channels will be
assigned to the Function buttons in Normal mode. See section
"Assigning Channels to Function Buttons" on page 141.

OR

• to associate the Software Player to the remote. The Software
Player option is displayed in the list only when the Software
Player is associated with a Control Panel or a Playlist Panel.

MENU: gets out of the list.

SEL(ect)
REC(order)

,

Displays a menu with the list of available recorder channels.

MENU: gets out of the list.

See section "Loading Media" on page 146.

GANG

,

When channels have previously been ganged, this function
ungangs, or re-gangs channels.

(available in layout with grab)
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Action Button Description

TAKE Playlists / clips / trains:

If the controlled channel is in PGM/PRV mode, the Take function
shifts from the current media on the PGM channel to the media on
the associated PRV channel using the Take Effect settings as
defined in Tools > Settings > Clips > Clips/Take.

If the controlled channel is in Lock Timeline mode, the Take
function acts as a toggle between the media on the Player pane
and the media on the Timeline pane using the Take Effect settings
as defined in Tools > Settings > Clips > Clips/Take.

BROWSE Enables or disables the Browse mode. The button is red in Browse
mode.

See section "Browsing Media with the BEPlay Remote" on page
149.

Clip Selection and Transfer

Action Button Description

SEARCH TC Clips / trains:

Displays the list of clips and trains containing the same TC as
the loaded clip and allows the selection of an element by using
the wheel.

The selected element is automatically loaded on the same
frame as the initial element.

MENU: gets out of the list.

ENTER: appends the loaded clip to the default playlist.

SHIFT - ENTER: inserts the loaded clip to the default playlist
before or after the on-air element.

LAST CLIPS

,

Displays the list of last created clips and allows the selection of
a clip by using the wheel,

Automatically loads the last created clip on the controlled
channel. Then, by moving the wheel through the list, the clip
highlighted in the list is automatically loaded on the controlled
player.

MENU: gets out of the Last Created Clips list.

ENTER: appends the selected clip to the default playlist.

SHIFT - ENTER: inserts the selected clip to the default playlist
before or after the on-air element.
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Action Button Description

SEND TO Sends the media to the destinations predefined in the Remote
Control Manager window.

Playlists: sends the loaded playlist.

Clips: sends the loaded clip or the marked portion of the loaded
clip.

Trains: sends the marked portion of the loaded train.

See section "BEPlay Remote Configuration" on page 126.

GRAB Playlists / clips / trains: (available in layout with grab)

Saves a small image of the loaded media for use as a thumbnail.
The image will be that of the current position when you click the
Grab button. The image is stored as a file in a directory
specified in the Settings (Tools > Settings > Image Capture >
Default Path for Captured Images). See section "Image
Capture Settings" to know how this path can be set.

Transport Functions

Action Button Description

PLAY Playlists / clips / trains / timelines:

Plays the media loaded on the controlled channel.

PLAY VAR

,

Playlists / clips / trains:

Plays the media loaded on the controlled channel at speed
defined in the Control Panel settings.

PAUSE Playlists / clips / trains / timelines:

Stops the playout of the media loaded on the controlled channel.

E/E Playlists / clips / trains:

Unloads the loaded media and loads the last loaded record train
or recording ingest at its current recording position.

This function can be used with clips loaded on the IPEdit Player.

RETURN (Ret)

,

Clips:

When a clip has been loaded on a player channel, pressing
RETURN loads the same frame of media from the original record
train, if it is still available (not overwritten in the recorder yet).

This function can be used with clips loaded on the IPEdit Player.
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Action Button Description

SNAP

,

Playlists / clips / trains:

Goes back to the last loaded record train or recording ingest at
the timecode where the E/E mode was exited, effectively
"snapping" back to where the user left off in the record train or
recording ingest.

This function can be used with clips loaded on the IPEdit Player.

PREV(ious) Playlists / clips / trains:

Loads the previous playlist element, linked clip or train on the
controlled channel.

PREV(iew)

TRANS(ition) ,

Playlists:

Allows the user to preview a transition effect between playlist
elements.

Starts the playout before the element transition, for the duration
of the pre-roll.

NEXT Playlists / clips / trains:

Loads the next playlist element, linked clip or train on the
controlled channel.

SKIP
(Element)

,

Playlists:

Skips the next playlist element during the playout of the playlist
so it will not play.

If the button is pressed twice, the next 2 elements will be
skipped, and so on.

GO TO

ELEM(ent) ,

(available in layout with split)

Playlists:

Exits a partial loop and jumps on the selected element, according
to the selected Exit Loop mode, i.e. as soon as possible or when
the OUT point of the current element is reached.

RECUE Playlists:

Preloads the first frame of the first playlist element from the
playlist associated with the controlled channel.

Timelines:

Acts as Goto Mark IN in the IPEdit Player.

Acts as Recue timeline in the IPEdit Timeline.
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Action Button Description

LOOP ELEM
(ent)

,

Playlists:

• If the loaded playlist element is not in a partial loop, the Loop
Elem button puts it in an infinite loop.

• If the loaded playlist element is the single element in a partial
loop, the Loop Elem button removes the loop.

• If the on-air playlist element is in a partial loop containing
other clips, the Loop Elem button has no effect.

LOOP CHNL

(channel) ,

Changes the loop mode of the controlled channel.

Playlists:

no loop ↔ loop (the action button is green).

Clips:

no loop ↔ loop (the action button is green)↔ loop

bounce (the action button is red).

Clip Creation Functions

Action Button Description

IN Playlist elements / clips / trains:

Sets a Mark IN point at the current position of the loaded media.

OUT Playlist elements / clips / trains:

Sets a Mark OUT point at the current position of the loaded media.

CLEAR IN

,

Playlist elements / clips / trains:

Clears the Mark IN point which has been set but not yet saved.

CLEAR OUT

,

Playlist elements / clips / trains:

Clears the Mark OUT point which has been set but not yet saved.

GOTO IN

,

Playlist elements / clips / timelines:

Goes to the IN point of the loaded media.

This function can be used with clips loaded on the IPEdit Player or
with timelines from the IPEdit timeline pane.
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Action Button Description

GOTO OUT

,

Playlist elements / clips / timelines:

Goes to the OUT point of the loaded media.

This function can be used with clips loaded on the IPEdit Player or
with timelines from the IPEdit timeline pane.

NEW Playlist elements / clips / trains:

Saves the new clip after having marked an IN point and an OUT
point.

This function can be used with clips loaded on the IPEdit Player.

UPDATE

,

Playlist elements / clips:

Allows the user to save the changes made to a playlist element or
to a clip.

SPLIT (available in layout with split)

Playlists Elements:

Splits the loaded playlist element in two elements at the current
timecode.

Special Buttons

Possible Operations

The BEPlay Remote has 4 buttons which can be used alone or together with other buttons to perform
various types of actions.

The following table gives a brief description of the action of each button.

Button Description

Acts as Escape to exit a screen.

When using the Sel XT, Last clips, Search TC or Sel Rec options, a list is displayed
on the IPDirector screen.

Pressing theMENU button gets out of the list.

,

Locks / unlocks the remote.

When the remote device is locked, no button is available, except to unlock the
BEPlay. The Function LED flash red one after each other.

The time to press the two buttons must not exceed 3 seconds.
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Button Description

The SHIFT button is used prior to another button to modify the behavior of this
button. When it is activated, its LED is green.

, action

Allows to apply the action associated with the upper part of the button. See section
"Action Buttons" on page 132.

,

From a list (Last clips, Search TC or Browse options), inserts the loaded clip to the
default playlist, before or after the loaded element, depending on the setting.

,

Switches the function buttons assignment between the normal mode (all channels of
an EVS video server) and the favorite mode (channels defined in the Remote Control
Manager window).

TheMENU LED flashes red in favorite mode.

,

,

See section "Wheel Mode Buttons" on page 139.

,

Used to associate the Software Player to the remote.

,

,

The CLEAR button is used prior to another button to modify the behavior of this
button. When it is activated, its LED is red.

• CLEAR, IN: works as CLEAR IN

• CLEAR, OUT: works as CLEAR OUT
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Button Description

,

Cancels the applied saved filter in the Database Explorer.

The ENTER button can be used alone (see below)

• In Browse mode, in the Last Created Clips list and in the Search on TC list, when
a clip is loaded on the controlled channel, pressing the ENTER button appends it
to the default playlist.

• In the SEL XT and the SEL REC lists: pressing the ENTER button confirms the
selection.

• In the Database Explorer tree view: opens or closes a tree node.

• In the saved filter pane of the Database Explorer: applies the selected saved
filter.

or it can be used together with another button (refer to the description of the other
buttons):

• seeMENU, ENTER.

• see SHIFT, ENTER.

• see CLEAR, ENTER.

LED Color Code

The LED
of

…when

is
green

the SHIFT button is activated to act as a modifyer of the behavior of another
button.

is red the CLEAR button is activated to act as a modifyer of the behavior of another
button.

Wheel Mode Buttons

Purpose

Three buttons are available to select the mode according to which the wheel will be used. As some of
these buttons can be used in association with other buttons, all things considered, 5 wheel modes are
available to the users.

Pressing aWheel Mode button activates a wheel mode but does not change the playout speed.
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VAR Mode

The Var wheel mode enables to move in the loaded media at a selected constant review speed.

It is activated by pressing . The VAR button LED is red.

On the wheel, the zero position is calculated from the current playout speed to correspond to the point
where the speed is null. The following picture represents the positions of different speed values:

Shift Var Mode

The Shift Var wheel mode is used to fine tune a speed by applying +1% or -1% to the speed.

It is activated by pressing then . The VAR button LED flashes red.

The current speed corresponds to the zero position. The speed can be increased (clockwise), or
decreased (counter-clockwise). The positions of the different speed values will differ according to the
initial playout speed.

Shuttle Mode

The Shuttle wheel mode enables to play fast forward or fast rewind the loaded media.

It is activated by pressing . The SHUTTLE button LED is red.

The zero position is calculated from the current playout speed to correspond to the point where the
speed is null. The speed range is: -35x to +35x.
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Jog Mode

The Jog wheel mode is used to navigate through the loaded media field by field.

It is activated by pressing . The JOG button LED is red.

One impulsion of the wheel corresponds to a jump of one field and is equivalent to pressing the left
arrow or the right arrow keys on the keyboard.

Fast Jog Mode

The Fast Jog wheel mode is used to navigate through content second by second.

It is activated by pressing then . The JOG button LED flashes red.

One impulsion of the wheel corresponds to a jump of 1 second.

9.3.3. Assigning Channels to Function Buttons

Assignment Modes
Each of the 6 Function buttons can be assigned to a recorder channel, to a player channel or to the
Software Player.

The assignment of channels to Function buttons can be done in two ways:

• Favorite Mode: selected channels are defined in the Remote Control Manager window. This is done
during the configuration of the remote.

The LED of theMENU button flashes red.

• Normal mode: this mode uses all channels of an EVS video server. The server can be selected from
the remote, during its use. When the server has more than 6 channels, press twice theMENU button
to be able to select one of the channels from 7 to 12. The LED of theMENU button is red when
function buttons are assigned to channels 7 to 12. The LED of theMENU button is turned off when
function buttons are assigned to channels 1 to 6.

To switch the function buttons assignment between the normal mode and the favorite mode, press the
SHIFT key and then theMENU button.
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Assigning Channels to Function Buttons in Favorite
Mode

How to Assign Player or Recorder Channels to Function Buttons from
the Channel Name Contextual Menu
To assign a recorder channel, a player channel or the Software Player to a Function button of the BEPlay
Remote from the Channel Name field of the Remote Control Manager window, proceed as follows:

1. In the Remote Control Manager window, right-click one of the Channel Name field. A contextual
menu is displayed.

2. Select a channel or the Software Player.

3. Repeat steps 1 and 2 for all the channels you want to associate to the buttons.

The channel name is displayed in the Channel Name field:

and the Function button LED turns red (recorder) or green (player) in the Remote Control Manager and
on the remote:
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How to Assign Player or Recorder Channels to Function Buttons from
the Channel Explorer
To assign a recorder channel or a player channel to a Function button of the BEPlay Remote by a drag-
and-drop operation from the Channel Explorer,

1. Open the Channel Explorer.

2. Select the channel and drag it to one of the six Function button / Channel Name field areas in the
Remote Control Manager window.

The channel name is displayed in the Channel Name field:

and the Function button LED turns red (recorder) or green (player) in the Remote Control Manager
and on the remote:

If you do not have the user right to control the channel, the channel name is displayed but the
Function button LED is dimmed.

3. If needed, repeat step 2 for the other Function buttons.

Linked Channels

In case the channel is linked to another one in a PGM/PRV mode, Fill and Key mode or gang mode, the
linked channels are listed in the Linked Channels box.

• PGM/PRV Mode
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• Gang Mode

• Fill and Key Mode

How to Un-Assign Player or Recorder Channels to Function Buttons
To un-assign a player or recorder channel from a Function button, proceed in one of the following ways:

• Right-click the Channel Name field and select None

• Double-click the Channel Name field.

Assigning EVS Server Channels to Function Buttons
in Normal Mode
To assign all the channels from an EVS video server to the Function buttons of the BEPlay Remote,

1. On the remote, press the SHIFT key and then the Sel XT button.

The list with the available EVS video servers is displayed on screen.

2. Use the remote wheel to move through the list of EVS servers.

3. Press the ENTER button of the remote to select one of the EVS servers.

To cancel the operation: pressMENU.
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The server recorder channels are assigned to the first Function buttons and the corresponding LED are
red. The server player channels are assigned to the next buttons and the corresponding LED are green.

In case the EVS server has less than 6 channels, the exceeding buttons are not assigned.

When it has more than 6 channels, recorder channels are assigned first and the player channels are
assigned. Press twice theMENU button to be able to select one of the channels from 7 to 12. The LED of
theMENU button is then red.

9.3.4. Selecting a Player to Control

Selecting a Player Channel to Control

To select one of the player channels, press the Function button which has been associated with it in
Favorite mode or in Normal mode, as described in section "Assigning Channels to Function Buttons" on
page 141.

The LED of the Function button flashes green.

If the player channel is already associated with a Control Panel or a Playlist Panel, the BEPlay remote
icon appears in the Player field of this panel:

It is also displayed in the Channel Explorer, next to the controlled player.

In Timeline mode, two players are associated with form the Timeline Engine. They can be PGM1/PGM2 or
PGM3/PGM4. Pressing the Function button assigned to the odd player gives access to the IPEdit
Timeline pane. Pressing the Function button assigned to the even player gives access to the IPEdit
Player pane.

Controlling the Software Player

Favorite Mode

If you work with the player and recorders which have been selected in the Remote Control Manager
window, you can take the control of the Software Player with the BEPlay remote in one of the following
ways:

• Press the Function button which has been assigned the Software Player in the Remote Control
Manager window.

• Press SHIFT, F1 on the Remote, would the Software Player be associated with a Function button or
not.
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Normal Mode

If you have assigned all the channels of an EVS server to Function buttons from the Sel XT function, you
can take the control of the Software Player with the BEPlay remote in one of the following ways. In both
cases, the Software Player must have previously been associated with an open Control Panel or Playlist
Panel.

• Press SHIFT, F1 on the Remote.

• Press SHIFT, SEL XT on the Remote, as explained below.

a. On the remote, press the SHIFT key and then the SEL XT button.

The list with the available EVS video servers and the Software Player is displayed on screen.

b. Use the remote wheel to select the Software Player.

c. Press the ENTER button of the remote.

To cancel the operation: pressMENU.

The Remote icon appears on the left of the Player field in the Control Panel or Playlist Panel:

9.3.5. Loading Media

Loading a Train

Possible Actions

Users can load a train on the controlled player channel in one of the following ways:

• If the required recorder is assigned to a Function button, press this Function button. The LED
flashes red.

• In case a train is already loaded on the controlled player, you can press the NEXT or the PREV button
to load the train from the next or the previous recorder.

• To select a recorder channel not assigned to a Function button, proceed as follows:
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a. Press the SHIFT key and then the SEL REC button.

The list with the available recorder channels is displayed on screen.

b. Use the remote wheel to move through the recorder channels list.

c. Press the ENTER button of the remote to select a recorder.

To cancel the operation: pressMENU.

The train is loaded on the player channel or on the Software Player controlled by the remote.

Rules for Loading a Train

Depending on the element previously loaded on the controlled player channel, the behavior will vary as
follows:

Element Previously Loaded Pressing the F button of a recorder…

Playlist loads the corresponding train in E/E.

Clip loads the corresponding train in E/E.

Train in Pause loads the corresponding train in pause at the same timecode.

Train in Play loads the corresponding train in play at the same timecode.

Train in E/E loads the corresponding train in E/E.

Loading a Clip

Possible Sources of Clips

Clips can be selected from different sources to load them on the controlled player channel:

• From the Search TC list: see section "BEPlay Remote Buttons" on page 129.

• From the Last Created Clips list: see section "BEPlay Remote Buttons" on page 129.
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• From the Database Explorer grid: see section "Browsing Media with the BEPlay Remote" on page
149.

How to Load a Linked Clip

1. Select the player to be controlled by the BEPlay remote, as described in "Selecting a Player to
Control" on page 145.

2. Press SHIFT, Last Clips on the BEPlay.

The Last Clips window is displayed on screen and the last created clip is loaded on the controlled
player.

3. Use the wheel to move through the list until the requested clip is highlighted.

The highlighted clip is automatically loaded on the controlled player.

4. PressMENU to get out of the list.
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5. Press Search TC on the BEPlay.

The Search TC window opens on screen and displays the list of clips linked to the loaded clip.

6. Use the wheel to move through the list until the requested clip is highlighted.

The highlighted clip is automatically loaded on the controlled player.

9.3.6. Browsing Media with the BEPlay Remote

Browsing a Playlist

Introduction

The BEPlay remote allows the users to browse elements within a playlist.

Prerequisites

To be able to browse a playlist with the remote, some conditions must be met:

• a player channel or the Software player must be controlled by the remote

• the playlist must be opened in a playlist panel or in a control panel

• the player channel controlled by the remote must be assigned to the playlist panel or the control
panel where the playlist is opened.

How to Browse a Playlist

To browse a playlist when the prerequisites are met,

1. Press the BROWSE button on the remote.

The panel on which the playlist is opened becomes active on screen.
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2. Use the wheel to select a playlist element:

◦ in clockwise to select the next element

◦ in a counter-clockwise to select the previous element.

The selected element is cued on its IN point.

Browsing Clips

Introduction

The BEPlay remote allows the users to browse clips from the Database Explorer, would they be in the
Clips plug-in or in the Bins/Clips plug-in.

Prerequisites

To be able to browse a clip with the remote, some conditions must be met:

• a player channel or the Software player must be controlled by the remote

• the player channel or Software player controlled by the remote must be assigned to the Database
Explorer

• the remote must be linked to the Database Explorer by double-clicking the BEPlay Remote area on
the status bar of the Database Explorer.

Moving through the Database Explorer

The users can navigate in the grid, in the tree view or in the saved filters pane if it is displayed. To move
from one pane of the Database Explorer to another, use the following remote buttons:

• NEXT: move from grid → saved filters, if the pane is displayed → tree view

• PREV: move from grid → tree view→ saved filters, if the pane is displayed.

The active pane is not highlighted. When you turn the remote wheel, you will see in which
pane the selection is moving.

How to Browse a Clip in the Grid

To browse clips when the prerequisites are met,

1. Press the BROWSE button on the remote.

The Database Explorer linked to the remote becomes active on screen.

The Browse mode of the Database Explorer is enabled .

The focus is on the grid.
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2. Use the wheel to select a clip:

◦ in clockwise to select the next clip

◦ in a counter-clockwise to select the previous clip.

The selected clip is cued on its IN point on the controlled player.

3. To send the loaded clip the default playlist, do one of the following:

◦ Press the ENTER button to append the current clip to the default playlist.

◦ Press SHIFT then ENTER to insert the current clip to the default playlist before or after the on-air
element, according to the settings.

To send the clip to the predefined destination:

◦ Press the SEND TO button.

How to Browse a Clip in the Tree View

To browse clips when the prerequisites are met,

1. Press the BROWSE button on the remote.

The Database Explorer linked to the remote becomes active on screen.

The Browse mode of the Database Explorer is activated

The focus is on the grid.

2. Use the PREV button to move to the tree view.

3. In the tree view, only the Clips plug-in and the Bins/Clips plug-in can be browsed. Use the wheel to
move from one plug-in to the other.

4. Press the ENTER button to open or close a tree node.

The corresponding list of clips is displayed in the grid.

5. Press the NEXT button to be able to browse the list.

How to Browse a Clip in the Saved Filters

To browse clips when the prerequisites are met,

1. Press the BROWSE button on the remote.

The Database Explorer linked to the remote becomes active on screen.

The Browse mode of the Database Explorer is activated

The focus is in the grid

2. Press the NEXT button to move to the saved filters, if the pane is displayed.

3. Use the wheel to select a filter.

4. Press the ENTER button to apply a filter.
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5. Press the PREV button to move to the grid and browse clips.

6. To cancel the filter, press the CLEAR button then the ENTER button.

152 | December 2024 | Issue 8.06.B



10. ShuttlePRO Keys

10.1. Introduction
The ShuttlePRO device has a Jog wheel, a Shuttle ring, and fifteen buttons. The two top rows of buttons
on the ShuttlePRO have labels for quick reference as to which function each button is designed to
perform.

However, the controller has different functions depending on which mode IPDirector is being operated
in.

No ShuttlePRO driver is needed. The button configuration is hard coded. IPDirector accesses directly
this device.

Details on the button functions are included in the respective sections of the current manual.

The diagrams in sections "Quick Reference in Clip Mode" on page 154 and "Quick Reference in Playlist
Mode" on page 155 are quick reference guides to the location of the functions on the ShuttlePRO.

Some buttons may be used with CTRL or SHIFT from the keyboard as a modifier to change the button
function. These functions are shown in red for CTRL and blue for SHIFT in the diagrams.
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10.2. Quick Reference in Clip Mode
In clip mode, the ShuttlePRO buttons can be used for the following operations:
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10.3. Quick Reference in Playlist Mode
In playlist mode, the ShuttlePRO buttons can be used for the following operations:
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11. Display Tools
Media can be viewed on an external monitor or from the IPDirector Video Display, either in the Player
pane of the Control Panel or the Playlist Panel) or in the Video Display module. You can choose to
browse the media loaded on a player channel or to browse media through the Software Player.

The On-Screen Display (OSD) provides, overlaid on a monitor, relevant information on the media loaded
on the controlled player channels. See section "On-Screen Display" on page 164.

11.1. Software Player

Context of Use

The Software Player acts as media viewer and allows the users to browse media through the GigE
network.

The Software Player can be chosen as a source for the Control Panel or the Playlist Panel, in the same
way as a normal player channel. Browsed media can also be viewed in the Video Display. The Software
Player can be used with the ShuttlePRO or with the BEPlay remote.

You can only open one instance of the Software Player at a time in IPDirector.

As the Software Player works by decoding files on the IPDirector, its performance will depend on the
workstation capacity.

Browsable Media

Using the Software Player, you will be able to browse any of the hi-res or lo-res following media
elements as long as they are available on an EVS server or on an online nearline via the GigE network:

• trains

• XT clips or growing clips defined on an EVS server

• files stored on a nearline storage.

• playlist elements

• playlists

The Software Player will not play transition effects between the playlist elements. All
transitions will be viewed as "Cut".

Once a near line clip is loaded on the player, the user can make sub clips in the same way as in a normal
Control Panel.
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11.2. Video Display

11.2.1. Introduction
There are two ways to view video on the IPDirector workstation:

• through the Software Player

• by connecting the SDI output of an EVS server into the IPDirector

In both cases, the video associated with the channel can be displayed within the Control Panel or the
Playlist Panel, or externally in the Video Display.

The advantage of displaying the video in the Video Display is that the window can be resized and placed
anywhere on the IPDirector desktop.

11.2.2. Using a Player Channel on a Video
Display

Preliminary Steps

Before you can actually display a channel in the Video Display, you need to perform the following tasks:

1. Make a physical connection from the required video source to the input of the A/V board on the
IPDirector workstation.

2. Assign a player channel to the Video Display in the Remote Installer application.

3. Select the A/V board in the Video Display to open the related channel.
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Connecting the Video Source
To be able to display a channel in the Video Display window, a physical connection must be made from
the required video source to the input of the IPDirector workstation A/V board.

To display video on the VGA uses around 25% of the CPU power of the workstation for a
display size of 384 x 288, more if a larger display is required. The reactivity of the IPDirector
interface could be significantly slower if larger window sizes are used.

Assigning a Channel to a Video Display
Once the physical connection is made, the Video Display panel needs to be linked to the corresponding
PGM video channel connected to the input of the IPDirector Workstation video card.

In the Remote Installer,

1. With the Classic theme:

a. Right-click the IPDirector Service box on the Workstation area.

b. Select Edit Config from the contextual menu.

With the Dark theme,

◦ Click the button on the service box.

The IPDirector Configuration window opens:
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2. Select the box in the Linked column corresponding to the player channel you want to link to the
video display.

3. Select which video display device it must be linked to from the drop down list in the Video Display
column.

The linked box can be selected without being linked to a Video Display. For example, this is
used when an external monitor is connected to your workstation.

4. Click Save.

5. Repeat steps 1 to 5 for all IPDirector workstations as these parameters are local to the IPDirector
workstation.

For more information, refer to the IPDirector Remote Installer Technical Reference.

Opening the Video Display

To open the Video Display panel, select the corresponding icon on the IPDirector
Application bar.

To open the Video Display within a Control Panel or a Playlist Panel, you need to assign the player
channel linked to the A/V board to the corresponding panel. Then, you can hide or unhide the Video
Display by right-clicking the panel and selecting Show/Hide Video Display.

Selecting the A/V Board in the Video Display
When you open the Video Display module, you need to select the A/V board to be able to view the
channel associated with the board.

1. Right-click the Video Display window.

A contextual menu is displayed with the names of the A/V board(s) connected to the IPDirector
workstation.

2. Select EVS AVH.

The media loaded on the player channel linked to the A/V board will be displayed in the Video Display
window.
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Video Display Linked to the Player Channel
The options available if you right-click the Video Display window when a media is loaded on the linked
player channel are described below.

EVS AVH Config

Opens the Audio Output Channels window allowing the selection of audio channels to be listened to.

See section "Audio Configuration and Monitoring" on page 162.

Show/hide Video Display

Displays, or not, the media in the Video Display.

4/3

Sets the video ratio to 4/3 format.

16/9

Sets the video ratio to 16/9 format.

11.2.3. Using the Software Player and the Video
Display

Introduction

The Software Player acts as media viewer and allows the users to browse media through the GigE
network. See section "Software Player" on page 156 for more details.
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Opening the Video Display
Media browsed through the Software Player can be viewed in the Video Display module, provided that
the Software Player has previously been assigned to a Control Panel or a Playlist Panel. See the Control
Panel user manual and the Playlist Panel user manual. The Software Player option will then be available
when right-clicking the Video Display window:

Video Display Linked to the Software Player
The options available if you right-click the Video Display window when a media is loaded on the
Software Player are described below.

OCX Audio Configuration

Opens the Audio Output Channels window allowing the selection of audio channels to be listened to and
the selection of the number of audio channels for the audiometers display. See section "Audio
Configuration" on page 162.
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Show/hide Video Display

Displays, or not, the media in the Video Display.

Activate Audio Template Selection

Displays the Audio Template Selection field at the bottom of the Video Display to allow the quick
selection of a predefined audio template.

See section "Applying an Audio Template" on page 163.

11.2.4. Audio Configuration and Monitoring

Audio Configuration
To select the audio channels you want to listen to,

1. Right-click the Video Display.

2. SelectOCX Audio Configuration (Software Player) or EVS AVH Config(player channel) from the
contextual menu.

The Audio Output Channels window opens.

3. On the Left line, click the cell corresponding to the channel you want to associate with the left ear.

4. On the Right line, click the cell corresponding to the channel you want to associate with the right ear.

5. (optional) Adjust the input gain.
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6. Click the radio button corresponding to the number of audio channels to display on the sides of the
Video Display window when you use the Software Player: None, 2 channels, 4 channels, 8
channels, 16 channels, 32 channels.

7. For an easy retrieval of the configuration, you can save it:

◦ Enter a name in the Template Name field

◦ Click the Add button.

8. ClickOK.

The audio configuration is automatically applied.

The audiometers are shown on the Video Display sides.

Applying an Audio Template
To select the audio channels you want to listen to,

9. Right-click the Video Display.

10. Select Activate Audio Template Selection from the contextual menu.

The Audio Template Selection field is displayed at the bottom of the Video Display.
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11. Click the arrow next to the Audio Template Selection field.

12. Select one of the audio templates.

The audio configuration is applied.

11.3. On-Screen Display

Configuration and Activation

The information to display on a monitor is set in the OSD Settings window. It is defined for each playout
channel. This does not apply to recorder channels or software player. See section "OSD Settings" on
page 111.
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The OSD can be turned ON or OFF in several ways:

• By using a shortcut in the various IPDirector applications: Control Panel, Playlist Panel, AB Roll
Playlist, IPEdit, IPLogger, Database Explorer. See sections "Channel Management Shortcuts" on
page 118.

• By using a shortcut on the ShuttlePRO. See section "ShuttlePRO Keys" on page 153.

• By selecting an option in the Channel Explorer. Refer to the Channel Explorer user manual.

Impacted Channels

Depending on the channel mode the player channel is involved into, the effect of the Turn OSD ON or
OFF shortcut will differ as detailed in the table below.

If the channel
mode is…

…the OSD appears / disappears for…

PGM the player channel linked to the device or active panel from which the shortcut
has been applied

PGM/PRV • In Clip mode (clip, growing clip, train loaded):

the player channel linked to the device or active panel from which the
shortcut has been applied

• In Playlist mode (playlist loaded):

both player channels engaged in PGM/PRV mode

Fill & Key the player channel linked to the device or active panel from which the shortcut
has been applied

Ganged the player channel linked to the device or active panel from which the shortcut
has been applied

IPEdit (Timeline
mode)

the player channel associated with the panel which is active in IPEdit: Player or
Timeline

AB Roll all the player channels associated with the AB Roll Playlist Panel
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12.Fill and Key
Here, you will find some information regarding the association of channels, clips and playlists in Fill and
Key mode.

12.1. Associating Channels in Fill and Key
Mode

Purpose

Recorder channels or player channels of the EVS servers can be ganged in a specific style called Fill &
Key. This mode manages assignments of clips or playlists, and forces them to recall to the appropriate
channels, so as to allow you to perform synchronized clip or playlist recalls in a Fill & Key scenario
(sometimes called Matte & Fill).

How to Associate Channels in Fill and Key Mode
To associate two channels in Fill & Key mode,

1. Select two channels with SHIFT+click or CTRL+click.

The first channel you select will become the Fill and the second one the Key.

2. Do one of the following operations:

◦ Right-click one of the channels and select Fill Key

◦ Press CTRL+Y.

Display of Channels in Fill and Key Mode

In Channel Explorer, the channels are shown with the Fill and Key icons:
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In the Control Panel and the Playlist Panel where the player channel is selected, the Fill or Key
information is displayed in the panel title bar.

12.2. Fill and Key Clips

12.2.1. Introduction
This chapter is intended to highlight specificities of Fill and Key clips.

Most of the operations performed on a Fill or a Key clip are done in the same way as for Normal clips.
References are therefore made to the chapters "Control Panel" and "Database Explorer", describing in
details all the procedures about clip management.
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12.2.2. Setting Clips as Fill and Key

At Clip Creation

Clip can be defined as Normal, Fill or Key clip when metadata is assigned to it.

By default the clip type is set to Normal.

• Select the Fill button to define the clip as Fill clip.

• Select the Key button to define the clip as Key clip.

After Clip Creation

How to Edit the Clip Type from the Database Explorer

The clip type can be modified after the clip creation.

To edit the metadata of an existing clip from the Database Explorer,

1. Select the clip in the Database Explorer.

2. Right-click the selected clip in the grid.

The Clip contextual menu is displayed.
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3. Select Edit.

The Edit Clip window appears and allows you to modify the clip type.

4. Select the Fill button to define the clip as Fill clip.

Select the Key button to define the clip as Key clip.

How to Edit the Clip Type from the Control Panel

To edit the metadata of an existing clip from the Control Panel,

1. Load the clip on the Control Panel.

2. In the Clip Information tab,

◦ select the Fill button to define the clip as Fill clip.

◦ select the Key button to define the clip as Key clip.

12.2.3. Associating Fill and Key Clips

How to Manually Associate Two Clips as Fill and Key
To manually associate two clips in a Fill and Key association,

1. In the Database Explorer, select a clip 1 (Normal, Fill, or Key).

2. Drag it onto a clip 2 (Normal, Fill, or Key), keeping the CTRL and SHIFT keys pressed.

The clips are automatically linked in a Fill and Key association according to the rules described below.
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The Fill icon is now displayed in the Type column for the Fill clip.

The Key icon is now displayed in the Type column for the Key clip.

Rules in Key and Fill Clip Associations
The result will depend on the original type of the two clips: some associations are not allowed, some clip
type will be converted to another one. The table below describes the different cases which can occur
when dragging a clip 1 onto a clip 2:

Clip 1 Clip 2

Normal Fill Key

Normal Normal clip1 → Fill

Normal clip2 → Key

Link the two clips

If Fill not yet linked:

Normal clip1 → Key

Link the two clips

Normal clip1 → Fill

Link the two clips

If Fill already linked:

Error message in popup
window

Fill If Fill not yet linked:

Normal clip2 → Key

Link the two clips

Invalid operation

Error message in the error list

If Fill not yet linked:

Link the two clips

If Fill already linked:

Error message in popup
window

If Fill already linked:

Error message in popup
window

Key Normal clip2 → Fill

Link the two clips

If Fill not yet linked:

Link the two clips

Invalid operation

Error message in the error list

If Fill already linked:

Error message in popup
window

How to Disassociate Fill and Key Links
To delete a link between fill and key clips, proceed in one of the following ways:

1. Select the Fill or Key clip in the Database Explorer.

2. Right-click on the selected clip to display the contextual menu.

3. Select Unlink from the contextual menu.

The link is deleted.

1. Load the Fill or Key clip in the Control Panel.
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2. Right-click on the control panel to display the contextual menu.

3. Select Unlink from the contextual menu.

The link is deleted.

How to View Fill and Key Associations
To view Fill and Key associations,

1. Click the button in the Database Explorer toolbar.

2. Select Fill Key from the contextual menu.

Once selected, the Thumbnail and Key Thumbnail columns are added in the Database Explorer.

If a Fill clip is associated with a Key clip, the corresponding key thumbnail is displayed in the Key
Thumbnail column. If no key clip is associated, no key thumbnail is displayed.

To narrow your search, click the Show / Hide Grid Filter Bar button on the top of the grid and
perform a search on the Type column by selecting Fill and/or Key. Refer to sections "Search Options"
and "Searching the Database > Grid Filters" in Database Explorer chapter of the user manual.
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How to View Key Clip Information
In the Control Panel, the associated Key or Fill clip is displayed in the Linked to Clips area of the Clip
Information tab:

A thumbnail for the Key clip will only appear if the user has manually defined a thumbnail photo
for the original Key clip or thumbnails can be created automatically when there is an XFile3 or
XTAccess designated within the thumbnails configuration in the IPDirector Remote Installer.
Please see the Technical Reference manual for further details.

12.3. Fill and Key Playlists

12.3.1. Purpose
This chapter is intended to highlight specificities of Fill and Key playlists.
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Most of the operations performed on a Fill or a Key playlist are done in the same way as for Normal
playlists. References are therefore made to the Playlist Panel user manual, describing in details the
Playlist Panel interface and all the procedures about playlist management, playlist editing and playout
effects and parameters. Refer to the Playlist Panel user manual for more information.

The differences will mainly reside in the behavior of the system when an action is applied on a Fill or a
Key playlist or playlist element and on the resulting action, or absence of action, on the corresponding
Key or Fill playlist.

Virtual elements cannot be used in fill and key playlists.

12.3.2. Fill and Key Playlists Management

Creating Fill and Key Playlists

Introduction

Fill and Key playlists can be created on-line or off-line exactly like Normal playlists. Refer to the Playlist
Panel user manual for more information.

In the New Playlist window, the user can define the type of the playlist between Normal, Fill or Key.

When the playlist type is defined as Fill (or Key), the system creates both a Fill playlist and a Key playlist.

How to Create a Fill or Key Playlist
You can create a new on-line or off-line playlist

• from the Playlist Panel,

OR

• from the Database Explorer.

To create a new Fill (or Key) playlist,

1. From the Playlist Panel:

If required, associate a channel as described in section "How to Assign a Player Channel or the
Software Player".

Right-click the Playlist Name field.

From the Database Explorer:

In the Playlists tree view of the Database Explorer, right-click in the element list.

The Playlist contextual menu is displayed.
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2. Select New Playlist from the contextual menu.

The Create a New Playlist window is displayed. See section "Create a New Playlist" for more details
on this window.

3. Fill in a playlist name and any desired information.

In the Type area, click the Fill (or the Key) button.

4. Click theOK button or press the ENTER key.

The system creates both a Fill playlist and a Key playlist.

They are both created with the same information (name, keywords,…).

When the new playlist is created from a server tree view in the Database Explorer, it is made on-line on
the selected EVS video server, as well as its corresponding Fill or Key playlist.

When the new Fill (or Key) playlist is created from a clip-list Panel or a Playlist Panel associated with a
channel, the playlist is made on-line on the EVS video server of the channel. If this channel is linked to
another channel in a Fill & Key mode, the corresponding Key (or Fill) playlist is made on-line on the EVS
server of the corresponding channel.

Manually Linking or Unlinking Two Playlists as Fill
and Key

Purpose

When creating a Fill (or Key) playlist, the corresponding Key (or Fill) playlist is automatically created.
However, with a drag-and-drop operation, it is possible either to change the existing association
afterwards, to associate two playlists for which the respective links have been broken or to change the
type of a Normal playlist to associate it to a Fill or Key playlist.

How to Manually Associate Two Playlists as Fill and Key
To manually associate two playlists,

1. In the Database Explorer, select a playlist 1 (Normal, Fill, or Key).

2. Drag it onto a playlist 2 (Normal, Fill, or Key), pressing the SHIFT and CTRL keys at the same time.

The result will depend on the original type of the two playlists: some associations are not allowed, some
playlist type will be converted to another one.

Rules in Key and Fill Playlist Associations
The table below describes the different cases which can occur when associating two playlists:
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Playlist 1
(PL1)

Playlist 2 (PL2)

Normal Fill Key

Normal Normal PL1 → Fill

Normal PL2 → Key

Link the two PL

If Fill not yet linked:

Normal PL1 → Key

Link the two PL

Normal PL1 → Fill

Link the two PL

If Fill already linked:

Error message in popup
window

Fill If Fill not yet linked:

Normal PL2 → Key

Link the two PL

Invalid operation

Error message in the error
list

If Fill not yet linked:

Link the two PL

If Fill already linked:

Error message in popup
window

If Fill already linked:

Error message in popup
window

Key Normal PL2 → Fill

Link the two PL

If Fill not yet linked:

Link the two PL

Invalid operation

Error message in the error
list

If Fill already linked:

Error message in popup
window

When a Fill and Key association already exists, a warning message will be displayed informing you that
the playlist must first be unlinked to be able to create a new association.

How to Manually Unlink Two Fill and Key Playlists
To manually remove the link between one or several Fill playlists and one or several Key playlists,

1. In the Database Explorer, select either one playlist of the Fill and Key association or both.

You can also select playlists from multiple associations.

2. Right-click one of the selected playlist.

The Playlist contextual menu opens.

3. Select Unlink from the menu.

All Fill and Key associations of all elements from the selection are cleared, but the type of each playlist is
kept.
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Opening and Loading a Fill or Key Playlist
General procedures for the opening of a Normal playlist and for the loading of a Normal playlist on a
player channel are detailed in the Playlist Panel user manual.

However, the behavior of the system could be slightly different when you work with Fill or Key playlists
as well as when you try to load a Normal playlist on a Fill or Key channel.

The table below describes the different actions which result when

• you want to open a Normal, Fill or Key playlist in a Playlist Panel or the clip-list tab of a Control Panel
(no channel associated)

• you want to load a Normal, Fill or Key playlist on a Normal, Fill or Key channel associated with a
Playlist Panel or the clip-list tab of a Control Panel. See section "Associating Channels in Fill and Key
Mode" on page 166 for more information on Fill and Key player channels.

Playlist Type Channel Type

No channel Normal Fill Key

Normal Open Load Warning + black on
Key channel

Warning

Fill Open the Fill
PL

Load the
Fill PL on
the
channel

If Fill PL not linked to
Key PL:

Load the Fill PL on
the Fill channel

Warning

If Fill PL linked to Key
PL:

1. Load the Fill PL
on the Fill
channel, AND

2. Load the Key PL
on the Key
channel

Key Open the
Key PL

Load the
Key PL on
the
channel

Warning If Key PL not linked to Fill PL:

Load the Key PL on the Key
channel

If Key PL linked to Fill PL:

1. Load the Key PL on the Key
channel, AND

2. Load the Fill PL on the Fill
channel
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Renaming or Modifying Information of a Fill or Key
Playlist

Introduction

Renaming a Fill or Key playlist or modifying information of a Fill or Key playlist can be done in the same
way as for a Normal playlist through the Edit a Playlist window.

When a Fill (or Key) playlist is renamed, the corresponding Key (or Fill) playlist is automatically renamed
as well.

Modifying the Playlist Type

Modifying the type of a Fill (or Key) playlist which is linked to a Key (or Fill) playlist is not allowed and the
Type buttons cannot be selected in the Edit a Playlist window.

If the playlist is not linked to another one, it is allowed to modify its type as follows:

• A Normal playlist can be produced from the modification of a Key playlist or a Fill playlist.

• A Key playlist can be produced from the modification of a Normal playlist or a Fill playlist.

• A Fill playlist can be produced from the modification of a Normal playlist or a Key playlist. In this case,
the corresponding Key playlist will be created and the Fill and Key playlists will be linked together.

This is summarized in the table below:

To

From

Normal Fill Key

Normal NA 1. Normal → Fill

2. Create corresponding Key PL

3. Link the 2 PL

→ Key

Fill → Normal NA → Key

Key → Normal 1. Key → Fill

2. Create corresponding Key PL

3. Link the 2 PL

NA
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Deleting a Fill or Key Playlist
Deleting a Fill (or Key) playlist can be done in the same way as for a Normal playlist.

Refer to the Playlist Panel user manual for more information.

The Fill playlist and the corresponding Key playlist are deleted from the IPDirector database and from all
bins in which they were included.

12.3.3. Fill and Key Playlists Editing

Adding Elements in a Fill or Key Playlist

How to Insert a Playlist in a Fill or Key Playlist

Inserting a playlist into a Fill (or Key) playlist can be done in the same way as for inserting a playlist into a
Normal playlist.

However, the system will behave differently depending on the type of the two playlists. The table below
summarizes the actions resulting from the insertion of a playlist (PL1) into another playlist (PL2):

Playlist 1
(PL1)

Playlist 2 (PL2)

Fill Key

Normal 1. Normal PL1 inserted in Fill PL2 as a group.

2. Black or white elements of exact same
duration inserted in corresponding Key
PL.

Error message: you can only insert a Key PL
into another Key PL.

Fill 1. Fill PL1 inserted in Fill PL2 as a group.

2. Key PL corresponding to PL1 inserted as a
group in Key PL corresponding to PL2.

Error message: you cannot insert a Fill PL
into a Key PL and vice-versa.

Key Error message: you cannot insert a Fill PL into
a Key PL and vice-versa.

1. Key PL1 inserted in Key PL2 as a group.

2. Fill PL corresponding to PL1 inserted as
a group in Fill PL corresponding to PL2.

Adding Elements in a Fill or a Key Playlist

Adding an element by drag-and-drop operation into a Fill (or Key) playlist can be done in the same way
as for adding a Normal element into a Normal playlist. Refer to the Playlist Panel user manual for more
information.
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However, the system will behave differently depending on the type of the element added and the type
of the playlist. The table below summarizes the actions resulting from the insertion of an element into a
playlist:

Element
Type

Playlist Type

Fill Key

Normal 1. Element inserted in Fill PL.

2. Black or white element of exact same duration
inserted in corresponding Key PL: warning message
displayed.

Error message: you can only
insert a Key element into a Key
PL.

Fill If Fill element is not linked to a Key element:

1. Element inserted in Fill PL.

2. Black or white element of exact same duration
inserted in corresponding Key PL: warning message
displayed.

Error message: you can only
insert a Key element into a Key
PL.

If Fill element is linked to a Key element:

1. Fill element inserted in Fill PL.

2. Corresponding Key element inserted in
corresponding Key PL.

Key Error message: you cannot insert a Key element into a Fill
PL

If Key element is not linked to a
Fill element:

Key Element inserted in Key PL.

If Key element is linked to a Fill
element:

1. Key element inserted in Key
PL.

2. Corresponding Fill element
inserted in corresponding Fill
PL.

When a Key clip is linked to several Fill clips, it cannot be inserted into a Key playlist. You
should insert the Fill clip into the fill playlist to avoid any confusion.

When the element is appended to the playlist, by using the APPEND CLIP button or the Send
to Default Playlist option, both Fill and Key elements will be added at the last position in their
respective playlist, even if the playlists do not have the same number of elements.
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Modifying an Element in a Fill or Key Playlist
When the user modifies one of the parameters listed below to a Fill (or Key) playlist element, the
modification is automatically applied to the corresponding Key (or Fill) playlist element:

• Playlist element duration

• Playlist element name

Refer to the Playlist Panel user manual for more information.

Moving Fill and Key Playlist Elements
Moving a Fill (or Key) playlist can be done in the same way as for a Normal playlist.Refer to the Playlist
Panel user manual for more information.

The elements are moved inside the Fill (or Key) playlist as well as the corresponding elements in the Key
(or Fill) playlist which are moved at the same position.

Removing Playlist Elements from a Fill or Key Playlist
Removing elements in a Fill (or Key) playlist can be done in the same way as for a Normal playlist. Refer
to the Playlist Panel user manual for more information.

All selected elements in the Fill (or Key) playlist are removed as well as the corresponding elements in
the Key (or Fill) playlist.

Modifying Tags of a Fill or Key Playlist Element
When the user inserts, modifies or deletes tags on a Fill (or Key) playlist element (see parameters listed
below), the modification is not applied to the corresponding Key (or Fill) playlist element:

• GPI tags

• Swap audio tags

• Hide

• Mute

Refer to the Playlist Panel user manual for more information on tags.

Grouping Elements in a Fill or Key Playlist
When the user creates or deletes a group of elements in a Fill (or Key) playlist, the same operation is
performed on the corresponding Key (or Fill) playlist.

Refer to the Playlist Panel user manual for more information.
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12.3.4. Fill and Key Playlists Playout Effects and
Parameters

Applying Transport Commands on a Fill or Key Playlist
When both Fill and corresponding Key playlists are loaded on Fill and Key channels, if the operator
performs one of the actions listed below on the Fill (or Key) playlist, the same operation is performed at
the same time on the corresponding Key (or Fill) playlist:

• Play, Pause, Fast Forward,

• Fast rewind

• Jog

• Next

• Skip

• Go to Element

• E/E

• Preload a playlist element

• Recue

Modifying Playout Effects and Parameters
When the user modifies one of the parameters listed below to a Fill (or Key) playlist element, the
modification is automatically applied to the corresponding Key (or Fill) playlist element. Refer to the
corresponding sections of the Playlist Panel user manual for more information on the different topics.

• Video effect: "Adding Audio/Video Transition Effects"

• Audit effect: "Adding Audio/Video Transition Effects"

• Playlist element speed: "Setting the Playout the Speed"

• Reset transition to default: "Resetting Playout Parameters to Default"

• Still/Start mode: "Stopping or Starting Automatically the Playout of a Playlist"

Looping Playlist Elements
When the user creates or deletes a loop in a Fill (or Key) playlist, the same operation is performed on the
corresponding Key (or Fill) playlist.

Refer to the Playlist Panel user manual for more information.
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Associating an Auxiliary Clip to a Fill or Key Playlist
Associating an auxiliary clip to a Fill (or Key) playlist can be done in the same way as for a Normal playlist.
Refer to the Playlist Panel user manual for more information.

The system associates the auxiliary clip to the Fill (or Key) playlist but does not perform any operation on
the corresponding Key (or Fill) playlist.
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