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1.1

1.2

1.2.1

1.2.2

1.2.3

1. Introduction

PURPOSE

XNet Monitor is a tool aimed at monitoring EVS products. XNet Monitor displays
real time information and status about the servers as well as past alert and
warning messages.

XNet Monitor uses the SNMP (Simple Network Management Protocol) protocol to
request and receive monitoring data from the servers. These internal status data
are defined in the MIB (Management Information Base) on each server.

One XNet Monitor application can monitor several servers while one server may
also be monitored by several XNet Monitors or similar applications.

XNet Monitor is mainly a monitoring application that cannot act on the monitored
servers. The only possible remote actions are Multicam update and server reboot.

INSTALLATION

REQUIREMENT

e PC compatible computer
e Supported OS: Windows XP, Windows Vista or Windows 2003 Server

e Net framework 3.0 or higher installed

RECOMMENDATION

The SNMP information is available through the PC LAN connector of the server.
The XNet Monitor running computer should be connected to the same network, and
not on any of the Gigabit Ethernet ports of the servers. These ports are dedicated
to high flow video data and can not be used for any other purpose.

INSTALLATION

XNet Monitor is delivered as a single executable file.

To install the program, run this installation file. During the installation, a warning
will be displayed if .Net framework is not installed on your computer. In this case,
you should manually install this.

If you need to install the .Net framework, double-click the DotNet 3.5 SP1
Install3.bat file, which is delivered with the XNet Monitor executable file.
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During XNet Monitor installation, the only required parameter is the installation
path for the application. If you want to change the default one, enter the desired
path.

Once the application is installed it can be executed immediately.

UPDATE

If an older version of XNet Monitor is already installed on your computer, it will be
automatically removed and replaced by the new one.

UNINSTALL

The XNet Monitor application must be removed through Windows Control Panel
and Add or Remove Programs menu.
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2. Configuration

2.1 USER INTERFACE

At first start-up or when it is not configured, the XNet Monitor displays the
following window.

et Monitor 01.00.11
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The window is divided in 4 panes:

e The Hosts List pane displays the monitored servers in a user-defined tree
architecture.

e The Monitoring Data pane displays the selected server information.

e The Disk Usage pane displays a pie chart with the totalized used and left disk
space for the selected server(s).

e The SNMP Messages pane displays the SNMP alert and warning messages for
the selected period and enables the user to acknowledge them.

2.2  HOSTS LIST

The Hosts List pane displays the monitored servers on the network. They are
listed in a tree architecture independent of the network architecture as shown on
the following figure.
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= [l ®Met [23]

=l Cantral room [15]
B Server (8]
W Server 210]

= FRemote room (5]
B Server 7 (8]

E Dizcovered Hosts (3]

1.1.201(3)

2.2.1  XNET

The higher node is called XNet as it represents the EVS XNet proprietary network.
Under this first level node, you must add one or more groups. These groups are
only virtual groups used for easy organization and management of multiple
servers.

2.2.2 GROUPS

To add a new group, right-click on the XNet node and select Add group, the only
available command. Enter a representative group name.

As this is only a virtual layout, we recommend that you organize the groups based
on physical localization of servers for easier management.

To remove a group, right-click on it and select the Remove command.

2.2.3 HOSTS

Once the groups are ready, you can add servers or hosts to them.

You can add hosts to XNet Monitor in two ways:

How TO ADD HOSTS MANUALLY

To add individual hosts manually, proceed as follows:

1. Right-click on a group and select the Add host command
2. Enter the host IP address in the Host Definition window.
- Host Definition M[=1E3
IP Address: 1.1.20.1

Once the hosts are entered in the list manually, you can organize them in the
different groups by drag and drop.
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2.2.4

How TO ADD HOSTS AUTOMATICALLY

1. Open the Tools menu and select Discover.

The Discover SNMP Agents window opens

Discover SNMP Agents

|P Start:

IP Stop: [172.16.255.255

Ping 172.16.0.4
Discovery Results
MNa IP Address Mame Type

2. In this window, set the start and stop IP addresses between which the
program will look for available servers and hosts

3. Click on the Start button to start the discovery process.

At the end of this process, the discovered hosts will be listed in a new group
called Discovered Hosts.

Once the hosts are entered through the discovery process, you can organize them
in the different groups by drag and drop.

@ Note
As this process is based on timeout for not used addresses, it may take
some time to parse a long list.

How TO REMOVE A HOST

You can only remove a host when the monitoring is not started.

To remove a host, right-click on it and select the Remove command.

SUMMARY INFORMATION

In the Hosts List pane, the bullet colour has the following meaning:
e Ared bullet means that there is a warning and/or an error on a host.

e A green bullet means that everything is ok for that item.

The number between brackets next to an item indicates the number of pending
SNMP alert messages.
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3. Monitoring

START MONITORING

Once servers and hosts have been added in the groups, the monitoring is started
by clicking on the Start command in the Monitoring menu.

To stop the monitoring once it is running, simply click on the Stop command in the
same Monitoring menu.

The monitoring status is available in the status bar at the bottom of XNet Monitor
window.

e Server 1.2.3.5 25/04/2005

Polling 1.1.20.1 (host 1/3) M

e 'Polling not started’ means that the monitoring has not been started yet since
the application launch.

e ‘Polling’ followed by IP address means status data are presently read from the
selected host MIB.

e ‘Waiting x/y sec’ indicates that the monitor is waiting for next polling process. It
has already been waiting for x seconds out of a total of y seconds (according to
related parameter setting).

e '‘Polling ended’ means that the monitoring has been stopped by the user. At
monitoring restart, hosts will be immediately polled and the waiting period will
be reset.

S%)} Note
At XNet Monitor start-up, the monitoring is always stopped and must be
started manually using the Start command.

CONFIGURATION

A few parameters can be set to configure display and monitoring according to your
needs.

APPLICATION SETTINGS

In the Settings command in the Tools menu, you can set following parameters:
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- Settings

# Local Clip Threshald: 4000

Rem. Cap. Threshold: 10 X

SHMP Paling Period: 300 Sec

SMMP Time Out: 3000 mSec

Enable Gigabit ICMP Paling:  []

ICHP Tirne Qut: 500 mSec

Enable Server Reboot: F

Enable SNMP Log: o

Server Log Target Directary ;| C:5Program FileshEWS Broadcast Equipment'Met [j
Parameter Description
# Local Clip When this number of clips is reached on a machine, a
Threshold message will be displayed to warn the user that a

cleaning and purge will soon be necessary on that
server.

Rem. Cap. Threshold

Same warning as the previous one but based on the
server remaining storage capacity.

SNMP Polling Period

Wait time between polling. A small period will guarantee
fast refreshing of data but will request high data flow on
the network while a long period will display less up-to-
date data but will reduce the load on the network.

SNMP Time Out

Delay after which a host will be considered as not
responding. An alert message will be displayed in the
event log if such an event happens for a monitored host.

The automatic discovery process total duration depends
on this parameter.

Enable Gigabit ICMP
Polling

Enables the pinging of the Servers GBE ports.

ICMP Time Out

Time Out for the pinging of the Servers GBE ports

Enable Server Reboot

If this option is enabled, XNet Monitor will be able to
initiate a reboot of any monitored server through the
Reboot command in the contextual menu opened by
right-clicking on a host in the Hosts List pane.

Enable SNMP Log

If this option is enabled, XNet Monitor will keep a log
file with all SNMP messages.
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Parameter Description
Server Log Target Path to the directory used to store the SNMP log files.
Directory

Click on the OK button once the parameters are properly configured for your
application.

DATA DISPLAY

When you select XNet or a group in the Hosts List pane, the Monitoring Data pane
displays a table with a number of columns. In this table, you will find summary
data about the servers available under XNet or under the selected group.

CUSTOMIZING THE DATA DISPLAY
You can specify which information should be displayed in the Monitoring Data

pane and how it should be displayed in the Select Columns window. To access
this window, select the in Organize Columns command from the Tools menu

= Select Columns E]@@

Awvailable columns SelectedColumns
A (Name |
Codec F SN
Comp. Bt Rate Multicam Version
Controller State
Default Gateway Genlock

Dik 0B | Do x|
Digk 0-C =
D:Sk 0o KMET Status

Disk 0-E Traffic

Digk 1-A DE Status
Disk 1-B Loc. Clips
Ciigh: 14C Fem. Capacity
Digk 1-0

Disk 1-E

Digk 2-A b’

The following actions are possible:

e To add a column to the display list, select it in the left Available columns list
and click on the Insert button.

e To remove a column from the table, select it in the right SelectedColumns list
and click on the Remove button.

e To change the columns order, select a column name in the right
SelectedColumns list and move it up or down in the list using the Up and Down
buttons respectively.

Click on OK once the columns are organized as desired.
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3.3

3.3.1

3.3.2

3.3.3

INFORMATION DISPLAY

The Monitoring Data pane displays the following information according to the
selected item in the Hosts List pane:

e A summary of underlying hosts if XNet or a group is selected.

o An empty table for the host SNMP parameters and their respective values if the
selected host is not a server.

e A specific parameters display table if the selected host is a server.

SUMMARY OF HOSTS DATA

If XNet or a group is selected, the Monitored Data pane displays a summary of
underlying hosts parameters as shown on the following figure.

The available columns are selected and organized in the Organize Columns
window available in the Tools menu.

Mame SH Multicam VYersion | State Genlock Analog LTC | Disk FsU #MET Statuz | Traffic DB 5t

Detected MotDetected | Digk 0-D... m

HoST SNMP DATA

Presently, if a host other than a server is selected, the Monitored Data pane will
not display any data other than the host IP address and name.

MName Data

SERVER MIB DATA

If a server is selected, the Monitored Data pane displays its MIB parameters in 3
tabs each displaying a specific table.

%} Note
If Multicam is not active and running on the selected server, most of the
parameter fields will be left blank.

STATUS TAB

In the Status tab, the main parameters are organized in several group boxes as
shown on the following figure.
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Status | Hardware || Codzs

General 10 Interfacing

Type: KT[2]BU Genlock: Detected

Serial Mumber: 29100 Analog LTC: [NotDetected |
Soft. Rev.: 10.01.31

State: Running

PSLI 0K

Storage

Type: Intemal PSL: /

Rem. Capacity: 02:17:42 [BBX] Fans: /

Norninal Capacity: | 03:20:05 Therrnal: oK

Raid

Raid ID Rebuild ReadRetry  ReadFailed  ‘Wiite Retry  Wiite Failed
/ D D D

Disk

|} State Cap [Gb] Temp("]  Model Rev. SH
00 EE" 43 M&XTOR AT.. |DFLO | B2301E3M
08 | Present |34 s} MaxTOR AT.. |DFLD | B2414RBM
0L |Present |34 e} MaxTOR AT.. |DFLD | B29024WM
00 |Present |34 a7 M&<TOR AT.. |DFLO | B29E0GHM
0E |Present |34 kil MaxTOR AT.. DFLD | BZ&l4<8M

Metwark,

SOTI NoRielay1485
et Marme: Server 2

Het Number: 2

Type: taster

Clip Edit No
AudicVideo

Video Channels: Tin Tout

Audio Channels: 4
Viden Std: 1080 PAL

Gigabit Connections 5 ettings

Mtpc
11.20.22

IP Mask. 256.266.0.0
Dief. gateway 1.1.201
Canroller b Protocol
Port CantrollerProtocol

ESRemaote
RS 422 #2 EVvSRemate
RS 422 43 EVSRemote
RS 422 #4 SoryBY W TE
RS 422 45 SongBYWWTE
RS 422 #1E TouchScresn

XNet Monitor V.1.00 — User Manual

Mb Clip:
Metwork. Clip:
DB State:
Conn. State:

Traffic State:

Codec:

CompEitFiate:

Ggbl
11.201

265, 255.0.0
1261.254 1

EVS Broadcast Equipment

1

222

ok
Cornected

Marmal

MIPEG_EWS
100 Mbps

Ggh2
1261.222
265,265, 255.0
1261.254 1

Cannection State

Connected
Defined
Defined
Defined
Defined
Defined

The different group boxes and their parameters are detailed hereafter.

General
Parameter Description
Type Server type: XT, XT[2]...

Serial Number

Server unique serial number

Soft. Rev. Server software revision
State Server state: running,
PSU State of the power supply unit

10 Interfacing

Parameter Description
Genlock Presence or absence of Genlock synchronization signal
Analog LTC Status of LTC (Longitudinal Time Code) analogue signal
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Storage
Parameter Description
Type Type of storage: internal or external

Rem. Capacity

Remaining capacity of the storage expressed as a video
duration (hours, minutes and seconds) as well as a
percentage

Nominal Capacity

Total capacity of the storage expressed as a video
duration (hours, minutes and seconds)

PSU Power supply unit(s) status

Fans Fans status

Thermal Temperature status of the system
Raid

Parameter Description

Raid ID RAID storage system identification
Rebuild System rebuild status during rebuild performing
Read Retry Number or read retries on the system
WriteRetry Number or write retries on the system
Disk

Parameter Description

ID Disk identification

State Disk status: present, disconnect...
Cap (Gb) Disk capacity in Ghytes.

Temp(°) Disk internal temperature

Model Disk manufacturer and model

Rev. Level Disk revision level

11
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Network

Parameter Description

SDTI SDTI (Serial Data Transport Interface) network type

Net Name Server name on the SDTI network

Net Number Server identification number on the SDTI network

Type Server type on the SDTI network: master, client, server

Clip Edit A clip is being transferred and edited or not

Nb Clip Number of clips stored on the server

Network Clip Total number of clips stored on the whole network

DB State Status of the database

Conn. State Status of the network connection

Traffic State Network traffic status

Audio-Video

Parameter Description

Video Channels Video channels configuration (number of in and out
channels)

Audio Channels Number of audio channels

Video Std Video standard used on the server ports

Codec Codec used for video digitalization and storage

CompBitRate Bit rate of compressed video data

Gigabit Connections Settings

Parameter Description

Mtpc Control board (MTPC) port
Gghl Gigabit port 1

Ggh2 Gigabit port 2

IP Address IP address of the interface port

12
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Parameter Description

IP Mask IP mask of the interface port

Def. gateway

Default gateway used by the interface port

Controller \ Protocol

Parameter Description

Port Server control port identification
Controller\Protocol Controller or protocol used on that port
Connection State Control port connection status

HARDWARE TAB

The Hardware tab lists the available modules and boards installed in the server
along with their respective version or revision number and their configuration

when relevant.

Status | Hardware | Codes

Mame

MTPLC Board

“Wersion

HCTx CPU Board

ld=021

HCTx CTL Module 1d=0%23, Jumpers=0:0F
COHX Base Board #0 1D=0:C2, IDE=0x0
COHX Base Board #1 1D=0:C2, IDE=0=0
COH Base Board #2 1D=0:C2, IDE=0x0
COH module #0 Fev=0xaZ, Feature=0xc3
COHx module #1 Rev=0:a2. Feature=0xc3
COHx module #2 Rev=0xa2, Feature=0xc3
COHX module #3 Rev=0za2, Feature=0xc3
COHx module #4 Fev=0xaZ, Feature=0xc3
COH module #5 Rev=0za2, Feature=0xc3
ACODEC 1d=0=E5, |de=0x04, |de2=0x00
GEE Rev=HCTH_GEE A41
Modules
Parameter Description
Name Server module type
Version Server module revision and additional parameters

13
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CODES TAB

The Codes tab lists the options codes activated on the server along with their
description.

Status | Hardware | Codes

Mumber Diescription A
_ configurations
3 Auythorize HD configurations
4 Authorize video configuration changes
5 Avid DMxHd[R] Codec
E Apple ProRes 422 Codec
7 Proxy Codec [Jpeq)
20 L5SM Hypermation
21 1080p Dual-Link.
23 30 Dual-Stream
90 #5 Open Canfig
91 5 0 PLAY
92 ®51PLAY v

SNMP ALERT MESSAGES

ALERT MESSAGES MANAGEMENT

The SNMP Messages pane displays the SNMP alert messages sent by the host or
groups of hosts selected in the Hosts List pane. These messages are displayed
until they are acknowledged by the user.

Stat Date: | Monday . Apil 27,2003 % | Filter Mgt Acknowledged - fick aler(s)

End D ate: Monday . Map 04,2003 W

Hosgt Hame Date filert mezzage
B/4/2009120412 ... Disk alert: state of digk Disk 0-D iz Disconnected
Server 2 B/A20097121412 0 Analog LTC MotD etected
Semver 2 4/29/2009 2:46:80 .. Analog LTC MotD etected
Server 2 4/28/2003171:32:28... Status: not running
Server 2 4272009 10:36:57 . Analog LTC MotD etected

ALERT MESSAGES DISPLAY

Use the calendar of the Start Date and End date drop-down fields to restrict the
displayed alerts list to the selected.

Use the Filter drop-down menu to select the alerts to be displayed:

o All: All alerts that occurred during the selected period are displayed.

e Acknowledged: Only alerts that already have been acknowledged are
displayed.

e Not Acknowledged: Only alerts that do not have been acknowledged yet are
displayed.
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ALERT MESSAGES ACKNOWLEDGEMENT

The alert acknowledgment function helps you to easily remove alert messages
from the displayed list once they have been visualized and/or taken care of.

Use the Ack alert(s) button to acknowledge the selected alerts. These alerts are
kept in the log file but are not displayed anymore (depending on the display filter
configuration).

SERVER LOGS EXTRACTION

To remotely recover the SNMP logs stored on a server, right-click on it in the
Hosts List pane and click Extract logs in the contextual menu.

The following warning message window is displayed to warn you that the
extraction process may interfere with the video diffusion from that server. Launch
the extraction process again later if you cannot accept any diffusion trouble at this
time.

Lops extraction

L] E The log extraction process may affect the diffusion on server Server 2, Are wou sure wou wank to proceed?
Ld

e I w ]

The next window displays progress bars of the extraction and the current directory
and file being downloaded.

Logs Extraction from Server 2 Z”E'E'

Directary /CALSMCEDATA/LDGY

D ownloading hardware. log

[= ]

Once the logs extraction is done, a window briefly appears about the log files
compression then the Logs Extraction window displays the zip file name and its
storing folder and path.

Logs Extraction

.
\y Logs files successfully extracted For Server 2, Available under C:\Program Files\EWS Broadcast Equipmentixiet MonitoriDownloaded logsi22100.zip

The different logged information (configuration, alerts...) is stored in different
folders and files and packed together in a zip file. Next to the zip files is a text file
(LogExtracion_servername. log) for each server that log the extractions
dates, operations, results and resulting zip file.

15
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%} Note
At log extraction, the log file on the remote server is closed and
transferred. After this operation, a new log file is created on the remote
server to log the events that happen from now on.

SERVERS SNMP CONFIGURATION

In the Tools menu, the Server configuration command opens the Server
Configuration window as shown below.

In this window, a table is displayed with all servers and for each of these, a list of
all IP addresses to which they send their SNMP trap messages. So, it is easy to
see which monitoring computer will receive any trap message.

Server Configuration
Server Configuration

Server Mame LocalP IPaddress 1 | IPAddress 2 IPAddress 3 | IPAddiess 4 | IPAddress & | |PAddress 6 | IPAddress 7 IPAddiess 8 | IPAddiess 9 | IPAddress 10

192168.1. 0.0.00 oooo 0noo 0ooo 0.0.00 0o.oo onoo 0000

IP Address: |1.1.20.104 | Remove
Add Local IP

Idle

| l

The Remove button allows removing the selected IP Address

The Add Local IP button allows adding the current XNet Monitor IP Address on
the monitored server.

The status line and progress bar at the bottom of the window display the currently
executed command and its progress status.

HOSTS LISTS MANAGEMENT

From the File menu, commands make it possible to manage the hosts and servers
list available in the Hosts List pane. This list is saved as an xml file for future use
and/or for transfer to another monitoring computer. This allows easy sharing and
management synchronization of servers and hosts tree organization.

The following commands are available in the File menu.

e New: To create a new virtual architecture from scratch.

e Open: To open an existing architecture saved as an xml file.
e Save: To save the currently open architecture xml file.

e Save as: To save the currently open architecture xml file as a new file.

Exit: To close and exit XNet Monitor program.



XNet Monitor V.1.00 — User Manual

Issue 1.00.B

EVS Broadcast Equipment

3.6

DISK USAGE

The Disk Usage pane displays a summary of the total used and remaining disk
space. This total is computed for all disks available on the server or group of
servers selected in the Hosts List pane.

A colour pie chart helps you to immediately visualize the disk usage of your
system. More precise figures are given over that pie chart, expressed as a used
and remaining video time in hours, minutes and seconds.

|lzed Capacity: 004042

Fem. Capacity: 01:34:29

17
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4. Server Update
and Reboot

XNet Monitor is a monitoring tool. Nevertheless it is able to remotely perform two
actions on any server if configured accordingly:

e Update the Multicam version on a server

e Reboot a server if necessary

MULTICAM UPDATE

To remotely update Multicam on one or several servers, proceed as follows:

1. Click on Installation in the Tools menu. The Installation window appears.

 Installation EI[E |g|
= ] AMet
=+ [] Control room Version: D

Server 1.1.20.1 jversion 10.01.28)
[ Server 1.2.3.4 {version 77}
[ Server 1.2.3.5 {version 77}

)

2. Select the server(s) to update in the left pane of the Installation window.

As a reminder, the currently installed Multicam version is displayed next to
each server.

3. In the Version field, browse your computer to select the new Multicam

installation zip file

4, Click on the Install button to start the installation process on all selected

Servers.
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4.2

S%)} Note
The Multicam installation zip file can be generated from the
makezip.bat file available with all Multicam installation packages.

SERVER REBOOT

To remotely reboot a server, right-click on it in the Hosts List pane and click
Reboot in the contextual menu.

The Server Reboot message window is displayed. You must confirm the reboot
process to start it on the remote host.

%‘,;;!ﬁ? Note
This command will be available only if the corresponding parameter is
enabled in the Settings window.
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Regional Contacts

AMERICA (NORTH & LATIN)

EVS Americas Tel: +1 973 575 7811 usa@evs.tv
Fax: +1 973 575 7812
Tech. line: +1 973 575 7813

EVS Canada Tel: +1 514 750 7544 usa@evs.tv

Fax: +1 514 750 7518
Tech. line: +1 973 575 7813

ASIA & PACIFIC

EVS Australia Tel: +61 02 9452 8600
Fax: +61 02 9975 1368
Mobile: +61 420 307 387

sales@evs-asia.com.hk

EVS China Tel: +86 10 6808 0248
Fax: +86 10 6808 0246
Tech. line: +86 139 1028 9860

evschina@evs.tv

EVS Hong-Kong Tel: +852 2914 2501
Fax: +852 2914 2505
Tech. line: +852 9401 2395

sales@evs-asia.com.hk

EVS India Tel: +91 22 6697 2999
Fax: +91 22 2673 2092
Mobile: +91 98 9017 5958

sales@evs-asia.com.hk

EUROPE, MIDDLE EAST & AFRICA

EVS Belgium Tel: +32 4 361 7000
Headquarters Fax: +32 4 391 7099
Tech. line: +32 495 284 000

support@evs.tv
sales@evs.tv
marketing evs.tv

EVS Brussels Tel : +32 2 421.78.78
Fax : +32 2 421.78.79

m.dewolf@evs.tv

EVS France Tel: +33 1 46 99 9000
Fax: +33 1 46 99 9009
Tech. line: +33 1 46 99 9003

france@evs.tv

EVS Iberica Tel: +34 91 490 3930
Fax: +34 91 490 3939
Tech. line: +34 91 490 3933

iberica@evs.tv

EVS Italy Tel: +39 030 296 400
Fax: +39 030 294 3650
Tech. line: +39 334 631 1493

italy@evs.tv
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EVS Middle East

Tel: +971 4 365 4222 middle-east@evs.tv
Fax: +971 4 425 3501
Mobile: +971 50 887 8758

EVS UK

Tel: +44 1372 387 250 uk@evs.tv
Fax: +44 1372 387 269
Tech. line: +44 1372 387 266

21



EVS Broadcast Equipment
Liege Science Park

16, rue Bois St Jean
B-4102 Ougrée
Belgium

Corporate North & Latin America
Headquarters Headquarters

+32 4 361 7000 +1 973 575 7811

Evs To learn more about EVS go to www.evs.tv

Asia & Pacific
Headquarters

+852 2914 2501

.”///

Instant Tapeless TechnOlogy

Other regional offices
available on

www.evs.tv/contact
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