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Information contained in this manual is believed to be accurate and reliable. However, Evertz assumes no responsibility for the use thereof nor 
for the rights of third parties, which may be effected in any way by the use thereof.  Any representations in this document concerning 
performance of Evertz products are for informational use only and are not warranties of future performance, either express or implied. The only 
warranty offered by Evertz in relation to this product is the Evertz standard limited warranty, stated in the sales contract or order confirmation 
form. 
 
Although every attempt has been made to accurately describe the features, installation and operation of this product in this manual, no 
warranty is granted nor liability assumed in relation to any errors or omissions unless specifically undertaken in the Evertz sales contract or 
order confirmation.  Information contained in this manual is periodically updated and changes will be incorporated into subsequent editions.  If 
you encounter an error, please notify Evertz Customer Service department. Evertz reserves the right, without notice or liability, to make 
changes in equipment design or specifications. 
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1. OVERVIEW 

The 7780R2x1-ASI-CS-2 is a complete hardware base solution for MPEG-2 feed redundancy 
switching. By providing automatic smart switching of the main signal to a back up signal, the 
7780R2x1-ASI-CS-2 offers protection to digital compressed signals. 
 
Controlled by the industry leading VistaLINK® PRO, the 7780R2x1-ASI-CS-2 offers signal providers the 
capability to design automatic redundancy into their system and alarm the operator the second a 
problem arises. By constantly monitoring the incoming signals, the 7780R2x1-ASI-CS-2 is capable of 
knowing when the signals reach a point where they are no longer suitable for broadcast and 
automatically switches to a backup feed. The user can customize all monitored and switching rules to 
meet Broadcast, Cable, Satellite and IPTV needs. 
 
Features: 

• Two automatic smart switches, each having 2 ASI inputs and 2 ASI outputs 
• Fully integrated with the Industry leading VistaLINK® PRO NMS system 

o TR101290 monitoring bitrate measurement and component matching test on all inputs 
o Smart configuration of error threshold and switching rules to avoid false switching 

• Delay of stream up to 3 seconds for perfect synchronization of incoming streams from different 
paths 

• Complete TS data rate measurement from 100Kb/s to 120Mb/s with user settable measurement 
window 

• Bitrate measurement on each PID 
• Display of Transport Stream tree 
• Matching of PID assignment, with predefined PID list and TSID 
• Complete customization of status view and error report in VistaLINK® PRO 
• Fits in 7700 Chassis 
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Figure 1-1: 7780R2X1-CS-2 Block Diagram 
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2. INITIAL 7780R2X1-CS-2 CONFIGURATION 

To successfully install the 7780R2x1-CS-2 you will need the following: 
 

1. Unused IP address on the network or a DHCP server. 
2. Evertz serial cable 
3. VLPro Server IP address 

 
This manual assumes that the VLPro installation has already been updated by the network 
administrator and the VLPro Client has been restarted. Refer to section 7 for further information if you 
are the Network Administrator. 
 
Locate, on a 7700 chassis, two adjacent vacant slots. Unpack the 7780R2X1-CS-2 and separate the 
rear card from the main card. Locate, on the rear of the rack, the two slots and remove the blanking 
panels. Insert the rear card into the back of the chassis and secure using the four screws provided.  
 
Before inserting the front card, connect the multi-coloured serial cable to the board using the serial 
cable provided. Now insert the 7780R2X1-CS-2I front card into the front slots ensuring the card lines up 
with the slot runners on the top and bottom of the chassis. Push the card into the slot ensuring that 
when it mates with the rear card that is has been firmly pushed into a seated position. The connectivity 
lights for the Ethernet port on the rear plate will illuminate to confirm that the card is properly inserted.  
Do not connect any cables to the rear card (failure to do this could cause unwanted network issues until 
the initial configuration has been completed). 
 
Connect the 9-pin d-type to the serial port of your computer. Open a Terminal session and configure 
your COM port for the following configuration: 
 

Bits per second: 115200 
Data Bits: 8 
Parity: None 
Stop Bits: 2 
Flow Control: None 

 
 
Apply these settings and return to the terminal window. Now press return, the session should respond 
by displaying the Main Menu.  
 
Now select option (1) Network Configuration. If you prefer to use DHCP then you may select option (5), 
otherwise and continue from step 4: 
 

1. Select option (1) Set IP Address and configure the IP address for the 7780R2X1-CS-2 ensuring 
that IP address is not already in use on the network.  

2. Now select option (2) Set Netmask and configure the correct subnet mask for your network.  
3. If required also configure option (3) Set Gateway.  
4. Exit from the Network Configuration menu using (S) Save and Exit, NOT (x) Exit. 

 
From the Main Menu select option (2) SNMP Configuration. It is normally only necessary to configure 
here, under option (1) Set Trap IP Address, enter the IP address of your VLPro Server.  Exit using 
option (S), now extract the card from the rack and re-insert it. 
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Note: In smaller systems it is not unusual for your VLPro Sever and Client to be 
on the same computer. 

 
Your initial setup is now complete. All other configuration can be performed through the VLPro Client. 
 

3. CONNECTING TO VLPRO 

Open VLPro and click on the refresh tree icon. Expand the hardware tree by clicking on the “+”. Your 
7780R2x1-CS-2 should appear as a newly listed device with the IP address used earlier to configure 
the card. It may take a few minutes to appear while the card and switch negotiate network settings (this 
can be verified directly on the switch if necessary). 
 

 

Note: If after a couple of minutes the card has still not appeared try selecting 
Add Agent from the Tree> Add/Update Agent menu. Enter the IP address used 
in the configuration stage earlier and select OK.  The card should now be listed 
and will remain greyed out for a moment while VLPro finds the card and 
confirms its configuration. 

 
Please consult your network administrator if you continue to have problems connecting the card with 
VLPro, alternatively contact Evertz Microsystems Ltd. or your authorized reseller for technical support. 
 

4. 7780R2X1-CS-2 OVERVIEW 

The 7780R2x1-CS-2 provides a means of switching between two identical ASI streams without any 
visual or audible interruptions to any of the channels in the stream. The part number 77880R2X1-CS-2 
refers to the dual switch version that provides two fully independent clean switches in one two-slot 
board for a standard 7700 3RU chassis. 
 
The board can operate in two different modes, Packet-matching or GOP boundary switching.  The 
packet-matching mode makes a clean switch by buffering and finding the same reference point in both 
streams. When a switch is initiated the stream input is seamlessly swapped. Downstream devices will 
not be able to detect this change and no interruption will occur on professional or consumer set top 
boxes. This mode is ideal for identical inputs from the same route source (the same mux). 
 
In GOP mode, the switch will wait for the end of the group of pictures and generate a switch on the next 
I frame to reduce the visual artefacts. Often the switch is very clean. Downstream devices will not 
display an outage that is often expected from ASI switches. However, some visual artefacting may be 
present. This mode is ideal for non-identical streams (exactly the same content from different muxes).  
 
Clean switching is still possible between the two streams even if one of them is delayed (maximum 3 
seconds per switch).  While it is possible to make manual (clean) switches for engineering works, the 
switch can be fully configured to respond to TR101 290 test conditions and each is fully independently 
custom configurable. This capability provides a rapid response clean switch to signals that may be 
beginning to break up or have begun to exceed the specified limitations of the tests. 
 
The 7780R2X1-CS-2 specifications are as follows:  
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General: 
3 Second buffer, per clean switch up to 213M/bs 
2 x RJ45 10/100/1000 Mb/s Ethernet port 
 
 
Inputs and Outputs per switch: 
2 x ASI Inputs 
 Min ASI TS Input bitrate – 100Kb/s 
 Max ASI TS Input bitrate – 213Kb/s 
2 x ASI Output 
 Min ASI TS output bitrate – 100Kb/s 
 Max ASI TS output bitrate – 213M/bs 
 
Monitored Parameters TR 101 290: 
1.1 TS_sync_loss 
1.2 Sync_byte_error 
1.3 Pat_error 
1.4 Continuity_count_error 
1.5 PMT_error 
 
2.1 Transport_error 
2.2 CRC_error 
2.3 PCR_error 
2.4 PCR_accuracy error 
2.5 PTS_error 
2.6 CAT_error 
 
 
Tables and Repetition: 
DVB SI repetition error (NIT, SDT, EIT, RST, TDT) 
ATSC PSIP tables repetition error (MGT,TVCT,CVCT,EIT,RRt, STT) 
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5. REAR PANEL CONNECTIONS 

The rear panel consists of eight BNC connectors and two Ethernet ports as shown below:  
 

 

 

ETHERNET:  The upper Ethernet port is for VLPro control and should be connected to the control 
network. Connection should only be made to the network once the initial IP configuration has 
been completed. 

 
The lower second Ethernet port is reserved for future use and should not be connected to the 
network. 

 
BNC GROUP A: The upper group of ports (group A) consists of the two inputs; left bottom and right 

bottom are inputs 1 and 2 respectively. The upper left port is the main output that is also bypass 
protected (the ASI input 1 is passed directly through in the event the card is extracted). The 
output to the right, labelled ASI OUT is a second output from the internal distribution amplifier. 
This output is lost when the card is extracted but is useful for monitoring purposes. 

 
BNC GROUP B:  The lower group of ports (group B) consists of the two inputs; left bottom and right 

bottom are inputs 1 and 2 respectively. The upper left port is the main output that is also bypass 
protected (the ASI input 1 is passed directly through in the event the card is extracted). The 
output to the right, labelled ASI OUT is a second output from the internal distribution amplifier. 
This output is lost when the card is extracted but is useful for monitoring purposes. 
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6. FRONT PANEL CONTROLS 

Located on the front of the card edge are the following controls and LED’s: 
 

1. User toggle switch (toggles up and down). 
2. Four (4) Character dot matrix display. 

a. This provides a convenient access to quick user functions, the menu can be started by 
pushing the push button, when ready to select your option press the push button again. 

b. Reset > Yes or no 
 

 
Note: Resetting the switch will cause an outage on both clean switches. 

 
c. Select> Switch 1 or Switch 2 

i. Select Input 1 or Input 2 
 

 

Note: It is only possible to make clean switches. The 7780 will switch as soon as 
the next switch point is found. It is not possible to make a forced manual 
switch. 

  
3. A set of LED’s to display the connectivity state of the Ethernet connections: 

a. D1 A red and a green LED indicating the health of the board. Red indicates that the 
board is in reset. A green LED is software controlled and should illuminate shortly after 
the board completes the booting. 

b. D2 indicates that the large FPGA chip has loaded successfully. It should distinguish 
shortly after the power is applied 

c. D11 & D12 are reserved for future use. 
d. D17, a red LED that indicates the small FPGA chip is loaded; this should turn off shortly 

after the power is applied. 
e. D23 Ethernet 0 10M/bs 
f. D24 Ethernet 0 100M/bs 
g. D25 Ethernet 0 1000M/bs 
h. D26 Ethernet 0 Duplex 
i. D27 Ethernet 0 Rx 
j. D28 Ethernet 0 Tx 
k. D23 Ethernet 1 10M/bs 
l. D24 Ethernet 1 100M/bs 
m. D25 Ethernet 1 1000M/bs 
n. D26 Ethernet 1 Duplex 
o. D27 Ethernet 1 Rx 
p. D28 Ethernet 1 Tx 
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7. TROUBLESHOOTING 

7.1. VLPRO DOES NOT DISPLAY THE 7780R2X1-CS-2 ALARMS 

Refer to section 1 to connect directly to the board via the serial port. Once a connection has been 
established check and/or configure the SNMP settings with the correct VLPro Server IP address and 
ensure the community strings are correctly set. Refer to the network administrator if you are in doubt as 
to what these should be set to. 

 

7.2. UPDATING VLPRO SERVER JAR FILE  

Products from Evertz are constantly evolving and new features are often added. It is therefore 
important to update the JAR files in use to provide access to all the latest features or enhancements. It 
will also be necessary to add JAR files for new products. If your new product has not appeared even 
after waiting a few minutes for the Ethernet switch negotiation to complete then it is possible that your 
JAR file may be old or missing. 

 
To perform a JAR update, ensure that all VLPro clients are closed (those clients which are not closed 
will automatically be disconnected as soon as the VLPro Server is restarted). Maximize the VLPro 
Server window from the Windows task bar, select Help> Apply Update> Product from the menu.  

 
A window will appear, as shown below, simply navigate to the location of the new JAR file and select 
the file by double clicking it. The window will automatically close and the update will be applied in the 
background.  

 
You will be prompted to restart the server to enable the change to take effect. Apply as many JAR 
updates as required before restarting the server. 

 

 
NOTE: You may confirm that all updates have been successfully applied by 
selecting from the menu Tools>View>Show/Hide Product update log. 

 
Now shutdown the server by selecting from the menu: File>Shutdown Server. Re-open the server, it is 
normal for the start-up to take marginally longer while each individual update is being applied. Once 
complete, you may restart the VLPro Clients. As the Client restarts you will experience a short delay 
while the update is applied. A prompt will appear confirming that the updates have been applied.
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8. ABBREVIATIONS 

For the purposes of the present document, the following abbreviations apply: 
 
BAT Bouquet Association Table 
BER  Bit Error Rate 
BW  BandWidth 
CA  Conditional Access 
CAT Conditional Access Table 
CPE Common Phase Error 
CRC  Cyclic Redundancy Check 
ETSI European Telecommunications Standards Institute 
DC  Direct Current 
DVB  Digital Video Broadcasting 
DVB-C  Digital Video Broadcasting baseline system for digital cable television (EN 300 429 [6]) 
DVB-CS  Digital Video Broadcasting baseline system for SMATV distribution systems (EN 300 473 

[13]) 
DVB-S  Digital Video Broadcasting baseline system for digital satellite television (EN 300 421 [5]) 
DVB-T  Digital Video Broadcasting baseline system for digital terrestrial television (EN 300 744 

[9]) 
EIT  Event Information Table 
ETR  ETSI Technical Report 
ETS  European Telecommunication Standard 
FEC  Forward Error Correction 
HEX  Hexadecimal 
ISO  International Organization for Standardization 
ITU  International Telecommunication Union 
MGT Master Guide Table 
MPEG  Moving Picture Experts Group 
NIT  Network Information Table 
PAT  Program Association Table 
PCR  Program Clock Reference 
PID  Packet Identifier 
PMT Program Map Table 
PSI  MPEG-2 Program Specific Information (as defined in ISO/IEC 13818-1 [1]) 
PSIP Program and System Information Protocol 
PTS  Presentation Time Stamps 
RS  Reed-Solomon 
RST  Running Status Table (see EN 300 468 [7]) 
RTE Residual Target Error 
SDT  Service Description Table 
SI  Service Information 
TDT  Time and Date Table 
TOT  Time Offset Table 
TS  Transport Stream 
UTC  Universal Time Co-ordinated 
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