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Section 10 – CP Input/Output Set Editor

The Control Panel Input/Output Set Editor (sometimes referred to as the “Active Editor”) allows special CP I/O Sets to be
created and downloaded to the VM/SI 3000 controller boards without using the Jupiter Configurator or the Control Center
(see Figure 10–1). Since the download is limited to these special sets, the download process occurs much more rapidly than
it would otherwise. Modifications such as assigning a new category/number to an input, or changing a mnemonic, can thus
be made without affecting on–air operation or taking the control system down. It is also possible to edit Category names.
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Figure 10–1.

The user first selects an existing CP I/O Set from the active configuration set, then creates a copy for exclusive use by the
CP I/O Set Editor. The copy is then modified and activated (downloaded). The set (or sets) are sent to the controller board’s
PMEM, overriding the current input or output sets.

Note 1: Saturn control panels are not supported by the CP I/O Set Editor, nor are the following control panel input/
outset set types: cp3310, mc3020D, mc3020L, serial, and cpsatrn.

Note 2: The CP I/O Set Editor does not support remote PC operation.

Since the modified set information is kept in PMEM, it will be preserved in the event of a power loss. However, it will be
lost if PMEM is cleared.

Important: Sets modified with the CP I/O Set Editor will no longer match those in the original Jupiter Configura-
tion Set. This creates a situation where, for example, Selected Set “config01” seen by the Jupiter Configurator does
not match Current Set “config01” seen by the Control Center. A good practice is to reconcile these sets as soon
as possible by using the Jupiter Configuration Editor to modify the original CP I/O Sets. This will avoid the poten-
tial confusion of having two versions of the same set.
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The CP I/O Set Editor is launched using the JNS Console, in the “JNS Applications” program group. (For more information
about the JNS Console, see Section 4.)

Note: If the application can’t find an active set, it will not start. Be sure you have selected a configuration set (as
described on page 5–10), and then compiled and activated the set (page 5–13).

PASSWORDS

When the CP I/O Set Editor is started, the system presents a log in dialog:

Figure 10–2.

— If the CP I/O Set Editor has never been run before, you must create an administrator Name. If you want to
create a Password, enter the password (up to eight characters) and press OK. Or, if you don’t want a password
established, just select OK.

— If you are logged in as the administrator, and want to add a new user, go to “Options > Passwords.” You will see
a list of all users. Note that the first person in the list (the administrator) is always assigned a security level of
“4.” Only those with a security level of 4 can add new users. As administrator, you can also delete users and
re–assign passwords.

— If you need a password, or forget your password, contact the administrator. If you are the administrator and
have forgotten the administrator password, contact Thomson Technical Support for assistance. (Rebooting or
re–installing software will not restore the password system to its original state.) For more information about
passwords, see page 10–8.

After entering the appropriate password, the main window is displayed (Figure 10–3). On entry, no set selected, and the main
window is empty. The “Edit Set” child windows will not appear until sets are selected for editing, or new ones created.

Figure 10–3.

DROP–DOWN MENUS

File

Select Edit Set – Allows the user to open (edit), delete, copy, and create new CP I/O Set Editor sets (see page 10–3).
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Select Group – Allows CP I/O Set Editor sets to be grouped and activated (downloaded) (see page 10–5).

Activate Sets – Can be used to activate individual CP I/O Set Editor sets (see page 10–7).

Close/Save – These options are only available when an set is open. “Save” makes the modified set information available for
activation.

Print Log – Allows the user to specify a log file to print (see page 10–7).

Print Setup – Standard Windows dialog for printer selection, etc.

Log In – Following a Log Out, allows a user to log in and use the CP I/O Set Editor (see page 10–8).

Log Out – Logs the user out of the CP I/O Set Editor (see page 10–8).

Exit

View

This displays the Input and Output Set Usage table (see page 10–11).

Options

Passwords – This menu displays the password window and allows an operator to add or delete users (see page 10–8).

Compare Sets – Allows the user to compare two sets and print the results (see page 10–9).

Generate Log – Toggles the generation of log entries (on/off) when sets are activated. This can only be changed by users with
level 4 privilege.

Check for duplicates – This option is only available when an edit set is open. Selecting this menu option checks the currently
active set for duplicate entries.

Settings – Shows the current user and allows setting the activation timeout interval and the session privilege level.

SELECTING A SET FOR EDITING AND DOWNLOAD

“File > Select Edit Set” brings up a menu similar to the following:

Figure 10–4.



JNS CP I/O Set Editor

10–4 VM 3000 Installation and Operating Manual

This dialog lists the sets that have been created for use with the CP I/O Set Editor (when first opened, the list will be empty.)
From here, you can edit existing sets, delete and copy sets, and create new sets.

To create a new set, select New. The following dialog is displayed:

Figure 10–5.

This table shows the CP I/O Sets that are in use by the active (“Current”) Set. (The name of the Current Set is shown in the
Control Center menu; the names of the CP I/O sets are shown on the MPK Devices table). To create a new set for the CP I/O
Set Editor, select a set, enter a Name, and select Create. The program will create a copy of the selected input or output set,
and then display an edit window for that set.

EDITING SETS

To edit an existing CP I/O Set Editor set, select a row on the Select Set menu, and select Edit. An example of a CP input set
is shown in Figure 10–6.

Figure 10–6.
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The Edit Set window for output sets is similar, except that the Category/Entry numbers are grayed out (cannot be changed).
The Level Set and Button assignments are shown but cannot be changed.

On an Input set table, selecting the Category field displays a drop–down list of categories; Entry numbers are typed in. The
Mnemonic column contains simple edit fields. The Input/Output field is a combo box that lists all switcher inputs or outputs.
You can select an input or output or type one.

There are two additional fields per row that are not contained in the active set: Password Level and Comment. The Password
Level ranges from 1 through 4, 1 being the default. The Password Level prevents users with lower passwords from changing
entries that are protected with a higher password level. (Password Levels are assigned in the Options menu; for more informa-
tion see page 10–8.) The Password Level drop–down list contains the numbers 1 through the level of the current user.

On Input sets only, you can insert new rows using the Insert key or the Insert Row command from the Edit menu, or, delete
rows with the Delete key or the Delete command.

To save the set(s), select “File > Save.” (This does not download the sets.)

EDITING CATEGORY NAMES

To change the name of a category or add a new category, select a set for editing, then go to “Edit > Edit Categories.” After
making the change, select OK.

Note: After you have selected “OK,” be sure to save the set using “File > Save.” If you close the set without saving,
further editing will be confusing because two versions of the category name will exist in the system. To correct
this situation, you must return to “Edit > Edit Categories” and re–enter the old name of the category (as shown
in the window with the name of the set in the upper left corner), then click OK; then return to “Edit > Edit Catego-
ries” and make the desired change.

CREATING AND ACTIVATING A GROUP OF SETS (SELECT GROUP)

In most cases, you will want to create an input set and an output set and manage them as a unit. For example, during a particular
show or production project you may want to use special mnemonics for sources and destinations.

The Group function allows you to group input and output sets and name the group (after the name of the project, for example).
Thus the sets can edited and activated together.

“File > Select Group” displays a window similar to the following (when first opened, the list will be empty):

Figure 10–7.
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To create a new group, select the New button. The following dialog is displayed:

Figure 10–8.

Enter a new name and select OK. The group will be created and the Edit Group dialog will be displayed (Figure 10–9).

Figure 10–9.

The left column shows all the CP input and output sets. The right–hand column shows all the sets in this group. To add sets
to the group, select one or more entries from the left–hand column and click the >> button. To remove sets, click on one or
more set names in the right column and click the << button. To select multiple sets, use standard Windows keys – Shift–click
or Ctrl–click.

To edit the sets in the group, select a group in the Select Group dialog and click the Edit Sets button. An edit window will
appear for each set in the group (see “Editing Sets” above).

To immediately activate (download) all the sets in a group, select the Activate button in the Select Group dialog. During this
process, the following dialog is then displayed:

Figure 10–10.

This dialog displays the names of all boards in the active set, and the status of the transfer. The status will display as follows:
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READY – The board has received the new control panel set, or the board does not need the set. The set will only
be sent to boards that require it.

NO MEMORY – The board has reported back that there is insufficient memory to download the selected sets. The
board will not be downloaded at this time.

UNKNOWN – The board is not responding. If a board has not responded within 15 seconds, this will change to
INACTIVE.

The OK button is disabled until the process has completed.

It is also possible to activate sets individually, as described below.

ACTIVATING (DOWNLOADING) A SINGLE SET

To activate individual input or output sets, go to “File > Activate Sets.”

Figure 10–11.

Select one or more “Replacement Set” fields and select a set name. Click the Activate button. The system will ask for verifica-
tion. If you elect to proceed, the information will be sent to the controller boards and a Sending Status display will appear
(as described on page 10–6).

LOGGING

After the sets are activated two log files will be written to the Jupiter/AppData/IOEdit directory. The first contains the set
names and group names. The second log file contains the actual sets that have been sent. Both files will have a date and time
stamp, along with the name of the user who did the activation as a header field, and will be comma delimited (CSV) for export-
ing to other applications. The name of the file will be the same, with the extension describing the log file type. The file names
will be:

Lxxxxxxx.nam

Lxxxxxxx.set

where xxxxxxx is a seven digit sequential number starting at 0000000, going to 9999999. These log files can be printed from
the “File” menu.
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LOG IN/LOG OUT

Logging In

The user must log into the system to be able to edit and activate sets and groups. When the user selects the “Log In” option
from the File menu, he will be prompted with the following dialog:

Figure 10–12.

The user will be required to enter his or her log in name and password. The system password level will be set to the user’s
password level.

Passwords are up to eight characters in length and can be any alphanumeric character. This includes special DOS filename
characters such as ‘*’, ‘\’, etc. The user will be prompted to enter a new password twice for validation purposes.

Logging Out

When the user logs out of the system, no changes can be made. The login screen will be displayed.

Without being logged into the system, the user can view the input and output usage tables. If the application is running and
no changes or activations have occurred within the last 15 minutes, the operator will have the option to stay logged in or auto-
matically log out. This option will be available for only 30 seconds. If there is no operator intervention, the system will log
out the user and the login window above will be displayed.

OPTIONS MENU

Passwords

The user logged in must have a password level of 4 to use all options available in this window. Otherwise the options will
be grayed out, indicating they cannot be selected. Any user will be able to change their own password; all other operations
are password level dependent. On validation of password level, the password table will be displayed:
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Figure 10–13.

The window contains a list of users and their password levels. Actual passwords are not displayed in this window. Each pass-
word is assigned a level 1 through 4. This level determines the entries in the table that the operator has authority to change.
Level 4 is the highest and can change any entry. Level 3 can change levels 1, 2, and 3. Level 2 can change levels 1 and 2, while
level 1 passwords can only change level 1 entries.

A level 4 user can add, delete, or change entries in the password table by selecting the entry and then the Add, Delete, or
Change buttons. Adding or changing entries will bring up the following window:

Figure 10–14.

This dialog contains a 20 character (maximum) name, an eight character (maximum) password, and a single digit level. Levels
are entered using a drop–down box.

Compare Sets

This option provides a comparison utility between two sets. The sets must be of the same type; i.e. both input sets or both
output sets. The Compare Sets window shown provides the user with a complete list of sets.
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Figure 10–15.

Highlight the two sets for the comparison and press the Compare button to start the comparison. The following comparison
window will be displayed:

Figure 10–16.

The comparison list shown puts the two sets together for scrolling purposes. Various highlight shadings are used to distinguish
between items added, changed, or deleted. Care will be taken to display only the changes made. However, if the files are out
of synchronization, the resulting list could be misleading.

To print the comparison results, select the Print button. Otherwise, when done, press the Close button. The system will return
to the previous menu to allow additional set comparisons.
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INPUT AND OUTPUT SET USAGE TABLES

Input/Output Set Usage, from the View menu, shows where inputs are and outputs are being used.

Figure 10–17.

This window is displayed when the user se-
lects an input. It displays all the control panel
input sets where the input is used.

ADDITIONAL NOTES

1. The CP I/O Set Editor does not know when a PMEM Clear is done on a controller board. This means that if there were
any edit sets on the board before the PMEM clear the editor still thinks they are on the board; therefore when the editor
is running and the pull–down menu “File > Activate Sets” is used to bring up the Activate Sets dialog, the Current Sets
list will not reflect the changes made by the PMEM Clear. The PMEM Clear causes the board to revert to the original
sets. If you want to force the Current Sets list to display the original sets, delete the server file “CurSets.dat.” This file
is found in the directory “jupiter\AppData\IOEdit\SetName\” where SetName is the current set that has been selected
with the Control Center (this file doesn’t get created until you successfully activate a set). Note that edit sets may span
boards and a PMEM Clear on just one board may cause the system to be in a state where the Current Sets list cannot
reflect the system.

2. Cut and paste in edit sets do not behave the same as in most applications:

� When a row is selected, Cut will only cut from the Entry, Mnemonic, and Comment columns.

� Paste Row does not automatically create a new row. To create a new row, a blank row must first be Inserted
and remain selected; then the copied (or cut) row can be pasted into the new row’s position.

� Certain columns (Input, Output, PW level, and Category [for input sets]) have drop down lists of valid values
for the cells in these columns. You cannot paste invalid values into the cells in these columns.


