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Overview

The HP 1910 Switch Series can be configured through the command line interface (CLI), Web interface,
and SNMP/MIB. These configuration methods are suitable for different application scenarios.

e The Web interface supports all 1910 Switch Series configurations.

e The Cll provides configuration commands to facilitate your operation. To perform other
configurations not supported by the CLI, use the Web interface.



Configuring the switch in the Web interface

Restrictions and guidelines

To ensure a successful login, verify that your operating system and Web browser meet the requirements,
and follow the guidelines in this section.

Operating system requirements

The device supports the following operating systems:
o Windows XP

o Windows 2000

o Windows Server 2003 Enterprise Edition

o Windows Server 2003 Standard Edition

o Windows Vista

o Linux

o MAC OS

If you are using a Windows operating system, turn off the Windows firewall. The Windows firewalll
limits the number of TCP connections. When the limit is reached, you cannot log in to the Web
inferface.

Web browser requirements

HP recommends that you use the following Web browsers:
o Internet Explorer 6 SP2 or higher

o Mozilla Firefox 3 or higher

o Google Chrome 2.0.174.0 or higher

If you are using a Microsoft Internet Explorer browser, you must enable the security settings (see
"Enabling securing settings in a Microsoft Internet Explorer browser"), including Run ActiveX
controls and plug-ins, Script ActiveX controls marked safe for scripting, and Active scripting.

If you are using a Moxzilla Firefox browser, you must enable JavaScript (see "Enabling JavaScript in a
Firefox browserEnabling JavaScript in a Firefox browser").

Enabling securing settings in a Microsoft Internet Explorer browser

1.
2,

Launch the Internet Explorer, and select Tools > Internet Options from the main menu.

Select the Security tab, and select the content zone where the target Website resides, as shown
in Figure 1.



Figure 1 Internet Explorer settings (1)
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3. Click Custom Level.

4. In the Security Settings dialog box, enable Run ActiveX controls and plug-ins, Script ActiveX
controls marked safe for scripting, and Active scripting.



Figure 2 Internet Explorer settings (2)
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5. Click OK to save your settings.
Enabling JavaScript in a Firefox browser

1. Launch the Firefox browser, and select Tools > Options.

2. In the Options dialog box, click the Content icon, and select Enable JavaScript.



Figure 3 Firefox browser settings
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Click OK to save your settings.

The Web interface does not support the Back, Next, and Refresh buttons provided by the browser.
Using these buttons might result in abnormal display of Web pages.

To ensure correct display of Web page contents after software upgrade or downgrade, clear data
cached by the browser before you log in.

If you click the verification code displayed on the Web login page, you can get a new verification
code.

Up to five users can concurrently log in to the device through the Web interface.
A list can contain a maximum of 20000 entries if displayed in pages.

The PC where you configure the device is not necessarily a Web-based network management
terminal. A Web-based network management terminal is a PC used to log in to the Web interface
and is required to be reachable to the device.

After logging in to the Web interface, you can select Device > Users from the navigation tree, create
a new user, and select Wizard or Network > VLAN interface to configure the IP address of the
VLAN interface acting as the management interface. For more information, see the corresponding
configuration guides of these modules.



Overview

The device provides web-based configuration interfaces for visual device management and
maintenance.

Figure 4 Web-based network management operating environment
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Logging in to the Web interface

You can use the following default settings to log in to the web interface through HTTP:
e Username—admin
e Password—None

e IP address of VLAN-interface 1 on the device—IP address of the device, depending on the status of
the network where the device resides.

o If the device is not connected to the network, or no DHCP server exists in the subnet where the
device resides, you can get the IP address of the device on the label on the device. IP address
is 169.254 xxx.xxx. If the MAC address is 08004E000102, the IP address would be
169.254.1.2.

o If a DHCP server exists in the subnet where the device resides, the device will dynamically
obtain its IP address through the DHCP server.

You can log in to the device through the console port, and execute the summary command to view the
information about its IP address.

<Sysname> summary

Select menu option: Summary

IP Method: DHCP

IP address: 169.254.1.2
Subnet mask: 255.255.0.0
Default gateway: 0.0.0.0
<Omitted>

Assuming that the IP address of the device is 169.254.1.2, to log in to the Web interface of the device
from a PC:

1. Connect the Ethernet interface of the device to a PC by using a crossover Ethernet cable. By default,
all interfaces belong to VLAN 1.

2. Configure an IP address for the PC and make sure that the PC and device can reach each other.

For example, assign the PC an IP address (for example, 169.254.1.27) within 169.254.0.0/16
(except for the IP address of the device).

3. Open the browser, and input the login information.
a. Type the IP address http:// 169.254.1.2 in the address bar and press Enter.

The login page of the web interface (see Figure 5) appears.



b. Enter the username admin and the verification code, leave the password blank, and click
Login.
Figure 5 Login page of the Web interface
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Logging out of the Web interface

/\ CAUTION:
* You cannot log out by directly closing the browser.

o For security purposes, log out of the Web interface after you finish your operations.

1. Save the current configuration.

Because the system does not save the current configuration automatically, HP recommends that
you perform this step to avoid loss of configuration.

2. Click Logout in the upper-right corner of the Web interface.

Web interface

The Web interface includes three parts: navigation tree, title area, and body areq, as shown in Figure 6.



Figure 6 Web-based configuration interface
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Apr26 13:37:47:689 2000 Information Service=login- T
UserName=admin@system; AAA launched. ' R LR
-AAATYDe=AUTHOR-A%ASChemes= local- LEVEETE
Apr 26 13:37.47.688 2000 Information Sernvice=login- 0 Hardware Version
UserName=admin@systermn; AAA is successiul. REV.A
-AAAType=AUTHOR-AAASCheme= local-
Apr 26 13-37-47°688 2000 Information  Senice=login- ¢ T EEDT
UserName=admin@system; A4 launched. 105
@, Running Time:
Odays1h 37 minutes 33
More Logs On Devicelore.. @ sec?:ds OUIS SEmindiEs
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e Navigation tree—Organizes the Web-based NM functions as a navigation tree, where you can
select and configure functions as needed. The result is displayed in the body area.

e Body area—Allows you to configure and display features.

o Title area—On the left, displays the path of the current configuration interface in the navigation
area; on the right, provides the Save button to quickly save the current configuration, the Help button
to display the Web-related help information, and the Logout button to log out of the Web interface.

Web user level

Web user levels, from low to high, are visitor, monitor, configure, and management. A user with a
higher level has all the operating rights of a user with a lower level.

e Visitor—Users of this level can only use the network diagnostic tools ping and Trace Route. They
can neither access the device data nor configure the device.

e Monitor—Users of this level can only access the device data but cannot configure the device.

o  Configure—Users of this level can access device data and configure the device, but they cannot
upgrade the host software, add/delete/modify users, or backup/restore configuration files.

e Management—Users of this level can perform any operations to the device.

Web-based NM functions

User level in Table 1 indicates that users of this level or users of a higher level can perform the
corresponding operations.



Table 1 Web-based NM function description

Function menu Description User level
Wizard IP Setup Perform quick configuration of the device. Management
Display global settings and port settings of a stack. ~ Configure
Setup
Configure global parameters and stack ports. Management
Stack Topology . .
Summary Display the topology summary of a stack. Configure
Device Display the control panels of stack members. Configure
Summary
System Display the basic system information, system Monitor
Information resource state, and recent system operation logs.
Summary
Device . . . . .
. Display the port information about the device. Monitor
Information
System Name  Display and configure the system name. Configure
Basic Web Idle Display and configure the idle timeout period for .
: . Configure
Timeout logged-in users.
Software Upload upgrade file from local host, and upgrade Management
Upgrade the system software.
Device Reboot Reboot the device. Management
Maintenanc i
e Electronic Display the electronic label of the device. Monitor
Label
Diagnostic Generate diagnostic information file and view or Management
Information save the file to local host. 9
System Time Display and configure the system date and time. ~ Configure
System Time : -
Net Time Display the syn.chronlzohon status of the system Monitor
clock and configure the network time.
Display and refresh system logs. Monitor
Devi Loglist
ce Clear system logs. Configure
Syslog Loghost Display and configure the loghost. Configure
log Sefup Plsploy and conflgure the buffer capacity and Configure
interval for refreshing system logs.
Back up the configuration file to be used at the next
Backup startup from the device to the host of the current Management
user.
. . Upload the configuration file to be used at the next
Configurati  Restore startup from the host of the current user to the Management
on device.
Sav Save the current configuration to the configuration Confiqur
ave file to be used at the next startup. ontigure
Initialize Restore the factory default settings. Configure
File File Manage files on the device, such as displaying the
Manageme file list, downloading a file, uploading a file, and ~ Management
Management X .
nt removing a file.
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Function menu Description User level
Summary Display port information by features. Monitor
Port . . . . .
Manageme Detail Display feature information by ports. Monitor
nt Create, modity, delete, and enable/disable a port, .
Setup . Configure
and clear port statistics.
Summary Dlisplo.y the configuration information about a port Monitor
mirroring group.
Port Add Create a port mirroring group. Configure
Mirroring
Remove Remove a port mirroring group. Configure
Modify Port Configure ports for a mirroring group. Configure
Summary Display the brief information about FTP and Telnet Monitor
users.
Configure a password for a lower-level user to
Super .
switch from the current access level to the Management
Password
management level.
Users Create Create an FTP or Telnet user. Management
Modify Modify FTP or Telnet user information. Management
Remove Remove an FTP or a Telnet user. Management
Switch To Switch the current user level to the management -
Visitor
Management  level.
Loopback Loopback Perform loopback tests on Ethernet interfaces. Configure
VCT VCT Check the status of the cables connected to Ethernet Configure
ports.
Flow Port Traffic Dlsp!ay the average rate at whncih the mk?r'foce. .
- receives and sends packets within a specified time  Monitor
Interval Statistics .
interval.
Statistics Dlsplgy, create, modify, and clear RMON Configure
statistics.
History SD;flclxi)rl], Cir:gj;;?;ilfy' and clear RMON history Configure
RMON P :
Alarm Display, create, modify, and clear alarm entries.  Configure
Event Display, create, modify, and clear event entries. Configure
Log Display log information about RMON events. Configure
Energy Energy Saving DlsPloy and configure the energy saving settings of Configure
Saving an interface.

10



Function menu Description User level
Dlsplqy qnd refre.sh SNMP configuration and Monitor
Setup statistics information.
Configure SNMP. Configure
Display SNMP community information. Monitor
Community
Create, modify, and delete an SNMP community.  Configure
Display SNMP group information. Monitor
Group
Create, modify, and delete an SNMP group. Configure
SNMP Display SNMP user information. Monitor
User
Create, modify, and delete an SNMP user. Configure
Plsplay The status of the SNMP trap function and Monitor
information about target hosts.
Trap
Enable or disable the SNMP trap function; create, Conficure
modify, and delete a target host. 9
Display SNMP view information. Monitor
View
Create, modify, and delete an SNMP view. Configure
Interface Interface Display and clear the statistics information about .
- - i Configure
Statistics Statistics an interface.
Net  VLAN Select VLAN Select a VLAN range. Monitor

11



Function menu Description User level
Create Create VLANS. Configure
Port Detail Display the VLAN-related details of a port. Monitor
: Display the member port information about a .
Detail VIAN. Monitor
Modify VIAN Modify the description and member ports of a Configure
VLAN.
Modify Port Change the VLAN to which a port belongs. Configure
Remove Remove VLANE. Configure
Summary Display voice VLAN information globally or on a Monitor
port.
Setup Configure the global voice VLAN. Configure
Port Setup Configure a voice VLAN on a port. Configure
Voice VIAN Display the addresses of the OUls that can be .
OUI Summary identified by voice VLAN. Monifor
Add the address of an OUI that can be identified .
OUI Add by voice VIAN. Configure
Remove the address of an OUI that can be :
OUI Remove identified by voice VLAN. Configure
Summary Display information about VLAN inferfaces by Monitor
address type.
Creat Create VLAN interfaces and configure IP addresses Coni
VIAN reate for them. onfigure
Interface " f
Modify Modl y the IP addresses and status of VLAN Configure
interfaces.
Remove Remove VLAN interfaces. Configure
Display MAC address information. Monitor
MAC
MAC Create and remove MAC addresses. Configure
Setup Display and configure MAC address aging time. ~ Configure
Display information about MST regions. Monitor
Region
Modify MST regions. Configure
MSTP Global Set global MSTP parameters. Configure
Port Summary  Display the MSTP information about ports. Monitor
Port Setup Set MSTP parameters on ports. Configure
Summary Display information about link aggregation Monitor
groups.
Link
Aggregatio Create Create link aggregation groups. Configure
n Modify Modify link aggregation groups. Configure
Remove Remove link aggregation groups. Configure

12



Function menu Description User level
Summary Dlsplay information about LACP-enabled ports and Monitor
LACP their partner ports.
Setup Set LACP priorities. Configure
Display the LLDP configuration information, local
information, neighbor information, statistics Monitor
Port Sefup information, and status information about a port.
Modify LLDP configuration on a port. Configure
Display global LLDP configuration information. Monitor
LLDP Global Setup
Configure global LLDP parameters. Configure
Global Display global LLDP local information and statistics.  Monitor
Summary
Neighbor . . . . .
Summary Display global LLDP neighbor information. Monitor
Display ARP table information. Monitor
ARP Table
ARP Add, modify, and remove ARP entries. Configure
:\]/t\cncgeme Displgy th;;c;nfigurotion information about Monitor
Gratuitous ARP _gratuitous ARP.
Configure gratuitous ARP. Configure
ARP . Display ARP detection configuration information.  Monitor
Anti-Attack ARP Detection _ _ .
ni-Aflac Configure ARP detection. Configure
Display global IGMP snooping configuration
information or the IGMP snooping configuration Monitor
Basic information in a VLAN, and the IGMP snooping onto
multicast entry information.
IGMP
Snooping Configure IGMP snooping globally or in a VLAN.  Configure
Plsplay The IGMP snooping configuration Monitor
Advanced information on a port.
Configure IGMP snooping on a port. Configure
Display global MLD snooping configuration
information or the MLD snooping configuration Monitor
Basic information in a VLAN, and the MLD snooping onte
multicast entry information.
MLD
Snooping Configure MLD snooping globally or in a VLAN.  Configure
Plsplay The MLD snooping configuration Monitor
Advanced information on a port.
Configure MLD snooping on a port. Configure
Summary Display the IPv4 active route table. Monitor
IPv4 Routing  Create Create an IPv4 static route. Configure
Remove Delete the selected IPv4 static routes. Configure
Summary Display the IPv6 active route table. Monitor
IPv6 Routing
Create Create an IPv6 static route. Configure

13



Function menu Description User level
Remove Delete the selected IPv6 static routes. Configure
Display information about the DHCP status,
advanced configuration information about the
DHCP relay agent, DHCP server group Monitor
configuration, DHCP relay agent interface
DHCP Relay configuration, and the DHCP client information.
Enable/disable DHCP, configure advanced DHCP
DHCP relay agent settings, configure a DHCP server Confiqure
group, and enable/disable the DHCP relay agent 9
on an interface.
Display the status, trusted and untrusted ports and Monitor
DHCP DHCP client information about DHCP snooping. !
Snooping Enable/disable DHCP snooping, and configure Confiqure
DHCP snooping trusted and untrusted ports. 9v
Display the states of services: enabled or disabled. ~ Configure
Service Service Enable/disable services, and set related
Management
parameters.
IPv4 Ping Ping an IPv4 address. Visitor
IPvé Ping Ping an IPv6 address. Visitor
Diagnostic
Tools 'll't\;ieroufe Perform IPv4 trace route operations. Visitor
Py Perform IPv6 trace route operations. Visitor
Traceroute
MAC MAC Plfsplay MAC authentication configuration Monitor
Authenticati o information.
Authentication
on Configure MAC authentication. Configure
Display 802.1X configuration information globally Monitor
802.1X 802.1X or on a port.
Configure 802.1X globally or on a port. Configure
Display port security configuration information. Monitor
Port Security  Port Security
Configure port security. Configure
Auth Display ISP domain configuration information. Monitor
. Domain Setup
entic Add and remove ISP domains. Management
ation
Plsplay The authentication conflgurohon Monitor
Authentication  information about an ISP domain.
Specify authentication methods for an ISP domain.  Management
AAA Display the authorization method configuration Monitor
Authorization  information about an ISP domain.
Specify authorization methods for an ISP domain.  Management
Plsplay The accounting method .conflgurcmon Monitor
Accounting information about an ISP domain.
Specify accounting methods for an ISP domain. Management

14



Function menu Description User level
RADIUS Server  Display and configure RADIUS server information.  Management
RADIUS
RADIUS Setup  Display and configure RADIUS parameters. Management
Display configuration information about local Monitor
Local User users.
Create, modify, and remove a local user. Management
Users o - - ] b
Display contiguration information about user Monitor
User Group groups.
Create, modify, and remove a user group. Management
Display information about PKI entities. Monitor
Entity
Add, modify, and delete a PKI entity. Configure
Display information about PKI domains. Monitor
Domain
Add, modify, and delete a PKI domain. Configure
Certificate Display the certificate information about PKI Monit
Manageme domains and the contents of a certificate. ontor
nt o
Certificate Generate a key pair, destroy a key pair, retrieve a
certificate, request a certificate, and delete a Configure
certificate.
Display the contents of the CRL. Monitor
CRL
Receive the CRL of a domain. Configure
Port Isolate ~ Summary Display port isolation group information. Monitor
Group Port Setup Configure the ports in an isolation group. Configure
Display the configurations of authorized IP, the
Secu  Authorized Summary associated IPv4 ACL list, and the associated IPv6 ~ Management
. P ACL list.
rity
Setup Configure authorized IP. Management
Loopback Loopback Dlsrplrc;y tc::d cnc;lnflgLrJtrT sysi)eml(lodop:bc:Fkndetecilon ot
Detection Detection parameters and port loopback detectio onfigure
parameters.
Summary Display time range configuration information. Monitor
Time Range  Create Create a time range. Configure
Remove Delete a time range. Configure
Summary Display IPv4 ACL configuration information. Monitor
Create Create an IPv4 ACL. Configure
QoS Basic Setup Configure a rule for a basic IPv4 ACL. Configure
ACL IPv4
?:I;L/;nced Configure a rule for an advanced IPv4 ACL. Configure
Link Setup Create a rule for a link layer ACL. Configure
Remove Delete an IPv4 ACL or its rules. Configure
ACL IPvé Summary Display IPv6 ACL configuration information. Monitor
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Function menu Description User level
Create Create an IPvé ACL. Configure
Basic Setup Configure a rule for a basic IPv6 ACL. Configure
?;\L/Jc:)nced Configure a rule for an advanced IPvé ACL. Configure
Remove Delete an IPvé ACL or its rules. Configure
Summary Display the queue information about a port. Monitor
Queue
Setup Configure a queue on a port. Configure
Summary Display line rate configuration information. Monitor
Line Rate
Setup Configure the line rate. Configure
Summary Display classifier configuration information. Monitor
Create Create a class. Configure
Classifier
Setup Configure the classification rules for a class. Configure
Remove Delete a class or its classification rules. Configure
Summary Display traffic behavior configuration information.  Monitor
Create Create a traffic behavior. Configure
Behavior Setup Configure actions for a traffic behavior. Configure
Port Setup Conﬂgurg traffic mirroring and traffic redirecting Configure
for a traffic behavior
Remove Delete a traffic behavior. Configure
Summary Display QoS policy configuration information. Monitor
Create Create a QoS policy. Configure
QoS Policy ey Configure the classifier-behavior associations for a Confiqure
P QoS policy. ¢
Remove Deletg a QoS policy or its classifier-behavior Configure
associations.
Summary Display the QoS policy applied to a port. Monitor
Port Policy ~ Setup Apply a QoS policy to a port. Configure
Remove Remove the QoS policy from the port. Configure
Priority Priority Display priority mapping table information. Monitor
Mapping Mapping Modity the priority mapping entries. Configure
Display port priority and trust mode information. ~ Monitor
Port Priority  Port Priority
Modify port priority and trust mode. Configure
Summary Plsplcuy !’SE information and PoE interface Monitor
information.
PoE  PoE PSE Setup Configure a PoE interface. Configure
Port Setup Configure a port. Configure
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Common items on the Web pages

Buttons and icons

Table 2 Commonly used buttons and icons

Button and icon

Function

Bpply Applies the configuration on the current page.
Cancel Cancels the configuration on the current page.
Refresh Refreshes the current page.
Clear Clears all entries in a list or all statistics.
A Adds an item.
Remuove )
! Removes the selected items.
Del Selected
Selact All Selects all the entries in a list.
Selact Mone Clears selection of all entries in a list.
— Buffers but does not apply the configuration of the current step, and enters
= the next configuration step.
I Buffers but does not apply the configuration of the current step, and returns
At to the previous configuration step.
Finish Applies the configurations of all configuration steps.
=N Enters the modification page of an item so that you can modify the
=

configurations of the item.

Deletes the item corresponding to this icon.

Page display function

The Web interface can display contents by pages, as shown in Figure 7. You can set the number of
entries displayed per page, and view the contents on the first, previous, next, and last pages, or go to any
page that you want to check.

17



Figure 7 Content display by pages

=N Port Name v  Search | advanced Search
[ Port Mame LLDOP Status LLDOP Work Mode Operation
[C] Ethernet1/0/ Enabled TxRx
[C] Ethernet1/0/2 Enabled TxRx
[] Ethernet1/0/3 Enabled TxRx
[] Ethernet1/0/4 Enabled Tx
[T] Ethernet1/0/5 Enabled TxRx
[T] Ethernet1/0/5 Disabled Rax
[T] Ethernet1/0/7 Dizabled TxRx
[T] Ethernet1/0/8 Disabled TxRx
[] Ethernet1/0/9 Disabled TxRx
[] Ethernet1/0/10 Enabled Rax
[] Ethernet1/0/11 Enabled TxRx
[] Ethernet1/0/12 Enabled TxRx
[] Ethernet1/0/13 Disabled Tx
[] Ethernet1/0/14 Enabled Tx
[] Ethernet1/0/15 Disabled TxRx
26 records, 15~ per page | page 1/2, record 1-15 | Mext Last GO

Search function
The Web interface provides you with the basic and advanced searching functions to display only the
entries that match specific searching criteria.

e Basic search—As shown in Figure 7, type the keyword in the text box above the list, select a search
item from the list and click Search to display the entries that match the criteria. Figure 8 shows an
example of searching for entries with LLDP disabled.

Figure 8 Basic search function example

[Disabled LLDP Status - | Advanced Search

| Port Name LLDP Status LLDP Work Mode Operation

[ Ethernet1i0/s Disabled Rux

[ Ethernet1i0/7 Disabled TxRx

[7] Ethernet1/0/8 Disabled TxRx

[7] Ethernet1/0/9 Disabled TxRx

[7] Ethernet1/0M13 Disabled Tx

[[] Ethernet1/015 Disabled TxRx
6records, 15~ per page | page 111, record 1-6 | 1 GO

e Advanced search—As shown in Figure 9, you can click the Advanced Search link to open the
advanced search area. Specify the search criteria, and click Apply to display the entries that match
the criteria.

18



Figure 9 Advanced search

Advanced Search

Port Mame -

@ And O Or

Match Case
Search inthe result

Apply Zancel

Take the LLDP table shown in Figure 7 as an example.

To search for the LLDP entries with LLDP Work Mode TxRx, and LLDP Status Disabled:

1. Click the Advanced Search link, specify the search criteria on the advanced search page as shown
in Figure 10, and click Apply. The LLDP entries with LLDP Work Mode being TxRx are displayed.

Figure 10 Advanced search function example (1)

Advanced Search

LLDP Waork Mode -

Equal to -  TuwRx
@ And O Or

Match Case
Search inthe result

Apply Zancel

2. Click the Advanced Search link, specify the search criteria on the advanced search page as shown

in Figure 11, and click Apply. The LLDP entries with LLDP Work Mode being TxRx and LLDP Status
being Disabled are displayed as shown in Figure 12.

Figure 11 Advanced search function example (2)

Advanced Search

LLDP Status -

Equal to -~ Disabled
@ And O Or

Match Case
Search inthe result

Apply Zancel
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Figure 12 Advanced search function example (3)

}O\ LLDP Status - | Search | advanced Search

1 Port Mame LLDP Status LLDP Work Mode Operation
[] Ethernet1/0/7 Disabled THRx

[[] Ethernet1/0/8 Disabled TxRx

[[] Ethernet1/0/9 Disabled T#Rx

[T] Ethernet1/0M15 Disabled TxRx

Sort function

On some list pages, the Web interface provides the sorting function to display the entries in a certain
order.

The Web interface provides you with the sorting functions to display entries in certain orders.

On a list page, you can click the blue heading item of each column to sort the entries based on the
heading item you selected. After your clicking, the heading item is displayed with an arrow beside it as
shown in Figure 13. The upward arrow indicates the ascending order, and the downward arrow
indicates the descending order.

Figure 13 Sort display

=N Port Name ~ | Search | Advanced Search

[ Port Mame LLDOP Status LLDP Work Modet Operation

[C] Ethernet1/0/6 Disabled R

[[] Ethernet1/0/10 Enabled R

[[] Ethernet1/0/13 Disabled Tx

[[] Ethernet1/0/4 Enabled Tx

[C] Ethernet1/0/14 Enabled Tx

[T] Ethernet1/0/7 Disabled TxRx

[T] Ethernet1/0/8 Disabled TxRx

[T] Ethernet1/0/9 Disabled TxRx

[T] Ethernet1/0/15 Disabled TxRx

[T] Ethernet1/0M Enabled TxRx

[T] Ethernet1/0/2 Enabled TxRx

[] Ethernet1/0/3 Enabled TxRx

[T] Ethernet1/0/5 Enabled TxRx

[] Ethernet1/0/11 Enabled TxRx

[] Ethernet1/0/12 Enabled TxRx
26records, 15~ perpage | page 1/2, record 1-15 | Mext Last GO
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Configuring the switch at the CLI

The HP 1910 Switch Series can be configured through the CLI, Web interface, and SNMP/MIB, among
which the Web interface supports all 1910 Switch Series configurations. These configuration methods are
suitable for different application scenarios. As a supplementary to the Web interface, the CLI provides
some configuration commands to facilitate your operation, which are described in this chapter. To
perform other configurations not supported by the CLI, use the Web interface.

You will enter user view directly after you log in to the device. Commands in the document are all
performed in user view.

Getting started with the CLI

As a supplementary to the Web interface, the CLI provides some configuration commands to facilitate
your operation. For example, if you forget the IP address of VLAN-interface 1 and cannot log in to the
device through the Web interface, you can connect the console port of the device to a PC, and
reconfigure the IP address of VLAN-interface 1 at the CLI.

This section describes using the CLI to manage the device.

Setting up the configuration environment

To set up the configuration environment, connect a terminal (a PC in this example) to the console port on
the switch with a console cable.

A console cable is an 8-core shielded cable, with a crimped RJ-45 connector at one end for connecting
to the console port of the switch, and a DB-9 female connector at the other end for connecting to the
serial port on the console terminal.

Figure 14 Console cable

A side

T Pos.9 Main label

B side

Use a console cable to connect a terminal device to the switch, as follows:
1. Plug the DB-9 female connector to the serial port of the console terminal or PC.

2. Connect the RJ-45 connector to the console port of the switch.

/\ CAUTION:

Identify the mark on the console port to make sure that you are connecting to the correct port.
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NOTE:

The serial port on a PC does not support hot swapping. When you connect a PC to a powered-on switch,
connect the DB-9 connector of the console cable to the PC before connecting the RJ-45 connector fo the
switch.

When you disconnect a PC from a powered-on switch, disconnect the DB-9 connector of the console
cable from the PC after disconnecting the RJ-45 connector from the switch.

Setting terminal parameters

To configure and manage the switch, you must run a terminal emulator program on the console terminal.

The following are the required terminal settings:

Bits per second— 38,400

Data bits—8
Parity—None
Stop bits— 1

Flow control —None
Emulation—VT100

To set terminal parameters, for example, on a Windows XP HyperTerminal:

1.

Select Start > All Programs > Accessories > Communications > HyperTerminal.
The Connection Description dialog box appears.
Enter the name of the new connection in the Name field and click OK.

Figure 15 Connection description

Connection Description ﬂﬁl

Enter a name and chooze an icaon far the connection:

Marme;
ISwitcH

lzan:

Select the serial port to be used from the Connect using list, and click OK.
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Figure 16 Setting the serial port used by the HyperTerminal connection

& Suitch

Enter detailz for the phone number that you want bo dial:

Countryregion; ILlniteu:I States of Amernca 1] j

Area code; mo

Phone number; I

Connect using:
k. I Cancel |

4. Set Bits per second to 38400, Data bits to 8, Parity to None, Stop bits to 1, and Flow control to
None, and click OK.

Figure 17 Setting the serial port parameters

Port Settingz |

Bits per second: I 38400 j

Drata bitg: IE j

Parity: I M ore j

Stop bits: I 1 j

Flow contral; {{EyE A

Festore Default: |

k. I Cancel | Spply |

5. Select File > Properties in the HyperTerminal window.
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Figure 18 HyperTerminal window

“g Switch - HyperTerminal 10l =|

File Edit WYiew Call Transfer Help

C
[
Connected 0:00:03 |Aut0 detect |Aut0 detect |SCROLL |CAPS |NL|M |Capture |Print echo Y

6. Click the Settings tab, set the emulation to VT100, and click OK in the Switch Properties dialog
box.

Figure 19 Setting terminal emulation in Switch Properties dialog box

Switch Properties 21xl
Connect To Settings |

— Function, arrow, and ctrl keys act az
" windows keps

— Backspace key sends
& Cul+H  Del  Cul+H,Space, Ctil+H

Ernulation:

YT100 =] Teminal Setup.. |

Telnet terminal |D: {¥T100

Backscroll butfer lines: IEEIEI j

[ Play zound when connecting or dizconnecting

Input Translation... | ASCI Setup... |

] 4 I Cancel |
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Logging in to the CLI

The login process requires a username and password. The default username for first time configuration
is admin, no password is required. Usernames and passwords are case sensitive.

To log in to the CLI:

1. Press Enter. The Username prompt displays:
Login authentication

Username:

2. Enter your username at the Username prompt.
Username:admin

3.  Press Enter. The Password prompt appears.
Password:

The login information is verified, and the following CLI menu appears:
<HP 1910 Switch>

If the password is invalid, the following message appears and process restarts.
% Login failed!

CLl commands

This section contains the following commands:

Task Command
Display a list of CLI commands on the device. ?
Reboot the device and run the default configuration. initialize

ipsetup { dhep | ip-address ip-address { mask
| mask-length } [ default-gateway
ip-address | }

Configure VLAN-interface 1 to obtain an IPv4 address through
DHCP or manual configuration.

ipsetup ipv6 { auto | address { ipv6-address
prefix-length | ipvé-address/ prefix-length }
[ defauli-gateway ipvé-address | }

Configure VLAN-interface 1 to obtain an IPvé address through
the autoconfiguration function or manual configuration.

Modify the login password. password

Log out of the system. quit

Download the Boot ROM image or system software image file

from the TFTP server and specify it as the startup configuration upgrade [ ipv6 | server-adidress

source-filename { bootrom | runtime }

file.

Reboot the device and run the main configuration file. reboot

View the summary information about the device. summary

Ping a specified destination. ping [ ipvé ] host
Tear down the current connection and quit the system. quit
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initialize
Syntax

initialize
Parameters

None
Description

Use initialize to delete the configuration file to be used at the next startup and reboot the device with the
default configuration being used during reboot.

Use the command with caution because this command deletes the configuration file to be used at the
next startup and restores the factory default settings.

Examples

# Delete the configuration file to be used at the next startup and reboot the device with the default
configuration being used during reboot.
<Sysname> initialize

The startup configuration file will be deleted and the system will be rebooted.Continue?
[Y/N]:y
Please wait. ..

Ipsetup

Syntax
ipsetup { dhep | ip-address ip-address { mask | mask-length } [ detault-gateway ip-address | }

Parameters
dhcp: Specifies the interface to obtain an IPv4 address through DHCP.
ip-address ip-address: Specifies an IPv4 address for VLAN-interface 1 in dotted decimal notation.
mask: Subnet mask in dotted decimal notation.
mask-length: Subnet mask length, the number of consecutive ones in the mask, in the range of 0 to 32.

default-gateway ip-address: Specifies the IPv4 address of the default gateway. With this argument and
keyword combination configured, the command not only assigns an IPv4 address to the interface, but
also specifies a default route for the device.

Description
Use ipsetup dhep to specify VLAN-interface 1 to obtain an IPv4 address through DHCP.
Use ipsetup ip address ip-address { mask | mask-length } to assign an IPv4 address to VLAN-interface 1.

By default, the device automatically obtains its IPv4 address through DHCP; if fails, it uses the assigned
IP address.

If there is no VLAN-interface 1, either command creates VLAN-interface 1 first, and then specifies its IPv4
address.

Examples

# Create VLAN-interface 1 and specify the interface to obtain an IPv4 address through DHCP.
<Sysname> ipsetup dhcp
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# Create VLAN-interface 1 and assign 192.168.1.2 to the interface, and specify 192.168.1.1 as the default
gateway.
<Sysname> ipsetup ip-address 192.168.1.2 24 default-gateway 192.168.1.1

ipsetup ipvd

Syntax

ipsetup ipvé { auto | address { ipvé-address prefixlength | ipv6-address/prefix-length }
[ default-gateway ipvé-address ] }

Parameters

auto: Enables the stateless address autoconfiguration function. With this function enabled,
VLAN-interface 1 can automatically generate a global unicast address and link local address.

address: Enables manual configuration of a global unicast IPvé address for VLAN-interface 1.
ipv6-address: Specifies an IPv6 address.
prefix-length: Prefix length in the range of 1 to 128.

default-gateway ipv6-address: Specifies the IPv6 address of the default gateway. With this argument
and keyword combination configured, the command not only assigns an IPvé address to the inferface,
but also specifies a default route for the device.

Description

Use ipsetup ipv6 auto to enable the stateless address autoconfiguration function so a global unicast
address and link local address can be automatically generated.

Use ipsetup ipvé address { ipv6-address prefix-length | ipv6-address/ prefix-length } [ default-gateway
ipv6-address | to manually assign an IPv6 address to VLAN-interface 1.

Examples

# Create VLAN-interface 1 and enable VLAN-interface 1 to automatically generate a global unicast IPv6
address and link local address.

<Sysname> ipsetup ipv6 auto

# Create VLAN-interface 1 and assign 2001::2 to the interface, with the prefix length 64, and specify
2001::1 as the default gateway.
<Sysname> ipsetup ipv6 address 2001::2 64 default-gateway 2001::1

password

Syntax

password

Parameters

None

Description

Use password to modify the login password of a user.

Examples

# Modify the login password of user admin.
<Sysname> password
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Change password for user: admin

Old password: ***

Enter new password: **

Retype password: **

The password has been successfully changed.

ping
Syntax
ping host
Parameters
host: Destination IPv4 address (in dotted decimal notation) or host name (a string of 1 to 255 characters).
Description
Use ping fo ping a specified destination.
To terminate a ping operation, press Ctrl+C.
Examples

# Ping IP address 1.1.2.2.

<Sysname> ping 1.1.2.2
PING 1.1.2.2: 56 data bytes, press CTRL_C to break
Reply from 1.1.2.2: bytes=56 Sequence=1 ttl=254 time=205 ms
Reply from 1.1.2.2: bytes=56 Sequence=2 ttl=254 time=1 ms
Reply from 1.1.2.2: bytes=56 Sequence=3 ttl=254 time=1 ms
Reply from 1.1.2.2: bytes=56 Sequence=4 ttl=254 time=1 ms
Reply from 1.1.2.2: bytes=56 Sequence=5 ttl=254 time=1 ms

---1.1.2.2 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 1/41/205 ms

The output shows that IP address 1.1.2.2 is reachable and the echo replies are all returned from the
destination. The minimum, average, and maximum roundtrip intervals are 1 millisecond, 41 milliseconds,
and 205 milliseconds respectively.

ping ipvb
Syntax
ping ipvé host
Parameters
host: Destination IPvé address or host name (a string of 1 to 255 characters).
Description
Use ping ipvé to ping a specified destination.

To terminate a ping operation, press Ctrl+C.
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Examples

# Ping IPvé address 2001::4.
<Sysname> ping ipv6 2001::4
PING 2001::4 : 56 data bytes, press CTRL_C to break

Reply from 2001::4
bytes=56 Sequence=1 hop limit=64 time = 15 ms
Reply from 2001::4
bytes=56 Sequence=2 hop limit=64 time = 2 ms
Reply from 2001::4
bytes=56 Sequence=3 hop limit=64 time = 11 ms
Reply from 2001::4
bytes=56 Sequence=4 hop limit=64 time = 2 ms
Reply from 2001::4
bytes=56 Sequence=5 hop limit=64 time = 12 ms

--— 2001::4 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 2/8/15 ms

The output shows that IPv6 address 2001::4 is reachable and the echo replies are all returned from the
destination. The minimum, average, and maximum roundtrip intervals are 2 millisecond, 8 milliseconds,
and 15 milliseconds respectively.

quit
Syntax
quit
Parameters
None
Description
Use quit to log out of the system.

Examples

# Log out of the system.

<Sysname> quit

* AR T

* Copyright (c) 2010-2013 Hewlett-Packard Development Company, L.P. *
* Without the owner®s prior written consent, *
* no decompiling or reverse-engineering shall be allowed. *

User interface aux0 is available.
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reboot

Syntax
reboot
Parameters
None
Description
Use reboot to reboot the device and run the main configuration file.
Use the command with caution because reboot results in service interruption.

If the main configuration file is corrupted or does not exist, the device cannot be rebooted with the reboot
command. In this case, you can specify a new main configuration file to reboot the device, or you can
power off the device, and then power it on, and the system will automatically use the backup
configuration file at the next startup.

If you reboot the device when file operations are being performed, the system does not execute the
command to ensure security.

Examples

# If the configuration does not change, reboot the device.
<Sysname> reboot
Start to check configuration with next startup configuration file, please

This command will reboot the device. Continue? [Y/N]:y

Now rebooting, please wait...

# If the configuration changes, reboot the device.
<Syshame> reboot
Start to check configuration with next startup configuration file, please

This command will reboot the device. Current configuration will be lost in next startup
if you continue. Continue? [Y/N]:y

Now rebooting, please wait...

summary

Syntax

summary
Parameters

None
Description

Use summary to view the summary of the device, including the IP address of VLAN-interface 1, and
software version information.

Examples

# Display summary information about the device.

<sysname>summary
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Select menu option: Summary

1P Method: Manual
IP address: 192.168.0.233
Subnet mask: 255.255.255.0

Default gateway:

I1Pv6 Method:

IPv6 link-local address:
IPv6 subnet mask length:
IPv6 global address:
IPv6 subnet mask length:
IPv6 default gateway:

Current boot app is: flash:/jg538a-cmw520-e1101.bin
Next main boot app is: flash:/jg538a-cmw520-e1101.bin
Next backup boot app is: flash:/test.bin

HP Comware Platform Software

Comware Software, Version 5.20.99, ESS 1101

Copyright (c) 2010-2013 Hewlett-Packard Development Company, L.P.
HP 1910-24 Switch uptime is 0 week, 0 day, 1 hour, 25 minutes

HP 1910-24 Switch

128M bytes DRAM

32M bytes Flash Memory
Config Register points to Flash

Hardware Version is VER.A
Bootrom Version is 105
[SubSlot 0] 24FE+2GE Combo Hardware Version is VER.A

upgrade

Syntax
upgrade server-address source-filename { bootrom | runtime }
Parameters
server-address: IPv4 address or host name (a string of 1 to 20 characters) of a TFTP server.
source-filename: Software package name on the TFTP server.
bootrom: Specifies the Boot ROM image in the software package file as the startup configuration file.

runtime: Specifies the system software image file in the software package file as the startup configuration
file.

Description

Use upgrade server-address source-filename bootrom to upgrade the Boot ROM image. If the Boot ROM
image in the downloaded software package file is not applicable, the original Boot ROM image is still
used as the startup configuration file.
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Use upgrade server-address source-filename runtime to upgrade the system software image file. If the
system software image file in the downloaded software package file is not applicable, the original
system software image file is still used as the startup configuration file.

To validate the downloaded software package file, reboot the device.

NOTE:

The HP 1910 Switch Series does not provide an independent Boot ROM image; instead, it integrates the
Boot ROM image with the system software image file together in a software package file with the
extension name of .bin.

Examples

# Download software package file main.bin from the TFTP server and use the Boot ROM image in the
package as the startup configuration file.

<Sysname> upgrade 192.168.20.41 main.bin bootrom

# Download software package file main.bin from the TFTP server and use the system software image file
in the package as the startup configuration file.
<Sysname> upgrade 192.168.20.41 main.bin runtime

upgrade ipvé

Syntax
upgrade ipvé serveraddress source-filename { bootrom | runtime }

Parameters
server-address: IPv6 address of a TFTP server.
source-filename: Software package name on the TFTP server.
bootrom: Specifies the Boot ROM image in the software package file as the startup configuration file.
;‘tlmiime: Specifies the system software image file in the software package file as the startup configuration
ile.

Description

Use upgrade ipvé server-address source-filename bootrom to upgrade the Boot ROM image. If the Boot
ROM image in the downloaded software package file is not applicable, the original Boot ROM image
is still used as the startup configuration file.

Use upgrade ipvé server-address source-filename runtime to upgrade the system software image file. If
the system software image file in the downloaded software package file is not applicable, the original
system software image file is still used as the startup configuration file.

To validate the downloaded software package file, reboot the device.

NOTE:

The HP 1910 Switch Series does not provide an independent Boot ROM image; instead, it integrates the
Boot ROM image with the system software image file together in a software package file with the
extension name of .bin.
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Examples

# Download software package file main.bin from the TFTP server and use the Boot ROM image in the
package as the startup configuration file.

<Sysname> upgrade ipv6 2001::2 main.bin bootrom

# Download software package file main.bin from the TFTP server and use the system software image file
in the package as the startup configuration file.
<Sysname> upgrade ipv6 2001::2 main.bin runtime

Configuration example for upgrading the system
software image at the CLI

Network requirements

As shown in Figure 20, a 1910 switch is connected to the PC through the console cable, and connected
to the gateway through Ethernet 1/0/1. The IP address of the gateway is 192.168.1.1 /24, and that of the
TFTP server where the system software image (suppose its name is Switch1910.bin) is located is

192.168.10.1/24. The gateway and the switch can reach each other.

The administrator upgrades the Boot ROM image and the system software image file of the 1910 switch
through the PC and sets the IP address of the switch to 192.168.1.2/24.

Figure 20 Network diagram

Console cable

<-§-) IP network
Sy,

e,

3y,
Console prot W Eth1/0/1

PC Switch Gateway TFTP Server

Configuration procedure

1. Run the TFTP server program on the TFTP server, and specify the path of the file to be loaded.
(Omitted)

2. Configure the switch:

# Configure the IP address of VLAN-interface 1 of the switch as 192.168.1.2/24, and specify the
default gateway as 192.168.1.1.

<Switch> ipsetup ip-address 192.168.1.2 24 default-gateway 192.168.1.1
# Download the software package file Switch1910.bin on the TFTP server to the switch, and
upgrade the system software image in the package.
<Switch> upgrade 192.168.10.1 Switch1910.bin runtime
File will be transferred in binary mode
Downloading file from remote TFTP server, please wait.../
TFTP: 10262144 bytes received in 71 second(s)
File downloaded successfully.
# Download the software package file Switch1910.bin on the TFTP server to the switch, and
upgrade the Boot ROM image.
<Switch> upgrade 192.168.10.1 Switch1910.bin bootrom
The Ffile flash:/Switchl1910.bin exists. Overwrite 1t? [Y/N]:y
Verifying server file...
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Deleting the old file, please wait...

File will be transferred in binary mode

Downloading file from remote TFTP server, please wait.../
TFTP: 10262144 bytes received in 61 second(s)

File downloaded successfully.

BootRom file updating finished!

# Reboot the switch.
<Switch> reboot

After getting the new image file, reboot the switch to validate the upgraded image.
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Configuration wizard

The configuration wizard guides you through configuring the basic service parameters, including the
system name, system location, contact information, and management IP address.

Basic service setup

Entering the configuration wizard homepage

Select Wizard from the navigation tree.

Figure 21 Configuration wizard homepage

Welcome to the Management IF Interface Setup Wizard: Step 1 of 4

This wizard helps you sat, modify, or guickhy view the |P configuration paramstars.

To continus, click Mext.

Mexd= Cancel

Contiguring system parameters

1. On the wizard homepage, click Next.
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Figure 22 System parameter configuration page

Systern Parameters: Step 2 of 4

[

o

o

ysname sysname OChar
yslocation Server room 501 1- 200Char
yscontact Hewlett-Packard Development Company L P 1. 200Char

<Back Next> Cancel

2. Configure the parameters as described in Table 3.

Table 3 Configuration items

ltem Description
Specify the system name.
Sysname The system name appears at the top of the navigation tree.
You can also set the system name in the System Name page you enter by selecting
Device > Basic. For more information, see "Configuring basic device settings."
Specify the physical location of the system.
Syslocation You can also set the physical location in the setup page you enter by selecting
Device > SNMP. For more information, see "Configuring SNMP."
Set the contact information for users to get in touch with the device vendor for help.
Syscontact You can also set the contact information in the setup page you enter by selecting

Device > SNMP. For more information, see "Configuring SNMP."
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Configuring management [P address

/\ CAUTION:
Modifying the management IP address used for the current login terminates the connection to the device.
Use the new management IP address to re-log in to the system.

1. On the system parameter configuration page, click Next.

Figure 23 Management IP address configuration page

Management IP Interface configuration: Step 3 of 4

s&d as the management P address to

The |IF address of 3 VLAN interface can be used
Select VLAN Interface 1 v Admin status Up L%
C.- qure |Pv4 3ddress

O DHCP OCBooTP ® Manual

B4 ssdress: | 192.168.1.60 MaskLen | 205.255.255.0

D Conf gure IPvE link-local address

Auto Manual
<Back Next= Cancel

2. Configure the parameters as described in Table 4.

Table 4 Configuration items

ltem Description

Select a VLAN interface.
Available VLAN interfaces are those configured in the page that you enter by selecting
Network > VLAN Interface and selecting the Create tab.

The IP address of a VLAN interface can be used as the management IP address to access
the device. Configure a VLAN interface and its IP address in the page that you enter by
selecting Network > VLAN Interface. For more information, see "Configuring VLAN

interfaces."

Select VLAN
Interface
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ltem Description

Enable or disable the VLAN interface.

When errors occurred in the VLAN interface, disable the interface and then enable the
port to bring the port to operate correctly.

Admin status

By default, the VLAN interface is down if no Ethernet ports in the VLAN is up. The VLAN
is in the up state if one or more ports in the VLAN are up.

@ IMPORTANT:

Disabling or enabling the VLAN interface does not affect the status of the Ethernet ports in
the VLAN. That is, the port status does not change with the VLAN interface status.

DHCP
BOOTP

Configure IPv4 Manual
address

Configure how the VLAN interface obtains an IPv4 address:

o DHCP—Select the option for the VLAN interface to get an IP address
through DHCP.

e BOOTP—Select the option for the VLAN interface to get an IP address
through BOOTP.

e Manual—Select this option to manually specify an IPv4 address and
the mask length for the VLAN interface.

IPv4 address

Specify an IPv4 address and the mask length for the VLAN interface.
Dotted decimal notation is also allowed for the mask length field.

Masklen These two fields are configurable if Manual is selected.
Auto Configure how the VLAN interface obtains an IPvé link-local address.
o Auto—Select this option for the device to automatically generate a
link-local address based on the link-local address prefix (FE80::/64)
Manual and the link layer address of the interface.
C.:onfigure IPv6 e Manual—Select this option to manually assign an IPvé linklocal
link-local address address to the inferface.
IPvé address Specify an IPvé link-local address for the VLAN interface.

This field is configurable if you select Manual. The address prefix must be
FE8O::/64.

Finishing configuration wizard

After finishing the management IP address configuration, click Next.

The page displays your configurations. Review the configurations and if you want to modify the settings
click Back to go back to the page. Click Finish to confirm your settings and the system performs the

configurations.
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Figure 24 Configuration complete
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Configuring stack

Overview

The stack management feature allows you to configure and monitor a group of connected devices by
logging in to one device in the stack, as shown in Figure 25.

Figure 25 Stacking devices

@® Stack port

Master
device

device

Slave

Slave Slave device
device device

Slave
device

To set up a stack for a group of connected devices, you must log in to one device to create the stack. This
device is the master device for the stack. You configure and monitor all member devices on the master
device. The ports that connect the stack member devices are called stack ports.

Contiguration task list

Perform the tasks in Table 5 to configure a stack.

Table 5 Stack configuration task list

Task Remarks

Configuring the master device of a stack:

Required.

Configure a private IP address pool for a stack and establish the
stack, and meantime the device becomes the master device of the

Conflgurlng globol parameters of a stack stack.

By default, no IP address pool is configured for a stack and no stack
is established.

Required.

Configure the ports of the master device that connect to member

figuring stack port
Configuring stack ports devices as stack ports.

By default, a port is not a stack port.
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Task Remarks

Configuring member devices of a stack:

Required.

Configure a port of a member device that connecs to the master

Configuring stack port . .
ontiguring stack poris device or another member device as a stack port.

By default, a port is not a stack port.

Optional.
Displaying topology summary of a stack ) )
Display information about stack members.

Optional.

Display the control panels of stack members.

@ IMPORTANT:

Displaying device summary of a stack Before viewing the control panel of a member device, you must make
sure the username, password, and access right you used to log on to
the master device are the same with those configured on the member
device; otherwise, the control panel of the member device cannot be

displayed.

Optional.

Log in to the Web network management interface of a member
device from the master device.

(D IMPORTANT:

Before logging in to a member device, you must make sure the
username, password, and access right you used to log on to the
master device are the same with those configured on the member
device. Otherwise, you cannot log in to the member device. You can
configure them by selecting Device and then clicking Users from the
navigation tree.

Logging in to a member device from the
master

Contiguring global parameters of a stack

Select Stack from the navigation tree to enter the page shown in Figure 26. You can configure global
parameters of a stack in the Global Settings area.
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Figure 26 Setting up

Topology Summary Device Summary

Global Settings

Private Met IP Mask

Build Stack Disable -

Apply
Part Settings
P Port Name ~ | Search | agvanced Search
il Part Name Port Status
[T] Ethernet/0/ not stack port
[] Ethernet1/0/2 not stack port
[[] Ethernet1/0/3 not stack port
[T] Ethernet1i0/4 not stack port
[C] Ethernet1/0/5 not stack port

26 records, B ¥ per page | page 1/6, record 1-5 | Mext Last 1 GO
Enable Disable

Table 6 Configuration items

ltem Description

Configure a private IP address pool for the stack.

The master device of a stack must be configured with a private IP address pool to
make sure it can automatically allocate an available IP address to a member device

. when the device joints the stack.
Private Net [P

Mask @ IMPORTANT:

When you configure a private IP address pool for a stack, the number of IP addresses
in the address pool needs to be equal to or greater than the number of devices to be
added to the stack. Otherwise, some devices might not be able to join the stack
automatically for lack of private IP addresses.

Enable the device to establish a stack.

After you enable the device to establish a stack, the device becomes the master
device of the stack and automatically adds the devices connected to its stack ports to

Build Stack the stack.
@ IMPORTANT:

You can delefe a stack only on the master device of the stack. The Global Settings area
on a member device is grayed out.

Contiguring stack ports

Select Stack from the navigation tree to enter the page shown in Figure 26. You can configure stack ports
in the Port Settings area.

o Select the box before a port name, and click Enable to configure the port as a stack port.
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o Select the box before a port name, and click Disable to configure the port as a non-stack port.

Displaying topology summary of a stack

Select Stack from the navigation tree and click the Topology Summary tab to enter the page shown
in Figure 27.

Figure 27 Topology Summary tab

Setup Device Summary
Device ID Device Role
1 Slave
0 [Master

Table 7 Field description

Fields Description

Member ID of the device in the stack:

e Value O indicates that the device is the master device of the stack.

Device ID
e A value other than O indicates that the device is a member device and the value
is the member ID of the member device in the stack.
Device Role Role of the device in the stack: master or slave.

Return to Stack configuration task list.

Displaying device summary of a stack

Select Stack from the navigation tree and click the Device Summary tab to enter the page shown in Figure
28. On this page, you can view interfaces on the panel of each stack member by clicking the tab of the
corresponding member device.

Figure 28 Device summary (the master device)

Setup Topology Summary

0 1 )
A0 1 Y D Y N Y N I HP 1910-24 Swi
Lol Lol Jledal e Lefle]=l=]]

Logging in to a member device from the master

Select Stack from the navigation tree, click the Device Summary tab, and click the tab of a member
device to enter the page shown in Figure 29.

Click the Configuring the Device hyperlink, you can log in to the Web interface of the member device to
manage and maintain the member device directly.
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Figure 29 Device summary (a member device)

Setup Topology Summary
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Stack configuration example

Network requirements
As shown in Figure 30, Switch A, Switch B, Switch C, and Switch D are connected to one another.

Create a stack, where Switch A is the master device, and Switch B, Switch C, and Switch D are member
devices. An administrator can log in to Switch B, Switch C, and Switch D through Switch A to perform
remote configurations.

Figure 30 Network diagram

Switch A: Master device

Stack

Switch B:

Slave device Eth1/0/1

Switch C: Slave device Switch D: Slave device

Configuration procedure

1. Configure global parameters for the stack on Switch A:

a. Select Stack from the navigation tree of Switch A, and then perform the subsequent steps on the
Setup tab, as shown in Figure 31.

b. Type 192.168.1.1 in the field of Private Net IP.
c. Type 255.255.255.0 in the field of Mask.

d. Select Enable from the Build Stack list.

e. Click Apply.
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Figure 31 Configuring global parameters for the stack on Switch A

Topology Summany Device Summary

Global Settings

Private MetIP |192.1EB.1.1 | Mask 295.255.255.0
Build Stack |Enable v
Apply
Port Settings
R Port Name | Search | advanced Search
d Fort Mame Fort Status
[] Ethernet1/oi not stack port
[] Ethernet1/0i2 not stack port
[] Ethernet1/0i3 not stack port
[] Ethernet1iod not stack port
[] Ethernet1iis not stack port
[] Ethernet1f0i6 not stack port
[] Ethernet1iof? not stack port
[] Ethernet1is not stack port
e recnrds,per page | page 11, record 1-23 |
Enahle Dizahle

Switch A becomes the master device.

2. Configure a stack port on Switch A:
a. In the Port Settings area on the Setup tab, select Ethernet1/0/1.
b. Click Enable.

45



Figure 32 Configuring a stack port on Switch A

Topology Summary Device Summary

Global Settings

Private Met IP 192168.1.1 Mask 255285 2550
Build Stack Enable w
Apply

Fart Settings
P\ Faort Mame Search |Ad'\fanced Search

i Port Marne Port Status
| Ethernet! 0/ not stack port

[] Ethernet1irz not stack port

[] Ethernettior not stack port

[] Ethernet1ird not stack port

[] Ethernettilrns not stack port

[] Ethernet1is not stack port

[] Ethernettiniy not stack port

[] Ethernet1irs not stack port

grecords, 19 ¥ |per page | page 101, record 1-8 | 1

Disable

3. On Switch B, configure Ethernet 1/0/2 (connected to Switch A), Ethernet 1/0/1 (connected to
Switch C), and Ethernet 1/0/3 (connected to Switch D) as stack ports:

a. Select Stack from the navigation tree of Switch B.

b. In the Port Settings area on the Setup tab, select Ethernet1/0/1, Ethernet1/0/2, and
Ethernet1/0/3.

c. Click Enable.
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Figure 33 Configuring stack ports on Switch B

Topology Summany Device Summary

Global Settings

Private Met IP | | Mask
Build Stack | Disable v|
Apply
Part Settings
= Fort Name % Search | advanced Search
F Fort Marne Fort Status
Ethernet1/0M not stack port
Ethernet1ir2 not stack port
Ethernet1/0s3 not stack port
[] Ethernet1iod not stack port
[] Ethernetiors not stack port
[] Ethernet1/om not stack port
[] Ethernet1oir not stack port
[] Ethernet1iora not stack port

g recnrds,perpage | page 11, record 1-8 |

Switch B becomes a member device.
4.  On Switch C, configure Ethernet 1/0/1 (the port connected to Switch B) as a stack port:
a. Select Stack from the navigation tree of Switch C.
b. In the Port Settings area on the Setup tab, select Ethernet1/0/1.
c. Click Enable.
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Figure 34 Configuring a stack port on Switch C

Topology Surmmary

Global Settings

Device Surmmary

Private Met IP Mask
Build Stack Disable w

Apply
Part Settings

R

Paort Mame | Search

| Advanced Search

i Port Name Port Status
| Ethernet1/0i1 not stack port
[] Ethernettiiz not stack port
[] Ethernet1imi3 not stack port
[] Ethernettini not stack port
[] Ethernettinis not stack port
[] Ethernet1inig not stack port
[] Ethernettimiy not stack port
[] Ethernet1insg not stack port
grecords, 19 ™ per page | page 104, record 1-8 | 1

Enahle Disahle

Switch C becomes a member device.
5. On Switch D, configure Ethernet 1/0/1 (the port connected to Switch B) as a stack port:
a. Select Stack from the navigation tree of Switch D.
b. In the Port Settings area on the Setup tab, select Ethernet1/0/1.
c. Click Enable.

Now, Switch D becomes a member device.
Verifying the configuration

To verify the stack topology on Switch A:
1. Select Stack from the navigation tree of Switch A.

2. Click the Topology Summary tab.
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Figure 35 Verifying the configuration

Setup Device Summary
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Contiguration guidelines

When you configure a stack, follow these guidelines:

e If a device is already configured as the master device of a stack, you cannot modify the private IP
address pool on the device.

e If a device is already configured as a member device of a stack, the Global Settings area on the
member device is not available.
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Displaying system and device information

Displaying system information

Select Summary from the navigation tree to enter the System Information page to view the basic system

information, system resource state, and recent system logs.

Figure 36 System information

Device Information
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Service=login-
UserMame=admin@system; A%A launched.

Refresh

m Device Mame

A

w S L &8 & B D

HPF 1910-24 Switch JG538A
Product Information

HF 1910-24 Switch Software
Version ESS 1101

Device Location

Contact Information

SerialNum
219801A08W
Software Version
520ES5 1101
Hardware Version
REV.A

Bootrom Version
105

Running Time:

0 days 0 hours 6 minutes 7
seconds

Displaying basic system information

Table 8 Field description

ltem

Description

Product Information

Description for the device.

Device Location

Device location, which you can configure on the page you enter by

selecting Device > SNMP > Setup.

Contact Information

Contact information, which you can configure on the page you enter

by selecting Device > SNMP > Setup.

SerialNum

Serial number of the device.
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ltem Description

Software Version Software version of the device.
Hardware Version Hardware version of the device.
Bootrom Version Boot ROM version of the device.
Running Time System up time.

Displaying the system resource state

The System Resource State area displays the most recent CPU usage, memory usage, and temperature.

Displaying recent system logs

Table 9 Field description

Field Description

Time Time when the system logs were generated.
Level Severity of the system logs.

Description Description for the system logs.

The System Information page displays up to five the most recent system logs.

To display more system logs, click More to enter the Log List page. You can also enter this page by
selecting Device > Syslog. For more information, see "Configuring syslog."

Setting the refresh period

To set the interval for refreshing system information, select one of the following options from the Refresh
Period list:

o If you select a certain period, the system refreshes system information at the specified interval.

e Ifyou select Manual, the system refreshes system information only when you click the Refresh button.

Displaying device information

Select Summary from the navigation tree, and click the Device Information tab to enter the page that
displays information about the device ports. Hover the cursor over a port and the port details appear,
including the port name, type, speed, utilization, and status, as shown in Figure 37. The aggregation
group number is also displayed if the port is added to an aggregation group. For the description about
the port number and its color, see Figure 37.

51



Figure 37 Device information

System Information

T =] 1910-24 Switch
Lol o]l =10

Port: Ethernet1/0/2

Type: 100M100BaseTx
Speed: 100M, Full Duplex
Utilization: 0%

Status: Disabled

Refresh Period 30 seconds - Refresh

Description of port number color:

D Unconnected Port.
I:‘ Connected port.

. Part that has been setto inactive by user or protocol.

. Paortthat has been selected by user.

. Port or Module has failed POST or module is not recognized.
Description on port numbers:

s Common number: Mumber of the port

« BnAddto a Layer 2 aggregation group. n represents the aggregation group number.
» Rn:Addto a Layer 3 aggregation group. n represents the aggregation group number.

To set the interval for refreshing device information, select one of the following options from the Refresh
Period list:

e If you select a certain period, the system refreshes device information at the specified interval.

e Ifyou select Manual, the system refreshes device information only when you click the Refresh button.
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Configuring basic device settings

The device basic information feature provides the following functions:

o Set the system name of the device. The configured system name is displayed on the top of the
navigation bar.

o Setthe idle timeout period for logged-in users. The system logs an idle user off the Web for security
purpose after the configured period.

Configuring system name

1. Select Device > Basic from the navigation tree.

The system name configuration page appears.

Figure 38 Configuring the system name

Web Idle Timeout

Sel sysname

Sysname HP * Chars. (1-30)
Items marked with an asterisk(*) are required

Apply

2. Enter the system name.
3. Click Apply.

Contiguring idle timeout period

. Select Device > Basic from the navigation tree.
2. Click the Web Idle Timeout tab.

The page for configuring idle timeout period appears.

Figure 39 Configuring the idle timeout period

System Mame

Setidle timeout

|dle timeout 10 *Minutes(1-239, Default = 10)

Iterms marked with an asterisk(*) are required
Apply
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3. Set the idle timeout period for logged-in users.

4. Click Apply.
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Maintaining devices

Software upgrade

/\ CAUTION:

Software upgrade takes some time. Avoid performing any operation on the Web interface during the
upgrading procedure. Otherwise, the upgrade operation may be interrupted.

A boot file, also known as the system software or device software, is an application file used to boot the
device. Software upgrade allows you to obtain a target application file from the local host and set the file
as the boot file to be used at the next reboot. In addition, you can select whether to reboot the device to
bring the upgrade software into effect.

1. Select Device > Device Maintenance from the navigation tree to enter the Software Upgrade tab.

Figure 40 Software upgrade configuration page

Reboot Diagnostic Infarmation
File Type hain hd

[11f a file with the same name already exists, overwrite it without any promaot
[1To upgrade the files of slave boards at one tirme

[ Reboat after the upgrade is finished

MHote:
Do not perform any operation when upgrade is in process.
The length of filename cannot exceed 37, and must end with an extension of app or hin.
[terms marked with an asterisk({® are required

ARply

2. Configure software upgrade parameters as described in Table 10.
3. Click Apply.

Table 10 Configuration items

ltem Description

File Specify the path and filename of the local application file, which must be suffixed
with the .app or .bin extension.
Specify the type of the boot file for the next boot:

File Type e Main—Boots the device.

e Backup—Boots the device when the main boot file is unavailable.
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ltem Description

If o file with the same Specify whether to overwrite the file with the same name.

name already exists, If you do not select the option, when a file with the same name exists, a dialog box
overwrite it without any  qppears, telling you that the file already exists and you cannot continue the
prompt upgrade.

Reboot after the upgrade  Specify whether to reboot the device to make the upgraded software take effect
finished after the application file is uploaded.

Device reboot

/\ CAUTION:

o Before rebooting the device, save the configuration. Otherwise, all unsaved configuration will be lost
after device reboot.

o When the device reboots, re-log in fo the device.

1. Select Device > Device Maintenance from the navigation tree.
2. Click the Reboot tab.

Figure 41 Device reboot page

Software Upgrade Electronic Lahel Diagnastic Information

Device Reboot

@Any configuration changes that have not heen
saved are lostwhen the systern reboots,

Checkwhether the current configuration is saved in the next startup configuration file.

Rehoot Cancel

3. Enable or disable the "Check whether the current configuration is saved in the next startup
configuration file" option.

Click Reboot. A confirmation dialog box appears.
5. Click OK.

o Ifyou select Check whether the current configuration is saved in the next startup configuration
file, the system will check the configuration before rebooting the device. If the check succeeds,
the system reboots the device. If the check fails, a dialog box appears, telling you that the
current configuration and the saved configuration are inconsistent, and the device is not
rebooted. In this case, save the current configuration manually before you can reboot the
device.

o If you do not select the box, the system reboots the device directly.
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Electronic label

Electronic label allows you to view information about the device electronic label, which is also known as
the permanent configuration data or archive information. The information is written into the storage
medium of a device or a card during the debugging and testing processes, and includes card name,
product bar code, MAC address, debugging and testing dates, and manufacture name.

1. Select Device > Device Maintenance from the navigation tree.

2.  Click the Electronic Label tab to view the electronic label information.

Figure 42 Electronic label
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Diagnostic information

Each functional module has its own running information. Generally, you view the output for each module
one by one. To receive as much information as possible in one operation during daily maintenance or
when system failure occurs, the diagnostic information module allows you to save the running statistics of
multiple functional modules to a file named default.diag, and then you can locate problems faster by

checking this file.
1. Select Device > Device Maintenance from the navigation tree.

2. Click the Diagnostic Information tab.

Figure 43 Diagnostic information

Software Upgrade Reboot Electronic Lahel

Create Diagnostic Information File

s Mote: The operation may take a long time. Do not perfarm any operation when creating diagnostic
infarmatian file is in process.

3.  Click Create Diagnostic Information File.

The system begins to generate a diagnostic information file.
4. Click Click to Download.

The File Download dialog box appears.

5.  Select to open this file or save this file to the local host.
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Figure 44 The diagnostic information file is created

Software Upagrade Rehoot Electronic Label
Create Diagnostic Information File

Click to Download

e Mote: The operation may take a long time. Do not perform any operation when creating diagnostic
information file is in process.

Creating diagnostic infarmation file succeeded.

The generation of the diagnostic file takes a period of time. During this process, do not perform any
operation on the Web page.

After the diagnostic file is generated successfully, you can view this file on the page you enter by
selecting Device > File Management, or downloading this file to the local host. For more information, see
"Managing files."
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Configuring system time

Overview

You must configure a correct system time so that the device can operate correctly with other devices. The
system time module allows you to display and set the device system time on the Web interface.

You can set the system time through manual configuration or network time protocol (NTP) automatic
synchronization.

Defined in RFC 1305, the NTP synchronizes timekeeping among distributed time servers and clients. NTP
can keep consistent timekeeping among all clock-dependent devices within the network, and ensure a
high clock precision so that the devices can provide diverse applications based on consistent time.

Displaying the current system time

To view the current system date and time, select Device > System Time from the navigation tree to enter
the System Time page.

Figure 45 System time configuration page

Metwark Time Protocol

System Time Configuration
2013-06-25 09:56:19

Apply

Manually configuring the system time

1. Select Device > System Time from the navigation tree.
The page for configuration the system time appears.

2. Click the System Time Configuration text to open a calendar.
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Figure 46 Calendar page

|2[]13~U?—04 134510 ||

T 201 VW
Sun Mon Tue Wed Thu Fri Sat
1 2 3 i 6

.
17 18 1% 20
6

.
(=)
=] k

L
= W O

Time E
Moday |" oK |

3. Enter the system date and time in the Time field, or select the date and time in the calendar. To set
the time on the calendar page, select one of the following methods:

o Click Today. The date setting in the calendar is synchronized to the current local date
configuration, and the time setting does not change.

o Select the year, month, date, and time, and then click OK.

4.  Click Apply on the system time configuration page to save your configuration.

Contiguring system time by using NTP

Select Device > System Time from the navigation tree.
2. Click the Network Time Protocol tab.
The page for configuring the system time through NTP appears.
Figure 47 NTP configuration page
System Time

Clock status: unsynchronized

Source Interface -
Key 1 D (1-4294967295)  Key String (1-32 Chars.)
Key 2 D (1-4294967295)  Key String (1-32 Chars.)
External Reference Source
NTP Server 1 Reference Key ID
MTP Server 2 Reference Key IO

Set System TimeZone
TimeZone  (GMT +00:00) Casablanca.Monrovia -

Apply

3. Configure the system time as described in Table 11.
4.  Click Apply.
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Table 11 Configuration items

ltem

Description

Clock status

Display the synchronization status of the system clock.

Source Interface

Set the source interface for an NTP message.

This configuration makes the source IP address in the NTP messages the
primary IP address of this interface. If the specified source interface is down,
the source IP address is the primary IP address of the egress interface.

QTP
If you do not want the IP address of an interface on the local device to become

the destination address of response messages, specify the source interface for
NTP messages.

Key 1 Set NTP authentication key.
Enable the NTP authentication feature for a system running NTP in a network
that requires high security. This feature improves the network security by
means of client-server key authentication, and prohibits a client from
synchronizing with a device that has failed authentication.
Key 2 You can set two authentication keys, each of which has a key ID and a key
string.
e ID—ID of a key.
o Key string—Character string of the MD5 authentication key.
NTP Server Specify the IP address of an NTP server, and configure the authentication key
1/Reference ID used for the association with the NTP server. The device synchronizes its
Key ID. time to the NTP server only if the key provided by the server is the same as the
Extornal specified key.
Reference You can configure two NTP servers. The clients choose the optimal reference
Source NTP Server source.
2/Reference (D
Key ID. IMPORTANT:

The IP address of an NTP server is a unicast address, and cannot be a broadcast
or a multicast address, or the IP address of the local clock source.

Network requirements

As shown in Figure 48:

System time configuration example

e  The local clock of Device A is set as the reference clock.

e Switch B operates in client mode, and uses Device A as the NTP server.

Configure NTP authentication on Device A and Switch B so that Switch B is fo be synchronized to Device

A.
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Figure 48 Network diagram

@1_0.1.11/24 1.0_1.12/24@

Device A Switch B

Configuring the system time

1. Configure the local clock as the reference clock, with the stratum of 2. Enable NTP authentication,
set the key ID to 24, and specify the created authentication key aNiceKey as a trusted key. (Details
not shown.)

2. On Switch B, configure Device A as the NTP server:
a. Select Device > System Time from the navigation tree.
b. Click the Network Time Protocol tab.

c. Enter 24 in the ID field, enter aNiceKey in the Key String field for key 1, enter 1.0.1.11 in the
NTP Server 1 field, and enter 24 in the Reference Key ID field.

d. Click Apply.
Figure 49 Configuring Device A as the NTP server of Switch B
System Time

Clock status: unsynchronized

Source Interface -
Key 1 D24 (1-4294967295) KeyString  eessssss (1-32 Chars.)
Key2 1D (1-4204067295)  Key String (1-32 Chars)

External Reference Source
‘ MNTP Server1 1.0.1.11 Reference KeyID 24

NTP Server 2 Reference Key 1D

Set System TimeZone
TimeZone  (GMT +00:00) Casablanca.Monrovia -

Apply

Verifying the configuration

After the configuration, verify that Device A and Switch B have the same system time.

Contiguration guidelines

When you configure the system time, follow these guidelines:

e Adevice can act as a server to synchronize the clock of other devices only after its clock has been
synchronized. If the clock of a server has a stratum level higher than or equal to the level of a client's
clock, the client will not synchronize its clock to the server's.
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The synchronization process takes some time. The clock status might be displayed as
unsynchronized after your configuration. In this case, refresh the page to view the clock status and
system time later on.

If the system time of the NTP server is ahead of the system time of the device, and the time gap
exceeds the Web idle time specified on the device, all online Web users are logged out because of
timeout after the synchronization finishes.
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Configuring syslog

System logs record network and device information, including running status and configuration changes.
With system logs, administrators can take corresponding actions against network problems and security
problems.

The system sends system logs to the following destinations:

Console

Monitor terminal, a terminal that has logged in to the device through the AUX or VTY user interface
Log buffer

Log host

Web interface

Log file

Displaying syslogs

1.

2,

Select Device > Syslog from the navigation tree.

The page for displaying syslogs appears. You can click Reset to clear all system logs saved in the
log buffer on the Web interface. You can click Refresh to manually refresh the page, or you can
set the refresh interval on the Log Setup page to enable the system to automatically refresh the
page periodically. For more information, see "Setting buffer capacity and refresh interval "
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o

View system logs.
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Table 12 Field description

Field

Description

Time/Date

Displays the time/date when the system log was generated.

Source

Displays the module that generated the system log.

Level

Displays the severity level of the system log. The information is classified into eight
levels by severity:

o Emergency—The system is unusable.

o Alert—Action must be taken immediately.

e Critical —Critical condition.

o Error—Error condition.

e Warning—Warning condition.

¢ Notification—Normal but significant condition.
e Information—Informational message.

o Debug—Debug-level message.

Digest

Displays the brief description of the system log.

Description

Displays the content of the system log.

Setting the log host

3.

Select Device > Syslog from the navigation tree.

Click the Loghost tab.

The log host configuration page appears.

Figure 51 Setting the log host

Loglist

Loghaost

@ |Pv4/Domain

Loghost IP/Domain

Log Setup

"(1-255Chars. )

tems marked with an asterisk(*) are required

Please select the loghostIP

Apply

IPv4 address/Domain IPv6 address

Select None

Hote: The maximum number of loghosts that can be configured is 4.

Configure the log host as described in Table 13.
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4. Click Apply.

Table 13 Configuration items

ltem Description

IPv4/Domain Specify the IPv4 address or domain name

Loghost IP/Domain of the log host. @ IMPORTANT:

[Pvé You can specify up to four log hosts.

Set the IPvé address of the log host.
Loghost IP

Setting buffer capacity and refresh interval

. Select Device > Syslog from the navigation tree.
2. Click the Log Setup tab.

The syslog configuration page appears.

Figure 52 Syslog configuration page

Loglist Loghost

Buffer Set

Buffer Capacity 512 ltem(s) {1- 1024, default=512)

Refresh Set

Refresh Interval Manual v

Apply

3. Configure buffer capacity and refresh interval as described in Table 14.
4. Click Apply.

Table 14 Configuration items

Item Description

Buffer Capacity Set the number of logs that can be stored in the log buffer.

Set the log refresh interval.

You can select manual refresh or automatic refresh:

Refresh Interval e Manual—Click Refresh to view the latest log information.
o Automatic—Select to refresh the Web interface every 1 minute, 5 minutes, or 10
minutes.
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Managing the configuration

You can back up, restore, save, or reset the device configuration.

Backing up the configuration

Configuration backup allows you to do the following:
e Open and view the configuration files for the next startup, including the .cfg file and .xml file.

e Back up the configuration files for the next startup to your local host.

(D IMPORTANT:

HP recommends backing up both the .cfg and .xml files. If you back up only the .cfg file, some
configuration information might not be restored when, for example, the configuration is mistakenly
removed.

To back up the configuration:

1. Select Device > Configuration from the navigation tree.
The Backup page appears.
Figure 53 Backing up the configuration

Restore Save Initialize
Configuration File
Backup:
Backup the configuration file with the extension ~.cfg” Backup

Backup the configuration file with the extension “xml” Backup

2. Click the upper Backup button.
The file download dialog box appears.

3. Choose to view the .cfg file or to save the file to your local host.
Click the lower Backup button.
The file download dialog box appears.

5. Choose to view the .xml file or to save the file to the local host.

Restoring the contfiguration

Configuration restoration allows you to do the following:
e Upload a .cfg file from your local host to the device.

e Upload an .xml file from your local host to the device, and delete the .xml configuration file that
was used for the next startup.

The restored configuration takes effect at the next device startup.
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To restore the configuration:
1. Select Device > Configuration from the navigation tree.
2. Click the Restore tab.

Figure 54 Restoring the configuration

Backup Save Initialize

Restore the Configuration File:

|'the file with the exension ~.cfg”)
|[_Browse. .. Jithe file with the extension “xmi")

Note: This operation replaces the configuration in the startup configuration file with the restored configuration, but the restored configuration
1akes effect at the next starup.

ltems marked with an asterisk(*) are required

Apply

3. Click the upper Browse button.

The file upload dialog box appears.

Select the .cfg file to be uploaded, and click OK.
5. Click the lower Browse button.

The file upload dialog box appears.
6. Select the .xml file to be uploaded, and click OK.

Saving the contiguration

You save the running configuration to both the .cfg configuration file and .xml configuration file that will
be used at the next startup.

Saving the configuration takes some time.

Only one administrator can save the configuration at @ moment. If you save the configuration while the
system is saving the configuration as required by another administrator, the system prompts you fo try
again later.

You can save the configuration in either of the following modes:
e Fast mode.

To save the configuration in fast mode, click the Save button at the upper right of the auxiliary
area.
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Figure 55 Saving the configuration

Sawve | Help | Logout

Backup Restore Initialize

Save Current Settinos

Mote; Click Save Current Settings to save the current configuration.

e Common mode.
To save the configuration in common mode:
a. Select Device > Configuration from the navigation tree.
b. Click the Save tab.

c. Click Save Current Settings.

Resetting the configuration

Resetting the configuration restores the device's factory defaults, deletes the current configuration files,
and reboots the device.

To reset the configuration:

1. Select Device > Configuration from the navigation tree.
2. Click the Initialize tab.

3.  Click Restore Factory-Default Settings.

Figure 56 Resetting the configuration

Backup Festore Save

Restore Factory-Default Settings

Hote: Click Restore Factory-Default Settings to restore and initialize the factory-default settings and
reboot.
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Managing files

The device requires a series of files for correct operation, including boot files and configuration files.
These files are saved on the storage media. You can display files on the storage media, download,
upload, or remove a file, or specify the main boot file.

Displaying files

1. Select Device > File Management from the navigation tree.

Figure 57 File management page

Please select disk flash ~ Used space: 22.18 MB Free space: 6.24 MB Capacity: 28.42 MB

] File Size(KB) Boot File Type Operation

flash:ftest_old_2126d002.bin 11,184 Backup ﬂl

[7] flash:/default diag 94.433 1]

[ flash:/system.xml 0.147 1]

[ flashistartup.cig 1.288 i |

[ flash:_startup_bak.cfg 1272 1]

[F] flash:testbin 11,214 Main L]

[7] Nash:Nogfileogfile.log 208.504 1]
7records, 20 ¥ perpage | page 1/1, record 1-7 | 1 GO

DownloadFile ~ Remove File Set as Main Boot File
Upload File

Please selectdisk flash ~

File Browse . . .
«» Note: Do not perform any operation when upload is in process.

Apply

2. Select a medium from the Please select disk list.
Two categories of information are displayed:
o Medium information, including the used space, the free space, and the capacity of the medium.

o File information, including all files on the medium, the file sizes, and the boot file types (Main or
Backup). The boot file type is only displayed for an application file (.bin or .app file) that will be
used as the main or backup boot file.

Downloading a file

1. Select Device > File Management from the navigation tree to enter the file management page
(see Figure 57).

From the Please select disk list, select the medium where the file to be downloaded resides.
Select the file from the list.

Only one file can be downloaded at a time.
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4. Click Download File.
The File Download dialog box appears.

5.  Open the file or save the file to a path.

Uploading a file

(D IMPORTANT:

Uploading a file takes some time. HP recommends not performing any operation on the Web interface
during the upload.

1. Select Device > File Management from the navigation tree to enter the file management page
(see Figure 57).

In the Upload File areq, select the medium for saving the file from the Please select disk list.
. Click Browse to navigate to the file to be uploaded.
4. Click Apply.

Removing a file

1. Select Device > File Management from the navigation tree to enter the file management page
(see Figure 57).

2. Do one of the following:
o Click the | icon of a file to remove the file.
o Select a file from the file list and click Remove File.

To remove multiple files, repeat step 2, or select the files from the file list and click Remove File.

Specitying the main boot file

1. Select Device > File Manage from the navigation tree to enter the file management page
(see Figure 57).

2. From the Please select disk list, select the medium that holds the application file to be used as the
main boot file.

3. Select the application file (.bin or .app file) from the file list.
Click Set as Main Boot File.
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Managing ports

You can use the port management feature to set and view the operation parameters of a Layer 2 Ethernet
port and an aggregate interface.

e For alayer 2 Ethernet port, these operation parameters include its state, speed, duplex mode, link
type, PVID, description, MDI mode, flow control settings, MAC learning limit, and storm
suppression ratios.

e Foran aggregate interface, these operation parameters include its state, link type, PVID, description,
and MAC learning limit.

Setting operation parameters for a port

1. Select Device > Port Management from the navigation tree.
2. Click the Setup tab.

Figure 58 The Setup tab

Summary Detail

Basic Configuration

Port State Mo Change ~ Speed Mo Change - Duplex Mo Change -
Link Type Mo Change - [ pviD (1-4084) Combo Mo Change
Description Chars. (1-80)

Advanced Configuration

MDI Mo Change - Flow Control Mo Change -
Max MAC
Power Save Mo Change - Count MNo Change = (0-8182)
Storm Suppression
Broadcast Mo Change = Multicast NoChange ~ Unicast Mo Change  ~
Suppression Suppression Suppression

pps rangs (1-148810 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-102400 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

1910-24 Switch ..

Select All Select None
Unit Selected Ports
1
+ |t may take some time if you apply the above settings to multiple ports. Apph Cancel
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3. Set the operation parameters for the port as described in Table 15.
4. Click Apply.

Table 15 Configuration items

ltem Description

Enable or disable the port.

Port State Sometimes, after you modify the operation parameters of a port, you must disable and
then enable the port to have the modifications take effect.

Set the transmission speed of the port:

e 10—10 Mbps.

o 100—100 Mbps.

e 1000—1000 Mbps.

e Auto—Autonegotiation.

e Auto 10—Autonegotiated to 10 Mbps.

¢ Auto 100—Autonegotiated to 100 Mbps.

e Auto 1000—Autonegotiated to 1000 Mbps.

e Auto 10 100—Autonegotiated to 10 or 100 Mbps.

e Auto 10 1000—Autonegotiated to 10 or 1000 Mbps.

e Auto 100 1000—Autonegotiated to 100 or 1000 Mbps.
e Auto 10 100 1000—Autonegotiated to 10, 100, or 1000 Mbps.

Speed

Set the duplex mode of the port:
e Auto—Autonegotiation.

Duplex
e Full—Full duplex.

e Half—Half duplex.

Set the link type of the current port, which can be access, hybrid, or trunk. For more

. information, see "Configuring VLANS."
Link Type
To change the link type of a port from trunk to hybrid, or vice versa, you must first set its link

type to access.

Set the port VLAN ID (PVID) of the interface. For more information about setting the PVID,
see "Configuring VLANs."

To make sure a link correctly transmits packets, the trunk or hybrid poris at the two ends of
the link must have the same PVID.

PVID

Set the active port of a combo interface:
Combo e Copper.
e Fiber.

Description Set the description of the port.
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ltem

Description

Set the MDI mode of the port.

You can use two types of Ethernet cables to connect Ethernet devices: crossover cable and
straightthrough cable. To accommodate these two types of cables, an Ethernet port can
operate in one of the following three MDI modes: across, normal, and auto.

An Ethernet port is composed of eight pins. By default, each pin has its particular role. For

example, pin 1 and pin 2 are used for transmitting signals, and pin 3 and pin 6 are used

for receiving signals. You can change the pin roles by setting the MDI mode.

o For an Ethernet port in across mode, pin 1 and pin 2 are used for transmitting signals,
and pin 3 and pin 6 are used for receiving signals. The pin roles are not changed.

e For an Ethernet port in auto mode, the pin roles are decided through autonegotiation.

MDI o For an Ethernet port in normal mode, the pin roles are changed. Pin 1 and pin 2 are

used for receiving signals, and pin 3 and pin 6 are used for transmitting signals.

To enable normal communication, you must connect the local transmit pins to the remote

receive pins. Configure the MDI mode depending on the cable types.

When you configure the MID mode, follow these guidelines:

o Typically, use the auto mode. The other two modes are used only when the device
cannot determine the cable type.

o When straight-through cables are used, the local MDI mode must be different from the
remote MDI mode.

e  When crossover cables are used, the local MDI mode must be the same as the remote
MDI mode, or the MDI mode of at least one end must be set to auto.

Enable or disable flow control on the port.

With flow control enabled at both sides, when traffic congestion occurs on the ingress

Flow Control port, the ingress port sends a Pause frame notifying the egress port to temporarily suspend
the sending of packets. The egress port is expected to stop sending any new packet when
it receives the Pause frame. In this way, flow control helps to avoid dropping of packets.
Flow control works only affer it is enabled on both the ingress and egress poris.

Enable or disable Energy Efficient Ethernet (EEE) energy saving on the port.
By default, EEE energy saving is disabled on an Ethernet port.

Power Save With EEE energy saving enabled, when an Ethernet port does not receive any packet for
a certain period, it automatically enters the power save mode and resumes its normal state
upon the arrival of a packet.

Set the MAC learning limit on the port:

Max MAC Count e User Defined—Select this option to set the limit manually.

¢ No Limited—Select this option fo set no limit.

Set broadcast suppression on the port:

o ratio—Sets the maximum percentage of broadcast traffic to the total bandwidth of an
Ethernet port. When you select this option, you must enter a percentage in the box
below.

Broadcast e pps—Sets the maximum number of broadcast packets that can be forwarded on an

Suppression

Ethernet port per second. When you select this option, you must enter a number in the
box below.

o kbps—Sets the maximum number of kilobits of broadcast traffic that can be forwarded

on an Ethernet port per second. When you select this option, you must enfer a number
in the box below.
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ltem Description

Set multicast suppression on the port:

e ratio—Sets the maximum percentage of multicast traffic to the fotal bandwidth of an
Ethernet port. When you select this option, you must enter a percentage in the box

below.
Multicast e pps—Sets the maximum number of multicast packets that can be forwarded on an
Suppression Ethernet port per second. When you select this option, you must enter a number in the
box below.

o kbps—Sets the maximum number of kilobits of multicast traffic that can be forwarded
on an Ethernet port per second. When you select this option, you must enter a number
in the box below.

Set unicast suppression on the port:

o ratio—Sets the maximum percentage of unicast traffic to the total bandwidth of an
Ethernet port. When you select this option, you must enter a percentage in the box

below.
Unicast o pps—Sets the maximum number of unicast packets that can be forwarded on an
Suppression Ethernet port per second. When you select this option, you must enter a number in the
box below.

e kbps—Sets the maximum number of kilobits of unicast traffic that can be forwarded on
an Ethernet port per second. When you select this option, you must enter a number in
the box below.

Interface or interfaces that you have selected from the chassis front panel and the
Selected Ports aggregate interface list below, for which you have set operation parameters.

You can set only the state and MAC learning limit for an aggregate interface.

If you set operation parameters that a port does not support, you are notified of invalid settings and might
fail to set the supported operation parameters for the port or other ports.

Displaying port operation parameters

Displaying a specified operation parameter for all ports

1. Select Device > Port Management from the navigation tree to enter the Summary page by default.
2. Select the option for a parameter you want to view.

The parameter information for all the ports is displayed in the lower part of the page.

75



Figure 59 The Summary tab

Detail Setup

Select Feature:

@ PortState @ Max MAC Count

() Flow Control © Defautt VLAN ID(PVID)
2 Link Type @ mol

*) Duplex ©) Speed

! Broadcast Suppression

(2 Mutticast Suppression ) Unicast Suppression
O Power Save © Description
Feature Summary:
Ports Jetting
Ethl/0/1 Enabled -
Ethl/0/2 Enabled
Ethl/0/3 Enabled
Ethl/0/4 Enabled
Ethl/0/5 Enzbled
Ethl/0/6 Enzbled
Ethl/0/7 Enabled
Ethl/0/8 Enabled hd

Displaying all the operation parameters for a port

1. Select Device > Port Management from the navigation tree
2. Click the Detail tab.
3. Select a port whose operation parameters you want to view in the chassis front panel.

The operation parameter settings of the selected port are displayed on the lower part of the page.
Whether the parameter takes effect is displayed in the square brackets.

Figure 60 The Detail tab

Summary Setup

Select a Port

1910-24 Switch ...

Port State Enabled [InActive] PVID 1

Flow Control Disabled Link Type Access

WDl Auto Speed Auto [100K]

Duplex Auto [Full Max MAC Count Mo Limit

Broadcast Suppression 100%

Multicast Suppression 100% Unicast Suppression 100%

Power Save Disabled Description Ethernet1/0/3 Interface

The table shows the configured values for the selected port, while those inside the square brackets are the actual values of the selected port.
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Port management configuration example

Network requirements

As shown in Figure 61:

e  Server A, Server B, and Server C are connected to Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet
1/0/3 of the switch, respectively. The rates of the network adapters of these servers are all 1000

Mbps.
o The switch connects to the external network through GigabitEthernet 1/0/25 whose speed is 1000
Mbps.

To avoid congestion at the egress port, GigabitEthernet 1/0/25, configure the autonegotiation speed
range on Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3 as 100 Mbps.

Figure 61 Network diagram

GE1/0/25

Switch

(Speed 100Mbps)

(Speed 100Mbps) (Speed 100Mbps)

Server A Server B Server C

Configuring the switch

1. As shown in Figure 62 and Figure 63, activate the copper combo port and set the speed of
GigabitEthernet 1/0/25 to 1000 Mbps:
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Figure 62 Activating the copper combo port

summary Detail

Basic Configuration

Port State  No Change ~ Speed No Change - Duplex No Change ~
Link Type No Change ~ [E1 pviD (1-4004) Combo Copper -
Description Chars. (1-80)

Advanced Configuration

Flow

MDI No Change « Control Mo Change -
Max MAC
Power Save No Change ~ Count No Change (0-8192)
Storm Suppression
Broadcast o Change - Multicast Mo Change  ~ Unicast No Change  ~
Suppression Suppression Suppression

pps range (1-148810 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-102400 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

Select All Select Mone
Unit Selected Ports
1 GE1/0/25

e |t may take some time if you apply the above settings to multiple ports. Apply Cancel
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Figure 63 Configuring the speed of GigabitEthernet 1/0/25

Summary Detail

Basic Configuration

Port State Mo Change - Speed 1000 - Duplex Mo Change -
Link Type Mo Change - [ pviD (1-4094) Combo Mo Change ~
Description Chars. (1-80)

Advanced Configuration

MDI Mo Change - Flow Control Mo Change -
Max MAC
Power 3ave Mo Change = Count Mo Change hd (0-8192)
Storm Suppression
Broadcast Mo Change Mutticast Mo Change - Unicast Mo Change -
Suppression Suppression Suppression

pps range (1-14&310 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-102400 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

LD T 1910.2¢ Swieh
[l LeleJfelelele (e l=T=1= ][ ][=]

Select All Select None
Unit Selected Ports
1 GE1/0/25

+ [t may take some time if you apply the above settings to muktiple ports. Apphy Cancel

2. Batch configure the autonegotiation speed range on Ethernet 1/0/1, Ethernet 1/0/2, and
Ethernet 1/0/3 as 100 Mbps:

a. On the Setup tab, select Auto 100 from the Speed list.
b. Select 1, 2, and 3 on the chassis front panel.

1, 2, and 3 represent ports Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3.
c. Click Apply.
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Figure 64 Batch configuring the port speed

Summary Dretail

Basic Configuration

Port State Mo Change - |S|Je&d Auta 100 ha Duplex Mo Change ~
Link Type No Change - O pvip (1-4094) Combo Mo Change =
Description Chars. (1-80)
Advanced Configuration

MO Mo Change ~ Flow Control Mo Change =

Max MAC

Power Save Mo Change - Count Mo Change - (0-8192)

Storm Suppression

Broadcast No Change ~ Multicast No Change ~ Unicast No Change ~
Suppression Suppression Suppression

pps range (1-148810 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-102400 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

E LT =] 1910.2¢ Swich
eLeodeloladeledlel=lz=]x]

Select Al Select None

Unit Selected Ports

Ethl/0/1-Ethl/0/3

+ [t may take some time if yvou apply the above settings to multiple ports.

Cancel

3. Display the speed settings of ports:
a. Click the Summary tab.

b. Click the Speed button to display the speed information of all ports on the lower part of the
page, as shown in Figure 65.
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Figure 65 Displaying the speed settings of ports

Detail Setup

Select Feature:

! PortState (@) Max MAC Count
! Flow Control ) Defaul VLAN IDiPVID)
Link Type 2 MDI
' Duplex
! Broadcast Suppression
) Multicast Suppression ) Unicast Suppression
) Power Save (& Description
Feature Summary:
Ports Setting
Eth1/0/1 Luto (100M)
Ethl/0/2 Ruto (100M)
Eth1/0/3 Zuto (100M)
Ethl/0/4 Ruto
Ecthl/0/5 Buto
Ethl/0/6 Ruto
Ethl/0/7 Ruto
Ethl/0/8 Buto
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Configuring port mirroring

Port mirroring refers to the process of copying the packets passing through a port/VLAN/CPU to the
monitor port connecting to a monitoring device for packet analysis.

Terminology

Mirroring source

The mirroring source can be one or more monitored ports, called source ports. The device where the
ports reside is called a "source device." Packets (called "mirrored packets") passing through them are
copied to a port connecting to a monitoring device for packet analysis.

Mirroring destination

The mirroring destination is the destination port (also known as the monitor port) of mirrored packets and
connects to the data monitoring device. The device where the monitor port resides is called the
"destination device." The monitor port forwards the mirrored packets to its connecting monitoring device.

A monitor port might receive multiple duplicates of a packet in some cases because it can monitor
multiple mirroring sources. For example, assume that Port 1 is monitoring bidirectional traffic on Port 2
and Port 3 on the same device. If a packet travels from Port 2 to Port 3, two duplicates of the packet will
be received on Port 1.

Mirroring direction

The mirroring direction indicates that the inbound, outbound, or bidirectional traffic can be copied on a
mirroring source:

e Inbound—Copies packets received on a mirroring source.
e Outbound—Copies packets sent out of a mirroring source.

o Bidirectional—Copies packets both received and sent on a mirroring source.

Mirroring group

Port mirroring is implemented through mirroring groups, which include local and remote mirroring groups.
Only local mirroring groups are supported.

Local port mirroring

In local port mirroring, the mirroring source and the mirroring destination are on the same device. A
mirroring group that contains the mirroring source and the mirroring destination on the device is called
a "local mirroring group."
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Figure 66 Local port mirroring implementation

Mirroring process in the
device

Eth1/0/1 Eth1/0/2

—L_—

P, —— »

‘ Eth1/0/1 Eth1/0/2

Host Device

Data monitoring
device

—— Original packets ‘ Source port
——>» Mirrored packets [] Monitor port

As shown in Figure 66, the source port Ethernet 1/0/1 and monitor port Ethernet 1/0/2 reside on the
same device. Packets of Ethernet 1/0/1 are copied to Ethernet 1/0/2, which then forwards the packets
to the data monitoring device for analysis.

Contiguration restrictions and guidelines

When you configure port mirroring, follow these restrictions and guidelines:
e Alocal mirroring group can contain multiple source ports, but only one monitor port.
e Do not enable the spanning tree feature on the monitor port.

e Use a monitor port only for port mirroring to make sure the data monitoring device receives and
analyzes only the mirrored traffic rather than a mix of mirrored traffic and other forwarded traffic.

Recommended configuration procedures

Step Remarks

Required.
1. Configure a local mirroring

group. For more information, see "Configuring a mirroring group.

Select the mirroring group type local in the Type list.

Required.
2.  Configure source ports for

the mirroring group. For more information, see "Configuring ports for the mirroring group.

Select the port type Mirror Port.

Required.
3. Configure the monitor port

for the mirroring group. For more information, see "Configuring ports for the mirroring group.

Select the port type Monitor Port.

Contiguring a mirroring group

1. From the navigation tree, select Device > Port Mirroring.
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2. Click Add to enter the page for adding a mirroring group.

Figure 67 Adding a mirroring group

Summary

Mirraring Group 1D

Type

Remove Modify Port
(-1}
Local -
Apply
Group ID Type

3. Configure the mirroring group as described in Table 16.

4. Click Apply.

Table 16 Configuration items

ltem

Description

Mirroring Group ID

ID of the mirroring group to be added.

Type

Specify the type of the mirroring group fo be added as Local, which indicates
adding a local mirroring group.

Contiguring ports for the mirroring group

1. From the navigation tree, select Device > Port Mirroring.

2. Click Modify Port to enter the page for configuring ports for a mirroring group.

84



Figure 68 Modifying ports
Summary Add Remove
Wirroring Group ID Select Group ID ~

Port Type Monitor Port Stream Orientation both

Select port(s)

1910-24 Switch

.Selected Port(s) .Ncll Available for Selection

Selected Port(s)

Note:

1. Selected Port(s):Configured member port(s).
2. Mot Available for Selection:All the member ports of mirrering group on the device except Selected Port(s).

3. Configure ports for the mirroring group as described in Table 17.
Click Apply.
A progress dialog box appears.

5.  After the success notification appears, click Close.

Table 17 Configuration items

ltem Description
ID of the mirroring group fo be configured.
Mirroring . .
Group ID The available groups were added previously.
Select a Local mirroring group ID to configure ports for the local mirroring group.
Configure ports for a local mirroring group:
Port Type ¢ Monitor Port—Configures the monitor ports for the local mirroring group.
e Mirror Port—Configures mirroring ports for the local mirroring group.
Set the direction of the traffic monitored by the monitor port of the mirroring group:
Stream e both—Mirrors both received and sent packets on mirroring ports.
Orientation e inbound—Mirrors only packets received by mirroring port.

e outbound—Mirrors only packets sent by mirroring ports.

Click the ports to be configured on the chassis front panel. If aggregate interfaces are
configured on the device, the page displays a list of aggregate interfaces below the chassis
front panel. You can select aggregate interfaces from this list and configure them as
mirroring ports of a port mirroring group.

Select port(s)
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Local port mirroring configuration example

Network requirements

As shown in Figure 69, configure local port mirroring on Switch A so the server can monitor the packets
received and sent by the Marketing department and Technical department.

Figure 69 Network diagram

. P

Marketing Dept.
Eth1/0/1
. @:Etmm/a ‘
Device A
Eth1/0/2 Server
Technical Dept.

| <) Source port
[J Monitor port

Contiguration procedure

Adding a local mirroring group

1. From the navigation tree, select Device > Port Mirroring.

2. Click Add to enter the page for adding mirroring groups as shown in Figure 70.
Figure 70 Adding a local mirroring group

Summary Remowve Modify Port
Wirroring Group ID 1 (1-1)
Type Local -
Apply
Group 1D Type
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3. Enter 1 for Mirroring Group ID, and select Local from the Type list.
4. Click Apply.

Configuring Ethernet 1/0/1 and Ethernet 1/0/2 as the source ports

Click Modify Port.

Select 1 - Local from the Mirroring Group ID list.

Select Mirror Port from the Port Type list.

Select both from the Stream Orientation list.
Select 1 (Ethernet 1/0/1) and 2 (Ethernet 1/0/2) on the chassis front panel.

vk 0D

Figure 71 Configuring the source ports

sSummary Add Remove
Mirroring Group ID 1-Local A
Port Type Mirror Port = Stream Orientation bath hd

Select port(s)

1910-24 Switch ...

Select Al Select None

.Selected Portis} .NUt Available for Selection

Selected Port(s)
Eth1/0/1-Eth1/0/2

Note:

1. Selected Port(s):Configured member port(s).
2. Mot Available for Selection:All the member ports of mirroring group on the device except Selected Port(s).

6. Click Apply.
A configuration progress dialog box appears.

7.  Atfter the success notification appears, click Close.
Configuring Ethernet 1/0/3 as the monitor port
Click Modify Port.
Select 1 - Local from the Mirroring Group ID list.

Select Monitor Port from the Port Type list.
Select 3 (Ethernet 1/0/3) on the chassis front panel.

el o
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Figure 72 Configuring the monitor port

Summary Add Remove
Wirroring Group 1D 1-Local -
Port Type Monitor Port Stream Orientation both

Select port(s)

1910-24 Switch ...

.Selected Port(s) .Nut Available for Selection

Selected Portis)
Eth1/0/3

Hote:

1. Selected Port(s):Configured member port(s).
2. Mot Available for Selection:All the member ports of mirroring group on the device except Selected Port(s).

5. Click Apply.
A configuration progress dialog box appears.

6.  After the success notification appears, click Close.
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Managing users

The user management function allows you to do the following:
e Adding a local user, and specifying the password, access level, and service types for the user.
o Setting the super password for non-management level users to switch fo the management level.

e Swifching to the management level from a lower level.

Adding a local user

1. Select Device > Users from the navigation tree.
2. Click the Create tab.

Figure 73 Adding a local user

Summary Super Password Modify Remove Switch To Management
Create User

Username (1-55 Chars.) Access Level Visitor -
Password (1-63 Chars.} Confirm Password
Password Encryption @ Reversible ) Irreversible
Service Type [Eweb [CFTP [C] Telnet

Apply
Summary
Username Rcecess Level Service Type

admin Management Web

Note: Username cannot contain Chinese characters and any of the following characters / % @ | @ * 7 " < > ' & & $

3. Configure a local user as described in Table 18.
4. Click Apply.

Table 18 Configuration items

ltem Description

Username Enter a username fOf’ the user.
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ltem Description

Select an access level for the user.
Users of different levels can perform different operations. User levels, in order from low
to high, are as follows:

e Visitor—A visitor level user can perform only ping and traceroute operations. They
cannot access the data on the device or configure the device.

Access Level e Monitor—A monitor level user can perform ping and traceroute operations and
access the data on the device, but they cannot configure the device.
e Configure—A configure level user can perform ping and traceroute operations,
access data on the device, and configure the device, but they cannot upgrade the
software, add/delete/modify users, or back up or restore the configuration file.

¢ Management—A management level user can perform any operations on the device.

Password Set the password for the user.

Confirm Password  Enter the same password again.

Select the password encryption type:

o Reversible—Uses a reversible encryption algorithm. The ciphertext password can be

P
E:zsr:/v;irgn decrypted to get the plaintext password.
e lIrreversible—Uses an irreversible encryption algorithm. The ciphertext password
cannot be decrypted to get the plaintext password.
. Select the service types for the user to use, including Web, FTP, and Telnet. You must
Service Type

select at least one service type.

Setting the super password

A management level user can set the password for non-management level users to switch to the
management level. If the password is not set, non-management level users cannot switch to the
management level from a lower level.

To set the super password:
1. Select Device > Users from the navigation tree.

2. Click the Super Password tab.
Figure 74 Setting the super password

Summary Create Modify Remove Switch To Management

Please specify the super password

@ Create Remove
Pazswaord (1-16 Chars.)
Canfirm Password
Password Encryption @ Reversible Irreversible
Apply

Note: Use the super password to switch from the current user level to the management level.

3. Configure a super password as described in Table 19.
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4. Click Apply.

Table 19 Configuration items

ltem Description

Select the operation type:
Create/Remove e Create—Configure or change the super password.

e Remove—Remove the current super password.

Password Set the password for non-management level users to switch to the management level.

Confirm Password  Enter the same password again.

Select the password encryption type:

e Reversible—Uses a reversible encryption algorithm. The ciphertext password can be

Password decrypted to get the plaintext password.

Encryption
o lIrreversible—Uses an irreversible encryption algorithm. The ciphertext password

cannot be decrypted to get the plaintext password.

Switching to the management level

A non-management level user can switch fo the management level after providing the correct super
password.

The level switching operation does not change the access level setting for the user. When the user logs
in fo the Web interface again, the access level of the user is still the level set for the user.

To switch to the management level:

1. Select Device > Users from the navigation tree.
2. Click the Switch To Management tab.

3.  Enter the correct super password.

4.  Click Login.

Figure 75 Switching to the management level

Summary Super Password Create Modify Remaove

Please enter the super password to switch from the current user level
to the management level.

Password (1-16 Chars.)

Lagin
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Configuring a loopback test

You can check whether an Ethernet port operates correctly by performing Ethernet port loopback test.
During the test time, the port cannot forward data packets correctly.

Ethernet port loopback test has the following types:

Internal loopback test—Establishes self loop in the switching chip and checks whether there is a
chip failure related to the functions of the port.

External loopback test—Uses a loopback plug on the port. Packets forwarded by the port will be
received by itself through the loopback plug. The external loopback test can be used to check
whether there is a hardware failure on the port.

Configuration guidelines

When you configure a loopback test, follow these restrictions and guidelines:

When a port is physically down, you cannot perform an external loopback test on the port.
After a port is shut down manually, you can perform neither internal nor external test on the port.

When a port is under loopback test, you cannot apply Rate, Duplex, Cable Type, and Port Status
configuration fo the port.

An Ethernet port operates in full duplex mode when a loopback test is performed. It restores its
original duplex mode after the loopback test is finished.

Contiguration procedure

1.

2.
3.

From the navigation tree, select Device > Loopback.

Figure 76 Loopback test page

Testing type: @ External ) Internal

A 1 o Y o i N I 1910-24 Swich .
2 lolefuleluyelelalzla

Result:

Select External or Internal for loopback test type.

Select an Ethernet interface from the chassis front panel.
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4. Click Test.

After the test is complete, the system displays the loopback test result.

Figure 77 Loopback test result

Testing type: () External @ Internal

I 1 | Y 1Y 1 R ) B 1910.24 Swich
(E] ) By S ] ) i o] ] ]

Result:
Ethernet1/0/2: Loop internal succeeded!
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Configuring VCT

Overview

You can use the Virtual Cable Test (VCT) function to check the status of the cable connected to an Ethernet
port on the device. The result is returned in less than 5 seconds. The test covers whether short circuit or
open circuit occurs on the cable and the length of the faulty cable.

The fiber port of a combo interface does not support this feature.

Testing cable status

Select Device > VCT from the navigation tree to enter the page for testing cable status.

Select the port you want to test on the chassis front panel.
Click Test.
The test result is returned within 5 seconds and displayed in the Result field.

Figure 78 Testing the status of the cable connected to an Ethernet port

ufafs]afofulnlefalola]a] 1910:24 Swich .
oy ] e wnf onp o] anfy ] anf 2n) o GRS

Result:

Ethernet1/0/2:

Cable status: abnormal({open), 6 metre(s)
Pair Impedance mismatch: no

Pair skew: - ns

Pair swap: -

Pair polarity: -

Insertion loss: - db

Return loss: - db

Mear-end crosstalk: - db

Mote: The error ofthe length detected is £5 meters.

The result displays the cable status and length. The cable status can be normal, abnormal,
abnormal (open), abnormal (short), or failure.

o When a cable is normal, the cable length displayed is the total length of the cable.

o When a cable is abnormal, the cable length displayed is the length between the current port
and the location where fault occurs.

o The cable length detected can have an error of up to 5 meters.
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Configuring the flow interval

With the flow interval module, you can view the number of packets and bytes sent and received by a port,
and the bandwidth use of the port over the specitied interval.

Viewing port traffic statistics

1. Select Device > Flow interval from the navigation tree.
By default, the Port Traffic Statistics tab is displayed.

2. View the number of packets and bytes sent and received by each port, and the bandwidth use of
each port over the last interval.

Figure 79 Port traffic statistics

|°\ Interface Mame | Search | a:izcces sesier

Interface Name "E};e“é?' RPESCEL“;E' SentPacket Received Byte  SentByte Utiﬁ;ﬂﬁfg:‘?%} Umifafi’;tn(%}
Ethernet1/0/1 300 0 0 0 0 0 0
Ethernet1/0/2 300 0 0 0 0 0 0
Ethernetlio/z 300 1288 1385 183370 1071643 1 1
Ethernetl/0i4 300 0 0 0 0 0 0
Ethernetlio/s 300 0 0 0 0 0 0
Ethernetl//é 300 0 0 0 0 0 0
Ethernetliorf 300 0 0 0 0 0 0
Ethernettiiz 300 0 0 0 0 0 0
Ethernetlio/e 300 0 0 0 0 0 0
Ethernet1/0r10 300 0 0 0 0 0 0
Ethernet1/0/11 300 0 0 0 0 0 0
Ethernet1/0/12 300 0 0 0 0 0 0
Ethernet1/0M13 300 0 0 0 0 0 0
Ethernetlio/4 300 0 0 0 0 0 0
Ethernet1/0/15 300 92 188 8426 18903 1 1

28 resorts) 15 Mo page | page 172, reoord 115 | F 1 Next Last|l  |L.GO
Refresh

When the bandwidth utilization is lower than 1%, 1% is displayed.
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Configuring RMON

Overview

Remote Network Monitoring (RMON) is an enhancement to SNMP. It enables proactive remote
monitoring and management of network devices and subnets. An RMON monitor periodically or
continuously collects traffic statistics for the network attached to a port on the managed device. The
managed device can automatically send a notification when a statistic crosses an alarm threshold, so the
NMS does not need to constantly poll MIB variables and compare the results.

RMON uses SNMP notifications to notify NMSs of various alarm conditions such as broadcast traffic
threshold exceeded. In contrast, SNMP reports function and inferface operating status changes such as
link up, link down, and module failure.

HP devices provide an embedded RMON agent as the RMON monitor. An NMS can perform basic
SNMP operations to access the RMON MIB.

Working mechanism

RMON monitors typically take one of the following forms:

o Dedicated RMON probes—NMSs can obtain management information from RMON probes
directly and control network resources. NMSs can obtain all RMON MIB information by using this
method.

e RMON agents embedded in network devices—NMSs exchange data with RMON agents by using
basic SNMP operations to gather network management information. Because this method is
resource intensive, most RMON agent implementations provide only four groups of MIB information:
alarm, event, history, and statistics.

You can configure your device to collect and report traffic statistics, error statistics, and performance
statistics.

RMON groups

Among the RFC 2819 defined RMON groups, HP implements the statistics group, history group, event
group, and alarm group supported by the public MIB. HP also implements a private alarm group, which
enhances the standard alarm group.

Ethernet statistics group

The statistics group defines that the system collects various traffic statistics on an interface (only Ethernet
interfaces are supported), and saves the statistics in the Ethernet statistics table (ethernetStatsTable) for
future retrieval. The interface traffic statistics include network collisions, CRC alignment errors,
undersize/oversize packets, broadcasts, multicasts, bytes received, and packets received.

After you create a statistics entry for an interface, the statistics group starts to collect traffic statistics on the
interface. The statistics in the Ethernet statistics table are cumulative sums.
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History group

The history group defines that the system periodically collects traffic statistics on interfaces and saves the
statistics in the history record table (ethernetHistoryTable). The statistics include bandwidth utilization,
number of error packets, and total number of packets.

The history statistics table record traffic statistics collected for each sampling interval. The sampling
interval is user-configurable.

Event group

The event group defines event indexes and controls the generation and notifications of the events

triggered by the alarms defined in the alarm group and the private alarm group. The events can be

handled in one of the following ways:

e log—Llogs event information (including event time and description) in the event log table so the
management device can get the logs through SNMP.

e Trap—Sends an SNMP notification when the event occurs.

e Log-Trap—Logs event information in the event log table and sends an SNMP notification when the
event occurs.

° None—No action.
Alarm group

The RMON alarm group monitors alarm variables, such as the count of incoming packets (etherStatsPkis)
on an interface. After you define an alarm entry, the system gets the value of the monitored alarm
variable at the specified interval. If the value of the monitored variable is greater than or equal to the
rising threshold, a rising event is triggered. If the value of the monitored variable is smaller than or equal
to the falling threshold, a falling event is triggered. The event is then handled as defined in the event

group.
If an alarm entry crosses a threshold multiple times in succession, the RMON agent generates an alarm
event only for the first crossing. For example, if the value of a sampled alarm variable crosses the rising
threshold multiple times before it crosses the falling threshold, only the first crossing triggers a rising alarm
event, as shown in Figure 80.

Figure 80 Rising and falling alarm events

Alarm
variable value

Rising threshold 7DU/—\ fum
Falling threshold x&/ &

Time
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RMON contiguration task list

Configuring the RMON statistics function

The RMON statistics function can be implemented by either the Ethernet statistics group or the history
group, but the objects of the statistics are different, as follows:

e Astatistics object of the Ethernet statistics group is a variable defined in the Ethernet statistics table,
and the recorded content is a cumulative sum of the variable from the time the statistics entry is
created to the current time. Perform the tasks in Table 20 to configure RMON Ethernet statistics

function.

e A statistics object of the history group is the variable defined in the history record table, and the
recorded content is a cumulative sum of the variable in each period. Perform the tasks in Table 21
to configure RMON history statistics function.

Table 20 RMON statistics group configuration task list

Task

Remarks

Configuring a statistics entry

Required.
You can create up to 100 statistics entries in a statistics table.

After you create a statistics entry on an interface, the system collects
various traffic statistics on the interface, including network collisions, CRC
alignment errors, undersize/oversize packets, broadcasts, multicasts,
bytes received, and packets received. The statistics are cleared at a
reboot.

@ IMPORTANT:

You can create only one statistics entry on one interface.

Table 21 RMON history group configuration task list

Task

Remarks

Configuring a history entry

Required.
You can create up to 100 history entries in a history table.

After an entry is created, the system periodically samples the number of
packets received/sent on the current interface. It saves the statistics as an
instance under the leaf node of the etherHistoryEntry table.

(D IMPORTANT:

When you create an entry, if the value of the specified sampling interval is
identical to that of the existing history entry, the system considers their
configurations are the same and the creation fails.

Configuring the RMON alarm function

To send traps to the NMS when an alarm is triggered, configure the SNMP agent as described in
"Configuring SNMP" before configuring the RMON alarm function.

Perform the tasks in Table 22 to configure RMON alarm function.

98



Table 22 RMON alarm configuration task list

Task Remarks

Required.
You can create up to 100 statistics entries in a statistics table.

As the alarm variables that can be configured through the Web interface are MIB
variables that defined in the history group or the statistics group, configure the
RMON Ethernet statistics function or the RMON history statistics function on the

Configuring a statistics monitored Ethernet interface.

entry After you create a statistics entry on an interface, the system collects various traffic
statistics on the interface, including network collisions, CRC alignment errors,
undersize/oversize packets, broadcasts, multicasts, bytes received, and packets
received. The statistics are cleared at a reboot.

(D IMPORTANT:

You can create only one statistics entry for one interface.

Required.
You can create up to 60 event entries for an event table.

An event entry defines event indexes and the actions the system takes, including

log the event, send a trap to the NMS, take no action, and log the event and send

Configuring an event a frap fo the NMS.
entry

@ IMPORTANT:

You cannot create an entry if the values of the specified alarm variable, sampling
interval, sampling type, rising threshold and falling threshold are identical to those
of an existing entry in the system.

Required.
You can create up to 60 alarm entries for an alarm table.

With an alarm entry created, the specified alarm event is triggered when an

Configuring an alarm abnormity occurs. The alarm event defines how to deal with the abnormity.

entry

(D IMPORTANT:

You cannot create an entry if the values of the specified event description, owners,
and actions are identical to those of an existing entry in the system.

Displaying RMON running status

After you configure the RMON statistics function or the alarm function, you can view RMON running
status and verify the configuration by performing tasks in Table 23.

Table 23 Displaying RMON running status

Task Remarks

Display the interface statistics during the period from the time the
Displaying RMON statistics statistics entry is created fo the time the page is displayed. The statistics
are cleared after the device reboots.

After you create a history control entry on an interface, the system
calculates the information of the interface periodically and saves the
Displaying RMON history sampling  information to the etherHistoryEntry table. You can perform this task to
information display the entries in this table. When you configure the history group,
the system specifies the number of history sampling records that can be
displayed and the history sampling interval.
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Task Remarks

If you configure the system to log an event after the event is triggered
Displaying RMON event logs when you configure the event group, the event is recorded in the RMON

log. Perform this task to display the details of the log table.

Contfiguring a statistics entry

1. Select Device > RMON from the navigation tree.

The Statistics tab page appears.
Figure 81 Statistics entry

History Alarm Event Log

k. Index v Search | | Advanced Search

= Index Interface Name Owner
|1 Ethernet1/0/1 usert

Add Del Selected
2. Click Add.
Figure 82 Adding a statistics entry
Histary Alarm Event Log

Add a Statistic Group

Interface Mame: Ethemnet1/0/2 -

Owner. | Chars. (1-127)

» Only one statistics group can be created on one interface.

Status

Active

Operation

w

Iltems marked with an asterisk(*) are required

Cancel

3. Configure a statistic entry as described in Table 24.
4. Click Apply.

Table 24 Configuration items

ltem Description

Interface Name

Only one statistics entry can be created on one interface.

Select the name of the interface on which the statistics entry is created.

Owner Set the owner of the statistics entry.

Configuring a history entry

1. Select Device > RMON from the navigation tree.
2. Click the History tab.
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Figure 83 History entry

Statistics Alarm Event Log
|O\ Index v | Search | adgvanced Search
Buckets Buckets o . -
[ Index Interface Name TeqieeE Granted Interval(Sec) Owner Status
|1 Ethernet1/0/1 10000 10 360 useri Active
Add Del Selected
3. Click Add.
Figure 84 Adding a history entry
Statistics Alarm Event Log
Add a History Group
Interface Mame: Ethernet1/0/1 -
Buckets Granted: *(1-65535)

Interval:

Owner:

*Seconds(5-3600)

Chars. (1-127)

Operation

T
"

Iltems marked with an asterisk(*) are required

Cancel

4. Contfigure a history entry as described in Table 25.

5. Click Apply.

Table 25 Configuration items

ltem

Description

Interface Name

Select the name of the interface on which the history entry is created.

Set the capacity of the history record list corresponding to this history entry (the
maximum number of records that can be saved in the history record list).

If the current number of the entries in the table has reached the maximum

Buckets Granted

number, the system deletes the earliest entry to save the latest one. The statistics

include total number of received packets on the current interface, total number
of broadcast packets, and total number of multicast packets in a sampling

period.
Interval Set the sampling period.
Owner Set the owner of the entry.

Configuring an event entry

1. Select Device > RMON from the navigation tree.

2. Click the Event tab.
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Figure 85 Event entry

Statistics History Alarrm Log
= Index v | =earch | sdvanced Search
[0 Index Crescription I_Er:zr;t Tﬁggitrlrl'?s:e Chner Status
1 null Laog 123111853?1 B usert Active
Add el Selected
3. Click Add.

Figure 86 Adding an event entry

Statistics History Alarm Log

Add an Event Group

Description: Chars. (1-127)
Chiner: Chars. (1-127)
Event Tvpe: CLog ClTrap

lterms marked with an asterisk{™ are required

Apply Cancel

4. Configure an event entry as described in Table 26.
5. Click Apply.

Table 26 Configuration items

Item Description
Description Set the description for the event.
Owner Set the entry owner.

Set the actions that the system takes when the event is triggered:
e Log—The system logs the event.
Event Type o Trap—The system sends a frap in the community name of null.

If you select both Log and Trap, the system logs the event and sends a trap. If
neither is selected, the system takes no action.

Contfiguring an alarm entry

1. Select Device > RMON from the navigation tree.
2. Click the Alarm tab.
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Figure 87 Alarm entry

Statistics History Event Log
= Index ~  Search | Advanced Search
. Current . . Rising Falling
Interval . Interface  Sampling K Rising Falling o .
d o a3 ( Ve Ve Al = S
= Index (Sec) Static ltem Mame Type .,c_n_"nplm; Threshold Threshold Event Event Owner tatus Operation
Value Index  Index
Mumber of
Packet ; 4y
=1 10000 Discarding Ethernet1/0M1 Absolute 0 10000000 100 1 1 useri Active
Events
Add Del Selected
3. Click Add.

Figure 88 Adding an alarm entry

Statistics History Event Log

Add an Alarm Group

Alarm Variable
Static ltem: Mumber of Packet Discarding Events -

Interface Name: Ethemet1/0/1 ~

Sample ltem
Interval: *Seconds(5-655358)

Sample Type: Absolute -

Owner: Chars. (1-127)
Alarm
[[] Create Default Event

Rising Threshold: *(0-2147483647) Rising Event: 1~

Falling Threshold: *(0-2147483647) Falling Event: 1 -

= Before creating Alarm, please create Statistic and Event at fisrt.

ltems marked with an asterisk(*) are required
pply Cancel

4. Configure an alarm entry as described in Table 27.
5. Click Apply.

Table 27 Configuration items

ltem Description

Alarm variable:

Set the traffic statistics that are collected and monitored. For

tatic It . .
Static ltem more information, see Table 28.

Set the name of the interface whose traffic statistics are

Interface Name )
collected and monitored.

Sample ltem:

Interval Set the sampling interval.
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Displaying RMON statistics

1.

2.

ltem Description
Set the sampling type:
o Absolute—Absolute sampling fo obtain the value of the
variable when the sampling time is reached.
Sample Type
o Delta—Delta sampling to obtain the variation value of the
variable during the sampling interval when the sampling
time is reached.
Owner: Set the owner of the alarm entry.
Alarm:

Create Default Event

Select whether to create a default event.

The description of the default event is default event, the action
is log-and-trap, and the owner is default owner.

If there is no event, you can create the default event. And when
the value of the alarm variable is higher than the alarm rising
threshold or lower than the alarm falling threshold, the system
adopts the default action log-and-trap.

Rising Threshold

Set the alarm rising threshold.

Rising Event

Set the action that the system takes when the value of the alarm
variable is higher than the alarm rising threshold.

If you select the Create Default Event box, this option is not
configurable.

Falling Threshold

Set the alarm falling threshold.

Falling Event

Set the action that the system takes when the value of the alarm
variable is lower than the alarm falling threshold.

If you select the Create Default Event box, this option is not
configurable.

Select Device > RMON from the navigation tree.

The page in Figure 81 appears.

Click the " icon for the statistics entry of an interface.
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Figure 89 RMON statistics

History Alarm Event Log

Statistic Group Detail

CurTntlnterrace: Ethernet1/0/M1

Statistic ltem

Statistic Value

Mumber of Received Bytes 34375
Mumber of Received Packets 304
Mumber of Received Broadcasting Packets 180
Mumber of Received Multicast Packets 117
Mumber of Received Packets With CRC Check Failed 0
Mumber of Received Packets Smaller Than 64 Bytes 0
Mumber of Received Packets Larger Than 1518 Bytes 0
Mumber of Received Packets Smaller Than 64 Bytes And FCS Check 0
Failed
Nu_mber of Received Packets Larger Than 1518 Bytes And FCS Check 0
Failed
Mumber of Network Conflicts 0
Mumber of Packet Discarding Events 0
Mumber of Received 64 Bytes Packets 116
Mumber of Received 65 to 127 Bytes Packets 128
Mumber of Received 128 to 255 Bytes Packets 40
Mumber of Received 256 to 511 Bytes Packets 14
Mumber of Received 512 to 1023 Bytes Packets 3]
Mumber of Received 1024 to 1518 Bytes Packets 0
Back Refresh
Table 28 Field description
Field Description

Number of Received Bytes

Total number of octets received by the interface,
corresponding to the MIB node etherStatsOctets.

Number of Received Packets

Total number of packets received by the interface,
corresponding to the MIB node etherStatsPkis.

Number of Received Broadcasting Packets

Total number of broadcast packets received by the
inferface, corresponding to the MIB node
etherStatsBroadcastPkts.

Number of Received Multicast Packets

Total number of multicast packets received by the
inferface, corresponding fo the MIB node
etherStatsMulticastPkts.

Number of Received Packets With CRC Check
Failed

Total number of packets with CRC errors received on the
interface, corresponding to the MIB node
etherStatsCRCAlignErrors.

Number of Received Packets Smaller Than 64
Bytes

Total number of undersize packets (shorter than 64
octets) received by the interface, corresponding fo the
MIB node etherStatsUndersizePkts.

Number of Received Packets Larger Than
1518 Bytes

Total number of oversize packets (longer than 1518
octets) received by the interface, corresponding fo the
MIB node etherStatsOversizePkts.

Number of Received Packets Smaller Than 64
Bytes And FCS Check Failed

Total number of undersize packets (shorter than 64
octets) with CRC errors received by the interface,
corresponding to the MIB node etherStatsFragments.
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Field

Description

Number of Received Packets Larger Than

1518 Bytes And FCS Check Failed

Number of oversize packets (longer than 1518 octets)
with CRC errors received by the interface,
corresponding fo the MIB node etherStatsjabbers.

Number of Network Conflicts

Total number of collisions received on the interface,
corresponding to the MIB node etherStatsCollisions.

Number of Packet Discarding Events

Total number of drop events received on the interface,
corresponding to the MIB node etherStatsDropEvents.

Number of Received 64 Bytes Packets

Total number of received packets with 64 octets on the
inferface, corresponding to the MIB node
etherStatsPkts64Octets.

Number of Received 65 to 127 Bytes Packets

Total number of received packets with 65 to 127 octets
on the inferface, corresponding to the MIB node
etherStatsPkis65t0127Octets.

Number of Received 128 to 255 Bytes
Packets

Total number of received packets with 128 to 255 octets
on the inferface, corresponding to the MIB node
etherStatsPkis 128t02550ctets.

Number of Received 256 to 511 Bytes
Packets

Total number of received packets with 256 to 511 octets
on the inferface, corresponding to the MIB node
etherStatsPkts256t0511Octets.

Number of Received 512 to 1023 Bytes
Packets

Total number of received packets with 512 to 1023
octets on the interface, corresponding to the MIB node
etherStatsPkis512t01023Octets.

Number of Received 1024 to 1518 Bytes
Packets

Total number of received packets with 1024 to 1518
octets on the interface, corresponding to the MIB node
etherStatsPkis1024t015180ctets.

Displaying RMON history sampling information

Select Device > RMON from the navigation tree.

Click the History tab.
Click the

« icon for a history entry.

Figure 90 RMON history sampling information

Statistics Alarm Event Log

History Group Detail

Current Interface:  Ethernet1/0/1

MO Time DropEvents Octets Pkis BroadcastPkis MulticastPkts CRCAlignErrors UndersizePkts OversizePkis Fragments Jabbers Collisions Utilization

lc_>\ Time v | Search | Agvanced Search
2000-4-
1 26 0 0 ] 0 ] 0
132841
2000-4-
2 26 0 0 ] 0 0 0
133441
2000-4-
3 26 o 38898 348 2008 131 o
13:40:41
Back
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Table 29 Field description

Field Description
Number of the entry in the system buffer.

NO Statistics are numbered chronologically when they are saved to the system
buffer.

Time Time at which the information is saved.

DropEvents Dropped pac.:kets during the sampling period, corresponding to the MIB
node etherHistoryDropEvents.

Oclets Number of octets received during the sampling period, corresponding to the
MIB node etherHistoryOctets.

Pkt Number of packets received during the sampling period, corresponding to

s the MIB node etherHistoryPkts.

Number of broadcasts received during the sampling period, corresponding

BroadcastPkts to the MIB node etherHistoryBroadcastPkts.

MulticastPkis Number of multicasts received during the sampling period, corresponding to

the MIB node etherHistoryMulticastPkis.

CRCAlignErrors

Number of packets received with CRC alignment errors during the sampling
period, corresponding to the MIB node etherHistoryCRCAlignErrors.

UndersizePkts

Number of undersize packets received during the sampling period,
corresponding to the MIB node etherHistoryUndersizePkts.

OversizePkts

Number of oversize packets received during the sampling period,
corresponding to the MIB node etherHistoryOversizePkts.

Number of fragments received during the sampling period, corresponding to

Fragments the MIB node etherHistoryFragments.
Number of jabbers received during the sampling period, corresponding to
Jabbers the MIB node etherHistoryJabbers.
Support for the field depends on the device model.
Collisions Number of collision packets received during the sampling period,
corresponding to the MIB node etherHistoryCollisions.
Utilization Bandwidth utilization during the sampling period, corresponding to the MIB

node etherHistoryUtilization.

Displaying RMON event logs

1.
2.

Select Device > RMON from the navigation tree.

Click the Log tab.
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Figure 91 Log tab

Statistics Histary Alarm Event

I Event Index | Search | advanced Search
Ewvent Log ' -
Indes I Log Time Description

The 1.3.6.1.21.16.1.1.1.4.1 defined in alarmEntry 1, uprise
10000000 with alarm value 11779184 Alarm sample type is
absolute

2011-5-16
16:18:37

Refresh

In this example, event 1 has generated one log, which is triggered because the alarm value

(11779194) exceeds the rising threshold (10000000). The sampling type is absolute.

RMON configuration example

Network requirements

As shown in Figure 92, create an entry in the RMON Ethernet statistics table to gather statistics on
Ethernet 1/0/1 with the sampling interval being 10 seconds. Perform corresponding configurations so
that the system logs the event when the number of bytes received on the interface more than 1000 or less
than 100.

Figure 92 Network diagram

Agent
Eth1/0/1
Internet

Server NMS

Configuration procedure
1. Configure RMON to gather statistics for Ethernet 1/0/1:
a. Select Device > RMON from the navigation tree.
The Statistics tab page appears.
b. Click Add.
The page in Figure 93 appears.

c. Select Ethernet1/0/1 from the Interface Name list, type user1 in the Owner field, and click
Apply.
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Figure 93 Adding a statistics entry

History Alarm Event Log

Add a Statistic Group

Interface Mame: Ethermet1/0/1 -

Owner. userT| Chars. (1-127)

» Only one statistics group can be created on one interface.
ltems marked with an asterisk(*) are required

Cancel

Display RMON statistics for Ethernet 1/0/1:
a. Click the icon ™= corresponding to Ethernet 1/0/1.

b. Display this information as shown in Figure 94.
Figure 94 Displaying RMON statistics

History Alarm Event Log

Statistic Group Detail

Curlfnt Interface: Ethernet1/0/1

Statistic ltem Statistic Value
Mumber of Received Bytes 34375
Number of Received Packets 304
Mumber of Received Broadcasting Packets 180
Mumber of Received Multicast Packets 17
Mumber of Received Packets With CRC Check Failed 0
Mumber of Received Packets Smaller Than 64 Bytes 0
Mumber of Received Packets Larger Than 1518 Bytes 0
Mumber of Received Packets Smaller Than 64 Bytes And FCS Check 0
Failed
Mumber of Received Packets Larger Than 1518 Bytes And FCS Check 0
Failed
Mumber of Network Conflicts 0
Mumber of Packet Discarding Events 0
Mumber of Received 64 Bytes Packets 116
Mumber of Received 65 to 127 Bytes Packets 128
Mumber of Received 128 to 255 Bytes Packets 40
Mumber of Received 256 to 511 Bytes Packets 14
Mumber of Received 512 to 1023 Bytes Packets i}
Mumber of Received 1024 to 1518 Bytes Packets 0

Back Refresh

Create an event to start logging after the event is triggered:
a. Click the Event tab.
b. Click Add.
The page in Figure 95 appears.
c. Type user1l-rmon in the Owner field, select the box before Log, and click Apply.

d. The page displays the event entry, and you can see that the entry index of the new event is 1,
as shown in Figure 96.
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Figure 95 Configuring an event group

Statistics History Alarm Log

Add an Event Group

Description: | |Char5. (1-127
Crmar: |user1 |Char5. {1-127)
Event Type: Log [ Trap

lterms marked with an asterisk{*) are required

Cancel

Figure 96 Displaying the index of an event entry

Statistics History Alarm Log
= |Index ¥ | Search | sdvanced Search
- Event Evnet Last
(1 Index Crescription Twpe Trigger Time Dwner Status
] |1 null Log - useri Aptive
Add Cel Selected

Configure an alarm group to sample received bytes on Ethernet 1/0/1. When the received bytes

exceed the rising or falling threshold, logging is enabled:
a. Click the Alarm tab.
b. Click Add.

The page in Figure 97 appears.

c. Select Number of Received Bytes from the Static ltem list, select Ethernet1/0/1 from the
Interface Name list, enter 10 in the Interval field, select Delta from the Simple Type list, enter
user1 in the Owner field, enter 1000 in the Rising Threshold field, select 1 from the Rising Event
list, enter 100 in the Falling Threshold field, select 1 from the Falling Event list, and click Apply.
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Figure 97 Configuring an alarm group

Statistics History Event Log

Add an Alarm Group

Alarm Variable

Static ltem: Number of Packet Discarding Events -
Interface Name: Ethernet1/0M1 ~
Sample ltem
Interval: 10 *Seconds(5-65535)
Sample Type: Delta -
owner: userl Chars. (1-127)
Alarm
[C] Create Default Event
Rising Threshald: 1000 “(0-2147483647) RisingEvent: 1 +
Falling Threshold: 100 *(0-2147483647) FallingEvent. 1 ~

» Before creating Alarm, please create Statistic and Event at fisrt.

ltems marked with an asterisk(*) are required
Apply Cancel

Verifying the configuration

After the above configuration, when the alarm event is triggered, you can display log information for
event 1 on the Web interface.

1. Select Device > RMON from the navigation tree.

2. Click the Log tab.

The log page appears. The log in this example indicates that event 1 generated one log, which
was triggered because the alarm value (22050) exceeded the rising threshold (1000). The
sampling type is absolute.

Figure 98 Log information for event 1

Statistics History Alarm Event
= Event Index | Search | sdvanced Search
Ewvent Log . .
Indes I Log Time Description
1 ’ 2011-5-16 The 1.3.61.2.1.16.1.1.1.4.1 defined in alarmEntry 1, uprise 1000
16:32:53 with alarm value 22050, Alarm sample type is delta
Refrash
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Configuring energy saving

Energy saving enables a port to operate at the lowest transmission speed, disable PoE, or go down
during a specific time range on certain days of a week. The port resumes when the effective time period
ends.

Contfiguring energy saving on a port

1. Select Device > Energy Saving from the navigation tree to enter the energy saving configuration
page.
2. Click a port.

Figure 99 Energy saving configuration page

Flease select a port:

Lfelalafolnlalefalalalz] 1910.24-PoE+ (1.
LR EILILIE] BIEIRIE]

Index Time Range Sun  Mon Tue Wed Thu Fri Sat PoE Disabled LowestSpeed  Shutdown
1 08:30-16:00 B & m O b =
2 22:00-03100 0 ®E @ F B [ [ El
3 00:00-00:00 BE B B O B B B | ] [
4 00:00-00:00 B B B B B B [ [ (]
5 00:00-00:00 BE B B O B B H [ O [
Mote:lf PoE is enabled through a PoE profile, PoE configured in energy saving does not take effect.
Cancel
3. Configure an energy saving policy for the port as described in Table 30.
4.  Click Apply.
Table 30 Configuration items
ltem Description
Time Range Set the time period when the port is in the state of energy saving.
@ IMPORTANT:
e Up fo five energy saving policies with different time ranges can be configured on a
port.
Sun through Sat o Specify the start time and end time in units of 5 minutes, such as 08:05 to 10:15.

Otherwise, the start time is postponed and the end time is brought forward so that
they meet the requirements. For example, if you set the time range to 08:08 to
10:12, the effective time range is 08:10 to 10:10.

PoE Disabled Disable PoE on the port.
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ltem Description

Set the port o transmit data at the lowest speed.

Lowest Speed If you configure the lowest speed limit on a port that does not support 10 Mbps, the
configuration cannot take effect.

Shut down the port.

Shutdown An energy saving policy can have all the three energy saving schemes configured, of
which the shutdown scheme takes the highest priority.
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Configuring SNMP

This chapter provides an overview of the Simple Network Management Protocol (SNMP) and guides you
through the configuration procedure.

Overview

SNMP is an Infernet standard protocol widely used for a management station to access and operate the
devices on a network, regardless of their vendors, physical characteristics and interconnect technologies.

SNMP enables network administrators to read and set the variables on managed devices for state
monitoring, troubleshooting, statistics collection, and other management purposes.

SNMP mechanism

The SNMP framework comprises the following elements:

e SNMP manager—Works on an NMS to monitor and manage the SNMP-capable devices in the
network.

e SNMP agent—Works on a managed device to receive and handle requests from the NMS, and
send traps to the NMS when some events, such as interface state change, occur.

e Management Information Base (MIB)—Specifies the variables (for example, interface status and
CPU usage) maintained by the SNMP agent for the SNMP manager to read and set.

Figure 100 Relationship between an NMS, agent and MIB
Get/Set requests

8$—

Get/Set responses
NMS and Traps

A MIB stores variables called "nodes" or "objects" in a tree hierarchy and identifies each node with a
unique OID. An OID is a string of numbers that describes the path from the root node to a leaf node. For
example, the object B in Figure 101 is uniquely identified by the OID {1.2.1.1}.

Figure 101 MIB tree

SNMP provides the following basic operations:
o Get—The NMS retrieves SNMP object nodes in an agent MIB.
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e Set—The NMS modifies the value of an object node in an agent MIB.

e Notifications—Includes traps and informs. SNMP agent sends traps or informs to report events to
the NMS. The difference between these two types of notification is that informs require
acknowledgement but traps do not. The device supports only traps.

SNMP protocol versions

HP supports SNMPv1, SNMPv2¢, and SNMPv3. An NMS and an SNMP agent must use the same
SNMP version to communicate with each other.

e SNMPv1—Uses community names for authentication. To access an SNMP agent, an NMS must use
the same community name as set on the SNMP agent. If the community name used by the NMS is
different from the community name set on the agent, the NMS cannot establish an SNMP session to
access the agent or receive traps and notifications from the agent.

e SNMPv2c—Uses community names for authentication. SNMPv2c is compatible with SNMPv 1, but
supports more operation modes, data types, and error codes.

e SNMPv3—Uses a user-based security model (USM) to secure SNMP communication. You can
configure authentication and privacy mechanisms to authenticate and encrypt SNMP packets for
integrity, authenticity, and confidentiality.

Recommended configuration procedure

SNMPv3 differs from SNMPv1 and SNMPv2c in many ways. Their configuration procedures are
described in separate sections.

Table 31 SNMPv1 or SNMPv2c configuration task list

Task

Remarks

Enabling SNMP agent

Required.
The SNMP agent function is disabled by default.

@ IMPORTANT:

If SNMP agent is disabled, all SNMP agent-related configurations are
removed.

Optional.

2. Configuring an SNMP view After creating SNMP views, you can specify an SNMP view for an
SNMP community to limit the MIB objects that can be accessed by the
SNMP community.
3. Configuring an SNMP community  Required.
Optional.
Allows you to configure that the agent can send SNMP traps to the
NMS, and configure information about the target host (usually the
4. Configuring SNMP trap function  NMS) of the SNMP traps.
The SNMP agent sends traps to inform the NMS of imporfant events,
such as a reboot.
By default, an agent is allowed to send SNMP traps to the NMS.
5. Displaying SNMP packet statistics ~ Optional.
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Table 32 SNMPv3 configuration task list

Task

Remarks

1. Enabling SNMP agent

Required.
The SNMP agent function is disabled by default.

@ IMPORTANT:

If SNMP agent is disabled, all SNMP agent-related configurations are
removed.

2. Configuring an SNMP view

Optional.

After creating SNMP views, you can specify an SNMP view for an SNMP
group to limit the MIB objects that can be accessed by the SNMP group.

3. Configuring an SNMP group

Required.

After creating an SNMP group, you can add SNMP users to the group
when creating the users. Therefore, you can realize centralized
management of users in the group through the management of the group.

4. Configuring an SNMP user

Required.

Before creating an SNMP user, you need to create the SNMP group to
which the user belongs.

© IMPORTANT:

After you change the local engine ID, the existing SNMPv3 users become
invalid, and you must re-create the SNMPv3 users. For more information
about engine ID, see "Enabling SNMP agent."

5. Configuring SNMP trap
function

Optional.

Allows you to configure that the agent can send SNMP traps to the NMS,
and configure information about the target host (usually the NMS) of the
SNMP traps.
The SNMP agent sends traps to inform the NMS of important events, such
as a reboot.

By default, an agent is allowed to send SNMP traps to the NMS.

6. Displaying SNMP packet
statistics

Optional.

Enabli

1.

ng SNMP agent

Select Device > SNMP from the navigation tree.

The SNMP configuration page appears.
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Figure 102 Setup tab

Community Group User Trap iy
SMMP @ Enable O Disabla
Local Engine 1D BO00R3A2033CESARCDIARE *(10-54 Hex Chars.)
Maximum Packet Size 1500 "Bytes{484-17840, Default=1500)
Contact Hewlett-Packard Development Compar+(1-200 Chars.)
Laocation HF *(1-200 Chars.)
SNMP Yarsion Owvi Owze M3

Mote: Ifyou disable SMMP, all SMMP related configurations will not be sawved.
fterns marked with an asterisk(®) are required

Apply Cancel

SHMP Statistics Count
Wessages delivered ta the ShMP entity
Messages which were for an unsupported version
Messages which used a SMMP community name not known
Messages which represented an illegal operation for the community supplied
ASM.1 or BER errors in the process of decoding
W8 abjects retrieved successfully
MIB ohjects altered successfully
GetRequest-PDU accepted and processed
GetMextRequestPDU accepted and processed
SetRequestPDU accepted and processed
Messages passed from the SNMP entity
SMMF PDUs which had tooBig error-status (Maximum packet size 1500)
SHMP PDUs which had noSuchMame error-status
SMMP PDUs which had badvalue error-status
ShMP PDUs which had genErr error-status
GetResponse-PDU accepted and processed
Trap POUs accepted and pracessed

o Y e e Y e N e Y e T e e e Y e Y e Y e Y Y e Y e Y e e

17 records | 100 % \per page | page 141, record 1-17 | 1
Refresh

2. Configure SNMP settings on the upper part of the page as described in Table 33.
3. Click Apply.

Table 33 Configuration items

ltem

Description

SNMP

Specify to enable or disable SNMP agent.

Local Engine ID

Configure the local engine ID.

The validity of a user after it is created depends on the engine ID of the
SNMP agent. If the engine ID when the user is created is not identical to the
current engine ID, the user is invalid.

Maximum Packet Size

Configure the maximum size of an SNMP packet that the agent can receive
or send.

Contact

Set a character string o describe contact information for system
maintenance.

If the device is faulty, the maintainer can contact the manufacture factory
according to the contact information of the device.
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ltem Description

Location Set a character string to describe the physical location of the device.

SNMP Version Set the SNMP version run by the system.

Contiguring an SNMP view

Creating an SNMP view

3.

Select Device > SNMP from the navigation tree.
Click the View tab.
The View tab appears.

Figure 103 View tab

Setup Cammunity Group Ilser
|°\ |\=’iew Mame » | Search
Wiew Mamet Rule MIB Subtree QID
wiewDefault

WiewDefault  Included 1

WiewDefault  Excluded 1.3.6.1.6.3.145
YiewDefaull  Excluded 1.3.6.1.6.3.16
WiewDefaull  Excluded 1.3.61.63.18
ViewDefault  Excluded 1.3.6.1.4.1.25506.2.111

Add

Click Add.
The Add View window appears.

Figure 104 Creating an SNMP view (1)

Please input the name of the view you want to create.

YWiew Mame

Apply Cancel

Trap

| Advanced Search

Subtree Mask

(1-32 Chars)

Type the view name.
Click Apply.
The page in Figure 105 appears.

Configure the parameters as described in Table 34.

Click Add to add the rule into the list box at the lower part of the page.
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8. Repeat steps 6 and 7 to add more rules for the SNMP view.
9.  Click Apply.

To cancel the view, click Cancel.

Figure 105 Creating an SNMP view (2)

Add Wiew
Wiew Mame Wi el
Rule @ Included O Excluded
MIB Subtres QID Fi1-255 Chars)
Subtree Mask (2-32Hex Chars.)
[tems marked with an asterisk(™) are required
Add
Rule MIB Subtree OI0 Subtree Mask Qperation

Apply Cancel

Table 34 Configuration items

ltem Description
View Name Set the SNMP view name.
Rule Select to exclude or include the objects in the view range determined by the MIB

subtree OID and subtree mask.

Set the MIB subtree OID (such as 1.4.5.3.1) or name (such as system).

MIB Subtree OID MIB subtree OID identifies the position of a node in the MIB tree, and it can
uniquely identify a MIB subtree.

Set the subtree mask, a hexadecimal string. Its length must be an even number in

the range of 2 to 32.
Subtree Mask

If no subtree mask is specified, the default subtree mask (all Fs) will be used for
mask-OID matching.

Adding rules to an SNMP view

Select Device > SNMP from the navigation tree.
2. Click the View tab.
The page in Figure 103 appears.

3. Click the = icon of the target view.

The Add rule for the view ViewDefault window appears.
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Figure 106 Adding rules to an SNMP view

Add rule for the view ViewDefault

Rule @ Included O Excluded
MIB Subtree OID | ~(1-255Chars.
Subtree Mask | (2-32Hex Chars.)

lterms marked with an asterisk(®) are required

Apply Cancel

4. Configure the parameters as described in Table 34.
5. Click Apply.

NOTE:

You can also click the % icon corresponding to the specified view on the page as shown in Figure 103,
and then you can enter the page to modify the view.

Contiguring an SNMP community

Select Device > SNMP from the navigation tree.
2. Click the Community tab.
The Community tab appears.

Figure 107 Configuring an SNMP community

Setup Group zer Trap Wiew
R Commurity Name v | Searth | sgvanced Search
[F] Caommunity MNarme Aé'i:ge}_lsts MIB *iewy ACL Cperation
[ cammunity Read only  WiewDefault 2001 @ ﬁl
Add Delete Selected
3. Click Add.

The Add SNMP Community page appears.
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Figure 108 Creating an SNMP Community

Setup

Add SHMP Community

Group Usar Trap Wien

Cammunity Mame
Access Right
Wi

ACL

*1-32Chars. )
Read only w
“iewDefault |+

(2000-2995)

lterns marked with an asteriski™ are required

Apply Cancel

4.  Configure the SNMP community as described in Table 35.

5. Click Apply.

Table 35 Configuration items

ltem

Description

Community Name

Set the SNMP community name.

Access Right

Configure SNMP NMS access right:
o Read only—The NMS can perform read-only operations to the MIB objects
when it uses this community name to access the agent.

¢ Read and write—The NMS can perform both read and write operations to
the MIB objects when it uses this community name to access the agent.

View

Specify the view associated with the community to limit the MIB objects that
can be accessed by the NMS.

ACL

Associate the community with a basic ACL to allow or prohibit the access to
the agent from the NMS with the specified source IP address.

Contiguring an SNMP group

1. Select Device > SNMP from the navigation tree.

2. Click the Group tab.
The Group tab appears.
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Figure 109 SNMP group

Setup Community Lzer Trap W ey
|Q Group Name % | Search | agvanced Search
[0 GroupMame Security Lewvel Read Wiew WEite WiEw Matify Wiews  ACL Operation
[ group MHoAuthitlaPriv ViewDefault YiewDefault YiewDefault 200 m
Add Delete Selected
Click Add.

The Add SNMP Group page appears.
Figure 110 Creating an SNMP group

Setup Comrmunity Iser Trap Wiewy

Add SMMP Group

Group Mame *1-32Chars. )
Security Level MoAuth/MoPriv i

Read Wiew YiewDefault +

Write e v

[ otify Wiew Lv

AL (2000-2999)

[terns marked with an asteriski* are required

Anply Cancel

Configure SNMP group as described in Table 36.
Click Apply.

Table 36 Configuration items

ltem Description

Group Name Set the SNMP group name.

Select the security level for the SNMP group:
e NoAuth/NoPriv—No authentication no privacy.
o Auth/NoPriv—Authentication without privacy.

Security Level o Auth/Priv—Authentication and privacy.

@ IMPORTANT:

For an existing SNMP group, its security level cannot be modified.

Read View Select the read view of the SNMP group.
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ltem Description

Select the write view of the SNMP group.

Write View If no write view is configured, the NMS cannot perform the write operations to all
MIB objects on the device.

Select the notify view (the view that can send trap messages) of the SNMP group.

Notify View

If no notify view is configured, the agent does not send traps to the NMS.

Associate a basic ACL with the group to restrict the source IP address of SNMP
ACL packets. To restrict the intercommunication between the NMS and the agent, you
can allow or prohibit SNMP packets with a specific source IP address.

Configuring an SNMP user

3.

Select Device > SNMP from the navigation tree.

Click the User tab.
The User tab appears.

Figure 111 SNMP user

Setup Coammunity Group
|Q User Mame
i LIzer Mame Group Mame
[ usert ?E;Ejthmnprwj
Add
Click Add.

The Add SNMP User page appears.

Trap Wiewy

v | Search | advanced Search

Authentication

Made Frivacy lode ACL Operation

MD5 DESS6 i
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Figure 112 Creating an SNMP user

Setup Community

Add SMMP User

ger Mame
Security Level
Group Mame

Authentication Mode

Authentication Password

Confirm Authentication Password

Privacy Mode

Privacy Passward

Confirm Privacy Password

ACL

Eroup Trap RH =

*1-32Chars. )
Mosuth/MaP riv hd
graup? { MoAuth/MaPriv) »

(1-Bd4izhars. )

(1-64iChars. )

(1-64Chars.)
(1-64Chars.)

(2000-2999)

lterns marked with an asterisk{® are required

Apply Cancel

4. Contigure the SNMP user as described in Table 37.

5. Click Apply.

Table 37 Configuration items

ltem

Description

User Name

Set the SNMP user name.

Security Level

Select the security level for the SNMP group. The available security
levels are:

¢ NoAuth/NoPriv—No authentication no privacy.
o Auth/NoPriv—Authentication without privacy.
o Auth/Priv—Authentication and privacy.

Group Name

Select an SNMP group to which the user belongs:

e When the security level is NoAuth/NoPriv, you can select an
SNMP group with no authentication no privacy.

e When the security level is Auth/NoPriv, you can select an SNMP
group with no authentication no privacy or authentication without
privacy.

o When the security level is Auth/Priv, you can select an SNMP
group of any security level.

Authentication Mode

Select an authentication mode (including MD5 and SHA) when the
security level is Auth/NoPriv or Auth/Priv.
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ltem Description

Authentication Password Set the authentication password when the security level is

Auth/NoPriv or Auth/Priv.
Confirm Authentication The confirm authentication password must be the same with the
Password authentication password.

Select a privacy mode (including DES56, AES128, and 3DES) when

Privacy Mode the security level is Auth/Priv.

Privacy Password Set the privacy password when the security level is Auth/Priv.

The confirm privacy password must be the same with the privacy

Confirm Privacy Password d
password.

Associate a basic ACL with the user to restrict the source IP address of
SNMP packets. To allow or prohibit the specified NMS to access the
agent by using this user name, you can allow or prohibit SNMP
packets with a specific source IP address.

ACL

Contiguring SNMP trap function

. Select Device > SNMP from the navigation tree.
2. Click the Trap tab.
The Trap tab appears.

Figure 113 Traps configuration

Setup Community Graup lser ey

[¥] Enable SMMP Trap Apply

Trap Target Host

= Destination |P Address v | Search | agvanced Search

Destination P . ) UDP  Security  Security )
O rees IPvaPvBiDomain - Security Name o S - 08 570 DY Operation
[] 10112 IPvd user 162 w3 AuthiPriv ﬂ

Add Delete Selected

3. Select Enable SNMP Trap.
Click Apply to enable the SNMP trap function.

5. Click Add.
The page for adding a target host of SNMP traps appears.
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Figure 114 Adding a target host of SNMP traps

Setup Carmmunity Group User Wi
Add Trap Target Host
Destination IP Address & |PydiDomain IPwE

*1-255Chars. )

Security Mame *1-32Chars. )
LIOP Port 162 *(0-65534, Default=162)
Security Model ywl L

Security Level

lterns marked with an asterisk{™ are reguired

Apply Cancel

6. Configure the settings for the target host as described in Table 38.
7.  Click Apply.

Table 38 Configuration items

ltem Description

Set the destination IP address.

Destination IP Address  Select the IP-address type: IPv4/domain name or IPv6, and then type the
corresponding IP address or domain name in the field according to the IP
address type.

Set the security name, which can be an SNMPv1 community name, an

Security Name SNMPv2c community name, or an SNMPv3 user name.

Set UDP port number.

(D IMPORTANT:

UDP Port The default port number is 162, which is the SNMP-specified port used for
receiving traps on the NMS. Generally (such as using IMC or MIB Browser as the
NMS), you can use the default port number. To change this parameter to another
value, you need fo make sure the configuration is the same with that on the NMS.

Select the security model, for which you must set the SNMP version. For the
Security Model NMS to receive notifications, make sure the SNMP version is the same with that
on the NMS.

Set the authentication and privacy mode for SNMP traps when the security
model is selected as v3. The available security levels are: no authentication no
Security Level privacy, authentication but no privacy, and authentication and privacy.

When the security model is selected as v1 or v2¢, the security level is no
authentication no privacy, and cannot be modified.

Displaying SNMP packet statistics

Select Device > SNMP from the navigation tree.
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The page for displaying SNMP packet statistics appears.
Figure 115 SNMP packet statistics

SMMP Statistics Count
Messages delivered to the SHMP entity
Messages which were for an unsuppaorted version
Messages which used a SMMP community name not known
Messages which represented an illegal operation for the community supplied
ASM.1 or BER errors in the process of decoding
mMIB objects retrieved successiully
MIB ohjects altered successiully
GetRequest-PDU accepted and processed
GethexdRequest-PDU accepted and processed
SetRequest-FDU accepted and processed
Messages passed from the SMMP entity
SHMP PDUs which had tooBig error-status (Maximum packet size 2000)
SMMP FDUs which had noSuchMame error-status
SMMP PDUs which had badWalue error-status
ShMP PDUs which had genErr error-status
GetResponse-PDU accepted and processed
Trap PDUs accepted and processed

o o o o o o o o o o o o oo o oo

Refresh

SNMPv1/v2c contiguration example

Network requirements

As shown in Figure 116, the NMS at 1.1.1.2/24 uses SNMPv 1 or SNMPv2c to manage the switch (agent)
at 1.1.1.1/24, and the switch automatically sends traps to report events to the NMS.

Figure 116 Network diagram

Vlan-int2
@ 1.1.1.1/24 .

Switch NMS
Agent 1.1.1.2/24

Configuring the agent
1. Enable SNMP:

a. Select Device > SNMP from the navigation tree.
The SNMP configuration page appears.
b. Select the Enable option, and select the v1 and v2¢ options.

c. Click Apply.
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Figure 117 Configuring the SNMP agent

Community Group User Trap View
[SNIP ® Enable O Disable|
Local Engine ID 3830303036334132363531333030303C+(10-64 Hex Chars.)
Maximum Packet Size 1600 *Bytes(484-17940, Default = 1500)
Contact (1-200Chars. )
Location (1-200Chars. )
SNMP Version Fvi Fvec [Fhg

Mote: Ifyou disable SNMP, all SNMP related configurations will not be saved.

Ilterms marked with an asterisk(*) are required
Apply Cancel

2. Configure a read-only community:
a. Click the Community tab.
b. Click Add.
The Add SNMP Community page appears.
c. Enter public in the Community Name field, and select Read only from the Access Right list.

d. Click Apply.
Figure 118 Configuring an SNMP read-only community

Setup Group Lzer Trap ey

Add SHMP Community

Comrmunity Marme public *(1-32Chars. )
Access Right ‘ Read anly V|
ACL | \(2000-2999)

[tems marked with an asterisk(™ are required

Cancel

3. Configure a read and write community:
a. Click Add on the Community tab page.
The Add SNMP Community page appears.

b. Enter private in the Community Name field, and select Read and write from the Access Right
list.

c. Click Apply.
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Figure 119 Configuring an SNMP read and write community

Setup Group Usar Trap Wien

Add SHMP Community

Community Mame |private |*(1-320hars.)
Access Right ‘ Read and write V|
ACL | |(2000-2999)

lterns marked with an asteriski™ are required

Zancel

Enable SNMP traps:
a. Click the Trap tab.
The Trap tab page appears.
b. Select Enable SNMP Trap.
c. Click Apply.
Figure 120 Enabling SNMP traps

Setup Community Group zer Wiew

[¥|Enable SNMP Trap  APRIY |

Trap Target Host

|Q Destination IP Address % | Search | advanced Search

Cestination IF ] ' LDP  Security  Security .
ol e IPvdfiPvB/Domain  Security Mame Port Model Lovel Dperation

Add Delete Selected

Configure a target host SNMP traps:
a. Click Add on the Trap tab page.
The page for adding a target host of SNMP traps appears.

b. Select the IPv4/Domain option and type 1.1.1.2 in the following field, type public in the
Security Name field, and select v1 from the Security Model list.

c. Click Apply.
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Figure 121 Adding a trap target host

Setup Community Eroup Lzer RH =
Add Trap Target Host
Destination 1P Address & \PydiDomain  IPv6E
1112 |*(1-256Chars. )
Security Mame |pub|i|: |*(1-320har5.}
UDP Port 162 *(0-65535, Default= 162)
Security Model |v1 V|

Security Level

ltems marked with an asterisk(™ are required

Configuring the NMS

The configuration on the NMS must be consistent with that on the agent. Otherwise, you cannot perform
corresponding operations.

To configure the NMS:
1. Configure the SNMP version for the NMS as v1 or v2c.
2. Create a read-only community and name it public.

3. Create a read and write community and name it private.
For information about how to configure the NMS, see the NMS manual.
Verifying the configuration

After the above configuration, an SNMP connection is established between the NMS and the agent. The
NMS can get and configure the values of some parameters on the agent through MIB nodes.

Disable or enable an idle interface on the agent, and you can see the interface state change traps on the
NMS.

SNMPv3 configuration example

Network requirements

As shown in Figure 122, the NMS (1.1.1.2/24) uses SNMPv3 to monitor and manage the interface status
of the AP (the agent) at 1.1.1.1/24, and the AP automatically sends traps to report events to the NMS.

The NMS and the agent perform authentication when they set up an SNMP session. The authentication
algorithm is MD5 and the authentication key is authkey. The NMS and the AP also encrypt the SNMP
packets between them by using the DES56 algorithm and the privacy key prikey.
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Figure 122 Network diagram

Vian-int2
@ 1.1.1.1/24 ‘

Switch NMS
Agent 1.1.1.2/24

Configuring the agent
1. Enable SNMP agent:

a. Select Device > SNMP from the navigation tree.
The SNMP configuration page appears.
b. Select the Enable option, and select the v3 option.

c. Click Apply.
Figure 123 Configuring the SNMP agent
Community Group User Trap Wiew
[SNIP @ Enable © Disable]|
Local Engine 1D 3830303036334132363531333030303(+(10-64 Hex Chars.)
Maximum Packet Size 1500 *Bytes(484-17940, Default = 1500)
Contact (1-200Chars. )
Location (1-200Chars. )
SNIP Version EEEEEE)

Mote: If you disable SNMP, all SMMP related configurations will not be saved.

Items marked with an asterisk(*) are required
Apply Cancel

2. Configure an SNMP view:
a. Click the View tab.
b. Click Add.
The page for creating an SNMP view appears.
c. Type view1 in the View Name field.

d. Click Apply.
Figure 124 Creating an SNMP view (1)

Please input the name of the view you want to create.

View Mame |view] (1-32 Chars.)

Apply Cancel

e. Onthe page that appears, select the Included option, type the MIB subtree OID interfaces, and
click Add.
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f.  Click Apply.
A configuration progress dialog box appears.

g. Click Close after the configuration process is complete.

Figure 125 Creating an SNMP view (2)

Add Wiew
Wiew Mame e
Rule @ ncloded O Excluded
flB Subiree OID |interfa|:es |*{1-2550har5.}|
Subtree Mask | |{2-32Hex Chars.)
ltermns marked with an asterisk{™ are required
Add

Fule MIE Subtree OI0 Subtree Mask Dperation

|Inc|uded interfaces | m

Cancel

3. Configure an SNMP group:
a. Click the Group tab.
b. Click Add.
The page in Figure 126 appears.

c. Type group] in the Group Name field, select view1 from the Read View list, select view1 from
the Write View list.

d. Click Apply.
Figure 126 Creating an SNMP group

Setup Caormmunity Lser Trap Wiey

Add SHMP Group

Group Mame |grDLID1 |*(1-320hars.}

Security Level ‘ MoAuth/MaPriv V|

Mlotify Wiew

I

ACL \(2000-2989)

[tems marked with an asterisk™ are required

Cancel

4.  Configure an SNMP user:
a. Click the User tab.
b. Click Add.
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The page in Figure 127 appears.

c. Type userl in the User Name field, select Auth/Priv from the Security Level list, select group1
from the Group Name list, select MD5 from the Authentication Mode list, type authkey in the
Authentication Password and Confirm Authentication Password fields, select DES56 from the
Privacy Mode list, and type prikey in the Privacy Password and Confirm Privacy Password

fields.
d. Click Apply.

Figure 127 Creating an SNMP user

Setup Cammunity Group Trap Wiy

Add SMMP User

Lser Marme user *1-32Chars. )
Security Level Auth/Priv v

Group Mame graup? { MoAuth/MoPriv])
Authentication Mode | w
Authentication Password TTITIY (1-B4Chars. )
Confirm Authentication Passward (LLLLTT {1-64Chars. )
Privacy Mode DE=SR hd

Privacy Password LAl (1-64Chars. )
Confirm Privacy Password senene (1-B4Chars. )
ACL (2000-29949)

lterms marked with an asterisk{™) are required

Apply Cancel

5. Enable SNMP traps:
a. Click the Trap tab.
The Trap tab page appears.
b. Select Enable SNMP Trap.
c. Click Apply.
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Figure 128 Enabling SNMP traps

Setup Carmmunity Group Lsar Wie

[¥] Enable SNMP Trap Apply |

Trap Target Host
I Destination |P Address ~ | Search | advanced Search

Destination P . ) UDF  Security  Security )
O e IFudilPvBiDomain - SecurityMame oo e ST Operation

Add Celete Selected

6. Configure a target host SNMP traps:
a. Click Add on the Trap tab page.
The page for adding a target host of SNMP traps appears.

b. Select the IPv4/Domain option and type 1.1.1.2 in the following field, type user1 in the
Security Name field, select v3 from the Security Model list, and select Auth/Priv from the
Security Level list.

c. Click Apply.
Figure 129 Adding a trap target host

Setup Community Eroup Lzer R=
Add Trap Target Host
Destination IP Address & IPvdiDomain 1PV

1112 *(1-265Chars. )

Security Name |user1 |*(1-320hars.}
UDF Fort 162 |*(0-56525, Default= 162)
Security Model |v3 V‘
Security Level Auth/Priv b

lterms marked with an asterisk(™) are required

Configuring the NMS

The configuration on NMS must be consistent with that on the agent. Otherwise, you cannot perform
corresponding operations.

To configure the NMS:
1. Specify the SNMP version for the NMS as v3.
2. Create an SNMP user userl.

3. Enable both authentication and privacy functions

134



4. Use MD5 for authentication and DES56 for encryption.
5.  Set the authentication key to authkey and the privacy key to prikey.
For information about configuring the NMS, see the NMS manual.

Verifying the configuration

After the above configuration, the NMS can establish an SNMP connection with the agent and query
and reconfigure values of objects in the agent MIB.

Disable or enable an idle interface on the agent, and you can see the interface state change traps on the

NMS.
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Displaying interface statistics

The interface statistics module displays statistics about the packets received and sent through interfaces.
To display interface statistics, select Device > Interface Statistics from the navigation tree.

Figure 130 Interface statistics display page

lc_l Interface Name

s
[C] Ethernet1/0/1 29459
[7] Ethernet1/0/2 1420
[7] Ethernet1/0/3 0
[7] Ethernet1/0/id 0
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Table 39 describes the fields on the page.

Table 39 Field description

Field Description

InOctets Total octets of all packets received on the interface.
InUcastPkts Number of received unicast packets.

InNUcastPkts Number of received non-unicast packets.

InDiscards Number of valid packets discarded in the inbound direction.
InErrors Number of received invalid packets.

InUnknownProtos Number of received unknown protocol packets.

OutOctets Total octets of all packets sent through the interface.
OutUcastPkts Number of unicast packets sent through the interface.
OutNUcastPkts Number of non-unicast packets sent through the interface.
OutDiscards Number of valid packets discarded in the outbound direction.
OutErrors Number of invalid packets sent through the interface.
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Field Description

Last statistics clearing time  Last time when the statistics were cleared.
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Configuring VLANs

Overview

Ethernet is a network technology based on the CSMA/CD mechanism. As the medium is shared,

collisions and excessive broadcasts are common on an Ethernet. To address the issue, virtual LAN (VLAN)

was introduced to break a LAN down info separate VLANs. VLANS are isolated from each other at Layer

2. AVLAN is a bridging domain, and all broadcast traffic is contained within it, as shown in Figure 131.
VLAN 2

Figure 131 A VLAN diagram
% ; Switch A @Switch B

Router

VLAN §

AVLAN is logically divided on an organizational basis rather than on a physical basis. For example, all
workstations and servers used by a particular workgroup can be assigned to the same VLAN, regardless
of their physical locations.

VLAN technology delivers the following benefits:

e Confining broadcast traffic within individual VLANS. This reduces bandwidth waste and improves
network performance.

e Improving LAN security. By assigning user groups to different VLANS, you can isolate them at Layer
2. To enable communication between VLANS, routers or Layer 3 switches are required.

e Flexible virtual workgroup creation. As users from the same workgroup can be assigned to the same
VLAN regardless of their physical locations, network construction and maintenance is much easier
and more flexible.

VLAN fundamentals

To enable a network device to identify frames of different VLANSs, a VLAN tag field is inserted into the
data link layer encapsulation. The format of VLAN-tagged frames is defined in IEEE 802.1Q-1999.

In the header of a traditional Ethernet data frame, the field after the destination MAC address and the
source MAC address is the Type field indicating the upper layer protocol type, as shown in Figure 132.
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Figure 132 Traditional Ethernet frame format

DA&SA Type Data FCS

I[EEE 802.1Q inserts a four-byte VLAN tag after the DA&SA field, as shown in Figure 133.
Figure 133 Position and format of VLAN tag

VLAN Tag

A 4

<
<«

DA&SA TPID Priority | CFI | VLANID | Type Data FCS

A VLAN tag comprises the following fields:

Tag protocol identifier (TPID)—The 16-bit TPID field indicates whether the frame is VLAN-tagged
and is 0x8100 by default.

Priority—The 3-bit priority field indicates the 802.1p priority of the frame.

Canonical format indicator (CFl)—The 1-bit CFl field specifies whether the MAC addresses are
encapsulated in the standard format when packets are transmitted across different media. A value
of O indicates that MAC addresses are encapsulated in the standard format. The value of 1
indicates that MAC addresses are encapsulated in a non-standard format. The value of the field is

0 by default.

VLAN ID—The 12-bit VLAN ID field identifies the VLAN the frame belongs to. The VLAN ID range
is 0 to 4095. As O and 4095 are reserved, a VLAN ID actually ranges from 1 to 4094.

A network device handles an incoming frame depending on whether the frame is VLAN tagged and the
value of the VLAN tag, if any.

The Ethernet Il encapsulation format is used in this section. In addition to the Ethernet Il encapsulation
format, Ethernet also supports other encapsulation formats, including 802.2 LLC, 802.2 SNAP, and
802.3 raw. The VLAN tag fields are added to frames encapsulated in these formats for VLAN
identification.

When a frame carrying multiple VLAN tags passes through, the device processes the frame according to
its outer VLAN tag, and transmits the inner tags as payload.

VLAN types

You can implement VLANs based on the following criteria:

Port

MAC address
Protocol

IP subnet
Policy

Other criteria

The Web interface is available only for port-based VLANs, and this chapter introduces only port-based
VLANES.
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Port-based VLAN

Port-based VLANs group VLAN members by port. A port forwards traffic for a VLAN only after it is
assigned to the VLAN.

Port link type

You can configure the link type of a port as access, trunk, or hybrid. The link types use the following
VLAN tag handling methods:

Access port—An access port belongs to only one VLAN and sends traffic untagged. It is usually
used fo connect a terminal device unable to identify VLAN tagged-packets or when it is
unnecessary to separate different VLAN members. As shown in Figure 134, Device A is connected
to common PCs that cannot recognize VLAN tagged-packets, and you must configure Device A's
ports that connect to the PCs as access ports.

Trunk port—A trunk port can carry multiple VLANS to receive and send traffic for them. Except
traffic from the port VLAN ID (PVID), traffic sent through a trunk port will be VLAN tagged. Usually,
ports that connect network devices are configured as trunk ports. As shown in Figure 134, Device
A and Device B need to transmit packets of VLAN 2 and VLAN 3, and you must configure the ports
inferconnecting Device A and Device B as trunk ports and assign them to VLAN 2 and VLAN 3.
Hybrid port—A hybrid port allows traffic of some VLANS to pass through untagged and traffic of
some other VLANSs to pass through tagged. Usually, hybrid ports are configured to connect devices
whose support for VLAN-tagged packets are uncertain. As shown in Figure 134, Device C connects
to a small-sized LAN in which some PCs belong to VLAN 2 and other PCs belong to VLAN 3, and
Device B is uncertain about whether Device C supports VLAN-tagged packets. Configure on Device
B the port connecting to Device C as a hybrid port to allow packets of VLAN 2 and VLAN 3 to pass
through untagged.

Figure 134 Port link types

VLAN 2
VLAN 2

VLAN 3

Device A Device B Device C

Access links are required

Trunk links are reuqired
VLAN 3

Hybrid links are required
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PVID

By default, VLAN 1 is the PVID for all ports. You can change the PVID for a port, as required.

Use the following guidelines when you configure the PVID on a port:

An access port can join only one VLAN. The VLAN to which the access port belongs is the PVID of
the port.

A trunk or hybrid port can join multiple VLANs, and you can configure a PVID for the port.

You can use a nonexistent VLAN as the PVID for a hybrid or trunk port, but not for an access port.
After you delete the VLAN that an access port resides in, the PVID of the port changes to VLAN 1.
However, deleting the VLAN specified as the PVID of a trunk or hybrid port does not affect the PVID
setting on the port.

H3C recommends that you set the same PVID for local and remote ports.

Make sure a port permits its PVID. Otherwise, when the port receives frames tagged with the PVID
or untagged frames, the port drops these frames.

Frame handling methods

The following table shows how ports of different link types handle frames:

Actions Access Trunk Hybrid

In the inbound
direction for an
untagged frame

Tags the frame with the
PVID tag.

Checks whether the PVID is permitted on the port:

If yes, tags the frame with the PVID tag.

If not, drops the frame.

In the inbound
direction for a
tagged frame

e Receives the frame if
its VLAN ID is the
same as the PVID.

o Drops the frame if its
VLAN ID is different
from the PVID.

Receives the frame if its VLAN is permitted on the port.

Drops the frame if its VLAN is not permitted on the port.

In the outbound
direction

Removes the VLAN tag
and sends the frame.

Removes the tag and sends
the frame if the frame carries
the PVID tag and the port
belongs to the PVID.

Sends the frame without
removing the tag if its VLAN is
carried on the port, but is
different from the PVID.

Sends the frame if its VLAN
is permitted on the port. The
frame is sent with the VLAN
tag removed or intact
depending on your
configuration with the port
hybrid vlan command. This
is true of the PVID.
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Recommended VLAN contiguration procedures

Recommended configuration procedure for assigning an
access port to a VLAN

Step Remarks

I- C ea (] A q .
i V NS ae Ulled
: eare one ofr U|l|p|e VLANS

Optional.
2. Configuring the link type of a port. Configure the link type of the port as access.
By default, the link type of a port is access.

Configure the PVID of the

3.  Setting the PVID for a port.
access port.

4. Configuring the access ports as untagged

members of a VLAN:

a. Selecting VLANs
Specify the range of VLANs available for
selection during related operations.
Configure a subset of all existing VLANS.
This step is required before you perform
operations on the Detail, Modify VLAN,
and Modify Port tabs.

b. Modifying a VLAN By default, an access port
Configure the access ports as untagged is an untagged member of
members of the specified VLAN. VIAN 1.

Required.

An access port has only
one untagged VLAN and
the untagged VLAN is its
PVID. The three operations

N/A produce the same result,
and the latest operation
takes effect.

Configure the untagged

5. Modifyi ts.
oditying poris VLAN of the port.

Recommended contiguration procedure for assigning a trunk
port to a VLAN

Step Remarks

I- C: e n A Req .I d
a | g V NS uire
: edre one or U|i|p|e VLANS

Optional.
Configure the link type of the port as trunk.

2. Configuring the link type of a port. To configure a hybrid port as a trunk port, first configure it
as an access port.

By default, the link type of a port is access.

142



Step Remarks
3. Setting the PVID for a port. Contigure the PVID of the
trunk port.
4.  Configure the trunk port as an untagged
member of the specified VLANSs:
a. Selecting VLANs
Specify the range of VLANs available for
selection during related operations.
Confi bset of all existing VLANS.
onfigure a subset of all existing S ON/A

This step is required before you perform
operations on the Detail, Modify VLAN,

and Modify Port tabs.
b. Modifying a VLAN

Configure the trunk port as an untagged

member of the specified VLANS.

5.  Modifying ports.

Configure the untagged
VLAN of the trunk port.

Required.

A trunk port has only one
untagged VLAN and the
untagged VLAN is its PVID.
The three operations produce
the same result, and the latest
operation takes effect.

By default, the untagged
VLAN of a trunk port is VLAN
1.

When you change the
untagged VLAN (PVID) of a
trunk port, the former untagged
VLAN automatically becomes a
tagged VLAN of the trunk port.

6.  Configure the trunk port as a tagged
member of the specified VLANSs:

a. Selecting VLANs

Specify the range of VLANs available for

selection during related operations.

Configure a subset of all existing VLANS.
This step is required before you perform
operations on the Detail, Modify VLAN,

and Modify Port tabs.
b. Modifying a VLAN

Configure the trunk port as a tagged

member of the specified VLANS.

N/A

7. Modifying ports.

Configure the tagged
VLAN of the trunk port.

Required.

A trunk port can have multiple
tagged VLANs. You can
repeat these steps to configure
multiple tagged VLANS for the
trunk port.

Recommended configuration procedure for assigning a hybrid

port to a VLAN

Step

Remarks

1. Creating VLANS.

Required.

Create one or multiple VLANS.

2. Configuring the link type of a port.

Optional.

Configure the link type of the port as hybrid.

To configure a trunk port as a hybrid port, first
configure it as an access port.

If you configure multiple untagged VLANS for a trunk
port at the same time, the trunk port automatically
becomes a hybrid port.

By default, the link type of a port is access.
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Step Remarks

3.

Optional.

Setting the PVID for a port. Configure the PVID of the hybrid port.
By default, the PVID of a hybrid port is VLAN 1.

Configure the hybrid port as an untagged
member of the specified VLANS:
a. Selecting VLANs
Specify the range of VLANSs available for
selection during related operations. Configure
a subset of all existing VLANS. This step is N/A
required before you perform operations on the
Detail, Modify VLAN, and Modify Port tabs.
b. Modifying a VLAN
Configure the hybrid port as an untagged
member of the specified VLAN.

Configure the
Modifying ports. untagged VLAN of the
hybrid port.

Required.

A hybrid port can have
multiple untagged VLANS.
Repeat these steps fo
configure multiple
untagged VLANS for a
hybrid port.

By default, the untagged
VLAN of a hybrid port is
VLAN 1.

Configure the hybrid port as a fagged member of
the specified VLAN:
a. Selecting VLANs
Specify the range of VLANSs available for
selection during related operations. Configure
a subset of all existing VLANS. This step is N/A
required before you perform operations on the
Detail, Modify VLAN, and Modify Port tabs.
b. Modifying a VLAN
Configure the hybrid port as a tagged
member of the specified VLAN.

Configure the tagged
Modifying ports. VLAN of the hybrid
port.

Required.

A hybrid port can have
multiple tagged VLANS.
You can repeat these steps
to configure multiple
tagged VLANSs for the
hybrid port.

Creating VLANs

A

From the navigation tree, select Network > VLAN.
Click Create to enter the page for creating VLANE.
Enter the VLAN IDs, a VLAN ID range, or both.
Click Create.
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Figure 135 Creating VLANSs

Select WVLAN Fart Detail Detail Tadify WLAR Maodify Port Remove
Create:
VLAM [Ds: Example:3, 510
Create
Im} Description
1 WLAR 0001

fadify WLAN description (Mote: you can do this later an the Modify VLAMN page)
Modify the description ofthe selected WLAN:
D Description

(1-32 Chars)

Table 40 Configuration items

ltem Description
VLAN IDs IDs of the VLANS to be created.

o ID—Select the ID of the VLAN whose description string is to be modified.
Modify the description Click the ID of the VLAN to be modified in the list in the middle of the page.

of the selected VLAN e  Description—Set the description string of the selected VLAN.
By default, the description string of a VLAN is its VLAN ID, such as VLAN 0001.

Contiguring the link type of a port

You can also configure the link type of a port on the Setup tab of Device > Port Management. For more
information, see "Managing ports."

To configure the link type of a port:

From the navigation tree, select Network > VLAN.

Click Modify Port.

Select the port that you want to configure on the chassis front panel.
Select the Link Type option.

Set the link type to access, hybrid, or trunk.

Click Apply.

A progress dialog box appears.

o Uk

7. Click Close on the progress dialog box when the dialog box prompts that the configuration
succeeds.
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Figure 136 Modifying ports

Select VLAM Create Port Detail Detail Modify VLAN Remaove

Select Ports

A e o D 1) N 1810-26 Swich
L Lo Ledelol el Lol =]zl

Select All Select None .Not avaliable for selection

Select membership type:

) Untagged () Tagged () NotAMember @ Link Type © PVID

Link Typeg® Access =

Selected ports:

Link Type
Eth1/0/1-Eth1/0/4

Apply Cancel

Setting the PVID for a port

You can also configure the PVID of a port on the Setup tab of Device > Port Management. For more
information, see "Managing ports."

To set the PVID for a port:

1.

2.
3.
4

From the navigation tree, select Network > VLAN.

Click Modify Port.

Select the port that you want to configure on the chassis front panel.
Select the PVID option.

The option allows you to modify the PVID of the port.

Set a PVID for the port. By selecting the Delete box, you can restore the PVID of the port to the
default, which is VLAN 1.

The PVID of an access port must be an existing VLAN.
Click Apply.
A progress dialog box appears.

Click Close on the progress dialog box when the dialog box prompts that the configuration
succeeds.
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Figure 137 Modifying the PVID for a port

Select VLAM Create Port Detail Detail Modify VLARN Remaove

Select Ports

- Cl T 1810-26 Swich
e dloLal Ll el =] 2] )

Select All Select Mone .Not avaliable for selection

Select membership type:

) Untagged ©) Tagged @) MotAMember (0 Link Type @ PVID

PVIDE® [[Delete

Selected ports:

PVID
Eth1/0/1, Eth1/0/3

Apply Cancel

Selecting VLANs

1. From the navigation tree, select Network > VLAN.
The Select VLAN tab is displayed by default for you to select VLANS.

Figure 138 Selecting VLANs

Create Fort Detail Dietail o dify WLARN modify Part Remove

YLAM range display: select an option to view all available YLAMS or a subset of configured YLAMNS.

() Display all VLANS. Mote: This option may reduce browser response time.

O | Display a subset of all configured YWLAMNS, example: 3,5-10.
Select
YWLAN Summary
| ] Description Untagged Membership Tagged Membership

2. Select the Display all VLANs option to display all VLANS, or select the Display a subnet of all
configured VLANSs option to enter the VLAN IDs to be displayed.
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3. Click Select.

Modifying a VLAN

. From the navigation tree, select Network > VLAN.
2. Click Modify VLAN to enter the page for modifying a VLAN.

Figure 139 Modifying a VLAN

Select VLAN Create Port Detail Detail Modify Port Remove
Please select a VLAN to modify: Maodify Description (optional)
Please select a VLANID (1-32 Chars.) Apply

Select membership type:

@ .Untagged DTagged DNotAMember

Select ports to be modified and assigned to this VLAN:

. Mot avaliable for selection

A 1 1 o < B 0 N I 1910.24 Switch
Lzl e e Jled el o d =21z

Mote: You can assign multiple ports in different membership types to this VLAN.

Summary

Untagged Membership Tagged Membership

3. Modify the member ports of a VLAN as described in Table 41.
Click Apply.
A progress dialog box appears.

5. Click Close on the progress dialog box when the dialog box prompts that the configuration
succeeds.

Table 41 Configuration items

ltem Description
Select the VLAN to be modified.

The VLANs available for selection are existing VLAN selected on the page for
selecting VLANS.

Please select a VLAN
to modify

Modify the description string of the selected VLAN.

Modify Description
By default, the description string of a VLAN is its VLAN ID, such as VLAN 0001.
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ltem Description

Set the member type of the port to be modified in the VLAN:
e Untagged—Configures the port to send the traffic of the VLAN after removing the

Select membership VLAN tag.
type o Tagged—Configures the port to send the traffic of the VLAN without removing the
VLAN tag.
e Not a Member—Removes the port from the VLAN.
Select ports to be Select the ports to be modified in the selected VLAN.
modified and When you configure an access port as a tagged member of a VLAN, the link type of the

assigned fo this VIAN port is automatically changed into hybrid.

Moditying ports

1. From the navigation tree, select Network > VLAN.
2. Click Modify Port to enter the page for modifying ports.
Figure 140 Modifying ports

Select VLAN Create Port Detail Detail Modify VLAN Remove

Select Ports

CE Tl =] 1610.28 Swich .
2 Lol lol el le][el=]=] )

Select All SelectNone .Not avaliable for selection

Select membership type:

@ Untagged () Tagged ) NotAMember () Link Type @ PVID

Enter VLAM |Ds to which the port is to be assigned:

WLAM IDs: Example: 1,3,5-10

Selected ports:

Untagged Membership

Apply Cancel

3. Modify the VLANs of a port as described in Table 42,
Click Apply.
A progress dialog box appears.

5. Click Close on the progress dialog box when the dialog box prompts that the configuration
succeeds.
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Table 42 Configuration items

ltem

Description

Select Ports

Select the ports to be modified.

Set the member types of the selected ports to be modified in the specified VLANS:

Untagged—Configures the ports to send the traffic of the VLANSs after removing the VLAN

Select . fags.
;‘;z:bershlp o Tagged—Configures the ports to send the traffic of the VLANs without removing the VLAN
tags.
¢ Not a Member—Removes the ports from the VLANS.
Set the IDs of the VLANSs to or from which the selected ports are to be assigned or removed.
When you set the VLAN IDs, follow these guidelines:
e You cannot configure an access port as an untagged member of a nonexistent VLAN.
VLAN IDs e When you configure an access port as a tagged member of a VLAN, or configure a trunk

port as an untagged member of multiple VLANS in bulk, the link type of the port is
automatically changed into hybrid.

You can configure a hybrid port as a tagged or untagged member of a VLAN only if the
VLAN is an existing, static VLAN.

VLAN configuration example

Network requirements

As shown in Figure 141, trunk port Ethernet 1/0/1 of Switch A is connected to trunk port Ethernet 1/0/1

of Switch B.

Configure the PVID of Ethernet 1/0/1 as VLAN 100, and configure Ethernet 1/0/1 to permit packets
from VLAN 2, VLAN 6 through VLAN 50, and VLAN 100 to pass through.

Figure 141 Network diagram

@ Eth1/0/1

Switch A

Eth1/0/1 @

Switch B

Configuring Switch A

1. Configure Ethernet 1/0/1 as a trunk port and configure VLAN 100 as the PVID:

a. From the navigation tree, select Device > Port Management.

b. Click Setup to enter the page for setting ports.
c. Select Trunk in the Link Type list, select the PVID box, and then enter PVID 100.
d. Select Ethernet 1/0/1 on the chassis front device panel.

e. Click Apply.
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Figure 142 Configuring Ethernet 1/0/1 as a trunk port and its PVID as 100

Summarny Deetail

Basic Configuration

Fort Btate Mo Changs - Speed No Change v  Duplex No Change -
Link Type  Trunk - PVID 100 (1-4094) Gombo Mo Change -
Description Chars. {1-80)

Advanced Configuration

MDI Flow
Mo Changs - Cantral Mo Changs -
Power Maze MAC
Save Mo Changs - Count Mo Changs v (0-8152)
Storm Suppression
Brosdcast Mo Change Multizsst No Change ¥ Unicsst Mo Change
Suppression Suppression Suppression

pps range {1-148810 for 3 100 Mbps port, 1-260000 for a GE port, and 1-250000 for a 10GE port)
kbps range (1-102400 for 3 100 Mbps port, 1-180000 for a GE port, and 1-180000 for 3 10GE port)

1510-24 Switch ...

Select Al Select Mone
Tnit ZFelected Ports
1 Ethl/O/f1

= |t may take some time if you apphy the above settings to multiple ports. Cancel

Create VLAN 2, VLAN 6 through VLAN 50, and VLAN 100:
a. From the navigation tree, select Network > VLAN.

b. Click Create to enter the page for creating VLANS.

c. Enter VLAN IDs 2, 6-50, 100.

d. Click Apply.
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Figure 143 Creating VLAN 2, VLAN 6 through VLAN 50, and VLAN 100

SelectWLAN Fort Detail Detail hd odify WLARN todify Port Remove
Create:
WLAN DS 2, 6-50, 100 Exarnple:3, 5-10
Create
Ing Description
1 YLAR 0001

mModify WLAMN description {Mote: you can do this later on the Modify WVLARM page)
tdodify the description of the selected WLAN:
Ing Diescription

(1-32 Chars)

3. Assign Ethernet 1/0/1 to VLAN 100 as an untagged member:
a. Click Select VLAN to enter the page for selecting VLANS.

b. Select the option before Display a subnet of all configured VLANSs, and enter 1-100 in the field.
c. Click Select.

Figure 144 Setting a VLAN range

Create Port Detail Detail Modify YLAN Modify Port Rermuove

YLAM range display: select an option to view all available VLANS or a subset of configured YLARNS.

(O Display all VLANS. Mote: This option may reduce Browser response time.

(& |1-100 Display a subset of all configured YLANS, example; 3,510,
YLAM Summary
ID Description Untageed Mernbership Tagoed hembership

d. Click Modify VLAN to enter the page for modifying the ports in a VLAN.
e. Select 100 - VLAN 0100 in the Please select a VLAN to modify: list, select the Untagged option,

and select Ethernet 1/0/1 on the chassis front device panel.
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f.  Click Apply.
A configuration progress dialog box appears.
g. After the configuration process is complete, click Close.
Figure 145 Assigning Ethernet 1/0/1 to VLAN 100 as an untagged member

Select VLAN Create Fort Detail Detail Modify Port Remove

Please select a VLAN to modify:
100 - VLAN 0100 -

Modify Description (optional)
VLAN 0100 (1-32 Chars.) Apply

Select membership type:

@
- -Untagged - DTagged - DNotAMember -Notavaliableforseledion

Select ports to be modified and assigned to this VLAN:

A o o K I Y 1910:24 Swich
el Lo Lo flelelede][el=]=]]

Select All Select Mone Mote: You can assign multiple ports in different membership types to this VLAN.
Summary
Untagged Membership Tagged Membership
Eth1/0/1

Cancel

4.  Assign Ethernet 1/0/1 to VLAN 2, and VLAN 6 through VLAN 50 as a tagged member:
a. Click Modify Port to enter the page for modifying the VLANSs to which a port belongs.

b. Select Ethernet 1/0/1 on the chassis front device panel, select the Tagged option, and enter
VLAN IDs 2, 6-50.

c. Click Apply.
A configuration progress dialog box appears.

d. After the configuration process is complete, click Close in the dialog box.
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Figure 146 Assigning Ethernet 1/0/1 to VLAN 2 and to VLANs 6 through 50 as a tagged

member

Select VLAN Create Fort Detail Detail Modify VLAN

Select Ports

0 A A o 0 K I

Remove

Select All Select None

Select membership type:
©) Untagged @ Tagged ©) Not AMember

Enter VLAN 1Ds to which the portis to be assigned:

VLAM IDs: 2.6-50 Example: 1,3,5-10

Selected ports:

Tagged Membership
Eth1/0/1

Configuring Switch B

Configure Switch B in the same way Switch A is configured.

Contiguration guidelines

When you configure VLANS, follow these guidelines:
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- Mot avaliable for selection

7 Link Type © PVID

Apply Cancel

As the default VLAN, VLAN 1 can be neither created nor removed manually.
You cannot manually create or remove VLANS reserved for special purposes.
Dynamic VLANSs cannot be removed on the page for removing VLANS.

You cannot remove a VLAN that has referenced a QoS policy.



Configuring VLAN interfaces

Before creating a VLAN interface, you must create the corresponding VLAN in Network > VLAN. For
more information, see "Configuring VLANs."

Overview

For hosts of different VLANs to communicate, you must use a router or Layer 3 switch to perform layer 3
forwarding. To achieve this, you can use VLAN interfaces.

VLAN interfaces are virtual interfaces used for Layer 3 communication between different VLANs. They do
not exist as physical entities on devices. For each VLAN, you can create one VLAN interface. You can
assign the VLAN interface an IP address, and specify it as the gateway of the VLAN to forward the traffic
destined for an IP network segment different from that of the VLAN.

Creating a VLAN interface

When you create a VLAN interface, you can select to assign an IPv4 address and an IPvé linklocal
address to the VLAN interface in this step or in a separate step. If you do not select to configure an IP
address, you can create the VLAN interface, and configure an IP address for the VLAN interface by
modifying it.

To create a VLAN interface:

1. From the navigation tree, select Network > VLAN Interface.

2. Click Create to enter the page for creating a VLAN interface.
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Figure 147 Creating a VLAN interface

Summany
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IPvd Address:
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Auto

IPvE Address:
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Apply Cancel

3. Configure the VLAN interface as described in Table 43.

4. Click Apply.

Table 43 Configuration items

ltem Description
Inout o VAN [D- Enter the ID of the VLAN interface to be created. Before creating a VLAN interface,
P ’ make sure the corresponding VLAN exists.
DHCP Configure the way in which the VLAN interface gets an IPv4 address.
BOOTP  Allow the VLAN interface to get an IP address automatically by
— selecting the DHCP or BOOTP option. Otherwise, select the Manual
option to manually assign the VLAN interface an IP address. These items
) Manual  After a VLAN interface fails to get an IP address through DHCP are available
Configure o ) - .
pri multiple times, the device stops IP address application and configures  after you
lPr\I/rZGFY the default IP address for the interface. select the
Address IPv4 Configure an IPv4 address for the VLAN intferface. CCfnflgure
Primary IPv4
Address  This field is available after you select the Manual option. Address box.
Set the subnet mask length (or enter a mask in dotted decimal
Mask notation format).
Length

This field is available after you select the Manual option.
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ltem Description
Auto Configure the way in which the VLAN interface gets an IPv6 link-local
address.
Select the Auto or Manual option: These |t§ms
are available
Configure P Auto—The device automatically assigns a link-local address tothe e, you
IPvé Link Manua VLAN interface based on the link-local address prefix (FE80::/64)  gloct the
Local and the link-layer address of the VLAN inferface. Configure
Address ¢ Manual——Requires manual assignment. IPv6 Link
Py Configure an IPv6 link-local address for the VLAN interface. ;I-O:ic:ll'ess box
V .
Address  This field is available after you select the Manual option. The prefix of

the IPv6 link-local address you enter must be FE80::/64.

Moditying a VLAN intertace

By modifying a VLAN interface, you can assign an IPv4 address, an IPvé link-local address, and an IPv6
site-local address, or global unicast address to the VLAN interface, and shut down or bring up the VLAN

interface.

After you modify the IPv4 address and status or the IPv6 address and status, or add an IPv6 unicast
address for a selected VLAN interface on the page for modifying VLAN interfaces, you must click the
correct Apply button to submit the modification.

After you change the IP address of the VLAN interface you are using to log in to the device, you will be
disconnected from the device. You can use the changed IP address to re-log in.

To modify a VLAN interface:
1. From the navigation tree, select Network > VLAN Interface.
2. Click Modify to enter the page for modifying a VLAN interface.

157



Figure 148 Modifying a VLAN interface
Summary Create Remove

SelectVLAN Interface| 1 %

madify [Pvd Address hodify IPvE Address
Modify Primary IP And Status Modify IPvE Link Local Address And Status
Y DHCP O BOOTR O Manual Auto Manual
Admin Status Up M Admin Status
Apply

Add IPwE Unicast Address

ELI-G4

IPvE Address

3. Modify a VLAN interface as described in Table 44.
4. Click Apply.

Table 44 Configuration items

ltem Description

Select the VLAN interface to be configured.

Select VIAN Interface  The VLAN interfaces available for selection in the list are those created on the page

for creating VLAN interfaces.
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ltem Description
DHCP Configure the way in which the VLAN inferface gets an IPv4 address.
BOOTP  Allow the VLAN interface to get an IP address automatically by selecting the DHCP or
— BOOTP option, or manually assign the VLAN interface an IP address by selecting the
Manual  Manual option. In the latter case, you must set the mask length or enter a mask in
dotted decimal notation format.
Select Up or Down from the Admin Status list to bring up or shut down the selected
VLAN interface.
Modify . . . .
Py When the VLAN interface fails, shut down and then bring up the VLAN interface,
Address which might restore the VLAN interface.
Admi By default, a VLAN interface is down if all Ethernet ports in the VLAN are down.
min Otherwise, the VLAN interface is up.
Status
When you set the admin status, follow these guidelines:
e The current VLAN interface state in the Modify IPv4 Address and Modify IPvé
Address frames changes as the VLAN interface state is modified in the Admin
Status list.
o The state of each port in the VLAN is independent of the VLAN interface state.
Auto Configure the way in which the VLAN inferface gets an IPv6 link-local address.
Select the Auto or Manual option:
e Auto—The device automatically assigns a linklocal address to the VLAN interface
Manual according to the link-local address prefix (FE80::/64) and the link-layer address of
the VLAN interface.
e Manual—Configures an IPv6 link-local address for the VLAN interface manually.
Select Up or Down from the Admin Status list to bring up or shut down the selected
VLAN interface.
When the VLAN interface fails, shut down and then enable the VLAN interface, which
might restore the VLAN intferface.
Admi By default, a VLAN interface is down if all Ethernet ports in the VLAN are down.
Sto;msn Otherwise, the VLAN interface is up.
. v
Modify When you set the admin status, follow these guidelines:
1:;3 e The current VLAN interface state in the Modify IPv4 Address and Modify IPvé
ress Address frames changes as the VLAN interface state is modified in the Admin
Status list.
e The state of each port in the VLAN is independent of the VLAN interface state.
Assign an [Pvé site-local address or global unicast address to the VLAN interface.
Add IPvé  Enter an IPv6 address in the field and select a prefix length in the list next to it.
Unicast  The prefix of the IPvé address you entered cannot be FE80::/10, the prefix of the
Address link-local address.
The prefix of the IPv6 site-local address you enter must be FECO::/10.
Select the box to generate IPv6 site-local addresses or global unicast addresses in the
EUL6A 64-bit Extended Unique Identifier (EUl-64) format.

If the EUI-64 box is not specified, manually configured IPvé site-local addresses or
global unicast addresses are used.
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Contiguration guidelines

When you configure VLAN interfaces, follow these guidelines:

A linkllocal address is automatically generated for an IPvé VLAN interface after an IPv6 site-local
address or global unicast address is configured for the VLAN interface. This generated link-local
address is the same as the one generated in the Auto mode. If a manually assigned link-local
address is available, the manually assigned one takes effect. After the manually assigned link-local
address is removed, the automatically generated one takes effect.

For an IPv6 VLAN interface whose IPvé link-local address is generated automatically after you
assign an IPvé site-local address or global unicast address, removing the IPv6 site-local address or
global unicast address also removes the generated [Pvé link-local address.

For IPv6 linkllocal address configuration, manual assignment takes precedence over automatic
generation. If you first adopt the manual assignment and then the automatic generation, the
automatically generated link-local address will not take effect and the link-llocal address of the
interface is still the manually assigned one. However, if you remove the manually assigned one, the
one automatically generated takes effect.

160



Configuring a voice VLAN

Overview

The voice technology is developing quickly, and more and more voice devices are in use. In broadband
communities, data traffic and voice traffic are usually transmitted in the network at the same time. Usually,
voice traffic needs higher priority than data traffic to reduce the transmission delay and packet loss ratio.

A voice VLAN is configured for voice traffic. After assigning the ports that connect to voice devices to a
voice VLAN, the system automatically modifies quality of service (QoS) parameters for voice traffic, to
improve the transmission priority of voice traffic and ensure voice quality.

NOTE:

Common voice devices include IP phones and integrated access devices (IADs). Only IP phones are used
in the voice VLAN configuration examples in this document.

OUIl addresses

A device determines whether an incoming packet is a voice packet by checking its source MAC address.
If the source MAC address of a received packet matches an organizationally unique identifier (OUI) in
the voice device OUI list (referred to as the OUI list in this document) maintained by the switch, the packet
is regarded as a voice packet.

You can add OUI addresses to the OUI list maintained by the device or use the default OUI list shown
in Table 45 for voice traffic identification.

Table 45 The default OUI list

Number OUI Address Vendor
1 0003-6b00-0000 Cisco phone
2 00e0-7500-0000 Polycom phone

An OUI address is usually the first 24 bits of a MAC address (in binary format). It is a globally unique
identifier assigned to a vendor by the IEEE. In this document, however, OUl addresses are used by the
system to determine whether received packets are voice packets and they are the results of the AND

operation of a MAC address and a mask. For more information, see "Adding OUI addresses to the OUI
list."

You can remove default OUI addresses and if needed, add them to the OUI list after their removal.

Voice VLAN assignment modes

A port connected to a voice device, an IP phone for example, can be assigned to a voice VLAN in one
of the following modes:

e Automatic mode—The system matches the source MAC addresses in the protocol packets (tagged
packets) sent by the IP phone upon its power-on against the OUI list. If a match is found, the system
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automatically assigns the receiving port to a voice VLAN, issues ACL rules and configures the
packet precedence. You can configure an aging timer for the voice VLAN. The system will remove
the port from the voice VLAN when the aging timer expires if no voice packet is received on the port
during the aging timer. The system automatically assigns ports to, or removes ports from, a voice
VLAN. Automatic mode is suitable for scenarios where PCs and IP phones connected in series
access the network through the device and ports on the device simultaneously transmit both voice
traffic and data traffic, as shown in Figure 149. When the voice VLAN works normally, if the system
reboots, the system reassigns ports in automatic voice VLAN assignment mode to the voice VLAN
after the reboot, ensuring that existing voice connections can work normally. In this case, voice
traffic streams do not trigger port assignment to the voice VLAN.

Figure 149 PCs and IP phones connected in series access the network

Host IP Phone Device

e Manual mode—You must assign the port to a voice VLAN manually. Then, the system matches the
source MAC addresses in the packets against the OUI addresses. If a match is found, the system
issues ACL rules and configures the packet precedence. In this mode, you must manually assign
ports to, or remove ports from, a voice VLAN. Manual mode is suitable for scenarios where only IP
phones access the network through the device, and ports on the device transmit only voice traffic,
as shown in Figure 150. In this mode, ports assigned to a voice VLAN transmit voice traffic
exclusively, which prevents the impact of data traffic on the transmission of voice traffic.

Figure 150 Only IP phones access the network

Voice gateway

IP Phone IP Phone

Both modes forward tagged packets according to their tags.

Table 46 and Table 47 list the configurations required for ports of different link types to support tagged
or untagged voice traffic sent from IP phones when different voice VLAN assignment modes are
configured.

e IP phones send tagged voice traffic
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Table 46 Required configurations on ports of different link types for them to support tagged voice

traffic
Voice VLAN assignment mode
Port link type  supported for tagged voice Configuration requirements
traffic
Access Manual Configure the PVID of the port as the voice VLAN.
In automatic mode, the PVID of the port cannot be
the voice VLAN.
Trunk Automatic and manual
In manual mode, configure the port to permit
packets of the voice VLAN to pass through.
In automatic mode, the PVID of the port cannot be
the voice VLAN.
Hybrid Automatic and manual
In manual mode, configure the port to permit
packets of the voice VLAN to pass through tagged.
e IP phones send untagged voice traffic

When IP phones send untagged voice traffic, you can only configure the voice traffic receiving
ports on the device to operate in manual voice VLAN assignment mode.

Table 47 Required configurations on ports of different link types for them to support tagged voice

traffic
Voice VLAN assignment mode
Port link type  supported for untagged voice Configuration requirements
traffic
Configure the PVID of the port as the voice
Access Manual VIAN.
Tronk Manual Configure the PVID of the port as the voice

VLAN and assign the port to the voice VLAN.

Configure the PVID of the port as the voice
Hybrid Manual VLAN and configure the port to permit packets
of the voice VLAN to pass through untagged.

NOTE:

« If an IP phone sends tagged voice traffic and its access port is configured with 802.1X authentication
and guest VLAN, you must assign different VLAN IDs for the voice VLAN, the PVID of the access port,
and the 802.1X guest VLAN for the functions to operate normally.

« If an IP phone sends untagged voice traffic, to deliver the voice VLAN function, you must configure the
PVID of the access port as the voice VLAN. As a result, 802.1X authentication does not take effect.

Security mode and normal mode of voice VLANs

Depending on their inbound packet filtering mechanisms, voice VLAN-enabled ports operate in one of
the following modes:

e Normal mode—In this mode, both voice packets and non-voice packets are allowed to pass
through a voice VLAN-enabled inbound port. When receiving a voice packet, the port forwards it
without checking its source MAC address against the OUI addresses configured for the device. If
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the PVID of the port is the voice VLAN and the port operates in manual VLAN assignment mode, the
port forwards all received untagged packets in the voice VLAN. In normal mode, the voice VLANSs
are vulnerable to traffic attacks. Vicious users can forge a large amount of untagged packets and
send them to voice VLAN-enabled ports to consume the voice VLAN bandwidth, affecting normal
voice communication.

e Security mode—In this mode, only voice packets whose source MAC addresses comply with the
recognizable OUI addresses can pass through the voice VLAN-enabled inbound port, but all other
packets are dropped.

In a safe network, you can configure the voice VLANs to operate in normal mode, reducing the
consumption of system resources due to source MAC addresses checking.

HP recommends not transmitting both voice packets and non-voice packets in a voice VLAN. If you have
to, first make sure that the voice VLAN security mode is disabled.

Table 48 How a voice VLAN-enable port processes packets in security/normal mode

Voice VLAN operating mode Packet type Packet processing mode

Untagged packets If the source MAC address of a
packet matches an OUI address
configured for the device, it is
Packets carrying the voice VIAN tag  {orwarded in the voice VIAN;

otherwise, it is dropped.

Security mode If the packet is a voice packet does
not carry the voice VLAN tag or
PVID tag, the packet is dropped.
Packets carrying other tags Otherwise, the packet is
forwarded or dropped depending
on whether the port allows packets
of these VLANS to pass through.

Untagged packets The port does not check the source
MAC addresses of inbound
packets. All types of packets can
be transmitted in the voice VLAN.

Packets carrying the voice VLAN tag
Normal mode

Forwarded or dropped depending
Packets carrying other tags on whether the port allows packets
of these VLANS to pass through

Recommended voice VLAN configuration
procedure

Before configuring the voice VLAN, you must create the VLAN and configure the link type of each port
to be assigned to the VLAN. Because VLAN 1 is the system-default VLAN, you do not need to create it;
however, you cannot configure it as the voice VLAN. For information about port link types, see
"Managing ports."
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Recommended configuration procedure for a port in automatic voice VLAN assignment mode

Step Remarks
(Optional.)
1. Configuring voice VLAN globally Configure the voice VLAN to operate in security mode and configure

the aging timer

2.

(Required.)

Configure the voice VLAN assignment mode of a port as automatic
Configuring voice VLAN on ports  and enable the voice VLAN function on the port.

By default, the voice VLAN assignment mode of a port is automatic,
and the voice VLAN function is disabled on a port.

3.

(Optional.)

Adding OUI addresses fo the The system supports up to 8 OUI addresses.

OUl list By default, the system is configured with two OUl addresses, as shown

in Table 45.

Recommended configuration procedure for a port in manual voice VLAN assignment mode

Step Remarks
N . (Optional.)
1. Configuring voice
VLAN globally Configure the voice VLAN to operate in security mode and configure the aging
timer.
(Required.)

Configure the voice VLAN assignment mode of a port as manual and enable

Configuri i
oraunng veiee voice VLAN on the port.

VLAN on ports
By default, the voice VLAN assignment mode of a port is automatic, and voice
VLAN is disabled on a port.

Addins OUI (Optional.)

oddrlgsgses o the OU  Youcan configure up to 8 OUl addresses.

list By default, the system is configured with the two OUI addresses shown in Table
45.

Contiguring voice VLAN globally

Select Network > Voice VLAN from the navigation tree.
Click the Setup tab.

Figure 151 Configuring voice VLAN

Summary Port Setup QUI Surmmary OUI Add QU Rermave
Yoice WLARM security: Enable w
ellete LA gl Wi 1440 “minutes (5-43200, Default= 14407

lterns marked with an asterisk{™) are required

Apply Cancel
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3. Configure the global voice VLAN settings as described in Table 49.
4.  Click Apply.

Table 49 Configuration items

ltem Description
Select Enable or Disable in the list o enable or disable the voice VLAN security
Voice VLAN security mode.

By default, the voice VLANSs operate in security mode.

Set the voice VLAN aging timer.

The voice VLAN aging timer setting only applies to a port in automatic voice

Voice VLAN aging time VLAN assignment mode. The voice VLAN aging timer starts as soon as the port
is assigned to the voice VLAN. If no voice packet has been received before the
timer expires, the port is removed from the voice VLAN.

Contiguring voice VLAN on ports

1. Select Network > Voice VLAN from the navigation tree.
2. Click the Port Setup tab.
Figure 152 Configuring voice VLAN on ports

Summary Setup OUl Summary QUl Add OUl Remaove
Voice VLAN port mode: Mo Change ~

Voice VLAN port state: Mo Change ~

Voice VLAN 1D: (2-4094)

ltems marked with an asterisk(*) are required

Select ports:

Select All Select Mone

Ports selected for voice VLAN:

Apply Cancel

3. Configure the voice VLAN function for ports as described in Table 50.
4. Click Apply.

Table 50 Configuration items

ltem Description

Set the voice VLAN assignment mode of a port to:
Voice VLAN port mode e Auto—Automatic voice VLAN assignment mode
¢ Manual—Manual voice VLAN assignment mode

166



ltem Description

Select Enable or Disable in the list to enable or disable the voice VLAN function

Voice VLAN port state on the port.

Voice VLAN ID Set the voice VLAN ID of a port when the voice VLAN port state is set to Enable.

Select the port on the chassis front panel.

You can select multiple ports to configure them in bulk. The numbers of the

selected ports will be displayed in the Ports selected for voice VLAN field.
Select Ports NOTE:

To set the voice VLAN assignment mode of a port to automatic, you must make
sure that the link type of the port is trunk or hybrid, and that the port does not
belong to the voice VLAN.

Adding OUI addresses to the OUI list

1. Select Network > Voice VLAN from the navigation tree.
2. Click the OUI Add tab.

Figure 153 Adding OUI addresses to the OUI list
Summary Setup Paort Setup OUl Summary OUl Remove

Specify an OUI and click Apply to add it to the list. There can be 8 entries at most.

OUl Address: *(Example: 0010-dc28-a4e9)
Mask: FFFF-FFO0-0000 -
Description: Chars. (1-30)

ltems marked with an asterisk(*) are required

Apply Cancel

OUl Address Mask Description
0003-6b00-0000 fiff-f00-0000 Cisco phone
00e0-7500-0000 f-f00-0000 Palycom phone

3. Add an OUI address to the list as described in Table 51.
4. Click Apply.

Table 51 Configuration items

ltem Description

OUl Address Set the source MAC address of voice traffic.
Mask Set the mask length of the source MAC address.
Description Set the description of the OUI address entry.
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Voice VLAN configuration examples

Configuring voice VLAN on a port in automatic voice VLAN

assignment mode

Network requirements
As shown in Figure 154:
e Configure VLAN 2 as the voice VLAN allowing only voice traffic to pass through.
o The IP phone connected to hybrid port Ethernet 1/0/1 sends untagged voice traffic.

o Ethernet 1/0/1 operates in automatic VLAN assignment mode. Set the voice VLAN aging timer to

30 minutes.

e  Configure Ethernet 1/0/1 to allow voice packets whose source MAC addresses match the OUI
addresses specified by OUI address 0011-2200-0000 and mask ffff-#f00-0000. The description of

the OUI address entry is test.
Figure 154 Network diagram

Switch A Switch B

Internet

VLAN 2

010-1001 0755-2002
OUI: 0011-2200-0000
Mask: ffff-ff00-0000

Configuring Switch A

1. Create VLAN 2:
a. Select Network > VLAN from the navigation tree.
b. Click the Create tab.
c. Enter VLAN ID 2.
d. Click Create.
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Figure 155 Creating VLAN 2

Select VLAN Fort Detail Detail Modify VLAN Modify Port
Create:
VLAM IDs: 2 Example:3, 5-10
Create
In] Description
1 WLAMN 0001

Modify VLAM description (Mote: you can do this later on the Modify VLAM page)
Madify the description of the selected VLAMN:
In] Description

(1-32 Chars.)

2. Configure Ethernet 1/0/1 as a hybrid port:
a. Select Device > Port Management from the navigation tree.
b. Click the Setup tab.
c. Select Hybrid from the Link Type list.
d. Select Ethernet 1/0/1 from the chassis front panel.
e. Click Apply.
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Figure 156 Configuring Ethernet 1/0/1 as a hybrid port

Summary Detail

Basic Configuration

Port State Mo Change - Speed MNo Change v Duplex No Change -
Link Type Hybrid - 1 pviD (1-4094) Combo Mo Change -
Description Chars. (1-80)

Advanced Configuration

Flow
MDI No Change ~ Caontral No Change -
Max MAC
Power Save No Change - Count MNo Change = (0-8192)
Storm Suppression
Broadcast  'l° Change  ~ Muticast "o Change  ~ Unicast Mo Change ~
Suppression Suppression Suppression

pps range (1-148810 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-100000 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

CEEET el =]

Select All Select None
Unit Selected Ports
1 Ethl/0/1

* |tmaytake some time if you apply the above settings to multiple ports. Apply Cancel

3. Configure the voice VLAN function globally:
a. Select Network > Voice VLAN from the navigation tree.
b. Click the Setup tab.
c. Select Enable in the Voice VLAN security list.
d. Set the voice VLAN aging timer to 30 minutes.
e. Click Apply.

Figure 157 Configuring the voice VLAN function globally

Surmmary Fort Setup DUl sumimary CUl Add DUl Remove

nice YLAMN security:
oice VLAN aging time: 30 minutes (5-43200, Default = 1440)

lterms marked with an asterisk{™) are required

Apphy Cancel

4. Configure voice VLAN on Ethernet 1/0/1:
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a. Click the Port Setup tab.

b. Select Auto in the Voice VLAN port mode list.

c. Select Enable in the Voice VLAN port state list.

d. Enter voice VLAN ID 2.

e. Select Ethernet 1/0/1 on the chassis front panel.

f. Click Apply.

Figure 158 Configuring voice VLAN on Ethernet 1/0/1
Summary Setup OUI Summary OUI Add OUI Remave
Voice VLAN port mode: Auto -

Voice VLAN port state: Enable -
Voice VLAN ID: 2 *(2-4004)

ltems marked with an asterisk(*) are required

Select ports:

(T T =T

Select All SelectNone

Ports selected for voice VLAN:
Eth1/0M1

Apply Cancel

Add OUI addresses to the OUI list:

a. Click the OUI Add tab.

b. Enter OUIl address 0011-2200-0000.
c. Select FFFF-FFO0-0000 in the Mask list.

d. Enter description string fest.

e. Click Apply.
Figure 159 Adding OUI addresses to the OUI list
Summary Setup Port Setup QU Summary QU Remaove
Specify an OUI and click Apply to add itto the list. There can be 8 entries at most.
Ol Address: 0011-2200-0000 *{Example; 0010-dc28-aded)
Mask: FFFF-FF00-0000 -
Description: test Chars. (1-30)

lterns marked with an asterisk(*) are required

Cancel

OUl Address Mask Description
0003-6000-0000 ff-f00-0000 Cisco phone
00e0-7500-0000 fif-ff00-0000 Palycom phone
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Verifying the configuration

1. When the preceding configurations are completed, the OUI Summary tab is displayed by default,
as shown in Figure 160. You can view the information about the newly-added OUI address.

Figure 160 Displaying the current OUI list of the device

Summary Setup Port Setup QU Add QU Remove
OUl Address Mask Description
0003-6b00-0000 fif-f00-0000 Cisco phone
|0011-2200-0000 fifi-f00-0000 test |
00e0-7500-0000 fifi-ff00-0000 Polycom phone

2. Click the Summary tab, where you can view the current voice VLAN information.

Figure 161 Displaying voice VLAN information

Setup Port Setup

WVoice VLAM security:
Voice VLAN aging time:
Maximum of voice YLAMNS:

Current number of voice VLAMNS:

Ports enabled for voice WLAMN:

FPort Mame Voice VLANM 1D
Ethernet1/0/1 2

OUl Summary Ul Add QUlI Remove

Enabled

30 minutes
1

1

Mode
Auto

Contfiguring a voice VLAN on a port in manual voice VLAN

assignment mode

Network requirements

As shown in Figure 162:

e Configure VLAN 2 as a voice VLAN that carries only voice traffic.

e The IP phone connected to hybrid port Ethernet 1/0/1 sends untagged voice traffic.

e  Ethernet 1/0/1 operates in manual voice VLAN assignment mode and allows voice packets whose
source MAC addresses match the OUI addresses specified by OUI address 0011-2200-0000 and
mask ffff-ff00-0000 to pass through. The description of the OUI address entry is test.
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Figure 162 Network diagram

Switch A Switch B

Internet

010-1001 0755-2002

OuUI: 0011-2200-0000
Mask: ffff-ff00-0000

Configuring Switch A

1. Create VLAN 2:
a. Select Network > VLAN from the navigation tree.
b. Click the Create tab.
c. Enter VIAN ID 2.
d. Click Create.

Figure 163 Creating VLAN 2

Select VLAN Port Detail Dietail Modify VLAN Modify Port
Create:
VLANM IDs: 2 Example.3, 5-10
Create
D Cescription
1 YLAM 0001

Maodify WLAN description (Mote: you can do this later on the Modify VLAMN page)
WMaodify the description of the selected VLARN:
D Cescription

(1-32 Chars.}

2. Configure Ethernet 1/0/1 as a hybrid port and configure its PVID as VLAN 2:
a. Select Device > Port Management from the navigation tree.
b. Click the Setup tab.
c. Select Hybrid from the Link Type list.
d. Select the PVID box and enter 2 in the field.
e. Select Ethernet 1/0/1 from the chassis front panel.
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f.  Click Apply.
Figure 164 Configuring Ethernet 1/0/1 as a hybrid port

Summary Detail

Basic Configuration

PortState Mo Change - Speed Mo Change - Duplex Mo Change -
Link Type Hybrid - PVID 2 (1-4094) Combo Mo Change -
Description Chars. (1-80)

Advanced Configuration

Flow
MDI MNo Change ~ Contral No Change -
Max MAC
Power Save No Change - e Mo Change - (0-8192)
Storm Suppression
Broadcast No Change  ~ Multicast No Change  ~ Unicast NoChange ~
Suppression Suppression Suppression

pps range (1-148810 for a 100 Mbps port, 1-260000 for a GE port, and 1-260000 for a 10GE port)
kbps range (1-100000 for a 100 Mbps port, 1-180000 for a GE port, and 1-180000 for a 10GE port)

06 A e o o D N I

Select All Select None
Unit Selected Ports
1 Ethl/0/1

* |t may take some time if you apply the above settings to multiple pors. Apply Cancel

Assign Ethernet 1/0/1 to VLAN 2 as an untagged member:
a. Select Network > VLAN from the navigation tree.
b. Click the Modify Port tab.
c. Select Ethernet 1/0/1 from the chassis front panel.
d. Select the Untagged option.
e. Enter VIAN ID 2.
f.  Click Apply.
A configuration progress dialog box appears.

g. After the configuration process is complete, click Close.
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Figure 165 Assigning Ethernet 1/0/1 to VLAN 2 as an untagged member
Select VLAM Create Port Detail Detail Modify WLAM Remove

Select Ports

L]
el Lo de Jlede L Lol la =]

Select All Select None .Not avaliable for selection

Select membership type:

@ Untagged ©) Tagged @) Not A Member () Link Type ) PVID

Enter VLAN IDs to which the portis to be assigned:

VLAN IDs; 2 Example: 1,3,5-10

Selected ports;

Untagged Membership
Eth1/0M1

Cancel

Configure voice VLAN on Ethernet 1/0/1:

a. Select Network > Voice VLAN from the navigation tree.
Click the Port Setup tab.

Select Manual in the Voice VLAN port mode list.

Select Enable in the Voice VLAN port state list.

Enter 2 in the VLAN IDs field.

Select Ethernet 1/0/1 on the chassis front panel.

Click Apply.

S

- 0o o o

@
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Figure 166 Configuring voice VLAN on Ethernet 1/0/1

Summary Setup QU Summary QU Add OUl Remove
Woice VLAN port mode: Manual -

Woice WLAN port state: Enable -

Woice VLAN ID: 2 *(2-4094)

Iltems marked with an asterisk(*) are required

Select ports:

1 O 0 i DY

Selact All Select Mone

Ports selected for voice VLAN:

Cancel

5. Add OUl addresses to the OUI list:
a. Click the OUI Add tab.
b. Enter OUIl address 0011-2200-0000.
c. Select FFFF-FFO0-0000 as the mask.
d. Enter description string test.

e. Click Apply.
Figure 167 Adding OUI addresses to the OUI list

Summary Setup Port Setup OUl Summary OuUl Remave
Specify an OUI and click Apply to add it to the list. There can be 8 entries at most.
OUI Address: 0011-2200-0000 “(Example; 0010-dc28-ade9)
Mask: FFFF-FF00-0000
Description: test Chars. {1-30)

ltems marked with an asterisk(*} are required

Apply Cancel

OUl Address Mask Description
0003-6000-0000 fif-ffo0-0000 Cisco phone
00e0-7500-0000 ff-fO0-0000 Polycom phone

Verifying the configuration

1. When the preceding configurations are complete, the OUl Summary tab is displayed by default,
as shown in Figure 168. You can view the information about the newly-added OUI address.
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2,

Figure 168 Displaying the current OUI list of the device

Summary Setup Port Setup oUl Add QU Remove
QLI Address Mask Description
0003-6b00-0000 fff-ffF00-0000 Cisco phone
[0011-2200-0000 fif-f00-0000 test |
00e0-7500-0000 fiff-fF00-0000 Palycom phone

Click the Summary tab, where you can view the current voice VLAN information.

Figure 169 Displaying the current voice VLAN information

Setup Port Setup QU Summary OUl Add oUl Remove
Voice VLAN security: Enabled
Voice VLAN aging time: 1440 minutes
Maximum of voice VLAMS: 1
Current number of voice VLAMS: 1

Ports enabled for voice VLAM:

Port Mame YWoice VLAM 1D Mode
Ethernet1/0M1 2 Manual

Configuration guidelines

When you configure the voice VLAN function, follow these guidelines:

To remove a VLAN functioning as a voice VLAN, disable its voice VLAN function first.

Only one VLAN is supported and only an existing static VLAN can be configured as the voice
VLAN.

Do not enable the voice VLAN function on a link aggregation group member port.

After you assign a port operating in manual voice VLAN assignment mode to the voice VLAN, the
voice VLAN takes effect.
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Configuring the MAC address table

MAC address configurations related to interfaces apply to Layer 2 Ethernet interfaces and Layer 2
aggregate interfaces only.

This document covers only the configuration of unicast MAC address entries, including static, dynamic,
and blackhole entries.

Overview

To reduce single-destination packet flooding in a switched LAN, an Ethernet device uses a MAC address
table to forward frames. This table describes from which port a MAC address (or host) can be reached.
Upon receiving a frame, the device uses the destination MAC address of the frame to look for a match
in the MAC address table. If a match is found, the device forwards the frame out of the outgoing interface
in the matching entry. If no match is found, the device floods the frame out of all but the incoming port.

How a MAC address entry is created

The device automatically learns entries in the MAC address table, or you can add them manually.
MAC address learning

The device can automatically populate its MAC address table by learning the source MAC addresses of
incoming frames on each port.

When a frame arrives at a port (for example, Port A), the device performs the following tasks:
1. Verifies the source MAC address (for example, MAC-SOURCE) of the frame.
2. Looks up the source MAC address in the MAC address table.

o If an entry is found, the device updates the entry.

o If no entry is found, the device adds an entry for MAC-SOURCE and Port A.

3. When the device receives a frame destined for MAC-SOURCE after learning this source MAC
address, the device finds the MAC-SOURCE entry in the MAC address table and forwards the
frame out of Port A.

The device performs this learning process each time it receives a frame from an unknown source MAC
address until the MAC address table is fully populated.

Manually configuring MAC address entries

With dynamic MAC address learning, a device does not distinguish between illegitimate and legitimate
frames. For example, when a hacker sends frames with a forged source MAC address to a port different
from the one with which the real MAC address is associated, the device creates an entry for the forged
MAC address, and forwards frames destined for the legal user to the hacker instead.

To improve port security, you can manually add MAC address entries to the MAC address table of the
device to bind specific user devices to the port.
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Types of MAC address entries

A MAC address table can contain the following types of entries:

e Static entries—Manually added and never age out.

e Dynamic entries—Manually added or dynamically learned, and might age out.

e Blackhole entries—Manually configured and never age out. They are configured for filtering out
frames with specific source or destination MAC addresses. For example, to block all frames
destined for a specific user for security concerns, you can configure the MAC address of this user

as a blackhole MAC address entry.

A static or blackhole MAC address entry can overwrite a dynamic MAC address entry, but not vice

versa.

Displaying and configuring MAC address entries

1. Select Network > MAC from the navigation tree.

The MAC tab automatically appears, which shows all the MAC address entries on the device.

Figure 170 The MAC tab

Setup
& MAC v | Search | | Advanced Search
[l MAC WLAN 1D Type Port
[] 6431-5045-d29e 1 Learned Ethernet1/0/1
[] 0016-2188-86f 1 Learned Ethernet1/0/23

Add Refresh Del Selected

2. Click Add in the bottom to enter the page for creating MAC address entries.

Figure 171 Creating a MAC address entry

Setup
Add MAC
MALC: *(Example: 0010-dc28-aded)
Type: static -
WLAM: 1 -
Port: Ethernet1/0/1 -

Operation

1]
1]

ltems marked with an asterisk(*) are required

Apply Cancel

3. Configure a MAC address entry as described in Table 52.
4. Click Apply.
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Table 52 Configuration items

ltem Description

MAC Set the MAC address to be added.

Set the type of the MAC address entry:
o Static—Static MAC address entries that never age out.
e Dynamic—Dynamic MAC address entries that will age out.
o Blackhole—Blackhole MAC address entries that never age out.
Type The MAC tab (see Figure 170) displays the following types of MAC address entries:
o Config static—Static MAC address entries manually configured by the users.
o Blackhole—Blackhole MAC address entries.
¢ Learned—Dynamic MAC address entries learned by the device.
o Other—Other types of MAC address entries.

VLAN ID Set the ID of the VLAN to which the MAC address belongs.

Set the port fo which the MAC address belongs. This port must belong to the specified

Port VIAN.

Setting the aging time of MAC address entries

1. Select Network > MAC from the navigation tree.
2. Click the Setup tab to enter the page for setting the MAC address entry aging time.

Figure 172 Setting the aging time for MAC address entries

MAC

Set mac-address aging time

() Mo-aging
@ Aging Time 300 seconds (10-1000000, Default = 300)

Apply

3. Configure the aging time for MAC address entries as described in Table 53.
4. Click Apply.

Table 53 Configuration items

Item Description
No-aging Specify that the MAC address entry never ages out.
Aging time Set the aging time for the MAC address entry.
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MAC address table configuration example

Network requirements

Use the Web-based NMS to configure the MAC address table of the device. Add a static MAC address
00e0-£c35-dc71 under Ethernet 1/0/1 in VLAN 1.

Creating a static MAC address entry

1. Select Network > MAC from the navigation tree.
By default, the MAC tab is displayed.
Click Add.
Configure a MAC address entry:
a. Type MAC address 00e0-fc35-dc71.
b. Select static from the Type list.
c. Select 1 from the VLAN list.
d. Select Ethernet1/0/1 from the Port list.
4. Click Apply.

Figure 173 Creating a static MAC address entry

Setup
Add MAC
MAC: 00e0-fc35-de 71| *(Example: 0010-dc28-aded)
Type: static -
WLAN: 1 -
Port: Ethernet1/0/1 -

ltems marked with an asterisk(*) are required

Cancel
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Configuring MSTP

Overview

Spanning tree protocols eliminate loops in a physical link-redundant network by selectively blocking
redundant links and putting them in a standby state.

The recent versions of STP include the Rapid Spanning Tree Protocol (RSTP) and the Multiple Spanning
Tree Protocol (MSTP).

Introduction to STP

STP was developed based on the 802.1d standard of IEEE to eliminate loops at the data link layer in a
LAN. Networks often have redundant links as backups in case of failures, but loops are a very serious
problem. Devices running STP detect loops in the network by exchanging information with one another,
and eliminate loops by selectively blocking certain ports to prune the loop structure into a loop-free tree
structure. This avoids proliferation and infinite cycling of packets that would occur in a loop network.

In the narrow sense, STP refers to IEEE 802.1d STP. In the broad sense, STP refers to the IEEE 802.1d STP
and various enhanced spanning tree protocols derived from that protocol.

STP protocol packets

STP uses bridge protocol data units (BPDUs), also known as configuration messages, as its protocol
packets. This chapter uses BPDUs to represent all types of spanning tree protocol packets.

STP-enabled network devices exchange BPDUs to establish a spanning tree. BPDUs contain sufficient
information for the network devices to complete spanning tree calculation.

STP uses the following types of BPDUs:

o  Configuration BPDUs—Used for calculating a spanning tree and maintaining the spanning tree
topology.

o  Topology change notification (TCN) BPDUs—Used for notifying the concerned devices of network
topology changes.

Configuration BPDUs contain sufficient information for the network devices to complete spanning tree
calculation. Important fields in a configuration BPDU include the following:

*  Root bridge ID—Consisting of the priority and MAC address of the root bridge.

e Root path cost—Cost of the path to the root bridge denoted by the root identifier from the
transmitting bridge.

o Designated bridge ID—Consisting of the priority and MAC address of the designated bridge.
o Designated port ID—Consisting of the priority and global port number of the designated port.
e Message age—Age of the configuration BPDU while it propagates in the network.

*  Max age—Maximum age of the configuration BPDU stored on a device.

e Hello time—Configuration BPDU transmission interval.
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e  Forward delay—Delay that STP bridges use to transit port state.

The descriptions and examples in this chapter only use the following fields in the configuration BPDUs:

Root bridge ID (represented by device priority)

Root path cost

Designated bridge ID (represented by device priority)

Designated port ID (represented by port name)

Basic concepts in STP

Root bridge

A tree network must have a root bridge. The entire network contains only one root bridge, and all the
other bridges in the network are called "leaf nodes". The root bridge is not permanent, but can change
with changes of the network topology.

Upon initialization of a network, each device generates and periodically sends configuration BPDUs,
with itself as the root bridge. After network convergence, only the root bridge generates and periodically
sends configuration BPDUs. The other devices only forward the BPDUs.

Root port

On a non-root bridge, the port nearest to the root bridge is the root port. The root port communicates with
the root bridge. Each non-root bridge has only one root port. The root bridge has no root port.

Designated bridge and designated port

Classification  Designated bridge Designated port

Device directly connected with the local
For a device device and responsible for forwarding
BPDUs to the local device.

Port through which the designated bridge
forwards BPDUs to the local device.

Device responsible for forwarding BPDUs to  Port through which the designated bridge

Fora LAN this LAN segment. forwards BPDUs to this LAN segment.

As shown in Figure 174, Device B and Device C are connected to the LAN. AP1 and AP2, BP1 and BP2,
and CP1 and CP2 are ports on Device A, Device B, and Device C, respectively.

o If Device A forwards BPDUs to Device B through AP1, the designated bridge for Device B is Device
A, and the designated port of Device B is port AP1 on Device A.

e If Device B forwards BPDUs to the LAN, the designated bridge for the LAN is Device B, and the
designated port for the LAN is the port BP2 on Device B.
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Figure 174 Designated bridges and designated ports

Device A

Device B Device C

Path cost

Path cost is a reference value used for link selection in STP. STP calculates path costs to select the most
robust links and block redundant links that are less robust, to prune the network into a loop-free tree.

All the ports on the root bridge are designated ports.

Calculation process of the STP algorithm

The spanning tree calculation process described in the following sections is a simplified process for
example only.

Calculation process

The STP algorithm uses the following calculation process:
1. Network initialization.

Upon initialization of a device, each port generates a BPDU with the port as the designated port,
the device as the root bridge, O as the root path cost, and the device ID as the designated bridge
ID.

2. Root bridge selection.

Initially, each STP-enabled device on the network assumes itself to be the root bridge, with its own
device ID as the root bridge ID. By exchanging configuration BPDUs, the devices compare their
root bridge IDs to elect the device with the smallest root bridge ID as the root bridge.

3. Root port and designated ports selection on the non-root bridges.

Step Description

A non-root-bridge device regards the port on which it received the optimum
1 configuration BPDU as the root port. Table 54 describes how the optimum configuration
BPDU is selected.
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Step Description

Based on the configuration BPDU and the path cost of the root port, the device
calculates a designated port configuration BPDU for each of the other poris.

e The root bridge ID is replaced with that of the configuration BPDU of the root port.

2 o The root path cost is replaced with that of the configuration BPDU of the root port plus
the path cost of the root port.

e The designated bridge ID is replaced with the ID of this device.
e The designated port ID is replaced with the ID of this port.

The device compares the calculated configuration BPDU with the configuration BPDU
on the port whose port role will be determined, and acts depending on the result of the
comparison:

e Ifthe calculated configuration BPDU is superior, the device considers this port as the
3 designated port, replaces the configuration BPDU on the port with the calculated
configuration BPDU, and periodically sends the calculated configuration BPDU.

e If the configuration BPDU on the port is superior, the device blocks this port without

updating its configuration BPDU. The blocked port can receive BPDUs, but it cannot
send BPDUs or forward any data.

When the network topology is stable, only the root port and designated ports forward user traffic.
Other ports are all in the blocked state to receive BPDUs but not to forward BPDUs or user traffic.

Table 54 Selecting the optimum configuration BPDU

Step Actions

Upon receiving a configuration BPDU on a port, the device compares the priority of
the received configuration BPDU with that of the configuration BPDU generated by
the port. It takes one of the following actions:

1 o |Ifthe former priority is lower, the device discards the received configuration BPDU
and keeps the configuration BPDU the port generated.

o If the former priority is higher, the device replaces the content of the configuration

BPDU generated by the port with the content of the received configuration BPDU.

The device compares the configuration BPDUs of all the ports, and chooses the
optimum configuration BPDU.

The following are the principles of configuration BPDU comparison:
a. The configuration BPDU with the lowest root bridge ID has the highest priority.

b. If all the configuration BPDUs have the same root bridge ID, their root path costs are compared.
For example, the root path cost in a configuration BPDU plus the path cost of a receiving port
is S. The configuration BPDU with the smallest S value has the highest priority.

c. If all configuration BPDUs have the same root bridge ID and S value, their designated bridge
IDs, designated port IDs, and the IDs of the receiving ports are compared in sequence. The
configuration BPDU that contains a smaller designated bridge ID, designated port ID, or
receiving port ID is selected.

A tree-shape topology forms when the root bridge, root ports, and designated ports are selected.
Example of STP calculation

Figure 175 provides an example showing how the STP algorithm works.
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Figure 175 STP network

Device A
With priority 0

. CP1
Device B

With priority 1

Device C
With priority 2

As shown in Figure 175, the priority values of Device A, Device B, and Device C are O, 1, and 2, and the
path costs of links among the three devices are 5, 10, and 4, respectively.

1. Device state initialization.

In Table 55, each configuration BPDU contains the following fields: root bridge ID, root path cost,
designated bridge ID, and designated port ID.

Table 55 Initial state of each device

Device Port name BPDU of port
AP1 {0, 0, O, APT}
Device A
AP2 {0, 0, 0, AP2}
BP1 {1,0, 1, BP1}
Device B
BP2 {1,0, 1, BP2}
CP1 {2,0, 2, CP1}
Device C
CP2 {2, 0,2, CP2}

2. Configuration BPDUs comparison on each device.

In Table 56, each configuration BPDU contains the following fields: root bridge ID, root path cost,
designated bridge ID, and designated port ID.
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Table 56 Comparison process and result on each device

Configuration BPDU on

Device Comparison process .
ports after comparison

e Port AP1 receives the configuration BPDU of Device B {1, O,
1, BP1}. Device A finds that the configuration BPDU of the
local port {0, O, O, AP1} is superior to the received
configuration BPDU, and it discards the received
configuration BPDU.

o Port AP2 receives the configuration BPDU of Device C {2, O,
2, CP1}. Device A finds that the BPDU of the local port {0, O,
0, AP2} is superior to the received configuration BPDU, and
it discards the received configuration BPDU.

o Device A finds that both the root bridge and designated
bridge in the configuration BPDUs of all its ports are itself, so
it assumes itself to be the root bridge. It does not make any
change to the configuration BPDU of each port, and it starts
sending out configuration BPDUs periodically.

AP1: {0, 0, 0, AP1}

Device A AP2: {0, 0, 0, AP2}

e Port BP1 receives the configuration BPDU of Device A {0, O,
0, AP1}. Device B finds that the received configuration BPDU
is superior to the configuration BPDU of the local port {1, O,
1, BP1}, and it updates the configuration BPDU of BP1.

o Port BP2 receives the configuration BPDU of Device C {2, O,
2, CP2}. Device B finds that the configuration BPDU of the
local port {1, O, 1, BP2} is superior to the received
configuration BPDU, and it discards the received
configuration BPDU.

BP1: {0, 0, O, AP1}
BP2: {1, 0, 1, BP2}

o Device B compares the configuration BPDUs of all its ports,
and defermines that the configuration BPDU of BP1 is the
optimum configuration BPDU. Then, it uses BP1 as the root
port, the configuration BPDUs of which will not be changed.

Device B

e Based on the configuration BPDU of BP1 and the path cost Root port BPT: {0, 0
of the root port (5), Device B calculates a designated port 0, AP1} T
configuration BPDU for BP2 {0, 5, 1, BP2}. D’ onated dort BP2

esignated por :

e Device B compares the calculated configuration BPDU {0, 5, 10, 5, 1, BP2}
1, BP2} with the configuration BPDU of BP2. If the calculated T
BPDU is superior, BP2 will act as the designated port, and
the configuration BPDU on this port will be replaced with the
calculated configuration BPDU, which will be sent out
periodically.

e Port CP1 receives the configuration BPDU of Device A {0, O,
0, AP2}. Device C finds that the received configuration
BPDU is superior to the configuration BPDU of the local port
{2, 0, 2, CP1}, and it updates the configuration BPDU of
CP1.

Device C e Port CP2 receives the configuration BPDU of port BP2 of
Device B {1, 0, 1, BP2} before the configuration BPDU is
updated. Device C finds that the received configuration
BPDU is superior to the configuration BPDU of the local port
{2, 0, 2, CP2}, and it updates the configuration BPDU of
CP2.

CP1: {0, 0, 0, AP2}
CP2: {1, 0, 1, BP2}

187



Configuration BPDU on

Device Comparison process .
poris after comparison

After comparison:

e The configuration BPDU of CP1 is elected as the optimum
configuration BPDU, so CP1 is identified as the root port, the Root port CP1: {0, O
configuration BPDUs of which will not be changed. 0, AP2} o

e Device C compares the calculated designated port o Designated port CP2:
configuration BPDU {0, 10, 2, CP2} with the configuration {0, 10, 2, CP2}
BPDU of CP2, and CP2 becomes the designated port, and
the configuration BPDU of this port will be replaced with the
calculated configuration BPDU.

o Then, port CP2 receives the updated configuration BPDU of
Device B {0, 5, 1, BP2}. Because the received configuration
BPDU is superior to its own configuration BPDU, Device C
launches a BPDU update process.

o CP1:{0, 0, 0, AP2}

e At the same time, port CP1 receives periodic configuration °© CP2:{0, 5,1, 8P2)

BPDUs from Device A. Device C does not launch an update
process after comparison.

After comparison:

e Because the root path cost of CP2 (9) (root path cost of the
BPDU (5) plus path cost corresponding to CP2 (4)) is smaller
than the root path cost of CP1 (10) (root path cost of the
BPDU (0) + path cost corresponding to CP2 (10)), the BPDU
of CP2 is elected as the optimum BPDU, and CP2 is elected ®  Blocked port CP2: {0,

as the root port, the messages of which will not be changed. 0, 0, AP2}
o Affer comparison between the configuration BPDU of CP1 ~ ©  Root port CP2: {0, 5,
and the calculated designated port configuration BPDU, 1, BP2}

port CP1 is blocked, with the configuration BPDU of the port
unchanged, and the port will not receive data from Device A
until a spanning tree calculation process is triggered by a
new event, for example, the link from Device B to Device C
going down.

After the comparison processes described in Table 56, a spanning tree with Device A as the root bridge
is established, and the topology is as shown in Figure 176.

Figure 176 The final calculated spanning tree

Device A
With priority O

Device B
With priority 1

Device C
With priority 2
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The configuration BPDU forwarding mechanism of STP

The configuration BPDUs of STP are forwarded according to these guidelines:

e Upon network initiation, every device regards itself as the root bridge, generates configuration
BPDUs with itself as the root, and sends the configuration BPDUs at a regular hello interval.

o If the root port received a configuration BPDU and the received configuration BPDU is superior to
the configuration BPDU of the port, the device increases the message age carried in the
configuration BPDU following a certain rule, and it starts a timer to time the configuration BPDU
while sending this configuration BPDU through the designated port.

e Ifthe configuration BPDU received on a designated port has a lower priority than the configuration
BPDU of the local port, the port immediately sends its own configuration BPDU in response.

o If a path becomes faulty, the root port on this path no longer receives new configuration BPDUs and
the old configuration BPDUs will be discarded because of timeout. The device generates
configuration BPDUs with itself as the root and sends the BPDUs and TCN BPDUs. This triggers a
new spanning tree calculation process to establish a new path to restore the network connectivity.

However, the newly calculated configuration BPDU cannot be propagated throughout the network
immediately, so the old root ports and designated ports that have not detected the topology change
continue forwarding data along the old path. If the new root ports and designated ports begin to
forward data as soon as they are elected, a temporary loop might occur.

STP timers

STP calculation involves the following timers:

o Forward delay—The delay time for device state transition. A path failure can cause spanning tree
recalculation to adapt the spanning tree structure to the change. However, the resulting new
configuration BPDU cannot propagate throughout the network immediately. If the newly elected
root ports and designated ports start to forward data immediately, a temporary loop is likely to
occur.

For this reason, as a mechanism for state transition in STP, the newly elected root ports or
designated ports require twice the forward delay time before they transit to the forwarding state,
which makes sure the new configuration BPDU has propagated throughout the network.

o Hello time—The time interval at which a device sends hello packets to the neighboring devices to
make sure the paths are fault-free.

e Max age—A parameter used to determine whether a configuration BPDU held by the device has
expired. The device discards the BPDU if the max age is exceeded.

Introduction to RSTP

Developed based on the 802.1w standard of IEEE, RSTP is an optimized version of STP. It achieves rapid
network convergence by allowing a newly elected root port or designated port to enter the forwarding
state much faster than STP.

If the old root port on the device has stopped forwarding data and the upstream designated port has
started forwarding data, a newly elected RSTP root port rapidly enters the forwarding state.

A newly elected RSTP designated port rapidly enters the forwarding state if it is an edge port (a port that
directly connects to a user terminal rather than to another network device or a shared LAN segment) or
it connects to a pointto-point link. Edge ports directly enter the forwarding state. Connecting to a
point-to-point link, a designated port enters the forwarding state immediately after the device receives a
handshake response from the directly connected device.
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Introduction to MSTP

MSTP overcomes the following STP and RSTP limitations:

o STP limitations— STP does not support rapid state transition of ports. A newly elected port must wait
twice the forward delay time before it transits to the forwarding state, even if it connects to a
point-to-point link or is an edge port.

e RSTP limitations—Although RSTP enables faster network convergence than STP, RSTP fails to
provide load balancing among VLANs. As with STP, all RSTP bridges in a LAN share one spanning
tree and forward packets from all VLANs along this spanning tree.

MSTP features

Developed based on IEEE 802.1s, MSTP overcomes the limitations of STP and RSTP. In addition to
supporting rapid network convergence, it provides a better load sharing mechanism for redundant links
by allowing data flows of different VLAN to be forwarded along separate paths.

MSTP provides the following features:

e MSTP divides a switched network into multiple regions, each of which contains multiple spanning
trees that are independent of one another.

e MSTP supports mapping VLANS to spanning tree instances by means of a VLAN-to-instance
mapping table. MSTP can reduce communication overheads and resource usage by mapping
multiple VLANS to one instance.

e MSTP prunes a loop network into a loop-free tree, which avoids proliferation and endless cycling of
packets in a loop network. In addition, it supports load balancing of VLAN data by providing
multiple redundant paths for data forwarding.

e MSTP is compatible with STP and RSTP.

MSTP basic concepts

Figure 177 shows a switched network that comprises four MST regions, each MST region comprising four
MSTP devices.
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Figure 177 Basic concepts in MSTP

Region A0

VLAN 1 mapped to instance 1
VLAN 2 mapped to instance 2
Other VLANs mapped to CIST

Region BO

VLAN 1 mapped to instance 1
VLAN 2 mapped to instance 2
Other VLANs mapped to CIST

Region DO
VLAN 1 mapped to instance 1,
B as regional root bridge
VLAN 2 mapped to instance 2,
C as regional root bridge
Other VLANs mapped to CIST

Region CO

VLAN 1 mapped to instance 1
VLAN 2 mapped to instance 2
Other VLANs mapped to CIST

MST region

MSTI

A multiple spanning tree region (MST region) consists of multiple devices in a switched network and the
network segments among them. All these devices have the following characteristics:

e A spanning tree protocol enabled.

e Same region name.

e Same VLAN-o-instance mapping configuration.

e Same MSTP revision level.

o Physically linked with one another.

Multiple MST regions can exist in a switched network. You can assign multiple devices to the same MST

region. In Figure 177, the switched network comprises four MST regions, MST region AO through MST
region DO, and all devices in each MST region have the same MST region configuration.

MSTP can generate multiple independent spanning trees in an MST region, and each spanning tree is
mapped fo a range of VLANs. Each spanning tree is referred to as a "multiple spanning tree instance
(MSTI)".

In Figure 177, multiple MSTIs can exist in each MST region, each MSTI corresponding to the specified
VLANS.
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VLAN-to-instance mapping table

CST

IST

CIST

As an attribute of an MST region, the VLAN-to-instance mapping table describes the mapping
relationships between VLANs and MSTIs.

In Figure 177, the VLAN-to-instance mapping table of region AO is: VLAN 1 is mapped to MSTI 1, VLAN
2 to MSTI 2, and the rest to CIST. MSTP achieves load balancing by means of the VLAN-to-instance
mapping table.

The common spanning tree (CST) is a single spanning tree that connects all MST regions in a switched
network. If you regard each MST region as a device, the CST is a spanning tree calculated by these
devices through STP or RSTP.

The red lines in Figure 177 represent the CST.

An internal spanning tree (IST) is a spanning tree that runs in an MST region. It is also called MSTI O,
special MSTI to which all VLANs are mapped by default.

In Figure 177, the CIST has a section in each MST region, and this section is the IST in the respective MST
region.

The common and internal spanning tree (CIST) is a single spanning tree that connects all devices in a
switched network. It consists of the ISTs in all MST regions and the CST.

In Figure 177, the ISTs in all MST regions plus the inter-region CST constitute the CIST of the entire network.

Regional root bridge

The root bridge of the IST or an MSTI within an MST region is the regional root bridge of the IST or the
MSTI. Based on the topology, different spanning trees in an MST region might have different regional
roofs.

As shown in Figure 177, the regional root of MSTI 1 in region DO is device B, and that of MSTI 2 is device
C.

Common root bridge

The common root bridge is the root bridge of the CIST.

In Figure 177, for example, the common root bridge is a device in region AO.

Port roles

A port can play different roles in different MSTls. As shown in Figure 178, an MST region has device A,
device B, device C, and device D. Port 1 and port 2 of device A are connected to the common root
bridge, port 5 and port 6 of device C form a loop, and port 3 and port 4 of device D are connected
downstream to the other MST regions.
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Figure 178 Port roles

Connecting to the
common root bridge

Edge port

MST region Port 1 Port 2

Master port

Backup port

Designated
port 7

Port 3 Port 4

MSTP calculation involves the following port roles:

Port states

Root port—Forwards data for a non-root bridge to the root bridge. The root bridge does not have
any root port.

Designated port—Forwards data to the downstream network segment or device.

Master port—Serves as a port on the shortest path from the local MST region to the common root
bridge. The master port is not always located on the regional root. It is a root port on the IST or CIST
and still a master port on the other MSTIs.

Alternate port—Serves as the backup port for a root port or master port. When the root port or
master port is blocked, the alternate port takes over.

Backup port—Serves as the backup port of a designated port. When the designated port is invalid,
the backup port becomes the new designated port. A loop occurs when two ports of the same
spanning tree device are connected, so the device blocks one of the ports. The blocked port acts as

the backup.

Boundary port—Connects an MST region to another MST region or to an STP/RSTP-running device.
In MSTP calculation, a boundary port's role on an MSTI is consistent with its role on the CIST. But
that is not true with master ports. A master port on MSTls is a root port on the CIST.

In MSTP, a port can be in one of the following states:

Forwarding—The port learns MAC addresses and forwards user traffic.
Learning—The port learns MAC addresses but does not forward user traffic.

Discarding—The port does not learn MAC addresses or forwards user traffic.

A port can have different port states in different MSTls. A port state is not exclusively associated with a
port role. Table 57 lists the port states supported by each port role. (A check mark [V] indicates that the
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port state is available for the corresponding port role, and a dash [—] indicates that the port state is not
available for the corresponding port role.)

Table 57 Ports states supported by different port roles

Port role
Port state Root port/master  Designated  Boundary Alternate port  Backup port
port port port P PP
Forwarding v v v — —
Learning v v v — —
Discarding v v v v v

How MSTP works

MSTP divides an entire Layer 2 network into multiple MST regions, which are connected by a calculated
CST. Inside an MST region, multiple spanning trees, called MSTIs, are calculated. Among these MSTIs,
MSTI O is the CIST.

Similar to RSTP, MSTP uses configuration BPDUs to calculate spanning trees. An important difference is
that an MSTP BPDU carries the MSTP configuration of the bridge from which the BPDU is sent.

CIST calculation

The calculation of a CIST tree is also the process of configuration BPDU comparison. During this process,
the device with the highest priority is elected as the root bridge of the CIST. MSTP generates an IST within
each MST region through calculation. At the same time, MSTP regards each MST region as a single
device and generates a CST among these MST regions through calculation. The CST and ISTs constitute
the CIST of the entire network.

MSTI calculation

Within an MST region, MSTP generates different MSTIs for different VLANs based on the
VLAN-fo-instance mappings. For each spanning tree, MSTP performs a separate calculation process,
which is similar to spanning tree calculation in STP/RSTP. For more information, see "Calculation process
of the STP algorithm"

In MSTP, a VLAN packet is forwarded along the following paths:
e Within an MST region, the packet is forwarded along the corresponding MSTI.
e Between two MST regions, the packet is forwarded along the CST.

MSTP implementation on devices

MSTP is compatible with STP and RSTP. STP and RSTP protocol packets can be recognized by devices

running MSTP and used for spanning tree calculation.

In addition to basic MSTP functions, the device provides the following functions for ease of management:
e Root bridge hold

e Root bridge backup

e Root guard

e BPDU guard
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Loop guard
TC-BPDU (a message that notifies the device of topology changes) guard

Support for the hot swapping of interface boards and switchover of the active and standby main
boards.

Protocols and standards

MSTP is documented in the following protocols and standards:

IEEE 802.1d, Spanning Tree Protocol
IEEE 802.1w, Rapid Spanning Tree Protocol
IEEE 802.1s, Multiple Spanning Tree Protocol

Configuration guidelines

When you configure MSTP, follow these guidelines:

Two or more spanning tree devices belong to the same MST region only if they are configured to
have the same MST region name, MST region level, and the same VLAN-to-instance mapping
entries in the MST region, and they are connected through a physical link.

If two or more devices are selected as the root bridge in a spanning tree at the same time, the device
with the lowest MAC address is chosen.

If BPDU guard is disabled, a port set as an edge port becomes a non-edge port again if it receives
a BPDU from another port. To restore its port role as an edge port, you must restart the port.

If a port directly connects to a user terminal, configure it as an edge port and enable BPDU guard
for it. This enables the port to quickly transit to the forwarding state when ensuring network security.

Recommended MSTP configuration procedure

Step Remarks

1.

Optional.
Configuring an MST Configure the MST region-related parameters and VLAN-+o-instance
region. mappings.

By default, the MST region-related parameters adopt the default values, and
all VLANs in an MST region are mapped to MSTI 0.

Required.

2. Configuring MSTP globally. Enable STP globally and configure MSTP parameters.
By default, STP is enabled globally. All MSTP parameters have default
values.
Optional.

3. Configuring MSTP on a Enable MSTP on a port and configure MSTP parameters.

port. By default, MSTP is enabled on a port, and all MSTP parameters adopt the

default values.
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Step Remarks

Optional.
4. Displaying MSTP priond

information of a port.

Display MSTP information of a port in MSTI O, the MSTI to which the port

belongs, and the path cost and priority of the port.

Contiguring an MST region

1. From the navigation tree, select Network > MSTP.
By default, the Region tab is displayed.

Figure 179 MST region

Global Fort Summary Port Setup
Format Selector Region MName
0 00e0fcO03620
Modify
Instance
0 1to 4094

2. Click Modify.
Figure 180 Configuring an MST region

YLAM Mapped

Revision Level

Global Port Summary Fort Setup
Region Mame |li]li]eli]fct]t]3l320 ||j1-32 Chars.)
Revision Level o (0-65535, Default = 0)

@ Wanual O Madulo

Instance ID

YLAN ID

(Example:1,3,5-10)

Instance ID YLAMN Mapped

Apply  Remove

Activate Cancel

3. Configure the MST region information as described in Table 58, and click Apply.
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4.

Table 58 Configuration items

ltem

Description

Region Name

MST region name.
The MST region name is the bridge MAC address of the device by default.

Revision Level

Revision level of the MST region.

Manual (Instance ID and

VLAN ID)

Manually add VLAN-o-instance mappings. Click Apply to add the
VLAN-o-instance mapping entries to the list.

Modulo

The device automatically maps 4094 VLANS to the corresponding MSTIs
based on the modulo value.

Click Activate.

Contiguring MSTP globally

1.
2,

From the navigation tree, select Network > MSTP.

Click the Global tab.
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Figure 181 Configuring MSTP globally

Region Port Summary Port Setup

Global M2TP Configuration

Enable STP Globally: Disahle w
BFDU Praotection: Disahle hd
Maode: WMSTP e
Max Hops: 20 o
Fath Cost Standard: Legacy hd

|:|Elridge Diameter:

[ Timer(in centiseconds)

Forward Delay: (400-3000, Must be a multiple of 100}

Hello Time: 100-1000, Must ke a multiple of 100}

Max Age: (B00-4000, Must be a multiple of 100)
[instance:

Instance 10:

Root Type:

Bridge Priarity:
TC Protection: Enahle b

TC Protection Threshold: 3 (1-255, default=8)

Apply

Contfigure the global MSTP configuration as described in Table 59, and then click Apply.

Table 59 Configuration items

ltem Description

Selects whether to enable STP globally.
Enable STP Globally
Other MSTP configurations take effect only after you enable STP globally.

Selects whether to enable BPDU guard.

BPDU Guard BPDU guard can protect the device from malicious BPDU attacks, making the
network topology stable.
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ltem Description
Sets the operating mode of STP:
e STP—Each port on a device sends out STP BPDUs.
e RSTP—Each port on a device sends out RSTP BPDUs, and automatically
Mode migrates to STP-compatible mode when detecting that it is connected with a
device running STP.
e MSTP—Each port on a device sends out MSTP BPDUs, and automatically
migrates fo STP-compatible mode when detecting that it is connected with a
device running STP.
Sets the maximum number of hops in an MST region to restrict the region size.
Max Hops The setting can take effect only when it is configured on the regional root

bridge.

Path Cost Standard

Specifies the standard for path cost calculation. It can be legacy, IEEE
802.1D-1998, or [EEE 802.1T.

Bridge Diameter

Any two stations in a switched network are interconnected through a specific
path composed of a series of devices. The bridge diameter (or the network
diameter) is the number of devices on the path composed of the most devices.

After you set the network diameter, you cannot set the timers. Instead, the
device automatically calculates the forward delay, hello time, and max age.

When you configure the bridge diameter, follow these guidelines:
e The configured network diameter is effective on CIST only, not on MSTls.

o The bridge diameter cannot be configured together with the timers.

Timers

Configure the timers:

o Forward Delay— Set the delay for the root and designated ports to transit to
the forwarding state.

¢ Hello Time—Set the interval at which the device sends hello packets to the
surrounding devices to make sure the paths are faultfree.

e Max Age—Set the maximum length of time a configuration BPDU can be

held by the device.

When you configure timers, follow these guidelines:

o The settings of hello time, forward delay and max age must meet a certain
formula. Otherwise, the network topology will not be stable. HP
recommends you to set the network diameter and then have the device
automatically calculate the forward delay, hello time, and max age.

o The bridge diameter cannot be configured together with the timers.

Instance (Instance ID,
Root Type, and Bridge
Priority)

Sets the role of the device in the MSTI or the bridge priority of the device, which

is one of the factors deciding whether the device can be elected as the root

bridge.

Role of the device in the MSTI:

o Not Set—Not set (you can set the bridge priority of the device when
selecting this role)

e Primary—Configure the device as the root bridge (you cannot set the bridge
priority of the device when selecting this role)

e Secondary—Configure the device as a secondary root bridge (you cannot
set the bridge priority of the device when selecting this role).
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ltem Description

Selects whether to enable TC-BPDU guard.

When receiving topology change (TC) BPDUs, the device flushes its forwarding
address entries. If someone forges TC-BPDUs to attack the device, the device
will receive a large number of TC-BPDUs within a short time and frequently
flushes its forwarding address entries. This affects network stability.

tc-protection

With the TC-BPDU guard function, you can prevent frequent flushing of
forwarding address entries.

HP recommends not disabling this function.

Sets the maximum number of immediate forwarding address entry flushes the
tc-protection threshold  device can perform within a certain period of time after receiving the first
TC-BPDU.

Contiguring MSTP on a port

From the navigation tree, select Network > MSTP.
2. Click the Port Setup tab.

Figure 182 MSTP configuration on a port

Region Global Port Summary
STP: Mo Change = Protection: Mo Change ¥ Note : The new protection will replace the old one
+instance
+Advanced
Select port(s):

AN 1 o o N R SN N 1910:24 Swich .
e e de el el d=]= 0]

Select All Select None

Selected port(s):

Cancel

3. Configure MSTP for poris as described in Table 60, and then click Apply.

Table 60 Configuration items

ltem Description

STP Selects whether to enable STP on the port.
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ltem Description
Sets the type of protection to be enabled on the port:
Protection e Not Set—No protection is enabled on the port.
o Edged Port, Root Protection, Loop Protection—For more information, see Table 61.
Sets the priority and path cost of the port in the current MSTI:
o Priority—The priority of a port is an important factor in determining whether the port
can be elected as the root port of a device. If all other conditions are the same, the
Instance port with the highest priority will be elected as the root port. On an MSTP-enabled
(Instance ID, device, a port can have different priorities in different MSTls, and the same port can
Port Priority, play different roles in different MSTls, so that data of different VLANs can be
Auto Path propagated along different physical paths, implementing perVLAN load balancing.
Cost, and You can set port priority values based on the actual networking requirements.
Manual Path o Path cost—A parameter related to the rate of a port. On an MSTP-enabled device, a
Cost) port can have different path costs in different MSTls. Setting appropriate path costs
allows VLAN traffic flows to be forwarded along different physical links, achieving
VLAN-based load balancing. The device can automatically calculate the default
path cost. Alternatively, you can also manually configure path cost for ports.
e Point to Point
Specifles whether the port is connected to a point-to-point link:
o Auto—Configures the device to automatically detect whether or not the link type
of the port is point-to-point.
o Force False—The link type for the port is not point-to-point link.
o Force True—The link type for the port is point-to-point link.
If a port is configured as connecting to a point-to-point link, the setting takes effect on the
port in all MSTIs. If the physical link to which the port connecis is not a point-to-point link
and you force it to be a point-to-point link by configuration, the configuration might incur
a temporary loop.
Advanced

o Transmit Limit—Configures the maximum number of MSTP packets that can be sent
during each Hello interval.
The larger the transmit limit is, the more network resources will be occupied. HP
recommends that you use the default value.

e MSTP Mode—Sets whether the port migrates to the MSTP mode.
In a switched network, if a port on an MSTP (or RSTP) device connects to a device
running STP, this port will automatically migrate to the STP-compatible mode. After
the device running STP is removed, the port on the MSTP (or RSTP) device might not
be able to migrate automatically to the MSTP (or RSTP) mode, but will remain
operating in the STP-compatible mode. You can set this option to enable the port to
automatically migrate to the MSTP (or RSTP) mode.

Select port(s)

Selects one or multiple ports on which you want to configure MSTP on the chassis front
panel. If aggregate interfaces are configured on the device, the page displays a list of
aggregate inferfaces below the chassis front panel. You can select aggregate interfaces
from this list.
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Table 61 Protection types

Protection type Description

Sets the port as an edge port.

Some ports of access layer devices are directly connected to PCs or file servers,
which cannot generate BPDUs. You can set these ports as edge ports to achieve
Edged Port fast transition for these ports.

HP recommends that you enable the BPDU guard function in conjunction with the
edged port function to avoid network topology changes when the edge ports
receive configuration BPDUs.

Enables the root guard function.

Configuration errors or attacks might result in configuration BPDUs with their

Root Protection priorities higher than that of a root bridge, which causes a new root bridge to be
elected and network topology change to occur. The root guard function is used to
address such a problem.

Enables the loop guard function.

By keeping receiving BPDUs from the upstream device, a device can maintain the
state of the root port and other blocked ports. These BPDUs might get lost because
of network congestion or unidirectional link failures. The device will re-elect a root
port, and blocked ports might transit fo the forwarding state, causing loops in the
network. The loop guard function is used to address such a problem.

Loop Protection

Displaying MSTP information of a port

From the navigation tree, select Network > MSTP.
Click the Port Summary tab.
3. Select a port on the chassis front panel.

If you have configured aggregate interfaces on the device, the page displays a list of aggregate
inferfaces below the chassis front panel. You can select aggregate interfaces from this list. The
lower part of the page displays the MSTP information of the port in MSTI O (when STP is enabled
globally) or the STP status and statistics (when STP is not enabled globally), the MSTI to which the
port belongs, and the path cost and priority of the port in the MSTI.
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Figure 183 The port summary tab
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Table 62 Field description

Field Description

[FORWARDING] The port is in forwgrdmg state, so the port learns MAC addresses and
forwards user traffic.

(LEARNING] The port is in |earr1ing state, so the port learns MAC addresses but does not
forward user traffic.

[DISCARDING] The port is in dlscgrdlng state, so the port does not learn MAC addresses or
forward user traffic.

[DOWN] The port is down.

Port Protocol

Whether STP is enabled on the port.

Role of the port, which can be Alternate, Backup, Root, Designated, Master,

Port Role or Disabled.
Port Priority Priority of the port.

Path cost of the port. The field in the bracket indicates the standard used for
Port Cost(Legacy) port path cost calculation, which can be legacy, dot1d-1998, or dot1t.

Config indicates the configured value, and Active indicates the actual value.

Desg. Bridge/Port

Designated bridge ID and port ID of the port.

The port ID displayed is insignificant for a port that does not support port
priority.

Port Edged

Whether the port is an edge port:
o Config—The configured value.

e Active—The actual value.
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Field

Description

Point-to-point

Whether the port is connected to a pointto-point link:
o Config—The configured value.

e Active—The actual value.

Transmit Limit

Maximum number of packets sent within each Hello time.

Protection Type

Protection type on the port:
e Root—Root guard.

¢ Loop—Loop guard.

e BPDU—BPDU guard.

e None—No protection.

MST BPDU Format

Format of the MST BPDUs that the port can send, which can be legacy or
802.1s. Config indicates the configured value, and Active indicates the
actual value.

Port Config-
Digest-Snooping

Whether digest snooping is enabled on the port.

Rapid transition

Whether the current port rapidly transits to the forwarding state.

Num of Vlans Mapped

Number of VLANs mapped to the current MSTI.

Maijor parameters for the port:
o Hello—Hello timer.
e MaxAge—Max Age timer.

PortTimes
e FWDIly—Forward delay timer.
* MsgAge—Message Age timer.
e Remain Hop—Remaining hops.
BPDU Sent Statistics on sent BPDUs.

BPDU Received

Statistics on received BPDUs.

Protocol Status

Whether MSTP is enabled.

Protocol Std.

MSTP standard.

Version

MSTP version.

CIST Bridge-Prio.

Priority of the current device in the CIST.

MAC address

MAC address of the current device.

Max age(s)

Maximum age of a configuration BPDU.

Forward delay(s)

Port state transition delay, in seconds.

Hello time(s)

Configuration BPDU transmission interval, in seconds.

Max hops

Maximum hops of the current MST region.

MSTP contiguration example

Network requirements
As shown in Figure 184, configure MSTP as follows:
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e All devices on the network are in the same MST region.

e Packets of VLAN 10, VLAN 20, VLAN 30, and VLAN 40 are forwarded along MSTI 1, MSTI 2,
MSTI 3, and MSTI O, respectively.

e Switch A and Switch B operate at the distribution layer. Switch C and Switch D operate at the access
layer. VLAN 10 and VLAN 20 are terminated on the distribution layer devices, and VLAN 30 is
terminated on the access layer devices, so the root bridges of MSTI 1 and MSTI 2 are Switch A and
Switch B, respectively, and the root bridge of MSTI 3 is Switch C.

Figure 184 Network diagram

Switch A Switch B

Permit: all VLAN

Permit:
VLAN 10, 40

Permit:

Permit:
VLAN 10, 40

Permit:
VLAN 20, 40

Permit: VLAN 30, 40
Switch C Switch D

"Permit:" next to a link in the figure is followed by the VLANs the packets of which are permitted to pass
this link.

Contiguration procedure

Configuring Switch A
1. Configure an MST region:
a. From the navigation tree, select Network > MSTP.
By default, the Region tab is displayed.
b. Click Modify.

Figure 185 The region tab

Global Fart Summary Fart Setup
Format Selector Region Mame Revision Level
0 00e0fc003620 0
Modify
Instance VLAM Mapped
0 110 4084

c. Set the region name to example.
d. Set the revision level to 0.

e. Select Manual.
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Select 1 from the Instance ID list.
Set the VLAN ID to 10.
Click Apply.

The system maps VLAN 10 to MSTI 1 and adds the VLAN-o-instance mapping entry to the
VLAN-o-instance mapping list.

Repeat the preceding three steps to map VLAN 20 to MSTI 2 and VLAN 30 to MSTI 3 and add
the VLAN-to-instance mapping entries to the VLAN-fo-instance mapping list.

Click Activate.

Figure 186 Configuring an MST region

Glahal FPort Summary Fort Setup
Region Name example (1-32 Chars.)
Revision Level 0 (0-65535, Default=0}

@ Manual | Modula

| Instance ID| 3 % VLAN ID | (Example:1,3,5-10)

Apply Remaove

Instance D VLAN Mapped
10
20
30

[FE ey

Activate Cancel

Configure MSTP globally:

a.

o

=@ ™9 oo

From the navigation tree, select Network > MSTP.
Click the Global tab.

Select Enable from the Enable STP Globally |ist.
Select MSTP from the Mode list.

Select the box before Instance.

Set the Instance ID field to 1.

Set the Root Type field to Primary.

Click Apply.
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Figure 187 Configuring MSTP globally (on Switch A)

Region Port Summary Port Setup

Glohal METP Configuration

Enable STP Globally | Enable v|
BPDU Protection: | Disable v|
Mode: [MsTP v
Max Hops: |2EI V|
Path Cost Standard: | Legacy v|

|:|E|ridge Diameter:

(] Timer(in centiseconds)

Forward Delay: ‘ |[4EIEI—3EIEIEI. Must be a multiple of 100)
Hello Time: | (100-1000, Must be a multiple of 100)
Wax Age: ‘ |[EEIEI—4IZIEIIZI. Must be a multiple of 100)

[l Instance:

Instance 1D | 1 v|

Root Type: |F'rimary V|

Bridge Pricrity:

TC Protection: |Enah|e V|

TC Protection Threshold: |6 | (1-255, default=6)

Apply

Configuring Switch B

1. Configure an MST region on the switch in the same way the MST region is configured on Switch
A.

2. Configure MSTP globally:
a. From the navigation tree, select Network > MSTP.
Click the Global tab.
Select Enable from the Enable STP Globally |ist.
Select MSTP from the Mode list.
Select the box before Instance.
Set the Instance ID field to 2.
Set the Root Type field to Primary.
Click Apply.

S

- 0o o 0

s @
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Configuring Switch C

1. Configure an MST region on the switch in the same way the MST region is configured on Switch
A.

2. Configure MSTP globally:

a. From the navigation tree, select Network > MSTP.
Click Global.
Select Enable from the Enable STP Globally list.
Select MSTP from the Mode list.
Select the box before Instance.
Set the Instance ID field to 3.

s

Set the Root Type field to Primary.
Click Apply.

@ ™o oo

Configuring Switch D

1. Configure an MST region on the switch in the same way the MST region is configured on Switch
A.

2. Configure MSTP globally:
a. From the navigation tree, select Network > MSTP.
b. Click Global.
c. Select Enable from the Enable STP Globally list.
d. Select MSTP from the Mode list.
e. Click Apply.

208



Figure 188 Configuring MSTP globally (on Switch D)

Region Port Summary Port Setup

Glohal METP Configuration

Enable STP Globally | Enable v|
BPDU Protection: | Disable v|
Mode: [MsTP v
Max Hops: |2EI V|
Path Cost Standard: | Legacy v|

|:|E|ridge Diameter:
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Forward Delay:
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Hello Time:
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IMax Age:

[ instance:
Instance 1D

Root Type: Mot Set

Bridae Priarity: 32768

TC Protection: |Enable V|

TC Protection Threshold: |6 | (1-255 default=6)

Apply
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Configuring link aggregation and LACP

Overview

Ethernet link aggregation bundles multiple physical Ethernet links into one logical link, called an
aggregate link. Link aggregation has the following benefits:

e Increased bandwidth beyond the limits of any single link. In an aggregate link, traffic is distributed
across the member ports.

e Improved link reliability. The member ports dynamically back up one another. When a member
port fails, its traffic is automatically switched to other member ports.

Basic concepts

Aggregate interface
An aggregate interface is a logical interface.
Aggregation group

An aggregation group is a collection of Ethernet interfaces. When you create an aggregate interface,
the switch automatically creates an aggregation group of the same number as the aggregate interface.

Aggregation states of the member ports in an aggregation group

A member port in an aggregation group can be in either of the following states:
o Selected—A Selected port can forward user traffic.

e  Unselected—An Unselected port cannot forward user traffic.

The port rate of an aggregate interface equals the total rate of its member ports in Selected state, and its
duplex mode is the same as that of the selected member ports.

For more information about the states of member ports in an aggregation group, see "Static aggregation
mode" and "Dynamic aggregation mode."

LACP
The Link Aggregation Control Protocol (LACP) is defined in IEEE 802.3ad. It uses LACPDUs to exchange

aggregation information between LACP-enabled devices.

LACP is automatically enabled on member ports in a dynamic aggregation group. An LACP-enabled
port sends LACPDUs to notify the remote system (the partner) of its system LACP priority, system MAC
address, LACP port priority, port number, and operational key. Upon receiving an LACPDU, the peer port
compares the received information with the information received on other member ports. In this way, the
two systems reach an agreement on which ports are placed in Selected state.

Operational key

When aggregating ports, link aggregation control automatically assigns each port an operational key
based on port attributes, including the port rate, duplex mode, and link state configuration.

In an aggregation group, all Selected ports are assigned the same operational key.
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Configuration classes

Port configurations include the following classes:

e Class-two configurations—A member port can be placed in Selected state only if it has the same
class-two configurations as the aggregate interface.

Table 63 Class-two configurations

Type Considerations

Whether a port has joined an isolation group, and the isolation group to which
the port belongs.

Permitted VLAN IDs, port VLAN ID (PVID), link type (trunk, hybrid, or access), IP
VIAN subnet-based VLAN configuration, protocol-based VLAN configuration, and
VLAN tagging mode.

Port isolation

MAC address learning capability, MAC address learning limit, and forwarding
of frames with unknown destination MAC addresses after the upper limit of the
MAC address table is reached.

MAC address

learning

e  Class-one configurations—Include settings that do not affect the aggregation state of the member
port even if they are different from those on the aggregate interface. For example, MSTP, can be
configured on aggregate interfaces and member ports. However, class-one configurations do not
take effect in operational key calculation.

Any classtwo configuration change might affect the aggregation state of link aggregation member ports
and running services. To make sure that you are aware of the risk, the system displays a warning
message every time you attempt to change a class-two configuration setting on a member port.

Link aggregation modes

Based on the link aggregation procedure, link aggregation operates in one of the following modes:
e  Static aggregation mode

e  Dynamic aggregation mode
Static aggregation mode

LACP is disabled on the member ports in a static aggregation group. In a static aggregation group, the
system sets the aggregation state of each member port according fo the following rules:

1. Choose a reference port from the member ports that are in up state and with the same classtwo
configurations as the aggregate interface. The candidate ports are sorted in the following order:

o Full duplex/high speed

o Full duplex/low speed

o Half duplex/high speed

o Half duplex/low speed

If two ports have the same duplex mode/speed pair, the one with the lower port number is chosen.

2. Place the poris in up state with the same port attributes and class+two configurations as the
reference port in Selected state, and place all others in Unselected state.

3. The number of Selected ports is limited in a static aggregation group. When the number of the
Selected ports is under the limit, all the member ports become Selected ports. When the limit is
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exceeded, place the ports with smaller port numbers in the Selected state and those with greater
port numbers in the Unselected state.

Place the member ports in the Unselected state if all the member ports are down.

5. Place the ports that cannot aggregate with the reference port in the Unselected state, for example,
as a result of the inter-board aggregation restriction.

After a static aggregation group has reached the limit on Selected ports, any port that joins the group is
placed in Unselected state to avoid traffic interruption on the existing Selected ports. However, the state
of link aggregation member ports might change after a reboot.

Dynamic aggregation mode
LACP is enabled on member ports in a dynamic aggregation group.

In a dynamic aggregation group, a Selected port can receive and send LACPDUs. An Unselected port
can receive and send LACPDUs only when it is up, and has the same configurations as the aggregate
interface.

In a dynamic aggregation group, the local system (the actor) negotiates with the remote system (the
partner) to determine the aggregation state of each port in the following steps:

1. Compare the system IDs. (A system ID comprises the system LACP priority and the system MAC
address). The lower the LACP priority, the smaller the system ID. If LACP priority values are the
same, the two systems compare their system MAC addresses. The lower the MAC address, the
smaller the system ID.

2. The system with the smaller system ID chooses the port with the smallest port ID as the reference
port. (A port ID comprises a port priority and a port number.) The port with the lower priority value
is chosen. If two ports have the same aggregation priority, the system compares their port numbers.
The port with the smaller port number becomes the reference port.

3. Ifaportin up state is with the same port attributes and classtwo configuration as the reference port,
and the peer port of the port is with the same port attributes and class-two configurations as the
peer port of the reference port, consider the port as a candidate selected port. Otherwise place the
port in the Unselected state.

The number of Selected ports in an aggregation group is limited. When the number of Selected ports is
under the limit, all the member ports are set to Selected state. When the limit is exceeded, the system sets
the ports with smaller port IDs as the Selected ports, and place other ports in the Unselected state. At the
same time, the peer device, being aware of the changes, sets the aggregation state of local member
ports the same as their peer ports.

The system places the ports that cannot aggregate with the reference port in the Unselected state, for
example, as the result of the inter-board aggregation restriction.

When you configure static and dynamic aggregation modes, follow these guidelines:

e In an aggregation group, a Selected port must have the same port attributes and class-two
configurations as the reference port. To keep these configurations consistent, you should configure
the port manually.

e Any port aftribute or class-two configuration change might affect the aggregation state of all
member ports and ongoing traffic. If you need to make this change, make sure you understand its
impact on the live network.
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Contiguration procedures

Configuring a static aggregation group

Step Remarks

Create a static aggregate interface and configure member
1. Creating a link aggregation group. ports for the static aggregation group.

By default, no link aggregation group exists.
2. (Optional.) Displaying aggregate Display detailed information of an existing aggregation

interface information.

group.

Configuring a dynamic aggregation group

Step

Remarks

Creating a link
aggregation group.

Create a dynamic aggregate interface and configure member ports for the
dynamic aggregation group automatically created. LACP is enabled
automatically on all the member ports.

By default, no link aggregation group exists.

(Optional.) Displaying
aggregate interface
information.

Display detailed information of an existing aggregation group.

(Optional.) Setting
LACP priority.

Set LACP priority for the local system and link aggregation member ports.
Changes of LACP priorities affect the aggregation state of the member ports.
The default port LACP priority and system LACP priority are both 32768.

(Optional.) Displaying
LACP-enabled port
information.

Display detailed information of LACP-enabled ports and the corresponding
remote (partner) ports.

Creating a link aggregation group

1. From the navigation tree, select Network > Link Aggregation.
2. Click Create.
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Figure 189 Creating a link aggregation group

Summarny Maodify Remove
Enter Link Aggregation Interface ID: 1 1-8)
Specify Interface Type: @ Static (LACF Disabled) Hote: The type of the link aggregation interface set here

overarites the existing LACP settings of the ports in the link

'~ Dynamic (LACF Enabled) sggregstion interface.

Select portfs) for the link aggregation interface:

BERE AR0E BREE —

Select All Select Mone

Selected Ports: Unselected Ports:

] b f the li ticn interf to b
. smeners of the link sggregation Interacs to be D Mot a member of any link aggregation interface.

oreated.

. Members of existing link aggregation interfaces.

SI.IITIITIHI'}‘:
Aggregstion Interface ID Member Ports Aggregation Interface Type
1 Static
4 3

Cancel

3. Configure a link aggregation group as described in Table 64.
4. Click Apply.

Table 64 Configuration items

ltem Description
Enter Link Aggregation Assign an ID to the link aggregation group to be created.
Interface 1D You can view the result in the Summary area at the bottom of the page.

Set the type of the link aggregation inferface to be created:
Specify Interface Type e Static—LACP is disabled.
e Dynamic—LACP is enabled.

Select one or multiple ports to be assigned to the link aggregation group from

Select port(s) for the link the chassis front panel.

aggregation interface ) )
You can view the result in the Summary area at the bottom of the page.

Displaying aggregate interface information

1. From the navigation tree, select Network > Link Aggregation.

The Summary tab is displayed by default. The list on the upper part of the page displays
information about all the aggregate interfaces.

2. Choose an aggregate inferface from the list.
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The list on the lower part of the page displays the detailed information about the member ports of
the link aggregation group.

Figure 190 Displaying information of an aggregate interface
Create Modify Remaove

Select port from the table to view port details:
Aggregation Interface Link Type Partner ID Selected Poris Standby Ports

Bridge-Aggregation Static Mone

Member port details:
Member Port State Reason for being Unselected
Ethernet1/0M1 Unselected The port's physical state (down) is improper for being attached.

Table 65 Field description

Field Description

o Type and ID of the aggregate interface.
Aggregation interface . L .
Bridge-Aggregation indicates a Layer 2 aggregate interface.

Link Type Type of the aggregate interface: static or dynamic.

Partner ID ID of the remote device, including its LACP priority and MAC address.

Number of Selected ports in each link aggregation group (Only Selected ports

Selected Ports .
can send and receive user data).

Number of Unselected ports in each link aggregation group (Unselected ports

Standby Port .
andby Foris cannot send or receive user data).

A member port of the link aggregation group corresponding to the selected

Member Port :
aggregate interface.

State Aggregation state of a member port: Selected or Unselected.

Reason why the state of a member port is Unselected. For a Selected port, this

Reason for being Unselected field displays a hyphen ().

Setting LACP priority
1. From the navigation tree, select Network > LACP.
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Click Setup.

In the Set LACP enabled port(s) parameters areq, set the port priority, and select the ports in the
chassis front panel.

4.  Click Apply in the area.
Figure 191 The Setup tab

Summary

Select LACP enabled port(s) parameters :
Port Priority: (0-65535, Default = 32768)

Select port{s) to apply Port Priority:

LT Tl LT =] 1910-24 Swich
el et Jlodal e f{e]=]=]z]

Select All Select None

Mote:Click a port to toggle its state

Selected LACF Enabled LACP Disableg DC8fWeen enabled and disabled.

Cancel
Set global LACP parameters :

System Priority: (0-65535, Default = 32768)
Apply Cancel

Table 66 Configuration items

ltem Description

Port Priority Set a port LACP priority.

Select port(s) to Choose the ports where the port LACP priority you set will apply on the chassis front panel.
apply Port Priority Yoy can set LACP priority on both LACP-enabled ports and LACP-disabled ports.

5. In the Set global LACP parameters area, set the system priority.
6. Click Apply in the area.

Displaying LACP-enabled port information

1. From the navigation tree, select Network > LACP.

The Summary tab is displayed by default. The upper part of the page displays a list of all
LACP-enabled ports on the device and information about them. Table 67 describes the fields.

Select a port on the port list.
Click View Details.

Detailed information about the peer port appears on the lower part of the page. Table 68
describes the fields.
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Figure 192 Displaying the information of LACP-enabled ports

Setup

Select port(s) from the table to view partner port details:

LACP Port *Inactive Partner Partner Cper
Unit Port State Priprity State Reas=on Fort Port State Hev
1 071 Enable 32768 Not in group 3 a EF 1
1 af2 Enakble 32768 Not in group 3 a EF 2

View Details

Partner Port Details:
Unit Port Fartner ID Partner Port Priority Fartner COper Eey
1 /1 0x8000,0000-0000-0000 32768 0

*MNote: The following numbers are used to indicate the reasons for being inactive.
1— All active ports are already in-use for this aggregataor.

2— All aggregation resources are already in-use.

3— The portis not configured properly.

4— The ports partner is not configured properly.

Table 67 Field description

Field Description

Unit ID of a device in a stack.
Port Port where LACP is enabled.
LACP State State of LACP on the port.
Port Priority LACP priority of the port.

Aggregation state of the port. If a port is Selected, this field also displays the ID

State of the aggregation group it belongs to.

Reason code indicating why a port is Unselected for receiving or sending user
Inactive Reason data. For more information about the reason codes, see the bottom of the page
shown in Figure 192.

Partner Port ID of the peer port.
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Field

Description

Partner Port State

States of the peer port:

A—LACP is enabled.

B—LACP short timeout. If B does not appear, it indicates LACP long timeout.
C—The sending system considers the link is aggregatable.

D—The sending system considers the link is synchronized.

E—The sending system considers the incoming frames are collected.
F—The sending system considers the outgoing frames are distributed.
G—The sending system receives frames in the default state.

H—The sending system receives frames in the expired state.

Oper Key

Operational key of the local port.

Table 68 Field description

Field Description

Unit Number of the remote system.

Port Name of the remote port.

Partner ID LACP priority and MAC address of the remote system.

Partner Port Priority

LACP priority of the remote port.

Partner Oper Key

Operational key of the remote port.

Link aggregation and LACP configuration example

Network requirements

As shown in Figure 193, aggregate the ports on each device to form a link aggregation group,
distributing incoming and outgoing traffic across the member ports.

Figure 193 Network diagram

Link aggregation

Eth1/0/1 l Eth1/0/1

Eth1/0/2 / \ Eth1/0/2
J

Eth1/0/3 \~/ Eth1/0/3

@ Switch A

@ Switch B

You can create a static or dynamic link aggregation group to achieve load sharing.

Method 1: Create static link aggregation group 1

1. From the navigation tree, select Network > Link Aggregation.

2. Click Create.

3. Configure static link aggregation group 1:
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a. Enter link aggregation interface ID 1.

b. Select the Static (LACP Disabled) option for the aggregate interface type.

c. Select Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3 on the chassis front panel.
4. Click Apply.

Figure 194 Creating static link aggregation group 1

Summary Modify Remove
Enter Link Aggregation Interface ID; 1 {1-8)
Specify Interface Type: @ Static (LACP Disabled) Note: The type of the link aggregation interface set here
§ i . overwrites the existing LACP settings of the ports in the link
' Dynamic (LACP Enabled) aggregation interface.

Select port(s) for the link aggregation interface:

E Hﬂ nﬂ 1910-24 Switch ...
L bl el el

Select All Select None
Selected Ports: Unselected Ports:
. Memebers of the link aggregation interface to be I:I Not a member of any link aggregation interface.
created.
. Members of existing link aggregation interfaces.
Summary:
Aggregation Interface ID Member Ports Aggregation Interface Type
1 Eth1/041-Eth1/0/3 Static
4 3

Apphy Cancel

Method 2: Create dynamic link aggregation group 1

1. From the navigation tree, select Network > Link Aggregation.
2. Click Create.
3. Configure dynamic aggregation group 1:
a. Enter link aggregation interface ID 1.
b. Select the Dynamic (LACP Enabled) option for aggregate interface type.
c. Select Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3 on the chassis front panel.
4.  Click Apply.
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Figure 195 Creating dynamic link aggregation group 1

Summary Modify Remove

Enter Link Aggregation Interface ID; 1 (1-8)

Specify Interface Type: ) Static (LACP Disabled) Note: The type of the link aggregation interface set here
- . . overwrites the existing LACP settings of the ports in the link
@ Dynamic (LACF Enabled) aggregation interface.

Select port(s) for the link aggregation interface:

Hﬂ ) il ol o] ol ) 1910:28 Swich

L Lol L]l d == 0] = ][=]

Select All Select None

Selected Ports: Unselected Ports:

. Memebers of the link aggregation interface to be

created. D Not a member of any link aggregation interface.

. Members of existing link aggregation interfaces.

Summary:
Aggregation Interface ID Member Ports. Aggregation Interface Type

1

Eth1/0/M-Eth1/0/3 Dynamic

| Cancel

Configuration guidelines

When you configure a link aggregation group, follow these guidelines:

In an aggregation group, a Selected port must have the same port attributes and class-two
configurations as the reference port. To keep these configurations consistent, you should configure
the port manually.

Choose a reference port from the member ports that are in up state and with the same class-two
configurations as the aggregate interface. The candidate ports are sorted in the following order:

o Full duplex/high speed

o Full duplex/low speed

o Half duplex/high speed

o half duplex/low speed

If two ports have the same duplex mode/speed pair, the one with the lower port number is chosen.

Port attribute configuration includes the configuration of the port rate, duplex mode, and link state.
For more information about classtwo configurations, see "Configuration classes."

To guarantee a successtul static aggregation, make sure that the ports at the two ends of each link
to be aggregated are in the same aggregation state. To guarantee a successful dynamic
aggregation, make sure that the peer ports of the ports aggregated at one end are also aggregated.
The two ends can automatically negotiate the aggregation state of each member port.

Do not assign the following types of ports to Layer 2 aggregate groups:
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o MAC address authentication-enabled ports.
o port security-enabled ports.

o packet filtering-enabled ports.

o Ethernet frame filtering-enabled ports.

o P source guard-enabled ports.

o 802.1X-enabled ports.

Removing a Layer 2 aggregate interface also removes its aggregation group and causes all
member ports to leave the aggregation group.

When a load-sharing aggregation group becomes non-load-sharing because of insufficient load
sharing resources, one of the following problems might occur:

o The number of Selected ports of the actor is inconsistent with that of the partner, which might
result in incorrect traffic forwarding

o The peer port of a Selected port is Unselected, which might result anomalies in upper-layer
protocol and traffic forwarding.
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Configuring LLDP

Overview

In a heterogeneous network, a standard configuration exchange platform makes sure different types of
network devices from different vendors can discover one another, and exchange configuration for the
sake of interoperability and management.

The Link Layer Discovery Protocol (LLDP) is specified in [EEE 802.1AB. The protocol operates on the data
link layer to exchange device information between directly connected devices. With LLDP, a device sends
local device information, including its major functions, management IP address, device ID, and port ID,
as TLV (type, length, and value) triplets in LLDP Data Units (LLDPDUs) to the directly connected devices. At
the same time, the device stores the device information received in LLDPDUs sent from the LLDP neighbors
in a standard MIB. LLDP enables a network management system to quickly detect and identity Layer 2
network topology changes.

For more information about MIBs, see "Configuring SNMP."

Basic concepts

LLDPDU formats

LLDP sends device information in LLDP data units (LLDPDUs). LLDPDUs are encapsulated in Ethernet Il or
SNAP frames.

1. LLDPDUs encapsulated in Ethernet Il
Figure 196 LLDPDU encapsulated in Ethernet II

0 15 31
Destination MAC address

Source MAC address

Type

Data = LLDPU
(1500 bytes)

FCS

Table 69 Fields in an Ethernet Il encapsulated LLDPDU

Field Description

MAC address to which the LLDPDU is advertised. It is fixed to
0x0180-C200-000E, a multicast MAC address.

Source MAC address MAC address of the sending port.

Destination MAC address

Type Ethernet type for the upper layer protocol. It is 0x88CC for LLDP.
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LLDPDUs

TLVs

Field Description
Data LLDP data.
FCS Frame check sequence, a 32-bit CRC value used to determine the

validity of the received Ethernet frame.

2. LLDPDUs encapsulated in SNAP
Figure 197 LLDPDU encapsulated in SNAP

0

15

31

Destination MAC address

Source MAC address

Type

Da

ta = LLDPU
(n bytes)

FCS

Table 70 Fields in a SNAP-encapsulated LLDPDU

Field

Description

Destination MAC address

MAC address to which the LLDPDU is advertised. It is fixed to

0x0180-C200-000E, a multicast MAC address.

Source MAC address

MAC address of the sending port. If the port does not have a MAC
address, the MAC address of the sending bridge is used.

SNAP-encoded LLDP Ethernet type for the upper layer protocol. It is

Type OxAAAA-0300-0000-88CC for LLDP.
Data LLDP data unit.
FCS Frame check sequence, a 32-bit CRC value used to determine the

validity of the received Ethernet frame.

LLDP uses LLDPDUs to exchange information. An LLDPDU comprises multiple TLV sequences, each
carrying a type of device information, as shown in Figure 198.

Figure 198 LLDPDU encapsulation format

Chassis ID TLV

Port ID TLV

Time To Live TLV

Optional TLV

Optional TLV

End of LLDPDU TLV

An LLDPDU can carry up to 28 types of TLVs. The chassis ID TLV, port ID TLV, TTLTLV, and end of LLDPDU
TLV are mandatory TLVs that must be carried, and the other TLVs are optional.

TLVs are type, length, and value sequences that carry information elements, where the type field identifies
the type of information, the length field indicates the length of the information field in octets, and the
value field contains the information itself.
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LLDPDU TLVs include the following categories: basic management TLVs, organizationally (IEEE 802.1
and IEEE 802.3) specific TLVs, and LLDP-MED (media endpoint discovery) TLVs. Basic management TLVs
are essential to device management. Organizationally specific TLVs and LLDP-MED TLVs are used for
improved device management. They are defined by standardization or other organizations and are

optional to LLDPDUs.

1. Basic management TLVs

Table 71 lists the basic management TLV types. Some of them must be included in LLDPDUs.

Table 71 Basic LLDP TLVs

Type Description Remarks

Chassis ID Specifies the bridge MAC address of the sending device.
Specifies the ID of the sending port.
If LLDP-MED TLVs are included in the LLDPDU, the port ID

Port ID TLV carries the MAC address of the sending port or the
bridge MAC in case the port does not have a MAC Mand
address. If no LLDP-MED TLVs are included, the port ID andatory.
TLV carries the port name.

. . Specifies the life of the transmitted information on the
Time to Live

receiving device.

End of LLDPDU

Marks the end of the TLV sequence in the LLDPDU.

Port Description

Specifies the port description of the sending port.

System Name

Specifies the assigned name of the sending device.

System Description

Specifies the description of the sending device.

System Capabilities

Identifies the primary functions of the sending device and

tional.
the primary functions that have been enabled. Optiona

Management Address

Specifies the management address used to reach higher
level entities to assist discovery by network management,
and the interface number and OID associated with the
address.

2. IEEE 802.1 organizationally specific TLVs
Table 72 IEEE 802.1 organizationally specific TLVs

Type

Description

Port VLAN ID

Specifies the port's VLAN identifier (PVID). An LLDPDU carries
only one TLV of this type.

Port And Protocol VLAN ID

Indicates whether the device supports protocol VLANs and, if
so, what VLAN IDs these protocols will be associated with. An
LLDPDU can carry multiple different TLVs of this type.

VLAN Name

Specifies the textual name of any VLAN to which the port
belongs. An LLDPDU can carry multiple different TLVs of this

type.

Protocol Identity

Indicates protocols supported on the port. An LLDPDU can
carry multiple different TLVs of this type.

DCBX

Data center bridging exchange protocol.
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HP devices support only receiving protocol identity TLVs.
3. |EEE 802.3 organizationally specific TLVs

Table 73 IEEE 802.3 organizationally specific TLVs

Type Description
MAC/PHY Contains the rate and duplex capabilities of the sending port, support for
Configuration/Status auto negotiation, enabling status of auto negotiation, and the current rate
9 and duplex mode.
Contains the power supply capability of the port, including the PoE type
Power Via MDI (PSE or PD), PoE mode, whether PSE power supply is supported, whether
PSE power supply is enabled, and whether the PoE mode is controllable.
Indicates the support of the port for link aggregation, the aggregation
Link Aggregation capability of the port, and the aggregation status (or whether the link is in an

aggregation).

Maximum Frame Size Indicates the supported maximum frame size. It is now the MTU of the port.

Indicates the power state control configured on the sending port, including
the power type of the PSE/PD, PoE sourcing/receiving priority, and PoE
sourcing/receiving power.

Power Stateful Control

The power stateful control TLV is defined in IEEE P802.3at D1.0. The later versions no longer
support this TLV. HP devices send this type of TLVs only after receiving them.

4. LLDP-MED TLVs

LLDP-MED TLVs provide multiple advanced applications for VolP, such as basic configuration,
network policy configuration, and address and directory management. LLDP-MED TLVs meet the
voice device vendors' requirements for cost effectiveness, ease of deployment, and ease of
management. In addition, LLDP-MED TLVs make deploying voice devices in Ethernet easier.
LLDP-MED TLVs are shown in Table 74.

Table 74 LLDP-MED TLVs

Type Description

LLDP-MED Capabilities  Allows a network device to advertise the LLDP-MED TLVs that it supports.

Network Policy

Allows a network device or terminal device to advertise the VLAN ID of the
specific port, the VLAN type, and the Layer 2 and Layer 3 priorities for specific
applications.

Extended
Power-via-MDI

Allows a network device or terminal device to advertise power supply
capability. This TLV is an extension of the Power Via MDI TLV.

Hardware Revision

Allows a terminal device to advertise its hardware version.

Firmware Revision

Allows a terminal device to advertise its firmware version.

Software Revision

Allows a terminal device to advertise its software version.

Serial Number

Allows a terminal device to advertise its serial number.

Manufacturer Name

Allows a terminal device to advertise its vendor name.

Model Name Allows a terminal device to advertise its model name.
Allows a terminal device to advertise its asset ID. The typical case is that the
Asset ID user specifies the asset ID for the endpoint to help directory management and

asset tracking.
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Type Description

Allows a network device to advertise the appropriate location identifier
Location Identification  information for a terminal device to use in the context of location-based
applications.

For more information about LLDPDU TLVs, see the IEEE standard (LLDP) 802.1AB-2005 and the
LLDP-MED standard (ANSI/TIA-1057).

Management address

The management address of a device is used by the network management system to identify and
manage the device for topology maintenance and network management. The management address is
encapsulated in the management address TLV.

Operating modes of LLDP

LLDP can operate in one of the following modes:

e  TxRx mode—A port in this mode can send and receive LLDPDUs.
e Txmode—A port in this mode can only send LLDPDUs.

e Rxmode—A port in this mode can only receive LLDPDUs.

o  Disable mode—A port in this mode cannot send or receive LLDPDUs.

Each time the LLDP operating mode of a port changes, its LLDP protocol state machine re-initializes. To
prevent LLDP from being initialized too frequently at times of frequent operating mode changes, you can
configure an initialization delay. With this delay mechanism, a port must wait for the specified interval
before it can initialize LLDP after the LLDP operating mode changes.

How LLDP works

Transmitting LLDPDUs

An LLDP-enabled port operating in TxRx mode or Tx mode sends LLDPDUs to its directly connected
devices both periodically and when the local configuration changes. To prevent the network from being
overwhelmed by LLDPDUs at times of frequent local device information change, an interval is introduced
between two successive LLDPDUs.

This inferval is shortened o 1 second in either of the following cases:

e A new neighbor is discovered. A new LLDPDU is received carrying device information new fo the
local device.

e The LLDP operating mode of the port changes from Disable/Rx to TxRx or Tx.

This is the fast sending mechanism of LLDP. With this mechanism, a specific number of LLDPDUs are sent
successively at the 1-second interval to help LLDP neighbors discover the local device as soon as possible.
Then, the normal LLDPDU transit interval resumes.

Receiving LLDPDUs

An LLDP-enabled port operating in TxRx mode or Rx mode checks the TLVs carried in every LLDPDU it
receives for validity violation. If valid, the information is saved and an aging timer is set for it based on
the TTL TLV carried in the LLDPDU. If the TTL TLV is zero, the information is aged out immediately.
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Protocols and standards

e  |EEE 802.1AB-2005, Station and Media Access Control Connectivity Discovery
e ANSI/TIA-1057, Link Layer Discovery Protocol for Media Endpoint Devices

Recommended LLDP configuration procedure

Step Remarks
Optional.
1. Enabling LLDP on ports. By default, LLDP is enabled on ports.

Make sure LLDP is also enabled globally, because LLDP can work on a port
only when it is enabled both globally and on the port.

Optional.

LLDP settings include LLDP operating mode, packet encapsulation, CDP
compatibility, device information polling, trapping, and advertisable TLVs.

By default:

2. Setting LLDP parameters . .
on ports. o The LLDP operating mode is TxRx.
e The encapsulation format is Ethernet Il.
e CDP compatibility is disabled.
e Device information polling and trapping are disabled.
e All TLVs except the Location Identification TLV are advertised.
3 Confiouring LLDP Required.
’ |Or£)|(‘:|ilurmg By default, global LLDP is disabled.
globally.
To enable LLDP to work on a port, enable LLDP both globally and on the port.
Optional.
You can display the local LLDP information, neighbor information, statistics,
4. Displaying LLDP and status information of a port, where:
information for a port. e The local LLDP information refers to the TLVs to be advertised by the local
device to neighbors.
e The neighbor information refers to the TLVs received from neighbors.
5. Displaying global LLDP  Optional.
information. You can display the local global LLDP information and statistics.
6. Displaying LLDP

information received

from LLDP neighbors.

Optional.

You can display the LLDP information received from LLDP neighbors.

Enabling LLDP on

ports

1. From the navigation tree, select Network > LLDP.
By default, the Port Setup tab is displayed. This tab displays the enabling status and operating
mode of LLDP on a port.

2. Select one or more ports and click Enable beneath the port list to enable LLDP on these ports.
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To disable LLDP on a port, select the port and click Disable.
Figure 199 The port setup tab

Global Setup Global Summary Meighbor Summary

|CR Port Name v | Search | Advanced Search

[l Port Name LLDFP Status LLDP Work Mode Operation
[] Ethernet1/0/1 Enabled TxRx [

[] Ethernet1/0/2 Enabled TxRx

[] Ethernet1/0/3 Enabled TxRx

[] Ethernet1/0/4 Enabled TxRx ff

[] Ethernet1/0/5 Enabled TxRx B

[C] Ethemnet1/0/8 Enabled TxRx 2

[] Ethernet1/0/7 Enabled TxRx =

[] Ethernet1/0/3 Enabled TxRx B

[£] Ethernet1/0/a Enabled TxRux 2

[] Ethernet1/0/10 Enabled TxRx 2

[] Ethernet1/0/11 Enabled TxRx [

[] Ethernet1/0/12 Enabled TxRx e

[] Ethernet1/0/13 Enabled TxRx EF

[] Ethernet1/0/14 Enabled TxRx ff

[] Ethernet1/0/15 Enabled TxRx B

26 records, 15 ¥ per page | page 1/2, record 1-15 | First Prev Mext Last | 1
Enable Disable Modify Selected

Meighbor Information | Statistic Information | Status Information

Setting LLDP parameters on ports

The Web interface allows you to set LLDP parameters for a single port and for multiple ports in batch.

Setting LLDP parameters for a single port

1. From the navigation tree, select Network > LLDP.
By default, the Port Setup tab is displayed.

o

2. Click the = icon for the port you are configuring.

On the page as shown in Figure 200, the LLDP settings of the port are displayed.
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Figure 200 Modifying LLDP settings on a port

Global Setup Global Summarny Meighbor Summarny

Interface Name Eth1/0d1

Basic Settings

LLDF State Enable

LLDP Operating Mode TxRx
CDP Cperating Mode Dizable

LLDP Trapping Dizable

Base TLV Settings

- Encapsulation Format ETHII -

- LLDF Pelling Interval seconds (1-30)

Fort Description
System Desoription

Management Address

+2ddticnal TLV Settings

System Capabilities

[@] System Mame

Number -

Apply Cancel

Modify the LLDP parameters for the port as described in Table 75.

Click Apply.
A progress dialog box appears.

Click Close on the progress dialog box when the progress dialog box prompts that the

configuration succeeds.

Table 75 Configuration items

ltem

Description

Interface Name

Displays the name of the port or ports you are configuring.

Displays the LLDP enabling status on the port you are configuring.

DLDP State
This field is not available when you batch-configure ports.
Set the LLDP operating mode on the port or ports you are
configuring:

Basic e TxRx—Sends and receives LLDPDUs.

Seftings LLDP Operating Mode

e Tx—Sends but does not receive LLDPDUs.
e Rx—Receives but not does not send LLDPDUs.
e Disable—Neither sends nor receives LLDPDUs.
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ltem

Description

Encapsulation Format

Set the encapsulation for LLDPDUs:

o ETHII—Encapsulates outgoing LLDPDUs in Ethernet Il frames and
processes an incoming LLDPDU only if its encapsulation is
Ethernet II.

o SNAP—Encapsulates outgoing LLDPDUs in Ethernet Il frames
and processes an incoming LLDPDU only if its encapsulation is
Ethernet II.

LLDP-CDP PDUs use only SNAP encapsulation.

CDP Operating Mode

Set the CDP compatibility of LLDP:
e Disable—Neither sends nor receives CDPDUs.

e TxRx—Sends and receives CDPDUs

To enable LLDP to be compatible with CDP on the port, you must
enable CDP compatibility on the Global Setup tab and set the CDP

operating mode on the port to TxRx.

LLDP Polling Interval

Enable LLDP polling and set the polling interval.
If no polling interval is set, LLDP polling is disabled.

With the polling mechanism, LLDP periodically detects local
configuration changes. If a configuration change is defected, an
LLDPDU is sent to inform the LLDP neighbors of the change.

LLDP Trapping

Set the enable status of the LLDP trapping function on the port or
ports.

LLDP trapping is used to report fo the network management station
critical events such as new neighbor devices detected and link
failures.

To avoid excessive traps from being sent when topology is instable,
tune the minimum trap transit interval on the Global Setup tab.

Base TLV
Settings

Port Description

Select the box to include the port description TLV in transmitted
LLDPDUs.

System Capabilities

Select the box to include the system capabilities TLV in transmitted
LLDPDUs.

System Description

Select the box to include the system description TLV in transmitted

LLDPDUs.

System Name

Select the box to include the system name TLV in transmitted
LLDPDUs.

Management Address

Select the box to include the management address TLV in
transmitted LLDPDUs and, in addition, set the management address
and its format (a numeric or character string in the TLV).

If no management address is specified, the main IP address of the
lowest VLAN carried on the port is used. If no main IP address is
assigned to the VLAN, 127.0.0.1 is used.
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ltem Description
Port VLAN ID Select the box to include the PVID TLV in transmitted LLDPDUs.
Select the box to include port and protocol VLAN ID TLVs in
Protocol VLAN ID transmitted LLDPDUs and specify the VLAN IDs to be advertised.
.lrjl_(\?ﬂ If no VLAN is specified, the lowest protocol VLAN ID is transmitted.
Setting Select the box to include VLAN name TLVs in transmitted LLDPDUs,
and specify the VLAN IDs to be advertised.
VLAN Name
If no VLAN is specified, the lowest VLAN carried on the port is
advertised.
. . Select the box to include the link aggregation TLV in transmitted
Link Aggregation LLDPDUs.
MAC/PHY Select the box to include the MAC/PHY configuration/status TLV in
DOT3 Configuration/Status  transmitted LLDPDUs.
v
Sefting Maximum Frame Size Select the box to include the maximum frame size TLV in transmitted
LLDPDUs.
p ia MDI Select the box to include the power via MDI TLV and power stateful
owervia control TLV in transmitted LLDPDUs.
LLDP-MED Select the box to include the LLDP-MED capabilities TLV in
Capabilities transmitted LLDPDUs.
Select the box to include the hardware revision TLV, firmware
Inventor revision TLV, software revision TLV, serial number TLV,
ventory manufacturer name TLV, model name TLV and asset ID TLV in
transmitted LLDPDUs.
. Select the box to include the network policy TLV in transmitted
Network Policy LLDPDUs.
Extende.d Select the box to include the extended power-via-MDI TLV in
Power-via-MDI .
. transmitted LLDPDUs.
Capability
Select the box to encode the emergency call number in the location
MED TLV  Emergency Number identification TLV in transmitted LLDPDUs and set the emergency call
Sefting number.

Address

Network Device
Address

Select Address to encode the civic address information of the
network connectivity device in the location identification TLV in
transmitted LLDPDUs. In addition, set the device type (DHCP server,
switch, or LLDP-MED endpoint), country code, and network device
address.

When you configure the network device address, select the address
information type from the list, enter the address information in the
field below, and click Add next to the field to add the information to
the address information list below. To remove an address
information entry, select the entry from the list, and click Delete. The
civic address information can include language, province/state,
country, city, street, house number, name, postal/zip code, room
number, post office box, and, if necessary, additional information.
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Setting LLDP parameters for ports in batch

1. From the navigation tree, select Network > LLDP.

By default, the Port Setup tab is displayed.

Select one or multiple ports on the port list.

Click Modify Selected to enter the page for modifying these ports in batch.

Figure 201 Modifying LLDP settings on ports in batch

Globkal Setup Globkal Summary MNeighbor Summary
Interface Mame Ethernet1/0/1 Ethernet1/0/2 Ethernet1/0/2
Basic Settings
LLDP Operating Mode TxRx - Encapsulation Format ETHII
‘COP Cperating Mode Dizable - LLDP Palling Interval
LLDP Trapping Disable -

Base TLW Settings

[7] Port Description
D System Desoription

[F] ma nagement Address

+2ddtional Settings

[7] system Capabilities

] Systern Name

String -

Apply Cancsl|

Set the LLDP settings for these ports as described in Table 75.

5. Click Apply.
A progress dialog box appears.

seconds {1-30)

6. Click Close on the progress dialog box when the progress dialog box prompts that the

configuration succeeds.

Contiguring LLDP globally

1. From the navigation tree, select Network > LLDP.

2. Click the Global Setup tab.
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Figure 202 The global setup tab

FPort Setup Global Surmmary Meighbor Surmmary
Global Setup

LLOP Enable Disable b

CDP Compatibility Disable b

Fast LLDPDU Count |3 (1-10, Default=2)

TTL Multiplier 4 (2-10, Default=4)

Trap Interval ] Second(5-3600, Default= )
Reinit Delay 2 Second{1-10, Default= 2

Tx Delay 2 Second(1-8192, Default= 2}
Ty Interval a0 Second(5-32768, Default= 30

Apfaly

Set the global LLDP setup as described in Table 76.
Click Apply.
A progress dialog box appears.

Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.

Table 76 Configuration items

ltem Description

LLDP Enable Select from the list to enable or disable global LLDP.

Select from the list to enable or disable CDP compatibility of LLDP.
When you configure CDP compatibility, follow these guidelines:

¢ To enable LLDP to be compatible with CDP on a port, you must set the CDP
operating mode on the port to TxRx and enable CDP compatibility on the
CDP Compatibility Global Setup tab.

e Because the maximum TTL allowed by CDP is 255 seconds, you must make
sure the product of the TTL multiplier and the LLDPDU transmit inferval is less
than 255 seconds for CDP-compatible LLDP to work correctly with Cisco IP
phones.

Set the number of LLDPDUs sent each time fast LLDPDU transmission is

Fast LLDPDU Count .
triggered.
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ltem Description
Set the TTL multiplier.
The TTL TLV carried in an LLDPDU determines how long the device information
carried in the LLDPDU can be saved on a recipient device. You can configure
the TTL of locally sent LLDPDUs to determine how long information about the
local device can be saved on a neighbor device by setting the TTL multiplier.
The TTL is expressed as TTL multiplier x LLDPDU transit interval.

TTL Muttiplier When you configure the TTL multiplier, follow these guidelines:

o |If the product of the TTL multiplier and the LLDPDU transmit interval is
greater than 65535, the TTL carried in transmitted LLDPDUs takes 65535
seconds.

e Because the maximum TTL allowed by CDP is 255 seconds, you must make
sure the product of the TTL multiplier and the LLDPDU transmit inferval is less
than 255 seconds for CDP-compatible LLDP to work correctly with Cisco IP
phones.

Trap Interval

Set the minimum interval for sending traps.

With the LLDP trapping function enabled on a port, traps are sent out of the
port to advertise the topology changes detected over the trap interval to
neighbors. By tuning this interval, you can prevent excessive traps from being
sent when topology is instable.

Reinit Delay

Set initialization delay for LLDP-enabled ports.

Each time the LLDP operating mode of a port changes, its LLDP protocol state
machine re-initializes. To prevent LLDP from being initialized too frequently at
times of frequent operating mode change, initialization delay is introduced.
With this delay mechanism, a port must wait for the specified interval before it
can initialize LLDP after the LLDP operating mode changes.

Tx Delay

Set LLDPDU transmit delay.

With LLDP enabled, a port advertises LLDPDUs to its neighbors both
periodically and when the local configuration changes. To avoid excessive
number of LLDPDUs caused by frequent local configuration changes, an
LLDPDU transmit delay is intfroduced. After sending an LLDPDU, the port must
wait for the specified interval before it can send another one.

LLDPDU transmit delay must be less than the TTL to make sure the LLDP neighbors
can receive LLDPDUs to update information about the device you are configuring
before it is aged out.

Tx Interval

Set the LLDPDU transmit interval.

If the product of the TTL multiplier and the LLDPDU transmit interval is greater
than 65535, the TTL carried in transmitted LLDPDUs takes 65535 seconds. The
likelihood exists that the LLDPDU transmit inferval is greater than TTL. You should
avoid the situation, because the LLDP neighbors will fail to receive LLDPDUs to
update information about the device you are configuring before it is aged out.

Displaying LLDP information for a port

1.

From the navigation tree, select Network > LLDP.

By default, the Port Setup tab is displayed.

On the port list, click a port name to display its LLDP information at the lower half of the page.

By default, the Local Information tab is displayed. Table 77 describes the fields.
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Figure 203 The local information tab

Meighbor Information | Statistic Information | Status Information

LLDF local-information of port 23[Ethernet1/0/23]:
Port 1D subtype : Interface name
FPort 1D :Ethernet1/0/23
Port description : Ethernet1/0/23 Interface

Management address type sipvd
Management address 0 169.264.2013
Management address interface type : ifindex
Management address interface ID ;30
Management address QID -0

Port VLAN ID(PVID): 1

Table 77 Field description

Field Description

Port ID representation:
e Interface dlias.
e Port component.
e MAC address.

Port ID subtype o Network address.
¢ Interface name.
e Agent circuit ID.

¢ locally assigned—Locally-defined port ID type other than those listed
above.

Power over Ethernet port class:
Power port class o PSE—Power supply device.

e PD—Powered device.

Port power classification of the PD:

e Unknown.

b e ClassO.

ort power e Classl.
classification

e Class2.

e Class3.

o Class4.

Media policy type:

e Unknown.

e Voice.

e Voice signaling.
Media policy type ° Gvest voice. o
e Guest voice signaling.
o Soft phone voice.
e Videoconferencing.
e Streaming video.

e Video signaling.
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Field Description

Type of PSE power source advertised by the local device:
PoE PSE power source e  Primary.

e Backup.

PSE priority of the port:

e Unknown—Unknown PSE priority.
Port PSE priority e Critical —Priority level 1.

e High—Priority level 2.

e Low—Priority level 3.

3. Click the Neighbor Information tab to display the LLDP neighbor information.
Table 78 describes the fields.

Figure 204 The neighbor information tab

Local Information Statistic Information | Status Information

LLDP neighbor-information of port 5[Ethernet1/0/5];

Meighborindex -1

Update time 0 days,2 hours 47 minutes,57 seconds

Chassis type : MAC address

Chassis ID . d07e-2849-dack

PortID type : Interface name

PortID : Ethernet1/0/3

Port description : Ethernet1/0/3 Interface

System name "HP

System description : 1910-24-PoE+ (180W) Switch Software Version 5.20, ESS 1101
Copyright(c)2010-2013 Hewlett-Packard Development Company, L.P. -

Refresh

Table 78 Field description

Field Description

Chassis ID representation:

e Chassis component.

¢ Interface dlias.

e Port component.
Chassis type e MAC address.

¢ Network address.

e Interface name.

¢ locally assigned—Locally-defined chassis type other than those listed
above.

Chassis ID depending on the chassis type, which can be a MAC address

Chassis ID of the device.
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Field

Description

Port ID representation:
¢ Interface dlias.

e Port component.

e MAC address.

Port ID type o Network address.
¢ Interface name.
e Agent circuit ID.
¢ Llocally assigned—Locally-defined port ID type other than those listed
above.
Port ID Port ID value.

System capabilities supported

Primary network function of the system:
® Repeater.
e Bridge.

e Router.

System capabilities enabled

Network function enabled on the system:
® Repeater.
e Bridge.

e Router.

Auto-negotiation supported

Support of the neighbor for auto negotiation.

Auto-negotiation enabled

Enabling status of auto negotiation on the neighbor.

OperMau

Current speed and duplex mode of the neighbor.

Link aggregation supported

Support of the neighbor for link aggregation.

Link aggregation enabled

Enabling status of link aggregation on the neighbor.

Aggregation port ID

Link aggregation group ID. It is O if the neighbor port is not assigned to
any link aggregation group.

Maximum frame Size

Maximum frame size supported on the neighbor port.

Device class

MED device type:

e Connectivity device—An intermediate device that provide network
connectivity.

o Class I—A generic endpoint device. All endpoints that require the
discovery service of LLDP belong to this category.

e Class llI—A media endpoint device. The class Il endpoint devices
support the media stream capabilities and the capabilities of generic
endpoint devices.

e Class lll—A communication endpoint device. The class lll endpoint
devices directly support end users of the IP communication system.
Providing all capabilities of generic and media endpoint devices,
Class Ill endpoint devices are used directly by end users.
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Field

Description

Media policy type

Media policy type:

e Unknown.

e Voice.

e Voice signaling.

e Guest voice.

o Guest voice signaling.
e Soft phone voice.

e Videoconferencing.

e Streaming video.

¢ Video signaling.

Unknown Policy

Indicates whether the media policy type is unknown.

VLAN tagged

Indicates whether packets of the media VLAN are tagged.

Media policy VlanID

ID of the media VLAN.

Media policy L2 priority

Layer 2 priority.

Media policy Dscp

DSCP precedence.

HardwareRev

Hardware version of the neighbor.

FirmwareRev

Firmware version of the neighbor.

SoftwareRev

Software version of the neighbor.

SerialNum

Serial number advertised by the neighbor.

Manufacturer name

Manufacturer name advertised by the neighbor.

Model name

Model name advertised by the neighbor.

Asset tracking identifier

Asset ID advertised by the neighbor. This ID is used for the purpose of
inventory management and asset tracking.

PoE PSE power source

Type of PSE power source advertised by the neighbor:
e Primary.

e Backup.

Port PSE priority

PSE priority of the port:

e Unknown—Unknown PSE priority.
e Critical —Priority level 1.

o High—Priority level 2.

e Low—Priority level 3.

4.  Click the Statistics Information tab to display the LLDP statistics.
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Figure 205 The statistic information tab

Local Information | Meighbor Information Status Information

LLDP statistics information of port 23 [Ethernet1/0/23]:
The number of LLDP frames transmitted c441
The number of LLDP frames received 0

The number of LLDP frames discarded 0
The number of LLDP error frames -0

The number of LLDP TLVs discarded -0

The number of LLDP TLVs unrecognized -0
The number of LLDP neighbor information aged out: 0
The number of COP frames transmitted 0
The number of COP frames received -0

The number of COP frames discarded 0

The number of COP error frames 0

5.  Click the Status Information tab to display the LLDP status information.
Figure 206 The status information tab

Local Information | Meighbor Information | Statistic Information

Port 23 [Ethernet1/0/23]:

Port status of LLDP :Enable
Admin status cTe_Rx
Trap flag "Moo

Polling interval (0=
Mumber of neighbars: 0

Mumber of MED neighbors -0
Mumber of COP neighbors -0
Mumber of sent aptional TLY 23
Mumber of received unknown TLV : 0

Displaying global LLDP information

1. From the navigation tree, select Network > LLDP.
2. Click the Global Summary tab to display global local LLDP information and statistics.
Table 79 describes the fields.
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Figure 207 The global summary tab

Port Setup Global Setup Neighbor Summary

Local Information

Glebal LLDP locak-information:
Chassis I : 0000-2013-1410
System name :HP
System description : 1910-24 Switch Software Version 5.20, Demo 1101
Copyright{c)2010-2013 Hewlett-Packard Develepment Company, L.P.
System capabilties supperted : Bridge Router
System capabilties enabled : Bridge,Router

MED information
Device class: Connectivity device

(MED inventory information of master board)
HardwareRev CREV.A

Statistic Information

LLDP statistics global infarmation:

LLDP neighbor information last change time:0 days,0 hours,0 minutes,0 seconds
The number of LLDP neighbor information inserted ; 0

The number of LLDP neighbor information deleted : 0

The number of LLOFP neighbor information dropped 0

The number of LLOP neighbor information aged out: 0

Table 79 Field description

Field Description
Chassis ID Local chassis ID depending on the chassis type defined.
Primary network function advertised by the local device:
System capabilities e Repeater.
supported e Bridge.
e Router.

Enabled network function advertised by the local device:

System capabilities ® Repeater.
enabled e Bridge.
e Router.
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Field Description

Device class advertised by the local device:

o Connectivity device—An intermediate device that provide network
connectivity.

e Class |—A generic endpoint device. All endpoints that require the discovery
service of LLDP belong to this category.

Device class e Class l—A media endpoint device. The class Il endpoint devices support
the media stream capabilities and the capabilities of generic endpoint
devices.

e Class lll—A communication endpoint device. The class Ill endpoint devices
directly support end users of the IP communication system. Providing all
capabilities of generic and media endpoint devices, Class Ill endpoint
devices are used directly by end users.

Displaying LLDP information received from LLDP
neighbors

From the navigation tree, select Network > LLDP.

2. Click the Neighbor Summary tab to display the global LLDP neighbor information, as shown

in Figure 208.
Figure 208 The neighbor summary tab
Port Setup Global Setup Global Summary
R Update Time = | Search | sdvanced Search
Update Time Local Port Chassis ID C“?rs_gif 2 Port ID PortiDType  System Name
Ype
0 days 0 hours 0
minutes 52 Ethernet1/0/5 d07e-2849-4acf MAC address  Ethernet1/0/2 Interface name HP
seconds
0 days 0 hours 32
minutes 53 Ethernet1/0/13 d07e-2849-4acf MAC address  Ethernet1/0M13 Interface name HP
seconds
Refresh

LLDP configuration example

Network requirements

As shown in Figure 209, configure LLDP on Switch A and Switch B so that the NMS can determine the
status of the link between Switch A and MED and the link between Switch A and Switch B.
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Figure 209 Network diagram

Eth1/0/1

Eth1/0/2 Eth1/0/1 @

Switch A Switch B

NMS

Configuring Switch A

1. (Optional.) Enable LLDP on Ethernet 1/0/1 and Ethernet 1/0/2. (By default, LLDP is enabled on
Ethernet poris.)

2. Set the LLDP operating mode to Rx on Ethernet 1/0/1 and Ethernet 1/0/2:
a. From the navigation tree, select Network > LLDP.
By default, the Port Setup tab is displayed, as shown in Figure 210.
b. Select port Ethernet1/0/1 and Ethernet1/0/2.
c. Click Modify Selected.
The page shown in Figure 211 appears.

Figure 210 The port setup tab

Global Setup Global Summary Neighbor Summary
Port Name v Search | agvanced Search

& Port Hame LLDP Status LLDP Work Mode Operation

thernet1/0i1 Enabled TrRxX @
Ethernet1/0/2 Enabled TxRx @
[0 Ethernet1/0i3 Enabled TxRx @
[ Etherneti/oid Enabled TrRx ]
D Ethernet!/0/5 Enabled TxRx @
[0 Etherneti/ois Enabled TrRx &)
[ Ethernet1/0i7 Enabled TxRx ]
[F] Ethernet1/0i3 Enabled TrRx @
[F] Ethernet1/0i9 Enabled TxRx @
[ Ethernet1/0i10 Enabled TxRx ]
[ Ethernett/oi1 Enabled TrRxX @
D Ethernet1/0/12 Enabled TxRx @
[T Ethernet/ons Enabled TrRxX @
[ Ethernett/ons Enabled TxRx i
[0 Ethernet1/0i1S Enabled TxRx @

26 records, 15 per page | page 1/2, record 1-15 Next Last 1 =2
Neighbor Statisti Status

d. Select Rx from the LLDP Operating Mode list.
3. Click Apply.
A progress dialog box appears.
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4.

Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.

Figure 211 Setting LLDP on multiple ports

Global Setup Global Summarny Meighbor Summary
Interface Mame Ethernet1/0/1 Ethernet1/0/2
Basic Settings
LLDF Operating Mode  Rx Encapsulation ETHII
perating =3 - Format -
. . LLEP Pelling
CDP Operating Mode Disable - Interal seconds {1-30)
LLDFP Trapping Disable -
Base TLVW Settings
[] Port Desaiption [ System Capabilities
= Systemn Description & Systemn Mame
D Management Address
String -

+2ddticnal Settings

Apply Cancel

Enable global LLDP:

a. Click the Global Setup tab, as shown in Figure 212.
b. Select Enable from the LLDP Enable list.

Click Apply.

A progress dialog box appears.

Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.
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Figure 212 The global setup tab

Faort Setup Global Summary Meighbor Summary
Global Setup _
LLDP Enable Enable v
CDP Compatibility | Disable w
Fast LLDPDLU Count |3 (1-10, Default= 3
TTL Multiplier 4 (2-10, Default= 43
Trap Interval ] Second(f-3600, Default= )
Reinit Delay 2 Second(1-10, Default= 2}
T Delay 2 Second(1-8182, Default= 23
Tx Interval 30 Second(f-32768, Default= 30)

Configuring Switch B

(Optional.) Enable LLDP on port Ethernet 1/0/1. (By default, LLDP is enabled on Ethernet ports.)
2. Set the LLDP operating mode to Tx on Ethernet 1/0/1:

a. From the navigation tree, select Network > LLDP.

By default, the Port Setup tab is displayed.

b. Click the & icon for port Ethernet 1/0/1.

c. Select Tx from the LLDP Operating Mode list.
3. Click Apply.

A progress dialog box appears.

4. Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.
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Figure 213 Setting the LLDP operating mode to Tx

Global Setup Global Summary Meighbor Summary
Interface Name Eth1/0/1 LLDF State Ensable
Basic Settings
LLDP Operating Mode Tx - Encapsulation Format ETHII -
COP Cperating Mode Disable - LLDP Polling Interal seconds (1-30)
LLDP Trapping Disable -

Base TLV Settings

Port Description Systemn Capabilities
System Desoription System Name

Management Address

Number -

+ addtional TLV Settings

Cancel

5. Enable global LLDP:

a. Click the Global Setup tab.

b. Select Enable from the LLDP Enable list.
6. Click Apply.

A progress dialog box appears.

7.  Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.

Veritying the contiguration

1. Display the status information of port Ethernet 1/0/1 on Switch A:
a. From the navigation tree, select Network > LLDP.
By default, the Port Setup tab is displayed.
b. Click the Ethernet1/0/1 port name in the port list.
c. Click the Status Information tab at the lower half of the page.
The output shows that port Ethernet 1/0/1 is connected to an MED neighbor device.
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2,

Figure 214 The status information tab (1)
Local Information | Meighbor Information | Statistic Information

Port 1 [Ethernet1/0/1]:

Port status of LLDP :Enable
Admin status - Rx_Only
Trap flag *MNo

Paolling interval (0s
Mumber of neighbors: 0

Mumber of MED neighbors -0
Mumber of CDP neighbors 0
Mumber of sent optional TLV 23
Mumber of received unknown TLV : 0

Display the status information of port Ethernet 1/0/2 on Switch A:
a. Click the Ethernet1/0/2 port name in the port list.
b. Click the Status Information tab at the lower half of the page.

The output shows that port Ethernet 1/0/2 is connected to a non-MED neighbor device (Switch
B), as shown in Figure 215.

Figure 215 The status information tab (2)
Local Information | Meighbor Information | Statistic Information

Port 2 [Ethernet1/0/2]:

Port status of LLDP -Enable
Admin status - Ry_Cinly
Trap flag “MNo

Polling interval 05
Mumber of neighbors: 1

Mumber of MED neighbors -0
Mumber of CDP neighbors -0
Mumber of sent optional TLV 23
Mumber of received unknown TLV : 0

Refresh

Tear down the link between Switch A and Switch B.
Click Refresh to display the status information of port Ethernet 1/0/2 on Switch A.

The updated status information of port Ethernet 1,/0/2 shows that no neighbor device is connected
to the port, as shown in Figure 216.

Figure 216 The status information tab displaying the updated port status information
Local Information | Meighbor Information | Statistic Information

Port 2 [Ethernet1/0i2]:

Port status of LLDP - Enable
Admin status T Ry_oOnly
Trap flag Mo

Palling interval ‘0s
Mumber of neighbors: 0

Mumber of MED neighbors -0
Mumber of COP neighbors 0
Mumber of sent optional TLY 23
Mumber of received unknown TLY : 0

246



LLDP contiguration guidelines

When you configure LLDP, follow these guidelines:

To make LLDP take effect on a port, enable LLDP both globally and on the port.

To advertise LLDP-MED TLVs other than the LLDP-MED capabilities TLV, include the LLDP-MED
capabilities TLV.

To remove the LLDP-MED capabilities TLV, remove all other LLDP-MED TLVs.
To remove the MAC/PHY configuration TLV, remove the LLDP-MED capabilities set TLV first.

When the advertising of LLDP-MED capabilities TLV and MAC/PHY configuration/status TLV is
disabled, if the LLDP-MED capabilities set TLV is included, the MAC/PHY configuration/status TLV
is included automatically.

When you configure LLDP settings for ports in batch, if you do not set the TLVs, each port uses its
own TLV settings.
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Configuring ARP

Overview

ARP resolves IP addresses into MAC addresses on Ethernet networks.

ARP message format

ARP uses two types of messages: ARP request and ARP reply. Figure 217 shows the format of the ARP
request/reply messages. Numbers in the figure refer to field lengths.

Figure 217 ARP message format

—» Hardware address length

’—> Protocol address length

Hardware|Protocol Sender hardware |Sender protocoll  Target hardware |Target protoco
type type oP address address address address
2 2 11 2 6 4 6 4

A 4

A

28-byte ARP request/reply

e  Hardware type—Hardware address type. The value 1 represents Ethernet.

e Protocol type—Type of the protocol address to be mapped. The hexadecimal value 0x0800
represents IP.

e Hardware address length and protocol address length—Length, in bytes, of a hardware address
and a protocol address. For an Ethernet address, the value of the hardware address length field is
6. For an IPv4 address, the value of the protocol address length field is 4.

e OP—Operation code, which describes type of the ARP message. Value 1 represents an ARP request,
and value 2 represents an ARP reply.

e Sender hardware address—Hardware address of the device sending the message.
o Sender protocol address—Protocol address of the device sending the message.
o  Target hardware address—Hardware address of the device to which the message is being sent.

o Target protocol address—Protocol address of the device to which the message is being sent.

ARP operating mechanism

As shown in Figure 218, Host A and Host B are on the same subnet. Host A sends a packet to Host B as

follows:

1. Host A looks through its ARP table for an ARP entry for Host B. If one entry is found, Host A uses
the MAC address in the entry to encapsulate the IP packet into a data link layer frame. Then Host
A sends the frame to Host B.
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2. If Host A finds no entry for Host B, Host A buffers the packet and broadcasts an ARP request. The
payload of the ARP request comprises the following information:

o Sender IP address and sender MAC address—Host A's IP address and MAC address.
o Target IP address—Host B's IP address.
o Target MAC address—An all-zero MAC address.

All hosts on this subnet can receive the broadcast request, but only the requested host (Host B)
processes the request.

3. Host B compares its own IP address with the target IP address in the ARP request. If they are the
same, Host B:

a. Adds the sender IP address and sender MAC address into its ARP table.
b. Encapsulates its MAC address into an ARP reply.
c. Unicasts the ARP reply to Host A.
4.  After receiving the ARP reply, Host A:
a. Adds the MAC address of Host B into its ARP table.
b. Encapsulates the MAC address into the packet and sends the packet to Host B.

Figure 218 ARP address resolution process

Host A Host B
192.168.1.1 192.168.1.2
0002-6779-0f4c 00a0-2470-febd
A
Sender MAC Sender IP Target MAC Target IP
address address address

address
0002-6779-0f4c 192.168.1.1 0000-0000-0000 192.168.1.2

Sender MAC Sender IP Target MAC Target IP
address address address address
00a0-2470-febd 192.168.1.2 0002-6779-0f4c 192.168.1.1

If Host A and Host B are on different subnets, Host A sends a packet to Host B, as follows:

1. Host A broadcasts an ARP request o the gateway. The target IP address in the ARP request is the
IP address of the gateway.

The gateway responds with its MAC address in an ARP reply to Host A.

Host A uses the gateway's MAC address to encapsulate the packet, and then sends the packet to
the gateway.

4. If the gateway has an ARP entry for Host B, it forwards the packet to Host B directly. If not, the
gateway broadcasts an ARP request, in which the target IP address is the IP address of Host B.

5.  After the gateway gets the MAC address of Host B, it sends the packet to Host B.

ARP table

An ARP table stores dynamic and static ARP entries.
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Dynamic ARP entry

ARP automatically creates and updates dynamic entries. A dynamic ARP entry is removed when its aging
timer expires or the output interface goes down. In addition, a dynamic ARP entry can be overwritten by
a static ARP entry.

Static ARP entry

A static ARP entry is manually configured and maintained. It does not age out and cannot be overwritten
by any dynamic ARP entry.

Static ARP entries protect communication between devices, because attack packets cannot modify the
[P-to-MAC mapping in a static ARP entry.

Gratuitous ARP

In a gratuitous ARP packet, the sender IP address and the target IP address are the IP address of the
sending device, the sender MAC address is the MAC address of the sending device, and the target MAC
address is the broadcast address ff:ff:f:f:ff:ff.

A device sends a gratuitous ARP packet for either of the following purposes:

e Determine whether its IP address is already used by another device. If the IP address is already used,
the device is informed of the conflict by an ARP reply.

e Inform other devices of a MAC address change.
Gratuitous ARP packet learning

This feature enables a device to create or update ARP entries by using the sender IP and MAC addresses
in received gratuitous ARP packets.

When this feature is disabled, the device uses the received gratuitous ARP packets to update existing ARP
entries only.

Contiguring ARP entries
Displaying ARP entries

From the navigation tree, select Network > ARP Management. The default ARP Table page appears, as
shown in Figure 219.

This page displays all ARP entries.
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Figure 219 ARP Table configuration page

Gratutous ARP

IP Address = | Search | | advanced Search

= IP Address MALC Address WVLAN ID Paort Type Operation
[ 169.254.21.139 001b-2188-86fF 1 Ethernet1/0WZ3 Dynamic EI
Add Del Selected Delete Static and Dynamic Delete Static Delete Dynamic
Refresh

Creating a static ARP entry

1. From the navigation tree, select Network > ARP Management.
The default ARP Table page appears, as shown in Figure 219.
2. Click Add.

The New Static ARP Entry page appears.
Figure 220 Add a static ARP entry

Gratuitous ARF

Mlesy Static ARP Entry

IP Address: *

MAC Address: FiExarmple: 0010-dc28-a4e9)
] Advanced Options

WLAMN ID: (1-4094)

Fort:

[terms marked with an asterisk™) are required

Apply Back

3. Configure the static ARP entry as described in Table 80.
4. Click Apply.

Table 80 Configuration items

ltem Description
IP Address Enter an IP address for the static ARP entry.
MAC Address Enter a MAC address for the static ARP entry.

VLAN ID Enter a VLAN ID and specify a port for the static ARP entry.

Advanced @ IMPORTANT:
Options Port

The VLAN ID must be the ID of the VLAN that has already been created, and the port
must belong to the VLAN. The corresponding VLAN interface must have been created.
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Removing ARP entries

1. From the navigation tree, select Network > ARP Management.
The default ARP Table page appears, as shown in Figure 219.
2.  Remove ARP entries:
o To remove specific ARP entries, select the boxes of target ARP entries, and click Del Selected.
o To remove all static and dynamic ARP entries, click Delete Static and Dynamic.
o To remove all static ARP entries, click Delete Static.

o To remove all dynamic ARP entries, click Delete Dynamic.

Contiguring gratuitous ARP

1. From the navigation tree, select Network > ARP Management.
2. Click the Gratuitous ARP tab.

Figure 221 Gratuitous Configuring ARP page

ARF Table

Gratuitous ARP
[] Disahle gratuitous ARP packets learning function

[] Send gratuitous ARP packets when receiving ARP requests from another network segment
Apply

3. Configure gratuitous ARP as described in Table 81.
4. Click Apply.

Table 81 Configuration items

ltem Description
Disable gratuitous ARP packets Disable learning of ARP entries from gratuitous ARP packets.
learning function Gratuitous ARP packet learning is enabled by default.

Enable the device to send gratuitous ARP packets upon receiving ARP

Send gratuitous ARP packets when requests from another network segment.

receiving ARP requests from another

network segment By default, the device does not send gratuitous ARP packets upon

receiving ARP requests from another network segment.

Static ARP configuration example

Network Requirements

As shown in Figure 222, hosts are connected to Switch A, and Switch A is connected to Router B through

Ethernet 1/0/1 in VLAN 100.
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To ensure secure communications between Switch A and Router B, configure a static ARP entry on Switch
A for Router B.

Figure 222 Network diagram

Router B

192.168.1.1/24
00e0-fc01-0000

Eth1/0/1
VLAN 100

Switch A

2

Configuring Switch A
1.  Create VLAN 100:

a. From the navigation tree, select Network > VLAN.
b. Click the Add tab.

c. Enter 100 for VLAN ID.

d. Click Create.

Figure 223 Creating VLAN 100

Select VLAR Fart Detail Detail oo iy WLAR Mo dify Port Remaowe
Create:
YLAN IDs: 100 | Example:3, 510
Create
[ Descriptian
1 WLAR 0001

Modify VLARM description (Mote: you can do this later on the Modify VLAN page)
modify the description ofthe selected WLAN:
In} Description

| |(1-32 Chars.)

2.  Add Ethernet 1/0/1 to VLAN 100:
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Click the Modify Port tab.

Select interface Ethernet 1/0/1 in the Select Ports field.

Select the Untagged option in the Select membership type field.
Enter 100 for VLAN IDs.

e. Click Apply.
A configuration process dialog box appears.

o o a

o

f.  After the configuration process is complete, click Close.

Figure 224 Adding Ethernet 1/0/1 to VLAN 100

Select VLAN Create Port Detail Detail Modify WVLAN Remove

Select Ports

o N Y Y Y Y 191026 Swich .
. Not avaliable for selection

Select All Select None

Select membership type:
[C] Untagged ® Tagged @ Not A Member Link Type @ PviD

Enter VLAN IDs to which the port is to be assigned:

WLAN IDs: 100 Example: 1,3,5-10

Selected ports:

Untagged Membership
Eth1/0/1

Apphy Cancel

Create VLAN-interface 100:

a. From the navigation tree, select Network > VLAN Interface.
Click the Create tab.

Enter 100 for VLAN ID.

Select the Configure Primary IPv4 Address box.

o

Select the Manual option.

Enter 192.168.1.2 for IPv4 Address.

Enter 24 or 255.255.255.0 for Mask Length.
Click Apply.

=@ ™9 oo

254



Figure 225 Creating VLAN-interface 100

Summary b ondifyy Remove

Input a YLAM 1D

100 { 1-4094)

Configure Prirmary [Pwd Address
) DHCP BOOTR ® Manual

IPvd Address|192.168.1.2 Mask Length|255.255.255.0

O Configure IPvE Link Local Address
Auto Manual

IPvE Address: |

Cancel

Create a static ARP entry:

a. From the navigation tree, select Network > ARP Management.
The default ARP Table page appears.
Click Add.

Enter 192.168.1.1 for IP Address.

Enter 00e0-fc01-0000 for MAC Address.
Select the Advanced Options box.

Enter 100 for VLAN ID.

Select Ethernet1/0/1 for Port.

Click Apply.

Figure 226 Creating a static ARP entry

s

@ ™= 0o oo

Gratuitous ARF

Mew Static ARP Entry

IP Address: 192.168.11 *

MAC Address: 00e0-fc01-0000 *(Example: 0010-dc28-ade9)
Advanced Options

WLAM 1D: 100 (1-4094)

Port: Ethernet1/0/1 v

ltems marked with an asterisk(*) are required

Apply Back
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Configuring ARP attack protection

Overview

Although ARP is easy to implement, it provides no security mechanism and is vulnerable to network
attacks. The ARP detection feature enables access devices to block ARP packets from unauthorized clients
to prevent user spoofing and gateway spoofing attacks.

ARP detection provides user validity check and ARP packet validity check.

User validity check

This feature does not check ARP packets received from ARP trusted ports, but it checks ARP packets from
ARP untrusted ports.

Upon receiving an ARP packet from an ARP untrusted interface, this feature compares the sender IP and
MAC addresses against the DHCP snooping entries and 802.1X security entries. If a match is found from
those entries, the ARP packet is considered valid and is forwarded. If no match is found, the ARP packet
is considered invalid and is discarded.

ARP packet validity check

This feature does not check ARP packets received from ARP trusted ports. It checks ARP packets received
from ARP untrusted ports based on the following objects:

e src-mac—Checks whether the sender MAC address in the message body is identical to the source
MAC address in the Ethernet header. If they are identical, the packet is forwarded. Otherwise, the
packet is discarded.

e dst-mac—Checks the target MAC address of ARP replies. If the target MAC address is all-zero,
all-one, or inconsistent with the destination MAC address in the Ethernet header, the packet is
considered invalid and discarded.

o ip—Checks the sender and target IP addresses of ARP replies, and the sender IP address of ARP
requests. All-one or multicast IP addresses are considered invalid and the corresponding packets
are discarded.

Contiguring ARP detection

To check user validity, at least one among DHCP snooping entries and 802.1X security entries is
available. Otherwise, all ARP packets received from ARP untrusted ports are discarded.

1. From the navigation tree, select Network > ARP Anti-Attack.
The default ARP Detection page appears.
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Figure 227 ARP detection configuration page

VLAM Settings Trusted Ports

----- Enabled VLANs- —--Disabled VLANs —Trusted Ports-— —--Untrusted Portg-—- =

1 Ethernet1/0/1

100 Ethernet1/0/2

- - Ethernet1/0/3
Ethernet1/0/4

Ethernet1/0/2

Ethernet1/0/6

Ethernet1/0/7

Ethernet1/0/8

Ethernet1/0/9 i

P ==

ARP Packet Validity Check
Discard the ARP packet whose sender MAC address is different from the source MAC address in the Ethernet header

Discard the ARP packet whose target MAC address is all Os, all 1s, orinconsistent with the destination MAC address in the Ethernet

header

Discard the ARP requestwhose source IP address is all 0s, all 15, or a multicast address, and discard the ARP reply whose source and
destination IP addresses are all Os, all 15, or multicast addresses

Apply

2. Configure ARP detection as described in Table 82.

3. Click Apply.

Table 82 Configuration items

ltem

Description

VLAN Settings

Select VLANs on which ARP detection is to be enabled.

To add VLANSs to the Enabled VLANGs list, select one or multiple VLANs from the Disabled
VLANS list and click the << button.

To remove VLANSs from the Enabled VLANS list, select one or multiple VLANSs from the list
and click the >> button.

Trusted Ports

Select trusted ports and untrusted ports.

To add ports to the Trusted Ports list, select one or multiple ports from the Untrusted Ports list
and click the << button.

To remove ports from the Trusted Ports list, select one or multiple ports from the list and click
the >> button.

ARP Packet
Validity Check

Select ARP packet validity check modes:

o Discard the ARP packet whose sender MAC address is different from the source MAC
address in the Ethernet header.

e Discard the ARP packet whose target MAC address is all Os, all Ts, or inconsistent with
the destination MAC address in the Ethernet header.

o Discard the ARP request whose sender IP address is all 1s or a multicast address, and
discard the ARP reply whose sender and target IP addresses are all 1s or multicast
addresses.

If none is selected, the system does not check the validity of ARP packets.

If both ARP packet validity check and user validity check are enabled, the system performs
the former first, and then the latter.
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Configuring IGMP snooping

Overview

IGMP snooping runs on a Layer 2 switch as a multicast constraining mechanism to improve multicast
forwarding efficiency. It creates Layer 2 multicast forwarding entries from IGMP packets that are
exchanged between the hosts and the router.

As shown in Figure 228, when IGMP snooping is not enabled, the Layer 2 switch floods multicast packets
to all hosts. When IGMP snooping is enabled, the Layer 2 switch forwards multicast packets of known
multicast groups to only the receivers of the multicast groups.

Figure 228 Multicast forwarding before and after IGMP snooping is enabled
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Multicast packet transmission
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|
A\ |
i
|
|
|
|
|
|
|
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|
|

———» Multicast packets

Basic IGMP snooping concepts

This section lists the basic IGMP snooping concepts.
IGMP snooping related ports

As shown in Figure 229, IGMP snooping runs on Switch A and Switch B, Host A and Host C are receivers
in a multicast group.
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Figure 229 IGMP snooping related ports
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The following describes the ports involved in IGMP snooping:

e Router port—Layer 3 multicast device-side port. Layer 3 multicast devices include designated
routers and IGMP queriers. In Figure 229, Ethernet 1/0/1 of Switch A and Ethernet 1/0/1 of
Switch B are router ports. A switch records all its local router ports in its router port list.

Do not confuse the "router port" in IGMP snooping with the "routed interface" commonly known as
the "Layer 3 interface." The router port in IGMP snooping is the Layer 2 interface.

e Member port—Multicast receiverside port. In Figure 229, Ethernet 1/0/2 and Ethernet 1/0/3 of
Switch A and Ethernet 1/0/2 of Switch B are member ports. A switch records all its member ports
in the IGMP snooping forwarding table.

Unless otherwise specified, router ports and member ports in this document include both dynamic and
static ports.

NOTE:

When IGMP snooping is enabled, all ports that receive PIM hello messages or IGMP general queries with
the source addresses other than 0.0.0.0 are considered dynamic router poris.

Aging timers for dynamic ports in IGMP snooping

Message received Action after the timer

Timer Description before the timer expires expires

When a port receives an IGMP

general query with the source IGMP general query with

Dynamic address other than 0.0.0.0 or PIM The switch removes this
. the source address other .
router port hello message, the switch starts or port from its router port
L S than 0.0.0.0 or PIM hello 7
aging timer resets an aging timer for the port. list.

When the timer expires, the message.

dynamic router port ages out.
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Message received Action after the timer

Timer Description before the timer expires expires

When a port dynamically joins a The switch removes this

Dynamic multicast group, ihe' switch starts . port from the IGMP
member port  or resets an aging timer for the IGMP membership report. snooping forwardin
aging timer port. When the timer expires, the Ping 9

) table.
dynamic member port ages out. able

NOTE:
In IGMP snooping, only dynamic ports age out.

How IGMP snooping works

The ports in this section are dynamic ports.

IGMP messages include general query, IGMP report, and leave message. An IGMP snooping-enabled
switch performs differently depending on the message.

General query

The IGMP querier periodically sends IGMP general queries to all hosts and routers on the local subnet to

determine whether any active multicast group members exist on the subnet. The destination address of
IGMP general queries is 224.0.0.1.

After receiving an IGMP general query, the switch forwards the query through all ports in the VLAN
except the receiving port. The switch also performs one of the following actions:

o Ifthe receiving port is a dynamic router port in the router port list, the switch restarts the aging timer
for the port.

o Ifthe receiving port is not in the router port list, the switch adds the port as a dynamic router port into
the router port list and starts an aging timer for the port.

IGMP report
A host sends an IGMP report to the IGMP querier for the following purposes:

e Responds to IGMP queries if the host is a multicast group member.

e Applies for a multicast group membership.

After receiving an IGMP report, the switch forwards it through all the router ports in the VLAN, resolves
the address of the reported multicast group, and performs one of the following actions:

e If no forwarding entry matches the group address, the switch creates a forwarding entry for the
group, adds the receiving port as a dynamic member port to the forwarding entry, and starts an
aging timer for the port.

e If a forwarding entry matches the group address, but the receiving port is not in the forwarding
entry for the group, the switch adds the port as a dynamic member port to the forwarding entry, and
starts an aging timer for the port.

o If a forwarding entry matches the group address and the receiving port is in the forwarding entry
for the group, the switch restarts the aging timer for the port.

A switch does not forward an IGMP report through a non-router port. If the switch forwards a report
message through a member port, the IGMP report suppression mechanism running on hosts causes all
attached hosts that monitor the reported multicast address to suppress their own reports. In this case, the
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switch cannot determine whether the reported multicast group still has active members attached to that
port.

Leave message

An IGMPv1 host silently leaves a multicast group and the switch is not notified of the leaving. However,
because the host stops sending IGMP reports as soon as it leaves the multicast group, the switch removes
the port that connects to the host from the forwarding entry for the multicast group when the aging timer
for the port expires.

An IGMPv2 or IGMPv3 host sends an IGMP leave message to the multicast router when it leaves a
multicast group.

When the switch receives an IGMP leave message on a dynamic member port, the switch first examines
whether a forwarding entry matches the group address in the message, and, if a match is found, whether
the forwarding entry for the group contains the dynamic member port.

o If no forwarding entry matches the group address, or if the forwarding entry does not contain the
port, the switch directly discards the IGMP leave message.

e If a forwarding entry matches the group address and the forwarding entry contains the port, the
switch forwards the leave message to all router ports in the VLAN. Because the switch does not
know whether any other hosts attached to the port are still listening to that group address, the switch
does not immediately remove the port from the forwarding entry for that group. Instead, it restarts
the aging timer for the port.

After receiving the IGMP leave message, the IGMP querier resolves the multicast group address in the
message and sends an IGMP group-specific query to the multicast group through the port that received
the leave message. After receiving the IGMP group-specific query, the switch forwards it through all its
router ports in the VLAN and all member ports of the multicast group. The switch also performs one of the
following actions for the port that received the IGMP leave message:

o Ifthe port (assuming that it is a dynamic member port) receives an IGMP report in response to the
group-specific query before its aging timer expires, it means that some host attached to the port is
receiving or expecting fo receive multicast data for the multicast group. The switch restarts the aging
timer for the port.

o If the port receives no IGMP report in response to the group-specific query before its aging timer
expires, it means that no hosts attached to the port are still listening to that group address. The
switch removes the port from the forwarding entry for the multicast group when the aging timer
expires.

Protocols and standards

RFC 4541, Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener
Discovery (MLD) Snooping Switches

Recommended configuration procedure

Step Remarks

1. Enabling IGMP Required.
snooping globally Disabled by default.
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Step

Remarks

2. Configuring IGMP
snooping in a VLAN

Required.

Enable IGMP snooping in the VLAN and configure the IGMP snooping version
and querier feature.

By default, IGMP snooping is disabled in a VLAN.

When you enable IGMP snooping, follow these guidelines:

e Enable IGMP snooping globally before you enable it for a VLAN.

o IGMP snooping for a VLAN takes effect only on the member poris in that
VLAN.

3. Configuring IGMP
snooping port
functions

Optional.

Configure the maximum number of multicast groups and fast-leave processing on

a port of the specified VLAN.

When you configure IGMP snooping port functions, follow these guidelines:

o Before you enable IGMP snooping on a port, enable multicast routing or
IGMP snooping globally.

e To make IGMP snooping effective on a port of a VLAN, enable IGMP
snooping for the VLAN first.

4. Displaying IGMP
snooping multicast
forwarding entries

Optional.

Enabling IGMP snooping globally

1. From the navigation tree, select Network > IGMP snooping.
2. Click Enable for IGMP snooping.

3. Click Apply.

Figure 230 Enabling IGMP snooping globally
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+show Entries
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Configuring IGMP snooping in a VLAN

From the navigation tree, select Network > IGMP snooping.
Click the E icon for the VLAN.

Figure 231 Configuring IGMP snooping in a VLAN

Advanced

YLAN Configuration

WLAM ID: 1

IGMP Snooping: ) Enable @ Disable
Version: @2 3
Quierier; Enable (@ Dizable
Cluery Interval:

General Query Source IP:

Special Query Source IP:

*Seconds (2-300, Default = 60)
*IP Address (Default =0.0.0.0)

*IP Address (Default=0.0.0.0)

3.
4.

ltems marked with an asterisk(*) are required

Apply Cancel

Configure the parameters as described in Table 83.
Click Apply.

Table 83 Configuration items

ltem

Description

IGMP snooping

Enable or disable IGMP snooping in the VLAN.

here.

Version

The default setting is IGMPv2.

By configuring an IGMP snooping version, you actually configure the versions of

IGMP messages that IGMP snooping can process.

e IGMPv2 snooping can process IGMPv1 and IGMPv2 messages, but it floods
IGMPv3 messages in the VLAN instead of processing them.

e IGMPv3 snooping can process IGMPv1, IGMPv2, and IGMPv3 messages.

@ IMPORTANT:

If you change IGMPv3 snooping to IGMPv2 snooping, the system clears all IGMP

snooping forwarding entries that are dynamically added.
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ltem Description

Enable or disable the IGMP snooping querier function.

On an IP multicast network that runs IGMP, a Layer 3 device acts as an IGMP
querier to send IGMP queries and establish and maintain multicast forwarding
entries, ensuring correct multicast traffic forwarding at the network layer.

Querier On a network without Layer 3 multicast devices, IGMP querier cannot work
because a Layer 2 device does not support IGMP. To address this issue, you can
enable IGMP snooping querier on a Layer 2 device so that the device can
generate and maintain multicast forwarding entries at the data link layer,
providing IGMP querier functions.

Query interval Configure the IGMP query interval.

General Query Source IP Specify the source IP address of general queries.

Special Query Source IP Specify the source IP address of group-specific queries.

Contiguring IGMP snooping port tunctions

1. From the navigation tree, select Network > IGMP snooping.
2. Click the Advanced tab.

Figure 232 Configuring IGMP snooping port functions

Basic
Fort Configuration
Port: Flease select a port »
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Multicast Group Limit: (1-259)
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Apply
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WLAM D Multicast Group Limit Fast Leave Operation

3. Configure the parameters as described in Table 84.
4. Click Apply.
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Table 84 Configuration items

ltem Description

Port

Select the port on which advanced IGMP snooping features will be configured. The port
can be an Ethernet port or Layer 2 aggregate interface.

After a port is selected, advanced features configured on this port are displayed at the
lower part of this page.

QTP
The advanced IGMP snooping configurations on a Layer 2 aggregate interface do not
interfere with configurations on its member ports, nor do they participate in aggregation

calculations. The configuration on a member port of the aggregate group does not take
effect until the port leaves the aggregate group.

VLA

N D Specify the ID of the VLAN in which the port functions are to be configured.
The configurations made in a VLAN take effect on the ports only in this VLAN.

Gro

Configure the maximum number of multicast groups on a port.

With this feature, you can limit multicast traffic on the port.

@ IMPORTANT:

If the number of multicast groups on a port exceeds the limit that you are sefting, the system
removes all the forwarding entries related to that port from the IGMP snooping forwarding
table. The receiver hosts attached to that port can join multicast groups again before the
number of multicast groups on the port reaches the limit.

up Limit

Fast

Enable or disable fastleave processing on the port.

When a port that is enabled with the IGMP snooping fast-leave processing feature
receives an IGMP leave message, the switch immediately removes that port from the
forwarding entry for the multicast group specified in the message. When the switch
receives IGMP group-specific queries for that multicast group, it does not forward them to
that port.

Leave

You can enable IGMP snooping fast-leave processing on poris to save bandwidth and
resources.

Displaying IGMP snooping multicast forwarding

entries

From the navigation tree, select Network > IGMP snooping.

Click Show Entries to display information about IGMP snooping multicast forwarding entries.
Figure 233 Displaying entry information

—Show Entries

= YLAN ID v |1 Search | sdvanced Search
WLAR D Source Group Cperation
100 nooao 2241141 .

To display detailed information about an entry, click the “ icon for the entry.
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Figure 234 Displaying detailed information about the entry

Advanced
Entry Details
YLAM D 100
Source Address: 0.0.0.0
Group Address: 224111
Router Port(s): Ethernet1/0/1
Member Port{s): Ethernet1/0/3
Back
Table 85 Field description
Field Description
VLAN ID ID of the VLAN to which the entry belongs.
Source Address Multicast source address. If no multicast sources are specified, this field displays
0.0.0.0.
Group Address Multicast group address.
Router Port(s) All router ports.
Member Port(s) All member ports.

IGMP snooping configuration example

Network requirements

As shown in Figure 235, IGMPv2 runs on Router A and IGMPv2 snooping runs on Switch A. Router A
acts as the IGMP querier.

Perform the configuration so Host A can receive the multicast data addressed to the multicast group
224.1.1.1.

Figure 235 Network diagram

VLAN 100

1::1/64

Eth1/0/1
2001::1/64 Eth1/0/1

Eth1/0/2

1::2/64 Eth1/0/3

Switch A Host A
Source MLD querier Receiver

Router A
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Configuration procedure

Configuring Router A

Enable IP multicast routing globally, enable PIM-DM on each interface, and enable IGMP on Ethernet
1/0/1. (Details not shown.)

Configuring Switch A
1. Create VLAN 100:

a. From the navigation tree, select Network > VLAN.
b. Click the Create tab.

c. Enter 100 as the VLAN ID.

d. Click Apply.

Figure 236 Creating VLAN 100

Select WLAN Fart Detail Ditail v ify WA Madify Part Remove
Create:
WLAM (D 100 Example:3, 5-10
Create
D Description
1 WLAR 0001

Modify VLAN description (Mote: you can do this [ater on the Modify VLAN page)
Wodify the description of the selected WLAN:
1D Description

{1-32 Charsg)

2. Assign Ethernet 1/0/1 through Ethernet 1/0/3 to VLAN 100:
a. Click the Modify Port tab.
b. Select Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3 in the Select Ports area.
c. Select Untagged for Select membership type.
d. Enter 100 as the VLAN ID.
e. Click Apply.
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Figure 237 Assigning ports to the VLAN

Select VLAN Create Port Detail Detail Modify VLAN Remaove

Select Ports

BUUTBUTG UUsTE

Select All SelectNone -Not avaliable for selection

Select membership type:
@ Untagged ©) Tagged ) Mot A Member ) Link Type @ PVID

Enter VLAN 1Ds to which the portis to be assigned:

VLAN IDs: 100 Example: 1,3,5-10

Selected ports:

Untagged Membership
Eth1/0/1-Eth1/0/3

Apply Cancel

Enable IGMP snooping globally:

a. From the navigation tree, select Network > IGMP snooping.
b. Select Enable.

c. Click Apply.

Figure 238 Enabling IGMP snooping globally

Advanced

| IGMP Snooping: & Enahle O Disable Apply

WLAM Configuration

k. WLAN 1D ¥ | Search | advanced Search

|GMP . Cirop . Cluery . .
WLAR 1D SrEERing Wersion Ul Gluerier Interval (Sec) General Query Source [P Special Gluery Source P QOperation
1 Digabled 2 Digabled Dizabled G0 0.0.0.0 0.0.0.0
100 Disabled 2 Disabled Disabled 60 0.0.0.0 0.0.00 E
+5how Entries

Enable IGMP snooping for VLAN 100:
a. Click the E icon for VLAN 100.
b. Select Enable for IGMP snooping.
c. Select 2 for Version.

d. Click Apply.
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Figure 239 Configuring IGMP snooping in VLAN 100

Advanced

YLAM Configuratian

WLAN 1D 100

IGMP Snooping: @ Enable i©) Disable

Version: @ 2 03

Querier: 7 Enable @ Disable

Query Interval: &0 *Seconds (2-300, Default = 60)
General Query Source |P: 0.0.0.0 *|P Address (Default = 0.0.0.0)
Special Query Source IP: 0.0.00 *IP Address (Default=0.0.0.0)

[tems marked with an asterisk(*) are required
Apply Cancel

Verifying the configuration

From the navigation tree, select Network > IGMP snooping.

2. Click Show Entries in the basic VLAN configuration page to display information about IGMP
snooping multicast forwarding entries.

Figure 240 Displaying IGMP snooping multicast forwarding entries

= Show Entries

= WLANID v | Search | advanced Search

YLAMN 1D Source Group Operation
100 0.0.0.0 224111 e

3. Clickthe " icon for the multicast entry (0.0.0.0, 224.1.1.1) to display detailed information about
this entry.

Figure 241 Displaying detailed information about the entry

Advanced
Entry Details
VLAM 1D 100
Source Address: 0.0.0.0
Group Address: 224111
Router Port(s): Ethernet1/0/1
Member Paort(s): Ethernet1/0/3

Back
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The output shows that Ethernet 1/0/3 of Switch A is listening to the multicast streams destined for
multicast group 224.1.1.1.
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Configuring MLD snooping

Overview

MLD snooping runs on a Layer 2 switch as an IPvé multicast constraining mechanism to improve multicast
forwarding efficiency. It creates Layer 2 multicast forwarding entries from MLD messages that are
exchanged between the hosts and the router.

As shown in Figure 242, when MLD snooping is not enabled, the Layer 2 switch floods IPvé multicast
packets to all hosts. When MLD snooping is enabled, the Layer 2 switch forwards multicast packets of
known IPv6 multicast groups to only the receivers of the multicast groups.

Figure 242 IPv6 multicast forwarding before and after MLD snooping is enabled

IPv6 multicast packet transmission
without MLD Snooping

‘% Multicast router

Source

IPv6 multicast packet transmission
when MLD Snooping runs

‘ﬁ Multicast router

Source

Layer 2 switch Layer 2 switch

T X

Host A Host C
Receiver Receiver

Host B

S

Host A Host C
Receiver Receiver

Host B

|
|
|
|
|
|
|
|
|
|
|
|
A\ |
|
|
|
|
|
|
|
|
|
|
|

————» |Pv6 multicast packets

Basic MLD snooping concepts

This section lists the basic MLD snooping concepts.
MLD snooping related ports

As shown in Figure 243, MLD snooping runs on Switch A and Switch B. Host A and Host C are receivers
in an IPv6 multicast group.
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Figure 243 MLD snooping related ports

Receiver

Router A Switch A

Eth1/0/1
O

Receiver
Source Eth1/0/2
[ ]

Switch B

(@) Router port
O Member port

— > |Pv6 multicast packets

Host D

The following describes the ports involved in MLD snooping:

e Router port—Layer 3 multicast device-side port. Layer 3 multicast devices include designated
routers and MLD queriers. As shown in Figure 243, Ethernet 1/0/1 of Switch A and Ethernet
1/0/1 of Switch B are router ports. A switch records all its local router ports in its router port list.

Do not confuse the "router port" in MLD snooping with the "routed interface" commonly known as
the "Layer 3 interface." The router port in MLD snooping is a Layer 2 interface.

e Member port—Multicast receiver-side port. As shown in Figure 243, Ethernet 1/0/2 and Ethernet
1/0/3 of Switch A and Ethernet 1/0/2 of Switch B are member ports. A switch records all local
member ports in its MLD snooping forwarding table.

Unless otherwise specified, router ports and member ports in this document include both dynamic and
static ports.

NOTE:

When MLD snooping is enabled, all ports that receive IPvé PIM hello messages or MLD general queries
with source addresses other than 0::0 are considered dynamic router ports.

Aging timers for dynamic ports in MLD snooping

Message received
Timer Description before the timer
expires

Action after the timer
expires

When a port receives an MLD

general query with the source

address other than 0::0 or IPv6 The switch removes this

PIM hello message, the switch the source address ofher ort from its router port
9e, e =¥ than 0:0 or IPv6 PIM P P

starts or resets an aging timer. hello message list.

When the timer expires, the ge:

dynamic router port ages out.

MLD general query with
Dynamic router
port aging timer
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Message received
Timer Description before the timer
expires

Action after the timer
expires

When a port dynamically joins
an IPv6 multicast group, the The switch removes this
Dynamic member  switch starts or resets an aging port from the MLD
port aging timer timer for the port. When the snooping forwarding
timer expires, the dynamic table.
member port ages out.

MLD membership report.

NOTE:

In MLD snooping, only dynamic ports age out.

How MLD snooping works

The ports in this section are dynamic ports.

MLD messages include general query, MLD report, and done message. An MLD snooping-enabled
switch performs differently depending on the MLD message.

General query

The MLD querier periodically sends MLD general queries to all hosts and routers on the local subnet to
check whether any active IPv6 multicast group members exist on the subnet. The destination IPvé address
of MLD general queries is FFO2::1.

After receiving an MLD general query, the switch forwards the query to all ports in the VLAN except the
receiving port. The switch also performs one of the following actions:

o Ifthe receiving port is a dynamic router port in the router port list, the switch restarts the aging timer
for the router port.

o Ifthe receiving port is not in the router port list, the switch adds the port as a dynamic router port fo
the router port list and starts an aging timer for the port.

MLD report
A host sends an MLD report to the MLD querier for the following purposes:

e Responds to queries if the host is an IPvé6 multicast group member.

e Applies for an IPv6 multicast group membership.

After receiving an MLD report, the switch forwards it through all the router ports in the VLAN and resolves
the address of the reported IPvé multicast group. The switch also performs one of the following actions:

o If noforwarding entry matches the IPvé group address, the switch creates a forwarding entry for the
group, adds the receiving port as a dynamic member port to the forwarding entry, and starts an
aging timer for the port.

o Ifaforwarding entry matches the IPv6 group address, but the receiving port is not in the forwarding
entry for the group, the switch adds the port as a dynamic member port to the forwarding entry, and
starts an aging timer for the port.

o If a forwarding entry matches the IPvé group address and the receiving port is in the forwarding
entry for the group, the switch resets an aging timer for the port.

A switch does not forward an MLD report through a non-router port. If the switch forwards a report
through a member port, the MLD report suppression mechanism causes all attached hosts that monitor
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the reported IPvé multicast group address to suppress their own reports. In this case, the switch cannot
determine whether the reported IPv6 multicast group still has active members attached to that port.

Done message

When a host leaves an IPvé multicast group, the host sends an MLD done message to the multicast router.
When the switch receives an MLD done message on a member port, the switch first examines whether a
forwarding entry matches the IPvé group address in the message, and, if a match is found, determines
whether the forwarding entry contains the dynamic member port.

If no forwarding entry matches the IPvé multicast group address, or if the forwarding entry does not
contain the port, the switch directly discards the MLD done message.

If a forwarding entry matches the IPvé multicast group address and contains the port, the switch
forwards the MLD done message to all router ports in the VLAN. Because the switch does not know
whether any other hosts attached to the port are still listening to that IPvé multicast group address,
the switch does not immediately remove the port from the forwarding entry for that group. Instead,
the switch resets the aging timer for that port.

After receiving the MLD done message, the MLD querier resolves the IPv6 multicast group address in the
message and sends an MLD multicast-address-specific query to that IPvé multicast group through the port
that received the MLD done message. After receiving the MLD multicast-address-specific query, the switch
forwards it through all its router ports in the VLAN and all member ports for that IPv6 multicast group. The
switch also performs one of the following actions for the port that received the MLD done message:

If the port (assuming that it is a dynamic member port) receives any MLD report in response fo the
MLD multicast-address-specific query before its aging timer expires, it means that some host
attached to the port is receiving or expecting to receive IPv6 multicast data for that IPvé multicast
group. The switch resets the aging timer for the port.

If the port receives no MLD report in response to the MLD multicast-address-specific query before its
aging timer expires, it means that no hosts attached to the port are still monitoring that IPvé
multicast group address. The switch removes the port from the forwarding entry for the IPv6
multicast group when the aging timer expires.

Protocols and standards

RFC 4541, Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener
Discovery (MLD) Snooping Switches

Recommended configuration procedure

Step Remarks
1. Enabling MLD snooping Required.
globally Disabled by default.
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Step

Remarks

2. Configuring MLD snooping in

a VLIAN

Required.

Enable MLD snooping in the VLAN and configure the MLD snooping
version and querier.

By default, MLD snooping is disabled in a VLAN.

When you enable MLD snooping, follow these guidelines:
e Enable MLD snooping globally before you enable it for a VLAN.

e MLD snooping for a VLAN takes effect only on the member ports in
that VLAN.

3. Configuring MLD snooping
port functions

Optional.

Configure the maximum number of IPv6 multicast groups and fastleave
processing on a port of the specified VLAN.

When you configure MLD snooping port functions, follow these
guidelines:

e Enable MLD snooping globally before you enable it on a port.

e MLD snooping enabled on a port takes effect only after MLD
snooping is enabled for the VLAN.

4. Displaying MLD snooping
multicast forwarding entries

Optional.

Enabling MLD snooping globally

1. Select Network > MLD snooping from the navigation tree.
2. Click Enable for MLD snooping.
3. Click Apply.

Figure 244 Enabling MLD snooping globally

Advanced
MLD Snooping: () Enable @ Disable Apply
VLAM Configuration
R VLAN D v | Search | Advanced Search
WLAN ID HLD. Wersion Querier Oual_'-,-' . General Query Source Address  Special Query Source Address Operation
Snooping Interval (Sec)
1 Disabled 1 Disabled 125 FEB0:2FF:FFFF:FEOO:1 FE&0:2FF.FFFF.FEOO:1
100 Disabled 1 Disabled 125 FEB0::2FF.FFFF:FEQD:1 FE&0::2FF.FFFF.FEQQ:1
200 Disabled 1 Disabled 125 FEB0:2FF:FFFF:FEDD:1 FE80::2FF.FFFF:FEDO:1
300 Disabled 1 Disabled 125 FEB0::2FF:FFFF:FEQD:1 FES&0::2FF.FFFF:FEDQ:1
+5how Entries
Refresh

Configuring MLD snooping in a VLAN

1. Select Network > MLD snooping from the navigation tree.
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2. Click the & icon for the VLAN.
Figure 245 Configuring MLD snooping in a VLAN

Advanced

WLAM Configuration

VLAN 1D 1

MLD Snooping: _) Enable @ Disable

Version: D) 1 2

Querier. Enable 2 Disable

Cuery Interval: *Seconds (2-300, Default = 125)

General Query Source Address: *|Pv6 linklocal address (Default = FES0::2FF:FFFF:FEQQ:1)

Special Query Source Address: *IPv6 linklocal address (Default = FES0:2FF:FFFF:FEQO:1)

ltems marked with an asterisk(*) are required
Apply Cancel

3. Configure the parameters as described in Table 86.
4. Click Apply.

Table 86 Configuration items

ltem Description
Enable or disable MLD snooping in the VLAN.

MLD snooping
You can proceed with the subsequent configurations only if Enable is selected here.
The default sefting is MLDv1.

By configuring an MLD snooping version, you actually configure the versions of MLD
messages that MLD snooping can process.
e MLDv1 snooping can process MLDv1 messages, but it floods MLDv2 messages in

Version the VLAN instead of processing them.

e MLDv2 snooping can process MLDv1 and MLDv2 messages.

(D IMPORTANT:

If you change the MLDv2 snooping to MLDv1 snooping, the system clears all MLD
snooping forwarding entries that are dynamically added.

Enable or disable the MLD snooping querier function.

In an IPv6 multicast network that runs MLD, a Layer 3 device acts as the MLD querier
to send MLD queries and establish and maintain IPvé multicast forwarding entries,
ensuring correct IPvé multicast traffic forwarding at the network layer.

Querier On an IPv6 network without Layer 3 multicast devices, MLD querier cannot work
because a Layer 2 device does not support MLD. To address this issue, you can
enable MLD snooping querier on a Layer 2 device so that the device can generate
and maintain IPv6 multicast forwarding entries at data link layer, providing MLD
querier functions.

Query interval Configure the MLD general query interval.

General Query Source

Address Specify the source IPv6 address of MLD general queries.

Special Query Source

Address

Specify the source IPv6 address of MLD multicast-address-specific queries.
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Configuring MLD snooping port functions

Select Network > MLD snooping from the navigation tree.
2. Click the Advanced tab.

Figure 246 Configuring MLD snooping port functions

Basic

Port Configuration

Paort: Please select a pot  ~

VLAM 1D: *(1-4094, example: 3,5-10) Up to 10 VLAN ranges can be specified.
Multicast Group Limit: (1-510, Default=510)

Fast Leave: _) Enable @ Disable

Iltems marked with an asterisk(*) are required

Apply
|°\ VLAN ID v | Search | advanced Search
VLAN 1D Multicast Group Limit Fast Leave Operation
Refresh

3. Configure the parameters as described in Table 87.
4. Click Apply.

Table 87 Configuration items

ltem Description

Select the port on which advanced MLD snooping features will be configured. The port
can be an Ethernet port or Layer 2 aggregate interface.

After a port is selected, advanced features configured on this port are displayed at the
lower part of this page.

Port Qe

Advanced MLD snooping features configured on a Layer 2 aggregate interface do not
interfere with configurations on its member ports, nor do they take part in aggregation
calculations. The configuration on a member port of the aggregate group does not take
effect until the port leaves the aggregate group

VIAN ID Specify the ID of the VLAN in which port functions are to be configured.
The configurations made in a VLAN take effect on the ports only in this VLAN.

Configure the maximum number of IPvé multicast groups on a port.

With this feature, you can regulate IPvé multicast traffic on the port.

Multicast Group (D IMPORTANT:

Limit When the number of IPvé multicast groups on a port exceeds the limit that you are setting,
the system deletes all the IPv6 forwarding entries related to that port from the MLD snooping
forwarding table. The receiver hosts to that port can join the IPv6 multicast groups again
before the number of IPv6 multicast groups on this port reaches the limit.
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ltem Description

Enable or disable fast-leave processing on the port.

When a port that is enabled with the MLD snooping fast-leave processing feature receives
an MLD done message, the switch immediately deletes that port from the IPvé forwarding
table entry for the multicast group specified in the message. When the switch receives
MLD multicast-address-specific queries for that multicast group, it does not forward them to
that port.

Fast Leave

You can enable MLD snooping fast-leave processing on ports to save bandwidth and
resources.

Displaying MLD snooping multicast forwarding entries

Select Network > MLD snooping from the navigation tree.

2. Click Show Entries to display information about MLD snooping multicast forwarding entries.
Table 88 Displaying entry information

—Show Entries

R YLAMID v || Search | Advanced Search
WLAR D Source Graup Operation
100 : FF1E:101 =

3. To view defailed information about an entry, click the “ icon for the entry.

Figure 247 Detailed information about an MLD snooping multicast entry

Advanced

Entry Details

WLAM ID: 100

Source Address:

Group Address: FF1E:101
Router Ports: Ethernet! 0/
Member Poris: Ethernet1 /03
Back
Table 89 Field description
Field Description
VLAN ID ID of the VLAN to which the entry belongs.

Multicast source address. If no IPvé6 multicast sources are specified, this field
Source Address

displays ::.
Group Address Multicast group address.
Router Ports All router ports.
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Field Description

Member Ports All member ports.

MLD snooping configuration example

Network requirements

As shown in Figure 248, MLDv1 runs on Router A and MLDv1 snooping runs on Switch A. Router A acts
as the MLD querier.

Perform the configuration so that Host A can receive the IPvé6 multicast packets destined for the IPvé

multicast group FF1E::101.
Figure 248 Network diagram

VLAN 100

1:1/64
Eth1/0/2 Eth1/0/1
1::2/64 2001::1/64 Eth1/0/1 Eth1/0/3
Router A Switch A Host A
Source MLD querier Receiver

Contiguration procedure

Configuring Router A

Enable IPvé6 multicast routing, assign an IPvé address to each interface, enable IPvé6 PIM-DM on each
interface, and enable MLD on Ethernet 1/0/1. (Details not shown.)

Configuring Switch A
1. Create VLAN 100:
a. Select Network > VLAN from the navigation tree.
b. Click the Create tab.
c. Enter 100 as the VLAN ID.
d. Click Apply.
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Figure 249 Creating VLAN 100

Select WLAR Fort Detail Detail fd o dify WLAR Madify Port Rermuoue
Create:
WLAN D5 100 Example:3, 510
Create
In} Cescription
1 WLAMN 0001

mModify WLAM description (Mote: you can da this later on the Modify VLA page)
Maodify the description ofthe selected WLAN:
In} Description

(1-32 Chars)

Assign Ethernet 1/0/1 through Ethernet 1/0/3 to VLAN 100:

a. Click the Modify Port tab.

b. Select Ethernet 1/0/1, Ethernet 1/0/2, and Ethernet 1/0/3 in the Select Ports area.
c. Select Untagged for Select membership type.

d. Enter 100 as the VLAN ID.

e. Click Apply.
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Figure 250 Assigning ports to VLAN 100

Select VLAM Create FPort Detail Detail Modify VLAN Remove

Select Ports

% 0 1 8 D N Y HP 191024 Swit
Lo e Lol el el = l=] ]

SelectAll SelectNone .Not avaliable for selection

Select membership type:
@ Untagged () Tagged @ NotAMember ) Link Type ) PVID

Enter VLAM IDs to which the portis to be assigned:

|VLAN IDs: 100 Example: 1,3,5-10

Selected ports:

Untagged Membership
Eth1/0/1-Eth1/0/3

Cancel

Enable MLD snooping globally:

a. Select Network > MLD snooping from the navigation tree.
b. Select Enable.

c. Click Apply.

Figure 251 Enabling MLD snooping globally

Advanced

MLD Snooping: @ Enable (©) Disable Apply

WLAN Configuration

5N WLAN ID v | Search | Advanced Search

WLAN ID MLD. Yersion CQuerier Quer}'lnt:ewal General Query Source Address Special Query Source Address Operation
Snooping (Sec)

1 Digabled 1 Dizabled 125 FEBO::2FF:FFFF:FEOD:1 FEB0::2FF:FFFF:FEQD:1

100 Dizsabled 1 Disabled 125 FEB0::2FF:FFFF:FEQ0:1 FE30:2FF:FFFF:FEQ0:1 E=

200 Dizabled 1 Dizabled 125 FEBO0::2FF:FFFF:FEQD:1 FES0:2FF.FFFF.FEDD:1 i

300 Dizsabled 1 Disabled 125 FEBO::2FF:FFFF:FE0D:1 FES80:2FF:FFFF:FEDD:1 =

“+show Entries

Refresh

Enable MLD snooping:
a. Click the B icon for VLAN 100.
b. Select Enable for MLD snooping.

c. Select 1 for Version.
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d. Click Apply.
Figure 252 Enabling MLD snooping in VLAN 100

Advanced

YLAM Configuration

WVLAN ID: 100

MLD Snoaping: @ Enable () Disable
Version: @1 B2
Querier: ) Enable @ Disable
Query Interval: 125

*Seconds (2-300, Default = 125)

General Query Source Address:  FEB0:2FF:FFFF:FEQD: *IPv6 linklocal address (Default = FES0:2FF:FFFF.FEQQ:1)

Special Query Source Address:  FE80:2FF:FFFF:FE00:1 *IPv6 linklocal address (Default = FEB0::2FF.FFFF:FE00:1)

ltems marked with an asterisk(*) are required

Apply Cancel

Verifying the configuration

Select Network > MLD snooping from the navigation tree.

2. Click Show Entries in the basic VLAN configuration page to display information about MLD
snooping multicast forwarding entries.

Figure 253 Displaying MLD snooping multicast forwarding entries

= Show Entries

= WLAMID v | Search | advanced Search

WLAM 1D Source

Group Operation

100 - FF1E:101 L)

3. Clickthe ™ icon for the multicast entry (::, FF1E::101) to display detailed information about this
entry.

Figure 254 Displaying detailed information about the entry

Advanced
Entry Details
WLAM ID: 100
Source Address:
Group Address: FF1E:1D1
Router Ports: Ethernet 70/
Mernber Pors: Ethernet] /03

Back

The output shows that Ethernet 1/0/3 of Switch A is listening to multicast streams destined for IPvé
multicast group FF1E::101.
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Configuring IPv4 and IPvé6 routing

The term "router" in this chapter refers to both routers and Layer 3 switches.

Overview

A router selects an appropriate route according to the destination address of a received packet and
forwards the packet to the next router. The last router on the path is responsible for sending the packet to
the destination host. Routing provides the path information that guides the forwarding of packets.

Routing table

A router selects optimal routes from the routing table, and sends them to the forwarding information base
(FIB) table to guide packet forwarding. Each router maintains a routing table and a FIB table.

Routes discovered by different routing protocols are available in a routing table and they can be divided
into the following categories by origin:

Direct routes—Routes discovered by data link protocols, also known as "interface routes."

Static routes—Manually configured routes. Static routes are easy to configure and require fewer
system resources. They work well in small and stable networks, but cannot adjust to network
changes, so you must manually configure the routes again whenever the network topology
changes.

Dynamic routes—Routes that are discovered dynamically by routing protocols.

Each entry in the FIB table specifies a physical interface that packets destined for a certain address
should go out to reach the next hop—the next router—or the directly connected destination.

A route entry includes the following items:

Destination IP address—Destination IP address or destination network.

Mask (IPv4)/prefix length (IPv6)—Specifies, together with the destination address, the address of
the destination network. A logical AND operation between the destination address and the
network mask/prefix length yields the address of the destination network.

Preference—Routes to the same destination might be discovered by various routing protocols or
manually configured, and routing protocols and static routes have different preferences configured.
The route with the highest preference (the smallest value) is optimal.

Outbound interface—Specifies the interface through which a matching IP packet is to be
forwarded.

Next hop—Specifies the address of the next hop router on the path.

Static route

Static routes are manually configured. If a network's topology is simple, you only need to configure static
routes for the network to work correctly.
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Static routes cannot adapt to network topology changes. If a fault or a topological change occurs in the
network, the network administrator must modify the static routes manually.

Default route

A default route is used to forward packets that do not match any specific routing entry in the routing table.

Without a default route, packets that do not match any routing entries are discarded.

You can configure default routes in the Web interface in the following ways:

e Configure an IPv4 static default route and specify both its destination IP address and mask as

0.0.0.0.

e Configure an IPv6 static default route and specify both its destination IP address and prefix as ::/0.

Displaying the IPv4 active route table

Select Network > IPv4 Routing from the navigation tree fo enter the page.

Figure 255 IPv4 active route table

Create Remuove
k. Destination v | Search | Advanced Search
Destination Mask Protocol Priority Mext Hop Interface
127.0.0.0 255.0.0.0 Direct 0 127.0.0.1 InLoopBackD
127.0.0.1 255 255 255 255 Direct 0 127.0.0.1 InLoopBackd
192.168.1.0 255255 255.0 Direct 0 192.168.1.2 Vlan-interface100
192.168.1.2 255,255 255 255 Direct 0 127.0.0.1 InLoopBackd
127.0.0.0 255.0.0.0 Direct 0 127.0.0.1 InLoopBackd
127.0.0.1 255.255 255.255 Direct 0 127.0.0.1 InLoopBackd
192.168.1.0 255.255.266.0 Direct 0 102.168.1.2 Vian-interface100
192.168.1.2 255.255 255255 Direct 0 127.0.0.1 InLoopBackd
Srecords, 159 = perpage | page 11, record 1-8 | 1 GO
Table 90 Field description

Field Description
Destination IP Address

Destination IP address and subnet mask of the IPv4 route.
Mask
Protocol Protocol that discovered the IPv4 route.

Preference value for the IPv4 route.
Preference )

The smaller the number, the higher the preference.
Next Hop Next hop IP address of the IPv4 route.
Inferface Output interface of the IPv4 route. Packets destined for the specified

network segment are sent out of the interface.
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Creating an IPv4 static route

Select Network > IPv4 Routing from the navigation tree.
2. Click the Create tab.

The page for configuring an IPv4 static route appears.

Figure 256 Creating an IPv4 static route

Summary Femove

Destination IP

Address
Mask 2 [JPreference
Mest Hop [interface

ltems marked with an asterisk(™ are required

Apply

Configured Static Route Information

Destination IP Address Mask Protocal Freference

3. Create an IPv4 static route as described in Table 91.
4. Click Apply.

Table 91 Configuration items

Mext Hop

(1-255 Default=60)

Interface

ltem

Description

Destination IP Address

Enter the destination host or network IP address in dotted decimal notation.

Enter the mask of the destination IP address.

Mask
You can enter a mask length or a mask in dotted decimal notation.

Set a preference value for the static route. The smaller the number, the higher the
preference.

Preference For example, specifying the same preference for multiple static routes to the same
destination enables load sharing on the routes. Specifying different preferences
enables route backup.

Next Hop Enter the next hop IP address in dotted decimal notation.
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ltem Description
Select the output inferface.
Interface You can select any available Layer 3 interface, for example, a virtual interface, of

the device. If you select NULL O, the destination IP address is unreachable.

Displaying the IPv6 active route table

Select Network > IPv6 Routing from the navigation tree fo enter the page.

Figure 257 IPvé6 active route table

Create Remove

Active Route Table

Fref
Destination IP Address Length  Protocal Preference Mext Hop Interface
1 128 Direct 0 1 InLaopBackl
Table 92 Field description
Field Description

Destination IP Address

Prefix Length

Destination IP address and prefix length of the IPv6 route.

Protocol Protocol that discovered the IPv6 route.
Preference value for the IPvé route.
Preference
The smaller the number, the higher the preference.
Next Hop Next hop IP address of the IPv6 route.
Output interface of the IPv6 route. Packets destined for the specified network
Interface

segment are sent out of the inferface.

Creating an IPv6 static route

1. Select Network > IPvé Routing from the navigation tree.

2. Click the Create tab.
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The page for configuring an IPv6 static route appears.

Figure 258 Creating an IPvé static route

Summary

Destination 1P
Address

Prefix Length [=F:}

Mext Hop

Remove

ltems marked with an asterisk(™) are required

Apply

Configured Static Route Information

Destination IP Address

M [CIPreference (1-255,Default=60)
Cinterface
Prefix
Length  Protocol Preference Mext Hop Interface

3. Create an IPvé static route as described in Table 93.

4. Click Apply.

Table 93 Configuration items

ltem

Description

Destination IP Address

Enter the destination host or network IP address, in the X:X::X:X format. The
128-bit destination IPvé address is a hexadecimal address with eight parts
separated by colons (:). Each part is represented by a 4-digit hexadecimal
integer.

Prefix Length

Enter or select the prefix length of the destination IPv6 address.

Set a preference value for the static route. The smaller the number, the higher the
preference.

Preference For example, specifying the same preference for multiple static routes to the same
destination enables load sharing on the routes. Specifying different priorities for
them enables route backup.

Next Hop Enter the next hop address, in the same format as the destination IP address.
Select the output interface.

Interface You can select any available Layer 3 interface, for example, a virtual interface,

of the device. If you select NULL O, the destination IPv6 address is unreachable.
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IPv4 static route configuration example

Network requirements

As shown in Figure 259, configure IPv4 static routes on Switch A, Switch B, and Switch C for any two
hosts to communicate with each other.

Figure 259 Network diagram

Vlan-int900
1.2 X 1.1.3.1/24
Host A Switch A Switch C Host C

1.1.2.2/124 1.1.3.2/124

Configuration considerations

On Switch A, configure a default route with Switch B as the next hop.

On Switch B, configure one static route with Switch A as the next hop and the other with Switch C as the
next hop.

On Switch C, configure a default route with Switch B as the next hop.

Configuration procedure

1. Configure a default route to Switch B on Switch A:
a. Select Network > IPv4 Routing from the navigation tree of Switch A.
b. Click the Create tab.
c. Enter 0.0.0.0 for Destination IP Address, 0 for Mask, and 1.1.4.2 for Next Hop.
d. Click Apply.

288



2,

Figure 260 Configuring a default route

Summary

Destination [P
Address

hfask
Mext Hop

0000

1]
1.1.42

lterns marked with an asterisk(™ are required

Apply

Configured Static Route Information

Destination IF Address

Frotocal

[JPreference
linterface

Freference Mext Hop

Configure a static route to Switch A and Switch C on Switch B:

a. Select Network > IPv4 Routing from the navigation tree of Switch B.
b. Click the Create tab.

The page for configuring a static route appears.
c. Enter 1.1.2.0 for Destination IP Address, 24 for Mask, and 1.1.4.1 for Next Hop.
d. Click Apply.
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Figure 261 Configuring a static route

Summary

Remove

Destination [P
Address

Mask

Mext Hop

1.1.2.0

24
1.1.41

lterns marked with an asterisk(™ are required

Apply

Configured Static Route Information

Destination 1P Address

Mask Praotocal

ClPreference
Clinterface

Preference Mext Hop

{1-255,Default=60)

Interface

e. Enter 1.1.3.0 for Destination IP Address, enter 24 for Mask, and enter 1.1.5.6 for Next Hop.
Click Apply.
Configure a default route to Switch B on Switch C:

f.

a.
b.

C.
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Select Network > IPv4 Routing from the navigation tree of Switch C.

Click the Create tab.

Enter 0.0.0.0 for Destination IP Address, 0 for Mask, and 1.1.5.5 for Next Hop.
Click Apply.



Figure 262 Configuring a default route

Surmary Remove

Destination IP

Address 0.0.00 i

Mask u} I* [ Preference (1-265 Default=60)
Mext Hop 1155 [interface

ltems marked with an asterisk(*) are required

Configured Static Route Information

Cestination IP Address Mask Frotocaol Freference Mext Hop Interface

Veritying the configuration

1. Display the routing table.
Enter the IPv4 route page of Switch A, Switch B, and Switch C to verify that the newly configured
static routes are displayed as active routes on the pages.

2. Ping Host C from Host A (assuming both hosts run Windows XP):
C:\Documents and Settings\Administrator>ping 1.1.3.2

Pinging 1.1.3.2 with 32 bytes of data:

Reply from 1.1.3.2: bytes=32 time=1ms TTL=128
Reply from 1.1.3.2: bytes=32 time=1lms TTL=128
Reply from 1.1.3.2: bytes=32 time=1lms TTL=128
Reply from 1.1.3.2: bytes=32 time=1ms TTL=128

Ping statistics for 1.1.3.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 1ms, Average = 1lms
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IPv6 static route configuration example

Network requirements

As shown in Figure 263, configure IPv6 static routes on Switch A, Switch B, and Switch C for any two
hosts to communicate with each other.

Figure 263 Network diagram

Host B 2::2/64

Vlan-int400

Vlan-int300

Vlan-int200 Vlan-int300
4::1/64, 5::1/64

Vlan-int100
1::1/64 ) 3::1/64
Host A 1::2/64 Switch A Switch C Host C 3::2/64

Vlan-int500

Configuration considerations

On Switch A, configure a default route with Switch B as the next hop.

On Switch B, configure one static route with Switch A as the next hop and the other with Switch C as the
next hop.

On Switch C, configure a default route with Switch B as the next hop.

Configuration procedure

1. Configure a default route to Switch B on Switch A:
a. Select Network > IPv6 Routing from the navigation tree of Switch A.
b. Click the Create tab.

c. Enter :: for Destination IP Address, select 0 from the Prefix Length list, and enter 4::2 for Next
Hop.

d. Click Apply.
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Figure 264 Configuring a default route

Surmmary Remove
Destination IP .
Address
Prefix Length ] aild [ Preference (1-245,Default=60)
Mext Hop 4:2 [interface

lterns marked with an asterisk(® are required

Configured Static Route Information

Prefix
Destination IP Address Length  Protocol Preference Mext Hop Interface

Configure a static route to Switch A and Switch C on Switch B:

a. Select Network > IPvé Routing from the navigation tree of Switch B.

b. Click the Create tab.
The page for configuring a static route appears.

c. Enter 1:: for Destination IP Address, select 64 from the Prefix Length list, and enter 4::1 for Next
Hop.

d. Click Apply.
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Figure 265 Configuring a static route

Summany Remowve
Destination IP ' .
Address -
Prefix Length B4 il [CIPreference {1-245 Default=60)
Mext Hop 41 interface

lterms marked with an asterisk{*) are reguired

Configured Static Route Information

e.

f.

Prefix
Destination IP Address Length  Protocol Preference Mext Hop Interface

Enter 3:: for Destination IP Address, select 64 from the Prefix Length list, and enter 5::1 for Next
Hop.
Click Apply.

Configure a default route to Switch B on Switch C:

a.
b.

C.

Select Network > IPv6 Routing from the navigation tree of Switch C.
Click the Create tab.

Enter :: for Destination IP Address, select O from the Prefix Length list, and enter 5::2 for Next
Hop.
Click Apply.
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Figure 266 Configuring a default route

Surmmary Remaove
Destination P l.
Address
Frefix Length 0 il [CIPreference (1-245 Default=60)
Mext Hop 52 dinterface

ltems marked with an asterisk(*) are required

Configured Static Route Information

Prefix
Destination IP Address Length  Protocol Preference Mlext Hop Interface

Veritying the configuration

1. Display the routing table.

Enter the IPv6 route page of Switch A, Switch B, and Switch C to verify that the newly configured
static routes are displayed as active routes on the pages.

2. Ping Host C from Switch A:
<SwitchA> ping ipv6 3::2
PING 3::2 : 56 data bytes, press CTRL_C to break
Reply from 3::2
bytes=56 Sequence=1 hop limit=254 time = 63 ms
Reply from 3::2
bytes=56 Sequence=2 hop limit=254 time = 62 ms
Reply from 3::2
bytes=56 Sequence=3 hop limit=254 time = 62 ms
Reply from 3::2
bytes=56 Sequence=4 hop limit=254 time = 63 ms
Reply from 3::2
bytes=56 Sequence=5 hop limit=254 time = 63 ms

--- 3::2 ping statistics ---
5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
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round-trip min/avg/max = 62/62/63 ms

Configuration guidelines

When you configure a static route, follow these guidelines:

If you do not specify the preference, the default preference will be used. Reconfiguration of the
default preference applies only to newly created static routes. The Web interface does not support
configuration of the default preference.

If you specify the next hop address first and then configure it as the IP address of a local interface,
such as a VLAN interface, the static route does not take effect.

When you specify the output interface, note the following:
o If the output interface is NULL O or a loopback interface, no next hop address is required.

o If the output interface is a broadcast interface (such as a VLAN interface), which might have
multiple next hops, you must specify the output interface and the next hop at the same time.

You can delete only IPv4/IPvé static routes on the Remove tab.
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DHCP overview

The Dynamic Host Configuration Protocol (DHCP) provides a framework to assign configuration
information to network devices.

DHCP uses the client-server model. Figure 267 shows a typical DHCP application.

A DHCP client can obtain an IP address and other configuration parameters from a DHCP server on
another subnet through a DHCP relay agent. For more information about the DHCP relay agent, see
"Configuring DHCP relay agent." You can enable the DHCP client on an interface. For more information
about the DHCP client configuration, see "Configuring VLAN interface."

Figure 267 A typical DHCP application

DHCP client  DHCP client

DHCP server
T
DHCP client DHCP client

DHCP address allocation

Allocation mechanisms

DHCP supports the following mechanisms for IP address allocation:

o Static allocation—The network administrator assigns an IP address to a client (for example, a
WWW server), and DHCP conveys the assigned address to the client.

e Automatic allocation—DHCP assigns a permanent IP address to a client.

¢ Dynamic allocation—DHCP assigns an IP address to a client for a limited period of time, which is
called a lease. Most DHCP clients obtain their addresses in this way.
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IP address allocation process

Figure 268 Dynamic IP address allocation process

DHCP client DHCP server

= =

(1) DHCP-DISCOVER

(2) DHCP-OFFER

(3) DHCP-REQUEST

(4) DHCP-ACK

The client broadcasts a DHCP-DISCOVER message to locate a DHCP server.

2. A DHCP server offers configuration parameters such as an IP address to the client in a
DHCP-OFFER message. The sending mode of the DHCP-OFFER is determined by the flag field in
the DHCP-DISCOVER message. For more information about the DHCP message format, see
"DHCP message format."

3. If several DHCP servers send offers to the client, the client accepts the first received offer, and
broadcasts it in a DHCP-REQUEST message to request the IP address formally. (IP addresses
offered by other DHCP servers can be assigned to other clients.)

4.  All DHCP servers receive the DHCP-REQUEST message, but only the server from which the client
accepts the offered IP address returns a DHCP-ACK message to the client, confirming that the IP
address has been allocated to the client, or a DHCP-NAK unicast message, denying the IP address
allocation.

o After the client receives the DHCP-ACK message, it broadcasts a gratuitous ARP packet to verify
whether the IP address assigned by the server is in use.

o Ifthe client receives no response within the specified time, the client uses this IP address.
Otherwise, the client sends a DHCP-DECLINE message to the server and requests an IP address
again.

IP address lease extension

A dynamically assigned IP address has a lease. When the lease expires, the IP address is reclaimed by
the DHCP server. To continue using the IP address, the client must extend the lease duration.

When half of the lease duration elapses, the DHCP client unicasts a DHCP-REQUEST to the DHCP server
to extend the lease. Depending on the availability of the IP address, the DHCP server returns either a
DHCP-ACK unicast confirming that the client's lease duration has been extended, or a DHCP-NAK
unicast denying the request.

If the client receives no reply, it broadcasts another DHCP-REQUEST message for lease extension when
seven eighths of the lease duration elapses. Again, depending on the availability of the IP address, the
DHCP server returns either a DHCP-ACK unicast confirming that the client's lease duration has been
extended, or a DHCP-NAK unicast denying the request.
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DHCP message format

Figure 269 shows the DHCP message format. DHCP uses some of the fields in significantly different ways.
The numbers in parentheses indicate the size of each field in bytes.

Figure 269 DHCP message format

0 7 15 23 31
op (1) htype (1) hlen (1) hops (1)

xid (4)

secs (2) flags (2)

ciaddr (4)

yiaddr (4)

siaddr (4)

giaddr (4)

chaddr (16)

sname (64)

file (128)

options (variable)

e op—Message type defined in option field. 1 = REQUEST, 2 = REPLY

e htype, hlen—Hardware address type and length of the DHCP client.

e hops—Number of relay agents a request message traveled.

o  xid—Transaction ID, a random number chosen by the client to identify an IP address allocation.

o secs—Filled in by the client, the number of seconds elapsed since the client began address
acquisition or renewal process. This field is reserved and set to 0.

o flags—The leftmost bit is defined as the BROADCAST (B) flag. If this flag is set to O, the DHCP server
sent a reply back by unicast. If this flag is set to 1, the DHCP server sent a reply back by broadcast.
The remaining bits of the flags field are reserved for future use.

o  ciaddr—Client IP address if the client has an IP address that is valid and usable. Otherwise, it is set
to zero. (The client does not use this field to request a specific IP address to lease.)

o yiaddr—"Your" (client) IP address, assigned by the server.

e siaddr—Server IP address, from which the client obtained configuration parameters.
o giaddr—(Gateway) IP address of the first relay agent a request message traveled.

e chaddr—Client hardware address.

e sname—Server host name, from which the client obtained configuration parameters.
o file—Bootfile name and path information, defined by the server to the client.

e options—Optional parameters field that is variable in length, which includes the message type,
lease duration, subnet mask, domain name server IP address, and WINS IP address.
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DHCP options

DHCP defines the message format as an extension to BOOTP for compatibility. DHCP uses the Option
field to carry information for dynamic address allocation and to provide additional configuration
information to clients.

Figure 270 DHCP option format

0

7 15

Option type Option length

Value (variable)

Common DHCP options

The following are common DHCP options:

Option 3—Router option. It specifies the gateway address.
Option 6—DNS server option. It specifies the DNS server's IP address.

Option 33— Static route option. It specifies a list of classful static routes (the destination addresses
in these static routes are classful) that a client should add into its routing table. If both Option 33
and Option 121 exist, Option 33 is ignored.

Option 51—IP address lease option.
Option 53—DHCP message type option. It identifies the type of the DHCP message.

Option 55 —Parameter request list option. It is used by a DHCP client to request specified
configuration parameters. The option includes values that correspond to the parameters requested
by the client.

Option 60— Vendor class identifier option. It is used by a DHCP client to identify its vendor, and by
a DHCP server to distinguish DHCP clients by vendor class and assign specific IP addresses to the
DHCP clients.

Option 66—TFTP server name option. It specifies a TFTP server o be assigned to the client.
Option 67 —Bootfile name option. It specifies the bootfile name to be assigned to the client.

Option 121 —Classless route option. It specifies a list of classless static routes (the destination
addresses in these static routes are classless) that the requesting client should add to its routing table.
If both Option 33 and Option 121 exist, Option 33 is ignored.

Option 150—TFTP server IP address option. It specifies the TFTP server IP address to be assigned to
the client.

For more information about DHCP options, see RFC 2132 and RFC 3442.

Option 82

Some options, such as Option 82, have no unified definitions in RFC 2132.

Option 82 is the relay agent option. It records the location information about the DHCP client. When a
DHCP relay agent or DHCP snooping device receives a client's request, it adds Option 82 to the request
message and sends it to the server.
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The administrator can use Option 82 to locate the DHCP client and further implement security control
and accounting. The DHCP server can use Option 82 to provide individual configuration policies for the
clients.

Option 82 can include up to 255 sub-options and must have one sub-option at least. Option 82 supports
two sub-options: sub-option 1 (Circuit ID) and sub-option 2 (Remote ID).

Option 82 has no unified definition. Its padding formats vary with vendors.

By default, the normal padding format is used on the device. You can specity the code type for the
sub-options as ASCII or HEX. The padding contents for sub-options in the normal padding format are as
follows:

o Sub-option 1—Padded with the VLAN ID and interface number of the interface that received the
client's request. The following figure gives its format. The value of the sub-option type is 1, and that
of the circuit ID type is O.

Figure 271 Sub-option 1 in normal padding format

0 7 15 23 31
Sub-option type (0x01) Length (0x06) Circuit ID type (0x00) Length (0x04)
VLAN ID Interface number

e Sub-option 2—Padded with the MAC address of the DHCP relay agent interface or the MAC
address of the DHCP snooping device that received the client's request. The following figure gives
its format. The value of the sub-option type is 2, and that of the remote ID type is O.

Figure 272 Sub-option 2 in normal padding format

0 7 15 23 31
Sub-option type (0x02) Length (0x08) Remote ID type (0x00) Length (0x06)

MAC Address

Protocols and standards

e RFC 2131, Dynamic Host Configuration Protocol

e RFC 2132, DHCP Options and BOOTP Vendor Extensions

o RFC 1542, Clarifications and Extensions for the Bootstrap Protocol
e RFC 3046, DHCP Relay Agent Information Option

o RFC 3442, The Classless Static Route Option for Dynamic Host Configuration Protocol (DHCP)
version 4.
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Configuring DHCP relay agent

Overview

Since the DHCP clients request IP addresses through broadcast messages, the DHCP server and clients
must be on the same subnet. Through a DHCP relay agent, DHCP clients can get IP addresses from a
DHCP server on another subnet. This feature avoids deploying a DHCP server for each subnet to

centralize management and reduce investment. Figure 273 shows a typical application of the DHCP
relay agent.

Figure 273 DHCP relay agent application

DHCP client DHCP client

DHCP relay agent

S

DHCP client DHCP client DHCP server

The DHCP server and client interact with each other in the same way regardless of whether the relay

agent exists (see "DHCP overview"). For more information about DHCP packet exchange, see "IP
address allocation process."

The following only describes steps related to the DHCP relay agent:

1. After receiving a DHCP-DISCOVER or DHCP-REQUEST broadcast message from a DHCP client,
the DHCP relay agent fills the giaddr field of the message with its IP address and forwards the
message to the designated DHCP server in unicast mode.

2.  Based on the giaddr field, the DHCP server returns an IP address and other configuration
parameters in a response.

3. The relay agent conveys the response to the client.
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Figure 274 DHCP relay agent operation

DHCP client DHCP relay agent DHCP server
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DHCP-ACK (unicast)

Recommended configuration procedure

Task

Remarks

Enabling DHCP and configuring
advanced parameters for the DHCP
relay agent

Required.
Enable DHCP globally and configure advanced DHCP parameters.
By default, global DHCP is disabled.

Creating a DHCP server group

Required.

To improve reliability, you can specify several DHCP servers as a
group on the DHCP relay agent and correlate a relay agent interface
with the server group. When the interface receives requesting
messages from clients, the relay agent forwards them to all the DHCP
servers of the group.

Enabling the DHCP relay agent on an

interface

Required.

Enable the DHCP relay agent on an interface, and correlate the
interface with a DHCP server group.

@ IMPORTANT:

The DHCP relay agent works on interfaces with IP addresses manually
configured only.

Configuring and displaying clients'
[Pto-MAC bindings

Optional.

Create a static IP+o-MAC binding, and view static and dynamic
bindings.

The DHCP relay agent can dynamically record clients' IP4+o-MAC
bindings after clients get IP addresses. It also supports static bindings,
that is, you can manually configure IP4+o-MAC bindings on the DHCP
relay agent, so that users can access external network using fixed IP
addresses.

By default, no static binding is created.
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Enabling DHCP and configuring advanced
parameters for the DHCP relay agent

From the navigation tree, select Network > DHCP to enter the default DHCP Relay page.

2. Click Display Advanced Configuration to expand the advanced DHCP relay agent configuration
areq, as shown in Figure 275.

Figure 275 DHCP relay agent configuration page
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3. Enable DHCP service and configure advanced parameters for DHCP relay agent as shown
in Table 94.
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4.

Click Apply.

Table 94 Configuration items

ltem

Description

DHCP Service

Enable or disable global DHCP.

Unauthorized Server
Detect

Enable or disable unauthorized DHCP server detection.

There are unauthorized DHCP servers on networks, which reply DHCP clients with
wrong IP addresses.

With this feature enabled, upon receiving a DHCP request, the DHCP relay agent
records the IP address of any DHCP server that assigned an IP address to the DHCP
client and the receiving interface. The administrator can use this information to check
out DHCP unauthorized servers. The device puts a record once for each DHCP
server. The administrator needs to find unauthorized DHCP servers from the log
information. After the information of recorded DHCP servers is cleared, the relay
agent re-records server information following this mechanism.

Dynamic Bindings
Refresh

Track Timer Interval

Enable or disable periodic refresh of dynamic client entries, and set the refresh
inferval.

A DHCP client sends a DHCP-RELEASE unicast message to the DHCP server through
the DHCP relay agent to relinquish its IP address. In this case the DHCP relay agent
simply conveys the message to the DHCP server, thus it does not remove the IP
address from dynamic client entries. To solve this problem, the periodic refresh of
dynamic client entries feature is introduced.

With this feature, the DHCP relay agent uses the IP address of a client and the MAC
address of the DHCP relay agent interface to periodically send a DHCP-REQUEST
message to the DHCP server.

o If the server returns a DHCP-ACK message or does not return any message within
a specific interval, which means that the IP address is assignable now, the DHCP
relay agent ages out the client entry.

o If the server returns a DHCP-NAK message, which means the IP address is still in
use, the relay agent does not age it out.

If the Auto option is selected, the refresh interval is calculated by the relay agent
according to the number of client entries.

Creating a DHCP server group

1.

in Figure 275.

From the navigation tree, select Network > DHCP to enter the default DHCP Relay page shown

In the Server Group areq, click Add to enter the page shown in Figure 276.

Figure 276 Create a server group
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3. Configure the DHCP server group as shown in Table 95.
4. Click Apply.

Table 95 Configuration items

ltem Description

Enter the ID of a DHCP server group.
Server Group ID
You can create up to 20 DHCP server groups.

Enter the IP address of a server in the DHCP server group.

IP Address The server IP address cannot be on the same subnet as the IP address of the DHCP
relay agent. Otherwise, the client cannot obtain an IP address.

Enabling the DHCP relay agent on an interface

1. From the navigation tree, select Network > DHCP to enter the default DHCP Relay page shown
in Figure 275.

2. In the Interface Config field, click the B icon of @ specific interface to enter the page shown
in Figure 277.

Figure 277 Configuring a DHCP relay agent interface
DHCP Snooping

Interface Mame Ylan-interface

DHCF Relay O Enable ® Disable
Address hatch

Check () Enahle () Dizable
Server Group 1D w

Apply Cancel

3. Configure the DHCP relay agent on the interface as shown in Table 96.
4. Click Apply.

Table 96 Configuration items

ltem Description
Interface Name This field displays the name of a specific interface.
DHCP Relay Enable or disable the DHCP relay agent on the interface.

Enable or disable IP address check.

With this function enabled, the DHCP relay agent checks whether a requesting

Address Match Check client's IP and MAC addresses match a binding (dynamic or static) on the DHCP
relay agent. If not, the client cannot access outside networks through the DHCP
relay agent. This prevents invalid IP address configuration.

Correlate the interface with a DHCP server group.
Server Group ID
A DHCP server group can be correlated with multiple interfaces.
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Configuring and displaying clients' IPto-MAC
bindings

1. From the navigation tree, select Network > DHCP to enter the default DHCP Relay page shown
in Figure 275.

2. Inthe User Information areq, click User Information to view static and dynamic bindings, as shown
in Figure 278.

Figure 278 Displaying clients' IP-to-MAC bindings

DHCFP Snooping

I IP Address ¥ | Search | advanced Search
P Address MAC Address Type |nterface Mame Dperation
11.1.2 00e0-1234-5678 Static Y0an-interface m
Add Return Refresh Reset

3. Click Add to enter the page as shown in Figure 279.
Figure 279 Creating a static IP-to-MAC binding

DHCP Snooping

IP Address | ,
MAC Address | S (H-H-H)
Interface Mame | W |
[tems marked with an asterisk(*) are required
Apply Zancel

4.  Configure the static IP+to-MAC binding as described in Table 97.
5. Click Apply.

Table 97 Configuration items

ltem Description
IP Address Enter the IP address of a DHCP client.
MAC Address Enter the MAC address of the DHCP client.

Select the Layer 3 interface connected with the DHCP client.

@ IMPORTANT:

The interface of a static binding entry must be configured as a DHCP relay agent.
Otherwise, address entry conflicts might occur.

Interface Name
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DHCP relay agent configuration example

Network requirements

As shown in Figure 280, VLAN-interface 1 on the DHCP relay agent (Switch A) connects to the network

where DHCP clients reside.

The IP address of VLAN-interface 1 is 10.10.1.1 /24 and the IP address of VLAN-interface 2 is 10.1.1.1/24.

VLAN:-interface 2 is connected to the DHCP server whose IP address is 10.1.1.1/24.
The switch forwards DHCP messages between DHCP clients and the DHCP server.
Figure 280 Network diagram

DHCP client DHCP client

Vlan-intl Vlan-int2

10.10.1.1/24 g 10.1.1.2/24 |?;I
Switch A

DHCP relay agent DHCP server

DHCP client DHCP client

Configuring Switch A
1. Enable DHCP:
a. From the navigation tree, select Network > DHCP to enter the default DHCP Relay page.
b. Select the Enable option next to DHCP Service, as shown in Figure 281.

c. Click Apply.
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Figure 281 Enabling DHCP

ODHCP Enooping

DHCF Service ® Enable O Disable
Digplay Advanced Configuration
Apphy Cancel
Semer Group
R sener Group |0 | Search | advanced Search
Server Group 1D IP Address

Add
Interface Config
R Interface Name v = Search | sdvanced Search

Interface Mame DHCP Relay State

Ylan-interface1 Disahled
Ylan-interface2 Disahled

IIser Information

IJser Infarmation

2. Configure a DHCP server group:

a. In the Server Group areq, click Add and then perform the following operations, as shown

in Figure 282.
b. Enter 1 for Server Group ID.
c. Enter 10.1.1.1 for IP Address.
d. Click Apply.

Figure 282 Adding a DHCP server group

DHCP Snooping

Server Group 1D 1

P Address 10111

H0-18)

*

Dperation

Dperation

&
&

[tems marked with an asterisk(*) are required

Apply Cancel
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3.  Enable the DHCP relay agent on VLAN-interface 1:

a. In the Interface Config field, click the ¥ icon of VLANinterface 1, and then perform the
following operations, as shown in Figure 283.

b. Select the Enable option next to DHCP Relay.
c. Select 1 for Server Group ID.
d. Click Apply.

Figure 283 Enabling the DHCP relay agent on an interface and correlate it with a server group
DHCP Snooping

Interface Mame Wlan-interface

DHCP Relay & Enable ) Disable
Address Match

Check ) Enable () Disahle
Sener Graup 1D 1 w

Al Cancel

Because the DHCP relay agent and server are on different subnets, you need to configure a static route
or dynamic routing protocol to make them reachable to each other.
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Configuring DHCP snooping

DHCP snooping works between the DHCP client and server, or between the DHCP client and DHCP
relay agent. It guarantees that DHCP clients obtain IP addresses from authorized DHCP servers. Also, it
records IPto-MAC bindings of DHCP clients (called DHCP snooping entries) for security purposes.

DHCP snooping does not work between the DHCP server and DHCP relay agent.

Overview

DHCP snooping defines trusted and untrusted ports to make sure clients obtain IP addresses only from
authorized DHCP servers.

e Trusted—A trusted port can forward DHCP messages correctly to make sure the clients get IP
addresses from authorized DHCP servers.

e Untrusted—An untrusted port discards received DHCP-ACK and DHCP-OFFER messages to prevent
unauthorized servers from assigning IP addresses.

DHCP snooping reads DHCP-ACK messages received from trusted ports and DHCP-REQUEST messages
to create DHCP snooping entries. A DHCP snooping entry includes the MAC and IP addresses of a client,
the port that connects to the DHCP client, and the VLAN. The DHCP snooping entries can be used by ARP
detection to prevent ARP attacks. For more information about ARP detection, see "Configuring ARP attack
protection".

Application of trusted ports

Configure ports facing the DHCP server as trusted ports, and configure other ports as untrusted ports.

As shown in Figure 284, configure the DHCP snooping device's port that is connected to the DHCP
server as a trusted port. The trusted port forwards response messages from the DHCP server to the client.
The untrusted port connected to the unauthorized DHCP server discards incoming DHCP response
messages.

Figure 284 Trusted and untrusted ports

DHCP server

DHCP client Unauthorized

DHCP server

DHCP reply messages

—
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In a cascaded network as shown in Figure 285, configure each DHCP snooping device's ports
connected to other DHCP snooping devices as trusted ports. To save system resources, you can disable

the untrusted ports that are not directly connected to DHCP clients from generating DHCP snooping
entries.

Figure 285 Trusted and untrusted ports in a cascaded network

DHCP client
Host A

DHCP snooping
Switch A DHCP server

Eth1/0/1

Eth1/0/1

. ¢ DHCP snooping
DHCP client
i Eth1/0/3 Switch C

DHCP client DHCP snooping

Host C Switch B
@ Untrusted ports
© Trusted ports disabled from recording binding entries
DHCP client © Trusted ports enabled to record binding entries

Host D

Table 98 describes roles of the ports shown in Figure 285.
Table 98 Roles of ports

. Trusted port disabled from Trusted port enabled to
Device Untrusted port L L . . .
recording binding entries record binding entries
Switch A Ethernet 1/0/1 Ethernet 1/0/3 Ethernet 1/0/2
. Ethernet 1/0/3 and
Switch B Ethernet 1/0/4 Ethernet 1/0/1 Ethernet 1/0/2
Switch C Ethernet 1/0/1 Ethernet 1/0/3 and Ethernet 1/0/4 Ethernet 1/0/2

DHCP snooping support for Option 82

Option 82 records the location information about the DHCP client so the administrator can locate the
DHCP client for security and accounting purposes. For more information, see "Option 82."

DHCP snooping uses the same strategies as the DHCP relay agent to handle Option 82 for DHCP
request messages, as shown in Table 99. If a response returned by the DHCP server contains Option 82,
DHCP snooping removes Option 82 before forwarding the response to the client. If the response contains
no Option 82, DHCP snooping forwards it directly.
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Table 99 Handling strategy

If a DHCP request has... Handling strategy  The DHCP snooping device...

Drop Drops the message.
Keep Forwards the message without changing Option 82.
Opfion 82 Forwards the message after replacing the original
Replace Option 82 with the Option 82 padded in normal
format.
No Option 82 N/A Forwards the message after adding the Option 82

padded in normal format.

Recommended configuration procedure

Task Remarks

Required.

Enabling DHCP snoopin
" Pina By default, DHCP snooping is disabled.

Required.

Specify an interface as trusted and configure DHCP snooping to support
Option 82.

By default, an inferface is untrusted and DHCP snooping does not support

Configuring DHCP snooping Option 82

functions on an interface

@ IMPORTANT:

You need to specify the ports connected to the authorized DHCP servers as
trusted fo make sure DHCP clients can obtain valid IP addresses. The trusted
port and the port connected to the DHCP client must be in the same VLAN.

Displaying clients' IP4to-MAC Optionall.
bindings Display clients' IP-to-MAC bindings recorded by DHCP snooping.

Enabling DHCP snooping

1. From the navigation tree, select Network > DHCP.
2. Click the DHCP Snooping tab to enter the page shown in Figure 286.
3. Select the Enable option next to DHCP Snooping to enable DHCP Snooping.
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Figure 286 DHCP snooping configuration page

DHCF Relay

DHCP Snooping 71 Enable @ Disable

Interface Config

IO\ Interface Mame « Search | Advanced Search
Interface Name Interface State Operation
Ethernet1/0/1 Unitrust Ex
Ethernet1/0i2 Unirust B
Ethemnet1/0/3 Unitrust &
Ethemnet1/0/4 Unitrust Ex
Ethernet1/0/5 Untrust £
Ethemnet1/0/6 Unitrust e
Ethemnet1/0/7 Unitrust e
Ethernet1/0/3 Untrust B
Ethemnet1/0/9 Unitrust Ex
Ethernet1/0/10 Untrust @
Ethernet1/0/11 Untrust @
Ethernet1/0M12 Untrust @
Ethernet1/0/13 Untrust e
Ethernet1/0/14 Untrust @
Ethernet1/0/15 Untrust @
26records, 15~ perpage | page 1/2, record 1-15 | First Prev Mext Last | GO

Contiguring DHCP snooping functions on an
interface

From the navigation tree, select Network > DHCP.
2. Click the DHCP Snooping tab to enter the page shown in Figure 286.

3. Click the BB icon of a specific interface in the Interface Config area to enter the page shown
in Figure 287.
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Figure 287 DHCP snooping interface configuration page
DHCP Relay

Interface Mame GigahitEthernet1/0/M1

Interface State O Trust ® Untrust
Option 82 Suppoert O Enable ® Disable
Option 82 Strategy '@| (Default = Replace)

Apply Cancel

4.  Configure DHCP snooping on the interface as described in Table 100.
5.  Click Apply.

Table 100 Configuration items

ltem Description

Interface Name This field displays the name of a specific interface.
Interface State Configure the inferface as trusted or untrusted.

Option 82 Support Configure DHCP snooping to support Option 82 or not.

Select the handling strategy for DHCP requests containing Option 82. The strategies

include:
Oution 82 Strat o Drop—The message is discarded if it contains Option 82.
pHon raiesy Keep—The message is forwarded without its Option 82 being changed.

o Replace—The message is forwarded affer its original Option 82 is replaced with
the Option 82 padded in normal format.

Displaying clients' IPto-MAC bindings

From the navigation tree, select Network > DHCP.
Click the DHCP Snooping tab to enter the page shown in Figure 286.

Click User Information to enter the page as shown in Figure 288.

Figure 288 DHCP snooping user information

DHCF Relay
| IP Address ¥ | Bearch | advanced Search
IP Addrass MAC Address Type Interface Mame Feemainir :':“ETI“H Operation
1.0.0.2 00e0-1234-5678  Dymamic Ethemet1ion 1 836353 u
Retum Refresh Resel

Table 101 describes the fields of DHCP snooping entries.
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Table 101 Field description

ltem Description
IP Address Displays the IP address assigned by the DHCP server to the client.
MAC Address Displays the MAC address of the client.
Displays the client type:
Type e Dynamic—The IP-to-MAC binding is generated dynamically.

o Static—The IP-to-MAC binding is configured manually. Static bindings are not
supported.

Interface Name

Displays the device interface to which the client is connected.

VLAN

Displays the VLAN to which the device belongs.

Remaining Lease Time

Displays the remaining lease time of the IP address.

DHCP snooping configuration example

Network requirements

As shown in Figure 289, a DHCP snooping device (Switch B) is connected to a DHCP server through
Ethernet 1/0/1, and to DHCP clients through Ethernet 1/0/2 and Ethernet 1/0/3.

Enable DHCP snooping on Switch B and configure DHCP snooping to support Option 82.
Configure the handling strategy for DHCP requests containing Option 82 as replace.

Enable Ethernet 1/0/1 to forward DHCP server responses. Disable Ethernet 1/0/2 and Ethernet
1/0/3 from forwarding DHCP server responses.

Configure Switch B to record clients' IP-to-MAC address bindings in DHCP-REQUEST messages and
DHCP-ACK messages received from a trusted port.

Figure 289 Network diagram

Eth1/0/1

Eth1/0/2

DHCP client

Configuring Switch B

1.

a.
b.

C.

Switch A
DHCP server

Switch B
DHCP snooping

Eth1/0/3

DHCP client

Enable DHCP snooping:
From the navigation tree, select Network > DHCP.
Click the DHCP Snooping tab.

As shown in Figure 290, select the Enable option next to DHCP Snooping to enable DHCP

snooping.
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Figure 290 Enabling DHCP snooping

DHCF Relay
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Interface Config
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Interface Mame Interface State Operation
Ethernet1/0/1 Untrust B
Ethernet1/0/2 Untrust B
Ethernet1/0/3 Untrust &
Ethernet1/0/4 Untrust &
Ethernet1/0/5 Untrust &
Ethernet1/0/5 Untrust B
Ethernet1/0/7 Untrust B
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2.  Configure DHCP snooping functions on Ethernet 1/0/1:
a. Click the icon of Ethernet 1/0/1 on the interface list.

b. Select the Trust option next to Interface State as shown in Figure 291.

c. Click Apply.
Figure 291 Configuring DHCP snooping functions on Ethernet 1/0/1

DHCP Relay

Interface Mame GigahitEthernet1/0/1
Interface State ® Trust O Untrust

Option 82 Support O Enable () Disable

Option 82 Strategy (Default = Replace)

Apply Cancel

3. Configure DHCP snooping functions on Ethernet 1/0/2:
a. Click the icon of Ethernet 1/0/2 on the interface list.
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e.

. Select the Untrust option for Interface State shown in Figure 292.

Select the Enable option next to Option 82 Support.

. Select Replace for Option 82 Strategy.

Click Apply.

Figure 292 Configuring DHCP snooping functions on Ethernet 1/0/2

DHCP Relay

Interface Mame GigahitEthernet1/0/2

Interface State O Trust ® Untrust

Option 82 Support &) Enable (O Disable

Option 82 Strategy [Default = Replace)
Apply Cancel

Configure DHCP snooping functions on Ethernet 1/0/3:

a. Click the icon of Ethernet 1/0/3 on the interface list.
b.
c.
d.

e.

Select the Untrust option for Interface State as shown in Figure 293.
Select the Enable option next to Option 82 Support.

Select Replace for Option 82 Strategy.

Click Apply.

Figure 293 Configuring DHCP snooping functions on Ethernet 1/0/3

DHCP Relay

Interface Mame GigabitEthernet1/0/3

Interface State O Trust 3 Untrust
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Managing services

Overview

Service management allows you to manage the following types of services: FTP, Telnet, SSH, SFTP, HTTP
and HTTPS.

You can enable or disable the services, modify HTTP and HTTPS port numbers, and associate the FTP,
HTTP, or HTTPS service with an ACL to block illegal users.

FTP service

FTP is an application layer protocol for sharing files between server and client over a TCP/IP network.
Telnet service

Telnet is an application layer protocol that provides remote login and virtual terminal functions.
SSH service

Secure Shell (SSH) offers an approach to securely logging in to a remote device. By encryption and
strong authentication, it protects devices against attacks such as IP spoofing and plain text password
interception.

SFTP service

The secure file transfer protocol (SFTP) is a new feature in SSH2.0. SFTP uses the SSH connection to
provide secure data transfer. The device can serve as the SFTP server, allowing a remote user to log in to
the SFTP server for secure file management and transfer. The device can also serve as an SFTP client,
enabling a user to login from the device to a remote device for secure file transfer.

HTTP service

HTTP is used for transferring webpage information across the Internet. It is an application-layer protocol
in the TCP/IP protocol suite.

You can log in to the device by using the HTTP protocol with HTTP service enabled, accessing and
controlling the device with Web-based network management.

HTTPS service

The Hypertext Transfer Protocol Secure (HTTPS) refers to the HTTP protocol that supports the Security
Socket Layer (SSL) protocol.

The SSL protocol of HTTPS enhances the security of the device in the following ways:

o Uses the SSL protocol to ensure the legal clients to access the device securely and prohibit the illegal
clients.

e Encrypts the data exchanged between the HTTPS client and the device to ensure the data security
and integrity.

e Defines certificate aftribute-based access control policy for the device to control user access.
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Managing services

1. Select Network > Service from the navigation tree to enter the service management configuration
page, as shown in Figure 294.

Figure 294 Service management

PFTP [1Enable FTP senice
Telnet [#] Enable Telnet service
S5H [1Enahle S5H semice
SFTP [|Enakle SFTP service

PHTTP [¥] Enable HTTF service

PHTTPS []Enahle HTTPS serice Certificate:
[terms marked with an asterisk(™ are required

Apply Cancel

2. Enable or disable services on the page. Table 102 describes the detailed configuration items.
3. Click Apply.

Table 102 Configuration items

ltem Description
Enable FTP Enable or disable the FTP service.
service The FTP service is disabled by default.
FTP Associate the FTP service with an ACL. Only the clients that pass the ACL
AcL filtering are permitted to use the FTP service.
You can view this configuration item by clicking the expanding button in
front of FTP.
Telnet Enql?|e Telnet Enable or disable the Telnet service.
service The Telnet service is disabled by default.
SSH Enq.ble SSH Enable or disable the SSH service.
service The SSH service is disabled by default.
Enable or disable the SFTP service.
- Enable SFTP The SFTP service is disabled by default.
service ® IMPORTANT:
When you enable the SFTP service, the SSH service must be enabled.
HTTP Enql?le HTTP Enable or disable the HTTP service.
service The HTTP service is enabled by default.
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ltem Description

Set the port number for HTTP service.
You can view this configuration item by clicking the expanding button in
front of HTTP.

Port Number
@ IMPORTANT:
When you modify a port, make sure the port is not used by any other
service.
Associate the HTTP service with an ACL. Only the clients that pass the ACL

Al filtering are permitted to use the HTTP service.
You can view this configuration item by clicking the expanding button in
front of HTTP.

Enable HTTPS Enable or disable the HTTPS service.

service The HTTPS service is disabled by default.
Select a local certificate for the HTTPS service from the Certificate
dropdown list.
You can configure the certificates available in the dropdown list in
Authentication > Certificate Management. For more information, see

Certificate "Managing certificates."
(D IMPORTANT:
If no certificate is specified, the HTTPS service generates its own
certificate.

HTTPS

Port Number

Set the port number for HTTPS service.

You can view this configuration item by clicking the expanding button in
front of HTTPS.

(D IMPORTANT:

When you modify a port, make sure the port is not used by any other
service.

ACL

Associate the HTTPS service with an ACL. Only the clients that pass the
AClL filtering are permitted fo use the HTTPS service.

You can view this configuration item by clicking the expanding button in
front of HTTPS.
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Using diagnostic tools

This chapter describes how to use the ping and traceroute utilities.
Ping

Use the ping utility fo defermine if a specific address is reachable.

A ping operation involves the following steps:

1. The source device sends ICMP echo requests to the destination device.

2. The destination device responds by sending ICMP echo replies to the source device after receiving
the ICMP echo requests.

3. The source device displays related statistics after receiving the replies.

You can ping the IP address or the host name of a device. A prompt appears if the host name cannot be
resolved.

If the source device does not receive an ICMP echo reply within the timeout time, it displays:
e A prompt.

e Ping statistics.

If the source device receives ICMP echo replies within the timeout time, it displays:
e Number of bytes for each echo reply.

*  Message sequence number.

e Time to Live (TTL).

®  Response time.

e  Ping statistics.

Ping statistics include:

e Number of echo requests sent.

e Number of echo replies received.

o Percentage of echo replies not received.

e Minimum, average, and maximum response time.

Traceroute

Traceroute retrieves the IP addresses of Layer 3 devices in the path to a specific destination. You can use
traceroute to test network connectivity and identify failed nodes.

You can traceroute the IP address or the host name of a destination device. If the target host name cannot
be resolved, a prompt appears.

A traceroute operation involves the following steps:

1. The source device sends a packet with a Time to Live (TTL) value of 1 to the destination device.
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2. The first hop device responds with an ICMP TTL-expired message to the source. In this way, the
source device gets the address of the first device.

3. The source device sends a packet with a TTL value of 2 to the destination device.

The second hop responds with an ICMP TTL-expired message. In this way, the source device gets
the address of the second device.

5. The destination device responds with an ICMP port-unreachable message because the packet from
the source has an unreachable port number. In this way, the source device gets the address of the
destination device.

In this way, the source device can get the addresses of all Layer 3 devices on the path.

Ping operation

The Web interface does not support IPvé ping.

To perform a ping operation:
1. From the navigation tree, select Network > Diagnostic Tools.

The ping configuration page appears.
Figure 295 Ping configuration page

Trace Route

Destination IP address ar host name: Start

Sumrmary:

2. Enfer the IP address or the host name of the destination device in the Destination IP address or host
name field.

3. Click Start.

View the output in the Summary area.
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Figure 296 Ping operation result

Summany:

PING 192.165.1.16: 56 data bytes
Beply from 192.168.1.16: bytes=56 Sequence=1 ttl=128 time=4 ms
Beply from 192.163.1.16: bytes=56 Jequence=Z ttl=125 time=4 ms
Feply from 192,168.1.16: bytes=56 Sequence=3 ttl=125 time=3 ms
Feply from 192.1658.1.16: bytes=56 Sequence=4 ttl=125 time=3 ms
Deply from 192,.168.1.16: bytes=56 Sequence=5 ttl=125 time=3 ms

- - -

-—-- 192.168.1.16 ping statistics ---
5 packet(s] transmitted
L packet(s] receiwved
0.00% packet loss
round-trip nindawvg/max = 3/3/4 ns

Traceroute operation

The Web interface does not support IPvé traceroute.

Before performing a traceroute operation, perform the following tasks:

e Enable sending of ICMP timeout packets by executing the ip tl-expires enable command on
infermediate devices.

e Enable sending of ICMP destination unreachable packets by executing the ip unreachables enable
command on the destination device.

To perform a traceroute operation:
1. From the navigation tree, select Network > Diagnostic Tools.
2. Click the Trace Route tab.

The traceroute configuration page appears.

Figure 297 Traceroute configuration page

Fing

Destination IP address or hast name: Start

Summary:
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Enter the IP address or host name of the destination device in the Trace Route field.
Click Start.

View the output in the Summary area.

Figure 298 Traceroute operation result

Summary;

traceroute to 192 168 2. 1 (192,168 2. 1) 30 hops ma, 40 bytes packet

1 192.168.2.1 1 ms <1 ms 1 ms

325



Configuring 802.1X

802.1X overview

802.1X is a port-based network access control protocol initially proposed by the IEEE 802 LAN/WAN
committee for the security of WLANS. It has been widely used on Ethernet for access control.

802.1X controls network access by authenticating the devices connected to 802.1X-enabled LAN ports.

This chapter describes how to configure 802.1X on an HP device. You can also configure the port security
feature to perform 802.1X. Port security combines and extends 802.1X and MAC authentication. It
applies to a network (for example, a WLAN) that requires different authentication methods for different
users on a port. For more information, see "Configuring port security."

802.1X architecture

802.1X operates in the client/server model. It comprises three entities: the client (the supplicant), the
network access device (the authenticator), and the authentication server.

Figure 299 802.1X architecture

: o—@

Authentication server

Client

o Client—A user terminal seeking access to the LAN. It must have 802.1X software to authenticate to
the network access device.

e Network access device— Authenticates the client to control access to the LAN. In a typical 802.1X
environment, the network access device uses an authentication server to perform authentication.

e  Authentication server—Provides authentication services for the network access device. The
authentication server authenticates 802.1X clients by using the data sent from the network access
device, and returns the authentication results to the network access device to make access decisions.
The authentication server is typically a RADIUS server. In a small LAN, you can also use the network
access device as the authentication server.

Access control methods

HP implements port-based access control as defined in the 802.1X protocol, and extends the protocol to
support MAC-based access control.

o Port-based access control—Once an 802.1X user passes authentication on a port, any subsequent
user can access the network through the port without authentication. When the authenticated user
logs off, all other users are logged off.
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e MAC-based access control—Each user is separately authenticated on a port. When a user logs off,
no other online users are affected.

Controlled/uncontrolled port and port authorization status

802.1X defines two logical ports for the network access port: controlled port and uncontrolled port. Any
packet arriving at the network access port is visible to both logical ports.

o Controlled port—Allows incoming and outgoing traffic to pass through when it is in the authorized
state, and denies incoming and outgoing traffic when it is in the unauthorized state, as shown
in Figure 300. The controlled port is set in authorized state if the client has passed authentication,
and in unauthorized state, if the client has failed authentication.

e Uncontrolled port—Is always open to receive and transmit EAPOL frames.

Figure 300 Authorization state of a controlled port

Authenticator system 1 Authenticator system 2

Controlled port Uncontrolled port Controlled port Uncontrolled port

A A

l Port unauthorized Port authorized

In the unauthorized state, a controlled port controls traffic in one of the following ways:
e Performs bidirectional traffic control to deny traffic to and from the client.

o Performs unidirectional traffic control to deny traffic from the client.

The device supports only unidirectional traffic control.

Packet formats

EAP packet format
Figure 301 shows the EAP packet format.
Figure 301 EAP packet format

0 7 15
Code Identifier 2
Length 4
Data
N
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Code—Type of the EAP packet. Options include Request (1), Response (2), Success (3), or Failure
(4).

Identifier—Used for matching Responses with Requests.

Length—Length (in bytes) of the EAP packet. The length is the sum of the Code, Identifier, Length,
and Data fields.

Data—Content of the EAP packet. This field appears only in a Request or Response EAP packet. The

Data field comprises the request type (or the response type) and the type data. Type 1 (Identify) and
type 4 (MD5-challenge) are two examples for the type field.

EAPOL packet format
Figure 302 shows the EAPOL packet format.
Figure 302 EAPOL packet format

0 7 15
PAE Ethernet type 2
Protocol version Type 4
Length 6

Packet body

PAE Ethernet type—Protocol type. It takes the value 0x888E for EAPOL.
Protocol version—The EAPOL protocol version used by the EAPOL packet sender.

Type—Type of the EAPOL packet. Table 103 lists the types of EAPOL packets supported by HP
implementation of 802.1X.

Table 103 Types of EAPOL packets

Value Type Description

0x00 EAP-Packet The client and th(.-:- ne.two.rk access device uses EAP-Packets to
transport authentication information.

0x01 EAPOLStart The cllgni s'ends an EAPOL-Start message to initiate 802.1X
authentication to the network access device.

0x02 EAPOL-Logoff The client sends an EAPOL-Logoff message to tell the network

access device that it is logging off.

Length—Data length in bytes, or length of the Packet body. If packet type is EAPOLStart or
EAPOL-Logoff, this field is set to O, and no Packet body field follows.

Packet body—Content of the packet. When the EAPOL packet type is EAP-Packet, the Packet body
field contains an EAP packet.

EAP over RADIUS

RADIUS adds two attributes, EAP-Message and Message-Authenticator, for supporting EAP
authentication. For the RADIUS packet format, see "Configuring RADIUS."
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EAP-Message

RADIUS encapsulates EAP packets in the EAP-Message attribute, as shown in Figure 303. The Type field
takes 79, and the Value field can be up to 253 bytes. If an EAP packet is longer than 253 bytes, RADIUS

encapsulates it in multiple EAP-Message attributes.
Figure 303 EAP-Message attribute format

0 7 15 N

Type Length String

EAP packets

Message-Authenticator

RADIUS includes the Message-Authenticator attribute in all packets that have an EAP-Message attribute
to check their integrity. The packet receiver drops the packet if the calculated packet integrity checksum
is different from the Message-Authenticator attribute value. The Message-Authenticator prevents EAP
authentication packets from being tampered with during EAP authentication.

Figure 304 Message-Authenticator attribute format

0 1 2 18 bytes

Type Length String

Initiating 802.1X authentication

Both the 802.1X client and the access device can initiate 802.1X authentication.
802.1X client as the initiator

The client sends an EAPOL-Start packet to the access device to initiate 802.1X authentication. The
destination MAC address of the packet is the IEEE 802.1X specified multicast address
01-80-C2-00-00-03 or the broadcast MAC address. If any intermediate device between the client and
the authentication server does not support the multicast address, you must use an 802.1X client (for
example, the HP iNode 802.1X client) that can send broadcast EAPOL-Start packets.

Access device as the initiator

The access device initiates authentication, if a client cannot send EAPOL-Start packets. One example is
the 802.1X client available with Windows XP.

The access device supports the following modes:

e Multicast trigger mode—The access device multicasts Identity EAP-Request packets periodically
(every 30 seconds by default) to initiate 802.1X authentication.

e Unicast trigger mode—Upon receiving a frame with the source MAC address not in the MAC
address table, the access device sends an Identity EAP-Request packet out of the receiving port to
the unknown MAC address. It retransmits the packet if no response has been received within a
certain time interval.
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802.1X authentication procedures

802.1X provides the following methods for authentication:
e EAP relay.

° EAP termination.

You choose either mode depending on the support of the RADIUS server for EAP packets and EAP
authentication methods.
e  EAP relay mode:

EAP relay is defined in IEEE 802.1X. In this mode, the network device uses EAPOR packets to send

authentication information to the RADIUS server, as shown in Figure 305.

Figure 305 EAP relay

Client Device RADIUS server
‘ EAP packets over LAN lﬁl EAP packets over RADIUS
| |
| < EAP authentication =:

In EAP relay mode, the client must use the same authentication method as the RADIUS server. On
the network access device, you only need to enable EAP relay.

Some network access devices provide the EAP server function so you can use EAP relay even if the
RADIUS server does not support any EAP authentication method or no RADIUS server is available.

e  EAP termination mode:

In EAP termination mode, the network access device terminates the EAP packets received from the
client, encapsulates the client authentication information in standard RADIUS packets, and uses

PAP or CHAP to authenticate to the RADIUS server, as shown in Figure 306.
Figure 306 EAP termination

Client Device RADIUS server

. EAP packets over LAN l?s;l RADIUS

:<—EAP authentication—>:<—PAP/CHAP authentication—>:

Comparing EAP relay and EAP termination

Packet exchange method  Benefits Limitations

e Supports various EAP

authentication methods. The RADIUS server must support the

EAP-Message and Message-Authenticator
attributes, and the EAP authentication method
used by the client.

EAP relay e The configuration and
processing is simple on the
network access device.
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Packet exchange method  Benefits Limitations

e Supports only MD5-Challenge EAP
authentication and the "username +

Works with any RADIUS password" EAP authentication initiated by
EAP termination server that supports PAP or an HP iNode 802.1X client.

CHAP authentication.

o The processing is complex on the network
access device.

EAP relay

Figure 307 shows the basic 802.1X authentication procedure in EAP relay mode, assuming that
EAP-MDS5 is used.

Figure 307 802.1X authentication procedure in EAP relay mode

Client Device Authentication server

. EAPOL @ EAPOR

(1) EAPOL-Start

o
|

(2) EAP-Request/Identity

(3) EAP-Response/ldentity - (4) RADIUS Access-Request
(EAP-Response/ldentity)

(5) RADIUS Access-Challenge
(EAP-Request/MD5 challenge)

\J

A

(6) EAP-Request/MD5 challenge

A

(7) EAP-Response/MD5 challenge (8) RADIUS Access-Request
(EAP-Response/MD5 challenge)

(9) RADIUS Access-Accept
(EAP-Success)

\

\

(10) EAP-Success -

A

(11) EAP-Request/Identity

A

(12) EAP-Response/ldentity

\

(13) EAPOL-Logoff

(14) EAP-Failure =~ "7 "7 TTTTTTT

1. When a user launches the 802.1X client software and enters a registered username and password,
the 802.1X client software sends an EAPOL-Start packet to the network access device.

2. The network access device responds with an Identity EAP-Request packet to ask for the client
username.

3. In response to the Identity EAP-Request packet, the client sends the username in an Identity
EAP-Response packet to the network access device.

4.  The network access device relays the Identity EAP-Response packet in a RADIUS Access-Request
packet to the authentication server.

331



10.

11.

12.

13.
14.

The authentication server uses the identity information in the RADIUS Access-Request to search its
user database. If a matching entry is found, the server uses a randomly generated challenge
(EAP-Request/MD5 challenge) to encrypt the password in the entry, and sends the challenge in a
RADIUS Access-Challenge packet to the network access device.

The network access device relays the EAP-Request/MD5 Challenge packet in a RADIUS
Access-Request packet to the client.

The client uses the received challenge to encrypt the password, and sends the encrypted password
in an EAP-Response/MD5 Challenge packet to the network access device.

The network access device relays the EAP-Response/MD5 Challenge packet in a RADIUS
Access-Request packet to the authentication server.

The authentication server compares the received encrypted password with the one it generated at
step 5. If the two are identical, the authentication server considers the client valid and sends a
RADIUS Access-Accept packet to the network access device.

Upon receiving the RADIUS Access-Accept packet, the network access device sends an
EAP-Success packet to the client, and sets the controlled port in the authorized state so the client
can access the network.

Atter the client comes online, the network access device periodically sends handshake requests to
check whether the client is still online. By default, if two consecutive handshake attempts fail, the
device logs off the client.

Upon receiving a handshake request, the client returns a response. If the client fails to return a
response after a certain number of consecutive handshake attempts (two by default), the network
access device logs off the client. This handshake mechanism enables timely release of the network
resources used by 802.1X users that have abnormally gone offline.

The client can also send an EAPOL-Logoff packet to ask the network access device for a logoff.

In response to the EAPOL-Logoff packet, the network access device changes the status of the
controlled port from authorized to unauthorized and sends an EAP-Failure packet to the client.

EAP termination

Figure 308 shows the basic 802.1X authentication procedure in EAP termination mode, assuming that
CHAP authentication is used.
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Figure 308 802.1X authentication procedure in EAP termination mode

Client Device Authentication server
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(14) EAP-Failure
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In EAP termination mode, the network access device rather than the authentication server generates an
MD5 challenge for password encryption (see Step 4). The network access device then sends the MD5
challenge together with the username and encrypted password in a standard RADIUS packet to the
RADIUS server.

802.1X timers

This section describes the timers used on an 802.1X device to guarantee that the client, the device, and
the RADIUS server can interact with each other correctly.

e Username request timeout timer— Starts when the device sends an EAP-Request/Identity packet to
a client in response to an authentication request. If the device receives no response before this timer
expires, it retransmits the request. The timer also sets the interval at which the network device sends
multicast EAP-Request/Identity packets to detect clients that cannot actively request authentication.

e  Client timeout timer—Starts when the access device sends an EAP-Request/MD5 Challenge packet
to a client. If no response is received when this timer expires, the access device retransmits the
request to the client.

e Server timeout timer— Starts when the access device sends a RADIUS Access-Request packet to the
authentication server. If no response is received when this timer expires, the access device
retransmits the request to the server.
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e Handshake timer—Sefs the interval at which the access device sends client handshake requests to
check the online status of a client that has passed authentication. If the device receives no response
after sending the maximum number of handshake requests, it considers that the client has logged
off. For information about how to enable the online user handshake function, see "Configuring
802.1X on a port."

e Quiet timer—Starts when the access device sends a RADIUS Access-Request packet to the
authentication server. If no response is received when this timer expires, the access device
retransmits the request to the server.

e Periodic online user re-authentication timer— Sefs the interval at which the network device
periodically re-authenticates online 802.1X users. For information about how to enable periodic
online user re-authentication on a port, see "Configuring 802.1X on a port."

Using 802.1X authentication with other features

VLAN assignment

You can configure the authentication server to assign a VLAN for an 802.1X user that has passed
authentication. The way that the network access device handles VLANs on an 802.1X-enabled port
differs by 802.1X access control mode.

Access control VLAN manipulation

Assigns the VLAN to the port as the port VLAN (PVID). The authenticated 802.1X
user and all subsequent 802.1X users can access the VLAN without authentication.

Port-based ] )
When the user logs off, the previous PVID restores, and all other online users are

logged off.

o Ifthe port is a hybrid port with MAC-based VLAN enabled, the device maps the
MAC address of each user to the VLAN assigned by the authentication server.
The PVID of the port does not change. When a user logs off, the MAC-+o-VLAN

mapping for the user is removed.

MAC-based e If the port is an access, trunk, or MAC-based VLAN disabled hybrid port, the
device assigns the first authenticated user's VLAN to the port as the PVID. If a
different VLAN is assigned to a subsequent user, the user cannot pass the
authentication. To avoid the authentication failure of subsequent users, be sure to
assign the same VLAN to all 802.1X users on these ports.

With 802.1X authentication, a hybrid port is always assigned to a VLAN as an untagged member. After
the assignment, do not reconfigure the port as a tagged member in the VLAN.

On a periodic online user re-authentication enabled port, if a user has been online before you enable the
MAC-based VLAN function, the access device does not create a MAC+o-VLAN mapping for the user
unless the user passes re-authentication and the VLAN for the user has changed.

Guest VLAN

You can configure a guest VLAN on a port to accommodate users that have not performed 802.1X
authentication, so they can access a limited set of network resources, such as a software server, to
download anti-virus software and system patches. Once a user in the guest VLAN passes 802.1X
authentication, it is removed from the guest VLAN and can access authorized network resources. The
way that the network access device handles VLANSs on the port differs by 802.1X access control mode.

e On a port that performs port-based access control:
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Authentication status VLAN manipulation

No 802.1X user has The device assigns the 802.1X guest VLAN to the port as the PVID. All
performed authentication 802.1X users on this port can access only resources in the guest VLAN.
within 90 seconds after If no 802.1X guest VLAN is configured, the access device does not
802.1X is enabled. perform any VLAN operation.

If an 802.1X Auth-Fail VLAN (see "Auth-Fail VLAN") is available, the
A user in the 802.1X guest ~ device assigns the Auth-Fail VLAN to the port as the PVID. All users on this
VLAN fails 802.1X port can access only resources in the Auth-Fail VLAN.

authentication. If no Auth-Fail VLAN is configured, the PVID on the port is still the 802.1X
guest VLAN. All users on the port are in the guest VLAN.

o The device assigns the VLAN specified for the user to the port as the
PVID, and removes the port from the 802.1X guest VLAN. After the

A user in the 802.1X guest user logs off, the user configured PVID restores.

VLAN passes 802.1X e Ifthe authentication server assigns no VLAN, the user configured PVID

authentication. applies. The user and all subsequent 802.1X users are assigned fo the
user-configured PVID. After the user logs off, the PVID remains
unchanged.

e On a port that performs MAC-based access control:

Authentication status VLAN manipulation

The device creates a mapping between the MAC address of the user and
the 802.1X guest VLAN. The user can access resources in the guest
VLAN.

A user has not passed
802.1X authentication yet.

If an 802.1X Auth-Fail VLAN is available, the device remaps the MAC
A user in the 802.1X guest ~ address of the user to the Auth-Fail VLAN. The user can access only

VLAN fails 802.1X resources in the Auth-Fail VLAN.

authentication. If no 802.1X Auth-Fail VLAN is configured, the user is still in the guest
VLAN.

A user in the 802.1X guest The device remaps the MAC address of the user to the authorized VLAN.

VLAN passes 802.1X If the authentication server assigns no authorized VLAN, the device

authentication. remaps the MAC address of the user to the initial PVID on the port.

To use the 802.1X guest VLAN function on a port that performs MAC-based access control, make sure the
port is a hybrid port, and enable MAC-based VLAN on the port.

The network device assigns a hybrid port to an 802.1X guest VLAN as an untagged member.
Auth-Fail VLAN

You can configure an Auth-Fail VLAN to accommodate users that have failed 802.1X authentication
because of the failure to comply with the organization security strategy, such as using a wrong password.
Users in the Auth-Fail VLAN can access a limited set of network resources, such as a software server, to
download anti-virus software and system patches.

The Auth-Fail VLAN does not accommodate 802.1X users that have failed authentication for
authentication timeouts or network connection problems. The way that the network access device
handles VLANs on the port differs by 802.1X access control mode.

e On a port that performs port-based access control:
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Authentication status VLAN manipulation

A user fails 802.1X The device assigns the Auth-Fail VLAN to the port as the PVID. All 802.1X
authentication. users on this port can access only resources in the Auth-Fail VLAN.
A user in the Auth-Fail VLAN

The Auth-Fail VLAN is still the PVID on the port, and all 802.1X users on

fails 802.1X this port are in this VLAN.

re-authentication.

o The device assigns the VLAN specified for the user to the port as the
PVID, and removes the port from the Auth-Fail VLAN. After the user

logs off, the user-configured PVID restores.
A user passes 802.1X

- o If the authentication server assigns no VLAN, the initial PVID applies.
authentication.

The user and all subsequent 802.1X users are assigned to the
user-configured PVID. After the user logs off, the PVID remains
unchanged.

e On a port that performs MAC-based access control:

Authentication status VLAN manipulation

A user fails 802.1X The device remaps the MAC address of the user to the Auth-Fail VLAN.
authentication. The user can access only resources in the Auth-Fail VLAN.

A user in the Auth-Fail VLAN

fails 802.1X The user is still in the Auth-Fail VLAN.

re-authentication.

The device remaps the MAC address of the user fo the server-assigned
A user in the Auth-Fail VIAN AN

passes 802.1X

authentication. If the authentication server assigns no VLAN, remaps the MAC address of

the user to the initial PVID on the port.

To perform the 802.1X Auth-Fail VLAN function on a port that performs MAC-based access control, you
must ensure that the port is a hybrid port, and enable MAC-based VLAN on the port.

The network device assigns a hybrid port to an 802.1X Auth-Fail VLAN as an untagged member.
ACL assignment

You can specity an ACL for an 802.1X user to control its access to network resources. After the user
passes 802.1X authentication, the authentication server, either the local access device or a RADIUS
server, assigns the ACL to the port to filter the traffic from this user. In either case, you must configure the
ACL on the access device. You can change ACL rules while the user is online.

Contiguration prerequisites

When you configure 802.1X, follow these restrictions and guidelines:

e Configure an ISP domain and AAA scheme (local or RADIUS authentication) for 802.1X users. For
more information, see "Configuring AAA" and "Configuring RADIUS."

e |f RADIUS authentication is used, create user accounts on the RADIUS server.

e Iflocal authentication is used, create local user accounts on the access device and specify the LAN
access service for the user accounts. For more information, see "Configuring users."
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Recommended configuration procedure

Step

Remarks

Required.

1. Configuring 802.1X globally

This function enables 802.1X authentication globally. It also

configures the authentication method and advanced parameters.By
default, 802.1X authentication is disabled globally.

Required.

2. Configuring 802.1X on a port

This function enables 802.1X authentication on the specified port and

configures 802.1X parameters for the port.By default, 802.1X
authentication is disabled on a port.

Contiguring 802.1X globally

1. From the navigation tree, select Authentication > 802.1X.

The 802.1X page appears.
Figure 309 Configuring 802.1X

801X Configuration
Enable 802.1x

Authentication Method CHAP v

Cuiet [JEnable the Quiet Function
Retry Times 2 |(1-10, Default = 2)
Handshake Period

Supplicant Timeout Time

Ports With 802 1X Enabled

Port Control ~ Handshake

F Port

[ Ethernet1/0/3 MAC Based  Enabled

15 |seconds (5-1024, Default =

30 |seconds (1-120, Default = 30)

Quiet Period 60 |seconds (10-120, Default = 60}

Tx-Period 30 |seconds (10-120, Default = 30}
15) Re-Authentication Period 3600seconds (50-7200, Default = 3600}

Server Timeout Time 100 |seconds (100-300, Default = 100)

Apply
Re- Max Number . _ .., o i VI A Port .
Authentication of Users SRR R Authorization TRERICT
Disahled 256 Dizabled Dizabled Auto ﬁl
Add Del Selected

In the 802.1X Configuration areq, select Enable 802.1X.

Select an authentication method from the Authentication Method list.

Authentication Method list

o CHAP—Sets the access device to perform EAP termination and use CHAP to communicate with

the RADIUS server.

o PAP—Sets the access device to perform EAP termination and use PAP to communicate with the

RADIUS server.

o EAP—Sets the access device to relay EAP packets, and supports any of the EAP authentication
methods to communicate with the RADIUS server.

When you configure EAP relay or EAP termination, consider the following factors:
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o The support of the RADIUS server for EAP packets.
o The authentication methods supported by the 802.1X client and the RADIUS server.
4. Click Advanced to expand the advanced 802.1X configuration area.

Figure 310 Configuring advanced 802.1X parameters

wAdvanced
Quiet [CIEnahle the Guiet Function Quiet Period 60 |seconds (10-120, Default = 60)
Retry Times 2 [(1-10, Default= 2) Tx-Period 30 |seconds (10-120, Default= 30}
Handshake Period 15 |seconds (5-1024, Default=15) Re-Authentication Period 3600seconds (60-7200, Default= 3600)
Supplicant Timeout Time |30 seconds (1-120, Default= 300 Server Timeout Time 100 |seconds 100-300, Default=100)

5.  Configure advanced 802.1X settings as described in Table 104, and then click Apply.
Table 104 Configuration items

ltem Description
Quiet Sets whether to enable the quiet timer.
Quiet Period Sets the value of the quiet timer.

Sets the maximum number of authentication request attempts.

The network access device retransmits an authentication request if it does not
receive a response to the request it has sent to the client within a period of time (set

Retry Times . ’ . .
by the TX Period or the Supplicant Timeout Time value). The network access
device stops retransmitting the request, if it has made the maximum number of
request transmission attempts but still received no response.

TX-Period Sets the username request timeout timer.

Handshake Period Sets the handshake timer.

Re-Authentication

. Sets the periodic online user re-authentication timer.
Period

Supplicant Timeout

. Sefs the client timeout timer.
Time

Server Timeout Time  Sets the server timeout timer.

NOTE:

You can set the client timeout timer to a high value in a low-performance network, and adjust the
server timeout timer to adapt to the performance of different authentication servers. In most cases, the
default settings are sufficient.

Contiguring 802.1X on a port

1. From the navigation tree, select Authentication > 802.1X.
2. In the Ports With 802.1X Enabled areq, click Add.
3.  Configure 802.1X features on a port as shown in Figure 311, and then click Apply.
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Figure 311 Configuring 802.1X on a port
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Table 105 describes the configuration items.

Table 105 Configuration items

ltem Description
Selects a port where you want to enable 802.1X. Only ports not enabled
Port with 802.1X authentication are available.
or
802.1X configuration takes effect on a port only after 802.1X is enabled
both globally and on the port.
Port Control Selects an access control method for the port, MAC Based or Port Based.

Port Authorization

Selects a port authorization state for 802.1X:

e Auto—Places the port initially in the unauthorized state to allow only
EAPOL packets to pass, and after a user passes authentication, sets the
port in the authorized state to allow access to the network. You can use
this option in most scenarios.

o Force-Authorized—Places the port in the authorized state, enabling users
on the port to access the network without authentication.

¢ Force-Unauthorized—Places the port in the unauthorized state, denying
any access requests from users on the port.

Max Number of Users

Sets the maximum number of concurrent 802.1X users on the port.

Enable Handshake

Specifies whether to enable the online user handshake function.

This function enables the network access device to send handshake
messages to online users at the interval set by the Handshake Period setting.
If no response is received from an online user after the maximum number of
handshake attempts (set by the Retry Times setting) has been made, the
network access device sets the user in the offline state. For information about
the timers, see "Configuring 802.1X globally."

NOTE:

If the network has 802.1X clients that cannot exchange handshake packets with
the network access device, disable the online user handshake function to
prevent their connections from being inappropriately torn down.
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ltem Description

Specifies whether to enable periodic online user re-authentication on the
port.

Periodic online user re-authentication tracks the connection status of online
users and updates the authorization attributes assigned by the server, such as
the ACL, and VLAN. The re-authentication interval is specified by the
Re-Authentication Period setting in Table 104.

NOTE:

e The periodic online user re-authentication timer can also be set by the
authentication server in the session-timeout attribute. The server-assigned
timer overrides the timer sefting on the access device, and it enables
periodic online user re-authentication, even if the function is not
configured on the access device. Support for the server assignment of
re-authentication timer and the re-authentication timer configuration on
the server vary with servers.

Enable Re-Authentication

e The VLAN assignment status must be consistent before and after
re-authentication. If the authentication server has assigned a VLAN before
re-authentication, it must also assign a VLAN at re-authentication. If the
authentication server has assigned no VLAN before re-authentication, it
must not assign one at re-authentication. Violation of either rule can cause
the user to be logged off. The VLANs assigned to an online user before
and after re-authentication can be the same or different.

Specifies an existing VLAN as the guest VLAN.
Guest VIAN

For more information, see "Configuring an 802.1X guest VLAN."

Specifies whether to enable MAC-based VLAN.
Required when MAC Based is selected for Port Control.
NOTE:

Only hybrid ports support the feature.

Enable MAC VLAN

Specifies an existing VLAN as the Auth-Fail VLAN to accommodate users that
Auth-Fail VLAN have failed 802.1X authentication.

For more information, see "Configuring an Auth-Fail VLAN."

Configuring an 802.1X guest VLAN

Configuration prerequisites

o Create the VLAN to be specified as the 802.1X guest VLAN.

o Ifthe 802.1X-enabled port performs MAC-based access control, configure the port as a hybrid port,
enable MAC-based VLAN on the port, and assign the port to the 802.1X guest VLAN as an
untagged member.

Configuration guidelines

o The 802.1X guest VLANs on different ports can be different.

e Assign different IDs to the port VLAN and the 802.1X guest VLAN on a port, so the port can
correctly process incoming VLAN tagged traffic.

e With 802.1X authentication, a hybrid port is always assigned to a VLAN as an untagged member.
After the assignment, do not reconfigure the port as a tagged member in the VLAN.

e Use Table 106 when you configure multiple security features on a port.
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Table 106 Relationships of the 802.1X guest VLAN and other security features

Feature Relationship description

Only the 802.1X guest VLAN take effect. A user that
fails MAC authentication will not be assigned to the
MAC authentication guest VLAN.

MAC authentication guest VLAN on a port that
performs MAC-based access control

802.1X Auth-Fail VLAN on a port that performs

MAC-based access control The 802.1X Auth-Fail VLAN has a higher priority.

The 802.1X guest VLAN function has higher priority
Port intrusion protection on a port that performs  than the block MAC action, but it has lower priority
MAC-based access control than the shutdown port action of the port intrusion
protection feature.

Configuring an Auth-Fail VLAN

Configuration prerequisites

e Create the VLAN to be specified as the 802.1X Auth-Fail VLAN.

o Ifthe 802.1X-enabled port performs MAC-based access control, configure the port as a hybrid port,
enable MAC-based VLAN on the port, and assign the port to the Auth-Fail VLAN as an untagged
member.

Configuration guidelines

e The 802.1X Auth-Fail VLANs on different ports can be different.

e Assign different IDs to the port VLAN and the 802.1X Auth-Fail VLAN on a port, so the port can
correctly process VLAN tagged incoming traffic.

e Use Table 107 when configuring multiple security features on a port.

Table 107 Relationships of the 802.1X Auth-Fail VLAN with other features

Feature Relationship description

MAC authentication guest VLAN on a port that

performs MAC-based access control The 802.1X Auth-Fail VLAN has a high priority.

The 802.1X Auth-Fail VLAN function has higher priority
Port intrusion protection on a port that performs  than the block MAC action, but it has lower priority
MAC-based access control than the shutdown port action of the port intrusion
protection feature.

802.1X configuration examples

MAC-based 802.1X configuration example

Network requirements

As shown in Figure 312, the access device performs 802.1X authentication for users that connect to port
Ethernet 1/0/1. Implement MAC-based access control on the port, so the logoff of one user does not
affect other online 802.1X users. Enable periodic re-authentication of online users on the port, so that the
server can periodically update the authorization information of the users.
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Use RADIUS servers to perform authentication, authorization, and accounting for the 802.1X users. If

RADIUS accounting fails, the access device logs the user off. The RADIUS servers run CAMS or IMC.

Configure the host at 10.1.1.1 as the primary authentication and secondary accounting servers, and the
host at 10.1.1.2 as the secondary authentication and primary accounting servers. Assign all users to the
ISP domain fest.

Configure the shared key as name for packets between the access device and the authentication server,
and the shared key as money for packets between the access device and the accounting server.

Exclude the ISP domain name from the username sent to the RADIUS servers.

Specify the device to try up to 5 times at an interval of 5 seconds in transmitting a packet to the RADIUS
server until it receives a response from the server, and to send real time accounting packets to the
accounting server every 15 minutes.

Figure 312 Network diagram

Vlan-int2
1_1_1_1/24@ ¥ 10.1.1.1
10.1.1.2
Eth1/0/1
Supplicant Authenticator Authentication servers
1.1.1.10/24 (Switch) (RADIUS server cluster)

Configuring IP addresses

# Assign an IP address to each interface as shown in Figure 312. Make sure the supplicant, switch, and
servers can reach each other. (Details not shown.)

Configuring the RADIUS servers

For more information about the RADIUS configuration, see "Configuring RADIUS."
Configuring 802.1X for the switch

1. Configure global 802.1X:

a. From the navigation tree, select Authentication > 802.1X.
b. Select Enable 802.1X, select the authentication method as CHAP, and click Apply.

Figure 313 Configuring 802.1X globally

8021 Configuration
Enable 802.13%

Authentication Method | CHAP “
b Advanced

Apply

Ports With 802.1% Enabled

k=X

FPort - Guest  Auth-Fail Fort )
O Pl control TANISNAKE ) entication ;“:,"'U”;befsr WLAM  WLAM  Authorization OPEration
Add Del Selected
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2.  Configure 802.1X for Ethernet 1/0/1:
a. In the Ports With 802.1X Enabled areq, click Add.
b. Select Ethernet1/0/1 from the Port list, select Enable Re-Authentication, and click Apply.

Figure 314 Configuring 802.1X for Ethernet 1/0/1

Apply 802.1X Port Configuration

Port Ethernet1/0/1 -
Port Control MAC Based A
Port Authorization Auto ¥

Max Mumber of Users 256  #(1-256, Default = 256)

& Enable Handshake

| & Enable Re-Authentication
Guest VLAN (1-4094)
Auth-Fail VLAN (1-4094)

ltems marked with an asterisk(*) are required

Apply Cancel

Configuring the RADIUS scheme for the switch

1. Configure authentication and accounting attributes for the RADIUS scheme:
a. From the navigation tree, select Authentication > RADIUS, and click Add.
b. Enter the scheme name system.

c. Select the server type Extended, and select Without domain name from the Username Format
list.

Click Advanced.

Enter name in the Authentication Key and Confirm Authentication Key fields.

o

Enter money in the Accounting Key and Confirm Accounting Key fields.

Enter 5 as the server timeout timer.

@ ™9

Enter 5 as the maximum number of request fransmission attempts.

Enter 15 as the realtime accounting interval.
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Figure 315 Configuring the RADIUS scheme

Add RADIUS Scheme

Scheme Mame

Server Type

Username Farmat
widvanced

Authentication key

Accounting Key

common Configuration

Confirm Accounting Key

Confirm Authentication Key

system "(1-32 Chars.)

Extended v

Without domain name %

Ty (1-64 Chars)
seaw (1-64 Chars))
sewew (1-64 Chars)
ceere (1-64 Chars)

Quiet Time

Minutes(0-255. Default= 5)

Server Response Timeout Time
Reguest Transmission Attempts

Realtime Accounting Interval

5 Secondsi1-10. Default= 3)
5 (1-20. Default= 3}
15 Minute g(0-60. Default= 12, must be a multiple of 3.)

Realtime Accounting Attempts

Unit for Data Flows
Unit for Packets

Security Palicy Server

RADILS Packet Source IP & 1Pvd O IPvE

Stop-Accounting Attempts

O

Attribute

RADILS Server Configuration

(1-255. Default=5)

Byte v

Orne-packet v

Buffer stop-accounting packets

(10-65535. Default= 500)

Send accounting-on packets

Interpretation

Server Type IP Address Fort Cperation
Primary Authentication 101141 1812 m
Backup Authentication 10112 1812 m
Primary Accounting 10112 1813 i
Backup Accounting 101141 1813 m
Add

lterns marked with an asterisk(*) are required

Apply Cancel

Configure the primary authentication server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.
b. Select the server type Primary Authentication.

c. Enter the IP address 10.1.1.1, and enter the port number 1812.
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d.

Click Apply.
The RADIUS Server Configuration area displays the primary authentication server you have
configured.

3. Configure the backup authentication server in the RADIUS scheme:

a.
b.
c.

d.

In the RADIUS Server Configuration area, click Add.

Select the server type Backup Authentication.

Enter the IP address 10.1.1.2, and enter the port number 1812.
Click Apply.

The RADIUS Server Configuration area displays the backup authentication server you have
configured.

4.  Configure the primary accounting server in the RADIUS scheme:

a.
b.
c.

d.

In the RADIUS Server Configuration areq, click Add.

Select the server type Primary Accounting.

Enter the IP address 10.1.1.2, and enter the port number 1813.
Click Apply.

The RADIUS Server Configuration area displays the accounting server you have configured.

5.  Configure the secondary accounting server in the RADIUS scheme:

a.
b.
c.

d.

In the RADIUS Server Configuration areq, click Add.

Select the server type Backup Accounting.

Enter the IP address 10.1.1.1, and enter the port number 1813.
Click Apply.

The RADIUS Server Configuration area displays the backup accounting server you have
configured.

6. On the RADIUS configuration page, click Apply.

Configuring AAA for the scheme

1. Create an ISP domain:

a.

From the navigation tree, select Authentication > AAA.

The Domain Setup page appears.

Select test from the Domain Name list, and select Enable from the Default Domain list.
Click Apply.
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Figure 316 Creating an ISP domain

Authentication Authorization Accounting
ISP Domain
Darmain Marne |test |V i(1 - 24 Chars))
Default Damain | Enable V|

Apply

FPlease selectthe ISP domain(s)

Domain Mame Default Domain

2. Configure AAA authentication method for the ISP domain:
a. Click the Authentication tab.
b. Select test from the Select an ISP domain list.

c. Select Default AuthN, select authentication method RADIUS from the Default AuthN list, and
select the authentication scheme system from the Name list, as shown in Figure 317.

Figure 317 Configuring AAA authentication method for the ISP domain

Domain Setup Authorization Accounting

Authentication Configuration of AA4

Select an ISP domain test -
Default AuthM RADIUS + Mame system - Secondary Method -
[ LAN-access Authi Mame Secondary Method
[ Login AuthM Name Secondary Method

PPP AuthM Mame Secondary Method

Portal suthi MName Secondary Method

Apply
d. Click Apply.

A configuration progress dialog box appears, as shown in Figure 318.
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Figure 318 Configuration progress dialog box

Current Configuration
Setting Default Auth™ - K]

100%

Close

e. After the configuration process is complete, click Close.
Configure AAA authorization method for the ISP domain:
a. Click the Authorization tab.

b. Select test from the Select an ISP domain list.

c. Select Default AuthZ, select the authorization method RADIUS from the Default AuthZ list, and
select the authorization scheme system from the Name list, as shown in Figure 319.

Figure 319 Configuring the AAA authorization method for the ISP domain

Domain Setup Authentication Accounting

Authorization Configuration of AA&

Selectan ISP domain ~ test -
Default AuthZ RADIUS = MName system - Secondary Method -
[T LAMN-access AuthZ Name Secondary Method
[T Login Authz Name Secondary Method

PPP AuthZ Name Secondary Method

Portal AuthZ Name Secondary Method

Command AuthZ Name

Apply
d. Click Apply.

A configuration progress dialog box appears.
e. After the configuration process is complete, click Close.
Configure AAA accounting method for the ISP domain:
a. Click the Accounting tab.
b. Select test from the Select an ISP domain list.

c. Select Default Accounting, select the accounting method RADIUS as the default accounting
method, and select the accounting scheme system from the Name list, as shown in Figure 320.
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Figure 320 Configuring the AAA accounting method for the ISP domain

Domain Setup Authentication Authorization

Accounting Configuration of A&

Selectan ISP domain  test
[7] Accounting Optional Disable
Default Accounting RADIUS = MName system - | Secondary Method -
[7] LAN-access Accounting Name Secondary Method
[T Login Accounting Name Secondary Method

PPP Accounting MName Secondary Method

Portal Accounting MName Secondary Method

Apply
d. Click Apply.

e. After the configuration process is complete, click Close.

802.X with ACL assignment configuration example

Network requirements

As shown in Figure 321, perform 802.1X authentication on port Ethernet 1/0/1. Use the RADIUS server
at 10.1.1.1 as the authentication and authorization server and the RADIUS server at 10.1.1.2 as the

accounting server. Assign an ACL to Ethernet 1/0/1 to deny the access of 802.1X users to the FTP server
at 10.0.0.1/24.

Figure 321 Network diagram

Authentication servers
5 (RADIUS server cluster)

I

i

Vlan-int2
192.168.1.1/24
Internet
Eth1/0/1
Host Switch FTP server
192.168.1.10 10.0.0.1
Configuring IP addresses
# Assign an IP address to each interface as shown in Figure 321. (Details not shown.)

Configuring a RADIUS scheme

1. Create a RADIUS scheme:
a. From the navigation tree, select Authentication > RADIUS, and then click Add.
b. Enter the scheme name system.

c. Select the server type Extended.
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d. Select Without domain name from the Username Format list.

e. Click Apply.

Configure the primary authentication server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.

b. Select the server type Primary Authentication.

c. Enter the IP address 10.1.1.1, and enter the port number 1812.
d. Enter expert in the Key and Confirm Key fields.

e. Click Apply.

Figure 322 Configuring the RADIUS authentication server

Add RADIUS Server

Server Type |F'rimar§,r Authenticatio V|
IP address @ 1Pva O IPve 10.1.1.1 b
Port [1812 (1-65535. Default= 1812)
Key eecaee (1-64 Chars)
confirm Key |.nnn |(1-E4 Chars.)
Apply Cancel

Configure the primary accounting server in the RADIUS scheme:

a. In the RADIUS Server Configuration areq, click Add.

b. Select the server type Primary Accounting.

c. Enter the IP address 10.1.1.2, and enter the port number 1813.
d. Enter expert in the Key and Confirm Key fields.

Figure 323 Configuring the RADIUS accounting server

Add RADIUS Server

Server Type |F'rimary Accounting V|
IP Address @ 1P O IPv6 |10.1.1.2 -
Part 1813 (1-65536. Default= 1813)
Key |""" |(1—E4 Chars.)
Confirm Key |u-nn |(1-54 Chars)
Apply Cancel

e. Click Apply.

The RADIUS Server Configuration area displays the accounting server you have configured, as
shown in Figure 324.
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Figure 324 Configuring the RADIUS scheme

Add RADILS Scheme

Scheme MName |system |*(1-32 Chars.)

Common Configuration

Server Type |E}{tended V|
Usernatme Format |Withnut damain narne V|
F Advanced

RADIUS Server Configuration

Server Type P Address Fort Operation
Primary
Authentication 10.1.1.1 1812 m
Primary Accounting 10.1.1.2 1813 m
Add

tems marked with an asterisk{® are required

Apply cCancel

4. Click Apply.
Configuring AAA
1. Create an ISP domain:
a. From the navigation tree, select Authentication > AAA.
The Domain Setup page appears.

b. Enter test from the Domain Name list, and select Enable from the Default Domain list.

c. Click Apply.
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Figure 325 Creating an ISP domain

Authentication Autharization Accounting
ISP Diomain
Daomain Marne |test |V i(1 - 24 Chars )
Default Domain |Enab|e V|

Apply

Please selectthe ISP domainis)

Domain Mame Default Domain

2. Configure AAA authentication method for the ISP domain:
a. Click the Authentication tab.
b. Select test from the Select an ISP domain list.

c. Select Default AuthN, select RADIUS as the default authentication method, and select the
authentication scheme system from the Name list, as shown in Figure 326.

Figure 326 Configuring the AAA authentication method for the ISP domain

Domain Setup Authorization Accounting

Authentication Configuration of AAA

Selectan ISP domain  test  «
Default AuthM RADIUS ~ MName system - Secondary Method -
[T LAM-access Authi Name Secondary Method
[T Login AuthN Name Secondary Method

PPP AuthM Mame Secondary Method

Portal AuthM Name Secondary Method

Apply
d. Click Apply.

A configuration progress dialog box appears, as shown in Figure 327.
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e. After the configuration process is complete, click Close.
Configure AAA authorization method for the ISP domain:
a. Click the Authorization tab.

b.

C.

Figure 327 Configuration progress dialog box

Current Configuration

Setting Default Authi - OKI

100%

Close

Select test from the Select an ISP domain list.

Select Default AuthZ, select RADIUS as the default authorization method, and select the

authorization scheme system from the Name list, as shown in Figure 328.

Figure 328 Configuring the AAA authorization method for the ISP domain

Domain Setup Authentication Accounting
Authorization Configuration of AAA
Select an ISP domain test -
Default AuthZ RADIUS ~ MName system
[C]LAN-access AuthZ Mame
[ Login AuthZ Mame
PPP AuthZ Name
Portal AuthZ Name
Command AuthZ Mame

d.
e. After the configuration process is complete, click Close.
Configure AAA accounting method for the ISP domain:

a. Click the Accounting tab.

b.

C.

- Secondary Method

Click Apply.

Select test from the Select an ISP domain list.

Select Accounting Optional and select Enable from the list.

Select Default Accounting, select the accounting method RADIUS, and select the accounting

scheme system from the Name list.

Click Apply.
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Figure 329 Configuring the AAA accounting method for the ISP domain

Dlomain Setup Authentication

Accounting Configuration of A&

Authorization

Select an I5F domain test -
[7] Accounting Optional Disable
Default Accounting RADIUS * MName system -
[7] LAM-access Accounting Mame
[7] Login Accounting Mame
PPP Accounting Mame
Mame

Portal Accounting

f.  After the configuration process is complete, click Close.

Configuring an ACL

1. From the navigation tree, select QoS > ACL IPv4.

2. Click the Add tab.

3. Enter the ACL number 3000, and click Apply.

Figure 330 Creating ACL 3000

Summary Basic Setup

Advanced Setup Link Layer Setup

ACL Nurmber (3000

3000-3999 for adva

Match Qrder Config »

Secondary Method
Secondary Method
Secondary Method
Secondary Method

Secondary Method

Remove

2000-29949 for basic ACLs.

nced ACLs.

4000-49949 far Ethernet frame header ACLs.

Description

Characters(0-127)

ACL Mumhber Type Mumhber of Rules tatch Crder

4. Click the Advanced Setup tab.

5.  Configure the following parameters:

a. Select 3000 from the ACL list.

b. Select Rule ID, enter the rule ID 0, and select the action Deny.
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c. Inthe IP Address Filter areq, select Destination IP Address:
—  Enter 10.0.0.1 as the destination IP address.
—  Enter 0.0.0.0 as the destination IP address wildcard.

d. Click Add.
Figure 331 ACL rule configuration

Summary Add Basic Setup Link Layer Setup Remaove

ACL| 3000 “ Help

Configure an Advanced ACL

[“IRule 1D |D (0-65534, Ifno 1D is entered, the system will specify one.)
[ ron-first Fragrments Only CLogying

IP Address Filter

[Jsource IP Address | | Saurce Wildcard | |

‘ [7] Destination IP Address | 10.0.0.1 | Destination Wildcard |0,0.0.0 | ‘

Protacol [P ]

ICHMP Type
ICMP Messange

ICMP Type (0-255) ICMP Code (0-255)

TCRJDP Port
TCF Connection

Established
Source; Operation F'Drt| | | |
Destination: Operation F'ort| | | |

(Range of Portis D-65535)

Frecedence Filtar

DSCP | Mot Check |
TOS | Mot Check v Precedence] Mot Check |
[ITime Range
Add
Rule ID Operation Description Tirme Rat
Configuring 802.1X

1. Configure 802.1X globally:
a. From the navigation tree, select Authentication > 802.1X.

b. Select Enable 802.1X.
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c. Select the authentication method CHAP.
d. Click Apply.

Figure 332 Configuring 802.1X globally

2021 Configuration
Enahle 802.1X

Authentication Method | CHAP v|
b Advanced

Apply

Ports With 802.1% Enabled

[LEF :
Part Fe- Guest  Auth-Fail Fart )
O P Control ANGSNAKE 4 o ntication MUTHEN g AN WLAN Authorization ©PEFEHON
of Lzers
Add Del Selected

2.  Configure 802.1X for Ethernet 1/0/1:
a. In the Ports With 802.1X Enabled areq, click Add.

b. Select Ethernet1/0/1 from the Port list.
c. Click Apply.

Figure 333 Configuring 802.1X for Ethernet 1/0/1

Apply 302.1X Port Configuration

Paort Ethemnet1/0/1 hd
Port Control MAC Based A
Port Authorization Auto

Max Mumber of Users 256 *(1-256, Default = 256)

Enable Handshake

[l Enable Re-Authentication
Guest VLAN (1-4094)
Auth-Fail VLAM (1-4094)

ltems marked with an asterisk(*) are required
Verifying the configuration

After the user passes authentication and gets online, use the ping command to test whether ACL 3000
takes effect.

1. From the navigation tree, select Network > Diagnostic Tools.
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The ping page appears.
Enter the destination IP address 10.0.0.1.
Click Start.

Figure 334 shows the ping operation summary.
Figure 334 Ping operation summary

Summary

PING 1l0.0.0.1: 56 data bytes
Fequest time out
Fequest time out
Fequest time out
Fequest time out
Fequest time out

--- 10.0.0,1 ping statistics ---
5 packet(s) transmitted
0 packetis) receiwved
100.00% packet lozz
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Configuring AAA

Overview

AAA

Authentication, Authorization, and Accounting (AAA) provides a uniform framework for implementing
network access management. It provides the following security functions:

e  Avuthentication—Identifies users and determines whether a user is valid.

e Authorization—Grants user rights and controls user access to resources and services. For example,
a user who has successfully logged in to the device can be granted read and print permissions to
the files on the device.

e Accounting—Records all network service usage information, including service type, start time, and
traffic. The accounting function provides information required for charging, and allows for network
security surveillance.

application

AAA typically uses a client/server model, as shown in Figure 335. The client runs on the network access
server (NAS), which is also called the access device. The server maintains user information centrally. In
an AAA network, the NAS is a server for users but a client for AAA servers.

Figure 335 AAA application scenario

=S Internet

e

NAS RADIUS server 1

_‘

RADIUS server 2

The NAS uses the authentication server to authenticate any user who tries to log in, use network resources,
or access other networks. The NAS transparently transmits authentication, authorization, and accounting
information between the user and the servers. The RADIUS protocol defines how a NAS and a remote
server exchange user information.

The network shown in Figure 335 contains two RADIUS servers. You can choose different servers to
implement different security functions. For example, you can use RADIUS server 1 for authentication and
authorization, and RADIUS server 2 for accounting.

You can implement any of the three security functions provided by AAA as needed. For example, if your
company wants employees to be authenticated before they access specific resources, configure an
authentication server. If network usage information is needed, you must also configure an accounting
server.
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AAA can be implemented through multiple protocols. The device supports RADIUS, which is most often
used. For more information about RADIUS, see "Configuring RADIUS."

Domain-based user management

A NAS manages users based on ISP domains. On a NAS, each user belongs to one ISP domain. A NAS
determines the ISP domain for a user by the username entered by the user at login. For a username in the
userid@isp-name format, the access device considers the userid part the username for authentication and
the isp-name part the ISP domain name.

In a networking scenario with multiple ISPs, a NAS can connect users of different ISPs. Different ISP users
can have different user attributes (such as username and password structure), different service type, and
different rights. To manage these ISP users, you need to create ISP domains and then configure AAA
methods and domain attributes for each ISP domain

On the NAS, each user belongs fo an ISP domain. If a user provides no ISP domain name at login, the
NAS considers the user belongs to the default ISP domain.

AAA allows you to manage users based on their access types:

e LAN users—Users on a LAN who must pass 802.1X or MAC address authentication to access the
network.

e Login users—Users who want fo log in to the device, including SSH users, Telnet users, Web users,
FTP users, and terminal users.

In addition, AAA provides command authorization for login users to improve device security. Command
authentication enables the NAS to defer to the authorization server to determine whether a command
entered by a login user is permitted for the user, and allows login users to execute only authorized
commands.

Contiguration prerequisites

To deploy local authentication, configure local users on the access device. See "Configuring users."

To deploy remote authentication, authorization, or accounting, configure the RADIUS schemes to be
referenced. See "Configuring RADIUS."

Recommended configuration procedure

Step Remarks

Optional.

Create ISP domains and specify one of them as the default ISP
1. Configuring an ISP domain domain.

By default, there is an ISP domain named system, which is the default
ISP domain.

Optional.
2. Configuring authentication

methods for the ISP domain Configure authentication methods for various types of users.

By default, all types of users use local authentication.
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Step Remarks

Optional.
3. Configuring authorization

methods for the ISP domain Specify the authorization methods for various types of users.

By default, all types of users use local authorization.

Required.
4. Configuring accounting methods

for the ISP domain Specify the accounting methods for various types of users.

By default, all types of users use local accounting.

Contiguring an ISP domain

1. Select Authentication > AAA from the navigation tree.
The Domain Setup page appears.
Figure 336 Domain Setup page

Authentication Authorization Accounting
ISP Damain
Damain Marme ¥ |{1-24 Chars)
Default Domain | Disable M

Please selectthe ISP damainds)

Domain Mame Default Domain

2. Create an ISP domain, as described in Table 108.
3. Click Apply.

Table 108 Configuration items

ltem Description

Enter the ISP domain name, which is for identifying the domain.

Domain Name You can enter a new domain name to create a domain, or specify an existing domain
to change its status (whether it is the default domain).
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ltem Description

Specify whether to use the ISP domain as the default domain. Options include:
e Enable—Uses the domain as the default domain.
Default Domain e Disable—Uses the domain as a non-default domain.

There can only be one default domain at a time. If you specify another domain as the
default domain, the original default domain becomes a non-default domain.

Contiguring authentication methods for the ISP domain

Select Authentication > AAA from the navigation tree.
2. Click the Authentication tab.
Figure 337 Authentication method configuration page
Domain Setup Authorization Accounting

Authentication Configuration of AAA

Select an ISP domain system -
Default AuthiM Local Mame Secondary Method
LAM-access Authi MName Secondary Method
Login AuthM MName Secondary Method
PPP AuthM Name Secondary Method
Portal AuthM Name Secondary Method

3. Select the ISP domain and specify authentication methods for the domain, as described in Table
109.

4. Click Apply.
Table 109 Configuration items

ltem Description

Select an ISP domain  Select the ISP domain for which you want to specify authentication methods.

Configure the default authentication method and secondary authentication method for
all types of users.
Options include:

Default AuthN o HWTACACS—HWTACACS authentication. You must specify the HWTACACS

scheme to be used.
Name

Secondary Method

¢ local—Local authentication.
None—No authentication. This method trusts all users and is not for general use.
e RADIUS—RADIUS authentication. You must specify the RADIUS scheme to be used.

e Not Set—The device uses the default authentication setting, which is local
authentication.
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ltem Description

Configure the authentication method and secondary authentication method for LAN
access users.

LAN-access AuthN Options include:

e Local—Local authentication.
Name

e None—No authentication. This method trusts all users and is not for general use.
Secondary Method

e RADIUS—RADIUS authentication. You must specify the RADIUS scheme to be used.

o Not Set—The device uses the settings in the Default AuthN area for LAN access
users.

Configure the authentication method and secondary authentication method for login
users.

Options include:

Login AuthN e HWTACACS—HWTACACS authentication. You must specify the HWTACACS
Name scheme to be used.
Secondary Method e Local—Local authentication.

e None—No authentication. This method trusts all users and is not for general use.
e RADIUS—RADIUS authentication. You must specify the RADIUS scheme to be used.
o Not Set—The device uses the settings in the Default AuthN area for login users.

Configuring authorization methods for the ISP domain

1. Select Authentication > AAA from the navigation tree.
2. Click the Authorization tab.
Figure 338 Authorization method configuration page
Domain Setup Authentication Accounting

Authorization Configuration of AAA

Select an ISP domain system -

[7] Default AuthZ Local Mame Secondary Method

] LAN-access AuthZ MName Secondary Method

[T Login AuthZ Mame Secondary Method
PPP AuthZ Name Secondary Method
Portal AuthZ MName Secondary Method
Command AuthZ MName

3. Selectthe ISP domain and specify authorization methods for the ISP domain, as described in Table

110.
4. Click Apply.
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Table 110 Configuration items

ltem

Description

Select an ISP domain

Select the ISP domain for which you want to specify authentication methods.

Default AuthZ
Name

Secondary Method

Configure the default authorization method and secondary authorization method for
all types of users.

Options include:

e HWTACACS—HWTACACS authorization. You must specify the HWTACACS
scheme to be used.

e Llocal—Local authorization.
e None—This method trusts all users and assigns default rights to them.
e RADIUS—RADIUS authorization. You must specify the RADIUS scheme to be used.

e Not Set—The device uses the default authorization setting, which is local
authorization.

LAN-access AuthZ
Name

Secondary Method

Configure the authorization method and secondary authorization method for LAN
access users.

Options include:

¢ Local—Local authorization.

e None—This method trusts all users and assigns default rights to them.

e RADIUS—RADIUS authorization. You must specify the RADIUS scheme to be used.

o Not Set—The device uses the settings in the Default AuthZ area for LAN access
users.

Login AuthZ
Name

Secondary Method

Configure the authorization method and secondary authorization method for login
users.

Options include:

o HWTACACS—HWTACACS authorization. You must specify the HWTACACS
scheme to be used.

¢ local—Local authorization.

e None—This method trusts all users and assigns default rights to them.

e RADIUS—RADIUS authorization. You must specify the RADIUS scheme to be used.
o Not Set—The device uses the settings in the Default AuthZ area for login users.

Contfiguring accounting methods for the ISP domain

1. Select Authentication > AAA from the navigation tree.

2. Click the Accounting tab.
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Figure 339 Accounting method configuration page
Domain Setup Authentication Authorization

Accounting Configuration of AAA&

Selectan ISP domain system =
Accounting Optional Disable
Default Accounting Local Name Secondary Method
LAM-access Accounting Name Secondary Method
Login Accounting MName Secondary Method
PPP Accounting MName Secondary Method
Portal Accounting Name Secondary Method

3. Select the ISP domain and specify accounting methods for the ISP domain, as described in Table
111.

4. Click Apply.

Table 111 Configuration items

ltem Description

Select an ISP domain Select the ISP domain for which you want to specify authentication methods.

Specify whether to enable the accounting optional feature.

The feature enables a user who would otherwise be disconnected to use network
resources even if there is no accounting server available or communication with the

Accounting Optional . .
current accounting server fails.

If accounting for the user fails, the device no longer sends real4ime accounting
updates for the user.

Configure the default accounting method and secondary accounting method for all
types of users.
Options include:

e  HWTACACS—HWTACACS accounting. You must specify the HWTACACS

Default Accounting
scheme to be used.

Name

¢ Local—Local accounting.
Secondary Method

e None—No accounting.
e RADIUS—RADIUS accounting. You must specify the RADIUS scheme to be used.

o Not Set—The device uses the default accounting setting, which is local
accounting.

Configure the accounting method and secondary accounting method for LAN
access users.

LAN-access Accounting Options include:

e Local—Local accounting.
Name

None—No accounting.
Secondary Method

RADIUS —RADIUS accounting. You must specify the RADIUS scheme to be used.

o Not Set—The device uses the settings in the Default Accounting area for LAN
access users.
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ltem Description

Configure the accounting method and secondary accounting method for login users.

Options include:
o HWTACACS—HWTACACS accounting. You must specify the HWTACACS

Login Accounting scheme to be used.
Name e Local—Local accounting.
Secondary Method e None—No accounting.

e RADIUS—RADIUS accounting. You must specify the RADIUS scheme to be used.

o Not Set—The device uses the settings in the Default Accounting area for login
users.

AAA contiguration example

Network requirements

As shown in Figure 340, configure the switch to perform local authentication, authorization, and
accounting for Telnet users.

Figure 340 Network diagram

Vlan-int2
192.168.1.1/24 (_§_,
Eth1/0/1

Telnet user
192.168.1.12/24

Internet

Configuration procedure

1. Enable the Telnet server function, and configure the switch to use AAA for Telnet users. (Details not
shown.)

Configure IP addresses for the interfaces. (Details not shown)
Configure a local user:

a. Select Device > Users from the navigation tree.

Click the Create tab.

s

Enter the username telnet.

Select the access level Management.

Enter the password abed and confirm the password.
Select the password encryption method Irreversible.
Select the service type Telnet Service.

Click Apply.

ma@ ™9 oo
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Figure 341 Configuring a local user
Summary Super Password Modify Remove Switch To Management

Create User

Username telnet I (1-55 Chars ) Access Level Management
Password sene (1-63 Chars.) Confirm Password sene

Password Encryption (7 Reversible @ Irreversible

Senvice Type [Flweb [CIFTP [ Telnet

Apply

Summary

Username Bccess Lewel Service Type

admin Management Web

Note: Username cannot contain Chinese characters and any of the following characters / \ : | 8 *+ 2 " < > ' % & #

4.  Configure ISP domain test:
a. Select Authentication > AAA from the navigation tree.
The domain configuration page appears.
b. Enter the domain name test.

c. Click Apply.
Figure 342 Configuring ISP domain test

Authentication Authorization Accounting
ISP Diomain
Darnain Marne |test |V i(1 - 24 Charg.)
Default Domain |Disah|e V|

Apply

Flease zelectthe ISP damaings)

Daomain Mame Default Damain

5. Configure the ISP domain to use local authentication:
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. Select Authentication > AAA from the navigation tree.
b.
c.

d.

Click the Authentication tab.
Select the domain test.

Select Login AuthN and select the authentication method Local.

Figure 343 Configuring the ISP domain to use local authentication

Domain Setup Authorization Accounting

Authentication Configuration of AAA

e.

f.

|Selectan ISP domain  test

[7] Default AuthM Local Name Secondary Method

[ LAM-access AuthM MName Secondary Method

|L0gin AuthM Local ~| Mame Secondary Method
PPP Authh MName Secondary Method
Portal Authi Mame Secondary Method

Apply
Click Apply.

A configuration progress dialog box appears, as shown in Figure 344.

Atter the configuration process is complete, click Close.

Figure 344 Configuration progress dialog box

Current Canfiguration

Setting Login Authi - QK

100%

Close

Configure the ISP domain to use local authorization:

a.
b.

C.

Select Authentication > AAA from the navigation tree.

Click the Authorization tab.

Select the domain test.

Select Login AuthZ and select the authorization method Local.
Click Apply.

A configuration progress dialog box appears.

After the configuration progress is complete, click Close.
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Figure 345 Configuring the ISP domain to use local authorization

Domain Setup Authentication Accounting

Authorization Configuration of AAA

|Se|ect an ISP domain test -

[7] Default AuthZ Local MName Secondary Method

[ LAM-access AuthZ Mame Secondary Method

|L0gin.ﬂ\uth2 Local = | Mame Secondary Method
PPP AuthZ Mame Secondary Method
Portal AuthZ Name Secondary Method
Command AuthZ MName

7.  Configure the ISP domain to use local accounting:
a. Select Authentication > AAA from the navigation tree.
b. Click the Accounting tab.
c. Select the domain test.
d. Select Login Accounting and select the accounting method Local.
e. Click Apply.
A configuration progress dialog box appears.

f.  After the configuration process is complete, click Close.
Figure 346 Configuring the ISP domain to use local accounting

Domain Setup Authentication Authorization

Accounting Configuration of AAA

|Se|ect an ISP domain test -

[7] Accounting Optional Disable
[] Default Accounting Local MName Secondary Method
[7]LAN-access Accounting MName Secondary Method
| [#] Login Accounting Local -| Name Secondary Method
PPP Accounting MName Secondary Method
Partal Accounting MName Secondary Method

Verifying the configuration

Telnet to the switch and enter the username telnet@test and password abed. You will be serviced as a
user in domain fest.
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Configuring RADIUS

Overview

Remote Authentication Dial-ln User Service (RADIUS) is a distributed information interaction protocol that
uses a client/server model fo implement AAA. It can protect networks against unauthorized access and
is often used in network environments that require both high security and remote user access. For more
information about AAA, see "Configuring AAA."

RADIUS uses UDP port 1812 for authentication and UDP port 1813 for accounting.

RADIUS was originally designed for dial-in user access. With the addition of new access methods,
RADIUS has been extended to support additional access methods, including Ethernet and ADSL.
RADIUS provides access authentication, authorization, and accounting services. The accounting function
collects and records network resource usage information.

Client/server model

RADIUS clients run on NASs located throughout the network. NASs pass user information to RADIUS
servers, and determine to reject or accept user access requests depending on the responses from RADIUS
servers.

The RADIUS server runs on the computer or workstation at the network center and maintains information
related to user authentication and network service access. It receives connection requests, authenticates
users, and returns access control information (for example, rejecting or accepting the user access request)
to the clients.

The RADIUS server typically maintains the following databases: Users, Clients, and Dictionary.
See Figure 347.

Figure 347 RADIUS server databases

RADIUS servers

Users Clients Dictionary

e Users—Stores user information such as usernames, passwords, applied protocols, and IP
addresses.

o Clients—Stores information about RADIUS clients, such as shared keys and IP addresses.

e Dictionary—Stores RADIUS protocol attributes and their values.
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Security and authentication mechanisms

The RADIUS client and the RADIUS server use a shared key to authenticate RADIUS packets and encrypt
user passwords exchanged between them. For security, this key must be manually configured on the
client and the server.

RADIUS servers support multiple authentication protocols, including PPP PAP and CHAP. A RADIUS

server can act as the client of another AAA server to provide authentication proxy services.

Basic RADIUS message exchange process

Figure 348 illustrates the interactions between the host, the RADIUS client, and the RADIUS server.

Figure 348 Basic RADIUS message exchange process

Host RADIUS client RADIUS server

N =

1) Username and password

\ 4

2) Access-Request

\

3) Access-Accept/Reject

A

4) Accounting-Request (start)

\

5) Accounting-Response

-t
-«

< 6) The host accesses the resources

7) Accounting-Request (stop)

Y

8) Accounting-Response

A

9) Notification of access termination

-t
-

RADIUS operates in the following manner:

1.

The host initiates a connection request that carries the user's username and password to the

RADIUS client.

Having received the username and password, the RADIUS client sends an authentication request
(Access-Request) to the RADIUS server, with the user password encrypted using the MD5 algorithm
and the shared key.

The RADIUS server authenticates the username and password. If the authentication succeeds, the
server returns an Access-Accept message containing the user's authorization information. If the
authentication fails, the server returns an Access-Reject message.

The RADIUS client permits or denies the user according fo the returned authentication result. If it
permits the user, it sends a start-accounting request (Accounting-Request) to the RADIUS server.

The RADIUS server returns an acknowledgement (Accounting-Response) and starts accounting.

The user accesses the network resources.
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7.  The host requests the RADIUS client to tear down the connection and the RADIUS client sends a
stop-accounting request (Accounting-Request) to the RADIUS server.

8.  The RADIUS server returns an acknowledgement (Accounting-Response) and stops accounting for
the user.

RADIUS packet format

RADIUS uses UDP to transmit messages. To ensure smooth message exchange between the RADIUS
server and the client, RADIUS uses a timer management mechanism, a retransmission mechanism, and
a backup server mechanism. Figure 349 shows the RADIUS packet format.

Figure 349 RADIUS packet format

0 7 15 31

Code Identifier Length

Authenticator

Attributes

The following describes the fields of a RADIUS packet:
e The Code field (1 byte long) indicates the type of the RADIUS packet.

Table 112 Main values of the Code field

Code  Packet type Description

From the client to the server. A packet of this type carries user
information for the server to authenticate the user. It must contain the
User-Name attribute and can optionally contain the attributes of
NAS-IP-Address, User-Password, and NAS-Port.

1 Access-Request

From the server to the client. If all attribute values carried in the
2 Access-Accept Access-Request are acceptable, the authentication succeeds, and the
server sends an Access-Accept response.

From the server to the client. If any attribute value carried in the
3 Access-Reject Access-Request is unacceptable, the authentication fails, and the
server sends an Access-Reject response.

From the client to the server. A packet of this type carries user
information for the server to start or stop accounting for the user. The
Acct-Status-Type attribute in the packet indicates whether to start or
stop accounting.

4 Accounting-Request

From the server to the client. The server sends a packet of this type to
5 Accounting-Response  notify the client that it has received the Accounting-Request and has
successfully recorded the accounting information.

o The Identifier field (1 byte long) is used to match request packets and response packets and to detect
duplicate request packets. Request and response packets of the same type have the same identifier.
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The Length field (2 bytes long) indicates the length of the entire packet, including the Code,
Identifier, Length, Authenticator, and Attribute fields. Bytes beyond this length are considered
padding and are neglected upon reception. If the length of a received packet is less than this length,
the packet is dropped. The value of this field is in the range 20 to 4096.

The Authenticator field (16 bytes long) is used to authenticate replies from the RADIUS server and to
encrypt user passwords. There are two types of authenticators: request authenticator and response
authenticator.

The Attributes field, variable in length, carries the specific authentication, authorization, and
accounting information that defines the configuration details of the request or response. This field
may contain multiple attributes, each with three sub-fields:

o Type—(1 byte long) Type of the attribute. It is in the range 1 to 255. Commonly used attributes
for RADIUS authentication, authorization and accounting are listed in Table 113.

o length—(1 byte long) Length of the attribute in bytes, including the Type, Length, and Value
fields.

o Value—(Up to 253 bytes) Value of the attribute. lts format and content depend on the Type and
Length fields.

Table 113 Commonly used RADIUS attributes

No. Attribute No. Attribute

1 User-Name 45 Acct-Authentic

2 User-Password 46 Acct-Session-Time

3 CHAP-Password 47 AcctInput-Packets

4 NAS-P-Address 48 Acct-Output-Packets

5 NAS-Port 49 Acct-Terminate-Cause
6 Service-Type 50 Acct-Multi-Session-ld

7 Framed-Protocol 51 Acctlink-Count

8 Framed-IP-Address 52 Acct-Input-Gigawords
9 Framed-IP-Netmask 53 Acct-Output-Gigawords
10 Framed-Routing 54 (unassigned)

11 Filter-ID 55 Event-Timestamp

12 Framed-MTU 56-59 (unassigned)

13 Framed-Compression 60 CHAP-Challenge

14 Login-IP-Host 61 NAS-Port-Type

15 Login-Service 62 Port-Limit

16 Login-TCP-Port 63 Login-LAT-Port

17 (unassigned) 64 Tunnel-Type

18 Reply_Message 65 Tunnel-Medium-Type
19 Callback-Number 66 Tunnel-Client-Endpoint
20 Callback-ID 67 Tunnel-Server-Endpoint
21 (unassigned) 68 Acct-Tunnel-Connection
22 Framed-Route 69 Tunnel-Password
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No. Attribute No. Attribute

23 Framed-IPX-Network 70 ARAP-Password

24 State 71 ARAP-Features

25 Class 72 ARAP-Zone-Access

26 Vendor-Specific 73 ARAP-Security

27 Session-Timeout 74 ARAP-Security-Data

28 Idle-Timeout 75 Password-Retry

29 Termination-Action 76 Prompt

30 Called-Station-ld 77 ConnectInfo

31 Calling-Station-Id 78 Configuration-Token

32 NAS-Identifier 79 EAP-Message

33 Proxy-State 80 Message-Authenticator

34 Login-LAT-Service 81 Tunnel-Private-Group-id

35 Login-LAT-Node 82 Tunnel-Assignment-id

36 Login-LAT-Group 83 Tunnel-Preference

37 Framed-AppleTalk-Link 84 ARAP-Challenge-Response

38 Framed-AppleTalk-Network 85 AcctInterim-Interval

39 Framed-AppleTalk-Zone 86 Acct-Tunnel-Packets-Lost

40 Acct-Status-Type 87 NAS-Port-ld

41 Acct-Delay-Time 88 Framed-Pool

42 AcctInput-Octets 89 (unassigned)

43 Acct-Output-Octets 90 Tunnel-Client-Auth-id

44 Acct-Session-ld 91 Tunnel-Server-Auth-id
NOTE:
This table lists the attribute types, which are defined by RFC 2865, RFC 2866, RFC 2867, and RFC
2568.

Extended RADIUS attributes

Attribute 26 (Vendor-Specific), an attribute defined by RFC 2865 allows a vendor to define extended
attributes to implement functions that the standard RADIUS protocol does not provide.

A vendor can encapsulate multiple sub-attributes as TLVs in attribute 26 to provide extended functions. As
shown in Figure 350, a sub-attribute encapsulated in Attribute 26 consists of the following parts:

e Vendor-ID—ID of the vendor. lts most significant byte is 0. The other three bytes contains a code
that is compliant to RFC 1700.

e Vendor-Type—Type of the sub-attribute.
e Vendor-Length—Length of the sub-attribute.

e  Vendor-Data—Contents of the sub-aftribute.

372



Figure 350 Format of attribute 26

0 7 15 23 31
Type Length Vendor-ID

Vendor-ID (continued) Vendor-Type Vendor-Length

Vendor-Data
(Specified attribute value:----- )

Protocols and standards

e RFC 2865, Remote Authentication Dial In User Service (RADIUS)

e RFC 2866, RADIUS Accounting

e RFC 2867, RADIUS Accounting Modlifications for Tunnel Protocol Support
e RFC 2868, RADIUS Attributes for Tunnel Protocol Support

e RFC 2869, RADIUS Extensions

Contiguring a RADIUS scheme

A RADIUS scheme defines a set of parameters that the device uses to exchange information with the
RADIUS servers. There might be authentication servers and accounting servers, or primary servers and
secondary servers. The parameters mainly include the IP addresses of the servers, the shared keys, and
the RADIUS server type. By default, no RADIUS scheme exists.

To configure a RADIUS scheme:
1. Select Authentication > RADIUS from the navigation tree.

Figure 351 RADIUS scheme list

Scheme Serer I lsername Frirmany Frimary '
O Marme Type Format Authentication Server  Accounting Sener SR
[ systern Standard Without domain m
name
Add Cel Selected
2. Click Add.
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Figure 352 RADIUS scheme configuration page

Add RADIUS Scheme

Scheme Name *(1-32 Chars.)

Common Configuration
Server Type Standard

-

Username Format Without domain name ~

b Advanced

RADIUS Server Configuration

Server Type IP Address Port Operation

Add

Iltems marked with an asterisk(*) are required

Apply Cancel

3. Configure the parameters as described in Table 114.

4. Click Apply.
Table 114 Configuration items
ltem Description
Scheme Name Enter a name for the RADIUS scheme.

Configure the common parameters for the RADIUS scheme, including the
Common Configuration server type, the username format, and the shared keys for authentication and

accounting packets. For more information about common configuration, see
"Configuring common parameters."

Configure the parameters of the RADIUS authentication servers and
accounting servers. For more information about RADIUS server
configuration, see "Adding RADIUS servers."

RADIUS Server Configuration

Configuring common parameters

1. Click the expand button before Advanced in the Common Configuration area to expand the

advanced configuration area.
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Figure 353 Common configuration

Common Configuration

Server Type

Username Format
wAdvanced

Authentication Key

Confirm Authentication Key
Accounting Key

Confirm Accounting Key

Cuiet Time

Server Response Timeout Time
Request Transmission Attempts
Realtime Accounting Interval
Realtime Accounting Attempts
Unit for Data Flows

Unit for Packets

Security Policy Server

RADIUS Packet Source IP @ [Pvd

v

Stop-Accounting Attempts

Attribute

2. Configure the parameters,

Table 115 Configuration items

Standard -

Without domain name -

(1-64 Chars.)

(1-64 Chars.)

(1-64 Chars.)

(1-64 Chars.)

Minutes(0-255. Default = 5)

Seconds(1-10. Default = 3)

(1-20. Default = 3)

Minutes(0-60. Default = 12, must be a multiple of 2.)

(1-255. Default = 5)
Byte -

Cne-packet -

IPvE

Buffer stop-accounting packets

(10-65535. Default = 500)

Send accounting-on packets

- Interpretation -

as described in Table 115.

ltem

Description

Server Type

Select the type of the RADIUS servers supported by the device, which can be:

o Standard—Standard RADIUS servers. The RADIUS client and RADIUS
server communicate by using the standard RADIUS protocol and packet
format defined in RFC 2138/2139 or lafer.

o Extended—Extended RADIUS servers, usually running on CAMS or IMC.
The RADIUS client and the RADIUS server communicate by using the
proprietary RADIUS protocol and packet format.
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ltem

Description

Username Format

Select the format of usernames to be sent to the RADIUS server.

Typically, a username is in the format of userid@isp-name, of which isp-name
is used by the device to determine the ISP domain for the user. If a RADIUS
server (such as a RADIUS server of some early version) does not accept a
username that contains an ISP domain name, you can configure the device to
remove the domain name of a username before sending it to the RADIUS
server. The options include:

e Original format—Configure the device to send the username of a user on
an "as is" basis.

e With domain name—Configure the device to include the domain name in
a username.

o Without domain name—Configure the device to remove any domain
name of a username.

Authentication Key
Confirm Authentication Key
Accounting Key

Confirm Accounting Key

Set the shared key for RADIUS authentication packets and that for RADIUS
accounting packets.

The RADIUS client and the RADIUS authentication/accounting server use
MD?5 to encrypt RADIUS packets. They verify packets through the specified
shared key. The client and the server can receive and respond to packets
from each other only when they use the same shared key.

@ IMPORTANT:

o The shared keys configured on the device must be consistent with those
configured on the RADIUS servers.

o The shared keys configured in the common configuration part are used
only when no corresponding shared keys are configured in the RADIUS
server configuration part.

Quiet Time

Set the time the device keeps an unreachable RADIUS server in blocked
state.

If you set the quiet time to O, when the device needs to send an authentication
or accounting request but finds that the current server is unreachable, it does
not change the server's status that it maintains. It simply sends the request to
the next server in the active state. As a result, when the device needs to send
a request of the same type for another user, it still tries to send the request to
the server because the server is in the active state.

You can use this parameter to control whether the device changes the status
of an unreachable server. For example, if you determine that the primary
server is unreachable because the device's port for connecting the server is
out of service temporarily or the server is busy, you can set the time fo O so
that the device uses the primary server as much.

Server Response Timeout Time

Set the RADIUS server response timeout time.

If the device sends a RADIUS request to a RADIUS server but receives no
response in the specified server response timeout time, it retransmits the
request. Setting a proper value according to the network conditions helps in
improving the system performance.
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ltem

Description

Request Transmission Attempts

Set the maximum number of attempts for transmitting a RADIUS packet to a
single RADIUS server. If the device does not receive a response to its request
from the RADIUS server within the response timeout period, it retransmits the
RADIUS request. If the number of transmission attempts exceeds the limit but
the device still does not receive a response from the RADIUS server, the
device considers the request a failure.

@ IMPORTANT:

The server response timeout time multiplied by the maximum number of
RADIUS packet transmission attempts must not exceed 75.

Realtime Accounting Interval

Set the inferval for sending realtime accounting information. The inferval
must be a multiple of 3.

To implement real4ime accounting, the device must send real4ime
accounting packets to the accounting server for online users periodically.

Different realtime accounting intervals impose different performance
requirements on the NAS and the RADIUS server. A shorter interval helps
achieve higher accounting precision but requires higher performance. Use a
longer interval when a large number of users (1000 or more) exist. For more
information about the recommended real4ime accounting intervals, see
"Configuration guidelines."

Realtime Accounting Attempts

Set the maximum number of attempts for sending a realtime accounting
request.

Unit for Data Flows

Specify the unit for data flows sent to the RADIUS server, which can be:

e Byte.

o Kilo-byte.

e Mega-byte.
e Giga-byte.

Unit for Packets

Specify the unit for data packets sent to the RADIUS server, which can be:
e  One-packet.

o Kilo-packet.

e Mega-packet.

o Giga-packet.

Security Policy Server

Specify the IP address of the security policy server.

RADIUS Packet Source IP

Specify the source IP address for the device to use in RADIUS packets sent to
the RADIUS server.

HP recommends you to use a loopback interface address instead of a
physical interface address as the source IP address. If the physical interface
is down, the response packets from the server cannot reach the device.

Buffer stop-accounting packets

Enable or disable buffering of stop-accounting requests for which no
responses are received.
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ltem

Description

Stop-Accounting Attempts

Set the maximum number of stop-accounting attempts.

The maximum number of stop-accounting attempts, together with some other
parameters, controls how the NAS deals with stop-accounting request
packets.

Suppose that the RADIUS server response timeout period is three seconds,
the maximum number of transmission attempts is five, and the maximum
number of stop-accounting attempts is 20. For each stop-accounting request,
if the device receives no response within three seconds, it retransmits the
request. If it receives no responses after retransmitting the request five times,
it considers the stop-accounting attempt a failure, buffers the request, and
makes another stop-accounting attempt. If 20 consecutive attempts fail, the
device discards the request.

Send accounting-on packets

Enable or disable the accounting-on feature.

The accounting-on feature enables a device fo send accounting-on packets to
RADIUS servers after it reboots, making the servers forcedly log out users
who logged in through the device before the reboot.

(D IMPORTANT:

When enabling the accounting-on feature on a device for the first time, you
must save the configuration so that the feature takes effect after the device
reboots.

Accounting-On Interval

Set the interval for sending accounting-on packets. This field is configurable
only after you select the Send accounting-on packets box.

Accounting-On Attempts

Set the maximum number of accounting-on packets transmission attempts.
This field is configurable only after you select the Send accounting-on
packets box.

Attribute

Interpretation

Enable or disable the device to interpret the RADIUS class attribute as CAR
parameters.

Adding RADIUS servers

1. In the RADIUS Server Configuration areq, click Add.
Figure 354 RADIUS server configuration page
Server Type Primary Authenticatio -
IP Address @ IPv4 ) IPvE :
Port (1-65535. Default = 1812)
Key (1-64 Chars.)
Confirm Key (1-64 Chars.)
Apply Cancel
2. Configure the parameters, as described in Table 116.
3. Click Apply.
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Table 116 Configuration items

ltem Description

Select the type of the RADIUS server to be configured. Options include primary authentication
Server Type  server, primary accounting server, secondary authentication server, and secondary accounting
server.

Specify the IPv4 or IPv6 address of the RADIUS server.

The IP addresses of the primary and secondary servers for a scheme must be different.

IP Address Otherwise, the configuration fails.

RADIUS server addresses in the same scheme must use the same IP version.
Port Specify the UDP port of the RADIUS server.
Key Specify the shared key for communication with the RADIUS server.

Confirm Key  If no shared key is specified, the shared key specified in the common configuration part is used.

RADIUS configuration example

Network requirements

As shown in Figure 355, an 802.1X user logs in to the switch from the host. Configure the switch to
implement RADIUS authentication and accounting for the 802.1X user. RADIUS accounting records the
online duration of the 802.1X user.

Configure RADIUS servers on CAMS or IMC to use the default port for authentication and accounting.
The 802.1X user's username and password and the shared key expert are configured for packet
exchange with the switch.

On the switch, configure the shared key for packet exchange with the RADIUS server as expert, and
configure the system to remove the domain name of a username before sending it to the RADIUS server.

On the switch, enable the Telnet server function, and configure the switch to use AAA for authentication,
authorization and accounting of Telnet users.

Figure 355 Network diagram

Vlan-int2
192.168.1.1/24

Eth1/0/1

Host Switch RADIUS server
192.168.1.10/24 10.110.91.146/24

Configuration prerequisites

Enable 802.1X globally and on the specified port. Configure network access control based on MAC
addresses. (Details not shown.)

Configuring a RADIUS scheme

1. Select Authentication > RADIUS from the navigation tree.
2. Click Add to add a RADIUS scheme:
a. Enter system as the scheme name.

b. Select Extended as the server type.
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C.

a.
b.
c

d.

e.

Select Without domain name for the username format.

In the RADIUS Server Configuration areq, click Add to configure the primary authentication server:

Select Primary Authentication as the server type.

Enter 10.110.91.146 as the IP address.

Enter 1812 as the port.

Enter expert as the key and enter expert again to confirm the key.
Click Apply.

Figure 356 RADIUS authentication server configuration page

Add RADIUS Server

Server Type Primary Authenticatio -

IP Address @ IPv4 ) IPve 10.110.91.146 *

Port 1812 (1-65535. Default = 1812)

Key ssesss (1-64 Chars.)

Confirm Key --.---l (1-64 Chars.)

Apply Cancel

In the RADIUS Server Configuration area, click Add again to configure the primary accounting

server:

a.
b.
c.

d.

e.

Select Primary Accounting as the server type.

Enter 10.110.91.146 as the IP address.

Enter 1813 as the port.

Enter expert as the key and enter expert again to confirm the key.
Click Apply.

The RADIUS scheme configuration page refreshes. The added servers appear in the server list.

Figure 357 RADIUS accounting server configuration page

Add RADIUS Server

Server Type Primary Accounting  ~

IP Address @ IPv4 O IPv6  10.110.91.146 *

Paort 1813 (1-65535. Default = 1813)
Key ssssse {1-64 Chars.)

Confirm Key ssnues (1-64 Chars.)

Apply Cancel

5. Click Apply.
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Figure 358 RADIUS scheme configuration

Add RADIUS Scheme

Scheme Name system *(1-32 Chars.)

Common Configuration

Server Type Extended -
Username Format Without domain name -
b Advanced

RADIUS Server Configuration

Server Type IP Address Port Operation
Primary Authentication 10.110.91.146 1812 ﬂ
Primary Accounting 10.110.91.146 1813 ﬂ
Add

ltems marked with an asterisk(*) are required

Apply Cancel

Configuring AAA

1. Select Authentication > AAA in the navigation tree.
The domain setup page appears.

2. On the domain setup page, configure a domain:
a. Enter test for Domain Name.
b. Click Enable to use the domain as the default domain.
c. Click Apply.
Figure 359 Creating an ISP domain

Authentication Authorization Accounting
ISP Domain
Dornain Marne |test |V |(1 - 24 Chars.)
Default Domain |Enab|e V|

Apply

Flease selactthe ISP domainis)

Damain Mame Cefault Domain
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Select the Authentication tab to configure the authentication scheme:
a. Select the domain name test.
b. Select Default AuthN and select RADIUS as the authentication mode.
c. Select system from the Name list to use it as the authentication scheme.
d. Click Apply.
A configuration progress dialog box appears.
e. Affer the configuration process is complete, click Close.

Figure 360 Configuring the AAA authentication method for the ISP domain

Domain Setup Authorization Accounting

Authentication Configuration of AAA

Select an ISP domain test -

[V] Default AuthM RADIUS - Name system - Secondary Method

[l LAN-access Authi Mame Secondary Method

[T Login AuthM Mame Secondary Method
PPP Authly Mame Secondary Method
Portal AuthM Mame Secondary Method

Figure 361 Configuration progress dialog box

Current Configuration
Setting Default AuthM - QK!

100%

Close

Select the Authorization tab to configure the authorization scheme:
a. Select the domain name test.
b. Select Default AuthZ and select RADIUS as the authorization mode.
c. Select system from the Name list to use it as the authorization scheme.
d. Click Apply.
A configuration progress dialog box appears.

e. After the configuration process is complete, click Close.
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Figure 362 Configuring the AAA authorization method for the ISP domain

Domain Setup Authentication Accounting

Authorization Configuration of AdA

Selectan ISP domain test =
Default AuthZ RADIUS -~ MName system
[[] LAM-access AuthZ Mame
[ Lagin AuthZ Mame

PPF AuthZ MName
Portal AuthZ Mame
Command AuthZ Name

5. Select the Accounting tab to configure the accounting scheme:

a. Select the domain name test.

b. Select Accounting Optional and select Enable from the list.

Secondary Method
Secondary Method
Secondary Method
Secondary Method
Secondary Method

c. Select Default Accounting and select RADIUS as the accounting mode.

d. Select system from the Name list to use it as the accounting scheme.

e. Click Apply.
A configuration progress dialog box appears.

f.  After the configuration process is complete, click Close.

Figure 363 Configuring the AAA accounting method for the ISP domain

Domain Setup Authentication Authorization

Accounting Configuration of AAA

Selectan ISP domain test -
[¥] Accounting Optional Enable -
[¥] Default Accounting RADIUS » MName system
[[]LAM-access Accounting MName
[7] Login Accounting MName
PPP Accounting MName
Portal Accounting Mame

Contfiguration guidelines

When you configure the RADIUS client, follow these guidelines:

e Accounting for FTP users is not supported.
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If

you remove the accounting server used for online users, the device cannot send real-time

accounting requests and stop-accounting messages for the users to the server, and the
stop-accounting messages are not buffered locally.

The status of RADIUS servers, blocked or active, determines which servers the device will
communicate with or turn to when the current servers are not available. In practice, you can specify
one primary RADIUS server and multiple secondary RADIUS servers, with the secondary servers
that function as the backup of the primary servers. Typically, the device chooses servers based on
these rules:

O

When the primary server is in the active state, the device communicates with the primary server.
If the primary server fails, the device changes the state of the primary server to blocked, starts
a quiet timer for the server, and turns to a secondary server in the active state (a secondary
server configured earlier has a higher priority). If the secondary server is unreachable, the
device changes the state of the secondary server to blocked, starts a quiet timer for the server,
and continues to check the next secondary server in the active state. This search process
continues until the device finds an available secondary server or has checked all secondary
servers in the active state. If the quiet timer of a server expires or an authentication or
accounting response is received from the server, the status of the server changes back to active
automatically, but the device does not check the server again during the authentication or
accounting process. If no server is found reachable during one search process, the device
considers the authentication or accounting attempt a failure.

Once the accounting process of a user starts, the device keeps sending the user's real-time
accounting requests and stop-accounting requests to the same accounting server. If you remove
the accounting server, realtime accounting requests and stop-accounting requests for the user
can no longer be delivered to the server.

If you remove an authentication or accounting server in use, the communication of the device
with the server will soon time out, and the device will look for a server in the active state by
checking any primary server first and then the secondary servers in the order they are
configured.

When the primary server and secondary servers are all in the blocked state, the device
communicates with the primary server. If the primary server is available, its statues changes to
active. Otherwise, its status remains to be blocked.

If one server is in the active state but all the others are in the blocked state, the device only tries
to communicate with the server in the active state, even if the server is unavailable.

After receiving an authentication/accounting response from a server, the device changes the
status of the server identified by the source IP address of the response to active if the current
status of the server is blocked.

Set a proper realtime accounting interval based on the number of users.

Table 117 Recommended real-time accounting intervals

Number of users Real-time accounting interval (in minutes)
110 99 3

100 to 499 o)

500 to 999 12

=1000 =15
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Configuring users

You can configure local users and create groups to manage them.

A local user represents a set of user attributes configured on a device (such as the user password, use
type, service type, and authorization attribute), and is uniquely identified by the username. For a user to
pass local authentication, you must add an entry for the user in the local user database of the device. For
more information about local authentication, see "Configuring AAA."

A user group consists of a group of local users and has a set of local user attributes. You can configure
local user attributes for a user group to implement centralized management of user attributes for the local
users in the group. All local users in a user group inherit the user attributes of the group. However, if you
configure user attributes for a local user, the settings for the local user take precedence over the settings
for the user group.

By default, every newly added local user belongs to a user group named system, which is created
automatically by the system.

Contiguring a local user

1. Select Authentication > Users from the navigation tree to enter the Local User tab, which displays
all local users.

Figure 364 Local user list

User Group
= User Mame v | Zearch | pdvanced Search
Lzer Service Llzer Llzer Expire .
F] Narne T Level WLAR ACL Profile R Lzer Type Tirne Qperation
; WWeb, Cammon G
] adrmin Telnet Management system Usar ﬂ
Add BatchDelete
2. Click Add.

The page for adding a local user appears.
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Figure 365 Local user configuration page

User Group

Add Local User
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Confirm:
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Expire-time:
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*(1-65 Chars.)
(1-63 Chars.)
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system -

Comman User -
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[Clweb ClrFrpP [ClTelnet [ClLAN-access  [C]ssH
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(2000-4999)
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ltems marked with an asterisk(*) are required

3. Configure the local

Cancel

user as described in Table 118.

4. Click Apply.
Table 118 Configuration items
Item Description
Username Specify a name for the local user.
Specify and confirm the password of the local user.
Password
The settings of these two fields must be the same.
Confirm

Do not specify a password starting with spaces because the spaces will be ignored.

Password Encryption

Select a password encryption method: Reversible or Irreversible.

Select a user group for the local user.

Grou
P For information about user group configuration, see "Configuring a user group."
Select a user type for the local user: Common User, Security Log Administrator, or
Usertype Guest Administrator.
Only the Common User option takes effect on this software version.
Select an authorization level for the local user: Visitor, Monitor, Configure, or
Level Management, in ascending order of priority.

This option takes effect on only Web, FTP, Telnet, and SSH users.

Servicetype

Select the service types for the local user to use, including Web, FTP, Telnet, LAN
access (Ethernet access service such as 802.1X), and SSH.

If you do not specify any service type for a local user who uses local authentication,
the user cannot pass authentication and therefore cannot log in.

The service type of the guest administrator and security log administrator is Web.
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ltem Description

Specify an expiration time for the local user, in the HH:MM:SS-YYYY/MM/DD

format.

Expire-time To authenticate a local user with the expiration time configured, the access device
checks whether the expiration time has passed. If it has not passed, the device permits

the user to log in.

Specify the VLAN to be authorized to the local user after the user passes

VIAN authentication.

This option takes effect on only LAN users.

Specify the ACL to be used by the access device to restrict the access of the local user

ACL after the user passes authentication.

This option takes effect on only LAN users.

Specify the user profile for the local user.

User-profile This option takes effect on only LAN users, but it does not take effect on this software

version.

Contiguring a user group

1. Select Authentication > Users from the navigation tree.

2. Click the User Group tab to display the existing user groups.
Figure 366 User group list

Allow Guest

Local User
| Group Name ¥| Search | advanced Search
Group Mame Lewel WLAM AL Llzer Praofile
system Wisitar TES
Add
3. Click Add.

The page for configuring a user group appears.
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Figure 367 User group configuration page

Local User
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WLAMN:
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ser-profile:

*1-32 Chars.)
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Apply Cancel

4.  Configure the user group as described in Table 119.

5. Click Apply.

Table 119 Configuration items

ltem

Description

Group-name

Specify a name for the user group.

Select an authorization level for the user group: Visitor, Monitor, Configure, or

Level Management, in ascending order of priority.
VIAN Specify the VLAN to be authorized to users of the user group after the users pass
authentication.
ACL Specify the ACL to be used by the access device to control the access of users of the
user group after the users pass authentication.
) Specify the user profile for the user group.
User-profile

This option does not take effect on this software version.

Allow Guest Accounts

Select this option to allow guest accounts to be added to the user group.

This option is selected for the system-defined user group system and cannot be
modified. However, this option does not take effect on this software version.
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Managing certificates

Overview

The Public Key Infrastructure (PKI) offers an infrastructure for securing network services through public key
technologies and digital certificates, and for verifying the identities of the digital certificate owners.

A digital certificate is a binding of certificate owner identity information and a public key. Users can get
certificates, use certificates, and revoke certificates. By leveraging digital certificates and relevant
services like certificate and blacklist distribution, PKI supports authenticating the entities involved in
communication, and therefore guarantees the confidentiality, integrity, and non-repudiation of data.

PKI terms

Digital certificate

CRL

A digital certificate is a file signed by a certificate authority (CA) that contains a public key and the
related user identity information. A simplest digital certificate contains a public key, an entity name, and
a digital signature from the CA. Generally, a digital certificate also includes the validity period of the key,
the name of the CA and the sequence number of the certificate. A digital certificate must comply with the
international standard of ITU-T_X.509. This document involves local certificate and CA certificate. A local
certificate is a digital certificate signed by a CA for an entity. A CA certificate, also known as a "root
certificate", is signed by the CA for itself.

An existing certificate might need to be revoked when, for example, the username changes, the private
key leaks, or the user stops the business. Revoking a certificate will remove the binding of the public key
with the user identity information. In PK, the revocation is made through certificate revocation lists (CRLs).
When a certificate is revoked, the CA publishes one or more CRLs to show all certificates that have been
revoked. The CRLs contain the serial numbers of all revoked certificates and provide an effective way for
checking the validity of certificates.

A CA might publish multiple CRLs when the number of revoked certificates is so large that publishing
them in a single CRL might degrade network performance.

CA policy

A CA policy is a set of criteria that a CA follows in processing certificate requests, issuing and revoking
certificates, and publishing CRLs. Usually, a CA advertises its policy in the form of certification practice
statement (CPS). A CA policy can be acquired through out-of-band means such as phone, disk, and
email. Because different CAs might use different methods to examine the binding of a public key with an
entity, make sure you understand the CA policy before selecting a trusted CA for certificate request.

PK| architecture

A PKI system consists of entities, a CA, a registration authority (RA) and a PKI repository.
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Entity
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Figure 368 PKI architecture
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An entity is an end user of PKI products or services, such as a person, an organization, a device like a
router or a switch, or a process running on a computer.

A CA is a trusted authority responsible for issuing and managing digital certificates. A CA issues
certificates, specifies the validity periods of certificates, and revokes certificates as needed by publishing

CRLs.

An RA is an extended part of a CA or an independent authority. An RA can implement functions
including identity authentication, CRL management, key pair generation and key pair backup. It only
examines the qualifications of users. It does not sign certificates. Sometimes, a CA assumes the
registration management responsibility and no independent RA exists. The PKI standard recommends
that an independent RA be used for registration management to achieve higher security of application
systems.

PKI repository

A PKl repository can be an LDAP server or a common database. It stores and manages information like
certificate requests, certificates, keys, CRLs and logs, and it provides a simple query function.

LDAP is a protocol for accessing and managing PKI information. An LDAP server stores user information
and digital certificates from the RA server and provides directory navigation service. From an LDAP server,
an entity can retrieve digital certificates of its own and other entities.

How PKI works

In a PKl-enabled network, an entity can request a local certificate from the CA and the device can check
the validity of certificate. The following describes how it works:

1. An entity submits a certificate request to the CA.

2. The RA verifies the identity of the entity and then sends the identity information and the public key
with a digital signature to the CA.

3. The CA verifies the digital signature, approves the application, and issues a certificate.
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The RA receives the certificate from the CA, sends it to the LDAP server to provide directory
navigation service, and notifies the entity that the certificate is successtully issued.

The entity retrieves the certificate. With the certificate, the entity can communicate with other
entities safely through encryption and digital signature.

The entity makes a request to the CA when it needs to revoke its certificate. The CA approves the
request, updates the CRLs and publishes the CRLs on the LDAP server.

PKI applications

The PKI technology can satisfy the security requirements of online transactions. As an infrastructure, PKI
has a wide range of applications. Here are some application examples.

VPN—A VPN is a private data communication network built on the public communication
infrastructure. A VPN can leverage network layer security protocols (for example, IPSec) in
conjunction with PKI-based encryption and digital signature technologies to achieve confidentiality.

Secure email—Emails require confidentiality, integrity, authentication, and non-repudiation. PKI
can address these needs. The secure email protocol that is developing rapidly is S/MIME, which is
based on PKI and allows for transfer of encrypted mails with signature.

Web security—For Web security, two peers can establish an SSL connection first for transparent
and secure communications at the application layer. With PKI, SSL enables encrypted
communications between a browser and a server. Both the communication parties can verify the
identity of each other through digital certificates.

Recommended configuration procedures

The device supports the following PKI certificate request modes:

Manual—In manual mode, you need to manually retrieve a CA certificate, generate a local RSA
key pair, and submit a local certificate request for an entity.

Auto—In auto mode, an entity automatically requests a certificate through the SCEP when it has no
local certificate or the present certificate is about to expire.

You can specify the PK certificate request mode for a PKI domain. Different PKI certificate request modes
require different configurations.

Recommended configuration procedure for manual request

Step Remarks

1.

Required.
Create a PK| entity and configure the identity information.

A certificate is the binding of a public key and the identity information of an
Creating a PKI entity entity, where the distinguished name (DN) shows the identity information of
the entity. A CA identifies a certificate applicant uniquely by an entity DN.

The DN settings of an entity must be compliant o the CA certificate issue
policy. Otherwise, the certificate request might be rejected. You must know the
policy to determine which entity parameters are mandatory or optional.
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Step Remarks
Required.
Create a PKI domain, setting the certificate request mode to Manual.
2. Creating a PKI domain Before requesting a PKI certificate, an entity needs to be configured with

some enrollment information, which is called a PKI domain.

A PKI domain is intended only for convenience of reference by other
applications like IKE and SSL, and has only local significance.

3.

Generating an RSA key
pair

Required.
Generate a local RSA key pair.
By default, no local RSA key pair exists.

Generating an RSA key pair is an important step in certificate request. The
key pair includes a public key and a private key. The private key is kept by
the user, and the public key is transferred to the CA along with some other
information.

@ IMPORTANT:

If a local certificate already exists, you must remove the certificate before
generating a new key pair, so as to keep the consistency between the key pair
and the local certificate.

4.

Retrieving the CA
certificate

Required.
Certificate retrieval serves the following purposes:

e Locally store the certificates associated with the local security domain for
improved query efficiency and reduced query count,

e Prepare for certificate verification.

@ IMPORTANT:

If a local CA certificate already exists, you cannot perform the CA certificate
retrieval operation. This will avoid possible mismatch between certificates and
registration information resulting from relevant changes. To retrieve the CA
certificate, you must remove the CA certificate and local certificate first.

5.

Requesting a local
certificate

Required.

When requesting a certificate, an entity introduces itself to the CA by
providing its identity information and public key, which will be the major
components of the certificate.

A certificate request can be submitted to a CA in online mode or offline
mode.

e In online mode, if the request is granted, the local certificate will be
retrieved to the local system automatically.

¢ In offline mode, you must retrieve the local certificate by an out-of-band
means.

@ IMPORTANT:

If a local certificate already exists, you cannot perform the local certificate
retrieval operation. This will avoid possible mismatch between the local
certificate and registration information resulting from relevant changes. To
retrieve a new local certificate, you must remove the CA certificate and local
certificate first.
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Step

Remarks

Destroying the RSA key pair

Optional.
Destroy the existing RSA key pair and the corresponding local certificate.

If the certificate to be retrieved contains an RSA key pair, you must destroy
the existing key pair. Otherwise, the retrieving operation will fail.

Retrieving and displaying a
certificate

Optional.

Retrieve an existing certificate.

Retrieving and displaying a
CRL

Optional.

Retrieve a CRL and display its contents.

Recommended configuration procedure for automatic request

Task

Remarks

Creating a PKI entity

Required.
Create a PK| entity and configure the identity information.

A certificate is the binding of a public key and the identity information of an
entity, where the DN shows the identity information of the entity. A CA
identifies a certificate applicant uniquely by an entity DN.

The DN settings of an entity must be compliant to the CA certificate issue
policy. Otherwise, the certificate request might be rejected. You must know
the policy to determine which entity parameters are mandatory or optional.

Creating a PKI domain

Required.
Create a PKI domain, setting the certificate request mode to Auto.

Before requesting a PKI certificate, an entity needs to be configured with
some enrollment information, which is called a PKI domain.

A PKI domain is intended only for convenience of reference by other
applications like IKE and SSL, and has only local significance.

Destroying the RSA key pair

Optional.
Destroy the existing RSA key pair and the corresponding local certificate.

If the certificate to be retrieved contains an RSA key pair, you must destroy
the existing key pair. Otherwise, the retrieving operation will fail.

Retrieving and displaying a
certificate

Optional.

Retrieve an existing certificate.

Retrieving and displaying a
CRL

Optional.

Retrieve a CRL and display its contents.

Creating a PKI entity

From the navigation tree, select Authentication > Certificate Management.

The PKI entity list page is displayed by default.
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Figure 369 PKI entity list
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2. Click Add on the page.
Figure 370 PKI entity configuration page
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Apply Cancel

3. Configure the parameters, as described in Table 120.
4. Click Apply.

Table 120 Configuration items

ltem Description

Entity Name Enter the name for the PKI entity.
Common Name Enter the common name for the entity.
IP Address Enter the IP address of the entity.

Enter the FQDN for the entity.

An FQDN is a unique identifier of an entity on the network. It consists of a host

FQDN name and a domain name and can be resolved to an IP address. For example,
www.whatever.com is an FQDN, where www indicates the host name and
whatever.com the domain name.

Country/Region Code Enter the country or region code for the entity.
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ltem Description

State Enter the state or province for the entity.
Locality Enter the locality for the entity.
Organization Enter the organization name for the entity.
Organization Unit Enter the unit name for the entity.

Creating a PKI domain

1. From the navigation tree, select Authentication > Certificate Management.
2. Click the Domain tab.

Figure 371 PKI domain list

Entity Cedificate CRL
Diarmain Mame CA ldentifier Entity Mame Requestode  Operation
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Add
3. Click Add.

4. Click Display Advanced Contfig to display the advanced configuration items.
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Figure 372 PKI domain configuration page
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5.  Configure the parameters, as described in Table 121.

6. Click Apply.

Table 121 Configuration items

ltem

Description

Domain Name

Enter the name for the PKI domain.

CA |dentifier

Enter the identifier of the trusted CA.

An entity requests a certificate from a trusted CA. The trusted CA takes the responsibility
of certificate registration, distribution, and revocation, and query.

In offline mode, this item is optional. In other modes, this item is required.

Entity Name

Select the local PKI entity.

When submitting a certificate request to a CA, an entity needs to show its identity
information.

Available PKI entities are those that have been configured.

Institution

Select the authority for certificate request.
e CA—Indicates that the entity requests a certificate from a CA.
e RA—Indicates that the entity requests a certificate from an RA.

RA is recommended.
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ltem

Description

Requesting URL

Enter the URL of the RA.

The entity will submit the certificate request to the server at this URL through the SCEP
protocol. The SCEP protocol is intended for communication between an entity and an
authentication authority.

In offline mode, this item is optional. In other modes, this item is required.

@ IMPORTANT:

This item does not support domain name resolution.

LDAP IP

Port

Version

Enter the IP address, port number and version of the LDAP server.

In a PKI system, the storage of certificates and CRLs is a crucial problem, which is usually
addressed by deploying an LDAP server..

Request Mode

Select the online certificate request mode, which can be auto or manual.

Password

Confirm Password

Set a password for certificate revocation and re-enter it for confirmation.

The two boxes are available only when the certificate request mode is set to Auto..

Fingerprint Hash

Fingerprint

Specify the fingerprint used for verifying the CA root certificate.

After receiving the root certificate of the CA, an entity needs to verify the fingerprint of the
root certificate, namely, the hash value of the root certificate content. This hash value is
unique to every certificate. If the fingerprint of the root certificate does not match the one
configured for the PKI domain, the entity will reject the root certificate.

o If you specify MD5 as the hash algorithm, enter an MD5 fingerprint. The fingerprint
must a string of 32 characters in hexadecimal notation.

o If you specify SHA1 as the hash algorithm, enter an SHAT fingerprint. The fingerprint
must a string of 40 characters in hexadecimal notation.

e If you do not specify the fingerprint hash, do not enter any fingerprint. The entity will
not verify the CA root certificate, and you yourself must make sure the CA server is
trusted.

@ IMPORTANT:

The fingerprint must be configured if you specify the certificate request mode as Auto. If you
specify the certificate request mode as Manual, you can leave the fingerprint settings null. If
you do not configure the fingerprint, the entity will not verify the CA root certificate and you
yourself must make sure the CA server is trusted.

Polling Count

Polling Interval

Set the polling interval and attempt limit for querying the certificate request status.

After an entity makes a certificate request, the CA might need a long period of time if it
verifies the certificate request in manual mode. During this period, the applicant needs to
query the status of the request periodically to get the certificate as soon as possible after
the certificate is signed..

Enable CRL
Checking

Select this box to specify that CRL checking is required during certificate verification.

CRL Update Period

Enter the CRL update period, that is, the interval at which the PKI entity downloads the
latest CRLs.

This item is available after you click the Enable CRL Checking box.
By default, the CRL update period depends on the next update field in the CRL file.
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ltem Description

Enter the URL of the CRL distribution point. The URL can be an IP address or a domain
name.

CRL URL This item is available after you click the Enable CRL Checking box.

If the URL of the CRL distribution point is not set, you should get the CA certificate and a
local certificate, and then get a CRL through SCEP.

Generating an RSA key pair

1. From the navigation tree, select Authentication > Certificate Management.
2. Click the Certificate tab.

Figure 373 Certificate configuration page
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Please copy itto the CA serverto produce the cedificate file offling, and then retrieve the file.

» Whenyou delete the CA cedificate, the relevant local cerdificate will also be deleted.

3. Click Create Key.
4.  Set the key length.
5. Click Apply.
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Figure 374 Key pair parameter configuration page
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Apply Cancel

Destroying the RSA key pair

From the navigation tree, select Authentication > Certificate Management.
Click the Certificate tab.
Click Destroy Key.

WD~

Click Apply to destroy the existing RSA key pair and the corresponding local certificate.
Figure 375 Key pair destruction page

Entity Domain CRL
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This operation will destroy the key, and corresponding local cedificate.

Apply Cancel

Retrieving and displaying a certificate

You can retrieve an existing CA certificate or local certificate from the CA server and save it locally. To
do so, you can use offline mode or online. In offline mode, you must retrieve a certificate by an
out-of-band means like FTP, disk, email and then import it into the local PKI system. By default, the
retrieved certificate is saved in a file under the root directory of the device, and the filename is
domain-name_ca.cer for the CA certificate, or domain-name_local.cer for the local certificate.

To retrieve a certificate:

1. From the navigation tree, select Authentication > Certificate Management.
2. Click the Certificate tab.

3. Click Retrieve Cert.
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Figure 376 PKI certificate retrieval page

Entity Domain CRL

Retrieve Cerlificate

Daomain Mame: ahcd |%
Certificate Type: CA  w

[CJEnable offline
Mode
Items marked with an asterisk(*) are required

Apply Cancel

4.  Configure the parameters, as described in Table 122.
5.  Click Apply.

Table 122 Configuration items

ltem Description
Domain Name Select the PKI domain for the certificate.
Certificate Type Select the type of the certificate to be retrieved, which can be CA or local.

Click this box to retrieve a certificate in offline mode (that is, by an out-of-band means like
FTP, disk, or email), and then import the certificate into the local PKI system.

Enable Offline

Mode
The following configuration items are displayed if this box is selected.

Get File From Specify the path and name of the certificate file to import:

Device o Ifthe certificate file is saved on the device, select Get File From Device and then specify
the path and name of the file on the device. If no file is specified, the system, by
default, gets the file domain-name_ca.cer (for the CA certificate) or

Get File From PC domain-name_local.cer (for the local certificate) under the root directory of the device.

o If the certificate file is saved on a local PC, select Get File From PC and. then specify
the path and name of the file and specify the partition that saves the file..

Password Enter the password for protecting the private key, which was specified when the

certificate was exported.

After retrieving a certificate, you can click View Cert corresponding to the certificate from the PKI
certificates list to display the contents of the certificate.
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Figure 377 Certificate information

Entity Damain ZRL

Yiew Certificate Details

Certificate:
Data:
Version: 3 [(0x2)
Serial Mumbher:
6144CCFS 00000000 0014
Signature Algorithm: shalWithRISAEncryption
Issuer:
CN=CkL serwver
Validity
Not Before: Nowv 3 08:10:21 2009 GMT
Mot After : Now 3 05:20:21 2010 GMT
Subject:
C=CH
CH=aaa
subject Public Eey Info:
Public Eey ALlgorithm: rsaEncryption
B34 Public Eey: (1024 bit)
Modulus (1024 bit):
0oAg5SecF EFAzZSDeC CEZ371Ee EAT329E7
56940922 DESTAODD 915B90383 05944261
TS5FEC35D 61la3644Dh SESFLIESO S543E415E
ABGSFESZ 656214ED BAFDZEED FDADVEDF
§585175C SOEFSE34 SEDIESS4 acZCEZVE
TBZC964h ASDIAFEDD SEZ4TCIE FFDSA193
FSCCF5DA 315B0O898 EF21768D S71341CF
11FF1409 B79F54058 242ZDF0OAS BESCSSEZLA
93
Exponent: 65537 [(0=x10001)
X093 extensions:
XE509v3 Subject EKey Identifier:

NoAOnSa2TE Do2NT220 ANn20To2 29297 CPSCT AdASAT1T A A

Requesting a local certiticate

1. From the navigation tree, select Authentication > Certificate Management.
2. Click the Certificate tab.
3. Click Request Cert.
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Figure 378 Local certificate request page

Entity Domain CRL

Request Certificate

Domain Mame: abcd w
&) Password: (1-31 Chars.)

O Enable Offline Mode
ltems marked with an asterisk(*} are required

Apply Cancel

Configure the parameters, as described in Table 123.

Table 123 Configuration items

ltem Description
Domain Name Select the PKI domain for the certificate.
Password Enter the password for certificate revocation.

Select this box to request a certificate in offline mode, that is, by an out-of-band

Enable Offline Mode means like FTP, disk, or email.

Click Apply.

If you select the online mode, the system shows a prompt that the certificate request has been
submitted. In this case, click OK to finish the operation. If you select the offline mode, the offline
certificate request information page appears In this case, you must submit the information by an
out-of-band way to the CA to request a local certificate.

Figure 379 Offline certificate request information page

Entity Damain CRL

Offline Cerdificate Reguest Information

MITEW)CExATBADADM]swC QYD VOQGEWIDTIEMMA0 GAITE & MD T ITFhM I GEMADGC S
SIb3DEBAQTALAGNADCELIQFEgOC oV, vollsyyNx tupeFbdiingkiloeg3ZFbk THF
o Thd £ TDGoZElexx SQVISEichl /pJ 1Y hTouvin7 £ 2del+IiEdcTT09eNIvRE FRL
LOJ7eyyWgyqPRrt2edHub /9ihk A N9 dox Wi ¥y F2i¥cToc SR/ 0T 54+ECCQLEKEOL
FIAqkwIDAQARoAAWD) VI o Z IhweHAQEERQAD YEAE T 9 TyobtatH4igGewlBr1a6
T5adQ65ik2tZiPaGEL111l3gqex0z) 7onccClGUEPY+E /£1i1e0P7TECaAGTTuTEODVL+2
EyTZucTkVayb01lseY0qMuxEwqu? 0L/ danil Driwsl 46k GasuNGEL 4F5 6 ThNE 52T
Wple8FLueslk70zelwi=

Back
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Retrieving and displaying a CRL

1. From the navigation tree, select Authentication > Certificate Management.
2. Click the CRL tab.

Figure 380 CRL page
Entity Domain Cerificate
Darmain Mame Operation
ahcd [Retrieve CRL] Miew CRL]

3. Click Retrieve CRL to retrieve the CRL of a domain.
4. Click View CRL for the domain to display the contents of the CRL.

Figure 381 CRL information

Entity Damain Cerificate

View CRL Details

Certificate Revocation List (CREL):
Version 2 (0xl1)
Signature Algorithm: shalWithRSAEncryption
Issuer:
C=cn
O=cl
oU=cl
Cl=cl
Last Update: Oct 25 07:34:1&6 2007 GMT
Next Update: NONE
CEL extensions:
X509v3 CRL Number:

¥509v3 Ruthority Key Identifier:
keyid:BD5SDO5A5 ET744RR19 ER41R2EZ €9BESOAS F&2E6CL0

shalWithRSAEncryption
24C25849 4E15985C
EI4EL18RC 2

3150B401
93B3CEA
SBZREDAR 5R
CSEBER4D TGDBEOEFL 7

Z356BBTD ZEF341F3

D2177A49 &DCSCZED

o o
[T
[

Back
Table 124 Field description
Field Description
Version CRL version number.
Signature Algorithm Signature algorithm that the CRL uses.
Issuer CA that issued the CRL.
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Field

Description

Last Update

Last update time.

Next Update

Next update time.

X509v3 CRL Number

CRL sequence number

X509v3 Authority Key Identifier

Identifier of the CA that issued the certificate and the certificate version

(X509v3).

Pubic key identifier.

keyid A CA might have multiple key pairs, and this field identifies which key

pair is used for the CRL signature.

No Revoked Certificates. No certificates are revoked.

PKI configuration example

Network requirements

As shown in Figure 382, configure the switch working as the PKI entity, so that:

The switch submits a local certificate request to the CA server, which runs the RSA Keon software.

The switch retrieves CRLs for certificate verification.

Figure 382 Network diagram

$—

Host Switch CA server

PKI entity

Configuring the CA server

1.

Create a CA server named myca:

In this example, first configure the basic attributes of Nickname and Subject DN on the CA server:
the nickname is the name of the trusted CA, and the subject DN is the DN attributes of the CA,
including the common name, organization unit, organization, and country. Leave the default
values of the other attributes.

Configure extended attributes:

After configuring the basic attributes, configure the parameters on the Jurisdiction Configuration
page of the CA server. This includes selecting the proper extension profiles, enabling the SCEP
autovetting function, and adding the IP address list for SCEP autovetting.

Configure the CRL publishing behavior:
After completing the configuration, perform CRL related configurations.

In this example, select the local CRL publishing mode of HTTP and set the HTTP URL to
http://4.4.4.133:447 /myca.crl.

After the configuration, make sure the system clock of the switch is synchronous to that of the CA,
so that the switch can request certificates and retrieve CRLs properly.
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Configuring the switch

1.

Create a PKI entity:

a.

From the navigation tree, select Authentication > Certificate Management.

The PKI entity list page is displayed by default.
Click Add.

Enter aaa as the PKI entity name, enter ac as the common name, and click Apply.

Figure 383 Creating a PKI entity

Domain Certificate CRL
Add PKI Entity
Entity Mame: aaa *(1-15 Chars.)
Commaon Mame: ac *{1-31 Chars.}
IP Address:
FQDM: (1-127 Chars.)

(Country/Region name symhal, two characters

Country/Region Code:
compliant to 130 3166 standard. )

State: (1-31 Chars.)
Locality: {1-31 Chars.)
Crganization: (1-31 Chars.}
Qrganization Unit; (1-31 Chars.}

ltems marked with an asterisk(*) are required

Create a PKI domain:

. Click the Domain tab.

Click Add.
The page in Figure 384 appears.

Enter torsa as the PKI domain name, enter myca as the CA identifier, select aaa as the local
entity, select CA as the authority for certificate request, enter
http://4.4.4.133:446/c95e970632d27be5e8cbf80e97 1d9c4a9a93337 as the URL for
certificate request (the URL must be in the format of http://host:port/Issuing Jurisdiction ID,
where Issuing Jurisdiction ID is the hexadecimal string generated on the CA), and select
Manual as the certificate request mode.

Click the collapse button before Advanced Configuration.

In the advanced configuration areq, click the Enable CRL Checking box, and enter
http://4.4.4.133:447 /myca.crl as the CRL URL.

Click Apply.

A dialog box appears, asking "Fingerprint of the root certificate not specified. No root
certificate validation will occur. Continue?"

Click OK.
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Figure 384 Creating a PKI domain

Entity Certificate CRL

Add PEI Domain

Damain Mame: tarsa *(1-15Chars.)

CA ldentifier: myca (1-63Chars. )

Entity Mame:
Institution:

Requesting URL: hittprfid. 4.4133: 44609597 0f632d27heseBchf30e971d9c 429293337 (1-127Chars.}
LOAP IP: Port:|389 hfersiun:|2 v|
‘ Request Mode: |Manua| V| |

Fingerprint Hazsh:

Fingerprint:

wAdvanced Configuration |

Palling Count: a0 (1-100, Default= a0}

Falling Interval: 20 minutes(5-168, Default= 20)

| [FEnatile CRL Checking |
CRL Update Pariod: hours(1-720)

‘ CRLURL: hitp:rd.4.4.133:447imyca.crl (1-288Chars. )

lterns marked with an asterisk{®™ are required
Apply Cancel

Generate an RSA key pair:

a. Click the Certificate tab.

b. Click Create Key.

c. Enter 1024 as the key length, and click Apply to generate an RSA key pair.

Figure 385 Generating an RSA key pair

Entity Domain CRL
Add Key
Key Length: 1024 *(512-2048, Default = 1024)

Ifthere is already a key, overwrite it.
ltems marked with an asterisk(*) are required

Apply Cancel

Retrieve the CA certificate:

a. Click the Certificate tab.

b. Click Retrieve Cert.

c. Select torsa as the PKI domain, select CA as the certificate type, and click Apply.
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Figure 386 Retrieving the CA certificate

Entity Damain CRL

Retrieve Cerificate

Domain Mame: torsa

Cerificate Type: CA W

[JEnable Offline Mode
Items marked with an asterisk(*) are required

Apply Cancel

5.  Request a local certificate:
a. Click the Certificate tab.
b. Click Request Cert.
c. Select torsa as the PKI domain, select Password , and enter challenge-word as the password.
d. Click Apply.
The system displays "Certificate request has been submitted."

e. Click OK to finish the operation.

Figure 387 Requesting a local certificate

Entity Damain CRL
Request Cettificate

Domain Mame: torsa w

& Password: T IYYIT) (1-31 Chars.)

() Enahle Offline Mode
lterns marked with an asterisk(®) are required

Cancel

6. Retrieve the CRL:
a. Click the CRL tab.
b. Click Retrieve CRL of the PKI domain of torsa.

Figure 388 Retrieving the CRL

Entity Domain Cerificate

Domain Mame Operation

tarsa [Retrieve CRL][Wiew CRL]

Verifying the configuration

After the configuration, select Authentication > Certificate Management > Certificate from the navigation
tree to view detailed information about the retrieved CA certificate and local certificate, or select
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Authentication > Certificate Management > CRL from the navigation tree to view detailed information
about the retrieved CRL.

Contiguration guidelines

When you configure PKI, follow these guidelines:

Make sure the clocks of entities and the CA are synchronous. Otherwise, the validity period of
certificates will be abnormal.

The Windows 2000 CA server has some restrictions on the data length of a certificate request. If the
PKI entity identity information in a certificate request goes beyond a certain limit, the server will not
respond fo the certificate request.

The SCEP plug-in is required when you use the Windows Server as the CA. In this case, specify RA
as the authority for certificate request when you configure the PKI domain.

The SCEP plug-in is not required when you use the RSA Keon software as the CA. In this case,
specify CA as the authority for certificate request when you configure the PKI domain.
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Configuring MAC authentication

Overview

MAC authentication controls network access by authenticating source MAC addresses on a port. It does
not require client software. A user does not need to enter a username and password for network access.
The device initiates a MAC authentication process when it detects an unknown source MAC address on
a MAC authentication enabled port. If the MAC address passes authentication, the user can access
authorized network resources. If the authentication fails, the device marks the MAC address as a silent
MAC address, drops the packet, and starts a quiet timer. The device drops all subsequent packets from
the MAC address within the quiet time. This quiet mechanism avoids repeated authentication during a
short time.

If the MAC address that has failed authentication is a static MAC address or a MAC address that has

passed any security authentication, the device does not mark the MAC address as a silent address.

User account policies

MAC authentication supports the following user account policies:

e One MAC-based user account for each user—The access device uses the source MAC addresses in
packets as the usernames and passwords of users for MAC authentication. This policy is suitable for
an insecure environment.

e One shared user account for all users—You specify one username and password, which are not
necessarily a MAC address, for all MAC authentication users on the access device. This policy is
suitable for a secure environment.

Authentication methods

You can perform MAC authentication on the access device (local authentication) or through a RADIUS
server.

Local authentication:

e If you configure MAC-based accounts, the access device uses the source MAC address of the
packet as the username and password to search its local account database for a match.

o If you configure a shared account, the access device uses the shared account username and
password to search its local account database for a match.

RADIUS authentication:

o If you configure MAC-based accounts, the access device sends the source MAC address as the
username and password to the RADIUS server for authentication.

e If you configure a shared account, the access device sends the shared account username and
password to the RADIUS server for authentication.
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MAC authentication timers

MAC authentication uses the following timers:

o  Offline detect timer—Sets the interval that the device waits for traffic from a user before it regards
the user idle. If a user connection has been idle for two consecutive intervals, the device logs the
user out and stops accounting for the user.

e Quiet timer—Sets the interval that the device must wait before it can perform MAC authentication
for a user that has failed MAC authentication. All packets from the MAC address are dropped
during the quiet time. This quiet mechanism prevents repeated authentication from affecting system
performance.

e Server timeout timer—Sets the interval that the device waits for a response from a RADIUS server
before it regards the RADIUS server unavailable. If the timer expires during MAC authentication,
the user cannot access the network.

Using MAC authentication with other features
VLAN assignment

You can specify a VLAN in the user account for a MAC authentication user to control its access to
network resources. After the user passes MAC authentication, the authentication server, either the local
access device or a RADIUS server, assigns the VLAN to the port as the default VLAN. After the user logs
off, the initial default VLAN, or the default VLAN configured before any VLAN is assigned by the
authentication server, restores. If the authentication server assigns no VLAN, the initial default VLAN
applies.

A hybrid port is always assigned to a serverassigned VLAN as an untagged member. After the
assignment, do not re-configure the port as a tagged member in the VLAN.

If MAC-based VLAN is enabled on a hybrid port, the device maps the server-assigned VLAN to the MAC
address of the user. The default VLAN of the hybrid port does not change.

ACL assignment

You can specify an ACL in the user account for a MAC authentication user to control its access to network
resources. After the user passes MAC authentication, the authentication server, either the local access
device or a RADIUS server, assigns the ACL to the access port fo filter the traffic from this user. You must
configure the ACL on the access device for the ACL assignment function. You can change ACL rules while
the user is online.

Auth-Fail VLAN

You can configure an Auth-Fail VLAN on a port to accommodate MAC authentication users that have
failed MAC authentication on the port. Users in the Auth-Fail VLAN can access a limited set of network
resources, such as a software server, to download anti-virus software and system patches. If no MAC
Auth-Fail VLAN is configured, the user that fails MAC authentication cannot access any network
resources.
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If a user in the Auth-Fail VLAN passes MAC authentication, it is removed from the Auth-Fail VLAN and
can access all authorized network resources. If not, the user is still in the Auth-Fail VLAN.

A hybrid port is always assigned to an Auth-Fail VLAN as an untagged member. After the assignment,
do not re-configure the port as a tagged member in the VLAN.

Contiguration prerequisites

Before you configure MAC authentication, complete the following tasks:

1. Configure an ISP domain and specify an AAA method. For more information, see "Configuring
AAA"

o For local authentication, you must also create local user accounts (including usernames and
passwords), and specify the lan-access service for local users.

o For RADIUS authentication, make sure the device and the RADIUS server can reach each other,
and create user accounts on the RADIUS server. If you are using MAC-based accounts, make
sure the username and password for each account are the same as the MAC address of each
MAC authentication user.

2.  Make sure the port security feature is disabled. For more information about port security, see
"Configuring port security."

Recommended configuration procedure

Step Remarks

Required.

This function enables MAC authentication globally and

1. Configuring MAC authentication globall
engunng avientication giobaly configures the advanced parameters.

By default, MAC authentication is disabled globally.

Required.
This function enables MAC authentication on a port.

MAC authentication can take effect on a port only when it is
enabled globally and on the port. You can configure MAC
authentication on ports first.

By default, MAC authentication is disabled on a port.

2. Configuring MAC authentication on a port

Contiguring MAC authentication globally

1. From the navigation tree, select Authentication > MAC Authentication.

2. In the MAC Authentication Configuration area, click Advanced.
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Figure 389 MAC authentication configuration page

MAC Authentication Configuration
[] Enable MAC Authentication

wAdvanced
Offline Detection Period 300 seconds (G0-2147483647, Default = 300)
Quiet Time 60 seconds (1-3600, Default = 60)
Server Timeout Time 100 seconds (100-300, Default = 100)
Authentication ISP Domain -

Authentication Infarmation Format

@ MAC without hyphen (MAC as ‘ooonooc)

() MAC with hyphen (MAC: 25 30630t 16306006300 )
Eined Username Chars. = Password Chars.
(1-55) (1-63)

Ports With MAC Authentication Enabled

[E Port Auth-Fail VLAN Operation

Add Del Selected

3.  Configure MAC authentication global settings as described in Table 125, and then click Apply.

Table 125 Configuration items

ltem Description

Enable MAC Authentication Specifies whether to enable MAC authentication globally.

Sets the period that the device waits for traffic from a user before it

Offline Detection Period regards the user idle.

Sets the interval that the device must wait before it can perform MAC

Quiet Time - . N
viet it authentication for a user that has failed MAC authentication.

Sets the interval that the device waits for a response from a RADIUS

Ti t Ti
Server Timeout Time server before it regards the RADIUS server unavailable.

Specifies the ISP domain for MAC authentication users.

Authentication ISP Domain If no ISP domain is specified, the system default authentication
domain is used for MAC authentication users.

Configures the properties of MAC authentication user accounts.
e MAC without hyphen—Uses MAC-based accounts, and excludes
hyphens from the MAC address, for example, xxxxxxxxxxxx.

e MAC with hyphen—Uses MAC-based accounts, and hyphenates
the MAC address, for example, xx-xxxx-xx-xxxx.

Authentication Information
Format

o Fixed—Uses a shared account. You must specify a username and
password for the account.
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Configuring MAC authentication on a port

1. From the navigation tree, select Authentication > MAC Authentication.
2. In the Ports With MAC Authentication Enabled area, click Add.

Figure 390 Configuring MAC authentication on a port

Enable MAC Authentication

Port Ethernet1/0/1 -

ltems marked with an asterisk(*) are required

Apply Cancel

3. Configure MAC authentication for a port as described in Table 126, and then click Apply.

Table 126 Configuration items

ltem Description

Port Selects a port on which you want to enable MAC authentication.

Specifies whether to enable MAC-based VLAN on the port.
Enable MAC VIAN () IMPORTANT:

You can enable MAC authentication only on hybrid ports.

Specifies an existing VLAN as the MAC authentication Auth-Fail VLAN.

@ IMPORTANT:

e The MAC authentication Auth-Fail VLAN has a lower priority than the
802.1X guest VLAN on a port that performs MAC-based access
control. If a user fails both types of authentication, the access port
adds the user fo the 802.1X guest VLAN. For more information about

Auth-Fail VLAN 802.1X guest VLANS, see "Configuring 802.1X."

e The MAC authentication Auth-Fail VLAN function has higher priority
than the quiet function of MAC authentication.

e The MAC authentication Auth-Fail VLAN function has higher priority
than the block MAC action, but it has lower priority than the shutdown
port action of the port intrusion protection feature. For more
information about port intrusion protection, see "Configuring port
security."
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MAC authentication configuration examples

Local MAC authentication configuration example

Network requirements

As shown in Figure 391, configure local MAC authentication on port Ethernet 1/0/1 to control Internet
access, as follows:

e  Configure all users to belong to the domain aabbcc.net, and specify local authentication for users
in the domain.

o Use the MAC address of each user as the username and password for authentication, and require
that the MAC addresses is hyphenated and in lower case.

e Conlfigure the access device to detect whether a user has gone offline every 180 seconds. When a
user fails authentication, the device does not authenticate the user within 180 seconds.

Figure 391 Network diagram

Supplicant Authenticator

Eth1/0/1
IP network

3
W'T“H

Host Switch
MAC: 00e0-fc12-3456

Configuring a local user

# Add a local user. Set the username and password as 00-e0-fc-12-34-56, the MAC address of the user.
Set the service type to LAN access. (Details not shown.)

Configuring AAA
1. From the navigation tree, select Authentication > AAA.

2. On the Domain Setup page, enter the domain name aabbcc.net and click Apply.
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Figure 392 Creating an ISP domain

I5P Diomain

Authentication

uthorization Accounting

Darnain Mame |aahbcc.net

|V ||:1 - 24 Chars)

Default Darmain | Digsable

Flease selectthe ISP domaings)

v

Domain Mame

3. Click the Authentication tab.
4. Select the ISP domain aabbcc.net.
5. Select LAN-access AuthN, and select Local from the list.

Apply

Default Domain

Figure 393 Configuring the authentication method for the ISP domain

Domain Setup

Authentication Configuration of AAA

Authorization

| 3elect an ISP domain

aabbcc.net v|

Accounting

[ Default Auth

Local

| LAN-access AuthM

Local

h |

[T Login Authn
PPP AuthiM
Paortal AuthM

Mame
MName
Mame
Mame

Mame

Secondary Method
Secondary Method
Secondary Method
Secondary Method
Secondary Method

6. Click Apply.

A configuration progress dialog box appears, as shown in Figure 394.
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Figure 394 Configuration progress dialog box

Current Configuration
Setting LAN-access Authh - Okl

100%

Close

7. After the configuration process is complete, click Close.
Configuring MAC authentication
1. Configure MAC authentication globally:

a. From the navigation tree, select Authentication > MAC Authentication.
Select Enable MAC Authentication.
Click Advanced, and configure advanced MAC authentication.

o

Set the offline detection period to 180 seconds.

Set the quiet timer to 180 seconds.

Select aabbec.net from the Authentication ISP Domain list.

Select MAC with hyphen from the Authentication Information Format area.
Click Apply.

@ ™9 oo
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Figure 395 Configuring MAC authentication globally

MAC Authentication Configuration
Enable MAC Authentication

wAdvanced

Cffline Detection Period 180  |seconds (G0-65535, Default= 300

Cuiet Time 180 |seconds (1-3600, Default= G0)
Server Timeaut Time 100 |seconds (100-300, Default=100)
| Authentication ISP Domain | asbbcc.net v |

Authentication Information Format
O MAC without hyphen (MAC a8 4e0000000)

[ © MAC with hyphen (MAC 23 06 10010010600 |

O Fixed Ussrmarne Chars.(1-65) [] Password|  |Chars.(1-83)
ApRly

Ports With MAC Authentication Enabled

O Part Guest YLAN Operation

Add Del Selected

2. Configure MAC authentication for Ethernet 1/0/1:
a. In the Ports With MAC Authentication Enabled areq, click Add.
b. Select Ethernet1/0/1 from the Port list, and click Apply.

Figure 396 Enabling MAC authentication for port Ethernet 1/0/1

Enable MAC Authentication

Fort Ethermnet1/0M1 -

tems marked with an asterisk(*) are required

Apply Cancel

ACL assignment configuration example

Network requirements

As shown in Figure 397, the switch uses RADIUS servers to perform authentication, authorization, and
accounting.

Configure MAC authentication on port Ethernet 1/0/1 to control Internet access. Make sure an
authenticated user can access the Internet but not the FTP server at 10.0.0.1.

Use MAC-based user accounts for MAC authentication users. The MAC addresses are not hyphenated.
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Figure 397 Network diagram

RADIUS servers
Auth:10.1.1.1
Acct:10.1.1.2

Eth1/0/1

Internet

Host Switch FTP server
192.168.1.10 10.0.0.1

Configuring IP addresses

# Assign an IP address to each interface. Make sure the RADIUS servers, host, and switch can reach
each other. (Details not shown.)

Configuring the RADIUS servers

# Add a user account with the host MAC address unhyphenated as both the username and password,
and specify ACL 3000 as the authorization ACL for the user account. (Details not shown.)

For information about the RADIUS server configuration, see "Configuring RADIUS."
Configuring a RADIUS scheme for the switch
1. Create a RADIUS scheme:

a. From the navigation tree, select Authentication > RADIUS.
Click Add.

Enter the scheme name system.

S

Select the server type Extended.
Select Without domain name from the Username Format list.
Click Apply.
2. Configure the primary authentication server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.
b. Configure the RADIUS authentication server:

= 0o o 0

—  Select Primary Authentication from the Server Type list.
—  Enter 10.1.1.1 in the IP Address field, and enter the port number 1812.
—  Enter expert in the Key field and the Confirm Key field.

c. Click Apply.
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Figure 398 Configuring a RADIUS authentication server

Add RADIUS Server

Server Type Primary Authenticatio -
IP Address @ IPv4 ) IPve  10.1.1.1 #
Port 1812 (1-65535. Default = 1812)
Key sesese (1-64 Chars.)
Confirm Key sesene (1-64 Chars.)
Apply Cancel

3. Configure the primary accounting server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.
b. Configure the primary accounting server:
—  Select the server type Primary Accounting.
—  Enter the IP address 10.1.1.2, and enter the port number 1813.
— Enter expert in the Key field and the Confirm Key field.
c. Click Apply.

Figure 399 Configuring a RADIUS accounting server

Add RADIUS Server

Server Type Primary Accounting -

IP Address @ IPvd (O IPve 10112 *

Port 1813 (1-65535. Default=1813)
Key LAL L L L (1-64 Chars.)

Confirm Key [TITIL] (1-64 Chars.)

Apply Cancel

4. On the RADIUS configuration page, click Apply.
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Figure 400 RADIUS configuration

Add RADIUS Scheme
Scherme Mame |53,fstem )’*(1-32 Chars.)
Cammaon Configuration
Server Type ‘ Extended V|
Lisernarne Format ‘Withnut domain narme V|
b Advanced

RADIUS Server Configuration

Server Type IP Address Port WEM Cperation
Primary
Authentication 10311 1812 m
Primary Accounting 10.1.1.2 1813 m
Add

lterns marked with an asterisk™ are reguired

Apply Cancel

Configuring AAA for the scheme
1. Create an ISP domain:
a. From the navigation tree, select Authentication > AAA.

b. On the Domain Setup page, enter test in the Domain Name field and click Apply.
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Figure 401 Creating an ISP domain

Aulthentication Authorization Accounting
ISP Diomain
Domain Marme |test |V (1 - 24 Chars)
Cefault Domain |Disah|e V|

Apply

Please selectthe ISP domain(s)

Diamain Marme Default Domain

2. Configure AAA authentication method for the ISP domain:
a. Click the Authentication tab.
b. Select the ISP domain test.

c. Select Default AuthN, select the authentication method RADIUS, and select the authentication
scheme system from the Name list.

Figure 402 Configuring the authentication method for the ISP domain

Domain Setup Authorization Accounting

Authentication Configuration of AA4

Select an ISP domain test -
Default Authi RADIUS ~ Name system - Secondary Method -
[] LAN-access AuthM Name Secondary Method
[T Login Authm Name Secondary Method

PPP suthi MName Secondary Method

Portal AuthM MName Secondary Method

Apply
d. Click Apply.

A configuration progress dialog box appears, as shown in Figure 403.
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Figure 403 Configuration progress dialog box

Current Configuration
Setting Default Authi - kI

100%

Close

e. After the configuration process is complete, click Close.
Configure AAA authorization method for the ISP domain:
a. Click the Authorization tab.

b. Select the ISP domain test.

c. Select Default AuthZ, select the authorization mode RADIUS, and select the authorization
scheme system from the Name list.

d. Click Apply.
Figure 404 Configuring the authorization method for the ISP domain

Domain Setup Authentication Accounting

Authorization Configuration of AAA

Selectan ISP domain test -
Default AuthZ RADIUS ~ Name system - Secondary Method -
[ LAM-access Auth? Mame Secondary Method
[T Login Authz Mame Secondary Method
PPP AuthZ MName Secondary Method
Partal AuthZ Mame Secondary Method
Command AuthZ MName

e. After the configuration process is complete, click Close.
Configure AAA accounting method for the ISP domain:

a. Click the Accounting tab.

b. Select the ISP domain test.

c. Select Default Accounting, select the accounting method RADIUS, and select the accounting
scheme system from the Name list.

d. Click Apply.

422



Figure 405 Configuring the accounting method for the ISP domain

Diomain Setup Authentication

Accounting Configuration of ARA

Authorization

Selectan ISP domain test -
[C] Accounting Optional Disable
[¥] Default Accounting RADIUS + Name system -
[T LAM-access Accounting Mame
[] Login Accounting Name
PFPP Accounting Mame
MName

Portal Accounting

e. Affer the configuration process is complete, click Close.

Configuring an ACL

1. From the navigation tree, select QoS > ACL IPv4.

2. Click the Add tab.

3. Enter the ACL number 3000, and then click Apply.

Figure 406 Adding ACL 3000

Summary Basic Setup

Advanced Setup Link Layer Setup

ACL Mumber  [3000

Match Qrder Zonfig w

Secondary Method
Secondary Method
Secondary Method
Secondary Method
Secondary Method

Remove

2000-259949 for basic ACLs.
3000-359949 for advanced ACLs.

4000-45999 for Ethernet frame header ACLs.

Description

ACL Mumhber Type Mumber of Rules match Crdar

4. Click the Advanced Setup tab.

5. Configure the following parameters:

a. Select the ACL 3000.

b. Select Rule ID, and enter the rule ID 0.
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c. Select the action Deny.

d. In the IP Address Filter areq, select Destination IP Address:
— Enter the destination IP address 10.0.0.1.
—  Enter the destination address wildcard 0.0.0.0.

e. Click Add.

Figure 407 Configuring an ACL rule

Summary Add Basic Setup Link Layer Setup
ACL | 3000 A4 Help

Configure an Advanced ACL
[¥] Rule ID 0

Action

[IMan-first Fragments Only DLDgging

IF Address Filter

Rermove

(0-65534, Ifno 1D is entered, the system will specify one.)

[Isource IP Address | | Source Wildeard |

| [¥] Destination I Address |10.0.0.1 |

Destination Wildcard [0.0.0.0

Protocal [P ]

TP Type
ICMF Message

ICHMP Type (0-255) ICMP Code (0-255)
TCPIUDP Port
TCP Connection
Esztablizhed
Source; Operation F'Drt| | | |
Destination: Operation F'Drt| | | |
(Range of Port is 0-65535)
Precedence Filter
DSCP | Not Check |
TOS |NDtCheck - Precedence Mot Check vl
[ITirne Range
Add
Rule 1D Operation Description Time Rat

Configuring MAC authentication
1. Configure MAC authentication globally:

a. From the navigation tree, select Authentication > MAC Authentication.
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b. Select Enable MAC Authentication.
c. Click Advanced.

d. Select the authentication ISP domain test, select the authentication information format MAC
without hyphen, and click Apply.

Figure 408 Configuring MAC authentication globally

mAC Authentication Configuration
| Enable MAC Authentication |

whdvanced

Offline Detection Period 00 seconds (B0-65534, Default= 300)

Quiet Time &0 seconds (1-3600, Default = 60}
Server Timeout Time 100 seconds (100-200, Default= 100)
Authentication ISP Domain | test v

Authentication Infarmation Format
(3 MAC without hyphen (MAC as 0e000000)

O MAC with hyphen (MAC 85 HeHe0e0E0E)

O Fived Username Chars. {1-59) Pasgword Chars. {1-63)

Ports with MAC Authentication Enabled

O Fort Auth-F ail WLAR Operation

Add Del Selacted

2.  Configure MAC authentication for Ethernet 1/0/1:
a. In the Ports With MAC Authentication Enabled areq, click Add.
b. Select the port Ethernet1/0/1, and click Apply.

Figure 409 Enabling MAC authentication for port Ethernet 1/0/1

Enable MAC Authentication

Port Ethernet1/0/1 -

ltems marked with an asteriski*) are required

Apply Cancel

Verifying the configuration

# After the host passes authentication, ping the FTP server from the host to see whether ACL 3000
assigned by the authentication server takes effect.
C:\>ping 10.0.0.1
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Pinging 10.0.0.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
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Configuring port security

Overview

Port security combines and extends 802.1X and MAC authentication to provide MAC-based network
access control. It applies networks that require different authentication methods for different users on a
port.

Port security prevents unauthorized access to a network by checking the source MAC address of inbound
traffic and prevents access to unauthorized devices by checking the destination MAC address of
outbound traffic.

Port security can control MAC address learning and authentication on a port to make sure the port learns
only source trusted MAC addresses.

A frame is illegal if its source MAC address cannot be learned in a port security mode or it it is from a
client that has failed 802.1X or MAC authentication. The port security feature automatically takes a
predefined action on illegal frames. This automatic mechanism enhances network security and reduces
human intervention.

For scenarios that require only 802.1X authentication or MAC authentication, HP recommends you
configure 802.1X authentication or MAC authentication rather than port security for simplicity.

For more information about 8021X and MAC authentication, see "Configuring 802.1X" and
"Configuring MAC authentication."

Port security features

Outbound restriction
The outbound restriction feature is not supported in this release.

The outbound restriction feature prevents traffic interception by checking the destination MAC addresses
in outbound frames. The feature guarantees that frames are sent only to devices that have passed
authentication or whose MAC addresses have been learned or configured on the access device.

Intrusion protection

The intrusion protection feature checks the source MAC addresses in inbound frames for illegal frames
and takes a predefined action on each detected illegal frames. The action can be disabling the port
temporarily, disabling the port permanently, or blocking frames from the illegal MAC address for 3
minutes (not user configurable).

Port security traps

You can configure the port security module to send traps for port security events such as login, logoff, and
MAC authentication. These traps help you monitor user behaviors.

Port security modes
Port security supports the following categories of security modes:
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Basic mode—In this mode, a port can learn the specified number of MAC addresses and save those
addresses as secure MAC addresses. It permits only frames whose source MAC addresses are
secure MAC addresses or configured static MAC addresses. When the number of secure MAC
addresses reaches the upper limit, no more secure MAC addresses can be added.

Advanced mode—Port security supports 802.1X and MAC authentication. Different port security
modes represent different combinations of the two methods.

Table 127 describes the advanced security modes.

Table 127 Advanced security modes

Advanced mode

Description

MAC-Auth

A port performs MAC authentication for users. It services multiple users.

802.1X Port Based

A port performs 802.1X authentication and implements port-based access
control.

In this mode, a port can service multiple 802.1X users. If one 802.1X user
passes authentication, all the other 802.1X users of the port can access the
network without authentication.

In this mode, neither outbound restriction nor intrusion protection will be
triggered.

802.1X Single Host

A port performs 802.1X authentication and implements MAC-based access
control. It services only one user passing 802.1X authentication.

802.1X MAC Based

A port performs 802.1X authentication of users and implements MAC-based
access control. The port in this mode supports multiple online 802.1X users.

802.1X MAC Based Or
oul

Similar to the 802.1X Single Host mode, a port in this mode performs
802.1X authentication of users and allows only one 802.1X user to access
at a time.

e The port also permits frames from a wired terminal whose MAC address
contains a specific OUI.

e For frames from a wireless user, the port performs OUI check at first. If the
OUI check fails, the port performs 802.1X authentication.

MAC-Auth Or 802.1X
Single Host

This mode is the combination of the 802.1X Single Host and MAC-Auth

modes, with 802.1X authentication having higher priority.

e For wired users, the port performs MAC authentication upon receiving
non-802.1X frames and performs 802.1X authentication upon receiving
802.1X frames.

o For wireless users, 802.1X authentication is performed first. If 802.1X
authentication fails, MAC authentication is performed.

MAC-Auth Or 802.1X
MAC Based

Similar to the MAC-Auth Or 802.1X Single Host mode, except that it
supports multiple 802.1X and MAC authentication users on the port.

MAC-Auth Else 802.1X
Single Host

This mode is the combination of the MAC-Auth and 802.1X Single Host
modes, with MAC authentication having higher priority.

e A port in this mode performs only MAC authentication for non-802.1X
frames.

e For 802.1X frames, the port performs MAC authentication and then, if
MAC authentication fails, 802.1X authentication.

MAC-Auth Else 802.1X
MAC Based

Similar to the MAC-Auth Else 802.1X Single Host mode, except that it
supports multiple 802.1X and MAC authentication users on the port.
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The maximum number of users a port supports equals the maximum number of secure MAC addresses
that port security allows or the maximum number of concurrent users the authentication mode in use

allows, whichever is smaller.

An OUl is a 24-bit number that uniquely identifies a vendor, manufacturer, or organization. In MAC
addresses, the first three octets are the OUI.

Configuration guidelines

When you configure port security, follow these restrictions and guidelines:

e Before you enable port security, disable 802.1X and MAC authentication globally.

e Only one port security mode can be configured on a port.

e The outbound restriction feature is not supported in this release.

Recommended configuration procedure

To configure basic port security mode:

Step

Remarks

1. Configuring global settings for
port security

Required.

This function enables port security globally and configures intrusion
protection actions.

By default, port security is disabled globally.

2. Configuring basic port security
control

Required.

This function configures the basic port security mode, maximum secure
MAC addresses, intrusion protection, and outbound restriction for a
port.

By default, port security is disabled on all ports, and access to the ports
is not restricted.

3. Configuring secure MAC
addresses

Optional.

Secure MAC addresses never age out or get lost if saved before the
device restarts. One secure MAC address can be added to only one
port in the same VLAN. You can bind a MAC address to one port in the
same VLAN.

Secure MAC addresses can be learned by a port in basic port security
mode or manually configured in the Web interface.

When the maximum number of secure MAC addresses is reached, no
more can be added. The port allows only packets sourced from a secure
MAC address to pass through.

By default, no secure MAC addresses are configured.

To configure advanced port security mode:
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Step

Remarks

1. Configuring global settings for
port security

Required.

This function enables port security globally and configures intrusion
protection actions.

By default, port security is disabled globally.

2. Configuring advanced port
security control

Required.

This function configures the advanced port security mode, intrusion
protection action, or outbound restriction, and selects whether to
ignore the authorization information from the RADIUS server.

By default, port security is disabled on all ports, and access to the ports
is not restricted.

3. Configuring permitted OUls

Optional.
This setting is available only for the 802.1X MAC Based Or OUI

mode.

You can configure up to 16 permitted OUl values. A port in this mode
allows only one 802.1X user and one user whose MAC address
contains the specified OUI to pass authentication at the same fime.

By default, no OUI values are configured.

Contiguring global settings for port security

1. From the navigation tree, select Authentication > Port Security.

Figure 410 Port security configuration page

Port Security Configuration
] Enable Port Security

P Advanced

Security Ports And Secure MAC Address List

Il Port
[] Ethernet1/0/3 5

P Secure MAC Address List

Advanced Port Security Configuration

Max Number
of MAC

Apply
Intrusion Protection Outbound Restriction Operation
) - ]
Add Del Selected

b Ports Enabled With Advanced Features
b Permitted OUls (for ports working in the mode of '802.1X MAC Based Or QUI")

2. In the Port Security Configuration area, click Advanced.
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Figure 411 Port security configuration
Fort Security Configuration
[] Enable Port Security
widvanced

Temporarily Disabling Port Time 20 |zeconds (20-300, Default= 200

Traps Switch [Omac Learned  []802.1%-Auth Failure [J802.1¥ Logoff [Jg02.1% Logon
Mintrusion I MaC-Auth Failure [ mac-auth Logof [T mac-Auth Logan
Apply

3. Configure global port security seftings as described in Table 128.
4. Click Apply.

Table 128 Configuration items

Item Description

Specifies whether to enable the port security feature globally.
Enable Port Security
By default, port security is disabled.

Configures intrusion protection actions globally.
Intrusion protection actions:

o Temporarily Disabling Port Time—Sets the time length for how long the port is
disabled temporarily upon receiving illegal frames. Traps Switch—Selects one or
more events to trigger trap sending. The following is the available events:

o MAC Learned.
Advanced o 802.1X-Auth Failure.

o 8021X Logoff.

o 802.1X Logon.

o Intrusion.

o MAC-Auth Failure.
o MAC-Auth Logoff.

o MAC-Auth Logon.

Contiguring basic port security control

1. From the navigation tree, select Authentication > Port Security.

On the Port Security page, the Security Ports And Secure MAC Address List area displays the port
security control settings, as shown in Figure 412.

Figure 412 Security Ports And Secure MAC Address List area

Security Ports And Secure MAC Address List

[ Port r-.-1a,§fr-4r_:|lp:3ser Intrusion Protection Outbound Restriction Operation
[[] Ethernet1/0/3 5 - - i
Add Del Selected

b Secure MAC Address List
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2. Click Add.

The page for applying port security control appears.

Figure 413 Configuring basic port security control

Apply Port Security Control

Paort

Max Mumber of MAC

Ethernet1/0/2 -

5 [%{1-1024, Default = 5)

[ Enable Intrusion Protection Disable Port Temporarily

[T Enable Qutbound Restriction | Only MAC-Known Unicasts

[tems marked with an asterisk(*) are required

Apply Cancel

3. Configure basic port security control settings as described in Table 129.

4. Click Apply.

Table 129 Configuration items

ltem

Description

Port

Selects a port where you want to configure port security.

By default, port security is disabled on all ports, and access to the ports is not
restricted.

Max Number of MAC

Sets the maximum number of secure MAC addresses on the port.

The number of authenticated users on the port cannot exceed the specified upper
limit.

You can set the maximum number of MAC addresses that port security allows on
a port for the following purposes:

e Control the maximum number of concurrent users on the port.

e Control the number of secure MAC addresses that can be added with port
security.

NOTE:

The port security's limit on the maximum number of MAC addresses on a port is
independent of the MAC learning limit in MAC address table management.
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ltem

Description

Enable Intrusion Protection

Specifies whether to enable intrusion protection, and selects an action to be
taken on illegal frames.

Available actions:

Disable Port Temporarily—Disables the port for a period of time. The period
can be configured in the global settings. For more information, see
"Configuring global settings for port security."

Disable Port Permanently —Disables the port permanently upon detecting an
illegal frame received on the port. The port does not come up unless you bring
it up manually.

Block MAC—Adds the source MAC addresses of illegal frames to the blocked
MAC addresses list and discards the frames. All subsequent frames sourced
from a blocked MAC address will be dropped. A blocked MAC address is
restored to normal state after being blocked for 3 minutes. The interval is not
user configurable.

Enable Outbound

Restriction

Specifies whether to enable outbound traffic control, and selects a control
method.

Available control methods:

Only MAC-Known Unicasts—Allows only unicast frames with their destination
MAC addresses being authenticated to pass through.

Only Broadcasts and MAC-Known Unicasts—Allows only broadcast and
unicast packets with their destination MAC addresses being authenticated to
pass through.

Only Broadcasts, Multicasts, and MAC-Known Unicasts—Allows only
broadcast, multicast, and known unicast packets with their destination MAC
addresses being authenticated to pass through.

Contiguring secure MAC addresses

1.

From the navigation tree, select Authentication > Port Security.

The Port Security page appears.

In the Security Ports And Secure MAC Address List area, click Secure MAC Address List.

The secure MAC address configuration area displays the secure MAC addresses that have been

learned or configured.

Figure 414 Secure MAC address list

wSecure MAC Address List

Port
Ethernet1/0/3

Click Add.

Port

~  Search | advanced Search

MAC VLAN ID Operation

001b-2188-836f 100 ﬂ

Add Del Selected

The page for adding a secure MAC address appears.

433



4.
5.

Figure 415 Adding secure MAC address

Add Secure MAC Address

Part Ethernet1/0/3 ~ (Select a port with Port-Security enabled)

Secure MAC ;

Address i)

WLAN ID *1-4094, The VLAN ID should match the port)

Iltems marked with an asterisk(*) are required

Apply Cancel

Configure a secure MAC address as described in Table 128.
Click Apply.

Table 130 Configuration items

ltem Description

Port

Selects a port where the secure MAC address is configured.

Secure MAC Address Enters the MAC address that you want to configure as a secure MAC address.

VLAN ID

Enters the ID of the VLAN in which the secure MAC address is configured.
The VLAN must already exist on the selected port.

Contiguring advanced port security control

1.

From the navigation tree, select Authentication > Port Security.

The Port Security page appears.

In the Advanced Port Security Configuration area, click Ports Enabled With Advanced Features.
Figure 416 Ports Enabled With Advanced Features area

Advanced Port Security Configuration
¥Paorts Enabled With Advanced Features

[ Port Security Mode Intrusion Protection Outbound Restriction Ign-;re_ Operation
Authorizaiton
[T] Ethernet1/0i1 MAC-Auth - - Disable ﬂ
Add Del Selected

b Permitted OUIs (for ports working in the mode of '802.1X MAC Based Or QU

Click Add.

The page for configuring advanced port security control appears.
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Figure 417 Configuring advanced port security control

Apply Advanced Port Security Configuration

Port Ethernet1/0/1 -
Security Mode MAC-Auth -
[C]Enable Intrusion Protection Disable Port Temporarily

[[] Enable Qutbound Restriction | Only MAC-Known Unicasts

[l1gnere Authorization

Apply Cancel

4.  Configure advanced port security control as described in Table 131.

5. Click Apply.

Table 131 Configuration items

ltem Description

Port Selects a port where you want to configure port security.
By default, port security is disabled on all ports, and access to the ports is not restricted.
Selects a port security mode.

Security Mode

For more information about advanced security modes, see Table 127.

Enable Intrusion
Protection

Specifies whether to enable intrusion protection, and selects an action to be taken upon
detection of illegal frames.

Available actions:

¢ Disable Port Temporarily—Disables the port for a period of time. The period can be
configured in the global settings. For more information, see "Configuring global
settings for port security."

o Disable Port Permanently—Disables the port permanently upon detecting an illegal
frame received on the port. The port does not come up unless you bring it up manually.

e Block MAC—Adds the source MAC addresses of illegal frames to the blocked MAC
addresses list and discards the frames. All subsequent frames sourced from a blocked
source MAC address will be dropped. A blocked MAC address is restored to normal
state after being blocked for 3 minutes. The interval is fixed and cannot be changed.

Enable Outbound
Restriction

Specifies whether to enable the outbound traffic control, and selects a control method.
Available control methods:

e Only MAC-Known Unicasts—Allows only unicasts frames with their destination MAC
addresses being authenticated to pass through.

e Only Broadcasts and MAC-Known Unicasts—Allows only broadcast and unicasts
packets with their destination MAC addresses being authenticated to pass through.
e Only Broadcasts, Multicasts, and MAC-Known Unicasts—Allows only broadcast,

multicast, and unicasts packets with their destination MAC addresses being
authenticated to pass through.
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ltem Description

Specifies whether to configure the port to ignore the authorization information from the

Ignore authentication server.

Authorization The authorization information is delivered by the authentication server to the device after

an 802.1X user or MAC authenticated user passes authentication.

Contiguring permitted OUIs

1.

From the navigation tree, select Authentication > Port Security.
The Port Security page as shown in Figure 410 appears.
In the Advanced Port Security Configuration area, click Permitted OUIs.

Figure 418 Permitted OUIs

wPermitted OUIs for ports working in the mode of ‘80215 MAC Based Qr OUI%

0L Yalue Add in the forrnat H-H-H. Only the first 24 bits make sense)
oul value Cperation

0004-0000-0000 il

1234-0000-0000 i

Enter the 48-bit MAC address in the format of H-H-H in the OUI Value field.
Click Add.

The system automatically saves the first 24 bits as an OUI value.

Port security contiguration examples

Basic port security mode configuration example

Network requirements

As shown in Figure 419, configure port Ethernet 1/0/3 of the switch as follows:

Allow up to three users to access the port without authentication, and permit the port to learn the
MAC addresses of the users as secure MAC addresses.

After the number of secure MAC addresses reaches 3, the port stops learning MAC addresses. If an
unknown MAC address frame arrives, intrusion protection is triggered and the port is disabled and
stays silence for 30 seconds.

Figure 419 Network diagram

Eth1/0/3
192.168.1.1/24
- Internet

Host Switch
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Configuring global port security settings

From the navigation tree, select Authentication > Port Security.

In the Port Security Configuration area, configure global port security settings:
a.
b.
c.

d.

e.

Select Enable Port Security.

Click Advanced.

Specify the system to disable the port temporarily for 30 seconds.
Select Intrusion from the Trap Switch area.

Click Apply.

Figure 420 Configuring port security

Part Security Configuration
‘ Enahle Port Security

whdvanced

‘ Tempaoararily Disabling Fort Time 30 |zeconds (20-300, Default= 200 ‘

Traps Switch [OmMac Learned  []802.13-Auth Failure [J802.1% Logof

Intrusion [ mac-auth Failure [T mAC-Auth Logor
Apply

Security Ports And Secure MAC Address List

[F] Port R ey Intrusion Protection Outhound Restriction

of MAC

Add Del Selected
b Secure MAC Address List

Advanced Port Secutity Configuration
} Parts Enabled With Advanced Features

b Permitted OUIs (for ports warking in the mode of '802.1% MAC Based Or OUIY

Configuring the basic port security control
In the Security Ports And Secure MAC Address List areq, click Add.
On the page that appears, select Ethernet1/0/3.

vk

Enter 3 as the maximum number of MAC addresses.

[Jg02.1% Logon
I mac-aAuth Logon

Operatian

Select Enable Intrusion Protection, and select Disable Port Temporarily from the list.
Click Apply.
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Figure 421 Applying the port security feature

Apply Port Security Cantral

Port Ethernet1/0/3 -
Max Mumber of MAC 3 P(1-1024, Default = 5)
Enable Intrusion Protection Dizable Port Temporarily -

[F]1 Enable Outbound Restriction | Only MAC-Known Unicasts

Items marked with an asterisk(*) are required

Cancel

Verifying the configuration

1. Display the secure MAC address entries learned and manually configured on port Ethernet 1/0/3.
The maximum number of secure MAC is configured as 3, so up to 3 MAC addresses can be

learned and added as secure MAC addresses, as shown in Figure 422.

Figure 422 Secure MAC address list
Security Ports And Secure MAC Address List

Max Mumber of

& Port MAC Intrusion Protection Outbound Restriction
[7] Ethernet1/0/3 3 - -
Add Del Selected
w3ecure MAC Address List
|o\ Port ~ Search | Advanced Search
= Port MAC WLAN 1D
[] Ethernet1/0/3 0000-0000-0001 100
[T Ethernet1/0/2 0000-0000-0002 100
[] Ethernet1/0/3 001b-2188-86fF 100
Add Del Selected

Operation

@0

Operation

L]
o
L]

2. When the maximum number of MAC addresses is reached, intrusion protection is triggered. Select
Device > Port Management from the navigation tree, and then select the Detail tab.

On the page, click the target port (Ethernet 1/0/3 in this example) to view details.

Figure 423 shows that the port state is inactive.

438



Figure 423 Displaying port state

Summary Setup

Select a Port

Igiiﬂiﬁﬂﬂﬂﬂﬂ 19102
Port State Enabled|[InActive] PVID 100

Flow Control Disabled Link Type ACCRSS

MDI Auto Speed Auto [100M]

Duplex Auto [Full] Max MAC Count Mo Limit

Broadcast Suppression 100%

Multicast Suppression 100% Unicast Suppression 100%

Power Save Disabled Description Ethernet1/0/3 Interface

The table shows the configured values for the selected port, while those inside the square brackets are the actual values of the selected port.

3. Reselect Ethernet 1/0/3 to refresh its data 30 seconds later.

Figure 424 shows that the port state is active.

Figure 424 Displaying port state

Summary Setup
Select a Port
L TG EEEEETE] 191024 Switch .
Port State Enabled [Active] PVID 100
Flow Control Dizabled Link Type Access
MO Auto Speed Auto [100M]
Duplex Auto [Full] Max MAC Count Mo Limit
Broadcast Suppression 100%
Multicast Suppression 100% Unicast Suppression 100%
Power Save Disabled Description Ethernet1/0/3 Interface

The table shows the configured values for the selected port, while those inside the square brackets are the actual values of the selected port.

If you remove MAC addresses from the secure MAC address list, the port can continue to learn
MAC addresses.

Advanced port security mode configuration example

Network requirements

As shown in Figure 425, the switch authenticates the client with a RADIUS server. If the authentication
succeeds, the client is authorized to access the Internet.

e The RADIUS server at 192.168.1.2 functions as the primary authentication server and the secondary
accounting server, and the RADIUS server at 192.168.1.3 functions as the secondary authentication
server and the primary accounting server. The shared key for authentication is name, and the
shared key for accounting is money.
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o All users use the default authentication, authorization, and accounting methods of ISP domain
system.

e The switch sends usernames without domain names to the RADIUS server.
Configure port Ethernet 1/0/1 of the switch to perform the following operations:
e Allow only one 802.1X user to be authenticated.

e Allow up to three OUl values to be configured, and allow one terminal that uses any of the OUI
values to access the port.

Figure 425 Network diagram

RADIUS server
192.168.1.2/24

Eth1/0/1

Internet

Host Switch

NOTE:

Configurations on the host and RADIUS servers are not shown.

Configuring a RADIUS scheme
1. Create a RADIUS scheme:

a. From the navigation tree, select Authentication > RADIUS.
b. Click Add.
c. On the page that appears, configure a RADIUS scheme:
—  Enter the scheme name system.
—  Select the service type Extended.
—  Select Without domain name from the Username Format list.
d. Click Apply.
2. Configure the primary authentication server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.
b. Configure the primary authentication server:
—  Select the server type Primary Authentication.
— Enter the IP address 192.168.1.2, and enter the port number 1812.
— Enter name in both the Key field and the Confirm Key field.
c. Click Apply.
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Figure 426 Configuring the RADIUS authentication server

Add RADIUS Server

Server Type Primary Authenticatio -
IP Address @ IPv4 ) IPve  192.168.1.2 b
Port 1812 (1-65535. Default = 1812)
Key [TTT) (1-64 Chars.)
Confirm Key I (1-64 Chars.)
Apply Cancel

3. Configure the primary accounting server in the RADIUS scheme:
a. In the RADIUS Server Configuration areq, click Add.
b. Configure the primary accounting server:
—  Select the server type Primary Accounting.
—  Enter the IP address 192.168.1.2, and enter the port number 1813.
—  Enter money in both the Key field and the Confirm Key field.

Figure 427 Configuring the RADIUS accounting server

Add RADIUS Server

Server Type Primary Accounting

IP Address @ Pv4 O IPve  192.168.1.2 i

Port 1813 (1-65535. Default = 1813}
Key [TTTT) (1-64 Chars.)

Confirm Key I (1-64 Chars.)

Apply Cancel

c. Click Apply.

The RADIUS Server Configuration area displays the servers you have configured, as shown
in Figure 428.
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Figure 428 Configuring the RADIUS scheme

Add RADIUS Scheme

Scheme Mame

Common Configuration
Server Type
Username Format

P Advanced

RADIUS Server Configuration

system *(1-32 Chars.)

Extended -

Without domain name -

Server Type IP Address Port Operation
Primary Authentication  192.168.1.2 1812 ﬂ
Primary Accounting 192.168.1.2 1813 ﬂ
Add
tems marked with an asterisk(*) are required
Apply Cancel

4. Click Apply.
Configuring AAA
1. Configure AAA authentication method:

a. From the navigation tree, select Authentication > AAA.

b. Click the Authentication tab.

c. Select the ISP domain system.

d. Select Default AuthN, select the authentication method RADIUS from the list, and select
authentication scheme system from the Name list.

Figure 429 Configuring AAA authentication

Domain Setup Authorization Accounting
Authentication Configuration of AAA

Select an ISP domain system -

Default AuthiN RADIUS - Name system - Secondary Method

7] LAN-access AuthM Name Secondary Method

[ Lagin AuthN Name Secondary Method
PPP AuthM Mame Secondary Method
Portal Authi Mame Secondary Method

e. Click Apply.

A dialog box appears, displaying the configuration progress, as shown in Figure 430.
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Figure 430 Configuration progress dialog box

Current Configuration
Setting Default AuthM - OK!

100%

Close

f. When the configuration process is complete, click Close.
Configure AAA authorization method:

a. Click the Authorization tab.

b. Select the ISP domain system.

c. Select Default AuthZ, select authorization method RADIUS from the list, and select the
authorization scheme system from the Name list.

d. Click Apply.
Figure 431 Configuring AAA authorization

Domain Setup Authentication Accounting

Authorization Configuration of A%

Selectan ISF domain system -
[¥] Default AuthZ RADIUS = MName system - Secondary Method -
[ClLAN-access AuthZ MName Secondary Method
[T Login AuthZ MName Secondary Method
PPP AuthZ Mame Secondary Method
Portal AuthZ MName Secondary Method
Command AuthZ MName

e. When the configuration process is complete, click Close.
Configure AAA accounting method:

a. Click the Accounting tab.

b. Select the ISP domain system.

c. Select Default Accounting, select the accounting method RADIUS from the list, and select the
accounting scheme system from the Name list.

d. Click Apply.
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Figure 432 Configuring AAA accounting

Domain Setup Authentication Authorization

Accounting Configuration of AA4

Select an ISP domain system -

[7] Azcounting Optional Disable

[¥] Default Accounting RADIUS » Mame system «| Secondary Method

[T LAM-access Accounting MName Secondary Method

[T Lagin Accounting MName Secondary Method
PPP Accounting MName Secondary Method
Portal Accounting MName Secondary Method

e. When the configuration process is complete, click Close.

Configuring port security

1. Enable port security:
a. From the navigation tree, select Authentication > Port Security.
b. Select Enable Port Security.
c. Click Apply.
Figure 433 Configuring global port security settings

Fart Security Configuration
Enable Port Security

b Advanced

Apply

Security Ports And Secure MAC Address List

(=Y )
P Fart murmber of Intrusn_:un Cuthound Restriction Cperation
MAC Protection
Add Del Selected

FSecure MAC Address List

Advanced Port Security Configuration
FFPaorts Enabled wWith Advanced Features

FPermitted QLIS {for ports working in the mode of '502.1% MAC Based Or QU

2.  Configure advanced port security control:
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a. Inthe Advanced Port Security Configuration areq, click Ports Enabled With Advanced Features,
and then click Add.

b. Select Ethernet1/0/1 from the Port list, and select 802.1X MAC Based Or OUI from the Security
Mode list.

c. Click Apply.

Figure 434 Configuring advanced port security control settings on Ethernet 1/0/1

Apply Advanced Port Security Configuration

Port Ethernet1/0M1 -
Security Mode 021X MAC Based Or QU -
[] Enable Intrusion Protection Disable Port Tempaorarily

[C] Enable Qutbound Restricion | Only MAC-Known Unicasts

Dlgnnre Autharization

Apply Cancel

3. Add permitted OUls:
a. In the Advanced Port Security Configuration area, click Permitted OUIs.
b. Enter 1234-0100-0000 in the OUI Value field.
c. Click Add.

Figure 435 Configuring permitted OUI values

Advanced Port Security Configuration
FPorts Enabled With Advanced Features

wPermitted OIS for parts working in the mode of '802. 13X MAC Based Or QLIS

Ul value1234-0100-0000 Add  lin the format H-H-H. Only the first 24 bits make sense)

QU alue Cperation

d. Repeat previous three steps to add the OUl values of the MAC addresses 1234-0200-0000
and 1234-0300-0000.
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Configuring port isolation

The port isolation feature isolates Layer 2 traffic for data privacy and security without using VLANS. You
can also use this feature to isolate the hosts in a VLAN from one another.

The switch supports only one isolation group that is automatically created as isolation group 1. You
cannot remove the isolation group or create other isolation groups on the device. The number of ports
assigned to the isolation group is not limited.

Within the same VLAN, ports in an isolation group can communicate with those outside the isolation
group at Layer 2.

Contiguring the isolation group

1. Select Security > Port Isolate Group from the navigation tree.
2. Click the Port Setup tab.

Figure 436 Configuring the port isolation group

3. Configure the port isolation group as described in Table 132.
4. Click Apply.

Table 132 Configuration items

ltem Description

Specify the role of the ports to be assigned to the isolation group:

e Isolated port—Assign the ports to the isolation group as isolated ports.

Config type e Uplink port—Assign the port to the isolation group as the uplink port.
The switch does not support the Uplink port config type.
Select the ports you want to assign to the isolation group.
Select port(s) You can click ports on the chassis front panel for selection; if aggregate interfaces

are configured, they will be listed under the chassis panel for selection.
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Port isolation contiguration example

Network requirements

As shown in Figure 437:

e Campus network users Host A, Host B, and Host C are connected to Ethernet 1/0/2, Ethernet
1/0/3, and Ethernet 1/0/4 of Switch.

e Swifch is connected to the external network through Ethernet 1/0/1.

e  Ethernet 1/0/1, Ethernet 1/0/2, Ethernet 1/0/3, and Ethernet 1/0/4 belong to the same VLAN.

Configure Host A, Host B, and Host C so that they can access the external network but are isolated from
one another at Layer 2.

Figure 437 Networking diagram

Internet

Configuring the switch

1. Assign Ethernet 1/0/2, Ethernet 1/0/3, and Ethernet 1/0/4 to the isolation group:
a. Select Security > Port Isolate Group from the navigation tree.
b. Click the Port Setup tab.
c. Select Isolated port for Config Type.

d. Select 2, 3, 4 on the chassis front panel. 2, 3, 4 represent ports Ethernet 1/0/2, Ethernet
1/0/3, and Ethernet 1/0/4, respectively.
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Figure 438 Configuring isolated poris for an isolation group

Summary
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e. Click Apply.
A configuration progress dialog box appears.

f.  After the configuration process is complete, click Close.
Viewing information about the isolation group

Click Summary.

2. Display port isolation group 1, which contains ports Ethernet 1/0/2, Ethernet 1/0/3, and
Ethernet 1/0/4.

Figure 439 Viewing information about port isolation group 1
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Configuring authorized IP

The authorized IP function associates the HTTP or Telnet service with an ACL fo filter the requests of clients.
Only the clients that pass the ACL filtering can access the device.

Contfiguration procedure

1. From the navigation tree, select Security > Authorized IP.

2. Click Setup to enter the authorized IP configuration page.
Figure 440 Authorized IP configuration page

Summary
Telnet
[P ACL MNoChange v IPvE ACL
Weh (HTTF)
IPvd ACL MNoChange v
Rule 1D Operatian Description Time Range

3. Configure authorized IP as described in Table 133.
4. Click Apply.

Table 133 Configuration items

Item Description
Associate the Telnet service with an IPv4 ACL.
IPv4 ACL
| To configure the IPv4 ACL to be selected, select QoS > ACL IPv4.
Telnet
Associate the Telnet service with an IPv6 ACL.
IPv6 ACL
To configure the IPvé ACL to be selected, select QoS > ACL IPvé.
Web Pud ACL Associate the HTTP service with an [Pv4 ACL.
V.
(HTTP) To configure the IPv4 ACL to be selected, select QoS > ACL IPv4.
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Authorized IP configuration example

Network requirements

In Figure 441, configure Switch to deny Telnet and HTTP requests from Host A, and permit Telnet and
HTTP requests from Host B.

Figure 441 Network diagram

Host A

Host B

10.1.1.2124 10.1.1.1/24 @

' Switch

10.1.1.3/24

Configuration procedure

1. Create an ACL:

a.
b.

C.

From the navigation tree, select QoS > ACL IPv4.
Click Create.

Enter 2001 for ACL Number.

Click Apply.

Figure 442 Creating an ACL

Sumemary Basic Setup Advanced Setup

ACLNumber (2001 | |

Match Qrder Canfig »

Link Layer Setup Remaove

2000-2399 for basic ACLs.
3000-3353 for advanced ACLs.
4000-4393 for Ethernet frame header ACLs.

Description

Characters(0-127)

ACL Mumber Type Murnber of Rules

2. Configure an ACL rule to permit Host B:
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a. Click Basic Setup.
The page for configuring an ACL rule appears.

b. Select 2001 from the ACL list, select Permit from the Action list, select the Source IP Address
box and enter 10.1.1.3, and then enter 0.0.0.0 in the Source Wildcard field.

c. Click Add.
Figure 443 Configuring an ACL rule to permit Host B

surmrmary Create Advanced Setup Link Layer Setup Remaove

L&CL 2001 b |

configure a Basic ACL

JRule D (0-65534, Ifno ID is entered, the system will specify one. )
|Acti0n Fermit « |
[ check Fragment [ check Logaing
‘ [¥] Source IP Address 10.1.1.3 Source Yildcard 0.0.0.0 |
O Time Range
Add
Rule ID Operation Description Time Range

Configure authorized IP:
a. From the navigation tree, select Security > Authorized IP.
b. Click Setup.

The authorized IP configuration page appears.

c. Select 2001 for IPv4 ACL in the Telnet field, and select 2001 for IPv4 ACL in the Web (HTTP)
field.

d. Click Apply.
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Figure 444 Configuring authorized IP

Surmmary mm

I Telnet
IPvaACL: | 2001 v IPVBEACL: | MoChange
teh (HTTP)
IPva ACL: 2001 v
Rule ID Cperation Description Time Range
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Configuring loopback detection

A loop occurs when a port receives a packet sent by itself. Loops might cause broadcast storms. The
purpose of loopback detection is to detect loops on ports.

With loopback detection enabled on an Ethernet port, the device periodically checks for loops on the
port. If the device detfects a loop on the port, it operates on the port according to the preconfigured
loopback detection actions.

When the device detects a loop on an access port, it disables the port from forwarding data packets,
sends a trap message to the terminal, and deletes the corresponding MAC address forwarding entry.

When the device detects a loop on a trunk port or a hybrid port, it sends a trap message to the terminal.
If loopback detection control is also enabled on the port, the device disables the port from forwarding
data packets, sends a trap message to the terminal, and deletes the corresponding MAC address
forwarding entry.

Recommended configuration procedure

Step Remarks

1. Configuring loopback detection globally Required.

By default, loopback detection is disabled globally.

2. Configuring loopback detection on a port Required.

By default, loopback detection is disabled on a port.

NOTE:

Loopback detection takes effect on a port only after you enable loopback detection both globally and on the port.

Contiguring loopback detection globally

1. From the navigation tree, select Security > Loopback Detection.

The System Loopback Detection area appears.
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Figure 445 Loopback detection configuration page

B

System Loopback Detection

Port Loopback Detection

Loopback Detection

Ethernet1/0M1
Ethernet1/0/2
Ethernet1/0/3
Ethernet1/0/4
Ethernet1/0/5
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Ethernet1/0/12
Ethernet1/0M13
Ethernet1/0/14

Ethernet1/015

[] Enable loopback detection on the system Interval: 30 Seconds(5-300, Default = 30)
Apply
< Interface Name ~ | Search | | advanced Search
Interface Name Loopback Deteclion Detection Control Detection in VLAN
Disable ~ Disable
Disable ~ Disable
Disable ~ Disable
Disable + Disable
Disable ~ Disable
Disable ~ Disable
Disable ~ Disable
Disable Disable
Disable ~ Disable
Disable Disable
Disable ~ Disable
Disable ~ Disable
Disable ~ Disable
Disable ~ Disable
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26 records, 15~ per page | page 1/2, record 1-15 | Next Last 1 GO
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2. Configure the global loopback detection settings as described in Table 134, and then click Apply.

Table 134 Configuration items

ltem Description
Enable loopback detection on the system Sets whether to enable loopback detection globally.
Loopback Detection Interval Sets the loopback detection interval.

Contiguring loopback detection on a port

1. From the navigation tree, select Security > Loopback Detection.

The Port Loopback Detection area appears.

2. Configure loopback detection on a port as described on Table 135, and then click Apply.

Table 135 Configuration items

ltem

Description

Loopback Detection

Sets whether to enable loopback detection on the target port.

Detection Control

Sets whether the system disables the target trunk or hybrid port from forwarding
data packets when the device detects a loop on it.

This configuration item is available only for a trunk or hybrid port.

Detection in VLAN

Sets whether the system performs loopback detection in all VLANS for the target
trunk or hybrid port.

If you select Disable, the system performs loopback detection only in the default
VLAN of the target trunk or hybrid port.

This configuration item is available only for a trunk or hybrid port.
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Configuring ACLs

Unless otherwise stated, ACLs refer to both IPv4 and IPvé ACLs throughout this document. Grayed-out
options on Web configuration pages cannot be configured.

Overview

An access control list (ACL) is a set of rules (or permit or deny statements) for identifying traffic based on
criteria such as source IP address, destination IP address, and port number.

AClLs are essentially used for packet filtering. A packet filter drops packets that match a deny rule and
permits packets that match a permit rule. ACLs are also widely used by many modules, for example, QoS
and IP routing, for traffic identification.

ACL categories

Category ACL number IP version  Match criteria

IPv4 Source IPv4 address
Basic ACLs 2000 to 2999

IPv6 Source IPv6 address

Source/destination IPv4 address, protocol number,

IPva and other Layer 3 and Layer 4 header fields
Advanced ACLs 3000 to 3999
Pv6 Source/destination IPv6 address, protocol number,
v and other Layer 3 and Layer 4 header fields
Ethernet frame IPv4 and Layer 2 header fields, such as source and destination
header ACL 4000 to 4999 Pv6 MAC addresses, 802.1p priority, and link layer

protocol type

Match order

The rules in an ACL are sorted in certain order. When a packet matches a rule, the device stops the match
process and performs the action defined in the rule. If an ACL contains overlapping or conflicting rules,
the matching result and action to take depend on the rule order.

The following ACL match orders are available:

e Config—Sorts ACL rules in ascending order of rule ID. A rule with a lower ID is matched before a
rule with a higher ID. If you use this method, check the rule content and order carefully.

e Auto—Sorts ACL rules in depth-first order. Depth-first ordering makes sure any subset of a rule is
always matched before the rule. Table 136 lists the sequence of tie breakers that depth-first ordering
uses fo sort rules for each type of ACL.
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Table 136 Depth-first match for ACLs

ACL category Sequence of tie breakers

1. More Os in the source IP address wildcard (more Os means a narrower
IPv4 basic ACL IP address range).

2. Smaller rule ID.
1. Specific protocol number.
2. More Os in the source IP address wildcard mask.
IPv4 advanced ACL 3. More Os in the destination IP address wildcard.
4.  Narrower TCP/UDP service port number range.
5.  Smaller ID.
1. Llonger prefix for the source IP address (a longer prefix means a
IPv6 basic ACL narrower |P address range).
2. Smaller ID.
1. Specific protocol number.
2. Longer prefix for the source IPvé address.
IPv6 advanced ACL 3. Longer prefix for the destination IPv6 address.
4.  Narrower TCP/UDP service port number range.
5.  Smaller ID.
1. More 1s in the source MAC address mask (more 1s means a smaller
MAC address).
Ethernet frame header ACL 2.  More 1s in the destination MAC address mask.
3. Smaller ID.

A wildcard mask, also called an "inverse mask," is a 32-bit binary and represented in dotted
decimal notation. In contrast to a network mask, the O bits in a wildcard mask represent ‘do care’
bits, while the 1 bits represent 'don’t care bits'. If the 'do care' bits in an IP address identical to the
'do care' bits in an IP address criterion, the IP address matches the criterion. All 'don’t care' bits
are ignored. The Os and 1s in a wildcard mask can be noncontiguous. For example, 0.255.0.255
is a valid wildcard mask.

Rule numbering

ACL rules can be manually numbered or automatically numbered. This section describes how automatic
ACL rule numbering works.

Rule numbering step

If you do not assign an ID to the rule you are creating, the system automatically assigns it a rule ID. The
rule numbering step sets the increment by which the system automatically numbers rules. For example, the
default ACL rule numbering step is 5. If you do not assign IDs to rules you are creating, they are
automatically numbered O, 5, 10, 15, and so on. The wider the numbering step, the more rules you can
insert between two rules.

By introducing a gap between rules rather than contiguously numbering rules, you have the flexibility of
inserting rules in an ACL. This feature is important for a config-order ACL, where ACL rules are matched
in ascending order of rule ID.

Automatic rule numbering and renumbering

The ID automatically assigned to an ACL rule takes the nearest higher multiple of the numbering step to
the current highest rule ID, starting with 0.
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For example, if the numbering step is 5 (the default), and there are five ACL rules numbered O, 5, 9, 10,
and 12, the newly defined rule is numbered 15. If the ACL does not contain any rule, the first rule is
numbered O.

Whenever the step changes, the rules are renumbered, starting from O. For example, if there are five rules
numbered 5, 10, 13, 15, and 20, changing the step from 5 to 2 causes the rules to be renumbered O, 2,
4, 6, and 8.

Implementing time-based ACL rules

You can implement ACL rules based on the time of day by applying a time range to them. A time-based
ACL rule takes effect only in any time periods specified by the time range.

The following basic types of time range are available:
e Periodic time range—Recurs periodically on a day or days of the week.

e Absolute time range—Represents only a period of time and does not recur.

IPv4 fragments filtering with ACLs

Traditional packet filtlering matches only first fragments of IPv4 packets, and allows all subsequent
non-irst fragments to pass through. Attackers can fabricate non-irst fragments to attack networks.

To improve network security, ACL filters all packets by default, including fragments and non-fragmented
packets. Meanwhile, to improve match efficiency, you can modify ACL rules. For example, you can
configure ACL rules to filter non-first fragments only.

Contiguration guidelines

When you configure an ACL, follow these guidelines:

e You cannot add a rule with, or modify a rule to have, the same permit/deny statement as an
existing rule in the ACL.

¢ You can only modify the existing rules of an ACL that uses the match order of config. When
modifying a rule of such an ACL, you can choose to change just some of the settings, in which case
the other settings remain the same.

Recommend ACL configuration procedures

Recommended IPv4 ACL configuration procedure

Step Remarks

Optional.

1. Configuring a time range. Add a time range. A rule referencing a time range

takes effect only during the specified time range.

Required.

2. Adding an IPv4 ACL. Add an IPv4 ACL. The category of the added ACL
depends on the ACL number that you specity.
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Step

Remarks

3. Configuring a rule for a basic IPv4 ACL.

Required.

4. Configuring a rule for an advanced IPv4 ACL.

Complete one of the following tasks according to

5. Configuring a rule for an Ethernet frame header ACL.

the ACL category.

Recommended IPvé6 ACL configuration procedure

Step

Remarks

1. Configuring a time range.

Optional.

Add a time range. A rule referencing a time range takes
effect only during the specified time range.

2. Adding an IPv6 ACL.

Required.

Add an IPv6 ACL. The category of the added IPv6 ACL
depends on the ACL number that you specify.

w

Configuring a rule for a basic IPvé ACL.

Required.

&

Configuring a rule for an advanced IPvé ACL.

Comeplete one of the tasks according to the ACL category.

Configuring a time range

1. Select QoS > Time Range from the navigation tree.

2. Click the Add tab.
Figure 446 Adding a time range

Summary Remaove

Time Range Mame
[ Periodic Time Range
Start Time
3un Man
[Jabsolute Tirme Range
Fram

To
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(1-32 Chars.)

End Time
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Apply

3. Configure a time range as described in Table 137.
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4. Click Apply.

Table 137 Configuration items

ltem

Description

Time Range Name

Set the name for the time range.

Set the start time of the periodic time range.

Set the end time of the periodic time range. The end time must
be greater than the start time.

Select the day or days of the week on which the periodic time
range is valid. You can select any combination of the days of
the week.

Set the start time and date of the absolute time range. The time
of the day is in the hh:mm format (24-hour clock), and the date
is in the MM/DD/YYYY format.

Start Time
End Time
Periodic
Time Range  Sun, Mon,
Tue, Wed,
Thu, Fri,
and Sat.
From
Absolute
Time Range
To

Set the end time and date of the absolute time range. The time
of the day is in the hh:mm format (24-hour clock), and the date
is in the MM/DD/YYYY format. The end time must be greater

than the start time.

You can define
both a periodic
time range and
an absolute
time range to
add a
compound time
range. This
compound time
range recurs on
the day or days
of the week
only within the
specified
period.

Adding an IPv4 ACL

1. Select QoS > ACL IPv4 from the navigation tree.

2. Click the Add tab.

Figure 447 Adding an IPv4 ACL

Apply

Summary Basic Setup Advanced Setup Link Layer Setup Femaove
AL Mumber 2000-25949 far hasic ACLs.
3000-35949 for advanced ACLs.
4000-4594 far Ethernet frame header ACLs.
match Order Config
Description
Characters(0-127)
ACL Mumber Type Mumber of Rules Match Order Description

3. Add an IPv4 ACL as described in Table 138.

4. Click Apply.
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Table 138 Configuration items

Item Description
ACL Number Set the number of the IPv4 ACL.
Set the match order of the ACL. Available values are:
Match Order J fg:;lggL;ePdCfckeis are compared against ACL rules in the order that the rules are

o Auto—Packets are compared against ACL rules in the depth-first match order.

Description Set the description for the ACL.

Contiguring a rule for a basic IPv4 ACL

Select QoS > ACL IPv4 from the navigation tree.
2.  Click the Basic Setup tab.

The rule configuration page for a basic IPv4 ACL appears.
Figure 448 Configuring a basic IPv4 ACL

Summary Add Advanced Setup Link Layer Setup Femaove

AL | Selectan ACL w

Configure a Basic ACL

[JrRule 1D (0-65534, Ifno 1D is entered, the system will specify ane. )

Action Fermit

[Ocheck Fragment [check Logging

[ source IP Address Source Wildcard

[JTime Range

Rule ID Cperation Description Time Rar

3. Configure a rule for a basic IPv4 ACL.
4. Click Add.
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Table 139 Configuration items

ltem Description

Acl Select the basic IPv4 ACL for which you want to configure rules.
Available ACLs are basic IPv4 ACLs.

Select the Rule ID box and enter a number for the rule.

Rule ID If you do not specify the rule number, the system will assign one automatically.
If the rule number you specify already exists, the following operations modify
the configuration of the rule.

Select the action to be performed for IPv4 packets matching the rule:

Action e Permit—Allows matched packets to pass.

e Deny—Drops matched packets.

Check Fragment

Select this box to apply the rule to only nonirst fragments.

If you do no select this box, the rule applies to all fragments and
non{fragments.

Check Logging

Select this box to keep a log of matched IPv4 packets.

A log entry contains the ACL rule number, operation for the matched packets,
protocol number, source/destination address, source/destination port
number, and number of matched packets.

This function is not supported.

Source IP Address
Source Wildcard

Select the Source IP Address box and enter a source IPv4 address and a
wildcard mask, in dotted decimal notation.

Time Range

Select the time range during which the rule takes effect.

Contiguring a rule for an advanced IPv4 ACL

1. Select QoS > ACL IPv4 from the navigation tree.
2. Click the Advance Setup tab.

The rule configuration page for an advanced IPv4 ACL appears.
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Figure 449 Configuring an advanced IPv4 ACL
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3. Configure a rule for an advanced IPv4 ACL as described in Table 140.
4. Click Add.
Table 140 Configuration items

ltem Description

Select the advanced IPv4 ACL for which you want to configure
ACL rules.

Available ACLs are advanced IPv4 AClLs.
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ltem Description

Select the Rule ID box and enter a number for the rule.

If you do not specify the rule number, the system will assign one
Rule ID automatically.

If the rule number you specify already exists, the following

operations modify the configuration of the rule.

Select the action to be performed for packets matching the rule:
Action e Permit—Allows matched packets to pass.

e Deny—Drops matched packets.

Non-First Fragments Only

Select this box to apply the rule to only non-first fragments.

If you do no select this box, the rule applies to all fragments and
non-fragments.

Logging

Select this box to keep a log of matched packets.

A log entry contains the ACL rule number, operation for the
matched packets, protocol number, source/destination address,
source/destination port number, and number of matched
packets.

This function is not supported.

Source IP Address

Source Wildcard
IP Address Filter

Select the Source IP Address box and enter a source IPv4
address and a source wildcard mask, in dotted decimal
notation.

Destination IP Address

Destination Wildcard

Select the Source IP Address box and enter a source IP address
and a source wildcard mask, in dotted decimal notation.

Select the protocol number.

If you select 1 ICMP, you can configure the ICMP message type
and code. If you select 6 TCP or 17 UDP, you can configure the
TCP or UDP port.

Protocol
ICMP Message
ICMP Type
ICMP Type
ICMP Code

Specify the ICMP message type and code.

These items are available only when you select 1 ICMP from the
Protocol list.

If you select Other from the ICMP Message list, you need to type
values in the ICMP Type and ICMP Code fields. Otherwise, the
two fields will take the default values, which cannot be changed.
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ltem

Description

TCP Connection
Established

Select this box to make the rule match packets used for
establishing and maintaining TCP connections.

These items are available only when you select 6 TCP from the
Protocol list.

Source
Port

Operator

Operator

TCP/UDP Port

Destination
Port

Select the operators and enter the source port numbers and
destination port numbers as required.

These items are available only when you select 6 TCP or 17 UDP
from the Protocol list.

Different operators have different configuration requirements for
the port number fields:

o Not Check—The following port number fields cannot be
configured.

e Range—The following port number fields must be configured
to define a port range.

o Other values—The first port number field must be configured
and the second must not.

Only Not Check and Other values are supported.

DSCP

Specify the DSCP value. If you specify the ToS

Precedence 105

Specify the To$ preference precedence or IP precedence

Filter
Precedence

when you specify the DSCP
value, the specified TOS or IP
Specify the IP precedence. precedence does not take
effect.

Time Range

Select the time range during which the rule takes effect.

Contiguring a rule for an Ethernet frame header ACL

1. Select QoS > ACL IPv4 from the navigation tree.

2. Click the Link Layer Setup tab.

The rule configuration page for an Ethernet frame header IPv4 ACL appears.
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Figure 450 Configuring a rule for an Ethernet frame header ACL
sSummany Add Basic Setup Advanced Setup Femove

ACL | Selectan ACL Help

Configure an Ethernet frame header ACL
Orule 1D (0-65534, Ifno [D is entered, the system will specify one.)
Action Perrmit

MAC Address Filter

[ source MAG Address Source Mask

[ Destination MAC Address Destination Mask

Format of MAC address and mask is "H-H-H"

COS(802.1p priority| -Mone-- b

Type Filter

CIL=aP Type (0-FFFF) LEAP Mask (0-FFFF)

[ Protocal Type (0-FFFF) Pratocal Mask (0-FFFF)
[ Time Range

Rule D Operation Description Time Rat
4 »

Configure a rule for an Ethernet frame header IPv4 ACL as described in Table 141.
Click Add.

Table 141 Configuration items

ltem Description

ACL

Select the Ethernet frame header IPv4 ACL for which you want to configure
rules.

Available ACLs are Ethernet frame header IPv4 AClLs.

Rule

Select the Rule ID box and enter a number for the rule.

If you do not specify the rule number, the system will assign one
ID automatically.

If the rule number you specify already exists, the following operations
modify the configuration of the rule.

Select the action to be performed for packets matching the rule:

Action o Permit—Allows matched packets to pass.

o Deny—Drops matched packets.
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ltem Description
Source MAC
Address Select the Source MAC Address box and enter a source MAC address and
a mask.
MAC Source Mask
Address
Filter Destination MAC
Address Select the Destination MAC Address box and enter a destination MAC

Destination Mask

address and a mask.

COS(802.1p priority)

Specify the 802.1p priority for the rule.

Select the LSAP Type box and specify the DSAP and SSAP fields in the LLC

LSAP Type encapsulation by configuring the following items:
o LSAP Type—Frame encapsulation format.
LSAP Mask « LSAP Mask—LSAP mask.
Type Filter  protocol Type Select the Protocol Type box and specify the link layer protocol type by
configuring the following items:
e Protocol Type—Frame type. It corresponds to the type-code field of
Protocol Mask Ethernet_Il and Ethernet_ SNAP frames.
o Protocol Mask—Protocol mask.
Time Range Select the time range during which the rule takes effect.

Adding an IPv6 ACL

Select QoS > ACL IPv6 from the navigation tree.

2. Click the Add tab.

The IPvé6 ACL configuration page appears.
Figure 451 Adding an IPv6 ACL

Summary Basic Setup Advanced Setup Retmave

ACL Murmber
Match Order Confiy +
Diescription

ACL Humhber Type

3. Addan IPv6 ACL.
4. Click Apply.

2000-2999 far Basic ACL.
3000-3994 for Advanced ACL.

Characters{0-127)
Apply Cancel

Murmhber of Rules Match Order Description
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Table 142 Configuration items

ltem Description
ACL Number Enter a number for the IPv6 ACL.
Select a match order for the ACL. Available values are:
Match Order e Config—Packets are compared against ACL rules in the order the rules are
configured.

o Auto—Packets are compared against ACL rules in the depth-first match order.

Description Set the description for the ACL.

Contiguring a rule for a basic IPvé ACL

Select QoS > ACL IPvé6 from the navigation tree.
2.  Click the Basic Setup tab.
The rule configuration page for a basic IPvé ACL appears.

Figure 452 Configuring a rule for a basic IPvé ACL
Summary Add Advanced Setup Remove
Select Access Control List(acLy | Selectan ACL »

Configure a Basic ACL

CJRule ID (0-65534, Ifno (D is entered, the systerm will specify one.)
Ciperation FPermit
[dcheck Fragment [check Logging
[ source IP Address Source Prefix
CTime Fange
Cancel
Rule 1D Ciperation Diescription Time Rar
1 3

3.  Add a rule for a basic IPvé ACL.
4. Click Add.

Table 143 Configuration items

ltem Description

fii:e(cAfac):cess Control Select the basic IPvé ACL for which you want to configure rules.
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ltem Description

Select the Rule ID box and enter a number for the rule.

If you do not specify the rule number, the system will assign one automatically.

Rule ID
If the rule number you specify already exists, the following operations modify the
configuration of the rule.
Select the operation to be performed for IPvé packets matching the rule:
Operation e Permit—Allows matched packets to pass.

e Deny—Drops matched packets.

Select this box to apply the rule to only nonirst fragments.
Check Fragment
If you do no select this box, the rule applies to all fragments and non-fragments.

Select this box to keep a log of matched IPvé packets.

A log entry contains the ACL rule number, operation for the matched packets, protocol
Check Logging number, source/destination address, source/destination port number, and number of
matched packets.

This function is not supported.

Source IP Address Select the Source IP Address box and enter a source IPvé address and prefix length.
The IPvé address must be in a format like X:X::X:X. An IPv6 address consists of eight
Source Prefix 16-bit long fields, each of which is expressed with two hexadecimal numbers and

separated from its neighboring fields by colon (:).

Time Range Select the time range during which the rule takes effect.

Contiguring a rule for an advanced IPvé6 ACL

1. Select QoS > ACL IPv6 from the navigation tree.
2. Click the Advance Setup tab.

The rule configuration page for an advanced IPvé ACL appears.
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Figure 453 Configuring a rule for an advanced IPv6 ACL
Surrimary Add Basic Setup Refnove
Select Access Cantral ListiACL) Selectan ACL Help

Configure an Advanced ACL

Crule 1D (0-65534, Ifno 1D is entered, the system will specify ane.)
Operation Permit «

[JcheckFragment [l Check Logoing

IP Address Filter

[J5ource IP Address Source Prefix
[ Destination IP Address Destination Prefix
Pratacol | IPY¥6 ~

1CMPyE Type

Mamed ICMPYE Type

ICMPYE Type (0-255)  ICMPYE Code (0-255)

TCPUDP Port

Source: Operation Port To Port

Destination: Cperation Port To Port
(Range of Partis 0-65535)

[CITirme Range
Cancel
Rule ID Operation Description Time Rar

3. Add a rule for an advanced IPv6 ACL as described in Table 144,
4. Click Add.
Table 144 Configuration items

Item Description

Select Access Control List (ACL) Select the advanced IPvé ACL for which you want to configure rules.

Select the Rule ID box and enter a number for the rule.

If you do not specify the rule number, the system will assign one
Rule ID automatically.

If the rule number you specify already exists, the following operations
modify the configuration of the rule.

Select the operation to be performed for IPv6 packets matching the

rule:

Operation e Permit—Allows matched packets to pass.

e Deny—Drops matched packets.
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ltem

Description

Check Fragment

Select this box to apply the rule to only nonirst fragments.

If you do no select this box, the rule applies to all fragments and
nonfragments.

Check Logging

Select this box to keep a log of matched IPvé packets.

A log entry contains the ACL rule number, operation for the matched
packets, protocol number, source/destination address,
source/destination port number, and number of matched packets.

This function is not supported.

Source IP Address

Source Prefix

Select the Source IP Address box and enter a source IPvé address and
prefix length.

The IPvé address must be in a format like X:X::X:X. An IPv6 address
consists of eight 16-bit long fields, each of which is expressed with
two hexadecimal numbers and separated from its neighboring fields

IP by colon (:
y colon (:).
Address
Filter Select the Destination IP Address box and enter a destination IPvé
Destination IP Address address and prefix length.
The IPvé address must be in a format like X:X::X:X. An IPv6 address
consists of eight 16-bit long fields, each of which is expressed with
Destination Prefix two hexadecimal numbers and separated from its neighboring fields
by colon (:).
Select the protocol number.
Protocol If you select 58 ICMPv6, you can configure the ICMP message type
and code. If you select 6 TCP or 17 UDP, you can configure the TCP or
UDP specific items.
Named ICMPvé Type Specify the ICMPv6 message type and code.
ICMPv6 Type These items are available only when you select 58 ICMPv6 from the
ICMPv6 Protocol list.
Type If you select Other from the Named ICMPvé6 Type list, you need to enter
ICMPv6 Code values in the ICMPv6 Type and ICMPv6 Code fields. Otherwise, the
two fields will take the default values, which cannot be changed.
Operator Select the operators and enter the source port numbers and
destination port numbers as required.
Source  Port
These items are available only when you select 6 TCP or 17 UDP from
To Port the Protocol list.
Operator Different operators have different configuration requirements for the
port number fields:
TCP/UDP Port : ,
Port o Not Check—The following port number fields cannot be
configured.
Destinati . ' .
e Range—The following port number fields must be configured to
on To Port define a port range.
o Por
o Other values—The first port number field must be configured and
the second must not.
Only Not Check and Other values are supported.
Time Range Select the time range during which the rule takes effect.
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Configuring QoS

Grayed-out options on Web configuration pages cannot be configured.

Overview

Quality of Service (QoS) reflects the ability of a network to meet customer needs. In an internet, QoS
evaluates the ability of the network to forward packets of different services.

The evaluation can be based on different criteria because the network might provide various services.
Generally, QoS performance is measured with respect to bandwidth, delay, jitter, and packet loss ratio
during packet forwarding process.

Networks without QoS guarantee

On traditional IP networks without QoS guarantee, devices treat all packets equally and handle them
using the first in first out (FIFO) policy. All packets share the resources of the network and devices. How
many resources the packets can obtain completely depends on the time they arrive. This service is called
"best-effort." It delivers packets to their destinations as possibly as it can, without any guarantee for delay,
jitter, packet loss ratio, and so on.

This service policy is only suitable for applications insensitive to bandwidth and delay, such as Word
Wide Web (WWW) and email.

QoS requirements of new applications

The Internet has been growing along with the fast development of networking technologies.

Besides traditional applications such as WWW, email and FTP, network users are experiencing new
services, such as tele-education, telemedicine, video telephone, videoconference and Video-on-Demand
(VoD). Enterprise users expect to connect their regional branches together with VPN technologies to
carry out operational applications, for instance, to access the database of the company or to monitor
remote devices through Telnet.

These new applications all have special requirements for bandwidth, delay, and jitter. For example,
videoconference and VoD require high bandwidth, low delay and jitter. As for mission-critical
applications, such as transactions and Telnet, they might not require high bandwidth but do require low
delay and preferential service during congestion.

The emerging applications demand higher service performance of IP networks. Better network services
during packets forwarding are required, such as providing dedicated bandwidth, reducing packet loss
ratio, managing and avoiding congestion, and regulating network traffic. To meet these requirements,
networks must provide more improved services.
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Conges’rion: causes, impacts, and countermeasures

Network congestion is a major factor contributed to service quality degrading on a traditional network.
Congestion is a situation where the forwarding rate decreases due to insufficient resources, resulting in

extra delay.
Causes
Congestion easily occurs in complex packet switching circumstances in the Internet. Figure 454 shows
two common cases:
Figure 454 Traffic congestion causes
100Ml
100M 10M 10M 100M
— %—» — —
100M > 10M T
50M
(100M + 10M + 50M) > 100M
(1) ()
o The traffic enters a device from a high speed link and is forwarded over a low speed link.
o The packet flows enter a device from several incoming interfaces and are forwarded out of an
outgoing interface, whose rate is smaller than the total rate of these incoming interfaces.
When traffic arrives at the line speed, a bottleneck is created at the outgoing interface causing
congestion.
Besides bandwidth bottlenecks, congestion can be caused by resource shortage in various forms such as
insufficient processor time, buffer, and memory, and by network resource exhaustion resulting from
excessive arriving traffic in certain periods.
Impacts
Congestion might bring these negative results:
e Increased delay and jitter during packet transmission
e Decreased network throughput and resource use efficiency
e Network resource (memory in particular) exhaustion and even system breakdown
It is obvious that congestion hinders resource assignment for traffic and degrades service performance.
Congestion is unavoidable in switched networks and multi-user application environments. To improve the
service performance of your network, you must address the congestion issues.
Countermeasures

A simple solution for congestion is to increase network bandwidth, however, it cannot solve all the
problems that cause congestion because you cannot increase network bandwidth infinitely.

A more effective solution is to provide differentiated services for different applications through traffic
control and resource allocation. In this way, resources can be used more properly. During resources
allocation and traffic control, the direct or indirect factors that might cause network congestion should be
controlled to reduce the probability of congestion. Once congestion occurs, resource allocation should
be performed according to the characteristics and demands of applications to minimize the effects of
congestion.
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End-to-end QoS

Figure 455 End-to-end QoS model
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As shown in Figure 455, traffic classification, traffic policing, traffic shaping, congestion management,
and congestion avoidance are the foundations for a network to provide differentiated services. Mainly
they implement the following functions:

o Traffic classification—Uses certain match criteria fo organize packets with different characteristics
into different classes. Traffic classification is usually applied in the inbound direction of a port.

e Traffic policing—Polices particular flows entering or leaving a device according to configured
specifications and can be applied in both inbound and outbound directions of a port. When a flow
exceeds the specification, some restriction or punishment measures can be taken to prevent
overconsumption of network resources.

o Traffic shaping—Proactively adjusts the output rate of traffic to adapt traffic to the network resources
of the downstream device and avoid unnecessary packet drop and congestion. Traffic shaping is
usually applied in the outbound direction of a port.

e  Congestion management—Provides a resource scheduling policy to arrange the forwarding
sequence of packets when congestion occurs. Congestion management is usually applied in the
outbound direction of a port.

e  Congestion avoidance—Monitors the usage status of network resources and is usually applied in
the outbound direction of a port. As congestion becomes worse, it actively reduces the amount of
traffic by dropping packets.

Among these QoS technologies, traffic classification is the basis for providing differentiated services.
Traffic policing, traffic shaping, congestion management, and congestion avoidance manage network
traffic and resources in different ways to realize differentiated services.

This section is focused on traffic classification, and the subsequent sections will introduce the other
technologies in details.

Traffic classification

When defining match criteria for classifying traffic, you can use IP precedence bits in the type of service
(ToS) field of the IP packet header, or other header information such as IP addresses, MAC addresses, IP
protocol field and port numbers. You can define a class for packets with the same quintuple (source
address, source port number, protocol number, destination address and destination port number for
example), or for all packets to a certain network segment.
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When packets are classified on the network boundary, the precedence bits in the ToS field of the IP
packet header are generally re-set. In this way, IP precedence can be directly used to classify the packets
in the network. IP precedence can also be used in queuing to prioritize traffic. The downstream network
can either use the classification results from its upstream network or classify the packets again according
to its own criteria.

To provide differentiated services, traffic classes must be associated with certain traffic control actions or
resource allocation actions. What traffic control actions to use depends on the current phase and the
resources of the network. For example, CAR polices packets when they enter the network. GTS is
performed on packets when they flow out of the node. Queue scheduling is performed when congestion
happens. Congestion avoidance measures are taken when the congestion deteriorates.

Packet precedences

IP precedence and DSCP values
Figure 456 ToS field and DS field

Bits: 0 1 2 3 45 6 7

DS-Field DSCP CcuU
(for IPv4,ToS
octet,and for

IPv6, Traffic
Class octet) | Class Selector Currently
codepoints Unused

Differentiated Services
Codepoint (DSCP)
RFC 2474

As shown in Figure 456, the ToS field of the IP header contains 8 bits. According to RFC 2474, the ToS
field of the IP header is redefined as the differentiated services (DS) field, where a differentiated services
code point (DSCP) value is represented by the first 6 bits (O to 5) and is in the range of O to 63. The
remaining 2 bits (6 and 7) are reserved.

Table 145 Description on IP Precedence

IP Precedence (decimal) IP Precedence (binary) Description
0 000 Routine

1 001 priority

2 010 immediate

3 011 flash

4 100 flash-override
5 101 critical

6 110 internet

7 111 network
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Table 146 Description on DSCP values

DSCP value (decimal) DSCP value (binary) Description
46 101110 ef
10 001010 af11
12 001100 af12
14 001110 af13
18 010010 af21
20 010100 af22
22 010110 af23
26 011010 af31
28 011100 af32
30 011110 af33
34 100010 af41
36 100100 af42
38 100110 af43
8 001000 csl
16 010000 cs2
24 011000 cs3
32 100000 cs4
40 101000 cshb
48 110000 csb
56 111000 cs/
0 000000 be (defaull

802.1p priority

802.1p priority lies in Layer 2 packet headers and applies to occasions where Layer 3 header analysis
is not needed and QoS must be assured at Layer 2.

Figure 457 An Ethernet frame with an 802.1Q tag header

802.1Q
inati header
Destination Source Length/Type Data ( CIz(C:SS 2)
Add .
Address = 1 1pPD | TCI
6 bytes 6 bytes 4 bytes 2 bytes 46 to 1500 bytes 4 bytes

As shown in Figure 457, the 4-byte 802.1Q tag header consists of the tag protocol identifier (TPID, two
bytes in length), whose value is 0x8100, and the tag control information (TCl, two bytes in length). Figure
458 presents the format of the 802.1Q tag header. The priority in the 802.1Q tag header is called
"802.1p priority," because its use is defined in [EEE 802.1p. Table 147 presents the values for 802.1p
priority.
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Figure 458 802.1Q tag header
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Table 147 Description on 802.1p priority

802.1p priority (decimal) 802.1p priority (binary) Description

0 000 best-effort

1 001 background

2 010 spare

3 011 excellent-effort

4 100 controlled-load

5 101 video

6 110 voice

7 111 network-management

Queue scheduling

In general, congestion management uses queuing fechnology. The system uses a certain queuing
algorithm for traffic classification, and then uses a certain precedence algorithm to send the traffic. Each
queuing algorithm handles a particular network traffic problem and has significant impacts on

bandwidth resource assignment, delay, and jitter.

In this section, two common hardware queue scheduling algorithms Strict Priority (SP) queuing and

Weighted Round Robin (WRR) queuing are introduced.

SP queuing

SP queuing is designed for mission-critical applications, which require preferential service to reduce

response delay when congestion occurs.
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Figure 459 SP queuing
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A typical switch provides eight queues per port. As shown in Figure 459, SP queuing classifies eight
queues on a port info eight classes, numbered 7 to O in descending priority order.

SP queuing schedules the eight queues strictly according to the descending order of priority. It sends
packets in the queue with the highest priority first. When the queue with the highest priority is empty, it
sends packets in the queue with the second highest priority, and so on. You can assign mission-critical
packets to the high priority queue to make sure they are always served first and common service (such as
Email) packets to the low priority queues to be transmitted when the high priority queues are empty.

The disadvantage of SP queuing is that packets in the lower priority queues cannot be transmitted if the
higher priority queues have packets. This might cause lower priority traffic to starve to death.

WRR queuing

WRR queuing schedules all the queues in turn to make sure every queue can be served for a certain time,
as shown in Figure 460.

Figure 460 WRR queuing
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A typical switch provides eight output queues per port. WRR assigns each queue a weight value
(represented by w7, w6, w5, w4, w3, w2, wl, or w0) to decide the proportion of resources assigned to
the queue. On a 100 Mbps port, you can set the weight values of WRR queuing to 25, 25, 15, 15, 5,
5, 5, and 5 (corresponding to w7, w6, w5, w4, w3, w2, wl, and wO, respectively). In this way, the
queue with the lowest priority is assured of at least 5 Mbps of bandwidth, and the disadvantage of SP
queuing (that packets in low-priority queues might fail to be served for a long time) is avoided.

Another advantage of WRR queuing is that while the queues are scheduled in turn, the service time for
each queue is not fixed. If a queue is empty, the next queue will be scheduled immediately. This improves
bandwidth resource use efficiency.

Basic WRR queuing contains multiple queues. You can configure the weight, percentage (or byte count)
for each queue, and WRR schedules these queues based on the user-defined parameters in a round robin
manner.

You can implement SP+WRR queue scheduling on a port by assigning some queues on the port to the SP
scheduling group when you configure WRR. Packets in the SP scheduling group are scheduled
preferentially by SP. When the SP scheduling group is empty, the other queues are scheduled by WRR.

Rate limit

Rate limit is a traffic control method using token buckets. The rate limit of a physical interface specifies the
maximum rate for forwarding packets (including critical packets). Rate limit can limit all the packets
passing a physical interface.

Traffic evaluation and token bucket

A token bucket can be considered as a container holding a certain number of tokens. The system puts
tokens into the bucket at a set rate. When the token bucket is full, the extra tokens will overflow.

Figure 461 Evaluate traffic with the token bucket
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The evaluation for the traffic specification is based on whether the number of tokens in the bucket can
meet the need of packet forwarding. If the number of tokens in the bucket is enough to forward the
packets (usually, one token is associated with a 1-bit forwarding authority), the traffic conforms to the
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specification, and the traffic is called "conforming traffic." Otherwise, the traffic does not conform to the
specification, and the traffic is called "excess traffic."

A token bucket has the following configurable parameters:

e Mean rate—Rate at which tokens are put into the bucket, or the permitted average rate of traffic. It
is usually set to the committed information rate (CIR).

o Burst size—The capacity of the token bucket, or the maximum traffic size permitted in each burst. It
is usually set to the committed burst size (CBS). The set burst size must be greater than the maximum
packet size.

One evaluation is performed on each arriving packet. In each evaluation, if the number of tokens in the
bucket is enough, the traffic conforms to the specification and the tokens for forwarding the packet are
taken away. If the number of tokens in the bucket is not enough, it means that too many tokens have been
used and the traffic is excessive.

Working mechanism of rate limit

With rate limit configured on an interface, all packets to be sent through the interface are firstly handled
by the token bucket of rate limit. If the token bucket has enough tokens, packets can be forwarded.
Otherwise, packets are put info QoS queues for congestion management. In this way, the traffic passing
the physical interface is controlled.

Figure 462 Rate limit implementation
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With a token bucket used for traffic control, when the token bucket has tokens, the bursty packets can be
transmitted. When no tokens are available, packets cannot be transmitted until new tokens are
generated in the token bucket. In this way, the traffic rate is restricted to the rate for generating tokens, the
traffic rate is limited, and bursty traffic is allowed.

Priority mapping

Concepts

When a packet enters a network, it is marked with a certain priority to indicate its scheduling weight or
forwarding priority. Then, the intermediate nodes in the network process the packet according to the
priority.

When a packet enters a device, the device assigns to the packet a set of predefined parameters
(including the 802.1p priority, DSCP values, and local precedence).
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e For more information about 802.1p priority and DSCP values, see "Packet precedences."

e Llocal precedence is a locally significant precedence that the device assigns to a packet. A local
precedence value corresponds to an output queue. Packets with the highest local precedence are
processed preferentially.

The device provides the following priority trust modes on a port:

e Trust packet priority—The device assigns to the packet the priority parameters corresponding to the
packet's priority from the mapping table.

o Trust port priority—The device assigns a priority to a packet by mapping the priority of the
receiving port.

You can select one priority trust mode as needed. Figure 463 shows the process of priority mapping on
a device.

Figure 463 Priority mapping process
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The device provides the following types of priority mapping tables:
e CoS to Queue—802.1 p-to-local mapping table.
e DSCP to Queue—DSCP-to-local mapping table, which applies to only IP packets.

Table 148 through Table 149 list the default priority mapping tables.
Table 148 Default CoS to Queue mapping table

Input CoS value Local precedence (Queue)
0 2
1 0
2 1
3 3
4 4
5 5
6 6
7 7
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Table 149 Default DSCP to Queue mapping table

Input DSCP value Local precedence (Queue)
Oto7 0

8to 15 1

16 to 23
24 10 31
32 to 39
40 to 47
48 to 55
56 to 63

N | OO |~ [w (N

Contiguration guidelines

When an ACL is referenced by a QoS policy for traffic classification, the action (permit or deny) in the
ACL is ignored, and the actions in the associated traffic behavior are performed.

Recommended QoS configuration procedures

Recommended QoS policy configuration procedure

A QoS policy involves the following components: class, traffic behavior, and policy. You can associate a
class with a traffic behavior using a QoS policy.

1. Class
Classes identify traffic.
A class is identified by a class name and contains some match criteria.

You can define a set of match criteria to classify packets. The relationship between criteria can be
and or or.

o and—The device considers a packet belongs to a class only when the packet matches all the
criteria in the class.

o or—The device considers a packet belongs to a class as long as the packet matches one of the
criteria in the class.

2. Traffic behavior
A traffic behavior, identified by a name, defines a set of QoS actions for packets.
3. Policy

You can apply a QoS policy to a port. A QoS policy can be applied to only the inbound direction
of one port.

Perform the tasks in Table 150 to configure a QoS policy:
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Table 150 Recommended QoS policy configuration procedure

Step

Remarks

1.

Adding a class

Required.

Add a class and specify the logical relationship
between the maich criteria in the class.

Required.

2. Configuring classification rules
Configure match criteria for the class.
Required.
3. Adding a traffic behavior equire
Add a traffic behavior.
4. Configure actions for the behavior:
o Configuring traffic mirroring and traffic redirecting ~ Use either method.
for a traffic behavior Configure various actions for the traffic behavior.
o Configuring other actions for a traffic behavior
Required.
5. Adding a policy equire
Add a policy.
Required.
Associate the traffic behavior with the class in the
6. Configuring classifier-behavior associations for the QoS policy.
policy A class can be associated with only one traffic
behavior in a QoS policy. Associating a class
already associated with a traffic behavior will
overwrite the old association.
) ) Required.
7. Applying a policy to a port

Apply the QoS policy to a port.

Recommended queue scheduling configuration procedure

Step

Remarks

1.

Configuring queue scheduling on a port

Optional.

Configure the queue scheduling mode for a port.

Recommended

rate limit configuration procedure

Step

Remarks

1.

Configuring rate limit on a port

Required.

Limit the rate of incoming packets or outgoing packets

of a physical port.

Recommended priority mapping table configuration procedure

Step

Remarks

1.

Configuring priority mapping tables

Required.
Set priority mapping tables.
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Recommended priority trust mode configuration procedure

Step

Remarks

1. Configuring priority trust mode on a port

Required.
Set the priority trust mode of a port.

Adding a class

1. Select QoS > Classifier from the navigation tree.

2. Click the Add tab to enter the page for adding a class.

Figure 464 Adding a class
Summary Setup Femaove
Classifier Name (1-31 Chars.)
Operation And A
Add
Classifier Mame Operation Rule Count

3. Add a class as described in Table 151.

4. Click Add.

Table 151 Configuration items

ltem

Description

Classifier Name

Specify a name for the classifier to be added.

Operator

Specify the logical relationship between rules of the classifier.

e and—Specifies the relationship between the rules in a class as logic AND. The
device considers a packet belongs to a class only when the packet matches all the
rules in the class.

e or—Specifies the relationship between the rules in a class as logic OR. The device
considers a packet belongs to a class as long as the packet matches one of the rules
in the class.

Do not specify the relationship between the rules in a class as logic OR. Otherwise, the
relevant QoS policy will fail to be applied.
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Configuring classitication rules

1. Select QoS > Classifier from the navigation tree.

2. Click Setup to enter the page for setting a class.

Figure 465 Configuring classification rules

Summary Add

Please select a classifier | Select a clagsifier V|

[Cary

[losce |

|(D—53, you can input 8 entries, for example, 3, 5-7)

CIIP Precedence |

|(D-T, you can input 8 entries, for example, 3, 5-7)

Classifier |

| (1-31 Chars)

Inbound Interface

RTP Port frnm|

1o (2000-85535)

Cotlp

[lgenice 802.1p |

| [Jcustomerg02.1p | |

WAL

[0-7 wou can input 8 entries, for example, 3, 5-T)

[ 5ource MAC |

| []Destination MAC | |

WLAMN

(Format of MAC is "H-H-H")

Clservice vian |

| {1-4094 input a range such as 3-20 orup to & entries

like 3, 5-7)

[ Customer wLAN |

| {1-4094 input a range such as 3-20 orup to & entries
like 3, 8-T)

AGL

ClACL IPy4 |

| {2000-4530)

CIACL IPve |

| (2000-3399)

Rule Type

Rule ¥alue

3. Configure classification rules for a class as described in Table 152.

4. Click Apply.



Table 152 Configuration items

ltem

Description

VLAN Customer VLAN

Define a rule to match customer VLAN IDs.

If multiple such rules are configured for a class, the new configuration does not
overwrite the previous one.

You can configure only one VLAN ID at a time. Otherwise, the relevant QoS
policy fails to be applied. If the same VLAN ID is specified multiple times, the
system considers them as one. The relationship between different VLAN IDs is
logical OR.

ACL IPv4

Define an IPv4 ACl-based rule.

ACL IPv6

Define an IPv6 ACL-based rule.

Adding a trattic behavior

1. Select QoS > Behavior from the navigation tree.
2. Click the Add tab to enter the page for adding a traffic behavior.

Figure 466 Adding a traffic behavior

Summary

Behavior Mame

Add

Setup Fort Setup Femove

1-31 Chars)

3. Add a traffic behavior as described in Table 153.

4. Click Add.

Table 153 Configuration items

ltem

Description

Behavior name

Specify a name for the behavior to be added.
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Configuring traftic mirroring and traffic redirecting
tor a traftic behavior

Select QoS > Behavior from the navigation tree.
2. Click Port Setup to enter the port setup page for a traffic behavior.
Figure 467 Port setup page for a traffic behavior
Summary Add Setup Remove

Please select a behavior Select a behavior «

[T Wirror To Enable [ Redirect Enable

Please select a port

el e Lo oLl el e d= 1]

Behavior Detail

3. Configure traffic mirroring and traffic redirecting as described in Table 154.
4.  Click Apply.

Table 154 Configuration items

ltem Description

Please select a behavior Select an existing behavior in the list.

Mirror To Set the action of mirroring traffic to the specified destination port.
Redirect Set the action of redirecting traffic to the specified destination port.

Specify the port to be configured as the destination port of traffic mirroring or

PI lect t e .
ease selecta por traffic directing on the chassis front panel.

Contiguring other actions for a traffic behavior

1. Select QoS > Behavior from the navigation tree.

2. Click Setup to enter the page for setting a traffic behavior.
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Figure 468 Setting a traffic behavior

Summary Add

Port Setup Remove

Please select a behavior Select a behavior

Ccar
(@ Enable
CIR
CBs

Red (@ Discard
Remark

IP Precedence 0

Local Precedence | 0

Clueue

EF Max Bandwidth
CBS
Fercent
CBS-Ratio

AF Max Bandwidth
Percent

WFQ

[CIFiter Permit

Behavior Detail

Dizable

kbps(16-1000000, it must be a multiple of 16)

byte(0-4294967294)

Pass

[[oot1p
[[pscr

kbps(8-1000000)
byte(32-2000000)
%a(1-100)
%(25-500)
kbps(8-1000000)
%(1-100)

(16-4096)

0 default

Accounting | Enable

3. Configure other actions for a traffic behavior as described in Table 155.

4. Click Apply.

Table 155 Configuration items

ltem

Description

Please select a behavior

Select an existing behavior in the list.

CAR Enable/Disable

Enable or disable CAR
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ltem

Description

CIR Set the committed information rate (CIR), the average traffic rate.

Set the committed burst size (CBS), number of bytes that can be sent in

CBS each interval. This function is not supported in the current software
version, and it is reserved for future support.

Set the action to perform for exceeding packets.
Discard After selecting the Red box, you can select one of the following options:

Red e Discard—Drops the exceeding packet.

e Pass—Permits the exceeding packet to pass through.

Pass This function is not supported in the current software version, and it is
reserved for future support.
Configure the action of marking 802.1p priority for packets.

Dotlp Select the Dot1p box and then select the 802.1p priority value to be
marked for packets in the following list. Select Not Set to cancel the
action of marking 802.1p priority.

Remark
Configure the action of marking DSCP value for packets.

DSCP Select the DSCP box and then select the DSCP value to be marked for
packets in the following list. Select Not Set to cancel the action of
marking DSCP value.

Configure the packet filtering action.
After selecting the Filter box, select one item in the following list:
Filter e Permit—Forwards the packet.

e Deny—Drops the packet.
o Not Set—Cancels the packet filtering action.

Adding a policy

1. Select QoS > QoS Policy from the navigation tree.

2. Click the Add tab to enter the page for adding a policy.

Figure 469 Adding a policy

Summary

Falicy Marme
Add

Setup Remaove

(1-31 Chars.)
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3.  Add a policy as described in Table 156.
4. Click Add.

Table 156 Configuration items

ltem Description

Specify a name for the policy to be added.

Policy Name Some devices have their own system-defined policies. The policy name you specify
cannot overlap with system-defined ones. The system-defined policy is the policy default.

Contiguring classifier-behavior associations for the
policy

1. Select QoS > QoS Policy from the navigation tree.
2. Click Setup to enter the page for setting a policy.

Figure 470 Setting a policy
Summary Add Remaove

Please selecta policy | Selact a policy

Classifier Mame .V.(1-31 Chars.)

Behaviar Name .V.(1-31 Chars.)

Classifier Behavior

3. Configure a classifier-behavior association for a policy as described in Table 157.
4. Click Apply.

Table 157 Configuration items

ltem Description

Please select a policy Select an existing policy in the list.
Classifier Name Select an existing classifier in the list.
Behavior Name Select an existing behavior in the list.
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Applying a policy to a port

Select QoS > Port Policy from the navigation tree.
2. Click Setup to enter the page for applying a policy to a port.
Figure 471 Applying a policy to a port
Summary Remove
Please selecta palicy Select a policy ~

Direction Inbound -

Please select port(s)

[alafalafalulalefulala]=] 1910-24 Swicn
el el flel el vlellel=]=l=][=][=]

Select All Select None

3. Apply a policy to a port as described in Table 158.
4. Click Apply.

Table 158 Configuration items

ltem Description

Please select a policy Select an existing policy in the list.

Set the direction in which the policy is to be applied.
Direction e Inbound—Applies the policy to the incoming packets of the specified ports.
o Outbound—Applies the policy to the outgoing packets of the specified ports.

Please select port(s) Select one port to which the QoS policy is to be applied on the chassis front panel.

Configuring queue scheduling on a port

1. Select QoS > Queue from the navigation tree.

2. Click Setup to enter the queue scheduling configuration page.

Figure 472 Configuring queue scheduling

Summary
@ WRR Setup
WRR Enable -
Quelie Mo Change - Group | SP Weight | 1

Please select port(s)

5 10 I I D N Y 1910.24 Switen
el Lo e Lol dell=la]z=]1a][=][=]

Select All SelectNone

Cancel
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3. Configure queue scheduling on a port as described in Table 159.
4. Click Apply.

Table 159 Configuration items

ltem Description

Enable or disable the WRR queue scheduling mechanism on selected ports. The
following options are available:

WRR e Enable—Enables WRR on selected ports.

o Not Set—Restores the default queuing algorithm on selected ports.

Select the queue to be configured.
Queve
The value range for a queue ID is O to 7.

WRR

Setup Specify the group the current queue is to be assigned to.

This list is available after you select a queue ID. The following groups are available
Group for selection:

e SP—Assigns a queue to the SP group.
e 1—Assigns a queue to WRR group 1.

) Set a weight for the current queve.
Weight
This list is available when group 1 is selected.

Please select port(s) Click to select ports to be configured with queuing on the chassis front panel.

Contiguring rate limit on a port

1. Select QoS > Line rate from the navigation tree.

2. Click the Setup tab to enter the rate limit configuration page.

Figure 473 Configuring rate limit on a port

Summary
Please selectan interface type  Ethernat(L2) -
Rate Limit Enable - Direction  Inbound -
CIR kbps (16-100000, it must be a multiple of 16)
cBs
EBS
Please select portis)
Ethernet1/0/1 -

Ethernet1/0/2
Ethernet1/0/3
Ethernet1/0/4
Ethernet1/0/5
Ethernet1/0/6
Ethernet1/0/7
Ethernet1/0/8
Ethernet1/0/9
Ethernet1/0/10 b

Select All

3. Configure rate limit on a port as described in Table 160.
4. Click Apply.
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Table 160 Configuration items

ltem

Description

Please select an interface type

Select the types of interfaces to be configured with rate limit.

Rate Limit Enable or disable rate limit on the specified port.
Select a direction in which the rate limit is to be applied.
o e Inbound—Limits the rate of packets received on the specified port.
Direction . p.
e Outbound—Limits the rate of packets sent by the specified port.
o Both—Limits the rate of packets received and sent by the specified port.
CIR Set the committed information rate (CIR), the average traffic rate.

Please select port(s)

Specify the ports to be configured with rate limit.

Click the ports to be configured with rate limit in the port list. You can select
one or more ports.

Contiguring priority mapping tables

1. Select QoS > Priority Mapping from the navigation tree.

Figure 474 Configuring priority mapping tables

WMapping Type CoS to Queue

Input Value Cutput Value
0 2 -
4 4 -

Input Value Output Value Input Value Output Value Input Value Output Value
1 ] - 2 1 - 3 3 -
5 5 - B 6 - 7 7 -
Restore Apply Cancel

2. Configure a priority mapping table as described in Table 161.

3. Click Apply.

Table 161 Configuration items

ltem

Description

Mapping Type

Select the priority mapping table to be configured:
e CoS to Queue.
e DSCP to Queue.

Input Priority Value

Output Priority Value

Set the output priority value for an input priority value.

Restore

Click Restore to display the default settings of the current priority mapping
table on the page.

To restore the priority mapping table to the default, click Apply.
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Contiguring priority trust mode on a port

1. Select QoS > Port Priority from the navigation tree.

Figure 475 Configuring port priorities

Fk Interface Name ~ = Search | Advanced Search

Interface Name Priority Trust Mode Operation
Ethernet1/0/1
Ethernet1/0/2

Untrust
Untrust
Ethernet1/0/2 Untrust
Ethernet1/0/4

Ethernet1/0/5

Untrust
Untrust
Ethernet1/0/5 Untrust
Ethernet1/0/7

Ethernet1/0/8

Untrust
Untrust
Ethernet1/0/2 Untrust
Ethernet1/0/10

Ethernet1/0/11

Untrust
Untrust
Ethernet1/0/12 Untrust
Ethernet1/0/13

Ethernet1/0/14

Untrust
Untrust

PERPpRPRPRPRPRRPRRERDR

o lel clel o lie oz e e @ el o e =

Ethernet1/0/15 Untrust

26 records, 15~ perpage | page 1/2, record 1-15 | Mext Last 1 GO

2. Click the 2 icon for a port.
Figure 476 Modifying the port priority

Interface

Mame

Priarity 0 -
Trust Mode Untrust -

Restore Apply Cancel

3. Configure the port priority for a port as described in Table 162.
4. Click Apply.

Table 162 Configuration items

ltem Description
Interface Interface to be configured.
Priority Set a local precedence value for the port.

Select a priority trust mode for the port:

o Untrust—Packet priority is not trusted.

Trust Mode o ) . . . .
o Dot1p—802.1p priority of the incoming packets is trusted and used for priority mapping.

e DSCP—DSCP value of the incoming packets is trusted and used for priority mapping.
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ACL and QoS configuration example

Network requirements

As shown in Figure 477, the FTP server (10.1.1.1/24) is connected to the Switch, and the clients access the
FTP server through Ethernet 1/0/1 of the Switch.

Configure an ACL and a QoS policy as follows to prevent the hosts from accessing the FTP server from
8:00 to 18:00 every day:

1. Add an ACL to prohibit the hosts from accessing the FTP server from 8:00 to 18:00 every day.
2. Contigure a QoS policy to drop the packets matching the ACL.
3. Apply the QoS policy in the inbound direction of Ethernet 1/0/1.

Figure 477 Network diagram
' 10.1.1.1/24
Eth1/0/1 g; ‘
.7 Switch FTP server

Contiguring Switch

1. Define a time range to cover the time range from 8:00 to 18:00 every day:
a. Select QoS > Time Range from the navigation tree.
Click the Add tab.

Enter the time range name test-time.

s

Select the Periodic Time Range box.

Set the Start Time to 8:00 and the End Time to 18:00.
Select the options Sun through Sat.

Click Apply.

@ =0 oo
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Figure 478 Defining a time range covering 8:00 to 18:00 every day

Summary Femaove

Time Range Mame |test—time |(1—32 Chars)

Feriodic Time Range

Start Time :

End Time :

¥ sun ] Man ¥ Tue ] wyed ¥ Thu M [sat
[ absolute Time Range
From : i i
Ta : ) i
Apply
Summary
2.  Add an advanced IPv4 ACL:
a. Select QoS > ACL IPv4 from the navigation tree.
b. Click the Add tab.
c. Enter the ACL number 3000.
d. Click Apply.
Figure 479 Adding an advanced IPv4 ACL
Summany Basic Setup Advanced Setup Link Layer Setup Femove
ACL Number 3000 | | 2000-2999 far basic ACLs.
3000-3994 for advanced ACLs.
4000-49949 for Ethernet frame header ACLs.
fatch Crder Config w
Description
Characters(i-127)
ACL Mumber Twpe Mumber of Rules Match Crder Description
3. Define an ACL rule for traffic to the FTP server:

a. Click the Advanced Setup tab.
b. Select 3000 in the ACL list.
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c. Select the Rule ID box, and enter rule ID 2.
d. Select Permit in the Action list.

e. Select the Destination IP Address box, and enter IP address 10.1.1.1 and destination wildcard

0.0.0.0.
f. Select test-time in the Time Range list.
g. Click Add.

Figure 480 Defining an ACL rule for traffic to the FTP server

Summary Add Basic Setup Link Layer Setup Remove

ACL | 3000 w Help

Configure an Advanced ACL

M Rule ID |2 (0-65934, Ifno D is entered, the systern will specify oned
I Mon-first Fragments Only O Logging

|IF Address Filter

[J5ource IP Address | | Source Wildcard | |
| [7] Destination IP Address |10.1.1.1 | Destination Wildcard |0.0.0.0 | ‘
Protocol [P ]
ICMP Type

ICMP Message

ICMP Type (0-255) ICMP Code (0-255)

TCRIUDP Port
TCP Connection

Established
Source: Operation F'Drtl | | |
Destination: Operation F'Drtl | | |

(Range of Portis 0-65535)

Precedence Filter

DSCP | Not Check |

TOS |NDtCheck v| Precedence| Mot Check v|

|Time Range | testtime + ‘

Add

Rule ID Operation Description Titme Rat

4. Adda class:
a. Select QoS > Classifier from the navigation tree.
b. Click the Add tab.
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5.

c. Enter the class name class1.

d. Click Add.
Figure 481 Adding a class

Summary Setup Femaove
|CIassiﬂerName |c|ass1 | {1-31 Chars.)
Operation |And V|
Add
Classifier Mame Qperation

Define classification rules:

a. Click the Setup tab.

b. Select the class name class1 in the list.

c. Select the ACL IPv4 box, and select ACL 3000 in the following list.
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Figure 482 Defining classification rules

Summary Add Remove
Please select a classifier | classi hd
Cany
loscp (0-63, you can input 8 entries, for example, 3, 5-7)
ClIP Precedence (0-7,vou can input 8 entries, for example, 3, 5-7)
Classifier (1-31 Chars)

Inbhaund Interface

RTP Port from ta (2000-655349)
Dotlp
[1semice 202.1p DCustnmerSDMp
(0-7,vou can input 8 entries, for example, 3, 5-7)
AT
(D source MaC [ Destination MAC
(Format of MAC is "H-H-H"
WLAMN
) (1-4094, input a range such as 3-20 or up to & entries
[ serice WLAN like 3, 5-7)
[ Gustomer VLAN (_1-4094, input a range such as 3-20 orup to & entries
like 3, 5-7)
ACL
MlACL P4 3000 | (2000-4993)
ClAcL P 3]
Appaly
Rule Type Rule “alue

d. Click Apply.
A progress dialog box appears, as shown in Figure 483.

e. Click Close on the progress dialog box when the progress dialog box prompts that the
configuration succeeds.
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Figure 483 Configuration progress dialog box

Current Configuration
Setting ACL IPvd - QK

100%

Close

Add a traffic behavior:

a. Select QoS > Behavior from the navigation tree.
b. Click the Add tab.

c. Enter the behavior name behaviorl.

d. Click Add.
Figure 484 Adding a traffic behavior

Summany Setup Fart Setup Remove
Behaviar Name |hehavinr1 |(1-31 Chars.)
Add

Configure actions for the traffic behavior:
a. Click the Setup tab.
b. Select behavior1 in the list.
c. Select the Filter box, and then select Deny in the following list.
d. Click Apply.
A progress dialog box appears.

e. Click Close when the progress dialog box prompts that the configuration succeeds.
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Figure 485 Configuring actions for the behavior

Surmmany Add Foart Setup Femaove
Please select a behavior | behavior V| |
Ocar
Enable Disable
CIR | |khps(4-1DDDDEIEI Committed Information Ratedkhps)
CRS | |tme(n-1uunnuu)
Red Discard Pass
Remark
P Precedence Ooatip
[TLocal Precedence [Josce
Quele
EF Max Bandwidth | kbps(8-1000000)
CBs | byta(32-2000000)
Fearcent | |%(1—1DD)
CBS-Ratio | %(25-500)
AF Max Bandwidth | kbps(8-1000000)
Percent | %(1-100)
WEQ | (16-4098)
[~ Filter Deny v Accounting
Apply

Behavior Detail

dzer Defined Behavior Infarmation:
Behavior: behavior
-hone-

8. Add a policy:
a. Select QoS > QoS Policy from the navigation tree.
b. Click the Add tab.

c. Enter the policy name policy1.
d. Click Add.
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10.

Figure 486 Adding a policy

Summary Setup Remove
Policy Marme [policy (1-31 Chars)
Add

Configure classifier-behavior associations for the policy:
a. Click the Setup tab.

b. Select policy1.

c. Select dass1 from the Classifier Name list.

d. Select behavior1 from the Behavior Name list.

e. Click Apply.
Figure 487 Configuring classifier-behavior associations for the policy

Summary Add Remove
Please select a palicy | policy ~

Classifier Name |class1 "9-?(1-31 Chars)

Behavior Mame  |hehavior] "9-?(1-31 Chars)

Apply
Classifier Behavior

Apply the QoS policy in the inbound direction of interface Ethernet 1/0/1:
a. Select QoS > Port Policy from the navigation tree.
Click the Setup tab.

Select policy1 from the Please select a policy list.

o

Select Inbound from the Direction list.
Select port Ethernet 1/0/1.
Click Apply.

A configuration progress dialog box appears.

- 0o o n

g. Click Close when the progress dialog box prompts that the configuration succeeds.
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Figure 488 Applying the QoS policy in the inbound direction of Ethernet 1/0/1

Summary Remaove
Please selecta policy policy1 A
Direction Inbound -

Please select port(s)

ﬁ-ﬁﬁ LT o106
el Lo Lelol el Ll e l=]2] )

Select All Select None
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Configuring PoE

Only a device with a mark of PoE supports the PoE feature.

Overview

IEEE 802.3af-compliant power over Ethernet (PoE) enables a power sourcing equipment (PSE) to supply
power to powered devices (PDs) through Ethernet interfaces over straight-through twisted pair cables.
Examples of PDs include IP telephones, wireless APs, portable chargers, card readers, Web cameras,
and data collectors. A PD can also use a different power source from the PSE at the same time for power
redundancy.

As shown in Figure 489, a PoE system comprises the following elements:
o PoE power—The entire PoE system is powered by the PoE power.

o PSE—The PSE supplies power for PDs. A PSE can examine the Ethernet cables connected to PoE
interfaces, search for PDs, classify them, and supply power to them. When detecting that a PD is
removed, the PSE stops supplying power to the PD. A PSE can be built-in (Endpoint) or external
(Midspan). A built-in PSE is integrated into a switch or router, and an external PSE is independent
of a switch or router. The HP PSEs are built-in. Only one PSE is available on the device, so the entire
device is considered as a PSE.

e PI—An Ethernet interface with the PoE capability is called PoE interface. A PoE interface can be an
FE or GE interface.

e PD—APD receives power from the PSE. You can also connect a PD to a redundant power source for
reliability.

The PSE supplies power over category 3/5 twisted pair cable for a PoE interface in the following two

modes:

e Over signal wires—The PSE uses data pairs (pins 1, 2 and 3, 6) to supply DC power to PDs.

e Over spare wires—The PSE uses spare pairs (pins 4, 5 and 7, 8) to supply DC power to PDs.
A PSE can supply power to a PD only when the selected power supply mode is supported by both the PSE
and PD. If the PSE and PD support different power supply modes (for example, the PSE does not support

power over spare wires, while the PD supports power over spare wires), you have to change the order
of the lines in the twisted pair cable to supply power to the PD.

Figure 489 PoE system diagram

PD
PI
~ 1
Pl
PoE power 2 ¢ PD
Pl
PSE
PD
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Configuring PoE

Before configuring PoE, make sure the PoE power supply and PSE are operating correctly. Otherwise,
either you cannot configure PoE or the PoE configuration does not take effect.

Configuring PoE ports

1. Select PoE > PoE from the navigation tree.
2. Click the Port Setup tab.

Figure 490 Port Setup tab
Summary PSE Setup
e\edPort:
Select All Select None Note: The "Select All” and the "Select None™ are only applied to current unit.
. Selected I:I Power Supplied I:I Power Enabled . Power Disabled . Mot Supported - Power Fault

Power State: No Change ~

[Cpower Max: (1000-30000 millwatis, step = 100)

Power Prority: No change =

Selected Ports:

Apply Cancel

3. Configure the PoE ports as described in Table 163.
4. Click Apply.

Table 163 Configuration items

ltem Description

Select Port Select ports to be configured and they are displayed in the Selected Ports area.

Enable or disable PoE on the selected ports.
e The system does not supply power to or reserve power for the PD connected to
a PoE port if the PoE port is not enabled with the PoE function.

® You can enable PoE for a PoE port if the PoE port does not result in PoE power

Power State overload. Otherwise, you cannot enable PoE for the PoE port.

By default, PoE is enabled on a PoE port.
@ IMPORTANT:

When the sum of the power consumption of all ports exceeds the maximum power of
PSE, the system considers the PSE as overloaded.

Set the maximum power for the PoE port.

The maximum PoE interface power is the maximum power that the PoE interface
Power Max can provide to the connected PD. If the PD requires more power than the maximum
PoE interface power, the PoE interface does not supply power to the PD.

By default, the maximum power of a PoE port is 30 watts.
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ltem Description

Set the power supply priority for a PoE port. In descending order, the power-supply
priority levels of a PoE port are critical, high, and low.

e When the PoE power is insufficient, power is first supplied to PoE ports with a
higher priority level.

o If the PoE power is overloaded and a PSE power-management-priority policy is
enabled, the PSE that has a lower priority is first disconnected to guarantee the
power supply to a new PSE that has a higher priority.

e The guaranteed remaining PoE power is the maximum PoE power minus the
power allocated to the critical PSE, regardless of whether PoE is enabled for the
PSE. If this is lower than the maximum power of the PSE, you cannot set the
power priority of the PSE to critical. Otherwise, you can set the power priority to
critical, and this PSE preempts the power of the PSE that has a lower priority
level. In this case, the PSE whose power is preempted is disconnected, but its
configuration remains unchanged. If you change the priority of the PSE from

Power Priority critical to a lower level, other PSEs have an opportunity to be powered.

By default, the power priority of a PoE port is low.
@ IMPORTANT:

e A guard band of 20 watts is reserved for each PoE inferface on the device to
prevent a PD from being powering off because of a sudden increase of power.
If the remaining power of the PSE is lower than 20 watts, the PoE interface with
higher priority can preempt the power of a PoE interface with lower priority fo
supply power to a new PD. In this way, you can ensure normal operation of the
PoE interface with higher priority. If the power of the PoE interface with lower
priority is lower than 20 watts, for the PoE interface to operate correctly, it
supplies power again.

e If a sudden increase of the PD power results in PSE power overload, power
supply to the PD on the PoE interface that has a lower priority is stopped to
ensure power supply to the PD that has a higher priority.

Configuring non-standard PD detection

There are standard PDs and nonstandard PDs. Usually, the PSE can detect only standard PDs and supply
power to them. The PSE can detect nonstandard PDs and supply power to them only if you enable the PSE
to detect nonstandard PDs.

1. Select PoE > PoE from the navigation tree.
2. Click the PSE Setup tab.

The page displays the location of all PSEs, and the status of the non-standard PD detection function.

Figure 491 PSE Setup tab

Summary Port Setup

FSEID Location MNon-Standard PD Compatibility
1 slot 1 subslot 0 Disable -

Apply Enable All Disable All
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Enabling the non-standard PD detection function for a PSE

1. Select Enable in the corresponding Non-Standard PD Compatibility column.
2. Click Apply.

Disabling the non-standard PD detection function for a PSE

1. Select Disable in the corresponding Non-Standard PD Compatibility column.
2. Click Apply.

Enabling the non-standard PD detection for all PSEs
Click Enable All.

Disabling the non-standard PD detection for all PSEs
Click Disable All.

Displaying information about PSE and PoE ports

1. Select PoE > PoE from the navigation tree to enter the Summary tab.
The upper part of the page displays the PSE summary.

2. To view the configuration and power information, click a port on the chassis front panel.

Figure 492 PoE summary (with Ethernet 1/0/1 selected)

PSE Setup Port Setup
PSE Summary:
PSEID Location State Max Power (W) Average Power(W) Peak Power(W) Available Power(W)
1 slot 1 subslot 0 off 180 0 0 180

Ports Power Display:

1910-24-PoE+(1...

Port Power State:
Port State Priarity Max Power(m\W) Average Power(m\W) Peak Power(m\V) Free Power(m)
Eth1/0/1 disable Low 30000 0 0 30000

PoE contiguration example

Network requirements

As shown in Figure 493, Ethernet 1/0/1 and Ethernet 1/0/2 are connected to IP telephones.
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Ethernet 1/0/11 is connected to AP whose maximum power does not exceed 9000 milliwatts.

The IP telephones have a higher power supply priority than the AP so the PSE supplies power to the IP
telephones first if the PSE power is overloaded.

Figure 493 Network diagram

Phone1 Phone2 AP

Configuring PoE
1. Enable PoE on Ethernet 1/0/1 and Ethernet 1/0/2, and set their power supply priority to critical:

a. Select PoE > PoE from the navigation tree.
b. Click the Setup tab.

c. On the tab, click to select ports Ethernet 1/0/1 and Ethernet 1/0/2 from the chassis front
panel, select Enable from the Power State list, and select Critical from the Power Priority list.

d. Click Apply.
Figure 494 Configuring the PoE ports supplying power to the IP telephones

Summary PSE Setup

Select Port:

1910-24-PoE~+ (1...

Select All Select Mone Mote: The "Select All" and the "Select None™ are only applied to current unit.
wies ] B W Il
. Selected Supplied Power Enabled Disanbled Mot Supported Power Fault
| Power State: Enable v|
[ Power Max; (1000-30000 milliwatts, step = 100)
|F'0werF'r0rity: High v|

Selected Ports:
Eth1/0/1-Eth1/0/2

Cancel

2. Enable PoE on Ethernet 1/0/11 and set the maximum power of the port to 9000 milliwatts:
a. Click the Setup tab.

b. On the tab, click to select port Ethernet 1/0/11 from the chassis front panel, select Enable from
the Power State list, and select the box before Power Max and enter 9000.
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c. Click Apply.

Figure 495 Configuring the PoE port supplying power to AP
sSummary PSE Setup

Select Port:

1910-24-PoE+ (1...

Select All Select Mone Mote: The "Select All" and the "Select None™ are only applied to current unit.

Power Power
. Selected Supplied D PowerEnabled.Disabled . Mot Supported . Power Fault

Power State: Enable A

Power Max: 9000|

(1000-20000 milliwatts, step = 100)

Power Prority: Mo change -

Selected Ports:
Eth1/0/11

Cancel

After the configuration takes effect, the IP telephones and AP are powered and can operate correctly.
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Support and other resources

Contacting HP

For worldwide technical support information, see the HP support website:

http://www.hp.com/support

Before contacting HP, collect the following information:

e Product model names and numbers

e Technical support registration number (if applicable)
e Product serial numbers

e Error messages

e Operating system type and revision level

o Detailed questions

Subscription service

HP recommends that you register your product at the Subscriber's Choice for Business website:

http://www.hp.com/go/wwalerts

After registering, you will receive email notification of product enhancements, new driver versions,
firmware updates, and other product resources.

Related information

Documents

To find related documents, browse to the Manuals page of the HP Business Support Center website:

http://www.hp.com/support/manuals

e For related documentation, navigate to the Networking section, and select a networking category.

o For a complete list of acronyms and their definitions, see HP FlexNetwork Technology Acronyms.

Websites

e  HP.com http://www.hp.com

e HP Networking http://www.hp.com/go/networking

e HP manuals http://www.hp.com/support/manuals

e  HP download drivers and software http://www.hp.com/support/downloads

e HP software depot http://www.software.hp.com

e  HP Education http://www.hp.com/learn
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Conventions

This section describes the conventions used in this documentation set.

Command conventions

Convention Description

Boldface Bold text represents commands and keywords that you enter literally as shown.

Italic ltalic text represents arguments that you replace with actual values.

[ Square brackets enclose syntax choices (keywords or arguments) that are optional.

Ix1yl o1 Braces enclose a set of required syntax choices separated by vertical bars, from which
vl you select one.

X1yl ] Square brackets enclose a set of optional syntax choices separated by vertical bars, from
vl which you select one or none.

X1yl o1* Asterisk-marked braces enclose a set of required syntax choices separated by vertical
LA bars, from which you select at least one.

[xy|..1* Asterisk-marked square brackets enclose optional syntax choices separated by vertical
Yol bars, from which you select one choice, multiple choices, or none.

&<ln> The argument or keyword and argument combination before the ampersand (&) sign can

be entered 1 to n times.
# A line that starts with a pound (#) sign is comments.

GUI conventions

Symbols

Convention Description
Window names, button names, field names, and menu items are in bold text. For
Boldface . .
example, the New User window appears; click OK.
> Multi-level menus are separated by angle brackets. For example, File > Create > Folder.
Convention Description
A An alert that calls attention to important information that if not understood or followed can
WARNING result in personal injury.
A An alert that calls attention to important information that if not understood or followed can
CAUTION result in data loss, data corruption, or damage to hardware or software.
@ IMPORTANT  An alert that calls attention to essential information.
NOTE An alert that contains additional or supplementary information.

Qe

An alert that provides helpful information.
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Network topology icons

Represents a generic network device, such as a router, switch, or firewall.

Represents a routing-capable device, such as a router or Layer 3 switch.

Represents a generic switch, such as a Layer 2 or Layer 3 switch, or a router that supports
Layer 2 forwarding and other Layer 2 features.

Represents an access controller, a unified wired-WLAN module, or the switching engine
on a unified wired-WLAN switch.

Represents an access point.

Represents a security product, such as a firewall, a UTM, or a load-balancing or security
card that is installed in a device.

Represents a security card, such as a firewall card, a load-balancing card, or a
NetStream card.

¢6e00BE

Port numbering in examples

The port numbers in this document are for illustration only and might be unavailable on your device.
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Index

Numerics RADIUS Message-Authentication attribute, 329
802.1X timers, 333
access control methods, 326 using authentication with other features, 334
ACL assignment, 336 VLAN assignment, 334
architecture, 326 802.x
authentication, 330 802.1 LLDPDU TLV types, 223

802.3 LLDPDU TLV types, 223
QoS packet 802.1p priority, 475

authentication (access device initiated), 329
authentication (client initiated), 329

authentication configuration, 341 A
authentication initiation, 329 AAA
Auth-Fail VLAN, 335 configuration, 357, 364

configuration, 326, 337
configuration (global), 337

ISP domain accounting methods configuration, 362

ISP domain authentication methods

configuration (port-specific), 338 configuration, 360

configuring Auth-Fail VLAN, 341 ISP domain authorization methods
configuring guest VLAN, 340 configuration, 361

configuring MAC-based 802.1X, 341 ISP domain configuration, 359
configuring with ACL assignment, 348 RADIUS implementation, 368, 379
controlled/uncontrolled port, 327 user management by ISP domains, 358
EAP over RADIUS, 328 absolute time range (ACL), 457

EAP packet format, 327 absolute time range configuration (ACL), 458
EAP relay authentication, 331 access control methods (802.1X), 326

EAP relay termination, 332 accounting

EAP relay/termination authentication AAA configuration, 357, 364

mode, 330 AAA ISP domain accounting methods
EAP-Message attribute, 329 configuration, 362

EAPOL packet format, 328 RADIUS common parameter configuration, 374
guest VLAN, 334 RADIUS scheme configuration, 373
packet format, 327 RADIUS server configuration, 378

port authorization status, 327 ACL

port security advanced control 802.1X assignment, 336

configuration, 434 advanced configuration, 461, 468

port security advanced mode assignment (MAC authentication), 410

configuration, 439 automatic rule numbering, 456, 456

port security basic control configuration, 431 automatic rule renumbering, 456

port security basic mode configuration, 436 basic configuration, 460, 467

port security configuration, 427, 429, 436 categories, 455

port security configuration (global), 430 configuration, 455, 494

port security modes, 427 configuring 802.1X assignment, 348

port security permitted OUls configuration, 436 Ethernet frame header configuration, 464
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match order, 455

packet fragment filtering, 457

rule numbering step, 456

security MAC authentication, 417

time range configuration, 458

time-based ACL rules, 457
adding

IPv4 ACL, 459

IPv6 ACL, 466

NMM local port mirroring local group, 86

QoS policy, 488

QoS traffic behavior, 485

QoS traffic class, 483

RADIUS server, 378

rules to SNMP view, 119

Web device local user, 89
address

DHCEP allocation, 297

DHCP lease extension, 298
Address Resolution Protocol. Use ARP
advanced

port security advanced mode, 427

port security advanced mode
configuration, 439

advanced ACL
category, 455

aggregate interface (Ethernet link aggregation), 214

aggregating
link, 210
aging
MAC address table timer, 180
alarm
NMM RMON alarm function, 98
NMM RMON configuration, 96, 108
NMM RMON group, 97
alarm entry
configuration, 102
algorithm
STP calculation, 184
allocating
DHCP IP addresses allocation, 297
alternate port (MST), 192
application
AAA application, 357

applying

QoS policy to port, 490
architecture
security 802.1X, 326
ARP
attack protection. See ARP attack protection
configuration, 248
dynamic table entry, 250
entry configuration, 250
entry display, 250
entry removal, 252
gratuitous ARP configuration, 252
gratuitous ARP packet, 250
gratuitous ARP packet learning, 250
message format, 248
operation, 248
static configuration, 252
static entry configuration, 251
static table entry, 250
table, 249
ARP attack protection
configuration, 256
detection configuration, 256
packet validity check, 256
user validity check, 256
assigning
802.1X ACL, 336
MAC authentication ACL assignment, 410
MAC authentication VLAN assignment, 410
VLAN (802.1X), 334
attribute
AAA RADIUS extended afttributes, 372
local user and user group configuration, 385
security 802.1X RADIUS EAP-Message, 329

security 802.1X RADIUS
Message-Authentication, 329

authenticating
AAA configuration, 357, 364

AAA ISP domain authentication methods
configuration, 360

configuring MAC authentication (global), 411

configuring MAC authentication (port-specific), 413

local user and user group configuration, 385
local user configuration, 385

port security advanced control configuration, 434
port security advanced mode configuration, 439
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port security authentication modes, 427

port security basic control configuration, 431
port security basic mode configuration, 436
port security configuration, 427, 429, 436
port security configuration (global), 430

port security permitted OUls configuration, 436
RADIUS common parameter configuration, 374
RADIUS scheme configuration, 373

RADIUS server configuration, 378

security 802.1X access device initiated
authentication, 329

security 802.1X authentication, 330

security 802.1X client-initiated, 329

security 802.1X EAP over RADIUS, 328
security 802.1X EAP relay authentication, 331

security 802.1X EAP relay/termination
mode, 330

security 802.1X EAP termination, 332
security 802.1X initiation, 329

security 802.1X RADIUS
Message-Authentication attribute, 329

security MAC authentication, 409

security MAC authentication ACL
assignment, 41/

security MAC authentication
configuration, 411, 414

security MAC local authentication
configuration, 414

user group configuration, 387

using 802.1X authentication with other
features, 334

using MAC authentication with other
features, 410

Authentication, Authorization, and Accounting.
Use AAA

Auth-Fail VLAN
802.1X authentication, 335
configuring 802.1X, 341
MAC authentication, 410
authorized IP
configuration, 449, 450
authorizing
AAA configuration, 357, 364

AAA ISP domain authorization methods
configuration, 361

security 802.1X port authorization status, 327

auto

DHCP automatic address allocation, 297

automatic

ACL automatic rule numbering, 456, 456

backing up

Web device configuration, 67

backup port (MST), 192
bandwidth

QoS policy configuration, 471

basic

port security basic mode, 427

port security basic mode configuration, 436

basic ACLs, 455
basic management LLDPDU TLV types, 223
bidirectional

NMM port mirroring, 82

blackhole entry

MAC address table, 179

boundary port (MST), 192
BPDU

STP BPDU forwarding, 189

bridge

MST common root bridge, 192, 192
MST regional root, 192

STP designated bridge, 183

STP root bridge, 183

buttons on webpage, 17

C

cable status

testing, 94

calculating

MSTI calculation, 194
MSTP CIST calculation, 194
STP algorithm, 184

category

ACL advanced, 455

ACL auto match order sort, 455
ACL basic, 455

ACL config match order sort, 455
ACL Ethernet frame header, 455

choosing
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CIST
calculation, 194
network device connection, 192

class (Ethernet link aggregation port
configuration), 211, 221, 540

class-two

Ethernet link aggregation MAC address
learning configuration class, 211, 221, 540

Ethernet link aggregation port isolation
configuration class, 211, 221, 540

Ethernet link aggregation VLAN configuration
class, 211, 221, 540

CLl
commands, 25
configuration, 21
getting started, 21
logging in, 25

client
DHCP snooping Option 82 support, 312
security 802.1X authentication, 330
security 802.1X authentication (access device
initiated), 329
security 802.1X authentication
(client-initiated), 329

security 802.1X authentication
configuration, 341

security 802.1X authentication initiation, 329
security 802.1X configuration, 326, 337
security 802.1X configuration (global), 337
security 802.1X configuration
(port-specific), 338

commands
CLl, 25

common
DHCP options, 300

common root bridge, 192

comparing
security 802.1X EAP relay/termination
authentication modes, 330

configuration guideline
LLDP, 247
static routing, 296

configuration guidelines
ACL, 457
QoS, 481

configuration wizard

basic service setup, 35

configuring
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802.1X ACL assignment, 348

802.1X Auth-Fail VLAN, 341

802.1X guest VLAN, 340

AAA, 357, 364

AAA accounting methods for ISP domain, 362
AAA authentication methods for ISP domain, 3460
AAA authorization methods for ISP domain, 361
AAA ISP domain, 359

ACL, 494

ACL (Ethernet frame header), 464

ACL time range, 458

ACls, 455

advanced IPv4 ACL, 461

advanced IPv6 ACL, 468

alarm entry, 102

ARP, 248

ARP (static), 252

Auth-Fail VLAN (802.1X), 335

authorized IP, 449, 450

basic device settings, 53

basic IPv4 ACL, 460

basic IPv6 ACL, 467

client's IPto-MAC bindings, 307

DHCP relay agent, 302, 303, 308

DHCP relay agent advanced parameters, 304
DHCP snooping, 311, 313, 316

DHCP snooping functions on inferface, 314
energy saving, 112

energy saving on port, 112

Ethernet link aggregation and LACP, 210, 218
Ethernet link aggregation group, 213

Ethernet link dynamic aggregation group, 213
Ethernet link static aggregation group, 213
event entry, 101

flow interval, 95

gratuitous ARP, 252

guest VLAN (802.1X), 334

history entry, 100

idle timeout period, 53

IGMP snooping, 258, 266

IGMP snooping port function, 264

IP routing (IPv4), 283

IP routing (IPv6), 283



IP services ARP entry, 250

isolation group, 446

LLDP, 222, 241

LLDP (globally), #5i% ! s L% . , 232
local user, 385

local user and user group, 385
loopback detection, 453, 453

loopback detection (global), 453
loopback detection (port-specific), 454
loopback test, 92, 92

MAC address table, 178, 179, 181

MAC authentication (global), 411

MAC authentication (port-specific), 413
MAC-based 802.1X configuration, 341
management IP address, 37

maximum PoE interface power, 504

MLD snooping, 271, 279

MLD snooping port function, 277

MST region, 196

MSTP, 182, 195, 204

MSTP (global), 197

MSTP (port-specific), 200

NMM local port mirroring, 86

NMM local port mirroring group, 83
NMM local port mirroring group monitor
port, 87

NMM local port mirroring group ports, 84

NMM local port mirroring group source
ports, 87

NMM RMON, 96, 108

NMM RMON alarm function, 98
NMM RMON statistics function, 98
NMM SNMP, 114

PoE, 503, 506, 507

PoE interface power management, 504
PoE ports, 504

port isolation, 446, 447

port link type, 145

port security, 427, 429, 436

port security (global), 430

port security advanced control, 434
port security advanced mode, 439
port security basic control, 431

port security basic mode, 436

port security permitted OUls, 436
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port-based VLAN, 140

priority mapping table, 492

priority trust mode, 493

PVID, 146

QoS, 494

QoS classifier-behavior associations, 489
QoS policy, 471

QoS traffic class, 484

QoS traffic mirroring, 486

QoS traffic redirecting, 486

queue scheduling on port, 490, 491
RADIUS, 368, 379

RADIUS common parameter, 374
RADIUS scheme, 373

secure MAC addresses, 433
security 802.1X, 326, 337

security 802.1X (global), 337
security 802.1X (port-specific), 338
security 802.1X authentication, 341
security ARP attack protection, 256
security ARP detection, 256

security MAC authentication, 409, 411, 414

security MAC authentication ACL assignment, 417

security MAC local authentication, 414
setting environment, 21
SNMP community, 120
SNMP group, 121

SNMP trap function, 125
SNMP user, 123

SNMP view, 118

SNMPv1, 127

SNMPv2¢, 127

SNMPv3, 130

stack, 40, 44

stack global parameters, 41
stack ports, 42

static routing (IPv4), 288
static routing (IPv6), 292
statistics entry, 100

system name, 53

system parameters, 35
system time, 59

system time (by using NTP), 60, 61
system time (manually), 59
user group, 387



VCT, 94

VLAN interface, 155

Web device configuration management, 67

Web device user management, 89

Web interface, 2

Web service management, 319, 320
console terminal parameters, 22
controlling

security 802.1X controlled/uncontrolled
port, 327

cost
STP path cost, 184
creating
ARP static entry, 251
DHCP server group, 305
Ethernet link aggregation group, 213
SNMP view, 118
static route (IPv4), 285
static route (IPv6), 286
VLAN, 144
VLAN inferface, 155
critical
PoE interface power management, 504
CST
MST region connection, 192

D

default
static route, 284
designated
MST port, 192
STP bridge, 183
STP port, 183
destination
NMM port mirroring, 82
detecting
security ARP detection configuration, 256
device
basic settings configuration, 53
CLI configuration, 21
configuring MAC authentication (global), 411
configuring MAC authentication
(port-specific), 413
DHCP overview, 297
DHCP relay agent configuration, 308

idle timeout period configuration, 53

LLDP configuration, 222, 241

MAC authentication timers, 410

NMM local port mirroring configuration, 86
NMM local port mirroring group monitor port, 87
NMM port mirroring configuration, 82

NMM SNMP configuration, 114

port management, 72, 77

security MAC authentication, 409

security MAC authentication ACL assignment, 417

security MAC authentication
configuration, 409, 411, 414

security MAC local authentication
configuration, 414

SNMPv1 configuration, 127

SNMPv2c configuration, 127

SNMPv3 configuration, 130

stack global parameters configuration, 41
syslog configuration, 64

system name configuration, 53

VCT configuration, 94

Web common page features, 17

Web configuration backup, 67

Web configuration management, 67
Web configuration reset, 69

Web configuration restoration, 67

Web configuration save, 68

Web device local user adding, 89
Web device privilege level switching, 91
Web device super password setting, 90
Web device user management, 89
Web file displaying, 70

Web file download, 70

Web file management, 70

Web file removing, 71

Web file upload, 71

Web interface, 7

Web interface HTTP login, 6

Web interface logout, 7

Web main boot file specifying, 71
Web service management, 319, 320
Web stack configuration, 40

Web user level, 8

Web-based NM functions, 8

device information



displaying device information, 50, 51

device management

device reboot, 56
diagnostic information, 57
electronic label, 57
software upgrade, 55

DHCP

configuring client's IPto-MAC bindings, 307
configuring DHCP relay agent advanced
parameters, 304

configuring snooping functions on interface, 314

creating DHCP server group, 305

displaying client's IPto-MAC bindings, 307, 315

enable, 304

enable snooping, 313

enabling relay agent on interface, 306
IP address allocation, 297, 298

IP address lease extension, 298
message format, 299

Option #, 300, See also Option #
Option 121, 300

Option 150, 300

Option 3;Option 003, 300

Option 33;0Option 033, 300

Option 51;0Option 051, 300

Option 53;0ption 053, 300

Option 55;0Option 055, 300

Option 6;Option 006, 300

Option 60;Option 060, 300

Option 66;Option 066, 300

Option 67;Option 067, 300

Option 82 (relay agent);Option 082 (relay
agent), 300

options, 300

options (common), 300

overview, 297

protocols and standards, 301

relay agent configuration, 302, 303, 308
snooping. See DHCP snooping
snooping configuration, 311, 313, 316
snooping Option 82 support, 312
snooping trusted port, 311, 311
snooping untrusted port, 311, 311

diagnostic

tools, 322

direction

NMM port mirroring (bidirectional), 82
NMM port mirroring (inbound), 82
NMM port mirroring (outbound), 82

discarding

MST discarding port state, 193

displaying

active route table (IPv4), 284

active route table (IPv6), 286

all operation parameters for a port, 76

client's IPto-MAC bindings, 307, 315

current system time, 59

Ethernet link aggregation aggregate interface, 214
Ethernet link aggregation LACP-enabled port, 216
global LLDP, 239

IGMP snooping multicast forwarding entries, 265
interface statistics, 136

IP services ARP entry, 250

LLDP for a port, 234

LLDP information information, 241

MAC address table, 179

MLD snooping multicast forwarding entries, 278
MSTP information on port, 202

NMM RMON running status, 99

PoE, 506

port operation parameters, 75

RMON event logs, 107

RMON history sampling information, 106
RMON statistics, 104

SNMP packet statistics, 126

specified operation parameter for all ports, 75
stack device summary, 43

stack topology summary, 43

syslogs, 64

Web device file, 70

Web page display, 17

done message

IPvé multicast MLD snooping, 274

downloading

Web device file, 70

DSCP

QoS packet IP precedence and DSCP values, 474

dst-mac validity check (ARP), 256
dynamic
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DHCP address allocation, 297 security 802.1X RADIUS EAP-Message

Ethernet link aggregation dynamic mode, 212 attribute, 329
Ethernet link aggregation mode, 211 VLAN frame encapsulation, 138
Ethernet link dynamic aggregation group energy saving
configuration, 213 configuring energy saving, 112
IP multicast IGMP snooping dynamic port, 259 port-based configuration, 112
IPvé multicast MLD snooping dynamic port, 272 entering
MAC address table dynamic aging timer, 180 configuration wizard homepage, 35
MAC address table entry, 179 environment
Dynamic Host Configuration Protocol. See DHCP setting configuration environment, 21
E Ethernet

ARP configuration, 248
ARP static configuration, 252
DHCP snooping configuration, 316

EAP
security 802.1X EAP over RADIUS, 328
security 802.1X packet format, 327

security 802.1X RADIUS EAP-Message
attribute, 329

security 802.1X RADIUS
Message-Authentication attribute, 329

gratuitous ARP configuration, 252

link aggregation and LACP, 210

LLDPDU encapsulated in Ethernet Il, 222
loopback detection configuration, 453, 453
loopback test configuration, 92, 92

MAC address table configuration, 178, 179, 181
NMM port mirroring configuration, 82

security 802.1X relay authentication, 331
security 802.1X relay termination, 332
security 802.1X relay/termination

authentication mode, 330 NMM RMON statistics group, 96
EAPOL port isolation configuration, 446, 447
security 802.1X authentication (access device port-based VLAN configuration, 140
initiated), 329 security ARP attack protection configuration, 256
security 802.1X authentication VLAN configuration, 138, 150
(client-initiated), 329 VLAN frame encapsulation, 138
security 802.1X packet format, 328 VLAN type, 139
edge port Ethernet frame header ACL
MST, 192 category, 455
emulator (terminal parameters), 22 configuration, 464
enabling Ethernet link aggregation
DHCP, 304 aggregate interface, 210, 214
DHCP relay agent on interface, 306 aggregation group, 210
DHCP snooping, 313 basic concepts, 210
IP multicast IGMP snooping (globally), 262 configuration, 210, 218
IP multicast IGMP snooping (in a VLAN), 263 dynamic group configuration, 213
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configuring DHCP relay agent advanced
parameters, 304

configuring DHCP snooping functions on
interface, 314

creating DHCP server group, 305

device idle timeout period configuration, 53
device system name configuration, 53
displaying client's IP-to-MAC bindings, 307, 315
enabling DHCP, 304

enabling DHCP relay agent on interface, 306
enabling DHCP snooping, 313

Ethernet link aggregation aggregate
interface, 214

Ethernet link aggregation dynamic mode, 212
Ethernet link aggregation LACP, 210
Ethernet link aggregation LACP priority, 215

Ethernet link aggregation LACP-enabled
port, 216

Ethernet link aggregation modes, 211

Ethernet link aggregation operational key, 210
Ethernet link aggregation static mode, 211
gratuitous ARP packet, 250

gratuitous ARP packet learning, 250

IP services ARP entry configuration, 250

IP services ARP entry removal, 252

MAC address table dynamic aging timer, 180
MAC address table entry types, 179

MAC authentication timers, 410
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