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TSI1000 Tally Mapper 
 
This document assumes some familiarity with TSI1000 programming and provides a general overview as to how to use the 
TSI Tally Mapper (TSI-TM) console. Please note that many of the details of configuring the TSI1000 Tally Mapper are 
outlined in the program’s context sensitive help system, accessible by clicking “?” within each dialog box.  
 
The TSI1000 Tally mapper can be used in one of three modes: Tally Mapper mode, Virtual Control mode, and Router 
Control mode.  
 
In Tally Mapper mode, the TSI1000 is set up to map certain input conditions to GPI outputs. A tally map input becoming 
“active” will cause any GPI output mapped to the input (via the tally mapper crosspoint selection grid) to turn on. 
 
In Virtual Control mode the Tally Mapper simply sets crosspoints in a virtual matrix within the TSI1000 configuration. The 
tally system programmer must set up the TSI1000 configuration appropriately to take advantage of Virtual Control mode.  
 
In Router Control mode the tally mapper can be used to send crosspoint commands to most of the real routing devices 
supported by the TSI1000. 
 

Operational Mode Setups 
 
In the TSI-TM configuration, the setup differences between the three operational modes are as follows: 
 
Tally Mapper mode:   
 

1. A “Tally Definition Device” is configured in the “Edit Default Resource Devices” dialog box. The tally definition 
device is used by the Tally Mapper and TSI1000 to define the “active” state of each tally map input. A tally map 
input state could, for example, be a GPI input being shorted, or a switcher source going to air. 

 
2. For each tally map output, a “Tally Destination” is defined and enabled in the “Edit Tally Map I/O” dialog box. This 

defines a particular GPI output which is switched on when the tally map output is mapped to an active tally map 
input. 

 
3. For each tally map input the “Monitoring Logic” is set to something other than “None” and the “Monitored 

Resource I/O” is filled in. This information determines what is monitored to detect the “active” or "inactive" state of 
the tally map input. For example, a tally map input could be deemed to be active when a particular GPI input 
receives a closure, or when a particular switcher input goes on-air. 

 
4. “External Router Control” is disabled in the “Edit Default Resource Devices” dialog box. External router control is 

used only in the Router Control mode. 
 

5. Depending on whether Tally System Console (TSC) configuration has GPI Input Base Addresses defined in it’s 
“Configure GPIs” dialog box, the Tally Mapper Console’s “GPI Ports” dialog box may be filled in. This assigns a 
range of GPI input addresses to a GPI port. 

  
Virtual Control mode: 
 

1. A “Tally Definition Device” is not configured in the “Edit Default Resource Devices” dialog box. Because the 
Virtual Control mode merely sets crosspoints in a virtual router within the TSI1000 configuration database, 
information about tally input states is not required. 

 
2. For each tally map output the “Tally Destination” is disabled in the “Edit Tally Map I/O” dialog box. Because the 

“Virtual Control” operating mode is not a tally mapping function, GPI outputs are not defined. 
 

3. For each tally map input the “Monitoring Logic” is set to “None”. Because the “Virtual Control” operating mode is 
not a tally mapping function, the tally input state monitoring logic is not required. 

 
4.  “External Router Control” is disabled in the “Edit Default Resource Devices” dialog box.  
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5. The Tally Mapper Console’s “GPI Ports” dialog box is not filled in. 
 
Router Control mode: 
 

This mode allows direct control of a real router connected to the TSI1000. 
 

This mode is similar to the Virtual Control mode, except that the “External Router Control” is enabled in the “Edit 
Default Resource Devices” dialog box. Depending on the type of router being controlled, the “Level” of control may also 
be set (this causes the TSI1000 to insert level information in each crosspoint switch command in order to target the 
correct router level). 
 

Procedures 
 
Procedure for setting up Virtual Control mode: 
 

1. Click on “Configuration” => “TSI1000(s)” and add one or more TSI1000s, including the TSIs Interface ID and IP 
address. 

 
2. Click on “Configuration” => “Resource Devices” and set the “Tally Mapper Device Name”. This defines the tally 

mapping resource device (a virtual routing matrix) within the TSI1000 configuration database. Select one “Host 
TSI1000” for the Tally Mapper Device, to assign ownership of the resource device to a TSI1000. 

 
3. Click on “Edit” => “Insert” (or press Ctrl-I) to enter the inputs and outputs of the tally matrix. Tally map inputs have 

the “Tally Source” radio button selected, while tally map outputs have the “Tally Destination” radio button selected.  
 

4. For each tally map input or output set a “Displayed Name”, which is the name that appears at each input or output 
on the axes of the tally map.  

 
5. For each tally map input or output set a “Controlled TSI Resource Input or Output”. This is the name of the input or 

output name used by the TSI1000 at a low level to identify an input or output. The name can be entered in the TSC’s 
double-colon format (e.g. R1::001[1] for router “R1”, input “001” on level “1”), or the router name and double-
colon can be omitted, in which case the Tally Mapper Device name will be  automatically pre-pended to the 
resource device name. 

 
Virtual Control mode is the simplest mode to set up in TSI-TM, because most of the work of using virtual control takes 
place in the programming of the TSC. The Virtual Control mode simply causes crosspoint selections to be set in a 
resource device in the TSI1000s database, named after the Tally Mapper Device. As crosspoints are selected on the tally 
map surface, destinations in the Tally Mapper Device resource device within the running TSI1000 are selecting resource 
device inputs. The names of the resource device destinations and the inputs thereby selected are set by the “Controlled 
TSI Resource Input or Output” field of I/O editor dialog box.  
 
In Virtual Control mode, it is necessary only to program tally map inputs and outputs with the appropriate “Controlled 
TSI Resource Input or Output” name programmed for each tally map input or output, along with the Tally Mapper 
Device name. Along with the appropriate tally system programming using the TSC, such a configuration can be used for 
any number of crosspoint-mapping applications, such as assigning camera sources to CCUs, assigning cameras to 
studios, assigning router sources or destinations to UMDs, etc. 

 
Procedure for setting up Tally Mapper mode: 
 

In addition to the steps given in the “procedure for setting up Virtual Control mode” above: 
 

1. Click on “Configuration” => “Resource Devices” and set the “Tally Definition Device Name”. This defines the 
name of the resource device within the TSI1000 configuration database which holds the tally map input state logic. 
Leave “External Router Control” unchecked and select one “Host TSI1000” for the Tally Definition Device. 

 
2. If necessary, as noted below, click on “Configuration” =>”GPI Ports” and set the base address of each GPI port in 

each TSI1000. This is equivalent to the  Tally System Console’s “GPI Input Base Addresses” setting, defined in the 
Tally System Console’s “Configure GPIs” dialog box. A GPI port's base address assigns the start of a range of GPI 
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input addresses that can be read from the port, using one or more Image Video model 4211 GPI units. The first GPI 
input is addressed by a value of zero. 

 
For typical TSI1000 GPI setups where all GPIs are serviced by COM7, this setup is unnecessary, and “Disable Base 
Address Transmit” can be left checked. This setup is also unnecessary if the GPI port base addresses are already set 
up in TSC. In such cases the base address of the COM7 port is assumed to be zero. 

 
This setup is necessary if the GPI port base addresses is not set up in the TSC configuration, and GPI ports other 
than COM7 is programmed in the TSI1000, or more than one GPI port is programmed in the TSI1000. 
 
Note: GPI input addresses start at zero and are each unique within a single TSI1000, ranging in value from zero to 
4095 for each TSI1000. GPI output addresses are each unique within one GPI port of a TSI1000, ranging in value 
from zero to 511 for each GPI port in a TSI1000. 
 

3. Click on “Edit” => “Insert” or right-click the name of an existing tally map input or output, to program the tally map 
inputs and outputs.  

 
Tally map inputs must have the “Tally Source” radio button selected, while tally map outputs must have the “Tally 
Destination” radio button selected. 

 
For tally map inputs, select the desired “Monitoring Logic” and set the “Monitored Resource I/O”. The "Monitored 
Resource I/O" must contain information to specify which inputs or outputs are monitored for purposes of detemining 
the active or non-active state of a given tally map input. 
 
Example 1: To map a GPI input to a tally map input, select the “GPI” radio button and in the “Monitored Resource 
I/O” field enter the address (starting from zero) of the GPI input to be monitored. The physical state of this GPI 
input (shorted or non-shorted) will determine the active state for the tally map input.  
 
Example 2: To assign the on-air state of a particular production switcher input to a tally map input, select the 
“PGM” radio button and set “Monitored Resource I/O” to the name of the source in TSC’s double-colon format (e.g. 
"S1::1" for switcher “S1” input "1"). The on-air state of the switcher input will determine that active state of the tally 
map input. 
 
The meaning of the different “Monitoring Logic” options can be found by opening the Edit I/O dialog box, clicking 
on “?” then clicking each Monitoring Logic radio button. 
 

For tally map outputs, “Enable” the tally destination and select the name of the TSI hosting the GPI output, the GPI 
port (e.g. COM7) and the address of the GPI output (starting with zero for each GPI port). 

 
Note: For an application which requires only the mapping of some commonly-tallied input conditions to GPI 
outputs, Tally Mapper mode is actually easier to set up than Virtual Control mode, because it can generally be done 
without additional programming in the TSC. 

 
Procedure for setting up Router Control mode: 
 

In addition to the steps given in the “procedure for setting up Virtual Control mode” above: 
 

1. Click on “Configuration” => “Resource Devices” and check the “External Router Control” “Enable” checkbox. 
 
2. If the router type requires a level to be specified, enter the name or number of the level in the “Level” field. 

Information on level requirements for specific routers is available in the online help of Tally System Console 
program. 

 
3. The name of the TSI1000 hosting the router port must be selected under “Host TSI1000”. 

 
4. Click on “Edit” => “Insert” or right-click the name of a tally map input or output to get the Input / Output editor 

dialog box. The name of “Controlled TSI Resource Input or Output” in this dialog needs to reflect the “real” inputs 
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and outputs being switched. The format of these inputs and outputs for each router type can be found in the online 
help of the TSC. 
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TMAP Demo Configuration 
 
The TMAP demo configurations for the Tally System Console (TSC) and the TSI Tally Mapper Console (TSI-TM) gives 
an example of the use of Virtual Control mode to provide a simple control interface for assigning sources to UMDs. 
 
In this demonstration configuration, six UMDs can be mapped to six different cameras, allowing camera displays to be 
easily assigned to different UMDs using the tally map grid. Connecting a Kalypso switcher to COM8 at 76800 baud will 
also generate onair tally in the UMDs, using the first 6 Kalypso inputs. 
 
The TSI-TM configuration is set up as follows: 
 
•  TSI1000 Name: TSI1 
•  TSI1000 interface number: 1 (starts from zero, this is the default TSI interface number, corresponds to an interface 

number of “2” in the TSC). 
•  Tally Mapper Device Name: TMAP (this virtual resource device could also be defined in the TSC, but is 

automatically defined in the TSI1000 by TSI-TM). 
•  Tally Map Output Displayed Names: UMD01 to UMD06 
•  Controlled TSI Resource Outputs: TMAP::UMD01 to TMAP::UMD06 
•  Tally Map Input Displayed Names: CAM01 to CAM06 
•  Controlled TSI Resource Inputs: TMAP::CAM01 to TMAP::CAM06 
 
The TSI-TM configuration sets up a grid in which the inputs represent camera sources and the outputs represent UMDs. 
Selecting a crosspoint in the grid assigns a camera to a UMD. 
 
The TSC configuration is set up as follows: 
 
•  Resource Device #1: S1 (Kalypso switcher, can be used to on-air tally the displays) 
•  Resource Device #2: DA (Virtual router, contains sources DA::CAM01-DA::CAM06) 
•  UMDs: UMD01- UMD06 
•  Typical UMD control string: TSX(TMAP::UMD01,A,AC(85),AC(255),AC(170)) 
•  (monitors a virtual destination controlled by the tally map, which can select one of  six cameras on the destination). 
•  Typical resource interconnection: Origin is DA::CAM01, ends are S1::1 (switcher input CAM1) and 

TMAP::CAM01 (input selected by tally mapper). 
•  On-air resource interconnection PGM: specifies the program bus of the Kaypso switcher as the on-air destination. 
•  Typical DA output control: destination DA::CAM01 permanently selects input DA::CAM01.  
 
Taking source CAM01 as an example, the TSX function programmed into each UMD causes the TSI1000 to trace a path 
from the TSI-TM-controlled destination TMAP::UMDXX, to the TMAP input selected in the tally map (i.e. 
TMAP::CAM01), through a resource interconnection called CAM01, to destination DA::CAM01 and finally to input 
DA::CAM01. DA::CAM01 is necessary to provide a common source which is "DA'd" to the switcher input (for on-air 
tally) and to the tally map (for mapping to the UMDs). 
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To use the demo program: 
 

1. It is assumed there is a TSC installed and able to communicate with the TSI1000. 
2. Install the TSI-TM a PC networked to a TSI1000. 
3. Run the TSC online with the TSI1000 and load Tmap-Demo.tsc. 
4. Run TSI-TM and open Tmap-Demo.tsi. 
5. Click on "Configuration" => "TSI1000(s)", click on "TSI1" in the list, modify the IP address of the TSI1000 and 

click "Modify" and close.  
6. Click "File" => "Save". 
7. Press Ctrl-K to connect to the TSI1000. "TSI1000 Online" should appear in the bottom-left status bar. * 
8. Click on the tally map grid to assign different cameras to UMDs. The desktop UMDs should follow the 

assignments. 
 

Depending on the application, logic similar to the that used in the TSC demo program can be used for any application 
where selections using a crosspoint grid make a logical user interface. A few possibilities are: 
 

1. Assigning cameras to CCUs. 
2. Assigning cameras from a camera pool to different studios (allowing cameras to be tallied by different 

production switchers). 
3. Assigning external GPI inputs from another switcher to local sources (allowing another switcher to take over 

local sources and be tallied correctly). 
4. Assigning GPI outputs going to another studio to local sources (allowing local tally to be sent to another 

studio). 
5. Assigning different sources or destinations to monitor wall UMDs or monitor wall tally lights. 

 
Known Bugs in TSI-TM 

 
1. TSI-TM may periodically to show "TSI1000 offline" on the status bar. This is not generally an operational problem 
(proper tally map control will still occur), but this can be easily corrected by pressing Ctrl-D to disconnect and Ctrl-K or 
Ctrl-H to re-connect (ctrl-H reconnects without resend the TSI-TM configuration data). An update will be issued as soon 
as this bug is fixed. 


