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ABOUT THIS MANUAL 

DOCUMENTATION AND SAFETY OVERVIEW 
This manual provides detailed instructions for the installation, operation, and maintenance of the 
PESA equipment. 

It is the responsibility of all personnel involved in the installation, operation, and maintenance of 
the equipment to know all the applicable safety regulations for the areas they will be working in.  
Under no circumstances should any person perform any procedure or sequence in this manual 
if the procedural sequence will directly conflict with local Safe Practices.  Local Safe Practices 
shall remain as the sole determining factor for performing any procedure or sequence outlined 
in this document. 

WARNINGS, CAUTIONS, AND NOTES 

Throughout this manual you should notice various Warnings, Cautions, and Notes.  These 
addendum statements supply invaluable information pertaining to the text that they address.  It is 
imperative that audiences read and understand the statements to avoid possible loss of life, 
personal injury, destruction/damage to the equipment, and/or added information that could 
enhance the operating characteristics of the equipment (i.e., Notes).  The following subsections 
represent a description of the Warnings, Cautions, and Notes statements contained in this manual: 

WARNING 

 

Warning statements identify conditions or practices that can result in loss of 
life or permanent personal injury if the instructions contained in the 
statement are not complied with. 

 

CAUTION 

 

Caution statements identify conditions or practices that can result in 
personal injury and/or damage to equipment if the instructions contained in 
the statement are not complied with. 

 

NOTE 

 

Notes are for information purposes only.  However, they may contain 
invaluable information important to the correct installation, operation, 
and/or maintenance of the equipment. 
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End User Commercial License Agreement 
 

Grant 

Subject to purchase of a PESA System Controller, PESA Switching Systems, Inc. (PESA) grants to you a non-
exclusive license to use the Software and accompanying documentation (“Documentation”) in the manner described 
below under “Scope of Grant.” 

Limited Warranty 
PESA warrants that for a period of ninety (90) days from the date of acquisition, the Software, if operated as 
directed, will substantially achieve the functionality described in the Documentation. PESA does not warrant, 
however, that your use of the Software will be uninterrupted or that the operation of the Software will be error-free 
or secure. In addition, the security mechanisms implemented by PESA software have inherent limitations, and you 
must determine that the Software sufficiently meets your requirements.  PESA also warrants that the media 
containing the Software, if provided by PESA, is free from defects in material and workmanship and will so remain 
for ninety (90) days from the date you acquired the Software. PESA’s sole liability for any breach of this warranty 
shall be, in PESA’s sole discretion: (i) to replace your defective media; or (ii) to advise you how to achieve 
substantially the same functionality with the Software as described in the Documentation through a procedure 
different from that set forth in the Documentation; or (iii) if the above remedies are impracticable, to refund the 
purchase price you paid for the System Controller. Repaired, corrected, or replaced Software and Documentation 
shall be covered by this limited warranty for the period remaining under the warranty that covered the original 
Software, or if longer, for thirty (30) days after the date (a) of shipment to you of the repaired or replaced Software, 
or (b) PESA advised you how to operate the Software so as to achieve the functionality described in the 
Documentation. Only if you inform PESA of your problem with the Software during the applicable warranty period 
and provide evidence of the date you purchased a license to the Software will PESA be obligated to honor this 
warranty. PESA will use reasonable commercial efforts to repair, replace, advise or, for individual consumers, 
refund pursuant to the foregoing warranty within 30 days of being so notified. 

THIS IS A LIMITED WARRANTY AND IT IS THE ONLY WARRANTY MADE BY PESA. PESA MAKES NO 
OTHER EXPRESS WARRANTY AND NO WARRANTY OF NONINFRINGEMENT OF THIRD PARTIES’ 
RIGHTS. THE DURATION OF IMPLIED WARRANTIES, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OF MERCHANTABILITY AND OF FITNESS FOR A PARTICULAR PURPOSE, IS LIMITED 
TO THE ABOVE LIMITED WARRANTY PERIOD; SOME JURISDICTIONS DO NOT ALLOW 
LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO LIMITATIONS MAY NOT APPLY 
TO YOU. NO PESA DEALER, AGENT, OR EMPLOYEE IS AUTHORIZED TO MAKE ANY 
MODIFICATIONS, EXTENSIONS, OR ADDITIONS TO THIS WARRANTY. If any modifications are made to 
the Software by you during the warranty period; if the media is subjected to accident, abuse, or improper use; or if 
you violate the terms of this Agreement, then this warranty shall immediately be terminated. This warranty shall not 
apply if the Software is used on or in conjunction with hardware or software other than the unmodified version of 
hardware and software with which the software was designed to be used as described in the Documentation.  THIS 
WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY HAVE OTHER LEGAL RIGHTS 
THAT VARY BY JURISDICTION. 

 

Scope of Grant 

You may:  
• use the Software on any single computer; 
• use the Software on a second computer so long as only one copy is used at a time;  
• copy the Software for archival purposes, provided any copy must contain all of the original Software’s 

proprietary notices.   
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You may not:  
• permit other individuals to use the Software except under the terms listed above;  
• permit concurrent use of the Software;  
• modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable laws specifically 

prohibit such restriction), or create derivative works based on the Software;  
• copy the Software other than as specified above;  
• rent, lease, grant a security interest in, or otherwise transfer rights to the Software; or  
• remove any proprietary  notices or labels on the Software. 

 
Title 

Title, ownership rights, and intellectual property rights in the Software shall remain in PESA and/or its suppliers. 
The Software is protected by the copyright laws and treaties.  Title and related rights in the content accessed through 
the Software is the property of the applicable content owner and may be protected by applicable law. This License 
gives you no rights to such content. 

Termination 

The license will terminate automatically if you fail to comply with the limitations described herein.  On termination, 
you must destroy all copies of the Software and Documentation. 

LIMITATION OF LIABILITY. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, 
CONTRACT, OR OTHERWISE, SHALL PESA OR ITS SUPPLIERS OR RESELLERS BE LIABLE TO YOU 
OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER 
COMMERCIAL DAMAGES OR LOSSES. IN NO EVENT WILL PESA BE LIABLE FOR ANY DAMAGES IN 
EXCESS OF THE AMOUNT PESA RECEIVED FROM YOU FOR A LICENSE TO THE SOFTWARE, EVEN IF 
PESA SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY 
CLAIM BY ANY OTHER PARTY. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY 
FOR DEATH OR PERSONAL INJURY TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH 
LIMITATION. FURTHERMORE, SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION AND 
EXCLUSION MAY NOT APPLY TO YOU. 

Miscellaneous 
If the copy of the Software you received was accompanied by a printed or other form of “hard-copy” End User 
License Agreement whose terms vary from this Agreement, then the hard-copy End User License Agreement 
governs your use of the Software.  This Agreement represents the complete agreement concerning this license and 
may be amended only by a writing executed by both parties. THE ACCEPTANCE OF ANY PURCHASE ORDER 
PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON YOUR ASSENT TO THE TERMS SET 
FORTH HEREIN, AND NOT THOSE IN YOUR PURCHASE ORDER. If any provision of this Agreement is held 
to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable.  This 
Agreement shall be governed by Alabama law (except for conflict of law provisions). 
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FCC Statement 

This device complies with part 15 of the FCC Rules. Operation is subject 
to the following two conditions: 
 
(1) This device may not cause harmful interference, and 
 
(2) this device must accept any interference received, including 

interference that may cause undesired operation. 
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Section I:  Getting Started 
 
 

Welcome to the 3500Pro manual! This section describes the system and explains how to set up both the 
hardware and software.  For more detailed information about the hardware and software, refer to Section 
II and Section III. 

The following topics are included in this section: 

• Chapter 1 – Introduction (Includes product description and specifications) 

• Chapter 2 - Installing and Setting Up the System 

• Chapter 3 - Installing 3500ProLE Software 
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Chapter 1 – Introduction 
1.1 PRODUCT DESCRIPTION 

The 3500Pro System Controller is a low cost, full-featured, microprocessor-based unit designed 
to interface with various configurations of PESA video and audio routing switchers.  The 
3500Pro System Controller, working in conjunction with the 3500Pro Control System software, 
enables users to configure and operate a routing switcher system from a standard IBM-compatible 
personal computer.  Both the 3500Pro System Controller and the 3500Pro Control System 
software are inherently flexible and easily configured.  The 3500ProLE has a smaller feature set, 
which is designed for customers with smaller systems. 

The 3500Pro System Controller utilizes the Motorola 68332 embedded microprocessor.  In 
addition, it is equipped with 4 MB of RAM, 2 MB of FLASH memory, and 8 serial UARTS 
making the 3500Pro System Controller a high-powered control platform for its size. 

The 3500Pro System Controller is capable of controlling up to a 1024 input by 1024 output, 
sixteen level routing switcher system.  Standard features include independent control of each 
level, audio-follow-video switching, virtual matrix mapping, and software reentry.  Matrix 
segmentation (breakup) is also a standard feature. Matrix segmentation enables RGB, Y/C, or 
multiple levels of audio to be configured as smaller matrixes within a larger matrix.  Multiple 
levels of lock priority, 128 salvo capability, full diagnostics, and all-call switching are also 
included in the 3500Pro Controller's standard features plus the ability to configure 1200 sources 
and destinations. 

The controller supports the low-cost RCP control panels manufactured by PESA.  The control 
panels are connected via twisted pair cable and can be remotely located up to 4000 feet from the 
controller.  The control panels communicate with the 3500Pro Controller over a standard RS-485 
interface.  Two RS422 ports and two RS232 ports are provided for communications interface 
with the routing switcher system, the control system computer, and additional equipment items. 

The 3500Pro System Controller is available as a stand-alone unit (rack mountable) or as a plug-in 
unit for routing switchers.  The 3500Pro Controller is fully compatible with PESA's System 5, 
Lynx, Cougar, Jaguar, Tiger, and Cheetah lines of audio and video routing switchers. 
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1.2 MODELS OF THE 3500PRO CONTROLLER 
The six models of the 3500Pro System Controller are described in the following table. 

Table 1: 3500Pro System Controller Basic Models 

Model Description 
3500Pro Internal controller. One or two may be installed in any large-

scale router (except the TDM3000). 
3500Pro-S Single: One controller in a 1RU chassis. 
3500Pro-D Dual: Two controllers in a 2RU chassis. 
3500Pro-SE Single Expandable: One controller installed in a 2RU chassis. 

Expand with Model 3500Pro-DE. 
3500Pro-LE Internal controller. One or two may be installed in any large-

scale router (except the TDM3000). 
3500Pro-LE-S Single: One controller in a 1RU chassis. 
3500Pro-LE-D Dual: Two controllers in a 2RU chassis. 
3500Pro-LE-SE Single Expandable: One controller installed in a 2RU chassis. 

Expand with Model 3500Pro-LE-DE. 
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1.3 SPECIFICATIONS 

1.3.1 Operational Environment 
Temperature...............................................................................................0-40°C 

Operational Humidity .................................................... 0-90% Non-Condensing 

1.3.2 Physical Characteristics 
3500Pro-S 

 Height ........................................................ 1.75 in (45 mm) (1 Rack Unit) 
 Width ................................................................................. 19 in (483 mm) 
 Depth.................................................................................... 8 in (203 mm) 
  

 

3500Pro-D 

 Height .......................................................3.50 in (89 mm) (2 Rack Units) 
 Width ................................................................................. 19 in (483 mm) 
 Depth.................................................................................. 10 in (254 mm) 
  

1.3.3 Power 
3500Pro-S 

 Input ................................................................................ 8.5 +1.5 VDC 
 Input Connector, 3500-S.......................................... 3-Contact Proprietary 
  

3500Pro-D 

 Input ................................................................................ 8.5 +1.5 VDC 
 Input Connector, 3500-D ......................................... 6-Contact Proprietary 
  

PS130 Internal Power Supply (Optional for 3500Pro-D Only) 

 Part Number...................................................................... 81-9065-2048-0 
 Input ............................................................... 105-240 VAC, 50-60 Hz 
 Input Connector IEC 320 Receptacle 
 Output .........................................................................+8.9 VDC at 5.5 A 

1.3.4 SRU Power Pack 
 Part Number...................................................................... 81-9065-2215-0 
 AC to DC Power. Pack .......................................Input AC 95 to 240 VAC 
  ..............................................Output DC +12 VDC and –12 VDC 

 



 
 

3500PROLE – SECTION I  
81-9059-0549-0 Rev. D 

 

Proprietary Information of PESA SWITCHING SYSTEMS, INC. 5 

 

1.3.5 IEC 320 Line Cords 
US 

 Part Number...................................................................... 81-9028-0403-0 
 Connectors ................................................. IEC 320-C13 to NEMA 5-15P 

UK 
 Part Number...................................................................... 81-9028-TBD-0 
 Connectors ....................................................... IEC 320-C13 to BS 1363A 

Euro 
 Part Number...................................................................... 81-9028-0411-0 
 Connectors ............................................. IEC 320-C13 to CEE 7/7 Schuko 

1.3.6 Communications 
Number of RS-232 Ports .................................................................................... 2 
Number of RS-422 Ports .................................................................................. 2* 
Data Rate .................................................................................. 9600/38400 baud 

 
* =  One port is dedicated to use as PRC interface.  It is an RS422, but customer can’t utilize 

it for 3rd-party installs. 
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Chapter 2 – Installing and Setting up  
the System 

To get started with the 3500Pro system, first you need to install and set up the hardware.  Next, 
you need to connect the hardware to the computer that will run the 3500Pro software.  Finally, 
you will install the 3500Pro software and establish communication with the hardware.  This 
chapter describes how to perform these steps.  Additionally, this chapter provides basic 
instructions for setting up your system.  For detailed information about the hardware and how to 
operate it, refer to Section II.  For detailed information about the software and how to work with 
it, refer to Section III. 

2.1 SHIPPING DAMAGE INSPECTION 
Immediately upon receipt, all shipping containers should be inspected for damage caused in 
transit. If any damage is noted, save all packing material and contact both PESA and the carrier as 
soon as possible. 

2.2 UNPACKING 

 

This equipment contains static sensitive devices.  A grounded wrist strap 
and mat should be used when handling the 3500Pro System Controller. 

 

Carefully unpack the equipment and compare the parts received against the packing list.  If any 
parts appear to be missing, please contact PESA immediately. 

2.3 INSTALLATION LOCATION 
This controller was designed for installation in a standard 19-inch equipment rack located in an 
environment conforming to the specifications shown in Chapter 1.  Each unit should be located as 
close as possible to its associated equipment to minimize cable runs.  Sufficient space must be 
provided behind the equipment racks to allow for control, signal, and power cables.  All panel 
mounting holes should be utilized and mounting hardware tightened securely. 

Consideration should be given to the connection of this equipment to the supply circuit and the 
effect that possible overloading could have on overcurrent protection circuits and supply wiring.  
Refer to the nameplate ratings when addressing this concern. 
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Install the equipment into the rack as follows: 

1.  Insert the panel assembly into the equipment rack and support the bottom of the panel 
assembly until all mounting hardware has been installed and properly tightened. 

2.  Install the bottom two panel-mounting screws. 

3.  Install the top two panel-mounting screws. 

4. Install any remaining panel-mounting screws. 

5.  Tighten all panel-mounting screws until they are secure. 

2.4 INTERNAL INSTALLATION - MODEL 3500PRO 
One or two 3500Pro or 3500ProLE System Controllers can be installed in a any of the large scale 
routers except for the TDM3000.  For detailed instructions for installing the controller, refer to 
the related product manual.  

2.5 INTERFACE CONNECTIONS 
For reasons of personal safety, and to prevent damage to the equipment or cables, the following 
guidelines should be followed when connecting cables to this equipment. 

1. Install the equipment in the rack before connecting cables. 

2. All cables should be carefully strain relieved to prevent connector separation. 

3. To the extent possible, separate control, signal, and power cables to minimize crosstalk and 
interference. 

4. The liberal use of nylon cable ties to secure cables to the rack is encouraged. This will 
minimize the amount of force transmitted to the equipment and help route cables away 
from hazardous areas. 

5. Route cables away from walk areas to avoid creating a safety hazard. 
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2.5.1 Model 3500-S Connection Guide 
The following section shows how to connect the 3500Pro and 3500Pro-S. For detailed 
information about each available option, refer to Section II.   

 

 

 

 

 

CPU ALARM1 PRINTER

3300/3500 SYNC
6600 POLLING PORTS

2 3 4
COM3/PRC

COM4
COM2 COM1 AUXILIARY STROBESYSTEM V CONTROL

21 3

PANEL PORTS

4

485

GNDGND

+V

-V -V

+V

POWER

 
 

 

 

 

 

 

 

Figure 1: 3500Pro-S Connection Guide 
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2.5.2 Models 3500Pro-D (and 3500Pro-SE/3500Pro-DE) Connection Guide 
The following section shows how to connect the 3500Pro-D, SE, and DE.  For detailed 
information about each available option, refer to Section II. 
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Figure 2: 3500Pro-D (and 3500Pro-SE / 3500Pro-DE) 

 

2.5.3 Model 3500Pro Connection Guide 
Installing internal 3500Pro models are different for each switcher.  For detailed information 
about how to install 3500Pro internal models and how to connect the hardware, refer to the 
appropriate switcher manual.   

However, you will always need to establish a connection from the COM1 port or Serial 1 port 
on the rear of the router switcher to the PC that will run the 3500Pro software.  
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2.6 INSTALLING THE SOFTWARE 
After installing the hardware and establishing a connection with the computer where you will 
install the software, you need to install the 3500Pro software. Then you can create a basic 
configuration to communicate with the controller. This chapter describes how to do this. 

Before you start this procedure, make sure you have connected the 3500Pro System Controller to 
the PC where you will install the software (see Figures 3 and 4).  
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Figure 3: Connecting the 3500Pro-S to the PC 
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Figure 4: Connecting the 3500Pro-D, DE, and SE to the PC 

 

 

Systems using an internal 3500Pro are different depending on the type of 
system you purchased. However, you will always need to establish a 
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2.6.1 Hardware and Software Requirements 
The minimum PC requirements to run Win3500Pro are: 

• Processor:  500 MHz or above 

• Memory:  128 MB of RAM or more 

• Monitor:  800X600 SVGA or better 

• Serial Port: One serial port available from COM1 through COM4 available for CPU 
Link use (Minimum of a 16550 UART preferred.) 

• Hard Disk:  100 MB of available space  

• Operating System: Microsoft® Windows® NT™ 4.0, Microsoft Windows 
2000/Professional, or Microsoft Windows XP (Home and Pro) 
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2.6.2 General Specifications Table 

Table 2: Specifications Table 

Specification 3500Pro 3500ProLE 

Max. Number of Levels 16 8 

Max Number of 
Inputs/Outputs per Level 

1024 144 

Max Number of 
Components 

32 16 

Max Number of Tielines 64 0 

Max Number of 
Categories 

254 254 

Max Number of Sources 1200 180 

Max Number of 
Destinations 

1200 180 

Max Number of Reentries 8 0 

Max Number of Salvos 128 (1024 switches 
can be allocated 
across all 128 
salvos) 

64 

Component Types RM5 (System 5) PRC, XTN, TGR 

Offset Range 0-255 0-4094 

Strobe Range 1-5 1-63 

Specification 3500Pro and 3500ProLE 

Lock Priority Range 0-255 ("0" is Highest Priority) 

Max Number of Control 
Panels 

500 

Panel Address Range 1-1023 

Panel Requestor Code 
Range 

1-65535 

Chop Rate 1-255 Frames 
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Chapter 3 Installing 3500Pro/  
LE Software 

3.1 READ THIS FIRST! 
 

 

• Installing the 3500Pro/3500ProLE software is not a simple procedure. 
You must follow the instructions in this guide EXACTLY.  Please read 
this document before you install the software.  

• PESA highly recommends that you use either Microsoft Windows 2000 
or Microsoft Windows XP Professional. 

• Installation of the 3500Pro/3500ProLE must be performed by a user 
with Administrator privileges.  Please refer to your System 
Administrator for more information about acquiring these privileges.    

• The 3500Pro software suite requires the installation of Microsoft 
Transaction Server (MTS), Microsoft Data Access Components 
(MDAC) V2.8, and the Microsoft Desktop Engine (MSDE2000) 
database.  These components must be properly installed before the 
3500Pro/3500ProLE will operate properly.   This document details how 
these component are installed.      

 
 

 

This document describes the installation process for both the 3500Pro and 
3500ProLE tool suite.  Though many of the figures in the document 
describe the 3500ProLE installation, they apply to the 3500Pro as well.   

 

3.2 HARDWARE AND SOFTWARE REQUIREMENTS 
The minimum PC requirements to run 3500Pro/3500ProLE are: 

 

 

PESA highly recommends that you use either Microsoft Windows 2000 or 
Microsoft Windows XP Professional. 

 
• Processor:  500 MHz 

• Memory:  128 MB of RAM 

• Monitor:  800X600 SVGA 
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• Serial Port:  One serial port  (Minimum of a 16550 UART preferred.) 

• Hard Disk:  300 MB of available space on your C drive  

• Operating System:  Microsoft® Windows® 2000, Microsoft Windows XP (Home and Pro), 
or Microsoft Windows NT™ 4.0.   

3.3 IMPORTANT INFORMATION FOR WINDOWS NT USERS! 
Although the 3500Pro/3500ProLE runs on Windows NT 4.0, it is strongly suggested that you 
migrate your operating system to Windows 2000 or Windows XP (Professional).  Upgrading your 
software allows you to take advantage of newer Microsoft technologies that are marginally 
supported under Windows NT 4.0.   

If you are going to install the 3500Pro/3500ProLE under Windows NT 4.0, you must install the 
Microsoft Transaction Server (MTS).  The MTS installation package is included in the Windows 
NT Option Pack available from Microsoft:  

http://www.microsoft.com/ntserver/nts/downloads/recommended/NT4OptPk/default.asp 

The web page provides instructions for installing the service pack. Follow the instructions 
exactly! 

 

Microsoft Transaction Server (MTS) must be installed on your machine in 
order for the 3500Pro/3500ProLE to operate.  The installation software 
provides no indication of whether the MTS software is installed or not.  What 
appears to be a valid installation will not work if the MTS is not already 
installed. 
Installing the MTS will require you to reboot your machine. 

 

3.4 3500PRO/3500PROLE SOFTWARE INSTALLATION SEQUENCE 
 

 

Installation of the 3500Pro/3500ProLE must be performed by a user with 
Administrator privileges.  Please refer to your System Administrator for more 
information about acquiring these privileges.    
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Follow these steps to install the software. 

1. Insert the 3500Pro/3500ProLE CD into the CD drive.  The installation program should 
automatically start when the PC recognizes the installation program.  

If the program does not automatically start, you can double-click the executable installation 
program on CD drive.  (3500ProVx.xInstall.EXE or 3500ProLEVx.xInstall.EXE depending 
upon the type of control software you are installing.) 
 

 

The first dialog encountered during the installation process is a README file 
about converting the *.db extension files.  If this is a first-time installation, the 
user may just ignore this message and continue.   

 

 

 

 

 

 

 

 

 

 

 

 

 
If this is an upgrade installation from a previous version, the README file 
explains the necessity and the process to save all configurations that were 
previously saved as *.db files to *.txt files so that the new *.db file that this 
upgrade creates can be populated to include the old data that is pertinent to 
the controller configuration.   
The *.db files are the actual database files that contain ALL of the database 
information and will typically change from version to version.  However, after 
an upgrade, some data in the older version may be required to be included in 
the new upgrade.  That is the reason *.txt files are created from the old *.db 
files to include just the data that is required to be imported. 
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2. If you are installing the program on Windows NT and do not have the Microsoft 
Transaction Server (MTS) installed on your PC, you will see the following message (see 
Figure 5):   

 

Figure 5: MTS Installation Not Detected 

You will need to acquire the Windows NT option pack from Microsoft and install it before 
continuing with the 3500Pro/3500ProLE installation. 

3. The first items installed by the installation program are the Microsoft Data Access 
Components (MDAC).  Select OK in the following window (see Figure 6). 

 

 
Figure 6: MDAC Installation Notice 

 
 

 

If your computer already has MDAC installed, this step will simply be 
skipped and you will not need to reboot.  Instead, go directly to MSDE 
installation (Step 4). 
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The following prompt (see Figure 7) displays while the MDAC components are installed. 

 

 

 

 

 

Figure 7: Second MDAC Installation Notice 

After MDAC is successfully installed, the following prompt (see Figure 8) displays.  You 
must reboot your computer to proceed with the installation of 3500Pro/3500ProLE.  Make 
sure all other applications are closed, then select OK in this window. 

 

 

 

 

 

 

 

 

 

Figure 8: MDAC Successful Installation Notice 
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4. After you reboot, the installation program will restart and begin installation of the 
Microsoft Desktop Engine (MSDE2000).  The software will install the installation files into 
temporary directories on your machine’s C drive and then install the software.  This 
process will take a number of minutes to complete (see Figures 9 and 10).  

 
 
 
 
 
 
 
 
 
 
 

Figure 9: MSDE2000 Install Progress Window 

 
 
 
 
 
 
 
 
 
 

Figure 10: MSDE2000 Install Notice 
 

Upon completion of installing the MSDE2000, the PC will reboot.    

 

 

If your computer already has MSDE2000 installed, this step will simply be 
skipped and your PC will not reboot. 
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5. After installation of the MSDE2000, the actual 3500Pro/3500ProLE components are 
installed.  This portion of the install displays a greeting window (see Figure 11) indicating 
that you have reached the portion where the actual 3500Pro/3500ProLE is installed. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 11: 3500Pro Install Greeting Window 

The software then presents End User License Agreement (EULA) for the 
3500Pro/3500ProLE (see Figure 12).  The user must accept the license by clicking the 
NEXT button for the installation to continue.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 12: 3500Pro License Agreement 
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After accepting the license, the software prompts for a location where the 
3500Pro/3500ProLE software is to be installed.  Use the Browse button to select the 
location for the 3500Pro/3500ProLE software.  You can install it in any directory on your 
computer, or you can create a new directory.  When the correct directory location displays 
in the following window (see Figure 13), select NEXT. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13: Install Location Window 

If you select the Browse button, this window will display (see Figure 14).  Select the drive 
where you want to install the software.  If you want to create a new directory, type in the 
new directory path in the top of the window.  When the correct directory location displays, 
select OK. 

 
 
 
 
 

 

 

 

 

 

 

Figure 14: Select Destination Directory Window 
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Next, select the components you want to install.  Each item that you want to install should 
have a check mark displayed (see Figure 15).  “Configurator” is the Configuration Editor 
where you set up configuration files.  “Status” is the Status module that allows you to 
monitor the 3500Pro/3500ProLE system.  Select the options you want to install and select 
NEXT. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15: Select Components Window 
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The resulting screen (see Figure 16) allows you to add the associated icons of the 
previously selected components to your desktop.   

 

 

 

 

 

 

 

 

 

Figure 16: Desktop Icon Selection 

If desired, click in the Yes radio button.  If not desired, click in the No radio button.  Then, 
click on Next, which will continue the installation sequence. 

6. After the 3500Pro/3500ProLE software has been installed, the 3500Pro COM+ modules are 
registered with MTS and the runtime database tables are initialized (see Figure 17).  You 
do not have to do anything during this process. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 17: COM+ Registration Installation Progress 
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After this process completes, the final window displays (see Figure 18). Select Finish to 
complete the software installation process. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 18: Finish the Installation 

The installation of the 3500Pro/3500ProLE is now complete.  

You can invoke the 3500Pro/3500ProLE programs through the START menu: 

START->PROGRAMS->PESA 3500Pro Vx.x (where x.x is the current version) 

or: 

START->PROGRAMS->PESA 3500ProLE Vx.x 

The programs can also be invoked by using the icons installed on the user’s desktop.   
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3.5 DOWNLOADING A CONFIGURATION TO THE CONTROLLER 
You can test the connection between the computer and the controller by downloading a sample 
configuration file to the controller.  A sample file is available on the product CD and is called 
“cougar combo numeric”. 

 

This will change the settings on the controller. Do not perform these steps if you 
do not want the current configuration to be overwritten! 

 

 

If you have an existing configuration file, you can use it to test the connection 
instead of the delivered sample file. 

 

1. When you are done with all the installation steps, you can open the 3500Pro Configuration 
Editor by selecting Start > Programs > 3500Pro > Configuration Editor. 

2. Select File > New Configuration Database.  Enter a name for the new configuration and 
select Open.  

3. The software will ask if you want to create the file. Select Yes. 

4. Select File > Transfer Configuration.   

5. Select Import Configuration From ASCII File, then select Execute.   

6. Change to the CD drive with the 3500Pro installation CD.  You will see a file called 
“cougar combo numeric”.  Select this file then select Open.  When Import is Complete 
displays, select OK.   

7. Now, select Download Configuration to Controller and select Execute.  A prompt asks 
if you want to continue. Select OK.  

8. This will send the information in the configuration file you just opened to the controller.  
You will see: 

• Exporting the configuration to a file  
• Downloading to the Controller 
• Committing the configuration to Flash 
• Configuration Download is complete 

Congratulations! You have established a connection.  

Now, you can start to customize the configuration file to suit your requirements.  Go on to 
Section III for detailed instructions for adding to your configuration and customizing it for your 
applications. 
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Section II:  Hardware Reference Guide 
 
 
The section provides detailed information about the 3500Pro System Controller hardware.  The 3500Pro-
S and 3500Pro-D are both described. 
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Chapter 4 – Hardware Description 
 

This chapter provides descriptions for all of the available features in the 3500Pro-S and 3500Pro-
D System Controllers.  For details about internal 3500Pro controllers, refer to the appropriate 
routing switcher manual. 

4.1 MODEL 3500PRO-S 
All interface connections are made at the rear of this equipment as shown in Figure 19. 

CPU ALARM1 PRINTER

3300/3500 SYNC
6600 POLLING PORTS

2 3 4
COM3/PRC

COM4
COM2 COM1 AUXILIARY STROBESYSTEM V CONTROL

21 3

PANEL PORTS

4

485

GNDGND

+V

-V -V

+V

POWER

 
Figure 19: 3500Pro-S Rear View 

4.1.1 3300/3500Pro SYNC / 6600 POLLING PORT 1 (J1) 
This BNC connector is used for an optional vertical sync signal input.  If it will not be used, 
install a 75 Ohm terminator (Part No. 81-9029-0668-4).  This signal allows the switches to be 
scheduled for vertical, interval timing.    

4.1.2 6600 POLLING PORTS 2, 3, and 4 (J2, J3, J4) 
These BNC connectors are reserved for future use.  There are no internal connections and they 
do not need to be terminated. 

4.1.3 PRINTER (J5) 
This DB25-Female connector is reserved for future use.  See Figure 20 for an orientation view 
showing contact locations. 

1

14

2345678910111213

1516171819202122232425

Contact locations when viewed
from rear of chassis.  

Figure 20: 3500Pro-S J5 (PRINTER) Connector 
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4.1.4 COM 1 (J14), COM 2 (J13) 
These DB9-Male connectors provide RS-232 serial communication interfaces.  See Figure 21 
for an orientation view showing contact locations. 

• COM 1 is the primary RS-232 CPU Link and may be connected to the PC running 
3500Pro Control System software with a null modem cable (Part No. 81-9028-0393-0).  
COM 1 may only be used with the P1E protocol, at either 9600 or 38400 baud.  The 
communication rate is selected with switch S1 as described in “S1-3 COM 1 Rate” on 
page 45. 

• COM 1 may also be connected to an external modem using an AT Serial Modem cable 
(Part No. 81-9028-0400-0).   

• COM 2 is a secondary RS-232 CPU Link, which may also be connected to a PC or 
external modem.  COM 2 may be used with any of the protocols shown in the following 
table and may operate at either 9600 or 38400 baud.  The communication rate for COM 2 
is determined by settings made in the 3500Pro software.  COM2 has the same pinout as 
COM1. 

If necessary, a cable up to 50 feet in length may be fabricated in the field.  For a Null-Modem 
cable, see Figure 22.  For an AT Serial-Modem cable, see Figure 23. 

Table 3: PESA CPU Link Protocols 

Protocol Document No. 
CPU Link Protocol No. 1 (P1) 81-9062-0407-0 
CPU Link Protocol No. 1 Extensions 
(P1E) 

81-9062-0408-0 

Unsolicited Status Protocol (USP) 81-9062-0409-0 
Truck Link Protocol (TRK) 81-9062-0410-0 

Contact locations when viewed
from rear of chassis.

54321

9876

 
Figure 21: 3500Pro-S J13, J14 (COM 1, COM 2) Connectors 

 

CD (Carrier Detect)

RX (Receive Data)
TX (Transmit Data)

DTR (Data Terminal Ready)
SG (Signal Ground)
DSR (Data Set Ready)

RTS (Ready To Send)
CTS (Clear To Send)

RI (Ring Indicator)

DB-9 Female To:
3500Plus-S J13 or J14

CTS (Clear To Send)
RTS (Ready To Send)
DSR (Data Set Ready)

DTR (Data Terminal Ready)

RX (Receive Data) 2

RI (Ring Indicator)

SG (Signal Ground)

TX (Transmit Data)

9
8
7
6
5
4
3

CD (Carrier Detect) 1
3

9
7
8

5
6
2

4

DB-9 Female To:
PC

1

 
Figure 22: 3500Pro-S RS-232 CPU Link (Null Modem) Cable 
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DSR (Data Set Ready)
RTS (Ready To Send)
CTS (Clear To Send)

DTR (Data Terminal Ready)

DB-9 Female To:
3500Plus-S J13 or J14

3TX (Transmit Data)

SG (Signal Ground)

RI (Ring Indicator)

5
6
7
8
9

4

CD (Carrier Detect)
RX (Receive Data)

1
2

RI (Ring Indicator)

RTS (Ready To Send)
CTS (Clear To Send)

DTR (Data Terminal Ready)
SG (Signal Ground)
DSR (Data Set Ready)

RX (Receive Data)
TX (Transmit Data)

CD (Carrier Detect)

2

6
7

4
5

22

20

DB-25 Male To:
 External Modem

8
3

 
Figure 23: 3500Pro-S RS-232 CPU Link (AT Serial Modem) Cable 

4.1.5 COM 3/PRC (J12), COM 4 (J6) 
These DB9-Male connectors provide RS-422 serial communication interfaces. See Figure 24 
for an orientation view showing contact locations. 

• COM 3/PRC is the communications interface to a PRC type routing switcher system and 
is connected to a routing switcher. If necessary, a cable up to 4000 feet in length may be 
fabricated in the field as shown in Figure 25.   

• COM 4 is an RS-422 CPU Link and may be connected to a PC with the 3500Pro software 
installed.  The cable may be up to 4000 feet in length and an RS-422 interface card must 
be installed in the PC.  COM 4 may be used with any of the protocols shown in Figure 26 
on the next page.  If necessary, a cable may be fabricated in the field as shown in Figure 
26. 

Contact locations when viewed
from rear of chassis.

6 7 8 9

1 2 3 4 5

 
Figure 24: 3500Pro-S J6, J12 (COM 3/PRC, COM 4) Connectors 

 

System Controller TX+ (High)
System Controller TX- (Low)
Chassis Ground
System Controller RX+ (High)
System Controller RX- (Low)
Chassis Ground
Chassis Ground
Chassis Ground
Chassis Ground

DB-9 Female To:
3500Plus-S J12

6Chassis Ground
Chassis Ground 9

System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

Chassis Ground
Chassis Ground

Chassis Ground

5
4
7
2
1
3
8

6
9

5
4
7
2
1
3
8

DB-9 Female To:
PRC Type Device

 
Figure 25: 3500Pro-S RS-422 Serial Cable 
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System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

6Chassis Ground
Chassis Ground 9

DB-9 Female To:
3500Plus-S J6

System Controller RX+ (High)
System Controller RX- (Low)

System Controller TX- (Low)
System Controller TX+ (High)

Chassis Ground
Chassis Ground

Chassis Ground

2
7

8
3
4
5

1

Customer supplied 
Connector

 
Figure 26: 3500Pro-S RS-422 CPU Link Cable 

4.1.6 CPU ALARM (J7) 
This 3-contact connector provides the interface for the CPU alarm.  See Figure 27 for an 
orientation view showing contact locations. 

The 3500Pro operating software determines when an alarm condition is declared.  During an 
alarm condition, an optically isolated, closed circuit exists between contacts 1 and 3.  The 
customer supplied external alarm circuit is connected with a cable constructed as shown in 
Figure 28. 

The 81-9029-0780-0 connector body has an integral strain relief, which requires the use of a 
nylon cable tie included with the connector.  If this is not available, cable tie Part No. 
81-9021-0028-8 may be used. 

 

 

The alarm circuit connected to this connector must not exceed 12VDC or 
10mA. 

Contact locations when viewed
from rear of chassis.

3 2 1

 
Figure 27: 3500Pro-S J7 (CPU ALARM) Connector 

 

81-9029-0780-0 To:
3500Plus-S J7

Customer Supplied
Connector

Chassis Ground
3Alarm Low
2

Alarm High 1

 
Figure 28: 3500Pro-S CPU Alarm Cable 
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4.1.7 485 PANEL PORTS 1-4 (J8, J9, J10, J11) 
These 3-contact connectors are wired in parallel, which provide RS-485 serial communication 
interfaces using the PESA RCP Protocol (Document No. 81-9062-0300-0).  See Figure 29 for 
an orientation view showing contact locations. 

J8, J9, J10, and J11 are connected to PESA Remote Control Panels with daisy-chained cables 
constructed with 3-contact connectors (Part No. 81-9029-0780-0) and shielded, twisted-pair 
audio cable (Part No. 81-9028-0043-2, Belden 8451, or equivalent) as shown in Figure 30.  The 
connector body has an integral strain relief, which requires the use of a nylon cable tie, which is 
included with the connector.  If this cable tie is not available, Part No. 81-9021-0028-8 may be 
used. 

1

Contact locations when viewed
from rear of chassis.

23

 
Figure 29: 3500Pro-S J8, J9, J10, J11 (485 PANEL PORTS 1-4) Connectors 

 

`

RCP connector
contact locations
when viewed from

rear of chassis.

High (+)
Low (-)

81-9029-0780-0 To:
3500Plus-S J8, J9, J10 or J11

Shield (S)

1
3
2

Additional RCPs may be 
daisy-chained together 

as required.

1
3
2

1

2
3

81-9029-0780-0 To:
Remote Control Panel

1
3
2

High (+)
Low (-)
Shield (S)

3

-

1

+

2

S

 

Figure 30: 3500Pro-S RS-485 Serial Cable 
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4.1.8 SYSTEM V CONTROL (J15) 
This DB37-Male connector provides the System 5 control interface and uses the RM5 Protocol 
(Document No. 81-9062-0155-3).  See Figure 31 for an orientation view showing contact 
locations. 

J15 is connected to a Lynx or RM5 type routing switcher with cable assembly Part No. 
81-9065-1189-2.  If necessary, a cable may be fabricated in the field as shown in Figure 32.  If 
more than one System 5 Routing Switcher will be connected to the System Controller, refer to 
Drawing No. WI50-0262 for bifurcated cable construction details. 

Contact locations when viewed
from rear of chassis.

1119 18 17 16 15 14 13 12

37 36 35 34 33 32 3130 29

10 9 8

28 27 26

7 6 5 4 3 2

202524 23 22 21

1

 
Figure 31: 3500Pro-S J15 (SYSTEM V CONTROL) Connector 
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9

DB-37 Female To:
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DB-37 To:
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23
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20
19
18
17
16
15

11
12
13

10

Ground

Strobe 1

Read/Write
Primary/Secondary

Vertical Trigger Inhibit

Strobe 2
Strobe 3
Strobe 4
Strobe 5

Readback Data Bit 3
Readback Data Bit 4
Readback Data Bit 5
Readback Data Bit 6
Readback Data Bit 7
Readback Data Bit 8
Readback Data Bit 9

Input Address Bit 6

Output Address Bit 5

Output Address Bit 9
Output Address Bit 8
Output Address Bit 7
Output Address Bit 6

Confidence
Readback Data Bit 1
Readback Data Bit 2

Input Address Bit 9
Input Address Bit 8
Input Address Bit 7

Output Address Bit 4
Output Address Bit 3
Output Address Bit 2
Output Address Bit 1

Input Address Bit 1

Input Address Bit 3

Input Address Bit 5
Input Address Bit 4

Input Address Bit 2

 
Figure 32: 3500Pro-S RM5 Control Cable 

4.1.9 AUXILIARY STROBE (J16) 
This DB15-Male connector is reserved for future use.  See Figure 33 for an orientation view 
showing contact locations. 

Contact locations when viewed
from rear of chassis.

9 10 11 12 1314 15

1 2 3 4 5 6 7 8

 
Figure 33: 3500Pro-S J16 (AUXILIARY STROBE) Connector 
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4.1.10 POWER (J17, J18) 
These 3-contact connectors are the power connectors.  See Figure 34 for an orientation view 
showing contact locations. 

 

 

To avoid damage to the 3500Pro-S System Controller, the power connectors 
(J17 and J18) must never be connected to any of the following: 

• A Lynx, Cougar or Jaguar audio routing switcher 
• An external audio power supply (PS140A or PS270A) 
• An RM5000 video routing switcher or its external power supply 

(PS270V) 
 

The Model 3500Pro-S has no internal power supply. J17 and J18 are connected in parallel.  One 
is used for power input and the other may be used as a loop-through connector to provide 
power to another device.  Input power may be drawn from the following sources: 

The 3500Pro-S may obtain power from PESA system components having 3-contact power 
connectors by using a power cable assembly (Part No. 81-9065-1183-7) constructed as shown 
in Figure 35.  If this cable is to be constructed in the field, refer to Drawing No. WI50-0172 for 
assembly details.  

The 3500Pro-S may obtain power from PESA system components having 6-contact power 
connectors by using a power cable assembly (Part No. 81-9065-1653-0) constructed as shown 
in Figure 36.  If this cable is to be constructed in the field, consult Drawing No. WI50-0238 for 
assembly details.  

 

Contact locations when viewed
from rear of chassis.

1

2

3

 
Figure 34: 3500Pro-S J17, J18 (POWER) Connectors 

GND (BLK)
+V (RED)

-V (WHT)

81-9029-0649-4 To:
3500Plus-S J17 or J18

1
2
3 3

1

81-9029-0649-4 To:
Power Source

2

 
Figure 35: 3500Pro-S Power Cable with 3-Contact Plug 
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-V (WHT)

+V (RED)
GND (BLK)

81-9029-0649-4 To:
3500Plus-S J17 or J18

3
2
1

81-9029-0160-2 To:
Power Source

5
4

6
1
2
3

 
Figure 36: 3500Pro-S Power Cable with 6-Contact Plug 

4.2 MODELS 3500PRO-D (AND 3500PRO-SE / 3500PRO-DE) 
All interface connections are made at the rear of this equipment as shown in Figure 37. 

PWR
EXTERNAL 

ALARM
PWR DUAL SYSTEM CONTROLLER

COM 2

COM 3 / PRC PRC

SYNC

COM 4

COM 1

CPU
ALARM

  4
POLLING 

  2  3   1SYSTEM V CONTROL

 
Figure 37: 3500Pro-D Rear View 

4.2.1 EXTERNAL POWER (J5) 
This 6-contact connector is the DC power interface connector. See Figure 38 for an orientation 
view showing contact locations. 

 

 

To avoid damage to the 3500Pro-D System Controller, the External Power 
connector (J5) must never be connected to any of the following: 

• A Lynx, Cougar or Jaguar audio routing switcher 
• An external audio power supply (PS140A or PS270A) 
• An RM5000 video routing switcher or its external power supply 

(PS270V) 
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The Model 3500Pro-D may be configured with or without internal power supplies.  If either of 
the internal power supplies are installed, J5 may be used to provide power to other equipment.  
If neither of the internal power supplies is installed, J5 is used to connect the 3500Pro-D to an 
external power source.  Input power may be drawn from the following sources: 

• The 3500Pro-D may obtain power from PESA system components having 3-contact 
power connectors by using a power cable assembly (Part No. 81-9065-1653-0) 
constructed as shown in Figure 39.  If this cable must be constructed in the field, consult 
Drawing No. WI50-0238 for assembly details.  

• The 3500Pro-D may obtain power from PESA system components having 6-contact 
power connectors by using a power cable assembly (Part No. 81-9065-TBD-0) 
constructed as shown in Figure 40.  If this cable must be constructed in the field, consult 
Drawing No. WI50-TBD for assembly details.  

3 2 1

6 5 4

Contact locations when viewed
from rear of chassis.  

Figure 38: Orientation View - 3500Pro-D J5 (EXTERNAL POWER) Connector 

GND (BLK)
+V (RED)

-V (WHT)

81-9029-0160-2 To:
3500Plus-D J5

1
2
3

3
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2
1
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4
5

 
Figure 39: 3500Pro-D Power Cable with 3-Contact Plug 
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Figure 40: 3500Pro-D Power Cable with 6-Contact Plug 
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4.2.2 PWR ALARM (J22) 
This 3-contact connector provides the interface for the Power Supply alarms.  See Figure 41 for 
an orientation view showing contact locations. 

Each of the two PS130 Power Supplies has its own internal low voltage alarm, which will be 
enabled when the output voltage varies from 9VDC by ±12%.  During an alarm condition, an 
optically isolated, closed circuit exists between contacts 3 and 1 for Power Supply A (top), and 
contacts 2 and 1 for Power Supply B (bottom).  The customer supplied external alarm circuit is 
connected with a cable constructed as shown in Figure 42. 

 

 

The alarm circuit connected to this connector must not exceed 12VDC or 
10mA. 

Contact locations when viewed
from rear of chassis.

S
-
+

3
2
1

 
Figure 41: 3500Pro-D J22 (PWR ALARM) Connector 

PS Alarm A (Top) (+)

PS Alarm (-)
PS Alarm B (Bottom) (+)

81-9029-0811-0 To:
3500Plus-D J22

S
-
+

Customer Supplied 
Connector

1
2
3

 
Figure 42: 3500Pro-D PS Alarm Cable 

4.2.3 SYNC (J16, J17) 
These BNC connectors are wired in parallel and are used for an optional vertical sync signal 
input.  The second connector is to allow the signal to be looped through the 3500Pro-D chassis 
and routed to other equipment.  Unused connectors must be terminated with a 75Ω terminator 
(Part No. 81-9029-0668-4). 
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4.2.4 COM 1 (J7), COM 2 (J8) 
These DB9-Male connectors provide RS-232 serial communication interfaces.  See Figure 43 
for an orientation view showing contact locations. 

• COM 1 is the primary RS-232 CPU Link and may be connected to the PC running 
3500Pro Control System software with a null modem cable (Part No. 81-9028-0393-0).  
If necessary, a cable up to 50 feet in length may be fabricated in the field as shown in 
Figure 44.  COM 1 may only be used with the P1E protocol, at either 9600 or 38400 
baud.  The communication rate is selected with switch S1 as described in “S1-3 COM 1 
Rate” on page 45. 

• COM 1 may also be connected to an external modem using an AT Serial Modem cable 
(Part No. 81-9028-0400-0).  If necessary, a cable up to 50 feet in length may be 
fabricated in the field as shown in Figure 45. 

• COM 2 is a secondary RS-232 CPU Link, which may also be connected to a PC or 
external modem.  COM 2 may be used with any of the protocols shown in the following 
Table 4 and may operate at either 9600 or 38400 baud.  The communication rate for 
COM 2 is determined by settings made in the 3500Pro software.  COM2 has the same 
pinout as COM1. 

Table 4: PESA CPU Link Protocols 

Protocol Document No. 
CPU Link Protocol No. 1 (P1) 81-9062-0407-0 
CPU Link Protocol No. 1 Extensions (P1E) 81-9062-0408-0 
Unsolicited Status Protocol (USP) 81-9062-0409-0 
Truck Link Protocol (TRK) 81-9062-0410-0 

Contact locations when viewed
from rear of chassis.

54321

9876

 
Figure 43: 3500Pro-D J7, J8 (COM 1, COM 2) Connectors 

CD (Carrier Detect)

CTS (Clear To Send)
RTS (Ready To Send)
DSR (Data Set Ready)

DTR (Data Terminal Ready)

RI (Ring Indicator)

SG (Signal Ground)

TX (Transmit Data)
RX (Receive Data)

DB-9 Female To:
3500Plus-D J7 or J8

DB-9 Female To:
PC

2 3

9
8
7
6
5
4
3

9
7
8

5
6
2

4

1 1
TX (Transmit Data)

DSR (Data Set Ready)

DTR (Data Terminal Ready)

RX (Receive Data)

SG (Signal Ground)

RTS (Ready To Send)
CTS (Clear To Send)

RI (Ring Indicator)

CD (Carrier Detect)

 
Figure 44: 3500Pro-D RS-232 CPU Link (Null Modem) Cable 
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DTR (Data Terminal Ready)

DB-9 Female To:
3500Plus-D J7 or J8

RI (Ring Indicator)

SG (Signal Ground)

CTS (Clear To Send)
RTS (Ready To Send)
DSR (Data Set Ready)

RX (Receive Data)
TX (Transmit Data)

CD (Carrier Detect)

4

9
8
7
6
5

2
3

1

DB-25 Male To:
 External Modem

CD (Carrier Detect)

TX (Transmit Data)
RX (Receive Data)

DSR (Data Set Ready)
SG (Signal Ground)
DTR (Data Terminal Ready)

CTS (Clear To Send)
RTS (Ready To Send)

RI (Ring Indicator)

20

22
5
4

7
6

3
2

8

 
Figure 45: 3500Pro-D RS-232 CPU Link (AT Serial Modem) Cable 

4.2.5 COM 3/PRC (J9), COM 4 (J10) 
These DB9-Male connectors provide RS-422 serial communication interfaces.  See Figure 46 
for an orientation view showing contact locations. 

• COM 3/PRC is the communications interface to a PRC type routing switcher system and 
is connected to a routing switcher.  If necessary, a cable up to 4000 feet in length may be 
fabricated in the field as shown in Figure 47.  It contains the same physical connections 
as in 5-pin, PRC connector. 

• COM 4 is an RS-422 CPU Link.  The cable may be up to 4000 feet in length and an RS-
422 interface card must be installed in the PC that has the 3500Pro software program.  
COM 4 may be used with any of the protocols shown in Table 4 on the previous page.  If 
necessary, a cable may be fabricated in the field as shown in Figure 47. 

1

Contact locations when viewed
from rear of chassis.

6 7 8 9

2 3 4 5

 
Figure 46: 3500Pro-D J9, J10 (COM 3/PRC, COM 4) Connectors 

Chassis Ground
Chassis Ground
Chassis Ground
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System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

Chassis Ground
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5
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1
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PRC Type Device

 
Figure 47: 3500Pro-D RS-422 Serial Cable 
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9
6

Chassis Ground
Chassis Ground

System Controller TX+ (High)
System Controller TX- (Low)

System Controller RX- (Low)
System Controller RX+ (High)

1

5
4
3
8

7
2

DB-9 Female To:
3500Plus-D J9

Chassis Ground

Chassis Ground
Chassis Ground

System Controller TX+ (High)
System Controller TX- (Low)

System Controller RX+ (High)
System Controller RX- (Low)

Customer supplied 
Connector

 
Figure 48: 3500Pro-D RS-422 CPU Link Cable 

4.2.6 CPU ALARM (J18) 
This 3-contact connector provides the interface for the CPU alarm.  See Figure 49 for an 
orientation view showing contact locations. 
 
The 3500Pro operating software determines when an alarm condition is declared.  During an 
alarm condition, an optically isolated, closed circuit exists between contacts 3 and 1 for 
Controller A (top), and contacts 2 and 1 for Controller B (bottom).  The customer supplied 
external alarm circuit is connected with a cable constructed as shown Figure 50. 

Contact locations when viewed
from rear of chassis.

1
2
3

+
-
S

 
Figure 49: 3500Pro-D J18 (CPU ALARM) Connector 

 

81-9029-0811-0 To:
3500Plus-D J18

+
-
S

Alarm (-)

Controller A (Top) Alarm (+)

Customer
Supplied

Connector

Controller B (Bottom) Alarm (+)
1
2
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Figure 50: 3500Pro-D CPU Alarm Cable 
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4.2.7 PRC (J11) 
This 5-contact connector is a loop-through connector used to provide an RS-422 serial 
communication interface using the PESA PRC Protocol (Document No. 81-9062-0316-0).  It is 
wired in parallel with J9 (COM 3/PRC).  See Figure 51 for an orientation view showing contact 
locations. 

J11 may be connected to other PESA PRC type equipment with a cable assembly (Part Number 
81-9028-0395-0) constructed as shown in Figure 52.  If this cable is to be constructed in the 
field, consult Drawing No. WI50-0250 for assembly details. 

5 4 3 2 1  
Figure 51: 3500Pro-D J11 (PRC) Connector 

 

System Controller RX- (Low)
System Controller RX+ (High)

Chassis Ground
System Controller TX- (Low)

System Controller TX+ (High)

81-9029-0813-0 To:
3500Plus-D J11

1
2

4
5

3

System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

81-9029-0813-0 To:
PRC Type Device

Chassis Ground3

1

4
5

2

 
Figure 52: 3500Pro-D RS-422 System Expansion Cable 
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4.2.8 SYSTEM V CONTROL (J20) 
This DB37-Male connector provides the System 5 control interface and uses the RM5 Protocol 
(Document No. 81-9062-0155-3).  See Figure 53 for an orientation view showing contact 
locations. 

J20 is connected to a Lynx or RM5 type routing switcher with cable assembly Part No. 
81-9065-1189-2.  If necessary, a cable up to 8 feet in length may be fabricated in the field as 
shown in Figure 54.  If more than one System 5 Routing Switcher will be connected to the 
System Controller, consult Drawing No. WI50-0262 for bifurcated cable construction 
information. 

Contact locations when viewed
from rear of chassis.
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Figure 53: 3500Pro-D J20 (SYSTEM V CONTROL) Connector 
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Figure 54: 3500Pro-D RM5 Control Cable 

4.2.9 POLLING 1-4 (J12, J13, J14, J15) 
These 3-contact connectors are wired in parallel and provide RS-485 serial communication 
interfaces that use the PESA RCP Protocol (Document No. 81-9062-0300-0).  See Figure 55 for 
an orientation view showing contact locations. 

J12, J13, J14, and J15 are connected to PESA Remote Control Panels with daisy-chained cables 
constructed with 3-contact connectors (Part No. 81-9029-0780-0) and shielded, twisted-pair 
audio cable (Part No. 81-9028-0043-2, Belden 8451, or equivalent) as shown in Figure 56.  The 
connector body has an integral strain relief, which requires the use of a nylon cable tie that is 
included with the connector.  If this cable tie is not available, Part No. 81-9021-0028-8 may be 
used. 
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When connecting RS-485 cables between the dual controller and the actual 
panels, the ordering of the pins is different. Look closely at the diagrams 
below. 

Contact locations when viewed
from rear of chassis.
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-
+
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2
1

 
Figure 55: 3500Pro-D J12, J13, J14, J15 (POLLING 1-4 ) Connectors 
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Figure 56: 3500Pro-D RS-485 Serial Cable 

4.3 PS130 POWER SUPPLY LINE CORDS 

 

Always use a grounded AC receptacle to avoid a potentially lethal shock 
hazard in the event of an equipment power line fault. 

 

 

This equipment will not meet FCC EMI limits unless both AC line cords are 
plugged into properly grounded AC receptacles. 

 
Each PS130 Power Supply requires a line cord (Part No. 81-9028-0403-0) to connect it to the AC 
mains. 
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4.4 PC BOARD SWITCH AND JUMPER SETTINGS 

4.4.1 S1 - Operational Mode/Config Bypass/COM 1 Rate 
S1 is a four-position, slide-style, dipswitch consisting of four, single-pole, single-throw (SPST) 
switches numbered 1 through 4.  Position 1 is used to set the operational mode, position 2 is 
used to enable/disable configuration bypass, and position 3 is used to select the serial 
communication rate.  Position 4 is reserved for future use.  See Table 5 on the next page for 
switch settings. 

S1

ON ¯

 

Figure 57: 3500Pro S1 (Operational Mode/Config Bypass/Comm Rate) 
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4.4.2 3500Pro Switch Operational Descriptions 

Table 5: 3500Pro Switch S1 

3500Pro S1 
Operational Mode/ 

Config Bypass/Comm Rate 

Switch 
S1-1 

Switch 
S1-2 

Switch 
S1-3 

Switch 
S1-4 

Software Upgrade Mode ON    

Normal Operation Mode OFF    

Configuration Bypass Enabled  ON   

Configuration Bypass Disabled  OFF   

COM 1 Rate: 38400 Baud   ON  

COM 1 Rate: 9600 Baud   OFF  

Reserved – Set S1-4 to OFF    OFF 

 

4.4.2.1 S1-1 Operational Mode 
This switch is used to place the 3500Pro into software upgrade mode for use with Load3500, 
the software installation utility.  For more information on the use of Load3500, consult the 
technical bulletin that came with your software upgrade. 

For normal operation, this switch should be in the OFF position. 

4.4.2.2 S1-2 Configuration Bypass 
For normal operation, this switch should be in the OFF position. For information on using the 
configuration bypass feature, see “Configuration Bypass” on page 50. 

4.4.2.3 S1-3 COM 1 Rate 
This switch is used to select the communications rate used by COM 1 on the 3500Pro.  The 
communication rate for COM 2 is determined by settings made in the 3500Pro software. 

4.4.2.4 S1-4 Reserved 
S1-4 is reserved for future use. 
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4.5 SUBASSEMBLY INSTALLATION 

4.5.1 Model 3500Pro-S 
The 3500Pro-S consists of an external chassis and a 3500Pro System Controller board.  There is 
no internal power supply. 

The 3500Pro System Controller board is installed in the chassis as follows: 

1. Align the board support tray with the card guides in the chassis. 

2. Carefully, insert the board into the chassis until the connectors on the board make contact 
with the connectors on the backplane.  If possible, inspect the mating connectors to 
ensure proper alignment. 

3. Firmly, push the board into the chassis until the board connectors are fully mated with the 
backplane connectors.  If the contact insertion force seems excessive, gently push up on 
the bottom of the board with one hand, while pushing on the front of the board with the 
other. 

4.5.2 Model 3500Pro-D, Model 3500Pro-SE, and Model 3500Pro-DE 
The 3500Pro-D consists of an external chassis and two 3500Pro System Controller boards and 
two PS130 Power Supplies.  It may also be ordered as the 3500Pro-SE, which has only one 
3500Pro System Controller board and one PS130 Power Supply installed in the same chassis.  
The 3500Pro-DE is the expansion kit required to convert a 3500Pro-SE to a 3500Pro-D. 

4.5.3 3500Pro System Controller Board Installation 
The 3500Pro System Controller boards are installed in the chassis as follows: 

1. Align the support tray of the first board with the card guides in the chassis. 

2. Carefully, insert the board into the chassis until the connectors on the board make contact 
with the connectors on the backplane.  If possible, inspect the mating connectors to 
ensure proper alignment. 

3. Firmly, push the board into the chassis until the board connectors are fully mated with the 
backplane connectors. 

4. Repeat the above steps for the second board. 
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4.5.4 PS130 Power Supply Installation 

 

A fully configured 3500Pro-D contains two PS130 Power Supplies connected 
in parallel.  Either power supply is capable of powering both system 
controller boards, with the second power supply serving as a backup for the 
first. One power supply may be removed and replaced while the other is 
connected to the power source, and the 3500Pro-D is operational. 

 
The PS130 Power Supplies are installed in the chassis as follows: 

1. Align the shield plate of the first power supply with the card guides in the chassis. 

2. Carefully, insert the power supply into the chassis until the connectors on the power 
supply make contact with the connectors on the backplane. If possible, inspect the mating 
connectors to ensure proper alignment. 

3. Firmly, push the power supply into the chassis until the power supply connectors are 
fully mated with the backplane connectors, and the power supply latch engages the 
corresponding slot in the chassis. 

4. Repeat the above steps for the second power supply. 
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Chapter 5 - Operating the System  
Controller Hardware 

5.1 GENERAL 
This equipment is to be controlled by the 3500Pro Control System software.  For detailed 
operational information, consult Section III. 

Figures 58 and 59 show typical views of the 3500Pro System Controller board.  The 
configuration shown is that used in Models 3500Pro, 3500Pro-D, 3500Pro-SE, and 3500Pro-DE. 
Other models use a different support tray; but are operated in the same way. 

 
Figure 58: 3500Pro System Controller Board Assembly Top View 

ACTIVEON

ACTIVE
+BATTERY+5VGND

RUN
 MODE BATTERY

OFF

RESET
STANDBY

 
Figure 59: 3500Pro System Controller Board Assembly Front View 
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5.2 FRONT PANEL SWITCHES 

5.2.1 Reset (S2) 
This SPDT momentary pushbutton switch is used to manually reset the 3500Pro System 
Controller in the event of system failure or lockup (similar to a warm boot on a PC).  To reset 
the controller, press and hold this switch for about three seconds. 

5.2.2 Mode (S4) 
This SPDT toggle switch is used in a dual controller system to designate, which controller is 
the primary controller, and which is the backup controller.  Set the Mode switch to ACTIVE on 
the primary controller, and to STANDBY on the backup controller. 

In a single controller system, this switch has no effect. 

5.3 FRONT PANEL LEDS 
See “LEDs” on page 51. 
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Chapter 6 – Maintenance and Repair  
6.1 PERIODIC MAINTENANCE 

There are no periodic maintenance requirements for this equipment. 

6.2 CONFIGURATION BYPASS 
If the configuration being used by the 3500Pro System Controller becomes corrupt, it may be 
bypassed to allow the loading of another configuration as follows: 

1. Remove power from the 3500Pro. 

2. Remove the 3500Pro from the chassis to allow access to switch S1 (see Figure 57 on page 
44).  Set switch S1-2 to the ON position in accordance with Table 5 on page 45. 

3. Reinstall the 3500Pro and apply power. 

4. Load the new configuration. This will overwrite the corrupted configuration. 

5. Remove power from the 3500Pro. 

6. Remove the 3500Pro from the chassis and return switch S1-2 to the OFF position. 

7. Reinstall the 3500Pro and apply power. 

 
Figure 60: 3500Pro System Controller Board Assembly Front View 

6.3 FRONT PANEL TEST POINTS 

6.3.1 3500Pro System Controller Board 
The 3500Pro System Controller board has three test points accessible from the front panel, 
GND, +5V, and +BATTERY, as shown in Figure 60. 

6.3.2 GND (TP17) 
This test point provides a convenient ground when measuring voltages at the other test points. 

6.3.3 +5V (TP18) 
The voltage measured between this test point and GND (TP1) is the output of the voltage 
regulation circuit and should be 5VDC, ±0.1VDC. 
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6.3.4 +BATTERY (TP19) 
The voltage measured between this test point and GND (TP1) is the output voltage of the 
backup memory power source and should be >2VDC when power has been removed 
from the board. This voltage is stored in a “super-cap” and has limited capability to retain 
memory for more than 48 hours.  

6.4 LEDS 
In the rare event this equipment fails to operate correctly, check the appropriate LEDs listed 
below for information concerning operational status. 

6.4.1 3500Pro System Controller Board 
The 3500Pro System Controller board has two front panel LEDs, RUN and ACTIVE, as shown 
in Figure 60 on the previous page. 

 

LED Color Panel 
Legend 

Normal 
State 

Troubleshooting Info 

LED1 RED N/A OFF Controller board is in reset state or is in program 
download mode. 

LED2 GRN RUN ON Indicates that input voltage to this board is within 
design parameters. 
If LED is OFF: 
1.  Remove and reinstall board to verify backplane  

 connector is properly seated. 
2.  Check power supplies for proper operation. 
3.  Contact PESA Customer Service. 

LED3 YEL ACTIVE ON Indicates that the board is currently in active control 
of a routing switcher system. 
In a dual controller system, the primary controller 
ACTIVE LED will be ON and the backup controller 
ACTIVE LED will be OFF. 
If the LED is OFF: 
1.  Remove and reinstall board to verify backplane 

connector is properly seated. 
2.  Ensure the board has been configured to be 

active.  
3.  Contact PESA Customer Service. 
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6.4.2 PS130 Power Supply 
LED Color Panel Legend Normal 

State 
Troubleshooting Info 

D27 GRN n/a ON Indicates that output voltage is within 
design parameters. 
 
If LED is OFF: 
1. Check input power connections. 
2. Check internal fuse (3.15A 

250VAC) 
3. Replace the power supply. 
4. Contact PESA Customer Service. 

 

6.5 PESA CUSTOMER SERVICE 
If the troubleshooting information above has not solved your problem, contact the PESA 
Customer Service Department. Skilled technicians are available to assist you 24 hours per day, 
seven days per week. 

Detailed contact information for the Customer Service Department is located inside the front 
cover of this document. 

6.6 REPAIR 
Before attempting to repair this equipment, please consult your warranty documents and/or the 
PESA Customer Service Department. Unauthorized repairs may void your warranty. 

 

The PS130 Power Supply assemblies in this equipment are not field/user 
serviceable. These offline switching power supplies contain internal voltages 
that are not isolated from the AC power source.  They should only be 
serviced by qualified service personnel using appropriate equipment.  
Because of this, it is strongly suggested that power supplies be returned to 
the PESA Customer Service Department for service. 

 

 

Many of the PC boards in this equipment contain large numbers of SMT 
(Surface Mount Technology) components.  Special tools are required to 
replace these components without causing damage to adjacent areas.  It is 
strongly recommended that PESA Customer Service be consulted prior to 
attempting to repair any of the PC boards in this equipment 
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6.6.1 Replacement Parts 
Only parts of the highest quality have been used in the design and manufacture of this 
equipment.  If the inherent stability and reliability are to be maintained, replacement parts must 
be of the same high quality.  For this reason, we suggest that you consult our Customer Service 
Department before installing any parts not purchased from PESA. 

6.6.2 Factory Service 
Before returning any equipment to our factory for service or repair, please contact our 
Customer Service Department for an RMA number. 

Detailed contact information for the Customer Service Department is located inside the front 
cover of this document. 
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Section III:  Software Reference Guide 
 
 

This section describes the 3500Pro software and how to use the software.  The following modules are 
described: 

• 3500Pro Configuration Editor: Defines the environment under which the control system operates.   

• 3500 Pro Status: Provides a way to monitor the status of the system as well as providing a 
selection of diagnostic tools.. 

• 3500 Pro User Manager: Sets up the PC communications and allows you to create and edit users 
who can access the 3500Pro software. 

• Runtime Database Initialization: Provides a fresh copy of the runtime databases used for online 
monitoring of the router.   

 

For further information, refer to the descriptions in Chapter 7 on the next 
page. 
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Chapter 7 – 3500Pro Configuration Editor 
This section describes in detail each command available in the software, and how the command is 
integrated into the overall workflow.  This section begins with a general overview of a typical 
workflow you might use when just getting started with the 3500Pro software. 

The 3500Pro software is designed for users who require more control levels, components, 
sources, destinations, and tielines.  The 3500Pro expands upon its proven capabilities to bring you 
the industry's easiest and most comprehensive control solution.  The graphic-oriented, point-and-
click interface permits error-free, offline/online configuration and editing.  

 

This section describes both the 3500Pro and the 3500ProLE.  The 
3500ProLE has a smaller feature set and is designed for customers with 
smaller systems. 

 

There are seven modules in the software.  To access each module, select Start > Programs > 
PESA 3500Pro Vx.x (where Vx.x is the version) and then, select the module you want to open. 

• 3500Pro Configuration Editor: Defines the environment under which the control system 
operates.   

• 3500 Pro Help:  Provides user-friendly help tools. 

• 3500 Pro Status:  Provides a way to monitor the status of the system(s) and provides 
troubleshooting/diagnostic tools. 

• 3500 Pro User Manager:  Sets up the PC communications and allows you to create and 
edit users who can access the 3500Pro software. 

• 3500Pro Db Admin:  Database administration tool that provides useful troubleshooting 
information, version of MSDE, Version of databases, allows databases to be closed when 
inadvertently left open, and allows runtime database initialization to be performed. 

• 3500Pro Db-to-Textfile:  A utility that is used to convert earlier version database (*.db) 
files to a text (*.txt) file.  Text file(s) may be imported into the current version’s database. 

• Runtime Database Initialization:  Provides a fresh copy of the runtime databases used for 
online monitoring of the router.   
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7.1 HOW TO USE THE 3500PRO 

7.1.1 Setup Overview 
This section describes how to use the 3500Pro to set up configuration files to interface with 
3500Pro Controllers.  When you are starting your 3500Pro setup, the following represent the 
main workflows that you will need to follow: 

• Setting up your computer  

• Initializing the Databases  

• Creating 3500Pro Users  

• Creating a New Configuration  

OR 

• Importing an Existing Configuration  

• Downloading the configuration to the controller  

Each of these sections provides general information for your workflow.  The following sections 
provide in-depth information about the different steps in the workflow. 

7.1.2 Time Saving Tools 
The 3500Pro provides many new, timesaving options that make it much faster for you to enter 
repetitive information into your configuration. 

7.1.2.1 Right-click mouse commands 
For many fields that require you to enter repetitive information, such as Inputs, Outputs, etc., 
there are additional commands available if you click the right mouse button.  These 
commands vary depending on the window you are working with: 

 
 

 

 

 

 

 

 

 

 

Figure 61: Right-click mouse commands 
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7.1.2.2 Autonumber 
Automatically numbers selected fields, starting with the number at the top of the selected 
column.  For example, if you select a range of fields with a “1” in the top field, then select 
this command and they will automatically number (see Figure 62): 

 

 

 

 

 

 

 

Figure 62: Autonumber 

7.1.2.3 Cut, Copy, Paste 
This activates the Cut, Copy, and Paste commands.  

7.1.2.4 Fill-Up 
This fills in fields above a selected field with the same information.  First, select the field 
with the number you want to duplicate and then, select the fields above it.  Right-click and 
select Fill-Up to fill in the fields with the selected information (see Figure 63). 

 

 

 

 

 

 

Figure 63: Fill-Up 
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7.1.2.5 Fill-Down 
This fills in the fields below a selected field with the selected number.  First, select the field 
with the number you want to duplicate and then, select the fields below it.  Right-click and 
select Fill-Down to fill in the fields with the selected number (see Figure 64). 

 

 

 

 

 

 

Figure 64: Fill-Down 

7.1.2.6 Fill-Left 
This fills in the fields to the left of a selected field with the selected number(s).  First, select 
the fields with the numbers you want to duplicate and then, select the fields to the left.  Right-
click and select Fill-Left to fill in the fields with the selected numbers.  You can select either 
one field or several fields with this option (see Figure 65).  

 

 

 

 

 

 

 

Figure 65: Fill-Left 
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7.1.2.7 Fill-Right 
This fills in the fields to the right of a selected field with the selected number(s).  First, select 
the fields with the numbers you want to duplicate and then, select the fields to the right.  
Right-click and select Fill-Right to fill in the fields with the selected numbers.  You can select 
either one field or several fields with this option (see Figure 66).  

 

 

 

 

 

 

Figure 66: Fill-Right 

7.1.2.8 Delete Rows 
This deletes the selected rows.  You only have to select one item in a row to delete it. 

 

Make sure you really want to delete the row before selecting this command. 
You cannot "Undo" this action. 

 

7.1.2.9 Clear Selected 
This removes information from the selected fields (does not delete the row).  

7.1.2.10 Clear All 
This removes information from the entire window.  
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7.2 GETTING STARTED 
The first thing you need to do with the 3500Pro software is to define the serial port connection 
and the baud rate. 

1.  Connect the computer that has the 3500Pro software program installed to the COM1 
Connector on the 3500Pro Controller using a 9-pin NULL modem RS232 cable. 

2. Select Start > Programs > 3500Pro > 3500Pro User Manager.  The 3500Pro 
Connection/User Manager window displays (see Figure 67). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 67: Connection Tab 

3. In the Connection Parameters section, make sure there is a check mark next to the Serial 
Port Connection option.  

4. In the COM Port pull-down window, select the COM port you are using to connect to the 
3500Pro Controller.  

5. In the Baud Rate field, select the baud rate you want to use.  The baud rate is defined by a 
dipswitch setting on the Controller board.  Refer to the 3500Pro Controller documentation for 
details. 

6. Select Commit to save your changes. 
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7.3 INITIALIZING THE DATABASE 
After setting up your computer, initialize the configuration and runtime databases.  To 
accomplish this, select Start > Programs > 3500Pro > Runtime Database Initialization.  This 
will purge any old runtime databases from your system and makes a new copy of the master 
database. 

7.4 CREATING USERS 
After your computer is properly configured, you can create users for the 3500Pro software.  

 

User accounts are optional. If used, at least one user account must be 
assigned all privileges.  If no user accounts are configured, all users have all 
privileges. 

 

1. If the 3500Pro Connection/User Manager window is not open, select Start > Programs > 
3500Pro > 3500Pro User Manager. The 3500Pro Connection/User Manager window 
displays. 

2. Select the Users tab (see Figure 68).   

 

Figure 68: Users Tab 
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7.4.1 Create a User With Access to Everything 
1. First, you need to create a user who has access to everything in the system.  Select the 

Add>> button to start. 

2. In the User Name field, type in a name for the user.   

3. Select the Set Password button to define a password for the user.  

4. Type in the password you want to use in the New Password field.  Re-enter the exact 
same password in the Confirm New Password field.  

 

You must enter the exact same password in both fields! 

 

5. Select OK to accept the new password.  The password window will close, and you will 
return to the User Manager window. 

6. Now select the Set All button and check marks will display next to each field.  This 
means that the user will have access to everything in the 3500Pro software.  

7. Select Commit and the user will be added to the system and will display in the Available 
Users box on the left side of the window. 

7.4.2 Create the Rest of the Users 
1. Now, you can create additional users with access to specific sections of the software. 

Select the Add>> button. 

2. Enter a User Name. 

3. Select the Set Password button and enter a password.  Select OK to accept the 
password and close the password window. 

4. Now, select the specific sections of the software you want the user to be able to access.  
When you are finished, select Commit and the user will be added to the system and will 
display in the Available Users section. 

5. Repeat this process for as many users as necessary. 
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7.5 CREATING A NEW CONFIGURATION 
If you do not have an existing configuration file, you need to create one.  You will use the 
Configuration Editor to create a configuration file. 

7.5.1 Create a New Configuration File 
1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor.  The 

Configuration Editor window is displayed. 

2. Select File > New Configuration Database to create a new database on your computer. 
Select the directory location for the file, enter a name and then, select OK.  A new 
configuration file will be created on your computer.  The name of the file will display at 
the top of the window. 

 

There is a sample configuration test file provided on the 3500Pro software 
installation compact disk (CD).  You may import this file into a 
configuration database to become familiar with some of the configuration 
options.  To import the file, perform the following steps: 

1. Select File>Transfer Configuration… 

2. When the Transfer window appears, select the Import 
Configuration From ASCII File radio button and then, click on the 
Execute function button. 

3. When the File Open window appears, navigate to the drive 
containing the 3500Pro software installation CD and then, click on 
the Cougar Combo Numeric.txt file to highlight it. 

4. Click the Open button.  The configuration text file will be imported 
into the database. 

 

7.5.2 Setting Up The Configuration File 
Each configuration file will be different depending on the specific configuration you are working 
with.  However, the following are some basic steps that are common to each configuration file.  

1. Select Configuration > System Configuration > Level/Comp to set up Levels and 
Components. 

2. Select Configuration > System Configuration > CPU Link/Port to set up serial 
communications link to the controller.   

3. Select Configuration > Matrix Configuration to define sources and destinations that 
match the equipment connected to the router. 

4. Select Configuration > Panels to define the settings for different RCP remote control 
panels in your system. 
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7.5.3 Optional Features Setup 
The remainder configuration commands are optional depending on how you want to set up your 
system.  If you choose, you can define the following options: 

1. Select Configuration > Salvo to define salvos. 

2. Select Configuration > Categories to define categories. 

3. Select Configuration > Tielines to define tielines. 

4. Select Configuration > Reentry to define reentries. 

7.6 IMPORTING AN EXISTING CONFIGURATION 
If you have an existing configuration file from an older version of 3500, you can import it into 
the software.  

7.6.1 Importing an ASCII File 
Make sure you have the configuration file on your computer and stored in ASCII format (.txt or 
.dat extension).  

1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor.  The 
Configuration Editor window displays. 

2. Select File > Transfer Configuration (see Figure 69).  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 69: Import a Configuration from an ASCII File 
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3. Select the Import Configuration From ASCII file button, then select Execute. 

4. The Import window will display. Change to the directory where the configuration file 
you want to import is located.  Select the file and select the Open button.  

5. The message Importing Text File displays.  When the process is complete, the message 
“Import is Complete” displays.  You can now work with the configuration file. 

7.6.2 Uploading The Current Configuration 
If you have a system already set up you can just load the existing configuration file from the 
3500 Controller to the 3500Pro software.  

1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor.  The 
Configuration Editor window displays. 

2. Select File > Upload Configuration From Controller.  If a configuration file is 
currently open, the following message displays (see Figure 70): 

 

Figure 70: Confirm Configuration File Upload 

3. The current configuration will be loaded to the 3500Pro software, and you can then save 
the configuration to your computer and start working with it. 

7.7 DOWNLOADING THE CONFIGURATION TO THE CONTROLLER 
After you are done creating your configuration file, you need to download it to the controller.  

1. From the Configuration Editor window, select File > Transfer Configuration. 

2. Select the Download Configuration TO Controller option, then select Execute.  The 
following prompt displays (see Figure 71): 

 

 

 

 

 

Figure 71: Download Configuration Prompt 
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3. If you are sure you want to download the configuration file, select OK. 

4. The following prompts display in the Status Bar at the bottom of the window: 

• Exporting the configuration to a file.   

• Downloading to the Controller 

• Committing the Configuration to Flash 

5. The configuration file will be sent to the controller and you can then use additional 3500Pro 
tools to monitor the controller and perform diagnostics. 

 

 

The controller is non-operational while it is committing the configuration to 
Flash.   

 
You have now established a basic connection with the system controller.  Continue to modify and 
customize your configuration file and upload the configuration file to the controller.  The 
following chapters provide in-depth information about each command available in the 
Configuration Editor. 

7.8 3500PRO CONFIGURATION EDITOR FILE MENU 
The File menu (see Figure 72) provides tools to open, save, close, upload, and download 
configuration files.  In addition, there are tools to import ASCII files and export to a database. 

 

Figure 72: Configuration Editor File Menu 
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7.8.1 Shortcuts 
There are several "shortcuts" available to quickly access commonly used commands.  The 
following shortcut keys and buttons are available: 

• Keys: 

To use the following shortcuts, press the Control (Ctrl) key and the additional letter at the 
same time. 

Ctrl+N:  File > New Configuration Database:   

Ctrl+O:  File > Open Configuration Database:  

Ctrl+X:  Edit > Cut:  

Ctrl+C:  Edit > Copy:  

Ctrl+V:  Edit > Paste:   

• Buttons: 

  Accesses the File > New Configuration Database command 

 

  Accesses the File > Open Configuration Database command 

 

  Accesses the File > Save Configuration Database command (if you have 
already save the configuration file) OR the Save Configuration Database As 
command if you have not saved the configuration file. 

 

  Accesses the Edit > Cut command 

 

  Accesses the Edit > Copy command 

 

  Accesses the Edit > Paste command 
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7.8.2 New Configuration Database   
The File > New Configuration Database command creates a new 3500Pro configuration file. 
Configuration files contain all of the information required to communicate with the 3500Pro 
Controller.   

• Creating a New Configuration Database 
When you select this command, the New Config Database window displays.  Select a 
location for the new configuration file, and enter a file name.  Select Open, and an empty 
configuration will be created.  The new configuration file is automatically saved to your 
hard drive to the directory location and file name you entered.  If a configuration file is 
currently open, you will be given the option to save or discard any changes that you have 
entered before making a new configuration file active. 

After you have entered all of the information describing your Routing Switcher into the 
new configuration file, you can use the File > Download Configuration TO Controller 
command to load the configuration file to the controller. 

7.8.3 Open Configuration Database   
The File > Open Configuration Database command        opens a previously saved 
configuration file list (see Figure 73).   

 

 

Before using this command, you must have a valid configuration file 
available on your computer or computer network.  If you need to access a 
configuration file stored on a controller but is not on your computer, use 
the File > Configuration Transfer > Upload Configuration FROM 
Controller command. 

 

 

Figure 73: New Configuration Database 
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7.8.4 Close Configuration Database 
The File > Close Configuration Database! command closes the active configuration file.   

Before using this command: 

• Close all of the open windows.  

• You will have the option to save the configuration file with either the File > Save 
Configuration or File > Save Configuration Database As commands before closing 
the file, otherwise you will lose your changes. 

7.8.5 Controller Status 
The File > Controller Status command verifies the communication to the controller.  The 
command displays a window with the name and version number of the controller software. 
Select OK to dismiss the window (see Figure 74). 

 

 

 

 

 

Figure 74: Controller Status Message 

If there is a problem with the connection to the controller, the following message will display 
(see Figure 75): 

 

 

 

 

 

Figure 75: Controller Status Error Message 

If you get this error, ensure that the physical connections to the controller are in place.  Refer to 
your 3500Pro Controller Manual for detailed information about hardware setup. 

• Before Using this Command 

Connect the computer that has the 3500Pro software program installed to the COM1 
Connector on the 3500Pro Controller using a 9-pin NULL Modem RS232 cable.  

*Text Varies with the 
controller that is in use.
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7.8.6 Clear Configuration Locks 
In the rare event that a power failure, hardware malfunction, or other occurrence prevents a 
configuration upload or download from terminating in a normal manner, the configuration lock 
may latch in place.  To manually clear a configuration lock, select File > Clear Configuration 
Locks. 

If the malfunction occurred while downloading a configuration to the controller (sometimes 
referred to as writer’s lock), the controller will also be reset.  You will be warned in this event. 

7.8.7 Reset Controller 
In the event that it is determined the controller hardware should be reset, this function provides 
a mechanism to reset the system without pressing the actual reset button (switch) located on the 
controller card.  You will be prompted to verify that you understand the impact of what is about 
to be performed. 

7.8.8 Validate Configuration 
The File > Validate Configuration command checks the currently open configuration file to 
make sure it does not contain any errors. Use this command before transferring the 
configuration file to the controller.  

You can also validate the configuration before you download or export the configuration with 
the “Validate” option in the Transfer Configuration window (see Figure 76). 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 76: Validate Window 
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7.8.9 Transfer Configuration 
The File > Transfer Configuration command provides a way to transfer a configuration file to 
the controller, upload a configuration file stored on the controller, and to import and export 
configuration files to and from ASCII files (see Figure 77). 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 77: Configuration Transfer Window 

7.8.9.1 Before Using This Command 
• If you are uploading a configuration file from the controller, close any configuration 

files you are currently working with. 

• If you are importing a configuration from an ASCII file, make sure the file you want to 
use is stored in a location you can access. 

7.8.9.2 Configuration Transfer Options: 
The following options are available in this window: 

1. Force Router Switches After Download:  After downloading a configuration file to 
the controller, automatically performs switches. 

2. Validate Configuration before Download/Export: Validates the configuration file 
before you download it to the controller to export it to a file. 

3. Prompt Before Taking the Controller Offline: Displays a message box informing 
you that the following procedure will take the controller offline. 
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4. Configuration Transfer Actions: For detailed information about each of these 
options, see the following sections. 

• Upload Configuration FROM Controller (Section 7.8.9) 

• Download Configuration TO Controller (Section 7.8.10) 

• Import ASCII File TO Database (Section 7.8.11) 

• Export Database TO ASCII File (Section 7.8.12) 

5. Execute: Performs the action you selected in this window. After you select Execute, 
messages will display in this window to let you know the progress of the selected 
action, and when the action is complete. 

7.8.10 Upload Configuration FROM Controller 
The File > Upload Configuration FROM Controller command uploads a configuration from 
the 3500Pro System Controller to the PC.  

7.8.10.1 Before Using This Command 
This command overwrites the configuration information in the 3500Pro Configuration Editor. 
To avoid data loss, be sure to save and/or close the configuration currently open in 3500Pro 
before overwriting it with the uploaded configuration. 

7.8.10.2 Uploading a Configuration from the Controller 
When you select this command, the following messages display in the Status Bar at the 
bottom of the 3500Pro window: 

• Pulling the configuration from the controller 

• Importing the configuration into the database 

• Configuration Upload is Complete 

 

If a status bar does not display at the bottom of the window, select View > 
Status Bar. 

 

After the process is complete, the configuration settings will be available in the 
Configuration Editor. 
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7.8.11 Download Configuration TO Controller 
The File > Download Configuration TO Controller command downloads a configuration file 
from your computer to the controller.  

7.8.11.1 Before Using This Command 

• Save the configuration file on the controller before downloading a new file. 

• Create or Open the configuration file you want to use with the controller. 

• Save the configuration file before downloading it.  

 

 

This command causes the controller and switchers to be temporarily 
unavailable until the download is complete. 

 

7.8.11.2 Downloading a Configuration to the Controller 
When you select this command, the following prompt displays (see Figure 78): 

 
 

 

 

 

 

Figure 78: Download Configuration Message 

If you are sure you want to download the new configuration, select OK.  The following 
prompts display in the Status Bar at the bottom of the window: 

• Exporting the configuration to a file   

• Downloading to the Controller 

• Committing the Configuration to Flash 

• Configuration Download is Complete 

The configuration file will be sent to the controller and you can then use additional 3500Pro 
tools to monitor the controller and perform diagnostics. 
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7.8.12 Import ASCII File To Database 
The File > Import ASCII File to Database option imports an ASCII configuration from the 
PC into 3500Pro.  If you have a configuration file from an older version of 3500, you can 
import the ASCII .txt file into this version of the software.  

A configuration may exist in two different formats: 

1. A DB configuration is stored as a .db style database.  This is the format that 3500Pro 
uses when storing a configuration on the PC. 

2. An ASCII configuration is stored as an ASCII text file (.txt).  3500Pro converts a 
configuration from an ASCII text file to a DB file when it is uploaded from a 3500Pro 
system controller or imported from an ASCII text file. 

7.8.12.1 Before Using This Command 
A configuration file must be open before you can import an ASCII file.  Open an existing 
configuration file or create a new configuration file.  

 

If you import the ASCII text file into an existing configuration file, the 
current configuration will be overwritten. 

 

7.8.12.2 Importing an ASCII File 
1. When you select this option, the Import window will be displayed.  

2. Use the Look in drop-down list to select the directory where the configuration file is 
stored. The available files will display in the middle part of the window.  

3. Select the file you want to import and then, select Open.  

4. The configuration settings will be imported into the software and you can review the 
information with the menus. 

7.8.13 Export Database To ASCII File 
The File > Export Database to ASCII File exports an ASCII configuration from 3500Pro to 
the PC.  

A configuration may exist in two different formats: 

1. A DB configuration is a configuration stored as a (.db) file extension.  This is the format 
that 3500Pro uses when storing a configuration on the PC. 

2. An ASCII configuration is a configuration stored as an ASCII text file.  3500Pro converts 
a configuration from DB to ASCII when it is downloaded to a 3500Pro System Controller 
or exported to an ASCII text file. 
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This option is useful if you need to transfer the database file to another computer, or easily look 
at the data in the database.  You can open the ASCII file in a simple text editor or a word 
processing program such as Microsoft Word to review the information.  If you open the file, 
just make sure you do not change the file extension (.txt). 

7.8.13.1 Before Using This Command 
• The configuration file you want to export must be open.  

• Save the configuration file before you export it. 

7.8.13.2 Exporting a Database File 
1. When you select this command, the Export window will be displayed.  

2. Use the Save in drop-down list to select the directory where you want to save the file.  

3. Then, type a name in the File name field.  Select Save and the file will be saved to 
your computer. 

7.8.14 Save Configuration Database   
The File > Save Configuration Database         command saves the configuration file to your 
hard drive (or network).   

If this is the first time you have saved the configuration file, the Save Config Database As 
window will be displayed.  You can then enter a name for the file and select a location to save 
the file. 

• Before using this command, a configuration file must be open. 
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7.8.15 Save Configuration Database As   
The File > Save Configuration Database As          command allows you to enter a name and 
directory location for the configuration file, and then saves the file to the specified location (see 
Figure 79).   

 

Figure 79: Save Configuration Database As 

 

 

If this is the first time you have saved the configuration file, the Save 
Config Database As window will automatically display. 

 
 

 

Use this command to save an existing configuration file to another file 
name or directory location. 

 

• Before using this command, a configuration file must be open. 

7.8.16 Exit 
The File > Exit command closes the 3500Pro Configuration Editor 

• Before using this command, save the configuration file you are working with. 
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7.9 CONFIGURATION EDITOR EDIT MENU 
The Edit commands allow you to cut, copy, and paste information in the 3500Pro workspace. The 
following commands are available (see Figure 80): 

 

Figure 80: Edit Menu 

7.9.1 Cut   
The Edit > Cut         command removes information from a selected field or fields (see Figure 
81).  To use this option, you must highlight an area that contains information you want to "cut".  
When the area is highlighted, as shown below, select this command and the information will be 
removed and placed on the "clipboard" (temporary storage location on your computer).  

 

 

Figure 81: Highlighted Field 
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 TIP: If you need to remove the information from an entire column, highlight the entire 
column.  Select the first field you want to cut, then hold down the left mouse button 
and move the cursor so all of the fields you want to cut are highlighted.  Then, 
select the Cut command and all of the information will be removed (see Figure 82). 

 

 

Figure 82: Highlighted Column 
 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten. 

 

 

If you Cut information, you cannot "Undo" the action. Make sure you cut 
the correct information.  If you accidentally cut the wrong information, 
immediately use the Edit > Paste command to replace the cut information. 

 

 TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button.  A menu will display, and you can select Cut.  



 
 

3500PRO/LE – SECTION III  
81-9059-0549-0 Rev. D 

 

Proprietary Information of PESA SWITCHING SYSTEMS, INC. 79 

 

7.9.2 Copy   
The Edit > Copy         command copies highlighted information to the clipboard (a temporary 
storage location on your computer).  Then, you can Paste the information into another 
location.  This saves time when you have to type information in several different places. 

To copy information, select a field.  When it highlights, as shown in Figure 83, select Copy and 
the information will be pasted to your clipboard.   

 

 

 

 

 

 

 

 

 

Figure 83: Highlighted Field 
 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten. 

 

 TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button.  A menu will display, and you can select Copy.  

7.9.3 Paste   
The Edit > Paste      command places information stored on the clipboard in the selected 
location. Use this command to place information you either Cut or Copied to a different 
location in the 3500Pro interface. 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten.  If you want to "Paste" information, 
make sure you do so before overwriting the information. 

 

 TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button.  A menu will display, and you can select Paste.  
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7.9.4 Panel Template 
The Edit > Panel Template command allows you to set up defaults for panel information (see 
Figure 84). These settings will be set as a default each time you create a new panel (with the 
Configuration > Panels option). 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 84: Panel Template Window 

7.9.4.1 Lock Priority 
The lock priority is used with the requester code to determine if a lock or protect can be 
removed.  When a lock or protect has been assigned by a panel or port, it can only be 
removed by another panel or port with a higher lock priority, or with the same lock priority 
and same requester code.  The lower the lock priority number, the higher the priority. 

Panel lock priorities not explicitly defined automatically default to "0", which gives absolute 
authority to clear any lock or protect on the system.  The acceptable range of lock priorities is 
shown in the General Specifications Table. 

7.9.4.2 Requestor Code 
The requester code is used with the lock priority to determine if a lock or protect can be 
removed.  When a lock or protect has been assigned by a panel (or serial communications 
port), it can only be removed by another panel (or port) with a higher lock priority or with the 
same lock priority and same requester code. 

Requestor codes are also used with protects.  When a destination is placed into protect, only 
those panels/users with the same requestor code can switch the destination. 
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Requester codes that are not explicitly defined, automatically default to the panel address.  
You can also select the "Follow Panel Address" box to ensure that the Requestor Code is 
always identical to the Address. 

7.9.4.3 Status Method 
When a panel is in all levels mode (ALL LEVS), the status shown will be the source on the 
Status Level assigned to that panel.  If the destination is not defined on the Status Level, 
Status Method is used to control the resulting display: 

• If DEF (Default Method) is selected, NO XXXXX will be displayed where XXXXX is 
the Status Level assigned to the panel. 

• If GRP (Group Method) is selected, the controller will examine every level 
sequentially, starting with the level designated as Level Order 1.  The source switched 
on the first level found where the destination is defined, will be displayed as the 
destination status. 

7.9.4.4 Status Level 
One function of the LCD display on a panel is to show which source is currently switched to 
a selected destination.  This is known as destination status.  Although more than one source 
can be switched to a single destination (limited to one source per level), the status display can 
only show one source at a time.  When the panel is in all levels mode (ALL LEVS), Status 
Level is used to designate a default level to be used when displaying status.  Only the source 
on this default level will be displayed.  Pushbutton only panels also use the status level.  It is 
used to determine which tally LED to light on a panel in a split/breakaway condition. 

 

 

For the following items (7.9.4.5 through 7.9.4.8), if you need to find out the 
names of current lists, select Configuration > Panel.  Use the various List 
pull-down menus on the far right side of the Panel Specific Data tab to 
review the available lists. 

7.9.4.5 Level Include List 
The Levels Include List is a named list of all levels the panel (or remote client) is authorized 
to control.  Enter the name of the list that you want to assign to new panels, or select the ALL 
Level Include List to assign all of the available levels. 

7.9.4.6 Source Include List 
A source include list is a named list of the sources a specific control panel (or remote client) 
is authorized to control.  A source include list may be shared by multiple panels.  Enter the 
name of the list that you want to assign to new panels, or select the ALL Source Include List 
to assign all of the available sources. 
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7.9.4.7 Destination Include List 
A destination include list is a named list of the destinations a specific control panel (or remote 
client) is authorized to control.  A destination include list may be shared by multiple panels.  
Enter the name of the list that you want to assign to new panels, or select the ALL 
Destination Include List to assign all of the available destinations. 

7.9.4.8 Salvo Include List 
A salvo include list is a named list of the salvos a specific control panel (or remote client) is 
authorized to control.  A salvo include list may be shared by multiple panels.  Enter the name 
of the list that you want to assign to new panels, or select the ALL Salvo Include List to 
assign all of the available salvo groups. 

7.9.4.9 Key List Create Mode 
The Key List Create Mode allows you to reset the default method of handling the entry of 
certain objects into a key list.  The objects that this mode applies to are entered in a key list 
and the database is queried to see if they exist.  If they do not exist, this setting determines the 
action taken.  The following mode selections appear: 

• Prompt Before Creating:  This mode will ask you if you want to create the object. 

• Automatically Create:  This mode will automatically create the object. 

• Do Not Create:  This mode will not create the object and you will have to manually 
create the objects.   

7.9.5 Download Mode 
The Download Mode always defaults to “Compressed Block Download Method”.  This should 
never be changed unless you are unable to download a configuration to the controller.  The 
modes are used in sequence from the fastest method to the slowest method.  The software will 
automatically switch down to the next slower method if problems are encountered.  The setting 
of this mode determines which method the download will start with.   
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7.10 CONFIGURATION EDITOR VIEW MENU 
The View commands display or hide the toolbar and status bar.  The following commands are 
available (see Figure 85): 

 

Figure 85: View Menu 

7.10.1 Toolbar 
The View > Toolbar command hides or displays the bar with the shortcut icons.  Select this 
command to display or hide the toolbar. 

7.10.2 Status Bar 
The View > Status Bar command hides or displays the bar with the status information that 
displays at the bottom of the 3500Pro window. Select this command to display or hide the 
status bar. 

7.11 CONFIGURATION EDITOR CONFIGURATION MENU 
The Configuration commands define all of the settings in the configuration file that allow you to 
customize the configuration of your 3500Pro system controller.  Use these commands to set up 
the configuration file and then, download the configuration file to the controller.  The following 
commands are available (see Figure 86): 

 

 

Figure 86: Configuration Menu 

If the configuration menu is “grayed out”, this indicates that you do not have a configuration 
database open.  In the File Menu, create a New or Open an existing configuration database. 
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7.11.1 Level/Comp 
The Configuration > System Configuration > Level/Comp provides an interface to work 
with Levels and Components.  The following sections describe what levels and components are 
and how to work with them. 

7.11.1.1 Levels 
The Levels section of the window allows you to add, edit, and delete levels (see Figure 87).  

 

Figure 87: Level/Component Configuration Window 

A level is a group of related components that are switched together by 3500Pro.  Levels are 
the lowest element that the user can manipulate in the control system.  The maximum number 
of levels in a configuration is 16 (8 for the 3500ProLE).  The example shown in Figure 88 is 
a 2x2 RGB video level named VID, which is made up of three components named RED, 
GRN and BLU.   
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Figure 88: 2x2 RGB Video Level 

Column Descriptions 

• Level #:  Defines the number for the level. You cannot edit this field.  If you want to 
change the Level #, use the Reorder Levels button.  The number implies the order of 
levels for use on serial commands and panel operation.    

• Name: Specifies the name of the level. Level names are one to eight characters in 
length and are constructed using uppercase letters, numbers, and spaces. The first 
character must be a letter.  

• Inputs:  specifies the number of inputs associated with the level. The maximum number 
of inputs per level is 1024 (144 for the 3500ProLE). 

 TIME SAVING TIP: If the Input value is the same for several different levels (for 
example, 144), type "144" in the first Input field. Then, select the 
number you just entered, and highlight the rest of the fields below 
it that have the same value. Click the right-mouse button and select 
Fill Down.  All of the fields will populate with the same Input 
value.  

Example:  Enter the first Input (see Figure 89). 

 

 

 

 

 

 

Figure 89: Entering an Input 
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Select the first input and then, highlight the rest of the Input fields with the same value.  
Click the right mouse button and select Fill-Down (see Figure 90). 

 

 

 

 

 

 

 

 

 

Figure 90: Fill Down 

The highlighted fields are populated (see Figure 91).   

 

 

 

 

 

 

 

Figure 91: Populated Fields 

• Outputs: Specifies the number of Outputs associated with the level.  The maximum 
number of inputs per level is 1024 (144 for the 3500ProLE). 

 TIP: Use the same method described in the Inputs section to quickly enter Outputs.  Or, 
if the Outputs values are the same as the Inputs, highlight all of the Inputs and the 
corresponding cells in the output column, right-click your mouse and then, select 
Fill-Right. 

• Properties:  Determines if the level is "Chop Enabled".  Select the gray box to enable or 
disable "Chop".  When a red check mark displays, Chop is enabled. 
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Working with Levels 

• Adding a Level:  You can have a maximum of 16 levels (8 with the 3500ProLE).  To 
add a level, simply type new level information into a blank row. 

• Deleting a Level:  To delete a level, click on the information you want to remove and 
press the Delete key.  You can delete several entries at one time by highlighting all of 
the fields you want to delete, then pressing the Delete key.  When you are done deleting 
a level, select OK.  Be sure to Save the configuration file.  

• Reordering Levels:  To change the Level numbers, select the Reorder Levels button. 
The Change Level Order window will appear, and you can assign new level numbers 
to each available level. 

7.11.1.2 Change Level Order 
You can change the order of levels with the Reorder Levels button. (Configuration > 
System Configuration > Level/Comp > Reorder Levels).  This window displays all of the 
defined Level Names and the Level Order (see Figure 92).  

 

Figure 92: Change Level Order Window 

To change the level number, double-click in the field you want to change, and enter a new 
level number. 

 

Make sure the cursor is blinking inside the field before entering a new level 
number. 
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The number you enter in this field will be the position in this window.  For example, if you 
enter a "5" in the Level Order field, the Level Name will move to the fifth row in the window. 
If another level was already assigned "5", it will move down a row to the "6" row. 

7.11.1.3 Components 
The Components section of the window allows you to add, edit, and delete components.  A 
component is the most basic signal element that can be switched by a system controller. 
Components map level inputs/outputs to the actual physical matrix and are collected under a 
level to be controlled by users.  For example, in RGB video, "Red", "Green", and "Blue" are 
components; in stereo audio, "Left" and "Right" are components.  The example shown in 
Figure 93 is a 2x2 RGB video level named VID, which is made up of three components 
named RED, GRN and BLU.  

 

 

 

 

 

 

 

 

 

Figure 93: 2x2 RGB Video Level 

The maximum number of components in a configuration is 32 (16 for the 3500ProLE). 

Column Descriptions: 

• Name: defines the name of the component.  Component names are one to eight 
characters in length and are constructed using uppercase letters, numbers, and spaces.  
The first character must be a letter.  The example shown above is a 2x2 RGB video 
level named VID, which is made up of three components named RED, GRN and BLU.  
For the example, "RED" would be used for the first component, "GRN" for the second, 
and "BLU" for the third.   

• Level Name: specifies the name of the level associated with the component.  You must 
have already created the level you want to use (in the top half on this window) before 
you enter the value in this field. 
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• Input Offset: Acceptable values for input offsets are shown in the General 
Specifications Table.  For the example shown above, "0" and "0" would be used for the 
component "RED"; "2" and "2" would be used for the component "GRN"; and "4" and 
"4" would be used for the component "BLU". 

Physical Input = Level Input + Component Input Offset 

  

3500Pro allows components to overlap in matrix space.  Care should be 
taken when entering offsets to ensure that any resulting overlap of 
components is intentional. 

 

 TIP: If the Input value is the same for several different offsets (for example, 0), type "0" 
in the first Input Offset field. Then, select the number you just entered, and 
highlight the rest of the fields below it that have the same value. Click the right-
mouse button and select Fill-Down.  All of the fields will populate with the same 
Input Offset value.   

• Output Offset:  Acceptable values for input offsets are shown in the General 
Specifications Table.  For the example shown above, "0" and "0" would be used for the 
component "RED"; "2" and "2" would be used for the component "GRN"; and "4" and 
"4" would be used for the component "BLU". 

Physical Output = Level Output + Component Output Offset 

• Type: PRC, TGR (Tiger), XTN (External Manufacturer or Third Party), or RM5 
(System 5). Select the one you want from the pull-down menu. 

• Strobe:  Enter the Strobe assigned to the routing switcher that contains the component.  

Every routing switcher in a switching system is assigned a strobe. This is usually 
accomplished by setting a dipswitch on the back of the routing switcher. Strobes do not 
have to be unique and, in larger systems, each strobe might be associated with several 
routing switchers. 

In many switching systems, strobes are used to group levels of the same type together. 
For example, video may be on Strobe 1, audio on Strobe 2, etc. 

The following table shows the offset, strobe, and address ranges for the RM5 and PRC 
component types: 
 
COMPONENT TYPES RM5 (SYSTEM 5) PRC, XTN, TGR 

Offset Range 0-255 0-4094 

Strobe Range 1-5 1-63 
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RM5 components utilize the System 5 37 pin parallel interface.  PRC, TGR, and XTN 
matrices use the PRC RS-422 based interface.  (PRC, TGR, and XTN matrices are all 
controlled by the same set of commands.  The difference between the components is 
the boundary size used for background checking the matrix health.  PRC uses a 8x8 
boundary, TGR uses a 48x16 boundary, and the XTN uses a 64x64 boundary.)  

Working with Components 

• Adding a Component:  You can have a maximum of 32 components (16 for the 
3500ProLE).  To add a component, simply type new component information into a 
blank row and then, select the necessary options described above. 

• Deleting a Component: To delete a component, click on the information you want to 
remove and press the Delete key.  You can delete several entries at one time by 
highlighting all of the fields you want to delete, then pressing the Delete key.  When 
you are done deleting a level, select OK. Be sure to Save the configuration file.  

7.11.2 CPU Link/Port 
The Configuration > System Configuration > CPU Link/Port command allows you to 
configure the serial ports on the 3500Pro System Controller.  This window (see Figure 94) is 
divided into two sections.  Refer to the following sections for information about the items in 
each field of the window. 

 

Figure 94: CPU Link/Port Configuration Window 
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7.11.2.1 CPU Link Protocol Configuration:  

This section of the window allows you to define CPU Link Protocol Configurations.  
Then, you can assign a specific configuration to a port in the lower portion of the 
window. 

7.11.2.2 CPU Link Protocol Configuration 
The Configuration > System Configuration > CPU Link/Port > CPU Link Protocol 
Configuration section determines the format to be used when sending data through the serial 
ports on the 3500Pro System Controller.  Then, you can assign a specific configuration to a 
port in the lower portion of the window.  

• Link Name 
This defines the name of the protocol configuration that is being defined.  It is used 
when assigning a protocol variation to a serial port.  You will associate a defined 
configuration with a specific port in the lower portion of this window. 

• Link Type 

This is the protocol, which determines the format to be used when sending data through 
the serial ports on the 3500Pro System Controller.  Select one from the pull-down 
menu.  There are currently three protocols available for use.  

1. CPU Link Protocol 1 with Extensions (P1E) (81-9062-0407-0) 

2. Unsolicited Status Protocol (USP) (81-9062-0409-0) 

3. Truck Link Protocol (TRK) (81-9062-0410-0).  Truck link only works when 
configured for COM4.  

• Checksum 
A checksum determines how the validity of transmitted data will be confirmed.  The 
three available checksum types are: 

1. NONE:  No validity checking. 

2. PESA:  Data validity is checked using PESA's standard method.  (See Protocol 
documentation.)  

3. HEX ASCII:  Data validity is checked using a standard HEX-ASCII checksum. 
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• Terminator 
The terminator is the character(s) to be used to denote the end of a data packet or 
command string.  The three terminators available are: 

1. CR:  A carriage return. 

2. LF:  A line feed. 

3. CL:  A carriage return followed by a line feed. 

• Status Filter 
Status filtering allows the user to filter the data sent through the port using USP.  This 
is only available for Unsolicited Status Protocol (USP).  The nine filters available are: 

1. A - All Unsolicited Items 

2. C - Configuration Changes 

3. D - Dual Transition Changes (Dual 3500Pro Control Systems Only) 

4. E - Confidence Errors 

5. G - User Logon/Log Off 

6. L - Lock/Protect Changes 

7. P - Physical Switches 

8. S - Switch Change Requests 

9. U - User Account Changes 

They can be specified in any combination.  Enter the filter you want to use in the 
Status Filter field. 

7.11.2.3 Port Configuration 
The Configuration > System Configuration > CPU Link/Port > Port Configuration 
section of the window defines the actual configuration of the three available ports.  You can 
assign specific CPU Link Protocol Configurations defined in the top portion of this window 
with each port (in the Link Name field). 

• Before Using This Command 

You must have defined the CPU Link Protocol Configurations in the top portion of 
this window. 
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• Address 
This defines the port address.  You can configure the following ports: 

1. Port 1 - The default CPU link port, which is pre-configured to be used with 
3500Pro.  The only items that may be changed on this port are the Port Name 
and the Requester Code. 

2. Port 2 - Available for user configuration. 

3. Port 3 - Not available.  This port is the PRC Communications Port on the 
3500Pro System Controller and may not be used for external control. 

4. Port 4 - Available for user configuration. 

• Port Name 
Because a port is identified by its address, the assignment of a port name is optional.  If 
used, port names are one to eight characters in length and are constructed using 
uppercase letters, numbers, and spaces.  The first character must be a letter. 

• Requestor 
The requester code is used with the lock priority to determine if a lock or protect 
function can be removed.  When a lock or protect has been assigned by a port (or 
panel), it can only be removed by another port (or panel) with a higher lock priority or 
with the same lock priority and same requester code. 

Requester codes not explicitly defined automatically default to 1024, 1025, and 1027 
for Ports 1, 2, and 4 respectively. 

The acceptable range of requester codes is 1 - 65535. 

• Lock Priority 
The lock priority is used with the requester code to determine if a lock or protect 
function can be removed.  When a lock or protect has been assigned by a port or panel, 
it can only be removed by another port or panel with a higher lock priority, or with the 
same lock priority and same requester code. The lower the lock priority number, the 
higher the priority. 

Port lock priorities not explicitly defined automatically default to "0" which gives 
absolute authority to clear any lock or protect on the system.  The Lock Priority 
assigned to Port 1, which may not be changed, is "0". 

The acceptable range of lock priorities is 0-255 ("0" is Highest Priority). 

• Link Name 
This defines the CPU Link Protocol Configuration you want to associate with this port.  
Each configuration in the top portion of this window is identified by its Link Name.  
Enter the Link Name you want to use from the top portion of the window in this field to 
assign the correct configuration. 
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• Baud Rate 

Baud rate is the data transfer rate through the serial port measured in Baud (bits per 
second).  A baud rate of either 9600 or 38400 may be selected for Port 2 and Port 4.  
Port 1’s baud rate is specified by the dipswitch on the controller board and cannot be 
set via the configuration software.  The baud rate is either 9600 or 38400 baud.   

• Stop Bits 
In asynchronous communications, a stop bit is a bit that indicates that a byte of data has 
just been transmitted.  Every byte of data is preceded by a start bit and followed by a 
stop bit. 

Either 1 or 2 stop bits may be selected for Port 2 and Port 4.  The number of stop bits 
assigned to Port 1, which may not be changed, is 2. 

7.11.3 Configuration Info 
The Configuration > System Configuration > Configuration Info window shows 
information about the configuration currently open in 3500Pro (see Figure 95). 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

Figure 95: Configuration Information Window 
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7.11.3.1 Configuration Name 
This field allows you to name or rename the current configuration.  Type the desired name in 
the Configuration Name box.  Configuration names may have up to 32 alphanumeric 
characters.  You can query this name from the 3500Pro System Controller.  

 

  

The Configuration Name may be different from the file name. 

 

7.11.3.2 Chop Rate 
The chop rate indicates the frames rate of switches used by the Chop mode of operation.  To 
change the chop rate, enter the desired value in the Chop Rate box.  The range of chop rates 
the 3500Pro Control System can be configured for is between 1 and 255. 

7.11.3.3 Case Sensitivity 
This option specifies whether the 3500Pro software distinguishes between upper and lower 
case letters when you are entering information in the category, source, destination, and 
reentry windows.  For example, if you have Case Sensitivity turned ON, the software will 
recognize when you enter information using capital letters.  If you have Case Sensitivity 
turned off, it doesn’t matter if you use lower or upper case.  

After making changes, click the OK button to close the window.  Be sure to save the 
configuration file. 

7.11.3.4 PRC Delay 
This option specifies the delay between PRC messages.  It applies to PRC, TGR, and XTN 
types of components.  The range of the PRC delay value can be from 5 to 10 ms.  The default 
value is 10 ms. 

7.11.4 Matrix Configuration 
The Configuration > Matrix Configuration command allows you to define Sources and 
Destinations.  The maximum number of sources and destinations is 1200 (180 for the 
3500ProLE). 

There are 2 tab sheets in this window, one for sources, and the other for destinations. The 
Destinations tab displays in yellow so you can easily determine which tab sheet you are 
working with.   
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7.11.4.1 Display Error Command 
• When selected, entering invalid data in the source or Destination grid will display a 

popup message box on the screen warning you of the invalid data.  You can not 
continue until you click on the OK button to clear the message box.  The invalid data 
will be changed to a red color. 

• When selected, entering invalid data in the source or destination grid causes the invalid 
box data to be displayed in red, but no message box will be displayed. 

7.11.4.2 Before Using This Command  
You must have already used the Configuration > System Configuration > Level/Comp 
command to set up all of the levels. 

7.11.4.3 Sources 
The Matrix Configuration > Sources tab allows you to define all of the sources in the 
configuration (see Figure 96).  Only one source per level is allowed.  A level may be left 
undefined on a source.  Inputs may be shared between different sources.  The maximum 
number of sources is 1200 (180 for the 3500ProLE). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 96: Matrix Configuration Sources Window 
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• Name 
Specifies the name of each source.  Type in the name you want to use in this field. 

• Src # (Source Number) 
Identifies the source number. As you enter Names, this field will automatically display 
a number.  The source number is a numeric alias that can be used to refer top the 
source.  This is used by the serial protocols and incremental edits.   

• Levels 
The remaining columns identify the input on each level that you defined with the 
Levels window. For each level, enter the source that corresponds with each Source 
Name.  

• Right Click in Source Grid 

When you right-click in the Source grid, a pop-up menu will appear, providing menu 
options for some of the shortcut items mentioned in section 7.1.2 of the manual as well 
as a few other options.  The other options may or may not be enabled, depending on 
which column the cursor was in when the right-click was performed.  If you right-click 
in the Name column, there will be a menu selection enabled called Properties (see 
Figure 97). 

 

Figure 97: Properties Enabled (Source Grid) 
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Clicking on Properties will display another screen that shows the destinations that the 
source that you right-clicked on is Blocked from (see Figure 98). 

 

 

Figure 98: Properties – Source Destination Blocks 

You can block more destinations or remove destinations from the Blocked list.  Notice 
that the Sync Reference Definition frame is disabled.  Sync Reference Definition is 
a destination property and is not available for sources. 
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If you right-click in one of the level columns, which is any column to the right of the 
Dst # column, there will be a menu selection enabled called: Tieline Source Define 
(see Figure 99). 

 

Figure 99: Tieline Source Define 

Clicking on Tieline Source Define will display another screen that enables the 
definition of a source on a level connected by a tieline (see Figure 100). 

 

 
 

Figure 100: Tieline Definition Screen 



 
 

3500PRO/LE – SECTION III  
81-9059-0549-0 Rev. D 

 

Proprietary Information of PESA SWITCHING SYSTEMS, INC. 100 

 

In the right-click menus shown previously, note the menu item Export To CSV File.  
If you click this item, a standard file save dialog will be displayed allowing you to 
create a “*.csv” (comma separated variable) file that contains the source configuration 
data shown in the Sources grid.  This *.csv file can be loaded directly into Excel and 
a host of other programs.  The file contains a header row followed by the configuration 
data.  Once loaded into Excel, the data can be formatted to your 
specifications/requirements and printouts can then be performed. 

7.11.4.4 Destinations 
The Matrix Configuration > Destinations tab (see Figure 101) allows you to define all of 
the destinations in the configuration.  The maximum number of destinations is 1200 (180 for 
the 3500ProLE). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 101: Matrix Configuration Destinations Window 
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• Name 
This specifies the name of each destination.  Type in the name you want to use in this 
field. 

• Dst # (Destination Number) 
This identifies the destination number. As you enter Names, this field will 
automatically display a number.  The destination number is a numeric alias that can be 
used to refer top the destination.  This is used by the serial protocols and incremental 
edits.   

• Levels 
The remaining columns identify the input on each level that you defined with the 
Levels window. For each level, enter the destination that corresponds with each Source 
Name.  

• Right-Click in Destinations Grid 

When you right-click in the Destinations grid, a pop-up menu will appear, providing 
menu options for some of the shortcut items mentioned in section 7.1.2 of this manual 
as well as a few other options.  The other options may or may not be enabled, 
depending on which column the cursor was in when the right-click was performed.  If 
you right-click in the Name column, there will be a menu selection enabled called 
Properties (see Figure 102). 

 

 
Figure 102: Properties (Destinations Grid) 
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Clicking on Properties will display another screen (see Figure 103) that shows the 
sources that are Blocked from the destination that you right-clicked on as well as the 
Sync Reference Definition for this particular destination.  By checking the checkbox 
at the bottom of the Sync Reference Definition frame, any change you make to the 
Sync Reference Definition for a level, will be applied to every destination that is 
defined on that level. 

 

 

Figure 103: Properties For Destinations Display 

In the right-click menus shown previously, note the menu item Export To CSV File.  
If you click this item, a standard file save dialog will be displayed allowing you to 
create a “*.csv” (comma separated variable) file that contains the destination 
configuration data shown in the Destinations grid.  This file can be loaded directly 
into Excel and a host of other programs.  The file contains a header row followed by 
the configuration data.  Once loaded into Excel, the data can be formatted to your 
specifications/requirements and printouts can then be performed. 
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7.11.5 Panels 
The Configuration > Panels command adds new panels to the configuration.  At the top of the 
window, a graphic illustration of the selected panel displays.  Below the graphic, there is a list 
of all the currently defined panels.   

The description field is the only field that can be directly changed.  The description is a 
completely optional field that does not have affect on the configuration of the controller.  It is 
strictly a convenience field for the user to help identify the control panels.  The information is 
stored in the controller so that it will be recalled later when the configuration is uploaded.  The 
address, name, and type fields cannot be directly changed.  These fields are populated when 
you create a new control panel as described in the following subsections. 

The following tabs display in this window: 

• Panel Specific Data  

• Data Key Definition  

• Panel Access Lists  

• List Assignment  

• Salvo Key Definition  

7.11.5.1 Before Using This Command 
• You must have already set up Levels and Components. 

• You must have already set up the Matrix Configuration. 
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7.11.5.2 Adding a New Panel 
1. Choose the Specific panel tab  

2.  Select the New Panel button.  

3. Select the panel from the Type list.   

4. Enter the Requestor Code. 

5. Enter the lock priority 

6. Enter the status method.  

7.11.5.3 Panel Specific Data 
The Panel Specific Data tab (see Figure 104) allows you to add new panels, edit existing 
panels, and delete panels.  This tab also allows you to define information about the panel, 
such as name, address, etc.  The following fields are available in this panel: 

 

Figure 104: Panel Configuration Window, Panel Specific Data Tab 
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If you right-click in the configured panels grid, which is right below the panel image, a pop-
up menu (see Figure 105) will be displayed.  If you click the item labeled Export To CSV 
File, a standard file save dialog will be displayed allowing you to create a “*.csv” (comma 
separated variable) file that contains the control panel configuration data shown in the Panel 
Specific Data tab of the panel screen.  The file can be loaded directly into Excel and a host 
of other programs.  The file contains a header row followed by the configuration data.  Once 
loaded into Excel, the data can be formatted to your specifications/requirements and 
printouts can then be performed. 

 

Figure 105: Exporting To CSV File Menu 

• Type 
This field identifies the type of panel.  This field is read-only unless you select the New 
Panel button.  The panel you select here displays in the middle section of the window 
in the Type field. 

• Address 
This indicates the physical address of the control panel.  Every control panel has 
dipswitches on the back.  These switches are used to set a unique address for each 
panel in a switching system.  Find out what the address is, and enter it here.  The 
address you enter here displays in the middle section of the window in the Address 
field. 

• Requestor Code 
The requester code is used with the lock priority to determine if a lock or protect 
function can be removed.  When a lock or protect has been assigned by a panel (or 
serial communications port), it can only be removed by another panel (or port) with a 
higher lock priority or with the same lock priority and same requester code. 

Requestor codes are also used with protects.  When a destination is placed into protect, 
only those panels/users with the same requestor code can switch the destination. 

Requester codes not explicitly defined automatically default to the panel address. 
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• Lock Priority 
The lock priority is used with the requester code to determine if a lock or protect can be 
removed.  When a lock or protect has been assigned by a panel or port, it can only be 
removed by another panel or port with a higher lock priority, or with the same lock 
priority and same requester code.  The lower the lock priority number, the higher the 
priority. 

Panel lock priorities not explicitly defined automatically default to "0" which gives 
absolute authority to clear any lock or protect on the system.  The acceptable range of 
lock priorities is shown in the General Specifications Table. 

• Status Method 
When a panel is in all levels mode (ALL LEVS), the status shown will be the source on 
the Status Level assigned to that panel.  If the destination is not defined on the Status 
Level, Status Method is used to control the resulting display: 

If DEF (Default Method) is selected, NO XXXXX will be displayed where XXXXX is 
the Status Level assigned to the panel. 

If GRP (Group Method) is selected, the controller will examine every level 
sequentially, starting with the level designated as Level Order 1.  The source switched 
on the first level found where the destination is defined, will be displayed as the 
destination status. 

• Name 
Because a panel is identified by its address, the assignment of a panel name is optional.  
If used, panel names are one to eight characters in length and are constructed using 
uppercase letters, numbers, and spaces.  The first character must be a letter.  The name 
you enter here will display in the middle portion of the window as the "Name" of the 
panel. 

• Status Level 
One function of the LCD display on a panel is to show, which source is currently 
switched to a selected destination.  This is known as destination status. Although more 
than one source can be switched to a single destination (limited to one source per 
level), the status display can only show one source at a time.  When the panel is in all 
levels mode (ALL LEVS), Status Level is used to designate a default level to be used 
when displaying status.  Only the source on this default level will be displayed. 
Pushbutton only panels also use the status level.  It is used to determine which tally 
LED to light on a panel in a split/breakaway condition. 
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• Default Dest 
Select the default destination for which status will be displayed when power is applied 
to a panel, or when a new configuration is downloaded to the controller.  

The panel will have control over the destination selected here, even if it is not included 
in the associated destination include list. 

• Data Key List 
A data key is a user configurable control panel key, whose assigned function is used 
when the panel is in any mode except Salvo Select Mode. 

A data key list is a named list of the functions assigned to each data key on a panel.  A 
data key list may be shared by multiple panels as long as they are the same type of 
panel.  Different panel types may not use the same data key list. 

Define new Data Key Lists with the Data Key Definition tab. 

• Level List 
The Levels of Control List is a named list of all levels the panel (or remote client) is 
authorized to control. Two special lists come pre-configured:  ALL and NONE.  Define 
new items that should appear in this list with the Panel Access Lists tab (in the Include 
List Type section, select Level). 

• Src Include List 
A source include list is a named list of the sources a specific control panel is authorized 
to control.  A source include list may be shared by multiple panels. 

The Source Include List is a named list of all sources the panel is authorized to 
control. It functions the same as the LEVELS OF CONTROL LIST window.  Define 
new items that should appear in this list with the Panel Access Lists tab (in the 
Include List Type section, select Source). 

• Dst Include List 
A destination include list is a named list of the destinations a specific control panel is 
authorized to control.  A destination include list may be shared by multiple panels.  The 
default destination assigned to a panel may be controlled even if it is not on the 
destination include list.  Define new items that should appear in this list with the Panel 
Access Lists tab (in the Include List Type section, select Destination). 

• Slv Include List 
A salvo include list is a named list of the salvos a specific control panel is authorized to 
control.  A salvo include list may be shared by multiple panels.  Define new items that 
should appear in this list with the Panel Access Lists tab (in the Include List Type 
section, select Salvo). 
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• Salvo Key List 
A salvo key is a user configurable control panel key, whose assigned function is used 
when the panel is in salvo select mode.  A salvo key list is a named list of the functions 
assigned to each salvo key on a panel.  A salvo key list may be shared by multiple 
panels as long as they are the same type of panel.  Different panel types may not use 
the same salvo key list.  Define new items that should appear in this list with the Salvo 
Key Definition window. 

• New Panel 
The New Panel button adds a new panel to the list in the center of the screen.  You 
need to select the Type of panel to add, and define all of the other information about the 
panel (on all five tab sheets). 

• Copy Panel 
Copies all of the information about the currently selected panel and creates a new panel 
with identical information.  The new panel will automatically display in the list in the 
middle of the window with a new panel address.  You can then enter a name and 
description for the new panel. 

• Delete Panel 
This deletes the currently selected panel.  

 

Make sure you really want to delete the panel before selecting this 
command.  You cannot "Undo" this action. 
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7.11.5.4 Data Key Definition 
The Data Key Definition tab (see Figure 106) sheet defines the settings for each 
configurable control panel key, whose assigned function is used when the panel is in any 
mode except Salvo Select Mode.  At the top of the window, a picture of the currently 
selected panel displays.  Click on the buttons on the control panel to see the Data Key that is 
assigned to the button.  You can change which panel you are reviewing by selecting another 
panel from the middle part of the window (with Address, Name, and Type listed).  Also, the 
List Names that are defined in this tab sheet are the items that display in the Data Key List 
in the Panel Specific Data tab.   

 

Figure 106: Data Key Definition Tab 
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If you right-click in the data key list grid, located on the Data Key Definitions tab of the 
panel screen, a pop-up menu will be displayed (see Figure 107).  If you click the item labeled 
Export To CSV File, a standard file save dialog will be displayed allowing you to create a 
“*.csv” (comma separated variable) file that contains the data key definitions for all data key 
lists in the controller configuration.  This file can be loaded directly into Excel and a host of 
other programs. The file contains a header row, followed by the key list data.  Each key list in 
the CSV file is separated by a blank row and contains the list name, panel type, and the key 
definition data.  Once loaded into Excel, the data can be formatted to your 
specifications/requirements and printouts can then be performed. 

 

 
 

Figure 107: Data Key List Grid Menu 

• Definition List 
This identifies the Key Type and Name/Category associated with a specific button on 
the panel.  When you select an item from this list, the graphic at the top of the screen 
will highlight the button you selected.  To change the definition, double-click items in 
the Sources, Destinations, Levels, or Categories lists. 

• Sources 
This lists all of the available sources for the panel.  Double-click any item in this field 
to assign it to the currently selected key.  You can also copy and paste. 

• Destinations 
This lists all of the available destinations for the panel.  Double-click any item in this 
field to assign it to the currently selected key. 

• Levels  
This lists all of the available levels.  Double-click any item in this field to assign it to 
the currently selected key. 
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• Categories 
This lists all of the available categories.  Double-click any item in this field to assign it 
to the currently selected key. 

• Soft Sources/Soft Destinations 
Typing SSRC or SDST sets the data key type to a soft key.  A soft key can be 
programmed by the user at a panel.  

• List Name 
This shows the existing Data Keys.  These items display in the Data Key List pull-
down in the Panel Specific Data tab.  When you select the New DK List button, a 
new line displays in this section.  You can double-click any name in this list, and type 
in a new name. 

• New DK List 
Adds a new Data Key List to the List Name field.  Type in the name for the new list. 

• Copy DK List 
Copies the information in the currently selected Data Key List and creates a new Data 
Key List with identical information. The new Data Key List will display in the List 
Name field and you can specify a new name for the list. 

• Del DK List 
This deletes the Data Key List that is selected in the List Name field. 

 

Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action. 
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7.11.5.5 Soft Key Definition 
Soft Keys can be configured locally at the panel using Store Mode, or with 3500Pro. 

 

Soft Keys cannot be configured until at least one soft key has been defined 
in the Data Key List assigned to the panel. 

 

7.11.5.6 Panel Access Lists 
The Panel Access Lists tab (see Figure 108) shows the include lists for Levels, Sources, 
Destinations, and Salvos.  Included lists are named lists of the Levels, Sources, Destinations, 
and Salvos a specific control panel is authorized to control.  A source include list may be 
shared by multiple panels. 

 

Figure 108: Panel Access List Tab 
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• Include List Type 
Lists the types of include lists you can review or edit.  Click on the button to the left of 
the list. 

• List Name 
Lists the names of the lists associated with each list type.  Click on each item in this list 
to review its contents. 

If you right-click in the List Name grid, located on the Panel Access Lists tab of the 
panel screen, a pop-up menu will be displayed (see Figure 109).  If you click the item 
labeled Export To CSV File, a standard file save dialog will be displayed allowing 
you to create a “*.csv”(comma separated variable) file that contains the include list 
definitions for all include lists in the controller configuration.  This is file can be loaded 
directly into Excel and a host of other programs.  The file contains a header row, 
followed by the include list data.  Each include list in the CSV file is separated by a 
blank row and contains the list name, list type, and the definition data depending on 
whether it is a Level, Source, Destination, or Salvo include list.  Once loaded into 
Excel, the data can be formatted to your specifications/requirements and printouts can 
then be performed. 

 

 
Figure 109: List Name Popup 

 

• Associated Panels 
Shows the panels associated with each list you select in the List Name field.  To 
associate a list with a panel, go to the Panel Specific Data tab.  Select an item from 
the Level List, Src Include List, Dst Include List, or Slv Include List.  After you 
select a list to associate with the panel, the panel name and number will display in this 
field. 
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• New Inc. List 
Create a new Include list in the List Name field.  Be sure to first select the type of list 
you want to create in the Include List Type field.  After you select this button, type a 
name for the new list. 

• Copy Inc. List 
Copies the Level and Include List settings for the selected List Name and creates a 
new item in the List Name field.  You can then enter a different name for the new list 
item.  

• Del Inc. List 
This deletes the selected list from the List Name field. 

 

Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action. 

 

• Include List Contents 

Levels/Sources/Destinations/Salvos 

The title and contents of this section will change depending on the item you select in 
the Include List Type field are as follows:  

1. Level: This section will show all of the available levels.  

2. Source: This section will show all of the available sources. 

3. Dest: This section will show all of the available destinations. 

4. Salvo: This section will show all of the available salvos. 

• Include List 
Shows all of the items in the include list.  To add an item to the include list, select it 
from the left portion of the window, then select the >> button.  The items will move 
from the left column to the right column.  
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7.11.5.7 List Assignment 
The List Assignment tab (see Figure 110) shows all of the panel lists that are currently 
defined, the panels that are actually available, and the panels that are associated with each 
different list. 

 

Figure 110: List Assignment Tab 
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• Panel List 
This section lists each of the different types of panel lists.  Select each button to review 
the lists available. 

• List Name 
Shows the lists available for the type of panel list you select in the Panel List section. 
Select each individual list to review the panels that are currently available and the 
panels that are currently associated with the list. 

• Available Panels 
This section shows all of the panels that are currently available to associate with the 
selected List Name.  To associate an available panel with the selected list, select the 
panel then select the >> button.  The panel will move from the Available Panels to 
Associated Panels column. 

• Associated Panels 
Shows the panels actually associated with the selected List Name.  To disassociate a 
panel from the list, select the panel name then select the << button.  The panel will 
move from the Associated Panels column to the Available Panels column. 
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7.11.5.8 Salvo Key Definition 
A salvo key (see Figure 111) is a user configurable control panel key, whose assigned 
function is used when the panel is in salvo select mode. 

A salvo key list is a named list of the functions assigned to each salvo key on a panel.  A 
salvo key list may be shared by multiple panels as long as they are the same type of panel. 
Different panel types may not use the same salvo key list. 

 

Figure 111: Salvo Key Definition Tab 
 

 

A Salvo Key List cannot be created until at least one salvo has been 
configured. 
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If you right-click in the Salvo Key List grid, located on the Salvo Key Definitions tab of the 
panel screen, a pop-up menu will be displayed (see Figure 112).  If you click the item labeled 
Export To CSV File, a standard file save dialog will be displayed allowing you to create a 
“*.csv” (comma separated variable) file that contains the data key definitions for all data key 
lists in the controller configuration.  This file can be loaded directly into Excel and a host of 
other programs.  The file contains a header row, followed by the key list data.  Each key list 
in the CSV file is separated by a blank row and contains the list name, panel type, and the key 
definition data.  Once loaded into Excel, the data can be formatted to your 
specifications/requirements and printouts can then be performed. 

 

 

Figure 112: Salvo Key List Grid Menu 

• Salvo Group 
This field shows the salvo group associated with each individual button on the panel.  
You can click on the button on the panel at the top of the window to see that salvo group 
associated with it, or, you can select the row to highlight the associated panel button. 

• List Name 
This shows the names of the defined salvo lists.  This window shows the salvo groups 
associated with the list. 

• Salvo Grps 
The Salvo Grps shows the currently defined Salvos (using the Configuration > Salvo 
command).   

• New SK List 
This adds a new Salvo list to the List Name field.  Type in a new name for the lists, 
then select the salvos to associate with it from the Salvo Grps field. 
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• Copy SK List 
Copies the information in the currently selected Salvo List and creates a new List with 
identical information.  You can then change the name of the new Salvo List. 

• Delete SK List 
This deletes the selected List Name.  

 

Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action.  
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7.11.6 Salvo 
The Configuration > Salvo command allows you to add, edit, and delete Salvos (see Figure 
113).  A Salvo is a group of predefined logical switches taken at the same time.  All switches in 
a Salvo are taken within the same vertical interval.  The maximum number of Salvos is 128 (64 
for the 3500ProLE).  The maximum number of Salvo entries is 1024 that is spread across the 
128 (64) Salvo Groups. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 113: Salvo Configuration Screen 

7.11.6.1 Before Using This Command 
• You must have already set up Levels and Components (with the Configuration > 

System Configuration Level/Comp command). 

• You must have already set up Sources and Destinations (with the Configuration > 
Matrix Configuration command). 

7.11.6.2 Adding a New Salvo: 
1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, enter a name for the salvo.  The number field will be 
automatically populated. 

3. Make sure you do not highlight another row in the Salvo Groups field, then click in 
the Destination field in the top row of the Salvo Entries section.  
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4. Scroll through the Destinations list at the top of the window.  When you find the 
destination that you want to assign to the Salvo, double-click it.  The destination name 
displays in the Salvo Entries list.  

5. Follow the same procedures for the sources.  In the Salvo Entries section, highlight 
the source field that you want to define.  Scroll through the Sources list and then, 
double-click the source you want to use.  

6. If you want to fill in several levels all at once, you can click Fill All Levels.  This will 
assign one source to all levels, or, you can select specific levels you want to 
automatically populate by select items from the Fill Level section.  Each level that is 
highlighted will be automatically assigned a source that you double-click. 

7. After completing one salvo, you can go back to the Salvo Groups section, click on the 
second row, and repeat this process. 

8. When you are finished entering salvos, click OK to save your changes and to close the 
window. 

7.11.6.3 Editing a Salvo 
1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, select the salvo you want to edit. 

3. Change any of the destination and source information following the procedures 
outlined for adding a new salvo. 

4. When you are finished editing one salvo, you can select another from the Salvo 
Groups list, and edit it. 

5. When you are finished editing, select the OK button to save your changes and close the 
window. 

7.11.6.4 Deleting a Salvo 
1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, select the Name of the salvo you want to delete. 

3. Select the Delete button, and the salvo will be deleted. 

4. When you are finished deleting one salvo, you can select another from the Salvo 
Groups list, and delete it. 

5. When you are finished, select the OK button to save your changes and close the 
window. 
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7.11.7 Categories 
The Configuration > Category option defines categories (see Figure 114).  A category is an 
optional entity assigned to a panel key that may be used alone, or with other categories, to 
select a source, destination, or reentry.  Categories, if used, are simply sub strings used to build 
names (source, destination, and reentry) by linking together.  When the user presses a category 
button on a panel, the category is linked onto the right side of the name in the preset.  If 
necessary, the left side of the name will be trimmed to bring its length to a maximum of eight 
characters. 

 

Figure 114: Category Configuration Window 

Functionally, categories only affect panel operations where panels have been defined to have 
categories assigned to their data keys.  

Panels can have one or two categories assigned to a data key.  When the user presses a category 
button, the panel concatenates the category to the source or destination name on the panel. 

When two categories are assigned to a button, the panel uses the first category if the preset is 
blank. Otherwise, the panel concatenates the second category.  This requires the user to use the 
CLEAR button to clear out the preset name before accessing the first category assigned to a 
key. 

When there is only one category assigned to a button, it is always linked to the name in the 
preset. 
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For example, given a panel with the following definitions: 

Button 1

Cat1: VTR

Cat2: 0

Button 2

Cat1: CAM

Cat2: 1

Button 3

Cat1: CG

Cat2: 2

Button 4

Cat1: 3

Cat2:

Button 5

Cat1: 4

Cat2:
 

To access VTR13 and take it online, the user would press: 

1. CLEAR (Clears out the name in the preset display) 

2. Button 1 (VTR in the preset display) 

3. Button 2 (VTR1 in the preset display) 

4. Button 4 (VTR13 in the preset display) 

5. TAKE (Causes VTR13 to be taken to the active destination.) 

You can assign up to 254 categories.  To enter a category, click in the field and type the 
category name.  A category can contain any combination of leading, trailing, embedded spaces, 
or simply be a space.  When representing a leading or trailing space, the space character must 
be substituted with the “~” (tilde) character.  Spaces in the middle of a category must be 
represented with the space character.  A “~” that is embedded within a category will cause an 
error.  



 
 

3500PRO/LE – SECTION III  
81-9059-0549-0 Rev. D 

 

Proprietary Information of PESA SWITCHING SYSTEMS, INC. 124 

 

7.11.8 Tielines 
The Configuration > Tielines command defines tielines, which are special types of logical 
switches that allow a logical input on one level to be switched to a logical output on a different 
level (see Figure 115).  

 

Figure 115: Tieline Configuration Window 

Tielines are not available with the 3500ProLE. 

The maximum number of tielines is 64. 
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The example shown (see Figure 116) demonstrates a tieline being used to route a video signal 
from an analog camera, through an external analog-to-digital converter, to a digital VTR. 

ROUTING SWITCHER

LOGICAL
OUTPUTS

1
2
3
4
5
6
7
8

LOGICAL
INPUTS

3 4 51 2 6 7 8

TLINE1

ANCAM

ROUTING SWITCHER

LOGICAL
OUTPUTS

1
2
3
4
5
6
7
8

3 4 51 2 6 7 8

ANALOG TO DIGITAL CONVERTER
LEVEL ANAVID

LOGICAL
INPUTS

DIGVTR

LEVEL DIGVID

 

Figure 116: Tieline Example 

 

Once a Tieline has been configured, it may then be used by a source. 

 

7.11.8.1 Adding a Tieline 
To add a tieline, follow these steps. 

1. Click in a blank field at the bottom of the screen. If you do not select a blank field, an 
existing tieline will be overwritten. A blank row will highlight. 

2. At the top of the window, enter a name in the Tieline Name field.  

3. Select the Output Level and Output # for the tieline. The output cannot be used by any 
other tieline or destination. 

4. Next, select the Input Level and Input # for the tieline. 

5. Select Add/Edit Tieline. The tieline displays in the list at the bottom of the window. 
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7.11.8.2 Editing a Tieline 
To edit a tieline, follow these steps. 

1. Select the tieline you want to edit.  

2. Enter the new information in the upper portion of the window.  

After you are done editing information, select the Add/Edit Tieline button. The new 
information will display in the tieline. 

7.11.8.3 Deleting a Tieline 
To delete a tieline, follow these steps. 

1. Select the tieline you want to delete. 

2. When the row highlights, select the Delete Tieline button.  The tieline will be removed 
from the list. 

7.11.9 Reentry 
The Configuration > Reentry command adds reentries and entities, which exist as both a 
source and destination at the same time (see Figure 117).  The function of reentries is to 
facilitate switching a single source to multiple destinations with a single, logical switch. 

 

Figure 117: Reentry Configuration Window 

Reentries are not available with the 3500ProLE. 
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Example (see Figure 118): assume there exists source SRC1 and destinations DST1, DST2, and 
DST3.  Reentry REENT1 is created and switched to the three destinations.  With a single 
logical switch, SRC1 can now be switched to REENT1 and the signal will arrive at all three 
destinations at the same time. 

SRC1 REENT1 DST2

DST1

DST3
 

Figure 118: Reentry Example 

The maximum number of reentries is 8. 

7.11.9.1 Adding a Reentry 
1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. In the Name field, type the name of the Reentry.  

3. In the Source # field, type the source number.  When a reentry name is created, an 
unused source number is automatically assigned to the source number field.  You may 
use this number or change it to some other unused source number. 

4. In the Dest # field, type the destination number.  When a reentry name is created, an 
unused destination number is automatically assigned to the destination number field.  
You may use this number or change it to some other unused destination number. 

5. Select OK to close the window. 

7.11.9.2 Editing a Reentry 
1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. Change any of the information in the window. 

3. Select OK to close the window. 

7.11.9.3 Deleting a Reentry 
1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. Highlight name of the Reentry you want to delete. 

3. Press the Delete button.  The reentry is deleted.  

4. Select OK to close the window. 



 
 

3500PRO/LE – SECTION III  
81-9059-0549-0 Rev. D 

 

Proprietary Information of PESA SWITCHING SYSTEMS, INC. 128 

 

7.11.10 Remote Client 
The Configuration > Remote Clients command allows you to add, edit, and remove remote 
clients from the 3500Pro system (see Figure 119).  This window defines the part of the matrix 
that remote clients can see and control.  The KlikControl software uses remote clients to 
provide names, passwords and privileges for its users.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 119: Remote Client Configuration 
 

7.11.10.1 Before Using This Command 
Remote clients must have the KlikControl software. 
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7.11.10.2 Adding a New Remote Client 
1. Select Configuration > Remote Client to open the Remote Client Configuration 

window. 

2. In the User Name field, type in the user’s name. 

3. In the Password field, type in a password for the user.  As you type the password, it 
will display in the field.  As you select the next field, however, the password will be 
encrypted and you will no longer be able to tell what the password is.  Be sure the 
remote user knows his/her user name and password. 

4. Select the Lev Include field for the user and then, from the Level Incl. field, select the 
Level List, which defines the levels that you want the user to access.  If they should 
have access to all levels, select All.  The options that display in the Level Incl. field are 
defined in the Configuration > Panels window in the Panel Access List tab as 
Level Include Lists.  

5. Select the Src Include field for the user.  In the Src Incl box at the top of the window, 
select the Source Include List, which defines the sources that the user should be able 
to access.  If they should have access to all sources, select All.  The options that display 
in the Level Incl. field are defined in the Configuration > Panels window in the 
Panel Access List tab as Source Include Lists. 

6. Select the Dst Include field for the user.  In the Dst Incl box at the top of the window, 
select the Destination Include List, which defines the destinations the user should be 
able to access.  If they should have access to all destinations, select All.  The options 
that display in the Level Incl. field are defined in the Configuration > Panels window 
in the Panel Access List tab as Destination Include Lists. 

7. Select the Slv Include field for the user.  In the Slv Incl box at the top of the window, 
select the Salvo Include List that defines the salvo groups the user should be able to 
access.  If the should have access to all salvo groups, select All.  The options that 
display in the Slv Incl box at the top of the window are defined in the Configuration > 
Panels menu item on the Panel Access Lists tab as Salvo Include Lists. 

8. The Options field provides a place to enter additional information about the user.  You 
can enter a text string here.  

9. Now you can add additional users if necessary. 

10. When you are finished, select OK to save your changes and to close the window. 
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7.11.10.3 Editing a Remote Client 
1. Select Configuration > Remote Client to open the Remote Client Configuration 

window. 

2. In the lower part of the window, select the user you want to edit.  The user name field 
highlights. 

3. Make changes to any of the information for the user.  

4. When you are finished, you can add, edit, delete other users, or select OK to save your 
changes and close the window. 

7.11.10.4 Deleting a Remote Client 
1. Select Configuration > Remote Client to open the Remote Client Configuration 

window. 

2. In the lower part of the window, select the user you want to delete.  The user name field 
highlights. 

3. Select Delete, then press Enter.  The user will be deleted.  

You can now add, edit, or delete additional users, or select OK to save your changes and 
close the window.  
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7.12 WINDOW MENU 
The Window menus arrange the windows that display in the 3500Pro interface.  The following 
commands are available: 

• New Window  

• Cascade  

• Tile Horizontal  

• Tile Vertical  

• Arrange Icons  

7.12.1 New Window 
The Window > New Window command opens a second window that displays the same 
information as the currently active window. 

7.12.2 Cascade 
The Window > Cascade command arranges all of the open windows so that they slightly 
overlap one another. 

7.12.3 Tile Horizontal 
The Window > Tile Horizontal command arranges all of the open windows so that they all 
appear on the screen in a horizontal row. 

7.12.4 Tile Vertical 
The Window > Tile Vertical command arranges all of the open windows so that they all appear 
on the screen in a vertical row. 

7.12.5 Arrange Icons 
The Window > Arrange Icons command aligns the icons of collapsed window in a row along 
the bottom of the screen. 

7.12.6 Open Windows 
The currently open windows are listed at the bottom of the Window menu.  The currently 
active menu has a check mark next to it.  To quickly switch to another open window, select 
another window from this list, and it will become active and display. 
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7.13 HELP MENU 
The Help menu displays the 3500Pro help file and the current version number of the 3500Pro 
software.  The following commands are available: 

• Contents  

• Search for Help On  

• About  

7.13.1 Contents 
The Help > Contents option opens the contents tab of the help file.  From there, you can 
browse for the topic you want to review. 

7.13.2 Search for Help On 
The Help > Search for Help On option opens the Index tab of the help file.  Type in a word 
you need help on, and matching items will highlight in the window.  Double-click an item to 
open the help topic.  

 

You can also use the Find tab to search on any word in the help file.  Try 
this option if the topic you are looking for is not listed in the index. 

 

7.13.3 About 
The Help > About option displays the version of the 3500Pro software.  In addition, if you 
select the System Info button, detailed information about your computer hardware and software 
displays.  This information is useful to review if you need to call Technical Support.  
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Chapter 8 - 3500Pro Status and  
Diagnostics 

The 3500Pro Status module shows the status of different parts of the 3500Pro system.  The 
following menu items are available: 

• File Menu  

• View Menu  

• Tools Menu  

• Status 

• Preset 

• Tielines 

• Panel 

• Readback 

• Window Menu  

• Help Menu  

8.1 FILE MENU 
The File menu logs you into the 3500Pro Status module, closes open windows, and exits the 
module.  The following commands are available (see Figure 120): 

 
Figure 120: File Menu 

8.1.1 Login 
The File > Login menu logs you into the Status module. 

• Before using this command, you must have a User name and password.  Refer to 3500Pro 
User Manager for information on creating and editing users.  
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8.1.2 Close 
The File > Close command closes the currently active window.  

• Before using this command, make sure the window you want to close is active (the top 
border is highlighted). 

8.1.3 Exit 
The File > Exit command closes the 3500Pro Status window. 

8.2 VIEW MENU 

8.2.1 View Menu 
The View menu displays and hides the toolbar and status bar, and open different status 
windows.  The following commands are available (see Figure 121): 

 

 

 

 

 

 

 

 

 

 

Figure 121: View Menu 

8.2.2 Toolbar 
The View > Toolbar command hides or displays the bar with the shortcut icons.  Select this 
command to display or hide the toolbar. 

8.2.3 Status 
The View > Status Bar command hides or displays the bar with the status information that 
displays at the bottom of the 3500Pro window.  Select this command to display or hide the 
status bar. 
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8.2.4 Matrix Status    
The View > Matrix Status command displays the status of the available destinations.  The 
information shown in this window automatically updates as changes occur.  Three types of 
columns display in this window (see Figure 122):  

 

Figure 122: Matrix Status Window 

8.2.4.1 Dests 
This displays all of the destinations. 

8.2.4.2 Lock 
This indicates if the destination is locked or unlocked.  If it is locked, a "lock" icon       
displays in the field.  Click on the Lock field next to the destination to Lock or Unlock the 
destination (toggle function).   

8.2.4.3 Levels 
The remainder of the columns in this section display all of the levels that are defined for the 
configuration.  For each destination, the source displays on the Destination’s row. 

8.2.4.4 Sources 
This displays the available sources.   
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8.2.4.5 Take  
The Take button switches a specific physical switch.  You can perform a Take on single or 
multiple destinations. 

1. Select the fields for the routers on which you want to perform a take.  When you select 
a field, the border of the field highlights.  You can select multiple fields: 

2. Select the first field, press the Shift key, then select the last field. All fields in between 
will highlight. 

3. Select the first field, then press the Ctrl key.  Keep the Ctrl key pressed down while you 
select additional fields.  Each one you select highlights.  

4. After you select all of the fields, select the Source.  

5. Select Take, and the source you selected displayed in the highlighted fields.  

 

You cannot perform a take on a locked destination. 

 

8.2.4.6 Lock 
The Lock button locks the selected destination.  

8.2.4.7 Unlock 
The Unlock button unlocks the selected destination. 

8.2.4.8 Right-click Menu Options 
If you right-click your mouse, three menu options display (see Figure 123): 

 

 

 

Figure 123: Menu Options  

• Take:  performs a take.  Select the Destinations, then the Sources, then right click 
and select this button. 

• Source Status:  Displays matrix status information for the selected Source.   

• Definition:  Displays the Level number and Input/Output number for the selected 
destination or source.   
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8.2.5 Preset    
The View > Preset window allows you to build complex combination of switches and to take 
them simultaneously on the router (see Figure 124).   

 
Figure 124: Preset Builder Window 

8.2.5.1 Dest  
This displays the destinations.  Double-click an item in the Destinations field on the right side 
of the window to assign it to this field. 

8.2.5.2 Lock  
This indicates if the Destination is locked.  If it is locked, a "lock" icon      displays in the 
field.  Click on the Lock field next to the destination to Lock or Unlock the destination.   

8.2.5.3 Router  
This displays the sources for the router.  Double-click an item in the Sources field on the 
right side of the window to assign it to this field. 

8.2.5.4 Sources  
This displays the available sources.  
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8.2.5.5 Destinations  
This displays the available destinations.  

8.2.5.6 Clear All 
This removes all of the information from the Preset Builder. 

8.2.5.7 Clear Selected 
This removes the information from the selected rows in the Preset Builder.  To select 
multiple rows, select the first field, press the Shift key, then select the last field.  All fields in 
the selections highlight. 

8.2.5.8 Insert Rows 
This adds a new row above the currently selected row. 

8.2.5.9 Delete Rows 
This removes the currently selected row. 

8.2.5.10 Get Mtx Current 
This loads the current matrix that is configured with the View > Matrix Status option. 

8.2.5.11 Take All 
This performs a Take on all of the destinations. 

8.2.5.12 Take Selected 
This performs a Take on only the selected destinations.  To select multiple destinations, 
perform one of the following: 

1. Select the first field, press the Shift key, then select the last field.  All of the selected 
fields in between will highlight. 

2. Select the first field and then, press the Ctrl key.  Keep the Ctrl key pressed down while 
you select additional fields.  Each one that you select will highlight.  

8.2.5.13 Lock After Take  
This locks the destinations after performing a Take.  (Locks are set per destination on the 
preset grid.)  

8.2.5.14 Clear Lock Before Take 
Clears all locked Destinations before performing a Take. 
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8.2.5.15 Save 
This saves the Preset settings in this window.  The file will have a .preset extension. 

8.2.5.16 Load 
Loads preset settings into the Preset Builder.  You must have used the Save button in this 
window to save your settings before you will be able to load information with this button. 

8.2.6 Salvo 
The View > Salvo option displays information about the salvos that are defined in the 
configuration (see Figure 125).  A salvo is a group of predefined logical switches taken at the 
same time.  All switches in a salvo are taken within the same vertical interval. 

 

Figure 125: Salvo Status Window 

8.2.6.1 Salvo 
This shows specific information about the salvo that is selected in the 3500Pro Salvos 
section.   

8.2.6.2 3500Pro Salvos 
Shows a list of the salvos currently defined in the configuration file.  Select each salvo to 
review information about it in the Salvo section. 
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8.2.6.3 Fire Salvo 
This executes the selected salvo. 

8.2.7 Reentry   
The View > Reentry option displays direct source-to-destination status for every configured 
reentry (see Figure 126). 

 

Figure 126: Reentry Status Window 

8.2.7.1 Connection Status for Reentry 
This displays the reentries that are currently available.  To define a reentry, use the 
Configuration > Reentry command in the Configuration Editor module. 

8.2.7.2 Reentry as Destinations   
This shows the destination status of the selected reentry. 

8.2.7.3 Reentry as Source    
This shows the source status of the selected reentry. 
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8.2.8 Source Status   
The View > Source Status command shows the destinations (by level) that are currently 
switched to the specified source (see Figure 127).  

 

Figure 127: Source Status Window 

8.2.9 Tieline   
The View > Tielines window shows all of the defined tielines and allows you to "free up" 
existing tielines.  Tielines are special types of logical switches that allow a logical input on one 
level to be switched to a logical output on a different level.  The following example (see Figure 
128 on the next page) demonstrates a tieline being used to route a video signal from an analog 
camera, through an external analog-to-digital converter, to a digital VTR. 

The tielines menu item is available when a Tieline Status screen is being displayed.  It 
contains the following menu selections: 

• Sort Ascending 

• Sort Descending 
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Figure 128: Tieline Status Window 

8.2.9.1 Before Using This Command 
You must define tielines before they will display in this window.  To define tielines, use the 
Configuration > Tielines command in the Configuration Editor module. 

8.2.9.2 Options 
• Defined Tielines:  shows all of the currently defined tielines.  

• Tieline Status For:  displays the status of a specific tieline. Select a tieline from the 
drop-down list.  

• Free Up Tielines:  remove tieline definitions you created in the Configuration Editor 
(Configuration > Tieline command).  Select the source containing the tieline, and select 
Free Tieline. 

• Local Sources:  displays the sources that have assigned tielines 

• Override Locks:  overrides locked sources. 

• Free Tieline:  frees tieline associations.  
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8.2.10 Matrix Confidence 
The View > Matrix Confidence command displays information about the matrix status (see 
Figure 129).  You cannot edit any of the information in this window.  If the matrix confidence 
charts display in green, there is high confidence that the controller can communicate with the 
matrix.  If the chart displays in red, there is not confidence in the matrix. 

 

Figure 129: Matrix Confidence Window 

8.2.10.1 Before Using This Command 
• You must have set up the configuration for each component with the 3500Pro 

Configuration Editor module with the Configuration > System Configuration > 
Level/Comp command (in the Configuration module). 

• The configuration files you are working with are valid. 

8.2.10.2 Components: 
At the top of the window, the available components display.  You can click on each 
component to view the matrix status.  

• Component Info 

When you click on each component in the top portion of the window, information 
about the component displays in this area.  The information includes Matrix Type, 
Strobe, Starting Input, Ending Input, Starting Output, and Ending Output. 
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• Confidence Matrix 

This window is a map of the physical inputs and physical outputs of the selected 
component.  Each small square represents one physical switch.  If the confidence is 
good, the block displays in green.  Physical switches in blocks having a confidence 
error will be display in red.  Move your cursor over the different blocks to review 
information about it in the Current Block section. 

• Current Block 

This displays the Inputs and Outputs for the block that you have the mouse cursor over 
in the Confidence Matrix graphic. 

8.2.11 Panel Status 
The View > Panel Status command displays information about the available panels (see 
Figure 130).  You cannot edit any of this information.  To change configuration information for 
the panels, use the Configuration Editor module.  Refer to Panels in the 3500 Pro 
Configuration Editor. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 130: Panel Status Window 
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The following information displays for each panel: 

1. Port:  Displays the port number of the panel. 

2. Address:  Displays the address for the panel. 

3. Name:  Displays the name of the panel. 

4. Type:  Displays the type of panel.  

5. Description:  Displays the description information entered in the Configuration 
Editor. 

 

 TIP: Double-click the column title to sort the column in ascending or descending order. 

 

Select the Reset button to reset the panel. 

 

The panel will be offline until the reset procedure is complete! 

 

8.2.12 Readback Status 
The View > Readback Status command displays the physical switches that are currently 
active as reported by the routing switcher (see Figure 131).  

 

You cannot edit any of the information in this window. 

 

Figure 131: Readback Status Window 
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8.2.12.1 Components 
This displays the currently active components.  Click on each component to review 
information about it in other parts of the window. 

8.2.12.2 Dest 
Displays the physical outputs defined for the component selected in the Components section.  
The first column displays the Destination names and the second column displays physical 
outputs. 

8.2.12.3 Component Info 
Displays the following information about the component that is selected in the Components 
section:  Matrix Type, Strobe, Starting Input, Ending Input, Starting Output, and Ending 
Output. 

8.2.12.4 Physical Switch 
This opens a second window that allows you to perform simple takes and all call/diagonal 
diagnostic procedures. 

8.2.13 Memory Status 
The View > Memory Status command displays memory information about the controller (see 
Figure 132).  The Reset Controller button resets the controller.  You cannot edit any of the 
information in this window.  

 

Figure 132: Memory Status Window 
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The following information displays: 

1. Controller Software:  Displays the name and current version of the controller 
software. 

2. Memory Status:  Displays general information about the memory status, including 
Help Free, Biggest Heap Free, Novram Free, and Biggest Novram Block. 

3. Reset Controller:  Causes the controller to reset.   

 

This will take the controller off line during the reset period and will reset all 
user panels.  Only select this option if you are sure that this is what you 
want! 
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8.3 TOOLS MENU 
The Tools menu provides options to refresh the currently open window, enable and disable the 
switcher, and view the current controller status (see Figure 133). 

 

 

 

 

 

 

 

 

Figure 133: Tools Menu 

8.3.1 Controller Status 
The Tools > Controller Status command displays status information about the controller. 

8.3.2 Offline Warning 
The Tools > Offline Warning command, if selected, displays a message when the controller is 
offline.  Select this command to turn this option on and off. 

8.3.3 Reinitialize Status 
The Tools > Reinitialize Status command updates the display in the selected window.  This 
ensures that the information that displays in up to date. 

8.3.4 Disable Block Check  
The Tools > Disable Block Check command turns block checking off.  This can be useful 
when troubleshooting system problems.  This will cause the current state to be reported and, if 
desired, allows it to be toggled. 

8.3.5 Enable Block Check 
The Tools > Enable Block Check command turns block checking on.  If you used the Tools 
> Disable Block Checking command to turn block checking off, use this command to turn 
block checking back on. 
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8.3.6 Disable Switcher 
The Tools > Disable Switcher command disables the switcher.  To enable the switcher again, 
select Tools > Enable Switcher. 

8.3.7 Enable Switcher 
The Tools > Enable Switcher enables a switcher.  

8.3.8 Disable Background Update  
The Tools > Background Update Disable! turns off standard background activity that occurs 
during the readback status screen.   

8.3.9 Enable Background Update  
The Tools > Enable Background Update turns on standard background activity the 3500Pro 
performs in displaying the read-back window.  At times, this background activity could cause 
the computer to run slower, so you can turn off the background checking to increase CPU 
performance.  If you use the Tools > Disable Background Update command to turn off 
background activity, use the same command to enable it. 

8.3.10 Controller Status 
The Tools > Controller Status command displays status information about the controller. 
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8.4 STATUS MENU 
The Status Menu options (see Figure 134) define how items in the Matrix Status window 
display.  This menu will not be available until you select View > Matrix Status and the Matrix 
Status window is active. 
 

 

Figure 134: Status Menu 

8.4.1 Refresh 
The Status > Refresh option updates the information in the Matrix Status window.  This 
option ensures that the information that display is up to date. 

8.4.2 Sort Ascending 
The Status > Sort Ascending option displays information in the Matrix Status window in 
numeric ascending order (smaller numbers display at the top of the window).  

8.4.3 Sort Descending 
The Status > Sort Descending option displays information in the Matrix Status window in 
numeric descending order (larger numbers display at the top of the window). 

8.4.4 Preview Destination 
The Status > Preview Destination command allows you to preview what is occurring in the 
status window. 

Click on a cell in the status window and the preview destination is switched to the same status 
as the destination corresponding to the active cell. 
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8.5 PRESET MENU 
The Preset menu (see Figure 135) provides options for working with the Preset window.  This 
menu will not be available until you select View>Preset and the Preset window is active.  The 
following options are available: 

 

 

Figure 135: Preset Menu 

8.5.1 Load 
The Preset > Load command opens a Preset Configuration (.preset file). You can save 
preset configurations with the Save button on the Preset window or the Save As command in 
this menu. 

8.5.1.1 Before Using This Command 
You must have used the Save button in the Preset window or the Save As command in this 
menu to save preset settings. 

8.5.1.2 Loading a Preset File 
1. Select this option, and the Open window displays 

2. Change to the directory that contains the preset file you want to load.  

3. Select the file you want to load.  You can select files with either .preset or .txt 
extensions. 

4. Select Open and the file will load into the Preset window. 
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8.5.2 Save As 
The Preset > Save As command saves the information in the Preset window to a file name 
and directory location that you select.  The files will be saved as a .preset file. 

8.5.2.1 Before Using This Command 
Use the Preset window to build your preset settings. 

8.5.2.2 Saving the Preset Builder Settings 
1. Set up the Preset window. 

2. Select the Preset > Save As command.  The Save As window displays. 

3. Select the directory location to store the file. 

4. Type in a file name.  The file will automatically have a .preset extension.  

5. Select Save and the file will be saved to your computer that you can open the file later. 

8.5.3 Delete Rows 
The Preset > Delete Rows command deletes the selected row in the Preset window.  This 
option is the same as selecting the Delete Rows button in the Preset window. 

8.5.4 Insert Rows 
The Preset > Insert Rows command adds a new row above the selected row in the Preset 
window.  This option is the same as selecting the Insert Rows button in the Preset window. 

8.5.5 Cleared Selected 
The Preset > Clear Selected option removes the information from the selected rows in the 
Preset window.  To select multiple rows, select the first field, press the Shift key, then select 
the last field.  All fields in between will highlight.  This option is the same as selecting the 
Clear Selected button in the Preset window. 

8.5.6 Clear All 
The Preset > Clear All option removes all of the information from the Preset Builder.  This 
option is the same as selecting the Clear All button in the Preset window. 

8.5.7 Capture Current Matrix Status 
The Preset > Capture Current Matrix Status option loads the current matrix that is 
configured with the View > Matrix Status option into the Preset Builder window.  This 
option is the same as selecting the Get Mtx Current button in the Preset Builder. 
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8.5.8 Take Selected 
The Preset > Take Selected option performs a take on only the selected destinations.  To 
select multiple destinations: 

Select the first field, press the Shift key, then select the last field.  All fields in between will 
highlight. 

Select the first field, then press the Ctrl key.  Keep the Ctrl key pressed down while you select 
additional fields.  Each one you select will highlight.  

This option is the same as selecting the Take Selected button in the Preset Builder window. 

8.5.9 Take All 
The Preset > Take All button performs a take on all of the destinations.  This option is the 
same as selecting the Take All button in the Preset Builder window. 
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8.6 TIELINE MENU 
The Tieline menu provides options for working with the Tieline window.  You cannot access this 
menu until you select View > Tieline to display the tieline window and the tieline window is 
active (the border of the window will highlight). 

8.6.1 Sort Ascending 
The Tieline > Sort Ascending command sorts the tielines in ascending order. 

• Before using this command, you must have selected View > Tieline to open the Tieline 
window, and the Tieline window must be active.  To make the Tieline window active, 
select Window > Tieline Status. 

8.6.2 Sort Descending 
The Tieline > Sort Descending command sorts the tielines in descending order. 

• Before Using This Command, you must have selected View > Tieline to open the Tieline 
window, and the Tieline window must be active.  To make the Tieline window active, 
select Window > Tieline Status. 

8.7 PANEL MENU 
The Panel menu (see Figure 136) sorts information in the View > Panel Status window.  
Before you can access these commands, you must select View > Panel Status and the Panel 
Status window must be displayed.  The following commands are available: 
 

 

Figure 136: Panel Menu 

8.7.1 Sort Ascending 
The Panel > Sort Ascending command sorts information in the Panel Status window in 
ascending order.  

8.7.2 Sort Descending 
The Panel > Sort Descending command sorts information in the Panel Status window in 
descending order.  
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8.8 READBACK MENU 
The Readback menu (see Figure 137) sorts information in the View > Readback Status 
window.  Before you can access these commands, you must select View > Readback Status and 
the Readback Status window must be displayed.  The following commands are available: 

 

 

Figure 137: Readback Menu 

8.8.1 Sort Ascending 
The Readback > Sort Ascending command sorts information in the Readback Status 
window in ascending order.  

8.8.2 Sort Descending 
The Readback > Sort Descending command sorts information in the Readback Status 
window in descending order. 

8.8.3 Physical Switch 
The Readback > Physical Switch command allows you to perform simple takes, all call, and 
diagonal diagnostic procedures (see Figure 138).  

 

Figure 138: Physical Switch 
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8.8.3.1 Components to Switch 
Before working with the window, first select the component you want to switch.  The 
available components display in this drop-down list. 

8.8.3.2 Simple Take 
The Simple Take section switches a specific physical switch.  To perform a Simple Take 
sequence, complete the following: 

1. Select the Input and Output to switch. 

2. Select the Take button. 

8.8.3.3 All Call 
An all call is a diagnostic procedure that causes a single physical input to be switched to a 
range of physical outputs, for a specified component, with a single command. 

Example (see Figure 139):  Assume the existence of component RED spanning physical 
inputs 1 through 6 and physical outputs 1 through 6.  All call can be used to switch physical 
input 3, to physical outputs 2 through 6, with a single command. 

1 2 3 4 5 6 7 8

PHYSICAL
OUTPUTS

1
2
3
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7
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PHYSICAL
INPUTS

COMPONENT RED

 

Figure 139: All Call Example 

Complete the following to perform All Call function: 

1. Select the Starting Input 

2. Select the Starting Output. 

3. Select the Ending Output. 

4. Select the All call button. 
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8.8.3.4 Diagonal 
A diagonal is a diagnostic procedure that causes a range of physical inputs to be switched to a 
range of physical outputs, in a diagonal pattern starting from a specified coordinate and 
continuing until either the inputs or outputs are exhausted, for a specified component, with a 
single command. 

Example (see Figure 140): Assume the existence of component RED spanning physical 
inputs 1 through 6 and physical outputs 1 through 6. A diagonal with a starting input of 2 and 
a starting output of 1 would cause the following physical switches to be taken: (2,1), (3,2), 
(4,3), (5,4), and (6,5). 
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Figure 140: Diagonal Diagnostic Example 

Complete the following to perform a Diagonal sequence: 

1. Select the Starting Input 

2. Select the Starting Output. 

3. Select the Ending Output. 

4. Select the Wrap option to ensure that all of the inputs and outputs are processed.  

5. Select the Diagonal button. 

8.8.3.5 Restore Router 
Select the Restore Router button to return the routing switcher to the original state before you 
performed takes, all calls, or diagonal diagnostic procedures. 

8.8.3.6 Exit 
This function closes the Physical Switch window. 
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Chapter 9 - 3500Pro User Manager 
The 3500Pro Connection/User Manager (see Figure 141) module allows you to configure 
your computer connections and to add and edit users who can access the 3500Pro software. 

 

 

Figure 141: User Manager Window 
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9.1 CONNECTION TAB 
The Connection tab defines connection parameters used to connect the PC to the actual 
controller (see Figure 142). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 142: Connection Tab 

9.1.1 Serial Port Connection 
Select this check box if you will connect to the controller through a serial port. 

9.1.2 COM Port 
Select the COM Port you are using to connect to the controller if you are using a serial port 
connection.  

9.1.3 Baud Rate 
Select the baud rate for the connection if you are using a serial port connection. 

9.1.4 Network Connection 
Select this check box if you will connect to the controller through the network.  
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9.1.5 Controller Address 
Enter the TCP/IP address of the controller. 

9.1.6 Commit 
This applies your connection settings.  The settings you selected will display at the bottom of 
the window. 

9.1.7 Present Connection 
Displays the current method you are connecting to the controller, such as "RS-232/422 through 
COM1 at 38400 baud". 

9.1.8 Reinitialize Communications 
Reinitialize serial communications based on what is stored in registry.   

9.1.9 Controller Test 
This command performs a test to verify communication to the controller, similar to the 
Controller Status test in an earlier section of this manual.  A window will be displayed 
indicating whether communication was established.  If there is a communication error, you 
must recheck the physical connections to the controller.   

Refer to the Hardware chapter in this manual for detailed information about hardware setup.  
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9.2 USERS TAB 
The Users tab allows you to add, edit, and delete users (see Figure 143).  

 

User accounts are optional. If used, at least one user account must be 
assigned all privileges. If no user accounts are configured, all users have all 
privileges. 

 

Figure 143: Users Tab 

9.2.1 Adding a User 
1. Select the Add>> button.   

2. Enter a name for the user. 

3. Select the Set Password button, and enter a password for the user.  

 

Make sure each user knows his or her initial username and password. 

 

4. Select the privileges the user should have.  Just select each check box, and a check mark 
will display.  If the user needs access to everything, select the Set All button.  At least 
one user must be assigned all privileges. 

5. When you are done, select Commit.  The user will be added to the Available Users 
section in the left portion of the screen, and the user will now have access to the software. 
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9.2.2 Editing a User 
1. Select the user you want to edit from the Available Users list. 

2. Select the Edit>> button.  

3. Change any of the settings.  To change the password, select the Set Password button 
and enter the new password. 

4. Select the Commit button, and you changes will be saved. 

9.2.3 Deleting a User 
1. Select the user you want to delete from the Available Users list. 

2. Select the Delete button.  The user is removed from the Available Users list. 
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9.3 PATH OPTIONS TAB 
The Path Options tab (see Figure 144) displays information about the directory location of items 
in the 3500Pro configuration.  You cannot edit any of this information. 

 

Figure 144: Path Options Tab 
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Chapter 10 - Runtime Database Initialization 
The Runtime Database Initialization module makes new copies of the configuration and 
runtime databases (from the master copies).  Then, old versions of the databases are purged.  Use 
this option when you first install the software.  In addition, you can use this option if you are 
having problems with modules correctly reading current controller information.  For example, if 
you download a configuration to the controller, but the Status module is not recognizing the 
current setting, use this command.  This command will ensure that the databases the software is 
reading contain the most current information. 
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