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About This Manual 
 
This manual provides detailed instructions for the installation, operation, and maintenance of the 
PESA 3500Pro and 3500Pro LE Software and System Controller hardware. 

 
Warnings, Cautions, and Notes 
 

 

Warning statements identify conditions or practices that can result in 
personal injury or loss of life. 

 

Caution statements identify conditions or practices that can result in 
damage to equipment. 

 
Notes contain information important to the correct installation, operation, 

or maintenance of the equipment. 
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End User Commercial License Agreement 
 

Grant 
Subject to purchase of a PESA System Controller, PESA Switching Systems, Inc. (PESA) grants to you a non-
exclusive license to use the Software and accompanying documentation (“Documentation”) in the manner described 
below under “Scope of Grant.” 

Limited Warranty 
PESA warrants that for a period of ninety (90) days from the date of acquisition, the Software, if operated as 
directed, will substantially achieve the functionality described in the Documentation. PESA does not warrant, 
however, that your use of the Software will be uninterrupted or that the operation of the Software will be error-free 
or secure. In addition, the security mechanisms implemented by PESA software have inherent limitations, and you 
must determine that the Software sufficiently meets your requirements.  PESA also warrants that the media 
containing the Software, if provided by PESA, is free from defects in material and workmanship and will so remain 
for ninety (90) days from the date you acquired the Software. PESA’s sole liability for any breach of this warranty 
shall be, in PESA’s sole discretion: (i) to replace your defective media; or (ii) to advise you how to achieve 
substantially the same functionality with the Software as described in the Documentation through a procedure 
different from that set forth in the Documentation; or (iii) if the above remedies are impracticable, to refund the 
purchase price you paid for the System Controller. Repaired, corrected, or replaced Software and Documentation 
shall be covered by this limited warranty for the period remaining under the warranty that covered the original 
Software, or if longer, for thirty (30) days after the date (a) of shipment to you of the repaired or replaced Software, 
or (b) PESA advised you how to operate the Software so as to achieve the functionality described in the 
Documentation. Only if you inform PESA of your problem with the Software during the applicable warranty period 
and provide evidence of the date you purchased a license to the Software will PESA be obligated to honor this 
warranty. PESA will use reasonable commercial efforts to repair, replace, advise or, for individual consumers, 
refund pursuant to the foregoing warranty within 30 days of being so notified. 

THIS IS A LIMITED WARRANTY AND IT IS THE ONLY WARRANTY MADE BY PESA. PESA MAKES NO 
OTHER EXPRESS WARRANTY AND NO WARRANTY OF NONINFRINGEMENT OF THIRD PARTIES’ 
RIGHTS. THE DURATION OF IMPLIED WARRANTIES, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OF MERCHANTABILITY AND OF FITNESS FOR A PARTICULAR PURPOSE, IS LIMITED 
TO THE ABOVE LIMITED WARRANTY PERIOD; SOME JURISDICTIONS DO NOT ALLOW 
LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO LIMITATIONS MAY NOT APPLY 
TO YOU. NO PESA DEALER, AGENT, OR EMPLOYEE IS AUTHORIZED TO MAKE ANY 
MODIFICATIONS, EXTENSIONS, OR ADDITIONS TO THIS WARRANTY. If any modifications are made to 
the Software by you during the warranty period; if the media is subjected to accident, abuse, or improper use; or if 
you violate the terms of this Agreement, then this warranty shall immediately be terminated. This warranty shall not 
apply if the Software is used on or in conjunction with hardware or software other than the unmodified version of 
hardware and software with which the software was designed to be used as described in the Documentation.  THIS 
WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY HAVE OTHER LEGAL RIGHTS 
THAT VARY BY JURISDICTION. 

 

Scope of Grant 
You may:  
• use the Software on any single computer; 
• use the Software on a second computer so long as only one copy is used at a time;  
• copy the Software for archival purposes, provided any copy must contain all of the original Software’s 

proprietary notices.   
 
You may not:  
• permit other individuals to use the Software except under the terms listed above;  
• permit concurrent use of the Software;  
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• modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable laws specifically 
prohibit such restriction), or create derivative works based on the Software;  

• copy the Software other than as specified above;  
• rent, lease, grant a security interest in, or otherwise transfer rights to the Software; or  
• remove any proprietary  notices or labels on the Software. 
 
Title 
Title, ownership rights, and intellectual property rights in the Software shall remain in PESA and/or its suppliers. 
The Software is protected by the copyright laws and treaties.  Title and related rights in the content accessed through 
the Software is the property of the applicable content owner and may be protected by applicable law. This License 
gives you no rights to such content. 

Termination 
The license will terminate automatically if you fail to comply with the limitations described herein.  On termination, 
you must destroy all copies of the Software and Documentation. 

LIMITATION OF LIABILITY. UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, 
CONTRACT, OR OTHERWISE, SHALL PESA OR ITS SUPPLIERS OR RESELLERS BE LIABLE TO YOU 
OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER 
COMMERCIAL DAMAGES OR LOSSES. IN NO EVENT WILL PESA BE LIABLE FOR ANY DAMAGES IN 
EXCESS OF THE AMOUNT PESA RECEIVED FROM YOU FOR A LICENSE TO THE SOFTWARE, EVEN IF 
PESA SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY 
CLAIM BY ANY OTHER PARTY. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY 
FOR DEATH OR PERSONAL INJURY TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH 
LIMITATION. FURTHERMORE, SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION AND 
EXCLUSION MAY NOT APPLY TO YOU. 

Miscellaneous 
If the copy of the Software you received was accompanied by a printed or other form of “hard-copy” End User 
License Agreement whose terms vary from this Agreement, then the hard-copy End User License Agreement 
governs your use of the Software.  This Agreement represents the complete agreement concerning this license and 
may be amended only by a writing executed by both parties. THE ACCEPTANCE OF ANY PURCHASE ORDER 
PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON YOUR ASSENT TO THE TERMS SET 
FORTH HEREIN, AND NOT THOSE IN YOUR PURCHASE ORDER. If any provision of this Agreement is held 
to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable.  This 
Agreement shall be governed by Alabama law (except for conflict of law provisions). 
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FCC Statement 

This device complies with part 15 of the FCC Rules. Operation is subject 
to the following two conditions: 
 
(1) This device may not cause harmful interference, and 
 
(2) this device must accept any interference received, including 
interference that may cause undesired operation. 
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Section I:  Getting Started 
 
 

Welcome to the 3500Pro manual! This section describes the system and explains how to set up both the 
hardware and software. For more detailed information about the hardware and software, refer to Section 
II and Section III. 

 

The following topics are included in this section: 

 

• Product Description 

• Product Specifications 

• Installing the Hardware 

• Installing the Software 
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Chapter 1 – Introduction 
1.1 Product Description 

The 3500Pro System Controller is a low cost, full-featured microprocessor-based unit designed to 
interface with various configurations of PESA video and audio routing switchers. The 3500Pro 
System Controller, working in conjunction with the 3500Pro Control System software, enables 
users to configure and operate a routing switcher system from a standard IBM compatible PC. 
Both the 3500Pro System Controller and the 3500Pro Control System software are inherently 
flexible and easily configured. The 3500Pro LE has a smaller feature set and is designed for 
customers with smaller systems. 

The 3500Pro System Controller utilizes the Motorola 68332 embedded microprocessor. In 
addition, it is equipped with 4 MB of RAM, 2 MB of FLASH memory, and 8 serial UARTS 
making the 3500Pro System Controller a high-powered control platform for its size. 

The 3500Pro System Controller is capable of controlling up to a 576 input by 576 output, sixteen 
level routing switcher system. Standard features include independent control of each level, audio-
follow-video switching, virtual matrix mapping, and software reentry. Matrix segmentation 
(breakup) is also a standard feature. Matrix segmentation enables RGB, Y/C, or multiple levels of 
audio to be configured as smaller matrixes within a larger matrix. Multiple levels of lock priority, 
128 salvo capability, full diagnostics, and all-call switching are also included in the 3500Pro 
Controller's standard features plus the ability to configure 600 sources and destinations. 

The controller supports the low-cost RCP control panels manufactured by PESA. The control 
panels are connected via twisted pair cable and can be remotely located up to 4000 feet from the 
controller. The control panels communicate with the 3500Pro Controller over a standard RS-485 
interface. Two RS422 ports and two RS232 ports are provided for communications interface with 
the routing switcher system, the control system computer, and additional equipment items. 

The 3500Pro System Controller is available as a stand-alone unit (rack mountable) or as a plug-in 
unit for routing switchers. The 3500Pro Controller is fully compatible with PESA's System 5, 
Lynx, Cougar, Jaguar, Tiger, and Cheetah lines of audio and video routing switchers. 
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1.2 Models of the 3500Pro Controller 
The six models of the 3500Pro System Controller are described in the following table. 

Table 1. 3500Pro System Controller Basic Models 

Model Description 
3500Pro Internal controller. One or two may be installed in any large-

scale router (except the TDM3000). 
3500Pro-S Single: One controller in a 1RU chassis. 
3500Pro-D Dual: Two controllers in a 2RU chassis. 
3500Pro-SE Single Expandable: One controller installed in a 2RU chassis. 

Expand with Model 3500Pro-DE. 
3500Pro-LE Internal controller. One or two may be installed in any large-

scale router (except the TDM3000). 
3500Pro-LE-S Single: One controller in a 1RU chassis. 
3500Pro-LE-D Dual: Two controllers in a 2RU chassis. 
3500Pro-LE-SE Single Expandable: One controller installed in a 2RU chassis. 

Expand with Model 3500Pro-LE-DE. 
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1.3 Specifications 

1.3.1 Operational Environment 
Temperature ..................................................................................................0-40°C 

Operational Humidity ....................................................... 0-90% Non-Condensing 

1.3.2 Physical Characteristics 
3500Pro-S 

 Height ........................................................ 1.75 in (45 mm) (1 Rack Unit) 
 Width ................................................................................. 19 in (483 mm) 
 Depth.................................................................................... 8 in (203 mm) 
  

 

3500Pro-D 

 Height .......................................................3.50 in (89 mm) (2 Rack Units) 
 Width ................................................................................. 19 in (483 mm) 
 Depth.................................................................................. 10 in (254 mm) 
  

1.3.3 Power 
3500Pro-S 

 Input ................................................................................ 8.5 +1.5 VDC 
 Input Connector, 3500-S.......................................... 3-Contact Proprietary 
  

3500Pro-D 

 Input ................................................................................ 8.5 +1.5 VDC 
 Input Connector, 3500-D ......................................... 6-Contact Proprietary 
  

PS130 Internal Power Supply (Optional for 3500Pro-D Only) 

 Part Number...................................................................... 81-9065-2048-0 
 Input ............................................................... 105-240 VAC, 50-60 Hz 
 Input Connector IEC 320 Receptacle 
 Output .........................................................................+8.9 VDC at 5.5 A 
 

1.3.4 IEC 320 Line Cords 
 US 
  Part Number ............................................................... 81-9028-0403-0 
  Connectors........................................... IEC 320-C13 to NEMA 5-15P 
 UK 
  Part Number ............................................................... 81-9028-TBD-0 
  Connectors.................................................IEC 320-C13 to BS 1363A 
 Euro 
  Part Number ............................................................... 81-9028-0411-0 
  Connectors....................................... IEC 320-C13 to CEE 7/7 Schuko 
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1.3.5 Communications 
 Number of RS-232 Ports........................................................................... 2 
 Number of RS-422 Ports........................................................................... 2 
 Data Rate......................................................................... 9600/38400 baud 
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Chapter 2 – Installing and Setting up  
the System 

 

To get started with the 3500Pro system, first you need to install and set up the hardware. Next, 
you need to connect the hardware to the computer that will run the3500Pro software. Finally, you 
will install the 3500Pro software and establish communication with the hardware. This chapter 
describes how to perform these steps.  This chapter provides basic instructions for setting up your 
system. For detailed information about the hardware and how to operate it, see Section II.  For 
detailed information about the software and how to work with it, see Section III. 

2.1 Shipping Damage Inspection 
Immediately upon receipt, all shipping containers should be inspected for damage caused in 
transit. If any damage is noted, save all packing material and contact both PESA and the carrier as 
soon as possible. 

2.2 Unpacking 

 

This equipment contains static sensitive devices. A grounded wrist strap and 
mat should be used when handling the 3500Pro System Controller. 

 

Carefully unpack the equipment and compare the parts received against the packing list. If any 
parts appear to be missing, please contact PESA immediately. 

 

2.3 Installation Location 
This equipment is designed to be installed in a standard 19-inch equipment rack located in an 
environment conforming to the specifications shown in Chapter 1. Each unit should be located as 
close as possible to its associated equipment to minimize cable runs. Sufficient space must be 
provided behind the equipment racks to allow for control, signal, and power cables. All panel 
mounting holes should be utilized and mounting hardware tightened securely. 

Consideration should be given to the connection of this equipment to the supply circuit and the 
effect that possible overloading could have on overcurrent protection circuits and supply wiring.  
Refer to the nameplate ratings when addressing this concern. 

Install the equipment into the rack as follows: 

1.  Insert the panel assembly into the equipment rack and support the bottom of the panel 
assembly until all mounting hardware has been installed and properly tightened. 

2.  Install the bottom two panel mounting screws. 

3.  Install the top two panel mounting screws. 

4. Install any remaining panel mounting screws. 

5.  Tighten all of the panel mounting screws until they are secure. 
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2.4 Internal Installation - Model 3500Pro 
One or two 3500Pro or 3500Pro LE System Controllers can be installed in a any of the large scale 
routers except for the TDM3000. For detailed instructions for installing the controller, refer to the 
related product manual.  

2.5 Interface Connections 
For reasons of personal safety, and to prevent damage to the equipment or cables, the following 
guidelines should be followed when connecting cables to this equipment. 

1. Install the equipment in the rack before connecting cables. 

2. All cables should be carefully strain relieved to prevent connector separation. 

3. To the extent possible, separate control, signal, and power cables to minimize crosstalk and 
interference. 

4. The liberal use of nylon cable ties to secure cables to the rack is encouraged. This will 
minimize the amount of force transmitted to the equipment and help route cables away from 
hazardous areas. 

5. Route cables away from walk areas to avoid creating a safety hazard. 
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2.5.1 Model 3500-S Connection Guide 
The following section shows how to connect the 3500Pro and 3500Pro-S. For detailed 
information about each available option, refer to Section II.   
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2.5.2 Models 3500Pro-D (and 3500Pro-SE / 3500Pro-DE) Connection Guide 
The following section shows how to connect the 3500Pro-D, SE, and DE. For detailed 
information about each available option, refer to Section II. 
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2.6 Installing the Software 
After installing the hardware and establishing a connection with the computer where you will 
install the software, you need to install the 3500Pro software. Then you can create a basic 
configuration to communicate with the controller. This chapter describes how to do this. 

Before you start this procedure, make sure you have connected the 3500Pro System Controller to 
the PC where you will install the software (as shown below).  
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Figure 3. Connecting the 3500Pro-S to the PC 
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Systems using an internal 3500Pro are different depending on the type of 
system you purchased. However, you will always need to establish a 
connection from the COM1 port or the Serial 1 Port to the PC. 
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2.6.1 Hardware and Software Requirements 
 

The minimum PC requirements to run Win3500Pro are: 

• Processor:  500 MHz 

• Memory:  128 MB of RAM 

• Monitor:  800X600 SVGA 

• Serial Port:  One serial port available from COM1 through COM4 available for CPU 
Link use (Minimum of a 16550 UART preferred.) 

• Hard Disk:  100 MB of available space  

• Operating System:  Microsoft® Windows® NT™ 4.0, Microsoft Windows 2000, and 
Microsoft Windows XP (Home and Pro) 
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2.6.2 General Specifications Table 
 

3500Pro                      3500Pro LE 

Max. Number of Levels 16 8 

Max Number of 
Inputs/Outputs per Level 

576 144 

Max Number of 
Components 

32 16 

Max Number of Tielines 64 0 

Max Number of 
Categories 

254 254 

Max Number of Sources 600 180 

Max Number of 
Destinations 

600 180 

Max Number of Reentries 8 0 

Max Number of Salvos 128 (1024 switches 
can be allocated 
across all 128 
salvos) 

 

 

64 

3500Pro and 3500Pro LE 

Lock Priority Range 0-255 ("0" is Highest Priority) 

Max Number of Control 
Panels 

500 

Panel Address Range 1-1023 

Panel Requestor Code 
Range 

1-65535 

Chop Rate 1-255 Frames 

Component Types RM5 (System 5) PRC, XTN, TGR 

Offset Range 0-255 0-4094 

Strobe Range 1-5 1-63 

Address Range 1-255 1-4095 
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2.6.3 Read This First! 

 

Installing the 3500Pro software is not a simple procedure. You must follow 
the instructions in this guide EXACTLY. Please read through this 
document before you install the software. Please follow the detailed 
instructions EXACTLY to insure proper installation! 

 

2.6.4 Important Information for Windows NT Users! 
Although the 3500Pro runs on Windows NT 4.0, it is highly suggested that you migrate your 
operating system to Windows 2000 or Windows XP (Home or Professional).   Upgrading your 
software allows you to take advantage of newer Microsoft technologies that are marginally 
supported under Windows NT 4.0.   

If you are going to install the 3500Pro under Windows NT 4.0, you must install the Microsoft 
Transaction Server (MTS).  The MTS installation package is included on your 3500Pro CD or 
from the Windows NT Option Pack available from Microsoft:  

http://www.microsoft.com/ntserver/nts/downloads/recommended/NT4OptPk/default.asp 

The web page provides instructions for installing the service pack. Follow the instructions 
exactly! 

 

Depending upon the Service Pack that you have installed, some MTS 
installation programs may not be able to successfully install MTS.  If the MTS 
supplied with the 3500Pro does not install, you will need to install the NT 
Option Pack.   

Installing the MTS will require you to reboot your machine. 

2.6.5 Installing on Microsoft Windows 2000 and XP 

2.6.5.1 Starting the Setup 
Follow these steps to install the software. 

1. Insert the 3500Pro CD into the CD drive. 

2. Double-click the My Computer icon on your desktop.  The following window displays. 
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Figure 5. My Computer Window 

3. Double-click the CD drive with the 3500Pro software CD (labeled V1.1 3500PRO GUI). 
The following window displays. 

 

Figure 6. 3500Pro GUI CD 

4. Double-click the Win2k-xp directory.  
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5. The following window shows the icons available for installing for Windows 2000 and 
Windows XP.  Double-click the 3500Pro Win2K-XP V1.1 Install icon to start the 
install process.   

 

Figure 7. Installing on Windows 2000 or Windows XP 

2.6.5.2 Installing Microsoft Data Access Components 
When you start the install, the window shown in Figure 5 displays. Follow the directions in this 
section to continue installing the software. 

1. Before the 3500Pro software can be installed, Microsoft Data Access Components (MDAC) 
must be installed. Select OK in the following window. 

 

 
Figure 8. MDAC Installation Notice 

 

 

If your computer already has MDAC installed, this step will simply be 
skipped and you will not need to reboot. Instead go directly to step 1 in the 
following section “Installing the 3500Pro Software”. 
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The following prompt displays and MDAC will be installed. 

 

Figure 9. Second MDAC Installation Notice 

 

2. After MDAC is successfully installed, the following prompt displays. You must reboot your 
computer to proceed with the installation of 3500Pro. Make sure all other applications are 
closed, then select OK in this window. 

 

 

Figure 10. MDAC Successful Installation Notice 
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2.6.5.3 Installing the 3500Pro Software 
1. After you reboot, this window will automatically display.  Do not open any other Windows 

applications while installing 3500Pro. Select Next to proceed with the installation.  

 

 

Figure 11. 3500Pro Install Window 

2. Use the Browse button to select the location for the 3500Pro software. You can install it in 
any directory on your computer, or you can create a new directory. When the correct 
directory location displays in the following window, select Next. 

 

 
Figure 12. Install Location Window 
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3. If you select the Browse button, this window will display. Select the drive where you want to 
install the software. If you want to create a new directory, type in the new directory path in 
the top of the window. When the correct directory location displays, select OK. 

 

 

Figure 13. Select Destination Directory Window 

4. Next, select the components you want to install. Each item that you want to install should 
have a check mark displayed. “Configurator” is the Configuration Editor where you set up 
configuration files. “Status” is the Status module that allows you to monitor the 3500Pro 
system.  “Diagnostics” allows you to troubleshoot the system. Select the options you want to 
install and select Next. 

 

 
Figure 14. Select Components Window 
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5. When the following screen displays, select Next. 

 

Figure 15. Start Installation Window 

 

6. The software will install, and the following screen will show the progress. 

 

 
Figure 16. Install Progress Window 

 

PESA SWITCHING SYSTEMS  19 



81-9059-0549-0 Rev B  3500PRO SOFTWARE AND SYSTEM CONTROLLER 

7. Then, this window displays. You do not need to do anything. 

  

 
Figure 17. MSDE Install Notice 

 
8. After this process completes, your computer will restart. After it reboots, log back into your 

computer, and the install process will automatically continue.   

You will see the same screens that displayed during steps 1-6.  Select the same options and 
directory location that you selected during the first part of the install.   

After the process shown in Figure 16 is complete a second time, you will see the following 
window: 

 

Figure 18. Updating System Configuration 

After a few minutes, another window will display. This will show you the status of the actual 
installation procedure. You do not have to do anything during this process. 

 

 

Figure 19. Installation Progress 

9. After this process completes, the final window displays. Select Finish to complete the 
software installation process. 
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Figure 20. Finish the Installation 

 

2.6.5.4 Install the SQL Server Service Pack 3 
You also need to install the SQL Server Service Pack 3 software before you can use the 3500Pro.   

1. Double-click the sql70sp3i.exe program from the install CD directory. The following 
window displays. 

 
Figure 21. SQL Server Service Pack Install Window 

 
2. Make sure the following directory is listed in this window:   C:\70SP3 
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If your computer already has this software installed, a prompt will display. 
You can choose to either overwrite the existing software or exit the 
installation. 

3. Open your Explorer program and change to the C:\70SP3 directory. 

4. Double-click SETUP.BAT. An install window will display. Follow the instructions to 
proceed. 

5. When the following window displays, select the first button. If this is the first time you have 
installed this software, leave the password field blank.  If you have installed this software 
before, enter the password sa in the password field.  Select Next to continue. 

 
Be sure to change this setting!   

 

 
Figure 22. Connect to Server Window 
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6. When prompted (toward the end of the process), add the user to “sa” with the password to 
"sa".  (Use the mixed mode option) 

 
Be sure to change this setting!   

 

 
Figure 23. Adding a Password 

The service pack has now been installed.  The PC will reset to finish the installation.   

2.6.5.5 Initialize the Database 
Before you open the 3500Pro software, you must initialize the database.   

1. Select Start > Programs > PESA 3500Pro  > Runtime Database Initialization. The 
following window displays: 

 

Figure 24. Runtime Database Initialization 

2. This batch file will create new empty databases from the master database template. After this 
process is complete, the window closes and you can move on to the next step. 
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2.6.6 Installing on Microsoft Windows NT 

2.6.6.1 Starting the Setup 
Follow these steps to install the software. 

1. Insert the 3500Pro CD into the CD drive. 

2. Double-click the My Computer icon on your desktop.  The following window displays. 

 

Figure 25. My Computer Window 

3. Double-click the CD drive with the 3500Pro software CD (labeled V1.1 3500PRO GUI). 
The following window displays. 

 

Figure 26. 3500Pro GUI CD 
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5. Double-click the winnt directory.  

6. The following icons are available. Double-click the 3500Pro NT V1.1 Install icon to 
start the install process.  

 

Figure 27. Installing on Windows NT 

2.6.6.2 Installing Microsoft Data Access Components 
When you start the install, the window shown in Figure 5 displays. Follow the directions in this 
section to continue installing the software. 

1. Before the 3500Pro software can be installed, Microsoft Data Access Components (MDAC) 
must be installed. Select OK in the following window. 

 

 
Figure 28. MDAC Installation Notice 

 

 

If your computer already has MDAC installed, this step will simply be 
skipped and you will not need to reboot. Instead go directly to step 1 in the 
following section “Installing the 3500Pro Software”. 
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The following prompt displays and MDAC will be installed. 

 

Figure 29. Second MDAC Installation Notice 

 

2. After MDAC is successfully installed, the following prompt displays. You must reboot your 
computer to proceed with the installation of 3500Pro. Make sure all other applications are 
closed, then select OK in this window. 

 

 

Figure 30. MDAC Successful Installation Notice 
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2.6.6.3 Installing the 3500Pro Software 
1. After you reboot, this window will automatically display.  Do not open any other Windows 

applications while installing 3500Pro. Select Next to proceed with the installation.  

 

 

Figure 31. 3500Pro Install Window 

2. Use the Browse button to select the location for the 3500Pro software. You can install it in 
any directory on your computer, or you can create a new directory. When the correct 
directory location displays in the following window, select Next. 

 

 
Figure 32. Install Location Window 
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3. If you select the Browse button, this window will display. Select the drive where you want to 
install the software. If you want to create a new directory, type in the new directory path in 
the top of the window. When the correct directory location displays, select OK. 

 

 

Figure 33. Select Destination Directory Window 

4. Next, select the components you want to install. Each item that you want to install should 
have a check mark displayed. “Configurator” is the Configuration Editor where you set up 
configuration files. “Status” is the Status module that allows you to monitor the 3500Pro 
system.  “Diagnostics” allows you to troubleshoot the system. Select the options you want to 
install and select Next. 

 

 
Figure 34. Select Components Window 
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5. When the following screen displays, select Next. 

 

Figure 35. Start Installation Window 

 

6. The software will install, and the following screen will show the progress. 

 

 
Figure 36. Install Progress Window 
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7. Then, this window displays. You do not need to do anything. 

  

 
Figure 37. MSDE Install Notice 

 
8. After this process completes, your computer will restart. After it reboots, log back into your 

computer, and the install process will automatically continue.   

You will see the same screens that displayed during steps 1-6.  Select the same options and 
directory location that you selected during the first part of the install.   

After the process shown in Figure 36 is complete a second time, you will see the following 
window: 

 

Figure 38. Updating System Configuration 

After a few minutes, another window will display. This will show you the status of the actual 
installation procedure. You do not have to do anything during this process. 

 

 

Figure 39. Installation Progress 
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9. After this process completes, the final window displays. Select Finish to complete the 
software installation process. 

 
Figure 40. Finish the Installation 

 

Go on to the next section to continue the installation. 
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2.6.6.4 Installing the Microsoft Transaction Server (Windows NT ONLY) 
If you are running Microsoft Windows NT, you must install the Microsoft Transaction Server.  

 

Depending upon the Service Pack that you have installed, some MTS installation 
programs may not be able to successfully install MTS.  If the MTS supplied with 
the 3500Pro does not install, you will need to install the NT Option Pack: 

Installing the MTS will require you to reboot your machine. 

http://www.microsoft.com/ntserver/nts/downloads/recommended/NT4OptPk/default.asp

 

1. Double-click the mts11x86 icon in the install directory.  

 

Figure 41. Installing MTS 

2. The following screen displays. Select Yes. 
 

 
Figure 42. Install Prompt 
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Several processes will run, and you do not have to do anything. Next, the following window 
displays. 

 
3. Read the agreement, then select I Agree. 

 

 
Figure 43. MTS License Agreement 

4. The following window displays. Enter your name and your company name, then select OK. 
 

 
Figure 44. Name and Organization Information 
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5. Confirm the name and organization information, then select OK. 

 

Figure 45. Confirm Name and Organization 

5. The following window displays. Select the first button, Microsoft Transaction Server. 
 

 

Figure 46. MTS Setup Window 
 

6. The following screen displays. Select Yes. 
 

 
Figure 47. System Server Process Window 
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7. The following window displays.  The first check box is selected by default.  Do not change 
any settings in this window, and select OK. 

 
Figure 48. Interactive User Screen 

8. The following window displays. Select Yes. 
 

 
Figure 49. MS DTC Window 

 
9. The software will now install. When installation is complete, you will be prompted to reboot.  

Go on to the next section. 

 

If you see an error that MTS did not successfully install, you will need to 
install the NT Option Pack: 

http://www.microsoft.com/ntserver/nts/downloads/recommended/NT4OptPk/defau
lt.asp 
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2.6.6.5 Install the SQL Server Service Pack 3 
You also need to install the SQL Server Service Pack 3 software before you can use the 3500Pro.   

1. Double-click the sql70sp3i.exe program from the install CD directory. The following 
window displays. 

 
Figure 50. SQL Server Service Pack Install Window 

 
2. Make sure the following directory is listed in this window:   C:\70SP3 

 

If your computer already has this software installed, a prompt will display. 
You can choose to either overwrite the existing software or exit the 
installation. 

6. Open your Explorer program and change to the C:\70SP3 directory. 

7. Double-click SETUP.BAT. An install window will display. Follow the instructions to 
proceed. 

8. When the following window displays, select the first button. If this is the first time you have 
installed this software, leave the password field blank.  If you have installed this software 
before, enter the password sa in the password field.  Select Next to continue. 

 
Be sure to change this setting!   
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Figure 51. Connect to Server Window 
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6. When prompted (toward the end of the process), add the user to “sa” with the password to 
"sa".  (Use the mixed mode option) 

 
Be sure to change this setting!   

 

 
Figure 52. Adding a Password 

The service pack has now been installed.  The PC will reset to finish the installation.   

2.6.6.6 Initialize the Database 
Before you open the 3500Pro software, you must initialize the database.   

2. Select Start > Programs > PESA 3500Pro  > Runtime Database Initialization. The 
following window displays: 

 

Figure 53. Runtime Database Initialization 

2. This batch file will create new empty databases from the master database template. After this 
process is complete, the window closes and you can start using the 3500Pro software. 
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2.6.7 Downloading a Configuration to the Controller 
You can test the connection between the computer and the controller by downloading a sample 
configuration file to the controller.  A sample file is available on the product CD and is called 
“cougar combo numeric”. 

 

This will change the settings on the controller. Do not perform these steps if you 
do not want the current configuration to be overwritten! 

 

If you have an existing configuration file, you can use it to test the connection 
instead of the delivered sample file. 

 

1. When you are done with all the installation steps, you can open the 3500Pro Configuration 
Editor by selecting Start > Programs > 3500Pro > Configuration Editor. 

2. Select File > New Configuration Database. Enter a name for the new configuration and 
select Open.  

3. The software will ask if you want to create the file. Select Yes. 

4. Select File > Transfer Configuration.   

5. Select Import Configuration From ASCII File, then select Execute.   

6. Change to the CD drive with the 3500Pro installation CD.  You will see a file called “cougar 
combo numeric”.  Select this file then select Open. When Import is Complete displays, 
select OK.   

6. Now, select Download Configuration to Controller and select Execute.  A prompt asks if 
you want to continue. Select OK.  

7. This will send the information in the configuration file you just opened to the controller.  You 
will see: 

 Exporting the configuration to a file.   
 Downloading to the Controller. 
 Configuration Download is complete! 

 

Congratulations! You have established a connection.  

Now, you can start to customize the configuration file to suit your requirements.  Go on to 
Section III for detailed instructions for adding to your configuration and customizing it for your 
applications. 
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Section II:  Hardware Reference Guide 
 
 
The section provides detailed information about the 3500Pro System Controller hardware.  The 3500Pro-
S and 3500Pro-D are both described. 
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Chapter 3 – Hardware Description 
 

This chapter provides descriptions for all of the available features in the 3500Pro-S and 3500Pro-
D System Controllers. For details about internal 3500Pro controllers, refer to the appropriate 
routing switcher manual. 

3.1 Model 3500Pro-S 
All interface connections are made at the rear of this equipment as shown in the following figure. 

CPU ALARM1 PRINTER

3300/3500 SYNC
6600 POLLING PORTS

2 3 4
COM3/PRC

COM4
COM2 COM1 AUXILIARY STROBESYSTEM V CONTROL

21 3

PANEL PORTS

4

485

GNDGND

+V

-V -V

+V

POWER

 
Figure 54. 3500Pro-S Rear View 

3.1.1 3300/3500Pro SYNC / 6600 POLLING PORT 1 (J1) 
This BNC connector is used for an optional vertical sync signal input. If it will not be used, 
install a 75 Ohm terminator (Part No. 81-9029-0668-4). This signal allows for switches to be 
scheduled for vertical interval timing.    
 

3.1.2 6600 POLLING PORTS 2, 3, and 4 (J2, J3, J4) 
These BNC connectors are reserved for future use. There is no internal connection and they 
do not need to be terminated. 

3.1.3 PRINTER (J5) 
This DB25-Female connector is reserved for future use. See the following figure for an 
orientation view showing contact locations. 

1

14

2345678910111213

1516171819202122232425

Contact locations when viewed
from rear of chassis.  

Figure 55. 3500Pro-S J5 (PRINTER) Connector 
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3.1.4 COM 1 (J14), COM 2 (J13) 
These DB9-Male connectors provide RS-232 serial communication interfaces. See Figure 56 for 
an orientation view showing contact locations. 

COM 1 is the primary RS-232 CPU Link and may be connected to the PC running 3500Pro 
Control System software with a null modem cable (Part No. 81-9028-0393-0). If necessary, a 
cable up to 50 feet in length may be fabricated in the field as shown in Figure 57. COM 1 may 
only be used with the P1E protocol, at either 9600 or 38400 baud. The communication rate is 
selected with switch S1 as described in “S1-3 COM 1 Rate” on page 60. 

If necessary, a cable up to 50 feet in length may be fabricated in the field as shown in Figure 58. 

COM 2 is a secondary RS-232 CPU Link which may also be connected to a PC or external 
modem. COM 2 may be used with any of the protocols shown in the following table and may 
operate at either 9600 or 38400 baud. The communication rate for COM 2 is determined by 
settings made in the 3500Pro software. The  pinout for COM2 is identical to COM1. 

Table 2. PESA CPU Link Protocols 
Protocol Document No. 

CPU Link Protocol No. 1 (P1) 81-9062-0407-
0 

CPU Link Protocol No. 1 Extensions 
(P1E) 

81-9062-0408-
0 

Unsolicited Status Protocol (USP) 81-9062-0409-
0 

Truck Link Protocol (TRK) 81-9062-0410-
0 

Contact locations when viewed
from rear of chassis.

54321

9876

 
Figure 56. 3500Pro-S J13, J14 (COM 1, COM 2) Connectors 

 

CD (Carrier Detect)

RX (Receive Data)
TX (Transmit Data)

DTR (Data Terminal Ready)
SG (Signal Ground)
DSR (Data Set Ready)

RTS (Ready To Send)
CTS (Clear To Send)

RI (Ring Indicator)

DB-9 Female To:
3500Plus-S J13 or J14

CTS (Clear To Send)
RTS (Ready To Send)
DSR (Data Set Ready)

DTR (Data Terminal Ready)

RX (Receive Data) 2

RI (Ring Indicator)

SG (Signal Ground)

TX (Transmit Data)

9
8
7
6
5
4
3

CD (Carrier Detect) 1
3

9
7
8

5
6
2

4

DB-9 Female To:
PC

1

 
Figure 57. 3500Pro-S RS-232 CPU Link (Null Modem) Cable 
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DSR (Data Set Ready)
RTS (Ready To Send)
CTS (Clear To Send)

DTR (Data Terminal Ready)

DB-9 Female To:
3500Plus-S J13 or J14

3TX (Transmit Data)

SG (Signal Ground)

RI (Ring Indicator)

5
6
7
8
9

4

CD (Carrier Detect)
RX (Receive Data)

1
2

RI (Ring Indicator)

RTS (Ready To Send)
CTS (Clear To Send)

DTR (Data Terminal Ready)
SG (Signal Ground)
DSR (Data Set Ready)

RX (Receive Data)
TX (Transmit Data)

CD (Carrier Detect)

2

6
7

4
5

22

20

DB-25 Male To:
 External Modem

8
3

 
Figure 58. 3500Pro-S RS-232 CPU Link (AT Serial Modem) Cable 

 

3.1.5 COM 3/PRC (J12), COM 4 (J6) 
These DB9-Male connectors provide RS-422 serial communication interfaces. See Figure 59 
for an orientation view showing contact locations. 
 

• COM 3/PRC is the communications interface to a PRC type routing switcher system 
and is connected to a routing switcher. If necessary, a cable up to 4000 feet in length 
may be fabricated in the field as shown in Figure 60.   

• COM 4 is an RS-422 CPU Link similar to the RS-232 CPU Link, except the cable 
may be up to 4000 feet in length and an RS-422 interface card must be installed in 
the expansion bus. COM 4 may be used with any of the protocols shown in Table 2 
on page 43. If necessary, a cable may be fabricated in the field as shown in Figure 61. 

Contact locations when viewed
from rear of chassis.

6 7 8 9

1 2 3 4 5

 
Figure 59. 3500Pro-S J6, J12 (COM 3/PRC, COM 4) Connectors 

 

 

System Controller TX+ (High)
System Controller TX- (Low)
Chassis Ground
System Controller RX+ (High)
System Controller RX- (Low)
Chassis Ground
Chassis Ground
Chassis Ground
Chassis Ground

DB-9 Female To:
3500Plus-S J12

6Chassis Ground
Chassis Ground 9

System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

Chassis Ground
Chassis Ground

Chassis Ground

5
4
7
2
1
3
8

6
9

5
4
7
2
1
3
8

DB-9 Female To:
PRC Type Device

 
Figure 60. 3500Pro-S RS-422 Serial Cable 
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System Controller RX- (Low)
System Controller RX+ (High)

System Controller TX- (Low)
System Controller TX+ (High)

6Chassis Ground
Chassis Ground 9

DB-9 Female To:
3500Plus-S J6

System Controller RX+ (High)
System Controller RX- (Low)

System Controller TX- (Low)
System Controller TX+ (High)

Chassis Ground
Chassis Ground

Chassis Ground

2
7

8
3
4
5

1

Customer supplied 
Connector

 
Figure 61. 3500Pro-S RS-422 CPU Link Cable 

 

3.1.6 CPU ALARM (J7) 
This 3-contact connector provides the interface for the CPU alarm. See Figure 62 for an 
orientation view showing contact locations. 

The 3500Pro operating software determines when an alarm condition is declared. During an 
alarm condition, an optically isolated, closed circuit exists between contacts 1 and 3. The 
customer supplied external alarm circuit is connected with a cable constructed as shown in Figure 
63. 

The 81-9029-0780-0 connector body has an integral strain relief which requires the use of a nylon 
cable tie included with the connector. If this is not available, cable tie Part No. 81-9021-0028-8 
may be used. 

 

 

The alarm circuit connected to this connector must not exceed 12VDC or 
10mA. 

Contact locations when viewed
from rear of chassis.

3 2 1

 
Figure 62. 3500Pro-S J7 (CPU ALARM) Connector 

81-9029-0780-0 To:
3500Plus-S J7

Customer Supplied
Connector

Chassis Ground
3Alarm Low
2

Alarm High 1

 
Figure 63. 3500Pro-S CPU Alarm Cable 
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3.1.7 485 PANEL PORTS 1-4 (J8, J9, J10, J11) 
These 3-contact connectors are wired in parallel and provide RS-485 serial communication 
interfaces using the PESA RCP Protocol (Document No. 81-9062-0300-0). See Figure 64 for an 
orientation view showing contact locations. 

J8, J9, J10, and J11 are connected to PESA Remote Control Panels with daisy-chained cables 
constructed with 3-contact connectors (Part No. 81-9029-0780-0) and shielded, twisted-pair audio 
cable (Part No. 81-9028-0043-2, Belden 8451, or equivalent) as shown in Figure 65. The 
connector body has an integral strain relief which requires the use of a nylon cable tie which is 
included with the connector. If this cable tie is not available, Part No. 81-9021-0028-8 may be 
used. 

1

Contact locations when viewed
from rear of chassis.

23

 
Figure 64. 3500Pro-S J8, J9, J10, J11 (485 PANEL PORTS 1-4) Connectors 

 

RCP connector
contact locations
when viewed from

rear of chassis.

High (+)
Low (-)

81-9029-0780-0 To:
3500Plus-S J8, J9, J10 or J11

Shield (S)

1
3
2

Additional RCPs may be 
daisy-chained together 

as required.

1
3
2

1

2
3

81-9029-0780-0 To:
Remote Control Panel

1
3
2

High (+)
Low (-)
Shield (S)

3

-

1

+

2

S

 
Figure 65. 3500Pro-S RS-485 Serial Cable 
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3.1.8 SYSTEM V CONTROL (J15) 
This DB37-Male connector provides the System 5 control interface and uses the RM5 Protocol 
(Document No. 81-9062-0155-3). See Figure 66 for an orientation view showing contact 
locations. 

J15 is connected to a Lynx or RM5 type routing switcher with cable assembly Part No. 
81-9065-1189-2. If necessary, a cable may be fabricated in the field as shown in Figure 67. If 
more than one System 5 Routing Switcher will be connected to the System Controller, consult 
Drawing No. WI50-0262 for information on constructing a bifurcated cable. 

Contact locations when viewed
from rear of chassis.

1119 18 17 16 15 14 13 12

37 36 35 34 33 32 3130 29

10 9 8

28 27 26

7 6 5 4 3 2

202524 23 22 21

1

 
Figure 66. 3500Pro-S J15 (SYSTEM V CONTROL) Connector 
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8
9

DB-37 Female To:
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37
36
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27
28
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31

37

29

36
35
34
33
32
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28
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24
23
22

14

21
20
19
18
17
16
15

11
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13

10

Ground

Strobe 1

Read/Write
Primary/Secondary

Vertical Trigger Inhibit

Strobe 2
Strobe 3
Strobe 4
Strobe 5

Readback Data Bit 3
Readback Data Bit 4
Readback Data Bit 5
Readback Data Bit 6
Readback Data Bit 7
Readback Data Bit 8
Readback Data Bit 9

Input Address Bit 6

Output Address Bit 5

Output Address Bit 9
Output Address Bit 8
Output Address Bit 7
Output Address Bit 6

Confidence
Readback Data Bit 1
Readback Data Bit 2

Input Address Bit 9
Input Address Bit 8
Input Address Bit 7

Output Address Bit 4
Output Address Bit 3
Output Address Bit 2
Output Address Bit 1

Input Address Bit 1

Input Address Bit 3

Input Address Bit 5
Input Address Bit 4

Input Address Bit 2

 
Figure 67. 3500Pro-S RM5 Control Cable 
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3.1.9 AUXILIARY STROBE (J16) 
This DB15-Male connector is reserved for future use. See Figure 68 for an orientation view 
showing contact locations. 

Contact locations when viewed
from rear of chassis.

9 10 11 12 1314 15

1 2 3 4 5 6 7 8

 
Figure 68. 3500Pro-S J16 (AUXILIARY STROBE) Connector 

 

3.1.10 POWER (J17, J18) 
These 3-contact connectors are the power connectors. See Figure 69 for an orientation view 
showing contact locations. 

 

 

To avoid damage to the 3500Pro-S System Controller, the power connectors 
(J17 and J18) must never be connected to any of the following: 
• A Lynx, Cougar or Jaguar audio routing switcher 
• An external audio power supply (PS140A or PS270A) 
• An RM5000 video routing switcher or its external power supply 

(PS270V) 
 

The Model 3500Pro-S has no internal power supply. J17 and J18 are connected in parallel. One is 
used for power input and the other may be used as a loop-through connector to provide power to 
another device. Input power may be drawn from the following sources: 

The 3500Pro-S may obtain power from PESA system components having 3-contact power 
connectors by using a power cable assembly (Part No. 81-9065-1183-7) constructed as shown in 
Figure 70. If this cable must be constructed in the field, consult Drawing No. WI50-0172 for 
assembly details.  

The 3500Pro-S may obtain power from PESA system components having 6-contact power 
connectors by using a power cable assembly (Part No. 81-9065-1653-0) constructed as shown in 
Figure 71. If this cable must be constructed in the field, consult Drawing No. WI50-0238 for 
assembly details.  
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Contact locations when viewed
from rear of chassis.

1

2

3

 
Figure 69. 3500Pro-S J17, J18 (POWER) Connectors 

GND (BLK)
+V (RED)

-V (WHT)

81-9029-0649-4 To:
3500Plus-S J17 or J18

1
2
3 3

1

81-9029-0649-4 To:
Power Source

2

 
Figure 70. 3500Pro-S Power Cable with 3-Contact Plug 

-V (WHT)

+V (RED)
GND (BLK)

81-9029-0649-4 To:
3500Plus-S J17 or J18

3
2
1

81-9029-0160-2 To:
Power Source

5
4

6
1
2
3

 
Figure 71. 3500Pro-S Power Cable with 6-Contact Plug 
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3.2 Models 3500Pro-D (and 3500Pro-SE / 3500Pro-DE) 
All interface connections are made at the rear of this equipment as shown in Figure 72. 

PWR
EXTERNAL 

ALARM
PWR DUAL SYSTEM CONTROLLER

COM 2

COM 3 / PRC PRC

SYNC

COM 4

COM 1

CPU
ALARM

  4
POLLING 

  2  3   1SYSTEM V CONTROL

 
Figure 72. 3500Pro-D Rear View 

 

3.2.1 EXTERNAL POWER (J5) 
This 6-contact connector is the DC power interface connector. See Figure 73 for an orientation 
view showing contact locations. 

 

 

To avoid damage to the 3500Pro-D System Controller, the External Power 
connector (J5) must never be connected to any of the following: 

• A Lynx, Cougar or Jaguar audio routing switcher 

• An external audio power supply (PS140A or PS270A) 

• An RM5000 video routing switcher or its external power supply 
(PS270V) 

 
The Model 3500Pro-D may be configured with or without internal power supplies. If either of the 
internal power supplies are installed, J5 may be used to provide power to other equipment. If 
neither of the internal power supplies are installed, J5 is used to connect the 3500Pro-D to an 
external power source. Input power may be drawn from the following sources: 

 
• The 3500Pro-D may obtain power from PESA system components having 3-contact 

power connectors by using a power cable assembly (Part No. 81-9065-1653-0) 
constructed as shown in Figure 74. If this cable must be constructed in the field, 
consult Drawing No. WI50-0238 for assembly details.  

• The 3500Pro-D may obtain power from PESA system components having 6-contact 
power connectors by using a power cable assembly (Part No. 81-9065-TBD-0) 
constructed as shown in Figure 75. If this cable must be constructed in the field, 
consult Drawing No. WI50-TBD for assembly details.  
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3 2 1

6 5 4

Contact locations when viewed
from rear of chassis.  

Figure 73. Orientation View - 3500Pro-D J5 (EXTERNAL POWER) Connector 
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Figure 74. 3500Pro-D Power Cable with 3-Contact Plug 
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Figure 75. 3500Pro-D Power Cable with 6-Contact Plug 
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3.2.2 PWR ALARM (J22) 
This 3-contact connector provides the interface for the Power Supply alarms. See Figure 76 for an 
orientation view showing contact locations. 

Each of the two PS130 Power Supplies has its own internal low voltage alarm which will be 
enabled when the output voltage varies from 9VDC by ±12%. During an alarm condition, an 
optically isolated, closed circuit exists between contacts 3 and 1 for Power Supply A (top), and 
contacts 2 and 1 for Power Supply B (bottom). The customer supplied external alarm circuit is 
connected with a cable constructed as shown in Figure 77. 

 

 

The alarm circuit connected to this connector must not exceed 12VDC or 
10mA. 

Contact locations when viewed
from rear of chassis.

S
-
+

3
2
1

 
Figure 76. 3500Pro-D J22 (PWR ALARM) Connector 

PS Alarm A (Top) (+)

PS Alarm (-)
PS Alarm B (Bottom) (+)

81-9029-0811-0 To:
3500Plus-D J22

S
-
+

Customer Supplied 
Connector

1
2
3

 
Figure 77. 3500Pro-D PS Alarm Cable 

 

3.2.3 SYNC (J16, J17) 
These BNC connectors are wired in parallel and are used for an optional vertical sync signal 
input. The second connector is to allow the signal to be looped through the 3500Pro-D 
chassis and routed to other equipment. Unused connectors must be terminated with a 75 Ohm 
terminator (Part No. 81-9029-0668-4). 
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3.2.4 COM 1 (J7), COM 2 (J8) 
These DB9-Male connectors provide RS-232 serial communication interfaces. See Figure 78 for 
an orientation view showing contact locations. 

• COM 1 is the primary RS-232 CPU Link and may be connected to the PC running 3500Pro 
Control System software with a null modem cable (Part No. 81-9028-0393-0). If necessary, a 
cable up to 50 feet in length may be fabricated in the field as shown in Figure 79. COM 1 
may only be used with the P1E protocol, at either 9600 or 38400 baud. The communication 
rate is selected with switch S1 as described in “S1-3 COM 1 Rate” on page 60. 

• COM 1 may also be connected to an external modem using an AT Serial Modem cable (Part 
No. 81-9028-0400-0). If necessary, a cable up to 50 feet in length may be fabricated in the 
field as shown in Figure 80. 

• COM 2 is a secondary RS-232 CPU Link which may also be connected to a PC or external 
modem. COM 2 may be used with any of the protocols shown in the following table and may 
operate at either 9600 or 38400 baud. The communication rate for COM 2 is determined by 
settings made in the 3500Pro software. COM2 has the same pinout as COM1. 

Table 3. PESA CPU Link Protocols 
Protocol Document No. 

CPU Link Protocol No. 1 (P1) 81-9062-0407-0 
CPU Link Protocol No. 1 Extensions (P1E) 81-9062-0408-0 
Unsolicited Status Protocol (USP) 81-9062-0409-0 
Truck Link Protocol (TRK) 81-9062-0410-0 

Contact locations when viewed
from rear of chassis.

54321

9876

 
Figure 78. 3500Pro-D J7, J8 (COM 1, COM 2) Connectors 

CD (Carrier Detect)

CTS (Clear To Send)
RTS (Ready To Send)
DSR (Data Set Ready)

DTR (Data Terminal Ready)

RI (Ring Indicator)

SG (Signal Ground)

TX (Transmit Data)
RX (Receive Data)

DB-9 Female To:
3500Plus-D J7 or J8

DB-9 Female To:
PC

2 3

9
8
7
6
5
4
3

9
7
8

5
6
2

4

1 1
TX (Transmit Data)

DSR (Data Set Ready)

DTR (Data Terminal Ready)

RX (Receive Data)

SG (Signal Ground)

RTS (Ready To Send)
CTS (Clear To Send)

RI (Ring Indicator)

CD (Carrier Detect)

 
Figure 79. 3500Pro-D RS-232 CPU Link (Null Modem) Cable 
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DTR (Data Terminal Ready)
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5
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Figure 80. 3500Pro-D RS-232 CPU Link (AT Serial Modem) Cable 

3.2.5 COM 3/PRC (J9), COM 4 (J10) 
These DB9-Male connectors provide RS-422 serial communication interfaces. See Figure 81 for 
an orientation view showing contact locations. 

• COM 3/PRC is the communications interface to a PRC type routing switcher system and is 
connected to a routing switcher. If necessary, a cable up to 4000 feet in length may be 
fabricated in the field as shown in Figure 82. It contains the same physical connections as in 5 
pin PRC connector. 

• COM 4 is an RS-422 CPU Link similar to the RS-232 CPU Link, except the cable may be up 
to 4000 feet in length and an RS-422 interface card must be installed in the expansion bus. 
COM 4 may be used with any of the protocols shown in Table 3 on page 53. If necessary, a 
cable may be fabricated in the field as shown in Figure 83. 

1

Contact locations when viewed
from rear of chassis.

6 7 8 9

2 3 4 5

 
Figure 81. 3500Pro-D J9, J10 (COM 3/PRC, COM 4) Connectors 
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Figure 82. 3500Pro-D RS-422 Serial Cable 
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9
6

Chassis Ground
Chassis Ground

System Controller TX+ (High)
System Controller TX- (Low)

System Controller RX- (Low)
System Controller RX+ (High)

1

5
4
3
8

7
2
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3500Plus-D J9

Chassis Ground

Chassis Ground
Chassis Ground

System Controller TX+ (High)
System Controller TX- (Low)

System Controller RX+ (High)
System Controller RX- (Low)

Customer supplied 
Connector

 
Figure 83. 3500Pro-D RS-422 CPU Link Cable 

 

3.2.6 CPU ALARM (J18) 
This 3-contact connector provides the interface for the CPU alarm. See Figure 84 for an 
orientation view showing contact locations. 
 
The 3500Pro operating software determines when an alarm condition is declared. During an 
alarm condition, an optically isolated, closed circuit exists between contacts 3 and 1 for 
Controller A (top), and contacts 2 and 1 for Controller B (bottom). The customer supplied 
external alarm circuit is connected with a cable constructed as shown Figure 85. 

Contact locations when viewed
from rear of chassis.

1
2
3

+
-
S

 
Figure 84. 3500Pro-D J18 (CPU ALARM) Connector 

 

81-9029-0811-0 To:
3500Plus-D J18

+
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S
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3

 
Figure 85. 3500Pro-D CPU Alarm Cable 
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3.2.7 PRC (J11) 
This 5-contact connector is a loop-through connector used to provide an RS-422 serial 
communication interface using the PESA PRC Protocol (Document No. 81-9062-0316-0). It 
is wired in parallel with J9 (COM 3/PRC). See Figure 86 for an orientation view showing 
contact locations. 
J11 may be connected to other PESA PRC type equipment with a cable assembly (Part 
Number 81-9028-0395-0) constructed as shown in Figure 87. If this cable must be 
constructed in the field, consult Drawing No. WI50-0250 for assembly details. 

5 4 3 2 1  
Figure 86. 3500Pro-D J11 (PRC) Connector 
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System Controller TX- (Low)

System Controller TX+ (High)
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3500Plus-D J11

1
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4
5

3
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System Controller TX- (Low)
System Controller TX+ (High)
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Figure 87. 3500Pro-D RS-422 System Expansion Cable 
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3.2.8 SYSTEM V CONTROL (J20) 
This DB37-Male connector provides the System 5 control interface and uses the RM5 
Protocol (Document No. 81-9062-0155-3). See Figure 88 for an orientation view showing 
contact locations. 
J20 is connected to a Lynx or RM5 type routing switcher with cable assembly Part No. 
81-9065-1189-2. If necessary, a cable up to 8 feet in length may be fabricated in the field as 
shown in Figure 89. If more than one System 5 Routing Switcher will be connected to the 
System Controller, consult Drawing No. WI50-0262 for information on constructing a 
bifurcated cable. 

Contact locations when viewed
from rear of chassis.
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Figure 88. 3500Pro-D J20 (SYSTEM V CONTROL) Connector 
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Figure 89. 3500Pro-D RM5 Control Cable 
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3.2.9 POLLING 1-4 (J12, J13, J14, J15) 
These 3-contact connectors are wired in parallel and provide RS-485 serial communication 
interfaces using the PESA RCP Protocol (Document No. 81-9062-0300-0). See Figure 90 for 
an orientation view showing contact locations. 
J12, J13, J14, and J15 are connected to PESA Remote Control Panels with daisy-chained 
cables constructed with 3-contact connectors (Part No. 81-9029-0780-0) and shielded, 
twisted-pair audio cable (Part No. 81-9028-0043-2, Belden 8451, or equivalent) as shown in 
Figure 91. The connector body has an integral strain relief which requires the use of a nylon 
cable tie which is included with the connector. If this cable tie is not available, Part No. 
81-9021-0028-8 may be used. 
 

When connecting RS-485 cables between the dual controller and the actual 
panels, the ordering of the pins is different. Look closely at the diagrams 
below.  

Contact locations when viewed
from rear of chassis.

S
-
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Figure 90. 3500Pro-D J12, J13, J14, J15 (POLLING 1-4 ) Connectors 

 

High (+)
Low (-)
Shield (S)

81-9029-0780-0 To:
Remote Control Panel

Shield (S)

Additional RCPs may be 
daisy-chained together 

as required.

3 2

81-9029-0811-0 To:
3500Plus-D J12, J13, J14 or J15

Low (-)
High (+)

2
1

3
1

RCP connector
contact locations
when viewed from

rear of chassis.

3
2

2
3
1

1

3 2

- S

1

+

 
Figure 91. 3500Pro-D RS-485 Serial Cable 
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3.3 PS130 Power Supply Line Cords 

 

Always use a grounded AC receptacle to avoid a potentially lethal shock 
hazard in the event of an equipment power line fault. 

 
This equipment will not meet FCC EMI limits unless both AC line cords are 
plugged into properly grounded AC receptacles. 

 

Each PS130 Power Supply requires a line cord (Part No. 81-9028-0403-0) to connect it to the AC 
mains. 

 

3.4 PC Board Switch and Jumper Settings 

3.4.1 S1 - Operational Mode/Config Bypass/COM 1 Rate 
S1 is a four-position, slide-style, DIP switch consisting of four single-pole, single-throw (SPST) 
switches numbered 1 through 4. Position 1 is used to set the operational mode, position 2 is used 
to enable/disable configuration bypass, and position 3 is used to select the serial communication 
rate. Position 4 is reserved for future use. See Table 4 on the next page for switch settings. 

S1

ON ¯

 

Figure 92. 3500Pro S1 (Operational Mode/Config Bypass/Comm Rate) 

PESA SWITCHING SYSTEMS  59 



81-9059-0549-0 Rev B  3500PRO SOFTWARE AND SYSTEM CONTROLLER 

Table 4. 3500Pro Switch S1 
3500Pro S1 

Operational Mode/ 
Config Bypass/Comm Rate 

Switch 
S1-1 

Switch 
S1-2 

Switch 
S1-3 

Switch 
S1-4 

Software Upgrade Mode ON    
Normal Operation Mode OFF    
Configuration Bypass Enabled  ON   
Configuration Bypass Disabled  OFF   
COM 1 Rate: 38400 Baud   ON  
COM 1 Rate: 9600 Baud   OFF  
Reserved – Set S1-4 to OFF    OFF 
 

3.4.1.1 S1-1 Operational Mode 
This switch is used to place the 3500Pro into software upgrade mode for use with Load3500, 
the software installation utility. For more information on the use of Load3500, consult the 
technical bulletin that came with your software upgrade. 
For normal operation, this switch should be in the OFF position. 

3.4.1.2 S1-2 Configuration Bypass 
For normal operation, this switch should be in the OFF position. For information on using the 
configuration bypass feature, see “Configuration Bypass” on page 65. 

3.4.1.3 S1-3 COM 1 Rate 
This switch is used to select the communications rate used by COM 1 on the 3500Pro. The 
communication rate for COM 2 is determined by settings made in the 3500Pro software. 

3.4.1.4 S1-4 Reserved 
S1-4 is reserved for future use. 
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3.5 Subassembly Installation 

3.5.1 Model 3500Pro-S 
The 3500Pro-S consists of an external chassis and a 3500Pro System Controller board. There is 
no internal power supply. 

3.5.1.1 3500Pro System Controller Board Installation 
The 3500Pro System Controller board is installed in the chassis as follows: 

1. Align the board support tray with the card guides in the chassis. 

2. Carefully insert the board into the chassis until the connectors on the board make contact with 
the connectors on the backplane. If possible, inspect the mating connectors to ensure proper 
alignment. 

3. Firmly push the board into the chassis until the board connectors are fully mated with the 
backplane connectors. If the contact insertion force seems excessive, gently push up on the 
bottom of the board with one hand, while pushing on the front of the board with the other. 
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3.5.2 Model 3500Pro-D, Model 3500Pro-SE, and Model 3500Pro-DE 
The 3500Pro-D consists of an external chassis and two 3500Pro System Controller boards and 
two PS130 Power Supplies. It may also be ordered as the 3500Pro-SE which has only one 
3500Pro System Controller board and one PS130 Power Supply installed in the same chassis. The 
3500Pro-DE is the expansion kit required to convert a 3500Pro-SE to a 3500Pro-D. 

3.5.3 3500Pro System Controller Board Installation 
The 3500Pro System Controller boards are installed in the chassis as follows: 
1. Align the support tray of the first board with the card guides in the chassis. 

2. Carefully insert the board into the chassis until the connectors on the board make contact 
with the connectors on the backplane. If possible, inspect the mating connectors to ensure 
proper alignment. 

3. Firmly push the board into the chassis until the board connectors are fully mated with the 
backplane connectors. 

4. Repeat the above steps for the second board. 

3.5.4 PS130 Power Supply Installation 

 

A fully configured 3500Pro-D contains two PS130 Power Supplies connected 
in parallel. Either power supply is capable of powering both system 
controller boards, with the second power supply serving as a backup for the 
first. One power supply may be removed and replaced while the other is 
connected to the power source, and the 3500Pro-D is operational. 

 
The PS130 Power Supplies are installed in the chassis as follows: 
 
1. Align the shield plate of the first power supply with the card guides in the chassis. 

2. Carefully insert the power supply into the chassis until the connectors on the power 
supply make contact with the connectors on the backplane. If possible, inspect the mating 
connectors to ensure proper alignment. 

3. Firmly push the power supply into the chassis until the power supply connectors are fully 
mated with the backplane connectors, and the power supply latch engages the 
corresponding slot in the chassis. 

4. Repeat the above steps for the second power supply. 
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Chapter 4 - Operating the System  
Controller Hardware 

4.1 General 
This equipment is designed to be operated by the 3500Pro Control System software. For detailed 
operational information, consult Section III. 

Figure 93 and Figure 94 show typical views of the 3500Pro System Controller board. The 
configuration shown is that used in Models 3500Pro, 3500Pro-D, 3500Pro-SE, and 3500Pro-DE. 
Other models use a different support tray, but are operated in the same way. 

 
Figure 93. 3500Pro System Controller Board Assembly Top View 

ACTIVE

ACTIVE
+BATTERY

ON

 BATTERY
OFF

+5VGND
RUN

 MODERESET
STANDBY

 
Figure 94. 3500Pro System Controller Board Assembly Front View 
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4.2 Front Panel Switches 

4.2.1 Reset (S2) 
This SPDT momentary pushbutton switch is used to manually reset the 3500Pro System 
Controller in the event of system failure or lockup (similar to a warm boot on a PC). To reset the 
controller, press and hold this switch for about three seconds. 

4.2.2 Mode (S4) 
This SPDT toggle switch is used in a dual controller system to designate which controller is the 
primary controller, and which is the backup controller. Set the Mode switch to ACTIVE on the 
primary controller, and to STANDBY on the backup controller. 

In a single controller system, this switch has no effect. 

4.3 Front Panel LEDs 
See “LEDs” on page 66. 
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Chapter 5 – Maintenance and Repair  
5.1 Periodic Maintenance 

There are no periodic maintenance requirements for this equipment. 

5.2 Configuration Bypass 
If the configuration being used by the 3500Pro System Controller becomes corrupt, it may be 
bypassed to allow the loading of another configuration as follows: 

1. Remove power from the 3500Pro. 

2. Remove the 3500Pro from the chassis to allow access to switch S1 (see Figure 92 on page 
59). Set switch S1-2 to the ON position in accordance with Table 4 on page 60. 

3. Reinstall the 3500Pro and apply power. 

4. Load the new configuration. This will overwrite the corrupted configuration. 

5. Remove power from the 3500Pro. 

6. Remove the 3500Pro from the chassis and return switch S1-2 to the OFF position. 

7. Reinstall the 3500Pro and apply power. 

 
Figure 95. 3500Pro System Controller Board Assembly Front View 

5.3 Front Panel Test Points 

5.3.1 3500Pro System Controller Board 
The 3500Pro System Controller board has three test points accessible from the front panel, 
GND, +5V, and +BATTERY, as shown in Figure 95. 
 

5.3.2 GND (TP17) 
This test point provides a convenient ground when measuring voltages at the other test 
points. 

5.3.3 +5V (TP18) 
The voltage measured between this test point and GND (TP1) is the output of the voltage 
regulation circuit and should be 5 ±0.1 VDC. 

5.3.4 +BATTERY (TP19) 
The voltage measured between this test point and GND (TP1) is the output voltage of the 
backup memory power source and should be >2VDC when power has been removed 
from the board. This voltage is stored in a “super-cap” and has limited capability to retain 
memory for more than 48 hours.  
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5.4 LEDs 
In the rare event this equipment fails to operate correctly, check the appropriate LEDs listed 
below for information concerning operational status. 

5.4.1 3500Pro System Controller Board 
The 3500Pro System Controller board has two front panel LEDs, RUN and ACTIVE, as 
shown in Figure 95. 

 

LED Color Panel 
Legend 

Normal 
State 

Troubleshooting Info 

LED1 RED N/A OFF Controller board is in reset state or is in program 
download mode. 

LED2 GRN RUN ON Indicates that input voltage to this board is within 
design parameters. 
 
If LED is OFF: 
 
1.  Remove and reinstall board to verify backplane  

 connector is properly seated. 
2.  Check power supplies for proper operation. 
3.  Contact PESA Customer Service. 

LED3 YEL ACTIVE ON Indicates that the board is currently in active control 
of a routing switcher system. 
 

In a dual controller system, the primary 
controller ACTIVE LED will be ON and 

 
If the L
 
1.  Rem

con
2.  Ens

acti
3.  Con
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the backup controller ACTIVE LED will 
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ED is OFF: 
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5.4.2 PS130 Power Supply 
LED Color Panel Legend Normal 

State 
Troubleshooting Info 

D27 GRN n/a ON Indicates that output voltage is within 
design parameters. 
 
If LED is OFF: 
1. Check input power connections. 
2. Check internal fuse (3.15A 

250VAC) 
3. Replace the power supply. 
4. Contact PESA Customer Service. 

 

5.5 PESA Customer Service 
If the troubleshooting information above has not solved your problem, contact the PESA 
Customer Service Department. Skilled technicians are available to assist you 24 hours per day, 
seven days per week. 

Detailed contact information for the Customer Service Department is located inside the front 
cover of this document. 

5.6 Repair 
Before attempting to repair this equipment, please consult your warranty documents and/or the 
PESA Customer Service Department. Unauthorized repairs may void your warranty. 

The PS130 Power Supply assemblies in this equipment are not field/user 
serviceable. These offline switching power supplies contain internal voltages 
that are not isolated from the AC power source. They should only be 
serviced by qualified service personnel using appropriate equipment. 
Because of this, it is strongly suggested that power supplies be returned to 
the PESA Customer Service Department for service. 

 

 

Many of the PC boards in this equipment contain large numbers of SMT 
(Surface Mount Technology) components. Special tools are required to 
replace these components without causing damage to adjacent areas. It is 
strongly recommended that PESA Customer Service be consulted prior to 
attempting to repair any of the PC boards in this equipment 

 

5.6.1 Replacement Parts 
Only parts of the highest quality have been used in the design and manufacture of this equipment. 
If the inherent stability and reliability are to be maintained, replacement parts must be of the same 
high quality. For this reason, we suggest that you consult our Customer Service Department 
before installing any parts not purchased from PESA. 
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5.6.2 Factory Service 
Before returning any equipment to our factory for service or repair, please contact our Customer 
Service Department for an RMA number. 

Detailed contact information for the Customer Service Department is located inside the front 
cover of this document. 
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Section III:  Software Reference Guide 
 
 

This section describes the 3500Pro software and how to use the software. The following modules are 
described: 

 

• 3500Pro Configuration Editor: Defines the environment under which the control system 
operates.   

• 3500 Pro Diagnostics: Provides troubleshooting tools. 

• 3500 Pro Status: Provides a way to monitor the status of the systems. 

• 3500 Pro User Manager: Sets up the PC communications and allows you to create and edit users 
who can access the 3500Pro software. 

• Runtime Database Initialization: Provides a fresh copy of the runtime databases used for online 
monitoring of the router.   
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Chapter 6 – 3500Pro Configuration Editor 
 

This section describes in detail each command available in the software, and how the command is 
integrated into the overall workflow. This section begins with a broad overview of a typical 
workflow you might use when just getting started with the 3500Pro software. 

The 3500Pro software is aimed at users who require more control levels, components, sources, 
destinations, and tielines. The 3500Pro expands upon its proven capabilities to bring you the 
industry's easiest and most comprehensive control solution. The graphic-oriented, point-and-click 
interface permits error-free, offline/online configuration and editing.  

 

This section describes both the 3500Pro and the 3500Pro LE. The 3500Pro 
LE has a smaller feature set and is designed for customers with smaller 
systems. 

 

There are five modules in the software. To access each module, select Start > Programs > 
PESA 3500Pro and then the module you want to open. 

� 3500Pro Configuration Editor: Defines the environment under which the control system 
operates.   

� 3500 Pro Diagnostics: Provides troubleshooting tools. 

� 3500 Pro Status: Provides a way to monitor the status of the systems. 

� 3500 Pro User Manager: Sets up the PC communications and allows you to create and edit 
users who can access the 3500Pro software. 

� Runtime Database Initialization: Provides a fresh copy of the runtime databases used for 
online monitoring of the router.   

6.1 How to Use the 3500Pro 
This section describes how to use the 3500Pro to set up configuration files to interface with 
3500Pro Controllers. When you are starting your 3500Pro setup, there are five main workflows 
you will need to follow: 

� Setting up your computer  

� Initializing the Databases  

� Creating 3500Pro Users  

� Creating a New Configuration  

OR 

Importing an Existing Configuration  

� Downloading the configuration to the controller  

 

Each of these sections provide general information for your workflow. The following sections 
provide in-depth information about the different steps in the workflow. 
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6.1.1 Time Saving Tools 
The 3500Pro provides many new time-saving options that make it much faster for you to enter 
repetitive information into your configuration. 

Right-click mouse commands 

For many fields that require you to enter repetitive information, such as Inputs, Outputs, and so 
on, there are additional commands available if you click the right mouse button. These commands 
vary depending on which window you are working with: 

 

          

Figure 96. Right-click mouse commands 

Autonumber 

 

Automatically numbers selected fields, starting with 1.  For example, if you select a range of 
blank fields, then select this command, they will automatically number: 

 

Figure 97. Autonumber 

Cut, Copy, Paste 

Activates the Cut, Copy, and Paste commands.  
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Fill-Up 

Fills in fields above a selected field with the same information. First select the field with the 
number you want to duplicate, then select the fields above it. Right-click and select Fill-Up to fill 
in the fields with the selected information. 

 

  

Figure 98. Fill-Up 

Fill-Down 

Fills in the fields below a selected field with the selected number. First, select the field with the 
number you want to duplicate, then select the fields below it. Right-click and select Fill-Down to 
fill in the fields with the selected number. 

  

Fills in the fields to the left of a selected field with the selected number(s).  First, select the fields 
with the numbers you want to duplicate, then select the fields to the left. Right-click and select 
Fill-Left to fill in the fields with the selected numbers.  You can either select one field or several 
fields with this option.  

 

Figure 99. Fill-Down 

Fill-Left 

  

Figure 100. Fill-Left 
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Fill-Right 

Fills in the fields to the right of a selected field with the selected number(s).  First, select the 
fields with the numbers you want to duplicate, then select the fields to the right. Right-click and 
select Fill-Right to fill in the fields with the selected numbers.  You can either select one field or 
several fields with this option.  

 

  

Figure 101. Fill-Right 

Delete Rows 

Deletes the selected rows. You only have to select one item in a row to delete it. 

 
Make sure you really want to delete the row before selecting this command. 
You cannot "Undo" this action. 

 

Clear Selected 

Removes information from the selected fields (does not delete the row).  

 

Clear All 

Removes information from the entire window.  

 

6.2 Getting Started 
The first thing you need to do with the 3500Pro software is to define the serial port connection 
and the baud rate. 

1.  Connect the primary external computer to the COM1 Connector on the 3500Pro Controller 
using a 9-pin NULL modem RS232 cable. 

3. Select Start > Programs > 3500Pro > 3500Pro User Manager. The 3500Pro 
Connection/User Manager window displays. 
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Figure 102. Connections Tab 

3. In the Connection Parameters section, make sure there is a check mark next to the Serial 
Port Connection option.  

4. In the COM Port pulldown window, select the COM port you are using to connect to the 
3500Pro Controller.  

5. In the Baud Rate field, select the baud rate you want to use. The baud rate is defined by a 
DIP switch setting on the Controller board. Refer to the 3500Pro Controller documentation 
for details. 

6. Select Commit to save your changes. 

 

6.3 Initializing the Database 
After setting up your computer, initialize the configuration and runtime databases. To do this, 
select Start > Programs > 3500Pro > Runtime Database Initialization.  This will purge any 
old runtime databases from your system and makes a new copy of the master database. 
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6.4 Creating Users 
After your computer is properly configured, you can create users for the 3500Pro software.  

 

User accounts are optional. If used, at least one user account must be 
assigned all privileges. If no user accounts are configured, all users have all 
privileges. 

 

1. If the 3500Pro Connection/User Manager window is not open, select Start > Programs > 
3500Pro > 3500Pro User Manager. The 3500Pro Connection/User Manager window 
displays. 

2. Select the Users tab.   

 

Figure 103. Users Tab 
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6.4.1 Create a User With Access to Everything 
1. First you need to create a user who has access to everything in the system. Select the Add>> 

button to start. 

2. In the User Name field, type in a name for the user.   

3. Select the Set Password button to define a password for the user.  

4. Type in the password you want to use in the New Password field. Re-enter the exact same 
password in the Confirm New Password field.  

 
You must enter the exact same password in both fields! 

 

5. Select OK to accept the new password. The password window will close, and you will return 
to the User Manager window. 

6. Now select the Set All button and check marks will display next to each field. This means 
that the user will have access to everything in the 3500Pro software.  

7. Select Commit and the user will be added to the system and will display in the Available 
Users box on the left side of the window. 

 

6.4.2 Create the Rest of the Users 
1. Now you can create additional users with access to specific sections of the software. Select 

the Add>> button. 

2. Enter a User Name. 

3. Select the Set Password button and enter a password. Select OK to accept the password and 
close the password window. 

4. Now, select the specific sections of the software you want the user to be able to access.  
When you are done, select Commit and the user will be added to the system and will display 
in the Available Users section. 

5. Repeat this process for as many users as necessary. 

6.5 Creating a New Configuration 
If you do not have an existing configuration file, you need to create one. You will use the 
Configuration Editor to do this. 

 

There is a sample configuration file shipped with the 3500Pro that you can 
look at to become familiar with the different options. To open the file, select 
File > Open Configuration Database. 
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6.5.1 Create a New Configuration File 
1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor. The Configuration 

Editor window displays. 

2. Select File > New Configuration Database to create a new database on your computer. 
Select the directory location for the file, enter a name, then select OK. A new configuration 
file will be created on your computer. The name of the file will display at the top of the 
window. 

 

6.5.2 Set up the Configuration File 
Each configuration file will be different depending on the specific configuration you are working 
with. However, there are some basic steps that are common to each configuration file.  

 

4. Select Configuration > Reentry to define reentries. 

If you have an existing configuration file from an older version of 3500, you can import it into 
the software.  

 
1. Select Configuration > System Configuration > Level/Comp to set up Levels and 

Components. 

2. Select Configuration > System Configuration > CPU Link/Port to set up serial 
communications link to the controller.   

3. Select Configuration > Matrix Configuration to define sources and destinations that match 
the equipment connected to the router. 

4. Select Configuration > Panels to define the settings for different RCP remote control panels 
in your system. 

 

6.5.3 Setting Up Optional Features 
The remainder of the available Configuration commands are optional depending on how you 
want to set up your system. If you choose, you can define the following options: 

1. Select Configuration > Salvo to define salvos. 

2. Select Configuration > Categories to define categories. 

3. Select Configuration > Tielines to define tielines. 

 

6.6 Importing an Existing Configuration 
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6.6.1 Importing an ASCII file 
Make sure you have the configuration file on your computer and stored in ASCII format (.txt or 
.dat extension).  

1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor. The Configuration 
Editor window displays. 

4. Select File > Transfer Configuration. 

 

Figure 104. Import a Configuration from an ASCII FIle 

4. The message Importing Text File displays. When the process is complete, the message 
“Import is Complete” displays. You can now work with the configuration file. 

5. Select the Import Configuration From ASCII file button, then select Execute. 

6. The Import window will display. Change to the directory where the configuration file you 
want to import is located. Select the file and select the Open button.  

6.6.2 Uploading the Current Configuration 
If you have a system already set up you can just load the existing configuration file from the 3500 
Controller to the 3500Pro software.  

1. Select Start > Programs > 3500Pro > 3500Pro Configuration Editor. The Configuration 
Editor window displays. 

2. Select File > Upload Configuration From Controller. If a configuration file is currently 
open, the following message displays: 

 

Figure 105. Confirm Configuration File Upload 
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3. The current configuration will be loaded to the 3500Pro software, and you can then save the 
configuration to your computer and start working with it. 

6.7 Downloading the Configuration to the Controller 
After you are done creating your configuration file, you need to download it to the controller.  

1. From the Configuration Editor window, select File > Transfer Configuration. 

2. Select the  Download Configuration TO Controller option, then select Execute.  The 
following prompt displays: 

 

Figure 106. Download Configuration Prompt 

2. If you are sure you want to download the configuration file, select OK. 

3. The following prompts display in the Status Bar at the bottom of the window: 

 Exporting the configuration to a file.   

 Downloading to the Controller 

4. The configuration file will be sent to the controller and you can then use additional 3500Pro 
tools to monitor the controller and perform diagnostics. 

 

 
The controller is non-operational while it is loading the new configuration.   

 
You have now established a basic connection with the system controller. Continue to modify and 
customize your configuration file and upload the configuration file to the controller. The 
following chapters provide in-depth information about each command available in the 
Configuration Editor. 
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6.8 3500Pro Configuration Editor File Menu 
The File menu provides tools to open, save, close, upload, and download configuration files. In 
addition, there are tools to import ASCII files and export to a database. 

 

Figure 107. Configuration Editor File Menu 

6.8.1 Shortcuts 
There are several "shortcuts" available to quickly access commonly-used commands. The 
following shortcut keys and buttons are available: 

Keys: 

To use the following shortcuts, press the Control (Ctrl) key and the additional letter at the same 
time. 

Ctrl+N:  File > New Configuration Database:   

Ctrl+V:  Edit > Paste:  

Ctrl+O:  File > Open Configuration Database:  

Ctrl+X:  Edit > Cut:  

Ctrl+C:  Edit > Copy:  

  
Buttons: 

 Accesses the File > New Configuration Database command 

 

 Accesses the File > Open Configuration Database command 

 

 Accesses the File > Save Configuration Database command (if you have already save the 
configuration file) OR the Save Configuration Database As command if you have not saved the 
configuration file. 
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 Accesses the Edit > Cut command 

 

 Accesses the Edit > Copy command 

 

 Accesses the Edit > Paste command 

 

6.8.2 New Configuration Database   
The File > New Configuration Database command creates a new 3500Pro configuration file. 
Configuration files contain all of the information required to communicate with the 3500Pro 
Controller.   

 

Before Using This Command 

If a configuration file is currently open, close it before creating a new configuration. 

 

Creating a New Configuration Database 

When you select this command, the New Config Database window displays. Select a location for 
the new configuration file, and enter a file name. Select Open, and an empty configuration will be 
created. The new configuration file is automatically saved to your hard drive to the directory 
location and file name you entered. 

After you set up a configuration file, you can use the File > Download Configuration TO 
Controller command to load the configuration file to the controller. 
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6.8.3 Open Configuration Database   
The File > Open Configuration Database command opens a configuration file.   

 
Save your existing configuration before opening another one.  

 

 

Figure 108. New Configuration Database 

 

Before Using This Command 

You must have a valid configuration file available on your computer or computer network. 

 

If you need to access a configuration file stored on a controller but is not on 
your computer, use the File > Configuration Transfer > Upload 
Configuration FROM Controller command. 
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6.8.4 Close Configuration Database! 
The File > Close Configuration Database! command closes the active configuration file.   

 
Before Using This Command: 

� Close all of the open windows.  

� Save the configuration file with either the File > Save Configuration or File > Save 
Configuration Database As commands before closing the file, otherwise you will lose your 
changes. 

 

6.8.5 Controller Status 
The File > Controller Status command verifies the communication to the controller.  The 
command displays a window with the name and version number of the controller software. Select 
OK to dismiss the window. 

 

Figure 109. Controller Status Message 

If there is a problem with the connection to the controller, the following message will display: 

 

 

Figure 110. Controller Status Error Message 

If you get this error, ensure that the physical connections to the controller are in place. Refer to 
your 3500Pro Controller Manual for detailed information about hardware setup. 

 

Before Using this Command 

Connect the primary external computer to the COM1 Connector on the 3500Pro Controller using 
a 9-pin NULL Modem RS232 cable.  
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6.8.6 Clear Configuration Locks 
In the rare event that a power failure, hardware malfunction, or other occurrence prevents a 
configuration upload or download from terminating in a normal manner, the configuration lock 
may latch in place. To manually clear a configuration lock, select File > Clear Configuration 
Locks. 

If the malfunction occurred while downloading a configuration to the controller (sometimes 
referred to as writer’s lock), the controller will also be reset. You will be warned in this event. 

6.8.7 Validate Configuration 
The File > Validate Configuration command checks the currently open configuration file to 
make sure it does not contain any errors. Use this command before transferring the configuration 
file to the controller.  

You can also validate the configuration before you download or export the configuration with the 
“Validate” option in the Transfer Configuration window. 

 

Figure 111. Validate Window 
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6.8.8 Transfer Configuration 
The File > Transfer Configuration command provides a way to transfer a configuration file to 
the controller, upload a configuration file stored on the controller, and to import and export 
configuration files to and from ASCII files. 

 

Figure 112. Configuration Transfer Window 

Before Using This Command 

• If you are uploading a configuration file from the controller, close any configuration files 
you are currently working on. 

• If you are importing a configuration from an ASCII file, make sure the file you want to 
use is stored in a location you can access. 

 

Configuration Transfer Options: 

The following options are available in this window: 

Force Router Switches After Download:  After downloading a configuration file to the 
controller, automatically performs switches. 

Validate Configuration before Download/Export: Validates the configuration file before you 
download it to the controller to export it to a file. 

Configuration Transfer Actions: For detailed information about each of these options, see the 
following sections. 

• Download Configuration TO Controller on page 86 

• Upload Configuration FROM Controller on page 8  6

7• Import ASCII File To Database on page 8  

• Export Database To ASCII File on page 88 

Execute: Performs the action you selected in this window. After you select Execute, messages 
will display in this window to let you know the progress of the selected action, and when the 
action is complete. 
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6.8.9 Upload Configuration FROM Controller 
The File > Upload Configuration FROM Controller command uploads a configuration from 
the 3500Pro System Controller to the PC.  

Before Using This Command 

This command overwrites the configuration information in the 3500Pro Configuration Editor. To 
avoid data loss, be sure to save and/or close the configuration currently open in 3500Pro before 
overwriting it with the uploaded configuration. 

Uploading a Configuration from the Controller 

When you select this command, the following messages display in the Status Bar at the bottom of 
the 3500Pro window: 

Pulling the configuration from the controller 

Importing the configuration into the database 

Done 

 

If a status bar does not display at the bottom of the window, select View > 
Status Bar. 

 

After the process is complete, the configuration settings will be available in the Configuration 
Editor. 

 

6.8.10 Download Configuration TO Controller 
The File > Download Configuration TO Controller command downloads a configuration file 
from your computer to the controller.  

Before Using This Command 

� Create or Open the configuration file you want to use with the controller. 

� Save the configuration file before uploading it.  

� Save the configuration file on the controller before uploading a new file. 

 

 

This command causes the controller and switchers to be temporarily 
unavailable until the download is complete. 

 

Downloading a Configuration to the Controller 

When you select this command, the following prompt displays: 
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Figure 113. Download Configuration Message 

If you are sure you want to download the new configuration, select OK.  The following prompts 
display in the Status Bar at the bottom of the window: 

 Exporting the configuration to a file.   

 Downloading to the Controller 

The configuration file will be sent to the controller and you can then use additional 3500Pro tools 
to monitor the controller and perform diagnostics. 

 

6.8.11 Import ASCII File To Database 
The File > Import ASCII File to Database option imports an ASCII configuration from the PC 
into 3500Pro.  If you have a configuration file from an older version of 3500, you can import the 
ASCII .txt file into this version of the software.  

 
A configuration may exist in two different formats: 

1. A DB configuration is stored as a .db style database. This is the format that 3500Pro uses 
when storing a configuration on the PC. 

2. An ASCII configuration is stored as an ASCII text file (.txt). 3500Pro converts a 
configuration from DB to ASCII when it is when uploaded from or downloaded to a 3500Pro 
System Controller. 

Before Using This Command 

A configuration file must be open before you can import an ASCII file. Open an existing 
configuration file or create a new configuration file.  

 

If you import the database into an existing configuration file, the current 
configuration will be overwritten. 

 

Importing an ASCII File 

1. When you select this option, the Import window displays.  

2. Use the Look in drop-down list to select the directory where the configuration file is stored. 
The available files will display in the middle part of the window.  

3. Select the file you want to import, then select Open.  

4. The configuration settings will be imported into the software and you can review the 
information with the menus. 
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6.8.12 Export Database To ASCII File 
The File > Export Database to ASCII File exports an ASCII configuration from 3500Pro to the 
PC.  

A configuration may exist in two different formats: 

1. A DB configuration is a configuration stored as a .db style database. This is the format that 
3500Pro uses when storing a configuration on the PC. 

2. An ASCII configuration is a configuration stored as an ASCII text file. 3500Pro converts a 
configuration from DB to ASCII when it is when uploaded from or downloaded to a 3500Pro 
System Controller. 

 
This option is useful if you need to transfer the database file to another computer, or easily look at 
the data in the database. You can open the ASCII file in a simple text editor or a word processing 
program such as Microsoft Word to review the information. If you open the file, just make sure 
you do not change the file extension (.txt). 

Before Using This Command 

The configuration file you want to export must be open.  

Save the configuration file before you export it. 

Exporting a Database File 

1. When you select this command, the Export window displays.  

2. Use the Save in drop-down list to select the directory where you want to save the file.  

3. Then, type a name in the File name field.  Select Save and the file will be saved to your 
computer. 

6.8.13 Save Configuration Database   
The File > Save Configuration Database command saves the configuration file to your hard 
drive (or network).   

If this is the first time you have saved the configuration file, the Save Config Database As 
window will display. You can then enter a name for the file and select a location to save the file. 

 

Before Using This Command 

A configuration file must be open. 
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6.8.14 Save Configuration Database As   
The File > Save Configuration Database As command allows you to enter a name and directory 
location for the configuration file, and then saves the file to the specified location.   

 

Figure 114. Save Configuration Database As 

 

 

If this is the first time you have saved the configuration file, the Save 
Config Database As window will automatically display. 

 

Use this command to save an existing configuration file to another file 
name or directory location. 

 

Before Using This Command 

A configuration file must be open. 

 

6.8.15 Exit 
The File > Exit command closes the 3500Pro Configuration Editor 

 

Before Using This Command 

Save the configuration file you are working with. 
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6.9 Configuration Editor Edit Menu 
The Edit commands allow you to cut, copy, and paste information in the 3500Pro workspace. 
The following commands are available: 

 

Figure 115. Edit Menu 

6.9.1 Cut   
The Edit > Cut command removes information from a selected field or fields. To use this option, 
you must highlight an area that contains information you want to "cut". When the area is 
highlighted, as shown below, select this command and the information will be removed and 
placed on the "clipboard" (temporary storage location on your computer).  

 

 

Figure 116. Highlighted Field 
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TIP:  If you need to remove the information from an entire column, highlight the entire 
column. Select the first field you want to cut, then hold down the left mouse button and 
move the cursor so all of the fields you want to cut are highlighted. Then, select the Cut 
command and all of the information will be removed. 

 

 

Figure 117. Highlighted Column 
 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten. 

 

 

If you Cut information, you cannot "Undo" the action. Make sure you cut 
the correct information. If you accidentally cut the wrong information, 
immediately use the Edit > Paste command to replace the cut information. 

 

TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button. A menu will display, and you can select Cut.  

 

6.9.2 Copy   
The Edit > Copy command copies highlighted information to the clipboard (a temporary storage 
location on your computer). Then, you can Paste the information into another location. This 
saves time when you have to type information in several different places. 

To copy information, select a field. When it highlights, as shown below, select Copy, and the 
information will be pasted to your clipboard.   
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Figure 118. Highlighted Field 
 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten. 

 

TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button. A menu will display, and you can select Copy.  

 

6.9.3 Paste   
The Edit > Paste command places information stored on the clipboard in the selected location. 
Use this command to place information you either "Cut" or "Copied" to a different location in 
the 3500Pro interface. 

 

Each time you use the "Cut" or "Copy" command, the information stored 
on the clipboard will be overwritten. If you want to "Paste" information, 
make sure you do so before overwriting the information. 

 
TIP: In many 3500Pro windows, you can also access this command by clicking the right 
mouse button. A menu will display, and you can select Paste.  
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6.9.4 Panel Template 
The Edit > Panel Template command allows you to set up defaults for panel information. These 
settings will be set as a default each time you create a new panel (with the Configuration > 
Panels option). 

 
Figure 119. Panel Template Window 

 

Lock Priority 

The lock priority is used with the requester code to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a panel or port, it can only be removed by another 
panel or port with a higher lock priority, or with the same lock priority and same requester code. 
The lower the lock priority number, the higher the priority. 

Panel lock priorities not explicitly defined automatically default to "0" which gives absolute 
authority to clear any lock or protect on the system. The acceptable range of lock priorities is 
shown in the General Specifications Table. 

Requestor Code 

The requester code is used with the lock priority to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a panel (or serial communications port), it can only 
be removed by another panel (or port) with a higher lock priority or with the same lock priority 
and same requester code. 

Requestor codes are also used with protects.  When a destination is placed into protect, only those 
panels/users with the same requestor code can switch the destination. 

Requester codes not explicitly defined automatically default to the panel address. You can also 
select the "Follow Panel Address" box to ensure that the Requestor Code is always identical to 
the Address. 
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Status Method 

When a panel is in all levels mode (ALL LEVS), the status shown will be the source on the Status 
Level assigned to that panel. If the destination is not defined on the Status Level, Status Method 
is used to control the resulting display: 

• If DEF (Default Method) is selected, NO XXXXX will be displayed where XXXXX is 
the Status Level assigned to the panel. 

• If GRP (Group Method) is selected, the controller will examine every level sequentially, 
starting with the level designated as Level Order 1. The source switched on the first level 
found where the destination is defined, will be displayed as the destination status. 

 

Status Level 

One function of the LCD display on a panel is to show which source is currently switched to a 
selected destination. This is known as destination status. Although more than one source can be 
switched to a single destination (limited to one source per level), the status display can only show 
one source at a time. When the panel is in all levels mode (ALL LEVS), Status Level is used to 
designate a default level to be used when displaying status. Only the source on this default level 
will be displayed. Pushbutton only panels also use the status level.  It is used to determine which 
tally LED to light on a panel in a split/breakaway condition. 

 

For the following items, if you need to find out the names of current lists, 
select Configuration > Panel. Use the various List pulldown menus on the 
far right side of the Panel Specific Data tab to review the available lists. 

 

Level Include List 

The Levels Include List is a named list of all levels the panel (or remote client) is authorized to 
control. Enter the name of the list that you want to assign to new panels, or select the ALL Level 
Include List to assign all of the available lists. 

Source Include List 

A source include list is a named list of the sources a specific control panel is authorized to 
control. A source include list may be shared by multiple panels. Enter the name of the list that 
you want to assign to new panels, or select the ALL Source Include List to assign all of the 
available lists. 

Destination Include List 

A destination include list is a named list of the destinations a specific control panel is authorized 
to control. A destination include list may be shared by multiple panels. Enter the name of the list 
that you want to assign to new panels, or select the ALL Destination Include List to assign all of 
the available lists. 

Salvo Include List 

A salvo include list is a named list of the salvos a specific control panel is authorized to control. 
A salvo include list may be shared by multiple panels. Enter the name of the list that you want to 
assign to new panels, or select the ALL Salvo Include List to assign all of the available lists. 
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6.10 Configuration Editor View Menu 
The View commands display or hide the toolbar and status bar. The following commands are 
available: 

 

Figure 120. View Menu 

6.10.1 Toolbar 
The View > Toolbar command hides or displays the bar with the shortcut icons. Select this 
command to display or hide the toolbar. 

 

6.10.2 Status Bar 
The View > Status Bar command hides or displays the bar with the status information that 
displays at the bottom of the 3500Pro window. Select this command to display or hide the status 
bar. 

6.11 Configuration Editor Configuration Menu 
The Configuration commands define all of the settings in the configuration file that allow you to 
remotely access the controller. Use these commands to set up the configuration file, then 
download the configuration file to the controller. The following commands are available. 

 

 

Figure 121. Configuration Menu 

6.11.1 Level/Comp 
The Configuration > System Configuration > Level/Comp provides an interface to work with 
Levels and Components. The following sections describe what levels and components are and 
how to work with them. 

Before Using This Command 

You must have created or opened a configuration file. 
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6.11.1.1 Levels 
The Levels section of the window allows you to add, edit, and delete levels.  

 

Figure 122. Level/Component Configuration Window 

A level is a group of related components that are switched together by 3500Pro. Levels are the 
lowest element that the user can manipulate in the control system.  The maximum number of 
levels in a configuration is 16 (8 for the 3500Pro LE).  The example shown below is a 2x2 RGB 
video level named VID which is made up of three components named RED, GRN and BLU.   

 

  
 

Figure 123. 2x2 RGB Video Level 
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Before Using This Command 

You must have created or opened a configuration file. 

 

Column Descriptions: 

Level #:  Defines the number for the level. You cannot edit this field.  If you want to change the 
Level #, use the Reorder Levels button.  The number implies the order of levels for use on serial 
commands and panel operation.    

Name: Specifies the name of the level. Level names are one to eight characters in length and are 
constructed using uppercase letters, numbers, and spaces. The first character must be a letter.  

Inputs: specifies the number of inputs associated with the level. The maximum number of inputs 
per level is 576 (144 for the 3500Pro LE). 

 

TIME SAVING TIP:  If the Input value is the same for several different levels (for example, 
144), type "144" in the first Input field. Then, select the number you just entered, and highlight 
the rest of the fields below it that have the same value. Click the right-mouse button and select 
Fill Down.  All of the fields will populate with the same Input value.  

 

Example:  Enter the first Input. 

 

Figure 124. Entering an Input 

Select the first input, then highlight the rest of the Input fields with the same value.  Click the 
right mouse button and pick Fill-Down. 

 

Figure 125. Fill Down 
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The highlighted fields are populated.   

 

Figure 126. Populated Fields 

 

Outputs: Specifies the number of Outputs associated with the level. The maximum number of 
inputs per level is 576 (144 for the 3500Pro LE). 

 

TIP:  Use the same method described in the Inputs section to quickly enter Outputs. Or, if the 
Outputs values are the same as the Inputs, highlight all of the Inputs, right-click your mouse, then 
select Fill-Right. 

 

Properties:  Determines if the level is "Chop Enabled".  Select the gray box to enable or disable 
"Chop". When a red check mark displays, Chop is Enabled. 

 
Working with Levels: 
Adding a Level:  You can have a maximum of 16 levels (8 with the 3500Pro LE).  To add a level, 
simply type new level information into a blank row. 

 
Deleting a Level: To delete a level, click on the information you want to remove and press the 
Delete key. You can delete several entries at one time by highlighting all of the fields you want to 
delete, then pressing the Delete key. When you are done deleting a level, select OK. Be sure to 
Save the configuration file.  

 

Reordering Levels: To change the Level numbers, select the Reorder Levels button. The Change 
Level Order window will appear, and you can assign new level numbers to each available level. 
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6.11.1.2 Change Level Order 
You can change the order of levels with the Reorder Levels button. (Configuration > System 
Configuration > Level/Comp > Reorder Levels). This window displays all of the defined Level 
Names and the Level Numbers.  

 

Figure 127. Change Level Order Window 

To change the level number, double-click in the field you want to change, and enter a new level 
number. 

 
Make sure the cursor is blinking inside the field before entering a new level 
number. 

  

The number you enter in this field will be the position in this window. For example, if you enter a 
"5" in the Level Order field, the Level Name will move to the fifth row in the window. If another 
level was already assigned "5", it will move down a row to the "6" row. 
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6.11.1.3 Components 
The Components section of the window allows you to add, edit, and delete comonents. A 
component is the most basic signal element that can be switched by a single crosspoint. 
Components map level inputs/outputs to the actual physical matrix and are collected under a level 
to be controlled by users.  For example, in RGB video, "Red", "Green", and "Blue" are 
components; in stereo audio, "Left" and "Right" are components. The example shown below is a 
2x2 RGB video level named VID which is made up of three components named RED, GRN and 
BLU.  

 

  

Figure 128. 2x2 RGB Video Level 

The maximum number of components in a configuration is 32 (16 for the 3500Pro LE). 

 

Before Using This Command 

You must have created or opened a configuration file. 

 

Column Descriptions: 

Name: defines the name of the component. Component names are one to eight characters in 
length and are constructed using uppercase letters, numbers, and spaces. The first character must 
be a letter. The example shown above is a 2x2 RGB video level named VID which is made up of 
three components named RED, GRN and BLU. For the example, "RED" would be used for the 
first component, "GRN" for the second, and "BLU" for the third.   

Level Name: specifies the name of the level associated with the component. You must have 
already created the level you want to use (in the top half on this window) before you enter the 
value in this field. 

Input Offset: Acceptable values for input offsets are shown in the General Specifications Table. 
For the example shown above, "0" and "0" would be used for the component "RED"; "2" and "2" 
would be used for the component "GRN"; and "4" and "4" would be used for the component 
"BLU". 

Physical Input = Level Input + Component Input Offset 
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3500Pro allows components to overlap in matrix space. Care should be 
taken when entering offsets to ensure that any resulting overlap of 
components is intentional. 

 

TIP:   If the Input value is the same for several different offsets (for example, 0), type "0" 
in the first Input Offset field. Then, select the number you just entered, and highlight the 
rest of the fields below it that have the same value. Click the right-mouse button and select 
Fill-Down.  All of the fields will populate with the same Input Offset value.   

 

Output Offset: Acceptable values for input offsets are shown in the General Specifications Table. 
For the example shown above, "0" and "0" would be used for the component "RED"; "2" and "2" 
would be used for the component "GRN"; and "4" and "4" would be used for the component 
"BLU". 

Type: PRC, TGR (Tiger), XTN (External Manufacturer or Third Party), or RM5 (System 5). 
Select the one you want from the pulldown menu. 

 

Strobe: Enter the Strobe assigned to the routing switcher that contains the component.  

Every routing switcher in a switching system is assigned a strobe. This is usually accomplished 
by setting a DIP switch on the back of the routing switcher. Strobes do not have to be unique and, 
in larger systems, each strobe might be associated with several routing switchers. 
 
In many switching systems, strobes are used to group levels of the same type together. For 
example, video may be on Strobe 1, audio on Strobe 2, etc. 
 
The following table shows the offset, strobe, and address ranges for the RM5 and PRC 
component types: 

Component Types RM5 (System 5) PRC, XTN, TGR 

Offset Range 0-255 0-4094 

Strobe Range 1-5 1-63 

Address Range 1-255 1-4095 

 

RM5 components utilize the System 5 37 pin parallel interface.  PRC, TGR, and XTN matrices 
use the PRC RS-422 based interface.  (PRC, TGR, and XTN matrices are all controlled by the 
same set of commands.  The difference between the components is the boundary size used for 
background checking the matrix health.  PRC uses a 8x8 boundary, TGR uses a 48x16 boundary, 
and the XTN uses a 64x64 boundary.)  

 

Working with Components 

Adding a Component:  You can have a maximum of 32 components (16 for the 3500Pro LE).  To 
add a component, simply type new component information into a blank row, then select the 
necessary options described above. 
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Deleting a Component: To delete a component, click on the information you want to remove and 
press the Delete key. You can delete several entries at one time by highlighting all of the fields 
you want to delete, then pressing the Delete key. When you are done deleting a level, select OK. 
Be sure to Save the configuration file.  

 

6.11.2 CPU Link/Port 
The Configuration > System Configuration > CPU Link/Port command allows you to 
configure the serial ports on the 3500Pro System Controller. This window is broken into two 
sections. See the following sections for information about the items in each section of the 
window. 

 

Figure 129. CPU Link/Port Configuration Window 

CPU Link Protocol Configuration: This section of the window allows you to define up to 16 
CPU Link Protocol Configurations. You can then assign a specific configuration to a port in the 
lower portion of the window. 

Port Configuration: This section of the window defines the actual configuration of the three 
available ports. You can assign specific CPU Link Protocol Configurations defined in the top 
portion of this window with each port (in the Link Name field). 

 

Before Using This Command: 

Create or open a configuration file. 
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6.11.2.1 CPU Link Protocol Configuration 
The Configuration > System Configuration > CPU Link/Port > CPU Link Protocol 
Configuration section determines the format to be used when sending data through the serial 
ports on the 3500Pro System Controller. You can define up to 16 CPU Link Protocol 
Configurations. You can then assign a specific configuration to a port in the lower portion of the 
window.  

 

Link Name 

Defines the name of the protocol configuration being defined. It is used when assigning a 
protocol variation to a serial port.  You can define up to 16 configurations. You will associate a 
defined configuration with a specific port in the lower portion of this window. 

 
Link Type 

This is the protocol that determines the format to be used when sending data through the serial 
ports on the 3500Pro System Controller. Select one from the pulldown menu. There are currently 
three protocols available for use.  
 
1. CPU Link Protocol 1 with Extensions (P1E) (81-9062-0407-0) 

2. Unsolicited Status Protocol (USP) (81-9062-0409-0) 

3. Truck Link Protocol (TRK) (81-9062-0410-0)  Truck link only works when configured for 
COM4.  

 

Checksum 

A checksum determines how the validity of transmitted data will be confirmed. The three 
checksum types available are: 

NONE: No validity checking. 

PESA: Data validity is checked using PESA's standard method.  (See Protocol documentation.)  

HEX ASCII: Data validity is checked using a standard HEX-ASCII checksum. 

 

Terminator 

The terminator is the character(s) to be used to denote the end of a data packet or command 
string. The three terminators available are: 

CR: A carriage return. 

LF: A line feed. 

CL: A carriage return followed by a line feed. 
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Status Filter 

Status filtering allows the user to filter the data sent through the port using USP. This is only 
available for Unsolicited Status Protocol (USP). The nine filters available are: 

A - All Unsolicited Items 

C - Configuration Changes 

D - Dual Transition Changes (Dual 3500Pro Control Systems Only) 

E - Confidence Errors 

G - User Logon/Log Off 

L - Lock/Protect Changes 

P - Physical Switches 

S - Switch Change Requests 

U - User Account Changes 

 

They can be specified in any combination.  Enter the filter you want to use in the Status Filter 
field. 

 

6.11.2.2 Port Configuration 
The Configuration > System Configuration > CPU Link/Port > Port Configuration section 
of the window defines the actual configuration of the three available ports. You can assign 
specific CPU Link Protocol Configurations defined in the top portion of this window with each 
port (in the Link Name field). 

 

Before Using This Command 

You must have defined the CPU Link Protocol Configurations in the top portion of this 
window. 

 

Address 

Defines the port address.  There are three ports that you can configure: 

Port 1 - The default CPU link port which is pre-configured to be used with 3500Pro. The only 
items which may be changed on this port are the Port Name and the Requester Code. 

Port 2 - Available for user configuration. 

Port 3 - Not available. This port is the PRC Communications Port on the 3500Pro System 
Controller and may not be used for external control. 

Port 4 - Available for user configuration. 
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Port Name 

Because a port is identified by its address, the assignment of a port name is optional. If used, port 
names are one to eight characters in length and are constructed using uppercase letters, numbers, 
and spaces. The first character must be a letter. 

 

Requestor 

The requester code is used with the lock priority to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a port (or panel), it can only be removed by another 
port (or panel) with a higher lock priority or with the same lock priority and same requester code. 

 

Requester codes not explicitly defined automatically default to 1024, 1025, and 1027 for Ports 1, 
2, and 4 respectively. 

The acceptable range of requester codes is shown in the General Specifications Table. 

Lock Priority 

The lock priority is used with the requester code to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a port or panel, it can only be removed by another 
port or panel with a higher lock priority, or with the same lock priority and same requester code. 
The lower the lock priority number, the higher the priority. 

Port lock priorities not explicitly defined automatically default to "0" which gives absolute 
authority to clear any lock or protect on the system. The Lock Priority assigned to Port 1, which 
may not be changed, is "0". 

The acceptable range of lock priorities is 0-255 ("0" is Highest Priority). 

 

Link Name 

Defines the CPU Link Protocol Configuration you want to associate with this port. Each 
configuration in the top portion of this window is identified by its Link Name. Enter the Link 
Name you want to use from the top portion of the window in this field to assign the correct 
configuration. 

 

Baud Rate 

Baud rate is the data transfer rate through the serial port measured in Baud (bits per second). 

A baud rate of either 9600 or 38400 may be selected for Port 2 and Port 4.   Port 1’s baud rate is 
specified by the DIP switch on the controller board and cannot be set via the configuration 
software.  The baud rate is either 9600 or 38400 baud.   

 

Stop Bits 

In asynchronous communications, a stop bit is a bit that indicates that a byte of data has just been 
transmitted. Every byte of data is preceded by a start bit and followed by a stop bit. 

Either 1 or 2 stop bits may be selected for Port 2 and Port 4. The number of stop bits assigned to 
Port 1, which may not be changed, is 2. 
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6.11.3 Configuration Info 
The Configuration > System Configuration > Configuration Info window shows information 
about the configuration currently open in 3500Pro. 
 

 
Figure 130. Configuration Information Window 

 
Configuration Name: 
 
This field allows you to name or rename the current configuration. Type the desired name in the 
Configuration Name box. Configuration names may have up to 32 alphanumeric characters. 
You can query on this name from the 3500Pro System Controller.  
 

  
The Configuration Name may be different from the file name. 

 
Chop Rate: 
The CHOP rate indicates the frames rate of switches used by the Chop mode of operation.  To 
change the chop rate, enter the desired value in the Chop Rate box. The range of Chop Rates the 
3500Pro Control System can be configured for is between 1 and 255. 
 
Case Sensitivity: 
This option specifies whether the 3500Pro software distinguishes between upper and lower case 
letters when you are entering information in the category, source, destination, and reentry 
windows. For example, if you have Case Sensitivity turned ON, the software will recognize when 
you enter information using capital letters.  If you have Case Sensitivity turned off, it doesn’t 
matter if you use lower or upper case.  
After making changes, click the OK button to close the window. Be sure to save the 
configuration file. 
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6.11.4 Matrix Configuration 
The Configuration > Matrix Configuration command allows you to define Sources and 
Destinations.  

The maximum number of sources and destinations is 600 (180 for the 3500Pro LE). 

There are 2 tab sheets in this window, one for sources, and the other for destinations. The 
Destinations tab displays in yellow so you can easily determine which tab sheet you are working 
with.   

Before Using This Command 

You must have already used the Configuration > System Configuration > Level/Comp 
command to set up all of the levels. 

 

6.11.4.1 Sources 
The Matrix Configuration > Sources tab allows you to define all of the sources in the 
configuration. Only one source per level is allowed.  A level may be left undefined on a source.  
Inputs may be shared between different sources.  The maximum number of sources is 600 (180 
for the 3500Pro LE). 

 

Figure 131. Matrix Configuration Sources Window 
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Name 

Specifies the name of each source . Type in the name you want to use in this field. 

Src 

Identifies the source number. As you enter Names, this field will automatically display a number.  
The source number is a numeric alias that can be used to refer top the source.  This is used by the 
serial protocols and incremental edits.   

Levels 

The remaining columns identify the input on each level that you defined with the Levels window. 
For each level, enter the source that corresponds with each Source Name.  

 

6.11.4.2 Destinations 
The Matrix Configuration > Destinations tab allows you to define all of the sources in the 
configuration. The maximum number of destinations is 600 (180 for the 3500Pro LE). 

 

Figure 132. Matrix Configuration Destinations Window 
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Name 

Specifies the name of each destination . Type in the name you want to use in this field. 

Src 

Identifies the destination number. As you enter Names, this field will automatically display a 
number.  The destination number is a numeric alias that can be used to refer top the destination.  
This is used by the serial protocols and incremental edits.   

 

Levels 

The remaining columns identify the input on each level that you defined with the Levels window. 
For each level, enter the destination that corresponds with each Source Name.  

 

6.11.5 Panels 
The Configuration > Panels command adds new panels to the configuration. At the top of the 
window, a graphic illustration of the selected panel displays. Below the graphic, there is a list of 
all the currently defined panels.   

The following tabs display in this window: 

• Panel Specific Data  

• Data Key Definition  

• Panel Access Lists  

• List Assignment  

• Salvo Key Definition  

 

Before Using This Command 

You must have already set up Levels and Components. 

You must have already set up the Matrix Configuration. 

 

Adding a New Panel 

1. Choose the Specific panel tab  

2.  Select the New Panel button.  

3. Select the panel from the Type list.   

4. Enter the Requestor Code. 

5. Enter the lock priority 

6. Enter the status method.  
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6.11.5.1 Panel Specific Data 
The Panel Specific Data tab allows you to add new panels, edit existing panels, and delete 
panels. This tab also allows you to define information about the panel, such as name, address, and 
so on.  The following fields are available in this panel: 

 

Figure 133. Panel Configuration Window, Panel Specific Data Tab 

Type 

This field identifies the type of panel.  This field is read-only unless you select the New Panel 
button. The panel you select here displays in the middle section of the window in the Type field. 

Address 

This indicates the physical address of the control panel. Every control panel has DIP switches on 
the back. These switches are used to set a unique address for each panel in a switching system. 
Find out what the address is, and enter it here. The address you enter here displays in the middle 
section of the window in the Address field. 

Requestor Code 

The requester code is used with the lock priority to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a panel (or serial communications port), it can only 
be removed by another panel (or port) with a higher lock priority or with the same lock priority 
and same requester code. 
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Requestor codes are also used with protects.  When a destination is placed into protect, only those 
panels/users with the same requestor code can switch the destination. 

Requester codes not explicitly defined automatically default to the panel address. 

Lock Priority 

The lock priority is used with the requester code to determine if a lock or protect can be removed. 
When a lock or protect has been assigned by a panel or port, it can only be removed by another 
panel or port with a higher lock priority, or with the same lock priority and same requester code. 
The lower the lock priority number, the higher the priority. 

Panel lock priorities not explicitly defined automatically default to "0" which gives absolute 
authority to clear any lock or protect on the system. The acceptable range of lock priorities is 
shown in.the General Specifications Table. 

 

Status Method 

When a panel is in all levels mode (ALL LEVS), the status shown will be the source on the Status 
Level assigned to that panel. If the destination is not defined on the Status Level, Status Method 
is used to control the resulting display: 

 
If DEF (Default Method) is selected, NO XXXXX will be displayed where XXXXX is the Status 
Level assigned to the panel. 

If GRP (Group Method) is selected, the controller will examine every level sequentially, starting 
with the level designated as Level Order 1. The source switched on the first level found where the 
destination is defined, will be displayed as the destination status. 

 

Name 

Because a panel is identified by its address, the assignment of a panel name is optional. If used, 
panel names are one to eight characters in length and are constructed using uppercase letters, 
numbers, and spaces. The first character must be a letter. The name you enter here will display in 
the middle portion of the window as the "Name" of the panel. 

 

Status Level 

One function of the LCD display on a panel is to show which source is currently switched to a 
selected destination. This is known as destination status. Although more than one source can be 
switched to a single destination (limited to one source per level), the status display can only show 
one source at a time. When the panel is in all levels mode (ALL LEVS), Status Level is used to 
designate a default level to be used when displaying status. Only the source on this default level 
will be displayed. Pushbutton only panels also use the status level.  It is used to determine which 
tally LED to light on a panel in a split/breakaway condition. 

 

Default Dest 

Select the default destination for which status will be displayed when power is applied to a panel, 
or when a new configuration is downloaded to the controller.  
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The panel will have control over the destination selected here, even if it is not included in the 
associated destination include list. 

 

Data Key List 

A data key is a user configurable control panel key, whose assigned function is used when the 
panel is in any mode except Salvo Select Mode. 

A data key list is a named list of the functions assigned to each data key on a panel. A data key 
list may be shared by multiple panels as long as they are the same type of panel. Different panel 
types may not use the same data key list. 

Define new Data Key Lists with the Data Key Definition tab. 

 

Level List 

The Levels of Control List is a named list of all levels the panel (or remote client) is authorized to 
control. Two special lists come pre-configured: ALL and NONE.  Define new items that should 
appear in this list with the Panel Access Lists tab (in the Include List Type section, select Level). 

 

Src Include List 

A source include list is a named list of the sources a specific control panel is authorized to 
control. A source include list may be shared by multiple panels. 

The Source Include List is a named list of all sources the panel is authorized to control. It 
functions the same as the LEVELS OF CONTROL LIST window. Define new items that should 
appear in this list with the Panel Access Lists tab (in the Include List Type section, select Source). 

 

Dst Include List 

A destination include list is a named list of the destinations a specific control panel is authorized 
to control. A destination include list may be shared by multiple panels. The default destination 
assigned to a panel may be controlled even if it is not on the destination include list. Define new 
items that should appear in this list with the Panel Access Lists tab (in the Include List Type 
section, select Destination). 

 

Slv Include List 

A salvo include list is a named list of the salvos a specific control panel is authorized to control. 
A salvo include list may be shared by multiple panels. Define new items that should appear in this 
list with the Panel Access Lists tab (in the Include List Type section, select Salvo). 

 

Salvo Key List 

A salvo key is a user configurable control panel key, whose assigned function is used when the 
panel is in salvo select mode. A salvo key list is a named list of the functions assigned to each 
salvo key on a panel. A salvo key list may be shared by multiple panels as long as they are the 
same type of panel. Different panel types may not use the same salvo key list. Define new items 
that should appear in this list with the Salvo Key Definition  window. 
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New Panel 

The New Panel button adds a new panel to the list in the center of the screen. You need to select 
the Type of panel to add, and define all of the other information about the panel (on all five tab 
sheets). 

 

Copy Panel 

Copies all of the information about the currently selected panel and creates a new panel with 
identical information. The new panel will automatically display in the list in the middle of the 
window with a new panel address. You can then enter a name and description for the new panel. 

 

Delete Panel 

Deletes the currently selected panel.  

 
Make sure you really want to delete the panel before selecting this 
command. You cannot "Undo" this action. 
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6.11.5.2 Data Key Definition 
The Data Key Definition tab sheet defines the settings for each configurable control panel key, 
whose assigned function is used when the panel is in any mode except Salvo Select Mode.  At the 
top of the window, a picture of the currently selected panel displays. Click on the buttons on the 
control panel to see the Data Key that is assigned to the button. You can change which panel you 
are reviewing by selecting another panel from the middle part of the window (with Address, 
Name, and Type listed). Also, the List Names that are defined in this tab sheet are the items that 
display in the Data Key List in the Panel Specific Data tab.   

 

Figure 134. Data Key Definition Tab 

Definition List 

This identifies the Key Type and Name/Category associated with a specific button on the panel. 
When you select an item from this list, the graphic at the top of the screen will highlight the 
button you selected. To change the definition, double-click items in the Sources, Destinations, 
Levels, or Categories lists. 

 

Sources 

Lists all of the available sources for the panel. Double-click any item in this field to assign it to 
the currently selected key. You can also copy and paste. 
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Destinations 

Lists all of the available destinations for the panel. Double-click any item in this field to assign it 
to the currently selected key. 

 

Levels  

Lists all of the available levels. Double-click any item in this field to assign it to the currently 
selected key. 

 

Categories 

Lists all of the available categories.  Double-click any item in this field to assign it to the 
currently selected key. 

 

Soft Sources/Soft Destinations 

Typing SSRC or SDST sets the data key type to a soft key.  A soft key can be programmed by the 
user at a panel.  

 

List Name 

Shows the existing Data Keys. These items display in the Data Key List pulldown in the Panel 
Specific Data tab.  When you select the New DK List button, a new line displays in this section. 
You can double-click any name in this list, and type in a new name. 

New DK List 

Adds a new Data Key List to the List Name field. Type in the name for the new list. 

   

Copy DK List 

Copies the information in the currently selected Data Key List and creates a new Data Key List 
with identical information. The new Data Key List will display in the List Name field and you 
can specify a new name for the list. 

 

Del DK List 

Deletes the Data Key List that is selected in the List Name field. 

 
Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action. 
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6.11.5.3 Soft Key Definition 
Soft Keys can be configured locally at the panel using Store Mode, or with 3500Pro. 

 

Soft Keys cannot be configured until at least one soft key has been defined 
in the Data Key List assigned to the panel. 

 

6.11.5.4 Panel Access Lists 
The Panel Access Lists window shows the include lists for Levels, Sources, Destinations, and 
Salvos. Include lists are named lists of the Levels, Sources, Destinations, and Salvos a specific 
control panel is authorized to control. A source include list may be shared by multiple panels. 

 

Figure 135. Panel Access List Tab 
Include List Type 

Lists the types of include lists you can review or edit.  Click on the button to the left of the list. 

List Name 

Lists the names of the lists associated with each list type. Click on each item in this list to review 
its contents. 

PESA SWITCHING SYSTEMS  116 



81-9059-0549-0 Rev B  3500PRO SOFTWARE AND SYSTEM CONTROLLER 

Associated Panels 

Shows the panels associated with each list you select in the List Name field. To associate a list 
with a panel, go to the Panel Specific Data tab.  Select an item from the Level List, Src Include 
List, Dst Include List, or Slv Include List. After you select a list to associate with the panel, the 
panel name and number will display in this field. 

 

New Inc. List 

Create a new Include list in the List Name field.  Be sure to first select the type of list you want to 
create in the Include List Type Field. After you select this button, type in a name for the new list. 

 

Copy Inc. List 

Copies the Level and Include List settings for the selected List Name and creates a new item in 
the List Name field. You can then enter a different name for the new list item.  

 

Del Inc. List 

Deletes the selected list from the List Name field. 

 
Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action. 

 

Include List Contents 

Levels/Sources/Destinations/Salvos 

The title and contents of this section will change depending on which item you select in the 
Include List Type field:  

Level: This section will show all of the available levels.  

Source: This section will show all of the available sources. 

Dest: This section will show all of the available destinations. 

Salvo: This section will show all of the available salvos. 

 

Include List 

Shows all of the items in the include list.  To add an item to the include list, select it from the left 
portion of the window, then select the >> button. The items will move from the left column to the 
right column.  
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6.11.5.5 List Assignment 
The List Assignment tab shows all of the panel lists that are currently defined, the panels that are 
actually available, and the panels that are associated with each different list. 

 

Figure 136. List Assignment Tab 

Panel List: 

This section lists each of the different types of panel lists. Select each button to review the lists 
available. 

List Name: 

Shows the lists available for the type of panel list you select in the Panel List section. Select each 
individual list to review the panels that are currently available, and the panels that are currently 
associated with the list. 

 

Available Panels: 

This section shows all of the panels that are currently available to associate with the selected List 
Name. To associate an available panel with the selected list, select the panel then select the >> 
button. The panel will move from the Available Panels to Associated Panels column. 
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Associated Panels: 

Shows the panels actually associated with the selected List Name. To disassociate a panel from 
the list, select the panel name then select the << button. The panel will move from the Associated 
Panels column to the Available Panels column. 

6.11.5.6 Salvo Key Definition 
A salvo key is a user configurable control panel key, whose assigned function is used when the 
panel is in salvo select mode. 

A salvo key list is a named list of the functions assigned to each salvo key on a panel. A salvo key 
list may be shared by multiple panels as long as they are the same type of panel. Different panel 
types may not use the same salvo key list. 

 

Figure 137. Salvo Key Definition Tab 

 
A Salvo Key List cannot be created until at least one salvo has been 

configured. 
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Salvo Group 

This field shows the salvo group associated with each individual button on the panel.  You can 
click on the button on the panel at the top of the window to see that salvo group associated with 
it. Or, you can select the row to highlight the associated panel button. 

List Name 

Shows the names of the defined salvo lists.  This window shows the salvo groups associated with 
the list. 

Salvo Grps 

The Salvo Grps shows the currently defined Salvos (using the Configuration > Salvo command).   

New SK List 

Adds a new Salvo list to the List Name field. Type in a new name for the lists, then select the 
salvos to associate with it from the Salvo Grps field. 

Copy SK List 

Copies the information in the currently selected Salvo List and creates a new List with identical 
information. You can then change the name of the new Salvo List. 

Delete SK List 

Deletes the selected List Name.  

 

Make sure you really want to delete the list before selecting this command. 
You cannot "Undo" this action.  

 

6.11.6 Salvo 
The Configuration > Salvo command allows you to add, edit, and delete Salvos.  A salvo is a 
group of predefined logical switches taken at the same time. All switches in a salvo are taken 
within the same vertical interval. The maximum number of salvos is 128 (64 for the 3500Pro LE). 

 

Before Using This Command 

• You must have already set up Levels and Components (with the Configuration > System 
Configuration Level/Comp command). 

• You must have already set up Sources and Destinations (with the Configuration > Matrix 
Configuration command). 
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Adding a New Salvo: 

 
1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, enter a name for the salvo. The number field will be 
automatically populated. 

3. Make sure you do not highlight another row in the Salvo Groups field, then click in the 
Destination field in the top row of the Salvo Entries section.  

4. Scroll through the Destinations list at the top of the window. When you find the Destination 
you want to assign to the Salvo, double-click it. The Destination name displays in the Salvo 
Entries list.  

5. Follow the same procedures for the Sources. In the Salvo Entries section, highlight the 
Source field you want to define. Scroll through the Sources list, then double-click the source 
you want to use.  

If you want to fill in several levels all at once, you can click Fill All Levels.  This will assign 
one Source to all levels. Or, you can select specific levels you want to automatically populate 
by select items from the Fill Level section. Each level that is highlighted will be 
automatically assigned a source that you double-click. 

6. After completing one salvo, you can go back to the Salvo Groups section, click on the second 
row, and repeat this process. 

7. When you are finished entering salvos, click OK to save your changes and to close the 
window. 

Editing a Salvo 

1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, select the salvo you want to edit. 

3. Change any of the Destination and Source information following the procedures outlined for 
adding a new salvo. 

4. When you are finished editing one salvo, you can select another from the Salvo Groups list, 
and edit it. 

5. When you are finished editing, select the OK button to save your changes and close the 
window. 

 
Deleting a Salvo 

1. Select Configuration > Salvo to open the Salvo Configuration window.  

2. In the Salvo Groups section, select the Name of the salvo you want to delete. 

3. Select the Delete button, and the salvo will be deleted. 

4. When you are finished deleting one salvo, you can select another from the Salvo Groups list, 
and delete it. 

5. When you are finished, select the OK button to save your changes and close the window. 
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6.11.7 Categories 
The Configuration > Category option defines categories. A category is an optional entity 
assigned to a panel key that may be used alone, or with other categories, to select a source, 
destination, or reentry.  Categories, if used, are simply sub strings used to build names (source, 
destination, and reentry) by concatenation. When the user presses a category button on a panel, 
the category is concatenated onto the right side of the name in the preset. If necessary, the left 
side of the name will be trimmed to bring its length to a maximum of eight characters. 

 

Figure 138. Category Configuration Window 

Functionally, categories only affect panel operations where panels have been defined to have 
categories assigned to their data keys.  

Panels can have one or two categories assigned to a data key. When the user presses a category 
button, the panel concatenates the category to the source or destination name on the panel. 

When two categories are assigned to a button, the panel uses the first category if the preset is 
blank. Otherwise, the panel concatenates the second category. This requires the user to use the 
CLEAR button to clear out the preset name before accessing the first category assigned to a key. 

When there is only one category assigned to a button, it is always concatenated to the name in the 
preset. 
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For example, given a panel with the following definitions: 

Button 1

Cat1: VTR

Cat2: 0

Button 2

Cat1: CAM

Cat2: 1

Button 3

Cat1: CG

Cat2: 2

Button 4

Cat1: 3

Cat2:

Button 5

Cat1: 4

Cat2:
 

To access VTR13 and take it online, the user would press: 

CLEAR (Clears out the name in the preset display) 

Button 1 (VTR in the preset display) 

Button 2 (VTR1 in the preset display) 

Button 4 (VTR13 in the preset display) 

TAKE (Causes VTR13 to be taken to the active destination.) 

 

You can assign up to 254 categories. To enter a category, click in the field and type the category 
name.  
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6.11.8 Tielines 
The Configuration > Tielines command defines tielines, which are special types of logical 
switches that allow a logical input on one level to be switched to a logical output on a different 
level.  

 

Figure 139. Tieline Configuration Window 

Tielines are not available with the 3500Pro LE. 

The maximum number of tielines is 64. 
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The example shown demonstrates a tieline being used to route a video signal from an analog 
camera, through an external analog-to-digital converter, to a digital VTR. 

ROUTING SWITCHER

LOGICAL
OUTPUTS

1
2
3
4
5
6
7
8

LOGICAL
INPUTS

3 4 51 2 6 7 8

TLINE1

ANCAM

ROUTING SWITCHER

LOGICAL
OUTPUTS

1
2
3
4
5
6
7
8

3 4 51 2 6 7 8

ANALOG TO DIGITAL CONVERTER
LEVEL ANAVID

LOGICAL
INPUTS

DIGVTR

LEVEL DIGVID

 

Figure 140. Tieline Example 

 
Once a Tieline has been configured, it may then be used by a source. 

 

Adding a Tieline 

1. To add a tieline, follow these steps. 

2. Click in a blank field at the bottom of the screen. If you do not select a blank field, an 
existing tieline will be overwritten. A blank row will highlight. 

3. At the top of the window, enter a name in the Tieline Name field.  

4. Select the Output Level and Output # for the tieline. The output cannot be used by any other 
tieline or destination. 

5. Next, select the Input Level and Input # for the tieline. 

6. Select Add/Edit Tieline. The tieline displays in the list at the bottom of the window. 

 
Editing a Tieline 

To edit a tieline, follow these steps. 

1. Select the tieline you want to edit.  

2. Enter the new information in the upper portion of the window.  

After you are done editing information, select the Add/Edit Tieline button. The new information 
will display in the tieline. 
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Deleting a Tieline 

To delete a tieline, follow these steps. 

1. Select the tieline you want to delete. 

2. When the row highlights, select the Delete Tieline button. The tieline will be removed from 
the list. 

6.11.9 Reentry 
The Configuration > Reentry command adds reentries, entities which exist as both a source and 
destination at the same time. The function of Reentries is to facilitate switching a single source to 
multiple destinations, with a single logical switch. 

 

Figure 141. Reentry Configuration Window 

 

Reentries are not available with the 3500Pro LE. 

Example (see below): Assume there exists source SRC1 and destinations DST1, DST2, and 
DST3. Reentry REENT1 is created and switched to the three destinations. With a single logical 
switch, SRC1 can now be switched to REENT1 and the signal will arrive at all three destinations 
at the same time. 

SRC1 REENT1 DST2

DST1

DST3
 

Figure 142. Reentry Example 
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The maximum number of reentries is 8. 

 

 
Once a Tieline has been configured, it may then be used by a source.  

 

Adding a Reentry 

1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. In the Name field, type the name of the Reentry.  

3. In the Source # field, type the source number. Tielines can be used as sources. 

4. In the Dest # field, type the destination number. 

5. Select OK to close the window. 

 

Editing a Reentry 

1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. Change any of the information in the window. 

3. Select OK to close the window. 

 
Deleting a Reentry 

1. Select Configuration > Reentry to open the Reentry Configuration window. 

2. Highlight name of the Reentry you want to delete. 

3. Press the Delete button. The reentry is deleted.  

4. Select OK to close the window. 
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6.11.10 Remote Client 
The Configuration > Remote Clients command allows you to add, edit, and remove remote 
clients from the 3500Pro system. This window defines the part of the matrix that remote clients 
can see and control. The e-Route Controller uses remote clients to provide names, passwords and 
privileges for its users.   

 

Figure 143. Remote Client Configuration 

 

Remote Client settings are associated with the configuration file. You must 
enter remote clients for each individual configuration file. 

  

Before Using This Command 

Remote clients must have the eRoute Controller and software. 
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Adding a New Remote Client 

1. Select Configuration > Remote Client to open the Remote Client Configuration window. 

2. In the User Name field, type in the user’s name. 

3. In the Password field, type in a password for the user. As you type the password, it will 
display in the field. As you select the next field, however, the password will be encrypted and 
you will no longer be able to tell what the password is. Be sure the remote user knows his or 
her user name and password. 

4. Select the Lev Include field for the user, then from the Level Incl. field select the levels you 
want the user to access. If they should have access to all levels, select All. The options that 
display in the Level Incl. field are defined in the Configuration > Panels window in the List 
Assignment tab as Level Include Lists.  

5. Select the Src Include field for the user. In the Src Incl box at the top of the window, select 
the sources the user should be able to access. If they should have access to all sources, select 
All. The options that display in the Level Incl. field are defined in the Configuration > 
Panels window in the List Assignment tab as Source Include Lists. 

6. Select the Dst Include field for the user. In the Dst Incl box at the top of the window, select 
the destinations the user should be able to access. If they should have access to all 
destinations, select All. The options that display in the Level Incl. field are defined in the 
Configuration > Panels window in the List Assignment tab as Destination Include Lists. 

7. The Options field provides a place to enter additional information about the user. You can 
enter a text string here.  

8. Now you can add additional users if necessary. 

9. When you are finished, select OK to save your changes and to close the window. 

 

Editing a Remote Client 

1. Select Configuration > Remote Client to open the Remote Client Configuration window. 

2. In the lower part of the window, select the user you want to edit. The user name field 
highlights. 

3. Make changes to any of the information for the user.  

4. When you are finished, you can either add, edit, or delete other users, or select OK to save 
your changes and close the window. 

 

Deleting a Remote Client 

1. Select Configuration > Remote Client to open the Remote Client Configuration window. 

2. In the lower part of the window, select the user you want to delete. The user name field 
highlights. 

3. Select Delete, then press Enter. The user will be deleted.  

You can now add, edit, or delete additional users, or select OK to save your changes and close 
the window.  
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6.12 Window Menu 
The Window menus arrange the windows that display in the 3500Pro interface. The following 
commands are available: 

 
• New Window  

• Cascade  

• Tile Horizontal  

• Tile Vertical  

• Arrange Icons  

 

6.12.1 New Window 
The Window > New Window command opens a second window that displays the same 
information as the currently active window. 

 

6.12.2 Cascade 
The Window > Cascade command arranges all of the open windows so that they slightly overlap 
one another. 

 

6.12.3 Tile Horizontal 
The Window > Tile Horizontal command arranges all of the open windows so that they all 
appear on the screen in a horizontal row. 

 

6.12.4 Tile Vertical 
The Window > Tile Vertical command arranges all of the open windows so that they all appear 
on the screen in a vertical row. 

 

6.12.5 Arrange Icons 
The Window > Arrange Icons command lines up icons of collapsed window in a row along the 
bottom of the screen. 
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6.12.6 Open Windows 
The currently open windows are listed at the bottom of the Window menu. The currently active 
menu has a check mark next to it. To quickly switch to another open window, select another 
window from this list, and it will become active and display. 

 

6.13 Help Menu 
 

The Help menu displays the 3500Pro help file and also the current version number of the 
3500Pro software. The following commands are available: 

• Contents  

• Search for Help On  

• About  

 

6.13.1 Contents 
The Help > Contents option opens the contents tab of the help file. From there, you can browse 
for the topic you want to review. 

 

6.13.2 Search for Help On 
The Help > Search for Help On option opens the Index tab of the help file. Type in a word you 
need help on, and matching items will highlight in the window. Double-click an item to open the 
help topic.  

 
You can also use the Find tab to search on any word in the help file. Try this 
option if the topic you are looking for is not listed in the index. 

 

 

6.13.3 About 
The Help > About option displays the version of the 3500Pro software. In addition, if you select 
the System Info button, detailed information about your computer hardware and software 
displays.  This information is useful to review if you need to call Technical Support.  
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Chapter 7 - 3500Pro Diagnostics 
 

The 3500Pro Diagnostics module allows you to perform diagnostic procedures on the 3500Pro 
software and controller.   

 

Prior to performing any diagnostic or reset function that affects the 
configuration or operation of the 3500Pro System Controller, you must be 
logged on to the controller and have the appropriate privileges assigned to 
your  user account (if user accounts are used). 

 

The following menu items are available: 

 

• File Menu  

• View Menu  

• Tools Menu  

• Panel Menu  

• Readback Menu  

• Window Menu  

• Help Menu  

 

7.1 File Menu 
The File menu option allow you to login to the module, close the active window, and exit the 
application. The following commands are available: 

 

 

Figure 144. File Menu 

7.1.1 Login 
The File > Login command allows you to log into the application. Enter your user name and 
password, then select OK. 

 
If you did not create Users with the 3500 Pro User Manager module, the 

Login option will not be available. 
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7.1.2 Close 
The File > Close command closes the currently active window. 

 

7.1.3 Exit 
The File > Exit command closes the 3500Pro Diagnostics window. 

 

7.2 View Menu 
The View commands display or hide the toolbar and status bar. The following commands are 
available: 

 

 

Figure 145. View Menu 

7.2.1 Diagnostics Toolbar 
The View > Toolbar command hides or displays the bar with the shortcut icons. Select this 
command to display or hide the toolbar. 

 

7.2.2 Diagnostics Status Bar 
The View > Status Bar command hides or displays the bar with the status information that 
displays at the bottom of the 3500Pro window. Select this command to display or hide the status 
bar. 
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7.2.3 Matrix Confidence 
The View > Matrix Confidence command displays information about the matrix status.  You 
cannot edit any of the information in this window.  If the matrix confidence charts display in 
green, there is high confidence that the controller can communicate with the matrix. If the chart 
displays in red, there is not confidence in the matrix. 

 

Figure 146. Matrix Confidence Window 

Before Using This Command 

You must have set up the configuration for each component with the 3500Pro Configuration 
Editor module with the Configuration > System Configuration > Level/Comp command (in 
the Configuration module). 

The configuration files you are working with are valid. 

Components: 

At the top of the window, the available components display. You can click on each component to 
view the matrix status.  

Component Info: 

When you click on each component in the top portion of the window, information about the 
component displays in this area. The information includes Matrix Type, Strobe, Starting Input, 
Ending Input, Starting Output, and Ending Output. 

 

Confidence Matrix: 

This window is a map of the physical inputs and physical outputs of the selected component. 
Each small square represents one physical switch. If the confidence is good, the block displays in 
green. Physical switches in blocks having a confidence error will be display in red. Move your 
cursor over the different blocks to review information about it in the Current Block section. 

PESA SWITCHING SYSTEMS  134 



81-9059-0549-0 Rev B  3500PRO SOFTWARE AND SYSTEM CONTROLLER 

Current Block: 

Displays the Inputs and Outputs for the block you are highlighting in the Confidence Matrix 
graphic. 

7.2.4 Panel Status 
The View > Panel Status command displays information about the available panels. You cannot 
edit any of this information. To change configuration information for the panels, use the 
Configuration Editor module or On-Line Panel Editor modules. See Panels or 3500 Pro On-Line 
Panel Editor for details. 

 

Figure 147. Panel Status Window 

The following information displays for each panel: 

 

Address: Displays the address for the panel. 

Name: Displays the name of the panel. 

Type: Displays the type of panel.  

Online: Displays whether or not the panel is currently online. 

Port: Displays the port number of the panel. 

 
TIP: Double-click the column title to sort the column in ascending or descending order. 

 

Select the Reset button to Reset the panel. 

 
The panel will be offline until the reset procedure is complete! 
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7.2.5 Readback Status 
The View > Readback Status command displays which physical switches are currently active as 
reported by the routing switcher.  

 
You cannot edit any of the information in this window. 

 

Figure 148. Readback Status Window 

Components 

Displays the currently active components. Click on each component to review information about 
it in other parts of the window. 

 

Dest 

Displays the physical outputs defined for the component selected in the Components section. The 
first column displays the Destination names, and the second column displays physical outputs. 

 

Component Info 

Displays the following information about the component that is selected in the Components 
section:  Matrix Type, Strobe, Starting Input, Ending Input, Starting Output, Ending Output. 

 
Commands 

Provides the Physical Switch button. This opens a second window that allows you to perform 
simple takes, and all call/diagonal diagnostic procedures. 
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7.2.6 Memory Status 
The View > Memory Status command displays memory information about the controller.  The 
Reset Controller button resets the controller. You cannot edit any of the information in this 
window.  

 

Figure 149. Memory Status Window 

The following information displays: 

 
Controller Software:  Displays the name and current version of the controller software. 

Memory Status: Displays general information about the memory status, including Help Free, 
Biggest Heap Free, Novram Free, and Biggest Novram Block. 

Reset Controller:    Causes the controller to reset.   

 

 

This will take the controller off line during the reset period and will reset all user 
panels.  Only select this option if you are sure this is what you want! 

7.3 Tools Menu 

7.3.1 Controller Status 
The Tools > Controller Status command displays the current status of the controller. The 
information that displays is: 

 

Controller is:  Displays the name and current version number of the controller software. 

 

Block Status:  Indicates if the block status is valid. 

 

Panel Status:  Indicates if the panel status is valid. 

Press Continue to close the window and return to the main Diagnostics window. 
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7.3.2 Offline Warning 
The Tools > Offline Warning command, if selected, displays a message when the controller is 
offline.  Select this command to turn this option on and off. 

7.3.3 Restore Router 
The Tools > Restore Router command refreshes the matrices with the logical switches stored in 
the configuration. When you select this command, a window displays that notifies you of what 
will occur. Select OK to continue to restore the matrices, or select Cancel to return to the main 
window.  

 

You can use this command if you changed any of the switcher settings with a the Physical Switch 
command. 

7.3.4 Block Check Disable! 
The Tools > Block Check Disable! command turns block checking off. This can be useful when 
troubleshooting system problems. This will cause the current state to be reported and allow it to 
be toggled if desired. 

 

7.3.5 Block Check Enable! 
The Tools > Block Check Enable! command turns block checking on. If you used the Tools > 
Block Checking Disable! command to turn block checking off, use this command to turn block 
checking back on. 

 

7.3.6 Switcher Disable! 
When troubleshooting system problems, it may occasionally be useful to disable all routing 
switchers in the system. To do so, select Tools > Switcher Disable!.  

 

This mode causes the controller to simulate the matrix function.  No switches are actually taken 
on the physical matrix.    

7.3.7 Switcher Enable! 
The Tools > Switcher Enable! command enables all routing switchers in the system. If you used 
the Tools > Switcher Disable! command to disable all switchers, this command will enable them 
again.  

 

7.3.8 Background Update Disable 
The Tools > Background Update Disable! turns off standard background activity that occurs 
during the readback status screen.   
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7.3.9 Background Update Enable 
The Tools > Background Update Enable! turns on standard background activity the 3500Pro 
performs in displaying the readback window.  At times, this background activity could cause the 
computer to run slower, so you can turn off the background checking to increase CPU 
performance.  If you use the Tools > Background Update Disable! command to turn off 
background activity, use this command to enable it. 

 

7.4 Panel Menu 
The Panel menu sorts information in the View > Panel Status window.  

 

 
You cannot access these commands until you select View > Panel Status and 
the Panel Status window displays. 

 

The following commands are available: 

 

 

Figure 150. Panel Menu 

 

7.4.1 Sort Ascending 
The Panel > Sort Ascending command sorts information in the Panel Status window in 
ascending order.  

 

7.4.2 Sort Descending 
The Panel > Sort Descending command sorts information in the Panel Status window in 
descending order.  

 

7.5 Readback Menu 
The Readback menu sorts information in the View > Readback Status window.  

 
You cannot access these commands until you select View > Readback Status 
and the Readback Status window displays. 

The following commands are available: 
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Figure 151. Readback Menu 

7.5.1 Sort Ascending 
The Readback > Sort Ascending command sorts information in the Readback Status window 
in ascending order.  

 

7.5.2 Sort Descending 
The Readback > Sort Descending command sorts information in the Readback Status window 
in descending order. 

 

7.5.3 Physical Switch 
The Readback > Physical Switch command allows you to perform simple takes, all call, and 
diagonal diagnostic procedures.  

 

Figure 152. Physical Switch 

Components to Switch 

Before working with the window, first select the component you want to switch. The available 
components display in this drop-down list. 

 

Simple Take 

PESA SWITCHING SYSTEMS  140 



81-9059-0549-0 Rev B  3500PRO SOFTWARE AND SYSTEM CONTROLLER 

The Simple Take section switches a specific physical switch. 

 

Performing a Simple Take: 

1. Select the Input and Output to switch. 

2. Select the Take button. 

All Call 

An all call is a diagnostic procedure that causes a single physical input to be switched to a range 
of physical outputs, for a specified component, with a single command. 

 

Example (see below): Assume the existence of component RED spanning physical inputs 1 
through 6 and physical outputs 1 through 6. All call can be used to switch physical input 3, to 
physical outputs 2 through 6, with a single command. 

1 2 3 4 5 6 7 8

PHYSICAL
OUTPUTS

1
2
3
4
5
6
7
8

PHYSICAL
INPUTS

COMPONENT RED

 
 

Performing an All Call: 

1. Select the Starting Input 

2. Select the Starting Output. 

3. Select the Ending Output. 

4. Select the All call button. 

 

Diagonal: 

A diagonal is a diagnostic procedure that causes a range of physical inputs to be switched to a 
range of physical outputs, in a diagonal pattern starting from a specified coordinate and 
continuing until the either the inputs or outputs are exhausted, for a specified component, with a 
single command. 

Example (see below): Assume the existence of component RED spanning physical inputs 1 
through 6 and physical outputs 1 through 6. A diagonal with a starting input of 2 and a starting 
output of 1 would cause the following physical switches to be taken: (2,1), (3,2), (4,3), (5,4), and 
(6,5). 
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21

8
7
6
5
4
3
2
1

PHYSICAL
OUTPUTS

PHYSICAL
INPUTS

876543
COMPONENT RED

 
 

Performing a Diagonal: 

1. Select the Starting Input 

2. Select the Starting Output. 

3. Select the Ending Output. 

4. Select the Wrap option to ensure that all of the inputs and outputs are processed.  

5. Select the Diagonal button. 

 

Restore Router 

Select the Restore Router button to return the routing switcher to the original state before you 
performed takes, all calls, or diagonal diagnostic procedures. 

 

Exit 

Closes the Physical Switch window. 
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Chapter 8 - 3500Pro Status 
 

The 3500Pro Status module shows the status of different parts of the 3500Pro system. The 
following menu items are available: 

 

• File Menu  

• View Menu  

• Window Menu  

• Help Menu  

8.1 File Menu 

• Tools Menu  

 

The File menu logs you into the 3500Pro Status module, closes open windows, and exits the 
module. The following commands are available: 

 
Figure 153. File Menu 

8.1.1 Login 
The File > Login menu logs you into the Status module. 

Before Using This Command 

You must have a User name and password.  See 3500Pro User Manager for information on 
creating and editing users.  

 

8.1.2 Close 
The File > Close command closes the currently active window.  

Before Using This Command 

Make sure the window you want to close is active (the top border is highlighted). 

 

8.1.3 Exit 
The File > Exit command closes the 3500Pro Status window. 
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8.2 View Menu 

8.2.1 View Menu 
The View menu displays and hides the toolbar and status bar, and open different status windows. 
The following commands are available: 

 

Figure 154. View Menu 

 

 

8.2.2 Toolbar 
The View > Toolbar command hides or displays the bar with the shortcut icons. Select this 
command to display or hide the toolbar. 

8.2.3 Status 
The View > Status Bar command hides or displays the bar with the status information that 
displays at the bottom of the 3500Pro window. Select this command to display or hide the status 
bar. 
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8.2.4 Matrix Status    
The View > Matrix Status command displays the status of the available destinations.  The 
information shown in this window automatically updates as changes occur. Three columns 
display in this window:  

 

Figure 155. Matrix Status Window 

 

Dests 

Indicates whether or not the destination is locked. If it is locked, a "lock" icon 

Displays all of the destinations. 

Lock 

 displays in the 
field.  Click on the Lock field next to the destination to Lock or Unlock the destination.   

Sources 

The Take button switches a specific physical switch. You can perform a Take on single or 
multiple destinations. 

Levels 

The remainder of the columns in this section display all of the levels that are defined for the 
configuration.  For each destination, the source displays on the Destination’s row. 

Displays the available sources.   

Take  

1. Select the fields for the routers on which you want to perform a take. When you select a field, 
the border of the field highlights.  You can select multiple fields: 
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2. Select the first field, press the Shift key, then select the last field. All fields in between 
highlight. 

3. Select the first field, then press the Ctrl key. Keep the Ctrl key pressed down while you select 
additional fields. Each one you select highlights.  

4. After you select all of the fields, select the Source.  

5. Select Take, and the source you selected displayed in the highlighted fields.  

 
You cannot perform a take on a locked destination. 

 

Lock 

The Lock button locks the selected destination.  

 

Unlock 

The Unlock button unlocks the selected destination. 
 

Right-click menu options: 

If you right-click your mouse, three menu options display: 

  
 

Take: performs a take. Select the Destinations, then the Sources, then right click and select this 
button. 

Source Status:  Displays matrix status information for the selected Source.   

Definition: Displays the Level number and Input/Output number for the selected destination or 
source. You can edit the information in this field. Enter new information and select OK.  
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8.2.5 Preset    
The View > Preset window allows you to build complex combination of switches and to take 
them simultaneously on the router.  . To take a switch in Preset mode: 

 
Figure 156. Preset Builder Window 

 
Dest: Displays the destinations. Double-click an item in the Destinations field on the right side of 
the window to assign it to this field. 

Lock: Indicates if the Destination is locked. If it is locked, a "lock" icon  displays in the field.  
Click on the Lock field next to the destination to Lock or Unlock the destination.   

Router: Displays the sources for the router. Double-click an item in the Sources field on the right 
side of the window to assign it to this field. 

Sources: Displays the available sources.  

Destinations: Displays the available destinations.  

Clear All: Removes all of the information from the Preset Builder. 

Clear Selected: Removes the information from the selected rows in the Preset Builder. To select 
multiple rows, select the first field, press the Shift key, then select the last field. All fields in 
between highlight. 

Insert Rows: Adds a new row above the currently selected row. 

Delete Rows: Removes the currently selected row. 

Get Mtx Current: Loads the current matrix that is configured with the View > Matrix Status 
option. 
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Take All:  Performs a Take on all of the destinations. 

Take Selected: Performs a Take on only the selected destinations. To select multiple 
destinations: 

Select the first field, press the Shift key, then select the last field. All fields in between highlight. 

Select the first field, then press the Ctrl key. Keep the Ctrl key pressed down while you select 
additional fields. Each one you select highlights.  

 

Lock After Take: Locks the destinations after performing a Take.  (Locks are set per destination 
on the preset grid.)  

Clear Lock Before Take: Clears all locked Destinations before performing a Take. 

Save: Saves the Preset settings in this window. The file will have a .preset extension. 

Load: Loads Preset settings into the Preset Builder. You must have used the Save button in this 
window to save your settings before you will be able to load information with this button. 

8.2.6 Salvo 
The View > Salvo option displays information about the salvos that are defined in the 
configuration.  A salvo is a group of predefined logical switches taken at the same time. All 
switches in a salvo are taken within the same vertical interval. 

 

Figure 157. Salvo Status Window 

Shows specific information about the salvo that is selected in the 3500Pro Salvos section.   

Salvo 
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3500Pro Salvos 

Shows a list of the salvos currently defined in the configuration file.  Select each salvo to review 
information about it in the Salvo section. 

 

Fire Salvo 

Executes the selected salvo. 

8.2.7 Reentry   
The View > Reentry option displays direct source-to-destination status for every configured 
reentry. 

 

Figure 158. Reentry Status Window 

Connection Status for Reentry 

Displays the reentries that are currently available. To define reentires, use the Configuration > 
Reentry command in the Configuration Editor module. 

Reentry as Destinations   

Shows the destination status of the selected reentry. 

Reentry as Source    

Shows the source status of the selected reentry. 
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8.2.8 Source Status   
The View > Source Status command shows the destinations (by level) that are currently 
switched to the specified source.  

 

Figure 159. Source Status Window 

8.2.9 Tieline   
The View > Tielines window shows all of the defined tielines and allows you to "free up" 
existing tielines.  Tielines are special types of logical switches that allow a logical input on one 
level to be switched to a logical output on a different level. The example shown below 
demonstrates a tieline being used to route a video signal from an analog camera, through an 
external analog-to-digital converter, to a digital VTR. 
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Figure 160. Tieline Status Window 

Before Using This Command 

You must define tielines before they will display in this window. To define tielines, use the 
Configuration > Tielines command in the Configuration Editor module. 

 

Options: 

Local Sources: Displays the sources that have assigned tielines 

Defined Tielines: shows all of the currently defined tielines.  

Tieline Status For: Displays the status of a specific tieline. Select a tieline from the drop-down 
list.  

Free Up Tielines: remove tieline definitions you created in the Configuration Editor 
(Configuration > Tieline command).  Select the source containing the tieline, and select Free 
Tieline. 

Override Locks:  Overrides locked sources. 

Free Tieline:  Frees tieline associations.  
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8.3 Tools Menu 
The Tools menu provides options to refresh the currently open window, enable and disable the 
switcher, and view the current controller status. 

 

Figure 161. Tools Menu 

8.3.1 Controller Status 

 

The Tools > Reinitialize Status command updates the display in the selected window. This 
ensures that the information that displays in up to date. 

8.3.5 Enable Switcher 
The Tools > Enable Switcher enables a switcher.  

 

8.3.6 Controller Status 

 

The Tools > Controller Status command displays status information about the controller. 

8.3.2 Offline Warning 
The Tools > Offline Warning command, if selected, displays a message when the controller is 
offline.  Select this command to turn this option on and off. 

 

8.3.3 Reinitialize Status 

 

8.3.4 Disable Switcher 
The Tools > Disable Switcher command disables the switcher. To enable the switcher again, 
select Tools > Enable Switcher. 

 

The Tools > Controller Status command displays status information about the controller. 
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8.4 Status Menu 
The Status Menu options define how items in the Matrix Status window display.  This menu will 
not be available until you select View > Matrix Status and the Matrix Status window is active. 

 

 

Figure 162. Status Menu 

Before Using This Command 

The Status > Sort Ascending option displays information in the Matrix Status window in 
numeric ascending order (smaller numbers display at the top of the window).  

You must have selected View > Matrix Status to open the Matrix Status window, and the 
Matrix Status window must be active. To make the Matrix Status window active, select Window 
> Matrix Status. 

 

8.4.3 Sort Descending 

Before Using This Command 

You must have selected View > Matrix Status to open the Matrix Status window, and the 
Matrix Status window must be active. To make the Matrix Status window active, select Window 
> Matrix Status. 

8.4.1 Refresh 
The Status > Refresh option updates the information in the Matrix Status window.  This option 
ensures that the information that display is up to date. 

 

You must have selected View > Matrix Status to open the Matrix Status window, and the Matrix 
Status window must be active. To make the Matrix Status window active, select Window > 
Matrix Status. 

 

8.4.2 Sort Ascending 

 

Before Using This Command 

The Status > Sort Descending option displays information in the Matrix Status window in 
numeric descending order (larger numbers display at the top of the window). 
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8.4.4 Preview Destination 
The Status > Preview Destination command allows you to preview what is occurring in the 
status window. 

Click on a cell in the status window and the preview destination is switched to the same status as 
the destination corresponding to the active cell. 

Before Using This Command 

The Preset menu provides options for working with the Preset window.  The following options 
are available: 

 

You must have selected View > Matrix Status to open the Matrix Status window, and the 
Matrix Status window must be active. To make the Matrix Status window active, select Window  

8.5 Preset Menu 

 

Figure 163. Preset Menu 

8.5.1 Load 

 

The Preset > Load command opens a Preset Configuration (.preset file). You can save preset 
configurations with the Save button on the Preset window. 

 

Before Using This Command 

You must have used the Save button in the Preset window to save preset settings. 

 

Loading a Preset File 

1. Select this option, and the Open window displays 

2. Change to the directory that contains the preset file you want to load.  

3. Select the file you want to load. You can select files with either .preset or .txt extensions. 

4. Select Open and the file will load into the Preset window. 
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8.5.2 Save As 
The Preset > Save As command saves the information in the Preset window to a file name and 
directory location that you select. The files will be saved as a .preset file. 

 

Before Using This Command 

Use the Preset window to build your preset settings. 

Saving the Preset Builder Settings 

4. Type in a file name. The file will automatically have a .preset extension.  

The Preset > Delete Rows command deletes the selected row in the Preset window.  This option 
is the same as selecting the Delete Rows button in the Preset window. 

 

8.5.6 Clear All 

 

1. Set up the Preset window. 

2. Select the Preset > Save As command. The Save As window displays. 

3. Select the directory location to store the file. 

5. Select Save and the file will be saved to your computer. You can now open the file later with  

 

8.5.3 Delete Rows 

 

8.5.4 Insert Rows 
The Preset > Insert Rows command adds a new row above the selected row in the Preset 
window.  This option is the same as selecting the Insert Rows button in the Preset window. 

8.5.5 Cleared Selected 
The Preset > Clear Selected option removes the information from the selected rows in the Preset 
window.  To select multiple rows, select the first field, press the Shift key, then select the last 
field. All fields in between highlight. This option is the same as selecting the Clear Selected 
button in the Preset window. 

 

The Preset > Clear All option removes all of the information from the Preset Builder.  This 
option is the same as selecting the Clear All button in the Preset window. 
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8.5.7 Capture Current Matrix Status 
The Preset > Capture Current Matrix Status option loads the current matrix that is configured 
with the View > Matrix Status option into the Preset Builder window.  This option is the same as 
selecting the Get Mtx Current button in the Preset Builder. 

Select the first field, press the Shift key, then select the last field. All fields in between highlight. 

The Preset > Take All button performs a take on all of the destinations.  This option is the same 
as selecting the Take All button in the Preset Builder window. 

 

Before Using This Command 

8.5.12 Sort Descending 
The Tieline > Sort Descending command sorts the tielines in descending order. 

Before Using This Command 

 

8.5.8 Take Selected 
The Preset > Take Selected option performs a take on only the selected destinations. To select 
multiple destinations: 

Select the first field, then press the Ctrl key. Keep the Ctrl key pressed down while you select 
additional fields. Each one you select highlights.  

This option is the same as selecting the Take Selected button in the Preset Builder window. 

8.5.9 Take All 

 

8.5.10 Tieline Menu 
The Tieline menu provides options for working with the Tieline window. You cannot access this 
menu until you select View > Tieline to display the tieline window and the tieline window is 
active (the border of the window will highlight). 

8.5.11 Sort Ascending 
The Tieline > Sort Ascending command sorts the tielines in ascending order. 

 

You must have selected View > Tieline to open the Tieline window, and the Tieline window 
must be active. To make the Tieline window active, select Window > Tieline Status. 

 

 

You must have selected View > Tieline to open the Tieline window, and the Tieline window 
must be active. To make the Tieline window active, select Window > Tieline Status. 
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Chapter 9 - 3500Pro User Manager 
 

The 3500Pro User Manager module allows you to configure your computer connections and to 
add and edit users who can access the 3500Pro software. 

 

 

Figure 164. User Manager Window 
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9.1 Connection Tab 
The Connection tab defines connection parameters  used to connect the PC to the actual 
controller. 

 

Figure 165. Connection Tab 

Serial Port Connection 

Select this check box if you will connect to the controller through a serial port. 

Baud Rate: 

Commit 

COM Port 

Select the COM Port you are using to connect to the controller if you are using a serial port 
connection.  

Select the baud rate for the connection if you are using a serial port connection. 

Network Connection 

Select this check box if you will connect to the controller through the network.  

Controller Address 

Enter the TCP/IP address of the controller. 

Applies your connection settings. The settings you selected will display at the bottom of the 
window. 
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Present Connection 

Displays the current method you are connecting to the controller, such as "RS-232/422 through 
COM1 at 38400 baud". 

Reinitialize Communications 

Reinitialize serial communications based on what is stored in registry.   

9.2 Users Tab 
The Users tab allows you to add, edit, and delete users.  

User accounts are optional. If used, at least one user account must be 
assigned all privileges. If no user accounts are configured, all users have all 
privileges.  

 

Figure 166. Users Tab 

Adding a User 

1. Select the Add>> button.   

2. Enter a name for the user. 

3. Select the Set Password button, and enter a password for the user.  

 
Make sure each user knows his or her initial username and password. 

 

4. Select the privileges the user should have. Just select each check box, and a check mark will 
display. If the user needs access to everything, select the Set All button.  At least one user must 
be assigned all privileges. 
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5. When you are done, select Commit. The user will be added to the Available Users section in 
the left portion of the screen, and the user will now have access to the software. 

 

Editing a User 

1. Select the user you want to edit from the Available Users list. 

2. Select the Edit>> button.  

3. Change any of the settings. To change the password, select the Set Password button and 
enter the new password. 

4. Select the Commit button, and you changes will be saved. 

 

Deleting a User 

1. Select the user you want to delete from the Available Users list. 

2. Select the Delete button. The user is removed from the Available Users list. 

 

9.3 Path Options Tab 
The Path Options tab displays information about the directory location of items in the 3500Pro 
configuration. You cannot edit any of this information. 

 

Figure 167. Path Options Tab 
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Chapter 10 - Runtime Database Initialization 
 

The Runtime Database Initialization module makes copies of the configuration and runtime 
databases (from the master copies).  Then, old versions of the databases are purged.  Use this 
option when you first install the software. Also, you can use this option if you are having 
problems with modules correctly reading current controller information.  For example, if you 
download a configuration to the controller, but the Status module is not recognizing the current 
setting, use this command. This command will ensure that the databases the software is reading 
contain the most current information. 

 

 

Figure 168. Runtime Database Initialization Window 
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