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Feature Enhancements

A number of features have been added, or updated, to this version of software.
This section provides a brief introduction to these features, and how to use
them.

Audio Fader Module
The Audio Control Module allows you to map audio channels, or groups, from
an audio mixer to any of the audio faders on the Audio Control Module.

Figure 1: Audio Control Module

When an audio channel, or group, is assigned to a slider, the source name for
that audio channel is shown in the mnemonic above the audio fader. Audio
channels, or groups, can be dynamically assigned to audio faders with a custom
control.

The color of the mnemonic above each audio fader indicates the state of the
audio channel, or group, assigned to the fader.

• Orange — Indicates that a channel assigned to that fader is on-air.

• Yellow — Indicates that all channels assigned to that fader are off-air.

To set up the Audio Control Module, you must first assign each Audio Control
Module to a panel row. Once the Audio Control Module is assigned to a panel
row you can assign audio channels to the audio faders.

To Assign Audio Fader Maps

1. Press HOME > Setup > Installation > More > Audio > Audio
Fader Map.

2. Use the Fader knob to select the audio fader that you want to assign
an audio channel to.

3. Use the Audio Source knob to select the audio source that you want
to assign to the audio fader.
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• NONE — Select this option to not assign an audio channel to the
selected audio fader.

• Chan X — Select this option to assign an audio channel to the
selected audio fader.

• Group X — Select this option to assign an audio group to the
selected audio fader.

• Floating — Select this option to have the switcher dynamically
assign the audio channel, or group, that is on-air to the audio fader.
Audio channel assignment starts with the lowest number channel
that is on-air.

• Master — Select this option to assign the master level to the audio
fader.

Copy and Paste Keyframes
You can now copy or cut a keyframe and paste it into a different location in
the same or a different sequence. The keyframe is inserted after the selected
keyframe when you paste.

To Copy and Paste a Keyframe

1. Load the sequence you want to overwrite the keyframe for.

2. Press the DVE quick navigation button.

3. Press Sequence > More > More.

4. Use the Previous Keyframe and Next Keyframe buttons to select
the keyframe that you want to cut or copy.

5. Press Cut Keyframe or Copy Keyframe.

6. Use the Previous Keyframe and Next Keyframe buttons to select
the location you want to paste the keyframe. You can also load another
sequence and paste the keyframe into it. The keyframe will be inserted
after the selected keyframe.

7. Press Paste Keyframe to insert the keyframe after the selected
keyframe.

Independent Key Transitions
Keys can now be transitioned independently using the dedicated key transition
buttons on the Keyers Module. This allows you to dissolve keys on/off-air
while the fader is off-limit, or an Auto Transition is in progress from the
Transition Module.

Keep the following in mind when performing independent key transitions:
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• Only dissolves or cuts can be used for an independent key transition.

• If the key is part of the next transition, the key will be dissolved off-air
and is removed from the next transition. This applies even if the key
was not on-air.

• Independent key transitions are performed at the key rate, and not the
MLE rate.

• Each keyer has an independent key rate.

• This feature is not compatible with OverDrive and is disabled when
Editor is enabled.

Memory Text
As well as names, memories can be given descriptions that are shown on the
Memories Setup Menu. These descriptions and names can be copied from one
MLE to another.

To Assign a Description to a Memory

Tip:  Press Copy Description & Name to All MLEs to copy the current description

and memory name to the same memory register on all MLEs.You cannot copy the

description to a locked memory register.

1. Press HOME > Attributes > Memories Setup.

2. Use the MLE knob to select the MLE that you want to add a
description to.

3. Use the Memory knob to select the memory register on the selected
MLE that you want to add a description to.

4. Press Edit Description.

5. Enter a description for the memory.

6. Press Accept.

Menu Updates
The menu system on the switcher has been updated to place the Setup menu
on the first page of the Main Menu. Other updates include the move of the
Preview Overlay and Aux Bus menus to the Effects menu.
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Figure 2: Setup Menu Navigation

Multiple Shift Bus Maps
The Bus Maps have been improved to include multiple shifted buses. You
can now assign up to seven shift buttons to your top level bus map, allowing
for eight total mappings per bus map.

To Set Up a Multiple Shift Bus Map

1. Press HOME > Setup > More > Bus Maps > Edit.

2. Use the Map knob to select the Bus Map you want to edit. The default
Bus Map cannot be edited.

3. Select the button on the shift level that you want to assign a video
signal to. Use the middle knob to scroll the list. The button lights on
the program bus of all panel rows.

4. Use the Source knob to select SHFT X and assign the Shift function
to the selected crosspoint button, where X refers to the shift level.

Tip:  Press Insert to insert a source at the selected button and shift the
remaining sources to the right. Press Delete to delete a source at the selected
button and shift the remaining sources to the left. Press Clear to remove the
source from the selected button and not shift the remaining sources. None is
selected for the cleared buttons and the last button when a source is deleted.

5. Press HOME > Confirm.

OverDrive Custom Control
A number of custom control have been added to the Insert Special - Special
- OverDrive list to trigger events in OverDrive.

• Take & Prep — The Take & Prepare Next custom control allows you
to tell OverDrive to take to current shot on-air and prepare the next shot
in the rundown.

• Prep Next — The Prepare Next custom control allows you to tell
OverDrive to prepare the next shot in the rundown.
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• Prep Prev — The Prepare Previous custom control allows you to tell
OverDrive to prepare the previous shot in the rundown.

• Prep CC — The Prepared CC custom control allows you to tell
OverDrive to run one of the prepared CC buttons on rundown control.
The buttons are numbered 1-6.

• Use the CC knob to select the custom control you want to run.

• On-Air CC — The On-Air CC custom control allows you to tell
OverDrive to run one of the on-air CC buttons on rundown control. The
buttons are numbered 1-6.

• Use the CC knob to select the custom control you want to run.

• Transition — The Transition custom control allows you to tell
OverDrive to activate a particular button on rundown control. The buttons
are numbered 1-4.

• Use the Trans knob to select transition rate.

• Rundown — The Rundown custom control allows you to tell OverDrive
to run a selected event in a rundown.

• Use the Cmd knob to select the command.

Satellite Panel Server Control
You can now control a video serve, over VDCP, from a satellite control panel,
as well as from the master control panel. You must select the control panel
that the video server is connected to from the ExtraOptions of the video server.

Split Keys
The Split Key functionality has been changed to allow you to assign a different
alpha source for a key, as opposed to the video.

To Perform a Split Key

1. Set up your key as usual.

2. Ensure that the Keyers Module is assigned to the Keyer that you want
to perform the split key on.

3. Press and hold the AUTO SELECT (or SELF KEY) button on the
Keyers Module.

4. Select the video source that you want to use as the new alpha on the
key bus.

5. Release both buttons.

6. Fine tune the key as required.
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New Devices Supported

Support for the following devices or features was added for this version of
software:

• Ross Robotics Furio Robo — Support for this device was added as a
FlexCAM device.

• Merging Technologies Ovation Media Server — Support for this
device was added as a RAP device.

• Yamaha 02R96 — Support for this device was added for using a MIDI
interface.

• Audio Mute Custom Controls — Custom controls have been added
to mute or un-mute an audio channel or group.

• Remote Aux Panels (RCP-NK Series) — Support for the Ross Routing
Systems RCP-NK1, RCP-NKM, and RCP-NKQ remote control panels
was added. This allows you to integrate the switcher into your existing
Ross Routing system as a router level being controlled from one of the
router remote control panels.
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Known Issues and Limitations

Keep these notes in mind when upgrading your switcher to this version of
software. Contact Ross Video Technical Support if you have any questions
about performing a software upgrade.

External Devices
The following issues have been identified when working with external devices:

• TargetMachine Settings — Check all TargetMachine extra option
settings after performing an upgrade. Extra option settings may revert
to default values after an upgrade.

• Video Servers (VDCP) — You may experience communication
problems after performing an upgrade. Please verify the channel and
sub address settings for the video server on the BNC Menu. These values
must match the settings on the video server you are trying to control.

• EVS maXS — If you experience pausing during clip playback, perform
the following procedure whenever the Vision control panel is restarted:

1. Set the Port Cmd option to Yes.

2. On any bus, select each crosspoint that is associated with an EVS
maXS channel.

3. Set the Port Cmd option to No.

• Avid AirSpeed and OverDrive® — If you are using the Avid AirSpeed
Video Server with the OverDrive Production Control System, you must
set the Playback Mode to PB from the Extra Options on the
Communications Menu 1-2 on the switcher.

• Video Servers, LoopRecueTime — The minimum LoopRecueTime
from the Extra Options Menu has been lowered to 1 frame, instead of
7. The default value for the Ross Video SoftMetal™ Video Server has
been lowered to 2.

• SoftMetal Video Server, version 4.3 — If you upgrade your SoftMetal
Video Server to version 4.3, or higher, you must set the TargetMachine
on the Communications Menu of the switcher to Ross SMS4.3 for proper
communications.

• GVG Profile Video Server, Looping — The GVG Profile Video Server
does not support Looping at this time. Turning looping on may cause
undesired video aberrations when the loop is performed.

• Audio Memory Custom Control — The Euphonix Audio Mixer does
not support Audio Memory Custom Controls at this time.
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• Harris Inscriber CG Custom Controls — When you create a custom
control for the Inscriber, you cannot include Select Effect or Run Effects
commands.

• Harris Inscriber Before Version 5.0 — If the Inscriber is set to before
5.0 on the Communications Menu, the switcher may stop loading pages
on the CG correctly. Setting the Inscriber to 5.0 or later, confirming,
and then back to before 5.0 should clear the problem.

• Harris Inscriber G-Scribe Strata Layers — For the G-Scribe, you do
not need to set the Strata Layers, the software will configure this
automatically.

• Robotic Camera Control and Editors/OverDrive — If you are using
the Robotic Camera Control Menu while the Editor Remote Enable is
active, you may experience menu errors.

• FlexDevice Drivers — If there is a FlexDevice driver for a device
connected to the switcher, we recommend using the FlexDevice driver
over the legacy integrated driver. The FlexDevice driver includes the
most recent features and bug fixes.

• Avid Deko — If you are trying to control the Avid Deko from the
switcher over ethernet, please contact Ross Video Technical Support
for information on interface issues.

• Gallery Sienna Looping Clips — Looping of a clip from the switcher
is not supported at this time.

• Gallery Sienna Clip Control — Selecting and cueing a clip from the
switcher is not supported at this time. Only basic transport commands
such as play, pause, stop, rewind, and fast forward are supported.

• Execute Macro Custom Control Command Length — The command
field for the execute macro custom controls only allows you to enter 62
characters, and not the 64 that are indicated on the menu.

• Execute Macro Custom Control Commands — When you create a
custom control with multiple Execute Macro commands in it, you must
insert a 10-15 frame pause between all the Execute Macro commands.

• Miranda HMP-1801 Clip Names — The cumulative size of all clip
names on the HMP-1801 must be less than 100 characters for the
switcher to properly interface with it.

• Miranda HMP-1801 Recorded Clip Names — When you record a
clip on the HMP-1801 from the switcher, the clip is named the same as
the last clip you recorded on the HMP-1801. You must rename the clip
after it has been captured.

• GPI Outputs on Reboot — The GPI outputs may trigger, or come up
in an unknown state, when the switcher is restarted or rebooted.

• Canon Camera Manual Control — The Canon Cameras do not report
their current state to the switcher. Under manual control, this means that
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the expected value that the switcher has, and the actual value on the
camera, may not be the same. This can result in a small adjustment to a
value from the switcher causing a dramatic change on the camera as the
switcher and camera synchronize values.

• Canon Camera Iris Control — In Manual mode, the iris control from
the switcher controls the iris function of the camera. In Auto mode, the
iris control from the switcher controls the AE level of the camera.

Operational Notes
The following issues have been identified when working with the switcher:

• Custom Control Sources — Custom Controls created in version 10.0d,
or higher, now record specific Bus Map Sources. This allows a custom
control created with one Bus Map to be run with a different Bus Map,
as long as the same Bus Map Source exists in the different Bus Map.
Custom Controls created prior to version 10.0d only record the source
button that was pressed, not the Bus Map Source that the button was
mapped to in the Bus Map. All custom controls created in version 10.0c,
or lower, should be edited so that source button selections are replaced
with the new Bus Map sources.

• Relative Custom Control (MultiPanel) — You cannot run the same
relative custom control on different control panels at the same time.

• Stopping Custom Controls (MultiPanel) — Only the control panel
that starts a custom control can stop that custom control.

• External Power Supplies — When connecting power to a switcher
component that uses an external power supply (such as the Touchscreen),
always connect the power supply to the switcher component before
connecting it to the AC mains power. Connecting the power supply to
the AC mains power before connecting to the switcher component could
damage the switcher component.

• MLE-Store Animation Playback — If you change any values in the
Installation Menu while an MLE-Store animation is playing, the
animation will re-start when you confirm the Installation Menu changes.
Global-Store animations are unaffected.

• QMD/X Power Supplies — The 500 Watt (4800AR-014) and 700 Watt
(4800AR-024) Power Supplies cannot be used in the same frame at the
same time; doing so may damage the Power Supply, the Frame, or both.
Completely power off the QMD or QMD-X frame before replacing all
the 500 Watt Power Supplies with the 700 Watt Power Supplies.

• Unsupported Video Formats — The video format 1080p 24 is not
supported at this time.

• Select Custom Control Bank — The Select Custom Control Bank
custom control command is not available at this time.
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• Key 4 Mode Configuration (Vision QMD/X Only) — There are a
number of changes to the normal operation of the switcher, depending
on how the Key 4 Mode is set.

1. If the Key 4 Mode is set to an Internal Mode from the Installation
Menu, an All+All reset does not select Black for Key 4.

2. If the Key 4 Mode is set to Internal Mode 2, the Clean Feeds for
that MLE show Key 4 Video and Alpha.

3. If the Key 4 Mode is set to Internal Mode 3, and you assign a Color
Corrector to an Aux Bus, selecting a different Key 4 Mode locks
the Aux Bus to Black. You must remove the color correction from
the Aux Bus before changing the Key 4 Mode.

4. If the Key 4 Mode is set to External Mode, Utility Mask and Utility
Wash show Key 4 Video and Alpha.

• Border/Trails Video Delay — Turning Borders or Trails on for a key
will cause a one (1) frame delay in the video on the keyer.

• Squeeze & Tease Video Delay — Squeeze & Tease wipe transitions
cause a one (1) frame delay in the video.

• Switching Between Borders and Trails — If you switch between a
Trails mode to a Border mode and back again, the key may flash when
a Trails mode is selected the second time.

• Key Trails on a Flying Key — If you apply a Key Trail or Key Smear
Trail to a Shaped Flying Key, a visible black line may be displayed next
to the key.

• Bus Maps Assigned to New MLEs — When you add an MLE to the
switcher, the default settings are applied to it, including Bus Maps.

• Using the Keypad to Select a Pattern — You cannot select a pattern
from the Global Memory Module for a Preset Pattern wipe, or Pattern
Mask.

• Serial Tally for MultiDSK Keys 5 and 6 — The Serial Tally protocol
does not support more than 4 keyers. You cannot use the serial tally
protocol to tally MultiDSK keyers 5 and 6.

• Preview Output on Vision 1 Preview Module — The MLE PV and
MLE PGM buttons select the main Program (PGM) and Preview (PV)
assigned to the control panel, and not the selected MLE.

• Satellite Control Panels and NTP Servers — If the switcher is
connected to a Network Time Protocol (NTP) server, the satellite panels
only receive date and time information when they first connect to the
frame.

• Video Input Board with Reference in QMD — Do not install a Video
Input Board with Reference into Slot E of the QMD frame. Doing so
may cause the frame to not lock to reference.
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• Still Approximate Size — The approximate size of stills reported on
the Still-Store Cache Menu is the uncompressed size in RAM of the
original image, before the image is converted to the video format the
switcher is operating in. The actual size of the image in cache can be
different than the size of the uncompressed image in RAM, depending
on the format that the original image was captured in.

• Applying Warp Effect to Chroma Key — If you apply a Page Roll or
Magnify Squeeze & Tease Warp effect to a chroma key, some distortion
may be visible around the edges of the key when the key is flown towards
the screen, or zoomed in.

• MultiViewer Overlay Cropping — The overlay borders on the
MultiViewer output cover a portion of the active video. This is equal to
24 lines per frame on the large boxes, and 48 lines per frame on the
smaller boxes. This only effects the MultiViewer output.

• Pre-MultiViewer Switcher Setups — If you are upgrading to a
MultiViewer configuration, your existing switcher setups containing the
Installation register should be re-saved with the MultiViewer active.

• MultiViewer Hardware Support — The MultiViewer requires the
Video Processor Board (4800AR-041), and is not supported by the Video
Processor Board (4800AR-040).

• MultiViewer Source Names — If you change your switcher installation,
or source names, the names shown on the MultiViewer output may be
incorrect. Enter the MultiViewer Layout Editor Menu and re-assign the
sources to the MultiViewer Layout to update the source names on the
MultiViewer output.

• Recall Installation May Reboot Boards — If you recall an Installation
Register that requires a hardware reconfiguration, the required boards
will reboot when the recall is confirmed.

• Key 4 Configuration — MLEs that are not present in the switcher may
be listed on the Key 4 Configuration Menu if the Video Processor
supporting those MLEs is configured as a MultiViewer.

• MultiViewer Upgrades — If you are upgrading to a MultiViewer setup,
each MultiViewer option must be purchased in order. When the
MultiViewer is installed, the MLE, and any Squeeze & Tease resources
that were supporting that MLE, become unavailable as long as the
MultiViewer is active.

• All-All Reset in Custom Controls — If you include an ALL+ALL
reset of the control panel in a custom control, it must be the last or only
event in the custom control.

• Simple Pattern Generators — The 4 simple pattern generators per
MLE have been removed.

• Windows® 7 WebDAV Connection — If you create a connection from
a Windows 7 computer to transfer stills to the switcher. The computer
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may not be able to connect to the switcher after the computer has been
rebooted. You must re-create the WebDAV connection to re-establish
connection.

• OverDrive Assigned Channel Names — OverDrive can assign names
to channels, and channels to faders on the Audio Control module. These
setting persist even after the Editor has been disabled. You must perform
an All+All reset to return the names and fader assignments to the switcher
default assignments.

• Global-Store Capture Won't Complete — If you perform a
Global-Store capture and the capture complete message does not appear
(the Capture button remains gray), you must restart your switcher to
regain the capture functionality.
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Software Upgrade

Software upgrades are performed from the web interface to the switcher frame.
You must download the upgrade files and have then on a computer connected
to the switcher over Ethernet to perform the upgrade.

Depending on the version of software you are upgrading from, your menus
may be arranged or appear differently. Refer to the switcher documentation
that came with your current version of software for more information on your
menus.

Important: Version 14.1b requires Vision OS v33, or higher. To confirm the current
OS version, press Home > More > Setup > Installed Options > Panel Boards. If the
Vision OS is not v33, or higher, please contact Ross Video Technical Support for
information on upgrading your Vision OS.

Upgrade Compatibility
Before upgrading your switcher, review the following version compatibility
information.

Table 1: Upgrade Compatibility

CompatibilityProduct

This version of software has been tested with OverDrive.OverDrive® Production
Control System

The Synergy control panel is not supported by this version of software.Synergy MD/X

To upgrade to the new Vision control panel, you must first upgrade to
version 6.0 or 6.1. Once you have upgraded to version 6.0 or 6.1, you must

Synergy to Vision

upgrade to version 7.1b, or higher, to support your Vision control panel.
Contact Ross Video Technical Support for assistance before starting the
upgrade.

Vision 7.0 or higher • Pre-MultiViewer Switcher Setups — If you are upgrading to a
MultiViewer configuration, your existing switcher setups containing
the Installation register should be re-saved with the MultiViewer
active, instead of the MLE.

• Ancillary Data Passed — If the Ancillary Data is set to Strip
(default) before the upgrade, it will be set to Pass after the upgrade.
If custom settings have been applied to the Ancillary Data handling,
these settings are preserved.

You must set the GlobStorChan4 option, on the Personality Menu, to Pvw
Overlay before performing the upgrade. If Global-Store channel 4

Vision 11.0a or higher

(Still-Store) is active during the upgrade to v14.1b, you must factory default
the switcher after the upgrade to regain the preview overlay.

Program MLE settings of Automatic will be replaced with MLE 8 when you
restore your settings, even if MLE 8 is not installed. After you restore your

Vision 11.0a or lower

settings, you must manually set the Program MLE for each panel. Ross
Video also recommends that the Program MLE be set to MLE 1 for Satellite
Panels that are not installed.
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CompatibilityProduct

Vision 6.1 or lower • SmartConversion™ settings may need to be reconfigured after
upgrading. Please note your SmartConversion settings before
upgrading so that you may restore them once the upgrade is
complete. Refer to the Vision Engineering Manual for detailed
instructions on configuring SmartConversion.

• AuxKeys™ (Aux Mix/Keyers and Aux Mixers) will need to be
reconfigured after upgrading. Please note your AuxKeys (Aux
Mix/Keyers and Aux Mixers) settings before upgrading that you
may restore them once the upgrade is complete. Refer to the Vision
Engineering Manual for instructions on AuxKeys.

Downgrade Compatibility
For information on downgrading to a previous version, contact Ross Video
Technical Support.

Note:  If your switcher was shipped with the new Frame CPU Board (4800AR-002) with
the Frame CPU Processor Card (4800AR-003), you cannot downgrade past v14.0a.

• Corrupt Custom Controls — A custom control created in v15.0, or
higher, cannot be used with a previous version of software.

Hardware Compatibility
Before upgrading or downgrading your switcher, review the following
hardware compatibility information.

Table 2: Hardware Compatibility

HardwareVersion

14.0a or higher • 4800AR-002 — Frame CPU Board

• 4800AR-003 — Frame CPU Processor Card

11.0a or higher • 4800AR-066 — Video Output Board

10.1i or higher • 4800AR-041-02 — Video Processor Board

10.1g or higher • 4800AR-019 — QMD-X Midplane

10.1c or higher • 4400AR-061 — Video Input Board with crosspoint and reference
(16 Input)

• 4800AR-047A — Squeeze & Tease Carrier Board

10.0b or higher • 4800AR-061A — Video Input Board with reference (16 Input)

• 4800AR-061B — Video Input Board without reference (16 Input)

• 4800AR-061C — Video Input Board without reference (10 Input)
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Backup Switcher Registers
Because the software upgrade process automatically returns the switcher to
default values, it is important that you back up all switcher registers to the
hard drive.

To Back up Switcher Registers

1. Press HOME > Disk.

2. Press Dest/Source.

3. Use the Disk Type knob to select Hard Drive.

4. Use the Set Names knob to select the Setup you want to store the
registers to.

5. Press Store.

6. Press All to store all categories of registers to the selected Setup.

Prepare the Switcher Before an Upgrade
Recalling the factory default settings for the switcher before the upgrade
ensures that all the boards, cards, and modules on the switcher are in a known
state, and are ready to accept an upgrade. The switcher must then be set back
to the proper reference format before the upgrade.

To Perform a Factory Default

1. Press HOME > More > Setup > Installation > More > More >
Recall Factory .

2. Press Personality > Yes  to recall the factory default setting for the
personality registers.

3. Press Memories > Yes  to recall the factory default setting for the
memory registers.

4. Press Switcher > Yes  to recall the factory default setting for the
switcher registers.

5. Press Installation > Yes  to recall the factory default setting for the
installation registers.

6. Press Custom Controls > Yes  to recall the factory default setting
for the custom control registers.

7. Press Default VTR Clips > Yes  to recall the factory default setting
for the clip registers.

8. Press Default NV-RAM > Yes  to recall the factory default setting
for the NV-RAM.
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9. Press Default S&T > Yes  to recall the factory default setting for
the Squeeze & Tease registers.

10. Press Default Bus Maps > Yes  to recall the factory default Bus
Maps.

11. Press Default Shot Box Pages > Yes  to recall the factory default
Shot Box Pages.

12. Press Camera File > Yes  to recall the factory default Camera Files.

13. Press CC/Macro Attachments > Yes  to remove custom control
attachments.

14. Press Default MultiViewer > Yes  to recall the factory default
MultiViewer settings.

15. Press Default CC Variables > Yes  to recall the factory default
custom control variables settings.

16. Press HOME > Confirm .

Power Down all Satellite Panels
To ensure that all control panels upgrade properly, you should power down
any satellite panels before performing the upgrade. After the upgrade has been
completed, you can power on each of your satellite panels and upgrade them.

To Set Video Reference

The factory default procedure resets the reference format. You must set the
reference back to the input reference that is connected to the switcher before
starting the upgrade.

1. Press HOME > More > Setup > Installation > More > Reference
.

2. Use the Input Board knob to select the Video Input Board that
reference is connected to.

3. Use the Ref Format knob to select the reference format of the input
reference.

4. Use the Video Format knob to select the video format that is
connected to the switcher.

5. Press HOME > Confirm .

Performing the Upgrade
Depending on the number of boards, cards and modules in the switcher, and
the current version of software on them, it will take between 15 and 40 minutes
to complete the upgrade.
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Note:  After the Factory Default is performed, the Bus Maps and Output BNC settings
have been changed to the default settings. Ensure that you can find a source button
that is assigned to a valid input, and that you have a monitor connected to a default
Aux Bus output of your switcher.You will need to verify that the switcher is passing
video properly after the upgrade.

To Upgrade the Switcher Software

1. On your computer, open your Web Browser and, in the address bar,
enter the IP address of your frame and press Enter. The QMD/X Web
Interface Splash Screen is displayed.

2. Enter your username and password as follows when the Login Dialog
Box appears. The default Name is user and Password is password.

3. Click Upgrade. The Upgrade Page lists all the previous upgrade
packages that were stored on the hard drive of the frame.

Figure 3: Upgrade Page

4. Enter a name for the upgrade package in the New_Name field. This
must be unique and descriptive enough to allow you to easily identify
it at a later point. Upgrade package names can only include numbers,
letters, periods, and underscores or dashes. Spaces and other symbols
are not allowed.

5. Click Browse.

6. Locate the upgrade package file you want to upload to the switcher
on your computer. The file is named
mdx-<version><build>.tgz.

7. Click Open/Choose to select the file. The file path and name appears
in the Select File to Upload field.

8. Select Vision as the panel type.

9. Click Upgrade Selected Version.
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Figure 4: Upgrade Page

Important:  Do not reload/refresh the web page while the upgrade file is being
downloaded and activated. It can take several minutes for the file to be
uploaded to the switcher, depending on network congestion.

10. Click Browse.

11. Locate the Vision upgrade package file you want to upload to the
switcher on your computer. The file is named vision-<version>-
<build>.tgz.

12. Click Open/Choose to select the file. The file path and name appear
in the Select File to Upload field. If the switcher is unable to verify
that the file is an upgrade package, an error message is displayed.

13. Click Add This File to add the selected file to the software upgrade
package.

14. Wait while the switcher installs the software version. This may take
a few minutes. When the software version has been installed, the
Additional Files page is displayed.

Figure 5: Additional Files Page

Note:  If you receive a warning that the upgrade has failed because the flash
is full (Rsync failed, is flash full?), check the remaining
Application Flash in the Storage Capacity section of the System Info page. If
the remaining capacity is less than 2M, you must delete a number of FlexDevice
drivers to free up space for the upgrade.You can re-install the FlexDevice
drivers after the upgrade. Once you have freed up the required space, try the
upgrade again.

15. Click Reboot Now to restart the switcher.

This cycles the logs on the switcher and propagates the upgrade to all
the boards, cards and modules on the switcher.
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Note:  If a message asking you to Reboot the control panel appears on the menus
of the Touchscreen display, click Cancel.You will be rebooting the entire switcher in
a later step.

16. Allow the switcher to propagate the upgrade to all the boards and
cards by waiting at least 20 mins before proceeding to the next step.

17. Wait for the System Information page to be displayed and the upgrade
to complete.

• Periodically reload/refresh the System Information page until
all the items listed have Done as their Status.

• Verify that the switcher is passing video properly by selecting
different crosspoints. This ensures that the upgrade has
completed. If the switcher is not passing video properly, check
the System Information page again to ensure all items are done.

Upgrade Errors

Table 3: Error Messages and Resolutions

ResolutionError Message

Press HOME > More > System Shutdown >
Upgrade Panel .

If the message The software versions of
the panel and frame do not match is
shown, you need to upgrade your panel.

Press HOME > More > Setup > More > Panel
Modules > Upgrade PMCs .

If the message PMCs need to be upgraded;
please go to Panel Modules menu is
shown, you need to upgrade your PMCs.

Restoring the Switcher After the Upgrade
Rebooting the switcher after the upgrade ensures that all the boards, cards,
and modules on the switcher are properly upgraded and initialized. If a board,
card or module was not properly upgraded, the switcher attempts to upgrade
and initialize it again with the reboot. Once the upgrade is complete, you can
restore your switcher registers.

To Reboot the Switcher

1. Press HOME > More > System Shutdown > Shut Down .

2. Toggle the power switches in the QMD/X frame and Vision control
panel to Off.

3. Wait at least 6 seconds for the System Status Indicators on the frame
to go out.

4. Toggle the power switches in the Vision control panel and the QMD/
X frame, to On.
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5. Toggle the power switch on the Vision control panel CPU Module to
On.

Upgrading Satellite Panels
With the upgrade complete, you can power on each of the Satellite Panels,
connect them to the frame, and upgrade them. Power on each Satellite Panel,
in order, to upgrade it. Ensure that a Satellite Panel is upgraded properly before
powering on the next one.

Refer to the Vision Engineering Manual, for information on adding Satellite
Panels to the switcher.

Tip:  If the message The software versions of the panel and
frame do not match is shown, restart the Satellite Panel to trigger the upgrade.

To Restore Switcher Registers

1. Press HOME > Disk.

2. Press Dest/Source.

3. Use the Disk Type knob to select Hard Drive.

4. Use the Set Names knob to select the Setup you want to store the
registers to.

5. Press Recall.

6. Press All to recall all categories of registers from the selected Setup.
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Video Production Technology

Contact Us
Contact our friendly and professional support representatives for the 
following:

• Name and address of your local dealer
• Product information and pricing
• Technical support
• Upcoming trade show information  

Visit Us
Please visit us at our website for:

• Company information
• Related products and full product lines
• On-line catalog
• News
• Testimonials

PHONE

General Business Office 
and Technical Support 613 • 652 • 4886

After Hours Emergency 613 • 349 • 0006

Fax 613 • 652 • 4425

E-MAIL
General Information solutions@rossvideo.com

Technical Support techsupport@rossvideo.com

POSTAL
SERVICE

Ross Video Limited
8 John Street,
Iroquois, Ontario, Canada
K0E 1K0

Ross Video Incorporated
P.O. Box 880,
Ogdensburg, New York, USA
13669-0880
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