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1 Important Safety Instructions 

1) Read these instructions. 

2) Keep these instructions. 

3) Heed all warnings. 

4) Follow all instructions. 

5) Do not use this apparatus near water. 

6) Clean only with dry cloth. 

7) Do not block any ventilation openings. Install in accordance with the 

manufacturer’s instructions. 

8) Do not install near any heat sources such as radiators, heat registers, 

stoves, or other apparatus (including amplifiers) that produce heat. 

9) Do not defeat the safety purpose of the polarized or grounding-type plug. 

A polarized plug has two blades and a third grounding prong. The wide 

blade or the third prong are provided for your safety. If the provided plug 

does not fit into your outlet, consult an electrician for replacement of the 

obsolete outlet. 

10) Protect the power cord from being walked on or pinched particularly at 

plugs, convenience receptacles, and the point where they exit from the 

apparatus. 

11) Only use attachments/accessories specified by the manufacturer. 

12) Use only with the cart, stand, tripod, bracket, or table specified by the 

manufacturer, or sold with the apparatus. When a cart is used, use caution 

when moving the cart/apparatus combination to avoid injury from tip-over. 

13) Unplug this apparatus during lightning storms or when unused for long 

periods of time. 

14) Refer all servicing to qualified service personnel. Servicing is required when 

the apparatus has been damaged in any way, such as power-cord supply or 

plug is damaged, liquid has been spilled or objects have fallen into the 

apparatus, the apparatus has been exposed to rain or moisture, does not 

operate normally, or has been dropped. 

15) Warning: To reduce the risk of fire or electric shock, do not expose this 

product to rain or moisture. 
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Safety symbols 

Familiarize yourself with the safety symbols in Figure 1 below. These symbols are displayed 

on the apparatus and warn you of the potential danger of electric shock if the 

system is used improperly. They also refer you to important operating and 

maintenance instructions in the product user manual.  

 

 
Figure 1-1: Safety symbols 

Mains power cord 

Eclipse HX matrices are powered by an internal power supply. The cord to connect 

the internal power supply to the mains supply must conform to the following: 

 

• The mains power cord shall have an IEC C13 connector at one end and a 

mains power plug at the other end. 

• An IEC C13 plug has three pins, the center pin carrying the earth / ground. 

The other two pins carry neutral and live circuits. 

• The conductors of the mains cords shall have adequate cross-sectional area 

for rated current consumption of the equipment. 

• The mains plug that connects to the mains supply must be approved for use 

in the country where the equipment is to be used. 

• The mains power cord must be an IEC mains power cord complying with 

standard IEC60320; IEC320/C13. 

• Mains power cords used in the U.S. must also comply with standard UL817. 
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2 Introduction 

This guide describes how to upgrade from ECS v5.2.5 to Eclipse HX v9.1, a 

software release for the Clear-Com Eclipse HX™ digital matrix system 

(standalone or networked).  This guide additionally identifies the simpler upgrade 

from v7.x/v8.x/v9.0 to v9.1. 

The system components covered by the guide include (but are not limited to): 

• Matrices (Eclipse HX-PiCo, Eclipse HX-Delta, Eclipse HX-Median and Eclipse 

HX-Omega) 

• Interface cards (E-FIB, E-QUE, MVX-A16, E-MADI64, LMC-64, and others) 

• Interface modules (AES-6, TEL-14 and others) 

• User panels (V-series and i-Station panels) 

 

Important note:  

Eclipse HX upgrades must be performed by a technically qualified engineer. 

 

2.1 Planning the upgrade to Eclipse HX 
Before you start upgrading your Eclipse (ECS v5.2.5 or EHX v7x/v8.x/v9.0) system 

components to Eclipse HX v9.1 ensure that you have: 

• Sufficient spare (replacement) cards, interfaces or panels for the upgrade. 

 

• Scheduled enough time to complete the upgrade, or if required, roll back 

the upgrade to the version that was running before the upgrade.  

 

• A suitable backup system is in place to maintain service, if your intercom 

system is part of a mission critical or sensitive application.  

You should also be aware that: 

• The order in which you carry out the upgrade is important. The chapters of 

this guide are laid out in the order that your system components should be 

upgraded. 

 

Tip:  For a quick reference to the upgrade procedures you require, and the 

order in which they should be carried out, see chapter 3 Quick reference: 

Upgrading to Eclipse HX. 

 

• If you are upgrading V-Series panels, you may have to upgrade each V-

Series panel individually by connecting it directly to a PC. 

• Upgrading the matrices in a networked (linked) system should take place 

at the same time, because the data sent between networked matrices can 

change.  

When upgrading networked (linked) matrices, Clear-Com recommends that you: 
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• Upgrade only one CPU card in each matrix first and then perform the rest 

of the system upgrade (interface cards, user panels, and so on) afterwards.  

 

• Upgrade the remaining CPU cards in the matrices only when the upgrade 

has been completed and tested across the full system. Leaving the 

remaining CPU cards until last gives you the capability of quickly rolling 

back to the previously running version, if any mission critical issues are 

encountered. NOTE – When the second card is upgraded retrospectively as 

described it needs to be placed in the frame without the other CPU card in 

place. This is because CPU cards only exchange data as a master/slave pair 

when both cards are already running the same firmware. Once both cards 

are upgraded insert both cards and re-download the frame configuration. 

 

• Great care must be taken when opening the lid of the Eclipse HX-PiCo 

matrix to upgrade components. This may invalidate UL status. 

 

 

Remove power from the device first, to avoid working with 

the system while it is live. Observe all electrical shock 

hazard warning and precautions for handling electrostatic 

sensitive devices  

 

2.1.1 Client / Server installations  

When upgrading Client / Server installations from ECS v5.2.5 or EHX 

v7.x/v8.x/v9.0 to Eclipse HX v9.1, you must: 

 

• Use the EHX v9.1 Server Installer only on the PC that is to be the EHX 

Server. The EHX v9.1 server installer will automatically update your IIS 

and configure it to work with Eclipse HX v9.1. 

• Use the standard combined EHX/Dynam-EC 9.1 Client Installer on all the 

Client PCs. The Server PC can also act as a client. 

You should check that you have the appropriate IIS and .Net Windows components 

installed prior to installing the EHX Server. Please refer to the Initial Setup section 

of the Client/Server chapter in the EHX User Guide for a complete list of the 

components required for each version of Windows. 

Note: Installing an EHX Server is an advanced workflow - please contact Clear-Com 

Support for advice before attempting to install an EHX Server. 

Before upgrading your EHX Server installation, Clear-Com strongly recommends 

that you export any existing projects (using File->Export from an EHX Client) and 

backup your users list (using the Export command in the User Management 

screen). It is recommended that you uninstall your existing EHX Server before 

installing the newer version. 
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2.1.2 Roll back strategy  

You should not encounter any mission critical issues when upgrading to Eclipse HX 

v9.1. However, if you decide to roll back the system to the previously running 

version, then you must: 

• Allow adequate time for the roll back operation. 

• Roll back all system components to the same baseline version. 

Temporary roll back strategy 

If you want to roll back to the previously running version for a temporary period 

only, before making another attempt to upgrade to Eclipse HX v9.1, then you may 

implement the following temporary roll back strategy: 

1) Leave all cards and panels at Eclipse HX v9.1 

2) Roll back the matrix CPU card to run at the previously running version. 

3) Re-install the previous running version of ECS/EHX and import your old 

configurations. 

Caution: 

The above strategy is a temporary solution only. Eclipse HX v9.1 configurations will 

not import or work with a CPU card at ECS v5.2.5 or EHX v7.x/v8.x/v9.0 If you 

want to run the previously running system software for an extended period, Clear-

Com recommends rolling back all system components to the same baseline version.  

2.1.3 Supplied Upgrade Media 

Different upgrade media are supplied to the customer, according to the type of 

Eclipse HX product that has been purchased: 

 

Product Software/Documentation 

USB 

System 

Drivers 

USB 

Documentation 

USB 

Matrix  - - 

 
 

ECS / EHX / 

Dynam-EC 

 

 
 

- - 

Upgrade kit  

 

 - 

Table 2-1: Supplied USBs 
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System Drivers Upgrade Media 

The System Drivers upgrade media contains the latest firmware for your Eclipse HX 

devices, including Boot PROM and FPGA / CPLD code files for Eclipse HX matrices, 

interface cards, interface modules and supported panels (i-Station and V-Series 

panels). You must upgrade to the latest firmware when upgrading to Eclipse HX 

v9.1. 

The System Drivers USB also includes the third party software that may be used 

during upgrades. 

Software USB 

The Software USB contains:  

• The EHX configuration software, which is used to manage and configure 

your Eclipse HX devices. 

• Dynam-EC, which provides fast, intuitive audio routing control for your 

Eclipse HX system. 

• A full set of Eclipse HX documentation, including release notes and user 

guides. 

• The application code files for your Eclipse HX matrices. 

The Software USB also includes the third party software that may be used during 

upgrades. 

You must upgrade to the latest application code files when upgrading to Eclipse HX 

v9.1. You require both sets of upgrade media to complete a full upgrade to Eclipse 

HX v9.1. 

Tip:  You can find user documentation, brochures and summary information for all 

Clear-Com’s products (including the Eclipse and Eclipse HX systems), on the Clear-

Com website at: http://www.clearcom.com/support/user-manuals. 

A number of upgrade procedures, require the use of a TFTP Server. One is supplied 

on the USB, but you can use any compatible TFTP Server. 

2.1.4 Fitting the Eclipse HX door panel 

To enable you to change the branding of Eclipse Median and Eclipse Omega 

matrices that have been upgraded to Eclipse HX, Clear-Com provides an Eclipse HX 

door panel kit. 

The figures that illustrate the procedure below feature an Eclipse Median matrix. 

However, the procedure is also applicable to Eclipse Omega matrices.  

Tip: For more information about fitting the Eclipse HX door panel to your upgraded 

Eclipse Median and Eclipse Omega matrices, see the Eclipse Matrix Door 

Replacement Instructions, included with your kit. 

To replace the Eclipse branded door with the Eclipse HX door: 

http://www.clearcom.com/support/user-manuals
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1) Remove the two screws securing the Eclipse door (and hinge) unit to the 

Eclipse matrix. Retain the screws. 

 

 

Figure 2-1: Screws securing the Eclipse door (and 

hinge) unit 

2) Remove the four screws securing the hinge to the existing door unit. Retain 

the screws. 

 

 

 

 

 

 

 

 

 

 Figure 2-2: Removing the screws securing the hinge to 

the Eclipse door 

3) Use the four screws retained in Step 2 to secure the hinge to the new 

Eclipse HX door unit.  

 

 

 

1 

2 
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Figure 2-3: Securing the hinge to the Eclipse HX door 

 

4) Use alcohol to clean the latch-mount surface (located to the bottom right 

on the inside of the Eclipse HX door). 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-4: Latch-mount surface, inside the Eclipse HX 

door 

3 

4 

Latch-mount 

surface 
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5) To attach the Eclipse HX door to the matrix, secure the hinge to the matrix 

using the two screws retained from Step 1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-5: Attaching the Eclipse HX door to the matrix 

6) Open the door. Insert the latch (a separate item from the door unit) into 

the latch receptacle on the chassis. 

The latch receptacle is located to the bottom left of the area enclosed by 

the door. 

 
Note: 
Leave the white plastic protector on the latch when you insert the latch into the 
receptacle. 
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Figure 2-6: Inserting the latch into the latch receptacle 

7) To expose the adhesive surface of the latch, remove the green film from 

the back of the latch.  

 

8) Close the door. Press down firmly on the bottom left of the door, so that 

the latch adheres firmly to the latch-mount surface inside the door. 

9) Open the door again and remove the white plastic protector from the latch. 

 
The Eclipse HX door has now been fitted to the matrix. 

 

 

Latch 

receptacle 

Latch 
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Figure 2-7: Removing the white plastic protector from 

the latch 

2.1.5  Help with upgrading 

If you require more help with either a particular upgrade procedure or the 

implementation of a whole system upgrade, contact either: 

• Clear-Com Technical Support 

(http://www.clearcom.com/contact/support-contacts). 

• Your Clear-Com sales representative, to arrange for an engineer to visit 

your site and assist you with the upgrade. 

 

See page 2 of this guide for contact email addresses, or go to 

http://www.clearcom.com/contact/sales-contacts. 

 

9 

White 

http://www.clearcom.com/contact/support-contacts
http://www.clearcom.com/contact/sales-contacts
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3 Quick reference: Upgrading to Eclipse HX v9.1 

The upgrade kit includes a Drivers USB, containing the latest firmware files (including Boot and FPGA / CPLD code files) for your Eclipse 

HX devices. It also includes a software USB, containing the application code files for your Eclipse HX feature applications. It includes the 

EHX configuration software, Dynam-EC audio routing software, and Eclipse HX v9.1 documentation. You require both upgrade media to 

complete a full system upgrade. For more information, see 2.1.3 Supplied . 

3.1 Upgrading from 5.2.5 

The following table lists the procedures that you will require to upgrade from ECS v5.2.5 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 
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Order System component 

 

Upgrade procedure(s) Notes 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 V-

Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required  

6 CellCom® / FreeSpeak® 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application upgrade 

required 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 
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Order System component 

 

Upgrade procedure(s) Notes 

MK II (Blue) card only 

 

8 Eclipse HX-PiCo  6.1 Changing the Eclipse HX-PiCo PROM 

6.2 Changing the Eclipse HX-PiCo RAM 

6.3 Changing the Eclipse HX-PiCo DIP switches 

 Upgrading the Eclipse HX-PiCo application code 

6.4.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app code 

using the Renesas FDT 

6.6 Upgrading the Eclipse HX-PiCo CPLD and FPGA code with Xilinx 

tools 

If you are upgrading the PiCo to 

an HX-PiCo please contact your 

Clear-Com representative to 

establish if your hardware is HX 

ready. If your PiCo hardware is 

not HX ready then this is a 

factory only upgrade. 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software  

4.1 Backing up your ECS v5.2.5 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.1 Changing the CPU card PROM 

5.2 Changing the CPU card RAM 

5.3 Changing the CPU card DIP switches 

5.4 Upgrading the CPU card application code 

5.7 Upgrading CPU Card U53 CPLD 
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Order System component 

 

Upgrade procedure(s) Notes 

5.5 Setting the matrix type 

5.8 Upgrading CPU Card U1 CPLD 

5.11 Downloading a test configuration to the CPU card using 

EHX 

5.9 Upgrading the CPU card U53 CPLD code with Xilinx tools 

5.10 Upgrading the CPU card U1 CPLD code with Xilinx tools 

12 Dynam-EC (without EHX 

on the same PC) 

4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-1: Procedures for upgrading from ECS v5.2.5 to Eclipse HX v9.1 

3.2 Upgrading from 7.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.0 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 



 

 

Eclipse | Upgrade Guide 

Page 21    

   

 

 

 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 V-

Serie

s 

panel

s 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 
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Order System component 

 

Upgrade procedure(s) Notes 

5 i-Station No upgrade required  

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application upgrade 

required 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 

 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required.  

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.4 Upgrading the CPU card application code  
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Order System component 

 

Upgrade procedure(s) Notes 

 

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-2: Procedures for upgrading from Eclipse HX v7.0 to Eclipse HX v9.1 

3.3 Upgrading from 7.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.1 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 
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Order System component 

 

Upgrade procedure(s) Notes 

9.3 Upgrading the E-QUE card (MK2) No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 V-

Serie

s 

panel

s 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required   
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Order System component 

 

Upgrade procedure(s) Notes 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application upgrade 

required 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required 

 

 

10 EHX configuration 

software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

 

11 CPU card 5.4 Upgrading the CPU card application code 
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Order System component 

 

Upgrade procedure(s) Notes 

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

Table 3-3: Procedures for upgrading from Eclipse HX v7.1 to Eclipse HX v9.1 

3.4 Upgrading from 7.5 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.5 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 
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Order System component 

 

Upgrade procedure(s) Notes 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 

 

 

 

V-

Serie

s 

panel

s 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required   

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Antenna application only. 
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Order System component 

 

Upgrade procedure(s) Notes 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required  

10 EHX configuration 

software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 
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Order System component 

 

Upgrade procedure(s) Notes 

matrix audio monitoring and 

control is required. 

Table 3-4: Procedures for upgrading from Eclipse HX v7.5 to Eclipse HX v9.1 

3.5 Upgrading from 7.6 

The following table lists the procedures that you will require to upgrade from Eclipse HX v7.6 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM upgrade is required 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 
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Order System component 

 

Upgrade procedure(s) Notes 

3 E-FIB card No upgrade required.  

4 V-

Serie

s 

panel

s 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required  

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application only 

7 MVX-A16 card 7.2.2 Upgrading the MVX-A16 boot and app code using the Renesas 

FDT 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

Clear-Com recommends 

upgrading the MVX boot and 

application code using the 

combined MVX boot and 

application code file. See the 

Drivers USB. 

MK II (Blue) card only 

 



 

 

Eclipse | Upgrade Guide 

Page 31    

   

 

 

 

 

Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required.  

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

17 Upgrading FreeSpeak II™ wireless systems Beltpack application only. 

Table 3-5: Procedures for upgrading from Eclipse HX v7.6 to Eclipse HX v9.1 
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3.6 Upgrading from 8.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.0 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM or FPGA upgrade is 

required. 

2 E-MADI64 card 11.3 Upgrading the E-MADI64 application, DSP and FPGA code 

using EHX 

11.4 Upgrading the E-MADI64 FPGA using the Xilinx tool set 

 

No DSP upgrade required. 

(Note – if the E-MADI64 card 

is upgraded before the CPU 

Card then there is no E-MADI 

card LED activity during the 

upgrade. See E-MADI64 

section for important upgrade 

information). 

3 E-FIB card No upgrade required. 

 

 

4 
Uboot 

14.3 Manually upgrading V-Series Panels  



 

 

Eclipse | Upgrade Guide 

Page 33    

   

 

 

 

 

Order System component 

 

Upgrade procedure(s) Notes 

V-

Serie

s 

panel

s 

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station Upgrade required. 

  

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application only 

7 MVX-A16 card 7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-6: Procedures for upgrading from Eclipse HX v8.0 to Eclipse HX v9.1 
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3.7 Upgrading from 8.5 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM or FPGA upgrade is 

required. 

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 
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Order System component 

 

Upgrade procedure(s) Notes 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application only 

7 MVX-A16 card 7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  



 

 

Eclipse | Upgrade Guide 

Page 37    

   

 

 

 

 

Order System component 

 

Upgrade procedure(s) Notes 

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

17 Upgrading FreeSpeak II™ wireless systems  

Table 3-7: Procedures for upgrading from Eclipse HX v8.5 to Eclipse HX v9.1 

3.8 Upgrading from 8.5.1 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5.1 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 
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Order System component 

 

Upgrade procedure(s) Notes 

9.3 Upgrading the E-QUE card (MK2) No PROM or FPGA upgrade is 

required. 

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

13 Upgrading CellCom®/FreeSpeak® wireless systems. Beltpack application only 
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Order System component 

 

Upgrade procedure(s) Notes 

7 MVX-A16 card See 7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools. 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 
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Order System component 

 

Upgrade procedure(s) Notes 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

17 Upgrading FreeSpeak II™ wireless systems 1.9 and 2.4 FS II Beltpack 

application only 

Table 3-8: Procedures for upgrading from Eclipse HX v8.5.1 to Eclipse HX v9.1 

3.9 Upgrading from 8.5.2 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.5.2 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

9.1 Identifying MK1 and MK2 E-QUE cards 

 

9.2 Upgrading the E-QUE card (MK1) 

 

9.3 Upgrading the E-QUE card (MK2) 

The procedures used to upgrade 

E-QUE cards to Eclipse HX v9.1 

can also be used to upgrade IVC-

32 and LMC-64 cards. 

No PROM or FPGA upgrade is 

required. 

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 
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Order System component 

 

Upgrade procedure(s) Notes 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

No upgrade required. 

 

 

7 MVX-A16 card 7.4 Upgrading the MVX-A16 MK I or MK II card FPGA with Xilinx 

tools 

 

MK II (Blue) card only 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 
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Order System component 

 

Upgrade procedure(s) Notes 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

17 Upgrading FreeSpeak II™ wireless systems 1.9 and 2.4 FS II Beltpack 

application only 

Table 3-9: Procedures for upgrading from Eclipse HX v8.5.2 to Eclipse HX v9.1 

3.10 Upgrading from 8.7 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.7 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 
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Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

No upgrade required.  

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display 

module  
14.1 Upgrading panels using EHX  

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

No upgrade required. 

 

 

7 MVX-A16 card No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

No upgrade required. 

 

 

Table 3-10: Procedures for upgrading from Eclipse HX v8.7 to Eclipse HX v9.1 
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3.11 Upgrading from 8.8 

The following table lists the procedures that you will require to upgrade from Eclipse HX v8.8 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 

 

Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

No upgrade required.  

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
14.3 Manually upgrading V-Series Panels  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 
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Order System component 

 

Upgrade procedure(s) Notes 

Display 

module  
14.1 Upgrading panels using EHX 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

No upgrade required. 

 

 

7 MVX-A16 card No upgrade required.  

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-
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Order System component 

 

Upgrade procedure(s) Notes 

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

No upgrade required.  

14 E-DANTE64-HX Card No upgrade required.  

Table 3-11: Procedures for upgrading from Eclipse HX v8.8 to Eclipse HX v9.1 

 

 

 

 

3.12 Upgrading from 9.0 

The following table lists the procedures that you will require to upgrade from Eclipse HX v9.0 to Eclipse HX v9.1. 
 

Important note:  

The table lists the procedures in the order in which they must be carried out. To go to a procedure, click the cross-reference / link. 
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Order System component 

 

Upgrade procedure(s) Notes 

1 E-QUE card 

IVC-32 card 

LMC-64 card 

No upgrade required.  

2 E-MADI64 card No upgrade required.  

3 E-FIB card No upgrade required. 

 

 

4 V-Series 

panels 

Uboot 
No upgrade required.  

Kernel 

Root file 

system 

App code 
14.3 Manually upgrading V-Series Panels 

 

 

Display 

module  
No upgrade required. 

 

 

5 i-Station No upgrade required. 

 

 

6 CellCom / FreeSpeak 

Beltpack / Antenna / 

Splitter 

No upgrade required. 

 

 

7 MVX-A16 card No upgrade required.  
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Order System component 

 

Upgrade procedure(s) Notes 

8 Eclipse HX-PiCo  5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

 

9 AES-6 No upgrade required. 

 

 

10 EHX configuration / 

Dynam-EC software 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

4.3 Installing EHX and Dynam-EC Clients 

4.4 Importing your configurations into EHX 

 

11 CPU card 5.4 Upgrading the CPU card application code  

12 Dynam-EC 4.5 Updating  Dynam-EC is also installed as 

part of the EHX/Dynam-EC 

combined installer. This section 

details how to install the Dynam-

EC client only on a machine i.e. 

where only the dynamic online 

matrix audio monitoring and 

control is required. 

 

13 FreeSpeak II Beltpack, 

Antenna Transceiver 

No upgrade required.  

14 E-DANTE64-HX Card No upgrade required.  

Table 3-11: Procedures for upgrading from Eclipse HX v8.8 to Eclipse HX v9.1 



 

 

Eclipse | Upgrade Guide 

Page 50 

   

 

 

 

 

4 Upgrading to Eclipse HX v9.1 

This chapter describes the files you require to install Eclipse HX v9.1. It also describes 

how to back up your ECS 5.2.5 configurations and import them into Eclipse HX v9.1  

Important notes: 

This guide is laid out in the order in which you must upgrade your Eclipse software and 

hardware devices to Eclipse 9.0. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

4.1 Backing up your ECS v5.2.5 configurations 

Back up your ECS v5.2.5 configurations by exporting them from ECS v5.2.5 to a hard 

disk location. In ECS: 

1) Open the configuration you wish to save. 

2) Select File > Export Project. 

3) Save the configuration to a location on your hard drive. The configuration will be 

saved as a *.ccn file, which you can import later into EHX (the configuration 

software for Eclipse HX v9.1). 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

Repeat the above procedure for all the configurations you want to save. 

4.2 Backing up your EHX 7.x/8.x/9.0 configurations 

Back up your EHX 7.x/8.x configurations by saving them to a secure location on your 

hard drive. 

1) Open the configuration you wish to save. 

2) Select File > Save Project. 

4.3 Installing EHX and Dynam-EC Clients  

EHX is the configuration software for Eclipse HX v9.1. Dynam-EC is the application used 

for online monitoring and dynamic audio routing. 

The Eclipse HX v9.1 software USB contains a number of executable (*.exe) files for 

installing EHX and Dynam-EC: 
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Installation (*.exe) file Description and comments 

EHXDynam-ECSetup.exe The installer for the client version of EHX (both 32 and 

64 bit machines) and Dynam-EC (both 32 and 64 bit 

machines).  

You can use the EHX Client version to connect: 

• Directly to a matrix in Client-only mode. 
 

• To an EHX Server in Client-Server mode. 
 

EHXServerSetup.exe The installer for the server version of EHX (both 32 and 

64 bit machines). 

 

The EHX Server enables multiple EHX clients to work 

together when configuring an Eclipse HX system. 

Table 4-1: Installing EHX 

Note: If you are required to uninstall and re-install EHX for any reason, ensure to save your 

configurations for re-importing into EHX (see section below). You can uninstall EHX from 

your Windows All Programs menu. 

EHX uninstall will stop and restart IIS during the uninstall process to remove any files 

that are currently in use. 

Additionally, if a PC only requires the installation of Dynam-EC then the standalone 

installer for Dynam-EC should be used. See the section below.  

4.4 Importing your configurations into EHX 

The procedure below is only applicable if you are running EHX in Client-Server mode. 

Tip: Remember to import any control macros which may be associated with a 

configuration. 

To import a saved configuration from ECS v5.2.5 into EHX: 

1) Open EHX. From the top menu bar, select File > Import Project. 

2) Navigate to the ECS v5.2.5 configuration (*.ccn) file saved to your hard drive. 

To import the file, click Open. 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

To import a saved project from an earlier version of EHX or ECS into EHX in Client-only 

mode: 

3) Open EHX. Select File > Open. 
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4) Navigate to the project file (*.hxn or *.ccn format) saved to your hard drive. 

Click Open. 

Note: If you import a .ccn file, remember to save your imported project as an *.hxn format 

file. 

Repeat the above procedure for all the configurations you want to import. 

4.5 Updating Dynam-EC 

If you are installing Dynam-EC as an update to an existing Dynam-EC installation, you 

must first uninstall your existing version of Dynam-EC. Ensure that you save your 

Dynam-EC layouts project files (*.ccr files) and all relevant EHX system configurations 

(*.hxn files) 

To update Dynam-EC to your PC: 

1) Insert the USB into the PC. Navigate to the USB and click the relevant *.exe file 

for your machine. 

2) When the Setup wizard has loaded, the License Agreement dialog is 

displayed. Use the internal scroll bar to review the agreement. To continue with 

the installation, click I Agree. 

3) The Choose Install Location dialog is displayed. The default location is 

Program Files > ClearCom on the C Drive. To select a different location, click 

Browse. To continue, click Next. 

4) The Choose Start Menu Folder dialog is displayed. The default Start Menu 

folder is Clear-Com\Dynam-EC. To select an alternative folder either: 

• Select from the list of existing Start Menu folders. Use the dialog scroll bar 

to navigate the list. 

• Enter a name into the selection field to create a new folder. 

To prevent the creation of shortcuts, select Do not create shortcuts. Click 

Install. 

5) Dynam-EC starts to install. During installation, an installation progress bar is 

displayed. For more detailed information about the progress of the installation, 

click Show Details.  

When the installation is complete, click Close. 

Note: On installing Dynam-EC, a firewall dialog may be displayed asking if Windows should 

Block or Unblock Dynam-EC. Select Unblock Dynam-EC.
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5 Upgrading the CPU cards 

This chapter describes how to upgrade the Boot PROM, CPLD and application code for the 

CPU cards, two of which are fitted to the Eclipse HX-Median, Eclipse HX-Omega and 

Eclipse HX-Delta matrices.  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

 

 

Eclipse HX devices are powered by mains voltage. Unless 

specifically advised to the contrary, disconnect mains supply before 

carrying out any maintenance or repair tasks. Observe precautions 

for handling electrostatic sensitive devices. 

 

Changing the CPU card PROM, RAM and DIP switch settings 

The CPU card PROM and RAM should be changed at the same time. The CPU card DIP 

switch settings must also be upgraded. 

5.1 Changing the CPU card PROM 

Note: When you change the CPU card PROM, you must also change the CPU card RAM (from 

128Mb RAM to 256Mb RAM). See 5.2 Changing the CPU card RAM below. 

To change the CPU card PROM: 

1) Ensure that you have the following equipment: 

 

• 2MBit PROM device (ST M27W201 or equivalent). 

• PROM Programming Unit (with the appropriate programming software for that 

unit). 

• The *.s record file for the CPU card boot PROM. To find the file, go to: 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – Config 
Boot PROM  
 
Where xxxxxx represents the product number. 
. 
The folder contains the *.s record file and a Read Me file (*.txt), with version 
information. 

2) Program the PROM device with the *.s record file. Follow the instructions for the 

PROM Programming Unit you are using. 

Note: Ensure that the PROM device is empty before you begin programming. 

3) Ensure that the checksum of the programmed device matches the checksum in 

the Eclipse HX Release Notes. 
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4) Remove the existing PROM device from the CPU card. 

5) Insert the newly programmed PROM device, taking care to ensure the correct 

polarity of the device. 

5.2 Changing the CPU card RAM 

Note: When you change the CPU card RAM (from 128Mb RAM to 256Mb RAM), you must also 

change the CPU card PROM. See 5.1 Changing the CPU card PROM above. 

To change the CPU card RAM (from 128Mb to 256Mb): 

1) Ensure that you have the replacement 256Mb CPU card RAM to hand. 

 

2) Remove the CPU card from the Eclipse HX-Median, Eclipse HX-Omega or Eclipse 

HX-Delta matrix. 

 

3) The cassette that holds the CPU card RAM daughter board is located towards the 

center of the main board:  

 

 
Figure 5-1: CPU card 128Mb RAM daughter board 

To release the 128Mb RAM daughter board, push back the levers to either side of the 

cassette. Remove the board. 

4) Fit the replacement 256Mb CPU card RAM daughter board to the cassette. The 

daughter board is fitted chip-side up. Ensure that the daughter board is securely 

fitted (only the top edge of the connectors along the lower edge of the board 

should be visible). 



 

 

Eclipse | Upgrade Guide 

Page 55 

   

 

 

 

 

 

 

Figure 5-2: CPU card 256Mb RAM daughter board 

5) Secure the RAM daughter board by closing the levers to either side of the 

cassette. 

6) Return the CPU card to the Eclipse HX-Median, Eclipse HX-Omega or Eclipse HX-

Delta matrix. 

5.3 Changing the CPU card DIP switches 

To change the CPU card DIP switches to the appropriate Eclipse HX v9.1 settings, see 

either: 

• Appendix B: CPU card DIP switches 

 

• 5.4.3 Upgrading the CPU Card app code using Tera Term 

5.4 Upgrading the CPU card application code 

5.4.1 Upgrading the CPU card app code using EHX with 

Ethernet connection 

Before you upgrade the CPU card application code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 

• There is a valid configuration in the matrix. A valid configuration enables the 

matrix to identify its IP address and run its TCP / IP stack. 

Note: Both CPU cards may remain in place (inserted) for this procedure. 

To upgrade the CPU card application code, using EHX with an Ethernet connection: 
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1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

matrix connection 

For direct connections, use Ethernet crossover 

cable. If the connection passes through an 

Ethernet switch on its way to the PC / matrix, 

use straight CAT5 cable. 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have an 

appropriate IP address set. 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the 

software USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Application (where xxxxxx represents 

the product number). 
Table 5-1: Required equipment 

2) Start EHX. Select File > Matrix connection. 

3) In the Matrix connection dialog, select the Ethernet communications option. 

4) Connect the PC to the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 

matrix, using the LAN#1 port on the rear of the matrix. 

5) In EHX, select File > Import project. Navigate to the configuration file (*.ccn or 

*.hxn format) and click Open to import the file. 

6) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

7) From the menu, select Firmware > Update Firmware. 
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Figure 5-3: Upgrading app code: Matrix firmware update 

1) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  

2) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - 

EHX.xxx > Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card 

Application (where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

3) Click Next. Confirm that the correct file has been selected, and click Next again 

to start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the SI LED on the front of the 

CPU card(s) is flashing rapidly. Rapid flashes indicate communication with the 

PC.  

4) When the update is completed, click Finish in the Firmware Update wizard. 

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta (matrix) matrix reboots. 

The CPU card(s) is reset.  

Download a configuration file (apply changes), using EHX. 

Note: The CPU card uses a default configuration that is embedded in the download application 

(even though the CPU DOT matrix display shows zero (0)). The default configuration 

helps with the initial hardware configuration and testing of the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix by providing usable functionality to each of 

the MVX-A16 cards fitted to the matrix. 
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5.4.2 Upgrading the CPU card app code with EHX using a serial 

link 

You can upgrade the CPU card with EHX using a serial link, whether or not there is a 

valid configuration (map) on the Eclipse HX-Median / Eclipse HX-Omega matrix / Eclipse 

HX-Delta. Both CPU cards may remain inserted during the upgrade. You may choose to 

perform the initial upgrade with EHX using a serial connection, then move to an Ethernet 

connection for future configuration downloads and upgrades, once an IP address has 

been configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to a 

CPU card with a configuration. Both CPU cards may remain inserted during the upgrade. 

To upgrade the application code with EHX, using a serial link: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as 

a COM port. 

Standard RS232 serial cable  

(9-pin D-Type to 9-pin D-

Type) 

- 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have the 

appropriate IP addresses set. 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the 

software USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Application  

(where xxxxxx represents the product 

number). 
Table 5-2: Required equipment 

2) Start EHX. Select File > Matrix connection. 

3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Use the RS232 cable to connect the PC with the serial port on the rear of the 

Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 
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6) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to 

import the file. 

• If you are running EHX in Client-Only mode, select File > Open. 

Navigate to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format configuration files. 

7) Select System > Layout. In the work area, right click the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

8) From the menu, select Firmware > Update Firmware. 

 

 
Figure 5-4: Upgrading app code: Matrix firmware update 

9) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again.  

10) In the next dialog, click Browse and navigate to the required *.fwr file for the  

Eclipse HX-Omega / Eclipse HX-Median / Eclipse HX-Delta CPU card application:  

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - 

EHX.xxx > Eclipse HX-Omega-Median-Delta > xxxxxx – Config Card 

Application (where xxxxxx represents the product number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwr file and click Open. Ensure that the correct file name is 

displayed in the dialog. 

Click Open. Ensure that the correct file name is displayed in the dialog. 
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11) Click Next. Confirm that the correct file has been selected and then click Next 

again to start the firmware update. The update will take approximately 2 

minutes. 

Tip: While the update is in progress, check that the SI LED on the front of the 

CPU card(s) is flashing rapidly. Rapid flashes indicate communication with the PC.  

Note: If you are upgrading from v5.2.5 to Eclipse HX v9.1, the download dialog does not 

automatically finish. This is due to a messaging change between the two system 

architectures. Instead, close the dialog (which will continue to indicate Verifying) when 

the matrix reboots (see Step 11). 

12) When the update is completed, click Finish in the Firmware Update wizard. 

The Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta (matrix) matrix 

reboots. The CPU card(s) is reset.  

Download a configuration file (apply changes), using EHX. 

 

Note: The CPU card uses a default configuration that is embedded in the download application 

(even though the CPU DOT matrix display shows zero (0)). The default configuration 

helps with the initial hardware configuration and testing of the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix by providing usable functionality to each of 

the MVX-A16 cards fitted to the matrix. 

If the upgrade fails 

If the upgrade of both CPU cards fails, repeat the procedure (with only one CPU card in 

the matrix) for each card. When the procedure is complete, insert both the CPU cards 

into the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix. 

If there was no previous configuration loaded in the matrix, download a basic 

configuration file (apply changes) to the CPU cards using EHX. Make any further 

configuration changes over the Ethernet LAN. 

Tip: For more information about setting up a configuration, see the EHX User Guide.  

5.4.3 Upgrading the CPU Card app code using Tera Term 

To upgrade the CPU card application code using Tera Term: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as a 

COM port.   
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Required equipment Description / comments 

Standard RS232 serial 

cable (9-pin D-Type to 9-

pin D-Type) 

- 

Tera Term installation Tera Term must be configured and 

operational. You can find the Tera Term 

application on both of the Eclipse HX 9.0 

upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

An EHX configuration file 

(*.hxn or *.ccn format) 

The configuration file must have the 

appropriate IP addresses set. 

The appropriate *.fwr data 

file for the CPU card 

application 

You can find the *.fwr data file on the 

software USB: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-

Omega-Median-Delta > xxxxxx – Config 

Card Application  

(where xxxxxx represents the part number). 
Table 5-3: Required equipment 

2) Install the Tera Term application. Accept all default settings. 

Tip:  To find out how to install Tera Term, see Appendix G:Tera Term. 

3) Start Tera Term. In the New Connection dialog, select Serial (connection) and 

the COM port to use. Click OK. 

 
Figure 5-5: Tera Term: selecting serial connection 
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Figure 5-6: Tera Term: selecting Serial port 

4) From the Setup menu, select the Serial port… entry.  

5) The Serial port configuration dialog is displayed. Configure the serial port as 

follows: 

Field Data (to enter / select) 

Port Com1 

Note: 

Change as required to match a COM port on the PC. 

Baud Rate 115200 

Parity Even 

Stop One (bits) 

Data 8 (bits) 

Table 5-4: Tera Term: Serial port configuration 

Tip:  You can use the Tera Term application for many of the Eclipse HX system 

upgrade processes. To save and recall the relevant com port settings in Tera 

Term, select the Setup / Save or Restore settings options. 

6) Connect the PC serial port to the RS232 port on the rear of the Eclipse HX-

Median / Eclipse HX-Omega / Eclipse HX-Delta matrix, using the RS232 cable. 

7) Remove both CPU cards from the matrix. Power on the Eclipse HX-Median / 

Eclipse HX-Omega / Eclipse HX-Delta matrix. 

8) Erase the old application code from the CPU cards. 
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a. Place the CPU card in Test mode. 

 

b. Set the DIP switches on the CPU card as follows: 

 
Figure 5-7: DIP switch settings, Test mode 

c. Insert the CPU card into the Eclipse HX-Median / Eclipse HX-Omega / 

Eclipse HX-Delta matrix. You can place the card in either the P1 or P2 

slot. 

 

d. Confirm that the CPU card has entered test mode. If the card is in test 

mode, data similar to the following is displayed on the PC: 

 

 

 

Figure 5-8: Tera Term: CPU card test mode. 

Note: If you do not see the data above, press Enter on the PC. 

 

Tip: To see all the available options in test mode, press ? on your 

keyboard. To see all the current applications loaded onto the CPU, press i. 

 

e. On your PC keyboard, press number 1. To start the erasure of Flash 

memory, press Enter (or Return). Select y and Enter to confirm. 

Note:  

It takes approximately 1 minute to erase Flash. 

f. When the Flash has been erased, press number 2 on your keyboard. To 

start the erasure of NVRAM, press Enter (or Return). When the NVRAM 

erase is complete, remove the CPU card. 

9) Download the new application code (firmware) to the CPU card(s), using Tera 

Term.  

a. Place the erased CPU card in serial download mode. Set the DIP switches 

on the CPU card as follows: 
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Figure 5-9: Tera Term: DIP switches, serial download mode 

b. Insert the CPU card into the Eclipse HX-Median / Eclipse HX-Omega / 

Eclipse HX-Delta matrix. The LED on the front of the matrix should flash 

LD AP. 

c. In Tera Term, open File and select Send file…  Ensure that the BINARY 

option box is selected. 

 

 

 

 

 

 

 

 

 

 

Figure 5-10: Tera Term: Send file… 

d. In the Send file dialog > Select the file to download, navigate to the 

CPU card application code (firmware) *.fwr file: 

i. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - 

EHX.xxx > Eclipse HX-Omega-Median-Delta > xxxxxx – 

Config Card Application (where xxxxxx represents the product 

number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with 

version information. 

ii.Select the*.fwr file and click OK / Open. Ensure that the correct file 

name is displayed in the dialog. 
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e. The file starts to download. Confirm that the CPU card LED matrix display 

shows numbers counting up. 

 

Important note: 

The count-up display indicates that packets are being received by the CPU 

card. The numbers do not represent a percentage complete figure. 

 

If the download fails, the CPU card display shows LD Err. This type of 

failure is usually caused by the user continuing to use the PC for other 

tasks while the download is occurring. The Tera Term screen will not 

indicate a failure and will continue to show a download. If this occurs: 

i. Abort the Tera Term download (press Cancel in the Tera Term 

screen). 

ii. Reset the CPU card (by removing the card from the matrix and 

reinserting it again). 

iii. Check the cable connections, then restart the Send file download 

process again. 

f. When the download is complete, the CPU card reboots. The CPU card(s) is 

reset and the OK LED produces a double flash.  

Note:  

The zero ( 0 ) displayed indicates that although valid application code is 

present, the CPU cards do not contain a configuration. 

g. Remove the upgraded CPU card and set the DIP switches to normal 

running (watchdog) mode: 

 

 

 

 

 

 

 

 

 
Figure 5-11: Tera Term: DIP switches in normal running 

(watchdog) mode 

h. Repeat the above procedure for the second CPU card, if present. Reinsert 

both of the upgraded CPU cards into the matrix. 

i. The OK LED shows a double flash, which indicates that valid application 

code is present, but that there is no configuration in the cards.  

Download a configuration file (apply changes), using EHX. 
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5.5 Setting the matrix type 

The Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices run common 

software, which means that when you upgrade the application code for the CPU card, the 

CPU card cannot automatically distinguish between the two matrix types. You must 

therefore set the matrix type in EHX. 

Note: The Eclipse HX-PiCo runs its own matrix-specific software, and will always identify itself 

as an Eclipse HX-PiCo on hardware discovery. There is therefore no requirement to set 

the matrix type for the Eclipse HX-PiCo. 

To set the matrix type: 

1) In EHX, select Diagnostics > Event Log. 

2) In the Matrix Event Log tab, Click the Play icon [        ]. 

3) Click Request info. In the dialog (see Figure 5-12: Setting the matrix type), 

enter the following custom command: 

Custom 145.1.12096. <2 == Eclipse HX-Median, 3 == Eclipse HX-Omega,  

4 == Eclipse HX-Delta> 

 

Click Send. 

 
Figure 5-12: Setting the matrix type 

Note: If the Event Log does not display, stop and restart the EHX software. 
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5.6 Checking the CPU card application code version 

To check the CPU card application code version: 

1) In EHX, select Diagnostics > Event Log. 

2) In the Matrix Event Log tab, Click the Play icon [        ]. 

3) Click Request info. In the dialog, select Matrix Overview and click Send. 

4) Look for the line that displays the application code (firmware) version. In the 

following example, the application code (version) number is 4.28.2.0: 

 

 

 

 

 
 

Figure 5-13: Application code (firmware) version 

5.7 Upgrading CPU Card U53 CPLD 

The U53 image that was embedded in the CPU card firmware image (for upgrade 

purposes) had to be removed at v8.8. However, the U53 image specified in in the 9.0 

firmware release note still needs to be installed on the CPU card to run the 9.0 

application.  

If the CPU card supports the embedded (DIP switch based) upgrade (see below) and U53 

needs upgrading, then temporarily install the CPLD upgrader application CPU card image 

found on the software release USB and follow the steps below for the duration of the 

CPLD upgrade. Note – this also applies to the UI CPLD upgrade. 

The CPLD upgrader CPU card image can be found next to the official fully featured CPU 

card application on the software disk in the following folder. 

\Eclipse HX-Omega-Median-Delta\Tool – CPLD Updater 

Once the CPLD upgrade is complete install the 9.0 CPU card application and complete 

the remainder of the matrix software and firmware upgrade to 9.0. 

The CPU card U53 upgrade can be performed any time after the CPLD upgrader CPU card 

firmware has been loaded into the card. 

The U53 firmware image is embedded in the CPLD upgrader CPU card firmware image 

and therefore no additional download from EHX is required. 
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Note: Upgrade one CPU card at a time and verify correct functionality of the card after 

the upgrade before upgrading the second card. 

Note – Older revisions of CPU card do not support this following centralized upgrade. In 

order to establish if a CPU card supports the following upgrade method request a 

firmware report from EHX. If the U53 and U1 versions for a CPU card are reported as 

UNKNOWN then this method of CPLD upgrade is not supported and the Xilinx tools 

method of upgrade detailed in this section will need to be used. 

To upgrade a CPU card U53 CPLD device firmware image: 

1) Set the CPU card DIP switches as follows. This enables CPLD firmware upgrades. 

 
 

2) Re-insert the CPU card into the matrix. If the CPLD image requires upgrading 

this will be performed and the CPU card will reset on completion to action the 

image in the CPLD device. 

3) When the CPU card initializes (or re-initializes as a result of step 2.) and 

determines that the CPLD image is up to date it will output the following 

message via the LED front panel “CPLD Upgrades Enabled”.  

4) When the CPU card is running the CPLD upgrader application it will appear red in 

the layout screen indicating that this is not valid image to be configured using 

the EHX. However, the EHX firmware report can still be used. Use the EHX 

firmware report to verify that the correct version of the U53 CPLD is now loaded. 

5) If the upgrade has been completed disable the CPLD upgrade functionality by 

setting the DIP switches to the following settings and downloading the 

regular 9.0 CPU card application into the CPU card. 
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5.8 Upgrading CPU Card U1 CPLD 

The U51 image that was embedded in the CPU card firmware image prior to v8.8 (for 

upgrade purposes) had to be removed. However, the U51 image specified in in the 9.0 

firmware release note still needs to be installed on the CPU card to run the 9.0 

application.  

Note: If the CPU card supports the embedded (DIP switch based) upgrade (see below) and U51 

needs upgrading, then temporarily install the following CPU application found on the 

software release USB and follow the steps below for the duration of the CPLD upgrade.  

Note: This also applies to the U53 CPLD upgrade. 

The CPLD upgrader CPU card image can be found next to the official fully featured CPU 

card application on the software disk in the following folder. 

\Eclipse HX-Omega-Median-Delta\Tool – CPLD Updater 

Once the CPLD upgrade is complete install the 9.0 CPU card application and complete 

the remainder of the matrix software and firmware upgrade to 9.0. 

The CPU card U51 upgrade can be performed any time after the CPLD upgrader CPU card 

firmware has been loaded into the card. 

The U51 firmware image is embedded in the CPLD upgrader CPU card firmware image 

and therefore no additional download from EHX is required. 

Note: Upgrade one CPU card at a time and verify correct functionality of the card after 

the upgrade before upgrading the second card. 

Note: Power must not be lost to the CPU card during the upgrade of the U1 CPLD. The duration 

of the device load is approximately 5 seconds, but this will only commence a number of 

seconds after the card has been booted. If power is lost during the U1 CPLD upgrade the 

Xilinx tools method of upgrade will be required to recover the card. Until this is done the 
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card will not be usable. It is therefore also especially important to upgrade the U1 CPLD 

on one CPU card at a time. 

Note: Older revisions of CPU card do not support this following centralized upgrade. In order to 

establish if a CPU card supports the following upgrade method request a firmware report 

from EHX. If the U53 and U1 versions for a CPU card are reported as UNKNOWN then 

this method of CPLD upgrade is not supported and the Xilinx tools method of upgrade 

detailed in this section will need to be used. 

To upgrade a CPU card U1 CPLD device firmware image 

1) Set the CPU card DIP switches as follows. This enables CPLD firmware upgrades. 

 
 

2) Re-insert the CPU card into the matrix. 

3) Press and hold the ‘Config’ button on the front of the CPU card.  

4) Pin reset the CPU card and wait for 5 seconds. 

5) Release the ‘Config’ button. . If the CPLD image requires upgrading this will be 

performed and the CPU card will reset on completion to action the image in the 

CPLD device. 

6) When the CPU card initializes (or re-initializes as a result of step 2.) and 

determines that the CPLD image is up to date it will output the following 

message via the LED front panel “CPLD Upgrades Enabled”.  

7) When the CPU card is running the CPLD upgrader application it will appear red in 

the layout screen indicating that this is not valid image to be configured using 

the EHX. However, the EHX firmware report can still be used. Use the EHX 

firmware report to verify that the correct version of the U51 CPLD is now loaded. 



 

 

Eclipse | Upgrade Guide 

Page 71 

   

 

 

 

 

8) If the upgrade has been completed disable the CPLD upgrade functionality by 

setting the DIP switches to the following settings and downloading the regular 

9.0 CPU card application into the CPU card. 

 

5.9 Upgrading the CPU card U53 CPLD code with 

Xilinx tools 

Use the following procedure to upgrade the U53 CPLD code for the CPU card.  

To upgrade the CPU U53 CPLD code with Xilinx tools: 

1) Check that you have the latest version of Xilinx tools installed.  

Tip: Upgrading the CPU card(s) CPLD code using Xilinx tools requires specialized 

equipment. For more information about installing Xilinx programming tools, see 

 Appendix J:Xilinx tools.  

2) Connect the USB connector of the download cable (Platform cable USB DLC9G) 

to the USB port of the PC. 

3) Connect the 14way IDC header to CON11. 

4) Power up the CPU card and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) Hold the CPU card in reset by inserting a suitable tool into the Reset pin at the 

top of the card. You must press and hold the reset pin during the whole upgrade 

process. 

7) In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 5-14: Example iMPACT Boundary Scan 

8) If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain shows two devices, as shown below. 

 
Figure 5-15: Example Xilinx chip chain 

9) The Assign New Configuration File dialog asks you to select the CPLD code 

for the first device in the chain or to bypass that device.  

Select the first device in the chain. 
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For this (first) device, select the U53 CPLD code. The U53 CPLD code for the CPU 

card is available from the Drivers USB: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx 

- Config Card U53 CPLD code. 

Note: xxxxxx represents the part number. 

The folder contains a CPLD code file (*.jed) and a Read Me file (*.txt), which 

contains version information. 

10) Right click the first device (U53) and select Programming.  

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the 

main window. 

11) Power down the CPU card. 

5.10 Upgrading the CPU card U1 CPLD code with Xilinx 

tools 

Use the following procedure to upgrade the U1 CPLD code for the CPU card.  

To upgrade the CPU U1 CPLD code with Xilinx tools: 

1) Check that you have the latest version of Xilinx tools installed.  

 

Tip: Upgrading the CPU card(s) CPLD code using Xilinx tools requires specialized 

equipment. For more information about installing Xilinx programming tools, see 

Appendix J:Xilinx tools.  

2) Connect the USB connector of the download cable (Platform cable USB DLC9G) 

to the USB port of the PC. 

3) Connect the 14way IDC header to CON11. 

4) Power up the CPU card and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) Hold the CPU card in reset by inserting a suitable tool into the Reset pin at the 

top of the card. You must press and hold the reset pin during the whole upgrade 

process. 

7) In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 5-16: Example iMPACT Boundary Scan 

8) If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain shows two devices, as shown below. 

 
Figure 5-17: Example Xilinx chip chain 

9) The Assign New Configuration File dialog asks you to select the CPLD code 

for the first device in the chain or to bypass that device.  

Bypass the first device. 



 

 

Eclipse | Upgrade Guide 

Page 75 

   

 

 

 

 

For the second device, select the U1 CPLD code. The U1 CPLD code for the CPU 

card is available from the Drivers USB: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx 

- Config Card U1 CPLD code. 

Note: xxxxxx represents the part number. 

The folder contains a CPLD code file (*.jed) and a Read Me file (*.txt), which 

contains version information. 

10) A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 

 
Figure 5-18: Example Xilinx device programming properties 

11) Right click the second device and select Programming.  

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the 

main window. 

12) Power down the CPU card. 

5.11 Downloading a test configuration to the CPU card 

using EHX 

After you have upgraded your Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta 

matrix CPU cards, Clear-Com recommends downloading a test configuration from EHX to 

the CPU cards.  

Downloading a configuration will enable you to make any further configuration changes 

to the cards using either a serial or Ethernet connection. 

For more information, see your EHX User Manual. 
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5.12 Forcing the CPU card to the factory default IP 

address 

In rare situations, the CPU card may not be able to find a valid IP address for the 

Ethernet port. To address this issue, you can force the matrix to the factory default IP 

address (169.254.0.100): 

13) Set your PC Ethernet IP address to DCHP mode. 

14) Directly connect the PC to the matrix, using an Ethernet crossover cable. 

15) Force the system to use the default IP address, by performing the 3-finger 

reset. Press and hold both the ENG and FULL RESET front panel buttons 

simultaneously, then press the top RESET button. 

1. When the CPU card OK LED starts to flash, release both the ENG and FULL 

RESET buttons. 

Tip: For help with selecting the other procedures you require for upgrading to EHX, see 

the quick reference procedures tables in 3 Quick reference: Upgrading to Eclipse HX 

v.
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6 Upgrading the Eclipse HX-PiCo 

This chapter describes how to upgrade the Eclipse HX-PiCo matrix, including the PROM, 

FPGA and application code. 

The Eclipse HX-PiCo PROM is different from the PROM used with the CPU cards, which 

are fitted to the Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices. 

Care should be taken to ensure that the correct PROM is fitted. 

Note: If you are upgrading your PiCo to an HX-PiCo please contact your Clear-Com 

representative to establish if your hardware is HX ready. If your PiCo hardware is not HX 

ready then this is a factory only upgrade. 

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

Note: The HX-PiCo mainboard needs a factory hardware modification. 

 

Eclipse HX devices are powered by mains voltage. Unless 

specifically advised to the contrary, disconnect mains supply before 

carrying out any maintenance or repair tasks. Observe precautions 

for handling electrostatic sensitive devices. 

6.1 Changing the Eclipse HX-PiCo PROM 

Note: When you change the Eclipse HX-PiCo PROM, you must also change the Eclipse HX-PiCo 

RAM (from 128Mb RAM to 256Mb RAM). See 6.2 Changing the Eclipse HX-PiCo RAM 

below. 

To upgrade the Eclipse HX-PiCo PROM: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

2MBit PROM device (ST 

M27W201 or equivalent). 

 

- 

PROM Programming Unit  You will also require the appropriate 

programming software for the unit. 

 

The appropriate S record 

file for the Eclipse HX-PiCo 

boot PROM.  

You can find the S record file on the Drivers 

USB: 

Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx – Boot PROM 

(where xxxxxx represents the part number). 
Table 6-1: Required equipment 

2) Ensure that the Eclipse HX-PiCo is powered off. Remove the lid of the device. 
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Remove power from the device first, to avoid working with the 

system while it is live. Observe all electrical shock hazard 

warning and precautions for handling electrostatic sensitive 

devices  

3) Ensure that the PROM device to be programmed / upgraded is empty. 

4) Program the PROM device with the appropriate file, in accordance with the 

instructions for the PROM device. 

5) Confirm that the checksum of the programmed device matches that given in the 

Eclipse HX Release Notes (for this documentation, see the Eclipse HX v9.1 

software USB). 

6) Remove the existing PROM device from the main board.  

 

Figure 6-1: Eclipse HX-PiCo main board 

7) Insert the newly programmed PROM device, taking care to ensure the correct 

polarity of the device. 

8) Replace the lid of the Eclipse HX-PiCo device. 

6.2 Changing the Eclipse HX-PiCo RAM 

Note: When you change the Eclipse HX-PiCo RAM (from 128Mb RAM to 256Mb RAM), you must 

also change the Eclipse HX-PiCo PROM. See 6.1 Changing the Eclipse HX-PiCo PROM 

above. 
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To change the Eclipse HX-PiCo RAM (from 128Mb to 256Mb): 

1) Ensure that: 

2) The Eclipse HX-PiCo is powered off.  

3) You have the replacement 256Mb CPU card RAM daughter board to hand. 

4) Remove the lid of the Eclipse HX-PiCo. 

5) The cassette that holds the Eclipse HX-PiCo RAM daughter board is left of center 

on the main board: 

 

Figure 6-2: Eclipse HX-PiCo 128Mb RAM daughter board 

To release the 128Mb RAM daughter board, push back the levers to either side of 

the cassette. Remove the board. 

6) Fit the replacement 256Mb CPU card RAM daughter board to the cassette. The 

daughter board is fitted chip-side up. Ensure that the daughter board is securely 

fitted (only the top edge of the connectors along the lower edge of the board 
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should be visible). 

 

Figure 6-3: Eclipse HX-PiCo 256Mb RAM daughter board 

7) Secure the RAM daughter board by closing the levers to either side of the 

cassette. 

8) Return the CPU card to the Eclipse HX-Median, Eclipse HX-Omega or Eclipse HX-

Delta matrix. 

6.3 Changing the Eclipse HX-PiCo DIP switches 

To change the Eclipse HX-PiCo DIP switches to the appropriate Eclipse HX v9.1 settings, 

see either: 

• Appendix D:Eclipse HX-PiCo CPU DIP switches 

 

• 6.3.3 Upgrading the Eclipse HX-PiCo application code using 

Tera Term 

Upgrading the Eclipse HX-PiCo application code 

6.3.1 Upgrading the Eclipse HX-PiCo app code using EHX with 

Ethernet 

Before you upgrade the Eclipse HX-PiCo card application code, check that: 

• The PC can successfully connect to the matrix with an Ethernet connection by 

viewing the Event Log (Diagnostics > Event Log) in EHX. 

• There is a valid configuration in the matrix. A valid configuration enables the 

matrix to identify its IP address and run its TCP / IP stack. 

To upgrade Eclipse HX-PiCo application code using EHX with an Ethernet connection: 

1) Ensure that you have the following equipment: 
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Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

LAN cable for the PC-to-

Eclipse HX PiCo connection 

For direct connections, use Ethernet crossover 

cable. If the connection passes through an 

Ethernet switch on its way to the PC / matrix, 

use straight CAT5 cable. 

 

EHX installation EHX must be configured and operational. 

 

An EHX configuration file 

(*.ccn or *.hxn file format) 

The configuration file must have an 

appropriate IP address set. 

 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

You can find the *.fwr data file on the 

software USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo 

> xxxxxx – Application Code (where 

xxxxxx represents the product number). 

 
Table 6-2: Required equipment 

2) Start EHX. Select File > Matrix Connection. 

3) In the Matrix Connection dialog, select the Ethernet communications option. 

4) Connect the PC with the Eclipse HX-PiCo, using the LAN port on the rear of the 

matrix. 

5) Do one of the following: 

• If you are running EHX in Client-Server mode, select File > Import project. 

Navigate to the configuration (*.ccn) file and click Open to import the file. 

• If you are running EHX in Client-Only mode, select File > Open. Navigate to the 

configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 

6) In EHX, select System > Layout. In the work area, right click the Eclipse HX-

PiCo. 

7) From the menu, select Firmware > Update Firmware. 
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Figure 6-4: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo  application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > SOFTWARE - 

EHX.xxx > Eclipse HX-PiCo > xxxxxx – Application Code (where 

xxxxxx represents the part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file 

name is displayed in the dialog. 

10) Click Next. Confirm that the correct file has been selected, and click Next again 

to start the firmware update. The update will take approximately 2 minutes. 

Tip: While the update is in progress, check that the LED on the front of the 

Eclipse HX-PiCo is flashing rapidly. Rapid flashes indicate communication with the 

PC. 

Note: If you are upgrading from v5.2.5 to Eclipse HX v9.1, the 

download dialog does not automatically finish. This is due to a 

messaging change between the two system architectures. 

Instead, close the dialog (which will continue to indicate 

Verifying) when the Eclipse HX-PiCo reboots (see Step 10). 

11) When the update is completed, click Finish in the Firmware Update wizard. The 

Eclipse HX-PiCo reboots. The CPU is reset. 

Note: The OK LED double flashes to indicate that valid application code 

is present, but that there is no configuration in the cards. 

Download a configuration file (*.hxn or *.ccn format), using 

EHX. 
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6.3.2 Upgrading the Eclipse HX-PiCo app code using EHX with 

serial link 

You can upgrade the Eclipse HX-PiCo application code using EHX with a serial link, 

whether or not there is a valid configuration (map) on the matrix. With EHX, it is 

possible to perform the initial upgrade using a serial connection, then move to an 

Ethernet connection for future configuration downloads and upgrades, once an IP 

address has been configured. 

Note: Before you use this procedure, check that the matrix event log can connect serially to an  

Eclipse HX-PiCo with a configuration. 

To upgrade the application code with EHX, using a serial link: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as 

a COM port.   

RS232 serial cable  Use an RS232 cable with DB9 to 3.5mm jack 

connectors (a CellCom / FreeSpeak / 

FreeSpeak II (FSBP) registration cable 

(PD4007Z)). 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn) 

The configuration file must have the 

appropriate IP address set. 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

You can find the *.fwr data file on the 

software USB at: 

Software USB > SOFTWARE - EHX.xxx > 

SOFTWARE - EHX.xxx > Eclipse HX-PiCo 

> xxxxxx – Application Code (where 

xxxxxx represents the part number). 

 
Table 6-3: Required equipment 

2) Start EHX. Select File > Matrix connection. 

3) In the Matrix connection dialog, select the serial communications option. 

4) Select the correct COM port then click OK. 

5) Connect the PC to the serial port on the front of the device, using an RS232 

cable with DB9 to 3.5mm jack connectors (CellCom / FreeSpeak / FreeSpeak II 

(FSBP) registration cable (PD4007Z)). 

5. Do one of the following: 
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• If you are running EHX in Client-Server mode, select File > Import 

project. Navigate to the configuration (*.ccn) file and click Open to 

import the file. 

• If you are running EHX in Client-Only mode, select File > Open. 

Navigate to the configuration (*.ccn) and open the file. 

Note: EHX can open *.ccn format files as well as its own *.hxn format 

configuration files. 

6) In EHX, select System > Layout. In the work area, right click the matrix. 

7) From the menu, select Firmware > Update Firmware. 

 
Figure 6-5: Upgrading app code: Matrix firmware update 

8) In the Firmware update wizard, click Next. Ensure that Matrix is selected in the 

following dialog, then click Next again. 

9) In the next dialog, click Browse and navigate to the required *.fwr file for the 

Eclipse HX-PiCo  application: 

a. Go to Software USB > SOFTWARE - EHX.xxx > Eclipse HX-PiCo > 

xxxxxx – Application Code (where xxxxxx represents the part 

number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwr file and click OK / Open. Ensure that the correct file 

name is displayed in the dialog. 

10) Click Next. Confirm that the correct file has been selected, and click Next again 

to start the firmware update. The upgrade will take approximately 2 minutes. 

Tip: While the update is in progress, the LED on the front of the CPU card will 

flash rapidly. Rapid flashes indicate communication with the PC.  

Note: If you are upgrading from v5.2.5 to Eclipse HX v9.1, the 

download dialog does not automatically finish. This is due to a 
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messaging change between the two system architectures. 

Instead, close the dialog (which will continue to indicate 

Verifying) when the Eclipse HX-PiCo reboots (see Step 11). 

 

11) When the update is completed, click Finish in the Firmware Update wizard. The 

Eclipse HX-PiCo reboots. The CPU card(s) is reset.  

Note: The OK LED double flashes to indicate that valid application code 

is present, but that there is no configuration in the cards. 

Download a configuration (*.cnn or *.hxn format) file, using 

EHX. 

If the upgrade fails 

If the upgrade fails, check the cabling and repeat the procedure. If the procedure still 

fails, use Tera Term to upgrade the Eclipse HX-PiCo firmware (see below). 

If there was no previous configuration loaded in the matrix, download a basic 

configuration file to the Eclipse HX-PiCo matrix using EHX. Make any further 

configuration changes over the Ethernet LAN. 

6.3.3 Upgrading the Eclipse HX-PiCo application code using 

Tera Term 

To upgrade the Eclipse HX-PiCo application code using Tera Term: 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with either a serial port 

connection or USB-to-serial 

port adaptor 

If using a USB-to-serial port adaptor cable, 

you must connect the cable before starting 

EHX to enable EHX to detect the USB port as a 

COM port.   

 

RS232 serial cable Use a RS232 cable with DB-9 to 3.5mm jack 

connectors (a CellCom / FreeSpeak / 

FreeSpeak II (FSBP) registration cable 

(PD4007Z)). 

 

Tera Term installation Tera Term must be configured and 

operational. You can find the Tera Term 

application on both of the Eclipse HX 9.0 

upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

ECLIPSE DRIVERS > 3rd_Party_Software 
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Required equipment Description / comments 

> Teraterm 

 

The appropriate *.fwr data 

file for the Eclipse HX-PiCo 

application 

You can find the *.fwr data file on the 

software USB at: 

Software USB > SOFTWARE - EHX.xxx > 

Eclipse HX-PiCo > xxxxxx – Application 

Code (where xxxxxx represents the part 

number). 

 
Table 6-4: Required equipment 

2) Install the Tera Term application. Accept all default settings. 

3) Start Tera Term. In the New Connection dialog, select Serial (connection) and 

the COM port to use. Click OK. 

 
Figure 6-6: Tera Term: selecting serial connection 

4) From the Setup menu, select the Serial port… entry.  

 

 

 

 

 

 

 

 

 

 
 

Figure 6-7: Tera Term: selecting Serial port… 
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5) The Serial port configuration dialog is displayed. Configure the serial port as 

follows: 

Field Data (to enter / select) 

Port Com1 
Note: 

Change as required to match a COM port on the PC. 

Baud Rate 115200 

Parity Even 

Stop One (bits) 

Data 8 (bits) 

Table 6-5: Tera Term: Serial port configuration 

Tip: The Tera Term application can be used for many of the Eclipse system 

upgrade processes. You can save and recall the relevant com port settings in Tera 

Term by selecting the Setup / Save or Restore settings options. 

6) Connect the PC serial port to the RS232 port to the front of the Eclipse HX-PiCo 

matrix. 

7) Power off the matrix. To access the CPU, remove the lid from the matrix.  

 

Remove power from the device first, to avoid 

working with the system while it is live. Observe all 

electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices.  

 

8) Erase the old application code (firmware) from the CPU: 

a. Place the CPU in TEST mode. 

b.  

c. Set the DIP switches on the CPU as follows: 
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Figure 6-8: Eclipse HX-PiCo dip switches in Test mode 

d. To bring the DIP switch changes into effect, power cycle or reset the 

matrix. 

e. To confirm that the matrix has entered Test mode, check the display 

screen. Information similar to the following should be displayed: 

 

 

Figure 6-9: Tera Term CPU test mode 

 

Note: If you do not see the data above, press the enter button on the 

PC. 
 

Tip: To see all the available options in test mode, press ? on your 

keyboard. To see all the current applications loaded onto the CPU, press i. 

f. On your PC keyboard, press number 1. To start the erasure of Flash 

memory, press Enter (or Return). Select y and Enter to confirm. 

Note: It takes approximately 1 minute to erase Flash. 

g. When the Flash has been erased, press number 2 on your keyboard. To 

start the erasure of NVRAM, press Enter (or Return). When the NVRAM 

erase is complete, remove the CPU card. 

9) Download the new application code to the CPU, using Tera Term: 

a. Place the erased CPU in serial download mode. Set the DIP switches on 

the CPU as follows: 



 

 

Eclipse | Upgrade Guide 

Page 89 

   

 

 

 

 

 
Figure 6-10: Tera Term: DIP switches, serial download mode 

b. Power cycle or reset the Eclipse HX-PiCo to bring the DIP switch changes 

into effect. 

c. In Tera Term, open File and select Send file… Ensure that the BINARY 

option box is selected.  

 
Figure 6-11: Tera Term: Send file… 

d. In the Select file dialog, select the file to download, navigate to the CPU 

application code (firmware) *.fwr file: 

i. Go to Software USB > SOFTWARE - EHX.xxx > Eclipse HX-

PiCo > xxxxxx – Application Code (where xxxxxx represents 

the part number). 

The folder contains the *.fwr file and a Read Me file (*.txt) with 

version information. 

ii. Select the*.fwr file and click OK / Open. Ensure that the correct 

file name is displayed in the dialog. 

Note: Confirm that the matrix resets and restarts correctly. 

Note: It may take up to 1 minute for the matrix to write the new 

application code in Flash before it reboots and the OK LED starts 

to double flash 
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e. Set the DIP switches to normal running mode (watchdogs enabled): 

 
Figure 6-12: DIP switches set to normal running mode (watchdogs enabled) 

f. Power cycle the Eclipse HX-PiCo so the DIP switch changes come into 

effect. 

Note: If the download fails the matrix OK LED displays a long flash/ off rate. Tera Term does 

not indicate a failure onscreen and continues to download.  

In this case, re-erase the matrix by placing the SW1 and SW2 into Test mode and 

repeating the steps that follow. Check your cabling.  

6.4 Upgrading the Eclipse HX-PiCo MVX code  

The Eclipse HX-PiCo has two MVX cards (or sections) on the same PCB, both of which 

require upgrading. 

If you are upgrading from ECS v5.2.5, Clear-Com recommends upgrading the Eclipse 

HX-PiCo with the combined MVX boot and application code file (*.mot), using the 

Renesas Flash Development Tool (FDT). 

If you are upgrading an existing Eclipse HX installation, you can upgrade: 

• The MVX application code separately (*.fwc), using EHX. 

• The MVX boot code separately (*.mot), using the Renesas FDT method. 

• The MVX boot and application code simultaneously, using the Renesas FDT 

method and the combined MVX boot and application code file (*.mot). 

MVX code Renesas FDT 

method 

EHX method 

MVX boot code (*.mot)  - 

 

MVX application code 

(.fwc) 

- 

 
 

Combined MVX boot and 

application code (*mot) 
 

 

- 
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Table 6-6: Upgrading the Eclipse HX-PiCo MVX code 

Note: Because of small differences in PCB layout, it may not be possible to complete the 

upgrade of the MVX application code on a small number of Eclipse HX-PiCo units, using 

EHX. If the upgrade fails, you can still upgrade the MVX application code using Renesas 

FDT (which is suitable for all Eclipse HX-PiCo units). 

6.4.1 Upgrading the Eclipse HX-PiCo MVX application code 

 with EHX 

Note: To upgrade the Eclipse HX-PiCo MVX application code with EHX, your system must 

already be running a version of Eclipse HX. 

Recommendation 

Clear-Com recommends that you monitor the MVX application code upgrade using the 

Event Log in EHX. The upgrade process is complete when the MVXs on the Eclipse HX-

PiCo briefly disappear and then reappear in the log. To check that the upgrade has been 

successful, run a firmware report. 

If the upgrade is unsuccessful, use the Renesas FDT to upgrade the MVX code  

(see 6.4.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app code using the 

Renesas FDT). 

To upgrade the Eclipse HX-PiCo MVX application code using EHX: 

1) Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

 

- 

Serial cable or Ethernet 

cable for the PC to matrix 

connection 

 

- 

EHX installation 

 

EHX must be configured and operational. 

An EHX configuration file 

(*.hxn or *.ccn format) 

 

The configuration file must have an 

appropriate IP address set. 

The appropriate *.fwc 

format file for the Eclipse 

HX-PiCo MVX cards / 

sections 

You can find the Eclipse HX-PiCo MVX 

application code (*.fwc) file on the software 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 

> xxxxxx-MVX Application 
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Table 6-7: Required equipment 

2) Start EHX on the PC. 

3) Connect the PC to the matrix using either Ethernet or a serial communications 

port. 

4) Open the EHX configuration map within EHX. Select System > Layout. 

5) Right click the matrix and then select Firmware> Update Firmware. 

6) The Update Firmware wizard dialog is displayed. Click Next. 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected.  

 

Figure 6-13: Select Hardware Type 

 

7) In the next dialog, click Browse and navigate to the required *.fwc file for the 

Eclipse HX-PiCo  application: 

8) Go to Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – 

MVX Application (where xxxxxx represents the part number). 

9) The folder contains the *.fwc file and a Read Me file (*.txt) with version 

information. 

10) Select the*.fwc file and click OK / Open. Ensure that the correct file name is 

displayed in the dialog. 

11) Click Next and confirm that the details displayed are correct. 

12) Click Next and confirm that the download commences. 

13) When the download has completed, click Finish to close the update firmware 

wizard. 

Note: Because of small differences in PCB layout, it may not be possible to complete the 

upgrade of the MVX application code on a small number of Eclipse HX-PiCo units, using 

EHX. If the upgrade fails, you can still upgrade the MVX application code using Renesas 

FDT (which is suitable for all Eclipse HX-PiCo units). 
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6.4.2 Upgrading the Eclipse HX-PiCo MVX boot and/or app 

code using the Renesas FDT 

 

To upgrade certain components within the Eclipse HX-PiCo matrix, 

the lid must be removed. 

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  

 

You can use the Renesas FDT to upgrade: 

• The MVX boot code file separately (*.mot). 
 

• The MVX boot code and MVX application code simultaneously, using the combined MVX 
boot and application code file (*.mot). 
 

Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

To upgrade the Eclipse HX-PiCo MVX code (MVX boot code or combined MVX boot and 

application code): 

 

 

 

1) Ensure that you have the following equipment: 

Required equipment Description / comments 

PC with a serial port 

connection or USB-to-

serial port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. You can find the Renesas FDT 

application on both of the Eclipse HX v9.1 

upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT  

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

The appropriate MVX code 

file  
You can find the Eclipse HX-PiCo MVX code files 

on the Eclipse Drivers USB: 
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(*.fwc format for the 

separate MVX boot file, 

*.mot format for the 

combined MVX boot and 

application code file ) 

Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx-MVX Boot 

Drivers USB > ECLIPSE DRIVERS > PiCo-

HX_PiCo_E-32 > xxxxxx-MVX Combined 

Boot & App 

Where xxxxxx represents the product number. 
Table 6-8: Required equipment 

2) Install the Renesas Flash Development Toolkit 3.4 Basic (FDT). Accept the 

default install settings. 

3) Start the Renesas Flash Development Toolkit 3.4 (FDT) from Programs, 

selecting the basic Startup option. 

4) Access the configuration (settings) dialogs, by selecting Options > New 

Settings...  Configure the FDT, as shown in the table below: 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 

Select Port COM1 (Change to match a COM port present on the 

PC) 

CPU Frequency 20.0000 Mhz 

Connection Boot mode 

Recommended 

Speed 

38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

Table 6-9: FDT settings 

Note:  

The first time the FDT is run, the settings dialogs are displayed by default. After 

the FDT has been configured, the settings dialogs are no longer shown by default.  

Tip:  For more information about installing and configuring the Renesas FDT, see 

 Appendix E: Hitachi Renesas Flash Development Tool. 

 

5) In the Download window, click Options and ensure that: 
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• Auto-Disconnect is selected (checked). 

• Download File Area has User Area selected (checked). 

• The Download File radio button is selected. 

6) Select ‘…’ for the User area and select the appropriate MVX code file from the 

Eclipse HX v9.1 software USB. According to your requirements, select one of the 

following: 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx-

MVX Boot 

 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx-

MVX Combined Boot & App 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

7) Upgrade / program the first of the two H8 devices: 

a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the 

PC and J9 (H8FP1) on the MVX card. 

Note:  

The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper H8 Boot1 (JP8) is made. 

c. Select Program Flash from the Flash Development Toolkit (FDT) program. 

d. Confirm that FDT reports the image has been written successfully. 

e. Remove the serial cable. 

f. Remove jumper JP8. 

For the location of connectors, jumpers and reset switch positions on the Eclipse 

HX-PiCo, see Figure 6-14: Eclipse HX-PiCo main board. 

Note: If the MVX card fails to upgrade, press the Reset button, located near the J9 (H8FP1) 

connector and select Program Flash from the FDT again. 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged 

and re-plugged to enable the upgrade to start on some computers. If you are 

running the EHX application, ensure that EHX is configured for Ethernet and not 

serial connection. 

8) Upgrade / program the second of the two H8 devices: 

a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the 

PC and J11 (H8FP2) on the MVX card. 

Note: The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper H8 Boot2 (JP10) is made. 
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c. Select Program Flash from the Flash Development Toolkit (FDT) program.  

d. Confirm that FDT reports the image has been written successfully. 

e. Remove the serial cable. 

f. Remove jumper JP10. 

For the location of connectors, jumpers and reset switch positions on the Eclipse 

HX-PiCo, see Figure 6-14: Eclipse HX-PiCo main board. 

Note: If the MVX card fails to upgrade, press the Reset button, located 

near the H8FP1 (JP11) connector and select Program Flash from 

the FDT again.  

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged and re-

plugged to enable the upgrade to start on some computers. If you are running the EHX 
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application, ensure that EHX is configured for Ethernet and not serial connection.

 

Figure 6-14: Eclipse HX-PiCo main board 
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6.5 Checking the Eclipse HX-PiCo app code and MVX 

code versions 

You can check both the Eclipse HX-PiCo application code and MVX code versions by 

going to EHX> Matrix Event Log > Matrix Overview. 

You can also use the Firmware report tool in EHX to confirm code versions. To use the 

Firmware report tool: 

1) Go to EHX> System> Layout. 

2) Right click the matrix icon. 

3) Select Firmware > Firmware report. 

To check the Eclipse PiCo MVX code version only using Tera Term: 

4) Install Tera Term. Tera Term is available to install from both of the Eclipse HX 

9.0 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 

 

5) Open Tera Term and select the following port settings: 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 
Table 6-10: Tera Term port settings 

6) Open the Eclipse HX-PiCo lid. 

  

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  

 

7) There are two three-pin connectors (H8DBG1 and H8DBG2), one for each of the 

two MVX cards / sections. Connect the MVX serial cable (CAB-MVX-48Z) to one of 

the connectors. 



 

 

Eclipse | Upgrade Guide 

Page 99 

   

 

 

 

 

Note: Take care not to confuse these two three-pin connectors with the identical (but 

differently labeled) three-pin connectors which are used to upload new application code. 

 

8) Run Tera Term. If necessary, press Enter on your keyboard or the MVX reset 

switch a few times. The version information is displayed in the Tera Term 

window. 

Note: Reports the MVX application code version only. 

9) Repeat the procedure with the second MVX card / section. 

6.6 Upgrading the Eclipse HX-PiCo CPLD and FPGA 

code with Xilinx tools 

To upgrade either the Eclipse HX-PiCo U1 CPLD code or FPGA code with Xilinx tools: 

1) Ensure that the latest version of the Xilinx programming tools has been 

installed.  

Tip: For more information about installing Xilinx programming tools, see 

Appendix J:Xilinx tools. 

Connect the USB connector of the download cable (Platform cable USB DLC9G) 

to the USB port of the PC. 

2) If you are upgrading the FPGA code, connect the 14way IDC header to 

CON12. 

3) If you are upgrading the U1 CPLD code, connect the 14way IDC header to 

CON25. 

Tip: For the location of CON12 and CON25, see Figure 6-14: Eclipse HX-PiCo 

main board. 

4) Power up the Eclipse HX-PiCo and start the iMPACT programming tool. 

5) In Load Project, select Cancel. 

6) In Flows, double click Boundary Scan. Right click the main window and select 

Initialise Chain / Ctrl+ I: 
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Figure 6-15: Example iMPACT Boundary Scan 

1. If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. 

The full chain should show two devices, as shown in the example figure below. 

 
Figure 6-16: Example Xilinx chip chain 
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2. The Assign New Configuration File dialog asks you to select the code for the 

first device in the chain or to bypass that device.  

In this example procedure, the first device will be bypassed and either the U1 

CPLD or FPGA code will be assigned to the second device. 

 
• For the first device, press Bypass. 

 

• For the second device, select the appropriate code file (either the U1 CPLD code or 
FPGA code file). The U1 CPLD and FPGA code files are available from the Drivers 
USB: 
 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – E32 
Glue Logic CPLD (U1). 
 

• Drivers USB > ECLIPSE DRIVERS > PiCo-HX_PiCo_E-32 > xxxxxx – 
Eclipse 32 FPGA Code. 
 

Reminder: 

If you are upgrading the FPGA code, the 14way IDC header must be 

connected to CON12. If you are upgrading the U1 CPLD code, the 14way IDC 

header must be connected to CON25. See Step 3. 

 

3. A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 

 

 
 

Figure 6-17: Example Xilinx device programming properties 

4. Right click the second device and select Programming.  

 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 
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5. Power down the matrix. 

 

6.7 Download a test configuration into the Eclipse 

HX-PiCo using EHX 

After you have upgraded your Eclipse HX-PiCo, Clear-Com recommends downloading a  

test configuration to the matrix. Downloading a configuration will enable you to make 

any further configuration changes you require using EHX over an Ethernet or serial 

connection. 

For more information, see your EHX User Guide. 

6.8 Forcing the Eclipse HX-PiCo to the factory default 

IP address 

 
In rare situations, the CPU card may not be able to find a valid IP address for the 

Ethernet port. To address this issue, force the matrix to the factory default IP address 

(169.254.0.100) by using the Eclipse HX-PiCo menu system to enable DHCP. 

For more information about using the Eclipse HX-PiCo menu system, see the Eclipse 

HX-PiCo User Guide. 

Alternatively, you can reset the Eclipse HX-PiCo to the factory default IP address with 

the internal reset switches. 

To force the Eclipse HX-PiCo to the factory default IP address using the internal 

switches: 

1. Set your PC Ethernet IP address to DCHP mode. Directly connect the PC to the 

matrix using an Ethernet crossover cable. 

 

2. To gain access to the internal reset switches, remove the lid of the Eclipse HX-

PiCo.  

 

 

The device is live (powered). Observe all electrical shock hazard 

warning and precautions for handling electrostatic sensitive devices.  
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                   Figure 6-18: Eclipse HX-PiCo: resetting to the 

factory default IP address 

3. To reset the IP address, press and hold the two rightmost switches 

simultaneously (the IP Reset switch and the Full Reset switch), then press and 

release RESET on the front of the matrix. 

4. Once the OK LED starts to flash, release both internal buttons. 

 

5. Replace the Eclipse HX-PiCo lid. 
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7 Upgrading the MVX-A16 card  

This chapter describes how to upgrade the MVX-A16 analog port card, which is fitted to 

the Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

 

7.1 Identifying MK I and MK II MVX-A16 cards 

 

You can identify MK I and MK II cards visually. 

The MK 1 MVX-A16 card is green. – see Figure 7-2: MVX-A16 MK I card: J1, CON8 

and CON12 

The MK2 E-QUE card is blue. – see Figure 7-3: MVX-A16 MK 

II card: J1, CON8 and CON12 

Both cards are upgraded with the same code except for the FPGA – see 7.4 Upgrading 

the MVX-A16 MK I or MK II card FPGA with Xilinx tools 

7.2 Upgrading the MVX-A16 MK I or MK II boot 

and/or app code 

If you are upgrading from ECS v5.2.5, Clear-Com recommends upgrading the MVX-A16 

card with the combined MVX boot and application code file (*.mot), using the Renesas 

Flash Development Tool (FDT). 

If you are upgrading an existing Eclipse HX installation, you can upgrade: 

• The MVX application code separately (*.fwc), using EHX. 
 

• The MVX boot code separately (*.mot), using the Renesas FDT method. 
 

• The MVX boot and application code simultaneously, using the Renesas FDT method and the 
combined MVX boot and application code file (*.mot). 

MVX code Renesas FDT method EHX method 

MVX boot code 

(*.mot) 
 - 

 

MVX application code 

(.fwc) 

- 
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MVX code Renesas FDT method EHX method 

Combined MVX boot 

and application code 

(*mot) 

 

 

- 

Table 7-1: Upgrading the Eclipse HX-PiCo MVX code 

7.2.1 Upgrading the MVX-A16 card app code using EHX 

You can upgrade the MVX-A16 application code (*.fwc) using EHX and an Eclipse HX 

matrix. For Ethernet connections, an EHX configuration is required with the correct IP 

address configured. The application code is available from the Eclipse HX v9.1 software 

USB.  

Place the H8 application code in a location that EHX can access. When these files are 

downloaded to the matrix, all the MVX-A16 cards that have been fitted to the matrix will 

be upgraded. 

To upgrade MVX-A16 H8 application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet 

connector 

- 

Serial cable or Ethernet 

cable for the PC to matrix 

connection. 

- 

EHX installation EHX must be configured and operational. 

An EHX configuration file 

(*.hxn) 

The configuration file must have an 

appropriate IP address set. 

The appropriate *.fwc 

format file for the MVX-A16 

card 

You can find the *.fwc file on the software 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

Omega-Median-Delta > xxxxxx-MVX 

Application (where xxxxxx represents the 

product number).  
Table 7-2: Required equipment 

2. Start EHX on the PC. 

3. Connect the PC to the matrix using either Ethernet or a serial communications 

port. 

4. Open the EHX configuration map within EHX. Select System > Layout. 

5. Right click the matrix and then select Firmware> Update Firmware. 
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6. The Update Firmware wizard dialog is displayed. Click Next. 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected. 

 

 

Figure 7-1: Select Hardware Type 

7. In the next dialog, click Browse and navigate to the required *.fwc file for the 

MVX-A16 card  application: 

a. Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX Application (where xxxxxx represents the part number). 

The folder contains the *.fwc file and a Read Me file (*.txt) with version 

information. 

b. Select the*.fwc file and click OK / Open.  

8. Click Next and confirm that the details displayed are correct. 

9. Click Next and confirm that the download commences. 

10. When the download has completed, click Finish to close the update firmware 

wizard. 

 

Note: The MVX-A16 card status light flashes green while the upgrade is in process (LED on to 

off ratio: 1:4 at 0.5Hz). When the upgrade is complete, the status light is lit green at a 

steady heartbeat (LED on to off ratio: 1:1 at 1Hz). 

11. Ensure that the MVX-A16 cards reset once the download is complete. Reset 

should take approximately 1 minute. 

7.2.2 Upgrading the MVX-A16 boot and app code using the 

Renesas FDT 

 

 

Remove power from the devices first, to avoid working with the 

system while it is live. Observe all electrical shock hazard warning 

and precautions for handling electrostatic sensitive devices  

 

You can use the Renesas FDT to upgrade: 

• The MVX boot code file separately (*.mot). 
 

• The MVX boot code and MVX application code simultaneously, using the combined MVX 
boot and application code file (*.mot). 
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Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

To upgrade the MVX code (MVX boot code or combined MVX boot and application code) 

for the MVX-A16 card: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port 

connection or USB-to-

serial port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. You can find the Renesas FDT 

application on both of the Eclipse HX v9.1 

upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT  

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

 

The appropriate MVX code 

file (*.fwc format for the 

separate MVX boot file, 

*.mot format for the 

combined MVX boot and 

application code file ) 

You can find the Eclipse HX-PiCo MVX code files 

on the Eclipse drivers USB: 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx-MVX Boot 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx-MVX Combined 

Boot & Application 

Where xxxxxx represents the product number. 
Table 7-3: Required equipment 

2. Install the Renesas Flash Development Toolkit 3.4 Basic (FDT). Accept the default 

install settings. 

3. Start the Renesas Flash Development Toolkit 3.4 (FDT) from Programs, selecting 

the basic Startup option. 

4. Access the configuration (settings) dialogs, by selecting Options > New 

Settings...  Configure the FDT, as shown in the table below: 

 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 
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Settings dialog / 

option 

Setting to enter 

Select Port COM1 (Change to match a COM port present on the 

PC) 

CPU Frequency 20.0000 Mhz 

Connection Boot mode 

Recommended 

Speed 

38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

             Table 7-4: FDT settings 

Note: The first time the FDT is run, the settings dialogs are displayed by default. After the FDT 

has been configured, the settings dialogs are no longer shown by default.  

Tip:  For more information about installing and configuring the Renesas FDT, see 

Appendix E: Hitachi Renesas Flash Development Tool. 

5. In the Download window, click Options and ensure that: 

• Auto-Disconnect is selected (checked). 

• Download File Area has User Area selected (checked). 

• The Download File radio button is selected. 

6. Select ‘…’ for the User area and select the appropriate MVX code file from the 

Eclipse HX v9.1 software USB. According to your requirements, select either: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-

MVX Boot 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-

MVX Combined Boot & Application 

Where xxxxxx represents the product number. The folder contains the 

*.mot file and a Read Me file (*.txt) with version information. 

7. Upgrade / program the device: 

a. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the 

PC and CON8 on the MVX-A16 card. 

Note: The MVX connection is polarized to ensure correct connection. 

b. On the MVX card, ensure that jumper JP1 is made. 
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c. Select Program Flash from the Flash Development Toolkit (FDT) 

program. 

d. Confirm that FDT reports the image has been written successfully. 

e. Remove the serial cable. 

f. Remove jumper JP1. 

Tip: For the location of connectors and jumpers on the MVX-A16 MK I card, see 

 Figure 7-2: MVX-A16 MK I card: J1, CON8 and CON12 

Tip: For the location of connectors and jumpers on the MVX-A16 MK II card, see 

 Figure 7-3: MVX-A16 MK II card: J1, CON8 and CON12 

8. Repeat for Step 7 for all other MVX-A16 cards in the system. 

Important note: 

If the MVX card fails to upgrade, press the Reset button on the front of the card, 

and select Program Flash from the FDT again. 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged 

and re-plugged to enable the upgrade to start on some computers. If you are 

running the EHX application, ensure that EHX is configured for Ethernet and not 

serial connection. 

 

 

Figure 7-2: MVX-A16 MK I card: J1, CON8 and CON12 

CON8 J1 CON12
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CON8 CON12

 

Figure 7-3: MVX-A16 MK II card: J1, CON8 and CON12 

 

7.3 Checking the MVX-A16 MK I or MK II boot and 

application code version 

You can check the MVX-A16 boot and application code versions by going to EHX> 

Matrix Event Log > Matrix Overview. 

You can also use the Firmware report tool in EHX to confirm the application code version. 

To use the Firmware report tool: 

 

1. Go to EHX> System> Layout. 

2. Right click the matrix icon. 

3. Select Firmware > Firmware report. 

To check the firmware version using Tera Term: 

1. Install Tera Term. Tera Term is available to install from both of the Eclipse HX 9.0 

upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 

2. Open Tera Term and select the following port settings: 
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Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 
Table 7-5: Tera Term port settings 

3. Remove the MVX-A16 card to be checked from the Eclipse HX-Median / Eclipse 

HX-Omega / Eclipse HX-Delta matrix.  

4. Connect the MVX serial cable (CAB-MVX-48Z) to the CON8 connector on the MVX-

A16 card and to the PC (see Figure 7-2: MVX-A16 MK I card: J1, CON8 and 

CON12).  

5. Reset (re-seat) the MVX-A16 card back in the Eclipse HX-Median / Eclipse HX-

Omega / Eclipse HX-Delta matrix. 

The MVX-A16 firmware version is the first line of the information received on Tera 

Term. 

 

a. Select Firmware > Firmware report. 

 

7.4 Upgrading the MVX-A16 MK I or MK II card FPGA 

with Xilinx tools 

7.4.1 Upgrading the MVX-A16 MK1 

Note: Some very early MVX (MKI) cards may exhibit the following errors when 

upgrading the FPGA device: 

Programming failed or  

The idcode read from the device does not match the idcode in the bsdl 

File. 

There are two possible solutions 

a) USB cable speed : Adjust the USB cable speed, Output > Cable Setup 

and setting the TCK Speed/Baud to 1.5Mhz 

Always try this solution first for either failure mode  

b) Modify the Device ID bsdl file 

In the Xilinx installation directory, change the expected IDCODE from .bsd file.  

To do this:  
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1) Search for xc18v04.bsd in Xilinx installation directory.  

2) Change Part Number from 0101000000110110 to 0101000000100110 in 

the file. 

3) Save the file, then close and open impact. After doing this the prom is 

accessible from impact. 

Example File location: C:\Xilinx\14.5\LabTools\LabTools\xc18v00\data 

You can use the Firmware report tool in EHX to confirm the firmware version of 

H8 application and FPGA code. The Firmware report tool does not provide 

firmware version information for DSP code.  

To use the Firmware report tool: 

4) Open EHX and go to System > Layout. 

5) Right click the matrix icon. 

6) Select Firmware > Firmware report. 

To upgrade the MVX FPGA with Xilinx tools: 

1. Ensure that version 11.1 of the Xilinx programming tools has been installed. 
Tip:  For more information about installing the Xilinx programming tools, see 
 Appendix J:Xilinx tools. 

2. Connect the USB connector of the download cable (Platform cable USB DLC9G) to 

the USB port of the PC. 

3. Connect the 14way IDC header to CON12 (see Figure 7-2: MVX-A16 MK I 

card: J1, CON). 

4. Power up the MVX-A16 card and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialize Chain / Ctrl+ I: 
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Figure 7-4: Example iMPACT Boundary Scan 

7. If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given. The full chain should show two devices, as shown in the 

example figure below. 

 

 
Figure 7-5: Example Xilinx chip chain 

8. The Assign New Configuration File dialog asks you to select an FPGA image 

for the first device in the chain or to bypass that device.  
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In this example procedure, the first device will be bypassed and an FPGA image 

will be assigned to the second device. 
• For the first device, press Bypass. 

• For the second device, select the FPGA image (*.mcs format). The FPGA file is 
available from the Drivers USB and is dependent on whether the MVX Card is a Mark 
I or a Mark II   : 

• MVX MK I (Green PCB) 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX MK I (Green PCB) FPGA  

(Where xxxxxx represents the product number). 

• MVX MK II (Blue PCB) 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx – MVX MK II (Blue PCB) FPGA  

(Where xxxxxx represents the product number). 

 
Figure 7-6: Example Xilinx device programming properties 

9. Right click the second device and select Programming. 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

A summary dialog is presented. For all devices, ensure that the Erase Before 

Programming and Verify flags are set. Click OK. 

10. Power down the MVX-A16 card. 

7.4.2 Upgrading the MVX-A16 MK2 

1. Ensure that version 13.1 of the Xilinx programming tools has been installed. 

 
Tip:  For more information about installing the Xilinx programming tools, see 
 Appendix J:Xilinx tools. 
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2. Connect the USB connector of the download cable (Platform cable USB DLC9G) to 

the USB port of the PC. 

3. Connect the 14way IDC header to CON12 (see Figure 7-2: MVX-A16 MK I 

card: J1, CON). 

4. Power up the MVX-A16 card and start the iMPACT programming tool (Ver 13.1) 

on the PC. 

5. Ensure that Xilink box shows GREEN led. (Orange Led means no connection) 

 

6. Select "No" 

 

7. Select  

a. "Yes" if more upgrade is to be performed later on. 

b. "No" if this is a one off upgrade 

8. Cancel the following pop up when seen 
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9. Double click on "Boundary Scan" on the right of the window. 

 

10. In the Boundary Scan window, right click in the display and select "Initilise Chain" 
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11. When asked whether to "Continue and assign configuration file(s)?" 

a. Select "No" 

12. "Cancel" the next pop up window. 

13. On the device shown on the diagram, right click on the "SPI/BPI" on top of the 

device. 

14. Select "Add SPI/BPI....." 

 

15. Pop up "Add PROM File" appears, select where the .mcs file needed, and click 

"Open" 

16. Pop up "Select Attached SPI/BPI, on the first drop down list on the right, select 

"S25FL032P" from the list, click "OK". 
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17. Right click on the "SPI/BPI" device, it should show GREEN with the word "FLASH". 

Select "Program" 

18. Pop up "Device Programming Properties" window, select "Device1(Attached Flash, 

S25FL032P), then click "OK". 

 

19. Pop up "Executing command....." to show the progress. 

20. On success, pop up "Program Suceeded" is shown. 
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21. Power down the MVX-A16 card and remove the Xilinx programming tool. 
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8 Upgrading E-FIB cards 

This chapter describes how to upgrade the E-FIB fiber cards, which are fitted to the 

Eclipse HX-Median, Eclipse HX-Omega and Eclipse HX-Delta matrices.  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

8.1 Upgrading E-FIB card FPGA with Xilinx tools 

If the E-FIB card FPGAs are going to be upgraded in an Eclipse HX-Median / Eclipse HX-

Omega / Eclipse HX-Delta matrix, take one of the following measures: 

• Fit the E-FIB cards to a slot which is not configured for it. 
 

• Manually reset the E-FIB card for the duration of the upgrade operation. 
 

• Remove both CPU cards from the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-
Delta matrix for the duration of the upgrade. 
 

If you do not take one of the above measures then the upgrade may fail. 

To upgrade the Xilinx FPGAs (front card and rear card) on an E-FIB card: 

1. Ensure that the latest versions of the Xilinx programming tools have been 

installed. 

 
Tip: For more information about installing Xilinx programming tools, see 
Appendix J:Xilinx tools. 

2. Connect the USB connector of the download cable (Platform cable USB DLC9G) to 

the USB port of the PC. 

3. Connect the 14way IDC header to: 

 
• CON8 on the front card, if you are programming both cards simultaneously or just 

the front card. 
 

• CON5 of the rear card if you are only programming the rear card. 
 

Note: The front and rear cards can be upgraded (programmed) either individually or together. 

If only the front card is being programmed, fit LK9 to the front card. 

4. Power up the UUT and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 8-1: Example iMPACT Boundary Scan 

7. If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given.  

If only one of the cards (the front or the rear) is being upgraded, only the first 

two or last two devices in the above chain are displayed. 

Note: The Assign New Configuration File dialog is also displayed. However, ignore this 

dialog until you have checked the chain. 

Tip: If the programming tool fails initially to recognize the adaptor or the FPGA 

chain, you can sometimes solve this issue by: 
• Pressing the reset switches by the FPGA. 

• Setting a slower cable speed. 

8. The Assign New Configuration File dialog asks you to select an FPGA image 

for the first device in the chain or to bypass that device.  

In this example procedure: 

a. Bypass the first and third devices. In the Assign New Configuration File 

dialog, press Bypass for each device. 

b. Provide the second and fourth devices (the FPGA Flashes) with images. In 

the Assign New Configuration File dialog, select the FPGA image for the 

second device, the router FPGA Flash.  

 

Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > 

xxxxxx-Fibre Router (front) FPGA (where xxxxxx represents the 

product number). 
 
The folder contains the FPGA file (*.mcs format) and a Read Me file (*.txt), which 
contains version information. 
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c. Select the FPGA image for the fourth device, the networking FPGA Flash. 

 
Go to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-Fibre 
Networking (rear) FPGA  
(where xxxxxx represents the product number). 
 
The folder contains the FPGA file (*.mcs format) and a Read Me file (*.txt), which 
contains version information. 

9. A summary dialog is presented. For the FPGA Flash device(s), ensure that the 

Erase Before Programming and Verify flags are set. Click OK. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 

                    

Figure 8-2: Example Xilinx device programming properties 

10. The upgrade (programming) starts, and takes approximately 2 minutes to 

complete. When the upgrade is complete, the Program Succeeded message is 

displayed in the main window. 

11. Power down the UUT. 
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9 Upgrading E-QUE cards 

The following chapter describes how to upgrade E-QUE cards (both MK1 and MK2).  

Note: This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 3 Quick 

reference: Upgrading to Eclipse HX. 

9.1 Identifying MK1 and MK2 E-QUE cards 

To identify the E-QUE card as a MK1 or a MK2 card, run a firmware report in EHX. To use 

the Firmware report tool: 

a. Go to EHX> System> Layout . 

b. Right click the matrix icon. 

c. Select Firmware > Firmware report. 

You can also identify MK 1 and MK 2 cards visually. 

The MK 1 E-QUE card is green. It also features a large chip in the upper right hand 

corner of the PCB (as it is installed in the matrix): 

 

Figure 9-1: MK 1 E-QUE card detail 

The MK2 E-QUE card is blue. The large chip no longer forms part of the PCB: 

 

 

 

 

 

Figure 9-2: MK 2 E-QUE card detail 
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9.2 Upgrading the E-QUE card (MK1) 

You must upgrade the E-QUE card (MK1) in the following order: 

1. E-QUE card application code (using the procedure described in this section). 

Note: An MVX upgrade cable is required. The procedure also requires 

an Ethernet connection between the E-QUE card and the PC. If 

the card and the PC are not connected to the network, they can 

be connected directly using a crossover Ethernet cable.  

2. E-QUE card FPGA code (see 9.4 Upgrading the E-QUE card (MK1 and MK2) FPGA with 
Xilinx tools). 

Note: Requires specialized equipment. For more information about 

installing and using Xilinx programming tools, see Appendix 

J:Xilinx tools. 

3. E-QUE card (MK1) Boot PROM (if required) (see 9.5 Upgrading the E-QUE card (MK1) 
boot ROM). 

 

 

 

 

 

 

 

 

 

Figure 9-3: E-QUE upgrade 

To upgrade the application code of the E-QUE card (MK1): 

1. Ensure that you have the following equipment:  

 

Required equipment Description / comments 

Tera Term software Tera Term must be configured and operational. 

You can find the Tera Term application on both 

of the Eclipse HX 9.0 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

MVX cable connected to the 

E-QUE front card. 

Ethernet Crossover cable from PC LAN port 

>  

E-QUE rear card LAN connector.  
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Required equipment Description / comments 

TFTP Server software - 

MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-1: Required equipment 

 

 
 

 
Figure 9-4: MVX-A16 serial cable (CAB-MVX-48Z) 

2. Install Tera-Term. Third party software is available from either of the Eclipse HX 

9.0 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

Teraterm 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 

Tip: For more information about installing Tera Term, see Appendix G: Tera 

Term  
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3. Create a directory on your PC called c:\tuft. 
4. Navigate to either of the following folders: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server 
App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 
 

             Open the folder. Copy tftpserv.exe into the c:\tftp directory. 

Note: 

Any TFTP server can be used as long as it points to the C:\TFTP folder. 
5. Navigate to the following folder on the software USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx- E-Que 
application MK-I & MK-II (where xxxxxx represents the product number) 
 

Open the folder. Copy the E-QUE software file (*.image format file) into the c:\tftp directory. 
6. From the same folder, copy the Tera Term macro file combined_eque_upgrade.ttl to the 

c:\tftp directory. 
 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
 

 
 

Figure 9-5: Tera Term: selecting Serial Port 

8. In the Serial port configuration dialog, enter the following settings: 
 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 
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Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, 

change this value to 50ms. 
Table 9-2: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
 

 
 

Figure 9-6: TFTP Server Window 

 
Note:  
The TFTP application can only access files in the same folder as the TFTP application. The 
E-QUE firmware file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE 
card CON-200. 
 
Reinsert the E-QUE card into the rack.  
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Figure 9-7: E-QUE MK1 card serial connector 

 
12. If it is not already powered up, power up the Eclipse HX-Median / Eclipse HX-Omega / 

Eclipse HX-Delta matrix.  
 

13. Ensure that the E-QUE card and the PC are both connected to the Ethernet network in some 
way, or are connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When 
the E-QUE card is connected to the PC or to the network, check that the LAN LEDs (the 
yellow and green lights at the bottom of the card) are flashing occasionally, indicating a 
network connection.  

14. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 
combined_eque_upgrade.ttl and follow the macro instructions. 
 
Note: 

The macro should reset and re-boot the E-QUE card automatically. However, if it does not, 
you may have to reset the E-QUE card using the reset button on the front. The reboot should 
be seen on the serial console. This reset is essential, as it permits Tera Term to interrupt the 
boot process. 

15. The Macro will detect the card as a MKI. You will be prompted to verify the card has a green 
PCB by the macro. If the card is Blue, it is a MKII. 
 

16. Enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range 

as your PC IP address (for example, 192.168.42.5). 

 

b.  Enter your PC IP address (for example,192.168.42.1) 
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c. Enter the name of the E-QUE card firmware file. 

 
17. The application code downloads to the E-QUE card. When the download is complete, the 

E-QUE card reboots. 
 
Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
entered. Also check that the filename has no file extension. 
 
Tip: On the Tera Term screen towards the end of the boot sequence messages there will be 
a status message that shows a date stamp and version string. Check this string to verify the 
firmware version. 

9.3 Upgrading the E-QUE card (MK2) 

You must upgrade the E-QUE card (MK 2) in the following order: 

1. E-QUE card application code (using the procedure described in this section). 
 
Note: 
An MVX upgrade cable is required. The procedure also requires an Ethernet connection 
between the E-QUE card and the PC. If the card and the PC are not connected to the 
network, they can be connected directly using a crossover Ethernet cable.  
 

2. E-QUE card FPGA code (see 9.4 Upgrading the E-QUE card (MK1 and MK2) FPGA with 
Xilinx tools). 
 
Note: 
Requires specialized equipment. For more information about installing and using Xilinx 
programming tools, see Appendix J:Xilinx tools. 
 

3. E-QUE card (MK2) Boot PROM (if required) (see 9.6 Upgrading the E-QUE card (MK2) 
boot ROM). 

 

 

 

 

 

 

 

 

 

Figure 9-8: E-QUE upgrade 

MVX cable connected to the 

E-QUE front card. 

Ethernet Crossover cable from PC LAN port 

>  

E-QUE rear card LAN connector.  
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To upgrade the firmware file / application code of the E-QUE card (MK2): 

1. Ensure that you have the following equipment:  

 

Required equipment Description / comments 

Tera Term software Tera Term (version 4.3 or later) must be 

configured and operational. You can find the 

Tera Term application on both of the Eclipse HX 

9.0 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

TFTP Server software - 

MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-3: Required equipment 
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Figure 9-9: MVX-A16 serial cable (CAB-MVX-48Z) 

2. Install Tera-Term. Third party software is available from either of the Eclipse HX 9.0 upgrade 

media: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 
 

Tip: For more information about installing Tera Term, see Appendix G: Tera 

Term  

3. Create a directory on your PC called c:\tftp. 
 

4. Navigate to either of the following folders: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server 
App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 
 

5. Open the folder. Copy tftpserv.exe into the c:\tftp directory. 
Note: 

Any TFTP server can be used as long as it points to the C:\TFTP folder. 

5. Navigate to the following folder on the software USB: 
 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-Que 
application MK-I & MK-II (where xxxxxx represents the product number) 
 

Open the folder. Copy the E-QUE firmware file (*.image format file) into the c:\tftp directory. 
 

Tip: The folder also contains a Read Me file (*.txt), which includes the procedure 

for upgrading the E-QUE firmware file. 

 
6. From the same folder, copy the Tera Term macro file combined_eque_upgrade.ttl to the 

c:\tftp directory. 
 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
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Figure 9-10: Tera Term: selecting Serial Port 

8. In the Serial port configuration dialog, enter the following settings: 
 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, 

change this value to 50ms. 
Table 9-4: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 
 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
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Figure 9-11: TFTP Server Window 

Note:  
The TFTP application can only access files in the same folder as the TFTP application. The 
E-QUE firmware file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE 
card (MK2) CON-2200. 
 
Reinsert the E-QUE card (MK2) into the rack:  
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Figure 9-12: E-QUE card (MK2) serial connector 

 
12. Power up the Eclipse HX-Median / Eclipse HX-Omega / Eclipse HX-Delta matrix (if not 

already powered up).  
 

13. Ensure that the E-QUE card (MK2) and the PC are either: 
 

• Connected to your Ethernet network. 
 

• Directly connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When 
the E-QUE card is connected to the PC or to the network, check that the LAN LEDs (the 
yellow and green lights at the bottom of the card) are flashing occasionally, indicating a 
network connection. 

 
14. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 

combined_eque_upgrade.ttl and follow the macro instructions. 
 
Note: 

The macro should reset and re-boot the E-QUE card automatically. However, if it does not, 
you may have to reset the E-QUE card using the reset button on the front. The reboot should 



 

 

Eclipse | Upgrade Guide 

Page 135 

   

 

 

 

 

be seen on the serial console. This reset is essential, as it permits Tera Term to interrupt the 
boot process. 
 

15. If the reset is successful, the following dialog is displayed:  
 

 
 

Figure 9-13: E-QUE (MK2) successful reset dialog 

To continue, click OK. 
 
 
Note:  
If the reset and reboot is not successful, the following error message is displayed: 
 

 
 

Figure 9-14: E-QUE (MK2) reset error message 

If you receive this message, you are advised to repeat the procedure from Step 6. 
 

16. The boot countdown appears again on the serial console. Tera Term recognizes that the card 
has rebooted and you are asked to enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range 
as your PC IP address (for example, 192.168.42.5). 

 
b.  Enter your PC IP address (for example,192.168.42.1). 

 
c. Enter the file name of the E-QUE card application code (firmware) (for example, 

eque_release_image-3.16.5.0). 
 

d. Enter the Gateway IP address or accept the default (10.50.16.1). 
 

e. Enter the Subnet Mask or accept the default (255.255.255.0). 
 

The application code downloads to the E-QUE card (MK2). When the download is complete, 
the E-QUE card (MK2) reboots. 
 
Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
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entered.  
 

17. If the download is successful, the following dialog is displayed by Tera Term: 
 

 
Figure 9-15: Successful download dialog 

To exit the macro, click OK. 
 
Note: 

If the download was not successful, the following error dialog is displayed by Tera Term: 

 

 
Figure 9-16: Failed download dialog 

If you receive this message, you are advised to repeat the procedure from Step 6. 
 

9.4 Upgrading the E-QUE card (MK1 and MK2) FPGA 

with Xilinx tools 

Note: Upgrading the E-QUE card FPGA using Xilinx tools requires specialized equipment. For 

more information about the Xilinx programming tools, see Appendix J:Xilinx tools. 

To upgrade the E-QUE card FPGA code with Xilinx tools: 

1. Ensure that the latest versions of the Xilinx programming tools have been 

installed. 

2. Connect the USB connector of the download cable (Platform cable USB DLC9G) to 

the USB port of the PC. 

3. Connect the 14way IDC header to CON3100. 

4. Power up the UUT and start the iMPACT programming tool. 

5. In Load Project, select Cancel. 

6. In Flows, double click Boundary Scan. Right click the main window and select 

Initialize Chain / Ctrl+ I: 
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Figure 9-17: iMPACT Boundary Scan 

 

7. If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given.  

 
Figure 9-18: Example Xilinx chip chain 

8. The Assign New Configuration File dialog asks you to select an FPGA image 

for the first device in the chain or to bypass that device.  
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In this example procedure, the first device will be bypassed and an FPGA image 

will be assigned to the second device. 
• For the first device, press Bypass. 

• For the second device, select the FPGA image (*.mcs) from the Drivers USB: 
 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – EQUE 
FPGA  

(where xxxxxx represents the product number). 

A summary dialog is presented. Ensure that the Erase Before Programming 

and Verify flags are set. Click OK. 

 

 

 
 

Figure 9-19: Example Xilinx device programming properties 

9. Right click the second device and select Programming. 

 

The upgrade starts, and takes approximately 2 minutes to complete. When the 

upgrade is complete, the Program Succeeded message is displayed in the main 

window. 

10. Power down the UUT. 

9.5 Upgrading the E-QUE card (MK1) boot ROM 
 

Only upgrade the E-QUE (MK1) boot ROM after the main E-QUE application code has 

been upgraded.  

Note: 

The procedure below is for E-QUE (MK1) cards only. To upgrade the PROM of an E-QUE 

card (MK2), see 9.6 Upgrading the E-QUE card (MK2) boot ROM. 

To upgrade the E-QUE card (MK1) boot PROM: 
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1. Ensure that you have the required equipment: 

 
• 2 MBit PROM device (ST M27W201 or equivalent). 

 

• PROM programming unit and PROM programming software appropriate for that unit. 
 

• Appropriate ‘S’ record file. To find the file, go to: 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – E-Que MKI 
(Green PCB) Boot ROM (where xxxxxx represents the part number). 
. 
The folder contains the *.s record file and a Read Me file (*.txt), with version 
information. 

2. Ensure that the PROM device to be programmed is empty. 

3. Program the PROM device with the appropriate file, according to the instructions 

for the PROM programmer being used. 

Note: 

The load address for the S record is 0xFFF00000. 

Confirm that the checksum of the programmed device matches that detailed in 

the Eclipse HX Release Notes. 

4. Remove the existing PROM device from the configuration card. 

Insert the newly programmed PROM device taking care to ensure the correct 

polarity of the device. 

 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 

9.6 Upgrading the E-QUE card (MK2) boot ROM 
Only upgrade the E-QUE (MK2) boot ROM after the main E-QUE application code has 

been upgraded.  

Note: The procedure below is for E-QUE (MK2) cards only. To upgrade the PROM of an E-QUE 

card (MK2), see 9.5 Upgrading the E-QUE card (MK1) boot ROM. 

To upgrade the E-QUE (MK2) boot PROM: 

1. Ensure that you have the following equipment:  

 

Required equipment Description / comments 

Tera Term software Tera Term must be configured and operational. 

You can find the Tera Term application on both 

of the Eclipse HX 9.0 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 
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Required equipment Description / comments 

TFTP Server software - 

MVX Serial cable (CAB-

MVX-48Z) 

See Figure 9-4: MVX-A16 serial cable (CAB-

MVX-48Z) 

Ethernet crossover cable - 

Small reset tool  For example, a bent paper clip 
Table 9-5: Required equipment 

2. Install Tera Term. 

Tip: For more information about installing Tera Term, see Appendix G: Tera 

Term  

3. Create a directory on your PC called c:\tftp. 
4. Navigate to either of the following folders: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > EQue TFTP Server 
App 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > EQue TFTP Server App 
 

             Open the folder. Copy tftpserv.exe into the c:\tftp directory. 

Note: Any TFTP server can be used as long as it points to the C:\TFTP 

folder. 

5. Navigate to Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx – E-Que 
MKII (Blue PCB) Boot ROM  

(where xxxxxx represents the product number). 

Open the folder. Copy the E-QUE (MK2) boot ROM file into the c:\tftp directory. 
 

6. From the same folder, copy the Tera Term macro file EQ2_uboot_upgrade.ttl to the c:\tftp 
directory. 

7. Start Tera Term. Open the Setup menu and select Serial Port…. 
 

 
Figure 9-20: Tera Term: selecting Serial Port 
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8. In the Serial port configuration dialog, enter the following settings: 

Port setting Setting to enter 

Port COM1 (Change to match a COM port present on the PC) 

Baud rate 115200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow control none 

Transmit delay 0 msec/char. If the E-QUE card fails to load correctly, 

change this value to 50ms. 
Table 9-6: Tera Term port settings 

9. Set the IP address of your PC to a fixed / static address (any IP address of your choice is 
suitable). 

10. Navigate to the c:\tftp directory. To open the TFTP Server command window, double click the 
application tftpsrv.exe. 
 

 
 

Figure 9-21: TFTP Server Window 

Note:  
The TFTP application can only access files in the same folder as the TFTP application. The 
E-QUE MK2 boot ROM file must be in the same directory as the tftpsrv.exe program. 
 

11. Connect the MVX serial cable (CAB-MVX-48Z) between the PC serial port and the E-QUE 
card (MK2) serial connector (CON-2200): 
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Figure 9-22: E-QUE card (MK2) serial connector 

12. Reinsert the E-QUE card (MK2) into the rack. 
 

13. Power up the Eclipse HX-Median / Eclipse HX-Omega matrix / Eclipse HX-Delta matrix (if it is 
not already powered up).  
 

14. Ensure that the E-QUE card (MK2) and the PC are either: 
 

• Connected to your Ethernet network. 
 

• Directly connected using a crossover Ethernet cable. 
 
The LAN connector on the E-QUE card is the highest RJ-45 socket on the back panel. When 
the E-QUE (MK2) card is connected to the PC or to the network, check that the LAN LEDs 
(the yellow and green lights at the bottom of the card) are flashing occasionally, indicating a 
network connection. 

15. In Tera Term, select Control > Macro and then navigate to the c:\tftp directory. Open 
EQ2_uboot_upgrade.ttl and follow the macro instructions. 
 
Note: 

The macro should reset and re-boot the E-QUE card (MK2) automatically. However, if it does 
not, you may have to reset the E-QUE card (MK2) using the reset button on the front. The 
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reboot should be seen on the serial console. This reset is essential, as it permits Tera Term to 
interrupt the boot process. 
 

16. If the reset is successful, the following dialog is displayed:  
 

 
 

Figure 9-23: E-QUE (MK2) successful reset dialog 

To continue, click OK. 

 

Note:  
If the reset and reboot is not successful, the following error message is displayed: 
 

 
 

Figure 9-24: E-QUE (MK2) reset error message 

If you receive this message, you are advised to repeat the procedure from Step 6. 

 
17. The boot countdown appears again on the serial console. Tera Term recognizes that the card 

has rebooted and you are asked to enter the following information to enable the download:  
 

a. Enter an IP address for the E-QUE card. This address must be in the same range 
as your PC IP address (for example, 192.168.42.5). 

 
b.  Enter your PC IP address (for example,192.168.42.1). 

 
c. Enter the file name of the E-QUE card application code (firmware) (for example, 

eque_release_image-3.16.5.0). 
 

d. Enter the Gateway IP address or accept the default (10.50.16.1). 
 

e. Enter the Subnet Mask or accept the default (255.255.255.0). 
 

The application code downloads to the E-QUE card (MK2). When the download is complete, 
the E-QUE card (MK2) reboots. 
 
Note:  
If when downloading file, T T T T is displayed on the Tera Term serial screen, this indicates a 
problem downloading the file.  Check the network connection and the IP addresses that were 
entered.  
 



 

 

Eclipse | Upgrade Guide 

Page 144 

   

 

 

 

 

17. If the download is successful, the following dialog is displayed by Tera Term: 
 

 
        Figure 9-25: Successful download dialog 

To exit the macro, click OK. 
 
Note: 

If the download was not successful, the following error dialog is displayed by Tera Term: 
 

 
            Figure 9-26: Failed download dialog 

If you receive this message, you are advised to repeat the procedure from Step 6. 
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10 Upgrading IVC-32 and LMC-64 cards 

To upgrade IVC-32 and LMC-64 cards, follow the same upgrade procedures for E-QUE 

cards (MK1), as described in 9 Upgrading E-QUE cards.  

At EHX v9.1, the application code for all 3 cards (E-QUE, IVC-32 and LMC-64 cards) is 

the same. 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 3 Quick 

reference: Upgrading to Eclipse HX. 

10.1 Identifying MK1 and MK2 IVC-32 / LMC-64 cards 

To find out if the IVC-32 / LMC-64 card is either a MK 1 or a MK 2 card, run a firmware 

report in EHX. The firmware report identifies the card as either a MK 1 or a MK 2 card. 

To use the Firmware report tool: 

a. Go to EHX> System> Layout . 

 

b. Right click the matrix icon. 

 

c. Select Firmware > Firmware report. 

You can also identify MK1 and MK2 cards visually. 

The MK1 IVC-32/LMC-64 card is green. It features a large chip in the upper right hand 

corner of the PCB (as it is installed in the matrix): 

 

Figure 10-1: IVC-32/LMC-64 MK1 card detail 

The MK2 IVC-32/LMC-64 card is blue. If you look at the upper right hand corner of the 

card, the large chip no longer forms part of the PCB: 
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Figure 10-2: IVC-32/LMC-64 MK2 card detail 
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11 Upgrading E-MADI64 cards 

This chapter describes how to upgrade MK1 E-MADI64 cards. The following E-MADI64 

code can be upgraded: 

• The boot code file (*.mot), which is upgraded using the Renesas Flash Development Toolkit 
3.4 Basic (FDT). 
 

• The application code and DSP code files (*.fwc), which are upgraded using EHX. 
  

• The FPGA code, which is upgraded using either EHX or Xilinx iMPACT programming 
software.  
 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

11.1 Identifying MK1 and MK2 E-MADI64 cards 

Note: this chapter only describes how to update MK1 E-MADI64 cards. 

To identify the E-MADI64 card as a MK1 or a MK2 card, run a firmware report in EHX. To 

use the Firmware report tool: 

a. Go to EHX> System> Layout . 

b. Right click the matrix icon. 

c. Select Firmware > Firmware report. 

You can also identify MK 1 and MK 2 cards visually. 
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The MK 1 E-MADI64 card is blue or green: 

 

Figure 11-1: MK 1 E-MADI64 card detail 

The MK2 E-QUE card is blue: 

 

Figure 11-2: MK 2 E-MADI64 card detail 
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11.2 Upgrading the E-MADI64 boot code 

To upgrade the E-MADI64 card H8 boot code: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port 

connection or USB-to-serial 

port adaptor 

If you are using a USB-to-serial port adaptor, 

download the latest drivers. 

Renesas Flash 

Development Toolkit 3.4 

Basic (FDT) 

 

The Renesas FDT must be installed and 

configured. The Renesas FDT application is 

available from both Eclipse HX v9.1 upgrade 

media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > RenesasFDT 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > RenesasFDT 

 

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

For an image of this cable, see 

Figure 28: MVX-A16 Serial upgrade cable. 

 

The E-MADI64 card H8 

boot code file (*.mot): 

 

The E-MADI64 card boot code file (*.mot) is 

available from the following folder: 

 

Drivers USB > ECLIPSE DRIVERS > Omega-

Median-Delta > xxxxxx – E-MADI Boot  

(Where xxxxxx represents the product 

number). 
Table 11-1: Required equipment 

 

2. Install the Renesas Flash Development Toolkit (FDT), which is available from 

either of the Eclipse HX v9.1 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

RenesasFDT 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > 

RenesasFDT 

Accept the default install settings. 

3. Start the Renesas Flash Development Toolkit (FDT) from Programs, selecting the 

basic Startup option. 
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4. Access the configuration (settings) dialogs, by selecting Options > New 

Settings...  Configure the FDT, as shown in the table below: 

 

Settings dialog / 

option 

Setting to enter 

 

Select Device 

 

H8S/2318F 

Select Port COM1 (Change to match a COM port present on the 

PC) 

CPU Frequency 25.0 Mhz 

Connection Boot mode 

Recommended 

Speed 

38400 (Deselect the Use-Default option) 

Protection Automatic 

Messaging Advanced 

User Area Selected (Checked)  

Readback 

verification 

Yes 

Table 11-2: FDT settings 

Note:  

The first time the FDT is run, the settings dialogs are displayed by default. After 

the FDT has been configured, the settings dialogs are no longer shown by default.   

 

5. In the Download window, click Options and ensure that: 

 

• Auto-Disconnect is selected (checked). 

• The Download File radio button is selected. 

 

6. Select ‘…’ for the User area and select the appropriate *.mot format file for the 

E-MADI64 H8 boot code. 

 

The EMADI64 boot code file is available from the Drivers USB: 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx-E-

MADI Boot  

(where xxxxxx represents the product number). 
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7. On the E-MADI64 card to be updated, ensure that jumper J1000 is made. 

 
Figure 11-3: E-MADI64 PCB (upper right hand corner) 

 

8. Connect the MVX serial cable (CAB-MVX-48Z) between the COM port on the PC and 

the CON1001 on the E-MADI64 card to be updated. 

 

See Figure 11-3: E-MADI64 PCB (upper right hand corner) above. 

 

Note:  

The E-MADI64 connection is polarized to ensure a correct connection. 

 

9. Insert the E-MADI64 card into the Eclipse HX-Median / Eclipse HX-Omega / 

Eclipse HX-Delta matrix (having ensured that the matrix is powered on). 

 

10. Select Program Flash from the FDT. Confirm that FDT reports the image has 

been written successfully. 

 

Important note: 

If the E-MADI64 card fails to upgrade, reset (re-seat) the E-MADI64 card and 

select Program Flash from the FDT again. 

 

If you are using a USB-to-serial adaptor, the adaptor may have to be unplugged 

and re-plugged to enable the upgrade to start on some computers. If you are 

running the EHX application, ensure that EHX is configured for Ethernet and not 

serial connection. When the upgrade is complete, you can also do the following: 

1. Remove the E-MADI64 card from the matrix. 
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2. Remove the MVX serial cable (CAB-MVX-48Z). 

3. Remove jumper J1000. 

4. Repeat steps 7 through 11 for each remaining E-MADI64 card. 

11.3 Upgrading the E-MADI64 application, DSP and 

FPGA code using EHX 

You can upgrade the E-MADI64 application, DSP and FPGA code using EHX and an 

Eclipse matrix. If you are using an Ethernet connection, an EHX configuration map is 

required with the correct IP address configured. 

Note: 

With E-MADI64, you can upgrade the FPGA code in exactly the same way as the 

application and DSP code. 

*.fwc format files are used in the download of the E-MADI64 application code, the DSP 

code, and the FPGA code. The Drivers USB contains the E-MADI64 application and DSP 

code: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI Application 
 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI DSP 
 

The Drivers USB contains the E-MADI64 FPGA code: 

• Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > E-MADI FPGA 
 

Place the application, DSP and FPGA code files in a location that EHX can access. When 

these files are downloaded to the matrix, all the E-MADI64 cards that have been fitted 

to the matrix will be upgraded. 

Note – Once the firmware is downloaded from EHX to the CPU card it can take between 

45 – 60 minutes to transmit this image to the MADI cards (depending on the number of 

cards that are inserted and therefore receiving the image in parallel). Please use the 

matrix event log of the matrix frame to monitor the percentage complete state of the 

image transmission. Allow the card to automatically reboot at the end of upgrade as the 

image has to be copied to permanent storage on the card after it has been received. 

Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v9.1, see the quick reference procedures tables in 2  Selecting Upgrade Procedures. 

 

To upgrade E-MADI64 H8, DSP or FPGA code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 
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PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 

Ethernet or serial cable 

for the PC-to-matrix 

connection 

- 

H8 application code, DSP 

and FPGA code files 

The appropriate application code, DSP code and 

FPGA code files (*.fwc format) are available 

from the Eclipse HX v9.1 upgrade media: 

 
• Drivers USB > ECLIPSE DRIVERS > 

Omega-Median-Delta > E-MADI Application 

 

• Drivers USB > ECLIPSE DRIVERS > 
Omega-Median-Delta > E-MADI DSP 

 

• Drivers USB > ECLIPSE DRIVERS > 
Omega-Median-Delta > E-MADI FPGA. 

 

Table 11-3: Required equipment 

 

2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or a serial communications 

port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware. 

The Update Firmware wizard dialog is displayed. Click Next. 

 

In the Select Hardware Type screen, ensure that the Card radio button is 

selected. 

 

 

Figure 11-4: Select Hardware Type 
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7. Click Next and then browse to the E-MADI64 code file (application, DSP or FPGA 

code files (*.fwc)). 

 

Tip: See Step 1 for the location of the .fwc files on the Eclipse HX v9.1 USB. 

 

8. Click Next and confirm that the details displayed are correct. 

 

9. Click Next and confirm that the download commences. 

 
Note: 

The E-MADI64 card status light flashes green while the upgrade is in process 

(LED on to off ratio: 1:4 at 0.5Hz). When the upgrade is complete, the status 

light is lit green at a steady heartbeat (LED on to off ratio: 1:1 at 1 Hz). 

 

10. When the download has completed, click Finish to close the update firmware 

wizard. 

 

11. Ensure that the E-MADI64 cards reset once the download is complete. All the 

cards are upgraded at the same time. 
 

Code Approx. reset time 

Application 1 minute 

DSP 3 minutes 

FPGA 18 minutes 

Table 11-4: Approximate reset times per system 

12. Confirm the updated firmware version by opening EHX and going to  

Matrix event log > Matrix overview. 

 

Note: 

You can also use the Firmware report tool in EHX to confirm the firmware version 

for the H8 boot code (see the previous procedure), H8 application code and FPGA. 

However, the Firmware report tool does not provide firmware version information 

for DSP code.  

 

To use the Firmware report tool: 

 

b. Open EHX and go to System > Layout. 

 

c. Right click the matrix icon. 

 

d. Select Firmware > Firmware report. 
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11.4 Upgrading the E-MADI64 FPGA using the Xilinx 

tool set 
Note: 

Upgrading the E-QUE card FPGA using Xilinx tools requires specialized equipment. For 

more information about the Xilinx programming tools, see Appendix J:Xilinx tools. 

Note: 

Ensure that the Xilinx tool set is Version 11 or later. 

To upgrade the Xilinx FPGAs on an E-MADI64 card: 

1. Ensure that the latest versions of the Xilinx programming tools have been 

installed. 

 
Tip: For more information about installing Xilinx programming tools, see 
Appendix J:Xilinx tools. 
 

2. Obtain the latest version of the Xilinx device firmware from the Drivers USB: 

 

Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-

MADI FPGA > xxxxxx.mcs and xxxxxx.cfi 

Where xxxxxxx represents the product / file number. 

Note: 

When upgrading the E-MADI64 FPGA, both the *.mcs and *.cfi file are required. 

The *.cfi and *.mcs file are available from the same location. The user does not 

have to do anything else, as the tools find the files. 

 

3. Connect the USB connector of the download cable (Platform cable USB DLC9G / 

DLC10) to the USB port of the PC. 

 

4. Connect the 14way IDC header to CON4000. 

 

5. Power up the UUT and start the iMPACT programming tool. 

 

6. In Automatically create and save a project, select No. 

 

7. In Load Project, select Cancel. 

8. In Flows, double click Boundary Scan. Right click the main window and select 

 Initialise Chain / Ctrl+ I: 
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Figure 11-5: Example iMPACT Boundary Scan 

9. If the cable is connected correctly, the application will connect and a Xilinx chip 

chain will be shown. If the cable is not connected correctly, a cable connection 

warning is given.  

 
Figure 11-6: Example Xilinx chip chain 

10. In the Auto Assign Configuration Files Query dialog, select Yes. 



 

 

Eclipse | Upgrade Guide 

Page 157 

   

 

 

 

 

11. The Assign New Configuration File dialog asks you to select an FPGA image 

for the first device in the chain or to bypass that device. 

 

In this example procedure, the first device will be bypassed and an FPGA image 

will be assigned to the second device. 

 
• For the first device, press Bypass. 

 

• For the second device, select the FPGA image: 
 
Drivers USB > ECLIPSE DRIVERS > Omega-Median-Delta > xxxxxx - E-MADI 
FPGA > xxxxxx.mcs and xxxxxx.cfi 
 
Where xxxxxx represents the product / file number. 

Note: 

When upgrading the E-MADI64 FPGA, both the *.mcs and *.cfi file are required. 

The *.cfi and *.mcs file are available from the same location. The user does not 

have to do anything else, as the tools find the files. 

 

12. A summary dialog is presented. For the selected device, ensure that the Erase 

the Entire Device and Verify flags are set. Click OK. 

 

 
Figure 11-7: Example Xilinx device programming properties 

13. In Impact Processes, double click program. 

The upgrade (programming) starts, and takes approximately 2 minutes to 

complete. When the upgrade is complete, the Program Succeeded message is 

displayed in the main window. 

14. Power down the UUT. 
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12 Upgrading E-DANTE64-HX cards 

Upgrades for your E-DANTE64-HX card are available for both EHX and Dante firmware 

and are available from your Clear-Com representative. 

The upgrade process for each of the two modules on the card (EHX and Dante) is 

different. The two processes are outlined below.  

Note: When upgrading your E-Dante64 card, only use the Clear-Com supplied upgrade files for 

both  

(A: EHX) ClearCom - App, Boot, DSP, FPGA:  xxxxxx.FWC files  

(B: Dante) ClearCom [Brooklyn]: xxxxxx.dnt file.  

To check if your firmware is up to date, open the Firmware Report 

in EHX: 

1) In the EHX software, navigate to the Layout tab. 

2) Right click on the required matrix and select Firmware/Firmware Report. 

 

12.1.1 Upgrade EHX E-DANTE64 firmware 

1) In the EHX software, navigate to the Layout tab.  

2) Right click on the matrix to be upgraded and select Firmware > Update 

Firmware > Card.  

3) Navigate to where the E-Dante64 upgrade file is stored and click to upload.  

There are 4 possible upgrade file types. 
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Upgrade file type Approximate upgrade time/notes 

App.FWC 2 min. This is the most common file to 

upgrade and is usually labeled 

‘Clearcom’. 

Boot.FWC 1 min. 

DSP.FWC 3 min. Reset card on front panel after 

upgrade. 

FPGA.FWC 16 mins. 

 

While the E-DANTE64 card is being upgraded with EHX firmware, the active light (green) 

on the front of the device will flash at double its usual speed and the error light (red) will 

show. The card is ready for use when the error light is off and the status light has 

returned to a steady 1Hz pulse.  

 

 

Note: The upgrade process for an E-DANTE64 card is the same as a MADI card. If you need 

more detailed information, see 11 Upgrading E-MADI64 cardsUpgrading E-MADI64 

cards). 

12.1.2 Upgrade Dante firmware 
Before updating the Dante component of your E-DANTE64 card, you must first download 

the Dante Firmware Update Manager from the Audinate website.  

Open the Dante Firmware Update Manager and follow the instructions on the screen.  

The Dante firmware upgrade file (usually labeled ‘Brooklyn’) has a .dnt extension.  
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Note: Disable any firewalls before upgrading the E-Dante combined Brooklyn file via Dante 

Firmware Update Manager.  

Note: When upgrading firmware for the Dante component, the status light on the front of the 

E-Dante64 card will not change.  
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13 Upgrading CellCom®/FreeSpeak® wireless 

systems 

For detailed guidance on CellCom / FreeSpeak firmware upgrades, including MKII 

beltpacks, antennas and splitters, see the CellCom and FreeSpeak Firmware 

Upgrade Manual. 

For FreeSpeak II firmware upgrades see 17 Upgrading FreeSpeak II™ wireless 

systems 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 
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14 Upgrading panels 

This chapter describes how to upgrade the i-Station and V-Series user panels supported 

by Eclipse HX. 

Supported panels may be upgraded using an installed and configured copy of EHX and 

an active Eclipse HX matrix.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

14.1 Upgrading panels using EHX 

In all cases, panels should initially be upgraded using EHX. Manual programming of 

panels should only be attempted if the EHX download repeatedly fails. 

The download of a panel application requires an *.fwp format file, which is located on 

the software USB. This must be placed in a location that is accessible by the installed 

EHX application. 

Note:  

The Eclipse HX v9.1 contains all the firmware files required for upgrading a panel.  

 

The download of a panel application requires: 

• An operational Eclipse HX matrix with the panels connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet 
connection is used). 
 

Once the *.fwp format file is downloaded to the Eclipse HX matrix, all panels of the 

same type will be upgraded at the same time through an automatic download from the 

matrix to the panel. 

Each panel type requires a different *.fwp format file, but the Eclipse HX matrix 

determines the panel type before attempting any download. It is therefore not 

necessary to disconnect panels of a different type to prevent an accidental download. 

To upgrade panel application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 
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Required equipment Description / comments 

EHX configuration file / 

map 

- 

Ethernet or serial cable 

for the PC-to-matrix 

connection 

- 

Appropriate *.fwp format 

panel application 

The appropriate *.fwp format panel code is 

available from the Drivers USB: 

 

Drivers USB > ECLIPSE DRIVERS > Panel 

Software > <Panel type> 

 

Table 14-1: Required equipment 

2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or serial communications port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware.  

 

7. The update firmware wizard dialogue is displayed. Click Next and ensure that the 

Panel radio button is selected. 

 

In Options: 

• Selecting Automatic mode forces panels to upgrade automatically. 

 

• Selecting Panel Prompt mode means that each panel user will be asked 

to accept / decline the panel upgrade. 

8. Click Next and then browse to the appropriate *.fwp file: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > <Panel type> 
 

9. Click Next and confirm that the details displayed are correct. 

 

10. Click Next and confirm that the download commences. 

 

11. When the download has completed, click Finish to close the update firmware 

wizard. 

 

12. Ensure that the matrix commences downloading to connected panels of the 

required type. If automatic download does not commence, power cycle the 

panel(s) being upgraded. 
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13. Ensure that the panels reset once the download is complete. 

 

14. Confirm the updated firmware version using either: 

 

• The  EHX firmware report tool: 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 

- Select Firmware > Firmware report. 

 

• The local menu on the panel (display panels only). 

14.1.1 Locating Panel *.fwp files on the software USB 

Panel type *.fwp file 

i-Station (i-Series) Drivers USB > ECLIPSE DRIVERS > Panel_Software > i-

Station > xxxxxx-i-Station App (where xxxxxx represents 

the product number) 

 

Note:  

Clear-Com recommends that you upgrade Expansion panels 

first before upgrading the main i-Station.  

E-Station Drivers USB > ECLIPSE DRIVERS > Panel Software > E-

Station > xxxxxx-E-Station App (where xxxxxx represents 

the product number). 

Note:  

Clear-Com recommends that you upgrade Expansion panels 

first before upgrading the main E-station. 

V-Series Drivers USB > ECLIPSE DRIVERS > Panel Software > V-

Series > Main Board > xxxxxx-Panel Application  

(where xxxxxx represents the product number). 

 

V-Series Display 

Module 

The Display Module upgrade files (*.fwp format) are available 

from the Drivers USB: 

 
• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-

Series > Display_Module > xxxxxx-Display PIC Boot 
Loader 
 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-
Series > Display_Module > xxxxxx-Display PIC Application 
Code 
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Where xxxxxx represents a product number. 

 

Table 14-2: Locating Panel *.fwp files 

Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v9.1, see the quick reference procedures tables in 2 Selecting Upgrade Procedures. 

14.1.2 V-Series upgrades 

You cannot upgrade any other panels during a V-Series panel upgrade.  

The size of the V-Series firmware means that it cannot be stored in the flash memory of 

the matrix during the upload, and has to be retained in the upload buffer. If an attempt 

is made to upgrade another panel while the V-Series panel is being upgraded, the V-

Series firmware upload will be overwritten. 

Clear-Com also recommends that you do not download any configurations during the V-

Series panel upgrade. An Apply Changes download from EHX will break a V-Series 

panel upgrade (the download partially resets the configuration for each panel and this 

makes the rack "forget" that it is upgrading the panel).  

14.2 Upgrading panel application code manually  
The application code for most panels can be upgraded manually either by re-

programming the PROM or by directly connecting the panel to a PC. Before attempting 

any upgrade, ensure that anti-static precautions are taken, as Eclipse HX devices are 

sensitive to static discharges. 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 
Tip: For help with selecting the other procedures you require for upgrading to Eclipse HX 

v9.1 see the quick reference procedures tables in 2 Selecting Upgrade Procedures. 

Cabling for i-Station upgrades 

14.2.1 Manually upgrading i-Station & E-Station panel 
application code 
 

Before you manually upgrade the application code for i-Station & E-Station panels, 

ensure that you have the following equipment: 

• An i-Station serial interconnect lead. 

 

• RS232/RS422 adaptor (see Figure 14-1: Example converter cable). 
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• An installed Tera Term application. 

  

• A paperclip or small flat blade screwdriver to access maintenance button 

on the rear of the i-Station panel.  

 

Tera Term uses a special file with the updated i-Station or E-station application code, 

instead of an *.fwp file. The file has an *.s19 file extension and the specific files can be 

found on the software USB: 

• Software USB > SOFTWARE - EHX.xxx > Panel Software > i-Station > xxxxxx-i-Station 
App 
 

• Software USB > SOFTWARE - EHX.xxx > Panel Software > E-Station > xxxxxx-E-Station 
App 
 
Where xxxxxx represents the product number. 

The convertor cable connects from a serial port on the PC, routes through an RS-232 

to RS-422 adapter and connects to the expansion out RJ-45 port and the i-Station or the 

expansion in RJ-45 port of the E-Station using separate CAT5 cables. 

 

Figure 14-1: Example converter cable 

Figure 14-2 shows an example wiring scheme for serial programming an i-Station 

panel: 
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Figure 14-2: Example wiring scheme for i-Station serial programming 

Figure 14-3 shows an alternative cabling scheme that does not require the use of the 

RS-422 converter module:  

 

 

Figure 14-3: Alternate example wiring scheme for i-Station serial programming 

Note: 

The cabling scheme shown supports i-Station panels. To use with an E-station simply 

reverse the TX and RX connections at the Sub-D 9-pin F connector. 

 

Tip:  An i-Station or E-station with either no firmware installed or corrupted firmware 

may be repaired through an upgrade (the station will display Display Module Test, 

Press All Buttons 3X). 

 

To manually upgrade the i-Station panel application code:  
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1. Install Tera Term. Third party software is available from either of the Eclipse HX 9.0 upgrade 

media: 
 

• Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > Teraterm 
 

• Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > Teraterm 
 

Tip: For more information about installing Tera Term, see Appendix G: Tera 

Term  

2. Connect the converter cable to the expansion out RJ-45 port (J1) on the i-Station 

undergoing the upgrade. 

If the cable has separate i-Station and E-station CAT5 cables, the i-Station CAT5 

cable is used for the connection to J1 on the i-Station. Connect the other end of 

the cable to the serial port of the PC running the Tera Term software. 

 
Note: 

The i-Station panel must not be powered while the cable is connected. 

 

 

 

 

 

 

 

Figure 14-4: i-Station manual upgrade 

3. Start Tera Term. 

 

Configure Tera Term for the appropriate COM port on the PC, as shown in the 

following figure. 

 

Select the Serial radio button and then the correct COM port setting for the PC 

from the Port drop-down menu. Click OK. 

 

 

 

 

 

 

Figure 14-5: Tera Term: COM port setting 
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4. From the Tera Term main screen select Setup > Serial port….  

 

The serial port setup screen should now be visible. Configure Tera Term with the 

following settings:  

 

Field Setting 

Baud 19200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow Control None 

Table 14-3: Serial port setup screen settings 

 
Note: 

Do not configure (ignore) the Transmit delay settings. 

 

Click OK. 

 

5. Power up the i-Station panel into maintenance mode by first holding in the 

recessed button found on the rear panel during a simultaneous AC power up. 

 

The reset button must be held in until all front panel keys turn bright red and 

the front panel display modules show the message Display Module Test’, Press 

All Buttons 3x. 

 

Tip:  If the recessed button cannot easily be accessed, use a bent paper clip or 

small flat blade screwdriver to press the button in. 

 

 

 

 

 

 

 

 

 

Figure 14-6: Module display message 
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6. The following Tera-Term boot up message is displayed.  

 
Note: 

Do not proceed until you see the boot up message. If you do not see the boot up 

message, check your wiring connections and software settings. Repeat steps 1 – 

6 

 

 

 

 

 

 

 

 

 

 

Figure 14-7: Boot up message 

7. Press the 1 key on the PC keyboard. Press Enter to access the Checksums and 

Versions information on the i-Station panel. 

 

The boot code version and application code versions are displayed on the Tera-

Term screen. 

 
Note: 

Do not proceed until the version information is displayed, as shown below.  

 

 

 

 

 

 

 

 

 

Figure 14-8: Version and application code (firmware) versions 
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8. Before loading the new application code (*.s19 format file), you must erase the 

Flash ROM on the i-Station panel. 

 

Press in the 2 key on the PC keyboard and press Enter. 

 

A message is displayed indicating Flash Erasing – Please wait. . After the Flash 

ROM is erased, a message is displayed asking you to Download S-record file 

now. 

 

 

 

 

 

 

 

 

 

Figure 14-9: Erasing Flash ROM 

9. In File, select the Send File. You are prompted to browse for the i-Station *.s19 

file: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > i-Station > xxxxxx-

i-Station App 

 

10. Select the i-Station *.s19 file. Select Open to start the *.s19 file download 

process to the Flash ROM of the i-Station panel.  

 

Note: 

The download process takes several minutes to complete.  

 

11.  When the download process is complete, Tera-Term will display the message on 

the PC Download Success! 

 

Exit Tera Term and reboot the i-Station panel to leave maintenance / update 

mode. Press 9 on the PC keyboard and then Enter. 

 

The i-Station panel begins its reset process. 

 
Note: 

When the reset process is underway, the display modules briefly display the 

updated firmware version. If the i-Station is re-connected to an Eclipse HX matrix 
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with a valid configuration press keypad button 9 to access the updated 

firmware/rack code version.  

 

 

 

 

Figure 14-10: Example version display 

Note:  

If the manual upgrade fails repeat the above procedure. It can be necessary to attempt 

the manual process up to 3-5 times before the application is installed. 

14.2.2 Upgrading the i-Station panel firmware using EHX 

 

Caution: Central upgrade from EHX is not support on all I-

Stations, when upgrading I-Stations with the serial number 

45PC0001 or above you must contact your Clear-Com sales 

representative first. 

Caution: When a firmware upgrade to an i-Station has started, 

wait for it to complete on all panels before doing any other changes 

to the matrix.  

1) Download the i-Station firmware upgrade to the Eclipse / Eclipse HX matrix from 

ECS / EHX. 

2) Provided that the Panel Prompt option is set, the i-Station panel displays the 

following message: 

UPGRD TO VER nnnnn YES NO 

 

Each word corresponds to a key on the panel, and  nnnnn represents the firmware 

upgrade number.  

Note: The i-Station panel keys flash, indicating that an upgrade is 

available. 
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Note: The prompt is displayed provided that the i-Station panel is 

online. 

3) To decline the upgrade, the i-Station user presses the NO key (right-hand 

flashing). The i-Station panel returns to its normal display. If the upgrade is 

declined it will not be offered again until a black reset (reset and clear all 

memory) is performed on the matrix. 

To accept the upgrade, the i-Station user: 

a. Presses the YES key (left-hand flashing). The i-Station panel displays the 

following: 

  ARE YOU SURE nnnnn YES NO. 

 

Each word corresponds to a key on the panel, and  nnnnn represents the 

firmware upgrade number.  

b. If the user selects the NO key, the upgrade is cancelled and will not be 

offered again until a black reset (reset and clear all memory) is performed 

on the matrix. 

If the user selects the YES key, the firmware upgrade is applied to the i-

Station panel. 

14.2.3 Manually upgrading E-Station application code 

The procedure for upgrading the E-station application code is very similar to the 

procedure for upgrading the i-Station panel application code (see 14.2.1 Manually 

upgrading i-Station & E-Station panel application code). 

To manually upgrade the E-Station: 

1. Connect the converter cable to the expansion in RJ-45 port (J1) on the E-station 

undergoing the upgrade.  

If the cable has separate i-Station and E-station CAT5 cables, the E-station 

CAT5 cable lead is used for the connection to J1 on the E-station. Connect the 

other end of the cable to the serial port of the PC running the Tera-Term 

software.  

 
Note: 

The E-Station must not be powered while the cable is connected. 

 

 

 

 

Figure 14-11: E-Station manual upgrade 
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2. Start Tera Term. 

 

Configure Tera Term for the appropriate COM port on the PC, as shown in the 

following figure.  Select the Serial radio button and then the correct COM port 

setting for the PC from the Port drop-down menu. Click OK. 

 

 

Figure 14-12: Tera Term: COM port setting 

3. From the Tera Term main screen select Setup > Serial port….  

 

The serial port setup screen should now be visible. Select the following settings to 

configure Tera Term for updating the E-station: 

 

Field Setting 

Baud 19200 

Data 8 bit 

Parity None 

Stop 1 bit 

Flow Control None 

Table 14-4: Serial port setup screen settings 

Note: 

Do not configure (ignore) the Transmit delay settings. 

 

Click OK. 

 

4. Power up the E-station into maintenance mode by first holding in the recessed 

button found on the rear panel during a simultaneous AC power up. 

 

The reset button must be held in until all front panel keys turn bright red and 

the front panel display modules show the message Display Module Test, Press 

All Buttons 3x.  

If the recessed button cannot easily be accessed, use a bent paper clip or small 

flat blade screwdriver to press the button in. 

The following Tera Term boot up message is displayed.  
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Figure 14-13: Module display message 

Note: 

Do not proceed until you see the boot up message. If you do not see the boot up 

message, check your wiring connections and software settings. Repeat steps 1 – 

6.  

 

 

 

 

 

 

 

 

 

 

 

Figure 14-14: Tera Term boot up message 

5. Before loading the new application code (*.s19 format file), you must erase the 

Flash ROM on the E-station. 

 

Press in the 2 key on the PC keyboard and press Enter, a message is displayed 

indicating Flash Erasing – Please wait.  

 

After the Flash ROM is erased, a message is displayed asking you to Download 

S-record file now. 
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Figure 14-15: Erasing Flash ROM 

6. In File, select the Send File. This prompts the user to browse for the correct E-

Station *.s19 file for download to the unit undergoing the firmware upgrade: 

 

Drivers USB > ECLIPSE DRIVERS > Panel Software > E-Station > xxxxxx-E-Station App 
 
Where xxxxxx represents the product number. 
 

7. When you have selected the E-Station *.s19 file, select Open to start the s19 file 

download process to the E-station Flash ROM.  

 
Note: 

The download process take several minutes to complete. 

 

8.  When the download process is complete Tera-Term will display the message on 

the PC Download Success! 

 

Exit Tera Term and reboot the E-station out of maintenance / update mode. 

 

Press 9 on the PC keyboard and then Enter. The E-station begins its reset 

process. 

 
Note: 

When the reset process is underway, the display modules briefly display the 

updated firmware version. If the E-station is re-connected to an Eclipse matrix 

with a valid configuration press keypad button 9 to access the updated 

firmware/rack code version.  
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Figure 14-16: Example version display 

 
Tip: For help with selecting the other procedures you require for upgrading to EHX 

V5.2.5, see the quick reference procedures tables in 2  Selecting Upgrade 

Procedures. 

14.3 Manually upgrading V-Series panels 
 

Before attempting to upgrade V-Series panels, ensure that anti-static precautions are 

taken, as the Eclipse HX items are sensitive to static discharges. 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 

V-Series panels can be manually upgraded using a PC directly connected to the panel. 

Before manually upgrading a V-Series Panel, ensure you have the following equipment: 

• An Ethernet crossover cable. 

  

• A PC with an installed and running TFTP server (there is a TFTP server 

application on the EHX USB), or any TFTP server as long as it points to the 

C:\TFTP folder. 

 

 

Figure 14-17: PC LAN port connected directly to V-Series Panel Ethernet port 
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The following components of the V-Series panel can be upgraded either by EHX or 

directly  

Component Description Upgrade path 

U-Boot This is the very first software which runs when 

the panel starts. It initializes hardware and 

then starts the kernel running. 

Direct only 

Kernel The micro-Linux kernel binary. Direct only 

Kernel Root File 

system 

The file system containing all the files used 

and required by the kernel (servers, utilities, 

etc). 

Direct only 

Application Files The Clear-com software which actually runs in 

the panel and is used by the system to 

operate the panel. 

Direct or EHX 

Display module Boot 

loader 

Each bank of six displays forms a single 

module. This module is a discrete hardware 

component and like the panel itself, has its 

software, which runs when the module is 

started, which in turn initializes the module 

and starts the display module application. 

EHX only 

 

Display Module 

Application 

The software which actually operates the 

module, which the panel communicates with 

to get the displays to perform. 

EHX only 

 

Table 14-5: Upgradeable V-Series components  

Direct manual upgrades are described in this section.  

Note: 

EHX upgrades operate in the same way as all EHX based panel upgrades See 14.1 

Upgrading panels using EHX. 

To manually upgrade a V-Series panel: 

1. Unpack and install the TFTPUtil application.  

 

Tip:  For more information about installing the TFTPUtil application on either 32 

bit or 64 bit computers, see Appendix F:TFTPUtil. 

 

2. When the TFTPUtil GUI program has been installed, you can find the program at  

Start > Programs> TFTPUtil > TFTPUtil GUI. 

 

Run TFTPUtil. 
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3. Open My Computer and navigate to your C: drive. Create a new directory called 

C:\TFTP.  

4. In the C:\TFTP directory: 

 

a.  Create another directory called Release. 

 

b. Copy the following file from the Drivers USB to the C:\TFTP\Release 

directory: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series 

> Main_Board > xxxxxx- Panel UBOOT TFTP Image > u-boot.ldr 

 

Where xxxxxx represents a product number. 

 

c. Copy the following files from the software USB to the C:\TFTP\Release 

directory: 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series 

> Main_Board > xxxxxx- Root File System > rootfs.cramfs  

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series 

> Main_Board > xxxxxx- Panel Kernel > vmImage 

 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series 

> Main_Board > xxxxxx -  Panel Application > sbin.jffs2 

 

Where xxxxxx represents a product number. 

 

The C:\TFTP > Release directory appears similar to the following: 

 

 

Figure 14-18: C:\TFTP > Release directory 

5. From the Start menu of your PC: 

 

a. Select Settings > Network and Dial-up Connections.  
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b. Double click Local Area Connection and click Properties. 

 

c. In the This connection uses the following items box, select Internet 

Protocol (TCP/IP) and select Properties. 

 

Tip: Make a note of all information in this window in case of later problems 

with networking. 

 

d. Select the Use the following IP address radio button and enter 

172.16.5.50 into the IP address line. Set the Subnet mask to 

255.255.0.0. 

 
Note:  

It is advisable to switch off any wireless Wi-Fi connections that maybe 

running on your PC when doing this upgrade. 

 

6. Start the TFTP server application. 

 

7. Click the options icon (spanner) to display the options window. Check that the 

C:\TFTP\ folder is set as the path.  

 

Figure 14-19: TFTPUtil Options 

 

8. Select the icon with two blue cogs on the left hand side of the window. Check the 

settings as below. 
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Figure 14-20: TFTPUtil settings 

9. If a firewall is running it may request permission for the program to have access 

when the TFTP server is run for the first time.  Click Yes. Click OK and OK again. 

 

10.  Check that your PC IP address is correctly displayed on the main header of the 

TFTP application:  

 

 
Figure 14-21: Checking the PC IP address 

11. Connect an Ethernet cross-over cable from the PC to the Ethernet port at the 

back of the V-series panel and disconnect the cable that connects to the matrix. 

 

Your PC is now ready to act as a file server to a V-series panel and the panel is 

now ready to be told which files to upload. 

 

12. To upgrade the V-Series U-Boot Loader: 

 

a. Press and hold down both the MAIN and AUX knobs on the V-Series Panel 

while applying a reset.  

 

The reset may be applied by either power cycling the panel or poking a 

paper clip into the reset hole between the H/S and MENU buttons. 
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b. The 4 function button LEDs (Mic On, H/S, Shift and Menu) will flash. 

Press and release the H/S button then press and release the Shift button 

to trigger the U-Boot code upload. 

 
Note: 

As the upload proceeds, the AUX and MAIN lights on the panel will 

gradually change from green to amber and then red. This process may 

take a few minutes. 

 

c. When the upload is complete, the panel will reset itself, completing the 

procedure.  After the panel has reset the display will either go blank or 

display the versions. 

 

13. To upgrade the V-Series Kernel, Root File System and Application files: 

 

a. Press and hold down both the AUX and MAIN knobs whilst applying a 

reset. 

 

The reset may be applied by either power cycling the panel or poking a 

paper clip into the reset hole between the H/S and MENU buttons. 

b. The 4 function button LEDs (Mic On, H/S, Shift and Menu) will flash. 

Press and release the Shift button to trigger the Kernel, Root File 

System and Application files upload. 

 
Note: 

As the upload proceeds, the AUX and MAIN lights on the panel will 

gradually change from green to amber and then red. This process may 

take a few minutes. 

 

c. When the upload is complete, the panel will reset itself, completing the 

procedure.  

 

Wait until the panel completely resets itself and displays the offline status 

screen before powering down the panel (example shown below). 
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Figure 14-22: Panel after update reset 

Notes:  

After the V-Series panel has been upgraded using the TFTP server some of the 

level settings may be disabled. IP settings will also be lost. To restore the level 

and IP settings, download a map from EHX using the Clear Matrix Data option. 

 

14.3.1 Upgrading the V-Series Display Module 

The only upgradeable component in a V-Series expansion panel is the Display Module. 

When the parent V-series panel has its Display Module updated, the updates are 

automatically propagated to the expansion panels. 

However, this only occurs if the expansion panel is plugged in at the time the parent 

panel is upgraded. Expansion panels connected afterwards are not upgraded. 

The Display Module upgrade is only performed using EHX. The required files (*.fwp 

format) are available from the Drivers USB: 

 
• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > Display_Module > 

xxxxxx-Display PIC Boot Loader 
 

• Drivers USB > ECLIPSE DRIVERS > Panel_Software > V-Series > Display_Module > 
xxxxxx-Display PIC Application Code 

 

Where xxxxxx represents a product number. 

 

For more information, see 14.1.1 Locating Panel *.fwp files on the software USB. 
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15 Upgrading the TEL-14 module 

This chapter describes how to upgrade the TEL-14 module, including how to: 

 

• Replace the TEL-14 processor. 

 

• Re-fit TEL-14 modules. 

  

• Update TEL-14 firmware. 

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3Quick reference: Upgrading to Eclipse HX. 

15.1 Upgrading the TEL-14 hardware 

To upgrade the TEL-14 hardware, you require the following equipment: 

 

• The old Tel-14 card 

 

• The replacement TEL-14 processor module. 

 

• Flash Magic Software. Third party software is available from either of the 

Eclipse HX 9.0 upgrade media: 

 

Software USB > SOFTWARE - EHX.xxx > 3rd_Party_Software > 

FlashMagic 

 

Drivers USB > ECLIPSE DRIVERS > 3rd_Party_Software > 

FlashMagic 

 

Tip: For more information about installing Flash Magic, see 

 Appendix H: Flash Magic. 

 

• TEL-14 application software. The TEL-14 application software (*.HEX 

format file) is available from the software USB:  

 

Drivers USB > ECLIPSE DRIVERS > Other_Software >xxxxxx-TEL-

14 Application 

 

Where xxxxxx represents the product number. 

 

To upgrade the TEL-14 hardware: 

 

1. Remove the four screws securing the front panel and remove the front panel. 

 

2. Remove the three screws securing the PCB without the backplane connector and 

open the two cards up. It is not necessary to disconnect the two cards. 
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3. Remove the original processor (IC20) from its socket. 

 

 

Figure 15-1: original IC20 in position 

4. Replace the old processor with the new processor module, ensuring that it is 

correctly positioned. 

 

Tip: The blue serial connector should be farthest away from the front panel. 

 

Figure 15-2: replacement processor module in position 
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15.2 Upgrading the TEL-14 firmware 

To upgrade the TEL-14 firmware: 

1. Ensure that you have the following equipment: 

Required equipment Description / comments 

MVX-A16 serial upgrade 

cable (Clear-Com part 

CAB-MVX-48Z) 

See: 

Figure 28: MVX-A16 Serial upgrade cable. 

 

Flash Magic 
Third party software is available from either of the 

Eclipse HX 9.0 upgrade media: 

• Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > FlashMagic 

 

• Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > FlashMagic 

 

Tip: For more information about installing Flash 

Magic, see Appendix H: Flash Magic. 

*.HEX file to upload 
TEL-14 application software. The TEL-14 

application software (*.HEX format file) is 

available from the software USB: 

• Drivers USB > ECLIPSE DRIVERS > 

Other_Software >xxxxxx-TEL-14 

Application 

 

Where xxxxxx represents the product number. 

 

Table 15-1: Required equipment 

2. Connect the PC to the Serial Programming port of the TEL-14 processor card, as 

shown in the following figure. 

 

Figure 15-3: Processor module with serial cable attached 
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Note:  

For correct connector orientation, the wires must exit the plug on the top side as 

shown. 

3. Power up the TEL-14. 

 

4. Start Flash Magic. Configure the following settings for the 5 purple numbered 

boxes in the Flash Magic dialog: 

 

Box Setting(s) to enter 

1 The COM port to which you are connected. 

Baud Rate: 2400 

Device: 89LPC935 

Oscillator Frequency:  3.5795 MHz 

2 Select Erase blocks used by Hex File 

3 Enter the name of the file (710756Z .hex) to be loaded, or 

use Browse to locate the file. 

4 Ensure all boxes are clear 

 

5 Do not press Start. 

Table 15-2: FlashMagic settings 

 

 

Figure 15-4: FlashMagic configuration dialog 

5. In the menu options along the top of the Flash Magic dialog, select ISP (second 

option from the left). 
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From the drop-down menu, select Start Bootloader. 

  

 

Figure 15-5: Start Bootloader dialog 

6. Ensure that Send Break Condition is checked, then press Start Bootloader.  

 

7. The configuration dialog is re-displayed after a few seconds. In box 5, press 

Start. 

 

Note: 

The status bar along the bottom displays Programming device, and the 

progress bar displays the state of the operation. 

 

After about 20 seconds, Finished is displayed in the status bar. The device has 

now been reprogrammed. Power cycle the TEL-14 to activate the new firmware. 
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16 Upgrading the AES-6 module 

This chapter describes how to upgrade the application code of the AES-6 interface 

module. 

Before attempting any upgrade of the AES-6 card, ensure that anti static precautions are 

taken, as the Eclipse HX devices are sensitive to static discharges. 

 

 

Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 
Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 3Quick 

reference: Upgrading to Eclipse HX. 

To upgrade the AES-6 application code: 

1. Ensure you have the following equipment: 

Required equipment Description / comments 

PC with a serial port  A USB-to-serial adapter is usually acceptable. 

CellCom / FreeSpeak 

/ FreeSpeak II 

(FSBP) registration 

cable 

PD4007Z, DB-9 to 3.5mm jack. 

The appropriate AES-

6 application code file  

(*.mot file) 

The AES-6 application code (*.mot format file) is 

available from the software USB: 

Drivers USB > ECLIPSE DRIVERS > 

Other_Software > xxxxxx - AES-6 Application  

(where xxxxxx represents the product number) 

Hitachi Renesas Flash 

Development Toolkit 

(FDT) 

 

Third party software is available from either of the 

Eclipse HX 9.0 upgrade media: 

 

• Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Hitachi_FDT 

 

• Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Hitachi_FDT 

 

Tip: For more information about installing the Hitachi 

Renesas FDT, see Appendix E:Hitachi Renesas 

Flash Development Tool. 

 
Table 16-1: Required equipment 
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2. Fit the AES-6 card to either the IMF-3 interface frame or Eclipse HX-Median Matrix. If 

there is a jumper on J6, move the jumper to J3.Reset or power-cycle the card so 

the jumper change takes effect. 

 

3. Connect the serial cable to the front of the AES-6.  

 

4. Run Flash Development Toolkit BASIC (FDT). Configure the FDT (Options > New 

Settings) as follows: 

 

FDT field Setting 

Select Device H8S/2318F 

Select Port COM1 (change to match COM port present on the PC) 

CPU Frequency 25.0000 MHz 

Connection BOOT mode 

Recommended Speed Deselect Use Default and set to 9600 

Protection Automatic 

Messaging Advanced 

User data Selected (Checked) 

Table 16-2: FDT settings  

5. Navigate to the AES-6 application code (*.mot format file) on the software USB: 

 

Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 

Application 

 

Where xxxxxx represents the product number). 

 

6. Select Program Flash and download the AES-6 application code (*.mot format 

file).  

 

7. When the download is complete, move the jumper on J3 back to J6. Reset or 

power-cycle the card.  

Note: 

If an FPGA image is present, the card will now run normally. If an FPGA image is 

not present, you will be prompted for an FPGA image. See 3.33.1 Upgrading 

AES-6 FPGA. 

16.1 Upgrading AES-6 FPGA 

Before attempting any upgrade of the AES-6 card, ensure that anti static precautions are 

taken, as the Eclipse items are sensitive to static discharges. 
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Observe all electrical shock hazard warning and precautions for 

handling electrostatic sensitive devices  

 

 

 
Tip: For help with selecting the other procedures you require for upgrading to EHX 

V5.2.5, see the quick reference procedures tables in 2  Selecting Upgrade 

Procedures. 

To upgrade the AES-6 FPGA: 

1. Ensure you have the following equipment: 

 

Required equipment Description / comments 

PC with a serial port  A USB-to-serial adapter is usually acceptable. 

 

CellCom / FreeSpeak / 

FreeSpeak II (FSBP) 

registration cable 

 

PD4007Z, DB-9 to 3.5mm jack. 

The appropriate AES-6 

FPGA code file 

The AES-6 FPGA code is available from the Drivers 

USB: 

Drivers USB > ECLIPSE DRIVERS > 

Other_Software > xxxxxx - AES-6 FPGA  

(where xxxxxx represents the product number) 

 

Tera Term terminal 

software 

Third party software is available from either of 

the Eclipse HX 9.0 upgrade media: 

Software USB > SOFTWARE - EHX.xxx > 

3rd_Party_Software > Teraterm 

 

Drivers USB > ECLIPSE DRIVERS > 

3rd_Party_Software > Teraterm 

 

Tip: For more information about installing Tera 

Term, see Appendix G: Tera Term  

 
Table 16-3: Required equipment 

 
2. Fit the AES-6 card to a parent unit. 

 

3. Run TeraTerm. Configure the serial settings to the following: 
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Serial setting Setting 

Baud rate 57600 

Parity None 

Data Bits 8 

Stop Bits 1 

Flow Control None 

Table 16-4: Tera Term serial settings 

4. Reset or power-cycle the module.  

 

5. At this point, the procedure varies depending on whether or not an FPGA image is 

already present.  

 

If there is an FPGA image present: 

 

a. After the reset, the following output will be shown in the TeraTerm 

window: 

 

 

Figure 16-1: AES-6 FPGA upgrade using Tera Term 
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Type testmode into the Tera Term window and press Enter (return). The 

card enters test mode and displays the following menu: 

 

Figure 16-2: AES-6 main menu 

b. Select option 6, Download FPGA Image. 

 

c. You are prompted to delete the old FPGA image. Press Y. 
Note:  

Key entry is case sensitive, so Y must be a capital. 

The card deletes the old image and then prompts you for a new FPGA 

image: 

d. In Tera Term, select Send File and select the FPGA image, which is 

located on the Drivers USB: 

 

• Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 
FPGA  

(where xxxxxx represents the product number). 

 

Note: 

During the download the six yellow LEDs illuminate in a circulating anti-

clockwise direction. 

 

e. When the download is complete, the six yellow LEDs should be off and the 

following text should be displayed in TeraTerm: 
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Figure 16-3: FPGA HEX file load 

f. Reset the card to complete the upgrade. 

If the FPGA image is not present: 

a. After the reset, the following output will be shown in the TeraTerm 

window: 

 

Figure 16-4: AES-6 FPGA HEX file load 

The card is ready to load the FPGA image. In Tera Term, select Send File 

and select the FPGA image, which is located on the Drivers USB:  

 

• Drivers USB > ECLIPSE DRIVERS > Other_Software > xxxxxx - AES-6 
FPGA  

(where xxxxxx represents the product number). 

 

b. During the download the six yellow LEDs illuminate in a circulating anti-

clockwise direction. When the download is complete, the following text 

should be displayed in TeraTerm: 
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Figure 16-5: FPGA upgrade completed 

c. Reset the card to complete the upgrade. 
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17 Upgrading FreeSpeak II™ wireless systems 

This chapter describes how to upgrade FreeSpeak II beltpacks and antennas supported 

by Eclipse HX. 

 

Supported FreeSpeak II beltpacks and antennas may be upgraded using an installed and 

configured copy of EHX and an active Eclipse HX matrix, or via a USB connection from 

within EHX.  

Note: 

This guide is laid out in the order in which you must upgrade your Eclipse HX software 

and hardware devices. For a quick reference to upgrading your system, see 

 3 Quick reference: Upgrading to Eclipse HX. 

17.1 Upgrading FreeSpeak II Beltpacks and Antennas 

centrally using EHX 

FreeSpeak II beltpacks and antennas can be upgraded centrally via EHX in a similar 

fashion to upgrading panel software. This allows multiple beltpacks or antennas to be 

upgraded simultaneously. 

The download of a FreeSpeak II application requires an *.fww format file, which is 

located on the drivers USB. This must be placed in a location that is accessible by the 

installed EHX application. 

Note:  

The Eclipse HX v9.1 contains all the firmware files required for upgrading a FreeSpeak II 

beltpack or antenna.  

 

The download of a beltpack application requires: 

• An operational Eclipse HX matrix with the beltpacks registered, connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet 
connection is used). 
 

Once the beltpack *.fww format file is downloaded to the Eclipse HX matrix, all 

beltpacks of the same type will be upgraded at the same time through an automatic 

download from the matrix to the beltpack. The beltpack *.fww file will be stored so that 

if any beltpack subsequently connects to the matrix, an upgrade can still be performed. 

The download of an antenna application requires: 

• An operational Eclipse HX matrix with the antennas configured, connected and powered. 
 

• A suitable EHX configuration (with the correct IP address configured, if an Ethernet 
connection is used). 
 

Once the antenna *.fww format file is downloaded to the Eclipse HX matrix, all 

antennas of the same type will be upgraded at the same time through an automatic 

download from the matrix to the antenna.  



 

 

Eclipse | Upgrade Guide 

Page 197 

   

 

 

 

 

 

To upgrade FreeSpeak II beltpack or antenna application code using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an Ethernet or 

serial communications 

port 

- 

EHX software EHX must be installed and configured. 

EHX configuration file / 

map 

- 

Ethernet or serial cable 

for the PC-to-matrix 

connection 

- 

Appropriate *.fww format 

application 

The appropriate *.fww format beltpack and 

antenna code is available from the software 

USB 

Table 45: Required equipment 

2. Start EHX on the PC. 

 

3. Connect the PC to the matrix using either Ethernet or serial communications port. 

 

4. Open the EHX configuration map within EHX. 

 

5. Select System > Layout. 

 

6. Right click the matrix and then select Firmware> Update Firmware.  

 

7. The update firmware wizard dialogue is displayed. Click Next and ensure that the 

Wireless radio button is selected. The Wireless radio button will only be available 

if you have an E-Que FSII-TA Antenna or E-Que FSII-TA Splitter card configured 

in your matrix configuration. 
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In Options: 

• Selecting Automatic mode forces beltpacks or antennas to upgrade 

automatically. 

 

• Selecting Prompted mode means that each beltpack user will be asked 

to accept / decline the beltpack upgrade. If you select this option when 

upgrading an antenna, the matrix will function as in Automatic mode. 

 

8. Click Next and then browse to the appropriate *.fww file. 

 

9. Click Next and confirm that the details displayed are correct. 

 

10. Click Next and confirm that the download commences. 

 

11. When the download has completed, click Finish to close the update firmware 

wizard. 

 

12. The matrix will transmit the *.fww file to the antennas – this process takes 

approximately 9-10 minutes. The progress of transmitting the *.fww file to the 

antennas can be tracked using the Event Log from EHX. 

 

13. Once the file has been transmitted, if the *.fww file contains antenna code, the 

antennas will update themselves and restart. 

 

14. If the *.fww file contains beltpack code, the file will be transmitted to the 

beltpacks, which will indicate their progress. Upon completion of the upgrade, the 

beltpacks will restart. 

 

15. Confirm the updated firmware version using either: 

 

• The  EHX firmware report tool: 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 

- Select Firmware > Firmware report. 

 

• The local menu on the beltpack. 

17.2 Upgrading FreeSpeak II Beltpacks and Antennas 

via USB 

FreeSpeak II beltpacks and antennas can be upgraded via a micro USB cable connected 

directly to the device. This allows direct upgrading of a single device without the need to 

be connected to an active matrix. 
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The download of a FreeSpeak II application requires an *.fww format file, which is 

located on the software USB. This must be placed in a location that is accessible by the 

installed EHX application. 

Note:  

The Eclipse HX v9.1 contains all the firmware files required for upgrading a FreeSpeak II 

beltpack or antenna.  

 

The download of a beltpack application requires: 

• A powered beltpack connected to a PC via a USB connection 
 

• A copy of EHX installed with the appropriate USB drivers (part of a standard EHX installation) 
 

 

To upgrade FreeSpeak II beltpack or antenna application code via USB using EHX: 

1. Ensure that you have the following equipment: 

 

Required equipment Description / comments 

PC with an USB port - 

EHX software EHX must be installed and configured. 

USB to Micro USB cable - 

Appropriate *.fww format 

application 

The appropriate *.fww format beltpack and 

antenna code is available from the software 

USB 

       Table 46: Required equipment 

 

2. Start EHX on the PC. 

 

3. Connect the FreeSpeak II beltpack or antenna to the PC using either a micro USB 

cable. 

 

4. Select Tools->Apply Wireless Firmware Via USB from the EHX menu. 

 

5. The Update Wireless Firmware Via USB Dialog will now appear. 

 

6. Click Browse and then browse to the appropriate *.fww file. 

 

7. Click Update Firmware to begin the update process. 

 

8. A bar will indicate the progress of the upgrade process. It may take 10-20 

seconds to initially connect to the device and begin the upgrade. 

 

9. When the upgrade has completed, EHX will display a message box indicating 

whether the upgrade has been successful. The beltpack or antenna device should 

restart itself. 
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10. Confirm the updated firmware version using either: 

 

• The local menu on the beltpack. 

• The  EHX firmware report tool: 

 

- Connect the device to the matrix and allow it to connect. 

 

- Go to EHX > System > layout. 

 

- Right click the matrix icon. 

 

- Select Firmware > Firmware report. 

 

 



 

 

Eclipse | Upgrade Guide 

Page 201 

   

 

 

 

 

Appendix A: CPU card layout 

 

 

Figure 17-1: Eclipse HX-Median / Eclipse HX-Omega / 

Eclipse HX-Delta CPU card layout 
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Appendix B: CPU card DIP switches 

 

 

 

Test mode settings for CPU card DIP switches 

 

 

Serial download settings for CPU card DIP switches 
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Normal running (watchdog enabled) settings for CPU card DIP switches 
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Appendix C: PiCo card layout 
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Appendix D: Eclipse HX-PiCo CPU DIP 

switches 

 

 

 

 

 

 

 

 

 

Figure 17-2: Test mode settings for Eclipse HX-PiCo DIP switches 

 

 

 

Figure 17-3: Serial download settings for Eclipse HX-PiCo DIP switches 
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Figure 17-4: Normal running (watchdog enabled) settings for Eclipse HX-PiCo DIP 

switches 
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Appendix E: Hitachi Renesas Flash 

Development Tool 

To install and configure the Hitachi Renesas Flash Development Tool (FDT): 

1.  Navigate to the installation file on the Eclipse installation USB: 

 

USB\3rd_Party_Software\Hitachi_FDT\fdt3_04.exe 

Double click to install. 

 

Note:  

Later versions can be downloaded from 
http://www.renesas.com/products/tools/flash_prom_programming/fdt/download_search_results.jsp# 

 

 

2. When the installation file is run, the installer displays a series of setup screens to 

configure the installation. 

 

 

Figure 17-5: Initial install screen 

Click Next. 

3. Select the required language (International English, Asia (Japanese), Asia 

(English)).  

 

http://www.renesas.com/products/tools/flash_prom_programming/fdt/download_search_results.jsp
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Figure 17-6: Language selection 

Click Next. 

4. Click Yes to accept the license conditions. The installer then displays the Select 

Components screen: 

 

 

Figure 17-7: Select Components 
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Note: 

It may be advisable to uncheck the Microsoft System Files checkbox as the 

versions of system files in the installation may be older than those currently on 

the system. If these files are required then the software can be uninstalled and 

then reinstalled with the system files.   

 

Click Next. 

5. The Additional Information (Application) screen is displayed. Leave the default 

options selected unless this causes an issue for other installed software. 

 

 

Figure 17-8: Additional Information (Application) 

Click Next. 

 

6. The Kernels screen (Part 1) is displayed. Leave as is, unless you want to reduce 

the amount of disk space used by reducing the number of kernels installed. 
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Figure 17-9: Kernels 1 

Click Next. 

 

7. The Kernels screen (Part 2) is displayed. Leave as is, unless you want to reduce 

the amount of disk space used by reducing the number of kernels installed. 

 

 

Figure 17-10: Kernels 2 

Click Next. 
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8. The Select Destination Directory screen is displayed. The default installation 

directory is usually recommended. 

 

Figure 17-11: Select Destination 

Click Next. 

9. The Select Start Menu Group screen is displayed. The default menu can be used 

or the programmer can be added to the Clear-Com menu.  

 

 

Figure 17-12: Select Start Menu Group 
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Click Next. 

10. The Ready to Install screen is displayed. Click Install. The files will be installed 

in the selected directory.  

 

Figure 17-13: Ready to install 

 

11.  When the installation is complete a completion screen is displayed: 

 

 

Figure 17-14: Installation completed 

To exit the installer, click Finish.
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Appendix F: TFTPUtil 

To install the TFTPUtil tool: 

1.  Navigate to the installation file on the Eclipse installation USB. 

 

USB\3rd_Party_Software\V-Panel TFTO Server 

App\TFTPUtil_GUI_Version_1.3.0_Installer.exe 

 

2. When the installation file is run, the installer will display a series of setup screens 

to configure the installation. The first screen is the License Agreement. Click I 

Agree. 

 

 

Figure 17-15: License Agreement 

 

3. The TFTPUtil Components screen is displayed. Accept the defaults and click 

Next. 
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Figure 17-16: Components 

4. The Installation Folder destination screen is displayed. Accept the default 

destination folder unless it clashes with other system setups.  Click Install. 

 

 

Figure 17-17: Installation Folder destination screen 

5. When the installation is completed, click Close to exit the installer. If the defaults 

were accepted the TFTPUtil server can be run from Programs under TFTPUtil. 

TFTPUtil on Vista and Windows 7 PCs 

 

The TFTP Util TFTP server has been known to fail on Vista or Windows 7 PCs. In this 

case, you use any TFTP server that is known to work on your PC.  
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The TFTP servers below are known to operate on Vista or Windows 7 PCs. Install the 

server and point the server to the C:\TFTP folder as described above. 

Win Agents TFTP server  

The server is available from either of the Eclipse HX v9.1 upgrade media: 

Software USB \3rd_Party_Software > V-Panel TFTP Server App > tftpserver-

setup.exe 

Drivers USB \3rd_Party_Software > V-Panel TFTP Server App > tftpserver-

setup.exe  

Alternatively, it can be downloaded from http://tftp-server.com. 

SolarWinds TFTP server  

http://www.solarwinds.com/products/freetools/free_tftp_server.aspx 

tftp32 server 

http://tftpd32.jounin.net/tftpd32_download.html 
  

 
Note:  

Select the 32 or 64 bit installer. 
 

http://tftp-server.com/
http://www.solarwinds.com/products/freetools/free_tftp_server.aspx
http://tftpd32.jounin.net/tftpd32_download.html
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Appendix G: Tera Term 

To install Tera Term: 

1.  Navigate to the installation file on the Eclipse installation USB: 

 

USB\3rd_Party_Software\Teraterm\tterm23.zip 

 

2. Open the file with WinZip and execute Setup.exe to start the Tera Term 

installation. The language options screen will be displayed. 

 

 

Figure 17-18: Language selection 

Select the required language mode and click Continue.  

 

3. You are asked to close any old versions of Tera Term that are running. Close any 

old versions and click Continue. 

 

4. The Destination Path screen is displayed. Enter the required installation 

directory name if it is different to the default.  It is recommended that the default 

is used. Click Continue. 

 

 

Figure 17-19: Destination Path 
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The Installation complete screen is displayed. To exit the installer, click OK. 

 

 

Figure 17-20: Installation complete 

 

TIP: The Tera Term application is used for many of the Eclipse system upgrade 

processes. You can save and recall the relevant com port settings by selecting the 

Setup / Save or restore settings options.
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Appendix H: Flash Magic 

To install Flash Magic: 

1.  Navigate to the installation file on the Eclipse installation USB. 

 

USB\3rd_Party_Software\FlashMagic\FlashMagic.exe 

 

2. Execute the file to start the installation. The Flash Magic Setup Wizard 

welcome screen is displayed. Click Next. 

 

 

Figure 17-21: Welcome screen (installer) 

3. The License Agreement screen is displayed. Accept the agreement and click 

Next. 

 

4. The Select Destination Location screen is displayed. Select the destination 

folder for FlashMagic (normally the default is accepted). Click Next. 
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Figure 17-22: Select Destination Location 

 

5. The Select Start Menu Folder is displayed. Select the Start menu folder for 

Flash Magic; (normally the default is accepted). Click Next. 

 

Figure 17-23: Select Start Menu Folder 

 

6. The Select Additional Tasks screen is displayed. Select Create a Desktop icon 

and / or Quick Launch icon, if desired. Click Next. 
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Figure 17-24: Select Additional Tasks 

 

7. The Ready to Install screen is displayed. Click Install.  

 

 

 

Figure 17-25: Ready to Install 

 

8. When the installation is complete, the completion screen is displayed. 
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Figure 17-26 Completion screen 

Click Finish to exit the installer. 
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Appendix I: i-Station converter cable 

wiring and rear panel layouts 

 

 

Figure 17-27: Converter cable wiring example for i-Station serial programming 
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    Figure 17-28: i-Station rear panel layout 

 

 

 

Figure 17-29: E-Station rear panel layout 

 

RESET BUTTON 

RESET BUTTON 
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Appendix J: Xilinx tools 

Xilinx programming tools are used to upgrade FPGA and CLPD code. For more 

information about using this specialized equipment, contact your Clear-Com technical 

support representative.  

The following cards and matrices can be upgraded using Xilinx tools: 

• CPU card (CPLD). 
 

• MVX-A16 (FPGA). 
 

• E-QUE / IVC-32 / LMC-64 (FPGA). 
 

• E-FIB (FPGA). 
 

• E-MADI64 (FPGA). 
 
Note: 

The E-MADI64 FPGA can also be upgraded using EHX. For more information, see 

 11.3 Upgrading the E-MADI64 application, DSP and FPGA code using EHX. 
 

• Eclipse HX-PiCo matrix (FPGA). 

 

To program the Flash PROM, you require a PC or laptop with the Xilinx iMPACT 

programming software and a Xilinx Download Cable (such as platform cable USB 

model DLC9G)) is required.  

The Xilinx programming tool, Xilinx iMPACT, may be obtained by downloading ISE 

WebPACK™ from: http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp 

If you are using: 

• The red DLC10 programming box, download ISE ver 11 or later 

• The black DLC9G programming box, download ISE ver 11 or later. 

 
Note:  

You must create an account at the Xilinx website, and accept a license agreement, 

before you can download ISE WebPACK™.  

Tip: A number of Found new hardware dialogs will display when the programming 

device is plugged into the USB port of the PC or laptop. Clear-Com recommends 

installing the software (which also installs the necessary drivers) before you plug in the 

device, to reduce the number of dialogs.  

 

http://www.xilinx.com/xlnx/xil_sw_updates_home.jsp
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Appendix K: Clear-Com®End User Software 

License 

 

IMPORTANT: CAREFULLY READ THE FOLLOWING BEFORE USING THIS 

SOFTWARE.  USING THE SOFTWARE INDICATES YOUR ACKNOWLEDGMENT 

THAT YOU HAVE READ THE FOLLOWING AND AGREE TO ITS TERMS.   

IF YOU DO NOT AGREE, RETURN THE SOFTWARE COMPLETE TO CLEAR-COM OR 

YOUR CLEAR-COM REPRESENTATIVE AND CANCEL THE INSTALLATION. 

THIS IS YOUR PROOF THAT YOU HAVE A VALID LICENSE.  PLEASE TREAT IT AS 

VALUABLE PROPERTY. 

HME CLEAR-COM LIMITED OR CLEAR-COM LLC., as the case may be (hereinafter 

referred to as “CLEAR-COM”), offers you this storage media containing a 

computer program and files (the “SOFTWARE”) and offers to grant to you a 

non-exclusive  and non-transferable License to use the Software on the 

following terms.  Any new revision or update of the Software provided by 

CLEAR-COM to Customer under this License shall be governed by the terms and 

conditions of this License. 

SOFTWARE LICENSE AGREEMENT 

 

IMPORTANT–THIS IS A LEGAL AGREEMENT BETWEEN YOU AND CLEAR-COM.  BEFORE 

DOWNLOADING, ACCESSING, OR USING ANY PART OF THE SOFTWARE, YOU SHOULD 

READ CAREFULLY THE FOLLOWING TERMS AND CONDITIONS CONTAINED IN THIS 

SOFTWARE LICENSE AGREEMENT ("AGREEMENT") AS THEY GOVERN YOUR ACCESS TO 

AND USE OF THE SOFTWARE. CLEAR-COM IS WILLING TO LICENSE AND ALLOW THE 

USE OF THIS SOFTWARE ONLY ON THE CONDITION THAT YOU ACCEPT AND AGREE TO 

ALL OF THE TERMS AND CONDITIONS CONTAINED IN THIS AGREEMENT.  IF YOU DO 

NOT AGREE WITH THIS AGREEMENT, YOU ARE NOT GRANTED PERMISSION TO ACCESS 

OR OTHERWISE USE THE SOFTWARE. 

 

This Agreement applies to any computer program and related files (the 

“Software”) offered to you by either Clear-Com LLC or HME Clear-Com Ltd. 

(each of whom is referred to herein as “Clear-Com”) and whether the software is 

delivered in the form of a diskette, USB, USB storage device or CD-ROM (the 

“Storage Media”), over the Internet or through an on-line network.  Your use of 

the Software constitutes your acceptance of the following terms and conditions. 
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TERMS AND CONDITIONS 

4) License Grant.  The Software is provided by Clear-Com, and this Agreement 

provides to you a personal, revocable, limited, non-exclusive, royalty-free, non-

transferable license to use the Software conditioned on your continued 

compliance with the terms and conditions of this Agreement.  This Agreement 

permits you to use and access for personal or business purposes the Software 

only at a single physical location in connection with the use of Clear-Com 

products.  You may also load information from the Software into your laptop, 

workstation, or computer temporary memory (RAM) and print and download 

materials and information from the Software solely for your personal or business 

use, provided that all hard copies contain all copyright and other applicable 

notices contained in such materials and information.  If you are using the 

Software on behalf of a company or other form of entity, please note that such a 

company or entity may have a separate agreement with Clear-Com regarding 

access and usage privileges for the Software.  Nevertheless, your use of the 

Software will be subject to the obligations and restrictions regarding use of the 

Software as set forth in this Agreement.   

5) Restrictions.  The license granted under this Agreement is limited.  You may not 

use, copy, store, reproduce, transmit, distribute, display, rent, lease, sell, 

modify, alter, license, sublicense, or commercially exploit any data provided by 

Clear-Com through the Software in any manner not expressly permitted by this 

Agreement.  In addition, you may not modify, translate, decompile, create any 

derivative work(s) of, copy, distribute, disassemble, broadcast, transmit, 

publish, remove or alter any proprietary notices or labels, license, sublicense, 

transfer, sell, mirror, frame, exploit, rent, lease, private label, grant a security 

interest in, or otherwise use the Software in any manner not expressly 

permitted herein. 

6) User Obligations.  By downloading, accessing, or using the Software in order to 

view our information and materials or submit information of any kind, you 

represent that you are at least 18 years of age and will, at all times, provide 

true, accurate, current, and complete information when submitting information 

or materials on the software including, without limitation, when you provide 

information via a software registration or submission form.  In addition, you 

agree to abide by all applicable local, state, national, and international laws and 

regulations with respect to your use of the software.  This Agreement is also 

expressly made subject to any applicable export laws, orders, restrictions, or 

regulations.   

7) Proprietary Rights.  This Agreement provides only a limited license to access and 

use the Software.  Accordingly, you expressly acknowledge and agree that 

Clear-Com transfers no ownership or intellectual property interest or title in and 

to the Software to you or anyone else.  All text, graphics, user interfaces, visual 

interfaces, photographs, sounds, artwork, computer code (including html code), 

programs, software, products, information, and documentation as well as the 

design, structure, selection, coordination, expression, "look and feel," and 

arrangement of any content contained on or available through the Software, 

unless otherwise indicated, are owned, controlled, and licensed by Clear-Com 

and its successors and assigns and are protected by law including, but not 
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limited to, United States copyright, trade secret, patent, and trademark law, as 

well as other state, national, and international laws and regulations.  Except as 

expressly provided herein, Clear-Com does not grant any express or implied 

right to you or any other person under any intellectual or proprietary rights.  

Accordingly, your unauthorized use of the Software may violate intellectual 

property or other proprietary rights laws as well as other laws, regulations, and 

statutes.  The name of the Software, the Clear-Com logo, and all other names, 

logos, and icons identifying Clear-Com and its programs, products, and services 

are proprietary trademarks of Clear-Com, and any use of such marks, including, 

without limitation, as domain names, without the express written permission of 

Clear-Com is strictly prohibited.  Other service and entity names mentioned 

herein may be the trademarks and/or service marks of their respective owners. 

8) Feedback and Submissions.  Clear-Com welcomes your feedback and 

suggestions about Clear-Com’s products or services or the Software. By 

transmitting any suggestions, information, material, or other content 

(collectively, "feedback") to Clear-Com, you represent and warrant that such 

feedback does not infringe or violate the intellectual property or proprietary 

rights of any third party (including, without limitation, patents, copyrights, or 

trademark rights) and that you have all rights necessary to convey to Clear-Com 

and enable Clear-Com to use such feedback.  In addition, any feedback received 

will be deemed to include a royalty-free, perpetual, irrevocable, transferable, 

non-exclusive right and license for Clear-Com to adopt, publish, reproduce, 

disseminate, transmit, distribute, copy, use, create derivative works, and display 

(in whole or in part) worldwide, or act on such feedback without additional 

approval or consideration, in any form, media, or technology now known or later 

developed for the full term of any rights that may exist in such content, and you 

hereby waive any claim to the contrary.  

9) Limited Warranty.   

6.1 Clear-Com warrants that any Storage Media on which the Software 

is stored will be free from defects in materials and workmanship for 90 
days from the date you acquire it.  If a defect in the Storage Media 
occurs, return the Storage Media to Clear-Com and Clear-Com will 

replace it at no cost to you.  This remedy is your exclusive remedy for 
breach of this warranty.  This limited warranty is void if the damage or 

defect has resulted from accident, abuse or misapplication.   

6.2 WHILE CLEAR-COM ENDEAVORS TO PROVIDE RELIABLE 
INFORMATION, SERVICES, PROGRAMS, SOFTWARE, AND MATERIALS, 

EXCEPT AS SPECIFICALLY PROVIDED IN SECTION 6.1, THE SOFTWARE 
IS PROVIDED ON AN "AS-IS" AND "AS AVAILABLE" BASIS AND MAY 

INCLUDE ERRORS, OMISSIONS, OR OTHER INACCURACIES.  YOU 
ASSUME THE SOLE RISK OF MAKING USE OF THE SOFTWARE.  CLEAR-
COM MAKES NO REPRESENTATIONS OR WARRANTIES ABOUT THE 

RESULTS THAT CAN BE ACHIEVED FROM OR THE SUITABILITY, 
COMPLETENESS, TIMELINESS, RELIABILITY, LEGALITY, OR ACCURACY 

OF THE SOFTWARE FOR ANY PURPOSE, AND EXPRESSLY DISCLAIMS ALL 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT 
LIMITATION, ANY WARRANTY OF MERCHANTABILITY, FITNESS FOR A 
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PARTICULAR PURPOSE, OR NON-INFRINGEMENT OR ANY OTHER 
IMPLIED WARRANTY UNDER THE UNIFORM COMPUTER INFORMATION 

TRANSACTIONS ACT AS ENACTED BY ANY STATE.  CLEAR-COM ALSO 
MAKES NO REPRESENTATION OR WARRANTY THAT THE SOFTWARE 

WILL OPERATE ERROR FREE OR IN AN UNINTERRUPTED FASHION OR 
THAT ANY DOWNLOADABLE FILES OR INFORMATION WILL BE FREE OF 
VIRUSES OR CONTAMINATION OR DESTRUCTIVE FEATURES. 

10) Limitation of Liability.  You expressly absolve and release Clear-Com from any 

claim of harm resulting from a cause beyond Clear-Com’s control, including, but 

not limited to, failure of electronic or mechanical equipment or communication 

lines, telephone or other connection problems, computer viruses, unauthorized 

access, theft, operator errors, severe weather, earthquakes, or natural 

disasters, strikes, or other labor problems, wars, or governmental restrictions.  

MOREOVER, IN NO EVENT SHALL CLEAR-COM BE LIABLE FOR ANY INDIRECT, 

PUNITIVE, INCIDENTAL, SPECIAL, EXEMPLARY, MULTIPLE, INDIRECT OR 

CONSEQUENTIAL DAMAGES ARISING OUT OF OR IN ANY WAY CONNECTED 

WITH THE USE OF THE SOFTWARE, WITH ANY DELAY OR INABILITY TO USE 

THE SOFTWARE, OR FOR ANY INFORMATION, SERVICES, PROGRAMS, 

PRODUCTS, AND MATERIALS AVAILABLE THROUGH THE SOFTWARE, WHETHER 

BASED IN CONTRACT, TORT, STRICT LIABILITY, OR OTHERWISE, EVEN IF 

CLEAR-COM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  

BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR 

LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, 

THE ABOVE LIMITATION MAY NOT APPLY.  NOTWITHSTANDING THE 

FOREGOING, TOTAL LIABILITY OF CLEAR-COM FOR ANY REASON WHATSOEVER 

RELATED TO USE OF THE SOFTWARE SHALL NOT EXCEED THE TOTAL AMOUNT 

PAID BY YOU TO CLEAR-COM TO PURCHASE THE SOFTWARE. 

11) Indemnity.  You agree to protect, defend, indemnify, and hold harmless Clear-

Com and its affiliates and all of their respective employees, agents, directors, 

officers, shareholders, attorneys, successors, and assigns from and against any 

and all claims, proceedings, damages, injuries, liabilities, losses, costs, and 

expenses (including reasonable attorneys’ fees and litigation expenses) relating 

to or arising from any breach by you of this Agreement.   

12) Legal Matters.   

9.1 If you are resident or domiciled anywhere other than Europe, the 

Middle East or Africa, this Agreement will be construed and enforced 
solely in accordance with the laws of the State of California, U.S.A., and 

courts in California shall have exclusive subject matter jurisdiction, 
personal jurisdiction, and venue to adjudicate any dispute arising out of 
this Agreement.   

9.2 If you are resident or domiciled in Europe, the Middle East or Africa 
(the “EMEA”), this Agreement will be construed and enforced solely in 

accordance with English law and English Courts shall have exclusive 
subject matter jurisdiction, personal jurisdiction and venue to adjudicate 
any dispute arising out of this Agreement. 
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9.3 You agree to waive any right to a jury trial in connection with any 
action or litigation in any way arising out of or related to this Agreement 

and acknowledge that either party may seek attorney's fees in any 
proceeding.  Any claim you might have against Clear-Com must be 

brought within two (2) years after the cause of action arises, or such 
claim or cause of action will be barred.  You also acknowledge and agree 
that any applicable state law implementation of the Uniform Computer 

Information Transactions Act (including any available remedies or laws) 
shall not apply to this Agreement and is hereby disclaimed.   

9.4 Clear-Com makes no representation that the Software is 
appropriate or available for use in locations outside the State of 
California or the EMEA and access to or use of the Software from states, 

territories, or nations where any aspect of the Software is illegal is 
prohibited.  You access or use the Software on your own volition and are 

responsible for compliance with all applicable local laws with respect to 
your access and use of the Software. 

9.5 A printed version of this Agreement and of any related notice given 

in electronic form shall be admissible in judicial or administrative 
proceedings based upon or relating to this Agreement to the same extent 

and subject to the same conditions as other business documents and 
records originally generated and maintained in printed form. 

9.6 Clear-Com has no obligation to provide free updates to or upgrades 
of the Software or to provide support of any kind with respect to the 
Software. 

 

9.7 If you are acquiring the Software for an agency of the United States 

Government, the provisions of Federal Acquisition Regulations Section 
12.212 or Department of Defense FAR Supplement Section 227.7202-3, 
as applicable, apply to such acquisition. 

13) Term and Termination.  This Agreement and your right to use the Software will 

take effect at the moment you click "I ACCEPT" or you install, access, or use the 

Software and is effective until terminated as set forth below.  This Agreement 

will terminate automatically if you click "I REJECT."  In addition, Clear-Com 

reserves the right at any time and on reasonable grounds, which shall include, 

without limitation, any reasonable belief of fraudulent or unlawful activity or 

actions or omissions that violate any term or condition of this Agreement, to 

deny your access to the Software or to any portion thereof in order to protect its 

name and goodwill, its business, or other authorized users, and this Agreement 

will also terminate automatically if you fail to comply with this Agreement, 

subject to the survival rights of certain provisions identified below.  Termination 

will be effective without notice.  You may also terminate this Agreement at any 

time by ceasing to use the Software, but all applicable provisions of this 

Agreement will survive termination, as identified below.  Upon termination, you 

must destroy all copies of any aspect of the Software in your possession.  In 

addition to the miscellaneous section below, the provisions concerning Clear-

Com’s proprietary rights, feedback, indemnity, disclaimers of warranty, 
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limitation of liability, and governing law will survive the termination of this 

Agreement for any reason. 

14) Miscellaneous.  You acknowledge that any breach, threatened or actual, of this 

Agreement will cause irreparable injury to Clear-Com, such injury would not be 

quantifiable in monetary damages, and Clear-Com would not have an adequate 

remedy at law.  You therefore agree that Clear-Com shall be entitled, in addition 

to other available remedies, to seek and be awarded an injunction or other 

appropriate equitable relief from a court of competent jurisdiction restraining 

any breach, threatened or actual, of your obligations under any provision of this 

Agreement.  Accordingly, you hereby waive any requirement that Clear-Com 

post any bond or other security in the event any injunctive or equitable relief is 

sought by or awarded to Clear-Com to enforce any provision of this Agreement.  

The parties agree that this Agreement is for the benefit of the parties hereto as 

well as Clear-Com's licensors.  Accordingly, this Agreement is personal to you, 

and you may not assign your rights or obligations to any other person or entity 

without Clear-Com's prior written consent.  Failure by Clear-Com to insist on 

strict performance of any of the terms and conditions of this Agreement will not 

operate as a waiver by Clear-Com of that or any subsequent default or failure of 

performance.  If any provision (or part thereof) contained in this Agreement is 

determined to be void, invalid, or otherwise unenforceable by a court of 

competent jurisdiction or on account of a conflict with an applicable government 

regulation, such determination shall not affect the remaining provisions (or parts 

thereof) contained herein and the illegal, invalid, or unenforceable clause shall 

be modified in compliance with applicable law in a manner that most closely 

matches the intent of the original language.  No joint venture, partnership, 

employment, or agency relationship exists between you and Clear-Com as a 

result of this Agreement or your utilization of the Software.  Headings herein are 

for convenience only.  This Agreement represents the entire agreement between 

you and Clear-Com with respect to use of the Software, and it supersedes all 

prior or contemporaneous communications and proposals, whether electronic, 

oral, or written between you and Clear-Com with respect to the Software. 
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