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Dealing with Layouts 

How to create a Layout? 

1. First, if you’re not already in the KEdit environment open it. 

2. From the menu File, select New… The following dialog appears. Select the Display Ratio. If 
the Layout is intended to be used on a Dual Head system specify it in the Configuration 
section. Currently only the horizontally tiled heads are supported so make sure “Horizontal” is 
the option selected. Press OK. 

 

3. It would be a good time to save your Layout. To do so select “Save” from the “File” menu or 
press “Ctrl-S”. Navigate to the folder where you want to save your Layout and enter the name 
of your Layout. It would be good to save your Layout from time to time while creating it. 

4. Next step is to add monitors to the Layout. Display the Monitor Browser (either by pressing 
F6 or by selecting Monitor Browser from the View menu or by clicking on the icon in the 
toolbar). Select, one by one, the monitor names from the list until the Monitor displayed in the 
Preview pane best satisfies your needs. Note that you can modify the monitor you select 
later, so that it exactly meets your needs. 



 

5. Now click on the Monitor in the preview pane and without releasing your mouse button drag 
the Monitor to the desired position on the Layout. If the Monitor is not positioned where you 
want it to be, click on it and without releasing the mouse drag it where you want it to be. 

 

6. You can adjust the size of the Monitor using the squares located at the corners or using the 
white triangles located on the sides.  



7. If the Monitor is not exactly what you need, it is time to configure, add or remove 
Components. To modify a Monitor you have to “unlock” it. To do so: 

Right-click on the Monitor and select unlock, or ALT-click on the Monitor (this also selects the 
clicked component inside the Monitor). When the Monitor’s border turns yellow the 
modifications you will make will be applied inside that Monitor. 

 

• To remove unnecessary Components select them and press the “delete” key. 

• To add Components to the Monitor select the Component’s icon from the Components 
toolbar, click in the Monitor where you want to add the Component and drag your mouse 
to adjust the Component’s size. Use your mouse to size and position the Component. 

• To configure a Component select it, then press F5 or select “Configuration Panel” from the 
“View” menu, or right-click and select Configuration Panel from the pop-up menu to open 
the configuration panel. This panel adapts itself to the selected Component; by clicking 
different Component types you will see the fields associated with the Component’s 
configuration. This allows the configuration of all the graphical Components and behaviors 
as well as source assignment, but don’t make the source assignment yet; it is simpler if 
you do it later in step 10 of this procedure. Concentrate on the configuration of the 
graphical elements such as text fonts, text colors, UMD backgrounds and alarm behaviors 
such as color or icons to display with multiple Alarm conditions, latching and audio scales. 

When you’re done simply click outside of the Monitor so its border turns white again. 

You can save the modified Monitor in the available Monitor list. Doing so will allow you to 
reuse it at a later time. To save the Monitor in the Monitor list make sure its border is white, 



then click on the Monitor, hold the Ctrl key of your keyboard while dragging the Monitor onto 
the list or the Preview pane, and enter a name that will be associated with this Monitor.  

8. To ease the positioning of the Monitors and the Components you can display a grid. To do so 
select “Grid” from the “View” Menu and then select “Show” or press the button F2. The 
number of columns and rows displayed can be modified via the “Grid” dialog that you will 
obtain by selecting “Grid” from the “View” menu and then selecting “Setting…” or by pressing 
the F3 button. To hide the grid press F2 or select “Grid” from the “View” menu and then 
“Hide”. Note that the grid is only displayed while you are editing the Layout in KEdit – it will 
not appear in the Kaleido output display. 

9. To add a Monitor to your Layout, you can select another one from the Monitor Browser list or 
duplicate the one you just created. To duplicate a Monitor, click on it while holding the “Ctrl” 
key, and drag the Monitor to where you want the copy to lie. Alternatively, you can select the 
Monitor and press “Ctrl-D”. Drag the newly created Monitor into position. Repeat these 
operations until you have the number of Monitors you want in your Layout. 

To add other graphical elements (clock, logo, count down timers…) to your Layout, proceed 
as follows: 

• Select the corresponding icon from the Components toolbar and then click on the Layout 
at the start location (left top corner). 

• Hold the click and drag the mouse until the Component has the desired size. 

• Click on the Component and drag it for repositioning. 

You can align the monitors and Components using the alignment and distribution tools found 
in the Draw menu, Align or Distribute section. 

 



10. Now you can start assigning sources to all the Components within a Monitor: First, unlock the 
Monitor by right-clicking on it and selecting Unlock Monitor from the pop-up menu, or by ALT-
clicking on it. Then, click on a Component inside the monitor. It’s bounding box and resizing 
handles will appear to confirm that it is selected. Open the configuration panel by pressing F5 
or selecting “Configuration Panel” from the “View” menu or from the right-click pop-up menu. 
The Configuration Panel is adaptive, meaning that it will change to reflect the selected 
Component, and need not be closed and reopened when you select a new Component. 
Select each Component in turn, and enter the appropriate data in the configuration panel. 
This will always include a definition of the source of data for the Component (e.g. a video 
input number for a video screen) and will often include other data such as Alarms and 
Actions. Press “Apply” when the configuration of a Component is complete, and move on to 
the next Component. To create Alarms and Actions, consult the user manual. 

11. Click outside the monitor to exit it. You will be prompted to save your assignments as a new 
Channel. Select "Yes" and name the Channel in the dialog box that appears. The Monitor 
remains selected, and the configuration panel shows the Monitor’s attributes. It is important to 
save a Channel because it can be used afterward for other Layouts and is also essential for 
most operations through the remote control panel. 

12. Some Channel examples are already available in the Channel list. You can select one of 
them by using the dropdown list located at the top of the Monitor’s configuration panel. This 
Channel’s inputs will now be connected to your Monitor’s Components. To modify the 
configuration of the Components simply select the Component. If you haven’t closed the 
Configuration Panel you should see the values associated with the selected Component. 
Modify them to associate the desired source. If you modified one or more Components, then 
when you “exit” the Monitor by clicking outside of its boundaries, you will be asked if you want 
to save the modifications made to the Channel. It is strongly suggested that you answer 
“Save” or “Save As” if you want to keep the modifications that you made. 

 

13. After all the mapping, configuring and associations are done, your Layout is completed. You 
can save it to file by using “Ctrl-S” button or select “Save” from the “File” menu.  



14. Now you are ready to apply this Layout online to the Kaleido-K2: Select “Apply Layout online” 
from the “File” menu or press “Alt-A”. This brings up the following dialog.  

 

Select the Kaleido-K2 to which this Layout will be applied, and select what parameters will be 
exported from KEdit (Channels, images, audio meters scales or Alarms). 

15. Once displayed on the Kaleido-K2 you can connect online with the Kaleido-K2 and make final 
corrections. Select “Open” and then “Online” from the “File” menu or press “Ctrl-O” and select 
the Kaleido-K2 from the list. Note: From this point, you are connected to the Kaleido-K2 and 
you are remotely controlling it. You will be using the Channels, Alarms and Components that 
are resident in the Kaleido-K2, not on your KEdit client.  

16. You can assign the Layout to a preset key of the Kaleido RCP by pressing and holding for at 
least 6 seconds one of the 10 function keys located at the top of the device. 

 

How to configure the Kaleido-K2 and the KEdit to di splay other 
languages like Chinese, Japanese or Arabic? 

First you need to get a font that supports those languages. Typically a Unicode font like “Arial 
Unicode MS” is suitable. Those fonts are usually accessible through the web. 

• Copy the font to the “C:\WINNT\Fonts\” folder of the computer where KEdit is run. 



• Copy the same font to the “C:\WINNT\Fonts” folder of the Kaleido-K2. 

• Restart your Kaleido so that the software will recognize the new font. 

• Start KEdit and open the Layout where you want to use this font. 

• Select the UMD or Text Component that will display the extended characters and select 
the Unicode font you just copied from the drop-down located on the toolbar of your KEdit. 

• Enter your text in the Configuration panel. 

• Apply and save your modifications. 

• Apply your Layout online on the Kaleido-K2 where you copied the font. 

• You should get your text displaying the characters. 

How to save my preferred Monitor in the Monitor Lis t? 

Once you modified a Monitor so it suits your needs you can save it in your Monitor List. Saving 
the Monitor in your Monitor List will allow you to use this Monitor later on in the current Layout or 
in other Layouts. 

• Within KEdit, load the Layout containing the Monitor you want to save in the Monitor List.  

• Display the Monitor Browser (either by pressing F6 or by selecting Monitor Browser from 
the View menu or by clicking on the icon in the toolbar). 

• Make sure the Monitor’s border is white, then click on the Monitor and hold the Ctrl key of 
your keyboard while dragging the Monitor onto the list or the Preview pane. 

• Enter a name that will be associated with this Monitor. 

The name of the Monitor should now appear selected in the list and your Monitor should be 
displayed in the Preview Pane. 

How to save and load more Layouts than the 10 avail able from 
the Kaleido-RCP? 

Here are four different ways of using more than the ten Layouts accessible through the RCP:  

Using KEdit 

It is possible to load a Layout on your Kaleido-K2 from your KEdit by applying a Layout online 
from the KEdit: 

• From the KEdit open the Layout you want to load onto the Kaleido-K2. 

• From the “File” menu select the “Apply Layout Online” option or press “Alt-A”. The “Apply 
Layout Online” dialog should appear. 



• Select the Kaleido-K2 on which you want to load the Layout from the list of the available 
Kaleido-K2s. 

• Select the data that needs to be exported to the Kaleido-K2 in order to be able to use the 
Layout. 

• Select the “Load” button. 

• The Layout should appear on the Kaleido-K2. 

Using an Action attached to a Component 

You can create an Action containing one Action Element that loads a Layout and then assign this 
Action to be executed when clicking or double clicking on a Component. Following are the steps 
to create the Action and assign it to a Component. 

To create the Action: 

• Select “Action Browser” from the “View” menu or press F9. The Action Browser should 
appear. 

• In the Action Browser press on the “New” button located in the left corner of the dialog. 
The Action Configuration dialog should appear. 

• Enter the name to assign to the Action in the text field. 

 

• In the Action List section click in the “Type” column of the first row. A drop down will 
appear allowing you to choose the type of Action Element to create.  

• Select “Load Layout”, the “Load Layout Configuration” dialog should appear. 

• Select the name of the Layout to load when the Action Element is executed. The drop-
down contains the names of the Layouts saved in the “C:\iControl\Startup\KALEIDO 
LAYOUTS” folder. 



• Click on the “OK” button of the “Load Layout Configuration” dialog. 

• Click on the “Save” button of the “Action Configuration” dialog. 

Your Action is now created. 

To configure the Component to execute the Action on the click or double-click Trigger: 

• Select the Component by clicking on it. 

• Display the “Configuration Panel” by pressing F5 or by selecting “Configuration Panel” 
from the “View” menu. 

• Select the “Action” tab 

• Beside “Action on Single Click” or beside “Action on Double Click” select the name of the 
Action to execute (in this case, the name of the Action you just created). 

• Click on the “Apply” button. 

 

This Layout needs to be exported to the Kaleido-K2 where it will be executed. To do so: 

• Select “Apply Layout Online” from the “File” menu or press Alt-A. 

• Select the destination Kaleido-K2 from the list. 

• Select the data that needs to be exported to the Kaleido-K2: you have to choose the 
“Actions” option in order to export the Action created and associated with the Component. 

• Press the “Load” button. 

Now the Layout containing the association is the current Layout on the specified Kaleido-K2. If 
you want to test the association you just made, assign the Layout to a preset key of the Kaleido 
RCP by pressing and holding for at least 6 seconds one of the 10 function keys located at the top 
of the Kaleido RCP device, then click or double-click on your configured Component on the 
Kaleido. The new Layout should be loaded.  



Using a GPI Input 

You can create an Action containing one Action Element that loads a Layout and then choose this 
Action to be executed when a GPI Input goes on or off. Following are the steps to create the 
Action and a GPI Input Assignment. 

Since only Actions residing on the Kaleido-K2 where the GPI Input will be created can be used 
the following steps will create an Action directly on the Kaleido-K2. This means that you will not 
need to export the Action from the KEdit to the Kaleido-K2. 

To create the Action on the Kaleido-K2: 

• Open KEdit. 

• Select “Online” from the “Open” item of the “File” menu. 

• Select the Kaleido-K2 where you want to create the Action. The Layout displayed on the 
selected Kaleido-K2 must now appear in your KEdit. 

• Select “Action Browser” from the “View” menu or press F9. The Action Browser should 
appear. 

• In the Action Browser press on the “New” button located to the left corner of the dialog. 
The Action Configuration dialog should appear. 

• Enter the name to assign to the Action in the text field. 

• In the Action List section click in the “Type” column of the first row. A drop down will 
appear allowing you to choose the type of Action Element to create.  

• Select “Load Layout”, the “Load Layout Configuration” dialog should appear. 

• Select the name of the Layout to load when the Action Element is executed. The drop-
down contains the names of the Layouts saved in the “C:\iControl\Startup\KALEIDO 
LAYOUTS” folder. 

• Click on the “OK” button of the “Load Layout Configuration” dialog. 

• Click on the “Save” button of the “Action Configuration” dialog. 

The Action is now created. 

The next step is to assign this Action to a state (on or off) of a GPI Input. Take note that the 
creation of GPI Input assignment is only available when you are connected (or on-line) to a 
Kaleido-K2. To create a GPI Input assignment: 

• Select “GPI Input Configuration” from the “View” menu or press F12. 

• Press on the “New” button located at the bottom of the dialog. The GPI In On/Off state 
actions will appear. 

• Enter the number of the GPI Input to which you want to attach the Action. 

• Beside the state on which the Action must be executed select the name of the Action. 



• Press on the “OK” button. 

The assignment is now made and next time the GPI Input goes to the specified state the 
assigned Action will be executed. 

Using the Gateway 

It is possible to operate the Kaleido-K2 using its Internal Gateway. The Gateway is a very flexible 
and powerful tool that is usually used through a program but the Gateway can also be used via 
telnet. The following explanations will guide you through the use of the Gateway via the 
HyperTerminal software. 

First you must verify if the Internal Gateway service is running on your Kaleido-K2.  

The internal gateway is configured through the Kaleido Properties File, and is turned on or off by 
editing that file. Here is how to do it: 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.properties” using the Notepad 
(right click on the “Kaleido.properties” file and select “Notepad” from the “Open With” 
menu). 

• Search the file for either of the following lines: 

activateInternalGateway=TRUE 

activateInternalGateway=FALSE 

• If activateInternalGateway is TRUE, the internal gateway is ON by default at startup. 
Disable the internal gateway at startup by replacing TRUE with FALSE in this line. 

• If activateInternalGateway is FALSE, the internal gateway is OFF by default at startup. 
Enable the internal gateway at startup by replacing FALSE with TRUE in this line. 

• Save your changes using the Save item in the File menu. 

• Close the Notepad editor. 

• Restart the Kaleido. 

The internal gateway supports all Kaleido/Gateway commands when connected via port 13000, 
and supports only the <listnodes\> command when connected via port 10001. 

Your Gateway service is now up and running. 

Open the HyperTerminal software on your computer, and from the “Program” menu choose 
“Accessories”, “Communications” and “HyperTerminal”. A dialog will appear, asking you to enter 
a name for the connection and to select an icon.  



A second dialog, “Connect To”, will appear. In 
the “Connect using” dropdown field choose 
“TCP/IP (Winsock)”. Two new fields will 
appear; in the “Host address” field enter the IP 
address of your Kaleido-K2 and in the “Port 
number” field enter “13000”. This indicates that 
you want to connect to your Kaleido-K2 via the 
port 13000. Click on the “OK” button.  

 

To be able to see the typed characters: 

• Select “Properties” from the “File” menu, 
the “Properties” dialog box appears.  

• Go to the “Settings” tab, click on the 
“ASCII Setup…” button located at the 
bottom of the dialog  

• Select “Echo typed characters locally”. 

Click on the “OK” button and click again on the 
“OK” button from the “Properties” dialog.  

 

You can now see the typed characters appearing in the console. 

Commands can be sent to the Gateway while a session is opened. There is no maximum number 
of commands that can be sent in a session. A session must be opened and closed using two 
specific commands. While sending a command the syntax must be exact. If you make a mistake 
in the syntax, the command will not be understood. Here is a simplified example of a session: 

Open a session 

send command 
send command 
… 
send command 

Close the session. 

To open a session, enter the following command: 



<openID>IP_ADDRESS_0_4_0_0</openID> 

Where: 

• IP_ADDRESS is the IP address of your target Kaleido-K2. 

If the Gateway receives the command, recognizes it as a command that can be handled it will 
send you the following response: 

<ack/> 

If the command cannot be recognized the following message will appear: 

<nack/> 

If you received this message, please consult the Gateway documentation included on the 
Kaleido-K2 CD to troubleshoot the installation and communication. 

You are now ready to send commands. There is a command to use to load a Layout. Here is the 
syntax of the command to send to load a Layout: 

<setKCurrentLayout>set LayoutName.kg2</setKCurrentLayout> 

Where: 

• LayoutName is the name of the Layout to load. 

If you received a <ack/> the specified Layout should now be the displayed Layout on your 
Kaleido-K2. 

There is a command that can be used to get the list of available Layouts from the Kaleido-K2 
system. Here is the syntax of the command: 

<getKLayoutList/> 

The answer to this command takes the form: 

<kLayoutList>Layout1.kg2 Layout2.kg2 Layout3.kg2…</kLayoutList> 

where the names of all available Layouts are listed one after the other. 

You can execute as many commands as you want. When you want to stop sending commands 
you have to close the session. The following command is used to close a session: 

<closeID>IP_ADDRESS_0_4_0_0</closeID> 

Where: 

• IP_ADDRESS is always the IP address of the Kaleido-K2. 

Your session is now closed. Note that this command closes the current connection to the client 
via port 13000, so this connection must be re-established before another session can be opened. 
If you are using Hyperterminal, it will automatically re-establish the previous connection if you 
begin typing new commands, but other clients may require you to manually reconnect. 



To end the communication, select the “Disconnect” icon from the toolbar. 

Using the LOAD button on the RCP 

Push the LOAD button to open a dialog listing layouts currently saved on the Kaleido  [Note: This 
dialog lists the names of Layouts located in the “c:\iControl\Startup\KALEIDO_LAYOUTS” folder – 
layouts saved at other locations are not available through this dialog].  

 

The top layout will be highlighted. 

• Use the up and down arrow keys on the Kaleido-RCP  to move through the list 

• When the desired layout is highlighted, push the ENTER button to load it 

• Push the ESCAPE button to exit the process without changing the layout. 

 

How to load a Layout onto the Kaleido-Alto? 

This operation is done from within KEdit. The Layout you want to export must be the currently 
displayed Layout in KEdit. 

• Select “Export Layout” from the “File” menu. The “Export to Kaleido Alto” dialog box should 
appear. 

• In the “Alto Frame IP Address” enter the IP of the Kaleido-Alto where you want to load the 
Layout. 

• In the “Layout Name” field enter the name of the Layout on the destination machine (the 
default name will be the same as on KEdit) 

• Choose if Alarms, Channels, Actions, Images and/or Audio scales must also be exported. 

• Click on the “Export” button. 

 



           

 

The Layout is now exported to the destination Kaleido-Alto. The Layout is also displayed. If you 
chose to export the Alarms, Channels etc. you might have to wait a few seconds before your 
Layout is displayed on the Kaleido-Alto. 

How to make my video window appear in the appropria te aspect 
ratio? 

The Aspect Ratio of a Video Component can be changed at configuration time or during 
operation. 

At Configuration Phase 

The Video Component has a Default Aspect Ratio, but it can also retrieve its Aspect Ratio from 
the encoded WSS. In the absence of WSS information, the default Aspect Ratio will be used.  

To Specify the Default Aspect Ratio: 

When configuring a Video Component, the Default Aspect Ratio can be selected as either 4/3 or 
16/9.The Default Aspect Ratio is used by the software to determine the maximum size of the 
Video Component. Note that switching back and forth between the two Aspect Ratios will lead to 
smaller and smaller Video Components due to the algorithm used. 

• Select the Video to configure (if the Video is within a Monitor, right-click on the Monitor and 
select Unlock Monitor from the popup menu, and then click on the Video, or more directly, 
ALT-click on the Video). 

• Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Video, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• In the “Assign Video Input” section select the “Default Ratio” to use (4/3 or 16/9). 

• Click on the “Apply” button. 

To retrieve the Aspect Ratio from WSS 

Specifying that the Aspect Ratio is changed automatically through the use of WSS allows the 
Video Component to respond automatically to the input signal content without operator 
intervention. Note that when automatically changing the Aspect Ratio, the Video Component 
check the configured Default Aspect Ratio to determine its maximum size. 



• From your KEdit open the Layout to modify (select “Open” and “Online” from the “File” 
menu or press “Ctrl-O” and select the K2 from which you want to modify the Layout). 

• Select the Video to configure (if the Video is within a Monitor, right-click on the Monitor and 
select Unlock Monitor from the popup menu, and then click on the Video, or more directly, 
ALT-click on the Video). 

 Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Video, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”.. 

• In the “Assign Video Input” section select “Change aspect ratio automatically (WSS)”. 

• Click on the “Apply” button to apply the modifications to the selected Video Component. 

When the decoded Aspect Ratio changes, the Video Component’s size will automatically reflect 
the new value. 

You can assign the modified Layout to a preset. To do so using the Kaleido RCP, press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your K2 press the function key (F1 
through F10) for at least 6 seconds to associate to the Layout. 

During Operation 

It is possible to modify the Aspect Ratio of a Video during operation using the RCP or the 
keyboard. When modifying the Aspect Ratio of a Video during operation the Video Component 
checks the configured Default Aspect Ratio to know the maximum size it can have. 

Using the Kaleido RCP 

Using the Kaleido RCP connected to the K2 you will need to select the appropriate Video 
Component and indicate the modification of the Aspect Ratio. 

• Press the “Select” key of your Kaleido RCP. You will see numbers appearing over the 
Video Components, verifying that you are in selection mode. 

• Using the Arrow buttons, navigate to the desired Video Component and press on the 
“Enter” button to select it. If needed, navigate to other Video Component and select them. To 
select all the Video Components contained in your Layout press on the “Select” button again. 

• Press the “Aspect Ratio” button to toggle the Aspect Ratio from 4:3 to 16:9 and vice-versa. 

• To exit the selection press on the “ESC” button. 

Using a keyboard connected to the K2 

Using the keyboard connected to the K2 you will need to select the appropriate Video Component 
and indicate the modification of the Aspect Ratio. 

• Press the “Tab” key of your keyboard. You will see numbers appearing over the Video 
Components, verifying that you are in selection mode. 



• Using the Arrow keys, navigate to the desired Video Component and press on the “Enter” 
key to select it. If needed, navigate to other Video Component and select them. To select all 
the Video Components contained in your Layout press on the “Tab” key again. 

• Always on the keyboard, press the “R” key to toggle the Aspect Ratio from 4:3 to 16:9 and 
vice-versa. 

• To exit the selection press on the “Esc” key. 

How to change the default Full Screen Layout? 

You must open KEdit and create or open the Layout you want to use as your default full screen 
Layout. 

A full screen Layout can contain more than one Monitor but it contains only one Monitor that is 
used to display the current Channel. This means that whichever Channel is selected at the 
moment you load the full screen Layout will be the one displayed in this Monitor. The target 
Monitor is the Monitor with the smallest “z-order”.  

To assign the smallest “z-order” to the Monitor that will be used as the target Monitor: 

• Select the Monitor. 

• Select “Order” from the “Draw” menu and then “Send to Back” or select the “Send to Back” 
icon from the toolbar. 

• Save the Layout by pressing “Ctrl-S” or by choosing “Save” from the “File” menu. 



 

The next step is to apply the Layout on the Kaleido-K2: 

• Select “Apply Layout Online” from the “File” menu or press “Alt-A”. The “Apply Layout 
Online” dialog should appear. 

• Select the Kaleido-K2 on which the Layout will be applied from the Kaleido-K2 list. 

• Select the data to export at the same time. If the Layout uses Actions, Channels, Alarm 
Monitors, Audio Scales or Images that are not on the destination or that might have 
changed since they were last exported it is a good practice to export them while exporting 
the Layout. 

• Press “Load”. 

The Layout should now be displayed on the selected Kaleido-K2. 

To indicate that the Layout will be used as the full screen Layout press the “Full screen” button of 
your Kaleido-RCP or the “F” key of the Kaleido-K2 keyboard and hold it for at least 6 seconds. 

 



Dealing with Alarms 

How to Configure My Monitor to Report Alarms? 

Your Monitor can report Alarms using different meanings. The following steps will guide you 
through the creation of an Alarm and will also explain how to associate an Alarm to some of the 
Components that can be found inside of a Monitor. 

Creating an Alarm 

From within your KEdit open the Layout where you’ll want to use the Alarm. An Alarm is not 
associated to a Layout but is created for the system, so that an Alarm can be used by several 
Layouts on the same machine. 

• Open the Alarm Browser by selecting “Alarm Browser” from the “View” menu or by pressing 
“F7”. The “Alarm Browser” should appear. 

• Select the “New” button. The “Alarm Monitor” configuration panel appears. 

• In the “Name” field enter a name for the Alarm. 

• If you want to associate the Alarm to a group (this is useful when you want to enable or 
disable all the Alarms of a specific group instead of doing it one Alarm at the time) select an 
existing group or type the name of a new group. You can also leave this field empty and 
associate a group later on. 

• Click in the first column of the first row of the Alarm List table and select the type of the 
Alarm. A configuration dialog will appear allowing you to configure the Alarm. When you’re 
done with the configuration select the “Ok” button; the newly created Alarm should appear in 
the Alarm List of the “Alarm Monitor” configuration dialog. 

• An Alarm Monitor can report the status of one or many Alarms. You can create other 
Alarms if you wish to. Note that when it contains more than one Alarm, the Alarm Monitor 
reports the status of the top priority Alarm: if an Alarm is in Error the Alarm Monitor will report 
an Error Status even if all the other Alarms are Ok. 

• If needed, associate an Action to execute when the Alarm Monitor reaches the specified 
state. Doing so, for example, can allow you to load a specific Layout if a Video Signal reports 
an Error state. 

• When you’re done, click on the “Save” button; the created Alarm Monitor should now 
appear in the “Alarm Browser”. 

Associating an Alarm with a Monitor 

In a Monitor, the Alarm can be reported by many Components: Video, UMD, Text Label, Status 
Indicator and Tally can be used to report Alarms. 



Associating an Alarm with a Video Component 

• Select the Video to configure (if the Video is within a Monitor, right-click on the Monitor and 
select Unlock Monitor from the popup menu, and then click on the Video, or more directly, 
ALT-click on the Video). 

• Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Video, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• In the “Configuration Panel” select the “Border” tab; the panel that appears will let you 
select which Alarm Monitor will be monitored by the Video Component and configure how the 
border of the Video will reflect the changes to the Alarm Monitor state. 

• In the “Border Color” section select the appearance that the border will take for each of the 
states, and indicate if you want the border to flash when the state turns to “Warning” or 
“Error”. 

• In the “Assign Alarm Monitor” section select the name of the Alarm Monitor that will be 
reported by the border. 

• In the “Error Latching” section indicate if you want the error to be latched or not (default 
behavior) or held for a specified duration (in seconds). 

• In the “Alarm Link Order” section indicate the Link Order to associate with this Alarm (the 
Link Order refers to the precedence of Alarms when assigning a Channel to a Monitor; please 
refer to the Channel Concepts documentation for more information). 

• Select the “Apply” button to apply this information to the selected Video Component. 

• Save the Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. If the 
Layout you are editing is the online Layout you can assign this modified Layout to a preset by 
pressing on one of the preset keys of the RCP for at least 6 seconds. 

From now on, the Video border will report the status of the Alarm. 

Associating an Alarm with a UMD Component 

The following steps describe how to associate an Alarm with a UMD that is part of a Monitor, but 
an Alarm could also be associated with a UMD that is not part of a Monitor (leave out the first 
step of the following procedure in the later case). 

• Select the UMD to configure (if the UMD is within a Monitor, right-click on the Monitor and 
select Unlock Monitor from the popup menu, and then click on the UMD, or more directly, 
ALT-click on the UMD). 

 Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
UMD, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• In the “Configuration Panel” select the “Alarm” tab; the panel that appears will let you select 
which Alarm Monitor will be reported by the UMD Component and configure how the 
background and text color will change to report the Alarm Monitor state. 

• In the “Display Options” section select the appearance that the UMD will take for each of 
the states. Indicate if you want the UMD to flash when the state turns to “Warning” or “Error”. 



• In the “Assign Alarm Monitor” section select the name of the Alarm Monitor that will be 
reported by the Component. 

• In the “Error Latching” section indicate if you want the error to be latched or not (default 
behavior) or held for a specified duration (in seconds). 

• In the “Alarm Link Order” section indicate the Link Order to associate with this Alarm (the 
Link Order refers to the precedence of Alarms when assigning a Channel to a Monitor; please 
refer to the Channel Concepts documentation for more information). 

• Select the “Apply” button to apply this information to the selected UMD Component. 

• Save the Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. If the 
Layout you are editing is the online Layout you can assign this modified Layout to a preset by 
pressing on the preset key of the RCP for at least 6 seconds. 

From now on, the UMD will report the status of the selected Alarm. 

Associating an Alarm with a Text Label Component 

The following steps describe how to associate an Alarm with a Text Label that is part of a 
Monitor, but an Alarm can also be associated with a Text Label that is not part of a Monitor (leave 
out the first step of the following procedure in the later case). 

• Select the Text Label to configure (if the Text Label is within a Monitor, right-click on the 
Monitor and select Unlock Monitor from the popup menu, and then click on the Text Label, or 
more directly, ALT-click on the Text Label). 

• Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Text Label, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• In the “Configuration Panel” select the “Alarm” tab. The panel that appears will let you 
select which Alarm Monitor will be reported by the Text Label Component and configure how 
the background and text color will change to report the Alarm Monitor state. 

• In the “Display Options” section select the appearance that the Text Label will take for each 
of the possible state. Indicate if you want the Text Label to flash when the state turns to 
“Warning” or “Error”. 

• In the “Assign Alarm Monitor” section select the name of the Alarm Monitor that will be 
reported by the Component. 

• In the “Error Latching” section indicate if you want the error to be latched or not (default 
behavior) or held for a specified duration (in seconds). 

• In the “Alarm Link Order” section indicate the Link Order to associate with this Alarm (the 
Link Order refers to the precedence of Alarm when assigning a Channel to a Monitor; please 
refer to the Channel Concepts documentation for more information). 

• Select the “Apply” button to apply this information to the selected Text Label Component. 

• Save the Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. If the 
Layout you are editing is the online Layout you can assign this modified Layout to a preset by 
pressing on the preset key of the RCP for at least 6 seconds. 



From now on, the Text Label you configured will report the status of the selected Alarm. 

Associating an Alarm with a Status Indicator Component 

The Status Indicator is a Component whose primary function is to report the status of an Alarm 
Monitor. A Status Indicator can be part of a Monitor but it can also be placed independently in the 
Layout (leave out the first step of the following procedure in the later case). 

• Select the Status Indicator to configure (if the Status Indicator is within a Monitor, right-click 
on the Monitor and select Unlock Monitor from the popup menu, and then click on the Status 
Indicator, or more directly, ALT-click on the Status Indicator). 

• Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Status Indicator, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• The panel that appears will let you select which Alarm Monitor will be reported by the 
Status Indicator Component and configure the icon that will be used to report the Alarm 
Monitor state. 

• In the “Icon Selection” section click on the “Select…” button located on the side of each 
status to configure. A dialog will appear allowing you to select the icon that will be displayed 
for the states. Indicate if you want the Status Indicator to flash when the state turns to 
“Warning” or “Error”. 

• In the “Assign Alarm Monitor” section select the name of the Alarm Monitor that will be 
reported by the Status Indicator Component. 

• In the “Error Latching” section indicate if you want the error to be latched or not (default 
behavior) or held for a specified duration (in seconds). 

• In the “Transparency” section your can specify if you want your Component to be opaque 
or transparent. Indicating a value other than “Opaque” will allow the video to be seen through 
the Status Indicator if it is positioned over a Video Component. 

• In the “Alarm Link Order” section indicate the Link Order to associate with this Alarm (the 
Link Order refers to the precedence of Alarm when assigning a Channel to a Monitor; please 
refer to the Channel Concepts documentation for more information). 

• Select the “Apply” button to apply this information to the selected Status Indicator 
Component. 

• Save the Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. If the 
Layout you are editing is the online Layout you can assign this modified Layout to a preset by 
pressing on the preset key of the RCP for at least 6 seconds. 

From now on, the Status Indicator you configured will report the status of the selected Alarm 
Monitor. 

Associating an Alarm with a Tally Component 

The Tally is a Component that can modify its displayed color in order to report the status of its 
associated Alarm Monitor. A Tally can be part of a Monitor but it can also be placed 
independently on the Layout(leave out the first step of the following procedure in the later case). 



• Select the Tally to configure (if the Tally is within a Monitor, right-click on the Monitor and 
select Unlock Monitor from the popup menu, and then click on the Tally, or more directly, 
ALT-click on the Tally). 

• Display the “Configuration Panel” (if it is not already displayed) by double-clicking on the 
Tally, by selecting “Configuration Panel” from the “View” menu or by pressing “F5”. 

• The panel that appears will let you configure the color to use for each state. Do to so, click 
on the “Select…” button that is located to the side of the Tally associated with each status. 
You can indicate to a Tally to flash in any state by selecting the “Flashing” button to the right. 

• In the “Tally Assignment” section choose the Alarm Monitor with which this Component will 
be associated. The GPI_XX options are automatically-generated Alarm Monitors that reports 
the status of the GPI IN XX. Choosing any of these Alarm Monitors means that the Tally 
would report the status of the named GPI input. 

• In the “Transparency” section your can specify if you want your Component to be opaque 
or transparent. Indicating a value other than “Opaque” will allow the video to be seen through 
the Tally if it is positioned over a Video Component. 

• In the “Alarm Link Order” section indicate the Link Order to associate with this Alarm (the 
Link Order refers to the precedence of Alarm when assigning a Channel to a Monitor; please 
refer to the Channel Concepts documentation for more information). 

• Select the “Apply” button to apply this information to the selected Tally Component. 

• Save the Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. If the 
Layout you are editing is the online Layout you can assign this modified Layout to a preset by 
pressing on the preset key of the RCP for at least 6 seconds. 

From now on, the Tally you configured will report the status of the selected Alarm Monitor. 

How to squelch the Alarms during the day? 

You can choose to stop the Alarms through the use of the Alarm Group inhibit button, through the 
Gateway or through the Schedule, but before doing so there are a couple of steps that must be 
completed. 

First you need to create your Alarms. The creation of the Alarms is done from the Alarm Browser. 
To access the Alarm Browser select “Alarm Browser” from the “View” menu or press F7. Once 
the Alarm Browser is displayed you will see the list of Alarms available on your machine (either 
the KEdit if you’re currently editing an off-line Layout, or the Kaleido-K2 if you are editing an on-
line Layout) and their Alarm Inhibition Group if any was defined at the Alarms creation time. 
Please refer to the documentation to create the Alarms. If no Alarm Inhibition Groups are 
associated with your Alarms, here is how you can assign them: 

• Select the Alarm from the list and click on the “Edit” button. The “Alarm Monitor” dialog 
should appear containing the configuration of the Alarm. 

• Enter or select the name of the group to which the Alarm will belong. 

• Click on the “Save” button. You should see the name of the group appearing beside the 
name of the Alarm in the Alarm Browser. 



Continue until all the Alarms you want to enable and disable are associated with groups. 

From now on, there are different options to disable your Alarms. 

Using the Alarm Group Inhibit Button 

The Alarm Group Inhibit Button can be added to any Layout. In operation mode, pressing this 
Component will toggle the state of the Alarms contained in the group associated with the button. 
To add and configure this Component within your Layout: 

• From KEdit open the Layout (either by connecting on-line to a Kaleido-K2 or by opening a 
Layout from a file) 

• Select the Alarm Group Inhibit Button icon from the Component toolbar. 

• Click on your Layout and adjust the position and size of the Component. 

• Select “Configuration Panel” from the “View” menu or press F5 to view the Configuration 
Panel. 

• In the Alarm Group drop-down select the name of the Alarm Group that will be driven by 
the button. 

• Click on the “Apply” button located at the bottom of the dialog. 

• Save your Layout. 

• If it is not already on-line on a Kaleido-K2 apply it on-line. 

The Alarms of the group associated with the Alarm Group Inhibit Button should be enabled. 
Pressing the button will disable them. Pressing again on the button should re-enable the Alarms. 
This button will toggle the state of the Alarms associated with the group each time it is clicked. 

Using the Gateway 

It is possible to operate the Kaleido-K2 using its Internal Gateway. The Gateway is a very flexible 
and powerful tool that is usually used through a program but the Gateway can also be used via 
telnet. The following explanations will guide you through the use of the Gateway via the 
HyperTerminal software. 

First you must verify if the Internal Gateway service is running on your Kaleido-K2.  

The internal gateway is configured through the Kaleido Properties File, and is turned on or off by 
editing that file. Here is how to do it: 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.properties” using the Notepad 
(right click on the “Kaleido.properties” file and select “Notepad” from the “Open With” 
menu). 

• Search the file for either of the following lines: 

activateInternalGateway=TRUE 



activateInternalGateway=FALSE 

• If activateInternalGateway is TRUE, the internal gateway is ON by default at startup. 
Disable the internal gateway at startup by replacing TRUE with FALSE in this line. 

• If activateInternalGateway is FALSE, the internal gateway is OFF by default at startup. 
Enable the internal gateway at startup by replacing FALSE with TRUE in this line. 

• Save your changes using the Save item in the File menu. 

• Close the Notepad editor. 

• Restart the Kaleido. 

The internal gateway supports all Kaleido/Gateway commands when connected via port 13000, 
and supports only the <listnodes\> command when connected via port 10001. 

Your Gateway service is now up and running. 

Open the HyperTerminal software on your computer, and from the “Program” menu choose 
“Accessories”, “Communications” and “HyperTerminal”. A dialog will appear, asking you to enter 
a name for the connection and to select an icon.  

A second dialog, “Connect To”, will appear. In the “Connect using” dropdown field choose 
“TCP/IP (Winsock)”. Two new fields will appear, in the “Host address” field enter the IP address of 
your Kaleido-K2 and in the “Port number” field enter “13000”. This indicates that you want to 
connect to your Kaleido-K2 via the port 13000. Click on the “OK” button.  

To be able to see the typed characters: 

• Select “Properties” from the “File” menu, the “Properties” dialog box appears.  

• Go to the “Settings” tab, click on the “ASCII Setup…” button located at the bottom of the 
dialog.  

• Select “Echo typed characters locally”. 

• Click on the “OK” button and click again on the “OK” button from the “Properties” dialog.  

You can now see the typed characters appearing in the console. 

Commands can be sent to the Gateway while a session is open. There is no maximum number of 
commands that can be sent in a session. A session must be opened and closed using two 
specific commands. While sending a command the syntax must be exact. If you make a mistake 
in the syntax, the command will not be understood. Here is a rough example of a session: 

Open a session 

send command 
send command 
… 
send command 

Close the session. 



To open a session enter the following command: 

<openID>IP_ADDRESS_0_4_0_0</openID> 

Where: 

• IP_ADDRESS is the IP address of your destination Kaleido-K2. 

If the Gateway receives the command, and recognizes it as a command that can be handled, it 
will send you the following response: 

<ack/> 

If the command cannot be recognized the following message will appear: 

<nack/> 

If you received this message, please consult the Gateway documentation included on the 
Kaleido-K2 CD to troubleshoot the installation and communication. 

You are now ready to send commands. There are commands to enable and disable Alarm 
Groups. Here is the syntax for the command that enables an Alarm Group: 

<setKEnableAlarmGroup>set name=”NameOfTheGroup”</setKEnableAlarmGroup> 

Where: 

• NameOfTheGroup is the name of the Alarm Group to enable. 

If you received a <ack/> the specified Alarm Group should now be enabled on your Kaleido-K2. 

The syntax to disable an Alarm Group is the following: 

<setKDisableAlarmGroup>set name=”NameOfTheGroup”</setKDisableAlarmGroup> 

Where: 

• NameOfTheGroup is the name of the Alarm Group to disable. 

You can execute as many commands as you want. When you want to stop sending commands 
you have to close the session. The following command is used to close a session: 

<closeID>IP_ADDRESS_0_4_0_0</closeID> 

Where: 

• IP_ADDRESS is always the IP address of the Kaleido-K2. 

Your session is now closed. 

To end the communication, select the “Disconnect” icon from the toolbar. 



Using the Schedule 

You can enable and disable Alarms using the Schedule. Since a Schedule can only be created in 
on-line mode you need to open the Layout. To do so: 

• Start KEdit 

• Select “Open” from the “File” menu and then the “Online…” menu item or press the “Ctrl-
O” keys. 

• Select the Kaleido-K2 from the list. 

• Click on the “Open” button. 

You are now in on-line mode. 

You must have an Action that disables an Alarm Group. The following steps will guide you 
through the creation of this Action: 

• Select the “Action Browser” option from the “View” menu or press F9. The “Action 
Browser” dialog will appear; it lists all the Action objects that are defined on your Kaleido-
K2. 

• Click on the “New” button located at the bottom of the dialog, the “Action Configuration” 
dialog should appear. 

• Enter a name for your Action. 

• In the Action List section click in the “Type” column of the first row and select “Alarm 
Group” from the list. The “Alarm Group Configuration” dialog should appear. 

• Indicate that you want to disable the Alarm Group. 

• Select the name of the Alarm Group from the list of the existing Alarm Groups. 

• Click on the “Ok” button. 

• Click on the “Save” button. 

The Action is now created and you can use it. Repeat the same steps to create an Action that will 
be used to re-enable the Alarms associated to the same group, don’t forget to select “Enable” in 
the “Alarm Configuration Dialog” this time! 

It is now the time to create an entry in the Schedule. 

• Select “Schedule” from the “View” menu. The “Schedule Editor” appears, showing you the 
Schedule Entry objects already created, if any. 

• Click on the “New…” button located at the bottom of the dialog. The “Schedule Entry” 
editor appears. 

• Since you want your Alarms to be disabled every day during the day select the “Recurrent 
Executions” option. You now have access to more fields. 



• Select the days on which you want your Alarms to be disabled. 

• Enter the time at which you want your Alarms to be disabled. This field works like a time 
code field: simply enter the digits and they will move to left. If you want your Alarms to be 
disabled at 8 AM simply enter 8-0-0-0-0 and it should display “08:00:00”. 

• Select the name of the Action you created that disabled the Alarms from the specified 
group. 

• Click on the “Ok” button. 

Back to the “Schedule Editor” you should see that a Schedule Entry has been added. You now 
need to create a new Schedule Entry so your Alarms will be re-activated at night: 

• In the list click on the newly added Schedule Entry. 

• Click on the “Duplicate…” button. The “Schedule Entry Editor” appears with all the 
information of the previously created Schedule Entry. 

• Go to the time field and press on the spacebar of your keyboard. The time should now 
indicate “00:00:00”. 

• Enter the time at which those Alarms will be enabled again. Note that this value is based 
on a 24-hour clock. To get 6PM, which is 18h, enter 1-8-0-0-0-0. You should now see 
“18:00:00”. 

• In the Action drop down select the name of the Action that enabled the Alarms of the 
Group. 

• Click on “Ok”. 

Back to the “Schedule Editor” you should see another entry that describes the enabling of the 
Alarms. Click on the “Save” button to save the modifications you made to the Schedule. 

How to display Alarms on the Kaleido-K2 from other Miranda 
devices through iControl? 

The first step is to find the “Miranda Long ID” associated with each Miranda device from which 
you want to receive status. You can achieve this either by using iNavigator or, if you don’t have 
access to iNavigator, via the log generated by the Kaleido. Then you can create an alias for this 
ID that is easier to recall and enter than the ID itself. This step is not necessary but it could be 
useful if you must create many Alarms with this ID. Then you can create your Alarms and finally 
export the Layout and Alarms to the targeted Kaleido-K2. 

Getting the Miranda Long ID using iNavigator 

Start your iNavigator. Use iNavigator to locate the device on the network (please refer to the 
iNavigator manual for more details). Note the device’s address (something like 
ANIPADDRESS_COM9_SOMETHINGAGAIN). 

Getting the Miranda Long ID using the Kaleido.log 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 



• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.log” using the Notepad (right 
click on the “Kaleido.log” file and select “Notepad” from the “Open With” menu).  

• Within Notepad, press “Ctrl-F” or select “Find…” from the Edit menu and in the “Find What” 
section enter “serviceAdded called for ID:”. 

Each entry found will give you a Miranda Long ID. Continue looking through the file until you 
find the device you’re looking for. 

• Note the device address (something like ANIPADDRESS_COM9_SOMETHINGAGAIN). 

Creating an Alias for the Miranda Long ID 

After you collected the device’s ID you can decide to create an alias, which is a “nickname” you 
could use while configuring Alarms, or to configure the Alarms right away. Here are the steps to 
create an alias. If you prefer to use the Miranda Long ID you can skip this section. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <ServiceStatus> section. 

• Enter the following line: 

<Service ServiceLabel=”MyService” id=” ANIPADDRESS_COM9_SOMETHINGAGAIN”/> 

Where: 

• “MyService” is the nickname you want to use for the device 

• ANIPADDRESS_COM9_SOMETHINGAGAIN is the device’s Long ID. 

• Save the KG2Config.xml file. 

• It is a good time to reboot your Kaleido-K2 system: doing so will allow the Kaleido-K2 to 
recognize and use the newly defined alias. 

Example of a KG2Config.xml: 



 

Creating and using a Layout using Alarms for the device 

• From within your KEdit open a Layout from the Kaleido-K2 (select “Open” from “File” menu 
and then select “Online” or press “Ctrl-O” and choose the Kaleido-K2), open an existing 
Layout (select “Open” from the “File” menu and “File” or press “Ctrl-F” and navigate to the file 
containing the Layout) or create a new Layout (select “New” from the “File” menu or press 
“Ctrl-N”), lay your Components and when you’re satisfied with the result go to the next 
operation. 

• Select “Alarms Browser” from the “View” menu or press “F7” to display the “Alarm 
Browser”. 

• From the Alarm Browser select the “New” button. You are ready to create a new Alarm 
Monitor. 

• Enter a name for this Alarm Monitor. 

• If required, associate the Alarm Monitor with an Alarm Group. 



• Click “New” to add a blank alarm to the alarms list if there is not already one there. 

• Click the blank alarm under the “Type” column; a pulldown list of alarm types will appear. 

• Select “iControl Device” from the list; the Alarm Setting dialog will appear. 

• In the “iControl Device Service ID” box enter the Miranda Long ID associated with the 
device or its alias if you created one for this device, then click “OK” to return to the Alarm 
Monitor panel. 

• If required, associate Actions to be executed with one or many statuses of the Alarm 
Monitor. 

• Click on the “Save” button to save your Alarm Monitor. 

Back in your Layout, identify a Component to display the Alarm’s status. Let’s say you add a 
“General Status Indicator” to display the Alarm’s status: 

• Click on the “General Status Indicator” icon from the toolbar 

• Create the Component in your Layout. 

• Select the Component and select “Configuration Panel” from the “View” menu or press 
“F5” to display the “Configuration Panel”. 

• Select the icons to use to represent the different states the Component can display. 

• In the Alarm dropdown field choose the Alarm you just created. 

• Configure more parameters if needed (Error Latching, Transparency, Channel, Action,…) 

• Click on the “Apply” button to save the configuration. 

If you’re not in online mode (that is if you have not opened the Layout you are editing via the 
“Open” and “Online” option) you must apply your Layout online on the Kaleido-K2 in order to test 
what you just did. To do so: 

• Select “Apply Layout Online” from the “File” menu or press “Alt-A”. The “Apply Layout 
Online” dialog should appear. 

• Select the destination Kaleido-K2. 

• Select the data to export: make sure to select the Alarms Monitors. 

• Click on the “Load” button. You should be able to see the new Layout on the specified 
Kaleido-K2. 

You are now ready to test your Alarm. Don’t forget to save the Layout as a Preset Layout if you 
want to be able to retrieve it at a later time. 



How to unlatch Alarms in the Kaleido-K2 

When acknowledging an Alarm you may want to unlatch it so it could come up again when 
needed. You can unlatch Alarms using the Kaleido RCP, using a mouse connected to the 
Kaleido-K2, using a keyboard connected to the Kaleido-K2 or using Actions.  

Unlatching Alarms using the Kaleido RCP 

Using the RCP you can unlatch Alarms of one or many Monitors. 

• Push on the “SELECT” button. You should see the identifier of the Monitor and its assigned 
Channel appearing in the center of each Monitor. The current Monitor is the one that has a 
yellow border around this information. 

• It is possible to unlatch Alarms of one or many Monitors. 

To unlatch the Alarms of one Monitor: 

• If the current Monitor is not the one for which you want to unlatch the Alarms use the 
arrow keys to navigate to the targeted Monitor. 

• Push on the “DEL” button. The Alarm reporters should now be unlatched. 

To unlatch the Alarms of many Monitors: 

• If the current Monitor is part of the group of Monitors from which you want to unlatch 
Alarms push the “ENTER” button. If the current Monitor is not part of these Monitors 
navigate to another Monitor that is part of the group using the arrow keys and push the 
“ENTER” button. 

• Using the arrow keys navigate to every Monitor to include to the group and push the 
“ENTER” button. If you want to select every Monitor of the displayed Layout simply push the 
“SELECT” button again. 

• When all the Monitors you want to unlatch are selected push the “DEL” button. The Alarm 
reporters should now be unlatched. 

• Push the “ESC” button to return to the normal mode. 

Unlatching Alarms using a keyboard connected to the  Kaleido-K2 

Using a keyboard connected to the Kaleido-K2 it is possible to unlatch Alarms of one or many 
Monitors. 

• Press on the “Tab” key. You should see the identifier of the Monitor and its assigned 
Channel appearing in the center of each Monitor. The current Monitor is the one which has a 
yellow border around the information. 

• It is possible to unlatch the Alarms for one or many Monitors. 

To unlatch the Alarms of one Monitor: 



• If the current Monitor is not the one for which you want to unlatch the Alarms use the 
arrow keys to navigate to the targeted Monitor. 

• Press on the “Delete” key. The Alarm reporters should now be unlatched. 

To unlatch the Alarms of many Monitors: 

• If the current Monitor is part of the group of Monitors from which you want to unlatch 
Alarms press the “Tab” button. If the current Monitor is not part of these Monitors navigate 
to another Monitor that is part of the group using the arrow keys and press the “Tab” key. 

• Using the arrow keys navigate to every Monitor to include to the group and press the 
“Enter” key. If you want to select every Monitor of the displayed Layout simply press the 
“Tab” key again. 

• When all the Monitors you want to unlatch are selected, press on the “Delete” key. The 
Alarm reporters should now be unlatched. 

• Press the “Esc” key to return to the normal mode. 

Unlatching Alarms using a mouse connected to the Ka leido-K2 

Using a mouse connected to the Kaleido-K2 it is possible to unlatch Alarms of a Monitor, of a 
Video, of a UMD, of a Text Label or of a Status Indicator Component. 

To unlatch the status of the Video Component 

• Using the mouse, right click on the Video Component from which you want to unlatch the 
status. 

• Select the “Unlatch Border Status” option. 

To unlatch all the statuses of a Monitor 

• Using the mouse, right click on the Video Component of the Monitor from which you want to 
unlatch the statuses. 

• Select the “Unlatch Monitor Status” option. 

To unlatch the status of a UMD Component 

• Using the mouse right click on the UMD Component from which you want to unlatch the 
status. 

• Select the “Unlatch Status” option. 

To unlatch the status of a Text Label Component 

• Using the mouse, right click on the Text Label Component from which you want to unlatch 
the status. 

• Select the “Unlatch Status” option from the contextual menu. 



To unlatch the status of a Status Indicator Component 

• Using the mouse, right click on the Status Indicator Component for which you want to 
unlatch the status. 

• Select the “Unlatch Status”. 

Unlatching Alarms using an Action 

It is possible to unlatch Alarms using an Action associated with a Component: when clicking or 
double clicking on the Component the Action is executed. The following steps explain how to 
create an Action that unlatches Alarms and how to associate it with a Text Label Component so 
when you click on the Text Label the created Action is executed. The following steps are 
executed from within your KEdit connected online to the Kaleido-K2 where you’ll want to use this 
feature. 

To get connected online to your Kaleido-K2 

• Open your KEdit if it is not already opened. 

• Select “Online” from the “Open” item of the “File” menu. A dialog containing the names of 
every Kaleido available on your network will appear. 

 Select the Kaleido-K2 where you want to create the Action and click on the “Open” button. 
The Layout displayed on the selected Kaleido-K2 must now appear in your KEdit and “ONLINE 
– YourKaleidoName (999.999.999.999) -”YourLayoutName” | 9x9 should appear in the title of 
your edited layout. YourKaleidoName is the name of the selected Kaleido-K2, 
999.999.999.999 is the IP address of the selected Kaleido-K2, YourLayoutName is the name 
of the current layout displayed on the Kaleido-K2 and, finally, 9x9 is the layout aspect ratio. 

You are now connected online to your Kaleido-K2 and all the modifications you will make will be 
applied directly on the Kaleido-K2 (you will not need to export the Layout and the new Action to 
the Kaleido-K2 in order to use them). 

To create an Action that unlatches Alarms 

All the following steps are done inside your KEdit. 

• Select “Action Browser” from the “View” menu or press F9. The Action Browser will appear. 

• In the Action Browser press on the “New” button located in the left corner of the dialog. The 
Action Configuration dialog will appear. 

• Enter the name to assign to the Action in the text field. 



 

• In the Action List section click in the “Type” column of the first row. A drop down will appear 
allowing you to choose the type of Action Element to create. 

• Select “Unlatch Alarm”; the “Unlatch Alarms Configuration” dialog should appear. 

• Choose whether you want to unlatch the Alarms of the selected Monitor or all the Alarms of 
the current Layout. Please note that if you choose to unlatch the Alarms of the selected 
Monitor and at execution time there is no selected Monitor, nothing will happen. 

• Click on the “OK” button of the “Unlatch Alarms Configuration” dialog. 

• Click on the “Save” button of the “Action Configuration” dialog. 

Your Action is now created. 

Assigning the Action to a Text Label 

If your Layout doesn’t contain a Text Label that could be used to trigger the created Action add 
one. To add a Text Label Component to your Layout click on the Text Label tool from the 
Components Tool Bar, click and drag to create a Text Label of the appropriate size. If you want to 
add a Text Label in a Monitor, right-click on the monitor and select 'Unlock Monitor' from the 
contextual menu. Its border will become yellow with four yellow handles. You have now "entered" 
the monitor. Click on the Text Label tool from the Components Tool Bar, then click and drag 
inside the monitor’s border to create a Text Label of the appropriate size. 

To configure the Component to execute the Action on the click or double-click Trigger: 

• Select the Text Label by clicking on it. 

• Display the “Configuration Panel” by pressing F5, by double-clicking the Text Label, by 
right-clicking the text label and selecting “Configuration Panel” from the popup menu, or by 
selecting “Configuration Panel” from the “View” menu. 

• Select the “Action” tab 



• Beside “Action on Single Click” or beside “Action on Double Click” select the name of the 
Action to execute (in this case, the name of the Action you just created). 

• Click on the “Apply” button. 

 

Your Layout now contains a Text Label Component that when pressed will unlatch the Alarms of 
the current Monitor or of the current Layout depending on the configuration you chose when you 
created your Action. 

If you want to test the association you just made, assign the Layout to a preset key of the Kaleido 
RCP by pressing and holding for at least 6 seconds one of the 10 function keys located at the top 
of the Kaleido RCP device, then click on the Text Label Component to unlatch your Alarms. 

 



Configuring Features 

How to configure router cross point control on the Kaleido-K2? 

The Kaleido–K2 can control an external router to change its cross points. To be able to do so you 
should have a Router supported by Miranda (contact your Miranda dealer to find out which 
routers are currently supported). 

You first need to install the Router Control Software to be able to control your router. Typically the 
software is installed on an External computer, and the Router is connected to this computer using 
a serial port. Please see the Router Control user’s manual for more information on how to install 
and configure your Router Control software. 

Once you have your Router Control software installed and configured, you will need to configure 
the Kaleido-K2 to be able to deal with your router. Each configured router has a Miranda Long ID 
that enables us to identify that device on the network. You will first need to retrieve this Long ID, 
then create an alias for it, and finally configure the Router Reference Table that identifies the 
physical connections between the Kaleido and the Router. 

Getting the Router’s Long ID 
 
Case 1:  The router is installed on a Miranda Application Server (“Appserver”)   

• Use internet explorer to access the Appserver 

• Click on System Tools  

• Click on Administration 

• Enter username and password 

• Click on File Manager 

• Go to : 

/usr/local/iControl/bin/tmp/ 

There, you will find the Long ID of all routers installed on the Appserver. Identify the 
router you need from it’s name, which will be embedded in the Long ID, e.g.: 

10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX 
  
Case 2:   The router is installed on the Kaleido 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”.  

• Navigate to  

C:\iRouter\iControl\bin\tmp 



There, you will find the Long ID of all routers installed on the Kaleido. Identify the router 
you need from it’s name, which will be embedded in the Long ID, e.g.: 

10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX 

Creating an Alias for the Router’s Long ID 

After finding the router’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the router’s 
Long ID you can skip this section, but we highly recommend you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheRouter” 
id=”10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX”/> 

Where: 

• TheRouter is the nickname you want to use for the router 

• 10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX is the router’s Long ID you 
just retrieved. 

• Save the KG2Config.xml file. 

• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml: 



 

Configuring the Router Reference Table 

It is now time to configure the physical connection between the Kaleido and the Router. 

• From within your KEdit connect online to your Kaleido-K2 (select “Open” from “File” menu 
and then select “Online” or press “Ctrl-O” and choose the Kaleido-K2). 

• Select “Router Reference Table” from the “View” menu or press “F4” to display the “Router 
Reference Table”. 

• From the Router Reference Table select the “New” button. You are ready to create a new 
entry in the Router Reference Table. 

• An entry is used to inform the Kaleido about the link between an output of the router and an 
input of the Kaleido-K2. 

• In the Router ID field, put the alias you created for your Router. 



• In the Router Level, put the level of your router (0 based). Note that if you have several 
levels (e.g. 0 for Video, 1 for audio), you can enter the two levels separated by a comma (e.g. 
0, 1). If you have more than one level, the cross points will be set on all the levels, thus you 
need to be sure that the levels are identically wired (i.e. the input 1 of the video level must 
have its audio on the input 1 of the audio level). 

• In the Router Output field, put the output of the router you are configuring. 

• And in the Kaleido Input field, put the equivalent Kaleido input, i.e. the input that is 
connected to the router output you just entered. 

• When you’re done click on the Ok button. 

• You should see the new entry in the Router Reference Table. 

• Repeat this for all the Kaleido Inputs that are connected to the Router. 

Once you have configured your Router Reference Table, you can control your router. There are 
several ways to control the router, all of which are explained here. 

Using KEdit 

You can change cross points using the KEdit. This function is available only in online mode. 

• From within your KEdit connect online to your Kaleido-K2 (select “Open” from “File” menu 
and then select “Online” or press “Ctrl-O” and choose the Kaleido-K2). 

• Select the destination monitor, that is, the monitor that will receive the new router input. 

• Right-click on the monitor and select Unlock Monitor from the popup menu. The Monitor 
border will turn yellow, indicating it is unlocked, and you now have access to the individual 
components inside it. 

• Select the Video Component and select “Configuration Panel” from the “View” menu or 
press “F5” or double-click on the video Component to display the “Configuration Panel”. 

• In the Assignment tab, you have a field called Router Input. This field shows you the 
current router source viewed in this Video Component. 

• Enter a new source input, and then click on the Apply button. 

• The cross point should have been set. Note that for this to work, your Kaleido input must 
have been configured in the Router Reference Table. 

Using the pop-up menu 

You can use the mouse of the Kaleido-K2 system to change cross points. 

• Go on your Kaleido-K2 and with your mouse, right-click on a Video Component whose 
input is configured within the Router Reference Table. A popup menu should appear. 

• Click on the “Router Cross Point” item. 



• Then choose the router source you want to have (note that we show you the label 
associated with the input), and click on it. 

• The cross point should have been set. You can verify it using the pop-up menu: a check 
mark should appear beside the current router source associated to this Video Component. 
Note that if the Video input has been configured for more than one level (in the Router 
Reference Table), then the cross point has been set on all the levels. 

Using an Action 

You can also use Actions to change cross points. 

Here are the steps to create the Action that will change a cross point: 

• Open KEdit 

• Select “Open” from the “File” menu and then the “Online…” menu item or press the “Ctrl-
O” keys. 

• Select the Kaleido-K2 from the list. 

• Click on the “Open” button. 

• Open the Action Browser by selecting “Action Browser” from the “View” menu or by 
pressing the F9 key. 

• Select the “New” button, the “Action Configuration” dialog should appear. 

• Enter a name to associate with the Action in the “Name” field. 

• Click in the “Type” column of the first row and select “Router Cross Point”. The Router 
Cross Point Configuration dialog should appear. 

• In the Router ID field, put the alias you created for your Router. 

• In the Router Output field, put the output of the router you want to change. 

• In the Router Level, put the level of your router (0 based). 

• And in the Router Input field, put the input you want to set. 

• Click on the “Ok” button. 

• Click on the “Save” button. 

The Action is now created and it should appear in the list of the Action Browser. To be useful this 
Action needs to be associated with a Trigger. Here is how to configure your Layout so the defined 
Action will be executed when a Video Component is clicked: 

• Select a Video and display the “Configuration Panel” 

• Click on the “Action” tab. This tab allows the association of Action to Triggers. 



• Click on the drop down beside “Action On Single Click” and select the name of your 
Action. 

• Click on the “Apply” button. 

The Action is now assigned to the single click Trigger of the selected Video Component. To test 
what you just configured go on your Kaleido-K2 and, using the mouse, click on the Video to which 
you assigned the Action. You should have your cross point changed to what you configured. 

Note that you can also launch this action using the Gateway. See the user’s manual for more 
information on how to do this. 

How to operate the Count Down Timer Component? 

In operation mode you can start, stop and modify the preset value of the Count Down Timer. 
Following are the steps to do this via the Gateway or using an Action. 

Using the Gateway 

It is possible to operate the Kaleido-K2 using the Gateway. The Gateway is a very flexible and 
powerful tool that is usually used through a program but the Gateway can also be used via telnet. 
The following explanations will guide you through the use of the Gateway via the HyperTerminal 
software. 

Open the HyperTerminal software on your computer, and from the “Program” menu choose 
“Accessories”, “Communications” and “HyperTerminal”. A dialog will appear, asking you to enter 
a name for the connection and to select an icon.  

A second dialog, “Connect To”, will appear. In the “Connect using” dropdown field choose 
“TCP/IP (Winsock)”. Two new fields will appear, in the “Host address” field enter the IP address of 
your Kaleido-K2 and in the “Port number” field enter “13000”. This indicates that you want to 
connect to your Kaleido-K2 via the port 13000. Click on the “OK” button.  

To be able to see the typed character: 

• Select “Properties” from the “File” menu, the “Properties” dialog box appears.  

• Go to the “Settings” tab, click on the “ASCII Setup…” button located at the bottom of the 
dialog  

• Select “Echo typed characters locally”. 

• Click on the “OK” button and click again on the “OK” button from the “Properties” dialog.  

You can now see the typed characters appearing in the console. 

Commands can be sent to the Gateway while a session is open. There is no maximum number of 
commands that can be sent in a session. A session must be opened and closed using two 
specific commands. While sending a command the syntax must be exact. If you make a mistake 
in the syntax, the command will not be understood. Here is a rough example of a session: 

Open a session 



send command 
send command 
… 
send command 

Close the session. 

To open a session enter the following command: 

<openID>IP_ADDRESS_0_4_0_0</openID> 

Where: 

• IP_ADDRESS is the IP address of your destination Kaleido-K2. 

If the Gateway receives the command, and recognizes it as a command that can be handled, it 
will send you the following response: 

<ack/> 

If the command cannot be recognized the following message will appear: 

<nack/> 

If you received this message, please consult the Gateway documentation included on the 
Kaleido-K2 CD to troubleshoot the installation and communication. 

You are now ready to send commands. There are commands to start the Count Down Timer, 
stop the Count Down Timer, reset the Count Down Timer and modify its configuration. 

To configure a Count Down Timer: 

<setKTimer>set id=”ID” preset=”99:99:99” direction=”Direction” loop=”State” </setKTimer> 

Where: 

• ID is the identifier of the Count Down Timer to configure. 

• 99:99:99 is the new preset of the Count Down Timer. 

• Direction is either UP or DOWN to indicate the direction of the count. 

• State is either ON or OFF and indicates if the Count Down Timer must count continuously. 

To start, stop or reset a Count Down Timer: 

<setKTimerTrigger>set id=”ID” trigger=”Trigger”</setKTimerTrigger> 

Where: 

• ID is the identifier of the Count Down Timer on which the action will take place. 

• Trigger is any of START, STOP or RESET. 



You can execute as many commands as you want. When you want to stop sending commands 
you have to close the session. The following command is used to close a session: 

<closeID>IP_ADDRESS_0_4_0_0</closeID> 

Where: 

• IP_ADDRESS is always the IP address of the Kaleido-K2. 

Your session is now closed. 

To end the communication, select the “Disconnect” icon from the toolbar. 

Using an Action 

Set the Preset Value and Start the Count Down Timer 

You can use an Action to modify the preset value and start the Count Down Timer at the same 
time. This means that you could, with a single click on your Layout, set the preset value of a 
Count Down Timer to 15 seconds and start counting. This operation can be done in either off-line 
or on-line mode. The following explanations will guide you through the operation while in on-line 
mode. 

Here are the steps to create the Action that will start the Count Down Timer: 

• Open KEdit 

• Select “Open” from the “File” menu and then the “Online…” menu item or press the “Ctrl-
O” keys. 

• Select the Kaleido-K2 from the list. 

• Click on the “Open” button.  If the current Layout doesn’t contain a Count Down Timer 
Component add one. 

• Select the Count Down Timer and open the “Configuration Panel” by selecting 
“Configuration Panel” from the “View” menu or press the F5 key. Note the Timer ID 
assigned to the Count Down Timer. 

• Open the Action Browser by selecting “Action Browser” from the “View” menu or by 
pressing the F9 key. 

• Select the “New” button, the “Action Configuration” dialog should appear. 

• Enter a name to associate to the Action in the “Name” field. 

• Click in the “Type” column of the first row and select “Timer”. The Timer Configuration 
dialog should appear. 

• Enter the Timer ID of the Count Down Timer you want to modify and start. 

• In the preset field enter the new preset of the Count Down Timer. This field works like a 
time code field: if you want to set the preset to 30 sec enter 3-0 and it should display 
“00:00:30”. 



• Select the direction of counting: indicating “Up” will make the Timer go from 0 to the 
specified preset and specifying “Down” will make the Timer go from the preset to 0. 

• Click on the “Ok” button. 

• Click on the “Save” button. 

The Action is now created and it should appear in the list of the Action Browser. To be useful this 
Action needs to be associated with a Trigger. Here is how to configure your Layout so the defined 
Action will be executed when a Text Label Component is clicked: 

• Select a Text Label and display the “Configuration Panel” 

• Click on the “Action” tab. This tab allows the association of Actions to Triggers. 

• Click on the drop down beside “Action On Single Click” and select the name of your 
Action. 

• Click on the “Apply” button. 

The Action is now assigned to the single click Trigger of the selected Text Label Component. To 
test what you just configured go on your Kaleido-K2 and, using the mouse, click on the Text Label 
to which you assigned the Action. You should see your Count Down Timer modified and started. 

Stop the Count Down Timer 

You can use an Action to stop the Count Down Timer. This means that you can, with single or 
double clicks on your Layout, stop the Count Down Timer. 

To create the Action follow the steps described in the previous section but when clicking in the 
“Type” column of the Action List choose the “Timer Pause” option. The “Timer Pause 
Configuration” dialog should appear:  

• Enter the ID of the Timer Count Down you want to stop.  

• Click on the “Ok” button. 

• Click on the “Save” button of the Action Browser. 

The Action is now created and it should appear in the list of the Action Browser. To be useful this 
Action needs to be associated with a Trigger. Here is how to configure your Layout so the defined 
Action will be executed when a Status Indicator Component is double-clicked: 

• Select a Status Indicator and display the “Configuration Panel” 

• Click on the “Action” tab. This tab allows the association of Actions to Triggers. 

• Click on the drop down beside “Action On Double Click” and select the name of your 
Action. 

• Click on the “Apply” button. 

The Action is now assigned to the double click Trigger of the selected Status Indicator 
Component. To test what you just configured go on your Kaleido-K2. Make sure your Count 



Down Timer is currently counting and, using the mouse, double click on the Status Indicator to 
which you assigned the Action. You should see that the Count Down Timer stops. 

How to configure the Layout to use Quality Control Monitors on 
the Kaleido-K2? 

The Quality Control Monitor uses the capability of the Kaleido–K2 to control an external router. To 
be able to do so you should have a Router supported by Miranda (contact your Miranda dealer to 
find out which routers are currently supported). 

You first need to install the Router Control Software to be able to control your router. Typically the 
software is installed on an External computer, and the Router is connected to this computer using 
a serial port. Please see the Router Control user’s manual for more information on how to install 
and configure your Router Control software. 

Once you have your Router Control software installed and configured, you will need to configure 
the Kaleido-K2 to be able to deal with your router. Each configured router has a Miranda Long ID 
that enables us to identify that device on the network. You will first need to retrieve this Long ID, 
then create an alias for it, and finally configure the Router Reference Table that identifies the 
physical connections between the Kaleido and the Router. When you’ve done configuring your 
setup, you can configure your monitors to be in Quality Control mode. 

If you already have your Kaleido configured to control a router, you can skip the following section 
and go directly to the section “Configuring the Monitors to be in Quality Control mode.” 

Getting the Router’s Long ID 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.log” using the Notepad (right 
click on the “Kaleido.log” file and select “Notepad” from the “Open With” menu).  

• Within Notepad, press “Ctrl-F” or select “Find…” from the Edit menu and in the “Find What” 
section enter “serviceAdded called for ID:”. 

Each entry found will give you a Miranda Long ID. Continue looking through the file until you 
find the Long ID of your Router. The Long ID of a router should have the following form:  

10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX. 

Where 10.6.5.8 is the IP address of the computer controlling the router. 

Creating an Alias for the Router’s Long ID 

After finding the router’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the router’s 
Long ID you can skip this section, but we highly recommend you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 



• Enter the following line: 

<Service ServiceLabel=”TheRouter” 
id=”10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX”/> 

Where: 

• TheRouter is the nickname you want to use for the router 

• 10.6.5.8_COM1_YourRouter_00_SLOTXX_MODULEIDXXXX is the router’s long ID 
you just retrieved. 

• Save the KG2Config.xml file. 

• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml:  

 



Configuring the Router Reference Table 

It is now time to configure the physical connection between the Kaleido and the Router. 

• From within your KEdit connect online to your Kaleido-K2 (select “Open” from “File” menu 
and then select “Online” or press “Ctrl-O” and choose the Kaleido-K2). 

• Select “Router Reference Table” from the “View” menu or press “F4” to display the “Router 
Reference Table”. 

• From the Router Reference Table select the “New” button. You are ready to create a new 
entry in the Router Reference Table. 

• An entry is used to inform the Kaleido about the link between an output of the router and an 
input of the Kaleido-K2. 

• In the Router ID field, put the alias you created for your Router. 

• In the Router Level, put the level of your router (0 based). Note that if you have several 
levels (e.g. 0 for Video, 1 for audio), you can enter the two levels separated by a comma (e.g. 
0, 1). If you have more than one level, the cross points will be set on all the levels, thus you 
need to be sure that the levels are identically wired (i.e. the input 1 of the video level must 
have its audio on the input 1 of the audio level). 

• In the Router Output field, put the output of the router you are configuring. 

• And in the Kaleido Input field, put the equivalent Kaleido input, i.e. the input that is 
connected to the router output you just entered. 

• When you’re done click on the Ok button. 

• You should see the new entry in the Router Reference Table. 

• Repeat this for all the Kaleido Inputs that are connected to the Router. 

Once you have configured your Router Reference Table, your Kaleido-K2 can control your router. 
It is now time to configure the monitors for the Quality Control mode. 

Configuring the Monitors to be in Quality Control m ode. 

To configure a Monitor to be a Quality Control Monitor, follow these steps: 

• From within your KEdit connect online to your Kaleido-K2 (select “Open” from “File” menu 
and then select “Online” or press “Ctrl-O” and choose the Kaleido-K2). 

• Select the monitor you want to configure. 

• Right-click on the monitor and select Unlock Monitor from the popup menu. The Monitor 
border will turn yellow, indicating it is unlocked, and you now have access to the individual 
components inside it. 

• Select the Video Component and select “Configuration Panel” from the “View” menu or 
press “F5” or double-click on the Component to display the “Configuration Panel”. 



• In the Action tab, select the checkbox called “Use this monitor as target quality Monitor”. 
You will see that the Action On Double Click becomes grayed out. 

• Click on the Apply button. 

• On your Kaleido-K2, you should see some gray corner markers (└, ┘, ┌ and ┐) around 
the Video Component, indicating that your monitor is configured to be a Quality Control 
Monitor. 

You can repeat these steps for each monitor you want to configure for Quality Control. 

Operate the quality Control Monitor. 

Once at least one monitor has been configured to be a Quality Control Monitor, you can operate 
the Kaleido-K2. To do so: 

• On your Kaleido-K2, use your mouse to double-click on a Quality control Monitor. The 
corner markers should become white. 

• At this time, you have selected your destination. 

• You can then click on any other Video Component that has been configured in the Router 
Reference Table. When you click on a Video Component, the Kaleido will take the router 
source that feeds this Video and change a Router cross point so that this router source 
will also be displayed in the quality Control Monitor. 

• If you have more than one Monitor designated as a Quality Control Monitor, you can 
switch to any other one just by double-clicking on it. The newly selected Monitor will have 
white corners, and the previous one will revert to gray corners, showing that it is no longer 
the active Quality Control Monitor. 

• When you have finished with the Quality Control Mode, and want to revert to a Normal 
operation mode, just double-click on the current Quality control Monitor. Its corners should 
become gray. 

How to use the Text Label Component with the “Dynam ic Text” 
option? 

The Text Label Component can be configured to be used with static or dynamic text. The 
dynamic text option will allow you to set the text to display using a TSL, an Andromeda, an 
Encoda, a router, a Kalypso or the Gateway while your Layout is online. 

Note that this procedure also works for a UMD component. 



Modifying a Dynamic Text Label using a TSL 

Connection to the Kaleido-K2 

Located on the rear panel of the control panel, two control ports are available. 

COM1: RS-232 Can be used to connect to the TSL controller. You need a 
converter from RS-232 to RS-422 in this case because the TSL ports are all 
RS-422.  

COM2: RS-422/485 : Is mainly used for connecting the Kaleido-RCP. 

Make sure the pinout from the TSL to the Kaleido-K2 COM port 
is null modem.  

 

 

Installing the TSL option 

Use the Kaleido-K2's CD-ROM and locate the folder named "Options". Inside this folder, select 
the following file and double click:  

"TSLSetup_X_xx.exe"  where X and xx are version numbers and will change with each release. 

During the installation you need to select the appropriate communication port; COM1 or COM2. 
Refer to the first section for details. 

Now that the TSL controller is connected to the Kaleido-K2, you can get the TSL “ID” as defined 
by Miranda’s iControl community. You will need this ID to configure each dynamic text or Tally 
component inside your layouts. Because this unique identifier is long and complex to remember, 
it is suggested that you create an alias in the configuration files and use this alias as a substitute.  

Getting the TSL service’s Long ID 

The long ID is made up of the IP address of the Kaleido-K2, the COM port on which the TSL 
controller is connected, and the name TSL.  

e.g. 10.9.8.7_COM1_TSL 

To verify that this is correctly installed and active, you may want to follow the following procedure. 



• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\TSL”  

The Long ID of a TSL should have the following form:  

10.9.8.7_COM1_TSL 

Creating an Alias for the TSL’s Long ID 

After finding the TSL’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the complete 
TSL’s Long ID when configuring Components you can skip this section, but we highly recommend 
you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheTSL” id=”10.9.8.7_COM1_TSL”/> 

Where: 

• TheTSL is the nickname to use for the TSL. You can enter any Alphanumeric characters 
here. 

• 10.9.8.7_COM1_TSL is the just retrieved TSL’s Long ID. 

• Save the KG2Config.xml file. 

• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml: 



 

Configuring the Text Label Component to be modified by a TSL. 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so its displayed text will be driven by a TSL. These steps are executed from KEdit. 

• Select a Text Label Component. 

• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “Configuration Panel” select “Label Dynamic Text”. 

• In the “ServiceID” field type the alias of the TSL or the TSL Long ID if you choose to use 
the Long ID instead of an alias. 

• In the “Text Address” field enter the address to associate with this Text Label. This value 
must range between 1 and 127. 



• In the “Level” field enter the value that represents what you want to use from the data 
located at the specified address: 

• 0: you want to use the 16 characters 

• 1: you want to use the first 8 characters 

• 2: you want to use the last 8 characters. 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a Channel to use. 

• Click on the “Apply” button to apply your modifications to the Text Label Component. 

 

The Component is now configured to take the text to display from the specified address of the 
TSL and to display a part of or all the characters found at this address. Considering that your TSL 
is already available to your Kaleido, all you have to do now to see the text appearing in the Text 
Label is to apply your Layout on your Kaleido-K2. 



Configuring Dynamic Tallies from the TSL 

To configure the Tallies sourced from the TSL, you must first create Alarm Monitors. These Alarm 
Monitors can then be assigned to any components that have alarm behavior in your layout i.e. 
Text Label color, UMD color, Tally, Video border or Status Indicators. 

Creating an alarm monitor 

Access Kaleido-K2’s alarm resources by opening the Alarm Browser from the View menu, or by 
using F7. The browser shows a list of existing Alarm Monitors, and the Alarm Inhibition group with 
which each alarm monitor is associated, if any. Click on the header of either column to sort the 
table in ascending order according to that column.  

Create a new Alarm:  Click New to add a new 
alarm monitor to this list. A blank Alarm Monitor 
control panel will open.  

 

Click inside the Type column and select the Tally type.  

Service ID:  Enter either the Miranda LongID or the Alias 
for the service that will be monitored by this alarm. 

Text Address: Enter the address of the dynamic data 
[between 1 and 127]. 

Level: Enter the level of the dynamic data. 

The level can be 0, 1 or 2 and have a particular meaning. 
The TSL box has 4 Tallies per address, but the Kaleido is 
able to treat only 2 Tallies per address (one left and one 
right), so here is the rule followed to retrieve the Tally left 
and Tally right status: 

 

Level Umd shows Tally Left Tally Right 

0 16 chars T1 or T3 T2 or T4 

1 First 8 chars T1 T2 

2 Last 8 chars T3 T4 

 



Create an Alarm Monitor for every Tally device to be 
displayed in the Kaleido-K2 layout. 

 

Assigning an Alarm Monitor to a Video border.  

 

You can use the border around the periphery of the 
video to display the 4 Tally states. This method is 
the same if the UMD, the Text Label or the Status 
Indicator is used to display the Tally status. 

Select the video component, press F5 to display 
the configuration panel and select the Border Tab. 

Configure the Disable, Normal, Warning and Error 
colors to match with the Tally state: 

 

Assign Alarm Monitor:  

Select the alarm monitor “Tally 1” that you just 
created and assign it to that border. The status of 
the alarm will be shown by the border.  

 

Repeat this procedure for every Tally inside the layout.   

Assign an Alarm Monitor “Tally 1” to individual Tally components. 



 

Click the Select… button beside each of the four 
states to select the Tally colors that will represent that 
state. A Tally Colors selection box will appear, 
offering eleven options (bright and dark versions of 
five colors, plus invisible. You can also specify if the 
Tally will flash for all states. 

Assign the “Tally 1” Alarm Monitor that you have just 
created using the pull down menu in Tally 
Assignment.  

The shape of the icon in the tally color window 
reflects the type of tally being configured (Left Tally in 
the example here), as the same configuration panel 
opens for all four types (top, bottom, left and right). 

 

Because you are using independent Tallies, you need to assign the right and left Tally 
individually. Use the same Alarm Monitor for both but configure different color scenarios for left 
and right to differentiate the states. Repeat this procedure for every Tally inside the layout.   

Left Tally 

 

Right Tally 

 

Following this scenario: 

No Tally activated = Both Tallies are Invisible 

Both Preview and Program activated = Both Tallies activated Yellow  

Tally Preview activated = Left Tally activated Green 



Tally Program activated = Right Tally activated Red 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now the Layout that is currently displayed on the selected Kaleido-K2. You can 
assign the modified Layout to a preset key of the Kaleido RCP by pressing and holding one of the 
10 function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) of your keyboard 
for at least 6 seconds to assign the modified Layout to that preset key. 

The texts and the Tallies will then be dynamically updated from the TSL device.  

Modifying a Dynamic Text Label using an Andromeda 

Connection to the Kaleido-K2 

Located on the rear panel of the control panel, two control ports are available. 

COM1: RS-232: Recommended for connection to the Andromeda controller.  

COM2: RS-422/485: Is mainly used for connecting the Kaleido-RCP. 

 

Installing the Andromeda option 

Use the Kaleido-K2's CD-ROM and locate the folder named "Options". Inside this folder, select 
the following file and double click:  

phillips ("AndromedaSetup.exe") 



The installer will automatically install the device to the COM1 port. 

To change the serial port settings of the Thomson-Andromeda, use the xml files located on your 
Kaleido system under c:\iControl\Startup\Phillips\umdcfg.xml. 

Now that the Andromeda controller is connected to the Kaleido-K2, you can get the Andromeda 
“ID” as defined by Miranda’s iControl community. You will need this “ID” to configure each 
dynamic text or Tally component inside your layouts. Because this unique identification is long 
and complex to remember, it is suggested that you create an alias in the configuration files and 
use this alias as a substitute.  

Getting the Andromeda service’s Long ID 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\Phillips”  

The Long ID of an Andromeda should have the following form:  

10.9.8.7_COM1_UMD_00_SLOTXX_MODULEIDXXXX 

Where: 

• 10.9.8.7 is the IP address of the computer controlling the Andromeda. 

• COM1 is the communication port on which the Andromeda is connected. 

Creating an Alias for the Andromeda’s Long ID 

After finding the Andromeda’s ID you can create an alias, which is a “nickname” you could use 
while configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the 
complete Andromeda’s Long ID when configuring Components you can skip this section, but we 
highly recommend you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheAndromeda” 
id=”10.9.8.7_COM1_UMD_00_SLOTXX_MODULEIDXXXX”/> 

Where: 

• TheAndromeda is the nickname to use for the Andromeda. You can enter any 
Alphanumeric characters here. 

• 10.9.8.7_COM1_UMD_00_SLOTXX_MODULEIDXXXX is the just retrieved Andromeda’s 
Long ID. 

• Save the KG2Config.xml file. 



• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml file: 

 

Configuring the Text Label Component to be modified by an Andromeda. 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so its displayed text will be driven by an Andromeda. These steps are executed from 
KEdit. 

• Select a Text Label Component. 

• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “Configuration Panel” select “Label Dynamic Text”. 



• In the “ServiceID” field type the alias of the Andromeda or the Andromeda Long ID if you 
choose to use his Long ID instead of an alias. 

• In the “Text Address” field enter the address to associate to this Text Label. This value 
must range between 1 and 256. 

• In the “Level” field enter the level to associate to this Text Label. This value must range 
between 0 and 14. 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a Channel to use. 

• Click on the “Apply” button to apply your modifications to the Text Label Component. 

 

The Component is now configured to take the text to display from the specified address and level 
of the Andromeda. Considering that your Andromeda is already available to your Kaleido, all you 
have to do now to see the text appearing in the Text Label is to apply your Layout on your 
Kaleido-K2. 

Configuring Dynamic Tallies from the Andromeda 

To configure the Tallies sourced from the Andromeda, you must first create Alarm Monitors. 
These Alarm Monitors can then be assigned to any components that have alarm behavior in your 
layout i.e. Text label color, UMD color, Tally, video border or status indicators. 



Creating an Alarm Monitor 

Access Kaleido-K2’s alarm resources by opening the Alarm Browser from the View menu, or by 
using F7. The browser shows a list of existing Alarm Monitors, and the Alarm Inhibition group with 
which each alarm monitor is associated, if any. Click on the header of either column to sort the 
table in ascending order according to that column.  

Create a new Alarm:  Click New to add a new 
alarm monitor to this list. A blank Alarm Monitor 
control panel will open.  

 



Alarm Setting –Tally 

Click inside the Type column and select the Tally type.  

Service ID:  Enter either the Miranda LongID or the Alias 
for the service that will be monitored by this alarm. 

Text Address: Enter the address of the dynamic data 
[between 1 and 256]. 

Level: Enter the level of the dynamic data [between 0 and 
15]. 

Create an Alarm Monitor for every Tally device to be 
displayed onto the Kaleido-K2 layout. 

 

Assigning the Alarm Monitor “Tally 1” to a Video border.  

 

You can use the border around the periphery of the video 
to display the 4 Tally states. This method is the same if the 
UMD, the Text Label or the Status Indicator is used to 
display the Tally status. 

Select the video component, press F5 to display the 
configuration panel and select the Border Tab. 

Configure the Disable, Normal, Warning and Error colors to 
match with the Tally state: 

 

Assign Alarm Monitor:  

Select the alarm monitor “Tally 1” that you just created and 
assign it to that border. The status of the alarm will be 
shown by the border.  

 



Repeat this procedure for every Tally inside the layout.   

To assign an Alarm Monitor to a Tally component: 

 

Click the Select… button beside each of the four states to 
select the Tally colors that will represent that state. A Tally 
Colors selection box will appear, offering eleven options 
(bright and dark versions of five colors, plus invisible. You 
can also specify if the Tally will flash for all states. 

Assign the “Tally 1” Alarm Monitor that you have just 
created using the pull down menu in Tally Assignment.  

The shape of the icon in the tally color window reflects the 
type of tally being configured (Left Tally in the example 
here), as the same configuration panel opens for all four 
types (top, bottom, left and right). 

 

Because you are using independent Tallies, you need to assign the right Tally and left Tally 
individually. Use the same Alarm Monitor for both but configure different color scenarios for left 
and right to differentiate the states. Repeat this procedure for every Tally inside the layout. 

Left Tally 

 

Right Tally 

 

Following this scenario: 

No Tally activated = Both Tallies are Invisible 

Both Preview and Program activated = Both Tallies activated Yellow  



Tally Preview activated = Left Tally activated Green 

Tally Program activated = Right Tally activated Red 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now on your Kaleido-K2, it is the Layout that is currently displayed on the selected 
Kaleido-K2. You can assign the modified Layout to a preset key of the Kaleido RCP by pressing 
and holding for at least 6 seconds one of the 10 function keys located at the top of the device. If 
you’re using a keyboard instead of the Kaleido RCP, press one of the 10 function keys (F1 
through F10) or your keyboard for at least 6 seconds to assign the modified Layout to a preset 
key. 

Modifying the displayed text 

To modify the text displayed by the Text Label Component you must use the software associated 
with the Andromeda operation. 



Modifying a Dynamic Text Label using an Encoda 

Connection to the Kaleido-K2 

Located on the rear panel of the control panel, two control ports are available. 

COM1: RS-232 Can be used to connect to the Encoda controller. You need a 
converter from RS-232 to RS-422 in this case because the Encoda ports are 
all RS-422.  

COM2: RS-422/485 : Is mainly used for connecting the Kaleido-RCP. 

 

 

Installing the Encoda option 

Use the Kaleido-K2's CD-ROM and locate the folder named "Options". Inside this folder, select 
the following file and double click:  

EncodaSetup_X_xx.exe  (The values X and xx will vary with the release you have purchased) 

During the installation you need to select the appropriate communication port; COM1 or COM2. 
Refer to the first section for details. 

Now that the Encoda controller is connected to the Kaleido-K2, you can get the Encoda “ID” as 
defined by Miranda’s iControl community. You will need this ID to configure each dynamic text 
component inside your layouts. Because this unique identifier is long and complex to remember, 
it is suggested that you create an alias in the configuration files and use this alias as a substitute.  

Getting the Encoda service’s Long ID 

The long ID is made up of the IP address of the Kaleido-K2, the COM port on which the Encoda 
controller is connected, and the name Encoda.  

e.g. 10.9.8.7_COM1_ENCODA 

To verify that this is correctly installed and active, you may want to follow the following procedure. 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\program files\miranda\encoda service\startup”  

The Long ID of an Encoda should have the following form:  

10.9.8.7_COM1_ENCODA 



Creating an Alias for the Encoda’s Long ID 

After finding the Encoda’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the complete 
Encoda’s Long ID when configuring Components you can skip this section, but we highly 
recommend you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheEncoda” id=”10.9.8.7_COM1_ENCODA”/> 

Where: 

• TheEncoda is the nickname to use for the Encoda. You can enter any alphanumeric 
characters here. 

• 10.9.8.7_COM1_ENCODA is the just-retrieved Encoda’s Long ID. 

• Save the KG2Config.xml file. 

• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml: 



 

Configuring the Text Label Component to be modified by an Encoda. 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so its displayed text will be driven by an Encoda. These steps are executed from 
KEdit. 

• Select a Text Label Component. 

• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking the Component or by pressing “F5”. 



• In the Assignment tab of the 
Configuration Panel, select “Label Dynamic 
Text”. 

• In the “ServiceID” field type the alias of 
the Encoda or the Encoda Long ID if you 
choose to use the Long ID instead of an 
alias. 

• In the “Text Address” field enter the 
address to associate with this Text Label. 
This value must range between 1 and 255 
for Encoda. 

• Level is not used by Encoda, so the 
contents of the data box will be ignored. 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a 
Channel to use. 

• Click on the “Apply” button to apply your 
modifications to the Text Label 
Component. 

 

 

The Component is now configured to take the text to display from the specified address of the 
Encoda and to display the characters found at this address. Considering that your Encoda is 
already available to your Kaleido, all you have to do now to see the text appearing in the Text 
Label is to apply your Layout on your Kaleido-K2. 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now the Layout that is currently displayed on the selected Kaleido-K2. You can 
assign the modified Layout to a preset key of the Kaleido RCP by pressing and holding one of the 



10 function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) on your keyboard 
for at least 6 seconds to assign the modified Layout to that preset key. 

The texts will then be dynamically updated from the Encoda device.  

 

Configuring Text Label for dynamic tracking from Ro uting switcher 

This is available when you have purchased the option MWS-Router CTRL or MWS-UMD. An 
installer is provided to install the iControl Router Manager from which the Kaleido-K2 will be 
querying the Source Labels. The Router Manager can be installed on the Kaleido-K2 itself or on a 
separate PC when several Kaleidos will be querying the labels. We recommend installing the 
Router Manager on a separate PC in this case to isolate the dynamic label service from one 
Kaleido in particular. Refer to the Router Manager installer provided with the option to install this 
service. The connection to the client PC or to the Kaleido-K2 to get the source label is done 
through the Ethernet via TCP-IP network.  

Text data base is configured in the iControl Router Manager.  

In order to be able to send information from a Router to a Text Label contained in a Kaleido-K2 
Layout, you must know the address of the Router on the network. It is also convenient to create 
an alias for this address. 

Getting the Router service’s Long ID 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.log” using the Notepad (right 
click on the “Kaleido.log” file and select “Notepad” from the “Open With” menu).  

• Within Notepad, press “Ctrl-F” or select “Find…” from the Edit menu and in the “Find What” 
section enter “serviceAdded called for ID:”. 

Each entry found will give you a Miranda Long ID. Continue looking through the file until you 
find the Long ID of your Router. The Long ID of a Router should have the following form:  

10.9.8.7_COM1_RouterName_00_SLOTXX_MODULEIDXXXX 

Where: 

• 10.9.8.7 is the IP address of the computer controlling the Router. 

• RouterName is the name you gave to your logical router in the iControl Router Manager. 

Creating an Alias for the Router’s Long ID 

After finding the Router’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the complete 
Router’s Long ID you can skip this section, but it is highly recommend that you use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 



• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheRouter” 
id=”10.9.8.7_COM1_RouterName_00_SLOTXX_MODULEIDXXXX”/> 

Where: 

• TheRouter is the nickname to use for the Router. 

• 10.9.8.7_COM1_RouterName_00_SLOTXX_MODULEIDXXXX is the just retrieved 
Router’s Long ID. 

Save the KG2Config.xml file. 

• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml file: 



 

Configuring the Text Label Component for dynamic tracking from the router. 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so a Router will drive its displayed text. These steps are executed from KEdit. 

• Select a Text Label Component. 

• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “Configuration Panel” select “Label Dynamic Text”. 

• In the “ServiceID” field type the alias of the Router or the Router Long ID if you choose to 
use its Long ID instead of an alias. 

• In the “Text Address” field enter the Router’s output number from which you want to 
retrieve the label. Valid values start at 1. 



• In the “Level” field enter the level of the router associated with this entry. Valid values start 
at 0 for this field. 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a Channel to use. 

• Click on the “Apply” button to apply your modifications to the Text Label Component. 

The Component is now configured to take the text to display from the specified output of the 
Router. Considering that your Router is already available to your Kaleido, all you have to do now 
to see the text appearing in the Text Label is to apply your Layout on your Kaleido-K2. 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now the Layout that is currently displayed on the selected Kaleido-K2. You can 
assign the modified Layout to a preset key of the Kaleido RCP by pressing and holding one of the 
10 function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) or your keyboard 
for at least 6 seconds to assign the modified Layout to a preset key. 

Modifying the displayed text 

To modify the text displayed by the Text Label Component you must use the software associated 
with the Router operation. 

Updating Dynamic Text Labels using the Gateway 

It is possible to modify the text of a Dynamic Text Label via the Gateway. 

Configuring the Text Label Component to be controlled by the Gateway. 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so its displayed text will be modifiable via the Gateway. These steps are executed 
from KEdit. 

• Select a Text Label Component. 



• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “Configuration Panel” select “Label Dynamic Text”. 

• In the “ServiceId” field type “Gateway”. Be sure to use a capital ‘G’. 

• In the “Text Address” field enter an identifier that will be used to identify this Text Label 
when sending its command via the Gateway. This identifier is limited to numeric 
characters. 

• Leave the “Level” field empty. 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a Channel to use. 

• Click on the “Apply” button to apply your modifications to the Text Label Component. 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now the Layout that is currently displayed on the selected Kaleido-K2. You can 
assign the modified Layout to a preset key of the Kaleido RCP by pressing and holding one of the 
10 function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) of your keyboard 
for at least 6 seconds to assign the modified Layout to a preset key. 

Modifying the displayed text 

The following explanations will guide you through the use of the Gateway via the HyperTerminal 
software in order to modify the text displayed by a Text Label Component. 

Open the HyperTerminal software on your computer, and from the “Program” menu choose 
“Accessories”, “Communications” and “HyperTerminal”. A dialog will appear, enter a name for the 
connection and select an icon. 

A second dialog, “Connect To”, will appear. In the “Connect using” dropdown field choose 
“TCP/IP (Winsock)”. Two new fields will appear; in the “Host address” field enter the IP address of 



your Kaleido-K2 and in the “Port number” field enter “13000”. This indicates that you will be 
connected to your Kaleido-K2 via the port 13000. Click on the “OK” button.  

To be able to see the typed characters: 

• Select “Properties” from the “File” menu, the “Properties” dialog box appears.  

• Go to the “Settings” tab, click on the “ASCII Setup…” button located at the bottom of the 
dialog  

• Select “Echo typed characters locally”. 

• Click on the “OK” button and click again on the “OK” button from the “Properties” dialog.  

You can now see the typed characters appearing in the console. 

Commands can be sent to the Gateway while a session is opened. There is no maximum number 
of commands that can be sent in a session. A session must be opened and closed using two 
specific commands. While sending a command the syntax must be exact. If you make a mistake 
in the syntax, the command will not be understood. Here is a rough example of a session: 

Open a session 

send command 
send command 
… 
send command 

Close the session. 

To open a session enter the following command: 

<openID>IP_ADDRESS_0_4_0_0</openID> 

Where: 

• IP_ADDRESS is the IP address of your destination Kaleido-K2. 

If the Gateway receives the command, recognizes it as a command that can be handled it will 
send you the following response: 

<ack/> 

If the command cannot be recognized the following message will appear: 

<nack/> 

If you received this message, please consult the Gateway documentation included on the 
Kaleido-K2 CD to troubleshoot the installation and communication. 

You are now ready to send commands. There is a command to use to change the text displayed 
by a Text Label Component. Here is the syntax of the command to send to change the text of a 
Text Component supporting Dynamic Text from the Gateway: 

<setKDynamicText>set address=”Identifier” text=”NewText”</setKCurrentLayout> 



Where: 

• Identifier is the identifier of the Text Label Component (the one you entered in the “Text 
Address” field while configuring the Component) 

• MyText is the text to display. 

If you received a <ack/> the specified text should now be displayed by the specified Text Label on 
your Kaleido-K2. 

You can execute as many commands as you want. When you want to stop sending commands 
you have to close the session. The following command is used to close a session: 

<closeID>IP_ADDRESS_0_4_0_0</closeID> 

Where IP_ADDRESS is always the IP address of the Kaleido-K2. 

Your session is now closed. 

To end the communication, select the “Disconnect” icon from the toolbar. 

Modifying a Dynamic Text Label using a Kalypso 

Connection to the Kaleido-K2 

Select a separate PC running Windows 2000/XP to install the standalone Kalypso service. This 
PC must have a least one free COM port as well as access to the Kaleido-K2 through TCP/IP 
connection. Physically connect the Kalypso equipment to this PC.  

Note: If the Kalypso equipment is a Ross Synergy series Production Switcher, then please refer 
to the following checklist when connecting to the Miranda Kalypso service:  

• make sure that the serial port settings between the Production Switcher and the Kalypso 
service match 

• make sure the baud rate selected is at least 38400 bps 

• On the Production Switcher, configure the Tally protocol to "COMPLETE" instead of 
"NORMAL" 

Installing the Kalypso standalone service 

Contact Miranda to obtain the optional Kalypso installer if you plan to use this third-party device.  

The Kalypso installer will be an executable file with a name something like 
"KalypsoSetup_X_XX.exe" 

The installer will automatically install the device to the COM1 port. 

To change the serial port settings of the Kalypso, use the kalypso.properties files located on your 
PC system under C:\Program Files\Miranda\Kalypso service\Startup\kalypso.properties 

Make sure the Kalypso equipment COM settings matches the one set for the Kalypso service. 



Now that the Kalypso controller is connected to the Kaleido-K2, you can get the Kalypso “ID” as 
defined by Miranda’s iControl community. You will need this “ID” to configure each dynamic text 
or Tally component inside your layouts. Because this unique identification is long and complex to 
remember, it is suggested that you create an alias in the configuration files and use this alias as a 
substitute.  

Running the Kalypso standalone service 

The Kalypso is a Windows service. As such, it is automatically started after installation. To take 
into account modifications to the kalypso.properties file, the service must be stopped and 
restarted using Windows service manager part of the Windows administrative tools. 

Getting the Kalypso service’s Long ID 

The long ID is made up of the IP address of the PC running the Kalypso service, the COM port on 
which the Kalypso controller is connected, and the name Kalypso.  

e.g. 10.9.8.7_COM1_KALYPSO 

To verify that this is correctly installed and active, you may want to follow the following procedure. 

• From your PC's desktop (the one where the Kalypso service is installed), double click on 
the icon “My Computer”. 

• Navigate to “C:\Program Files\Miranda\Kalypso service\Startup”. You should see a file 
named X.X.X.X_COMX_KALYPSO. 

This will give you the Miranda Long ID of the Kalypso service.  

Creating an Alias for the Kalypso's Long ID 

After finding the Kalypso’s ID you can create an alias, which is a “nickname” you could use while 
configuring your Kaleido. Here are the steps to create an alias. If you prefer to use the complete 
Kalypso’s Long ID when configuring Components you can skip this section, but we highly 
recommend you to use the alias. 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”TheKalypso” id=”10.9.8.7_COM1_KALYPSO”/> 

Where: 

• TheKalypso is the nickname to use for the Kalypso. You can enter any alphanumeric 
characters here. 

• 10.9.8.7_COM1_KALYPSO is the just-retrieved Kalypso’s Long ID. 

• Save the KG2Config.xml file. 



• You need to restart the Kaleido-K2 system, to be able to recognize the alias you just 
created. 

Example of a KG2Config.xml: 

 

Configuring the Text Label Component to be modified by a Kalypso 

The following explanations will guide you through the steps to take to configure a Text Label 
Component so its displayed text will be driven by a Kalypso. These steps are the same with a 
UMD. These steps are executed from KEdit. 

• Select a Text Label Component. 

• If the “Configuration Panel” is not already displayed display it by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “Configuration Panel” select “Label Dynamic Text”. 



• In the “ServiceID” field type the alias of the Kalypso or the Kalypso Long ID if you choose to 
use the Long ID instead of an alias. 

• In the “Text Address” field enter the address to associate with this Text Label. This value 
must range between 1 and 128 or 1 to 48 depending on the "Level" selected. 

• In the “Level” field enter the value that represents what you want to use from the data 
located at the specified address. 

• Level 0 to 3 implies that the "Text Address" represent a Kalypso device output. In that case 
the "Text Address" must range between 1 and 48.  

• 0: the label represents the initial background feed 

• 1: the label represents the initial and the previous background feed 

• 2: the label represents the previous background feed 

• 3: the label represents the current background feed 

• Level 4 implies that the "Text Address" represents a Kalypso device Source ID. In that 
case the "Text Address" must range between 1 and 128. 

• 4: the label represents the current source id background feed 

• If needed, adjust the transparency. 

• If wanted choose a Border. 

• If you’re online you can specify a Channel to use. 

• Click on the “Apply” button to apply your modifications to the Text Label Component. 



 

The Component is now configured to take the text to display from the specified address of the 
Kalypso and to display a part of or all the characters found at this address. Considering that your 
Kalypso is already available to your Kaleido, all you have to do now to see the text appearing in 
the Text Label is to apply your Layout on your Kaleido-K2. 

Configuring Dynamic Tallies from the Kalypso 

To configure the Tallies sourced from the Kalypso, you must first create Alarm Monitors. These 
Alarm Monitors can then be assigned to any components that have alarm behavior in your layout 
i.e. Text Label color, UMD color, Tally, Video border or Status Indicators. 

Creating an alarm monitor 

Access Kaleido-K2’s alarm resources by opening the Alarm Browser from the View menu, or by 
using F7. The browser shows a list of existing Alarm Monitors, and the Alarm Inhibition group with 
which each alarm monitor is associated, if any. Click on the header of either column to sort the 
table in ascending order according to that column.  



Create a new Alarm:  Click New to add a new 
alarm monitor to this list. A blank Alarm Monitor 
control panel will open.  

 

Click inside the Type column and select the 
Tally type.  

Service ID:  Enter either the Miranda LongID or 
the Alias for the service that will be monitored 
by this alarm. 

Text Address: Enter the address of the 
dynamic data [between 1 and 128]. The text 
address identifies a Kalypso source Id 

Level: ignored: 

 

Create an Alarm Monitor for every Tally device 
to be displayed in the Kaleido-K2 layout. 

 



Assigning an Alarm Monitor to a Video border.  

 

You can use the border around the periphery of the 
video to display the 4 Tally states. This method is 
the same if the UMD, the Text Label or the Status 
Indicator is used to display the Tally status. 

Select the video component, press F5 to display 
the configuration panel and select the Border Tab. 

Configure the Disable, Normal, Warning and Error 
colors to match with the Tally state: 

 

Assign Alarm Monitor:  

Select the alarm monitor “Tally 1” that you just 
created and assign it to that border. The status of 
the alarm will be shown by the border.  

 

Repeat this procedure for every Tally inside the layout.   

Assign an Alarm Monitor “Tally 1” to individual Tally components. 



 

Click the Select… button beside each of the four 
states to select the Tally colors that will represent that 
state. A Tally Colors selection box will appear, 
offering eleven options (bright and dark versions of 
five colors, plus invisible. You can also specify if the 
Tally will flash for all states. 

Assign the “Tally 1” Alarm Monitor that you have just 
created using the pull down menu in Tally 
Assignment.  

The shape of the icon in the tally color window 
reflects the type of tally being configured (Left Tally in 
the example here), as the same configuration panel 
opens for all four types (top, bottom, left and right). 

 

Because you are using independent Tallies, you need to assign the right and left Tally 
individually. Use the same Alarm Monitors for both but configure different color scenarios for left 
and right to differentiate the states. Repeat this procedure for every Tally inside the layout.   

Left Tally 

 

Right Tally 

 

Following this scenario: 

No Tally activated = Both Tallies are Invisible 

Both Preview and Program activated = Both Tallies activated Yellow  

Tally Preview activated = Left Tally activated Green 



Tally Program activated = Right Tally activated Red 

Applying the modified Layout to a Kaleido-K2 

The following explanations will guide you through the steps to take in order to apply the modified 
Layout on a Kaleido-K2: 

• From KEdit, using the Layout to apply as the current Layout, select “Apply Layout Online” 
from the “File” menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select the objects that need to be exported (hint: if 
the Layout is using a Channel you created for this Layout, you should choose to export at 
least the Channels). 

• Click on the “Load” button. 

Your Layout is now on your Kaleido-K2, and is the Layout that is currently displayed on the 
selected Kaleido-K2. You can assign the modified Layout to a preset key of the Kaleido RCP by 
pressing and holding for at least 6 seconds one of the 10 function keys located at the top of the 
device. If you’re using a keyboard instead of the Kaleido RCP, press one of the 10 function keys 
(F1 through F10) or your keyboard for at least 6 seconds to assign the modified Layout to a 
preset key. 

Modifying the displayed text 

To modify the text displayed by the Text Label Component you must use the software associated 
with the Kalypso operation. 

How to display thumbnails or streaming video on the  Kaleido-
K2? 

Kaleido-K2 has the ability to display streaming video or thumbnails coming from Allegro Encoders 
or Densité probes. The following steps explain how to add a Streaming Video Component to a 
Layout while connected online to a Kaleido-K2 and how to add a Streaming Video Component to 
a Layout while working with an offline Layout. 

Using an online Layout 

Identify the Kaleido-K2 on which you will apply the modifications and open KEdit. 

• Choose “Online” from the “Open” option of the “File” menu or press “Ctrl-O”. 

• Select the name of the Kaleido-K2 on which you want to apply your modifications from the 
list containing the discovered Kaleido-K2 and select “Open”. 

• The Layout contained in KEdit is now the Layout from the selected Kaleido-K2. The title of 
the Layout should begin with “ONLINE-“, which indicates you are now editing a Layout that is 
currently displayed on a Kaleido-K2. 



• From the Components toolbar, select the “Streaming Video” icon. Click on the Layout 
where you want the Component to appear and drag your mouse until the Component reaches 
the desired size. 

• If needed, resize (using the white squares located in the middle of each side and at the 
corners) the Component and move it. 

• If it is not already displayed, display the “Configuration Panel” by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “RTP” section the IP address and Feed Id fields must be completed. The values to 
enter in those fields will be different if you want to display data coming from an Allegro 
Encoder or from a Densité Probe. 

With a source coming from an Allegro Encoder: 

• In the “IP Address” text field enter the IP address of the encoder. This takes the form of 
“999.999.999.999”. 

• In the “Feed Id” text field enter the channel to use from the data stream, typically “C1” or 
“C2”. 

With a source coming from a Densité Probe: 

• In the “IP Address” text field enter the IP address of the Miranda Application Server that is 
controlling the probe. 

• In the “Feed Id” text field enter the card’s Long ID. 

• If you wish to use the Native Resolution click on the “Restore Native Resolution” button. 

• Click on the “Apply” button to apply your modifications to the Streaming Video Component. 

The added Streaming Viewer Component should now display the data it receives from the 
selected source. 

You can assign the modified Layout to a preset on the Kaleido RCP by pressing and holding one 
of the 10 function keys located at the top of the device for at least 6 seconds. Using a keyboard 
connected to your Kaleido-K2 press a function key (F1 through F10) for at least 6 seconds to 
associate it with the Layout. 

Using an offline Layout 

If it is not already opened, open the Layout to modify by selecting “File” from the “Open” item of 
the “File” menu or by pressing “Ctrl-F”. 

• From the Components toolbar, select the “Streaming Video” icon. Click on the Layout 
where you want the Component to appear and drag your mouse until the Component reaches 
the desired size. 

• If needed, resize (using the white squares located in the middle of each side and at the 
corners) the Component and move it. 



• If it is not already displayed, display the “Configuration Panel” by selecting “Configuration 
Panel” from the “View” menu or by double-clicking on the Component or by pressing “F5”. 

• In the “RTP” section the IP address and Feed Id fields must be completed. The values to 
enter in those fields will be different if you want to display data coming from an Allegro 
Encoder or from a Densité Probe. 

With a source coming from an Allegro Encoder: 

• In the “IP Address” text field enter the IP address of the encoder. This takes the form of 
“999.999.999.999”. 

• In the “Feed Id” text field enter the channel to use from the data stream, typically “C1” or 
“C2”. 

With a source coming from a Densité Probe: 

• In the “IP Address” text field enter the IP address of the Miranda Application Server that is 
controlling the probe. 

• In the “Feed Id” text field enter the card’s Long ID. 

• Click on the “Apply” button to apply your modifications to the Streaming Video Component. 

You can adjust the size and position of your Component. Save your modified Layout by selecting 
“Save” from the “File” menu or by pressing “Ctrl-S”. 

Applying the Layout to a Kaleido-K2 

The Layout you modified now needs to be applied on a Kaleido-K2 in order to use the 
modifications you made. Here are the steps to take in order to apply this Layout to a Kaleido-K2: 

• From KEdit, with the Layout to apply opened, select “Apply Layout Online” from the “File” 
menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• Click on the “Load” button. 

The Layout is now the currently displayed Layout on the selected Kaleido-K2. You can assign the 
modified Layout to a preset key on the Kaleido RCP by pressing and holding one of the 10 
function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) on your keyboard 
for at least 6 seconds to assign the modified Layout to a preset key. 

How to insert a custom logo on the Kaleido-K2? 

Inserting a logo and assigning it a custom image is different if you’re editing an online Layout (i.e. 
if you are editing the Layout currently displayed by the Kaleido-K2) or if you’re editing an offline 
Layout. 



Inserting a custom logo while working with an onlin e Layout 

If it is not already opened in your KEdit, open the Layout on which you want to make the 
modification: 

• Select “Open” then “Online” from the “File” menu of your KEdit or press “Ctrl-O”. 

• In the “Open Online Layout…” dialog choose the name of the Kaleido-K2 from which you 
want to edit the Layout and click on the “OK” button. 

Now it is time to add the Logo Component and assign it the desired image: 

• Click on the Logo icon from the Components toolbar. 

• Click on your Layout where you want the Logo to appear and drag the mouse until the 
Component’s size is what you need. You can resize the Logo Component by clicking on it 
and using the white squares and you can move the Component by clicking on it and 
dragging it where you want it to be. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. Currently it should give you 
information on the displayed image, which is by default the Miranda logo. 

• If your image is already in the list of available images, select it. If not, click on the “Add 
picture from file” icon located to the right of the list of available images. The “Add Logo 
Picture…” file picker should appear. Navigate to your image and choose it. Note that you 
navigate on the KEdit’s machine, not on the Kaleido one. If your image is on another 
machine than the KEdit’s one, navigate to it and select it. 

• Click on the “Open” button. The dialog will close and the name of the file you selected will 
appear as the selected one in the list of available images. The image will be automatically 
copied to your Kaleido-K2. 

• If needed, adjust the Transparency so it suits your needs. 

• Click on the “Apply” button located to the bottom of the dialog. 

Your logo should now display the image you selected. If your custom logo contains Black pixels 
(R=0, G=0 and B=0), then these pixels won’t be visible on the Kaleido. This is useful when you 
have non-square logos. 

You can assign the modified Layout to a preset. To do so using the Kaleido RCP press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your Kaleido-K2 press a function key 
(F1 through F10) for at least 6 seconds to associate it with the Layout. 

Inserting a custom logo while working with an offli ne Layout 

If it is not already opened, open the Layout to modify by selecting “File” from the “Open” item of 
the “File” menu or by pressing “Ctrl-F”.  

The following steps will guide you through the addition of a Logo Component: 

• Click on the Logo icon from the Components toolbar. 



• Click on your Layout where you want the Logo to appear and drag the mouse until the 
Component’s desired size is reached. You can resize the Logo Component by clicking on 
it and using the white squares and you can move the Component by clicking on it and 
dragging it where you want it to be. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. Currently it should give you 
information on the displayed image, which normally is the Miranda logo. 

• Click on the “Add picture from file” icon located to the right of the list of available images. 
The “Add Logo Picture…” file picker should appear. Navigate to the image to use and 
choose it. If your image is on another machine than the KEdit you’re working on navigate 
to it and select it. 

• Click on the “Open” button. The dialog will close and the name of the file you selected will 
appear as the selected one in the list of available images. 

•  If needed, adjust the Transparency so it suits your needs. 

• Click on the “Apply” button located to the bottom of the dialog. 

You should now see your customized Logo in your Layout. If your custom logo contains Black 
pixels (R=0, G=0 and B=0), then these pixels won’t be visible on the Kaleido. This is useful when 
you have non-square logos. You can adjust the size and position of your Component. Save your 
modified Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. 

Applying the Layout to a Kaleido-K2 

The Layout you modified now needs to be applied on a Kaleido-K2. Here are the steps to take in 
order to have the image file exported to the Kaleido-K2 as the Layout will be: 

• In your KEdit with the Layout to apply opened select “Apply Layout Online” from the “File” 
menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select at least “Images”: this means that the image 
files used by your Layout will be copied to your Kaleido-K2. 

• Click on the “Load” button. 

Your Layout and the image files are now on your Kaleido-K2, and your Layout is currently 
displayed on the selected Kaleido-K2. You can assign the modified Layout to a preset key of the 
Kaleido RCP by pressing and holding one of the 10 function keys located at the top of the device 
for at least 6 seconds. If you’re using a keyboard instead of the Kaleido RCP, press one of the 10 
function keys (F1 through F10) on your keyboard for at least 6 seconds to assign the modified 
Layout to a preset key. 

Please note that if a Layout is using a customized image and that this image is not present on the 
machine (either the Kaleido-K2 or the KEdit) where the Layout is used a default image indicating 
“Image Not Found” will be displayed in place of the absent image. 



How to change the background of a Layout? 

It is possible to use a custom image as a background to your Layout. You can do it while editing 
an online or offline Layout.  

Changing the background of an online Layout 

If it is not already opened in your KEdit, open the Layout for which you want to change the 
background: 

• Select “Open” then “Online” from the “File” menu of your KEdit or press “Ctrl-O”. 

• In the “Open Online Layout…” dialog choose the name of the Kaleido-K2 from which you 
want to edit the Layout and click on the “OK” button. 

Now it is time to change the displayed background: 

• Click on the background. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. It should give you information 
on the current background. 

• You can paint the whole background with a single color or you can choose to use an 
image (tiled or not). 

To paint the whole background with a color: 

• Click on the down arrow of the “Fill Color” icon located to the right of the image list. A 
dialog containing a few preset colors will appear. 

• If you want an invisible background (the background will be black) select the “Invisible” 
button. If the preset colors contain a color that suits your needs select it. If you want a 
color that is not part of the preset colors choose “More Colors…”; a sophisticated color 
chooser will appear. It will close when you choose a color. 

To use an image: 

• If your image is already in the list of available images, select it. If not, click on the “Add 
picture from file” icon located to the right of the list of available images. The “Add 
Background Picture…” file picker appears. Navigate to your image and choose it. Note 
that you navigate on the KEdit machine, not on the Kaleido. If your image is on another 
machine than KEdit, navigate to it and select it. 

• Click on the “Open” button. The dialog will close and the name of the file you selected 
will appear as the selected one in the list of available images. The image will be 
automatically copied to your Kaleido-K2. 

• If you want your image to be tiled select the “Tiled” option. 

• Click on the “Apply” button located at the bottom of the dialog. 

Your background should now be display the color or the image you selected. 



You can assign the modified Layout to a preset. To do so using the Kaleido RCP press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your Kaleido-K2 press a function key 
(F1 through F10) for at least 6 seconds to associate it with the Layout. 

Changing the background of an offline Layout 

If it is not already opened, open the Layout to modify by selecting “File” from the “Open” item of 
the “File…” menu or by pressing “Ctrl-F”.  

The following steps will guide you through the modification of the background: 

• Click on the background of your Layout. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. If it is not displaying 
information about the background click on the background again. 

• You can paint the whole background with a single color or you can choose to use an 
image (tiled or not). 

To paint the whole background with a color: 

• Click on the down arrow of the “Fill Color” icon located to the right of the image list. A 
dialog containing a few preset colors will appear. 

• If you want an invisible background (the background will be black) select the “Invisible” 
button. If the preset colors contain a color that suits your needs select it. If you want a 
color that is not part of the preset colors choose “More Colors…”; a sophisticated color 
chooser will appear. It will close when you choose a color. 

To use an image: 

• If your image is already in the list of available images, select it. If not, click on the “Add 
picture from file” icon located to the right of the list of available images. The “Add 
Background Picture…” file picker appears. Navigate to your image and choose it. If 
your image is on another machine than the KEdit you’re working on navigate to it and 
select it. 

• Click on the “Open” button. The dialog will close and the name of the file you selected 
will appear as the selected one in the list of available images. If you choose a file 
located on another machine, it will be automatically copied to your KEdit machine. 

• If you want your image to be tiled select the “Tiled” option. 

• Click on the “Apply” button located to the bottom of the dialog. 

You should now see your customized background in your Layout. Save your modified Layout by 
selecting “Save” from the “File” menu or by pressing “Ctrl-S”. 

Applying the Layout to a Kaleido-K2 

If you choose to display an image in the background of your Layout, the image file containing the 
image will need to be stored on your Kaleido-K2 in order for the Layout to be properly displayed 



when exported to the Kaleido-K2. Here are the steps to take in order to have the image file 
exported to the Kaleido-K2 along with the Layout: 

• In your KEdit with the Layout to apply opened select “Apply Layout Online” from the “File” 
menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select at least “Images”: this means that the image 
files used by your Layout will be copied to your Kaleido-K2. 

• Click on the “Load” button. 

Your Layout and the image files are now copied on your Kaleido-K2. The Layout that is currently 
displayed on the selected Kaleido-K2 is the Layout you just applied. You can assign the modified 
Layout to a preset key of the Kaleido RCP by pressing and holding one of the 10 function keys 
located at the top of the device for at least 6 seconds. If you’re using a keyboard instead of the 
Kaleido RCP, press one of the 10 function keys (F1 through F10) on your keyboard for at least 6 
seconds to assign the modified Layout to a preset key. 

Please note that if a Layout is using a customized image and that this image is not present on the 
machine (either the Kaleido-K2 or the KEdit) where the Layout is used, a default image indicating 
“Image Not Found” will be displayed in place of the absent image. 

How to change the audio scales and the ballistics o n the 
Kaleido-K2? 

It is possible to change the ballistic and the scale of an Audio Meter Component from an online 
Layout or from an offline Layout (an offline Layout is a Layout that is not the Layout currently 
displayed by a Kaleido-K2). 

Modifying the ballistic and the scale of an Audio M eter in an online 
Layout 

If it is not already opened in your KEdit, open the Layout of the Kaleido-K2 containing the Audio 
Meter to modify: 

• Select “Open” then “Online” from the “File” menu of your KEdit or press “Ctrl-O”. 

• In the “Open Online Layout…” dialog choose the name of the Kaleido-K2 from which you 
want to edit the Layout and click on the “OK” button. 

Now it is time to modify the Audio Meter: 

• Click on the Audio Meter to modify. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. It should display information 
on the selected Audio Meter. 

• Click on the “Appearance” tab. The fields of this tab will allow you to configure the ballistic 
and the scale to use for the selected Audio Meter. 



• In the “Meter Option” section, indicate the ballistic to use: you can select “VU”, “Peak” or 
both. While selecting the ballistic to use you should see that the scale to use is modified to 
use the default scale related to the selected ballistic. 

• If the selected scale is not the one you want to use for this Audio Meter you can select 
another one from the list. This list contains the names of the audio scales available on the 
Kaleido-K2. If no scale satisfies your needs, you can modify or create a scale: 

To modify an existing scale: 

• Be sure the audio scale is the one selected in the Scale drop down list. 

• Click on the “Advanced” button. 

• Configure the colors to use for each phase and the value representing the boundaries 
of the phases. 

• Click on the “Save” button. 

To create a new audio scale: 

• Click on the “Advanced” button. 

• Configure the colors to use for each phase and the value representing the boundaries 
of the phases. 

• Click on the “Save As…” button. 

• A dialog will appear. In this dialog you can either choose to save the audio scale under 
an existing name (doing so will overwrite the existing audio scale) or type a new name 
in the “Scale Name” text field. 

• Click on the “Save” button. 

• Click on the “Apply” button located at the bottom of the dialog to apply the selected 
ballistic and audio scale to the Audio Meter. 

Your Audio Meter now uses the configured ballistic and Audio Scale. 

Note that if you modified an Audio Scale, then every Audio Meter that is associated to this Audio 
Scale will have the modification. 

You can assign the modified Layout to a preset. To do so using the Kaleido RCP press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your Kaleido-K2 press a function key 
(F1 through F10) for at least 6 seconds to associate it with the Layout. 

Modifying the ballistic and the scale of an Audio M eter of an offline 
Layout 

If it is not already opened, open the Layout containing the Audio Meter to modify by selecting 
“File…” from the “Open” item of the “File” menu or by pressing “Ctrl-F”.  

Now it is time to modify the Audio Meter: 



• Click on the Audio Meter to modify. 

• Open the “Configuration Panel” by pressing “F5” or by double-clicking on the Component 
or by selecting “Configuration Panel” from the “View” menu. It should display information 
on the selected Audio Meter. 

• Click on the “Appearance” tab. The fields of this tab will allow you to configure the ballistic 
and the scale to use for the selected Audio Meter. 

• In the “Meter Option” section, indicate the ballistic to use: you can select “VU”, “Peak” or 
both. While selecting the ballistic to use you should see that the scale to use is modified to 
use the default scale related to the selected ballistic. 

• If the selected scale is not the one you want to use for this Audio Meter you can select 
another one from the list. This list contains the names of the audio scales available on the 
Kaleido-K2. If no scale satisfies your needs, you can modify or create an audio scale: 

To modify an existing audio scale: 

• Be sure the audio scale is the one selected in the Scale drop down list. 

• Click on the “Advanced” button. 

• Configure the colors to use for each phase and the value representing the boundaries 
of the phases. 

• Click on the “Save” button. 

To create a new audio scale: 

• Click on the “Advanced” button. 

• Configure the colors to use for each phase and the value representing the boundaries 
of the phases. 

• Click on the “Save As…” button. 

• A dialog will appear. In this dialog you can either choose to save the audio scale under 
an existing name (doing so will overwrite the existing audio scale) or type a new name 
in the “Scale Name” text field. 

• Click on the “Save” button. 

• Click on the “Apply” button located at the bottom of the dialog to apply the selected 
ballistic and audio scale to the selected Audio Meter. 

Save your modified Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. 

Note that if you modified an Audio Scale, then every Audio Meter that is associated to this Audio 
Scale will have the modification. 



Applying the Layout online on a Kaleido-K2 

If you modified or created a new Audio Scale you must also export it while exporting the modified 
Layout to the Kaleido-K2 of your choice in order to be able to use it. If you chose to modify an 
existing audio scale or if you created an audio scale with the same name used by another audio 
scale the previous one will be overwritten and the Layouts using this audio scale will use the one 
you just exported. 

Here are the steps to take in order to include the audio scales in the files exported to the Kaleido-
K2 when exporting the modified Layout: 

• In your KEdit with the Layout to apply opened select “Apply Layout Online” from the “File” 
menu or press “Alt-A”. The “Apply Layout Online…” dialog will appear. 

• Select the destination Kaleido-K2 from the list of the detected Kaleido-K2. 

• In the “Exporting data from KEdit” area select at least “Audio Scales”: this means that the 
files containing the audio scales used by your Layout will be copied to your Kaleido-K2. 

• Click on the “Load” button. 

Your Layout and the audio scale files are now copied on your Kaleido-K2. The Layout that is 
currently displayed on the selected Kaleido-K2 is the Layout you just applied. You can assign the 
modified Layout to a preset key of the Kaleido RCP by pressing and holding one of the 10 
function keys located at the top of the device for at least 6 seconds. If you’re using a keyboard 
instead of the Kaleido RCP, press one of the 10 function keys (F1 through F10) on your keyboard 
for at least 6 seconds to assign the modified Layout to a preset key. 

How to display close caption text on the Kaleido-K2 ? 

Kaleido-K2 can display close captioning text coming from a Densité probe (like the SCP-1121) or 
from an incoming feed. 

Displaying close caption text from a Densité probe 

The following steps describe how to create an Alias for the Densité probe, how to add a Close 
Caption Text Component that will display close caption text coming from a Densité probe to an 
online Layout (while the KEdit is connected to the Layout displayed by a Kaleido-K2) or to an 
offline Layout, and how to apply online a Layout on a Kaleido-K2. 

Creating an Alias for a Densité probe 

The first step is to get the Miranda Long ID from the Kaleido.log: 

• From your Kaleido-K2’s desktop, double click on the icon “My Computer”. 

• Navigate to “C:\iControl\Startup\” and open the file “Kaleido.log” using the Notepad (right 
click on the “Kaleido.log” file and select “Notepad” from the “Open With” menu).  

• Within Notepad, press “Ctrl-F” or select “Find…” from the Edit menu and in the “Find 
What” section enter “serviceAdded called for ID:”. 



Each entry found will give you a Miranda Long ID. Continue looking through the file until 
you find the Densité probe you are looking for (something like 
APPSERVERNAME_D1_DENSITE_SLOT_3_31). 

Note the probe’s address. 

Note that you can also retrieve the Miranda Long ID using the iNavigator application. Please refer 
to the iControl Navigator Manual for instructions. 

After you have found the Densité Probe’s ID you can create an alias. An alias is a “nickname” that 
can be used through-out the Kaleido-K2 instead of the probe’s Long ID when referring to the 
probe. Here are the steps to create an alias. If you prefer to use the Miranda Long ID you can 
skip these steps: 

• On your Kaleido-K2 machine, open the file “C:\iControl\Startup\KG2Config.xml” with 
Notepad. 

• Find the <OtherServices> section. 

• Enter the following line: 

<Service ServiceLabel=”MyService” id=” APPSERVERAME_D1_DENSITE_SLOT_3_31”/> 

Where: 

• “MyService” is the nickname you want to use for the device. 

• APPSERVERNAME_D1_DENSITE_SLOT_3_31 is the probe’s Long ID. 

• Save the KG2Config.xml file. 

• It is a good time to reboot your Kaleido-K2 system: doing so will allow the Kaleido-K2 to 
recognize and use the newly defined alias. 

Example of a KG2Config.xml file: 



 

Adding a Close Caption Text Component to an online Layout 

• From within your KEdit select “Open” from “File” menu and then select “Online” or press 
“Ctrl-O”. The “Open Online Layout” dialog appears. 

• Select the name of the Kaleido-K2 from which you want to edit the Layout and click on the 
“Open” button. The Layout that is currently displayed on the selected Kaleido-K2 is now 
opened in KEdit. 

• If you want to add the Close Caption Text Component to a Monitor, right-click on the 
Monitor and select Unlock Monitor from the popup menu. The Monitor’s border will turn 
yellow, indicating that you have access to its contents, and that Components added inside the 
border of the Monitor will be part of the Monitor. 

• From the Components toolbar select the Close Caption Text icon. 

• Click on the Layout where you want the Component to appear, drag the mouse to adjust 
the Component’s size to what you want it to be and release the mouse button. You can now 
move the Component by selecting it and dragging it where you want it to be positioned. You 



can resize the Component by using the white squares located on the corners and the sides of 
the Component when it is selected. 

• To configure the Component show the “Configuration Panel” by pressing “F5” or by double-
clicking on the Component or by selecting “Configuration Panel” from the “View” menu. 

• In the “Service ID” text field enter the alias of Densité probe from which the feed comes. 

• In the “Input Number” text field enter the input of the card. Typically it should be 1. 

• In the “Number of Lines” text field enter the number of lines to be displayed by the 
Component. 

• Adjust the transparency if necessary. 

• The last field to configure is the “VBI Link Order” field. It is used only if you added the Close 
Caption Text Component to a Monitor; if so, enter the link order to associate with this Close 
Caption Text Component. Typically this number will be ‘1’ and it will be incremented if the 
Monitor contains more than one Close Caption Text Component. 

• Click on the “Apply” button to apply the configured information to the Component. 

• If you added the Close Caption Text Component to a Monitor, click outside the Monitor so 
its border turns white again. If you are asked to save the changes made to the Channel, 
choose if you want to save the modified Channel by selecting “Save” or if you want to create 
a new Channel by choosing “Save As”. 

Your Close Caption Text Component now uses the configured Densité probe as its source. 

You can assign the modified Layout to a preset. To do so using the Kaleido RCP press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your Kaleido-K2 press a function key 
(F1 through F10) for at least 6 seconds to associate it with the Layout. 

Adding a Close Caption Text Component to an offline Layout 

• From within your KEdit select “Open” from “File” menu and then select “File…” or press 
“Ctrl-F”. The “Open File…” dialog appears. 

• Select the file containing the Layout to edit and click on the “Open” button. 

 If you want to add the Close Caption Text Component to a Monitor, right-click on the Monitor 
and select Unlock Monitor from the popup menu. The Monitor’s border will turn yellow, 
indicating that you have access to its contents, and that Components added inside the border 
of the Monitor will be part of the Monitor. 

• From the Components toolbar select the Close Caption Text icon. 

• Click on the Layout where you want the Component to appear, drag the mouse to adjust 
the Component’s size to what you want it to be and release the mouse button. You can now 
move the Component by selecting it and dragging it where you want it to be positioned. You 
can resize the Component by using the white squares located on the corners and the sides of 
the Component when it is selected. 



• To configure the Component show the “Configuration Panel” by pressing “F5” or by double-
clicking on the Component or by selecting “Configuration Panel” from the “View” menu. 

• In the “Service ID” text field enter the alias of Densité probe from which the feed comes, 
typically it should be the alias you just created. 

• In the “Input Number” text field enter the input of the card. Typically it should be 1. 

• In the “Number of Lines” text field enter the number of lines to be displayed by the 
Component. 

• Adjust the transparency if necessary. 

• The last field to configure is the “VBI Link Order” field. It is used only if you added the Close 
Caption Text Component to a Monitor; if so, enter the link order to associate with this Close 
Caption Text Component. Typically this number will be ‘1’ and it will be incremented if the 
Monitor contains more than one Close Caption Text Component. 

• Click on the “Apply” button to apply the configured information to the Component. 

• If you added the Close Caption Text Component to a Monitor, click outside the Monitor so 
its border turns white again. If you are asked to save the changes made to the Channel, 
choose if you want to save the modified Channel by selecting “Save” or if you want to create 
a new Channel by choosing “Save As”. 

• Save the modified Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. 

Your Close Caption Text Component now uses the configured Densité probe as its source. To be 
used, this Layout needs to be applied online to a Kaleido-K2. 

Applying a Layout online on a Kaleido-K2 

• From the KEdit open the Layout you want to load onto the Kaleido-K2. 

• From the “File” menu select the “Apply Layout Online” option or press “Alt-A”. The “Apply 
Layout Online” dialog appears. 

• Select the Kaleido-K2 on which you want to load the Layout from the list of available 
Kaleido-K2s. 

• Select the data that needs to be exported to the Kaleido-K2 in order to be able to use the 
Layout. That is, if the Layout uses images, audio scales, Actions or Alarms that were created 
for this Layout or that were modified for this Layout you need to indicate it by selecting what 
needs to be exported. 

• Select the “Load” button. 

The Layout should appear on the Kaleido-K2. You can assign the newly applied Layout to a 
preset key of the Kaleido RCP by pressing and holding one of the 10 function keys located at the 
top of the device for at least 6 seconds. If you’re using a keyboard instead of the Kaleido RCP, 
press one of the 10 function keys (F1 through F10) on your keyboard for at least 6 seconds to 
assign the modified Layout to a preset key. 



Displaying close caption text from an incoming feed  

The following steps describes how to configure a Kaleido-K2 so it will display close captioning 
text, how to add a Close Caption Text Component to an online Layout (while the KEdit is 
connected to the Layout displayed by a Kaleido-K2) or to an offline Layout and how to apply 
online a Layout on a Kaleido-K2. 

Configuring a Kaleido-K2 to decode VBI following the North American Standard 
(EIA 608) 

This operation can only be done while connected online to the Kaleido-K2: 

• From within your KEdit select “Open” from “File” menu and then select “Online” or press 
“Ctrl-O”. The “Open Online Layout” appears. 

• Select the name of the Kaleido-K2 to configure and click on the “Open” button. The Layout 
that is currently displayed on the selected Kaleido-K2 is now opened in KEdit. 

• Select “Setting” from the “View” menu and then “VBI/ANC Standard”. 

• In the “VBI/ANC Data Standard Selection” dialog choose “North American Standard (EIA 
608)”. 

• Click on the “Ok” button. 

Your Kaleido-K2 is now configured to decode close caption text. 

Adding a Close Caption Text Component to an online Layout 

• From within your KEdit select “Open” from “File” menu and then select “Online” or press 
“Ctrl-O”. The “Open Online Layout” appears. 

• Select the name of the Kaleido-K2 from which you want to edit the Layout and click on the 
“Open” button. The Layout that is currently displayed on the selected Kaleido-K2 is now 
opened in KEdit. 

 If you want to add the Close Caption Text Component to a Monitor, right-click on the Monitor 
and select Unlock Monitor from the popup menu. The Monitor’s border will turn yellow, 
indicating that you have access to its contents, and that Components added inside the border 
of the Monitor will be part of the Monitor. 

• From the Components toolbar select the Close Caption Text icon 

• Click on the Layout where you want the Component to appear, drag the mouse to adjust 
the Component’s size to what you want it to be and release the mouse button. You can now 
move the Component by selecting it and dragging it where you want it to be positioned. You 
can resize the Component by using the white squares located on the corners and the sides of 
the Component when it is selected. 

• To configure the Component show the “Configuration Panel” by pressing “F5” or by double-
clicking on the Component or by selecting “Configuration Panel” from the “View” menu. 

• In the “Service ID” text field enter the alias of the Kaleido-K2 from which the feed comes, 
most of the time you enter ‘A’ since the feed is located on the same Kaleido-K2 as your 



Layout. In an environment where many Kaleido-K2s are on the same network, you could 
want to get the close caption from another machine. In that case enter the alias of the other 
Kaleido-K2 (for more explications on aliases and how to work when many Kaleido-K2s are on 
the same network please consult the User’s Manual). 

• In the “Input Number” text field enter the video input number that contains the close caption 
text to display. 

• In the “Number of Lines” text field enter the number of lines to be displayed by the 
Component. 

• Adjust the transparency if necessary. 

• The last field to configure is the “VBI Link Order” field. It is used only if you added the Close 
Caption Text Component to a Monitor. If so, enter the link order to associate with this Close 
Caption Text Component. Typically this number will be ‘1’ and it will be incremented if the 
Monitor contains more than one Close Caption Text Component. 

• Click on the “Apply” button to apply the configured information to the Component. 

• If you added the Close Caption Text Component to a Monitor click outside of the Monitor so 
its border turns white again. If you are asked to save the changes made to the Channel, 
choose to save the modified Channel by selecting “Save” or to create a new Channel by 
choosing “Save As”. 

Your Close Caption Text Component now uses the configured input as its source. 

You can assign the modified Layout to a preset. To do so using the Kaleido RCP press and hold 
the function key (those keys are located to the top of the device) for at least 6 seconds to 
associate it with the Layout. Using a keyboard connected to your Kaleido-K2 press a function key 
(F1 through F10) for at least 6 seconds to associate it with the Layout. 

Adding a Close Caption Text Component to an offline Layout 

• From within your KEdit select “Open” from “File” menu and then select “File…” or press 
“Ctrl-F”. The “Open File…” dialog appears. 

• Select the file containing the Layout to edit and click on the “Open” button. 

• If you want to add the Close Caption Text Component to a Monitor double click on the 
Monitor so its border becomes yellow, this indicates that Components added inside the limits 
of the Monitor will be part of this Monitor. 

• From the Components toolbar select the Close Caption Text icon. 

• Click on the Layout where you want the Component to appear, drag the mouse to adjust 
the Component’s size to what you want it to be and release the mouse button. You can now 
move the Component by selecting it and dragging it where you want it to be positioned. You 
can resize the Component by using the white squares located on the corners and the sides of 
the Component when it is selected. 

• To configure the Component show the “Configuration Panel” by pressing “F5” or by 
selecting “Configuration Panel” from the “View” menu. 



• In the “Service ID” text field enter the alias of the Kaleido-K2 from which the feed comes, 
most of the time you enter ‘A’ since the feed is located on the same Kaleido-K2 as your 
Layout. In an environment where many Kaleido-K2s are on the same network, you could 
want to get the close caption from another machine. In that case enter the alias of the other 
Kaleido-K2 (for more explications on aliases and how to work when many Kaleido-K2s are on 
the same network please consult the User’s Manual). 

• In the “Input Number” text field enter the video input number that contains the close caption 
text to display. 

• In the “Number of Lines” text field enter the number of lines to be displayed by the 
Component. 

• Adjust the transparency if necessary. 

• The last field to configure is the “VBI Link Order” field. It is used only if you added the Close 
Caption Text Component to a Monitor. If so, enter the link order to associate with this Close 
Caption Text Component. Typically this number will be ‘1’ and it will be incremented if the 
Monitor contains more than one Close Caption Text Component. 

• Click on the “Apply” button to apply the configured information to the Component. 

• If you added the Close Caption Text Component to a Monitor, click outside of the Monitor 
so its border turns white again. If you are asked to save the changes made to the Channel, 
choose to save the modified Channel by selecting “Save” or to create a new Channel by 
choosing “Save As”. 

• Save the modified Layout by selecting “Save” from the “File” menu or by pressing “Ctrl-S”. 

Your Close Caption Text Component now uses the configured input as its source. To be used, 
this Layout needs to be applied online to a Kaleido-K2. 

Applying a Layout online on a Kaleido-K2 

• From the KEdit open the Layout you want to load onto the Kaleido-K2. 

• From the “File” menu select the “Apply Layout Online” option or press “Alt-A”. The “Apply 
Layout Online” dialog appears. 

• Select the Kaleido-K2 on which you want to load the Layout from the list of the available 
Kaleido-K2s. 

• Select the data that needs to be exported to the Kaleido-K2 in order to be able to use the 
Layout. That is if the Layout uses images, audio scales, Actions or Alarms that were created 
for this Layout or that were modified for this Layout you need to indicate it by selecting what 
needs to be exported. 

• Select the “Load” button. 

The Layout should appear on the Kaleido-K2. You can assign the newly applied Layout to a 
preset key of the Kaleido RCP by pressing and holding one of the 10 function keys located at the 
top of the device for at least 6 seconds. If you’re using a keyboard instead of the Kaleido RCP, 
press one of the 10 function keys (F1 through F10) on your keyboard for at least 6 seconds to 
assign the modified Layout to a preset key. 



How to stop the processing of Actions on the Kaleid o-K2? 

The Actions combined with the Schedule are an extremely powerful configuration tool. The user 
may configure very complex automated behavior. At the same time, it is possible to inadvertently 
program a repetitive loop of Actions. In order to stop such a loop of Actions and make some 
corrections to your Layout or Schedule, we provide this mean of stopping the processing of 
Actions. 

You need to open your KEdit and connect on-line to the Kaleido-K2. To do so: 

• From your KEdit select “Open” from the “File” menu and then “Online”. 

• Select the Kaleido-K2 from the list. You should now see the Layout from the Kaleido-K2 in 
your KEdit. 

Select “Settings” from the “View” menu and select the “Stop Action Processing” menu item. A 
check should appear at the left of the “Stop Action Processing” item indicating that this option is 
currently on. 

To restart the processing of Actions simply reselect the same option, the check should disappear 
indicating that the processing of Action objects is enabled. 

How to configure the Kaleido to display a specific Layout during 
the boot up sequence? 

You must open KEdit and create or open the Layout you want to use as your default boot up 
Layout. This Layout must be exported to the Kaleido-K2. To export a Layout to your Kaleido-K2: 

• Select “Apply Layout Online” from the “File” menu. The “Apply Layout Online” dialog 
should appear. 

• From the list of Kaleido-K2s, select the destination Kaleido. 

• Select the data that needs to be exported to the Kaleido-K2 at the same moment. 

• Click on the “Load” button to apply the Layout on the Kaleido-K2. The Layout should now 
be displayed on the selected Kaleido-K2. 

If the Layout you want to use as your default boot-up Layout is already on your Kaleido-K2 
connect online to this Layout. To do so: 

• Display the Layout on your Kaleido-K2 system. 

• From within your KEdit select “Open” from the “File” menu and then “Online” or press 
“Ctrl-O”. The “Open Online Layout” dialog should appear. 

• Select the Kaleido-K2 on which you want to set the boot-up Layout. 

Now it is time to indicate to the system that the displayed Layout will be the boot up Layout. To do 
so you must select “Setting” from the “View” menu and select “Save this Layout as default boot-
up Layout”. 



How to display Japanese text in the UMDs? 

First you need to get a font that supports Japanese: you need a Unicode font like “Arial Unicode 
MS”. Those fonts are usually accessible through the web. 

• Copy the font to the “C:\WINNT\Fonts\” folder of the computer where the KEdit is run. 

• Copy the same font to the “C:\WINNT\Fonts” folder of the Kaleido-K2. 

• Restart your Kaleido so that the software will recognize the new font. 

• Start the KEdit and open the Layout where you want to use this font. 

• Select the UMD Component that will display the Japanese characters and select the 
Unicode font you just copied from the drop-down located the toolbar of your KEdit. 

• Enter your Japanese text in the Configuration panel. 

• Apply and save your modifications. 

• Apply your Layout online on the Kaleido-K2 where you copied the font. 

• You should get your text displaying the Japanese characters. 

How to install and configure the Serial-to-TCP disp atcher? 

The purpose of the Serial-to-TCP dispatcher is to allow a Serial device to have access to the TCP 
network, while only having a physical serial connector available. In order for a Serial device to 
communicate to the Dispatcher that device needs to respect the Serial-to-TCP dispatcher 
protocol. This protocol is presented in a separate document. (link To Serial Dispatcher Protocol 
file )The following sections show you how to install, configure and run the Dispatcher service. 

Installing the Serial-to-TCP dispatcher 

Select a separate PC running Windows 2000/XP to install the standalone Serial-to-TCP 
dispatcher. This PC must have a least one free COM port as well as access to the Kaleido-K2 
through TCP/IP connection. Physically connect the 3rd party equipment to the COM port of this 
PC.  

Use the Kaleido-K2's CD-ROM and locate the folder named "Options". Inside this folder, select 
the following file and double click:  

"SerialDispatcher_X_XX.exe" 

Installation 
1. Double click on DispatcherSetup_XX.exe 
2. Click next in the first panel (introduction panel) 
3. Click next in the second panel (Important Note panel) 
4. Click install in the 3rd panel 
5. Click Done in the 4th panel  
6. The SerialToTCP Dispatcher will install automatically in the folder:   C:\Program 

Files\Miranda\Dispatcher 



 

Configuring the Serial-to-TCP dispatcher 

The installer will automatically install the device to the COM1 port. 

And the default the values of the current used Serial Port are: 

ComPort=COM1 

BaudRate=9600 

DataBits=8 

StopBits=1 

Parity=NONE 

To change the serial port settings of the Dispatcher, use the SerialPort.properties files located on 
your PC system under C:\Program Files\Miranda\Dispatcher\Startup\ 

Make sure the 3rd party equipment COM settings matches the one set for the Dispatcher. 

Running the Serial-to-TCP dispatcher 

The Dispatcher is a Windows service. As such, it is automatically started after installation. To take 
into account modifications to the SerialPort.properties file, the service must be stopped and 
restarted using Windows service manager part of the Windows administrative tools. 



Miscellaneous 

How to get the log files from Kaleido-K2? 

Kaleido-K2 logs information about the system, the discovered devices and problems 
encountered. The log files are located on the Kaleido-K2’s machine. To get those files: 

• On your Kaleido-K2 quit the application by pressing “Ctrl-Q”  

• From the Desktop, click on the “My Computer” icon and navigate to the 
“C:\iControl\Startup” folder. 

In this folder you will see the “Kaleido.log” file and possibly other files named “Kaleido.log.1”, 
“Kaleido.log.2” up to “Kaleido.log.5”. These files are all log files. 

To open a log file: 

• Select the log file you want to open. 

• Right click on it and select “Open With” from the contextual menu. 

• In the “Choose the program you want to use:” section select “Notepad” or any other text 
editor. 

• Select the “Always use this program to open these files” option. 

• Click on the “Ok” button. 

The selected text editor must let you access the selected log file. 

How to get the log files from KEdit? 

KEdit logs information about the system’s environment, the discovered devices, actions 
performed and problems encountered. The log files are located on the machine where the KEdit 
is used. To get those files: 

• Display the Desktop on the machine where KEdit is installed. 

• Click on the “My Computer” icon and navigate to the “C:\Program Files\Miranda\KEdit 
5.10\Startup” folder. 

In this folder you will see the “KEdit.log” file and possibly other files named “KEdit.log.1”, 
“KEdit.log.2” up to “KEdit.log.5”. These files are all KEdit log files. 

To open a log file: 

• Select the log file you want to open. 

• Right click on it and select “Open With” from the contextual menu. 



• In the “Choose the program you want to use:” section select “Notepad” or any other text 
editor. 

• Select the “Always use this program to open these files” option. 

• Click on the “Ok” button. 

The selected text editor must let you access the selected log file. 

How to monitor the Kaleido-K2 boot-up sequence? 

The first step is to locate your output card: when looking to the front of your Kaleido-K2 frame, the 
output card is the right-most one (slot 1). There can be another output card in your system 
located in slot 10 (count slots from right to left). 

There is a led located on the card; it should be green. Press on the black button located above 
the led for one second: you have entered the “bypass mode” and the led’s color should be rapidly 
changing between red and green. The way to distinguish between “normal” and “bypass” mode is 
by the color of the led; when it is green the card is in normal mode and when it is flashing (it can 
appear as orange) it is in bypass mode. 

You can now see the Window’s boot up sequence. When the graphic of your Layout appears, the 
process will be completed. To return to normal mode press on the black button of the output card 
for again one second. Note: the bypass mode conceals the video displays, and shows only the 
graphic components of the layout during operation; during boot up the graphic components are 
suppressed in favour of the Windows boot up display. 

How to get the current software version installed o n my system? 

Here are the steps to take in order to get the software version of the Kaleido-K2, KEdit or Kaleido-
Alto. 

To get the current software version from KEdit 

Select “About” from the “Help” menu. A dialog appears and the version of the software is 
indicated below the Miranda logo. 

To get the current software version from Kaleido-K2  

These steps must be executed from within KEdit. 

First you must get connected online to the Kaleido-K2 to interrogate: 

• Select “Open” and then “Online” from the “File” menu. 

• From the list of the accessible Kaleido-K2 select the one to interrogate. 

• Click on the “Open” button 

Your are now connected online to the selected Kaleido-K2. The next step is to get the Kaleido-K2 
system’s information: 



• Select “System Status” from the “View” menu or press “F8”. 

• The “System Info” dialog appears. In this dialog you will find information on your Kaleido-
K2 system. 

• The version of the software can be found beside the “Kaleido Software Version” tag. 

To get the current software version from Kaleido-Al to 

Information on your Kaleido-Alto system’s status can be found inside the “System” tab of the 
“Status” dialog. There is three possible ways to get the “Status” dialog: 

• Press on the “Status” button from the Kaleido-RCP. 

• Press on “Ctrl-Y” of your keyboard 

• Display the menu bar, select the “Menu” button and then the “Status” option.  

How to retrieve the firmware version from the log f ile? 

Kaleido-K2 logs information about the system, the discovered devices and problems 
encountered. The versions of the firmware in use in the system is also logged in the log file. 

First you must locate the log file: from the Desktop of your Kaleido-K2, click on the “My 
Computer” icon and navigate to the “C:\iControl\Startup” folder. In this folder you will see the 
“Kaleido.log” file and possibly other files named “Kaleido.log.1”, “Kaleido.log.2” up to 
“Kaleido.log.5”. These files are all log files but to get the most recent information you must use 
the “Kaleido.log” file. 

Then you must open the log file to search information in it. This research is conducted from the 
end of the file because the same log file is used for more than one session. The most recent 
information are added to the end of the file: 

• Select the “Kaleido.log” file to open. 

• Right click on it and select “Open With” from the contextual menu. 

• In the “Choose the program you want to use:” section select “Notepad” or any other text 
editor. 

• Select the “Always use this program to open these files” option if you want to always open 
your log files with the Notepad (or the selected text editor). 

• Click on the “Ok” button. 

• Position the cursor to the end of the file, either by using the scroll bar and clicking at the 
end of the text or by pressing “Ctrl-End”. 

• From the end of the file, press “Ctrl-F” or select “Find” from the “Edit” menu and use the 
“Find” tool to find text like the following example: 

960 [Thread-7]  INFO 
service.Kaleido2AVService:******************************************************* 



960 [Thread-7]  INFO service.Kaleido2AVService:  

960 [Thread-7]  INFO service.Kaleido2AVService:  

960 [Thread-7]  INFO service.Kaleido2AVService:Slot 3, Video input card (MWI-SDI). 

960 [Thread-7]  INFO service.Kaleido2AVService:Hardware version: 2, Package Number 
10, Mode: 0 

960 [Thread-7]  INFO service.Kaleido2AVService: DSP Version Sector 0: 212 

960 [Thread-7]  INFO service.Kaleido2AVService: DSP Version Sector 123: 112 

960 [Thread-7]  INFO service.Kaleido2AVService: FPGA Version In: 201 

960 [Thread-7]  INFO service.Kaleido2AVService: FPGA Version Out: 102 

In the log file, every line begins with the date and the time at which the entry is made 
using the following format: “YYYY-MM-DD HH:MM:SS”.  

You will find one block per occupied slot. This block contains information about the card detected 
and about firmware and hardware versions: 

• The first three lines are used to separate the blocks. 

• The fourth line indicates the slot number and the type of card found in it. 

• The next line indicates the hardware version, the package number and the mode. 

• The next two lines give information about the DSP version. 

• The last two lines are about the FPGA version. 

How to configure the Kaleido-K2 in networks includi ng more 
than two units and application servers? 

Miranda devices (iControl services) communicate with one another via a network. The lookup 
service allows the discovery of any of the devices so that they become part of the iControl 
community. For redundancy purposes, you may want to start a second lookup service on a local 
area network, but too many of these services will generate too much traffic on the network, 
leading to slower updates and slower operation.  

At the factory, all Kaleido-K2s are configured to start a lookup service automatically. If multiple 
Kaleido-K2s are installed inside the same network, we recommend disabling some of the lookup 
services to eliminate unnecessary network traffic. We also recommend starting the lookup service 
on the Application server. Two lookup services within a network are enough for redundancy and 
network traffic. 

Stopping and disabling a lookup service on a Kaleid o-K2  

• Go into the Services manager by double clicking on the Services Icon located on the 
Kaleido-K2 desktop. 



 

• Select “MT_JiniLookup” by single clicking on it with the mouse and stop the service by 
depressing the stop button located in the top toolbar.  

 

• Right click on “MT_JiniLookup” and select “Properties”. 



 

• In “Startup type”, use the drop down to select “Manual”. This way, the lookup service will 
not automatically start at next reboot: if you have to use the lookup service you will have to 
start it manually. 

• Reboot the Kaleido system. 

Note: If the Kaleido-K2 is then removed from the network and operated standalone, you must 
restart the lookup service on the Kaleido-K2 in order to re-establish the network device 
recognition. 

How to backup your Kaleido-K2 Layouts and configura tion files? 

Backup your files: 

• Establish a communication with your Kaleido-K2 through the network and copy the 
following files and folders located in “C:\iControl\Startup” to a secure location (possibly your 
KEdit PC). 

• actions 

• alarms 

• audioscale 

• channel 



• configuration 

• images 

• kaleido layouts 

• monitor 

• Kaleido-K2.kcf 

• KaleidoXmlSettings.xml 

• KG2Config.xml 

 



• These files and folders include all the Layouts, Channels, Alarm Monitors and other 
information you may have configured since your received your Kaleido-K2.  

Restore your data: 

• Quit the Kaleido application using <ctrl> + Q. 

• Reconnect your PC via the network to the Kaleido-K2 and copy the backup files to the new 
CPU.  

• Copy all the files previously backed up and paste them into the new MWA-CPU Dual at the 
location “C:\iControl\Startup” and accept to copy your backup files over the existing files. See 
message example bellow. 

 

How to use the MT-Gateway in unicast mode? 

By default, the MT-Gateway looks through the whole network (multicast mode) in order to find the 
MT_Lookup to which it will connect itself. In unicast mode, the Gateway connects itself to a 
specified MT_Lookup. To specify on which MT_Lookup to connect, the IP address of the 
MT_Lookup must be set in the Gateway.lax file: 

• On your Kaleido-K2 machine, use the Explorer to navigate to the folder C:\iControl\Startup. 

• Using Notepad, open the file “Gateway.lax”. 

• Just below the line containing “java.security.policy=C:\\\\jini\\policy\\policy.all” enter the 
following line: 

icontrol.gateway.unicast=Kaleido IP 

Where Kaleido IP is the IP of the machine where the targeted MT_Lookup runs. 



 

• Reboot your Kaleido-K2 machine. 

Note that the Internal Gateway on a Kaleido is incorporated into the Kaleido software and utilizes 
all of the Kaleido’s configurations. It does not use a lookup like the MT-Gateway. 

How to configure Synergy to use a single mouse and keyboard 
with multiple Kaleidos? 

Synergy is third-party software that enables control of multiple Kaleidos using a mouse and 
keyboard connected to one of them. Synergy is included on the CD-ROM that comes with your 
Kaleido. See the Quick Start Manual for instructions on loading it onto your Kaleidos. 

Server 

The Server is the Kaleido that has the mouse and keyboard used to control all Kaleidos in the 
group. 

Locate the Synergy folder installed on the Kaleido as explained in the Quick Start manual. In the 
folder, you will find the application synergy.exe. Double-click on it to start it. 

You will see the following dialog: 



 

Select the Server radio button, since you will first configure the server. 

You then need to add the definition of all your screens (i.e. all the Kaleidos including the server). 

To do so, click on the Add Button. A new dialog will appear: 



 

In this dialog, enter the name of the Kaleido (the name is the hostname of the machine). In the 
section aliases, enter the IP address of the machine. Leave the Options and Modifiers at their 
default values. Then, click on OK. 

Repeat the previous steps to define all the screens you have on your setup. 

Note that a screen represents a Kaleido, so on multi-head systems, a screen can be seen as all 
the displays connected to the Kaleido. 

Once the Screens have been defined, you can configure the link between them. To do so, select 
a screen, and on the right select the screens that link to it. 

Repeat this configuration for all the screens to configure your layout of displays. 

Now that you have configured your setup, you need to setup the Synergy application to start 
automatically at startup. To do so, click on the Configure… button, and select a way to start the 
Synergy application automatically. Note that it is preferred to start it when the Kaleido starts 
(doing this will enable the keys <ctrl>+<alt>+<delete> to work correctly). 

Click Close, then click Save to store your configuration. You can now start the Synergy server by 
clicking on Start. 

To quit the configuration dialog, click on Quit. 

Client 

A Client is a Kaleido that will be controlled by the server’s mouse and keyboard. 



Locate the Synergy folder installed on the Kaleido as explained in the Quick Start manual. In the 
folder, you will find the application synergy.exe. Double-click on it to start it. 

You will see the following dialog: 

 

Ensure that Client is selected, then enter the hostname of the server (the Kaleido that has the 
mouse and keyboard). 

Now that you have configured the server hostname, you need to set up the Synergy application to 
start automatically at startup. To do so, click on the Configure… button., and select a way to start 
the Synergy application automatically. Note that it is preferred to start it when the Kaleido starts 
(doing this will enable the keys <ctrl>+<alt>+<delete> to work correctly). 

Click Close, then click Save to store your configuration. You can now start the Synergy client by 
clicking on Start. 

To quit the configuration dialog, click on Quit. 

Repeat those steps for every client you have to control. 

Extra configuration 

Now you should have your setup working correctly. With the mouse and keyboard of the server, 
you should be able to control the client Kaleidos seamlessly. 



Note that you can always control the client Kaleido with its own mouse and keyboard, without any 
interference with Synergy. 

Remove mouse from clients 

If you don’t want to have a mouse and a keyboard connected on the client Kaleido, you will need 
to set up the machine so that the mouse cursor is visible. 

To do so, follow those steps: 

• Open the Control panel 

• Select Accessibility Options 

• Select the Mouse tab. 

• Check Use MouseKeys 

• Then click on OK 

Now shut down the Kaleido, remove the keyboard and the mouse, and restart it. Synergy will 
connect correctly to the Kaleido, and you will be able to control the Kaleido correctly 

How to import csv files to and export csv files fro m KEdit? 

The Data Explorer provides the access point to csv file import and export functions. 

1. Open the Data Explorer from the View menu via View����Data Explorer, or use the shortcut 
Shift+F5  

2. Right-click on a Kaleido in the Tree portion of the Data Explorer to open its contextual menu, 
then click to select either the import or the export option. 

 



Import data from a csv file 

If you select Import data from csv… , the following browser window will open: 

 

Browse to locate the csv file you require, click to select it, and then click on Import. 

The imported channels will be saved on the Kaleido that belongs to the current active layout. 

• if the current layout is an offline layout, the channels will be saved on the KEdit computer, 

• if the current layout is an online one, the channels will be saved on the Kaleido machine. 

If a channel of the same name already exists, a replace confirmation dialog will appear as follows: 

 

• If the user selects Yes, this specific channel will be replaced. 

• If the user selects Yes to All , all the channels will be replaced. 

• If the user selects No, this specific channel won’t be replaced, but the process will continue. 

• If the user selects Cancel , the operation is aborted. 

 

Export data to a csv file 

If you select Export data to csv… , the following browser window will open: 



 

Browse to the location where you wish to store the csv file, and enter a name for the csv file using 
either of these methods: 

• Type a name for the csv file in the file name window  

• If you want to replace an existing csv file in that location, click on it to select it, and its name 
will appear in the File name window. 

Click on Export to store the channels from the Kaleido associated with the current active layout in 
the named csv file. 

• If the csv file already exists, a dialog will appear asking you to confirm that you want to 
replace it. 

How to configure the Kaleido-K2 to support differen t displays? 

Some available screens that can be used to display the Kaleido-K2 output require input signals 
conforming to standards that are not included in the default resolution set of the Kaleido-K2. The 
Kaleido-K2 will work with these displays once the appropriate resolution definitions are installed. 
The Kaleido-K2 can work with either its default resolutions, or the display-specific resolutions, but 
both cannot be installed at the same time.  

Note that the nominal resolutions of these displays appear in the pulldown list on the Output 
Configuration control panel (open it using F11 in KEdit) for the default resolutions), but these will 
not work due to some specific signal timing issues. 

If you have selected the appropriate resolution for your display from the Output Configuration 
panel and find that it does not work correctly, you should install the resolution files for your display 
type. 

Here are instructions on how to install the display-specific resolutions, and how to re-install the 
default set shipped with Kaleido-K2: 



Install the display-specific resolution files 

In order for the Kaleido-K2 to work correctly with the supported displays, you will need to replace 
some files on the Kaleido itself. Use the mouse and keyboard connected to the Kaleido. 

• First quit the Kaleido-K2 application, by pressing <Ctrl> + Q keys. 

• Then open Windows explorer, and browse to the folder c:\iControl\Startup\resolution 

• In this folder you will find folders for the supported displays, listed by manufacturer’s name. 
Within the Manufacturer folders are folders for the individual display models. 

 

Manufacturer Supported displays 

Barco OverviewDR 
OverviewDR+ 

Christie DS25 

Clarity Baycat 

BobcatX 

Margay 

Panasonic TH-42PHD6 
TH-50PHD 

RCA (all) 

Sanyo PLV-42 

Sharp LC-65G5M 

Sony Qualia004 

SDM-P232W 

Tecnovision (all) 

• Copy-Paste all the .krs files that reside in the folder for your display type into the Resolution 
folder. Doing this will replace the default resolutions with resolutions appropriate for your 
display.  

NOTE – You must COPY – PASTE these files into the R esolution folder, leaving 
the original files in the Display folder.  

DO NOT DRAG-AND-DROP THE FILES, BECAUSE THE ORIGINA L FILES WILL BE 
LOST THE NEXT TIME YOU OVERWRITE THEM IN THE RESOLUTION FOLDER 

• Accept to replace the files, and then restart the Kaleido application. 

Revert back to the default resolutions 

If you want to reconfigure your Kaleido to support the default resolutions, follow these steps, 
using the mouse and keyboard connected to the Kaleido: 

• First quit the Kaleido-K2 application, by pressing <Ctrl> + Q keys. 



• Then open Windows explorer, and browse to the folder c:\iControl\Startup\resolution 

• In this folder you will find a folder called Factory. 

• Copy-Paste all the .krs files that reside in the Factory folder to the resolution folder.  

NOTE – You must COPY – PASTE these files into the R esolution folder, leaving 
the original files in the Factory folder.  

DO NOT DRAG-AND-DROP THE FILES, BECAUSE THE ORIGINA L FILES WILL BE 
LOST THE NEXT TIME YOU OVERWRITE THEM IN THE RESOLUTION FOLDER 

• Doing this will restore the default resolutions. Accept to replace the files, and then restart the 
Kaleido application. 

 

How to restore proper font appearance when the Kale ido Display 
is rotated 90° 

If the Kaleido display is rotated 90 degrees, the display font used for Text labels, UMDs, Digital 
Clocks and Count Down Timers may appear to be compressed horizontally, i.e. the characters 
will appear squeezed. Miranda provides a special font with wider-than-usual characters that will 
appear correct after the compression The user must install this special font, called Wide Arial, to 
display these characters correctly.  

To install the special font 

• In Windows’ Fonts folder, copy the font WIDEA___.TTF that is found in C:\Program 
Files\Miranda\KEdit 5.21\Tools.  (The Windows Font folder is located under C:\WINDOWS\ 
on Windows Xp and C:\WINNT\ on Windows 2000) 

• Restart KEdit to make the Wide Arial font available in the font list 

 

Select the affected components, and choose the font Wide Ariel from the font pulldown on the 
Edit Toolbar.  



Considerations when interconnecting a Ross Synergy series 
Production switcher with the Kalypso service 

Here is a checklist to verify when connecting a Ross Synergy series Production switcher with the 
Miranda Kalypso service: 

· make sure that the serial port settings between the Production Switcher and the Kalypso 
service match 

· make sure the baud rate selected is at least 38400 bps 

· On the Production Switcher, configure the Tally protocol to "COMPLETE" instead of 
"NORMAL" 

 

 


