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Introduction 

 
Kahuna Manager is a software application that enables users to: 

• Resize and position files images within various SMPTE video standard formats. 
• Save files in .SWS format for use by the Kahuna system. 
• Preview images to be transferred to or from the Kahuna system. 
• Transfer stills or video clips to the Kahuna system. 
• Import stills/clips from a Kahuna system. 
• Convert an .SWS clip to an .AVI file. 
• Convert an .AVI file to individual .BMP frames, and if audio is present, a .WAV file. 
• Convert an uncompressed audio .WAV file to an .SWS audio file. 

 
 
Installing Kahuna Manager 

To install the Kahuna Manager software, double click on the Kahuna Manager zipped 
file and extract all the files to a user defined area on the PC that will run the software, 
then follow the steps below: 

1. The extracted files should be as shown below, double click on the 
KManager.msi icon and the software will start to install. 

 
2. When the “Welcome” screen appears press Next, then check the “I 

accept” end user license agreement and press Next. 
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3. Select the type of installation (Typical, Custom or Complete) required  and 
press Next, then in the Ready to Install menu press Install. 

 
 

 
 

4. Finally press Finish to complete the installation. A Kahuna manager icon 
will have been placed on the desktop, double click on the icon to start 
Kahuna Manager software running.
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Kahuna Manager Main Menu 
 

Once the Kahuna Manager software is running, the first menu that will appear is the 
Kahuna Manager main menu. This menu is where the user sets up Kahuna Manager 
and selects files to convert into .SWS stills and clips. 
 

 
 
If Kahuna Manager is going to be networked to a Kahuna mainframe, it is advisable to 
setup the network link as described in the next section. 
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Setting up Kahuna Link 

Kahuna link established communications between a Kahuna mainframe and the PC on 
which Kahuna Manager is installed. This enables stills, video, and audio files to be 
transferred between Kahuna and Kahuna Manager without the need for an external 
USB storage device, such as a USB memory stick. 
Kahuna Manager supports direct access to Kahuna and Kahuna for transferring and 
exporting still and clips via swnfs. 

 
To set up Kahuna Link: 

In the main Kahuna Manager menu select “Options>Stills/Clip manager>Setup Kahuna 
Link” 

 
 
If this is the first the first time that a link has been setup a dialog box stating that there is 
an error may appear, if this happens click on “OK” and the menu below will appear 
“Setup Kahuna Link” click on “Configure” and the Kahuna IP Address will be displayed. 
 
 

 
The user now has 3 choices, they can enter an IP Address directly into the text entry box 
and click on “OK”, click on the browse button and a new menu (Available Mainframes) 
will appear – shown on the next page, or click on the {Remote IP Networks} button. 

Browse Button 

Important Note: 
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If the Kahuna Manager software is able to see other mainframes on the network then 
all the available Kahuna mainframes will be displayed in this menu. Click on one of the 
mainframes and press “OK” to connect to one of the mainframes. 

 

 
Remote IP Networks 

 
The Mainframes may sit on a different network to the PC. Setting the Mainframes Gateway IP 
ensures response data finds its way back to the PC. 
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Click on Settings>Configure>IP Mainframes (as in the menu below) and the Mainframe 
IP Addresses menu will appear. 
 

 
 

Mainframe IP Addresses 
 
This menu allows the user to manually input a known Master IP Address and 
corresponding Return Path Gateway. It is only necessary to use this option if the network 
disallows UDP Broadcasting 
 

 
Add the master IP Address and Return Path Gateway, and press {OK}. 
Once back in the Remote IP Networks menu, add the Return Path Gateway address 
and the Mask Bits, press the {Add IP Network} button. Then press {OK}. 
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IP Settings – Remote IP Networks and Return Port Number 

 
Kahuna Manager uses a Kahuna File Service (swnfs) to transfer and export stills/clips.  
The file service needs a heartbeat to ensure efficient communication between Kahuna 
Manager and a Kahuna or Kahuna Mainframe.  
 

 
Remote IP Networks 

 
Again this link goes to the Remote IP Networks menu. The Mainframes may sit on a different 
network to the PC. Setting the Mainframes Gateway IP ensures response data finds its way 
back to the PC. 
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Click on Settings>Configure>IP Mainframes (as in the menu below) and the Mainframe 
IP Addresses menu will appear. 
 

 
 

Mainframe IP Addresses 
 
This menu allows the user to manually input a known Master IP Address and 
corresponding Return Path Gateway. It is only necessary to use this option if the network 
disallows UDP Broadcasting 
 

 
Add the master IP Address and Return Path Gateway, and press {OK}. 
Once back in the Remote IP Networks menu, add the Return Path Gateway address 
and the Mask Bits, press the {Add IP Network} button. Then press {OK}.
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Return Port Number is used to inform the Kahuna Mainframe of its UDP comms port 
number (used for Kahuna mainframe response messages Default 5986 for Kahuna and 
5987 for Kahuna). 
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Using the Still Store Browser 

 
Use the Still Store Browser to search the current directory, either on the local computer 
or on the Kahuna mainframe, for stills, video, or audio files. After locating the files, they 
can be manipulated within various SMPTE video standard formats and saved for use in 
Kahuna 
 

 
 
Browsing for files 

 
The still store browser can browse for files accessible to the local machine, or on the 
Kahuna mainframe. 
To browse for local files: 

1. Below the folder list on the right of the Still Store Browser window, click 
Local. 

2. Use the folder list to navigate to the directory containing the correct files. 
The files available to Kahuna Manager are displayed in the pane on the 
left of the Still Store Browser window. 

To browse for files on the Kahuna mainframe: 
1. Below the folder list on the right of the Still Store Browser window, click 

Kahuna. 
2. Use the folder list to navigate to the directory containing the correct files. 

The files available to Kahuna Manager are displayed in the pane on the 
left of the Still Store Browser window. 

Kahuna Link must be set up before files stored on the Kahuna mainframe can be 
accessed. 

Note: 
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The Resize and Position functions allow images to be manipulated within various SMPTE 
video standard formats. As well, they allow images to be saved in the .SWS format so 
that they can be used by Kahuna. 
To manipulate images, browse for a file as described previously, and then from the 
drop-down list, select the required Output Video Standard. 
 
 

 
 
 

Output 
Video  
Standard
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Click the image to be manipulated to select it, and then click Resize and Position. 
Alternatively, double-click on the desired image. 
 
If Kahuna Manager cannot determine the aspect ratio of the selected image, a dialog 
appears in which the aspect ratio can be selected (4:3, 16:9, or Square Pixel).  
 

 
 
The image appears in the Resize and Position window. 
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Resize and Position Options 

Use the resize and position tools to manipulate the image as required. These tools can 
be accessed by means of the Tools menu or by clicking the toolbar buttons. 
 
Menu Option Toolbar Button Description 
Tools > Resizing > 
Size 
 

 
Adjust the entire size of the image, maintaining the aspect 
ratio, by dragging the bottom right corner. 

Tools > Resizing > 
ASP 
 

 
Adjust the horizontal size of the image by dragging the right 
edge. 

Tools > Resizing > 
Full Width  

Full Width – the full width of the input image follows the 
output image width, maintaining the original aspect ratio. 

Tools > Resizing > 
Full Height  

Full Height – the full height of the input image is used for 
the output image, maintaining the original aspect ratio. 

Tools > Resizing > 
Insert  

Inserts the input image in the center of the output image. 

Tools > Positioning > 
Position  

Adjust the horizontal and vertical position of the image by 
dragging it. 

Tools > Positioning > 
Pan  

Adjust the horizontal position of the image by dragging it. 

Tools > Positioning > 
Tilt  

Adjust the vertical position of the image by dragging it. 

 
 

View options 
If the current image has an associated key channel, the fill or key can be viewed by 
selecting: 
View > Fill 
View > Fill Audio 
View > Key 
View > Key Audio 
The output image view can be adjusted to either a 1:1 or 1:2 zoom. The zoom options 
can be accessed by means of the View menu or by clicking the toolbar buttons.  

 
Menu Option Toolbar Button Description 
View > Normal 

 
Displays the image at its normal size (1:1). 
 

View > Zoom Out 
 

Displays the image at half its normal size (1:2) 
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If a clip has been loaded for resize, Next Frame, Previous Frame, and a frame selection 
drop-down list are available. These options can be accessed by means of the View 
menu or the toolbar. 

 
Menu Option Toolbar Button Description 
View > Previous 
Frame  

Displays the next frame in the clip. 

View > Next Frame 
 

Displays the previous frame in the clip. 
 

N/A Selects a specific frame. 

 
 
 
Interpolation options 

The image interpolation options are available by means of the drop-down list in the 
toolbar. 
  
Drop-down list Option Description 

 

S&W  
interpolation 

Implements a special Snellresize interpolator. 

Bicubic 
interpolation 

Implements standard bicubic interpolation when resize 
occurs. 

Grid align Aligns the input image gris to the output image. When this 
option is selected, resizing is disabled. 

 
 
Input Still Type 

By default, images are frame-based. However, when resizing an image that is 
interlaced, better image resize quality can be obtained by selecting the Interlaced 
option. 

 
Menu Option Toolbar Button Description 
Tools > Input Still 
Type > Frame based  

Select this option when working with frame-based images. 

Tools > Input Still 
Type > Interlaced  

Select this option when working with interlaced images. 

 
 
Resetting to Original 

 
To restore an image to its original size and position, from the Edit menu, select Reset. 
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Save Still 

The Save Still option is accessed by means of the file menu (File > Save Still) and allows 
the current image to be saved as: 

.bmp 

.jpeg 

.tga (Targa) 

.sws (Snell) 
To save a still as a .bmp, .jpeg, or .tga file: 

1. From the file menu, select Save Still. 
A standard windows save dialog opens. 

2. Specify the location to which the file is to be saved, enter a name for the 
file and from the Save as type: drop-down list, select .bmp, .jpeg, or .tga. 

3. Click Save. 
 

When saving a Snell .sws file, several other items, including audio can be saved in the 
file. 
To save a still as a .sws file: 

1. From the file menu, select Save Still. 
A standard Windows save dialog opens. 

2. Specify the location to which the file is to be saved, enter a name for the 
file and from the Save as type: drop-down list, select .sws. 

 
The .sws files may only be named 1 to 999 (for example, 2.sws). 
 

3. Click Save. 
The Save Options window opens.  

4. (Optional) On the Metadata tab, enter the Name, Title, and Description of 
the still. 
 
 

Note: 
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5. (Optional) On the Associate Key data tab, a key channel can be 

associated with the currently selected fill. 
 

 
 

6. (Optional) On the Add Audio tab, .wav and .sws audio files can be 
associated with fill or key data. Up to eight channels can be divided 
between each of the four slots. 
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7. (Optional) On the Options tab, Playback mode specifies how the still 

should be displayed when loaded on Kahuna (Field, Frame, Field 1 Only, 
Field 2 Only). The Positioning options (Crop / Panning) can be enabled or 
disabled. 

 
 

8. Click OK 
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Arranging Images in the Still Store Browser 

The order of the stills can be changed in the Still Store Browser. To reorder stills in the Still 
Store Browser, right-click on a still, select Arrange and then select Move. When Move is 
selected, images can be moved by dragging them to the desired position. 
 

To sort the stills in the Still Store Browser into alphabetical/numeric order, right-click on a 
still, select Arrange, and then select Sort. 
To keep the stills in the Still Store Browser in their present order, right-click on a still, select 
Arrange, and then select Hold. 

 
View Thumbnails 

 
The View Thumbnails check box allows the user to view files in the Still Store Browser as 
Thumbnails (images) or as files (as shown below). 

View 
Thumbnails 

View as 
Thumbnails 
Or  
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Saving Clips 
Exporting Clips via Kahuna GUI Panel to USB device may separate the clip into more 
manageable files if the clip is very long. This is useful if the USB device happens to be 
formatted as a FAT32 system. 
The following tools provide the user a way of joining or splitting very large clips 

 
Tools 

 

 
Join Split Files - Kahuna Clips can be quite large depending on the Video Standard. 
Clips exported from a Kahuna mainframe via GUI Panel will be split into 2Gb files with 
*_XX extension and then store them in a folder *.SWS ( useful for FAT32 systems). 
This application will join these files back together. Select folder with split files in and 
select 'Tools - Join Split Files" 
Split Large Files - Kahuna Clips that are larger than 4Gb in size can be separated into 
individual files which is useful for storing files on a FAT32 system. 
 
 
When Save Clip is selected, all of the stills in the currently selected load directory will be 
taken as a sequence of frames to be converted as a Snell .sws clip, or a sequence of 
Targa .tga frames. 
To save stills as an .sws clip: 

1. From the File menu, select Save Clip. 
A standard Windows save dialog appears. 

2. Specify the location to which the file is to be saved, enter a name for the 
file and from the Save as type: drop-down list, select .sws. 

 The .sws files may only be named 1 to 999 (for example, 2.sws). 
3. Click Save. 

The Save Options window opens.  
4. Enter the save options (Metadata, Key Data, Audio, Playback mode, 

Positioning) as required. 
When the clip is saved, all of the stills in the current Still Store Browser window are saved 
as a Snell .sws clip, in the order in which they appear in the browser. 
 
If a clip has been selected for resize and position, the sequence of frames will follow the 
same sequence as the currently selected clip. 

Note: 

Note: 



K-Manager   

Issue 4 Rev 2  2016  © SAM Page 21

 
Batch Save 

 
The Batch Save option saves all of the stills in the currently selected load directory as a 
batch of Snell .sws stills. 
To perform a batch save: 

1. From the File menu, select Batch Save. 
A standard Windows save dialog appears. 

2. Specify the location to which the file is to be saved, enter a name for the 
file and from the Save as type: drop-down list, select .sws. 

 Snell .sws files may only be named 1 to 999 (for example, 2.sws). 
 

3. Click Save. 
The Save Options window opens. 

4. Enter the save options (Metadata, Key Data, Audio, Playback mode, 
Positioning) as required. 

5. Click OK. 
 

Saving Audio Only 
 

If a still or clip has audio associated with it, the audio can be saved separately as an 
uncompressed .wav file. 
To save audio only: 

1. From the file menu, select Save Audio Only. 
A standard Windows save dialog appears. 

2. Specify a name and location for the file, and then click Save. 
The file is saved as an uncompressed .wav file. 

Note: 
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Viewing and Updating Image Properties 
 

To view the properties of a still or clip in the Still Store Browser, right click on it and select 
Properties. 

 
 
Properties of .bmp, .jpeg, and .tga files 
 

 
 
 
Properties of .sws files 
 

 
 

Certain Snell .sws file properties can be edited from this window. If required, change 
any or all of the Name, Title, and Description fields, then click Update.
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Transferring Files to Kahuna 
 

Files can be transferred from the local computer running Kahuna manager to a Kahuna 
system by means of a USB storage device. 
Alternatively, if a Kahuna link has been established between the computer running the 
Kahuna manager software and Kahuna, files can be transferred using the methods 
described below. 
A Kahuna link must be set up before stills or clips can be transferred to Kahuna using 
Kahuna link. For more information, see “Setting up Kahuna Link” on page 6. 
To transfer files to Kahuna: 

1. Click Transfer Stills to Kahuna. 
The Transfer Stills to Kahuna window appears. 

2. Drag and drop files from the Still Store Browser window to the Transfer Stills 
to Kahuna window. 
 
When files are in the Transfer window, right-click on them to remove, 
reorder, or rename them as required. 

3. After moving the required files to the transfer window, enter a Kahuna 
Project Name, or click  to browse for one, then click Transfer. 

 
 

 
Another method of transferring files to Kahuna is as follows: 

1. In the Still Store Browser, select the files to Transfer to Kahuna (use Shift + 
click, or Ctrl + click to select multiple files), and then click Transfer Stills to 
Kahuna. 
 
The Transfer window appears with the selected files in it. When files are in 
the Transfer window, right-click on them to remove, reorder, or rename 
them as required. 

2. After moving the required files to the transfer window, enter a Kahuna 
Project Name, or click  to browse for one, then click Transfer. 

Note: 

Drag and drop 
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Browsing and Editing Stills from Kahuna 

 
If a Kahuna link has been established between the computer running the Kahuna 
manager software and the Kahuna mainframe, files on Kahuna can be browsed for 
and edited in Kahuna Manager. 
  
A Kahuna link must be set up before stills or clips stored on Kahuna can be edited in the 
Kahuna Manager software. 
 
To browse for files on Kahuna click the Kahuna button at the bottom of the Still Store 
Browser window. This connects to the Kahuna mainframe, and allows a Stills directory to 
be selected. Stills and clips appear as thumbnail images in the Still Store Browser. 
All of the editing options that are available when working locally can be used, with the 
currently selected still being captured to a temporary directory for editing. 
 

 
Selecting Export Stills from Kahuna opens a window, from which stills and clips can be 
selected from Kahuna and transferred to a destination directory. 

Note: 
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Converting a SnellClip to AVI 

 
The AVI Capture option converts a Snell.sws clip or still to an .avi file and save it in the 
same directory. 
To convert an .sws file to .avi: 

1. In the Still Store Browser, select an .sws file, and then click SnellClip to AVI. 
The AVI options window appears. 

 
2. Specify the size of the .avi in relation to the .sws clip and then click OK. 

The Conversion to AVI status window appears. 
 

 
 
3. When the conversion is complete, a confirmation dialog appears, click OK 

to close the dialog. 
The .avi file is saved in the same directory as the .sws file. 
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Converting an AVI to Bitmaps 

The AVI capture option converts an .avi file to a series of individual frames represented 
as bitmaps. If the .avi file contains audio, the audio is saved as a single .wav file. 
To convert an .avi to a series of bitmaps: 

1.  Click AVI Capture. 
The Open File for AVI Capture window appears. 
 

 
3. Browse for and select the .avi file to convert, and then click Open. 

The Initial Save As frame for AVI Capture window appears. 

 
 

4. In the File Name field, enter a file name.  
 
This file name will have 00001 appended to it and will be used for the first frame; the 
second frame will have 0002 appended to it and so on. . For example, TEST00001.bmp, 
TEST00002.bmp, TEST00003.bmp… 
 
If audio is present in the .avi, it will be saved as a .wav file in the same location. 
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Converting Audio to Kahuna Format 
 
The Audio to Kahuna Format option converts an uncompressed .wav file to a Snell .sws 
file. 
To convert a .wav file to .sws: 

1. In the Still Store Browser, select the .wav file to convert, and then click 
Audio to Kahuna Format. 
A Windows Save As dialog appears. 

2. Specify a name and location for the .sws file, and then click Save. 
Snell .sws files may only be named 1 to 999 (for example, 2.sws). 
 

Note: 
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Modifying User Setup Files 

The User Setup options enable user setup files to be modified and saved. A .ucf file can 
then be transferred to Kahuna by means of a USB storage device. 
To access the User Setup functions (Crosspoint Mapping), from the Options menu, 
select User setup > Crosspoint mapping. This opens a new Crosspoint mapping window. 

To open an existing file, click . 
 

Crosspoint Mapping 
The crosspoint mapping option is used to map inputs to crosspoints for each ME, to 
name the crosspoints and inputs, and make mnemonic button displays. 
To set up crosspoint options, from the Options menu, select User setup > Crosspoint 
mapping. 
 

If the Crosspoint mapping window is not already displayed, click . 

 
 
Modify the Xpt. Name, Fall Source/Name, Key Source/Name, and Legend Lamp Color 
as required. 
 

Xpt. Name 
To change a crosspoint name, click on a crosspoint name in the list. A window appears, 
in which a new name can be typed. Close the window to accept the new name. 
Crosspoint names may have a maximum length of 11 characters. 
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Fill Source/Name 

The Fill Source is the signal that provides the Fill when selected on a Key bus or provides 
the source for background busses. 
To change the Fill Source/Name, click on a Fill Source in the Crosspoint Mapping 
window. A list appears, from which a new Fill Source can be selected. Click on a Fill 
source to select it and close the window. 

 
Key Source/Name 

The Key Source provides the Key signal when selected on a Key Bus. It has no effect 
when selected on a background bus. 
To change the Key Source/Name, click on a Key Source in the Crosspoint Mapping 
window. A list appears, from which a new Key Source can be selected. Click on a Key 
Source to select it and close the window. 

 
 

Legend Lamp 
The Legend Lamp allows the mnemonics on the control panel to be color coded, using 
colored backlights. 
To change the Legend Lamp color for a crosspoint, click on a Legend Lamp in the 
Crosspoint Mapping window. A list appears from which the lamp color can be 
selected. Click on a color in the list to select it and close the window. 
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Saving a User Setup File 

User Setup files have a .ucf  file extension and can be transferred to Kahuna by means 
of a USB memory device. 
To save a .ucf file: 

1. From the File menu, select Save As. 

Alternatively, click the  button in the toolbar. 

 
A Windows Save As dialog appears 
 

2. Specify a name and location for the file, and in the Save as type: field 
select User Setup (*.UCF). 

The User setup options window appears. 
 
 
 

 
3. Enter a Name and Description for the file, and then click OK. 
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Modifying Engineering Setup Files 

The Engineering Setup options enable engineering setup files to be modified and 
saved. An .ecf file can then be transferred to Kahuna by means of a USB storage 
device. 
An Engineering Setup file provides the option to rename sources and select a video 
standard 
Source Names 
Each input source can be given a name, which is used as a reference to a Fill or Key 
source. 
To set up Source Names, from the Options menu, select Engineering setup > Source 
names. 
 

For each source, modify the Name and Allow Router Overwrite setting as required. 
 

Name 
To change the Source Name, click on a Name in the Source Names window. A window 
appears, in which a new name can be typed. Close the window to accept the new 
name. 
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Allow Router Overwrite 

When the Allow Router Overwrite option is set to Yes, an external router will be allowed 
to rename the source. 
To change the setting, click on Yes or No as applicable to toggle the setting. 

 
Source Standards 

By default, all sources are assumed to be in the default switcher output format. The 
Source Standards options enable a different video standard to be specified, if required. 
To set up Source Standards, from the Options menu, select Engineering setup > Source 
standards. 

 
To specify a different video standard for a source, clear the check box in the Use 
Output Standard column. A video standard will now be displayed in the Video 
Standard column. 
 

Click the on the video standard to display a list from which a new video 
standard can be selected. Click on a standard to select it and close the 
window.  
 
 



K-Manager   

Issue 4 Rev 2  2016  © SAM Page 33

Saving an Engineering Setup File 
 
Engineering Setup files have an .ecf file extension and can be transferred to Kahuna by 
means of a USB memory device. 
To save an .ecf file: 
From the File menu, select Save As. 

 
 
 

Alternatively, click the  button in the toolbar. 
 
A Windows Save As dialog appears 
Specify a name and location for the file, and in the Save as type: field select 
Engineering Setup (*.ECF). 
 
The Engineering setup options window appears. 
 

 
Enter a Name and Description for the file, and then click OK. 
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Contact Information 
 

Kahuna Support 
© 2016 

Customer Support 

For details of our Regional Customer Support Offices please visit the SAM web site and navigate to 
Support/Customer Support Contacts. 

https://s-a-m.com/support/247-support/ 

Customers with a support contract should call their personalized number, which can be found in their 
contract, and be ready to provide their contract number and details. 
 

Copyright and Disclaimer 

Copyright protection claimed includes all forms and matters of copyrightable material and information now 
allowed by statutory or judicial law or hereinafter granted, including without limitation, material generated 
from the software programs which are displayed on the screen such as icons, screen display looks etc. 

Information in this manual and software are subject to change without notice and does not represent a 
commitment on the part of SAM. The software described in this manual is furnished under a license 
agreement and can not be reproduced or copied in any manner without prior agreement with SAM, or their 
authorized agents. 

Reproduction or disassembly of embedded computer programs or algorithms prohibited. 

No part of this publication can be transmitted or reproduced in any form or by any means, electronic or 
mechanical, including photocopy, recording or any information storage and retrieval system, without 
permission being granted, in writing, by the publishers or their authorized agents. 

SAM operates a policy of continuous improvement and development. SAM reserves the right to make 
changes and improvements to any of the products described in this document without prior notice. 
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