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This supplement provides supplementary description of 
the functions newly supported in the MFS-2000 system 
version 3.30.
Insert this supplement in your copy of the MFS-2000 
System User’s Guide.
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Functions Newly Supported in Version 3.30

The functions newly supported in Version 3.30 of the 
MFS-2000 system are as follows.

Classification Functions supported Menu No. See page

Numeric keypad window Entering an adjustment with the Trim 
button

- 4

Transitions Pattern limit setting 2007, 2102 4

Pattern limit release and transition rate 
setting when released

5

Independent key transitions 
using effects (1-channel 
DME) (M/E only)

Assignment of buttons used (setup) 9302, 9307 6

Effect selection 1400, 1500 7

Detailed effect settings 1402 to 1405, 1502 to 1505 8

Default recall - 8

Button double click access to menus - 8

Additional effect functions Effect selection by entering a pattern 
number

1400, 1500, 2000 9

Additional parameters for squeeze 
patterns

1400, 1500, 2000 9

Selection of “no dead zone” mode for 
transitions with cropping enabled

1402, 1502, 2002 10

Using an external hard disk Formatting an external hard disk 4800 11

Saving and recalling still images 4801 11

Error messages for external hard disk 
operations

- 12

External media support Formatting “Memory Sticks” and media 
connected to the USB connections block

7900 13

Manually installing software from a USB 
storage device

9003 User’s Guide, 191

Timeline operations Switching between Timeline menu and 
Path menu

8000, 8100 14

Setup Video Disk Communications Protocol: 
detailed settings (response time setting, 
file naming mode setting, timecode 
sense setting)

5601, 9502 14

Renaming source signals 9301 15

Error Make and Error Break settings for 
switcher GPI output actions

9401 User’s Guide, 209

Error Make and Error Break settings for 
DCU GPI output actions

9405 User’s Guide, 214
3
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Trim Button Added

In the numeric keypad window, you can use the Trim 
button.

Using the Trim button
Enter an adjustment from the current value, then press the 
Trim button to confirm the entered value.
For example, if you press 8 when the current setting value 
is 50, then without pressing Enter press Trim, this confirms 
a setting of 58.

Pattern Limit

You can set the range of the transition during execution of 
an effect (wipe).
When you execute a transition with the pattern limit 
function on, the results will be as follows depending on the 
execution range setting.
• When the limit value is set to 50%, the effect at the end 

of the transition is the same as when the fader lever is at 
the center position in the normal case (with the pattern 
limit function disabled); the wipe pattern does not 
complete.

• When the limit value is set to 0%, the wipe effect is 
completely disabled, and carrying out the transition 
produces no change in the image.

• When the limit value is set to the maximum 100%, the 
image changes in exactly the same way as when the 
pattern limit function is off, but when the transition is 
completed, the cross-point selections do not interchange 
between the background A and B buses.

Notes
• A pattern limit only applies when an effect (wipe) is 

selected as the transition type. It cannot be applied to a 
mix or preset color mix.
A pattern limit cannot be applied when the pattern 
number 0901 or 0902 is selected.

• A pattern limit cannot be applied to an independent key 
transition.

Making the Pattern Limit Setting

The following procedure shows the case of an M/E bank 
setting, but the same basic procedure also applies to a 
PGM/PST bank setting.

1 From the top menu, select Effect/Wipe >M/E Effect 
>Pattern Limit.

The Pattern Limit menu appears.

2 Press [Pattern Limit], turning it on.

Trim button
MFS-2000
3-209-188-01 (1)
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3 Set the following parameter with the knob.

4 Carry out the transition.

The transition progresses as far as the set pattern limit.

5 Carry out the transition once again.

The status before the previous transition is restored.

Releasing the pattern limit
• To release the pattern limit after completion of step 5 in 

the previous procedure, in the Pattern Limit menu press 
[Pattern Limit], turning it off.

• If after carrying out step 4 in the previous procedure, the 
pattern limit has been reached, proceed as follows.

1 In the Effect/Wipe >M/E Effect >Pattern Limit menu 
press [Release].

A popup window appears.

2 Select the transition rate when the pattern limit is 
released.

Auto Trans: Use the transition rate set in the M/E 
tansition control block or PGM/PST transition 
control block.

Independ Trans: Use the transition rate set for pattern 
limit release. (See next item.)

3 Press [Pattern Limit], turning it off.

4 Carry out the transition.

This releases the pattern limit.
Depending on the way in which the transition was 
executed, the action will be as follows.
• When you press the [CUT] button, the pattern limit 

is immediately released, and the image switches 
instantaneously.

• When you press the [AUTO TRANS] button, until 
the state of the next transition, the transition is 
carried out over the duration given by the transition 
rate.

• When you move the fader lever, the transition is 
carried out from the pattern limit state to the state 
before the pattern limit transition was carried out.
Moving the fader lever even a little synchronizes the 
fader lever position with the transition state, and you 
can move the fader lever either in the forward 
direction or in the reverse direction.

Setting the transition rate when the pattern 
limit is released

1 In the Effect/Wipe >M/E Effect >Pattern Limit menu, 
press [Indep Rate].

The numeric keypad window appears.

2 Enter the desired number of frames in the range 0 to 
999, and press [Enter].

This confirms the input, and the transition rate appears 
on the button.

Knob Description Setting values

1 (Ptn Limit) Transition execution 
range

0.00 to 100.00
5
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Using an Effect for an 
Independent Key 
Transition

Overview

Using a 1-channel DME effect pattern (in the 1000 range), 
you can carry out an independent key transition.
Thus, for example, different effects can be applied to the 
background and key 1.

Notes
• This requires the DME Board Set (MKS-2470) to be 

installed.
• An effect can be used for an independent key transition 

on an M/E key. For a downstream key independent key 
transition, effects cannot be used.

• Effects using DME cannot be selected on the same keys 
for an M/E transition and an independent key transition. 
For example, when one of the effects numbered 1001 to 
1999 or 2001 to 2999 has already been selected on key 1 
for an M/E transition, you cannot select any effect using 
DME on key 1 for an independent key transition.

• In the MFS-2000 system you can use two of the DME 
channels. So, when one of the DME effects numbered 
2001 to 2999 is selected for an M/E transition, you 
cannot select any DME effect for an independent key 
transition on key 1 or key 2. And, when some effects are 
selected on key 1 and key 2 for independent key 
transitions, you can not use any effect using DME for M/
E transitions.

Effect patterns available for independent key 
transitions

Assigning the Buttons Used (Setup)

Assigning a key delegation to a utility 
control block button
In order to control an independent key transition effect in 
the Effect/Wipe control block, assign an independent key 
transition key delegation (M/E K1 Trans, M/E K2 Trans) 
to one of the utility control block buttons.
Operations in the Effect/Wipe control block apply to keys 
selected with these buttons.

For details of the assignment operation, see “Assigning 
utility commands” (User’s Guide, page 200).

Assigning the auto transition function to 
an M/E transition control block button (for 
a 1 M/E panel)
You can assign the auto transition function for an 
independent key transition to the [KEY1 ON] and [KEY2 
ON] buttons of the M/E transition control block of an 
MKS-2010 control panel (1 M/E panel).
The following procedure describes the case of assignment 
to the [KEY1 ON] button. Use a similar procedure for the 
[KEY2 ON] button.

Effect numbers Group name

1001 to 1008 Slide

1011 to 1013 Split

1015 to 1020 Expansion

1021 to 1031 Squeeze

1041 to 1048 Door

1051 to 1069 2D Trans

1071 to 1094 3D Trans

1201 to 1208, 1221 to 
1224, 1231

Frame In/Out

1301 to 1313, 1315 to 
1318, 1341 to 1345

Page Turn

1321 to 1333, 1335 to 
1338, 1346 to 1350

Page Roll

1351 to 1358 Mirror

1361 to 1364 Accordion

1365 to 1369, 1501 Sphere

1371 to 1374 Character Trail

1375 to 1379 Wave

1381 to 1382 Ripple

1384 to 1389 Split Slide

1391 to 1399 Sparkle

1901 to 1999 User Programmable DME
MFS-2000
3-209-188-01 (1)
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1 From the top menu, select Setup/Diag >Operation 
>Button Assign.

The Button Assign menu appears.

2 In the menu screen, press the indication of transition 
control block .

The current assignment appears on the right.

3 Press the indication (KEY1 ON) for the button whose 
assignment you want to change.

A popup window appears.

4 Press [KEY1 TRANS].

This assigns the auto transition function to the [KEY1 
ON] button for an independent key transition of key 1.

Selecting the Effect for an 
Independent Key Transition

The following procedure describes the case of setting for 
key 1. Use a similar procedure for key 2.

Setting the transition type of an 
independent key transition to be an effect

1 From the top menu, select Key >M/E K1 Trans >Main.

The Main menu appears.

2 Press [Trans Type].

A popup window appears.

3 Press [Effect].

The popup window closes, and the transition type of 
the independent key transition is set to “effect.”

Selecting the effect pattern for an 
independent key transition

1 Confirm that the transition type of an independent key 
transition is set to effect. (See previous item.)

2 In the Key >M/E K1 Trans >Main menu, press 
[Pattern].

A popup window for selection of effect patterns 
appears.

3 Use either of the following operations to select the 
effect pattern.

• Select the desired pattern by scrolling the popup 
window or from the group name.

See “Selecting Effects From Menus” (User’s Guide, 
page 62).

• Enter the number of the desired pattern to make the 
selection.

See steps 3 and following in “Selecting an effect 
with a pattern number” (page 9).
7
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Making Detailed Settings for an 
Independent Key Transition Effect

Effect modifiers
In the Main menu, you can make the following modifier 
settings. Carry out the operation in the same way as for a 
normal transition.

Advanced effect operations
Use the following menus for advanced effect operations. 
Carry out the operation in the same way as for a normal 
transition.

Transformations specific to effect patterns
As for a normal transition, you can set the transformation 
parameters.

For details, see “Effect Control Parameter List” (User’s 
Guide Appendix (separate volume), page 7).

Other Operations

Returning independent key transition data 
to the default values (default recall)
In the popup window that appears when you press the 
Default Recall button in a menu screen (see User’s Guide, 
page 31), you can select the following items.
• M/E K1 Trans: Functional unit in the Key >M/E K1 

Trans menu
• M/E K2 Trans: Functional unit in the Key >M/E K2 

Trans menu
This returns the data values set in these menus to the 
default values.

Note
The default recall function does not apply to transition 
type.

Accessing menus by double clicking
In the utility control block, double click the button to 
which M/E K1 Trans or M/E K2 Trans is assigned.
The respective Main menu (number 1400 or 1500) 
appears.

Setting Button(s) to 
press

Reference page 
in User’s Guide

Changing the position and 
size of the effect pattern

Position 68

Selecting effect directions Norm/Rev, 
Reverse

76

Adding borders to video Border 71

Setting border colors Border Color 71

Softening borders or 
edges of video

Soft 72

Setting Menus (menu page 
numbers)

Reference page 
in User’s Guide

Cropping effects Key >M/E K1 (K2) 
Trans > Crop (1402/
1502)

101

Adding beveled 
edges to video

Key >M/E K1 (K2) 
Trans >Beveled 
Edge (1403/1503)

102

Adding lighting Key >M/E K1 (K2) 
Trans >Lighting 
(1404/1504)

104

Adding 
afterimages (Trail)

Key >M/E K1 (K2) 
Trans >Trail/Shadow 
(1405/1505)

104

Adding shadows 
around effects

Key >M/E K1 (K2) 
Trans >Trail/Shadow 
(1405/1505)

106
MFS-2000
3-209-188-01 (1)
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Additional Effect 
Functions

Additional Effect Selection Method

Selecting an effect with a pattern number

1 From the top  menu, select one of the following.

• Effect/Wipe >M/E Effect >Main
• Effect/Wipe >P/P Wipe >Main
• Key >M/E K1 Trans >Main
• Key >M/E K2 Trans >Main

The Main menu appears.

2 Press [Pattern].

A popup window appears.

3 Press [Pattern No.].

The popup window closes, and the numeric keypad 
window appears.

4 Enter the desired pattern number.

This confirms the effect pattern; the popup window 
closes, returning to the Main menu.

Additional Squeeze Pattern 
Parameters

In a squeeze effect (Nos. 1025 to 1028), when cropping is 
enabled, you can adjust the position at which the new 
image appears, or apply borders to any of the four edges.

Enabling the image position adjustment 
and border

1 In any of the following menus, select a squeeze pattern 
(Nos. 1025 to 1028). (These effects can also be applied 
to an independent key transition.)

• Effect/Wipe >M/E Effect >Main
• Effect/Wipe >P/P Wipe >Main
• Key >M/E K1 Trans >Main
• Key >M/E K2 Trans >Main

2 Press [Crop Link] displayed in place of a parameter 
button, setting it to On.

Adjusting the position at which a image 
appears
After selecting the desired squeeze patterns, set the 
following parameters with the knobs.

Adding a border
Press [Border], turning it on.
This adds a border to the four edges of the image.

Parameter Description Setting 
values

Remarks

Knob 4 
(Crop Link)

Selection of 
whether to 
enable 
image 
position 
adjustment 
and border 
settings 

On/Off In the menu 
display, a [Crop 
Link] button 
appears in place 
of a parameter 
button for knob 4. 
Press the button 
to toggle the 
Crop Link 
function between 
On and Off.

Parameter Description Setting 
values

Remarks

Knob 1 
(Offset H)

Horizontal 
position at 
which image 
appears

–50.00 
to 
+50.00

–50%: Move left by 
25% of screen 
width

+50%: Move right 
by 25% of 
screen width

Knob 2 
(Offset V)

Vertical 
position at 
which image 
appears

–50.00 
to 
+50.00

–50%: Move 
downward by 
25% of screen 
height

+50%: Move 
upward by 25% 
of screen height
9
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Additional Mode for No Dead Zone 
When Cropping Is Enabled

When [Last 5%] is selected for carrying out a transition, 
you can set the transition completion timing to 70% ([Last 
30%]), 95% ([Last 5%]), or 100% ([Off]) of the transition 
duration.

Setting the transition completion timing

1 Refer to “To set a relationship between transition 
progress and cropping” (User's Guide, page 102), to 
select “Last 5%.”

2 Press [Release Trans].

A popup window appears.

3 Select one of the following.

Last30%: The transition completes at the end of 70% 
of the transition execution time. The transition has 
a dead zone from 70% to 95% of the transition 
time. The cropping is removed during the last 5% 
(enlarges).

Last5%: The transition completes at the end of 95% 
of the transition execution time. When the 
transition completes, the cropping is removed 
during the last 5% (enlarges).

Off: The transition completes at the end of the 
transition execution time. During the last 5% of 
the transition, the transition and cropping removal 
proceed together.

(See following diagram.)

0
100 (%)95

[Last 5%]

y

t

(%)
100

70
0

100 (%)95

[Last 30%]

y

t

(%)
100

70

0
100 (%)95

[Off]

y

(%)
100

95

t

t: transition execution time
y: transition and cropping progress
: transition
: cropping

“dead zone”
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External Hard Disk Drive 
Access

You can connect a hard disk drive to the MFS-2000 
system, and save and recall image data from frame 
memory.
Since image data saved in memory is lost when the system 
is powered off, using an external hard disk drive allows 
required data to be preserved.

Notes
• Only one hard disk drive can be connected to each 

system.
• While the hard disk is being accessed, frame memory 

operations are not possible from the control panel. All 
the frame memory operations, including recalling frame 
memory image data by a snapshot, are out of control.

Consult a Sony service representative or sales 
representative about the hard disk drives that can be 
connected.

Hard Disk Formatting

When you connect a hard disk drive for the first time, it is 
necessary to format the hard disk. This partitions the disk, 
creating five logical drives (FMHDD1 to FMHDD5).

1 From the top menu, select Frame Memory >External 
HDD >Format.

The Format menu appears.

2 Press [Refresh].

The product information for the connected hard disk 
drive appears at the upper right of the screen.

3 Press [Format].

A popup window for confirming formatting appears.

Note
Carrying out formatting erases any existing data on the 
hard disk.

4 Press [Yes].

This starts the hard disk formatting, and a window 
appears, showing the progress of the operation. When 
the operation is completed successfully, a completion 
message appears.
Press [OK] to close the window.

Saving Still Images to the External 
Hard Disk

You can save all of the files from frame memory to the 
external hard disk drive.

Note
Before carrying out this operation for the first time, it is 
necessary to format the hard disk. (See previous item.)

1 From the top menu, select Frame Memory >External 
HDD >Backup/Restore.

The Backup/Restore menu appears.

To get the hard disk drive information
Press [Refresh].
The product information for the connected hard disk 
drive appears at the upper right of the screen.

2 Using any of the following methods, select a logical 
drive (FMHDD1 to FMHDD5).

• Press directly on the list in the status area.
• Use the arrow buttons to scroll the reverse video 

cursor.
• Turn the knob.

Hard disk drive product information

Knob Description Setting values

1 (Partition) Logical drive selection 1 to 5

Logical drive names
Hard disk drive 
product information
11
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3 Press [Backup].

A popup window for confirming file saving appears.

Note
When you save the files, all of the saved files in the 
logical drive are erased immediately before the saving 
operations.

4 Press [Yes].

This starts the file saving operation. If there is no 
directory in the logical drive, a directory is 
automatically created, and the files are saved within it. 
A window appears, showing the progress of the 
operation.
When the operation is completed successfully, a 
completion message appears.
Press [OK] to close the window.

Renaming a directory

1 In the Frame Memory >External HDD >Backup/
Restore menu, select the directory you want to rename 
from the list.

2 Press [Rename].

A keyboard window appears.

3 Enter the new directory name (maximum eight 
characters), and press [Enter].

This renames the directory.

Recalling Files From the External 
Hard Disk

You can recall all of the saved files on the hard disk drive 
into frame memory.

1 Carry out steps 1 and 2 of the procedure “Saving Still 
Images to the External Hard Disk” (page 11).

Note
It is not possible to select a directory (logical drive) on 
which files are not saved.

2 Press [Restore].

A popup window for confirming file recall appears.

Note
When you recall the files, any existing data in frame 
memory is lost immediately before the recalling 
operation.

3 Press [Yes].

This starts the file recalling operation. A window 
appears, showing the progress of the operation. When 
the operation is completed successfully, a completion 
message appears.
Press [OK] to close the window.

Error Messages for External Hard 
Disk Operations

If an error occurs during an external hard disk operation, 
the following messages appear.

Error message Error description

No external HDD 
was found  (-2).

Frame Memory >External HDD 
>Format
Frame Memory >External HDD 
>Backup/Restore
In one of the above menu operations, 
the external hard disk could not be 
recognized. Check that the external 
hard disk is correctly connected.

Format operation 
failed (-10).

Frame Memory >External HDD 
>Format
In the above menu operation, 
formatting the external hard disk was 
not completed correctly.

Format operation 
failed (-11).

Cannot access the 
partition (-12).

Frame Memory >External HDD 
>Format
Frame Memory > External HDD 
>Backup/Restore
In one of the above menu operations, 
the logical drives of the external hard 
disk could not be accessed. Check that 
the external hard disk is correctly 
formatted.

Cannot access the 
directory (-20).

Frame Memory >External HDD 
>Format
Frame Memory >External HDD 
>Backup/Restore
In one of the above menu operations, 
the directory of the external hard disk 
could not be accessed.

Cannot access the 
directory (-21).

The external HDD 
is busy (-22).

Frame Memory >External HDD 
>Format
Frame Memory >External HDD 
>Backup/Restore
In one of the above menu operations, 
the external hard disk was busy and 
could not be accessed.

The external HDD 
is full (-32).

Frame Memory >External HDD 
>Backup/Restore
In the above menu operation, an 
attempt was made to execute [Backup] 
to the external hard disk which does not 
have enough capacity.
MFS-2000
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External Media Support

Formatting Media

You can format “Memory Sticks” and media connected to 
the USB connector.

1 From the top  menu, select File >Directory Manage.

The Directory Manage menu appears.

2 Press [Media Sel].

A popup window appears for media selection.

3 Press [Memory Stick] or [USB].

4 Press [Format].

A confirmation message appears.

5 Press [Yes].

This starts the formatting operation, and a window 
appears, showing the progress. When the operation is 
completed successfully, a completion message 
appears. 
Press [OK] to close the window.

Backup operation 
failed (-33).

Frame Memory >External HDD > 
Backup/Restore
In the above menu operation, an 
attempt was made to execute [Backup] 
but the file storing process was not 
completed correctly.

Backup operation 
failed (-34).

No file was found 
(-40).

Frame Memory >External HDD 
>Backup/Restore
In the above menu operation, an 
attempt was made to execute [Restore] 
but no files written on the external hard 
disk was found.

Restore operation 
failed (-42).

Frame Memory >External HDD 
>Backup/Restore
In the above menu operation, an 
attempt was made to execute [Restore] 
but recalling file from the external hard 
disk was not completed correctly.

Restore operation 
failed (-43).

Error message Error description
13
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Switching Menus in 
Timeline Operations

In menus in the 8000 range, the [Timeline] and [Path] 
buttons appear.
Press either of these to switch between the Timeline menu 
and Path menu.

Disk Recorder Control

Making Advanced Settings for Disk 
Recorders (Video Disk 
Communications Protocol)

Selecting the file name format
Select the format for the file names handled by the disk 
recorder.

For more information about files handled by the disk 
recorder (loading file lists, loading files, creating files), 
see page 179 in the User's Guide.

1 From the top  menu, select Setup/Diag >Device >Port 
Assign >Port Setting.

The Port Setting menu appears.

2 Press [Name Mode].

A popup window appears.

3 Select either of the following.

Fixed 8 Character: Handle eight-character fixed-
length file names

Variable Length: Handle variable-length file names 
(In the MFS-2000 system, file names are limited to 
a maximum of 23 characters.)

Setting the timecode sense

1 In the Setup/Diag >Device >Port Assign >Port Setting 
menu, press [TC Sense].

Timeline button

Path button
MFS-2000
3-209-188-01 (1)
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A popup window appears.

2 Select from the following, according to the protocol 
that the connected device supports.

Zero based: Mode in which the timecode is sensed 
with the first frame of the recalled file as 
00:00:00:00

SOM based: Mode in which the timecode is sensed 
with the values recorded in the recalled file

Note
The details of the above operating modes depend on 
the connected device. For details, refer to the 
documentation for the connected device.

Setting the response time
In the Setup/Diag >Device >Port Assign >Port Setting 
menu (see previous item), the following are added to the 
knob 3 setting items.
Still Delay: Time required to stop after issuing the Still 

command
Continue Delay: Time required to stop after issuing the 

Continue command

For details of the method of setting, see “Making detailed 
settings for disk recorders (Video Disk Communications 
Protocol)” (User’s Guide, page 222).

Renaming Source 
Signals

For the source signal names displayed on MKS-8082 and 
similar AUX bus remote panels, the default is “IN 16” and 
so on, but you can change the names as follows.

1 From the top  menu, select Setup/Diag >Operation >V/
K Pair Assign.

The Video/Key Pair Assign menu appears.

2 Using any of the following methods, select the number 
of the source whose name is to be changed.

• Press directly on the list in the status area.
• Use the arrow buttons to scroll the reverse video 

cursor.
• Turn the knob.

The selected source number appears in reverse video.

3 Press [Source Name].

A keyboard window appears.

4 Enter the new source name (maximum 16 characters), 
and press [Enter].

Note
The following characters cannot be used in a source 
name:

space \ / : , (comma) ; * ? “ < > . (period) |

Knob Description Setting values

4 (Source No) Source number 
setting

1 to 33
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